User’s Guide
© 2007 Autodesk, Inc. All Rights Reserved

Disclaimer
This publication, or parts thereof, may not be reproduced in any form, by any method, for any purpose.

AUTODESK INC., MAKES NO WARRANTY, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE REGARDING THESE MATERIALS, AND MAKES SUCH MATERIALS AVAILABLE SOLELY ON AN “AS-IS” BASIS. IN NO EVENT SHALL AUTODESK INC., BE LIABLE TO ANYONE FOR SPECIAL, COLLATERAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES IN CONNECTION WITH OR ARISING OUT OF ACQUISITION OR USE OF THESE MATERIALS. THE SOLE AND EXCLUSIVE LIABILITY TO AUTODESK INC., REGARDLESS OF THE FORM OF ACTION, SHALL NOT EXCEED THE PURCHASE PRICE, IF ANY, OF THE MATERIALS DESCRIBED HEREIN.

Autodesk, Inc. reserves the right to revise and improve its products as it sees fit. This publication describes the state of this product at the time of its publication, and may not reflect the product at all times in the future.

Trademarks

The following are registered trademarks or trademarks of Autodesk Canada Co. in the USA and/or Canada and other countries: Backburner, Discreet, Fire, Flame, Flint, Frost, Inferno, Multi-Master Editing, River, Smoke, Sparks, Stone, Wire.

All other brand names, product names or trademarks belong to their respective holders.

Third-Party Software Credits and Contributions
ACIS Copyright© 1989-2001 Spatial Corp.
Copyright © 1999-2000 The Apache Software Foundation. All rights reserved. This product includes software developed by the Apache Software Foundation (http://www.apache.org/dist/LICENSE.txt).

Typefaces from the Bitstream® typeface library Copyright© 1992.
HLM® Copyright D-Cubed Ltd. 1996-2006. HLM is a trademark of D-Cubed Ltd.
AutoCAD® 2008 and AutoCAD LT® 2008 are produced under a license of data derived from DIC Color Guide® from Dainippon Ink and Chemicals, Inc. Copyright © Dainippon Ink and Chemicals, Inc. All rights reserved. DIC and DIC Color Guide are registered trademarks of Dainippon Ink and Chemicals, Inc.

Portions of this software are based on the work of the Independent JPEG Group.

Active Delivery™ 2.0 © 1999-2004 Inner Media, Inc. All rights reserved.

ISYS and the ISYS logo are registered trademarks or trademarks of ISYS® Search Software Inc.

Copyright© Lingea s.r.o. 2006.
The New Features Workshop contains Macromedia Flash™ Player software by Macromedia, Inc. Copyright © 1995-2005 Macromedia, Inc. All rights reserved. Macromedia® and Flash® are registered trademarks or trademarks of Adobe Systems Incorporated in the United States or other countries.

Copyright© 1996-2006 Macrovision Corporation. All rights reserved.
Copyright© 1996-2002 Microsoft Corporation. All rights reserved.
Copyright© 2002 Joseph M. O’Leary.

PANTONE® Colors displayed in the software application or in the user documentation may not match PANTONE-identified standards. Consult current PANTONE Color Publications for accurate color.
PANTONE® and other Pantone, Inc. trademarks are the property of Pantone, Inc. © Pantone, Inc., 2004. Pantone Inc. is the copyright of color data and/or software which are licensed to Autodesk, Inc., to distribute for use only in combination with certain Autodesk software products. PANTONE Color Data and/or Software shall not be copied onto another disk or into memory unless as part of the execution of this Autodesk software product.

Typefaces from Payne Loving Trust© 1992, 1996. All rights reserved.
RAL DESIGN® RAL, Sankt Augustin, 2004
RAL CLASSIC® RAL, Sankt Augustin, 2004

Representation of the RAL Colors is done with the approval of RAL Deutsches Institut für Gütesicherung und Kennzeichnung e.V. (RAL German Institute for Quality Assurance and Certification, re. Assoc.), D-53757 Sankt Augustin.
This product includes code licensed from RSA Security, Inc. Some portions licensed from IBM are available at http://oss.software.ibm.com/icu4j/.
Contents

Overview ................................................................. 1

Chapter 1  About AutoCAD Mechanical  ................................ 3
  AutoCAD Mechanical Software Package  ........................................ 4
  Leveraging Legacy Data ......................................................... 4
  Starting AutoCAD Mechanical .................................................. 4
  Accessing AutoCAD Mechanical Commands .................................. 5
  AutoCAD Mechanical Help ...................................................... 5
  Product Support and Training Resources ...................................... 6
  Design Features in AutoCAD Mechanical ....................................... 7
    Mechanical Structure .......................................................... 7
    Associative Design and Detailing .............................................. 7
    External References for Mechanical Structure ............................ 8
    Associative 2D Hide ........................................................... 8
    Autodesk Inventor Companion Support ...................................... 8
    2D Design Productivity ....................................................... 9
    Engineering Calculations ..................................................... 9
    Machinery Systems Generators .............................................. 10
    Intelligent Production Drawing and Detailing ............................ 11
    Detailing Productivity ....................................................... 11
    Annotations ................................................................. 12
    Standard Mechanical Content .............................................. 12
    Standard Parts Tools ........................................................ 13
<table>
<thead>
<tr>
<th>Chapter 12</th>
<th>Working with BOMs and Parts Lists</th>
<th>243</th>
</tr>
</thead>
<tbody>
<tr>
<td>Key Terms</td>
<td>Working with Parts Lists</td>
<td>244</td>
</tr>
<tr>
<td></td>
<td>Inserting Part References</td>
<td>244</td>
</tr>
<tr>
<td></td>
<td>Editing Part References</td>
<td>245</td>
</tr>
<tr>
<td></td>
<td>Placing Balloons</td>
<td>248</td>
</tr>
<tr>
<td></td>
<td>Creating Parts Lists</td>
<td>249</td>
</tr>
<tr>
<td></td>
<td>Merging and Splitting Items In Parts Lists</td>
<td>255</td>
</tr>
<tr>
<td></td>
<td>Collecting Balloons</td>
<td>261</td>
</tr>
<tr>
<td></td>
<td>Sorting and Renumbering Items In Parts Lists</td>
<td>265</td>
</tr>
<tr>
<td></td>
<td>Using Filters</td>
<td>267</td>
</tr>
<tr>
<td></td>
<td></td>
<td>270</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 13</th>
<th>Creating Shafts with Standard Parts</th>
<th>277</th>
</tr>
</thead>
<tbody>
<tr>
<td>Key Terms</td>
<td>Creating Shafts</td>
<td>278</td>
</tr>
<tr>
<td></td>
<td>Configuring Snap Options</td>
<td>279</td>
</tr>
<tr>
<td></td>
<td>Configuring Shaft Generators</td>
<td>280</td>
</tr>
<tr>
<td></td>
<td>Creating Cylindrical Shaft Sections and Gears</td>
<td>281</td>
</tr>
<tr>
<td></td>
<td>Inserting Spline Profiles</td>
<td>282</td>
</tr>
<tr>
<td></td>
<td>Inserting Chamfers and Fillets</td>
<td>283</td>
</tr>
<tr>
<td></td>
<td>Inserting Shaft Breaks</td>
<td>284</td>
</tr>
<tr>
<td></td>
<td>Creating Side Views of Shafts</td>
<td>285</td>
</tr>
<tr>
<td></td>
<td>Inserting Threads on Shafts</td>
<td>286</td>
</tr>
<tr>
<td></td>
<td>Editing Shafts and Inserting Sections</td>
<td>287</td>
</tr>
<tr>
<td></td>
<td>Replacing Shaft Sections</td>
<td>288</td>
</tr>
<tr>
<td></td>
<td>Inserting Bearings</td>
<td>289</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 14</th>
<th>Calculating Shafts</th>
<th>299</th>
</tr>
</thead>
<tbody>
<tr>
<td>Key Terms</td>
<td>Calculating Shafts</td>
<td>300</td>
</tr>
<tr>
<td></td>
<td>Creating Shaft Contours</td>
<td>301</td>
</tr>
<tr>
<td></td>
<td>Specifying Material</td>
<td>302</td>
</tr>
<tr>
<td></td>
<td>Placing Shaft Supports</td>
<td>303</td>
</tr>
<tr>
<td></td>
<td>Specifying Loads on Shafts</td>
<td>305</td>
</tr>
<tr>
<td></td>
<td>Calculating and Inserting Results</td>
<td>306</td>
</tr>
<tr>
<td></td>
<td>Calculating Strengths of Shafts</td>
<td>307</td>
</tr>
</tbody>
</table>

| Engineering Calculations | 315 |

<table>
<thead>
<tr>
<th>Chapter 15</th>
<th>Calculating Moments of Inertia and Deflection Lines</th>
<th>317</th>
</tr>
</thead>
<tbody>
<tr>
<td>Key Terms</td>
<td></td>
<td>318</td>
</tr>
</tbody>
</table>
### Calculating Moments of Inertia and Deflection Lines
- Calculating Moments of Inertia
- Calculating Deflection Lines

### Chapter 16 Calculating Chains
- Key Terms
- Chain Calculations
  - Performing Length Calculations
  - Optimizing Chain Lengths
  - Inserting Sprockets
  - Inserting Chains

### Chapter 17 Calculating Springs
- Key Terms
- Calculating Springs
  - Starting Spring Calculations
  - Specifying Spring Restrictions
  - Calculating and Selecting Springs
  - Inserting Springs
  - Creating Views of Springs with Power View

### Chapter 18 Calculating Screw Connections
- Key Terms
- Methods for Calculating Screws
  - Using Stand Alone Screw Calculations
    - Selecting and Specifying Screws
    - Selecting and Specifying Nuts
    - Selecting and Specifying Washers
    - Specifying Plate Geometry and Properties
    - Specifying Contact Areas
    - Specifying Loads and Moments
    - Specifying Settlement Properties
    - Specifying Tightening Properties
    - Creating and Inserting Result Blocks

### Chapter 19 Calculating Stress Using FEA
- Key Terms
- 2D FEA
  - Calculating Stress In Parts
  - Defining Loads and Supports
  - Calculating Results
  - Evaluating and Refining Mesh
  - Refining Designs
  - Recalculating Stress
| Chapter 20 | **Designing and Calculating Cams** | 387 |
| Key Terms | 388 |
| Designing and Calculating Cams | 388 |
| Starting Cam Designs and Calculations | 389 |
| Defining Motion Sections | 393 |
| Calculating Strength for Springs | 399 |
| Exporting Cam Data and Viewing Results | 403 |

| Autodesk Inventor Link | 405 |

| Chapter 21 | **Using Autodesk Inventor Link Support** | 407 |
| Key Terms | 408 |
| Linking Autodesk Inventor Part Files | 408 |
| Shading and Rotating Geometry | 409 |
| Inserting Drawing Borders | 410 |
| Creating Drawing Views | 414 |
| Working with Dimensions | 421 |
| Exporting Drawing Views to AutoCAD | 425 |
| Linking Autodesk Inventor Assembly Files | 427 |
| Accessing Parts from the Browser | 428 |
| Accessing iProperties | 428 |
| Inserting Drawing Borders | 431 |
| Creating Parts Lists & Balloons | 432 |
| Creating Breakout Section Views | 436 |
| Modifying Breakout Section Views | 443 |
| Removing Views | 445 |
| Updating Autodesk Inventor Parts | 446 |

| Appendix A | **Layer Specifications** | 447 |
| Layer Specification Listing | 448 |

| Appendix B | **Title Block Attributes** | 453 |
| Attributes for Title Blocks | 454 |
| Attribute Definitions | 454 |
| Curly Brackets | 455 |
| Message Files | 456 |

| Appendix C | **Accelerator and Shortcut Keys** | 457 |
| Accelerator Keys | 458 |

| Index | 463 |
Overview

Part I provides information for getting started with your AutoCAD® Mechanical software.

It includes an overview of the product capabilities, a summary of commands with their toolbuttons and descriptions, and a summary of new and revised commands in this release of AutoCAD Mechanical.

In addition, Part I includes information about methods to access commands, AutoCAD Mechanical Help, and product support and training resources.
About AutoCAD Mechanical

This chapter provides information about the AutoCAD® Mechanical software application. It describes the software package, the basic design features in the software, and the methods for accessing commands.

A brief overview of the Help, along with information about where to find resources for product learning, training, and support are included.

In this chapter
- AutoCAD Mechanical Software Package
- Leveraging Legacy Data
- Starting AutoCAD Mechanical
- Accessing AutoCAD Mechanical Commands
- AutoCAD Mechanical Help
- Product Support and Training Resources
- Design Features in AutoCAD Mechanical
AutoCAD Mechanical Software Package

AutoCAD Mechanical is a 2D mechanical design and drafting solution for engineers, designers, and detailers. Its intelligent production drawing and detailing features decrease the time required to create and change 2D production designs. AutoCAD Mechanical introduces many 3D concepts in a familiar 2D environment. It is powered by AutoCAD®, with its easy-to-use palette interface and time-saving xref functionality.

The AutoCAD Mechanical design software package includes both AutoCAD Mechanical and AutoCAD. You can use one Options dialog box to customize settings for both AutoCAD Mechanical and AutoCAD.

Leveraging Legacy Data

The tools for migrating legacy data are installed automatically when you install the AutoCAD Mechanical software. A separate utility tool is available for adding structure to legacy files after they are migrated.

The integrated Autodesk® IGES Translator for transferring and sharing of CAD data between CAD/CAM/CAE systems is installed along with the AutoCAD Mechanical product.

Newly generated files in AutoCAD Mechanical can be saved to a previous version so that you can run multiple versions of AutoCAD Mechanical within the same environment.

Starting AutoCAD Mechanical

You can start AutoCAD Mechanical by using one of the following procedures:

- Click Start on the task bar, and then choose Programs. Select Autodesk ➤ AutoCAD Mechanical 2008.

- On the desktop, double-click the AutoCAD Mechanical icon:
Accessing AutoCAD Mechanical Commands

AutoCAD Mechanical provides several methods to access commands and manage your design process.

The following are samples of the access methods available to you:

**Context Menu**  
In the graphics area, right-click and choose Power Edit.

**Toolbutton**  
Modify ➤ Power Commands ➤ Power Edit

**Menu**  
Modify ➤ Power Commands ➤ Power Edit

**Command**  
AMPOWEREDIT

The step-by-step procedures in the tutorials in Part II of this manual indicate the command name in the opening procedural text. The appropriate toolbutton is displayed in the margin next to the preferred access method. In the tutorials, the context menu method is used when the menus are sensitive to what you are doing. The browser method is used when you can save time and steps. You can use any of the alternate methods as well.

Here is an example of how methods are used in the tutorials:

1. Use AMPOWEREDIT to edit a feature.

**Context Menu**  
In the graphics area, right-click and choose Power Edit.

---

**NOTE** To find the location of a particular toolbutton, refer to Appendix A.

AutoCAD Mechanical Help

The Help in AutoCAD Mechanical provides information about AutoCAD Mechanical with the power pack.

The Help is formatted for easy navigation, and includes:

- Content organized by the major functional areas of AutoCAD Mechanical, with Concept, Reference, and Procedure pages for each functional area. Procedure pages provide step by step instructions on how to execute a given task. The linked Concept page provides background information about the procedure. The linked Reference pages contain information
about all the commands and dialog boxes visited while performing the
procedure.

■ Specific information about each of the features in the program.
■ Concepts and procedures for the new features in this release.
■ A keyword index and search function.
■ Printable Command Reference.
■ Guides to system variables and accelerator keys.
■ Access to Support Assistance with integrated links to solutions.

For access to Help, you can choose from the following methods:

■ From the Help menu, select Mechanical Help Topics.
■ Select the Help button in the standard toolbar.
■ Press F1.
■ Click the Help button within a dialog box.

Product Support and Training Resources

Be more productive with Autodesk® software. Get trained at an Autodesk
Authorized Training Center (ATC®) with hands-on, instructor-led classes to
help you get the most from your Autodesk products. Enhance your productivity
with proven training from over 1,400 ATC sites in more than 75 countries.
For more information about Autodesk Authorized Training Centers, contact
atc.program@autodesk.com or visit the online ATC locator at
www.autodesk.com/atc.

Sources for product support are listed on the AutoCAD Mechanical Product
Information Web page. From the AutoCAD Mechanical Web site at
You can also navigate to the Community page, which contains links to various
communities, including the AutoCAD Mechanical Discussion Group.
Design Features in AutoCAD Mechanical

This section provides an overview of the functionality in the AutoCAD Mechanical software, including numerous innovative 2D design features.

Mechanical Structure

Mechanical structure comprises a suite of 2D structure tools for organizing drawings and for reusing associative data. The capabilities of reuse in blocks and accessibility in layer groups are combined in mechanical structure. When you start the AutoCAD Mechanical application, the Mechanical structure environment is enabled by default. You can also work with it disabled.

The mechanical structure tools include:

- A browser interface for structured 2D mechanical design, where parts, assemblies, views, and folders containing associated data are organized, structured, and managed. Standard parts are automatically organized and managed in the browser. All components are accessible through the browser for many functions, and filters can be set to control the type and level of detail of information displayed.

- Folders in the browser are used for capturing elements of design for reuse. These elements provide all of the associative instancing benefits of components, but do not register as items in the live BOM database. They can contain geometry.

- All geometry remains selectable and editable at all times using familiar commands in open workflows. Workflows for structure can be bottom-up (recommended), middle-out (the most flexible and common workflow), and top-down (not the primary workflow).

Associative Design and Detailing

The browser is used to manage and reuse data in both the design and detailing drafting stages. Many functions can be performed in the browser, including the following:

- You can instance components and assemblies multiple times. The live BOM database in AutoCAD Mechanical keeps track of the quantity of each part or assembly used.
Changes made to an associative instance of a part or assembly, associative component, assembly detailing view, or a standard part or feature are automatically reflected in the other instances.

Folders, components, and individual views of components can be reused as needed. They maintain full associativity with each other.

Annotation views can be created for components and assemblies to fully document the design. Changes made to geometry result in associative dimensions being updated to reflect the change.

**External References for Mechanical Structure**

External References for mechanical structure provides for the components of a drawing to be inserted as an external reference to multiple drawings. Conversely, multiple drawings can be attached as external references to a single drawing.

The following are the key benefits of external references for mechanical structure:

- Increased efficiency by allowing insertion of structure components from many drawings as external reference associatively for concurrent design.
- Reuse of parts from existing assembly drawings very quickly.
- Those involved in multiple design projects that reference the same drawing are able to obtain the most updated design from the externally reference component.
- Ability to set up design specific reference directories as libraries for different applications.

**Associative 2D Hide**

The 2D hide situation tool in AutoCAD Mechanical automates the process to accurately represent parts and features which are partially or completely hidden in drawing views. The following are some of the 2D hide benefits:

- Associative hide situations are managed in the browser.
- The underlying geometry is not altered when you create an associative hide situation.
When geometry is hidden, AutoCAD Mechanical knows it is a component in the mechanical structure, and provides a tooltip with the name and view of the component.

**Autodesk Inventor Companion Support**

Autodesk® Inventor™ companion support redefines the meaning of 3D to 2D interoperability. Use the companion functionality to:

- Access and associatively document native 3D part models without the presence of Autodesk Inventor.
- Visualize part models, examine and use part properties such as material, name, and number.
- Associatively document part models using precision hidden-line removed projections, dimensions, and annotations.
- Link to the native Autodesk Inventor part models automatically notifies you of changes and enables updating of views and annotations to keep your drawing up-to-date.

**2D Design Productivity**

These features increase productivity and reduce the number of steps needed to complete mechanical designs:

- AutoCAD Mechanical provides an intelligent, customizable layer management system that puts objects on the appropriate layers automatically.
- Entities that are not on the current layer group, or entities that are on a locked layer group can be displayed in a different color to reduce screen clutter.
- 2D hidden-line calculations are based on defined foreground and background objects. You can choose hidden line representation types.
- Auto detailing creates detailed drawings of individual components from an assembly drawing.
- One set of power commands is used to create, update, and edit objects.
Mechanical line objects are available for creating centerlines and center
crosses, construction lines, symmetrical lines, section lines, break lines,
and others.

Linear/symmetric stretch is used to modify dimensioned geometry by
changing the dimension value.

Predefined hatch patterns are applicable in two picks from toolbars and
menus.

Engineering Calculations

The automatic engineering calculations available in AutoCAD Mechanical
ensure proper function in mechanical designs.

The 2D FEA feature determines the resistance capability of an object put
under a static load and analyzes design integrity under various loads.

A number of moment of inertia and beam deflection calculations are
available.

Engineering calculations are available for shafts, bearings, and screws.

Machinery Systems Generators

Machinery systems in AutoCAD Mechanical generate the design and
calculation of shafts, springs, belts and chains, and cams. These tools ensure
that you get the design right the first time:

With the shaft generator, you can create drawing views of solid and hollow
shafts. Common shaft features supported include center holes, chamfers,
cones, fillets, grooves, profiles, threads, undercuts, and wrench fittings.
Common standard parts supported include bearings, gears, retaining rings,
and seals.

With the spring generator, you select, calculate, and insert compression,
extension, and torsion springs, and Belleville spring washers in a design.
You control the representation type of the spring, and create a spec form
to incorporate in the drawing.

The belt and chain generator function provides features to create chain
and sprocket systems, belt and pulley systems, calculate optimal lengths
for chains and belts, and insert these assemblies in your design. Chains and belts can be selected from standard libraries.

- The cam generator creates cam plates and cylindrical cams given input border conditions. You can calculate and display velocity, acceleration, and the cam curve path. You can couple driven elements to the cam and create NC data through the curve on the path.

**Intelligent Production Drawing and Detailing**

A number of commands are available in AutoCAD Mechanical that automate the process to create balloons and bills of material.

- You can create formatted balloons and bills of material, as well as detailed views of portions of designs.

- Multiple parts lists per drawing are supported. Grouping of a parts list provides lists of like items. Selected items can be combined to calculate total length required for stock ordering. The parts lists recognize standard parts. You can format item numbers on parts lists.

- Standard-sized drawing borders and customizable title blocks are available.

- Intelligent and associative hole tables show a total count of each type of hole along with a description of them. A second chart lists the coordinates for each of the holes selected. Any update to the holes is reflected in the charts.

- A language converter translates text on a drawing into one of seventeen different languages.

- Revision control tables in drawings track revisions and display comments.

- Fits lists chart all fits used in a drawing.

**Detailing Productivity**

- Smart dimensions automatically maintain the proper arrangement with each other.

- Power dimension commands provide a single command to create and edit all dimensions, apply specified formats, and add fits or tolerances.
Dimensions are automatic for 2D geometry with either ordinate or baseline dimensions.

One command quickly cleans up and arranges dimensions in 2D drawings. One system setting controls the scale for drawing symbols in all views.

Commands are available for align, break, insert, and join to easily dimension a drawing.

Annotations

Hole notes can be inserted for standard holes.

Commands are available to create standards-based surface texture symbols, geometric dimensioning and tolerances, targets, and weld symbols.

Fits description command creates fits descriptions for standard holes.

Leader command creates intelligent balloons and other leaders common in mechanical drawings.

Standard Mechanical Content

Standard content includes parametrically generated, intelligent geometry that you can use to generate an object from scratch. The following are available:

About 600,000 standard parts, including screws, nuts, washers, pins, rivets, bushings, rings, seals, bearings, keys, and others, can be quickly incorporated into any design.

About 8,000 standard features, including center holes, undercuts, keyways, and thread ends can be quickly incorporated into any design.

More than 20,000 standard holes, including through, blind, counterbored, countersunk, oblong, and others, can be quickly incorporated into any design.

Thousands of structural steel shapes, including U-shape, I-shape, T-shape, L-shape, Z-shape, rectangular tube, round tube, rectangular full beam, rectangular round beam, and others, can be quickly incorporated into any design.
Standard Parts Tools

Standard part tools provide for the elements that go with standard parts, such as a hole to accompany a screw. These tools include:

- Screw connection feature for selecting entire fastener assemblies at one time.
- Changeable representation of a standard part between a normal, simplified, or symbolic representation.
- Power view to automatically generate a different view of a standard part, such as a top view from a front view.

Collaboration

Enjoy the benefits of design collaboration for your 2D output through Autodesk Streamline® support. Autodesk Streamline is a hosted Web service for sharing personalized design data across the entire extended manufacturing enterprise.

Autodesk Streamline functionality includes the following:

- Members can view and interact with the 3D data set published on Autodesk Streamline, without waiting for the data to download.
- Using Streamline, many people can share design information and collaborate online. Functionality includes instant messages, e-mail notifications, polling/voting, discussion threads, database creation, and more.
- AutoCAD Mechanical data can be written to the AutoCAD DWF file format, which is one of the file types that Autodesk Streamline leverages.
- You can export 3D CAD data in ZGL format (a compressed form of a standard Open GL file format called XGL). ZGL readily captures 3D data that can be rendered by the Open GL library. ZGL files can then be uploaded to Autodesk Streamline.
This chapter provides a list of the commands available in AutoCAD® Mechanical, along with a brief description of the function of each command and the associated toolbutton.
Command Summary

The following is a list of the AutoCAD Mechanical commands, a brief description of each, and the associated toolbutton.

Some commands do not have an associated toolbutton. This list does not contain AutoCAD® commands.

In some cases where some of the task-specific toolbars are available in a more comprehensive format from the Main toolbar at View ➤ Toolbars, it is noted in the table.

<table>
<thead>
<tr>
<th>Toolbutton</th>
<th>Command Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>ADCENTER</td>
<td>Provides layer group support within the AutoCAD Design Center.</td>
</tr>
<tr>
<td></td>
<td>AM2DHIDE</td>
<td>Hides invisible edges in unstructured situations.</td>
</tr>
<tr>
<td></td>
<td>AM2DHIDEDIT</td>
<td>Edits existing unstructured hide situations.</td>
</tr>
<tr>
<td></td>
<td>AMADJRINGS2D</td>
<td>Creates an adjusting ring on a shaft.</td>
</tr>
<tr>
<td></td>
<td>AMANALYSEDWG</td>
<td>Creates a file in which the current layer structure of the drawing is written.</td>
</tr>
<tr>
<td></td>
<td>AMANNOTE</td>
<td>Creates, deletes, adds, and moves annotations associated with drawing views.</td>
</tr>
<tr>
<td></td>
<td>AMASSOHATCH</td>
<td>Suits an existing hatch to a changed contour.</td>
</tr>
<tr>
<td></td>
<td>AMATTACHSYM</td>
<td>Displays or attaches non attached symbols.</td>
</tr>
<tr>
<td>Toolbutton</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>AMAUTOCLINES</td>
<td>Automatically creates construction lines on selected drawing elements.</td>
</tr>
<tr>
<td></td>
<td>AMAUTODETAIL</td>
<td>Creates an external detail drawing (xref) of selected elements from an assembly drawing.</td>
</tr>
<tr>
<td></td>
<td>AMAUTODIM</td>
<td>Creates chain, baseline, ordinate in both axes, shaft, or symmetric dimensions.</td>
</tr>
<tr>
<td></td>
<td>AMBALLOON</td>
<td>Creates and places a balloon.</td>
</tr>
<tr>
<td></td>
<td>AMBEARCALC</td>
<td>Performs calculation on bearings.</td>
</tr>
<tr>
<td></td>
<td>AMBELL2D</td>
<td>Selects, calculates, and inserts Belleville spring washers, and inserts spring specification tables in drawings.</td>
</tr>
<tr>
<td></td>
<td>AMBHOLE2D</td>
<td>Creates a standard related blind hole.</td>
</tr>
<tr>
<td></td>
<td>AMBOM</td>
<td>Creates a formatted BOM database containing a list of attributes, parts lists with item numbers, and lists of like items in a BOM.</td>
</tr>
<tr>
<td></td>
<td>AMBREAKATPT</td>
<td>Breaks a line, polyline, or a spline on a specified point.</td>
</tr>
<tr>
<td></td>
<td>AMBOUTLINE</td>
<td>Draws a special spline to show the breakout borders.</td>
</tr>
</tbody>
</table>

Command Summary | 17
<table>
<thead>
<tr>
<th>Toolbutton</th>
<th>Command Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>AMBROWSER</td>
<td>Switches the mechanical browser on and off.</td>
</tr>
<tr>
<td></td>
<td>AMBROWSEROPEN</td>
<td>Switches the mechanical browser on.</td>
</tr>
<tr>
<td></td>
<td>AMBROWSERCLOSE</td>
<td>Switches the mechanical browser off.</td>
</tr>
<tr>
<td></td>
<td>AMBSLOT2D</td>
<td>Creates a blind slot.</td>
</tr>
<tr>
<td></td>
<td>AMCAM</td>
<td>Creates and calculates cam designs.</td>
</tr>
<tr>
<td></td>
<td>AMCENCRCANGLE</td>
<td>Draws a centerline cross with an angle.</td>
</tr>
<tr>
<td></td>
<td>AMCENCRCORNER</td>
<td>Draws a centerline cross in a corner.</td>
</tr>
<tr>
<td></td>
<td>AMCENCRFULLCIRCLE</td>
<td>Draws a centerline cross on a circle.</td>
</tr>
<tr>
<td></td>
<td>AMCENCRCRHOLE</td>
<td>Draws a centerline cross with a hole.</td>
</tr>
<tr>
<td></td>
<td>AMCENCRCRINHOLE</td>
<td>Draws a centerline cross in a hole.</td>
</tr>
<tr>
<td></td>
<td>AMCENCROSS</td>
<td>Draws a centerline cross.</td>
</tr>
<tr>
<td>Toolbutton</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>-----------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>AMCENCRLPLATE</td>
<td>Draws centerline cross on a plate.</td>
</tr>
<tr>
<td></td>
<td>AMCEINBET</td>
<td>Draws a centerline in between two lines.</td>
</tr>
<tr>
<td></td>
<td>AMCENTERHOLE2D</td>
<td>Creates a centerhole.</td>
</tr>
<tr>
<td></td>
<td>AMCENLINE</td>
<td>Creates a centerline and center marks through selected circles and arcs while in Drawing mode.</td>
</tr>
<tr>
<td></td>
<td>AMCENTLINE</td>
<td>Draws a centerline.</td>
</tr>
<tr>
<td></td>
<td>AMCHAINDRAW</td>
<td>Draws chain or belt links.</td>
</tr>
<tr>
<td></td>
<td>AMCHAINLENGTHCAL</td>
<td>Determines the tangent definition between sprockets or pulleys.</td>
</tr>
<tr>
<td></td>
<td>AMCHAM2D</td>
<td>Bevels the edges of objects.</td>
</tr>
<tr>
<td></td>
<td>AMCHECKDIM</td>
<td>Checks for, highlights, and edits dimensions with overridden text.</td>
</tr>
<tr>
<td></td>
<td>AMCLEVISPIN2D</td>
<td>Creates a clevis pin.</td>
</tr>
<tr>
<td>Toolbutton</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>--------------</td>
<td>-------------</td>
</tr>
<tr>
<td></td>
<td>AMCLINEL</td>
<td>Locks or unlocks the construction line layer.</td>
</tr>
<tr>
<td></td>
<td>AMCLINEO</td>
<td>Switches construction lines on or off.</td>
</tr>
<tr>
<td></td>
<td>AMCOMP2D</td>
<td>Designs, calculates, and inserts compression springs, and places spring specification tables in drawings.</td>
</tr>
<tr>
<td></td>
<td>AMCONSTLINES</td>
<td>Draws construction lines. Design Toolbar - Draw, Construction for more construction line commands.</td>
</tr>
<tr>
<td></td>
<td>AMCONSTSWI</td>
<td>Switches construction lines between lines and rays.</td>
</tr>
<tr>
<td></td>
<td>AMCONTIN</td>
<td>Displays the inner contour of an object.</td>
</tr>
<tr>
<td></td>
<td>AMCONTOUT</td>
<td>Displays the outer contour of an object.</td>
</tr>
<tr>
<td></td>
<td>AMCONTRACE</td>
<td>Traces all points of a contour.</td>
</tr>
<tr>
<td></td>
<td>AMCONVDWG</td>
<td>Converts the current drawing.</td>
</tr>
<tr>
<td></td>
<td>AMCOPYLG</td>
<td>Copies a user specified layer group or selected geometry into a new layer group.</td>
</tr>
<tr>
<td>Toolbutton</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>---------------------</td>
<td>------------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>AMCOPPYVIEW</td>
<td>Copies views to the same layout or to a different layout.</td>
</tr>
<tr>
<td></td>
<td>AMCOTTERPIN2D</td>
<td>Creates a cotter pin.</td>
</tr>
<tr>
<td></td>
<td>AMCOUNTB2D</td>
<td>Creates a standard related counterbore.</td>
</tr>
<tr>
<td></td>
<td>AMCOUNTS2D</td>
<td>Creates a standard related countersink.</td>
</tr>
<tr>
<td></td>
<td>AMCRIVET2D</td>
<td>Creates a countersunk rivet.</td>
</tr>
<tr>
<td></td>
<td>AMCYLPIN2D</td>
<td>Creates a cylindrical pin.</td>
</tr>
<tr>
<td></td>
<td>AMDATUMID</td>
<td>Creates datum identifier symbols.</td>
</tr>
<tr>
<td></td>
<td>AMDATUMTGT</td>
<td>Creates datum target symbols.</td>
</tr>
<tr>
<td></td>
<td>AMDEFLINE</td>
<td>Calculates the deflection line or moment line of an object that has various force elements acting on it.</td>
</tr>
<tr>
<td></td>
<td>AMDELVIEW</td>
<td>Deletes views and its dependent views.</td>
</tr>
<tr>
<td></td>
<td>AMDETAIL</td>
<td>Creates associative and scaled detail frames of selected parts of a drawing.</td>
</tr>
<tr>
<td>Toolbutton</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>--------------</td>
<td>-------------</td>
</tr>
<tr>
<td><img src="image1.png" alt="Image" /></td>
<td>AMDIMALIGN</td>
<td>Aligns linear, rotated, aligned, ordinate, or angular dimensions that have a base dimension of the same type.</td>
</tr>
<tr>
<td><img src="image2.png" alt="Image" /></td>
<td>AMDIMARRANGE</td>
<td>Rearranges individual dimensions that lie along one axis, in respect to a reference point.</td>
</tr>
<tr>
<td><img src="image3.png" alt="Image" /></td>
<td>AMDIMBREAK</td>
<td>Creates breaks in an existing dimension.</td>
</tr>
<tr>
<td><img src="image4.png" alt="Image" /></td>
<td>AMDIMFORMAT</td>
<td>Modifies dimensions in drawing mode.</td>
</tr>
<tr>
<td><img src="image5.png" alt="Image" /></td>
<td>AMDIMINSERT</td>
<td>Edits linear, aligned, rotated, and angular dimensions by inserting new dimensions of the same type simultaneously.</td>
</tr>
<tr>
<td><img src="image6.png" alt="Image" /></td>
<td>AMDIMJOIN</td>
<td>Edits linear, aligned, and angular (3-point or 2-line) dimensions by joining similar dimensions into a single dimension.</td>
</tr>
<tr>
<td><img src="image7.png" alt="Image" /></td>
<td>AMDIMMEDIT</td>
<td>Edits multiple dimensions at the same time.</td>
</tr>
<tr>
<td><img src="image8.png" alt="Image" /></td>
<td>AMDIMSTRETCH</td>
<td>Resizes objects by stretching/shrinking linear and symmetric dimensions.</td>
</tr>
<tr>
<td><img src="image9.png" alt="Image" /></td>
<td>AMDRBUSH2D</td>
<td>Creates a single drill bushing.</td>
</tr>
<tr>
<td><img src="image10.png" alt="Image" /></td>
<td>AMDRBUSHHOLE2D</td>
<td>Creates a drill bushing and the corresponding hole.</td>
</tr>
<tr>
<td>Toolbutton</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>-----------</td>
<td>------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>AMDWGVVIEW</td>
<td>Creates views of Autodesk Inventor® linked models while in Drawing mode.</td>
</tr>
<tr>
<td></td>
<td>AMEDGESYM</td>
<td>Creates edge symbols.</td>
</tr>
<tr>
<td></td>
<td>AMEDIT</td>
<td>Edits balloons, parts lists, and symbols.</td>
</tr>
<tr>
<td></td>
<td>AMEDITPSCUTLINE</td>
<td>Displays or selects the paper space cutline for breakout section views.</td>
</tr>
<tr>
<td></td>
<td>AMEDITVIEW</td>
<td>Edits views created in Drawing mode.</td>
</tr>
<tr>
<td></td>
<td>AMEQUATEDIT</td>
<td>Generates and organizes equations.</td>
</tr>
<tr>
<td></td>
<td>AMERASEALLCL</td>
<td>Erases all construction lines.</td>
</tr>
<tr>
<td></td>
<td>AMERASECL</td>
<td>Erases selected construction lines.</td>
</tr>
<tr>
<td></td>
<td>AMEXPLODE</td>
<td>Breaks a compound object in the mechanical structure environment into its component objects.</td>
</tr>
<tr>
<td></td>
<td>AMEXT2D</td>
<td>Designs, calculates, and inserts extension springs, and inserts spring specification tables in drawings.</td>
</tr>
<tr>
<td></td>
<td>AMEXTHREAD2D</td>
<td>Creates an external thread.</td>
</tr>
<tr>
<td>Toolbutton</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>--------------</td>
<td>-------------</td>
</tr>
<tr>
<td><img src="image" alt="AMFCFRAME" /></td>
<td>AMFCFRAME</td>
<td>Creates feature control frame symbols.</td>
</tr>
<tr>
<td><img src="image" alt="AMFEA2D" /></td>
<td>AMFEA2D</td>
<td>Calculates stress and deformation in a plane for plates with a given thickness or in a cross section with individual forces and stretching loads.</td>
</tr>
<tr>
<td><img src="image" alt="AMFEATID" /></td>
<td>AMFEATID</td>
<td>Creates feature identifier symbols.</td>
</tr>
<tr>
<td><img src="image" alt="AMFILLET2D" /></td>
<td>AMFILLET2D</td>
<td>Rounds and fillets the edges of objects.</td>
</tr>
<tr>
<td><img src="image" alt="AMFITSLIST" /></td>
<td>AMFITSLIST</td>
<td>Puts existing fits and their respective dimension values into a list and inserts this fits list into your drawing.</td>
</tr>
<tr>
<td><img src="image" alt="AMGROOVE2D" /></td>
<td>AMGROOVE2D</td>
<td>Inserts a retaining ring/circlip with the appropriate groove in a shaft.</td>
</tr>
<tr>
<td><img src="image" alt="AMGROOVESTUD2D" /></td>
<td>AMGROOVESTUD2D</td>
<td>Creates a grooved drive stud.</td>
</tr>
<tr>
<td><img src="image" alt="AMHATCH_135_11" /></td>
<td>AMHATCH_135_11</td>
<td>Creates a 135-degree and 11 mm/0.4 inch hatch.</td>
</tr>
<tr>
<td><img src="image" alt="AMHATCH_135_2" /></td>
<td>AMHATCH_135_2</td>
<td>Creates a 135-degree and 2.7 mm/0.11 inch hatch.</td>
</tr>
<tr>
<td><img src="image" alt="AMHATCH_135_4" /></td>
<td>AMHATCH_135_4</td>
<td>Creates a 135-degree and 4.7 mm/0.19 inch hatch.</td>
</tr>
<tr>
<td>Toolbutton</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>--------------</td>
<td>-------------</td>
</tr>
<tr>
<td><img src="image" alt="AMHATCH_45_13" /></td>
<td>AMHATCH_45_13</td>
<td>Creates a 45-degree and 13 mm/0.5 inch hatch.</td>
</tr>
<tr>
<td><img src="image" alt="AMHATCH_45_2" /></td>
<td>AMHATCH_45_2</td>
<td>Creates a 45-degree and 2.5 mm/0.1 inch hatch.</td>
</tr>
<tr>
<td><img src="image" alt="AMHATCH_45_5" /></td>
<td>AMHATCH_45_5</td>
<td>Creates a 45-degree and 5 mm/0.22 inch hatch.</td>
</tr>
<tr>
<td><img src="image" alt="AMHATCH_DBL" /></td>
<td>AMHATCH_DBL</td>
<td>Creates a double hatch of 45- and 135-degree and 2.3 mm/0.09 inch.</td>
</tr>
<tr>
<td><img src="image" alt="AMHELP" /></td>
<td>AMHELP</td>
<td>Displays the online Help.</td>
</tr>
<tr>
<td><img src="image" alt="AMHOLECHART" /></td>
<td>AMHOLECHART</td>
<td>Documents the holes in a design, including coordinate dimensions.</td>
</tr>
<tr>
<td><img src="image" alt="AMINERTIA" /></td>
<td>AMINERTIA</td>
<td>Calculates the following tasks: center of gravity, directions of the main axes moment, moments of inertia, effective moment of inertia, deflection angle.</td>
</tr>
<tr>
<td><img src="image" alt="AMINERTIAPROF" /></td>
<td>AMINERTIAPROF</td>
<td>Calculates the moment of inertia for cross sections of cylinders, hollow cylinders, rectangular prisms, or hollow rectangular prisms.</td>
</tr>
<tr>
<td><img src="image" alt="AMIVLINK" /></td>
<td>AMIVLINK</td>
<td>Recreates the associative link between a .dwg file and an Autodesk Inventor assembly (.iam) or part (.ipt) document.</td>
</tr>
<tr>
<td><img src="image" alt="AMIVPROJECT" /></td>
<td>AMIVPROJECT</td>
<td>Selects an Autodesk Inventor Project (.ipt) file to use as the active project file for opening Autodesk Inventor assembly (.iam) files.</td>
</tr>
</tbody>
</table>

Command Summary | 25
<table>
<thead>
<tr>
<th>Toolbutton</th>
<th>Command Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>AMIVUPDATE</td>
<td>Rereads associated Autodesk Inventor part or assembly file and updates the linked .dwg file.</td>
</tr>
<tr>
<td></td>
<td>AMJOIN</td>
<td>Joins different entities.</td>
</tr>
<tr>
<td></td>
<td>AMLANGCONV</td>
<td>Translates text strings in your drawing into another language.</td>
</tr>
<tr>
<td></td>
<td>AMLANGTEXT</td>
<td>Displays and uses text from the Language Converter.</td>
</tr>
<tr>
<td></td>
<td>AMLAYER</td>
<td>Manages the layer system.</td>
</tr>
<tr>
<td></td>
<td>AMLAYINVO</td>
<td>Switches invisible lines on or off.</td>
</tr>
<tr>
<td></td>
<td>AMLAYMOVE</td>
<td>Moves lines to another layer.</td>
</tr>
<tr>
<td></td>
<td>AMLAYMOVEPL</td>
<td>Moves lines to parts layers.</td>
</tr>
<tr>
<td></td>
<td>AMLAYMOVEWL</td>
<td>Moves lines to working layers.</td>
</tr>
<tr>
<td></td>
<td>AMLAYPARTO</td>
<td>Switches standard parts on or off.</td>
</tr>
<tr>
<td>Toolbutton</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>--------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>AMLAYPARTREFO</td>
<td>Switches part reference on or off.</td>
</tr>
<tr>
<td></td>
<td>AMLAYRESET</td>
<td>Resets all layers.</td>
</tr>
<tr>
<td></td>
<td>AMLAYTIBLO</td>
<td>Switches the border and title block on or off.</td>
</tr>
<tr>
<td></td>
<td>AMLAYVISENH</td>
<td>Specifies the layer group setting during a working session.</td>
</tr>
<tr>
<td></td>
<td>AMLAYVPO</td>
<td>Switches viewports on or off.</td>
</tr>
<tr>
<td></td>
<td>AMLGMOVE</td>
<td>Moves elements in a selection set to a specific layer group.</td>
</tr>
<tr>
<td></td>
<td>AMLIBRARY</td>
<td>Displays the Library dialog box.</td>
</tr>
<tr>
<td></td>
<td>AMLISTVIEW</td>
<td>Lists information about a selected view while in Drawing mode.</td>
</tr>
<tr>
<td></td>
<td>AMLUBRI2D</td>
<td>Creates a lubricator.</td>
</tr>
<tr>
<td></td>
<td>AMMANIPULATE</td>
<td>Dynamically moves and rotates selected geometry along/around the X, Y, Z axes.</td>
</tr>
<tr>
<td></td>
<td>AMMCONTV</td>
<td>Makes a contour visible.</td>
</tr>
<tr>
<td>Toolbutton</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>-------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>AM_MECHANICAL_BROWSER</td>
<td>Displays the browser in the mechanical structure environment.</td>
<td></td>
</tr>
<tr>
<td>AMMIGRATEBB</td>
<td>Converts infopoints, position numbers, and parts lists (on a drawing) from Genius 13/Genius 14 to AutoCAD Mechanical 6 format.</td>
<td></td>
</tr>
<tr>
<td>AMMIGRATESYM</td>
<td>Converts all symbols from Genius 13/14 to AutoCAD Mechanical 6 format.</td>
<td></td>
</tr>
<tr>
<td>AMMODE</td>
<td>Switches between model and drawing modes.</td>
<td></td>
</tr>
<tr>
<td>AMMOVEDIM</td>
<td>Moves dimensions on drawings while maintaining their association to the drawing view geometry.</td>
<td></td>
</tr>
<tr>
<td>AMMOVEVIEW</td>
<td>Moves a drawing view to another location in the drawing or to another layout while in Drawing mode.</td>
<td></td>
</tr>
<tr>
<td>AMNOTE</td>
<td>Describes holes, fits, and standard parts, and creates associative notes to the drawing with a leader.</td>
<td></td>
</tr>
<tr>
<td>AMNUT2D</td>
<td>Creates a nut.</td>
<td></td>
</tr>
<tr>
<td>AMOFFSET</td>
<td>Creates new objects at specified distances from an existing object or through a specified point.</td>
<td></td>
</tr>
<tr>
<td>AMOPTIONS</td>
<td>Sets configurations. Merged with AutoCAD command OPTIONS.</td>
<td></td>
</tr>
<tr>
<td>Toolbutton</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>----------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>AMPARTLIST</td>
<td>Creates and places a parts list in a drawing.</td>
</tr>
<tr>
<td></td>
<td>AMPARTREF</td>
<td>Creates part references.</td>
</tr>
<tr>
<td></td>
<td>AMPARTREFEDIT</td>
<td>Edits part reference data.</td>
</tr>
<tr>
<td></td>
<td>AMPIN2D</td>
<td>Creates cylindrical pins, cotter pins, taper pins, and grooved drive studs.</td>
</tr>
<tr>
<td></td>
<td>AMPLBEAR2D</td>
<td>Inserts a plain bearing on a shaft or in a housing.</td>
</tr>
<tr>
<td></td>
<td>AMPLLOTDATE</td>
<td>Inserts the current date in the lower right corner of the title block.</td>
</tr>
<tr>
<td></td>
<td>AMPLRIVET2D</td>
<td>Creates a plain rivet.</td>
</tr>
<tr>
<td></td>
<td>AMPLUG2D</td>
<td>Creates a plug.</td>
</tr>
<tr>
<td></td>
<td>AMPOWERCOPY</td>
<td>Copies an object with its internal information to another position in the drawing.</td>
</tr>
<tr>
<td></td>
<td>AMPOWERNMIM</td>
<td>Creates power dimensions, or assigns tolerances or fits to power dimensions.</td>
</tr>
<tr>
<td>Toolbutton</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>AMPOWERDIM_ANG</td>
<td>Creates angular dimensions, or assigns tolerances or fits to dimension.</td>
</tr>
<tr>
<td></td>
<td>AMPOWEREDIT</td>
<td>Starts the command with which the selected object was created to edit the object.</td>
</tr>
<tr>
<td></td>
<td>AMPOWERERASE</td>
<td>Deletes selected objects.</td>
</tr>
<tr>
<td></td>
<td>AMPOWERRECALL</td>
<td>Starts the command with which the selected object was created, to create a new object.</td>
</tr>
<tr>
<td></td>
<td>AMPOWERSNAP</td>
<td>Sets object snap modes, polar snap, and filters for object snaps.</td>
</tr>
<tr>
<td></td>
<td>AMPOWerview</td>
<td>Creates top or side views of standard parts.</td>
</tr>
<tr>
<td></td>
<td>AMPROJO</td>
<td>Creates a projection crosshairs used for creating orthographic views.</td>
</tr>
<tr>
<td></td>
<td>AMPScale</td>
<td>Controls the scale of all drawing symbols.</td>
</tr>
<tr>
<td></td>
<td>AMPSnap1</td>
<td>Sets user-defined snap settings on tab 1.</td>
</tr>
<tr>
<td></td>
<td>AMPSnap2</td>
<td>Sets user-defined snap settings on tab 2.</td>
</tr>
<tr>
<td></td>
<td>AMPSnap3</td>
<td>Sets user-defined snap settings on tab 3.</td>
</tr>
<tr>
<td>Toolbutton</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>--------------</td>
<td>-------------</td>
</tr>
<tr>
<td></td>
<td>AMPSNAP4</td>
<td>Sets user-defined snap settings on tab 4.</td>
</tr>
<tr>
<td></td>
<td>AMPSNAPCEN</td>
<td>Snaps the rectangle center.</td>
</tr>
<tr>
<td></td>
<td>AMPSNAPFILTERO</td>
<td>Switches the entity filter on or off.</td>
</tr>
<tr>
<td></td>
<td>AMPSNAPMID</td>
<td>Snaps to the middle of two points.</td>
</tr>
<tr>
<td></td>
<td>AMPSNAPREF</td>
<td>Snaps to a reference point.</td>
</tr>
<tr>
<td></td>
<td>AMPSNAPREL</td>
<td>Snaps to a relative point.</td>
</tr>
<tr>
<td></td>
<td>AMPSNAPVINT</td>
<td>Snaps to a virtual intersection point of two lines.</td>
</tr>
<tr>
<td></td>
<td>AMPSNAPZO</td>
<td>Switches snapping of the Z coordinate on or off.</td>
</tr>
<tr>
<td></td>
<td>AMRECTANG</td>
<td>Creates a rectangle by defining its starting and endpoint. See Appendix A, Design Toolbar - Draw - Rectangle for more rectangle commands.</td>
</tr>
<tr>
<td></td>
<td>AMREFCLOSE</td>
<td>Saves REFEDIT working set changes.</td>
</tr>
<tr>
<td>Toolbutton</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>--------------</td>
<td>-------------</td>
</tr>
<tr>
<td></td>
<td>AMREFCOPY</td>
<td>Copies objects from other blocks to the REFEDIT working set.</td>
</tr>
<tr>
<td></td>
<td>AMREFDIM</td>
<td>Creates reference dimensions between the part edges created in Model mode and lines, arcs, circles, ellipses created in Drawing mode.</td>
</tr>
<tr>
<td></td>
<td>AMRESCALE</td>
<td>Rescales dimensions and symbols in model and layout.</td>
</tr>
<tr>
<td></td>
<td>AMREV</td>
<td>Switches revision lists on or off.</td>
</tr>
<tr>
<td></td>
<td>AMREVLINE</td>
<td>Inserts a revision list into a drawing or adds an additional revision line to an existing revision list.</td>
</tr>
<tr>
<td></td>
<td>AMREVUPDATE</td>
<td>Updates revision lists.</td>
</tr>
<tr>
<td></td>
<td>AMRIVET2D</td>
<td>Creates plain and countersunk rivets.</td>
</tr>
<tr>
<td></td>
<td>AMROLBEAR2D</td>
<td>Inserts a radial or axial roller bearing on a shaft or in a housing.</td>
</tr>
<tr>
<td></td>
<td>AMSACTIVATE</td>
<td>Selects folder(s) or view folder(s) in mechanical structure and sets them as the active edit target.</td>
</tr>
<tr>
<td></td>
<td>AMSBASE</td>
<td>Specifies new base points for folders or views that can be activated.</td>
</tr>
<tr>
<td></td>
<td>AMSCALEXY</td>
<td>Allows scaling for entities in X and Y direction.</td>
</tr>
<tr>
<td>Toolbutton</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>-------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>AMSCAREA</td>
<td>Creates a scale area (an area that has a scale that is different to model space scale) in model space.</td>
</tr>
<tr>
<td></td>
<td>AMSCATALOG</td>
<td>Opens the structure catalog dialog box, which gives you the ability to insert structure components to the current drawing as external references and manage them.</td>
</tr>
<tr>
<td></td>
<td>AMSCATALOGOPEN</td>
<td>Opens the structure catalog dialog box</td>
</tr>
<tr>
<td></td>
<td>AMSCATALOGCLOSE</td>
<td>Closes the structure catalog dialog box.</td>
</tr>
<tr>
<td></td>
<td>AMSCMONITOR</td>
<td>Views and edits the scale of scale areas or viewports.</td>
</tr>
<tr>
<td></td>
<td>AMSCOPYDEF</td>
<td>Copies the definitions of instanced folders, components or views in the mechanical structure environment.</td>
</tr>
<tr>
<td></td>
<td>AMSCCREATE</td>
<td>Creates components, component views, folders, and annotation views in drawings in the mechanical structure environment.</td>
</tr>
<tr>
<td></td>
<td>AMSCREW2D</td>
<td>Creates a screw or bolt.</td>
</tr>
<tr>
<td></td>
<td>AMSCREWCALC</td>
<td>Calculates factors of safety for parts of a screw connection.</td>
</tr>
<tr>
<td></td>
<td>AMSCREWCON2D</td>
<td>Opens the Screw Connection dialog box.</td>
</tr>
<tr>
<td>Toolbutton</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>--------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>AMSCREWMACRO2D</td>
<td>Opens the Screw Assembly Templates dialog box.</td>
</tr>
<tr>
<td></td>
<td>AMSCRIPT</td>
<td>Generates scripts.</td>
</tr>
<tr>
<td></td>
<td>AMSEALRING2D</td>
<td>Creates a sealing ring for use under a plug.</td>
</tr>
<tr>
<td></td>
<td>AMSEALS2D</td>
<td>Inserts a seal or O-ring with the appropriate groove in a shaft.</td>
</tr>
<tr>
<td></td>
<td>AMSECTIONLINE</td>
<td>Creates cutting plane lines.</td>
</tr>
<tr>
<td></td>
<td>AMEDIT</td>
<td>Directly manipulates the contents of an active folder or view in the</td>
</tr>
<tr>
<td></td>
<td></td>
<td>mechanical structure environment.</td>
</tr>
<tr>
<td></td>
<td>AMSETUPDWG</td>
<td>Sets up a drawing.</td>
</tr>
<tr>
<td></td>
<td>AMSEXTERNALIZE</td>
<td>Moves a structure component from the current drawing to a new drawing file</td>
</tr>
<tr>
<td></td>
<td></td>
<td>and converts it to an external reference component.</td>
</tr>
<tr>
<td></td>
<td>AMSHAFT2D</td>
<td>Creates rotationally symmetric shaft parts and inner and outer shaft contours.</td>
</tr>
<tr>
<td></td>
<td>AMSHAFTCALC</td>
<td>Calculates deflection line, bending moment, torsion moment, supporting</td>
</tr>
<tr>
<td></td>
<td></td>
<td>force, torque rotation angle, equivalent tension, and the safety factor of</td>
</tr>
<tr>
<td></td>
<td></td>
<td>shafts.</td>
</tr>
<tr>
<td></td>
<td>AMSHAFTEND</td>
<td>Creates a zigzag line, a free-hand line, or loop to represent a shaft end.</td>
</tr>
<tr>
<td>Toolbutton</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>-----------</td>
<td>-----------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>AMSHAFTKEY2D</td>
<td>Inserts a parallel or woodruff key with the appropriate keyseat in a shaft.</td>
</tr>
<tr>
<td></td>
<td>AMSHAFTLNUT2D</td>
<td>Creates a shaft lock nut including the lock washer and inserts both in a shaft.</td>
</tr>
<tr>
<td></td>
<td>AMSHIDE</td>
<td>Creates and edits hide situations in the mechanical structure environment.</td>
</tr>
<tr>
<td></td>
<td>AMSHIDEEDIT</td>
<td>Edits hide situations created with AMSHIDE.</td>
</tr>
<tr>
<td></td>
<td>AMSHIMRING2D</td>
<td>Creates a shim ring on a shaft.</td>
</tr>
<tr>
<td></td>
<td>AMSIMPLEWELD</td>
<td>Creates seam and fillet simple welds.</td>
</tr>
<tr>
<td></td>
<td>AMSINSERT</td>
<td>Inserts a new instance of a component view, folder or annotation view in model space, in the mechanical structure environment.</td>
</tr>
<tr>
<td></td>
<td>AMSLOCALIZE</td>
<td>Converts an external reference component to a local component on the current drawing.</td>
</tr>
<tr>
<td></td>
<td>AMSMOVE</td>
<td>Moves objects and their associated occurrences in one or more folders or views to another folder or view in the mechanical structure environment.</td>
</tr>
<tr>
<td></td>
<td>AMSNAVMODE</td>
<td>Toggles the Design Navigation mode on and off.</td>
</tr>
<tr>
<td>Toolbutton</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>--------------</td>
<td>-------------</td>
</tr>
<tr>
<td><img src="image1.png" alt="AMSNEW" /></td>
<td>AMSNEW</td>
<td>Creates and manages new folders, components, and annotation views in the mechanical structure environment.</td>
</tr>
<tr>
<td><img src="image2.png" alt="AMSPROCKET" /></td>
<td>AMSPROCKET</td>
<td>Draws sprockets or pulleys.</td>
</tr>
<tr>
<td><img src="image3.png" alt="AMSPURGE" /></td>
<td>AMSPURGE</td>
<td>Removes unused structure objects, including folders, components, views, and annotation views in the mechanical structure environment.</td>
</tr>
<tr>
<td><img src="image4.png" alt="AMSREPLACEDEF" /></td>
<td>AMSREPLACEDEF</td>
<td>Replaces the definition of a folder or view with another definition of objects in the mechanical structure environment.</td>
</tr>
<tr>
<td><img src="image5.png" alt="AMSTDPLIB" /></td>
<td>AMSTDPLIB</td>
<td>Opens the Standard Parts Database dialog box for selection.</td>
</tr>
<tr>
<td><img src="image6.png" alt="AMSTDPLIBEDIT" /></td>
<td>AMSTDPLIBEDIT</td>
<td>Opens the Standard Parts Database dialog box for editing.</td>
</tr>
<tr>
<td><img src="image7.png" alt="AMSTDPREP" /></td>
<td>AMSTDPREP</td>
<td>Changes the representation of a standard part.</td>
</tr>
<tr>
<td><img src="image8.png" alt="AMSTLSHAP2D" /></td>
<td>AMSTLSHAP2D</td>
<td>Creates a steel shape.</td>
</tr>
<tr>
<td><img src="image9.png" alt="AMSTYLEITAL" /></td>
<td>AMSTYLEITAL</td>
<td>Changes the text style to italic.</td>
</tr>
<tr>
<td><img src="image10.png" alt="AMSTYLESIMP" /></td>
<td>AMSTYLESIMP</td>
<td>Changes the text style to simplex.</td>
</tr>
<tr>
<td>Toolbutton</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>-----------</td>
<td>--------------------</td>
<td>----------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>AMSTYLESTAND</td>
<td>Changes the text style to standard.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>AMSTYLETXT</td>
<td>Changes the text style to TXT.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>AMSURFSYM</td>
<td>Creates surface texture symbols.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>AMSYMLEADER</td>
<td>Appends or removes a leader.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>AMSYMLINE</td>
<td>Draws symmetrical lines.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>AMTAPBHOLE2D</td>
<td>Creates a standard related tapped blind hole.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>AMTAPETHREAD2D</td>
<td>Creates a taper hole with an external thread.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>AMTAPITHREAD2D</td>
<td>Creates a taper hole with an internal thread.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>AMTAPERPIN2D</td>
<td>Creates a taper pin.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>AMTAPTHOLE2D</td>
<td>Creates a standard related tapped through hole.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>AMTAPERSYM</td>
<td>Creates a taper or slope symbol.</td>
</tr>
<tr>
<td>Toolbutton</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>--------------</td>
<td>-------------</td>
</tr>
<tr>
<td></td>
<td>AMTEXT3</td>
<td>Inserts mtext with 3.5 mm height.</td>
</tr>
<tr>
<td></td>
<td>AMTEXT5</td>
<td>Inserts mtext with 5 mm height. See Appendix A, Assistance Toolbar - Text for more text commands.</td>
</tr>
<tr>
<td></td>
<td>AMTEXT7</td>
<td>Inserts mtext with 7 mm height.</td>
</tr>
<tr>
<td></td>
<td>AMTEXTCENT</td>
<td>Centers text horizontally and vertically.</td>
</tr>
<tr>
<td></td>
<td>AMTEXTHORIZ</td>
<td>Centers text centered horizontally around the selected point.</td>
</tr>
<tr>
<td></td>
<td>AMTEXTRIGHT</td>
<td>Aligns mtext to the right.</td>
</tr>
<tr>
<td></td>
<td>AMTEXTSIZE</td>
<td>Sets text to its default size in model space and layout, and defines a height for an inserted text.</td>
</tr>
<tr>
<td></td>
<td>AMTEXTXT</td>
<td>Creates text with the text style to TXT.</td>
</tr>
<tr>
<td></td>
<td>AMTHOLE2D</td>
<td>Creates a standard related through hole.</td>
</tr>
<tr>
<td></td>
<td>AMTHREADEND2D</td>
<td>Creates a thread end.</td>
</tr>
<tr>
<td>Toolbutton</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>----------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>AMTITLE</td>
<td>Inserts a title block and a drawing border.</td>
</tr>
<tr>
<td></td>
<td>AMTOR2D</td>
<td>Designs, calculates, and inserts torsion springs, and inserts spring specification tables in drawings.</td>
</tr>
<tr>
<td></td>
<td>AMTRCONT</td>
<td>Traces contours on construction lines.</td>
</tr>
<tr>
<td></td>
<td>AMTSLOT2D</td>
<td>Creates a standard related through slot.</td>
</tr>
<tr>
<td></td>
<td>AMUBHOLE2D</td>
<td>Creates a user-defined blind hole.</td>
</tr>
<tr>
<td></td>
<td>AMUBSLOT2D</td>
<td>Creates a user-defined blind slot.</td>
</tr>
<tr>
<td></td>
<td>AMUCOUNTB2D</td>
<td>Creates a user-defined counterbore.</td>
</tr>
<tr>
<td></td>
<td>AMUCOUNTS2D</td>
<td>Creates a user-defined countersink.</td>
</tr>
<tr>
<td></td>
<td>AMUNDERCUT2D</td>
<td>Creates an undercut on a shaft.</td>
</tr>
<tr>
<td></td>
<td>AMUSERHATCH</td>
<td>Inserts a user-defined hatch.</td>
</tr>
<tr>
<td>Toolbutton</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>--------------</td>
<td>-------------</td>
</tr>
<tr>
<td>AMUTSLOT2D</td>
<td>Creates a user-defined slot.</td>
<td></td>
</tr>
<tr>
<td>AMVARIODB</td>
<td>Connects to a database.</td>
<td></td>
</tr>
<tr>
<td>AMVIEWALL</td>
<td>Zooms the view according to the limits.</td>
<td></td>
</tr>
<tr>
<td>AMVIEWCEN</td>
<td>Zooms the center of the viewports.</td>
<td></td>
</tr>
<tr>
<td>AMVIEWLL</td>
<td>Zooms the predefined lower-left quarter of the drawing.</td>
<td></td>
</tr>
<tr>
<td>AMVIEWLR</td>
<td>Zooms the predefined lower-right quarter of the drawing.</td>
<td></td>
</tr>
<tr>
<td>AMVIEWUL</td>
<td>Zooms the predefined upper-left quarter of the drawing.</td>
<td></td>
</tr>
<tr>
<td>AMVIEWUR</td>
<td>Zooms the predefined upper-right quarter of the drawing.</td>
<td></td>
</tr>
<tr>
<td>AMVPORT</td>
<td>Creates a viewport in layout.</td>
<td></td>
</tr>
<tr>
<td>AMVPORTAUTO</td>
<td>Creates viewports automatically.</td>
<td></td>
</tr>
<tr>
<td>AMVPZOOMALL</td>
<td>Resets the viewports to the default scale factor.</td>
<td></td>
</tr>
<tr>
<td>AMWASHER2D</td>
<td>Creates a washer.</td>
<td></td>
</tr>
<tr>
<td>Toolbutton</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>----------------</td>
<td>----------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>AMWELDSYM</td>
<td>Creates a welding symbol.</td>
</tr>
<tr>
<td></td>
<td>AMXREFSET</td>
<td>Controls the representation of xrefs.</td>
</tr>
<tr>
<td></td>
<td>AMZIGZAGLINE</td>
<td>Draws zigzag lines.</td>
</tr>
<tr>
<td></td>
<td>AMZOOMVP</td>
<td>Displays a selected area in another viewport.</td>
</tr>
<tr>
<td></td>
<td>SAVEAS</td>
<td>Saves a file into a different file format for use in more than one version of AutoCAD Mechanical.</td>
</tr>
</tbody>
</table>
New and Revised Commands

This chapter contains information about new and revised commands in AutoCAD® Mechanical.

In this chapter
- Revised Commands
- New Commands
Revised Commands

This following are revised commands in this version of AutoCAD Mechanical.

**AMBALLOON**

Creates and places a balloon.

- **Toolbutton**
  - Annotate ➤ Parts List Tools ➤ Balloons

- **Menu**
  - Command: AMBOM

- Contains a powerful expression builder enabling you to create complex formulas for Balloons.

- All dialog boxes displayed that are displayed in response to this command have been enhanced with the intention of making them easier to understand and easier to use.

**AMBOM**

Creates a formatted BOM database containing a list of attributes, parts lists with item numbers, and lists of like items in a BOM.

- **Toolbutton**
  - Annotate ➤ Parts List Tools ➤ BOM Database

- **Menu**
  - Command: AMBOM

- Contains a powerful expression builder enabling you to create complex formulas for component properties, much easier than was possible in previous releases.
All dialog boxes displayed that are displayed in response to this command have been enhanced with the intention of making them easier to understand and easier to use.

**AMOPTIONS**

Sets configurations.

<table>
<thead>
<tr>
<th>Toolbutton</th>
<th>None</th>
</tr>
</thead>
<tbody>
<tr>
<td>Menu</td>
<td>Assist ➤ Options</td>
</tr>
<tr>
<td>Command</td>
<td>AMOPTIONS</td>
</tr>
</tbody>
</table>

- The AM:Structure tab has been updated to provide additional options for pre-configure how component views are created when they are copied, arrayed or mirrored. The remaining options have been rearranged to make them easier to understand.

- The AM:Standards tab has been updated to let you independently configure text settings for each symbol separately. The entire BOM, Balloon and Part List configuration process has been revamped. All related dialog boxes have been redesigned with the intention of making them easier to understand and easier to use.

**AMPARTLIST**

Creates and places a parts list in a drawing.

<table>
<thead>
<tr>
<th>Toolbutton</th>
<th>![Parts List Icon]</th>
</tr>
</thead>
<tbody>
<tr>
<td>Menu</td>
<td>Annotate ➤ Parts List Tools ➤ Parts list</td>
</tr>
<tr>
<td>Command</td>
<td>AMPARTLIST</td>
</tr>
</tbody>
</table>

- Provides options to wrap columns (also known as column splitting) directly from the Parts List dialog box.
All dialog boxes displayed that are displayed in response to this command have been enhanced with the intention of making them easier to understand and easier to use.

**AMPARTREF**

Creates part references.

**Toolbutton**

**Menu** Annotate ➤ Parts List Tools ➤ Part Reference

**Command** AMPARTREF

All dialog boxes displayed that are displayed in response to this command have been enhanced with the intention of making them easier to understand and easier to use.

**AMPARTREFEDIT**

Creates part references.

**Toolbutton**

**Menu** Annotate ➤ Parts List Tools ➤ Part Reference Edit

**Command** AMPARTREFEDIT

All dialog boxes displayed that are displayed in response to this command have been enhanced with the intention of making them easier to understand and easier to use.

**AMPOWERDIM**

Creates power dimensions, or assigns tolerances or fits to power dimensions.
Toolbutton

Menu Annotate ➤ Power Dimensioning
Command AMPOWERDIM

- Command has been enhanced to automatically create arc extension lines when points outside an arc is dimensioned.
- Supports the creation of inspection dimensions.

**AMSCATLOG**

Opens the structure catalog dialog box, which gives you the ability to insert structure components to the current drawing as external references and manage them.

Toolbutton

Menu Insert ➤ Structure Catalog
Command AMSCATALOG

- The structure catalog is now seamlessly integrated with Autodesk Vault and displays the status of vaulted referenced files.
- The dialog box has been enhanced and the right-click menus have been reorganized with the intention of making the options easier to understand and easier to use.

**AMSCREATE**

Creates components, component views, folders, and annotation views in drawings in the mechanical structure environment.

Toolbutton None
Command AMSCREATE

- The command can now create annotation views in paper space. Creation of annotation views is fully supported with calculation of the most
appropriate scale for a given paper size and standard compliant labels for each view.

**AMSEXTERNALIZE**

Creates components, component views, folders, and annotation views in drawings in the mechanical structure environment.

<table>
<thead>
<tr>
<th>Toolbutton</th>
</tr>
</thead>
<tbody>
<tr>
<td>Command AMSEXTERNALIZE</td>
</tr>
<tr>
<td>■ The command can now externalize local annotation views of xref components, back to the source file.</td>
</tr>
</tbody>
</table>

**AMSINSERT**

Inserts a new instance of a component view, folder or annotation view in model space, in the mechanical structure environment.

<table>
<thead>
<tr>
<th>Toolbutton</th>
</tr>
</thead>
<tbody>
<tr>
<td>Command AMSINSERT</td>
</tr>
<tr>
<td>■ The command can now create multiple instances of annotation views in model space as well as in paper space.</td>
</tr>
</tbody>
</table>

**AMSLOCALIZE**

Converts an external reference component to a local component on the current drawing.

| Toolbutton | None |

48 | Chapter 3  New and Revised Commands
AMSLOCALIZE Command

■ The command can now localize xref annotation views.

AMSNEW

Creates and manages new folders, components, and annotation views in the mechanical structure environment.

Toolbutton

Command AMSLOCALIZE

■ The command can now create annotation views in paper space. Creation of annotation views is fully supported with calculation of the most appropriate scale for a given paper size and standard compliant labels for each view.

AMSTLSHAP2D

Creates a steel shape.

Toolbutton

Menu Content ➤ Steel Shapes

Command AMSTLSHAP2D

■ The command has been updated to contain over 500 new steel shapes, in compliance with the year 2005 revision of the JIS and GB standards.

AMSURFSYM

Creates surface texture symbols.
You can now specify the surface texture parameter designation, numerical limit value and transmission band as a single surface texture requirement.

The Surface Symbol dialog box has been updated to contain customizable drop-down lists.

**AMWELDSYMBOL**

Creates welding symbols.

The Welding Symbol dialog box contains a revised process list. Additional you can automatically prefix the process number with the ISO standard that governs the symbol.

**New Commands**

This following are new commands in this version of AutoCAD Mechanical.

**AMBROWSEROPEN**

Turns on the mechanical browser.

<table>
<thead>
<tr>
<th>Toolbutton</th>
<th>None</th>
</tr>
</thead>
<tbody>
<tr>
<td>Menu</td>
<td>None</td>
</tr>
<tr>
<td>Command</td>
<td>None</td>
</tr>
<tr>
<td>Command</td>
<td>AMBROWSEROPEN</td>
</tr>
<tr>
<td>-------------------------</td>
<td>---------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>Typically invoked when the Structure workspace is turned on.</td>
</tr>
</tbody>
</table>

**AMBROWSERCLOSE**

Turns off the mechanical browser.

<table>
<thead>
<tr>
<th>Toolbutton</th>
<th>None</th>
</tr>
</thead>
<tbody>
<tr>
<td>Menu</td>
<td>None</td>
</tr>
<tr>
<td>Command</td>
<td>AMBROWSERCLOSE</td>
</tr>
<tr>
<td></td>
<td>Typically invoked when workspaces other than the structure workspace is turned on.</td>
</tr>
</tbody>
</table>

**AMSCATALOGOPEN**

Turns on the mechanical browser.

<table>
<thead>
<tr>
<th>Toolbutton</th>
<th>None</th>
</tr>
</thead>
<tbody>
<tr>
<td>Menu</td>
<td>None</td>
</tr>
<tr>
<td>Command</td>
<td>AMSCATALOGOPEN</td>
</tr>
<tr>
<td></td>
<td>Typically invoked when the Structure workspace is turned on.</td>
</tr>
</tbody>
</table>

**AMSCATALOGCLOSE**

Turns off the mechanical browser.

<table>
<thead>
<tr>
<th>Toolbutton</th>
<th>None</th>
</tr>
</thead>
<tbody>
<tr>
<td>Menu</td>
<td>None</td>
</tr>
<tr>
<td>Command</td>
<td>AMSCATALOGCLOSE</td>
</tr>
<tr>
<td></td>
<td>Typically invoked when workspaces other than the structure workspace is turned on.</td>
</tr>
</tbody>
</table>
AMSNAVMODE

Toggles the design navigation mode on or off.

<table>
<thead>
<tr>
<th>Toolbutton</th>
<th>None</th>
</tr>
</thead>
<tbody>
<tr>
<td>Menu</td>
<td>None</td>
</tr>
<tr>
<td>Command</td>
<td>AMSNAVMODE</td>
</tr>
<tr>
<td>Shortcut Key</td>
<td>CTRL - D</td>
</tr>
</tbody>
</table>

While the Design Navigation Mode is on, when you move the cursor through model space, each component the cursor moves over highlights (in model space as well as in the mechanical browser) and a tooltip displays the hierarchical structure of the component.
Design and Annotation Tools

The tutorials in this section teach you how to use AutoCAD® Mechanical’s design, annotation and productivity tools. The lessons include step-by-step instructions and helpful illustrations. You learn how to work with templates and layers, mechanical structure, model space and layouts, dimensions, steel shapes, bills of material (BOMs) and parts lists. Instructions on how to prepare your designs for final documentation are also included.

In this part
- Working with Templates
- Using Mechanical Structure
- Working with Layers and Layer Groups
- Designing Levers
- Working with Model Space and Layouts
- Dimensioning
- Working with 2D Hide and 2D Steel Shapes
- Working with Standard Parts
- Working with BOMs and Parts Lists
- Creating Shafts with Standard Parts
- Calculating Shafts
Working with Templates

In this tutorial, you learn about the predefined templates and how to create your own user-defined templates in AutoCAD® Mechanical.

In this chapter
- Key Terms
- Working with Templates
Key Terms

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>base layer</td>
<td>A layer made up of working layers and standard parts layers. Base layers are repeated in every layer group.</td>
</tr>
<tr>
<td>layer group</td>
<td>A group of associated or related items in a drawing. A major advantage of working with layer groups is that you can deactivate a specific layer group and a complete component. The drawing and its overview are enhanced with a reduction in regeneration time.</td>
</tr>
<tr>
<td>part layers</td>
<td>A layer where the standard parts are put. All standard parts layers have the suffix AM_*N.</td>
</tr>
<tr>
<td>template</td>
<td>A file with predefined settings to use for new drawings. However, any drawing can be used as a template.</td>
</tr>
<tr>
<td>working layer</td>
<td>The layer where you are currently working.</td>
</tr>
</tbody>
</table>

Working with Templates

In AutoCAD Mechanical, you can use templates (*.dwt files) to create drawings. Predefined templates, which contain settings for various drawings, such as am_iso.dwt or am_ansi.dwt, are supplied with AutoCAD Mechanical. You can create your own templates, or use any drawing as a template. When you use a drawing as a template, the settings in that drawing are used in the new drawing.

Although you can save any drawing as a template, prepare templates to include settings and drawing elements that are consistent with your company or project standards, such as the following items:

- unit type and precision
- drawing limits
- snap, grid, and ortho settings
- layer organization
title blocks, borders, and logos
- dimension and text styles
- linetypes and lineweights

If you start a drawing from scratch, AutoCAD Mechanical reads the system defaults from the registry. The system defaults have a predefined standard.

If you create a new drawing based on an existing template and make changes to the drawing, those changes do not affect the template.

To begin working with templates immediately, you can use the predefined template files stored in the `acadm\template` folder.

However, for this tutorial you create your own template.

If you are using Windows Vista and if UAC (User access Control) is enabled, in order to complete the exercises in this chapter, you must log on as a full administrator. **Logging on as a user with administrator privileges is not sufficient, you must log on using the built in administrator account.**

### Setting Up Starting Layers

Each time you start AutoCAD Mechanical, layer 0 is active. Since layer 0 does not belong to the Mechanical layers, it is not displayed in the Layer Control dialog box of AutoCAD Mechanical if you select Mechanical Layer in the Show field.

It is required that you specify the mechanical layer AM_0 as the default starting layer.

**To specify a starting layer**

1. Start the Layer Control command.

   - **Toolbutton**
   - **Menu**
     - Assist ➤ Layer/Layergroup ➤ Layer/Layer Group Control
   - **Command**
     - AMLAYER

2. In the Layer Control dialog box, Layer Control tab, select the layer AM_0 and then choose Current.
Choose OK.
The layer AM_0 is active, as you can see in the toolbar:

**Setting Mechanical Options**

In the Options dialog box, you can specify general settings for AutoCAD Mechanical, Autodesk® Mechanical Desktop®, and AutoCAD®,. Tabs that affect settings for either Mechanical Desktop or AutoCAD Mechanical, or both, have an AM prefix. Use the arrows at the right end of the tab bar to move left and right through all of the available tabs.

When you start the AutoCAD Mechanical application, mechanical structure is enabled by default. Although this setting is not stored in templates, disable mechanical structure for this exercise.

**To set mechanical options**

1. Start the Mechanical Options command.

58 | Chapter 4   Working with Templates
Menu Assist ➤ Options
Command OPTIONS or AMOPTIONS

2 In the Options dialog box, AM:Structure tab, clear the Enable Structure check box, and then choose Apply.

3 On the AM:Standards tab, specify:
   Standard: ISO
   Measurement: Metric
   Model Scale: 1:1

   Choose OK.

   NOTE All settings in this dialog that are stored in the drawing (template) are marked with this icon: The current standard and all related settings are listed in the right section.
Specifying Drawing Limits

Specify the drawing limits according to size A0 (840 x 1188 mm). This limits your drawing space to the specified size.

To specify the drawing limits

1. Start the Drawing Limits command.
   Menu     Assist ➤ Format ➤ Drawing Limits
   Command  LIMITS

2. Respond to the prompts as follows:
   Specify lower left corner or [ON/OFF] <0.00,0.00>: Press ENTER
   Specify upper right corner <420.00,297.00>: Enter 841, 1189, press ENTER
   The limits are expanded to A0 format.

Saving Templates

Save the previously changed drawing as a template.

To save a template

1. Start the Save As command.
   Menu     File ➤ Save As
   Command  SAVEAS

2. In the Save Drawing As dialog box, specify:
   Files of type: AutoCAD Mechanical Drawing Template (*.dwt)
   File name: my_own_template
Choose Save.

3 In the Template Description dialog box, specify:
   - **Description**: Tutorial Template
   - **Measurement**: Metric

Choose OK.

4 Close the drawing.
   - **Menu**: File ➤ Close
   - **Command**: CLOSE

Saving Templates | 61
Using Templates

Use the previously created template to start a new drawing.

To open a template

1. Start the New command.
   Toolbutton
   Menu File ➤ New
   Command NEW

2. In the Select template dialog box, select *my_own_template.dwt*, and then choose Open.

Start the new drawing using the settings of the previously saved template.

Setting Default Standards Templates

Specify your template as the default template.
To set a default template

1. Start the Mechanical Options command.
   - Menu: Assist ➤ Options
   - Command: AMOPTIONS

2. In the Options dialog box, AM:Standards tab, choose Browse.

3. In the Open dialog box, select my_own_template.dwt, and then choose Open.

4. In the Options dialog box, choose OK.
   
   The template my_own_template is used as the default standards template until you specify a different default template.

   **NOTE** The default standards template is used if a drawing does not contain any AutoCAD Mechanical configuration. If a drawing already contains AutoCAD Mechanical configuration data, or a new drawing has been created using an AutoCAD Mechanical template, the default template does not affect the drawing.

This is the end of this tutorial chapter.
In this tutorial, you learn how to use mechanical structure in AutoCAD® Mechanical. You learn how to work with folders, components and component views. You also review the bill of materials, restructure components and resolve ghost components. You learn how to insert components from external files, edit in-place, localize external components and externalize local components.
<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>annotation view</td>
<td>A folder that contains one or more component views dedicated to annotating and detailing parts and subassemblies.</td>
</tr>
<tr>
<td>associative</td>
<td>In mechanical structure, the implication that a change to one instance of a definition is reflected in all other instances of that definition, including the definition itself.</td>
</tr>
<tr>
<td>mechanical browser</td>
<td>A browser that contains the hierarchy of components, component views, annotation views, and folders of a given mechanical structure.</td>
</tr>
<tr>
<td>component</td>
<td>A browser placeholder and identification for the component type. A component is analogous to the manufacturing units of parts and assemblies.</td>
</tr>
<tr>
<td>component view folder</td>
<td>A folder nested under a component that contains the geometry for a particular view of that component.</td>
</tr>
<tr>
<td>definition</td>
<td>A description of a folder, component, or view that AutoCAD Mechanical saves in the database, similar to a block definition.</td>
</tr>
<tr>
<td>elemental geometry</td>
<td>The graphical elements of a drawing that represent the shape and size of a part or assembly.</td>
</tr>
<tr>
<td>folder</td>
<td>A folder that contains any drawing item that does not have a dedicated or default folder preprogrammed in mechanical structure.</td>
</tr>
<tr>
<td>free object (as used in the Create Hide Situation dialog box)</td>
<td>A unit of elemental geometry.</td>
</tr>
<tr>
<td>geometry</td>
<td>The graphical elements of a drawing that represent the shape and size of a part or assembly.</td>
</tr>
<tr>
<td>hidden geometry</td>
<td>Geometry that is included in a hide situation.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>instance</td>
<td>An iteration of a definition as it appears in mechanical structure.</td>
</tr>
<tr>
<td>object</td>
<td>Used variously to describe any item in mechanical structure, whether a component, folder, or geometry.</td>
</tr>
<tr>
<td>occurrence</td>
<td>Placement of a component, usually in multiple-level assemblies, where a component is replicated as a result of multiple placements of a single part or sub-assembly.</td>
</tr>
</tbody>
</table>

**Working with Mechanical Structure**

Mechanical structure is a set of tools used to organize data for reuse. Structure is graphically represented by a tree called the mechanical browser.

![Diagram of mechanical structure browser]

In this chapter, you learn how to use mechanical structure by working through simple demonstrations. First, you must create a new drawing and enable mechanical structure.
Enabling Mechanical structure

To enable mechanical structure

- Click the STRUCT status bar button and latch it down to enable mechanical structure.

To display the mechanical browser

1. If the mechanical browser is not visible, in the command line, enter AMBROWSER.
2. When prompted, enter ON.

Folders

The basic element of mechanical structure is the folder. A folder is similar to a block in that it has a definition that can be instanced multiple times. Like a block, the definition is stored away in the nongraphical area of the drawing. Similar to blocks, any change you make to the folder definition is reflected in all instances of that folder.

Creating Folders

1. Use the Circle tool to create a circle. The size and proportions are not important.
2. Use the Rectangle tool to draw a rectangle around the circle.
3. Right-click anywhere in the browser, and select New ➤ Folder.
4. Respond to the prompts as shown:
   Enter folder name <Folder1>: Press ENTER
   Select objects for new component view:
   Select the circle and then the rectangle and press ENTER
   Specify base point: Pick the lower left corner of the rectangle
Modifying Folders

While folders are similar to blocks, there are significant differences. The most significant, is that the contents of a folder remain editable without the need for a special editing mode like REFEDIT.

To grip edit the circle

1. Continue clicking the circle until you see the word CIRCLE in the tooltip window.
2. Select a grip, drag and then click.

If a folder's contents are selectable, how do you select the folder? This is where the tooltip comes in. You select folders (and other elements of structure) by cycling through a selection, and the tooltip tells you what you are selecting. In the next exercise, you copy the folder to demonstrate structure selection.

To copy the folder

1. Press ESC to clear any preselection.
2. In the command line, enter -COPY and press ENTER.
3 Continue clicking the circle until you see the word Folder1:1 in the tooltip window.

4 Press ENTER to complete selection, then pick points to finish the copy.

5 Press ESC to finish.

The mechanical browser shows a second instance of the folder (Folder1:2), implying that you copied the folder, not just the contents.

In the next exercise you modify the contents of a folder to demonstrate that modifying one instance of a folder updates both.

**To edit an instance**

1 Continue clicking a circle until you see the word CIRCLE in the tooltip window.

2 Press DELETE. Note how the circle is deleted from both instances.

Next, you add new geometry to a folder. Before you add geometry you must *activate* the folder to make it the active edit target. This ensures that geometry is added to the folder and not to model space.

**To activate and add geometry**

1 In the browser, right-click Folder1:1 and select Activate. The geometry that does not belong to this folder is dimmed out.
2 Use LINE to draw two diagonal lines from corner to corner on the rectangle. Note that the lines appear in the other instance as soon as the command is completed.

3 Double-click a vacant area in the browser to reset activation.

**Nesting Folders**

Like blocks, folders can be nested. However, a folder cannot be nested within itself, which is about the only restriction on folder nesting.

1 Draw a small circle in the lower triangle in the second instance of the folder.

2 Draw a line from the center of the circle to the 3 o’clock quadrant of the circle.

3 In the browser, right-click Folder1:2 and select New Folder.
4  Respond to the prompts as shown:
   Enter folder name `<Folder2>`: Press ENTER
   Select objects for new component view:
   Select the circle and then the line and press ENTER
   Specify base point: Select the center of the circle.

5  Expand Folder1:1 and Folder 1:2 and verify that a nested folder was created.

6  In the browser, right-click Folder1:2 again and select Insert Folder.

7  Respond to the prompts as below:
   Enter folder name to insert or [?] `<?>`: Enter `Folder2` and press ENTER
   Specify the insertion point or [Base point/Rotate 90]:
   Click in the triangle on the right, in the second instance of Folder1
   Specify rotation angle `<0>`: Enter 45 and press ENTER
Notice that when you added the nested folders, both instances updated, just like when you added the lines. Folder2:1 was created as a child of Folder1:2 because we chose New Folder from its context menu, and Folder2:2 was inserted into Folder1:2 for the same reason. Note that as with blocks, you were able to rotate the folder instance on insertion.

**Instance vs. Occurrence**

To finish with folders, you inspect a few browser functions such as visibility and property overrides. While performing these exercises you learn the difference between instances and occurrences.

**To override properties**

1. In the browser, right-click Folder1:1 and select Property Overrides.
2. In the Property Overrides dialog box, select the Enable overrides check box.
3. Select the Color check box. The default color changes to red.
4. Click OK.
   
   Note how the entire instance, inclusive of the nested folders is now red. Also note how the color change did not have an effect on Folder1:2.
5. In the browser, right-click Folder1:1 again, and select Property Overrides
6. In the Property Overrides dialog box, clear the Enable overrides check box, and click OK.
In the browser, right click Folder1:1 ➤ Folder2:1 and select property overrides.

Apply a color override of red to the folder.

The subfolder you selected is now red, but the other subfolder is not. Notice that the same subfolder is red in Folder1:2. This is because property overrides are instance-based. When you look at visibility you will understand why this matters.

To apply visibility overrides

1. In the browser, right-click Folder1:1 and select Visible. The entire folder is now invisible.
2. In the browser, right-click Folder1:1 and select Visible. The folder is visible again.
3. In the browser, right-click Folder1:1\Folder2:2 and select Visible. Notice that unlike the property overrides, both instances of Folder2 are visible in Folder1:2. That’s because visibility is occurrence-based.

Selection Modes

The three status bar buttons next to the STRUCT status bar button control the different selection modes.
Button | Function
--- | ---
BTM-UP/TOP-DN | Switches the structure selection order between bottom-up and top-down.
R-LOCK | Switches the Reference Lock on and off. When the Reference Lock is on, you cannot select entities in an external folder or view (more on this later).
S-LOCK | Switches the Selection Lock on and off. When the Selection Lock is on, selection is restricted to the active edit target and below.

The next two exercises demonstrate the behavior of the BTM-UP/TOP-DN and S-LOCK selection modes.

**To select items when the selection mode is set to top-down**

1. Press ESC to clear any selections.
2. Click the BTM-UP/TOP-DN button and ensure that the text on the button reads TOP-DN.
3. Click one of the circles in Folder1:1. Note the tooltip indicates that you selected the folder, Folder1:1, and not the circle.
4. Click the circle again. Note the tooltip indicates that you selected the nested folder.
5. Click the circle again. Note the tooltip indicates that you have finally managed to select the circle.
6. Click the circle again. Selection cycles to Folder1:1 again.

When the selection mode is set to top-down, the selection sequence begins at the topmost level and ends with the elemental geometry. When the selection mode is set to bottom-up the selection begins with the elemental geometry.

You may want to set the selection mode and repeat the exercise to verify the behavior of the selection modes under the bottom-up.
To select items when S-LOCK is on

1. Press ESC to clear any selections.
2. In the browser, double-click Folder1:1 to activate it.
3. Click the S-LOCK button and latch it down to turn on the selection lock.
4. Click one of the circles in Folder1:2. Note that the circle is no longer selectable.
5. Click one of the circles in Folder1:1. Grips appear, indicating that selection is possible.
6. Double-click the root of the mechanical browser tree to reset activation.
7. Close the drawing. You can save the drawing, if required.

Components and Component Views

You may notice that folders provide some useful features, but they're probably not different enough from blocks to convince you to change over to the structure paradigm. The potential of mechanical structure begins to be revealed when you start dealing with components and component views.

Component Views are basically folders with some extra rules that make them more suitable for mechanical design. You typically need more than one view to fully describe a part or assembly. Folders (and blocks before them) don't offer any mechanism other than naming to associate multiple views of the same part. Components and views solve this by allowing you to collect multiple folders (component views) under a single Component.

A component can be a part or assembly, based on its contents (if a component contains another component, then it's an assembly). The component also gives you a place to store attributes like description and material. Components don't actually contain geometry; they just group the views that contain the geometry. This will begin to make more sense when you create some components and component views.

Creating Part Components

1. Start a new drawing and draw a long thin rectangle (the edge view of a plate).
2 Draw a second rectangle, above the first, having the same width (the top view).

3 Right-click anywhere in the browser, and select New ➤ Component.

4 Respond to the prompts as shown:
   Enter new component name <COMP1>: Press ENTER
   Enter new view name <Top>: Press ENTER
   Select objects for new component view:
   Select the larger rectangle and press ENTER
   Specify base point: Pick the lower left corner of the rectangle

   Note that the mechanical browser now displays the component COMP1:1 and that it contains the component view; Top, below it.

To add a new view to a component

1 In the browser, right-click COMP1:1 and select New ➤ Component View.

2 Accept the default name for the component view.

3 Select the smaller rectangle and press ENTER.

4 To specify a base point, click the lower left corner of the rectangle. Note that the new component view, Front, was added to the component COMP1:1
Creating Assembly Components

You now have two component views; Front and Top, and they are grouped together in the browser by COMP1:1. In the next exercise, you insert another instance of COMP1 and assemble the two components (parts) in an “L” shape.

To insert a new instance of a component

1. In the browser, right-click a vacant area, and select Insert ➤ Component.
2. Respond to the prompts as shown:
   Enter component name or [?] <?>: Enter COMP1 and press ENTER
   Enter component view name or [?] <Top>: Enter Front and press ENTER
   Specify the insertion point or [Base point/Rotate 90]:
   Pick point 1, the top left corner of the larger rectangle
   Specify rotation angle <0>: Press ENTER
3 In the browser, right-click COMP1:2 and select Insert ➤ Component View ➤ Top.

4 Respond to the prompts as shown:
   Specify the insertion point or [Base point/Rotate 90]:
   Pick point 2, the lower left corner of the front view of COMP1:1
   Specify rotation angle <0>: Press ENTER.

To assemble components

1 Right-click anywhere In the browser, and select New ➤ Component.
2. Respond to the prompts as shown:
   Enter new component name <COMP2>: Enter ASSY and press ENTER
   Enter new view name <Top>: Enter Front and press ENTER
   Select objects for new component view:
   Select COMP1:1 (Front) and COMP1:2 (Top) and press ENTER
   To select a component view instead of the geometry, continue clicking the geometry until you see the component view name in the tooltip window. If you accidentally select the wrong view, you can cancel the selection by selecting the view again with the SHIFT key pressed.
   Specify base point: Pick the lower left corner of the combined view.
   The Component Restructure dialog box is displayed.

3. In the Destination Components list, right-click a vacant area, and select Create New View.

4. Respond to the prompts as shown:
   Enter new view name <Top>: Press ENTER
   Select objects for new component view:
   Select COMP1:1 (Top) and COMP1:2 (Front) and press ENTER
   Specify base point: Pick the lower left corner of the combined view
Modifying Assembly Components

As you work, you can continue to add views as needed. To demonstrate this, in the next exercise, you add a side view of this assembly.

To add a component view

1. Draw a rectangle representing the side view of the first instance of COMP1.
2. In the browser, right-click ASSY:1 and select New ➤ Component View.
3. Respond to the prompts as follows:
   - Enter new view name <Right>: Enter Side and press ENTER
   - Select objects for new component view:
     - Don’t pick anything - just press ENTER
   - Specify base point: Pick the lower left corner of the rectangle
4. In the browser, right-click COMP1:1 and select New ➤ Component View.
5. Respond to the prompts as shown:
   - Enter new view name <Right>: Enter Side and press ENTER
   - Specify parent view or [] <Front>: Enter Side and press ENTER
   - Select objects for new component view:
Pick the rectangle and press ENTER

Specify base point: Pick the lower left corner of the rectangle

6 In the browser, right-click COMP1:2 and select Insert ➤ Component View ➤ Side.

7 Respond to the prompts as shown:
   Specify parent view or [?] <Front>: Enter Side and press ENTER
   Specify the insertion point or [Base point/Rotate 90/nextView]: Enter R and press ENTER
   Specify the insertion point or [Base point/Rotate 90/nextView]: Pick a place close to the other view
   Specify rotation angle <90>: Press ENTER

8 Move the view into the correct position.
In the next exercise, you add a component to the assembly to demonstrate the ability to add a component after the assembly is created.

**To add a component**

1. Draw a circle on the top view of the assembly.
2. In the browser, right-click ASSY:1(Top) and select New ➤ Component.
3. Respond to the prompts as shown:
   - Enter new component name <COMP2>: Press ENTER
   - Enter new view name <Top>: Press ENTER
   - Select objects for new component view: Select the circle and press ENTER
   - Specify base point: Click the center of the circle
4 Draw a rectangle representing the projected view in the front view of the assembly

5 In the browser, double-click ASSY:1 ➤ Top to activate that view

6 Right-click COMP2:1 and select New ➤ Component View.

7 Respond to the prompts as shown:
   Enter new view name <Front>: Enter Side and press ENTER
   Specify parent view or [?] <Front>: Press ENTER
   Select objects for new component view:
   Select the rectangle and press ENTER
   Specify base point: Pick the midpoint of the lower edge of the rectangle
8  In the browser, double-click ASSY:1 ➤ Side to activate it.

9  Ensure that S-LOCK is off and copy COMP2:1(Side) and position it in the side view.

   To select a component view instead of the geometry, continue clicking the geometry until you see the component view name in the tooltip window

10 In the Component View Instance created dialog box, select Existing in the last column.

11 Double-click a vacant area to reset activation.
Using Folders with Component Views

When folders are used in conjunction with component views, you can do several useful things. This section shows two examples. You can use folders to contain drawing items that would otherwise not be accounted for with a default component view folder.

In the following example, a folder, Groove:1, was created to contain the upper groove and arrayed to create the others. Because the groove is implemented as a folder, it does not have an impact on the BOM. Modifying one of the grooves results in all grooves being updated.

In the following example, a folder, Profile:1, was created to contain the upper-wheel profile. Profile:2 is another instance of this folder, created by mirroring Profile:1. Changing one profile automatically updates the other. The wheel component was created after the Profile folders. The design intent is captured and organized with these folders.

Mechanical Browser Display Options

The mechanical browser shows the hierarchical organization of components within a drawing. In this section, you use browser options to show data in different ways to get a better understanding of components and component views.
The default view of the mechanical browser shows the hierarchical organization of components as well as indicates which component owns a given component view.

To show the View Tree and Component Tree

1. Right-click the root node of the mechanical browser and select Browser Options.
2. In the View Tree section, select the Display Tree check box.
3. In the Component Tree section, clear the Component Views check box.
4. Click OK.
5. Right-click a vacant area in the browser and select Expand All.

In this view, the hierarchy of components as well as views are shown.
To show both default and expandable assembly views

1. Right-click the root node of the mechanical browser and select Browser Options.

2. In the Component Tree section, select the Component Views check box.

3. Click OK.

In this view, the mechanical browser shows the hierarchy of components, component views as well as indicates which component owns a given component view. In practice, you can work with the view settings that make most sense to you.

**Mechanical Browser and Bombs**

Components not only group component views, they hold bills of material (BOM) attributes as well. In the next exercise, you insert a parts list and in the process, explore the BOM of the simple assembly you created.
To insert a parts list

1  In the command line, enter AMBOM.

2  Respond to the prompts as shown:

Specify BOM to create or set current [Main/?] <MAIN>: Press ENTER

3  In the BOM dialog box, click the plus sign (+) in the first column to expand ASSY.

4  Click the Insert Parts list button on the toolbar of the BOM dialog box.

5  In the Parts List dialog box, click OK and click inside the drawing to indicate where to insert the parts list.

6  In the BOM dialog box, click OK.
By associating views through a single component, the BOM is managed accurately and semi-automatically. You can manage component attributes through the BOM editor or directly on the component from the browser.

Browser Restructure and Ghost Components

In the next exercise you restructure COMP1:1 and COMP2:1 to be parts of an assembly named SUB-ASSY. To do this, you must create SUB-ASSY first.

To create a component

1. Right-click a vacant area in the browser and choose New ➤ Component.

2. Respond to the prompts as follows:
   
   Enter new component name <COMP3>: Enter SUB-ASSY and press ENTER
   
Enter new view name <Top>: Press ENTER
   
   Select objects for new component view:
Select COMP1:1 (Top) and COMP2:1 (Top) and press ENTER.

To select a component view instead of the geometry, continue clicking the geometry until you see the component view name in the tooltip window. If you accidentally select the wrong view, you can cancel the selection by selecting the view again with the SHIFT key pressed.

Specify base point: Pick the lower left corner of the combined view.

The Component Restructure dialog box is displayed.

3. Observe the mechanical browser.
Note that the component SUB-ASSY is already created (1) and COMP1:1 and COMP2:1 are components of it. Also, the COMP1:1 and COMP2:1 continue to exist as components of ASSY1 (2), but the icon changed. This icon indicates that the component is a Ghost Component. Ghost components are containers of the views of components that are in an intermediate state of restructure.

To learn how to resolve ghost components, you must stop creating SUB-ASSY at this point.

4 Click OK. You now have two ghost components in the browser.

Before you start resolving ghost components, you must add two component views to the component SUB-ASSY.

5 In the browser, right-click SUB-ASSY:1 and select New ➤ Component View.

6 Respond to the prompts as follows:

Enter new view name <Front>: Press ENTER

Select objects for new component view:
Don’t pick anything. Just press ENTER

Specify base point:

**Pick the lower left corner of the large rectangle in the lower left of the drawing**

7 In the browser, right-click SUB-ASSY:1 and select New ➤ Component View again.

8 Respond to the prompts as shown:

- Enter new view name <Right>: Enter Side and press ENTER
- Select objects for new component view:
  
  **Don’t pick anything. Just press ENTER**

  Specify base point:

  **Pick the lower left corner of the assembly displayed in the lower right of the drawing**
To resolve ghost components

1 In the browser, click the ghost component COMP1:1, press the CTRL key and click COMP2:1. Both components are selected.

2 Drag to SUB-ASSY1. The Component Restructure dialog box is displayed.

3 In the Source Component Views list, with the CTRL key pressed select COMP1:1(Front) and COMP2:1(Side).

4 Drag to SUB-ASSY1(Front). The views move from the Source Component Views list to the Destination Component Views list.

5 Drag the remaining views in the Source Component Views list to SUB-ASSY1:(Side) in the Destination Component Views list.

6 Click OK.
The ghost components disappear and COMP1:1 and COMP2:1 are now parts of SUB-ASSY1.

In the final exercise of browser restructure, you restructure SUB-ASSY1 to be a subassembly of ASSY1.

To restructure components

1. In the browser, drag SUB-ASSY:1 ➤ Front to ASSY:1 ➤ Front. The Restructure components dialog box is displayed.

2. Drag SUB-ASSY:1 (Top) to ASSY:1 (Top) and SUB-ASSY:1 (Side) to ASSY:1 (Side).

3. Click OK. SUB-ASSY1 is restructured as a subassembly of ASSY:1.
External Reference Components

In AutoCAD Mechanical, you can save individual parts and subassemblies in external files and share them between designs. When a part is modified, the changes are propagated to all instances, ensuring that assembly drawings are always synchronized with their related part drawings.
Inserting External Components

In this exercise, you insert a Gripper on to a Gripper Plate drawing.

1. Open the file Tut_Gripper_Plate.dwg in the acadm\tutorial folder.

   **Toolbutton**

   **Menu** File ➤ Open
   **Command** OPEN

   The drawing contains two views of a gripper plate and contains two construction lines.

2. To keep the original file intact, save the file as Gripper.dwg

3. Display the Structure Catalog.

   **Toolbutton**

   **Menu** Insert ➤ Structure Catalog
   **Command** AMSCATALOG

4. In the Files tab, navigate to the acadm\tutorial folder and select Tut_Gripper.dwg. The structure panel shows the mechanical structure components in the drawing and the preview panel shows a preview of the drawing.

5. In the structure panel, drag GRIPPER ➤ Front to model space.

6. Respond to the prompts as shown:

   *Specify the insertion point or [Base point/Rotate 90/nextView]:*

   *Pick the upper left corner of the smaller rectangle*

   *Specify rotation angle <0>: Press ENTER*

   Note the mechanical browser. The external reference (xref) component is indicated by a blue colored marker.
Once one view of an xref component is inserted, the other views can be inserted as normal.

**To insert another view of the xref component**

1. In the browser, right-click GRIPPER1 and select Insert from Xref Drawing ➤ Component View ➤ Top.
2. Respond to the prompts as shown:
   - **Specify the insertion point or [Base point/ Rotate 90/nextView]:**
     - *Pick the upper left corner of the larger rectangle*
   - **Specify rotation angle <0>: Press ENTER**

**To insert more instances of the xref component**

1. In the command line enter `MIRROR` and press ENTER.
2. Respond to the prompts as shown:
Select objects:

Ensure that the selection mode is set to TOP-DN and in model space, click both xref views you just inserted and press ENTER

Specify first point of mirror line:

Click anywhere on the vertical construction line

Specify second point of mirror line:

Click elsewhere on the vertical construction line

Erase source objects? [Yes/No] <N>: Enter N and press ENTER

3 In the last column of the Component View Instance Created dialog box, select New.

A new instance of the component, GRIPPER:2 is created. You will now mirror the top views of GRIPPER:1 and GRIPPER:2 to draw two more grippers on the top view of the plate.

4 In the command line enter MIRROR and press ENTER.

5 Respond to the prompts as follows:

Select objects:

Ensure that the selection mode is set to TOP-DN and in model space, click the top views of the two grippers, press ENTER

Specify first point of mirror line:

Click anywhere on the horizontal construction line
Specify second point of mirror line:

*Click elsewhere on the horizontal construction line*

Erase source objects? [Yes/No] <N>: Enter N and press ENTER

Next, you assemble the components under an assembly, named GRIPPER ASSEMBLY.

**To assemble components**

1. Right-click a vacant area in the browser, and select New ➤ Component.
2. Respond to the prompts as shown:
   - Enter new view name <Top>: Enter Front and press ENTER
   - Select objects for new component view: Ensure that the selection mode is set to TOP-DN and window select the smaller rectangle and the two grippers connected to it and press ENTER
   - Specify base point: Pick the intersection of the construction line with the upper edge of the rectangle
The Component Restructure dialog box is displayed.

3 In the Destination Components list, right-click a vacant area, and select Create New View.

4 Respond to the prompts as shown:

   Enter new view name <Top>: Press ENTER

   Select objects for new component view:

   Ensure that the selection mode is set to TOP-DN and window select the larger rectangle and the four grippers connected to it and press ENTER

   Specify base point: Pick the intersection of the two construction lines

5 Save the file as Gripper Assembly.dwg.

**Editing External Components In-place**

In AutoCAD Mechanical, you can edit xref components in-place. Although this is very convenient, if you accidently modify a component, the mistake effects all drawings that use this xref component. As a precaution, you must do one of the following before you edit an xref component:

- Release the R-LOCK status bar button.
- Activate the xref component view or folder to be edited.
In the next exercise, you modify the gripper lever using the activate method.

**To edit an xref component in place**

1. In the browser, double-click Gripper ➤ Front to activate it.
   Notice that locks appear on all instances of the gripper in the browser. This indicates that the source file containing the gripper is now locked and no one else can modify it.

2. Start the Chamfer command.
   - **Toolbutton**
   - **Menu** Modify ➤ Chamfer
   - **Command** AMCHAM2D

3. Respond to the prompts as shown:
   
   Select first object or [Polyline/Setup/Dimension]: <Setup>
   Press ENTER

4. In the Chamfer dialog box, select 10 as the first and second chamfer lengths, and click OK

5. Respond to the prompts as shown:
   
   Select first object or [Polyline/Setup/Dimension]: <Setup>
   Select the left vertical line of the gripper lever (1)
   Select second object or <Return for polyline>:
   Select the lower horizontal line of the gripper lever (2)
   Select object to create original length: Press ESC

6. In the browser, double-click a vacant area to reset activation.
   Note that although the xref component view is no longer the active edit target, the gripper continues to be locked.
7  In the browser, right-click a vacant area, and select Purge All Locks.
8  In the Purge Locks message box, click OK.

To verify if the changes were written back to the source file
- In the browser, right-click GRIPPER1 and select Open to Edit. The Gripper source file opens.

Note that the component view Open Position has also been modified. How did this happen?
Expand the component Lever1. Notice that it has two instances of the component view Front. Another example of how mechanical structure can eliminate repetitive tasks.

Localizing and Externalizing

To modify a part without effecting other drawings that use the part, you can localize the xref component. By localizing you copy the definition of the xref component to the current drawing and the link with the xref file is severed.

To localize an xref component
1  From the Window menu, switch to the Gripper Assembly drawing.
2  In the browser, right-click the GRIPPER assembly node and select Localize.
3  In the Xref Info message box, click Yes.
   The Gripper is no longer an xref component.

To detail a part without losing associativity between the detail and assembly, you can externalize the part to a file and detail it in that file. In the next exercise you externalize the cylinder component.

To externalize a component
1  In the browser, expand one of the Gripper components and right click CYLINDER:1.
2  Select Externalize.
3  In the New External File dialog box, accept the defaults and click Save.
Annotation Views

In some cases, externalizing to detail may be considered excessive. Mechanical Structure provides for creating Annotation Views, an associative view of a component purely for the purpose of detailing. Annotation views have no effect on the BOM.

In the next exercise, you create an annotation view for the LEVER component.

To create an annotation view

1. In the browser, expand one of the Gripper components and right-click LEVER:1
2. Select New ➤ Annotation View.
3. Respond to the prompts as follows:
   - Enter annotation view name <LEVER(AV1)>: Press ENTER
   - Select placement location
     [Modelspace/existing Layout/ New layout] <existing Layout>:
     Press ENTER
   - Enter existing layout name <Layout1>:
     Press ENTER
   - Enter scale or [Calculate] <1:2>:
     Press ENTER
   --- Switch to Paperspace ---
   - Restoring cached viewports - Regenerating layout.
   - Create labels for all subviews [Yes/No] <No>:
     Press ENTER
   - Specify base point:
     Select a point at the center of the A3 paper for the annotation views
   - Specify the insertion point or [Base point/ Rotate 90/nextView/Done] <Done>:
     Select a point just below and to the right of the point you clicked on previously
   - Specify rotation angle <0>:
     Press ENTER
   - Specify the insertion point or [Base point/ Rotate 90/nextView/Done] <Done>:
Use object tracking mode for alignment, select a point directly below the point you clicked on previously.

Specify rotation angle <0>: Press ENTER

Specify the insertion point or [Base point/Rotate 90/nextView/Done] <Done>: Press ENTER

NOTE: You can type AMSNEW at the command line to display the New dialog box to create annotation views.

To annotate the geometry in the annotation view

1. Start the Automatic Dimension command.
   Toolbutton
   Menu Annotate ➤ Automatic Dimension
   Command AMAUTODIM
   The Automatic Dimensioning dialog box is displayed.

2. In the Type drop-down list, select Chain and click OK.

3. Respond to the prompts as follows:
   Select objects [Block]:
   *Window-select the larger of the two views in the annotation view*
   Select objects [Block]: Press ENTER
   First extension line origin: *Pick the upper left corner of the geometry*
   Specify dimension line location or [Options/Pickobj]:
   *Select a point to the left of the geometry*
   Starting point for next extension line: Press ENTER
4 Note the dimension of the chamfer section.

To modify the chamfer in the assembly

1 Switch to model space. In the browser, expand GRIPPER:1, right-click LEVER:1 ➤ Front and select Zoom to.

2 Start the Power Edit command.
   Toolbutton Modify ➤ Power Commands ➤ Power Edit
   
   Menu AMPOWEREDIT

3 Respond to the prompts as shown:
   Select object: Select the Chamfer

4 In the Chamfer dialog box, select 2.5 as the First Chamfer Length and 5 as the Second Chamfer Length, and click OK.

5 Switch to layout1. In the browser, right click LEVER(AV1:1) and select Zoom to.
   Note that the Lever shape is changed and the dimensions are updated.

**Associative Hide**

Mechanical structure is all about reuse, especially reuse of components in an assembly to show multiple instances of a component and reuse of component views in the assembly and in the part detail. Component view instances are
often obscured in the assembly, sometimes the same view is even obscured differently in different instances. This requires a mechanism to make a folder or component view instance partially or fully hidden without effecting other view instances. Use Associative hide (AMSHIDE) to do just that.

**Basics of AMSHIDE**

In the next exercise, you create a hide situation between two folders.

**To create a hide situation**

1. Open the file Tut_AMSHIDE.dwg in the acadm\tutorial folder.
   
   **Toolbutton**
   
   **Menu** File ➤ Open
   **Command** OPEN
   
   The drawing contains three instances of a folder, where two overlap each other.

2. Start the Associative Hide command.
   
   **Toolbutton**
   
   **Menu** Modify ➤ Associative Hide ➤ Create Associative Hide Situation
   **Command** AMSHIDE
3. Respond to the prompts as follows:
   Select foreground objects:
   *Ensure that the selection mode is set to TOP-DN and click the upper rectangle (1)*
   Select foreground objects: Press ENTER

4. In the Create Hide Situation dialog box, expand Level1 and Level2. Note how Folder1 is selected for the foreground (Level1) and Folder2 is selected for the background.

5. Click the Hide node on the tree in the dialog box.

6. Click the Hide Style button.
   The hidden lines are set to invisible. The change is immediately reflected in model space.

7. In the Name box, enter *Test Hide.*

8. To swap the foreground and background, select Level1 on the tree and click the Send to Back button on the toolbar of the dialog box. Note that the position of Level1 changes in the tree and model space reflects the change immediately.

9. Click OK.
   In the next exercise, you edit the hide situation and add the third folder to the hide situation.
To edit a hide situation

1. In the browser, expand the Hide Situations node, and select Test Hide. Note that the entities involved in the hide are highlighted in model space.

2. Double-click Test Hide. The Edit Hide situations dialog box is selected.

3. In Edit Hide Situation dialog box, click the button. Level3 is added to the top of the tree.

4. Click the select objects button.

5. Respond to the prompts as follows:
   Select objects:
   *Ensure that the selection mode is set to TOP-DN and click the rectangle on the extreme right
   Select objects: Press ENTER

6. Click OK.

7. Use the MOVE command to move the contents of Folder 1:3 on top of Folder1:2 and Folder 1:3.
Using AMSHIDE in Assemblies

In this section, you create a hide situation on an assembly and save it to the appropriate position in the mechanical structure.

To open the sample files

- Open the file Tut_Robot_Arm.dwg in the acadm\tutorial folder.

To create a hide situation between the gripper and the axis of the robotic arm

1. Start the Associative Hide command.
   
   Menu: Modify ➤ Associative Hide ➤ Create Associative Hide Situation
   Command: AMSHIDE
2. Respond to the prompts as shown:
   Select foreground objects:
   *Continue clicking (1) until you see GRIPPER:2 (Front) in the tooltip*
   Select foreground objects: Press ENTER

3. In the message box that appears, click No.

4. In the Create Hide Situation dialog box, expand Level2.
   Note that the background selection includes two views, GRIPPER PLATE1:(Front) and ROBOT:1 (Front). The GRIPPER PLATE:1 (Front) should not be in the hide situation at all. The correct object for the background should be AXIS:1 (Front) and not ROBOT:1, which is the current selection. So, remove both objects selected for Level2 and do the selection all over again.

5. In the tree of the Create Hide Situation dialog box, right click GRIPPER PLATE:1 (Front) and select Remove.

6. Similarly remove ROBOT:1 (Front) from Level2.
   **NOTE:** You could have removed both component views at once by clicking the Clear Selection button.

7. Click Level2 in the tree view and select the button.

8. Respond to the prompts as shown:
   Select objects:
   *Continue clicking (2) until you see AXIS:1 (Front) in the tooltip*
   Select objects: Press ENTER
9. In the tree view of the Create Hide Situations dialog box, click the Hide node.
   In the next step, you select where in the browser the hide situation is stored. The most logical place to store the hide situation is on the Front view of the ROBOT:1 assembly.

10. In the Store Hide Situation on list, select ROBOT:1 (Front).

11. Click OK. The Hide Situation is created and stored under ROBOT:1 (Front) in the browser.
    This is the end of the tutorial.
Working with Layers and Layer Groups

In this tutorial, you learn more about the various commands used for working with layers and layer groups in AutoCAD® Mechanical.
## Key Terms

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>base layer</td>
<td>A layer made up of working layers and standard parts layers. Base layers are repeated in every layer group.</td>
</tr>
<tr>
<td>layer group</td>
<td>A group of associated or related items in a drawing. A major advantage of working with layer groups is that you can deactivate a specific layer group and a complete component. The drawing and its overview is enhanced with a reduction in regeneration time.</td>
</tr>
<tr>
<td>part layers</td>
<td>The layer where the standard parts are put. All standard parts layers have the suffix AM_*N.</td>
</tr>
<tr>
<td>working layer</td>
<td>The layer where you are working.</td>
</tr>
</tbody>
</table>

## Working with Layers and Layer Groups

Layers and their colors can be customized and renamed according to your needs. In the Options dialog box, AM Standards tab, choose a standard. In the list of related settings for your standard, double-click Layer/Objects. The Layer/Objects dialog box is displayed. See “customize layers” in Help for further information.

- Layer 0 is a default layer and not a mechanical layer, because this layer has special properties (by block). If you want to have these special properties available, rename layer AM_0 to 0 in the Layer/Objects dialog box.

- Because AutoCAD® always starts with Layer 0, we recommend that you use template files, where layer AM_0 is always the starting layer.

- If you move elements on layer 0 to other layer groups, you are asked if you always want to move the elements on layer group layergroupname-AM_0.
Getting Started

To open the initial drawing

1. Open the file tut_layers.dwg in the acadm\tutorial folder.

   Toolbutton
   Menu File ➤ Open
   Command OPEN

2. Zoom in to the area of interest.

   Toolbutton
   Menu View ➤ Zoom ➤ Window
   Command ZOOM

3. Respond to the prompts as follows:
   - Specify first corner: Specify first point (1)
   - Specify opposite corner: Specify second point (2)

Save your file under a different name or to a different directory to preserve the original tutorial file.
Changing Layers By Selecting Objects

First, you move the layer (and layer group) containing two objects to another layer (and layer group) by selecting an object in the original layer (and layer group).

To change a layer by selecting an object

1. Start the Move to another Layer command.
   
   Toolbutton
   
   Menu Modify ➤ Properties ➤ Move to another Layer
   
   Command AMLAYMOVE

2. Respond to the prompts as follows:

   Select objects: Specify the centerlines of the differential gear (1, 2)
   
   Select objects: Press ENTER
   
   Specify new layer using object, layer field or keyboard (RETURN for dialog): Specify the engine centerline (3)

The centerlines of the differential gear are moved to the layer and layer group of the engine centerline.

Save your file.
Creating Layer Groups

Layer groups provide another way to structure assembly drawings. Use layer groups to highlight single parts and lock and freeze whole parts. This gives you a better overview of your assembly drawing.

First, you move a block to a layer group.

To move a block to a layer group

1. Start the Move to Another Group command. 
   Toolbutton: Modify ➤ Properties ➤ Move to another Layer Group
   Command: AMLGMOVE

2. Respond to the prompts as follows:
   Select objects: Specify the gear (1)
   Select objects: Press ENTER
   Specify new group using object or enter group name (Return for dialog):
   Press ENTER

3. In the Layer Control dialog box, choose the Create button, and create a new layer group called Gear. Choose Apply, and then choose OK.
4 In the Named Block dialog box, choose Yes All.

5 In the AutoCAD dialog box, choose Yes.

The complete block is moved to the layer group Gear.

Now, you create two new layer groups and move the parts (blocks) to those groups.

To create a new layer group

1 Start the Layer Group Control command.

   Toolbutton

   Menu      Assist ➤ Layer/Layergroup ➤ Layer/Layer Group Control

118 | Chapter 6   Working with Layers and Layer Groups
2 In the Layer Control dialog box, choose the Layer Group Control tab, and then choose Create.

3 Enter *Coverplate* for the layer group name, and then choose Apply.

4 Choose Create again, and then create a layer group called Bushing.

Choose OK.

5 Start the Move to Another Group command.

   **Toolbutton**

   **Menu**

   **Command**

   6 Respond to the prompts as follows:

   Select objects: *Specify the coverplate (1)*

   Select objects: *Press ENTER*
7 In the Layer Control dialog box, select the layer group Coverplate, and then choose OK.

8 In the Named Block dialog box, choose Yes. Now, move the bushing to the new Bushing layer group.

To move elements to another layer group

1 Start the Move to Another Group command.
2 Respond to the prompts as follows:
   Select objects:  Specify the bushing (1)
   Select objects:  Press ENTER

   Specify new group using object or enter group name (Return for dialog):

   Press ENTER

3 In the Layer Control dialog box, select the layer group Bushing, and choose OK.
4 In the Name Block dialog box, choose Yes. The coverplate and the bushing have been moved to their respective layer groups. Save your file.

Using Layer Groups to Copy Objects

Now, copy the objects of the layer group Shaft to a new drawing border.

To copy objects of a layer group

1 Zoom to the extents of the drawing.

Toolbutton

Menu View ➤ Zoom ➤ Extents

Command ZOOM

2 Start the Visibility Enhancement command.
3 In the Visibility Enhancement dialog box, specify:

Mode: Color all Inactive Layer Groups

4 Choose OK.

**NOTE** For a correct representation, you might need to start the REGEN command.

5 Start the Layer Group Control command.

**NOTE** You can activate the layer group Shaft with a double-click, too.

6 In the Layer Control dialog box, Layer Group Control tab, select the layer group Shaft, and then choose the Current button.
Choose OK.

Copy the layer group Shaft to the second drawing border.

7 Start the Copy command, responding to the prompt.

Toolbutton

Menu Modify ➤ Copy Layer Group
Command AMCOPYLG

Enter layer group name or (?) <select object>: 

Enter Shaft, press ENTER

Layer group "shaft" selected, 47 found.

Select objects: Press ENTER

Enter new layer group name or (?) <Group1>: Enter Shaft2, press ENTER

Specify base point or displacement:

Specify a point on the shaft

Specify second point of displacement or <use first point as displacement>: Specify another point in the drawing border on the right
The second drawing order looks like this:

This is the end of the tutorial chapter.
Save your file.
Designing Levers

In this tutorial, you start with a lever inserted from the parts library, and then you refine the design using many of the design options available in AutoCAD® Mechanical. You also create a drawing detail and add dimensions to it.
# Key Terms

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>construction lines</td>
<td>Lines, which are infinite in both directions or rays, which are infinite starting at a point that can be inserted into the drawing area. You use construction lines to transfer important points (for example, center points of holes) into other views or drawing areas.</td>
</tr>
<tr>
<td>construction geometry</td>
<td>A line or an arc created with construction lines. Using construction geometry in 2D drawings helps define the shape of a contour.</td>
</tr>
<tr>
<td>detail</td>
<td>A portion of a design drawing that cannot be clearly displayed or dimensioned in the overall representation but can be enlarged to show the details.</td>
</tr>
<tr>
<td>distance snap</td>
<td>To give the dimensions in a drawing a uniform appearance, Power Dimensioning and Automatic Dimensioning enable automatic insertion of the dimension line at a defined distance from the object being dimensioned. While dragging the dimension line dynamically, you will find that it remains “fixed” and is highlighted in red as soon as the required distance to the object being dimensioned is reached.</td>
</tr>
<tr>
<td>library</td>
<td>A feature that makes it possible to store parts such as blocks and drawings in a library. For every inserted part, an icon can be created. The icon is put in the display section on the right side of the dialog box along with an assigned name.</td>
</tr>
<tr>
<td>Power Dimensioning</td>
<td>Power Dimensioning is a very useful tool for generating linear, radial and diameter dimensions, which minimizes the number of the individual actions required while generating a dimension. Power Dimensioning selects the type of linear dimension (horizontal, vertical, or aligned), based on the selected point, and the dimensions of the drawing can have a uniform style using the distance snap.</td>
</tr>
</tbody>
</table>
Extending Designs

First, you start a new drawing template with ISO standard. Then you load the initial drawing using the Library.

To open a template

1. Open a new drawing.
   - Toolbutton
   - Menu File ➤ New
   - Command NEW
   - The Select template dialog box opens.

2. In the Select template dialog box, select the template am_iso.dwt.
   - This opens a new drawing template. Now you insert the drawing from the library.

Using Libraries to Insert Parts

Insert the required part from the library.

To insert a drawing from the library

1. Start the Library.
   - Toolbutton
   - Menu Insert ➤ Library
   - Command AMLIBRARY

2. Double-click the tut_lever.dwg file in the Library.
3 Respond to the prompt as follows:
   Specify insertion point: Specify any point in the drawing

4 Start the Zoom Window command, responding to the prompt.
   Toolbutton

   Menu         View ➤ Zoom ➤ Window
   Command      ZOOM

   Specify first corner: Specify first corner (1)
   Specify opposite corner: Specify opposite corner (2)
Before starting the design, define the object snaps that you will use in later operations.

**Configuring Snap Settings**

In addition to the AutoCAD® snap, mechanical snap options like arc radial, arc tangent, and so forth are available. You also have four different snap settings, which can be configured separately for a quick switch to a different snap setting. For example, you can use different snap settings for detailing or general design.

**NOTE** The snap defaults can be set in the Options dialog box on the AM:Preferences tab.

**To configure Power Snap settings**

1. Start the Power Snap settings.
   Toolbutton
In the Power Snap Settings dialog box, specify:

Settings 1: Endpoint, Intersection
Settings 2: Endpoint, Center, Quadrant, Intersection, Parallel
Settings 3: Perpendicular

After configuring the settings, activate Setting 1, and then choose OK.
Save your file.

**NOTE** Within a command, the various object snap functions are also accessible. Hold down the SHIFT key, and right-click.

**Creating Construction Lines (C-Lines)**

Construction lines are very useful when you start your design process. With their help, you draw a design grid with your defined values for distance and angles. After generating the design grid, you simply trace your contour with the contour layer.

Now insert the construction lines, which will help you draw the contour lines.
To create construction lines

1. Start the Draw Construction Lines command.
   ▶ Toolbutton
   ▶ Menu: Design ➤ Construction Lines ➤ Draw Construction Lines
   ▶ Command: AMCONSTCRS
   
   If you have started the command using the menu, the Construction Lines dialog box opens. If you started the command directly using the toolbar or the command line, you can skip step 2.

2. In the Construction Lines dialog box, choose the Cross icon shown above.

3. Respond to the prompts as follows:
   Specify insertion point: Specify the intersection of line b and line c (1)
   Specify insertion point: Press ENTER

4. Next, draw two lines parallel to the vertical and horizontal lines of the construction line cross.

5. Start the Draw Construction Lines command.
   ▶ Toolbutton
   ▶ Menu: Design ➤ Construction Lines ➤ Draw Construction Lines
   ▶ Command: AMCONSTPAR
   
   If you started the command using the menu, the Construction Lines dialog box is displayed.

Creating Construction Lines (C-Lines) | 133
6 In the Construction Lines dialog box, choose the Parallel with Full Distance icon.

7 Respond to the prompts as follows:
   Select line, ray or xline: Select line c (1)
   Specify insertion point or Distance (xx|xx|xx..) <10|20|30>: Enter 3|9, press ENTER
   Specify point on side to offset: Specify a point to the left of line c (2)

8 Insert the second set of parallel lines, and respond to the prompts as follows:
   Select line, ray or xline: Select line b
   Specify insertion point or Distance (xx|xx|xx..) <3|9>: Enter 4.5|9.5, press ENTER
   Specify point on side to offset: Specify a point below line b (2)

9 Press ENTER.
Creating additional C-Lines

AutoCAD Mechanical offers a choice of C-line options.

To create additional construction lines

1 Activate snap setting 2.

   Toolbutton

   Menu  Assist ➤ Drafting Settings ➤ Power Snap Configuration 2

   Command  AMPSNAP2

2 Start the Draw Construction Lines command.

   Toolbutton

   Menu  Design ➤ Construction Lines ➤ Draw Construction Lines

   Command  AMCONSTHB

   If you started the command using the menu, the Construction Lines dialog box is displayed.

3 In the Construction Lines dialog box, choose the Two Points or Angle icon.

Save your file.
4. Respond to the prompts as follows:
   
   Specify first point: **Select the first point (1)**
   
   Specify second point or Angle (xx|xx|xx..) <30|45|60>:
   
   *Move the cursor over line a and back to the rectangle until the Parallel symbol appears, click (2)*

5. Press ENTER to finish the command.

   Now, you draw tangential circles between the diagonal C-line and the right vertical line and lower horizontal line of the rectangle.

   
   **Toolbutton**
   
   **Menu** Design ➤ Construction Lines ➤ Draw Construction Lines
   
   **Command** AMCONSTKR

---

136 | Chapter 7  Designing Levers
If you started the command using the menu, the Construction Lines dialog box is displayed.

7 In the Construction Lines dialog box, choose the Circle Tangent to 2 Lines icon.

![Construction Lines dialog box with icons]

8 Draw the two circles by responding to the prompts as follows:
   - Select first tangent: Select tangent point (1)
   - Select second tangent: Select tangent point (2)
   - Specify diameter: Enter 2, press ENTER
   - Select first tangent: Select tangent point (3)
   - Select second tangent: Select tangent point (4)
   - Specify diameter <2>: Enter 2, press ENTER

9 Press ENTER to end the command.

All construction lines have been inserted, and the contour can be generated.
Save your file.

Creating Contours and Applying Fillets

Now, you connect the two tangential circles with the right part of the rectangle, to build a filleted triangle.

To create and edit a contour

1. Start the Polyline command.  
   Toolbutton ➤ Design ➤ Polyline  

   Menu Command  
   Design ➤ Polyline  

2. Create the contour by responding to the prompts as follows:
   
   Specify start point: Specify the intersection point (1)

   Specify next point or [Arc/Halfwidth/Length/Undo/Width]:
   Specify next point (2)

   Specify next point or [Arc/CLOSE/Halfwidth/Length/Undo/Width]:
   Enter A, press ENTER

   Specify endpoint of arc or
   [Angle/CLOSE/Direction/Halfwidth/Line/RADIUS/Second pt/Undo/Width]: Specify next point (3)

   Specify endpoint of arc or
   [Angle/CLOSE/Direction/Halfwidth/Line/RADIUS/Second pt/Undo/Width]: Enter L, press ENTER

   Specify next point or [Arc/CLOSE/Halfwidth/Length/Undo/Width]:
   Specify next point (4)

   Specify next point or [Arc/CLOSE/Halfwidth/Length/Undo/Width]:
   Enter A, press ENTER

   Specify endpoint of arc or
   [Angle/CLOSE/Direction/Halfwidth/Line/RADIUS/Second pt/Undo/Width]: Specify next point (5)
Specify endpoint of arc or [Angle/CEnter/Close/Direction/Halfwidth/Line/Radius/Second pt/Undo/Width]: \textit{Enter Cl, press ENTER}.

Now, erase the C-Lines. You can erase all C-lines by calling one command.

3. Erase all C-Lines.
   \textbf{Toolbutton} \hspace{5em} \textbf{Menu} \hspace{5em} \textbf{Command}
   \begin{itemize}
   \item Modify ➤ Erase ➤ Erase all Construction Lines
   \item AMERASEALLCL
   \end{itemize}

\textbf{NOTE} You can switch construction lines on and off temporarily by choosing Assist ➤ Layer/Layergroup ➤ Construction Line On/Off.

4. Apply a fillet to the corner of the triangle.
   \textbf{Toolbutton} \hspace{5em} \textbf{Menu} \hspace{5em} \textbf{Command}
   \begin{itemize}
   \item Modify ➤ Fillet
   \item AMFILLET2D
   \end{itemize}

5. Respond to the prompts as follows:
   (Dimension mode:OFF) (Trim mode) Current fillet radius = 2.5
   Select first object or [Polyline/Setup/Dimension] <Setup>:
   \textit{Press ENTER}

6. In the Fillet Radius dialog box, specify:
   Input: \texttt{1}
   Trim Mode: On
Choose OK.

7 Respond to the prompts as follows:

(Dimension mode:OFF) (Trim mode) Current fillet radius = 1
Select first object or [Polyline/Setup/Dimension] <Setup>:

Enter P , press ENTER
Select polyline: Select a point on the polyline near the corner

8 Press ESC to cancel the command.
The triangular contour is complete.
Save your file.

**Trimming Projecting Edges on Contours**

Now, you create another part of the contour and trim projecting edges.

**To edit a contour**

1 Activate Power Snap Setting 3 command.
Next, insert the next contour.

2 Start the Line command.

3 Respond to the prompts as follows:
   - Specify first point: *Hold down SHIFT as you right-click, choose Intersection int of: Select line a (1) and: Select intersection on line b (2)*
   - Specify next point or [Undo]: *Hold down SHIFT as you right-click, choose Perpendicular, trace over line e, click the perpendicular point (3)*
   - Specify next point or [Undo]: *Drag the cursor to the right, crossing over line c, and select intersection point (4)*
   - Specify next point or [Close/Undo]: *Press ENTER*

Now, trim the projecting edges at the upper edge of the lever.

4 Start the Trim command.
5 Respond to the prompts as follows:

Current settings: Projection = UCS, Edge = None

Select cutting edges:
Select Objects: Select cutting edge (1)
Select Objects: Select cutting edge (2)
Select Objects: Press ENTER
Select object to trim or shift-select to extend or [Project/Edge/Undo]: Select object to trim (3)
Select object to trim or shift-select to extend or [Project/Edge/Undo]: Select object to trim (4)
Select object to trim or shift-select to extend or [Project/Edge/Undo]: Press ENTER

6 Zoom to the extents of the lever.
The contour is complete and looks like this. Save your file.
Applying Hatch Patterns to Contours

There are a number of predefined hatch patterns available in AutoCAD Mechanical. Choose one of the predefined hatching styles, and then specify a point within a contour to apply the hatching.

To apply hatching to a contour

1. Start the Hatch command, using an angle of 45 degrees and 2.5 mm / 0.1 inch spacing.
   Toolbutton
   Menu Design ➤ Hatch ➤ Hatch 45 deg. 2.5mm/0.1 inch
   Command AMHATCH_45_2

2. Respond to the prompt as follows:
   Select additional boundary or point in area to be hatched or [Select objects]: Click a point inside the contour (outside the cutouts)
   The lever is hatched. It looks like this:
Dimensioning Contours

Now, dimension the lever, using the Power Dimensioning command.

To dimension a contour

1. Start the Power Snap Setting 1 command.
   Toolbutton
   Menu Assist ➤ Drafting Settings ➤ Power Snap Configuration 1
   Command AMPSNAP1

2. Start the Power Dimensioning command.
   Toolbutton
   Menu Annotate ➤ Power Dimensioning
   Command AMPOWERDIM
3 Respond to the prompts as follows:

(SINGLE) Specify first extension line origin or [Angular/Options/Baseline/Chain/Update] <Select>:

Select the first corner point of the lever opening (1)

Specify second extension line origin:

Select the second corner point (2)

Specify dimension line location or [Options/Pickobj]:

Drag the dimension line to the left until it is highlighted in red, click (3)

4 In the Power Dimensioning dialog box, click the Add Tolerance icon and specify:

Deviation: Upper: 0.1
Deviation: Lower: 0
Precision: Primary: 1

Choose OK.

5 Press ENTER twice to finish the command.
The lever looks like this:
Creating and Dimensioning Detail Views

Now, define a detail of the upper part of the lever.

To create a detail

1. Start the Detail command.

   Toolbutton
   Design ➤ Detail

   Command AMDETAIL

2. Respond to the prompts as follows:
   Center of circle or [Rectangle/Object]:
   Click a point in the center of the area to be detailed (1)
   Specify radius or [Diameter]:
   Drag the radius to the appropriate size, click (2)

Save your file.
3 In the Detail dialog box, specify:

Detail View: Detail in Current Space

![Detail ISD dialog box](image)

4 Choose OK, and respond to the prompts as follows:

Place the detail view: Select a location to the right of the lever

**NOTE** Some entities such as dimensions and symbols are automatically filtered out in the detail function.
5 Start the Power Dimensioning command.

Toolbutton

Menu Annotate ➤ Power Dimensioning
Command AMPOWERDIM

6 Respond to the prompts as follows:

(SINGLE) Specify first extension line origin
or[Angular/Options/Baseline/Chain/Update] <Select>: Press ENTER

Select arc, line, circle or dimension: Select the radius (1)
7 Select an appropriate position for the dimension.

8 In the Power Dimensioning dialog box, click the tolerances button to deactivate the tolerances.

Choose OK.

9 Press ENTER twice to finish the command.

Now, your lever looks like this:
The Power Dimensioning command recognizes the different scale area. If you dimensioned the radius in the original drawing, the dimension value would be the same. The text height is also the same, as related to the standard.

This is the end of this tutorial chapter.

Save your file.
Working with Model Space and Layouts

In this tutorial, you work with layouts in AutoCAD® Mechanical, to create scale areas, viewports, and detail views in model space. You learn how to freeze objects in viewports without affecting the model and other layouts.
### Key Terms

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>base layer</td>
<td>A layer made up of working layers and standard parts layers. Base layers are repeated in every layer group.</td>
</tr>
<tr>
<td>detail</td>
<td>Enlargement of a portion of the design drawing that cannot be clearly displayed or dimensioned. The overall representation (surface texture symbols, etc.) can be enlarged.</td>
</tr>
<tr>
<td>drawing</td>
<td>A layout of drawing views in model space or layout.</td>
</tr>
<tr>
<td>layer group</td>
<td>A group of associated or related items in a drawing. A major advantage of working with layer groups is that you can deactivate a specific layer group and a complete component. The drawing and its overview are enhanced by reduction in regeneration time.</td>
</tr>
<tr>
<td>layout</td>
<td>The tabbed environment in which you create and design floating viewports to be plotted. Multiple layouts can be created for each drawing.</td>
</tr>
<tr>
<td>Power Dimensioning</td>
<td>A command useful for generating linear, radial, and diameter dimensions, which minimizes the number of the individual actions while generating a dimension. Power Dimensioning automatically selects the type of the linear dimension (horizontal, vertical, aligned), based on the selected point.</td>
</tr>
<tr>
<td>scale area</td>
<td>Defines the scale for an area of the drawing.</td>
</tr>
<tr>
<td>scale monitor</td>
<td>A function to view and control the scale for any scale area.</td>
</tr>
<tr>
<td>viewport</td>
<td>A scaled view of the model defined in a layout.</td>
</tr>
<tr>
<td>view scale</td>
<td>The scale of a base drawing relative to the model scale. Also, the scale of dependent views relative to the base view.</td>
</tr>
<tr>
<td>working layer</td>
<td>The layer where you are currently working.</td>
</tr>
</tbody>
</table>
Working with Model Space and Layouts

Using model space and layouts, you can create different views with different scales from the same model. The main advantage of working with layouts is that views are associative. If you make changes in one viewport, those changes are made in all other viewports as well, since each viewport is another view of the same model. You can also freeze objects in a new viewport without affecting objects in other views.

Getting Started

In this tutorial, you work with viewports. You generate an associative detail and create a subassembly drawing.

To open a file

- Open the file tut_engine.dwg in the acadm\tutorial folder.

Creating Scale Areas

To generate correct views with correct zoom factors in a layout, you must define a scale area in model space.

Create the scale area.

To create a scale area

1. Start the Viewport/Scale Area command.
Command: AMSCAREA

2. Respond to the prompts as follows:
   - Define the border...
   - Specify first point or [Circle/Object]: Specify the first corner point (1)
   - Specify second point: Specify the second corner point (2)

3. In the Scale Area dialog box, specify:
   - Scale: 1:1
Choose OK.
Since you now have a defined scale area, you can automatically create a viewport.

To create a viewport automatically

1. Start the Viewport Auto Create command.

   **Toolbutton**
   
   ![View ➤ Viewports ➤ Viewport Auto Create](image)

   **Menu**
   View ➤ Viewports ➤ Viewport Auto Create

   **Command**
   AMVPORTAUTO

2. Respond to the prompts as follows:

   Enter layout name (<Return> for “Layout1”): *Press ENTER*

   Select target position (<Return> for current position):

   *Place the viewport on the left, inside the drawing border*
Creating Detail Views

There are two types of detail views; associative and non associative. In this exercise, you create an associative detail, because you use a viewport.

Create an associative detail of the valve.

To create a detail

1. Start the Detail command.
   Toolbutton
   Menu Design ➤ Detail
   Command AMDETAIL
   The viewport is activated automatically.

2. Respond to the prompts as follows:
   Define the enlargement area for the detail ...
   Center of circle or [Rectangle/Object]:
   Select the center of the detail (3)
Specify radius or [Diameter]: *Drag the radius to the desired size (4)*

3 In the Detail dialog box, specify the settings shown in the illustration.

![Detail dialog box](image)

Choose OK.

4 Respond to the prompt as follows:

Select target position 〈Return> for current position): 

*Place the detail to the right of the current viewport*
Generating New Viewports

Now, you create a viewport inside a layout.

To create a viewport in the layout

1. Start the Viewport/Scale Area command. 
   Toolbutton 
   Menu View ➤ Viewports ➤ Viewport/Scale Area 
   Command AMVPORT

2. Respond to the prompts as follows: 
   Specify first point or [Circle/Border/Object]: 
   Select point 5 in the drawing 
   Specify second point: Select point 6 in the drawing

3. In the View dialog box, specify:

Save your file.

158 | Chapter 8  Working with Model Space and Layouts
Scale: 5:1

Choose Midpoint.

The drawing is changed to model space so that you can define the midpoint.

4  Respond to the prompt:

Select view center: *Select the endpoint of the centerline*

5  In the View dialog box, choose OK.

Your drawing looks like this:
Inserting Holes Within Viewports

To demonstrate the main advantage of working with layouts, insert a hole in the housing. When you make this change, it is immediately displayed in every view.

Insert a user through hole in the previously created viewport.

To insert a through hole

1. Activate the previously created viewport.  
   Toolbutton

2. Start the Through Hole command.
Toolbutton ➤ Holes ➤ Through Holes

Menu ➤ Content ➤ Holes ➤ Through Holes
Command AMTHOLE2D

In the Select a Through Hole dialog box, scroll to and select User Through Holes, and then click Front View.

4 Respond to the prompts as follows:

Specify insertion point:

*Hold down the SHIFT key and right-click, and then choose Midpoint*

Specify insertion point: _mid of Select the midpoint of the housing (1)

Specify hole length: Select the endpoint of the hole (2)
6. In the User Through Holes - Nominal Diameter dialog box, specify:
   Nominal Diameter: 8

Choose Finish.

The user through hole is inserted into your drawing.

The drawing looks like this:
Because of the associativity, the through hole created in the viewport also appears in the original view.

In the next step, you dimension the through hole diameter in the viewport. Since the dimension is to appear only in the detail view, you generate the dimension directly in the layout without having a viewport active.

To apply a dimension in the layout

1. Change to the layout.
   Toolbutton
   Command
   PSPACE

2. Start the Power Dimensioning command
   Toolbutton
   Menu Annotate ➤ Power Dimensioning
   Command AMPOWERDIM

3. Respond to the prompts as follows:
   (SINGLE) Specify first extension line origin for
   [Angular/Options/Baseline/Chain/Update] <Select>:
   Select the first edge of the hole (1)
   Specify second extension line origin:
   Select the second edge of the hole (2)
Specify dimension line location [Options/Pickobj]:

Drag the dimension line toward point 3 until it turns red, and then click

4 In the Power Dimensioning dialog box, choose OK.

5 Continue to respond to the prompts as follows:
   (SINGLE) Specify first extension line origin or [Angular/Options/Baseline/Chain/Update] <Select>: Press ENTER
   Select arc, line, circle or dimension: Press ENTER
   The viewport looks like this:
NOTE You can also dimension the hole in model space and turn off the layer of one specific viewport. In that case, the dimension text is correct only in the 1:1 viewport, and not in the detail view. Therefore, you can dimension directly on the layout.

Save your file.

Creating Subassemblies in New Layouts

If you use layer groups in your assembly drawing, you can create detail and subassembly drawings in layouts. You can switch off selected layer groups in a viewport so that only the detail or subassembly is visible.

Before you create a subassembly in a new layout, freeze the model and other views. Then when you create a new viewport in Layout 2, only the specified subassembly is displayed, and objects are not hidden in the model and other views.

To freeze the model and other layouts

1 Select the Layout 2 tab on the bottom of your drawing area. Layout 2 is displayed.

2 Start the Layer Group Control.
   Toolbutton
   Menu Assist ➤ Layer/Layergroup ➤ Layer/Layer Group Control
AMLAYER

Command AMLAYER

3 In the Layer Control dialog box, Layer Group Control tab, click the icon in the Base Layer Group row, Freeze/Thaw in new viewports column to freeze it.

Choose OK.

Create an associative view of a subassembly in layout 2.

To create an associative view of a subassembly

1 Select the Layout 2 tab on the bottom of your drawing area. Layout 2 is displayed.

2 Start the Viewport/Scale Area command.
   Toolbutton
   Menu View ➤ Viewports ➤ Viewport/Scale Area
   Command AMVPORT

3 Respond to the prompts as follows:
Specify first point or [Circle/Border/Object]:
Select point 7 in the drawing
Specify second point: Select point 8 in the drawing

4 In the View dialog box, specify:
Scale: 5:1
Choose Midpoint.

The drawing is changed to model space.

5 Specify the point, as shown in the following drawing:

6 In the View dialog box, choose OK.
In the new viewport, only the subassembly you specified is visible. AutoCAD Mechanical freezes the Base Layer Group.

Your drawing looks like this:

![Drawing Image]

Finish your detail drawing with text, remarks, annotations, and so on.

**NOTE** When you plot the drawing, the red viewport frame is turned off automatically. If you have a plotter or printer driver installed, use the plot command, and preview the drawing.

This is the end of this tutorial chapter.

Save your file.
Dimensioning

In this tutorial, you learn how to add dimensions to your drawing with the automatic dimensioning in AutoCAD® Mechanical, change the dimensions with Power Commands, and insert a drawing border.
### Key Terms

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>baseline dimension</td>
<td>A dimension that is aligned to extension lines and read from the bottom or right side of the drawing.</td>
</tr>
<tr>
<td>centerline</td>
<td>Line in the center of a symmetrical object.</td>
</tr>
<tr>
<td>drawing border</td>
<td>A standardized frame that is used for technical drawings.</td>
</tr>
<tr>
<td>fit</td>
<td>Range of tightness or looseness in mating parts (for example shafts or holes). Tolerances in these dimensions are expressed in standard form.</td>
</tr>
<tr>
<td>fit name</td>
<td>Name of the selected fit (for example, H7).</td>
</tr>
<tr>
<td>multi edit</td>
<td>An option where you determine a selection set of dimensions and edit them together.</td>
</tr>
<tr>
<td>Power Dimensioning</td>
<td>Power Dimensioning is a tool for generating linear, radial, angular, and diameter dimensions, which minimizes the number of the individual actions required while generating a dimension. Power Dimensioning selects the type of linear dimension (horizontal, vertical, or aligned), based on the selected point, and the dimensions of the drawing can have a uniform style using the distance snap.</td>
</tr>
<tr>
<td>Power Erase</td>
<td>Command for deleting. Use Power Erase when you delete part reference numbers or dimensions that were created with Power Dimensioning and Automatic Dimensioning.</td>
</tr>
<tr>
<td>title block</td>
<td>A title block contains a series of attributes. Some already have values. The pre-assigned values can be modified, and the vacant attributes can be completed with new values.</td>
</tr>
<tr>
<td>tolerance</td>
<td>The total amount by which a given dimension (nominal size) may vary (for example, 20 ± 0.1).</td>
</tr>
</tbody>
</table>
Adding Dimensions to Drawings

AutoCAD Mechanical offers various dimensioning tools. Use automatic dimensioning to add dimensions to a bushing, and then change these dimensions.

To open a file

- Open the file *tut_bushing.dwg* in the *acadm\tutorial* folder.

The file contains a drawing of a bushing.

Save your file under a different name or to a different directory to preserve the original tutorial file.

Adding Automatic Dimensions

Dimension the bushing using automatic dimensioning.

To dimension a contour automatically

1. Start Automatic Dimensioning.

The command is `AMAUTODIM`.

Command

<table>
<thead>
<tr>
<th>Menu</th>
<th>File ➤ Open</th>
</tr>
</thead>
<tbody>
<tr>
<td>Command</td>
<td>OPEN</td>
</tr>
</tbody>
</table>

The file contains a drawing of a bushing.
In the Automatic Dimensioning dialog box, Parallel tab, specify:
Type: Baseline

Choose OK.

Respond to the prompts as follows:
Select objects [Block]:
Select the complete bushing by creating a window around it
Select objects [Block]: Press ENTER
First extension line origin:
Select the lower leftmost corner of the bushing (1)
Specify dimension line location or [Options/Pickobj]:
Drag the dimensioning downwards until it snaps in (highlighted red), and then click
Generate the diameter dimensions using shaft dimensioning.

To dimension a shaft

1  Start Automatic Dimensioning.
   Toolbutton
   Menu  Annotate ➤ Automatic Dimension
   Command  AMAUTODIM

2  In the Automatic Dimensioning dialog box, Shaft/Symmetric tab, specify:
   Type: Shaft (Front View)
   Choose OK.
3 Respond to the prompts as follows:
Select objects [Block]:
Select the complete bushing by creating a window around it
Select objects [Block]: Press ENTER
Select Centerline or new starting point:
Select the centerline of the bushing (1)
Specify dimension line location or [Options/Pickobj]:
Drag the dimensioning to the right until it snaps in (highlighted red), and then click

4 Continue responding to the prompt:
Starting point for next extension line:
Press ENTER to end the command

Your drawing looks like this.

Save your file.

**Editing Dimensions with Power Commands**

Some dimensions in the drawing are not necessary. In the next step, you delete the dimensions that you don’t need.

**To delete dimensions**

1. Start Power Erase.
   
   **Toolbutton**
   
   Modify ➤ Power Commands ➤ Power Erase
   
   **Command**
   
   AMPOWERERASE

2. Respond to the prompt as follows:

   **Select objects:**
   
   *Select baseline dimensions 2 and 61, and diameter dimensions 12, 14, and 36, press ENTER*

   The dimensions are deleted, and the remaining dimensions are rearranged. Your drawing looks like this:
Add a single dimension with a fit using Power Dimensioning.

To add a dimension with a fit

   
   **Toolbutton**
   
   **Menu**  Annotate ➤ Power Dimensioning
   
   **Command**  AMPOWERDIM

2. Respond to the prompts as follows:

   (Single) Specify first extension line origin or
   [Angular/Options/Baseline/Chain/Update] <Select>:

   *Select the first point (1)*

   Specify second extension line origin: *Select second point (2)*

   Specify dimension line location or [Options/Pickobj]:

   *Drag the dimensioning to the left until it is highlighted red, and then click*
In the Power Dimensioning dialog box, choose the Add Fit button, and then specify:

- Fit: Symbol: H7

Click the Special Characters button, and then select the diameter symbol (upper left).

Choose OK.

Apply angular dimensioning.

**To apply an angular dimension**

1. Respond to the prompts as follows:
   
   (Single) Specify first extension line origin or
   [Angular/Options/Baseline/Chain/Update] <Select>:

   Enter A, press ENTER
(Single) Select arc, circle, line or [Linear/Options/Baseline/Chain/Update] <specify vertex>:

Select the line (1)
Select second line: Select the second line (2)
Specify dimension arc line location:

Drag the dimension to a suitable position, and then click

2 Press ENTER twice to finish the command.
   Add a fit to the shaft dimensions using Multi Edit.

To add a fit using Multi Edit

1 Start Multi Edit.
   Toolbutton
   Menu Annotate ➤ Edit Dimensions ➤ Multi Edit
   Command AMDIMEDIT

2 Respond to the prompts as follows:
   Select dimensions: Select the dimensions 18 and 30
   Select dimensions: Press ENTER

3 In the Power Dimensioning dialog box, choose the Add Fit button, and then specify:
   Fit: Symbol: h7
Choose OK.
The fit description h7 is added to the dimensions.
Save your file.

**Breaking Dimension Lines**

The automatic dimensioning process created intersecting dimension lines. The drawing appearance can be improved by breaking these lines.

**To break dimension lines**

1. Start the Break Dimension command.
   
   **Toolbutton**

   ![Toolbutton](image)

   **Menu**
   Annotate ➤ Edit Dimensions ➤ Break Dimension

   **Command**
   AMDIMBREAK

2. Respond to the prompt as follows:
   
   Select dimension or extension line to break <Multiple>:
   
   **Press ENTER**
   
   Select dimensions:
   
   *Select baseline dimension 10 and 13, and diameter dimensions 18, 30, and 40, press ENTER*
   
   Select Objects [Restore] <Automatic>: **Press ENTER**
The selected dimensions are broken automatically and your drawing looks like this:

![Drawing with dimensions]

Save your file.

**Inserting Drawing Borders**

Insert a drawing border.

**To insert a drawing border**

1. Start the Drawing Title/Borders command.
   - **Toolbutton**: Annotate ➤ Drawing Title/Revisions ➤ Drawing Title/Borders
   - **Menu**: AMTITLE

2. In the Drawing Borders with Title Block dialog box, specify:
   - **Paper Format**: A4 (297x210mm)
   - **Title Block**: ISO Title Block A
   - **Scale**: 1:1
Choose OK.

3 Respond to the prompt as follows:
   Specify insertion point: Enter -150,0, press ENTER

4 In the Edit Attributes dialog box, specify:
   Drawing Title: *Bushing*

Choose OK.

5 Respond to the prompts as follows:
Select Objects: Select the complete bushing including dimensions
Select Objects: Press ENTER
New location for objects: Click Zoom Extents
New location for objects:
Place the bushing in the middle of the drawing border
Your drawing looks like this:

Save your file.

**Inserting Fits Lists**

Insert a fits list. Fits lists describe all fits existing in a drawing.

To insert a fits list

1. Start the Fits List command.
Toolbutton

Menu

Command

AMFITSLIST

2 Respond to the prompts as follows:

Fits lists [Update all/Order/New] <New>: Press ENTER

Specify insertion point: Specify the upper right corner of the title block

The fits list is inserted above the title block, and looks like this.

Edit a dimension with a fit. The fits list is updated.

To edit a dimension

1 In the drawing, double-click the diameter dimension (not the dimension line) 18 h7.

2 In the Power Dimensioning dialog box, specify:

Fit symbol: g6
Choose OK.

3 In the AutoCAD Question dialog box, choose Yes.

The fits list is updated, too. Save your file.

This is the end of this tutorial chapter.
In this tutorial, you learn about the features in AutoCAD® Mechanical for defining 2D hide situations, and how to work with 2D steel shapes.
Key Terms

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>background</td>
<td>A contour that is covered by another contour or by objects that are lying behind another contour, in the 3D sense. A background may be a foreground for an additional contour.</td>
</tr>
<tr>
<td>foreground</td>
<td>Objects which are lying in front of another contour, in the 3D sense. A foreground may also be a background for an additional contour.</td>
</tr>
<tr>
<td>hidden line</td>
<td>Line that is not visible in a specified view. For example, in a front view, lines behind the front plane are not visible.</td>
</tr>
<tr>
<td>steel shapes</td>
<td>Steel shapes are standardized steel geometries and profiles that are used for steel and plant construction.</td>
</tr>
</tbody>
</table>

Working with 2D Hide and 2D Steel Shapes

Use the AM2DHIDE command when mechanical structure is not enabled. Use AMSHIDE when mechanical structure is enabled. For this exercise you work with AM2DHIDE.

Before you begin this tutorial...

This tutorial requires the mechanical browser. If the mechanical browser is not visible:

1. Enter `AMBROWSER` in the command prompt and press ENTER.
2. When prompted, enter `ON` and press ENTER.

Opening the initial drawing

To open a drawing

1. Open the file `tut_steelshape.dwg` in the `acadm\tutorial` folder.
Toolbutton

Menu File ➤ Open
Command OPEN

2 Zoom in to the chain drive on the right.
Toolbutton

Menu View ➤ Zoom ➤ Window
Command ZOOM

Defining 2D Hide Situations

Define a 2D hide situation. You can define foreground and background contours and the settings for the representation of the hidden objects.

To define a 2D hide situation

1 Start the Hide Invisible Edges command.
Menu Modify ➤ 2D Hide ➤ Hide Invisible Edges
Command AM2DHIDE

2 Respond to the prompts as follows:
   Select objects for foreground: Select the chain
   Select objects for foreground: Press ENTER

3 In the Create Hide Situation dialog box, Background tab, specify:
   Representation of Hidden Objects: Dashed
   Choose Preview.

   ![Create Hide Situation dialog box]

   **NOTE** As you can see, the parts of the sprockets that should be visible appear as hidden lines. This shows that the complete area inside the outer chain contour is defined as foreground.

   Define the 2D hide situation in a way that the chain has an inner contour.

4 Respond to the prompt as follows:
   Accept preview and exit command [Yes/No] <Yes>: Enter N, press ENTER

5 In the Create Hide Situation dialog box, Foreground tab, choose Select Inner Contours.
6  Respond to the prompt as follows:
   Select point inside a hole or select a loop to remove:
   Select a point inside the chain (1)
   The inner contour of the chain is displayed green.

7  Respond to the prompt as follows:
   Select point inside a hole or select a loop to remove: Press ESC

8  In the Create Hide Situation dialog, choose Preview.
   The sprocket is no longer displayed as a hidden line and the chain drive
   is displayed correctly.
Respond to the prompt as follows:

Accept preview and exit command [Yes/No] <Yes>: Press ENTER

The 2D hide situation is defined correctly, and you can proceed with your drawing.

Save your file under a different name or to a different directory to preserve the original tutorial file.

**Inserting 2D Steel Shapes**

Steel Shapes can easily be inserted through a selection dialog box, where you can define the standard, profile, size, and length of the steel shape.

Insert a steel shape with a square hollow section on the left edge of the I-shaped girder.

**To insert a 2D steel shape**

1. Start the Zoom All command.

   **Toolbutton**

   **Menu**       **View ➤ Zoom ➤ All**

   **Command**    **ZOOM**
2 Start the Steel Shape command.
   Toolbutton ➤ Steel Shapes

3 In the Select a Steel Shape dialog box, select Steel Shapes ➤ Square/Rectangular Hollow Section, and then select ISO 657/14-1982 (Rectangular) and Top View.

4 Respond to the prompts as follows:
   Specify insertion point: Select point P1
   Specify rotation angle <0>: Press ENTER

5 In the ISO 657/14 - 1982 (Rectangular) - Size Selection dialog box, specify:
   Select a Size: 90x90x4.0
Choose Finish.

6 Respond to the prompt as follows:

Drag Size: Select point P2

The steel shape is inserted. Your drawing looks like this:

Save the file.
Modify the steel shapes using the Power Commands.
Modifying Steel Shapes Using Power Commands

With the Power Commands, you can create different views of the steel shapes. You can copy, multiply, or edit the steel shapes.

Insert the steel shapes in the top view of the assembly using Power View and Power Copy.

To modify a steel shape using a Power Command

1. Start the Power View command.
   Toolbutton
   Menu Modify ➤ Power Commands ➤ Power View
   Command AMPOWERVIEW

2. Select the previously inserted steel shape.

3. In the Select new view dialog box, select the Front View.

4. Respond to the prompts as follows:
   Specify insertion point: Select point P3
   Specify rotation angle <0>: 0, press ENTER

   The steel shape is inserted in the top view of the assembly. Your drawing looks like this:

   ![Diagram of inserted steel shape]

   Copy the previously inserted view to the other edge of the girder.

5. Start the Power Copy command.
   Toolbutton
   Menu Modify ➤ Power Commands ➤ Power Copy
Command AMPOWERCOPY

6 Respond to the prompts as follows:
   Select object: Select the previously inserted steel shape at point P3
   Enter an option [Next/Accept]<Accept>: Press ENTER
   Specify insertion point: Select point P4
   Specify rotation angle <0>: Press ENTER
   The steel shape is copied. Your drawing looks like this:

   ![Drawing of copied steel shape]

   Save your file.

Editing 2D Hide Situations

The insertion of the steel shapes in the top view of the assembly created a 2D hide situation automatically. This 2D hide situation is not correct. Use the command AM2DHIDEDIT when mechanical structure is disabled.

Edit the 2D hide situation.

To edit a 2D hide situation

1 Start the Edit Hidden Edges command.
   Menu Modify ➤ 2D Hide ➤ Edit Hidden Edges
   Command AM2DHIDEDIT

2 Respond to the prompts as follows:
   Edit the behind situation [modify/Move/Restore/Genius12] <Update>: Enter Y, press ENTER
   Select objects: Select the square hollow section on the left
   Select objects: Press ENTER

3 In the Modify Hide Situation dialog box, Foreground tab, choose Select View.
4 Respond to the prompts as follows:
Select objects for foreground: Select the I-shaped girder
Select objects for foreground:
Press SHIFT while you click the square hollow section on the left to deselect it
Select objects for foreground: Press ENTER

5 In the Modify Hide Situation dialog box, Background tab, choose Select View.
6 Respond to the prompts as follows:
   Select objects for background:
   Select the square hollow section on the left
   Select objects for background:
   Select the square hollow section on the right
   Select objects for background: Press ENTER

7 In the Modify Hide Situation dialog box, click Preview.
   Your drawing looks like this:

   ![Image of the drawing]

   Press ENTER

8 Respond to the prompts:
   Accept preview and exit command [Yes/No] <Yes>: Press ENTER
   Edit the behind situation [modifY/Move/Restore/Genius12] <Update>: Press ENTER
   Select objects: Press ENTER
   The 2D hide situation is corrected.
   Save your file.

**Copying and Moving 2D Hide Situations**

If you copy or move assemblies that contain 2D hide situations, the 2D hide information is not lost.

Copy the girder assembly.

**To copy a 2D hide situation**

1 Select the I-shaped girder and the two square hollow sections.

2 Right-click the graphics area background, and then choose Copy with Base Point.
   Respond to the prompt as follows:
   Specify base point: Select point P3
3 Right-click, and then choose Paste. Respond to the prompt as follows:

Specify insertion point: Select point P5

The girder assembly is copied to the new location. Your drawing looks like this.

Save your file.

Move the chain drive from the beginning of the chapter to the top view of the assembly.

To move a 2D hide situation

1 Start the Move command.

   Toolbutton

   Menu Modify ➤ Move

   Command MOVE

2 Respond to the prompts as follows:

   Select objects: Select the complete chain drive using a window

   Select objects: Press ENTER

   Specify base point or displacement: Select point P6

   Specify second point of displacement or <use first point as displacement>: Select point P7
The complete chain drive is moved to the top view of the assembly. Your drawing looks like this:

Define the 2D hide situation for the girder assembly and the chain drive.

**To define a 2D hide situation**

1. Start the Hide Invisible Edges command.
   - **Menu**: Modify ➤ 2D Hide ➤ Hide Invisible Edges
   - **Command**: AM2DHIDE

2. Respond to the prompts as follows:
   - Select objects for foreground: *Select the complete chain drive*
   - Select objects for foreground: Press ENTER

3. In the Create Hide Situation dialog box, choose OK.
Now, the girder assembly is hidden by the chain drive. Your drawing looks like this:

![Diagram of girder assembly hidden by chain drive]

This is the end of this exercise.

Save your file.
Working with Standard Parts

In this tutorial, you learn to work with standard parts in AutoCAD® Mechanical. You insert a screw connection, a hole, and a pin. You also edit the standard parts with power commands. You work with mechanical structure enabled, and see how the standard parts you insert in the drawing are added to the mechanical browser.
## Key Terms

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>background</td>
<td>A contour that is covered by another contour or by objects that are lying behind another contour, in the 3D sense. A background may be a foreground for an additional contour.</td>
</tr>
<tr>
<td>C-line (construction line)</td>
<td>A line that is infinite in both directions or infinite starting at a point which can be inserted into the drawing area. You use C-lines to transfer important points (for example, center points of holes) into other views or drawing areas.</td>
</tr>
<tr>
<td>countersink</td>
<td>A chamfered hole that allows bolt and screw heads to be flush or below the part surface.</td>
</tr>
<tr>
<td>dynamic dragging</td>
<td>The act of determining the size of a standard part with the cursor while inserting it into a side view. The standard part is displayed dynamically on the screen and can be dragged to the next possible size or length. The values (sizes) are taken from the Standard parts database.</td>
</tr>
<tr>
<td>Power Copy</td>
<td>A command that copies a drawing object to another position in the drawing. Power Copy produces an identical copy of the original object.</td>
</tr>
<tr>
<td>Power Edit</td>
<td>An edit command for all objects in your drawing.</td>
</tr>
<tr>
<td>Power Erase</td>
<td>A command for intelligent deleting. Use Power Erase when you delete part reference numbers or when you delete dimensions that have been created with Power Dimensioning and Automatic Dimensioning.</td>
</tr>
<tr>
<td>Power Recall</td>
<td>A command that lets you click an existing drawing object and places you in the correct command for creating that object.</td>
</tr>
<tr>
<td>Power View</td>
<td>A command where you can quickly and easily create a standard part top view or bottom view of a side view and vice versa.</td>
</tr>
</tbody>
</table>
Working with Standard Parts

AutoCAD Mechanical provides a large selection of standard parts to work with, including regular and fine threads, many types of holes, fasteners, and other standard parts. You can insert complete screw connections (screws with holes and nuts) in one step. Some intelligence is built into this process. For example, if you select a screw with a metric thread, you get only metric threads when you add any additional parts such as tapped holes or nuts.

**NOTE** It is required that the ISO standard parts be installed for this tutorial exercise.

When standard parts are placed in a drawing, they are automatically included in mechanical structure, whether or not the assembly drawing is structured.

Open the initial drawing.

**To open a drawing**

1. Open the file *tut_std_pts.dwg* in the *acadm\tutorial* folder.

<table>
<thead>
<tr>
<th>Toolbutton</th>
<th>File ➤ Open</th>
<th>Command</th>
<th>OPEN</th>
</tr>
</thead>
</table>

The drawing contains a motor with a gearbox. Some construction lines are inserted to help you work through the tutorial exercise. The gearbox is not completed yet. We want to add standard components and show how easy it is to edit standard parts with an automatic update of the background objects.

Before you proceed, you must enable mechanical structure. If you proceed without mechanical structure enabled, some command line prompts will differ from the prompts in the exercise.

2. On the status bar, click the STRUCT button to latch it down.
3 If the mechanical browser is not visible:
   a In the command line, enter `AMBROWSER`.
   b When prompted, enter `ON`.

4 Zoom in to the area of interest.

   ![Toolbutton](image)

   **Menu**
   - View ➤ Zoom ➤ Window
   
   **Command**
   - ZOOM

5 Respond to the prompts as follows:

   **Specify first corner:** _Specify the first corner point (1)_

   **Specify opposite corner:** _Specify the second corner point (2)_

Save your file under a different name or to a different directory to preserve the original tutorial file.
Inserting Screw Connections

Insert a screw connection in the differential gear housing.

To insert a screw connection

1. Start the Screw Connection command.
   Toolbutton ➤ Screw Connection
   Menu AMSCREWCON2D

2. In the Screw Connection dialog box, choose the Screws button.

3. In the Select a Screw dialog box, select Socket Head Types.
4 Select ISO 4762 and Front View.
You are returned to the Screw Connection - Front View dialog box.

5 In the Screw Connection - Front View dialog box, choose the upper Holes button. Then select Through Cylindrical, and ISO 273 normal.

6 In the Screw Connection - Front View dialog box, choose the lower Holes button. Then select Tapped Holes, Blind, and ISO 262 (Regular Thread).

| NOTE | The screw types available and the order depend on the standard selected to be active in AMOPTIONS, AM:Standard Parts. |

7 In the Screw Connection dialog box, specify the size M4.
Choose Next.

8 Respond to the prompts as follows:

Specify insertion point of first hole: Specify first point (1)

Specify endpoint of first hole [Gap between holes]:

Specify second point (2)
In the Screw Assembly Representation - Front View dialog box, choose Next.

In the Screw Assembly Grip Representation - Front View dialog box, choose Finish.
11 Respond to the prompts as follows:

Drag Size:

*Drag the screw connection dynamically to size M4 x 16, and then click*

Drag Size: *Enter 12,*  press ENTER.

The screw connection is inserted with a specified a screw length of 16 mm and a blind hole depth of 12 mm.

**NOTE** During dragging, the size of the screw is shown as a tooltip and in the status bar, where the coordinates are usually displayed.

The background is automatically hidden, and your drawing looks like this:
Copying Screw Connections with Power Copy

With Power Copy, you can copy complete objects, including the information attached to those objects. In the case of a screw connection, you copy the whole screw connection to another location. The background is automatically updated.

Copy the new screw connection using the Power Copy command.

To copy a screw connection

1. Start the Power Copy command.
   - Toolbutton
   - Menu Modify ➤ Power Commands ➤ Power Copy
   - Command AMPOWERCOPY

2. Respond to the prompts as follows:
   - Select object: Select the previously inserted screw
   - Specify insertion point: Specify a point (1)
   - Specify direction: Press ENTER
The screw is copied to the specified location. Your drawing looks like this:

The standard parts you inserted are listed in the browser. If you start with a structured assembly drawing, the standard parts are automatically structured within the subassembly where they are inserted.
Creating Screw Templates

Create a screw template and store it for repeated use. This makes the insertion of identical or similar screw connections much faster.

Before you create and insert the screw template, zoom to the cover plate.

To zoom to a window

1. Zoom to the extents of the drawing.
   Toolbutton
   Menu View ➤ Zoom ➤ Extents
   Command ZOOM

2. Zoom in to the coverplate.
   Toolbutton
   Menu View ➤ Zoom ➤ Window
   Command ZOOM

3. Respond to the prompts as follows:
Specify first corner: Specify first corner point (1)
Specify opposite corner: Specify second corner point (2)

Start the screw connection and create a screw template.

To create a screw template

1. Start the Screw Connection command.
   Toolbutton

   Menu Content ➤ Screw Connection

   Command AMSCREWCON2D

2. In the Screw Connection dialog box, choose the Screws button.
3 In the Select a Screw dialog box, select Countersink Head Type.
Select ISO 10642, and Front View.
5 In the Screw Connection - Front View dialog box, choose the upper Holes button. Then select Countersinks, and ISO 7721.

6 In the Screw Connection - Front View dialog box, choose the lower Holes button. Then select Tapped Holes, Blind, and ISO 262.

7 In the Screw Connection - Front View dialog box, choose Back to store the screw template.
8 In the Screw Assembly Templates dialog box, choose the Save icon. Your screw connection is stored as a template and is added to the list.

Choose Next.
NOTE The screw template contains the combination of the used standard parts. It contains no sizes, like diameters or lengths.

9 In the Screw Connection dialog box, choose the Pre-calculation icon.

10 In the Screw Diameter Estimation dialog box, specify:
   - Material Class: 10.9
   - Applied Force: 1500
   - Nature of Load: Static and Centric applied Axial Force (upper-left icon)
   - Method for Tightening Screw: Mechanical Screw Driver
The Result field displays a nominal diameter size of M4. Choose OK.

In the Screw Connection - Front View dialog box, the precalculation routine has marked M4.

Choose Next.
12 Respond to the prompts as follows:

Specify insertion point of first hole: Specify first point (1)

Specify endpoint of first hole [Gap between holes]:

Specify second point (2)

13 In the Screw Assembly Location - Front View dialog box, choose Next.

14 In the Screw Assembly Grip Representation - Front View dialog box, choose Finish.

15 Respond to the prompts as follows:

Drag Size:

Drag screw connection dynamically to size M4 x 12, and then click

Drag Size: Enter 8, press ENTER

The screw connection is inserted with a screw length of 12 mm and a blind hole depth of 8 mm.

Your drawing looks like this:
The screw connection is added to the list in the mechanical browser.
Save your file.

Editing Screw Connections with Power Edit

Rather than use different editing commands for different objects, you can use only one command, Power Edit, for editing all objects in a drawing with built-in intelligence. When you use Power Edit on a screw connection, the whole assembly can be edited and is updated in your drawing with an automatic background update.

Change the screw connections to the appropriate length.

To edit a screw connection that is not yet structured

1  Start the Power Edit command.
   Toolbutton
   Menu Modify ➤ Power Commands ➤ Power Edit
   Command AMPOWEREDIT

2  Respond to the prompts as follows:
Select object: *Select the lower screw of the coverplate*

**NOTE** You can also start Power Edit by double-clicking the desired part.

3 In the AutoCAD® message box, click OK.

4 Respond to the prompts as follows.

   Select parent component and view or (ModelSpace/Active) <Active>: Press ENTER
   
   Select entity for another standard component view <Done>: Press ENTER

   The legacy standard part is migrated, and is listed in the mechanical browser.

5 In the Screw Connection New Part Front View - Front View dialog box, choose Back.

6 On the Templates page, double-click the ISO 10642 screw template in the list, or select it and choose the Load the template icon.
The Screw Connection New Part Front View - Front View dialog box contains the screw connection as it has been stored in the template.

7 Select the size M4, and then choose Next.
8  Respond to the prompts as follows:
   Specify insertion point of first hole: Press ENTER
   Specify endpoint of first hole [Gap between holes]: Press ENTER

9  In the Screw Connection New Part Front View - Front View dialog box, Location representation, choose Next.

10 In the Screw Connection New Part Front View - Front View dialog box, Grip representation, choose Finish.

   Drag Size:
   Drag the screw connection dynamically to the size M4 x 12, and then click
   Drag Size: Enter 8, press ENTER

   The screw connection is edited to a screw length of 12 mm and a blind hole depth of 8 mm.

   Your drawing looks like this:

   ![Drawing Image]

   Save your file.
Working with Power View

With Power View, you can quickly generate a top or bottom view of a side view of a standard part and vice versa.

Before you complete the top view of the coverplate, you have to zoom into it.

To zoom to a window

1. Zoom to the extents of the drawing.
   Toolbutton
   Menu View ➤ Zoom ➤ Extents
   Command ZOOM

2. Zoom in to the coverplate.
   Toolbutton
   Menu View ➤ Zoom ➤ Window
   Command ZOOM

3. Respond to the prompts as follows:
   Specify first corner: Specify first corner point (1)
   Specify opposite corner: Specify second corner point (2)
To insert a standard part using Power View

1. Start the Power View command.
   - **Toolbutton**
   - **Menu**
     - Modify ➤ Power Commands ➤ Power View
   - **Command**
     - AMPOWerview

2. Respond to the prompt as follows:
   - **Select object:** *Select the screw at cover plate (1)*
   - The AutoCAD Mechanical message box is displayed.
3 Choose Top, and respond to the prompt as follows:

Specify insertion point: Specify the centerline cross at top view (2)

The top view of the screw connection is inserted into the top view of the coverplate. Your drawing should look like this:

4 Repeat steps 1 and 2 to insert the top view of the screw at the other three centerline crosses of the top view of the coverplate.

The coverplate should look like this:
Delete your file.

**Deleting with Power Erase**

Power Erase is an intelligent erase command. It detects the object information of a part. If you delete a screw connection with Power Erase, the representation of the background is automatically corrected.

Before you delete the standard part, you have to zoom into it.

**To zoom to a window**

1. **Zoom to the extents of the drawing.**
   - Toolbutton
   - **Menu** View ➤ Zoom ➤ Extents
   - **Command** ZOOM

2. **Zoom in to the coverplate.**
   - Toolbutton
   - **Menu** View ➤ Zoom ➤ Window
   - **Command** ZOOM

3. **Respond to the prompts as follows:**
   - **Specify first corner:** Specify first corner point (1)
Delete a screw using the Power Erase command.

To delete a standard part

1. Start the Power Erase command.
   Toolbutton
   Menu Modify ➤ Power Commands ➤ Power Erase
   Command AMPOWERERASE

2. Respond to the prompts as follows:
   Select object: Select the screw (1)
   Select object: Press ENTER
The screw connection is deleted and the lines and hatch are restored.

Save your file.

**Inserting Holes**

Replace the previously deleted screw connection with a pin. First you insert a blind hole for the pin.
To insert a hole

1. Start the Blind Hole command.
   Toolbutton ➤ Holes ➤ Blind Holes
   Menu Command ➤ AMBHOLE2D

2. In the Select a Blind Hole dialog box, select Acc. to ISO 273, and Front View.

3. Respond to the prompts as follows:
   Specify insertion point: Specify insertion point (1)
   Specify rotation angle <0>: Specify a point to define insertion angle (2)
4 In the Acc. to ISO 273 - Nominal Diameter dialog box, select a size of 5, and then choose Finish.

5 Continue to respond to the prompts as follows:

   Drag Size:  *Enter 20, press ENTER*

   The blind hole is inserted.

   Your drawing should look like this:
Inserting Pins

Insert a pin into the blind hole.

To insert a pin

1. Start the Cylindrical Pins command.
   - **Toolbutton**
   - **Menu** Content ➤ Fasteners ➤ Cylindrical Pins
   - **Command** AMCYLPIN2D

2. In the Select a Cylindrical Pin dialog box, select ISO 2338 and Front View.
3 Respond to the prompts as follows:
   Specify insertion point: Specify insertion point (1)
   Specify rotation angle <0>: Specify a point to define insertion angle (2)

4 In the ISO 2338 - Nominal Diameter dialog box, select a size of 5.
5 Choose Finish, and then continue to respond to the prompt as follows:

Drag Size: Drag the pin to size 5\text{ h8 x 16 - B}, and then click

NOTE Turn the object snap (OSNAP) option off to snap to the correct pin size.

6 In the Select Part Size dialog box, select 5\h eight x 16 - B, and then choose OK.

7 The Create Hide Situation dialog box is displayed. Click OK. The pin is inserted. Your drawing should look like this:
You inserted the blind hole first, and then the pin. This results in overlapping centerlines. In order to have a correct plot, turn one centerline off.

**To turn off a centerline**

1. Select the previously inserted cylindrical pin.
2. Right-click, and on the shortcut menu deactivate Centerlines on/off. With the centerline of the pin turned off, only the centerline of the blind hole is displayed.

Save your file.

---

**Turning Off Centerlines in Configurations**

If your drawing already contains holes with centerlines, and you want to add standard parts, it is recommended to turn off the centerlines for standard parts in the configuration. This avoids removing overlapped centerlines.

**To turn off centerlines in the configuration**

1. Open the Mechanical Options dialog box.
   - **Menu**
     - Assist ➤ Options
   - **Command**
     - AMOPTIONS

2. On the AM:Standard Parts tab, clear the Draw Centerlines check box.
Choose Apply, and then choose OK.

**Hiding Construction Lines**

For a better overview, you can hide the construction lines by turning them off temporarily.

Zoom to the extents of the drawing.

**To zoom to the extents**

- Zoom to the extents of the drawing.
  
  **Toolbutton**

  ![Toolbutton Image]

  **Menu** View ➤ Zoom ➤ Extents

  **Command** ZOOM

Turn off all construction lines.
To turn off C-lines

Start the Construction Line On/Off command.

Toolbutton

Menu Assist ➤ Layer/Layergroup ➤ Construction Line On/Off
Command AMCLINEO

All construction lines are turned off temporarily.
Save your file.

Simplifying Representations of Standard Parts

In some cases, such as in complex assemblies, it is helpful to have a simplified representation of the standard parts for a better overview. With AutoCAD Mechanical, you can switch between different representation types without losing object or part information.

Change the representation of the differential gear screws.

To change the representation of a standard part

1  Start the Change Representation command.

Toolbutton

Menu Content ➤ Change Representation
Command AMSTDPREP

2  Respond to the prompts as follows:

Select objects: Select the differential gear with a window (1, 2)
Select objects: Press ENTER
In the Switch Representation of Standard Parts dialog box, select Symbolic.

Choose OK.

The representation of the selected standard parts is symbolic. Your drawing should look like this:
All of the standard parts you inserted in this exercise are listed in the mechanical browser.
Save your file.
This is the end of this tutorial chapter.
Working with BOMs and Parts Lists

In AutoCAD® Mechanical, you can create parts lists and bills of material (BOMs), and modify part references and balloons. In this chapter, you insert and edit a parts list, and work with the bill of material (BOM) database.
Key Terms

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>balloon</td>
<td>Circular annotation tag that identifies a bill of material item in a drawing. The number in the balloon corresponds with the number of the part in the bill of material.</td>
</tr>
<tr>
<td>bill of material</td>
<td>A dynamic database containing a list of all the parts in an assembly. Used to generate parts lists that contain associated attributes such as part number, manufacturer, and quantity.</td>
</tr>
<tr>
<td>BOM attribute</td>
<td>An entity that contains attributes by default (the attribute is invisible) that can add information to and describe details of a part in the drawing. The values of these attributes are transformed into the parts list attributes when converting BOM attributes and creating a parts list.</td>
</tr>
<tr>
<td>part reference</td>
<td>Part information for a bill of material, which is attached to the part in the drawing.</td>
</tr>
<tr>
<td>parts list</td>
<td>A dynamic list of parts and associated attributes generated from a bill of material database. The parts list automatically reflects additions and subtractions of parts from an assembly.</td>
</tr>
</tbody>
</table>

Working with Parts Lists

The drawing used for this exercise is not structured. In structured drawings, BOMs and parts list are generated automatically, and it is not necessary to insert part references manually.

Open the initial drawing.

To open a drawing

1. Open the file tut_pts_list in the acadm\tutorial folder.
   - File ➤ Open

244 | Chapter 12  Working with BOMs and Parts Lists
The drawing contains a shaft with a housing.

2  Zoom in to the area of interest.

Menu  ➤  View ➤  Zoom ➤  Window

Command  ZOOM

3  Respond to the prompts as follows:

Specify first corner:  Specify the first corner point figure (1)

Specify opposite corner:  Specify the second corner point (2)

Save your file under a different name or to a different directory to preserve the original tutorial file.

**Inserting Part References**

Part references contain the part information required for a bill of material. The information in a part reference is available in the BOM database for creating a parts list.

Use the part reference command to enter part information for your part.

**To insert a part reference**

1  Start the Part Reference command.

Menu  ➤  Annotate ➤  Parts List Tools ➤  Part Reference

Command  AMPARTREF

2  Respond to the prompts as follows:

Select point or [Block/Copy/Reference]:

Inserting Part References  |  245
Specify a point on the part (1).

3 In the Part Ref Attributes dialog box, specify:
- Description: Housing Partition
- Standard: Size 130x125x55
- Material: EN-GJL-200

Click OK.

The Part Reference is inserted into the drawing. In the next step, you create a part reference by reference.
To insert a part reference by reference

1. Start the Part reference command again.
   Toolbutton
   Annotate ➤ Parts List Tools ➤ Part Reference

2. Respond to the prompts as follows:
   Select point or [Block/Copy/Reference]:
   Enter R at the command prompt to select Reference.

3. In the drawing, select the previously inserted part reference to create a reference.

   **NOTE** You can use the option Copy to create a new part with similar text information.

4. Respond to the prompts as follows:
   Enter an option [Next/Accept]<Accept>: Press ENTER

5. Select point or: Specify the insertion point at the circular edge (2)

6. In the Part Ref Attributes dialog box, click OK.

   **NOTE** This part reference looks different, because it has been attached to an object (the circular edge) of the part.

   Subsequently, when you generate the parts list, it shows a quantity of 2 for this item.

   Save your file.
Editing Part References

In this exercise, you edit an existing part reference in a drawing that is not structured.

To edit a Part Reference

1. Start the Part Reference Edit command.
   - **Toolbutton**: Annotate ➤ Parts List Tools ➤ Part Reference Edit
   - **Menu**: Annotate ➤ Parts List Tools ➤ Part Reference Edit
   - **Command**: AMPARTREFEDIT

2. Respond to the prompts as follows:
   - **Select pick object**: *Specify the part reference of the left bolt (3)*
   - **Enter an option [Next/Accept]<Accept>*: Press ENTER

3. In the Part Ref Attributes dialog box, Reference Quantity field, enter 3, and then click OK.
4 Zoom to the extents to display the entire drawing.

**Toolbutton**

**Menu** View ➤ Zoom ➤ EXTENTS

**Command** ZOOM

Save your file.

---

**Placing Balloons**

Create balloons from the part references in the drawing.

**To place a balloon**

1 Start the Balloon command.

**Toolbutton**

**Menu** Annotate ➤ Parts List Tools ➤ Balloons

**Command** AMBALLOON
2  Respond to the prompt as follows:

```
SELECT PART/ASSEMBLY OR [AUTO/AUTOALL/SET BOM/COLLECT/ARROW
INSET/MANUAL/ONE/RENUMBER/REORGANIZE/ANNOTATION VIEW]: ENTER B
```

**NOTE** At this stage the drawing doesn’t contain a BOM database. As with the AMPARTLIST command, the AMBALLOON command creates a BOM database automatically. All part references are added to the database and item numbers are created inside the database. However, unless specifically instructed the commands create only the main BOM database. For the purpose of this tutorial, you must create a BOM database to contain part references held within the border; a border BOM. This is why you are instructed to type B, to trigger the set BOM option of the AMBALLOON command.

**NOTE** To create and edit a database manually, use the AMBOM command.

```
SELECT BORDER/ANNOTATION VIEW OR SPECIFY BOM TO CREATE/USE
[MAIN/?] <MAIN>: ENTER
```

Select part/assembly or:

```
SELECT PART/ASSEMBLY OR [AUTO/AUTOALL/SET BOM/COLLECT/ARROW
INSET/MANUAL/ONE/RENUMBER/REORGANIZE/ANNOTATION VIEW]: ENTER A
```

Select pick object:

```
USE A WINDOW TO SELECT ALL OBJECTS, AND THEN PRESS ENTER
```

**NOTE** Press ENTER to change the type of arrangement (horizontal, vertical, angle or stand-alone).

3  Place the balloons horizontally, above the assembly.
Because the balloons are numbered automatically, depending on where you located the part references, the appearance of your drawing can be different.

In the next step, you renumber the balloons.

**To renumber balloons**

1. Start the Balloon command again.  
   
   Menu ➤ Annotate ➤ Parts List Tools ➤ Renumber Balloons

2. Respond to the prompt as follows:

   Enter starting item number: <1>: Press ENTER

   Enter increment: <1>: Press ENTER

   Select balloon: *Select the balloons in numerical order from 1 to 7*

   Select balloon: Press ENTER

   ![Schematic Diagram]

   Your drawing must look like the following image for you to continue:

   ![Schematic Diagram]

   **NOTE** Since balloon 7 has a reference, there is no need to select balloon 8. It is numbered 7 automatically.

   Rearrange the balloons for a better representation.
To rearrange balloons.

1. Start the Balloon command again.

   Toolbutton
   Annotate ➤ Parts List Tools ➤ Balloons
   Command AMBALLOON

2. Respond to the prompt as follows:

   Select part/assembly or [auTo/autoAll/set Bom/Collect/arrow
   Inset/Manual/One/Renumber/rEorganize/annotation View]: Enter E

   Select balloon: Select the six balloons on the right

   Select balloon: Press ENTER

   Align [Angle/Standalone/Horizontal/Vertical]<Vertical>:

   Enter h, press ENTER

3. Move the cursor through the center of balloon 1 to get the horizontal
   tracking line.

   NOTE Make sure that the OTRACK function is active.

4. Move the cursor to the right, and snap along the tracking line until you
   reach a distance of 120, and then click.

   The result must look like the following image:
NOTE You can control snap distance within the Balloon Properties dialog box.

Create a part reference and a balloon in one step with the manual option.

To create a part reference and a balloon using the manual option

1 Start the Balloon command again.

   Menu
   Annotate ➤ Parts List Tools ➤ Balloons
   Command AMBALLOON

2 Respond to the prompt as follows:

   Select part/assembly or [auTo/autoAll/set Bom/Collect/arrow Inset/Manual/One/ReNumber/reO rganize/annotation View]: Enter M, press ENTER

   Select point or [Block/Copy/Reference]: Select a point on the shaft

NOTE Instead of selecting a point to create a part reference, you can use Copy or Reference from the Manual option to get the information from an existing balloon or part reference.
3. In the Part Ref Attributes dialog box, specify:
   - **Description**: Shaft
   - **Standard**: Size Dia 50x150
   - **Material**: C45

   ![Part Reference Dialog Box]

   Click OK.

4. Press **ENTER** to start the leader line of the balloon in the center of the part reference.

5. Move the cursor through the center of balloon 1 to get the tracking line and the snap distance, and then click the insertion point.

   **NOTE** Instead of entering the insertion point, you can select another point to create an extended leader line.
6  Press ENTER.
   Save your file.

**Creating Parts Lists**

Generate a parts list from the part reference information.

**To create a parts list**

1  Start the Parts List command.

   Annotate ➤ Parts List Tools ➤ Parts List

   **Menu**

   **Command**    AMPARTLIST

2  Respond to the prompt as follows:

   *Select border/annotation view or specify BOM to create/use [Main/?] <MAIN>*:

   *Move the cursor over the border until tooltip ISO_A2 is displayed, click the highlighted border*

   The Parts List dialog box is displayed.
Click OK.

The parts list appears dynamically on the cursor.

3 Move the cursor to position the parts lists above the title block, and then click to insert the parts list.

The parts list looks like the following:
NOTE If a drawing contains more than one border, the borders are listed in the BOM dialog box. From there you can select a particular border and view the associated parts list.

In the next exercise, you edit balloon and parts list information using several methods.

To edit parts list information

1. Start the Edit Part List/Balloon command.
   Toolbutton
   Command AMEDIT

2. Respond to the prompt as follows:
   Select object: Select balloon 2

3. In the Balloon dialog box, Material column, enter 8.8.
Click OK.
The parts list reflects the material value you added.
NOTE  Choose Apply to see the results in the drawing immediately without leaving the dialog box. All changes made in the dialog box are associative and change the data in the drawing immediately.

4 Double-click the parts list.
The Parts List dialog box is displayed.

You can edit your data in this dialog box. Some examples are shown next.

5 Select the Hex Nut entry, and then choose the Set values icon.
6 In the Set Value dialog box, specify:

- **Column:** Material
- **Value:** 8
Click OK.
The material value is added to the Parts List.

<table>
<thead>
<tr>
<th>Item</th>
<th>Qty</th>
<th>Description</th>
<th>Standard</th>
<th>Material</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>Needle Roller Bearing</td>
<td>ISO 1206 - M6 - 40 x 62 x 22</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>2</td>
<td>Hex-Head Bolt</td>
<td>ISO 4017 - M6x25</td>
<td>8.8</td>
</tr>
<tr>
<td>3</td>
<td>2</td>
<td>Hex-Head Bolt</td>
<td>ISO 4017 M6x25</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>2</td>
<td>Hex Nut</td>
<td>ISO 4034 - M6</td>
<td>9</td>
</tr>
<tr>
<td>5</td>
<td>3</td>
<td>Hex Nut</td>
<td>ISO 4034 - M6</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>1</td>
<td>Needle Roller Bearing</td>
<td>ISO 1206 - M6 - 40 x 62 x 22</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>2</td>
<td>Housing Partition</td>
<td>Size 130x125x65</td>
<td>EN-GJL-200</td>
</tr>
<tr>
<td>8</td>
<td>1</td>
<td>Shaft</td>
<td>Size 60x90x150</td>
<td>C45</td>
</tr>
</tbody>
</table>

7. Now, change the material of the second bolt and nut accordingly.

**NOTE** Use the shortcut menu inside a field to cut, copy, and paste.

### Merging and Splitting Items In Parts Lists

Use the Parts List function to merge like items that are listed repeatedly.

**To merge items in a parts list**

1. In the Parts List dialog box, select the repeated items -Needle Roller Bearing. Click the box in front of item 1, and then hold down CTRL while you click the box in front of item 6.

2. With items 1 and 6 selected, choose the Merge items icon.
The two items are merged. In the table, Item 1 now has a quantity of 2, and Item 6 is missing.

You can select several rows to merge or split items. To merge, the selected rows need to have the same entries.

3. Choose Apply to display the changes in the drawing.

Balloon is displayed twice.
**NOTE** Select the gray field to the left of row 1, and the Split item icon is activated.

In this case, if you choose Split item, the previously merged items are split again.

To select all rows at once, click the gray field in the upper left corner, as shown in the following illustration.
NOTE In this case, the Merge item and Split item icons are active. Using these icons, you can merge or split all items at once. All data is compared, and like items are merged. If they are already merged items, they are split.

Now that you have merged the bearing, you can delete one of the balloons and add an additional leader. Click OK to exit the Parts List dialog box.

To delete a balloon

1 Use Power Erase, and select the left balloon with the item number 1.
2 Press ENTER to delete the balloon.
NOTE  Deleting a balloon in the drawing doesn’t delete any data. Data is lost only if you delete a part reference. You can add more than one balloon to a part reference. For example, you can create a balloon with the same item number for the same part in another view.

To add an additional leader

1  Select the remaining balloon 1.

2  Right-click to display the shortcut menu. Select Add Leader and respond to the prompts as follows:
   Select object to attach:  Select the left bearing
   Next point (or F for first point):  Select a point inside the balloon 1

The leader is added and your drawing should look like the following:

![Drawing](image)

Save your file.

Collecting Balloons

You can collect balloons to place balloons of related parts to one leader line. For example, you can place the balloons of a screw and a nut to one common leader line.

Use Zoom Window to zoom in the top view of the drawing.

Toolbutton

![Toolbutton]

Menu  View ➤ Zoom ➤ Window
Command  ZOOM

To collect balloons

1  Start the AMBALLOON command.
2 Respond to the prompt as follows:

Select part/assembly or [auto/autoAll/set Bom/collect/arrow
Inset/Manual/One/renumber/rEorganize/annotation View]:

Enter C, press ENTER

3 Continue to respond to the prompts as follows:

Select pick object or balloon: Select the part reference of the left nut

4 Continue to respond to the prompts as follows:

Select pick object or balloon: Press ENTER
Select balloon: Select balloon 2
Pick orientation: Select a vertical orientation

5 Repeat the collect balloon command for the screw and nut on the right side.
The result should look like this:
Save your file.

**Sorting and Renumbering Items In Parts Lists**

You can sort a parts list for manufacturing and sort standard parts with updated item numbers.

**To sort a parts list**

1. Zoom to the extents of the drawing.
   - **Toolbutton**
     - View ➤ Zoom ➤ Extents
   - **Menu**
     - Command ZOOM

2. Double-click the parts list to display the Parts List dialog box.

3. Choose the Sort icon.
The Sort dialog box opens.

**NOTE** You can sort within a selection set, otherwise you are sorting all items.

4. In the Sort dialog box, specify as shown in the following image.

Click OK.

The result should look like this:
In the next step, you renumber the items.

To renumber parts list items

1. Click the Item cell to select the whole Item column.

2. Choose the Set values icon.

3. In the Set Value dialog box, specify:
   Column: Item
   Start value: 10
   Step: 10

4. Click OK to return to the Parts List dialog box.

5. Choose Apply to see the results.
6 Choose OK to return to the drawing.
   Save your file.

Using Filters

You can create and use one or more filters for every parts list you have inserted in the drawing.

To use filters in a parts list

1 Double-click the parts list to display the Parts List dialog box.
2 Right-click the white Filters field.
3  Select Add Filter to display the List of Filters dialog box.

4  Select Custom and click OK.
The details for this filter are displayed in the Filter/Groups section of the Parts List dialog box.

5 Set the following values to define the filter.
6 Activate the filter with the Custom check box.

7 Click Apply.
The Standards that contain ISO are displayed.
The filtered parts list is displayed in the drawing. The defined filters are saved with the parts list and can be used again later.

To print only the filtered list, choose the Print icon.

8. Deactivate the custom filter, and then click OK to close the dialog box.

The filter is used in this drawing.

The result looks like the following:

---

274 | Chapter 12  Working with BOMs and Parts Lists
Save your file.

This is the end of this tutorial chapter.
Creating Shafts with Standard Parts

In this tutorial, you work with the automated shaft generator and standard parts in AutoCAD® Mechanical to create and edit a shaft, and insert bearings. The standard parts you use are automatically structured in the mechanical browser.
## Key Terms

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>bearing calculation</td>
<td>Calculates limiting value, dynamic and static load rating, dynamic and static equivalent load, and fatigue life in revolutions and hours.</td>
</tr>
<tr>
<td>chamfer</td>
<td>A beveled surface between two faces or surfaces.</td>
</tr>
<tr>
<td>dynamic calculation</td>
<td>Calculation required for a revolving bearing. The result is the Adjusted Rating Life. This is the life associated with 90% reliability with contemporary, commonly used material, and under conventional operating conditions. With the number of revolutions you get the life in working hours.</td>
</tr>
<tr>
<td>dynamic dragging</td>
<td>The act of determining the size of a standard part with the cursor while inserting it into a side view. The standard part is displayed dynamically on the screen and can be dragged to the next possible size and length. The values (sizes) are taken from the Standard parts database.</td>
</tr>
<tr>
<td>fillet</td>
<td>A curved transition from one part face or surface to another. The transition cuts off the outside edge or fills in the inside edge.</td>
</tr>
<tr>
<td>gear</td>
<td>Any of several arrangements, especially of toothed wheels in a machine, which allow power to be passed from one part to another to control the power, speed, or direction of movement.</td>
</tr>
<tr>
<td>radius reflection line</td>
<td>Thin line that represents the radius in the side or top view.</td>
</tr>
<tr>
<td>shaft break</td>
<td>Interruption of a shaft. A shaft can be interrupted at a point, and the shaft break symbols are inserted in a suitable size.</td>
</tr>
<tr>
<td>shaft generator</td>
<td>Tool to draw rotationally symmetrical parts. A shaft is usually created from left to right using different sections. These sections are positioned automatically one after the other. Additionally, any shaft section can be inserted, deleted, or edited.</td>
</tr>
</tbody>
</table>
Creating Shafts

In this section, you use the shaft generator to create a shaft with standard parts. You also perform a bearing calculation.

To open a template

1. Open a new drawing.
   - Toolbutton
   - Menu File ➤ New
   - Command NEW

2. In the Select template dialog box, click the template am_iso.dwt, and then click Open.

   ![Select template dialog box]

   This creates a new drawing based on the am_iso template. Use Save As to save the drawing file with an appropriate name.

   **NOTE** The ISO standard part standard has to be installed for this tutorial exercise.

   Ensure that mechanical structure is enabled
To enable mechanical structure

1. Click the STRUCT status bar button and latch it down to enable mechanical structure.

2. If the mechanical browser is not visible, in the command line, enter `AMBROWSER`.

3. When prompted, enter `ON`.

**Configuring Snap Options**

Configure the snap options.

**To configure the snap options**

1. Start the Power Snap Settings.
   - **Toolbutton**
     - Assist ➤ Drafting Settings ➤ Osnap Settings
   - **Menu**
     - AMPOWERSNAP
   - **Command**

2. In the Power Snap Settings dialog box, activate the tab Setting 4 and specify:
   - **Snap Modes**: Endpoint, Midpoint, Intersection

![Power Snap Settings dialog box](image)
Choose OK
Save your file.

Configuring Shaft Generators

In the next steps, you start and configure the shaft generator.

To start and configure the shaft generator

1 Start the Shaft Generator command.
   Toolbutton ➤ Shaft Generator
   Menu Content ➤ Shaft Generator
   Command AMSHAFT2D

2 Respond to the prompts as follows:
   Enter shaft component name <Shaft1>: Press ENTER
   Specify starting point or select center line:
   Enter 150,150, press ENTER
   Specify centerline endpoint: Enter 240,150, press ENTER

   NOTE The start and endpoints of the centerline are only important in
determining the direction. The length of the centerline is automatically
adapted to the length of the shaft.

3 In the Shaft Generator dialog box, click Options.
4 In the Shaft Generator - Configuration dialog box, specify:
   For Segment inserted: Insert
   Stationary Shaft End: Left
   Adjust Centerline: Yes
   Front View: Radius Reflection Line, Check contour
   Side and Sectional Views: Sectional with Background, Always update
   View of Interrupt: Hatch
   If shaft is in background, hide standard part too: Yes

Choose OK.
You return to the Shaft Generator dialog box.

Creating Cylindrical Shaft Sections and Gears

The shaft generator is configured. Now you want to generate the first shaft segments.
To create shaft segments

1. Choose the lower cylinder button to define a cylinder section, and respond to the prompts as follows:
   
   Specify length <50>: Enter 12, press ENTER
   Specify diameter <40>: Enter 20, press ENTER

2. Choose the gear button, and then enter the values for module, number of teeth, and length as shown in the following figure:

   ![Gear dialog box]

   **NOTE** Here, the DIN standard requires that you indicate the module. The ANSI standard requires the Diametral Pitch 1/module. You can switch between these two representations using the DIN and ANSI options.

3. Close the Shaft Generator dialog box.

   In the mechanical structure browser, the shaft is added as a component. Add an assembly to structure the shaft components you create in this exercise.

Creating Cylindrical Shaft Sections and Gears | 283
To add an assembly to the mechanical browser

1. In the mechanical browser, right click the file name node (the root node) and choose New ➤ Component.

2. Respond to the prompts:
   - Enter new component name <COMPl>: Enter shaftassembly, press ENTER
   - Enter new view name <Top>: Enter front, press ENTER
   - Select objects for new component view: Select the shaft with a window
   - Select objects for new component view: Press ENTER
   - Specify base point: Specify a point at the upper left of the shaft

   The shaft assembly is listed at the top of the browser, and the existing shaft components are listed within the assembly. As you add more components to the shaft, they are automatically structured in the assembly.

3. Choose the lower cylinder button to define a further cylinder section and respond to the prompts as follows:
   - Specify length <10>: Enter 5, press ENTER
   - Specify diameter <20>: Enter 20, press ENTER

4. Choose the gear button, and then enter the values for module, number of teeth, and length as shown in the following figure:
Choose the lower cylinder button to define another cylinder section, and then respond to the prompts as follows:

Specify length <10>: Enter 4, press ENTER
Specify diameter <20>: Enter 24, press ENTER

Choose the lower cylinder button to define another cylinder section, and then respond to the prompts as follows:

Specify length <4>: Enter 33, press ENTER
Specify diameter <24>: Enter 20, press ENTER

The first five sections of the shaft are created, as represented in the following figure:
Inserting Spline Profiles

Add a spline profile to the shaft.

To create a profiles segment

1. Choose the Profile button.
2. Choose ISO 14 in the database browser.
3. In the Splined Shaft ISO 14 dialog box, select the standard size 6 x 13 x 16 and enter a length of 26.

Choose OK.

You created another section of the shaft, as shown in the following figure:
Inserting Chamfers and Fillets

Apply a chamfer and a fillet to the shaft.

To apply a chamfer and a fillet

1. Choose the Chamfer button to apply a chamfer to a shaft section, and then respond to the prompts as follows:
   - Select object: Select the leftmost cylinder section (1)
   - Specify length (max. 12) <2.5>: Enter 2, press ENTER
   - Specify angle (0-79) or [Distance] <45>: Enter 45, press ENTER

2. Choose the Fillet button to apply a fillet to a shaft section, and then respond to the prompts as follows:
   - Select object:
     Select the cylinder section between the two gears near the second gear (1)
   - Enter radius (max. 5.00) <2.50>: Enter 2, press ENTER
NOTE The fillet is applied to the edge of the selected section that is closer to the selected point.

The shaft looks like the following figure:

![Shaft Diagram]

**Inserting Shaft Breaks**

Insert a shaft break in the drawing.

**To insert a shaft break**

Choose the Break button to insert a shaft break, and then respond to the prompts as follows:

Specify point: *Select the midpoint of the cylindrical section (1)*

Specify length (min. 4.00) <6>: *Enter 10, press ENTER*

![Shaft Break Diagram]

NOTE You can insert the break to the left if you enter a negative value.

The shaft break is inserted.
Creating Side Views of Shafts

Insert a side view of the shaft.

To insert a side view

1. Choose the Side view button.
2. In the Side view from dialog box, select Right. Choose OK.
3. Respond to the prompt as follows:
   
   Specify insertion point: Press ENTER

   The right side view is inserted at the proposed position.

In the mechanical browser, the new right side view is listed within the shaft component along with the existing front view. The right side view includes its hide situations.
Inserting Threads on Shafts

Add a thread to the shaft.

To insert a thread on a shaft

1. Choose the Thread button to insert a thread, and then select ISO 261 External in the browser.

2. In the ISO 261 ExternalThreads (Regular Thread) dialog box, select M10 and enter a length of 20. Choose OK.

The thread is added to the shaft, which looks like this:
NOTE If Always Update is unchecked in Options, AM:Shaft tab, you are prompted to update associated views when you close the Shaft Generator.

**Editing Shafts and Inserting Sections**

Edit an existing shaft section and insert a new section. You use the Edit button in the shaft generator to turn on AMPowerEDIT.

**To edit and insert a shaft section**

1. Choose the Edit button, and then respond to the prompts as follows:
   - Select object: *Select the first cylindrical section (1)*
   - Specify length <12>: *Press ENTER*
   - Specify diameter <20>: *Enter 18, press ENTER*

   ![Diagram of a shaft with specified points](image)

   The diameter is changed to 18 while the length remains 12.

2. Choose the Insert button, and then respond to the prompt as follows:
   - Specify point: *Select a point after the second gear (1)*
Choose the Slope button, and then respond to the prompts as follows:

Specify length or [Dialog] <20>: Enter 4, press ENTER
Specify diameter at starting point <24>: Enter 28, press ENTER
Specify diameter at endpoint or [Slope/Angle] <20>:
   Enter 22, press ENTER

Replacing Shaft Sections

The previously inserted slope needs to be deleted again.

To replace a shaft section

1. Choose the Undo button.
   The previous slope insertion is undone.
   Replace an existing shaft section. To do this, change the settings in the configuration.
2 Choose the Options button to start the shaft generator configuration, and then specify:

For Segment inserted: **Overdraw**

Choose OK.

3 Choose the Slope button, and then respond to the prompt as follows:

*Specify length or [Dialog] <4>: Enter D, press ENTER*

4 In the Shaft Generator - Cone dialog box, specify the following settings.

Choose OK.

The slope replaces the cylindrical shaft section.
Inserting Bearings

Insert a bearing and perform a bearing calculation.

To insert a bearing

1. Choose the Standard Parts button, and then select Roller Bearings ➤ Radial ➤ ISO 355. Respond to the prompts as follows:
   - Specify insertion point on shaft contour: Specify insertion point (1)
   - Direction to [Left]: Select a point to the right (2)

2. In the ISO 355 dialog box, choose Next.
3 Specify the loads, and activate Work Hours as shown in the following.

Choose Next.

4 In the ISO 355 dialog box, select the bearing 2BD - 20 x 37 x 12, and then choose Finish.
You can drag the cursor to see all available bearing sizes.

5 Drag to the size 2BD - 20 x 37 x 12, and then press ENTER.

6 In the Create Hide Situation dialog box, click OK.
The bearing is inserted.

7 Close the Shaft Generator dialog box.
In the mechanical structure browser, the roller bearing component is added to the assembly.
This is the end of this tutorial chapter.
Save your file.
Calculating Shafts

In this tutorial, you use the shaft generator in AutoCAD® Mechanical to perform a calculation on an existing shaft, and apply various loads to a supported shaft. Then you insert the results into a drawing.
# Key Terms

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>deflection line</td>
<td>A curve representing the vertical displacement of different points along the member subjected to a load.</td>
</tr>
<tr>
<td>bending moment</td>
<td>The moment of all forces that act on the member to the left of a section (a point along the member where bending moment needs to be calculated) taken about the horizontal axis of the section.</td>
</tr>
<tr>
<td>fatigue factor</td>
<td>Safety to endurance or fracture under repetitive cycles of loads.</td>
</tr>
<tr>
<td>fixed support</td>
<td>A support that prevents translation as well as rotation about all axes.</td>
</tr>
<tr>
<td>gear</td>
<td>Any of several arrangements in a machine, especially toothed wheels, that allow power to be passed from one part to another to control the power, speed, or the direction of movement.</td>
</tr>
<tr>
<td>load</td>
<td>The forces and moments that act on a part.</td>
</tr>
<tr>
<td>movable support</td>
<td>A support that prevents translation as well as rotation about all axes.</td>
</tr>
<tr>
<td>notch</td>
<td>A change of cross section, such as an undercut, groove, hole or shoulder. A notch leads to higher stress in the part. The flux of the stress is interrupted or redirected.</td>
</tr>
<tr>
<td>point force</td>
<td>A force that is concentrated on a point.</td>
</tr>
<tr>
<td>strength</td>
<td>A summary term for all forces and moments, thus loads and stress, which act on a part.</td>
</tr>
<tr>
<td>stress</td>
<td>Force or pressure on a part. Stress is the force per unit area.</td>
</tr>
<tr>
<td>yield point</td>
<td>Safety to the stress beyond which the material exhibits permanent deformation.</td>
</tr>
</tbody>
</table>
Calculating Shafts

With AutoCAD Mechanical, you can perform a shaft calculation using a contour created with the Shaft Generator, or any other symmetric shaft contour. The function provides a static calculation, which is important for the design of the shaft and the bearing load.

In this tutorial, you calculate a gearbox shaft. The general way to calculate an existing shaft is to define the contour and insert forces and supports. The routine calculates all necessary values and draws the respective graphs for moment and deflection.

Mechanical structure does not impact this engineering structure routine. You can calculate shafts with mechanical structure enabled or disabled.

Load the initial drawing.

To open a file

1. Open the file *tut_shafts* in the *acadm\tutorial* folder.

   **Toolbutton**

   **Menu** File ➤ Open
   **Command** OPEN

   The drawing contains a shaft in front and side view.

2. Zoom in to the shaft.

   **Toolbutton**

   **Menu** View ➤ Zoom ➤ Window
   **Command** ZOOM

3. Respond to the prompts as follows:

   Specify first corner: Specify the first corner point (1)
   Specify opposite corner: Specify the second corner point (2)
Creating Shaft Contours

Before you can perform any calculations on a shaft, you have to create the shaft contour.

**To create a shaft contour**

1. Start the Shaft Calculator.
2. Toolbutton ➤ Content ➤ Calculations ➤ Shaft Calculation
   - Command ➤ AMSHAFTCALC
3. Respond to the prompts as follows:
   - *Select contour or [Create contour/Strength] <Create>*: 
     - Enter C, press ENTER
   - Select objects: *Select the complete shaft*
   - Select objects: *Press ENTER*
4. In the AutoCAD® Question dialog box, choose Yes.

Save your file under a different name or to a different directory to preserve the original tutorial file.
Respond to the prompts as follows:

Specify contour position:  Press ENTER

**NOTE** The calculation routine recognizes hollow shafts and uses the contour for the calculation.

After you create the shaft contour, the Shaft Calculation dialog box is displayed so that you can select the boundary conditions, the material, and the representation of the calculation results.

---

### Specifying Material

You specify the material by selecting it from a table containing the most commonly used materials. You can also to enter the characteristics for other materials using the option Edit.

**To specify a material**

1. In Material, choose Edit.
   The Material Properties dialog box is displayed.

2. In the Material Properties dialog box, choose Table, and then select the ANSI Material standard.

3. In the Material dialog box, select the material Steel SAE 1045 from the table.
Choose OK.

**NOTE** If the ANSI standard is not installed on your system, you can select a different standard, but the results may differ from the results in this tutorial. For example, if you select DIN, you can select a similar material, like E335, to achieve similar results.

**NOTE** Some material properties are not complete. In this case, you have to complete them to obtain calculation results.

4. In the Material Properties dialog box, complete the ANSI material properties, if necessary.

Choose OK.

304 | Chapter 14  Calculating Shafts
Placing Shaft Supports

Specify the shaft supports.

To place a support

1. In the Shaft Calculation dialog box, select the Movable Support icon, and then respond to the prompt as follows:
   Specify insertion point: Select the midpoint of the leftmost shaft section

2. Select the Fixed Support icon, and then respond to the prompt as follows:
   Specify insertion point: Select the midpoint of the third cylindrical shaft section

   The shaft supports are specified, and the result looks like this:

   ![Shaft Supports Diagram]

Specifying Loads on Shafts

Specify the effective loads. AutoCAD® Mechanical uses geometry from the drawing for load calculations.

The loads depend on the Calculated Part setting. There are three possibilities: Rotating Shaft, Rotating Axle, and Not rotating Axle. Shafts transfer torque and rotating axles results in different stress values than static axles results.

To specify a load

1. From the Calculated Part drop-down list, choose Rotating Shaft.
2 Choose the Gear icon, and then respond to the prompt as follows:

Specify insertion point:
Select the midpoint of the second gear from the left

3 In the Gear dialog box, Inputs tab, specify:

Gear Load: Constant Motive Power, Driven
Torque: 15

Choose OK.

NOTE The Components tab displays the force components. Changes in one tab are automatically reflected in the other tab.

4 Choose the Point Load icon, and then respond to the prompts as follows:

Specify insertion point: Select the midpoint of the profile section
Specify rotation angle: Press ENTER

5 In the Point Load dialog box, Resultant tab, specify:
Point Load: $2500$

Choose OK.

6. Choose the Torque icon, and then respond to the prompt as follows:

Specify insertion point: *Select the midpoint of the profile section*

7. In the Torque dialog box, specify:
   
   Torque: $M_t$ = 15

Choose OK.

The loads are specified, and the result looks like this:
Calculating and Inserting Results

Perform a calculation of the moments and deformations, and insert the results in your drawing.

To perform a shaft calculation

1. In the Shaft Calculation dialog box, choose the Moments and Deformations button.

2. In the Select Graph dialog box, specify:
   - **Bend**: Bending Moment in Y - Axis, Deflection in Y - Axis
   - **Torsion**: Torsion Moment in X - Direction
   - **Stresses**: Result Bending Stress
   - **Table Title**: Shaft Calculation Exercise

All boundary conditions necessary for a shaft calculation are specified.
3 Choose OK, and then respond to the prompts as follows:

Specify insertion point:

*Select an appropriate point to the right of the shaft*

The result block and the deflection and torsion moment graphs are inserted.

4 Close the Shaft Calculation dialog box.

Your drawing looks like this:
The result block provides the most important information about your calculated shaft, such as the maximum stress deflection and moment values.
5 Close the Shaft Calculation dialog box.  
Save your file.

**Calculating Strengths of Shafts**

Check the strength at a critical place of the shaft, such as at a notch.

To calculate the strength at a notch

1 Restart the Shaft Calculation Toolbutton

2 Respond to the prompt as follows:
Select contour or [Create contour/Strength] <Create>:

*Select the shaft contour*

The Shaft Calculation dialog box opens. Continue with calculations on the previously specified shaft.

3 In the Shaft Calculation dialog box, choose the Strength button, and then respond to the prompt as follows:

*Specify calculation position on shaft or [Graph]:*

*Specify the notch at the end of the conical section (1) (do not select the endpoint of the cylindrical shaft section)*

![Diagram of a shaft with a notch and loads](image)

*NOTE* This notch was selected because the calculation established that the highest bending stress is close to this place.

The Strength Calculation dialog box opens.

Use the Strength Calculation dialog box to specify the properties of the notch in more detail and display the strength values and factors.
Choose OK.

4 Respond to the prompts as follows:

Specify next point <Symbol>: Specify a point below the shaft

Specify next point <Symbol>: Press ENTER

The result block is inserted in the drawing.
The safety factors are greater than 1.0, so the shaft does not need to be redesigned at this notch.

5 Close the Shaft Calculation dialog box.
This is the end of this tutorial chapter.
Save your file.
The tutorials in this section teach you how to calculate moments of inertia and deflection lines, create and calculate chains, springs and cams. The drawing files for each lesson can be found in the Acadm/tutorial/ folder of the AutoCAD® Mechanical installation folder. These drawing files provide design elements that help you understand several AutoCAD Mechanical concepts.
Calculating Moments of Inertia and Deflection Lines

Many engineering calculations are automated in AutoCAD® Mechanical. This tutorial illustrates how you calculate the moment of inertia for a profile section, and calculate the deflection line on a beam based on the profile calculation.
### Key Terms

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>bending moment</td>
<td>The moment of all forces that act on the member to the left of a section (a point along the member where bending moment needs to be calculated) taken about the horizontal axis of the section.</td>
</tr>
<tr>
<td>deflection line</td>
<td>A curve representing the vertical displacement of different points along the member subjected to a load.</td>
</tr>
<tr>
<td>distributed load</td>
<td>A load or force that is exerted over a certain length.</td>
</tr>
<tr>
<td>fixed support</td>
<td>A support that prevents translation as well as rotation about all axes.</td>
</tr>
<tr>
<td>load</td>
<td>Force or moment acting on a member or body.</td>
</tr>
<tr>
<td>moment of inertia</td>
<td>An important property of areas and solid bodies. Standard formulas are derived by multiplying elementary particles of area and mass by the squares of their distances from reference axes. Moments of inertia, therefore, depend on the location of reference axes.</td>
</tr>
<tr>
<td>movable support</td>
<td>A support that prevents rotation in all axes, but allows translation along one axis.</td>
</tr>
<tr>
<td>point force</td>
<td>A force that is concentrated on a point.</td>
</tr>
</tbody>
</table>

### Calculating Moments of Inertia and Deflection Lines

The measurement unit for the moment of inertia is mm\(^4\) or inches\(^4\). These are geometric values, which appear in deflection, torsion, and buckling calculation. AutoCAD Mechanical uses the result of the moment of inertia calculation for the deflection line calculation.

Moment of inertia calculations are performed on cross sections of beams or on other objects that can be represented as closed contours. Calculations can be performed on a cross section of any shape, as long as the geometry of the cross section forms a closed contour.
AutoCAD Mechanical determines the center of gravity for a cross section, draws the main axes, and calculates the moment of inertia about each of those axes. You can also select a load direction for a cross section; AutoCAD Mechanical calculates the moment of inertia and angle of deflection for that load.

**NOTE** Before you perform this exercise, verify that the ISO standard part standard is installed.

Load the initial drawing.

**To open a file**

- Open the file *tut_calc* in the *acadm\tutorial* folder.

**Calculating Moments of Inertia**

In order to perform any calculations on a profile, you need to know its moment of inertia.

**To calculate the moment of inertia**

1. Start the calculation for the moment of inertia.
2 Respond to the prompts as follows:
Specify interior point: Click a point inside the profile
Specify interior point: Press ENTER
Is the area filled correctly? (Yes/No)? <Yes>: Press ENTER
The coordinates of the centroid and the moment of inertia along the principle axes are displayed on the command line, as follows:
Coordinates of centroid (in user coordinates):
X coordinate: 228.071933 Y coordinate: 150.027674
Moments of inertia along principal axes:
I1: 2.359e+004 I2: 1.4095e+004
Axis angle for major moment (I1): 5.3
Define the direction of the loads. They must be in one plane.

3 Respond to the prompts as follows:
Specify direction of load forces (must all lie in one plane):
Enter 270, press ENTER
The data for this load direction is displayed on the command line, as follows:
Effective moment of inertia for this load direction: 2.341e+004
Angle of deflection: 266.5
Maximum distances neutral line - border:
Extension side: 16.690 Compression side: 14.444
Enter a description for the calculated profile and locate the block with the calculation data in the drawing.

4 Respond to the prompts as follows:
Enter description: Enter Frame Profile, press ENTER
Specify insertion point: Place the calculation block next to the profile
Your drawing looks like this:
NOTE The main axes, 1 and 2, are the axes with the most and least deflection. The F arrow displays the direction of the force, the s arrow displays the resultant deflection. The moment of inertia block shows the moments related to the main axis, the maximum distances from the edges, and the calculated area. For more detailed information, see Help.

A side view of the profile has been created for the deflection line.

5 Zoom to the extents of the drawing.

**Calculating Deflection Lines**

The calculation of the deflection line requires the calculation result from the moment of inertia calculation.

Calculate the deflection line under a specific load situation.

**To calculate the deflection line**

1 Start the deflection line calculation.
Toolbutton

Menu
Content ➤ Calculations ➤ Deflection Line
Command
AMDEFLINE

2 Respond to the prompts as follows:
Select moment of inertia block: Select the calculation block (1)
Specify starting point or [Existing beam]:
Select the left end of the beam (2)
Specify endpoint: Select the right end of the beam (3)

3 In the Beam Calculation dialog box, choose Table.

4 In the Select Standard for Material dialog box, select ANSI Material.

5 In the Material Type dialog box, select ANSI standard and the material Al. Bronze Cast.

NOTE If you have not installed ANSI standard, selecting a different standard according to your preference is also possible, but the results will differ from the results in this tutorial exercise. For example, if you select DIN, you can select a similar material, like AlMgSi0.5F22, to achieve similar results.
Click OK.
Define the supports and the loads.

6 Choose the Fixed Support icon, and then respond to the prompt as follows:

Specify insertion point:  *Select the left edge of the beam (1)*

**NOTE** The support can only be placed along the beam.

7 Choose the Movable Support icon, and then respond to the prompt as follows:

Specify insertion point:  *Select the right edge of the beam (2)*

8 Choose the Uniform Load icon, and then respond to the prompts as follows:

Specify insertion point:  *Select the left edge of the beam (3)*
Specify endpoint: Select the midpoint of the beam using midpoint snap (4)

Line Load [N/mm]<50>: Enter 10, press ENTER

9 Choose the Moment icon, and then respond to the prompts as follows:

Specify insertion point:
Select a point in the center of the uniform load (5)

Bending moment (Nm)<10>: Enter 3, press ENTER

10 In the Beam Calculation dialog box, choose Moments and Deflection.

11 In the Select Graph dialog box, select the options as shown in the following figure, and then choose OK.

12 Respond to the prompts as follows:

Enter scale for bending moment line (drawing unit:Nm)<1:1.3913>: 

324 | Chapter 15 Calculating Moments of Inertia and Deflection Lines
Press ENTER

Enter scale for deflection (drawing unit:mm)<37.208:1>:

Press ENTER

Specify insertion point: Select a point in the drawing

The result looks like this:

The calculation result block displays all important data on your calculation:

<table>
<thead>
<tr>
<th>Moment of Inertia</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>I1</td>
<td>2350</td>
</tr>
<tr>
<td>I2</td>
<td>14395</td>
</tr>
<tr>
<td>Ileft</td>
<td>23411</td>
</tr>
<tr>
<td>Max. Bending Force</td>
<td>16.49</td>
</tr>
<tr>
<td>Safety Factor</td>
<td>1.3475</td>
</tr>
<tr>
<td>Von Mises</td>
<td>172</td>
</tr>
<tr>
<td>E-Modulus</td>
<td>206861</td>
</tr>
<tr>
<td>Material</td>
<td>Al. Bronze Cast</td>
</tr>
<tr>
<td>Max. Deflection S1</td>
<td>1.257418</td>
</tr>
<tr>
<td>Max. Bending Moment MD1</td>
<td>16.16%</td>
</tr>
<tr>
<td>Max. Deflection S2</td>
<td>1.654856</td>
</tr>
<tr>
<td>Max. Bending Moment MD2</td>
<td>19.31</td>
</tr>
<tr>
<td>Max. Stress Res. (von Mises)</td>
<td>133.98</td>
</tr>
<tr>
<td>Max. Deflection Smes</td>
<td>1.699753</td>
</tr>
<tr>
<td>Max. Bending Moment Mmax</td>
<td>125.90</td>
</tr>
<tr>
<td>Scale for Def. Line</td>
<td>37.208</td>
</tr>
<tr>
<td>Scale for Bending Mom. Line</td>
<td>1.3475</td>
</tr>
</tbody>
</table>

This is the end of this tutorial chapter.
Save your file.
Calculating Chains

In this AutoCAD® Mechanical tutorial, you calculate a chain length, and insert sprockets and chain links into a drawing.

Key Terms

- Chain Calculations

In this chapter
Key Terms

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>partition</td>
<td>Distance in mm or inches between centers of adjacent joint members. Other dimensions are proportional to the pitch. Also known as pitch.</td>
</tr>
<tr>
<td>pitch diameter</td>
<td>The diameter of the pitch circle that passes through the centers of the link pins as the chain is wrapped on the sprocket.</td>
</tr>
<tr>
<td>roller chain</td>
<td>A roller chain is made up of two kinds of links: roller links and pin links alternately and evenly spaced throughout the length of the chain.</td>
</tr>
<tr>
<td>sprocket</td>
<td>A toothed wheel that transfers the power from the chain to the shaft or the other way round.</td>
</tr>
</tbody>
</table>

Chain Calculations

NOTE Before you begin this tutorial exercise, be sure the ISO standard parts are installed on your screen.

Before you begin this tutorial...

This tutorial requires the mechanical browser. If the mechanical browser is not visible:

1 Type AMBROWSER in the command prompt and press ENTER.
2 When prompted, enter ON and press ENTER.

To load the tutorial drawing

1 Open the file tut_chain.dwg in the acadm\tutorial folder.

Menu File ➤ Open
Command OPEN

Save your file under a different name to preserve the original tutorial file.
2 Use a window to Zoom in to the chain housing.

3 Respond to the prompts as follows:
   Specify first corner: Specify first corner point (1)
   Specify opposite corner: Specify second corner point (2)

Performing Length Calculations

To calculate the required length of the chain

1 Start the Length Calculation command.

Performing Length Calculations | 329
2 In the Belt and Chain Length Calculation dialog box, choose Library.

3 In the Library, select ISO 606 metric.

4 In the Select Part Size dialog box, specify:
   Standard: ISO 606 - 05B - 1
   Choose OK.

5 In the Belt and Chain Length Calculation dialog box, choose OK, and then respond to the prompts as follows:
   Specify 1st point for tangent or [Undo] <exit>: Select circle a (1)
Specify 2nd point for tangent: \textit{Select circle c (2)}
Specify 1st point for tangent or [Undo] <exit>: \textit{Select circle c (3)}
Specify 2nd point for tangent: \textit{Select circle b (4)}
Specify 1st point for tangent or [Undo] <exit>: \textit{Select circle b (5)}
Specify 2nd point for tangent: \textit{Select circle a (6)}
Specify 1st point for tangent or [Undo] <exit>: \textit{Press ENTER}

The tangent definition is finished, and the length of the chain is calculated. Because the length is divided into whole numbers of links, one sprocket has to be moved to achieve such a length.

6 Continue responding to the prompts as follows:
Select pulleys or sprockets to be moved. Select objects:
\textit{Select circle b}
Select objects: \textit{Press ENTER}
Specify base point of displacement: \textit{Select the center of circle b}
Specify second point of displacement: \textit{Select the center of the cross (8)}
Select pulleys or sprockets to be moved.
Select objects: \textit{Press ENTER}

AutoCAD Mechanical calculated the new length, which is still not a multiple of the chain division:

Number of links in chain: 121 Distance to next link: 6.88567 mm
Length: 974.8857

Performing Length Calculations | 331
NOTE: You can view the results by resizing the command line or opening the AutoCAD® Text Window using F2.

The chain arrangement has to be optimized to a length that is a multiple of the chain division.
Save your file.

Optimizing Chain Lengths

To optimize the chain length

1. Start the Length Calculation command.

In the Belt and Chain Length Calculation dialog box, select Auto Optimization and Move, and then specify:

   Required Number of Links: 122
Choose OK.

3 Respond to the prompts as follows:
   Select pulleys or sprockets to be moved.
   Select objects: *Select the relocated circle b*
   Select objects: *Press ENTER*
   Specify direction angle to move: *Enter 90, press ENTER*
   Sprocket b is moved until a chain length of 122 links is achieved.

4 In the Belt and Chain Length Calculation dialog box, choose OK. Close the dialog box by clicking Cancel.
   Your drawing looks like this:

   ![Diagram](image)

   Save your file.

**Inserting Sprockets**

To insert the sprocket

1 Start the Draw Sprocket/Pulley command.
   **Toolbutton**

   **Menu**  
   Content ➤ Chains / Belts ➤ Draw Sprocket/Pulley

   **Command**  
   AMSPROCKET
2 In the Select Pulley and Sprocket dialog box, Buttons tab, click Sprockets ➤ Front view.
   Respond to the prompts:
   Specify insertion point: Select the center of circle a
   Specify rotation angle < 0 >: Enter 360, press ENTER

3 In the Sprockets - Size Selection dialog box, select ISO 606 05B-1, and then click Next.

4 In the Sprockets - Geometry dialog box, specify:
   Geometry of Sprocket:
   Number of teeth: 21
   Number of Visible Teeth: 21
   Shaft Diameter: 10

   ![Sprockets - Geometry dialog box]

   Click Finish.
   The sprocket is inserted into the drawing, and the Create Hide Situation is displayed.

5 In the Create Hide Situation dialog box, click OK.
A hide situation is created, and is listed at the top of the tree in the mechanical browser.

Insert the next two sprockets.

6 Start the Draw Sprocket/Pulley command again.

   Toolbutton ➤
   Content ➤ Chains / Belts ➤ Draw Sprocket/Pulley
   Command ➤ AMSPROCKET

7 In the Select Pulley and Sprocket dialog box, Buttons tab, click Sprockets Front view.
   Respond to the prompts:
   Specify insertion point: Select the center of circle b
   Specify rotation angle < 0 >: Enter 360, press ENTER

8 In the Sprockets - Size Selection dialog box, select ISO 606 05B-1, and then click Next.

9 In the Sprockets - Geometry dialog box, specify:
   Geometry of Sprocket:
   Number of teeth: 13
   Number of Visible Teeth: 13
   Shaft Diameter: 10
10 In the Create Hide Situation dialog box, click OK. A hide situation is created, and is listed in the mechanical browser. The sprocket is inserted into the drawing.
Create the next sprocket.

11 Start the Draw Sprocket/Pulley command again.

Menu ➤ Content ➤ Chains / Belts ➤ Draw Sprocket/Pulley
Command AMSPROCKET

12 In the Select Pulley and Sprocket dialog box, Buttons tab, click Sprockets ➤ Front view.
Respond to the prompts:
Specify insertion point: Select the center of circle c
Specify rotation angle < 0 >: Enter 360, press ENTER

13 In the Sprockets - Size Selection dialog box, select ISO 606 05B-1, and then click Next.

14 In the Sprockets - Geometry dialog box, specify:
Geometry of Sprocket:
Number of teeth: 51
Number of Visible Teeth: 3
Shaft Diameter: 10

Choose Finish.

In the Create Hide Situation dialog box, click OK.
A hide situation is created, and is listed in the mechanical browser.
The last sprocket is inserted as a simplified representation with only three teeth, as specified in the dialog box. Your drawing looks like this:

Save your file.
Inserting Chains

To insert a chain

1  Start the Draw Chain/Belt Links command.
   Toolbutton

   Menu  ➤ Chains / Belts ➤ Draw Chain/Belt Links

   Command  AMCHAINDRAW

2  In the Select Belt and Chain dialog box, Buttons tab, choose Chains. Respond to the prompts:
   Select polyline: Select the polyline near point 9
   Select starting point on polyline: Select a point on the polyline

3  In the Select a Chain dialog box, select ISO 606 Metric.

4  In the Chains - Size Selection dialog box, select ISO 606 05B - 1, and then choose Next.

5  In the Chains - Geometry selection dialog box, specify:
   Number of Links: 121

   Click Finish.

6  Respond to the prompts:
Specify direction of Links [Flip/Accept] <Accept>: Press ENTER
Specify orientation of Links [Flip/Accept] <Accept>: Enter F, press ENTER
Specify orientation of Links [Flip/Accept] <Accept>: Press ENTER

7 In the Create Hide Situation dialog box, click OK.
The chain is inserted into the drawing, and a hide situation is created.
Your drawing looks like this:

The mechanical browser reflects the standard components you created in the drawing.

This is the end of this tutorial chapter.
Save your file.
Calculating Springs

In this tutorial, you calculate a spring for existing boundary conditions and insert the spring into a drawing. You copy and edit the spring using the Power Copy and Power Edit commands in AutoCAD® Mechanical.
Key Terms

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Belleville spring washer</td>
<td>A washer-type spring that can sustain relatively large loads with small deflections. The loads and deflections can be increased by stacking the springs.</td>
</tr>
<tr>
<td>compression spring</td>
<td>A spring type that can be compressed and can absorb pressure forces.</td>
</tr>
<tr>
<td>dynamic dragging</td>
<td>The act of determining the size of a standard part with the cursor while inserting the part into a side view. The standard part is displayed dynamically on the screen and can be dragged to the next possible size and length. The values (sizes) are taken from the Standard parts database.</td>
</tr>
<tr>
<td>extension spring</td>
<td>A spring type that can absorb tension forces.</td>
</tr>
<tr>
<td>Power Copy</td>
<td>A command that copies a drawing object to another position in the drawing. Power Copy produces an identical copy of the copied object.</td>
</tr>
<tr>
<td>Power Edit</td>
<td>A single edit command for all objects in a drawing.</td>
</tr>
<tr>
<td>torsion spring</td>
<td>A spring type that can absorb torque forces.</td>
</tr>
</tbody>
</table>

Calculating Springs

With the AutoCAD Mechanical spring function, you can insert compression, extension, and torsion springs, as well as Belleville spring washers. The calculation is carried out in accordance with DIN 2098 or ANSI. The standard sizes of the springs can be selected from various standard catalogs.

NOTE The ISO standard parts have to be installed for this tutorial exercise.

In this tutorial, you create a compression spring in two different compression situations. You calculate and insert the springs in the existing drawing.

Perform this tutorial with mechanical structure disabled.
To open a drawing

1. Open the file `tut_spring.dwg` in the `acadm\tutorial` folder.

   Toolbutton

   Menu File ➤ Open

   Command OPEN

2. Click the STRUCT status bar button and latch it down to enable mechanical structure.

3. Zoom in to the area of the spring housings.

   Toolbutton

   Menu View ➤ Zoom ➤ Window

   Command ZOOM

4. Respond to the prompts as follows:

   Specify first corner: Specify first corner (1)

   Specify opposite corner: Specify opposite corner (2)
The drawing shows two views (A and B) of the lever and spring housing, to reflect two different states of compression. Save your file under a different name or to a different directory to preserve the original tutorial file.

**Starting Spring Calculations**

Specify the spring and the location.

**To specify a spring**

1. Start the Compression Spring command.
   - **Toolbutton**
   - **Menu** Content ➤ Springs ➤ Compression
   - **Command** AMCOMP2D

2. In the Select Compression Spring dialog box, choose Standards ➤ SPEC® Catalog A ➤ Front View.

   ![Select Compression Spring dialog box](image)
Specifying Spring Restrictions

Specify the spring restrictions. Use the Compression Springs dialog box to restrict the spring selection in various ways.

To specify the spring restrictions

1. In the Compression Springs - Select from Table SPEC® Catalog A [mm] dialog box, specify:
   - Specification: 2 Loads, 2 Lengths
   - Absolute Set: Lengths
   - Click the Da button.
A row for specifying the outer diameter Da is added to the restrictions table.

2 Click the value field for the diameter Da. You can pick a point on the inner spring housing to specify the diameter, or enter a value. In this instance, enter the value 15.

Define the initial spring length.

3 In the Compression Springs - Select from Tables SPEC® Catalog A [mm] dialog box, click the value field for the length L1, and then choose the pick icon.
4 Respond to the prompts as follows:

**Specify point for spring length L1:**

*Select a point on the spring pressure plate (1)*

Use view B of the lever and spring housing to define the compressed spring length.

5 In the Compression Springs dialog box, click the value field for the length L2, and then choose the pick icon.
6  Respond to the prompts as follows:

Specify point for spring length L2:

Select a point on the spring pressure plate in view B (1)

The geometric boundary conditions are defined, and you can proceed with the calculation.

**Calculating and Selecting Springs**

Make the calculation settings and calculate the possible springs.
To calculate and select a spring

1. In the Compression Springs - Select from Tables SPEC® Catalog A [mm] dialog box, choose the Additional Calculation Settings button.

2. In the Compression Springs - Additional Calculation [ANSI] dialog, select the left buckling case, and then choose OK.

3. In the Compression Springs - Select from Tables SPEC® Catalog A [mm] dialog box, choose Next.
The possible springs are calculated and the results are displayed in the Compression Springs - Select from Tables SPEC® Catalog A [mm] dialog box.

4 Choose Select All to select all possible springs for the dynamic dragging process.
Choose Finish.

**Inserting Springs**

Drag the cursor dynamically to switch between the selected possible springs. The outline of the spring is displayed in the drawing and the spring description is displayed in the tooltip.

**To insert a spring**

1. Drag the cursor until the tooltip reads SPEC - 1.6 x 14.1 x 36, and then click.

2. Respond to the prompts as follows:
   
   Topical Length (14.28 - 36) [Force/Deflection] <32.01>:

   *Select a point on the spring pressure plate (1)*

3. Continue to respond to the prompts as follows:
   
   Select rod (only closed contours) <Enter=continue>: Press ENTER

   The spring is inserted as shown below.
Save your file.

Creating Views of Springs with Power View

In order to adjust the length of the spring in view B, the springs in the two views need to be different components rather than instances of the same component.

Use the previously inserted spring in view A to create a spring for view B, using the Power View command.

To create a view of a spring with Power View

1. Start the Power View command
   Toolbutton
   Menu Modify ▶ Power Commands ▶ Power View
   Command AMPOWERVIEW

2. Respond to the prompts as follows:
   Select objects: Select the spring in view A

3. In the Select New View dialog box, select Front View.
4 Respond to the prompts:

Specify starting point: Select point (1) in view B
Specify direction: Select point (2) in view B

Topical Length (14.28 - 36)(Force/Deflection)<32.01>:
Select the lower contact point of the compressed spring
Select rod (only closed contours) <Enter=continue>: Press ENTER

The spring is copied into view B in its compressed length.
Save your file.
This is the end of this tutorial chapter.
Calculating Screw Connections

In this tutorial, you calculate a screw connection using the stand-alone screw calculation function in AutoCAD® Mechanical.

In this chapter

- Key Terms
- Methods for Calculating Screws
- Using Stand Alone Screw Calculations
Key Terms

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>axial force</td>
<td>A force parallel to the screw axis.</td>
</tr>
<tr>
<td>contact area</td>
<td>The touching surfaces of the plates, which are effective for the calculation.</td>
</tr>
<tr>
<td>safety factor</td>
<td>The safety factor is the ratio of effective load and safe load.</td>
</tr>
<tr>
<td>shear force</td>
<td>A force perpendicular to the screw axis.</td>
</tr>
<tr>
<td>stress</td>
<td>The force acting on a member or body per unit area.</td>
</tr>
</tbody>
</table>

Methods for Calculating Screws

The Screw Calculation provides two different ways to calculate a screw connection:

- Stand-alone calculation: All data and properties are specified by the user.
- Calculation of an existing screw connection: The user selects an existing screw connection to be calculated. All geometric and standard-related data is taken from the screw connection and cannot be edited.

In this exercise, you use the stand-alone Screw Calculation. With the standalone calculation, you can calculate a screw connection without any prerequisites. You can specify the screw connection in detail (material, geometry, load, settlement and tightening properties). In this exercise, you are provided with the drawing of a screw calculation. Some values are selected from tables, some are entered manually, and some are taken directly from the drawing.

To open the initial drawing

- Open the file tut_screw in the acadm\tutorial folder.

Toolbutton
The drawing contains the representation of a screw connection.

Save your file under a different name or to a different directory to preserve the original tutorial file.

Problem for this exercise:

- Two hollow shafts made of C45 with forged coupling flanges are to be connected by 13 hex-head bolts ISO 4017 M12 x 45 - 10.9, which are arranged at a pitch diameter of 130 mm.
- The through holes are according to ISO 273 close.
- The bolts are safeguarded against loosening by gluing the threads ($\mu = 0.14$). The tightening takes place manually using a torque wrench ($k = 1.8$).
- The flanged connection is to be designed for a alternating torque of $T = 2405 \text{ Nm}$ and non-skid (seal safety of plates 1).

**Using Stand Alone Screw Calculations**

**To start the Screw Calculation**

1. Start the Screw Calculation command.

   **Toolbutton**

   ![Toolbutton]

   **Menu**  ➤  Content ➤  Calculations ➤  Screw Calculation

   **Command**  AMSCREWCALC
2. Respond to the prompts as follows:

Select screw connection <Stand alone calculation>: Press ENTER

The Screw Calculation dialog box opens.
Specify the screw connection.

**Selecting and Specifying Screws**

In the Definition of SCREW section of the screw calculation, you can select
the screw standard and size and the material properties. You can also enter
the geometric properties of a user-defined screw, for example in detail.

**To specify a screw**

1. On the Screw: Geometry tab, choose Table of Screws.

2. In the Select a Screw dialog box, choose Hex Head Types, and then choose
   ISO 4017 (Regular Thread).

3. In the Select a Row dialog box, choose the standard M12x45.
Choose OK.

The geometric values of the standard screw ISO 4017 M12x45 are entered. Specify the property class.

Choose the Material tab and then specify:

Property class: DIN 10.9

The screw is specified completely. Specify the nut.
5 Choose Next or the Definition of NUT icon in the top row to proceed.

**Selecting and Specifying Nuts**

In the Definition of NUT section of the screw calculation, you can select a nut standard and size.

**To specify a nut**

1 On the Nut tab, choose Table of Nuts.

2 In the Select a Nut dialog box, choose Hex Nuts and ISO 4032 (Regular Thread). You do not need to specify a size, because the size is determined by the screw size. Specify the washers.

3 Choose Next or the Definition of WASHERS icon in the top row to proceed.
Selecting and Specifying Washers

In the Definition of WASHERS section of the screw calculation, you can select the washer standard and size and the positions of the washers.

To specify a washer

1. On the Washer under: Head 1 tab, clear the Washer check box.
2. Choose the Washer under: Nut 1 tab, and then choose Table of Washers.
3. In the Select a Washer dialog box, choose ISO 7091.
4. Specify the plates.
5. Choose Next or the Definition of PLATES icon in the top row to proceed.

Specifying Plate Geometry and Properties

In the Definition of PLATES section of the screw calculation, you can select plate materials and their geometric properties.
To specify the plates

1. On the Plates tab, specify:
   - Hole: dh: 13
   - Number of Plates: 2
   - Height of plate 1 h1: 10
   - Height of plate 2 h2: 10

2. For the definition of both plate materials, choose Table.

3. In the Please Select a Part dialog box, choose DIN material.

4. Choose the material Cq 45, and then choose OK.

5. Specify the contact area.

6. On the Gaps and Chamfers tab, choose the pick button of the value gr.

7. Respond to the prompts as follows:
   - Specify first point: Select the point (1)
   - Second point: Select the point (2) as shown in the following figure
The value for gr is changed to 17, as shown in the illustration.

7 Choose Next or the Definition of CONTACT AREA icon in the top row to proceed.
Specifying Contact Areas

In the Definition of CONTACT AREA section of the screw calculation, you can specify the geometric properties of the contact area.

To specify the contact area

1. On the Contact Area tab, choose the Type icon.
2. In the Select the Type of Contact Area dialog box, choose the third of the predefined icons.
3. Select the User Changes check box.
4. In the entry field, specify:
   \[ \text{ang: 22.5} \]
5 For the outer radius ro, choose the pick button next to the entry field and respond to the prompts as follows:
   Specify first point: Select the point (1)
   Second point: Select the point (2)

6 For the inner radius ri, choose the pick button next to the entry field and respond to the prompts as follows:
   Specify first point: Select the point (1)
   Second point: Select the point (3)

Specify the loads and moments.

7 Choose Next or the Definition of LOADS icon in the top row to proceed.

**Specifying Loads and Moments**

In the Definition of LOADS section of the screw calculation, you can specify the loads and moments and their points of application.

**To specify loads and moments**

1 On the Axial Loads tab, clear the Dynamic check box and specify:
Axial force: \( FB: 0 \)

2 Choose the Shear Loads tab and specify:

<table>
<thead>
<tr>
<th>Torsion Moment ( T = )</th>
<th>185 [Nm]</th>
</tr>
</thead>
<tbody>
<tr>
<td>Radius ( R = )</td>
<td>65</td>
</tr>
<tr>
<td>Coefficient of Friction ( m_t = )</td>
<td>0.14</td>
</tr>
</tbody>
</table>

**NOTE** The torsion moment of 185 Nm results from the total torsion moment of 2405 Nm as given in the terms of reference divided by the 13 bolts.
Specify the settlement.

3 Choose Next or the Definition of SETTLEMENT icon in the top row to proceed.

**Specifying Settlement Properties**

In the Definition of SETTLEMENT section of the screw calculation, you can specify settlement properties.

To specify the settlement

1 Activate Calculate from Roughness and >= 1.6 micro m.
Specify the tightening.

2 Choose Next or the Definition of TIGHTEN icon in the top row to proceed.

**Specifying Tightening Properties**

In the Definition of TIGHTEN section of the screw calculation, you can specify the tightening method and properties.

To specify the tightening

1 Specify as follows:

   **Tightening Factor:** \( k_A = 1.5 \)

   **Coefficient of Friction:** in Thread \( m_{ig} = 0.12 \)
Insert the result block.

2 Choose Next or the RESULTS icon in the top row to proceed.

**Creating and Inserting Result Blocks**

In the Results section of the screw calculation, you can take a look at the results.

You have a complete overview of the results of the screw calculation.
Insert the result block.

To insert a result block

- Choose Finish and respond to the prompts as follows:
  - Specify start point: Specify a point right of the screw connection
  - Specify next point <Symbol>: Press ENTER

The result block is inserted at the specified location.

This is the end of this tutorial chapter. Save your file.
In this tutorial, you calculate the stresses in a lever using the finite element analysis (FEA) in AutoCAD® Mechanical. You use the results to improve the design of the lever.
## Key Terms

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>distributed load</td>
<td>A load or force that is exerted over a certain length.</td>
</tr>
<tr>
<td>FEA</td>
<td>Finite Element Analysis. A calculation routine based on analyzing a rigid body subject to loads and restraints for stress, strain, and deformation.</td>
</tr>
<tr>
<td>fixed support</td>
<td>A support that prevents translation as well as rotation about all axes.</td>
</tr>
<tr>
<td>load</td>
<td>Force or moment acting on a member or body.</td>
</tr>
<tr>
<td>movable support</td>
<td>A support that prevents rotation in all axes, but allows translation along one axis.</td>
</tr>
<tr>
<td>Power Edit</td>
<td>A single edit command for the objects in your drawing.</td>
</tr>
<tr>
<td>stress</td>
<td>The force acting on a member or body per unit area.</td>
</tr>
</tbody>
</table>

## 2D FEA

To determine the stability and durability of a given structure under various loading situations, you need to observe the stress and deformation in the components while they are being loaded. A structure is considered to be durable if the maximum stress is less than what the material permits.

There are various computational methods for calculating deformation and stress conditions. One of these methods is called the Finite Element Analysis.

The knowledge gained from this stress rating may lead to changing the structure in certain areas, which in turn necessitates changes to the design.

The FEA routine uses its own layer group for input and output.

Note that FEA is not designed for solving all special FEA tasks. Its purpose is to provide you with a quick idea of the stress and deformation distributions.

**NOTE** The ISO standard parts have to be installed for this tutorial exercise.
For this exercise, work with mechanical structure disabled.

**To open the initial drawing**

1. Open the file *tut_fea.dwg* in the *acadm\tutorial* folder.

   - **Toolbutton**
   - **Menu** File Open
   - **Command** OPEN

   The drawing contains a lever, which is the basis for your calculations.

2. Zoom in to the lever.

   - **Toolbutton**
   - **Menu** View Zoom Window
   - **Command** ZOOM

   The complete lever is displayed on your screen.
Save your file under a different name or to a different directory to preserve the original tutorial file.

**To regenerate the drawing**

- Activate the REGENALL command

  **Menu**  View  Regen All
  **Command**  REGENALL

  The drawing is regenerated.

---

**Calculating Stress In Parts**

Before you calculate the stress in a part, specify the border conditions.

**To specify the border conditions**

1. Activate the FEA calculation

   **Toolbutton**

   **Menu**  Content  ➤  Calculations  ➤  FEA
   **Command**  AMFEA2D

2. Respond to the prompts as follows:

   **Specify interior point:**  *Specify a point inside the contour*

   The FEA 2D Calculation dialog box opens so that you can define border conditions and perform calculations.
Select the thickness and the material of the lever.

3 In the Default section, a thickness of 10.

4 In the Material section, choose Table. Select the material from your preferred standard table, such as Al. Alloys Diecast if you choose ANSI materials.

5 Choose Config to open the FEA Configuration dialog box, and specify:
   Scale Factor for Symbols: 0.1

6 Choose OK to return to the FEA 2D - calculation dialog box.

### Defining Loads and Supports

To perform calculations, you need to define the loads and supports.

**To specify loads and supports**

1 Choose the fixed line support button, and respond to the prompts as follows:
   Specify insertion point <Enter=Dialogbox>: Specify point (1)
Specify endpoint: Specify point (2)
Specify side from endpoint: Specify a point above the contour

2 Choose the movable line support button, and respond to the prompts as follows:
Specify insertion point <Enter=Dialogbox>:
Hold down SHIFT, right-click and choose Quadrant, specify point (3)
Specify endpoint: Press ENTER to define the starting point as the endpoint

3 Choose the line force button, and respond to the prompts as follows:
Specify insertion point <Enter=Dialogbox>: Specify point (5)
Specify endpoint: Specify point (4)
Specify side from endpoint:
Specify a point to the right of the specified points
Enter a new value <1000 N/mm>: Enter 500, press ENTER
4 Choose the line force button again, and respond to the prompts as follows:

Specify insertion point <Enter=Dialogbox>: Specify point (6)

Specify endpoint: Specify point (7)

Specify side from endpoint:

Specify a point to the right of the specified points

Enter a new value <1000 N/mm>: Enter 500, press ENTER

Calculating Results

Before you calculate the results, generate a mesh.

NOTE If you calculate results without creating a mesh in advance, the mesh will be created automatically.

To calculate the results

1 In the Mesh section, choose the mesh button, and then press ENTER to return to the dialog box.
2 In the Results section, choose the isolines (isoareas) button.

3 In the FEA 2D Isolines (Isoareas) dialog box, select the Graphic Representation button on the right.

Choose OK.

4 Respond to the prompts as follows:

Specify base point <Return - in boundary>:
Press ENTER to place the isoareas in the boundary
Insertion point: Select a point to place the table to the left of the part
<Return>: Press ENTER to return to the dialog box

The result looks like this:
After calculation, the support forces are displayed near the support symbol.

**Evaluating and Refining Mesh**

The stress table allocation relative to the lever shows heavy concentration of local stress near drawing points 8 and 9. Refine the mesh near these points to obtain more exact calculation results for the points of interest.

**To refine the mesh**

1. In the Refining section, choose the left refining button, and respond to the prompts as follows:

   Specify center point 1 <Return=Continue>:

   Specify a point near point 8

   Specify center point 2 <Return=Continue>:

   Specify a point near point 9
Specify center point 3 <Return=Continue>:

Press ENTER to continue meshing

<Return>: Press ENTER to return to the dialog box

The mesh is refined at the specified points. Recalculate the stress representation.

2 Choose the isolines (isoareas) button.

3 In the FEA 2D Isolines (Isoareas) dialog box, choose the Graphic Representation button on the right.

Choose OK

4 Respond to the prompts as follows:

Specify base point <Return - in boundary>: Press ENTER

Insertion point: To the left of the part, select a location for the table

<Return>: Press ENTER to return to the dialog box
Refining Designs

The results show a critical area around point 8 that can be improved by applying a larger radius. Before changing the geometry, the results and solutions have to be deleted.

To edit the geometry

1. Choose the Delete Solution button.
2. In the AutoCAD Question dialog box, choose Yes to delete the solutions and results.

3. In the AutoCAD Question dialog box, choose No to keep the loads and supports.

4. Start Power Edit to change the radius, and respond to the prompt as follows:
   - Toolbutton
   - Menu Modify ➤ Power Commands ➤ Power Edit
   - Command AMPOWEREDIT
   - Select object: Select the radius at point 8
   - Enter an option [Next/Accept] <Accept>:
   - Press ENTER to exit the command
In the Fillet Radius dialog box, specify:

Input: 10

Choose OK.

Respond to the prompt:

Select objects: Press ENTER to exit the command

The radius of the fillet is changed to 10.

Zoom to the extents of the drawing.

Menu: View ➤ Zoom ➤ Extents

Command: ZOOM

Save your file.

**Recalculating Stress**

Before recalculating the stress division of the lever, calculate and display the deformation.
To calculate the stress

1. Restart the FEA routine.

   Menu ➤ Content ➤ Calculations ➤ FEA
   Command ➤ AMFEA2D

2. Respond to the prompts as follows:
   Specify interior point: Specify a point inside the contour
   Select the thickness and the material of the lever again, as you did it before.

3. In the Default section, enter a thickness of 10.

4. Choose Table, and select the material from your preferred standard table.
   Select Al. Alloys Diecast if you prefer to use ANSI materials.

5. Choose the deformation button in the Results field.

6. In the FEA 2D - Displacements dialog box, choose OK.

7. Respond to the prompts as follows:
   Specify base point <Return = in boundary>: Press ENTER
   Insertion point: To the right of the part, select a location for the table
   <Return>: Press ENTER to return to the dialog box
   The result looks like this:
Recalculate the stress division of the lever.

1. Choose the isolines (isoareas) button.

2. In the FEA 2D Isolines (Isoareas) dialog box, choose the Graphic Representation button on the right.

Choose OK.
3  Respond to the prompts as follows:
   Specify base point <Return = in boundary>: Press ENTER
   Specify insertion point:
   To the left of the part, select a location for the table
   <Return>: Press ENTER to return to the dialog box

4  Choose Close to leave the FEA 2D - Calculation.
   The final result looks like this:

```
NOTE
You can return to the FEA 2D - Calculation using Power Edit.

This is the end of this tutorial chapter.
Save your file.
```

Recalculating Stress | 385
In this tutorial you use the automated cam design and calculation functionality in AutoCAD® Mechanical to create a cam, perform calculations, and generate data for NC production.
Key Terms

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>acceleration</td>
<td>Rate of change in velocity.</td>
</tr>
<tr>
<td>cam</td>
<td>Types of gears for obtaining unusual and irregular motions that would be difficult to produce otherwise.</td>
</tr>
<tr>
<td>curve path</td>
<td>Geometric shape of the cam.</td>
</tr>
<tr>
<td>motion diagram</td>
<td>Diagram illustrating the lift or rotation of the follower for each degree of rotation or translation of the cam plate.</td>
</tr>
<tr>
<td>motion section</td>
<td>Part of the motion diagram. Some sections are defined by design. For example, the maximum lift of 15 mm is reached at an angle of 90 degrees.</td>
</tr>
<tr>
<td>NC</td>
<td>Numerical Control. Used in manufacturing to represent the control on machine tool motion through numeric data for 2 to 5 axis machining.</td>
</tr>
<tr>
<td>resolution</td>
<td>Controls the precision of curves. A low value increases computing time. Use a higher value for initial design.</td>
</tr>
<tr>
<td>step width</td>
<td>Graph of the speed of the straight driven element, or the rotation angle of a rocker and the cam plate angle of rotation.</td>
</tr>
</tbody>
</table>

Designing and Calculating Cams

With the cam design and calculation functionality in AutoCAD Mechanical, you can implement all motions required in the scope of process control with a minimum number of gear elements. The basis for systematic design procedures is offered using standardized laws of movement in the development of new cam gears.

With the automated cam features, you can create cams (linear, circular, and cylindrical cams) based on sections drawn in a motion diagram. You can also calculate velocity and acceleration of an existing section of the motion diagram. The cam curve path can be determined with the calculated cam
sections. An existing curve path can be scanned and transferred in the motion diagram. A driven element can be coupled to the cam. NC data can be created using the curve path.

In the following exercise, you generate a circular cam and a swinging follower with a single roller. You also calculate the spring of the follower. The cam and the follower are inserted into the drawing together with the motion diagrams. At the end you generate the NC data for the cam production.

Start with an ISO drawing template.

To open a template

1. Open a new drawing.
   Toolbutton
   Menu File ➤ New
   Command NEW

2. The Select template dialog box opens. Select the template *am_iso.dwt* and click Open. This creates a new drawing based on the *am_iso* template. Use Save As to save the drawing file with an appropriate name.

Starting Cam Designs and Calculations

To start a cam design and calculation

1. Open the cam design and calculation tool.
   Toolbutton
   Menu Content ➤ Cams
   Command AMCAM

   Specify the cam type.

2. In the Cam Design and Calculation dialog box, on the Cam tab, specify:
   Type: Circular
   In the Type of Cam dialog box, click the center Circular icon and specify:
   Revolutions [1/min]: 100
   Drawn: Select the check box
Diameter of Body [mm]: 50

3 Choose the Follower button.

**NOTE** You can also step through the dialog using the Next button.

4 On the Follower tab, Movement section, click the Translating button.

5 In the Type of Follower dialog box, choose the Swinging button. You are returned to the CAM Design and Calculation dialog box.
Specify the following settings.

Choose the Profile button, and define the profile. You can select between a power-contact profile (inner or outer) or a form-contact profile (both outer). Specify an inner profile, which requires a spring to keep contact.

Specify the following settings.

6 Choose the Profile button, and define the profile.
You can select between a power-contact profile (inner or outer) or a form-contact profile (both outer). Specify an inner profile, which requires a spring to keep contact.
Specify the following settings.
7 Choose the Location button.
The dialog box is hidden so you can specify a location for the cam and
the follower in the drawing.

8 Respond to the prompts as follows:
Specify center of cam: 100,100, press ENTER
Specify center of follower swing [Undo]: @100,0, press ENTER
Specify start of movement [Undo]: @90<157.36, press ENTER
Specify origin of movement diagram [Undo/Window] <Window>:
Specify a point next to the cam
Specify length of movement diagram [Undo]: @360,0, press ENTER
The cam and the follower are inserted into the drawing with the motion
diagram. Your drawing looks like this:

The Cam Design and Calculation dialog box is opened again.
Defining Motion Sections

Define five motion sections to describe the cam.

To specify motions

1. In the Cam Design and Calculation dialog box, choose the Motions button, and then choose the New button.

In the Select Method to Add New Segment dialog box, you can either insert or append a new motion section.
2 Choose Append.

Define the first motion section.

3 In the Motion - New mode dialog box, specify the following settings.

Position [deg] <from - to> 0 -: 90
Elevation [deg] 0 -: 0

Choose OK.

The motion is inserted into the drawing and you are reverted back to the Cam Design and Calculation dialog.

Define the next motions to describe the cam.

1 In the Cam Design and Calculation dialog box, Motion tab, choose New.
2 In the Select Method to Add New Segment dialog box, choose Append.

3 In the Motion - New mode dialog box, specify the following settings.
   Position [deg] <from - to> 90 - 150
   Elevation [deg] 0 - 5

4 Click the Context of Follower movement button.

5 Choose Dwell - Constant Velocity (second button from left).
6  In the Motion - New mode dialog box, specify the following settings.
   Curve: 5th polynomial
   Velocity \([\text{rad/s}]\) 0 -: 2

Choose OK.

The next motion section has to be ‘Constant Velocity,’ since the motion section before is ‘Dwell - Constant Velocity’.

1  In the Cam Design and Calculation dialog box, Motion tab, choose New.
2  In the Select Method to Add New Segment dialog box, choose Append.
3  In the Motion - New mode dialog, specify the following settings.
   Position [deg] <from - to> 150 -: 180
   Elevation [deg] 5 -: 8
4 Click the Context of Follower movement button.

5 Choose Constant Velocity (leftmost button).

The routine recalculates the elevation and inserts the correct value 10.73. Choose OK.

Define the next motion section.

1 In the Cam Design and Calculation dialog box, Motion tab, choose New.
2 In the Select Method to Add New Segment dialog box, choose Append.
3 In the Motion - New mode dialog box, specify the following settings.
   - Position [deg] <from - to> 180 -: 220
   - Elevation [deg] 10.73 -: 16
4 Click the Context of Follower movement button, and then choose Constant Velocity - Reverse (fourth button from left).
5. In the Motion - New mode dialog box, specify the following settings.

- Acceleration [rad/s^2] 0 - 60

Choose OK.

Define the last motion section to complete the 360 degrees.

1. In the Cam Design and Calculation dialog box, Motion tab, choose New.
2. In the Select Method to Add New Section dialog box, choose Append.
3. In the Motion - New mode dialog, specify the following settings.
   - Position [deg] <from - to> 220 - 360
   - Elevation [deg] 16 - 0

4. Click the Context of Follower movement button.
   The routine calculates the correct values for the end position.

5. In the Motion - New mode dialog box, specify the following settings.
   - Curve: Harmonic Combination
Choose OK.

The definition of the motion section is complete, and all motion sections are displayed in the list.

The definition of the geometry is finished.

**Calculating Strength for Springs**

To calculate the strength for the spring

1. In the Cam Design and Calculation dialog box, select the Strength check box, and then click the Strength button.
2. In the Cam Design and Calculation dialog box, Loads tab, specify:

External Force [N] \( F_e = 20 \)

Reduced Mass of the Follower [kg] \( m_f = 0.1 \)

Reduced Inert Mass [kg] \( m_i = 0.07 \)

3. On the Spring tab, specify:

Preload [N] \( F_0 = 10 \)

Mass of Spring [kg] \( m_s = 0.08 \)

Spring Location [mm] \( l_s = 45 \)

Spring Rate: Select the User Change check box, and then enter 30
4 On the Material tab, you can specify the material for cam and roller. In this case, use the default material.

5 On the Arm tab, specify:

   Dimensions of Arm [mm] \( d = 8 \)

   [Image of Cam Design and Calculation window with 'd = 8']

   **NOTE** You can choose other types of cross sections for the arms.

6 Choose Results, and then choose Calculation.

   [Image of Cam Design and Calculation window with 'Calculation' button highlighted]

   All calculation results are displayed on the respective tabs:

   **Geometry** Displays the geometric properties and enables to optimize the cam position.

   **Calculating Strength for Springs**
Pressure Displays the factor of safety to pressure. You can display the pressure at any point of the cam by choosing Simulation and dragging the mouse pointer over the motion graphs.

Frequency Displays the resonance frequency and the safety against resonance effects.

Shaft Displays the loads on the shaft as well as the necessary drive power for the cam. You can display the shaft loads at any point of the cam by choosing Simulation and dragging the mouse pointer over the cam.

Arm Displays the stress on the arm. You can display the arm stress at any point of the cam by choosing Simulation and dragging the mouse pointer over the cam.

Bearing Displays the middle normal force on the bearing.

Spring Displays the results of the spring calculation. You can display the results at any point of the cam by choosing Simulation and dragging the mouse pointer over the cam.

3D Cam Generates a 3D body of the cam.

The Calculation button gives you the results of your design. To optimize your design, you can choose to generate the correct size of the cam based on the pressure angle and the radius of curvature.

To generate a cam design based on pressure angle and radius of curvature

1. Click the Calculation button.
   To optimize the size of the cam, the pressure angle from your design must be less than or equal to a certain value (automatically calculated and displayed at the bottom of the cam Design and Calculation dialog box) while the radius of curvature must be greater than or equal to a certain value (automatically calculated and displayed at the bottom of the cam Design and Calculation dialog box).

2. Click the Results button.

3. In the Geometry tab, click the Center of Cam button.
   Two hatched open triangles are displayed on the screen.

4. Respond to the prompts as follows:
Press ESC or ENTER to exit, or [Change center of cam]:

*Enter C, press ENTER*

Specify center of cam <100,100>: *Press ENTER*

5 Snap to the apex of the triangle that produces a maximal pressure angle less than or equal to the recommended value and a minimal radius of curvature greater than or equal to the recommended value.

**Exporting Cam Data and Viewing Results**

To export TXT cam data for an NC machine

1 In the Cam Design and Calculation dialog box, click Export.
   On the File tab, specify:
   - Export Curves: Inner
   - Precision [mm]: 0.01
   - Data Type: File: TXT
   - Data Type: Coordinates: Polar

   Choose Generate File.

2 In the Save As dialog box, specify a descriptive file name and a location.
   Choose Save.
   The cam is completely designed and calculated.
To view the results, choose Finish, and then respond to the prompt as follows:

Specify insertion point of result table:

Specify a location for the result table

The table of results is inserted into the drawing.

This is the end of the tutorial chapter.

Save your file.
The tutorial in this section teaches you how to import an Autodesk Inventor® file and generate drawing views from them for documentation. The Autodesk Inventor assembly and part drawings required for this tutorial are available in the Acadm/tutorial/tut_bracket folder of the AutoCAD® Mechanical installation folder.
Using Autodesk Inventor Link Support

In this chapter, you learn how to enable AutoCAD® Mechanical to create views and documentation for Autodesk® Inventor™ assemblies and parts.

In this chapter

- Key Terms
- Linking Autodesk Inventor Part Files
- Exporting Drawing Views to AutoCAD
- Linking Autodesk Inventor Assembly Files
- Updating Autodesk Inventor Parts
Key Terms

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>parametric dimensions</td>
<td>A type of dimension associated with an Autodesk Inventor part model. Parametric dimensions control the size and positions of geometry. If the dimension value is changed, the size and position of the geometry adjusts to reflect the new value. Parametric dimensions can be changed only from Autodesk Inventor.</td>
</tr>
<tr>
<td>power dimensioning</td>
<td>A command useful for generating linear, radial, and diameter dimensions, which minimizes the number of individual actions while generating a dimension. Power dimensioning automatically selects the type of linear dimension (horizontal, vertical, or aligned), based on the selected point.</td>
</tr>
<tr>
<td>reference dimensions</td>
<td>A type of dimension that indicates the size and position of geometry. Reference dimensions do not control the geometry size or position, but follow them instead. The type of dimensions created with power dimensioning commands are reference dimensions.</td>
</tr>
<tr>
<td>template</td>
<td>A file with predefined settings to use for new drawings. However, any drawing can be used as a template.</td>
</tr>
<tr>
<td>title block</td>
<td>A title block contains a series of attributes. Some already have values. The pre-assigned values can be modified, and the vacant attributes can be completed with new values.</td>
</tr>
<tr>
<td>viewport</td>
<td>A scaled view of the model defined in a layout.</td>
</tr>
<tr>
<td>view scale</td>
<td>The scale of the base drawing relative to the model scale. Also, the scale of dependent views relative to the base view.</td>
</tr>
</tbody>
</table>

Linking Autodesk Inventor Part Files

With Autodesk Inventor link support, you can create views of Autodesk Inventor part files while maintaining full model to drawing associativity. Note that the exercises in this chapter can be done only if AutoCAD Mechanical was installed with the Install Autodesk Inventor link option enabled. If
Autodesk Inventor link support is not installed, an error message is displayed when you select the New Inventor link option on the File menu.

**To link an Autodesk Inventor part file**

1. Create a link to the file Holder Bracket.ipt in the acadm\tutorial.
2. Tut_Bracket\Bracket Components folder.
3. In the Select template dialog box, click the template am_ansi.dwt, then click Open.
4. In the Link Autodesk Inventor File dialog box, click Holder Bracket.ipt, then click Open.

**Shading and Rotating Geometry**

Use the Mechanical View toolbar to shade and rotate geometry.

**To shade a part**

1. Activate the Mechanical View toolbar.
Click the Toggle Shading/Wireframe button to shade the part. Use the 3D Orbit tool to rotate the part.

To rotate a part

1. Select the 3D Orbit tool from the Mechanical View toolbar.
2. Place the cursor in the appropriate location inside or on the Arcball.
3. Click and hold the left mouse button, then rotate the part to a position that resembles the following illustration.
4. Right-click, then select Exit from the menu.

Inserting Drawing Borders

If the mechanical browser isn’t visible, complete the following steps.

Menu View ➤ Display ➤ Mechanical Browser
Command AMBROWSER

Desktop browser? [ON/OFF/Auto hide] <ON>: Type ON
To insert a drawing border

1. Click the Drawing tab in the browser.
2. Start the Drawing Title/Borders command.
   Toolbutton
   ![Toolbutton](image)
   Menu
   Annotate ➤ Drawing Title/Revisions ➤ Drawing Title/Borders
   Command
   AMTITLE

3. In the Drawing Borders with Title Block dialog box, specify:
   - Paper Format: C (17.0x22.0 inch)
   - Title Block: US Title Block
   - Scale: 1:1

4. Choose OK.

5. In the Page Setup Manager dialog box, select Layout1, then click Modify.
In the Page Setup - Layout1 dialog box, specify the following value:

Paper size: ANSI C (22.00 x 17.00 Inches)
Choose OK to exit the Page Setup Manager.

Click Close.

Respond to the prompt as follows:

Specify insertion point:  \textit{Enter} -0.25,-0.75, \textit{press} ENTER

In the Change Title Block Entry dialog box, click Next.

In the next page specify:

\texttt{File Name: InventorPart}
12 Choose OK.

13 In the Save Title Block Filename dialog box, verify the following settings:
   - **File Name:** InventorPart.dwg
   - **File of Type:** Drawing (*.dwg)

14 Choose Save.

**Creating Drawing Views**

You can create a variety of drawing view for a part. Any changes made to the part in Autodesk Inventor are automatically updated in the drawing views, when the .dwg file is updated.

When you create a drawing view, the link reads parametric dimensions from the model and adds them to the view.

**To enable creation of parametric dimensions**

1. Open the Options dialog box
   - **Menu** ➤ Assist ➤ Options
   - **Command** OPTIONS or AMOPTIONS

2. Select the AM:Drawing tab.
3 Under Parametric Dimension Display, select the Active Part Views check box.

4 Choose OK.

To create a base view

1 Open the AMDWGVIEW command.
   - Toolbutton
   - Menu Drawing ➤ New View
   - Browser Right-click a Layout icon in the Drawing tab, then choose New View.
   - Command AMDWGVIEW

2 In the Create Drawing View dialog box, specify:
   - View Type: Base
   - Data Set: Select
   - Layout: Layout1
Choose OK.

Respond to the prompts as follows:

Specify location for base view:

*Click in the lower left corner of the graphics area, press ENTER*
The base view is placed in the lower-left corner of the drawing. Parametric dimensions extracted from the Inventor Part file are displayed.
Create an orthogonal view from the base view.

To create an orthogonal view type

1. Open the AMDWGVIEW command.
   - **Toolbutton**: 
   - **Menu**: Drawing ➤ New View
   - **Browser**: Right-click the Base icon in the Drawing tab, then choose New View.
   - **Context Menu**: Right-click in the graphics area, then choose New View.
   - **Command**: AMDWGVIEW

2. In the Create Drawing View dialog box, specify:
   - View Type: Ortho
3 Choose OK.

4 Respond to the prompts as follows:
   Select parent view: *Select the base view*
   Specify location for orthogonal view:
   *Drag to a location above the base view, click to select location*
   Specify location for orthogonal view: *Press ENTER*
The view is placed in the upper-left corner of the drawing. Parametric dimensions read from the Autodesk Inventor part are displayed.
Working with Dimensions

Some of the dimensions need rearranging, while a few may be redundant. You may also need to create dimensions for some entities. Dimensions you add yourself are called reference dimensions. If the part is modified in Autodesk Inventor, these dimensions automatically display the correct part size.

To delete a parametric dimension

1  In the orthogonal view, click the dimension that reads .0450 and press DELETE. The dimension is deleted.
NOTE The dimension you deleted may have been entered as a sketch dimension originally, and extruded later resulting in the redundancy of dimensions.

To move dimensions

1 Click the diameter dimension of 0.8800.

Three grip points are displayed on the dimension.

2 Drag the middle grip outside the bracket, and click. The dimension should be displayed as shown in the following image.
3 You may want to rearrange all the dimensions to tidy up the drawing view.

To add a hole note

1 Start the Leader note command.
   Menu                Annotate ➤ Leader Note
   Command            AMNOTE
2 Respond to the prompts as follows:

Select object to attach [rEorganize]:

In the orthogonal view, click the center of the hole in the middle (1), drag to a placement point (2), click and press ENTER.

![Diagram of a hole with center and placement point indicated]

The Note Symbol ANSI dialog box is displayed.

3 Click OK. The Hole Note is added.

**NOTE** The note text is automatically generated with details extracted from the part file.

**To create a vertical reference dimension**

1 Start the power dimensioning command.

- **Toolbutton**

- **Menu** Annotate ➤ Power Dimensioning

- **Command** AMPOWERDIM

2 Respond to the prompts as follows:

(Single) Specify first extension line origin or [Angular/Options/Baseline/Chain/Update] <Select>: **Press ENTER**

Select arc, line, circle or dimension:

In the orthogonal view, click the end points of the line (1 & 2 shown in the figure below)

Specify dimension line location of [Options/Pickobj]:

Drag the dimension line to the right until it is highlighted in red and click (3)
3 In the Power Dimensioning dialog box, click OK.

4 Press ENTER twice to exit the command.

**NOTE** Parametric dimensions and reference dimensions are shown in different colors.

---

**To create a radial reference dimension**

1 Start the power dimensioning command.
   - **Toolbutton**
     - Annotate ➤ Power Dimensioning
   - **Menu**
     - Annotate ➤ Power Dimensioning
   - **Command**
     - AMPOWERDIM

2 Respond to the prompts as follows:
   - (Single) Specify first extension line origin or
     [Angular/Options/Baseline/Chain/Update] <Select>: Press ENTER
   - Select arc, line, circle or dimension:
     - In the base view, click the circle indicating the hole (1), drag the dimension to a placement point (2) and click

3 In the Power Dimensioning dialog box, click OK.

---

**Exporting Drawing Views to AutoCAD**

It is possible to export a drawing view of a linked drawing such that it can be viewed in AutoCAD® or AutoCAD® LT.
To export a drawing view

1. Start the AMVIEWOUT command.
   - **Menu**: Drawing ➤ Export Views
   - **Browser**: Right-click the Base icon in the Drawing tab, then choose Export.
   - **Command**: AMVIEWOUT

2. In the Export Drawing Views dialog box, from the Source drop-down list, select Select Views/Entities, then click Select.

   ![Export Drawing Views dialog box](image)

   The dialog box is hidden.

3. Respond to the prompts:
   - Select objects to export <all views>: Select the base view
   - Select objects to export <all views>: Press ENTER
   - You are returned to the Export Drawing Views dialog box.

4. In the File Name box, enter the name of a drawing file to export to.

5. Click OK.

6. Save the file.
7 Close AutoCAD Mechanical, start AutoCAD and open the file that you created in step 5.

**Linking Autodesk Inventor Assembly Files**

**To link an Autodesk Inventor assembly file**

1 Create a link to the file `Bracket.iam` in the `acadm\tutorial\ut_Bracket` folder.
   **Menu** File ➤ New Inventor link

2 In the Select template dialog box, click the template `am_ansi.dwt`, then click Open.
   The Link Autodesk Inventor File dialog box is displayed.

3 In files Files of style list, select `*.iam`.

4 Locate and click `Bracket.iam`, then click Open.

**To shade and rotate the assembly**

1 Click the Toggle Shading/Wireframe button to shade the part.
   Use the 3D orbit tool to rotate the part.

2 Select the 3D Orbit tool from the Mechanical View toolbar.

3 Place the cursor in the appropriate location inside or on the Arcball.

4 Click and hold the left mouse button, then rotate the part to a position that resembles the following illustration.
Accessing Parts from the Browser

To select a part from the browser

1. Click a part in the browser. The part is highlighted in model space.
2. Right-click a part and select Zoom-to. The display zooms to the part.

Accessing iProperties

When the assembly file is linked, AutoCAD Mechanical is able to access iProperties through its Bill of Materials (BOM).

To access iProperties

1. Start the BOM command.
   Toolbutton
   Annotate ➤ Part List Tools ➤ BOM Database
   Menu
   Command AMBOM

2. Respond to the prompts as follows:
   Specify BOM to create or set current [Main/?] <MAIN>: Press ENTER
   The BOM dialog box is displayed.
3 Click the + sign in the first column to expand the row.

4 Click Settings. The BOM Settings dialog box is displayed.
5 Click the More button to display More Properties dialog box.

6 Select Part Number and click OK. You are returned to the BOM dialog box. Notice the additional row in the available component properties list.
7  Save the file as Inventor Assembly.dwg.

**Inserting Drawing Borders**

To insert a drawing border

1  Click the Drawing tab in the browser.

2  Start the Drawing Title/Borders command.

   Toolbutton
   
   Menu  ➤ Annotate ➤ Drawing Title/Revisions ➤ Drawing Title/Borders

   Command  AMTITLE

3  In the Drawing Borders with Title Block dialog box, specify:

   Paper Format:  C (17.0x22.0 inch)

   Title Block:  US Title Block

   Scale:  1:1
Retrieve from Assembly Properties: Select

4 Click OK.

5 In the Page Setup Manager dialog box, select Layout1, then click Modify.

6 In the Page Setup - Layout1 dialog box, specify the following value:
   Paper size: ANSI C (22.00 x 17.00 Inches)

7 Choose OK to exit the Page Setup Manager.

8 Click Close.

9 Respond to the prompt as follows:
   Specify insertion point: Enter -0.25,-0.75, press ENTER

10 In the Change Title Block Entry dialog box click Next.
    Observe how the drawing title is displayed using information extracted from the Autodesk Inventor assembly file.

**Creating Parts Lists and Balloons**

You can create a variety of drawing view types for a part, but you must create a base view first. Subsequent changes made to the assembly file in Autodesk Inventor are automatically updated in the drawing views when the drawing file is updated.
To create a base view

1 Create a base view.
   Toolbutton
   Menu Drawing ➤ New View
   Browser Right-click a Layout icon in the Drawing tab, then choose New View.
   Command AMDWGVIEW

2 In the Create Drawing View dialog box, specify:
   View Type: Base
   Data Set: Select
   Layout: Layout1
   Orientation: Top
   Scale: 2.0000

3 Choose OK.

4 Respond to the prompts as follows:
   Specify location for base view:
   Click in the lower left corner of the graphics area, press ENTER
The base view is placed in the lower-left corner of the drawing.

To create the parts list

1. Start the Parts List command.
   
   **Toolbutton**
   
   ![Toolbutton Image]

   **Menu**
   Annotate ➤ Parts List Tools ➤ Parts List

   **Command**
   AMPARTLIST

   The Part List ANSI dialog box is displayed.

2. Click OK.

3. Move the cursor to position the parts lists above the title block, then click to insert the parts list.
To create balloons

1. Start the Balloon command.
   
   **Toolbutton**
   
   **Menu** Annotate ➪ Parts List Tools ➪ Balloons
   
   **Command** AMBALLOON

2. Respond to the prompt as follows:
   
   Select part/assembly or
   [auto/autoAll/Collect/Manual/One/Reorganize]: Enter A
   
   Select pick object: Window select the entire assembly
   
   Select pick object: Press ENTER

3. Place the balloons horizontally above the assembly.
Creating Breakout Section Views

A breakout section view shows hidden details by cutting away portions that block their visibility. In this exercise, you indicate the section to remove by creating a cut line on one view and marking the depth of the cut on another view. Once the breakout section view is generated, you create an isometric view for it.

To create the base view and orthogonal view:

1. Click the Drawing tab in the browser and double-click Layout 2.
2. Start the Drawing Title/Borders command.

   **Toolbutton**
   
   ![Toolbutton Image]

   **Menu**
   
   Annotate ➤ Drawing Title/Revisions ➤ Drawing Title/Borders

   **Command**
   
   AMTITLE
The Drawing Borders with Title Block dialog box is displayed

3 Create a new drawing border for Layout2, following the procedure outlined in Inserting Drawing Borders (page 410).

To create a base view and orthogonal view

1 Start the AMDWGVIEW command.
   Toolbutton
   Menu Drawing ➤ Multiple Views
   Browser Right-click the Layout2 icon in the Drawing tab, then choose New View.
   Command AMDWGVIEW

2 In the Create Drawing View dialog box, specify:
   View Type: Multiple
   Data Set: Select
   Layout: Layout2
   Scale: 1.5
   Display Hidden Lines: Clear the check box

3 Choose OK.

4 Respond to the prompt as follows:
   Select planar face, work plane or
   [Standard view/Ucs/View/worldXy/worldYz/worldZx]: Enter X
   Select work axis, straight edge or [worldX/worldY/worldZ]: Enter X
   Adjust orientation [Flip/Rotate] <Accept>: Press ENTER
   Specify location of base view:
   Position the view in the lower left corner of the graphics area and click
   Specify location of base view or [Done] <next view>: Press ENTER
   Specify location of projected view or [New parent view]:
   Drag to a location above the base view, click to select location
   Specify location of projected view or [Done] <next view>: 

Creating Breakout Section Views | 437
Press ENTER
Specify location of projected view or [New parent view]:
Press ENTER

To create the cut line:

1. Start the creation of a polyline.
   Menu       Design ➤ Polyline
   Command    PLINE

2. Respond to the prompts as follows:
   Specify start point: **Click point (1)**
   Specify next point or [Arc/Halfwidth/Length/Undo/Width]:
     **Click point (2)**
   Specify next point or [Arc/Halfwidth/Length/Undo/Width]:
     **Click point (3)**
   Specify next point or [Arc/Halfwidth/Length/Undo/Width]:
   **Enter close and press ENTER**
A closed polyline is created.

To create a breakout section view

1. Create a base view type.
   **Toolbutton**
   ```
   Drawing ➤ New View
   ```
   **Menu**
   ```
   Right-click the Ortho icon in the Drawing tab, then choose New View.
   ```
   **Browser**
   ```
   Right-click in the graphics area, then choose New View.
   ```
   **Context Menu**
   ```
   Right-click in the graphics area, then choose New View.
   ```
   **Command**
   ```
   AMDWGVIEW
   ```

2. In the Create Drawing View dialog box, specify:
   - **View Type:** Base

3. On the Section Tab, specify
   - **Type:** Breakout
Hatch: Selected

4 Click OK.

5 Respond to the prompts:
   Select first parent view for breakout view:
   *Select the orthogonal view*
   Specify location of base view:
   *Drag just above the base view, click to select the location and press ENTER*

![Diagram showing the selection process]

Select polyline to use as cutline:
*Click the polyline you created in the previous exercise (1)*
Select second parent view for depth selection:
*Select the base view (2)*
Select point for depth of section: *Select point (3)*
The breakout section view is created.
To create an isometric view of the breakout section view:

1. Create an isometric view type.
   - Toolbutton
   - Menu: Drawing ➤ New View
   - Browser: Right-click the Section icon in the Drawing tab, then choose New View.
   - Context Menu: Right-click in the graphics area, then choose New View.
   - Command: AMDWGVIEW

2. In the Create Drawing View dialog box, specify:
   - View Type: Iso

3. Choose OK.

4. Respond to the prompts:
   - Select parent view: Select the breakout section view
Specify location of base view:

Drag to the left of the orthogonal view, click and Press ENTER

**NOTE** The details shown in the view that is generated depend on where you place the view. When you drag to the left, the isometric view that is generated reveals a hole and a screw. They would not be visible if you placed the view elsewhere.

The isometric view is created.

5 Move the isometric view to the right of the orthogonal view.

- **Menu**
  - Drawing ➤ Move View

- **Browser**
  - In the Drawing tab, right-click the Iso icon, then choose Move.

- **Context Menu**
  - Right-click in the graphics area, then choose Move View.

- **Command**
  - AMMOVEVIEW

6 Respond to the prompts:

- Select view to move: **Select the isometric view**
Modifying Breakout Section Views

The cut line used to generate the breakout section view can be modified and breakout section view regenerated. Under normal circumstances, the cut line is not visible. To modify the cut line, you must display it first.

To display the cutline:

   - **Browser**: Right-click the Section icon in the Drawing tab, then choose Re-Select Cutline.
   - **Command**: AMEDITPSCUTLINE

2. Respond to the prompts:
   - **Select broken-out section view**: Click the breakout section view
Enter an option for paperspace cutline [Display/Select]  
<Display>: Press ENTER  
The cut line is displayed.

3 Modify the cutline to any shape you want it to be.

4 Start the Edit Paper Space Cut Line command.  
Browser Right-click the Section icon in the Drawing tab, and then choose Re-Select Cutline.  
Command AMEDITPSCUTLINE

5 Respond to the prompts.  
Select broken-out section view: Click the breakout section view  
Enter an option for paperspace cutline [Display/Select]  
<Display>: Enter 5  
Select polyline to use as cutline: Click the edited polyline  
The breakout section view and the isometric view update.
Removing Views

You can remove views, even though that view may have been used to derive other views.

To delete the base view:

1. Right-click the base view icon in the browser and select Delete. The Delete dependent views dialog box is displayed.
2. Click No. The base view is deleted.
3. Save the file and close AutoCAD Mechanical.
Updating Autodesk Inventor Parts

If you have access to Autodesk Inventor (version 8 or above), you can modify the part file using Autodesk Inventor, then update the part in AutoCAD Mechanical to reflect the change.

To edit a dimension using Autodesk Inventor

1. Open *Holder Bracket.ipt* in Autodesk Inventor.
2. Edit a feature.
3. Save the modified part file.

When the part file has been modified outside AutoCAD Mechanical, on the browser, the affected views are highlighted in yellow. Additionally, a balloon is displayed on the status bar informing you that a newer version is now available. To bring in the modifications, you must update the part file.

To update the part file

1. Use AutoCAD Mechanical to open the Assembly file or Part file that was used in this exercise.
2. Observe how the browser indicates the parts and views affected by the part modification.
3. Start the update command.
   - **Browser** Right-click the yellow part node, then choose Update.
   - **Command** AMIVUPDATE
4. Verify that your part has been modified.
   - You are notified of the number of drawing views that have been updated.
   - Save your file.

This is the end of this tutorial chapter.
Layer Specifications

This appendix contains a list of the layer specifications for AutoCAD® Mechanical.

In this appendix

- Layer Specification Listing
## Layer Specification Listing

The AutoCAD Mechanical layer system is comprised of the following layers:

<table>
<thead>
<tr>
<th>Description</th>
<th>Name</th>
<th>Color</th>
<th>Linetype</th>
<th>Lineweight</th>
<th>Base</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contour</td>
<td>AM_0</td>
<td>7</td>
<td>ISO: Continuous</td>
<td>ISO: 0.5mm/ANSI:</td>
<td>no</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>ANSI: Continuous</td>
<td>0.3mm=0.012’</td>
<td></td>
</tr>
<tr>
<td>Contour</td>
<td>AM_1</td>
<td>14</td>
<td>ISO: Continuous</td>
<td>ISO: 0.5mm/ANSI:</td>
<td>no</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>ANSI: Continuous</td>
<td>0.3mm=0.012’</td>
<td></td>
</tr>
<tr>
<td>Contour</td>
<td>AM_2</td>
<td>5</td>
<td>ISO: Continuous</td>
<td>ISO: 0.5mm/ANSI:</td>
<td>no</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>ANSI: Continuous</td>
<td>0.3mm=0.012’</td>
<td></td>
</tr>
<tr>
<td>Hidden</td>
<td>AM_3</td>
<td>6</td>
<td>ISO: AM_ISO02W050</td>
<td>ISO: 0.25mm/ANSI:</td>
<td>no</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>ANSI: Hidden</td>
<td>0.15mm=0.006’</td>
<td></td>
</tr>
<tr>
<td>Auxiliary Line</td>
<td>AM_4</td>
<td>3</td>
<td>ISO: Continuous</td>
<td>ISO: 0.25mm/ANSI:</td>
<td>no</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>ANSI: Continuous</td>
<td>0.15mm=0.006’</td>
<td></td>
</tr>
<tr>
<td>Dimension/Annotation</td>
<td>AM_5</td>
<td>3</td>
<td>ISO: Continuous</td>
<td>ISO: 0.25mm/ANSI:</td>
<td>no</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>ANSI: Continuous</td>
<td>0.15mm=0.006’</td>
<td></td>
</tr>
<tr>
<td>Text</td>
<td>AM_6</td>
<td>2</td>
<td>ISO: Continuous</td>
<td>ISO: 0.35mm/ANSI:</td>
<td>no</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>ANSI: Continuous</td>
<td>0.3mm=0.012’</td>
<td></td>
</tr>
<tr>
<td>Centerline</td>
<td>AM_7</td>
<td>4</td>
<td>ISO: AM_ISO08W050</td>
<td>ISO: 0.25mm/ANSI:</td>
<td>no</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>ANSI: Center</td>
<td>0.15mm=0.006’</td>
<td></td>
</tr>
<tr>
<td>Description</td>
<td>Name</td>
<td>Color</td>
<td>Linetype</td>
<td>Lineweight</td>
<td>Base</td>
</tr>
<tr>
<td>-------------------</td>
<td>-------</td>
<td>-------</td>
<td>--------------</td>
<td>-----------------------------</td>
<td>------</td>
</tr>
</tbody>
</table>
| Hatch             | AM_8  | 1     | ISO: Continuous
                      ANSI: Continuous | ISO: 0.25mm/ANSI: 0.15mm=0.006' | no   |
| Behind            | AM_9  | 253   | ISO: Continuous
                      ANSI: Continuous | 0               | no   |
| Section Line      | AM_10 | 7     | ISO:
                      AM_ISO08W050
                      ANSI: Center | ISO: 0.5mm/ANSI:
                      0.3mm=0.012' | no   |
| Phantom           | AM_11 | 3     | ISO:
                      AM_ISO09W050
                      ANSI: Phantom2 | ISO: 0.25mm/ANSI:
                      0.15mm=0.006' | no   |
| Part Reference Objects | AM_12 | 7     | ISO: Continuous
                      ANSI: Continuous | ISO: 0.5mm/ANSI:
                      0.3mm=0.012' | no   |
| Std. Parts: Contour | AM_0N | 7     | ISO: Continuous
                      ANSI: Continuous | ISO: 0.5mm/ANSI:
                      0.3mm=0.012' | no   |
| Std. Parts: Contour | AM_1N | 14    | ISO: Continuous
                      ANSI: Continuous | ISO: 0.5mm/ANSI:
                      0.3mm=0.012' | no   |
| Std. Parts: Contour | AM_2N | 5     | ISO: Continuous
                      ANSI: Continuous | ISO: 0.5mm/ANSI:
                      0.3mm=0.012' | no   |
| Std. Parts: Hidden | AM_3N | 6     | ISO:
                      AM_ISO02W050
                      ANSI: Hidden | ISO: 0.25mm/ANSI:
                      0.15mm=0.006' | no   |
<table>
<thead>
<tr>
<th>Description</th>
<th>Name</th>
<th>Color</th>
<th>Linetype</th>
<th>Lineweight</th>
<th>Base</th>
</tr>
</thead>
<tbody>
<tr>
<td>Std. Parts: Auxiliary Line</td>
<td>AM_4N</td>
<td>3</td>
<td>ISO: Continuous</td>
<td>ISO: 0.25mm/ANSI: 0.15mm=0.006'</td>
<td>no</td>
</tr>
<tr>
<td>Std. Parts: Dimension /Annotation</td>
<td>AM_5N</td>
<td>3</td>
<td>ISO: Continuous</td>
<td>ISO: 0.25mm/ANSI: 0.15mm=0.006'</td>
<td>no</td>
</tr>
<tr>
<td>Std. Parts: Text</td>
<td>AM_6N</td>
<td>2</td>
<td>ISO: Continuous</td>
<td>ISO: 0.35mm/ANSI: 0.3mm=0.012'</td>
<td>no</td>
</tr>
<tr>
<td>Std. Parts: Centerline</td>
<td>AM_7N</td>
<td>4</td>
<td>ISO: AM_ISO08W050 ISO: Center</td>
<td>ISO: 0.25mm/ANSI: 0.15mm=0.006'</td>
<td>no</td>
</tr>
<tr>
<td>Std. Parts: Hatch</td>
<td>AM_8N</td>
<td>1</td>
<td>ISO: Continuous</td>
<td>ISO: 0.25mm/ANSI: 0.15mm=0.006'</td>
<td>no</td>
</tr>
<tr>
<td>Std. Parts: Behind</td>
<td>AM_9N</td>
<td>253</td>
<td>ISO: Continuous</td>
<td>0</td>
<td>no</td>
</tr>
<tr>
<td>Std. Parts: Section Line</td>
<td>AM_10N</td>
<td>7</td>
<td>ISO: AM_ISO08W050 ISO: Center</td>
<td>ISO: 0.5mm/ANSI: 0.3mm=0.012'</td>
<td>no</td>
</tr>
<tr>
<td>Std. Parts: Phantom</td>
<td>AM_11N</td>
<td>3</td>
<td>ISO: AM_ISO09W050 ISO: Phantom2</td>
<td>ISO: 0.25mm/ANSI: 0.15mm=0.006'</td>
<td>no</td>
</tr>
<tr>
<td>Std. Parts: Part Reference Objects</td>
<td>AM_12N</td>
<td>7</td>
<td>ISO: Continuous</td>
<td>ISO: 0.5mm/ANSI: 0.3mm=0.012'</td>
<td>no</td>
</tr>
<tr>
<td>Description</td>
<td>Name</td>
<td>Color</td>
<td>Linetype</td>
<td>Lineweight</td>
<td>Base</td>
</tr>
<tr>
<td>-----------------</td>
<td>--------</td>
<td>-------</td>
<td>------------</td>
<td>--------------------</td>
<td>------</td>
</tr>
<tr>
<td>Construction Line</td>
<td>AM_CL</td>
<td>1</td>
<td>ISO: Amconstr ANSI: Amconstr</td>
<td>ISO: 0.25mm/ANSI: 0.15mm=0.006'</td>
<td>yes</td>
</tr>
<tr>
<td>Part Reference</td>
<td>AM_PAREF</td>
<td>4</td>
<td>ISO: Continuous ANSI: Continuous</td>
<td>ISO: 0.25mm/ANSI: 0.15mm=0.006'</td>
<td>yes</td>
</tr>
<tr>
<td>Border/Title Block</td>
<td>AM_BOR</td>
<td>7</td>
<td>ISO: Continuous ANSI: Continuous</td>
<td>ISO: 0.5mm/ANSI: 0.3mm=0.012'</td>
<td>yes</td>
</tr>
<tr>
<td>Viewport</td>
<td>AM_VIEW</td>
<td>1</td>
<td>ISO: Continuous ANSI: Continuous</td>
<td>ISO: 0.25mm/ANSI: 0.15mm=0.006'</td>
<td>yes</td>
</tr>
</tbody>
</table>
| Behind (extra)  | AM_INV  | 253   | ISO: Continuous ANSI: Continuous | 0
| Trailing Line   | AM_TR   | 3     | ISO: Continuous ANSI: Continuous | ISO: 0.25mm/ANSI: 0.15mm=0.006' | yes  |
Title Block Attributes

This appendix helps you to learn about the AutoCAD®
Mechanical title block attributes.

In this appendix
- Attributes for Title Blocks
Attributes for Title Blocks

AutoCAD Mechanical offers several different title blocks you can choose from. To customize these title blocks, it is important to understand their attributes. This appendix will give you an overview which text and attributes are available in a title block, and their location within the title block structure.

When a title block drawing is inserted, it is displayed with attributes, curly brackets, and text messages, that refer to the message files from which the attribute is called.

Attribute Definitions

The following definitions are assigned to the attributes used in the title block:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>GEN-TITLE-NR</td>
<td>Drawing Number</td>
</tr>
<tr>
<td>GEN-TITLE-DWG</td>
<td>File Name</td>
</tr>
<tr>
<td>GEN-TITLE-MAT1</td>
<td>Material</td>
</tr>
<tr>
<td>GEN-TITLE-MAT2</td>
<td>Material (second line)</td>
</tr>
<tr>
<td>GEN-TITLE-DES1</td>
<td>Drawing Name</td>
</tr>
</tbody>
</table>
### Attribute Definitions for Title Block and Drawing Border

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GEN-TITLE-DES2</td>
<td>Subtitle</td>
</tr>
<tr>
<td>GEN-TITLE-NAME</td>
<td>Name of the Draftsperson</td>
</tr>
<tr>
<td>GEN-TITLE-QTY</td>
<td>Quantity</td>
</tr>
<tr>
<td>GEN-TITLE-SCA</td>
<td>Scale Factor</td>
</tr>
<tr>
<td>GEN-TITLE-POSI</td>
<td>Position Number</td>
</tr>
<tr>
<td>GEN-TITLE-CHKM</td>
<td>Checked By</td>
</tr>
<tr>
<td>GEN-TITLE-CHKD</td>
<td>Check Date</td>
</tr>
<tr>
<td>GEN-TITLE-DAT</td>
<td>Completion Date</td>
</tr>
<tr>
<td>GEN-TITLE-SHEET</td>
<td>Page</td>
</tr>
<tr>
<td>GEN-TITLE-PLOT</td>
<td>Plot Date</td>
</tr>
</tbody>
</table>

### Curly Brackets

The curly brackets behind the attribute display the ratio of the defined width for the text to the text height.

Example: If you want to enter a text with the height of 5 units, and the width of the available space is 100 units, the value \{20\} has to be entered. In this case the text is fit exactly. If a text with a greater height is inserted afterwards (for example 8), the value in the curly brackets also has to be adjusted (to \{12.5\}); otherwise, the text is displayed outside the available space.
Message Files

Message files are text files that contain the attributes which are displayed in the Change Title Block Entry dialog when you are inserting a drawing border. These attributes change, depending on the selected drawing border and standard.

The message files can be found in the `acadm/translator` directory. You can modify or extend the message files to meet your specifications.
Accelerator and Shortcut Keys

Use this appendix as a guide to the AutoCAD® Mechanical accelerator keys and shortcut keys.

In this appendix

- Accelerator Keys
Accelerator Keys

Many frequently used commands are accessible using automated shortcuts known as accelerator keys. Accelerator keys are available for AutoCAD as well as for AutoCAD® Mechanical.

**WARNING** Accelerator keys are loaded when you install AutoCAD Mechanical. Accelerator keys specific to AutoCAD Mechanical are appended at the end of the `acad.pgp` file. If you have created custom accelerator keys with the same letter combinations as those in the following table, they will be superseded because the last entry in the file is activated by the keystrokes. To restore custom accelerator keys, move the definition to the end of the `acad.pgp` file.

To use an accelerator key to start a command

1. On the command line, enter the key(s) that correspond to the command you want to use.
2. Press ENTER, the spacebar, or the right mouse button to execute the command.

### Accelerator keys available in AutoCAD Mechanical

<table>
<thead>
<tr>
<th>Key</th>
<th>Function</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>bal</td>
<td>Place Balloon</td>
<td>AMBALLOON</td>
</tr>
<tr>
<td>cb</td>
<td>Centerline Cross with Hole</td>
<td>AMCENCRIHOLE</td>
</tr>
<tr>
<td>cha</td>
<td>Chamfer</td>
<td>AMCHAM2D</td>
</tr>
<tr>
<td>cl</td>
<td>Centerline</td>
<td>AMCENTLINE</td>
</tr>
<tr>
<td>clin</td>
<td>Draw C-Lines</td>
<td>AMCONSTLINES</td>
</tr>
<tr>
<td>cloo</td>
<td>C-Lines ON/OFF</td>
<td>AMCLINEO</td>
</tr>
<tr>
<td>cr</td>
<td>Copy+Rotate+Move</td>
<td>AMMANNERUPUTATE</td>
</tr>
<tr>
<td>cs</td>
<td>Centerline Cross</td>
<td>AMCENCROSS</td>
</tr>
</tbody>
</table>
### Accelerator keys available in AutoCAD Mechanical

<table>
<thead>
<tr>
<th>Key</th>
<th>Function</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>dan</td>
<td>Angle Dimensioning</td>
<td>AMPOWERDIM_ANG</td>
</tr>
<tr>
<td>dau</td>
<td>Automatic Dimensioning</td>
<td>AMAUTODIM</td>
</tr>
<tr>
<td>dmed</td>
<td>Multi Edit</td>
<td>AMDIMMEDIT</td>
</tr>
<tr>
<td>f</td>
<td>Fillet</td>
<td>AMFILLET2D</td>
</tr>
<tr>
<td>h</td>
<td>User Defined Hatch</td>
<td>AMUSERHATCH</td>
</tr>
<tr>
<td>hioo</td>
<td>Invisible Lines ON/OFF</td>
<td>AMLAYINVO</td>
</tr>
<tr>
<td>10</td>
<td>Layer AM_0</td>
<td>AMLAYER</td>
</tr>
<tr>
<td>11</td>
<td>Layer AM_1</td>
<td>AMLAYER</td>
</tr>
<tr>
<td>12</td>
<td>Layer AM_2</td>
<td>AMLAYER</td>
</tr>
<tr>
<td>13</td>
<td>Layer AM_3</td>
<td>AMLAYER</td>
</tr>
<tr>
<td>14</td>
<td>Layer AM_4</td>
<td>AMLAYER</td>
</tr>
<tr>
<td>15</td>
<td>Layer AM_5</td>
<td>AMLAYER</td>
</tr>
<tr>
<td>16</td>
<td>Layer AM_6</td>
<td>AMLAYER</td>
</tr>
<tr>
<td>17</td>
<td>Layer AM_7</td>
<td>AMLAYER</td>
</tr>
<tr>
<td>18</td>
<td>Layer AM_8</td>
<td>AMLAYER</td>
</tr>
<tr>
<td>110</td>
<td>Layer AM_10</td>
<td>AMLAYER</td>
</tr>
<tr>
<td>111</td>
<td>Layer AM_11</td>
<td>AMLAYER</td>
</tr>
</tbody>
</table>
### Accelerator keys available in AutoCAD Mechanical

<table>
<thead>
<tr>
<th>Key</th>
<th>Function</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>lib</td>
<td>Library</td>
<td>AMLIBRARY</td>
</tr>
<tr>
<td>lg</td>
<td>Layer/Layer Group Control</td>
<td>AMLAYER</td>
</tr>
<tr>
<td>lgo</td>
<td>Move to another Layer Group</td>
<td>AMLGMOVE</td>
</tr>
<tr>
<td>lgv</td>
<td>Layer Group Visibility</td>
<td>AMLAYVISENH</td>
</tr>
<tr>
<td>lmo</td>
<td>Move to another Layer</td>
<td>AMLAYMOVE</td>
</tr>
<tr>
<td>o</td>
<td>Offset</td>
<td>AMOFFSET</td>
</tr>
<tr>
<td>oo</td>
<td>3DOrbit</td>
<td>3DORBIT</td>
</tr>
<tr>
<td>par</td>
<td>Create Part Reference</td>
<td>AMPARTREF</td>
</tr>
<tr>
<td>pc</td>
<td>Power Copy</td>
<td>AMPOWERCOPY</td>
</tr>
<tr>
<td>pd</td>
<td>Power Dimensioning</td>
<td>AMPOWERDIM</td>
</tr>
<tr>
<td>ped</td>
<td>Power Edit</td>
<td>AMPOWEREDIT</td>
</tr>
<tr>
<td>per</td>
<td>Power Erase</td>
<td>AMPOWERERASE</td>
</tr>
<tr>
<td>prc</td>
<td>Power Recall</td>
<td>AMPOWERRECALL</td>
</tr>
<tr>
<td>proo</td>
<td>Part Reference Layer ON/OFF</td>
<td>AMLAYPARTREFO</td>
</tr>
<tr>
<td>pss</td>
<td>Power Snap Settings 1-4</td>
<td>AMPOWERSNAP</td>
</tr>
<tr>
<td>Q</td>
<td>Create View</td>
<td>AMDWGVVIEW</td>
</tr>
<tr>
<td>QQ</td>
<td>Edit View</td>
<td>AMEDITVIEW</td>
</tr>
</tbody>
</table>
## Accelerator keys available in AutoCAD Mechanical

<table>
<thead>
<tr>
<th>Key</th>
<th>Function</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>rec</td>
<td>Rectangle</td>
<td>AMRECTANG</td>
</tr>
<tr>
<td>s1</td>
<td>Power Snap Settings 1</td>
<td>AMPSNAP1</td>
</tr>
<tr>
<td>s2</td>
<td>Power Snap Settings 2</td>
<td>AMPSNAP2</td>
</tr>
<tr>
<td>s3</td>
<td>Power Snap Settings 3</td>
<td>AMPSNAP3</td>
</tr>
<tr>
<td>s4</td>
<td>Power Snap Settings 4</td>
<td>AMPSNAP4</td>
</tr>
<tr>
<td>sm</td>
<td>Scale Monitor</td>
<td>AMSCMONITOR</td>
</tr>
<tr>
<td>stoo</td>
<td>Standard Parts Layer ON/OFF</td>
<td>AMLAYPARTO</td>
</tr>
<tr>
<td>tioo</td>
<td>Title Block Layer ON/OFF</td>
<td>AMLAYTIBLO</td>
</tr>
<tr>
<td>txl</td>
<td>Language Converter</td>
<td>AMLANGCONV</td>
</tr>
<tr>
<td>u0</td>
<td>Units 0</td>
<td>AMUNIT_0</td>
</tr>
<tr>
<td>u1</td>
<td>Units 1</td>
<td>AMUNIT_1</td>
</tr>
<tr>
<td>u2</td>
<td>Units 2</td>
<td>AMUNIT_2</td>
</tr>
<tr>
<td>u3</td>
<td>Units 3</td>
<td>AMUNIT_3</td>
</tr>
<tr>
<td>u4</td>
<td>Units 4</td>
<td>AMUNIT_4</td>
</tr>
<tr>
<td>v1</td>
<td>Upper Left</td>
<td>AMVIEWUL</td>
</tr>
<tr>
<td>v2</td>
<td>Upper Right</td>
<td>AMVIEWUR</td>
</tr>
<tr>
<td>v3</td>
<td>Lower Left</td>
<td>AMVIEWLL</td>
</tr>
</tbody>
</table>
### Accelerator keys available in AutoCAD Mechanical

<table>
<thead>
<tr>
<th>Key</th>
<th>Function</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>v4</td>
<td>Lower Right</td>
<td>AMVIEWLR</td>
</tr>
<tr>
<td>v5</td>
<td>Center</td>
<td>AMVIEWCEN</td>
</tr>
<tr>
<td>val</td>
<td>View All</td>
<td>AMVIEWALL</td>
</tr>
<tr>
<td>vpo0</td>
<td>Viewport Layer ON/OFF</td>
<td>AMLAYVPO</td>
</tr>
</tbody>
</table>
Index

A
acceleration 388
adjusting rings 16
angular dimensions 30, 177
annotation views 66, 104
associative 106, 166
hide 106
views 166
Autodesk Inventor link option 408
Autodesk Inventor linked models 409, 415, 418, 427, 433, 436, 439, 441, 446
base views 415, 433
breakout section views 436, 439
isometric views 441
multiple views 436
orthogonal views 418
shade and rotate 409, 427
update 446
Automatic Dimensioning dialog box 172
automatic dimensions 171

B
balloons 244, 249, 435
base layers 56, 114, 152
base views 415, 433
for assembly files 433
for part files 415
baseline dimensions 170
Beam Calculation dialog box 322
bearing calculations 278, 294
bearings, plain 29
belleville spring washers 17, 342
Belt and Chain Length Calculation dialog box 330
belts 19
bending moments 34, 300, 318
bills of material 17, 244
blind holes 17, 39, 231
blind slots 18, 39
bolts 33
BOM databases 17, 244, 250
border conditions in stress calculations 374
break dimensions 22, 179
breakout section views, assembly files 436, 439
breaks in shafts 288
browser 66
mechanical 66

C
calculations on bearings 17, 294
Cam Design and Calculation dialog box 389, 393, 399, 403
cams 388
centerholes 19
centerlines 170, 237
centroids 320
chains 19, 327–329, 338
calculations 327
length calculations 329
partitions 328
pitch diameters 328
roller 328
sprockets 328
chamfers 278, 287
Change Title Block Entry dialog box 413, 432
circlets 24
clevis pins 19
command access methods 5
command summary 16
components 66, 76, 94–96, 98, 101, 103
external reference 96, 101, 103
externalize local 103
ghost 94
insert views of external 98
mechanical structure 66
mechanical structure folders 66
restructure 95
view 76
compression springs 342
construction lines 23, 128, 132, 202, 238
Construction Lines dialog box 133
contact areas in screw calculations 364
context menu command access 5
contours 27, 132, 143, 186, 202
backgrounds and foregrounds 186, 202
hatch patterns 143
lines 132
visibility 27
cotter pins 21
counterbores 21, 39
countersinks 21, 39, 202
countersunk rivets 21
Create Drawing View dialog box 415, 418, 433, 437, 439, 441
cross-hatches 143
crosshairs 30
curve paths on cams 388
custom filters for parts lists 274
cutlines 438
cutting planes 34
cylinders in shafts 283
cylindrical pins 21

D
default layers 114
deflection lines 34, 300, 318, 321
desktop menu command access 5
detail dialog box 147
detail views 128, 146, 152, 156
deviations to dimensions 145
Automatic Dimensioning 172
Beam Calculation 322
Belt and Chain Length Calculation 330
Cam Design and Calculation 389
Change Title Block Entry 413, 432
Construction Lines 133
Create Drawing View 415
Create Drawing View 418, 433, 437, 439, 441
detail 147
Drawing Borders with Title Block 180, 431
drawing borders with title block 411
Edit Attributes 181
Export Drawing Views 426
FEA 2D Calculation 374
FEA 2D Isolines (Isoareas) 378
FEA Configuration 375
Fillet Radius 139
Gear 306
Layer Control 57, 117, 119, 123, 166
Library 27
List of Filters 271
Material 303
Material Properties 304
Material Type 322
Nominal Diameter 162
Options 58, 414
Page Setup Manager 411, 432
Page Setup-Layout 412, 432
Part Ref Attributes 246, 248, 254
Parts List 259
Point Load 306
Power Dimensioning 145, 149, 164, 170
Power Snap Settings 132, 280
Pulleys and Sprockets 334
Save Drawing As 60
Save Title Block Filename 414
Scale Area 154
Screw Assembly Grip Representation
- Front View 209
Screw Assembly Templates 218
Screw Calculation 358
Screw Connection New Part Front View 223
Screw Diameter Estimation 219
Select a Blind Hole 232
Select a Cylindrical Pin 234
Select a Nut 360
Select a Row 358
Select a Screw 205, 358
Select Graph 308, 324
Select Part Size 236, 330
Select Template 129, 279, 409, 427
Set Value 260, 269
Shaft Calculation 303
Shaft Generator 281
Sort 268
Standard Parts Database 36
Switch Representation of Standard Parts 240
Template Description 61
Torque 307
Type of Follower 390
View 158, 167
Visibility Enhancement 123
angular 177
automatic 171
baseline 170
breaks 22, 179
contours 144
deviations 145
multi edit 170, 178
parametric 414, 421
radial 425
reference 424
distance snaps 128
distributed loads 318, 372
drawing borders 39, 180, 411, 431
Drawing Borders with Title Block dialog box 180, 411, 431
drawing views 411, 414, 426, 431–432
export to AutoCAD 426
insert drawing borders 411, 431
drawings 56, 60, 62, 170
borders 170
default templates 62
layers 56
limits 56, 60
new 62
templates 56, 60
drill bushings 22
durability calculations 372
dynamic calculations 278
dynamic dragging 202, 278, 342
E
edge symbols 23
Edit Attributes dialog box 181
Export Drawing Views dialog box 426
export drawing views to AutoCAD 426
extension springs 23, 342
external reference components 96, 101, 103
external threads 23
F
fatigue factors 300
FEA (Finite Element Analysis) 372
FEA 2D Calculation dialog box 374
FEA 2D Isolines (Isoareas) dialog box 378
FEA Configuration dialog box 375
feature control frame symbols 24
feature identifier symbols 24
Fillet Radius dialog box 139
fillets 24, 139, 278
filters for parts lists 270, 274
finite element analysis (FEA) 372
fits 24, 170, 178
fits lists 182
fixed supports 300, 318, 372, 375
fixed supports on shafts 305
folders 66, 69–70, 86
instances of 70
mechanical structure 66, 86
modify 69
frequently used commands 458
**G**

Gear dialog box 306
gears 278, 300
geometry in structure 66
ghost components 94
grooved drive studs 24

**H**
hatch patterns 24, 39, 143
hidden edges 194
hidden lines 186
hide situations 106, 187
  2D 187
  associative 106
  in mechanical structure 106
holes 21, 37–39, 202, 231, 423
  add notes 423
  blind 231
  counterbored 39
  countersunk 21, 39, 202
  tapped blind 37
  tapped through 37
  through 38
  user-defined 39

**I**
inner shaft contours 34
instances 67, 73
  compared to occurrences 73
  in mechanical structure 67
isoareas in calculations 378
isolines in stress calculations 378

**K**
keys in shafts 35

**L**
language converter 26
Layer Control dialog box 57, 117, 119, 123, 166
layer groups 27, 56, 114, 117, 152
layer specifications 447
layer system 26, 448
layers 57
layouts 152–153
leaders 28, 37, 254, 265
length calculations for chains 329
libraries for storage 128
Library dialog box 27
lines 300, 321
  deflection 300, 321
link to assembly files 427
link to part files 409
List of Filters dialog box 271
load calculations 24, 300, 318, 365, 372
lock washers 35
lubricators 27

**M**
Material dialog box 303
Material Properties dialog box 304
material properties for screws 358
Material Type dialog box 322
mechanical browser 18, 66, 86, 88, 90
  restructure 90
  usage with Bill of Materials 88
mechanical layers 57, 114
mechanical options 58
mechanical structure 66–68, 106, 280
  enable 68, 280
  folders 66, 68
  hide situations 106
mesh in stress calculations 377, 379
model space 33, 153, 159
module values in shafts 283
moments of inertia 25, 318
motion diagrams for cams 388
movable supports 300, 318, 372, 376
movable supports on shafts 305
mtext 38
multi edit dimensions 170, 178

**N**
NC (numerical control) 388
new commands 50
Nominal Diameter dialog box 162
notations and stress calculations 300
numerical control (NC) 388
nuts 28

O
o-rings 34
object snap modes 30
object snaps 131
objects 67, 122
  copy with layer groups 122
  mechanical structure 67
occurrences 67, 73
  compared with instances 73
  in mechanical structure 67
Options dialog box 58
orthogonal views for part files 418
outer shaft contours 34

P
Page Setup - Layout dialog box 412, 432
Page Setup Manager dialog box 411, 432
parallel keys 35
part information 245
Part Ref Attributes dialog box 246, 248, 254
part references 29, 244–245
partitions in chains 328
parts layers 26, 56, 114
Parts List dialog box 259
parts lists 29, 244, 255, 261–262, 267, 270, 434
  defined 244
  filters 270
  merge rows 261
  sort 267
  split rows 262
pins 234
pitch diameters in chains 328
plain bearings 29
plain rivets 29
plugs 29, 34
point forces 300, 318
Point Load dialog box 306
polylines 138
power commands 128, 193
Power Copy 202, 211, 342
Power Dimensioning 128, 152, 170
Power Dimensioning dialog box 145, 149, 164
Power Edit 202, 222, 342, 372, 381
Power Erase 170, 202, 229, 264
Power Recall 202
Power Snap Settings dialog box 132, 280
Power View 202, 226, 352
precision in dimensions 145
profiles in shafts 286
property class for screws 359
pulleys 19, 36
Pulleys and Sprockets dialog box 334
radial dimensions 425
radius reflection lines 278
rectangles 31
reference dimensions 424
reference points 31
relative points 31
representations of standard parts 36, 203, 239
resolution in cam calculations 388
restructure components 95
result blocks in screw calculations 370
retaining rings 24
revised commands 44
revision lists 32
rivets 21, 29
  countersunk 21
  plain 29
roller bearings 32
roller chains 328
rotate tool 409, 427

S
Save Drawing As dialog box 60
Save Title Block Filename dialog box 414
Scale Area dialog box 154
scale areas 33, 152–153
scale monitors 152
scale of viewports, default 40
Screw Assembly Grip Representation - Front View dialog box 209
Screw Assembly Templates dialog box 34, 218
Screw Calculation dialog box 358
Screw Connection dialog box 33, 205, 214, 219
Screw Connection New Part Front View dialog box 223
screw connections 33
Screw Diameter Estimation dialog box 219
  calculations 356
  connections 356
  contact areas 364
  loads and bending moments 365
  material properties 358
  precalculations 219
  property class 359
  result blocks 370
  settlement properties 367
  stand-alone calculations 356
  templates 213
  tightening properties 368
  washers 361
scripts 34
sealing rings 34
Select a Blind Hole dialog box 232
Select a Cylindrical Pin dialog box 234
Select a Nut dialog box 360
Select a Row dialog box 358
Select a Screw dialog box 205, 358
Select Graph dialog box 308, 324
Select Part Size dialog box 236, 330
Select Template dialog box 129, 279, 409, 427
Set Value dialog box 260, 269
settlement properties in screw calculations 367
Shaft Calculation dialog box 303
Shaft Generator dialog box 281
shafts 34–35, 39, 278, 283, 286, 288–290, 292, 301, 308
  breaks 278, 288
  calculations 301, 308
  commands that act on 39
  contours 34
  cylinders 283
  generator 278, 301
  lock nuts 35
  module values 283
  profiles 286
  safety factors 34
  side views 289
  slopes 292
  threads 290
shim rings 35
shortcuts 458
simple welds 35
slopes on shafts 292
slots, through 39
snap distance for balloons 254
snap settings 30, 131–132
Sort dialog box 268
sort parts lists 267
springs 17, 20, 23, 39, 341–342, 345
  belleville 342
  calculations 341–342, 345
  compression 342
  extension 342
  layouts 345
  torsion 342
sprockets 19, 36, 328, 333
stability calculations 372
standard parts 30, 203
Standard Parts Database dialog box 36
steel shapes 36, 186, 190, 193
step width in cam calculations 388
Strength Calculation dialog box 312
strength calculations for shafts 300, 311
stress calculations 24, 300, 372
stress divisions 382
stress representations 380
stress tables 379
stress yield points 300
structure catalog 33
supporting forces 34
supports 300
surface texture symbols 37
Switch Representation of Standard Parts
dialog box 240
symbols 23–24, 37
drop line 23
feature control frame 24
feature identifier 24
drop lines 23
symmetrical lines 37

T
tangent definitions for chains 331
taper pins 37
tapped holes 37
blind 37
through 37
Template Description dialog box 61
templates, drawings 56, 60, 62
text styles 36, 38
thread ends 38
tools on shafts 290
through holes 38
through slots 39
tightening properties in screw
calculations 368
title block attributes 454
title blocks 29, 39, 170
tolerances 29, 145, 170
toolbutton command access 5
Torque dialog box 307
torque rotation angles 34
torsion moments 34
torsion springs 39, 342
trace contours 39
tracking lines 254
translate text 26
trim 141
Type of Follower dialog box 390

V
view components 76
View dialog box 158, 167
viewports 27, 40, 152–153, 156
views 104, 128, 152, 156, 166, 289, 414,
418, 432–433, 436, 441
annotation 104
associative 166
base 433
breakout section 436
detail 128, 156
drawing 414, 432
isometric 441
multiple for assembly files 436
orthogonal 418
scales 152
sides of shafts 289
virtual intersections 31
Visibility Enhancement dialog box 123

W
washers 35, 40, 361
weld symbols 41
woodruff keys 35
Working layers 56, 114, 152

X
xref components 96, 101, 103
xrefs 41

Y
yield points of stress 300

Z
z coordinate 31
zigzag lines 41
zigzag lines for shaft ends 35
zoom 40