Contents

Chapter 1  Basic Customization  ................................................. 1
   Overview of Customization ................................................. 1
   Organize Program and Support Files  ................................. 3
      Overview of File Organization ...................................... 3
      Multiple Configurations .......................................... 6
      Multiple Drawing Folders ......................................... 7
   Locate Customized Files ............................................. 8
      Locate Plot Style Files .......................................... 9
      Locate Plotter Files ........................................... 10
      Locate the PMP File ........................................... 10
      Locate Support Files .......................................... 11
      Locate Drawing Template Files .................................. 14
   Customize a Publish to Web Template  ............................ 14
   Create Command Aliases ............................................ 17

Chapter 2  Custom Linetypes .................................................. 19
   Overview of Linetype Definitions .................................. 19
   Simple Custom Linetypes ............................................ 20
   Text in Custom Linetypes ......................................... 24

Chapter 3  Custom Hatch Patterns .......................................... 27
   Overview of Hatch Pattern Definitions ............................ 27
   Hatch Patterns with Dashed Lines .................................. 30
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create Tooltips and Extended Help for Commands</td>
<td>122</td>
</tr>
<tr>
<td>Create Status Line Help Messages</td>
<td>128</td>
</tr>
<tr>
<td>Assign, Create, and Manage Images for Commands</td>
<td>129</td>
</tr>
<tr>
<td>Assign Images to a Command</td>
<td>129</td>
</tr>
<tr>
<td>Create and Edit Custom Images for Commands</td>
<td>132</td>
</tr>
<tr>
<td>Manage, Import, and Export Custom Images</td>
<td>134</td>
</tr>
<tr>
<td>Customize User Interface Elements</td>
<td>139</td>
</tr>
<tr>
<td>Quick Access Toolbars</td>
<td>142</td>
</tr>
<tr>
<td>Ribbon</td>
<td>148</td>
</tr>
<tr>
<td>Ribbon Panels</td>
<td>149</td>
</tr>
<tr>
<td>Ribbon Tabs</td>
<td>180</td>
</tr>
<tr>
<td>Ribbon Contextual Tab States</td>
<td>186</td>
</tr>
<tr>
<td>Toolbars</td>
<td>190</td>
</tr>
<tr>
<td>Create and Edit Toolbars</td>
<td>190</td>
</tr>
<tr>
<td>Add Flyouts to a Toolbar</td>
<td>202</td>
</tr>
<tr>
<td>Add, Remove or Switch Toolbar Controls</td>
<td>207</td>
</tr>
<tr>
<td>Pull-down and Shortcut Menus</td>
<td>212</td>
</tr>
<tr>
<td>Overview of Pull-Down and Shortcut Menus</td>
<td>212</td>
</tr>
<tr>
<td>Create a Pull-Down Menu</td>
<td>213</td>
</tr>
<tr>
<td>Create a Shortcut Menu</td>
<td>217</td>
</tr>
<tr>
<td>Create Submenus</td>
<td>227</td>
</tr>
<tr>
<td>Reference Pull-Down or Shortcut Menus</td>
<td>229</td>
</tr>
<tr>
<td>Swap and Insert Pull-Down Menus</td>
<td>230</td>
</tr>
<tr>
<td>Quick Properties</td>
<td>233</td>
</tr>
<tr>
<td>Rollover Tooltips</td>
<td>241</td>
</tr>
<tr>
<td>Keyboard Shortcuts</td>
<td>248</td>
</tr>
<tr>
<td>Shortcut Keys</td>
<td>248</td>
</tr>
<tr>
<td>Temporary Override Keys</td>
<td>255</td>
</tr>
<tr>
<td>Double Click Actions</td>
<td>262</td>
</tr>
<tr>
<td>Overview of Double Click Actions</td>
<td>262</td>
</tr>
<tr>
<td>Double Click Action Object Names</td>
<td>266</td>
</tr>
<tr>
<td>Examples of Double Click Actions</td>
<td>269</td>
</tr>
<tr>
<td>Mouse Buttons</td>
<td>270</td>
</tr>
<tr>
<td>Overview of Mouse Buttons</td>
<td>270</td>
</tr>
<tr>
<td>Accept Coordinate Entry in Button Menus</td>
<td>271</td>
</tr>
<tr>
<td>Legacy Interface Elements</td>
<td>272</td>
</tr>
<tr>
<td>Create Tablet Menus</td>
<td>272</td>
</tr>
<tr>
<td>Customize Tablet Buttons</td>
<td>274</td>
</tr>
<tr>
<td>Create Image Tile Menus</td>
<td>275</td>
</tr>
<tr>
<td>Customize Workspaces</td>
<td>280</td>
</tr>
<tr>
<td>Overview of Workspace Customization</td>
<td>280</td>
</tr>
<tr>
<td>Control User Interface Elements Outside the CUI Editor</td>
<td>293</td>
</tr>
<tr>
<td>Control User Interface Elements in the CUI Editor</td>
<td>296</td>
</tr>
<tr>
<td>Control the Appearance of Palettes</td>
<td>312</td>
</tr>
<tr>
<td>Transfer and Migrate Customization</td>
<td>316</td>
</tr>
<tr>
<td>Customize User Interface (CUI) Editor FAQs</td>
<td>319</td>
</tr>
</tbody>
</table>
Chapter 5  DIESEL ......................................................... 325
  Customize the Status Line ........................................ 325
  Overview of the MODEMACRO System Variable .............. 325
  Set MODEMACRO Values ......................................... 326
DIESEL Expressions in Macros .................................... 328
Catalog of DIESEL Functions ..................................... 331
  + (addition) ................................................... 331
  - (subtraction) ............................................... 331
  * (multiplication) ............................................ 331
  / (division) ................................................... 332
  = (equal to) .................................................. 332
  < (less than) ................................................ 333
  > (greater than) ............................................. 333
  != (not equal to) ............................................. 333
  <= (less than or equal to) .................................. 334
  >= (greater than or equal to) ................................ 334
  and .............................................................. 335
  angtos .......................................................... 335
  edtime .......................................................... 336
  eq ............................................................... 337
  eval ............................................................. 338
  fix ............................................................... 338
  getenv .......................................................... 339
  getvar .......................................................... 339
  if ................................................................. 340
  index ............................................................ 340
  nth ............................................................... 340
  or ................................................................. 341
  rtos ............................................................. 341
  strlen ........................................................... 341
  substr ........................................................... 342
  upper ............................................................ 342
  xor ............................................................... 343
DIESEL Error Messages ............................................. 343

Chapter 6  Slides and Command Scripts .......................... 345
Create Slides ....................................................... 345
  Overview of Slides ........................................... 345
  View Slides ..................................................... 347
  Create and View Slide Libraries ................................ 348
Create Command Scripts .......................................... 350
  Overview of Command Scripts ................................ 350
  Run Scripts at Startup ........................................ 352
  Run Slide Shows from Scripts ................................ 354
Index ................................................................. 359
Basic Customization

Your dealer can offer you independently developed applications that can further tailor AutoCAD LT to your needs.

Overview of Customization

AutoCAD LT can be customized in simple ways. For example, you can change the directory structure or move a button from one toolbar to another. If you want to change the interface further, you can edit the CUIx file and use DIESEL code to create customizations with your own commands.

The list that follows is arranged from least to most complex:

- **Organize files.** You can organize program, support, and drawing files. For example, you can make a separate folder for each project that includes only the support files that project needs.

- **Customize Tool Palettes.** You can create a tool by dragging objects from your drawing onto a tool palette. You can create a tool palette by right-clicking on the Tool Palettes title bar and selecting New Palette. For information about customizing tool palettes, see “Customize Tool Palettes” in the User's Guide.

- **Create custom templates.** Use templates to define common parameters when you publish a drawing using the Publish to Web wizard.

- **Define command aliases.** You can define simple abbreviations, or aliases, for frequently used commands from within AutoCAD LT by adding the command to the PGP file `acadlt.pgp`. For example, you might want to start the BLOCK command by entering `b`. 
■ **Create custom linetypes and hatch patterns.** You can create linetypes and hatch patterns that conform to your company standards and working methods.

■ **Customize the user interface.** The CUIx file controls many aspects of the user interface, including the behavior of your pointing device buttons and the functionality and appearance of pull-down, tablet, and image tile menus, toolbars, and accelerator keys. You can edit or create a CUIx file to add commands or combine commands and assign them to a menu, toolbar, or other location.

■ **Customize the status line.** You can use the DIESEL string expression language and the MODEMACRO system variable to provide additional information at the status line, such as the date and time or system variable settings.

■ **Automate repetitive tasks by writing scripts.** A script is an ASCII text file containing commands that are processed like a batch file when you run the script. For example, if a set of drawings needs to be plotted a certain way, you can write a script that opens each drawing, hides and displays various layers, and issues PLOT commands. You can use scripts with slides to create automated presentations like those used at trade shows. A slide is a “snapshot” of the drawing area that cannot be edited. Slides can also be used in image tile menus and dialog boxes.

**See also:**

■ “Organize Program and Support Files”

■ “Toolbars”

■ “Customize a Publish to Web Template”

■ “Create Command Aliases”

■ “Custom Linetypes”

■ “Custom Hatch Patterns”

■ “User Interface Customization”

■ “DIESEL”

■ “Customize the Status Line”

■ “Slides and Command Scripts”
**Quick Reference**

**Commands**

CUI

Manages the customized user interface elements in the product.

CUSTOMIZE

Customizes tool palettes and tool palette groups.

**System Variables**

TOOLTIPS

Controls the display of tooltips on the ribbon, toolbars, and other user interface elements.

**Organize Program and Support Files**

You can change the default directory structure for the program and support files to suit your needs.

**Overview of File Organization**

AutoCAD LT® uses support files for purposes such as storing customization definitions and describing text fonts.

The default directory structure for the AutoCAD LT program and support files is designed to efficiently organize those files into logical groups. If this organization does not suit your needs, you can change it. However, some applications look for certain files in specific locations, and you should verify that your modifications do not conflict with the requirements of those applications. Without the full path, including drive and directory, AutoCAD LT can locate only those files that are found in the library search path.

The location of the support folder changed in AutoCAD 2004. The location of local customizable files is stored in the LOCALROOTPREFIX system variable. The location of roamable customizable files is stored in the ROAMABLEROOTPREFIX system variable. If a network supports roaming,
customizable files in the user’s roaming profile are available on the machine
the user is logged onto.

**Library Search Path**

The library search path specifies where the program searches for files when
you do not specify a full path name, as follows:

- Current directory. (This is typically determined by the “Start In” setting
  in your shortcut icon.)
- Directory that contains the current drawing file.
- Directories listed in the search path specified on the Files tab in OPTIONS.
  (See Specify Search Paths and File Locations in the *User’s Guide.*)
- Directory that contains the AutoCAD LT program files.

Depending on the current environment, two or more directories may be the
same.

If a file is not in this search path, you must specify both its path name and
file name before AutoCAD LT can find it. For example, if you want to insert
the *part5.dwg* drawing into your current drawing and it is not in the library
search path, you must specify its full path name, as shown here:

Command: `insert`
Enter block name or [?]: `/files2/olddwgs/part5`

If the drawing exists in that location, AutoCAD LT prompts you to finish the
INSERT command in the usual manner.

**Directory Structure**

AutoCAD LT uses tree-structured directories and subdirectories. It is
recommended that you keep supplemental files (such as third-party
applications and customization files) separate from the AutoCAD LT program
and support files. This makes it easier to track possible conflicts and to upgrade
each application without affecting the others.

You can create a new directory on the same level as the main AutoCAD LT
directory and store any customization files or third-party applications in
subdirectories on the next level.

If you want to store drawings by job, you can create a third directory on the
same level. Subdirectories for each job could contain drawing files and a
subdirectory for related support files.
Command Search Procedure

When you enter a command, AutoCAD LT goes through a series of steps to evaluate the validity of the command name. A command can be a built-in command or system variable or an alias defined in the acadlt.pgp file. Commands can also be defined by a device driver command. You can enter a command on the command prompt or choose a command from the appropriate menu. Commands can also be entered from a script file.

The following list describes the search order AutoCAD LT uses to validate a command name.

1. If the input is a null response (SPACEBAR or ENTER), AutoCAD LT uses the name of the last command issued. HELP is the default.
2. AutoCAD LT checks the command name against the list of built-in commands. If the command is in the list and is not preceded by a period (.), AutoCAD LT then checks the command against a list of undefined commands. If the command is undefined, the search continues. Otherwise, the command is run, unless another reason prevents it from doing so. Running it transparently or in Perspective mode might be impossible.
3. AutoCAD LT checks the command name against the names of commands defined by a device driver, and then by those defined by the display driver.
4. AutoCAD LT checks the command name against the list of system variables. If the command name is in the list, AutoCAD LT executes the SETVAR command, using the input as the variable name.
5. If the command name corresponds to a command alias defined in the program parameters file, AutoCAD LT uses the expanded command name and continues the search, starting a new search against the list of built-in commands.
6. If all the preceding steps fail, the search terminates with a warning message about illegal command names.

See also:

- “Specify Search Paths and File Locations” in the User's Guide
Quick Reference

Commands

OPTIONS
Customizes the program settings.

System Variables

LOCALROOTPREFIX
Stores the full path to the root folder where local customizable files were installed.

ROAMABLEROOTPREFIX
Stores the full path to the root folder where roamable customizable files were installed.

Multiple Configurations

If you use more than one pointing device or use different plotters, you can set up more than one configuration file to make it easy to switch between devices.

When you configure AutoCAD LT for a pointing device and plotter drivers, the information you supply is recorded in a configuration file.

Typically, only a single configuration is necessary, but you may need multiple configurations. For example, if you use a mouse for most of your work but occasionally require a large digitizing tablet, you can set up your system to handle multiple configurations rather than reconfiguring each time you change a device.

The configuration file stores the values of many AutoCAD LT system variables and the configuration options defined in the Options dialog box. If you want different settings for these system variables and operating parameters, you can save those values to different configuration files. For a list of the system variables and where they are stored, see System Variables in the Command Reference.

To take advantage of multiple configurations, you must set up AutoCAD LT to use different configuration files. Use the /c switch to specify alternative configuration files at startup.
Quick Reference

Commands
OPTIONS
Customizes the program settings.

Multiple Drawing Folders

Keeping your drawing and other associated files in separate directories makes it easier to perform basic file maintenance.

Keeping your drawing files and other associated files in separate directories makes it easier to perform basic file maintenance. The scenario described in this topic is based on the sample directory structure described in Overview of File Organization on page 3, but you can expand or alter it to meet your needs.

You can set up the /AcltJobs directory to contain your drawing subdirectories. The drawing subdirectories can contain other subdirectories that hold related support files for that particular drawing type or job. The /AcltJobs/Job1/Support directory can contain blocks and other files specific to the drawing files in /AcltJobs/Job1. Specifying support (with no path prefix) in the Support path adds the support directory within the current directory to the Support path.

Notice that if you use the Options dialog box to specify a directory, AutoCAD LT creates a hard-coded path to that directory. To use the relative naming convention previously described, you must specify the Support path with the /s switch on the command line. See “Customize Startup” in the User's Guide.

To make sure that the required drawing directory is the current directory when you start AutoCAD LT, and that all files and subdirectories in that directory are easily accessible, you can create a program icon or a Start menu item that specifies the correct working directory for each job. This functionality works only if you set the AutoCAD LT system variable RESEMEMBERFOLDERS to 0.

You can use a batch program as an alternative to using icons or menus. With batch programs you can create new job directories automatically. The following
batch program verifies that a specified directory exists, sets that directory to be current, and then runs AutoCAD LT.

@echo off
C:
if exist \AcltJobs\Jobs\%1 goto RUNACLT
echo.
echo *** Creating \AcltJobs\Jobs\%1
echo *** Press Ctrl+C to cancel.
echo.
pause
mkdir \AcltJobs\Jobs\%1
:RUNACAD
cd \AcltJobs\Jobs\%1
start C:\ AutoCAD LT\acadlt.exe

Using an ASCII text editor (such as Notepad), save the batch program to a file named acadlt.bat. Be sure to change the drive and directory names to match those on your system. Place this file in a directory that is on your system search path (for example, C:\winnt). You can run this batch program using the Run command on the Start menu or by double-clicking the file in Explorer. If you saved the file as acadlt.bat, use the following syntax:

`aclt jobname`

where `jobname` is the name of the job directory to make current.

**Quick Reference**

**Locate Customized Files**

Beginning with AutoCAD LT 2004, the location of some of your customized files has changed. The reasons for the file location changes include the following:

- **Limited user rights on a workstation.** You can run AutoCAD LT as a limited user. This means that you no longer need power user or Administrator permissions to run AutoCAD LT once it is installed.

- **Roaming profiles.** Roaming profiles allow you to log on to any computer within a network and retain your user settings. Some files, such as your personal settings and documents, follow you from computer to computer, while other files, such as templates (including Publish to Web templates), reside only on your system.
If roaming profiles are allowed on your network, your “roamable” files are located in the \Application Data\Autodesk\<Product Version> folder, and your “nonroamable” files are located in the \Local Settings\Application Data\Autodesk\<Product Version> folder.

**NOTE** In some operating systems, the folders that are located under your profile are hidden by default. To display these files, you may need to change your display settings. On the Start menu, click Control Panel ➤ Folder Options. In the Folder Options dialog box, on the View tab, click Show Hidden Files and Folders.

## Locate Plot Style Files

Beginning with the AutoCAD KT 2004, the default location of your plot style files has changed. For information about the default location of these files, see [Locate Customized Files](#) on page 8.

**To locate your plot style files**

1. Do one of the following:
   - (Windows XP) Click Start menu ➤ Programs ➤ Autodesk ➤ <AutoCAD LT> ➤ <AutoCAD LT>.
   - (Windows Vista) Click Start menu ➤ All Programs ➤ Autodesk ➤ <AutoCAD LT> ➤ <AutoCAD LT>.

2. Click application menu ➤ Options.

3. In the Options dialog box, Files tab, click the plus sign (+) to the left of Printer Support File Path.

4. Click the plus sign (+) to the left of the Plot Style Table Search Path file.

5. Under Plot Style Table Search Path, click the path name to view the location of your plot style files.

**NOTE** You can also locate your plot style files by entering *stylesmanager* on the AutoCAD LT command line.
Locate Plotter Files

Beginning with AutoCAD LT 2004, the default location of your plotter files has changed. For information about the default location of these files, see Locate Customized Files on page 8.

To locate your plotter files

1. Do one of the following:
   - (Windows XP) Click Start menu ➤ Programs ➤ Autodesk ➤ <AutoCAD LT> ➤ <AutoCAD LT>.
   - (Windows Vista) Click Start menu ➤ All Programs ➤ Autodesk ➤ <AutoCAD LT> ➤ <AutoCAD LT>.

2. Click application menu ➤ Options.

3. In the Options dialog box, Files tab, click the plus sign (+) to the left of Printer Support File Path.

4. Click the plus sign (+) to the left of Printer Configuration Search Path.

5. Under Printer Configuration Search Path, click the path name to view the location of your plotter files.

NOTE You can also locate your plotter files by entering plottermanager on the AutoCAD LT command line.

Locate the PMP File

Beginning with the 2004 Autodesk products, the default location of your PMP file has changed. For information about the default location of this file, see Locate Customized Files on page 8.

To locate your PMP file

1. Do one of the following:
   - (Windows XP) Click Start menu ➤ Programs ➤ Autodesk ➤ <AutoCAD LT> ➤ <AutoCAD LT>.
   - (Windows Vista) Click Start menu ➤ All Programs ➤ Autodesk ➤ <AutoCAD LT> ➤ <AutoCAD LT>.
2 Click application menu ➤ Options.

3 In the Options dialog box, Files tab, click the plus sign (+) to the left of Printer Support File Path.

4 Under Printer Description File Search Path, click the path name to view the location of your PMP file.

**Locate Support Files**

Beginning with AutoCAD LT 2004, the default location for some of your support files has changed. For information about the default location of these files, see Locate Customized Files on page 8.

Support files include the following:

- Customization file (*acadlt.cuix*)
- Custom icon files
- Help and miscellaneous files
- Font mapping file (*acadlt.fmp*)
- Alternate font file (*simplex.shx*)
- Support path files (*acadlt.dcl*, *acadlt.lin*, *acadlt.pat*, *acadlt.pgp*, *acadlt.psf*, *acadlt.unt*, *acadltiso.lin*, *acadltiso.pat*, and *gdt.shx*)

**To find the default location of the customization files**

1 Do one of the following:
   - (Windows XP) Click Start menu ➤ Programs ➤ Autodesk ➤ <AutoCAD LT> ➤ <AutoCAD LT>.
   - (Windows Vista) Click Start menu ➤ All Programs ➤ Autodesk ➤ <AutoCAD LT> ➤ <AutoCAD LT>.

2 Click application menu ➤ Options.

3 In the Options dialog box, Files tab, click the plus sign (+) to the left of Customization Files.

4 Click the plus sign (+) to the left of Main Customization File.
5 Under Main Customization File, click the path name to view the location of your main customization file.

6 Click the plus sign (+) to the left of Enterprise Customization File.

7 Under Enterprise Customization File, click the path name to view the location of your enterprise customization files.

**NOTE** By default, the path to an enterprise customization file is empty until you define the file. For more information about defining a customization file, see “Customize the User Interface” in the *Customization Guide*.

---

**To find the default location of the custom icon files**

1 Do one of the following:
   - (Windows XP) Click Start menu ➤ Programs ➤ Autodesk ➤ `<AutoCAD LT>` ➤ `<AutoCAD LT>`.
   - (Windows Vista) Click Start menu ➤ All Programs ➤ Autodesk ➤ `<AutoCAD LT>` ➤ `<AutoCAD LT>`.

2 Click application menu ➤ Options.

3 In the Options dialog box, Files tab, click the plus sign (+) to the left of Customization Files.

4 Under Custom Icon Location, click the path name to view the location for the custom button image files used with your customization files.

---

**To find the default location of the Help and miscellaneous files**

1 Do one of the following:
   - (Windows XP) Click Start menu ➤ Programs ➤ Autodesk ➤ `<AutoCAD LT>` ➤ `<AutoCAD LT>`.
   - (Windows Vista) Click Start menu ➤ All Programs ➤ Autodesk ➤ `<AutoCAD LT>` ➤ `<AutoCAD LT>`.

2 Click application menu ➤ Options.

3 In the Options dialog box, Files tab, click the plus sign (+) to the left of Help and Miscellaneous File Names to expand the list.

4 Click the plus sign (+) to the left of the file you want to locate, and then click the path name to view the location of the files.
To find the default location of the font mapping file

1 Do one of the following:

■ (Windows XP) Click Start menu ➤ Programs ➤ Autodesk ➤ <AutoCAD LT> ➤ <AutoCAD LT>.

■ (Windows Vista) Click Start menu ➤ All Programs ➤ Autodesk ➤ <AutoCAD LT> ➤ <AutoCAD LT>.

2 Click application menu ➤ Options.

3 In the Options dialog box, Files tab, click the plus sign (+) to the left of Text Editor, Dictionary, and Font File Names.

4 Click the plus sign (+) to the left of Font Mapping File.

5 Under Font Mapping File, click the path name to view the location of your font mapping file.

To find the default location of the alternate font file

1 Do one of the following:

■ (Windows XP) Click Start menu ➤ Programs ➤ Autodesk ➤ <AutoCAD LT> ➤ <AutoCAD LT>.

■ (Windows Vista) Click Start menu ➤ All Programs ➤ Autodesk ➤ <AutoCAD LT> ➤ <AutoCAD LT>.

2 Click application menu ➤ Options.

3 In the Options dialog box, Files tab, click the plus sign (+) to the left of Text Editor, Dictionary, and Font File Names.

4 Click the plus sign (+) to the left of Alternate Font File.

5 Under Alternate Font File, click the path name to view the location of your alternate font file.

To find the default location of the support path files

1 Do one of the following:

■ (Windows XP) Click Start menu ➤ Programs ➤ Autodesk ➤ <AutoCAD LT> ➤ <AutoCAD LT>.

■ (Windows Vista) Click Start menu ➤ All Programs ➤ Autodesk ➤ <AutoCAD LT> ➤ <AutoCAD LT>. 
2 Click application menu ➤ Options.

3 In the Options dialog box, Files tab, click the plus sign (+) to the left of Support File Search Path.

4 Under Support File Search Path, click a path name to view the location of your support files.

**Locate Drawing Template Files**

Beginning with AutoCAD LT 2004, the default location of your drawing template files has changed. For information about the default location of these files, see Locate Customized Files on page 8.

**To locate your drawing template files**

1 Do one of the following:
   - (Windows XP) Click Start menu ➤ Programs ➤ Autodesk ➤ <AutoCAD LT> ➤ <AutoCAD LT>.
   - (Windows Vista) Click Start menu ➤ All Programs ➤ Autodesk ➤ <AutoCAD LT> ➤ <AutoCAD LT>.

2 Click application menu ➤ Options.

3 In the Options dialog box, Files tab, click the plus sign (+) to the left of Template Settings.

4 Under Template Settings, click the plus sign (+) to the left of Drawing Template File Location.

5 Under Drawing Template File Location, click the path name to view the location of your drawing template files.

**Customize a Publish to Web Template**

You can create customized templates to use in the Publish to Web wizard by modifying one of the Publish to Web template (PWT) files provided. Use any HTML editor or text editor.

To create a custom template, add or modify any of the following elements:

- Images
There are four default Publish to Web templates that you can customize:

- **Array of Thumbnails**. Creates a web page containing an array of thumbnail images.

- **Array Plus Summary**. Creates a web page containing an array of thumbnail images and summary information about each image.

- **List of Drawings**. Creates a web page containing a list of drawings and an image frame.

- **List Plus Summary**. Creates a web page containing a list of drawings, an image frame, and summary information about a selected image.

**NOTE** You must be familiar with HTML syntax to customize the Publish to Web templates.

You can make changes or additions to the look and feel of a template, but you cannot change the arrangement of images within it. For example, in the **Array of Thumbnails** template, the images are presented across the page in rows. You cannot alter the presentation of the images, but you can wrap text and graphics around the table of images.

**WARNING** To ensure that you do not overwrite the default Publish to Web template files, back up those files before you make any changes to them.

**To create quick access to the Publish to Web templates**

1. Click Tools menu ➤ Options.

2. In the Options dialog box, Files tab, click the plus sign (+) next to Template Settings. Then click the plus sign next to Drawing Template File Location.

3. Move the cursor to the path name that is displayed and click inside it, and press F2, and press CTRL+C to copy it.
Click OK or Cancel to close the Options dialog box.

Click File menu ➤ Open.

In the Select File dialog box, right-click an empty area in the vertical panel on the left side, and click Add on the shortcut menu.

Enter a name in the Item name box (for example, Templates).

Press CTRL+V to paste the path into the Item Path box, and click OK.

You can now access the Template folders by clicking the button in the left panel of the Select File dialog box.

**To customize a Publish to Web template**

1. Browse to the Publish to Web template folder, click File menu ➤ Open. See To create quick access to the Publish to Web templates on page 15.

2. Double-click the PTWTemplates folder to open it. The following folders are displayed. Each contains a Publish to Web template and preview images (BMP) that you see when you run the Publish to Web wizard.

   - **Template1.** Contains the Array of Thumbnails template and a preview image
   - **Template2.** Contains the Array Plus Summary template, a preview image, and HTML frames
   - **Template3.** Contains the List of Drawings template, a preview image, and HTML frames
   - **Template4.** Contains the List Plus Summary template, a preview image, and HTML frames

3. Right-click the folder you want to use, and click Copy.

4. Press ALT+2, right-click the PTWTemplates folder, and click Paste.

5. Reopen the PTWTemplates folder, and right-click the new folder and rename it.

6. Right-click the new folder and click Open to display its contents.

7. Rename the Publish to Web template (PWT) file with an .htm or .html file extension.

8. Open the template file in an HTML editor or a text editor.
The template file contains comments that help you determine which areas of the code you can modify to create your new web page.

9 Review the comments and make changes to the parts of the template you want to customize.

10 Save the template with a .pwt file extension. Make sure you save the file to the template folder you created in step 3.

**NOTE** Each template folder can contain only one PWT file. If you create a new PWT file, make sure you delete any other PWT files that exist in the same folder.

When you run the Publish to Web wizard, the new template is displayed in the list of templates.

**Quick Reference**

**Commands**

PUBLISHTOWEB

Creates HTML pages that include images of selected drawings.

**Create Command Aliases**

A command alias is an abbreviation that you enter at the command prompt instead of entering the entire command name.

For example, you can enter `c` instead of `circle` to start the CIRCLE command. An alias is not the same as a keyboard shortcut, which is a combination of keystrokes, such as CTRL+S for SAVE.

The acadlt.pgp file defines command aliases. You can change existing aliases or add new ones by editing acadlt.pgp in an ASCII text editor (such as Notepad). In addition to command aliases in acad.pgp, you will also find comment lines which are preceded by a semicolon (;). Comment lines allow you to add textual information to acad.pgp, such as when or who revised the file last.

**NOTE** Before you edit acadlt.pgp, create a backup so that you can restore it later, if necessary.
To define a command alias, add a line to the `acadlt.pgp` file using the following syntax:

```
abbreviation,*command
```

where `abbreviation` is the command alias that you enter at the command prompt and `command` is the command being abbreviated. You must enter an asterisk (`*`) before the command name to identify the line as a command alias definition.

If you can enter a command transparently, you can also enter its alias transparently. When you enter the command alias, the full command name is displayed at the command prompt and the command is executed.

You can create command aliases that include the special hyphen (-) prefix, such as those listed here, that accesses the version of a command that displays command prompts instead of a dialog box.

```
BH, *-BHATCH
BD, *-BOUNDARY
```

**NOTE** You cannot use command aliases in command scripts. Using command aliases in menu files is not recommended.

If you edit `acadlt.pgp` while AutoCAD LT is running, enter `reinit` in order to use the revised file. Restarting AutoCAD LT automatically reloads the file.

**To open the program parameters file (acadlt.pgp)**

- Click Tools ➤ Customize ➤ Edit Program Parameters (acadlt.pgp)

**Quick Reference**

**Commands**

REINIT

Reinitializes the digitizer, digitizer input/output port, and program parameters file.
Custom Linetypes

AutoCAD LT® provides a library of standard linetypes in the acadlt.lin and acadltiso.lin files. You can use the linetypes as they are, modify them, or create your own custom linetypes.

Overview of Linetype Definitions

Linetypes are defined in one or more linetype definition files that have a .lin file extension.

The linetype name and definition determine the particular dash-dot sequence, the relative lengths of dashes and blank spaces, and the characteristics of any included text or shapes. You can use any of the standard linetypes that AutoCAD LT provides, or you can create your own linetypes.

examples of linetypes

A LIN file can contain definitions of many simple and complex linetypes. You can add new linetypes to an existing LIN file, or you can create your own LIN file. To create or modify linetype definitions, edit the LIN file using a text editor or word processor or use LINETYPE at the command prompt.

When you create a linetype, you must load the linetype before you can use it.

The LIN files included in AutoCAD LT are acadlt.lin and acadltiso.lin. You can display or print these text files to better understand how to construct linetypes.
Quick Reference

Commands
LINETYPE
   Loads, sets, and modifies linetypes.

System Variables
MEASUREINIT
   Controls whether a drawing you start from scratch uses imperial or metric default settings.

Simple Custom Linetypes
Each linetype is defined on two lines in a linetype definition file. The first line contains the linetype name and an optional description. The second line is the code that defines the actual linetype pattern.

The second line must begin with the letter A (alignment), followed by a list of pattern descriptors that define pen-up lengths (spaces), pen-down lengths (dashes), and dots. You can include comments in an LIN file by beginning the line with a semicolon (;).

Linetype Definition Format
The format of the linetype definition is

   *linetype_name,description
   A,descriptor1,descriptor2, ...

For example, a linetype called DASHDOT is defined as

   *DASHDOT,Dash dot __ . __ . __ . __ . __ . __ . __ . __
   A,.5,-.25,0,-.25

This indicates a repeating pattern starting with a dash 0.5 drawing units long, a space 0.25 drawing units long, a dot, and another space 0.25 drawing units long. This pattern continues for the length of the line, ending with a dash 0.5 drawing units long. The linetype would be displayed as shown below.

   __ . __ . __ . __ . __ . __ . __ . __

LIN files must be saved in ASCII format and use an .lin file extension. Additional information about each field in a linetype definition follows.
**Linetype Name**

The linetype name field begins with an asterisk (*) and should provide a unique, descriptive name for the linetype.

**Description**

The description of the linetype should help you visualize the linetype when you edit the LIN file. The description is also displayed in the Linetype Manager and in the Load or Reload Linetypes dialog box.

The description is optional and can include

- A simple representation of the linetype pattern using ASCII text
- An expanded description of the linetype
- A comment such as "Use this linetype for hidden lines"

If you omit the description, do not insert a comma after the linetype name. A description cannot exceed 47 characters.

**Alignment Field (A)**

The alignment field specifies the action for pattern alignment at the ends of individual lines, circles, and arcs. Currently, AutoCAD LT supports only A-type alignment, which guarantees that the endpoints of lines and arcs start and stop with a dash.

For example, suppose you create a linetype called CENTRAL that displays the repeating dash-dot sequence commonly used as a centerline. AutoCAD LT adjusts the dash-dot sequence on an individual line so that dashes and line endpoints coincide. The pattern fits the line so that at least half of the first dash begins and ends the line. If necessary, the first and last dashes are lengthened. If a line is too short to hold even one dash-dot sequence, AutoCAD LT draws a continuous line between the endpoints. For arcs also, the pattern is adjusted so that dashes are drawn at the endpoints. Circles do not have endpoints, but AutoCAD LT adjusts the dash-dot sequence to provide a reasonable display.

You must specify A-type alignment by entering `a` in the alignment field.
Pattern Descriptors

Each pattern descriptor field specifies the length of segments making up the linetype, separated by commas (no spaces are allowed):

- A positive decimal number denotes a pen-down (dash) segment of that length.
- A negative decimal number denotes a pen-up (space) segment of that length.
- A dash length of 0 draws a dot.

You can enter up to 12 dash-length specifications per linetype, provided they fit on one 80-character line in the LIN file. You need to include only one complete repetition of the linetype pattern defined by pattern descriptors. When the linetype is drawn, AutoCAD LT uses the first pattern descriptor for the starting and ending dashes. Between the starting and ending dashes, the pattern dash specifications are drawn sequentially, beginning with the second dash specification and restarting the pattern with the first dash specification when required.

A-type alignment requires that the first dash length be 0 or greater (a pen-down segment). The second dash length should be less than 0 if you need a pen-up segment and more than 0 if you are creating a continuous linetype. You must have at least two dash specifications for A-type alignment.

To create a simple linetype from the Command prompt

1. At the command prompt, enter -linetype.
2. Enter c (Create).
3. Enter a name for the linetype and press ENTER.
   The linetype name can include up to 255 characters. Linetype names can contain letters, digits, and the special characters dollar sign ($), hyphen (-), and underscore (_). Linetype names cannot include blank spaces.
4. In the Create or Append Linetype File dialog box, select an LIN linetype library file from the File Name box and choose Save.
   If you select an existing file, the new linetype name is added to the linetype names in the file.
5. Enter text that describes the new linetype (optional).
At the Enter Pattern prompt, specify the pattern of the line. Follow these guidelines:

- All linetypes must begin with a dash.
- Enter zeros for dots.
- Enter negative real numbers for spaces. The value defines the length of the space in drawing units.
- Enter positive real numbers for dashes. The value defines the length of the dash in drawing units.
- Separate each dot, dash, or space value from the next with a comma.
- Use a space between a dot and a dash.

Press ENTER to end the command.

**NOTE** When you create a linetype, it is not loaded into your drawing automatically. Use the Load option of LINETYPE.

**To add a simple linetype to a LIN file**

1. Open the `acadlt.lin` or `acadltiso.lin` file in a text editor that saves in ASCII format (for example, Notepad).

2. Create a header line that includes an asterisk and a linetype pattern name. The name of the linetype pattern is limited to 31 characters.

3. (Optional) To include a description in the header line, follow the linetype pattern name with a comma and description text.

4. Create a descriptor line that includes:
   - All linetypes must begin with a dash.
   - Enter zeros for dots.
   - Enter negative real numbers for spaces. The value defines the length of the space in drawing units.
   - Enter positive real numbers for dashes. The value defines the length of the dash in drawing units.
   - Separate each dot, dash, or space value from the next with a comma.
   - Use a space between a dot and a dash.
Quick Reference

Commands
LINETYPE
Loads, sets, and modifies linetypes.

System Variables
MEASUREINIT
Controls whether a drawing you start from scratch uses imperial or metric default settings.

Text in Custom Linetypes
Characters from text fonts can be included in linetypes. Linetypes with embedded characters can denote utilities, boundaries, contours, and so on. As with simple linetypes, lines are dynamically drawn as you specify the vertices. Characters embedded in lines are always displayed completely; they are never trimmed.

Embedded text characters are associated with a text style in the drawing. Any text styles associated with a linetype must exist in the drawing before you load the linetype.

The format for linetypes that include embedded characters is similar to that for simple linetypes in that it is a list of pattern descriptors separated by commas.

Character Descriptor Format
The format for adding text characters in a linetype description is as follows:

"text",textstylename,scale,rotation,xoffset,yoffset

This format is added as a descriptor to a simple linetype. For example, a linetype called HOT_WATER_SUPPLY is defined as

*HOT_WATER_SUPPLY,---- HW ---- HW ---- HW ---- HW ---- HW ---- A,.5,−.2,\("HW",STANDARD,S=.1,U=0.0,X=0.1,Y=−.05\),−.2

This indicates a repeating pattern starting with a dash 0.5 drawing units long, a space 0.2 drawing units long, the characters HW with some scale and placement parameters, and another space 0.2 drawing units long. The text
characters come from the text font assigned to the STANDARD text style at a scale of 0.1, an upright rotation of 0 degrees, an X offset of -0.1, and a Y offset of -0.05. This pattern continues for the length of the line, ending with a dash 0.5 drawing units long. The linetype would be displayed as shown below.

Notice that the total upstroke length is 0.2 + 0.2 = 0.4 and that the text origin is offset -.01 units in the X direction from the end of the first upstroke. An equivalent linetype would be

```
*HOT_WATER_SUPPLY,---- HW ---- HW ---- HW ---- HW ---- HW ----
A,.5,-.1, ["HW",STANDARD,S=.1,U=0.0,X=0.0,Y=-.05],-.3
```

The total upstroke is still 0.1 + 0.3 = 0.4, but the text origin is not offset in the X direction.

Additional information about each field in the character descriptor follows. The values to be used are signed decimal numbers such as 1, -17, and 0.01.

**text** The characters to be used in the linetype.

**text style name** The name of the text style to be used. If no text style is specified, AutoCAD LT uses the currently defined style.

**scale** S=value. The scale factor to be used for the text style relative to the scale of the linetype. The height of the text style is multiplied by the scale factor. If the height is 0, the value for S=value alone is used as the height.

**rotation** U=value, R=value, or A=value. U- specifies upright or easy-to-read text. R- specifies relative or tangential rotation with respect to the line. A- specifies absolute rotation of the text with respect to the origin; that is, all text has the same rotation regardless of its position relative to the line. The value can be appended with a d for degrees (degrees is the default value), r for radians, or g for grads. If rotation is omitted, 0 relative rotation is used. Rotation is centered between the baseline and the nominal cap height.
NOTE Drawings containing legacy linetypes that do not use the U (upright) rotation flag can be updated to the latest linetype definition by reloading the linetype from the LIN files. Custom linetypes can be updated by changing the R (rotation) flag to the U (upright) flag prior to reloading a linetype definition. For information on loading a linetype, see Load Linetypes.

xoffset X=value. The shift of the text on the X axis of the linetype, which is along the line. If xoffset is omitted or is 0, the text is elaborated with no offset. Use this field to control the distance between the text and the previous pen-up or pen-down stroke. This value is not scaled by the scale factor defined by S=value, but it is scaled to the linetype.

yoffset Y=value. The shift of the text in the Y axis of the linetype, which is at a 90-degree angle to the line. If yoffset is omitted or is 0, the text is elaborated with no offset. Use this field to control the vertical alignment of the text with respect to the line. This value is not scaled by the scale factor defined by S=value, but it is scaled to the linetype.

To include text characters in linetypes

1 Create a simple linetype, as described in To add a simple linetype to a LIN file on page 23.

2 Add the text character descriptor within the linetype pattern, using the following format:

   ["text",textstylename,scale,rotation,xoffset,yoffset]

Quick Reference

Commands
LINETYPE
Loads, sets, and modifies linetypes.

System Variables
MEASUREINIT
Controls whether a drawing you start from scratch uses imperial or metric default settings.
Custom Hatch Patterns

AutoCAD LT® provides a library of standard hatch patterns in the `acadlt.pat` and `acadltiso.pat` files. You can use the hatch patterns as they are, modify them, or create your own custom hatch patterns.

Overview of Hatch Pattern Definitions

In addition to using the predefined hatch patterns that are supplied, you can design and create your own custom hatch patterns.

In addition to using the predefined hatch patterns that are supplied, you can design and create your own custom hatch patterns. Developing a hatch pattern definition requires knowledge, practice, and patience. Because customizing hatches requires familiarity with hatch patterns, it is not recommended for new users.

The hatch patterns supplied by AutoCAD LT are stored in the `acadlt.pat` and `acadltiso.pat` text files. You can add hatch pattern definitions to this file or create your own files.

Regardless of where the definition is stored, a custom hatch pattern has the same format. It has a header line with a name, which begins with an asterisk and is no more than 31 characters long, and an optional description:

```
*pattern-name, description
```

It also has one or more line descriptors of the following form:

```
angle, x-origin, y-origin, delta-x, delta-y, dash-1, dash-2, ...
```

The default hatch pattern ANSI31 shown in the Boundary Hatch and Fill dialog box looks like this:
and is defined as follows:

*ANSI31, ANSI Iron, Brick, Stone masonry
45, 0,0, 0,.125

The pattern name on the first line, *ANSI31, is followed by a description: ANSI
Iron, Brick, Stone masonry. This simple pattern definition specifies a line
drawn at an angle of 45 degrees, that the first line of the family of hatch lines
is to pass through the drawing origin (0,0), and that the spacing between
hatch lines of the family is to be 0.125 drawing units.

Hatch pattern definitions follow these rules:

- Each line in a pattern definition can contain up to 80 characters. You can
  include letters, numbers, and the special characters underline (_), hyphen
  (-), and dollar sign ($). However, you must begin a pattern definition with
  a letter or number, not a special character.

- AutoCAD LT ignores both blank lines and text to the right of a semicolon.

- Each pattern line is considered to be the first member of a line family,
  created by applying the delta offsets in both directions to generate an
  infinite family of parallel lines.

- The \textit{delta-x} value indicates the displacement between members of the
  family in the direction of the line. It is used only for dashed lines.

- The \textit{delta-y} value indicates the spacing between members of the family;
  that is, it is measured perpendicular to the lines.

- A line is considered to be of infinite length. A dash pattern is superimposed
  on the line.

\textbf{NOTE} A blank line must be placed after the last hatch pattern definition in a PAT
file. If a blank line is not placed after the last hatch pattern definition, the last hatch
pattern definition will not be accessible when creating a hatch fill.

The process of hatching consists of expanding each line in the pattern
definition to its infinite family of parallel lines. All selected objects are checked
for intersections with any of these lines; any intersections cause the hatch
lines to be turned on and off as governed by the hatching style. Each family
of hatch lines is generated parallel to an initial line with an absolute origin to guarantee proper alignment.

If you create a very dense hatch, AutoCAD LT may reject the hatch and display a message indicating that the hatch scale is too small or its dash length too short. You can change the maximum number of hatch lines by setting the MaxHatch system registry variable using SETENV and entering a number between 100 and 10000000 (ten million).

**NOTE** When changing the value of MaxHatch, you must enter MaxHatch with the capitalization as shown.

**To create a simple hatch pattern**

1. Open the `acadlt.pat` or `acadltiso.pat` file in a text editor that saves in ASCII format (for example, Microsoft® Windows® Notepad).

2. Create a header line that includes an asterisk and a pattern name. The name of the hatch pattern is limited to 31 characters.

3. (Optional) To include a description in the header line, follow the pattern name with a comma and description text.

4. Create a descriptor line that includes
   - An angle at which the line is drawn
   - An X,Y origin point
   - A `delta-x` of 0
   - A `delta-y` of any value

**Quick Reference**

**Commands**

ADCENTER

Manages and inserts content such as blocks, xrefs, and hatch patterns.

FILL

Controls the filling of objects such as hatches, 2D solids, and wide polylines.
HATCH
HATCHEDIT
Modifies an existing hatch or fill.
SOLID
Creates solid-filled triangles and quadrilaterals.

System Variables
FILLMODE
Specifies whether hatches and fills, 2D solids, and wide polylines are filled in.
HPANG
Sets the angle for new hatch patterns.
HPBOUND
Controls the object type created by HATCH and BOUNDARY.
HPDOUBLE
Specifies hatch pattern doubling for user-defined patterns.
HPNAME
Sets the default hatch pattern name.
HPSCALE
Sets the hatch pattern scale factor.
HPSPACE
Sets the hatch pattern line spacing for user-defined patterns.

Hatch Patterns with Dashed Lines
To define dashed-line patterns, you append dash-length items to the end of the line definition item.

To define dashed-line patterns, you append dash-length items to the end of the line definition item. Each dash-length item specifies the length of a segment making up the line. If the length is positive, a pen-down segment is drawn. If the length is negative, the segment is pen-up, and it is not drawn. The pattern starts at the origin point with the first segment and cycles through
the segments in circular fashion. A dash length of 0 draws a dot. You can specify up to six dash lengths per pattern line.

The hatch pattern ANSI33, shown in the Boundary Hatch and Fill dialog box, looks like this:

```
\[ ------------------- \\
| \| \| \| \| \| \| |
| \| \| \| \| \| \| |
| \| \| \| \| \| \| |
| \| \| \| \| \| \| |
```

and is defined as follows:

```
*ANSI33, ANSI Bronze, Brass, Copper
45, .176776695,0, 0,.25, .125,-.0625
```

For example, to modify a pattern for 45-degree lines to draw dashed lines with a dash length of 0.5 units and a space between dashes of 0.5 units, the line definition would be

```
*DASH45, Dashed lines at 45 degrees
45, 0,0, 0,.5, .5,-.5
```

This is the same as the 45-degree pattern shown in Overview of Hatch Pattern Definitions on page 27, but with a dash specification added to the end. The pen-down length is 0.5 units, and the pen-up length is 0.5, meeting the stated objectives. If you wanted to draw a 0.5-unit dash, a 0.25-unit space, a dot, and a 0.25-unit space before the next dash, the definition would be

```
*DDOT45, Dash-dot-dash pattern: 45 degrees
45, 0,0, 0,.5, .5,-.25, 0,-.25
```

The following example shows the effect of delta-x specifications on dashed-line families. First, consider the following definition:

```
*GOSTAK
0, 0,0, 0,.5, .5,-.5
```

This draws a family of lines separated by 0.5, with each line broken equally into dashes and spaces. Because delta-x is zero, the dashes in each family member line up. An area hatched with this pattern would look like this:

```
--- --- ---
--- --- ---
--- --- ---
```
Now change the pattern to

```
*SKEWED
0, 0, .5, .5, .5, -.5
```

It is the same, except that you have set \textit{delta-x} to 0.5. This offsets each successive family member by 0.5 in the direction of the line (in this case, parallel to the \textit{X} axis). Because the lines are infinite, the dash pattern slides down the specified amount. The hatched area would look like this:

```
-- --- --- ---
-- --- --- ---
-- --- --- ---
```

\textbf{To create a hatch pattern with dashed lines}

1. Open the \textit{acadlt.pat} or \textit{acadltiso.pat} file in a text editor that saves in ASCII format (for example, Notepad).

2. Create a header line that includes an asterisk and a pattern name. The name of the hatch pattern is limited to 31 characters.

3. (Optional) To include a description in the header line, follow the pattern name with a comma and description text.

4. Create a descriptor line that includes
   - An angle at which the line is drawn
   - An \textit{X,Y} origin point
   - A \textit{delta-x} of any value if you want to offset alternating lines in the line family
   - A \textit{delta-y} of any value
   - A value for a dash length
   - A value for a dot length
   - An optional second value for a different dash length
   - An optional second value for a different dot length
Quick Reference

Commands

ADCENTER
Manages and inserts content such as blocks, xrefs, and hatch patterns.

FILL
Controls the filling of objects such as hatches, 2D solids, and wide polylines.

HATCH

HATCHEDIT
Modifies an existing hatch or fill.

SOLID
Creates solid-filled triangles and quadrilaterals.

System Variables

FILLMODE
Specifies whether hatches and fills, 2D solids, and wide polylines are filled in.

HPANG
Sets the angle for new hatch patterns.

HPBOUND
Controls the object type created by HATCH and BOUNDARY.

HPDOUBLE
Specifies hatch pattern doubling for user-defined patterns.

HPNAME
Sets the default hatch pattern name.

HPSCALE
Sets the hatch pattern scale factor.

HPSPACE
Sets the hatch pattern line spacing for user-defined patterns.
Hatch Patterns with Multiple Lines

Complex hatch patterns can have an origin that passes through offsets from the origin and can have multiple members in the line family.

Not all hatch patterns use origin points of 0,0. Complex hatch patterns can have an origin that passes through offsets from the origin and can have multiple members in the line family. In composing more complex patterns, you need to carefully specify the starting point, offsets, and dash pattern of each line family to form the hatch pattern correctly.

The hatch pattern AR-B816 shown in the Boundary Hatch and Fill dialog box looks like this:

*AR-B816, 8x16 Block elevation stretcher bond
0, 0, 0, 8
90, 0, 0, 8, 8, -8

The following figure illustrates a squared-off, inverted-U pattern (one line up, one over, and one down). The pattern repeats every one unit, and each unit is 0.5 high and wide.

This pattern would be defined as follows:

*IUS, Inverted U's
90, 0, 0, 0, 1, .5, -.5
0, 0, 0, .5, 0, 1, .5, -.5
270, .5, .5, 0, 1, .5, -.5

The first line (the up bar) is a simple dashed line with 0,0 origin. The second line (the top bar) should begin at the end of the up bar, so its origin is 0,.5. The third line (the down bar) must start at the end of the top bar, which is at
.5,.5 for the first instance of the pattern, so its origin is at this point. The third line of the pattern could be the following:

\[ 90, .5, 0, 0, 1, .5, -.5 \]

or

\[ 270, .5, 1, 0, 1, -.5, .5 \]

The dashed pattern starts at the origin points and continues in the vector direction given by the angle specification. Therefore, two dashed-line families that are opposed 180 degrees are not alike. Two solid-line families are alike.

The following pattern creates six-pointed stars.

This example can help you refine your skills at pattern definition. (Hint: 0.866 is the sine of 60 degrees.)

The following is the AutoCAD LT definition of this pattern:

```
*STARS,Star of David
0, 0, 0, 0, .866, .5, -.5
60, 0, 0, 0, .866, .5, -.5
120, .25, .433, 0, .866, .5, -.5
```

**To create a hatch pattern with multiple lines**

1. Open the `acadlt.pat` or `acadltiso.pat` file in a text editor that saves in ASCII format (for example, Notepad).

2. Create a header line that includes an asterisk and a pattern name. The name of the hatch pattern is limited to 31 characters.

3. (Optional) To include a description in the header line, follow the pattern name with a comma and description text.

4. Create a descriptor line that includes:
   - An angle at which the line is drawn
   - An X,Y origin point
   - A delta-x of any value if you want to offset alternating lines in the line family
A \textit{delta-y} of any value

A value for a dash length

A value for a dot length

An optional second value for a different dash length

An optional second value for a different dot length

5 Create a second line including all the parameters in the previous step.

6 (Optional) Create additional lines to complete the multiple-line hatch pattern.

\section*{Quick Reference}

\section*{Commands}

\textbf{ADCENTER}

Manages and inserts content such as blocks, xrefs, and hatch patterns.

\textbf{FILL}

Controls the filling of objects such as hatches, 2D solids, and wide polylines.

\textbf{HATCH}

\textbf{HATCHEDIT}

Modifies an existing hatch or fill.

\textbf{SOLID}

Creates solid-filled triangles and quadrilaterals.

\section*{System Variables}

\textbf{FILLMODE}

Specifies whether hatches and fills, 2D solids, and wide polylines are filled in.

\textbf{HPANG}

Sets the angle for new hatch patterns.

\textbf{HPBOUND}

Controls the object type created by HATCH and BOUNDARY.
HPDOUBLE
   Specifies hatch pattern doubling for user-defined patterns.
HPNAME
   Sets the default hatch pattern name.
HPSCALE
   Sets the hatch pattern scale factor.
HPSPACE
   Sets the hatch pattern line spacing for user-defined patterns.
When you work in the program, you use a variety of ribbon panels, menus, toolbars, shortcut keys, and other user interface elements to help you accomplish your tasks efficiently. You can also streamline your environment by customizing these elements.

**Understand User Interface Customization**

Using the customization tools of AutoCAD LT, you can tailor your drawing environment to suit your needs. Customization capabilities, including the customize (CUIx) file format and the Customize User Interface (CUI) Editor, help you to easily create and modify customized content.

**Overview of the Customization**

Customization of the user interface is done by modifying the XML-based CUIx file with the Customize User Interface (CUI) Editor. The XML-based CUIx file replaces the customization and menu files from releases prior to AutoCAD LT 2011. Instead of using a text editor to customize menu files (MNU and MNS files) used in release prior to AutoCAD 2006, you customize the user interface from within AutoCAD LT. You can

- Add or change toolbars, menus, and ribbon panels (including shortcut menus, image tile menus, and tablet menus)
- Add and modify the commands on the Quick Access toolbar
- Create or change workspaces
- Assign commands to various user interface elements
Create or change macros
Define DIESEL strings
Create or change aliases
Add descriptive text for command tooltips
Control the properties displayed when using rollover tooltips

Customizable User Interface Elements

The editor allows you to create and manage commands that are used in the CUIx file in a centralized location. Along with commands, you are able to customize many of the different user interface elements. From the CUI Editor you can customize:

- Double click actions
- Legacy user interface elements (tablets, tablet buttons, screen menus and image tile menus)
- Mouse buttons
- Pull-down menus
- Quick Access toolbar
- Quick properties
- Toolbars
- Ribbon panels
- Ribbon tabs
- Ribbon contextual tab states
- Rollover tooltips
- Shortcut keys
- Shortcut menus
- Temporary override keys
- Workspaces
Quick Reference

Commands

CUI
Manages the customized user interface elements in the product.

CUIEXPORT
Exports customized settings from the main CUIx file to an enterprise or partial CUIx file.

CUIIMPORT
Imports customized settings from an enterprise or partial CUIx file to the main CUIx file.

CUILOAD
Loads a CUIx file.

CUIUNLOAD
Unloads a CUIx file.

QUICKCUI
Displays the Customize User Interface Editor in a collapsed state.

System Variables

DBLCLKEDIT
Controls the double click editing behavior in the drawing area.

TOOLTIPS
Controls the display of tooltips on the ribbon, toolbars, and other user interface elements.

Use the Customization Environment

You customize the XML-based CUIx file with the Customize User Interface (CUI) Editor to create new commands, user interface elements, and workspaces.
Overview of the Customize User Interface (CUI) Editor

The Customize User Interface (CUI) Editor is used to customize the user interface of AutoCAD LT. Before you start customizing your own menus, toolbars, and other user interface elements, you should familiarize yourself with the customization environment.

To open the Customize User Interface Editor, click Manage tab ➤ Customization panel ➤ User Interface. Once the Customize User Interface (CUI) Editor is opened, view the contents of the loaded customization files by expanding the elements in the tree structure, and view the properties of the elements by selecting them.

Select the Transfer tab to see how to migrate or transfer customizations; select the Customize tab to see how to create or modify user interface elements.

Once you are familiar with the environment, you can start to take advantage of the capabilities of the tools. For more information about the improved customization capabilities, see How Customization Has Changed on page 48.

Following is an example of the Customize User Interface (CUI) Editor, Customize tab. You use this tab to customize interface elements in CUIx files.
Customize the user interface to make the drawing environment specific to certain types of tasks. For example, if you want a toolbar that contains the commands you use most often, you can create a new Favorites toolbar in the Customize User Interface (CUI) Editor and then load the new toolbar in AutoCAD LT.

**Quick Reference**

**Commands**

**CUI**

Manages the customized user interface elements in the product.

**CUIEXPORT**

Exports customized settings from the main CUIx file to an enterprise or partial CUIx file.
**CUIIMPORT**
Imports customized settings from an enterprise or partial CUIx file to the main CUIx file.

**CUILOAD**
Loads a CUIx file.

**CUIUNLOAD**
Unloads a CUIx file.

**QUICKCUI**
Displays the Customize User Interface Editor in a collapsed state.

**System Variables**

**DBLCLKEDIT**
Controls the double click editing behavior in the drawing area.

**TOOLTIPS**
Controls the display of tooltips on the ribbon, toolbars, and other user interface elements.

**Work with the Customizations In Pane**

The Customizations In pane is used to navigate the different user interface elements that are in the loaded customization files.

In this pane, you create and modify user interface elements such as workspaces, toolbars, and menus. Along the top of the pane you will find tools that load partial customization files into the main customization file, save changes to the loaded customization files, and control how you view the loaded customization files.

The tree view is used to create new user interface elements such as toolbars and menus. Once a new user interface element is created, commands can then be added by dragging them from the Command List pane. Along with being able to create user interface elements and add commands to a user interface element, you can change the order in which commands appear on toolbars, menus, and ribbon panels by dragging them up and down.
Quick Reference

Commands

CUI

Manages the customized user interface elements in the product.

Work with the Command List Pane

The Command List pane is used to create and locate commands that are contained in the loaded customization files.

Use the Create a New Command button to create a new custom command in the CUIx file that is listed in the Customization File drop-down list at the top of the Customizations In <file name> pane. A command must be created before it can be associated with a user interface element in the Customizations In <file name> pane.

Next to the Create a New Command button is the Find Command or Text button. The Find Command or Text button displays the Find and Replace dialog box, where you can search for or replace text strings in the Command List pane only.

The Categories drop-down list near the top of the Command List pane contains a listing of preset categories used to filter the commands displayed in the Command list box. There are many different categories that you can select from, for example

- **All Commands.** Displays all of the commands for each of the loaded customization files.
Custom Commands. Displays the user defined commands that have been added to the loaded customization files. These commands are not part of a customization file that ships with AutoCAD LT.

Controls Elements. Displays the special controls that can be added to a toolbar or ribbon panel, such as drop-down lists, sliders, and other controls.

Available commands and controls are displayed in the bottom of the Command List pane. The names of the available commands, the image that is assigned to a command, and the name of the customization group that the command is assigned to are displayed. When the cursor hovers over top of a command, the macro assigned to the command is displayed in a tooltip.

At the top of the Command List pane is the Command Filter field which allows you to filter the Command list based on the text string entered. The text string is matched with any part of a command name, and the commands with the matching text strings are displayed in the Command list box.

Quick Reference

Commands

CUI

Manages the customized user interface elements in the product.

Work with the Dynamic Display Pane

The Dynamic Display pane controls the display of additional panes that respond to the item that is selected in either the Customizations In pane or Command List pane.
Based on the item selected, one or more of the following panes will be displayed:

- Button Image
- Information
- Panel Preview
- Properties
- Quick Properties
- Shortcuts
- Toolbar Preview
- Workspace Contents
Quick Reference

Commands

CUI

Manages the customized user interface elements in the product.

How Customization Has Changed

Although the basic customization techniques remain the same as in previous versions of the product, the environment that you use to customize the product was changed starting with AutoCAD 2006.

All of the previous customization options are still available. You are still able to create, edit, and delete interface elements; you can create partial customization files; you can use macros and DIESEL expressions.

However, you no longer perform customization tasks by creating or editing MNU or MNS text files by hand. All customizations are done through the program interface, in the Customize User Interface (CUI) Editor.

Menu Files Versus Customization Files

In releases prior to AutoCAD 2006, you customized the user interface by editing an MNU or MNS file in an ASCII text editor such as Notepad. You manually entered and verified customization data in the text file, which could be a tedious and error-prone process. As a result, a simple syntax error (such as mismatched parentheses) in the text file could invalidate the entire menu file, leading you back to the text file to investigate where you made the error.

With the Customize User Interface (CUI) Editor, you drag a command to a menu or toolbar or right-click to add, delete, or modify a user interface element. The Customize User Interface (CUI) Editor displays element properties and a list of options to choose from. This prevents you from creating syntax errors or spelling mistakes that may have occurred when you manually entered text in an MNU or MNS file.

The MNU and MNS files used in the past have been replaced with just one file type, the XML-based CUIx file. CUIx is the successor to the CUI file format which was introduced in AutoCAD 2006.

The XML-based format of the CUIx file allows the product to track customizations. When upgrading to a future version of the program, all of your customizations are automatically integrated into the new release. The XML format also supports a backward-compatible customization file. This
means that you can view a CUIx file from a future version in the previous release while preserving the customization data from the future version. However, you cannot modify the future version’s CUIx file in the previous release. For more information about migrating customization data, see Transfer and Migrate Customization on page 316.

The following table lists the menu files that previously shipped with the product and shows how those files are mapped to AutoCAD LT 2011.

<table>
<thead>
<tr>
<th>Menu file</th>
<th>Description</th>
<th>In AutoCAD LT 2011</th>
<th>Description of change</th>
</tr>
</thead>
<tbody>
<tr>
<td>MNU</td>
<td>ASCII text file. In previous releases, defined most user interface elements. The main MNU file, aclt.mnu, was automatically loaded when you started the product. Partial MNU files could be loaded or unloaded as you needed them during a drawing session.</td>
<td>CUIx</td>
<td>An XML file that defines most user interface elements. The main CUIx file, acadlt.cuix, is automatically loaded when you start the product. Partial CUIx files can be loaded or unloaded as you need them during a drawing session.</td>
</tr>
<tr>
<td>MNS</td>
<td>Source menu file. Was the same as the MNU ASCII text file but did not contain comments or special formatting.</td>
<td>CUIx</td>
<td>An XML file that defines most user interface elements. The main CUIx file, acadlt.cuix, is automatically loaded when you start the product. Partial CUIx files can be loaded or unloaded as you need them during a drawing session.</td>
</tr>
<tr>
<td>MNC</td>
<td>Compiled ASCII text file. Contained command strings and syntax that defined the functionality and appearance of user interface elements.</td>
<td>CUIx</td>
<td>An XML file that defines most user interface elements. The main CUIx file, acadlt.cuix, is automatically loaded when you start the product. Partial CUIx files can be loaded or unloaded as you need them during a drawing session.</td>
</tr>
</tbody>
</table>
Menu files mapped to CUIx files

<table>
<thead>
<tr>
<th>Menu file</th>
<th>Description</th>
<th>In AutoCAD LT 2011</th>
<th>Description of change</th>
</tr>
</thead>
<tbody>
<tr>
<td>MNR</td>
<td>Menu resource file. Contains the bitmaps that are used by the user interface elements.</td>
<td>MNR</td>
<td>No change.</td>
</tr>
</tbody>
</table>

Menu Text File Structure Versus CUI and CUIx Structure

In releases prior to AutoCAD 2006, you added, edited, and deleted menu information directly in a text file. In AutoCAD 2006 and later, you use the Customize User Interface (CUI) Editor.

Following is an example of how the Window menu looked in the legacy menu file `aclt.mnu`.

Contents of the Window menu in `aclt.mnu`

<table>
<thead>
<tr>
<th>Window menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>***POP10</td>
<td></td>
</tr>
<tr>
<td>**WINDOW</td>
<td></td>
</tr>
<tr>
<td>ID_MnWindow [Window]</td>
<td></td>
</tr>
<tr>
<td>ID_DWG_CLOSE [Close]^C^C_close</td>
<td></td>
</tr>
<tr>
<td>ID_WINDOW_CLOSEALL [Close All]^C^C_closeall</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>ID_WINDOW_CASCADE [Cascade]^C^C_syswindows;_cascade</td>
<td></td>
</tr>
<tr>
<td>ID_WINDOW_TILE_HORZ [Tile Horizontally]^C^C_syswindows;_hor</td>
<td></td>
</tr>
<tr>
<td>ID_WINDOW_TILE_VERT [Tile Vertically]^C^C_syswindows;_vert</td>
<td></td>
</tr>
<tr>
<td>ID_WINDOW_ARRANGE [Arrange Icons]^C^C_syswindows;_arrange</td>
<td></td>
</tr>
</tbody>
</table>

Compare the menu data above with the same menu data as it is displayed in the Customize User Interface (CUI) Editor, in the tree view.
For a more detailed comparison, following are examples of the Window menu properties, Close command properties, Close All command properties, and the Window shortcut menu that is displayed with the Insert Separator option.

Window menu Properties pane

Window menu, Properties pane for the Close command

Window menu, Properties pane for the Close All command
Window menu tree node, shortcut menu displayed with Insert Separator option

Menu Group Versus Customization Group

There is no difference between a menu group (the term used in previous releases) and a customization group. A CUIx file loaded into AutoCAD LT must have a unique customization group name to prevent conflicts between customization files in the program.

The main CUIx file, `acadlt.cuix` by default, has a customization group named ACADLT. You can load as many customization files into the program, as long as they each have a unique customization group name.

Following is an example of how you change the ACAD customization group name in the Customize tab of the Customize User Interface (CUI) Editor. You can change the partial CUIx file (named CUSTOM in this example) using the same method.
Dynamic Help

Dynamic Help is a feature that is in the online Help system and references some of the customization elements that are found in the CUIx file when it is loaded into AutoCAD LT. What Dynamic Help does, is it looks up the Element ID of a command that has been identified in the online Help system, and where that command is currently being referenced on a ribbon panel or menu when the CUIx file is loaded.

If the command is on a ribbon panel or menu, access to the command is updated in the online Help system to reflect the new location of the command. If one of the standard commands that ships with AutoCAD LT is moved from one ribbon panel or menu to another, the online Help system will automatically reflect this change the next time it is displayed. Currently, only commands on ribbon panels and menus work with Dynamic Help.

Dynamic Help may not display properly if a command is not available:

■ In one of the loaded CUIx files
■ On an accessible menu, ribbon panel, or ribbon tab in the current workspace

NOTE Dynamic Help only works with the online Help documents that come with AutoCAD LT, and has no affect on third-party documentation.

See also:

■ Transfer and Migrate Customization on page 316
■ Create and Load a Partial CUIx File on page 78
Quick Reference

Commands

CUI
Manages the customized user interface elements in the product.

CUIEXPORT
Exports customized settings from the main CUIx file to an enterprise or partial CUIx file.

CUIIMPORT
Imports customized settings from an enterprise or partial CUIx file to the main CUIx file.

CUILOAD
Loads a CUIx file.

CUIUNLOAD
Unloads a CUIx file.

QUICKCUI
Displays the Customize User Interface Editor in a collapsed state.

Customization Glossary

You should know several terms for customizing AutoCAD LT 2011.

Customization (CUIx) file A package file that contains multiple XML-based files and custom image files. Each one of the XML-based files contain the data for a different type of user interface element that can be customized. The custom images that are stored in the file are those that are referenced by the commands defined in the customization data and are not stored in a resource DLL. You modify a customization file through the Customize User Interface (CUI) Editor. CUIx files replace the CUI, MNU, MNS, and MNC files that were used to define menus in releases prior to AutoCAD LT 2011.

Customization group A name that is assigned to a CUIx file to identify customization content in the CUIx file. A CUIx file loaded into AutoCAD LT must have a unique customization group name to prevent conflicts between
CUIX files in the program. In releases prior to AutoCAD 2006, called a menugroup.

**Element ID** A unique identifier of an interface element. In previous releases, called a *tag*.

**Dashboard panel** An organizational structure used to lay out commands and controls for display on the dashboard, which was available in AutoCAD LT 2007 and AutoCAD LT 2008. The dashboard was replaced by the ribbon in AutoCAD LT 2009 and later. For information about transferring dashboard panels to ribbon panels, see [To copy a dashboard panel to a ribbon panel](#) on page 152.

**Enterprise customization file** A CUIX file that is typically controlled by a CAD manager. It is often accessed by many users and is stored in a shared network location. The file is read-only to users to prevent the data in the file from being changed. A CAD manager creates an enterprise CUIX file by modifying a main CUIX file and then saving the file to a shared network location. Users then specify this file in the Options dialog box, Files tab.

**Interface element** An object that can be customized, such as a toolbar, pull-down menu, shortcut key, palette, and so on. It is a node in the Customizations In *<file name>* pane that contains user interface items.

**Interface item** The individual parts of a user interface element, such as a toolbar button, pull-down menu item, shortcut key, temporary override key, and so on.

**Legacy Customization (CUI) file** An XML-based file that stores customization data for AutoCAD 2006 through AutoCAD LT 2009. The CUI file has been replaced by the CUIX file. A CUIX file can be generated from a CUI file using the Transfer tab of the CUI command.

**Legacy Menu (MNS) file** An ASCII based file that stores menu customization data for AutoCAD 2005 and earlier. Most of the file needed to be edited outside of AutoCAD LT using a text editor such as Notepad, but there were a few features that could be customized in AutoCAD LT using the CUSTOMIZE command. The MNS file has been replaced by the CUIX file. A CUIX file can be generated from an MNS file using the Transfer tab of the CUI command.

**Legacy Menu Template (MNU) file** An ASCII based file that is used as a template to define the contents of the MNS file when the MNU file is loaded into AutoCAD LT with the MENU command. The MNU file is used in AutoCAD 2005 and earlier, and is very similar to the MNS file. The MNU file has been replaced by the CUIX file. A CUIX file can be generated from a MNU file using the Transfer tab of the CUI command.
Macro A series of commands that are run in a defined sequence to accomplish a drawing task.

Main customization file A writable CUIx file that defines most of the user interface elements (including the standard menus, toolbars, keyboard accelerators, and so on). The acadlt.cuix file (the default main CUIx file) is automatically loaded when you start AutoCAD LT.

Ribbon An interface element that displays panels made up of commands and controls that can be docked horizontally or vertically along the program’s application window.

Ribbon panel An organizational structure used to lay out commands and controls for display on the ribbon or as a floating user interface.

Palette An interface element that can be docked or floating in the drawing area. Palettes include the Command Line window, Tool Palettes Window, Properties palette, and so on.

Partial customization file Any CUIx file that is not defined as the main or enterprise CUIx file. You can load and unload partial CUIx files as you need them during a drawing session.

Quick Access toolbar An interface element that is located to the right of the application menu and provides direct access to a defined set of commands.

Tree node A hierarchical structure in the Customize User Interface (CUI) Editor that contains interface elements and items that can be imported, exported, and customized.

Workspace A collection of user interface elements, including their contents, properties, display states, and locations.

Quick Reference

Commands

CUI

Manages the customized user interface elements in the product.

CUIEXPORT

Exports customized settings from the main CUIx file to an enterprise or partial CUIx file.
CUIIMPORT
Imports customized settings from an enterprise or partial CUIx file to the
main CUIx file.

CUILOAD
Loads a CUIx file.

CUIUNLOAD
Unloads a CUIx file.

CUSTOMIZE
Customizes tool palettes and tool palette groups.

QUICKCUI
Displays the Customize User Interface Editor in a collapsed state.

RIBBON
Opens the ribbon window.

RIBBONCLOSE
Closes the ribbon window.

TOOLPALETTES
Opens the Tool Palettes window.

TOOLPALETTESCLOSE
Closes the Tool Palettes window.

System Variables

DBLCLKEDIT
Controls the double click editing behavior in the drawing area.

ROLOVERTIPS
Controls the display of rollover tooltips in the application.

TOOLTIPS
Controls the display of tooltips on the ribbon, toolbars, and other user
interface elements.
Work with the Customize User Interface (CUI) Editor

With the Customize User Interface (CUI) Editor, you can create and manage standard and custom commands and user interface elements.

By customizing the user interface, you can arrange and access the commands that you frequently use. You can also extend AutoCAD LT by creating your own custom commands. Use the diagrams under this topic to understand the steps required to successfully create a custom command or to customize the various user interface elements that are available for customization.

Create a Command

Custom commands to define a series of actions that should be taken when the custom command is used. You can also determine how the command should appear when added to a user interface.

When creating a custom command, you need to give the command a unique name, element ID, and macro. Once the basic properties of a command have been defined, you can assign values to additional properties that determine the content for the command's tooltip, an image, and search tags. For more information about creating custom commands, see Customize Commands on page 92.

1. Set the working CUIx file on page 73
2. Add the new command on page 95
3. Define the macro on page 104

Determine which CUIx file to add to the custom command.
Create a new command in a CUIx file.
Define the series of actions that should be executed when the command is used from the user interface.
Control how the command and its name is displayed on page 113

Optional: Assign search tags to the command for use with the Search field on the application menu.

Optional: Assign tooltip text to the command, which is used when it is added to a ribbon panel or toolbar.

Optional: Assign extended help to the command which is used for the extended tooltip of a command.

Optional: Assign an image to the command. A standard or custom image can be assigned.

Optional: Assign status line text to the command which is used when it is added to a pull-down menu.
Create User Interface Elements

User interface elements are used to organize and display commands in AutoCAD LT.

To decide what user interface elements to create, determine how often you want to access a command. Then determine if you want to add the custom command to a shortcut key, the Quick Access toolbar, a ribbon panel or another type of user interface element.

Create a Quick Access Toolbar

You create Quick Access toolbars in the CUI Editor to determine which commands and controls are displayed on the Quick Access toolbar.

Quick Access toolbars are used to organize and display the commands that you frequently use. For more information about customizing the Quick Access toolbar, see Quick Access Toolbars on page 142.

Create a new Quick Access toolbar

Create a new Quick Access toolbar to hold the commands you want displayed.

Add commands and controls

Add the commands and controls to the Quick Access toolbar that you want to use.

Display a Quick Access toolbar

Assign the Quick Access toolbar to a workspace.

Set a workspace current

Set the workspace containing the Quick Access toolbar current.
Customize the Ribbon

Ribbon customization is broken out into three main components: panels, tabs, and contextual tab states. Each component of the ribbon is used to organize and display the commands that you want to use frequently.

Create a Ribbon Panel

Ribbon panels organize commands and controls on the ribbon.

You use rows, sub-panels, and drop-downs on a ribbon panel to organize the commands and controls you want to display on the ribbon. Each panel is divided into two halves with a panel separator; an upper and lower half. Rows above the panel separator are displayed by default while those below it are displayed only when the panel is expanded. Each panel can also be assigned a command to its Panel Launcher button, which can be used to start an associated dialog box. For more information about ribbon panel customization, see Ribbon Panels on page 149.

Create a new ribbon panel to organize the commands and controls you want to display on the ribbon.

Add rows to organize the commands and controls you want to add. Rows can also hold drop-downs and sub-panels.

Optional: Add drop-downs to organize multiple commands into a single drop-down list or split button.

Optional: Add fold panels to organize buttons, toggle buttons, split buttons and drop-down buttons within a row.

Create a new ribbon panel on page 150

Add a row on page 159

Add a drop-down on page 169

Add a fold panel on page 159
Once you have created a ribbon panel, it must be added to a ribbon tab before it can be displayed on the ribbon. For more information about assigning a ribbon panel to a ribbon panel, see the Create a Ribbon Tab on page 62 workflow diagram.

**Create a Ribbon Tab**

Ribbon tabs control and organize the display of a ribbon panel on the ribbon.
You create ribbon tabs to organize multiple ribbon panels into a single group of related tools. Once ribbon panels are added to the ribbon tab, the ribbon tab must be assigned to a workspace before it is displayed on the ribbon. For more information about ribbon tab customization, see **Ribbon Tabs** on page 180.

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a ribbon tab on page 182</td>
<td>Create a new ribbon tab to hold the ribbon panels you want to display on the ribbon.</td>
</tr>
<tr>
<td>Create a ribbon panel on page 61 (workflow diagram)</td>
<td>Create new ribbon panels as needed for the commands and controls you want to display on the ribbon.</td>
</tr>
<tr>
<td>Assign a ribbon panel to a ribbon tab on page 184</td>
<td>Assign a ribbon panel to a ribbon tab.</td>
</tr>
<tr>
<td>Assign a ribbon tab to a workspace on page 301</td>
<td>Assign a ribbon tab to a workspace.</td>
</tr>
<tr>
<td>Set a workspace current on page 289</td>
<td>Set the modified workspace current to see the ribbon tab and its associated ribbon panels.</td>
</tr>
</tbody>
</table>

### Create a Ribbon Contextual Tab State

A contextual tab state is used to control the display of ribbon tabs on the ribbon when certain commands are active or an object is selected.
You assign ribbon tabs to a contextual tab state to display commands and controls on the ribbon when working in a specific context. For more information about the customization of ribbon contextual tab states, see Ribbon Contextual Tab States on page 186.

Create a ribbon panel on page 61 (workflow diagram)

Create new ribbon panels as needed to display the commands and controls you want to display on the ribbon.

Create a ribbon tab on page 62 (workflow diagram)

Create new tabs as needed to control the display of ribbon panels when the context of the contextual tab state is met.

Assign a ribbon tab on page 187

Assign the ribbon tabs to the contextual tab state.

Create a Toolbar

Toolbars organize commands and controls on small dockable windows.

You can add commands and controls to a toolbar making it easier to access the commands you use. Commands on a toolbar can be displayed as a single button or a grouping of buttons with a flyout. For more information about toolbar customization, see Create and Edit Toolbars on page 190.

Create a toolbar on page 192

Create a new toolbar to organize the commands and controls you want to display.
Create User Interface Elements | 65

Create a Pull-Down Menu

Pull-down menus take up the least amount of space in the application frame of AutoCAD LT of all user interface elements, while providing access to a wide range of commands.

You can add commands to a pull-down menu for easy access to it from the menu bar, while not losing a large amount of space on the screen. Commands on a pull-down menu can be displayed as a single item or as a grouping of items with a submenu. Pull-down menus must be added to a workspace in
order for them to be displayed on the menu bar. For more information about pull-down menu customization, see Create a Pull-Down Menu on page 213.

Create a pull-down menu on page 214

Create a new pull-down menu to organize the commands you want to display.

Optional: Add submenus to organize multiple commands into a single drop-down menu.

Add a submenu on page 228

Add commands on page 215

Add commands to the pull-down menu and submenus.

Create a new command on page 58 (workflow diagram)

Create new commands as needed.

Change the caption for a command on page 216

Change the caption for the command when displayed on the pull-down menu.

Assign a pull-down menu to the menu bar on page 308

Assign the pull-down menu to a workspace to display it on the menu bar.
Create a Shortcut Menu

Shortcut menus provide contextual access to commands based on right-clicking. Contextual states vary depending on if a command is active, an object is selected, or if no command or object is selected.

You create custom shortcut menus that replace the default shortcut menus in AutoCAD LT or to insert additional commands into a specific shortcut menu. Commands on a shortcut menu can be displayed as a single item or as a grouping of items with a submenu. Unlike pull-down menus, shortcut menus do not need to be added to a workspace in order to be displayed. For more information about shortcut menu customization, see Create a Shortcut Menu on page 217.

Create a new shortcut menu to organize the commands you want to display.

Optional: Add submenus to organize multiple commands into a single drop-down menu.

Create new commands as needed.
Add commands to the shortcut menu and submenus.

Add commands on page 225

Change the caption that is used for the command when displayed on the shortcut menu.

Change the caption for a command on page 226

---

Customize Shortcut Key

Shortcut keys start a command by with a combination of the Ctrl or Alt key and some additional keys.

You assign commands to a shortcut key combination to make it easy to start the command. You use a key combination instead of clicking a menu item or a button. Shortcut keys include using the Ctrl or Alt key and also an alphanumeric key and or the Shift key. For more information about shortcut key customization, see Keyboard Shortcuts on page 248.

Create new commands as needed.

Create a new command on page 58 (workflow diagram)

Create a new shortcut key and assign a key combination to start the associated command.

Create a shortcut key on page 249

---

Create a Double Click Action

Double click actions start a command based on the objects that are selected when you double-click in the drawing window.

You assign commands to a double click action, which typically starts a command that allows you to modify the selected object. For more information
about double click action customization, see Double Click Actions on page 262.

Create a new command on page 58 (workflow diagram)

Create a double click action on page 263

Create new commands as needed.

Create a new double click action to start the command when an object is double clicked.

Create a Mouse Button

Mouse buttons start a command based on a mouse click and a key combination.

You assign commands to mouse button and key combinations. For more information about mouse button customization, see Mouse Buttons on page 270.

Create a new command on page 58 (workflow diagram)

Create a mouse button on page 270

Create new commands as needed.

Create a new mouse button to start the command when the mouse button and key combination is pressed.

Create and Modify Workspaces

Workspaces control the display and order in which user interface elements are displayed.
You create and manage workspaces from the user interface of AutoCAD LT or with the Customize User Interface (CUI) Editor. Creating and managing workspaces from the user interface is limited; the CUI Editor gives you full control over all user interface elements in a workspace. For more information about workspace customization, see Customize Workspaces on page 280.

Create a Workspace from the User Interface

You can perform some basic customization of a workspace from the user interface.

From the user interface, you can control the display of toolbars and palettes; you can also add and remove commands from the Quick Access toolbar. You can interactively update the position and display of both toolbars and palettes. This cannot be done from the CUI Editor. For more information about workspace customization from the user interface, see Control User Interface Elements Outside the CUI Editor on page 293.
Create a Workspace with the CUI Editor

The CUI Editor provides an editing environment to customization a workspace.

From the CUI Editor, you can control the display of the Quick Access toolbar, ribbon tabs, toolbars, menus, and palettes. You can also control the display of certain features in the application and drawing windows. For more information about workspace customization from the CUI Editor, see Control User Interface Elements in the CUI Editor on page 296.

Create a new workspace using the CUI Editor.

Display a Quick Access toolbar when the workspace is set current.

Display a ribbon tab on the ribbon when the workspace is set current.

Display a toolbar when the workspace is set current.
Control the display settings for a toolbar when the workspace is set current. You can control settings such as default position and docking, among others.

Display a menu on page 308

Display a palette when the workspace is set current.

Control the display settings for a palette when the workspace is set current. You can control settings such as position, transparency, and auto-hide, among others.

Control the display settings of various user interface elements on the application and drawing windows such as the menu bar, status bars, and layout tabs when the workspace is set current.

Set the modified workspace current to see the changes made to the workspace.
Create and Manage Customization Files

Customization (CUIx) files are used to store commands, user interface elements, and references to partial CUIx files. CUIx files can be designated as main, partial, or enterprise.

Basics of Customization Files

Customization files are loaded into AutoCAD LT to define elements that make up the user interface and are edited using the Customize User Interface (CUI) Editor.

AutoCAD LT comes with several different CUIx files that can be tailored to your work environment. AutoCAD LT has two main designations for CUIx files, main and enterprise; by default AutoCAD LT uses a main CUIx file. You can customize the files that come with AutoCAD LT or you can create your own CUIx files from scratch using the Transfer tab in the Customize User Interface (CUI) Editor.

When customizing the CUIx files that come with AutoCAD LT or creating your own CUIx files, the Customize User Interface (CUI) Editor creates a backup copy of the file when you first start making changes to the CUIx file. This allows you to restore the file if you delete something that you wanted to keep. If you happen to modify a CUIx file that comes with AutoCAD LT, you can reset it back to its original state.

The Customize User Interface allows you to not only create new user interface elements and commands from scratch, but you can also copy existing user interface elements and commands to modify them.

To set the working CUIx file

Before you can add custom commands to a CUIx file, you must set a CUIx file as the working file.

1. Click Manage tab ➤ Customization panel ➤ User Interface.

2. In the Customize User Interface Editor, Customize tab, Customizations In <file name> pane, click the down arrow on the Customization Files drop-down list.

3. Select Main Customization File <file name> or one of the loaded CUIx files to set it as the working CUIx file.
All new commands created are added directly to the working CUIx file. If the CUIx file that you want to work with is not loaded, select Open from the Customization Files drop-down list. Then browse to and select the CUIx file you want to work with.

To create a CUIx file from scratch

1. Click Manage tab ➤ Customization panel ➤ User Interface.
2. In the Customize User Interface Editor, Transfer tab, in the right pane, click the Create a New Customization File button.
3. In the right pane, select Save As from the drop-down list.
4. In the Save As dialog box, specify the location to save the new customization file to and enter a name in the File Name text box.
5. Click Save to create and save the customization file.

To create a customization file from an existing customization file

1. In Windows Explorer, navigate to the following location:
(Windows XP) <drive>:\Documents and Settings\<user profile name>\Application Data\Autodesk\<product name>\<release number>\<language>\support\<customization file name>.cuix

(Windows Vista) <drive>:\Users\<user profile name>\AppData\Roaming\Autodesk\<product name>\<release number>\<language>\support\<customization file name>.cuix

**NOTE** The folders under your profile may be hidden by default. To display these files, you may need to change your display settings. Click Start menu (Windows) ➤ Control Panel ➤ (Appearance and Themes, or Appearance and Personalization) ➤ Folder Options. In the Folder Options dialog box, View tab, click Show Hidden Files and Folders.

2 Copy the selected CUIx file to a new file name (such as *enterprise.cuix*) or location (such as the shared network location where users will access the file) so that you preserve the original CUIx file (in case you want to modify or use it again later).

**WARNING** This method of creating a new CUIx file can result in additional work if you do not want all the commands and user interface elements in the copied CUIx file.

To rename a customization group name

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customizations In <file name> pane, select a CUIx file from the drop-down list.

3 In the Customizations In <file name> pane, right-click the customization group name and click Rename.
4 Enter a new customization group name and press Enter.

**NOTE** You can click, wait, and click again on the customization group name to edit its name in-place.

**NOTE** The customization group name cannot contain spaces.

5 Click Apply.

To restore a customization backup file

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, right-click the customization group name.

3 Click Restore <file name>.

4 Click Apply.
To reset a standard customization file

1. Click Manage tab ➤ Customization panel ➤ User Interface.

2. In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, right-click over the customization group name.

3. Click Reset <file name>.

![Screenshot of Customize User Interface Editor](image)

**NOTE** Only CUIx files found in the UserDataCache folder under the install location of AutoCAD LT can be reset.

4. Click Apply.

To designate a CUIx file as the main CUIx file

1. Click Application menu ➤ Options.

2. In the Options dialog box, Files tab, click the plus sign (+) next to Customization Files to expand the list.

![Screenshot of Options dialog box](image)

3. Click the plus sign (+) next to Main Customization File to expand it.
4 Select the item below Main Customization File and click Browse.

5 In the Select a File dialog box, browse to and select the customization file to load. Click Open.
   The file you selected is now designated as the main customization file for the program.

6 In the Options dialog box, click OK.

Quick Reference

Commands
CUI
Manages the customized user interface elements in the product.

OPTIONS
Customizes the program settings.

Create and Load a Partial CUIx File
Create, load, or unload partial customization files as you need them. Loading and using a partial CUIx file allows you to create and modify most user interface elements (toolbars, menus, ribbon panels, and so on) in a separate CUIx file without having to import the customization to your main CUIx file.

The order of the partial CUIx files in the Partial Customization Files tree determines the order they are loaded in the program. You can rearrange the tree hierarchy to change the load order. Use the Transfer tab of the Customize User Interface (CUI) Editor to create a partial CUIx file. For more information on creating a new CUIx file, see To create a CUIx file from scratch on page 74. CUIx files can be loaded or unloaded with the CUILOAD and CUIUNLOAD commands from the Command prompt, or you can use the Customize tab in the Customize User Interface (CUI) Editor.
Commands and user interface elements can be added to a partial CUIx file that is loaded under the main CUIx file, but not the enterprise CUIx file unless it is loaded as the main CUIx file. Before adding commands to a partial CUIx file, the partial CUIx file must be set as the working CUIx. For more information on adding a command to a partial CUIx file, see To add commands to a partial CUIx file on page 81.

When a partial CUIx file is loaded, any workspaces defined in the file cannot be set current. To use a workspace defined in a partial CUIx file, it must be transferred to the main CUIx file first. For more information on transferring a workspace to the main CUIx file, see To import a workspace to a main CUIx file on page 291.

**To load a partial CUIx file using the CUILOAD command**

1. At the Command prompt, enter `cuiload`.
2. In the Load/Unload Customizations dialog box, in the File Name text box, enter a path to the CUIx file you want to load, or click Browse to locate the file.
3. Click Load, and then click Close.

**To load a partial CUIx file using the Customize tab**

1. Click Manage tab ➤ Customization panel ➤ User Interface.
2. In the Customize User Interface Editor, Customize tab, in the Customizations In `<file name>` pane, select Main Customization File (`<customization file name>.cuix`) from the drop-down list. To the right of the drop-down list, click the Load Partial Customization File button.
3. In the Open dialog box, locate and select the partial CUIx file you want to load, and click Open.
NOTE If the partial CUIx file you are attempting to load has the same customization group name as the main CUIx file, you need to change the customization group name before loading it. Open the partial CUIx file in the CUI Editor, select the customization group name, and right-click to rename it.

4 To verify that the file has been loaded into the main CUIx file, in the Customizations In <file name> pane, select the Main Customization File (<customization file name>.cuix) from the drop-down list.

![Customizations In All Files](image)

Loaded partial CUIx files in the main CUIx file are listed under the Partial Customization Files node.

5 Click Apply.

To unload a partial CUIx file using the CUIUNLOAD command

1 At the Command prompt, enter `cuiunload`.

2 In the Load/Unload Customizations dialog box, in the Loaded Customizations Group box, select a CUIx file.

3 Click Unload, and then click Close.

To unload a partial CUIx file using the Customize tab

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, select Main Customization File (<customization file name>.cuix) from the drop-down list.
3 In the tree view of the main CUIx file, click the plus sign (+) next to the Partial Customization Files node to expand it. Any partial CUIx files loaded in the main CUIx file are displayed.

4 Right-click the partial CUIx file that you want to unload. Click Unload <customization file name>.cuix.

The partial CUIx file is unloaded and removed from the list.

5 Click Apply.

To add commands to a partial CUIx file

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, select the partial CUIx file from the drop-down list.

3 In the Commands List pane, click Create a New Command.
4 Adjust the properties of the new command in the Properties pane as necessary.
5 Click Apply.

Quick Reference

Commands

CUI
Manages the customized user interface elements in the product.
CUILOAD
Loads a CUIx file.
CUIUNLOAD
Unloads a CUIx file.

Create an Enterprise CUIx File

An enterprise CUIx file typically stores customization information that is shared by many users, but is controlled by a CAD manager. Enterprise CUIx files make maintaining and modifying customization data easier for the individual responsible for controlling company standards.

Create an enterprise CUIx file by performing the following tasks:

■ Create an enterprise CUIx file from an existing CUIx file or a new CUIx file. Make a copy of the main customization file (acadlt.cuix) or another customization file of your choice that contains all the base user interface elements you need. If you want to start with a new customization file, use the Transfer tab to create a blank customization file.

■ Designate the new file as your main CUIx file. Using the Options dialog box, you must load the customization file as your the main customization
file so you make edits to all of the different user interface elements. Make sure to note which customization file is currently designated as the main customization file, as you will need to restore it later.

- **Modify the contents of the enterprise CUIx file.** Once the customization file is designated as the main customization file, you can change the customization group name and modify the CUIx file contents as needed. Changing the customization group name allows you to load more than one CUIx file in the program at one time. CUIx files with the same customization group name cannot be loaded into the program.

- **Replace the main CUIx file.** Using the Options dialog box, replace the previous customization file that was designated as the main customization file.

- **Save the enterprise CUIx file to a shared network location.** When you save the new enterprise file to a shared network location, all of your users that have access to the specified location can access the file.

  **NOTE** The folder where you place the enterprise CUIx file should be in a shared location that your users can access. To learn more about creating a network share, see “How to Create a Network Share” in the Network Administrator’s Guide.

- **Specify the enterprise CUIx file location.** The program automatically designates an enterprise customization file as read-only when you specify its file location in the Options dialog box. Specifying the enterprise customization file location can be done on individual workstations.

  **WARNING** Even though the Customize User Interface (CUI) Editor loads the enterprise customization file as read-only, this still doesn’t completely protect the file from being modified. The enterprise customization file could be loaded as the main customization file and then modified. To protect the enterprise customization file, the location where it is stored be marked as read-only and write access should be limited to those you want to be able to edit the file.

**To designate a CUIx file as an enterprise CUIx file**

1. On each user’s workstation in AutoCAD LT, click Application menu ➤ Options.

2. In the Options dialog box, Files tab, click the plus sign (+) next to Customization Files to expand the list.
3 Click the plus sign next to Enterprise Customization File to open it.

4 Select the item below Enterprise Customization Files and click Browse.

5 In the Select a File dialog box, browse to the location of the enterprise customization file. Click Open.
   The enterprise CUIx file if shared, must be saved in a location that all users can access.

6 In the Options dialog box, click OK.

To modify an enterprise CUIx file

1 Click Application menu ➤ Options.

2 In the Options dialog box, Files tab, click the plus sign (+) next to Customization Files to expand the list.

3 Click the plus sign next to Main Customization File to expand it.
   Take note of the current main CUIx file’s name and location as you will need to restore it later.

4 Select the item below Main Customization Files and click Browse. In the Select a File dialog box, browse to the location of the enterprise customization file. Click Open.

5 Click the plus sign next to Enterprise Customization File to expand it.
   Take note of the current enterprise CUIx file’s name and location as you will need to restore it later.
6. Select the item below Enterprise Customization Files and click Browse. In the Select a File dialog box, browse to the location of the main customization file. Click Open.

7. In the Options dialog box, click OK to save the changes.

8. Click Manage tab ➤ Customization panel ➤ User Interface.

9. In the Customize User Interface Editor, Customize tab, create new commands and user interface elements as necessary.

10. Once done adding new commands and user interface elements, click OK. Switch the file names of the main and enterprise values around in the Options dialog box.
   The main and enterprise CUIx files should now resemble the original configuration prior to making the changes.

**TIP** You can create two different profiles that can be used to switch between your main and enterprise CUIx files. One profile will have the CUIx files in a normal configuration that is used by your drafters, and the other profile has the main and enterprise CUIx files switched around making the enterprise customization file editable.

---

**Quick Reference**

**Commands**

**CUI**
Manages the customized user interface elements in the product.

**CUIEXPORT**
Exports customized settings from the main CUIx file to an enterprise or partial CUIx file.

**CUILOAD**
Loads a CUIx file.

**CUIUNLOAD**
Unloads a CUIx file.
OPTIONS
Customizes the program settings.

Find and Replace Commands and Text in a CUIx File
You can search one or more CUIx files for commands or search strings (including commands or user interface element names, command display names, descriptions, macros, and tags). You can also replace commands or search strings one at a time or all at once.

You can limit or expand your search depending on the search results you want to achieve.

■ Limit the search to commands located in the Command List pane. This search does not include the names of user interface elements, the commands that are associated to them, and their properties. For example, if you limit the search for the LINE command in the Command List only, a message similar to the following is displayed when you start your search: “Search string found in command ‘Dimension, Linear’ property ‘Name’ at position 11 (1/12).”

■ Expand the search to include all properties in all tree view nodes in the Customizations In pane. This type of search finds all instances or a search string. For example, if you search for the string “line” and start in the tree view, a message similar to the following is displayed: “Search string found in ‘Linear’ property ‘Name’ at position 0 (1/55).”

To find a search string in a CUIx file

1. Click Manage tab ➤ Customization panel ➤ User Interface.

2. In the Customize User Interface Editor, Customizations In <file name> pane, right-click anywhere in the tree view. Click Find.
3 In the Find and Replace dialog box, Find tab, do the following:
   ■ In the Find What box, enter the search string.
   ■ In the Ignore Case option, clear the check box if you want the search to find every instance of the search string regardless of its case.
   ■ In the Restrict Search To option, select the check box if you want to restrict the search to just one CUIx file. Then, under this option, select a CUIx file from the drop-down list.
   ■ Click Find Next to locate all instances of the search string.
A message is displayed that details the location of the search string and the number of results generated from the search.

4 Click Find Next to continue your search.

5 Click Close.

6 In the Customize User Interface Editor, click Apply.

To find a search string in the Command List pane

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Command List pane, right-click anywhere in the Command list. Click Find.
3 In the Find and Replace dialog box, Find tab, do the following:
   ■ In the Find What box, enter the search string.
   ■ In the Ignore Case option, clear the check box if you want the search to find every instance of the search string regardless of its case.
   ■ Click Find Next to locate all instances of the search string.
   A message is displayed that details the location of the search string and the number of results generated from the search.

4 Click Find Next to continue your search.
5 Click Close.
6 In the Customize User Interface Editor, click Apply.

To find where a command in the Command List pane is used

1 Click Manage tab ➤ Customization panel ➤ User Interface.
2 In the Customize User Interface Editor, Command List pane, right-click the command name you want to find. Click Find.
3 In the Find and Replace dialog box, Find tab, do the following:
   ■ In the Find What box, enter the command name.
   ■ In the Ignore Case option, clear the check box if you want the search
to find every instance of the search string regardless of its case.
   ■ Click Find Selected Command to locate all instances of the command.

4 In the search results text that is displayed, review the location of the
matching search string, its exact position in the tree node or Properties
pane, and the number of instances in which the command or search
string occurs.

5 Click Find Selected Command to continue your search.
6 Click Close.
7 In the Customize User Interface Editor, click Apply.

To replace a search string

1 Click Manage tab ➤ Customization panel ➤ User Interface.
2 In the Customize User Interface Editor, Customize tab, Customizations pane, right-click anywhere in the tree view. Click Replace.

3 In the Find and Replace dialog box, Replace tab, do the following:
   - In the Find What box, enter the search string.
   - In the Replace With box, specify the text string you want to use to replace the found string.
   - In the Ignore Case option, clear the check box if you want the search to find every instance of the search string, regardless of its case.
   - In the Restrict Search To option, select the check box if you want to restrict the search to just one CUIx file. Then, under this option, select a CUIx file from the drop-down list.
   - To step through each instance of a found string before replacing it, click Replace. In the search results text that is displayed, review the location of the matching search string, its exact position in the tree node or Properties pane, and the number of instances in which the command or search string occurs. You cannot undo this action.
   - To replace all instances of the search string, click Replace All. You cannot undo this action.
4 Click Close.

5 In the Customize User Interface Editor, click Apply.

To replace a command string

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, Command List pane, right-click the command name you want to replace. Click Replace.

3 In the Find and Replace dialog box, Replace tab, in the Find What box, the command name you selected in the previous step is displayed. To complete the dialog box, do the following:
   ■ In the Replace With box, specify the command name you want to use to replace the found command.
   ■ In the Ignore Case option, clear the check box if you want the search to find every instance of the command, regardless of its case.
   ■ To step through each instance of a command name before replacing it, click Replace. In the search results text that is displayed, review the location of the matching search string, its exact position in the tree node or Properties pane, and the number of instances in which the command or search string occurs. By renaming the command in the Command list, you rename the command everywhere that command is used in the CUIx file. You cannot undo this action.
   ■ To replace all instances of the command, click Replace All. You cannot undo this action.
4 Click Close.

5 In the Customize User Interface Editor, click Apply.

Quick Reference

Commands

CUI

Manages the customized user interface elements in the product.

Customize Commands

Commands in the Customize User Interface (CUI) Editor are used to define custom macros which are used to start standard and custom commands which can be executed from the command prompt in AutoCAD LT.

Overview of Commands

You can easily create, edit, and reuse commands. The Customize tab of the Customize User Interface (CUI) Editor allows you to add any command listed in the Command List pane to a toolbar, menu, and one of the other user interface element that can be customized.

When you change the properties of a command in the Command List pane or the tree view in the Customizations In pane, the properties of the command are changed everywhere the command is referenced. Each property of a command in the Command List pane controls which actions are taken when the command is used and how the command looks when added to a user interface element.
The following table shows the properties of the Scale command as they appear in the Properties pane.

### Properties for the Scale command in the Command List pane

<table>
<thead>
<tr>
<th>Properties pane item</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>String displayed as a menu name or as a tooltip when you click a toolbar button. The string must include alphanumeric characters with no punctuation other than a hyphen (-) or an underscore (_)</td>
<td>Scale</td>
</tr>
<tr>
<td>Description</td>
<td>String displayed as a tooltip when the cursor hovers over a toolbar or panel button, or menu item.</td>
<td>Enlarges or reduces selected objects, keeping the proportions of the object the same after scaling</td>
</tr>
<tr>
<td>Extended Help File</td>
<td>Displays the file name and ID for the extended tooltip that is displayed when the cursor hovers over a toolbar or panel button.</td>
<td></td>
</tr>
<tr>
<td>Command Display Name</td>
<td>String that contains the name of the command that is related to the command.</td>
<td>SCALE</td>
</tr>
<tr>
<td>Macro</td>
<td>The command macro. It follows the standard macro syntax.</td>
<td>$M=$(if,$(eq,$(substr,$(getvar,cmd-names),1,4),GRIP),_scale,^C^C_scale)</td>
</tr>
<tr>
<td><strong>NOTE</strong> When you change the name of a macro, the name of its corresponding menu item or toolbar button does not change. You must change a menu item or toolbar button name by selecting it in the tree view.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Tags</td>
<td>Keywords associated to a command. Tags provide an additional field to search for a loaded command when using the Search field in the application menu.</td>
<td></td>
</tr>
<tr>
<td>Element ID</td>
<td>Tag that uniquely identifies a command.</td>
<td>ID_Scale</td>
</tr>
</tbody>
</table>
Properties for the Scale command in the Command List pane

<table>
<thead>
<tr>
<th>Properties pane item</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Small Image</td>
<td>ID string of the small-image resource (16 × 16 bitmap). The string must include alphanumeric characters with no punctuation other than a hyphen (-) or an underscore (_). It can also be a user-defined bitmap. Click the [ ] button to open the Select Image File dialog box.</td>
<td>RCADATA_16_SCALE</td>
</tr>
<tr>
<td>Large Image</td>
<td>ID string of the large-image resource (32 × 32 bitmap). If the specified bitmap is not 32 × 32, the program scales it to that size. The string must include alphanumeric characters with no punctuation other than a hyphen (-) or an underscore (_). It can also be a user-defined bitmap. Click the [ ] button to open the Select Image File dialog box</td>
<td>RCDATA_32_SCALE</td>
</tr>
</tbody>
</table>

Quick Reference

Commands

CUI

Manages the customized user interface elements in the product.

Create, Edit, and Reuse Commands

You can create a new command from scratch, copy an existing command to create a new command, or edit the properties of an existing command. When you create or edit a command, the properties you can define are the command name, description, extended help file, command display name, macro, tags, element ID (for new commands only), and small or large image.

When you change the properties of a command in the Command List pane, the command is updated for all user interface elements that reference the command.
To create a command

1. Click Manage tab ➤ Customization panel ➤ User Interface.

2. In the Customize User Interface Editor, Customize tab, Command List pane, click Create a New Command.

A new command (named Command1) is displayed in both the Command List pane and the Properties pane.

3. In the Properties pane, do the following:
   - In the Name box, enter a name for the command. The name is displayed as a tooltip or menu name when the command is added to a user interface element.
   - In the Description box, enter a description for the command. The description will be displayed on the status bar or in a tooltip. When the cursor hovers over the command on a menu, the description is displayed on the status bar while if it is on a toolbar or ribbon panel it is displayed in a tooltip.
   - In the Extended Help File box, enter the name of the file and ID to use for the extended help for the command.
   - In the Command Display Name box, enter the name of the command that you want to display for the command.
   - In the Macro box, enter a macro for the command.
   - In the Tags box, enter the tags you want to use when searching for commands in the Search field of the application menu.
   - In the Element ID box, enter an element ID for the command.

For information about adding button images to a command, see Create and Edit Custom Images for Commands on page 132.
To remove a command

1. Click Manage tab ➤ Customization panel ➤ User Interface.

2. In the Customize User Interface Editor, Customize tab, Command List pane, select Custom from the Command Filter drop-down list. The list is filtered to only show the commands that you have created in the loaded customization files.

3. Select the command to be removed, and right-click over the command.

4. Click Remove.

**NOTE** A command only can be removed when it is not being referenced by a user interface element, such as a toolbar or menu.

**WARNING** There is no way to undo the removal of a command or user interface element from inside the Customize User Interface (CUI) Editor, so be careful when removing commands and user interface elements. If you accidentally remove the wrong command or user interface element the best thing to do is click Cancel, but this will also undo any other changes that you might have made. If you already made several changes to the CUIx file and do not want to lose the changes that you already made, you can open the backup CUIx file that is automatically created after a change is made to a CUIx file from the Transfer tab and then proceed to recover the command or user interface element that was accidentally removed.
To edit a command

1. Click Manage tab ➤ Customization panel ➤ User Interface.

2. In the Customize User Interface Editor, Customize tab, do one of the following:
   - In the Command List pane, select the command you want to edit.
   - In the Customizations In <file name> pane, tree view, locate and then select the command you want to edit.

3. In the Properties pane, do any of the following to edit the command:
   - In the Name box, enter a name for the command. The name is displayed as a tooltip or menu name when the command is added to a user interface element.
   - In the Description box, enter a description for the command. The description will be displayed on the status bar or in a tooltip. When the cursor hovers over the command on a menu, the description is displayed on the status bar while if it is on a toolbar or ribbon panel it is displayed in a tooltip.
In the Extended Help File box, enter the name of the file and ID to use for the extended help for the command.

In the Command Display Name box, enter the name of the command that you want to display for the command.

In the Macro box, enter a macro for the command.

In the Tags box, enter the tags you want to use when search for commands with the Search field of the application menu.

In the Element ID box, enter an element ID for the command. (For new commands only. You cannot modify the element ID of an existing command).

For information about adding button images to a command, see Create and Edit Custom Images for Commands on page 132.

To use a command

1. Click Manage tab ➤ Customization panel ➤ User Interface.
2. In the Customize User Interface Editor, Customize tab, Command List pane, locate the command you want to use and drag it to an interface element.
To copy and paste a command

1. Click Manage tab ➤ Customization panel ➤ User Interface.
2. In the Customize User Interface Editor, Customize tab, Command List pane, locate the command you want to copy.
3. Right-click over the command. Click Copy.
4. Right-click over a user interface element like a toolbar or menu. Click Paste.
NOTE The key combination Ctrl+C can be used to copy a command and Ctrl+V can be used to paste a command.

To duplicate a command

1. Click Manage tab ➤ Customization panel ➤ User Interface.
2. In the Customize User Interface Editor, Customize tab, Command List pane, locate the command you want to duplicate.
3. Right-click over the command. Click Duplicate.

A copy of the selected command is created in-place directly above the selected command in the Command List pane.
Quick Reference

Commands

CUI

Manages the customized user interface elements in the product.

Create Macros

A macro defines the action that results when an interface element is selected. A macro accomplishes a drawing task that would otherwise take a series of actions by a user.

Overview of Macros

A macro can contain commands, special characters, and DIESEL (Direct Interpretively Evaluated String Expression Language) programming code.

NOTE As AutoCAD LT is revised and enhanced, the sequence of prompts for various commands (and sometimes command names) might change. Therefore, your custom macros might require minor changes when you upgrade to a new release of AutoCAD LT.

You add macros to interface elements by using the Customize User Interface (CUI) Editor. Select an existing command or create a new command in the Command List pane. Enter macros in the Macros section of the Properties pane. There are no length limitations for macros. However, you do need to know how specific characters are used in macros and be aware of other considerations or limitations.

Macro Basics

A macro in a user interface element can be as simple as a command (such as circle) and some special characters (such as ^C^C).
For example, the macro `^C^C_circle \1`, draws a circle with a radius of 1 unit. The components that define this macro are explained in the table below.

### Components in CIRCLE macro

<table>
<thead>
<tr>
<th>Component</th>
<th>Component type</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>^C^C</code></td>
<td>Special control character</td>
<td>Cancels any running commands</td>
</tr>
<tr>
<td><code>\</code></td>
<td>Special control character</td>
<td>Creates a pause for the user to specify the center point</td>
</tr>
<tr>
<td><code>1</code></td>
<td>Special control character</td>
<td>Responds to the prompt for the circle's radius (1)</td>
</tr>
</tbody>
</table>

For a list of special control characters that you can use in macros, see [Use Special Control Characters in Macros](#) on page 104.

### Cancel Running Commands

Make sure that you have no AutoCAD LT commands in progress before you execute a macro. To automatically cancel a command before executing a macro, enter `^C^C` at the beginning of the macro (which is the same as pressing ESC twice). Although a single `^C` cancels most commands, `^C^C` is required to return to the command prompt from a dimensioning command and `^C^C^C` is required based on the current option of the Layer command. `^C^C^C` handles canceling out of most command sequences and therefore is the recommended sequence used to ensure no command is active before the macro is started.

### Verify Macro Characters

Every character in a macro is significant, even a blank space.

When you place a space at the end of the macro, AutoCAD LT processes the macro as though you had entered a command (`circle`, for example) and then pressed the SPACEBAR to complete the command.
Terminate Macros

Some macros require special terminators. Some commands (TEXT, for example) require you to press ENTER rather than SPACEBAR to terminate the command. Some commands require more than one space (or ENTER) to complete, but some text editors cannot create a line with trailing blanks.

Two special conventions resolve these problems.

- A semicolon (;) in a macro automatically issues ENTER at the command prompt.
- If a line ends with a control character, a backslash (\), a plus sign (+), or a semicolon (;), AutoCAD LT does not add a blank space after it.

An item that ends with a backslash (\) pauses a macro for user input.

Compare the following macros:

```
ucs
ucs ;
```

The first example enters `ucs` at the command prompt and presses SPACEBAR. The following prompt is displayed.

Specify origin of UCS or [Face/Named/Object/Previous/View/World/X/Y/Z/ZAxis] <World>:

The second example enters `ucs`, presses SPACEBAR, and presses ENTER, which accepts the default value (World).

Suppress Echoes and Prompts in Macros

Characters in a macro appear in the command window as though you had typed the characters on the keyboard. They are also displayed in the user interface element. This display duplication is called “echoing”. You can suppress the “echoed” displays with the MENUECHO system variable. If echoes and prompts from item input are turned off, a `^P` in the item turns them off.

Create Long Macros

You can create a macro of any length, without requiring any special characters at the end of a line. The Properties pane in the Customize User Interface (CUI) Editor accepts a macro of any length.
To assign or modify a command macro

1. Click Manage tab ➤ Customization panel ➤ User Interface.

2. In the Customize User Interface Editor, Customize tab, Command List pane, locate the command you want to assign (or modify) a command macro.

3. In the Properties pane, select the Macro field and click the [ ] button that is displayed. The Long String Editor dialog box is displayed.

4. In the Long String Editor, edit the macro as desired and click OK. You are returned to the Customize User Interface Editor.

Quick Reference

Commands

CUI

Manages the customized user interface elements in the product.

Use Special Control Characters in Macros

You can use special characters, including control characters, in macros. In a macro, the caret (^) is equivalent to pressing the Ctrl key on the keyboard. You can combine the caret with another character to construct macros that do such things as turn the grid on and off (^G) or cancel a command (^C).

The macro for the Address command below uses the backslash (\) to pause for user input and the semicolon (;) for ENTER.

```
text \.4 0 DRAFT Inc;;Main St.;;City, State;
```

The macro starts the TEXT command, pauses for the user to specify a start point, and then enters the address on three lines. In the triple semicolon (;;;), the first semicolon ends the text string, the second repeats TEXT, and the third accepts the default placement below the previous line.
Macros use the special characters listed in the following table.

<table>
<thead>
<tr>
<th>Character</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>;</td>
<td>Issues ENTER</td>
</tr>
<tr>
<td>^M</td>
<td>Issues ENTER</td>
</tr>
<tr>
<td>^I</td>
<td>Issues TAB</td>
</tr>
<tr>
<td>[blank space]</td>
<td>Enters a space; a blank space between command sequences in a command is equivalent to pressing the SPACEBAR</td>
</tr>
<tr>
<td>\</td>
<td>Pauses for user input (cannot be used with accelerators)</td>
</tr>
<tr>
<td>_</td>
<td>Translates AutoCAD LT commands and options that follow</td>
</tr>
<tr>
<td>-*</td>
<td>Displays the current top-level pull-down, shortcut, or image menu</td>
</tr>
<tr>
<td>*^C^C</td>
<td>Repeats a command until another command is chosen</td>
</tr>
<tr>
<td>$</td>
<td>Introduces a conditional DIESEL macro expression ($M=)</td>
</tr>
<tr>
<td>^B</td>
<td>Turns Snap on or off (equivalent to Ctrl+B)</td>
</tr>
<tr>
<td>^C</td>
<td>Cancels the active command or command option (equivalent to ESC)</td>
</tr>
<tr>
<td>^D</td>
<td>Turns Dynamic UCS on or off (equivalent to Ctrl+D)</td>
</tr>
<tr>
<td>^E</td>
<td>Sets the next isometric plane (equivalent to Ctrl+E)</td>
</tr>
<tr>
<td>^G</td>
<td>Turns Grid on or off (equivalent to Ctrl+G)</td>
</tr>
<tr>
<td>^H</td>
<td>Issues BACKSPACE</td>
</tr>
<tr>
<td>^O</td>
<td>Turns Ortho on or off</td>
</tr>
<tr>
<td>^P</td>
<td>Turns MENUECHO on or off</td>
</tr>
<tr>
<td>^Q</td>
<td>Echoes all prompts, status listings, and input to the printer (equivalent to Ctrl+Q)</td>
</tr>
</tbody>
</table>
Special characters used in macros

<table>
<thead>
<tr>
<th>Character</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>^R</td>
<td>Turns command versioning on or off. Command versioning is required for some commands to ensure command macros written in an older release work properly in the latest release.</td>
</tr>
<tr>
<td>^T</td>
<td>Turns tablet on or off (equivalent to Ctrl+T)</td>
</tr>
<tr>
<td>^V</td>
<td>Changes the current viewport</td>
</tr>
<tr>
<td>^Z</td>
<td>Null character that suppresses the automatic addition of SPACEBAR at the end of a command</td>
</tr>
</tbody>
</table>

Quick Reference

Commands

CUI
Manages the customized user interface elements in the product.

TEXT
Creates a single-line text object.

Pause for User Input in Macros

To accept input from the keyboard or pointing device in the middle of a command, place a backslash (\) in the macro at the point where you want input.

circle \1

In the circle example, \1 pauses for the user to specify the center point and then reads a radius of 1. Note that there is no space after the backslash.

-layer off \;

In this example, the macro starts -LAYER at the command prompt, enters the Off option (off), and then pauses for the user to enter a layer name (\). The macro then turns that layer off and exits the -LAYER command (\).
NOTE LAYER normally prompts for another operation and exits only if you press SPACEBAR or ENTER. In the macro, the semicolon (;) is the equivalent of pressing ENTER.

A macro typically resumes after one user input, such as a single point location. Therefore, you cannot construct a macro that accepts a variable number of inputs (as in object selection) and then continues. However, an exception is made for SELECT: a backslash (\) suspends the SELECT command until object selection has been completed. Consider the following example:

```
select \change previous ;properties color red ;
```

In this macro, SELECT creates a selection set of one or more objects (select \). The macro then starts CHANGE (change), references the selection set using the Previous option (previous;), and changes the color of all selected objects to red (properties color red ;).

NOTE The backslash character (\) causes a macro to pause for user input. You cannot use a backslash for any other purpose in a macro. When you need to specify a file directory path, use a forward slash (/) as the path delimiter: for example, /direct/file.

The following circumstances delay resumption of a macro after a pause:

- If input of a point location is expected, object snap modes may be used before the point is specified.
- If X/Y/Z point filters are used, the command remains suspended until the entire point has been accumulated.
- For SELECT only, the macro does not resume until object selection has been completed.
- If the user responds with a transparent command, the suspended macro remains suspended until the transparent command is completed and the originally requested input is received.
- If the user responds by choosing another command (to supply options or to execute a transparent command), the original macro is suspended, and the newly selected item is processed to completion. Then, the suspended macro is resumed.
NOTE When command input comes from a command, the settings of the PICKADD and PICKAUTO system variables are assumed to be 1 and 0, respectively. This preserves compatibility with previous releases of AutoCAD LT and makes customization easier because you are not required to check the settings of these variables.

Quick Reference

Commands
CHANGE
Changes the properties of existing objects.

LAYER
Manages layers and layer properties.

SELECT
Places selected objects in the Previous selection set.

System Variables

PICKADD
Controls whether subsequent selections replace the current selection set or add to it.

PICKAUTO
Controls automatic windowing at the Select Objects prompt.

Provide International Support in Macros
To develop menus that can be used with a non-English-language version of AutoCAD LT, precede each command or option with the underscore character (_). The underscore character allows the standard commands and options to be translated automatically.
Quick Reference

Commands

CUI

Manages the customized user interface elements in the product.

Repeat Commands in Macros

You can use a leading asterisk (*) to repeat a command in a macro until you choose another command.

Once you have selected a command, you might want to use it several times before moving on to another command. In a macro, you can repeat a command until you choose another command. You cannot use this feature to choose options.

If a macro begins with "^C^C", the command is repeated until you terminate by pressing ESC on the keyboard or by selecting another command.

NOTE Do not use ^C (Cancel) within a macro that begins with the string "^C^C"; this cancels the repetition.

The macros in the following examples repeat the commands:

"^C^Cmove Single
"^C^Ccopy Single
"^C^Cerase Single
"^C^Cstretch Single Crossing
"^C^Crotate Single
"^C^Cscale Single

Each macro in the example starts a command and then prompts you to select an object. Any other prompts necessary to complete the command are displayed, and then the command ends and starts again.

NOTE Command repetition cannot be used in macros for image tile menus.
Quick Reference

Commands

CUI

Manages the customized user interface elements in the product.

Use Single Object Selection Mode in Macros

Single Object Selection mode cancels the normal repetition of the Select Objects prompt in editing commands. After you select one object and respond to any other prompts, the command ends.

Consider the macro in the following example:

```
*^C^Cerase single
```

This macro terminates the current command and starts ERASE in Single Object Selection mode. After you choose this command, you either select a single object to be erased or click a blank area in the drawing and specify window selection. Any objects selected in this way are erased, and the command is repeated (due to the leading asterisk) so that you can erase additional objects. Press ESC to exit this mode.

Quick Reference

Commands

CUI

Manages the customized user interface elements in the product.

Use Macros to Swap User Interface Elements

You can replace the contents of active menus, mouse buttons, tablet buttons, tablet menus, or screen menus. The swapped content can be that of another user interface element of the same type in the main CUIx file, or it can come from a partial CUIx file.

You cannot swap interface elements that are of different types (menus and mouse buttons, for example). However, within a given type, you can swap any user interface element for any other element.
NOTE Swapping can lead to some strange behavior for tablet menus, because they typically have a different number of macros.

Use the following syntax in a macro to swap elements:

$section=customizationgroup.menuname

The following describes each section of the macro syntax for swapping elements:

Macro syntax for swapping elements
$ Loads an interface element
section Specifies the element type. Valid names are:
A1-A4 for Aux menus 1 through 4
B1-B4 for mouse buttons 1 through 4
P0-P16 for pull-down menus 0 through 16
I for the image tile menu
T1-T4 for tablet menus 1 through 4

customizationgroup Specifies the customization group that menuname is a member of (not necessary if menuname is in the main CUIx file).

menuname Specifies which section or submenu to insert. It is the main label or alias for the section to load

A pull-down menu can be present either in the menu bar or on the active shortcut menu but not both.

Quick Reference

Commands
CUI

Manages the customized user interface elements in the product.

Use Conditional Expressions in Macros

You can add conditional expressions to a macro by using a command that introduces macro expressions written in DIESEL (Direct Interpretively Evaluated String Expression Language).
The format is:

\[ SM=expression \]

Introducing the macro with \[ SM= \] tells AutoCAD LT to evaluate a string as a DIESEL expression, and that \[ expression \] is the DIESEL expression. The following example defines a conditional expression in a macro:

\[ FILLMODE \ SM=\{\{-,1,\$(getvar,fillmode)\}\} \]

The macro switches the FILLMODE system variable on and off by subtracting the current value of FILLMODE from 1 and returning the resulting value to the FILLMODE system variable. You can use this method to toggle system variables whose valid values are 1 or 0.

**Termination of Macros That Contain Conditional Expressions**

If you use the DIESEL string language to perform “if-then” tests, conditions might exist where you do not want the normal terminating space or semicolon (resulting in ENTER). If you add \(^Z\) to the end of the macro, AutoCAD LT does not automatically add a space (ENTER) to the end of the macro expression.

As with other control characters in commands, the \(^Z\) used here is a string composed of \(^\) (a caret) and \(Z\) and is not equivalent to pressing Ctrl+Z.

In the following examples, \(^Z\) is used as a macro terminator.

\[^C^C^M^S^M=\{\{if,\{-,\$(getvar,tilemode),0\},SS=mview_mspace\}\}\]^Z
\[^C^C^C^M^S^M=\{\{if,\{-,\$(getvar,tilemode),0\},SS=mview_pspace\}\}\]^Z

If these macros did not end with \(^Z\), AutoCAD LT would automatically add a space (ENTER), repeating the last command entered.

See also:
- **Use Special Control Characters in Macros** on page 104
- **DIESEL** on page 325

**Quick Reference**

**Commands**

CUI

Manages the customized user interface elements in the product.
System Variables

FILLMODE

Specifies whether hatches and fills, 2D solids, and wide polylines are filled in.

Control the Display of Command Items

The way a menu or ribbon button item is displayed indicates its availability in the program. A menu or ribbon button item can be displayed as:

- Grayed out (disabled)
- Marked with a check marker or border
- Both grayed out and marked

Ribbon button items do not display a check mark when marked; only a border is displayed.

**NOTE** To disable or mark ribbon button items, the "~" or "!." sequence cannot be placed before a command name explicitly; it must be inside a DIESEL expression.

Gray Out (Disable) Menu or Ribbon Button Items

You gray out a menu or ribbon button item by doing one of the following:

- Beginning a name with a tilde (~)
- Using a DIESEL string expression

Ribbon button items only support the use of DIESEL string expressions. For more information about using DIESEL expressions, see DIESEL Expressions in Macros. When grayed out, the macro and submenus associated with the menu or ribbon button item are made inaccessible.

In the following example, the tilde (~) is placed at the beginning of the Copy Link command label in the Name cell of the Properties pane.
Following is the resulting Copy Link command grayed out in the Edit menu.

DIESEL string expressions are used to conditionally disable or enable a menu or ribbon button item each time they are displayed. For example, the DIESEL string expression in the Macros cell of the Properties pane disables the MOVE command while any other command is active.

$$$(\text{if}(\text{getvar}, \text{cmdactive}), \sim)\text{MOVE}^\sim$$

Mark Menu or Ribbon Button Items

You can mark a menu or ribbon button item by doing one of the following:

- Beginning a command name with an exclamation point and a period (!.)
- Using a DIESEL string expression
Ribbon button items only support the use of DIESEL string expressions. A menu or ribbon button item is marked in one of two ways:

- **A check mark.** Displayed when a menu item does not have an image associated with it.
- **A border.** Displayed when a menu or ribbon button item has an image associated with it; a border is displayed around the image.

Following is an example of the Edit menu with the OLE Links command marked with a check mark and the Copy Link command's image marked with a border:

Menu items can and ribbon button items must contain DIESEL string expressions to conditionally mark them each time they are displayed. When the following DIESEL string is added to the Macros cell for the applicable command in the Properties pane, a check mark is placed to the left of the menu item whose related system variable is currently enabled.

```
$(if,$(getvar,orthomode),!.)Ortho^O
$(if,$(getvar,snapmode),!.)Snap^B
$(if,$(getvar,gridmode),!.)Grid^G
```
Simultaneously Disable and Mark Command Items

You can mark and disable commands at the same time using either of the following formats:

~!. labeltext
!.. labeltext

The tilde (~) is the special character code to disable a command and an exclamation point and period (!.) is the special character code to mark a command.

The tilde (~), exclamation point, and period (!.) are placed at the beginning of the Copy Link command label in the Name cell of the Properties pane. Following is the resulting Copy Link marked and grayed out in the Edit menu.

As with the previous examples, a DIESEL expression can be used to simultaneously disable and mark a command item.

To gray out (disable) a command's menu or ribbon button label

1. Click Manage tab ➤ Customization panel ➤ User Interface.

2. In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to the menu that contains the command you want to disable.

3. Select the command you want to gray out.
4 In the Properties pane, in the Name field, add a tilde (~) or add the desired DIESEL expression to the beginning of the command.

![Properties pane](image)

**NOTE** The command must be selected from the Customizations In pane, otherwise you are just modifying the name of the command and not the label that is displayed to the user.

5 Click Apply.
The changes to the command will be visible after the changes have been applied and the CUI Editor is closed.

![Command menu](image)

**To mark command's menu or ribbon button label**

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to the menu that contains the command you want to mark.

3 Select the command you want to mark.
4 In the Properties pane, in the Name field, add an exclamation point and a period (!.) or add the desired DIESEL expression to the beginning of the command.

5 Click Apply.

The changes to the command will be visible after the changes have been applied and the CUI Editor is closed.

To simultaneously gray out (disable) and mark a command's menu or ribbon button label

1 Click Manage tab ➤ Customization panel ➤ User Interface.
2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to the menu that contains the command you want to disable and mark.

3 Select the command you want to gray out and mark.

4 In the Properties pane, in the Name field, add a tilde, an exclamation point, and a period (~! . or ! .~) or add the desired DIESEL expression to the beginning of the command.

5 Click Apply.

Quick Reference

Commands

CUI

Manages the customized user interface elements in the product.

Assign Search Tags

With search tags, you can search for a command or a group of commands with the application menu.

You can assign one or more tags to a command to make it easy to locate when performing a search from the application menu. You add tags to a command using the Tag Editor dialog box. When a tag is assigned to a command, it is displayed on a tooltip (when the command is on a toolbar or ribbon panel and the cursor hovers over the command).

You can change the display of tooltips on the Display tab of the Options dialog box. See Search for Commands in the User’s Guide to learn more about using search in the application menu.

To add tags to a command

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, Command List pane, select the command to which you want to add a tag.
3 In the Properties pane, select the Tags field and click the [ ] button.

4 In the Tag Editor dialog box, in the Tags box, enter a tag. As you enter a tag, a popup menu might display showing a list of previously used tags. Click a tag on the menu to use that tag. You can add more than one tag to a command; separate each tag with a comma.

5 To add another tag for a command, press the Left Arrow key and enter the tag. Repeat as needed.

6 Click OK.
7  In the Customize User Interface Editor, click Apply.

**To remove a tag from a command**

1  Click Manage tab ➤ Customization panel ➤ User Interface.

2  In the Customize User Interface Editor, Customize tab, Command List pane, select the command from which you want to remove a tag.

   ![Image of Command List pane](image)

   The Properties pane is displayed on the right side.

3  In the Properties pane, select the Tags field and click the [ ] button.

   ![Image of Properties pane](image)

4  In the Tag Editor dialog box, in the Tags box, click the tag you want to remove. Press Delete.
The tag is removed.

5  Click OK.

6  In the Customize User Interface Editor, click Apply.

Quick Reference

Commands

CUI

Manages the customized user interface elements in the product.

OPTIONS

Customizes the program settings.

Create Tooltips and Extended Help for Commands

Tooltips are descriptive messages that are displayed near the cursor when it hovers over a toolbar or panel button, or menu item.

The Description property associated to a command provides a simple description for what the command does. The value of the Description property is displayed as part of a basic tooltip that is displayed when the cursor hovers over a button on a toolbar, or ribbon panel. Along with the description, a command tooltip also displays the name of the command, and the values assigned to the Command Display Name and Tags properties.

Additionally, a command can be assigned an extended help file and ID so it can display a second level of information for the command. The content from the extended help file is displayed in the extended description area of a tooltip. The content for the extended description area of a tooltip is stored in an XAML file, and can contain rich-text and images.
Control the Display of Tooltips

You control the display of tooltips and when the extended help assigned to a command is displayed from the Options dialog box. See Set Interface Options in the User’s Guide to learn more about tooltips.

Example of an XAML File

The XAML structure is a format that was developed by Microsoft. The following is an example of what an XAML file might look like for two custom commands that exist in your CUIx file.

```
<ResourceDictionary
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:src="clr-namespace:Autodesk.Windows;assembly=AdWindows">
  <src:RibbonToolTip x:Key="MYEH_CMD_0001">
    <src:RibbonToolTip.ExpandedContent>
      <StackPanel>
        <TextBlock Background="AntiqueWhite" TextAlignment="Center">
          Creates a rectangular revision cloud on the <Bold>REVISION</Bold> layer.
        </TextBlock>
        <Image Source="images/rectcloud.jpg" Width="Auto" Height="Auto"/>
      </StackPanel>
    </src:RibbonToolTip.ExpandedContent>
  </src:RibbonToolTip>
  <src:RibbonToolTip x:Key="MYEH_CMD_0002">
    <src:RibbonToolTip.ExpandedContent>
      <StackPanel>
        <TextBlock Background="Yellow" TextAlignment="Left">
          Creates a polygonal revision cloud on the <Run Text=" REVISION " Foreground="Red" FontStyle="Italic"/>
        </TextBlock>
        <Image Source="images/rectcloud.jpg" Width="Auto" Height="Auto"/>
      </StackPanel>
    </src:RibbonToolTip.ExpandedContent>
  </src:RibbonToolTip>
</ResourceDictionary>
```

The ResourceDictionary element is used to define the type of content that is in the XAML file; while the src:RibbonToolTip element is used to define each
of the extended help topics in the file. In the previous example there are two
different extended help topics, and they are uniquely defined by the keys
MYEH_CMD_0001 and MYEH_CMD_0002.

NOTE Extended tooltips defined to work with AutoCAD LT 2009 need to be
updated to work with AutoCAD LT 2011. For information on converting an
extended tooltip created for AutoCAD LT 2009 to work with AutoCAD LT 2011,
see To convert an AutoCAD LT 2009 extended tooltip to work with AutoCAD LT
2011 on page 127.

The Stack Panel element groups the TextBlock and Image elements together.
You can have as many TextBlock and Image elements under a StackPanel
element that you need. The TextBlock element holds the text; the Image
element holds an illustration that is part of the extended help. To learn more
about XAML, visit Microsoft’s web site at http://www.microsoft.com and perform
a search for XAML.

To add a tooltip to a command

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, Command List
pane, click the command to which you want to add a tooltip.

3 In the Properties pane, Description field, enter the tooltip text for the
selected command.
4 Click Apply.
The next time the cursor hovers over the command on a toolbar, or ribbon panel, the text is displayed in the tooltip.

**To add extended help to a command**

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, Command List pane, click the command to which you want to add extended help.

3 In the Properties pane, select the Extended Help File field and click [ ] button.

4 In the Select Extended Help File dialog box, browse to and select the XAML file that contains the extended help for the command. Click Open.

5 In the Select Help ID dialog box, select the help ID for the extended help content. Click OK.
6 Click Apply.

When the command is added to a toolbar or ribbon panel, the extended help is displayed if extended help is enabled for tooltips and the cursor hovers over the command for the designated time interval.

To create an XAML file

1 In a text editor (for example, Microsoft® Windows® Notepad), create a new file and enter the elements needed to define the extended help content.

As an example, enter the text below in the text editor:

```
<ResourceDictionary
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:src="clr-namespace:Autodesk.Windows;assembly=AdWindows">
    <src:RibbonToolTip x:Key="MYEH_CMD_0003">
        <src:RibbonToolTip.ExpandedContent>
            <StackPanel>
            <TextBlock Background="AntiqueWhite" TextAlignment="Center">
                Configures the settings for the current drawing.
            </TextBlock>
            </StackPanel>
        </src:RibbonToolTip.ExpandedContent>
    </src:RibbonToolTip>
</ResourceDictionary>
```
2 Save the file as ASCII text (TXT file), with a file extension of .xaml.

**To convert an AutoCAD LT 2009 extended tooltip to work with AutoCAD LT 2011**

1 Open the XAML file in a text editor (for example, Microsoft® Windows® Notepad).

   The following is an example of an extended tooltip created to use with AutoCAD LT 2009. You change the text shown in italic.

   ```xml
   <src:ProgressivePanel x:Key="MYEH_CMD_0003">
   <StackPanel>
   <TextBlock Background="AntiqueWhite" TextAlignment="Center">
   Configures the settings for the current drawing.
   </TextBlock>
   </StackPanel>
   </src:ProgressivePanel>

   2 Change the text shown in italic in the previous step to match the following:

   ```xml
   <src:RibbonToolTip x:Key="MYEH_CMD_0003">
   <src:RibbonToolTip.ExpandedContent>
   <StackPanel>
   <TextBlock Background="AntiqueWhite" TextAlignment="Center">
   Configures the settings for the current drawing.
   </TextBlock>
   </StackPanel>
   </src:RibbonToolTip.ExpandedContent>
   </src:RibbonToolTip>

   3 Save the changes made to the XAML file.

**Quick Reference**

**Commands**

CUI

Manages the customized user interface elements in the product.

OPTIONS

Customizes the program settings.
**System Variables**

**TOOLTIPS**

Controls the display of tooltips on the ribbon, toolbars, and other user interface elements.

**Create Status Line Help Messages**

Status line help messages are simple, descriptive messages that are displayed on the status line (at the bottom of the application window) when the cursor hovers over a menu item.

You can change or add descriptions for menu items by updating the Description property for a related command. If the status bar for the program is not displayed, no descriptive message is displayed for the menu item. The current workspace controls the display of the application status bar for the program. See Set Interface Options in the *User’s Guide* to learn more about workspaces.

**To create a status line help message**

1. Click Manage tab ➤ Customization panel ➤ User Interface.

2. In the Customize User Interface Editor, Customize tab, Command List pane, select the command to which you want to add a help message.

3. In the Properties pane, Description box, enter the descriptive text for the selected command.
4 Click Apply.

The next time you use the command, the descriptive text you added is displayed in the status line when the cursor hovers over the command on a menu.

<table>
<thead>
<tr>
<th>Command</th>
<th>CIRCLE Center, Radius</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>CIRCLE Center, Radius</td>
</tr>
<tr>
<td>Description</td>
<td>Creates a circle using a center point and radius</td>
</tr>
<tr>
<td>Advanced</td>
<td>ID: CircleRed</td>
</tr>
<tr>
<td>Images</td>
<td>Std Image: RCDATA_16_CIRCLED</td>
</tr>
<tr>
<td></td>
<td>Large Image: RCDATA_32_CIRCLED</td>
</tr>
</tbody>
</table>

Quick Reference

Commands

CUI

Manages the customized user interface elements in the product.

OPTIONS

Customizes the program settings.

Assign, Create, and Manage Images for Commands

Images can be assigned to commands, and can be of two different types: standard and custom. Standard commands come with AutoCAD LT in a library, while custom commands are created and managed from the Button Image pane and the Button Editor dialog box in the Customize User Interface Editor.

Assign Images to a Command

Standard and custom images can be assigned to a command.
When a command is added to a ribbon or toolbar, the assigned image is displayed on the ribbon or toolbar button, or if added to a pull-down menu, the image is displayed next to the menu item.

AutoCAD LT comes with a library of standard images that are used for the standard commands; these can be assigned to your own custom commands. You can create your own custom commands using the Button Editor dialog box found in the Customize User Interface Editor or an external image editor. For more information about creating custom images for your commands, see Create and Edit Custom Images for Commands on page 132.

**To assign an image to a command**

1. Click Manage tab ➤ Customization panel ➤ User Interface.

2. In the Customize User Interface Editor, Customize tab, in the Command List pane, select command to which you want to add an image.
   The Button Image pane (in the upper-right corner) and the Properties pane (in the lower-right corner) are displayed.

3. Do one of the following:
Assign a standard image

- In the Button Image pane, under Apply To, select one of the three image assignment options; Small Image, Large Image, or Both.

- Select an image from the image list and the image name is assigned to the Small, Large, or both the Small and Large image properties of the selected command.

**NOTE** As you select an image from the image list, the image’s name is displayed below the Export button in the Button Image pane.

Import and assign a custom image

- In the Button Image pane, right-click in the list of images and click Import Image.

- In the Open dialog box, browse to and select the BMP file that you want to import and click Open.

- In the Button Image pane, under Apply To, select one of the three image assignment options; Small Image, Large Image, or Both. Then select the image you imported from the image list.
4 Click Apply.

**Quick Reference**

**Commands**

CUI

Manages the customized user interface elements in the product.

**Create and Edit Custom Images for Commands**

Custom images can be created and edited which can be assigned to a command.

You can create custom images to assign to a command using the Button Editor dialog box built into the CUI Editor or an external image editor. You can either start with an existing button image or create your own from scratch. Custom images when saved are by default stored in the working customization file. Saved custom images can be exported to an external BMP file to use in another customization file.

**NOTE** In releases prior to AutoCAD LT 2011, custom images were stored separately from the customization file. In AutoCAD LT 2011, images are now stored as part of the CUIx file making it easier to share with others.

Custom images can be created in two different sizes: small and large. Small images should be 16 x 16 pixels. Large images should be 32 x 32 pixels. Images that do not match these sizes are scaled to fit.
To create or edit a button image

1. Click Manage tab ➤ Customization panel ➤ User Interface.

2. In the Customize User Interface Editor, Customize tab, in the Command List pane or the Customizations In <file name> pane, click a command to display the Button Image pane (in the upper-right corner).

3. In the Button Image pane, select an image from the image list that is closest in appearance to the image you want to create or select an existing image to edit. Click Edit.

   TIP. If you want to start with a blank image, select any image from the image list under the Button Images pane. Click Edit to display the Button Editor dialog box. In the Button Editor dialog box, click Clear.

4. In the Button Editor dialog box, use the Pencil, Line, Circle, and Erase buttons to create or edit the button image. To change the selected color, select a color from the color palette, or click More to open the Select Color dialog box.

   - **Pencil button.** Edits one pixel at a time in the selected color. You can drag the pointing device to edit several pixels at once.

   - **Line button.** Creates lines in the selected color. Click and hold to set the first endpoint of the line. Drag to draw the line. Release to complete the line.

   - **Circle button.** Creates circles in the selected color. Click and hold to set the center of the circle. Drag to set the radius. Release to complete the circle.

   - **Erase button.** Resets the color of one pixel at a time to the default canvas color.
NOTE Click Import to import a BMP file stored on a local or network drive to edit it in the Button Editor dialog box and store it in the working CUIx file.

5 Click Save.
   The Save Image dialog box is displayed.

6 In the Save Image dialog box, Image Name text box, enter a name and click OK.
   The image is saved to the working CUIx file.

7 Click Close.
   You are returned to the Customize User Interface Editor.

Quick Reference

Commands
CUI
   Manages the customized user interface elements in the product.

Manage, Import, and Export Custom Images

Custom images stored as externally saved BMP files can be imported into a loaded customization file and exported from a customization file to a local or network drive. Custom images can be deleted from a customization file in the Image Manager.

Prior to AutoCAD LT 2011, custom images used for commands in a customization file were stored on a local or network drive as separate BMP files or in a resource DLL. Resource DLLs are still maintained externally to customization files but starting with AutoCAD LT 2011, BMP files used by custom commands defined in a customization file are stored in the customization file.

You can use the Image Manager, the Button Editor dialog box, or the Button Image pane to manage custom images in the loaded customization files. With the Image Manager, you can import and export custom images to and from a customization file. You can also use the Image Manager to see which custom images are currently stored in a loaded customization file and remove those that you no longer need. You can also use the Button Editor dialog box and Button Image pane to import and export custom images.
To import a custom image to the image list and the working customization file

1. Click Manage tab ➤ Customization panel ➤ User Interface.

2. In the Customize User Interface Editor, Customize tab, in the Command List pane, select any command to display the Button Image pane.

3. In the Button Image pane, right-click the image list and click Import Image.

4. In the Open dialog box, browse to and select the BMP file that you want to import and click Open.
   The image is added to the image list and can then be assigned to a command.

To export an image from the image list

1. Click Manage tab ➤ Customization panel ➤ User Interface.

2. In the Customize User Interface Editor, Customize tab, in the Command List pane, select any command to display the Button Image pane.

3. In the Button Image pane, select the image to export, and click Export.
4 In the Export Image File dialog box, browse to the folder to which you want to export the image and enter a name for the image in the File Name text box.

5 Click Save.

NOTE You can only export images in the BMP (*.bmp, *.rle, or *.dib) format.

To import an image into a loaded customization file using the Image Manager

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click Launches the Image Manager Dialog.

3 In the Image Manager, Loaded Customization Files drop-down list, select the loaded customization file into which you want to import a custom image.
4 In the Import Images dialog box, browse to and select the images you want to import. Click Open.
   If the CUI Editor - Image Already Exists dialog box is displayed, click Import Image as Copy to create a copy of the image being imported or Overwrite Existing Image to replace the image with the one being imported.

5 Click OK.

To export an image from a loaded customization file with the Image Manager

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click Launches the Image Manager Dialog.

3 In the Image Manager, Loaded Customization Files drop-down list, select the loaded customization file that contains the custom image you want to export.
4 In the Custom Images list, select the image you want to export and click Export.

5 In the Browse For Folder dialog box, browse to the folder to which you want to export the selected images. Click OK.

6 Click OK.

To delete an image from a loaded customization file

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click Launches the Image Manager Dialog.

3 In the Image Manager, Loaded Customization Files drop-down list, select the loaded customization file that contains the custom image that you want to delete.
4 In the Custom Images list, select the image you want to remove and click Delete.

5 In the CUI Editor - Confirm Deletion of Image dialog box, click Delete Image.
   If the selected image is assigned to a command, the CUI Editor - Confirm Deletion of Referenced Image dialog box is displayed. The deletion of the image cannot be undone.

6 Click OK.

Quick Reference

Commands

CUI
   Manages the customized user interface elements in the product.

Customize User Interface Elements

User interface elements in the Customize User Interface (CUI) Editor are used to control how standard and custom commands can be started.
See also:

To copy and paste a user interface element

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, Customizations pane, expand the main node for the user interface element that you want to copy.

3 Right-click the user interface element, and click Copy.

4 Right-click the node that you want to paste the selected user interface element to, and click Paste.
5 Click Apply.

To duplicate a user interface element

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, Customizations In <filename> pane, expand the main node for the user interface element that you want to duplicate.

3 Right-click the user interface element, and click Duplicate.

A copy of the selected user interface element is created in-place directly above the selection in the Customizations In <filename> pane.

NOTE The key combination Ctrl+D can be used to duplicate a user interface element in-place.

4 Click Apply.
Quick Reference

Commands

CUI

Manages the customized user interface elements in the product.

Quick Access Toolbars

The Quick Access toolbar is located along the top of the application window (above or below the ribbon) and provides direct access to a defined set of commands.

The Quick Access toolbar is always located in the same place in the program, but different commands may be displayed on it based on the current workspace. You can customize the Quick Access toolbar by

- Creating Quick Access toolbars under the Customizations In <file name> pane and then adding the Quick Access toolbar to a workspace under the Workspace Contents pane in the Customize User Interface (CUI) Editor.

- Adding commands directly to the Quick Access toolbar from the ribbon or when the Customize User Interface (CUI) Editor is displayed. You can also remove commands when the Customize User Interface (CUI) Editor is displayed or not.

Customizing a Quick Access toolbar is similar to customizing a ribbon panel or toolbar. You can add, remove, and reposition commands and controls to tailor the user interface element to the way you work. You can also add drop-downs and separators to group and organize related commands.

Once a Quick Access toolbar has been defined, it can be displayed in the application window by assigning it to the Quick Access Toolbar node of a workspace under the Workspace Contents pane. For more information about assigning a Quick Access toolbar to a workspace, see To display a Quick Access toolbar on page 299.

NOTE You can add controls to a Quick Access toolbar. The controls you can add are listed under Ribbon Controls in the drop-down list under the Command List pane.
To create a Quick Access toolbar

1. Click Manage tab ➤ Customization panel ➤ User Interface.

2. In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, right-click Quick Access Toolbars. Click New Quick Access Toolbar.

   A new Quick Access toolbar (named Quick Access Toolbar1) is placed at the bottom of the Quick Access Toolbars tree.

3. Do one of the following:
   - Enter a new name over the default name Quick Access Toolbar1.
   - Right-click Quick Access Toolbar1. Click Rename. Enter a new name.
   - Click Quick Access Toolbar1, wait, and click again over the Quick Access toolbar’s name again to edit its name in-place.

4. Click Apply.

To delete a Quick Access toolbar

1. Click Manage tab ➤ Customization panel ➤ User Interface.

2. In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to the Quick Access Toolbars node to expand it.

3. Right-click the Quick Access toolbar you want to delete and click Delete.
4 Click Apply.

**To add a command or control to a Quick Access toolbar from the CUI Editor**

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, in the Customizations In `<file name>` pane, click the plus sign (+) next to the Quick Access Toolbars node to expand it.

3 Click the plus sign (+) next to the Quick Access toolbar that you want to modify.

4 Under the Command List pane, drag the command or control you want to add to the Quick Access toolbar from the Command List pane to the Quick Access Toolbar node under the Customizations In `<file name>` pane.
A splitter bar is displayed to indicate the location where the command or control will be added when you release the pointing device button.

5 Once the splitter bar is in the location you want to insert the command or control, release the pointing device button.

6 Click Apply.

To remove a command or control from a Quick Access toolbar with the CUI Editor

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to the Quick Access Toolbars node to expand it.

3 Click the plus sign (+) next to the Quick Access toolbar from which you want to remove a command or control.

4 Right-click the command you want to remove and click Remove.
5 Click Apply.

To add and remove commands from the Quick Access toolbar outside the CUI Editor

■ To add a command to the Quick Access toolbar
Do one of the following:
■ Right-click a command on the ribbon, and click Add to Quick Access Toolbar.

■ On the Quick Access toolbar, click the Customize button located on the right side and select one of the listed commands or select More Commands. Selecting More Commands displays the Customize User Interface (CUI) Editor in a compact state. Drag commands from the Command List pane to the Quick Access toolbar in the application window.

■ To remove a command from the Quick Access toolbar
■ Right-click the command you want to remove and click Remove from Quick Access Toolbar.
To add a drop-down to a Quick Access toolbar

1. Click Manage tab ➤ Customization panel ➤ User Interface.
2. In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to the Quick Access Toolbars node to expand it.
3. Click the plus sign (+) next to the Quick Access toolbar that you want to modify.
4. Right-click the Quick Access toolbar which you want to add a drop-down to. Click New Drop-down.

A new drop-down (named New Drop-down) is added to the bottom of the Quick Access toolbar.

5. Right-click the new drop-down. Click Rename. Enter a new name.

**NOTE:** You can click, wait, and click again over a drop-down name to edit its name in-place in the Customizations In <file name> pane.

6. Drag the drop-down under the Quick Access toolbar to the position where you want it placed. Use the visual indicator bar that is displayed to help specify the location for the drop-down. Release the pointing device button to reposition the drop-down.

7. Under the Command List pane, drag the command or control you want to add to the Quick Access toolbar from the Command List pane to the Quick Access Toolbar node under the Customizations In <file name> pane.
A visual indicator bar is displayed to indicate the location where the command or control will be added when the pointing device button is released.

8 Once the splitter bar is in the location where you want to insert the command or control, release the pointing device button.

9 Adjust the properties of the drop-down as desired to control the appearance of the drop-down and the commands under the drop-down. on page 164

10 If the drop-down will use the Split behavior, add a command to the Primary Command node under the drop-down to set the command for the main button.

11 Click Apply.

Quick Reference

Commands

CUI

Manages the customized user interface elements in the product.

Ribbon

You can customize the ribbon by creating and modifying ribbon panels and organizing ribbon panels into groups of task-based tools with ribbon tabs.
Ribbon tabs can be displayed on the ribbon with a workspace or based on a contextual tab state when they are needed.

**Ribbon Panels**

By customizing ribbon panels, you can organize commands that you use frequently similar to toolbars. With ribbon panels, you can quickly access commands, and reduce the number of user interface elements that are displayed.

**Overview of Ribbon Panels**

Ribbon panels are organized by rows, sub-panels, and slideout elements. Rows and sub-panels are used to organize how commands and controls are displayed on the ribbon panel. A slideout is automatically added to each ribbon panel and controls which rows are shown by default. Rows located below a slideout are displayed only when a ribbon panel is expanded.

The following table describes the properties of the Home 2D - Draw ribbon panel as they appear in the Properties pane.

<table>
<thead>
<tr>
<th>Properties Pane Item</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name of the panel; does not appear in the user interface.</td>
<td>Home 2D - Draw</td>
</tr>
<tr>
<td>Display Text</td>
<td>Title of the panel; displayed when the ribbon is set to display titles or when a panel is floating.</td>
<td>Draw</td>
</tr>
<tr>
<td>Description</td>
<td>Text used to describe the element; does not appear in the user interface and is optional.</td>
<td></td>
</tr>
<tr>
<td>KeyTip</td>
<td>Specifies the keytip characters that can be used to access the ribbon panel from the keyboard.</td>
<td></td>
</tr>
<tr>
<td>Aliases</td>
<td>Specifies the aliases for the panel. Click the [ ] button to open the Aliases dialog box. Each alias in the CUIx file should be unique and is used to reference the panel programmatically.</td>
<td>ID_Draw</td>
</tr>
</tbody>
</table>
Create a Ribbon Panel

Ribbon panels can be created from scratch or from an existing toolbar or dashboard panel. Create ribbon panels from scratch under the Ribbon Panels node on the Customizations In <file name> pane of the Customize tab. This gives you control over which commands are displayed on the ribbon panel.

If you have an existing toolbar or dashboard panel from a previous release, you can create a new ribbon panel from them. Copy toolbars to a ribbon panel from the Toolbars node under the Customizations In <file name> pane on the Customize or Transfer tabs. Dashboard panels can only be copied to ribbon panels from the Dashboard Panels node on the Transfer tab.

Display Ribbon Panels on the Ribbon

The display of ribbon panels is controlled with ribbon tabs. Once a ribbon tab is defined, the ribbon tab can be added to a workspace, which controls which ribbon tabs are displayed and the order in which they are displayed on the ribbon. For more information about ribbon tabs, see Ribbon Tabs on page 180 under Customize User Interface Elements on page 139.

Associating Tool Palette Group with a Ribbon Panel

You can associate a tool palette group with a ribbon panel. By associating a tool palette group to a ribbon panel you can quickly access additional tools that are related to a ribbon panel and are defined on a tool palette. The association of a tool palette group to a ribbon panel is done from the ribbon. For more information about tool palettes and tool palette groups, see Customize Tool Palettes and Organize Tool Palettes in the User’s Guide.

To create a ribbon panel

1. Click Manage tab ➤ Customization panel ➤ User Interface.
2. In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to the Ribbons node to expand it.
3 Right-click Panels. Click New Panel.

A new panel (named Panel1) is placed at the bottom of the Ribbon Panels tree.

4 Right-click Panel1. Click Rename. Enter a new panel name.

5 Select the new panel, and update its properties in the Properties pane:
   ■ In the Display Text box, enter the text you want to display for the title of the panel when it is displayed on the ribbon.
   ■ In the KeyTip box, enter the characters to access the ribbon panel from the keyboard.
   ■ In the Aliases box, enter an alias for the ribbon panel.

6 Click Apply.

To copy a toolbar to a ribbon panel

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to Toolbars to expand it.
3 Right-click the toolbar that you want to copy to a ribbon panel. Click Copy to Ribbon Panels.

4 In the CUI Editor - Confirm Copy to Ribbon Panels Node dialog box, click Yes.
   The copied toolbar is copied to the Panels node under the Ribbons node.

5 Click Apply.

To copy a dashboard panel to a ribbon panel

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Transfer tab, in the Customizations In <file name> pane on the right, click Open Customization File.

3 In the Open dialog box, Files of Type drop-down list, select Legacy Customization Files (*.cui).

4 Browse to and select the customization (CUI) file that contains the dashboard panels you want to copy to ribbon panels. Click Open.

5 Click the plus sign (+) next to Dashboard Panels to expand it.

6 Right-click over the dashboard panel you want to copy to a ribbon panel. Click Copy to Ribbon Panels.

7 In the CUI Editor - Confirm Copy to Ribbon Panels Node dialog box, click Yes.

   ![CUI Editor - Confirm Copy to Ribbon Panels Node](image)

   Do you want to copy the selected dashboard panel(s) to the Ribbon Panels node?

   This operation does not remove the selected items. The selected dashboard panel(s) are only copied to the Ribbon Panels node of this CUI file.

   □ Do not show me this message again
   Yes
   No

The copied dashboard panel is copied to the Panels node under the Ribbons node.

8 Drag the new ribbon panel from the Customizations In <file name> pane on the right to the Panels node of one of the loaded CUIx files in the Customizations In <file name> pane on the left.
9 Click Apply.

To remove a ribbon panel

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Custom User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to Ribbon to expand it.

3 Click the plus sign (+) next to Panels to expand it.

4 Right-click the panel that you want to remove. Click Delete.

WARNING There is no way to undo the removal of a user interface element, so be careful when removing user interface elements. If you remove the wrong user interface element, the best thing to do is click Cancel to not save changes, but this will also undo any other changes that you might have made.

5 In the AutoCAD LT message box, click Yes.

6 Click Apply.

To control the display of ribbon panel titles on the ribbon

- Right-click a ribbon tab on the ribbon, and click Show Panel Titles.
To assign a command to the Panel Dialog Box Launcher

1. Click Manage tab ➤ Customization panel ➤ User Interface.

2. In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to Ribbon to expand it.

3. Click the plus sign (+) next to Panels to expand it.

4. Click the plus sign (+) next to the ribbon panel where you want to assign a command to its Panel Dialog Box Launcher node.

5. Drag a command from the Command List pane to the Panel Dialog Box Launcher node for the panel.
6 Click Apply.

Quick Reference

Commands

CUI
Manages the customized user interface elements in the product.

RIBBON
Opens the ribbon window.

RIBBONCLOSE
Closes the ribbon window.

Add and Organize Commands and Controls on a Ribbon Panel

Commands and controls are added to and organized with rows and sub-panels on a ribbon panel.

You can add and rearrange the commands and controls on a row that you use often, and you can remove those from a row that you use infrequently. Rows are used to hold and organize commands and controls on a ribbon panel. Along with using rows to organize commands, you can also create drop-downs that contain multiple commands and only take up the space of a single
command. For more information about drop-downs on ribbon panels, see Add Drop-downs to a Ribbon Panel on page 167.

In addition to using rows and sub-panels to organize commands, you can also use menu separators. Menu separators are used to add space or lines between commands and controls.

The following table describes the properties for the Line command of Row 1 on the Home 2D - Draw ribbon panel as they appear in the Properties pane.

<table>
<thead>
<tr>
<th>Properties Pane Item</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Text used as the name and label of the command button; does appear in the user interface.</td>
<td>Line</td>
</tr>
<tr>
<td><strong>NOTE</strong></td>
<td>Use the “\n” character sequence to represent a line break and display a command label on more than one line. The “\n” character sequence is displayed as a space instead of the characters “\n” after the changes to the command are saved.</td>
<td></td>
</tr>
<tr>
<td>Button Style</td>
<td>Controls the size and the label display of the command. The available options are Large With Text (Vertical), Large With Text (Horizontal), Small With Text, or Small Without Text.</td>
<td>Large with Text (Vertical)</td>
</tr>
<tr>
<td><strong>NOTE</strong></td>
<td>It is recommended to not use the Large With Text (Horizontal) option as it takes up extra space on the ribbon.</td>
<td></td>
</tr>
<tr>
<td>Group Name</td>
<td>Specifies the group name assigned to the command that is used to control the organization of the command on a drop-down.</td>
<td></td>
</tr>
<tr>
<td>Command Name</td>
<td>Text that contains the name of the command as it appears in the Command List pane.</td>
<td>Line</td>
</tr>
<tr>
<td>Description</td>
<td>Text used to describe the element; does not appear in the user interface.</td>
<td>Creates straight line segments</td>
</tr>
<tr>
<td>Properties Pane Item</td>
<td>Description</td>
<td>Example</td>
</tr>
<tr>
<td>---------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>---------</td>
</tr>
<tr>
<td>Extended Help File</td>
<td>Text that displays the file name and ID for the extended tooltip that is displayed when the cursor hovers over a toolbar or panel button.</td>
<td></td>
</tr>
<tr>
<td>Command Display Name</td>
<td>Text that contains the name of the command that is related to the command.</td>
<td>LINE</td>
</tr>
<tr>
<td>Macro</td>
<td>The command macro. It follows the standard macro syntax. <strong>NOTE</strong> When you change the name of a macro, the name of its corresponding menu item or toolbar button does not change. You must change a menu item or toolbar button name by selecting it in the tree view.</td>
<td>^C^C_line</td>
</tr>
<tr>
<td>Tags</td>
<td>Keywords associated to a command. Tags provide an additional field to search when using the Search field in the application menu.</td>
<td></td>
</tr>
<tr>
<td>KeyTip</td>
<td>Specifies the keytip characters that can be used to access the command from the keyboard.</td>
<td>LI</td>
</tr>
<tr>
<td>Tooltip Title</td>
<td>Text string that controls the title of the tooltip for the command.</td>
<td></td>
</tr>
<tr>
<td>Element ID</td>
<td>Tag that uniquely identifies a command.</td>
<td>UIDU_0005</td>
</tr>
<tr>
<td>Small Image</td>
<td>ID string of the small-image resource (16 × 16 bitmap). The string must include alphanumeric characters with no punctuation other than a hyphen (-) or an underscore (_). It can also be a user-defined bitmap. Click the [ ] button to open the Select Image File dialog box.</td>
<td>RCDATA_16_LINE</td>
</tr>
<tr>
<td>Large Image</td>
<td>ID string of the large-image resource (32 × 32 bitmap). If the specified bitmap is not 32 × 32, RCDATA_32_LINE</td>
<td></td>
</tr>
</tbody>
</table>
**Properties for the Line Command on Row 1 of the Home 2D - Draw Ribbon Panel**

<table>
<thead>
<tr>
<th>Properties Pane Item</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>the program scales it to that size. The string must include alphanumeric characters with no punctuation other than a hyphen (-) or an underscore (_). It can also be a user-defined bitmap. Click the [ ] button to open the Select Image File dialog box.</td>
<td></td>
</tr>
</tbody>
</table>

**Organize Commands and Controls with Rows**

A row, similar to a toolbar, determines the order and position that commands and controls appear on a ribbon panel. Rows run horizontally on a ribbon panel no matter if the ribbon is displayed horizontally or vertically. Not all rows might be displayed by default on a ribbon panel, the `<SLIDEOUT>` element controls which rows are displayed without expanding a ribbon panel. A down arrow to the right of a ribbon panel’s title indicates that the ribbon panel can be expanded.

**Organize Rows with Sub-panels**

Sub-panels do not directly contain commands. Instead, sub-panels are used in combination with rows to organize commands and controls on a ribbon panel.

**Organize Rows with Fold Panels**

Fold panels can have buttons, toggles button, split buttons, and drop-down buttons. Button Style must be set to Large with Text. Fold panels can be converted to sub-panels.

**See also:**

- To add a row to a ribbon panel on page 159 (Procedure)
- To add a sub-panel or fold panel to a row on a ribbon panel on page 159 (Procedure)
- To remove a row or sub-panel from a ribbon panel on page 160 (Procedure)
- To reposition a row or sub-panel on a ribbon panel on page 161 (Procedure)
- To add a command to a ribbon panel on page 161 (Procedure)
To reposition a command on a ribbon panel on page 163 (Procedure)

To remove a command from a ribbon panel on page 162 (Procedure)

To change the display and behavior of commands, controls and drop-downs on a ribbon panel on page 164 (Procedure)

To add a row to a ribbon panel

1. Click Manage tab ➤ Customization panel ➤ User Interface.
2. In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to Ribbon to expand it.
3. Click the plus sign (+) next to Panels to expand it.
4. Right-click the ribbon panel to which you want to add a row. Click New Row.
5. Click Apply.

To add a sub-panel or fold panel to a row on a ribbon panel

1. Click Manage tab ➤ Customization panel ➤ User Interface.
2. In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to Ribbon to expand it.
3. Click the plus sign (+) next to Panels to expand it.
4. Click the plus sign (+) next to the ribbon panel where you want to add a sub-panel or fold panel.
5 Create a new row for the sub-panel or fold-panel if needed, or click the plus sign (+) next to the row where you want to add a sub-panel or fold panel.

6 Right-click the row where you want to add a sub-panel or fold-panel. Click New Sub-Panel or New Fold Panel.

7 Click Apply.

To remove a row or sub-panel from a ribbon panel

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to Ribbon to expand it.

3 Click the plus sign (+) next to Panels to expand it.

4 Click the plus sign (+) next to the ribbon panel from which you want to remove a row or sub-panel.

5 Right-click the row or sub-panel that you want to remove. Click Delete.
6 Click Apply.

To reposition a row or sub-panel on a ribbon panel

1 Click Manage tab ➤ Customization panel ➤ User Interface.
2 In the Customize User Interface Editor, Customize tab, in the Customizations In **<file name>** pane, click the plus sign (+) next to Ribbon to expand it.
3 Click the plus sign (+) next to Panels to expand it.
4 Click the plus sign (+) next to the ribbon panel where you want to reposition a row or sub-panel.
5 Drag the row or sub-panel that you want to reposition up or down under the ribbon panel’s node. Use the visual indicator bar to position the row above or below other rows or sub-panels.
6 Click Apply.

To add a command to a ribbon panel

1 Click Manage tab ➤ Customization panel ➤ User Interface.
2 In the Customize User Interface Editor, Customize tab, in the Customizations In **<file name>** pane, click the plus sign (+) next to Ribbon to expand it.
3 Click the plus sign (+) next to Panels to expand it.
4 Click the plus sign (+) next to the ribbon panel where you want to add a command.
5 Click the plus sign (+) next to the rows, sub-panels, or drop-downs to get to the location you want to add a command.
6 Drag a command from the Command List pane to a row, sub-panel, or drop-down on the panel. Use the visual indicator bar to specify the position of the command.

![Command List pane](image)

7 In the Properties pane, change the properties of the command you added on page 164.

![Properties pane](image)

8 Click Apply.

To remove a command from a ribbon panel

1 Click Manage tab ➤ Customization panel ➤ User Interface.
In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to Ribbon to expand it.

Click the plus sign (+) next to Panels to expand it.

Click the plus sign (+) next to the ribbon panel where you want to remove a command.

Click the plus sign (+) next to the rows, sub-panels, or drop-downs to get to the location you want to remove a command.

Right-click the command that you want to remove. Click Remove.

Click Apply.

To reposition a command on a ribbon panel

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to Ribbon to expand it.

3 Click the plus sign (+) next to Panels to expand it.

4 Click the plus sign (+) next to the ribbon panel where you want to reposition a command.

5 Click the plus sign (+) next to the rows, sub-panels, or drop-downs to get to the location you want to reposition a command.

6 Drag the command to a new location. Use the visual indicator bar to specify the position of the command.
To change the display and behavior of commands, controls and drop-downs on a ribbon panel

Do one of the following:

To show the label and set the orientation of a command or drop-down on a ribbon panel

1. Click Manage tab ➤ Customization panel ➤ User Interface.
2. In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to Ribbon to expand it.
3. Click the plus sign (+) next to Panels to expand it.
4. Click the plus sign (+) next to the ribbon panel where you want to show the label for a command.
5. Click the plus sign (+) next to the row, sub-panel, or drop-down where you want to show the label for a command. If you need to, continue expanding rows, sub-panels, and drop-downs to get to the command or drop-down.
6. Select the command that you want to show its label for.
7. In the Properties pane, Button Style box, click the down arrow and select Large With Text (Vertical), Large With Text (Horizontal), or Small With Text.
To set the size of a command or drop-down on a ribbon panel

1. Click Manage tab ➤ Customization panel ➤ User Interface.

2. In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to Ribbon to expand it.

3. Click the plus sign (+) next to Panels to expand it.

4. Click the plus sign (+) next to the ribbon panel which has the command or drop-down for which you want to set the size.

5. Click the plus sign (+) next to the row or sub-panel that has the command or drop-down for which you want to set the size. If you need to, continue expanding rows, sub-panels, and drop-downs to get to the command or drop-down.

6. Select the command or drop-down for which you want to set the size.

7. In the Properties pane, Button Style box, click the down arrow and select Large With Text (Vertical), Large With Text (Horizontal), Small With Text, or Small Without Text.

8. Click Apply.
8 Click Apply.

**To set the button and style of a drop-down on a ribbon panel**

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to Ribbon to expand it.

3 Click the plus sign (+) next to Panels to expand it.

4 Click the plus sign (+) next to the ribbon panel where you want to change the style of a drop-down.

5 Click the plus sign (+) next to the row or sub-panel that contains the drop-down you want to change. If you need to, continue expanding rows and sub-panels to get to the drop-down.

6 Select the drop-down that you want to change, and update its properties in the Properties pane:
   - In the Behavior box, click the down arrow and select Drop Down Menu with Recent, Drop Down Menu, Split with Recent, Split, or Split with Recent (Static).
   - In the Split Button List Style box, click the down arrow and select Icon, Icon and Text, and Descriptive.
7 Click Apply.

Quick Reference

Commands

CUI

Manages the customized user interface elements in the product.

RIBBON

Opens the ribbon window.

RIBBONCLOSE

Closes the ribbon window.

Add Drop-downs to a Ribbon Panel

Drop-downs can be used to group multiple related commands into a single button.

Ribbon panel drop-downs, like toolbar flyouts, that can hold a number of commands in a single place on a ribbon panel. Drop-downs are used to help reduce the amount of space that related commands can take up. Commands on a drop-down can be started by clicking the main button or selecting a command from the menu when the main or split button is clicked based on how the properties of a drop-down are configured. When a drop-down is set as a split button, the main button can reflect the most recently used command or not, or display the image of the most recently used command with a static label.
The following table describes the properties for the Arc drop-down of Row 1 on under Sub-Panel 1 of the Home 2D - Draw ribbon panel as they appear in the Properties pane.

<table>
<thead>
<tr>
<th>Properties Pane Item</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Logical name for the drop-down; does not appear in the user interface.</td>
<td>Arc</td>
</tr>
<tr>
<td><strong>NOTE</strong> The “\n” character sequence represents a line break in a command label, which is used to allow a command label to be displayed on more than one line. Once focus from the Name field is lost, the “\n” character sequence is displayed as a space instead of the characters “\n”.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Description</td>
<td>Text used to describe the element; does not appear in the user interface.</td>
<td></td>
</tr>
<tr>
<td>Behavior</td>
<td>Specifies if the button executes a command or displays a list of commands. The available options are Drop Down Menu with Recent, Drop Down Menu, Split with Recent, Split, Split with Recent (Static).</td>
<td>Split with Recent</td>
</tr>
<tr>
<td>Split Button List Style</td>
<td>Specifies how the commands on the drop-down will be displayed. The available options are Icon, IconText, or Descriptive.</td>
<td>IconText</td>
</tr>
<tr>
<td>Button Style</td>
<td>Controls the size and the label display of the drop-down. The available options are Large With Text (Vertical), Large With Text (Horizontal), Small With Text, or Small Without Text.</td>
<td>Large with Text (Vertical)</td>
</tr>
<tr>
<td><strong>NOTE</strong> It is recommended to not use the Large With Text (Horizontal) option as it takes up extra space on the ribbon.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Grouping</td>
<td>Controls whether the commands assigned to a drop-down are grouped based on the values assigned to their Group Name properties.</td>
<td>No</td>
</tr>
<tr>
<td>KeyTip</td>
<td>Specifies the keytip characters that can be used to access the command from the keyboard.</td>
<td>AR</td>
</tr>
</tbody>
</table>
### Properties for the Arc Drop-down on Row 1 of the Home 2D - Draw Ribbon Panel

<table>
<thead>
<tr>
<th>Properties Pane Item</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tooltip Title</td>
<td>Text string that controls the title of the tooltip for the command.</td>
<td></td>
</tr>
<tr>
<td>Element ID</td>
<td>Tag that uniquely identifies a panel section.</td>
<td>ID_RBN_SPLIT-BTN_ARC</td>
</tr>
<tr>
<td>Small Image</td>
<td>ID string of the small-image resource (16 × 16 bitmap). The string must include alphanumeric characters with no punctuation other than a hyphen (-) or an underscore (_). It can also be a user-defined bitmap. Click the [ ] button to open the Select Image File dialog box.</td>
<td>RCDATA_16_ARC3PT</td>
</tr>
<tr>
<td>Large Image</td>
<td>ID string of the large-image resource (32 × 32 bitmap). If the specified bitmap is not 32 × 32, the program scales it to that size. The string must include alphanumeric characters with no punctuation other than a hyphen (-) or an underscore (_). It can also be a user-defined bitmap. Click the [ ] button to open the Select Image File dialog box.</td>
<td>RCDATA_16_ARC3PT</td>
</tr>
</tbody>
</table>

### See also:
- To create a drop-down in a row on a ribbon panel

1. Click Manage tab ➤ Customization panel ➤ User Interface.
2. In the Customize User Interface Editor, Customize tab, in the Customizations In `<file name>` pane, click the plus sign (+) next to Ribbon to expand it.
3. Click the plus sign (+) next to Panels to expand it.
4. Click the plus sign (+) next to the ribbon panel where you want to add a drop-down.
5. Right-click the row to which you want to add a drop-down. Click New Drop-down.
A new drop-down (named New Drop-down) is created in the last position of the row.

6 Right-click the new drop-down. Click Rename. Enter a new name.

7 In the Command List pane, drag the commands that you want to add to the new drop-down in the Customizations In <file name> pane.

8 Adjust the properties of the drop-down as desired to control the appearance of the drop-down and the commands under the drop-down.

9 If the drop-down will use the Split behavior, add a command to the Primary Command node under the drop-down to set the command for the main button.

10 Click Apply.
Quick Reference

Commands

CUI
Manages the customized user interface elements in the product.

RIBBON
Opens the ribbon window.

RIBBONCLOSE
Closes the ribbon window.

Add and Remove Ribbon Panel Controls

You can add, remove, and relocate ribbon panel controls, such as drop-down lists, sliders, text boxes, and other types of panel-specific controls that start commands or change a setting. For example, the Home 2D/3D - Layers panel contains controls for working with the layers of a drawing.

The following table describes the controls found in the Customize User Interface (CUI) Editor that can be used on ribbon panels.

<table>
<thead>
<tr>
<th>Control element</th>
<th>Control Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ribbon Toggle Button - Authoring Palettes</td>
<td>Toggle</td>
<td>Displays or hides the Block Authoring palettes.</td>
</tr>
<tr>
<td>Ribbon Combo Box - Background Color Status</td>
<td>Drop-down list</td>
<td>Displays and changes the background color of the selected cells in a table.</td>
</tr>
<tr>
<td>Ribbon Toggle Button - Block Constraint Status</td>
<td>Toggle</td>
<td>Controls constraint display status and the shading of objects based on their constraint level.</td>
</tr>
<tr>
<td>Ribbon Label - Block</td>
<td>Label</td>
<td>Displays the name of the block that is currently being edited in the Block Editor.</td>
</tr>
<tr>
<td>Ribbon Combo Box - Block Visibility States</td>
<td>Drop-down list</td>
<td>Displays a list of the visibility states saved with the current block in the Block Editor.</td>
</tr>
<tr>
<td>Control element</td>
<td>Control Type</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------------------------------</td>
<td>--------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Ribbon Command Button - Block Visibility Hide</td>
<td>Button</td>
<td>Makes objects visible in the current visibility state or all visibility states in the block definition opened for edit in the Block Editor.</td>
</tr>
<tr>
<td>Ribbon Command Button - Block Visibility Mode</td>
<td>Button</td>
<td>Controls how objects that are made invisible for the current visibility state are displayed in the Block Editor.</td>
</tr>
<tr>
<td>Ribbon Command Button - Block Visibility State</td>
<td>Button</td>
<td>Makes objects invisible in the current visibility state or all visibility states in the block definition opened for edit in the Block Editor.</td>
</tr>
<tr>
<td>Ribbon Command Button - Block Visibility States</td>
<td>Button</td>
<td>Allows you to create or modify the visibility states of the current block definition opened for edit in the Block Editor.</td>
</tr>
<tr>
<td>Ribbon Combo Box - Cell Styles</td>
<td>Drop-down</td>
<td>Displays and changes the cell style of the selected cells in a table.</td>
</tr>
<tr>
<td>Ribbon Toggle Button - Command Line</td>
<td>Toggle</td>
<td>Displays or hides the command line window.</td>
</tr>
<tr>
<td>Ribbon Toggle Button - Design Center</td>
<td>Toggle</td>
<td>Displays or closes the DesignCenter palette.</td>
</tr>
<tr>
<td>Ribbon Toggle Button - DGN Osnap</td>
<td>Toggle</td>
<td>Controls object snapping for DGN underlays.</td>
</tr>
<tr>
<td>Ribbon Combo Box - Dimension Style</td>
<td>Drop-down</td>
<td>Displays and sets the current dimension style.</td>
</tr>
<tr>
<td>Ribbon Toggle Button - Drawing Recovery Manager</td>
<td>Toggle</td>
<td>Displays or closes the Drawing Recovery Manager palette.</td>
</tr>
<tr>
<td>Ribbon Toggle Button - Drawing Status Bar</td>
<td>Toggle</td>
<td>Displays or hides the drawing status bar.</td>
</tr>
<tr>
<td>Ribbon Toggle Button - DWF Osnap</td>
<td>Toggle</td>
<td>Controls object snapping for DWF underlays.</td>
</tr>
<tr>
<td>Ribbon Toggle Button - Dynamic Constraint Display</td>
<td>Toggle</td>
<td>Displays or hides dynamic constraints.</td>
</tr>
</tbody>
</table>
## Controls available for ribbon panels

<table>
<thead>
<tr>
<th>Control element</th>
<th>Control Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ribbon Combo Box - What to Export</td>
<td>Drop-down list</td>
<td>Controls which part of the drawing should be exported to a DWF, DWFx or PDF file.</td>
</tr>
<tr>
<td>Ribbon Combo Box - Page Setup</td>
<td>Drop-down list</td>
<td>Allows you to export the drawing to a DWF, DWfx, or PDF file using the page setup settings in the Page Setup Manager or to override these settings.</td>
</tr>
<tr>
<td>Ribbon Toggle Button - External References</td>
<td>Toggle</td>
<td>Displays or closes the External References palette.</td>
</tr>
<tr>
<td>Ribbon - Image, Show Image Toggle Button</td>
<td>Toggle</td>
<td>Displays or hides the selected raster image.</td>
</tr>
<tr>
<td>Ribbon - Image, Transparency Toggle Button</td>
<td>Toggle</td>
<td>Controls the use of transparency for the selected raster image.</td>
</tr>
<tr>
<td>Ribbon Combo Box - IPE Color Color</td>
<td>Drop-down list</td>
<td>Displays and changes the current color for the selected text in the multiline text editor.</td>
</tr>
<tr>
<td>Ribbon Combo Box - Font</td>
<td>Drop-down list</td>
<td>Displays and changes the current font style for the selected text in the multiline text editor.</td>
</tr>
<tr>
<td>Ribbon Combo Box - Text Height</td>
<td>Drop-down list</td>
<td>Displays and changes the current text height for the selected text in the multiline text editor.</td>
</tr>
<tr>
<td>Ribbon Gallery - IPE Text Style</td>
<td>Gallery</td>
<td>Displays and changes the current text style for the selected text in the multiline text editor.</td>
</tr>
<tr>
<td>Ribbon Spinner - Oblique Angle</td>
<td>Spinner</td>
<td>Displays and changes the current oblique angle for the selected text in the multiline text editor.</td>
</tr>
<tr>
<td>Ribbon Button - Paragraph Button</td>
<td>Button</td>
<td>Displays the Paragraph dialog box when the multiline text editor is active.</td>
</tr>
<tr>
<td>Control element</td>
<td>Control Type</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------------------</td>
<td>--------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Spell Check Settings</td>
<td>Button</td>
<td>Displays the Check Spelling Settings dialog box when the multiline text editor is active.</td>
</tr>
<tr>
<td>Ribbon Spinner - Tracking</td>
<td>Spinner</td>
<td>Displays and changes the current tracking spacing for the selected text in the multiline text editor.</td>
</tr>
<tr>
<td>Ribbon Spinner Width Factor</td>
<td>Spinner</td>
<td>Displays and changes the current width factor for the selected text in the multiline text editor.</td>
</tr>
<tr>
<td>Ribbon Toggle Button - Layer Properties</td>
<td>Toggle</td>
<td>Displays or closes the Layer Properties Manager palette.</td>
</tr>
<tr>
<td>LayerFilterComboControl</td>
<td>Drop-down list</td>
<td>Displays and sets the layer filter used in the drawing.</td>
</tr>
<tr>
<td>Ribbon Combo Box - Layer State</td>
<td>Drop-down list</td>
<td>Displays the available layer states; you can restore a saved layer state.</td>
</tr>
<tr>
<td>Ribbon Combo Box - Linetypes</td>
<td>Drop-down list</td>
<td>Displays and sets the current linetype.</td>
</tr>
<tr>
<td>Ribbon Combo Box - Lineweight</td>
<td>Drop-down list</td>
<td>Displays and sets the current lineweight.</td>
</tr>
<tr>
<td>Ribbon Toggle Button - Locked Layer Fading</td>
<td>Toggle</td>
<td>Enables or disables the fading effect for locked layers.</td>
</tr>
<tr>
<td>Locked layer fading</td>
<td>Slider</td>
<td>Adjusts the percentage lock layers are faded into the background.</td>
</tr>
<tr>
<td>Ribbon Toggle Button - Markup Set Manager</td>
<td>Toggle</td>
<td>Displays or closes the Markup Set Manager palette.</td>
</tr>
<tr>
<td>Ribbon Combo Box - Multileader Style</td>
<td>Drop-down list</td>
<td>Displays and sets the current multileader style.</td>
</tr>
<tr>
<td>Control element</td>
<td>Control Type</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------------------------------------</td>
<td>-----------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>3D Navigation Combo Control</td>
<td>Multiple</td>
<td>Displays and sets the current view to a standard orthographic or isometric view, or a saved name view based on the current space.</td>
</tr>
<tr>
<td>Lens length</td>
<td>Slider</td>
<td>Adjusts the lens length of a perspective view.</td>
</tr>
<tr>
<td>Ribbon Combo Box - Object Color</td>
<td>Drop-down list</td>
<td>Displays and sets the current object color.</td>
</tr>
<tr>
<td>Ribbon Menu Button - Switch Windows</td>
<td>Button</td>
<td>Displays a list of all open drawings; you can switch to a different open drawing.</td>
</tr>
<tr>
<td>Ribbon Radio Button - Paragraph Alignment</td>
<td>Radio button</td>
<td>Displays and changes the current paragraph alignment for the selected text in the multiline text editor.</td>
</tr>
<tr>
<td>Ribbon Toggle Button - Parameters Manager</td>
<td>Toggle</td>
<td>Displays or closes the Parameters Manager palette.</td>
</tr>
<tr>
<td>Ribbon Toggle Button - PDF Osnap</td>
<td>Toggle</td>
<td>Controls object snapping for PDF underlays.</td>
</tr>
<tr>
<td>Ribbon Combo Box - Plot Style</td>
<td>Drop-down list</td>
<td>Displays and sets the current plot style when the current drawing uses named plot styles.</td>
</tr>
<tr>
<td>Ribbon Toggle Button - Properties</td>
<td>Toggle</td>
<td>Displays or closes the Properties palette.</td>
</tr>
<tr>
<td>Ribbon Toggle Button - Quick Calculator</td>
<td>Toggle</td>
<td>Displays or closes the QuickCalc palette.</td>
</tr>
<tr>
<td>Ribbon Label - ReferenceEditName</td>
<td>Label</td>
<td>Displays the name of the block that is directly being edited in the current drawing.</td>
</tr>
<tr>
<td>Ribbon AutodeskSeekControl</td>
<td>Text box and button</td>
<td>Allows you to perform a context search from the Autodesk Seek web site.</td>
</tr>
<tr>
<td>Join Viewports</td>
<td>Button</td>
<td>Allows you to merge two adjacent tiled viewports into a single viewport.</td>
</tr>
<tr>
<td>Control element</td>
<td>Control Type</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------------------------------</td>
<td>----------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Ribbon Control - Empty Row Aligner</td>
<td>Spacer</td>
<td>Allows you to align empty rows with other rows that contain commands and controls.</td>
</tr>
<tr>
<td>Ribbon Text Box - Find Text</td>
<td>Text box</td>
<td>Searches a drawing for matching text based on a text string.</td>
</tr>
<tr>
<td>Ribbon Menu Button - Status Bar Options</td>
<td>Drop-down menu button</td>
<td>Displays a list of the status bar items that are currently turned on or off.</td>
</tr>
<tr>
<td>Ribbon Combo Box - Table Styles</td>
<td>Drop-down list</td>
<td>Displays and sets the current table style.</td>
</tr>
<tr>
<td>Ribbon Gallery - Text Style</td>
<td>Drop-down list</td>
<td>Displays and sets the current text style.</td>
</tr>
<tr>
<td>Ribbon Combo Box - Annotation Text Height</td>
<td>Drop-down list</td>
<td>Displays and sets the default text height for new text objects.</td>
</tr>
<tr>
<td>Ribbon Toggle Button - Tool Palettes</td>
<td>Toggle</td>
<td>Displays or hides the Tool Palettes window.</td>
</tr>
<tr>
<td>Ribbon - Underlay, Adjust Color for Background</td>
<td>Toggle</td>
<td>Determines if the colors of the selected underlay are adjusted based on the current background color.</td>
</tr>
<tr>
<td>Brightness</td>
<td>Slider</td>
<td>Displays and sets the current brightness for the selected underlay.</td>
</tr>
<tr>
<td>Contrast</td>
<td>Slider</td>
<td>Displays and sets the current contrast for the selected underlay.</td>
</tr>
<tr>
<td>Ribbon - Underlay, Display Monochrome</td>
<td>Toggle</td>
<td>Determines if the selected underlay should be displayed in monochrome colors only.</td>
</tr>
<tr>
<td>Toggle Button</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Fade</td>
<td>Slider</td>
<td>Displays and sets the current fade value for the selected underlay.</td>
</tr>
<tr>
<td>Ribbon - Clip Toggle Button</td>
<td>Toggle</td>
<td>Determines if the selected underlay is fully visible or just the area based on the clipping boundary.</td>
</tr>
</tbody>
</table>
### Controls available for ribbon panels

<table>
<thead>
<tr>
<th>Control element</th>
<th>Control Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ribbon - Show Underlay Toggle Button</td>
<td>Toggle</td>
<td>Determines if the selected underlay is visible or not.</td>
</tr>
<tr>
<td><strong>Ribbon Combo Box - Viewport Configurations</strong></td>
<td>Drop-down list</td>
<td>Sets how the active tiled viewport should be divided.</td>
</tr>
<tr>
<td>Xref fading</td>
<td>Slider</td>
<td>Displays and sets the level of fading that is applied to the objects of an xref.</td>
</tr>
<tr>
<td><strong>Ribbon Toggle Button - Xref fading</strong></td>
<td>Toggle</td>
<td>Indicates the objects of xrefs are faded into the background, enables or disables xref fading.</td>
</tr>
<tr>
<td><strong>Layer Combo Control</strong></td>
<td>Drop-down list</td>
<td>Displays and sets the current layer.</td>
</tr>
</tbody>
</table>

### To add a control to a ribbon panel

1. Click Manage tab ➤ Customization panel ➤ User Interface.
2. In the Customize User Interface Editor, Customize tab, in the Customizations In `<file name>` pane, click the plus sign (+) next to Ribbon to expand it.
3. Click the plus sign (+) next to Panels to expand it.
4. Click the plus sign (+) next to the ribbon panel where you want to add a control.
5. Create a new row for the control if you need to, or click the plus sign (+) next to the row where you want to add a control.
6. In the Command List pane, in the Categories list, click Ribbon Control Elements.
The Command List pane displays the list of ribbon control elements only.

7 Drag a control from the Command List pane to add it to the panel. Use the visual indicator bar to specify the position of the control.

8 Click Apply.

To reposition a control on a ribbon panel

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to Ribbon to expand it.

3 Click the plus sign (+) next to Panels to expand it.

4 Click the plus sign (+) next to the ribbon panel where you want to reposition a control.
5 Click the plus sign (+) next to the row where you want to reposition a control. If you need to, continue expanding sub-panels, rows, and drop-downs to get to the control.

6 Drag the control to a new location. Use the visual indicator bar to specify the position of the command.

7 Click Apply.

To remove a control from a ribbon panel

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to Ribbon to expand it.

3 Click the plus sign (+) next to Panels to expand it.

4 Click the plus sign (+) next to the ribbon panel where you want to remove a control.

5 Click the plus sign (+) next to the row where you want to remove a control. If you need to, continue expanding sub-panels, rows, and drop-downs to get to the control.

6 Right-click the control that you want to remove. Click Remove.
Click Apply.

**Quick Reference**

**Commands**

**CUI**
Manages the customized user interface elements in the product.

**RIBBON**
Opens the ribbon window.

**RIBBONCLOSE**
Closes the ribbon window.

**Ribbon Tabs**
Ribbon tabs control the display and order in which ribbon panels are displayed on the ribbon. You add ribbon tabs to a workspace to control which ribbon tabs are displayed on the ribbon.

Ribbon tabs do not contain any commands or controls like a ribbon panel does; instead, they manage the display of ribbon panels on the ribbon. Once a ribbon tab is created, you can then add references to any of the ribbon panels from the Panels node under the Ribbon node in the Customizations In `<file name>` pane to the ribbon tab. After references to ribbon panels are added to a ribbon tab, you can control the initial display order in which ribbon panels appear on a ribbon tab from the ribbon tab’s node in the Customizations In `<file name>` pane.

**NOTE** Newly created ribbon tabs are not automatically added to a workspace. To display a new ribbon tab on the ribbon, select the workspace in which you want the ribbon tab to be displayed with and then use the Workspace Contents pane to add it to the workspace. For information on adding a ribbon tab to a workspace, see To display ribbon tabs from the CUI Editor on page 301.

In the Workspace Contents pane, you add and remove ribbon tabs from the ribbon, which is controlled by the current workspace. Once a ribbon tab has been added to a workspace, you can control the order in which the tab is displayed on the ribbon by expanding the Ribbon Tabs node under the Workspace Contents pane.
From the Workspace Contents pane, you can control the default display of ribbon tabs and panels; this allows you to keep the associations of ribbon tabs and panels with a workspace, but turn it off. You can also control the tool palette group associated with a ribbon tab, and the collapse behavior, resize order, and orientation of a ribbon panel from the Workspace Contents pane.

The following table describes the properties for the Home - 2D ribbon tab as they appear in the Properties pane.

<table>
<thead>
<tr>
<th>Properties pane item</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display Text</td>
<td>Title of the tab; displayed when the ribbon tab is assigned to a workspace and the Ribbon palette is displayed.</td>
<td>Home</td>
</tr>
<tr>
<td>Contextual Display Type</td>
<td>Specifies whether the ribbon tab is displayed on its own tab or is merged with the ribbon tabs already displayed on the ribbon. The available options are Full or Merged.</td>
<td>Full</td>
</tr>
<tr>
<td>Default Display</td>
<td>Specifies if the ribbon tab is displayed the first time the CUIx file is loaded as a partial customization file. The available options are Do Not Add to Workspaces or Add to Workspaces.</td>
<td>Add to workspaces</td>
</tr>
<tr>
<td>Workspace Behavior</td>
<td>Specifies how the ribbon tab is merged or added to the ribbon when this CUIx file is loaded as a partial customization file. The available options are Add Tab Only, Merge Tab Only, or Merge or Add Tab.</td>
<td>Merge or add tab</td>
</tr>
<tr>
<td>KeyTip</td>
<td>Specifies the keytip character to access the ribbon tab on the ribbon from the keyboard.</td>
<td>H</td>
</tr>
<tr>
<td>Aliases</td>
<td>Specifies the aliases for the ribbon tab. Click the [ ] button to open the Aliases dialog box. Each alias in the CUIx file should be unique; it is used to reference the ribbon tab programmatically.</td>
<td>ID_TabHome</td>
</tr>
<tr>
<td>Element ID</td>
<td>Tag that uniquely identifies a panel.</td>
<td>ID_TabHome</td>
</tr>
</tbody>
</table>
Display Ribbon Tabs from a Partial CUIx File

When you load ribbon tabs from a partial CUIx file, you can use the Workspace Behavior property to control how ribbon tabs that might share the same alias in the main and partial CUIx files are handled. The Add Tab Only option displays each ribbon tab that is loaded with a workspace as its own tab. While Merge Tab Only displays the ribbon tabs from a partial CUIx file with those that have a matching alias in the main CUIx file. The Merge or Add Tab option merges the tab before a new tab is created on the ribbon.

To create a ribbon tab

1. Click Manage tab ➤ Customization panel ➤ User Interface.
2. In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to Ribbon to expand it.
3. Right-click Tabs and click New Tab.

A new ribbon tab (named New Tab) is placed at the bottom of the Tabs node.

4. Right-click New Tab. Click Rename. Enter a new name for the ribbon tab.
5. Select the new ribbon tab in the tree view, and update the Properties pane:
   ■ In the Display Text box, enter a text string that will appear on the ribbon tab.
   ■ In the Contextual Display Type box, specify how the ribbon tab should be displayed on the ribbon when used with a contextual ribbon tab state.
   ■ In the Default Display box, specify if the ribbon tab should be displayed by default when the CUIx file is loaded as a partial customization file.
In the Workspace Behavior box, specify if the ribbon tab is merged or added to the ribbon when the CUIx file is loaded as a partial file.

In the KeyTip box, enter a text string that can be used to access the ribbon tab from the keyboard.

In the Aliases box, enter an alias for the ribbon tab.

6 Click Apply.

To remove a ribbon tab

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to Ribbon to expand it.

3 Click the plus sign (+) next to Tabs to expand it.

4 Right-click the ribbon tab that you want to remove. Click Remove.

**WARNING** There is no way to undo the removal of a user interface element, so be careful when removing user interface elements. If you remove the wrong user interface element, the best thing to do is click Cancel to not save changes, but this will also undo any other changes that you might have made.

5 Click Apply.
To add a ribbon panel to a ribbon tab

1. Click Manage tab ➤ Customization panel ➤ User Interface.
2. In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to Ribbon to expand it.
3. Click the plus sign (+) next to Tabs to expand it.
4. Click the plus sign (+) next to the ribbon tab where you want to add a ribbon panel.
5. Click the plus sign (+) next to Panels to expand it.
6. Drag a ribbon panel from the Panels node to a ribbon tab. Use the visual indicator bar to specify the position of the ribbon panel on the ribbon tab.
7. Click Apply.

To remove a ribbon panel from a ribbon tab

1. Click Manage tab ➤ Customization panel ➤ User Interface.
2. In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to Ribbon to expand it.
3. Click the plus sign (+) next to Tabs to expand it.
4. Click the plus sign (+) next to the ribbon tab where you want to remove a ribbon panel.
5. Right-click the ribbon panel that you want to remove. Click Remove.
WARNING There is no way to undo the removal of a user interface element, so be careful when removing user interface elements. If you remove the wrong user interface element, the best thing to do is click Cancel to not save changes, but this will also undo any other changes that you might have made.

6 Click Apply.

To set the initial position of a ribbon panel on a ribbon tab

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to Ribbon to expand it.

3 Click the plus sign (+) next to Tabs to expand it.

4 Click the plus sign (+) next to the ribbon tab where you want to reposition a ribbon panel.

5 Select the ribbon panel that you want to reposition and drag it to a new location.

A visual indicator bar is displayed between the ribbon panels indicating the placement of the ribbon panel when you release the pointing device button.
6 Once the splitter bar is in the place where you want to insert the ribbon panel, release the pointing device button.

7 Click Apply.

To set the resize style of a ribbon panel on a ribbon tab

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to Ribbon to expand it.

3 Click the plus sign (+) next to Tabs to expand it.

4 Click the plus sign (+) next to the ribbon tab that contains the ribbon panel for which you want to adjust the resize style.

5 Select the ribbon panel that you want to change.

6 In the Properties pane, Resize Style, select an option (Collapse as Needed, Never Collapse, or Collapse Last).

7 Click Apply.

Quick Reference

Commands

CUI
Manages the customized user interface elements in the product.

RIBBON
Opens the ribbon window.

RIBBONCLOSE
Closes the ribbon window.

Ribbon Contextual Tab States

Ribbon contextual tab states are used to control the display of ribbon panels on the ribbon when certain commands are active or an object is selected.
You use the same ribbon tabs that you create to control the display of ribbon panels on the ribbon through a workspace, as those used for ribbon contextual tab states. Instead of using a workspace to control the display of a ribbon tab, you assign a ribbon tab to one of the predefined contextual states listed under the Contextual Tab States node in the Customizations In <file name> pane. Predefined contextual tab states range from selecting an object such as a table or opening a block in the Block Editor.

To assign a ribbon tab to a contextual tab state

1. Click Manage tab ➤ Customization panel ➤ User Interface.
2. In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to Ribbon to expand it.
3. Click the plus sign (+) next to Tabs to expand it.
4. Click the plus sign (+) next to Contextual Tab States to expand it.
5. Drag a ribbon tab from the Tabs node to a ribbon contextual tab state.
6. Click Apply.

To remove a ribbon tab from a contextual tab state

1. Click Manage tab ➤ Customization panel ➤ User Interface.
2. In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to Ribbon to expand it.
3. Click the plus sign (+) next to Contextual Tab States to expand it.
4. Click the plus sign (+) next to the contextual tab state that contains the ribbon tab you want to remove.
5 Right-click the ribbon tab under the contextual tab state and click Remove.

6 Click Apply.

To set the contextual display type a ribbon tab

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, in the Customizations In `<file name>` pane, click the plus sign (+) next to Ribbon to expand it.

3 Click the plus sign (+) next to Contextual Tab States to expand it.

4 Click the plus sign (+) next to the contextual tab state that contains the ribbon tab for which you want to change the contextual display type.

5 Select the ribbon tab you want to change.

6 In the Properties pane, Contextual Display Type, select Full or Merged.
7 Click Apply.

Quick Reference

Commands

CUI
Manages the customized user interface elements in the product.

RIBBON
Opens the ribbon window.

RIBBONCLOSE
Closes the ribbon window.

System Variables

RIBBONCONTEXTSELECT
Controls how ribbon contextual tabs are displayed when you single- or double-click an object.

RIBBONCONTEXTSELLIM
Limits the number of objects that can be changed at one time with the ribbon property controls or a contextual tab.

RIBBONSELECTMODE
Determines whether a pickfirst selection set remains selected after a ribbon contextual tab is invoked and the command is completed.
Toolbars

Toolbar customization can be as easy as placing or resizing a toolbar in the application window to gain drawing efficiency or space. You can also create and modify toolbars and flyout toolbars, add commands and controls, and reposition and remove commands and controls from a toolbar.

Create and Edit Toolbars

Some of the simplest toolbar customizations can make your daily drawing tasks more efficient. For example, you can consolidate frequently used commands and controls onto one toolbar, remove buttons that you never use, or change some simple toolbar properties.

You can also specify information to be displayed when the cursor passes over a button in the form of a tooltip.

You can add buttons or remove buttons you use infrequently, and rearrange buttons and toolbars. You can also create your own toolbars and flyout toolbars, and create or change the button image associated with a command. When creating a toolbar, you can create a toolbar from scratch, create a copy of an existing toolbar, or create a toolbar from an existing pull-down menu. Sub-menu items are not included when a toolbar is created from a pull-down menu.

NOTE When you create a toolbar, you should determine in which workspaces you want to display the toolbar. By default, a new toolbar is displayed in all workspaces.

The following table shows the properties of the Standard toolbar as they appear in the Properties pane.

<table>
<thead>
<tr>
<th>Properties for the Standard toolbar</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Properties pane item</strong></td>
</tr>
<tr>
<td>Name</td>
</tr>
<tr>
<td>Description</td>
</tr>
<tr>
<td>Default Display</td>
</tr>
</tbody>
</table>

190 | Chapter 4  User Interface Customization
### Properties for the Standard toolbar

<table>
<thead>
<tr>
<th>Properties pane item</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>tions are Do Not Add to Workspaces or Add to Workspaces.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Orientation</td>
<td>Specifies whether the toolbar is floating or docked (top, bottom, left, or right) the first time the CUIx file is loaded.</td>
<td>Top</td>
</tr>
<tr>
<td>Default X Location</td>
<td>Specifies the location from the left edge of the screen when the toolbar appears when it is floating, or the location when it is docked. If docked, a value of 0 indicates the left most location in a docked area.</td>
<td>0</td>
</tr>
<tr>
<td>Default Y Location</td>
<td>Specifies the location from the top edge of the screen when the toolbar appears when it is floating, or the location when it is docked. If docked, a value of 0 indicates the top most location in a docked area.</td>
<td>0</td>
</tr>
<tr>
<td>Rows</td>
<td>Specifies the number of rows the items on the toolbar are displayed in when the toolbar is floating.</td>
<td>1</td>
</tr>
<tr>
<td>Aliases</td>
<td>Specifies the aliases for the toolbar. Click the [ ] button to open the Aliases dialog box. Each alias in the CUIx file should be unique and it is used to reference the toolbar programmatically.</td>
<td>TB_STANDARD, Standard</td>
</tr>
<tr>
<td>Element ID</td>
<td>Tag that uniquely identifies a toolbar.</td>
<td>ID_TbStandard</td>
</tr>
</tbody>
</table>

**NOTE** The properties On By Default, Orientation, Default X Location, Default Y Location, and Rows are used only the first time the CUIx file is loaded and when no default workspace is set. After a toolbar is loaded the first time, a workspace is used to control the Appearance properties of a toolbar. See the procedure *To change the properties of a toolbar* on page 307 for more information.

When you create a new toolbar, the first task you need to do is to provide a name for it. A new toolbar has no commands or controls assigned to it. If a toolbar has no commands or controls on it, it is ignored by the program until you add at least one command or control to it. You add commands and controls to a toolbar by dragging a command or control from an existing toolbar or the Command List pane and dropping it onto a toolbar. Once a command or control has been added to a toolbar, you can change the text
that is displayed in the tooltip when the cursor hovers over top of the button by changing the Name property that is displayed in the Properties pane.

**Customize Toolbars with the Toolbar Preview Pane**

You can customize a toolbar using the tree view under the Customizations In `<file name>` pane or the Toolbar Preview pane. The Toolbar Preview pane allows you to add and remove commands or controls visually in real-time instead of just using the tree view. You can also interactively drag a command or control in the preview pane to reposition it.

**Customize Toolbars from the Application Window**

The program allows you to customize toolbars that are displayed in the application when the Customize User Interface (CUI) Editor is open. You drag commands from the Command List pane and drop them directly onto a visible toolbar that is docked or floating in the application window. You can also remove, reposition, or copy commands on a visible toolbar while the CUI Editor is open.

**Create Ribbon Panels from Toolbars**

New ribbon panels can be created from a toolbar by dragging existing toolbars from the Toolbars node under the Customizations In `<file name>` pane to the Panels node under Ribbon in the Customizations In `<file name>` pane. When the toolbar is dropped, you are prompted to convert a copy of the toolbar to a ribbon panel. See Ribbon Panels on page 149 for more information about customizing ribbon panels.

**To display a toolbar**

- Do one of the following:
  - To display toolbars from the user interface on page 295
  - To display toolbars using the CUI Editor on page 306

**To create a toolbar**

1. Click Manage tab ➤ Customization panel ➤ User Interface.
2. In the Customize User Interface Editor, Customize tab, in the Customizations In `<file name>` pane, right-click Toolbars. Click New Toolbar.
A new toolbar (named Toolbar1) is placed at the bottom of the Toolbars tree.

3 Do one of the following:
   - Enter a new name over the default name Toolbar1.
   - Right-click Toolbar1. Click Rename. Enter a new toolbar name.
   - Click Toolbar1, wait, and click again over the toolbar’s name again to edit its name in-place.

4 Select the new toolbar in the tree view, and update the Properties pane:
   - In the Description box, enter a description for the toolbar.
   - In the Default Display box, specify if the toolbar should be displayed by default when the CUIx file is loaded as a partial customization file.
   - In the Orientation box, specify the orientation of the toolbar.
   - In the Default X Location box, enter a number.
   - In the Default Y Location box, enter a number.
   - In the Rows box, enter the number of rows for an undocked toolbar.
   - In the Aliases box, enter an alias for the toolbar.
5. In the Command List pane, drag the command you want to add to a location just below the name of the toolbar in the Customizations In <file name> pane.

6. Click Apply.

To create a toolbar from a pull-down menu

1. Click Manage tab ➤ Customization panel ➤ User Interface.

2. In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to the Menus tree node to expand it.

3. Drag the menu that you want to create a toolbar from and drop it onto the Toolbars node.
Update the workspace as desired to update the display and position for the new toolbar.

**To add a command to a toolbar in the Customizations In pane**

1. Click Manage tab ➤ Customization panel ➤ User Interface.
2. In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to the Toolbars tree node to expand it.
3. In the Command List pane, drag the command to the toolbar you want to add it to in the Customizations In <file name> pane.
4. Click Apply.

**To add a command to a toolbar in the Toolbar Preview pane**

1. Click Manage tab ➤ Customization panel ➤ User Interface.
2. In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to the Toolbars tree node to expand it.
3 Select the toolbar you want to add a command to.

4 In the Command List pane, drag the command you want to add to the selected toolbar and drop it on the toolbar's preview in the Toolbar Preview pane.

You can control where the command is placed by releasing the mouse button when the black vertical splitter bar is displayed.

5 Click Apply.

**To add a command to a toolbar outside the CUI Editor**

1 Display the toolbar you want to add a command to by right-clicking over a toolbar button. Click the name of the toolbar.

2 Right-click over any toolbar button. Click Customize.

3 In the Customize User Interface Editor, Customize tab, Command List pane, drag the command you want to add and drop it onto the toolbar.
You can control the location of the command you are adding by using the visual or horizontal indicator bar.

4 Click Apply.

To reposition a command or control on a toolbar in the Customizations In pane

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to the Toolbars tree node to expand it.

3 Click the plus sign (+) next to the toolbar that contains the command or control you want to reposition to expand it.

4 Drag the name of the command or control you want to reposition to the new location in the list of tools.
While dragging the command or control, use the visual indicator bar to specify the new position of the command or control. When the left arrow appears, the command or control is moved to the front of the toolbar.

5 Click Apply.

To reposition a command or control on a toolbar in the Toolbar Preview pane

1 Click Manage tab ➤ Customization panel ➤ User Interface.
2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to the Toolbars tree node to expand it.
3 Select the toolbar that contains the command or control you want to reposition.
4 In the Toolbar Preview, drag the command or control that you want to reposition.

While dragging the command or control, use the visual indicator bar to specify the new position of the command or control.

5 Click Apply.

To reposition a command on a toolbar outside the CUI Editor

1 Display the toolbar you want to reposition a command on by right-clicking over a toolbar button. Click the name of the toolbar.
2 Right-click over any toolbar button. Click Customize.
The Customize User Interface (CUI) Editor is displayed.

3 Drag the command on the toolbar that you want to reposition.

While dragging the command, use the visual indicator bar to specify the new position of the command.

4 Click Apply.

To remove a command or control from a toolbar in the Customizations In pane

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, in the Customizations In `<file name>` pane, click the plus sign (+) next to the Toolbars tree node to expand it.

3 Click the plus sign (+) next to a toolbar that contains the command or control you want to remove.

4 Right-click the name of the command or control you want to remove. Click Remove.

5 Click Apply.
To remove a command or control from a toolbar in the Toolbar Preview pane

1. Click Manage tab ➤ Customization panel ➤ User Interface.
2. In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to the Toolbars tree node to expand it.
3. Select the toolbar that contains the command or control you want to reposition.
4. In the Toolbar Preview pane, drag the command or control that you want to remove and drop it outside of the preview.
5. Click Apply.

To remove a command from a toolbar outside the CUI Editor

1. Display the toolbar from which you want to remove a command by right-clicking over a toolbar button. Click the name of the toolbar.
2. Right-click over any toolbar button. Click Customize. The Customize User Interface (CUI) Editor is displayed.
3. Drag the command you want to remove from the toolbar and drop it over the drawing window.
4. Click OK to confirm the deletion of the command from the toolbar.
In the Customize User Interface (CUI) Editor, click Apply.

To change properties of a toolbar

1. Click Manage tab ➤ Customization panel ➤ User Interface.
2. In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to the Toolbars tree node to expand it.

   **NOTE** Making changes to a toolbar's properties here only affect the initial appearance of the toolbar after the CUIx file has been loaded. To control the appearance of a toolbar, it is best to use a workspace.

3. Select the toolbar whose properties you want to change.
4. In the Properties pane, make your changes.
5. Click Apply.

To change the tooltip of a command

1. Click Manage tab ➤ Customization panel ➤ User Interface.
2. In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to the Toolbars tree node to expand it.

3. Select the toolbar whose tooltip text you want to change.
4. In the Properties pane, Display section, make the desired change to the Name property (not the Command Name or Command Display Name properties), and the Description and Extended Help File properties.
5. Click Apply.
Quick Reference

Commands

CUI
Manages the customized user interface elements in the product.

QUICKCUI
Displays the Customize User Interface Editor in a collapsed state.

RIBBON
Opens the ribbon window.

RIBBONCLOSE
Closes the ribbon window.

System Variables

TOOLTIPS
Controls the display of tooltips on the ribbon, toolbars, and other user interface elements.

Add Flyouts to a Toolbar

You can use flyouts to group related commands together on a toolbar.

A flyout is a set of commands nested under a single button on a toolbar. Flyout buttons have a black triangle in the lower-right corner. To create a flyout, you can start from scratch, or drag an existing toolbar or drag pull-down menu onto a toolbar. When a pull-down menu is dragged onto a toolbar, a new toolbar is created and a flyout is created in the position that the pull-down menu was dropped onto the toolbar.

The following table shows the properties for the Zoom flyout as they appear in the Properties pane.

<table>
<thead>
<tr>
<th>Properties for the Zoom flyout on the Standard toolbar</th>
</tr>
</thead>
<tbody>
<tr>
<td>Properties pane item</td>
</tr>
<tr>
<td>Name</td>
</tr>
</tbody>
</table>

202 | Chapter 4   User Interface Customization
### Properties for the Zoom flyout on the Standard toolbar

<table>
<thead>
<tr>
<th>Properties pane item</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>Text used to describe the element, does not appear in the user interface.</td>
<td></td>
</tr>
<tr>
<td>Source Toolbar</td>
<td>A read-only value used to specify which toolbar is being referenced to create the flyout.</td>
<td>TB_ZOOM</td>
</tr>
<tr>
<td>Use Own Button</td>
<td>Controls whether the last used toolbar button is set as the current button or not. The possible values are Yes or No.</td>
<td>No</td>
</tr>
<tr>
<td>Small Image</td>
<td>ID string of the small-image resource (16 × 16 bitmap). The string must include alphanumeric characters with no punctuation other than a hyphen (−) or an underscore (_). It can also be a user-defined bitmap. Click the [ ] button to open the Select Image File dialog box.</td>
<td>RCDATA_16_ZOOM</td>
</tr>
<tr>
<td>Large Image</td>
<td>ID string of the large-image resource (32 × 32 bitmap). If the specified bitmap is not 32 × 32, the program scales it to that size. The string must include alphanumeric characters with no punctuation other than a hyphen (−) or an underscore (_). It can also be a user-defined bitmap. Click the [ ] button to open the Select Image File dialog box.</td>
<td>RCDATA_16_ZOOM</td>
</tr>
</tbody>
</table>

**WARNING** Do not change the aliases for a toolbar that is being used as a flyout; otherwise the link between the toolbar and flyout will become broken.

### To create a flyout toolbar from scratch

1. Click Manage tab ➤ Customization panel ➤ User Interface.

2. In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to the Toolbars tree node to expand it.

3. Right-click the toolbar to which you want to add a flyout toolbar. Click New Flyout.
A new flyout toolbar (named Toolbar1) is placed below the toolbar you selected.

4 Right-click Toolbar1. Click Rename. Enter a new toolbar name.

NOTE You can click, wait, and click again over a toolbar name to edit its name in-place in the Customizations In <file name> pane.

NOTE Just renaming the toolbar won’t change the name of the flyout. You must select and rename the flyout independently if you want them to both have the same name.

5 In the Command List pane, drag the command you want to add to the toolbar flyout in the Customizations In <file name> pane.
6 Click Apply.

To create a flyout toolbar from another toolbar

1 Click Manage tab ➤ Customization panel ➤ User Interface.
2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to the Toolbars tree node to expand it.
3 Click the plus sign (+) next to the toolbar to which you want to add a flyout toolbar.
4 Locate the toolbar you want to use as a flyout. Drag the toolbar to a location in the expanded toolbar.
5 Click Apply.

To create a flyout toolbar from a pull-down menu

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to the Toolbars tree node to expand it.

3 Click the plus sign (+) next to the toolbar to which you want to add a flyout toolbar.

4 Click the plus sign (+) next to the Menus tree node to expand it.

5 Drag the menu that you want to create a flyout from and drop it onto the node of the toolbar where you want to place the flyout.

If the menu is dropped on a toolbar, a new flyout and toolbar are created.
Reposition the new flyout on the toolbar.

Quick Reference

Commands

CUI

Manages the customized user interface elements in the product.

Add, Remove or Switch Toolbar Controls

Toolbar controls are drop-down lists of items that can affect the objects in a drawing or the way the program behaves from a toolbar. For example, the Layers toolbar contains controls for defining layer settings. In the Customize User Interface (CUI) Editor, you can add, remove, and relocate controls within toolbars.

The following table lists the toolbar controls found in the Customize User Interface (CUI) Editor and their definitions. The control elements in the left column of the table are not always the text that is displayed as a tooltip in the program (for example, Undo Skinny Button is displayed as Undo in the program's tooltip). Refer to this table when you want to change a control in a toolbar.

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Autodesk Seek Control</td>
<td>Allows for entering a text string to locate content on the Autodesk Seek web site.</td>
</tr>
<tr>
<td>Dim Style Control</td>
<td>Displays and sets the current dimension style.</td>
</tr>
<tr>
<td>Find Text Control</td>
<td>Allows for searching on a text string contained in the current drawing.</td>
</tr>
<tr>
<td>Layer Control</td>
<td>Displays the current layer and allows you to set a layer current.</td>
</tr>
<tr>
<td>Line Type Control</td>
<td>Displays and sets the current linetype.</td>
</tr>
<tr>
<td>Line Weight Control</td>
<td>Displays and sets the current line weight.</td>
</tr>
</tbody>
</table>
### Control elements for toolbars

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Multileader Style Control</td>
<td>Displays and sets the current multileader style.</td>
</tr>
<tr>
<td>Named View Control</td>
<td>Displays and sets the current named view.</td>
</tr>
<tr>
<td>OPT Color Control</td>
<td>Displays and sets the current color.</td>
</tr>
<tr>
<td>Plot Style Control</td>
<td>Displays and sets the current plot style.</td>
</tr>
<tr>
<td>Redo Skinny Button Control</td>
<td>Allows you to reverse the previous undo or undoes.</td>
</tr>
<tr>
<td>Reference Block Name Control</td>
<td>Displays the name of the xref being edited.</td>
</tr>
<tr>
<td>Table Style Control</td>
<td>Displays and sets the current table style.</td>
</tr>
<tr>
<td>Text Style Control</td>
<td>Displays and sets the current text style.</td>
</tr>
<tr>
<td>UCS Control</td>
<td>Displays the current UCS and allows you to restore a saved UCS.</td>
</tr>
<tr>
<td>Undo Skinny Button Control</td>
<td>Allows you to undo the previous action or actions.</td>
</tr>
<tr>
<td>View Control</td>
<td>Displays and sets the current standard 3D view for a viewport.</td>
</tr>
<tr>
<td>Viewport Scale Control</td>
<td>Displays and sets the current scale for a floating viewport.</td>
</tr>
<tr>
<td>Workspace Control</td>
<td>Displays the current workspace and allows you to set a workspace current.</td>
</tr>
</tbody>
</table>

### To add a control to a toolbar in the Customizations In pane

1. Click Manage tab ➤ Customization panel ➤ User Interface.
2 In the Customize User Interface Editor, Customize tab, Customizations In <file name> pane, click the plus sign (+) next to the Toolbars tree node to expand it.

3 Click the plus sign (+) next to the toolbar to which you want to add a control.

4 In the Command List pane, Categories list, click Toolbar Control Elements.

![Command List pane](image)

The Command List pane displays the list of toolbar control elements only.

5 In the Command list, drag the control to the Customizations In <file name> pane to the position where you want to add it in the toolbar.

![Command List pane with control added](image)

6 Click Apply.

**To add a control to a toolbar in the Toolbar Preview pane**

1 Click Manage tab ➤ Customization panel ➤ User Interface.
2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to the Toolbars tree node to expand it.

3 Select the toolbar to which you want to add a control.

4 In the Command List pane, Categories list, click Control Elements.

The Command List pane displays the list of toolbar control elements only.

5 In the Command List pane, drag the control you want to add to the selected toolbar and drop it on the toolbar's preview in the Toolbar Preview pane.

You can control where you place the command by releasing the mouse button when the vertical splitter bar is displayed in the location you want.

6 Click Apply.
To switch a control in a toolbar

1. Click Manage tab ➤ Customization panel ➤ User Interface.

2. In the Customize User Interface Editor, Customize tab, Customizations In <file name> pane, click the plus sign (+) next to the Toolbars tree node to expand it.

3. Click the plus sign (+) next to the toolbar to which you want to add a control.

4. Click the control element under the toolbar.

5. In the Properties pane, Control box, click the down arrow to display a list of toolbar controls.

6. Click a toolbar control to replace the original control with the one you selected.

7. Click Apply.
Quick Reference

Commands

CUI

Manages the customized user interface elements in the product.

Pull-down and Shortcut Menus

Pull-down menus are displayed as a list under a menu bar. Shortcut menus (also called context menus) are displayed at or near the crosshairs or cursor when you right-click in the drawing window, text window, command window, in toolbar areas, or the ribbon.

Overview of Pull-Down and Shortcut Menus

A pull-down menu can contain up to 999 commands. A shortcut menu can contain up to 499 commands. The command limit includes all menus in a hierarchy. If commands in the menu file exceed these limits (which is unlikely), the program ignores the extra commands. If a pull-down or shortcut menu is longer than the available display space, it is truncated to fit. When a pull-down or shortcut menu is truncated, two arrows are added to the menu; one is added at the top and another to the bottom. With the arrows, you can scroll the list of menu items up or down. The following table shows the properties for the File menu as they appear in the Properties pane. The properties for a pull-down menu and shortcut menu are identical.

<table>
<thead>
<tr>
<th>Properties for the File menu</th>
</tr>
</thead>
<tbody>
<tr>
<td>Properties pane item</td>
</tr>
<tr>
<td>Name</td>
</tr>
<tr>
<td>Description</td>
</tr>
<tr>
<td>Aliases</td>
</tr>
<tr>
<td>Element ID</td>
</tr>
</tbody>
</table>

212 | Chapter 4  User Interface Customization
NOTE When you create a pull-down or shortcut menu, you must also add at least one command to the menu. Otherwise, the menu will not be displayed on the menu bar.

Quick Reference

Commands
CUI
Manages the customized user interface elements in the product.

System Variables
MENUBAR

Create a Pull-Down Menu

You can create a pull-down menu, add submenus and commands to it on the Customize tab of the Customize User Interface (CUI) Editor.

You can create and modify standard pull-down menus to display and organize the commands to best match the way you work. Commands are added to a pull-down menu from the Command List pane. Once commands are added to a pull-down menu, you can change the caption displayed for the command on the menu, reposition commands, and organize commands using separators. Along with separators, you can also group commands using submenus. For more information on submenus, see Create Submenus on page 227.

As you modify the positioning of commands on menus, the online Help system is automatically updated to reflect the change through the Dynamic Help feature. For more information about how Dynamic Help affects customization, see How Customization Has Changed on page 48.

NOTE When you create a menu, you should determine in which workspaces you want to display the menu in. By default, a new menu is displayed in all workspaces.

Pull-Down Menu Aliases

Pull-down menus should have one alias in the range of POP1 through POP499. Menus with an alias of POP1 through POP16 are loaded by default when a menu loads. All other menus must be added to a workspace to be displayed.
To create a pull-down menu

1. Click Manage tab ➤ Customization panel ➤ User Interface.

2. In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, right-click Menus. Click New Menu.

   ![New Menu in Customize User Interface Editor](image)

   A new menu (named Menu1) is placed at the bottom of the Menus tree.

3. Do one of the following:
   - Enter a new name over the default name Menu1.
   - Right-click Menu1. Click Rename. Enter a new menu name.
   - Click Menu1, wait, and click again over the menu’s name again to edit its name in-place.

4. Select the new menu in the tree view, and update the Properties pane as follows:
   - In the Description box, enter a description for the menu.
   - In the Aliases box, an alias is automatically assigned to the new menu, based on the number of menus already loaded. For example, if the alias assignment is POP12, eleven menus are already loaded. View or edit the alias.
   - (Optional) If the name change is based upon a DIESEL expression, the DIESEL expression should be included in the Name box.

   ![Properties pane in Customize User Interface Editor](image)
5 In the Command List pane, drag the command to a location just below the menu in the Customizations In <file name> pane.

![](image)

**NOTE** You can change the name of a command after it has been added to a menu. This allows you to define how the user can access the menu item using keyboard navigation with the Alt key. To do this, select the menu item under the Menus node and then change the Name property in the Properties pane.

6 Click Apply.

**To add a command to a pull-down menu**

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the menu to which you want to add a command.

3 In the Command List pane, drag the command you want to add to a location just below the menu in the Customizations In <file name> pane.

![](image)
NOTE You can change the name of a command after it has been added to a menu. This allows you to define how the user can access the menu item using keyboard navigation with the Alt key. To do this, select the menu item under the Menus node and then change the Name property in the Properties pane.

4 Click Apply.
For information about creating a command, see Create, Edit, and Reuse Commands on page 94.

To change the caption of a menu item on a pull-down menu

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to the Menus node to expand it.

3 Click the plus sign (+) next to the pull-down menu that has the command whose text you want to change.

4 Select the command whose text you want to change.

5 In the Properties pane, in the Display section, make the desired change to the Name property (not the Command Name or Command Display Name properties).

6 Click Apply.
**Quick Reference**

**Commands**

CUI

Manages the customized user interface elements in the product.

**System Variables**

MENUBAR

---

**Create a Shortcut Menu**

Shortcut menus are displayed at or near the location of your cursor when you right-click on the pointing device. The shortcut menu and the options it provides depend on the location of the cursor and other conditions, such as whether an object is selected or a command is in progress.

*Context-sensitive* shortcut menus display menu options that are relative to the current command or the selected object when you right-click.

**Shortcut Menu Aliases**

Shortcut menus are referenced by their aliases and are used in specific situations. In the Customize User Interface (CUI) Editor, the alias names must follow the proper naming conventions. For example, the shortcut menu named “Default Menu” displays the following information in the Aliases section of the Properties pane:

POP501, CMDEFAULT

*CMDEFAULT* is one of the reserved aliases that the program looks for in specific situations. In this case, the shortcut menu assigned the alias *CMDEFAULT* is displayed if no objects are selected and no command is in progress when you right-click over the drawing window.

Aliases for context-sensitive shortcut menus must be numbered between POP500 and POP999, with the exception of the Object Snap menu which uses an alias of POP0. The following aliases are reserved for use by the program:

<table>
<thead>
<tr>
<th>Program aliases for shortcut menus</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alias</td>
</tr>
<tr>
<td>GRIPS</td>
</tr>
</tbody>
</table>
Program aliases for shortcut menus

<table>
<thead>
<tr>
<th>Alias</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CMDEFAULT</td>
<td>Defines the Default mode shortcut menu. (Right-click the drawing area while no command is active and no objects are selected.)</td>
</tr>
<tr>
<td>CMEDIT</td>
<td>Defines the Edit mode shortcut menu. (Right-click the drawing area while one or more objects are selected, no grips are selected, and no command is active.)</td>
</tr>
<tr>
<td>CMCOMMAND</td>
<td>Defines the Command mode menu. (Right-click the drawing area while a command is active.) In addition to the content of the CMCOMMAND menu, the command’s options (keywords within the square brackets) are inserted into this menu.</td>
</tr>
<tr>
<td>SNAP</td>
<td>Defines the Object Snap menu. (Shift-right-click the drawing area.)</td>
</tr>
</tbody>
</table>

Object Specific Shortcut Menus

The CMEDIT and CMCOMMAND shortcut menus can be made context-sensitive. In addition to the content of the CMEDIT menu, the appropriate object menu (if it exists) is inserted into this menu when one or more of a specific object type are selected. Object menus use either of the following naming conventions:

- OBJECT_objectname
- OBJECTS_objectname

If a single object is selected, the OBJECT_objectname menu is used, and if more than one of the same object type is selected, the OBJECTS_objectname menu is used. If no OBJECT_objectname is available, the program uses the OBJECTS_objectname menu (if it exists).

The object name used for the alias is the drawing interchange format (DXF™) name of the object in most cases except for inserted objects. The following table shows the object names that are specific to inserted objects (blocks, dynamic blocks, and xrefs).

Object names specific to insert objects

<table>
<thead>
<tr>
<th>Object Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ATTBLOCKREF</td>
<td>Block reference with attributes</td>
</tr>
</tbody>
</table>
Object names specific to insert objects

<table>
<thead>
<tr>
<th>Object Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ATTDYNBLOCKREF</td>
<td>Dynamic block reference with attributes</td>
</tr>
<tr>
<td>BLOCKREF</td>
<td>Block reference without attributes</td>
</tr>
<tr>
<td>DYNBLOCKREF</td>
<td>Dynamic block reference without attributes</td>
</tr>
<tr>
<td>XREF</td>
<td>External reference (xref)</td>
</tr>
</tbody>
</table>

For example, to support an object-specific shortcut menu for one or more selected block references, you would create or modify a shortcut menu and change its properties to those in the following table. The important property to change is Aliases, which would need to be modified to include the alias OBJECTS_BLOCKREF.

Properties for the Block Reference Objects shortcut menu

<table>
<thead>
<tr>
<th>Properties pane item</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>String that is only used in the CUI Editor and is not displayed in the user interface.</td>
<td>Block Objects Menu</td>
</tr>
<tr>
<td>Description</td>
<td>Text used to describe the element; does not appear in the user interface.</td>
<td>Shortcut menu for block objects</td>
</tr>
<tr>
<td>Aliases</td>
<td>Specifies the aliases for the shortcut menu. Click the [ ] button to open the Aliases dialog box. Each alias in the CUIx file should be unique and it is used to reference the shortcut menu programmatically.</td>
<td>POP512,OBJECTS_BLOCKREF</td>
</tr>
<tr>
<td>Element ID</td>
<td>Tag that uniquely identifies a shortcut menu.</td>
<td>PM_0021</td>
</tr>
</tbody>
</table>

Command Specific Shortcut Menus

Like the CMEDIT menu, the CMCOMMAND menu can contain context-sensitive commands. Menus named COMMAND_commandname control which commands are appended to the CMCOMMAND menu when a command is active. The text of commandname can be any valid AutoCAD LT command, including custom-defined or third-party commands.
In many cases, you can enter a hyphen before a command to suppress the display of a dialog box and display prompts for the command instead. To create a context-sensitive menu for a command that displays prompts instead of a dialog box (such as \texttt{-INSERT}), you need to name the menu \texttt{COMMAND_-INSERT}.

To create a shortcut menu
Do one of the following:

- **To create a standard shortcut menu**

  a. Click Manage tab ➤ Customization panel ➤ User Interface.

  b. In the Customize User Interface Editor, Customize tab, in the Customizations In \texttt{<file name>} pane, right-click Shortcut Menus. Click New Shortcut Menu.

  The new shortcut menu (named ShortcutMenu1) is placed at the bottom of the Menus tree.

  c. Do one of the following:

     - Enter a new name over the default name ShortcutMenu1.

     - Right-click ShortcutMenu1. Click Rename. Enter a new shortcut menu name.

     - Click ShortcutMenu1, wait, and click again over the shortcut menu’s name to edit its name in-place.

  d. In the Properties pane, Description box, optionally enter a description for the shortcut menu.

  e. In the Aliases box, click the [ ] button.

  f. In the Aliases dialog box, press Enter so you are on a new line. Enter additional aliases for the menu, and after each one, press Enter. An alias is automatically assigned, and defaults to the next available POP.
number, based on the number of shortcut menus already loaded in the program.

In the Command List pane, drag the command that you want to add to the location just below the shortcut menu in the Customizations pane.

Continue adding commands until the new shortcut menu is complete. Click Apply.

To create a command shortcut menu
In order for the commands on the shortcut menu to appear when a command is active, make sure to use the alias COMMAND_commandname. For example, if you want the commands on the shortcut menu to appear when using the LINE command use the alias COMMAND_LINE. The commands from the shortcut menu will appear at the bottom of the shortcut menu with the alias CMCOMMAND when it is displayed.

Click Manage tab ➤ Customization panel ➤ User Interface.
b In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, right-click Shortcut Menus. Click New Shortcut Menu.

The new shortcut menu (named ShortcutMenu1) is placed at the bottom of the Menus tree.

c Do one of the following:

■ Enter a new name over the default name ShortcutMenu1.

■ Right-click ShortcutMenu1. Click Rename. Enter a new shortcut menu name.

■ Click ShortcutMenu1, wait, and click again over the shortcut menu's name to edit its name in-place.

d In the Properties pane, Description box, optionally enter a description for the shortcut menu.

e In the Aliases box, click the [ ] button.

f In the Aliases dialog box, press Enter so you are on a new line. Enter additional aliases for the menu, and after each one, press Enter. An alias is automatically assigned, and defaults to the next available POP number, based on the number of shortcut menus already loaded in the program.

<table>
<thead>
<tr>
<th>General</th>
<th>LineCommand Menu</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td></td>
</tr>
<tr>
<td>Description</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Advanced</th>
</tr>
</thead>
<tbody>
<tr>
<td>Aliases</td>
</tr>
<tr>
<td>POP53_COMMAND_LINE</td>
</tr>
<tr>
<td>Element ID</td>
</tr>
<tr>
<td>PMU_0003</td>
</tr>
</tbody>
</table>

g In the Command List pane, drag the command that you want to add to the location just below the shortcut menu in the Customizations In <file name> pane.
Continue adding commands until the new shortcut menu is complete.

Click Apply.

To create an object shortcut menu

In order for the commands on the shortcut menu to appear when an object or objects of the same type are selected, make sure to use the alias OBJECT_objecttype or OBJECTS_objecttype. For example, if you want the commands on the shortcut menu to appear when a LINE object is selected in the drawing, use the alias OBJECT_LINE. The commands from the shortcut menu will appear near the top of the shortcut menu with the alias CMEDIT when it is displayed.

Click Manage tab ➤ Customization panel ➤ User Interface.

In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, right-click Shortcut Menus. Click New Shortcut Menu.
The new shortcut menu (named ShortcutMenu1) is placed at the bottom of the Menus tree.

c  Do one of the following:
   ■ Enter a new name over the default name ShortcutMenu1.
   ■ Right-click ShortcutMenu1. Click Rename. Enter a new shortcut menu name.
   ■ Click ShortcutMenu1, wait, and click again over the shortcut menu’s name to edit its name in-place.

d  In the Properties pane, Description box, optionally enter a description for the shortcut menu.

e  In the Aliases box, click the [ ] button.

f  In the Aliases dialog box, press Enter so you are on a new line. Enter additional aliases for the menu, and after each one, press Enter. An alias is automatically assigned, and defaults to the next available POP number, based on the number of shortcut menus already loaded in the program.

NOTE If you create a shortcut menu with the alias OBJECTS_objecttype, the commands assigned to the shortcut menu will be displayed when one or more objects are selected before right-clicking over the drawing area.

g  In the Command List pane, drag the command that you want to add to the location just below the shortcut menu in the Customizations in <file name> pane.
To add a command to a shortcut menu

1. Click Manage tab ➤ Customization panel ➤ User Interface.
2. In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the menu to which you want to add a command.
3. In the Command List pane, drag the command you want to add to a location just below the menu in the Customizations In <file name> pane.

h Continue adding commands until the new shortcut menu is complete.

i Click Apply.
NOTE You can change the name of a command after it has been added to a menu. This allows you to define how the user can access the menu item using keyboard navigation with the Alt key. To do this, select the menu item under the Shortcut Menus node and then change the Name property in the Properties pane.

4 Click Apply.
For information about creating a command, see Create, Edit, and Reuse Commands on page 94.

To change the caption of a menu item on a shortcut menu

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to the Shortcut Menus node to expand it.

3 Click the plus sign (+) next to the shortcut menu that has the command whose text you want to change.

4 Select the command whose text you want to change.

5 In the Properties pane, in the Display section, make the desired change to the Name property (not the Command Name or Command Display Name properties).

6 Click Apply.
Quick Reference

Commands

CUI

Manages the customized user interface elements in the product.

System Variables

SHORTCUTMENU

Controls whether Default, Edit, and Command mode shortcut menus are available in the drawing area.

Create Submenus

You can create submenus to organize and group similar commands together. Submenus are created in much the same way that you create a menu.

The following table describes the non-alphanumeric characters that can be used to control the display and behavior of the caption for a submenu. Non-alphanumeric characters not listed are reserved for future use as special menu characters.

<table>
<thead>
<tr>
<th>Character</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>$( ( ) )</td>
<td>Enables the pull-down or shortcut command label to evaluate a DIESEL string macro if $( are the first characters.</td>
<td>$(if,$(and,$(getvar,CleanScreenState),1),!.)Clean S&amp;creen</td>
</tr>
<tr>
<td>~</td>
<td>Makes a command unavailable.</td>
<td>~Plot Style</td>
</tr>
<tr>
<td>!.</td>
<td>Marks a command with a check mark or if an icon is displayed for the menu item it appears sunken.</td>
<td>!.Layer...</td>
</tr>
<tr>
<td>&amp;</td>
<td>Placed directly before a character, specifies the character as the menu access key in a pull-down or shortcut menu label.</td>
<td>&amp;Sample displays Sample (with the letter a underlined).</td>
</tr>
</tbody>
</table>
Special characters for submenus

<table>
<thead>
<tr>
<th>Character</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>\t</td>
<td>Pushes all label text entered after these characters to the right side of the menu.</td>
<td>Help \t F1 displays Help on the left side of the pull-down menu and F1 on the right side.</td>
</tr>
</tbody>
</table>

To create a submenu

1. Click Manage tab ➤ Customization panel ➤ User Interface.

2. In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to Menus. Select the menu you want to add a submenu to.

3. Right-click the menu. Click New Sub-menu. The new submenu (named Menu1) is placed at the bottom of the Menu you selected to add the submenu to.

4. Do one of the following:
   - Enter a new name over the default name Menu1.
   - Right-click Menu1. Click Rename. Enter a new submenu name.
   - Click Menu1, wait, and click again over the menu's name again to edit its name in-place.

5. In the Properties pane, do the following:
   - In the Description box, optionally enter a description for the submenu.
6 In the Command List pane, drag the command you want to add to a location just below the name of the submenu in the Customizations In <file name> pane.

7 Continue adding commands until the new submenu is complete.

8 Click Apply.

Quick Reference

Commands
CUI
Manages the customized user interface elements in the product.

Reference Pull-Down or Shortcut Menus

Using a method similar to that used to activate submenus, you can activate or deactivate another pull-down or shortcut menu. This is called menu referencing.

Pull-down or shortcut menus can be referenced using absolute referencing. Absolute referencing uses the absolute position of a menu item in the menu hierarchy.
Absolute Referencing of Pull-Down and Shortcut Menu Items

In addition to referencing a menu item, you can activate or deactivate a menu item with the $Pn=xxx syntax. This is the format:

$Pn.i=xxx

The $ loads a menu section; $Pn specifies the active menu section (0 through 16 are valid values); $i specifies the menu item number; and $xxx (if present), specifies a string of grayed out or marked characters.

Using the $Pn=xxx syntax, the following example adds a check mark to item 1 in the POP7 section.

$P7.1=!.

Menu item numbering is consecutive regardless of the hierarchy of the menu. To make it easy for an item to address itself regardless of its location in the menu hierarchy, use these forms:

$P@.@=xxx References the current or most recently chosen command.

$P@.n=xxx References item n in the current or most recently chosen menu.

Quick Reference

Commands

CUI

Manages the customized user interface elements in the product.

Swap and Insert Pull-Down Menus

Using the Customize User Interface (CUI) Editor, you can use workspaces to control the swapping of pull-down menus. However, you can also swap one pull-down menu programmatically for another (for example, when a user loads an application that requires an additional menu).

Swap Pull-Down Menus

Because the program has cascading pull-down menus, there is little need to swap menus. Also, swapping menus can detract from the consistency of the user interface. However, using $ commands, you can swap pull-down menus and submenus. An alternative to menu swapping involves relative (or global)
referencing. Using this method, you can insert the new menu in front of a known menu and then remove the known menu.

For menu-swapping purposes, the pull-down menu areas are named \( P_1 \) through \( P_{16} \). You can change the title that appears in the menu bar by replacing that line of the menu with a $P_n=$ command. You can use the special command \$P_n=* from within any command to force the menu currently assigned to area \( \text{POP}_n \) to pull down for greater flexibility in movement of the pointing device.

The following macro example replaces a menu at position \( P_3 \) with the menu named \( \text{MyMenu} \) in the customization group named \( \text{MYMENU} \).

\[
\$P3=\text{mymenu.new3}
\]

You can use the $P_n=*$ special command from within any macro to force the menu currently assigned to area \( \text{POP}_n \) to be displayed.

**NOTE** The swapping of pull-down menus does not conform to the Microsoft® user interface guidelines and is not guaranteed to be available in future releases of the program.

**Insert and Remove Pull-Down Menus**

Menu swapping is done by activating one menu directly from another menu. Menu swapping is supported for the following interface elements:

- **B** - Buttons
- **P** - Pull-down menus
- **A** - Mouse buttons
- **I** - Image tile menus
- **T** - Tablet menus

The syntax for the swapping of partial menus is as follows:

\[
\$\text{section} = \text{customizationgroup.menuname}
\]

section
B1-4, A1-4, P0-16, T1-4
customizationgroup
Customization group name in the desired CUIx file
menuname
Main label or alias

You can also insert a menu with the $Pn$ syntax. The following macro inserts a menu after the $P5$ menu.

If you use this method to insert a menu, remember that you cannot rely on its being inserted at the $P6$ menu location as you might expect. There are two reasons that this may not be the case.

- If the current menu bar has only three menus, inserting a menu after menu $P5$ results in the new menu's location being $P4$.
- If the user inserts or removes a customization file with the CUILOAD command or when another application inserts or removes customization files, menu numbering can get out of sync.

This is the syntax for removing a menu:

```
$G\text{customizationgroup.menuname}=-
```

The following shows how to remove the menu $\text{NEW3}$ that is a member of the $\text{MyMenu}$ group.

```
$G\text{mymenu.new3}=-$
```

As you might expect, the preceding format is preferable to the $Pn$ format because it removes only the specified menu. The following shows how to remove the menu at the $P4$ location (whatever it is).

```
$P4=-
```

**Control Toolbars Across Partial CUIx Files**

To control toolbars across partial CUIx files, use the following syntax at the Enter toolbar name or [ALL]: prompt of the -TOOLBAR command.

```
menugroup.subsection-name
```

This syntax accesses the toolbar identified by `menugroup.menuname` and allows you to use the full spectrum of -TOOLBAR command options on that toolbar.

If the menu group is left out of any of these commands and functions, the program defaults to the main CUIx file.

You should be aware of the following:

- Image tile menus cannot be swapped from external customization files.
You can swap customization elements of the same type only; that is, one shortcut menu for another, one toolbar for another, and so on. Trying to swap between types may result in unpredictable behavior.

**Quick Reference**

**Commands**

CUI
- Manages the customized user interface elements in the product.

CUILOAD
- Loads a CUIx file.

CUIUNLOAD
- Unloads a CUIx file.

-TOOLBAR
- Displays, hides, and customizes toolbars.

WORKSPACE
- Creates, modifies, and saves workspaces and makes a workspace current.

**Quick Properties**

With the Quick Properties palette, for a selected object, you can access a sub-set of the properties that are accessible from the Properties palette.

You can customize the properties that are displayed on the Quick Properties palette. The properties (displayed when an object is selected) are common to all object types and are specific to the object that was selected. The available properties are the same as those on the Properties palette and for rollover tooltips.

**NOTE** You can synchronize the properties that are displayed on the Quick Properties palette with those for rollover tooltips.

**Display Objects Properties on the Quick Properties Palette**

When customizing the Quick Properties palette, you control which object types display properties on the Quick Properties palette and which properties are displayed. You use the Objects pane to add and remove the object types.
that are set to display properties on the Quick Properties palette. Once an object type is added to the Objects pane, you can then decide which properties to display when on object of that type is selected in the drawing window.

You can change the general properties for a selected object type or for all object types. Selecting an object type from the Objects pane allows you to control the display of the general properties for the selected object type, or by clicking the General button at the bottom of the Objects pane you can override the general properties of all object types.

When the General button at the bottom of the Objects pane is clicked, a list of the general properties that can be used to override the general properties of all object types is displayed along with the Reset Overrides button. Selecting the general properties that you want to display for all object types and clicking Reset Overrides applies the selected general properties to all listed object types in the Objects pane. However, after applying a general property to all object types you can deselect any general property for a specific object type by selecting the object type and deselecting the property.

**Display the Quick Properties Palette**

The Quick Properties palette is displayed when objects are selected, if the object type of the selected objects is supported for Quick Properties, and if the QPMODE system variable is set to 1 or 2. See Display and Change the Properties of Objects in the *User’s Guide* for more information about controlling the display of the Quick Properties.

**NOTE** When the system variable QPMODE is set to a value of 1, the general properties that are checked are displayed in the Quick Properties palette for all object types that are not in the list on the Objects pane.

**To control which object types are used with the Quick Properties palette**

1. Click Manage tab ➤ Customization panel ➤ User Interface.
2. In the Customize User Interface Editor, Customize tab, in the Customizations In `<file name>` pane, select Quick Properties.
3 In the Objects pane, click Edit Object Type List.

4 In the Edit Object Type List dialog box, select the object types you want to display properties for on the Quick Properties palette.

If an object type is checked, the properties for the object type are displayed on the Quick Properties palette when an object of the same type is selected.
in the drawing window. Clear the check mark next to an object type to remove support for the object type from the Quick Properties palette.

5 Click OK.

6 In the Customize User Interface Editor, click Apply.

**To control the display of a property for an object on the Quick Properties palette**

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, select Quick Properties.

3 In the Objects pane, select an object from the Object Type list.

4 In the Properties pane, select the properties you want displayed for an object type on the Quick Properties palette.

If a property is checked, the property is displayed on the Quick Properties palette when an object of the same type is selected in the drawing window.
Clear the check mark next to a property to remove the property for the selected object type from the Quick Properties palette.

5 Click Apply.

To control the display of custom properties and attributes for block references on the Quick Properties palette

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, select Quick Properties.

3 In the Objects pane, select Block Reference from the Object Type list.

4 In the Properties pane, select the check box next to Custom and Attributes. If the Custom category is checked, the dynamic properties for a block are displayed on the Quick Properties palette. If the Attributes category is
checked, the attributes for a block are displayed on the Quick Properties palette.

5 Click Apply.

To override the general properties for all object types

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, select Quick Properties.

3 In the Properties pane, select the check boxes next to the general properties you want the Quick Properties palette to display for all object types.

4 Click Reset Overrides.

238 Chapter 4 User Interface Customization
5 Click Apply.

To restore the default settings for Quick Properties

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, right-click Quick Properties.

3 Click Restore Default.

4 Click Restore the Default Quick Properties Settings.

5 Click Apply.
To synchronize Quick Properties with rollover tooltips

1. Click Manage tab ➤ Customization panel ➤ User Interface.
2. In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, right-click Quick Properties.
3. Click Synchronize with Rollover Tooltips.
4. Click Apply Rollover Tooltips Settings to Quick Properties palette.
5. Click Apply.

Quick Reference

Commands

CUI
Manages the customized user interface elements in the product.
DSETTINGS
Sets grid and snap, polar and object snap tracking, object snap modes, Dynamic Input, and Quick Properties.

System Variables
QPLOCATION
Sets the location mode of Quick Properties palette.
QPMODE
Sets the on or off state of Quick Properties palette.

Rollover Tooltips
Rollover tooltips display the current values of selected properties.
The properties and values that are displayed in a rollover tooltip can be customized by object type. When customizing the display of the properties for a rollover tooltip, you can display properties common to all object types or properties that are specific to an object type. The available properties are the same as those on the Properties and Quick Properties palettes.

NOTE You can synchronize the properties used for rollover tooltips with those displayed on the Quick Properties palette.

Display Objects Properties on Rollover Tooltips
When customizing rollover tooltips, you control which object types display a tooltip when the cursor hovers over an object in the drawing window. You use the Objects pane to add and remove the object types for which you want to see a rollover tooltip. Once an object type is listed in the Objects pane, you can then specify which properties in the Properties pane are displayed on the rollover tooltip for the selected object type.

You can change the general properties for a selected object type or for all object types. Selecting an object type from the Objects pane allows you to control the display of the general and object specific properties for that selected object type. You can click the General button at the bottom of the Objects pane to override the general properties of all object types.

When the General button at the bottom of the Objects pane is clicked, a list of the general properties that can be used to override the properties of all object types is displayed along with the Reset Overrides button. Select the general properties that you want to display for all object types and click Reset.
Overrides. However, after applying a general property to all object types you can deselect any general property for a specific object type by selecting the object type and deselecting the property.

**NOTE** When an object is not in the Object Type list on the Objects pane, the general properties that are checked for all object types are displayed on the rollover tooltips.

**Display Rollover Tooltips**

Rollover tooltips are displayed for objects when the ROLLOVERTIPS system variable is set to 1. See Set Interface Options in the *User’s Guide* for more information about controlling the display of rollover tooltips and other tooltip settings for the program.

**To control which objects support rollover tooltips**

1. Click Manage tab ➤ Customization panel ➤ User Interface.
2. In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, select Rollover Tooltips.
3. In the Objects pane, click Edit Object Type List.
4 In the Edit Object Type List dialog box, select the object types you want to display properties for on a rollover tooltip.

![Edit Object Type List dialog box]

If an object type is checked, the properties for the object type are displayed on a rollover tooltip when the cursor hovers over an object of the same type. Clear the check mark next to an object type to remove support for the object type from rollover tooltips.

5 Click OK.

6 In the Customize User Interface Editor, click Apply.

**To control which properties are displayed on a rollover tooltip**

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, select Rollover Tooltips.
3 In the Objects pane, select an object from the Object Type list.

4 In the Properties pane, select the properties you want to display on a rollover tooltip.
   If a property is checked, the property is displayed on a rollover tooltip when the cursor hovers over an object of the selected object type in the drawing window. Clear the check mark next to a property to remove the property for the selected object type.

5 Click Apply.

To override the general properties for all object types that support rollover tooltips

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, select Rollover Tooltips.
3 In the Properties pane, select the check boxes next to the general properties you want rollover tooltips to display for all object types.

4 Click Reset Overrides.

5 Click Apply.

To restore the default settings for rollover tooltips

1 Click Manage tab ➤ Customization panel ➤ User Interface.
2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, right-click Rollover Tooltips.

3 Click Restore Default.

4 Click Restore the Default Rollover Tooltips Settings.

5 Click Apply.

To synchronize rollover tooltips with Quick Properties

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, right-click Rollover Tooltips.

3 Click Synchronize with Quick Properties.
4 Click Apply Quick Properties Settings to Rollover Tooltips.

5 Click Apply.

Quick Reference

Commands

CUI
Manages the customized user interface elements in the product.

OPTIONS
Customizes the program settings.

System Variables

ROLLOVERTIPS
Controls the display of rollover tooltips in the application.
Keyboard Shortcuts

Shortcut keys can be used to start commands and to be temporary override keys to execute a command or change a setting when a key is pressed.

Shortcut Keys

You can assign shortcut keys (sometimes called accelerator keys) to commands you use frequently.

Overview of Shortcut Keys

Shortcut keys are key combinations that start commands. For example, you can press Ctrl+O to open a file and Ctrl+S to save a file, which is the same as clicking Open and Save on the Quick Access toolbar or File menu.

To create a shortcut key, you start by dragging a command from the Commands List pane to the Shortcut Keys node in the Customizations In <file name> pane. Once you create a shortcut key, you assign a key combination to it.

The following table shows the properties of the Save shortcut key as they appear in the Properties pane.

<table>
<thead>
<tr>
<th>Properties pane item</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>String that is only used in the CUI Editor and is not displayed in the user interface.</td>
<td>Save</td>
</tr>
<tr>
<td>Description</td>
<td>Text used to describe the element; does not appear in the user interface.</td>
<td>Saves the current drawing</td>
</tr>
<tr>
<td>Extended Help File</td>
<td>Displays the file name and ID for the extended tooltip that is displayed when the cursor hovers over a toolbar or panel button.</td>
<td></td>
</tr>
<tr>
<td>Command Display Name</td>
<td>String that contains the name of the command that is related to the command.</td>
<td>QSAVE</td>
</tr>
</tbody>
</table>
Properties for the Save Shortcut Key

<table>
<thead>
<tr>
<th>Properties pane item</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Macro</td>
<td>The command macro. It follows the standard macro syntax.</td>
<td>^C^C_qsave</td>
</tr>
<tr>
<td>Key(s)</td>
<td>Specifies the keystroke combination that is used to execute the macro. Click the [ ] button to open the Shortcut Keys dialog box.</td>
<td>CTRL+S</td>
</tr>
<tr>
<td>Tags</td>
<td>Keywords associated to a command. Tags provide an additional field to search in the application menu.</td>
<td></td>
</tr>
<tr>
<td>Element ID</td>
<td>Tag that uniquely identifies a command.</td>
<td>ID_Save</td>
</tr>
</tbody>
</table>

**NOTE** A shortcut key inherits its properties from the command that is used to create it.

**To create or modify a shortcut key**

1. Click Manage tab ➤ Customization panel ➤ User Interface.
2. In the Customize User Interface Editor, Customize tab, click the plus sign (+) next to Keyboard Shortcuts to expand it.
3. Click the plus sign (+) next to Shortcut Keys to expand it.
4. Do one of the following:
   - To create a shortcut key, in the Command List pane, drag the command to the Shortcut Keys node of the Customizations In <filename> pane.
To modify a shortcut key, select a shortcut key.

In the Properties pane, the properties for the shortcut key are displayed.

5 In the Key(s) box, click the [ ] button to open the Shortcut Keys dialog box.

6 Hold down the modifier key Ctrl with a combination of Shift and Alt if desired and press a letter, number, function, or virtual key such as F1 or Insert. Valid modifier and key combinations include the following:

- Function (Fn) keys containing no modifiers
- Number Pad (NUMPADn) keys containing no modifiers
- Ctrl+letter, Ctrl+number, Ctrl+function, Ctrl+virtual key
- Ctrl+Alt+letter, Ctrl+Alt+number, Ctrl+Alt+function, Ctrl+Alt+virtual key
- Ctrl+Shift+letter, Ctrl+Shift+number, Ctrl+Shift+function, Ctrl+Shift+virtual key
- Ctrl+Shift+Alt+letter, Ctrl+Shift+Alt+number, Ctrl+Shift+Alt+function, Ctrl+Shift+Alt+virtual key

**NOTE** The virtual keys that are supported are Escape, Insert, Delete, Home, End, Page Up, Page Down, Left Arrow, Right Arrow, Up Arrow, and Down Arrow. The virtual key Escape can only be used by itself or with the modifier combination Ctrl+Shift+Alt.

Currently Assigned To displays any current assignments for the entered key combination. If you do not want to replace the current key assignment, use a different key combination.

7. Click OK to assign the key combination and close the Shortcut Keys dialog box.

8. In the Customize User Interface Editor, click Apply.

**To print a list of shortcut keys or temporary override keys**

1. Click Manage tab ➤ Customization panel ➤ User Interface.

2. In the Customizations In <file name> pane, click the Keyboard Shortcuts node.
3 In the Shortcuts pane, filter the type and status of keyboard shortcuts to print.
   ■ In the Type drop-down list, select the type of keyboard shortcuts to display in the list. Choices include All Keys, Accelerator Keys, or Temporary Override Keys.
   ■ In the Status list, select the status of keyboard shortcuts displayed in the list. Choices include All, Active, Inactive, and Unassigned.

4 In the Shortcuts pane, click Print.

Quick Reference

Commands
CUI
Manages the customized user interface elements in the product.

System Variables
TOOLTIPS
Controls the display of tooltips on the ribbon, toolbars, and other user interface elements.

Examples of Shortcut Keys
The CUIx file that ships with AutoCAD LT defines the default shortcut keys. You can use the default shortcut keys as examples when creating your own shortcut keys.
The following table lists the default actions for shortcut keys.

<table>
<thead>
<tr>
<th>Shortcut Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CTRL+0</td>
<td>Toggles Clean Screen</td>
</tr>
<tr>
<td>CTRL+1</td>
<td>Toggles Properties palette</td>
</tr>
<tr>
<td>CTRL+2</td>
<td>Toggles DesignCenter</td>
</tr>
<tr>
<td>CTRL+3</td>
<td>Toggles the Tool Palettes window</td>
</tr>
<tr>
<td>CTRL+7</td>
<td>Toggles Markup Set Manager</td>
</tr>
<tr>
<td>CTRL+8</td>
<td>Toggles the QuickCalc palette</td>
</tr>
<tr>
<td>CTRL+9</td>
<td>Toggles the Command Line window</td>
</tr>
<tr>
<td>CTRL+A</td>
<td>Selects all the objects in drawing that are not locked or frozen</td>
</tr>
<tr>
<td>CTRL+SHIFT+A</td>
<td>Toggles Groups</td>
</tr>
<tr>
<td>CTRL+B</td>
<td>Toggles Snap</td>
</tr>
<tr>
<td>CTRL+C</td>
<td>Copies objects to the Windows Clipboard</td>
</tr>
<tr>
<td>CTRL+SHIFT+C</td>
<td>Copies objects to the Windows Clipboard with Base Point</td>
</tr>
<tr>
<td>CTRL+E</td>
<td>Cycles through isometric planes</td>
</tr>
<tr>
<td>CTRL+F</td>
<td>Toggles running object snaps</td>
</tr>
<tr>
<td>CTRL+G</td>
<td>Toggles Grid</td>
</tr>
<tr>
<td>CTRL+H</td>
<td>Toggles PICKSTYLE</td>
</tr>
<tr>
<td>CTRL+SHIFT+H</td>
<td>Toggles the display of palettes with HIDE-PALETTES and SHOWPALETTES</td>
</tr>
<tr>
<td>CTRL+J</td>
<td>Repeats last command</td>
</tr>
<tr>
<td>Shortcut Key</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>CTRL+K</td>
<td>Inserts a hyperlink</td>
</tr>
<tr>
<td>CTRL+L</td>
<td>Toggles Ortho mode</td>
</tr>
<tr>
<td>CTRL+M</td>
<td>Repeats last command</td>
</tr>
<tr>
<td>CTRL+N</td>
<td>Creates a new drawing</td>
</tr>
<tr>
<td>CTRL+O</td>
<td>Opens an existing drawing</td>
</tr>
<tr>
<td>CTRL+P</td>
<td>Plots the current drawing</td>
</tr>
<tr>
<td>CTRL+SHIFT+P</td>
<td>Toggles the Quick Properties interface</td>
</tr>
<tr>
<td>CTRL+Q</td>
<td>Quits AutoCAD LT</td>
</tr>
<tr>
<td>CTRL+R</td>
<td>Cycles through the viewports on the current layout</td>
</tr>
<tr>
<td>CTRL+S</td>
<td>Saves current drawing</td>
</tr>
<tr>
<td>CTRL+SHIFT+S</td>
<td>Displays up the Save As dialog box</td>
</tr>
<tr>
<td>CTRL+T</td>
<td>Toggles Tablet mode</td>
</tr>
<tr>
<td>CTRL+V</td>
<td>Pastes data from the Windows Clipboard</td>
</tr>
<tr>
<td>CTRL+SHIFT+V</td>
<td>Pastes data from the Windows Clipboard as a Block</td>
</tr>
<tr>
<td>CTRL+X</td>
<td>Cuts objects from the current drawing to the Windows Clipboard</td>
</tr>
<tr>
<td>CTRL+Y</td>
<td>Cancels the preceding Undo action</td>
</tr>
<tr>
<td>CTRL+Z</td>
<td>Reverses the last action</td>
</tr>
<tr>
<td>CTRL+[</td>
<td>Cancels current command</td>
</tr>
<tr>
<td>CTRL+\</td>
<td>Cancels current command</td>
</tr>
</tbody>
</table>
Shortcut Key Assignments

<table>
<thead>
<tr>
<th>Shortcut Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CTRL+PAGE UP</td>
<td>Moves to the next layout tab to the left of the current tab</td>
</tr>
<tr>
<td>CTRL+PAGE DOWN</td>
<td>Moves to the next layout tab to the right of the current tab</td>
</tr>
<tr>
<td>F1</td>
<td>Displays Help</td>
</tr>
<tr>
<td>F2</td>
<td>Toggles Text Window</td>
</tr>
<tr>
<td>F3</td>
<td>Toggles OSNAP</td>
</tr>
<tr>
<td>F4</td>
<td>Toggles TABMODE</td>
</tr>
<tr>
<td>F5</td>
<td>Toggles ISOPLANE</td>
</tr>
<tr>
<td>F7</td>
<td>Toggles GRIDMODE</td>
</tr>
<tr>
<td>F8</td>
<td>Toggles ORTHOMODE</td>
</tr>
<tr>
<td>F9</td>
<td>Toggles SNAPMODE</td>
</tr>
<tr>
<td>F10</td>
<td>Toggles Polar Tracking</td>
</tr>
<tr>
<td>F11</td>
<td>Toggles Object Snap Tracking</td>
</tr>
<tr>
<td>F12</td>
<td>Toggles Dynamic Input</td>
</tr>
</tbody>
</table>

NOTE In the Customize User Interface (CUI) Editor, you can view, print, or copy a list of shortcut keys, temporary override keys, or both. The shortcut keys and temporary override keys in the list are those keys used by the CUIx files that are loaded in the program.

Temporary Override Keys

Temporary override keys allow you to execute a command or change a setting when a key combination is pressed, and then restore settings changed or execute a command when a key combination is released.
Overview of Temporary Override Keys

Temporary override keys are used to temporarily turn on or off drafting settings. For example, holding down the Shift key toggles the current setting of Ortho mode. The following table shows the Object Snap Override: Endpoint temporary override key properties as they appear in the Properties pane.

The creation of a temporary override key does not start with a command from the Commands List pane like a shortcut key does. Instead, you create a new temporary override key like you do a toolbar or ribbon panel, and that is by right-clicking over the Temporary Override Keys node and clicking New Temporary Override Key. Once a temporary override key is created you use the Properties pane to define its key up and key down behavior, and assign it a key combination.

The following table shows the properties of the Object Snap Override: Endpoint temporary override key as they appear in the Properties pane.

<table>
<thead>
<tr>
<th>Properties pane item</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>String that is only used in the CUI Editor and is not displayed in the user interface.</td>
<td>Object Snap Override : Endpoint</td>
</tr>
<tr>
<td>Description</td>
<td>Text used to describe the element; does not appear in the user interface.</td>
<td>Object Snap Override : Endpoint</td>
</tr>
<tr>
<td>Keys</td>
<td>Specifies the keystroke combination that is used to execute the temporary override. Click the [ ] button to open the Shortcut Keys dialog box.</td>
<td>SHIFT+E</td>
</tr>
<tr>
<td>Macro1 (Key Down)</td>
<td>Specifies the macro that should be executed when the keystroke combination is held down by the user.</td>
<td>^P_.osmode 1 $(if,$(eq,$(getvar, osnapoverride),'_.osnapoverride 1)</td>
</tr>
<tr>
<td>Macro2 (Key Up)</td>
<td>Specifies the macro that should be executed when the keystroke combination is released by the user. If left blank, AutoCAD LT restores any variables to their previous state.</td>
<td>^P_.osmode 1 $(if,$(eq,$(getvar, osnapoverride),'_.osnapoverride 1)</td>
</tr>
</tbody>
</table>

256 | Chapter 4   User Interface Customization
To create a temporary override key

1. Click Manage tab ➤ Customization panel ➤ User Interface.

2. In the Customize User Interface Editor, Customize tab, click the plus sign (+) next to Keyboard Shortcuts to expand it.

3. In the Customizations In <file name> pane, right-click Temporary Override Keys. Click New Temporary Override.

A new temporary override (named TemporaryOverride1) is placed at the bottom of the Temporary Override Keys tree.

4. Do one of the following:
   ■ Enter a new name over the default name TemporaryOverride1.
   ■ Right-click TemporaryOverride1. Click Rename. Enter a new temporary override name.
   ■ Click TemporaryOverride1, wait, and click again over the temporary override’s name again to edit its name in-place.

5. Select the new temporary override in the tree view, and update the Properties pane:
   ■ In the Description box, enter a description for the temporary override key.
   ■ In the Key(s) box, click the [ ] button to open the Shortcut Keys dialog box. In the Shortcut Keys dialog box, click in the Press New Shortcut Key box to ensure the box has focus, and press a key. Valid modifier keys include function (Fn keys) with no modifiers, Shift+letter, or Shift+number key.

Keyboard Shortcuts | 257
■ In the Macro 1 (Key Down) box, enter a macro to be executed when the temporary override key is pressed. When no value is assigned, the default macro is ^c^c.

■ In the Macro 2 (Key Up) box, enter a macro to be executed when the temporary override key is released. When no value is defined, key up restores the application to its previous state (before the temporary override was executed).

![Macro Table]

**NOTE** For information about creating a macro, see Create Macros on page 101.

6 Click Apply.

**To modify a temporary override key**

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, click the plus sign (+) next to Keyboard Shortcuts to expand it.

3 Click the plus sign (+) next to Temporary Override Keys to expand it.

4 In the Customizations In <file name> pane, click the temporary override key you want to modify.

5 Update the Properties pane as necessary:

■ In the Description box, enter a description for the temporary override key.
In the Key(s) box, click the [ ] button to open the Shortcut Keys dialog box. In the Shortcut Keys dialog box, click in the Press New Shortcut Key box to ensure the box has focus, and press a key. Under the Press New Shortcut Key box, Currently Assigned To displays any current assignments for the key. If a key you select is not already assigned, click OK.

In the Macro 1 (Key Down) box, enter a macro to be executed when the temporary override key is pressed. When no value is assigned, the default macro is ^c^c.

In the Macro 2 (Key Up) box, enter a macro to be executed when the temporary override key is released. When no value is defined, key up restores the application to its previous state (before the temporary override was executed).

<table>
<thead>
<tr>
<th>General</th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Toggles Orthogonal Mode</td>
<td>Toggles Orthogonal Mode</td>
</tr>
<tr>
<td>Shortcut</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Ke(y)</td>
<td>F8</td>
<td></td>
</tr>
<tr>
<td>Macro 1 (Key Down)</td>
<td>^c^c</td>
<td>Ortho Mode SH+9 Stand Sign</td>
</tr>
<tr>
<td>Macro 2 (Key Up)</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**NOTE** For information about creating a macro, see Create Macros on page 101.

6  Click Apply.

**To print a list of shortcut keys or temporary override keys**

1  Click Manage tab ➤ Customization panel ➤ User Interface.

2  In the Customizations In <file name> pane, click the Keyboard Shortcuts node.
3 In the Shortcuts pane, filter the type and status of keyboard shortcuts to print.

- In the Type drop-down list, select the type of keyboard shortcuts to display in the list. Choices include All Keys, Accelerator Keys, or Temporary Override Keys.
- In the Status list, select the status of keyboard shortcuts displayed in the list. Choices include All, Active, Inactive, and Unassigned.

4 In the Shortcuts pane, click Print.

Quick Reference

Commands

CUI
Manages the customized user interface elements in the product.

System Variables

TOOLTIPS
Controls the display of tooltips on the ribbon, toolbars, and other user interface elements.

TEMPOVERRIDES
Turns temporary override keys on and off.
Examples of Temporary Override Keys

The CUIx file that ships with AutoCAD LT defines the default temporary override keys. You can use the default temporary override keys as examples when creating your own temporary override keys.

The following table lists the default actions for temporary override keys on an English U.S. keyboard. For more information about default temporary override keys on other keyboards, see Override Object Snap Settings in the User's Guide.

<table>
<thead>
<tr>
<th>Temporary Override Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>F3</td>
<td>Toggles OSNAP</td>
</tr>
<tr>
<td>F8</td>
<td>Toggles ORTHOMODE</td>
</tr>
<tr>
<td>F9</td>
<td>Toggles SNAPMODE</td>
</tr>
<tr>
<td>F10</td>
<td>Toggles Polar Tracking</td>
</tr>
<tr>
<td>F11</td>
<td>Toggles Object Snap Tracking</td>
</tr>
<tr>
<td>F12</td>
<td>Toggles Dynamic Input</td>
</tr>
<tr>
<td>SHIFT</td>
<td>Toggles ORTHOMODE</td>
</tr>
<tr>
<td>SHIFT+’</td>
<td>Toggles OSNAP</td>
</tr>
<tr>
<td>SHIFT+,</td>
<td>Object Snap Override: Center</td>
</tr>
<tr>
<td>SHIFT+.</td>
<td>Toggles Polar Tracking</td>
</tr>
<tr>
<td>SHIFT+;</td>
<td>Enables Object Snap Enforcement</td>
</tr>
<tr>
<td>SHIFT+]</td>
<td>Toggles Object Snap Tracking</td>
</tr>
<tr>
<td>SHIFT+A</td>
<td>Toggles OSNAP</td>
</tr>
<tr>
<td>SHIFT+C</td>
<td>Object Snap Override: Center</td>
</tr>
<tr>
<td>SHIFT+D</td>
<td>Disable All Snapping and Tracking</td>
</tr>
</tbody>
</table>
Temporary Override Key Assignments

<table>
<thead>
<tr>
<th>Temporary Override Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SHIFT+E</td>
<td>Object Snap Override: Endpoint</td>
</tr>
<tr>
<td>SHIFT+L</td>
<td>Disable All Snapping and Tracking</td>
</tr>
<tr>
<td>SHIFT+M</td>
<td>Object Snap Override: Midpoint</td>
</tr>
<tr>
<td>SHIFT+P</td>
<td>Object Snap Override: Endpoint</td>
</tr>
<tr>
<td>SHIFT+Q</td>
<td>Toggles Object Snap Tracking</td>
</tr>
<tr>
<td>SHIFT+S</td>
<td>Enables Object Snap Enforcement</td>
</tr>
<tr>
<td>SHIFT+V</td>
<td>Object Snap Override: Midpoint</td>
</tr>
<tr>
<td>SHIFT+X</td>
<td>Toggles Polar Tracking</td>
</tr>
</tbody>
</table>

**NOTE** In the Customize User Interface (CUI) Editor, you can view, print, or copy a list of shortcut keys, temporary override keys, or both. The shortcut keys and temporary override keys in the list are those keys used by the CUIx files that are loaded in the program.

Double Click Actions

You can create a double click action which starts an editing command when the cursor is positioned over an object in a drawing and a double-click event is registered from a pointing device.

Overview of Double Click Actions

Double click actions execute a command that displays either the Properties palette or a specialized editor that is more powerful, convenient, or frequently used for the object type that is double-clicked in a drawing. The following
table shows the definition of the Attribute Block double click action in the CUI Editor.

### Properties for the Attribute Block double click action

<table>
<thead>
<tr>
<th>Properties pane item</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>String used to identify the double click action in the CUI Editor.</td>
<td>Attribute Block</td>
</tr>
<tr>
<td>Description</td>
<td>Text used to describe the element in the CUI Editor.</td>
<td></td>
</tr>
<tr>
<td>Object Name</td>
<td>Determines the type of object the double click action is associated to. For information on the object names that can be used, see Double Click Action Object Names on page 266.</td>
<td>ATTBLOCKREF</td>
</tr>
<tr>
<td>Element ID</td>
<td>Uniquely identifies a double click action in the CUI Editor.</td>
<td>DC_0002</td>
</tr>
</tbody>
</table>

### To create a double click action

1. Click Manage tab ➤ Customization panel ➤ User Interface.

2. In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, right-click Double Click Actions. Click New Double Click Action.

The new double click action (named DoubleClick1) is placed at the bottom of the Double Click Actions tree.

3. Do one of the following:
   - Enter a new name over the default name DoubleClick1.
Right-click DoubleClick1. Click Rename. Enter a new double click action name.

Click DoubleClick1, wait, and click again over the double click action's name again to edit its name in-place.

4 In the Properties pane, do the following:

In the Description box, enter a description for the double click action.

In the Object Name box, enter a DXF name or one of the special object names used for an insert, surface, or underlay object. The value will automatically be converted to uppercase after the box loses focus.

5 In the Command List pane, drag the command you want to add to the double click action in the Customizations In <file name> pane.

NOTE Only a single command can be associated with a double click action at a time.

6 Click Apply.

To modify a double click action

1 Click Manage tab ➤ Customization panel ➤ User Interface.
2 In the Customize User Interface Editor, Customize tab, click the plus sign (+) next to Double Click Actions to expand it.

3 Click a double click action.

In the Properties pane, the properties for the double click action you selected are displayed.

4 In the Object Name box, enter a DXF name or one of the special object names used for an insert, surface, or underlay object.

5 If you want to replace the current command assigned to the double click action, click in the Command List pane and drag a different command to the selected double click action in the Customizations In <file name> pane.

6 Click Apply.
Quick Reference

Commands
CUI
Manages the customized user interface elements in the product.

OPTIONS
Customizes the program settings.

System Variables
DBLCLKEDIT
Controls the double click editing behavior in the drawing area.
PICKFIRST
Controls whether you select objects before (noun-verb selection) or after you issue a command.

Double Click Action Object Names
The Object Name property of a double click action must be a valid drawing interchange format (DXF™) name, or a special name for insert objects.

There are some exceptions as to when the DXF name is not used for the Object Name property of a double click action. These exceptions apply to objects that use the INSERT DXF names. For example, the double click action named “Attribute Dynamic Block” in the acadlt.cui file uses the object name ATTDYNBLOCKREF, which is used for insert objects that contain attributes and dynamic actions.

The following table shows the DXF names for many of the objects commonly found in a drawing. In most cases, the DXF name and the object name are the same value with the exception of the INSERT DXF name.

<table>
<thead>
<tr>
<th>DXF Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACAD_PROXY_ENTITY</td>
<td>Object of an unknown type</td>
</tr>
<tr>
<td>ARC</td>
<td>3-point arc</td>
</tr>
<tr>
<td>ATTDEF</td>
<td>Attribute definition that is not defined in a block</td>
</tr>
</tbody>
</table>
### DXF Names for Commonly Used Objects

<table>
<thead>
<tr>
<th>DXF Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CIRCLE</td>
<td>Circle</td>
</tr>
<tr>
<td>DGNUNDERLAY</td>
<td>DGN file underlay</td>
</tr>
<tr>
<td>DIMENSION</td>
<td>Dimensions (all dimension objects)</td>
</tr>
<tr>
<td>DWFUNDERLAY</td>
<td>DWF file underlay</td>
</tr>
<tr>
<td>ELLIPSE</td>
<td>Ellipse and elliptical arc</td>
</tr>
<tr>
<td>EXTRUDEDSURFACE</td>
<td>3D extruded surface</td>
</tr>
<tr>
<td>HATCH</td>
<td>Hatch fill</td>
</tr>
<tr>
<td>IMAGE</td>
<td>Raster image</td>
</tr>
<tr>
<td>INSERT</td>
<td>The Object Names for the different types of block reference objects are as follows:</td>
</tr>
<tr>
<td></td>
<td>ATTBLOCKREF Block reference with attributes</td>
</tr>
<tr>
<td></td>
<td>ATTDYNBLOCKREF Dynamic block reference with attributes</td>
</tr>
<tr>
<td></td>
<td>BLOCKREF Block reference without attributes</td>
</tr>
<tr>
<td></td>
<td>DYNBLOCKREF Dynamic block reference without attributes</td>
</tr>
<tr>
<td></td>
<td>XREF External reference (xref)</td>
</tr>
<tr>
<td>LEADER</td>
<td>Legacy leader</td>
</tr>
<tr>
<td>LIGHT</td>
<td>Point light, spotlight, web light, and distant light</td>
</tr>
<tr>
<td>LINE</td>
<td>Line</td>
</tr>
<tr>
<td>LOFTEDSURFACE</td>
<td>3D lofted surface</td>
</tr>
<tr>
<td>LWPOLYLINE</td>
<td>Lightweight polyline</td>
</tr>
</tbody>
</table>

Double Click Actions | 267
## DXF Names for Commonly Used Objects

<table>
<thead>
<tr>
<th>DXF Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>MLINE</td>
<td>Multiline</td>
</tr>
<tr>
<td>MLEADER</td>
<td>Multileader</td>
</tr>
<tr>
<td>MTEXT</td>
<td>Multiline text</td>
</tr>
<tr>
<td>PDFUNDERLAY</td>
<td>PDF file underlay</td>
</tr>
<tr>
<td>POINT</td>
<td>Point</td>
</tr>
<tr>
<td>POLYLINE</td>
<td>2D or 3D polyline</td>
</tr>
<tr>
<td>RAY</td>
<td>Ray</td>
</tr>
<tr>
<td>REGION</td>
<td>2D region</td>
</tr>
<tr>
<td>REVOLVEDSURFACE</td>
<td>3D revolved surface</td>
</tr>
<tr>
<td>SHAPE</td>
<td>Shape insert</td>
</tr>
<tr>
<td>SOLID</td>
<td>2D solid</td>
</tr>
<tr>
<td>SPLINE</td>
<td>B-spline curve</td>
</tr>
<tr>
<td>SWEPTSURFACE</td>
<td>3D swept surface</td>
</tr>
<tr>
<td>TABLE</td>
<td>Table</td>
</tr>
<tr>
<td>TEXT</td>
<td>Single-line text</td>
</tr>
<tr>
<td>TOLERANCE</td>
<td>Geometric tolerance</td>
</tr>
<tr>
<td>VIEWPORT</td>
<td>Floating viewport</td>
</tr>
<tr>
<td>WIPEOUT</td>
<td>Wipeout</td>
</tr>
<tr>
<td>XLINE</td>
<td>Construction line</td>
</tr>
</tbody>
</table>
NOTE If more than one object is selected or if an object type is not associated with a double click action, the default command used is PROPERTIES.

Examples of Double Click Actions

The CUIx file that ships with AutoCAD LT defines the default double click actions. You can use the default double click actions as examples when creating your own double click actions.

The following table shows some of the object names that are set up in the acadlt.cuix file. Expand the Double Click Actions node in the Customize User Interface (CUI) Editor for a complete listing of all the actions that are defined.

### Double click action assignments

<table>
<thead>
<tr>
<th>Object Type</th>
<th>Command (Macro)</th>
</tr>
</thead>
<tbody>
<tr>
<td>ATTDEF</td>
<td>DDEDIT</td>
</tr>
<tr>
<td>ATTRIB</td>
<td>ATTIPEDIT</td>
</tr>
<tr>
<td>ATTBLOCKREF</td>
<td>ATTEDIT</td>
</tr>
<tr>
<td>ATTDYNBLOCKREF</td>
<td>ATTEDIT</td>
</tr>
<tr>
<td>BLOCKREF</td>
<td>$M=$(if,$(and,$(&gt;,$(getvar,blockeditlock),0)),^C^C_proper-ties,^C^C_bedit)</td>
</tr>
<tr>
<td>DYNBLOCKREF</td>
<td>$M=$(if,$(and,$(&gt;,$(getvar,blockeditlock),0)),^C^C_proper-ties,^C^C_bedit)</td>
</tr>
<tr>
<td>HATCH</td>
<td>HATCHEDIT</td>
</tr>
<tr>
<td>IMAGE</td>
<td>IMAGEADJUST</td>
</tr>
<tr>
<td>LWPOLYLINE</td>
<td>PEDIT</td>
</tr>
<tr>
<td>MTEXT</td>
<td>MTEDIT</td>
</tr>
<tr>
<td>POLYLINE</td>
<td>PEDIT</td>
</tr>
<tr>
<td>SPLINE</td>
<td>SPLINEDIT</td>
</tr>
<tr>
<td>TEXT</td>
<td>DDEDIT</td>
</tr>
</tbody>
</table>
Mouse Buttons
You can change the standard behavior of pointing devices in the program.

Overview of Mouse Buttons

Mouse buttons define how a Windows system pointing device functions. You can customize the behavior of a mouse or other pointing device in the Customize User Interface (CUI) Editor. If a pointing device has more than two buttons, you can change the behavior of the second and third buttons. The first button on any pointing device cannot be changed in the Customize User Interface (CUI) Editor.

By using the Shift and Ctrl keys, you can create a number of combinations to suit your needs. Your pointing device can recognize as many commands as it has assignable buttons. The Mouse Buttons section of the tree node is organized by keyboard combination such as Click, Shift+Click, Ctrl+Click, and Ctrl+Shift+Click. The tablet buttons are numbered sequentially. Drag a command to assign the command to a mouse button. Create additional buttons by dragging commands to a Click node.

The following table shows the Click mouse button properties as they appear in the Properties pane.

<table>
<thead>
<tr>
<th>Properties for the Click Mouse Button</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Properties Pane Item</td>
<td>Description</td>
</tr>
<tr>
<td>Aliases</td>
<td>Specifies the aliases for the mouse button. Click the [ ] button to open the Aliases dialog box. Each alias in the CUIx file should be unique and it is used to reference the mouse button programmatically.</td>
</tr>
</tbody>
</table>

To add a mouse button combination

1. Click Manage tab ➤ Customization panel ➤ User Interface.
2. In the Customize User Interface Editor, click the Customize tab.
3 In the Customizations In <file name> pane, click the plus sign (+) next to Mouse Buttons to expand the list.

4 Right-click a mouse button section. Click New Button.

![Mouse Buttons](image)

A new mouse button (named Buttonn) is placed at the bottom of the selected list.

5 In the Command List pane, drag the command you want to add to the mouse button in the Customizations In <file name> pane.

6 Click Apply.

**Quick Reference**

**Commands**

CUI

Manages the customized user interface elements in the product.

**System Variables**

MBUTTONPAN

Controls the behavior of the third button or wheel on the pointing device.

**Accept Coordinate Entry in Button Menus**

When you click one of the buttons on a multi-button pointing device, the program reads not only the button number but also the coordinate of the crosshairs at the time you click. By carefully constructing macros, you can choose to either ignore the coordinate or use it with the command activated by the button.

As described in *Pause for User Input in Macros* on page 106, you can include a backslash (\) in a command to pause for user input. For the Mouse and Digitize Buttons menus, the coordinate of the crosshairs is supplied as user
input when the button is clicked. This occurs only for the first backslash in
the command; if the item contains no backslashes, the crosshairs coordinate
is not used. Consider the following commands:

```
line
line \n```

The first button starts the LINE command and displays the Specify First Point
prompt in the normal fashion. The second button also starts the LINE
command, but the program uses the current crosshairs location at the Specify
First Point prompt and displays the Specify Next Point prompt.

**Quick Reference**

**Commands**

**CUI**

Manages the customized user interface elements in the product.

**Legacy Interface Elements**

The term “legacy” refers to those user interface elements that are not
commonly used with the current version of the program, but are still supported
because some users prefer them to alternative user interface elements that are
now provided.

**Create Tablet Menus**

You can configure up to four areas of your digitizing tablet as menu areas for
command input.

The nodes in the Customize User Interface (CUI) Editor are labeled Tablet
Menu 1 through Tablet Menu 4 and define the macros associated with tablet
selections.

The tablet menu areas that you define with the Cfg option of the TABLET
command are divided into equal-sized menu selection boxes, which are
determined by the number of columns and rows you specify in each area.
These tablet menu selection boxes correspond directly with the lines that
follow the Tablet section labels from left to right and top to bottom (whether
or not they contain text).

For example, if you configure a menu area for five columns and four rows,
the command on the line immediately following the Row label corresponds
to the left-most selection box in the top row. The program can recognize up to 32,766 commands in each tablet section, which should be more than enough for any tablet menu.

You can add your own macros to the Macros cell in the Properties pane. The command labels in this area correspond to the 225 boxes at the top of your tablet template (rows A through I and columns 1 through 25). You can add a macro using standard command syntax. The following table shows the Click mouse button properties as they appear in the Properties pane.

<table>
<thead>
<tr>
<th>Properties pane item</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Aliases</td>
<td>Specifies the aliases for the tablet menu. Click the [ ] button to open the Aliases dialog box. Each alias in the CUIx file should be unique and it is used to reference the tablet menu programmatically.</td>
<td>TABLET1, TABLET1STD</td>
</tr>
<tr>
<td>Rows</td>
<td>Number of rows that can be customized for the tablet menu.</td>
<td>9</td>
</tr>
<tr>
<td>Columns</td>
<td>Number of columns that can be customized for the tablet menu.</td>
<td>25</td>
</tr>
</tbody>
</table>

To define rows and columns in a tablet menu

1. Click Manage tab ➤ Customization panel ➤ User Interface.
2. In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to Legacy to expand it.
3. Click the plus sign (+) next to Tablet Menus to expand it.
4. Click the plus sign (+) next to a tablet menu to expand it.
5. Click the row that you want to define.
6. In the Command List pane, locate the command you want to add.
7. Drag the command to a column.
8. Click Apply.
To clear a tablet menu assignment

1. Click Manage tab ➤ Customization panel ➤ User Interface.
2. In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to Legacy to expand it.
3. Click the plus sign (+) next to Tablet Menus to expand it.
4. Click the plus sign (+) next to a tablet menu to expand it.
5. Right-click the row or column that you want to clear. Click Clear Assignment.
6. Click Apply.

Quick Reference

Commands

CUI
Manages the customized user interface elements in the product.

TABLET
Calibrates, configures, and turns on and off an attached digitizing tablet.

Customize Tablet Buttons

To customize tablet buttons, you follow the same procedures as for customizing mouse buttons.

Tablet buttons are the buttons that are found on the pointing device, also known as a puck, used with a digitizer tablet. Pucks come in a variety of shapes, sizes, and button configurations. You can customize all the buttons on a puck except for the first button.

Some hardware manufacturers utilize a slightly different button layout from one puck to another. One might start with the first button in the upper-left corner and count across and down from 1 through F, while another might start in the upper-left corner and have a different numbering scheme.
NOTE It is important to test your button assignments as they are assigned to ensure the proper button is being mapped. You may need to refer to your owners manual that came with your puck for how the buttons are laid out.

To customize tablet buttons, you follow the same procedures as for customizing mouse buttons.

For more information about customizing tablet buttons, see Mouse Buttons on page 270.

Quick Reference

Commands

CUI

Manages the customized user interface elements in the product.

Create Image Tile Menus

The purpose of an image tile menu is to provide an image that can be selected instead of text. You can create, edit, or add image tiles and image tile slides.

An image tile dialog box displays images in groups of 20, along with a scrolling list box on the left that displays the associated slide file names or related text. If an image tile dialog box contains more than 20 slides, the additional slides are added to a new page. Next and Previous buttons are activated so that you can browse the pages of images.

The following is an example of an image tile menu.
You define an image tile menu in the Customize User Interface (CUI) Editor. The following table shows the properties for an image tile menu.

### Properties for the Tiled Viewport Layout image tile menu

<table>
<thead>
<tr>
<th>Properties pane item</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>String that is used only in the CUI Editor and is not displayed in the user interface.</td>
<td>Tiled Viewport Layout</td>
</tr>
<tr>
<td>Description</td>
<td>Text that describes the element and does not appear in the user interface.</td>
<td></td>
</tr>
<tr>
<td>Aliases</td>
<td>Specifies the aliases for the image tile menu. Click the [ ] button to open the Aliases dialog box. Each alias in the CUJx file should be unique and it is used to reference the image tile menu programmatically.</td>
<td>image_vporti</td>
</tr>
</tbody>
</table>

The following table shows the properties for an image tile slide.

### Properties of the Four: Equal tile slide on the Tiled Viewport Layout image tile menu

<table>
<thead>
<tr>
<th>Properties pane item</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>String displayed in the list box on the left side of the image tile menu dialog box. The string must include alphanumeric characters with no punctuation other than a hyphen (-) or an underscore (_).</td>
<td>Four: Equal</td>
</tr>
<tr>
<td>Command Name</td>
<td>The name of the command as it appears in the Command List pane.</td>
<td>Tiled Viewports, Four: Equal</td>
</tr>
<tr>
<td>Description</td>
<td>Text that describes the element; does not appear in the user interface.</td>
<td></td>
</tr>
<tr>
<td>Macro</td>
<td>The command macro. It follows the standard macro syntax.</td>
<td>^C^C-vports 4</td>
</tr>
<tr>
<td>Element ID</td>
<td>Tag that uniquely identifies a command.</td>
<td>MM_0427</td>
</tr>
</tbody>
</table>
Properties of the Four: Equal tile slide on the Tiled Viewport Layout image tile menu

<table>
<thead>
<tr>
<th>Properties pane item</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Slide library</td>
<td>A file that is made up of multiple slides and created using the file slidelib.exe.</td>
<td>acadlt</td>
</tr>
<tr>
<td>Slide label</td>
<td>Name of a slide contained in the slide library file or a slide image that is stored separately.</td>
<td>vport-4</td>
</tr>
</tbody>
</table>

You can use any slide generated by AutoCAD LT as an image. Keep the following suggestions in mind as you prepare slides for an image tile menu.

- **Keep the image simple.** When an image tile menu is displayed, you must wait for all images to be drawn before making a selection. If you show numerous complex symbols, use simple, recognizable images rather than full renditions.

- **Fill the box.** When making a slide for an image, be sure to fill the screen with the image before starting MSLIDE. If the image is very wide and short, or long and thin, the image tile menu will look best if you use PAN to center the image on the screen before making the slide. Images are displayed with an aspect ratio of 3:2 (3 units wide by 2 units high). If your drawing area has a different aspect ratio, it can be difficult to produce image slides that are centered in the image tile menu. If you work within a layout viewport that has an aspect ratio of 3:2, you can position the image and be assured that it will look the same when it is displayed in the image tile menu.

- **Remember the purpose of the images.** Do not use images to encode abstract concepts into symbols. Image tiles are useful primarily for selecting a graphic symbol.

**To create an image tile slide**

1. In AutoCAD LT, draw the geometry that you want to appear in the slide.

2. Click View tab ➤ Navigate panel ➤ Zoom drop-down ➤ Center.

3. At the Command prompt, enter `mslide`.

4. In the Create Slide File dialog box, specify the file name.

5. Click Save, and add it to a slide library file if desired. You can associate this image slide to a new image tile.
To view an image tile slide
1. At the Command prompt, enter `vslide`.
2. In the Select Slide File dialog box, browse to and select the slide file you want to view.
3. Click Open.
   The slide file should be displayed in the drawing window. Perform a Regen on the drawing to clear the slide file from the display.

To create an image tile slide library
1. Place all your slides in a single folder location that you want to add to a slide library.
2. Click Start menu ➤ (All) Programs ➤ Accessories ➤ Command Prompt.
3. At the DOS prompt, enter `CD <folder location of slides>`.
   As an example: `CD "c:\slides`.
4. While in the location of the slide files, enter `dir *.sld /b > <file name>`.
   As an example: `dir *.sld /b > "myslides”`
   A text file will be created with the names of the slide files contained in the current folder.
5. With the text file created of all the slide files in the current folder, enter `<AutoCAD LT Install folder>\slidelib.exe <slide library file name> < <text file with slide names>`.
   As an example: “C:\Program Files\AutoCAD LT 2011\slidelib.exe” “myslidelib” < “myslides”
6. When you finish, close the DOS window.

**WARNING** After you create the slide library, place the individual slide files in a safe place so they do not accidently get deleted. This is important if you need to rebuild the slide library one day.

To create an image tile menu and assign an image tile slide

1. Click Manage tab ➤ Customization panel ➤ User Interface.
2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to Legacy to expand the list.

3 In the Legacy list, right-click Image Tile Menu. Click New Image Tile Menu.
   A new image tile menu (named ImageTileMenu1) is placed at the bottom of the Image Tile Menus tree.

4 Do one of the following:
   ■ Enter a new name over the default name ImageTileMenu1.
   ■ Right-click ImageTileMenu1. Click Rename. Then, enter a new image tile name.
   ■ Click ImageTileMenu1, wait, and click again over the image tile’s name again to edit its name in-place.

5 In the Command List pane, drag a command to the new image tile menu in the Customizations In <file name> pane.

6 In the Properties pane, enter the properties for the new image tile slide as follows:
   ■ In the Name box, enter the text to display in the list box for the image tile.
   ■ In the Description box, enter a description for the image tile.
   ■ In the Slide library box, enter the name of the image tile slide library that contains the slide for the image tile. The image tile slide library must be in one of the folders that defines the Support File Search Path. If you do not have a slide library, but rather an image tile slide file, you enter its name in the image tile slide library box.
   ■ In the Slide label box, enter the name of the image tile slide file contained in the image tile slide library listed in the Slide library box.

7 Click Apply.
Quick Reference

Commands
CUI
Manages the customized user interface elements in the product.
MSLIDE
Creates a slide file of the current model viewport or the current layout.
VSLIDE
Displays an image slide file in the current viewport.

Customize Workspaces
You can customize workspaces to create a drawing environment that displays only those commands on the Quick Access toolbar, toolbars, menus, ribbon tabs, and palettes that you select.

Overview of Workspace Customization
Customization options for workspaces include creating a workspace using the Customize User Interface (CUI) Editor, changing the properties of a workspace, and displaying a toolbar in all workspaces.

Create or Modify a Workspace Outside the Customize User Interface Editor
The easiest way to create or modify user interface elements in a workspace is by customizing them in the application window. From the application window, you can control the display and appearance of several of the most commonly used user interface elements.

Once you customize the workspace, you can save the changes to an existing or new workspace using the WSAVE command. Once saved, you can access the workspace any time you need to draw within that workspace environment. For more information about customizing workspaces without the Customize User Interface Editor, see Control User Interface Elements Outside the CUI Editor on page 293.

Create or Modify a Workspace Using the Customize User Interface Editor
In the Customize User Interface (CUI) Editor, you can create or modify workspaces with precise properties associated with the application and drawing
windows, and user interface elements (Quick Access toolbar, toolbars, menus, ribbon tabs, and palettes).

You customize a workspace by selecting a workspace from the Workspaces node in the Customizations In pane. The Workspace Contents and Properties panes are displayed. To modify a workspace, you click the Customize Workspace button in the Workspace Contents pane.

For more information about customizing workspaces with the Customize User Interface Editor, see Control User Interface Elements in the CUI Editor on page 296.

After you click Customize Workspace in the Workspace Contents pane, the Customizations In pane lists the user interface elements that can be added to the workspace that is currently being modified. Check boxes are displayed next to each user interface element in the loaded CUIx files. You use the check boxes to add or remove user interface elements from a workspace.
Change the Properties of a Workspace

In the Customize User Interface (CUI) Editor, you can define workspace properties, such as the workspace name, description, whether the Model or layout tab is displayed or not, and so on. The following table shows the AutoCAD LT Classic workspace properties as they appear in the Properties pane.

<table>
<thead>
<tr>
<th>Properties Pane Item</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>String displayed in the drop-down box on the Workspaces toolbar, at the command prompt for the WORKSPACE command, under the Workspaces menu item in the Tools menu, and in the CUI Editor.</td>
<td>AutoCAD LT Classic</td>
</tr>
<tr>
<td>Description</td>
<td>Text that describes the workspace; does not appear in the user interface.</td>
<td></td>
</tr>
<tr>
<td>Start On</td>
<td>Determines if the Model tab, last active layout tab, or the current active tab in the drawing is displayed when the workspace is restored or set current.</td>
<td>Model</td>
</tr>
<tr>
<td>Menu bars</td>
<td>Determines if the menu bar is displayed or not when the workspace is restored or set current.</td>
<td>On</td>
</tr>
<tr>
<td>Status bars</td>
<td>Determines if the status bars for the drawing window or application are displayed or not when the workspace is restored or set current. The available options are Application Only, All Off, All On, or Drawing Status Bar Only.</td>
<td>Application only</td>
</tr>
<tr>
<td>Model/Layout tabs</td>
<td>Determines if the Model/layout tabs are visible or not in the drawing window when the workspace is restored or set current.</td>
<td>On</td>
</tr>
<tr>
<td>Scroll bars</td>
<td>Determines if the scroll bars are visible or not when the workspace is restored or set current.</td>
<td>On</td>
</tr>
</tbody>
</table>

Import a Workspace to a Main CUIx File

You can import a workspace to the main CUIx file using the Transfer tab of the Customize User Interface (CUI) Editor. Workspaces in partially loaded
CUIx files must be transferred to the main CUIx file if you want to set that workspace current.

**Set the Default Workspace**
Workspaces in a CUIx file can be marked as default. This identifies which workspace in the CUIx file should be restored when the CUIx file is loaded into the program the first time, or after the CUIx file has been loaded with the CUILOAD command.

**Set a Workspace Current**
Once a workspace is created or modified, it must be set current before the workspace can be used to control the current display of the user interface. You set workspaces current through the user interface or the Customize User Interface (CUI) Editor. From the user interface, you can set a workspace current with the Workspaces toolbar, Workspace Switching button on the status bar, Tools menu on the menu bar, and the WORKSPACE command.

You can also use the /w command line switch to set a workspace current when you double-click the desktop shortcut to start AutoCAD LT. For more information about command line switches, see Customize Startup in the *User’s Guide*.

**To create a workspace using the CUI Editor**

1. Click Manage tab ➤ Customization panel ➤ User Interface.
2. In the Customize User Interface Editor, Customize tab, in the Customizations In `<file name>` pane, right-click the Workspaces tree node, and select New Workspace.

A new, empty workspace (named Workspace1) is placed at the bottom of the Workspaces tree node.
3 Do one of the following to rename the workspace:
   ■ Enter a new name over the default name Workspace1.
   ■ Right-click Workspace1. Click Rename. Then, enter a new workspace name.
   ■ Click Workspace1, wait, and click again over the workspace's name again to edit its name in-place.

4 In the Workspace Contents pane, click Customize Workspace.

5 In the Customizations In <file name> pane, click the plus sign (+) next to the tree nodes to expand them.

   **NOTE** The Quick Access toolbars, ribbon tabs, toolbars, menus, and partial CUIx file nodes now display check boxes next to them so you can easily add elements to the workspace.

6 Click the check box next to each user interface element that you want to add to the workspace.

   The selected user interface elements are added to the workspace.

7 In the Workspace Contents pane, click Done.
8 Click Apply.

To save or create a workspace from the user interface

Do one of the following:

- **To save a workspace from the Workspaces toolbar**

  1 Right-click over one of the visible toolbars that is currently displayed in the user interface and click Workspaces.

    A check mark is displayed to the left of any toolbar that is currently displayed.

  2 On the Workspaces toolbar, click the drop-down list and select Save Current As.

    In the Save Workspace dialog box, Name box, enter a name to create a new workspace or select an existing workspace from the drop-down list to overwrite it.
4 Click Save to create or modify the workspace.

■ To save a workspace from the status bar

1 On the status bar, click Workspace Switching. Then click Save Current As.

2 In the Save Workspace dialog box, Name box, enter a name to create a new workspace or select an existing workspace from the drop-down list to overwrite it.

3 Click Save to create or modify the workspace.

**NOTE** You can also save a workspace from the Quick Access toolbar.

To change the properties of a workspace

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the workspace whose properties you want to change.
3 In the Properties pane, do any of the following:
  ■ In the Name box, enter a name for the workspace.
  ■ In the Description box, enter a description.
  ■ In the Start On box, select an option (Model, Layout, Do Not Change).
  ■ In the Menu Bar box, select an option (Off, On).
  ■ In the Status Bar box, select an option (Application Only, All Off, All On, Drawing Status Bar Only).
  ■ In the Model/Layout Tab box, select an option (On, Off, Do Not Change).
  ■ In the Scroll Bars box, select an option (On, Off, Do Not Change).

4 Click Apply.

To duplicate a workspace

1 Click Manage tab ➤ Customization panel ➤ User Interface.
2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to Workspaces to expand it.
3 Right-click the workspace you want to duplicate. Click Duplicate.
A duplicate of the workspace (named Copy of <workspace name>) is placed at the bottom of the Workspaces tree node).

4 Do one of the following to rename the duplicate workspace:
   ■ Enter a new name over the default name Copy Of <workspace name>.
   ■ Right-click Copy Of <workspace name>. Click Rename. Enter a new name for the workspace.
   ■ Click Copy Of <workspace name>, wait, and click again over the workspace’s name again to edit its name in-place.

5 Modify the workspace as necessary.

6 Click Apply.

To set a workspace current from the user interface
Do one of the following:

■ To set a workspace current from the Workspaces toolbar
   ■ On the Workspaces toolbar, click the drop-down list and select the workspace you want to set current.

If the Workspaces toolbar is not displayed, right-click over one of the visible toolbars that is currently displayed in the user interface and click Workspaces.
To set a workspace current from the status bar

- On the status bar, click Workspace Switching. Then click the workspace you want to set current.

NOTE You can also set a workspace from the Quick Access toolbar.

To set a workspace current from the Tools menu on the menu bar

- On the menu bar, click Tools menu ➤ Workspaces ➤ select the workspace you want to set current.

To set a workspace current from the CUI Editor

1. Click Manage tab ➤ Customization panel ➤ User Interface.

2. In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to Workspaces to expand it.

3. Right-click the workspace you want to set current. Click Set Current.
4  Click Apply.

To restore the “classic” workspace

■  From the status bar, click Workspace Switching. Click AutoCAD LT Classic.

To set a workspace as default

1  Click Manage tab ➤ Customization panel ➤ User Interface.

2  In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to Workspaces to expand it.

3  Right-click the workspace you want to set as default. Click Set Default.

4  Click Apply.

To restore a workspace with a command line switch

1  Right-click the program icon on the Windows desktop. Click Properties.
2 In the AutoCAD LT Properties dialog box, Shortcut tab, in the Target box, edit the parameters for the switch using the following syntax:

```
drive:\pathname\acadlt.exe" [/switch “name”]
```

For Example, enter “d:\AutoCAD LT 2011\acadlt.exe" /w ”MyWorkspace”

3 Click OK.

To import a workspace to a main CUIx file

1 Click Manage tab ➤ Customization panel ➤ User Interface. The Transfer tab is displayed, with the main CUIx file displayed in the Customizations In <file name> pane (left side).

2 In the Customize User Interface Editor, Transfer tab, in the Customizations In <file name> pane (right side), click the Open Customization File button.
3. In the Open dialog box, locate and select the customization file that contains the workspace you want to add to the main CUIx file.

4. In the Customizations In `<file name>` pane (right side), drag the workspace from the CUIx file to the Workspaces node of the main CUIx file in the Customizations In `<file name>` pane (left side).

5. Click Apply.

**Quick Reference**

**Commands**

CUI

Manages the customized user interface elements in the product.

CUIEXPORT

Exports customized settings from the main CUIx file to an enterprise or partial CUIx file.

CUIIMPORT

Imports customized settings from an enterprise or partial CUIx file to the main CUIx file.
CUILOAD
Loads a CUIx file.

CUIUNLOAD
Unloads a CUIx file.

WORKSPACE
Creates, modifies, and saves workspaces and makes a workspace current.

WSSAVE
Saves a workspace.

System Variables

WSCURRENT
Returns the current workspace name at the Command prompt and sets a workspace to current.

Control User Interface Elements Outside the CUI Editor

Workspaces can be created and modified from the user interface with some limitations.

With the CUI Editor, you can customize the following user interface elements with a workspace:

- Quick Access toolbar
- Ribbon tabs
- Toolbars
- Palettes

Control the Display of the Quick Access Toolbar

Customization of the Quick Access toolbar outside the Customize User Interface Editor is limited to controlling the placement of the Quick Access toolbar in relation to the ribbon, and adding or removing commands. To place and customize the Quick Access toolbar, you right-click the Quick Access toolbar or click the Customize button located on the far right end of the Quick Access toolbar.
The Customize button displays a menu where you add or remove the commands currently assigned to the Quick Access toolbar. You can also add buttons on the ribbon to the Quick Access toolbar. With the CUI Editor, you can create new Quick Access toolbars, which you can assign to a workspace. To create a new Quick Access toolbar, see Quick Access Toolbars on page 142.

**Control the Display of the Ribbon Panels and Tabs on the Ribbon**
You can control the display of ribbon panels and tabs from the ribbon shortcut menu. You can display one of the ribbon tabs assigned to the current workspace or one of the ribbon panels assigned to the active ribbon tab. To control which ribbon tabs and panels are assigned to the current workspace, see Control User Interface Elements in the CUI Editor on page 296.

**Control the Display of Toolbars**
You can display toolbars with the toolbar shortcut menu and the Tools menu on the menu bar. You select the toolbar you want to display. On the Tools menu, the Toolbars submenu contains all the toolbars in the loaded CUIx files.

With the CUI Editor, you can create new toolbars, which can be assigned to and displayed with a workspace. Along with creating new toolbars, you can also modify existing toolbars to display the commands you frequently use. For information about creating and modifying toolbars, see Create and Edit Toolbars on page 190.

**Control the Display of Palettes**
Palettes are displayed using the ribbon, the Tools menu on the menu bar, or by entering a command. Once a palette is displayed, you can control many of the visual aspects of a palette from the application window. You can specify the position, size, transparency, and docking of a palette. For information about controlling the display of a palette, see Specify the Behavior of Dockable Windows in the User’s Guide.

See also:
- Control User Interface Elements in the CUI Editor on page 296
- To display the Quick Access toolbar above or below the ribbon from the user interface on page 295 (Procedure)
- To display toolbars from the user interface on page 295 (Procedure)
To control the display of ribbon tabs and panels on the ribbon from the user interface on page 295 (Procedure)

To display palettes from the user interface on page 295 (Procedure)

To display the Quick Access toolbar above or below the ribbon from the user interface

1. Right-click on the Quick Access toolbar.
2. Do one of the following:
   - Click Show Quick Access Toolbar Below the Ribbon to display the Quick Access toolbar below the ribbon.
   - Click Show Quick Access Toolbar Above the Ribbon to display the Quick Access toolbar above the ribbon.

To display toolbars from the user interface

Do one of the following:
- On the menu bar, click Tools menu ➤ Toolbars, and click one of the listed toolbars.
  If the menu bar is not displayed, on the Quick Access toolbar, click the Customize button. Click Show Menu Bar.
- Right-click a visible toolbar, and click one of the listed toolbars.

To control the display of ribbon tabs and panels on the ribbon from the user interface

1. Right-click on the ribbon.
2. Do one of the following:
   - Click Tabs, and click the ribbon tab to display or hide.
   - Click Panels, and click the ribbon panel to display or hide.

To display palettes from the user interface

Do one of the following:
- On the ribbon, View tab ➤ Palettes panel, and click the buttons to display the desired palette.
■ On the menu bar, click Tools menu ➤ Palettes, and click the desired palette.

■ At the Command prompt, enter the command to display the desired palette and press Enter.

Quick Reference

Commands

CUI

Manages the customized user interface elements in the product.

System Variables

MENUBAR

Control User Interface Elements in the CUI Editor

The Customize User Interface (CUI) Editor provides a wide range of options to create and modify all the content that can be displayed with a workspace. With the CUI Editor, you can customize the following user interface elements with a workspace:

■ Application and drawing windows
■ Quick Access toolbar
■ Ribbon tabs
■ Toolbars
■ Menus
■ Palettes

Control the Display of User Interface Elements on the Application and Drawing Windows

Workspaces control the display of user interface elements such as toolbars and the menu bar. While a workspace primarily provides toolbars, menus, ribbon tabs, and palettes, you can also use a workspace to control user interface
elements for the application and drawing windows. A workspace can control the following:

■ Which layout tab is set current when a drawing is opened
■ Display of the menu bar
■ Display of the application and drawing status bars
■ If layout tabs are displayed along the bottom of the drawing window.
■ Display of the legacy screen menu
■ Display of scroll bars in the drawing window

Control the Display of the Quick Access Toolbar
The Quick Access toolbar that is displayed on the application window is controlled by the current workspace. While a workspace does not directly control which commands are displayed on the Quick Access toolbar, it does control which Quick Access toolbar in the loaded CUIx files is displayed. For information about creating and editing Quick Access toolbars, see Quick Access Toolbars on page 142.

Control the Display of Ribbon Tabs and Panels on the Ribbon
The display and order of ribbon tabs and panels on the ribbon are controlled through workspaces. You add and specify the order of ribbon tabs and their associated panels in the Workspace Contents pane. You add ribbon panels to a ribbon tab through the Customizations In <file name> pane.

After you assign ribbon tabs to a workspace, you can control the default display and behavior of both ribbon tabs and panels through the Properties pane. From the Properties pane, you can set the Tool Palette Group for a ribbon tab and orientation and resize order for a ribbon panel. For information about creating and editing ribbon content, see Ribbon on page 148 under Customize User Interface Elements on page 139.

Control the Display of Toolbars
You can control which toolbars are displayed and how they are positioned in the application window (if they are floating or docked, and where they are in the application window). You add the toolbars through the Workspace Contents pane, and control the appearance of the toolbars in the Properties pane. For information about creating and editing toolbars, see Toolbars on page 190 under Customize User Interface Elements on page 139.
Control the Display of Menus on the Menu Bar

Menus and the order in which they are displayed on the menu bar can only be controlled through the Workspace Contents pane. By default the menu bar is not displayed when the ribbon is. Set the system variable MENUBAR to 1 to display the menu bar above the ribbon. You can also set the Menu Bar property for a workspace to On to display the menu bar each time a workspace is set current. For information about creating and editing pull-down menus, see Pull-down and Shortcut Menus on page 212 under Customize User Interface Elements on page 139.

Control the Display of Palettes

You set up a workspace to control the display, position, and appearance of palettes in the application window. They can be floating or docked. Unlike ribbon panels, ribbon tabs, and menus, palettes are available in any workspace. You can turn palettes on or off with a workspace. The display properties of palettes are modified through the Workspace Contents and Properties pane. For information about controlling palettes with workspaces, see Control the Appearance of Palettes on page 312.

See also:
- To display a Quick Access toolbar on page 299 (Procedure)
- To display the Quick Access toolbar above or below the ribbon from the CUI Editor on page 300 (Procedure)
- To display ribbon tabs from the CUI Editor on page 301 (Procedure)
- To reposition a ribbon tab on the ribbon on page 302 (Procedure)
- To reposition a ribbon panel on a ribbon tab on page 303 (Procedure)
- To control the display of ribbon tabs on the ribbon on page 304 (Procedure)
- To control the display of ribbon panels for a ribbon tab on page 304 (Procedure)
- To associate a tool palette group with a ribbon tab on page 305 (Procedure)
- To display toolbars using the CUI Editor on page 306 (Procedure)
- To change the properties of a toolbar on page 307 (Procedure)
- To display menus on the menu bar on page 308 (Procedure)
To display a quick access toolbar

1. Click Manage tab ➤ Customization panel ➤ User Interface.
2. In the Customize User Interface Editor, Customize tab, in the Customizations in `<file name>` pane, click the plus sign (+) next to the Workspaces node to expand it.
3. Select the workspace that you want to modify.
4. In the Workspace Contents pane, click Customize Workspace.
5. In the Customizations in `<file name>` pane, click the plus (+) next to the Quick Access Toolbars tree node or Partial Customization Files tree node to expand it.
6. Click the check box next to the Quick Access toolbar to add it to the workspace.
7. In the Workspace Contents pane, click Done.
NOTE Make sure to set the workspace current to ensure the changes are displayed.

8 Click Apply.

To display the Quick Access toolbar above or below the ribbon from the CUI Editor

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to the Workspaces node to expand it.

3 Select the workspace that you want to modify.

4 In the Workspace Contents pane, click the Quick Access Toolbar tree node.

5 In the Properties pane, click the Orientation box and select Above or Below from the drop-down list.
   Above displays the Quick Access Toolbar above the ribbon, while below sets the Quick Access Toolbar below the ribbon.

6 Click Apply.
To display ribbon tabs from the CUI Editor

1  Click Manage tab ➤ Customization panel ➤ User Interface.

2  In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to the Workspaces node to expand it.

3  Select the workspace that you want to modify.

4  In the Workspace Contents pane, click Customize Workspace.

5  In the Customizations In <file name> pane, click the plus sign (+) next to the Ribbon Tabs tree node or Partial Customization Files tree node to expand it.

6  Click the check box next to each ribbon tab that you want to add to the workspace.

   In the Workspace Contents pane, the selected elements are added to the workspace.

7  In the Workspace Contents pane, click Done.
NOTE Make sure to set the workspace current to ensure the changes are displayed.

8 Click Apply.

To reposition a ribbon tab on the ribbon

1 Click Manage tab ➤ Customization panel ➤ User Interface.
2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to the Workspaces node to expand it.
3 Select the workspace that has the ribbon tab you want to reposition.
4 In the Workspace Contents pane, click the plus sign (+) next to the Ribbon Tabs tree node to expand it.
5 Drag the ribbon tab into the new location.

A splitter bar shows the new location for the ribbon tab.
Once the splitter bar is in the place where you want to insert the ribbon tab, release the pointing device button.

**NOTE** Make sure to set the workspace as current to ensure the changes are displayed.

Click Apply.

**To reposition a ribbon panel on a ribbon tab**

1. Click Manage tab ➤ Customization panel ➤ User Interface.

2. In the Customize User Interface Editor, Customize tab, in the Customizations In `<file name>` pane, click the plus sign (+) next to the Workspaces node to expand it.

3. Select the workspace that you want to modify.

4. In the Workspace Contents pane, click the plus sign (+) next to the Ribbon Tabs tree node to expand it.

5. Click the plus sign (+) next to the ribbon tab with the ribbon panel that you want to reposition to expand it.

6. Drag the ribbon panel into the new location.

A splitter bar shows the new location for the ribbon panel.

7. Once the splitter bar is in the place where you want to insert the ribbon panel, release the pointing device button.
NOTE Make sure to set the workspace as current to ensure the changes are displayed.

8  Click Apply.

To control the display of ribbon tabs on the ribbon

1  Click Manage tab ➤ Customization panel ➤ User Interface.

2  In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to the Workspaces node to expand it.

3  Select the workspace that has the ribbon tab you want to change.

4  In the Workspace Contents pane, click the plus sign (+) next to the Ribbon Tabs tree node to expand it.

5  Select the ribbon tab that you want to change.

6  In the Properties pane, do any of the following:
   ■  In the Show box, select an option (Yes or No).
   ■  In the ToolPalette Group box, select one of the listed tool palette groups.

7  Click Apply.

To control the display of ribbon panels for a ribbon tab

1  Click Manage tab ➤ Customization panel ➤ User Interface.

2  In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to the Workspaces node to expand it.

3  Select the workspace that has the ribbon tab for which you want to change the properties of the ribbon panels.
4 In the Workspace Contents pane, click the plus sign (+) next to the Ribbon Tabs tree node to expand it.

5 Click the plus sign (+) next to the ribbon tab for which you want to change the properties of the ribbon panels.

6 Select the ribbon panel that you want to change.

7 In the Properties pane, do any of the following:
   ■ In the Show box, select an option (Yes or No).
   ■ In the Orientation box, select an option (Docked or Floating).

8 Click Apply.

To associate a tool palette group with a ribbon tab

1 At the Command prompt, enter `toolpalettes`.

2 Click Manage tab ➤ Customization panel ➤ User Interface.

3 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to the Workspaces node to expand it.

4 Select the workspace that has the ribbon tab for which you want to assign a tool palette group.

5 In the Workspace Contents pane, click the plus sign (+) next to the Ribbon Tabs node to expand it.

6 Select the ribbon tab that you want to assign a tool palette group.

7 In the Properties pane, in the ToolPalette Group box, click the down arrow and select the tool palette group you want to assign to the ribbon tab.
NOTE The Tool Palettes window must be displayed before you can assign a tool palette group to a ribbon tab.

8 Click Apply.

To display toolbars using the CUI Editor

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to the Workspaces tree node to expand it.

3 Select the workspace that you want to modify.

4 In the Workspace Contents pane, click Customize Workspace.

5 In the Customizations In <file name> pane, click the plus sign (+) next to the Toolbars tree node, or Partial Customization Files tree node to expand it.

6 Click the check box next to each toolbar that you want to add to the workspace.
In the Workspace Contents pane, the selected elements are added to the workspace.

7. In the Workspace Contents pane, click Done.

**NOTE** Make sure to set the workspace current to ensure the changes are displayed.

8. Click Apply.

**To change the properties of a toolbar**

1. Click Manage tab ➤ Customization panel ➤ User Interface.

2. In the Customize User Interface Editor, Customize tab, in the Customizations In *<file name>* pane, click the workspace that contains the toolbar you want to modify.

3. In the Workspace Contents pane, click the plus sign (+) next to the Toolbars tree node to expand it.
4 Select the toolbar that you want to modify.

5 In the Properties pane, do any of the following:
   - In the Orientation box, select an option (Floating, Top, Bottom, Left, or Right).
   - In the Default X Location box, enter a number. A value of 0 starts the location of the toolbar at the left edge of the screen, as the number increases the further from the left the toolbar is placed. (Available only if Orientation is set to Floating.)
   - In the Default Y Location box, enter a number. A value of 0 starts the location of the toolbar at the top edge of the screen, as the number increases the further from the top the toolbar is placed. (Available only if Orientation is set to Floating.)
   - In the Rows box, enter a number. Enter a number to have the buttons on the toolbar wrap around to create the number of rows if possible. 0 is the default value. (Available only if Orientation is set to Floating.)

6 Click Apply.

**To display menus on the menu bar**

1 Click Manage tab ➤ Customization panel ➤ User Interface.
2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to the Workspaces node to expand it.

3 Select the workspace that you want to modify.

4 In the Workspace Contents pane, click Customize Workspace.

5 In the Customizations In <file name> pane, click the plus sign (+) next to the Menus tree node, or Partial Customization Files tree node to expand it.

6 Click the check box next to each menu that you want to add to the workspace.

In the Workspace Contents pane, the selected elements are added to the workspace.

7 In the Workspace Contents pane, click Done.
NOTE Make sure to set the workspace current to ensure the changes are displayed.

8 Click Apply.

To reposition menus on the menu bar

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to the Workspaces node to expand it.

3 Select the workspace that you want to modify.

4 In the Workspace Contents pane, click the plus (+) next to the Menus node to expand it.

5 Drag the pull-down menu into the new location.

A splitter bar shows the new location for the pull-down menu.

6 Once the splitter bar is in the place where you want to insert the menu, release the pointing device button.
NOTE Make sure to set the workspace current to ensure the changes are displayed.

7 Click Apply.

To display a palette using the CUI Editor

1 Click Manage tab ➤ Customization panel ➤ User Interface.

2 In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the plus sign (+) next to the Workspaces node to expand it.

3 Select the workspace that you want to modify.

4 In the Workspace Contents pane, click the plus sign (+) next to the Palettes node to expand it.
5 Select the palette you want to display.
6 In the Properties pane, under Appearance, Show box, click the drop-down list and select Show.
7 Click Apply.

Quick Reference

Commands

CUI

Manages the customized user interface elements in the product.

Control the Appearance of Palettes

You can use workspaces to control the display and appearance of palettes.

Many windows, known as palettes, can be set to be docked, anchored, or floated in the application window. You can define the size, location, or appearance of these windows by changing their properties in the Workspace Contents pane of the Customize User Interface (CUI) Editor. These dockable windows include:

- Command Line
- DesignCenter
- External References
- Layer Properties Manager
- Markup Set Manager
- Properties
- QuickCalc
- Ribbon
- Tool Palette
The following table shows the properties as they appear in the Properties pane for a palette in the CUI Editor and as an example, the default values of the Tool Palettes window in the AutoCAD LT Classic workspace.

<table>
<thead>
<tr>
<th>Properties pane item</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show</td>
<td>Visibility state of the palette. The available options are No, Yes, or Do Not Change. Do Not Change keeps the last used state of the palette when the workspace is restored or set current.</td>
<td>Yes</td>
</tr>
<tr>
<td>Orientation</td>
<td>The on screen docking or floating state of the palette. The available options are Floating, Top, Bottom, Left, Right, or Do Not Change. Do Not Change keeps the last used state of the palette when the workspace is restored or set current. Some palettes like the Command Line also support a dock location of Top and Bottom.</td>
<td>Floating</td>
</tr>
<tr>
<td>Allow Docking</td>
<td>Controls if the user can dock the palette by dragging it to one of the designated docking areas. The available options are No, Yes, or Do Not Change. Do Not Change maintains the last used setting for the palette when the workspace is restored or set current.</td>
<td>Yes</td>
</tr>
<tr>
<td>Auto Hide</td>
<td>Controls if the palette rolls up when not in use. The available options are On, Off, or Do Not Change. Do Not Change maintains the last used setting for the palette when the workspace is restored or set current.</td>
<td>Off</td>
</tr>
<tr>
<td>Use Transparency</td>
<td>Controls if the palette appears transparent. The available options are No, Yes, or Do Not Change. Do Not Change maintains the last used setting for the palette when the workspace is restored or set current.</td>
<td>No</td>
</tr>
<tr>
<td>Transparency Amount</td>
<td>Controls how opaque the palette is displayed. The valid range is 0 through 100.</td>
<td>0</td>
</tr>
<tr>
<td>Default Group</td>
<td>Controls which of the user defined palette groups should be displayed.</td>
<td>All Palettes</td>
</tr>
</tbody>
</table>
Properties for the Tool Palettes window under the AutoCAD LT Classic workspace

<table>
<thead>
<tr>
<th>Properties pane item</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Height</td>
<td>Determines how tall the palette is when it is floating.</td>
<td>598</td>
</tr>
<tr>
<td>Width</td>
<td>Determines how wide the palette is when it is floating.</td>
<td>172</td>
</tr>
</tbody>
</table>

See also:

- To change the properties of a palette on page 314 (Procedure)

To change the properties of a palette

1. Click Manage tab ➤ Customization panel ➤ User Interface.
2. In the Customize User Interface Editor, Customize tab, in the Customizations In <file name> pane, click the workspace that contains the palette you want to modify.
3. In the Workspace Contents pane, click the plus sign (+) next to Palettes to expand the list.
4. Click the palette that you want to modify.
5. In the Properties pane, do any or all of the following:
   - In the Show box, select an option (No, Yes, or Do Not Change).
In the Orientation box, select an option (Floating, Top, Bottom, Left, or Right).

In the Allow Docking box, select an option (No, Yes, or Do Not Change).

**NOTE** To specify that a window should be anchored, set Orientation to Left, Right, Top, or Bottom, and set Auto Hide to On.

In the Auto Hide box, select an option (On, Off, or Do Not Change).

In the Use Transparency box, select an option (No, Yes, or Do Not Change).

In the Transparency Amount box, enter a number (if applicable).

In the Default Group box, select a Tool Palette group (Tool Palettes window only).

In the Height box, enter a number. A value of 0 is equivalent to Do Not Change.

In the Width box, enter a number. A value of 0 is equivalent to Do Not Change.

6 Click Apply.

**Quick Reference**

**Commands**

**CUI**

Manages the customized user interface elements in the product.
Transfer and Migrate Customization

You can transfer and migrate data from a customization or menu file from an earlier release using the Customize User Interface (CUI) Editor and the Migrate Custom Settings dialog box.

Transfer Customization

The Customize User Interface (CUI) Editor can be used to transfer data in a CUI, MNU, or MNS file to a CUIx file without modifying the original customization or menu file. The new customization file that is created has the same name as the original file, but with a .cuix extension.

You can also transfer customization information between files. For example, you can transfer toolbars from a partial CUIx file to the main CUIx file so that the program can display the toolbar information. In addition, you can move customizations from the main CUIx file to partial CUIx files, or from a partial CUIx file to another partial CUIx file.

NOTE All elements can be transferred between two CUIx files with the exception of the property settings defined under the Quick Properties and Rollover Tooltips nodes.

If you transfer user interface elements that reference other user interface elements, such as a flyout, all the relevant information for that interface element is also transferred. For example, if you transfer the Draw toolbar, which references the Insert toolbar, the Insert toolbar is also transferred.

NOTE Button images may not appear in the program when you transfer a toolbar, pull-down menu, or ribbon panel from a CUIx file. If the images are loaded from an image file, those images must reside in a folder that is defined in the Options dialog box, Files tab under Support File Search Path or Custom Icon Location. If the images come from a third-party resource DLL, contact the party who created the resource DLL.

The following is an example of the Customize User Interface (CUI) Editor, Transfer tab. You use this tab to transfer user interface customization.
Migrate Customization

As you make changes to the customization in a CUIx file, the changes are automatically tracked. The tracked changes are used when migrating customization from release to release with the Migrate Custom Settings dialog box. In the Migrate Custom Settings dialog box, you can migrate any changes made to the standard CUIx files that come with the program with the new shipping versions of the files with the same name. You can avoid manually migrating customization, which might result in the loss of customization.

NOTE The Migrate Custom Settings dialog box can be used to migrate user interface customization from previous releases. To access the Migrate Custom Settings dialog box, click Start menu (Windows) ➤ All Programs (or Programs) ➤ Autodesk ➤ AutoCAD LT 2011 ➤ Migrate Custom Settings.
To transfer customizations

1. Click Manage tab ➤ Customization panel ➤ Import Customizations.

2. In the Customize User Interface Editor, Transfer tab, in the left pane, click the Open Customization File button.

3. In the Open dialog box, locate the customization file (MNU, MNS, CUI, or CUIx) from which you want to import customizations, and select it. Click Open.

4. In the right pane, click the Open Customization File button.

5. In the Open dialog box, locate the customization file (MNU, MNS, CUI, or CUIx) to which you want to export customizations, and select it. Click Open.

6. In the left pane, click the plus sign (+) next to an interface element node to expand it. Expand the corresponding node in the right pane.

7. Drag interface elements from the right pane to the appropriate location in the left pane.

**NOTE** Interface elements can be dragged in either direction, from the left to the right pane or the right to the left pane.

8. Click Apply.
Quick Reference

Commands

CUI
Manages the customized user interface elements in the product.

CUIEXPORT
Exports customized settings from the main CUIx file to an enterprise or partial CUIx file.

CUIIMPORT
Imports customized settings from an enterprise or partial CUIx file to the main CUIx file.

Customize User Interface (CUI) Editor FAQs

FAQs will help you to find answers to some of the most commonly asked questions about using the Customize User Interface (CUI) Editor.

Migrating/Upgrading

How do I get my menu customization from a previous release to work in the new release?

In past releases this had to be done through a text editor, such as Notepad. With the CUI Editor, you use the Transfer tab to browse and select your MNS/MNU, CUI, or CUIx file that contains your menu customization. Once the previous customization file has been selected, you drag the user interface elements between two CUIx files. See To transfer customizations on page 318 for more information.

Commands

How do I create a new command and add it to a user interface element, such as a pull-down menu?

Commands are created and managed through the Command List pane located in the lower-left corner of the Customize tab of the CUI Editor. See To create a command on page 95 for more information.

Once the command has been created, it can be added to or used to create a number of different user interface elements. To add the command to a menu
for example, expand the menu under the Menus node in the Customizations pane that you want to add the command to and then drag the command under the menu. See To create a pull-down menu on page 214 for more information.

**Menus**

**Why doesn't my menu display on the menu bar?**

Workspaces are used to control the display of menus on the menu bar. See To display menus on the menu bar on page 308 for more information.

**How do I change the order of a pull-down menu?**

Workspaces are used to control the positioning of menus on the menu bar. See To reposition menus on the menu bar on page 310 for more information.

**Toolbars**

**Why do my toolbars not stay in the same place after I close and restart AutoCAD LT 2011?**

This happens because of the way menus are loaded into AutoCAD LT at startup. This problem only happens when partial and enterprise CUIx files are used. To resolve this problem, you can use the new /w command line switch. This causes AutoCAD LT 2011 to re-initialize the workspace upon startup and place the toolbars in their correct locations. See To restore a workspace with a command line switch on page 290 for more information.

**Why do my icons on a toolbar display as a cloud with a question mark after I migrate them using the Transfer tab in the CUI Editor?**

This happens because the images for the custom icons are not located in the AutoCAD LT support file paths. Locate the images using Windows Explorer and add the images location to the Support File Search Path node under the Files tab of the Options dialog box, or copy them into the folder:

(Windows XP) `<drive>:\Documents and Settings\<user profile name>\Application Data\Autodesk\<product name>\<release number>\<language>\Support\Icons`

(Windows Vista) `<drive>:\Users\<user profile name>\AppData\Autodesk\<product name>\<release number>\<language>\Support\Icons`
Why does my toolbar flyout not work?
A flyout might not work for a few different reasons. There might not be any commands currently assigned to the toolbar that it is referencing or a control is part of the toolbar that is being referenced for the toolbar flyout. Launch the CUI Editor and verify that there are commands on the toolbar that is being referenced and if there are, make sure there are no controls on the toolbar such as the Layer list control.

Why do I get an AutoCAD LT message box when I try to use a toolbar flyout?
The AutoCAD LT message box is displayed because the toolbar that is being referenced for the toolbar flyout is not found. AutoCAD LT can’t find the toolbar because it no longer exists, is not currently loaded because the partial CUIx file it is in is not loaded, or the alias for the toolbar has been changed.

Launch the CUI Editor and select the flyout on the toolbar that currently is not working properly. In the Properties pane look at the Source Toolbar property. Use the Find option to look for a toolbar element with an alias that matches the text string in the Source Toolbar property of the flyout that does not work. If one is not located, remove the flyout from the toolbar and drag the toolbar that you want to reference as a flyout on the toolbar. Close the CUI Editor. The flyout should now work correctly once again.

Double Click Actions

When I double-click an object nothing happens. Why is this happening?
There are a few different reasons why when double-clicking on an object in the drawing nothing happens. The first and most common problem is with the system variable PICKFIRST is set to 0. PICKFIRST must be set to a value of 1 in order for double-click editing to work. The next possible solution is that double-click editing has been disabled. Double-click editing is controlled by the system variable DBLCLKEDIT. If it is set to 0 it is currently turned off. DBLCLKEDIT should be set to 1.

Workspaces

Why do my changes not appear after I click Apply?
This happens because the workspace that you made changes to is not the current workspace. To resolve this problem, you need to set the workspace current and then when changes are applied they will appear. See To set a workspace current from the CUI Editor on page 289 for more information.
Enterprise CUIx Files

How do I edit an enterprise CUIx file if it is read-only in the CUI Editor?

An enterprise CUIx file can only be edited when it is loaded as the main CUIx file or as a partial CUIx file to the main CUIx file. It is recommended that you load it as the main CUIx file when you need to make edits. If you are creating a workspace that needs to include user interface elements from the CUIx file that is normally designated as the main CUIx file, load the main CUIx file as the enterprise CUIx file. Make edits to the enterprise CUIx file. See To modify an enterprise CUIx file on page 84 for more information.

Quick Reference

Commands

CUI
Manages the customized user interface elements in the product.

CUIEXPORT
Exports customized settings from the main CUIx file to an enterprise or partial CUIx file.

CUIIMPORT
Imports customized settings from an enterprise or partial CUIx file to the main CUIx file.

CULOAD
Loads a CUIx file.

CUIUNLOAD
Unloads a CUIx file.

OPTIONS
Customizes the program settings.

QUICKCUI
Displays the Customize User Interface Editor in a collapsed state.

WORKSPACE
Creates, modifies, and saves workspaces and makes a workspace current.
**System Variables**

WSCURRENT

Returns the current workspace name at the Command prompt and sets a workspace to current.
DIESEL

You can use DIESEL (Direct Interpretively Evaluated String Expression Language) to alter the AutoCAD LT® status line through the MODEMACRO system variable. You can also use DIESEL in menu items as a macro language instead of AutoLISP®. DIESEL expressions accept strings and generate string results.

Customize the Status Line

You can use the MODEMACRO system variable to display information on the status line.

Overview of the MODEMACRO System Variable

The status line can provide the user with important information without interrupting the work flow. The MODEMACRO system variable controls the user-defined area on the status line. The calculated value of the MODEMACRO system variable is displayed in a left-aligned panel in the status bar at the bottom of the AutoCAD LT® window. This variable is set to the null string when you start AutoCAD LT. Its value is not saved in the drawing, the configuration file, or anywhere else.

The number of characters displayed on the status line is limited only by the size of the AutoCAD LT window (and your monitor). The default panels move to the right as the content of the MODEMACRO panel grows. It is possible to push the default panels completely off the screen (if you want to).

You can use the MODEMACRO system variable to display, in the status line, most data known to AutoCAD LT. With its calculation, decision, and editing facilities you can compose the status line to your precise specifications.

MODEMACRO is a user-string variable. It can be set to any string value. The maximum string value is 4095 characters. You can set MODEMACRO with
SETVAR or by entering `modemacro` at the command prompt. If you modify the MODEMACRO setting, you can experiment with various status line formats; however, the maximum number of characters you can enter in this manner is 255.

If you set MODEMACRO to the null string by entering a period (.), AutoCAD LT displays the standard status line.

**Quick Reference**

**Commands**

SETVAR

Lists or changes the values of system variables.

**System Variables**

MODEMACRO

Displays a text string on the status line, such as the name of the current drawing, time/date stamp, or special modes.

**Set MODEMACRO Values**

You can use text strings and DIESEL to display messages in the user-defined section of the status line.

The value of MODEMACRO determines what is displayed in the mode status line. The simplest (and least useful) MODEMACRO consists of constant text. For example, to display a company name in the status line, you enter the following:

**Command:** `modemacro`

**New value for MODEMACRO, or . for none <"">:** *Greg's Bank and Grill*

This MODEMACRO value always displays the same text; the status line does not reflect changes to the AutoCAD LT internal state. It doesn't change until you change MODEMACRO.

To make the status line reflect the AutoCAD LT current state, enter macro expressions using the DIESEL language in the following format:

```
$(somefun, arg1, arg2, ...)
```

In the macro expression, `somefun` is the name of the DIESEL function, and `arg1, arg2, and so on` are arguments to the function, interpreted according
to the function’s definition. DIESEL macro expressions have only one data type: strings. Macros that operate on numbers express the numbers as strings and convert back and forth as required.

For descriptions of the DIESEL functions, see Catalog of DIESEL Functions on page 331.

Now define a more interesting status line (for example, one that shows the current text style name):

Command: **modemacro**
New value for MODEMACRO, or . for none <"">: **Style: $(getvar, textstyle)**
- **Style:** is a text string to be displayed on the status line.
- **$(getvar, textstyle)** is a DIESEL function (**getvar**) and argument that retrieves the current value of the TEXTSTYLE system variable.

**NOTE** The examples in this topic may show the MODEMACRO string as more than one line of text. You enter it as one long string at the prompt.

You can retrieve any system variable by entering **$(getvar, varname)**. The current setting of the system variable replaces the macro expression on the status line. Then, when you switch text styles, for example, MODEMACRO is reevaluated. If it changes, the new text style name is displayed on the status line.

Expressions can be nested, and they can be as complex as you want. The example that follows displays the current snap value and angle (in degrees) in the status line. It uses nested expressions to convert the snap angle from radians to degrees and truncates the value to an integer.

Command: **modemacro**
New value for MODEMACRO, or . for none <"">: **Snap: $(getvar, snapunit) $(fix,$(*,$(getvar,snapang),$(/,180,3.14159)))**

You can also display the values in the current linear and angular units modes.

Command: **modemacro**
New value for MODEMACRO, or . for none <"">: **Snap: $(rtos,$(index,0,$(getvar,snapunit)),$(rtos,$(index,1,$(getvar,snapunit))) $(angtos,$(getvar,snapang))**

DIESEL copies its input directly to the output until it comes to the dollar sign character ($) or a quoted string. You can use quoted strings to suppress evaluation of character sequences that would otherwise be interpreted as DIESEL functions. You can include quotation marks in quoted strings by using
two adjacent quotation marks. In the following example, the current layer is set to LAYOUT, and MODEMACRO is set to the string.

Command: **modemacro**
New value for MODEMACRO, or . for none \"\": \"$(getvar,clayer)=

\"\"$(getvar,clayer)\"\"\"

The status line displays the following:

$(getvar,clayer)="LAYOUT"

**Quick Reference**

**Commands**

**SETVAR**

Lists or changes the values of system variables.

**System Variables**

**MODEMACRO**

Displays a text string on the status line, such as the name of the current drawing, time/date stamp, or special modes.

**DIESEL Expressions in Macros**

You can use DIESEL string expressions in customization (CUI) files as an additional method of creating macros.

These expressions can return string values (text strings) in response to standard AutoCAD LT commands. They can also return string values to the menu itself, thereby altering the appearance or content of a menu label.

A DIESEL expression that you use in a menu item must follow the `$section=submenu` format where the section name is `M` and the submenu is the DIESEL expression you want.

Consider the following example:

`^C^C^P$M=$(if,$(=,$(getvar,cvport),1),mspace,pspace)`

This string provides a way to toggle between paper space and model space if TILEMODE is set to 0. This expression is evaluated transparently. If the special character `^P` (which toggles MENUECHO on and off) is omitted, the expression displays only the issued command.
This menu item uses the DIESEL expression:

```
^C^C^C\$M=$(if,$(=,$(getvar,cvport),1),mspace,pspace)
```

The next example is based on these assumptions:

- The CUI excerpt is included in the current customization file.
- The symbols to insert are one unit high by one unit wide.
- The DIMSCALE variable is set to the drawing's scale factor (that is, a drawing to be plotted at a scale of 1" = 10' would have a scale factor of 120, or a 1/4" = 1' scale drawing would have a scale factor of 48).

The DIESEL expressions in the following example multiply the current value of DIMSCALE by the specified value, and return an appropriate scale factor.

```
$M=$(*,$(getvar,dimscale),0.375)
$M=$(*,$(getvar,dimscale),0.5)
$M=$(*,$(getvar,dimscale),0.625)
```

DIESEL expressions can also return string values to pull-down menu item labels, so that you can make menus unavailable or otherwise alter the way they are displayed. To use a DIESEL expression in a pull-down menu label, make sure that the first character is the $ character.

In the next example, the current layer is set to BASE and the following DIESEL expression is used as the label.

```
$(eval,"Current layer: " $(getvar,clayer))
```

The result is that the appropriate pull-down menu is displayed and updated whenever the current layer changes.

Current Layer: BASE

**NOTE** The width of pull-down and shortcut menus is determined when the customization file is being loaded. Menu labels generated or changed by DIESEL expressions after a menu is loaded are truncated to fit within the existing menu width.

If you anticipate that a DIESEL-generated menu label will be too wide, you can use the following example to ensure that the menu width will accommodate your labels. This example displays the first 10 characters of the current value of the USERNAME system variable.

```
${(eval,"Current value: " $(getvar,username))} +
${(if, $(eq,$(getvar,username),""), 10 spaces })^C^CUsername
```
You cannot use trailing spaces in a menu label to increase the menu width, because trailing spaces are ignored while the menu is being loaded. Any spaces you use to increase the width of a menu label must be within a DIESEL expression.

The next example uses the same DIESEL expression as the label and a portion of the menu item. It provides a practical way to enter the current day and date into a drawing.

```
$(edtime,$(getvar,date),DDD", "D MON YYYY)^C^Ctext +
\\ $M=$(edtime,$(getvar,date),DDD", "D MON YYYY);
```

Also, you can use a DIESEL macro to mark pull-down menu labels or make them unavailable. The following pull-down menu label displays an unavailable ERASE while a command is active. The text is displayed normally when a command is not active.

```
$(if,$(getvar, cmdactive),~)ERASE
```

You can use a similar approach to place a mark beside a pull-down menu item or to interactively change the character used for the mark.

You can use the CLIPBOARD system variable to enable or disable Clipboard commands on your menu. For example, the following DIESEL expression disables the Paste Special menu item when the Clipboard is empty:

```
$(If,$(getvar, clipboard),,~)/Paste &Special...
^C^C_pastespec
```

### Quick Reference

**System Variables**

**CLIPBOARD**

- Indicates the status of the Clipboard.

**MENUECHO**

- Sets menu echo and prompt control bits.

**USERNAME**

- Specifies the user name.
Catalog of DIESEL Functions

Status retrieval, computation, and display are performed by DIESEL functions. All functions have a limit of 10 parameters, including the function name itself. If this limit is exceeded, you get a DIESEL error message.

+ (addition)

Returns the sum of the numbers $val1, val2, ..., val9$.

$(+, \text{val1}, [val2, ..., val9])$

If the current thickness is set to 5, the following DIESEL string returns 15.

$(+, \text{getvar,thickness},10)$

Quick Reference

System Variables

MENUECHO
Sets menu echo and prompt control bits.

- (subtraction)

Returns the result of subtracting the numbers $val2$ through $val9$ from $val1$.

$(-, \text{val1}, [val2, ..., val9])$

Quick Reference

System Variables

MENUECHO
Sets menu echo and prompt control bits.

* (multiplication)

Returns the result of multiplying the numbers $val1, val2, ..., val9$.

$(\ast, \text{val1}, [val2, ..., val9])$
Quick Reference

System Variables

MENUECHO

Sets menu echo and prompt control bits.

\/(division)

Returns the result of dividing the number val1 by val2, ..., val9.

$/ (val1 \div val2, \ldots, val9)$

Quick Reference

System Variables

MENUECHO

Sets menu echo and prompt control bits.

\=(equal to)

If the numbers val1 and val2 are equal, the string returns 1; otherwise, it returns 0.

$$(\neg, val1, val2)$$

Quick Reference

System Variables

MENUECHO

Sets menu echo and prompt control bits.
< (less than)

If the number $val1$ is less than $val2$, the string returns 1; otherwise, it returns 0.

```bash
$(<, val1, val2)
```

The following expression gets the current value of HPANG; if the value is less than the value stored in the system variable USERR1, it returns 1. If the value 10.0 is stored in USERR1 and the current setting of HPANG is 15.5, the following string returns 0.

```bash
$(<, $(getvar, hpang), $(getvar, userr1))
```

Quick Reference

System Variables

MENUECHO

Sets menu echo and prompt control bits.

> (greater than)

If the number $val1$ is greater than $val2$, the string returns 1; otherwise, it returns 0.

```bash
$(>, val1, val2)
```

Quick Reference

System Variables

MENUECHO

Sets menu echo and prompt control bits.

!= (not equal to)

If the numbers $val1$ and $val2$ are not equal, the string returns 1; otherwise, it returns 0.

```bash
$(!=, val1, val2)
```

Quick Reference

System Variables

MENUECHO

Sets menu echo and prompt control bits.
Quick Reference

System Variables

MENUECHO

Sets menu echo and prompt control bits.

<= (less than or equal to)

If the number \texttt{val1} is less than or equal to \texttt{val2}, the string returns 1; otherwise, it returns 0.

\$<=$, \texttt{val1}, \texttt{val2}$

Quick Reference

System Variables

MENUECHO

Sets menu echo and prompt control bits.

>= (greater than or equal to)

If the number \texttt{val1} is greater than or equal to \texttt{val2}, the string returns 1; otherwise, it returns 0.

\$=>$, \texttt{val1}, \texttt{val2}$

Quick Reference

System Variables

MENUECHO

Sets menu echo and prompt control bits.
and

Returns the bitwise logical AND of the integers \texttt{val1} through \texttt{val9}.

\begin{verbatim}
$(\text{and, } \texttt{val1 }, \texttt{val2}, \ldots, \texttt{val9})$
\end{verbatim}

Quick Reference

System Variables

\texttt{MENUECHO}

Sets menu echo and prompt control bits.

\texttt{angtos}

Returns the angular value in the format and precision specified.

\begin{verbatim}
$(\text{angtos, } \texttt{value }, \texttt{mode}, \texttt{precision})$
\end{verbatim}

Edits the given \texttt{value} as an angle in the format specified by the \texttt{mode} and \texttt{precision} as defined for the analogous AutoLISP function. (The values for \texttt{mode} are shown in the following table.) If \texttt{mode} and \texttt{precision} are omitted, it uses the current values chosen by the \texttt{UNITS} command.

\begin{table}[h]
\centering
\begin{tabular}{|c|c|}
\hline
Mode value & String format \\
\hline
0 & Degrees \\
\hline
1 & Degrees/minutes/seconds \\
\hline
2 & Grads \\
\hline
3 & Radians \\
\hline
4 & Surveyor's units \\
\hline
\end{tabular}
\end{table}
Quick Reference

System Variables

MENUECHO

Sets menu echo and prompt control bits.

edtime

Returns a formatted date and time based on a given picture.

\$\text{edtime}(\text{time}, \text{picture})$

Edits the AutoCAD LT Julian date given by \text{time} (obtained, for example, from $\text{getvar, date}$ according to the given \text{picture}). The \text{picture} consists of format phrases replaced by specific representations of the date and time. Characters not interpretable as format phrases are copied literally into the result of $\text{edtime}$. Format phrases are defined as shown in the following table. Assume that the date and time are Saturday, 5 September 1998 4:53:17.506.

<table>
<thead>
<tr>
<th>edtime format phrases</th>
</tr>
</thead>
<tbody>
<tr>
<td>Format</td>
</tr>
<tr>
<td>-----------</td>
</tr>
<tr>
<td>D</td>
</tr>
<tr>
<td>DD</td>
</tr>
<tr>
<td>DDD</td>
</tr>
<tr>
<td>DDDDD</td>
</tr>
<tr>
<td>M</td>
</tr>
<tr>
<td>MO</td>
</tr>
<tr>
<td>MON</td>
</tr>
<tr>
<td>MONTH</td>
</tr>
<tr>
<td>YY</td>
</tr>
<tr>
<td>YYYY</td>
</tr>
</tbody>
</table>
Enter the entire **AM/PM** phrase as shown in the preceding table; if **AM** is used alone, the **A** will be read literally and the **M** will return the current month.

If any **AM/PM** phrases appear in the picture, the **H** and **HH** phrases edit the time according to the 12-hour civil clock (12:00-12:59 1:00-11:59) instead of the 24-hour clock (00:00-23:59).

The following example uses the date and time from the preceding table. Notice that the comma must be enclosed in quotation marks because it is read as an argument separator.

\[
\text{\$\{edtime, \$\{getvar, date\},DDD"," DD MON YYYY - H:MMam/pm\}}
\]

It returns the following:

Sat, 5 Sep 1998 - 4:53am

If \textit{time} is 0, the time and date at the moment that the outermost macro was executed is used. This avoids lengthy and time-consuming multiple calls on \$	ext{\$\{getvar, date\}}$ and guarantees that strings composed with multiple \$	ext{\$\{edtime\}}$ macros all use the same time.

**Quick Reference**

**System Variables**

\textbf{MENUECHO}

Sets menu echo and prompt control bits.

\textbf{eq}

If the strings \textit{val1} and \textit{val2} are identical, the string returns 1; otherwise, it returns 0.

\[
\text{\$\{eq, val1, val2\}}
\]

**Quick Reference**

**System Variables**

\textbf{MENUECHO}

Sets menu echo and prompt control bits.
**eval**

Passes the string `str` to the DIESEL evaluator and returns the result of evaluating it.

```
$(eval, str)
```

**Quick Reference**

**System Variables**

```
MENUECHO
```

Sets menu echo and prompt control bits.

**fix**

Truncates the real number `value` to an integer by discarding any fractional part.

```
$(fix, value)
```

**Quick Reference**

**System Variables**

```
MENUECHO
```

Sets menu echo and prompt control bits.

**getenv**

Returns the value of the environment variable `varname`.

```
$(getenv, varname)
```

If no variable with that name is defined, it returns the null string.
Quick Reference

System Variables
MENUECHO
Sets menu echo and prompt control bits.

getvar

Returns the value of the system variable with the given varname.
$(getvar, varname)

Quick Reference

System Variables
MENUECHO
Sets menu echo and prompt control bits.

if

Conditionally evaluates expressions.
$(if, expr, dotrue [, dofalse])

If expr is nonzero, it evaluates and returns dotrue. Otherwise, it evaluates and returns dofalse. Note that the branch not chosen by expr is not evaluated.

Quick Reference

System Variables
MENUECHO
Sets menu echo and prompt control bits.
index

Returns the specified member of a comma-delimited string.

\$\text{index, which, string}\\

Assumes that the \text{string} argument contains one or more values delimited by the macro argument separator character, the comma. The \text{which} argument selects one of these values to be extracted, with the first item numbered 0. This function is most frequently used to extract \(X\), \(Y\), or \(Z\) coordinate values from point coordinates returned by \$\text{getvar}$.  

Quick Reference

System Variables

\text{MENUECHO}  
Sets menu echo and prompt control bits.  

nth

Evaluates and returns the argument selected by \text{which}.

\$\text{nth, which, arg0 [, arg1,..., arg7]}\\

If \text{which} is 0, \text{nth} returns \text{arg0}, and so on. Note the difference between \$\text{nth}$ and \$\text{index}$; \$\text{nth}$ returns one of a series of arguments to the function, while \$\text{index}$ extracts a value from a comma-delimited string passed as a single argument. Arguments not selected by \text{which} are not evaluated.  

Quick Reference

System Variables

\text{MENUECHO}  
Sets menu echo and prompt control bits.
or

Returns the bitwise logical OR of the integers \(\text{val1 through val9}\).

\$(\text{or, val1 }, \text{val2}, \ldots, \text{val9})$

Quick Reference

System Variables

MENUECHO

Sets menu echo and prompt control bits.

rtos

Returns the real value in the format and precision specified.

\$(\text{rtos, value }, \text{mode, precision})$

Edits the given \text{value} as a real number in the format specified by the \text{mode} and \text{precision} as defined by the analogous AutoLISP function. If \text{mode} and \text{precision} are omitted, it uses the current values selected with the UNITS command.

Edits the given \text{value} as a real number in the format specified by \text{mode} and \text{precision}. If \text{mode} and \text{precision} are omitted, it uses the current values selected with the UNITS command.

Quick Reference

System Variables

MENUECHO

Sets menu echo and prompt control bits.

strlen

Returns the length of \text{string} in characters.

\$(\text{strlen, string})$
Quick Reference

System Variables

MENUECHO

Sets menu echo and prompt control bits.

**substr**

Returns the substring of `string`, starting at character `start` and extending for `length` characters.

`$(substr, string, start [, length])`

Characters in the string are numbered from 1. If `length` is omitted, it returns the entire remaining length of the string.

Quick Reference

System Variables

MENUECHO

Sets menu echo and prompt control bits.

**upper**

Returns the `string` converted to uppercase according to the rules of the current locale.

`$(upper, string)`

Quick Reference

System Variables

MENUECHO

Sets menu echo and prompt control bits.
xor

Returns the bitwise logical XOR of the integers \textit{val1} through \textit{val9}.

\texttt{$(xor, val1 [, val2,..., val9])$}

Quick Reference

System Variables

\texttt{MENUECHO}

Sets menu echo and prompt control bits.

DIESEL Error Messages

Generally, if you make a mistake in a DIESEL expression, what went wrong will be obvious. Depending on the nature of the error, DIESEL embeds an error indication in the output stream.

\textbf{DIESEL error messages}

<table>
<thead>
<tr>
<th>Error message</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>$?</td>
<td>Syntax error (usually a missing right parenthesis or a runaway string)</td>
</tr>
<tr>
<td>$(func,??)</td>
<td>Incorrect arguments to \textit{func}</td>
</tr>
<tr>
<td>$(func)??</td>
<td>Unknown function \textit{func}</td>
</tr>
<tr>
<td>$(++)</td>
<td>Output string too long—evaluation truncated</td>
</tr>
</tbody>
</table>

Quick Reference

System Variables

\texttt{MENUECHO}

Sets menu echo and prompt control bits.
Slides and Command Scripts

Slides are snapshots of drawing files that can be used for giving presentations, for creating image tile menus, and for viewing another drawing while you work.

A script reads and executes commands from a text file. You can run a script when you start AutoCAD LT®, or you can run a script from within AutoCAD LT using the SCRIPT command. A script provides an easy way to create continuously running displays for product demonstrations and trade shows.

Create Slides

Slides are snapshots of drawing files. You can use slides for giving presentations, creating custom image tile menus, and viewing an image of another drawing while you work.

Overview of Slides

A slide is a snapshot of a drawing. Although it contains a picture of the drawing at a given instant, it is not a drawing file.

You cannot import a slide file into the current drawing, nor can you edit or print a slide. You can only view it.

You can use slide files in the following ways:

- For making presentations within AutoCAD LT®
- For viewing a snapshot of a drawing while working on a different drawing
- For creating menus of image tiles within a dialog box
You create a slide by saving the current view in slide format. A slide created in model space shows only the current viewport. A slide created in paper space shows all visible viewports and their contents. Slides show only what was visible. They do not show objects on layers that were turned off or frozen or objects in viewports that were turned off.

When you view a slide file, it temporarily replaces objects on the screen. You can draw on top of it, but when you change the view (by redrawing, panning, or zooming), the slide file disappears, and AutoCAD LT redisplays only what you drew and any preexisting objects.

You can display slides one by one or use a script to display slides in sequence. Slides also can be used in custom menus. For example, if you create scripts that insert blocks containing mechanical parts you use frequently, you can design a custom image tile menu that displays a slide of each part. When you click the slide image on the menu, AutoCAD LT inserts the block into the drawing.

A slide library is a file containing one or more slides. Slide library files are used for creating custom image tile menus and for combining several slide files for convenient file management.

You cannot edit a slide. You must change the original drawing and remake the slide. If you use a low-resolution graphics monitor when creating a slide file and later upgrade to a high-resolution monitor, you can still view the slide. AutoCAD LT adjusts the image accordingly; however, the slide does not take full advantage of the new monitor until you remake the slide file from the original drawing.

To make a slide

1. Display the view you want to use for the slide.
2. At the command prompt, enter `mslide`.
3. In the Create Slide File dialog box, enter a name and select a location for the slide.
   AutoCAD LT offers the current name of the drawing as a default name for the slide and automatically appends the `.sld` file extension.
4. Click Save.
   The current drawing remains on the screen, and the slide file is saved in the folder that you specified.
Quick Reference

Commands

MSLIDE
Creates a slide file of the current model viewport or the current layout.

REDRAW
Refreshes the display in the current viewport.

VSLIDE
Displays an image slide file in the current viewport.

System Variables

FILEDIA
Suppresses display of file navigation dialog boxes.

Utilities

SLIDELIB
Compiles slide files listed in an ASCII file into a slide library file.

View Slides

You can view slides individually using VSLIDE. To view a series of slides for a presentation, use a script file.

Be careful about using editing commands while you view a slide, which looks like an ordinary drawing. Editing commands affect the current drawing underneath the slide but not the slide itself.

Some commands may force redrawing, which removes the slide from display.

To view a slide

1. At the command prompt, enter vslide.

2. In the Select Slide File dialog box, select a slide to view and click OK. The slide image is displayed in the drawing area.

3. Click View menu ➤ Redraw. The slide image disappears.
Quick Reference

Commands

REDRAW
Refreshes the display in the current viewport.

VSLIDE
Displays an image slide file in the current viewport.

Create and View Slide Libraries

A slide library is a file containing one or more slides. Slide library files are used for creating custom image tile menus and for combining several slide files for convenient file management.

You can create slide libraries from slide files using the SLIDELIB utility. After you have set up a slide library, you can view slides by specifying the name of the slide library and the slide.

Do not delete the original slides after creating the slide library. The SLIDELIB utility cannot update a slide library once it is created. If you want to add or delete a slide, update the slide list file and remake the library with SLIDELIB. When you remake the slide library, all the slide files that you intend to include must be available.

To create a slide library

1. Use a Windows ASCII text editor to create a list of slide files to include in the library. The file would look similar to this example:
   - entrance.sld
   - hall.sld
   - stairs.sld
   - study.sld
   - balcony.sld

2. Name and save the file as a text file with a .txt file extension.

3. Click Start menu (Windows) ➤ All Programs (or Programs) ➤ Accessories ➤ Command Prompt.

4. In the Command Prompt window, at the prompt, enter `CD <folder location of slides>` to change folders.
As an example: CD “c:\slides”

5 At the prompt, enter the following syntax to create the slide library:

\texttt{slidelib \textit{libraryname} < list.txt}

For example, if you named your text file \textit{areas.txt}, you could create a library called \textit{house.slb} by entering \texttt{slidelib house < areas.txt}. The SLIDELIB utility appends the file extension .\textit{slb} to the slide library file.

**To view a slide in a slide library**

1 At the command prompt, enter \texttt{filedia}.

2 Enter \texttt{0} and press ENTER.

3 At the command prompt, enter \texttt{vslide}.

4 Enter \texttt{library(slidename)} to specify the slide.
   
   For example, enter \texttt{house (balcony)} to open the \textit{balcony} slide, which is stored in the \textit{house} slide library file.

5 To remove the slide from the display, click View menu ➤ Redraw.

**Quick Reference**

**Commands**

MSLIDE

Creates a slide file of the current model viewport or the current layout.

REDRAW

Refreshes the display in the current viewport.

VSLIDE

Displays an image slide file in the current viewport.

**Utilities**

SLIDELIB

Compiles slide files listed in an ASCII file into a slide library file.
Create Command Scripts

A script is a text file that contains a series of commands. Common uses for scripts are to customize startup and to run slide shows.

Overview of Command Scripts

A script is a text file with one command on each line.

You can invoke a script at startup, or you can run a script during a work session by using the SCRIPT command. A script also provides an easy way to create continuously running displays for product demonstrations and trade shows.

The BACKGROUND PLOT system variable must be set to 0 before a script can plot multiple jobs.

You create script files outside the program using a text editor (such as Microsoft® Windows® Notepad) or a word processor (such as Microsoft Word) that can save the file in ASCII format. The file extension must be .scr.

Each line of the script file contains a command. Each blank space in a script file is significant because SPACEBAR is accepted as a command or data field terminator. You must be very familiar with the sequence of prompts to provide an appropriate sequence of responses in the script file.

NOTE Keep in mind that prompts and command names may change in future releases, so you may need to revise your scripts when you upgrade to a later version of this program. For similar reasons, avoid the use of abbreviations; future command additions might create ambiguities.

A script can execute any command at the command prompt except a command that displays a dialog box. In most cases, a command that displays a dialog box has an alternative version of the command that displays command prompts instead of a dialog box.

Script files can contain comments. Any line that begins with a semicolon (;) is considered a comment, and it is ignored while the script file is being processed. The last line of the file must be blank.

All references to long file names that contain embedded spaces must be enclosed in double quotes. For example, to open the drawing my house.dwg from a script, you must use the following syntax:

```
open "my house"
```

The following commands are useful in scripts:
'DELAY' Provides a timed pause within a script (in milliseconds)

'GRAPHSCR' Switches from the text window to the drawing area

RESUME Continues an interrupted script

RSCRIPT Repeats a script file

'TEXTSCR' Switches to the text window

When command input comes from a script, it is assumed that the settings of the PICKADD and PICKAUTO system variables are 1 and 0, respectively; therefore, you do not have to check the settings of these variables.

A script is treated as a group, a unit of commands, reversible by a single U command. However, each command in the script causes an entry in the undo log, which can slow script processing. If you like, you can use UNDO Control None to turn off the undo feature before running the script, or you can write it at the beginning of the script itself. Remember to turn it back on (UNDO Control All) when the script is finished.

The script that is running stops when another script command is invoked.

To create a script that changes settings in a drawing

This script turns on the grid, sets the global linetype scale to 3.0, and sets layer 0 as the current layer with red as the color.

1. In a text editor, enter `grid on`.
2. On the next line, enter `ltscale 3.0`.
3. On the next line, enter `layer set 0 color red 0`.
4. Add a blank line.
5. Save the file as ASCII text (TXT file), with a file extension of `.scr`.

The script file may contain comments, as follows:

```
; Turn grid on
grid on
; Set scale for linetypes
ltscale 3.0
; Set current layer and its color
layer set 0 color red 0

; Blank line above to end LAYER command
```
Quick Reference

Commands

DELAY
Provides a timed pause within a script.

GRAPHSCR
Switches from the text window to the drawing area.

RESUME
Continues an interrupted script.

RSCRIPT
Repeats a script file.

SCRIPT
Executes a sequence of commands from a script file.

TEXTSCR
Opens the text window.

VSLIDE
Displays an image slide file in the current viewport.

Run Scripts at Startup

A script that runs at startup can open a drawing and change its settings.

Suppose that every time you begin a new drawing, you turn on the grid, set the global linetype scale to 3.0, and set layer 0 as your current layer, with red as the color. You can do this using a drawing template, but you could do it instead with the following script and store it in a text file called setup.scr.

grid on
ltscale 3.0
layer set 0 color red 0

The first line turns on the grid. The second line sets the global scale for linetypes. The third line sets the current layer to layer 0 and sets its default color to red. AutoCAD LT assumes that in a script you want to use the version of LAYER command that displays command prompts rather than the dialog box version. The result is equivalent to entering layer at the command prompt. The fourth line is blank, ending LAYER.
NOTE  VBA and AutoLISP® scripts that run at startup should check for whether the AutoCAD LT process is visible or invisible. If the process is invisible, the script should not execute, because the process may be performing background plotting or publishing operations. To check for whether the AutoCAD LT process is visible or invisible, you can use the Visible property of the Application object in the AutoCAD LT Object Model.

You could run a script at startup to open a drawing by using the following syntax in the Run dialog box:

```
ACADLT drawing_name /b setup
```

All file names that contain embedded spaces must be enclosed in double quotes, for example, “guest house”. You can also specify the view that is displayed when the drawing opens by using the /v switch and the view name. The /b switch and the script file must be the last parameter listed.

Including the file extensions .exe, .dwg, .dwt, and .scr is optional. If AutoCAD LT cannot find the script file, AutoCAD LT reports that it cannot open the file.

To run the same script at startup but create a new drawing using the MyTemplate.dwt file as the template, enter the following in the Run dialog box:

```
ACADLT /t MyTemplate /b setup
```

This command creates a new drawing and issues a sequence of setup commands from the setup.scr file. When the script has finished running, the command prompt is displayed. If you want to use the default template for the new drawing, you can omit the /t switch and the template file name.

NOTE You can no longer use this method to start a new drawing and give it a name. Name the drawing when you save it.

To run a script at startup

1  Click Start menu (Windows) ➤ Run.

2  In the Run dialog box, enter `acadlt drawing_name /b script_name`.

   To start a new file, instead of a drawing file name, enter the /t switch and the name of a template file: `/t template_drawing`

   To open a drawing file to a particular view, follow the drawing name with the /v switch and the name of the view: `/v view_name`

   The name of the script file must be the last parameter listed. The file extensions are optional.
3 Click OK.
AutoCAD LT opens the drawing and executes the commands in the script file. When the script has been completed, the command prompt is displayed.

Run Slide Shows from Scripts

Scripts are useful for creating slide shows.

Ordinarily, the speed with which you can display slides is limited by the number of times AutoCAD LT must access the disk to read the slide file. You can, however, preload the next slide from disk into memory while your audience is viewing the current slide and then quickly display the new slide from memory.

To preload a slide, place an asterisk before the file name in VSLIDE. The next VSLIDE command detects that a slide has been preloaded and displays it without asking for a file name.

The disk-access time to load the next slide overlaps with the viewing time for the current slide. You can specify additional delays with the DELAY command. Each delay unit is equal to one millisecond.

To stop a repeating script press ESC. You can resume the script with RESUME.

If the script will run for a long time, it is recommended that you use UNDO Control None to turn off the Undo log file.

To run slide shows from scripts

1 Create the slide library file as described in To create a slide library on page 348.

2 Create a script file using an ASCII text editor, as shown in To create a script that preloads slides on page 355.

3 At the command prompt, enter script.

4 In the Select Script File dialog box, select a script file and click Open.
To create a script that preloads slides

In this example of a script that displays three slides (files slide1.sld, slide2.sld, and slide3.sld), the time it takes to access the disk drive and load the next slide into memory overlaps with the viewing time for the current slide.

1. On the first line of the script, enter vslide slide1.
   The first line begins the slide show and loads slide1.

2. On the second line, enter vslide *slide2.
   The asterisk (*) preceding the slide name on the second line preloads slide2.

3. On the third line, enter delay 2000.
   The third line specifies a delay of 2000 milliseconds to allow the audience to view slide1.

4. On the fourth line, enter vslide. On the fifth line, enter vslide *slide3.
   On the sixth line, enter delay 2000.
   The fourth, fifth, and sixth lines display slide2, preload slide3, and specify a delay for viewing slide2.

5. On the seventh line, enter vslide. On the eighth line, enter delay 3000.
   The seventh and eighth lines display slide3 and specify a delay for viewing slide3.

6. On the last line, enter rscript to repeat the script.

7. To stop a repeating script press ESC. To continue the script, enter resume.
The script may contain comments, as follows:

; Begin slide show, load SLIDE1
VSLIDE SLIDE1
; Preload SLIDE2
VSLIDE *SLIDE2
; Let audience view SLIDE1
DELAY 2000
; Display SLIDE2
VSLIDE
; Preload SLIDE3
VSLIDE *SLIDE3
; Let audience view SLIDE2
DELAY 2000
; Display SLIDE3
VSLIDE
; Let audience view SLIDE3
DELAY 3000
; Cycle
RSCRIPT

Quick Reference

Commands

DELAY
  Provides a timed pause within a script.

GRAPHSCR
  Switches from the text window to the drawing area.

RESUME
  Continues an interrupted script.

RSCRIPT
  Repeats a script file.

SCRIPT
  Executes a sequence of commands from a script file.

TEXTSCR
  Opens the text window.
VSLIDE

Displays an image slide file in the current viewport.
Index

A
absolute menu referencing 229
accelerator keys 248, 253, 256, 261
actions (user)
double click actions 262
addition DIESEL function 331
aliases
creating for commands 17
pull-down menus 213, 231
shortcut menus 217
alignment
linetype patterns 21
alternate font mapping files 11
and DIESEL function 335
angtos DIESEL function 335
AutoCAD
customization 1
AutoLISP (LSP) applications
macros and 101

B
backup files
customization files 73
batch files 7
borders (menu items) 114
buttons
crosshair coordinates 271
customizing 190
drop-downs 167
flyouts 202
images on 190
moving 190
pointing device buttons 69, 270
ribbon controls 171
swapping 110, 231
tablet buttons 274

canceling commands 102
caret syntax in macros 104
cascading menus 213
categories
commands 45
characters
including in linetypes 24
macro control characters 101, 104
clicking actions 262, 270
command line
switches 353
command line switches
running scripts and 353
Command List pane (CUI editor) 45
command scripts 350
commands
about 92
aliases 17
canceling 102
categories 45
creating 94
customization FAQs 319
customizing 58, 92
double click actions 262
drop-downs 167
editing 94
flyouts 202
Help topics about 122
images for 129, 132, 134
listing 45
macros and 101–102
menu referencing 229
name validity 5
pausing for input 106
properties 92
pull-down menus 65, 212
Quick Access toolbar 142
rearranging 44
repeating 109
reusing 94
ribbon panels and 149
scripts 350
shortcut menus and 67, 212
status line messages 128
submenus and 227
swapping menu contents 110
tablet buttons and 274
tagging 119
tooltips 122
transparent commands 106
comments
script commenting 350
conditional expressions in macros 112
configuration files (plotters)
multiple 6
configuration files (pointing devices)
multiple 6
contextual ribbon tabs 64, 187
control characters in macros 104
customizing workspaces 70, 280,
copying buttons to other toolbars 190
customization file data 316
customization FAQs 322
defined 54
enterprise CUIx files 82
finding items in 86
importing workspaces 282
menu swapping 232
migrating older files to 316
partial CUIx files 78
structure 50
XML-based format 48
current workspaces 283
custom icon files 11
customization about 1
customization files (CUI)
backwards compatibility 48
CUIx files 42
defined 55
DIESEL expressions in 328
directory structure and 4
locating files 11
migrating to CUIx 316
structure 50
customization files (CUIx)
about 42, 73
backups 73
backwards compatibility 48
creating 73
CUI Editor 58
customization FAQs 322
defined 54
enterprise CUIx files 82
finding items in 86
importing workspaces 282
menu swapping 232
migrating older menu files to 316
coordinates
reading with pointing devices 271
crosshairs
coordinates of 271
CUI (customization) files
backwards compatibility 48
CUIx files 42
defined 55
migrating to CUIx 316
structure 50
CUI Editor
about 39, 42, 58
changes in customization and 48, 319
Command List pane 45
Customizations In pane 44
partial CUIx files 78
structure 50
XML-based format 48
customization groups 52, 54
Customizations In pane (CUI editor) 44
Customize User Interface editor about 39, 42, 58
changes in customization and 48
Command List pane 45
Customizations In pane 44
customizing workspaces 70, 280, 296
Dynamic Display pane 47
FAQs 319
tree nodes 56
customizing about customization 39
AutoCAD functions and features 1
commands 58, 92
Customize User Interface editor 39
double click actions 68, 262
FAQs for 319
glossary of terms for 54
hatch patterns 27
hatches 27
images for commands 132
legacy interface elements 272
linetypes 19
locating customized files 8
migrating older customization files 316
mouse button actions 69, 270
properties 233
pull-down menus 65, 212
Quick Access toolbar 142
ribbon 61, 149, 294
shortcut keys 68
shortcut menus 67, 212
status line 325–326
tablet buttons 274
templates 14
toolbars 60, 64, 190
tooltips 241
types of customized files 8
user interface 39, 73
windows 296
workspaces 70, 280, 293

d
dashboard panel 55
dashes
  hatch pattern definitions 30
  linetype definitions 20
dates
  edtime DIESEL function 336
delaying slide shows 354
deleting
  menus 231
  ribbon items 155
toolbar buttons 190
dialog boxes
  image tile dialog boxes 275
DIESEL expressions about 325
customizing status line 326
error messages 343
macros and 101, 112, 328
nesting 327
pull-down menu labels 329
quoted strings in 327
DIESEL functions
  addition 331
  and 335
  angtos 335
  catalog 331
  division 332
  edtime 336
  eq 332
  equal to 332
  eval 338
  fix 338
  getenv 338
  getvar 339
  greater than 333
  greater than or equal to 334
  if 339
  index 340
  less than 333
  less than or equal to 334
  multiplication 331
not equal to 333
nth 340
or 341
rtos 341
strlen 341
substr 342
subtraction 331
upper 342
xor 343
digitizing tablets
buttons 270, 274
directory paths
program and support files 4
displaying
contextual ribbon tabs 64
hidden files 9
list of shortcut keys 248
menus 298
palettes 294, 298
Quick Access toolbar 293, 297
ribbon panels 294, 297
ribbon tabs 294, 297
slide shows 354
slides 347
toolbars 294, 297
tooltips 241
workspace toolbars 190
division DIESEL function 332
docked windows 56
dots in linetype definitions 20
double click actions
customization FAQs 321
customizing 68, 262
drawing files (DWG)
folders and maintenance 7
slides of 345
drop-down lists 171, 207
drop-downs
ribbon panels 167
Dynamic Display pane (CUI editor) 47
Dynamic Help 53
editing
commands 94
double click actions for 262
shortcut keys 248
slide files and 347
toolbars 192
edtime DIESEL function 336
equal to DIESEL function 332
equivalent DIESEL function 337
eq DIESEL function 337
echoes in macros 103
   
E
   
edtime DIESEL function 336
   
F
   
files
locations 8
maintenance 7
roaming profiles and 9
finding
commands in CUIx files 86
customized files 8
tagged commands 119
fix DIESEL functions 338
floating windows 56
flyouts
buttons 202
toolbars 202
FMP files (font mapping) 11
font mapping files 11
fonts
including in linetypes 24
function keys (F1-F12) 248, 253, 256, 261
G

gmtime DIESEL function 338
getvar DIESEL function 339
graphics for commands 129, 132, 134
graying out menu item labels 113
greater than DIESEL function 333
greater than or equal to DIESEL function 334

H
hatch patterns
about 27
creating 27
examples 27, 31, 34
multiple lines 34
hatches
creating 27
customizing 27
Help
Dynamic Help 53
locating Help files 11
tooltip command Help 122
hidden files 9
hiding
toolbar buttons 190

I
if DIESEL function 339
image tile menus
creating 275
menu swapping 231
slides and 348
images for commands 129, 132, 134
importing
customization file data 316
images for commands 134
workspace settings 282
index DIESEL function 340
input
pausing macros for 106
inserting
menus 231
interface
changes in customization process 48
customization FAQs 319

Customize User Interface editor 39, 58, 296
customizing 39
legacy interface elements 272
terminology 54
workspaces 70
interface elements
defined 55
swapping 110, 231
tree view 44
interface items 55
international character sets 109
Internet
customizing templates for 14

K
keyboard input in macros 106
keyboard shortcuts 68, 248, 253, 256, 261

L
languages
macro translations 109
legacy interface elements 55, 272
less than DIESEL function 333
less than or equal to DIESEL function 334
library search path 4
LIN files (linetype library) 11, 19
linetypes
about 19
creating 20
customizing 19
examples 20
simple 20
text characters in 24
listing
commands 45
keyboard shortcuts 248
loading
customization files 73
partial customization files 78
macros
about 101
conditional expressions in 112
defined 56
DIESEL expressions in 112, 328
international language support 109
length 103
pausing for user input 103, 106
repeating commands 109
scripts 350
selecting objects with 110
shortcut keys and 248
special character codes for
commands 104
suppressing echoes and
prompts 103
swapping interface elements
with 110
syntax 101
tablet menus and 272
terminating 103
main customization files 56, 73
menu files 49
menu groups (customization
groups) 52, 54
menu items
DIESEL expressions and 329
disabling 113
graying out 113
status line messages 128
menu referencing 229
menu resource files (MNR) 49
menu swapping 110, 232
menu template files (MNU) 48, 55
menus
creating 65, 67, 212
customization FAQs 320
customizing 65, 67, 212
international language support 109
legacy interface elements 55
menu files 49
menu referencing 229
pull-down menus 65, 213
rearranging commands 44
removing 231
shortcut menus 67
submenus 227
swapping 110, 230
tablet menus 272
workspace arrangements 298
migrating
customization FAQs 319
menu files from previous
releases 316
MNC files 49
MNL files (menu LISP)
customization and 49
MNR files (menu template) 49
MNS files (source menu)
changes in customization and 48
defined 55
migrating 316
MNU files (menu template)
changes in customization and 48
defined 55
migrating 49, 316
model space
slides created in 346
modifying
commands 94
double click actions for 262
shortcut keys 248
toolbars 192
mouse
coordinates of crosshairs 271
customizing button actions 69, 270
double click actions 262
swapping actions 110
multiple configuration files 6
multiple-line hatch patterns 34
multiplication DIESEL function 331
n
naming
linetypes 21
networks
tablet menus 110
enterprise customization files
and 82
nodes
  interface customization 56
not equal to DIESEL function 333
nth DIESEL function 340
number pad keys 248, 253, 256, 261

O
object properties
  customizing 233
objects
  double click actions 266
  properties 233
  shortcut menus 218
or DIESEL function 341

P
palettes
  defined 56
  displaying 294
  workspaces and 298, 312
paper space
  slides created in 346
partial customization files
  about 73
  creating 78
  defined 56
  toolbars and 232
partial menu files 231
PAT files 11
patterns
  linetypes 22
pausing macros 103, 106
PGP files (program parameters) 11
plot styles
  locating files 9
plotter configuration files
  locating files 10
  multiple files 6
PMP files (plot model parameter) 10
pointing devices
  coordinates of crosshairs 271
  customizing button actions 270
  double click actions 262
  multiple configuration files 6
swapping actions 110
prefixes for commands 18
preloading slides 354
previous releases
  backwards compatibility 48
  changes in customization process 48
  legacy interface elements 272
  migrating custom settings from 316
printing
  lists of shortcut keys 248
profiles 9
prompts
  suppressing 103
properties
  commands 92
  customizing 233
  Quick Properties panel 233
toolbars 190
  workspaces 282
PSF files 11
Publish to Web wizard
  customizing templates 14
pull-down menus
  creating 65, 213
  customizing 65, 212, 231
  menu referencing 229

Q
Quick Access toolbar 56, 60, 142, 293,
  297
Quick Properties panel 233

R
rearranging
  menus 44
  ribbon items 155
  ribbon tabs 180
  toolbar buttons 190
repeating commands 109
referencing menus 229–230
removing
  menus 231
  ribbon items 155
  toolbar buttons 190
replacing commands in CUIx files 86
ribbon
command images 129, 132, 134
contextual tab states 64, 187
controls 171
customizing 61, 149
defined 56
drop-downs on panels 167
reorganizing command and controls 155
ribbon panels 56, 61
ribbon tabs 63–64, 180
workspaces and 297
ribbon panels
adding items to 155
controls for 171
creating 61
customizing 149, 294
defined 56
drop-downs on 167
rearranging 297
ribbon tabs
contextual tab states 64, 187
creating 63, 180
customizing 294
rearranging 297
roaming profiles 9
rollover tooltips 241
rows (ribbon) 149
rtos DIESEL function 341

S

SCR files (scripts) 350
scripts
about 345, 350
file names and 350, 353
running at startup 352
running slide shows from 354
switches and 353
search paths
default file locations 4
searching
finding commands in CUIx files 86
finding tagged commands 119
selecting objects with macros 110
shortcut keys
assigning 248
customizing 68
defaults 253
temporary override keys 256, 261
shortcut menus
aliases 217
ccontext-sensitive shortcut menus 217
creating 67, 217
customizing 67, 212
double click actions 262
menu referencing 229
slide libraries 277, 348
slide shows 354
SLIDELIB utility 348
slides
about 345
creating 345
editing commands and 347
image tile menus and 275, 277, 348
preloading 354
slide libraries 348
slide shows 354
viewing 347
source menu files (MNS) 48–49, 55, 316
spaces in linetypes 20
special characters
commands and 227
image tile menus 275
macros and 101, 104, 227
startup scripts 352
status line 128, 325–326
strings in CUIx files 86
strlen DIESEL function 341
submenus 227
substr DIESEL function 342
subtraction DIESEL function 331
support files
locations 11
suppressing echoes and prompts 103
swapping
interface elements with macros 110
menus 230
switches
  running scripts and 353
switching
toolbar controls 207
symbols
  commands and 227
  image tile menus 275
  macros and 101, 104, 227
syntax
  macros 101
system variables
toggling values with macros 112

T
tables
  customizing buttons 270, 274
  customizing menus 272
  menu swapping 110, 231
tags
  element IDs 55
  menu commands 119
templates
  customizing 14
temporary override keys 255, 261
terminating macros 103
text
  including in linetypes 24
time
  edtime DIESEL function 336
toolbar buttons
  customizing 190
  images 190
  rearranging 44, 190
toolbars
  command images 129, 132, 134
  controls on 207
  creating 64, 192
  customization FAQs 320
  customizing 64, 190
  displaying 294
  flyouts on toolbar buttons 202
  naming 190
  partial CUIx files and 232
  properties 190
  Quick Access toolbar 60, 142, 297
  rearranging elements on 44
  workspace arrangements 297
tooltips
  command Help in 122
  customizing 241
  transferring customization files 316
  translating macros 109
  transparent commands 106
tree nodes 56

U
unique IDs (element IDs) 55
unloading
  partial customization files 78
UNT files 11
updating
  customization files 316
upgrading
  customization FAQs 319
  migrating customization files 316
upper DIESEL function 342
user input
  pausing macros 106
user interface
  changes in customization process 48
  customization FAQs 319
  Customize User Interface editor 39, 58, 296
  customizing 39
  legacy interface elements 272
  terminology 54
  workspaces 70

W
web pages
  templates 14
windows
  customizing 296
  workspaces and 312
workspaces
  CUI Editor 280, 296
  current 283
  customization FAQs 321
  customizing 70, 280, 293
defined 56
importing 282
properties 282
ribbon tabs 180
toolbars in 190

X

XAML files 123
xor DIESEL function 343