iPhoto
Getting Started
Get to know iPhoto and learn how to import and organize your photos, and create a photo slideshow and book.
Contents

Chapter 1  3  Welcome to iPhoto
  3  What You’ll Learn
  4  Before You Begin
  4  What You Need
  5  The iPhoto Interface

Chapter 2  6  Learn iPhoto
  6  Step 1: Import Your Photos
  9  Step 2: Organize and View Your Photos
 10  Using Keywords
 11  Organizing Your Photos
 12  Step 3: Create a Slideshow
 13  Setting Slideshow Options
 14  Playing a Slideshow
 15  Step 4: Create a Book
 16  Making Changes to Your Book
 18  Editing Text in Your Book
 19  Continue to Explore iPhoto
 20  Getting More Help
Welcome to iPhoto

Create lasting treasures from your digital photos. This document familiarizes you with the basic features of iPhoto and introduces you to new features in iPhoto ’08.

iPhoto offers you many ways to enhance and share your digital photos, whether you have 100 images or 100,000. With iPhoto, you can quickly import and organize photos, improve or enhance them, and order or make your own prints.

You can use iPhoto to create slideshows, books, calendars, and cards. From within iPhoto, you can also email your photos or use them as screensavers, and publish photo albums to your MobileMe Gallery for others to view or download.

What You’ll Learn
If you follow all the steps in this tutorial, you’ll be able to:
• Connect your camera to your computer
• Import your photos into iPhoto from your camera
• Sort your photos in several ways
• Use or add keywords to find and organize your photos
• Group your photos into one or more photo albums
• Create and play a slideshow
• Create a book
Before You Begin
To make it easier to do the tasks in this tutorial, it’s a good idea to print this document before you start.

In many tasks shown in this tutorial and in iPhoto Help, you need to choose menu commands, which look like this:
Choose File > New Album.

The first term after Choose is the name of a menu in the iPhoto menu bar at the top of your computer screen. The next term is the item you choose from that menu.

What You Need
To complete all the parts of this tutorial, you need:
• A digital camera compatible with iPhoto (most digital cameras work with iPhoto, but for specific compatibility details, check with your camera’s manufacturer)
• Photos saved in your digital camera
• A computer with Mac OS X and iPhoto installed
• Built-in Universal Serial Bus (USB) ports on both your camera and computer
• An A-to-B USB cable, which connects your camera to your computer
The iPhoto Interface
When you open iPhoto, you’ll see the viewing area, which allows you to choose what you want to do next, such as organize or view images, edit them, or use them to create slideshows, books, calendars, or cards.
Learn iPhoto

You’ve shot some great pictures with your digital camera. Now it’s time to import them into iPhoto and organize them in ways that make it easy to share them by creating slideshows, books, and more.

Step 1: Import Your Photos
To edit and share your photos, you must first transfer them to your computer. This transfer process, known as importing, copies the photo files from their original source into iPhoto, where you can then work with them in a variety of ways.

Importing from a digital camera is the most common method of transferring photos to iPhoto.

To connect your camera to the computer:
1. Open iPhoto, located in the Applications folder on your computer.
2. Turn off your camera.
3. Plug the A connector (shown above) on your USB cable into the USB port on your computer.
4 Plug the B connector (shown above) on your USB cable into the USB port on your camera.

5 Turn on your camera.

Your camera should appear below Devices in the iPhoto Source list, located on the left side of the iPhoto window. The pictures in your camera will appear in the viewing area. If nothing happens when you connect your camera, make sure it's turned on and set to the correct mode for importing photos. For information about which mode to choose, see the instructions provided with your camera.

Also, you can set your preferences to open iPhoto automatically when you connect your camera. To do so, choose iPhoto > Preferences and click General at the top of the dialog. Choose iPhoto from the pop-up menu labeled, “Connecting camera opens.”

To import your photos from a digital camera:

1 Type a name in the Event Name field that describes the group of photos you’re importing (for example, “Mike’s Wedding, roll #4”).

Your photos will be imported into an Event group of that name. Photos are organized into Events in the iPhoto library so they’re easy to find and view.

2 Type a description (for example, “Pictures from the second half of Mike’s reception”) in the Description field for the group of photos.

3 If you want, you can select the “Auto split Events after importing” checkbox.

This is useful if you are importing photos from several different days. iPhoto will automatically split your photos into several different Events in the iPhoto library.

4 If you have already imported some of the photos in your camera, you can select the “Hide photos already imported” checkbox so that you see only the new photos in the Import window.

5 You can also choose to import only some of the images. To do so, hold down the Command (⌘) key as you click each photo you want.

6 To import all your photos, click the Import All button. If you have selected specific photos to import, click the Import Selected button.

To stop importing your photos at any time during the process, click Stop Import.
Before disconnecting your camera, wait until all your photos have been imported into iPhoto (or click Stop Import). If your camera has a sleep mode, make sure it's disabled or set to a time increment long enough to allow your images to download. For more information, see the instructions that came with your camera.

To view your pictures, click Last Import (in the Source list) or click Events and view your photos by Event.

To disconnect your camera from your computer:
1 Drag the camera's icon to the iPhoto Trash.
2 Turn off your camera.
3 Disconnect your camera from your computer.

**Importing Photos Without Using a Digital Camera**
In addition to importing photos on a digital camera, you can import photos that are:
- Saved on a CD. (When you take your 35 MM. film to be developed, ask if the photo developer can store your photos on a CD or floppy disk. Many offer this service.)
- Saved on a DVD or flash drive.
- Located in a file or folder on your hard disk.
- Saved on a memory card.

If you're not using a digital camera, for best results, ensure that all photos are in JPEG format.

To learn more about importing photos, see the topics in iPhoto Help.

You're now ready to view and organize your photos.
Step 2: Organize and View Your Photos

After you import your photos into iPhoto, it’s time to view and sort them, add keywords and view photos by keyword, and create a photo album.

To find your photos:

In iPhoto, all photos are stored in the iPhoto library. You can see the photos in the library by clicking Events, located at the top of the Source list on the left side of the iPhoto window.

The library holds all the photos and video clips you import, arranged by Event groupings based on the date they were taken.

Albums help you organize your photos by subject.

Smart Albums are automatically updated based on criteria you choose.

Published albums can be viewed on the web and updated regularly.

Books include photos and text.

Slideshows of your photos include transition effects and background music.

In the library, photos are grouped by year and by Event (an Event might represent an actual film roll, such as a roll of 35 MM. film stored on a photo CD, or a group of photos you imported from a digital camera).

iPhoto displays your photos in the order in which you imported them. To quickly display only your most recent photos, click the Last Import icon in the Source list. Clicking the Last Month icon shows you a larger set of your photos.

You can view photos in the photo library by sorting them in a variety of ways.
To sort your photos:
1. Click to select Photos in the Source list.
2. Choose View > Sort Photos, and then choose an option from the submenu:
   - **By Date:** Arranges photos by the date on which they were taken.
   - **By Keyword:** Arranges photos alphabetically by any keywords you’ve assigned to them (see the next section, “Using Keywords”).
   - **By Title:** Arranges photos alphabetically by their titles.
   - **By Rating:** Arranges photos from lowest to highest rating. (You can rate your photos to identify your favorites. See “Rating Favorite Photos” on page 11.)

You can also sort your Events. To learn more, see the topics in iPhoto Help.

**Using Keywords**
Keywords are brief labels you can add to your photos, such as “Birthday” or “Sports,” so you can easily find all the photos in a specific category.

iPhoto comes with some basic keywords; you can assign these to your photos or create your own keywords by editing the Keywords list. After you add a keyword to the Keywords list, you can assign it to any photo.

To assign keywords to your photos:
1. Select the photos you want to add keywords to. To do so, select Events in the Source list, double-click a specific Event to open it, and then click to select a photo.
2. Choose Window > Show Keywords to open the Keywords window.
3. Click to select the keyword you want to attach to the photo. You can select one keyword or many.
   To deselect a keyword, click it again.

To add your own keywords to the Keywords list:
1. Choose Window > Show Keywords.
2. Click the Edit Keywords button.
3. Click the Add (+) button.
4. Type your new keyword.
5. Click OK.

You can also delete keywords, rename keywords, or add shortcut names for long keywords.

*Important:* Editing a keyword changes that keyword in any photos to which you’ve assigned it.
To search for a photo by its keyword:
1. Click the search icon (on the left end of the search field).
2. Choose Keyword from the pop-up menu.
3. Click to select one or more keywords. Photos with those keywords appear in the viewing area.

Rating Favorite Photos
You can assign photos a one- to five-star rating to indicate how much you like them. These photo ratings can also make it easier to sort photos or find them later.

To rate photos:
1. Click to select the photo or photos you want to rate.
2. Choose Photos > My Rating, and then choose the number of stars you want to assign from the submenu.

Organizing Your Photos
You can group your photos into albums to better organize your photo library, put together the photos you want to burn to CD or DVD, or choose the pictures you want to publish on a webpage, for example.

In addition, you can use an album as a temporary holding place for a group of photos until you’re ready to create something else from the photos, such as a slideshow, book, calendar, or greeting card, or to publish your album to your MobileMe Gallery. Photos in your photo library are not affected by moving them into or out of albums.

To create a photo album:
1. Click the Add (+) button in the bottom-left corner of the iPhoto window.
2. Click the Album button in the dialog.
3. Type a name for your album and click Create.
   Your new album appears in the Source list.
4. Click Events in the Source list, and double-click an Event to open it.
5. Drag photos from the Event to your new album in the Source list.
   You can drag photos from more than one Event into your album.

   You can also drag a photo to an album directly from another album, a CD or DVD, or from another location on your hard disk. When you add a photo to an album this way, iPhoto automatically imports it into your photo library.
You can also create Smart Albums that can be automatically updated as your library changes. To learn more about creating Smart Albums, see the topics in iPhoto Help.

Making an Album from a Folder of Photos
You can also create an album by dragging a folder of photos from the Finder to a folder in the Source list. iPhoto creates an album with the dragged folder’s name and imports all the photos in the folder into your photo library.

Now that you’re comfortable moving around in iPhoto, you’re ready to create your first slideshow of favorite photos.

Step 3: Create a Slideshow
In a slideshow, photos appear one at a time, in succession. You can use as many photos as you want in a slideshow and arrange them in any order. When you save a slideshow, it appears in your Source list below Slideshows.

To create a slideshow:
1. Select the photos you want to include in your slideshow:
   • To use an entire album, click the album in the Source list on the left side of the iPhoto window.
   • To use a particular Event, click Events in the Source list, and then click to select the Event you want in the viewing area.
   • To select multiple photos in an album or your library, open the album or library and hold down the Command (⌘) key as you click each photo you want.

2. Click the Add (+) button in the bottom-left corner of the iPhoto window.

3. Click the Slideshow button in the dialog.

4. Type a name for your slideshow and click Create.
   Your new slideshow appears in the Source list.
In the photo browser at the top of the iPhoto window, drag the slideshow photos into the order you want them to appear.

To start your slideshow, click the Play button. To stop it, click anywhere on the screen.

**Setting Slideshow Options**
Before playing a slideshow, you can add your own background music, specify the display duration for each slide, choose among different transitions between slides, display slideshow controls, and set other options.

**To specify the display duration:**
1. Click to select your slideshow in the Source list.
   The iPhoto window changes to slideshow view.
2. Click the Settings button in the bottom-right corner of the slideshow window.
3. In the Settings dialog, click the arrows next to “seconds” to specify the number of seconds you want each photo to stay on the screen.

**To choose transition effects:**
1. Click to select your slideshow in the Source list.
   The iPhoto window changes to slideshow view.
Click the Settings button in the bottom-right corner of the slideshow window.

Choose a transition from the Transition pop-up menu.

The default transition for a new slideshow is the Dissolve transition. You can choose to have photos appear as if they’re on different sides of a cube, have one fade through black to the next, and so on.

Specify the transition duration using the speed slider.

In this dialog, you can also set other options for the entire slideshow, including the size of the photos, the Ken Burns Effect, and whether the slideshow repeats automatically.

You can also add background music to your slideshow from the sample music folder or your iTunes library.

To add background music to your slideshow:
1. Click to select your slideshow in the Source list. The iPhoto window changes to slideshow view.
2. Click the Music button in the bottom-right corner of the slideshow window.
3. Click to select a song or a playlist to play during your slideshow.
   You can search for a song by typing the artist or title in the search field.
4. Click OK.

Playing a Slideshow
After you create a slideshow, you can play it on your computer. The slideshow fills your entire screen while it plays.

To play a slideshow:
1. Click to select the slideshow you want to play in the Source list.
2. To start the slideshow, click the Play button in the bottom-left corner of the slideshow window.

To stop the slideshow, click anywhere on the screen. To pause or resume playing a slideshow, press the Space bar.

While viewing your slideshow, you can:
  - Use the Up and Down Arrow keys to adjust the speed of your slideshow
  - Use the Right and Left Arrow keys to move through a slideshow manually
• Press Delete to remove the photo currently being displayed from the slideshow
• Press Command-R to rotate the photo currently being displayed. (The Command key has a ⌘ symbol on it.)

**Another Way to See Photos as a Slideshow**
You can view any combination of photo albums or individual photos as a temporary slideshow. Simply click to select the photos or albums you want to view, and then click the Play button in the bottom-left corner of the iPhoto window.

You have completed your first slideshow.

**Step 4: Create a Book**
It’s easier to create a book in iPhoto than to print all your photos and paste them in a scrapbook. And after you’ve created your masterpiece, you have a variety of options for sharing: You can print it on a color printer, order it as a bound book, or even use it as the basis for a more creative slideshow.

**To create a book:**
1. Select the photos you want to include in your book:
   • To use an entire album, click the album in the Source list.
   • To use a particular Event, click Events in the Source list, and then click the Event you want to select in the viewing area.
   • To select multiple photos in an album or Events in your library, open the album or Event and hold down the Command (⌘) key as you click each photo you want.
2. Click the Add (+) button in the bottom-left corner of the iPhoto window.
3. Click the Book button in the dialog.
4. Type a name for your book.
5. Choose a hardcover, softcover, or wirebound softcover book size from the Book Type pop-up menu.
6. Select a theme for your book from the scrolling themes list.
   When you select a book theme, you can see an example of it to the right of the themes list. (For detailed descriptions and prices, click the Options + Prices button to go to the iPhoto website.)
7. Click Choose. iPhoto switches to book view.
   Your new book appears in the Source list, and the photos you selected are shown above in the photo browser as thumbnails.
If you chose a hardcover book and want photos to be printed on only one side of the book’s pages, click the Settings button and deselect the “Double-sided pages” checkbox in the dialog.

Drag photos from the photo browser to photo frames on your book pages.

A thumbnail for each photo used will remain in the photo browser, marked with a checkmark to show that photo is in use. If you have more photos than you need to fill up all your book pages, you can leave the extras in the photo browser. If you need more photos, see the next section, “Making Changes to Your Book”.

### Letting iPhoto Design Your Book for You

iPhoto can automatically design your book. To place all your selected photos on book pages in the order they appear in your library or album, click the Autoflow button.

### Making Changes to Your Book

You can try a different theme for your book, add and rearrange photos, and edit text in your book. To find out how to make even more changes to your book, see the topics in iPhoto Help.

**To change the theme of your book:**

1. Click to select the book whose theme you want to change.
2. Click the Themes button in the toolbar.
3. Select a theme for your book from the scrolling themes list.

You can also change the type of book in this dialog. Choose an option (hardcover, softcover, or wirebound softcover) from the Book Type pop-up menu.

4. Click Choose.

It’s a good idea to decide on a theme before adding text to a book layout. If you add custom text to a book layout and then change themes, you may lose your text.

If you chose a hardcover book and want photos to be printed on only one side of the book’s pages, click the Settings button and deselect the “Double-sided pages” checkbox in the dialog.
**To add photos to your book:**

1. Click to select an Event in your library or an album in the Source list.
2. Drag photos from the library or album to your book in the Source list.
3. Click to select your book in the Source list. iPhoto switches to book view.
4. Click the Photo Browser button to view all the photos for your book, including the new ones you added.

   The browser is a holding area, like a waiting room, for the photos you want to place in your book.

5. Do one or more of the following to place photos in your book:
   - To add a photo to an empty photo frame in your book, drag the photo from the photo browser to the empty frame.
   - To replace a photo in your book with a new photo, drag the new photo from the photo browser to the photo you want to replace. The new photo replaces the old photo.
   - To add a photo to a page, first change the number of photos allowed on that page by clicking Layout in the toolbar and choosing an option from the pop-up menu, and then drag photos to the new empty frames.
   - To add all unplaced photos to the book, click the Autoflow button. Pages are automatically added as needed.

You can change the order of photos on an individual page or from one page to another.
To rearrange photos in your book:

1. Click the Page View button to display book pages in the photo browser.

2. Do one of the following:
   - To swap photos that appear on the same page, click to select the page in the photo browser, and then, in the viewing area, drag one of the photos you want to swap to another photo.
   - To swap photos that appear in the same page spread, click the Two-Page View button, click to select the page spread in the photo browser, and then drag one of the photos you want to swap to another photo.
   - To move a photo from one page to another, click to select the page on which the photo appears in the photo browser, and then drag the photo from the viewing area to a new page in the photo browser.

Editing Text in Your Book

Most book themes include pages that contain text you can edit. If you don’t see any text on a page and you want to add some, you need to choose a design for your page that includes text. For more information about choosing and changing themes in a book, see the topics in iPhoto Help.

To edit text in your book:

1. Click the Page View button to display book pages in the photo browser.
2. Click to select the page that contains text you want to edit.
3. In the viewing area, click the text you want to edit, and then add or edit text.
When editing text, it's a good idea to zoom in on the text area first. To do so, drag the size slider to the right.

If you don't want text where a text field exists, don't enter any. The placeholder text, such as "Insert Title," will not appear in the book if the text field is not changed.

**Viewing a Book as a Slideshow**

You can use an iPhoto book as the base for a more creative slideshow to share with friends and family. Choose from a range of book themes, add your pictures and text, and then click the Play button to view the sequence. You can edit it as a slideshow by adjusting transitions, adding background music, and more.

With the successful creation of a book, you have now completed the full iPhoto tutorial. If you would like to print or order a copy of your book, see the topics in iPhoto Help.

**Continue to Explore iPhoto**

iPhoto ’08 offers a host of creative ways to use and enhance your photos. Check out one or more of these additional features:

- **Fast web publishing:** Use your MobileMe Gallery to share your photo albums online with a single click. Friends and family can view your photos or download them to print large, high-quality images—and even upload their own photos to share with you. You can also email photos from your mobile phone or other mobile device to your published albums.

- **Full-screen view:** Take advantage of every pixel your monitor can muster to view and show off your photos from one edge of your computer screen to the other. The large, high-resolution view makes editing easier and more precise. You can also view two or more photos at once, so that you can compare or edit them side by side.

- **Precise editing and special effects:** From cropping to color correction to retouching, iPhoto gives you tight control over the enhancements you make to your photos. For faster fixes, one-click editing lets you boost colors in a washed-out image, tone them down in a too-bright one, or use special enhancements such as blurring the edges or adding a vignette effect.
• **Custom keywords and quick searching:** Add standard or customized keywords to your photos so you can organize them to meet your specific needs, and create shortcuts to your most commonly used keywords. Search on text, keywords, date, or ratings to find exactly the photos you’re looking for quickly and easily.

• **Desktop printing:** Adjust the size, crop, or color in your photos without affecting the original image, choose from Apple-designed textured borders, and print photos suitable for framing right on your own printer.

• **Cool calendars:** Remind yourself of favorite people and moments with a 10 x 13 wall calendar created from your photos. Choose from a range of themes, and customize with your preferred holidays. Mark special days such as birthdays and anniversaries with your own photos and text.

• **Personal greeting cards:** Send your very best photos to friends and family as 4 x 6 double-sided or 5 x 7 folded greeting cards. Choose from themes such as birthdays, invitations, postcards, or blank cards, add your own message, and have a set sent straight to your door.

• **Full-scale websites:** Craft your own website or blog by sending your photo albums from iPhoto to iWeb, Apple’s web publishing application. Choose the theme that best displays your images, design the layout, add links, and place ads. Visitors can view and comment on your photos or blog entries.

**Getting More Help**

To get help while you’re using iPhoto, look in iPhoto Help, which is available from the Help menu when iPhoto is open. You’ll find more information about the topics covered in this document, as well as information about and instructions for many more topics.

You can also view how-to videos about popular iPhoto topics at www.apple.com/ilife/tutorials/iphoto. For technical information, discussion groups, and system requirements, go to www.apple.com/support/iphoto.

For complete and up-to-date information about iPhoto, including tips, news about the latest features, and a list of compatible cameras, go to the iPhoto website at www.apple.com/ilife/iphoto