Chapter 1: What’s new in Final Cut Pro?
13 What’s new in Final Cut Pro 10.0.3?
14 What’s new in Final Cut Pro 10.0.1?

Chapter 2: Final Cut Pro basics
15 What is Final Cut Pro?
16 Final Cut Pro workflow overview
18 Final Cut Pro interface overview
21 Media files and clips
22 Events and projects

Chapter 3: Import media
24 Importing overview
25 If it’s your first import
25 Import from connected devices
25 Import from file-based devices
30 Import spanned clips
33 Import from iPhone, iPad, or iPod touch
34 Import from a digital still camera
35 Import from tape-based devices
37 If your device isn’t recognized
38 Import from other applications
38 Import from iMovie
39 Import from iPhoto and Aperture
40 Import from iTunes
40 Import from disks
40 Import from a hard disk
42 Access media on an archive or disk image
45 Organize files while importing
46 Import while recording
48 About memory cards and cables
49 Supported media formats
Chapter 4: Analyze media

Analyzing media overview
Video and still-image analysis options
Audio analysis options
Analyze your media
View analysis keywords on clips

Chapter 5: Organize your media
Events and clips overview
Organize Events
Create a new Event
Rename an Event
Merge or split Events
Copy or move clips between Events
Copy or move Events
Sort Events
Delete clips or Events
Organize clips
View and sort clips
Rename clips
Rate clips as Favorite or Rejected
Add keywords to clips
Add or edit clip notes
Organize clips by roles
Find clips in the Event Browser
Save searches as Smart Collections
Organize Keyword and Smart Collections

Chapter 6: Play back and skim media
Playback and skimming overview
Play back media
Skim media
Use the J, K, and L keys
Play back media in a loop
Play video full screen
View playback on a second display
View playback on an external video monitor
Playback and background rendering
Play your projects on other devices
Chapter 7: Create and manage projects

Create a new project
Preview and open a project
Modify a project’s name and properties
Organize projects in the Project Library
Save projects

Chapter 8: Edit your project
Editing overview
Select clips and ranges
About selections and filmstrips
Select one or more clips
Select a range
Add and remove clips
Adding clips overview
Drag clips to the Timeline
Append clips to your project
Insert clips in your project
Connect clips to add cutaway shots, titles, and synchronized sound effects
Overwrite parts of your project
Replace a clip in your project with another clip
Add and edit still images
Add clips using video-only or audio-only mode
Remove clips from your project
Solo, disable, and enable clips
Find a Timeline clip’s source clip
Arrange clips in the Timeline
Cut and trim clips
Trimming overview
Cut clips with the Blade tool
Extend or shorten a clip
Make roll edits with the Trim tool
Make slip edits with the Trim tool
Make slide edits with the Trim tool
Show detailed trimming feedback
View and navigate
Zoom and scroll in the Timeline
Adjust Timeline settings
Navigate within your project
Navigate using timecode
Use the Timeline Index to view, navigate, and search your project
## 166 Add and remove markers

### 166 Markers overview

- Add and remove markers
- Edit and move markers
- Jump between markers
- Correct excessive shake and rolling shutter issues

### 172 Chapter 9: Add and adjust audio

- Audio overview
- Add audio
  - Add music and sound
  - Record audio
- Add and adjust audio effects
  - Add audio effects
  - Adjust audio effects
  - Adjust audio effects using keyframes
- Adjust and enhance audio
  - Adjust volume
  - Enhance audio
  - Fade audio in or out
- Pan audio
- Configure audio channels
- Match audio equalization settings
- Preserve pitch when retiming clips
- Audio tools and techniques
- View and correct audio levels
- About audio waveforms
- View audio waveforms at the audio sample level
- Ways to view audio clips
- Solo and mute audio clips
- Sync audio and video automatically
- Use roles to organize clips and export audio files

### 217 Chapter 10: Add transitions, titles, effects, and generators

- Transitions, titles, effects, and generators overview
- Add and adjust transitions
- Transitions overview
- How transitions are created
- Set the default duration for transitions
- Add transitions to your project
- Delete transitions from your project
224  Adjust transitions in the Timeline
227  Adjust transitions in the Transition inspector and Viewer
228  Adjust transitions with multiple images
229  Create specialized versions of transitions in Motion
229  Add and adjust titles
229  Titles overview
230  Add titles to your project
232  Adjust titles
234  Remove titles from your project
235  Find and replace text in your project
236  Adjust built-in effects
236  Built-in effects overview
236  Resize, move, and rotate clips
238  Trim clips
240  Crop clips
241  Pan and zoom clips
243  Skew a clip’s perspective
244  Work with built-in effects
250  Add and adjust clip effects
250  Clip effects overview
251  Add effects to your project
252  Adjust effects in Final Cut Pro
255  Change clip effect order
257  Turn off or remove an effect from a clip
257  Create specialized versions of the video effects in Motion
258  Add generators
258  Generators overview
259  Use a placeholder
260  Use a timecode counter
261  Use a shape
262  Use a background
263  Create specialized versions of the generators in Motion
264  Use onscreen controls
264  Onscreen controls overview
264  Show or hide onscreen controls
265  Onscreen control examples
270  Use the Video Animation Editor
270  Video animation overview
271  Adjust video effects using keyframes
281  Adjust effect curves using fade handles or keyframe animation
Chapter 11: Advanced editing

Group clips with compound clips
Compound clips overview
Create and break apart compound clips
Manage compound clips
Add storylines
Fine-tune edits with the Precision Editor
Create split edits
Make three-point edits
Three-point editing overview
Three-point edit examples
Try out clips using auditions
Auditions overview
Create auditions to try out clips
Add and remove clips in auditions
Use auditions to try out clips in your project
Retime clips to create speed effects
Retiming clips overview
Change clip speed
Reverse or rewind clips
Create instant replays
Create freeze frames
Reset retimed clips to play at normal speeds
Edit with mixed-format media
Use roles to manage clips
Roles overview
View and reassign roles
Create custom roles and subroles
View clips by role in the Timeline
Use roles to export media stems
Use XML to transfer projects and Events
Edit with multicam clips
Multicam editing overview
Multicam editing workflow
Import media for a multicam edit
Assign camera names and multicam angles
Create multicam clips in the Event Browser
Cut and switch angles in the Angle Viewer
Sync and adjust angles and clips in the Angle Editor
Edit multicam clips in the Timeline and the Inspector
Multicam editing tips and tricks
# Chapter 12: Keying and compositing

- **Keying**
  - Keying overview
  - Use chroma keys
  - Use luma keys
  - Finalize the key

- **Compositing**
  - Compositing overview
  - Use alpha channels
  - Use Compositing settings

# Chapter 13: Color correction

- **Color correction overview**
- Analyze and balance color automatically
- Color balance overview
- Analyze a clip for color balance
- Balance a clip's colors
- Match color between clips automatically
- Adjust color manually
- Manual color correction overview
- Color correct the whole image
- Target a specific color using a color mask
- Target specific areas using shape masks
- Add shape masks to a color mask
- Apply multiple color corrections
- Add a transition between color corrections
- Save and apply color correction presets
- Turn iMovie adjustments on or off
- Measure video levels
- Video scopes overview
- Use the video scopes
- Waveform Monitor display options
- Vectorscope display options
- Histogram display options

# Chapter 14: Share your project

- **Sharing projects overview**
- Share with other applications
- Use the Media Browser to share your project with iLife and iWork
- Play your project in iTunes, on mobile devices, or with Apple TV
- Email your project
- Publish your project to Podcast Producer
Contents

440  Burn your project to a disc or create a disk image
444  Share on the web
444  Publish your project to YouTube
445  Publish your project to Facebook
446  Publish your project to Vimeo
447  Publish your project to CNN iReport
448  Export your project
448  Export your project as media files
454  Export an image from your project
454  Export your project as an image sequence
455  Export your project for web streaming
456  Export your project using Compressor
459  Status of shared projects
459  Shared projects overview
461  Visit and announce shared projects
462  Remove shared projects
462  About Share Monitor

463  Chapter 15: Manage media files
463  Media management overview
464  Where your media and project files are located
466  Manage your media files
466  View a clip's information
467  Relink clips to media files
473  Transcode media files
476  View background tasks
477  Delete render files to free up disk space
478  Manage your Events and project files
478  Before you move or copy Events and projects
478  Consolidate a project’s media files
479  Back up projects, your Project Library, and Events
482  Edit your project on a different computer
487  Use SAN locations for Events and projects
488  Create and manage camera archives
492  Solutions to common media management issues
492  Alert icons
494  Common media management issues
What’s new in Final Cut Pro 10.0.3?

Final Cut Pro 10.0.3 includes major new features and enhancements, detailed below.

Multicam editing
You can now use multicam clips to edit footage from multicamera shoots or other synchronized footage in real time. Working with multicam clips in Final Cut Pro is a flexible and fluid process. While the active angle plays in the Viewer, you can also view all angles playing simultaneously in the Angle Viewer and easily cut and switch between them. You can create multicam clips from diverse media sources and modify existing multicam clips during the editing process.

For more information, see “Multicam editing overview” on page 351.

A/V output
You can now connect your computer to an external video monitor for audio and video (A/V) output. In addition to showing you how video and audio look and sound on an NTSC/PAL or HD broadcast monitor, this feature also allows you to test output with more sophisticated devices such as vectorscopes and waveform monitors.

A/V output is available only with OS X Lion v10.7.2 or later and requires compatible third-party video interface hardware and software. FireWire DV devices are not supported. For more information, contact the device manufacturer or go to the Final Cut Pro X Resources webpage at http://www.apple.com/finalcutpro/resources.

For more information, see “View playback on an external video monitor” on page 90.

Manual relinking of clips to media files
Now you can manually relink Event clips and project clips to media files. Manual relinking gives you more control over your post-production workflow.

For more information, see “Relink clips to media files” on page 467.
Other notable features

- Layered graphics files, such as Adobe Photoshop (PSD) files, can now be edited so that each layer appears as a connected clip in the Timeline.
- Advanced Keyer controls are now available.
- Keyframing controls are improved in the Video and Audio Animation Editors.

What’s new in Final Cut Pro 10.0.1?

Final Cut Pro 10.0.1 includes a number of new features, enhancements, and changes. The most significant features are introduced below.

Roles

You can use the new roles metadata labels to organize clips in your Events and projects, control the appearance of the Timeline, and export separate video or audio files (also known as media stems) for broadcast delivery, audio mixing, or post-production. For example, you can export roles as media stems in a combined, multitrack QuickTime file, or as separate audio or video files. During the export process you can assign mono, stereo, or surround output for your audio channels.

For more information, see “Roles overview” on page 339 and “Export your project as media files” on page 448.

Storage area network (SAN) locations

You can now add network volumes as storage locations for Events and projects. When you remove SAN locations in Final Cut Pro, other users on the network can work with the Events and projects stored on those locations.

For more information, see “Use SAN locations for Events and projects” on page 487.

XML export and import

Final Cut Pro now supports XML import and export so that you can transfer your project and Event information to and from systems and third-party applications that don’t recognize Final Cut Pro projects and Events.

For more information, see “Use XML to transfer projects and Events” on page 350.
Final Cut Pro basics

What is Final Cut Pro?

Final Cut Pro X is a revolutionary application for creating, editing, and producing the highest-quality video. Final Cut Pro combines high-performance digital editing and native support for virtually any video format with easy-to-use and time-saving features that let you focus on storytelling.

In Final Cut Pro, you can:

- Edit everything from uncompressed standard-definition video to HDV, DVCPRO HD, and uncompressed high-definition video—as well as file-based formats such as AVC-Intra, AVCHD, and XDCAM HD.
- Play back and skim resolution-independent media up to 4K resolution. You can also play your video full screen or on a second display.
- Assemble clips with ease using the Magnetic Timeline, which fluidly adjusts clips around the clip you’re dragging to eliminate gaps, collisions, and sync problems.
- Edit quickly with the complete set of professional editing and trimming tools. Fine-tune edits with the inline Precision Editor.
• Have Final Cut Pro analyze your video and nondestructively fix common problems such as camera shake, excess hum, or loudness. You can also have Final Cut Pro detect the presence of people or the shot type, and automatically apply keywords such as One Person or Wide Shot.

• Organize your media using Keyword Collections, which automatically group clips based on keywords, and Smart Collections, which automatically group clips based on criteria you specify.

• Try out clips in your project using auditions—sets of alternate takes, effects, or text treatments—and then choose the best clip for the edit.

• Create compound clips to group any combination of clips, and nest clips within other clips.

• Use connected clips and storylines to add cutaway shots, superimposed titles, and sound effects to your project. Connected clips and storylines always stay in sync.

• Add special effects to video, audio, and photos, and adjust them using keyframes and onscreen controls. You can also change clip speed to create fast-motion or slow-motion effects.

• Automatically balance and match color, or use the color correction tools to precisely control the look of any clip in your project.

• Publish your project directly to websites such as YouTube and Facebook, or send your project to iTunes for syncing with Apple devices such as iPhone, iPad, and Apple TV.

---

**Final Cut Pro workflow overview**

To give you an idea of the possibilities, the overall process for putting together a movie with Final Cut Pro is described below. You don’t have to do every step, and you might do others that aren’t listed. The workflow isn’t necessarily linear. You could, for example, go all the way through editing and adding effects, and then import more new media for your project.

**Import your media into Final Cut Pro**

To use Final Cut Pro, you need to transfer your media (video, audio, and still images) from your recording device to your computer or an external disk. You can import media from many kinds of cameras and other devices, or from other applications such as iMovie.
Organize your media
Final Cut Pro automatically organizes your imported media into Events. An Event is like a folder that contains all the media recorded on a certain date. In Final Cut Pro, your media appears as clips, which link to the media files stored on a disk. You can reorganize your clips by creating or renaming Events and moving clips between Events. For example, you could create an Event for all the media shot for a specific client.

As you review your footage, you can easily rate clips as Favorite or Rejected. These ratings make it easier to focus on your best footage. Final Cut Pro also offers other useful organizing tools, such as Keyword Collections and Smart Collections.

Create a project and add clips to it
Your project is the movie you create using clips from your Events and from the Final Cut Pro media browsers. Start creating your movie by adding clips to the Timeline. You make all your edits in the project; your original media files remain untouched (this is known as nondestructive editing).

Arrange and edit your clips
Now your movie can really begin to take shape. To assemble a rough cut, rearrange and trim clips in the Timeline. You can also try out different clips using auditions. Use connected clips and storylines to add cutaway shots, titles, background music, and sound effects to your project. Create compound clips to group any combination of clips and nest clips within other clips. You can simplify a complicated project by creating a separate compound clip for each major section.

Add effects and transitions
Add special effects from the ample collection of video and audio effects in the Final Cut Pro media browsers. Give your movie titles and credits, and apply video or audio transitions. Adjust clip speed settings to create fast-motion or slow-motion effects.

To further polish your project, you can fine-tune cuts and transitions with the Precision Editor, keyframe video and audio effects, correct color, and composite motion graphics.

Share your movie
When your project is finished, you can publish your movie right from Final Cut Pro to the web, or send it to iTunes, iPhone, iPad, iPod, or Apple TV. You can also burn a disc to give to others.
Final Cut Pro interface overview

The Final Cut Pro window has three main areas:

**Event Browser**: Access all the source media you import.

**Viewer**: Play back clips and projects.

**Magnetic Timeline**: Edit your movie in this area.
Organize media in the Event Library and Event Browser
All your imported media is available in the Event Library. (An Event is like a folder that contains clips.)

When you select an Event in the Event Library, its clips appear in the Event Browser on the right.

You can reorganize your media however you like at any time, and you can use the Event Library and the Event Browser to manage, rate, sort, and add keywords to your imported media. For more information, see “Events and clips overview” on page 57.
Play back clips and projects in the Viewer
The Viewer is where you play back your video, including clips and projects with up to 4K resolution. You can play back Events, projects, or individual clips in full-screen view or on a second display. For information about ways to play media, see “Play back media” on page 83.

Resolution-independent playback:
Play back video files up to 4K.

Onscreen controls:
Adjust effects such as Transform, Crop, and Distort.

Full-screen playback:
Play your video full screen, or on a second display.

You can also use onscreen controls, superimposed over the video in the Viewer, to adjust settings for a wide array of effects and transitions.
Edit your project in the Magnetic Timeline
The bottom portion of the Final Cut Pro window contains the Timeline, where you create your movie by adding and arranging clips and making all your edits. The Timeline in Final Cut Pro “magnetically” adjusts clips to fit around clips that you drag into place. If you drag clips out of place, the surrounding clips close up to fill the space.

A Final Cut Pro project holds all of the information for your final movie, including your editing decisions and links to all the source clips and Events. For more information about editing your project, see “Adding clips overview” on page 108 and “Arrange clips in the Timeline” on page 126.

Media files and clips
After you've imported media into Final Cut Pro, clips representing the source media files appear in the Event Browser. A large Event may hold many clips.

Media files are the raw materials you use to create your project. A media file is a video, audio, still-image, or graphics file on your hard disk that contains footage transferred from a camcorder or recording device or originally created on your computer. Media files can contain multiple video and audio components. Because media files—especially video files—tend to be quite large, projects that use a lot of footage require one or more high-capacity hard disks.
Clips represent your media, but they are not the media files themselves. The clips in a project simply point to (link to) the source media files on your hard disk. When you modify a clip, you are not modifying the media file, just the clip's information in the project. This is known as *nondestructive editing*, because all of the changes and effects you apply to clips in Final Cut Pro never affect the media itself. Trimmed or deleted pieces of clips are removed from your project only, not from the source clips in your Event Library or from the source media files on your hard disk.

**Events and projects**

In Final Cut Pro X, you use Events to collect and organize media. Events are like folders that contain unedited media imported from a camera or some other source.

You use projects to edit and construct movies and share them with your audience. A project is a record of the work you do in the Timeline and the editing decisions you make. When you add a clip from an Event to a particular project, you create a link between the source Event clip and the corresponding project clip (and, by extension, between the Event and the project). However, neither the Event nor the source clip is contained within the project. You can use that Event clip in other projects, and your project can use clips from other Events.
The illustration below shows the relationship between Events and projects: Final Cut Pro X keeps track of the links between project clips and their source Event clips, but projects and Events remain independent.
Importing overview
Importing media into Final Cut Pro is the first step toward making your movie. With Final Cut Pro, you can:

- Import from a file-based (tapeless) camera or device
- Import from iPhone, iPad, or iPod touch
- Import from a tape-based camcorder or device
- Import from iMovie
- Import from iPhoto and Aperture
- Import from iTunes
- Import from a hard disk
- Import from a camera archive

During import, you assign your media to an Event. You can also transcode your media and analyze your media for a variety of issues, such as identifying shaky video, the presence of people and shot type, and problematic audio issues.

When you import clips (video, audio, or still images), Final Cut Pro assigns one of five default roles to the video and audio components of each clip: Video, Titles, Dialogue, Music, and Effects. For more information, see “View and reassign roles” on page 340.

If you want to quickly back up your media (instead of taking the time to import it), you can create an archive.
If it’s your first import
The first time you open Final Cut Pro, it contains no media, no projects, and a single Event. Buttons appear in the Event Browser to help you quickly import Events from iMovie, media from your hard disk or a connected external storage device, or media directly from a connected camera.

Import media into an empty Event
Do one of the following:

- To import Events from iMovie: Click the Import iMovie Events button and follow the instructions for importing iMovie Events.
- To import media files: Click the Import Files button and follow the instructions for importing media files.
- To import files from a connected camera or device: Click the Import From Camera button and follow the instructions for importing files from a connected file-based camera or device, from a tape-based camera or device, or from a camera archive.

Import from connected devices

Import from file-based devices
File-based camcorders and cameras can record video, audio, and still images. These kinds of devices, which record to flash-based storage media, hard disk drives (HDD), and so on, usually connect to your computer via a USB cable. Some devices have removable memory cards that you can insert into your computer instead.
If your file-based device provides a clip-spanning feature, you can import all of the media as one spanned clip.

To check whether your camera is compatible with Final Cut Pro, go to the Final Cut Pro X Supported Cameras webpage at http://help.apple.com/finalcutpro/cameras.

**Import from a file-based camcorder, camera, or device**

1. Do one of the following:
   - Connect your camcorder, camera, or device to your computer, using the cable that came with the device, and turn it on.
     
     If you're using a camcorder, set it to PC Connect mode. (The name of this transfer mode may be different on your device.) Your camcorder may automatically go into “connect” mode if you turn it on in playback mode while it’s connected to your computer. For more information, see the documentation that came with your camcorder.
     
     *Note:* Connecting a DVD camcorder to your Mac can cause the DVD Player application to open. If that happens, simply close DVD Player.
   - Remove the memory card from your camcorder or device and insert it into the card slot on your Mac (if it has one) or into an external card reader.
     
     For more information about memory cards, see “About memory cards and cables” on page 48.

2. In Final Cut Pro, do one of the following:
   - Choose File > Import from Camera (or press Command-I).
   - Click the Import from Camera button on the left end of the toolbar.
     
     ![Image](image_url)
     
     The Camera Import window appears, displaying all the media on your device.
     
     If your media does not appear in the Camera Import window, try importing the media as files.

3. If necessary, select your camcorder, camera, or device from the list of devices on the left.
The media on the device appears at the bottom of the Camera Import window. You can preview the media by either playing it using the playback controls or skimming it by moving the pointer forward or backward over a filmstrip.

4 Do one of the following:
- **To import all clips**: Click Import All.
- **To import only some of the clips**: Select each clip you want to import by Command-clicking each thumbnail, and click Import Selected (the Import button changes its name).

**Tip**: To select several clips located together, you can drag around the clips to enclose them with the selection rectangle.
- **To import a portion of one clip**: Drag inside the clip to select the range that you want, and click Import Selected.

**Tip**: You can also select a clip, press the Space bar to play the clip, and press either I to set a start point or O to set an end point.
5 In the window that appears, choose how you want to organize the imported media in your Event Library:

- To add the imported clips to an existing Event: Select “Add to existing Event,” and choose it from the pop-up menu.
- To create a new Event: Select “Create new Event” and type a name (for example, “Chris and Kim Wedding”) in the text field; then choose the disk where you want to store the Event from the “Save to” pop-up menu.

To learn more about Events, see “Events and clips overview” on page 57.

6 If you want to organize your media, transcode your media, analyze the video, or analyze the audio, select the relevant checkboxes.

   If you don’t set Final Cut Pro to analyze your media during the import process, you can analyze it later (if necessary) in the Event Browser.

7 Click Import.

   Final Cut Pro imports your media in the background. If you selected any options in the previous step, Final Cut Pro transcodes and optimizes the files after the import process is complete. You can view the progress of the background tasks in the Background Tasks window.

8 To begin working with your clips, close the Camera Import window so you can access the Event Browser.

   You can create an archive from your file-based camera or device, recording everything on the tape from beginning to end and saving the captured clips as an archive. For more information, see “Create and manage camera archives” on page 488.

**Reimport a clip**

Two situations warrant reimporting a clip:

- If the clip was not completely imported: If you cancel or quit Final Cut Pro before an import is finished, a Camera icon appears on the bottom-left corner of the clip. This icon indicates that Final Cut Pro is using the media on the camera for playback (instead of using the QuickTime file that was created during import).
To play a clip with a Camera icon, Final Cut Pro locates the media on either a connected camera or in a connected, available camera archive. (See “Access media on an archive or disk image” on page 42 for more information.) If Final Cut Pro can’t locate the media in one of those locations, the clip will go offline and display the Missing Camera alert icon.

- **If the clip’s source media file is not available:** If a clip’s source media file is moved or deleted, or the volume it is located on is disconnected from the computer, a Missing File icon is displayed on the clip. To restore the clip, you can reimport it.

See “Alert icons” on page 492 for more information about alert icons.

When you reimport a clip, Final Cut Pro automatically connects to the necessary camera or camera archive. There is no need to manually mount a camera archive before reimporting.

1. Do one of the following:
   - Connect the camera that contains the clip to your computer, and turn it on. This will bring the clip online, but the clip will still display the Camera icon in the lower-left corner.
   - Insert the memory card that contains the clip in your computer or connected card reader.
     See “About memory cards and cables” on page 48 for more information.
   - Make sure the camera archive that contains the clip is located in one of the Final Cut Pro camera archives.
     See “Create and manage camera archives” on page 488 for more information.

2. In Final Cut Pro, do one of the following:
   - **To reimport one clip:** Select the clip in the Event Browser.
   - **To reimport all clips in an Event:** Select the Event the clip belongs to in the Event Browser sidebar.

3. Choose File > Import > Reimport from Camera/Archive.

The clip or clips are reimported.
Import spanned clips

Some file-based camcorders or devices that have more than one memory card slot can record one shot over multiple memory cards. The resulting shot is called a *spanned clip*.

A good way to import a spanned clip into Final Cut Pro is to attach your camera or card reader to your local system and create a camera archive for each memory card. You can store the camera archives on your local system or on an external storage device until you are ready to import the spanned clip. (Even if you are importing the spanned clip immediately, it’s useful to make the camera archive so you have a backup of the footage that makes up the spanned clip.) Then, when you’re ready to import, you can mount all of the camera archives and import the spanned clip.

Create a camera archive for each memory card

1. Connect your camcorder or camera to your computer and turn it on, or connect your card reader and memory card to your computer. If you’ll be saving the camera archives to an external storage device, connect that as well.

2. In Final Cut Pro, do one of the following:
   - Choose File > Import from Camera (or press Command-I).
   - Click the Import from Camera button on the left end of the toolbar.

   The Camera Import window appears.

3. Select a memory card to archive from the list of cameras on the left.

4. Click the Create Archive button at the bottom-left corner of the window.

5. In the “Create Camera Archive as” field, type a name for the archive.

6. Choose a location to save the archive from the Destination pop-up menu, and click OK.

   *Note:* It is recommended that you save your archive to a disk or partition different from the one where you store the media files used with Final Cut Pro.

7. Repeat steps 3-6 to create camera archives for each of the memory cards that contain a portion of the spanned clip.

   The camera archives appear in the Camera Archives list in the Camera Import window.

   See “Create and manage camera archives” on page 488 for more information about creating camera archives.
Import a spanned clip

1 If your camera archives are stored on an external storage device, make sure that it is connected to your local system.

2 Choose File > Import from Camera.

The Camera Import window appears, showing all camera archives on your local system (and on any connected external storage devices) in the Camera Archives section on the left.

3 Select each camera archive that makes up the spanned clip.

Final Cut Pro mounts all of the camera archives. If all portions of the spanned clip are available, all the mounted camera archives show a clip with the same duration and an icon indicating that the spanned clip is complete.
If one or more camera archives is missing, an icon appears on the camera archive to indicate which part of the spanned clip is available—the beginning, middle, or end. You can select each camera archive to see the different icons.

4 Click Import All to import the spanned clip.

 четыре

4 Click Import All to import the spanned clip.

Important: If the camera archives that make up the spanned clip are not all available, you can import each camera archive separately. Each portion of the spanned clip will be imported into Final Cut Pro as a separate clip.

5 Choose how you want to organize the imported media in your Event Library:

• To add the imported media to an existing Event: Select “Add to existing Event,” and choose it from the pop-up menu.

• To create a new Event: Select “Create new Event” and type a name (for example, “Chris and Kim Wedding”) in the text field; then choose the disk where you want to store the Event from the “Save to” pop-up menu.

To learn more about Events, see “Events and clips overview” on page 57.

6 If you want to organize your media, transcode your media, analyze the video, or analyze the audio, select the relevant checkboxes.

If you don’t set Final Cut Pro to analyze your media during the import process, you can analyze it later (if necessary) in the Event Browser.

7 Click Import.

Final Cut Pro imports your media in the background. If you selected any options in the previous step, Final Cut Pro transcodes and optimizes the files after the import process is complete. You can view the progress of the background tasks in the Background Tasks window.
To begin working with your clips, close the Camera Import window so you can access the Event Browser.

**Import from iPhone, iPad, or iPod touch**
Importing media from iPhone, iPad, or iPod touch is the same as importing it from a file-based camcorder, camera, or device.

1. Connect your iPhone, iPad, or iPod touch to your computer using the Dock Connector to USB cable that came with it. (If another application opens, close it.) Then turn on your device and unlock it.

2. In Final Cut Pro, do one of the following:
   - Choose File > Import from Camera (or press Command-I).
   - Click the Import from Camera button on the left end of the toolbar.

The Camera Import window appears, displaying all the media on your device. In this window you can preview the media by either playing it using the playback controls or skimming it by moving the pointer forward or backward over a filmstrip. You can also change which device to import from and change the way the clips appear using the buttons at the bottom-right corner of the window.
Do one of the following:

- **To import all clips:** Click Import All.
- **To import only some of the clips:** Select each clip you want to import by Command-clicking each thumbnail, or dragging to select a group of clips, and click Import Selected (the Import button changes its name).
- **To import a portion of one clip:** Drag inside the clip to select the range that you want, and click Import Selected.

**Tip:** You can also select a clip, press the Space bar to play the clip, and press either I to set a start point or O to set an end point.

In the window that appears, choose how you want to organize the imported media in your Event Library:

- **To add the imported clips to an existing Event:** Select “Add to existing Event,” and choose it from the pop-up menu.
- **To create a new Event:** Select “Create new Event” and type a name (for example, “Chris and Kim Wedding”) in the text field; then choose the disk where you want to store the Event from the “Save to” pop-up menu.

To learn more about Events, see “Events and clips overview” on page 57.

If you want to transcode your media, analyze the video, or analyze the audio, select the relevant checkboxes.

If you don’t set Final Cut Pro to analyze your media during the import process, you can analyze it later (if necessary) in the Event Browser.

Click Import.

Final Cut Pro imports your media in the background. If you selected any options in the previous step, Final Cut Pro transcodes and optimizes the files after the import process is complete. You can view the progress of the background tasks in the Background Tasks window.

To begin working with your clips, close the Camera Import window so you can access the Event Browser.

**Import from a digital still camera**

You can import video and still images from digital still cameras. The steps below describe how to import video and still images directly into Final Cut Pro. You can also import your photos into Aperture or iPhoto and access them through the Photos Browser in Final Cut Pro.

To check whether your camera is compatible with Final Cut Pro, go to the Final Cut Pro X Supported Cameras webpage at http://help.apple.com/finalcutpro/cameras.
Import still-image clips and video clips from a digital still camera

1 Connect your camera to your computer using the cable that came with the camera, and turn it on.

If your camera doesn't appear in the Finder, remove the camera's memory card and insert it into the card slot on your Mac (if it has one) or into an external card reader.

2 In the Finder, locate the DCIM folder inside the camera folder, and then locate the still-image or video files. The files may be in the DCIM folder, or in a folder one or two levels down. Devices and file structures vary by model and manufacturer.

3 In Final Cut Pro, do one of the following:
   - Choose File > Import and follow the instructions in “Import from a hard disk” on page 40.
   - Drag the files from the Finder into an Event or Timeline in Final Cut Pro. The files will be imported using the import settings you configured in Import preferences. See “Import from a hard disk” on page 40.

After import, you may have separate audio files that you want to use to replace the video's audio track. To do this, you can automatically synchronize the video and audio clips.

Import from tape-based devices

You can import media from a tape-based camcorder or tape-based device. To determine which clips you want to import (rather than importing all of them), you can view them using Final Cut Pro before you import them.

To check whether your camera is compatible with Final Cut Pro, go to the Final Cut Pro X Supported Cameras webpage at http://help.apple.com/finalcutpro/cameras.

Import media from a tape-based camcorder or device

1 Connect the camcorder to your computer using the cable that came with it, and configure your device for remote control over FireWire, if necessary.

   **Note:** For best results when importing from a tape-based camcorder, it is recommended that you import the video using the same camcorder that you used to record it.

2 Turn on the camcorder and set it to VTR or VCR mode. (This mode may have a different name on your camera. For more information, see the documentation that came with your camcorder.)
3 In Final Cut Pro, choose File > Import from Camera.

The Camera Import window appears. If you have multiple devices connected to your computer, choose the device you want to import from in the list of cameras on the left. The Camera Import window displays the image from the current position of the tape.

4 Use the playback controls (or use the J, K, and L keys) to set your tape to the point where you want to begin importing, and click Import.

5 In the window that appears, choose how you want to organize the imported media in your Event Library:
   - To add the imported clips to an existing Event: Select “Add to existing Event,” and choose it from the pop-up menu.
   - To create a new Event: Select “Create new Event” and type a name (for example, “Chris and Kim Wedding”) in the text field; then choose the disk where you want to store the Event from the “Save to” pop-up menu.

To learn more about Events, see “Events and clips overview” on page 57.

6 If you want to transcode your media, analyze the video, or analyze the audio, select the relevant checkboxes.

If you don’t set Final Cut Pro to analyze your media during the import process, you can analyze it later (if necessary) in the Event Browser.
7 Click Import.

Final Cut Pro begins importing immediately from the current location on the tape. It will continue to import (and save the resulting media file to the Event you specified) until one of the following occurs:
- It reaches the end of the tape.
- The hard disk you are importing to is full.
- You stop the import session by clicking Stop Import or Close (to close the Camera Import window).

The video plays as it’s being imported. It takes as long to import the video as it takes to watch it at normal speed.

8 When the section of video you want to import has been imported, click Stop Import. Then use the import controls to set your video to a point where you want to begin importing again, and repeat steps 5 through 7. If you selected any options in step 6, Final Cut Pro transcodes and optimizes the files after the import process is complete. You can view the progress of the background tasks in the Background Tasks window.

9 When you’re done importing, click Close to close the Camera Import window.

You can also create an archive from your tape-based device, recording everything on the tape from beginning to end and saving the captured clips as an archive. For more information, see “Create and manage camera archives” on page 488.

If your device isn’t recognized

If you’ve connected your camcorder to your computer but the Camera Import window doesn’t open, or Final Cut Pro can’t control your device, there are several things you can do to try to establish the connection.

Check your equipment and system

1 Make sure that you’re using the correct equipment configuration:
- Your camcorder or camera must be compatible with Final Cut Pro. For a list of compatible devices, go to the Final Cut Pro X Supported Cameras webpage at http://help.apple.com/finalcutpro/cameras.
- Your device must be connected properly to your computer.
- Your camcorder must be set to the correct output mode. On some camcorders, this is called VTR or VCR mode, but not all camcorders use the same terminology, so check the documentation that came with your device. On some camcorders you must set the output to DV mode or HDV mode, depending on whether the content is standard (DV) or high definition (HDV).
- If you’re connecting a tape-based camcorder to your computer, you should be using a FireWire cable (also called IEEE 1394, or i.LINK), not a USB cable.

See “About memory cards and cables” on page 48 for more information.
• If you’re importing video clips from a still camera or other flash memory device, make sure the file format of your video is MPEG-2, MPEG-4, or AVCHD, all of which are compatible with Final Cut Pro.

• If your still camera is not supported by Final Cut Pro, try importing the media as files, using a card slot on your Mac computer or an external card reader. See “Import from a hard disk” on page 40 for more information.

• If you’re importing from an AVCHD camcorder, make sure you’re using a Mac with an Intel Core Duo processor or better.

• If you’re importing from an AVCHD DVD camcorder, make sure your computer has the latest version of Mac OS X installed.

• If you’ve enabled Fast User Switching, make sure no one else is trying to use the camcorder from a different account at the same time.

2 If you still can’t import media after checking the items above, try the following:

• Turn the device off and on again.

• Disconnect the cable from both the device and the computer, and then reconnect it.

• Quit and then reopen Final Cut Pro.

• Restart your computer.

• Try using a different cable.

• Try using a different computer with Final Cut Pro installed.

• If you’re using a file-based camcorder, use the Finder to copy the mounted volume to a local disk. Then open the files in Final Cut Pro in the same way that you open an archive.

**Import from other applications**

**Import from iMovie**

You can import any of your existing iMovie projects and your iMovie Event Library into Final Cut Pro.

*Note:* If you want to import an iMovie trailer project, you first need to convert it to a standard iMovie project. For more information, choose Help in iMovie ’11 and search for “Convert a trailer to a project.”

*Important:* iMovie projects and clips from the iMovie Event Library are not automatically analyzed during import because they retain their original analysis results from iMovie. You can override iMovie analysis by analyzing your clips in Final Cut Pro after import. For more information, see “Analyze your media” on page 53.
**Import an iMovie project**

1. In Final Cut Pro, choose File > Import > iMovie Project and locate your existing iMovie project, typically found in the Movies folder on your hard disk.
2. Click Import.

The project opens in the Timeline and any associated Events appear in the Event Library.

**Import your iMovie Event Library**

1. In Final Cut Pro, choose File > Import > iMovie Event Library.
2. Read the message that appears and click OK.

The Events in your iMovie Event Library appear in the Final Cut Pro Event Library.

**Import from iPhoto and Aperture**

When you import photos and video clips from iPhoto or Aperture into Final Cut Pro, the media is imported using the import settings you defined in Import preferences. For more information, see “Import from a hard disk” on page 40.

**Import photos and video clips from iPhoto or Aperture**

1. In Final Cut Pro, do one of the following:
   - Choose Window > Media Browser > Photos.
   - Click the Photos button in the toolbar.

2. If necessary, navigate to the iPhoto or Aperture section of the Photos Browser.
3. To use one or more photos or video clips in your project, drag the items from the Photos Browser to an Event icon in the Event Library or a project in the Timeline.

You can also drag photos and video clips from iPhoto or Aperture directly to an Event in the Event Library or a project in the Timeline, without using the Photos Browser.

**Import from iTunes**
You can import music and sound from your existing iTunes library into Final Cut Pro.

**Import music and sound from iTunes**
1. In Final Cut Pro, do one of the following:
   - Choose Window > Media Browser > Music and Sound.
   - Click the Music and Sound button in the toolbar.

2. In the Music and Sound Browser, choose iTunes from the pop-up menu at the top.

   *Tip:* If the folder you’re looking for doesn’t appear, you can add it to the source list by dragging it from the Finder or desktop to the Music and Sound Browser.

3. In the list that appears, find the music or sound you want:
   - To search for an item: Type text in the search field. To filter your search, click the Filter button and choose a filter.
   - To preview an item: Double-click the item, or select the item and click the Play button.
   - To select more than one item: Command-click each item.

4. Drag the sound file or files to the Timeline.

**Import from disks**

**Import from a hard disk**
You can import media—video, audio, still images, and graphics files—from your computer’s hard disk, a connected external storage device, a memory card inserted in your computer’s card slot or a card reader, or a network attached volume. You can import media using the Import Files window or by dragging files from the Finder.
When you drag media from the Finder into Final Cut Pro, the media is imported using the organize, transcode, and analysis settings you set in the Final Cut Pro preferences. If you don’t want to use the Import Files window to manage your import, and if you want to always use the same organize, transcode, and analysis settings, importing by dragging files into Final Cut Pro is a good option. See “Import preferences” on page 500 for information on the Import preferences.

**Note:** Some file-based devices allow you to copy the recorded media (with its original directory structure) to a folder on your computer’s hard disk via the Finder. To import media copied in this way, see “Access media on an archive or disk image” on page 42, and follow the instructions in “Import media from an archive or disk image.”

**Import media using the Import Files window**

1. In Final Cut Pro, choose File > Import > Files.

2. Select a file or folder, or Command-click to select multiple files to import.

3. Do one of the following:
   - *To add the imported files to an existing Event*: Select “Add to existing Event,” and choose it from the pop-up menu.
   - *To create a new Event*: Select “Create new Event” and type a name (for example, “Chris and Kim Wedding”) in the text field; then choose the disk where you want to store the Event from the “Save to” pop-up menu.

To learn more about Events, see “Events and clips overview” on page 57.
4 To have Final Cut Pro copy your media files and add them to the Final Cut Pro Event folder that you specified, select the checkbox.

5 If you want to organize your media, transcode your media, analyze the video, or analyze the audio, select the relevant checkboxes.

   If you don’t set Final Cut Pro to analyze your media during the import process, you can analyze it later (if necessary) in the Event Browser.

6 Click Import.

Final Cut Pro imports your media in the background. If you selected any options in the previous step, Final Cut Pro transcodes and optimizes the files after the import process is complete. You can view the progress of the background tasks in the Background Tasks window.

**Import media by dragging from the Finder**

Do one of the following:

- Select a file, Command-click to select multiple files, or select a folder of files, and drag them from the Finder to the Event.

  The clip or clips appear in the Event.

- Select a file, Command-click to select multiple files, or select a folder of files and drag them from the Finder to a Keyword Collection.

  The clip or clips appear in the Event, and the keyword is automatically added to the clip or clips.

  **Important:** If you have the “Import folders as Keyword collections” Import preference selected, a Keyword Collection will be created for each folder name, and the files inside the folder will get that keyword.

- Select a file or Command-click to select multiple files and drag them to your project’s Timeline.

  The clip or clips appear in the Timeline, and in the project’s default Events folder.

  The file or files are imported using your default import settings.

**Access media on an archive or disk image**

If you’ve created a camera archive, you can use the media in the archive in two ways:

- You can connect to the camera archive, making the media available to Final Cut Pro. While all available camera archives are always listed in the Camera Import window, you can’t use any of the media in an archive until you’ve connected to the camera archive.

- You can import the media from the archive, or import media from disk images previously archived with the Final Cut Pro Log and Transfer window. When you do this, copies of the media are created on your local disk.
**Note:** Some file-based devices allow you to copy the recorded media (with its original directory structure) to a folder on your computer’s hard disk via the Finder. To import media copied in this way, follow the instructions in “Import media from an archive or disk image,” below.

**Mount and unmount a camera archive**

1. In Final Cut Pro, choose File > Import from Camera.

   The Camera Import window appears, showing all camera archives in the Camera Archives section on the left.

   ![Camera archive](camera-archive.png)

2. Select the camera archive to connect to it.

   The archive is connected to Final Cut Pro when the eject icon appears to the right of the archive name.

3. Click the eject icon to disconnect the camera archive.

**Import media from an archive or disk image**

1. In Final Cut Pro, choose File > Import from Camera.

   The Camera Import window appears, showing all camera archives in the Camera Archives section on the left. You can preview the media by either playing it using the playback controls or skimming it by moving the pointer forward or backward over a filmstrip. You can also change which archive to import from and change the way the clips appear using the controls at the bottom-right corner of the window.

   ![Camera archive](camera-archive.png)
2 Do one of the following:
   • Under the list of Camera Archives on the left, select the archive you want to import.
   • Click Open Archive, navigate to the folder of the archive you want to import, and click Open.

3 To select which clips you want to import, do one of the following:
   • **To import all clips:** Click Import All.
   • **To import only some of the clips:** Select each clip you want to import by Command-clicking each thumbnail, or dragging to select a group of clips, and click Import Selected.
   • **To import a portion of one clip:** Drag inside the clip to select the range that you want to import, and click Import Selected.

> **Tip:** You can also select a clip, press the Space bar to play the clip, and press either I to set a start point or O to set an end point.

4 Choose how you want to organize the imported media in your Event Library:
   • **To add the imported media to an existing Event:** Select “Add to existing Event,” and choose it from the pop-up menu.
   • **To create a new Event:** Select “Create new Event” and type a name (for example, “Chris and Kim Wedding”) in the text field; then choose the disk where you want to store the Event from the “Save to” pop-up menu.

To learn more about Events, see “Events and clips overview” on page 57.

5 If you want to organize your media, transcode your media, analyze the video, or analyze the audio, select the relevant checkboxes.

   If you don’t set Final Cut Pro to analyze your media during the import process, you can analyze it later (if necessary) in the Event Browser.

6 Click Import.

   Final Cut Pro imports your media in the background. If you selected any options in the previous step, Final Cut Pro transcodes and optimizes the files after the import process is complete. You can view the progress of the background tasks in the Background Tasks window.

7 To begin working with your clips, close the Camera Import window so you can access the Event Browser.
Organize files while importing
You have organizing options when you import files into Final Cut Pro.

- *Copy files to Final Cut Events folder:* This option duplicates the media files and places the copy in the Final Cut Events folder on your computer. If you’re importing media from a different disk or volume, or if you want to keep a copy of all the media files that have been imported into Final Cut Pro in the same location, select this checkbox.

If you import files with this checkbox deselected, you can still copy the files at a later time to the Final Cut Events folder using the Organize Event Files command.

- *Import folders as Keyword Collections:* If you have folders of files that have meaningful folder names, selecting this option creates a keyword for each folder name and applies the keyword to all the files in the folder during import. Additionally, a Keyword Collection is created for each keyword.

![Image of file organization in Final Cut Pro]

After import, these clips will have “B-roll” and “Callaway” keywords.

After import, these clips will have “Interviews” and “Callaway” keywords.

Organize your files during import
1. To import a file, choose File > Import > Files and navigate to the file you want to import.

2. In the window that appears, choose how you want to organize the imported media in your Event Library:
   - *To add the imported media to an existing Event:* Select “Add to existing Event,” and choose it from the pop-up menu.
   - *To create a new Event:* Select “Create new Event” and type a name (for example, “Chris and Kim Wedding”) in the text field; then choose the disk where you want to store the Event from the “Save to” pop-up menu.

To learn more about Events, see “Events and clips overview” on page 57.

3. Select one or both of the organize options (explained above).
4  If you want to transcode your media, analyze the video, or analyze the audio, select the relevant checkboxes.

If you don’t set Final Cut Pro to analyze your media during the import process, you can analyze it later (if necessary) in the Event Browser.

5  Click Import.

Final Cut Pro imports your media in the background. If you selected any options in the previous step, Final Cut Pro transcodes and optimizes the files after the import process is complete. You can view the progress of the background tasks in the Background Tasks window.

6  To begin working with your clips, close the Camera Import window so you can access the Event Browser.

**Copy all external media files used by an Event to its Event folder**

1  Select the Event in the Event Library.

2  Choose File > Organize Event Files.

3  In the window that appears, click Continue.

Final Cut Pro duplicates the media files and places the copy in the Final Cut Events folder on your computer.

**Import while recording**

You can record video directly into Final Cut Pro using your computer’s built-in camera and some camcorders.

**Record live video and audio into Final Cut Pro**

1  Do one of the following:

   - *To record using the built-in camera*: Click the Import from Camera button in the toolbar.

   - *To record using a camcorder*: Connect a camcorder to your computer with a FireWire cable. You should see a live image on the camcorder’s screen or viewfinder. Then click the Import from Camera button in the toolbar.

   **Note:** Most camcorders that connect to your computer using a USB cable go into PC Connect mode, which doesn’t allow you to record live video directly into Final Cut Pro.
2 In the Cameras list on the left side of the Camera Import window, select the camera you want to import from.

A live video image from the camera appears in the Camera Import window.

3 Click Import.

The Event Settings window appears.

4 Choose how you want to organize the imported media in your Event Library:
   - *To add the imported media to an existing Event:* Select “Add to existing Event,” and choose it from the pop-up menu.
   - *To create a new Event:* Select “Create new Event” and type a name (for example, “Chris and Kim Wedding”) in the text field; then choose the disk where you want to store the Event from the “Save to” pop-up menu.

To learn more about Events, see “Events and clips overview” on page 57.

5 If you want to organize your media, transcode your media, analyze the video, or analyze the audio, select the relevant checkboxes.

   If you don’t set Final Cut Pro to analyze your media during the import process, you can analyze it later (if necessary) in the Event Browser.

6 When you’re ready to begin recording, click Import.

   The camera begins recording immediately.

7 When you want to stop recording, click Stop Import.

   A new video clip is created. You can click Import to begin recording again. You can repeat this process as many times as necessary.
About memory cards and cables

To import media from your recording device to your computer, you need to remove the memory card from your device and insert it into either your computer or a memory card reader. You can also connect your device directly to your computer using the appropriate cable. Then you can import the media on the memory card or device using the Import Files window. For more information, see “Import from a hard disk” on page 40 and “Import from file-based devices” on page 25.

- **Memory cards:** Many file-based camcorders and devices record media on a removable memory card. You can connect a card reader to your computer and use that to transfer the contents of your memory card onto your computer. Some Mac computers feature an SD (Secure Digital) or SDXC (SD extended capacity) card slot that allows these computers to read and write data to SD media inserted in the slot. If your Mac has a card slot, you can remove the card from the camera, insert the card into your Mac, and then import the files.

  For more information, go to http://support.apple.com/kb/ht3553.

You can also connect your device to the computer using a FireWire or USB cable. The kind of cable you need depends on the kind of device you’re using:

- **USB device:** You use a USB cable for file-based camcorders, digital still cameras that record video, and iPhone, iPad, and iPod touch. The USB cable should have at least one connector that plugs into your Mac (at the top in the illustration below). The other end of the USB cable, which plugs into your recording device, might look different (on the bottom in the illustration below).
• **FireWire device:** For most camcorders that record to tape, you use a FireWire cable with a 6-pin connector on one end that plugs into your Mac (at the top in the illustration below) and a 4-pin connector on the other end that plugs into your camcorder (on the bottom in the illustration below).

  ![FireWire cable diagram](image)

  Or you might have a FireWire 800 cable, with a different end that plugs into your camcorder or computer.

  ![FireWire 800 cable diagram](image)

• **Thunderbolt device:** Devices that use Thunderbolt I/O technology use a connector that plugs into the mini display port on your Mac and looks like the connector below.

  ![Thunderbolt connector diagram](image)

If your device didn’t come with a cable and you’re not sure what kind of device you have, you can check the logo near the cable ports on your device to see if it matches the USB or FireWire logo, both shown above. Otherwise, check the documentation that came with your device.

**Note:** Not all Mac computers include a FireWire port. Check your system configuration to confirm that your Mac includes FireWire support before attempting to connect a standard (DV) or HDV camcorder.

To check whether your camera is compatible with Final Cut Pro, go to the Final Cut Pro X Supported Cameras webpage at [http://help.apple.com/finalcutpro/cameras](http://help.apple.com/finalcutpro/cameras).

**Supported media formats**

You can import and work with the following video, audio, and still-image formats in Final Cut Pro:

**Video formats**

• Apple Animation codec
• Apple Intermediate codec
- Apple ProRes (all versions)
- AVC-Intra
- AVCHD (including AVCCAM, AVCHD Lite, and NXCAM)
- DV (including DVCAM, DVCPRO, and DVCPRO50)
- DVCPRO HD
- H.264
- HDV
- iFrame
- Motion JPEG (OpenDML only)
- MPEG IMX (D-10)
- Uncompressed 10-bit 4:2:2
- Uncompressed 8-bit 4:2:2
- XDCAM HD/EX/HD422
- QuickTime formats

**Audio formats**
- AAC
- AIFF
- BWF
- CAF
- MP3
- MP4
- WAV

**Still-image formats**
- BMP
- GIF
- PNG
- PSD (static and layered)
- RAW
- TGA
- TIFF
Analyzing media overview
You can have Final Cut Pro analyze your media and automatically correct common problems it may find in your video, still images, and audio. For example, you can analyze your media to stabilize shaky video, to balance color, and to remove excess hum or loudness.

You can also analyze clips and still images to identify their contents. Analysis can detect the number of people in a shot and identify if the shot is a close up, medium, or wide shot. This is helpful if you need to quickly find a certain type of clip while viewing footage or editing a project.

See “Video and still-image analysis options” on page 51 and “Audio analysis options” on page 53 for complete lists of the video and audio analysis options.

After certain types of analysis, keywords are automatically added to the clip or still image to describe the results of the analysis, such as Excessive Shake, One Person, and Wide Shot.

You can analyze media during the import process or after you import it into Final Cut Pro. You can also set Final Cut Pro to automatically analyze clips you drag directly to the Final Cut Pro Timeline from the Finder.

Video and still-image analysis options
Final Cut Pro provides automatic video and still-image analysis that can find and correct shaky video, automatically balance color in video, and detect people and shot angles in video or still images. You can analyze video during import, or analyze video clips in the Event Browser or in a project’s Timeline. Keywords are attached to clips based on the results of the analysis.
Final Cut Pro provides these video and still-image analysis options:

- **Analyze for stabilization and rolling shutter:** Analyzes video clips and adds analysis keywords to clips with excessive shake, rolling shutter, or both. If a clip has an Excessive Shake keyword, you can fix the shaking after you add the clip to the Timeline by turning on Stabilization and Rolling Shutter corrections. See “Correct excessive shake and rolling shutter issues” on page 170.

  **Note:** If you’re analyzing for stabilization problems, it’s recommended that you also select the “Create Smart Collections after analysis” checkbox so you can easily locate clips with the Excessive Shake keyword.

- **Analyze for balance color:** Analyzes video clips to detect color balance and contrast. Color is automatically balanced when you add the clip to the Timeline. You can turn automatic color adjustments on and off at any time.

- **Remove pulldown:** Analyzes video clips and removes pulldown patterns.

  **Important:** This option is only available when importing from a tape-based camera or device.

- **Find people:** Analyzes video clips and still images for the number of people present and shot types. After analysis, any of the following keywords are added to the clip or still image: One Person, Two Persons, Group, Close Up Shot, Medium Shot, and Wide Shot.

  **Note:** If you’re analyzing to find people, it’s recommended that you also select the “Create Smart Collections after analysis” checkbox so you can easily locate clips with “find people” analysis keywords.

- **Consolidate find people results:** Summarizes all of the “find people” analysis keywords into one shot type keyword and one people keyword for every two-minute segment of the video. Select this checkbox if you don’t need to know all of the “find people” analysis keywords and instead want a summary of the keywords over a longer duration of the clip. For example, if you have a clip that contains three close-up shots and two wide shots, selecting the “Consolidate find people results” checkbox gives that clip a Close Up Shot keyword (the most prevalent keyword for that segment). If that same clip includes four shots containing one person and one shot containing a group of people, selecting the “Consolidate find people results” checkbox gives that clip a One Person keyword (the most prevalent keyword for that segment). If a clip is over two minutes, selecting the “Consolidate find people results” checkbox gives every two-minute segment of that clip a shot type keyword and a “find people” analysis keyword.

- **Create Smart Collections after analysis:** Creates a Smart Collection for each keyword applied when analyzing video clips for image stabilization problems or analyzing video clips and still images for the presence of people. The Smart Collections are sorted by type (people, shot type), and appear in a folder inside the Event in the Event Library.
When you drag a media file from the Finder to a Final Cut Pro Event or the Timeline, the import begins automatically, without displaying a window of import options. You can set automatic import options in the Final Cut Pro Import preferences pane.

Audio analysis options
Final Cut Pro provides automatic analysis that can fix common audio problems, analyze and group audio channels, and remove silent channels. You can analyze audio during import, or analyze video clips with audio issues in the Event Browser or in the Timeline.

Final Cut Pro provides these audio analysis options:

- **Analyze and fix audio problems**: Analyzes the audio for hum, noise, and loudness. Final Cut Pro automatically fixes problems that are considered severe (marked in red), and flags problems that are considered moderate (marked in yellow). See “Enhance audio” on page 194 for more information.

- **Separate mono and group stereo audio**: Audio channels are analyzed and grouped as dual mono or stereo, depending on the results of the analysis. Automatically corrected audio channels are marked as Autoselected. For more information about audio channels, see “Configure audio channels” on page 204.

- **Remove silent channels**: Audio channels are analyzed and silent channels are automatically removed. Clips that have had channels removed are marked as Autoselected. For more information about audio channels, see “Configure audio channels” on page 204.

When you drag a media file from the Finder to a Final Cut Pro Event or Timeline, the import begins automatically, without displaying a window of import options. You can set automatic import options in the Final Cut Pro Import preferences pane.

Analyze your media
You can analyze clips during the import process, after the import process in the Event Browser, or set Final Cut Pro to analyze clips automatically when they are dragged to a Final Cut Pro Event or Timeline.

**Analyze clips during import**

1. Do one of the following:
   - **To import a file from a compatible camcorder or camera, iPad, iPhone, iPod, or other device**: Connect the device to your computer, turn on the device, and choose File > Import from Camera (or press Command-I) and click Import.
   - **To import a file from a tape-based camcorder**: Connect the camcorder to your computer, turn on the camcorder, and set it to VTR or VCR mode. Then choose File > Import from Camera and click Import.
• To import a file from a memory card: Insert the memory card into the card slot on your Mac or into a card reader that’s connected to your computer. Then choose File > Import > Files (or press Command-I).

• To import a file located on your hard disk or a connected external storage device: Choose File > Import > File and navigate to the file you want to import.

• To import from an archive: Choose File > Import from Camera, and in the window that appears, choose a camera archive from the list on the left. Click Open Archive and navigate to the files you want to import, and click the Import button.

2 In the window that appears, choose how you want to organize the imported media in your Event Library:

• To add the imported media to an existing Event: Select “Add to existing Event,” and choose it from the pop-up menu.

• To create a new Event: Select “Create new Event” and type a name (for example, “Chris and Kim Wedding”) in the text field. Use the “Save to” pop-up menu to choose the disk where you want to store the Event.

To learn more about Events, see “Events and clips overview” on page 57.

3 Select any of the video and audio analysis options that you want to apply.

See “Video and still-image analysis options” on page 51 and “Audio analysis options” on page 53 for complete lists of the video and audio analysis options.

Final Cut Pro will analyze the files in the background, after the import process is complete.

4 Click Import.

The import may take a while, depending on the options you chose in step 3. You can see the status of all the background processes currently running in the Background Tasks window.

Analyze clips after import

1 If necessary, locate a clip in the Event Browser by Control-clicking it in the Timeline and choosing “Reveal in Event Browser” from the shortcut menu.

2 Control-click one or more clips and choose “Analyze and Fix” from the shortcut menu.

3 In the window that appears, select any or all of the video analysis and audio analysis options that you want to apply.

The transcoding process may take a while, depending on the analysis options you chose. You can see the status of all the background processes currently running in the Background Tasks window.
Automatically analyze media files when they are dragged directly to a Final Cut Pro Event or Timeline

1. To configure the Final Cut Pro analysis options:
   a. Choose Final Cut Pro > Preferences.
   b. In the Preferences window that appears, click Import.
   c. Select each of the video and audio analysis options that you want to apply.
   d. When you’re finished, close the Preferences window.

2. To import one or more files, select a file (or Command-click multiple files) in the Finder and drag it to an Event or Timeline.

View analysis keywords on clips
If you analyzed media to find shaky footage or people, analysis keywords like Excessive Shake, One Person, Close Up Shot, and so on are added to the relevant clips.

You can find analysis keywords in several locations in Final Cut Pro.

View keywords in the Skimmer Info window
1. Choose View > Show Skimmer Info (or press Control-Y).
2. Skim the clip in the Event Browser or in the Timeline.
   Keywords, including analysis keywords, are displayed in the Skimmer Info window.

View keywords in list view in the Event Browser
1. Click the List View button.
To see a clip’s keywords, click the disclosure triangle next to the clip. The keywords are listed next to the blue key.

**View the contents of a Smart Collection**

If you chose to create Smart Collections after analysis, clips that have analysis keywords are automatically grouped in Smart Collections. The Smart Collections are grouped in folders titled People and Shot.

- In the Event Library, locate and select a Smart Collection.

The clips that contain analysis keywords appear in the Event Browser.
Events and clips overview
When you import video, audio, and still images, or record directly into Final Cut Pro, the source media files (your raw footage) appear as clips in one or more Events in the Event Library. An Event is similar to a folder that can hold dozens, hundreds, or even thousands of video clips, audio clips, and still images. Each Event in the Event Library refers to a folder on your hard disk that contains the original source media files, any render files related to your media, and a database file that keeps track of where everything is.

When you select an Event in the Event Library, the media it contains appears as clips in the Event Browser. You select clips or portions of clips in the Event Browser to work with them. You can sort clips in the Event Browser by creation date, as well as by date imported, reel, scene, clip duration, and file type.

Select an Event in the Event Library.

The Event Browser displays the clips in the selected Event.
When you import video into a new Event, you name the Event. By giving your Events meaningful names, such as “Smith Wedding 2011,” you can organize all of your media so that it’s readily accessible. By default, Final Cut Pro lists the Events in the Event Library by the date they were recorded. You can organize the Event Library in other ways, and you can also hide the Event Library to give yourself more room to work. The Event Library is also the home for Final Cut Pro Keyword Collections and Smart Collections which provide a powerful way to organize your video editing projects using keywords and persistent search filters.

Organize Events

Create a new Event

After importing your source media files into Final Cut Pro, you may find that you need to create additional Events to organize your media. For example, after importing media shot for a specific client, you may decide to split the media into Events defined by the location the media was shot in; or split the media by the time of day it was shot, such as morning, afternoon, and evening.

Create a new Event in the Event Library

1. If you don’t see the Event Library, click the Event Library button at the bottom-left corner of the Event Browser.

2. Choose File > New Event (or press Option-N).

   A new Event appears in the Event Library.

3. Type a name for the Event and press Return.

4. Move clips from other Events into the new Event, as necessary.

Rename an Event

Change an Event’s name

As your project evolves, you may find that you want to rename an Event so that it more accurately reflects the clips it contains.
1 In the Event Library, select the Event whose name you want to change.

2 Do one of the following:
   • Click the Event’s name and type a new name.
   • Press Return and type a new name.

   **Important:** Renaming an Event also renames the Event’s folder on the hard disk where your source media is located.

**Merge or split Events**

You can merge (combine) two or more Events in the Event Library (for example, if the media they contain is very closely related). You can also split a single Event into multiple Events if you find an Event is getting unmanageable.

**Merge multiple Events**

1 In the Event Library, do one of the following:
   • Drag one or more Events that you want to combine to a new Event.
   • Select the Events you want to combine, and choose File > Merge Events.

2 In the Merge Events window that appears, type a new name for the Event.

3 Choose the disk where you want to store the Event’s source media files from the Location pop-up menu, and click OK.

Final Cut Pro merges the selected Events into a single Event in the Event Library. The source media files for all the clips are moved into the merged Event folder on the hard disk and stored in the location you chose from the pop-up menu.

**Split an Event into multiple Events**

1 Create the new Events you need.

2 Move the clips you want to separate out from the original Event to the new Events.

The source media files for all the clips are moved into the Event folders on disk corresponding to the newly created Events in the Event Library.

   **Important:** If you disconnect the disk where your merged or split Events are stored, you will not be able to access the Events or their source media files from within Final Cut Pro until you reconnect the disk.
Copy or move clips between Events

You can copy and move clips from one Event to another. When you copy a clip from one Event to another, its source media files are duplicated on disk. When you move a clip from one Event to another, its source media files are moved from one Event folder to the other on disk.

Copy clips from one Event to another

1. In the Event Library, select the Event that contains the clips you want to copy.
2. In the Event Browser, select the clip or clips you want to copy.
3. Do one of the following:
   - *If both Events are on the same hard disk:* Option-drag the clips from one Event to the other.
   - *If the Events are on separate hard disks:* Drag the clips from one Event to the other.

Move clips from one Event to another

1. In the Event Library, select the Event that contains the clips you want to move.
2. In the Event Browser, select the clip or clips you want to move.
3. Do one of the following:
   - *If both Events are on the same hard disk:* Drag the clips from one Event to the other.
   - *If the Events are on separate hard disks:* Command-drag the clips from one Event to the other.

The Event to which you copy or move the clips may be re-sorted in the Event Library. It will be listed below the year in which its most recent clip was recorded.

If you copy or move a large clip from an Event stored on one hard disk to an Event stored on another, the move may take a few minutes as the source media files are copied or moved from disk to disk.

Copy or move Events

You can easily copy or move an Event from your computer to a hard disk or from one hard disk to another. This is useful if you want to work with your Event on another computer that has Final Cut Pro installed or free up space on your computer’s hard disk.

Copy an Event

1. Make sure another hard disk is connected to your computer.
2. Choose Group Events by Disk from the Action pop-up menu 🌟 ▼ below the Event Library.
   The connected disk drive’s icon and name appear in the Event Library.
4 Do one of the following:
   - Choose File > Duplicate Event (or press Command-D).
   - Drag the Event to the external drive’s icon.

5 In the Duplicate Event window, type a name for the new Event.

6 To store your files in a second location, choose it from the Location pop-up menu.

7 Click OK.

Final Cut Pro makes a copy of the Event at the location you chose. It also makes copies of the source media files and places them in a new Event folder. Keep in mind that copying an Event with large source media files can take several minutes.

**Move an Event**

1 Make sure another hard disk is connected to your computer.

2 Choose Group Events by Disk from the Action pop-up menu below the Event Library.

   The connected disk drive’s icon and name appear in the Event Library.

3 Select an Event in the Event Library.

4 Do one of the following:
   - Choose File > Move Event.
   - Command-drag the Event to the drive’s icon.

5 To store your files in a second location, choose it from the Location pop-up menu.
6 Click OK.

Final Cut Pro moves the Event to the location you chose. It also moves the Event folder which contains the source media files. Keep in mind that moving an Event with large source media files can take several minutes.

*Important:* If you disconnect the disk containing the Event you moved, you will no longer have access to the Event or its source media files from within Final Cut Pro until you reconnect the disk.

**Sort Events**

In the Event Library, you can view your Events in a number of ways, including by the disk they’re stored on and the date when they were recorded.

**Sort Events by storage location or date**

- *To view Events by the hard disk where they’re stored:* Choose Group Events by Disk from the Action pop-up menu below the Event Library.

- *To view Events by the date they were recorded:* Choose Group Events by Date from the Action pop-up menu, and choose an option from the submenu.
Show Event date ranges
Final Cut Pro can display the date ranges for the source media files within each Event.

- Choose Show Date Ranges in Event Library from the Action pop-up menu 📜 ⬇️.

Sort Events by most recent
- Choose Arrange Events by Most Recent from the Action pop-up menu 📜 ⬇️.

Delete clips or Events
You can delete unwanted clips from an Event, and you can delete an entire Event in order to free up space on your hard disk. When you delete a clip from an Event or an entire Event, Final Cut Pro moves the source media to the Trash.

**Note:** The Event Library must contain at least one Event.

Delete clips from an Event or an entire Event
1. In the Event Library, select the Event you want to delete or delete clips from.
2. Do either of the following:
   - *To delete clips from the Event:* Select the clips you want to remove, and choose File > Move to Trash (or press Command-Delete).
   - *To delete the entire Event:* Choose File > Move Event to Trash (or press Command-Delete).

The selected clips' source media files, or the Event and all its associated source media files, are moved to the Finder Trash. To permanently delete the source media files from your hard disk, empty the Trash.

**WARNING:** After the Trash is emptied, the deleted clips or Event and all their source media files cannot be restored.
Organize clips

View and sort clips
You can display your clips in the Event Browser in two views:

- **Filmstrip view:** Displays the clips in the selected Event as a connected series of thumbnail images. Filmstrip view is useful when you want to visually locate your clips.

- **List view:** Displays a list of your clips with associated file information. Use this view when you want to view or sort clips by data such as duration, creation date, rating, keyword, and so on. When you select a clip in list view, a filmstrip for the selected clip appears at the top of the Event Browser. The filmstrip is fully interactive, allowing access to start and end points, markers, and keywords.
Switch between filmstrip and list views
Do one of the following:

- Click the Filmstrip View button in the bottom-left corner of the Event Browser.

- Click the List View button in the bottom-left corner of the Event Browser.

Customize filmstrip view

- To adjust the time represented by each thumbnail in a clip’s filmstrip: At the bottom-right corner of the Event Browser, drag the Duration slider.

Adjusting the Duration slider expands and contracts the amount of detail shown in each clip’s filmstrip. The longer each thumbnail’s duration, the fewer thumbnails each clip displays, and the more clips are displayed in the Event Browser.
To adjust the filmstrip height: At the bottom-right corner of the Event Browser, click the Clip Appearance button and drag the Clip Height slider.
To turn audio waveforms on and off: At the bottom-right corner of the Event Browser, click the Clip Appearance button and deselect the Show Waveforms checkbox in the window that appears.

When audio waveforms are on, they appear at the bottom of each clip’s filmstrip, increasing the height of all clips in the Event Browser.

Customize list view

- To choose what type of information is displayed in list view columns as well as customize the columns themselves: In the Event Browser, Control-click a column heading, and choose a category option from the shortcut menu.

- To rearrange columns in list view: In the Event Browser, drag a column heading to move the column to a new position.

- To sort clips in list view by a category: Click a column heading in the Event Browser to sort clips by that category.

- To view a clip’s rating and keywords in list view: Click the disclosure triangle to the left of the clip’s name.
If a disclosure triangle appears to the left of a clip in list view, it means a rating, keyword, or both have been applied to that clip.

**Sort clips in the Event Browser**
You can sort clips in the Event Browser into an order that makes it easier to visually locate them.

1. In the Event Library, select the Event whose clips you want to sort.
2. Do one or both of the following:
   - To group clips by category: Choose Group Clips By from the Action pop-up menu below the Event Library, and choose a category from the submenu. Choose to set the sort order as Ascending or Descending from the same submenu.
   - To set the sort order of the clips in the Event without grouping them: Choose Arrange Clips By from the Action pop-up menu below the Event Library, and choose a category from the submenu.

*Note:* You can both group clips and set their sort order (arrangement) independently.

**Reset the sort order in the Event Browser to its default state**
1. In the Event Library, select the Event that contains the clips whose sort order you want to reset.
2. Choose Group Clips By > None and Group Clips By > Ascending from the Action pop-up menu below the Event Library.
3. Choose Arrange Clips By > Content Created and Arrange Clips By > Ascending from the Action pop-up menu.

**Rename clips**
You can rename clips in the Event Browser, the Timeline Index, or the Info inspector at any time.

Renaming a clip affects only that instance of the clip. For example, if you add a clip from the Event Browser to the Timeline, copy clips between Events, or copy clips within the Timeline, each of these clip instances (copies) is independent of the others and can have its own name.

*Important:* Renaming a clip in Final Cut Pro does not rename the clip’s source media file on disk.

**Rename a clip in the Event Browser**
- To rename a clip in filmstrip view: Select a clip’s name, and type a new name.
- To rename a clip in list view: Select a clip’s name, press Return, and type a new name.
**Rename a clip in the Timeline Index**

1. To open the Timeline Index, click the Timeline Index button in the lower-left corner of the Final Cut Pro main window (or press Command-Shift-2).

2. Click the Clips button at the top of the Timeline Index.

3. Click the Name field for a clip, and type a new name.

**Rename a clip in the Info inspector**

1. Select a clip in the Event Browser or the Timeline.

2. To open the Info inspector, click the Inspector button in the toolbar (shown below), and click the Info button at the top of the pane that appears.

3. In the Name section of the Info inspector, click the Name field and type a new name.
Rate clips as Favorite or Rejected

If your clips contain sections that you don’t like or that you might never want to use in a project—because they’re blurry, for example—you can mark them as Rejected. You can easily rate the clips you like and the clips you don’t like as you review them. When you’re ready to make a project or play your clip for your client, you can focus on your best footage by choosing to display only those clips you marked as Favorite. You can also delete your rejected clips’ source media files to free up space on your hard disk.

Rate clips

1. In the Event Browser, select a range, a clip, or multiple clips you want to rate.
2. Do one of the following:
   - *If you like the selection:* Press the F key or click the Favorite button in the toolbar.
     - In the Event Browser, a green line appears at the top of frames you’ve marked as Favorite.
   - *If you don’t like the selection:* Press the Delete key or click the Reject button in the toolbar.
A red line appears at the top of frames you’ve marked as Rejected.

**Note:** If you chose Hide Rejected from the Filter pop-up menu at the top of the Event Browser, clips marked as Rejected disappear from view.

**Remove ratings from clips**

1. Make sure the clips you want to work with appear in the Event Browser. You might need to choose a new option, such as All Clips, from the Filter pop-up menu at the top-left corner of the Event Browser so that all the clips you need to access are visible.

2. In the Event Browser, select the clips whose rating you want to remove, and press the U key or click the Clear Rating button in the toolbar.

The green or red line at the top of the clips disappears.
Add keywords to clips
Applying keywords to your clips helps you quickly locate the clips you need to compose your movie. Analysis keywords are also automatically added to clips that have been analyzed for common video and audio issues.

When a keyword is applied to a clip or a section of a clip, a Keyword Collection appears in the Event Library. A Keyword Collection contains pointers (aliases) to clips tagged with a specific keyword. For example, if you apply the keyword “Toys” to all clips containing toys, you can then select the “Toys” Keyword Collection in the Event Library to view all clips containing toys in the Event Browser.

You can apply one or more keywords to any range within a clip, a whole clip, or groups of clips in an Event, and you can apply keywords in two ways:
- Add keywords using the Keyword Editor
- Add keywords quickly using keyboard shortcuts

You can also remove a keyword or subset of keywords that you previously applied.

Apply keywords using the Keyword Editor
1 In the Event Browser, select a range or one or more clips to which you want to add keywords.
2 To open the Keyword Editor, click the Keywords button in the toolbar.
3 At the top of the Keyword Editor, type the keyword or keyword phrase you want to apply to the selection, and press Return.
Repeat step 3 for each keyword or keyword phrase you want added to the selection. A blue line appears at the top of the selection in the Event Browser, indicating that keywords have been applied to it.

When you’re finished adding keywords, close the Keyword Editor.

Assign keywords using keyboard shortcuts
To add keyword phrases to your clips using keyboard shortcuts, you must first assign keywords and keyword phrases to the keyboard shortcuts.

1 If the Keyword Editor isn’t open, click the Keywords button in the toolbar.

2 In the Keyword Editor, click the disclosure triangle to the left of Keyword Shortcuts.

3 Type a keyword or phrase in each shortcut field, and press Return.

To reassign a keyboard shortcut, select the shortcut text in the field and type the new keyword.

To use a keyboard shortcut, select a range or one or more clips to which you want to add keywords, and press Control and the corresponding number key (1 through 9).
Remove all keywords from a clip
1 In the Event Browser, select a range or one or more clips from which you want to remove keywords.

A blue bar at the top of the clips indicates the portions of the clips that have keywords applied to them.

2 Choose Mark > Remove All Keywords (or press Control-0).

Remove a subset of keywords from a clip
You use the Keyword Editor to remove a subset of keywords from a clip.

1 In the Event Browser, select a range or one or more clips from which you want to remove specific keywords.

A blue bar at the top of the clips or range within the clip indicates the portions of the clips that have keywords applied to them. Each keyword assigned to a clip is also shown in list view.

2 Click the Keywords button in the toolbar to open the Keyword Editor, select the keyword or keywords you want to remove, and press Delete.

The keyword or keywords deleted in the Keyword Editor are removed from the selection in the Event Browser.

Add or edit clip notes
As you review your clips, you can add and edit notes about them in the Event Browser or the Timeline Index. You can quickly find your clips by entering the note text in the search field in the Event Browser or the Timeline Index, or the Text field in the Filter window.

Note: You can add notes to each instance of a clip. For example, if you add a clip from the Event Browser to the Timeline, copy clips between Events, or copy clips within the Timeline, each of these clip instances (copies) is independent of the others.
Add or edit clip notes in the Event Browser
1 Click the List View button in the bottom-left corner of the Event Browser.

2 Select the clip for which you want to add or edit notes.
   Note: Notes are applied to the whole clip, not to range selections.
3 Click the Notes field for the clip, and type or edit the notes for that clip.

Add or edit clip notes in the Timeline Index
1 To open the Timeline Index, click the Timeline Index button in the lower-left corner of the Final Cut Pro main window (or press Command-Shift-2).

2 To open the Clips pane, click the Clips button at the top of the Timeline Index.
3 If the Notes column is not visible in the Clips pane, Control-click a column heading and choose Notes from the shortcut menu.

4 Click the Notes field for the clip, and type or edit the notes for that clip.

Organize clips by roles
You can organize clips by roles, which are metadata text labels assigned to clips.

When you import clips (video, audio, or still images), Final Cut Pro automatically assigns one of five default roles to the video and audio components of each clip: Video, Titles, Dialogue, Music, and Effects. You can also create custom roles and subroles and assign them to clips.

You can view and reassign roles in the Event Browser, the Timeline Index, or the Info inspector. For example, you could easily identify all your dialogue clips and play them back in isolation from other audio clips. See “View and reassign roles” on page 340.

Find clips in the Event Browser
In Final Cut Pro, you can search for media in two ways:

- *Quickly filter clips by marking:* Use the Filter pop-up menu in the Event Browser to quickly locate individual clips by rating, or the absence of ratings and keywords.

- *Search by a combination of criteria using the Filter window:* Use the Filter window to perform complex searches for clips, also known as a *weighted search*. You can use a wide variety of criteria to search with, including clip name, rating, media type, excessive shake, keywords, the presence of people, format information, and date.
Filter clips quickly by rating
Use the Filter pop-up menu in the Event Browser to quickly find clips by rating.

1 In the Event Library, select one or more Events you want to search.
2 Choose an option from the Filter pop-up menu at the top of the Event Browser.

- **All Clips**: Shows all clips in the Event.
- **Hide Rejected**: Shows all clips or range selections except those you’ve rated Reject.
- **No Ratings or Keywords**: Shows only the clips or range selections without ratings or keywords.
- **Favorites**: Shows only the clips or range selections you’ve rated Favorite.
- **Rejected**: Shows only the clips or range selections you’ve rated Reject.

Search for clips by a combination of criteria
The Filter window allows you to combine multiple search criteria. For example, you can search for video clips that contain the text “exterior” in their metadata.

1 In the Event Library, select the Event or folder you want to search.
2 Click the Filter button at the top of the Event Browser.
3 In the Filter window, choose search criteria, or rules, from the Add Rule pop-up menu.
• **Text:** Find clips by their name or any notes applied to them in list view using text. You can add multiple Text rules to search by more than one word or phrase, as well as eliminate specific words and phrases from the search.

• **Ratings:** Find clips based on the rating (Favorite or Reject) assigned to them.

• **Media Type:** Find clips whose source media files are of a specific type, such as video, audio, or stills.

• **Stabilization:** Find video clips that Final Cut Pro has identified as having excessive shake.

• **Keywords:** Find clips by any of the keywords that you’ve assigned to them. You can select one or more keywords to search for.

• **People:** Find clips that Final Cut Pro has identified as having people in them.

• **Format Info:** Find clips using format information, such as video frame rate or scene number.

• **Date:** Find clips by either the date the clip’s media file was created or the date the media was imported into Final Cut Pro.

• **Roles:** Find clips by their assigned roles.

To remove a rule, click the Remove button to the right of the rule. To exclude a rule from your search without removing it, deselect the checkbox to the left of the rule.

4 Further refine your search by choosing items from the pop-up menus for the rules you’ve added.

5 Do one of the following:

• **To specify that a clip must match at least one of the criteria or keywords:** Choose Any from the pop-up menu in the upper-left corner of the Filter window.

• **To specify that a clip must match all the criteria and keywords:** Choose All from the pop-up menu.

The clips that match the search criteria are displayed in the Event Browser, and icons indicating the search status appear to the right of the Filter button at the top of the Event Browser.

If you wish, you can save your search results as a Smart Collection, which gathers clips automatically based on the search criteria.
Clear a weighted search

- Click the Reset button to the right of the search status icons in the upper-right corner of the Event Browser.

Tip: If clips still appear to be missing from view, make sure to choose either All Clips or Hide Rejected from the Filter pop-up menu in the upper-left corner of the Event Browser.

Search for clips by clip name and notes

You can use the search field to quickly find clips by name and any notes (applied in list view) without having to open the Filter window.

1. In the Event Library, select one or more Events you want to search.
2. In the search field, enter the clip’s name or notes applied to the clip you’re looking for.

Conduct a filter and search workflow

Performing a weighted search and then filtering the clips in the Event Browser by rating is a powerful way to quickly find clips. This is also the best method of finding specific clips that you haven’t rated and comparing them against the clips you have rated.

1. In the Event Library, select the Event or folder you want to search.
2. Search for clips using a combination of search criteria as described in the “Search for clips by a combination of criteria” steps above. However, do not apply a ratings filter using the Filter window.
3. Use the Filter pop-up menu, as described in the “Filter clips quickly by rating” steps above, to quickly filter the clips by rating.
4. Repeat step 3 until you find the clips you’re looking for.

Save searches as Smart Collections

When you search for clips in an Event using the Filter window, you can save your results by creating a new Smart Collection that gathers clips matching the search criteria. Anytime a new clip that matches the Smart Collection’s search criteria is brought into the Event, the new clip is automatically added to the Smart Collection.

Clips that appear in Smart Collections are not duplicates. Smart Collections filter clips in an Event to help you focus on the clips you need to use for a specific task.
Create a Smart Collection based on search criteria

1. In the Event Library, select an Event.
2. Use the Filter window to search for clips based on specified criteria.
3. In the Filter window, click the New Smart Collection button.
   A new, untitled Smart Collection appears in the Event Library.
4. Type a name for the Smart Collection, and press Return.
   When you add clips to the Event that match the Smart Collection’s search criteria, they’re automatically added to the Smart Collection.

Change the contents of a Smart Collection

1. In the Event Library, double-click the Smart Collection whose contents you want to change.
   The Filter window for the Smart Collection appears.

2. Revise the search criteria in the Filter window.
3. When you’re finished specifying search criteria, close the Filter window.

   Note: Modifying a clip’s ratings or keywords in such a way that it no longer matches a Smart Collection’s search criteria results in the clip no longer appearing in the Smart Collection.

Delete a Smart Collection

- In the Event Library, select the Smart Collection you want to delete, and choose File > Delete Smart Collection (or press Command-Delete).
   The Smart Collection is removed from the Event Library, but its associated clips (the clips that appeared in it) are unaffected.
Organize Keyword and Smart Collections
You can organize Keyword Collections and Smart Collections in the Event Library with folders.

Organize collections with folders
1 In the Event Library, select the Event containing the collections you want to organize, and choose File > New Folder.

2 Type a name for the new folder that appears within the Event.

3 Select the Smart Collections and Keyword Collections you want to organize, and drag them into the new folder.

You can show and hide the contents of the folder by clicking the disclosure triangle to the left of the folder’s name.
Playback and skimming overview

Final Cut Pro makes it easy to view and listen your media, whether it’s located in the Event Browser, the Project Library, or the Timeline. Its dynamic previewing capabilities let you find what you need quickly without being distracted from the task at hand.

You use two tools to preview and play back media in Final Cut Pro:

- The playhead marks your project’s current position in the Timeline or the Event Browser. You can move the playhead by dragging it or clicking another area of the Timeline or Event Browser. You use the playhead to scrub, or play back from its current position.

  The playhead appears as a gray vertical line that is fixed in place unless you move it or click elsewhere.

- The skimmer lets you preview clips in the Timeline, Event Browser, or Project Library, without affecting the playhead position. You use the skimmer to skim, or freely move over clips to play back at the position and speed of the pointer.
The skimmer appears as a pink vertical line as you move the pointer over the area you’re skimming. If you have snapping turned on, the skimmer turns orange when it snaps to a position.

When skimming is turned on, you can skim to see what’s in other clips, but still keep your playhead position in the Timeline. If both the playhead and skimmer are present in the same clip, the skimmer becomes the default position for playback or editing.

When skimming is turned off or the skimmer is not present in a clip, the playhead assumes the default position.

**Play back media**

You can play back projects and clips in Final Cut Pro. Playback options include playing from the beginning, playing from a certain point, looping playback, and playing at different speeds.

Whether Final Cut Pro uses proxy media or your original or optimized media during playback is determined by the playback setting you select in the Final Cut Pro Editing preferences. See “Playback preferences” on page 498 for more information.
Play back video and audio clips

- To play a project or clip from the beginning: Select the project or clip and choose View > Playback > Play from Beginning (or press Shift-Control-I).

- To play a section of a project, selected clips, or a frame range from the beginning: Select the project, clips, or all or part of a clip, and choose View > Playback > Play Selection, or press the Slash (/) key.

When you select a clip or a portion of a clip or project, the selected area is marked with a yellow border.

- To play a project or clip from a specific point: In the Event Browser or the Timeline, click a point in a project or within a clip where you want to begin (or move the playhead to the point in the Timeline), and either press the Space bar or click the Play button in the Viewer (or press L).

- To play around the playhead or skimmer: Choose View > Playback > Play Around, or press Shift-Question Mark (?).

- To stop playback: Press the Space bar.
Skim media

You can quickly skim your video and audio to preview it, search for a particular shot, or make an edit. When skimming is turned on and you move the pointer forward or backward over a clip in the Event Browser or the Timeline, the content under the pointer plays in the Viewer.

You can also use the Blade, Trim, and Range Selection editing tools to skim clips in the Timeline or in the Precision Editor.

As you're editing in Final Cut Pro, you may find skimming distracting when you move the pointer from one location to another. You can disable all skimming (or just audio skimming).

Skim clips

- Move the pointer forward or backward over a clip in the Event Browser or the Timeline. The skimmer (a vertical pink line) indicates exactly where the pointer is as you skim, and the corresponding frames are displayed in the Viewer.

Tip: You can also press the Space bar at any time to play forward from the skimmer position.
Skim clips with editing tools
You can skim clips when you use the Blade, Trim, and Range Selection tools in the Timeline or in the Precision Editor. The tools behave as skimmers as you move the pointer over a clip.

1 Select a clip in the Timeline or open the Precision Editor.

2 Select either the Blade, Trim, or Range Selection tool from the Tools pop-up menu in the toolbar.

3 Move the tool forward or backward over a clip.

When using an editing tool as a skimmer, you can skim and add markers to clips under connected clips in the Timeline.

Turn skimming on and off
- To turn all skimming on or off: Click the Skimming button, choose View > Skimming, or press S.
- To turn audio skimming on or off: Click the Audio Skimming button, choose View > Audio Skimming, or press Shift-S.

When skimming is turned on, the skimming buttons appear blue.

Note: When skimming is turned off, you can still skim with the Blade, Trim, and Range Selection editing tools.
Use the J, K, and L keys
You can use the J, K, and L keys on your keyboard to play through a project or clip. Playback begins at the location of the playhead (on a project) or the skimmer (on a clip). You can also use the J, K, and L keys to control a video playback device.

You can use these keys to speed playback up to 32x normal speed.

Use the J, K, and L keys for playback
- To begin forward playback at normal (1x) speed: Press L.
- To begin reverse playback at normal (1x) speed: Press J.
- To pause playback: Press K.
- To double the current playback speed: Press L or J twice.
- To immediately reverse the playback direction: Press J to play in reverse, or press L to play forward.
- To move the playhead one frame at a time: Hold down the K key, and press J or L.
- To move the playhead at 1/2x speed: Hold down the K key while holding down J or L.

When you use keyboard shortcuts to control a device (like a camcorder or camera), the speed of forward (L) and reverse (J) playback may differ depending on your video equipment.
Play back media in a loop
You can turn on looping so that a project (or any portion of it) plays in a continuous loop.

Turn looping on or off
Do one of the following:
- Choose View > Playback > Loop Playback (or press Command-L).
- Click the Loop Playback button  below the Viewer.

Loop your entire project
With looping turned on, press the Space bar to play the project.

Loop a portion of your project
1 Select a range in the Timeline.
2 Choose View > Playback > Selection, or press the Slash (/) key.

Play video full screen
Play video in full-screen view
1 Select or open a project in the Project Library or open a clip in the Event Library. Then position the playhead where you want the video to begin.
2 Do one of the following:
   • Choose View > Playback > Play Full Screen (or press Command-Shift-F).
   • Click the Play Full Screen button  below the Viewer.
   The item plays in full-screen view starting at the playhead position.
3 To leave full-screen view, press the Esc (Escape) key.
View playback on a second display
If you have a second display connected to your computer, you can show the Viewer on the second display to play video, or the Event Browser on the second display to view clips in an Event, thereby expanding your workspace in the Final Cut Pro main window.

Show the Viewer on a second display
1. Connect a second display (a second computer monitor connected to the PCI video card), and make sure it is connected to power and turned on.
2. In Final Cut Pro, choose Window > Show Viewer on Second Display.

The Viewer appears on the second display. All Viewer features (including onscreen controls) are now available on the second display.

3. To return the Viewer to the Final Cut Pro main window, choose Window > Show Viewer in the Main Window.

Show the Event Library and the Event Browser on a second display
1. Connect a second display (a second computer monitor connected to the PCI video card), and make sure it is connected to power and turned on.
2. In Final Cut Pro, choose Window > Show Events on Second Display.

The Event Library and Event Browser appear on the second display. All Event features (including selection capabilities, markers, keywords, and so on) are now available on the second display.

To return the Event Library and Event Browser to the Final Cut Pro main window, choose Window > Show Events in the Main Window.
View playback on an external video monitor

Final Cut Pro includes an A/V Output option to send video and audio from your computer to an external video monitor. In addition to showing you how video and audio look and sound on an NTSC/PAL or HD broadcast monitor, this feature also allows you to test output with more sophisticated devices such as vectorscopes and waveform monitors.

A/V output is available only with OS X Lion v10.7.2 or later and requires compatible third-party video interface hardware and software. FireWire DV devices are not supported. For more information, contact the device manufacturer or go to the Final Cut Pro X Resources webpage at http://www.apple.com/finalcutpro/resources.

Play video and audio on an external video monitor

1 Install the video interface hardware and software according to the manufacturer’s instructions.

2 Connect an external video monitor to the video interface and make sure it’s connected to power and turned on.

3 To select an A/V output device, choose Final Cut Pro > Preferences (or press Command-Comma), click Playback, and choose a device in the Playback preferences pane.

4 In Final Cut Pro, choose Window > A/V Output.

The Viewer contents appear on the broadcast monitor. Viewer features (such as onscreen controls and the title-safe and action-safe overlays) can be viewed only in Final Cut Pro.

Note: Video and audio are synced at the video frame (not audio sample) level.

To turn off A/V output, choose Window > A/V Output.
Playback and background rendering

When you add effects, transitions, generators, titles, and other items that require rendering, the background render indicator (an orange bar) appears below the timecode in the Timeline.

By default, background rendering begins 5 seconds after you stop working and moving the pointer in Final Cut Pro. Background rendering continues while you work in a different application. You can change this setting in the Final Cut Pro preferences.

Play your projects on other devices

You can view your Final Cut Pro project on Apple TV, watch your movies in Front Row, and sync a project to an iPhone, iPad, or iPod. For more information, see “Sharing projects overview” on page 434.
Create a new project
To create a movie in Final Cut Pro, you first create a project, which provides a record of your editing decisions and the media you use. Then you add clips to the project Timeline and edit them.

When you create a new Final Cut Pro project, you do the following:

- Name the project.
- Specify a default Event for the project.
  The default Event stores media that's dragged to the project from the Finder or a Final Cut Pro media browser. If you drag media from the Finder to the project's Timeline, that media is automatically located in the project's default Event.

Optionally, you can also set the starting timecode and define the video, audio, and render properties for the project.

After creating your project, you add clips to it from the Event Library.

Note: If you're creating a project and you haven't yet imported media into Final Cut Pro, you should do so. See “Importing overview” on page 24 for information.

Start a project
1 Do one of the following:
   - In Final Cut Pro, choose File > New Project (or press Command-N).
   - Make sure the Project Library is open, and click the New Project button.

2 In the window that appears, type a name for the project in the Name field.
3 Choose a default Event for the project.

If you drag any media files from the Finder directly to the project’s Timeline, or add media to the project from one of the media browsers, that media is automatically added to the project’s default Event.

4 If you want to further customize settings for your project, click Use Custom Settings.

**Note:** Final Cut Pro shows the Automatic Settings by default, but it will remember the settings you used last, so this step may be unnecessary.

5 If you want your project’s timecode to start at a value other than 00:00:00:00, type a starting timecode value in the Starting Timecode field.

6 If you want to make any changes to the project’s video or audio properties, select Custom and use the pop-up menus.

Unless you have a specific requirement for the project you’re creating, it’s best to leave “Set automatically based on first video clip” selected.

7 Click OK.

The new project appears in the Project Library with the name you gave it in step 2.

You can now add clips from the Event Browser and begin to edit your project in other ways, adding titles, special effects, background music, sound effects, and more.

You can change a project’s name, default Event, and project properties at any time. See “Modify a project’s name and properties” on page 94 for more information.
Preview and open a project
If you want to see the contents of a project, you can preview the project before opening it.

Preview a project
1 If the Project Library is not already open, click the Project Library button at the bottom-left corner of the Final Cut Pro main window.

2 Select a project in the Project Library.
3 To preview a project in the Viewer, select it and do one of the following:
   • To skim the project: Move the pointer over the filmstrip (to the right of the project’s name).
   • To play the project from the skimmer (the pink vertical line): Press the Space bar; press it again to stop playing the project.

Open a project
1 Open the Project Library.
2 Locate the project you want to open and double-click it.

Modify a project’s name and properties
As your project evolves, you may decide you want to rename it or change its properties.

Rename a project
1 If the Project Library is not already open, click the Project Library button at the bottom-left corner of the Final Cut Pro main window.

2 Select a project, and click the project’s name to highlight it.
3 Type a new name in the project Name field, and press Return.

Depending on how you have the Project Library organized, the project’s position in the project list may change after you rename it.

Change a project’s default Event and properties
When you create a project, you set the project properties and assign the project a default Event to hold media that is dragged directly into the project’s Timeline from a Final Cut Pro media browser or the Finder.
In most cases, Final Cut Pro manages project properties automatically based on the properties of the first clip you add to a project, but you can change a project’s properties at any time. If you must modify the project properties, choose video and audio project properties based on how you intend to share your final movie with your audience.

1. Open the Project Library and select a project.
2. Do one of the following:
   - Choose File > Project Properties (or press Command-J).
   - If the Inspector pane is hidden, click the Inspector button in the toolbar.

Then click the Properties button at the top of the pane.

3. Click the Project Properties button.

4. In the window that appears, change the settings as appropriate.
Name
- **Name:** Type a name for the project.

Default Event
- **Default Event:** Choose the default Event for the project.

Starting Timecode
- **Starting Timecode:** If you want your project’s timecode to start at a value other than 00:00:00:00, type a starting timecode value.

Drop Frame Timecode
- **Drop Frame:** Select the checkbox to turn on drop frame timecode (this option appears only for 29.97 and 59.94 fps media).

  In *non-drop frame* timecode, the timecode counter counts at a consistent rate without dropping any numbers from the count. Non-drop frame timecode is available as a display option for every frame rate.

  In *drop frame* timecode, frames 0 and 1 are skipped the first second of every minute, unless the minute number is exactly divisible by 10.

Video Properties
- **Format:** Choose the video format (a specific method of encoding the video).
- **Resolution:** Choose the frame size of the video.
- **Rate:** Choose the frames per second (fps).

Audio and Render Properties
- **Audio Channels:** Choose whether to present the audio as multichannel surround sound or as stereo.
- **Audio Sample Rate:** Choose the audio sample rate for your project (the number of times a signal is measured—or sampled—per second). A higher sample rate produces higher-quality audio and larger file sizes, and a lower sample rate produces lower-quality audio and smaller file sizes. Which sample rate you choose to work with depends on the source material you’re working with, and the final destination of your audio.
- **Render Format:** Choose the codec to use for your project’s background rendering.

5 Click OK.

Define the order in which Events are referenced by a project
If you have duplicate clips in different Events, you can define the order in which Final Cut Pro looks for the clips.

1 Open the Project Library and select a project.
2 Do one of the following:
   - Choose File > Project Properties (or press Command-J).
   - If the Inspector pane is hidden, click the Inspector button in the toolbar.

Then click the Properties button at the top of the pane.

3 Click the Modify Event References button in the Referenced Events section.

4 In the window that appears, drag the Events to set the order in which Final Cut Pro will look for clips.

5 When you’ve set the order, click OK.
Organize projects in the Project Library
All your Final Cut Pro video projects are listed in the Project Library. You can start organizing your projects by connecting additional hard disks, creating folders to hold projects, and giving your projects clear and specific names. As your Project Library grows, you can rename, copy, move, and delete your projects as necessary.

Use folders to sort projects
1. If the Project Library is not already open, click the Project Library button at the bottom-left corner of the Final Cut Pro main window.

2. Select a disk, folder, or project to which you want to add a folder, and click the New Folder button at the bottom-left corner of the Final Cut Pro main window.

A new folder called New Folder appears inside the disk or folder you selected, or at the same level as the project you selected.

3. Do any of the following:
   - To rename the folder: Select the folder, click the folder name, and type a new name.
   - To add a project to the folder: Drag the project to the folder.
   - To open or close the folder: Click the disclosure triangle to the left of the folder name.
Copy a project
Copying a project is useful if you want to work on a new version of a project or transfer a copy to another computer.

1 Open the Project Library and select a project.
2 Choose File > Duplicate Project.
3 In the window that appears, choose a location for the duplicated file from the Location pop-up menu.
4 Select an option to specify what is duplicated:
   - Duplicate Project Only: Duplicates only the project file.
   - Duplicate Project and Referenced Events: Duplicates the project file, any Events referred to by the project file, and all of the media in the referenced Events.
   - Duplicate Project + Used Clips Only: Duplicates the project file and the media files for any clips used in the project.
   - Include Render Files: Select this checkbox to include render files for the clips and projects. If you want to free up hard disk space, deselect this checkbox.

5 Click OK.

Final Cut Pro duplicates the project to the location you chose using the option you specified. The project is given an appended name (for example “.Bill's movie1”), and the project appears in the Project Library.

Quickly copy a project to a connected external storage device
- Open the Project Library, select a project, and drag the project to another hard disk’s icon in the Project Library.
Move a project
You can easily move a project to a connected hard disk or another computer. Moving a project file is useful if you want to work on a project using another computer that has Final Cut Pro installed, or if you want to free up space on your computer’s hard disk.

Important: You cannot undo a file move.

1 Open the Project Library and select a project.

2 Do one of the following:
   - Choose File > Move Project.
   - Hold down the Command key while you drag the project to another hard disk’s icon in the Project Library.

3 In the window that appears, choose where you want to move the project (to a hard disk or computer) from the Location pop-up menu.

4 Select an option to specify what is moved:
   - Move Project Only: Moves only the project file.
   - Move Project and Referenced Events: Moves the project file, any Events referred to by the project file, and all of the media in the referenced Events.

5 Click OK.

Final Cut Pro moves the project to the location you chose using the option you specified. See “Where your media and project files are located” on page 464 for information about the default location of Final Cut Pro projects and Events.
Delete a project or project folder
Deleting a project folder deletes the folder and all of the projects it contains. Your media is not deleted because media is stored in Events.

1 Open the Project Library and select a project.
2 Do one of the following:
   • To delete a project: Select the project and choose File > Move Project to Trash (or press Command-Delete).
   • To delete a folder and any projects the folder contains: Select the folder and choose File > Move Folder to Trash (or press Command-Delete).

The project or project folder (and the projects the folder contains) is removed from the Project Library and moved into the Finder Trash.

3 To permanently delete the project or project folder and its files and free up space on your hard disk, empty the Finder Trash.

**WARNING:** After the Trash is emptied, the file or folder cannot be restored.

You can also delete a project’s render files. See “View background tasks” on page 476 for more information.

Save projects
Final Cut Pro automatically saves all the changes you make as you work on a project, which means you never have to save changes manually. Also, you can undo all of your changes up to the last time you quit and reopened Final Cut Pro by choosing Edit > Undo (or pressing Command-Z).

Changes you make to a clip in a project do not affect the clip’s source file. Thus, if you’ve made a lot of changes to a clip but want to start fresh, you can easily restore the clip to its original state by adding a new copy of the clip (located in the Event Library) to your project.
Editing overview

The term video editing refers both to broader stages of a project workflow and to very specific manual tasks that you do with clips in a project Timeline.

- **Make selections and add clips to the Timeline:** Adding and arranging clips in your project is the fundamental step in creating a movie with Final Cut Pro. You move and reorder clips in the Timeline. See “Adding clips overview” on page 108, “Arrange clips in the Timeline” on page 126, and “Audio overview” on page 172.

- **Cut and trim clips:** Final Cut Pro provides a wide variety of tools for adjusting the start and end points of clips in the Timeline and for controlling pacing from one shot to the next. See “Trimming overview” on page 134.

- **Further refine and adjust your project:** Final Cut Pro provides many advanced editing tools to finish a highly polished movie with ease. See topics in the advanced editing section.

- **Add effects and color correction:** Finishing touches include visual effects and color correction. See “Transitions, titles, effects, and generators overview” on page 217 and “Color correction overview” on page 409.

Select clips and ranges

About selections and filmstrips

A fundamental step in editing a video project is choosing what you want to include in your final movie. In Final Cut Pro you indicate what clips or portions of clips you want to act on by making a selection. Final Cut Pro provides a variety of powerful tools for making selections with both speed and precision, including filmstrips, which are connected series of thumbnail images. Your video clips appear as filmstrips in the Timeline (where you build projects) and in the Event Browser (where your source media is displayed). A single video filmstrip might represent several seconds of video encompassing hundreds of video frames (individual images). Audio-only clips appear as audio waveforms, showing the change in the audio volume over time.
When you add clips from the Event Browser to a project in the Timeline, you can add one or more whole clips, or you can add a range within a clip. Then you can fine-tune the clips individually in the Timeline, adding video effects to them, for example, or inserting transitions between them.

You can adjust the appearance of filmstrips in the Event Browser and the Timeline so that it’s easier to make selections. For example, expanding the width of a filmstrip (by showing shorter durations per thumbnail) helps you make more precise selections.

You can also adjust the filmstrip appearance in the Timeline to make it easier to view and select audio waveforms.

**Select one or more clips**

Clips represent your video, audio, and graphics files and allow you to work with your media in Final Cut Pro without changing the files themselves. To add clips to your project, rearrange them, or trim them, you first need to select them. You can select a single clip or multiple clips at a time.
Selecting multiple clips allows you to move them as a group within your project, or from one Event to another. It’s also useful if you’ve made adjustments to a clip and you want to paste the same adjustments onto several other clips.

**Select an entire clip**
Do one of the following:

- Click the clip once.
- In the Timeline, move the skimmer (or the playhead if skimming is turned off) over the clip you want to select and press C. This method selects the clip in the primary storyline.

Connected clips and storylines are attached to clips in the primary storyline, and they appear above and below the primary storyline. To select a connected clip or storyline with this keyboard shortcut method, move the pointer directly on the connected clip and press C. For more information, see “Connect clips to add cutaway shots, titles, and synchronized sound effects” on page 113 and “Add storylines” on page 294.

A yellow border appears around the clip, indicating that it is selected.

![Select an entire clip](image)

**Note:** A clip selection (shown above) is functionally and visually distinct from a range selection, which has range handles for adjusting the selection start point and selection end point. Unless you are making a multiple clip selection, all selections in the Event Browser are range selections. In the Timeline, you can make either clip selections or range selections.

**Select multiple clips in the Event Browser or the Timeline**

- **To select a contiguous, linear series of clips:** Hold down the Shift key as you click the first and last clips in the range.
- **To select a number of individual clips:** Hold down the Command key as you click the clips you want to select.
- **To select all clips in the Event Browser or the Timeline:** Select a single clip in the Event Browser or Timeline and choose Edit > Select All (or press Command-A).
To select multiple clips by dragging: Drag a selection rectangle by dragging over the Timeline or Event clips you want to select.

Tip: To prevent the playhead from moving while you select a clip in the Timeline, press Option as you click.

Deselect clips in the Event Browser or the Timeline
- To deselect a single selected clip: Select a different clip, or click outside the clip.
- To deselect multiple selected clips: Hold down the Command key and click the clips you don’t want selected.
- To deselect all clips: Choose Edit > Select > None (or press Command-Shift-A).

Select a range
Instead of selecting whole clips, you can select a range within any clip in the Timeline or in the Event Browser. In the Timeline, you can also select a range that spans multiple clips. You can trim range selections, mark them with ratings and keywords, apply effects to them, and modify them in other ways. You can adjust the range selection start and end points using range handles on either side of the selection.
Select a range
Do one of the following:

- In the Event Browser, drag across any clip (filmstrip).
  A yellow border with handles appears around the range you've selected.
  If the filmstrip wraps onto two lines, you can select a frame range extending over the
  break simply by continuing to drag across the break. When you reach the edge, the
  pointer jumps to the next line.

- In the Timeline, choose Range Selection from the Tools pop-up menu in the toolbar
  (or press R).

The pointer changes to the Range Selection tool.

**Tip:** To temporarily turn on the Range Selection tool, hold down the R key. When you
release the R key, the tool reverts to the previously active tool.

Drag the Range Selection tool across one or more clips in the Timeline to select a
range. To adjust the selection start and end points, drag the range handles on either
side of the range.
Use the I and O keys to set the selection start and end points. For more information, see the instructions below.

In the Event Browser or the Timeline, move the skimmer (or the playhead) over a clip and press X. Final Cut Pro sets the range selection start and end points at the clip start and end points.

**Note:** To use this X key method with connected clips or clips in a connected storyline, move the pointer directly over the clip and press X.

**Set a range selection start point or end point**
Do either or both of the following:

- **To set the start point:** Position the skimmer (or the playhead, if skimming is turned off) where you want the selection to start, and press I. To remove the range selection start point, press Option-I.
- **To set the end point:** Position the skimmer (or the playhead, if skimming is turned off) where you want the selection to end, and press O. To remove the range selection end point, press Option-O.

**Tip:** You can also press the I or the O key to set the selection start point or end point while a clip or your project is playing back.

If you’re using the Blade, Trim, and Range Selection tools in the Timeline or in the Precision Editor, you can use this method to set selection start and end points in a connected clip or storyline, as well as on clips underneath connected clips and storylines. Move the pointer directly over a clip and press I to set a selection start point or O to set a selection end point.

**Extend or shorten the range selection**

- **To adjust where the selection starts or ends:** Drag the left or right edge of the yellow selection border.
- **To reset the selection start point or end point for an active range selection within the same Event clip or project:** Move the skimmer and press I or O.

**Tip:** You can also press the I or the O key while a clip is playing back.

**To extend or shorten a range selection within a selected Event clip:** Move the skimmer to any frame that you want the selection to begin or end with, and then hold down the Shift key and drag.

The frame range is lengthened or shortened accordingly.

If you require the skimmer and it is not present, you can turn on skimming at any time.
Deselect a range
- Click outside of the range or select a different range.

Add and remove clips

Adding clips overview
You build a movie project by adding clips to the Timeline in a chronological arrangement. To suit your particular editing style or need, you can choose from a wide variety of tools and techniques for adding clips. You can change the arrangement of the clips in the Timeline at any time.

In Final Cut Pro, you can edit your projects without worrying about maintaining clip connection or synchronization. For example, when you drag a clip into the Timeline, Final Cut Pro automatically rearranges the Timeline to fit each new clip without disturbing your existing work. This is true for all kinds of clips: video, audio, titles, generators, still images, and so on.

You can use clips from multiple Events in a single project. You can also add clips from the Final Cut Pro media browsers and from the Finder. Deleting clips from the Timeline does not affect clips or files in the Event Browser, the media browsers, or the Finder.

Connected clips and storylines remain attached to, and synchronized with, clips in the primary storyline until you explicitly move or remove them.
Drag clips to the Timeline
You can add clips to the Timeline by dragging them from the Event Browser, from a Final Cut Pro media browser (such as the Photos Browser or the Generators Browser), or from the Finder.

Drag clips from the Event Browser or a media browser
1 Do one of the following:
   • In the Event Library, select an Event containing the clips you want to add to your project.
   • Open the media browser containing the media you want to add to your project.
2 Drag one or more clips to the Timeline from the Event Browser or a media browser.
   Depending on where you drag the clips in the Timeline, your actions may result in an append, an insert, a connect, or a replace edit. Final Cut Pro automatically adjusts surrounding clips to fit in place around any clips you’ve dragged.

Tip: You can add one clip to your project at a time, or sometimes it’s easier to add a number of clips to the project at once, and then rearrange them in the Timeline.

Drag files from the Finder
1 Arrange the windows onscreen so that you can see both the Final Cut Pro main window and the files in the Finder.
2 Drag the files from the Finder to the Timeline.
   Depending on where you drag the clips in the Timeline, your actions may result in an append, an insert, a connect, or a replace edit.

Note: If you add clips to the Timeline from a Final Cut Pro media browser or the Finder, you are effectively importing the media to the default Event associated with the current project. You can configure the default Event in the project settings window. In this scenario, Final Cut Pro applies the default optimization and analysis settings to the new clips. You can set default optimization and analysis processes in Final Cut Pro preferences.
   If you add still images to the Timeline, they will have a duration of 4 seconds by default. You can change this default duration in Final Cut Pro preferences.
Append clips to your project
A simple way to add a clip to your project is an append edit, in which you add one or more clips to the end of a project or storyline.

Append clips to your project in the Timeline
1 Select one or more clips in the Event Browser.
2 To add the clips to the Timeline, do one of the following:
   - Choose Edit > Append to End (or press E).
   - Click the Append button in the toolbar.

If there is no selection, the clip appears at the end of the primary storyline in the Timeline. If a storyline is selected, the clip appears at the end of the selected storyline.

Insert clips in your project
An insert edit places the source clip so that all clips after the insertion point are moved forward (or rippled) in the Timeline to make room for the clip being added. No clips are removed from your project. An insert edit makes the project longer by the duration of the inserted clip.

You might use insert edits when you want to add a new shot in the beginning or the middle of your project. You can also use an insert edit to interrupt the action in an existing clip with the action in the newly inserted clip. The action in the original clip then resumes after the inserted clip.

Note: You can use three-point editing to make insert edits. For more information, see “Three-point editing overview” on page 308.

Insert Event Browser clips in the Timeline
1 Select one or more clips in the Event Browser.
2 Move the playhead to the point in the primary storyline or a selected storyline (or make a range selection) where you want to insert the clip.
3 Do one of the following:

- Choose Edit > Insert (or press W).

  **Note:** If you use the keyboard shortcut and the skimmer is present in the Timeline, the edit will occur at the skimmer position.

- Click the Insert button in the toolbar.

The clip appears in the Timeline and all clips after the insertion point are rippled forward. If the skimmer is not present, the clips are inserted at the playhead position. If you perform an insert edit in the middle of an existing Timeline clip, that clip is cut at the insertion point, and the second half is moved to the end of the newly inserted clip, along with the rest of the footage to the right of the insertion point.

**Insert a gap clip or a placeholder clip in the Timeline**
Sometimes you need to reserve space in the Timeline for a clip that you don’t yet have. Final Cut Pro provides two possible solutions to this problem: placeholder imagery or a blank and silent clip called a *gap clip* that can be adjusted to any duration.

1 Move the playhead to the point in the primary storyline or a selected storyline (or make a range selection) where you want to insert the gap clip or placeholder clip.

2 Do either of the following:

- To *insert a placeholder clip*: Choose Edit > Insert Placeholder (or press Command-Option-W).

  Final Cut Pro inserts gray placeholder imagery that you can customize. For more information, see “Use a placeholder” on page 259. You can adjust placeholder clips to any duration.

- To *insert a gap clip*: Choose Edit > Insert Gap (or press Option-W).
Final Cut Pro inserts a blank clip (containing blank video and silent audio) that you can adjust to any duration. (The film industry term for this is *slug*.)

Note: Gap clip color is determined by the current background color in Final Cut Pro. To adjust the background color, choose a Player Background option in the Playback pane of the Final Cut Pro Preferences window. If you want a different color, consider using a solid generator.

The clip appears in the Timeline, and all clips after the insertion point are rippled forward (to the right).

Insert clips by dragging them from the Event Browser, a media browser, or the Finder

You can insert clips between clips in the Timeline by dragging them from the Event Browser, another Final Cut Pro media browser, or the Finder.

- Drag the clip you want to insert to an edit point (between two clips) in the Timeline.

The clip appears in the Timeline, and all clips after the insertion point are rippled forward (to the right).
Connect clips to add cutaway shots, titles, and synchronized sound effects

You can attach clips to other clips in the Timeline. Connected clips remain attached and synchronized until you explicitly move or remove them.

Some uses for connected clips include:

- **Cutaway shots**: Add a cutaway shot by connecting it to a video clip in the Timeline.
- **Superimpose titles**: Add a title or a lower third to a video clip or range.
- **Spot sound effects and background music**: Synchronize audio clips to clips in the primary storyline. The clips will remain synchronized even if you move the primary storyline clips.

When you use the Connect menu command, keyboard shortcut, or toolbar button, video clips (blue) are connected above the primary storyline and audio clips (green) are connected below the primary storyline:
**Note:** You can use three-point editing to make connect edits. For more information, see “Three-point editing overview” on page 308.

**Connect clips in the Timeline**

1. If your project is empty, add clips to the dark gray primary storyline area in the Timeline to build your initial sequence.

The clips in the primary storyline serve as a foundation on which you connect (attach) clips to further build your project. Connect edits are slightly different than the other edit types in that they never add clips to the primary storyline. If you perform a connect edit in an empty Timeline, Final Cut Pro first adds a gap clip to the primary storyline and attaches the new connected clip to it.

2. Select one or more clips or a range in the Event Browser.

3. Do one of the following to indicate where you want to connect the selected source clip:
   - Position the playhead over the frame of the clip in the primary storyline.
   - Make a range selection in the primary storyline.
To connect the selected clips to the clips in the primary storyline, do one of the following:

- Choose Edit > Connect to Primary Storyline (or press Q).
  **Note:** If you use the keyboard shortcut and the skimmer is present in the Timeline, the clip will be connected at the skimmer position.
- Click the Connect button in the toolbar.
- Drag the clips to the gray area above or below the primary storyline.

The first frame of the source selection is connected to the clip in the primary storyline at the playhead or skimmer position. If you dragged the selection to the Timeline, the first frame of the source selection is connected to the primary storyline at the point where you released the mouse button.
When you rearrange, move, ripple, or remove clips in the primary storyline, any clips connected to them will move (or be deleted) along with the primary storyline clips.

When you connect clips by dragging them, you have the option to put video clips below the primary storyline or put audio clips above the primary storyline.
Note: In Final Cut Pro, if you connect clips, the topmost video clips block out any video clips below them. Exceptions to this rule are clips with some type of transparency, keying, or compositing settings. For more information, see “Compositing overview” on page 405. Audio clips never affect video output, even when they are placed above video clips in the Timeline.

Adjust the connection point of a connected clip
By default, connected clips and storylines are connected to the primary storyline at their first frame, but you can move the “connection point” of a connected clip or storyline. This is useful when you want to connect a specific frame or audio sample in the connected clip or storyline with a specific frame or audio sample in the primary storyline.

- Hold down the Command and Option keys, and click the connected clip (or the gray border of the storyline) at the point where you want to position the connection point.

The connection point is moved to the point where you clicked.

Special rules apply when you remove clips or ranges involved with connected clips and storylines. For more information, see “Remove clips from your project” on page 123.

Overwrite parts of your project
In an overwrite edit, one or more source clips overwrite any clips in the primary storyline or a selected storyline, starting at a range selection start point or at the playhead or skimmer position. No clip items are rippled forward, so the duration of your project remains the same.
Overwriting media is different from replacing it. Overwriting works with range selections only, not entire clips, and it is not constrained by clip boundaries. Use an overwrite edit when you want to edit media for a specific span of time, rather than specific shots.

**Note:** You can use three-point editing to make overwrite edits. For more information, see “Three-point editing overview” on page 308.

**Overwrite clips in the Timeline with clips from the Event Browser**

1. Select one or more clips in the Event Browser.

   If there are multiple source clips in the selection, the clips will appear in the Timeline in the order in which they were selected.

2. To define where you want the overwrite clip to start in the Timeline, do one of the following in the primary storyline or a selected storyline:
   - Position the playhead.
   - Select a range involving one or more clips in the Timeline.

   **Note:** The overwrite command ignores whole clip selections in the Timeline. If you don’t select a range in the Timeline, Final Cut Pro positions the start of the overwrite clip at the playhead or skimmer position.

3. Choose Edit > Overwrite (or press D).

   The source clip appears in the primary storyline and overwrites any clips for the duration of the source clip.

   **Note:** If you use the keyboard shortcut and the skimmer is present in the Timeline, the edit will occur at the skimmer position.

   To overwrite from the playhead back, so that the overwrite clip’s end point (rather than its start point) is aligned at the target position, press Shift-D.

**Replace a clip in your project with another clip**

You can replace clips in your project with clips from the Event Browser, other Final Cut Pro media browsers, or the Finder. In contrast to overwrite edits, replacing works on whole Timeline clips only and can change the duration of your project.
Replace options include using the start or end of the source clip, as well as automatically creating or adding to auditions.

**Replace a clip in the Timeline with one or more clips by dragging**

1. Do one of the following to make a source selection:
   - Select a clip or range in the Event Browser.
   - Select a media item in one of the Final Cut Pro media browsers or in the Finder.

2. Drag the source selection over the clip in the Timeline you want to replace.
   The target clip in the Timeline is highlighted with a white outline.

3. Release the mouse button and choose an option from the shortcut menu:

   - **Replace**: The target clip is replaced with the source clip selection. The duration is determined by the duration of the source clip selection. If the source clip selection and the target clip have different durations, the subsequent clips ripple.
   - **Replace from Start**: The target clip is replaced with the source clip selection, starting from the beginning of the source selection. The duration is determined by the duration of the Timeline clip.
   - **Replace from End**: The target clip is replaced with the source clip selection, starting from the end of the source selection. The duration is determined by the duration of the Timeline clip.
- **Replace and add to Audition:** The target clip is replaced with an audition that has the source clip selection as the pick and the target clip as an alternate. The duration is determined by the source clip selection. If the source clip and the target clip have different durations, the subsequent clips ripple.

- **Add to Audition:** The target clip is replaced with an audition that has the target clip as the pick and the source clip selection as an alternate.

- **Cancel:** The replace edit is canceled.

The source clip selection appears in the Timeline, in place of the original clip.

![Image of the source clip selection appearing in the Timeline.](image_url)

**Note:** In the case of Replace from Start and Replace from End, if the source clip selection is a range selection with a shorter duration than that of the target clip and there is sufficient extra media, Final Cut Pro extends the duration of the source selection to match the target clip duration. The resulting storyline duration does not change.

### Replace a clip in the Timeline using keyboard shortcuts

1. In the Event Browser, select the source clip or range.
2. In the Timeline, select the clip you want to replace.

   **Note:** This must be a whole clip selection, not a range selection. For more information, see “About selections and filmstrips” on page 102.

3. Do one of the following:

   - **To perform a standard replace edit:** Press Shift-R.
     
     The target clip is replaced with the source clip selection. The duration is determined by the duration of the source clip selection. If the source clip selection and the target clip have different durations, the subsequent clips ripple.

   - **To perform a Replace from Start edit:** Press Option-R.
     
     The target clip is replaced with the source clip, starting from the beginning of the source clip. The duration is determined by the duration of the Timeline clip.
Note: In the case of Replace from Start, if the source clip selection is a range selection with a shorter duration than that of the target clip and there is sufficient extra media, Final Cut Pro extends the source selection to match the target clip duration. The resulting storyline duration does not change.

The source clip selection appears in the Timeline, in place of the original clip.

Add and edit still images
In Final Cut Pro, you can add and edit a variety of still-image formats in your projects, including photos and graphics files.

Add a still image to the Timeline
You can add still images to your project from the Event Browser or the Photos Browser.

- To add a still image from the Event Browser: Import the still image into an Event, and then select all or part of the still-image clip and drag it from the Event Browser to the Timeline.

  Note: Once a still image is imported, it functions like any other clip in Final Cut Pro. You can use any of the techniques described in this chapter to add still-image clips to the Timeline.

- To add a still image from the Photos Browser: Open the Photos Browser, select a still image, and drag it directly into the Timeline.

  The default duration for still images is 4 seconds, but you can change this default setting in the Editing pane of Final Cut Pro preferences.

There is no limit on the duration of a still-image clip. To adjust the duration of a still-image clip in the Timeline, use any of the trimming techniques described in this chapter. To adjust the duration of multiple still-image clips at once, select the clips and choose Modify > Change Duration (or press Control-D).

Add layered graphics files to the Timeline
You can add layered graphics files, such as Adobe Photoshop (PSD) files, created with another image editing application to the Timeline.

1 Import the layered graphics file into an Event.

  Important: If the layered graphics file has a transparent background, make sure your project’s render format is set to Apple ProRes 4444 to preserve the transparency when rendering. See “Modify a project’s name and properties” on page 94.

2 In the Event Browser, Control-click the layered graphics image and choose Open in Timeline from the shortcut menu.
Each layer appears in the Timeline as a connected clip that you can edit as you would any other clip. For example, you can animate layers by fading them in or out.

Layered graphics image in the Viewer

Clips representing individual layers

**Edit a still image with an external image editing application**
You can modify a still image with an external image editing application, and the changes appear automatically in the clip in Final Cut Pro.

1. To add a still-image clip to the Timeline, follow the steps above.
2. To locate the clip's source media file in the Finder, Control-click the clip and choose Reveal in Finder from the shortcut menu (or press Command-Shift-R).
3. Open the source media file in the external image editing application.
4. In the image editing application, modify the image and save the changes.
5. Switch back to Final Cut Pro.

The changes appear automatically in the still-image clip in Final Cut Pro.

You can also create freeze frames from your video clips. For more information, see “Create freeze frames” on page 335.

**Add clips using video-only or audio-only mode**
By default, whenever you add clips from an Event to the Timeline, all of the video and audio components of the Event clip are included in the edit. However, you can also add just the video portion or just the audio portion of Event clips to the Timeline, even if the Event clips contain both video and audio.
Make video-only or audio-only edits

1 To set the edit mode, do one of the following:
   • To add just the video from your selection to the Timeline: Choose Video Only from the Edit pop-up menu in the toolbar (or press Shift-2).
     ![Video-only mode]
   • To add just the audio from your selection to the Timeline: Choose Audio Only from the Edit pop-up menu in the toolbar (or press Shift-3).

   The edit buttons in the toolbar change their appearance to indicate the mode you selected:
     ![Audio-only mode]

2 Add clips to the Timeline as you normally would.

   The video-only or audio-only clip appears in the Timeline.

   To return to the default (video and audio) mode, choose All from the Edit pop-up menu in the toolbar (or press Shift-1).

Remove clips from your project

When you remove clips from a project in the Timeline, the source media in Events, the Final Cut Pro media browsers, and the Finder is not affected.

Delete clips or ranges from the Timeline

1 In the Timeline, select the clips or the range you want to remove.

2 Choose Edit > Delete (or press the Delete key).

   The selected clips or portions of clips are removed from the Timeline and any clips to the right of the selection ripple to close the resulting gap.

   To undo the deletion immediately, choose Edit > Undo (or press Command-Z).
**Note:** If you select an entire Timeline clip (for example, with the C key) or a range over an entire clip (for example, with the X key) and delete it, any connected clips or storylines are also deleted. If you select a partial range of a clip that includes a connected clip or storyline, the connected clip will not be deleted. Instead, the connected items are shifted to the closest primary storyline clip.

**Delete clips or ranges without affecting the total project duration and timing**
If you want to remove clips from the Timeline but still maintain the total project duration and timing, you can replace clips with gap clips. This method prevents any ripple edits.

1. Select the clips or range you want to remove.

2. Choose Edit > Replace with Gap (or press Shift-Delete).

Final Cut Pro replaces the selection in the Timeline with a gap clip.

**Note:** This method preserves connected clips. When you replace a clip with a gap clip, any connected clips will be attached to the resulting gap clip.

**Solo, disable, and enable clips**
Sometimes, it is helpful to compare how a sequence plays with and without certain clips. In Final Cut Pro, you can quickly play one clip to the exclusion of other clips. This feature, called *solo*, works by disabling all unselected clips in the Timeline. You can also disable (rather than delete) selected clips, making them invisible and silent during playback. Disabled clips do not appear in any output. You can just as easily reenable them.
**Solo selected items**
When you want to focus on a subset of clips in the Timeline in isolation, you can select the clips and solo them.

1. In the Timeline, select the clips you want to isolate.
2. Do one of the following:
   - Choose Clip > Solo (or press Option-S).
   - Click the Solo button in the upper-right corner of the Timeline.

When solo is turned on, the Solo button turns yellow, and nonsoloed clips are shown in black and white, making the soloed clips outlined in yellow easy to identify.

3. To turn off solo, click the Solo button again.

**Disable and reenable one or more clips**
1. Select one or more clips in the Timeline.
2. Choose Clip > Disable (or press V).

Disabled clips are dimmed in the Timeline and are invisible and silent during playback.

3. To reenable the disabled clips, select them in the Timeline and choose Clip > Disable (or press V).
Find a Timeline clip’s source clip
You can quickly find the source Event clip for any clip you’re using in your project in the Timeline. This is particularly useful if you want to duplicate a clip in your project or add the same clip to a different project.

Find and reveal the source Event clip for a Timeline clip
1 In the Timeline, select the clip whose source Event clip you want to locate.
2 Do one of the following:
   • Choose Clip > Reveal in Event Browser (or press Shift-F).
   • Control-click the clip and choose Reveal in Event Browser from the shortcut menu.

A selection border appears around the source clip in the Event Browser, and the playhead position in the source clip matches the playhead position in the Timeline clip.

Arrange clips in the Timeline
In Final Cut Pro, you can arrange and reorder the clips in your project however you want. If you add or move a clip in the Timeline by dragging, Final Cut Pro moves other clips to make room for it. Other reordering techniques include moving clips numerically by entering a timecode value, nudging clips with keyboard shortcuts, overwriting with the Position tool, and moving clips vertically from and to the primary storyline.

Move clips by dragging horizontally
- In the Timeline, select one or more clips and drag them to a new location in the project.
As you drag your clips, you see an outline of your selection at the new position in the Timeline. When you release the mouse button, the repositioned clip (or clips) appears at the new location. Final Cut Pro ripples clips (and any connected clips) in the Timeline to make room for the repositioned clips and to close the gap left by the clips that were repositioned. You can also drag clips vertically in and out of the primary storyline.

**Note:** This method of moving clips horizontally is the functional equivalent of a shuffle edit in Final Cut Pro 7, just easier.

**Move clips by entering a timecode value**
You can move selected clips in the Timeline by entering an amount of time you want the clips to move.

1. Select one or more clips in the Timeline.

2. Do either or both of the following:
   - To move the clips forward: Press the Plus Sign (+) key, and type a timecode duration for the move.
   - To move the clips back: Press the Hyphen (-) key, and type a timecode duration for the move.

**Note:** For more information and tips on entering timecode, see “Navigate using timecode” on page 161.
The timecode entry field (with blue numbers) appears in the Dashboard in the toolbar as you type.

3 Press Return.

The clips move forward or back by the duration you entered and overwrite any clips at the new location. If the selected clips are in a storyline, a gap clip fills in vacated parts of the storyline.

Nudge clips with keyboard shortcuts
The nudging feature in Final Cut Pro allows you to move selected items by very small amounts, such as frames or subframes (for connected audio-only clips).

1 Select one or more clips in the Timeline.

2 To nudge the clips, do any of the following:
   • To move the selection left by one frame: Press Comma (,).
   • To move the selection left by 10 frames: Press Shift-Comma (,).
   • To move the selection right by one frame: Press Period (.)
   • To move the selection right by 10 frames: Press Shift-Period (.)
If you want to nudge connected audio clips by one or more subframes, do any of the following:

- To move the selection left by one subframe: Press Option-Comma (,).
- To move the selection left by 10 subframes: Press Shift-Option-Comma (,).
- To move the selection right by one subframe: Press Option-Period (.)
- To move the selection right by 10 subframes: Press Shift-Option-Period (.)

For more information about subframes, see “View audio waveforms at the audio sample level” on page 208.

The moved clips overwrite any clips at the new location. A gap clip fills in vacated parts of the Timeline.

**Overwrite clips using the Position tool**

You can move clips by dragging them in the Timeline to overwrite other clips. This allows you to place clips precisely without causing other clips to move to make room.

1. Choose the Position tool from the Tools pop-up menu in the toolbar (or press P).

   ![Position tool icon](image)

   The pointer changes to the Position tool icon.

   **Tip:** To switch to the Position tool temporarily, hold down the P key. When you release the P key, the tool reverts to the previously active tool.
2 Select the clip you want to move.

3 Drag the clip to a new position in the Timeline.

The moved clip overwrites any clips at the new position. A gap clip fills in the vacated part of the Timeline.

*Note:* If you prefer to move clips left or right in the Timeline without leaving a gap, you may want to perform a slide edit.

To return to the Select tool (the default), choose it from the Tools pop-up menu in the toolbar (or press A).

**Drag clips from and to the primary storyline**
You can drag clips from and to the primary storyline. This technique employs ripple edits, which affect the total duration of your project. When you move a clip out of the primary storyline, it becomes either an individual connected clip or part of a connected storyline.
1 If the Select tool is not the active tool, choose it from the Tools pop-up menu in the toolbar (or press A).

2 Select one or more clips (either clips in the primary storyline or connected clips).

3 Do either of the following:
   • *To move clips out of the primary storyline:* Drag the clips from the primary storyline to their new position as connected clips (above or below the primary storyline). The subsequent clips in the primary storyline ripple left to close the gap left by the clips you moved.
• *To move clips to the primary storyline:* Drag the clips from their position as connected clips to an edit point between two clips in the primary storyline. The result is effectively an insert edit: the former connected clips are inserted in the primary storyline and subsequent clips ripple right to make room for the new clips.

![Image of video editing software interface showing a timeline with clips and edit points.](image)

**Note:** You can drag clips from and to the primary storyline as long as there are no clips connected to them. If there is a connected clip, you must first move or remove the connected clip or use the Lift from Primary Storyline or Overwrite to Primary Storyline command.

**Move clips from and to the primary storyline without rippling the project**
You can move clips from and to the primary storyline without affecting the total duration of your project.

1. Select the clips you want to move.

![Image of video editing software interface with selected clips.](image)
2 Do either of the following:
   - *To move selected clips from the primary storyline to connected clips at the same Timeline position*: Choose Edit > Lift from Primary Storyline (or press Command-Option-Up Arrow).

   ![Diagram of Lift from Primary Storyline](image)
   
   New connected clip at the same Timeline position
   
   A gap clip fills in the vacated part of the primary storyline.

   Gap clips fill in the vacated parts of the primary storyline, as needed.

   - *To move selected connected clips to the primary storyline*: Choose Edit > Overwrite to Primary Storyline (or press Command-Option-Down Arrow).

   ![Diagram of Overwrite to Primary Storyline](image)

   Depending on the amount of overlap on the connected clip, the Overwrite to Primary Storyline command either creates a split edit or overwrites any video clips at the new location and converts the audio portion of the overwritten clip to a connected clip. The Overwrite to Primary Storyline command is not available for audio-only clips.

   **Note:** The Overwrite to Primary Storyline command works on individual connected clips only. To use this command on a clip in a connected storyline, first move the clip out of the storyline.

   You can achieve the same results by dragging clips with the Position tool.
Cut and trim clips

Trimming overview
After you’ve roughly assembled your clips in chronological order in the Timeline, you begin to fine-tune the cut point (or edit point) between each pair of contiguous clips. Any time you make a clip in a project longer or shorter, you’re trimming that clip. However, trimming generally refers to precision adjustments of anywhere from one frame to several seconds. If you’re adjusting clip durations by much larger amounts, you’re still trimming, but you may not be in the fine-tuning phase of editing yet.

In Final Cut Pro, you can use a variety of techniques to trim Timeline clips and edit points, including ripple edits, roll edits, slip edits, and slide edits.

No matter how you trim or make other edits in Final Cut Pro, the underlying media is never touched. Trimmed or deleted pieces of clips are removed from your project only, not from the source clips in your Event Library or from the source media files on your hard disk.

Tip: You can see a “two-up” display in the Viewer as you trim edit points in the Timeline. For more information, see “Show detailed trimming feedback” on page 154.

Cut clips with the Blade tool
Once you’ve added clips to the Timeline, you can easily cut them to adjust their durations or to remove unwanted sections.

The most basic edit is a straight cut. The term comes from the film editing process of cutting a filmstrip with a razor and attaching a new “clip” with glue.

Each time you cut a clip in your project, it is split into two clips. You can cut one clip at a time or multiple clips at a time.
Cut a clip in the Timeline

1 Choose the Blade tool from the Tools pop-up menu in the toolbar (or press B).

The pointer changes to the Blade tool icon.

Tip: To switch to the Blade tool temporarily, hold down the B key. When you release the B key, the tool reverts to the previously active tool.

2 Move the skimmer to the frame in the clip where you want to cut, and click.

Tip: You can also cut clips while playing back your project. To cut clips on the fly, press Command-B at any time while your project plays back.
An edit point appears where you clicked, and the clip is divided into two clips.

Cut multiple clips at once
You can use the Blade command to cut primary storyline clips and connected clips simultaneously.

1 In the Timeline, select the clips you want to cut.
2 Move the skimmer to the frame where you want to cut.

3 Choose Edit > Blade (or press Command-B).
The selected clips are cut at the skimmer position.

*Note:* If you don’t make a selection, this command acts only on the clip in the primary storyline.
Extend or shorten a clip
You can trim a clip in your project by adjusting the start point or end point of the clip.

The default type of trim in Final Cut Pro is a ripple trim, which adjusts a clip’s start point or end point without leaving a gap in the Timeline. The change in the clip’s duration ripples outward, moving all subsequent clips earlier or later in the Timeline.

Similarly, if you delete a clip from the Timeline, subsequent clips ripple earlier to close the gap. Ripple edits affect the trimmed clip, the position of all subsequent clips in the Timeline, and the total duration of your project.

You can see a “two-up” display in the Viewer as you trim edit points in the Timeline. This display shows a more detailed view of each side of an edit point. For more information, see “Show detailed trimming feedback” on page 154.

Drag edit points with the Select tool
1 In the Timeline, move the pointer to the start point or the end point of the clip you want to trim.

The pointer changes from an arrow icon to a trim icon. The look of the trim icon changes to indicate whether the trim will affect the end point of the left clip or the start point of the right clip.
2 Drag the start point or the end point in the direction you want to trim the clip. As you drag, the clip shortens or lengthens. A numerical timecode field indicates the amount of time you are moving the edit point.

Any clips to the right of the edit point are rippled accordingly. When you extend a clip to its maximum length in either direction, the clip edge turns red.

**Enter a new duration for a clip using timecode**
You can change the total duration of one or more selected clips by entering a timecode value.

1 Select one or more clips in the Timeline.

2 Do one of the following:
   • Choose Modify > Change Duration (or press Control-D).
   • Double-click in the center of the Dashboard in the toolbar.

The timecode entry field appears in the Dashboard.
3 Enter a new duration for the selected clip.

Final Cut Pro moves the end point of the clip to the duration you entered, and any subsequent Timeline clips ripple accordingly.

For more information about entering timecode values, see “Navigate using timecode” on page 161.

**Note:** If you enter a duration longer than the available media in the clip, Final Cut Pro extends the duration to the maximum length of the clip.

**Trim to a selection**

1 In the Timeline, select the part of a clip that you want to keep.

![Original clip with range selection](image)

For information about making range selections, see “Select a range” on page 105.

2 Choose Edit > Trim to Selection.

Final Cut Pro trims the clip start and end points to the range selection.

![Trimmed clip](image)

The unwanted sections are removed from the clip and the project, and the subsequent clips in the project ripple accordingly.
Nudge edit points with keyboard shortcuts
You can fine-tune the start or end point of a clip using keyboard shortcuts. You can move the edit point by one or more video frames, and you can also move the edit points of connected audio clips (those not in the primary storyline) by subframes.

1 In the Timeline, select the start or end point of the clip you want to trim.

2 To move the edit point, do any of the following:
   - To move the edit point left by one frame: Press Comma (,).
   - To move the edit point left by 10 frames: Press Shift-Comma (,).
   - To move the edit point right by one frame: Press Period (.).
   - To move the edit point right by 10 frames: Press Shift-Period (.).

3 If you want to move the edit point of connected audio clips by one or more subframes, do any of the following:
   - To move the edit point left by one subframe: Press Option-Comma (,).
   - To move the edit point left by 10 subframes: Press Shift-Option-Comma (,).
   - To move the edit point right by one subframe: Press Option-Period (.).
   - To move the edit point right by 10 subframes: Press Shift-Option-Period (.).

For more information about subframes, see “View audio waveforms at the audio sample level” on page 208.

The clip is trimmed and the Timeline updates accordingly.
Move edit points to the playhead
You can adjust selected edit points in the Timeline, either as a ripple edit or a roll edit, using keyboard shortcuts.

1 In the Timeline, select the edit point you want to adjust.

![Selected end point]

*Note:* For a roll edit, select both sides of the edit point with the Trim tool.

2 Position the playhead or the skimmer at the point in the Timeline to which you want to move the edit point.

![Skimmer]

3 Choose Edit > Extend Edit (or press Shift-X).
The edit point is extended (or shortened) to the playhead or skimmer position.

![The clip’s end point is extended to the skimmer position, and subsequent clips ripple right.]

In the example above, if you selected the end point of the clip, subsequent clips in the Timeline are rippled accordingly. If you selected both sides of the edit point with the Trim tool, the right clip is shortened (with a roll edit) and no clips ripple.
**Trim edit points using timecode**

You can trim clips numerically by entering timecode values.

1. If the Select tool is not the active tool, choose it from the Tools pop-up menu in the toolbar (or press A).

2. In the Timeline, select the start point or the end point of the clip you want to trim.

3. To trim the edit point, do one of the following:
   - *To move the edit point forward:* Press the Plus Sign (+) key, type a timecode duration for the trim, and press Enter.
   - *To move the edit point back:* Press the Minus Sign (–) key, type a timecode duration for the trim, and press Enter.

   The timecode entry field (with blue numbers and the plus or minus sign) appears in the Dashboard in the toolbar as you type.

   The clip is shortened or extended by the amount of time you entered, and subsequent clips in the Timeline are rippled accordingly.

   **Note:** You cannot use this feature to extend a clip beyond its maximum duration.
For more information and tips on entering timecode, see “Navigate using timecode” on page 161.

Cut the start or end of a clip at the playhead
Some of your video clips may have sections at the beginning or the end that you don’t want to include in your project. You can easily trim off these ranges with a single command, even while playing back the project. No selections are required. This type of edit is sometimes called a top and tail edit.

1 In the Timeline, position the playhead or the skimmer on the frame at which you want to trim the clip.

2 Do one of the following:
   - To trim off the start of the clip: Choose Edit > Trim Start, or press Option-Left Bracket (\].
   - To trim off the end of the clip: Choose Edit > Trim End, or press Option-Right Bracket (\]).
The clip is trimmed to the playhead (or skimmer) position, and the Timeline updates accordingly.

![Trimmed clip](image)

In the case of connected clips or storylines, Final Cut Pro trims the selected clip. If there is no selection, Final Cut Pro trims the topmost clip.

**Make roll edits with the Trim tool**

A roll edit adjusts the start point and the end point of two adjacent clips simultaneously. If you like where two clips are placed in the Timeline, but you want to change when the cut point happens, you can use the Trim tool to roll the edit point between the two clips. No clips move in the Timeline as a result; only the edit point between the two clips moves. No other clips in the project are affected.

When you perform a roll edit, the overall duration of the project stays the same, but both clips change duration. One gets longer while the other gets shorter to compensate.

![Before & After edit](image)

In the example above, clip B gets shorter while clip C becomes longer, but the combined duration of the two clips stays the same.

You can see a “two-up” display in the Viewer as you trim edit points in the Timeline. This display shows a more detailed view of each side of an edit point. For more information, see “Show detailed trimming feedback” on page 154.
Roll an edit point

1 Choose the Trim tool from the Tools pop-up menu in the toolbar (or press T).

   ![Trim tool in the toolbar](image)

   The pointer changes to the Trim tool icon ⌦:

   **Tip:** To switch to the Trim tool temporarily, hold down the T key. When you release the T key, the tool reverts to the previously active tool.

2 In the Timeline, click the center of the edit point you want to roll so that both sides of the edit point are selected.

3 Do one of the following:
   - Drag the edit point left or right.
   - Press the Plus Sign (+) key or the Minus Sign (–) key followed by the timecode duration to add or subtract from the current edit, and press Return.

   The timecode entry field (with blue numbers) appears in the Dashboard in the toolbar as you type.

   For more information about entering timecode values, see “Navigate using timecode” on page 161.

   - Position the playhead or skimmer at a point in the Timeline to which you want to move the edit point, and choose Edit > Extend Edit (or press Shift-X).
The edit point is rolled to the new location. The combined duration of the two clips stays the same.

If you can't roll the edit point any farther and one side of the edit point appears red, you've reached the end of the media for one of the two clips.

Make slip edits with the Trim tool
Performing a slip edit doesn't change a clip's position or duration in the Timeline, but instead changes what portion of the clip's media appears in the Timeline. A slip edit allows you to change a clip's start and end points simultaneously.

Whenever you arrange clips in the Timeline so that edit points line up with musical beats or other fixed sync points in a movie, you want to keep your clips in position to maintain the alignment. These situations leave you with very little room to adjust a clip because you cannot change its duration or move it elsewhere in the Timeline. All you can do is move both the start and end points of the clip simultaneously, keeping the clip's position and duration fixed.
The portion of the clip seen in the project changes, but its position in the Timeline stays the same. Surrounding clips are not affected, and the overall duration of your project doesn’t change.

In the example above, the slip edit changes the start and end points of clip B, but not its duration or position in the Timeline. When the project plays back, a different portion of clip B’s media is shown.

**Note:** To slip a clip, it must have media handles on both sides, meaning that there must be additional media available on both the head and the tail of the clip. If you’re having trouble slipping a clip, check that the clip has media handles on both sides. You can double-click any edit point to view or adjust its media handles in the Precision Editor.

If there are no media handles available, consider using the Position tool instead. For more information about the Position tool, see “Arrange clips in the Timeline” on page 126.

For more accurate visual feedback on edits involving contiguous clips, you can turn on “Show detailed trimming feedback” in Final Cut Pro preferences. For a slip edit, this “two-up” display in the Viewer shows the start and end points of the clip you’re slipping. For more information, see “Show detailed trimming feedback” on page 154.
Slip a clip in the Timeline

1 Choose the Trim tool from the Tools pop-up menu in the toolbar (or press T).

The pointer changes to the Trim tool icon 🕳️.

**Tip:** To switch to the Trim tool temporarily, hold down the T key. When you release the T key, the tool reverts to the previously active tool.
2 Drag a clip left or right.

As you drag, a timecode field indicates the amount of time you're moving the start point and the end point. Yellow edge selections on the start point and end point indicate a slip edit.

When you release the mouse button, the slipped clip appears in the Timeline with a new start point and a new end point.

With the current selection, you can also slip the clip with keyboard shortcuts by doing either of the following:

- Nudge the start and end points (one frame or 10 frames) to the left or right.
- Enter an amount of time to slip the clip left or right.
Note: If either the start point or the end point turns red as you drag, you’ve reached the end of the available media for that side of the clip.

Make slide edits with the Trim tool
Performing a slide edit allows you to move a clip’s position in the Timeline between two other clips without creating a gap. The clip’s content and duration remain the same; only its position in the Timeline changes. When you slide a clip, the adjacent clips get longer and shorter to accommodate the change in the clip’s position. The combined duration of these three clips stays the same, and the project’s total duration remains unchanged as well.

Note: To slide a clip between two others, the preceding clip and the following clip must have media handles, additional media available beyond the edit point. You can double-click any edit point to view or adjust its media handles in the Precision Editor. If there are no media handles available, consider using the Position tool instead. For more information about the Position tool, see “Arrange clips in the Timeline” on page 126.

For more accurate visual feedback on edits involving contiguous clips, you can turn on “Show detailed trimming feedback” in Final Cut Pro preferences. For a slide edit, this “two-up” display in the Viewer shows the two edit points you are adjusting: the end point of the preceding clip and the start point of the subsequent clip. For more information, see “Show detailed trimming feedback” on page 154.
Slide a clip in the Timeline

1 Choose the Trim tool from the Tools pop-up menu in the toolbar (or press T).

The pointer changes to the Trim tool icon 📕.

Tip: To switch to the Trim tool temporarily, hold down the T key. When you release the T key, the tool reverts to the previously active tool.

2 Option-click a clip, and drag it left or right.

Yellow selections on the neighboring clips indicate a slide edit.
As you drag, a timecode field indicates the amount of time you’re moving the clip in the Timeline.

When you release the mouse button, the slide clip appears at the new position in the Timeline. The adjacent clips are trimmed to accommodate the change in the clip’s position.

With the current selection, you can also slide the clip with keyboard shortcuts by doing either of the following:

- Nudge it (one frame or 10 frames) to the left or right.
- Enter an amount of time to slide the clip left or right.

For more information, see “Arrange clips in the Timeline” on page 126.

Note: If either edit point turns red as you drag, you’ve reached the end of the available media for that side of the clip.
**Show detailed trimming feedback**
For more accurate visual feedback on edits involving contiguous or connected clips, you can turn on “Show detailed trimming feedback” in Final Cut Pro preferences. For example, for a simple ripple trim, this “two-up” display in the Viewer shows the end point of the left clip and the start point of the right clip.

This display is available for ripple, roll, slip, and slide edits as well as for trimming in the Precision Editor.

**Turn on detailed trimming feedback**
1. Choose Final Cut Pro > Preferences, or press Command-Comma (,).
2. Click Editing.
3. In the Timeline section, select the “Show detailed trimming feedback” checkbox.

The “two-up” display appears in the Viewer whenever you use a supported edit type or when trimming in the Precision Editor.

> **Tip:** You can use the Option key to change the detailed trimming feedback display on the fly. If detailed trimming feedback is enabled, press the Option key to disable it. If detailed trimming feedback is disabled, press the Option key to switch the view between the end point of the left clip and the start point of the right clip.
View and navigate

Zoom and scroll in the Timeline
Being able to see and get to any point in your project is critical to efficient editing and storytelling. There are many ways to adjust the view of the Timeline. Learning keyboard shortcuts can save you time.

Fit the entire contents of the Timeline into the available window size
Whether you’re zoomed in to a single clip or zoomed out so far that all the clips in your project appear on the left side of the Timeline, you can quickly change the view so that all the clips fill the visible part of the Timeline and no scrolling is required.

- Choose View > Zoom to Fit (or press Shift–Z).
Zoom in to and out of the Timeline using the Zoom slider

- To zoom in to the Timeline: Drag the Zoom slider to the right, or press Command–Plus Sign (+).
- To zoom out of the Timeline: Drag the Zoom slider to the left, or press Command–Minus Sign (–).

Zoom in to and out of the Timeline using the Zoom tool

1. Choose the Zoom tool from the Tools pop-up menu in the toolbar (or press Z).

   The pointer changes to the Zoom tool icon.

   Tip: To switch to the Zoom tool temporarily, hold down the Z key. When you release the Z key, the tool reverts to the previously active tool.

2. Do one of the following:
   - To zoom in to the Timeline: Click the section of the Timeline you want to zoom in to. (You can also drag over an area of the Timeline to zoom in to just that area.)
     Click multiple times to continue zooming in.
   - To zoom out of the Timeline: Option-click the section of the Timeline you want to zoom out of.
     Option-click multiple times to continue zooming out.
Scroll horizontally through a zoomed-in Timeline

1. Zoom in to the Timeline until you see a portion of the project only.
2. Do one of the following:
   - Drag the slider at the bottom of the Timeline to the left or the right.
   - Choose the Hand tool from the Tools pop-up menu in the toolbar (or press H), and drag left or right in the Timeline.

Tip: To switch to the Hand tool temporarily, hold down the H key. When you release the H key, the tool reverts to the previously active tool.

Adjust Timeline settings

In Final Cut Pro, it’s very easy to adjust the Timeline display options. For example, you can show clips with or without video filmstrips or audio waveforms. Or you can change the vertical height of the clips or the size of filmstrips or audio waveforms in relation to the video thumbnails that appear in the filmstrip of each clip in the Timeline. You can also show only the clip names.

The snapping behavior makes it easier and quicker to do things like line up a video clip with an audio clip, or align the playhead to a particular marker. When snapping is turned on, items you move in the Timeline appear to jump, or “snap,” directly to certain points in the Timeline. This can help you quickly line up edits with other items in the project.
Snapping affects the functions of many of the editing tools in Final Cut Pro, including the Select tool, the Trim tool, the Position tool, the Range Selection tool, and the Blade tool. Several elements trigger snapping in the Timeline:

- Clip boundaries (start and end points)
- The playhead and the skimmer
- Markers
- Keyframes
- Range selections

Adjust clip appearance and height

1 Click the Clip Appearance button in the lower-right corner of the Timeline.

2 In the Clip Appearance window, do any of the following:
   - To adjust how clips appear in the Timeline: Click a clip appearance button at the top.
   - To adjust the vertical height of clips in the Timeline: Drag the Clip Height slider to the left to decrease the clip height, or to the right to increase the clip height.
   - To turn connection lines on or off: Select or deselect the checkbox to turn connection lines for connected clips and storylines on or off.
   - To view clips by name: Choose Clip Names from the Show pop-up menu.
   - To view clips by role: Choose Clip Roles from the Show pop-up menu.

Enable or disable snapping

While snapping is extremely useful, it can also be a hindrance if you’re trying to move a clip only a few frames among a series of markers and clip boundaries, and you don’t want it to snap to any of these points. Fortunately, you can turn snapping on or off at any time, even while you’re dragging a clip.
Do one of the following:

- Choose View > Snapping (or press N).
  
  A checkmark indicates that snapping is on. You can press N to turn snapping on or off while you’re dragging a clip.

- Click the Snapping button in the upper-right corner of the Timeline.

When snapping is on, the Snapping button appears blue.

**Tip:** To turn snapping on or off temporarily, hold down the N key. When you release the N key, snapping reverts to the previous state.

**Navigate within your project**

The ability to jump to any point in the Timeline instantly is one of the main benefits of a nonlinear editing environment. Final Cut Pro provides a variety of quick and easy ways to navigate your project.

You can also use a text-based view of the Timeline to navigate and search your project. For more information, see “Use the Timeline Index to view, navigate, and search your project” on page 162.

You can use the J, K, and L keys to play through a project with different speeds or directions. For more information, see “Use the J, K, and L keys” on page 87.

**Navigate by skimming, clicking, or dragging**

- To skim to a frame in your project: Move the skimmer left and right over the clips in the Timeline to quickly view them in the Viewer.

- To move the playhead to a frame in your project: Move the playhead by clicking or dragging in the ruler at the top of the Timeline, or by clicking in the Timeline background.

**Tip:** To prevent the playhead from moving while you select a clip in the Timeline, press Option as you click.
Navigate frame by frame
To make it easier to find specific frames in a clip, you can step through the filmstrip frame by frame, rather than skimming it.

1. In the Timeline or the Event Browser, move your pointer over a filmstrip and click.
2. Do either of the following:
   - To move backward in one-frame increments: Choose Mark > Previous > Frame (or press the Left Arrow key), or click the Previous Frame button below the Viewer.
   - To move forward in one-frame increments: Choose Mark > Next > Frame (or press the Right Arrow key), or click the Next Frame button below the Viewer.

Navigate by subframe
You can navigate clips by subframe. A subframe has 1/80 the duration of a video frame and is a more precise unit of reference when viewing or editing audio waveforms that are zoomed in to the sample level.

Note: You can’t make edits to video at the subframe level.

1. In the Timeline or the Event Browser, move your pointer over a clip and click.
2. Do either of the following:
   - To move backward in one-subframe increments: Press Command-Left Arrow.
   - To move forward in one-subframe increments: Press Command-Right Arrow.

Note: You can change the time display in the Dashboard to show subframes. For more information, see “Editing preferences” on page 497.

Navigate by jumping
Use the following techniques to move the playhead quickly from point to point in the Timeline.

- To go to the next edit point: Choose Mark > Next > Edit (or press the Down Arrow key), or click the Next Edit button below the Viewer.
- To go to the previous edit point: Choose Mark > Previous > Edit (or press the Up Arrow key), or click the Previous Edit button below the Viewer.
- To go to the start of the project: Choose Mark > Go to > Beginning (or press the Home key).
- To go to the end of the project: Choose Mark > Go to > End (or press the End key).
- To go to the next marker: Choose Mark > Next > Marker, or press Control–Apostrophe (’).
- To go to the previous marker: Choose Mark > Previous > Marker, or press Control–Semicolon (;).

For more information about markers, see “Markers overview” on page 166.
Navigate using timecode

Timecode is a signal recorded with your video that uniquely identifies each video frame. When you play a clip from the Event Browser, its timecode signal appears in the Dashboard, in the center of the Final Cut Pro toolbar, using this format:

![Timecode](01:32:15:28)

- **Hours**
- **Minutes**
- **Seconds**
- **Frames**

Timecode supports a variety of functions in Final Cut Pro, including Timeline playback, synchronizing video and audio clip items, and adding, trimming, and moving clips. In addition, timecode allows you to navigate through projects in the Timeline and see the duration of clips, range selections, and projects.

Navigate by entering timecode

To move the playhead to a new Timeline location, do either of the following:

- **To move the playhead to a specific Timeline location:** Click once in the center of the Dashboard (or press Control-P), enter the new timecode value, and press Return.

  For example, to move the playhead to 01:40:31:03, press Control-P, and then enter “1403103” and press Return.

- **To move the playhead by a timecode duration:** Make sure no clips are selected, and press the Plus Sign (+) or Minus Sign (–) key, enter the number of frames, seconds, or minutes you want to move the playhead, and press Return.

  For example, if you type “+1612” and press Return, the playhead moves ahead 16 seconds and 12 frames.

  ![Timecode](01:40:31:03)

  ![Timecode](+00:00:16:12)

The new timecode values appear in the Dashboard as you enter them. When you press Return, the playhead moves to the new Timeline location.
Here are some tips for entering timecode values:

- You don’t have to enter the separator characters (colons). Final Cut Pro adds them automatically after each set of two digits. For example, if you enter “01221419,” Final Cut Pro interprets it as 01:22:14:19 (1 hour, 22 minutes, 14 seconds, and 19 frames).

- If the leftmost fields are zeroes, you don’t have to enter them. For example, if you enter “1419,” Final Cut Pro interprets it as 00:00:14:19. If you enter “253407,” Final Cut Pro interprets it as 00:25:34:07.

- If the rightmost fields are zeroes, you can use periods instead. For example, to move to timecode 00:00:03:00, type “3.” (3 and a period). To move to 03:00:00:00, type “3…” (3 and three periods). Instead of a period, you can also use a comma, plus sign, minus sign, colon, semicolon, or ampersand.

Note: You can change the time display in the Dashboard to show timecode, timecode and subframes, just frames, or just seconds. For more information, see “Editing preferences” on page 497.

Use the Timeline Index to view, navigate, and search your project

The Timeline Index provides a text-based view of the clips and tags (various kinds of markers and keywords) used in your project in the Timeline. You can easily filter the Timeline Index to show only the items you want to see.

You can also use the Timeline Index to navigate in the Timeline. The Timeline Index playhead appears in the list of items. When you play a project, the playhead moves down the list of items in the Timeline Index. When you select an item in the Timeline Index, the playhead automatically moves to the beginning of the item.

Show or hide the Timeline Index

- Click the Timeline Index button in the lower-left corner of the Final Cut Pro main window (or press Command-Shift-2).
The Timeline Index appears in the lower-left corner of the Final Cut Pro window.

The Timeline Index playhead moves in tandem with the Timeline playhead.

**View a list of items in the Timeline Index**

1. If the Timeline Index is not already open, click the Timeline Index button in the lower-left corner of the Final Cut Pro main window (or press Command-Shift-2).

2. Do any of the following:
   - To view a list of the clips used in the Timeline, ordered chronologically: Click the Clips button at the top.

You can rename clips; see a list of clips by timecode in the Position column; view, reassign, and edit roles in the Roles column; or view and add notes in the Notes column.
You can specify which columns are displayed by Control-clicking a column heading and choosing an option from the shortcut menu.

![Column heading shortcut menu]

You can specify which items are displayed by clicking the All, Video, Audio, or Titles button at the bottom of the Timeline Index.

![Timeline Index buttons]

- To view a list of all the tags on the clips in the Timeline, ordered chronologically: Click the Tags button at the top.

![Tags button]

All of the tags are shown by default. You can specify which items are displayed by clicking a button at the bottom of the Timeline Index. You can show markers, keywords, analysis keywords, incomplete to-do items, and completed to-do items.

![Timeline Index buttons]

**Note:** To-do items are types of markers.
• To view a list of clips in the Timeline, organized by role: Click the Roles button at the top.

![Roles button]

Select a role name in the list to highlight all clips in the Timeline with that role assigned. Select or deselect the checkboxes next to the roles you want to turn on or off in the Timeline. When a checkbox is deselected, you can’t see or hear clips with that assigned role when you play back your project. For more information, see “View clips by role in the Timeline” on page 347.

Change a To Do marker

In the Timeline Index, you can quickly change a To Do marker’s state from incomplete to completed.

1 If the Timeline Index is not already open, click the Timeline Index button in the lower-left corner of the Final Cut Pro main window (or press Command-Shift-2).

![Timeline Index button]

2 Click the checkbox for the To Do marker.

• If the marker was red (an incomplete to-do item), it turns green (completed).
• If the marker was green (a completed to-do item), it turns red (incomplete).
Search for items in the Timeline Index

1. If the Timeline Index is not already open, click the Timeline Index button in the lower-left corner of the Final Cut Pro main window (or press Command-Shift-2).

2. Click Clips to search for clips, or click Tags to search for tags.

3. Enter a term in the search field at the top of the Timeline Index.

   You can search for clips, keywords, and markers (including to-do items).

   ▶ Tip: With the Timeline active, choose Edit > Find (or press Command-F). The Timeline Index opens with the search field active and ready for your search term.

Add and remove markers

Markers overview

Markers are reference points you can place within clips to locate, identify, and annotate specific frames. In editing, markers are particularly useful for synchronizing two or more clips at a specific point. For example, you can use a marker to label the frame where a door slams and then snap a sound effect to that marker. You can use markers to flag a specific location in a clip with editing notes or other descriptive information. You can also use markers for task management. Markers are classified as informational (blue markers), to-do items (red markers), and completed to-do items (green markers).

You work with markers in the same way for clips in the Event Browser and clips in the Timeline.
Add and remove markers
It's easy to add and remove markers. If you add markers to clips in the Event Browser, they are visible in both filmstrip view and list view. When you add clips with markers to the Timeline, the markers are visible in both the Timeline and the Timeline Index.

Add a marker to a clip in the Event Browser or in the Timeline
1 To specify where you want to add a marker, do one of the following:
   • Skim to the location.
   • Play the clip, and when the playhead reaches the location where you want to add a marker, press the Space bar to stop playback.

   For more information about positioning the skimmer and the playhead, see “Navigate within your project” on page 159.

2 Do one of the following:
   • To add a marker: Choose Mark > Markers > Add Marker (or press M).
   • To add a marker and show the marker’s information: Choose Mark > Markers > Add Marker and Modify (or press Option-M).
     Adding a marker this way automatically shows the marker’s information.

   Tip: To add markers on the fly, just press M while playing a clip.

   The marker appears at the top of the clip in the Event Browser or the Timeline.
Note: Event clip markers also appear in the list view filmstrip and text list.

Remove a marker
Do any of the following:

- Navigate to a marker and choose Mark > Markers > Delete Marker (or press Control-M).
- Select one or more clips, then choose Mark > Markers > Delete Markers in Selection.
- Double-click a marker to open the Marker window, and click the Delete button.

Edit and move markers
You can view and edit marker information and you can move markers within a clip or to different clips.

View and change a marker’s information
1 To view a marker’s information, do one of the following:
   • Select the marker and choose Mark > Markers > Modify Marker (or press Shift-M).
   • Control-click the marker and choose Modify Marker from the shortcut menu.
   • Double-click the marker.

The marker’s information appears in the Marker window above the marker.
2 To change the marker’s information, do any of the following:

- To change the descriptive text for the marker: Type the new text in the text field. (The text is automatically selected when the Marker window appears, so you don’t need to select it.)
- To make the marker a to-do item: Click the Make To Do Item button. The marker turns red.
- To indicate that a to-do item is completed: Select the Completed checkbox. The marker turns green.

3 Click Done.

Move or copy a marker
You can move or copy markers with the familiar Mac commands Cut, Copy, and Paste.

1 Control-click the marker you want to move or copy, and choose an option from the shortcut menu.

- To move the marker: Choose Cut Marker.
- To copy the marker: Choose Copy Marker.

2 Position the skimmer or the playhead where you want to move or copy the marker.

3 Choose Edit > Paste (or press Command-V).

The marker appears at the new location.

Nudge a marker one frame at a time

1 Click a marker to select it.

2 Do one of the following:

- To nudge the marker one frame to the right: Choose Mark > Markers > Nudge Marker Right, or press Control-Period (.)
- To nudge the marker one frame to the left: Choose Mark > Markers > Nudge Marker Left, or press Control-Comma (,).
Jump between markers
You can move quickly from marker to marker in the Timeline or the Event Browser.

Move between markers
Do either of the following:
- *To go to the next marker:* Choose Mark > Next > Marker, or press Control-Apostrophe (').
- *To go to the previous marker:* Choose Mark > Previous > Marker, or press Control-Semicolon (;).

Correct excessive shake and rolling shutter issues
You can smooth a clip’s shaky footage by correcting the stabilization, rolling shutter, or both.

The stabilization feature in Final Cut Pro reduces the camera motion in your video so that shaky parts can be played back more smoothly. And, at any time, you can turn off stabilization for any clip so that it plays as originally recorded.

Many camcorders and still cameras include CMOS image sensors that expose the picture they’re recording progressively, instead of all at once. As a result, if the camera moves a lot during recording, or if the camera is recording fast motion, image distortion can occur. This causes the picture to appear wobbly or skewed. Final Cut Pro has a rolling shutter feature that can reduce this motion distortion.

Fix a clip with excessive shake or rolling shutter distortion
1 If the clip is not already in your project, add it to the Timeline and select it.

*Note:* These operations act on whole clip selections, not on range selections. To get the highest-quality and fastest results, isolate the problem section by cutting the clip with the Blade tool in the Timeline. Then apply the correction to just the video footage that needs correcting.

2 To open the Video inspector, click the Inspector button in the toolbar (shown below), and click the Video button at the top of the pane that appears.
3 In the Video inspector, do either of the following:
   • To reduce the shake: Select the Stabilization checkbox.
   • To reduce rolling shutter distortion: Select the Rolling Shutter checkbox.
     When you turn on Stabilization or Rolling Shutter, its checkbox turns blue.

4 To view the fix, play the clip in the Timeline.
   You can refine the corrections by adjusting the Stabilization controls or changing the Rolling Shutter Amount setting.
Audio overview

Final Cut Pro has many features designed to make processing and editing audio easier. For example, you can use Final Cut Pro to analyze and automatically enhance audio to address problems such as noise or hum, add effects to your clips, synchronize video and audio clips automatically, and match audio between two clips.

This chapter includes information about some frequently used audio tasks, including the following:

- Adjust volume: Quickly adjust a clip’s volume directly in the Timeline or in the Audio inspector. See “Adjust volume” on page 192.
- Pan audio: Take advantage of built-in pan presets for both stereo and surround sound. See “Pan audio” on page 201.
- Create fades: Fade clips in or out with easy-to-use fade handles. See “Fade audio in or out” on page 197.
- Add audio effects: Add Audio Units effects, Logic Effects, or custom effects included with Final Cut Pro, such as reverb, to clips. See “Add audio effects” on page 175.
- Add keyframes to automate volume and effects: Vary volume or effect settings as a clip plays. See “Adjust audio effects using keyframes” on page 181.

You use the same tools used for video editing when you edit audio clips in Final Cut Pro. The following editing features are covered elsewhere in Final Cut Pro Help:

- Change edit mode: Set the edit mode for a clip to video only or audio only. See “Add clips using video-only or audio-only mode” on page 122.
- Add markers to clips: Add markers to mark specific reference points within an audio clip. For more information, see “Markers overview” on page 166.
- Trim audio: Make precision edits to the audio waveform—for example, to take out an unwanted sound in the recording. See “Trimming overview” on page 134.
- Add audio crossfades: Create a smooth transition when connecting two separate audio waveforms. See “Add transitions to your project” on page 221.
• *Use compound clips:* Compound clips let you combine any video or audio clips into a single compound clip. From an audio standpoint, compound clips let you apply the same audio effect or enhancement to a group of clips, similar to applying an effect or adjustment to the overall mix. See “Compound clips overview” on page 285.

• *Export audio:* You can export your project as an audio file in either mono, stereo, or surround sound. You can also export media by role. See “Export your project as media files” on page 448.

**Add audio**

**Add music and sound**
You can add music and sound files directly to your project from your iTunes library or other sources.

Final Cut Pro also includes a number of built-in Foley and other sound effects that you can insert as connected audio clips.

If you have a clip that contains both audio and video, you can change the edit mode to audio only to insert only the audio portion of the clip.

**Add music and sound to a project in the Timeline**

1 Click the Music and Sound button in the toolbar.

2 In the Music and Sound Browser, choose a source folder from the pop-up menu at the top. For example, choose iTunes to browse your iTunes collection.

> **Tip:** If the folder you're looking for doesn't appear, you can add it to the source list by dragging it from the Finder or desktop to the Music and Sound Browser.

3 In the sound list that appears, find the sound or music you want:

   • *To search for an item:* Type text in the search field. To filter your search, click the Filter button, and choose a filter.

   • *To preview an item:* Double-click the item, or select the item and click the Play button.

   • *To select more than one item:* Command-click each item.

4 Drag the sound file or files to the Timeline.
Record audio
You can record audio directly in Final Cut Pro from input sources such as built-in and external microphones. The recorded audio file appears both in the Event Browser and as a connected clip in the Timeline.

This function is particularly useful for recording voiceover narration.

Record live audio
1 Position the playhead where you want to start recording in the Timeline.
2 Choose Window > Record Audio.

3 If necessary, adjust the input parameters by doing any of the following:
   • To change where the recording is saved: Choose an Event folder from the Destination pop-up menu.
   • To change the input device or number of input channels (mono or stereo): Choose an option from the Input Device pop-up menu.
   • To adjust the input level of the microphone: Drag the Gain slider right to increase the input level, or left to decrease it, using the Audio meters to view and correct audio levels.

4 If necessary, adjust the output parameters by doing any of the following:
   • To hear output while recording: Select the Monitor checkbox.
     Note: If both input and output sources are near each other (such as the built-in microphone and built-in speakers), you may experience feedback.
   • To change the output device or number of output channels (mono or stereo): Choose an option from the Monitor pop-up menu.
   • To adjust the output level: Drag the Gain slider right to increase the output level, or left to decrease it.
5 To start recording, click the Record button.
6 To stop recording, click the Record button again (or press the Space bar).

Your audio recordings are attached to the primary storyline at the playhead position.

---

**Add and adjust audio effects**

**Add audio effects**

In addition to the built-in audio enhancement features of Final Cut Pro, you can take advantage of 64-bit Mac OS X built-in and third-party Audio Units (AU) effects for your audio processing tasks.

Final Cut Pro also comes with an extensive range of custom audio effects and professional Logic Effects, which are digital signal processing (DSP) effects and processors that are used to color or tonally shape existing audio recordings and audio sources—in real time.

Some of the most common processing options include noise reduction, pitch correction, EQs, dynamic processors, and reverbs. Further advanced features include delays, modulations, distortions, bass enhancement, and time-altering processors and utilities. Some custom effects included with Final Cut Pro combine multiple effects to create a particular sound environment, such as a cathedral.

You can add effects to individual clips or to a compound clip. Once you add an effect, you can adjust its settings using the Audio inspector.
Add audio effects to a clip
1 Click the Effects button in the toolbar.

2 In the Effects Browser, select an audio effect, and do any of the following to help you make the selection:
   - To preview what the effect sounds like using the audio from the currently selected Timeline clip: Move the pointer over the audio effect thumbnails.
   - To preview changing the effect’s primary control: Hold down the Option key while moving the pointer over an audio effect thumbnail.
   - To filter the list of effects that appear: Type text in the Effects Browser search field.

3 Do one of the following:
   - Drag the effect to an audio clip (or a video clip with audio) in the Timeline.
   - Double-click the effect icon to apply it to the selected clip.

The effect appears in the Effects section of the Audio inspector and in the Audio Animation Editor. You can now adjust the effect.

Turn off a clip effect
After you apply an audio effect to a clip, you can turn off the effect (but retain its settings) in the Audio inspector or the Audio Animation Editor.

1 Select the clip with the effect in the Timeline.

2 Do one of the following:
   - In the Effects section of the Audio inspector, select the effect and click its blue checkbox.
   - In the Audio Animation Editor, select the effect and click its green checkbox.

Remove a clip effect
After you apply an audio effect to a clip, you can remove the effect from the clip in the Audio inspector or the Audio Animation Editor.

1 Select the clip with the effect in the Timeline.

2 Do one of the following:
   - In the Effects section of the Audio inspector, select the effect and press Delete.
   - In the Audio Animation Editor, select the effect and press Delete.
Change the order of effects
After you apply audio effects to a clip, you can change the order in which they appear in the Audio inspector or the Audio Animation Editor.

1 In the Timeline, select a clip for which you’ve added effects.
2 Do one of the following:
   - In the Effects section of the Audio inspector, drag an effect up or down.
   - In the Audio Animation Editor, drag an effect up or down.

Transfer effects to another clip
You can transfer effects and their settings from one clip to another. This can be especially useful if you’ve made adjustments to effects in a clip that you’d like to preserve and use with other clips.

1 Select a clip in the Timeline, and choose Edit > Copy (or press Command-C).
2 Choose the clip or clips to which you want to apply the effects, and choose Edit > Paste Effects (or press Command-Option-V).

   If a clip has more than one effect applied to it, all of the effects and their settings are transferred to the other clip.

   For more information about using the Logic Effects that are included with Final Cut Pro, see the Final Cut Pro X Logic Effects Reference at http://help.apple.com/finalcutpro-logiceffects.

Adjust audio effects
You can adjust an effect’s parameters using controls in the Audio inspector or the effect’s window.

   If you’re using Audio Units effects or Logic Effects, you can show an expanded interface by opening the effect’s window.

   For more information about using the Logic Effects that are included with Final Cut Pro, see the Final Cut Pro X Logic Effects Reference at http://help.apple.com/finalcutpro-logiceffects.
Adjust an audio effect

1 In the Timeline, select the clip with the effect you want to adjust.

2 Locate the effect in the Effects section of the Audio inspector.

3 To see an effect’s parameters, do one of the following:
   - Click the Controls button (to the right of the effect’s name) to show a larger window with advanced controls.
   - Click the disclosure triangle next to Parameters to show controls in the Audio inspector.

   Tip: You can adjust effects over time using keyframes in the Audio inspector or in the Audio Animation Editor.

4 Select effect parameters and adjust their settings as needed. You can preview your adjustments by using the skimmer or playing the clip in the Timeline.

To return the effect’s values to their default settings, click the effect’s Reset button.

Use effect presets
Many Audio Units and Logic effects include built-in presets that are tailored for specific settings or environments, such as reverb presets that simulate the acoustics of a small room or a large cathedral. Presets make it easy to preview and apply effects quickly.
1 Locate the effect in the Effects section of the Audio inspector.

2 Choose a preset from the Preset pop-up menu.

You can preview your presets by using the skimmer or playing the clip in the Timeline. To return the effect to its default settings, choose Default from the Preset pop-up menu.

**Edit and save custom presets**
You can edit preset parameters by adjusting the effect's controls. If you want to keep your changes, you can save them as a custom preset.

1 Locate the effect in the Effects section of the Audio inspector.

2 Choose a preset from the Preset pop-up menu.

3 To see an effect’s parameters, do one of the following:
   - Click the Controls button (to the right of the effect’s name) to show a larger window with advanced controls.
   - Click the disclosure triangle next to Parameters to show controls in the Audio inspector.
4 Select effect parameters and adjust their settings as needed. You can preview your adjustments by using the skimmer or playing the clip in the Timeline.

When you adjust a preset’s parameters, the Preset pop-up menu indicates that the preset has been edited.

5 To save an edited preset, choose Save Preset from the Preset pop-up menu, and type a name for the new preset.

Saved presets appear in the Preset pop-up menu.

To return the effect to its default settings, choose Default from the Preset pop-up menu.
Delete custom presets

1. Locate the effect in the Effects section of the Audio inspector.

2. Choose Reveal User Presets in Finder from the Preset pop-up menu.

3. Select the preset or presets you want to delete in the Finder window, and drag them to the Trash.

   After a custom preset has been deleted, it no longer appears in the Preset pop-up menu.

Adjust audio effects using keyframes

With Final Cut Pro, you can use keyframes to create simple changes to audio over time, such as fading the volume or an effect in or out in the middle of a clip.

You place keyframes at specific points in a clip to change the parameter value of an audio enhancement or effect at those points. For example, you can keyframe specific points for volume or for an effect such as reverb or distortion.

You can set keyframes to adjust a clip's volume directly in the Timeline or in the Audio inspector. To see keyframes in the Timeline for all other effects, you need to display the Audio Animation Editor.

For information about keyframes for video clips, see “Adjust video effects using keyframes” on page 271.

Add keyframes

1. Select the clip in the Timeline.

   If you’re adding keyframes for volume adjustment only, go to step 5.
2 Do one of the following:
   - Choose Clip > Show Audio Animation (or press Control-A).
   - Click the upper-left corner of a clip to open the Adjustments pop-up menu, and choose Show Audio Animation.

Each effect in the Audio Animation Editor has a separate area for adding keyframes.

Some effects have more than one parameter and allow you to add keyframes to individual parameters separately. They appear in the Audio Animation Editor with a triangle next to the effect’s name or in the Audio inspector as additional parameter controls.

3 Select the effect for which you want to add keyframes in either the Audio Animation Editor or the Effects section of the Audio inspector.
4 Do one of the following:
   - To see expanded parameters in the Audio Animation Editor: Click the triangle to choose an individual parameter from the pop-up menu, or choose All to see all keyframes.
   - To see expanded parameters in the Audio inspector: Click the disclosure triangle next to Parameters for the effect.

5 Do one of the following for each effect parameter:
   - In the Audio Animation Editor (or the audio clip for volume only): Option-click (or press Option-K) at a point on the horizontal effect control where you want to add a keyframe.
     Keyframes for volume adjustment appear as white diamonds.

For effects with more than one parameter, keyframes for the selected parameter appear as white diamonds, while keyframes for other parameters appear gray.
Keyframes appear as white diamonds for all parameters when you choose All from the effect pop-up menu. Double diamonds indicate that you added a keyframe for more than one parameter at that point.

In the Audio inspector:

- Position the playhead in the Timeline at the point where you want to add a keyframe, and click the Keyframe button (or press Option-K).

Once you add a keyframe, the Keyframe button changes to yellow, indicating that the playhead currently sits on this keyframe.

When you move the playhead in the Timeline, arrows appear next to the Keyframe button in the Audio inspector to indicate which side of the playhead has keyframes. To go to the previous keyframe, click the left arrow or press Option-Semicolon (;). To go to the next keyframe, click the right arrow or press Option-Apostrophe (‘).
6 Add keyframes as needed.

Tip: After you’ve added one keyframe, you can add another automatically by moving the playhead in the Timeline and then adjusting the effect parameter (or the Volume slider when keyframing volume) in the Audio inspector.

Add keyframes automatically across a selected area
For volume adjustments to a clip in the Timeline, you can use the Range Selection tool to add keyframes automatically across a selected range.

If an effect appears in the Audio Animation Editor with a disclosure button, you can use either the Select or Range Selection tool to add keyframes across a selected area.

1 Select the clip in the Timeline.
If you’re adding keyframes for volume adjustment only, go to step 4.

2 Do one of the following:
   • Choose Clip > Show Audio Animation (or press Control-A).
   • Click the upper-left corner of a clip to open the Adjustments pop-up menu, and choose Show Audio Animation.

3 Select an effect, and click the disclosure button to expand it in the Audio Animation Editor.
In the Timeline, do one of the following:

- If you’re adjusting volume only: Choose Range Selection from the Tools pop-up menu in the toolbar (or press R).
  
  The pointer changes to the Range Selection tool icon 🔄.

- If you’re adjusting an effect in the Audio Animation Editor: Choose either Select or Range Selection from the Tools pop-up menu in the toolbar (or press A for Select, or R for Range Selection).

5 Drag across the area where you want to adjust the volume or effect.
6 Adjust the volume or effect within the range by dragging the effect’s horizontal control up or down.

Keyframes are automatically created along the adjustment points within the range.
Adjust keyframes in the Audio Animation Editor
You can move keyframes left or right in the Audio Animation Editor. If an effect appears with a disclosure button, you can expand the effect view and move keyframes up or down to change the parameter value.

1. Select a keyframe.
2. Do one of the following:
   - To change its position in the Audio Animation Editor, drag a keyframe left or right. As you drag, the timecode value appears.
   - If an effect appears with a disclosure button, click the button (or double-click the effect) to expand the effect view.

With the effect view expanded, you can drag the keyframe up or down to change the effect’s parameter value.
Tip: To adjust values with greater precision, hold down the Command key while dragging the keyframe up or down.

To add another keyframe, Option-click (or press Option-K) at a point on the effect control where you want to add the keyframe. To add a keyframe and change the effect’s parameter value at the same time, Option-click while dragging the effect control up or down.

Adjust keyframes in the Audio inspector
For many effects, you adjust the parameter value of individual keyframes using the Audio inspector.

1. Select a keyframe or position the playhead on a keyframe, and adjust the parameter value in the Audio inspector.

2. To change the value at the next keyframe, go to the next keyframe and adjust the value again.

Adjust all keyframes at once in the Audio Animation Editor
- Hold down the Command and Option keys, and drag either a keyframe or the effect control up or down.
All keyframes are adjusted by the same amount, preserving the original shape created by any keyframe adjustments.

View only one effect at a time in the Audio Animation Editor
You can collapse the Audio Animation Editor to view only one effect at a time. This can be useful if you have multiple effects applied to a clip and want to preserve screen space.

1. Choose Clip > Solo Animation (or press Shift-Control-V).
2. In the Audio Animation Editor, click the triangle next to the displayed effect’s name to choose an effect from the pop-up menu.

*Note:* When Solo Animation is turned on, you can’t delete effects from the Audio Animation Editor.

To turn off Solo Animation, choose Clip > Solo Animation (or press Shift-Control-V).
Delete keyframes
Do one of the following:

- Select a keyframe in the Audio Animation Editor, and press the Delete key.
- Navigate to a keyframe in the Audio inspector, and click the Keyframe button.

Hide audio animation
1 Select the clip in the Timeline.
2 Do one of the following:
   - Choose Clip > Hide Audio Animation (or press Control-A).
   - Click the close button in the upper-left corner of the Audio Animation Editor.
   - Click the upper-left corner of a clip to open the Adjustments pop-up menu, and choose Hide Audio Animation.
Adjust and enhance audio

Adjust volume
You can adjust the volume levels of audio clips from the Event Browser, the Timeline, the Audio inspector, or the Modify menu. Volume adjustments you make in the Audio inspector or from the Modify menu are applied to the entire selection. To make more precise adjustments, you can create keyframes in the clip, and then make adjustments to points between keyframes. See “Adjust audio effects using keyframes” on page 181.

You can make sure the volume doesn’t exceed peak levels, which may result in audible distortion, by using the Audio meters.

Adjust volume in the Timeline
- Drag the volume control (the horizontal line across the audio waveform) up or down.

As you drag, the level reading in dB appears, and the waveform changes shape to reflect your adjustments.

If you adjust the volume between two keyframes, the volume line slopes to show the change in volume between the keyframes.

Adjust volume from the Modify menu or the keyboard
1 Select one or more audio clips or video clips with audio in the Timeline.
2 Choose Modify > Volume, and choose Up or Down, or press Control-Equal Sign (=) or Control-Hyphen (-).

The volume is adjusted in +1 or –1 dB increments. If multiple clips are selected, the volume is adjusted for all clips.

Adjust volume in the Audio inspector
1 Select one or more audio clips or video clips with audio in the Event Browser or the Timeline.
2 In the Audio inspector, do one of the following:
   • Enter a value in the Volume field.
     If multiple clips are selected, the volume for all clips is set to the value you entered.
   • Drag the Volume slider right to increase the volume, or left to decrease it.
     If multiple clips are selected, the volume for all clips is adjusted relative to each clip’s original volume.

Adjust volume automatically across a selected area
For volume adjustments of a clip in the Timeline, you can use the Range Selection tool to add keyframes automatically across a selected range.

1 Select the clip in the Timeline.
2 Choose Range Selection from the Tools pop-up menu in the toolbar (or press R).

The pointer changes to the Range Selection tool icon 🔄.
3 Drag across the area where you want to adjust the volume.
4 Adjust the volume within the range by dragging the horizontal control up or down.
   Keyframes are automatically created along the adjustment points within the range.
Reset all volume adjustments
1 Select an audio clip or video clip with audio in the Event Browser or the Timeline.
2 Click the Reset button in the Volume and Pan section of the Audio inspector.

Enhance audio
Final Cut Pro includes several powerful tools for both analyzing and enhancing the audio portion of clips, including:

- **Loudness**: Improves the main audio signal and makes it more uniform.
- **Background Noise Removal**: Reduces background noise.
- **Hum Removal**: Reduces common electrical hum noise at either 50 or 60 Hz.

You can analyze audio and adjust loudness, background noise, and hum using the Audio Enhancements inspector. You can also analyze and fix audio problems when you import a clip.

The Audio Enhancements section of the Audio inspector also includes:

- **Equalization**: Enhances the high-end (treble), midrange, or low-end (bass) frequencies.

All enhancements are designed to correct most common audio problems automatically or with minor adjustments.

**Note**: When you import a clip, the analyze and fix audio function only corrects severe audio problems. If the clip contains moderate problems, these appear in yellow next to Audio Analysis in the Audio Enhancements section of the Audio inspector after the clip is imported. To correct these, you need to automatically enhance audio in the Audio Enhancements inspector.

Analyze audio
1 Select an audio clip or video clip with audio in the Timeline.
2 To analyze the audio, do one of the following:
   - Choose Window > Show Audio Enhancements (or press Command-8).
   - Click the upper-left corner of a clip to open the Adjustments pop-up menu, and choose Audio Enhancements.
   - Choose Show Audio Enhancements from the Enhancements pop-up menu in the toolbar.
In the Audio inspector, click the Audio Enhancements Inspector button next to Audio Analysis in the Audio Enhancements section. (The button changes color if any adjustments have been made.)

The Audio Enhancements inspector appears. After analysis, indicators appear next to each enhancement to show results:

- A red sign indicates severe problems.
- A yellow warning triangle indicates potential problems.
- A green checkmark indicates OK.

3 To close the Audio Enhancements inspector, click the back button.

You can automatically or manually change enhancement settings to correct any problems.

**Automatically enhance audio**

You can automatically enhance audio to analyze for and correct loudness, background noise, and hum.

1 Select an audio clip or video clip with audio in the Timeline.

2 Do one of the following:
   - Choose Modify > Auto Enhance Audio.
   - Choose Auto Enhance Audio from the Enhancements pop-up menu in the toolbar.
   - Click the Auto Enhance button at the bottom of the Audio Enhancements inspector.

3 To close the Audio Enhancements inspector, click the back button.

After analysis, a green checkmark next to an enhancement indicates that the clip was analyzed for that enhancement. Details appear if a correction was automatically applied.

A blue checkbox appears next to each enhancement that was turned on to apply a correction. Deselect the checkbox to turn off an enhancement.
Apply enhancements manually
After you analyze audio, you can adjust the enhancements manually.

1 Select an audio clip or video clip with audio in the Timeline.

2 To show the Audio Enhancements inspector, do one of the following:
   - Choose Window > Show Audio Enhancements (or press Command-8).
   - Click the upper-left corner of a clip to open the Adjustments pop-up menu, and choose Audio Enhancement.
   - Choose Show Audio Enhancements from the Enhancements pop-up menu in the toolbar.

3 To turn on an enhancement, click its icon or select its checkbox (when the enhancement is turned on, its checkbox is blue).

4 If necessary, do any of the following:
   - To change Loudness settings: Drag the Amount and Uniformity percentage sliders. The Amount slider increases or decreases the overall loudness (compression) of the clip, while the Uniformity slider increases or decreases the dynamic range affected.
   - To change the percentage of Background Noise Removal: Drag the Amount slider.
   - To remove hum: Select either 50 Hz or 60 Hz for Hum Removal.
To close the Audio Enhancements inspector, click the back button.

**Adjust equalization**

1. Select the clip in the Timeline.
2. In the Audio Enhancements section of the Audio inspector, choose an Equalization preset from the Equalization pop-up menu, or click the Controls button to make manual adjustments.

If you want a clip to sound like another clip, you can match the audio.

**Fade audio in or out**

There are several ways to create fade-ins or fade-outs to the audio portion of clips in Final Cut Pro:

- **Automatic crossfades during transitions:** When you add a transition to a video clip with attached audio, Final Cut Pro automatically applies a crossfade transition to the audio. If the audio is detached or expanded from the video, the audio is not affected by the video transition. See “Add transitions to your project” on page 221.

- **Crossfades:** When trimming the audio waveform in clips, you can apply a crossfade to the edit point. See “Trimming overview” on page 134.

- **Fade handles:** You can quickly create fade-ins and fade-outs to the audio portion of clips in the Timeline by using fade handles, which appear when you place the pointer over the top-left or top-right corner of the audio waveform.

You can also change the fade’s shape by choosing one of several predefined options. Changing the fade shape changes the sound of the fade.

**Note:** Fades created using fade handles override crossfades created by a transition.
Create a fade using fade handles

- Drag the fade handle to the point in the clip where you want the fade to begin or end.

Fade handles from the beginning of a clip create a fade-in, while fade handles at the end of a clip create a fade-out.

Fades complement any volume adjustments you’ve already made to a clip. For example, if you previously adjusted the volume lower at the beginning of a clip, the fade-in increases the volume from silence (–∞ dB) to the level you’ve already specified.

Create a crossfade manually using fade handles

1. Select two adjacent clips in the Timeline, and choose Clip > Expand Audio/Video (or press Control-S).

The clips appear expanded.
2 Drag the end point of the first clip to the right and the start point of the second clip to the left so that the audio portions of the clips overlap.

*Note:* Make sure to adjust the audio overlap to the length you want.

3 Drag the fade handles of each clip to the points where you want the fade to begin and end.

To change the fade shape for each clip, follow the instructions immediately below.
Change the fade shape when using fade handles

- Control-click a fade handle, and choose a fade option from the shortcut menu:

  • **Linear:** Maintains a constant rate of change over the length of the fade.
  • **S-curve:** Eases in and out of the fade with the midpoint at 0 dB.
  • **+3dB:** Starts quickly and then slowly tapers off toward the end. This is the most useful setting for quick fades.
  • **-3dB:** Starts slowly and then moves quickly toward the end. This is the default setting and is best for maintaining a natural volume when crossfading between two adjacent clips.

Change the fade shape of a transition crossfade

1 Select a transition in the Timeline, and do one of the following:
   - Choose Window > Show Inspector (or press Command-4).
   - Click the Inspector button in the toolbar.

2 In the Audio Crossfade section of the Transition inspector, choose a fade option from the Fade In Type and Fade Out Type pop-up menus:
   - **Linear:** Maintains a constant rate of change over the length of the fade.
   - **S-curve:** Eases in and out of the fade with the midpoint at 0 dB.
   - **+3dB:** Starts quickly and then slowly tapers off toward the end. This is the most useful setting for quick fades.
-3dB: Starts slowly and then moves quickly toward the end. This is the default setting and is best for maintaining a natural volume when crossfading between two adjacent clips.

**Pan audio**

Panning audio lets you distribute sound across the stereo or surround spectrum to create balance or a special effect. For example, you can place more sound in the right channel of a stereo clip or less sound in the center channel of a surround clip.

Final Cut Pro includes a built-in surround sound decoder that lets you choose among several stereo and surround preset pan modes that you can apply to clips from the Audio inspector. Using the pan mode presets, you can dynamically re-create surround sound fields from stereo source content.

When you change the pan mode in the Audio inspector, the setting is applied to the entire selection. To make more precise adjustments, you can add keyframes using the Audio Animation Editor or the Audio inspector, and then make adjustments to them in the Audio inspector.

**Pan audio for stereo**

1. Select the audio clip.
2. In the Audio inspector, choose Stereo Left/Right from the Pan Mode pop-up menu.
3. Move the sound left or right by doing one of the following:
   - Type a value in the Pan Amount field.
   - Drag the Pan Amount slider left or right.

**Pan audio for surround sound**

1. Select the audio clip.
2. In the Audio inspector, choose one of the following options from the Pan Mode pop-up menu:
   - *Create Space*: Distributes the signal across the surround spectrum, with more signal to the center and front left and right channels. This setting is useful for making a general-purpose surround mix from any stereo source. The Pan Amount slider setting can be adjusted from 0 (no effect) to 100 (total surround field).
   - *Dialogue*: Pans more signal to the center channel of the surround spectrum so that the direct sound is in the center, while ambient sound is distributed to the other channels. This setting is best used for voiceover or other dialogue clips. The Pan Amount slider setting can be adjusted from 0 (no effect) to 100 (all sound to the center channel).
   - *Music*: Distributes a stereo mix signal evenly across the surround spectrum. This setting is best used for converting stereo music to a surround mix. The Pan Amount slider setting can be adjusted from 0 (no effect) to 100 (total surround field).
• **Ambience:** Pans across the surround spectrum with more signal toward the surround channels and less signal to the front and center channels. This setting is useful for effects such as crowd noise or other outdoor environments. The Pan Amount slider setting can be adjusted from 0 (no effect) to 100 (total surround field).

• **Circle:** Pans the sound in a circle around the surround spectrum like a bee buzzing around the listener’s head. The Pan Amount slider adjusts the direction to the listener in degrees (–180 to 180).

• **Rotate:** Pans around the surround spectrum as if the listener is turning in a circle. The Pan Amount slider adjusts the listener rotation in degrees (–180 to 180).

• **Back to Front:** Pans from back to front across the surround spectrum. The Pan Amount slider setting can be adjusted from –100 (back) to 100 (front).

• **Left Surround to Right Front:** Pans from left surround to right front across the surround spectrum. The Pan Amount slider setting can be adjusted from –100 (left surround) to 100 (right front).

• **Right Surround to Left Front:** Pans from right surround to left front across the surround spectrum. The Pan Amount slider setting can be adjusted from –100 (right surround) to 100 (left front).

3 If you want to adjust the pan amount, do one of the following:

   • Type a value in the Pan Amount field.
   • Drag the Pan Amount slider left or right.

The Pan Amount settings vary according to the pan mode you choose.

**Adjust surround sound using the Surround Panner**

In the Audio inspector, you can use the Surround Panner to change the surround sound field or make advanced adjustments using sliders.

Using the Surround Panner, you can change the panning levels by moving a control that represents where the sound would appear to originate in an actual surround sound speaker setup.

1 Choose a surround preset from the Pan Mode pop-up menu.

2 To open the Surround Panner, click the disclosure triangle next to Surround Panner in the Volume and Pan section of the Audio inspector.
3 Do either of the following:

- To make adjustments in the Surround Panner: Drag the control within the surround field to pan toward or away from any of the surround channels (left, center, right, left surround, or right surround) represented by the speaker icons. Click a speaker icon to turn it on or off.

To move the control back to the center position, double-click it.

- To make advanced adjustments: Click the Advanced disclosure triangle below the Surround Panner, and drag the sliders up or down for any of the parameters you want to adjust.

  When you make adjustments to advanced parameters, the Pan Mode indicates that it has been edited.

**Reset pan adjustments**

- To reset an edited pan mode: Choose another preset from the Pan Mode pop-up menu. The Pan Amount slider is not affected.

- To reset adjustments to the Surround Panner only: Click the Reset button in the Surround Panner section of the Audio inspector.

- To reset all adjustments: Click the Reset button at the top of the Volume and Pan section of the Audio inspector.

  You can monitor stereo and surround sound channel levels using the Audio meters.
Configure audio channels

Final Cut Pro assigns a default channel configuration for audio clips when they are imported or added to a project. You can change the channel configuration if, for example, you want to convert a stereo dialogue clip to two mono channels.

The number of channel options you can configure depends upon how many channels are in your source clip or compound clip. You can configure channels in several formats, including:

- **Mono**: Single channel. In a surround sound setup, you can assign a mono channel to any surround channel.
- **Stereo**: Left and right channels.
- **5.1 surround**: Left, center, right, left surround, right surround, and low-frequency (subwoofer bass) channels.
- **7.1 surround**: Left, center, right, left surround, right surround, left back, right back, and low-frequency (subwoofer bass) channels.

**Note**: If you configure more than six surround channels, Final Cut Pro automatically adjusts the channel mix down to 5.1 surround during playback.

Change channel configuration

1. Select the clip in the Timeline.
2. In the Channel Configuration section of the Audio inspector, choose an option from the Channels pop-up menu.

**Note**: If you selected “Separate mono and group stereo audio” or “Remove silent channels” when you imported a clip, the default channel configuration appears as Auto-Detected. To retrieve the original audio configuration, deselect Auto-Detected in the Channels pop-up menu.

The channels appear as separate waveforms in the Audio inspector.

**Note**: If you have a compound clip, you can mute or unmute the different channels in the clip, but you can’t configure them.

3. Do any of the following:
   - **To listen to a single channel**: Skim over a channel waveform or play back the waveform using the Space bar or the J, K, and L keys.
   - **To mute or unmute a channel**: Select the checkbox next to a channel waveform. When you mute a channel, no sound is heard in the corresponding speaker for that channel.
To assign a mono channel to a specific surround channel: Select the mono channel waveform, and choose a surround channel from the Channels pop-up menu.

To reset a configuration, click the Reset button.

You can also choose a channel configuration when exporting roles as audio stems for mixing or post-production. See “Export your project as media files” on page 448. If you choose an export file channel configuration that is different from that of your source files, the channels are exported in the following ways:

- **Stereo source exported as surround:** The left and right channels are exported to the left and right channels of the surround file.
- **Surround source exported as stereo:** The surround source is exported as a stereo (left and right channel) mix.
- **Stereo or surround source exported as mono:** The stereo or surround source is exported as a mono (one channel) mix.

**Match audio equalization settings**

The Match Audio function uses equalization (EQ) to let you match a selected clip’s sound to another clip. This is particularly useful when you have multiple audio clips recorded in different environments but want the clips to sound similar to each other.

**Match audio**

1. Select the clip or clips you want changed in the Timeline.
2. Do one of the following:
   - Choose Modify > Match Audio.
   - Choose Match from the Equalization pop-up menu in the Audio Enhancements section of the Audio inspector.
   - Choose Match Audio from the Enhancements pop-up menu in the toolbar.
3 Click to select the clip whose sound you want to match.
4 Click Apply Match.

Once you match a clip, you can make adjustments to settings in the Audio Enhancements section of the Audio inspector.

Remove audio matching
1 Select the clip in the Timeline.
2 In the Audio Enhancements section of the Audio inspector, choose a different equalization setting from the Equalization pop-up menu.

To remove all equalization, choose the Flat setting.

Preserve pitch when retiming clips
By default, Final Cut Pro preserves pitch when retiming clips so that the pitch doesn’t sound higher when the clip is faster or lower when the clip is slower. You can turn this feature on or off before or after a clip has been retimed.

Turn Preserve Pitch on or off
1 In the Timeline, select an entire clip, or a range within a clip, whose speed you plan to change.
2 Choose Preserve Pitch from the Retime pop-up menu in the toolbar.

A checkmark to the left of the command name indicates that Preserve Pitch is turned on. To turn it off, choose Preserve Pitch again.

Audio tools and techniques

View and correct audio levels
The Audio meters let you see and track the audio levels of clips in Final Cut Pro and warn you if a particular clip or section of a clip reaches peak levels, which may result in audible distortion.

When an audio clip is approaching peak levels during playback, the level color changes from green to yellow.

When an audio clip exceeds peak levels, the level color changes from yellow to red, and the peak indicator lights red for the respective audio channel or channels. The peak indicators reset when you stop and start playback again.
To avoid having clip volume exceed peak levels, adjust the volume. Although the proper level for a clip depends upon the overall mix you want, it’s important to make sure that the combined level for all concurrent clips does not exceed 0 dB during the loudest sections.

Final Cut Pro includes two meters, a small Audio Meter icon in the Dashboard in the toolbar and a larger Audio Meters pane.

**Show or hide the Audio meters**
To show the Audio meters, do one of the following:

- Choose Window > Show Audio Meters.
- Click the Audio Meter icon in the Dashboard in the toolbar.

You can drag the edges of the meters to see an expanded view with additional information.

To hide the Audio meters, choose Window > Hide Audio Meters, or click the Audio Meter icon in the Dashboard in the toolbar.

**Reset and correct peak levels**
- Select the clip in the Timeline, readjust the level, and play back the clip again to test for peaks.

In the Timeline and Event Browser, the waveform section or sections of a clip turn yellow when a level is approaching peak levels or red when a level exceeds 0 dB.
About audio waveforms

Audio waveforms are visual representations of the actual sound. Audio waveforms appear in clips in the following ways:

- As the bottom portion of a video clip, colored blue
- As a detached or an audio-only clip, colored green

An audio waveform's amplitude and length change according to the underlying sound's volume and duration. A short, loud sound such as a drum beat has a sharp, peaked waveform, whereas low-level crowd noise has a lower, more uniform waveform. These properties make it easier to find specific edit points when trimming clips or keyframing effects.

In Final Cut Pro, audio waveforms change according to a clip's volume level or applied effects. The waveform appears larger when the volume is high and smaller when the volume is low.

You edit audio clips in the Timeline by first listening to a clip's audio through playback and skimming, and then applying changes to the clip, using the waveform as a reference.

View audio waveforms at the audio sample level

For even more precise editing, you can zoom in to audio clips at the audio sample level. Audio samples show the audio waveform at a fraction of a second (for example, 1/48,000 for audio recorded at a sample rate of 48 kHz). Sample-accurate editing resolution is available only for connected audio clips (that is, audio clips not in the primary storyline) or compound clips that contain only audio.
Tip: For reference when working with video, you can view subframes (1/80 the duration of a video frame) in the timecode display of the Dashboard. In the Editing pane of Final Cut Pro preferences, choose the subframe option in the Time Display pop-up menu.

Zoom to audio samples

1. Choose View > Zoom to Samples (or press Option-Z).
2. Select the clip in the Timeline.
3. Zoom in until the clip shows the waveform within the borders of a video frame.

You can continue to zoom in for closer detail of the waveform.

4. Make edits to the clip or adjustments to audio effects using keyframes.

To turn off zooming to audio samples, choose View > Zoom to Samples (or press Option-Z).
Navigate by subframe
1 In the Timeline or the Event Browser, move your pointer over a clip and click.
2 Do either of the following:
   • To move backward in one-subframe increments: Press Command-Left Arrow.
   • To move forward in one-subframe increments: Press Command-Right Arrow.

Ways to view audio clips
When you work with audio waveforms in the Timeline, you can zoom in or out or change the clip appearance to make the waveform taller or shorter.

Final Cut Pro also includes several ways of viewing and working with audio and video within clips. You can expand a clip to see separate audio and video, detach audio from a video clip to work on each clip separately, and change the background appearance of a clip to show reference waveforms, which make it easier to see audio waveforms when the volume is diminished.

Show expanded audio and video
You can view audio and video separately in the same clip in the Timeline by expanding clips that have both audio and video. This can be useful if you need to zoom in to the audio portion to make edits.

Note: If you create a split edit so that audio portions overlap, you won’t clearly see the overlapped waveforms unless you choose to show expanded audio for split clips.

- To expand a single clip: Double-click the audio waveform of the clip.
- To expand a clip or clips you’ve selected in the Timeline: Choose Clip > Expand Audio/Video (or press Control-S).
To expand all clips in the Timeline: Choose View > Expand Audio/Video Clips, and choose for all clips or for split clips.

When you show expanded audio, the audio and video portions of the clip remain attached to each other. To create a separate connected audio clip, detach the audio. You can also use the Precision Editor to see a detached view of the video and audio portions of the clip.
Collapse audio and video
You can collapse the expanded audio/video view for a single clip, multiple clips, or all clips in the Timeline.

- To collapse a single clip: Double-click the audio waveform of the clip.
- To collapse a clip or clips you’ve selected in the Timeline: Choose Clip > Collapse Audio/Video (or press Control-S).
- To collapse all expanded clips in the Timeline: Choose View > Collapse All Clips.

Detach audio from video
By default, Final Cut Pro imports audio and video from the same source into one clip. You can easily detach the audio from a video clip so that you can edit the audio clip separately in the Timeline.

- Select the clip in the Timeline, and choose Clip > Detach Audio.

A new audio clip appears as a connected clip beneath the video clip.

To reattach an audio clip to its original video clip, you need to create a compound clip.
Show or hide reference waveforms
A reference waveform shows the maximum visual resolution possible for the actual audio waveform. By factoring out loudness changes, reference waveforms let you see the details of the sound more clearly.

1 Choose Final Cut Pro > Preferences, and click Editing.
2 Select the “Show reference waveforms” checkbox.

When the actual waveform changes shape (for example, when it is diminished because a clip’s volume level is low), its full reference waveform is still visible for easy reference when editing.

Tip: You can place any clip with audio either above or below the primary storyline in the Timeline. If your clip contains video and is placed below the primary storyline, the video is invisible, but the audio will play. If you put the clip above the primary storyline, the audio plays and the video also plays instead of the video in the primary storyline.

Solo and mute audio clips
The solo feature temporarily disables playback of all clips in the Timeline except for selected ones. It is especially useful in audio editing if you have more than one audio clip layered in the Timeline (dialogue and background music, for example) but need to listen and make edits to just certain clips.

You can also mute clips by using the disable function. Disabled clips are both invisible and silent and will not appear in any output.

Solo clips in the Timeline
1 Select one or more clips in the Timeline.
2 Do one of the following:
   • Choose Clip > Solo (or press Option-S).
   • Click the Solo button in the Timeline.
The soloed clip appears highlighted, while other clips appear dimmed.

To turn off solo, click the Solo button, or choose Clip > Solo (or press Option-S) again.

**Disable clips**

1. Select one or more clips in the Timeline.
2. Choose Clip > Disable (or press V).

   Disabled clips are silent and appear dimmed in the Timeline.
3. To reenable the disabled clips, select them in the Timeline and choose Clip > Disable (or press V).

You can solo video clips in Final Cut Pro. For more information, see “Solo, disable, and enable clips” on page 124.

**Sync audio and video automatically**

Final Cut Pro can automatically analyze and sync the audio and video clips in your project using auto-synchronization.

For example, if you select two video clips and three separate audio clips from different sources that were all recorded during the same take, Final Cut Pro automatically analyzes and syncs the clips together into a compound clip in the Event Browser.
Final Cut Pro analyzes the clips for sync points such as markers you’ve added, timecode, file creation date, and audio content. If no sync points can be found, the clips are synced at their respective starting points.

**Selected clips in the Event Browser**

**New compound clip containing synchronized clips**

**Compound clip contents**

- Primary storyline for the compound clip
- Connected clips
Auto-synchronize clips

1. Select the audio and video clips you want to sync in the Event Browser.

2. Choose Clip > Synchronize Clips (or press Command-Option-G).

Synced compound clips are labeled “Synchronized clip” in the Event Browser. The original clips are not affected.

If your synchronized clip contains audio channels that aren’t being used, you can turn them off. See “Configure audio channels” on page 204.

Use roles to organize clips and export audio files

Final Cut Pro assigns an audio role (Dialogue, Music, or Effects) to the audio portion of all clips on import.

Role assignments make it easy to organize clips by audio type, but their most powerful benefit is the ease with which you can export separate files (also called media stems) from Final Cut Pro for all dialogue, music, or effects clips. This process is often used when delivering stems to match broadcast specifications or when handing off stems for mixing or post-production.

You can use roles for the following workflows:

- **Reassign roles**: You can view and reassign clip roles in the Timeline Index, the Event Browser, the Info inspector, or the Modify menu. See “View and reassign roles” on page 340. You can also create custom roles and subroles to further organize your clips.

- **View and organize clips by role**: In the Timeline Index, you can organize clips by role, turn roles on or off, and highlight or minimize clips for viewing in the Timeline. For example, you could easily identify all your dialogue clips and play them back in isolation from other audio clips. See “View clips by role in the Timeline” on page 347.

- **Export media stems**: You can export roles as media stems in a combined, multitrack QuickTime file, or as separate audio or video files. During the export process you can assign mono, stereo, or surround output for your audio channels. See “Export your project as media files” on page 448.
Transitions, titles, effects, and generators overview

You can easily add special effects to video, audio, and photos in your projects. Final Cut Pro provides several kinds of effects and controls:

- **Transitions**: Add an effect between clips to control how they change from one to the next. See “Transitions overview” on page 218.
- **Titles**: Use to add text at any point in your project. See “Titles overview” on page 229.
- **Effects**: Use to do a wide variety of things to your video and audio clips, from subtle (add film grain or a color effect to the video, or a graphic equalizer to the audio) to not so subtle (add droplet ripples or an insect-eye view to the video, or apply an exaggerated pitch shift to the audio). There are two main types of effects:
  - **Built-in effects**: Use these standard effects to resize, move, rotate, trim, skew, crop, or apply the Ken Burns zooming effect to a video clip. These effects are already part of each Timeline clip—you just need to adjust them. See “Built-in effects overview” on page 236.
  - **Clip effects**: Use these effects to change your video and audio clips to either correct issues or create stunning new looks or sounds. See “Clip effects overview” on page 250.
- **Generators**: Add a special element like a placeholder clip, a timecode generator, or a countdown timer, or add colors, patterns, or animated backgrounds to your project. See “Generators overview” on page 258.
- **Onscreen controls**: Customize many of your effects using onscreen controls. See “Onscreen controls overview” on page 264.
- **Video Animation**: Vary effect settings as a clip plays. See “Video animation overview” on page 270
Effects can be added to any clips in the Timeline. Once they have been added (or in the case of built-in effects, adjusted), you can customize the effects using controls in an inspector, onscreen controls in the Viewer, and controls in the Video Animation Editor and Audio Animation Editor. You can also try out multiple versions of an effect using auditions.

Most of the effects and generators can be opened in Motion, an Apple application designed to work with Final Cut Pro, where you can customize and save specialized versions of them.

Add and adjust transitions

Transitions overview
You can add cross dissolves and other transition effects between cuts to make your program more interesting.

Transitions replace one shot with another over a specified period of time; when one shot ends, another one replaces it. Three very common video transitions occur over time: fades, cross dissolves, and wipes.

You can add audio-only transitions to audio edits in a connected storyline. These transitions can be either a fade-in, fade-out, or crossfade.

Note: When a transition is added to a video clip with attached audio, a crossfade transition is automatically applied to the audio. If the audio is detached or expanded from the video, the audio is not affected by the video transition.
How transitions are created
Transitions require overlapping video from the clips on each side of the edit point. A one-second transition requires one second of video from the end of the left clip and one second of video from the start of the right clip. When you apply a transition to an edit point, Final Cut Pro attempts to use additional video from each of the clips to create the overlap. These additional (unused) sections of clips are known as *media handles*. The following image shows a clip with media handles on each end and a clip with no extra video, or media handle, at its start.

Clip selected in the Event Browser

The media handle video may not be appropriate for use in a transition. For example, if the video includes unusable video such as a slate, it will be visible in the project.

You can set the default duration for transitions. See “Set the default duration for transitions” on page 220.
The illustration below shows how transitions are created when the clips on either side of the edit point have media handles. The transition is placed so that it spans the clips; one half of the transition overlaps each clip. Unused media from the end of each clip is added to fill out the transition. The total duration of your project is unchanged.

![Edit with no transition](image)

If one or both of the clips do not have enough extra content (media handles) to support a transition of the default duration, you are given the option to overlap media in your project to create the transition.

Final Cut Pro uses any available media handles and then overlaps media as necessary to create the transition. The illustration below shows a transition created without media handles. The two clips are made to overlap, and the transition is placed over the overlapping region. This is effectively a ripple trim edit, and the total duration of your project decreases.

![Edit with no transition](image)

**Set the default duration for transitions**

You can set the default transition duration in Final Cut Pro preferences.

**Set the default duration**

1. Choose Final Cut Pro > Preferences, or press Command-Comma (,), and click Editing.

2. Use the “Default length” value slider to set the duration, in seconds, of all transitions you add to the Timeline.

You can adjust the duration of a transition after it is in the Timeline.

*Note:* Some transitions have a set duration and are not affected by this setting.
Add transitions to your project
There are several methods you can use to add transitions to your project. Once a transition is added, you can adjust its parameters. You can also modify the transition effect in Motion.

Add a cross dissolve

1 Choose the Select tool from the Tools pop-up menu in the toolbar (shown below), and click the edge of a clip (an edit point) in the Timeline.

![Select tool](Image)

One or both clip edges are highlighted.

Note: If you select a whole clip in the Timeline instead of just an edit point, transitions are added at each end of the selected clip.
2 Choose Edit > Add Cross Dissolve (or press Command-T).

The cross dissolve is inserted using the “Apply transitions using” setting. For more information, see “Set the default duration for transitions” on page 220. If the video clip has attached audio, a crossfade transition is applied to the audio.

Add or change a transition using the Transitions Browser
1 Click the Transitions button in the toolbar.

2 Select a transition.

Move the pointer over the transition thumbnails to see an example of what the transition looks like. Additionally, you can type text in the search field to filter the list of transitions that appear.

3 Do one of the following:
   - To apply the transition to an edit point: Drag the transition to it.
   - To replace an existing transition in your project: Drag the transition to it.

Tip: Alternatively, you can select the edit point first, and double-click a transition in the Transitions Browser to apply it.

The transition is added to the edit using the “Apply transitions using” setting. For more information, see “Set the default duration for transitions” on page 220. If the video clip has attached audio, a crossfade transition is applied to the audio.
Add an automatic audio crossfade
When a video clip has attached audio, the audio automatically has a crossfade transition applied when a video transition is applied. If the audio is detached or expanded from the video, the audio is not affected by the video transition. Follow these steps to add an audio crossfade between detached audio clips that are in a connected storyline.

1 Create an audio-only storyline that is connected to the primary storyline.
   For information on creating storylines, see “Add storylines” on page 294.
2 Using the Select tool, click the edge of a clip (an edit point) in the storyline.
   One or both clip edges are highlighted.

   ![Image of a storyline with audio clips]

   **Note:** If you select a whole clip in the storyline instead of just an edit point, transitions are added at each end of the selected clip.

3 To insert a crossfade, choose Edit > Add Cross Dissolve (or press Command-T).
   The crossfade is inserted using the “Apply transitions using” setting. For more information, see “Set the default duration for transitions” on page 220. You can configure the fade-in and fade-out settings in the Transition inspector.

**Copy a transition to other edit points using the Edit menu**

1 Select a transition in the Timeline, and choose Edit > Copy (or press Command-C).
2 Using the Select tool, click the edge of a clip (an edit point) in the Timeline, and choose Edit > Paste (or press Command-V).
   **Note:** If you copy a transition to an edit point that already has a transition, the existing transition is overwritten.

**Copy a transition to other edit points by dragging**

- Select a transition in the Timeline, press the Option key, and drag the transition to another edit point.
   **Note:** If you copy a transition to an edit point that already has a transition, the existing transition is overwritten.
Delete transitions from your project
You can easily delete a transition, restoring the edit point to a simple cut.

Delete a transition
1 Select one or more transitions in the Timeline.
2 Press Delete.

The selected transitions are removed and their edit points are converted to simple cuts.

Important: If a transition you deleted used Full Overlap, the edit point is now at the center point of the transition that was removed, not at its original location before the transition was applied. You can use Edit > Undo to remove the transition and return the clips to their original length. For more information, see “How transitions are created” on page 219.

Adjust transitions in the Timeline
You can adjust a transition’s duration and move it in the Timeline. You can also trim either of the clips under the transition.

Change the transition duration
1 Select a transition in the Timeline.
2 Do one of the following:
   • Choose Modify > Change Duration (or press Control-D), type the duration (it appears in the Dashboard in the toolbar), and press Return.
   • Drag one end of the transition away from the transition’s center to make it longer or toward the center to shorten it.

The transition maintains its center point and equally trims both ends, with the number showing how many frames have been added to or subtracted from the transition duration.
Move the transition
Moving a transition actually rolls the edit under the transition, adding content to one underlying clip while removing content from the other clip. The overall duration of the project is not affected. Additionally, you can only move the transition as long as sufficient media handles are available for the clip that is being extended.

1. Select a transition in the Timeline.
2. Drag the transition trim icon in the upper-center area of the transition.

The edit under the transition is rolled, with one clip being extended and the other shortened. A number appears showing the number of frames to the left (negative numbers) or to the right (positive numbers) you have rolled the transition.

You can also use the Precision Editor to roll the transition.
Trim a clip under a transition
The transition includes icons that make it easy to trim the left or right clip without affecting the transition.

1 Select a transition in the Timeline.
2 Drag one of the trim icons in the upper-left or upper-right area of the transition.

Dragging the trim icon in the upper left adjusts the right clip’s start point, and dragging the trim icon in the upper right adjusts the left clip’s end point. A number appears showing how many frames you have added to (negative numbers) or subtracted from (positive numbers) the clip’s duration. Trimming the clip doesn’t affect the transition’s duration, but it does affect the project’s duration.

You can also use the Precision Editor to trim the clips under the transition.
Adjust transitions in the Transition inspector and Viewer
You can adjust a transition using the controls in the Transition inspector and Viewer.

Adjust a transition using the Transition inspector and Viewer
1 If the Transition inspector is not already visible, choose Window > Show Inspector (or press Command-4).
2 In the Timeline, select the transition to adjust.

For this example, use the Circle transition.

The Viewer shows any onscreen adjustments you can make by dragging the handles. The Transition inspector shows the other parameters available for you to adjust. Additionally, some transitions have an image well for you to select a video frame that appears as part of the transition.

In the above example, you can drag the white circle in the Viewer (an onscreen control) to position the circle wipe’s center and the square to set the border width (in this case, its softness). The Transition inspector includes a setting for the circle wipe’s aspect ratio and edge treatment (including the border color if you choose a hard edge).

Additionally, many transitions have parameters that you can animate using keyframes. For example, you could have the center of the Circle transition move as you play the clip.

For more information on adjusting audio crossfades in the Transition inspector, see “Fade audio in or out” on page 197.
Adjust transitions with multiple images
Several transitions include areas that are filled with still images from the clips on either side of the transition. For example, this is the Pan Far Right transition (one of the Bulletin Board transitions).

This image is set by handle number 3 in the Timeline.

The areas are numbered and correlate to numbered points around the transition in the Timeline.

Adjust transitions with numbered points
1 Select the transition with numbered points in the Timeline.
2 Move the playhead over the transition until you see an area with the same number as one of the numbered handles in the Timeline.
3 Drag the numbered handle to select the image to fill the area.
4 Continue until you have selected images for all of the areas.
Create specialized versions of transitions in Motion
Many of the transitions were created using Motion, an Apple application designed to work with Final Cut Pro. You can open these transitions in Motion, make modifications, and save the changes as a new transition file that appears in the Transitions Browser.

**Important:** The following steps require you to have Motion 5 installed on your computer.

**Modify a transition in Motion**
1. Click the Transitions button in the toolbar.

2. In the Transitions Browser, Control-click the transition you want to modify, and choose “Open a copy in Motion” from the shortcut menu.

Motion opens and the transition’s project appears.

3. Modify the transition project.

See Motion Help for information on using Motion.

4. Choose File > Save As (or press Command-Shift-S), enter a name for this new transition (referred to as a Template in Motion), assign it to a category (or create a new category), choose a theme (if needed), and click Publish.

**Note:** If you choose File > Save, the transition is saved using the same name with “copy” appended to its end.

Add and adjust titles

**Titles overview**
Titles play a critical role in movies, providing important bookends (such as opening titles and closing credits) and conveying time and dates within the movie. Titles, especially in the lower third of the screen, are also used in documentaries and informational videos to convey details about subjects or products onscreen. You can also add notes and placeholders within your project while you edit. Subtitles can be a critical element for movies originating in a different language.

You can create titles and credits within Final Cut Pro with title effects. Titles are synthesized clips (similar to generators) generated by Final Cut Pro. Titles don’t refer to any media on your hard disk. When you add a title as a connected clip directly above another clip, the underlying clip appears as the title’s background, sparing you the need to perform any further compositing to create that effect.
Add titles to your project
You add titles to clips in your project using the Titles Browser. Once you have added

text, you can modify the title’s text style.

Add a title to a project clip
1 Drag the playhead in the Timeline to the point where you want to add the title.
2 Click the Titles button in the toolbar (or press Command-5).

3 Do any of the following:
   • *To add a title from the Titles Browser:* Double-click the title.
     The title is added at the playhead location.
   • *To add a basic title:* Choose Edit > Connect Title > Basic Title (or press Control-T).
     A title named Basic Title (with no effects or animations) is added at the
     playhead location.
   • *To add a lower-third title:* Choose Edit > Connect Title > Basic Lower Third (or press
     Shift-Control-T).
     A lower-third title named Basic Lower Third (with no effects or animations) is added
     at the playhead location.

The title is connected to the clip in the primary storyline at the position of the
playhead. Visually, the title is superimposed over the clip in the primary storyline at
the playhead position. If the playhead is not over a clip, the title is superimposed over
the default background.
Add a title as a clip in the Timeline
There are two ways to add a title as a clip in the Timeline. You can either insert a title at the edit point between two clips or replace an existing clip in the Timeline with a title.

- To add a title between clips in the Timeline: Drag a title from the Titles Browser to the edit point between the clips where you want it to appear.

- To replace an existing Timeline clip with a title: Drag a title from the Titles Browser to the clip in the Timeline that you want to replace, and choose Replace from the shortcut menu.

Enter text for your title
Once you’ve added a title to your project in the Timeline, you can type text for your title in the Viewer.

1. Select a title in the Timeline.
2. In the Viewer, double-click the title text.
3. Type text for your title.
4. Repeat steps 2 and 3 for each text box that appears in the Viewer for the title.
Adjust titles
You can adjust a title's text appearance using the Title and Video inspectors. For example, you can adjust a title's opacity or modify the text's font, alignment, color, glow, and drop shadow.

Adjust a title's position onscreen
1 Select a title in the Timeline.
2 In the Viewer, double-click the title text.
3 Click the position button and drag the title's text box to the new position.
4 Repeat steps 2 and 3 as needed for each text box that appears in the Viewer for the title.

Adjust a title's opacity
If you're placing a title over an existing clip, you can adjust the title's transparency.
1 Select a title in the Timeline.
2 Choose Window > Show Inspector (or press Command-4), and click the Video button at the top of the pane that appears.

3 In the Compositing section, adjust the opacity settings.

Note: You can also keyframe a title’s opacity setting.

Adjust a title’s settings
You can modify a title’s default settings in the Title inspector.

1 Select a title in the Timeline.
2 Choose Window > Show Inspector (or press Command-4), and click the Title button at the top of the pane that appears.

3 Adjust the available settings as needed.

Note: You can also keyframe many of the settings in both the Title and Text inspectors.
Modify a title's text style
You can modify the text style for a title.

1 Select a title in the Timeline.

2 Choose Window > Show Inspector (or press Command-4), and click the Text button at the top of the pane that appears.

3 Adjust the available settings as needed.

*Note:* You can also keyframe many of the settings in both the Title and Text inspectors.

Remove titles from your project
You can remove a title from your project at any time.

Remove a title
- In the Timeline, select the title you want to remove, and press Delete.
Find and replace text in your project
If your project contains multiple instances of a particular word or phrase displayed in multiple title clips, such as names, company names, or job titles, you can find the specific word or phrase and quickly change each instance of it.

Find and replace title text
1  Choose Edit > Find and Replace Title Text.
2  In the Find and Replace Title Text window that appears, type the text you want to search for in the Find field.

3  In the Replace field, type the text you want to replace the text you’re looking for.
4  To choose where to search, do one of the following:
   •  To search for text in the selected title clip: Choose Selected Title from the “Search in” pop-up menu.
      This option is useful for searching in title clips that have a lot of text, such as credits.
   •  To search for text across all the title clips in your project: Choose All Titles In Project from the “Search in” pop-up menu.
5  Do any of the following:
   •  To match how letters are capitalized in your search string: Select the “Match case” checkbox.
   •  To locate whole words rather than a group of letters within words: Select the “Whole words” checkbox.
   •  To have the search start over from the beginning of the searched item once it’s reached the end: Select the “Loop search” checkbox.
6  Do one of the following:
   •  To replace all instances of the text at once: Click the Replace All button.
   •  To replace this single instance of the text only: Click the Replace button.
   •  To replace this instance of the text and locate the next place the text appears: Click the Replace & Find button.
   •  To cycle forward and backward through each instance of the text you’re looking for: Click the Previous and Next buttons.
Adjust built-in effects

Built-in effects overview
Final Cut Pro includes several video effects that are part of each Timeline clip and directly accessible from the Viewer—all you need to do is select them and start making adjustments. You can use these to:

- Create a composited image from several clips
- Reposition or reframe a clip by zooming in on it
- Crop a clip to remove unwanted items, such as microphones or lighting equipment, that accidentally appear in the video
- Configure a Ken Burns effect to add life to your still images (and video clips as well)

You can use more than one of the built-in effects at the same time. For example, you can use Transform to reduce the image’s size and position, Trim to remove a portion of the video, and Distort to give the video a skewed look.

You can animate any of these effects so that they change as the clip plays. For example, you can have an image shrink and move offscreen. To configure an animation, you change settings at two or more points in the clip. When you play the clip, Final Cut Pro creates smooth animated transitions between the points.

Resize, move, and rotate clips
The Transform built-in effect allows you to resize, move, and rotate an image. This effect is commonly used on a clip placed over a primary storyline clip, which becomes the background of the resized clip. It is also often used to zoom in on a clip, allowing you to reframe a shot if needed.

Adjust the Transform effect
Controls in the Viewer and Video inspector allow you to adjust this effect. However, some controls are found in only one or the other.

1 Select a clip in the Timeline.

2 To access the Transform controls, do one of the following:
   - Click the Transform button in the lower-left corner of the Viewer (or press Shift-T).
   - Control-click in the Viewer and choose Transform from the shortcut menu.
To adjust the effect using the onscreen controls:

- **Blue handles at each corner**: Drag these to adjust the image’s size while maintaining its current aspect ratio.

- **Blue handles in the middle of each side**: Drag these to independently adjust the vertical and horizontal image size, changing the aspect ratio of the image.
  
  **Note**: These controls aren’t available in the Video inspector.

- **White circle in the center**: Shows the rotation anchor point. Drag anywhere inside the image to adjust the image’s position.

- **Blue handle extending from the center circle**: Drag this to rotate the image.

  **Tip**: For finer precision when rotating the image, drag the rotation handle farther away from the anchor point in the center.
4 Use the Transform controls in the Video inspector as follows:
   - Position X and Y: Use these to move the image left and right (X) and up and down (Y).
   - Rotation: Use this to rotate the image around its anchor point.
   - Scale: Use this to change the image’s size.
   - Anchor X and Y: Use these to move the image’s center point. This defines the point that the image rotates around.

   **Note:** This control isn’t available in the onscreen controls.

5 When you are finished adjusting the effect and no longer need the onscreen controls, click Done.

   You can animate the effect and have it appear over a background. For details on working with built-in effects, see “Work with built-in effects” on page 244.

**Trim clips**
Trim controls allow you to independently trim each of the image edges, creating a window look. This effect, often used along with the Transform effect, is commonly used on a clip placed over a primary storyline clip, which becomes the background of the trimmed clip.

**Adjust the Trim effect**
1 Select a clip in the Timeline.

2 To access the Trim controls, do one of the following:
   - Click the Crop button in the lower-left corner of the Viewer (or press Shift-C).
   - Control-click in the Viewer and choose Crop from the shortcut menu.

3 Click Trim in the upper-left corner of the Viewer.
4 To adjust the effect using the onscreen controls:
   • Blue handles at each corner: Drag these to adjust the position of two trim window sides at the same time.
   • Blue handles in the middle of each side: Drag these to independently adjust the position of each side.
   • Anywhere inside the window: Drag anywhere inside the window to adjust its position.

5 To individually adjust each edge using the Crop area of the Video inspector, use the Trim controls.

6 When you are finished adjusting the effect and no longer need the onscreen controls, click Done.

You can animate the effect and have it appear over a background. For details on working with built-in effects, see “Work with built-in effects” on page 244.
**Crop clips**
The Crop effect makes it easy to remove unwanted areas of the image. It automatically expands the cropped image so that it fills the screen.

**Adjust the Crop effect**
1. Select a clip in the Timeline.
2. To access the Crop controls, do one of the following:
   - Click the Crop button in the lower-left corner of the Viewer (or press Shift-C).
   - Control-click in the Viewer and choose Crop from the shortcut menu.
3. Click Crop in the upper-left corner of the Viewer.
4. To adjust the effect using the onscreen controls:
   - *Blue handles at each corner:* Drag these to adjust the crop of that corner. The cropped image always maintains the original aspect ratio.
   - *Anywhere inside the window:* Drag anywhere inside the crop window to adjust its position.

![Drag a corner handle to change the crop window's size (but not its aspect ratio).](image1)

![Drag anywhere inside the image to position the crop window.](image2)

Click Done to crop the image and expand it to full size.
To individually adjust each edge using the Crop area of the Video inspector, use the Crop controls.

**Note:** While you can use these controls to change the crop window’s aspect ratio, the final image still matches the original image’s aspect ratio, with additional content being cropped out so that the final image fits the original aspect ratio.

Click Done to have the crop applied and see the image zoomed to fill the screen.

You can animate the effect, creating the illusion of a pan and zoom camera move (effectively, a manual Ken Burns effect). For details on working with built-in effects, see “Work with built-in effects” on page 244.

### Pan and zoom clips
The Ken Burns effect creates a pan and zoom effect using the start and end positions you define. The Ken Burns effect is actually a Crop effect with two crop settings, one at the clip start and another at its end.

#### Adjust the Ken Burns effect
1. Select a clip in the Timeline.
2. To access the Ken Burns controls, do one of the following:
   - Click the Crop button in the lower-left corner of the Viewer (or press Shift-C).
   - Control-click in the Viewer and choose Crop from the shortcut menu.
3 Click the Ken Burns button in the upper-left corner of the Viewer.

Two rectangles appear in the Viewer: a green one that defines the position and size for the start of the clip and a red one that defines the position and size for the end of the clip. An arrow is superimposed to show the direction the image travels when the clip is played.

The default start and end settings result in a small zoom to the center of the image.

4 To choose the part of the image that appears at the start of the effect, drag the green handles to change the crop size of the image and drag the window to set its position.

5 To choose the part of the image that appears at the end of the effect, drag the red handles to change the crop size of the image and drag the window to set its position.

6 To have the clip with the effect play in a loop, click the Play Loop button.

7 To exchange the start and end positions, click the Swap button.

8 Click Done.

Tip: Use the Crop effect and intermediate keyframes to create a Ken Burns-style effect that follows a more complicated path.

For details on working with built-in effects, see “Work with built-in effects” on page 244.
Skew a clip's perspective

The Distort effect is similar to the Transform effect, except that you can drag each of the corners independently of the others, allowing you to create a skewed look or add a 3D perspective to the image.

Note: The Distort effect alters the shape of the video but does not actually move the video. To move the video to a different position, use the Transform effect.

Adjust the Distort effect

1. Select a clip in the Timeline.
2. To access the Distort controls, do one of the following:
   - Click the Distort button in the lower-left corner of the Viewer (or press Command-Shift-D).
   - Control-click in the Viewer and choose Distort from the shortcut menu.
3. To adjust the effect using the onscreen controls:
   - Blue handles at each corner: Drag these to adjust the position of each corner, adding a 3D perspective to the image by making parts of it appear closer to you than other parts.
   - Blue handles in the middle of each side: Drag these to adjust the position of each side. You can create a skewed look by dragging them in the same direction as their edge (as opposed to toward or away from the center).
   - Anywhere inside the window: Drag anywhere inside the window to adjust its position.

Drag the center handles to set a side’s position. Drag each corner to set its position.
To individually adjust each corner using the Video inspector, use the Distort controls.

When you are finished adjusting the effect and no longer need the onscreen controls, click Done.

You can animate the effect and have it appear over a background. For details on working with built-in effects, see “Work with built-in effects” on page 244.

**Work with built-in effects**

Following are ways you can work with built-in effects.

**Turn off or reset the effect**

1. Select the clip with the effect in the Timeline.

2. Do one of the following:

   - *To turn off the effect and retain its settings:* Click the blue checkbox next to the effect used (Transform, Crop, or Distort) in the Video inspector.

     You can click the checkbox again to turn the effect back on, making it easy to compare how the clip looks with and without the effect.
• To return all values for that effect to their default state: Click the Reset button 🔄.
• To turn off the effect in the Video Animation Editor: Open the Video Animation Editor by choosing Clip > Show Video Animation (or pressing Control-V), and click the checkbox next to the effect you want to turn off.

![Click an effect's checkbox to turn the effect on or off.](image)

Animate built-in effects
Use keyframes to have the effect's settings change as the clip plays. This applies to all built-in effects except the Ken Burns effect.

1 Select a clip in the Timeline.
2 Click the button in the lower-left corner of the Viewer for the effect you want to animate.
   For this example, click the Transform button (or press Shift-T).
3 Place the Timeline's playhead at the start of the clip.
4 Adjust the effect's onscreen controls to set the start position.
5 Click the Add Keyframe button in the upper part of the Viewer.

6 Move the playhead to the end of the clip.

7 Adjust the effect’s controls to set the end position.

A keyframe is automatically added. Additionally, for Transform effects, a line showing the image’s path appears.
8 To finish, click Done in the upper-right corner of the Viewer.

When you play the clip, the video moves smoothly between the keyframes, creating an animated effect. You can actually add multiple keyframes by moving the playhead to a new position and changing the effect’s controls. For more information on working with keyframes, see “Video animation overview” on page 270.

Adjust the Transform effect animation path
Transform animations have additional keyframe controls you can use to fine-tune the animation path. To show these, you first need to create a simple three-corner effect.

1 Select a clip in the Timeline and put the playhead at its start.
2 Click the Transform button in the lower-left corner of the Viewer (or press Shift-T), and drag the onscreen controls to reduce the image’s size and place it in the upper-left corner.
3 Click the Add Keyframe button.
4 Move the Timeline playhead to the middle of the clip.
5 Use the Transform onscreen controls to move the image to the upper-right corner. A keyframe is automatically added, and a red line appears showing the animation’s path so far.
6 Move the Timeline playhead to the end of the clip.
7 Use the Transform onscreen controls to move the image to the bottom center. A keyframe is automatically added, and the red line extends to this new point.
8 To jump between the keyframes, click the white squares along the red line. The first and last keyframes have white arrows. By default, the red line indicates a smooth path (indicated by how it curves).

9 To control the curve of the path, click the starting or middle keyframe and drag the curve handles.

10 Control-click a keyframe and choose an option from the shortcut menu:
   - *Linear*: Use for direct, non-curved paths in and out of that keyframe.
   - *Smooth*: Use for curved paths in and out of that keyframe, providing a more natural movement.
   - *Delete Point*: Use to delete that keyframe.
   - *Lock Point*: Use to prevent that keyframe from being adjusted. It changes to Unlock Point once set.
   - *Disable Point*: Use to ignore that keyframe, but keep the keyframe in place in case you want to use it later. It changes to Enable Point once set.
Composite effects over a background

Often, Transform, Trim, and Distort effects result in the image being less than full size, with the empty areas filled with black. You can replace the black with a background by placing the transformed clip over a background clip, known as *compositing*.

Do one of the following:

- Add a clip to the Timeline as a connected clip and then add the effect to that clip.
  
  This places the clip above the primary storyline clip, which automatically becomes the effect’s background.

- If the clip is already in the primary storyline, drag it above the primary storyline, positioning it over the clip you want to be the background.

  The result is a composited image.
For more information about working with connected clips, see “Add storylines” on page 294. For more information about compositing clips, see “Compositing overview” on page 405.

**Copy a clip's effects to another clip**

1. In the Timeline, select the clip you want to copy the effects from, and choose Edit > Copy (or press Command-C).

2. Select the clip you want to apply the effects to, and choose Edit > Paste Effects (or press Command-Option-V).

All the first clip's effects are applied to the second clip.

**Add and adjust clip effects**

**Clip effects overview**

In addition to the built-in effects, Final Cut Pro includes a wide variety of video effects that you can apply to your project’s video clips. Many of the effects modify the look of your video, from adding a blur or glow to severe distortions. Some effects overlay camcorder or timecode graphics. There is also an effect for keying one video clip over another.

Final Cut Pro also includes a broad range of audio effects that you can apply to your project’s audio clips. Many of the effects modify the sound of your audio, from subtle echoes to severe pitch distortions.

Once you have added an effect, you can adjust its parameters. Some effects have few adjustments, while others provide a comprehensive set, allowing you a lot of control over how the effects look. Effects can even be animated, with their settings changing as the clip plays.

You can apply multiple effects to your clips, creating a stack of effects. The order that you apply the effects, however, can affect how the final video looks.

Additionally, many of the video effects can be opened and changed in Motion, allowing you to create specialized versions for use in your projects.
Add effects to your project
You add effects to clips in your project using the Effects Browser.

Add an effect to a project clip
1 Select a clip in the Timeline and click the Effects button in the toolbar.

2 In the Effects Browser, select an effect, using any of the following to help you make the selection:
   • To preview what the effect looks like using the video from the currently selected Timeline clip: Move the pointer over the video effect thumbnails.
   • To preview changing the effect’s primary control: Hold down the Option key while moving the pointer over a video effect thumbnail.
   • To filter the list of effects that appear: Type text in the Effects Browser search field.

3 Do one of the following:
   • Drag the effect to the Timeline clip to which you want to apply it.
   • Double-click the effect thumbnail to apply it to the selected clip.

You can now adjust the effect.
Adjust effects in Final Cut Pro
Most effects have one or more parameters that you can adjust using the Video inspector or Audio inspector, the Viewer, or the Video Animation Editor or Audio Animation Editor. You can also control how the effect is applied to the clip, either gradually or constantly.

Adjust an effect in the Video inspector and Viewer
1. In the Timeline, select the clip with the effect you want to adjust.
2. Locate the effect in the Video inspector or Audio inspector.
   - Click to turn the effect on and off.
   - Click to reset the effect's adjustments.

In the above example, there are several settings for the Censor effect. Many effects also have adjustments that appear in the Viewer, known as onscreen controls.

Tip: For audio effects, you can click the Controls button (to the right of the effect’s name) to show a custom control window.

3. Select effect parameters and adjust their settings as needed.
   - To return the effect’s values to their default settings, you can click the effect’s Reset button .

Chapter 10  Add transitions, titles, effects, and generators
Adjust an effect in the Video Animation Editor

Many effect parameters can be adjusted in the Video Animation Editor. Additionally, you can set these parameters to fade in and out, allowing you to gradually apply the effect’s settings.

1. Select the clip with the video effect in the Timeline.
2. Choose Clip > Show Video Animation (or press Control-V).

The effect appears as one of the animations in the Video Animation Editor above the clip. You can click its checkbox to turn the effect off and on. Effects that have more than one adjustable attribute also have a pop-up menu for you to choose the attribute to show and adjust.

Click to turn the effect on and off.

Choose a specific effect adjustment from this pop-up menu.

Double-click effects with this icon to vertically expand them.
3 To vertically expand the effect’s adjustment area, choose a specific effect adjustment from the pop-up menu (if present) and double-click it.

This applies only to effect adjustments that have a single value. An icon appears on the right side of the effect’s section if the adjustment can be expanded.

4 To have the effect’s setting fade in and out of the clip, drag the handles on either end of the effect.

You can also drag the horizontal line up and down to control the effect’s selected setting (Amount, in the above example). Any keyframes you add also appear.
Show the audio effects applied to a clip
1 Select the clip with the audio effect in the Timeline.
2 Choose Clip > Show Audio Animation (or press Control-A).

The audio effect appears as one of the animations in the Audio Animation Editor. You can click its green checkbox to turn the effect off and on.

Change clip effect order
You can apply multiple clip effects to a Timeline clip. The order that you apply them can affect the final output. For example, applying the Artifacts effect, which by default adds random white circles to the video, before the Aged Paper effect results in the white circles also being aged; applying it after Aged Paper results in the circles remaining white.

You can easily change the order of the clip effects in the Video inspector, Audio inspector, Video Animation Editor, or Audio Animation Editor.

Note: You cannot change the order of the built-in effects or color correction.

Change video and audio clip effect order using the Video or Audio inspector
1 Select a clip in the Timeline that has multiple video or audio clip effects applied, and do one of the following:
   • To see the video effects: Open the Video inspector.
   • To see the audio effects: Open the Audio inspector.
In the Video inspector or Audio inspector, drag the effects to change their order.

Drag clip effects to rearrange their order.

Built-in effects and color correction cannot be rearranged.

Change video and audio clip effect order using the Video Animation or Audio Animation Editor

1 Select a clip in the Timeline that has multiple video or audio clip effects applied, and do one of the following:
   - To see the video effects: Choose Clip > Show Video Animation (or press Control-V).
   - To see the audio effects: Choose Clip > Show Audio Animation (or press Control-A).

2 In the Video Animation Editor or Audio Animation Editor, drag the effects to change their order.

Drag clip effects to rearrange their order.

Built-in effects and color correction cannot be rearranged.
Turn off or remove an effect from a clip
When you apply an effect to a clip, you can either turn off the effect (but retain its settings) or remove the effect from the clip.

Turn off a clip effect
1 Select the clip with the effect in the Timeline.
2 Do one of the following:
   • Choose Clip > Show Video Animation (or press Control-V) to see video effects or choose Clip > Show Audio Animation (or press Control-A) to see audio effects, select the effect, and click its checkbox.
   • Select the effect in the Video inspector or Audio inspector, and click its blue checkbox.

   The effect no longer affects the video or audio. You can click the checkbox again to turn the effect back on, with its settings still intact.

Remove an effect from a clip
1 Select the clip with the effect in the Timeline.
2 Do one of the following:
   • Choose Clip > Show Video Animation (or press Control-V) to see video effects or choose Clip > Show Audio Animation to see audio effects, select the effect, and press Delete.
   • Select the effect in the Video inspector or Audio inspector, and press Delete.

Create specialized versions of the video effects in Motion
Many of the supplied video effects were created using Motion, an Apple application designed to work with Final Cut Pro. You can open any of these effects in Motion, make modifications, and save the changes as a new effect that appears in the Effects Browser.

Important: The following steps require you to have Motion 5 installed on your computer.

Modify a video effect in Motion
1 Click the Effects button in the toolbar.

2 In the Effects Browser, Control-click the effect you want to modify, and choose “Open a copy in Motion” from the shortcut menu.

   Motion opens and the effect’s project appears.
3 Modify the effect’s project.
   See Motion Help for information on using Motion.

4 Choose File > Save As (or press Command-Shift-S), enter a name for this new effect (referred to as a Template in Motion), assign it to a category (or create a new category), choose a theme (if needed), and click Publish.

   **Note:** If you choose File > Save, the effect is saved using the same name with “copy” appended to its end.

### Add generators

#### Generators overview
Final Cut Pro includes a number of video clips, called *generators*, that you can use in your project for a variety of purposes. For example, you can use generators to add the following elements:

- **Placeholder content:** If your project is missing content that hasn’t yet been shot or delivered, you can add a placeholder clip. The placeholder generator allows you to add a clip to the Timeline with a suitable silhouette to represent the missing content. See “Use a placeholder” on page 259.

- **Timecode counter:** You can add a generated timecode clip to your project to superimpose a timecode counter over a portion or the entire project. See “Use a timecode counter” on page 260.

- **Shape clip:** You can choose from a wide variety of shapes for adding graphical elements to your project. See “Use a shape” on page 261.

- **General-purpose background clip:** Final Cut Pro includes a variety of still and animated backgrounds over which you can superimpose titles or keying effects. See “Use a background” on page 262.

All of the generators are added as clips to the project, using their default duration. You can change their duration and position the same way you would any other video clip in the Timeline.

**Note:** Generator clips do not appear in the Effects Browser.
Use a placeholder
Generated placeholders are useful in many situations where you want to fill a gap in the project with something that provides a hint about what the final content will include. You can configure placeholder clips to represent a wide variety of standard shots, such as close-ups, groups, wide shots, and so on.

Insert and configure a placeholder clip
1 Drag the playhead in the Timeline to the point where you want to add the placeholder clip.
2 Do one of the following:
   - Choose Edit > Insert Placeholder.
   - Open the Generators Browser by clicking the Generators button in the toolbar, and double-click the thumbnail named Placeholder.
3 Select the placeholder clip in the Timeline.
4 Configure the shot for the clip to represent using the settings in the Generator inspector.
5 Select View Notes to add a text area in the Viewer where you can type text that pertains to this clip.

If you prefer to fill a gap in your Timeline with a blank clip, you can insert a gap clip. For more information, see “Insert clips in your project” on page 110.
**Use a timecode counter**

When sending your project for review, it can be useful to superimpose timecode over it, making it easier for the reviewer to precisely specify sections when providing feedback.

**Insert and configure a timecode counter**

1. Open the Generators Browser by clicking the Generators button in the toolbar.

2. Drag the Timecode generator above the primary storyline.

   Usually the Timecode generator clip is placed at the start of the project, but you can place it anywhere you want it to appear and adjust its length to match the project’s length.

3. Configure the Timecode settings in the Generator inspector.

   ![Timecode settings](image)

   You can click the Reset button to return the generator to its default settings.
Use a shape
You can configure the Shapes generator to be any of a number of shapes, such as a star, a diamond, an arrow, and a heart. These are most often used above the primary storyline to add a graphical element to your project that you can animate.

Insert and configure a shape
1 Open the Generators Browser by clicking the Generators button in the toolbar.

2 Drag the Shapes generator above the primary storyline so that it is over the video clip you want the shape to appear over.
   The default shape is a white circle.
3 Choose the shape to use from the Shape pop-up menu in the Generator inspector.
4 Set the shape's fill color, outline color and width, and drop shadow.
   You can click the Reset button to return the generator to its default settings.
5 To change the shape’s size, position, and rotation, use the Transform or Distort built-in effect.

Using these effects also makes it possible to animate the shape. For example, you can have an arrow follow a person across a room.
6 To make the shape partially transparent, select it in the Timeline and adjust its Opacity setting in the Video inspector.
Use a background
Many of the generators provide a general background over which you can place built-in effects, titles, keys, and clips with an alpha channel. Some are solid colors while others are textures such as wood or stone. Some generators even have animated movement, providing a more interesting background.

Insert and configure a background clip
1 Drag the playhead in the Timeline to the point where you want to add the background clip.
2 Open the Generators Browser by clicking the Generators button in the toolbar.
3 In the Generators Browser, double-click the background thumbnail you want to use.
4 Select the background clip in the Timeline.
5 Configure the background (if applicable) using the settings in the Generator inspector.
Create specialized versions of the generators in Motion

Many of the generators were created using Motion, an Apple application designed to work with Final Cut Pro. To further customize the generators, you can open them in Motion, make modifications, and save the changes as a new file that appears in the Generators Browser.

Important: The following steps require you to have Motion 5 installed on your computer.

Modify a generator or background in Motion

1. Open the Generators Browser by clicking the Generators button in the toolbar.

2. In the Generators Browser, Control-click a thumbnail, and choose “Open a copy in Motion” from the shortcut menu. Motion opens and the clip’s project appears.

3. Modify the clip’s project.
   For more information on using Motion, see Motion Help.

4. Choose File > Save As (or press Command-Shift-S), enter a name for this new generator, and click Save.
   Note: If you choose File > Save, the generator is saved using the same name with “copy” appended to its end.
Use onscreen controls

Onscreen controls overview
Many effects, transitions, and other items use onscreen controls, superimposed over the video in the Viewer, to make it easier to adjust a variety of parameters. In many cases, these onscreen controls duplicate controls in the inspectors, although in some cases the controls are unique and provide the only way to adjust a particular parameter.

The controls can be as simple as defining the center of a fisheye effect or defining the more complex diameter, width, and position of a vignette effect.

This section focuses on the types of onscreen controls found in clip effects and transitions. Onscreen controls are also available in other areas of Final Cut Pro, including the following:

- **Built-in effects:** Onscreen controls are used extensively for all built-in effects. See “Built-in effects overview” on page 236.
- **Chroma keying:** You use specialized onscreen controls when configuring a chroma keyer. See “Use chroma keys” on page 383.
- **Color corrections:** Color corrections can contain onscreen controls used for creating color masks and shape masks. See “Manual color correction overview” on page 414.

Show or hide onscreen controls
Most of the time, the onscreen controls for transitions and clip effects only appear when you want to use them and do not appear at any other time. However, there are times when you might need to show or hide them.

**Note:** Onscreen controls are always hidden when you play clips in the Timeline.

Show or hide a transition’s onscreen controls
Do one of the following:

- **To show the transition’s onscreen controls:** Select the transition in the Timeline.
- **To hide the transition’s onscreen controls:** Deselect the transition in the Timeline.

Show or hide a clip effect’s onscreen controls
Do one of the following:

- **To show the effect’s onscreen controls:** Select the clip with the effect in the Timeline, and select the effect either in the Video Animation Editor or the Video inspector.
- **To hide the effect’s onscreen controls:** Either deselect the clip with the effect in the Timeline or deselect the effect in the Video Animation Editor or Video inspector.
Onscreen control examples
Following are a few examples of the onscreen controls you might use while working with clip effects and transitions. Many other clip effects and transitions use these same or similar controls—the examples are intended to provide general information about using the onscreen controls.

Keep the following in mind while going through these examples:
• These examples assume you are familiar with applying clip effects to clips in the Timeline.
• You can apply multiple clip effects to the same clip, but for the purpose of these examples, it’s best to either apply each clip effect to a different Timeline clip or remove the clip effect before applying a different one.
• These examples also assume you are familiar with adding transitions to edit points in the Timeline.
• Most of the effects and transitions have additional adjustments in the Video inspector or Transition inspector.

Example: Use onscreen controls to apply a Censor effect
1 Open the Effects Browser and drag the Censor effect to a clip in the Timeline.
2 To adjust the effect’s onscreen controls, do either of the following:
   • To position the effect: Drag the center circle.
   • To set the effect’s size: Drag the outer circle.
Example: Use onscreen controls to apply a Droplet effect

1. Open the Effects Browser and drag the Droplet effect to a clip in the Timeline.

2. To adjust the effect’s onscreen controls, do any of the following:
   
   - To *position the effect*: Drag the center circle.
   - To *set the effect’s outer limit*: Drag the outer circle.
   - To *set the effect’s inner limit*: Drag the inner circle.
   - To *set the effect’s overall size*: Drag any area in between the inner and outer circles. A shaded area appears when the pointer is in this area.
Example: Use onscreen controls to apply a Prism effect
1. Open the Effects Browser and drag the Prism effect to a clip in the Timeline.
2. To adjust the direction of the effect, drag the arrow.
   Because the effect has no center setting, the circle in the center cannot be dragged.

Example: Use onscreen controls to apply a Scrape effect
1. Open the Effects Browser and drag the Scrape effect to a clip in the Timeline.
2. To adjust the effect’s onscreen controls, do either of the following:
   • *To position the effect*: Drag the center circle.
   • *To set the effect’s direction*: Drag the rotation handle.
Example: Use onscreen controls to apply a Center transition

1 Open the Transitions Browser and drag the Center transition to an edit point in the Timeline.

2 To adjust the transition’s onscreen controls, do any of the following:
   - To position the transition: Drag the center circle.
   - To set the transition’s direction: Drag the arrow.
   - To set the transition’s border width (softness in this case): Drag the outer handle toward or away from the center circle.
Example: Use onscreen controls to apply a Star transition

1  Open the Transitions Browser and drag the Star transition to an edit point in the Timeline.

2  To adjust the transition's onscreen controls, do any of the following:
   • *To position the transition:* Drag the center circle.
   • *To set the number of points on the star:* Drag the longer handle.
   • *To rotate the star:* Drag the shorter handle.
Example: Use onscreen controls to apply a Zoom & Pan transition

1. Open the Transitions Browser and drag the Zoom & Pan transition to an edit point in the Timeline.

2. To adjust the transition’s onscreen controls, do either of the following:
   - To set the transition’s start point: Drag the green circle.
   - To set the transition’s end point: Drag the red circle.

Use the Video Animation Editor

Video animation overview

With Final Cut Pro, you can create simple changes to video over time, such as fading the video from invisible to visible at the beginning of a movie. Or you can make sophisticated and precise adjustments over time to many individual parameters of video effects, transitions, motion paths, and so on.

In Final Cut Pro, you use keyframes and fade handles in the Video Animation Editor to change effects over time.
The word *keyframe* comes from the traditional workflow in the animation industry, where only important (key) frames of an animated sequence were drawn to sketch a character’s motion over time. Once the keyframes were determined, an in-between artist drew all the frames between the keyframes.

With Final Cut Pro, you can set parameters to specific values at specific times (represented by keyframes) and Final Cut Pro acts as an automatic, real-time in-between artist, calculating all the values between your keyframes. For example, to animate a parameter, such as a rotation or scale setting, you need to create at least two keyframes in the clip. Final Cut Pro figures out the setting’s value between the keyframes, creating a smooth motion as the setting changes.

You can keyframe and animate both video and audio effects in Final Cut Pro, including individual effect parameters and clip properties. To learn more about keyframing audio, see “Adjust audio effects using keyframes” on page 181.

**Adjust video effects using keyframes**

You place keyframes at specific points in a clip to change parameter values at those points.

For example, if you want a clip in your project to fade to black, you set two opacity keyframes at two different times: one with the value of 100 (fully visible) and a second with the value of 0 (fully transparent). Final Cut Pro interpolates the values between 100 and 0, creating a smooth fade to black.

You can set keyframes in the Timeline or in the Video inspector. To see keyframes in the Timeline, you need to display the Video Animation Editor for the clip.

Additional keyframing controls appear with the Final Cut Pro built-in effects. See “Work with built-in effects” on page 244.

For information about keyframes for audio clips, see “Adjust audio effects using keyframes” on page 181.
Add keyframes

1 Select the clip in the Timeline, and do one of the following:
   - Choose Clip > Show Video Animation (or press Control-V).
   - Click the upper-left corner of a clip to open the Adjustments pop-up menu, and choose Show Video Animation.

Each effect in the Video Animation Editor has a separate area for adding keyframes.

Some effects have more than one parameter and allow you to add keyframes to individual parameters separately. They appear in the Video Animation Editor with a triangle next to the effect’s name or in the Video inspector as additional parameter controls.
2 Select the effect for which you want to add keyframes in either the Video Animation Editor or the Effects section of the Video inspector.

3 Do one of the following:
   - To see expanded parameters in the Video Animation Editor: Click the triangle to choose an individual parameter from the pop-up menu, or choose All to add keyframes for all parameters.
   - To see expanded parameters in the Video inspector: Click Show when you position the pointer over the effect.

4 Do one of the following for each effect:
   - In the Video Animation Editor: Option-click (or press Option-K) at a point on the horizontal effect control where you want to add the keyframe. Keyframes for the parameter you chose appear as white diamonds, while keyframes for other effect parameters appear gray.

When you choose to view all parameters in the Video Animation Editor, keyframes appear as white diamonds for all parameters. Double diamonds indicate you added a keyframe for more than one parameter at that point.

- In the Video inspector: Position the playhead in the Timeline at the point where you want to add a keyframe, and click the Keyframe button (or press Option-K). Once you add a keyframe, the Keyframe button changes to yellow, indicating that the playhead currently sits on this keyframe.
When you move the playhead in the Timeline, arrows appear next to the Keyframe button in the Video inspector to indicate which side of the playhead has keyframes. To go to the previous keyframe, click the left arrow or press Option-Semicolon (;). To go to the next keyframe, click the right arrow or press Option-Apostrophe (’).

5 Add keyframes as needed.

Tip: After you’ve added one keyframe, you can add another automatically by moving the playhead in the Timeline and then adjusting the effect parameter value in the Video inspector.

Add keyframes automatically across a selected area
If an effect appears in the Video Animation Editor with a disclosure button, you can use either the Select or Range Selection tool to add keyframes automatically for an adjustment you make over a selected area.

1 Select the clip in the Timeline, and do one of the following:
   • Choose Clip > Show Video Animation (or press Control-V).
   • Click the upper-left corner of a clip to open the Adjustments pop-up menu, and choose Show Video Animation.
2 Select an effect, and click the disclosure button to expand it in the Video Animation Editor.

![Disclosure button](image)

3 In the Timeline, choose either Select or Range Selection from the Tools pop-up menu in the toolbar (or press A for Select, or R for Range Selection).

4 Drag across the area in the Video Animation Editor where you want to adjust the effect.
5 Adjust the effect within the range by dragging the effect’s horizontal control up or down.

Keyframes are automatically created along the adjustment points within the range.
Adjust keyframes in the Video Animation Editor
You can move keyframes left or right in the Video Animation Editor. If an effect appears with a disclosure button, you can expand the effect view and move keyframes up or down to change the parameter value.

1 Select a keyframe.

2 Do one of the following:
   - To change its position in the Video Animation Editor, drag a keyframe left or right. As you drag, the timecode value appears.

[Image of Video Animation Editor with keyframe selection and drag handles]

   - If an effect appears with a disclosure button, click the button (or double-click the effect) to expand it.

[Image of Video Animation Editor with disclosure button]

With the effect expanded, you can drag the keyframe up or down to change the effect’s parameter value.
**Tip:** To adjust values with greater precision, hold down the Command key while dragging the keyframe up or down.

To add another keyframe, Option-click (or press Option-K) at a point on the effect control where you want to add the keyframe. To add a keyframe and change the effect’s parameter value at the same time, Option-click while dragging the effect control up or down.

If an effect appears with a disclosure button in the Video Animation Editor, you can also fade video effects in or out, or change the shape of the effect curve between keyframes.

**Adjust keyframes in the Video inspector**

For many effects, you adjust the parameter value of individual keyframes using the Video inspector.

When you move the playhead in the Timeline, arrows appear next to the Keyframe button in the Video inspector to indicate which side of the playhead has keyframes. To go to the previous keyframe, click the left arrow or press Option-Semicolon (;). To go to the next keyframe, click the right arrow or press Option-Apostrophe (').

1. Select a keyframe or position the playhead on a keyframe, and adjust the parameter value in the Video inspector.

2. To change the value at the next keyframe, go to the next keyframe and adjust the value again.
View only one effect at a time in the Video Animation Editor
You can collapse the Video Animation Editor to view only one effect at a time. This can be useful if you have multiple effects applied to a clip and want to preserve screen space.

1 Choose Clip > Solo Animation (or press Shift-Control-V).
2 In the Video Animation Editor, click the triangle next to the displayed effect’s name to choose an effect from the pop-up menu.

*Note:* When Solo Animation is turned on, you can’t delete effects from the Video Animation Editor.

To turn off Solo Animation, choose Clip > Solo Animation (or press Shift-Control-V).

Delete keyframes
Do one of the following:

- Select a keyframe in the Video Animation Editor, and press the Delete key.
- Navigate to a keyframe in the Video inspector, and click the Keyframe button.
**Hide video animation**

1. Select the clip in the Timeline.

2. Do one of the following:
   - Choose Clip > Hide Video Animation (or press Control-V).
   - Click the close button in the upper-left corner of the Video Animation Editor.
   - Click the upper-left corner of a clip to open the Adjustments pop-up menu, and choose Hide Video Animation.
Adjust effect curves using fade handles or keyframe animation
Some effects in the Video Animation Editor include fade handles. These allow you to fade the effect in or out. You can also move keyframes up or down to create a curve for the effect parameter and change the curve shape (interpolation) between keyframes.

Creating a fade or an effect curve smooths the transition so the effect changes appear more natural when the clip plays.

Change an effect using fade handles
1 Click the disclosure button to expand the effect in the Video Animation Editor.

Note: If an effect doesn’t have a disclosure button, it doesn’t have fade handles.

2 Drag the fade handle to the point in the clip where you want the fade to begin or end. Fade handles from the beginning of a clip create a fade-in, while fade handles at the end of a clip create a fade-out.
Change an effect using keyframes

- Click the disclosure button to expand the effect in the Video Animation Editor, and do either of the following:

![Disclosure button]

*Note:* If an effect doesn’t have a disclosure button, you can’t move keyframes up or down.

- To *add a keyframe:* Option-click (or press Option-K) at a point on the effect control where you want to add the keyframe.

*Tip:* To add a keyframe and change the effect’s parameter value at the same time, Option-click while dragging the effect control up or down.

- To *change the effect’s parameter value at a particular keyframe:* Select a keyframe and drag it up or down.

*Tip:* To adjust values with greater precision, hold down the Command key while dragging the keyframe up or down.
Change the curve shape (interpolation) between keyframes
Do one of the following:

- Drag the line horizontally between the keyframes to create a curve. To adjust the curve with greater precision, hold down the Command key while dragging.
- Control-click the line between keyframes, and choose a curve option from the shortcut menu.

- **Linear**: Maintains a constant rate of change over the duration of the fade.
- **Ease**: Eases in and out of the fade with the midpoint set between the beginning and end values.
- **Ease In**: Starts slowly from the beginning value and then moves quickly toward the end value.
- **Ease Out**: Starts quickly from the beginning value and then slowly tapers off toward the end value.

**Note**: You can change the curve shape between keyframes for video effects only. For audio volume only, you can change the curve shape for fades created using fade handles, but not keyframes. See “Fade audio in or out” on page 197.
Adjust all keyframes on a curve

- Hold down the Command and Option keys, and drag either a keyframe or the curve up or down.

All keyframes are adjusted by the same amount, preserving the original shape of the curve.
Group clips with compound clips

Compound clips overview
With Final Cut Pro, you can create *compound clips*, which allow you to group any combination of clips in the Timeline or the Event Browser and nest clips within other clips.

Compound clips can contain video and audio clip components, clips, and other compound clips. Effectively, each compound clip can be considered a mini project, with its own distinct project properties. Compound clips function just like other clips: you can add them to your project, trim them, retime them, and add effects and transitions.

You can open any clip in the Timeline to edit its contents. When you add media (clips) to the contents of a standard clip, the clip automatically becomes a compound clip. Icons appear on compound clips in the Event Browser and the Timeline.

Compound clip icon for a clip in the Event Browser

Compound clip icon for a clip in the Timeline

Compound clips have many uses. You can:

- Simplify a complicated project by creating a separate compound clip for each major section.
- Synchronize a video clip with one or more audio clips and then combine the clips into a compound clip, to avoid inadvertently moving them out of sync.
- Open any clip, edit its contents in the Timeline, and then close it.
• Quickly create a compound clip containing the clips in an Event, based on the Event Browser sort order.
• Use a compound clip to create a section of a project with settings different from those of the main project.

The following diagram shows how a project in the Timeline could be simplified using compound clips:

**Selected clips in the Timeline**

[Diagram of selected clips in the Timeline]

**New compound clip**

[Diagram showing creation of a new compound clip]

**Note:** Compound clips in Final Cut Pro X provide all functionality of the nested sequence feature in Final Cut Pro 7, with more flexibility and ease of use.

**Create and break apart compound clips**

You can create a compound clip from existing clips in the Timeline or the Event Browser, or you can create a new, empty compound clip and add clips to it. You can also break a compound clip into its component parts in the Timeline, so that the items are no longer grouped.

**Create a compound clip from existing clips**

1 Select one or more clips in the Timeline or the Event Browser.

The selected clips can be any combination of contiguous or noncontiguous clips, compound clips, primary storyline clips, or connected clips.
2. Do one of the following:
   - Choose File > New Compound Clip (or press Option-G).
   - Control-click the selection and choose New Compound Clip from the shortcut menu.

The way clips are grouped within the compound clip depends on where you selected the clips:

- *If you selected clips in an Event*: Final Cut Pro creates a new compound clip in the Event (in addition to the selected clips) and places duplicates of the selected clips in the new compound clip horizontally, in the order in which you selected them. (For further instructions on creating a compound clip in the Event Browser, see “Create an empty compound clip” below.)
• If you selected clips in the Timeline: Final Cut Pro places the selected clips in the new compound clip exactly as they are laid out in the Timeline. The new compound clip inherits the frame size and frame rate of the current Timeline.
Create an empty compound clip
You can create new, empty compound clips and then add clips to them. Each compound clip can be considered a mini project, with its own distinct project properties.

1 In the Event Library, select an Event to which you want to add the compound clip.

2 Choose File > New Compound Clip.

In the window that appears, type a name for the compound clip in the Name field.

3 Click Use Custom Settings to further customize settings for your compound clip.

   Note: Final Cut Pro shows the Automatic Settings by default, but it will remember the settings you used last, so this step may be unnecessary.

4 By default, Final Cut Pro sets the Starting Timecode field to the lowest timecode value in the selected clips. If you want the compound clip's timecode to start at a different value, type that starting timecode value in the Starting Timecode field.

5 To adjust video, audio, and render settings, click Custom. Unless you have a specific requirement for the compound clip you’re creating, it’s best to leave “Set automatically based on first video clip” and “Use default settings” selected.

6 Click OK.

The new compound clip appears in the Event.
Edit the contents of a standard clip in the Timeline
You can edit the contents of a standard clip. When you add clips to the contents of a
standard clip, you automatically create a compound clip.

- Select a clip in the Event Browser or the Timeline, and choose Clip > Open in Timeline.

The Timeline displays the contents of the clip. Most standard clips include a video
component, an audio component, or both. You cannot edit the contents of these video
and audio components.

If you add media to the contents of this clip (by adding clips to this Timeline), the clip
becomes a compound clip. If you then close this clip by navigating up one level in the
Timeline history, you see the icon indicating that this clip is now a compound clip.

Note: Because editing in Final Cut Pro is nondestructive, any changes you make to the
contents of standard or compound clips do not affect the corresponding source media
files, which remain unchanged on your computer’s hard disk. For more information
about the difference between media files and clips, see “Media files and clips” on
page 21.

Break apart clip items
You can break apart a compound clip or a standard clip to convert its contents to
individual clips in the Timeline.

- Select a compound clip or a standard clip in the Timeline, and choose Clip > Break
Apart Clip Items (or press Command-Shift-G).

Final Cut Pro replaces the clip selected in the Timeline with the individual items that
made up the clip.

If you selected a compound clip, its contents revert back to the original clips that
made up the compound clip.

If the selected clip is a standard clip, the contents appear as individual clips in the
Timeline. Most standard clips include a video component or an audio component or
both. The audio will appear as a connected clip.
Manage compound clips
There are many ways to manage and edit compound clips. For example, you can open up compound clips (and edit their component parts) in a separate Timeline. You can easily navigate up and down a series of compound clip levels. And you can open and edit a compound clip from within an Event.

Open a compound clip for editing
Do one of the following in the Timeline or the Event Browser:

- Select a compound clip in the Timeline or the Event Browser, and choose Clip > Open in Timeline.
- Double-click the video portion of a compound clip.
- Click the compound clip icon in the upper-left corner of a compound clip in the Timeline.

The compound clip opens in a new Timeline view, with its contents ready for editing.

Note: Because editing in Final Cut Pro is nondestructive, any changes you make to the contents of standard or compound clips do not affect the corresponding source media files, which remain unchanged on your computer’s hard disk. For more information about the difference between media files and clips, see “Media files and clips” on page 21.
Navigate compound clip levels using menu commands and keyboard shortcuts
To navigate up or down one or more levels of a compound clip, do one of the following:

- **To move forward (down one level):** Choose View > Go Forward in Timeline History, or press Command-Right Bracket (]).
- **To move back (up one level):** Choose View > Go Back in Timeline History, or press Command-Left Bracket ([).

Navigate compound clip levels using the arrow buttons
Do one of the following:

- Click the left and right arrows in the upper-left corner of the Timeline.

- Click and hold the right or left arrow in the upper-left corner of the Timeline, and choose a level from the pop-up menu.

The left arrow effectively closes the current compound clip and opens its parent, with the top level being the project or Event containing the compound clip. If there is no history available to navigate, both the left and right arrows are dimmed.
Make sure all contents of a compound clip appear in your movie
When you’re editing the contents of a compound clip, Final Cut Pro indicates the boundary of the compound clip with a dark gray, cross-hatched area to the left of the start point of the clip and to the right of the end point of the clip.

If you add clips to the contents of the compound clip, any parts of any clips that extend into the dark gray area do not appear in your project.

To have the new clip material appear in your project, do one of the following to make room for the new material:

- Reduce the total duration of the other clips inside the compound clip. For example, you could trim one or more clips inside the compound clip.
- Close the compound clip to navigate up one level, and extend the total duration of the parent clip (the "outside shell" of the compound clip) in the Timeline.

For more information, see “Trimming overview” on page 134.
Add storylines
Storylines are sequences of clips connected to the primary storyline. They combine the convenience of connected clips with the precision editing capabilities of the primary storyline.

You can use storylines for the same purposes as connected clips (such as creating cutaways, compositing titles and other graphics, and adding sound effects and music).

The unique advantage of storylines is the ability to edit a sequence of connected clips within the context of the other clips in the Timeline. For example, you can add cross dissolve transitions to a series of superimposed titles in a storyline and then adjust the timing of the titles to match clips in the primary storyline. Like connected clips, storylines can contain both video and audio, or they can be video only or audio only.

You edit storylines using the same methods you use to edit the primary storyline. You can:

- **Add clips**: Drag clips to the storyline to add them, or use the standard append, insert, replace, and overwrite commands.
- **Add transitions, titles, effects, and generators**: Add effects to a storyline by dragging them or by using any of the standard commands and keyboard shortcuts.

  **Note**: When you apply a transition to a clip connected to the primary storyline, a storyline is automatically created for that clip.
- **Trim clips:** Use any of the standard trim edits in a storyline, including ripple, roll, slip, and slide. You can also trim or move clips within storylines by entering timecode values.

- **Create split edits:** Set separate video and audio start and end points in an individual clip to create split edits (L-cuts and J-cuts) in a storyline.

**Create or break apart storylines**
You can quickly create storylines from existing connected clips.

1. In the Timeline, select two or more connected clips.

2. Choose Clip > Create Storyline (or press Command-G).

A gray border appears around the clips, indicating a storyline.

*Note:* If the original connected clips are not contiguous, Final Cut Pro inserts a gap clip to fill the space between the clips.
You can also create a storyline by holding down the G key as you drag a clip to a connected clip so that their edges touch:

3 To convert a storyline back to its component clips, do one of the following:
   - Select the storyline (by clicking the gray border), and choose Clip > Break Apart Clip Items (or press Command-Shift-G).
   - Drag the storyline into the primary storyline.
Select and move storylines
You can select or move entire storylines as if they were standard clips or compound clips. They have the connection properties of connected clips.

- **To select an entire storyline:** Click the gray border of the storyline.
- **To move a storyline by dragging it:** Click the gray border of the storyline, and drag it left or right to connect it to a different point along the primary storyline.

- **To move a storyline with timecode values or keyboard shortcuts:** Use the same techniques you would use with standard clips.

  For more information, see “Arrange clips in the Timeline” on page 126.
Fine-tune edits with the Precision Editor

You can fine-tune the edit point between two clips in the Timeline using the Precision Editor, which provides an expanded view of the clips on either side of the edit point as well as the unused portions of each clip. You can trim or extend the end of one clip and the beginning of the next, either separately or together. As you make changes, you can instantly see how your edits affect the cut or transition from one clip to the next.

You can see a “two-up” display in the Viewer as you trim edit points in the Timeline. For more information, see “Show detailed trimming feedback” on page 154.

Adjust the edit point between clips with the Precision Editor

1 Choose either the Select tool or the Trim tool from the Tools pop-up menu in the toolbar, and double-click the edit point you want to trim in the Timeline.

The Precision Editor appears, presenting an expanded view of your outgoing and incoming shots. The edit point is represented by a vertical line in the center of the Precision Editor. The outgoing clip and the clips before it appear in the top part of the storyline. The incoming clip and the clips after it appear in the bottom part.

The dimmed portions of clips to the right and left of the edit line are the unused portions of media that are available for trimming (called *media handles*). You can skim over these areas to view and play back the media to help you decide where to trim.
To adjust the edit point, do any of the following:

- Move the edit line in the center of the Precision Editor by dragging its handle left or right.

Moving the entire edit line performs a roll edit.
- Drag the end point of the outgoing clip or the start point of the incoming clip. This performs a ripple edit.

**Note:** You can drag the edit line or individual edit points to the extent that there are media handles available. When you extend a clip to its maximum length in either direction, the clip edge turns red.

- Skim over and click the outgoing clip or the incoming clip at any point.
The clip's edit point is adjusted to the frame you click. This is the equivalent of a ripple edit.

You can also enter a timecode value to adjust the edit point numerically. If you select either the end point of the outgoing clip or the start point of the incoming clip, a ripple edit is performed. Otherwise, a roll edit is performed.

3 To navigate to another edit point, do one of the following:
   • *To go directly to an edit point:* Click the other edit point.
   • *To go to the next or previous edit point:* Press the Up Arrow or Down Arrow key.

4 To close the Precision Editor, do one of the following:
   • Double-click the current edit point, or press the Esc (Escape) key.
   • Click the Close Precision Editor button at the bottom-right corner of the Timeline.
Create split edits

Final Cut Pro allows you to set separate video and audio start and end points in an individual clip. These edits, known as split edits, can be used in many different situations—in dialogue scenes, when cutting to illustrative B-roll footage during an interview, or when transitioning from one scene to another.

You can use a split edit to introduce the sound of a new shot or scene before cutting to the video of that shot or scene. Conversely, you can use a split edit to extend the audio of a shot over a subsequent shot. For example, you could cut from a clip of a person talking to video of a person listening, while the audio from the first clip continues.

The split edit technique results in L-shaped and J-shaped clips with audio extending to the left or the right. These are known as L-cuts and J-cuts.

Note: Whenever you use split edits in a project, it’s recommended that you choose View > Expand Audio/Video Clips > For Splits (so that there’s a checkmark next to the menu item). This setting provides you with the most accurate display of all your split edits.

Create a split edit by dragging

To create the split edit, you extend the audio of one clip over a neighboring clip. In this example, the audio from the close-up of the man is extended over the close-up of the woman to create a J-cut.

1 Add clips to the Timeline in the order in which you want them to appear in your movie.

2 To show separate audio for the clip you want to edit, do one of the following:
   • In the Timeline, select the clip whose audio you want to expand, and choose Clip > Expand Audio/Video (or press Control-S).
   • Double-click the clip’s audio waveform.
The audio and video portions of the clip appear as discrete components that you can change individually. They are still attached and will remain in sync.

3 Drag the start point (left edge) of the video portion of the clip to the right, effectively trimming it with a ripple edit.

The example below shows the video start point of the close-up of the man being dragged to the right.

This creates a J-shaped split edit, with the start point of the audio overlapping the preceding clip.
To complete the split edit, show separate audio for the preceding clip, and do one of the following:

- Drag the preceding clip’s end point to the left so that the two audio clips no longer overlap.

- Adjust the audio (fade) level of either clip so that the audio overlap sounds natural.
5 If you want to turn off the separate audio view to “clean up” the affected clips, do one of the following:

- Choose View > Collapse All Clips.
- Select the clip in the Timeline, and choose Clip > Collapse Audio/Video (or press Control-S).
- Double-click the clip’s audio waveform.

When you play back this section of the Timeline, you hear the man begin to speak before the video cuts to the close-up of him. In this way, you can use split edits to create seamless edits from one shot to the next.
Create a split edit using keyboard shortcuts
You can create split edits quickly using keyboard shortcuts. In this example, the audio from the close-up of the man is extended over the close-up of the woman to create a J-cut.

1 Confirm that the two adjacent clips have sufficient media handles. If not, trim the clips (shorter) to create the media handles.

2 To expand (show separate audio) for the two adjacent clips, do one of the following:
   • In the Timeline, select the clips whose audio you want to expand, and choose Clip > Expand Audio/Video (or press Control-S).
   • Double-click the clip’s audio waveform.
3  Move the playhead to the edit point between the two clips.

To ensure accurate playhead placement, use keyboard shortcuts:
- *To move the playhead to the previous edit point*: Press Semicolon (;) or the Up Arrow key.
- *To move the playhead to the next edit point*: Press Apostrophe (’) or the Down Arrow key.

4  Do one of the following:
- *To select both sides of the audio edit point*: Press Shift-Backslash (\).
- *To select both sides of the video edit point*: Press Backslash (\).
To roll the audio edit point or the video edit point, do any of the following:

- To nudge the edit point left or right: Press Comma (,) or Period (.), respectively.
- To nudge the edit point 10 frames left or right: Press Shift-Comma (,) or Shift-Period (.), respectively.
- To add or subtract from the current edit using timecode: Press Plus Sign (+) or Minus Sign (–) followed by the timecode duration, and press Return.

The timecode entry field (with blue numbers) appears in the Dashboard in the toolbar as you type. For more information about entering timecode values, see “Navigate using timecode” on page 161.

When you play back this section of the Timeline, you hear the man begin to speak before the video cuts to the close-up of him. In this way, you can use split edits to create seamless edits from one shot to the next.

Make three-point edits

Three-point editing overview

Three-point editing allows you to use start and end points in the Event Browser and the Timeline to specify the duration of a clip and where it should be placed in the Timeline. Three-point editing gets its name from the fact that only three edit points are necessary to determine the portion of the source clip to use and where to place that clip in the Timeline. Final Cut Pro infers the fourth edit point automatically. The result of the edit depends on which three points are set in the Event Browser and in the Timeline: two start points and one end point or one start point and two end points.
You can use three-point editing with the following types of edits:

- Insert
- Connect
- Overwrite

With each of these edit types, you can also perform *backtimed* three-point edits, in which the end point (rather than the start point) is aligned with the skimmer or playhead position in either the Event Browser or the Timeline. You can also make two-point edits in which start and end points are inferred from the skimmer position and the clip duration.

To make three-point edits, it’s important to know how to make selections and how to use the skimmer and the playhead. For more information about making selections, see “Select a range” on page 105 and “Select one or more clips” on page 103. For more information about the skimmer and the playhead, see “Playback and skimming overview” on page 82.

Basic three-point editing has three stages:

**Stage 1: Set source selection edit points in the Event Browser**

Specify which part of a clip you want to place in the Timeline. You do this by setting the start and end points. If you want to set just a start point in the Event Browser, position the skimmer (or playhead) at the point where you want the edit to begin. In this case, the end point is determined by the start and end points set in the Timeline or by the end of the clip. You can also select multiple clips in the Event Browser, and their aggregate source media duration determines the start and end points.

**Stage 2: Set edit points in a storyline in the Timeline**

Specify where you want the clip to appear in the Timeline by setting start and end points in the primary storyline or in a connected storyline. If both start and end points are set in the Timeline, these edit points determine the edit duration, regardless of the duration set in the Event Browser. If no start or end points are set in the Timeline, Final Cut Pro uses the skimmer position for the start point of the edit. If the skimmer is not present, Final Cut Pro uses the playhead position.

*Important:* With few exceptions, three-point editing requires range selections (rather than clip selections).
Stage 3: Add the source clip or selection to the Timeline
Choose to either insert, connect, or overwrite.

**Important:** Timeline start and end points always take precedence over start and end points set in the Event Browser. This means that if you set both a start point and an end point in the Timeline, the Timeline start and end points determine the duration of the edit, regardless of the start and end points in the Event Browser. This allows you to limit your edit to a specific section of the Timeline.

There are a few key things to keep in mind when making three-point edits.

<table>
<thead>
<tr>
<th>Edit points set</th>
<th>Results</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Source selection start and end points in the Event Browser&lt;br&gt;• Destination start point in the Timeline</td>
<td>The start point of the source selection in the Event Browser is aligned with the destination start point in the Timeline, and the duration of the edit is determined by the source selection start and end points in the Event Browser.</td>
</tr>
</tbody>
</table>
| • Source selection start point in the Event Browser<br>• Destination start and end points in the Timeline | The start point of the source selection in the Event Browser is aligned with the destination start point in the Timeline, and the duration of the edit is determined by the destination start and end points in the Timeline.  
  
  **Note:** This edit requires a range selection in the Timeline. You can use the Range Selection tool or the I and O keys for this purpose. For more information about making range selections, see “Select a range” on page 105. |
| • Source selection start and end points in the Event Browser<br>• Destination end point in the Timeline | The end point of the source selection in the Event Browser is aligned with the destination end point in the Timeline, and the duration of the edit is determined by the source selection start and end points in the Event Browser.  
  
  This is known as “backtiming” an edit. Use this method when you want to make sure a clip ends at a specific point in the project. |
| • Source selection end point in the Event Browser<br>• Destination start and end points in the Timeline | The end point of the source selection in the Event Browser is aligned with the destination end point in the Timeline, and the duration of the edit is determined by the destination start and end points in the Timeline.  
  
  This is known as “backtiming” an edit. Use this method when you want to make sure a clip ends at a specific point in the project.  
  
  **Note:** This edit requires a range selection in the Timeline. You can use the Range Selection tool or the I and O keys for this purpose. For more information about making range selections, see “Select a range” on page 105. |
Three-point edit examples

In Final Cut Pro, you can make precise edits using a combination of three (or sometimes two) edit points set in the Event Browser and the Timeline. For more information, see “Three-point editing overview” on page 308.

Here are a few examples of ways to make three-point edits.

Example: Make a three-point edit

The simplest way to perform a three-point edit is to specify start and end points for the source selection in the Event Browser, and then specify the destination start point in your project by positioning the skimmer (or the playhead) in the Timeline.

1. Set start and end points for the source selection in the Event Browser.

2. In the Timeline, position the skimmer (or the playhead, if the skimmer is not present) at the location in your project where you want the clip to start (the destination start point).
To add the source selection to the project using an overwrite edit, press D.

The portion of your source selection between the start and end points appears in the Timeline, starting at the skimmer position.

By defining only three points—the source selection start and end points in the Event Browser and the destination start point in the Timeline—you have total control of the edit.

**Example: Make a backtimed three-point edit**
You can make a three-point edit by defining source selection start and end points in the Event Browser and a destination end point (instead of a destination start point) in the Timeline. This is called *backtiming* a clip. You can use this method when you want to make sure a particular clip ends at a specific point in a project, on a musical beat. In the resulting edit, the end point of the media in the Event Browser selection is aligned with the end point you set in the Timeline, and the rest of the source selection appears to the left.

1. Set start and end points for the source selection in the Event Browser.
In the Timeline, position the skimmer (or the playhead, if the skimmer is not present) at the location in your project where you want the clip to end.

Do either of the following:

- To backtime the selection using a connect edit: Press Shift-Q.
- To backtime the selection using an overwrite edit: Press Shift-D.

Your source selection is edited into the project so that the end point of the media in your source selection lines up with the end point you specified in the Timeline.

The rest of your clip has overwritten any material to the left of the end point for the duration defined by the source selection start and end points set in the Event Browser.
Example: Make a three-point edit with multiple clips
You can make three-point edits with multiple clips at a time.

1 In the Event Browser, select two or more clips. (Don’t select a range within a single clip.)

For information about selecting multiple clips, see “Select one or more clips” on page 103.

2 In the Timeline, define a destination start point by positioning the skimmer at the location in your project where you want the clip or group of clips to start.

3 To add the selected clips to the project using an overwrite edit, press D.
The entire group of clips selected in the Event Browser has been edited into the project.

**Note:** The clips are added in the order in which you selected them.

Because you used an overwrite edit, any clip items already in the project are overwritten by the clips selected in the Event Browser for the duration of the Event Browser clips.

You can also make a three-point edit involving multiple clips in the Timeline. To select a range across multiple clips in the Timeline, you use the Range Selection tool or the I and O keys. For more information about range selections, see “Select a range” on page 105.

**Example: Make a two-point edit**

You can make an edit without any selections in either the Event Browser or the Timeline. This is known as a **two-point edit**. In this case, Final Cut Pro acts on the current clip in the Event Browser from the position of the skimmer or playhead to the end of the clip, and on the project in the Timeline from the position of the skimmer or playhead forward.

You can also make backtimed two-point edits, in which Final Cut Pro acts on the current clip in the Event Browser and the project in the Timeline from the skimmer or playhead position back.

In either case, the duration of the edit is determined by the skimmer or playhead position and the end of the clip in the Event Browser.

1 To specify a source selection start point in the Event Browser, move the skimmer or playhead to the location where you want the edit to start (but don’t make any selections).
2 To specify a destination start point in the Timeline, move the skimmer or playhead to the location where you want the edit to start (but don’t make any selections). The skimmer position in the Timeline is the destination start point.

3 To add the clip to the project using an overwrite edit, press D. The new clip starts where the skimmer was positioned. The new clip starts where the skimmer was positioned.
Try out clips using auditions

Auditions overview
In Final Cut Pro you can organize related clips into sets, called auditions, from which you can choose one clip to use. You can create an audition composed of different clips to try out multiple takes, or you can create an audition composed of multiple versions of the same clip to preview different effects. Auditions appear in the Event Browser and Timeline as clips with an Audition icon in the upper-left corner.

The audition's filmstrip displays the currently selected clip, called the pick. All other clips in the audition are referred to as alternates. You can open an audition to see the selected clip and the alternates.
Auditions allow you to preserve your alternate edits without affecting the other clips in the Timeline. When you’re not auditioning the clips in an audition, the audition functions like an individual clip. You can trim an audition, apply transitions between auditions and other clips, and add keywords and markers. You can keep your audition containing your alternate clips for as long as is necessary.

After you’ve reviewed the clips in the audition and decided which one works best in your project, you can finalize the audition, which dissolves it and leaves the pick as an individual clip in the Timeline. The pick retains the audition’s position in the Timeline and all keywords and markers applied to the audition.

Create auditions to try out clips
You can create auditions in the Event Browser and then add them to the Timeline, or you can create auditions directly in the Timeline. When you create auditions in the Timeline, you can either group related clips or group multiple versions of the same clip (for example, to try out multiple effect treatments or lower-third titles).

Create auditions in the Event Browser
- Select the clips you want to include in the audition, and choose Clip > Audition > Create (or press Command-Y).
Create auditions in the Timeline

- **To create an audition with related clips:** Drag a clip or a group of clips from the Event Browser onto a clip in the Timeline, and choose an audition option from the shortcut menu.

Choosing Add to Audition creates an audition with the current Timeline clip as the pick. Choosing Replace and Add to Audition makes the clip you’re dragging the pick.

**Important:** If a transition is applied to the current clip in the Timeline and the pick for the new audition lacks sufficient media for the transition, the transition is either shortened or removed.

- **To create an audition with a duplicate version of a clip, including applied effects:** Select a clip in the Timeline, and choose Clip > Audition > Duplicate as Audition.

An audition is created containing the selected clip and a duplicate version that includes any effects applied to the original.

- **To create an audition with a duplicate of the original version of a clip, without applied effects:** Select a clip in the Timeline, and choose Clip > Audition > Duplicate from Original.

An audition is created containing the selected clip and a duplicate version without any applied effects.

**Open an audition**

After you create an audition, it’s easy to open it and review its contents.

Do one of the following:

- Choose Clip > Audition > Open (or press Y).
- Click the Audition icon.

The Audition window appears, and you can preview your clips to choose a pick.
Add and remove clips in auditions
When building auditions to try out different clips or versions of a clip with different effects, you can add and remove clips at any time. In the Event Browser and the Timeline, you can add new clips to the audition as well as duplicate clips within an audition. When an audition in the Timeline contains the clips you want to try out, you can use the audition to preview the clips or effects in your project.

Add clips to an audition in the Event Browser
- To add new clips to an audition in the Event Browser: Select the audition and the clips you want to add to it, and choose Clip > Audition > Create (or press Command-Y).

- To duplicate a clip within an audition in the Event Browser: Click the icon in the upper-left corner of the audition to open the Audition window, select the clip you want to duplicate, and click Duplicate.

A new version of the selected clip appears in the Audition window.
Add new clips to an audition in the Timeline

- **To add a new clip to an audition and maintain the current clip in the Timeline as the pick:** Drag a clip from the Event Browser to the audition in the Timeline, and choose Add to Audition from the shortcut menu.

- **To add a new clip to an audition and make the clip you’re adding the pick:** Drag a clip from the Event Browser to the audition in the Timeline, and choose Replace and Add to Audition from the shortcut menu.

  **Important:** If a transition is applied to the current clip in the Timeline and the pick for the new audition lacks sufficient media for the transition, the transition is either shortened or removed.

- **To duplicate a clip within an audition:** Click the Audition icon in the upper-left corner of the audition to open the Audition window, select the clip you want to duplicate, and click Duplicate.

  A new version of the selected clip appears in the Audition window.

Remove a clip from an audition

1. To open the audition containing the clip you want to remove, click the icon in the upper-left corner of the audition.

2. In the Audition window, select the clip you want to remove, and press Delete.

   The clip is removed from the audition.
Use auditions to try out clips in your project
You create an audition to try out the clips within it and find the one that works best for your project. Although the auditioning workflow may differ from project to project, the general process is the same. You create an audition that contains a set of alternate takes, effects, or text treatments, and then you choose the best clip for the edit by making it the pick. When you’re sure of your decision, you finalize the audition, which dissolves it and leaves the pick in the Timeline.

Depending on your workflow, you may try out the clips within your auditions and flatten the auditions as you go, or you may leave the auditions in the Timeline for the purpose of showing alternate edits to a client.

Note: You can use audition commands only with one selected audition at a time. For example, you can’t finalize multiple selected auditions.

Review clips within an audition in the Timeline
1 In the Timeline, select the audition containing the clips you want to review, and open it by choosing Clip > Audition > Open (or pressing Y).

2 In the Audition window, select the pick and press the Space bar (or press Command-Control-Y) to play it.
3 To play an alternate clip in the Viewer, select a clip to the right or left of the pick (or press the Right Arrow or Left Arrow key).

The alternate becomes the new pick and plays back in the Viewer.

The star icon indicates the previous pick.

**Tip:** To quickly move through and play alternate clips, select a closed audition in the Timeline, press the Space bar, and press Control-Left Arrow to play clips to the left of the current pick, or Control-Right Arrow to play clips to the right.

4 When you decide on the clip you want to use, make sure it’s selected under the spotlight, and click Done.

5 If you’re sure of your decision and want to finalize the audition, choose Clip > Audition > Finalize Audition (or press Shift-Option-Y).

The audition is dissolved, leaving the pick in the Timeline. The clip selected as the pick retains any keywords or markers assigned to the audition.
Try out multiple effects on a clip in the Timeline

You can try out effects on a clip in the Timeline by creating an audition and adding individual effects to duplicates of the same clip. This technique allows you to view each effect in relation to the clips that precede and follow the audition in the Timeline.

1 In the Timeline, select the clip you want to try different effects on.

2 Do one of the following:
   • Choose Clip > Audition > Duplicate as Audition (or press Option-Y).
   • Control-click the clip, and choose Duplicate as Audition from the shortcut menu.

3 Repeat step 2 for each effect that you want to audition.

4 To open the Audition window, click the icon in the upper-left corner of the audition (or press Y).

5 To open the Effects Browser, click the Effects button in the toolbar (or press Command-5).

6 In the Audition window, select the version of the clip you want to apply the effect to.

7 In the Effects Browser, select the effect you want to try out, and drag it to the clip in the Audition window.
8 Repeat steps 6 and 7 until you’ve applied all the effects you want to audition.
9 Review each effect’s impact on the clip in the Timeline by selecting a clip to the right or left of the pick.

Tip: To quickly move through and play alternate clips, press Control-Left Arrow to play clips to the left of the current pick, or Control-Right Arrow to play clips to the right.

10 When you decide on the effect you want to use, select the clip with that effect in the Audition window, and click Done.

11 If you’re sure of your decision, and want to finalize the audition, choose Clip > Audition > Finalize Audition (or press Shift-Option-Y).

The audition is dissolved, leaving the clip with your chosen effect applied to it in the Timeline.

Tip: To save time, you can have Final Cut Pro automatically duplicate a clip in the Timeline and apply an effect to the duplicated clip by holding down the Control key while you drag an effect from the Effects Browser to the clip in the Timeline. You can also apply an effect to every clip in an audition by holding down the Option key and the Control key while you drag the effect from the Effects Browser to the audition in the Timeline. In both cases, you must start dragging the effect from the Effects Browser and then press the keys as you add the effect to the clip.
Retime clips to create speed effects

Retiming clips overview
You can adjust a clip’s speed settings to create fast-motion or slow-motion effects. You can also reverse a clip, rewind a segment of a clip, apply variable speed effects (also called speed ramping) to a clip selection, and create instant replays. By default, Final Cut Pro maintains the audio pitch of any speed adjustment, but you can turn this feature off to accentuate the speed effect.

You can’t apply speed changes to still images, generators, titles, and themes in Final Cut Pro.

Change clip speed
In Final Cut Pro you can make both constant and variable speed changes to your clips while preserving the audio’s pitch.

Note: Speed settings are applied to the specific instance of the selected clip only. They are not applied to that clip’s source media file on disk. To create a media file with the applied speed effects, export the clip as a QuickTime movie.

Apply a constant speed change
Applying a constant speed change to a range selection or a whole clip alters the entire selection’s playback speed by the same percentage. For example, applying a speed setting of 25 percent to the selection makes the entire selection play in slow motion.
Constant speed changes also alter the duration of a clip. If a constant speed change causes the duration of a clip in your project to become longer or shorter, all clips coming after it ripple forward or backward. If you change the speed to 50 percent, your clip is twice as long; if you change the speed to 200 percent, the clip is half as long. For example, if you set a 5-second clip to play back at 50 percent speed, Final Cut Pro adds frames to the clip so that the clip becomes 10 seconds long and plays back more slowly. If you increase the clip’s speed to 200 percent, Final Cut Pro removes frames and makes the clip 5 seconds long, and it plays back considerably faster.
1 In the Timeline, select a range, a whole clip, or a group of clips whose speed you want to change.

2 Do one of the following:
   - To apply a preset speed setting: Choose Slow or Fast from the Retime pop-up menu in the toolbar (shown below), and choose a speed from the submenu.
   - To apply a custom speed setting: Choose Show Retime Editor from the Retime pop-up menu (or press Command-R) to display the Retime Editor above the selection in the Timeline, and drag the retiming handle. If you drag the retiming handle to the right, the speed of the selection decreases, the duration of the selection increases, and the bar above the Timeline selection turns orange.
If you drag the retiming handle to the left, the speed of the selection increases, the duration of the selection decreases, and the bar above the Timeline selection turns blue.

Drag the retiming handle to the left to create a fast-motion effect.

Apply a variable speed change
To alter the speed of a clip over time, in forward or reverse motion, you can apply a variable speed change (also called speed ramping). Variable speed changes create sophisticated effects in which subjects appear to smoothly shift across a variety of different speeds, with gradual or abrupt transitions between each speed segment. These types of effects can be seen in many music videos and broadcast commercials, and the effects can be created directly in the Timeline. To apply variable speed effects, you divide a clip into speed segments that are set to specific speed percentages.

1 In the Timeline, select either a range within a clip or a whole clip to which you want to apply a speed ramp effect.

2 Do one of the following:
   - To ramp the speed down: Choose Speed Ramp > “to 0%” from the Retime pop-up menu in the toolbar.

   ![Speed Ramp Menu](image)

   - To ramp the speed up: Choose Speed Ramp > “from 0%” from the Retime pop-up menu in the toolbar.
The selection is segmented into four parts with different speed percentages, creating the ramp effect. If more precision is required, you can manually drag any one of the four retiming handles to set the speed you want.

Drag a retiming handle to modify the speed percentage of a speed ramp segment.

**Preserve audio pitch in retimed clips**

By default, Final Cut Pro is set to preserve the audio pitch of a clip that has been retimed. However, if you want to accentuate the retiming adjustment’s effect by allowing the pitch to change in accordance with the retiming adjustment, you can turn this feature off.

1. In the Timeline, select a range, a whole clip, or a group of clips whose speed you plan to change.
2. Choose Preserve Pitch from the Retime pop-up menu in the toolbar.

A checkmark to the left of the command name indicates that Preserve Pitch is turned on. Choose Preserve Pitch again to turn it off.

**Change the end frame of a speed segment**

You can change the end frame of a speed segment in the Timeline.

When you drag the retiming handle of a speed segment, you’re adjusting the speed of the segment, not trimming it. The Change End Source Frame command allows you to trim the end point (end frame) of a segment.

1. In the Timeline, select a clip that has speed segments.
2 To display the Retime Editor above the clip in the Timeline, choose Show Retime Editor from the Retime pop-up menu in the toolbar (or press Command-R).

3 Click the triangle next to the speed percentage for a speed segment, and choose Change End Source Frame from the pop-up menu.

A filmstrip icon appears over the end frame of the speed segment.

4 To change the end frame, drag the filmstrip icon left or right.

As you drag, the Viewer displays the current end frame.

**Conform a clip’s speed to match the project’s speed**

If you’ve applied speed effects using your camera, the native speed of the source media may not match the native speed of the source media for the rest of the clips in your project in the Timeline. However, you can change the clip with the differing native speed to match the rest of the clips in the Timeline.

1 In the Timeline, select the clip whose speed you want to change to match the rest of the clips in your project.

2 Choose Conform Speed from the Retime pop-up menu in the toolbar.
Smooth out a slow-motion clip with video quality presets
To smooth out the apparent motion of a clip playing back in slow motion, you can apply frame blending or optical flow analysis to the retimed clip.

1 In the Timeline, select a range, a whole clip, or a group of clips whose video quality you want to change.
2 Choose a Video Quality setting from the Retime pop-up menu in the toolbar.

- **Normal**: The default setting. Frames are duplicated, and no frame blending is applied to the slow-motion clip. No rendering is required.
- **Frame Blending**: Adds in-between frames by blending individual pixels of neighboring frames. Slow-motion clips created with Frame Blending appear to play back more smoothly than those created with the Normal (duplication) setting. Rendering is required.
- **Optical Flow**: Adds in-between frames using an optical flow algorithm, which analyzes the clip to determine the directional movement of pixels and then draws portions of the new frames based on the optical flow analysis. Only the portion of the clip used in the project (the media between the clip start and end points) is analyzed. Rendering is required.
  
  **Note**: The more motion contained in a clip, the longer the analysis and rendering takes.

Reverse or rewind clips
In addition to changing the speed of a clip, you can also add directional effects:

- **Reverse**: Reverses the order of frames in the clip, so that the last frame plays first.
- **Rewind**: Appends a duplicate of the range selection or clip as a segment, rewinds the duplicated segment at 1x, 2x, or 4x speed, and then plays the original clip segment again in forward motion at normal speed.

Reverse a clip
1 In the Timeline, select a clip or a group of clips whose contents you want to reverse.
2 Choose Reverse Clip from the Retime pop-up menu in the toolbar.

The green bar with arrows pointing to the left above the selection in the Timeline indicates that the clip is reversed.
3 If you want to adjust the speed of the reversed clip, drag the retiming handle to the left to increase the speed or to the right to decrease it.

4 To see the reverse effect, play back the reversed clip or selection.

**Rewind a range selection or clip**

1 In the Timeline, select a range, a whole clip, or a group of clips whose contents you want to rewind.

2 Choose Rewind from the Retime pop-up menu in the toolbar (shown below), and choose a speed from the submenu.

The selection is duplicated, added to the end of the original selection, and then reversed according to the speed choice. An additional duplicate of the Timeline selection follows the reversed section and plays back in forward motion at the selection’s original speed.
3 If you want to adjust the speed of the rewound section or the sections that precede and follow the rewound section, drag the section’s retiming handle to the left to increase the speed or to the right to decrease it.

Drag a retiming handle to change the speed.

4 Play the clip back to review the rewind effect.

Create instant replays
You can apply an instant replay to a range selection within a clip or a whole clip. Final Cut Pro duplicates the range or clip, appending the duplicated frames to the end of the selection as a new segment. You can then modify the speed of the new segment to achieve the instant replay effect you’re looking for.

Create an instant replay
1 In the Timeline, select a range or a whole clip whose contents you want to use to create an instant replay.

2 Choose Instant Replay from the Retime pop-up menu in the toolbar.

A duplicate of the range or clip is appended to the end of the selection and plays back in forward motion at the selection’s original speed. (By default, the instant replay is set to play back at 100 percent speed.)
3 If you want to adjust the speed of the instant replay segment, drag the retiming handle to the left to increase the speed or to the right to decrease it.

![Diagram of instant replay settings](image)

4 To see the instant replay effect, play back the original selection and the instant replay segment.

**Create freeze frames**

In Final Cut Pro, you can hold on a particular frame to create a freeze frame effect, temporarily stopping the action onscreen. By default, Final Cut Pro adds a 2-second freeze frame, called a *Hold segment*, at the location of the skimmer or playhead, but you can change the duration of the freeze frame at any time.

*Important:* Adding a Hold segment to a clip increases its duration.

**Create a freeze frame**

1 In the Timeline, do one of the following:
   - Select the clip with the frame you want to freeze, and move the skimmer or playhead to that frame.
   - Select a range within a clip in the Timeline.

2 Choose Hold from the Retime pop-up menu in the toolbar (or press Shift-H).

![Toolbar with Retime option](image)

If you selected a clip, a 2-second Hold segment is added to the clip at the position of the skimmer or the playhead.
If you selected a range, a Hold segment is created for the duration of the range. The frame used as the freeze frame is the first (leftmost) frame in the range.

3 If you want to adjust the duration of the freeze frame, drag the Hold segment’s retiming handle to the right to increase the duration, or to the left to decrease it.

Drag the retiming handle to change the duration of the Hold segment.

4 To see the freeze frame effect, play back the clip in the Timeline.

**Reset retimed clips to play at normal speeds**

You can reset a range selection or a clip to play back at normal (100 percent) speed at any time. Resetting the speed removes any directional effects and Holds applied to the selection at the same time.

**Reset a range or a clip to play forward at 100 percent**

1 In the Timeline, select a range, a whole clip, or a group of clips that you want to reset to their original speed.

2 Choose Normal 100% from the Retime pop-up menu in the toolbar (or press Shift-N).

**Edit with mixed-format media**

Final Cut Pro manages project settings automatically. This means you can work with multiple media types with differing frame sizes (also referred to as *resolution*) and frame rates in the same project. When you add the first video clip to your project, Final Cut Pro automatically sets the format, frame size, and frame rate for the entire project based on the properties of that first clip (or, more precisely, on the properties of the clip’s source media file).
You can modify the project’s settings at any time, and you can control, on a clip-by-clip basis, how Final Cut Pro conforms an individual clip’s frame rate and frame size to match the project settings.

**Note:** Compound clips can be thought of mini projects, each with its own distinct project settings. All of the project information in this section applies equally to compound clips.

Here are things to keep in mind when working with multiple formats and frame sizes:

- Choose video and audio project properties based on how you intend to share your final movie with your audience. For example, if you’re editing a project with mixed-format media and you intend to share it as 1080p HD, you should set your project’s video properties to 1080p HD.

- If you’re unsure of the final distribution format, the most important decision you can make before creating your project is choosing your project’s frame rate. It’s easy to change the format and the frame size of your project at any time, but changing the frame rate can cause all the edit points in your project to shift in time.

- If you have a clip that matches the video and audio properties of the format in which you intend to share your project, add this clip to your project first. Final Cut Pro automatically creates matching project settings. This saves you time by preventing you from having to change your project settings later.

  **Tip:** If the first clip you add to a project is an audio clip or a still-image clip, Final Cut Pro prompts you to choose the video properties for your project. Cancel the edit, add a video clip whose source media file has the video properties you require for your project, and then add the non-video clip to your project.

**Choose a method of conforming frame size**

You can choose how Final Cut Pro modifies the frame size of a clip to match the project’s frame size settings. For example, you can have Final Cut Pro change the frame size of the clip to fit within the longest dimension of the project’s frame dimensions, fill the entire frame of the project (which usually results in cropping), or leave the clip’s frame size as is.

1. Add a clip to the Timeline with a frame size that doesn’t match the current project’s frame size (resolution) settings.
2. Select the clip in the Timeline.
3. To open the Video inspector, click the Inspector button in the toolbar (shown below), and click the Video button at the top of the pane that appears.
Choose a method of conforming frame size from the Type pop-up menu in the Spatial Conform section of the Video inspector.

- **Fit**: The default setting. Fits the clip within the project’s frame size setting without cropping the clip’s video. Black bars appear on the sides of the frames that don’t match the project’s frame size (resolution). In the case of a standard-definition (SD) clip in a high-definition (HD) project, Final Cut Pro scales up the SD clip to fit the HD project’s frame size. In the case of an HD clip in an SD project, Final Cut Pro scales down the HD clip to fit the SD project’s frame size.

- **Fill**: Makes the clip’s video fill the project’s frame size. In the case of an SD clip in an HD project, Final Cut Pro scales up the SD clip to fit the HD project’s frame size. Cropping occurs along the clip’s longer dimension to allow the shorter dimension to fill the screen. In the case of an HD clip in an SD project, Final Cut Pro scales down the HD clip to fit the SD project’s frame size. Cropping occurs along the clip’s shorter dimension to allow the longer dimension to fill the screen.

- **None**: Leaves the clip’s frame size unchanged. If the clip’s frame size is larger than the project’s frame size, the clip appears cropped. If the clip’s frame size is smaller than the project’s frame size, black bars surround the clip.

**Choose a method of conforming frame rate**

When a clip’s frame rate differs from the project’s frame rate, Final Cut Pro employs a frame-sampling method to change the clip’s frame rate to match that of the project. You can choose which frame-sampling method Final Cut Pro uses to modify the clip’s frame rate. The method you choose depends on how important it is to you to eliminate visual stuttering and visual artifacts.

1. Add a clip to the Timeline with a frame rate that doesn’t match the current project’s frame rate settings.
2. Select the clip in the Timeline.
3. To open the Video inspector, click the Inspector button in the toolbar (shown below), and click the Video button at the top of the pane that appears.
Choose a method of conforming frame rate from the Frame Sampling pop-up menu in the Rate Conform section of the Video inspector.

- **Floor**: The default setting. Final Cut Pro truncates down to the nearest integer during its calculation to match the clip's frame rate to the project's frame rate.

- **Nearest Neighbor**: Final Cut Pro rounds to the nearest integer during its calculation to match the clip's frame rate to the project's frame rate. The Nearest Neighbor option reduces artifacts at the expense of visual stuttering. Rendering is required.

- **Frame Blending**: Creates in-between frames by blending individual pixels of neighboring frames. Slow-motion clips created with Frame Blending appear to play back more smoothly than those created with the Floor or Nearest Neighbor setting. This setting provides better reduction of visual stuttering, but you may see some visual artifacts. Rendering is required.

- **Optical Flow**: A type of frame blending that uses an optical flow algorithm to create new in-between frames. Final Cut Pro analyzes the clip to determine the directional movement of pixels, and then draws portions of the new frames based on the optical flow analysis. Choosing the Optical Flow option results in better reduction of visual stuttering, and Final Cut Pro spends a significant amount of time to fix visual artifacts.

**Use roles to manage clips**

**Roles overview**

Roles are metadata text labels that you assign to clips in the Event Browser or the Timeline, and they provide a flexible and powerful way to manage your editing workflow. You can use roles in Final Cut Pro to organize clips in your Events and projects, control the appearance of the Timeline, and export separate video or audio files (also known as *media stems*) for distribution, audio mixing, or post-production.

When you import clips (video, audio, or still images), Final Cut Pro analyzes existing clip metadata to assign one of five default roles to the video and audio components of each clip: Video, Titles, Dialogue, Music, and Effects. For example, if a source media file has an iTunes “genre” metadata tag, Final Cut Pro assigns the Music role to the resulting clip. Final Cut Pro assigns the Video and Dialogue roles to clips that contain both video and audio.
You can use roles for the following workflows:

- **Reassign roles:** You can view and reassign clip roles in the Timeline Index, the Event Browser, the Info inspector, or the Modify menu. See “View and reassign roles” on page 340. You can also create custom roles and subroles to further organize your clips.

- **View clips by role:** In the Timeline Index, you can organize clips by role, turn roles on or off, and highlight or minimize clips for viewing in the Timeline. For example, you could easily identify all your dialogue clips and play them back in isolation from other audio clips. See “View clips by role in the Timeline” on page 347.

- **Export media stems:** You can export roles as media stems in a combined, multitrack QuickTime file, or as separate audio or video files. During the export process you can assign mono, stereo, or surround output for your audio channels. See “Export your project as media files” on page 448.

### View and reassign roles

You can view and change the roles that are assigned to clips in the Event Browser, the Timeline Index, the Info inspector, or the Modify menu.

Keep in mind the following when using roles:

- Every clip must have at least one assigned role (clips with audio and video always have one audio and one video role). Still images are assigned the Video role by default, but you can create a custom (still image) role and assign it to your still images.

- Video roles can’t be assigned to audio-only clips, and audio roles can’t be assigned to video-only clips.

- Roles can be assigned to audio or video components of a clip, but can’t be assigned to a clip range or a portion of a clip.

- You can assign different roles to each instance of a clip. For example, if you add a clip from the Event Browser to the Timeline, copy clips between Events, or copy clips within the Timeline, each of these clip instances (copies) is independent of the others.
View and reassign roles in the Event Browser

1 In the Event Browser in list view, select one or more clips.

Note: If the Roles column isn’t visible in the Event Browser, Control-click a column heading and choose Roles from the shortcut menu.

2 In the Roles column, click the assigned role for a clip to see a shortcut menu listing the available roles.

3 To change the role assignments for the selected clips, choose different roles from the shortcut menu.

View and reassign roles in the Info inspector

1 Select one or more clips in the Event Browser or the Timeline.

2 To open the Info inspector, click the Inspector button in the toolbar (shown below), and click the Info button at the top of the pane that appears.

3 In the Info inspector, click the Roles pop-up menu to see the available roles.

4 To change the role assignments for the selected clips, choose different roles from the Roles pop-up menu.
View and reassign roles in the Timeline Index

1. To open the Timeline Index, click the Timeline Index button in the lower-left corner of the Final Cut Pro main window (or press Command-Shift-2).

2. To open the Clips pane, click the Clips button at the top of the Timeline Index.

3. If the Roles column is not visible in the Clips pane, Control-click a column heading and choose Roles from the shortcut menu.

4. Select one or more clips in the Clips pane.

5. To change the role assignments for the selected clips, click the assigned role and choose different roles from the shortcut menu.

View and reassign roles with the Modify menu

1. Select one or more clips in the Event Browser or the Timeline.

2. Choose Modify > Assign Roles, and choose a role from the submenu. A checkmark appears next to the role you chose.
View and reassign roles in compound clips

Compound clips reflect the roles of the original clips that make up the compound clip. You can view and reassign the roles of clips inside a compound clip, but you cannot assign roles to the compound clip itself.

1 Select a compound clip in the Event Browser or the Timeline.

2 To view the assigned roles or to assign a role to every clip inside the compound clip, use the following methods:

   - Roles column in the Event Browser in list view: Follow the instructions in “View and reassign roles in the Event Browser,” above.
   - Roles pop-up menu in the Info inspector: Follow the instructions in “View and reassign roles in the Info inspector,” above.
   - Roles column in the Clips pane of the Timeline Index: Follow the instructions in “View and reassign roles in the Timeline Index,” above.
   - Assign Roles command: Follow the instructions in “View and reassign roles with the Modify menu,” above.

When you assign a role to a compound clip (the container), the role is assigned to every clip inside the compound clip. If you want to assign different roles to specific clips within the compound clip, you can open the compound clip for editing and then assign roles to individual clips inside the compound clip.

For more information about compound clips, see “Compound clips overview” on page 285.
Create custom roles and subroles
You can create custom roles and subroles in addition to the five default roles (Video, Titles, Dialogue, Music, and Effects).

**Important:** Create custom roles and subroles with care. Custom roles (and the names of custom roles) cannot be edited or removed from the roles list. However, you can change the role assignments of clips at any time.

Create custom roles

1. To open the Role Editor, do one of the following:
   - Choose Modify > Edit Roles.
   - In the Event Browser in list view or the Clips pane of the Timeline Index, click a role in the Roles column and choose Edit Roles from the shortcut menu.
   - With a clip selected in the Event Browser or the Timeline, open the Info inspector and choose Edit Roles from the Roles pop-up menu.

2. Choose the role type from the Add Role pop-up menu in the lower-left corner of the Role Editor window.
The new role appears at the bottom of the Role column.

3 Type a name for the new role.

Once you have created a new role, it appears in the roles list so that you can assign it to any clip.
Create subroles
Subroles allow you to organize roles within a role; for example, you could create a Foley Effect subrole within the Effects role, or a Spanish Subtitles subrole within the Titles role.

1 To open the Role Editor, do one of the following:
   - Choose Modify > Edit Roles.
   - In the Event Browser in list view or the Clips pane of the Timeline Index, click a role in the Roles column and choose Edit Roles from the shortcut menu.
   - With a clip selected in the Event Browser or the Timeline, open the Info inspector and choose Edit Roles from the Roles pop-up menu.

2 Select a role in the Role column, and click the Add Subrole button (with a plus sign) below the Subrole column.
3 Type a name for the subrole.

The new subrole remains in the Subrole list and appears below its parent role in roles lists elsewhere in Final Cut Pro. When you assign subroles to clips in the Timeline, the subroles also appear in the Timeline Index.

View clips by role in the Timeline
You can use the Roles pane of the Timeline Index to view and play back clips by role in the Timeline.

All video and audio clips are organized by the default roles of Video, Titles, Dialogue, Music, or Effects, or by a custom role or subrole you’ve created. You can turn off roles to suspend playback for all clips with those roles assigned. For example, you could turn off all roles except Dialogue to play back only dialogue clips, and then turn on the Music role to listen to the movie soundtrack along with the dialogue.

Roles give you a powerful way to organize and preview clips before exporting them as files for broadcast or audio post-production.

Note: Turning roles on or off in the Timeline Index does not affect export settings or clip settings in the Event Browser, the Timeline, or the inspectors.
Turn roles on or off

1. In the Timeline Index, click the Roles button.

2. In the Roles pane, select the checkboxes next to the roles or subroles you want to turn on. Deselect the checkboxes next to the roles or subroles you want to turn off.

Active roles appear in color in the Timeline, and inactive roles appear gray. If you turn off all video or all audio roles, the respective portion of audio-video clips also appears gray.

3. To preview clips by role, play back your project.

   Only clips with active roles assigned play back.

Highlight roles in the Timeline

1. In the Timeline Index, click the Roles button.

2. In the Roles pane, click the name of the role you want to highlight.
The clips with this role assigned are highlighted in the Timeline. This includes both active (color) clips and inactive (gray) clips.

> **Tip:** To highlight more than one role at a time, Shift-click to select contiguous items and Command-click to select noncontiguous items.

**Minimize clips by role**

To make more space to view and work with clips in the Timeline, you can minimize clips with a particular role assigned. Minimized clips appear smaller in the Timeline.

1. In the Timeline Index, click the Roles button.
2. In the Roles pane, click the Minimize button next to the role whose clips you want to minimize.

You can also customize the display of clips in the Timeline by changing the clip appearance and height, and you can choose whether to view clips by name or role. See “Adjust Timeline settings” on page 157.
Use roles to export media stems
When you export your work, you can use roles to define the details of your output media files. This process is often used when delivering files to match broadcast specifications or when handing off media stems for mixing or post-production.

You can export roles in a combined, multitrack QuickTime file, or as separate audio or video files. During the export process you can assign mono, stereo, or surround output for your audio channels.

For more information, see “Export your project as media files” on page 448.

Use XML to transfer projects and Events
Final Cut Pro can import and export XML (Extensible Markup Language) files. You can use XML documents (plain ASCII text files with tagged elements) to transfer the details of your Events and projects between Final Cut Pro and third-party applications, devices, and media asset management tools that do not recognize Final Cut Pro Events or projects.

The XML import and export options are described in detail in the Final Cut Pro XML developer documentation. For more information, visit the Apple Applications page at the Apple Developer website: http://developer.apple.com/appleapplications.

Import XML into Final Cut Pro
You can generate XML files with your own applications and then import them into Final Cut Pro. When you import XML into Final Cut Pro, clips, Events, and projects are automatically generated in Final Cut Pro.

1 In Final Cut Pro, choose File > Import > XML.
2 Navigate to the XML file you want to import, and click Import.

Final Cut Pro processes the XML and generates clips, Events, and projects in the Event Library and the Project Library.

Export XML from Final Cut Pro
You can export Events and projects as XML files.

1 In the Event Library or the Project Library, select one or more Events or projects that you want to export as XML files.
2 Choose File > Export XML.
3 In the window that appears, navigate to a folder on your hard disk where you want to store the XML files, and click Save.
Edit with multicam clips

Multicam editing overview
You can use Final Cut Pro to edit footage from multicamera shoots or other synchronized footage in real time. For example, if you shot a live concert or a wedding with four different cameras, you can synchronize the footage from each camera angle into a single multicam clip and cut between the angles in real time.

The angles in a multicam clip are synchronized by a common sync point, a frame that you can recognize (visibly or audibly) in each of the angles you are synchronizing. When you add a multicam clip to the Timeline, the angle that appears in the Viewer when you play your project is called the active angle. While the active angle plays in the Viewer, you can also view all angles playing simultaneously in the Angle Viewer and easily cut and switch between them.

Working with multicam clips in Final Cut Pro is a flexible and fluid process. At any time, you can add angles to or remove angles from a multicam clip, and easily adjust the synchronization between angles.

You can also group unrelated footage together for real-time montage editing (such as for music videos). For example, if you’re editing a music video, you could add several angles of abstract visuals and cut to those angles at specific places in the music. You can even use photos (from a still camera) in a multicam clip. If the date and time (Content Created) information matches the contents of the other angles, the photos are automatically adjusted in duration to “fill in” the angle.

Functionally, multicam clips are a unique kind of clip in Final Cut Pro for the following reasons:

- You create multicam clips in the Event Browser only, from existing Event clips.
- You edit and adjust multicam clips in the Angle Editor, which looks similar to the Timeline.
When you add a multicam clip to the Timeline, you create a direct and active relationship between the “parent” multicam clip in the Event Browser and the “child” multicam clip in the Timeline.

When you open any multicam clip in the Angle Editor (whether from the Event Browser or the Timeline) you are in fact opening the parent multicam clip from the Event Browser. Any changes you make to a multicam clip in the Angle Editor are inherited by all of its child clips, in all projects. These changes include sync or trimming adjustments, clip speed retiming, video or audio effects such as color correction, and added or deleted angles. For example, if you delete an angle from a parent multicam clip, the angle is deleted from all child clips. For more information about the Angle Editor, see “Sync and adjust angles and clips in the Angle Editor” on page 371.

**Multicam editing workflow**
The process for creating a multicam project is outlined below. The procedures are presented in rough chronological order, but you can rearrange the order to suit your workflow.

*Shoot an event with multiple cameras and record appropriate sync information*
A multicamera shoot uses multiple cameras to record the same subject or event from different angles and distances.

For multicam projects, it’s a good idea to set the date, the time, and the time zone on your camcorder or recording device before you shoot footage for your multicam project. This provides useful information to Final Cut Pro during the automatic multicam clip creation process.

In professional multicamera shoots, each camcorder or VTR receives the same timecode from a master timecode generator, or you can jam sync the timecode generator of each camera at the beginning of the shoot. If you’re using consumer camcorders, which cannot accept external timecode, you need to record a visible or audible cue, such as a clapboard closing or a camera flash, on all cameras. You can use this cue to synchronize the angles in your multicam clips.
Because you can use the sophisticated automatic audio sync feature in Final Cut Pro to help ensure multicam synchronization accuracy, it makes sense to record audio on every camcorder and recording device in your multicam production. (Clear audio recordings provide the best results.)

**Import media for a multicam edit**
Although importing media for multicam projects is the same as importing for any other project, there are steps you can take during importing to help streamline the multicam workflow.

**Assign camera names and multicam angles**
You can use the Camera Name and Camera Angle metadata tags to automate and organize your multicam workflow. It's recommended (but not required) to apply these tags to your Event clips before you create an actual multicam clip.

**Create multicam clips**
You create multicam clips from selected Event clips (similar to the way you create auditions and compound clips in the Event Browser). Whether you do it manually or have Final Cut Pro do it for you automatically, creating a multicam clip involves three fundamental steps:

- Create angles (containing one or more clips each).
- Arrange the order of clips within each angle.
- Synchronize the angles using a common sync point.

If you know what kind of metadata your source media has, you can create multicam clips using manual methods even faster than with the automatic methods. For more information, see “Assign camera names and multicam angles” on page 354 and “Create multicam clips in the Event Browser” on page 355.

**Cut and switch between angles in the Angle Viewer**
After you create a multicam clip, you can watch all angles simultaneously in the Angle Viewer while switching or cutting to different angles in real time. You can cut and switch video and audio at the same time or independently. For example, you can use the audio from angle 1 while switching the video between angles 1 to 4.

**Sync and adjust angles in the Angle Editor**
At any time, you can open multicam clips in the Angle Editor to adjust the synchronization and the angle order, or to add or delete angles. You can also use the Angle Editor to make edits to the individual clips inside a multicam clip (such as trimming, making color corrections, adding transitions, and so on).

**Edit multicam clips in the Timeline**
You can switch multicam angles directly in the Timeline or the Inspector, without opening the Angle Viewer. Although multicam clips have some unique properties, you can edit them in the Timeline in the same way you edit any other clips.
Import media for a multicam edit

When you import media for a multicam project, you can give the camcorder or file-based recording device a name. Final Cut Pro uses this Camera Name tag to sort the source clips within a multicam clip during the automatic multicam clip creation process.

If you anticipate having multicam clips with numerous angles, select “Use proxy media” in Playback preferences to maintain top performance during your multicam edit. You can generate the necessary proxy versions of your clips during the import process.

If you have only a few angles in your multicam edit, you can make optimized versions of your media during import, using the Apple ProRes 422 codec. Or, if you prefer, you can select “Create optimized media for multicam clips” in Playback preferences to generate optimized media automatically every time you create a multicam clip. For more information, see “Playback preferences” on page 498.

Name your camera

The following instructions cover how to add the Camera Name property when you use the Import From Camera command to import from a connected file-based device. If your workflow requires using the Import Files command, you can add the Camera Name property at a later time.

1 Connect your camera or recording device to your computer.
2 In Final Cut Pro, choose File > Import From Camera.
3 In the Camera Import window, select your camcorder or recording device from the list of devices on the left, if it’s not already selected.
4 Click it again, and enter a name.

Final Cut Pro uses the name you enter as the Camera Name metadata property for all clips that you import from this device.

**Note:** Most modern camcorders and recording devices (including all iOS devices) record a Camera ID tag. Final Cut Pro imports the Camera ID metadata automatically when you import from a file-based device and can use this information to automatically build multicam angles.

Assign camera names and multicam angles

The Camera Angle and Camera Name properties are flexible metadata tags that you can use to organize your multicam workflow.

Although you can assign metadata to clips at any time, it makes the most sense to assign the Camera Angle and Camera Name tags before you use the clips to create multicam clips. The Camera Angle tag can help you determine and track which clips appear in which angles. The Camera Name tag can be applied during import and is useful in a variety of scenarios, such as in color correction.
Final Cut Pro allows you to create multicam clips automatically or manually. If you use the automatic method for creating angles in the multicam clip, Final Cut Pro looks for metadata in the selected clips in the following order:

- Camera Angle metadata
- Camera Name metadata
- Camera ID metadata

*Note:* The Camera ID tag is generated by most modern camcorders and recording devices (including all iOS devices). Final Cut Pro imports the Camera ID metadata automatically when you import from a file-based device.

Final Cut Pro uses the Camera Angle, Camera Name, and Camera ID metadata to place clips in the correct angle. If it doesn’t find any of this information, Final Cut Pro creates a separate angle for each selected clip.

**Assign camera names and angles to selected clips**

Do one of the following:

- Select one or more clips in the Event Browser or the Timeline, open the Info inspector, and enter text in the Camera Angle field or the Camera Name field.
- In the Event Browser in list view, enter text in the Camera Angle column or the Camera Name column for any clip.

*Note:* If you use the automatic method for creating angles, Final Cut Pro uses any Camera Angle tags in the selected clips to name the angles in the resulting multicam clip. If no Camera Angle tags are present, Final Cut Pro uses Camera Name, Name (clip name), or Camera ID metadata to name angles. You can rename angles in the Angle Editor. For more information, see “Sync and adjust angles and clips in the Angle Editor” on page 371.

**Create multicam clips in the Event Browser**

Creating multicam clips is similar to creating auditions and compound clips in the Event Browser. Multicam clips can be made up of diverse media sources (different formats, frame rates, and so on). You can have multiple clips in any given angle of a multicam clip.

You can have Final Cut Pro create multicam clips for you automatically, or you can create the clips manually.
If you know what kind of metadata your multicam media has, you can create multicam clips using manual methods faster than with the automatic methods. The automatic methods use sophisticated automatic audio sync technology to ensure synchronization accuracy (but at the expense of processing time). It’s best to turn off the “Use audio for synchronization” feature when it’s not needed. For example, if you’ve recorded accurate timecode in every clip, Final Cut Pro can create your multicam clip automatically without the audio sync feature.

Create a multicam clip automatically
1 In the Event Browser, select the clips you want to include in the multicam clip.
2 Do one of the following:
   • Choose File > New Multicam Clip.
   • Control-click the selection and choose New Multicam Clip from the shortcut menu.
3 In the window that appears, type a name for the multicam clip in the Name field.
4 If the multicam automatic settings are not shown, click Use Automatic Settings.
   The multicam automatic settings appear.

   ![](image)

   **Note:** The automatic settings are shown by default, but if the last multicam clip you created used custom settings, those settings are shown.

5 To sync angles automatically using audio waveform data, select “Use audio for synchronization.”

   This option makes precision sync adjustments using audio waveforms in each angle. This is the same audio sync technology that you can use to automatically sync clips together into a compound clip.

   ![](image)

   **Note:** Some audio recordings are not suited for use with this feature. Selecting this option may result in long processing times during which Final Cut Pro is not available for editing.

6 Click OK.
Final Cut Pro creates a new multicam clip in the Event and places duplicates of the selected clips in the new multicam clip.

Create a multicam clip with custom settings
1 In the Event Browser, select the clips you want to include in the multicam clip.
2 Do one of the following:
   • Choose File > New Multicam Clip.
   • Control-click the selection and choose New Multicam Clip from the shortcut menu.
3 In the window that appears, type a name for the multicam clip in the Name field.
4 If the multicam custom settings are not shown, click Use Custom Settings.

   The custom settings appear.

   Note: The automatic settings are shown by default, but if the last multicam clip you created used custom settings, those settings are shown.

5 In the Angle Assembly pop-up menu, choose how the angles in the multicam clip are created:
   • Automatic: Final Cut Pro creates the angles automatically.
   • Camera Angle: Final Cut Pro creates angles in the multicam clip based on the Camera Angle property of the selected clips.
• **Camera Name**: Final Cut Pro creates angles in the multicam clip based on the Camera Name property of the selected clips.

• **Clips**: Final Cut Pro creates a separate angle for each selected clip, using the Name property in each clip to name the angle.

6 In the Angle Clip Ordering pop-up menu, choose how angles are ordered within the multicam clip:

• **Automatic**: Final Cut Pro orders the clips within each angle automatically. If there is more than one clip per angle, Final Cut Pro inserts gap clips between the clips, as needed, to achieve the correct timing and spacing.

• **Timecode**: Final Cut Pro orders the clips within each angle using timecode recorded in the clips. If you recorded timecode in your clips, choose this option. It’s the fastest and most frame-accurate method of ordering clips.

• **Content Created**: Final Cut Pro orders the clips within each angle using the date and time information recorded by your camcorder or video recording device.
   
   The Content Created method can position clips within one-second accuracy (since, in most camcorders, the smallest unit in date and time information is one second). If you choose this clip-ordering method, you will probably need to manually synchronize your angles in the Angle Editor to make your multicam clip frame-accurate.

   **Note**: At any time, you can change the Content Created date and time of your source clips in the Event Browser. Just select one or more clips and choose Modify > Adjust Content Created Date and Time.

7 In the Angle Synchronization pop-up menu, choose how angles are synchronized in the multicam clip:

• **Automatic**: Final Cut Pro synchronizes the angles automatically (using one or more of the following methods).

• **Timecode**: Final Cut Pro synchronizes the angles based on the timecode recorded in the clips. For more information about recording timecode, see “Multicam editing workflow” on page 352.
• **Content Created**: Final Cut Pro synchronizes the angles based on the date and time information recorded by your camcorder or video recording device.

   **Note**: At any time, you can change the Content Created date and time of your source clips in the Event Browser. Just select one or more clips and choose Modify > Adjust Content Created Date and Time.

   ![Sync point diagram]

   • **Start of First Clip**: Final Cut Pro uses the first frame in each angle as the sync point.

   ![Sync point diagram]

   **Tip**: The Start of First Clip method is useful if you want to use specific range selections of your source clips only. In the Event Browser, add keywords or the Favorite rating to the range selections you want to use and then filter or search for the clips. When you create your multicam clip, Final Cut Pro uses only the media showing in the filtered view.

   • **First Marker**: Final Cut Pro uses the first marker in each angle as the sync point.

   ![Sync point diagram]

   **Tip**: With this method, you can use the first marker to define a region that can be fine-tuned with the “Use audio for synchronization” option (described below). In other words, you don’t need to place the marker exactly—just close enough so that the automatic audio sync feature can synchronize the angles the rest of the way.
8 To sync angles automatically using audio waveform data, select “Use audio for synchronization.”

This option makes precision sync adjustments using audio waveforms in each angle. This is the same audio sync technology that you can use to automatically sync clips together into a compound clip.

Note: Some audio recordings are not suited for use with this feature. Selecting this option may result in long processing times during which Final Cut Pro is not available for editing.

9 If you want the multicam clip's timecode to start at a value other than the earliest timecode value in the selected clips (the default), type a timecode value in the Starting Timecode field.

10 If you want to change the video properties settings, select Custom in the Video Properties section and change the settings as appropriate.

Note: By default, Final Cut Pro analyzes the selected clips and configures these settings according to the most common clip properties among those clips.

11 If you want to change the audio or render settings, select Custom in the Audio and Render Properties section and change the settings as appropriate.

12 Click OK.

Final Cut Pro creates a new multicam clip in the Event and places duplicates of the selected clips in the new multicam clip.
Cut and switch angles in the Angle Viewer

After you create a multicam clip, you can watch all angles simultaneously in the Angle Viewer while switching or cutting to different angles in real time. This allows you to cut an entire movie as if it were live, and then fine-tune your edits in the Timeline just as you would for any other project.

The Angle Viewer is both a display and an interactive interface for making quick cut and switch decisions as you play back your multicam clips and projects. Angles appear in banks of 2, 4, 9, or 16 angles.

Play back a multicam clip in the Angle Viewer

1 To open the Angle Viewer, do one of the following:
   • Choose Window > Show Angle Viewer (or press Command-Shift-7).
   • Choose Show Angle Viewer from the Viewer Options pop-up menu in the top-right corner of the Viewer.

2 Use the skimmer or the playhead to play back a multicam clip in the Event Browser or the Timeline.
The Angle Viewer appears in the upper part of the Final Cut Pro window, in the space normally occupied by the Viewer.

Play back a multicam clip in the Event Browser or the Timeline.

The multicam clip’s angles appear in the Angle Viewer.

Active angle

Cut and switch angles in the Angle Viewer
You can cut and switch angles “on the fly” (while playing back your project), or you can skim to specific points in the Timeline and then cut and switch. You can also use a combination of those two methods.

1 To open the Angle Viewer, choose Window > Show Angle Viewer (or press Command-Shift-7).

2 Add the multicam clip you want to cut and switch to the Timeline.

   Note: The cut and switch feature works on Timeline clips only.

3 Do one of the following:
   • Position the playhead and press the Space Bar to play back the multicam clip.
   • Skim the Timeline to the frame where you want to cut and switch to a different angle.

4 In the Angle Viewer, move the pointer over the angle that you want to switch to.
As you move the pointer over the angles in the Angle Viewer, the pointer changes to the Blade tool, indicating that a cut (and switch) will occur when you click.

The active angle is highlighted.

The pointer changes to the Blade tool.

5 Do one of the following:

- **To cut and switch:** Click the angle you want to switch to. (Or press any number key to cut and switch to the corresponding angle of the current bank. For example, press 5 to cut and switch to angle 5 of the current bank.)

  In the Timeline, the current multicam clip is cut at the playhead position. The section of the clip to the right of the playhead is replaced with a new instance of the clip, with the angle you clicked as the active angle. A special through edit point appears at the Timeline playhead position. For more information, see “Edit multicam clips in the Timeline and the Inspector” on page 379.

- **To switch:** Option-click the angle you want to switch to. (Or hold down the Option key and press any number key to switch to the corresponding angle of the current bank. For example, press Option-5 to switch to angle 5 of the current bank.)

  **Note:** The pointer changes to a pointing hand icon when you hold down the Option key, indicating a switch-only edit.

  In the Timeline, the multicam clip under the playhead changes to show the angle you switched to as the active angle.

In either case, the Viewer switches to the angle you selected. The active angle is highlighted in yellow, blue, or green, depending on the switch mode you’re using. For more information, see “Switch video or audio separately,” below.
Switch video or audio separately
By default, Final Cut Pro switches the video and audio of a multicam clip at the same time. But you can set Final Cut Pro to switch the video and audio separately.

1 To open the Angle Viewer, choose Window > Show Angle Viewer (or press Command-Shift-7).

2 To change the switch mode, do one of the following:
   • To enable video and audio switching: Click the left switch mode button in the upper-left corner of the Angle Viewer. This is the default setting.
   • To enable video-only switching: Click the middle switch mode button. Only the video switches. The audio from the original angle remains active.
   • To enable audio-only switching: Click the right switch mode button. Only the audio switches. The video from the original angle remains active.
3 Do one of the following:
- *To cut and switch:* Click an angle in the Angle Viewer.
- *To switch:* Option-click an angle in the Angle Viewer.

If you selected the video-only or audio-only switch mode, blue highlighting indicates the active video angle and green highlighting indicates the active audio angle.

**View and navigate banks of angles**
Depending on the Angle Viewer display setting you choose, you can show 2, 4, 9, or 16 angles at once. These sets of angles are known as *banks*. The bank switcher in Final Cut Pro is an efficient tool for displaying and navigating banks of angles in a multicam clip.

1 To open the Angle Viewer, choose Window > Show Angle Viewer (or press Command-Shift-7).

2 Position the skimmer or the playhead over a multicam clip in the Event Browser or the Timeline.
The bank switcher appears as a grid of squares at the bottom of the Angle Viewer. Yellow, blue, or green highlighting indicates the currently active angle.

The bank switcher shows the number of angles and which is active.

3 In the Settings pop-up menu (in the upper-right corner of the Angle Viewer), choose the number of angles you want to display in each bank.
If the number of angles in your multicam clip exceeds the current Angle Viewer display setting, Final Cut Pro creates additional banks and displays them as separate grids of squares.

Here are a few examples of different angle bank combinations:

- Three banks of 4 angles each, with the last angle in the third bank as the active angle, and the third bank as the currently displayed bank:

- One bank of 16 angles, with the last angle as the active angle:

- One bank of 9 angles and another bank of 7 angles, with the first bank as the currently displayed bank:

4 To navigate banks of angles, do any of the following:

- To display a bank’s angles in the Angle Viewer: Click the bank switcher icon for the bank.
- To display the previous bank: Press Shift-Option-Semicolon (;).
- To display the next bank: Press Shift-Option-Apostrophe (’).
Show overlays in the Angle Viewer
For each angle that appears in the Angle Viewer, you can display video overlays showing timecode and either the clip name or the angle name.

1 To open the Angle Viewer, choose Window > Show Angle Viewer (or press Command-Shift-7).

2 To choose a display option, do one of the following:
   - To display timecode for the clips in each angle: Choose Timecode from the Settings pop-up menu in the upper-right corner of the Angle Viewer. (Choose Timecode again to turn off the timecode display.)
   - To display the names of the clips in each angle: In the Settings pop-up menu, choose Display Name > Clip.
   - To display the name for each angle: In the Settings pop-up menu, choose Display Name > Angle.
   - To turn off display names: In the Settings pop-up menu, choose Display Name > None.
Adjust the Angle Viewer display
You can adjust the Angle Viewer display to suit your needs.

Do any of the following:

- To adjust the number of angles in the Angle Viewer: In the Settings pop-up menu in the upper-right corner of the Angle Viewer, choose either 2 Angles, 4 Angles, 9 Angles, or 16 Angles.
To adjust the size of the Angle Viewer and the Viewer: Drag the boundary between them.

Drag the boundary to the right.

Drag the boundary to the left.
To make the Angle Viewer a vertical column: Drag the boundary to the left, and drag the Final Cut Pro toolbar downward to expand the Viewer quadrant vertically. (This vertical column view is available only in the 2 Angles and 4 Angles views.)

![Angle Viewer](image)

Drag the boundary to the left. Drag the toolbar down.

Sync and adjust angles and clips in the Angle Editor
At any time, you can open multicam clips in the Angle Editor to adjust the synchronization and the angle order, set the monitoring angle, or add or delete angles.

Note: When you open any multicam clip in the Angle Editor (whether from the Event Browser or the Timeline) you are actually opening the parent multicam clip. Any changes you make in the Angle Editor are propagated to all child clips of that multicam clip, in every project. For more information, see “Create multicam clips in the Event Browser” on page 355.

You can use the Angle Editor to edit the individual clips inside a multicam clip (similar to how you can edit the contents of a compound clip). The many changes you can make in the Angle Editor include basic edits and trimming as well as effects you would normally add in the Timeline, such as color corrections and transitions.

Tip: Before you edit multicam clips in the Angle Editor, duplicate them in the Event Browser to maintain clean backup copies.

You cannot cut and switch between angles in the Angle Editor. You also cannot connect clips, solo clips, use the Precision Editor, perform ripple deletes, or use the Detach Audio, Break Apart Clip Items, and Change Duration commands.
Open a multicam clip in the Angle Editor
Do one of the following:

- Double-click a multicam clip in the Event Browser.
- Control-click a multicam clip in the Event Browser or the Timeline, and choose Open in Angle Editor from the shortcut menu.

The Angle Editor opens in the Timeline area at the bottom of the Final Cut Pro window. Although similar to the Timeline, the Angle Editor provides a separate interface dedicated to editing angles and clips inside multicam clips. Each angle in the multicam clip appears as a separate row in the Angle Editor.

Set video and audio monitoring in the Angle Editor
In the Angle Editor, you can set any one angle to be the monitoring angle. This is the angle you see in the Viewer when the multicam clip is playing back in the Angle Editor. You can also monitor the audio of any number of angles at once.

You use the monitoring angle to synchronize angles in the Angle Editor. The monitoring angle is not the same thing as the active angle (which you see in the Timeline). You cannot cut and switch between angles in the Angle Editor.

Note: Setting the correct monitoring angle is important for the two synchronization commands described later in this section: Sync to Monitoring Angle and Sync Angle to Monitoring Angle Using Audio.
1 To open the Angle Editor, do one of the following:
   - Double-click a multicam clip in the Event Browser.
   - Control-click a multicam clip in the Event Browser or the Timeline and choose Open in Angle Editor from the shortcut menu.

2 To set an angle as the monitoring angle, do any of the following:
   - Click the Video Monitor icon at the left side of the angle.
   - Choose Set Monitoring Angle from the pop-up menu next to the angle name.
   - Press Shift-V while skimming the angle.

   The Video Monitor icon turns white, and the entire angle is highlighted in light gray. The angle plays in the Viewer when you play back the multicam clip in the Angle Editor. Only one angle can be the video monitoring angle at a time.
To turn on audio monitoring for an angle, do one of the following:

- Click the Audio Monitor icon once. (To turn off audio monitoring, click the icon again.)
- Choose Monitor Audio from the pop-up menu next to the angle name. (To turn off audio monitoring, choose Monitor Audio again.)
- Press Shift-A while skimming the angle. (To turn off audio monitoring, press Shift-A again.)

The monitoring settings do not affect any of your active angles. They simply change what is playing back in the Viewer while you’re working in the Angle Editor.

**Tip:** You can use audio monitoring to double-check the synchronization of individual angles in a multicam clip. Open the clip in the Angle Editor, and turn on audio monitoring for two or more angles at a time. You will hear immediately if the angles are in sync or if you need to adjust them further.
Manually adjust the synchronization of a multicam clip

A primary function of the Angle Editor is to provide an easy way to correct out-of-sync angles in your multicam clips. The instructions below describe how to synchronize angles by locating sync points and then manually dragging them into alignment.

1 To open the Angle Editor, do one of the following:
   • Double-click a multicam clip in the Event Browser.
   • Control-click a multicam clip in the Event Browser or the Timeline and choose Open in Angle Editor from the shortcut menu.

2 Locate a sync point in one of the out-of-sync angles by skimming the angle in the Angle Editor.

As you skim, the angle is displayed in the left side of the Viewer (in place of the Angle Viewer). The sync points could be video or audio cues (such as a clapboard closing or a door slam).

3 Locate the corresponding sync point in one or more angles that you want to synchronize to the original angle.

To simplify this process, you can add markers at the sync points, to guide you visually and to provide snap points.

4 Drag the clips left or right in the rows of the Angle Editor so that the sync points align vertically.

![Diagram showing the process of aligning sync points](image-url)
If an angle contains more than one clip, you can easily select all clips in the angle so that you can move them all at once. To do this, choose Select Clips in Angle from the pop-up menu next to the angle name.

You can then drag the clips left or right to move them all by the same amount.
Automatically adjust the synchronization of a multicam clip

The instructions below describe two automatic methods for synchronizing angles in a multicam clip.

1 To open the Angle Editor, do one of the following:
   - Double-click a multicam clip in the Event Browser.
   - Control-click a multicam clip in the Event Browser or the Timeline and choose Open in Angle Editor from the shortcut menu.

2 In the out-of-sync angle, click the pop-up menu to the right of the angle name and choose one of the following:
   - *Sync to Monitoring Angle:* This option opens a two-up display in the Viewer, showing the frame at the skimmer position on the left and the frame at the playhead position of the monitoring angle on the right. In the out-of-sync angle, skim to a frame and click to sync the angle to the playhead position. All the clips in the angle move together to align the frame you clicked with the playhead. To close the two-up display in the Viewer, click Done.
   - *Sync Angle to Monitoring Angle Using Audio:* This option compares the audio waveforms in the selected angle to the waveforms in the monitoring angle, and then moves the clips in the selected angle to synchronize them with those in the monitoring angle. This is the same audio sync technology that you can use to automatically analyze and sync clips together into a compound clip.
     
     *Note:* Some audio recordings are not suited for use with this feature. Choosing this option may result in long processing times during which Final Cut Pro is not available for editing.

Adjust the order of angles in a multicam clip

You can adjust the order in which angles appear in the Angle Viewer and the Angle Editor.

*Note:* If you’ve already started a multicam edit on a multicam clip in the Timeline, changing the angle order does not affect which angle is chosen for each cut and switch edit.

1 To open the Angle Editor, do one of the following:
   - Double-click a multicam clip in the Event Browser.
   - Control-click a multicam clip in the Event Browser or the Timeline and choose Open in Angle Editor from the shortcut menu.
2 At the right side of the Angle Editor, use the drag handles to drag the angle rows up or down to reorder them.

![Drag handles to reorder angles](image)

The angles in the Angle Editor and the Angle Viewer change to the new order.

**Add, delete, or rename angles in a multicam clip**

1 To open the Angle Editor, do one of the following:
   - Double-click a multicam clip in the Event Browser.
   - Control-click a multicam clip in the Event Browser or the Timeline and choose Open in Angle Editor from the shortcut menu.

2 Do any of the following:
   - To *delete an angle*: Choose Delete Angle from the pop-up menu to the right of the angle name.
     The angle is removed from the Angle Editor, the Angle Viewer, and all child clips of the multicam clip.
     
     **Important**: Deleting an active angle affects the edits in your projects. The deleted angle is replaced with black filler in all projects.
   - To *add an angle*: Choose Add Angle from the pop-up menu to the right of the angle name.
     A new, empty angle appears in the Angle Editor and the Angle Viewer.
   - To *rename an angle*: At the left side of the Angle Editor, click the name of the angle you want to rename. When the text becomes highlighted, type the new name.
The new name appears in the Angle Editor and (if overlays are turned on) in the Angle Viewer.

**Edit multicam clips in the Timeline and the Inspector**

You can switch multicam clip angles directly in the Timeline or the Info Inspector, without having to open the Angle Viewer.

Multicam clips generally function in the Timeline like any standard clips. You can add video and audio effects, transitions, and markers; attach connected clips; and apply retiming effects. You can apply split edits to multicam clips and edit them in the Precision Editor. You can nest multicam clips in compound clips and storylines.

However, multicam clips do have some unique characteristics in the Timeline:

- You can display the names of the active video angle and the active audio angle in the multicam clip in the Timeline.
- Cut and switch edit points appear as dotted lines in the Timeline. These are through edits (in which the video or audio content on either side of the edit point is continuous). In the case of multicam editing, through edits indicate that the content on either side of the edit point comes from the same multicam clip. A black dotted line indicates that different angles from the same multicam clip are on either side of the edit point. In the case of video-only or audio-only cuts and switches, the edit point can be mixed (with both black and white dotted lines). For example, when you cut and switch video only, you see a black dotted line for the video and a white dotted line for the audio.
- When you move the pointer over a multicam through edit, the pointer changes to the Trim tool, indicating that the edit will be a roll edit (because any other type of edit breaks the relationship between the clips on either side of the cut and switch edit point in the Timeline).
- Many edits (such as split edits, markers, connected clips, and retiming effects) remain in place on a multicam clip in the Timeline even after you switch the angle. But certain editing operations are associated directly with the specific angle and are not retained when you switch angles:
  - Video and audio effects
  - Keyframing (including audio volume and panning)
  - Role assignments
Switch angles in the Timeline
1 In the Timeline, Control-click the multicam clip you want to switch.
2 Do one of the following:
   • To switch the video angle: Choose Active Video Angle from the shortcut menu, and choose the angle you want to switch to from the submenu.

   ![Active Video Angle Menu]

   • To switch the audio angle: Choose Active Audio Angle from the shortcut menu, and choose the angle you want to switch to from the submenu.

   The clip switches to the video or audio angle you chose.

Switch angles in the Inspector
Switching angles in the Inspector allows you to switch angles for multiple selected multicam clips at once.
1 Select one or more multicam clips that you want to switch.
2 Open the Info inspector.
3 In the Info inspector, do one of the following:
   • To switch the video angle: In the Active Video Angle pop-up menu, choose the angle you want to switch to.
   • To switch the audio angle: In the Active Audio Angle pop-up menu, choose the angle you want to switch to.

Display the names of the active video and audio angles in the Timeline
You can have Final Cut Pro display the names of the active video angle and the active audio angle in the multicam clip in the Timeline, in the following format: V: video angle name | A: audio angle name.

- Click the Clip Appearance button in the lower-right corner of the Timeline and choose Clip Names or Angles from the Show pop-up menu.
Multicam editing tips and tricks

The following tips can help you streamline your multicam workflow:

- Set the date, the time, and the time zone on your camcorder or recording device before you shoot footage for your multicam project. This provides useful information to Final Cut Pro during the automatic multicam clip creation process.

  **Note:** At any time, you can change the Content Created date and time of your source clips in the Event Browser. Just select one or more clips and choose Modify > Adjust Content Created Date and Time.

- Because you can use the sophisticated automatic audio sync feature in Final Cut Pro to help ensure multicam synchronization accuracy, it makes sense to record audio on every camcorder and recording device in your multicam production. (Clear audio recordings provide the best results.)

- Before you edit multicam clips in the Angle Editor, duplicate them in the Event Browser to maintain clean backup copies.

- To double-check the synchronization of individual angles in a multicam clip, open the clip in the Angle Editor and turn on audio monitoring for two or more angles at a time. You will hear immediately if the angles are in sync or if you need to adjust them further.

- If performance becomes an issue while you’re working on a multicam project, do any of the following:

  - Set Final Cut Pro to use proxy playback by selecting “Use proxy media” in Playback preferences. Proxy playback allows you to play back more angles at a time. To use proxy playback, you must have proxy versions of your media available, or you must create proxy versions. For more information about creating proxy versions, see “Transcode media files” on page 473.

  - Make sure that “Create optimized media for multicam clips” is selected in Playback preferences. For more information, see “Playback preferences” on page 498. This option transcodes video to the Apple ProRes 422 codec format, which provides better performance during multicam editing. This option is turned on by default. If the original camera format can be edited with good performance, you can deselect this checkbox.

  - Make sure that the hard disk holding your multicam source clips is fast enough to play back all of your media at once. You can check hard disk performance by choosing Final Cut Pro > Preferences and selecting “Warn when frames are dropped due to hard disk performance.” To find out if something else is causing playback issues, select “Warn when dropping frames during playback.”

  - You can use photos (from a still camera) in a multicam clip. If the date and time (Content Created) information matches the contents of the other angles, the photos are automatically adjusted in duration to “fill in” the angle.
Keying

Keying overview
There are times when you need to combine two clips to create an image with bits of both. A common way to combine two clips is to use a keying process, where the video of the top, or foreground, clip is processed to eliminate either a color or luma value in areas of the video and then is combined with the bottom, or background, clip.

For example, keying allows you to take a video clip of a person standing in front of a green background and replace that green with a street scene, making it appear as though that person is standing on the street.

This type of keying is accomplished using one of two keyer effects in Final Cut Pro:

- **Keyer**: This general purpose chroma-keying effect is optimized for blue- or green-screen keying but can key any range of color you choose. See “Use chroma keys” on page 383.

- **Luma Keyer**: This is designed to generate mattes based on the image’s lightness—you choose to remove the white or black areas and whether or not the gray areas should be partially transparent. See “Use luma keys” on page 394.

In addition to these keying effects, you may need to use a matte, a positioning effect, and color correction to ensure the foreground video looks natural when keyed over the background. For more information, see “Finalize the key” on page 401.

Another way to combine two clips is for the foreground clip to have an alpha or matte channel that defines which parts of the foreground clip to keep and which to replace with the background clip. This is common when working with computer-generated logos or animated graphics. For more information, see “Compositing overview” on page 405.
Use chroma keys

A challenging part of creating a good chroma key is shooting the chroma key video, and in particular, using a good, well-lit background that provides a uniform color to remove. A wide variety of specialized chroma key background options are available, from chroma key paint that includes highly reflective additives to chroma key cloth or paper sheets. Additionally, it is important to use the best camera you can access and avoid using a highly compressed video format such as DV or MPEG-2.

For the following examples, this woman will be keyed over a street scene. The light stands will be handled in “Finalize the key” on page 401.

Apply the chroma key effect

1 In the Timeline, add the foreground clip (the chroma key clip with the color you want to remove) to the primary storyline.

2 Drag the background clip (the clip you want to superimpose the chroma key clip over) so that it is connected below the foreground clip in the primary storyline.
For more information about connected clips, see “Connect clips to add cutaway shots, titles, and synchronized sound effects” on page 113.

3 Select the foreground clip in the Timeline, and click the Effects button in the toolbar.

Tip: For best results, also position the playhead at a point within the foreground clip that shows the maximum amount of the color to be keyed.

4 In the Effects Browser, select the Keyer effect.

Tip: Type “keyer” in the Effects Browser’s search field to quickly find the Keyer effect.

5 Do one of the following:
   • Drag the effect to the Timeline foreground clip to which you want to apply it.
   • Double-click the effect thumbnail to apply it to the selected clip.

The Keyer effect automatically analyzes the video to detect a green or blue dominant color and configures itself to remove that color. If the resulting key is not right or you would like to improve it, you can adjust the chroma key effect.

Adjust the chroma key effect
The following steps assume you have applied the chroma key effect.

1 In the Timeline, select the foreground clip with the Keyer effect, and open the Video inspector.

   Controls for modifying and improving the Keyer effect appear.

2 If the Select tool is not the active tool, choose it from the Tools pop-up menu in the toolbar (or press A).
3 To improve the key using controls in the Viewer, use the Refine Key and Strength controls to do any of the following:

- **To identify areas of the foreground clip that might still have some of the chroma key color showing:** Click the Sample Color thumbnail image in the Video inspector and draw a rectangle in the Viewer over the area where the chroma key color needs to be removed.

  Drag over an area where the chroma key color is not being removed.

  ![Image of a video editor interface with a keying effect and a keying result showing a person in a green-screen environment.]

  To improve the key, you can drag the rectangle to adjust its position or drag its corners to change its size, and you can drag additional rectangles over any areas with the chroma key color still showing.

  **Tip:** Select Matte (the center button) in the View area in the Video inspector to see the matte that the chroma keyer is creating. This can make it much easier to see areas that are not keying well.
• To refine any difficult areas, such as hair and reflections: Click the Edges thumbnail image in the Video inspector, draw a line across the difficult area in the Viewer (with one end in the area to keep and the other in the area to remove), and drag the line’s handle to adjust the edge softness.

You can use the following keyboard shortcuts to work directly in the Viewer:

• To make a Sample Color adjustment: Draw a rectangle while holding down the Shift key.

• To make an Edges adjustment: Draw a line while holding down the Command key.

• To delete a Sample Color or Edges adjustment: Click a Sample Color rectangle or Edges line while holding down the Option key, or select the control and press the Delete key.

• To choose a different color if the Keyer effect chose the wrong color: Set the Strength parameter to 0 (to override the automatic initial color sampling). Then use Sample Color to choose the color to remove. Select Composite (the left button) in the View area to see the foreground clip combined with the background clip.

• To adjust how strongly the Keyer matches a color in the foreground image to the default chroma key color: Use the Strength slider to adjust the tolerance (core transparency) of the Keyer effect’s automatic sampling. The default value is 100%. Reducing this value narrows the range of color sampled, resulting in less transparency in the keyed image. Increasing the Strength value expands the range of color sampled, resulting in more transparency in the keyed image. The Strength parameter is useful to retrieve areas of semitransparent detail such as hair, smoke, or reflections.
4 To help fine-tune the key, use the View options:

- **Composite**: Shows the final composited image, with the keyed foreground subject over the background clip. This is the default view.

- **Matte**: Shows the grayscale matte, or alpha channel, that’s being generated by the keying operation. White areas are solid (the foreground video is opaque), black areas are transparent (the foreground is not seen at all), and varying shades of gray indicate varying levels of transparency (the background video can be seen mixed with the foreground video). Viewing the matte makes it easier to spot unwanted holes in the key or areas that aren’t transparent enough.

- **Original**: Shows the original, unkeyed foreground image.

5 To further refine the matte, use the following controls:

- **Fill Holes**: Increasing this parameter value adds solidity to regions of marginal transparency within a key. This control is useful when you’re satisfied with the edges of your key, but you have unwanted holes in the interior that you can’t eliminate via the Strength parameter without ruining your edges.

- **Edge Distance**: Lets you adjust how close to the edge of your keyed subject the effect of the Fill Holes parameter gets. Reducing this parameter value brings the filled area of the matte closer to the edge of the subject, sacrificing translucency at the edges. Raising this parameter value pushes the filled area of the matte farther from the edge. Too much edge distance can result in unwanted translucency within parts of the subject that should be solid.

6 To suppress any of the background color that is appearing (spilling) on the foreground image, adjust the Spill Level control.
To reverse the keying operation, retaining the background color and removing the foreground image, select Invert.

To mix the keyed effect with the unkeyed effect, adjust the Mix control.

For information about making advanced chroma key adjustments, see the following instructions.

**Make advanced chroma key adjustments**

The following controls are available for use in difficult keying situations or for fine-tuning specific problems:

- *Color Selection:* These controls are meant to be used after you begin creating a key using automatic sampling or the Sample Color and Edges tools. (However, you can skip those tools and create a key using Manual mode, described below.) The graphical Chroma and Luma controls provide a detailed way of refining the range of hue, saturation, and image lightness that define the keyed matte.

- *Matte Tools:* These controls are for refining the transparency matte generated by the previous sets of parameters. These parameters don’t alter the range of values sampled to create the keyed matte. Instead, they alter the matte generated by the Keyer effect’s basic and advanced controls, letting you shrink, expand, soften, or invert the matte to achieve a better composite.

- *Light Wrap:* These controls are for blending color and lightness values from the background layer of your composite with the keyed foreground layer. Using these controls, you can simulate the interaction of environmental lighting with the keyed subject, making it appear as if background light wraps around the edges of a subject.

The following steps assume you have applied the chroma key effect.

1. In the Timeline, select the foreground clip with the Keyer effect, and open the Video inspector.

   Controls for modifying and improving the Keyer effect appear.
2 Click Color Selection to reveal the following controls:

- **Graph**: Provides two options to set how the adjustable graphs in the Chroma and Luma controls are used to fine-tune a key:
  - **Scrub Boxes**: Select to limit the Chroma and Luma controls to adjusting softness (edge transparency) in the matte you are creating. In this mode, you cannot manually adjust tolerance (core transparency), which is determined by the Keyer effect’s automatic sampling, plus any Sample Color rectangles you’ve added in the Viewer. To increase matte tolerance, add more Sample Color rectangles or adjust the Strength slider.
  - **Manual**: Select to use the Chroma and Luma controls to adjust the softness (edge transparency) and tolerance (core transparency) in the matte you are creating. Make sure the Strength slider is set to a value greater than 0 before you switch to Manual mode; otherwise the Chroma and Luma controls are disabled. When you switch to Manual mode, the Refine Key tools and Strength slider become disabled, but samples you’ve made with those controls continue to contribute to the matte.

*Important*: When you switch to Manual mode, it’s best not to switch back to Scrub Boxes mode. For best results, begin keying an image using the Sample Color and Edges tools in Scrub Boxes mode. Switch to Manual mode afterward if you feel it’s necessary to refine your matte using the Chroma and Luma controls. However, if you switch back to Scrub Boxes mode, you may experience unexpected combinations of additionally sampled and keyframed values that might be difficult to control.
- **Chroma:** Drag the two graphs in this color wheel control to adjust the isolated range of hue and saturation that help define the keyed matte. The selected mode governs which graphs in the color wheel are adjustable. The outer graph controls the softness (edge transparency) of the matte you’re creating, and can be adjusted in either Scrub Boxes or Manual mode. The inner graph controls tolerance (core transparency), and is only adjustable when in Manual mode. Drag any side of either graph to expand or contract the graph’s border, which adds to or subtracts from the range of hue and saturation contributing to the key. In Manual mode, you can also drag inside the tolerance graph to adjust its overall position in the color wheel. To the left of the color wheel, a small graph displays the slope of chroma rolloff, the relative softness of matte edges in regions most affected by the Chroma control. Dragging the Chroma Rolloff slider (described below) modifies the shape of this slope.

  **Tip:** It’s possible to zoom in to and pan around the Chroma control to more precisely adjust the graphs. To zoom in to the Chroma control, move the pointer over the color wheel, and, holding down the Z key, drag to the left to zoom out or to the right to zoom in. To pan in the Chroma control, hold down the H key and drag in the color wheel in the direction you want to move it. To reset the zoom and recenter the Chroma control, move the pointer over the Chroma control and press Shift-Z.

- **Luma:** Drag the adjustable handles in this grayscale gradient to modify the isolated range of the luma channel (the range of lightness and darkness) that also helps define the keyed matte. The upper handles (which appear only in Manual mode) adjust the tolerance (core transparency) of the luma channel’s contribution to the key. The lower handles adjust the softness (edge transparency) of the luma channel’s contribution to the key. The Graph mode governs which handles are adjustable. In Scrub Boxes mode, you can adjust only the lower softness handles, which modify the range of lightness and darkness affecting the edge transparency of the matte. In Manual mode, you can also adjust the upper tolerance handles, which modify core transparency within the luma channel of the matte. By default, the slope of the left and right sides of the Luma graph has a slight “S” curve. You can modify the shape of the curve by adjusting the Luma Rolloff slider (described below).

  **Note:** The luma softness handles may extend past the outer boundaries of the Luma control. This is due to the floating-point precision of the Keyer effect and is expected behavior. To reveal and move out-of-bounds handles, drag the slope line of the Luma graph.

- **Chroma Rolloff:** Use this slider to adjust the linearity of the chroma rolloff slope (displayed in the small graph to the left of the Chroma control). Chroma rolloff modifies the softness of the matte around the edges of regions that are affected most by the Chroma control. Lowering this value makes the slope of the graph more linear, which softens the edges of the matte. Raising this value makes the slope of the graph steeper, which sharpens the edges of the matte.
- **Luma Rolloff**: Use this slider to adjust the linearity of the luma rolloff slope (the ends of the bell-shaped luma curve displayed in the Luma control). Luma rolloff modifies the softness of the matte around the edges of regions that are affected most by the Luma control. Lowering this value makes the slope between the upper and lower handles in the Luma control more linear, which increases edge softness in the matte. Raising this value makes the slope steeper, sharpening the edges of the matte and making them more abrupt.

- **Fix Video**: Select this checkbox to apply subpixel smoothing to the chroma components of the image, reducing the jagged edges that result from keying compressed media using 4:2:0, 4:1:1, or 4:2:2 chroma subsampling. Although selected by default, this checkbox can be deselected if subpixel smoothing degrades the quality of your keys.

3 Click Matte Tools to reveal the following controls:

- **Levels**: Use this grayscale gradient to alter the contrast of the keyed matte, by dragging three handles that set the black point, white point, and bias (distribution of gray values between the black point and white point). Adjusting the contrast of a matte can be useful for manipulating translucent areas of the key to make them more solid (by lowering the white point) or more translucent (by raising the black point). Dragging the Bias handle right erodes translucent regions of the key, while dragging the Bias handle left makes translucent regions of the key more solid.

- **Black, White, Bias**: Click the disclosure triangle in the Levels row to reveal sliders for the Black, White, and Bias parameters. These sliders, which mirror the settings of the Levels handles described above, allow you to keyframe the three Levels parameters (via the Add Keyframe button to the right of each slider). Keyframing the Black, White, and Bias parameters may yield a better key, one that adapts to changing blue-screen or green-screen conditions.

- **Shrink/Expand**: Use this slider to manipulate the contrast of the matte to affect matte translucence and matte size simultaneously. Drag the slider left to make translucent regions more translucent while simultaneously shrinking the matte. Drag the slider right to make translucent regions more solid while simultaneously expanding the matte.
• **Soften:** Use this slider to blur the keyed matte, feathering the edges by a uniform amount.

• **Erode:** Drag this slider right to gradually increase transparency from the edge of the solid portion of the key inward.

4 Click Spill Suppression to reveal the following controls:

![Spill Suppression controls](image)

• **Spill Contrast:** Use this grayscale gradient to adjust the contrast of the color being suppressed, using Black and White point handles (and corresponding sliders). Modifying spill contrast can reduce the gray fringing surrounding a foreground subject. The Black point handle (on the left side of the gradient control) lightens edge fringing that is too dark for a successful composite. The White point handle (on the right side of the gradient control) darkens edge fringing that is too light. Depending on how much spill is neutralized by the Spill Level slider, these controls may have a greater or lesser effect on the subject.

• **Black, White:** Click the disclosure triangle in the Spill Contrast row to reveal sliders for the Black and White point parameters. These sliders, which mirror the settings of the Spill Contrast handles described above, allow you to keyframe the Black point and White point parameters (via the Add Keyframe button to the right of each slider).

• **Tint:** Use this slider to restore the natural color of the keyed foreground subject. Because the Spill Suppression controls eliminate blue or green spill by desaturating subtle blue or green fringing and reflection on the subject, the Tint slider lets you add hues to restore the natural color of the subject. Overdoing this parameter results in over-tinting the subject with the complementary color of the hue being suppressed—magenta if green, and orange if blue.

• **Saturation:** Use this slider to alter the range of hues introduced by the Tint slider (when the Tint slider is used at moderate levels).
5 Click Light Wrap to reveal the following controls:

- **Amount:** Use this slider to control the overall light wrap effect, setting how far into the foreground the light wrap extends.
- **Intensity:** Use this slider to adjust gamma levels to lighten or darken the interaction of wrapped edge values with the keyed foreground subject.
- **Opacity:** Use this slider to fade the light wrap effect up or down.
- **Mode:** Use this pop-up menu to choose the compositing method that blends the sampled background values with the edges of the keyed subject. There are five modes:
  - **Normal:** Evenly blends light and dark values from the background layer with the edges of the keyed foreground layer.
  - **Lighten:** Compares overlapping pixels from the foreground and background layers, and then preserves the lighter of the two. Good for creating a selective light wrap effect.
  - **Screen:** Superimposes lighter portions of the background layer over wrapped areas of the keyed foreground layer. Good for creating an aggressive light wrap effect.
  - **Overlay:** Combines the background layer with the wrapped areas of the keyed foreground layer so overlapping dark portions become darker, light portions become lighter, and colors become intensified.
  - **Hard Light:** Similar to the Overlay composite mode, except that colors become muted.
Animate the chroma key effect
To compensate for changing conditions in the foreground clip, you can make Sample Color and Edges adjustments at multiple points in the clip.

The following steps assume you have applied the chroma key effect.

1 Place the Timeline’s playhead at the start of the clip.
2 Use Sample Color and Edges (described above) to create a good chroma key.
3 Move the Timeline’s playhead to a point later in the clip where the lighting or background conditions change, resulting in the chroma key no longer being acceptable.
4 Use Sample Color and Edges to once again create a good chroma key.
5 To add additional adjustments at other playhead positions, repeat steps 3 and 4 as needed.
6 To move the playhead between each adjustment point you add, use the Jump to Sample arrows.

When you play the clip, the Sample Color and Edges settings smoothly change from one sample point to the next. For even greater control, you can add keyframes for most of the other settings in the Keyer section of the Video inspector. For more information about working with keyframes, see “Video animation overview” on page 270.

Note: Keyframes for the chroma and luma graphs in the Color Selection controls appear only in the Video inspector and not the Video Animation Editor in the Timeline.

Use luma keys
Luma keys provide a way to composite a foreground clip over a background clip based on the luminance levels in the video. This is most often useful for still images, such as a picture of a logo over a black background, or computer-generated graphics.
For the following examples, this speedometer image will be keyed over an outdoor car scene, creating a reflected look.

Apply the luma key effect

1 In the Timeline, move the playhead to the point in the background clip (the clip you want to superimpose the luma key clip over) where you want the key to start.

2 In the Event Browser, select the part of the foreground clip (the luma key clip with the black or white you want to remove) you want to key over the background, and choose Edit > Connect to Primary Storyline (or press Q).

For details about connecting clips in this way, see “Connect clips to add cutaway shots, titles, and synchronized sound effects” on page 113.
3 Select the foreground clip in the Timeline and click the Effects button in the toolbar.

4 In the Effects Browser, select the Luma Keyer effect.

Tip: Type “keyer” in the Effects Browser’s search field to quickly find the Luma Keyer effect.

5 Do one of the following:
   - Drag the effect to the Timeline foreground clip to which you want to apply it.
   - Double-click the effect thumbnail to apply it to the selected clip.

The Luma Keyer effect automatically configures itself to remove black video. If the resulting key is not right or you would like to improve it, you can adjust the luma key effect.

Adjust the luma key effect
The following steps assume you have applied the Luma Keyer effect.

1 In the Timeline, select the clip with the Luma Keyer effect.
2 Open the Video inspector.

The Effects section of the Video inspector shows the parameters available for adjusting the Luma Keyer effect.

3 To reverse the key and remove white instead of black areas of the foreground clip, select Invert.
4 To adjust the white and black clip values, drag the handles at either end of the gradient thumbnail image.

By default, these handles are set to provide a linear key where the luma level linearly controls the transparency of the foreground—100% white is fully opaque, 0% black is completely transparent, and 25% gray retains 25% of the foreground image. Dragging the white and black controls changes the values that result in fully opaque or fully transparent foreground video.

5 To adjust the softness of the edges, adjust the Luma Rolloff control.

Higher values make the edges harder, removing any partial transparency, while lower values take advantage of any anti-aliasing or softness the edges might have.

6 To help fine-tune the key, use the View options:

- **Composite**: Shows the final composited image, with the keyed foreground subject over the background clip. This is the default view.
- **Matte**: Shows the grayscale matte, or alpha channel, that’s being generated by the keying operation. White areas are solid, black areas are transparent, and varying shades of gray indicate varying levels of transparency. Viewing the alpha channel makes it easier to spot unwanted holes in the key or areas that aren’t transparent enough.
- **Original**: Shows the original, unkeyed image.

7 To leave smoothly aliased text or graphics in the image visually intact, which can improve the edges, select Preserve RGB.

8 To mix the keyed effect with the unkeyed effect, adjust the Mix control.

For information about making advanced luma key adjustments, see the following instructions.
Make advanced luma key adjustments
The following controls are available for use in difficult keying situations or for fine-tuning specific problems:

- **Matte Tools**: These controls are for refining the transparency matte generated by the previous sets of parameters. These parameters don’t alter the range of values sampled to create the keyed matte. Instead, they alter the matte generated by the Keyer effect’s basic and advanced controls, letting you shrink, expand, soften, or invert the matte to achieve a better composite.

- **Light Wrap**: These controls are for blending color and lightness values from the background layer of your composite with the keyed foreground layer. Using these controls, you can simulate the interaction of environmental lighting with the keyed subject, making it appear as if background light wraps around the edges of a subject.

The following steps assume you have applied the luma key effect.

1. In the Timeline, select the clip with the Luma Keyer effect.
2. Open the Video inspector.

The Effects section of the Video inspector shows the parameters available for adjusting the Luma Keyer effect.
3 Click Matte Tools to reveal the following controls:

- **Fill Holes:** Increasing this parameter value adds solidity to regions of marginal transparency within a key. This control is useful when you're satisfied with the edges of your key, but you have unwanted holes in the interior that you can't eliminate via the Luma Rolloff parameter without ruining your edges.

- **Edge Distance:** Lets you adjust how close to the edge of your keyed subject the effect of the Fill Holes parameter gets. Reducing this parameter value brings the filled area of the matte closer to the edge of the subject, sacrificing translucency at the edges. Raising this parameter value pushes the filled area of the matte farther from the edge, potentially introducing regions of unwanted translucency within parts of the subject that should be solid.

- **Levels:** Use this grayscale gradient to alter the contrast of the keyed matte, by dragging three handles that set the black point, white point, and bias (distribution of gray values between the black point and white point). Adjusting the contrast of a matte can be useful for manipulating translucent areas of the key to make them more solid (by lowering the white point) or more translucent (by raising the black point). Dragging the Bias handle right erodes translucent regions of the key, while dragging the Bias handle left makes translucent regions of the key more solid.

- **Black, White, Bias:** Click the disclosure triangle in the Levels row to reveal sliders for the Black, White, and Bias parameters. These sliders, which mirror the settings of the Levels handles described above, allow you to keyframe the three Levels parameters (via the Add Keyframe button to the right of each slider). Keyframing the Black, White, and Bias parameters may yield a better key, one that adapts to changing blue-screen or green-screen conditions.

- **Shrink/Expand:** Use this slider to manipulate the contrast of the matte to affect matte translucence and matte size simultaneously. Drag the slider left to make translucent regions more translucent while simultaneously shrinking the matte. Drag the slider right to make translucent regions more solid while simultaneously expanding the matte.
- **Soften**: Use this slider to blur the keyed matte, feathering the edges by a uniform amount.
- **Erode**: Drag this slider right to gradually increase transparency from the edge of the solid portion of the key inward.

4. Click Light Wrap to reveal the following controls:

![Light Wrap controls](image)

- **Amount**: Use this slider to control the overall light wrap effect, setting how far into the foreground the light wrap extends.
- **Intensity**: Use this slider to adjust gamma levels to lighten or darken the interaction of wrapped edge values with the keyed foreground subject.
- **Opacity**: Use this slider to fade the light wrap effect up or down.
- **Mode**: Use this pop-up menu to choose the compositing method that blends the sampled background values with the edges of the keyed subject. There are five modes:
  - **Normal**: Evenly blends light and dark values from the background layer with the edges of the keyed foreground layer.
  - **Lighten**: Compares overlapping pixels from the foreground and background layers, and then preserves the lighter of the two. Good for creating a selective light wrap effect.
  - **Screen**: Superimposes lighter portions of the background layer over wrapped areas of the keyed foreground layer. Good for creating an aggressive light wrap effect.
  - **Overlay**: Combines the background layer with the wrapped areas of the keyed foreground layer so overlapping dark portions become darker, light portions become lighter, and colors become intensified.
  - **Hard Light**: Similar to the Overlay composite mode, except that colors become muted.
**Finalize the key**

Quite often your foreground image will have objects that you don’t want to appear in the composited output. These could be production items like microphone booms and light stands or the edges of the chroma key backdrop. Additionally, you might need to resize or reposition the foreground object to better fit with the background. As a final step, you can use the color corrector to adjust the foreground so that it matches the look of the background.

Final Cut Pro includes effects that you can use for these purposes.

**Use the Mask effect**

1. In the Timeline, move the playhead to the point in the background clip (the clip you want to superimpose the chroma key clip over) where you want the key to start.

2. In the Event Browser, select the part of the foreground clip (the chroma key clip with the color you want to remove) you want to key over the background, and choose Edit > Connect to Primary Storyline (or press Q).

For details about connecting clips in this way, see “Connect clips to add cutaway shots, titles, and synchronized sound effects” on page 113.
3 Select the foreground clip.

In the above example, the light stands need to be removed.

4 Click the Effects button in the toolbar.

5 In the Effects Browser, double-click the Mask effect to apply it to the selected foreground clip.

Tip: Type “mask” in the Effects Browser’s search field to quickly find the mask effect.
6 Adjust the four corners of the mask to crop out the objects you want to remove, in this case, the light stands.

When adjusting the mask, be sure to leave shadows and other details that can help make the key more realistic later.

7 Apply the appropriate keyer effect to the foreground clip.

The foreground is composited over the background.
Use Transform to position the foreground image
The following steps assume you have already configured a key but need to reposition the foreground image.

1. Select the foreground clip in the Timeline.
2. In the Viewer, click the Transform button and move the image to the position you want. In the above example, you might want to move the woman to the left. You can also resize the image.

3. Click Done in the Viewer when you are finished repositioning the foreground image.
Compositing

Compositing overview
Compositing refers to combining parts of two or more video clips into a single image. There are a number of ways to combine video images in Final Cut Pro:

- **Transitions**: All video transitions involve combining the end of one clip with the start of a second clip, which results in a combination of the two clips appearing at the same time during the transition.

- **Keying**: All keys involve compositing a foreground image over a background image.

- **Alpha channels**: Many computer-generated video clips have an alpha channel—a built-in mask—that defines precisely the areas of the clip that are composited over a background clip. These require no key setup and generally just automatically work. Many effects, such as Transform and Distort; generators, such as Shapes and Timecode; and titles use alpha channels.

- **Compositing**: Each video clip in the Timeline has a set of Compositing settings. These are used when you want to combine clips without using the key effects.

Use alpha channels
Alpha channels provide an easy way to composite one image over another. Using an application like Motion, an Apple application designed to work with Final Cut Pro, you can create still images and video clips that have alpha channels. Alpha channels can be thought of as having a built-in keyer—when you use the key effects you are creating a mask that is used in the same way a clip with an alpha channel is used for compositing.

Below is an example of a clip with an alpha channel, showing the image that fills the alpha channel.
Below is the alpha channel image—the white areas define the video areas that are composited over the background. The gray areas (which define the shadow in this example) define parts of the image that are partially transparent.

This is what the final composite looks like over a background clip.

**Use a clip with an alpha channel**

1. Position the playhead in the Timeline where you want to add the alpha channel clip.
2. Select the clip that has an alpha channel in the Event Browser, and choose Edit > Connect to Primary Storyline (or press Q).
3 To see the composited clips, position the playhead within the clip that was just added above the primary storyline.

The clip is composited over the primary storyline video clip, with the alpha channel controlling the opacity of its clip.

You can also use the Opacity adjustment’s fade handles to dissolve the foreground clip on and off.

**Use Compositing settings**

The Compositing settings provide a wide variety of options for combining two images. You can make a simple adjustment to evenly combine two images, or you can choose from settings that use the video content to determine how to combine the images.

**Use the Opacity adjustment**

1 Position the playhead in the Timeline where you want to add a clip above the primary storyline.

2 Select the clip to add in the Event Browser, and choose Edit > Connect to Primary Storyline (or press Q).

3 To see the composited clips, position the playhead within the clip that was just added.

By default, the new clip completely obscures the clip on the primary storyline.
To make the new clip partially transparent, select it in the Timeline and adjust the Opacity control in the Compositing section of the Video inspector.

The closer you set Opacity to 0 percent, the more transparent the clip above the primary storyline becomes. Additionally, you can use the Opacity fade handles in the Video Animation Editor to have the composited clip dissolve on and off, or add keyframes to have the opacity value change at specified points.

Choose a blend mode

1. Position the playhead in the Timeline to where you want to add a clip above the primary storyline.

2. Select the clip to add in the Event Browser, and choose Edit > Connect to Primary Storyline (or press Q).

3. To see the composited clips, position the playhead within the clip that was just added.
   By default, the new clip completely obscures the clip on the primary storyline.

4. Choose an option from the Blend Mode pop-up menu in the Compositing section of the Video inspector.
   There are many blend mode settings to choose from—the correct one to use depends on the video content and the sort of look you are aiming for. Additionally, you can adjust the Opacity control to make the blend mode setting more subtle.
Color correction overview
In any post-production workflow, color correction is generally one of the last steps in finishing an edited program. There are a number of reasons to color correct your footage:

• Make sure that key elements in your program, such as flesh tones, look the way they should
• Balance all the shots in a scene to match
• Correct errors in color balance and exposure
• Achieve a look, such as making the scenes warmer or cooler
• Create contrast or special effects by manipulating the colors and exposure

Final Cut Pro color correction tools give you precise control over the look of every clip in your project, including still images, by letting you adjust each clip’s color balance, shadow levels, midtone levels, and highlight levels. Final Cut Pro also includes several automatic tools you can use to quickly balance and match the color in clips. In Final Cut Pro, you can:

• **Automatically balance colors:** With one click, neutralize any color casts and maximize image contrast. See “Color balance overview” on page 410.

• **Automatically match a clip’s color and look:** With two clicks, make one or more clips match the color look of any clip that you choose. See “Match color between clips automatically” on page 412.

• **Manually adjust color, saturation, and exposure:** Manually correct a clip’s overall color, or use color or shape masks to limit a correction to a particular color range or area in the image. You can even add multiple manual color corrections to one clip. See “Manual color correction overview” on page 414.

• **Save color correction settings and apply them to other clips:** Save a clip’s color correction settings and apply them to other clips in the project or in other projects. See “Save and apply color correction presets” on page 425.
Although these features are independent of one another—you can turn any of the features off and on to see its effect—the order in which you use them matters. In general, you should use these features in the order of Balance Color, Match Color, and (if necessary) manual color correction.

Final Cut Pro also includes several video scopes you can use when manually color correcting your video. The scopes make it possible to precisely monitor the luma and chroma levels of your video clips.

**Analyze and balance color automatically**

**Color balance overview**

Final Cut Pro includes an automatic color-balancing feature. When you use the color-balancing feature, Final Cut Pro samples the darkest and lightest areas of the image’s luma channel and adjusts the shadows and highlights in the image to neutralize any color casts. In addition, Final Cut Pro adjusts the image to maximize image contrast, so that the shot occupies the widest available luma range.

The video frame used as the reference frame depends on whether the clip has already been color analyzed:

- **If the clip has been color analyzed, either during import or while in the Event Browser:** The analysis process extracts color balance information for the entire clip. Whether you add a portion of the clip or the entire clip to a project, the color-balancing feature chooses the frame within the project clip that is closest to being correctly balanced. This means that if you add multiple partial clips from the same Event Browser clip to the project, each clip is balanced based on analysis information for its own section of media.

- **If the clip has not been color analyzed and you balance its color:** You can determine the reference frame for a clip selected in the Timeline by moving the playhead to that frame in the clip. If the playhead is on a different clip or you’ve selected a clip in the Event Browser, the clip’s middle frame is used.

**Analyze a clip for color balance**

To automatically balance a clip’s color, Final Cut Pro uses a single frame from the clip as a reference and calculates a correction for it that is then applied to the entire clip. Analyzing a clip for color balance allows Final Cut Pro to choose a representative frame as the clip’s color balance reference frame.

You can have a clip’s color balance analyzed when you import it, whether importing from a camera, importing a file, or dragging a clip directly to the Timeline from a Finder window. You can also analyze a clip’s color balance at any time in the Event Browser.
Analyzing a clip for color balance can take from a few seconds for shorter clips to a minute or more for longer clips. The analysis process takes longer if you also analyze for people and stabilization issues.

After a clip has been analyzed for color balance, you can turn the color balance correction on or off at any time. By default, color balance correction is off for clips in the Event Browser and on for clips in the Timeline, if they have been analyzed. For information about turning the color balance correction on and off, in either the Event Browser or the Timeline, see “Balance a clip’s colors” on page 412.

**Analyze color balance during file import**

1. Do one of the following:
   - To import files from a camera: Choose File > Import from Camera (or press Command-I).
   - To import files from your file system: Choose File > Import > File (or press Command-Shift-I).

2. Select the files to import, and select “Analyze for balance color” in the Video section of the window.

3. Click Import.

   The files are imported and analyzed for color balance issues.

**Analyze color balance for clips dragged to the Timeline from the Finder**

1. Choose Final Cut Pro > Preferences, or press Command-Comma (,).

2. In the Final Cut Pro Preferences window, click the Import button and select “Analyze for balance color” in the Video section.

   All clips that you drag directly to the Timeline from the Finder are now analyzed.

*Note:* When you change this setting in the Preferences window, the setting is also changed in all other windows with an “Analyze for balance color” option.

**Analyze color balance for clips in the Event Browser**

When you analyze the color balance of clips in the Event Browser, any clips that were analyzed during import are skipped.

1. Select one or more clips in the Event Browser.

2. Do one of the following:
   - Choose Modify > Analyze and Fix.
   - Control-click one of the selected clips and choose Analyze and Fix from the shortcut menu.

3. In the window that appears, select “Analyze for balance color” in the Video section and click OK.
Balance a clip’s colors
Clips in Final Cut Pro have a Balance setting that turns automatic color balance correction on and off, whether the clip is in the Event Browser or the Timeline. The frame used as the reference frame is either a frame chosen during color balance analysis, the frame the playhead is on in the Timeline, or the middle frame. For more information, see “Color balance overview” on page 410.

Turn a clip’s color balance correction on and off
1 Select one or more clips in the Timeline or the Event Browser.
2 Do one of the following:
   • Choose Modify > Balance Color (or press Command-Option-B).
   • Choose Balance Color from the Enhancements pop-up menu in the toolbar.
   • In the Color section of the Video inspector, select or deselect the Balance checkbox.

Match color between clips automatically
Your project likely uses video from a wide variety of sources. The Match Color feature makes it easy to ensure that all scenes that take place in the same location have the same look.

Match color between clips
1 Select one or more clips in the Timeline that you want to adjust.
2 Do one of the following:
   • Choose Modify > Match Color (or press Command-Option-M).
   • Choose Match Color from the Enhancements pop-up menu in the toolbar.
• In the Color section of the Video inspector, click the Choose button next to Match Color.

The Viewer changes to display the Timeline playhead’s frame on the right and the frame the pointer is over on the left.

3 Skim any clip in the Timeline or the Event Browser to find a frame with the color look you want to match, and click to preview that look applied to the selected clip.

You can click a variety of clips until you find the look you want.

**Tip:** You may want to import a still image that has the look you want, even if it’s not related to your project, so that you can match its color look.

4 To accept the current look, click Apply Match in the Match Color window.

The Viewer returns to its normal configuration, and the selected Timeline clips change to the new look.

**Turn match color corrections on or off**

You can turn off the color match corrections that have been applied to a clip. This is useful for viewing the difference between the original clip and the corrected clip.

1 In the Timeline, select a clip with match color corrections applied.
2 Click the Color Match checkbox in the Color section of the Video inspector.
Adjust color manually

Manual color correction overview
Final Cut Pro includes a powerful manual color correction tool that you can use to accomplish a wide variety of color correction or enhancement effects:

- *Apply a color correction to the whole image:* Adjust the color tint, color saturation, and exposure for the whole clip image. See “Color correct the whole image” on page 414.

- *Choose a specific color in the image to correct:* For example, choose a brightly colored object, such as a shirt or car, and use the color correction settings to mute or change the color. See “Target a specific color using a color mask” on page 417.

- *Choose an area of the image to correct:* Draw one or more shape masks, and then choose whether the correction applies inside or outside the masks. You can even have the position of the masks change as the clip plays. See “Target specific areas using shape masks” on page 419.

You can also apply multiple color corrections to a single clip and use shape masks in combination with a color mask. For example, you could use one correction to set the clip’s overall color look, a second to target and alter a specific color, and a third to target a different color or an area defined by a shape mask. See “Apply multiple color corrections” on page 423 and “Add shape masks to a color mask” on page 422.

You make manual color adjustments using the Color Board.

Color correct the whole image
You use the Color Board to manually adjust a clip’s color, saturation, and exposure.

Manually color correct the whole clip image
1 Select a clip in the Timeline, and do one of the following:
   - Choose Window > Show Color Board (or press Command-6).
   - Choose Show Color Board from the Enhancements pop-up menu in the toolbar.
• Click the Color Board button in the Color section of the Video inspector. (After you make any Color Board adjustments, the button changes color.)
• Click the upper-left corner of a clip in the Timeline and choose Color Adjustment from the pop-up menu.

2 If the clip has multiple corrections applied to it, choose the correction to adjust from the Correction pop-up menu in the Color Board’s upper-right corner.

3 To add or remove a color tint, click Color (or press Command-Control-C), and drag the controls in the Color pane.
   • To adjust the tint for the whole image: Drag the Global control (the large gray control).
   • To adjust the tint in the darker areas of the image: Drag the Shadows control (the black control).
   • To adjust the tint in the midtones: Drag the Midtones control (the small gray control).
   • To adjust the tint in the brighter areas of the image: Drag the Highlights control (the white control).

Dragging the controls up adds the color to the video, and dragging them down subtracts the color (effectively adding the opposite color). Dragging the controls left and right chooses the color to add or subtract.

Tip: To move the selected Color Board control up or down, press the Up Arrow or Down Arrow key. In the Color pane, you can also use the Left Arrow or Right Arrow key to move the selected control left or right.
To adjust the clip's chroma level, click Saturation (or press Command-Control-S), and drag the controls in the Saturation pane.

- To adjust saturation for the whole image: Drag the Global control on the left.
- To adjust saturation in the darker areas of the image: Drag the Shadows control.
- To adjust saturation in the midtones: Drag the Midtones control.
- To adjust saturation in the brighter areas of the image: Drag the Highlights control.

Dragging the controls up increases the chroma level, and dragging them down reduces the level. These controls do not move left and right.

To adjust saturation for the whole image:

Drag the Global control on the left.

To adjust saturation in the darker areas of the image:

Drag the Shadows control.

To adjust saturation in the midtones:

Drag the Midtones control.

To adjust saturation in the brighter areas of the image:

Drag the Highlights control.

To adjust saturation in the brighter areas of the image:

Drag the Highlights control.

Dragging the controls up increases the chroma level, and dragging them down reduces the level. These controls do not move left and right.

You can use the Command Editor to assign a keyboard shortcut to turn color corrections on and off while making adjustments in the Color Board, and to assign keyboard shortcuts to many other Color Board functions. For more information, see “View keyboard shortcuts in the Command Editor” on page 526.

Reset and turn off Color Board color corrections

1 In the Timeline, select a clip whose color corrections you want to remove.

2 In the Color Board, do any of the following:

- To reset the currently selected control to its neutral state: Press Delete.
- To reset all of a pane's controls to their neutral state: Click the Reset button in the pane’s upper-right corner.
To reset all three Color Board panes back to their neutral state: In the Color section of the Video inspector, click the Reset button to the right of the Correction setting.

To turn Color Board corrections off without resetting them: In the Color section of the Video inspector, deselect the checkbox for the correction. Turning the corrections off and on makes it easy to quickly see the effect of your adjustments.

Target a specific color using a color mask
A color mask isolates a particular color in the image. You can apply a color mask to a clip to correct a specific color, or to exclude that color from corrections to the rest of the image, or both. For example, you could mute a brightly colored shirt in the background that distracts attention from a clip's main subject.

Using a color mask to control the color correction allows you to pick a color and then independently adjust that color (reduce, enhance, or change it) or adjust everything except that color (for example, add a tint or reduce the brightness or chroma levels).

Add a color mask to a color correction
1 In the Timeline, select a clip with a color that you want to mute or enhance.
2 Click the Add Color Mask button in the Color section of the Video inspector.
The Color Mask section appears.

3 In the Viewer, position the eyedropper on a color in the image that you want to isolate, and drag to select the color.

As you drag, two concentric circles appear. The size of the outer circle determines the range of variations in the selected color that are included in the color mask. As you change the outer circle size, the image becomes monochrome except for the color you are selecting. You can drag a new selection circle as many times as you like to try for better results.

Note: When you stop dragging, the picture returns to its original look, but you'll see the effects of the color mask you have created as soon as you start making adjustments in the Color Board. You can then return to the Video inspector and use the eyedropper to make any adjustments to the color mask.

4 To change the range of color variations included in the mask, do either of the following:

- To add color shades: Hold down the Shift key, position the eyedropper on a color you want to add to the mask, and drag to select the color.
- To subtract color shades: Hold down the Option key, position the eyedropper on a color you want to remove from the mask, and drag to select the color.

5 To adjust the color mask edges, drag the Softness slider.

To have the Viewer temporarily show the color mask, hold down the Option key and then drag the Softness control: white indicates fully opaque mask areas, black indicates areas outside the mask, and levels of gray indicate transparent mask areas.
To adjust the color correction settings for this color mask, click the Color Board button in the Video inspector. (After you make any Color Board adjustments, the button color changes.)

Do one of the following:

- To apply a color correction to the selected color: Click Inside Mask.

- To apply a color correction to everything except the selected color: Click Outside Mask.

You can make corrections to both the inside and outside areas of the mask—each area effectively has its own complete set of Color Board controls. For example, you could select Inside Mask and enhance the targeted color, and then select Outside Mask to darken everything else.

Adjust the Color Board controls to create the effect you want.

For more information about working with the Color Board, see “Color correct the whole image” on page 414.

To limit the area of the image affected by a color mask, you can add a shape mask. For more information, see “Add shape masks to a color mask” on page 422.

**Target specific areas using shape masks**

A shape mask defines an area in the image so that you can apply color corrections either inside or outside that area. For example, you might want to emphasize a subject’s face by darkening the area around the face.

You can add multiple shape masks to define multiple areas, and you can also animate the shapes so that they follow an area while a camera pans or an object moves as the clip plays.

**Add a shape mask**

1. In the Timeline, select a clip with an area whose color you want to mute or enhance.
2. Click the Add Shape Mask button in the Color section of the Video inspector.
A Shape Mask area appears.

3 To adjust the default shape that appears in the Viewer, do any of the following:

- **To position the shape**: Drag the center.
- **To adjust the shape’s width or height**: Drag any of the four handles at the 90-degree points (top, bottom, left, or right) of the inner circle. You can hold down the Shift key while dragging to force all sides to scale proportionally.
- **To control the roundness of the shape**: Drag the handle to the left of the inner circle’s top handle.
- **To rotate the shape**: Drag the rotation handle (extending from the center).
- **To control the softness of the shape’s edge**: Drag the outer circle. Setting the outer circle close to the inner circle creates a hard edge and an abrupt transition to the corrections you apply, and dragging the outer circle away from the inner circle creates a softer edge and a more gradual transition.
- **To hide the mask’s controls**: Click the Shape Mask onscreen controls button in the Shape Mask area of the Color section of the Video inspector.

4 To adjust the color correction settings for this shape mask, click the Color Board button in the Video inspector. (After you make any Color Board adjustments, the button color changes.)
5 Do one of the following:
   • To apply a color correction to the shape area: Click Inside Mask.
   • To apply a color correction to everything except the shape area: Click Outside Mask.

You can make corrections to both the inside and outside areas of the mask—each area effectively has its own complete set of Color Board controls. For example, you could select Inside Mask and enhance the shape’s area, and then select Outside Mask to darken everything else.

6 Adjust the Color Board controls to create the effect you want.

For more information about working with the Color Board, see “Color correct the whole image” on page 414.

7 To add additional shapes to the correction, click the Add Shape Mask button in the color correction’s area in the Video inspector again.

Another default shape appears in the Viewer, and the original shape is dimmed. You can select and continue configuring the original shape by clicking its center.

Delete a shape mask
1 In the Video inspector, select the Shape Mask item you want to delete.

2 Press Delete.

   Note: If you delete all shape masks in the correction, the Inside Mask corrections are applied to the whole image.

Animate a shape mask
You can use keyframes to animate a shape mask so that it follows the movement of an onscreen object.

1 To add a shape mask, follow the instructions in “Add a shape mask,” above.

2 In the Timeline, position the playhead on the clip with the shape mask at the frame where you want the shape to begin moving.

3 Position the shape mask to its starting position in the Viewer.
In the Video inspector, click the Keyframe button.

A keyframe is added at the position of the playhead. You can see it in the Timeline by pressing Control-V to open the Video Animation Editor. The keyframe appears in the Color section as a diamond at the playhead position.

Move the playhead to the next point in the clip where you want to define the shape mask’s position, reposition the shape mask, and add the second keyframe.

To reposition the shape mask throughout the clip, continue adding keyframes until you’ve defined the shape movement you want.

When you’ve added all the keyframes, you can play the clip to see the shape mask move between them. For more information about working with keyframes, see “Video animation overview” on page 270.

Add shape masks to a color mask

Often when you create a color mask, more areas of the video are affected by it than you would like. For example, there might be a red car on the left side of the screen that you want to color correct, and a red stop sign on the right that you don’t want to affect. In this situation, you can add one or more shape masks to restrict the color mask to the areas defined by the shape masks.

Add a shape mask to a color mask

1 Select a clip in the Timeline, and use the Video inspector to add a color mask to it.

2 Apply a color correction using the Color Board, and note areas of the video that you don’t want the color mask to affect.

For more information about working with the Color Board, see “Color correct the whole image” on page 414.
3 In the Video inspector, click the Add Shape Mask button in the correction that has the color mask.

4 Adjust the shape mask so that it overlaps the part of the color mask you want to use.

5 To adjust the color correction settings, click the Color Board button in the Video inspector. (After you make any Color Board adjustments, the button color changes.)

6 Do either of the following:
   - To make color correction adjustments that apply only to the areas of overlap between the color mask and shape mask: Select Inside Mask, at the bottom of the Color Board.
   - To make color correction adjustments that apply outside the areas of overlap between the color mask and shape mask: Select Outside Mask.

If necessary, you can add additional shape masks, and even animate them.

**Apply multiple color corrections**

You can apply multiple color corrections to a clip to target specific issues. For example, you could have one color correction that mutes a bright orange shirt and a second one that enhances the green in the lawn.

Color masks are created based on the original colors in the clip. For example, if the first color correction removes all chroma from the clip, the second color correction can still create a color mask based on a color originally in the clip.

**Apply multiple color corrections to a clip**

1 Select a clip in the Timeline.

2 To add an additional color correction item, click the Add Correction button in the Video inspector.
By default, the Color section contains the first manual color correction item (Correction 1) along with the Balance and Match Color items. Color correction items that you add are named Correction 2, Correction 3, and so on. Each correction item has its own Color Board button—clicking one of these opens the Color Board with that correction’s settings. You can also choose a correction in the Color Board using the pop-up menu in the upper-right corner.

**View color correction keyframes in the Timeline**

If a clip has multiple corrections with animated shape masks, you can view a correction’s shape mask keyframes in the Video Animation Editor above the clip in the Timeline.

1. In the Timeline, select a clip that has multiple color corrections with animated shape masks applied.
2. Choose Clip > Show Video Animation (or press Control-V).
3. Choose the color correction you want to view from the Color pop-up menu:
   - To see a composite of keyframes from all corrections: Choose the correction, and if it contains multiple shape masks, choose the one you want to see.
   - To see keyframes from a specific shape mask in a correction: Choose the correction, and if it contains multiple shape masks, choose the one you want to see.

   When you choose a specific correction, such as Correction 2, you see its keyframes in white and the keyframes of other corrections in dark gray.

**Add a transition between color corrections**

You can have a video clip change from one color correction to another using a transition. For example, if you want a scene to gradually highlight the two main characters, you can use a transition to dissolve between the normal clip and the clip with shape masks and a color correction applied that darkens the image outside of the masks.

*Important:* Make sure that Available Media is chosen from the “Apply transitions using” pop-up menu in the Editing pane of Final Cut Pro preferences. For more information about this setting, see “How transitions are created” on page 219.
Configure a clip to change transitions

1 Temporarily switch to the Blade tool by holding down the B key.

2 In the Timeline, click a video clip at the point where you want to change between color corrections.
   The clip splits into two clips.

3 Apply a different color correction to each clip.
   You can also leave one clip uncorrected and apply a color correction to the other. The color correction could be an exaggerated tint, an exposure change, or any other noticeable adjustment.

4 Select the edit point between the two clips, and press Command-T to insert a cross dissolve.
   When you play the clip, one color correction dissolves into the other as the edit point is passed.

Save and apply color correction presets

With Final Cut Pro, you can save a clip's color correction settings as a preset, making it easy to apply those settings to other clips in the same project or a different project.

Final Cut Pro includes several presets you can use in addition to any that you create.

*Note:* Color correction presets save the current Color, Saturation, and Exposure settings only. They do not save the mask settings, including whether you have Inside Mask or Outside Mask selected.

Save a color correction preset

1 In the Timeline, select a clip that has the color correction look you want to save, and open the Color Board.

2 Choose Save Preset from the Action pop-up menu in the lower-right corner of the Color Board.

3 Type a name for the preset and click OK.

Apply a color correction preset

1 Select a clip in the Timeline, and open the Color Board.

2 Choose a preset from the Action pop-up menu in the lower-right corner of the Color Board.
   The preset’s adjustments are applied to the selection. After the preset has been applied, you can modify the settings using the Color Board.
Turn iMovie adjustments on or off
When editing a project in iMovie, you can adjust several video attributes, such as exposure, brightness, and saturation, in the Project Browser. If you import an iMovie project that has these adjustments into Final Cut Pro, the adjustments are retained and appear in the Color area of the Video inspector as an iMovie item.

Although you cannot modify the adjustments added in iMovie, you can choose whether they are applied to the clip or not.

Note: Video adjustments you make to clips in the iMovie Event Browser are not retained and do not appear in Final Cut Pro.

Turn a clip’s iMovie adjustments on or off
- In the Timeline, select a clip with iMovie adjustments applied, and select or deselect the iMovie checkbox in the Color area of the Video inspector.

Note: The iMovie adjustments appear only in the Timeline, not in the Event Browser.

For more information about importing iMovie projects, see “Import from iMovie” on page 38.

Measure video levels
Video scopes overview
Broadcast facilities have limits on the maximum values of luma and chroma that are allowable for broadcast. If a video program exceeds these limits, distortion can appear in the form of colors bleeding into one another, the whites and blacks of your program washing out, or the picture signal bleeding into the audio signal and causing audible distortion. In all these cases, exceeding standard signal levels can result in unacceptable transmission quality. As you’re color correcting clips in your project, you can use the Final Cut Pro video scopes to make sure that the luma and chroma levels of your video stay within the parameters referred to as broadcast-safe, or acceptable for broadcast.
Even if your project is not intended for broadcast, using the video scopes is an important part of your workflow. If the monitors you’re using don’t display color accurately or you’ve been working with the same clips for a while, you can easily get used to seeing a color cast or blacks that are not quite right. The scopes provide exact measurements of the luma and chroma levels of your clips so that you can make more informed decisions about adjusting Final Cut Pro color correction settings.

Final Cut Pro provides the following video scopes:

- Waveform Monitor
- Vectorscope
- Histogram

**Use the video scopes**
The video scopes appear in the Viewer, to the left of the video image. Only one scope appears at a time.

**Open a scope**

1. Do one of the following:
   - Choose Window > Show Video Scopes (or press Command-7).
   - Choose Show Video Scopes from the Viewer Options pop-up menu.

You can use the same commands to close the video scope.

2. Choose the scope to display from the top section of the Settings pop-up menu.

3. After you have chosen a scope, choose the display options from the bottom section of the Settings pop-up menu.
Waveform Monitor display options
The Waveform Monitor shows the relative levels of luma and chroma in the clip currently being examined. These values are displayed from left to right, mirroring the relative distribution of luma and chroma levels from left to right in the image. Spikes and dips in the displayed waveforms correspond to light and dark areas in your picture. The waveforms are also tinted to match the color of items in the video.

The Settings pop-up menu in the upper-right corner of the Waveform Monitor provides a variety of display options:

- RGB Parade: Presents three side-by-side waveform displays that display your video as three separate red, green, and blue components. The waveforms are tinted red, green, and blue so that you can easily identify them.
The RGB Parade view is useful for comparing the relative levels of red, green, and blue between two clips. If one clip has more blue than another, the Waveform Monitor displays an elevated blue waveform for the clip with more blue and a depressed blue waveform for the other clip.

- **RGB Overlay**: Combines waveforms for the red, green, and blue color components in one display.

- **Red**: Shows only the red color channel.
- **Green**: Shows only the green color channel.
- **Blue**: Shows only the blue color channel.
- **Luma**: Shows only the luma component of the video.
- **Chroma**: Shows only the chroma component of the video, and is tinted to match the video’s colors.
• **Y'CbCr Parade:** Presents three side-by-side waveform displays for the separate luma, Cb (the blue color difference channel), and Cr (the red color difference channel) components. The waveforms are tinted white (for luma), magenta (for Cb), and yellow (for Cr) so that you can easily identify the waveform for each component.

• **IRE:** Displays the video range in IRE units.
• **Millivolts:** Displays the video range in millivolts.
• **Show Guides:** Turns the Waveform Monitor’s grid and numeric values on or off.
Vectorscope display options

The Vectorscope shows the distribution of color in your image on a circular scale. The color in your video is represented by a series of connected points that fall somewhere within this scale. The angle around the scale represents the hue displayed, with targets indicating the primary colors of red, green, and blue and the secondary colors of yellow, cyan, and magenta. The distance from the center of the scale to the outer ring represents the saturation of the color being displayed. The center of the scale represents zero saturation, and the outer ring represents maximum saturation.

The Vectorscope shows you, at a glance, the hue and intensity of the various colors in your image. Once you learn to identify the colors in your clips using the Vectorscope, you can more easily see where two images differ and correct them so that they match as closely as possible.

The Settings pop-up menu in the upper-right corner of the Vectorscope provides a variety of display options:

- **100%**: Sets the reference chroma level for the color bar targets (the squares representing each color in a standard color bar test signal) at 100 percent saturated chroma. Use this when your source media uses 100 percent color bars as its reference.
- **133%**: Sets the reference chroma level for the color bar targets at 75 percent saturated chroma. Use this when your source media uses 75 percent color bars as its reference.
- **Vector**: Uses a normal chroma hue reference, with red near the top.
- **Mark3**: Uses a 90-degree rotated chroma hue reference, with red on the right side.
- **Show/Hide Skin Tone Indicator**: Shows or hides the diagonal line that represents the human skin tone chroma phase, which is between the yellow and red color bar targets.
**Histogram display options**

The Histogram provides a statistical analysis of the image by calculating the total number of pixels of each color or luma level and creating a graph that shows the number of pixels at each percentage of luma or color. Each increment of the scale from left to right represents a percentage of luma or color, and the height of each segment of the Histogram graph shows the number of pixels that correspond to that percentage.

The Settings pop-up menu in the upper-right corner of the Histogram provides a variety of display options:

- **Luma:** Shows only the luma component of the video. The height of the graph at each step on the scale represents the number of pixels in the image at that percentage of luma, relative to all the other values. For example, if an image has few highlights, the Histogram shows a large cluster of values in the midtones.

Using the Luma Histogram view, you can quickly compare the luma of two shots so that you can adjust their shadows, midtones, and highlights to match more closely.

The shape of the graph also helps you determine the amount of contrast in an image. A low-contrast image has a concentrated clump of values nearer to the center of the graph. By comparison, a high-contrast image has a wider distribution of values across the entire width of the graph.

- **RGB Overlay:** Combines waveforms for the red, green, and blue color components in one display. If the image being examined has equal levels of two or more colors, you see the combined color:
  - Equal levels of green and blue appear as cyan.
  - Equal levels of green and red appear as yellow.
• Equal levels of red and blue appear as magenta.
• Equal levels of red, green, and blue appear as gray.

*RGB Parade:* Presents three graphs that display your video as separate red, green, and blue components. The waveforms are tinted red, green, and blue so that you can easily identify them.

You can use the RGB Parade view to compare the relative distribution of each color channel across the tonal range of the image. For example, images with a red color cast have either a significantly stronger red graph or weaker green and blue graphs.

• *Red:* Shows only the red color channel.
• *Green:* Shows only the green color channel.
• *Blue:* Shows only the blue color channel.
Sharing projects overview

The Final Cut Pro Share menu provides a variety of options designed to make it easy for you to distribute your project. Most of the options have a specific target, such as an Apple device connected to iTunes, a Blu-ray disc, or a specific website.

You can also use export options in the Share menu to create an output file that you can then distribute manually. This is useful when you want to give a client a set of files on a portable drive or manually copy files to a network location.

To further customize your output file or to spread the processing work across multiple computers, you can use the settings for Compressor, the professional transcoding application.

By default, all Share menu options create the output files in the foreground, providing the fastest results. Except when using the Export Media and Save Current Frame options, you can choose to have output files created in the background. This means you can continue working in your project in Final Cut Pro (although any changes you make to the project after it has been shared are not reflected in the output files). For more information, see “Export your project using Compressor” on page 456.

<table>
<thead>
<tr>
<th>Share menu item</th>
<th>Use to</th>
</tr>
</thead>
<tbody>
<tr>
<td>Share with other applications</td>
<td></td>
</tr>
<tr>
<td>Media Browser</td>
<td>Make your project available for use in iLife and iWork applications, such as iPhoto, GarageBand, and Keynote.</td>
</tr>
<tr>
<td>Apple Devices</td>
<td>Play your project in iTunes; on iPhone, iPad, and iPod; and on your home theater system using Apple TV.</td>
</tr>
<tr>
<td>Email</td>
<td>Email your project using Mail.</td>
</tr>
<tr>
<td>Podcast Producer</td>
<td>Publish your project to a podcast server set up using Mac OS X Server.</td>
</tr>
<tr>
<td>Share menu item</td>
<td>Use to</td>
</tr>
<tr>
<td>-----------------------</td>
<td>----------------------------------------------------------------------</td>
</tr>
<tr>
<td>Burn to a disc</td>
<td>Burn your project to a standard-definition DVD or create a disk image (.img) file you can copy to an external drive or burn to disc later.</td>
</tr>
<tr>
<td>DVD</td>
<td>Burn your project to a standard-definition DVD or create a disk image (.img) file you can copy to an external drive or burn to disc later.</td>
</tr>
<tr>
<td>Blu-ray</td>
<td>Burn your project to a Blu-ray–compatible disc or create a disk image (.img) file you can copy to an external drive or burn to disc later.</td>
</tr>
<tr>
<td>Publish to a website</td>
<td>Publish your project to your account on any of these websites.</td>
</tr>
<tr>
<td>YouTube</td>
<td>Publish your project to your account on any of these websites.</td>
</tr>
<tr>
<td>Facebook</td>
<td>Publish your project to your account on any of these websites.</td>
</tr>
<tr>
<td>Vimeo</td>
<td>Publish your project to your account on any of these websites.</td>
</tr>
<tr>
<td>CNN iReport</td>
<td>Publish your project to your account on any of these websites.</td>
</tr>
<tr>
<td>Export to a file</td>
<td>Export your project as a movie file, as a video file (with no audio), or as an audio file (with no video). You can also export one or more of the roles used in your project in one or more files, also known as media stems.</td>
</tr>
<tr>
<td>Export Media</td>
<td>Export your project as a movie file, as a video file (with no audio), or as an audio file (with no video). You can also export one or more of the roles used in your project in one or more files, also known as media stems.</td>
</tr>
<tr>
<td>Save Current Frame</td>
<td>Export a video frame as an image file in a variety of standard image formats.</td>
</tr>
<tr>
<td>Export Image Sequence</td>
<td>Export your project as a series of numbered still frames.</td>
</tr>
<tr>
<td>Export HTTP Live Streaming</td>
<td>Export the project as a set of files ready for HTTP live streaming from a web server.</td>
</tr>
<tr>
<td>Send to Compressor</td>
<td>Open your project in Compressor so that you can use its customized export settings.</td>
</tr>
<tr>
<td>Export Using Compressor Settings</td>
<td>Export your project using previously configured Compressor settings, without actually opening Compressor.</td>
</tr>
</tbody>
</table>
Share with other applications

Use the Media Browser to share your project with iLife and iWork
If you want to use a finished Final Cut Pro project in another Apple application—such as GarageBand, iPhoto, or Keynote—you can send your movie to the Media Browser. The Media Browser is accessible in all iLife and iWork applications.

Note: If the Media Browser item is dimmed, update your version of Mac OS X.

Send your project to the Media Browser

1 Select the project and choose Share > Media Browser.

2 In the window that appears, select the Apple device that is your primary destination for the movie.

3 To render the project to more than one size or control the output file quality, click Show Details. The following options appear:
   - Sizes: Select one or more sizes.
   - Encode for: Choose either “Higher quality” or “More compatibility” and note the difference in file size and number of compatible devices listed. Choose the one that creates an output file compatible with the devices on which you intend to play the project, keeping in mind that greater compatibility generally results in lower quality when played on high-resolution devices.
   - Compression: This setting controls how long it will take to create the output file. Choose “Better quality (multi-pass)” if you want the best quality or “Faster encode (single-pass)” if you are willing to sacrifice quality for faster processing.

4 To see details about your choices (the files that will be output), click Summary.

5 To take advantage of distributed processing or to send your project to Compressor, click Advanced.

   For information on the Advanced options, see “Export your project using Compressor” on page 456.

6 Click Publish.

Rendering the files can take up to several minutes depending on the size of your movie and whether you’re rendering more than one movie size at once. You can monitor the render progress using Share Monitor.

For information about working with the project after it has been published, see “Shared projects overview” on page 459.
View your project in the Media Browser
1 Open an application that uses the Media Browser.
2 Click Media (or choose View > Show Media Browser) to open the Media Browser, click Movies, and select Final Cut Pro to see your projects.

Play your project in iTunes, on mobile devices, or with Apple TV
To sync your project to a device such as iPhone, iPad, or iPod, or play your project on your home theater system using Apple TV, you need to send the project to iTunes. You can also save your project in an iTunes-compatible format without actually sending it to iTunes.

Send your project to iTunes
1 Select the project and choose Share > Apple Devices.
2 In the window that appears, select the Apple device that is your primary destination for the movie.
3 Select Add to iTunes to have the output file automatically sent to iTunes.
   If Add to iTunes is not selected, the Share button changes to a Next button that you click to choose a disk location to save the output file.
4 To specify additional options, click Show Details and do any of the following:
   - To render the project to more than one size: Select the sizes you want.
   - To set the compatibility: Choose either “Higher quality” or “More compatibility” and note the difference in file size and number of compatible devices listed. Choose the one that creates an output file compatible with the devices on which you intend to play the project, keeping in mind that greater compatibility generally results in lower quality when played on high-resolution devices.
   - To change your project’s name in iTunes: Type a name in the Title field.
   - To add your project to a playlist: Choose an iTunes playlist from the “Add to playlist” pop-up menu.
   - To choose the compression method: From the Compression pop-up menu, choose “Better quality (multi-pass)” if you want the best quality or “Faster encode (single-pass)” if you are willing to sacrifice quality for faster processing.
To see details about the files that will be output, click Summary.

To take advantage of distributed processing or to send your project to Compressor, click Advanced.

For information on the Advanced options, see “Export your project using Compressor” on page 456.

Click Share.

Rendering the files can take up to several minutes depending on the size of your movie and whether you’re rendering more than one movie size at once. You can monitor the render progress using Share Monitor.

For information about working with the project after it has been published, see “Shared projects overview” on page 459.

If you’ve rendered a project to view in iTunes or on Apple devices, iTunes opens (if it wasn’t already open) when rendering is complete. You can:

- Play your movie in iTunes by double-clicking the movie or using Front Row.
- Stream your movie from iTunes to your home theater system using Apple TV.
- Copy the movie to iPhone, iPad, and iPod by syncing the device.

For more information, see iTunes Help.

**Email your project**

Final Cut Pro can create an email message in Mail and include your movie as an attachment.

*Important:* Many email services limit the file size for attachments.

**Email your project’s movie**

1. Select the project and choose Share > Email.
2. Choose the frame size to export using the Size pop-up menu.
3. From the Compression pop-up menu, choose “Better quality (multi-pass)” if you want the best quality or “Faster encode (single-pass)” if you are willing to sacrifice quality for faster processing.
4. To see details about the files that will be output, click Summary.
5. To take advantage of distributed processing or to send your project to Compressor, click Advanced.

For information on the Advanced options, see “Export your project using Compressor” on page 456.
6. Click Compose Message.

Mail opens an email with the subject already filled in and the movie attached.
Publish your project to Podcast Producer

Podcast Producer is a component of Mac OS X Server that you can use to create and publish podcasts. For more information, go to http://www.apple.com/server/macosx/features/podcast-producer.html.

Note: Before you can publish to Podcast Producer, you or your server administrator must first set up a podcast server.

Publish a project to Podcast Producer for the first time

1 Select the project and choose Share > Podcast Producer.
2 Click Configure.
3 Type the server’s IP address in the Server field and click OK.
   Final Cut Pro contacts the server to verify its address. If successful, the Name and Password fields appear.
   Note: Contact your server administrator for details about how to configure your account. Configuring your account requires a server IP address, a user name, and a password.
4 Type the Name and Password text and click OK.
5 Choose an option from the Workflow pop-up menu. The actual workflow options depend on how Podcast Producer is configured on its server.
6 Type the movie title and description you want viewers to see.
7 Choose an option from the Size pop-up menu, or select “Set size automatically” to have Final Cut Pro choose an appropriate size (which is displayed in the dimmed Size pop-up menu).
8 From the Compression pop-up menu, choose “Better quality (multi-pass)” if you want the best quality or “Faster encode (single-pass)” if you are willing to sacrifice quality for faster processing.
9 To see details about the file that will be output, click Summary.
10 To take advantage of distributed processing or to send your project to Compressor, click Advanced.
   For information on the Advanced options, see “Export your project using Compressor” on page 456.
11 Click Publish.

You have to type the server information only the first time you publish to Podcast Producer. After that, you only need to choose the Workflow, type the Title and Description, and choose the Size.
Final Cut Pro renders your movie and uploads it to Podcast Producer where the selected workflow is applied to it. You can monitor the render progress using Share Monitor.

For information about working with the project after it has been published, see “Shared projects overview” on page 459.

Burn your project to a disc or create a disk image

You can burn your project to either a standard-definition DVD or a Blu-ray–compatible disc. There are a couple of ways to create a Blu-ray–compatible disc:

- Use an external optical drive that supports Blu-ray burning to blue laser media.
- Use a standard DVD burner and standard red laser media to create an AVCHD disc with HD video content and menus. You can play AVCHD discs in Blu-ray players that are specifically compatible with AVCHD discs.

You can also create a disk image (.img) file that you can copy to an external drive to take to a disc replication facility or burn to DVD or Blu-ray disc media at a later time using Disk Utility.

Markers are automatically added every 30 seconds to the project on the disc. This makes it possible to use the DVD or Blu-ray player’s remote to skip forward or backward 30 seconds each time the Next Chapter or Previous Chapter button is pressed. Following are the limits to the number of markers that are added:

- Standard DVD: 99
- Standard Blu-ray: 999
- AVCHD: 50

Note: If you have Compressor installed, you can use the Send to Compressor option to open the project in Compressor, where you can add and name chapter markers using its Preview window. For more information, see Compressor Help.

Burn to a standard-definition DVD or create a standard-definition disk image file

1 Select the project and choose Share > DVD.

2 In the window that appears, choose a file destination from the “Output device” pop-up menu.

   The pop-up menu displays your system’s suitable output devices, including optical drives and the computer’s hard disk. To create a disk image (.img) file that you can copy to an external drive or burn to DVD media later, choose Hard Drive. You can click the Eject button to remove a disc from the drive.
**Important:** If a progress indicator appears next to the output device you selected, wait a moment for the list of available devices to update and for the Burn button at the bottom of the window to become active. This can happen when you eject or insert a disc or when you turn an optical drive on or off.

3 Choose a disc option from the Layers pop-up menu.
   - *Automatic:* Use this to have the type of disc you insert be automatically detected. *Note:* You must insert the disc before clicking Burn for Automatic to work. Additionally, Automatic always creates a single-layer disk image when Hard Drive is selected as the output device.
   - *Single-layer:* Identifies the disc as a single-layer disc. You can use this to force a dual-layer disc to be treated as a single-layer disc.
   - *Dual-layer:* Identifies the disc as a dual-layer disc. You can use this to force the disk image to be formatted for a dual-layer disc when you choose Hard Drive as your output device. *Important:* Choosing “Dual-layer” when using a single-layer disc may result in an error while burning the disc, depending on the project’s length.

4 Choose a template from the “Disc template” pop-up menu.

5 Type the name of the disc in the Title field. By default, the name of the disc is the project name.

6 To specify the DVD player’s action when the disc is inserted, choose an item from the “When disc loads” pop-up menu.
   - Choose Show Menu to have the main menu appear or Play Movie to begin playing the movie immediately.

7 Do any of the following:
   - *To add a background to the DVD menus:* Click the Add button and choose a graphic.
   - *To choose a different background:* Click the Reset button \( \times \) and click Add again.
   - *To see previews of the menus included with the selected template and background:* Click the Main Menu button.
   - *To skim over the main video content:* Click the Project button and move the pointer over the image.

8 To see details about the files that will be output, click Summary.
To take advantage of distributed processing or to send your project to Compressor, click Advanced.

For information on the Advanced options, see “Export your project using Compressor” on page 456.

Do one of the following:

- *If you’re burning to a disc (instead of creating a disk image):* Insert a blank disc into your disc-burning device and click Burn.
- *If you’re creating a disk image file:* Click Next, type a name and choose a location for the file, and click Save.

You can monitor the render progress using Share Monitor.

**Burn to a Blu-ray or AVCHD disc, or create a Blu-ray disk image file**

1. Select the project and choose Share > Blu-ray.

2. In the window that appears, choose a file destination from the “Output device” pop-up menu.

   The pop-up menu displays your system’s suitable output devices, including optical drives and the computer’s hard disk. Each device is identified by the type of output it supports (Blu-ray or AVCHD). To create a disk image (.img) file that you can copy to an external drive or burn to Blu-ray media later, choose Hard Drive.

   **Important:** If a progress indicator appears next to the output device you selected, wait a moment for the list of available devices to update and for the Burn button at the bottom of the window to become active. This can happen when you eject or insert a disc or when you turn an optical drive on or off.

3. Choose a disc option from the Layers pop-up menu.

   - **Automatic:** Use this to have the type of disc you insert be automatically detected.
     
     **Note:** You must insert the disc before clicking Burn for Automatic to work. Additionally, Automatic always creates a single-layer disk image when Hard Drive is selected as the output device.

   - **Single-layer:** Identifies the disc as a single-layer disc. You can use this to force a dual-layer disc to be treated as a single-layer disc.

   - **Dual-layer:** Identifies the disc as a dual-layer disc. You can use this to force the disk image to be formatted for a dual-layer disc when you choose Hard Drive as your output device.

     **Important:** Choosing “Dual-layer” when using a single-layer disc may result in an error while burning the disc, depending on the project’s length.
4 Choose a template from the “Disc template” pop-up menu.

5 Type the name of the disc in the Title field.
   By default, the name of the disc is the project name.

6 To specify the Blu-ray player’s action when the disc is inserted, choose an item from the “When disc loads” pop-up menu.
   Choose Show Menu to have the main menu appear or Play Movie to begin playing the movie immediately.

7 Do any of the following:
   • To add a loop icon to the menu: Select “Include loop movie button.”
     This option is not available for all disc templates.
   • To add a background, logo, or title to the menus: Click the Add button and choose a graphic.
     To choose a different background, click the Reset button \( \times \) and click Add again.
   • To see previews of the menus included with the selected template and background: Click the Main Menu button.
   • To skim over the main video content: Click the Project button and move the pointer over the image.

8 To see details about the files that will be output, click Summary.

9 To take advantage of distributed processing or to send your project to Compressor, click Advanced.
   For information on the Advanced options, see “Export your project using Compressor” on page 456.

10 Do one of the following:
   • If you’re burning to a disc (instead of creating a disk image): Insert a blank disc into your disc-burning device and click Burn.
   • If you’re creating a disk image file: Click Next, type a name and choose a location for the file, and click Save.

   You can monitor the render progress using Share Monitor.

   Note: Blu-ray and AVCHD menus are best suited for displays set to show 1080 lines of vertical resolution.
Share on the web

Publish your project to YouTube

If you have a YouTube account, you can publish a project to YouTube directly from Final Cut Pro. To create a free YouTube account, visit the YouTube website.

Publish your project to YouTube

1 Select the project and choose Share > YouTube.

2 If you don’t see your account in the Account pop-up menu, do one of the following:
   • If this is your first time using Final Cut Pro to publish to YouTube: Click Add to add your YouTube account. (If you don’t have one, go to www.youtube.com to create one.)
   • If you have more than one YouTube account: Choose the one you want to publish to from the Account pop-up menu.

3 Type the required information:
   • Password: Your YouTube account password.
   • Category: The YouTube category your movie will appear in.
   • Title: The movie name you want viewers to see.
   • Description: Information about your movie for viewers to read.
   • Tags: Keywords that viewers can use to find your movie.

4 To allow anyone to view your video, deselect “Make this movie private.”
   If the checkbox is selected, only the contacts you specify in your YouTube account settings can see the movie.

5 Choose a size for your published movie from the Size pop-up menu, or, to have Final Cut Pro choose the size based on your project’s media, select “Set size automatically.”
   Position the pointer over the blue Information icon to see details about the file that will be output.

6 From the Compression pop-up menu, choose “Better quality (multi-pass)” if you want the best quality or “Faster encode (single-pass)” if you are willing to sacrifice quality for faster processing.

7 To see details about the file that will be output, click Summary.

8 To take advantage of distributed processing or to send your project to Compressor, click Advanced.
   For information on the Advanced options, see “Export your project using Compressor” on page 456.
9 Click Next, read the terms of service, and click Publish.

Final Cut Pro renders your movie and uploads it to YouTube. The length of time it takes for your movie to appear depends on website traffic. You can monitor the render progress using Share Monitor.

For information about working with the project after it has been published, see “Shared projects overview” on page 459.

**Publish your project to Facebook**

If you have a Facebook account, you can publish a project to Facebook directly from Final Cut Pro. To create a free Facebook account, visit the Facebook website.

**Publish your project to Facebook**

1 Select the project and choose Share > Facebook.

2 If you don’t see your account in the Account pop-up menu, do one of the following:
   - *If this is your first time using Final Cut Pro to publish to Facebook:* Click Add to add your Facebook account. (If you don’t have one, go to www.facebook.com to create one.)
   - *If you have more than one Facebook account:* Choose the one you want to publish to from the Account pop-up menu.

3 Type the requested information:
   - *Password:* Your Facebook account password.
   - *Viewable by:* The subset of people who can view your video.
   - *Title:* The movie name you want viewers to see.
   - *Description:* Information about your movie for viewers to read.

4 Choose a size for your published movie from the Size pop-up menu, or, to have Final Cut Pro choose the size based on your project’s media, select “Set size automatically.”

Position the pointer over the blue Information icon to see details about the file that will be output.

5 From the Compression pop-up menu, choose “Better quality (multi-pass)” if you want the best quality or “Faster encode (single-pass)” if you are willing to sacrifice quality for faster processing.

6 To see details about the file that will be output, click Summary.

7 To take advantage of distributed processing or to send your project to Compressor, click Advanced.

For information on the Advanced options, see “Export your project using Compressor” on page 456.
Click Next, read the terms of service, and click Publish.

Final Cut Pro renders your movie and uploads it to Facebook. The length of time it takes for your movie to appear depends on website traffic. You can monitor the render progress using Share Monitor.

For information about working with the project after it has been published, see “Shared projects overview” on page 459.

**Publish your project to Vimeo**

If you have a Vimeo account, you can publish a project to Vimeo directly from Final Cut Pro. To create a free Vimeo account, visit the Vimeo website.

**Publish your project to Vimeo**

1 Select the project and choose Share > Vimeo.

2 Choose your account from the Account pop-up menu, or click Add to add an existing account.

   If you don’t have an account, go to the Vimeo website (www.vimeo.com) and create one first.

3 Type the requested information:
   - **Password**: Your Vimeo account password.
   - **Viewable by**: The subset of people who can view your video.
   - **Title**: The movie name you want viewers to see.
   - **Description**: Information about your movie for viewers to read.
   - **Tags**: Keywords that viewers can use to search for and find your movie.

4 Choose a size for your published movie from the Size pop-up menu, or, to have Final Cut Pro choose the size based on your project’s media, select “Set size automatically.”

   Position the pointer over the blue Information icon to see details about the file that will be output.

5 From the Compression pop-up menu, choose “Better quality (multi-pass)” if you want the best quality or “Faster encode (single-pass)” if you are willing to sacrifice quality for faster processing.

6 To see details about the file that will be output, click Summary.
7 To take advantage of distributed processing or to send your project to Compressor, click Advanced.

   For information on the Advanced options, see “Export your project using Compressor” on page 456.

8 Click Next, read the terms of service, and click Publish.

   Final Cut Pro renders your movie and uploads it to Vimeo. The length of time it takes for your movie to appear depends on website traffic. You can monitor the render progress using Share Monitor.

   For information about working with the project after it has been published, see “Shared projects overview” on page 459.

**Publish your project to CNN iReport**

   If you have a CNN iReport account, you can publish a project to CNN iReport directly from Final Cut Pro. To create a free CNN iReport account, visit the CNN iReport website.

**Publish your project to CNN iReport**

1 Select the project and choose Share > CNN iReport.

2 Choose your account from the Account pop-up menu, or click Add to add an existing account.

   If you don’t have an account, go to the CNN iReport website (www.ireport.com) and create one first.

3 Type the requested information:

   - **Password:** Your CNN iReport account password.
   - **Subject:** The movie name you want viewers to see.
   - **Body:** Information about your movie for viewers to read.
   - **Tags:** Keywords that viewers can use to search for and find your movie.

4 Choose a size for your published movie from the Size pop-up menu, or, to have Final Cut Pro choose the size based on your project’s media, select “Set size automatically.”

   Position the pointer over the blue Information icon to see details about the file that will be output.

5 From the Compression pop-up menu, choose “Better quality (multi-pass)” if you want the best quality or “Faster encode (single-pass)” if you are willing to sacrifice quality for faster processing.

6 To see details about the file that will be output, click Summary.
7 To take advantage of distributed processing or to send your project to Compressor, click Advanced.

For information on the Advanced options, see “Export your project using Compressor” on page 456.

8 Click Next, read the terms of service, and click Publish.

Final Cut Pro renders your movie and uploads it to CNN iReport. The length of time it takes for your movie to appear depends on website traffic. You can monitor the render progress using Share Monitor.

For information about working with the project after it has been published, see “Shared projects overview” on page 459.

Export your project

Export your project as media files
You can export your project as a movie file with video and audio, as a video file (with no audio), or as an audio file (with no video). You can also export one or more of the roles used in your project in one or more files, also known as media stems.

Using the Export Media command with the Current Settings option creates high-quality output files faster than the alternative methods in the Share menu, which use background processing.

Export your project as a movie file with video and audio
1 Select the project in the Project Library and choose Share > Export Media (or press Command-E).

2 Choose Video and Audio from the Export pop-up menu.

3 To export a file that matches the project’s properties, choose Current Settings from the “Video codec” pop-up menu.

You can also choose one of the available codecs (Apple ProRes, H.264, uncompressed 8- and 10-bit 4:2:2) from the “Video codec” pop-up menu.

4 Choose what to do after the movie file is exported from the “Open with” pop-up menu:
   • None: Choose this option if you don’t want to automatically open the exported file.
   • QuickTime Player.app: Choose this option to open the exported file in QuickTime Player.
• **Compressor**: Choose this option to open the exported file in Compressor. The exported file will be the source in a new batch, making it easy for you to continue to process the project’s movie. For example, you could create the compressed versions needed for distribution, without involving Final Cut Pro.

  *Note*: This option is available only if Compressor is installed on the same computer as Final Cut Pro.

• **Other**: Choose this option to automatically open the exported file in the application of your choice. Select the application in the window that appears, and click Open.

5 To see details about the file that will be output, click Summary.

6 Click Next, type a name and choose a location for the exported file, and click Save.

Final Cut Pro renders and saves your movie. A window showing the render progress appears.

**Export your project as a video file (with no audio)**

1 Select the project and choose Share > Export Media (or press Command-E).

2 Choose Video Only from the Export pop-up menu.

3 To export a file that matches the project’s properties, choose Current Settings.

You can also choose one of the available codecs (Apple ProRes, H.264, uncompressed 8- and 10-bit 4:2:2) from the “Video codec” pop-up menu.

4 Choose what to do after the movie file is exported from the “Open with” pop-up menu:

• **None**: Choose this option if you don’t want to automatically open the exported file.

• **QuickTime Player.app**: Choose this option to open the exported file in QuickTime Player.

• **Compressor**: Choose this option to open the exported file in Compressor. The exported file will be the source in a new batch, making it easy for you to continue to process the project’s movie. For example, you could create the compressed versions needed for distribution, without involving Final Cut Pro.

  *Note*: This option is available only if Compressor is installed on the same computer as Final Cut Pro.

• **Other**: Choose this option to automatically open the exported file in the application of your choice. Select the application in the window that appears, and click Open.

5 To see details about the file that will be output, click Summary.

6 Click Next, type a name and choose a location for the exported file, and click Save.

Final Cut Pro renders and saves your video file. A window showing the render progress appears.
Export your project as an audio file (with no video)

1 Select the project and choose Share > Export Media (or press Command-E).

2 Choose Audio Only from the Export pop-up menu.

3 Choose a format for the exported audio from the “Audio file format” pop-up menu.
   You can choose AAC, AC3, AIFF, CAF, MP3 or WAVE.

4 Choose what to do after the movie file is exported from the “Open with” pop-up menu:
   - None: Choose this option if you don’t want to automatically open the exported file.
   - iTunes (or another application): Choose this option to open the exported file in the default application associated with the file. The name of the default application appears automatically.
   - Compressor: Choose this option to open the exported file in Compressor. The exported file will be the source in a new batch, making it easy for you to continue to process the project’s movie. For example, you could create the compressed versions needed for distribution, without involving Final Cut Pro.
     Note: This option is available only if Compressor is installed on the same computer as Final Cut Pro.
   - Other: Choose this option to automatically open the exported file in the application of your choice. Select the application in the window that appears, and click Open.

5 To see details about the file that will be output, click Summary.

6 Click Next, type a name and choose a location for the exported file, and click Save.

Final Cut Pro renders and saves your audio file.

Export your project’s roles as media stems

If you need to export your project as separate media files (for example, if you want to export the dialogue, music, and sound effects from your project separately), you can export one or more of your project’s roles as media stems. You can create a combined, multitrack QuickTime file or separate audio or video files using your project’s audio and video roles, and you can assign mono, stereo, or surround output for your audio channels.

For more information about roles, see “Roles overview” on page 339.

1 Select the project and choose Share > Export Media (or press Command-E).

2 To determine which roles are exported, choose one of the following presets from the Export pop-up menu:
   - Roles Multitrack QuickTime Movie: Exports all the clips in your project as one QuickTime movie file containing all roles.
   - Roles As Separate Files: Exports each video or audio role in your project as a separate video or audio file.
• **Video Roles Only As Separate Files**: Exports each of the video roles in your project as a separate file.

• **Audio Roles Only As Separate Files**: Exports each of the audio roles in your project as a separate file.

3 To see which roles will be exported, click the Roles button.

The roles that will be exported appear below the Preset pop-up menu.

4 To add or remove roles that will be exported, do either or both of the following:

  • **To add a role to the export files**: Click Add Video File or Add Audio File, and choose a role from the pop-up menu that appears.

    If you’re adding an audio role, you can also choose the channel format for the role (Mono, Stereo, or Surround). For more information on channel configuration and exporting, see “Configure audio channels” on page 204.

    **Note**: If you’re exporting roles as a single multitrack file, the Add Video File button does not appear.

  • **To remove a role from the export files**: Move the pointer over the role you want to remove, and click the Remove button (with a minus sign) that appears to the right of the pop-up menu.
5 To choose a file type for the exported files, click the Options button and do either or both of the following:

- If you’re exporting one or more video files: Choose Current Settings to export files that match the project’s settings.
  You can also choose one of the available codecs (one of the Apple ProRes options, H.264, HDV, XDCAM EX, or XDCAM HD422) from the “Video codec” pop-up menu.
- If you’re exporting one or more audio files: Choose AIFF or WAVE from the “Audio file format” pop-up menu.

6 Choose what to do with the exported files from the “Open with” pop-up menu:

- None: Choose this option if you don’t want to automatically open the exported file.
- iTunes (or another application): Choose this option to open the exported file in the default application associated with the file. The name of the default application appears automatically.
- Compressor: Choose this option to open the exported file in Compressor. The exported file will be the source in a new batch, making it easy for you to continue to process the project’s movie. For example, you could create the compressed versions needed for distribution, without involving Final Cut Pro.
  Note: This option is available only if Compressor is installed on the same computer as Final Cut Pro.
- Other: Choose this option to automatically open the exported file in the application of your choice. Select the application in the window that appears, and click Open.

7 To see details about the files that will be exported, click Summary.

  Note: For instructions for saving customized export settings, see “Save a custom export preset,” below.

8 Click Next, type a name and choose a location for the exported files, and click Save.

  Final Cut Pro renders and saves the files for export as media stems.
Save a custom export preset
If you’ve created a customized list of roles to export, you can save it as a custom export preset.

1 Configure your export using the instructions in “Export your project’s roles as media stems,” above.

2 Click the Roles button, and do one of the following:
   • To save a new custom export preset: Choose Save As from the Preset pop-up menu, type a name for the preset, and click Save.
   • To save a custom export preset that you’ve modified: Choose Save from the Preset pop-up menu.
   • To save a custom export preset as a new preset: Choose Save As from the Preset pop-up menu, type a name for the preset, and click Save.
   • To rename a custom export preset: Choose Rename from the Preset pop-up menu, type a new name for the preset, and click Save.

Note: These options appear only in the Preset pop-up menu in the Roles pane. The word “edited” appears in the Preset pop-up menu after the names of custom export presets that you’ve modified.

The custom preset you created appears at the bottom of the Export pop-up menu.

Custom presets are stored in /Users/username/Movies/Final Cut Events/Export Presets/.

Delete a custom export preset
You can delete custom export presets that you created.

1 Select any project and choose Share > Export Media (or press Command-E).

2 In the Export pop-up menu, choose the custom export preset that you want to delete. (The custom export presets are listed at the bottom of the pop-up menu.)

3 Click the Roles button, and choose Delete from the Preset pop-up menu.
   Note: The Delete option appears only in the Preset pop-up menu in the Roles pane.
Export an image from your project
You can save a single image file of any video frame in your project.

Save a still frame
1 Select the project, and in the Timeline, place the playhead at the frame you want to save, and choose Share > Save Current Frame.
2 Choose a format from the Export pop-up menu.
3 To see details about the file that will be output, click Summary.
4 To scale the output file to use square pixels and maintain the original aspect ratio (which results in an increase or decrease in the number of horizontal and vertical pixels), select “Scale image to preserve aspect ratio.”

The checkbox affects only projects whose video resolution uses non-square pixels, such as NTSC and PAL formats. If the checkbox is not selected (the default setting), the output file uses the same pixel aspect ratio and has the same number of horizontal and vertical pixels as the original video.
5 Click Next.
6 Type a name and choose a location for the saved file, and click Save.

Final Cut Pro renders and saves your still image file.

Export your project as an image sequence
You can export your project as an image sequence—a set of sequentially numbered still-image files.

Export an image sequence
1 Select the project and choose Share > Export Image Sequence.
2 Choose the image file format from the Export pop-up menu.
3 To scale the output files to use square pixels and maintain the original aspect ratio (which results in an increase or decrease in the number of horizontal and vertical pixels), select “Scale image to preserve aspect ratio.”

The checkbox affects only projects whose video resolution uses non-square pixels, such as NTSC and PAL formats. If the checkbox is not selected (the default setting), the output files use the same pixel aspect ratio and have the same number of horizontal and vertical pixels as the original video.
4 To see details about the file that will be output, click Summary.
5 To take advantage of distributed processing or to send your project to Compressor, click Advanced.

For information on the Advanced options, see “Export your project using Compressor” on page 456.
Click Next.

Choose a location to create a new folder for the exported files.

Type a name.

The exported image files use this name with an appended sequential number.

Click Save.

Final Cut Pro renders and saves your movie. You can monitor the render progress using Share Monitor.

**Export your project for web streaming**

With HTTP live streaming, you can send audio and video to iPhone, iPad, iPod touch, and Mac, using an ordinary web server. Designed for mobility, HTTP live streaming can dynamically adjust movie playback quality to match the available speed of wired or wireless networks, making it great for delivering streaming media to your iOS-based app or HTML5-based website. For detailed information on implementing HTTP live streaming, go to http://developer.apple.com/resources/http-streaming.

**Export a set of HTTP live streaming files**

1. Select the project and choose Share > Export for HTTP Live Streaming.

2. Select one or more sizes to export using the “Versions to export” checkboxes.

   To provide the best experience to the most viewers, select all three checkboxes.

3. To include a file with basic HTTP live streaming usage information, select “Include Read Me file.”

4. Choose the segment length for the media using the Segment Length value.

   This value defines how the video streams are split into chunks. This segmentation defines when the web server can switch between the various video formats while streaming to a device with varying network connection speeds.
   - 10 seconds: Allows the server to respond more quickly to changing connection speeds, at the expense of slightly larger files.
   - 30 seconds: Creates smaller, more efficient files when you do not expect the server to need to respond to changing connection speeds.

5. To see details about the files that will be output, click Summary.

6. To take advantage of distributed processing or to send your project to Compressor, click Advanced.

   For information on the Advanced options, see “Export your project using Compressor” on page 456.
7 Click Next.
8 Choose a location to create a new folder for the exported files.
9 Type a name and click Save.

A folder containing the segmented video files and some support files is created for each selected video format. Additional support files, including the master index file (with a “.m3u8” file extension) and the Read Me file (if selected), are also saved to the folder.

**Export your project using Compressor**

The Share menu options provide results that work well for the most common situations. However, at times you might need to further customize the settings. Compressor, the professional transcoding application designed to work directly with Final Cut Pro, gives you maximum control over the media-conversion specifications and transcoding workflows. Here are some ways you can use Compressor:

- **If you have Compressor installed:** You can send your project to it to take advantage of the wide variety of settings and controls it offers. For example, you can create an output file from a portion of your project and use highly customized settings to create exactly the output files you need, including high-quality frame retiming and resizing controls.

  You can also choose to open any of the Share menu options in Compressor for additional customization.

- **If you have Compressor installed or have copied settings to your computer:** You can easily apply one or more Compressor settings (either the Apple-supplied or custom settings that you create) when you export a project. Each setting specifies a preconfigured codec for an output file. Exporting a project using Compressor settings provides many of the benefits of Compressor without actually opening your project in Compressor. You can use the Compressor settings to create multiple output files in one share operation, or have custom settings that modify your output file, for example, to add a watermark to the video.

- **If you have Compressor installed on the same computer as Final Cut Pro or on other computers in your local network:** You can use Compressor to set up distributed processing clusters to speed up the rendering process.

  By default, Final Cut Pro uses your computer to render the output files. If you have other computers with Compressor installed available on your network, you can spread the processing workload across them to speed up the process. A set of computers configured to process projects is called a *distributed processing cluster*. Using such clusters is called *background processing* because the processing happens in the background instead of tying up your computer.

  For information about setting up distributed processing clusters, see Compressor Help.
If you want to render your output files in the background: By default, when you export a project using any of the share options, the processing work is all done in the foreground. This is the fastest way to generate your output files; however, you can’t use Final Cut Pro while the output files are being created.

Except when using the Export Movie and Save Current Frame options, which always process in the foreground, you can choose to have output files processed in the background. This means that you can continue working in Final Cut Pro while the output files are being created. However, background processing is slowed down if you perform other processor-intensive tasks at the same time.

Send your project to Compressor

1. Select the project and choose Share > Send to Compressor.

   Note: The Send to Compressor item is dimmed if Compressor is not installed on the same computer as Final Cut Pro.

Compressor opens with a new batch that contains a job with the project’s movie as its media.

2. Configure the job by adding one or more settings, and click Submit.

   For more information about configuring jobs and settings, see Compressor Help.

Send your share configuration to Compressor

1. Select the project and choose and configure an option from the Share menu.

   For example, you can choose Share > Apple Devices and configure its settings as needed.

2. Click Advanced and click Send to Compressor.

   Note: The Send to Compressor item is dimmed if Compressor is not installed on the same computer as Final Cut Pro.

Compressor opens with a new batch containing a job with the project’s movie as its media and the settings you configured in the share window as the job’s settings.

3. Configure the job by modifying or adding settings, and click Submit.

   For more information about configuring jobs and settings, see Compressor Help.

Export your project using Compressor settings

Use either the settings provided by Compressor (if installed on the same computer as Final Cut Pro), or custom settings created on a computer with Compressor copied to username/Library/Application Support/Compressor/Settings to create multiple customized outputs of your project.

1. Select the project and choose Share > Export Using Compressor Settings.

2. Choose one or more settings.
The settings are grouped by type into folders. Hold down the Command key while selecting settings if you want more than one.

3 To have the exported files open with the default application for the exported file type, select the Open with Application checkbox.

4 To see details about the files that will be output, click Summary.

5 To take advantage of distributed processing or to send your project to Compressor, click Advanced.

6 Click Next.

7 Type a filename, choose a location for the output files, and click Save.

Final Cut Pro renders and saves your movie. You can monitor the render progress using Share Monitor.

Send your project to a distributed processing cluster

1 Select the project and choose and configure an option from the Share menu.

For example, you can choose Share > Apple Devices and configure its settings as needed.

2 Click Advanced and choose a cluster from the Background Rendering pop-up menu.

The minimum choices are None (which selects foreground processing and is selected by default), This Computer, and This Computer Plus (which automatically creates a cluster using any computers on the network that have Compressor installed and configured for this purpose).

Note: Compressor does not need to be installed on the same computer as Final Cut Pro for these choices to be available. However, it must be installed on all computers that make up the cluster.

3 Start the render by clicking the Publish, Share, Burn, Compose Message, or Next button.

For more information about configuring distributed processing clusters, see Compressor Help.

Important: Each computer in a distributed processing cluster must be able to mount the disk that has the Final Cut Pro media. An exception is if you use This Computer Plus.
Process your output files in the background

1. Select the project and choose and configure an option from the Share menu. For example, you can choose Share > Apple Devices and configure its settings as needed.

2. Click Advanced and choose This Computer, This Computer Plus, or any available cluster from the Background Rendering pop-up menu.

Choosing None processes the output files in the foreground.

3. Start the render by clicking the Publish, Share, Burn, Compose Message, or Next button.

Final Cut Pro renders and saves your movie. You can monitor the render progress using Share Monitor.

Status of shared projects

Shared projects overview
When you publish or share your project using any of the share options, the Share icon is added to the project in the Timeline and Project Library to indicate that it has been published.
You can click the Share icon in the Project Library to open the Sharing inspector. The project’s Sharing inspector displays when and where it was published, and also provides a pop-up menu with additional controls for those share options that support the controls.

If you make any changes to the project, a symbol appears next to the Share icon, indicating that the project has changed since it was last shared.
Visit and announce shared projects
You can use options in the Sharing inspector to open the shared project in your browser or send an email to announce it.

Open the Sharing inspector
- Click the project’s Share icon in the Project Library.

View the project at its shared location
- In the Sharing inspector, choose Visit from the shared item’s pop-up menu.
  
  *Note:* Not all shared items have a pop-up menu.

Create an email to announce a shared project
1 In the Sharing inspector, choose Tell a Friend from the shared item’s pop-up menu.
  
  *Note:* Not all shared items have a pop-up menu.

2 In Mail, complete the email that was created and click Send.

  The email includes a link to the published project and a subject.
**Remove shared projects**

You may find that you need to remove a shared project from its website or other final destination. In some cases Final Cut Pro may be able to remove it for you; in other cases you will have to manually remove it. In both cases, the project needs to be updated so that it no longer indicates that it was shared to that destination.

**Remove your movie from its destination**

1. Open the Sharing inspector by clicking the project’s Share icon in the Project Library.
2. In the Sharing inspector, choose Remove from the shared item’s pop-up menu.

   A window appears with options for that particular share item.

   **Note:** Not all share items have a pop-up menu.

3. Depending on the window options, do one of the following:
   - Enter your password for the website you shared to and click OK to have Final Cut Pro delete the project from the destination.
   - Manually delete the project from the destination and click Done.

   **Note:** To remove a project from CNN iReport you need to contact the website and request its removal.

The share item’s published status is removed from the project.

**About Share Monitor**

When you publish or export your project using any of the Share menu options, the Share Monitor application opens in your Dock.

You can click the Share Monitor icon to monitor the progress of the rendering process that’s creating your output files. A number appears on the icon to show how many files are being rendered. If there is an issue during the rendering process, the Share Monitor icon bounces in the Dock.

For more information on using Share Monitor, see Share Monitor Help.
Media management overview

In general, any task that relates to processing your media is considered to be media management. Media management includes:

- Importing media from cameras, an external storage disk, or another device. See “Importing overview” on page 24 for more information.

- Transcoding your source media files to formats that are high quality and easy to work with. See “Transcode media files” on page 473 for more information.

- Backing up, consolidating, and moving projects. See “Before you move or copy Events and projects” on page 478 for more information.

- Creating camera archives. See “Create and manage camera archives” on page 488 for more information.

- Relinking clips to media files. See “Relink clips to media files” on page 467 for more information.

Some of these tasks can be performed in Final Cut Pro, others can be performed in the Finder, and some require working in both Final Cut Pro and the Finder.
Where your media and project files are located

When you create a new Event or project, folders for the new item are created in one of two places:

- **If the new Event or project is on your local system:** The folders are in your Movies folder in your home folder (/Users/username/Movies/). This is the default location for your Final Cut Pro files.

- **If the new Event or project is on a connected external storage device:** The folders are at the main, or root, level of your device.

- **If the new Event or project is on a storage device connected to a local network:** The folders can be located in any folder you’ve added from a storage area network (SAN).

When you create a new Event on your local system, a folder is created for the Event:

/Users/username/Movies/Final Cut Events/Eventname/

The [Event name] folder can contain one or more of the following items. The contents of these folders depend on the options you selected during import or in the Import preferences. These files are used and managed by Final Cut Pro, and thus should not be moved, modified, or deleted.
• **Event file:** Final Cut Pro Event files have the name `CurrentVersion.fcpevent`.

• **Analysis Files:** This folder contains analysis files associated with the media files.

• **Original Media:** This folder contains either the original files that you imported from your camcorder or hard disk or *alias files* that point to the original files in another location.

• **Render Files:** This folder contains render files associated with the media files.

• **Transcoded Media:** If you chose to create optimized or proxy media, the transcoded files that were created are located in this folder.

• **Old Versions:** If you update existing Events to open them with a newer version of the application, Final Cut Pro first saves copies of the original Events in this folder.

• **Backups:** This folder contains a single backup copy of each Event. This is a copy of `CurrentVersion.fcpevent` (the Event file) only, not the associated source media files. Final Cut Pro updates the backup copy in 15-minute intervals (if it detects a change in the Event). This backup copy is meant to be used by Final Cut Pro automatically in the rare instance of an issue when opening the Event.

Similarly, when you create a Final Cut Pro project, a folder is created for the project:

```
/Users/username/Movies/Final Cut Projects/projectname/
```

The `[project name]` folder contains the following items. These files are used and managed by Final Cut Pro, and thus should not be moved, modified, or deleted.

• **Project file:** Final Cut Pro project files have the name `CurrentVersion.fcpproject`.

• **Render Files:** This folder contains render files associated with the project.

• **Old Versions:** If you update existing projects to open them with a newer version of the application, Final Cut Pro first saves copies of the original projects in this folder.

• **Backups:** This folder contains a single backup copy of each project. This is a copy of `CurrentVersion.fcpproject` (the project file) only, not any media files. Final Cut Pro updates the backup copy in 15-minute intervals (if it detects a change in the project). This backup copy is meant to be used by Final Cut Pro automatically in the rare instance of an issue when opening the project.

**Tip:** To quickly locate the source media file for a clip, select the clip and choose File > Reveal in Finder (or press Command-Shift-R). You can also Control-click the clip, and choose Reveal in Finder from the shortcut menu.
Manage your media files

View a clip's information
The Info inspector provides a summary of a clip's information. Here you can view status information about a clip's source media file, including the file's location, available media representations for the file, the Event the clip is located in, and the Event the clip references.

1. Select a clip in the Event Browser or Timeline.
2. To open the Info inspector, click the Inspector button in the toolbar (shown below), and click the Info button at the top of the pane that appears.
3. Choose Show File Status from the Action pop-up menu 🪑 at the bottom of the Info inspector.
Relink clips to media files

In Final Cut Pro, clips represent your media, but they are not the media files themselves. Final Cut Pro keeps track of the links between clips and media files automatically. However, there are times when you want to manually relink clips to media files.

One common scenario is that the media files were altered or re-created outside of your copy of Final Cut Pro. For example, you sent out files to be color-corrected, you’ve received the new versions of the files, and you want to relink the clips in your Event or project to the new versions.

Another case requiring manual relinking is missing media files. For example, if you move or rename files in the Finder, or you move an Event or a project to a different location, you need to relink the Event or project clips (which appear as red frames with yellow alert triangles) to the files.

In either case, manually relinking points the clips in Final Cut Pro to the correct files on your hard disk. Metadata in the relinked clips remains unchanged.

The new (relinked) files can have a different resolution and codec than the original files, but they must be the same media type. (In other words, you can’t relink a video clip to an audio file.) Relinked files must also have the same frame rate and similar audio channels as the original files.

The new (relinked) files can also be trimmed versions of the original files, but they must be long enough to cover all the clips that refer to the files.

Because relinking Event clips and relinking project clips have different effects on your Events and projects, they are described separately below.

Relink Event clips to media files

When you relink Event clips to media files on your hard disk, all matched clips (including those in other projects or Events) are updated to link to the new media files. In other words, if you used an Event clip in multiple projects (or Events), each of those projects and Events is relinked to the new media file. If the old files are in the Original Media folder, they are moved to the Trash. You cannot undo this operation.

1 In the Event Browser, select the clips you want to relink, or select an entire Event in the Event Library.

2 Choose File > Relink Event Files.

The Relink Files window appears. By default, this window shows missing clips or Events only.
3 If you want to show all items in the selection, select All.

4 Do one of the following:
   - *To locate all the matching files:* Click Locate All.
   - *To locate some of the matching files:* Select items in the list and click Locate Selected.

5 In the window that appears, navigate to one of the files you want to link to, or to the folder that contains it.
Text at the bottom of the window indicates how many potential matches to items in your original list were found (based on the filenames only).

![Image of a window with files and directories]

Note: Final Cut Pro identifies matches based on proximity in the directory structure and related filenames. For example, if your original files were in two adjacent folders, Final Cut Pro looks in folders adjacent to the file you chose and relinks all matching files in the relative path. If your original files were named “File1,” “File2,” “File3,” and so on, and you chose to relink to a file named “File1_A,” Final Cut Pro looks for files named “File2_A,” “File3_A,” and so on to link the remaining items in your list.

6 Click Choose.

Final Cut Pro analyzes the files to confirm that all attributes (in addition to the filename) match items in the original selection. Analysis results are shown below the Original Files list. For example, “3 of 3 files matched.”
7 Click the disclosure triangle next to the analysis results to show a list of old files (on the left) and the new matching files (on the right).

If a file was matched incorrectly, select it in the list and press Delete. The item is placed back in the original list at the top of the Relink Files window.

Items with no matches remain in the original list above. You can continue to locate those by selecting them and repeating steps 4 through 6.

8 If you want the matching media files duplicated and placed in the Final Cut Events folder on your computer, select the “Copy files into Final Cut Events folder” checkbox.

9 To link the Event clips to the new media files, click Relink Files.

All matched clips (including those in other projects or Events) are updated to link to the new media files.

**Relink project clips to media files**

Unlike relinking Event clips, relinking project clips to media files on your hard disk updates clips in the selected project only. New clips are added to the current project’s default Event. You cannot undo this operation.

1 In the Timeline, select the clips you want to relink, or select a project in the Project Library.

2 Choose File > Relink Project Files.

The Relink Files window appears. By default, this window shows missing clips only.
3 If you want to show all items in the selection, select All.

4 Do one of the following:
   - To locate all the matching files: Click Locate All.
   - To locate some of the matching files: Select items in the list and click Locate Selected.

5 In the window that appears, navigate to one of the files you want to link to, or to the folder that contains it.
Text at the bottom of the window indicates how many potential matches to items in your original list were found (based on the filenames only).

![Image of a window with a list of files]

Text indicates how many matches were found.

**Note:** Final Cut Pro identifies matches based on proximity in the directory structure and related filenames. For example, if your original files were in two adjacent folders, Final Cut Pro looks in folders adjacent to the file you chose and relinks all matching files in the relative path. If your original files were named “File1,” “File2,” “File3,” and so on, and you chose to relink to a file named “File1_A,” Final Cut Pro looks for files named “File2_A,” “File3_A,” and so on to link the remaining items in your list.

6 Click Choose.

Final Cut Pro analyzes the files to confirm that all attributes (in addition to the filename) match items in the original selection. Analysis results are shown below the Original Files list. For example, “4 of 4 files matched.”

7 Click the disclosure triangle next to the analysis results to show a list of old files (on the left) and the new matching files (on the right).
If a file was matched incorrectly, select it in the list and press Delete. The item is placed back in the original list at the top of the Relink Files window.

Items with no matches remain in the original list above. You can continue to locate those by selecting them and repeating steps 4 through 6.

8 To link the project clips to the new media files, click Relink Files.

Only clips in this project are updated to link to the new media files. New clips are added to the project’s default Event. All other Events and projects remain unchanged.

**Transcode media files**

Final Cut Pro can play back many media formats. See “Supported media formats” on page 49 for a complete list. Final Cut Pro also provides options for transcoding your media, converting it to a different format or changing its settings.

- **Create optimized media**: This option transcodes video to the Apple ProRes 422 codec format, which provides better performance during editing, faster render times, and better color quality for compositing. Still images are transcoded to either JPEG (if the original file doesn’t have alpha channel information) or PNG files (if the file has alpha channel information). If the original camera format can be edited with good performance, this option will be dimmed.

- **Create proxy media**: This option creates video and still-image proxy files. Video is transcoded to the Apple ProRes 422 (Proxy) codec format, which provides high-quality files useful for offline editing at the original frame size, frame rate, and aspect ratio. Final Cut Pro creates medium-quality (one-quarter resolution) proxy versions that increase editing performance. Video proxy files take up considerably less disk space, which often means you can work on a portable computer instead of a desktop computer that has significantly more memory and processing power. Still images are transcoded to either JPEG (if the original file doesn’t have alpha channel information) or PNG files (if the file has alpha channel information). Still-image proxy files facilitate faster processing and rendering when the original image is very large.

**Note**: When transcoding files, Final Cut Pro always retains the original media for future use. For more information about where to find original media, proxy media, and transcoded media files, see “Where your media and project files are located” on page 464.

You can create optimized and proxy media during the import process, or after the media has been imported, using the Event Browser. You can also create a proxy file for a clip using the Info Inspector. After the transcode is complete, the files are saved in the appropriate Event folder. See “Where your media and project files are located” on page 464 for more information.
Whether Final Cut Pro uses proxy media or your original or optimized media during playback is determined by the playback setting you select in the Final Cut Pro Editing preferences. See “Modify a project’s name and properties” on page 94 for more information.

**Transcode media files during import**

During import, Final Cut Pro either creates an alias file that points to the media file in its original location, or creates a copy of the original media file. After the files are imported, transcoding, optimization, and analysis are performed in the background.

1 Do one of the following:
   - To import a file from a compatible camcorder or camera, iPhone, iPad, iPod, or other file-based device: Connect your device to your computer, turn it on, choose File > Import from Camera (or press Command-I), and click Import.
   - To import a file from a tape-based camcorder: Connect your device to your computer, turn it on, and set it to VTR or VCR mode. Then choose File > Import from Camera, and click Import.
   - To import a file from a memory card: Insert the memory card into the card slot on your Mac or into a card reader that’s connected to your computer, and choose File > Import (or press Command-I).
   - To import a file located on your hard disk or a connected external storage device: Choose File > Import > File and navigate to the file you want to import.
   - To import from an archive: Choose File > Import from Camera. Select a camera archive from the list on the left, click Open Archive and navigate to the files you want to import, and click Import.

2 In the window that appears, choose how you want to organize the imported media in your Event Library:
   - To add the imported media to an existing Event: Select “Add to existing Event,” and choose it from the pop-up menu.
   - To create a new Event: Select “Create new Event” and type a name (for example, “Chris and Kim Wedding”) in the text field. Choose the disk where you want to store the Event from the “Save to” pop-up menu.

To learn more about Events, see “Events and clips overview” on page 57.

3 Select one or both of the transcode options.

Final Cut Pro will transcode the files in the background, after the import process is complete.

4 Click Import.

The import may take a while, depending on the options you chose in step 3. You can see the status of all the background processes currently running in the Background Tasks window.
Transcode clips after import

1. Control-click one or more clips in the Event Browser and choose Transcode Media from the shortcut menu.

2. In the window that appears, select the “Create optimized media” checkbox, the “Create proxy media” checkbox, or both, and click OK.

   Note: If the original camera format can be edited with good performance, the “Create optimized media” option will be dimmed.

   The transcoding process may take a while, depending on the options you chose in this step. You can see the status of all the background processes currently running in the Background Tasks window.

Automatically transcode media files when they’re dragged into Final Cut Pro

When you drag media from the Finder into an Event or Timeline in Final Cut Pro, it is automatically organized, transcoded, and analyzed based on the import settings that you set in Final Cut Pro preferences.

1. To configure the Final Cut Pro analysis options:
   a. Choose Final Cut Pro > Preferences.
   b. In the Preferences window that appears, click Import.
   c. Select each of the video and audio analysis options that you want to apply to your media.
   d. When you’re finished, close the Preferences window.

2. To import one or more files, select a file (or Command-click multiple files) in the Finder and drag it to an Event or Timeline.

Generate a proxy file from the Info inspector

Proxy files take up considerably less disk space. In some situations, using proxy files can allow you to work on a portable computer instead of a desktop computer that has significantly more memory and processing power. You can check to see if you have a proxy file for a clip by viewing the clip’s information in the Info inspector. If the file you’re viewing in the Info inspector doesn’t have a proxy file, you’ll see a red triangle.

![Proxy file information in the Info inspector](image)

If a proxy has not been created for a clip, a red triangle is shown.

You can create a proxy file for a clip by doing the following:
1 Select a clip in the Event Browser.
2 To open the Info inspector, click the Inspector button in the toolbar (shown below), and click the Info button at the top of the pane that appears.

3 Choose Show File Status from the Action pop-up menu.

4 Click the Generate Proxy button in the Available Media Representations section of the file status area.

The proxy file is created, and a green circle appears next to the proxy item in the Available Media Representations section, indicating that the proxy file for the clip is available.

**View background tasks**
Many Final Cut Pro tasks take place in the background:
- Importing
- Transcoding
- Video and audio optimization and analysis
- Rendering
- Sharing

Final Cut Pro manages background tasks automatically, so you don’t need to do anything to start or pause them. If you want to see the progress of any of the background processes, you can open the Background Tasks window. The tasks being performed and a percentage of completion are shown in the window.
Important: If you actively use Final Cut Pro while background tasks are running, the background tasks will pause. The tasks resume when you stop using Final Cut Pro.

View tasks that are running in the background
1 Do one of the following:
   • Choose Window > Background Tasks (or press Command-9).
   • In the toolbar, click the Background Process button.

2 To view the tasks that are running in each section, click a disclosure triangle.

Delete render files to free up disk space
Project and clip render files are stored in your Final Cut Events and Final Cut Projects folders. Over time, these files can accumulate and take up disk space. If you want to free up hard disk space, you can either delete unused render files or delete all of the render files for a particular compound clip or Final Cut Pro project.

Delete project render files
1 Select a project in the Project Library.
2 Choose File > Delete Project Render Files.
3 In the window that appears, choose to delete Unused Render Files Only or All Render Files, and click OK.

Delete Event render files
1 Select an Event in the Event Browser.
2 Choose File > Delete Event Render Files.
3 In the window that appears, choose to delete Unused Render Files Only or All Render Files, and click OK.
Manage your Events and project files

Before you move or copy Events and projects
If you want to edit a project on a different computer, or back up a project or Events to an external storage device, you can either move or copy it. Before you move or copy a project, it’s a good idea to consolidate its media and back it up.

By default, media files that are imported into Final Cut Pro are not moved from their original location. During import, you can choose to create a copy of the media files to be exclusively used by Final Cut Pro. Creating a copy can prevent you or others from accidentally moving files and making them unavailable to Final Cut Pro.

If a file that Final Cut Pro uses is moved, Final Cut Pro will mark the clip with a Missing File icon. If you think there’s a chance that media files will be moved or deleted, it’s a good idea to create a copy of the media.

Consolidate a project’s media files
In the course of creating a project in Final Cut Pro, you might use media from a variety of locations, including your local computer and external storage devices. If the media used in the project is located on multiple hard disks, you can consolidate all the media used in the project on the same hard disk as the project.

Collect a project’s clips in one location
1 Locate the project you want to consolidate in the Project Library.
2 Control-click the project to select it, and choose Consolidate Project Media from the shortcut menu.
   If a window appears stating that there is nothing to consolidate, all of your media files are already consolidated and located on one disk.
3 Select an option to specify how the consolidation will occur:
   • Copy Referenced Events: Duplicates the referenced Events (and all the clips in those Events) to the location of your project. You may want to select this option if you use the same media in multiple projects, or if you haven’t finished adding clips from the Event to your project.
   • Move Referenced Events: Moves all the referenced Events to the location of your project. If there are other projects that use the clips in the Event you’re consolidating, those projects will not have access to the Event. You may want to select this option if the clips in the Event are only used in the project you’re consolidating.
- **Copy Used Clips Only**: Duplicates only those media files used in the project. This option gives you only the media used in the project (and not all the clips in the Events referenced by the project). This is a good option to use if you want to conserve disk space.

- **New Event Name field**: If you select Copy Used Clips Only, you can create a new Event to hold the consolidated media. If you don’t specify a new Event name, the Event will be given the project name.

---

**Consolidate Project Media**

Consolidate the project "My First Project" and its referenced Events at the selected location, or copy media used in the project to a new Event at the selected location. You cannot undo this command.

- Copy Referenced Events
- Move Referenced Events
- Copy Used Clips Only
  - This option copies media used in the project to a new Event.
  - New Event Name: ___________

**Referenced Events**: My First Project, Touring The Town, Office Views

---

4 Click OK.

Final Cut Pro consolidates the media using the method you selected. The Event or Events appear on the same hard disk as the project.

**Back up projects, your Project Library, and Events**

Backing up your individual projects, your Project Library, and Events should be an essential part of your workflow. Some people back up daily or weekly; others back up when a project is complete. It is suggested that you back up to an external storage device (not to your local computer).

**Note**: Final Cut Pro maintains a single backup copy of each Event and each project. These are copies of the current Event and project files only, not the associated source media files. Final Cut Pro updates these backup copies every 15 minutes whenever it detects a change in an Events or project. For more information, see “Where your media and project files are located” on page 464.

**Back up your project in Final Cut Pro**

1 Connect an external storage device large enough to hold your project and media files and verify that the device appears in the Finder.

2 Control-click your project in the Project Library, and choose Duplicate Project from the shortcut menu.
3 In the window that appears, choose your external storage device from the Location pop-up menu.

4 Select an option to specify what is duplicated:

   - **Duplicate Project Only**: Duplicates files specific to the project you selected. You may want to choose this option if you use the same clips in multiple projects and plan to back up your Events separately (perhaps in your backup copy of your entire Project Library and Events).

   - **Duplicate Project and Referenced Events**: Duplicates the project and any Events referred to by the project. Selecting this option includes all of the media in the referenced Events. You may want to choose this option if you want to have the unused media available to use later.

   - **Duplicate Project + Used Clips Only**: Duplicates the project and the media for any clips used in the project. This is a good option for most backup copies. When you choose this option, provide a name for the new Event that is created.

5 If you want to include render files (so Final Cut Pro doesn’t have to create new ones), select the checkbox.

6 Click OK.

   Final Cut Pro duplicates the project using the option you specified. The project is given an incremented name (for example “Bill’s movie1”), and the project appears in the location you specified.
Back up your Project Library and Events using the Finder
To create a single backup copy of your Project Library and Events, you can copy the Final Cut Projects folder and Final Cut Events folder to the root level of an external storage device. When you connect the device to your computer, your device and the backup folders will appear in the Project Library.

If you are backing up incrementally, create a folder structure that helps you easily navigate through your backup folders. You could label the folders with the date you made the backup copy, for example.

**Important:** Final Cut Pro will detect project files and Events when they are in the correctly named folders at the root level of your external storage device. If you create multiple backup copies, you will not be able to access the backup projects and Events until you move a set of backup files to the root level of your external storage device. After you connect the device to your computer, your device and the backup folders will appear in the Project Library.

1. In the Finder, locate and select your Final Cut Projects folder, press Shift (to copy the selection), and then select your Final Cut Events folder.

Your Movies folder is the default location for all project and Event files:

/\Users/username/Movies/

**Important:** If you moved a project or Event after you created it, it will not be in the default location.

2. Drag the Final Cut Projects and Final Cut Events folders to the root level of your external storage device.

The folders will be copied to your external storage device.
In most situations, viewing your backup projects and Events is as simple as connecting your storage device to Final Cut Pro and locating your backup project or Event in the Project Library. For more information about locating or viewing your project, see “Common media management issues” on page 494.

Edit your project on a different computer
If you find yourself in a situation where you need to work on your project and media files on a different computer, you have a variety of options:

• **Move the project:** You can delete the project from its current location and put it in a new location. When you move a project, you can move all of the Events used in the project, all of the clips used in the project, or just the project.

• **Copy the project:** You can duplicate the project and put the copy in a new location. When you copy a project, you can copy all of the Events used in the project, all of the clips used in the project, or just the project.

• **Store projects and Events on a SAN location:** You can store files on a storage area network (SAN) location and then access them from the other computer over the network.

Move a project and its referenced Events to another computer
1 Connect your external storage device to the computer where your Final Cut Pro project file is located, and verify that the device appears in the Finder.
2 Verify that Final Cut Pro is installed on the computer to which you’re moving the files.
3 On the computer where your Final Cut Pro project file is located, select your project in the Project Library.
4 Choose File > Move Project.
5 In the window that appears, do the following:
   a Choose your external storage device from the Location pop-up menu.
   b Select “Move Project and Referenced Events.”
       Selecting this option moves the project file and any Events (and all the clips in the Event) referenced by the project file to the disk you chose in the Location pop-up menu.
       For more information about the options in this window, see “Organize projects in the Project Library” on page 98.
   c Click OK.
The project icon and Events disappear from their current location in the Project Library and Event Library and appear under the storage device icon (indicating that they have been moved).

6 Quit Final Cut Pro, and disconnect the storage device from your computer.

**WARNING:** Do not disconnect a device when Final Cut Pro is using it.

7 Connect the storage device to the computer to which you want to move your project, and verify that the device appears in the Finder.

8 Open Final Cut Pro, and then open the Project Library.

The project you moved appears in the Project Library, listed under the connected storage device.

**Note:** If the storage device does not appear in the Project Library, see “Common media management issues” on page 494.

9 To move the project off the storage device to the new computer, select the project and choose File > Move Project.
In the window that appears, do the following:

a. Choose the new computer from the Location pop-up menu.

b. Select “Move Project and Referenced Events.”

c. Click OK.

The project icon and Events disappear from the external storage device and appear under the startup disk (home icon) in the Project Library, and the Event that contains the project’s media appears under the startup disk (home icon) in the Event Library.

**Copy a project and its clips to another computer**

1. Connect your external storage device to the computer where your Final Cut Pro project file is located, and verify that the device appears in the Finder.

2. Verify that Final Cut Pro is installed on the computer to which you’re copying the files.

3. On the computer where your Final Cut Pro project file is located, select your project in the Project Library.

4. Control-click your project, and choose Duplicate Project from the shortcut menu.

5. In the window that appears, do the following:

   a. Choose your external storage device from the Location pop-up menu.

   b. Select Duplicate Project + Used Clips Only.

      Selecting this option copies the project file and the media files used by the project file.

      For more information about the options in this window, see “Organize projects in the Project Library” on page 98.
c Type a descriptive name in the New Event Name field. If you don’t create a new name for the new Event, it will be given the same name as your project.

d Click OK.

The project icon and Events appear under the storage device icon (indicating that they have been copied and moved to the new location).

6 Quit Final Cut Pro, and then disconnect the storage device from your computer.

Note: You cannot disconnect a device when Final Cut Pro is using it.

7 Connect the storage device to the computer to which you want to move your project, and verify that the device appears in the Finder.

8 Open Final Cut Pro, and open the Project Library.

The project you copied appears in the Project Library, listed under the connected storage device.

Note: If the storage device does not appear in the Project Library, see “Common media management issues” on page 494.

9 To copy the project and media files from the storage device to the new computer, drag the project to the home folder icon in the Project Library.
In the window that appears, do the following:

a. Choose the new computer from the Location pop-up menu.
b. Select “Duplicate Project and Referenced Events.”
c. Click OK.

The project appears under the the startup disk (home icon) in the Project Library, and the Event that contains the project’s media appears under the startup disk (home icon) in the Event Library.

You can now locate your project in the Project Library and begin editing. Any changes will be saved to the copy on the startup disk of the new computer.

If you see a Missing Media, Missing Project, or other warning icon, or if you can’t find your project in the Final Cut Pro Project Library, go through the steps in the task to verify that you performed the task correctly. For more information, see “Common media management issues” on page 494.

Use a SAN location to edit your project on a different computer

You can start editing a project over a network using a SAN location and then continue working on the project from a different computer using the same SAN location. To make the SAN location available to other computers on the network, you use the Remove command to disconnect the SAN location from the original computer.

1. Follow the steps for adding a SAN location in “Use SAN locations for Events and projects” on page 487.

2. Create a project on the SAN location, or copy or move your project to the SAN location.
3 To remove the SAN location and make it available to other computers on the network, select the SAN location in the Event Library or the Project Library, and choose File > Remove SAN Location.

The SAN location disappears from Event Library and the Project Library.

4 To access the SAN location on the other computer, follow the steps for adding a SAN location in “Use SAN locations for Events and projects” on page 487.

Make sure to navigate to the same folder you used in step 1.

The SAN location appears as a storage location in the Event Library and the Project Library on the second computer. You can now use this computer to edit any Events and projects stored on this SAN location.

**Use SAN locations for Events and projects**

You can store your Events and projects on a storage area network (SAN). These network storage locations give you more options for storing your media and streamlining your workflow over a high-speed local network.

Although you can access SAN locations from different computers on a network, only one installed copy of Final Cut Pro can use a SAN location at a time. If you have Events or projects stored on a SAN location, you must remove the location in Final Cut Pro to make it available to other computers on the network.

The SAN location feature requires a SAN volume, such as an Xsan volume connected using the Fibre Channel Protocol (FCP).

**Add a SAN location**

1 Choose File > Add SAN Location.

2 In the window that appears, navigate to a folder on a network-connected computer or storage device.

The folder you selected appears as a storage location in the Event Library and the Project Library.

Use the SAN location as you would any other storage device that appears in the Event Library and the Project Library. For example, you can create Events or projects on the SAN location. You can also copy and move Events or projects to the SAN location.
Remove a SAN location

1 In the Event Library or the Project Library, select the SAN location you want to remove.
2 Choose File > Remove SAN Location.

The SAN location disappears from Event Library and the Project Library. The SAN location, and any Events or projects stored there, are now available to other Final Cut Pro users on the network.

Create and manage camera archives

You can make a camera archive (backup copy) of the contents of your camera or camcorder. (Note that you cannot make an archive from a live video signal, such as the signal produced by an iSight camera.) It is recommended that you save your archive to a disk or partition different from the one where you store the media files used with Final Cut Pro.

Because you can import media into Final Cut Pro from an archive, archiving the media on your device can be useful if you want to:

- Quickly empty the contents of your camera or camcorder so that you can record more media right away, rather than wait for it to import into Final Cut Pro, which can take time.
- Import the archived media on multiple computers without having to keep it on the camcorder.
- Keep a browsable, “near-line” archive of media from a camera without having to import the media into Final Cut Pro.

See “Access media on an archive or disk image” on page 42 for information on how to import media into Final Cut Pro from a camera archive.

Archive the media on your file-based camera or camcorder

1 If you want to save the archive to an external hard disk, connect it to your computer.
2 Connect the camera or camcorder to your computer using the cable that came with it, and turn it on.

If you’re using a camcorder, set it to PC Connect mode. The name of this transfer mode may be different on your device. Your camcorder may automatically go into “connect” mode if you turn it on in playback mode while it’s connected to your computer. For more information, see the documentation that came with your camcorder.

Note: Connecting a DVD camcorder to your Mac can cause the DVD Player application to open. If that happens, simply close DVD Player.
3 In Final Cut Pro, click the Import from Camera button on the left end of the toolbar (or press Command-I).

4 In the Camera Import window that appears, select the device whose content you want to archive from the list of cameras on the left.

5 Click the Create Archive button at the bottom-left corner of the window.

6 In the “Create Camera Archive as” field, type a name for the archive.

7 Choose a location to save the archive from the Destination pop-up menu, and click OK.

   **Note:** It is recommended that you save your archive to a disk or partition different from the one where you store the media files used with Final Cut Pro.

   The camera archive is stored on your hard disk. You can mount the archive as if it were a file-based camcorder and browse the archive’s contents, or import the media on the camera archive into Final Cut Pro. For more information, see “Access media on an archive or disk image” on page 42.

   **Note:** Whenever the disk containing the archive is connected, the disk will automatically appear in the Camera Archives list in Final Cut Pro.
Archive the media on your tape-based camera or camcorder

1 If you want to save the archive to an external hard disk, connect the external hard disk to your computer.

2 Connect the camera or camcorder to your computer using the cable that came with it, and turn it on.

   If you’re using a camcorder, set it to PC Connect mode. The name of this transfer mode may be different on your device. Your camcorder may automatically go into “connect” mode if you turn it on in playback mode while it’s connected to your computer. For more information, see the documentation that came with your camcorder.

3 In Final Cut Pro, do one of the following:
   - Choose File > Import from Camera (or press Command-I).
   - Click the Import from Camera button on the left end of the toolbar.

4 In the Camera Import window that appears, select the device whose content you want to archive from the list of cameras on the left.

5 Click the Create Archive button at the bottom-left corner of the window.

6 In the “Create Camera Archive as” field, type a name for the archive.

7 Choose a location to save the archive from the Destination pop-up menu, and click OK.
Note: It is recommended that you save your archive to a disk or partition different from the one where you store the media files used with Final Cut Pro.

Final Cut Pro begins archiving from the current location on the tape. It will continue to archive until one of the following occurs:

- It reaches the end of the tape.
- You manually stop the archiving process by clicking Stop Import or Close (to close the Camera Import window).

The camera archive is stored on your hard disk. You can mount the archive as if it were a file-based camcorder and browse the archive's contents, or import the media on the camera archive into Final Cut Pro. For more information, see “Access media on an archive or disk image” on page 42.

Whenever the disk containing the archive is connected, the disk will automatically appear in the Camera Archives list in Final Cut Pro as long as the archive is in one of two locations:

- /Users/username/Movies/Final Cut Camera Archives/
- The root level of the startup disk

**Move or copy a camera archive**

1. In the Finder, select the camera archive that you want to move or copy.
2. Do one of the following:
   - To move the camera archive on your local disk: Drag the camera archive to a new location.
   - To copy the camera archive on your local disk: Hold down the Option key and drag the camera archive to a new location on your local disk.
   - To copy the camera archive to an external storage disk: Drag the camera archive to a location on the external storage disk.

**Delete a camera archive**

Camera archives are very small relative to other media files, and often don’t warrant being deleted. However, you can delete a camera archive at any time.

1. In the Finder, select the camera archive.
2. Hold down the Control key and choose Move to Trash from the shortcut menu that appears.
3. Control-click or click and hold the Trash icon in your Dock, and choose Empty Trash from the shortcut menu.

**Important:** Emptying the Trash permanently deletes the camera archive.
Solutions to common media management issues

Alert icons
When you see red frames and a yellow alert triangle in a Timeline or Event, Final Cut Pro is alerting you that part of your project or Event is missing. There are many reasons that clips and Events, media files, and effects can be missing: moving projects and Events between computers and actively managing your Final Cut Pro Events or Projects folder using the Finder are two common reasons.

For more information about where Events, clips, projects, and files are located, see “Where your media and project files are located” on page 464.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Alert</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Missing Event</td>
<td>The Event folder is not available. You may see this alert if you moved the Event to the Trash, moved the Event to another location, moved a project to another location, moved a project to another location, or consolidated a different project’s media.</td>
</tr>
<tr>
<td></td>
<td>Missing Clip</td>
<td>A clip used in a Final Cut Pro project or in an Event is not available. You may see this alert if you moved the clip to the Trash, moved a clip (or Event), moved a project to a different location, or consolidated a different project’s media.</td>
</tr>
<tr>
<td>Icon</td>
<td>Alert</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>-------</td>
<td>-------------</td>
</tr>
<tr>
<td><img src="image1.jpg" alt="Icon Alert" /></td>
<td>Missing Camera</td>
<td>A camera that contains files used in Final Cut Pro is not connected to your system. To avoid getting this alert, create a copy of the media when you import it. See “Organize files while importing” on page 45 for more information.</td>
</tr>
<tr>
<td><img src="image2.jpg" alt="Icon Media files" /></td>
<td>Missing File</td>
<td>A file is not available in the Finder. You may see this alert if you moved or renamed a file in the Finder, moved an Event or project to a different location, or consolidated a different project’s media.</td>
</tr>
<tr>
<td><img src="image3.jpg" alt="Icon Media files" /></td>
<td>Modified File</td>
<td>A media file has been changed by an application other than Final Cut Pro.</td>
</tr>
<tr>
<td><img src="image4.jpg" alt="Icon Media files" /></td>
<td>Missing Proxy File</td>
<td>A proxy file created by Final Cut Pro is not in its expected location in the Finder. See “Transcode media files” on page 473 for more information.</td>
</tr>
<tr>
<td><img src="image5.jpg" alt="Icon Final Cut Pro effects" /></td>
<td>Missing Effect</td>
<td>An effect in Final Cut Pro is missing.</td>
</tr>
<tr>
<td><img src="image6.jpg" alt="Icon Final Cut Pro effects" /></td>
<td>Missing Generator</td>
<td>A generator in Final Cut Pro is missing.</td>
</tr>
<tr>
<td><img src="image7.jpg" alt="Icon Final Cut Pro effects" /></td>
<td>Missing Title</td>
<td>A title in Final Cut Pro is missing.</td>
</tr>
<tr>
<td><img src="image8.jpg" alt="Icon Final Cut Pro effects" /></td>
<td>Missing Transition</td>
<td>A transition in Final Cut Pro is missing.</td>
</tr>
</tbody>
</table>
Common media management issues
This section describes common media management issues and solutions.

If you don’t see a project on an external storage device
- Make sure the Final Cut Projects folder and the Final Cut Events folder are at the root level of the storage device.
- If the storage device still does not appear in the Project Library device list, you can manually copy or move the Final Cut Projects folder and the Final Cut Events folder to the Movies folder.
- You can also manually add individual project folders or Events folders to any existing Final Cut Projects folder and the Final Cut Events folder.

For more information, see “Media management overview” on page 463.

If you import a file directly from a hard drive and change the name in the Finder
You may see a missing file alert if you move or rename a file in the Finder.

- In the Finder, change the filename back to the filename used in the Event Browser.

If you cancelled an import
If you cancelled an import and didn’t import an entire clip, the clip will have a Camera icon on its bottom-left corner.

- Follow the instructions in “Reimport a clip” in “Import from file-based devices” on page 25.
If your computer loses power while Final Cut Pro is performing media management tasks
Because Final Cut Pro automatically saves all the changes you make as you work on a project, your project will be current when you restart Final Cut Pro after an unexpected power loss. If Final Cut Pro was performing media management tasks in the background, you can restart those processes manually using the Organize Event Files and Organize Project Files commands.

1 Select one or more Events in the Event Library or a project in the Project Library.

2 Do one of the following:
   • To restart background media management tasks for a selected Event: Choose File > Organize Event Files.
   • To restart background media management tasks for a selected project: Choose File > Organize Project Files.

If your DSLR camera isn’t recognized by Final Cut Pro
- Follow the instructions in “Import from a digital still camera” on page 34.
Preferences and metadata overview
In Final Cut Pro, you can modify preference settings to specify how your source media is imported into the application, how your clips play back, and how you edit your clips in the Timeline.

You can also view and change the information associated with a clip, referred to as a clip's metadata. Metadata includes information about a clip's source media files as well as information you add to a clip, such as notes. For more information, see “Display and change metadata” on page 502.

Final Cut Pro preferences
Change preference settings
A preference modifies how a particular Final Cut Pro feature behaves. Most preference settings can be turned on or off at any time. The following sections describe Final Cut Pro preferences in detail.

Open Final Cut Pro preferences
- Choose Final Cut Pro > Preferences (or press Command-Comma), and click a pane’s button at the top of the window to open it.

Copy Final Cut Pro preferences between computers
You can copy Final Cut Pro preference settings to another Mac that has Final Cut Pro installed so that the settings are the same on both computers.

1 Find the preference settings file in the following location:
/Users/username/Library/Preferences/com.apple.FinalCut.plist

2 Copy the preference settings file to the same location on another Mac.
   If necessary, overwrite any existing version of the file at that location.
Editing preferences
Editing preferences affect editing behaviors in Final Cut Pro.

Time Display
- Time Display: Use this pop-up menu to choose the time mode for Final Cut Pro. Changes in this setting affect the time display (for the position of the skimmer or the playhead) in the Dashboard in the center of the toolbar, as well as trimming and navigation operations in Final Cut Pro. You have the following options:
  - Timecode display
  - Timecode display including subframes
  - Duration in frames
  - Duration in seconds

Timeline
- Show detailed trimming feedback: Select this checkbox to show the “two-up” display in the Viewer for more accurate feedback on an edit point involving two contiguous clips. For example, for a simple ripple or roll edit, this display shows the end point of the left clip and the start point of the right clip.
- Position playhead after edit operation: Select this checkbox to have the playhead automatically positioned in the Timeline at the end of your last edit. For example, if you insert a clip between two clips in the Timeline, the playhead is automatically positioned between the inserted clip and the clip that follows it.
Audio
- *Show reference waveforms*: Select this checkbox to change the background appearance of the audio portion of a clip to show reference waveforms. A reference waveform shows the maximum visual resolution possible of the actual audio waveform. By factoring out loudness, reference waveforms let you see the shape of the sound more clearly. When the actual waveform changes shape (for example, it is diminished when a clip's volume level is low), you can continue to see its reference waveform in full for easy reference when editing.

Still Images
- *Default length*: Use this value slider to set the default length of still-image clips in seconds.

Transitions
- *Default length*: Use this value slider to set the default length of transitions in seconds.

Dialog Warnings
- *Reset All*: Click this button to reset all warning dialogs.

Playback preferences
Playback preferences affect playback and rendering performance in Final Cut Pro.

Rendering
- *Background render*: Select this checkbox to turn on Final Cut Pro rendering operations when the system is idle.
- *Start after*: Use this value slider to set the amount of time your system is idle, in seconds, before Final Cut Pro begins background rendering.
Playback

- Use proxy media: Click this button to use medium-quality proxy media (converted to one-quarter resolution) rather than full-resolution media for playback. Choosing this option increases playback performance, but the video quality is lower. In Final Cut Pro, proxy media is in the Apple ProRes 422 (Proxy) format.

- Use original or optimized media: Click this button to use the optimized media for playback. If optimized media is not available, Final Cut Pro uses the original media for playback. In that case, use the Playback Quality pop-up menu to choose whether to always use the highest-quality video for playback or downsized video for better playback performance. In Final Cut Pro, optimized media is in the Apple ProRes 422 format.

- Create optimized media for multicam clips: Select this checkbox to automatically transcode multicam clip video to the Apple ProRes 422 codec, which provides better performance during editing and faster render times.

- Warn when dropping frames during playback: Select this checkbox to have Final Cut Pro warn you when frames are dropped during playback.

- Warn when frames are dropped due to hard disk performance: Select this checkbox to have Final Cut Pro warn you when frames are dropped during playback specifically because of hard disk performance.

Pre-Roll Duration

- Pre-Roll Duration: Use this value slider to set the amount of time to play before an audition or before the skimmer or playhead position when using the Play Around command.

Post-Roll Duration

- Post-Roll Duration: Use this value slider to set the amount of time to play after an audition or after the skimmer or playhead position when using the Play Around command.

Player Background

- Player Background: Use this pop-up menu to choose a background for the Viewer. The color you choose will be visible in the case of partially or completely transparent clips, or clips that do not fill the frame completely.

A/V Output

- A/V Output: Use this pop-up menu to choose an external audio/video device or monitor for output. A/V output requires third-party video interface hardware and software and is available only with OS X Lion v10.7.2 or later. For more information, see “View playback on an external video monitor” on page 90.
Import preferences
When you import media into Final Cut Pro using the Camera Import window or the Import Files window, you can customize your import settings each time you import files. However, if you drag media directly from the Finder into Final Cut Pro, Final Cut Pro uses the import settings you selected in the Final Cut Pro Import preferences window.

Organizing
- **Copy files to Final Cut Pro Events folder:** Duplicates the media files and places the copy in the Final Cut Events folder on your system. If you’re importing media from a different disk or volume, or if you want to keep a copy of all the media files that have been imported into Final Cut Pro in the same location, select this checkbox.
- **Import folders as Keyword Collections:** Creates a Keyword Collection for each folder in the files you’re importing. If the files you’re importing are in folders with meaningful names, select this option to keep the file organization that exists in the Finder. (Note that although Keyword Collections are not nested in the Event Library, every file in a folder will get a Keyword Collection for each folder it is in, whether it is one, two, or more levels deep in that folder.)

Transcoding
- **Create optimized media:** This option transcodes video to the Apple ProRes 422 codec, which provides better performance during editing, faster render times, and better color quality for compositing. This option transcodes still images to either JPEG (if the original file doesn’t have alpha channel information) or PNG files (if the file has alpha channel information). If the original camera format can be edited with good performance, this option will be dimmed.
• **Create proxy media:** This option transcodes video to the Apple ProRes 422 (Proxy) codec, which provides high-quality files useful for offline editing. Video proxy files can use considerably less disk space, often enough to allow you to work on a portable computer instead of a desktop computer that has significantly more memory and processing power. This option transcodes still images to either JPEG files (if the original file doesn’t have alpha channel information) or PNG files (if the file has alpha channel information).

**Note:** When transcoding files, Final Cut Pro always retains the original media for future use. For more information about where to find original media, proxy media, and transcoded media files, see “Where your media and project files are located” on page 464.

**Video**

• **Analyze for stabilization and rolling shutter:** Analyzes clips with video and adds keywords to clips with excessive shake, rolling shutter, or both. Clips that receive an Excessive Shake keyword during analysis are automatically corrected when you drag the clip to the Timeline. You can correct image stabilization issues for a clip in an Event by turning on Stabilization in the Video inspector. If you’re analyzing and fixing stabilization problems, it’s recommended that you also select the “Create Smart Collections after analysis” checkbox.

• **Analyze for balance color:** Analyzes clips with video and detects color cast and contrast issues. Color is automatically balanced when you drag the clip to the Timeline. You can fix color balance for a clip in an Event by turning on Balance in the Color section of the Video inspector.

You can turn off the automatic color adjustments at any time. After you do so, the clip has the colors originally recorded within the project.

• **Find people:** Analyzes clips with video for the presence of people and shot types. After analysis, any of the following keywords are added to the clip: One Person, Two Persons, Group, Close Up Shot, Medium Shot, and Wide Shot. If you’re analyzing to find people, it’s recommended that you also select the “Create Smart Collections after analysis” checkbox.

• **Create Smart Collections after analysis:** Creates Smart Collections for each keyword applied when video clips are analyzed for image stabilization problems or the presence of people. The Smart Collections appear inside a folder inside the Event.

**Audio**

• **Analyze and fix audio problems:** Analyzes audio and automatically corrects it for hum, noise, and loudness. You can turn off automatic audio corrections at any time; after you do so, the audio will play as originally recorded.

• **Separate mono and group stereo audio:** Analyzes and groups audio channels as dual mono or stereo, depending on the results of the analysis. For more information about audio channels, see “Configure audio channels” on page 204.
- **Remove silent channels:** Audio channels are analyzed and silent channels are automatically removed. For more information about audio channels, see “Configure audio channels” on page 204.

  **Note:** You can retrieve the original audio configuration after import. See “Configure audio channels” on page 204.

### Work with metadata

#### Display and change metadata

Information about your source media files, information recorded by the camera, and descriptive information about a clip are called metadata. In Final Cut Pro, you can create your own combinations of metadata to display with your clips, called metadata views. You can either create new metadata views or modify the ones that come with Final Cut Pro.

In Final Cut Pro, you work with three types of metadata:

- **Exchangeable Image File (EXIF) data:** Information recorded by the camera and stored in the media at the time it was shot, such as camera make and model, file size, color profile, and bits per sample.

- **International Press Telecommunications Council (IPTC) data:** Standardized data used by media organizations to embed keywords, captions, copyright notices, and other information in the media files themselves.

- **Final Cut Pro metadata:** Data you apply to clips within Final Cut Pro, such as clip name, ratings, and keywords.

You can use the Info inspector to view and change the metadata for a clip or group of clips selected in the Event Browser or Timeline.
View a clip’s metadata

1. Select a clip.

2. To open the Info inspector, click the Inspector button in the toolbar (shown below), and click the Info button at the top of the pane that appears.

Metadata for the selected clip or group of clips is displayed in fields in the Info inspector.

Switch metadata views in the Info inspector

You can change the metadata fields shown in the Info inspector by choosing a different metadata view from the Metadata View pop-up menu.

1. Select a clip.

2. Open the Info inspector.

3. Choose a metadata view from the Metadata View pop-up menu.

Note: If you create custom metadata views, they also appear in the pop-up menu.

Change a clip’s metadata

1. Select a clip.

2. Open the Info inspector.

3. In the Metadata View pop-up menu, choose a metadata view that contains fields for the metadata you want to change.

4. Do either of the following:
   - Click in a text field to make it active, and enter the text you want to include.
     
     Note: If you can’t click in a text field, the field can’t be edited. Some EXIF metadata fields, for example, can’t be edited.
   - Choose an option from the pop-up menu for the metadata you want to change.

Note: You can also change the Content Created date and time of your source clips in the Event Browser. Just select one or more clips and choose Modify > Adjust Content Created Date and Time.
Rearrange the fields in a metadata view
- In the Info inspector, drag the metadata labels into a different order.

Modify metadata views
You can create new metadata views or modify the ones that come with Final Cut Pro.

Create a new metadata view
1 Select a clip.
2 To open the Info inspector, click the Inspector button in the toolbar (shown below), and click the Info button at the top of the pane that appears.

3 In the Info inspector, choose Edit Metadata View from the Metadata View pop-up menu.
4 In the Metadata Views window, choose New Metadata View from the Action pop-up menu at the bottom-left corner of the window.
5 Enter a name for the new metadata view, and press Return.
6 To limit the number of properties to a specific group, such as EXIF or video properties, choose a property group from the Properties pop-up menu at the top of the window.
7 To add a property to the metadata view, select the checkbox to the left of the property.
When you are satisfied with the metadata fields assigned to the metadata view, click OK.

The new metadata view is added to the Metadata View pop-up menu in the Info inspector.

Modify an existing metadata view
You can change the combination of metadata that appears in an existing metadata view. You can rename metadata fields, add or remove metadata fields, create custom metadata fields, and rearrange the order in which the metadata fields are displayed.

1 Select a clip.
2 Open the Info inspector.
3 In the Info inspector, choose Edit Metadata View from the Metadata View pop-up menu.
4 In the Metadata Views window, select the metadata view you want to change, and do any of the following:
   - To rename the metadata view: Double-click the metadata view name in the column on the left, enter a new name, and press Return.
   - To remove properties (metadata fields) from the metadata view: In the Property column, click the checkmark to the left of the property you want to remove.
   - To add properties (metadata fields) to the metadata view: In the Property column, select the checkbox to the left of the property you want to add.
   - To add a custom property (metadata field) to the metadata view: Choose Add Custom Metadata Field from the Action pop-up menu, enter a name and description for the new property, and click OK.
5 When you are satisfied with the metadata fields assigned to the selected metadata view, click OK.

Duplicate a metadata view
If you want to create a new metadata view that contains most of the metadata fields in an existing metadata view, you can save time by duplicating the existing metadata view and then modifying it.

1 Select a clip.
2 Open the Info inspector.
3 In the Info inspector, choose the metadata view you want to duplicate from the Metadata View pop-up menu, and then choose Save Metadata View As from the Metadata View pop-up menu.
4 In the window that appears at the top of the Final Cut Pro window, enter a name for the new metadata view and click OK.
The new metadata view appears in the Metadata View pop-up menu in the Info inspector. Modify the new metadata view as needed.

**Delete a metadata view**

1. Select a clip.
2. Open the Info inspector.
3. In the Info inspector, choose Edit Metadata View from the Metadata View pop-up menu.
4. In the Metadata Views window, select the metadata view you want to delete in the column on the left, and choose Delete Metadata View from the Action pop-up menu ▼ in the lower-left corner.

The metadata view is removed from the left column of the Metadata Views window and from the Metadata View pop-up menu in the Info inspector.

**Note:** Deleting a metadata view does not delete metadata applied to a clip or its source media.

**Batch rename clips**

When you import media into Final Cut Pro, the clips often contain meaningless names, such as those assigned by the camera. Although you can rename clips individually, you can also automatically rename a selection of clips as a batch (*batch rename*) in the Event Browser, after the media has been imported into Final Cut Pro. Final Cut Pro provides customizable naming presets that make renaming large amounts of clips efficient and easy.

**Batch rename clips using a naming preset**

1. In the Event Browser, select the clips you want to rename.
2. To open the Info inspector, click the Inspector button in the toolbar (shown below), and click the Info button at the top of the pane that appears.
3. Choose Apply Custom Name from the Action pop-up menu ▼ and choose a naming preset from the submenu.

The clips selected in the Event Browser are renamed.
Create a new naming preset
In most cases, you’ll want to create a new naming preset and customize it.

Tip: The easiest way to create a new naming preset is to duplicate an existing one. See the following task for more information.

1 In the Event Browser, select the clips you want to rename.
2 Open the Info inspector.
3 Choose Apply Custom Name from the Action pop-up menu and choose New from the submenu.
4 In the Naming Presets window, double-click Untitled, type a name for the new preset, and press Return.

The new naming preset appears in the Apply Custom Name submenu of the Action pop-up menu.

Duplicate an existing naming preset
The simplest way to create a new naming preset is to duplicate an existing preset—one that contains most of the name format options you want to include—and modify it.

1 In the Event Browser, select the clips you want to rename.
2 Open the Info inspector.
3 Choose Apply Custom Name from the Action pop-up menu and choose Edit from the submenu.
4 In the Naming Presets window, Control-click the preset that you want to duplicate, and choose Duplicate from the shortcut menu.

The duplicate naming preset appears below the original preset.
5 Enter a name for the duplicate preset, and press Return.

You can now modify the preset to suit your needs.

Modify an existing naming preset
1 In the Event Browser, select the clips you want to rename.
2 Open the Info inspector.
3 Choose Apply Custom Name from the Action pop-up menu and choose Edit from the submenu.
4 In the Naming Presets window, add name tokens by dragging the elements from the Clip Info, Date/Time, Format, and Camera areas to the Format field.

To remove a naming token, select it in the Format field, and press Delete.

5 Rearrange the tokens in the Format field by dragging them into new positions.

6 If you like, add text characters between naming tokens in the Format field, such as underscores (_) and spaces.

7 When you are satisfied with the naming preset’s new format, click OK.

Remove a naming preset

1 Select a clip.

2 Open the Info inspector.

3 Choose Apply Custom Name from the Action pop-up menu 🌋 ▼ and choose Edit from the submenu.

4 In the Naming Presets window, select the naming preset you want to remove, and click the Remove Presets button (with a minus sign).

The naming preset is removed from the Naming Presets window.
Keyboard shortcuts and Multi-Touch gestures overview

Final Cut Pro provides several ways to increase your efficiency while you put together your project:

- **Standard keyboard shortcuts:** Many common tasks, such as opening a specific window or adding a clip from the Event Browser to the Timeline, can be accomplished very quickly by pressing one or more keys. See “Keyboard shortcuts” on page 509.

- **Multi-Touch gestures:** If you have a Multi-Touch trackpad or mouse, you can take advantage of Multi-Touch gestures to quickly perform many tasks while creating your project. See “Multi-Touch gestures” on page 526.

- **Custom keyboard shortcuts:** You can add to the standard keyboard shortcuts by creating your own custom keyboard shortcuts for features that you use frequently, such as Color Board controls. Or if you’re more familiar with keyboard shortcuts from another application, you can use the Command Editor to substitute those keyboard shortcuts in place of the default set in Final Cut Pro. See “View keyboard shortcuts in the Command Editor” on page 526.

Keyboard shortcuts

You can use keyboard shortcuts to quickly accomplish many tasks in Final Cut Pro. To use a keyboard shortcut, press all the keys in the shortcut at the same time. Shortcuts for common commands are listed in the table below.

<table>
<thead>
<tr>
<th>Application</th>
<th>Command</th>
<th>Shortcut</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hide Application</td>
<td></td>
<td>Command-H</td>
<td>Hide Final Cut Pro</td>
</tr>
<tr>
<td>Hide Other Applications</td>
<td></td>
<td>Command-Option-H</td>
<td>Hide all applications except Final Cut Pro</td>
</tr>
<tr>
<td>Keyboard Customization</td>
<td></td>
<td>Command-Option-K</td>
<td>Open the Command Editor</td>
</tr>
<tr>
<td>Command</td>
<td>Shortcut</td>
<td>Action</td>
<td></td>
</tr>
<tr>
<td>------------------------------</td>
<td>-------------------</td>
<td>-----------------------------------------------------</td>
<td></td>
</tr>
<tr>
<td>Minimize</td>
<td>Command-M</td>
<td>Minimize Final Cut Pro</td>
<td></td>
</tr>
<tr>
<td>Preferences</td>
<td>Command-Comma (,)</td>
<td>Open the Final Cut Pro Preferences window</td>
<td></td>
</tr>
<tr>
<td>Quit</td>
<td>Command-Q</td>
<td>Quit Final Cut Pro</td>
<td></td>
</tr>
<tr>
<td>Redo Change</td>
<td>Command-Shift-Z</td>
<td>Redo the last command</td>
<td></td>
</tr>
<tr>
<td>Undo Change</td>
<td>Command-Z</td>
<td>Undo the last command</td>
<td></td>
</tr>
</tbody>
</table>

## Editing

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Append to Storyline</td>
<td>E</td>
<td>Add the selection to the end of the storyline</td>
</tr>
<tr>
<td>Audition: Add to Audition</td>
<td>Shift-Control-Y</td>
<td>Add the selected clip to the audition</td>
</tr>
<tr>
<td>Audition: Duplicate and Paste Effects</td>
<td>Command-Option-Y</td>
<td>Duplicate clips in the audition and add effect</td>
</tr>
<tr>
<td>Audition: Duplicate as Audition</td>
<td>Option-Y</td>
<td>Create an audition with a Timeline clip and a duplicate version of the clip, including applied effects</td>
</tr>
<tr>
<td>Audition: Duplicate from Original</td>
<td>Command-Shift-Y</td>
<td>Duplicate the selected audition clip without applied effects</td>
</tr>
<tr>
<td>Audition: Replace and Add to Audition</td>
<td>Shift-Y</td>
<td>Create an audition and replace the Timeline clip with the current selection</td>
</tr>
<tr>
<td>Blade</td>
<td>Command-B</td>
<td>Cut the primary storyline clip (or the selection) below the skimmer or playhead</td>
</tr>
<tr>
<td>Break Apart Clip Items</td>
<td>Command-Shift-G</td>
<td>Break the selected item into its component parts</td>
</tr>
<tr>
<td>Change Duration</td>
<td>Control-D</td>
<td>Change the duration of the selection</td>
</tr>
<tr>
<td>Connect to Primary Storyline</td>
<td>Q</td>
<td>Connect the selection to the primary storyline</td>
</tr>
<tr>
<td>Connect to Primary Storyline - Backtimed</td>
<td>Shift-Q</td>
<td>Connect the selection to the primary storyline, aligning the selection's end point with the skimmer or playhead</td>
</tr>
<tr>
<td>Copy</td>
<td>Command-C</td>
<td>Copy the selection</td>
</tr>
<tr>
<td>Command</td>
<td>Shortcut</td>
<td>Action</td>
</tr>
<tr>
<td>---------------------------------</td>
<td>----------------</td>
<td>------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Create Audition</td>
<td>Command-Y</td>
<td>Create an audition from the selection</td>
</tr>
<tr>
<td>Create Storyline</td>
<td>Command-G</td>
<td>Create a storyline from a selection of connected clips</td>
</tr>
<tr>
<td>Cut</td>
<td>Command-X</td>
<td>Cut the selection</td>
</tr>
<tr>
<td>Cut and Switch to Viewer Angle 1</td>
<td>1</td>
<td>Cut and switch the multicam clip to angle 1 of the current bank</td>
</tr>
<tr>
<td>Cut and Switch to Viewer Angle 2</td>
<td>2</td>
<td>Cut and switch the multicam clip to angle 2 of the current bank</td>
</tr>
<tr>
<td>Cut and Switch to Viewer Angle 3</td>
<td>3</td>
<td>Cut and switch the multicam clip to angle 3 of the current bank</td>
</tr>
<tr>
<td>Cut and Switch to Viewer Angle 4</td>
<td>4</td>
<td>Cut and switch the multicam clip to angle 4 of the current bank</td>
</tr>
<tr>
<td>Cut and Switch to Viewer Angle 5</td>
<td>5</td>
<td>Cut and switch the multicam clip to angle 5 of the current bank</td>
</tr>
<tr>
<td>Cut and Switch to Viewer Angle 6</td>
<td>6</td>
<td>Cut and switch the multicam clip to angle 6 of the current bank</td>
</tr>
<tr>
<td>Cut and Switch to Viewer Angle 7</td>
<td>7</td>
<td>Cut and switch the multicam clip to angle 7 of the current bank</td>
</tr>
<tr>
<td>Cut and Switch to Viewer Angle 8</td>
<td>8</td>
<td>Cut and switch the multicam clip to angle 8 of the current bank</td>
</tr>
<tr>
<td>Cut and Switch to Viewer Angle 9</td>
<td>9</td>
<td>Cut and switch the multicam clip to angle 9 of the current bank</td>
</tr>
<tr>
<td>Delete</td>
<td>Delete key</td>
<td>Delete the Timeline selection, reject the Event Browser selection, or remove a multicam through edit</td>
</tr>
<tr>
<td>Deselect All</td>
<td>Command-Shift-A</td>
<td>Deselect all selected items</td>
</tr>
<tr>
<td>Duplicate</td>
<td>Command-D</td>
<td>Duplicate the Event Browser selection</td>
</tr>
<tr>
<td>Enable/Disable Clip</td>
<td>V</td>
<td>Enable or disable playback for the selection</td>
</tr>
<tr>
<td>Command</td>
<td>Shortcut</td>
<td>Action</td>
</tr>
<tr>
<td>--------------------------</td>
<td>-------------------</td>
<td>------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Expand Audio/Video</td>
<td>Control-S</td>
<td>View audio and video separately for selected clips</td>
</tr>
<tr>
<td>Extend Edit</td>
<td>Shift-X</td>
<td>Extend the selected edit point to the skimmer or playhead position</td>
</tr>
<tr>
<td>Extend Selection Down</td>
<td>Shift-Down Arrow</td>
<td>In the Event Browser, add the next clip to the selection</td>
</tr>
<tr>
<td>Extend Selection Up</td>
<td>Shift-Up Arrow</td>
<td>In the Event Browser, add the previous clip to the selection</td>
</tr>
<tr>
<td>Finalize Audition</td>
<td>Shift-Option-Y</td>
<td>Dissolve the audition and replace it with the audition pick</td>
</tr>
<tr>
<td>Insert</td>
<td>W</td>
<td>Insert the selection at the skimmer or playhead position</td>
</tr>
<tr>
<td>Insert Gap</td>
<td>Option-W</td>
<td>Insert a gap clip at the skimmer or playhead position</td>
</tr>
<tr>
<td>Insert Placeholder</td>
<td>Command-Option-W</td>
<td>Insert a placeholder clip at the skimmer or playhead position</td>
</tr>
<tr>
<td>Lift from Storyline</td>
<td>Command-Option-Up Arrow</td>
<td>Lift the selection from the storyline and connect it to the resulting gap clips</td>
</tr>
<tr>
<td>Lower Volume 1 dB</td>
<td>Control-Hyphen (-)</td>
<td>Lower the audio volume by 1 dB</td>
</tr>
<tr>
<td>Move Playhead Position</td>
<td>Control-P</td>
<td>Move the playhead by entering a timecode value</td>
</tr>
<tr>
<td>New Compound Clip</td>
<td>Option-G</td>
<td>Create a new compound clip (if there's no selection, create an empty compound clip)</td>
</tr>
<tr>
<td>Next Angle</td>
<td>Shift-Control-Right Arrow</td>
<td>Switch to the next angle in the multicam clip</td>
</tr>
<tr>
<td>Next Audio Angle</td>
<td>Shift-Option-Right Arrow</td>
<td>Switch to the next audio angle in the multicam clip</td>
</tr>
<tr>
<td>Next Pick</td>
<td>Control-Right Arrow</td>
<td>Select the next clip in the Audition window, making it the audition pick</td>
</tr>
<tr>
<td>Next Video Angle</td>
<td>Command-Shift-Right Arrow</td>
<td>Switch to the next video angle in the multicam clip</td>
</tr>
<tr>
<td>Command</td>
<td>Shortcut</td>
<td>Action</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-----------------------------</td>
<td>------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Nudge Audio Subframe Left</td>
<td>Option-Comma (,)</td>
<td>Nudge the selected audio edit point left by one subframe, creating a split edit</td>
</tr>
<tr>
<td>Nudge Audio Subframe Left</td>
<td>Shift-Option-Comma (,)</td>
<td>Nudge the selected audio edit point left by 10 subframes, creating a split edit</td>
</tr>
<tr>
<td>Nudge Audio Subframe Right</td>
<td>Option-Period (.)</td>
<td>Nudge the selected audio edit point right by one subframe, creating a split edit</td>
</tr>
<tr>
<td>Nudge Audio Subframe Right</td>
<td>Shift-Option-Period (.)</td>
<td>Nudge the selected audio edit point right by 10 subframes, creating a split edit</td>
</tr>
<tr>
<td>Nudge Down</td>
<td>Option-Down Arrow</td>
<td>Nudge down the value of the selected keyframe in the Animation Editor</td>
</tr>
<tr>
<td>Nudge Left</td>
<td>Comma (,)</td>
<td>Nudge the selection one unit to the left</td>
</tr>
<tr>
<td>Nudge Left Many</td>
<td>Shift-Comma (,)</td>
<td>Nudge the selection 10 units to the left</td>
</tr>
<tr>
<td>Nudge Right</td>
<td>Period (.)</td>
<td>Nudge the selection one unit to the right</td>
</tr>
<tr>
<td>Nudge Right Many</td>
<td>Shift-Period (.)</td>
<td>Nudge the selection 10 units to the right</td>
</tr>
<tr>
<td>Nudge Up</td>
<td>Option-Up Arrow</td>
<td>Nudge up the value of the selected keyframe in the Animation Editor</td>
</tr>
<tr>
<td>Open Audition</td>
<td>Y</td>
<td>Open the selected audition</td>
</tr>
<tr>
<td>Overwrite</td>
<td>D</td>
<td>Overwrite at the skimmer or playhead position</td>
</tr>
<tr>
<td>Overwrite - Backtimed</td>
<td>Shift-D</td>
<td>Overwrite from the skimmer or playhead position back</td>
</tr>
<tr>
<td>Overwrite to Primary Storyline</td>
<td>Command-Option-Down Arrow</td>
<td>Overwrite at the skimmer or playhead position in the primary storyline</td>
</tr>
<tr>
<td>Command</td>
<td>Shortcut</td>
<td>Action</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>------------------</td>
<td>------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Paste as Connected</td>
<td>Option-V</td>
<td>Paste the selection and connect it to the primary storyline</td>
</tr>
<tr>
<td>Paste Insert at Playhead</td>
<td>Command-V</td>
<td>Insert the Clipboard contents at the skimmer or playhead position</td>
</tr>
<tr>
<td>Previous Angle</td>
<td>Shift-Control-Left Arrow</td>
<td>Switch to the previous angle in the multicam clip</td>
</tr>
<tr>
<td>Previous Audio Angle</td>
<td>Shift-Option-Left Arrow</td>
<td>Switch to the previous audio angle in the multicam clip</td>
</tr>
<tr>
<td>Previous Pick</td>
<td>Control-Left Arrow</td>
<td>Select the previous clip in the Audition window, making it the audition pick</td>
</tr>
<tr>
<td>Previous Video Angle</td>
<td>Command-Shift-Left Arrow</td>
<td>Switch to the previous video angle in the multicam clip</td>
</tr>
<tr>
<td>Raise Volume 1 dB</td>
<td>Control-Equal Sign (=)</td>
<td>Raise the audio volume by 1 dB</td>
</tr>
<tr>
<td>Replace</td>
<td>Shift-R</td>
<td>Replace the selected clip in the Timeline with the Event Browser selection</td>
</tr>
<tr>
<td>Replace from Start</td>
<td>Option-R</td>
<td>Replace the selected clip in the Timeline with the Event Browser selection, starting from its start point</td>
</tr>
<tr>
<td>Replace with Gap</td>
<td>Shift-Delete</td>
<td>Replace the selected Timeline clip with a gap clip</td>
</tr>
<tr>
<td>Select All</td>
<td>Command-A</td>
<td>Select all clips</td>
</tr>
<tr>
<td>Select Clip</td>
<td>C</td>
<td>Select the clip under the pointer in the Timeline</td>
</tr>
<tr>
<td>Select Left Audio Edge</td>
<td>Shift-Left Bracket (I)</td>
<td>For audio/video clips in expanded view, select the left edge of the audio edit point</td>
</tr>
<tr>
<td>Select Left Edge</td>
<td>Left Bracket (I)</td>
<td>Select the left edge of the edit point</td>
</tr>
<tr>
<td>Select Left and Right Audio Edit Edges</td>
<td>Shift-Backslash ()</td>
<td>For audio/video clips in expanded view, select the left and right edges of the audio edit point</td>
</tr>
<tr>
<td>Select Left and Right Edit Edges</td>
<td>Backslash ()</td>
<td>Select the left and right edges of the edit point</td>
</tr>
<tr>
<td>Command</td>
<td>Shortcut</td>
<td>Action</td>
</tr>
<tr>
<td>------------------------------</td>
<td>-------------------</td>
<td>------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Select Right Audio Edge</td>
<td>Shift-Right Bracket (])</td>
<td>For audio/video clips in expanded view, select the right edge of the audio edit point</td>
</tr>
<tr>
<td>Select Right Edge</td>
<td>Right Bracket (])</td>
<td>Select the right edge of the edit point</td>
</tr>
<tr>
<td>Show/Hide Precision Editor</td>
<td>Control-E</td>
<td>When an edit point is selected, show or hide the Precision Editor</td>
</tr>
<tr>
<td>Snapping</td>
<td>N</td>
<td>Turn snapping on or off</td>
</tr>
<tr>
<td>Solo</td>
<td>Option-S</td>
<td>Solo the selected items in the Timeline</td>
</tr>
<tr>
<td>Source Media: Audio &amp; Video</td>
<td>Shift-1</td>
<td>Turn on audio/video mode to add the video and audio portion of your selection to the Timeline</td>
</tr>
<tr>
<td>Source Media: Audio Only</td>
<td>Shift-3</td>
<td>Turn on audio-only mode to add the audio portion of your selection to the Timeline</td>
</tr>
<tr>
<td>Source Media: Video Only</td>
<td>Shift-2</td>
<td>Turn on video-only mode to add the video portion of your selection to the Timeline</td>
</tr>
<tr>
<td>Switch to Viewer Angle 1</td>
<td>Option-1</td>
<td>Switch the multicam clip to angle 1 of the current bank</td>
</tr>
<tr>
<td>Switch to Viewer Angle 2</td>
<td>Option-2</td>
<td>Switch the multicam clip to angle 2 of the current bank</td>
</tr>
<tr>
<td>Switch to Viewer Angle 3</td>
<td>Option-3</td>
<td>Switch the multicam clip to angle 3 of the current bank</td>
</tr>
<tr>
<td>Switch to Viewer Angle 4</td>
<td>Option-4</td>
<td>Switch the multicam clip to angle 4 of the current bank</td>
</tr>
<tr>
<td>Switch to Viewer Angle 5</td>
<td>Option-5</td>
<td>Switch the multicam clip to angle 5 of the current bank</td>
</tr>
<tr>
<td>Switch to Viewer Angle 6</td>
<td>Option-6</td>
<td>Switch the multicam clip to angle 6 of the current bank</td>
</tr>
<tr>
<td>Switch to Viewer Angle 7</td>
<td>Option-7</td>
<td>Switch the multicam clip to angle 7 of the current bank</td>
</tr>
<tr>
<td>Switch to Viewer Angle 8</td>
<td>Option-8</td>
<td>Switch the multicam clip to angle 8 of the current bank</td>
</tr>
<tr>
<td>Command</td>
<td>Shortcut</td>
<td>Action</td>
</tr>
<tr>
<td>---------------------------------</td>
<td>-------------------</td>
<td>------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Switch to Viewer Angle 9</td>
<td>Option-9</td>
<td>Switch the multicam clip to angle 9 of the current bank</td>
</tr>
<tr>
<td>Toggle Storyline Mode</td>
<td>G</td>
<td>Turn on or turn off the ability to build storylines when dragging clips in the Timeline</td>
</tr>
<tr>
<td>Trim End</td>
<td>Option-Right Bracket (])</td>
<td>Trim the end of the selected or topmost clip to the skimmer or playhead position</td>
</tr>
<tr>
<td>Trim Start</td>
<td>Option-Left Bracket ([)</td>
<td>Trim the clip start point to the skimmer or playhead position</td>
</tr>
<tr>
<td>Trim to Selection</td>
<td>Option-Backslash ()</td>
<td>Trim clip start and end points to the range selection</td>
</tr>
</tbody>
</table>

**Effects**

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add Basic Lower Third</td>
<td>Shift-Control-T</td>
<td>Connect a basic lower-third title to the primary storyline</td>
</tr>
<tr>
<td>Add Basic Title</td>
<td>Control-T</td>
<td>Connect a basic title to the primary storyline</td>
</tr>
<tr>
<td>Add Cross Dissolve</td>
<td>Command-T</td>
<td>Add a cross dissolve to the selection</td>
</tr>
<tr>
<td>Color Board: Reset Current Board Controls</td>
<td>Option-Delete</td>
<td>Reset the controls in the current Color Board pane</td>
</tr>
<tr>
<td>Color Board: Switch to the Color Pane</td>
<td>Command-Control-C</td>
<td>Switch to the Color pane in the Color Board</td>
</tr>
<tr>
<td>Color Board: Switch to the Exposure Pane</td>
<td>Command-Control-E</td>
<td>Switch to the Exposure pane in the Color Board</td>
</tr>
<tr>
<td>Color Board: Switch to the Saturation Pane</td>
<td>Command-Control-S</td>
<td>Switch to the Saturation pane in the Color Board</td>
</tr>
<tr>
<td>Copy Effects</td>
<td>Command-Option-C</td>
<td>Copy the selected effects and their settings</td>
</tr>
<tr>
<td>Enable/Disable Balance Color</td>
<td>Command-Option-B</td>
<td>Turn Balance Color corrections on or off</td>
</tr>
<tr>
<td>Match Audio</td>
<td>Command-Shift-M</td>
<td>Match the sound between clips</td>
</tr>
<tr>
<td>Match Color</td>
<td>Command-Option-M</td>
<td>Match color between clips</td>
</tr>
<tr>
<td>Paste Effects</td>
<td>Command-Option-V</td>
<td>Paste effects and their settings to the selection</td>
</tr>
</tbody>
</table>
### Keyboard shortcuts and gestures

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Retime Editor</td>
<td>Command-R</td>
<td>Show or hide the Retime Editor</td>
</tr>
<tr>
<td>Retime: Create Normal Speed Segment</td>
<td>Shift-N</td>
<td>Set the selection to play at normal (100 percent) speed</td>
</tr>
<tr>
<td>Retime: Hold</td>
<td>Shift-H</td>
<td>Create a 2-second Hold segment</td>
</tr>
<tr>
<td>Retime: Reset</td>
<td>Command-Option-R</td>
<td>Reset the selection to play forward at normal (100 percent) speed</td>
</tr>
<tr>
<td>Solo Animation</td>
<td>Shift-Control-V</td>
<td>Show one effect at a time in the Video Animation Editor</td>
</tr>
</tbody>
</table>

#### General

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete</td>
<td>Delete</td>
<td>Delete the Timeline selection, or reject the Event Browser selection</td>
</tr>
<tr>
<td>Find</td>
<td>Command-F</td>
<td>Show or hide the Filter window (in the Event Browser) or the Timeline Index (in the Timeline)</td>
</tr>
<tr>
<td>Import Files</td>
<td>Command-Shift-I</td>
<td>Import media into Final Cut Pro</td>
</tr>
<tr>
<td>Import from Camera</td>
<td>Command-I</td>
<td>Open the Camera Import window</td>
</tr>
<tr>
<td>Move to Trash</td>
<td>Command-Delete</td>
<td>Move the selection to the Finder Trash</td>
</tr>
<tr>
<td>New Project</td>
<td>Command-N</td>
<td>Create a new project</td>
</tr>
<tr>
<td>Project Properties</td>
<td>Command-J</td>
<td>Open the Properties inspector for the current project</td>
</tr>
<tr>
<td>Render All</td>
<td>Shift-Control-R</td>
<td>Start all rendering tasks</td>
</tr>
<tr>
<td>Render Selection</td>
<td>Control-R</td>
<td>Start rendering tasks for the selection</td>
</tr>
<tr>
<td>Reveal in Finder</td>
<td>Command-Shift-R</td>
<td>Reveal the selected Event clip's source media file in the Finder</td>
</tr>
</tbody>
</table>
## Marking

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add Marker</td>
<td>M</td>
<td>Add a marker at the location of the skimmer or playhead</td>
</tr>
<tr>
<td>Add Marker and Modify</td>
<td>Option-M</td>
<td>Add a marker and edit the marker’s text</td>
</tr>
<tr>
<td>Apply Keyword Tag 1</td>
<td>Control-1</td>
<td>Apply keyword 1 to the selection</td>
</tr>
<tr>
<td>Apply Keyword Tag 2</td>
<td>Control-2</td>
<td>Apply keyword 2 to the selection</td>
</tr>
<tr>
<td>Apply Keyword Tag 3</td>
<td>Control-3</td>
<td>Apply keyword 3 to the selection</td>
</tr>
<tr>
<td>Apply Keyword Tag 4</td>
<td>Control-4</td>
<td>Apply keyword 4 to the selection</td>
</tr>
<tr>
<td>Apply Keyword Tag 5</td>
<td>Control-5</td>
<td>Apply keyword 5 to the selection</td>
</tr>
<tr>
<td>Apply Keyword Tag 6</td>
<td>Control-6</td>
<td>Apply keyword 6 to the selection</td>
</tr>
<tr>
<td>Apply Keyword Tag 7</td>
<td>Control-7</td>
<td>Apply keyword 7 to the selection</td>
</tr>
<tr>
<td>Apply Keyword Tag 8</td>
<td>Control-8</td>
<td>Apply keyword 8 to the selection</td>
</tr>
<tr>
<td>Apply Keyword Tag 9</td>
<td>Control-9</td>
<td>Apply keyword 9 to the selection</td>
</tr>
<tr>
<td>Clear Selection End</td>
<td>Option-O</td>
<td>Clear the selection’s end point</td>
</tr>
<tr>
<td>Clear Selection Start</td>
<td>Option-I</td>
<td>Clear the selection’s start point</td>
</tr>
<tr>
<td>Delete Marker</td>
<td>Control-M</td>
<td>Delete the selected marker</td>
</tr>
<tr>
<td>Delete Markers in Selection</td>
<td>Shift-Control-M</td>
<td>Delete all of the markers in the selection</td>
</tr>
<tr>
<td>Deselect All</td>
<td>Command-Shift-A</td>
<td>Deselect all selected items</td>
</tr>
<tr>
<td>Favorite</td>
<td>F</td>
<td>Rate the Event Browser selection as Favorite</td>
</tr>
<tr>
<td>New Keyword Collection</td>
<td>Command-Shift-K</td>
<td>Create a new Keyword Collection</td>
</tr>
<tr>
<td>Command</td>
<td>Shortcut</td>
<td>Action</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-----------------------</td>
<td>-------------------------------------------------------------</td>
</tr>
<tr>
<td>New Smart Collection</td>
<td>Command-Option-N</td>
<td>Create a new Smart Collection</td>
</tr>
<tr>
<td>Range Selection Tool</td>
<td>R</td>
<td>Make the Range Selection tool active</td>
</tr>
<tr>
<td>Remove All Keywords From</td>
<td>Control-0</td>
<td>Remove all keywords from the Event Browser selection</td>
</tr>
<tr>
<td>Selection</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Roles: Apply Dialogue Role</td>
<td>Option-Control-D</td>
<td>Apply the Dialogue role to the selected clip</td>
</tr>
<tr>
<td>Roles: Apply Effects Role</td>
<td>Option-Control-E</td>
<td>Apply the Effects role to the selected clip</td>
</tr>
<tr>
<td>Roles: Apply Music Role</td>
<td>Option-Control-M</td>
<td>Apply the Music role to the selected clip</td>
</tr>
<tr>
<td>Roles: Apply Titles Role</td>
<td>Option-Control-T</td>
<td>Apply the Titles role to the selected clip</td>
</tr>
<tr>
<td>Roles: Apply Video Role</td>
<td>Option-Control-V</td>
<td>Apply the Video role to the selected clip</td>
</tr>
<tr>
<td>Select All</td>
<td>Command-A</td>
<td>Select all clips</td>
</tr>
<tr>
<td>Select Clip Range</td>
<td>X</td>
<td>Set the range selection to match the boundaries of the clip below the skimmer or playhead</td>
</tr>
<tr>
<td>Set Selection End</td>
<td>O</td>
<td>Set the end point for the selection</td>
</tr>
<tr>
<td>Set Selection End</td>
<td>Control-O</td>
<td>Set the end point for the selection while editing a text field</td>
</tr>
<tr>
<td>Set Selection Start</td>
<td>I</td>
<td>Set the start point for the selection</td>
</tr>
<tr>
<td>Set Selection Start</td>
<td>Control-I</td>
<td>Set the start point for the selection while editing a text field</td>
</tr>
<tr>
<td>Unrate</td>
<td>U</td>
<td>Remove ratings from the selection</td>
</tr>
</tbody>
</table>
### Organization

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>New Event</td>
<td>Option-N</td>
<td>Create a new Event</td>
</tr>
<tr>
<td>New Folder</td>
<td>Command-Shift-N</td>
<td>Create a new folder</td>
</tr>
<tr>
<td>Reveal in Event Browser</td>
<td>Shift-F</td>
<td>Reveal the selected clip in the Event Browser</td>
</tr>
<tr>
<td>Synchronize Clips</td>
<td>Command-Option-G</td>
<td>Synchronize the selected Event clips</td>
</tr>
</tbody>
</table>

### Playback/Navigation

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Audio Skimming</td>
<td>Shift-S</td>
<td>Turn audio skimming on or off</td>
</tr>
<tr>
<td>Audition: Preview</td>
<td>Command-Control-Y</td>
<td>Play the pick in context in the Timeline</td>
</tr>
<tr>
<td>Cut/Switch Multicam Audio Only</td>
<td>Shift-Option-3</td>
<td>Turn on audio-only mode for multicam cutting and switching</td>
</tr>
<tr>
<td>Cut/Switch Multicam Audio and Video</td>
<td>Shift-Option-1</td>
<td>Turn on audio/video mode for multicam cutting and switching</td>
</tr>
<tr>
<td>Cut/Switch Multicam Video Only</td>
<td>Shift-Option-2</td>
<td>Turn on video-only mode for multicam cutting and switching</td>
</tr>
<tr>
<td>Down</td>
<td>Down Arrow</td>
<td>Go to the next item (in the Event Browser) or the next edit point (in the Timeline)</td>
</tr>
<tr>
<td>Down</td>
<td>Control-Down Arrow</td>
<td>While editing a text field, go to the next item (in the Event Browser) or the next edit point (in the Timeline)</td>
</tr>
<tr>
<td>Go Back 10 Frames</td>
<td>Shift-Left Arrow</td>
<td>Move the playhead back 10 frames</td>
</tr>
<tr>
<td>Go Forward 10 Frames</td>
<td>Shift-Right Arrow</td>
<td>Move the playhead forward 10 frames</td>
</tr>
<tr>
<td>Go to Beginning</td>
<td>Home button</td>
<td>Move the playhead to the beginning of the Timeline or the first clip in the Event Browser</td>
</tr>
<tr>
<td>Go to Next Edit</td>
<td>Apostrophe (')</td>
<td>Move the playhead to the next edit point in the Timeline</td>
</tr>
<tr>
<td>Go to Next Field</td>
<td>Option-Right Arrow</td>
<td>Move the playhead to the next field in an interlaced clip</td>
</tr>
<tr>
<td>Command</td>
<td>Shortcut</td>
<td>Action</td>
</tr>
<tr>
<td>-----------------------</td>
<td>-------------------</td>
<td>------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Go to Next Frame</td>
<td>Right Arrow</td>
<td>Move the playhead to the next frame</td>
</tr>
<tr>
<td>Go to Next Subframe</td>
<td>Command-Right Arrow</td>
<td>Move the playhead to the next subframe</td>
</tr>
<tr>
<td>Go to Previous Edit</td>
<td>Semicolon (;)</td>
<td>Move the playhead to the previous edit point in the Timeline</td>
</tr>
<tr>
<td>Go to Previous Field</td>
<td>Option-Left Arrow</td>
<td>Move the playhead to the previous field in an interlaced clip</td>
</tr>
<tr>
<td>Go to Previous Frame</td>
<td>Left Arrow</td>
<td>Move the playhead to the previous frame</td>
</tr>
<tr>
<td>Go to Previous Subframe</td>
<td>Command-Left Arrow</td>
<td>Move the playhead to the previous subframe</td>
</tr>
<tr>
<td>Go to Selection End</td>
<td>Shift-O</td>
<td>Move the playhead to the end of the range selection</td>
</tr>
<tr>
<td>Go to Selection Start</td>
<td>Shift-I</td>
<td>Move the playhead to the beginning of the range selection</td>
</tr>
<tr>
<td>Loop Playback</td>
<td>Command-L</td>
<td>Turn looped playback on or off</td>
</tr>
<tr>
<td>Monitor Audio</td>
<td>Shift-A</td>
<td>Turn on or turn off audio monitoring for the angle being skimmed</td>
</tr>
<tr>
<td>Negative Timecode Entry</td>
<td>Hyphen (-)</td>
<td>Enter a negative timecode value to move the playhead back, move a clip earlier, or trim a range or clip, depending on your selection</td>
</tr>
<tr>
<td>Next Clip</td>
<td>Command-Control-Right Arrow</td>
<td>Go to the next item (in the Event Browser) or the next edit point (in the Timeline)</td>
</tr>
<tr>
<td>Next Marker</td>
<td>Control-Apostrophe (')</td>
<td>Move the playhead to the next marker</td>
</tr>
<tr>
<td>Play Around</td>
<td>Shift-Question Mark (?)</td>
<td>Play around the playhead position</td>
</tr>
<tr>
<td>Play Forward</td>
<td>L</td>
<td>Play forward (press L multiple times to increase the playback speed)</td>
</tr>
<tr>
<td>Play Forward</td>
<td>Control-L</td>
<td>Play forward while editing a text field (press L multiple times to increase the playback speed)</td>
</tr>
<tr>
<td>Command</td>
<td>Shortcut</td>
<td>Action</td>
</tr>
<tr>
<td>--------------------------</td>
<td>---------------------------</td>
<td>------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Play from Playhead</td>
<td>Option-Space bar</td>
<td>Play from the playhead position</td>
</tr>
<tr>
<td>Play Full Screen</td>
<td>Command-Shift-F</td>
<td>Play full screen from the skimmer or playhead position</td>
</tr>
<tr>
<td>Play Reverse</td>
<td>J</td>
<td>Play in reverse (press J multiple times to increase the reverse playback speed)</td>
</tr>
<tr>
<td>Play Reverse</td>
<td>Control-J</td>
<td>Play in reverse while editing a text field (press J multiple times to increase the reverse playback speed)</td>
</tr>
<tr>
<td>Play Reverse</td>
<td>Shift-Space bar</td>
<td>Play in reverse</td>
</tr>
<tr>
<td>Play Selection</td>
<td>Slash (/)</td>
<td>Play the selection</td>
</tr>
<tr>
<td>Play to End</td>
<td>Shift-Control-O</td>
<td>Play from the playhead to the end of the selection</td>
</tr>
<tr>
<td>Play/Pause</td>
<td>Space bar</td>
<td>Start or pause playback</td>
</tr>
<tr>
<td>Play/Pause</td>
<td>Control-Space bar</td>
<td>Start or pause playback while editing a text field</td>
</tr>
<tr>
<td>Positive Timecode Entry</td>
<td>Equal Sign (=)</td>
<td>Enter a positive timecode value to move the playhead forward, move a clip later, or trim a range or clip, depending on your selection</td>
</tr>
<tr>
<td>Previous Clip</td>
<td>Command-Control-Left Arrow</td>
<td>Go to the previous item (in the Event Browser) or the previous edit point (in the Timeline)</td>
</tr>
<tr>
<td>Previous Marker</td>
<td>Control-Semicolon (;)</td>
<td>Move the playhead to the previous marker</td>
</tr>
<tr>
<td>Set Monitoring Angle</td>
<td>Shift-V</td>
<td>Set the angle being skimmed as the monitoring angle</td>
</tr>
<tr>
<td>Stop</td>
<td>K</td>
<td>Stop playback</td>
</tr>
<tr>
<td>Stop</td>
<td>Control-K</td>
<td>Stop playback while editing a text field</td>
</tr>
<tr>
<td>Timeline History Back</td>
<td>Command-Left Bracket ([])</td>
<td>Go back one level in the Timeline history</td>
</tr>
</tbody>
</table>
### Command Shortcuts and Gestures

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Timeline History Forward</td>
<td>Command-Right Bracket (])</td>
<td>Go forward one level in the Timeline history</td>
</tr>
<tr>
<td>Up</td>
<td>Up Arrow</td>
<td>Go to the previous item (in the Event Browser) or the previous edit point (in the Timeline)</td>
</tr>
<tr>
<td>Up</td>
<td>Control-Up Arrow</td>
<td>While editing a text field, go to the previous item (in the Event Browser) or the previous edit point (in the Timeline)</td>
</tr>
</tbody>
</table>

### Share and Tools

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Export Media</td>
<td>Command-E</td>
<td>Export the selected project as a media file</td>
</tr>
<tr>
<td>Select (Arrow) Tool</td>
<td>A</td>
<td>Make the Select tool active</td>
</tr>
<tr>
<td>Blade Tool</td>
<td>B</td>
<td>Make the Blade tool active</td>
</tr>
<tr>
<td>Crop Tool</td>
<td>Shift-C</td>
<td>Make the Crop tool active and display onscreen controls for the selected clip</td>
</tr>
<tr>
<td>Distort Tool</td>
<td>Command-Shift-D</td>
<td>Make the Distort tool active and display onscreen controls for the selected clip</td>
</tr>
<tr>
<td>Hand Tool</td>
<td>H</td>
<td>Make the Hand tool active</td>
</tr>
<tr>
<td>Position Tool</td>
<td>P</td>
<td>Make the Position tool active</td>
</tr>
<tr>
<td>Transform Tool</td>
<td>Shift-T</td>
<td>Make the Transform tool active and display onscreen controls for the selected clip</td>
</tr>
<tr>
<td>Trim Tool</td>
<td>T</td>
<td>Make the Trim tool active</td>
</tr>
<tr>
<td>Zoom Tool</td>
<td>Z</td>
<td>Make the Zoom tool active</td>
</tr>
</tbody>
</table>

### View

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Decrease Clip Height</td>
<td>Command-Shift-Hyphen (-)</td>
<td>Decrease the Event Browser clip height</td>
</tr>
<tr>
<td>Increase Clip Height</td>
<td>Command-Shift-Equal Sign (=)</td>
<td>Increase the Event Browser clip height</td>
</tr>
<tr>
<td>Show Fewer Filmstrip Frames</td>
<td>Command-Shift-Comma (,)</td>
<td>Show fewer filmstrip frames in Event Browser clips</td>
</tr>
<tr>
<td>Command</td>
<td>Shortcut</td>
<td>Action</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>---------------</td>
<td>-------------------------------------------------------------</td>
</tr>
<tr>
<td>Show/Hide Audio Animation</td>
<td>Control-A</td>
<td>Show or hide the Audio Animation Editor for the selected clips</td>
</tr>
<tr>
<td>Show/Hide Skimmer Info</td>
<td>Control-Y</td>
<td>Show or hide clip information when skimming in the Event Browser</td>
</tr>
<tr>
<td>Show/Hide Video Animation</td>
<td>Control-V</td>
<td>Show or hide the Video Animation Editor for the selected Timeline clips</td>
</tr>
<tr>
<td>Show More Filmstrip Frames</td>
<td>Command-Shift-Period (.)</td>
<td>Show more filmstrip frames in Event Browser clips</td>
</tr>
<tr>
<td>Show One Frame per Filmstrip</td>
<td>Command-Shift-Option-Comma (,)</td>
<td>Show one frame per filmstrip</td>
</tr>
<tr>
<td>View Clip Names</td>
<td>Shift-Option-N</td>
<td>Show or hide clip names in the Event Browser</td>
</tr>
<tr>
<td>View Event Browser as Filmstrip</td>
<td>Command-Option-1</td>
<td>Switch the Event Browser to filmstrip view</td>
</tr>
<tr>
<td>View Event Browser as List</td>
<td>Command-Option-2</td>
<td>Switch the Event Browser to list view</td>
</tr>
<tr>
<td>Zoom In</td>
<td>Command-Equal Sign (=)</td>
<td>Zoom in to the Timeline, Event Browser, or Viewer</td>
</tr>
<tr>
<td>Zoom Out</td>
<td>Command-Hyphen (-)</td>
<td>Zoom out of the Timeline, Event Browser, or Viewer</td>
</tr>
<tr>
<td>Zoom to Fit</td>
<td>Shift-Z</td>
<td>Zoom the contents to fit the size of the Event Browser, Viewer, or Timeline</td>
</tr>
<tr>
<td>Zoom to Samples</td>
<td>Control-Z</td>
<td>Turn zooming in to audio samples on or off</td>
</tr>
</tbody>
</table>

**Windows**

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Background Tasks</td>
<td>Command-9</td>
<td>Show or hide the Background Tasks window</td>
</tr>
<tr>
<td>Go to Audio Enhancements</td>
<td>Command-8</td>
<td>Make the Audio Enhancements inspector active</td>
</tr>
<tr>
<td>Go to Color Board</td>
<td>Command-6</td>
<td>Make the Color Board active</td>
</tr>
<tr>
<td>Command</td>
<td>Shortcut</td>
<td>Action</td>
</tr>
<tr>
<td>--------------------------</td>
<td>------------------</td>
<td>----------------------------------------------------------</td>
</tr>
<tr>
<td>Go to Event Browser</td>
<td>Command-1</td>
<td>Make the Event Browser active</td>
</tr>
<tr>
<td>Go to Inspector</td>
<td>Command-Option-4</td>
<td>Make the current inspector active</td>
</tr>
<tr>
<td>Go to Timeline</td>
<td>Command-2</td>
<td>Make the Timeline active</td>
</tr>
<tr>
<td>Go to Viewer</td>
<td>Command-3</td>
<td>Make the Viewer active</td>
</tr>
<tr>
<td>Next Tab</td>
<td>Control-Tab</td>
<td>Go to the next pane in the Inspector or the Color Board</td>
</tr>
<tr>
<td>Previous Tab</td>
<td>Shift-Control-Tab</td>
<td>Go to the previous pane in the Inspector or the Color Board</td>
</tr>
<tr>
<td>Show Histogram</td>
<td>Command-Option-H</td>
<td>Show the Histogram in the Viewer</td>
</tr>
<tr>
<td>Show Vectorscope</td>
<td>Command-Option-V</td>
<td>Show the Vectorscope in the Viewer</td>
</tr>
<tr>
<td>Show Video Waveform</td>
<td>Command-Option-W</td>
<td>Show the Waveform Monitor in the Viewer</td>
</tr>
<tr>
<td>Show/Hide Angle Viewer</td>
<td>Command-Shift-7</td>
<td>Show or hide the Angle Viewer</td>
</tr>
<tr>
<td>Show/Hide Audio Meters</td>
<td>Command-Shift-8</td>
<td>Show or hide the Audio meters</td>
</tr>
<tr>
<td>Show/Hide Effects Browser</td>
<td>Command-5</td>
<td>Show or hide the Effects Browser</td>
</tr>
<tr>
<td>Show/Hide Event Library</td>
<td>Command-Shift-1</td>
<td>Show or hide the Event Library</td>
</tr>
<tr>
<td>Show/Hide Inspector</td>
<td>Command-4</td>
<td>Show or hide the Inspector pane</td>
</tr>
<tr>
<td>Show/Hide Keyword Editor</td>
<td>Command-K</td>
<td>Show or hide the Keyword Editor</td>
</tr>
<tr>
<td>Show/Hide Project Library</td>
<td>Command-0</td>
<td>Show or hide the Project Library</td>
</tr>
<tr>
<td>Show/Hide Timeline Index</td>
<td>Command-Shift-2</td>
<td>Show or hide the Timeline Index for the open project</td>
</tr>
<tr>
<td>Show/Hide Video Scopes</td>
<td>Command-7</td>
<td>Show or hide the video scopes in the Viewer</td>
</tr>
</tbody>
</table>
Multi-Touch gestures
If your computer has a Multi-Touch trackpad, you can use the Multi-Touch gestures listed in the table below when working with Final Cut Pro.

For more information about Multi-Touch gestures, see the documentation that came with your computer.

<table>
<thead>
<tr>
<th>Gesture</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scroll (two-finger)</td>
<td>Moves the Timeline left or right.</td>
</tr>
<tr>
<td>Scroll (three-finger)</td>
<td>Swipe up to move the playhead to the beginning of the Timeline. Swipe down to move the playhead to the end of the Timeline. Swipe left or right to move the playhead left or right.</td>
</tr>
</tbody>
</table>

Customize keyboard shortcuts

**View keyboard shortcuts in the Command Editor**
Final Cut Pro provides a wide variety of menu commands and keyboard shortcuts that let you control almost every aspect of your project, from playback to displaying windows and inspectors to working with tools. You can use the Command Editor to modify existing shortcuts, create new shortcuts, and save multiple sets of keyboard shortcuts that you can export for others to use. You can also import a set of shortcuts that someone else created. And if you’re more familiar with keyboard shortcuts from other applications, you can use the Command Editor to substitute those shortcuts in place of the default set for Final Cut Pro.

The Command Editor provides a set of keyboard shortcuts for Final Cut Pro in English, Japanese, French, and German. The language that is shown is determined by your computer’s operating system. To learn how to change the language used by Final Cut Pro, see Mac OS X Help.
View keyboard shortcuts

1 Choose Final Cut Pro > Commands > Customize (or press Command-Option-K).

The Command Editor appears.

2 To find keyboard shortcuts in the Command Editor, do any of the following:
   - Click one or more keys on the virtual keyboard (or click one of the four modifier buttons at the top of the Command Editor).

The Command groups associated with the selected key or keys appear in the bottom-left corner of the window, and a list of all the keyboard shortcuts associated with the key you selected appears in the bottom-right corner of the window.
When you hold down any modifier buttons on the keyboard, the key colors update. Key colors correspond with command classifications; for example, playback commands, such as Play/Pause (Space bar), are blue. The Command Groups window on the left side of the Command List contains a clickable color key for reference.

- Enter a command name, description keywords, or a key name in the search field at the top-right corner of the window.

The commands that match the search term are listed in the Command List at the bottom of the window.

**Tip:** To show the keys that correspond with the items in the Command List, click the Keyboard Highlight button to the left of the search field.

Click any command in the list to view its details in the Command Detail area in the bottom-right corner of the window.

- Click a Command group to quickly filter the Command List to display only the commands and keyboard shortcuts in that group.
Click any command in the list to view its details in the Command Detail area in the bottom-right corner of the window.

View shortcuts from a different command set
If your system has multiple command sets, you can easily switch between them. For more information, see “Export and import command sets in the Command Editor” on page 531.

Do one of the following:

- Choose Final Cut Pro > Commands, and then choose a command set from the submenu.

  The Command Editor window appears, showing the command set you chose.

- If you’ve already opened the Command Editor, choose a command set from the pop-up menu at the top-left corner of the window.
Modify keyboard shortcuts in the Command Editor
You can quickly and easily customize keyboard shortcuts in the Command Editor. If you want to add a few custom commands to the default set in Final Cut Pro, you can duplicate the default set and assign keyboard shortcuts to some of the unassigned commands. You can also create a new set that contains only your commands.

Duplicate a command set
2. If the command set that you want to duplicate is not shown, choose a different command set from the pop-up menu in the top-left corner of the Command Editor.
3. Choose Duplicate from the pop-up menu.
4. In the window that appears, type a name for the command set, and click OK.

   The duplicate set is added to the Command submenu of the Final Cut Pro menu and to the pop-up menu in the Command Editor.

Modify a command set
You can add keyboard shortcuts to a command set or reassign keyboard shortcuts.
2. If the command set that you want to modify is not shown, select a different command set from the pop-up menu at the top of the Command Editor.
3. Select the command to which you want to assign a new keyboard shortcut by doing one of the following:
   - Type a command name in the search field at the top-right corner of the Command Editor window.
   - Browse the command list to find the command you want.
4. Press the combination of keys you want to use for the command (for example, Shift-Option-T, or any other keys).

   **Note:** Keys on the Command Editor virtual keyboard that are shaded with diagonal lines are reserved for system use and cannot be assigned.

   If the key combination is not already assigned to a command, the virtual keyboard updates to show the new key assignment. A gray dot appears on a newly assigned key (or keys), and a color is applied if the command belongs to a color-coded Command group.

   If the key combination is already assigned to a command, Final Cut Pro displays the current setting, and prompts you to confirm the change.

5. To save your changes to the command set, click the Save button in the lower-right corner of the Command Editor.
If you close the Command Editor with unsaved changes, Final Cut Pro prompts you to save your changes.

**Delete a command set**

2. If the command set that you want to delete is not shown, select a different command set from the pop-up menu at the top of the Command Editor.
3. Choose Delete from the pop-up menu in the top-left corner of the Command Editor.
4. In the window that appears, click Delete.

The command set is removed.

**Export and import command sets in the Command Editor**

After you save a command set, you may want to export it to create a backup or to share the new set with another user. Exported command sets are saved in a file that can be imported back into Final Cut Pro at a later time.

**Export a set of custom keyboard shortcuts**

2. If the command set that you want to export is not shown, select a different command set from the pop-up menu at the top of the Command Editor.
3. Do one of the following:
   - Choose Final Cut Pro > Commands > Export.
   - Choose Export from the pop-up menu in the top-left corner of the Command Editor.
4. Type a name for the exported command set in the Save As field, and navigate to the location where you want to save the exported set and click Save.

The file is saved in the location you chose, with the filename extension .commandset.

**Import a command set**

1. Do one of the following:
   - Choose Final Cut Pro > Commands > Import.
   - Open the Command Editor by choosing Final Cut Pro > Commands > Customize, and choose Import from the pop-up menu in the upper-left corner of the Command Editor.
2. In the window that appears, navigate to the location where you’ve stored a command set file, select it, and click Open.

If you’re already using a command set with the same name, a window appears and prompts you to rename the command set.

The new command set is added to the Commands submenu of the Final Cut Pro menu and to the pop-up menu in the Command Editor.
4:3 The aspect ratio for standard-definition (SD) broadcast video. The ratio of the width to the height of the visible area of the video frame is 4:3, or 1.33. See also standard-definition (SD).

16:9 A widescreen aspect ratio for video. The ratio of the width to the height of the visible area of the video frame is 16:9, or 1.78. The 16:9 aspect ratio is used for high-definition video. See also high-definition (HD).

AAC (Advanced Audio Coding) Also called MPEG-4 Audio. A standard way of compressing and encoding digital audio. AAC-encoded files rival the quality of audio CDs and generally sound as good as or better than MP3 files encoded at the same or even a higher bit rate.

AC3 (Audio Codec 3, Advanced Codec 3, Acoustic Coder 3) A Dolby Digital compressed audio format often used for encoding surround sound.

AIFF (Audio Interchange File Format) A cross-platform audio file format developed by Apple. Like WAV files, AIFF files contain “chunks” of information such as the Sound Data Chunk, which contains the actual sample data, and the Common Chunk, which contains sample rate and bit depth information.

alpha channel An image channel in addition to the R, G, and B color channels that is used to store transparency information for compositing. Alpha channels are often 8-bit, but some applications support 16-bit alpha channels. In Final Cut Pro, black represents 100 percent transparency, and white represents 100 percent opacity. Only certain formats, such as Targa, TIFF, PNG, PSD, Apple ProRes 4444, and the QuickTime Animation codec, support alpha channels. See also compositing, RGB.

Angle Editor You can open multicam clips in the Angle Editor to adjust the synchronization and the angle order, or to add or delete angles. You can also use the Angle Editor to make edits to the individual clips inside a multicam clip (such as trimming, making color corrections, adding transitions, and so on). See also multicam clip.
**Angle Viewer** A viewer used to watch all angles of a multicam clip simultaneously while switching or cutting to different angles in real time. You can cut and switch video and audio at the same time or independently. For example, you can use the audio from angle 1 while switching the video between angles 1 to 4. See also *multicam clip*.

**Apple ProRes** The Apple ProRes codecs provide an unparalleled combination of multistream, real-time editing performance coupled with impressive image quality at reduced storage rates. In particular, the Apple ProRes codecs have been designed to work especially well as high-quality, high-performance editing codecs for Final Cut Pro, taking full advantage of multcore processing and featuring fast, reduced-resolution decoding modes. All members of the Apple ProRes codec family support any frame size (including SD, HD, 2K, and 4K) at full resolution. The data rate of Apple ProRes varies based on codec type, image content, frame size, and frame rate.

**Apple ProRes 4444** This Apple ProRes codec offers the best quality for 4:4:4:4 sources and for workflows involving alpha channels. It features full-resolution, mastering-quality 4:4:4:4 RGBA color, perceptually indistinguishable from the original material with excellent multigeneration performance. It also features a mathematically lossless alpha channel (up to 16 bits) with real-time playback, a high-quality solution for storing and exchanging motion graphics and composites, and direct encoding of, and decoding to, both RGB and Y'CbCr pixel formats. This codec has a remarkably low data rate compared to uncompressed 4:4:4 HD (the target data rate is approximately 330 Mbps for 4:4:4 sources at 1920 x 1080 and 29.97 fps). See also *Apple ProRes*.

**Apple ProRes 422 (HQ)** This Apple ProRes codec preserves visual quality at the same high level as Apple ProRes 4444, but for 4:2:2 image sources. With widespread adoption across the video post-production industry, Apple ProRes 422 (HQ) offers visually lossless preservation of the highest-quality professional HD video that a (single-link) HD-SDI signal can carry. This codec supports full-width, 4:2:2 video sources at 10-bit pixel depths, while remaining visually lossless through many generations of decoding and reencoding. The target data rate of Apple ProRes 422 (HQ) is approximately 220 Mbps at 1920 x 1080 and 29.97 fps. See also *Apple ProRes*.

**Apple ProRes 422** This Apple ProRes codec offers nearly all the benefits of Apple ProRes 422 (HQ), but at 66 percent of the data rate for even better multistream, real-time editing performance. See also *Apple ProRes*.

**Apple ProRes 422 (LT)** With a target data rate that is roughly 70 percent of the data rate of Apple ProRes 422 and 30 percent smaller file sizes than Apple ProRes 422, this Apple ProRes codec is perfect for environments where storage capacity and bandwidth are at a premium. See also *Apple ProRes*.

**Apple ProRes 422 (Proxy)** This Apple ProRes codec is intended for use in offline workflows that require low data rates but full-resolution video. The target data rate is roughly 30 percent of the data rate of Apple ProRes 422. See also *Apple ProRes*.
aspect ratio  A film or video frame's width-to-height ratio on any viewing screen. Standard-definition (SD) video (used for regular television screens) has an aspect ratio of 4:3. High-definition (HD) video has an aspect ratio of 16:9.

Audio Animation Editor  You can show the Audio Animation Editor for clips in the Timeline to adjust effect parameters, create fade-ins or fade-outs, or change effects over time using keyframes.

audio sample rate  The number of times an audio signal is measured, or sampled, per second. A higher sample rate produces higher-quality audio and larger file sizes, and a lower sample rate produces lower-quality audio and smaller file sizes.

Audio Units  The standard real-time audio filter format for audio applications used with Mac OS X.

audio waveforms  Audio waveforms are visual representations of the actual sound. An audio waveform’s amplitude and length change according to the underlying sound’s volume and duration. A short, loud sound such as a drum beat has a sharp, peaked waveform, whereas low-level crowd noise has a lower, more uniform waveform. These properties make it easier to find specific edit points when trimming clips or keyframing effects.

audition  In Final Cut Pro you can organize related clips into sets, called auditions, from which you can choose one clip to use. You can create an audition composed of different clips to try out multiple takes, or you can create an audition composed of multiple versions of the same clip to preview different effects. Auditions appear in the Event Browser and Timeline as clips with an Audition icon in the upper-left corner.

AVCHD  A high-definition (HD) video format that uses Advanced Video Coding (AVC) compression (also known as MPEG-4 part 10 or H.264). Many Blu-ray players can play red laser discs with AVCHD format content, making this a common way to distribute short HD video projects using a standard red laser disc.

Background Tasks window  The Background Tasks window shows the progress of importing, transcoding, analysis, rendering, and other tasks.

batch  Compressor uses a batch to contain one or more source media files that you want to convert, or transcode, to another format. Each source media file creates its own job. This means that a batch can contain multiple jobs, with each job based on its own source media file. Each job also has at least one setting that defines the format of the transcoded file.

bit rate  The number of bits per second that makes up a digital video or audio asset. The higher the bit rate, the better the quality. However, higher bit rates require larger file sizes.
Blade tool  The editing tool that allows you to cut clips in the Timeline. You can select the Blade tool by pressing the B key.

blue laser media  Blu-ray burners and players use a blue laser when working with Blu-ray media. The blue color has a shorter wavelength, making it possible to store more data on a disc when compared to red lasers.

blue or green screening  See chroma key.

broadcast-safe  Broadcast facilities have limits on the maximum values of luma and chroma that are allowable for broadcast. If a video exceeds these limits, distortion can appear, resulting in unacceptable transmission quality. You can use the Final Cut Pro video scopes to make sure that the luma and chroma levels you set stay within acceptable limits.

B-roll  A term used to describe alternate footage shot to intercut with the primary shots used in a program. B-roll is frequently used for cutaway shots.

BWF (Broadcast Wave Format)  An extension of the WAV file format that includes additional metadata such as timecode and production information.

CAF (Core Audio Format)  Apple’s Core Audio Format (CAF) is a flexible file format for storing and manipulating digital audio data. It is fully supported by Core Audio APIs on Mac OS X v10.4 and later and on Mac OS X v10.3 with QuickTime 7 or later. CAF provides high performance and flexibility, and is scalable to future ultra high-resolution audio recording, editing, and playback.

chroma  The color information contained in a video signal, consisting of hue, which represents the color itself, and saturation, which represents the intensity of the color.

chroma key  A special effects technique that allows you to derive an alpha channel or matte from the blue or green background of a video clip in order to make it transparent for the purpose of compositing it against other clips. Blue-screen technology is what makes weather forecasters appear to be standing against an animated map, when in reality they’re standing in front of a blue wall. Also known as blue or green screening. See also alpha channel.

clip  The term used to describe a video or audio asset, especially after it has been imported into Final Cut Pro. Clips appear in the Event Browser, the Timeline, and the media browsers. Clips in Final Cut Pro point to (link to) source media files stored on a disk. When you modify a clip, you are not modifying the media file, just the clip’s information in Final Cut Pro. (This is known as nondestructive editing.)

clipping  Distortion occurring during the playback or recording of digital audio because of a signal that exceeds the maximum sample value of 0 dBFS.
**clip selection**  A selection of whole clips in the Event Browser or the Timeline. In contrast to a range selection, a clip selection is limited to clip boundaries and does not have range handles. You cannot adjust a clip selection to include portions of clips. However, you can add or remove whole clips.

**codec**  Short for *compressor/decompressor*, or *encode/decode*. A software component used to translate video or audio from its analog uncompressed form to the digital compressed form in which it is stored on a computer’s hard disk. DV, Photo JPEG, and Apple ProRes are common QuickTime video codecs.

**color balance**  Refers to the mix of red, green, and blue in a clip. In Final Cut Pro, you can adjust the color balance of the highlights (bright areas), midtones, or shadows (dark areas) of your clip using the Color Board.

**color bars**  A standard color test signal displayed as columns, often accompanied by a reference audio tone. Color bars are used to adjust the video signal of the incoming source to maintain proper color from import through output.

**Color Board**  The Color Board allows you to manually adjust a clip’s color properties. It contains separate panes for adding or subtracting a color tint, controlling the intensity of the color, and controlling the brightness of the video. In addition to an overall control, each pane has individual controls for the highlight, midtone, and shadow areas of the image.

**color cast**  An unwanted color tint in the image, usually caused by lighting issues.

**color correction**  A process in which the color of clips used in an edited program is evened out so that all shots in a given scene match. Color correction is generally one of the last steps in finishing an edited program. The color correction tools in Final Cut Pro give you precise control over the look of every clip in your project by allowing you to adjust the color balance, black levels, midtones, and white levels of individual clips.

**color difference**  In video formats that store color information in the Y’CbCr color space, color channels are derived by subtracting Y (luma) from the R (red) and B (blue) signals and are sometimes referred to generally as $B-Y$ and $R-Y$. See also $Y'CbCr$.

**compositing**  A process in which two or more images are combined into a single frame. This term can also describe the process of creating various video effects.
compound clip You can use compound clips to group any combination of clips in the Timeline or the Event Browser, and nest clips within other clips. You can open any compound clip, edit its contents in the Timeline, and then close it. Compound clips can contain video and audio clip components, clips, and other compound clips. Effectively, each compound clip can be considered a mini project, with its own distinct project settings. Compound clips function just like other clips: you can add them to your project, trim them, retime them, and add effects and transitions.

compression The process by which video, graphics, and audio files are reduced in size. “Lossy” compression refers to a process of reducing video file sizes through the removal of redundant or less noticeable image data. Lossless compression reduces file sizes by mathematically consolidating redundant image data without discarding it.

connected clip Connected clips are attached to clips in the primary storyline in the Timeline. They are useful for cutaway shots, superimposed or composited images, and sound effects. Connected clips remain attached and synchronized until you explicitly move or remove them. A sequence of connected clips is a storyline.

contrast The difference between the lightest and darkest values in an image. High-contrast images have a large range of values from the darkest shadow to the lightest highlight. Low-contrast images have a more narrow range of values, resulting in a “flatter” look.

cross dissolve A common type of video transition, in which the first shot fades out while the second shot simultaneously fades in. During the cross dissolve, the two shots are superimposed as they fade.

crossfade A common type of audio transition, in which the first shot’s audio fades down while the second shot’s audio simultaneously fades up. During the crossfade, audio from both shots is heard.

cut An edit in which one clip immediately follows another, with no transition effect. This is the simplest type of edit.

cutaway shot A shot that is related to the current subject and occurs in the same time frame (for example, an interviewer’s reaction to what is being said in an interview). Often, a cutaway shot is used to eliminate an unwanted visual section of another shot. The audio usually remains continuous during the cutaway, helping to make the edit less noticeable.

Dashboard The Dashboard appears in the center of the toolbar and provides a timecode display as well as icons showing audio levels and the status of background tasks.
**data rate** The speed at which data can be transferred, often described in megabytes per second (MB/sec.) or megabits per second (Mbps). The higher a video file’s data rate, the higher quality it is, but the more system resources (processor speed, hard disk space, and performance) it requires. Some codecs allow you to specify a maximum data rate for a movie during capture.

**decibel (dB)** Unit of measurement for sound levels; a logarithmic scale used to describe the loudness of sound as perceived by the human ear. (1 dB corresponds to approximately the smallest volume change that the average human ear can perceive.) For digital audio, dBFS is the standard decibel unit of sound level measurement.

**Disk Utility** Disk Utility is an Apple program that performs disk-related tasks in Mac OS X. It’s located in the Utilities folder inside the Applications folder. For more information, see Mac Help.

**distributed processing** Using Compressor, you can configure one or more computers to perform a portion of the render processing when sharing your project. Depending on your network and the nature of your project, distributed processing can greatly speed up the processing.

**downmixing** The process used to combine multiple audio channels into a single stereo (or dual mono) pair. Also referred to as *mixing down*.

**drop frame timecode** NTSC timecode that skips ahead in time by two frame numbers each minute, except every tenth minute, so that the timecode agrees with the actual elapsed clock time. (Timecode numbers are skipped, but actual video frames are not skipped.) This skipping corrects for NTSC’s actual frame rate of 29.97 fps, which causes non-drop frame timecode to lag behind actual elapsed time by 3 seconds and 18 frames per hour. To avoid confusion, drop frame timecode should be avoided in film-based productions. See also *non-drop frame timecode*.

**drop shadow** An effect that creates an artificial shadow behind an image. Typically used with graphics and text.

**DV** A standard-definition (SD) digital videotape recorder format that records an 8-bit, 5:1 compressed component video signal with 4:1:1 color sampling (PAL uses 4:2:0). Supports two tracks of audio with 16-bit, 48 kHz audio sampling, or four tracks of audio with 12-bit, 32 kHz audio sampling.

**DVCAM** A standard-definition (SD) digital videotape recorder format that records an 8-bit, 5:1 compressed component video signal with 4:1:1 color sampling (PAL uses 4:2:0). Supports two tracks of audio with 16-bit, 48 kHz audio sampling, or four tracks of audio with 12-bit, 32 kHz audio sampling.
DVCPRO  A standard-definition (SD) digital videotape recorder format that records an 8-bit, 5:1 compressed component video signal using 4:1:1 color sampling (PAL uses 4:2:0). Supports two tracks of audio with 16-bit, 48 kHz audio sampling.

DVCPRO 50  A standard-definition (SD) digital videotape recorder format that records an 8-bit, 3.3:1 compressed component video signal with 4:2:2 color sampling. Supports four tracks of audio with 16-bit, 48 kHz audio sampling.

DVCPRO HD  A high-definition (HD) video format that records an 8-bit, compressed component video signal with 4:2:2 color sampling. Both 720p and 1080i are supported. Includes up to eight tracks of audio with 16-bit, 48 kHz audio sampling. The total data rate is 115 Mbps.

DVD  A disc that is the size of a CD but that uses higher-density storage methods to significantly increase its capacity. Although usually used for video distribution, DVD-ROM discs can also be used to store computer data.

dynamic range  The difference, in decibels, between the loudest and softest parts of a recording.

edit point  Edit points define the part of a clip you want to use in an edited project. Edit points include start points, which specify the beginning of a section of a clip or project, and end points, which specify the end of a section of a clip or project. An edit point is also a point in the Timeline where the end point of one clip meets the start point of the next clip. This edit point can be selected for various operations.

Effects Browser  A media browser in Final Cut Pro that contains video and audio clip effects.

equalization  An equalizer (commonly abbreviated as EQ) shapes the sound of incoming audio by changing the level of specific frequency bands. Equalization is one of the most commonly used audio processes, both for music projects and in video post-production work. You can use EQ to subtly or significantly shape the sound of an audio file, instrument, or project by adjusting specific frequencies or frequency ranges.

Event  When you import video, audio, and still images, or record directly into Final Cut Pro, the source media files (your raw footage) are stored in Events. An Event is similar to a folder that can hold dozens, hundreds, or even thousands of video clips, audio clips, and still images. Each Event in the Event Library refers to a folder on your hard disk that contains the original source media files, any render files related to your media, and a database file that keeps track of where everything is.
**Event Browser**  The Event Browser displays the clips for the item selected in the Event Library. You select clips or portions of clips in the Event Browser to work with them. You can sort clips in the Event Browser by creation date, as well as by date imported, reel, scene, clip duration, and file type. You can also view your clips as filmstrips or in a list.

**Event Library**  The Event Library holds and organizes the Events that contain your imported media (video, audio, and still images). When you select an Event in the Event Library, the media it contains appears as clips in the Event Browser. The Event Library is also the home for Final Cut Pro Keyword Collections and Smart Collections, which provide a powerful way to organize your media using keywords and persistent search filters.

**exposure**  The amount of light in video or film images. Exposure affects the overall brightness of the image as well as its perceived contrast.

**fade**  A common type of transition in both video and audio. For video, a fade-out begins with a shot at full intensity and reduces until it is gone. A fade-in begins with a shot at no intensity and increases to full intensity. These are the common “fade to black” and “fade up (from black)” transitions. Audio fade-ins begin with silence and increase to full volume, and fade-outs begin at full volume and decrease to silence.

**filmstrip**  Your video clips appear as filmstrips in the Timeline (where you build projects) and in the Event Browser (where your source media is displayed). A single video filmstrip might represent several seconds of video encompassing hundreds of video frames (individual images). Audio-only clips appear as audio waveforms, showing the change in the audio volume over time.

**FireWire**  The trademarked Apple name for the IEEE 1394 standard. A fast and versatile interface used to connect DV camcorders to computers. FireWire is well suited to applications that move large amounts of data, and it can also be used to connect hard disks, scanners, and other kinds of computer peripherals.

**Foley effects**  Foley effects are custom sound effects that are heavily synchronized to picture, such as footsteps on different surfaces, clothes rustling, fight sounds, and the handling of various noisy objects. Final Cut Pro includes a number of built-in Foley and other sound effects that you can insert as connected audio clips.

**frame**  A single still image. Film and video are made up of a series of these images. Although a film frame is a single photographic image, an interlaced video frame contains two fields. See also *interlaced video*, *non-interlaced video*.

**frame blending**  Duplicating frames to create slow motion can result in a strobing, jittery effect. To minimize this, you can turn on Frame Blending in the Retime pop-up menu in the toolbar. Frame blending creates new in-between frames, each a composite of two neighboring frames.
frame rate  The number of images photographed per second for a video clip.

frame size  See resolution.

frequency  The number of times a sound or signal vibrates each second, measured in cycles per second, or hertz (Hz). Audio recordings are made up of a vast collection of waveforms, using many different frequencies of sound. Each frequency in a recording is associated with an audio pitch. For example, the note generated by each key of a piano has a specific frequency.

Front Row  Front Row, a program that comes with Mac OS X, is a way to navigate through your iTunes, iLife, and Final Cut Pro media using an Apple remote control or the Remote app. You can also open Front Row by pressing Command-Escape.

gain  The amount an audio or video signal is boosted. In video, this increases the white level; in audio, this increases the volume.

gamma  A curve that describes the intensity of an image. Gamma is a nonlinear function often confused with brightness or contrast. Gamma adjustment is often used to compensate for differences between Mac and Windows video graphics cards and displays.

gap clip  A blank clip (containing blank video and silent audio) that you can adjust to any duration. (The film industry term for this is slug.) Gap clip color is determined by the current background color in Final Cut Pro. You can adjust the background color using the Player Background pop-up menu in the Playback pane of the Final Cut Pro Preferences window.

generators  Clips that are synthesized by Final Cut Pro. Generators can be used as different kinds of backgrounds, titles, and elements for visual design.

Generators Browser  A media browser in Final Cut Pro that provides access to all video generators included with Final Cut Pro.

Hand tool  The editing tool that allows you to scroll in the Timeline. You can select the Hand tool by pressing the H key.

H.264  H.264/MPEG-4 Part 10 or AVC (Advanced Video Coding) is a video compression standard in widespread use for recording, distribution, and Internet streaming of high-definition video.

HDCAM  A high-definition (HD) digital videotape recorder format that records an 8-bit, 7:1:1 DCT-compressed component video signal with 3:1:1 color sampling. Recorded using 1/2-inch tape. Supports four tracks of audio.
**HDV** A format for recording high-definition video on DV tape. HDV uses MPEG-2 video compression with 8-bit samples and 4:2:0 chroma subsampling. HDV has a video bit rate of 18.3 Mbps for 720p (1280 x 720) and a bit rate of 25 Mbps for 1080i (1440 x 1080).

**high-definition (HD)** Refers to any video with a higher resolution than standard-definition NTSC or PAL video. The most common high-definition resolutions are 1280 x 720 (720p) and 1920 x 1080 (1080i or 1080p). See also *NTSC format*, *PAL format*, *standard-definition (SD)*.

**Histogram** A video scope in Final Cut Pro that provides a statistical analysis of the image by graphing the number of pixels at each percentage of luma or color. It’s useful for comparing two clips in order to match their brightness values more closely.

**hue** An attribute of color perception, also known as *color phase*. Red, blue, yellow, and green are all hues.

**import** The process of bringing media files of various types into Events in Final Cut Pro. You can import files from connected camcorders and other devices, other applications, or connected storage devices.

**IMX** A standard-definition (SD), all-I-frame MPEG-2 format stored on tape, XDCAM optical disc, or disk drive. Some IMX decks can play back and convert formats such as Digital Betacam, Betacam SX, and Betacam SP to IMX. The data rate of IMX can be set to 30, 40, or 50 Mbps.

**incoming clip** The clip to which a transition segues. For example, if Clip A dissolves to Clip B, Clip B is the incoming clip. See also *outgoing clip*.

**Info inspector** The Info inspector displays information (called *metadata*) about a clip or group of clips selected in either the Event Browser or the Timeline. You can display different combinations of metadata with your clips, such as codecs, media start and end times, reel, scene, take, EXIF information, and IPTC information. You can also use the Info inspector to change the metadata for a selected clip or group of clips, and you can create custom sets of metadata for display using the Metadata Views window, accessed from the Info inspector.

**In point** See *edit point*.

**insert edit** An insert edit places the source clip so that all clips after the insertion point are moved forward (or rippled) in the Timeline to make room for the clip being added. No clips are removed from your project. An insert edit makes the project longer by the duration of the inserted clip.
**inspectors**  Final Cut Pro provides a number of inspectors you can use to view and change the attributes of selected items. For example, you can adjust video effects and apply color corrections in the Video inspector. Other inspectors include the Audio, Audio Enhancements, Info, Transition, Title, Text, Generator, and Sharing inspectors. The inspectors appear in the Inspector pane in the upper-right corner of the Final Cut Pro main window.

**interlaced video**  A scanning method that divides a video frame into two fields, each consisting of alternating odd and even lines that are scanned at different times.

**IRE**  An analog video signal unit of measurement for luma, established by the Institute of Radio Engineers.

**J-cut**  See *split edit*.

**job**  Each media file added to a batch in Compressor is a job. Each job has one media file and one or more settings that define the type of file to render. See also *batch*.

**JPEG**  A popular image file format that lets you create highly compressed graphics files. The amount of compression used can be varied. Less compression results in a higher-quality image.

**keyframe**  A control that denotes the value of a video or audio effect parameter at a particular point in the project. When two keyframes with different values are set in Final Cut Pro, a transition from one value to another is calculated, resulting in a dynamic change to that parameter. The word *keyframe* comes from the traditional workflow in the animation industry, where only important (key) frames of an animated sequence were drawn to sketch a character's motion over time. Once the keyframes were determined, an in-between artist drew all the frames between the keyframes.

**keying**  See *chroma key, luma key*.

**Keyword Collection**  When you apply a keyword to a clip, a Keyword Collection is automatically created in the Event Library. When you select the Keyword Collection, each clip tagged with that keyword is displayed. Final Cut Pro can also create Keyword Collections from keywords added during clip analysis.

**keywords**  Keywords add descriptive information to a clip or a section of a clip. You can use keywords to organize, sort, and classify media. You can add keywords to a clip manually, and Final Cut Pro can also add keywords automatically during clip analysis. Keyword Collections make it easy to view all the clips with a particular keyword.

**L-cut**  See *split edit*. 
linear editing  Before digital video editing, programs were edited together by copying shots from the original source tapes to a master tape, one by one. Because the assembly was linear, any changes in duration made to an earlier point of the tape required reassembling the movie from that point forward. See also nonlinear editing.

looping  A playback mode in which clips and projects go back to the beginning whenever the playhead reaches the end of the media. You can turn looping on or off by clicking the Loop Playback button below the Viewer.

lower third  A television industry term for a graphic placed in the lower area of the screen, usually to convey details about subjects or products. A common use of lower thirds is to identify individuals on the screen with their names and job titles.

luma  A value describing the brightness of a video image. A luma channel is a grayscale image showing the range of brightness across the whole clip.

luma key  An effect used to key out pixels of a certain luma value (or a range of luma values), creating a matte based on the brightest or darkest area of an image. Keying out luma values works best when your clip has a large discrepancy in exposure between the areas that you want to key out and the foreground images you want to preserve, such as a white title on a black background. See also chroma key, matte.

Mail  Mail is the email program that comes with Mac OS X.

markers  Markers flag a specific location in a clip with editing notes or other descriptive information. You can also use markers for task management. Markers are classified as standard informational markers (blue), to-do items (red), and completed to-do items (green).

mask  An image or clip used to define areas of transparency in another clip. Similar to an alpha channel. The color correction tools can create masks based on a color you choose or a shape you create. See also alpha channel.

matte  Sometimes referred to as a holdout matte. An effect that uses information in one layer of video to affect another layer. Mattes are useful when you want to use one clip to selectively hide or reveal part of another; for example, you could use a round spotlight shape to reveal parts of a video layer. Matte effects can be used by themselves to mask out areas of a clip or to create alpha channel information for a clip in order to make a transparent border around the clip that can be composited against other layers. See also alpha channel, compositing.

media  A generic term for elements such as movies, sounds, and pictures.
**media browsers**  Media that you import into Events in Final Cut Pro is accessed from the Event Library and the Event Browser, but Final Cut Pro also includes a collection of media browsers you can use to add clips to your project. The media browsers provide access to the effects, titles, and transitions supplied with Final Cut Pro as well as to video, audio, and still-image files in other applications on your computer. For example, you can use the Photos Browser to access video and still-image files in the iPhoto and Aperture libraries. Other media browsers include the Effects, Music and Sound, Transitions, Titles, Generators, and Themes Browsers. The media browsers appear in the Media Browser pane in the lower-right corner of the Final Cut Pro main window.

**media handle**  Additional media available before a clip start point or after a clip end point.

**media stems**  Audio or video files that are usually exported separately for audio mixing or post-production, or to match specifications when delivering files to broadcast networks. For example, you may need to deliver a multitrack QuickTime file along with separate dialogue, music, and effects stems.

**mixing**  The process of adjusting the audio levels of all audio clips in an edited program, including the production audio, music, sound effects, voiceovers, and additional background ambience, to turn all of these sounds into a harmonious whole.

**monochrome**  An image presented in shades of a single color, most often as the shades of gray in a black-and-white image.

**MP3**  Refers to the MPEG-1 or MPEG-2 Audio Layer 3 compression standard and file format. Like AAC, MP3 uses perceptual audio coding and psychoacoustic compression to remove superfluous information that the human ear doesn’t hear.

**MPEG (Moving Picture Experts Group)**  A group of compression standards for video and audio, which includes MPEG-1, MPEG-2, and MPEG-4.

**multicam clip**  A set of clips grouped together and synchronized by a common sync point. You can use multicam clips to edit footage from multicamera shoots or other synchronized footage in real time. While the active angle plays in the Viewer, you can also view all angles playing simultaneously in the Angle Viewer and easily cut and switch between them.

**Music and Sound Browser**  A media browser in Final Cut Pro that allows you to access your iTunes content as well as sound effects and loops from Final Cut Pro and iLife.

**nested sequence**  See compound clip.

**NLE**  Short for nonlinear editor. See also nonlinear editing.
**nondestructive editing**  No matter how you edit clips in Final Cut Pro, the underlying media is never touched. This is known as *nondestructive editing*, because all of the changes and effects you apply to your footage never affect the original source media files. Clips represent your media, but they are not the media files themselves. The clips in a project simply point to (link to) the source media files on your hard disk. When you modify a clip, you are not modifying the media file, just the clip's information in the project. Trimmed or deleted pieces of clips are removed from your project only, not from the source clips in your Event Library or from the source media files on your hard disk.

**non-drop frame timecode**  Timecode in which frames are numbered sequentially and no timecode numbers are dropped from the count. When discussing NTSC video, the video frame rate is actually 29.97 fps, and non-drop frame timecode is off by 3 seconds and 18 frames per hour in comparison to actual elapsed time. See also *drop frame timecode*.

**non-interlaced video**  The standard representation of images on a computer. Also referred to as *progressive scan*. The monitor displays the image by drawing lines, one after another, from top to bottom.

**nonlinear editing**  A video editing method in which edits within a program can be changed at any time without having to re-create the entire program. When you use a nonlinear editing application to edit a program, all footage used is stored on a hard disk rather than on tape. This allows random access to all video, audio, and images as you edit. See also *linear editing*.

**NTSC format**  The video standard defined by the National Television Standards Committee, the organization that originally defined North American broadcast standards. Analog NTSC video has 525 interlaced lines per frame, a frame rate of 29.97 fps, and a limited color gamut. Digital NTSC video has a frame size of 720 x 486 pixels (720 x 480 for DV and DVD), and a frame rate of 29.97 fps. See also *PAL format*.

**offline**  A post-production process in which raw footage is copied and edited without affecting the original camera media (film, tape, or file-based media). After a program has been completed in the offline edit (typically using proxy media at a lower resolution), an *online edit* is performed to re-create the edit using the original media.

**opacity**  The level of a clip's transparency.

**outgoing clip**  The clip a transition segues from. For example, if Clip A dissolves to Clip B, Clip A is the outgoing clip. See also *incoming clip*.

**Out point**  See *edit point*. 

---

**Chapter 18  Glossary**
**overwrite edit** In an overwrite edit, one or more source clips overwrite any clips in the primary storyline or a selected storyline, starting at a range selection start point or at the skimmer or playhead position. No clip items are rippled forward, so the duration of your project remains the same. Overwriting is purely duration-based and works on range selections only, irrespective of clip boundaries.

**PAL format** Acronym for *Phase Alternating Line*, a 25 fps (625 lines per frame) interlaced video format used by many European countries. Digital PAL video has a frame size of 720 x 576. See also *NTSC format*.

**Photos Browser** A media browser in Final Cut Pro that allows you to access your iPhoto and Aperture photo libraries.

**pitch** Sounds are perceived as high or low depending on their frequency, or the number of times per second a sound wave cycles from positive to negative and back to positive. The word that musicians most commonly use for frequency is *pitch*. The higher the frequency, the higher the pitch. Modifying the speed of a clip affects the pitch of the audio. Slow motion creates low pitch, and fast motion creates high pitch.

**pixel** One dot in a video or still image. The more pixels in an image, the higher the resolution.

**playhead** The playhead marks your project’s current position in the Timeline or the Event Browser. You can move the playhead by dragging it or clicking another area of the Timeline or Event Browser. You use the playhead to *scrub*, or move through your project and play it back from different locations. The playhead appears as a gray vertical line that is fixed in place unless you move it or click elsewhere. See also *skimmer*.

**Position tool** The editing tool that allows you to place items in the Timeline. You can select the Position tool by pressing the P key.

**post-production** The phase of film or video editing in which all of the production elements are organized, assembled, and output.

**project** A project provides a record of your editing decisions and the media you use. You build your project by adding clips and editing them in the Timeline. A project is also defined by its video, audio, and render properties. In most cases, Final Cut Pro manages project settings automatically based on the properties of the first clip you add to a project.

**Project Library** The Project Library contains all of the Final Cut Pro projects on your hard disk and on any connected external drives.
**project properties**  A project’s default Event as well as the project’s video, audio, and render properties. In most cases, Final Cut Pro manages project’s properties automatically based on the properties of the first clip you add to a project. If you must modify the project properties, choose video and audio project properties based on how you intend to share your final movie with your audience. You set a project’s properties when you create a Final Cut Pro project, and you can change them at any time.

**proxy files**  You can use Final Cut Pro to transcode your original media to create proxy files, which are smaller files with a lower data rate. Proxy files can be used for offline editing or for editing when using a slower computer. Final Cut Pro creates video proxy files using the Apple ProRes 422 (Proxy) codec, and still-image proxy files using the JPEG format (if the original file doesn’t have alpha channel information) or the PNG format (if the file has alpha channel information). See also *alpha channel*.

**QuickTime**  Cross-platform multimedia technology from Apple. Widely used for production, post-production, and distribution of video, audio, and interactive programs.

**range selection**  A selection in the Event Browser or the Timeline that you can adjust by changing the selection start point or the selection end point. In contrast to clip selections, which include entire clips only, range selections allow you to select a portion of a clip. A range selection has range handles that you can drag to adjust the selection.

**Range Selection tool**  The editing tool that allows you to select a range in the Timeline. You can select the Range Selection tool by pressing the R key.

**red laser media**  Traditional DVD burners and players use a red laser when working with DVD media. Blu-ray burners and players use a blue laser when working with Blu-ray media. The blue color has a shorter wavelength, making it possible to store more data on a disc when compared to red lasers.

**render**  To process video and audio with any applied effects or transitions, and store the result on disk as a render file. These render files are stored with your Final Cut Pro Event and project files. When you publish or export a project, it is similarly rendered to create the output files.

**replace edit**  In a replace edit, a source selection replaces a clip in your project in the Timeline. In contrast to overwrite edits, replacing works on whole Timeline clips only and can change the duration of your project.
**Resolution** Image resolution refers to the number of pixels in an image. Resolution is expressed in terms of the width and height of the image in pixels (for example, 640 x 360 pixels). Higher-resolution images contain more detail but also create larger files that take longer to download. Your electronic devices (computer, iPhone, iPad, iPod, and so on) also have screen resolution. Ideally, you should match the image resolution of your media to the resolution of your playback device.

**Reverb** Reverberation, or reverb, refers to the reflection pattern created by bouncing sound waves off the surfaces—walls, ceilings, windows, and so on—of any space, or off objects within a space, gradually dying out until they are inaudible. Final Cut Pro includes a variety of audio effects that add reverb to the sound of a clip.

**RGB** Abbreviation for Red, Green, Blue. A color space commonly used on computers, in which each color is described by the strength of its red, green, and blue components. This color space directly translates to the red, green, and blue phosphors used in computer displays. The RGB color space has a very large gamut, meaning it can reproduce a very wide range of colors. This range is typically larger than the range that can be reproduced for broadcast.

**Ripple Edit** The default type of trim in Final Cut Pro is a ripple trim, which adjusts a clip’s start point or end point without leaving a gap in the Timeline. The change in the clip’s duration ripples outward, moving all subsequent clips earlier or later in the Timeline. Similarly, if you delete a clip from the Timeline, subsequent clips ripple earlier to close the gap. Ripple edits affect the trimmed clip, the position of all subsequent clips in the Timeline, and the total duration of your project.

**Role** Metadata text labels that you assign to clips in the Event Browser or the Timeline. They provide a flexible and powerful way to manage your editing workflow. You can use roles in Final Cut Pro to organize clips in your Events and projects, control the appearance of the Timeline, and export separate video or audio files (also known as media stems) for broadcast delivery, audio mixing, or post-production.

**Roll Edit** An edit that affects two clips that share an edit point. For example, if Clip A cuts to Clip B, a roll edit simultaneously adjusts the end point of Clip A and the start point of Clip B by the same amount. The overall duration of the project stays the same.

**Rough Edit** The first editing pass. The rough cut is an early version of a movie that pulls together its basic elements. Often, a rough edit is performed prior to adding transitions, titles, and other effects.

**Saturation** A measurement of the intensity of color in the video signal.

**Scene** A series of shots that take place at the same time in the same location. A series of scenes make up a program.
Select tool The default arrow-shaped pointer that allows you to select items in the Timeline. For example, you use it to select a clip or edit point. You can select the Select tool by pressing the A key.

**sequence** See project, Timeline.

**shortcut menu** A menu you access by holding down the Control key and clicking an item on the screen, or by pressing the right mouse button. Sometimes called a contextual menu.

**shot** A segment of continuously recorded video. A shot is the smallest unit of a program.

**skimmer** The skimmer lets you preview clips in the Timeline, Event Browser, or Project Library, without affecting the playhead position. You use the skimmer to skim, or freely move over clips to play back at the position and speed of the pointer. The skimmer appears as a pink vertical line as you move the pointer over the area you’re skimming. If you have snapping turned on, the skimmer turns orange when it snaps to a position.

**slate** A shot at the beginning of a scene, which identifies the scene with basic production information such as the take, date, and scene number. A clapper provides an audiovisual cue for synchronization when video and audio are recorded separately.

**slide edit** An edit in which an entire clip is moved, along with the edit points on its left and right. The duration of the clip being moved stays the same, but the clips to the left and right of it change in length to accommodate the new position of the clip. The overall duration of the project and of these three clips remains the same.

**slip edit** An edit in which the location of both start and end points of a project clip are changed at the same time, without changing the position or duration of the clip. This is referred to as slipping, because you slip the clip’s start and end points inside the available footage. The portion of the clip seen in the project changes, but its position in the Timeline stays the same.

**Smart Collection** When you search for clips in an Event using the Filter window, you can save your results by creating a new Smart Collection that gathers clips matching the search criteria. Whenever a new clip that matches the Smart Collection’s search criteria is brought into the Event, the new clip is automatically added to the Smart Collection. Clips that appear in Smart Collections are not duplicates. Smart Collections filter clips in an Event to help you focus on the clips you need to use for a specific task.
**snapping**  When the snapping feature is turned on in Final Cut Pro, items you move in the Timeline (including the playhead, the skimmer, and selected clips) appear to jump, or “snap,” directly to certain points in the Timeline. This can help you quickly line up edits with other items in the project. Snapping affects the functions of many of the editing tools in Final Cut Pro, including the Select tool, the Trim tool, the Position tool, the Range Selection tool, and the Blade tool. You can disable snapping when frame-by-frame precision editing is required.

**sound effects**  Specific audio material, such as the sound of a door closing or a dog barking, from effects libraries or from clips you recorded. Sound effects can be used to replace sounds in the location audio of a program, or to add sound that wasn’t originally recorded.

**source media files**  The original files (video, audio, and still images or graphics) that you import into Final Cut Pro. A clip you use in Final Cut Pro points to the location where the source media file is stored (either on a disk or on a camcorder, camera, or device). Changes made to clips within Final Cut Pro do not affect the source media files.

**special effects**  Visual effects applied to clips and projects, such as motion effects, compositing, keying, and retiming effects.

**spill suppression**  Spill suppression is a color correction operation that applies the complementary (opposite) color of the color that’s being made transparent to neutralize any green or blue fringing or light bounce that’s tinting the subject being keyed. The Spill Level slider controls how much spill suppression is applied to the keyed subject.

**split edit**  Final Cut Pro allows you to set separate video and audio start and end points in an individual clip. These edits, known as split edits, are a common technique in most dialogue scenes in films and television shows. You can use split edits to introduce the sound of a new shot or scene before cutting to the video of that shot or scene. Conversely, you can use a split edit to extend the audio of a shot over a subsequent shot.

**standard-definition (SD)**  Refers to the original NTSC and PAL video frame sizes. NTSC uses 480 or 486 active lines per frame, and PAL uses 576 active lines. See also high-definition (HD).

**stereo**  Short for stereophonic, in which audio contains two different channels. Audio level changes are automatically made to both channels at the same time.
storylines  All instances of the Timeline contain a primary storyline, which is the main sequence of clips that you build to create your movie. Storylines are sequences of clips connected to the primary storyline. You can use storylines for the same purposes as connected clips (such as creating cutaways, compositing titles and other graphics, and adding sound effects and music).

straight cut  A cut in which both the video and audio clip items are cut at the same time.

subframe  A subframe has 1/80 the duration of a video frame and is thus a more precise unit of reference when editing audio at the sample level.

sync (synchronization)  The relationship between the image of a sound being made in a video clip (for example, a person talking) and the corresponding sound in an audio clip. Maintaining audio sync is critical when editing dialogue. In Final Cut Pro X, connected clips and compound clips help maintain sync in your program.

Themes Browser  A media browser in Final Cut Pro that provides access to all transitions and title effects supplied with Final Cut Pro, grouped into related themes.

three-point editing  An editing technique in which three out of four edit points are set in a source selection and a project. When the edit is performed, the fourth edit point is calculated automatically by Final Cut Pro.

through edit  An edit point in which the video or audio content on either side of the edit is continuous.

TIFF (Tagged Image File Format)  A widely used bitmapped graphics file format, developed by Aldus and Microsoft, that handles monochrome, grayscale, 8- and 24-bit color. Can have alpha channels. See also alpha channel.

timecode  A signal recorded with your video that uniquely identifies each frame. By default, timecode appears in Final Cut Pro in the format hours: minutes: seconds: frames. Timecode supports a variety of functions in Final Cut Pro, including Timeline playback, synchronizing video and audio clip items, navigating through projects in the Timeline, and moving and trimming clips.

Timeline  The bottom portion of the Final Cut Pro window contains the Timeline, where you create your movie project by adding and arranging clips and making all your edits.

Timeline Index  You can view a text-based, chronological list of the clips, keywords, and markers in a project using the Timeline Index. When you select an item in the Timeline Index, the playhead jumps to that item in the Timeline.

tint  A color shade added to an image, usually to create an effect, such as sepia.
**Titles Browser**  A media browser in Final Cut Pro that provides access to all the title effects included with Final Cut Pro.

**toolbar**  The toolbar is a collection of buttons and tools located in the middle of the Final Cut Pro main window. The toolbar also includes the Dashboard, which displays the timecode for the clip selected in the Event Browser and for the playhead’s position in the Timeline.

**transcode**  All media files use a format. Video format examples include DV, H.264, and MPEG-2. Video files also have a variety of properties, such as video frame size and frame rate, data rate, and audio sample rate. When you need to convert a media file to a different format or change its properties, you transcode it to the new format or properties. Compressor, an Apple application designed to work with Final Cut Pro, makes transcoding media files a fast and easy process.

**transitions**  Effects that are applied to edit points to smooth out a change from clip to clip. In Final Cut Pro, you can choose from a variety of video transitions, such as a dissolves or wipes, or you can add an audio crossfade between audio clips.

**Transitions Browser**  A media browser in Final Cut Pro that provides access to all the video transitions included with Final Cut Pro.

**trim**  After you’ve assembled your clips in rough chronological order in the Timeline, you begin to fine-tune the cut point (or edit point) between each pair of contiguous clips. Any time you make a clip in a project longer or shorter, you’re trimming that clip. However, trimming generally refers to precision adjustments of anywhere from one frame to several seconds. If you’re adjusting clip durations by much larger amounts, you’re still trimming, but you may not be in the fine-tuning phase of editing yet. In Final Cut Pro, you can use a variety of techniques to trim Timeline clips and edit points, including ripple edits, roll edits, slip edits, and slide edits.

**Trim tool**  The editing tool that allows you to trim items in the Timeline. You can select the Trim tool by pressing the T key.

**uncompressed 8- and 10-bit 4:2:2**  These video formats can be used to store 8-bit or 10-bit 4:2:2 Y’CbCr video without employing data compression. Bypassing compression reduces the computer’s processing load but increases the data rate considerably. A large-capacity RAID storage system is typically required to work effectively with uncompressed video. In many cases, Apple ProRes is a better choice. The data rate of uncompressed 4:2:2 video varies according to frame size and frame rate. As an example, at a frame size of 1920 x 1080 and a frame rate of 29.97 fps, the data rate is 1.0 Gbps for uncompressed 8-bit 4:2:2 video and 1.3 Gbps for uncompressed 10-bit 4:2:2 video.

**variable speed**  Speed that varies dynamically, in forward or reverse motion, in a single clip.
VCR  Abbreviation for videocassette recorder. Generally refers to consumer equipment used for recording video from various sources. Sometimes referred to as a VTR. See also VTR.

Vectorscope  A video scope in Final Cut Pro that shows the distribution of color in your image on a circular scale. The Vectorscope is useful for comparing the hue and intensity of colors between two clips for the purposes of color correction.

Video Animation Editor  You can show the Video Animation Editor for clips in the Timeline to adjust effect parameters, create fade-ins or fade-outs, or change effects over time using keyframes.

Viewer  When you play clips selected in the Event Browser and the Timeline, they appear in the Viewer.

VTR  Abbreviation for videotape recorder. Generally refers to professional equipment used for recording video from various sources.

watermark  A visible graphic or text overlay applied to an image or video clip to indicate that it is protected by a copyright. Watermarks are used to discourage the use of images or video clips without the copyright holder’s explicit permission.

WAVE (or WAV)  An audio file format most commonly used for storing uncompressed linear pulse code modulation (LPCM) audio data.

Waveform Monitor  A video scope in Final Cut Pro that displays the relative levels of luma and chroma in the clip currently being examined. Spikes and dips in the displayed waveforms correspond to light or dark areas in your picture.

widescreen  Any movie presentation that has an aspect ratio wider than 4:3. In movie theaters, 1.85 is considered standard and 2.40 is considered widescreen. For video, 4:3 is considered standard and 16:9 (which is almost the same aspect ratio as 1.85) is considered widescreen. See also 4:3, 16:9.

wipe  A common type of video transition. In a wipe, the screen splits, moving from one side of the image to the other to gradually reveal the next shot. A wipe is more obvious (and customizable) than a fade or cross dissolve.

XDCAM  Sony optical disc format for recording DVCAM and IMX video within MXF container files. See also DVCAM, IMX.

XDCAM EX  A member of the Sony XDCAM product family that uses MPEG-2 video compression with 4:2:0 chroma sampling. In contrast to XDCAM HD, XDCAM EX supports 720p and records full HD resolution (either 1920 x 1080 or 1280 x 720). Its maximum bit rate is 35 Mbps. Instead of optical discs, XDCAM EX camcorders use solid-state memory cards known as SxS cards. See also HDV.
XDCAM HD422 A member of the Sony XDCAM product family featuring 4:2:2 chroma sampling and a video bit rate of 50 Mbps. Like XDCAM EX, it uses MPEG-2 video compression at full HD resolution (either 1920 x 1080 or 1280 x 720). See also HDV.

Y’CbCr The color space in which many digital video formats store data. Three components are stored for each pixel—one for luma (Y) and two for color information (Cb for the blue difference signal and Cr for the red difference signal). Also referred to as YUV. See also pixel.

Zoom tool The editing tool that allows you to zoom in to or out of the Timeline. You can select the Zoom tool by pressing the Z key.