MainStage 2
Exploring MainStage
Chapter 3: Editing Patches
- Adding a Channel Strip
- Changing the Channel Strip Setting
- Adding a Plug-in
- Creating a Keyboard Split
- Key Concepts

Chapter 4: Learning Controller Assignments
- Learning a Controller Assignment
- Key Concepts

Chapter 5: Mapping Screen Controls
- Mapping a Screen Control to a Parameter
- Mapping a Screen Control to an Action
- Mapping a Screen Control to Multiple Parameters
- Editing a Parameter Graph
- Key Concepts

Chapter 6: Working with Concerts and Sets
- Adjusting the Overall Concert Volume
- Defining the Tempo for a Concert
- Adding a Concert-Wide Effect
- Adding a Set-Level Channel Strip
- Overriding Concert- and Set-Level Mappings
- Key Concepts
A First Look at MainStage

Welcome to MainStage. If you’re new to MainStage, this guide is for you. You’ll learn by doing as you work on a concert, customize your sounds, and get ready to perform.

MainStage turns your computer into a powerful, customizable musical instrument and effects processor that you can use with your music gear in live performance. Whether you are a keyboard player, a guitarist, a vocalist, or play another instrument, you can use MainStage in your rig when you play live.

This Exploring guide presents the main features of MainStage and guides you in trying out different parts of the application. You’ll start by learning the basics and move on to more advanced features you can use when you perform live with MainStage.

If you prefer to learn by reading in-depth explanations of the features and controls in MainStage, open MainStage, then choose Help > MainStage Help to view the MainStage User Manual.
Getting Ready
Before you begin, you should install MainStage on your computer. For instructions, see the Installing Your Software booklet that comes with Logic Studio. You should also connect the music equipment that you plan to use, such as a MIDI controller, audio interface, musical instruments, or microphone, to your computer. For more information about using music hardware with MainStage, see the “Setting Up Your System” chapter in the MainStage User Manual.

Opening MainStage
You start by opening MainStage and creating a new concert from a template.

Open MainStage:
- Double-click the MainStage icon in your Applications folder or click the icon in the Dock.

When you open MainStage, and each time you create or close a concert, the Choose Template dialog appears, showing available concert templates for keyboards, guitars, vocals, and other instruments.
Choose a concert template:
1 Click an instrument from the list on the left to see the templates for that instrument type. If you play a keyboard controller, select Keyboards to view keyboard templates featuring software instrument patches. If you play an electric guitar, select Guitar Rigs to view guitar templates featuring audio patches with guitar amps and effects.
2 Scroll through the available templates to find the one you want.
3 Double-click the template you want to use.

A new concert created from the template opens in a full screen window. In the center of the MainStage window, the workspace shows the screen controls that correspond to the controls on your MIDI hardware. To the left of the workspace is the Patch List, where you can select patches and sets in the concert. The channel strips for the selected patch appear in the Channel Strips area to the right of the workspace. Below the workspace is the Inspector, which shows parameters for different items when you select them.
The new concert will look similar to this:
Name and save the concert:

1. Choose File > Save.
2. Enter a name for the concert in the name field.
3. Click Save.

Exploring Edit Mode

A new concert opens in Edit mode. Edit mode is where you create, customize, and organize your sounds, called patches. Patches contain channel strips with Logic Pro instruments and effects. You can add and edit patches, add channel strips, and create keyboard layers and splits to customize your sounds. Edit mode is also where you map screen controls to channel strip parameters and actions, and edit patch, set, and concert-level parameters.

A new concert contains at least one patch, which is selected in the Patch List. Below the workspace, the Patch Library is open so that you can select and audition different patch settings for the selected patch.
Try This

Play the selected patch:

- Using your instrument or microphone, play the patch. As you play, observe different parts of the MainStage window, including the screen controls in the workspace and the Activity Monitor in the center of the toolbar.

Explore the Patch Library:

- Select a different patch setting in the Patch Library and play the patch to hear the new patch setting. Try out several different patch settings and see how the sound changes.
Explore the Patch List and the Inspector:

- In the Patch Inspector, click the Attributes tab. Click the Icon well, and choose a new icon for the patch. You’ll explore other parameters in the Inspector in later chapters.
- Select the concert (the Untitled Concert icon) in the Patch List. The Inspector changes to show concert parameters, including time signature, tempo, device information, and tuning.

- Select the set (the blue My Song folder) in the Patch List. The Inspector changes to show set parameters, including time signature, change tempo, and tuning method.
Click one of the knobs or faders in the workspace. It highlights in blue, and mappings and other parameters for it appear in the Inspector. Click the tabs in the Inspector and look at the parameters each one contains.

![Patch Controls]

**Explore the Channel Strips area:**

- To the right of the workspace, the Channel Strips area shows the channel strips for the selected patch as well as channel strips at the set or concert level that affect the sound of the patch. Move the pointer to the left edge of the Channel Strips area and drag left or right to resize it.
- Click a channel strip. The Channel Strip Library appears in the Inspector, showing different channel strip settings. With the channel strip selected, click the other tabs in the Channel Strip Inspector to view different parameters for the selected channel strip.
Exploring Layout Mode

Layout mode is where you customize the visual layout of the concert, adding and arranging screen controls to match your hardware devices. You also make connections (called *controller assignments*) between your MIDI hardware and the screen controls in your concert in Layout mode.
In Layout mode, the workspace fills more of the screen so you can focus on editing your layout. Because you are working on the overall concert layout rather than with individual patches, there is no audio output when you are using Layout mode.

**Try This**

**Switch to Layout mode:**
- Click Layout at the upper-left corner of the toolbar (or press Command-1).

**Explore the workspace:**
- Click a screen control. It appears highlighted in a blue rectangle with square handles.

Some screen controls are part of a grouped control. If you try to move a member of a grouped control, the entire group moves.
Explore the Screen Controls Palette:
- Click each of the tabs in the Palette and observe which screen controls are available.
- Drag a screen control from the Palette to the workspace and try moving it to a new position. Resize it by dragging its blue resize handles. To remove it, press the Delete key.

Explore the Screen Control Inspector:
- Parameters for the currently selected screen control appear in the Screen Control Inspector to the left of the workspace. Select different types of screen controls and observe the differences in the Screen Control Inspector. Try changing the Color and Text Label parameters for the selected screen control. You’ll explore other screen control parameters in later chapters.
Exploring Perform Mode
In Perform mode, the workspace fills most of the screen. Above the workspace, the toolbar is available so you can switch modes, view the Activity Monitor, and access other toolbar buttons. Perform mode optimizes your computer for live performance, but you can still access the Finder and switch to other open applications.

Try This
Switch to Perform mode:
- Click Perform at the upper-left corner of the toolbar (or press Command-3).

The workspace fills the entire window except for the toolbar at the top.
Play a patch:
- Try playing the selected patch with your instrument. If you are playing a keyboard controller, play a few notes or chords and watch the keyboard in the workspace. You should hear sound, and the keys should respond as you play. If you are playing an electric guitar, you should hear your guitar through the amps and other effects in the patch and see the Output meter light as you play.

Use hardware controls:
- Move the pitch bend wheel and mod wheel on your keyboard. The corresponding screen controls move, and you hear a change in the sound.
- Try moving the knobs, rotary controls, sliders, and other controls on your MIDI controller. Some controllers respond, but others need to be configured first to respond to the MIDI input from your controller.
- If you have a sustain pedal, hold it down as you play. If you have a footswitch, wait a moment, then press it again.
Exploring Full Screen Mode
In Full Screen mode, the workspace fills your entire display, showing the workspace at its maximum size for optimal readability in performance environments. Full Screen mode optimizes your computer and display for live performance when you want to use MainStage exclusively while you play.

Try This
Switch to Full Screen mode:
- Click Full Screen at the upper-left corner of the toolbar (or press Command-4).

The workspace fills your display for easy viewing in a concert environment.
Play a patch:
- Try playing your instrument and watch the screen controls in the workspace respond.

Use hardware controls:
- Try the knobs and other controls on your controller, as you did in Perform mode. See if you like playing better in Perform mode or Full Screen mode.
Key Concepts

- **Concert:** The MainStage document that holds all the sounds and settings you’ll use in performance, the visual layout of screen controls, and information about the connections between your MIDI hardware devices and the screen controls.

- **Patch:** An individual sound in a MainStage concert that contains one or more channel strips with instruments, effects, or both.

- **Workspace:** The central area of the MainStage window that shows the layout for the concert.

- **Screen control:** A visual representation of a hardware control, such as a knob, fader, or button. Some screen controls can also display patch, parameter, or system information, text, or an image.

- **Edit mode:** Where you add, edit, and organize the patches in a MainStage concert. Edit mode is also where you map screen controls to parameters and actions.

- **Layout mode:** Where you add and arrange screen controls to edit the visual layout of a concert. Layout mode is also where you make connections (called controller assignments) between your MIDI hardware devices and the concert.

- **Perform mode:** One of the two modes optimized for performance. The workspace fills the MainStage window, but you can still access the Finder and the toolbar.

- **Full Screen mode:** The other mode optimized for live performance. The MainStage workspace fills your entire display for easy viewing in stage or club environments.
Adding and Organizing Patches

You add and organize the patches in a MainStage concert in the Patch List.

A MainStage concert can hold all the patches you’ll use in one performance or a series of performances. The number of patches you can have in a concert is limited only by the amount of available memory in your system.

MainStage includes a Patch Library with a large collection of patch settings for software instruments, guitar rigs, audio effects setups, and more. When you add a patch, you can select a patch setting for it in the Patch Library to play or to use as a starting point for your own custom setting.

Getting Ready

You add, organize, and edit patches in Edit mode. If the concert is currently in another mode, switch to Edit mode before you continue working.

Switch to Edit mode:

- Click Edit at the upper-left corner of the toolbar (or press Command-2).
Adding a Patch
By default, most new MainStage concerts contain at least one patch. When you add a patch, it appears below the selected patch in the Patch List.

Try This
Add a patch:
- Click the Add Patch button (+), located in the upper-right corner of the Patch List.

A new patch appears in the Patch List. The Patch Library tab is selected in the Patch Inspector so you can quickly audition patch settings and select one for the new patch. The patch settings visible in the Patch Library match the type of concert template used to create the concert: if you selected a Keyboard template, software instrument patches appear in the Patch Library. If you selected a Guitar Rig template, audio patches with guitar amps and effects appear.
Select a patch setting:
- In the Patch Library, select a patch setting, then play the patch to audition the new setting. Try out different patch settings until you find one you like.

When you select a patch setting, the patch name changes to match the patch setting. You can also give the selected patch a custom name to identify it.

Name the patch:
- In the Patch List, double-click the patch name, then type a new name for the patch.

Add another patch:
- Add a third patch to your concert, following the steps described above. Select a different patch setting for the patch, and give the patch a custom name.
Selecting Patches
After you have added a few patches to your concert, you can quickly select patches in the Patch List and start playing the selected patch.

Try This
Select a patch in the Patch List:
- Click a patch in the Patch List to select it, then start playing the selected patch.
- Try sustaining some notes while you select a new patch. Notice that the notes continue to sustain, but you can play notes using the new patch.

Select patches using key commands:
- Press the Down Arrow key to select the next (lower) patch in the Patch List.
- Press the Up Arrow key to select the previous (higher) patch in the Patch List.

Most concert templates include a selector screen control that you can use to select patches in performance, using the button screen controls to select the previous and next patch or set. By assigning hardware buttons to these screen controls, you can select different patches and sets in Perform and Full Screen modes.
Organizing Patches in the Patch List

You can organize your patches for easy access when you play. How you organize your patches depends on how you want to use them while performing. You can reorder patches in the Patch List so that they appear in the order in which you plan to use them or in any order that suits your needs.

You can also use sets to organize your patches. Sets are like folders that can hold groups of patches you want to keep together. For example, you can store all your favorite lead synth patches in a set or store multiple patches to use in a single song. You can start with a new, empty set or create a set from a group of selected patches.

Try This

Reorder patches in the Patch List:
- Drag patches up or down to change their order.

Create a new, empty set:
- Choose New Set from the Action menu in the upper-right corner of the Patch List. The new set appears in the Patch List.
Create a set from a group of patches:

1. In the Patch List, select the patches you want to include in the new set.
2 Choose New Set From Selection from the Action menu at the upper-right corner of the Patch List.

The new set containing the selected patches appears in the Patch List.

Add a new patch to a set:
1 Select either the set or a patch within the set.
2 Click the Add Patch (+) button.

Move existing patches into a set:
- Drag the patches from another part of the Patch List to the set.
Playing Patches
With the patch selected, try moving different controls on your MIDI controller. Some screen controls, including the keyboard, modulation and pitch bend wheel, and sustain pedal screen controls, respond to corresponding MIDI messages without requiring any configuration.

Try This
Play your keyboard controller:
- If you are playing a MIDI keyboard controller, try playing notes and chords on the keyboard. Move the mod wheel and pitch bend wheel. Try pressing buttons and moving different knobs, sliders, rotary encoders, or other controls on your controller, and observe whether the screen controls in the workspace respond.

Play your electric guitar:
- If you are playing an electric guitar, the screen controls don’t respond to the knobs on your guitar, but the Output meter shows audio output if your guitar is connected to the selected audio input. If you are using a MIDI footswitch, press the footswitch and observe whether the MIDI Activity meter above the workspace responds. You can use a MIDI footswitch to send patch changes to MainStage and use MIDI devices to control patch parameters in real time.
Play or sing using your microphone:

- If you are using a microphone or another musical instrument with MainStage, you can also use MIDI devices to send patch changes and control patch parameters as you play. Move the controls on your device and see if the MIDI Activity meter above the workspace responds.

Continue selecting and playing patches in the concert to find the sounds you want to use in performance or to use as a starting point for creating your own custom patches.

**Key Concepts**

- *Patch setting:* A group of channel strip and plug-in parameters that defines the sound of a patch. You select patch settings in the Patch Library.

- *Patch List:* The area to the left of the workspace in Edit mode that shows the patches and sets in a MainStage concert.

- *Set:* A folder in the Patch List that you can use to organize a group of patches you want to keep together.
You can edit patches to create your own custom sounds and effects setups.

MainStage patches are based on the same channel strip format used by Logic Pro. You can add multiple channel strips, choose different channel strip settings, and make use of a wide variety of Logic Pro instrument and effects plug-ins, as well as third-party plug-ins, in your patches. You can create layered sounds and keyboard splits.

Adding a Channel Strip
Patches contain one or more channel strips. You can add multiple channel strips to a patch to create layered sounds and keyboard splits or to use different channel strip types together in a single patch.
Channel Strip Types

You can use the following types of channel strips in a MainStage concert:

- Audio channel strip: Use with guitars, instruments, microphones, and other audio devices connected to your computer.
- Software instrument channel strip: Use with keyboard controllers and other MIDI devices that send MIDI note messages.
- External instrument channel strip: Use to control external hardware synthesizers and sound modules and ReWire applications.
- Auxiliary (aux) channel strip: Use to route the audio output from other channel strips and with multi-output instruments.
If you are using a Keyboard concert, use software instrument channel strips for the following tasks. If you are using a Guitar Rig concert, use audio channel strips.

**Try This**

**Add a channel strip to a patch:**

1. Select the patch you want to work with in the Patch List.
2. Click the Add Channel Strip (+) button at the upper-right corner of the Channel Strips area.
3. In the New Channel Strip dialog, select Software Instrument as the type if you are playing a keyboard, or select Audio as the type if you are playing a guitar.
4. Choose the audio output for the channel strip from the Output pop-up menu.
5. Do one of the following:
   • For software instrument channel strips, choose the MIDI input device from the MIDI Input pop-up menu. (The menu shows recognized input devices by name, while other devices appear as Keyboard 1, Keyboard 2, and so on.)
   • For audio channel strips, choose mono from the Format pop-up menu and choose the audio input source from the Input pop-up menu.

6. Click Create.
   A new channel strip appears in the Channel Strips area and is highlighted. The Channel Strip Inspector appears below the workspace, showing the Channel Strip Library.

7. For audio channel strips, play or sing, gradually raising the channel strip volume fader until you hear sound on the channel.

*Important:* Audio channel strips can produce feedback, particularly if you are using a microphone. When you add an audio channel strip, the volume of the channel strip is set to silence, and Feedback Protection is turned on to alert you when feedback occurs on the channel strip. When you add an external instrument channel strip, the volume of the channel strip is set to silence, but Feedback Protection is turned off.
Changing the Channel Strip Setting

In MainStage, you can access the Logic Pro Channel Strip Library, which contains a large collection of predesigned channel strip settings. After you choose a new setting, you can quickly change the instrument, effects, and other parameters to customize the sound to your liking.

Try This
Choose a channel strip setting from the Channel Strip Library:

1. In the Channel Strips area, select the channel strip you want to change. The selected channel strip appears highlighted.

2. In the Channel Strip Inspector, click the Channel Strip Library tab.

Available settings for the channel strip appear in the Channel Strip Library. Logic Studio content appears in a series of folders with different instrument categories. If you have GarageBand or any Jam Packs installed on your computer, their settings appear below the Logic Studio settings.
3 Click a category from the column on the left, then click subcategories from the columns on the right until you see the settings you want.

4 Click the new channel strip setting.

5 Play the patch. Try out different channel strip settings and see how the sound changes.

Adding a Plug-in
In addition to the plug-ins included in patch and channel strip settings, you can add individual plug-ins to a channel strip and adjust plug-in parameters to “dial in” your custom sound. You add a plug-in to a channel strip in MainStage in exactly the same way as you do in Logic Pro.

Try This
Add an effect plug-in to a channel strip:
- Click one of the empty Insert slots on the channel strip, choose an effect category from the Plug-in menu, then choose an effect from the submenu.

Change the instrument plug-in for a software instrument channel strip:
- Click the Instrument slot on the software instrument channel strip, choose an instrument category from the Plug-in menu, then choose an effect from the submenu.

Choose a different plug-in setting:
- Click the Insert or Instrument slot containing the plug-in, then select a new plug-in setting from the Plug-in Library below the workspace.
Adjust plug-in settings:

- Double-click the Insert or Instrument slot containing the plug-in, then try adjusting different controls in the plug-in window. Your changes are saved for as long as the concert is open. To save changes to channel strip and plug-in parameters permanently, save the concert before closing it.
Creating a Keyboard Split

When you add a software instrument channel strip to a patch, it extends over the entire MIDI keyboard range (C–2 to G8). Two or more channel strips in the same range produce a layered sound. You can easily create keyboard splits in your patches so different channel strips cover different parts of the keyboard. You create keyboard splits by defining a *key range* for each channel strip.

Key ranges can have floating split points, in which case the high and low notes of the key range change depending on the keys you play as you approach them.

**Try This**

**Open the Layer Editor:**

1. Select a layered patch, or add a channel strip to an existing patch.
2. In the Channel Strips area, select the first (leftmost) channel strip.

   The Channel Strip Inspector appears below the workspace.
3 In the Channel Strip Inspector, click the Layer Editor tab.
The Layer Editor shows a horizontal, colored layer for each channel strip in the patch.
The layer for the selected channel strip is highlighted.

Create a keyboard split:
- Move the pointer to the left edge of a layer, then drag the layer right to set the Low Key for the layer.
- Move the pointer to the right edge of a layer, then drag the layer right to set the High Key for the layer.

Define floating split points:
- Enter a value in the Low Key Floating value slider. You can type an integer value, click the arrows to increment or decrement the value, or drag the slider to set the number of notes used for the split.
Enter a value in the High Key Floating value slider, in the same way as you did for the Low Key Floating Split value slider.

Now when you play notes leading down to the Low Key note, or play notes leading up to the High Key note, the key range extends to follow your playing by the number of semitones defined for the floating split point.

**Key Concepts**

- *Key range*: For software instrument channel strips, the key range defines the incoming MIDI notes that will produce sound using the generator of the software instrument. Two instruments with overlapping key ranges create a layer.

- *Keyboard split*: A patch containing two or more channel strips, the key ranges of which are adjacent, so the sound is produced by different instruments depending on which notes you play.
Learning Controller Assignments

You make connections between your hardware MIDI devices and a MainStage concert by learning controller assignments.

A MainStage concert contains information about which knobs, sliders, and other controls on your MIDI hardware devices control the screen controls in the workspace. You make connections between your MIDI hardware and the concert by assigning hardware controls to the screen controls in the workspace. You only need to make controller assignments once for a concert as long as you are using the same music hardware.

MainStage recognizes many popular MIDI devices and automatically assigns some screen controls to hardware controls it recognizes. For many popular keyboard controllers, the pitch bend and mod wheels and the sustain pedal will work without any further configuration. For other controls, you need to learn controller assignments before you can use them to manipulate the screen controls in your MainStage concert.
Learning a Controller Assignment
You can quickly assign hardware controls to screen controls using the Learn process, which is similar to learning controller assignments for a control surface in Logic Pro.

Getting Ready
- Make sure your MIDI hardware device is connected to your computer and is working.
- Move the controls on the device and observe the Activity Monitor to make sure MainStage is receiving MIDI input from the device.

Try This
Switch to Layout mode:
- Click the Layout button in the toolbar (or press Command-1). MainStage switches to Layout mode.

Learn a controller assignment:
1 In the workspace, select the screen control you want to learn. The selected control appears highlighted in a blue rectangle.
2 Press Command-L.

The rectangle around the screen control turns red to indicate that the Learn process is active.

3 On your MIDI device, move the control you want to assign. Move faders and knobs through their full range of motion, and press buttons exactly three times (not too quickly) to enable MainStage to correctly learn the MIDI message types sent by these controls. Notice that some values in the Screen Control Inspector change to reflect the type of hardware control learned by the screen control. Any incoming MIDI messages appear in the Activity Monitor.

4 Learn additional controller assignments by selecting another screen control and moving the hardware control you want to assign to it. You can learn as many assignments as you wish while Learn mode is active.

5 When you are finished assigning controls, press Command-L again to turn off the Learn process.
Key Concepts

- *Layout*: The visual representation of your hardware controls in the MainStage workspace.
- *Controller assignment*: The process of making connections between your hardware MIDI devices and a MainStage concert, so the screen controls in the concert will receive and respond to MIDI messages sent from the devices.
- *Learn process*: The mode in which you learn controller assignments by selecting a screen control, then moving the hardware control you want to assign to it.
Mapping Screen Controls

After you make connections between your MIDI hardware and the screen controls in MainStage, you map the screen controls to channel strip and plug-in parameters in your patches so you can modify the patches in real time when you perform.

By mapping screen controls to different parameters in the patches in your concert, you can control exactly the parameters you want for each patch. You can map a single screen control to multiple parameters in the same patch or map screen controls to MainStage actions to select patches, change the tempo, use the Tuner, display information, and perform other functions.
Mapping a Screen Control to a Parameter
After you have customized the sound of the patches in your concert, you can map MainStage screen controls to channel strip and plug-in parameters to control them in real time.

Try This
Map a screen control to a channel strip or plug-in parameter:
1 In the workspace, click the screen control you want to map.
   The screen control is highlighted in blue. The Screen Control Inspector appears below the workspace.
2 Press Command-L.

In the Screen Control Inspector, the tab for the mapping is selected. (If there is no existing mapping, it is named Untitled; otherwise, it shows the name of the current mapping.) The Map Parameter button glows red to indicate that mapping is active, and the Parameter Mapping browser shows parameters available for mapping.
3 To map the screen control to a channel strip parameter, click the parameter you want to map on the channel strip.

4 To map the screen control to a plug-in parameter, double-click the Input or Insert slot for the plug-in to open the plug-in window, then click the parameter you want to map.

The screen control is mapped to the selected parameter, and the Unmapped tab takes the name of the parameter. While mapping is active, you can map additional screen controls by selecting them in the workspace, and then selecting the channel strip or plug-in parameters to map them to.

5 When you are finished mapping parameters, press Command-L again.
Mapping a Screen Control to an Action

In addition to channel strip and plug-in parameters, you can map screen controls to actions. Actions are functions specific to MainStage that let you select patches and sets, turn the Tuner or the metronome on or off, tap a new tempo, display patch parameters and other information, and perform other functions using screen controls.

Try This

Map a screen control to an action:

1. In the workspace, click the screen control you want to map.
2. In the Screen Control Inspector, click the Unmapped tab.
3. In the column at the left of the Parameter Mapping browser, click the Actions folder. Available actions appear in the second column.

4. Select an action from the Parameter Mapping browser.
Mapping a Screen Control to Multiple Parameters
You can use a single screen control to modify multiple parameters. Mapping a screen control to multiple parameters is called *multimapping*.

**Try This**

**Add a mapping to a screen control:**
- Select a mapped screen control, click the Add Mapping (+) button at the upper-right corner of the Screen Control Inspector, then choose the parameter you want to map from the Parameter Mapping Mapping browser.

**View all mappings for a screen control:**
- In the Screen Control Inspector, select the Mappings tab.
Editing a Parameter Graph

Each mapped parameter has a Parameter graph. You can edit the graph to remap the output values to different input values along the parameter’s range.

Open a Parameter graph for editing:
1 In the Screen Control Inspector, click the tab for the mapping you want to edit.
2 Click the Parameter graph button.

The graph for the parameter appears in a new window.
Edit a Parameter graph:

- Click one of the square buttons at the top of the window to set the graph to one of the preset curves.
- Click a point on the curve, then drag the node vertically to change the output value. Drag the point horizontally to change the input value.
- Double-click a point, then enter the x and y coordinates in the Precision Editor.
- Click the Invert button to invert the graph along the x (input) axis.
- Click the Reset to Default button to return the graph to its original state.
- To delete a point, click the point, then press the Delete key.
- When you are finished, click the close button in the upper-left corner of the graph window to close the graph.
**Key Concepts**

- **Mapping**: The connection between a screen control and a channel strip or plug-in parameter that allows you to change the parameter’s value using the screen control.

- **Action**: A MainStage function that can be controlled by a screen control to the action. MainStage actions are available in the Actions folder of the Parameter Mapping browser, and include functions for selecting patches and sets, tapping the tempo, showing the Tuner, displaying transport information, and more.

- **Graph**: A visual representation of a range of parameter values. MainStage includes transform, velocity scaling, and parameter graphs that you can edit to remap input values to different output values.
Working with Concerts and Sets

You can define the tempo for a concert, control the overall concert volume, and add channel strips at the concert level so they are available in every patch.

You can also edit parameters for a set, use the set to change the tempo, and add channel strips at the set level so they are available in every patch in the set.

Adjusting the Overall Concert Volume
Each MainStage concert contains Output and Master channel strips that you can use to control the overall volume of the concert. The Master channel strip always controls the output volume of the entire concert. If the concert has multiple Output channel strips, each Output channel strip controls the volume level for a particular (mono or stereo) physical output. You can use the Output and Master channel strips to control the overall volume in the same way you control the overall volume of a Logic Pro project.

Try This
Adjust the overall volume level of a concert:
1 In the Patch List, select the concert icon.
2 In the workspace, click a fader screen control. (If there is none, add one.)
A new tab titled Unmapped appears in the Screen Control Inspector. The tab is selected, and the Parameter Mapping browser appears in the Inspector.

3. In the leftmost column of the Parameter Mapping browser, select Output 1-2.

4. From the column to the right, select Volume.

5. Drag the fader assigned to the fader screen control. Observe that the volume of the concert changes in step with the movements of the fader.
Defining the Tempo for a Concert

Each concert has a tempo, which you can change in different ways while you are performing. The tempo controls time-based plug-in parameters, such as delay times, and affects sequencer-oriented plug-ins such as Playback as well as ReWire applications.

When you open a concert, the Tempo setting in the Concert Inspector is used as the tempo. You can change the tempo by selecting a patch or set with its own Tempo setting or by tapping a tempo. When you change the tempo, MainStage uses the new tempo until you change it again or until you close the concert.

Try This

Set the initial tempo for a concert:

1. In the Patch List, select the concert icon.
2. In the Concert Inspector, drag the Tempo slider or change the value using the value slider.

Tap the tempo using your computer keyboard:

- Press Control-T several times at the desired tempo.
Tap the tempo using the Tap Tempo button:
- Click the Tap Tempo button in the toolbar several times at the desired tempo.

Change the tempo by selecting a patch:
1. Select the patch you want to use to change the tempo.
2. In the Patch Inspector, select the General tab.
3. Select the Change Tempo To checkbox.
4. Set the patch tempo using the Change Tempo To value slider.

When you select the patch, the tempo changes to the value set in the Change Tempo To slider.
Adding a Concert-Wide Effect
You can add concert-wide effects such as reverb and delay using sends and auxiliary channels (auxes). When you choose a send from the Send slot on a channel strip in a patch, the corresponding auxiliary (aux) channel strip appears at the concert level. You can insert effects on the aux and have those effects apply to every channel strip sending its signal to the aux.

Try This
Send a channel strip signal to an aux:
1. In the Patch List, select a patch you want to use with a concert-wide effect.
2. In the Channel Strips area, click one of the Send slots on the first channel strip (not an aux) and choose Bus 3 from the menu.
3 Drag the Send knob next to the slot to set the amount of the signal sent through the bus to the aux.

A new auxiliary channel strip, Aux 3, appears in the Channel Strips area.

**Add a concert-wide effect to the aux:**
- Click one of the Insert slots on the Aux 3 channel strip, then choose an effect from the Effects menu. Try out different effects and see how they change the sound of the patch.
- Double-click the effect in the Insert slot to open the plug-in window, then adjust parameters in the plug-in window.
- Choose another patch and click one of the Send slots on a channel strip in the patch. Bus 3 (Aux 3) is available to add to a channel strip in any patch in the concert.

You can also add concert-wide effects to an aux at the patch level if Show Signal Flow Channel Strips is active.
Adding a Set-Level Channel Strip

You can add channel strips at the set level and play the set-level channel strips together with every patch in the set. This can be useful, for example, if you want to use the same bass instrument in a single song or group of songs. You can place the patches for all of the songs in a set, add a channel strip at the set level, and then add a bass instrument to the set-level channel strip. You can set the key range of the bass instrument to play only notes in the lower octaves so that you can play it together with your patches.

When you add a channel strip at the set level, it takes precedence over the channel strips in all of the patches in the set. For example, if you add a software instrument channel strip at the set level, the software instrument takes precedence over the software instruments in all of the patches in the set that fall within the same key range as the concert-wide software instrument. You can define the key range for the set-level instrument so it does not overlap the key ranges of any patches you want to play.

Try This

Add a channel strip at the set level:
1. In the Patch List, select the set.
2. Click the Add Channel Strip (+) button at the top of the Channel Strips area.
3. In the New Channel Strip dialog, select the type of channel strip you want to create.
4. Choose the audio output for the channel strip from the Output pop-up menu.
5. For audio channel strips, choose mono or stereo format from the Format pop-up menu and choose the audio input from the Input pop-up menu.
6. Click Create.
Overriding Concert- and Set-Level Mappings

By default, mappings you make at the concert level (to parameters and actions) take precedence over mappings for individual patches or sets in the concert. If you map a screen control to a parameter at the concert level (for example, to Master Volume), that screen control cannot be mapped to a parameter or action in a patch or set unless you override the concert-level mapping.

Similarly, mappings you make at the set level take precedence over mappings for any patches in the set. If you map a screen control to a parameter at the set level (for example, to an effect on a set-level channel strip), that screen control cannot be mapped to a parameter or action in a patch in the set, unless you override the set-level mapping.

When a screen control is mapped at another level, the parameters in the Screen Control Inspector are dimmed and are unavailable. You can override the concert- and set-level mappings for an individual patch, and then map the screen control at the patch level.
Try This

Override concert-level mappings for a screen control:
- Select one of the Global EQ screen controls, then select the Override Concert Mapping checkbox in the Screen Control Inspector.

Select the checkbox to override a concert-level mapping.

The parameters in the Screen Control Inspector become active.

Override set-level mappings and other parameters for a patch:
1. Select the patch you want to override the set-level mapping.
2. In the Screen Control Inspector, select the Override Set Mapping checkbox.

The Parameter Mapping section becomes active, so that you can map the parameter.
Key Concepts

- **Concert level:** Where you edit parameters and add and edit channel strips for the overall concert.

- **Set level:** Where you edit parameters and add and edit channel strips for a set.

- **Tempo:** A concert has only one tempo, which you can change by selecting a patch or set with a Change Tempo setting, by tapping a new tempo, or by using a screen control mapped to the Tap Tempo action.

- **Override:** By default, concert-level settings (including mappings and key ranges) take precedence over corresponding patch- or set-level settings. Set-level settings take precedence over corresponding settings for individual patches in the set. You can override the concert- or set-level settings for an individual patch (or set), so that its settings take precedence when it is selected.
Editing Concert Layouts

You visually arrange screen controls in the workspace to create your concert layout.

Each MainStage concert includes a layout. The layout is the visual arrangement of screen controls in the workspace and also contains information about which knobs, sliders, and other controls on your hardware devices control which screen controls.

You modify the layout of a concert in Layout mode. You can add and organize screen controls to match your music hardware, optimize your display size, and make assignments between controls on your MIDI hardware and the screen controls in your concert.

Screen controls are objects in a MainStage concert that correspond to the physical controls on your hardware devices. Screen controls can also display patch, parameter, and other information, or contain text or images.

You can add screen controls to a concert from the Screen Controls Palette and edit layout parameters from the Screen Control Inspector.
You can use three types of screen controls in a MainStage layout: panel controls, shelf controls, and grouped controls. In the Screen Controls Palette, each type has its own tab (the Panel Controls, Shelf Controls, and Grouped Controls tabs). Panel controls occupy a two-dimensional space, while shelf controls appear in three dimensions on an adjustable shelf.

**Adding Screen Controls**

If a concert you create from a template does not include screen controls for all the hardware controls you want to use, you can add screen controls to the workspace. You can also add screen controls to display patch, parameter, and system information.

**Try This**

**Switch to Layout mode:**
- If you are not in Layout mode, click the Layout button in the upper-left corner of the MainStage window to switch to Layout mode.

**Add a screen control:**
- Drag the screen control from the Screen Control Palette to the position you want it to occupy in the workspace. As you drag the screen control in the workspace, alignment guides appear, making it easier to align the screen control with other items in the workspace.

**Create a copy of a screen control:**
- Option-drag the screen control to a different part of the workspace.
Arranging Screen Controls
You can move and resize the screen controls to more closely match your hardware controls. You can align, distribute, and group screen controls to preserve your layout and edit their appearance in different ways.

Getting Ready
- Add some different screen controls to the workspace following the steps in the previous section, or open a concert with a variety of screen controls.

Try This
Move screen controls:
- Drag a screen control to a different location in the workspace.
- Shift-select a few screen controls, then move them together.
- “Rubber-band” multiple screen controls and move them together.

Resize a screen control:
1. Select a screen control in the workspace.
   Blue resize guides appear over the screen control.
2 Drag the blue resize guides to resize the screen control.

Resize the text display area of a screen control:
1 Select the screen control in the workspace.
2 Drag the inner resize guide to increase the area of the text display.
3 Drag the outer resize guide to increase the overall size of the control.
To mimic your hardware setup, you may want to arrange a series of screen controls so that they are aligned in the workspace. In Layout mode, the workspace features a palette of buttons to make it easy to align and distribute several selected screen controls.

**Note:** If there are overlapping controls when you switch from Layout mode to another mode, an alert appears, asking if you want to see the overlapping controls highlighted so you can adjust them.
Align selected screen controls:
- Click the Align Top button to vertically align the top edges of the screen controls.
- Click the Align Centers Vertical button to vertically align the centers of the screen controls.
- Click the Align Bottom button to vertically align the bottom edges of the screen controls.
- Click the Align Left button to horizontally align the left edges of the screen controls.
- Click the Align Centers Horizontal button to horizontally align the centers of the screen controls.
- Click the Align Right button to horizontally align the bottom edges of the screen controls.

Distribute selected screen controls evenly:
- Click the Distribute Vertical button to vertically distribute the screen controls.
- Click the Distribute Horizontal button to horizontally distribute the screen controls.
Adjust the angle of the shelf for a shelf control:
1 In the workspace, select the shelf control.
   White alignment guides for the control’s shelf appear.

2 Drag the lower alignment guide (the one aligned with the front of the shelf control) down to make the angle steeper (as though you are looking down on the shelf control from above), or drag it up to make the angle less steep (as though you are looking at it from the front).

Move a shelf vertically:
1 Select one of the screen controls on the shelf.
   The alignment guides for the shelf appear.
2 Place the pointer over the upper alignment guide (the one aligned with the rear of the shelf control).
   The pointer becomes a move pointer (a horizontal bar with up and down arrows).
3 Drag the upper alignment guide to move the shelf to a new position.
Grouping Screen Controls
You can group screen controls. When you group screen controls, you can move and resize them together. Grouped screen controls have a background that surrounds them. You can change the appearance of the background by choosing a panel or an image.

*Note:* You cannot group panel and shelf screen controls together or group screen controls on different shelves.

**Try This**
*Group screen controls:*
1. Arrange several screen controls that you want to group in the workspace.
2. Select the screen controls by Shift-clicking or “rubber-banding” them.
3. Click the Group button on the left edge of the workspace.

![Group button](image)

![Ungroup button](image)

The screen controls are grouped and appear surrounded by a background.

**Move a grouped control:**
- Drag any part of the grouped control.

**Resize a grouped control:**
- Click the background of the grouped control, then drag the dotted line around the grouped control to resize it.
Move or resize a member of a group independently:
- Holding down the Command key, move or resize the member of the grouped control.

When you are finished, release the Command key.

Change the background panel:
- In the Screen Control Inspector, click the Panel well and choose a new panel from the menu that appears.

Display an image in the background:
1. Select the Image button.
2. Do one of the following:
   - Drag an image to the Image well.
   - Click the Select button, select the image you want to use in the Open Image dialog, then click Choose Image.
Editing Layout Parameters
When you select a screen control in Layout mode, the parameters for the screen control appear in the Screen Control Inspector where you can edit them. Screen control parameters control the type of MIDI message received by the control, its appearance, and text display. Most screen controls share the same common parameters, while others have different parameters.

Try This
Edit screen control parameters:
1 Select a screen control in the workspace.
2 In the Screen Control Inspector, do any of the following:
   • In the Appearance section, click the Color pop-up menu and choose a different color for the active area of the screen control.
   • In the Text Labels section, click the Color pop-up menu and choose a different color for the screen control text. Click one of the Justify buttons to change text justification.

See the “Working in Layout Mode” chapter of the MainStage User Manual for detailed information about editing screen control parameters.
Customizing the MainStage Window
There are several ways you can customize the MainStage window to suit your way of working.

Try This

**Resize the workspace vertically:**
- Move the pointer to the space between the workspace and the Inspector, then drag up or down to resize the workspace.

**Resize the workspace horizontally:**
- Move the pointer to the space between the workspace and the Channel Strips area, then drag left or right to resize the workspace.

**Hide or show the Inspector:**
- Choose View > Inspectors (or press Command-5).

**Hide or show the Channel Strips area:**
- Choose View > Channel Strips (or press Command-6).
- In the toolbar, click the Channel Strips button.
Key Concepts

• Panel controls: Panel controls appear on a two-dimensional plane (or “panel”) in the workspace. You can move a panel control to any position in the workspace, except onto the shelf of a shelf control. Panel controls include knobs, faders, buttons, and drum pads.

• Shelf controls: When you add a shelf control, it appears on a three-dimensional shelf. You can move the shelf, adjust the angle of the shelf, and place multiple shelf controls on the same shelf. Shelf controls include keyboards, mod and pitch bend wheels, and foot pedals.

• Grouped controls: Grouped controls consist of individual controls that are grouped together to make them easier to work with as a single unit. You can create your own grouped controls and add them to the Screen Controls Palette.
Playing Back Audio

You can play back audio files while you are performing in MainStage and control playback in a variety of ways.

Playing back audio has several uses, including playing backing tracks to accompany your performance, playing song stems that you can mix live, and creating a virtual band that you can use to rehearse your performance.

You play back audio files using the Playback plug-in, which is available only in MainStage. The Playback plug-in supports several file formats, including AIFF, WAVE, and CAF. You can also play back files that include markers, including bounced files from Logic Pro projects and Apple Loops. When you use audio files that include markers with a Playback plug-in, you can use the markers to play back different parts of the audio file.

You can start and stop a Playback plug-in in real time as you perform and map screen controls to other Playback parameters to control them while you perform. The Screen Controls Palette includes a waveform screen control that you can use to view the audio waveform of the audio file for a Playback plug-in and a progress indicator that you can use with the Cycle feature of the Playback plug-in.
Adding a Playback Plug-in

The Playback plug-in is an instrument plug-in. You can use it in software instrument channel strips. You can add a Playback plug-in to a patch, a set, or at the concert level. Adding a Playback plug-in at the set level allows you to play the audio file while selecting and playing different patches in the set. Similarly, adding a Playback plug-in at the concert level allows you to play the audio file with every patch in the concert.

Try This

Add a Playback plug-in:

1. Select the item (the patch or set, or the concert icon) in which you want to use a Playback plug-in.
   The channel strips for the selected item appear in the Channel Strips area.

2. Drag the audio file you want to use between two existing channel strips in the Channel Strips area.
   A new software instrument channel strip is added between the existing channel strips.
   The new channel strip contains a Playback plug-in with the audio file added.
Using Playback Plug-in Parameters

The Playback plug-in includes several additional parameters that you can use in performance, including Return to Start, Cycle, Fade Out, and others. The controls for these parameters are located below the waveform display in the plug-in window. Because the Count In and Metronome parameters rely on the concert tempo, they are useful only when the Sync parameter is set to On.

When you add an audio file containing marker information, such as a bounced Logic Pro project or an Apple Loops file, you can shift playback to different parts of the audio file.
Getting Ready

- Be sure the Playback plug-in window is open.
- Add an audio file containing marker information to the Playback plug-in.

Try This

- Click the Play button to start playback, then click the Return to Start button (with the triangle pointing left) to start over from the beginning of the audio file.
- Start playback, then click the Cycle button (with the curved arrows) to loop playback of the audio file.
- Start playback, then click the Fade Out button (with the downward slope) to hear the sound fade out.
- If you are playing an audio file that contains marker information, start playback, then click the Go to Next Marker button (with the arrow pointing right) to move to the start of the next marker. Click the Go to Previous Marker button (with the arrow pointing left) to return to the previous marker.

To use the Playback parameters in performance, you can add screen controls to the workspace, then map the screen controls to the parameters on the Playback plug-in window.
Using the Sync Parameter
The Playback plug-in also includes a Sync parameter. For audio files containing tempo information, you can use the Sync parameter to control whether the audio file plays at its recorded tempo or at the current tempo of the concert. If you choose Off from the Sync pop-up menu, the audio file plays at its original tempo. If you choose On from the Sync pop-up menu, the audio file plays at the current tempo of the concert.

Try This
- Add an audio file containing tempo information to the Playback plug-in.
- Choose Off from the Sync pop-up menu, then start playback. Listen to the tempo of the audio file.
- Choose On from the Sync pop-up menu, then start playback again. Listen to whether the file plays back at the same tempo or a different tempo. With Sync set to On, change the tempo in the Patch Inspector.
- Click the Count In button (with the 1234 icon), then start playback. You hear four beats of the count-in before playback starts.
- Click the Metronome button (with the metronome icon), then start playback to hear the metronome sound a steady beat.

Note: If the audio file does not contain tempo information, Sync is set to off, and the Sync pop-up menu is unavailable.
Using the Group Parameter
The Group parameter is very useful when you have multiple instances of the Playback plug-in in a concert, and you want to control their playback relative to each other. By assigning multiple instances of the plug-in to a group, you can control transport and other functions of all members of the group simultaneously.

When you start playback for one group, all other groups stop playing. Changing the following parameters for one member of a group changes the corresponding parameter for all members of the group: Stop, Return to Start, Fade Out, Go to Previous Marker, or Go to Next Marker. You can change the following parameters for all members of a group by holding down the Shift key while editing the parameter for any group member: Cycle, Meter, Fade Time, Pitch, Sync, Snap To, or Play From.

When you change one of these functions for a group, ungrouped instances of the Playback plug-in are not affected.

Try This
1. Drag three different audio files between two existing channel strips in the Channel Strips area.
2. Choose A from the Group pop-up menu for two of the Playback plug-ins.
3. Choose B from the Group menu of the third Playback plug-in.
4. Click the Play button for one of the two plug-ins in Group A.
   The other plug-in in Group A starts, but the plug-in in Group B does not start.
5. Try using the Return to Start, Fade Out, and other parameters to see how they affect the plug-ins in Group A and the plug-in in Group B.
Key Concepts

- **Tempo information**: Information stored in an audio file that indicates the tempo at which it was recorded. Apple Loops and files exported from Logic Pro 9 contain tempo information that the Playback plug-in can use.

- **Sync**: Short for *synchronize*. The Sync parameter lets you control whether an audio file containing tempo information plays at its recorded tempo or at the current tempo of the MainStage concert.

- **Group**: Each instance of the Playback plug-in can be a member of a group (there are 26 possible groups, indicated by the letters A to Z). When you start playback of any member of a group, all members of the group start playing, and all other groups stop playing. You can stop playback of all members of a group and control other parameters, including Cycle, Fade Out, Go to Previous Marker, and Go to Next Marker, for all members of a group.
Now your concert is ready to go—it’s time to play.

This chapter includes some tips you can use when you play live with MainStage.

Before the Performance Starts
Here are a few things to check before you start performing:

• Make sure your MIDI controllers, instruments, microphones, and other music equipment are connected to your computer and are working.

• Select a patch with a software instrument channel strip and play your keyboard controller. Watch the Activity Monitor to verify that MainStage is receiving MIDI input from the controller, and make sure you can hear the audio output.

• Check to ensure that any instruments or microphones you plan to play through audio channel strips are connected to the correct audio inputs on your audio interface. Select a patch with an audio channel strip and play or sing to check whether you can hear audio output.

• For the best results, close any applications that you do not need while performing, particularly applications with high processor or RAM requirements.

• Make sure you are not connected to any wired or wireless networks.
Using Perform or Full Screen Mode

When you perform live, you can use either Perform mode or Full Screen mode, depending on which you prefer. Each mode offers some advantages for different performance situations. If you need to access other applications or access buttons in the toolbar, use Perform mode. If you want to view the workspace at maximum size on your display and do not need to access the Finder or the toolbar, use Full Screen mode.

Try This

Switch to Perform mode:
- Choose View > Perform (or press Command-3). Try practicing some of the songs you’ll perform, and see how you like working in Perform mode.

Switch to Full Screen mode:
- Choose View > Full Screen (or press Command-4). Try practicing some songs and see which mode you prefer to work in.

Exit Full Screen mode:
- Do one of the following
  - Press the Escape (Esc) key.
  - Click the circled “X” in the upper-left corner of the screen.
  - Use the key command for one of the other modes (Command-1 through Command-3).
Selecting Patches in Performance

In Full Screen or Perform mode, you can view and select patches using the selector screen control in your layout. Patches and sets appear in the selector in the same order as in the Patch List in Edit mode.

When you select a patch, you can start playing it instantly. If you are sustaining notes from the previous patch, they continue to be sustained until you release the notes or the sustain pedal. If the previous patch contains effects (such as a reverb or delay effect) with a release “tail,” the effect tail continues sounding for the amount of time set in the Silence Previous Patch pop-up menu in MainStage Preferences.

Try This

Select patches using key commands:

- Press Down Arrow to select the next patch in the selector. Do this several times to move through the patches in the selector.
- Press Up Arrow to select the previous patch. Do this several times until you return to the first patch in the selector.
- Press Command–Right Arrow to select the first patch in the next set.
- Press Command–Left Arrow to select the first patch in the previous set.
Using the Tuner

If you play guitar or another instrument using audio channel strips, you can use the built-in Tuner to tune your instrument while you are performing.

Try This

**Tune an instrument using the Tuner:**

1. Select the audio channel strip to which the instrument you want to tune is connected.
   
   **Note:** The Tuner only works on the first audio instrument in a patch. Channel strips that can use the Tuner are indicated by a tuning fork icon near the top of the channel strip.

2. Click the Tuner icon in the toolbar (or press Command-T).

   The Tuner appears in the workspace.

3. Play a single note on your instrument, and watch the Tuner display.

   As you play, the Tuner shows the note name of the closest note. If the note is not in tune, red vertical bars appear on the left or right side of the Tuner, showing whether the note is sharp or flat.

4. Adjust the tuning peg for the string you are tuning until the only vertical bar appears in the center and is blue in color.
Silencing MIDI Notes or Audio Output
You can use the MIDI Panic function to quickly silence all MIDI notes and reset the audio engine or use Master Mute to silence all audio output.

Try This
Silence all MIDI notes:
- Press Control-P. You can also silence MIDI notes by clicking the Panic button in the toolbar or by using a hardware control assigned to a screen control that is mapped to the Panic action.

Mute all audio output:
- Press Control-M. You can also mute audio output by clicking the Master Mute button or by using a hardware control assigned to a screen control that is mapped to the Master Mute action.
- Press Control-M again to unmute all audio output.
Getting Answers

There are additional resources to get answers to your questions about using MainStage.

Use MainStage Help and Logic Studio Help to find the answers you need.

Exploring MainStage Help
MainStage Help provides in-depth descriptions and instructions about the features and controls (the tasks you can perform) with MainStage.

Try This
Open the MainStage User Manual:
- In MainStage, choose Help > MainStage Help, then click MainStage 2 User Manual.

Open the Logic Studio Effects guide:
- In MainStage, choose Help > MainStage Help, then click Logic Studio Effects.

Open the Logic Studio Instrument guide:
- In MainStage, choose Help > MainStage Help, then click Logic Studio Instruments.
Search for a specific topic that interests you:
- Enter the topic you want to find in the Search field at the top of the Help Viewer window. Select topics from the search results that you want to learn about.

When you search in the MainStage manual, the search results include relevant topics from the *Logic Studio Effects* and *Logic Studio Instruments* guides as well.

Search for Apple Support information:
- Choose Help > MainStage Help, then click MainStage Support. Browse topics that interest you.

Read discussions on the MainStage forum:
- Choose Help > MainStage Help, then click MainStage Discussions in the list of additional resources. Browse discussion topics that interest you.

**What’s Next?**
You’ve now had a brief introduction to MainStage and a selection of its features. You can continue to experiment with the included templates and patches or edit them to create your own. Refer to MainStage Help for the in-depth information you need.