Copyright © 2009 Apple Inc. All rights reserved.

Your rights to the software are governed by the accompanying software license agreement. The owner or authorized user of a valid copy of Logic Studio software may reproduce this publication for the purpose of learning to use such software. No part of this publication may be reproduced or transmitted for commercial purposes, such as selling copies of this publication or for providing paid for support services.

The Apple logo is a trademark of Apple Inc., registered in the U.S. and other countries. Use of the “keyboard” Apple logo (Shift-Option-K) for commercial purposes without the prior written consent of Apple may constitute trademark infringement and unfair competition in violation of federal and state laws.

Every effort has been made to ensure that the information in this manual is accurate. Apple is not responsible for printing or clerical errors.

Note: Because Apple frequently releases new versions and updates to its system software, applications, and Internet sites, images shown in this manual may be slightly different from what you see on your screen.

Apple
1 Infinite Loop
Cupertino, CA 95014
408-996-1010
www.apple.com

Apple, the Apple logo, FireWire, Logic, Logic Studio, MainStage, QuickTime, and WaveBurner are trademarks of Apple Inc., registered in the U.S. and other countries.

Other company and product names mentioned herein are trademarks of their respective companies. Mention of third-party products is for informational purposes only and constitutes neither an endorsement nor a recommendation. Apple assumes no responsibility with regard to the performance or use of these products.
Contents

Preface 5  An Introduction to Using TDM Hardware in Logic Pro
  5  About Logic Pro TDM Support
  6  About the Logic Pro Documentation
  6  Additional Resources

Chapter 1 9  TDM Audio Hardware and Drivers
  9  Choosing a DAE or Direct TDM Device
  9  DAE Settings
  11  Direct TDM Settings

Chapter 2 13  About TDM
  13  How TDM Differs from Native Processing
  14  TDM Plug-ins
  15  Using TDM-Specific Functions
  15  Simultaneous Use of TDM and Other Hardware

Chapter 3 17  ESB TDM and EXS24 TDM
  17  About the ESB TDM and EXS24 TDM Plug-ins
  18  Using EXS24 TDM
  19  Using ESB TDM

Chapter 4 23  Logic Pro TDM Usage Tips and Tricks
  23  Importing Native Projects into a TDM System
  24  System Performance and TDM DSP Usage
  25  DAE and Direct TDM Bounce Strategies
An Introduction to Using TDM Hardware in Logic Pro

Earlier Digital Audio Workstations (DAWs) took one of two approaches to audio signal processing: The use of dedicated hardware DSPs (such as in TDM systems), or the native processing capabilities of the computer CPU.

Logic Pro enables you to use both your TDM system DSPs and the computer’s native CPU processing resources. The link between the DSP world of your TDM system, and your computer’s native CPU processing resources is ESB TDM.

This preface covers the following:

- About Logic Pro TDM Support (p. 5)
- About the Logic Pro Documentation (p. 6)
- Additional Resources (p. 6)

About Logic Pro TDM Support
Logic Pro provides access to many of the TDM functions supported by Pro Tools HD systems. Time Division Multiplexing (TDM) is the time-interlaced transmission of multiple digital audio signals (or streams) through a single data bus. This bus system is physically isolated from the computer system bus, and runs between individual TDM-capable cards. Up to 512 digital audio channels, each with 24-bit resolution, can be transmitted on the TDM bus. These streams form signal paths within a virtual mixer. These signal paths are necessary for the insertion of plug-ins, which are calculated on the DSP hardware, and routed into the individual channels, or are selected through auxiliary busses.
About the Logic Pro Documentation
Logic Pro comes with various documents that will help you get started as well as provide detailed information about the application.

• Logic Pro User Manual: The onscreen user manual is a comprehensive document that describes the Logic Pro interface, commands, and menus and gives step-by-step instructions for creating Logic Pro projects and for accomplishing specific tasks. It is written for users of all levels of experience. The user manual is available in Logic Pro Help (in Logic Pro, choose Help > Logic Pro).

• Exploring Logic Pro: This booklet presents the basics of Logic Pro in an easy, approachable way. Each chapter presents major features and guides you in trying things out. A PDF version of the printed manual is available in Logic Pro Help. You can also open the PDF directly in Logic Pro by choosing Help > Exploring Logic Pro).

• Logic Pro Control Surfaces Support: This onscreen manual describes the configuration and use of control surfaces with Logic Pro.

• Logic Pro TDM Guide: This onscreen manual describes the essential aspects of using TDM in Logic Pro.

• Logic Studio Instruments: This onscreen manual provides comprehensive instructions for using the powerful collection of instruments included with Logic Pro and MainStage.

• Logic Studio Effects: This onscreen manual provides comprehensive instructions for using the powerful collection of effects included with Logic Pro, MainStage, and WaveBurner.

• Logic Studio Working with Apogee Hardware: This onscreen manual describes the use of Apogee hardware with Logic Pro.

Additional Resources
Along with the documentation that comes with Logic Studio, there are a variety of other resources you can use to find out more.

Release Notes and New Features Documents
Each application offers detailed documentation that covers new or changed features and functions. This documentation can be accessed in the following location:

• Click the Release Notes and New Features links in the application Help menu.

Logic Pro Website
For general information and updates, as well as the latest news on Logic Pro, go to:

• http://www.apple.com/logicstudio/logicpro
Apple Service and Support Websites
For software updates and answers to the most frequently asked questions for all Apple products, go to the general Apple Support webpage. You'll also have access to product specifications, reference documentation, and Apple and third-party product technical articles.

• http://www.apple.com/support

For software updates, documentation, discussion forums, and answers to the most frequently asked questions for Logic Pro, go to:

• http://www.apple.com/support/logicpro

For discussion forums for all Apple products from around the world, where you can search for an answer, post your question, or answer other users' questions, go to:

• http://discussions.apple.com
To use Logic Pro with your TDM system, you require Pro Tools HD 7.4 or later.

This chapter covers the following:
- Choosing a DAE or Direct TDM Device (p. 9)
- DAE Settings (p. 9)
- Direct TDM Settings (p. 11)

Choosing a DAE or Direct TDM Device
Selecting and activating a particular audio hardware device is done in the Logic Pro > Preferences > Audio > Devices pane. You can choose between the Core Audio, DAE, and Direct TDM tabs.

- **Core Audio:** The Core Audio tab is used to activate and adjust audio hardware devices that use Core Audio drivers. Full details on Core Audio device settings are found in the *Logic Pro User Manual*.

- **DAE:** DAE is the abbreviated form of Digidesign Audio Engine. This is the driver software used to access TDM hardware—including use of on-board DSP chips—in Logic Pro.

- **Direct TDM:** The Direct TDM audio engine of Logic Pro is used to process the DTDM Mixer—which you can route into the (aux channel strip) inputs of the TDM Mixer. This allows use of your computer’s CPUs to process Logic Studio and Audio Units instruments and effects, while also using the DAE.

DAE Settings
DAE parameters can only be set after activating the DAE. Click the Enabled checkbox at the top left of the DAE tab to access to the following parameters:
**Note:** You need to restart Logic Pro to activate the DAE.

- **Global Bit Depth pop-up menu:** Choose between 16-bit or 24-bit playback and recording. **Note:** DAE does not allow the use of 16- and 24-bit files simultaneously.
- **PT HD Type pop-up menu:** Defines the number of tracks for your Pro Tools HD system. Each menu item allows you to define the required number of tracks, based on the number of Pro Tools HD DSPs that you want to use (and actually have) in your system.
- **“TDM setup indicator” checkbox:** Enables or disables the display of a small status window that shows the current TDM process (inserting a TDM plug-in, for example).
- **Pass Keyboard Events to Plug-ins pop-up menu:** Computer keyboard events (keystrokes) that are not used by a plug-in are passed on to Logic Pro. Under normal conditions, this ensures that Logic Pro functions like Start and Stop will continue to work. If this isn’t the case, use the options in this menu to specify certain computer keyboard sections, which will be passed to the plug-in. All other computer keyboard events will be received by Logic Pro.
• *Digidesign Hardware Setup button:* Opens the Digidesign Hardware Setup window that contains all important system settings for your hardware.

**Note:** The Process Buffer Range and ReWire Behavior parameters at the bottom of the Devices pane have no effect when DAE is active.

**Direct TDM Settings**
Activate Direct TDM if you want to use your computer CPUs to process Logic Studio instruments and effects, while also using the TDM features.

- *Enabled checkbox:* Click to activate Direct TDM.
- *Universal Track Mode checkbox:* Activate to enable playback of stereo and mono regions on a single track. Even-numbered audio channels are not regarded as the right channels of the odd-numbered stereo audio channel to their left. Every audio channel has its own Format button.
Depending on whether a mono or stereo region is played back, the Pan knob will behave as either a Balance or Pan control. If you play back a mono region when the Pan knob is centered, both channels of the audio channel strip will output the same signal level.

**Note:** Universal Track Mode has limited routing capabilities, as it doesn’t allow separate handling of the left and right audio channels. The Non-Universal Track Mode is useful if you need to play different mono files for the left and right (mono) channels of a single audio channel strip, even when it is assigned as a stereo channel. A stereo input and stereo output plug-in inserted into this stereo channel receives different signals for the left and right channels.
Logic Pro allows you to use the TDM functions of Pro Tools HD systems. TDM is an abbreviation for *Time Division Multiplexing*—the time-interlaced transmission of multiple digital audio signals (or streams) through a single data bus. This bus system is physically isolated from the computer system bus, and runs between the individual TDM-capable (PCI or PCIe) cards.

Up to 512 digital audio channels, each with 24-bit resolution, can be transmitted on the TDM bus. These streams form the signal paths within a virtual mixer. These signal paths are necessary for the insertion of plug-ins, which are calculated on the DSP hardware, and routed into the individual channels, or are selected through auxiliary busses.

Logic Pro allows you to use both your TDM system DSPs and the computer’s native CPU processing resources. The link between the DSP world of your TDM system, and your computer’s native CPU processing resources is ESB TDM. See ESB TDM and EXS24 TDM.

**Note:** It should be noted that the TDM channel count is sample-rate dependent, so if a rate of 88.2 or 96 kHz is used, the 512 channels available to a Pro Tools HD system will be halved to 256. At a sample rate of 192 kHz, this will again be halved to 128.

This chapter covers the following:

- How TDM Differs from Native Processing (p. 13)
- TDM Plug-ins (p. 14)
- Using TDM-Specific Functions (p. 15)
- Simultaneous Use of TDM and Other Hardware (p. 15)

**How TDM Differs from Native Processing**

Using Logic Pro with a TDM or native processing system is quite similar. Here is an overview of the main differences between the two systems:

- In a TDM system, all audio processing is done by the DSP chips of the TDM hardware. This means that “native” Logic Studio or Audio Units plug-ins cannot run on the TDM DSPs. TDM plug-ins, however, can be fully used and automated.
• The TDM hardware determines the overall features of the system: number of tracks, number of TDM plug-ins that can be used simultaneously, number of inputs and outputs, and so on. See your Pro Tools system manuals for further information.

• Stereo recordings require two tracks, and are recorded as two separate files. In Logic Pro’s Arrange window, a stereo recording is handled as two linked regions, which use two tracks. In the Sample Editor window, stereo recordings are displayed as a stereo file. All odd-numbered audio channels (1, 3, 5, 7, and so on) can be switched to stereo. Doing so will cause the following even-numbered audio channels to be “locked” to the preceding odd-numbered channels. The odd-numbered channel controls both sides of the stereo recording.

• DAE (Digidesign Audio Engine) does not support the QuickTime engine, which prevents you from using the Logic Pro movie facilities if you are working exclusively with the DAE. Activate Core Audio or Direct TDM to use the movie facilities when working with the DAE.

TDM Plug-ins
Correctly installed TDM plug-ins and settings can be used in Logic Pro. Use of TDM plug-ins is very similar to the use of Logic Studio and Audio Units plug-ins. TDM plug-ins can be fully automated.

Note: Logic Pro does not support TDM Surround and multi mono plug-ins with two or more channels.

All TDM plug-in settings are saved with the project, and are automatically restored when the project is next loaded.

Logic Pro can read the Digidesign format for plug-in settings (the supplied settings of most plug-ins are saved in this format). Logic Pro automatically displays the corresponding files in a dialog when loading settings with the plug-in window Settings menu. Settings files are usually located in a Settings folder in the Library/Application Support/Digidesign folder. The name of the most recently chosen setting is indicated by a dot in the plug-in window Settings menu.

Support of TDM Plug-in Side Chains
You can select a different source for the side chain input (or key input) in some TDM plug-ins—Compressors, Noise Gates, Vocoders, and so on. All tracks, busses, or inputs can be used as a side chain input source.

RTAS Plug-ins
RTAS plug-ins cannot be used in Logic Pro. Only Audio Units, TDM, and Logic Studio plug-ins are supported.
If you currently own any RTAS plug-ins, you should install the Audio Units equivalents for use in Logic Pro. Most plug-ins are available in several formats.

If no Audio Units version is available on your RTAS plug-in installation CDs, visit the websites of the plug-in manufacturers.

**Using TDM-Specific Functions**

Note the following if you want to use your hardware’s TDM functions with Logic Pro.

- **TDM Mixer Plug-in:** Ensure that the Plug-ins folder (found inside the DAE folder) contains only one Mixer plug-in; either the Stereo Mixer or the Stereo Dithered Mixer.

  You may also have one of the Surround Mixer plug-ins in the folder, but these Mixer plug-ins have no function in Logic Pro.

- **Changing Global Bit Depth:** When TDM hardware is being used, Logic Pro will ask whether you want to use 16- or 24-bit depth, when first opened. You can change the Global Bit Depth in the Logic Pro > Preferences > Audio > Devices > DAE tab at any time.

- **Sample Editor:** All Sample Editor functions work with 16- and 24-bit audio files. You can exchange audio material between 16- and 24-bit files when using Direct TDM, with the Copy and Paste commands.

  *Note:* AudioSuite plug-ins are supported at 16- and 24-bit depth, if using DAE.

**Simultaneous Use of TDM and Other Hardware**

Note the following if you wish to use a TDM system and other audio hardware simultaneously.

**Controlling the Prelisten Device in a TDM System**

Logic Pro’s Audio Bin, Browser, and Sample Editor windows allow you to choose the playback hardware unit. Control-click (or right-click) the Prelisten button, and choose a device from the shortcut menu:

- If you choose Core Audio, an additional audio channel strip (named Prelisten) is created automatically in the Mixer (and Environment), and used for playback.

- If you choose DAE, the highest-numbered audio channel strip (possible with your configuration) is used for playback. Note that this channel may be assigned to an Arrange window track when you use the Create Track functions.

**Total Number of Audio Tracks in a TDM System**

When operating different audio hardware devices simultaneously, the number of possible playback tracks cannot be determined by merely adding them together. This is especially true if the connected systems place a strain on the CPU.
The number of tracks may also be reduced if the connected systems access the same hard disk bus. This can be mitigated (resulting in an increase in the total track number) by using different hard drives for the various systems. For example, the audio data for a Direct TDM or Core Audio device, and a QuickTime movie are read from an internal hard disk, and audio data for a DAE device is read from an external FireWire hard disk.
Logic Pro allows you to use both your TDM system DSPs and the computer’s native CPU processing resources. The link between the DSP world of your TDM system and your computer’s native CPU processing resources is ESB TDM.

ESB TDM uses your computer CPU to process one audio engine (Direct TDM), and the DSP of the TDM hardware to process another (DAE). This is done by using two different mixers in Logic Pro. The TDM Mixer uses the DAE to process TDM plug-ins. The DTDM Mixer uses the computer CPU (Direct TDM) to process Logic Studio and Audio Units plug-ins.

Up to eight DTDM Mixer outputs can be configured as ESB TDM outputs, which can be routed in to the TDM Mixer. The DTDM Mixer outputs (ESB TDM outs) are received by the ESB TDM inputs—which are available as sources in the input slot pop-up menus of TDM Mixer aux channel strips.

This enables all Logic tracks, Logic Studio plug-ins, and Audio Units plug-ins—including software instruments—to be used in conjunction with your TDM system DSPs.

This chapter covers the following:

- About the ESB TDM and EXS24 TDM Plug-ins (p. 17)
- Using EXS24 TDM (p. 18)
- Using ESB TDM (p. 19)

**About the ESB TDM and EXS24 TDM Plug-ins**

The ESB TDM and EXS24 TDM plug-ins enhance TDM system functionality by expanding the capabilities of the TDM Mixer. If working at 44.1 or 48 kHz sample rates, up to 32 additional channels are available. These extra channels can be used for multiple EXS24 TDM sampler instances, and up to eight inputs routed from the DTDM Mixer—which uses the native audio engine (Direct TDM), running in parallel with the DAE.
The ESB TDM plug-in allows you to route up to eight audio channels of the DTDM Mixer \textit{in} to the DSP-based TDM Mixer. This is similar to having a card equipped with a multi-channel digital output installed in the computer, and physically connected to a second multi-channel input module for your TDM system. ESB TDM routes digital signals via software within the computer, effectively replacing the audio card’s digital outputs and driver, the TDM audio interface, and the cables between them.

In situations where you want to use both the Logic Pro native audio system (Direct TDM) and your TDM system, see \textit{Using ESB TDM}.

The EXS24 TDM plug-in allows up to 32 mono or 16 stereo EXS24 mkII sampler instances to be inserted in the top insert slots of aux channel strips in the TDM Mixer. Ensuing insert slots in the aux channel strip, and further TDM Mixer routing options, allow the sampler output signals to be processed with TDM effect plug-ins.

If you want to process the output signals of (up to 32) EXS24 TDM samplers with TDM effect plug-ins exclusively, see \textit{Using EXS24 TDM}. When using the EXS24 TDM exclusively, there is no need to activate Direct TDM in addition to the DAE (unless you need to use the movie facilities of Logic Pro).

\textit{Note:} EXS24 TDM is available as a mono or stereo plug-in, but not as a multi output plug-in.

\textbf{Using EXS24 TDM}

If no aux channel strips exist in your TDM Mixer, you can create them in your project.

\textbf{To create TDM channel strips that are displayed in both the Mixer and the Arrange window}

1. Open the New Tracks dialog by doing one of the following.
   - Click the New Tracks button.
   - Choose Track > New in the Arrange window or use Option-Command-N.

2. In the New Tracks dialog, make sure that the Auxiliary (for EXS24 TDM) button is active.

3. Choose other settings (number of tracks, and so on) as needed.

4. Click Create.
To insert the EXS24 TDM

- Click the top Insert slot of an aux channel strip in the TDM Mixer, and choose EXS24 TDM from the pop-up menu.

To play the EXS24 TDM sampler inserted in the aux channel strip

- Select the corresponding aux track in the Arrange window.

When the track is selected, you will be able to play and record the sampler instance. Subsequent insert slots in the aux channel strip allow the insertion of TDM effect plug-ins, for processing of the sampler’s output signal. Further TDM Mixer processing options such as sends to effect busses and output routings behave as per usual.

**Note:** The input routing parameter has no effect, as is the case when using TDM instruments such as Virus TDM.

**Using ESB TDM**

ESB TDM allows the outputs of the DTDM Mixer—processed by the computer CPUs (Direct TDM audio engine)—to be routed in to the input slots of TDM Mixer aux channel strips. This enables you to process Logic Pro audio tracks and Logic Studio or Audio Units instruments with TDM-based effects.

**Note:** Direct TDM must be activated in the Logic Pro > Preferences > Audio > Devices pane if you want to route signals from the DTDM Mixer into the TDM Mixer. See Direct TDM Settings.
Depending on the number of required channel strip types, your DTDM Mixer could look something like this:

This DTDM Mixer example features six audio channel strips, two aux channel strips, two instrument channel strips, and two stereo sums. The eight output signals of the DTDM Mixer example shown above are routed into the TDM Mixer. The DTDM Mixer output signals are received by the ESB TDM inputs—chosen as TDM aux channel strip input sources.

**To configure and choose ESB TDM sources**

1. Set up mono (ESB 1–8) or stereo (ESB 1–2, 3–4, 5–6, and 7–8) DTDM Mixer output channels.

2. Choose one of the available input sources for each TDM Mixer aux channel strip.

The following example shows ESB TDM sources in the input slots of TDM Mixer aux channel strips 1–8:
ESB TDM Mono and Stereo Handling
Logic Pro handles ESB TDM mono and stereo channel settings separately. You can specify either a mono output channel (ESB 1–8), or a stereo output channel pair (ESB 1–2, 3–4, 5–6, and 7–8) in the DTDM Mixer.

These can be individually selected as aux channel strip input sources in the TDM Mixer.

To create mono and stereo ESB TDM template projects
1 Set up mono DTDM Mixer output channels (ESB 1–8), and choose them as input sources for each TDM Mixer aux channel strip, then save your project as a template.
2 Set up stereo DTDM Mixer output channels (ESB 1–2, 3–4, 5–6, and 7–8), and choose them as input sources for each TDM Mixer aux channel strip, then save your project as a template.

Choose the appropriate template to quickly switch between mono and stereo setups, without needing to manually change settings each time.
This section provides tips and tricks that may be useful when using Logic Pro with TDM hardware.

As a general working suggestion, you should avoid the simultaneous use of more than two audio engines in Logic Pro. The strain on the PCI bus can be problematic, resulting in a number of DAE error messages.

Your first choice should be the DAE—in conjunction with Direct TDM. If necessary, choose DAE and Core Audio.

This chapter covers the following:

• Importing Native Projects into a TDM System (p. 23)
• System Performance and TDM DSP Usage (p. 24)
• DAE and Direct TDM Bounce Strategies (p. 25)

**Importing Native Projects into a TDM System**

If you want to use the native processing capabilities of Logic Pro with the project, start Logic Pro—with the Digidesign Core Audio driver activated.

You will be asked if you'd like an automatic conversion if the project was created on a non-Core Audio system, provided that the Universal Track Mode setting is the same on both systems.

You should be mindful of problems that can occur, due to plug-in incompatibilities and settings that differ between the source and target systems.

If you want to use TDM plug-ins and instruments with the project, you need to load the project into a DAE/Direct TDM system.

**To load a project that originated on a Core Audio system into a DAE/Direct TDM system**

1. Deactivate DAE and ensure that Direct TDM is active.

2. Ensure that the Universal Track Mode setting is the same for both Core Audio (on the project source system) and Direct TDM on your system.
3. Open the project. You will be asked if you'd like it automatically converted to Direct TDM. Logic Pro loads the project into a DTDM Mixer, and checks if there is a channel strip available for every hardware channel. If not, a suitable number of channel strips is automatically created in the DTDM Mixer. This facility ensures that changes to the hardware in a given computer, or moving project data to another computer (with different hardware), will result in corresponding channel strip changes. EQ, effect, and send settings are maintained for each channel.

If plug-ins used in the project differ between the source and target computers, unavailable plug-ins are dimmed in the Insert slots of affected channel strips. You need to manually replace dimmed plug-ins with plug-ins available on the target computer.

4. When the converted project has loaded, reactivate the DAE.
   
   **Note:** You will need to reopen Logic Pro after activating the DAE.

5. Reopen Logic Pro and open the converted project.

   All DTDM Mixer track outputs are routed to one of the ESB outputs.

6. Create the required number of aux channel strips in the TDM Mixer.

7. Choose ESB output sources (ESB 1–8 or ESB 1–2, 3–4, 5–6, and 7–8) in the Input slot(s) of the TDM Mixer aux channel strip(s).

**System Performance and TDM DSP Usage**

The Logic Pro System Performance window doesn't reflect any native processing via the DAE—which may be caused by the insertion of numerous EXS24 TDM instruments.

You can check the DSP load in the TDM DSP Usage window (Options > Audio > Open TDM DSP Usage).
DAE and Direct TDM Bounce Strategies

The easiest way to perform a stereo bounce is to choose File > Bounce (or use the Toolbar Bounce button or key command). This will open the Bounce dialog for outputs 1-2 of your primary audio device. It is recommended that you use the first output pair for main playback duties.

Note: If you are using other output channel strips for primary playback duties, click the Bounce button on these channels.

You can set the file format, bit depth, and sample rate of the bounce file in the Bounce dialog. Detailed information on all bounce parameters is found in the Logic Pro User Manual.

DAE
You can perform real-time bounces in mono, stereo, and all surround formats supported by Logic Pro. Offline bounces are not possible when you use DAE.

Keep in mind that none of the TDM surround features are available in Logic Pro.

Direct TDM
If using the DTDM Mixer output channels, all offline and real-time bouncing features are available.