## Contents

### Preface
12 Welcome to the *Keynote User’s Guide*

### Chapter 1
14 **Keynote Tools and Techniques**
14 About Themes and Master Slides
16 The Keynote Window
18 Zooming In or Out
18 Changing Views
18 Navigator View
19 Outline View
20 Light Table View
20 Jumping to a Particular Slide
21 The Toolbar
22 The Format Bar
23 The Inspector Window
24 The Media Browser
24 The Colors Window
24 The Font Panel
25 The Warnings Window
25 Keyboard Shortcuts and Shortcut Menus

### Chapter 2
26 **Working with a Keynote Document**
26 Creating or Opening a Slideshow
26 Creating a New Keynote Document
27 Importing a Slideshow
27 Opening an Existing Keynote Document
27 Saving Documents
28 Saving a Document
29 Undoing Changes
29 Saving a Copy of a Document
29 Automatically Saving a Backup Version of a Document
30 Saving a Document as a Theme
30 Saving Search Terms for a Document
30 Closing a Document Without Quitting Keynote
30 Adding, Deleting, and Organizing Slides
31 Adding Slides
31 Reordering Slides
31 Grouping Slides
32 Deleting Slides
32 Skipping Slides
33 Adding Slide Numbers
33 Using Comments
34 Copying or Moving Items Among Slides
34 Changing a Slide’s Theme, Master, or Layout
35 Changing the Theme
35 Using Multiple Themes
35 Applying a New Master to a Slide
36 Changing a Slide’s Layout
37 Making the Same Change on Multiple Slides

Chapter 3
38 Working with Text
38 Adding Text
39 Selecting Text
40 Deleting, Copying, and Pasting Text
40 Formatting Text Size and Appearance
41 Using the Format Menu to Format Text
41 Making Text Bold or Italic Using the Menus
41 Creating Outlined Text Using the Menus
41 Underlining Text Using the Menus
41 Changing Text Size Using the Menus
42 Making Text Subscript or Superscript Using the Menus
42 Changing Text Capitalization Using the Menus
42 Using the Font Panel to Format Text
43 Tips for Organizing Fonts
44 Changing Fonts Using the Font Panel
44 Changing Underlining Using the Font Panel
45 Adding a Strikethrough to Text Using the Font Panel
45 Changing Text Color Using the Font Panel
45 Changing the Paragraph Background Color Using the Font Panel
45 Creating Shadows on Text Using the Font Panel
46 Changing the Font Used in Outline View
46 Adding Accents and Special Characters
46 Adding Accent Marks
47 Viewing Keyboard Layouts for Other Languages
47 Typing Special Characters and Symbols
48 Using Smart Quotes
<table>
<thead>
<tr>
<th>Page</th>
<th>Topic</th>
</tr>
</thead>
<tbody>
<tr>
<td>49</td>
<td>Using Advanced Typography Features</td>
</tr>
<tr>
<td>49</td>
<td>Adjusting Font Smoothing</td>
</tr>
<tr>
<td>50</td>
<td>Setting Text Alignment, Spacing, and Color</td>
</tr>
<tr>
<td>50</td>
<td>Using the Text Inspector to Manage Alignment, Spacing, and Color</td>
</tr>
<tr>
<td>51</td>
<td>Aligning Text Horizontally</td>
</tr>
<tr>
<td>51</td>
<td>Aligning Text Vertically</td>
</tr>
<tr>
<td>51</td>
<td>Adjusting the Spacing Between Lines of Text</td>
</tr>
<tr>
<td>52</td>
<td>Adjusting the Spacing Before or After a Paragraph</td>
</tr>
<tr>
<td>53</td>
<td>Adjusting the Spacing Between Characters</td>
</tr>
<tr>
<td>53</td>
<td>Changing Text Color Using the Text Inspector</td>
</tr>
<tr>
<td>53</td>
<td>Setting Tab Stops to Align Text</td>
</tr>
<tr>
<td>54</td>
<td>Setting a New Tab Stop</td>
</tr>
<tr>
<td>54</td>
<td>Changing a Tab Stop</td>
</tr>
<tr>
<td>55</td>
<td>Deleting a Tab Stop</td>
</tr>
<tr>
<td>55</td>
<td>Setting Indents</td>
</tr>
<tr>
<td>56</td>
<td>Setting Indents for Paragraphs</td>
</tr>
<tr>
<td>56</td>
<td>Changing the Inset Margin of Text in Objects</td>
</tr>
<tr>
<td>56</td>
<td>Setting Indents for Lists</td>
</tr>
<tr>
<td>56</td>
<td>Using Bulleted, Numbered, and Ordered Lists (Outlines)</td>
</tr>
<tr>
<td>56</td>
<td>Generating Lists Automatically</td>
</tr>
<tr>
<td>57</td>
<td>Using Bulleted Lists</td>
</tr>
<tr>
<td>57</td>
<td>Using Numbered Lists</td>
</tr>
<tr>
<td>58</td>
<td>Using Ordered Lists (Outlines)</td>
</tr>
<tr>
<td>59</td>
<td>Using Text Boxes and Shapes to Highlight Text</td>
</tr>
<tr>
<td>59</td>
<td>Adding Free Text Boxes</td>
</tr>
<tr>
<td>60</td>
<td>Presenting Text in Columns</td>
</tr>
<tr>
<td>60</td>
<td>Putting Text Inside a Shape</td>
</tr>
<tr>
<td>61</td>
<td>Formatting a Text Box or Shape</td>
</tr>
<tr>
<td>61</td>
<td>Using Hyperlinks</td>
</tr>
<tr>
<td>62</td>
<td>Linking to a Webpage</td>
</tr>
<tr>
<td>62</td>
<td>Linking to a Preaddressed Email Message</td>
</tr>
<tr>
<td>63</td>
<td>Linking to a Slide</td>
</tr>
<tr>
<td>63</td>
<td>Linking to a Keynote File</td>
</tr>
<tr>
<td>64</td>
<td>Using a Hyperlink to Stop a Slideshow</td>
</tr>
<tr>
<td>64</td>
<td>Underlining Hyperlink Text</td>
</tr>
<tr>
<td>64</td>
<td>Automatically Substituting Text</td>
</tr>
<tr>
<td>65</td>
<td>Inserting a Nonbreaking Space</td>
</tr>
<tr>
<td>65</td>
<td>Checking for Spelling Mistakes</td>
</tr>
<tr>
<td>65</td>
<td>Finding Misspelled Words</td>
</tr>
<tr>
<td>66</td>
<td>Working with Spelling Suggestions</td>
</tr>
<tr>
<td>67</td>
<td>Finding and Replacing Text</td>
</tr>
</tbody>
</table>
Chapter 4 Working with Sound, Movies, Graphics, and Other Objects
68 Selecting Objects
68 Copying or Duplicating Objects
69 Deleting Objects
69 Moving Objects
70 Moving an Object Forward or Backward (Layering Objects)
70 Aligning Objects
70 Aligning Objects on a Slide Relative to One Another
71 Spacing Objects Evenly on a Slide
71 Using Alignment Guides
71 Creating Your Own Alignment Guides
72 Using Master Gridlines
72 Setting Precise Positions of Objects
73 Modifying Objects
73 Resizing Objects
74 Flipping and Rotating Objects
74 Changing the Style of Borders
75 Framing Objects
76 Adding Shadows
77 Adding a Reflection
77 Adjusting Opacity
78 Grouping and Locking Objects
78 Grouping and Ungrouping Objects
79 Locking and Unlocking Objects
79 Filling Objects
79 Filling an Object with Color
80 Using the Colors Window
81 Filling an Object with an Image
82 Using Shapes
82 Adding a Predrawn Shape
83 Adding a Custom Shape
84 Making Shapes Editable
84 Manipulating Points of a Shape
85 Reshaping a Curve
85 Reshaping a Straight Segment
85 Transforming Corner Points into Curved Points and Vice Versa
86 Editing Specific Predrawn Shapes
86 Editing a Rounded Rectangle
86 Editing Single and Double Arrows
87 Editing a Star
87 Editing a Polygon
88 Using Media Placeholders
89 Working with Images
<table>
<thead>
<tr>
<th>Page</th>
<th>Content</th>
</tr>
</thead>
<tbody>
<tr>
<td>89</td>
<td>Importing an Image</td>
</tr>
<tr>
<td>90</td>
<td>Masking (Cropping) Images</td>
</tr>
<tr>
<td></td>
<td>Cropping an Image Using the Default (Rectangular) Mask</td>
</tr>
<tr>
<td>91</td>
<td>Masking an Image with a Shape</td>
</tr>
<tr>
<td>91</td>
<td>Unmasking an Image</td>
</tr>
<tr>
<td>92</td>
<td>Removing the Background or Unwanted Elements from an Image</td>
</tr>
<tr>
<td>93</td>
<td>Changing an Image’s Brightness, Contrast, and Other Settings</td>
</tr>
<tr>
<td>94</td>
<td>Using Sound and Movies</td>
</tr>
<tr>
<td>95</td>
<td>Adding Sound to a Slide</td>
</tr>
<tr>
<td>95</td>
<td>Adding a Soundtrack to a Slideshow</td>
</tr>
<tr>
<td>96</td>
<td>Adding a Movie</td>
</tr>
<tr>
<td>96</td>
<td>Adjusting Media Playback Settings</td>
</tr>
<tr>
<td>97</td>
<td>Adding Narration</td>
</tr>
<tr>
<td>98</td>
<td>Rerecording a Recorded Slideshow</td>
</tr>
<tr>
<td>98</td>
<td>Playing a Recorded Slideshow</td>
</tr>
<tr>
<td>99</td>
<td>Deleting a Recording</td>
</tr>
<tr>
<td>99</td>
<td>Adding Web Views</td>
</tr>
<tr>
<td>100</td>
<td>Making an Object a Hyperlink</td>
</tr>
</tbody>
</table>

**Chapter 5**

101 Using Motion in Slideshows
101 Adding Transitions Between Slides
102 Animating Slides with Object Builds
103 Moving Objects on or off Slides Using Build Effects
105 Animating Objects on Slides (Action Builds)
107 Making Objects Fade, Rotate, Grow, or Shrink
107 Animating Images Using Smart Builds
109 Reordering Object Builds
110 Activating Object Builds
111 Creating Builds That Interleave an Object’s Parts
111 Animating Specific Kinds of Objects
111 Creating Text Builds
112 Creating Table Builds
112 Creating Chart Builds
113 Creating Movie Builds
113 Deleting Object Builds

**Chapter 6**

114 Using Tables
114 About Tables
115 Working with Tables
115 Adding a Table
116 Using Table Tools
117 Resizing a Table
118 Moving Tables
Performing a Basic Calculation Using Row Values
Removing a Formula
Using the Formula Editor
Adding a New Formula with the Formula Editor
Editing a Formula with the Formula Editor
Using Cell References
Adding Cell References to a Formula
Copying or Moving Formulas with Cell References
Applying a Formula Once to Cells in a Column or Row
Handling Errors and Warnings
Using Operators
Performing Arithmetic Operations
Understanding the Arithmetic Operators
Understanding the Comparison Operators
Using Functions

Chapter 8

Using Charts
About Charts
Adding a Chart
Selecting a Chart Type
Picking an Initial Chart Type
Changing a Chart from One Type to Another
Editing Chart Data
Copying Data into the Chart Data Editor
Working with Rows and Columns in the Chart Data Editor
Formatting General Chart Attributes
Using a Legend
Using a Chart Title
Resizing a Chart
Rotating Charts
Adding Labels and Axis Markings
Showing Axes and Borders
Using Axis Titles
Showing Data Point Labels
Formatting the Value Axis
Placing Labels, Gridlines, and Tick Marks
Formatting the Elements in a Data Series
Formatting Titles, Labels, and Legends
Adding Descriptive Text to a Chart
Formatting Specific Types of Charts
Pie Charts
Selecting Individual Pie Wedges
Showing a Series Name in a Pie Chart
<table>
<thead>
<tr>
<th>Page</th>
<th>Section</th>
</tr>
</thead>
<tbody>
<tr>
<td>157</td>
<td>Separating Individual Pie Wedges</td>
</tr>
<tr>
<td>158</td>
<td>Adding Shadows to Pie Charts and Wedges</td>
</tr>
<tr>
<td>158</td>
<td>Adjusting the Opacity of Pie Charts</td>
</tr>
<tr>
<td>158</td>
<td>Rotating 2D Pie Charts</td>
</tr>
<tr>
<td>159</td>
<td>Bar and Column Charts</td>
</tr>
<tr>
<td>159</td>
<td>Adjusting Spacing of Bar and Column Charts</td>
</tr>
<tr>
<td>159</td>
<td>Adding Shadows to Bar and Column Charts</td>
</tr>
<tr>
<td>160</td>
<td>Adjusting the Opacity of Bar and Column Charts</td>
</tr>
<tr>
<td>160</td>
<td>Area Charts and Line Charts</td>
</tr>
<tr>
<td>161</td>
<td>Scatter Charts</td>
</tr>
<tr>
<td>161</td>
<td>3D Charts</td>
</tr>
</tbody>
</table>

**Chapter 9** Viewing, Printing, and Exporting Your Slideshow

<table>
<thead>
<tr>
<th>Page</th>
<th>Section</th>
</tr>
</thead>
<tbody>
<tr>
<td>163</td>
<td>Customizing a Presentation for an Audience</td>
</tr>
<tr>
<td>164</td>
<td>Creating Hyperlinks-Only Presentations</td>
</tr>
<tr>
<td>164</td>
<td>Creating Self-Playing Presentations</td>
</tr>
<tr>
<td>165</td>
<td>Setting Playback Options</td>
</tr>
<tr>
<td>166</td>
<td>Rehearsing and Viewing Presentations</td>
</tr>
<tr>
<td>166</td>
<td>Adding Presenter Notes</td>
</tr>
<tr>
<td>166</td>
<td>Rehearsing Your Presentation</td>
</tr>
<tr>
<td>167</td>
<td>Viewing a Presentation on Your Computer’s Display</td>
</tr>
<tr>
<td>167</td>
<td>Viewing a Presentation on an External Display or Projector</td>
</tr>
<tr>
<td>168</td>
<td>Tips for Using an External Display</td>
</tr>
<tr>
<td>169</td>
<td>Viewing the Same Presentation on Two Screens</td>
</tr>
<tr>
<td>170</td>
<td>Customizing the Presenter’s View</td>
</tr>
<tr>
<td>171</td>
<td>Setting the Screen Refresh Rate</td>
</tr>
<tr>
<td>171</td>
<td>Setting the Slide Size</td>
</tr>
<tr>
<td>172</td>
<td>Configuring Video Random Access Memory (VRAM)</td>
</tr>
<tr>
<td>172</td>
<td>Controlling Presentations</td>
</tr>
<tr>
<td>173</td>
<td>Controlling a Presentation with the Keyboard</td>
</tr>
<tr>
<td>173</td>
<td>Pausing and Resuming a Presentation</td>
</tr>
<tr>
<td>173</td>
<td>Stopping a Presentation</td>
</tr>
<tr>
<td>173</td>
<td>Advancing to the Next or Previous Build or Slide</td>
</tr>
<tr>
<td>174</td>
<td>Jumping to a Specific Slide</td>
</tr>
<tr>
<td>175</td>
<td>Showing the Pointer During a Presentation</td>
</tr>
<tr>
<td>175</td>
<td>Using Other Applications During a Presentation</td>
</tr>
<tr>
<td>175</td>
<td>Playing Movies and Sound</td>
</tr>
<tr>
<td>176</td>
<td>Printing Your Slides</td>
</tr>
<tr>
<td>178</td>
<td>Exporting a Slideshow to Other Formats</td>
</tr>
<tr>
<td>178</td>
<td>Sharing a Presentation Across Platforms</td>
</tr>
<tr>
<td>178</td>
<td>Creating a QuickTime Movie</td>
</tr>
<tr>
<td>180</td>
<td>Creating a PowerPoint Slideshow</td>
</tr>
<tr>
<td>180</td>
<td>Creating a PDF File</td>
</tr>
</tbody>
</table>
Chapter 10 187 Designing Your Own Master Slides and Themes

187 Designing Master Slides and Themes
188 Using Master Slide Tools
189 Previewing Master Slides
190 Selecting Master Slides to Customize
190 Duplicating a Master Slide
190 Importing a Slide or Master Slide
191 Creating a Master Slide from Scratch
191 Customizing Master Slide Layouts
191 Defining Text Placeholders
191 Defining Media Placeholders
192 Defining Object Placeholders
192 Creating Background Elements on Master Slides
193 Adding Alignment Guides to Master Slides
193 Defining Default Attributes of Text and Objects
194 Defining Default Attributes of Text Boxes and Shapes
194 Defining Default Attributes of Imported Images
195 Defining Default Attributes of Tables
195 Defining Default Attributes of Charts
196 Defining Default Transitions
197 Creating Builds on Master Slides
197 Creating Custom Themes
197 Saving a Custom Theme
198 Creating a Theme from Scratch
198 Restoring Original Theme Attributes

Index 199
Welcome to the
*Keynote User’s Guide*

This full-color PDF document provides extensive instructions for using Keynote.

Before using this document, you may want to look at the Keynote tutorial in the *iWork ’08 Getting Started* book. It’s a quick way to prepare yourself to be a self-sufficient Keynote user. The book also provides additional resources for getting acquainted with Keynote, such as a tour of its features and how-to videos.

When you need detailed instructions to help you accomplish specific tasks, you’ll find them in this user’s guide. Most of the tasks in this guide are also available in online help.
The following table tells you where to find information in this guide. In Keynote Help, you can find information by browsing or searching.

<table>
<thead>
<tr>
<th>For information about</th>
<th>See</th>
</tr>
</thead>
<tbody>
<tr>
<td>Using Keynote windows and tools to create and format documents</td>
<td>Chapter 1, “Keynote Tools and Techniques,” on page 14</td>
</tr>
<tr>
<td>Formatting text in a Keynote document</td>
<td>Chapter 3, “Working with Text,” on page 38</td>
</tr>
<tr>
<td>Using graphics, shapes, sound, and more to enhance a document</td>
<td>Chapter 4, “Working with Sound, Movies, Graphics, and Other Objects,” on page 68</td>
</tr>
<tr>
<td>Adding transitions, special effects, and animations to slides</td>
<td>Chapter 5, “Using Motion in Slideshows,” on page 101</td>
</tr>
<tr>
<td>Creating, organizing, and formatting tables and table values</td>
<td>Chapter 6, “Using Tables,” on page 114</td>
</tr>
<tr>
<td>Using formulas and functions for calculations in tables</td>
<td>Chapter 7, “Using Formulas and Functions in Tables,” on page 134</td>
</tr>
<tr>
<td>Creating charts to graphically display numerical data</td>
<td>Chapter 8, “Using Charts,” on page 144</td>
</tr>
<tr>
<td>Sharing your Keynote document with others</td>
<td>Chapter 9, “Viewing, Printing, and Exporting Your Slideshow,” on page 163</td>
</tr>
<tr>
<td>Creating a theme or template from scratch</td>
<td>Chapter 10, “Designing Your Own Master Slides and Themes,” on page 187</td>
</tr>
</tbody>
</table>
Keynote Tools and Techniques

This chapter introduces you to the windows and tools you use to create slideshows with Keynote.

Each slideshow you create is its own Keynote document. If you add movies, sounds, or other media to your slideshow, you can save them as a part of the document so that you can easily move the presentation from one computer to another.

About Themes and Master Slides
When you first open Keynote (by clicking its icon in the Dock or by double-clicking its icon in the Finder), the Theme Chooser displays the built-in themes you can use.

Each Keynote theme comprises a family of master slides with coordinated design elements. Master slides are templates that provide predesigned layouts, fonts, textures, chart properties, background colors, and more.
When you want to create a slide with particular elements—such as a title, a block of text, a bulleted list, or a graphic—you select the master slide that most resembles what you need. Master slides contain placeholders, which you replace with your own content.

- **Placeholder text** ("Double-click to edit") shows what your text will look like. Double-click this text and type your own. To learn more, see “Adding Text” on page 38.
- **Media placeholders** can hold images, audio files, and movies. Drag your own image or movie to the placeholder. Although you can drag media files anywhere on a slide (not only to a placeholder), using media placeholders automatically sizes and positions the image or movie. To learn more, see “Using Media Placeholders” on page 88.

You can also add your own elements, such as tables and other objects, to any slide.
Most themes come with the following master slides:

<table>
<thead>
<tr>
<th>Master slide</th>
<th>Recommended use</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title &amp; Subtitle</td>
<td>Title page or section titles within your presentation</td>
</tr>
<tr>
<td>Title &amp; Bullets</td>
<td>Content</td>
</tr>
<tr>
<td>Title &amp; Bullets - 2 Column</td>
<td>Content you want to appear side by side</td>
</tr>
<tr>
<td>Bullets</td>
<td>General content pages that require bulleted text; the text area fills the entire slide</td>
</tr>
<tr>
<td>Blank</td>
<td>Graphics-rich layouts</td>
</tr>
<tr>
<td>Title - Top or Center</td>
<td>Title page or section titles within your presentation</td>
</tr>
<tr>
<td>Photo - Horizontal</td>
<td>Horizontal photo with title below</td>
</tr>
<tr>
<td>Photo - Vertical</td>
<td>Vertical photo with title and subtitle on the left</td>
</tr>
<tr>
<td>Title, Bullets &amp; Photo</td>
<td>Title page or section title with text and photo</td>
</tr>
<tr>
<td>Title &amp; Bullets - Left or Right</td>
<td>Content slides on which you can place bulleted text on the left or right and a graphic on the other side of the slide</td>
</tr>
</tbody>
</table>

The Keynote Window

Your Keynote document window has features to help you develop and organize your slideshow. You can show or hide each of these elements:

- A toolbar at the top of the window gives you fast access to the tools you need to create your slides. See “The Toolbar” on page 21 to learn more.
- The slide navigator at the left side of the window provides a visual overview of your slideshow. You can view a thumbnail of each slide or a text outline. See “Changing Views” on page 18 for more information.
- You can write notes about individual slides in the presenter notes field. You can refer to these notes during a presentation; the audience won’t see them. For more information, see “Adding Presenter Notes” on page 166.

Here are ways to show or hide these elements:
- To show or hide the toolbar, choose View > Show Toolbar or View > Hide Toolbar.
- To show the slide navigator, choose View > Navigator or View > Outline. To hide the slide navigator, choose View > Slide Only.
- To show or hide presenter notes, choose View > Show Presenter Notes or View > Hide Presenter Notes.
Zooming In or Out
You can enlarge (zoom in) or reduce (zoom out) your view of the slide canvas.

Here are ways to zoom in or out:
- Choose View > Zoom > zoom level.
- Choose a magnification level from the Zoom pop-up menu at the bottom left of the slide canvas.

Changing Views
Keynote offers several ways to view, manage, and organize the slides in a Keynote document: navigator view, outline view, and light table view. You can also view only the slide canvas.

To change from one view to the other:
- Click View in the toolbar and choose an option (or choose View > Navigator, Outline, Light Table, or Slide Only).

Navigator View
Navigator view displays thumbnail images of each slide and is useful for slideshows that contain a lot of graphics, tables, and other objects. This view provides a good visual overview of your slides but you might not be able to read all the text in the thumbnails.

![Diagram of slide navigator]

- Drag this handle down to display master slides.
- The slide selected here is the one you are working on.
- Click the disclosure triangle to show or hide groups of indented slides.
- Display thumbnails in different sizes.
- See the graphics on each of your slides at a glance.
- Organize slides into groups by indenting them. To indent a slide, drag it or select it and press Tab.
- Skip a slide during a presentation by choosing Slide > Skip Slide.

You can manipulate slides in the slide navigator to rearrange and organize your slides.
Here are ways to work with navigator view:

- To show navigator view, click View in the toolbar and choose Navigator, or choose View > Navigator.
- To rearrange or indent slides, drag them.
- To show or hide groups of slides (indented slides and their “parent” slide), click the disclosure triangles.
- To enlarge or shrink the thumbnail images, click the button in the lower-left corner and choose a size.
- To duplicate one or more adjacent slides, select them and choose Edit > Duplicate. The duplicates are inserted following the selected slides.
- To copy and paste one or more adjacent slides, select them, choose Edit > Copy, select the slide after which you want to paste the copied slides, and choose Edit > Paste.
- To show master slides (useful if you create your own master slides or themes), drag the handle at the top right of the slide navigator, or click View in the toolbar and choose Show Master Slides. See “Designing Master Slides and Themes” on page 187 for details.

Outline View
Outline view is most useful for visualizing the flow of text-rich presentations. It displays the title and bullet-point text of each slide in your slideshow. All the titles and bullet points appear legibly in the slide navigator.

Outline view provides an easy way to order and reorder your bullet points as you organize your presentation. You can add bullet points to existing text directly in the slide navigator. You can also drag bullets from one slide to another, or drag them to a higher or lower level within the same slide.
Here are ways to work with outline view:

- To show outline view, click View in the toolbar and choose Outline (or choose View > Outline).
- To change the font used in outline view, choose Keynote > Preferences, click General, and then choose a font and size from the Outline View Font pop-up menus.
- To print the outline view, choose File > Print. In the Print dialog, choose Keynote from the Copies & Pages pop-up menu, and then select Outline.

**Light Table View**  
If your slideshow contains many slides and you want to see more thumbnails at the same time, use light table view. You can easily reorder slides by dragging, as if the slides were spread out on a photographer’s light table.

Here are ways to work with light table view:

- To show light table view, click View in the toolbar and choose Light Table (or choose View > Light Table).
- To enlarge or shrink the thumbnail images, click the button in the lower left of the window and choose a size.
- To edit a slide or return to your previous view (navigator or outline), double-click a slide.

In light table view, you can add, delete, duplicate, skip, and reorder slides just as you can in navigator and outline views.

**Jumping to a Particular Slide**  
As you work on your document, you can easily jump to any slide.

Here are ways to jump to a particular slide:

- In navigator or outline view, click a thumbnail in the slide navigator to jump to any slide.
- Choose Slide > Go To and choose one of the options (Next Slide, Previous Slide, First Slide, or Last Slide).
**The Toolbar**

The Keynote toolbar provides one-click access to many of the actions you'll perform as you work in Keynote. You can add, remove, and rearrange toolbar buttons to suit your working style.

The default set of toolbar buttons is shown below.

To customize the toolbar:

1. Choose View > Customize Toolbar, or Control-click the toolbar and choose Customize Toolbar.

2. Make changes to the toolbar as desired.
   - To **add an item** to the toolbar, drag its icon to the toolbar at the top.
   - To **remove an item** from the toolbar, drag it out of the toolbar.
   - To **restore the default** set of toolbar buttons, drag the default set to the toolbar.
   - To make the toolbar **icons larger**, deselect Use Small Size.
   - To display **only icons or only text**, choose an option from the Show pop-up menu.
   - To **rearrange items** in the toolbar, drag them.

3. When you're finished, click Done.

Here are some shortcuts for customizing the toolbar without choosing View > Customize Toolbar:

- To remove an item, press the Command key while you drag the item out of the toolbar, or Control-click the item and then choose Remove.
- To move an item, press the Command key while you drag the item.

To see a description of what a toolbar button does, hold the pointer over it.
The Format Bar

Use the Format Bar to quickly change the appearance of text, tables, charts, and other elements in your slideshow.

Here are ways to show and hide the Format Bar:

- Choose View > Show Format Bar or View > Hide Format Bar.
- Click the Format Bar button in the toolbar.

The controls in the Format Bar depend on which object is selected. To see a description of what a Format Bar control does, hold the pointer over it.

Here's what the Format Bar looks like when text or graphical objects are selected.

Here's what the Format Bar looks like when a table is selected.
The Inspector Window

Most elements of your slideshow can be formatted using the Keynote inspectors. Each inspector focuses on a different aspect of formatting. For example, the Document Inspector contains settings for the entire slideshow.

Opening multiple Inspector windows can make it easier to work on your document. For example, if you open both the Graphic Inspector and the Text Inspector, you'll have access to all the text- and image-formatting options.

Here are ways to open an Inspector window:

- Click Inspector in the toolbar.
- To open more than one Inspector window, press the Option key while clicking an Inspector button, or choose View > New Inspector.

After the Inspector window is open, click one of the buttons at the top to display a different inspector. Clicking the second button from the left, for example, displays the Slide Inspector.

Hold your pointer over buttons and other controls in the Inspector to see a description of what they do.
The Media Browser
The Media Browser provides access to all the media files in your iPhoto library, your iTunes library, your Aperture library, and your Movies folder. You can drag an item from the Media Browser to a slide or to an image well in an inspector.

To open the Media Browser:
- Click Media in the toolbar, or choose View > Show Media Browser.

The Colors Window
You use the Mac OS X Colors window to choose colors for text, objects, and lines.

To open the Colors window:
- Click Colors in the toolbar.

For more information, see “Using the Colors Window” on page 80.

The Font Panel
Using the Mac OS X Font panel—accessible from any application—you can change a font’s typeface, size, and other options.

To open the Font panel:
- Click Fonts in the toolbar.
For more information about using the Font panel and changing the look of text, see “Using the Font Panel to Format Text” on page 42.

The Warnings Window

When you import a document into Keynote, or export a Keynote document to another format, some elements might not transfer identically. The Warnings window lists any problems encountered. You might get warnings in other situations, such as saving a document in an earlier version of the application.

If problems are encountered, you’ll see a message enabling you to review the warnings. If you choose not to review them, you can see the Warnings window at any time by choosing View > Show Document Warnings.

If you see a warning about a missing font, you can select the warning and click Replace Font to choose a replacement font.

You can copy warning messages and paste them into a document for reference later; these messages could be useful for diagnosing problems.

Keyboard Shortcuts and Shortcut Menus

You can use the keyboard to perform many of the Keynote menu commands and tasks. To see a comprehensive list of keyboard shortcuts, open Keynote and choose Help > Keyboard Shortcuts.

Many objects also have shortcut menus with commands you can use on the object. Shortcut menus are especially useful for working with tables and charts.

To open a shortcut menu:

- Press the Control key while you click an object.
Working with a Keynote Document

This chapter explains how to create, open, import, and save Keynote documents. It also describes how to add and organize slides, and how to change a slide’s theme, layout, or master.

Before you start working in Keynote, you may want to go through the tutorial in the iWork ’08 Getting Started book. It will help you become self-sufficient in Keynote quickly.

Creating or Opening a Slideshow
Each slideshow you create is its own Keynote document. You can create a slideshow by doing any of the following:

- Create a new Keynote document
- Import a document created in PowerPoint or AppleWorks
- Open an existing Keynote document

Creating a New Keynote Document

To create a new Keynote document:

1. If Keynote isn't open, open it by clicking its icon in the Dock or double-clicking its icon in the Finder.
   If Keynote is already open, choose File > New.

2. In the Theme Chooser, select a theme and click Choose.

You can change a slideshow’s theme at any time (see “Changing a Slide’s Theme, Master, or Layout” on page 34), and you can use more than one theme in a document (see “Using Multiple Themes” on page 35).

In the Theme Chooser, you can also choose a slide size (see “Setting the Slide Size” on page 171).
Tip: You can set up Keynote to use the same theme when you create a new document. Choose Keynote > Preferences, click General, select “Use theme,” and then choose a theme. To change the theme, click Choose.

Importing a Slideshow
If you already have a slide presentation that you created in Microsoft PowerPoint or AppleWorks, you can import it into Keynote and continue to work on it.

Here are ways to import a PowerPoint or an AppleWorks document:

- In Keynote, choose File > Open. In the Open dialog, find the document you want to import and click Open.
- In the Finder, drag the PowerPoint or AppleWorks document icon to the Keynote application icon.

Opening an Existing Keynote Document
There are several ways to open a document that was created using Keynote.

Here are ways to open a Keynote document:

- To open a document when you’re working in Keynote, choose File > Open, select the document, and then click Open.
- To open a document you’ve worked with recently, choose File > Open Recent and choose the document from the submenu.
- To open a Keynote document from the Finder, double-click the document icon or drag it to the Keynote application icon.

You can open a Keynote document created using an older version of Keynote (from iWork ’05 or iWork ’06). To preserve the document to for use with iWork ’05 or iWork ’06, save it in the same format. See “Saving a Presentation in iWork ’05 or iWork ’06 Format” on page 186.

If you see a message that a font or file is missing, you can still use the document. Keynote substitutes fonts for missing fonts. To use missing fonts, quit Keynote and add the fonts to your Fonts folder (for more information, see Mac Help). To make missing movies or sound files appear, add them to the document.

Saving Documents
Graphics and chart data are saved within a Keynote document, so they display correctly if the document is opened on another computer. Fonts, however, are not included as part of the document. If you transfer a Keynote document to another computer, make sure the fonts used in the document have been installed in the Fonts folder of that computer.
By default, audio and movie files are saved with Keynote documents, but you can change this setting. If you don’t save media files with the document, you need to transfer them separately to view the document on another computer.

**Saving a Document**

It’s a good idea to save your document often as you work. After you’ve saved it for the first time, you can press Command-S to re-save it using the same settings.

**To save a document for the first time:**

1. Choose File > Save, or press Command-S.
2. In the Save As field, type a name for the document.
3. If the location you want isn’t visible in the Where pop-up menu, click the disclosure triangle to the right of the Save As field.
4. Choose where you want to save the document.
5. If you want the document to be opened using Keynote in iWork ’05 or iWork ’06, select “Save a copy as” and choose iWork ’05 or iWork ’06.
6. If you or someone else will open the document on another computer, click Advanced Options and set up options that determine what’s copied into your document.
   - **Copy audio and movies into document:** Selecting this checkbox saves audio and video files with the document, so the files play if the document is opened on another computer. You might want to deselect this checkbox so that the file size is smaller, but media files won’t play on another computer unless you transfer them as well.
   - **Copy theme images into document:** If you don’t select this option and you open the document on a computer that doesn’t have the same theme installed (if you created your own theme, for example), the document might look different.
7. Click Save.

If the document was created using an earlier version of Keynote, you are asked whether to save the document in the same format.

You can generally save Keynote documents only to computers and servers that use Mac OS X. Keynote is not compatible with Mac OS 9 computers or Windows servers running Services for Macintosh. To open a Keynote document on a Windows computer, try using AFP server software available for Windows.

If you plan to share the document with others who don’t have Keynote installed on their computers, you can export it for use in another application. To learn about exporting your document in other file formats (including QuickTime, PowerPoint, PDF, and Flash), see “Sharing a Presentation Across Platforms” on page 178.
**Undoing Changes**
If you don't want to save changes you made to your document since opening it or last saving it, you can undo them.

**Here are ways to undo changes:**
- To undo your most recent change, choose Edit > Undo.
- To undo multiple changes, choose Edit > Undo multiple times. You can undo any changes you made since opening the document or reverting to the last saved version.
- To undo one or more Edit > Undo operations, choose Edit > Redo one or more times.
- To undo all changes you made since the last time you saved your document, choose File > “Revert to Saved” and then click Revert.

**Saving a Copy of a Document**
If you want to make a copy of your document—to create a backup copy or multiple versions, for example—you can save it using a different name or location. (You can also automate saving a backup version, as “Automatically Saving a Backup Version of a Document” describes.)

**To save a copy of a document:**
- Choose File > Save As and specify a name and location.

The document with the new name remains open. To work with the previous version, choose File > Open Recent and choose the previous version from the submenu.

**Automatically Saving a Backup Version of a Document**
Each time you save a document, you can save a copy without the changes you made since last saving it. That way, if you change your mind about edits you have made, you can go back to (revert to) the backup version of the document.

**Here are ways to create and use a backup version:**
- To automatically save a backup version of a document, choose Keynote > Preferences, click General, and then select “Back up previous version.”

The next time you save your document, a backup version is created in the same location, with “Backup of” preceding the filename. Only one version—the last saved version—is backed up. Every time you save the document, the old backup file is replaced with the new backup file.
- To revert to the last saved version after making unsaved changes, choose File > Revert to Saved. The changes in your open document are undone.
**Saving a Document as a Theme**
You can modify a theme and then save it so that it appears in the Theme Chooser and you can use it again.

**To save a document as a theme:**
- Choose File > Save Theme.

See “Designing Master Slides and Themes” on page 187 for additional details.

**Saving Search Terms for a Document**
You can store information—such as author name, keywords, and comments—in Keynote documents. On computers with Mac OS X, you can use Spotlight to locate documents containing that information.

**To store information about a document:**
1. Click Inspector in the toolbar, and then click the Document Inspector button.
2. Click Spotlight.
3. Type information in the fields.

To search for presentations containing stored information, click the Spotlight icon at the top-right of the screen, and then type what you want to search for.

**Closing a Document Without Quitting Keynote**
When you have finished working with a document, you can close it without quitting Keynote.

**Here are ways to close documents and keep the application open:**
- To close the active document, choose File > Close or click the close button in the upper-left corner of the document window.
- To close all open Keynote documents, press the Option key and choose File > Close All or click the active document’s close button.

If you’ve made changes since you last saved the document, Keynote prompts you to save.

**Adding, Deleting, and Organizing Slides**
Each new slide you create uses one of the Keynote master slides (templates). Each master slide has certain elements on it, such as a title, bulleted text, and media placeholders (containing photos). When you create a new Keynote document, the first slide automatically uses the Title & Subtitle master slide.

You can change a slide’s master at any time (see “Applying a New Master to a Slide” on page 35).
After you create a new slide, you customize it by adding your own text, images, shapes, tables and charts, and more.

**Adding Slides**

Here are ways to add a slide:
- Select a slide in the slide navigator and press Return.
- Select a slide and click the New (+) button in the toolbar.
- Select a slide and choose Slide > New Slide.
- Press Option and drag a slide until you see a blue triangle. This action duplicates the dragged slide.
- Select a slide and choose Edit > Duplicate.

These methods add the new slide after the slide selected in the slide navigator. To add a slide in another location in your slideshow, use the Copy and Paste commands, or drag the new slide where you want it.

In navigator or light table view, you can also create a new slide by dragging movie, sound, or image files from the Media Browser to the desired location in the slide navigator. (To open the Media Browser, click Media in the toolbar.)

When you add a new slide, it uses the master of the slide selected in the slide navigator. (For new Keynote documents, the first slide uses the Title & Subtitle master slide, and the second slide uses the Title & Bullets master.) You can change a slide's master at any time by clicking Masters in the toolbar and choosing a new master.

**Reordering Slides**

The navigator, outline, and light table views make it easy to reorder slides.

To reorder slides:
1. Click View in the toolbar and choose Navigator, Outline, or Light Table.
2. Select one or more slides and drag them to a new location.

**Grouping Slides**

In navigator view, you can create groups of slides by indenting them as many levels deep as you need to. Indented (subordinate) slides are called “children.” Indenting slides doesn’t affect how the slideshow plays.

To see navigator view, click View in the toolbar and choose Navigator.
Here are ways to work with groups of slides in navigator view:

- To indent slides, select them and press Tab or drag the slides to the right. You can create more indent levels by pressing Tab again or dragging farther to the right. However, you can indent a slide only one level deeper than the slide above it.

- To remove an indent, drag the slides to the left or press Shift-Tab.

- To show or collapse (hide) a group of slides, click the disclosure triangle to the left of the first slide above the group. If a group of slides is collapsed so that you see only the top slide in the navigator view, deleting the top slide deletes all its children, too. If the group isn’t collapsed, deleting the top slide moves all its children up one level.

- To move a group of slides, select the first slide in the group (in navigator view) and drag the group to a new location in the slide navigator.

Deleting Slides
You can delete a single slide or a group of slides.

Here are ways to delete slides:

- To delete a slide, select the slide in the slide navigator and press the Delete key. You can Shift-click to select multiple slides to delete. If you delete the first slide in a group while the subordinate slides (children) are visible in the slide navigator, the children are moved up by one outline level.

- To delete a slide and all its children, hide them (click the arrow to the left of the top slide) and press the Delete key. If you accidentally delete slides, you can recover them immediately by choosing Edit > Undo Delete.

Skipping Slides
You can skip a slide when your slideshow plays without deleting the slide from your document.

To skip one or more slides:

- Select the slide(s) in the slide navigator or light table view, and then choose Slide > Skip Slide.

- Control-click the slide and choose Skip Slide.

To make a skipped slide visible in a slideshow, select it and then choose Slide > Don’t Skip Slide (or Control-click the slide and choose Don’t Skip Slide).
Adding Slide Numbers
You can add numbers (similar to page numbers) to individual slides. Or you can turn on numbering for a master slide so that each new slide based on that master automatically gets an ascending slide number.

Here are ways to add slide numbers:

- Select a slide in the slide navigator, open the Slide Inspector, click Appearance, and then select Slide Number. The number assigned reflects the location of the slide in the organizer (skipped slides aren’t numbered).

- To add slide numbers to a master slide, click View in the toolbar and choose Show Master Slides. In the master slide navigator, select the master slide you want to modify. Open the Slide Inspector, click Appearance, and then select Slide Number.

You can drag the number wherever you like on the slide, and you can use the Font panel to format the number.

Using Comments
As you work on your slideshow, you can add comments to slides. For example, you could use comments to remind yourself of changes you want to make to the slide. (Comments are different from presenter notes; see “Adding Presenter Notes” on page 166.)

You can move comments anywhere on the slide canvas. If you have your own presenter display while making a presentation, you can see your comments but your audience can’t.

Comments are always on top of the slide canvas, so they may obscure parts of your slide. Simply drag the comments out of the way, hide them, or resize them.

Here are ways to work with comments:

- To add a comment, click Comment in the toolbar or choose Insert > Comment. Type a note, idea, or reminder, and then drag the comment wherever you want to place it on the canvas.
To hide or show comments, click View in the toolbar and choose Hide Comments or Show Comments.

To resize a comment, drag the lower-right corner.

To delete a comment, click the x icon in the upper-right corner.

To format a comment, see instructions in “Formatting Text Size and Appearance” on page 40 and “Filling an Object with Color” on page 79.

To print with comments showing, make sure the comments are visible on the slide canvas before you print.

Copying or Moving Items Among Slides
You can take text or an object from one slide and place it on another slide.

Here are ways to copy and move text and objects:

- To copy (or cut) and paste text or an object, select the text or object and choose Edit > Copy or Edit > Cut. Click where you want to paste the text or object and choose Edit > Paste.
  
  This method retains the text’s formatting. To have copied text take on the formatting of the text around it, choose Edit > “Paste and Match Style.”

- To delete text or an object, select it and choose Edit > Delete, or press the Delete key.
  
  If you accidentally delete something, choose Edit > Undo to restore it.

- To copy an image between Keynote documents, select the image and drag its icon from the File Info field in the Metrics Inspector to a slide in the other Keynote file.

  When you use the Copy or Cut command, the selected text or object is placed in a holding area called the Clipboard, where it remains until you choose Copy or Cut again (or turn off your computer). The Clipboard holds the contents of only one copy or cut operation at a time.

Changing a Slide’s Theme, Master, or Layout
You can change a slide’s theme, master, or layout at any time.

- **Theme:** Choose a different theme when you want to change a slide’s overall look and feel—for example, its background color, fonts, and “tone” (professional or fun).

- **Master:** Change a slide’s master when you want to use a different predefined layout. For example, you could change a slide’s master to orient a large photo vertically instead of horizontally.

- **Layout:** Change a slide’s layout when you want to add, delete, or modify slide elements such as text boxes and object placeholders.
Changing the Theme
You can change a slide's theme at any time by selecting it and choosing another theme using the Themes button in the toolbar. To retain formatting changes you've already made, or to change a whole slideshow's theme, follow these steps.

To change a slide's or a slideshow's theme:
1 In the slide navigator, select the slide or slides whose theme you want to change. (If you want to change all slides, skip this step.)
2 Click Themes in the toolbar and choose Theme Chooser.
3 Select a new theme.
4 If you made formatting changes that you don't want to keep in the new theme (for example, if you made body text brown but you want the text to use the new theme's text color), deselect “Retain changes to theme defaults.”
5 Choose All Slides or Selected Slides from the Apply Theme To pop-up menu.
   You can use multiple themes in the same slideshow by applying a new theme to only some of the slides.
6 Click Choose to apply the new theme.
   To return a slide to its theme defaults, select the slide and choose Format > Reapply Master to Slide.

Using Multiple Themes
You can use multiple themes in a slideshow to visually segregate slides into groups.

To use different themes for different slides in your slideshow:
1 In the slide navigator, select the slide or slides you want to have a different theme. (Shift-click or Command-click to select multiple slides.)
2 Click Themes in the toolbar and choose a new theme.
   You can also click Themes in the toolbar, choose Theme Chooser, and then choose Selected Slides from the Apply Theme To pop-up menu.

Applying a New Master to a Slide
You can change a slide's master at any time. For example, you might want to change a Photo master from horizontal to vertical.

To quickly choose another master, select the slide whose master you want to change, click Masters in the toolbar, and then choose a different master slide.

You can also use the Slide Inspector to change a slide's master.
To change a slide’s master using the Slide Inspector:
1 Select the slide whose layout you want to change.
2 Choose View > Show Inspector, and then click the Slide Inspector button.
3 Click Appearance.
4 To apply a different master slide, click the triangle next to the slide thumbnail image and choose one from the pop-up list.

Changing a Slide’s Layout
You can easily add a preformatted title box, body text box, object placeholder, or slide number to individual slides.

To change a slide’s layout:
1 Select the slide whose layout you want to change.
2 Choose View > Show Inspector, and then click the Slide Inspector button.
3 Click Appearance.
4 To add a title box or other elements to the slide, use the checkboxes below the master slide thumbnail image.

Choose a slide layout from among the master slides.
Choose a background color or image.
Drag an image here from the Media Browser or the Finder.

To add a title box or other elements to the slide, use the checkboxes below the master slide thumbnail image.
To apply a background, choose a background type from the Background pop-up menu.

*Color Fill:* Makes the background a single, solid color. Click the color well and choose a color in the Colors window.

*Gradient Fill:* Colors the background with a color gradient. Click each color well and choose colors in the Colors window.

*Image Fill:* Uses your own image as a background. Click Choose and select an image.

*Tinted Image Fill:* Uses your own image with a semi-opaque color tint over it. Click Choose and select an image.

If you chose Image Fill or Tinted Image Fill, choose a scaling option from the pop-up menu. See “Filling an Object with an Image” on page 81 for more information.

You can also modify a slide’s master slide, or even create a new one. See “Designing Master Slides and Themes” on page 187 for more information.

**Making the Same Change on Multiple Slides**

You can quickly make the same change—for example, resizing text, repositioning a graphic, or using a different background color—on many slides by modifying the master on which the slides are based.

**To make the same change on multiple slides:**

1. Select a slide you want to modify.
2. Click View in the toolbar and choose Show Master Slides.
3. In the slide navigator, click the master slide used for the selected slide (the master slide has a checkmark next to it).
4. Make your changes to the master slide.
   
   All slides based on that master inherit the changes you make to the master slide.
This chapter describes how to add and modify the appearance of text, including lists.

In Keynote, you can place text in text boxes, table cells, and shapes.

**Adding Text**

Master slides provide placeholder text (which you replace with your own) for slide titles and body text.

Title text is larger than body text. Most body text is bulleted (preceded by a “dot” or other ornament), but you can change to non-bulleted text using the Bullets pane in the Text Inspector.

**Here are ways to add text to a slide:**

- To add title text, double-click in a title text placeholder on the slide canvas and type your text.
- To add body text, double-click in a body text placeholder on the slide canvas and begin typing.
- To move to the next line, press Return.
- To indent a line, press Tab. To “outdent” an indented line, press Shift-Tab.
To move a bulleted line to a higher indent level, press Shift-Tab.

If the slide you’re working on doesn’t have title text or body text, you can either choose a different master or select Title or Body in the Appearance pane of the Slide Inspector. You can also add a free text box to the slide canvas. The text in free text boxes doesn’t appear in outline view.

Selecting Text
Before you format or perform other operations on text, you need to select the text you want to work with.

Here are ways to select text:
- To select one or more characters, click in front of the first character and drag across the characters you want to select.
- To select a word, double-click the word.
- To select a paragraph, click three times in the paragraph.
- To select all text in a document, choose Edit > Select All.
To select blocks of text, click the start of a text block, and then click the end of another text block while holding down the Shift key.

To select from the insertion point to the beginning of the paragraph, press the Up Arrow key while holding down the Shift and Option keys.

To select from the insertion point to the end of the paragraph, press the Down Arrow key while holding down the Shift and Option keys.

To extend the selection one character at a time, press the Left Arrow or Right Arrow key while holding down the Shift key.

To extend the selection one line at a time, press the Up Arrow or Down Arrow key while holding down the Shift key.

To select multiple words or blocks of text that are not next to each other, select the first amount of text you want, and then select additional text while holding down the Command key.

**Deleting, Copying, and Pasting Text**

The Edit menu contains commands that help you perform text editing operations.

Here are ways to edit text:

- To copy (or cut) and paste text, select the text and choose Edit > Copy or Edit > Cut. Click where you want to paste the text.
  
  To have the copied text retain its style formatting, choose Edit > Paste.
  
  To have the copied text take on the style formatting of the text around it, choose Edit > Paste and Match Style.

- To delete text, select the text and choose Edit > Delete or press the Delete key.
  
  If you accidentally delete text, choose Edit > Undo to restore it.

When you use the Copy or Cut command, the selected text is placed in a holding area called the Clipboard, where it remains until you choose Copy or Cut again or you turn off your computer. The Clipboard holds the contents of only one copy or cut operation at a time.

**Formatting Text Size and Appearance**

You can do all text formatting using the Keynote menus, the Text Inspector, or the Font panel.

You can do basic text formatting using the commands in the menus. If you want to change to a different font, or if you frequently change text formatting, it may be easier to use the Font panel and Text Inspector to format text.
**Using the Format Menu to Format Text**
The items in the Font submenu of the Format menu give you basic control over the size and appearance of text.

**Making Text Bold or Italic Using the Menus**
You can make characters bold or italic.

**To make text bold or italic:**
1. Select the text you want to make bold or italic, or click where you want to type new text.

Some fonts contain several bold and italic typefaces. To choose from a variety of bold and italic typefaces, use the Font panel. See “Using the Font Panel to Format Text” on page 42.

**Creating Outlined Text Using the Menus**
You can change text to appear as a stenciled outline.

**To create outlined text:**
1. Select the text you want to make outlined, or click where you want to type new text.
2. Choose Format > Font > Outline.

**Underlining Text Using the Menus**
You can underline text and then format the underline to change the underline style or color.

**To underline text:**
1. Select the text you want to underline, or click where you want to type new text.
2. Choose Format > Font > Underline.

To modify the underline style or color, click Fonts in the toolbar and use the Text Underline button in the Font panel. See “Using the Font Panel to Format Text” on page 42.

**Changing Text Size Using the Menus**
You can change the point size of text to make the text larger or smaller.

**To change the size of selected text:**
1. Select the text you want to resize.
2. To change the text size in 1-point increments, choose Format > Font > Bigger. Or choose Format > Font > Smaller.

You can also add Bigger and Smaller icons to the toolbar. Choose View > Customize Toolbar, drag the icons to the toolbar, and then click Done.
To specify a precise size for selected text, click Fonts in the toolbar and use the Size controls in the Font panel. See “Using the Font Panel to Format Text” on page 42.

**Making Text Subscript or Superscript Using the Menus**

You can raise or lower text from its baseline.

**To make text subscript or superscript:**

1. Select the text you want to raise or lower, or click where you want to type new text.
2. To create a subscript or superscript that has a smaller font size than the text it accompanies, choose Format > Font > Baseline > Subscript. Or choose Format > Font > Baseline > Superscript.
3. To raise or lower text without reducing its font size, choose Raise or Lower from the Baseline submenu.
4. To restore text to the same baseline as the body text, choose Use Default from the Baseline submenu.

You can add Subscript and Superscript icons to the toolbar. Choose View > Customize Toolbar, drag the icons to the toolbar, and click Done.

**Changing Text Capitalization Using the Menus**

You can quickly make blocks of text all uppercase or lowercase, or format text as a title.

**To change text capitalization:**

1. Select the text you want to change, or click where you want to type new text.
2. Choose Format > Font > Capitalization and choose an option from the submenu.
   - Choose All Caps to change the text to capitals.
   - Choose Small Caps to change the text to smaller capitals with larger capitals for uppercase letters.
   - Choose Title to change the text to a title format, which capitalizes the first letter of each word.
   - Choose None to change text from all capitals to initial caps. Uppercase characters, such as the first word of each sentence, are capitals but the rest are lowercase.

**Using the Font Panel to Format Text**

The Mac OS X Font panel gives you access to all the fonts installed on your computer. It provides a preview of the available typefaces (such as bold and italic) and sizes for each font. The buttons in the Font panel let you add underlines, strikethrough lines, color, and shadow to text. You can even change the background slide color in the Font panel.

For information on installing fonts, creating and managing font collections, or troubleshooting font-related issues, see Mac Help.
To open the Font panel:
- Click Fonts in the toolbar.

You can change the appearance of any text in your document by selecting it and then selecting options in the Font panel. When you make formatting changes in the Font panel, the selected text changes right away, so you can try different formatting options and quickly see what looks best.

Here is a summary of what the text effects buttons do, from left to right:
- The Text Underline pop-up menu lets you choose an underline style (such as single or double).
- The Text Strikethrough pop-up menu lets you choose a strikethrough style (such as single or double).
- The Text Color pop-up menu lets you apply a color to text.
- The Document Color pop-up menu lets you apply a color behind a paragraph.
- The Text Shadow button applies a shadow to selected text.
- The Shadow Opacity, Shadow Blur, Shadow Offset, and Shadow Angle controls control the appearance of the shadow.

If you don’t see the text effects buttons, choose Show Effects from the Action pop-up menu in the lower-left corner of the Font panel.

**Tips for Organizing Fonts**

If you frequently use the Font panel, there are several techniques for saving time.
Here are tips for using the Font panel:

- To quickly locate fonts you frequently use, organize them into font collections. Click the Add (+) button to create a font collection, and then drag a typeface into the new collection.

- To make it easy to change fonts often, leave the Font panel open. If it takes up too much space on your screen, you can shrink it by dragging its resize control (the bottom-right corner of the panel), so that only the font families and typefaces in your selected font collection are visible. To close it, click the Fonts button again or the Close button in the upper-left corner.

**Changing Fonts Using the Font Panel**
The Font panel gives you extensive control over fonts. Use size controls and typography settings to customize the appearance of your text.

**To modify the font of selected text:**

1. Click Fonts in the toolbar.

2. In the Font panel, select a font style in the Family column and then select the typeface in the Typeface column.

If you don’t see all the font families you know are installed on your computer, select All Fonts in the Collections column or type the name of the font you are looking for in the search field at the bottom of the Font panel.

A preview of the selected font appears in the preview pane at the top of the Font panel. If you don’t see a preview pane, choose Show Preview from the Action pop-up menu in the lower-left corner of the Font panel.

3. Adjust the font size using the size slider or other size controls.

4. Adjust the typography settings of the selected font by choosing Typography from the Action pop-up menu. In the Typography window, click the disclosure triangles to see and select the different typography effects that are available for the selected font. Different fonts have different typography effects available. See “Using Advanced Typography Features” on page 49 for more information.

**Changing Underlining Using the Font Panel**
You can use the Font panel to change the appearance of underlines.

**To modify underlining of selected text:**

1. Click Fonts in the toolbar.

2. Click the Text Underline button in the Font panel (the first button on the left), and choose None, Single, or Double from the pop-up menu.

3. To change the underline color, choose Color from the Text Underline pop-up menu, and then select a color in the Colors window.
Adding a Strikethrough to Text Using the Font Panel
You can mark text with a strikethrough line, and make the line's color different from the

text color.

To add a strikethrough to selected text:
1 Click Fonts in the toolbar.
2 Click the Text Strikethrough button (the second button from the left), and choose
None, Single, or Double from the pop-up menu. A single or double strikethrough
appears through the selected text in the same color as the text.
3 To change the strikethrough color, choose Color from the Text Strikethrough pop-up
menu, and then select a color in the Colors window. The strikethrough takes on the

color you select in the Colors window, but the text remains its original color.

Changing Text Color Using the Font Panel
Changes made to text color in the Font panel will override text color changes made in
the Text Inspector, and vice versa. (To read about changing color using the Text
Inspector, see “Changing Text Color Using the Text Inspector” on page 53.)

To modify the color of selected text:
1 Click Fonts in the toolbar.
2 Click the Text Color button menu in the Font panel (the third button from the left), and
then select a color in the Colors window. See “Using the Colors Window” on page 80
for instructions.

Changing the Paragraph Background Color Using the Font Panel
You can use the Font panel to add a color behind a paragraph.

To modify the background color of a selected paragraph:
1 Click Fonts in the toolbar.
2 Click the Document Color button in the Font panel (the fourth button from the left),
and then select a color in the Colors window. See “Using the Colors Window” on
page 80 for instructions.

Creating Shadows on Text Using the Font Panel
You can use the Font panel to create and format shadows on text.

To define shadows on selected text:
1 Click Fonts in the toolbar.
2 Click the Text Shadow button in the Font panel (the fifth button from the left).
3 Drag the shadow opacity slider (the first slider on the left) to the right to make the
shadow darker.
4 Drag the shadow blur slider (the middle slider) to the right to make the shadow more
diffuse.
5 Drag the shadow offset slider (the third slider) to the right to separate the shadow from the text.

6 Rotate the Shadow Angle wheel to set the direction of the shadow.

You can also set text shadows in the Graphic Inspector, as described in “Adding Shadows” on page 76.

**Changing the Font Used in Outline View**

You can change the font used when you view your slideshow in outline view.

**To change the outline view font:**
1 Choose Keynote > Preferences.
2 If the General pane isn’t showing, click General.
3 Choose a font and font size from the Outline View Font pop-up menus.

**Adding Accents and Special Characters**

If you need to type characters with accent marks (such as ü), mathematical symbols, arrows, or other special characters, you can use the International preferences pane or the Character Palette. You can also see where characters are located on keyboards used for other languages by using the Keyboard Viewer (for example, you can see how the keys on an Italian keyboard are laid out). All of these are built-in tools of Mac OS X.

**Adding Accent Marks**

You can use the Keyboard Viewer available in System Preferences to add accent marks to characters.

**To add accent marks:**
1 Choose Apple > System Preferences and click International.
2 Click Input Menu, then select the checkbox next to Keyboard Viewer.
3 Choose Show Keyboard Viewer from the Input menu on the right side of the menu bar (the one that looks like a flag or alphabetical symbol).

The Keyboard Viewer shows the characters for your keyboard. (If you’ve selected a different keyboard layout or input method in the Input menu, it shows the characters for the selected keyboard layout). For example, if U.S. is chosen in the Input menu, you see the characters that appear on a U.S. keyboard in the Keyboard Viewer.

4 To see the different accent marks that you can type highlighted in the Keyboard Viewer, press Option, or the Option and Shift keys.

The accent mark keys appear with white outlines. Depending on your keyboard, you may not need to press any of the modifier keys to see the accent keys.

5 Place the insertion point in your document where you want to type.
6 Press the modifier key you pressed in step 4 (Shift, Option, Option-Shift, or none) and press the key on your keyboard that is in the same place as the accent you see in the Keyboard Viewer. Then release the modifier key and press the key for the character you want to accent.

The accent key modifies the key you type next. For example, on a U.S. keyboard, to make the é appear, press Option and E (the accent key), then press E (the key on which you want that accent to appear).

**Viewing Keyboard Layouts for Other Languages**
You can use the Keyboard Viewer available in System Preferences to see where characters are located on keyboards used for other languages.

You must have fonts installed for the language you want to see in the Keyboard Viewer.

**To see keyboard layouts for different languages:**
1 Choose Apple > System Preferences and click International.
2 Click Input Menu, then select the checkbox next to Keyboard Viewer.
3 To see the character layout on keyboards used in different countries, select the On checkbox next to the country’s keyboard layout or input method.
4 Choose Show Keyboard Viewer from the Input menu on the right side of the menu bar (the one that looks like a flag or alphabetical character).

The Keyboard Viewer shows the characters for the keyboard layout or input method selected in the Input menu. For example, if U.S. is chosen in the Input menu, you see the characters that appear on a U.S. keyboard in the Keyboard Viewer.
5 To see the keyboard layout for a different country, choose its keyboard layout from the Input menu.

**Typing Special Characters and Symbols**
Using the Mac OS X Character Palette, you can insert special characters, such as mathematical symbols, letters with accent marks, arrows and other “dingbats,” and more. You can also use this palette to enter Japanese, Traditional Chinese, Simplified Chinese, and Korean characters, as well as characters from other languages.

**To insert special characters or symbols:**
1 Place the insertion point where you want the special character or symbol to appear.
2 Choose Edit > Special Characters to open the Character Palette (or choose Characters from the Action pop-up menu in the lower-left corner of the Font panel).
3 Choose the type of characters you want to see from the View pop-up menu at the top of the Character Palette. If you don’t see the View menu, click the button in the upper-right corner of the window to show the top portion of the window. Click this button again to hide the top portion of the window.
In Mac OS X version 10.4, the Character Palette looks like this:

4 Click an item in the list on the left to see the characters that are available in each category.

5 Double-click the character or symbol on the right that you want to insert into your document, or select the character and click Insert.

If the character or symbol has variations, they appear at the bottom of the window when you click the Character Info triangle or Font Variation triangle at the bottom of the palette. Double-click one to insert it in your document.

Using Smart Quotes
Smart quotes are opening and closing quotation marks that are curly; the opening quotation marks are different from the closing marks. When you don’t use smart quotes, the marks are straight and the opening and closing marks don’t differ.

“ ” Curly quotes

“ ” Straight quotes

To use smart quotes:
- Choose Keynote > Preferences, click Auto-Correction, and then select “Use smart quotes.”
Using Advanced Typography Features
Some fonts, such as Zapfino and Hoefler, have advanced typography features, which let you create different effects. If you are using a font that has different typography effects available, you can change many of them in the Font submenu of the Format menu. For example, you may be able to adjust the following:
- **Kern**: Place characters closer together or farther apart.
- **Ligature**: Use or leave out stylish flourishes between letters or at the end or beginning of lines that combine two or more text characters into one glyph.

![With ligature](image)
![Without ligature](image)

In the Ligature submenu, choose Use Default to use ligature settings specified in the Typography window for the font you’re using, choose Use None to turn off ligatures for selected text, or choose Use All to turn on additional ligatures for the selected text.

- **Baseline**: Move text higher or lower than the text around it.
- **Capitalization**: Convert characters to all capital letters, small capital letters, or initial capital letters (title style).

Advanced typography features are available in the Typography window.

**To open the Typography window:**
1. Click Fonts in the toolbar.
2. In the Font panel, choose Typography from the Action pop-up menu (in the lower-left corner).

Adjusting Font Smoothing
If the fonts on your screen look fuzzy, blurry, or jagged, you may want to adjust the font smoothing style or change the text size at which Mac OS X starts to smooth fonts.

**To smooth the fonts on your screen:**
1. Open System Preferences and click Appearance.
2. Choose a font smoothing style from the pop-up menu at the bottom. Depending on the type of display you have, you may notice only small or no differences between smoothing styles.
3. If you plan to use small font sizes in your document, choose a point size from the “Turn off text smoothing for font sizes” pop-up menu. When text smoothing (or “antialiasing”) is on, smaller fonts can be harder to read.
Setting Text Alignment, Spacing, and Color
The primary tool for adjusting text attributes is the Text Inspector. You can make some horizontal alignment adjustments (such as centering text or aligning it on the left) by using the Format menu.

Using the Text Inspector to Manage Alignment, Spacing, and Color
In the Text pane of the Text Inspector, you can change the text color and alignment. You can also adjust the spacing between individual text characters and lines.

To open the Text pane of the Text Inspector:
- Click Inspector in the toolbar, click the Text Inspector button, and then Click Text.

Aligning Text Horizontally
You can change the alignment of paragraphs in a column, table cell, text box, or shape so that text is aligned to the left or right border, centered, or aligned on both left and right (justified).

To align text left, center, right, or justified:
1. Select the text you want to change.
2. Click Inspector in the toolbar, click the Text Inspector button, and then click Text.
Click one of the five horizontal alignment buttons, located to the right of the color well. From left to right, these buttons have the following effects.

- The Align Left button places each line of text against the left margin of the object.
- The Center button sets the center of each line of text at the center of the object.
- The Align Right button sets each line of text against the right margin of the object.
- The Justify button spaces characters in each line so that the lines reach both the left and right margins of the object.
- The Auto Align Table Cell button left justifies text and right justifies numbers in a table cell.

If you want to indent the first line of text in a paragraph, or learn how to undo paragraph indenting, see “Setting Indents” on page 55.

You can also align text horizontally by choosing Format > Text > Align Left, Center, Align Right, or Justify.

Aligning Text Vertically
You can change the alignment of text in a table cell, text box (except free text boxes), or shape so that text is aligned to the top or bottom border, or centered between them.

To align text to the top, center, or bottom of a text box, table cell, or shape:
1. Select the text box, table cell, or shape whose alignment you want to change.
2. Click Inspector in the toolbar, click the Text Inspector button, and then click Text.
3. Click one of the three vertical alignment buttons, located below Color & Alignment.

Adjusting the Spacing Between Lines of Text
You can increase or decrease the distance between lines of text.

To adjust spacing:
1. Select the text you want to change.
2. Click Inspector in the toolbar, click the Text Inspector button, and then click Text.
3. Move the Line slider left to decrease spacing or right to increase it.

To specify a precise line spacing value, type a point value in the Line field, or click the Up Arrow or Down Arrow next to the field.
Choose a line spacing option from the Line spacing pop-up menu that appears when you click the text below the Line field.

Standard line spacing (Single, Double, Multiple): The space between lines is proportional to font size. Use this when the relative distance between ascenders (parts of letters that extend to the top of the line) and descenders (parts of letters that extend below the line) should remain fixed. Single sets line spacing to single-space, and Double sets it to double-spaced. Multiple lets you set line spacing values between single and double, or greater than double.

At Least: The distance from one line to the next will never be less than the value you set, but it may be larger for larger fonts in order to prevent overlapping text lines. Use this when the distance between lines should remain fixed, but overlap is not desired if the text gets large.

Exactly: The distance between the baselines.

Between: The value you set increases the space between the lines, instead of increasing the height of the lines. By contrast, double-spacing doubles the height of each line.

Adjusting the Spacing Before or After a Paragraph
You can increase or decrease the spacing before or after paragraphs.

To adjust the amount of space before or after a paragraph:
1. Select the paragraphs you want to change.
2. Click Inspector in the toolbar, click the Text Inspector button, and then click Text.
3. Drag the Before Paragraph or After Paragraph slider. You can also specify a precise value (5 pt, for example) in the text boxes.

If the Before Paragraph or After Paragraph values for adjacent paragraphs aren't equal, the higher spacing value will be used. For example, if the current paragraph's Before Paragraph value is 12 points and the paragraph preceding it has an After Paragraph value of 14 points, the spacing between paragraphs will be 14 points.

Spacing before a paragraph does not appear if it's the first paragraph in a text box, shape, or table cell.
To set spacing around text in boxes, shapes, and table cells, use the Inset Margin control, described in “Changing the Inset Margin of Text in Objects” on page 56.

**Adjusting the Spacing Between Characters**
You can increase or decrease the amount of space between characters.

**To adjust the amount of space between characters:**
1. Select the text you want to change, or click where you want to type new text.
2. Click Inspector in the toolbar, click the Text Inspector button, and then click Text.
3. Drag the Character slider or specify a new percentage in the Character field.

You can also adjust the space between selected characters by choosing Format > Font > Kern and choosing an option from the submenu.

**Changing Text Color Using the Text Inspector**
Changes made to text color in the Text Inspector will override text color changes made in the Font panel, and vice versa. (To read about changing color using the Font panel, see “Changing Text Color Using the Font Panel” on page 45.)

**To change text color:**
1. Select the text whose color you want to change, or click in the text to set the insertion point.
2. Click Inspector in the toolbar, click the Text Inspector button, and then click Text.
3. Click the color well.
4. In the Colors window, select a color. See “Using the Colors Window” on page 80 for more information.

**Setting Tab Stops to Align Text**
You can align text at specific points by setting tab stops in a text box, table cell, or shape. To move the insertion point to a tab stop, press Option-Tab.

You can work with tab stop settings by manipulating the tab symbols on the horizontal rulers. You can see symbols for existing tab stops on the horizontal ruler when you click View in the toolbar, choose Show Rulers, and then select some text on a slide.

To set tab stops in lists, see “Using Bulleted, Numbered, and Ordered Lists (Outlines)” on page 56.
Here are ways to work with rulers:

- To show or hide rulers, click View in the toolbar and choose Show Rulers or Hide Rulers.
- To change the units of measure in the rulers, choose Keynote > Preferences, click Rulers, and choose an item from the Ruler Units pop-up menu.
- To display measurements as a percentage of the distance across, choose Keynote > Preferences, click Rulers, and select “Display ruler units as percentage.”
- To place the ruler’s horizontal origin point at the center of the slide, choose Keynote > Preferences, click Rulers, and select “Place origin at center of ruler.”
- To reuse ruler settings elsewhere in your document, choose Format > Text > Copy Ruler and Format > Text > Paste Ruler.

When you change ruler settings in Keynote preferences, the new settings apply to all slides viewed in Keynote until you change the settings again.

**Setting a New Tab Stop**

You use the horizontal ruler to add a new tab stop.

**To create a new tab stop:**

1. Click View in the toolbar and choose Show Rulers.
2. Click the horizontal ruler to place a tab symbol where you want to set the tab stop.
   - If nothing happens, click in text to set the insertion point.
3. Control-click the tab symbol and choose an option from the shortcut menu.

[Diagram: Choose from among these tab types.]

- **Left Tab:** Aligns the left side of text with the tab stop.
- **Center Tab:** Places the center of text at the tab stop.
- **Right Tab:** Aligns the right side of text with the tab stop.
- **Decimal Tab:** For numbers, aligns the decimal character (such as a period or comma) with the tab stop.

You can also double-click the tab symbol repeatedly until the type of tab you want appears.

**Changing a Tab Stop**

You can change the location and type of tab stops using the horizontal ruler.

**To change tab stops:**

1. Click View in the toolbar and choose Show Rulers.
2. To move a tab stop, drag its blue tab symbol in the horizontal ruler.
3 To change the tab to a different type, Control-click the tab symbol and choose an option from the shortcut menu. Or double-click the tab symbol in the ruler repeatedly until the type of tab you want appears.

Deleting a Tab Stop
You can quickly remove a tab stop using the horizontal ruler.

To delete a tab stop:
1 Click View in the toolbar and choose Show Rulers.
2 Drag the tab symbol off the horizontal ruler.

Setting Indents
You can modify the amount of space between text and the inside border of a text box, shape, or table cell.

Setting Indents for Paragraphs
You can change indentation by dragging the indentation controls on the text ruler.

To set indents using the rulers:
1 Click View in the toolbar, and then choose Show Rulers.
2 To change the right indent, drag the right indent icon (downward blue triangle on the right side of the horizontal ruler) to the position where you want the right edge of the paragraph to end.

3 To change the left indent, drag the left indent icon (downward blue triangle on the left side of the ruler) to where you want the left edge of the paragraph to begin.

To change the left margin independently from the left indent, hold down the Option key as you drag.

4 To change the first line indent, drag the first line indent (blue rectangle) to where you want the first line to start.

If you want the first line to remain flush with the left margin, make sure the rectangle aligns with the left indent icon.

If you want to create a hanging indent, drag the rectangle to the left of the left indent icon.

To use the ruler settings elsewhere in your document, choose Format > Text > Copy Ruler and Format > Text > Paste Ruler.
Changing the Inset Margin of Text in Objects
You can change the amount of space between text and the inside border of a text box, shape, or table cell. This measurement is called the inset margin. The amount of space you specify is applied equally around the text on all sides.

To set the spacing between text and the inside of a text box, shape, or table cell:
1 Select the text box, shape, or table cell. (If the insertion point is inside the object, press Command-Return to get out of text editing mode and select the object.)
2 Click Inspector in the toolbar, click the Text Inspector button, and then click Text.
3 Drag the Inset Margin slider to the right to increase the space between text and the inside border of the object, or type a number in the Inset Margin box and press Return. You can also click the arrows to increase and decrease space.

Setting Indents for Lists
To indent bulleted lists, numbered lists, and ordered lists, you use the Text Inspector. See “Using Bulleted, Numbered, and Ordered Lists (Outlines)” for details.

Using Bulleted, Numbered, and Ordered Lists (Outlines)
Keynote provides pre-formatted bullet and numbering styles for creating simple or ordered lists (outlines). Bulleted and numbered lists are simple lists without nested hierarchies of information like you would see in an outline.

Generating Lists Automatically
When you use automatic list generation, Keynote automatically formats a list for you based on what you type. To use this feature, first choose Keynote > Preferences, click Auto-Correction, and make sure that “Automatically detect lists” is selected.

Here are ways to automatically generate lists:
- To create a bulleted list, type a bullet (•), a space, some text, and then press Return. To type a bullet, press Option-8.
- To create a list with labels that are asterisks (*) or hyphens (-), type an asterisk or a hyphen, a space, some text, and then press Return.
- To create a list with labels that are numbers, letters, or Roman numerals, type the number, letter, or Roman numeral; a period; a space; and some text. Then press Return.

You can use any of the character formats on the numbering style pop-up menu in the Text Inspector. To access this menu, in the Text Inspector click Bullets and choose Numbers from the Bullets & Numbering pop-up menu.
Using Bulleted Lists
Although you can use automatic list generation to create a simple bulleted list, using
the Text Inspector gives you many options for formatting bulleted lists

To add and format a bulleted list:
1 Place the insertion point where you want the list to begin.
2 Click Inspector in the toolbar, click the Text Inspector button, and then click Bullets.
3 Choose a bullet style from the Bullets & Numbering pop-up menu.
   To use a typed character as a bullet, choose Text Bullets and choose a character from
   the list or type a new character in the field.
   To use one of the image bullets that comes with Keynote, choose Image Bullets and
   choose an image from the scrolling list.
   To use your own image as a bullet, choose Custom Image and choose an image in the
   Open dialog that appears.
4 To change the size of an image bullet, specify a percentage of the original image size in
   the Size field. Or, select the “Scale with text” checkbox and specify a percentage of the
   text size; this option maintains the image-to-text size ratio of the bullets even if you
   later change the font size of text.
5 To adjust the space between bullets and the left margin, use the Bullet Indent field. To
   adjust the space between bullets and text, use the Text Indent field.
6 To position bullets higher or lower relative to text, use the Align field.

Use these techniques to add and indent bulleted items in your list:
• To add a new topic at the current indent level, press Return.
• To create an unbulleted paragraph within a topic, press Return while holding down
  the Shift key.
• To enter a new topic at the next lower or higher indent level, press Return and click
  one of the arrows adjacent to the Indent Level field. You can also click and hold a
  bullet, and then drag to the right, to the left, down and to the right, or down and to
  the left.
• To return to regular text at the end of your list, press Return twice, or press Return
  and choose No Bullets from the Bullets & Numbering pop-up menu. You may also
  need to adjust the indent level.

Using Numbered Lists
Although you can use automatic list generation to create a simple numbered list, using
the Text Inspector gives you many options for formatting numbered lists. See
“Generating Lists Automatically” on page 56 for information about automatic list
generation.
To add and format a numbered list:
1. Place the insertion point where you want the list to begin.
2. Click Inspector in the toolbar, click the Text Inspector button, and then click Bullets.
3. Choose Numbers from the Bullets & Numbering pop-up menu, and then choose a numbering style from the pop-up menu directly below it.
4. To adjust the space between numbers and the left margin, use the Number Indent field. To adjust the space between numbers and text, use the Text Indent field.

Use these techniques to add and indent items in your list:
- To add a new topic at the current indent level, press Return.
- To create an unnumbered paragraph within a topic, press Return while holding down the Shift key.
- To enter a new topic at the next lower or higher indent level, press Return and click one of the arrows adjacent to the Indent Level field. You can also click and hold a number, and then drag to the right, to the left, down and to the right, or down and to the left.
- To return to regular text at the end of your list, press Return twice, or press Return and choose No Bullets from the Bullets & Numbering pop-up menu. You may also need to adjust the indent level.
- To add an existing paragraph to a numbered list, click the paragraph, choose a numbering style, and click “Continue from previous.”
- To start a new numbered sequence in a list, click “Start at” and specify the number you want the sequence to begin with.

If you want items in your list to have labeled subtopics (like in an outline), use an ordered list instead of a numbered list.

Using Ordered Lists (Outlines)
Ordered lists (or outlines) provide different numbering styles for each indent level in a list, allowing you to create a hierarchy of information. For example:
- You can create an outline using a numbering sequence such as the following as you proceed from the highest level to lower levels: 1, A, 1, a), (1), (a), i), (1), and (a).
- You can create a legal style outline, which appends an additional number or letter at each lower level: 1, 1.1, 1.1.1, and so on.

You can add and format ordered lists using the Text Inspector.

To add and format an ordered list:
1. Place the insertion point where you want the list to begin.
2. Click Inspector in the toolbar, click the Text Inspector button, and then click List.
To create a legal style list, choose Tiered Numbers from the Bullets & Numbering pop-up menu. Otherwise, choose Numbers instead.

Choose a numbering style from the pop-up menu directly below it.

To adjust the space between numbers and the left margin, use the Number Indent field. To adjust the space between numbers and text, use the Text Indent field.

Use these techniques to add and indent items in your list:

- To add a new topic at the current indent level, press Return.
- To create an unnumbered paragraph within a topic, press Return while holding down the Shift key.
- To enter a new topic at the next lower indent level, press Tab. To enter a new topic at the next higher level, press Shift-Tab. To move among levels you can also click and hold a number, and then drag to the right, to the left, down and to the right, or down and to the left.
- To return to regular text at the end of your list, press Return twice, or press Return and choose No Bullets from the Bullets & Numbering pop-up menu. You may also need to adjust the indent level.
- To add an existing paragraph to a numbered list, click the paragraph, choose a numbering style, and then click “Continue from previous.”
- To start a new numbered sequence in a list, click “Start at” and specify the number you want the sequence to begin with.

Using Text Boxes and Shapes to Highlight Text

Use text boxes and shapes to make text stand out from the main body of text on a slide.

Adding Free Text Boxes

Various master slides provide text boxes, but you can add one or more “free text boxes” to a slide. Free text boxes are similar to the text boxes provided in various master slides. The main difference is that text in free text boxes does not appear in outline view.

You can drag free text boxes anywhere on a slide.

To create a free text box:
1 Click Text Box in the toolbar (or choose Insert > Text Box).
2 In the text box that appears, double-click the text and type.
   Free text boxes grow horizontally—to the width of the slide—to accommodate your text. To use the full slide width for the text, skip the next step.
3 To set a fixed width for the text box, drag its handles.
After you set a width (or the box is as wide as the slide), the text box grows vertically to accommodate your text. If you delete text, the box automatically shrinks.

4 When you’ve finished typing, click outside the text box. Or, to stop editing text and select the text box, press Command-Return.

5 Drag the text box to position it on the slide.

You can also draw a free text box. Option-click Text Box in the toolbar, and drag the pointer across the document window to create a text box that’s the size you want.

For more information about modifying text boxes, see “Formatting a Text Box or Shape” on page 61.

Presenting Text in Columns
You can create columns in a text box or a rectangular shape. When text fills one column, it flows into the next column.

To create and format columns:
1 Select the text box you want to divide into columns.
2 Click Inspector in the toolbar, click the Text Inspector button, and then click Columns.
3 To indicate how many columns you want, use the Columns field.
4 To use equal-width columns, select “Equal column width.”
   To set up different column widths, deselect “Equal column width,” double-click a Column value in the table, and type a new width.
5 To change the distance between columns, double-click a Gutter value and change it.

Putting Text Inside a Shape
All shapes, except lines, can contain text.

To add text to a shape:
1 Place a shape where you want it on the slide. To learn about adding shapes, see “Adding a Predrawn Shape” on page 82 and “Adding a Custom Shape” on page 83.
2 Double-click the shape and type the text you want. If the text extends beyond the border of the shape, a clipping indicator appears.

3 To resize the shape, select it and drag the selection handles. (If the insertion point is inside the shape, press Command-Return to get out of text editing mode and select the shape.)
You can format the text within a shape. You can also rotate a shape while keeping its text horizontal. After rotating the shape choose Format > Shape > Reset Text and Object Handles.

4 To add text to a shape that’s part of a group, double-click the text area of any shape in the group. If you resize the group, everything resizes except for the text. You can still edit and format the text.

See “Grouping and Locking Objects” on page 78 for details about grouping objects.

Formatting a Text Box or Shape
You can change the amount of space between text and the inside border of a text box, shape, or table cell. See “Changing the Inset Margin of Text in Objects” on page 56 for instructions.

Use the Graphic Inspector to format borders, shadows, opacity, color fill, and more for text boxes or shapes. For more information about setting object properties, see “Modifying Objects” on page 73.

Using Hyperlinks
You can turn text, images, and shapes into hyperlinks that open another slide, a Keynote document, a webpage, or an email message or that stop a slideshow.

<table>
<thead>
<tr>
<th>Use this type of hyperlink</th>
<th>To perform this action</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Webpage</td>
<td>Open a page in a web browser</td>
<td>Keynote opens your default browser.</td>
</tr>
<tr>
<td>Email Message</td>
<td>Open a new mail message with the specified subject and addressee</td>
<td>Keynote opens your default mail application.</td>
</tr>
<tr>
<td>Slide</td>
<td>Go to another slide in the presentation</td>
<td>Choose from the next, previous, first, or last slide; the last slide viewed; or a specific slide.</td>
</tr>
<tr>
<td>Keynote File</td>
<td>Open another Keynote document</td>
<td>If you transfer the presentation to another computer, remember to transfer the other document as well.</td>
</tr>
<tr>
<td>Exit Slideshow</td>
<td>Stop the slideshow</td>
<td>Keynote opens in edit mode to the last slide shown.</td>
</tr>
</tbody>
</table>

This underlined text is a hyperlink.

The blue arrow indicates that this text box is a hyperlink.
Linking to a Webpage
You can add a hyperlink that opens a webpage in your default web browser.

To add a hyperlink that opens a webpage:
1 Select the text or object that you want to turn into a hyperlink.
   If you type text that starts with “www” or “http” (or copy it from another document),
   the text automatically becomes a hyperlink. To turn off this feature, choose Keynote >
   Preferences, click Auto-Correction, and deselect “Automatically detect email and web
   addresses.” This setting is computer-specific, so if the document is opened on a
   computer with a different setting, that computer’s setting is used instead.
2 Click Inspector in the toolbar, click the Hyperlink Inspector button, and then select
   “Enable as a hyperlink.”
3 Choose Webpage from the Link To pop-up menu.
4 Type the webpage’s address in the URL field.
5 If you want to change text that appears as the hyperlink in the document, type new
   text in the Display field.

Linking to a Preaddressed Email Message
You can add a hyperlink that you can click to create a preaddressed email message in
your default mail application.

To add a hyperlink that links to an email message:
1 Select the text or object that you want to turn into a hyperlink.
   If you type an email address (or copy it from another document), the text automatically
   becomes a hyperlink. To turn off this feature, choose Keynote > Preferences, click Auto-
   Correction, and then deselect “Automatically detect email and web addresses.” This
   setting is computer-specific, so if the document is opened on a computer with a
   different setting, that computer’s setting is used instead.
2 Click Inspector in the toolbar, click the Hyperlink Inspector button, and then select
   “Enable as a hyperlink.”
3 Choose Email Message from the Link To pop-up menu.
4 Type the email address of the intended recipient in the To field.
5 Optionally type a subject line in the Subject field.
6 To display custom text for the hyperlink, type new text in the Display field. (This option is dimmed if you chose an object instead of text as the hyperlink.)

**Linking to a Slide**
Add a hyperlink that displays a particular slide.

**To add a hyperlink that links to a slide:**
1 Select the text or object that you want to turn into a hyperlink.
2 Click Inspector in the toolbar, click the Hyperlink Inspector button, and then select “Enable as a hyperlink.”
3 Choose Slide from the Link To pop-up menu.
4 Select the option that describes the slide you want to display (next, previous, first, last, last viewed, or a slide number).

You can use hyperlinks to control navigation during a slideshow. See “Creating Hyperlinks-Only Presentations” on page 164.

**Linking to a Keynote File**
Add a hyperlink that opens another Keynote file.

**To add a hyperlink that opens another Keynote document:**
1 Select the text or object that you want to turn into a hyperlink.
2 Click Inspector in the toolbar, click the Hyperlink Inspector button, and then select “Enable as a hyperlink.”
3 Choose Keynote File from the Link To pop-up menu.
4 Navigate to the file, and click Open.
5 If you want to change text that appears as the hyperlink in the document, type new text in the Display field.

When you click a link to another Keynote document, the new slideshow begins playing from the first slide.

**Using a Hyperlink to Stop a Slideshow**
Add a hyperlink that stops a slideshow.

**To add a hyperlink that stops a slideshow:**
1 Select the text or object that you want to turn into a hyperlink.
2 Click Inspector in the toolbar, click the Hyperlink Inspector button, and then select “Enable as a hyperlink.”
3 Choose Exit Slideshow from the Link To pop-up menu.

**Underlining Hyperlink Text**
Hyperlink text is underlined by default, but you can suppress underlining if you like.

**Here are ways to enable and disable underlining:**
- To prevent new text hyperlinks from being automatically underlined, choose Keynote > Preferences, click General, and deselect “Underline text hyperlinks on creation.”
- To remove an underline from an existing text hyperlink, select it, click Fonts in the toolbar, and in the Font panel choose None from the Underline pop-up menu.
- To underline hyperlink text that isn't underlined, click Fonts in the toolbar, and in the Font panel choose Single from the Underline pop-up menu.

**Automatically Substituting Text**
Keynote can be set to recognize and replace text you don’t want with text you do want. For example, when you type “teh,” Keynote can automatically change it to “the.”

**To set up automatic text substitution:**
1 Choose Keynote > Preferences.
2 Click Auto-Correction and select an option:
   - To automatically convert single and double quotation marks to smart quotes so that opening and closing quotation marks are not identical, select “Use smart quotes.”
   - To make sure that the first word in a sentence begins with a capital letter, select “Fix capitalization.”
   - To automatically convert the letters in “1st,” “2nd,” “3rd,” and so on into superscripts, select “Superscript numerical suffixes.”
To set Keynote to automatically detect that something you’ve typed is an email address or a URL, select “Automatically detect email and web addresses.” Email and web addresses you type automatically become hyperlinks for Mail or Safari.

To replace one or more characters with one or more different characters, select “Symbol and text substitution.” Then use the rows in the table to define and activate specific substitutions. For example, when you type (c), you can have Keynote automatically convert it to © by putting a checkmark in the On column. To define your own substitution, click the Add (+) button. To remove a selected item, click the Delete (–) button.

After you specify substitution settings, they’ll apply to any text you change or add in any Keynote documents.

**Inserting a Nonbreaking Space**
You can insert a nonbreaking space between words to make sure that the words always appear in the same line of text.

**To insert a nonbreaking space:**
- Press the Space bar while holding down the Option key.

**Checking for Spelling Mistakes**
Keynote can catch spelling errors in your document and help you find alternative spellings for misspelled words.

**Finding Misspelled Words**
You can set the spell checker to flag spelling errors as you type, or you can check your entire document or selected text at any time.

Misspelled words appear with a red line below them.

**Here are ways to find misspelled words:**
- To check spelling as you type, choose Edit > Spelling > “Check Spelling as You Type.”
- To turn off spell checking as you type, click Edit > Spelling > “Check Spelling as You Type” to deselect it (make sure the checkmark is not visible next to the menu command).
- To check spelling from the insertion point to the end of the document, click to place the insertion point and choose Edit > Spelling > Check Spelling. To limit spell checking to a specific part of the document, select the text you want to check before choosing the command.

The first misspelled word found is highlighted. You can correct it or choose the same menu command again to continue checking the document.
To go through the text more quickly, press Command-semicolon (;) to continue checking the document.

To check spelling and view suggestions for misspelled words, choose Edit > Spelling > Spelling.

The Spelling window opens, and you can use it as “Working with Spelling Suggestions,” next, describes.

**Working with Spelling Suggestions**

Use the Spelling window to work with alternative spellings.

**To work with spelling suggestions:**

1. Choose Edit > Spelling > Spelling.

   The Spelling window opens and the first misspelled word is highlighted:

2. Make sure that the correct language is selected in the Dictionary pop-up menu. Each language uses a different spelling dictionary.

3. To replace the incorrect spelling in the text, double-click the correct word or spelling in the Guess list.

4. If the correct word doesn’t appear in the Guess list but you know the correct spelling, select the misspelled word in the Spelling window, type the correct word, and click Correct.

5. If the current spelling is correct and you want to leave it as it is, click Ignore or Learn. Use Learn if the term is one you use often and you want to add it to the spelling dictionary.

   If you used Learn and later decide you don’t want the word in the dictionary, type the word into the text field below the Guess list, and then click Forget.

6. If no alternate spellings appear in the Guess list, select the misspelled word in the Spelling window and try a different spelling. Click Guess to see whether new possibilities appear in the Guess list.

7. Click Find Next and repeat steps 3 through 6 until you find no more spelling errors.

   You can also hold down the Control key and click a misspelled word. From the pop-up menu you can choose an optional alternative spelling, click Learn, or click Ignore.
Finding and Replacing Text
You can find every instance of a word or phrase in your document, and optionally change it to something else.

Here are ways to find and replace text:

- Choose Edit > Find > Find, click Simple or Advanced to set up find/replace criteria, and then click a button to conduct find/replace operations.
  
  **Simple:** In the Find field, type the text you want to find, and type any text you want to replace it with in the Replace field.

  **Advanced:** In addition to typing Find and Replace text, you can set up additional find/replace criteria.

  - **Replace All:** Automatically conducts the find/replace operation without your review.
  - **Replace:** Replaces the current selection with the replacement text.
  - **Replace & Find:** Replaces the current selection with the replacement text and immediately finds the next occurrence.
  - **Next or Previous:** Finds the next or previous occurrence of the Find text.

- Use the other commands on the Edit > Find submenu.

  - **Find Next or Find Previous:** Finds the next or previous occurrence of the current Find text.
  - **Use Selection for Find:** Finds the next occurrence of the selected text.
  - **Jump to Selection:** Displays the selected text when it’s not currently in view.
This chapter describes techniques for adding and modifying images, shapes, sound, and other objects.

An object is an item you can add to a document and then manipulate. Images, shapes, movies, audio files, web views, tables, charts, and text boxes are all objects.

Images include photographs or PDF files. Movies and sound can be used throughout a slideshow or only with particular slides. Shapes include simple predrawn shapes (such as triangles and arrows) and custom shapes that you draw yourself. Web views are webpage snapshots you can display on a slide.

**Selecting Objects**

Before you can move, modify, or perform other operations on objects, you must select them. A selected object has handles that let you move or manipulate them.

**Here are ways to select and deselect objects:**

- To select a single object, click anywhere on the object (to select an object that has no fill, click the edge).
- To select several objects on a slide, hold down the Shift key as you click objects.
- To select all the objects on a slide, click the slide and press Command-A.
- To select an object that's part of a group, you must first ungroup the objects. Select the group, and then choose Arrange > Ungroup.
- To deselect objects in a group of selected objects, hold down the Command key and then click objects you want to deselect.

**Copying or Duplicating Objects**

The technique you use to copy an object depends on where you want to place the copy. When the copy will be far from the original or in another document, copying and pasting is generally easier. When you’re working with an object that is near the original, duplicating is generally easier.
Here are ways to copy objects:

- To copy and paste an object, select it, and then choose Edit > Copy. Click where you want the copy to appear. Choose Edit > Paste.

- To duplicate an object on a slide, hold down the Option key while you drag the object. You can also duplicate the object. Select the object and choose Edit > Duplicate. The copy appears on top of the original, slightly offset. Drag the copy to the desired location.

- To copy an image between Keynote documents, select the image and drag its icon from the File Info field in the Metrics Inspector to a slide in the other Keynote file.

Deleting Objects
Deleting objects is quick and easy.

To delete objects:

- Select the object(s) and press the Delete key.

If you accidentally delete an object, choose Edit > Undo Delete.

Moving Objects
You can drag objects or cut and paste them to move them.

Here are ways to move objects:

- Click the object to select it (the selection handles appear), and then drag it to a new location.

- To constrain the object’s motion to horizontal, vertical, or a 45 degree angle, start dragging the object while holding down the Shift key.

- To move the object in small increments, press one of the arrow keys, causing the object to move a point at a time. To move the object ten points at a time, hold down the Shift key while pressing an arrow key.

- To show the position of the object when you move it, choose Keynote > Preferences, and then select “Show size and position when moving objects” in the General pane.

- To precisely align objects by their edges or centers, you can use alignment guides. See “Using Alignment Guides” on page 71 for details.

- Select the object and choose Edit > Cut. Place the insertion point where you want the object to appear, and then choose Edit > Paste.

Avoid dragging an object by the selection handles because you may inadvertently resize the object.
Moving an Object Forward or Backward (Layering Objects)
When objects overlap or when text and objects overlap, you can change the order of objects in the stack.

To move an object in front or in back of text or another object:
1. Select the object you want to move.
2. To move an object a layer at a time, choose Arrange > Bring Forward or Arrange > Send Backward.
3. To move an object to the very top or bottom of the stack, choose Arrange > Bring to Front or Arrange > Send to Back.

If you frequently layer objects, you can add the Front, Back, Forward, and Backward buttons to the toolbar to work more efficiently. To learn about customizing the toolbar, see “The Toolbar” on page 21.

Aligning Objects
There are various ways to align objects on slides.

Aligning Objects on a Slide Relative to One Another
You can quickly align objects relative to one another if they appear on the same slide.

To align objects:
1. Shift-click to select the objects you want to align.
2. Choose Arrange > Align Objects and then choose one of the alignment options in the submenu.
   - Left: Positions objects so that their left edges align vertically to the first object you select.
   - Center: Positions objects so that their centers align vertically to the first object you select.
   - Right: Positions objects so that their right edges align vertically to the first object you select.
   - Top: Positions objects so that their top edges align horizontally to the first object you select.
   - Middle: Moves objects vertically so that their centers align horizontally to the first object you select.
   - Bottom: Positions objects so that their bottom edges align horizontally to the first object you select.

You can also align objects relative to one another by dragging them and using alignment guides to determine when the objects are correctly positioned. See “Using Alignment Guides” for more information.
Spacing Objects Evenly on a Slide
You can quickly place an equal amount of space between objects, regardless of their size.

To space objects evenly:
1 Select the objects.
2 Choose Arrange > Distribute Objects, and then choose an option from the submenu.
   Horizontally: Adjusts the horizontal spacing between objects.
   Vertically: Adjusts the vertical spacing between objects.

Using Alignment Guides
You can turn on alignment guides to help you align objects on a slide. Alignment guide settings apply to all Keynote documents.

To turn on alignment guides:
1 Choose Keynote > Preferences, and then click Rulers.
2 To show guides when an object’s center aligns with another object or the center of the slide, select “Show guides at object center.”
3 To show guides when an object’s edges align with another object, select “Show guides at object edges.”
4 To change the color of alignment guides, click the color well and select a color in the Colors window.

Alignment guides don’t appear on printed slides.

To show or hide guides, choose View > Show Guides or View > Hide Guides. To temporarily hide alignment guides, hold down the Command key while you drag an object.

You can also create your own alignment guides to help you place objects in the same position on different slides.

Creating Your Own Alignment Guides
You can create your own alignment guides to help you place objects in the same position on different slides.

To create an alignment guide:
1 Click View in the toolbar, and then choose Show Rulers.
2 Place the pointer over a ruler and drag onto the slide canvas.
   An alignment guide appears.
3 Drag the guide where you want it on the slide.

*Note:* Alignment guides can’t be created if you are editing text. Stop editing text by selecting an object or clicking the slide canvas.

To remove an alignment guide that you’ve created, drag it off the edge of the slide.

**Using Master Gridlines**

In addition to alignment guides on a slide, you can turn on vertical and horizontal gridlines that divide a slide into equal sections.

Gridlines show on master slides, and appear on a slide when an object (its center or edge, depending on your Object Alignment preferences) aligns with a gridline. Gridlines don’t appear on printed slides.

**To turn on master gridlines:**

1. Choose Keynote > Preferences, and then click Rulers.
2. Select either or both of the Master Gridlines checkboxes.
3. Type a percentage value in the field to specify how close together the gridlines should be.
4. To change the color of gridlines, click the Master Gridlines color well and select a color in the Colors window.

To temporarily hide gridlines, hold down the Command key while you drag an object.

**Setting Precise Positions of Objects**

You use the Metrics Inspector to precisely locate objects.

**To set the precise position of an object:**

1. Select the object you want to position.
2. Click Inspector in the toolbar, and then click the Metrics Inspector button.
3. Enter X and Y values in the Position fields.

The specified coordinates determine the position of the upper-left corner of the object’s container box.

- The X value is measured from the left edge of the slide canvas.
- The Y value is measured from the top edge of the slide canvas.

If an object is rotated, the X and Y coordinates specify the upper-left corner of the rotated container box.
When you enter X and Y coordinates for line positions in the Metrics Inspector, the Start coordinates represent the first endpoint you created. If you later flip or rotate the line, the Start coordinates continue to represent the first endpoint.

Position a fixed line on the slide by specifying X and Y coordinates for its first endpoint.

Position a fixed line on the slide by specifying X and Y coordinates for its second endpoint.

Modifying Objects
You can resize objects, change their orientation, modify their border styles, add shadows and reflections to them, and adjust their opacity.

Resizing Objects
You can resize an object by dragging its handles or typing exact dimensions.

Here are ways to resize objects:

- To resize an object by dragging, select the object and then drag one of its selection handles. To resize an object in one direction, drag a side handle instead of a corner handle.
  
  To resize the object from its center, press the Option key as you drag.

  To maintain an object’s proportions, hold down the Shift key as you drag. You can also click Inspector in the toolbar, click the Metrics Inspector button, and then select “Constrain proportions” before dragging.

  To show the size of an object when you drag a selection handle, choose Keynote > Preferences, and then select “Show size and position when moving objects” in the General pane.

- To resize an object using exact proportions, select the object, click Inspector in the toolbar, click the Metrics Inspector button, and then use the Width and Height controls.

- To resize several objects at once, select the objects, click Inspector in the toolbar, click the Metrics Inspector button, and then type new values in the Width and Height fields.

- Select the object and then click Original Size in the Metrics Inspector.
**Flipping and Rotating Objects**

You can flip or rotate any object. For example, if you have an image of an arrow that you want to use in your document, but you need it to point in a different direction, you can reverse its direction vertically or horizontally, or point it at any angle.

**Here are ways to change an object’s orientation:**
- To flip an object horizontally or vertically, select the object, and then choose Arrange > Flip Horizontally or Arrange > Flip Vertically.
  
  You can also click Inspector in the toolbar, click the Metrics Inspector button, and then use the Flip buttons.
- To rotate an object, select the object, hold down the Command key and move the pointer toward an active selection handle until it changes to a curved, double-headed arrow, and then drag a selection handle.
  
  To rotate an object in 45-degree increments, press the Shift and Command keys while dragging a selection handle.
  
  You can also click Inspector in the toolbar, click the Metrics Inspector button, and then drag the Rotate wheel or use the Angle controls to set the angle of the object.
- To rotate a shape but keep its text horizontal, after rotating the shape choose Format > Shape > Reset Text and Object Handles.

**Changing the Style of Borders**

For shapes, chart elements, text boxes, and table cells, you can choose a line style and color for the object’s border, or you can specify no border. You can also put a border around imported images. You set border line style and color using the Graphic Inspector and the Colors window.

**To set the line style and color of an object’s border:**
1 Select the object that you want to modify.
2 Click Inspector in the toolbar, and then click the Graphic Inspector button.
3 Choose Line from the Stroke pop-up menu.
4 Choose a line style from the pop-up menu. For tables, only a solid line or None is available.
5 To change the line thickness, type a value in the Stroke field (or click the arrows).
6 To change the line color, click the color well and select a color.
7 To give the line endpoints, such as arrowheads or circles, choose left and right endpoints from the pop-up menus.

**Framing Objects**
Enclose your text boxes, images, movies, shapes, and media placeholders with graphical borders, known as *picture frames*.

**Here are ways to work with picture frames:**
- To add a picture frame, select the media or media placeholder, click Inspector in the toolbar, and then click the Graphic Inspector button.
  
  Choose Picture Frame from the Stroke pop-up menu, and then click the thumbnail to choose one.

  Some picture frames can be adjusted. To adjust your frame, use the Scale slider or type a specific percentage in the adjacent field.

- To change a picture frame, select a framed media or media placeholder, click Inspector in the toolbar, and then click the Graphic Inspector button. Choose Picture Frame from the Stroke pop-up menu, and then click the arrow next to the thumbnail to choose a new picture frame.

- To remove a picture frame from your media or media placeholder, select the media or media placeholder and then choose a line style (or None) from the Stroke pop-up menu.
Adding Shadows

Shadows give your objects an appearance of depth. An object’s shadow appears on any object behind it. You can create a variety of shadow effects, or remove the shadow from an object.

To add a shadow to an object:
1 Select the object.
2 Click Inspector in the toolbar, and then click the Graphic Inspector button.
3 Select Shadow to add a shadow to the object. Deselect Shadow to make a shadow go away.
4 Set the angle for the shadow using the Angle controls.
5 To set how far the shadow is from the object, use the Offset controls. A high shadow offset value makes an object’s shadow appear longer and slightly separated from the object.
6 To adjust the softness of the shadow’s edge, use the Blur controls. A high blur value makes the object’s shadow appear more diffuse; a low value gives the shadow more sharply defined edges.
7 To change the shadow’s transparency, use the Opacity controls. Don’t use the Opacity slider at the bottom of the Graphic Inspector, which is for controlling the opacity of the object itself.
8 To change the color for the shadow, click the Shadow color well and select a color.
You can also use the Graphic Inspector shadow controls to add shadows to text. Select the text to which you want to add shadows, and use the controls as described above.

**Adding a Reflection**

You can add a reflection to an object that reflects vertically downward.

To add a reflection to an object:
1. Select the object.
2. Click Inspector in the toolbar, and then click the Graphic Inspector button.
3. Select Reflection and drag the slider to increase or decrease the amount of reflection.

**Adjusting Opacity**

You can create interesting effects by making objects more opaque or less opaque.

When you put a low-opacity object on top of another object, for example, the bottom object shows through the top object. Depending on how high or low you set the opacity, the objects below can be highly visible, partly obscured, or completely blocked from view (at 100-percent opacity).

To change an object’s opacity:
1. Select the object.
2. Click Inspector in the toolbar, and then click the Graphic Inspector button.
3. Drag the Opacity slider or enter a percentage in the adjacent field.
For shapes, you can set opacity for fill and stroke colors separately from object opacity. If you move the Opacity slider in the Colors window to modify a fill or stroke color, that opacity value becomes maximum object opacity. Then, when you change the object opacity in the Graphic Inspector, you are changing it relative to the opacity you set in the Colors window.

If you change an object’s opacity and then can’t restore the object’s fill color to 100%, it may be because the opacity was set to less than 100% in the Colors window. To fix it, select the object, choose View > Show Colors, and then set the opacity in the Colors window to 100%.

**Grouping and Locking Objects**

Group objects you want to keep together, and lock objects you don’t want to inadvertently move.

**Grouping and Ungrouping Objects**

You can group objects together so that they can be moved, copied, resized, and oriented as a single object. You can edit text associated with a shape or text object in a group, but you can’t modify other attributes of individual objects in the group.

Grouped objects are built as one unit during object builds.

**To group objects:**

1. Hold down the Command (or Shift) key as you select the objects you want to group. If you can’t select an object, it may be locked.

2. Choose Arrange > Group, or click Group in the toolbar.

To ungroup a grouped object, select the group, and then choose Arrange > Ungroup or click Ungroup in the toolbar. If the group is locked, unlock it first.

If you group an object that has a build effect assigned to it, the effect is removed. Ungrouping a grouped object with a build effect assigned to it also removes the build effect.
Locking and Unlocking Objects
You can lock objects to avoid inadvertently moving them as you work.

After you lock individual or grouped objects, you can't move, delete, or modify them until you unlock them. A locked object can be selected, copied, or duplicated; when you copy or duplicate a locked object, the new object is also locked.

To lock objects:
1 Hold down the Command (or Shift) key as you select the objects you want to lock.
2 Choose Arrange > Lock.

To unlock an object, select the object, and then choose Arrange > Unlock.

Filling Objects
Fill an object with a solid color, a color gradient, or an image.

Filling an Object with Color
Use the Graphic Inspector to fill an object with a solid color or a color gradient, in which two colors gradually blend with each other.

To change an object's fill color:
1 Select the object.
2 Click Inspector in the toolbar, and then click the Graphic Inspector button.
3 To apply a solid fill color, choose Color Fill from the Fill pop-up menu. Click the color well below the Fill pop-up menu to open the Colors window, and then select a color in the Colors window.
4 To fill an object with a color gradient, choose Gradient Fill from the Fill pop-up menu. Click each color well and choose each color in the Colors window.
   To set a direction for the gradient, use the Angle wheel or field. To flip it horizontally or vertically, click the Angle arrow buttons.
   To invert the gradient, click the double-headed arrow next to the color wells.

Instructions for using the Colors Window follow.
Using the Colors Window
You use the Colors window to select color for objects.

You can use the color wheel in the Colors window to select colors. The color you select appears in the box at the top of the Colors window. You can save that color for future use by placing it in the color palette.

To apply the colors you select in the Colors window to an object on the slide, you must place the color in the appropriate color well in an Inspector pane. You can select a color well in one of the Inspectors, and then click a color in the color wheel. Or you can drag a color from the color palette or color box to a color well in one of the Inspectors.

To select a color:
1. Open the Color window by clicking Colors in the toolbar or clicking a color well in one of the inspectors.
2. Click anywhere in the color wheel. The selected color is displayed in the color box at the top of the Colors window.
3. To make the color lighter or darker, drag the slider on the right side of the Colors window.
4. To make the color more transparent, drag the Opacity slider to the left or enter a percentage value in the Opacity field.
5. To use the color palette, open it by dragging the handle at the bottom of the Colors window. Save a color in the palette by dragging the color from the color box to the color palette. To remove a color from the palette, drag a blank square to the color you want to remove.
6. To match the color of another item on the screen, click the magnifying glass to the left of the color box in the Colors window. Click the item on the screen whose color you want to match. The color appears in the color box. Select the item you want to color in the document window, and then drag the color from the color box to the item.

**Filling an Object with an Image**

You can fill a shape, text box, table, table cell, chart background, or chart series with an image.

**To fill an object with an image:**

1. Select the object you want to fill with an image.

2. If the Graphic Inspector isn't open, click Inspector in the toolbar and click the Graphic Inspector button.

3. In the Graphic Inspector, choose Image Fill or Tinted Image Fill, and then choose an image.

You can also drag an image file from the Finder or Media Browser to the image well in the Graphic Inspector. You can also drag an image to a table cell or chart series.

Use the pop-up menu to set the size of the image within the object.

4. Choose an image scale from the pop-up menu.

*Scale To Fit:* Resizes the image to fit the object’s dimensions as well as possible. If the object’s shape is different from the original image’s, parts of the image may not appear; blank space may also appear around the image.

*Scale To Fill:* Makes the image appear larger or smaller, sizing it to leave minimum space around the image, even if the object and image have different shapes.

*Stretch:* Sizes the image to fit the object’s dimensions but distorts it if the object has a shape different from the original image.

*Original Size:* Places the image inside the object without altering its original dimensions. If the image is larger than the object, you see only a part of the image in the object. If the image is smaller than the object, there is blank space around it.
Tile: Repeats the image inside the object, if the image is smaller than the object. If the image is larger than the object, you see only part of the image inside the object.

5 If you chose Tinted Image Fill, click the color well (to the right of the Choose button) to choose a tint color. Drag the Opacity slider in the Colors window to make the tint darker or lighter. (If you drag the Opacity slider in the Graphic Inspector, it will change the opacity of both the tint and the image.)

Using Shapes
Keynote provides a variety of predrawn shapes you can add to slides. You can also create your own custom shapes.

Adding a Predrawn Shape
You can insert predrawn shapes, such as triangles, arrows, circles, and rectangles, to use as simple graphics.

Here are ways to add a predrawn shape:
- Click Shapes in the toolbar, and then choose a shape from the Shapes submenu. You can also choose Insert > Shape > Shape.
- You can also create one of the included shapes from the shape’s center. Option-click Shapes in the toolbar, choose a shape, and then drag the crosshair pointer. To constrain the shape (for example, to keep triangles equal on all sides), press the Shift key as you drag.
Adding a Custom Shape
You can use the Draw tool to create your own shapes.

To create a custom shape:
1 Click Shapes in the toolbar, and then select the Draw tool (or choose Insert > Shape > Draw a Shape).

The pointer changes from an arrow to a small pen tip.

2 Click anywhere in your document to create the first point of the custom shape.
3 Click to create more points.
   Each point you add is connected to the preceding point. The shape is filled with the default color for the theme you’re using.
   To delete a segment you’ve just created, press Delete. You can press Delete multiple times.
4 To stop drawing and close the shape (add a solid line between the last and first points), click the first point.
   To stop drawing and leave the shape open (no line between the last and first points) so that you can work with it more later, press the Esc (Escape) key or double-click the last point created.
   To finish and close an open shape, click once in the shape to select it, and then click it a second time to show its points. Double-click one of the two points at either end of the open segment. The pointer changes to a pen tip.

To add additional points, click other locations as needed. When you’re ready to stop drawing and close the shape, click the point at the end of the open segment.
Making Shapes Editable
In addition to resizing shapes, you can manipulate the points of a shape. Before you can edit a shape in this way, you need to make it editable.

Here are ways to make shapes editable:
- To make a predrawn shape editable, select the shape and then choose Format > Shape > Make Editable.
  Red dots appear on the shape. Drag the points to edit the shape. Later, to edit a predrawn shape that has been made editable, click it twice slowly.
- To make a custom shape editable, click once in the shape to select it, and then click a second time to show its points.

Manipulating Points of a Shape
You can change the contour of a shape by adding, moving, or deleting its points. First you need to make the shape editable, as described in “Making Shapes Editable” on page 84.

Here are ways to manipulate a shape’s points:
- To add a point, make the shape editable, press the Option key, and then hold the pointer over the shape’s border. The pointer changes into a pen tip with a plus sign (+). Click the location on the border where you want to add a point, and then move the point if needed.
- To move a point, make the shape editable, click the point, and then drag it to another location. You can move several points at the same time by Shift-clicking multiple points, and then dragging.
- To delete a point, make the shape editable, click the point, and then press the Delete key. You can delete several points at the same time by Shift-clicking multiple points and then pressing Delete.
Reshaping a Curve
You can expand or contract a curve, or change its angle.

To reshape a curve:
1. Make the shape editable.
2. Click a red circular control on the curve you want to reshape. A control handle appears on both sides of the circular control.
3. To expand or contract the curve, drag the circular control or one of the control handles.
4. To change the angle of the curve, move the control handles clockwise or counter-clockwise. You achieve different effects when you move the handles together or independently of each other. Experiment until you achieve the desired effect.
   - To move the control handles together, press the Option key, and then drag one or the other of them.
   - To move only one control handle, press the Command key before dragging a handle.

Reshaping a Straight Segment
You can change the angle between two segments, or change the length of a segment.

To reshape a straight segment:
1. Make the shape editable.
2. Click a corner point.
3. To change the angle between the two attached segments, drag the point clockwise or counter-clockwise.
4. To change the length of one of the segments, drag the point out or in.

Transforming Corner Points into Curved Points and Vice Versa
You can change one or more points into curves or curves into points.

Here are ways to transform corner points into curved points and vice versa:
- To change a corner point into a curved point, make the shape editable, and then double-click the corner point.
- To change a curved point into a corner point, make the shape editable, and then double-click the curved point.
To change all corner points in one or more shapes into curved points, make the shapes editable, select the shape(s), and then choose Format > Shape > Smooth Path.

To change all curved points in one or more shapes into corner points, make the shapes editable, select the shape(s), and then choose Format > Shape > Sharpen Path.

After a shape is editable, you can use the Smooth Path and Sharpen Path commands without making the shape editable again.

**Editing Specific Predrawn Shapes**

Some predrawn shapes have special built-in editing controls.

**Editing a Rounded Rectangle**

The rounded rectangle has a circular control that lets you change the corners.

To edit a rounded rectangle:

- Select the shape, and drag its circular control to the left to straighten the corners and to the right to round them.

**Editing Single and Double Arrows**

The arrows have three special controls.

Here are ways to edit single and double arrows after selecting them:

- Drag the control on the arrow’s tail or arrowhead to increase or decrease the tail’s length without changing the shape of the arrowhead.
- Drag the circular control up or down to change the width of the tail.
- Drag the circular control left or right to resize the arrowhead.
**Editing a Star**
The star shape has a slider for increasing and decreasing the number of points in the star and a circular control for changing the angles between points.

Here are ways to edit a star:
- When you select a star shape, the slider appears. Drag the slider to increase or decrease the number of points in the star.
- Drag the circular control to change the angles between points in the star.

**Editing a Polygon**
The polygon has a slider for increasing and decreasing the number of sides in the polygon.

To edit a polygon:
- When you select the polygon, the slider appears. Drag the slider to increase or decrease the number of sides in the polygon.
Using Media Placeholders

Many Keynote themes contain placeholder photos. These photos are actually "media placeholders." You can drag your own images, movies, and audio files to these placeholders, and your media file is automatically sized and positioned for you. You can easily replace an item in a media placeholder by dragging a new file to it; you don’t have to delete the old file first. You can also turn any media file on a slide into a placeholder.

If you’re not sure if a photo or other media on a slide is a placeholder, let the pointer rest over it, and see if a help tag appears instructing you to drag your own media file to it.

Here are ways to work with media placeholders:

- Drag a file from the Media Browser, Finder, or other application to the media placeholder.

To open the Media Browser, click Media in the toolbar. Click a button at the top of the window to look for audio files, images, or movies.

- To change the content of a media placeholder, drag a new media file to the existing one.
To convert a placeholder image to an image, select the image, choose Format > Advanced > “Define as Media Placeholder” (remove the checkmark).

To delete a media placeholder, select it and press the Delete key.

To create a media placeholder, add a photo, movie, or audio file to a slide. Resize the file and set the desired attributes (add a reflection, a picture frame, and so on). Choose Format > Advanced > “Define as Media Placeholder” (make sure a checkmark is next to the command name).

Working with Images
Keynote accepts all QuickTime-supported formats, including the following graphics file types:
- TIFF
- GIF
- JPEG
- PDF
- PSD
- EPS
- PICT

After importing an image into a document, you can mask (crop) it and change its brightness and other settings. You can place an image inside of a shape, text box, chart element, or table cell. Keynote also lets you work with graphics with transparency (alpha-channel graphics).

Importing an Image
Import an image directly from the Finder or from the Media Browser.

Here are ways to import an image file:
- Drag an image file from the Finder to the document and position it where you want it.
- Drag an image to the slide navigator to create a new slide containing the image.
- Click Media in the toolbar, click Photos in the Media Browser, select the album where your picture is located, and then drag a thumbnail to position it where you want it.
- Choose Insert > Choose, select the file, and then click Insert. Drag the image to position it where you want it.

By default, if an image you place on a slide is larger than the slide, Keynote downsamples the image to fit the slide. (A downsized image has fewer pixels than the original; some of the image information is removed.) Images in JPEG format remain JPEG images; other formats are converted to TIFF.
After an image has been scaled down to fit on a slide, you can’t restore it to its original size by clicking Original Size in the Metrics Inspector. To avoid downsampling and use images at their original size, choose Keynote > Preferences, click General, and then deselect “Reduce placed images to fit on slides.”

**Masking (Cropping) Images**

You can crop images without actually changing the image files by masking parts of them.

**Cropping an Image Using the Default (Rectangular) Mask**

You can use a rectangular mask to define the boundaries of an image.

**To crop an image using the default (rectangular) mask:**

1. Import the image you want to mask (see “Importing an Image” on page 89 for instructions).

2. Select the image, and then click the Mask button in the toolbar.

   A mask appears over the image, and some controls appear.

   - Drag the selection handles to resize the mask.
   - Drag the image to position the part you want to show.
   - Drag the slider to resize the image.
   - Click to show or hide the area outside the mask.

3. To resize the image, drag the slider above the Edit Mask button.

4. Refine the mask by doing any of the following:
   - To resize the mask, drag the selection handles. To constrain the mask’s proportions, hold down the Shift key as you drag.
   - To rotate the mask, hold down the Command key as you drag a corner selection handle.

5. Drag the image to position the part you want to show. To move the mask, click the dotted edge of the mask and drag it.
To make only the area under the mask visible, double-click the mask or image, press Return, click outside the image, or click Edit Mask.

To resize or rotate the masked image, drag or Command-drag its selection handles.

To deselect the image and hide the mask controls, click outside the image.

Masking an Image with a Shape
You can use a shape to define the boundaries of an image.

To mask an image with a shape:
1. Do one of the following:
   - Select the image and choose Format > “Mask with Shape” > Shape.
   - Shift-click to select a shape and an image, and then click Mask in the toolbar (or choose Format > “Mask with Selected Shape”).
2. Drag the image to position the part you want to show. To move the mask, click the dotted edge of the mask and drag it.
3. To resize the image, drag the slider above the Edit Mask button.
4. To resize the mask, drag the selection handles.
5. To make only the area under the mask visible, double-click the mask or image, press Return, click outside the image, or click Edit Mask.
6. To resize the masked image, click Edit Mask and drag the selection handles.
7. To deselect the image and hide the mask controls, click outside the image.
   - To modify a masked image, double-click it.

   Note: If you use a shape containing text as a mask, the text is deleted. To restore the text, choose Edit > “Undo Mask with Shape.”

   You can also drag an image to mask a shape with an image.

Unmasking an Image
You can remove a mask and restore the original image.

To unmask an image:
- Select the masked image, and then click Unmask in the toolbar (or choose Format > Unmask).
Removing the Background or Unwanted Elements from an Image

The Instant Alpha tool enables you to convert certain colors in an image to transparent. This feature is useful for removing an unwanted background or other colors.

You'll get the best results removing solid colors with clear boundaries around them. To remove areas that are less distinct, select a smaller area and repeat the process.

To remove unwanted elements:
1. Select the image.
2. Click Alpha in the toolbar (or choose Format > Instant Alpha).
3. Click the color you want to make transparent, and then drag slowly over it.

As you drag, the selection grows to include the contiguous area that uses similar colors. You can control how much of the image is selected by dragging less or more.

4. Repeat step 3 as many times as you like.

You can restore the parts removed from the image at any time. To revert to the original image, choose Format > Remove Instant Alpha. To restore parts of the image removed using Instant Alpha, choose Edit > Undo Instant Alpha until the parts have been restored.
Changing an Image’s Brightness, Contrast, and Other Settings

You can change the brightness, contrast, and other settings of images to improve their quality or to create interesting effects. Adjustments you make don’t affect the original image; they affect only the image’s appearance in Keynote.

To adjust an image:
1. Select the image.
2. Choose View > Show Adjust Image.
3. Use the controls to make adjustments.

*Enhance button*: Automatically adjusts the image.

*Brightness*: Adjusts the lightness of the image.

*Contrast*: Adjusts the contrast of light and dark tones. You can make shadows darker, sharpen the edges of objects, and make colors stand out more. If you increase the contrast of a photo a lot, it looks more like an illustration.

*Saturation*: Changes the color intensity.

*Temperature*: Introduces more warmth (more orange tones) or coldness (more blue tones).

*Tint*: Changes the amount of red or green tones in the image.

*Sharpness*: Sharpens or softens the image’s focus.

*Exposure*: Adjusts shadows and highlights.
The histogram: Helps you understand the relationship between shadows (depicted on the left side of the display) and highlights (depicted on the right side) in your image.

Levels: Changes the levels of light and dark tones.

Auto Levels: Has Keynote enhance colors automatically.

To restore the original settings, click Reset Image.

To save any changes you made, save the document. The settings at the time you save the document are visible anytime you open the Adjust Image window.

Using Sound and Movies

You can add audio—a music file or playlist from your iTunes library, or any other sound file—to a Keynote document. You can add sound in the following ways:

- **On an individual slide.** The sound plays when the slide appears and stops when the slideshow advances. See “Adding Sound to a Slide” on page 95.

- **As a soundtrack for the entire slideshow.** The audio starts playing when the slideshow starts. See “Adding a Soundtrack to a Slideshow” on page 95.

- **As recorded narration.** You can record yourself talking about each slide. See “Adding Narration” on page 97.

You can also add video or Flash movies that play within a slide. For Flash to work with QuickTime 7.1.3 and later, choose Apple menu > System Preferences, click QuickTime, click Advanced, and select Enable Flash.

Keynote accepts any QuickTime or iTunes file type, including the following:

- MOV
- FLASH
- MP3
- MPEG-4
- AIFF
- AAC

**Note:** Some media files are protected under copyright law. Also, some downloaded music may be played only on the computer where the download occurred. Make sure you have permission to use the files you want to include.

**Important:** To make sure that the movies and other media can be played and viewed when your document is transferred to another computer, make sure that “Copy audio and movies into document” is selected; after you choose Save or Save As, click the disclosure triangle next to the field, and then click Advanced Options.
Adding Sound to a Slide
Add sound that plays when a slide appears and stops when you move to the next slide.

Here are ways to add sound to a slide:
- Drag a sound file from the Finder to a slide.
- Click Media in the toolbar, choose iTunes from the pop-up menu, select a playlist, and then drag a file to the slide canvas or a media placeholder. (You can also drag a playlist.)

You can more finely control when music starts and stops by using the Start Audio and Stop Audio effects in the Build Inspector. For more information, see “Animating Slides with Object Builds” on page 102.

Adding a Soundtrack to a Slideshow
If you add a soundtrack, the music starts playing when the slideshow starts. You can specify whether to play the audio once or repeatedly, or you can turn it off.

To add a soundtrack:
1. Click Inspector in the toolbar, and then click the Document Inspector button.
2. Click the Audio button.
3. Drag an audio file or playlist from the Media Browser to the Audio well in the Document Inspector. If you change a playlist, the change won’t be reflected in your soundtrack until you add the playlist again.

You can also drag a sound file from the Finder.
4. To repeat the sound file as long as the presentation is playing, choose Loop from the pop-up menu in the Document Inspector.
Adding a Movie
You can add a movie to a slide that plays when a slide appears or when the presenter clicks the mouse.

Here are ways to add a movie:
- Drag a movie file from the Finder to the slide canvas or to a media placeholder.
- Click Media in the toolbar, click Movies, select a file, and then drag it to the slide canvas or to a media placeholder.
- Choose Insert > Choose, select the movie file, and then click Insert.

When a movie plays during a presentation, movie controls appear when you move the pointer over the movie if “Show playback controls when pointer is over a movie” is selected in the Slideshow pane of Keynote preferences. The controls available depend on the size (dimensions) of the movie; the smaller the movie, the fewer controls visible.

Also see, “Creating Movie Builds” on page 113.

Adjusting Media Playback Settings
In the QuickTime Inspector, you can change such settings as when to start and stop a movie, and the frame to display until the movie starts playing.

To set media playback preferences:
1 Click Inspector in the toolbar, and then click the QuickTime Inspector button.
2 Click the movie or sound object to select it.
3 To start and stop the movie at particular frames or times, drag the Start and Stop sliders.
4 To specify which frame of a movie to display until the movie starts playing (called the “poster frame”), drag the Poster Frame slider until the movie displays the image you want.
5 To start the movie when the presenter clicks the mouse (instead of when the slide appears), select “Start movie on click.”
6 Choose a repeat option from the Repeat pop-up menu:

- *None*: Play only once.
- *Loop*: Repeat continuously.
- *Loop Back and Forth*: Play backward and forward continuously.

7 To increase or decrease the playback volume, drag the Volume slider to the right or left.

**Adding Narration**

You can record yourself talking about each slide. When you advance to the next slide or build, your timing is recorded as well.

**To record a slideshow:**

1 If you’re using an external microphone instead of your computer’s built-in microphone, connect the microphone and use the Sound pane of System Preferences to configure the input settings.

2 Select the slide on which you want the recording to start.

You don’t have to select the first slide, but a recorded slideshow plays back only from the first recorded slide.

If you select a skipped slide, recording starts with the nearest previous unskipped slide.

3 Do one of the following:
   - Open the Document Inspector, click Audio, and click Record.
   - Choose File > Record Slideshow.
4 As the presentation plays, speak into the microphone to record your narration.
   A pulsing red light in the upper-left corner of the screen indicates that recording is in progress.

5 To advance to the next slide, click the mouse or press the Right Arrow key.
The following table lists other ways you can control the presentation while you are recording.

<table>
<thead>
<tr>
<th>Press or click</th>
<th>To do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>W (white screen), F (freeze), or B (black screen)</td>
<td>Pause recording. Press any key to resume recording the slideshow.</td>
</tr>
<tr>
<td>Red recording indicator</td>
<td>Pause recording</td>
</tr>
<tr>
<td>Esc</td>
<td>Stop playback and save the recording</td>
</tr>
</tbody>
</table>

**Note:** When you record a slideshow, Recorded is automatically chosen from the Presentation pop-up menu in the Document Inspector.

**Rerecording a Recorded Slideshow**
If you record a slideshow and then modify slides, the recording might be out of sync with the slides. You can rerecord part or all of a recorded slideshow.

**To rerecord part or all of a recorded slideshow:**
1 Select the slide on which you want to start rerecording.
2 Open the Document Inspector and click Audio.
3 Click Record.
4 *If the selected slide was previously recorded*, do one of the following:
   • To replace the previous recording, starting with the selected slide, click Record & Replace. If there was recording before the first rerecorded slide, it remains intact.
   • To replace the entire recording, click Record From Beginning.
5 *If the selected slide was not previously recorded*, do one of the following:
   • To append the new recording to the end of the previous recording, click Record & Append.
   • To replace the entire recording, click Record From Beginning.

**Playing a Recorded Slideshow**
When playing a recorded slideshow, you can use all the regular presentation keyboard shortcuts (described in “Controlling a Presentation with the Keyboard” on page 173). There are also some special options for playing recorded slideshows.
To play a recorded slideshow:

- To listen to the narration, click the Play button on the Document Inspector's Audio pane. Adjust the volume by dragging the Volume slider.
- To play a recorded presentation, click Play in the toolbar, choose View > Play Slideshow, or choose View > Play Recorded Slideshow. Note that a recorded slideshow plays only from the first recorded slide, which might not be the first slide in the document.

If you click Play in the toolbar and the presentation doesn't play as expected, make sure Recorded is chosen from the Presentation pop-up menu in the Document Inspector.

Deleting a Recording

To delete a recording:

- Open the Document Inspector, click Audio, and click Clear.
- Choose File > Clear Recording.

Adding Web Views

You can display a snapshot of a webpage (called a “web view”) on a slide. When the document is opened, Keynote can automatically update the snapshot with the current webpage. (The computer running the slideshow must be connected to the Internet.) By default, the snapshot is a hyperlink you can click during a presentation to open the webpage in a browser; you can turn off the link in the Hyperlink Inspector.
To add a web view to a slide:

1. Choose Insert > Web View.

2. In the Hyperlink Inspector, type the page’s URL (www.apple.com, for example). You can also drag a URL’s icon from the address bar of a browser to the slide canvas; drag the icon to the slide navigator to add a new slide and create a web view on it in one step.

3. To automatically update the webpage periodically, select “Update automatically.” If you don’t select “Update automatically,” you can update the webpage at any time by clicking Update Now.

4. Optionally resize or reposition the web view (the webpage image is imported at full size). The web view stays at the same resolution when you resize it.

5. By default, the web view is automatically a hyperlink, which you can click during a presentation to open the webpage in a browser. To turn off this feature, deselect “Enable as a hyperlink” in the Hyperlink Inspector.

Making an Object a Hyperlink

In addition to text hyperlinks, you can turn images and shapes into hyperlinks that perform the following actions when you click them during a presentation:

- Go to a particular slide
- Open a webpage on the Internet
- Open another Keynote document
- Open an email message
- Exit the slideshow

Turn images into hyperlinks that open another slide, a Keynote document, a webpage, or an email message. The small blue arrow (visible only while you’re editing a slide) means the item is a clickable hyperlink.

See “Using Hyperlinks” on page 61 for instructions.
This chapter describes how to add visual interest using slide transitions and object builds.

After you've created and organized your slides, you can animate text and objects to add visual interest and emphasis.

- **Transitions** provide visual effects when you move from one slide to the next.
- **Object builds** animate elements on slides.

**Adding Transitions Between Slides**

Keynote provides a variety of transition styles.

You can control the duration of a transition, and you can specify when to start the transition (automatically or on click). You set up slide transitions in the Slide Inspector.
To add a transition effect between slides:
1. Select a slide.
2. Click Inspector in the toolbar, and then click the Slide Inspector button.
3. Click Transition.
4. Choose an option from the Effect pop-up menu.
   - If you see “Effects that can't play on this computer,” the transitions listed require your computer to have an advanced graphics card.
5. Choose an option from the Direction pop-up menu (not applicable for all effects).
6. To change how much time it takes to complete the transition, type a value in the Duration field (or click the arrows).
7. Choose an option from the Start Transition pop-up menu.
   - On Click: Initiates the transition when you click to advance to the next slide.
   - Automatically: Initiates the transition after the amount of time specified in the Delay field.
8. If you chose an effect with additional options (such as Mosaic, Swap, or Fade Through Color), select your settings.

To view the transition, click the image in the Transition pane of the Slide Inspector, or click Play in the toolbar.

If you use Cube or Flip transitions: Parts of those transitions might not be visible if “Scale slides up to fit display” is selected in the Slideshow pane of Keynote preferences (choose Keynote > Preferences and then click Slideshow). To ensure that these transitions aren’t clipped during your slideshow, either deselect “Scale slides up to fit display” or select one or both of the “Reduce transitions to avoid clipping” options in the Slideshow pane.

Animating Slides with Object Builds
You can use object builds to animate individual or grouped elements on a slide:
- Build In effects move elements onto a slide.
- Build Out effects move elements off a slide.
- Action builds animate elements on a slide.
- Smart Builds are predefined action builds for animating images.

You can create multiple object builds on one slide, and you can apply multiple builds to the same object.
You can, for example, make bulleted text appear line by line. Or you can display individual parts of a chart one at a time to focus viewers’ attention or build suspense. You can make an image move onto the slide from the left and later move off the slide to the right.

**Moving Objects on or off Slides Using Build Effects**

To move elements on or off a slide, begin with the completed slide (all elements visible), and then define a build for each element you want to appear or disappear.

**To automatically move an object on or off a slide:**

1. On a slide, select the object you want to make move on or off the slide.
   - Shift-click to select multiple objects.
2. Click Inspector in the toolbar, and then click the Build Inspector button.
3. To make the object move onto the slide, click Build In. To make the object leave the slide, click Build Out.

4. Choose an option from the Effect pop-up menu.

   *If you are applying the effect to a Smart Build: Some Smart Builds use effects that can also be used to move the images on or off a slide. If you use one of these Smart Builds, you’ll see “Use Smart Build” in the Effect menu. For more information, see “Animating Images Using Smart Builds” on page 107.*
To change the direction in which the object enters or leaves the slide, choose an option from the Direction pop-up menu. (Not all effects provide this option.)

To change whether the object builds as a whole or in parts, choose an option from the Delivery pop-up menu.

The options in the Delivery pop-up menu change depending on the selected object. For example, options for a table include building by row or by column; options for text include building by paragraph. For more information, see “Animating Specific Kinds of Objects” on page 111.

To set how long it takes for an object (or object element) to appear or disappear, type a value in the Duration field (or click the arrows).

To set different durations for individual object elements, select “Set separate timings for elements.” In the Build Order drawer, select each element, choose “Automatically” from the Start Build pop-up menu, and type a value in the Delay field.

To prevent some object parts from building, choose options other than First and Last from the “Build from” pop-up menu.

To view the build, click the image in the Build Inspector or click Play in the toolbar. You can also view a single element’s build by clicking it in the Build Order drawer.

About grouped objects: If you group or ungroup objects that have a build defined, the build effect is removed.

After you define an object build, you can also do the following:

- Change the order in which builds occur. See “Reordering Object Builds” on page 109.
- Specify whether to begin the build automatically (after a specified time) or on click. See “Activating Object Builds” on page 110.
- Interleave the build stages of different objects. See “Creating Builds That Interleave an Object’s Parts” on page 111.
- Apply action builds to move or modify the object on the slide. See the next two topics for instructions.

You can create an object build on a master slide so that the build effects appear on every slide created using that master. See “Defining Default Transitions” on page 196 for instructions.
**Animating Objects on Slides (Action Builds)**

With *action builds*, you can move objects on a slide.

**To move an object from one location on a slide to another:**

1. **Open the Build Inspector** (click Inspector in the toolbar and click the Build Inspector button).
2. **Click Action.**

3. **On a slide, select an object** (an image, shape, text box, chart, movie or other media file, or table).

4. **Choose Move from the Effect pop-up menu.**

   A red line connected to a “ghosted” (transparent) version of the object appears, showing the object’s destination.

5. **To modify the movement, do any of the following:**

   - *Change the direction or distance* the object moves by dragging the ghosted object.
   - *Change the path* from straight to curved by clicking the curved Path button in the Build Inspector.
Reshape a curved path by dragging one of its nodes or node handles. For more control, click a node (a point on a path) and drag its handles.

Control the speed and nature of the object’s motion by choosing an option from the Acceleration pop-up menu in the Build Inspector.

To move a path and its beginning and end objects, drag the path. You can Shift-click to select multiple paths.

Add a node (point) to a path by holding down the Option key while you click the path.

6 To move the object along a new path, click the Add Path button next to the last ghosted object or the Add Action button in the Build Inspector.

7 To reorder the stages of the action build, click More Options and drag builds in the Build Order drawer. (For more information, see “Reordering Object Builds” on page 109.)

You can even move objects off the slide.
After an object and all its paths have been deselected, you can see them again by clicking the red Show Path button on the object.

Making Objects Fade, Rotate, Grow, or Shrink
Use action builds to make objects on a slide rotate, or change opacity or size.

To modify an object using an action build effect:
1. Open the Build Inspector (click Inspector in the toolbar and click the Build Inspector button).
2. Click Action.
3. On a slide, select an object (an image, shape, text box, chart, movie or other media file, or table).
4. Choose an option from the Effect pop-up menu, and use the controls to specify how the object should look when the transformation is complete:
   - To make the object fade, choose Opacity from the Effect pop-up menu, and then drag the Opacity slider to set the object's final opacity.
   - To rotate the object, choose Rotate from the Effect pop-up menu, and then use the Direction and Acceleration controls to set the object's rotation direction and speed.
   - To shrink or expand the object, choose Scale from the Effect pop-up menu, and then use the Scale controls to set the object's final size (up to 200 percent).

Animating Images Using Smart Builds
Keynote provides predefined builds you can use to animate a collection of your own photos and other images. These animations are called Smart Builds.
**To set up a Smart Build:**

1. Click Smart Builds in the toolbar and choose an option.

2. Drag images from the Photos pane of the Media Browser (if it’s not open, click Media in the toolbar) to the rectangles in the Smart Build photo window.

   You can also drag photos and other image files from the Finder.

3. Use the Smart Build photo window to modify the Smart Build in any of the following ways:

   - **To reorder images**, drag them in the Smart Build photo window.
   - **To remove an image from the build**, drag it out of the photo window, or select it and press Delete.
   - **To make all photos the same size**, select “Scale images to same size.”
   - **To use the relative sizes of the photos**, deselect “Scale images to same size.”
Some Smart Builds display images in two states. Use the size buttons and the Scale slider to specify the image size in each state.

4. Use the Action pane of the Build Inspector to modify the Smart Build in any of the following ways:

   To change settings such as direction, alignment, and perspective, use the controls in the Build Inspector. (The settings available depend on the effect you choose.)

   To change how long the build takes, type a value in the Duration field (or click the arrows).

   To specify whether to begin a build stage automatically or on click, choose an option from the Start Build pop-up menu in the Build Order drawer. (For more information, see “Activating Object Builds” on page 110.)

   To set different timings for individual photos, select “Set separate timings for elements,” and then, in the Build Order drawer, select each photo and change its settings.

*The red badge indicates the photo is part of a Smart Build.*

Some Smart Builds use effects that can also move the images on or off a slide. See “Moving Objects on or off Slides Using Build Effects” on page 103.

You can create an action build on a master slide so that build effects appear on every slide created using that master. See “Defining Default Transitions” on page 196 for instructions.

**Reordering Object Builds**

You can change the order of builds on a slide. For example, you can make an object move on and off the screen before another object moves onto the screen. You can also make different parts of an object (such as a bullet in a series of bullets) build at different times. (For information about using object parts, see “Creating Builds That Interleave an Object’s Parts” on page 111.)

Here are ways to change the order in which builds occur:

- In the Build Inspector, if the Build Order drawer isn’t open, click More Options. In the Build Order drawer, drag items to reorder them.

- Select an object on the slide canvas, and then select an option from the Order pop-up menu in the Build Inspector.
Activating Object Builds
You can create various effects by specifying when a build starts.

To change when a build starts:
1. Click Inspector in the toolbar, and then click the Build Inspector button.
2. In the Build Inspector, if the Build Order drawer isn’t open, click More Options.
3. In the Build Order drawer, select an item in the list and then choose an option from the Start Build pop-up menu.
   - **On Click:** Initiates the build when you click.
   - **Automatically after build [number]:** Initiates the build after the previous build finishes and after the amount of time specified in the Delay field.
   - **Automatically with build [number]:** Makes two builds occur at the same time, after the amount of time specified in the Delay field. To make two builds occur at the same time, they must be next to each other in the Build Order list.

You can also make several objects build as one object by grouping them (see “Grouping and Ungrouping Objects” on page 78).

4. If you choose to start the build automatically (rather than on click), specify how long to wait after the previous build finishes by typing a value in the Delay field (or clicking the arrows).
   You can specify a delay up to 60 seconds.
Creating Builds That Interleave an Object’s Parts

After you set up object builds on a slide, you can set up criteria for when Build In and Build Out effects become animated.

For example, you can set up a build that brings the first text bullet onto the slide, then the first wedge of a pie chart, and then the second bullet. You can do the same to move objects off the slide. You can also specify a range of elements to be used in a build, such as only the second and third text bullets.

To interleave an object’s parts in a build:
1. Select an object on the slide canvas.
2. Click Inspector in the toolbar, and then click the Build Inspector button.
3. In the Build In or Build Out pane, choose an option from the Delivery pop-up menu other than “All at once.”
   For more information, see “Animating Specific Kinds of Objects” (next).
4. To specify a range of parts to build instead of building all parts, use the “Build from” and “Build to” pop-up menus.
5. Select “Set separate timings for elements.”
6. In the Build Order drawer, drag the builds to the desired order.
   For more information about starting individual builds, see “Activating Object Builds” on page 110.

Animating Specific Kinds of Objects

Text, tables, charts, and movies have build options that are object specific.

Creating Text Builds

You can build text line by line, word by word, or character by character. You can create text builds for bulleted or plain body text.

To set up a text build:
1. Select text on the slide canvas for which you’ve defined a build.
2. Click Inspector in the toolbar, and then click the Build Inspector button.
3. In the Build In or Build Out pane, choose an option from the Delivery pop-up menu.
   - All at Once: Moves all text in the text box at the same time.
   - By Bullet: Moves text bullet by bullet.
   - By Bullet Group: Moves each bullet and its subordinate bullets together.
   - By Highlighted Bullet: Highlights each bullet as it moves, leaving only the most recent bullet highlighted.
   - By Paragraph: For non-bulleted text.
Creating Table Builds

You can make tables appear or disappear on a slide row by row, column by column, and more.

To set up a table build:

1 Select a table on the slide canvas for which you've defined a build.
2 Choose an option from the Delivery pop-up menu in the Build In or Build Out pane of the Build Inspector.

- **All At Once**: Moves the whole table as a single object.
- **By Row**: Moves the table onto the screen row by row.
- **By Column**: Moves the table onto the screen column by column.
- **By Cell**: Moves the table onto the screen one cell at a time.
- **By Row Content**: Moves the entire empty table onto the screen, and then inserts the content row by row.
- **By Column Content**: Moves the entire empty table onto the screen, and then inserts the content column by column.
- **By Cell Content**: Moves the entire empty table onto the screen, and then adds the content cell by cell.

All elements of a table use the same build style.

Creating Chart Builds

Make charts appear or disappear a bar at a time, a wedge at a time, and more.

To set up a chart build:

1 Select a chart on the slide canvas for which you've defined a build.
2 Click Inspector in the toolbar, and then click the Build Inspector button.
3 In Build In or Build Out pane, choose an option from the Delivery pop-up menu.

- **All At Once**: Moves the whole chart as a single object.
- **Background First**: Moves each chart axis onto the screen, followed by all the data elements at once (bars, lines, or area shapes).
- **By Series**: Moves each chart axis onto the screen and then the data elements, one entire series at a time.
- **By Set**: Moves each chart axis onto the screen and then the data elements, one entire set at a time.
- **By Element in Series**: Moves the chart axes onto the screen, and then each separate data element, one series at a time.
- **By Element in Set**: Moves each chart axis onto the screen, and then each separate data element, one set at a time.
All elements of a chart (except the legend) use the same build style.

You can assign a chart legend its own build style and order. To make the legend appear with the chart, group it with the chart before you set the chart’s build style (see “Grouping and Ungrouping Objects” on page 78).

**Creating Movie Builds**
You can start and stop a movie while a particular slide is displayed.

**To set up a movie build:**
1. Select a movie on the slide canvas.
2. Click Inspector in the toolbar, and then click the Build Inspector button.
3. Click Build In, and then choose Start Movie from the Effect pop-up menu.
   The movie starts playing when the build occurs.
4. To stop the movie, choose Stop Movie from the Effect pop-up menu.
   The movie stops playing when the build occurs.

**Deleting Object Builds**
You can remove object builds using the Build Inspector.

**Here are ways to delete an object build:**
- In the Build Inspector, if the Build Order drawer isn’t open, click More Options. In the Build Order drawer, select the build you want to delete and press Delete.
- Select the item you want to remove the build effect for, and then choose None from the Effect pop-up menu in the Build Inspector.
Using Tables

This chapter tells you how to add and format tables and cell values.

To learn about using formulas in table cells, see Chapter 7,"Using Formulas and Functions in Tables," on page 134.

About Tables
Tables help you organize, analyze, and present data.

Keynote provides a wide variety of options for building and formatting tables and handling values of different types. You can also use special operations such as sorting and conditional formatting (a technique for automating the monitoring of cell values).

- “Working with Tables” on page 115 teaches you how to add tables, resize them, move them, name them, and more.
- “Selecting Tables and Their Components” on page 118 describes how to select tables, columns, and other table elements in order to work with them.
- “Working with Content in Table Cells” on page 120 tells you how to add text, numbers, dates, images, and other content to table cells as well as how to monitor cell values automatically.
- “Working with Rows and Columns” on page 128 covers adding rows and columns, resizing them, and more.
- “Working with Table Cells” on page 131 contains instructions for splitting cells, merging them, and copying and moving them as well as formatting cell borders.
- “Sorting Table Cells” on page 133 describes how to sort rows.
Working with Tables
Use a variety of techniques to create tables and manage their characteristics, size, and location.

Adding a Table
Add a table when you want to organize information or compare sets of data. When the table is complete, you can create interesting slide animations in which table elements appear cell by cell, row by row, or column by column.

Here are ways to add a table:
- Click Table in the toolbar (or choose Insert > Table).
- To draw a table on the slide canvas, hold down the Option key as you click Table in the toolbar. Release the Option key and move the pointer over the slide canvas until it becomes a crosshair. Drag across the slide canvas to create a table that’s the size you want. As you drag, the number of rows and columns increases or decreases with the size of the table. To size the table from the center, press the Option key while dragging.
- To create a new table based on one cell or several adjacent cells in an existing table, select the cell or cells, click and hold the selection, and then drag the selection to the canvas. Values in the original table’s cells are retained.

See “Selecting Tables and Their Components” on page 118 to learn about cell selection techniques.
Using Table Tools
You can format a table and its columns, rows, cells, and cell values using various Keynote tools.

Here are ways to manage table characteristics:

- Use the Table pane of the Table Inspector to precisely control column width and row height, add headers and a footer, format borders, and more. To open the Table Inspector, click Inspector in the toolbar, and click the Table Inspector button.

- Use the Format pane of the Table Inspector to format cell values. For example, you can display a currency symbol in cells containing monetary values.

You can also use the Format pane to set up conditional formatting. For example, you can make a cell red when its value exceeds a particular number.
Use the Graphics Inspector to create special visual effects, such as shadows and reflections. To open the Graphics Inspector, click Inspector in the toolbar and then click the Graphics Inspector button.

Access a shortcut menu by selecting a table or cell(s) and then holding down the Control key as you click again.

You can also use the Edit Rows & Columns pop-up menus in the Table Inspector.

Use the Formula Editor to add and edit formulas. See “Using the Formula Editor” on page 137 for details.

Use the Formula Browser to add and edit functions. See “Using Functions” on page 143 for details.

Resizing a Table
You can make a table larger or smaller by dragging one of its selection handles or by using the Metrics Inspector. You can also change the size of a table by resizing its columns and rows.

Before resizing a table, you must select it, as “Selecting a Table” on page 118 describes.

Here are ways to resize a table that’s selected:

- Drag one of the square selection handles that appear when a table is selected.

To maintain a table’s proportions, hold down the Shift key as you drag to resize the table.

To resize from the table’s center, hold down the Option key as you drag.

To resize a table in one direction, drag a side handle instead of a corner handle.
To resize by specifying exact dimensions, select a table or table cell, click Inspector in the toolbar, click the Metrics Inspector button, and then click Metrics. In this pane, you can specify a new width and height, change the table’s distance from the margins, and control the angle of rotation.

To resize by adjusting the dimensions of rows and columns, see “Resizing Table Rows and Columns” on page 130.

**Moving Tables**
You can move a table by dragging it, or you can relocate a table using the Metrics Inspector.

Here are ways to move a table:

- Select the table, click and hold anywhere in the table, and drag the table.
- To constrain the movement to horizontal, vertical, or 45 degrees, hold down the Shift key as you drag.
- To move a table more precisely, click any cell, click Inspector in the toolbar, click the Metrics Inspector button, and then use the Position fields to relocate the table.
- To copy a table and move the copy, hold down the Option key, click and hold at the edge of an unselected table, and drag.

**Copying Tables Among iWork Applications**
You can copy a table from one iWork application to another.

A table created in Numbers and placed in another application will retain its appearance, data, and other attributes, but some Numbers features aren’t supported in the other applications.

To copy a table from one iWork application to another:
1. Select the table you want to copy, as “Selecting a Table” on page 118 describes.
2. Choose Edit > Copy.
3. In the other application, create an insertion point for the copied table, and then choose Edit > Paste.

**Selecting Tables and Their Components**
You select tables, rows, columns, table cells, and table cell borders before you work with them.

**Selecting a Table**
When you select a table, selection handles appear on the edges of the table.

Here are ways to select a table:

- If a cell isn't selected, click anywhere in the table.
If a table cell is selected, press Command-Return, or click outside the table and then click anywhere in the table.

Selecting a Table Cell
When you select a cell, the border of the selected cell is highlighted.

To select a single table cell:
Select the table, and then click the cell.

When a cell is selected, here is how to select another cell.

<table>
<thead>
<tr>
<th>To select</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>The next cell to the right</td>
<td>Tab</td>
</tr>
<tr>
<td></td>
<td>If you press Tab in the last column, the first cell in the next row is selected.</td>
</tr>
<tr>
<td></td>
<td>If you press Tab in the last cell, a new row is added and its first cell is selected.</td>
</tr>
<tr>
<td>The next cell to the left</td>
<td>Shift-Tab</td>
</tr>
<tr>
<td>The next cell down</td>
<td>Down Arrow</td>
</tr>
<tr>
<td>The next cell up</td>
<td>Up Arrow</td>
</tr>
</tbody>
</table>

Selecting a Group of Table Cells
You can select adjacent or nonadjacent cells.

Here are ways to select a group of cells:
- To select adjacent table cells, select a single cell, and then hold down the Shift key as you select adjacent cells.
  
  You can also click a cell, hold it, and then drag through a range of cells.

- To select nonadjacent table cells, hold down the Command key as you select cells. Use Command-click to deselect a cell in the group.

Selecting a Row or Column
The fastest way to select entire rows and columns is to use the Table Inspector.

Here are ways to select rows and columns:
- To select a single row or column, choose Select Row or Select Column from the Edit Rows & Columns pop-up menu in the Table Inspector.
  
  You can also use the techniques described in “Selecting a Group of Table Cells” on page 119.

- To select multiple rows, select two or more vertically adjacent cells before choosing Select Row.

- To select multiple columns, select two or more horizontally adjacent cells before choosing Select Column.
Selecting Table Cell Borders
Select cell borders when you want to format one or more segments of the borders.

Here are ways to select borders and border segments:

- **To select specific borders for multiple cells:** Select the table, row, column, or cells, and then click one of the Cell Borders buttons in the Table Inspector.
- **To select a border:** If the table is selected, click the border. If the table isn’t selected, double-click the border.
- **To select a border segment:** If the table is selected, double-click the segment. If the table isn’t selected, click the segment three times. To select (or deselect) additional segments, press the Shift or Command key as you click.

When a table border is selected, clicking another border selects the border. Clicking the same border selects a segment.

When a segment is selected, clicking another segment selects the segment. Clicking the same segment selects the border.

When a cell, border, or segment is selected, the pointer appears to straddle the border or segment. You can drag these pointers to move a border.

![The pointer over a horizontal border or segment](image1)

![The pointer over a vertical segment](image2)

Working with Content in Table Cells
You can add text, numbers, and dates to table cells, and you can format values in cells. You can also add images and background color, as well as checkboxes, sliders, and other controls. And you can use autofilling to use the content in one or more cells to automatically add values to adjacent cells.

Adding and Editing Cell Values
You can add, change, and delete the content in cells.

Here are ways to add and edit values:

- **If the cell is empty, select it and then type a value.** “Selecting a Table Cell” on page 119 tells you how to select cells.

- **To replace specific content already in the cell, select the cell and then select what you want to replace by double-clicking; hold down the Shift key and select more content if you want to replace more.** Type to replace the selected content.
To replace everything in the cell, select the cell and then begin typing. You can also select the cell and then press Return or Enter, which selects everything in the cell, and then start typing.

To insert content within existing content, select the cell, click to set the insertion point, and begin typing.

To undo changes made to a table cell since selecting the cell, press Esc.

To delete the content of table cells, rows, or columns, select the cells, rows, or columns and then press the Delete key or choose Edit > Delete. To delete the contents, background fill, and any style settings, choose Edit > Clear All. The default style is applied to the selection.

To copy, paste, and move cell values, see the instructions in “Copying and Moving Cells” on page 132.

To add formulas and functions to cells, see the instructions in “Using Formulas” on page 134 and “Using Functions” on page 143.

**Working with Text in Cells**

You can control the format and alignment of text in table cells, and you can use find/replace and spell-checking features.

Here are techniques for working with text in table cells:

- To insert a line break, press Return or Option-Return.
- To insert a tab in a table, press Option-Tab.
- To control the color, alignment, and spacing of text within a cell, use the Text Inspector (click Inspector in the toolbar and click the Text Inspector button).
- To control font attributes, use the Font panel (click Fonts in the toolbar).
- To check spelling, follow the instructions in “Checking for Spelling Mistakes” on page 65.
- To find and optionally replace text in cells, follow the instructions in “Finding and Replacing Text” on page 67.
- To avoid having Keynote interpret what you type as a number, place an apostrophe in front of the text string.

*Note:* Text strings are ignored in functions that use values to perform calculations.

**Working with Numbers in Cells**

Some table operations, such as formulas and functions that perform mathematical operations, depend on cells containing numeric values.
Here are techniques for working with numbers in table cells:

- In a numeric cell use only numbers (0 through 9) or one of the following characters: +, -, (,), /, $, %, a period, E, or e.
- You can type some characters (such as %) into a cell, or you can use a cell format, as “Formatting Cell Values” on page 123 describes.
- To specify a negative number, precede it with the minus sign (–).

When you put a number in a table cell that’s too large to display, Keynote converts the number:

- When a decimal number doesn’t fit in a cell, the number is rounded. For example, 1.77777777777777777777 becomes 1.77777777777778.
- When a whole number doesn’t fit in a cell, the number is displayed using scientific notation. For example, 77777777777777777777 becomes 7.777778E+19.

Scientific notation displays numbers using an exponent raised by the power of 10. The exponent is displayed following the E.

If the converted number still doesn’t fit, it’s clipped. See “Displaying Content Too Large for Its Cell” on page 122 for suggestions.

Instructions for using formulas and functions in table cells are in “Using Formulas” on page 134 and “Using Functions” on page 143.

Working with Dates in Cells

Unless a cell has a date and time format associated with it, when you type a value that can be interpreted as a date or time value, Keynote automatically reformats the value. For example, if you type 1/22/45 or 1-22-45 into a table cell with the Automatic cell format, the value changes to Jan 22, 2045 when you exit the cell. If you enter a 2-digit year value greater than or equal to 50, Keynote adds the prefix “19”; otherwise Keynote adds the prefix “20.”

And if you type 12 pm, the value becomes 12:00 PM. You can edit the value if you need to change it.

For more information, see “Using the Date and Time Format” on page 125.

Displaying Content Too Large for Its Cell

When a cell is too small to display all its content, a clipping indicator (a small plus sign in the bottom right corner of the cell) appears.
You can enlarge a cell so that it displays more content, or you can let the cell’s content spill into adjacent blank cells.

To avoid clipping and spilling, you can set up a table so that all its cells automatically shrink or expand in height to accommodate content by selecting “Automatically resize to fit content” in the Table Inspector’s Table pane.

**Here are ways to handle content too large for a cell:**

- To let the content in a cell spill into adjacent cells, deselect Wrap Text in the Table Inspector’s Format pane and deselect “Automatically resize to fit content” in the Table pane.
  
  If the adjacent cells are empty, they’ll display spilled content. But if they contain data, content that doesn’t fit isn’t displayed and the clipping indicator appears.

- To cause content to wrap instead of spill, select Wrap Text in the Cells Inspector.

- To resize a column so that all of a particular cell’s value is visible, click its right border and drag right, or use the Column Width controls in the Table Inspector’s Table pane.

- To resize a row so that all of a particular cell’s value is visible, click its bottom border and drag down, or use the Row Height controls in the Table Inspector.

**Formatting Cell Values**

You can apply a format to a cell so its value is displayed in a particular way. For example, you can format cells that hold monetary values so that a currency symbol (such as $, £, or ¥) appears in front of numbers in them.

When you use a cell format, you are only setting the display characteristics of a value. When the value is used in formulas, the actual value is used, not the formatted value. The only exception is when there are too many numbers following a decimal point, in which case the number is rounded.

You define cell formats using the Cell Format pop-up menu in the Format pane of the Table Inspector. To display cell values exactly as you type them, choose Automatic from the pop-up menu; otherwise, choose the item that provides the specific formatting you want to use.

**Here are ways to work with cell formats:**

- To add a value to an empty cell that has a format, select the cell and enter a value. The format is applied when you leave the cell.

- To apply a cell format to an existing value, select one or more cells that contain values. Use the Format pane of the Table Inspector to define a cell format. The format you define is applied to values in the selected cell(s).

- To remove a format from a cell, select the cell, and then choose Automatic from the Format pop-up menu of the Format pane of the Table Inspector. The value remains, but its formatting is removed.
If you delete a value from a cell with a format, the format isn’t deleted. To delete the format, choose Automatic from the Format pop-up menu of the Format pane of the Table Inspector.

After you define a cell format, you can associate the format with multiple cells by using autofilling. See “Autofilling Table Cells” on page 127 for instructions.

**Using the Number Format**
Use the number format to format the display of a number’s decimal places, thousands separator, and negative values.

**To define a number format for one or more cells:**
1. Select the cell or cells.
2. Click Inspector in the toolbar, and then click the Table Inspector button.
3. Choose Number from the Format pop-up menu.
4. To specify how many decimal places to display, use the Decimals field. If a value contains more decimal places than you specify, the decimal value displayed is rounded, not truncated. For example, if a cell is formatted to display two decimal places, the value 3.456 is displayed as 3.46, not 3.45.
5. To specify how to display negative values, choose an entry from the pop-up menu adjacent to the Decimals field.
6. To specify whether to use a thousands separator, select Thousands Separator.

**Using the Currency Format**
Use the currency format to format the display of monetary values.

**To define a currency format for one or more cells:**
1. Select the cell or cells.
2. Click Inspector in the toolbar, and then click the Table Inspector button.
3. Choose Currency from the Format pop-up menu.
4. To specify a currency symbol, choose an option from the Symbol pop-up menu.
5. To specify how many decimal places to display, use the Decimals field. If a value contains more decimal places than you specify, the decimal value displayed is rounded, not truncated. For example, if a cell is formatted to display two decimal places, the value 3.456 is displayed as 3.46, not 3.45.
6. To specify how to display negative values, choose an entry from the pop-up menu adjacent to the Decimals field.
7. To specify whether to use a thousands separator, select Thousands Separator.
8. To display the currency symbol at the edge of the cell, select Accounting Style.

**Using the Percentage Format**
Use the percentage format to display numeric values followed by the % symbol.
If the value is used in a formula, its decimal number version is used. For example, a value that displays as 3% is used as 0.03 in a formula.

If you type 3% in a cell formatted using the automatic format and then apply the percentage format to the cell, the value displayed is 3%. However, if you type 3 in a cell formatted using the automatic format and then apply the percentage format to the cell, the value displayed is 300%.

To define a percentage format for one or more cells:
1. Select the cell or cells.
2. Click Inspector in the toolbar, click the Table Inspector button, and then click Format.
3. Choose Percentage from the Format pop-up menu.
4. To specify how many decimal places to display, use the Decimals field. If a value contains more decimal places than you specify, the decimal value displayed is rounded, not truncated. For example, if a cell is formatted to display two decimal places, the value 3.456 is displayed as 3.46, not 3.45.
5. To specify how to display negative values, choose an entry from the pop-up menu adjacent to the Decimals field.
6. To specify whether to use a thousands separator, select Thousands Separator.

If a cell you’re formatting already contains a value, the value is assumed to be a decimal value, and it’s converted into a percentage. For example, 3 becomes 300%.

Using the Date and Time Format
Use the date and time format to display date and/or time values.

To define a date and time format for one or more cells:
1. Select the cell or cells.
2. Click Inspector in the toolbar, click the Table Inspector button, and then click Format.
3. Choose Date & Time from the Format pop-up menu.
4. To specify how you want a date formatted, choose a format from the Date pop-up menu.
5. To specify how you want a time value formatted, choose a format from the Time pop-up menu.

Using the Fraction Format
Use the fraction format to control the display of values smaller than 1. For example, 27.5 displays as 27 1/2 when the format is Halves and as 27 4/8 when the format is Eighths.

To define a fraction format for selected cells:
1. Select the cell or cells.
2. Click Inspector in the toolbar, click the Table Inspector button, and then click Format.
3. Choose Fraction from the Cell Format pop-up menu.
4. Choose a display format from the Accuracy pop-up menu.

**Using the Scientific Format**

Use the scientific format to display numbers using an exponent raised by the power of 10. The exponent is displayed following an “E.” For example, the value 5.00 in scientific format displays as 5.00E0. And the value 12345 displays as 1.2345E4.

**To define a scientific format for one or more cells:**
1. Select the cell or cells.
2. Click Inspector in the toolbar, click the Table Inspector button, and then click Format.
3. Choose Scientific from the Cell Format pop-up menu.
4. Use the Decimals field to specify the number of decimal places to display.

**Using the Text Format**

Use the text format when you want all of a cell’s content to be treated as text, even when it’s a number.

**To define a text format for one or more cells:**
1. Select the cell or cells.
2. Click Inspector in the toolbar, click the Table Inspector button, and then click Format.
3. Choose Text from the Cell Format pop-up menu.

**Monitoring Cell Values**

You can have Keynote change a cell’s fill and/or text color when its content exhibits a particular condition.

You define simple rules that test for the condition and then change fill and/or text color if the condition is met. For example, you can define a rule that turns a cell blue if it contains a particular value and another rule that turns the cell green if it contains another value. Or you can define a rule that turns a value red when it duplicates a value in a group of cells, or purple if the value is above average in a group of cells.

You can apply a rule to a single cell or to a range of cells. Rules applied to multiple cells trigger color changes when **any** of the cells meet the rule’s condition.

**To define rules:**
1. Select one or more cells.
2. Click Inspector in the toolbar and then click the Table Inspector button.
3. Click Format.
4. Select Conditional Format, and then click “Show rules.”
5. Select “Highlight cells using the following rules.”
Choose a condition from the “Choose a rule” pop-up menu. The conditions in the top section of the menu apply tests to numeric values. Conditions for text values are in the middle section of the list, and date conditions are at the bottom.

Note that the Between condition requires that you specify two numbers. The condition is met if either of the numbers or any number in between them appears in the cell(s).

Provide additional information as required to fully specify a particular condition to test for.

Select Fill Color and/or Text Color and click the color wells (see “Using the Colors Window” on page 80) to define the background and value colors to apply to the cell if the condition is met.

To add another rule, click + and repeat steps 6 through 8.

If more than one rule is defined for a cell and the cell’s content satisfies the conditions of multiple rules, the colors associated with the higher rule in the list of rules are applied to the cell.

To stop using a rule, click its – button to delete the rule, or deselect Fill Color and Text Color to disable the rule. To stop using a list of rules, deselect “Highlight cells using the following rules.”

Adding Images or Color to Cells
You can add graphics or color to individual table cells or to an entire table.

To add an image or color to a table cell:
1 Select the cell.
2 Click Inspector in the toolbar, and then click the Table Inspector.
3 To add an image, choose Image Fill from the Cell Background pop-up menu. See “Filling an Object with an Image” on page 81 for instructions.
4 To add background color, choose Color Fill or Gradient Fill from the Cell Background pop-up menu. See “Filling an Object with Color” on page 79 for more information.

Autofilling Table Cells
Autofilling lets you use the content in one or more cells to automatically add values to adjacent cells.

Here are ways to autofill table cells:
- To paste the content and fill of a cell into adjacent cells, select the cell and then drag the Fill handle in its lower right corner over the cells into which you want to paste.
  Any data, cell format, formula, or fill associated with the selected cell is pasted. If any target cell contains data, autofilling overwrites that data with the value you’re repeating.
To paste the content and fill of a cell into one or more cells in the same row or column, select two or more adjacent cells. Choose Insert > Fill Right to assign selected cells the value that resides in the leftmost selected cell(s). Choose Insert > Fill Down to assign selected cells the value that resides in the topmost selected cell(s).

Any data, cell format, formula, or fill associated with the selected cell is pasted. If any target cell contains data, autofilling overwrites that data with the value you’re repeating.

You can also add values to cells based on value patterns. For example, if a cell contains a day of the week or a month, you can select the cell and then drag to the right or down to add the next day of the week or month to the adjacent cell.

To create new values based on numeric patterns, select two or more cells before dragging. For example, if two selected cells contain 1 and 2, the values 3 and 4 are added when you drag through the adjacent two cells. And if two selected cells contain 1 and 4, the values 7 and 10 are added when you drag through the adjacent two cells (values are incremented by 3).

Autofilling doesn’t set up an ongoing relationship among cells in the group. After autofilling, you can change the cells independently of each other.

**Working with Rows and Columns**

You can quickly add or remove rows and columns, create a header row or column or a footer row, and more.

**Adding Rows**

You can add rows within a table or at the end of a table. If the table contains a footer row, rows added at the bottom of the table are added above the footer row.

**Here are ways to add rows:**

- To add a single row, select a cell and then choose Format > Table > Add Row Above or Add Row Below. You can also choose these commands from the Edit Rows & Columns pop-up menu in the Table Inspector.
- To add a row at the end of the table, press Tab when the last cell is selected.
- To add one or more rows at the end of a table, use the Rows controls in the Table pane of the Table Inspector.
- You can split cells into two equal rows. “Splitting Table Cells” on page 131 tells you how.

**Adding Columns**

You can add new columns to a table.
Here are ways to add columns:

- To add a single column, select a cell and then choose Format > Table > Add Column Before or Add Column After. You can also choose these commands from the Edit Rows & Columns pop-up menu in the Table Inspector.

- To add one or more columns to the right side of a table, use the Columns controls in the Table pane of the Table Inspector.

- You can split cells into two equal columns. “Splitting Table Cells” on page 131 tells you how.

Deleting Table Rows and Columns

There are several techniques available for deleting one or more table rows or columns.

Here are ways to delete rows or columns:

- Select the row(s) or column(s) or a cell in them, and then choose Format > Table > Delete Row or Format > Table > Delete Column.

- To delete one or more rows or columns, select them and then choose Delete Row or Delete Column from the Edit Rows & Columns pop-up menu in the Table Inspector. You can also access these commands by choosing Format > Table > Option.

Using a Table Header Row or Column

Use header rows and columns to label the data in rows and columns. Header rows and columns are formatted so that they stand out from the other rows and columns. A header row consists of the topmost cell in each column. A header column consists of the leftmost cell in each row.

You can’t split a header row or footer row into multiple rows or header columns into multiple columns.

Here are ways to add or delete a header row or column:

- Select the table, and then select or deselect Header Row or Header Column in the Table pane of the Table Inspector.

- Select the table and then choose one of the following from the Format > Table submenu: Add Header Row, Delete Header Row, Add Header Column, or Delete Header Column.

Using a Footer Row

Use a footer row when you want to draw attention to the last row in a table. A footer row can contain the same content as any other row, but its formatting makes it visually prominent.

Here are ways to add or delete a footer row:

- Select the table, and then select or deselect Footer Row in the Table pane of the Table Inspector.
Select the table and then choose Add Footer Row or Delete Footer Row from the Format > Table submenu.

**Resizing Table Rows and Columns**

Resize all rows and columns so they’re equal in size, or resize only specific rows and columns.

**Here are ways to resize table rows and columns:**

- To make all rows the same size, select the table and choose Format > Table > Distribute Rows Evenly.
- To make all columns the same size, choose Format > Table > Distribute Columns Evenly.
- To resize a single row, select a cell in the row and use the Row Height field in the Table pane of the Table Inspector.
- To resize a single column, select a cell in the column and use the Column Width field in the Table pane of the Table Inspector.
- To make several rows the same size, select one or more cells in the rows and choose Table > Distribute Rows Evenly. The rows don’t have to be adjacent. You can also use the Row Height field in the Table pane of the Table Inspector.
- To make several columns the same size, select one or more cells in the columns and choose Table > Distribute Columns Evenly. The columns don’t have to be adjacent. You can also use the Column Width field in the Table pane of the Table Inspector.

If cell content is clipped as a result of resizing, see “Displaying Content Too Large for Its Cell” on page 122 for options.

**Alternating Row Colors**

Use a different color background for alternate rows to give a table a banded effect.

**To alternate row colors:**

1. Select the table.
2. Click Inspector in the toolbar and then click the Table Inspector button.
3. Select Alternating Row Color.
4. Click the adjacent color well to open the Colors Window, and then choose a color for the alternate rows. See “Using the Colors Window” on page 80 for instructions.
5. To change the fill attributes of the other rows, use the Cell Background controls in the Table Inspector. See “Filling an Object with Color” on page 79 for instructions.
Working with Table Cells
You can split and merge table cells, resize them, format them, hide them, add comments, and more.

Merging Table Cells
Merging table cells combines adjacent cells into one, eliminating the borders so that they behave as a single cell.

To merge table cells:
1 Select a group of two or more adjacent table cells. The group of cells you choose must form a rectangle, and they must all be body cells or header cells.
2 Choose Format > Table > Merge Cells.
You can also choose Merge Cells from the Edit Rows & Columns pop-up menu in the Table Inspector.

Merging horizontally contiguous cells containing only text or a mixture of text, numbers, formatted values, and formulas joins the content from all the original cells as text separated by tabs. Merging vertically contiguous cells containing only text or a mixture of text, numbers, formatted values, and formulas joins the content from all the cells as text separated by carriage returns.

When you merge column cells, the cell background takes on the image or color that was in the topmost cell. When you merge row cells, the cell background takes on the image or color that was in the leftmost cell.

When a cell containing text, a number, a formula, or a cell format is merged with an empty cell, the new cell retains the content of the non-empty cell.

When a cell containing a number format is merged with an empty cell, the new cell retains the number format.

Splitting Table Cells
Splitting cells divides each selected cell into two equal parts, horizontally (rows) or vertically (columns). Both of the new cells have identical background colors or images. Any text that was in the original cell remains in the topmost or leftmost cell.

To split cells horizontally or vertically:
1 Select a table cell or cells. To split an entire row or column, select all the cells in the row or column.
2 To split cells into rows, choose Format > Table > Split into Rows. To split cells into columns, choose Table > Split into Columns.
You can also choose Split Rows or Split Columns from the Edit Rows & Columns pop-up menu in the Table Inspector.
3 To create smaller and smaller units, repeat steps 1 and 2 for the split cells.
To rejoin split cells, merge them as “Merging Table Cells” on page 131 describes.

**Formatting Table Cell Borders**
You can change the line thickness and color of table cell borders. Or you can hide the cell border of any cell.

*Here are ways to format table cell borders:*
1 Select the cell border segments you want to format (see “Selecting Table Cell Borders” on page 120).
2 If the Table Inspector isn’t open, click Inspector in the toolbar, click the Table Inspector button, and click Table.
3 To set line thickness and color, use the Cell Borders settings:
   - *Stroke pop-up menu:* Lets you choose a stroke style. To hide borders, choose None.
   - *Line thickness field:* Controls the thickness of the stroke.
   - *Color well:* Lets you choose a stroke color using the Colors window. See “Using the Colors Window” on page 80 for instructions.

**Copying and Moving Cells**
You can use commands or dragging to move or copy table cells.

*Here are ways to copy and move cells:*
- To swap cell values within a table, select a cell or several adjacent cells, and then drag the selection to the destination cells. Values in the selection are swapped with values in the destination cells.
- To copy cells within or between tables, drag selected cells while holding down the Option key. Any values in the destination cells are replaced.

You can copy cells by selecting them, choosing Edit > Copy, selecting destination cells, and then choosing Edit > Paste.

See “Copying or Moving Formulas with Cell References” on page 139 to learn about techniques for duplicating or moving a cell that contains a formula.
Sorting Table Cells

You can arrange values in some or all the cells in a column in ascending or descending order. Rows containing cells being sorted are reordered. Header cells aren’t sorted.

Here are ways to sort:
• To sort all the cells in a column, select one of the column’s cells, open the Table Inspector, and then choose Sort Ascending or Sort Descending from the Edit Rows & Columns pop-up menu.
• To sort only some of the cells in a column, select the cells before choosing Sort Ascending or Sort Descending.

The following table describes how different types of data are sorted in ascending or descending order.

<table>
<thead>
<tr>
<th>Type of data</th>
<th>Ascending order</th>
<th>Descending order</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>aA–zZ</td>
<td>Zz–Aa</td>
</tr>
<tr>
<td>Dates</td>
<td>Year (earliest first), then Month (January first), then day (1-31)</td>
<td>Year (most current first), then month (December first), then day (31-1)</td>
</tr>
<tr>
<td>Numbers</td>
<td>–2, –1, 0, 1, and so on</td>
<td>1, 0, –1, –2, and so on</td>
</tr>
<tr>
<td>Cells containing only text, mixed with cells containing only numbers</td>
<td>–2, –1, 0, 1, and so on, then aA–zZ</td>
<td>Zz–Aa, then 1, 0, –1, –2, and so on</td>
</tr>
<tr>
<td>Cells containing a mixture of text and numbers</td>
<td>Values starting with numbers first (1z, 1Z, a1, A1)</td>
<td>Values starting with text first (A1, a1, 1A, 1z)</td>
</tr>
<tr>
<td>Empty cells</td>
<td>At the bottom</td>
<td>At the bottom</td>
</tr>
<tr>
<td>Boolean (TRUE, FALSE)</td>
<td>Below text and above an empty cell</td>
<td>Above text</td>
</tr>
</tbody>
</table>
This chapter tells you how to perform calculations in table cells using formulas and functions.

See Chapter 6, “Using Tables,” on page 114 for instructions for adding and formatting tables and data in them. See online help for complete information about individual functions.

Using Formulas
A formula is a mathematical expression that uses operations to derive a value. You can add a formula to a table cell to display a value derived from values in other table cells.

For example, you can add a formula to the bottom cell of a column that adds the numbers in all the other cells in the column. If any of the column values change, the total in the bottom cell changes automatically.

Formulas derive values by using operators and functions.

- **Operators** perform operations such as addition (+) and multiplication (*).
  
  Here’s a formula that adds values: =A2 + 16. A2 is called a cell reference; A2 refers to the second cell in the first column. The value 16 is called a constant, because it’s a specific value that uses no operators or functions.
  
  The value in cell A2 is added to the value 16, and the result is displayed in the cell that contains the formula.

  Formulas always begin with an equal sign (=). For simplicity, the examples throughout the Keynote documentation omit the equal sign.

- **Functions** are predefined, named operations, such as SUM and AVERAGE.
  
  To use a function, you name the function and, in parentheses following the name, you provide the arguments it needs. Arguments specify the data the function will use when it performs its operations.
Here’s a formula that adds the values in nine cells of the first column: \( \text{SUM(A2:A10)} \). There is one argument, A2:A10. The colon means the function should use the values in cells A2 through A10.

**Adding a Quick Formula**

An easy way to perform a basic calculation using values in a range of adjacent table cells is to add a quick formula using the Quick Formula pop-up menu on the Format pane of the Table Inspector.

You can also choose Insert > Function and use the submenu that appears.

Here are operations you can perform using the Quick Formula pop-up menu or submenu:

- Choose one of the following to perform calculations using values in the selected cells. Empty cells and cells containing values that aren't mentioned are ignored.
  - **Sum**: Totals numeric values in the cells.
  - **Average**: Calculates the arithmetic mean of numeric values in the cells.
  - **Min**: Determines which numeric value in the cells is the smallest.
  - **Max**: Determines which numeric value in the cells is the largest.
  - **Count**: Determines how many of the values in the cells are numeric or date/time values.
  - **Product**: Multiplies all the numeric values in the cells.

- Choose Insert > Function > More Functions to open the Function Browser. See “Using Functions” on page 143 for details about this tool.
- Choose Formula Editor to open the Formula Editor. See “Using the Formula Editor” on page 137 for instructions.
Performing a Basic Calculation Using Column Values
Using the Quick Formula pop-up menu on the Format pane of the Table Inspector makes it easy to perform basic calculations on adjacent values in a column and display the results.

Here are ways to perform basic calculations using values in a column:

- To use values in a range of adjacent cells, select the cells, click Inspector in the toolbar, click the Table Inspector button, and then click Format. Choose a formula from the Quick Formula pop-up menu.
  Keynote places the formula and its result in the first empty cell beneath the selected cells. If there is no empty cell, Keynote creates a footer row to hold the result.

- To use all the values in a column, click the column’s header cell or reference tab. In the Format pane of the Table Inspector, choose a formula from the Quick Formula pop-up menu.
  Keynote places the formula and its result in a footer row. If a footer row doesn’t exist, Keynote adds one.

Performing a Basic Calculation Using Row Values
Using the Quick Formula pop-up menu on the Format pane of the Table Inspector makes it easy to perform basic calculations on adjacent values in a row and display the results.

Here are ways to perform basic calculations using values in a row:

- To use values in a range of adjacent cells, select the cells, click Inspector in the toolbar, click the Table Inspector button, and then click Format. Choose a calculation from the Quick Formula pop-up menu.
  Keynote places the formula and its result in the first empty cell to the right of the selected cells. If there is no empty cell, Keynote adds a column to hold the result.

- To use all the values in a row, click the row’s header cell or reference tab. In the Format pane of the Table Inspector, choose a formula from the Quick Formula pop-up menu.
  Keynote places the formula and its result in a new column.

Removing a Formula
If you no longer want to use a formula that’s associated with a cell, you can quickly remove the formula.

To remove a formula from a cell:
1 Select the cell.
2 Press the Delete key.
Using the Formula Editor
The Formula Editor lets you create and modify formulas.

Here are ways to open the Formula Editor:

- Select a table cell and then type the equal sign (=).
- Select a table cell, click Inspector in the toolbar, click the Table Inspector button, and then click Format. Choose Formula Editor from the Quick Formula pop-up menu.
- Select the table, and then double-click a table cell that contains a formula.
- Select a table cell, and then choose Insert > Function > Formula Editor.

When the Formula Editor opens, it appears over the selected cell. To move the Formula Editor, hover the cursor over the left side of the Formula Editor until the cursor changes into a hand, then click and drag.

When you select a cell that contains a formula, its arguments are highlighted in color.

Adding a New Formula with the Formula Editor
Use the Formula Editor to create a formula.

To add a new formula using the Formula Editor:

1. Select the cell in which you want to display the result of the formula.
2. Open the Formula Editor. For example, type the equal sign (=).
3. Use the text field to specify the formula, making sure the equal sign is the first character in your formula.
   - To learn techniques for including cell references in your formulas, see “Using Cell References” on page 138.
   - To learn about using operators in formulas, see “Using Operators” on page 140.
   - To learn how to insert a function into a formula, see “Using Functions” on page 143.
4. To save changes, press Return, press Enter, or click the Accept button in the Formula Editor. You can also click outside the table.
   - To close the Formula Editor and discard changes, press Esc or click the Cancel button in the Formula Editor.
**Editing a Formula with the Formula Editor**

You can use the Formula Editor when you want to edit a formula.

**To edit a formula:**

1. Double-click a table cell that contains a formula. The Formula Editor opens, with the formula displayed in the text field and its arguments highlighted in color.
2. Make changes as required. You can use the arrow keys to move the insertion point around in the text field.
3. To save changes, press Return, press Enter, or click the Accept button in the Formula Editor. You can also click outside the table.

To close the Formula Editor and discard changes, press Esc or click the Cancel button in the Formula Editor.

**Using Cell References**

You use cell references to identify specific cells in formulas. For example, if you add a formula that averages the values in two cells, you use cell references to identify those cells.

You can create cell references using the letters and numbers of reference tabs or using header cell names:

- If your table has both a header row and a header column, you can identify a cell using the column name followed by the row name.
  For example, if a column is named 2006 and a row is named Class Enrollment, the cell where the row and column intersect would be referred to as 2006 Class Enrollment.
- You can use the letters and numbers of reference tabs to identify a specific cell. You specify the column letter and then the row number.
  For example, C55 refers to the fifty-fifth row in the third column.

**Adding Cell References to a Formula**

To insert a cell reference, you can click a cell, click a reference tab, or select a range of cells when there’s an insertion point in the text field of the Formula Editor. You can also insert a cell reference by typing it.

**Here are ways to add a cell reference at the insertion point in the text field:**

- To create a reference to a specific cell by using your mouse, click the cell.
  You can also type a reference to a specific cell. Use the column letter followed by the row number (A4) in the reference tabs or use the column name followed by the row name (2006 Class Enrollment).
To add a reference to a list of individual cells, click each cell. If the references are arguments in a function, Keynote automatically inserts a comma (,) between the references, which you can replace with a different character if needed. For example, if you’re in a location where the decimal separator is a comma, you can separate multiple cell references using a semicolon instead of a comma.

To add a reference to a range of adjacent cells, drag over the cells you want to add. You can also type or click the first cell, type a colon, and then type or click the last cell. For example B2:B5 refers to four cells in the second column. B2:C3 refers to two cells in the second column and two cells in the third column.

To refer to all the cells in a column, click the column’s reference tab or click its header cell if there is one. You can type the reference by using the column letter (C or C:C) or the column name if there’s a header cell. For example, SUM(B) or SUM(B:B) adds all the values in the cells of the second column.

To refer to all the cells in a row, click the row’s reference tab or click its header cell if there is one. You can type the reference by using the row number (1:1) or the row name if there’s a header cell. For example, SUM(1:1) adds all the values in the cells of the first row.

Copying or Moving Formulas with Cell References
You can copy or move a formula that contains cell references without invalidating the references.

Here are techniques for relocating formulas:

- To move a formula to a different cell, move the formula’s cell by dragging it to another cell.

- To paste a copy of a formula in a different cell and use the same cell references in both formulas, place a dollar sign ($) in front of column and row identifiers (=A$1). This technique creates what’s called an absolute cell reference.

  For example, if the formula =A1 appears in cell D1 and you want to paste a copy of the formula in cell E1, change the formula to =$A$1, select D1, copy it, and paste the copy into E1. The formula $A$1 is copied into cell E1. If you didn’t change the formula to use an absolute cell reference the formula in E1 would be =B1.

Applying a Formula Once to Cells in a Column or Row
When a table has header cells, you can use them to quickly apply a formula to all the cells in a row or column. The values in the cells are recomputed using the formula. This formula is called a header formula.
To apply a header formula to cells in a column or row:
1. Select the header cell for the column or row.
2. Open the Formula Editor. For example, type the equal sign (=).
3. Type the formula you want to apply to each cell in the column or row.
   For example, to assign values to the cells of column C that are five times greater than the corresponding cell in column B, you'd use the formula B*5 or B:B*5.
   The formula is duplicated in all the cells in the column or row. In this example, cell C4 would contain the value computed by using the formula B4*5.
4. Click the Accept button or press Return or Enter to save the formula.

Handling Errors and Warnings
When a formula in a table cell is incomplete, contains invalid cell references, or is otherwise incorrect, or when an import operation creates an error condition in a cell, Keynote displays an icon in the cell. A blue square in the upper left of a cell indicates one or more warnings. A red triangle in the middle of a cell means that a formula error occurred.

To view error and warning messages:
- Click the icon.

A message window summarizes each error and warning condition associated with the cell.

Using Operators
Use operators in formulas to perform arithmetic operations and compare values:
- **Arithmetic operators** perform arithmetic operations, such as addition and subtraction, and return numerical results.
- **Comparison operators** compare two values and return TRUE or FALSE.

Performing Arithmetic Operations
To create a formula that performs an arithmetic operation, you use arithmetic operators. For example, to add three values in a column, you could create a formula that looks like this: A2 + A3 + A5.
Here are the basic arithmetic operators. For complete information about arithmetic operators that Keynote supports, see “Understanding the Arithmetic Operators” on page 141.

<table>
<thead>
<tr>
<th>To perform this operation</th>
<th>Use this arithmetic operator</th>
<th>For example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sum two values</td>
<td>+</td>
<td>A2 + B2</td>
</tr>
<tr>
<td>Subtract one value from another value</td>
<td>–</td>
<td>A2 – B2</td>
</tr>
<tr>
<td>Multiply two values</td>
<td>*</td>
<td>A2 * B2</td>
</tr>
<tr>
<td>Divide one value by another value</td>
<td>/</td>
<td>A2 / B2</td>
</tr>
</tbody>
</table>

**To add an arithmetic formula to a cell:**

1. Select an empty cell for displaying the results of the formula.
2. Open the Formula Editor. For example, type an equal sign (=).
3. Enter the formula in the text field following the equal sign.
   - For example, to enter the formula $A3 \times B5 + B6$, in the text field following the equal sign you could click or type $A3$, type $\times$ (the multiplication operator), click or type $B5$, and then click $B6$ (if you don’t type an operator before clicking, Keynote adds the plus sign (+) automatically when you’re not specifying function arguments).
4. Click the Accept button or press Return or Enter to save the formula.

**Understanding the Arithmetic Operators**

Arithmetic operators in table cell formulas perform arithmetic operations and return numerical results.

Here are the arithmetic operators (examples presume that cell A2 contains 20 and that B2 contains 2):

- The operator + returns the sum of two values. For example, $A2 + B2$ returns 22.
- The operator – returns the difference between two values. For example $A2 – B2$ returns 18.
- The operator $\times$ returns the product of two values. For example, $A2 \times B2$ returns 40.
- The operator $\div$ returns the result of dividing one value by another value. For example, $A2/B2$ returns 10.
The operator \(^{\land}\) returns the result of raising one value to the power of another value.
For example, A2 \(^{\land} B2\) returns 400.

The operator \(\%\) returns the result of dividing a value by 100.
For example, A2\% returns 0.2, formatted for display as 20%.

When a cell reference points to an empty cell, 0 is the value used.
When a cell reference points to a cell containing FALSE, 0 is used. If the cell contains TRUE, 1 is used. For example, TRUE + 1 returns 2.

Using a string with an arithmetic operator returns an error. For example, 3 + "hello" is not a correct arithmetic operation.

**Understanding the Comparison Operators**

Comparison operators compare two values and return TRUE or FALSE.

Here are the comparison operators (examples presume that cell A2 contains 20 and that B2 contains 2):

- The operator \(=\) returns TRUE if two values are equal.
  For example, A2 = B2 returns FALSE.

- The operator \(<\>\) returns TRUE if two values aren’t equal.
  For example, A2<>B2 returns TRUE.

- The operator \(>\) returns TRUE if the first value is greater than the second value.
  For example, A2 > B2 returns TRUE.

- The operator \(<\)= returns TRUE if the first value is less than or equal to the second value.
  For example, A2 < B2 returns FALSE.

- The operator \(>=\) returns TRUE if the first value is greater than or equal to the second value.
  For example, A2 >= B2 returns TRUE.

- The operator \(<\)= returns TRUE if the first value is less than or equal to the second value.
  For example, A2 <= B2 returns FALSE.

Strings are larger than numbers. For example, "hello" > 5 returns TRUE.

TRUE and FALSE can be compared with each other, but not with numbers or strings.
TRUE > FALSE, and FALSE < TRUE, because TRUE is interpreted as 1 and FALSE is interpreted as 0. TRUE = 1 returns FALSE, and TRUE = "SomeText" returns FALSE.
Using Functions
A function is a predefined, named operation (such as SUM and AVERAGE) that you can use to perform a calculation in a table cell.

There are several families of functions, ranging from financial functions that calculate interest rates, investment values, and more to statistical functions that calculate averages, probabilities, standard deviations, and more. See Keynote Help for complete information about all the functions, including the arguments you specify to provide the data for functions to use in their calculations.

Although you can type a function into the text field of the Formula Editor, you can also use the Function Browser to add a function to a formula.

To use the Function Browser to add a function:
1 Select the cell in which you want to add a function.
2 Choose Insert > Function > More Functions. The Function Browser opens.
3 Select a function.
   To find a function, scroll through the list on the right, optionally subdividing the list by selecting a function category on the left. You can also search for a specific function within the selected function category by using the search field in the upper right.
4 Click Insert. The Formula Editor is displayed in the cell.
   Keynote inserts the function into the text field, followed by one or more argument placeholders, within parentheses.
5 Use the Formula Editor to replace each placeholder with a cell reference or other value or perform any additional formula editing required.
Using Charts

You can convert data from tables into attractive charts. This chapter outlines the basics of creating and formatting charts.

Keynote provides tools for creating your own visually appealing charts to present numerical data. You can copy and paste your data from a spreadsheet, or type it directly into the Chart Data Editor to create and edit your charts right on the slide canvas. By default, the appearance of charts is coordinated with the theme you’re using.

About Charts

You can display data in a chart to visually reveal trends or relationships that aren’t as apparent when you view the data in rows in columns. You can choose from a variety of chart types to present your data, including pie charts, line charts, bar charts, column charts, area charts, and scatter charts. Most charts have both two-dimensional and three-dimensional versions.

To enter the data to show in a chart, you use the Chart Data Editor, as “Editing Chart Data” on page 149 describes. If you change data in the Chart Data Editor, the chart updates automatically.

For example, you may want to create a chart that shows how many employees work in Region 1 and Region 2 each year. Such a table might have two rows (one for Region 1 and one for Region 2) and four columns (one for each year from 2007 through 2010).

These squares indicate which color represents each data series.
There are several ways to represent this data in a chart. In a bar chart, for example:

- You can plot 2007 employee counts for Region 1 and Region 2 in side-by-side bars, followed by pairs of bars for 2008, 2009, and 2010. Such a chart would have two data series and four data sets.

Region 1 and Region 2 are called data series; each region is represented by a series of data values. Data values (data points) for each region are represented by bars that are grouped side by side in the chart; each group is called a data set (2007 is a data set, 2008 is a data set, and so on).

- Alternatively, you can change the chart orientation so that data points are grouped by region rather than by year. In this case, the years are data series and the regions are data sets. The bar chart would contain two groups of bars, one for Region 1 and one for Region 2.
You can easily switch between using columns and rows as data series by using the Plot Row vs. Column button in the Chart Data Editor.

Data series are represented differently in different kinds of charts:

- In *column charts* and *bar charts*, a data series is represented by a series of bars in the same fill (color or texture).
- In a *line chart* (also called a *graph*), a data series is represented by a single line.
- In an *area chart*, a data series is represented by an area shape.
- In a *pie chart*, only a single data set (the first data point in each series) is represented on the chart (whichever is listed first in the Chart Data Editor).
- In a *scatter chart*, two columns of data are used to plot values for a single data series. Each pair of values determines the position of one data point.

**Adding a Chart**

Add a chart by inserting it on the slide canvas or by drawing it.

*Here are ways to add a chart:*

- Click Charts in the toolbar and choose a chart type from the pop-up menu.
- To draw a chart on the slide canvas, hold down the Option key as you click Charts in the toolbar and then choose a chart. Release the Option key and move the pointer over the canvas until it becomes a crosshair. Drag across the canvas to create a chart that's the size you want. To constrain the chart's proportions, hold down the Shift key as you drag.

A chart containing placeholder data appears on the slide, and the Chart Inspector and Chart Data Editor open. Use the Chart Inspector to select the initial chart type and to format your chart. Use the Chart Data Inspector to edit chart data. See “Picking an Initial Chart Type” on page 147, “Formatting General Chart Attributes” on page 150, “Formatting Specific Types of Charts” on page 156, and “Editing Chart Data” on page 149 for instructions.
Selecting a Chart Type
After you've added a chart, you can set or change its type. Choose from a wide variety of chart types, including bar charts, 3D bar charts, line charts, 3D line charts, and more.

Picking an Initial Chart Type
When you first add a chart, a default chart is inserted for you. You can change the type of the chart if you like.

Here are ways to specify a chart type:
- Select the chart, click Inspector in the toolbar, click the Chart Inspector button, and then choose a chart type from the pop-up menu that appears when you click the chart icon in the upper left.
- Choose Format > Chart > Chart Type > chart type.
Changing a Chart from One Type to Another
You can change a chart's type anytime you like.

To change a chart from one type to another:
1 Select the chart.
2 Click Inspector in the toolbar, click the Chart Inspector button, and then choose a different chart type from the pop-up menu that appears when you click the chart icon in the upper left.

If you switch to a pie chart, the first data point in each series is represented as a wedge. See “Pie Charts” on page 156.

If you switch to a scatter chart, each point in the chart requires two values. If the chart is based on an odd number of rows or columns, the last row or column isn’t plotted. See “Scatter Charts” on page 161.

If you switch to a bar, column, area, or line chart, each series in the new chart corresponds to a row or column in the Chart Data Editor.

If you switch to a 3D version of a chart, the Chart Inspector provides controls for managing object depth, lighting style, and more. See “3D Charts” on page 161.

Formatting you've applied to the chart you're changing may not be applied to the new chart. For example, the color fill attribute of data point elements (bars, wedges, and so on) has a different default value for each type of chart. If you've changed a column fill color and then change the chart to be a bar chart, the fill color change isn't retained.

- Depending on the type of chart, the attributes that may change when you change a chart's type are show value label, value label position, text style, series stroke, series shadow, series fill, data point symbol, and data point fill.
- Bar/column charts and stacked bar/column charts share attributes except for value label position. Also, bar/column charts have separate fills.
- 3D chart shadows are shared across chart types.

When you change a chart's type and the new type has some of the same attributes, those attributes don't change. Shared attributes include axes, gridlines, tick marks, axis labels, show minimum value, number format, borders, rotation, shadows, and 3D lighting style.

You'll learn more about these attributes throughout the remainder of this chapter.
Editing Chart Data
To edit chart data, open the Chart Data Editor and enter your data by typing it or by copying and pasting from Excel, AppleWorks, or other spreadsheet applications.

To open the Chart Data Editor:
1 Select the chart.
2 Click Inspector in the toolbar, click the Chart Inspector button, and then click Edit Data.
   You can also choose Format > Chart > Show Data Editor.

Copying Data into the Chart Data Editor
Copy data from Excel, AppleWorks, or other spreadsheet applications and paste it into the Chart Data Editor.

To use data from another spreadsheet:
1 Open the spreadsheet, and then select all the relevant cells.
2 Press Command-C.
3 Click Inspector in the toolbar, click the Chart Inspector button, and then click Edit Data to open the Chart Data Editor.
4 Select the top cell in the first column of the Chart Data Editor.
5 Press Command-V.

Working with Rows and Columns in the Chart Data Editor
Change the name of rows and columns and reorder, add, or delete rows and columns.

Here are ways to work with rows and columns in the Chart Data Editor:
- To edit the names of rows and columns or the data in a cell, double-click a cell or a row or column label, and then type.
- To reorder rows or columns, drag a row or column label to a new position.
To add rows or columns, click Add Row or Add Column to place a row above the selected row or a column to the left of the selected column. If no row or column is selected, the new row or column appears at the bottom or right edge of the table. (To see the new row or column, you may have to press the Return key or the Tab key, expand the Chart Data Editor window, or scroll.) Alternatively, select any blank cell, type your data, and then press Return. A new row or column is automatically created.

To delete rows or columns, select the row or column label, and then press Delete.

To choose whether the chart’s data series are represented by rows or columns in the Chart Data Editor, click a “Plot Row vs. Column” button.

Formatting General Chart Attributes
You can resize and reposition charts and chart legends. You can add a title to a chart. You can format chart elements (fonts, textures, colors, axis and data point labels, and tick marks). You can adjust the angle and lighting style of 3D charts.

Using a Legend
The chart legend describes the meaning of the colors used to plot data points in each data series.

![Region 1](image1.png) ![Region 2](image2.png)

You can show or hide a chart’s legend, and you can reposition it.

Here are ways to work with a chart’s legend:

- To show the legend, select the chart and then select Show Legend in the Chart Inspector.
- To edit the labels in the legend, edit the series labels in the Chart Data Editor or select the legend and edit the text directly in the legend.
- To format the legend’s text, see “Formatting Titles, Labels, and Legends” on page 156.
- To hide the legend, select the chart and then deselect Show Legend in the Chart Inspector.

You can also select the legend and press Delete.

- To move the legend, select and then drag it.
Using a Chart Title
You can add a title to a chart. The title can be formatted.

Here are ways to work with a chart's title:
- To add a title, select the chart and then select Show Title in the Chart Inspector. Replace the placeholder text with your title.
- To format the title's text, see “Formatting Titles, Labels, and Legends” on page 156.
- To hide the title, select the chart and then deselect Show Title in the Chart Inspector.

Resizing a Chart
You can make a chart larger or smaller by dragging one of its selection handles or by using the Metrics Inspector.

Here are ways to resize a chart:
- Click the chart to select it, and then drag an active selection handle. Active selection handles have a black outline.
- To maintain a chart’s proportions, hold down the Shift key as you drag to resize it.
- To resize a chart in one direction, drag a side handle instead of a corner handle.
- To resize by specifying exact dimensions, click Inspector in the toolbar, click the Metrics Inspector button, and then click Metrics. In this pane, you can specify a new width, height, and angle of rotation, and you can change the chart's distance from the margins.

Rotating Charts
There are several techniques for rotating 2D charts. You can't rotate (or flip) 3D charts. If a 3D chart is grouped with 2D charts, you can rotate the group, but only the 2D charts in the group will rotate.

Here are ways to rotate 2D charts:
- Select the chart, hold down the Command key, move the pointer toward an active selection handle until it changes to a curved, double-headed arrow, and then drag a selection handle.
- To rotate a chart in 45-degree increments, press the Shift and Command keys while dragging a selection handle.
- Click Inspector in the toolbar, click the Metrics Inspector button, and then drag the Rotate wheel or use the Angle controls to set the angle of the chart.

Pie charts can also be rotated using the Chart Inspector (see “Rotating 2D Pie Charts” on page 158).
Adding Labels and Axis Markings

Use the Axis pane in the Chart Inspector to format the grid and general look of chart axes.

![Chart Inspector Axis Pane](image)

Most charts have two axes, an X-axis and a Y-axis. Depending on the type of chart, data points are plotted on one of the axes and data sets are grouped on the other axis. The data point axis is called the value axis, and the data set axis is called the category axis.

Showing Axes and Borders

You can show any or all of these elements of a chart: the X-axis, the Y-axis, and chart borders.

To show axes and borders:

1. Select a chart.
2. Click Inspector in the toolbar, click the Chart Inspector button, and then click Axis.
3. Choose one or more items from the Axes & Borders pop-up menu to select the items.
   A selected item has a checkmark next to it; choose the item again to deselect it.

Using Axis Titles

You can add a title to a chart’s X-axis and Y-axis. The title can be formatted.

Here are ways to work with an axis title:

- To add an axis title, select the chart and then select Show Category Title from the X-Axis or Show Value Title from the Y-Axis pop-up menu in the Axis pane of the Chart Inspector. Replace the placeholder text with your title.
- To format the title’s text, see “Formatting Titles, Labels, and Legends” on page 156.
- To hide an axis title, select the chart and then deselect Show Category Title from the X-Axis or Show Value Title from the Y-Axis pop-up menu in the Axis pane of the Chart Inspector.
Showing Data Point Labels
You can display data point values on columns, bars, pie wedges, and other chart elements of 2D and 3D charts.

To format data point labels:
1 Select the chart.
2 Click Inspector in the toolbar, click the Chart Inspector button, and click Series.
3 Choose Show Value from the Data Point Settings pop-up menu.
   To display the value as a percentage or logarithmic value instead of an absolute value, choose Percentage or Logarithmic in the X-Axis or Y-Axis pop-up menu on the Axis pane.
   For pie charts, you display values as percentages by choosing Show Pie Values as Percentages from the Data Point Settings pop-up menu on the Series pane. To display the data series name for a wedge, choose Show Series Name from the Data Point Settings pop-up menu.
4 Select a label location from the Data Point Settings pop-up menu (for example, Middle or Below Right).
5 Specify the number of decimal places to display by entering a number in the Decimals field.
6 To format the data point labels, see “Formatting Titles, Labels, and Legends” on page 156.

Formatting the Value Axis
You can set the values and units to be displayed along the value axis, the axis on which you read the data point values. For column charts (vertical bars), line charts, and area charts, the Y-axis is the value axis. For horizontal bar charts, the X-axis is the value axis. For scatter charts, both axes are value axes. (Pie charts don’t have a value axis. To read about formatting pie charts, see “Pie Charts” on page 156.)

To format the value axis:
1 Select a chart.
2 Click Inspector in the toolbar, click the Chart Inspector button, and then click Axis.
3 To set the value at the chart origin, type a number in the Minimum field (under Value Axis Format).
   The Minimum value cannot be higher than the minimum value of your entire data set.
4 To set the highest number displayed on the value axis, type a number in the Maximum field.
   The Maximum value cannot be lower than the maximum value of your entire data set.
5 To specify the number of axis markings between the minimum and maximum values, specify a number in the Steps field.
6. To display the minimum data value on the value axis, select Show Value Labels and Show Minimum Value from the Labels, Ticks, & Grids X-Axis or Y-Axis pop-up menu, depending on the chart.

7. To specify units for axis values, under Number Format type text in the Prefix or Suffix field (or choose a symbol from the pop-up menus).

8. To display values on the value axis as logarithmic values, choose Logarithmic from the X-Axis or Y-Axis pop-up menu, depending on the chart. This option is available only for 2D bar/column charts that aren’t stacked and for line charts. You can’t plot negative values on the log axis.

9. To display values on the value axis of stacked charts as percentages, choose Percentage from the X-Axis or Y-Axis pop-up menu on the Axis pane.

   For pie charts, you display values as percentages by choosing Show Pie Values as Percentages from the Data Point Settings pop-up menu.

**Placing Labels, Gridlines, and Tick Marks**

The X-Axis and Y-Axis pop-up menus in the Axis pane of the Chart Inspector provide an array of options for placing tick marks, labels, and gridlines along the value axis or the category axis. The options in these pop-up menus vary depending on the kind of chart you select.

For vertical bar charts (column charts), line charts, and area charts, the Y-axis is the value axis and the X-axis is the category axis. For horizontal bar charts, the X-axis is the value axis. For scatter charts, both axes are value axes. For 3D charts, the X and Y axes are the same as their 2D counterparts.

**To format axis markings:**

1. Select the chart.

2. Click Inspector in the toolbar, click the Chart Inspector button, and then click Axis.

3. To format the X-axis, choose an option from the X-Axis pop-up menu. The menu for a column chart looks like this:
To format the Y-axis, choose an option from the Y-Axis pop-up menu. Here’s what the menu looks like for a column chart:

```
Show Value Labels
Show Minimum Value
Show Value Titles
No Major Tick Marks
Major Tick Marks Inside
Major Tick Marks Centered
Major Tick Marks Outside
Show Minor Tick Marks
Show Gridlines
Logarithmic
Percentage
```

**Formatting the Elements in a Data Series**

You can use a variety of visual effects to enhance the appearance of data series elements, such as bars, wedges, and area shapes.

To format data series elements:

1. To format all data series, select the chart.
   
   To format elements in a single data series, select the chart and then click one of the elements in the series.
   
   For all chart types except pie charts, selecting one element (such as a bar) of a series automatically selects the full series. For pie charts, you select individual wedges.

2. To fill series elements with specially designed colors or textures, click Inspector in the toolbar, click the Chart Inspector button, and then click Chart Colors.
   
   Choose a fill type (for example, 3D Texture Fills) from the first pop-up menu, and choose a fill collection (for example, Marble or Wood) from the second pop-up menu.
   
   To fill all the elements in all the data series, click Apply All. The first fill is applied to elements in the first series, the second fill to elements in the second series, and so on.
   
   To fill elements in a single data series, drag the fill to an element (bar, column, and so on) in the series.

3. To adjust the opacity, stroke, shadow, and other graphical attributes of series elements, click the Graphic Inspector button.

4. To adjust series element colors, see “Filling an Object with Color” on page 79.

5. To use one of your own images to fill series elements, see “Filling an Object with an Image” on page 81.

6. To format data point labels, see “Showing Data Point Labels” on page 153.

“Formatting Specific Types of Charts” on page 156 provides instructions for formatting charts of particular types.
Formatting Titles, Labels, and Legends
You can change the size and appearance of chart and axis titles, axis labels, data point labels, and legends.

To format the text of labels and legends:
1 Select the text you want to format.
   To format all chart titles and labels, click the chart to select it. If you select the text for one data point or axis label, all the text of that kind is also selected. You change the font for a chart legend separately.
2 Use the Format menu or the Font panel to format the text. See “Using the Format Menu to Format Text” on page 41 and “Using the Font Panel to Format Text” on page 42 for instructions.

Adding Descriptive Text to a Chart
You can add descriptive text to a chart, such as when you want to provide background information for a particular data point.

To add text:
1 Create a text box. See “Adding Free Text Boxes” on page 59 for instructions.
2 Drag the text box to where you want it on the chart.
3 Type text in the text box.
   Optionally group the chart and the text box so the text stays with the chart. Shift-click to select both the chart and the text box, and then choose Arrange > Group.

Formatting Specific Types of Charts
Different chart styles offer unique options for formatting their elements.

Pie Charts
For pie charts, Keynote plots only the first data point for each data series. If the data series are in rows, only the first column is charted; if the data series are in columns, only the first row is charted.

Thus, one pie chart represents a single data set, and each wedge is one element in that set. You can chart any data set by moving it to the first row or column.

You can format a pie chart as a whole, or you can format individual wedges.
**Selecting Individual Pie Wedges**

If you want to format one or more wedges, you need to select them first.

Here are ways to select pie wedges in a selected pie chart:

- To select a single wedge, click it.
- To select all the wedges, select any wedge and press Command-A.
- To select nonadjacent wedges, hold down the Command key as you select each wedge.
- To select a continuous range of wedges, select the first wedge, and then hold down the Shift key as you select the last wedge.

**Showing a Series Name in a Pie Chart**

On pie charts, you can display series names.

To show series names in a pie chart:

1. Select the chart or individual pie wedges.
2. Click Inspector in the toolbar, click the Chart Inspector button, and then click Series.
3. Choose Show Series Name from the Data Point Label pop-up menu.
4. Choose Inside or Outside from the Data Point Label pop-up menu.

**Separating Individual Pie Wedges**

To make pie wedges more visually prominent, you can separate them from the pie. You can add a series name to separated wedges to further enhance their prominence, as “Showing Data Point Labels” on page 153 describes.

Here are ways to separate individual pie wedges:

- To move a single wedge away from the center of a 2D or 3D pie chart, select it and then drag it or use the Explode control on the Series pane of the Chart Inspector.
- To separate all the wedges away from the center of a 3D pie chart, select the chart before using the Explode control.
Adding Shadows to Pie Charts and Wedges
You can put shadows on individual pie wedges or on the pie as a whole. Putting shadows on individual wedges makes it look as if the wedges are on different layers.

When you add a shadow to a pie wedge, it's a good idea to separate it first. See “Separating Individual Pie Wedges,” earlier in this section, for instructions.

To add shadows:
1. Select the chart or individual pie wedges.
2. Click Inspector in the toolbar, click the Chart Inspector button, and then click Series.
3. To add shadows to wedges, choose Individual from the Shadow pop-up menu.
   To add shadows to the chart as a whole, choose Group from the Shadow pop-up menu.
4. To set shadow attributes, use the Graphic Inspector. See “Adding Shadows” on page 76 for instructions.

Adjusting the Opacity of Pie Charts
You can change the opacity of the chart and individual chart elements, such as the legend. See “Adjusting Opacity” on page 77 for more information.

Rotating 2D Pie Charts
You can use various techniques for rotating a 2D pie chart.

Here are ways to rotate a pie chart:
- Select the chart, click Inspector in the toolbar, click the Chart Inspector button, click Series, and then use the Rotation Angle wheel or field.
- Click Inspector in the toolbar, click the Metrics Inspector button, and then drag the Rotate wheel or use the Angle controls to set the angle of the chart.
- Select the chart, hold down the Command key and move the pointer toward an active selection handle until it changes to a curved, double-headed arrow, and then drag a selection handle.
- To rotate the chart in 45-degree increments, press the Shift and Command keys while dragging a selection handle or Rotate wheel.
**Bar and Column Charts**
You can apply shadows to individual data series or to the entire chart. You can adjust the opacity for the chart as a whole or for individual series (but not individual bars). You can also adjust the spacing between data sets or individual bars.

**Adjusting Spacing of Bar and Column Charts**
You can adjust spacing between individual bars or data sets.

**To adjust spacing:**
1. Select the chart.
2. Click Inspector in the toolbar, click the Chart Inspector button, and then click Series.

   ![Chart Inspector](image)

   Add shadows to bars or data sets.

   Separate the individual bars in the chart.

   Separate the data sets in the chart.

3. To change the space between bars, type a value (or click the arrows) in the “Gap between bars” field.
   To change the space between data sets, specify a value in the “Gap between sets” field.
   The value is the percentage of the bar thickness. Decreasing the space between the bars makes them thicker.
   You can also move the pointer near a bar edge until it becomes a double-headed arrow, then drag to make the bars thicker or thinner.

**Adding Shadows to Bar and Column Charts**
You can add shadows to each bar in the chart or to each group of bars.

If you want to add shadows to individual bars, it’s a good idea to separate them first. See “Adjusting Spacing of Bar and Column Charts” on page 159 for instructions.

**To add shadows:**
1. Select the chart.
2. Click Inspector in the toolbar, click Chart Inspector, and then click Series.

   ![Chart Inspector](image)

3. To add shadows to individual bars, choose Individual from the Shadow pop-up menu.
   To add shadows to each group of bars, choose Group from the Shadow pop-up menu.
4. To set shadow attributes, use the Graphic Inspector. See “Adding Shadows” on page 76 for instructions.
Adjusting the Opacity of Bar and Column Charts
You can change the opacity of the chart and individual chart elements, such as the legend. See “Adjusting Opacity” on page 77 for more information.

Area Charts and Line Charts
In area and line charts, you can use symbols (circles, triangle, squares, and diamonds) to represent data points.

Here are ways to format area charts and line charts:

- To format symbols, select a data series (area shape or line), click Inspector in the toolbar, click the Chart Inspector button, and then click Series. Choose a symbol from the Data Point Symbol pop-up menu.

- To set the line color in line charts, select a line, click Inspector in the toolbar, click the Graphic Inspector button, and then use the Stroke controls. See “Changing the Style of Borders” on page 74 for instructions.

- To add shadows to line or area charts, select a data series (area shape or line), click Inspector in the toolbar, click the Graphic Inspector button, and then use the Shadow controls. See “Adding Shadows” on page 76 for instructions.
Scatter Charts
Scatter charts display data differently than the other kinds of charts. They require at least two columns or rows of data to plot values for a single data series. To show multiple data series, you use additional two-column or two-row pairs.

Each pair of values determines the position of one data point. The first data value in the pair is the X-axis of the point. The second data value is the Y-axis of the point.

Here are ways to work with a scatter chart:

- To format a symbol for a data series, see “Formatting the Elements in a Data Series” on page 155.
- To specify axis settings, use the Axis pane of the Chart Inspector. Because both axes of scatter charts have values, value axis format settings apply to both X-axis and Y-axis. Each axis can have its own number format. See “Formatting the Value Axis” on page 153 for instructions.

3D Charts
All the chart types except scatter charts can be displayed as 3D charts.

Here are 2D and 3D versions of a pie chart.

And here are 2D and 3D versions of a line chart.
To define 3D scene settings:
1. Select a 3D chart.
2. Click Inspector in the toolbar, click the Chart Inspector, and then click 3D Scene.
3. Modify the chart’s viewing angle, lighting style, and depth as desired using the 3D Scene controls.

Viewing angle arrows: Drag an arrow to adjust the angle. Click the vertical arrow and drag up or down to move the chart up or down. Click the horizontal arrow and drag side to side to move the chart left or right. To move the chart both ways, click the intersection of the arrows and drag.

Lighting Style: Choose an item from this pop-up menu to adjust the lighting effect.

Chart Depth: Slide this control to increase or decrease the depth of the 3D elements.
Viewing, Printing, and Exporting Your Slideshow

This chapter describes the various ways to share your Keynote presentation.

You can play a Keynote presentation on your computer and view it on the computer’s display or projected on a large screen. You can make the slideshow a self-running “movie” for a kiosk. You can share it across platforms by exporting it as a QuickTime movie, PowerPoint presentation, Flash file, or PDF document. You can also print directly from Keynote in a variety of page layouts.

Customizing a Presentation for an Audience

Depending on how it will be viewed, you can set up your slideshow to play in different ways:

- **Normal**: Advances when the presenter clicks the mouse or uses one of the presentation keyboard shortcuts. Slideshows work this way unless you specify otherwise.
- **Hyperlinks only**: Changes slides only when the presenter (or viewer) clicks a hyperlink.
- **Self-playing**: Advances automatically, like a movie. No user interaction is possible. Self-playing presentations are useful, for example, in a kiosk setting.
- **Recorded**: Plays like a movie using your prerecorded narration and timing. Viewers can pause the presentation. See “Adding Narration” on page 97.

For information about other options, such as making a slideshow play or repeat automatically, see “Setting Playback Options” on page 165.
Creating Hyperlinks-Only Presentations
Using hyperlinks, you can create controls for navigating through a slideshow. The iWork Tour is an example of a hyperlinks-only presentation. (To open the tour, choose Help > iWork Tour.)

To make a hyperlinks-only presentation:
1 Set up your slideshow using hyperlinks to navigate to particular slides.
   For more information, see “Linking to a Slide” on page 63.
2 In the Document pane of the Document Inspector, choose “Hyperlinks only” from the Presentation pop-up menu.

During a hyperlinks-only presentation, the pointer appears only on slides with hyperlinks. To make the pointer appear when the mouse moves instead, choose Keynote > Preferences, click Slideshow, and then select “Show pointer when the mouse moves.”

Creating Self-Playing Presentations
If you want your presentation to run by itself—at a kiosk, for example—you can make it a self-playing presentation.

In a self-playing presentation, transitions or builds set to begin automatically occur just as they do during a normal presentation. Transitions and builds set to begin on click also happen automatically, after the amount of time specified in the Delay fields in the Document Inspector. The values you specify in the Delay fields apply to all transitions and builds set to begin on click.

Although viewers can't interact with these kinds of presentations, self-playing presentations can be stopped in the same way as other presentations (for example, by pressing the Escape key). To prevent users from stopping a self-playing presentation, don't provide a keyboard, or require a password to exit the presentation.
To make a slideshow self-playing:
1 If the Document Inspector isn't open, click the Inspector button in the toolbar and then click the Document Inspector button.
2 Click Document.
3 Choose Self-playing from the Presentation pop-up menu.
4 To specify how much time to wait until transitions that start on click begin playing, type a value in the Transitions field (or click the arrows).
5 To specify how much time to wait until builds that start on click begin, type a value in the Builds field (or click the arrows).
6 To set other options, including setting a password, use the Slideshow Settings checkboxes.
   See the next topic for details.

**Setting Playback Options**
You can start a slideshow automatically when it’s opened, make a presentation play repeatedly, and more.

To change playback options:
1 If the Document Inspector isn't open, click Inspector in the toolbar and then click the Document Inspector button.
2 In the Document pane, select one or more options below Slideshow Settings:
   * **Automatically play upon open**: The presentation starts as soon as the Keynote document opens.
   * **Loop slideshow**: After the last slide, the presentation starts again with the first slide.
   * **Restart show if idle**: If no user interaction occurs for the specified number of minutes, the slideshow begins again.
   * **Require password to exit show**: To quit the presentation, viewers must provide a computer administrator’s name and password.
Rehearsing and Viewing Presentations

Full-screen presentations make the most of the crisp graphics and smooth animations possible with Keynote. You can show full-screen presentations on your computer’s display, on a second display, or projected onto a large screen, and you can play movies and sound during the presentation.

Adding Presenter Notes

Use the presenter notes field to type or view notes for each slide. You can print presenter notes or view them on an alternate display that only you see while you give your presentation. (Presenter notes are different from comments; see “Using Comments” on page 33.)

Here are ways to work with presenter notes:

- To view presenter notes, click View in the toolbar and choose Show Presenter Notes.
- To add presenter notes, type in the area below the slide canvas.
- To print presenter notes, choose File > Print, choose Keynote from the Copies & Pages pop-up menu, and select Slides With Notes.
- To hide presenter notes, choose View > Hide Presenter Notes.

Rehearsing Your Presentation

Using rehearsal view, you can see presenter information—without requiring a second display—so that you can practice and fine-tune the timing of your presentation.

In rehearsal view you can display the current slide, the next slide, and other items selected in Presenter Display preferences (see “Customizing the Presenter’s View” on page 170). Comments are visible if they were not hidden when you entered rehearsal view.

To rehearse your slideshow:

- Choose View > Rehearse Slideshow.

To quit rehearsal view, press Esc. To scroll presenter notes up or down, press the U or D key.
Viewing a Presentation on Your Computer’s Display

The simplest way to view a slideshow is by watching it directly on your computer’s display. This format works best for a very small audience.

To view a full-screen presentation on a single display:
1. Open the Keynote document and select the slide you want to play first.
2. Do one of the following:
   - If the presentation wasn’t recorded, click Play in the toolbar. To advance to the next slide or object build, click the mouse or press the Right Arrow or Space bar. To end the show, press Esc or Q.
   - If the presentation was recorded, click Play in the toolbar or choose View > Play Recorded Slideshow. To pause both the show and the audio, type H. To resume, click the Keynote icon in the Dock. To stop playback, press the Esc key.

For more options, see “Controlling a Presentation with the Keyboard” on page 173.

Viewing a Presentation on an External Display or Projector

Seeing your slideshow and presenter information (notes and a clock, for example) on one screen, while viewers see only the slideshow on a different screen, is called a dual display configuration.

You can’t use a dual display configuration on some notebook computers; you have to play the identical slideshow on both screens (called video mirroring). If you have less than 32 MB of video random access memory (VRAM) on your computer, you may have to use video mirroring to display your slideshow on an external projector. See “Configuring Video Random Access Memory (VRAM)” on page 172 and “Tips for Using an External Display” on page 168 for more information.

To view a presentation using dual displays:
1. Connect the second display or projector according to the instructions that came with the display or projector and the instructions that came with your computer. See “Tips for Using an External Display” on page 168 for some setup recommendations.
2. Choose Apple menu > System Preferences, and then click Displays.
3. Click Arrange and follow the onscreen instructions.
   - If there is no Arrange button, your computer detects only one display.
4. Make sure Mirror Displays is not selected.
5 Choose Keynote > Preferences and then click Slideshow.

6 Select “Present on primary display” or “Present on secondary display.”

The primary display is the one with the menu bar. If you choose “Present on secondary display,” you can customize what the presenter sees on the primary display. See “Customizing the Presenter’s View” on page 170.

7 Click Play in the toolbar.

8 Advance through the presentation by clicking the mouse or pressing the Space bar. See “Controlling a Presentation with the Keyboard” on page 173 for other options.

Tips for Using an External Display
You can play your Keynote slideshow on various kinds of projectors and external displays.

Here are ways to get the best video quality in your presentation:

- If you have a choice between a DVI connector and a VGA connector, use a DVI connector to connect the projector. DVI connections generally result in the best image quality and are easier to set up.

- Set the preferred screen resolution (the size of the image on the screen) in the Displays pane of System Preferences. Look for this information in the documentation that came with the display. For most projectors, the preferred screen resolution is 800 x 600 or 1024 x 768. Most liquid-crystal display (LCD) and Digital Light Processing (DLP) displays work with a variety of resolutions, but one is the preferred setting.
- Set the screen refresh rate (the number of times per second that images are updated on your screen) in the Displays pane of System Preferences. If you use an LCD display, LCD projector, or DLP projector, try to match the refresh rate of your computer or video card with the optimal refresh rate of the display device. (Usually this is an issue only if you are using a VGA-style connection to an LCD or DLP display. CRT devices do not typically have one optimal refresh rate.)

To change your computer’s screen refresh rate, choose Apple menu > System Preferences, click Displays, click Display, and then try different options from the Refresh Rate pop-up menu.

- If the colors on your display seem “washed out” when you connect to a new projector or if the text appears jagged, you may need to calibrate your display. Open ColorSync Utility (in Applications/Utilities) to set up color calibration.

**Viewing the Same Presentation on Two Screens**

Using video mirroring, you can play the same slideshow on two displays or projectors. You might want to use video mirroring when presenting to a very large audience.

Video mirroring doesn’t enable you to view presenter information on another display. To do so, see “Viewing a Presentation on an External Display or Projector” on page 167.

Some computers have video mirroring built in. If yours does not, you must configure it in the Displays pane of System Preferences. Some notebook models don’t support video mirroring.

**To view a presentation using video mirroring:**

1. Attach the second display or projector according to the instructions that came with the display or projector and the instructions that came with your computer.

   See “Tips for Using an External Display” on page 168 for setup recommendations.

2. Choose Apple menu > System Preferences, and then click Displays.

3. Choose a resolution and number of colors.

   Use the same settings for both displays.

4. Click Arrange and select Mirror Displays.

5. Open the Keynote document and click Play in the toolbar (or choose View > Play Slideshow).

   To advance to the next slide or object build, press the Space bar or click the mouse.
Keynote generally plays back very smooth animations. However, if the two displays have different refresh rates, one of the screens may appear to “stutter” because Keynote synchronizes with the refresh rate of only one display. If you’re using Keynote on an iBook, PowerBook, MacBook, or MacBook Pro with Mac OS X version 10.3.9 or later, Keynote synchronizes with the external display. If you are using a desktop computer and two displays, experiment to determine which display is synchronized with Keynote. See “Setting the Screen Refresh Rate” on page 171 for more information.

**Customizing the Presenter’s View**

If you have a dual-display configuration (one display for the presenter and another for the audience), or if you want to rehearse using a single display (see “Rehearsing Your Presentation” on page 166), you can view presenter information such as a clock and a timer. You can use these options for all presentations except self-playing presentations.

![Presenter Display Preferences](image)

Select to view presenter information on an alternate display (during a slideshow with a dual-display setup).

Select to make the menu bar red when a build is in progress and green when the build is complete.

Select the options that appear on the presenter’s display.

Click to rearrange the windows on the presenter’s display.

**To customize the presenter’s view:**

1. Choose Keynote > Preferences, and then click Presenter Display.
2. Select “Use alternate display to view presenter information.”
3. Select the items you want to appear on the presenter’s display.

   When the “Ready to Advance indicator” checkbox is selected, the menu bar turns red while an object build is in progress, to warn you not to move to the next slide. The menu bar turns green when the build is complete.

4. To rearrange the items on the presenter display, click Edit Presenter Layout.

   Comments are visible in the presenter’s view if they haven’t been hidden (see “Using Comments” on page 33).
Setting the Screen Refresh Rate
If you use video mirroring (show the same presentation on two displays) and see artifacts such as tearing and choppiness during animations, it may help to change the external display’s screen refresh rate.

To get the best animation quality, use the external display’s preferred screen refresh rate. You can probably find this information in the display’s documentation. If not, try different refresh rates to see which results in the best animation quality. Most LCD displays have an internal refresh rate of 60 Hz. Most CRT devices don’t have one optimal refresh rate.

To change the screen refresh rate:
1. Choose Apple menu > System Preferences, and then click Displays.
2. Choose Display and then choose an option from the Refresh Rate pop-up menu.

Setting the Slide Size
For highest-quality playback, your slide size should match the screen resolution of the display on which the slideshow will appear. Most projectors work best with slides at 800 x 600. Newer projectors may display slides at a resolution of 1024 x 768 or higher.

If your presentation includes movies, you might want to use a higher resolution. In this case, choose a high-density (HD) theme with a resolution of 1920 x 1080 (not all themes offer the higher resolution). Higher resolution requires more memory and a faster processor.

You can change the slide size of a Keynote document in the Document pane of the Document Inspector. If you’re not sure of the best slide size or you don’t want to change the original slide size in your document, Keynote plays the slideshow at its original size, centered on your display and surrounded by a black border. If a slide is too large to fit the display, Keynote automatically scales it down to fit the screen.

You can also have Keynote scale the slideshow up to fit your screen when the slideshow plays.

To scale a slideshow up during playback:
1. Choose Keynote > Preferences.
2. Click Slideshow.
3. Select “Scale slides up to fit display.”
   This option does not actually change the slide size of your Keynote document; it scales the document to fit the display. Some video quality may be lost during playback with this option.
4 If you use the Cube or Flip transition, make sure to select “Reduce Flip transitions to avoid clipping” or “Reduce Cube transitions to avoid clipping.” Otherwise, part of the transition may not be visible.

**Configuring Video Random Access Memory (VRAM)**
Make sure your computer has adequate VRAM so that transition animations and complex object builds play correctly. VRAM is a special area of memory on your computer’s video card.

Keynote requires a minimum of 8 MB of VRAM to play transitions. For more complex animations, such as some object builds, a minimum of 32 MB of VRAM is recommended.

You can find out how much VRAM you have by using Apple System Profiler, located in Applications/Utilities. Open Apple System Profiler, click PCI/AGP Cards, and click the disclosure triangle next to your video card. If your computer has fewer than 32 MB of VRAM and your slideshow plays poorly, there are several things you can try.

Here are ways to compensate for inadequate VRAM:

- Turn on video mirroring (see “Tips for Using an External Display” on page 168). This setup uses less VRAM and may be required for playback at higher resolutions. (When you use video mirroring, one of the two displays may show choppiness or “tearing” in the video playback. See “Setting the Screen Refresh Rate” on page 171 for more information.)

- Set your displays to lower resolutions in the Displays pane of System Preferences. Lower screen resolutions use less VRAM.

- Set your displays to use fewer colors in the Displays pane of System Preferences. Using Thousands instead of Millions uses less VRAM.

Even with 32 MB or more of VRAM, you may still see choppiness at very high screen resolutions when building large objects with several parts (for example, if you build a full-screen chart at a screen resolution of 1280 x 1024).

**Controlling Presentations**
If your presentation isn't self-playing, you can use the keyboard to pause and resume slideshows and to navigate among slides. And you can set up the presenter's display to show the next slide, elapsed time, and more.

If your Mac came with an Apple Remote, you can use it to control a presentation. For more information, see Mac Help or the documentation that came with your computer.
Controlling a Presentation with the Keyboard
For slideshows that aren't self-playing, you can use the keyboard to pause, resume, and stop a presentation, go to specific slides, and more.

Here are ways to view keyboard shortcuts:
- During a presentation, to see which keys you can use to control the slideshow, press the Help, question mark (?), or forward slash (/) key.
- To see a complete list of all Keynote keyboard shortcuts, choose Help > Keyboard Shortcuts.

Pausing and Resuming a Presentation
You can pause a presentation and display the current slide, a black screen, and more.

Here are ways to pause and resume a presentation:
- To pause the presentation and display the current slide (freeze), press F. To resume the presentation, press any key.
- To pause the presentation and display a black screen, press B. To resume the presentation, press any key.
- To pause the presentation and display a white screen, press W. To resume the presentation, press any key.
- To pause the presentation and show the last application used, press H. To resume the presentation, click the Keynote icon in the Dock.
- Click a hyperlink that opens a webpage, email message, or file. To resume the presentation, click the Keynote icon in the Dock.

Stopping a Presentation
You can use several keys to end a presentation.

To stop a presentation:
- If the presentation isn't recorded, press Escape, Q, Command-. (period), or . (period).
- If the presentation is recorded, press Escape.

Advancing to the Next or Previous Build or Slide
There are several techniques for navigating to next and previous builds and slides during a presentation that isn't recorded.

Here are ways to navigate to builds and slides:
- To advance to the next build, click the mouse button or press N, Space bar, Return, Right Arrow, Down Arrow, Shift–Right Arrow, or Page Down.
- To go back to the previous build, press Shift–Left Arrow, Shift–Page Up, or [ (left bracket).
To advance to the next slide, press Shift–Down Arrow, Shift–Page Down, or ] (right bracket).

To go back to the previous slide, press Left Arrow, Up Arrow, P, Delete, Page Up, or Shift–Up Arrow.

**Jumping to a Specific Slide**
During a presentation that isn’t recorded, you can easily jump to a particular slide.

**Here are ways to go to a specific slide during a presentation:**
- If you know the number of the slide you want to jump to, type the number and press Return or Enter.
- To browse for a particular slide, use the slide switcher.
  To open the slide switcher, press the plus sign (+), equal sign (=), or hyphen (-), or type a number.

To move forward or backward through the thumbnails, press the Right or Left Arrow key, or click the arrows in the slide switcher to jump three slides.

To see the thumbnail for the first slide, press the Up Arrow key; to see the thumbnail for the last slide, press the Down Arrow key.

To show a particular slide, click its thumbnail, or type the slide number and press Return.

To close the slide switcher without changing the current slide, press Escape.

You can also go to a particular slide using a hyperlink, as described in “Linking to a Slide” on page 63.

You can’t jump to a skipped slide (see “Skipping Slides” on page 32).
Showing the Pointer During a Presentation

You can set up your slideshow so that the pointer appears only on slides containing hyperlinks or movies, or only when the mouse moves.

To specify pointer options:
1. Choose Keynote > Preferences, and then click Slideshow.
2. Select “Show pointer only on slides with hyperlinks or movies” or “Show pointer when the mouse moves.”

During a slideshow, you can show or hide the pointer by pressing the C key.

Using Other Applications During a Presentation

To use Exposé, Dashboard, or other applications (such as Remote Desktop) while you’re playing a slideshow, you need to set a Keynote preference. Choose Keynote > Preferences, click Slideshow, and select “Allow Exposé, Dashboard, and others to use screen.” Selecting this option may cause your slideshow to run more slowly and animations to display poorly.

Older versions of Keyspan Remote software are not configured to work with Keynote, but you can configure Keyspan Remote yourself.

To configure Keyspan Remote to work with Keynote:
1. Open the KeySpanDMR application (located in the Applications folder on your hard disk).
2. Click Configure at the bottom of the window.
3. Choose KeySpanDMR > Add Application.
4. Locate Keynote in the Choose dialog, and then click Choose.

Playing Movies and Sound

If your slideshow includes movies or sound, you can save these media files as part of your slideshow. Saving media files with a slideshow enables you to move the slideshow to a different computer without having to transfer the media files separately.

To save media files with a slideshow:
1. Choose File > Save As.
2. If you don’t see Advanced Options at the bottom of the Save dialog, click the disclosure triangle to the right of the Save As field.
3. Click the disclosure triangle to the left of Advanced Options.
4 Make sure “Copy audio and movies into document” is selected and click Save.

When a movie plays during a presentation, movie controls appear when you move the pointer over the movie if “Show playback controls when pointer is over a movie” is selected in the Slideshow pane of Keynote preferences. The controls available depend on the size (dimensions) of the movie; the smaller the movie, the fewer controls visible.

You can also use the keyboard to control movie playback:
• To pause or resume playback, press K.
• To rewind when playback is paused, press J.
• To go forward when playback is paused, press L.
• To jump to the beginning of the movie, press I.
• To jump to the end of the movie, press O.

You can set the playback volume for sound and movies and specify whether to play media files once, continuously, or forward and backward (Loop Back and Forth). For instructions, see “Setting Playback Options” on page 165.

Printing Your Slides
You can print your Keynote slideshow in a variety of ways to meet different needs. You can print slides with or without notes or comments, or you can print the slideshow in outline or handout format.

To print slides:
1 To print comments, make sure comments are visible on the slide canvas (click View in the toolbar and choose Show Comments).
2 Choose File > Print.
3 To print one slide or a range of slides, use the From and To text fields to enter the slide number or range.

You can see slide numbers in the slide navigator.
4 To specify Keynote print options, choose Keynote from the Copies & Pages pop-up menu.

5 Select a Print option:

*Individual Slides*: Prints one slide per page without presenter notes.

*Slides With Notes*: Prints one slide per page with presenter notes.

*Outline*: Prints only the slide titles and bulleted text (what you see in outline view in the slide navigator). Text in free text boxes doesn’t print.

*Handout*: Provides options for putting more than one slide on a page. To speed up the printing of handouts, select “Draft-quality printout.”

6 Select print formatting options:

*Don’t print slide backgrounds or object fills*: Background color or objects don’t print; light text prints as black. This option is especially useful for printing colorful slides on black-and-white printers. On black-and-white printers, color images print in grayscale. On color printers, imported graphics files on each slide still print in color.

*Print each stage of builds*: Prints one slide image for each stage of an object build. (A slide with a three-stage object build prints as three slides.)

*Include skipped slides*: Prints all the slides in the slide navigator, even if some are marked as skipped.

*Add borders around slides*: Prints a line around the edges of each slide.

*Include slide numbers*: Prints the number at the bottom of each slide.

*Include date*: Prints the date on each slide.

*Print high resolution 3D Charts*: Enhances print quality for 3D charts.

7 Click Print.
Exporting a Slideshow to Other Formats
You can share your presentation across different platforms by exporting it to another format, such as QuickTime, PowerPoint, and PDF. You can also send your slideshow directly to iDVD, iPhoto, iTunes, iWeb, and GarageBand. And you can turn your slideshow into a movie you can watch on your iPod.

Sharing a Presentation Across Platforms
Export your presentation to formats that are compatible on different platforms.

Creating a QuickTime Movie
You can turn your slideshow into a QuickTime movie that includes all animated transitions and object builds.

You can create an interactive movie that viewers can advance at their own pace, or you can create a self-playing movie, with transitions and builds timed just as you set them.

To create a QuickTime movie of your slideshow:
1. Choose File > Export and then click QuickTime.

2. Choose an option from the Playback Uses pop-up menu:
   - **Manual Advance**: Viewers advance through the slideshow by clicking the mouse or Play (in the QuickTime controls), or by pressing the Space bar on the keyboard.
   - **Hyperlinks Only**: Viewers advance through the slideshow by clicking hyperlinks.
   - **Recorded Timing**: If you recorded your slideshow (as described in “Adding Narration” on page 97), your slideshow movie plays using the timing you recorded.
   - **Fixed Timing**: Viewers can't control how the slideshow advances; the slideshow plays using the timing you specify in the next step.
3 If you choose Fixed Timing, specify how long slides appear and how long it takes to complete object builds by typing values in the Slide Duration and Build Duration fields.

*Slide Duration:* How long each fully built slide remains on the screen after the last object build is complete.

*Build Duration:* The number of seconds between the beginning of one build stage and the next in each object build. There is no delay between the moment a slide first appears on the screen and the first stage of an object build.

4 If you choose Fixed Timing, you can choose an option from the Repeat pop-up menu:

- *None:* The slideshow plays only once.
- *Loop:* The slideshow plays continuously.
- *Back and Forth:* The slideshow plays through forward, then backward to the beginning, and so on.

5 To make the slideshow appear on the whole screen rather than in a window, select “Enter full screen mode when opened.”

6 Choose a playback quality and file size from the Formats pop-up menu:

- *Full Quality, Large:* Preserves the best playback quality, but these movies are large and are therefore more difficult to transfer through email or the web.
- *CD-ROM Movie, Medium:* Best if you are using a CD to send the slideshow to another viewer. These movies are high in quality but have somewhat smaller file sizes than full-quality movies.
- *Web Movie, Small:* Movies generally have poorer playback quality but are small enough to be shared across the web or through email.
- *Custom:* Choose your own QuickTime compression settings for video and audio so that you can control the tradeoff between file size and quality.

7 To include the slideshow soundtrack or the recorded audio, select the Audio checkbox.

8 If your slideshow has a transparent background you want to preserve in your QuickTime movie, select “Include transparency.” Some transitions might not work correctly with this option selected.

9 Click Next, type a name for your movie, choose a location in which to store it, and click Export.

If the slideshow includes a soundtrack, two movie files are created. The file with “soundtrack” appended contains only the audio and can be discarded.
When you export a self-playing slideshow as a QuickTime movie, note the following:

- If the slideshow includes a soundtrack, the movie won’t end until the audio finishes.
  If your slideshow is a lot shorter than the audio, you might want to use a shorter audio file.
- If the slideshow contains an Exit Slideshow link, clicking it makes the movie exit full-screen mode.

**Creating a PowerPoint Slideshow**

You can convert Keynote documents to PowerPoint files that can be viewed and edited by PowerPoint users on Windows or Mac OS computers.

**To create a PowerPoint slideshow:**

1. Choose File > Export and then click PowerPoint.
2. Click Next.
3. Type a name and choose a location for the file, and then click Export.

PowerPoint doesn’t support some Keynote features:

- Some bulleted text items may be lost. If you hide the bulleted text on a slide (by deselecting Body in the Slide Inspector), it is deleted from the outline when you export.
- PowerPoint doesn’t support alpha-channel graphics, so if you use a photo cutout frame, the image behind it will appear in front. You may also notice slight variations in other graphics.

**Creating a PDF File**

Your slideshow can be converted to a PDF file, which can be viewed or printed using Adobe Acrobat Reader or any PDF application.

If your slideshow contains hyperlinks, they are exported as active links in the PDF document.

**Here are ways to create a PDF file:**

- To create a PDF file that will be viewed only onscreen (not as a printed hardcopy), choose File > Export and then click PDF. Select your options (for more information, see “Printing Your Slides” on page 176), click Next, type a name and choose a location for the file, and then click Export.
  You can print PDF documents created using this method, but you might get better results using the following method.
- To create a PDF file that will be printed, choose File > Print, choose “Save as PDF” from the PDF pop-up menu, and click Print. In the Save dialog, type a name, choose a location for the file, and then click Save.
Exporting Slides as Image Files
You can export all your slides as image files in JPEG, PNG, or TIFF format.

To export slides as image files:
1. Choose File > Export and then click Images.
2. Specify whether to create a file for every slide or only a range of slides.
3. To create a separate image for each build stage, select “Create an image for each stage of builds.”
4. Choose an option from the Format pop-up menu.
   The better the quality, the larger the file size.
5. If you choose JPEG format, use the Quality controls to specify a percentage between low and high quality.
6. Click Next.
7. Type a filename, choose a location for the files, and then click Export.
   Each file is named filename.001, filename.002, and so on.
   You can also send individual image files to iPhoto, as described in “Creating an iPhoto Album” on page 183.

Creating a Flash Document
You can turn your slideshow into a Flash movie that can be viewed with the Flash viewer.

To convert your slideshow to a Flash document:
1. Choose File > Export and then click Flash.
2. To include the slideshow soundtrack or the recorded audio, select the Audio checkbox.
3. Click Next.
4. Type a filename, choose a location for the file, and click Export.

Creating an HTML Document
You can turn your slideshow into an HTML document that can be viewed with Safari or another web browser. Viewers click hyperlinks to advance the presentation.

To export slides to an HTML document:
1. Choose File > Export and click HTML.
2. Specify whether to export all slides or only a range of slides.
3. To create a separate image for each build stage, select “Create an image for each stage of builds.”
To have a Home, Previous, and Next link added to each slide (as appropriate), select “Include navigation controls.”

Choose an option from the Format pop-up menu to specify the image quality you want. The better the quality, the larger the file size.

If you choose JPEG format, use the Quality controls to increase or decrease the compression factor used for the export.

Click Next, type a filename, specify a location for the file, and then click Export.

**Publishing to YouTube**

You can send your slideshow directly to the YouTube website, where visitors can watch your presentation as a movie. To publish to YouTube, you must be connected to the Internet.

**To publish your slideshow to YouTube:**

1. Choose File > Send To > YouTube.
2. Choose your account from the Account pop-up menu.
   
   If you don't have a YouTube account, you can set one up by clicking Add.
3. Choose a category from the Category pop-up menu.
4. In the Title field, type a name for your movie, and in the Description field, give your movie a short description that viewers can read.
5. In the Tags field, you can type keywords to help people find your movie if they search for it on the YouTube website.
6. Choose a movie size from the “Size to Publish” pop-up menu.
7. If you don't want your movie to be seen by anyone but you or by viewers on lists you've created, select “Private video.”
8. Click Next, and then click Publish to accept the terms of service offered by YouTube. Your movie is uploaded to the YouTube website.
9. In the dialog that appears, click Go To Website to visit your movie on the YouTube website.
10. To create an email containing your movie's URL, click “Tell a friend.”
Sending a Presentation to iLife Applications
Send a presentation directly to iDVD, iPhoto, iTunes, iWeb, and GarageBand.

Creating an iDVD Project
You can create an iDVD project or add your slideshow as a movie to an existing iDVD project.

To create an iDVD movie of your slideshow:
1 Choose File > Send To > iDVD.
2 Choose an option from the Video Size pop-up menu:
   - Standard: Exports the slides for viewing on a standard video display.
   - Widescreen: Exports the slides for viewing on a widescreen video display.
3 Choose an option from the Playback Uses pop-up menu:
   - Manual Advance: Viewers advance the movie by clicking the mouse or Right Arrow, or by pressing the Space bar on the keyboard.
   - Recorded Timing: If you recorded your slideshow (as described in “Adding Narration” on page 97), your slideshow movie plays using the timing you recorded.
   - Fixed Timing: Viewers have no control over the speed at which the movie advances; the movie plays using the timing you specify in the next step.
4 If you choose Fixed Timing, specify how long slides appear and the how long it takes to complete object builds by typing values in the Slide Duration and Build Duration fields.
   - Slide Duration: How long each fully built slide remains on the screen after the last object build is complete.
   - Build Duration: The number of seconds between the beginning of one build stage and the next in each object build. There is no delay between the moment a slide first appears on the screen and the first stage of an object build.
5 To include the slideshow soundtrack or the recorded audio, select the Audio checkboxes.
6 Click Send, type a filename, specify a location (if you don’t want to store the movie in your Movies folder), and then click Export.

Creating an iPhoto Album
You can turn your slideshow into an iPhoto album, with each slide a separate image file.

To create an iPhoto album of a slideshow:
1 Choose File > Send To > iPhoto.
2 Specify whether to create a file for every slide or only a range of slides.
3 To create a separate image for each build stage, select “Create an image for each stage of builds.”

4 Choose an option from the Format pop-up menu.
   The better the quality, the larger the file size.

5 If you choose JPEG format, use the Quality controls to specify a percentage between low and high quality.

6 Click Next, type a name for your album, and click Send.
   If iPhoto was not already open, it opens; your new album appears at the bottom of the list.

**Exporting to iWeb**
If you use (or intend to use) iWeb to create a website, you can send your slideshow to iWeb so that your website visitors can download and view it as a PDF file, a Keynote document, or a video podcast. Your slideshow is added as a blog or podcast entry.

**To send your slideshow to iWeb:**
1 Make sure you have iWeb '08 or later installed.

2 In Keynote, choose File > Send To > iWeb.

3 Choose an option from the File Type pop-up menu:
   - **PDF:** You can choose many of the options described in “Printing Your Slides” on page 176.
   - **Keynote document:** Website visitors will need Keynote to view your slideshow.
   - **Video podcast:** Creates a self-playing movie.

4 If you choose Video Podcast, choose an option from the Playback Uses pop-up menu:
   - **Recorded Timing:** If you recorded your slideshow (as described in “Adding Narration” on page 97), your slideshow movie plays using the timing you recorded.
   - **Fixed Timing:** Viewers can’t control when the movie advances; the movie plays using the timing you specify in the next step.

5 If you choose Fixed Timing, type values in the duration fields:
   - **Slide Duration:** How long each fully built slide remains on the screen after the last object build is complete.
   - **Build Duration:** The number of seconds between the beginning of one build stage and the next in each object build. There is no delay between the moment a slide first appears on the screen and the first stage of an object build.

6 To include the slideshow soundtrack or the recorded audio, select the Audio checkbox.
Click Send.

If iWeb wasn’t open, it opens, and you can choose the blog or podcast to attach your slideshow to. (If you have only one blog or podcast, the document is attached to it.)

**Exporting to iTunes and iPod**

You can turn your slideshow into a movie you can play in iTunes. If you have an iPod, you can use iTunes to transfer the movie to it.

**To send your slideshow to iTunes or iPod:**

1. In Keynote, do one of the following:
   - Choose File > Send To > iTunes.
   - Choose File > Export and then click iPod.

2. Choose an option from the Playback Uses pop-up menu.
   - **Recorded Timing:** If you recorded your slideshow (as described in “Adding Narration” on page 97), your slideshow movie plays using the timing you recorded.
   - **Fixed Timing:** Viewers can’t control when the movie advances; the movie plays using the timing you specify in the next step.

3. If you choose Fixed Timing, type values in the duration fields:
   - **Slide Duration:** How long each fully built slide remains on the screen after the last object build is complete.
   - **Build Duration:** The number of seconds between the beginning of one build stage and the next in each object build. There is no delay between the moment a slide first appears on the screen and the first stage of an object build.

4. To include the slideshow soundtrack or the recorded audio, select the Audio checkbox.

5. Click Send.

6. Type a title and choose a location for your slideshow, and click Export.

   If iTunes wasn’t open, it opens. Your slideshow is imported as a movie. For information about transferring the movie to your iPod, see iTunes Help.

**Exporting to GarageBand**

You can turn your slideshow into a video podcast with sophisticated audio effects by exporting to GarageBand.

**To send your slideshow to GarageBand:**

1. In Keynote, choose File > Send To > GarageBand.

2. Choose an option from the Timing pop-up menu:
   - **Recorded Timing:** If you recorded your slideshow (as described in “Adding Narration” on page 97), your slideshow movie plays using the timing you recorded.
Fixed Timing: Viewers can't control when the movie advances; the movie plays using the timing you specify in the next step.

3 If you choose Fixed Timing, type values in the duration fields:

Slide Duration: How long each fully built slide remains on the screen after the last object build is complete.

Build Duration: The number of seconds between the beginning of one build stage and the next in each object build. There is no delay between the moment a slide first appears on the screen and the first stage of an object build.

4 To include the slideshow soundtrack or the recorded audio, select the Audio checkbox.

5 Click Send.

6 Type a title and choose a location for your slideshow, and click Export.

If GarageBand wasn't open, it opens. Your slideshow is imported as a movie.

Saving a Presentation in iWork '05 or iWork '06 Format
If others will be opening your slideshow using an older version of Keynote, you can export the slideshow to iWork '05 or iWork '06 format. New features included in iWork '08, such as Smart Builds and slideshow recording, might not be converted when the presentation is opened with an earlier version. Other elements, such as audio and movie files, will work the same.

To save a presentation so that it can be opened in iWork '05 or iWork '06:

1 Open the slideshow you want to export.

2 Choose File > Save As.

3 Type a name for the file and select a location.

4 Select “Save a copy as” and choose iWork '05 or iWork '06.

If you don't see these options, click the disclosure triangle to the right of the Save As field.

5 If you don't want to include audio and movie files in the export, click Advanced Options, and then deselect “Copy audio and movies into document” (this option is on by default).

6 Click Save.
This chapter describes how to change the default attributes of images, objects, and more, and how to create your own master slides and themes.

This chapter assumes you are already familiar with the Keynote design and formatting features described in previous chapters.

Designing Master Slides and Themes
The themes that come with Keynote are sets of master slides with predefined layouts, backgrounds, charts, tables, and text attributes. You can modify these attributes to create your own masters and themes. When you change a master slide, the changes appear on every slide in the document that’s based on that master.

You can create a new theme by:
• Modifying master slides and saving the document as a new theme.
• Deleting all master slides except the blank one, creating a collection of master slides from scratch, and then saving the document as a new theme.

You can customize the following master slide attributes:
• Default position of title and body text
• Background graphics
• Default fonts
• Default bullet styles
• Default position for objects (object placeholders)
• Object fills and line styles for objects
• Chart style
• Slide transition style
• Alignment guide positions
Using Master Slide Tools
Use the master slide navigator and the Master Slide Inspector to work with master slides.

To use the master slide tools:
1. Open the master slide navigator by clicking View in the toolbar and choosing Show Master Slides.
2. In the master slide navigator, select a master slide.
   See “Selecting Master Slides to Customize” on page 190 for more information on selecting master slides.
3. Click Inspector in the toolbar, and then click the Slide Inspector button.
4. To modify layout and background attributes, click Appearance.
   See “Customizing Master Slide Layouts” on page 191 for more information.
5. To add or modify transitions between master slides, click Transition.
Chapter 10  Designing Your Own Master Slides and Themes

See “Defining Default Transitions” on page 196 for more information.

To test a master slide:

1. Select a slide in the slide navigator, and then click New in the toolbar or press Return.
2. Apply the layout of the master slide you want to test by clicking Masters in the toolbar and then selecting the master slide.
3. Add text and objects to the new slide, returning to the master slide to make adjustments as required.
4. If you make changes to the slide that override master slide settings (such as changing the slide background), and you want the test slide to return to the master slide settings, select the test slide and choose Format > “Reapply Master to Slide.”
Selecting Master Slides to Customize
The easiest way to design a new master slide is to start with an existing master—in the current document or imported from another document—that resembles what you want. Or you can create a master slide from scratch, starting with a blank slide.

Duplicating a Master Slide
Before you modify a master slide, you might want to duplicate it so that you can continue using the original version in your document.

To duplicate a master slide:
1. Click View in the toolbar and choose Show Master Slides.
2. In the master slide navigator, select the master slide you want to duplicate.
3. Do one of the following:
   - Click New in the toolbar.
   - Choose Slide > New Master Slide.
   - Press Return.
   - Choose Edit > Duplicate.
4. In the master slide navigator, double-click the new slide's name and type a new name.

If you make changes to a master slide and then decide you want to return to the theme's default settings, select the slide and choose Format > "Reapply Master to Selection."

Importing a Slide or Master Slide
You can import slides and master slides from other Keynote documents.

To import a slide or master slide:
1. Open the Keynote source document (the one with the slide you want to import), and the current Keynote document (the one you want to import the slide into).
2. Do one of the following:
   - To import a slide, drag it from the slide navigator of the source document to the slide navigator of the current document. The slide and its master are added to the current document. (The master is the last slide in the master slide navigator.)
   - To import a master slide, drag it from the master slide navigator to the master slide navigator of the current document.
Creating a Master Slide from Scratch
If you can’t find a master slide that closely resembles the master you want, you can create one from scratch.

To create a new master slide:
- In the master slide navigator, select a blank slide.
- If the theme you’re using doesn’t have a blank slide, select a master slide, choose Edit > Select All, and then press Delete.

Customizing Master Slide Layouts
Define placeholders for text, media and objects; change a master slide’s background elements; add alignment guides; and more.

Defining Text Placeholders
You can add placeholders for text, and define default attributes for text in them.

To define a text placeholder:
1. In the Master Slide navigator, select a slide (to open the Master Slide navigator, click View in the toolbar and choose Show Master Slides).
2. Open the Master Slide Inspector, and then click Appearance.
3. To add a placeholder title text box, select Title.
4. To add a placeholder body text box, select Body.
   - To control whether text in the text box is bulleted, numbered, or plain by default, use the Bullets pane of the Text Inspector.
5. To add a placeholder free text box, click Text Box in the toolbar. In the Master Slide Inspector, select “Define as Text Placeholder” (or choose Format > Advanced > “Define as Text Placeholder”).
   - You can also add a shape and define it as a text placeholder.
6. Resize and rearrange the text boxes as desired.
7. Select the placeholder text and format it as desired.
   - In a text box, you can define attributes for as many as five levels of text.

Defining Media Placeholders
You can create one or more placeholders on a master slide to hold images, audio files, and movies. When you add one of these items to a slide based on that master, the file automatically goes into the placeholder at the specified position and size.
To define a media placeholder:
1 Select a master slide.
2 Open the Master Slide Inspector, and then click Appearance.
3 Select “Define as Media Placeholder.”
4 (Optional) Type a description in the Tag field.
5 Resize and rearrange the placeholder as desired.
6 (Optional) Add a placeholder image.

Defining Object Placeholders
You can create a placeholder on a master slide to hold tables and charts. When you add one of these items to a slide based on that master, the object automatically goes into the placeholder at the specified position and size.

To define an object placeholder:
1 In the Master Slide navigator, select a slide (to open the Master Slide navigator, click View in the toolbar and choose Show Master Slides).
2 Open the Master Slide Inspector and then click Appearance.
3 Select Object Placeholder.
4 Position and size the placeholder.

Creating Background Elements on Master Slides
You can make an element (such as a company logo or other graphic, text, or color) appear on every slide that's based on a particular master slide.

Using this technique is one way to create groups of related slides within a presentation. You could, for example, incorporate a subtle difference in the background of each group of slides. To do so, you create a set of master slides with each of the different backgrounds.

To modify a master slide background:
1 Select a master slide to work with.
2 Select unwanted elements and then press the Delete key.
3 If you want an object (shape, image, sound or movie file, table, or chart) to be a background element, add it to the master slide and then size and position it on the slide.

After you place an object, you can choose Arrange > Lock to prevent it from being accidentally moved as you work.
4 To allow master objects to interleave with objects added to slides based on that master, open the Master Slide Inspector, click Appearance, and select “Allow objects on slide to layer with master.”

For more information about layering objects, see “Moving an Object Forward or Backward (Layering Objects)” on page 70.

5 To fill the slide background with color or an image, use the Background controls in the Appearance pane of the Master Slide Inspector.

A common use of background layers is for alpha-channel graphics (graphics with transparency); you can add objects to a slide and layer them so that they show through part of the background image.

Adding Alignment Guides to Master Slides
You can create alignment guides to help you place your text and graphics consistently on each slide. Alignment guides created on a master slide are available when you are placing objects on any slides based on that master.

To create alignment guides on a master slide:
1 Select the master slide to which you want to add the alignment guides.
2 Click View in the toolbar, and then choose Show Rulers.
3 Place the pointer on a ruler and drag an alignment guide to wherever you want on the master slide.
   To place a horizontal guide, drag from the ruler at the top of the slide.
   To place a vertical guide, drag from the ruler on the left side.
You can also turn on gridlines that show on master slides and appear dynamically on slides. For more information, see “Using Master Gridlines” on page 72.

Defining Default Attributes of Text and Objects
You can define default attributes for text and objects.

For example, you can set up Keynote so that every time you click Table in the toolbar, the default table is added, formatted with the number of rows and columns, header and body text font, and border colors you’ve predefined.

To change an element’s default attributes, you create the element with the desired attributes, and then define the element for a specific master or for all masters in the theme. If you define the element for one master, the defaults apply to new elements on slides based on that master. If you define the element for all masters, every new element in the document uses the defaults.
Defining Default Attributes of Text Boxes and Shapes
You can define the default attributes of new text boxes and shapes.

To set default attributes for text boxes and shapes:
1 In the slide navigator, create a new slide.
2 If you’re setting up default attributes for a particular master slide (rather than all masters in the current theme), click Masters in the toolbar and choose the master slide.
3 To define a default text box, click Text Box in the toolbar and then format the placeholder text. See “Formatting Text Size and Appearance” on page 40 for more information.
4 Do one of the following:
   - To make the text box the default for only the current master slide, choose Format > Advanced > “Define Text for Current Master.”
   - To make the text box the default for all master slides in the current theme, choose Format > Advanced > “Define Text for All Masters.”
5 To define a default shape, add a shape and then set its attributes. See “Modifying Objects” on page 73 and “Filling an Object with Color” on page 79 for instructions.
6 Do one of the following:
   - To make the shape the default for only the current master slide, choose Format > Advanced > “Define Shape for Current Master.”
   - To make the shape the default for all master slides in the current theme, choose Format > Advanced > “Define Shape for All Masters.”
7 If you don’t want the default object on the slide, delete the object.

Defining Default Attributes of Imported Images
You can set default attributes such as shadow, reflection, opacity, and border (stroke) color, so that any image you add to your slideshow automatically uses the default settings.

To set default image attributes:
1 In the slide navigator, create a new slide.
2 If you’re setting up default attributes for a particular master slide (rather than all masters using the current theme), click Masters in the toolbar and choose the master slide.
3 Place an image on the slide and set its default attributes. For more information, see the following topics:
   - “Importing an Image” on page 89
   - “Adding Shadows” on page 76
   - “Adjusting Opacity” on page 77
4 Do one of the following:

- To make the image the default for only the current master slide, choose Format > Advanced > “Define Image for Current Master.”
- To make the image the default for all master slides in the current theme, choose Format > Advanced > “Define Image for All Masters.”

5 If you don’t want the image on the slide, delete the image.

**Defining Default Attributes of Tables**

You can set up table attributes such as number of rows and columns, line styles and colors, text styles, and shadows.

*Important:* A table has four distinct formatting areas: header row, header column, inside borders, and outside borders. To set default table attributes, you must apply each attribute to an entire formatting area. For example, to set the default formatting of a header row, you need to change the formatting of all the cells in the header row, not just one header cell.

**To set default table attributes:**

1. In the slide navigator, create a new slide.
2. If you’re setting up default attributes for a particular master slide (rather than all the masters in the current theme), click Masters in the toolbar and choose the master slide.
3. Place a table on the slide. “Adding a Table” on page 115 tells you how.
4. Select the table and set its attributes.

- See “Resizing a Table” on page 117 if you want to change the table’s dimensions.
- See “Working with Rows and Columns” on page 128 to learn about adding and removing columns and rows and creating header rows and columns.
- See “Working with Table Cells” on page 131 for information about splitting and merging table cells, resizing them, and formatting their borders.
- See “Formatting Cell Values” on page 123 to learn about options for formatting the display of cell values.
- See “Adding Images or Color to Cells” on page 127 if you want to add graphics to the table.

5 Do one of the following:

- To make the table the default for only the current master slide, choose Format > Advanced > “Define Table for Current Master.”
- To make the table the default for all master slides in the current theme, choose Format > Advanced > “Define Table for All Masters.”

6 If you don’t want the table on the slide, delete the table.
Defining Default Attributes of Charts
You can set the default chart type (the type of chart that appears when you click Chart in the toolbar) and also the default look of each chart type. Default attributes must be set individually for each chart type.

To set default chart styles and placement:
1. In the slide navigator, create a new slide.
2. If you’re setting up default attributes for a particular master slide (rather than all slides in the current theme), click Masters in the toolbar and choose the master slide.
3. Place a chart on the slide. See “Adding a Chart” on page 146 for instructions.
4. Select the chart, and then set its attributes.
   See “Selecting a Chart Type” on page 147 to learn how to change a chart’s type.
   See “Formatting General Chart Attributes” on page 150 to learn how to resize a chart, rotate it, and set other attributes that charts have in common.
   See “Formatting Specific Types of Charts” on page 156 to learn how to format pie charts, bar charts, and other chart types.
5. Repeat steps 3 and 4 for each chart type you want to define a default for.
6. For each chart, select the chart and do one of the following:
   • To make a chart the default for only the current master slide, choose Format > Advanced > “Define chart type for Current Master.”
   • To make a chart the default for all master slides in the current theme, choose Format > Advanced > “Define chart type for All Masters.”
7. To set which type of chart appears when you click Chart in the toolbar, select the chart of that type, and then choose Format > Advanced > “Set chart type as Default for Current Theme.”
8. If you don’t want the charts on the slide, delete them.

Defining Default Transitions
You can specify a default transition style for a master slide so that any slide based on the master automatically uses the specified style to go to the next slide.

To set the default transition style for a master slide:
1. Click View in the toolbar and choose Show Master Slides.
2. In the master slide navigator, select a master slide.
3. In the Transition pane of the Master Slide Inspector, define the transition. For more information, see “Adding Transitions Between Slides” on page 101.
Creating Builds on Master Slides
You can add object builds to a master slide so that the build effects appear on every slide based on that master.

For example, if you plan to create a number of slides with bulleted text, and you want each slide to build in bullet by bullet, create a master slide with the desired build effects, and then use that master to create the rest of your slides.

To create a build on a master slide:
1 Click View in the toolbar and choose Show Master Slides.
2 In the master slide navigator, select a master slide.
3 Define builds using the instructions in “Moving Objects on or off Slides Using Build Effects” on page 103.

Creating Custom Themes
If you modify master slides in a theme and you want to use these modifications again in other slideshows, you can save the modified theme as a custom theme. After you save your custom theme, it appears in the Theme Chooser. When you select your custom theme, it comes with all the master slides you defined.

Saving a Custom Theme
Create a new theme that contains any master slide changes you’ve made to the current theme.

To save the current theme as a custom theme:
1 Choose File > Save Theme.
2 Type a name for your theme.
3 If you added sound or movies that you want to include in the theme, select “Copy audio and movies into theme.” (If you don’t see this checkbox, click the disclosure triangle to the right of the Save As field.)
   Saving media files with a document makes the file much larger.
4 Click Save.

Unless you specify another location, custom themes are saved in the Themes folder on your hard disk ([home]/Library/Application Support/iWork/Keynote/Themes). Only themes in this folder appear in the Theme Chooser. If you store your theme in another location, you can still open it (from the Finder) and use it to create a slideshow.
Creating a Theme from Scratch

If you want to create an entirely new theme that is not based on any existing Keynote theme, the easiest way is to create a new Keynote document and delete all master slides from it except for one blank slide.

To delete a master slide, select it in the master slide navigator and choose Edit > Delete or press the Delete key.

Here are tips for creating the new theme:

- Set up all text and background attributes before creating new master slides.
- On a sample slide, test your text layouts to be sure they work with text longer than a line or two. Consider how many bullets you want to fit in a body text box when you set its size and placement.
- Duplicate the original master slide to create various text layouts. New masters made from copies automatically inherit the original’s text and background attributes. Then you only have to adjust the text box layouts (for example, remove the title text box and expand the body text box for a “body only” master slide).
- Create sample slides in the slide navigator based on each master you design and place free text boxes, shapes, tables, and images on each one, if you want the default object attributes to be different on different master slides. (If you want to set the same default object attributes for all masters, you need to do this for only one master slide.)
- Create a series of sample slides in the slide navigator based on each of your master slides. Design a chart on one slide, and then copy and paste it onto each of the slides. Then convert each chart to a different chart type, and set its size and position. Do this step before you define default chart styles using Format > Advanced.

Restoring Original Theme Attributes

If you modify master slides in a document and later want to return to the original theme defaults, you can reapply the theme to your document or to specific slides.

To restore the theme defaults:

1. If you want to restore defaults to only certain slides, select them in the slide navigator (press Command to select multiple slides).
2. Choose File > Choose Theme.
3. In the Theme Chooser, select the original theme and presentation size.
4. Make sure “Retain changes to theme defaults” is not selected.
5. Choose All Slides or Selected Slides from the Apply Theme To pop-up menu.
6. Click Choose.
Index

3D charts
  defining scene settings 161
  modifying the viewing angle 162

A
  Adjust Image window 93
  alignment guides
    creating new 71
    using 71, 72
  Alpha tool 92
  AppleWorks 27

area and line charts
  adding shadows 160
  formatting symbols 160
  setting line color 160

arrows, predrawn
  adding 82
  editing 86

B
  bar and column charts
    adding shadows 159
    adjusting opacity 160
    adjusting spacing 159
  bulleted text
    adding new 57
    moving in outline view 19
    rearranging and editing 57

C
  Character Palette 47
  characters in other languages 47
  charts
    adding 146
    adding descriptive text 156
    adding labels and axis markings 152
    changing chart type 148
    changing plotting orientation 146
    choosing chart type 147
    editing data 149
    formatting 150, 156
    formatting data series elements 155
    formatting the value axis 153
    formatting titles, labels, and legends 156
    placing grid labels and tick marks 154
    repositioning a legend 150
    resizing 151
    rotating 151
    showing and hiding a legend 150
    showing axes and borders 152
    understanding data series 145
  closing a document 30
  Colors window 24, 80
  comments
    adding 33
    deleting 34
    formatting 34
    printing 34
    resizing 34
    viewing and hiding 34
  conditional formatting 126
  cropping images 90

D
  displays
    optimizing an external display 168
    setting the refresh rate 171
    using a single display 167
    using dual displays 167
    using video mirroring 169
  document
    choosing a template 26
    creating 26
    opening existing 27
  Document Inspector 30
  Draw tool 83

E
  exporting
    as a blog or podcast entry 184
    as a Flash document 181
    as an HTML document 181
as an iDVD project 183
as an iPhoto album 183
as a PDF file 180
as a PowerPoint slideshow 180
as image files 181
to GarageBand 185
to iTunes 185
to YouTube 182

F
Find & Replace dialog 67
Flash 181
Font panel 24
font smoothing 49
Format Bar 22

I
iDVD 183
image formats supported 89
images
  adjusting brightness 93
  adjusting contrast 93
  adjusting exposure 93
  adjusting saturation 93
  adjusting sharpness 93
  adjusting temperature 93
  animating 107
  Auto Levels 94
  automatically adjusting 93
  histogram 94
  placing inside an object 81
  removing color from 92
  scaling 81
  tiling 82
  tinting 82
importing a presentation
  from AppleWorks 27
  from PowerPoint 27
inspectors
  using for formatting 23
  Inspector window 23
  Instant Alpha 92
  iPhoto 183
  iPod 185
  iTunes 185
  iWeb 184

J
JPEG 181

K
keyboard shortcuts
  using 25
  viewing a list of shortcuts in help 25
Keyboard Viewer 46

L
layout
  adding a title box or other elements 36
  applying a background 37
changing 36, 191
previewing for master slides 189
light table view 20
lists
  automatically generating 56
  bulleted 57
  numbered 57
  ordered (outlines) 58
  using 56

M
masking images 90
master slides
  adding alignment guides to 193
  changing 35
  creating background elements on 192
  creating builds on 197
  creating from scratch 191
  defining default chart attributes 196
  defining default image attributes 194
  defining default table attributes 195
  defining default text boxes and shapes 194
  defining default transitions for 196
  defining title and body text on 191
  designing 187
  duplicating 190
  importing 190
  media placeholders on 88
  numbering 33
  placeholder text on 38
  previewing layout 189
  showing 19
  understanding 14
  using 30
  using in custom themes 197
  using tools for 188
Media Browser 24
media files
  adding a movie 96
  adding a soundtrack 95
  adding sound 95
media formats supported 94
media placeholders 88
Metrics Inspector 117, 118, 151, 158
movie and sound file types supported 94
movies
  and display resolution 171
  exporting to QuickTime 178
  missing 27
  playing 175
  saving with slideshow 28
  showing pointer on slides with 175
N
narration 97
navigator view 18
numbers
  currency format 124
  date and time format 125
  fraction format 125
  number format 124
  percentage format 124
  scientific format 126
O
object builds
  activating 110
  creating chart builds 112
  creating movie builds 113
  creating table builds 112
  creating text builds 111
  deleting 113
  interspersing parts of an object 111
  reordering 109
  using 102
  using action builds 105
  using predefined Smart Builds 107
objects
  adding a custom shape 83
  adding a movie file 96
  adding an image 89
  adding a predrawn shape 82
  adding a sound file 95
  adding color and color gradients 79
  adding reflections 77
  adding shadows 76
  adjusting opacity 77
  aligning 70
  changing the border style 74
  changing the stacking order 70
  copying 68
  deleting 69
  duplicating 68
  flipping 74
  grouping and ungrouping 78
  locking and unlocking 79
  modifying 73
  moving 69
  positioning 70
  positioning precisely 72
  resizing 73
  rotating 74
  selecting and deselecting 68
  spacing evenly on a slide 71
  using as hyperlinks 100
operators
Index

arithmetic 140, 141
comparison 142
outline view
  changing fonts 20
  using to organize slides 19

P
PDF files
  creating 180
pie charts
  adding shadows 158
  adjusting opacity 158
  rotating 158
  selecting individual wedges 157
  showing a series name in 157
placeholders 88
PNG 181
polygon shape
  adding 82
  editing 87
PowerPoint 27, 180
Preferences 20, 27, 29, 46, 47, 48, 49, 54, 56, 62, 64,
  69, 71, 72, 73, 90, 97, 102, 164, 167, 168,
  169, 170, 171, 172, 175
presentations
  controlling with the keyboard 173
  created in iWork '05 or iWork '06 186
  customizing the presenter’s view 170
  finding in Spotlight 30
  hyperlinks-only 164
  jumping to a specific slide 174
  pausing and resuming 173
  self-playing 164
  setting playback options 165
  showing the pointer 175
  skipping slides 32
  stopping 173
  switching to next or previous build or slide 173
presenter notes
  using 166
  viewing while rehearsing a presentation 166
printing
  options 177
  slides 176
  with comments showing 176
  with presenter notes showing 166

Q
QuickTime 178
QuickTime Inspector 96

R
recording 97
rectangle, rounded
  adding 82
  editing 86
ruler
  showing and hiding 54
  using to change a tab stop 54
  using to delete a tab stop 55
  using to set a new tab stop 54
  using to set paragraph indents 55

S
saving
  a document 27
  as a theme 30
  automatic backup version 29
  copy of presentation 29
  for the first time 28
  for use on other computers 28
  Spotlight 30
  undoing changes made since 29
  with audio and movie files included 28
  with theme images 28
scatter chart
  formatting symbols 161
  specifying axis settings 161
searching for text 67
shapes
  adding custom 83
  adding predrawn 82
  cropping using the default (rectangular) mask 90
  editing predrawn 86
  formatting text in 61
  making editable 84
  manipulating points 84
  reshaping a curve 85
  reshaping a straight segment 85
  transforming corner points into curved points
    and vice versa 85
  using as masks 91
  using the Draw tool 83
shortcut menus 21, 25
slide canvas 18
Slide Inspector 33, 36, 39, 101, 104, 180, 188
slide organizer
  navigator view 18
  outline view 19
  showing and hiding 17
  using for navigation 20
  slides
    adding a chart 146
Index

adding a shape  82
adding a table  115
adding images  89
adding new  31
adding presenter notes  166
adding slide numbers  33
adding sound and movies  94
adding text  38
changing the layout  36
changing the resolution  168, 171
copying or moving items  34
deleting  32
grouping  31
jumping from one to another  20
organizing  18
reordering  31
skipping  32
using comments  33

slideshows
  changing the theme  35
  controlling  163, 173
  creating as hyperlinks-only  164
  creating self-playing  164
  playing  98, 165
  playing movies and sound  175
  printing  176
  recording  97
  rehearsing  166
  rerecording  98
  using dual displays  167
  using multiple themes  35
  using other applications during  175
  using video mirroring  169, 171, 172
  video mirroring  167
  viewing  167, 169, 170
  viewing on an external display  167
  viewing on your computer’s display  167
Smart Builds  107
smart quotes  48
sound
  adding a soundtrack  95
  adding to a slide  95
  missing files  27
  playing  175
  saving with slideshow  94
  sound file types supported  94
special characters and symbols
  inserting  47
spelling check
  finding misspelled words  65
  working with spelling suggestions  66
star shape
  adding  82
  editing  87

T

tables
  adding and editing content  120
  adding images  127
  autofilling  127
  defining rules  126
  enlarging so content fits  122
  formatting borders  132
  formatting numbers  124
  formatting values  123
  merging adjacent cells into one  131
  monitoring cell values with rules  126
  resizing  122
  selecting  119
  selecting a group of cells  119
  selecting borders  120
  sorting  133
  splitting into equal parts  131
  working with dates  122
  working with numbers  121
  working with text  121
table cells
  adding and editing content  120
  adding images  127
  autofilling  127
  defining rules  126
  enlarging so content fits  122
  formatting borders  132
  formatting numbers  124
  formatting values  123
  merging adjacent cells into one  131
  monitoring cell values with rules  126
  resizing  122
  selecting  119
  selecting a group of cells  119
  selecting borders  120
  sorting  133
  splitting into equal parts  131
  working with dates  122
  working with numbers  121
  working with text  121
tab stops
  changing  54
  deleting  55
  setting new  54
  using rulers to set  53
text
  adding  38
  adding free text boxes  59
  automatic substitution  64
  editing  40
formatting size and appearance 40
in table cells 121
nonbreaking space 65
presenting in columns 60
selecting 39
setting alignment, spacing, and color 50
setting indents 55
setting tab stops to align 53
using lists 56
text boxes (free) 59
Text Inspector 45, 50, 51, 52, 53, 56, 60, 121
themes
automatically opening a certain theme 27
choosing 14, 26
creating custom 197
saving a document as 30
TIFF 181
toolbar
customizing 21
transitions
adding between slides 101
typography
changing capitalization 49
changing the baseline 49
changing tracking 49
customizing the appearance of text 44
using ligatures 49
Typography window 49

U
undoing changes 29

V
views
changing 18
light table view 20
navigator view 18
outline view 19
views of slides
light table view 20
navigator view 18
outline view 19
Slide Only view 17
switching among views 18
zooming in and out 18
VRAM
compensating for inadequate VRAM 172
configuring 172

W
Warnings window 25

Z
zooming in or out 18