GarageBand
Getting Started
Includes a tour of the GarageBand window and step-by-step tutorials to help you start creating music and podcasts with GarageBand.
## Contents

### Chapter 1
6 Welcome to GarageBand
6 What You’ll Learn
7 Before You Begin
7 What You Need to Get Started
7 Where to Go for Help
7 Finding Out More

### Chapter 2
8 GarageBand at a Glance
9 *GarageBand Window*
11 Timeline
13 *Editor*
13 For Real Instruments
14 For Software Instruments–Graphic View
15 For Software Instruments–Notation View
16 For Podcasts and Movies–Marker View
17 *Loop Browser*
17 Button View and Podcast Sounds View
18 Column View
19 *Track Info Pane*
19 Real and Software Instrument Tracks
21 Master Track
23 *Media Browser*

### Chapter 3
24 Tutorial 1: Creating, Playing, and Saving GarageBand Projects
24 Creating a New Project
26 Creating a Project Automatically with Magic GarageBand
28 Playing Your Project
29 Saving Projects

### Chapter 4
30 Tutorial 2: Adding Apple Loops
31 Finding Loops You Want to Use
31 Finding Loops in Column View
32 Finding Loops in Button View
33 Previewing Loops
33 Refining Your Loop Searches
34 Showing Loops from a Specific Jam Pack or Folder
34 Searching by Scale Type
34 Limiting Searches to Nearby Keys
35 Searching by Name
35 Adding Loops to the Timeline
37 Changing Apple Loops in the Same Family
37 Creating Your Own Apple Loops
38 Adding Loops to the Loop Library

Chapter 5
39 Tutorial 3: Recording Vocals and Musical Instruments
39 Adding a Real Instrument Track
40 Getting Ready to Record
41 Recording a Real Instrument
42 Recording Multiple Takes with the Cycle Region
43 Recording on Several Tracks at the Same Time
44 Changing Real Instrument Settings
44 Changing the Track Instrument
45 Choosing the Input Source
45 Adjusting the Recording Level
46 Tuning Guitars and Other Instruments

Chapter 6
47 Tutorial 4: Playing and Recording Software Instruments
48 Playing Software Instruments with Musical Typing
49 Playing Software Instruments with the Onscreen Music Keyboard
50 Getting Ready to Record a Software Instrument
50 Recording a Software Instrument
51 Recording a Software Instrument with the Cycle Region
52 Changing Software Instrument Settings
53 Viewing Note and Chord Names

Chapter 7
54 Tutorial 5: Working with Music Notation
54 About Notation View
56 Editing Notes in Notation View
57 Adding Notes
57 Selecting Notes
57 Moving Notes
58 Copying Notes
58 Changing the Pitch of Notes
58 Changing the Duration of Notes
58 Deleting Notes
58 Changing Note Velocity
59 Adding Pedal Symbols
Chapter 8

61 Tutorial 6: Arranging and Editing Your Music

62 Arranging Basics
63 Moving Regions
63 Resizing Regions
64 Looping Regions
65 Splitting Regions
65 Joining Regions
65 Using the Arrange Track
67 Editing Regions in the Editor
68 Renaming Regions
68 Transposing Regions
68 Enhancing the Timing of Regions in a Real Instrument Track
69 Enhancing the Timing of Items in a Software Instrument Track
70 Enhancing the Tuning of Regions in a Real Instrument Track
70 Setting Real Instrument Regions to Follow Their Original Tempo and Pitch
71 Using Undo and Redo

Chapter 9

72 Tutorial 7: Mixing and Adding Effects

72 What Is Mixing?
73 Basic Mixing
73 Setting Track Volume Levels
73 Setting Track Pan Positions
74 Setting the Overall (Master) Volume
74 Adding a Fade-Out
75 Adding Effects to a Project
75 Types of Effects
75 Adding Effects to a Track
76 Turning Effects On and Off
77 Adjusting Effects Settings
77 Creating and Saving an Effect Preset
78 Creating Changes over Time with Automation Curves

Chapter 10

81 Tutorial 8: Creating Podcasts

82 Creating an Enhanced Podcast Episode
82 Creating a Podcast Project
82 Recording the Podcast Audio
83 Adding Podcast Sounds
84 Importing Media Files
85 Adding Music
86 Adding and Editing Markers
86 Adding Marker Region Artwork
87 Adding a URL to a Marker
87 Adding Chapter Titles
87 Deleting Markers
88 Adding Episode Artwork
88 Editing Artwork
88 Editing Episode Information
89 Ducking Backing Tracks
90 Creating Video Podcasts and Movie Projects
90 Importing a Movie or Video File
90 Viewing the Movie
90 Working with the Movie’s Audio Track
91 Adding Audio
91 Adding Markers, Titles, and URLs to a Video Podcast

Chapter 11 92 Tutorial 9: Sharing Your Projects
92 Sharing Music Projects
93 Sharing Podcasts
94 Sharing Video Podcasts
95 Exporting Projects at the Optimum Loudness

Appendix A 96 Keyboard Shortcuts

Appendix B 100 Connecting Music Equipment to Your Computer
100 Connecting a Musical Instrument or Microphone
101 Connecting a Music Keyboard to Your Computer
101 Connecting Other Music Equipment
Welcome to GarageBand

GarageBand brings out the rock star in everyone. It puts a music studio on your computer, where the band is never late and always plays in tune. This document gives you useful information and step-by-step instructions for creating projects with GarageBand.

No matter what your level of musical knowledge or experience, GarageBand lets you unleash your musical creativity. With GarageBand, you can record, arrange, and mix your music, and share it with the world. GarageBand puts a complete recording studio, with pro-quality instruments and effects, at your fingertips—and the band will never show up late for the gig! Whether you’re a pro or you’ve never played a note, you can make your own music using GarageBand.

What You’ll Learn
The following chapters give you a tour of the GarageBand windows and an extensive tutorial to help you start creating your own projects. You’ll learn to do the following:

• Create a new music project and make project settings (tempo, key, time)
• Add Apple Loops to start creating an arrangement
• Record using a microphone or an electric musical instrument
• Play and record the built-in Software Instruments
• Arrange your music in the timeline
• Mix your project and add effects
• Share your project (by sending it to another iLife application, exporting it to disk, or burning it to a CD)
• Create audio and video podcasts
• Add a musical score to an iMovie project or video

There are also appendixes listing keyboard shortcuts and describing how to connect music equipment to your computer.
Before You Begin
To make it easier to follow the tutorials as you work, print each tutorial before you start. In many of the tasks shown in this document you need to choose menu commands. In the tutorials, and in GarageBand Help, menu commands appear like this:

Choose Edit > Join Selected.

The first term after Choose is the name of the menu in the GarageBand menu bar. The term (or terms) following the angle bracket is the command you choose from that menu.

What You Need to Get Started
All you need to create music in GarageBand is a Macintosh computer that meets the system requirements, as listed in the Read Me file. Optionally, you can use any of the following equipment to expand your music-making possibilities:

- A microphone to record your voice or an acoustic musical instrument
- An electric musical instrument, such as an electric guitar or bass
- An audio interface to connect microphones and music instruments to your computer
- A Universal Serial Bus (USB) or other MIDI-compatible music keyboard to play and record Software Instruments
- A pair of speakers or monitors to hear the music you create with greater audio quality

Where to Go for Help
You can access these resources for help as you complete the tutorial:

- **Onscreen help**: GarageBand comes with a built-in help system. With a GarageBand project open, choose Help > GarageBand Help. When the help page opens, type a word or phrase into the search field at the top of the page, or click one of the topic areas to get detailed instructions for completing specific tasks.
- **Help tags**: Help tags describe the functions of buttons, tools, and other onscreen items. To see a help tag, hold the pointer over an item for a few seconds.

Finding Out More
For up-to-date information on GarageBand, including news about new features, user tips, and a list of supported music equipment, go to the GarageBand website at www.apple.com/ilife/garageband.

For support, go to the GarageBand support site at www.apple.com/support/garageband.
GarageBand at a Glance

This chapter gives you a tour of the GarageBand window. You will learn the names and locations of controls, to help orient you for the following tutorials.

It’s a good idea to take a look at these pages even if you don’t plan to complete the tutorials, because knowing the names and functions of the GarageBand controls will make it easier to find answers to your questions in GarageBand help. You may find the descriptions here enough to get you started working on your own projects.

The GarageBand window includes the timeline, the loop browser, the editor, and the Track Info pane. You record instrument, arrange regions, and mix your projects in the timeline, find and preview loops in the loop browser, and change instrument, effects, and input settings in the Track Info pane.
GarageBand Window
### A Track headers: The instrument icon and name are shown at the left of each track's header. Click the name to type a new track name. Click the Record Enable button (with the red circle) to turn on the track for recording. Click the Mute button (with the speaker icon) to silence the track. Click the Solo button (with the headphone icon) to hear the track by itself. Click the Lock Track button (with the padlock icon) to lock the track. Click the triangle to show the track's automation curves.

### B Track mixer: Drag the pan dial to adjust the pan position of the track (the left-to-right placement in the stereo field). Drag the volume slider to adjust the track's volume. Watch the level meters to see the track's volume level as you record and play.

### C Timeline: Contains the tracks where you record Real and Software Instruments, add loops, and arrange regions. Also includes the beat ruler, which you use to move the playhead and align items in the timeline with beats and measures. See “Timeline” on page 11 for a description of the features and controls of the timeline.

### D Zoom slider: Drag the zoom slider to zoom in for a closer view of part of the timeline, or to zoom out to see more of the timeline.

### E Add Track button: (+) Click to add a track below the existing tracks in the timeline.

### F Loop Browser and Editor buttons: Click to open the loop browser or the editor.

### G Transport controls: Click the Record button to start recording. Click the Play button to start or stop the project playing. Click the Go To Beginning, Rewind, or Fast Forward buttons to move the playhead to different parts of the project. Click the Cycle button to turn the cycle region on or off.

### H LCD: The LCD has four modes: Time, Measures, Chord, and Project.
   In Time and Measures modes, the LCD shows the playhead's position in either absolute time (hours, minutes, seconds, fractions) or musical time (measures, beats, ticks). Drag or double-click the numerals to move the playhead.
   In Chord mode, you can see chord symbols when you play any Software Instrument. You can also use the built-in tuner to tune guitars and other Real Instruments connected to your computer.
   In Project mode, you can choose a different key and time signature for the project, and change the project tempo.

### I Master volume slider and level meters: Drag the volume slider to adjust the project's master volume level. Watch the level meters to see if clipping is occurring before you export a project.

### J Track Info and Media Browser buttons: Click to open the Track Info pane or the Media Browser.
Timeline
The timeline contains the tracks where you record Real and Software Instruments, add loops, and arrange regions.
A Beat ruler: Shows beats and measures (the units of musical time) in the timeline. You can click the beat ruler to move the playhead to any point in the timeline.

B Tracks: You organize your music, record Real and Software Instruments, and shape their sound in tracks. When you add a loop to a project, a new track is created. You arrange your music by working with regions in tracks in the timeline.

C Playhead: Shows the point in the project that is currently playing, or where playback starts when you click the Play button. Cut and copied items are pasted at the playhead position. You can move the playhead to change what part of the project is playing.

D Arrange track: You can add Arrange regions to the Arrange track to define different sections of a project (such as intro, verse, and chorus). You can copy and move the Arrange regions to rearrange your project.

E Grid button: Choose a note value for the timeline grid, or choose Automatic to have the value change when you zoom in or out.

F Automation curves: Add automation curves for volume, pan, and other parameters to a track, then add and adjust control points on each curve to create changes over time.

G Regions: When you record a Real Instrument or Software Instrument, or add a loop, you create a region in the timeline. You can copy and paste regions, loop and resize them, move and transpose them, and make other changes to build the arrangement of your music.

H Master track: You can add automation curves to the master track to create changes to the overall project volume, add a fade-in or fade-out, change the tempo, or transpose parts of the project to a different key.

I Playhead Lock button: Click to unlock the playheads in the timeline and the editor, so that you can see different parts of the project in the timeline and the editor.

J Scroll bars: Drag the horizontal scroller to move to a different part of a project. Drag the vertical scroller to see tracks not currently visible.
Editor

The editor is like a microscope showing a close-up view of part of a track. You can edit Real and Software Instrument regions in the editor.

For Real Instruments

When you select a Real Instrument track, the editor shows the waveform of the regions on the track. You can crop, join, move, transpose, and rename regions in the editor.

A Name field: Type a new name for the selected region in the field.

B Pitch slider and field: Drag the slider to transpose the selected region up or down by up to 12 semitones. You can also type the number of semitones in the field. The Pitch slider and field are visible only when a region on the track is selected.

C Follow Tempo & Pitch checkbox: Select to have the selected region follow the project tempo and key. The checkbox is visible only when a region on the track is selected.

D Zoom slider: Drag to zoom in for a closer view or to zoom out to see more of the track or selected region. Zooming in the editor is independent of the timeline.

E Beat ruler: Shows beats and measures for the area visible in the editor.

F Waveform display: Shows the waveform of the regions in the track.

G Playhead: Shows the point in the project that is currently playing.

H Enhance Tuning slider and checkbox: Drag right to increase the amount of tuning enhancement, or drag left to lower the amount. The "Limit to Key" checkbox limits tuning enhancement to notes in the project key.

I Enhance Timing slider and pop-up menu: Drag right to increase the amount of timing enhancement, or drag left to lower the amount. Choose the note value to use as the basis for timing enhancement from the pop-up menu.

J Scroll bar: Drag the scroller to move to a different part of the track.
For Software Instruments–Graphic View
When you select a Software Instrument track, the editor shows a graphic display of the track or selected region. You can edit individual notes in Software Instrument regions, fix the timing of notes, and transpose and rename regions. You can also show and edit controller data for pitch bend, a modulation wheel, or a sustain pedal, recorded when you play your music keyboard.

A **Name field:** Type a new name for the selected region in the field.

B **Pitch slider and field:** Drag the slider to transpose the selected Software Instrument region up or down by up to 36 semitones. You can also type the number of semitones in the field. The Pitch slider and field are visible only when a region on the track is selected.

C **Velocity slider and field:** Drag the slider to change the velocity of selected notes. You can also type the velocity value in the field. A note's velocity reflects how hard the key is pressed when you play the note. The Velocity slider and field are visible only when a region on the track is selected.

D **Zoom slider:** Drag to zoom in for a closer view or to zoom out to see more of the track.

E **Graphic/Notation View buttons:** Click to change the editor to graphic view or notation view.

F **Display pop-up menu:** Choose whether to show notes or controller data in the editor.

G **Enhance Timing slider and pop-up menu:** Drag right to increase the amount of timing enhancement, or drag left to lower the amount. Choose the note value to use as the basis for timing enhancement from the pop-up menu.

H **Beat ruler:** Shows beats and measures for the area visible in the editor.

I **Playhead:** Shows the point in the project that is currently playing.

J **Notes/controller data display:** Shows the individual notes of Software Instrument regions in a graphic format. You can move and resize notes to adjust their pitch, where they start playing, and how long they play. To see controller data, choose the type of data you want to see in the Display pop-up menu.

K **Scroll bar:** Drag the scroller to move to a different part of a track.
For Software Instruments—Notation View
You can also view Software Instrument tracks and regions in notation view. In notation view, notes and other musical events are shown in standard music notation. You can edit notes and edit controller information (including velocity and pedal markings for sustain) in notation view.

A Name field: Type a new name for the selected region in the field.

B Pitch slider and field: Drag the slider to transpose the selected Software Instrument region up or down by up to 36 semitones. You can also type the number of semitones in the field.

C Velocity slider and field: Drag the slider to change the velocity of selected notes. You can also type the velocity value in the field. A note's velocity reflects how hard the key is pressed when you play the note.

D Zoom slider: Drag to zoom in for a closer view or to zoom out to see more of the track.

E Graphic/Notation View buttons: Click to change the editor to graphic view or notation view.

F Note Value button: Click to choose the note value for notes you add.

G Enhance Timing slider and pop-up menu: Drag right to increase the amount of timing enhancement, or drag left to lower the amount. Choose the note value to use as the basis for timing enhancement from the pop-up menu.

H Clef selector: Choose a different clef for the notation view display.

I Beat ruler: Shows beats and measures for the area visible in the editor.

J Playhead: Shows the point in the project that is currently playing.

K Notation display: Shows the musical events of Software Instrument regions in standard music notation. You can move notes to adjust their pitch and where they start playing, and change how long they play.

L Scroll bar: Drag the scroller to move to a different part of a track.
For Podcasts and Movies–Marker View

When you are working on a podcast episode, you can view and edit markers in the editor. In the marker list you can edit each marker’s time position, marker region artwork, URL, URL title, and chapter title. You can also add episode artwork in the editor.

**A** Episode Artwork well: Drag artwork here to represent the podcast. (Appears only when you are creating a podcast.)

**B** “Marks a Chapter” checkbox: Shows whether the selected marker marks a chapter.

**C** Add Marker button: Add a marker at the playhead position.

**D** Marker list: Shows each marker’s start time, artwork (for podcasts) or video frame (for videos), chapter title, URL, and URL title.

**E** Time column: Shows the start time for each marker.

**F** Artwork column: Shows the artwork for each marker region. Add artwork by dragging image files from the Media Browser. (Appears only when you are creating a podcast.)

**G** Chapter Title column: Shows the title of each chapter marker. Click and type a title for a marker.

**H** URL Title column: Shows the title of each marker region’s URL. Click and type a title for the URL.

**I** URL column: Shows the URL for each marker region. Type a URL (address) for the website for which you want to show a link.
Chapter 2  GarageBand at a Glance

Loop Browser
The loop browser lets you quickly search for loops to add to your projects. You can find loops using keywords for instrument, musical genre, or mood. You can also perform text searches and refine your results in several ways. The loop browser shows the tempo, key, and number of beats for each matching loop. You can preview loops in the loop browser before you add them to a project, and add more loops to GarageBand by dragging them onto the loop browser. The loop browser gives you three ways to find loops: button view, column view, and podcast sounds view.

Button View and Podcast Sounds View
In button view, the loop browser contains a set of keyword buttons. Click a button to show matching loops in the results list. Clicking multiple buttons narrows the results to those loops that match all of the selected keywords.

Podcast sounds view is similar to column view, but with a different set of keywords featuring sound effects, jingles, and other loops suitable for podcasts. You work with the keywords in podcast sounds view the same way you do in column view.

Keyword buttons: Click a keyword button to display matching loops in the results list. You can click multiple keyword buttons to narrow your results.

Reset button: Deselects all currently selected buttons, so you can start a new search.

View buttons: Click one of the buttons to show column view, button view, or podcast sounds view.

Scale pop-up menu: Choose a scale type to see only loops using that musical scale.

Search field: Type text in the field to see loops with the text in their file name or path.

Preview volume slider: Drag the slider to adjust the volume of the loop being previewed.
18 Chapter 2
GarageBand at a Glance

Column View
In column view, the loop browser features columns for keyword type, categories, and keywords. Click a keyword type to show categories for that type, click a category to show keywords, and then click a keyword to show matching loops in the results list. Clicking multiple keywords expands the results to those loops matching any of the selected keywords.

A Keyword type column: Click a keyword type to show the categories for that keyword type in the middle column.
B Category column: Click a category to show keywords for that category in the right column.
C Keyword column: Click a keyword to show matching loops in the results list. You can click multiple keywords to expand your results.
D View buttons: Click one of the buttons to change the view between column, button, or podcast sounds view.
E Scale pop-up menu: Choose a scale type to see only loops using that scale.
F Search field: Type text in the field to see loops with the text in their file name or path.
G Preview volume slider: Drag the slider to adjust the volume of the loop being previewed.
H Results list: Shows the loops that match the selected keywords. Also displays the tempo, key, and number of beats for each loop. Click a loop in the results list to preview it. Click the Favs checkbox for a loop to add it to your favorites.
**Track Info Pane**

The Track Info pane shows the current instrument, effects, and input settings for the selected track, and shows the master effects settings for the master track. You can change these settings in the Track Info pane.

**Real and Software Instrument Tracks**

Some controls in the Track Info pane are different for Real Instrument tracks than for Software Instrument tracks (as noted in the following descriptions).
In this chapter, we will explore the GarageBand interface in detail and learn how to use each feature effectively.

A Instrument library pop-up menu: Choose which instruments you want to see in the category and instrument lists from the pop-up menu.

B Instrument category list: Click an instrument category to see the instruments for that category in the instrument list on the right.

C Instrument list: Click an instrument from the list.

D Instrument icon pop-up menu: Click to choose a new instrument icon from the icon menu that appears. Icons make it easy to distinguish tracks that use similar instruments.

E Details triangle: Click to show the instrument and effects settings.

F Effect checkboxes, sliders, and pop-up menus: Click an effect checkbox to turn the effect on or off. Drag the sliders to adjust the level of the effects, or choose an item from the pop-up menus. Drag effects up or down by their left edge to reorder them.

- Gate slider (Real Instrument tracks only): Drag the slider to adjust the strength of the gate. The gate reduces noise from your input source.
- Instrument Generator and Generator Preset pop-up menus (Software Instrument tracks only): Choose an instrument generator and a generator preset from the menus.
- Compressor pop-up menu: Choose a compression setting from the pop-up menu.
- Visual EQ pop-up menu: Choose an EQ (equalizer) setting from the pop-up menu. Click the Edit button to see and graphically edit the Visual EQ.
- Effect and effect preset pop-up menus: Click a checkbox to turn additional effects on or off. Choose an effect from a pop-up menu on the left, then choose an effect preset from the pop-up menu on the right.
- Echo slider: Drag the slider to adjust the amount of echo.
- Reverb slider: Drag the slider to adjust the amount of reverb.

G Input Source pop-up menu (Real Instrument tracks only): Choose the input source for Real Instrument recording.

- Monitor pop-up menu: Turn on monitoring to hear your instrument as you play. You can turn on monitoring with or without feedback protection.
- Recording Level slider and checkbox: Drag to set the input volume for the track. Select the Automatic Level Control checkbox to have GarageBand lower the recording level to prevent clipping.

H Effect edit buttons: Click to show an effect’s preset window, where you can edit the effect preset.

I Save Instrument and Delete Instrument buttons: Click the Save Instrument button to save an instrument. Click the Delete Instrument button to delete a saved instrument.
Master Track
The Track Info pane for the master track shows the global project settings and effects settings for the overall project. Global project settings include tempo, time signature, and key. Global effects settings include master echo, reverb, EQ, and compressor.
The Echo and Reverb sliders for each track control the amount of echo and reverb sent from that track to the master echo and reverb effects. In the Track Info pane for the master track, you can change the master echo and reverb effects.

### A Master effects pop-up menu:
Choose which master effects you want to see in the category and effects lists from the pop-up menu.

### B Master effects category list:
Click a category to see the effects for that category in the master effects list on the right.

### C Master effects list:
Click a set of master effects from the list.

### D Tempo slider and field:
Drag the slider to change the project's tempo, or type a new tempo in the field.

### E Time pop-up menu and field:
Choose a time signature from the pop-up menu.

### F Key and scale type pop-up menus:
Choose a key from the Key pop-up menu, and then choose a scale type from the Scale pop-up menu.

### G Details triangle:
Click to show the global effects settings.

### H Effect checkboxes, pop-up menus, and slider:
Click an effect checkbox to turn the effect on or off. Choose an item from the pop-up menus, or drag the slider, to adjust an effect. The Track Info pane includes the following effects for the master track:

- **Echo pop-up menu:** Choose a global echo preset.
- **Reverb pop-up menu:** Choose a global reverb preset.
- **Effect and effect preset pop-up menus:** Click a checkbox to turn an additional effect on or off. Choose an effect from a pop-up menu on the left, then choose an effect preset from the pop-up menu on the right.
- **Visual EQ pop-up menu:** Choose a global equalizer setting from the menu.
- **Compressor pop-up menu:** Choose a global compressor setting from the menu.
- **Ducker pop-up menu:** When ducking is turned on, choose a ducking setting from the menu.

### I Effect edit buttons:
Click to show an effect's preset window, where you can edit the effect preset.

### J Save Master and Delete Master buttons:
Click the Save Master button to save a set of master effects. Click the Delete Master button to delete a saved set of master effects.
**Media Browser**

The Media Browser lets you find and add songs from your iTunes library, photos from your iPhoto library, iMovie projects, and other video files.

---

**A** Audio, Photos, and Movies buttons: Click the button for the type of media files you want to work with.

**B** Source list: Navigate to the folder containing the files you want to use. You can also add folders by dragging them from the Finder.

**C** Media list: View, preview, and select media files to add to your project.

**D** Play button: Click to preview the selected media file.

**E** Search field: Type text to search for files with matching names.
GarageBand projects hold your music and all the changes you make.

You can create and save projects, add loops and record your own performances in the timeline, and play the project to hear your music.

In this tutorial, you’ll learn how to:

• Create a new project
• Set the project tempo, time signature, and key
• Play the project
• Save the project

Creating a New Project
You start working in GarageBand by creating a project. Projects hold your music and all the changes you make. When you create a new project, you set the project tempo, key, and time signature. You can change these settings later in the LCD (liquid crystal display) or the Track Info pane.

To create a new project:
1 Choose File > New.
2 When the GarageBand screen appears, select Create New Music Project.
3 In the New Project dialog, type a name for the project in the Save As field, and then browse to the location where you want to store the project.
Set the project tempo, time signature, and key, as described in the following steps.

**Setting the Tempo**
Each project has a speed, or *tempo*. The tempo defines the rate at which beats, the basic rhythmic pulse, occur in the project. The tempo is measured in beats per minute, or *bpm*. You can set the tempo to any speed between 60 and 240 bpm. The default tempo is 120 bpm, which is a common tempo used in popular music.

5 Set the project tempo by dragging the Tempo slider (drag left to make the tempo slower, or drag right to make it faster). You can also type a tempo in the Tempo field (marked “bpm”).

**Setting the Time Signature**
Each project has a time signature, which controls the relationship between beats and measures. A project’s time signature consists of two numbers separated by a forward slash, which look similar to a fraction. The number on the left controls the number of beats in each measure, and the number on the right controls the beat value (the length of the note that gets one beat).

You can use any of the following time signatures in a GarageBand project: 2/2, 2/4, 3/4, 4/4, 5/4, 7/4, 6/8, 7/8, 9/8, or 12/8. The default is 4/4, the most commonly used time signature.

6 Choose a time signature from the Time pop-up menu.
Setting the Key
Each project has a key, which defines the central note to which the other notes in the music relate. The key can be any key between A and G-sharp (G#). Along with the key, you can choose to use either the major or minor scale.

7. Choose a key from the Key pop-up menu, and choose “major” or “minor” from the Scale pop-up menu to the right of the Key pop-up menu.

8. When you have finished making the project settings, click Create.

Note: You can change the tempo, time signature, and key later in the LCD or in the Track Info pane for the master track.

Your new project appears. New projects have one track by default, with the Grand Piano instrument loaded and ready to play. A project can be up to 9999 measures long.

The central area of the GarageBand window is the timeline, which is organized into horizontal rows called tracks, which hold your music. The left area shows the track headers, where you can adjust volume and other settings for each track. Below the timeline is a row of buttons for different editors and inspectors, and transport controls you use to play your projects. For more information about the controls in the GarageBand window, see Chapter 2, “GarageBand at a Glance.”

You can make music in three different ways using GarageBand:

• By adding Apple Loops
• By recording sound from a microphone or an electric instrument connected to your computer
• By connecting a USB or MIDI keyboard and playing the Software Instruments built into GarageBand

Creating a Project Automatically with Magic GarageBand
You can also have GarageBand create a project for you automatically with Magic GarageBand. When GarageBand creates a Magic GarageBand project, you can choose the genre (style) of music, and choose the instruments. GarageBand creates the project, which you can play, edit, and share as you can any GarageBand project.

To create a project automatically:
2. In the GarageBand screen, click Magic GarageBand.
3 When the Magic GarageBand stage appears, click one of the genre buttons (the large square buttons located under the stage) to select a genre for the song.

4 To preview the song, click either Snippet or Entire Song, then click the Play (π) button. The first time you click Play, the song takes a few moments to start playing. A progress indicator below the stage shows the progress of opening the song.

5 To choose different instruments to use in the song, click the Audition button. The curtain opens on the Magic GarageBand stage, showing the instruments used in the song.
Select one of the instruments on the stage, and then choose a different instrument from the list of instruments that appears below the stage.

After you choose the instruments you want, click Play again to hear the song with the new instruments.

When the song is ready, click Create Project.

The GarageBand window appears. Tracks appear for each of the instruments, with regions containing the music for each instrument.

After the song appears in the GarageBand timeline, you can edit the regions for the different instruments, record the part for My Instrument, and make other changes to the project.

Playing Your Project

After you have added some loops and recordings to your project, you’ll want to play it back to hear how it sounds. You play projects using the transport controls, which are located in the bar below the timeline.

The transport controls are similar to the playback controls used on tape and CD players. They include, from left to right:

- **Record**: Starts recording on tracks that are enabled for recording
- **Go to beginning**: Moves the playhead to the beginning of the project
- **Back (Rewind)**: Moves the playhead back one measure
- **Play/Pause**: Starts the project playing, or stops playback
- **Forward**: Moves the playhead forward one measure
- **Cycle**: Turns the cycle region on or off
Saving Projects
Now that you’ve made some changes to your project, it’s time to save your work.

To save a project:
- Choose File > Save (or press Command-S).

When you close a project, by default GarageBand creates an iLife preview for the project. An iLife preview lets you preview the project in the Media Browser and in other iLife applications. It can also increase the project’s file size. You can select whether to create an iLife preview for projects in the General pane of GarageBand preferences.

You can also save a project as an archive. When you save a project as an archive, all the audio files, loops, and other media the project uses are saved in the project file. This is especially useful if you want to copy the project to another computer, or are duplicating a project with your own Real Instrument recordings.

To save a project as an archive:
1. Choose File > Save As.
2. In the Save As dialog, select the Save As Archive checkbox.

You can also compact projects to make sharing easier. Compacting a project reduces the file size by compressing audio in the project. Compacting can result in some loss of audio quality.

To compact a project:
1. Choose File > Save As.
2. In the Save As dialog, select the Compact Project checkbox.
3. Choose the compression settings you want to use from the pop-up menu next to the Compact Project checkbox.
You can use Apple Loops to add backing and rhythm tracks to your projects. You can also add Apple Loops to your loop library and create your own Apple Loops.

GarageBand comes with a large collection of Apple Loops. Apple Loops are prerecorded musical phrases in a variety of genres, instruments, and moods that you can add to your projects. Loops are recorded to create seamlessly repeating patterns that you can extend (or “loop”) to fill any amount of time. What’s great about using Apple Loops in your GarageBand project is that you can freely mix loops that were recorded in different keys and at different tempos, but they all play back in the project key and at the project tempo.

Most popular music today is based on repeating rhythmic patterns (sometimes called “grooves” or “riffs”), especially in the drum and bass parts. To create music in a groove-based style, an effective way of working is to add loops for the drums, and then add loops for bass and other rhythm parts. Working this way, you can define the rhythmic feel of the project and also build the basic shape of the project by blocking out sections with different grooves. After the rhythm parts are in place, you can record voices and instruments to add lead, solo, and harmony parts.

You can quickly set the feel of a project by adding a few Apple Loops. GarageBand makes it easy to search for loops that fit the criteria you want, preview them, and add them to the timeline.

In this tutorial, you’ll learn how to:

- Find and preview loops in the loop browser
- Add loops to the timeline
- Create your own Apple Loops
- Add loops to the loop library
Finding Loops You Want to Use
GarageBand includes a loop browser that lets you search for loops by instrument, genre, mood, and other criteria. You can also search for loops by name and refine your searches in several ways. No matter how big your collection of loops becomes, you can quickly find the ones you want using the loop browser.

If the loop browser is not visible, show it so you can use it to search for loops.

To show the loop browser:
- Click the Loop Browser button (the button with the open eye).

You can search for loops using either column view or button view (there's also a special view for podcast sounds, which is covered in Chapter 10). In column view, you choose from different keyword types, categories, and keywords to find matching loops. In button view, you click keyword buttons to find loops that match the keywords. You can select either view using the view buttons in the lower-left corner of the loop browser, and move back and forth between them freely.

To choose column or button view:
- Click the left button (with columns) to show column view, or click the center button (with musical notes) to show button view. (The button on the right shows podcast sounds view, covered in Chapter 10.)

Finding Loops in Column View
In column view, clicking a keyword type in the left column shows categories for that keyword type in the middle column. Clicking a category shows keywords for that category in the right column. Clicking a keyword shows matching loops in the results list. You can expand your results by clicking multiple keywords.

To find loops in column view:
1. Click the column button in the lower-left corner of the loop browser to switch to column view.
2. Click a keyword type in the left column.
3. Click a category in the middle column.
4 Click a keyword in the right column to show matching loops in the results list.

Now find some bass loops in column view by first selecting the By Instruments keyword type, then the Bass category, and then the Grooving keyword.

When you find loops in either button view or column view, the total number of matching loops is shown next to the search field at the bottom of the loop browser.

**Finding Loops in Button View**

Button view features a grid of keyword buttons. You click a button to see the loops matching the selected keyword in the results list to the right. You can narrow your results by clicking multiple buttons.

To find loops in button view:

1. Click the button with musical notes in the lower-left corner of the loop browser to switch to button view.

2. Click a keyword button to show matching loops in the results list. The columns in the results list show the type of loop, name, tempo, key, and number of beats for each loop.

3. To refine your results, click multiple keyword buttons. This narrows the matching loops to only those that match all of the selected keywords.

4. To end a search, click the Reset button to deselect all selected keywords. You can also click keywords to deselect them individually.

When you click a keyword, incompatible keywords (those that share no loop with the selected keyword) are dimmed.

Now find some drum loops in button view by clicking the All Drums keyword button. Scroll through the list to see all the matching loops. Notice that the number of matching loops is shown next to the search field.
Previewing Loops
When you find loops that fit the criteria you want, you can preview them in the loop browser to hear which loop will sound best in your project. You can preview the loop by itself (solo), or preview it together with the project.

To preview a loop:
- Click the loop in the results list. Click the loop again to stop previewing it.

You can preview a loop together with the material you’ve already added to the project by clicking the Play button before you click the loop. When you preview a loop together with a project, GarageBand matches the tempo and key of the loop to the project’s tempo and key, and syncs the loop with the project so it starts playing on the beat.

When you preview a loop, you can control the volume of the loop using the volume slider in the loop browser.

To adjust the volume of the loop you are previewing:
- Drag the volume slider in the loop browser left to lower the loop’s volume, or right to raise the loop’s volume.

If you adjust the volume of a loop in the loop browser, and then add the loop to your project by dragging it to an empty part of the timeline, the volume of the track created for the loop is set to the preview volume of the loop.

Now try previewing the loops you found earlier, and see which ones you like.

Refining Your Loop Searches
You can refine your searches in the loop browser in several ways. You can:
- Display only loops from a specific Jam Pack or folder
- Display loops using a particular scale type
- Display only loops in keys near the project’s key
- Search for loops by name
Showing Loops from a Specific Jam Pack or Folder
If you have installed one or more of the GarageBand Jam Packs on your computer, your loop library can contain many thousands of loops. To make searching for loops easier, you can choose to display only loops from a specific Jam Pack, or only the loops included with GarageBand. If you have created your own loops or added loops from another source, you can also choose to display only those loops.

To view loops from a specific Jam Pack or folder:
- Choose the Jam Pack or folder with the loops you want to see from the loop library pop-up menu, located next to the word “Loops” at the top of the loop browser.

Searching by Scale Type
Most loops other than drum loops are recorded using a particular musical scale. In most cases, when you arrange several loops so that they play together, you’ll want to use loops with the same scale type. You can narrow the loops shown in the results list to those using either the major or minor scale, those using neither scale, or those that are good for both.

To display only loops with a particular scale type:
- Choose the scale type from the Scale pop-up menu.

Try refining the bass loops you found earlier to show only those using the major scale.

Limiting Searches to Nearby Keys
Loops with melody and harmony instruments are recorded in a specific musical key. When you add a loop to a project, GarageBand matches the loop’s key with the key of the project. The closer the loop’s original key is to the key of the project, the more natural the loop will sound when transposed to the project key. When a loop is transposed by a large number of semitones, the result can sometimes sound unnatural or distorted.
To view loops only in keys near the project key:
1. Choose GarageBand > Preferences, then click Loops.
2. In the Loops pane, click the “Filter for more relevant results” checkbox.

Note: The “Filter for more relevant results” checkbox is selected by default. To see loops in keys farther away from the project’s key, deselect the checkbox.

Searching by Name
You can quickly find loops by name using the search field. This makes it easy to find a specific loop or a group of related loops.

To search for loops by name:
- Type the name you want to search for in the search field, then press Return. Loops with the text in their file name appear in the results list.

Try refining the drum loops you found earlier by typing “acoustic”, “club”, or “funk” in the search field. You can try typing other words to see what results you get.

You can use several methods together to find specific loops. For instance, you can use keywords with the Scale pop-up menu, or with the search field, to find only bass loops using the major scale, or to find only percussion loops with “latin” in the file name.

Adding Loops to the Timeline
When you find a loop you want to use, you add the loop to the project by dragging it to the timeline.

Drag a loop to an empty part of the timeline to create a new track for the loop.
To add a loop to the timeline:
- Drag the loop from the loop browser to an empty part of the timeline where there is no track. A new track of the appropriate type is created, and the loop is added to the new track.

There are two types of Apple Loops: Real Instrument loops and Software Instrument loops. In the loop browser, the loop’s icon shows which type each loop is. Real Instrument loops have a blue icon with an audio waveform and Software Instrument loops have a green icon with a musical note.

Note: You can also drag a loop to a track of the same type (Real or Software Instrument) to add it to the timeline. If you drag a Software Instrument loop to a Software Instrument track, a dialog appears, asking which instrument you want to use. You can also convert a Software Instrument loop to a Real Instrument loop when you drag it to the timeline. Real Instrument loops require less processing power for playback, which can allow you to use more tracks and effects in your project, especially for projects with many loops.

To convert a Software Instrument loop to a Real Instrument loop:
- Option-drag the loop from the loop browser to the timeline.

By default, Option-dragging a Software Instrument loop converts it to a Real Instrument loop. You can change the default so that dragging a Software Instrument loop converts it to a Real Instrument loop, and Option-dragging does not convert it. You can change the default behavior in the Loops pane of GarageBand preferences.

When you add a loop to a project, a region is created in the timeline for the loop. The edits you make to the region do not change the original loop, so you can always return to the original sound of the loop or use it in another project.

Now try adding some of the drum and bass loops you found earlier to the timeline.

You can also add audio files in any of the following formats to your project from the Finder: AIFF, WAV, AAC (except protected AAC files), Apple Lossless, or MP3. When you add a compressed file to a project (such as an AAC or MP3 file), it stays compressed, saving space and time.

To add an audio file:
- Drag the file from the Finder to the timeline, either to a Real Instrument track or to the empty area below the existing tracks.

If you drag an audio file to the empty area below the existing tracks, a new basic track is added to the timeline, and the audio file is placed in the new track.
Changing Apple Loops in the Same Family

Some Apple Loops belong to a series, or family. Loops that belong to the same family have the same name, but with a unique number at the end. (For example, Classic Rock Guitar 01 and Classic Rock Guitar 02 belong to the same family.) When you add a loop belonging to a family to the timeline, the loop has a pair of arrows in its upper-left corner. You can change it to any other loop in the same family.

To change an Apple Loop to another loop in the same family:
1. Click the arrows in the upper-left corner of the loop.

   A menu appears, showing all the loops in the same family.

   ![Menu showing Apple Loops](image)

2. Choose a loop from the menu.

Creating Your Own Apple Loops

You can save your Real and Software Instrument recordings as Apple Loops. When you save a region as an Apple Loop, it is added to the loop library and appears in the loop browser, so you can use it in other projects. Apple Loops you create from recorded regions match the tempo and key of the project, just like the Apple Loops included with GarageBand.

To save a region as an Apple Loop:
1. Select the region in the timeline.

2. Choose Edit > Add To Loop Library, or drag the region over the loop browser.

3. In the Add Loop dialog, do the following:
   a. Type a name for the loop.
   b. Choose the scale and genre from the pop-up menus.
   c. Choose an instrument category and instrument name from the list.
   d. Click the appropriate mood buttons for easy searching.

4. Click Create.
Adding Loops to the Loop Library

When you install GarageBand, the loops included with the application are installed in the Apple Loops library. When you add more loops to your collection, they are installed in the loop library and appear in the loop browser for you to use.

To add Apple Loops to your loop library:

- Drag the loops, or the folder containing the loops, over the loop browser. The loops are added to the Apple Loops library and are immediately available to use in your projects.

  If you add loops located on a different hard disk or partition, a dialog appears asking whether you want to copy them to the loop library, or index them in their current location. If you add loops from the desktop, a dialog asks if you want to move them or index them in their current location.

  If you add loops located on a CD or DVD, GarageBand copies them to the loop library.
You can record your voice or any other sound you can capture using a microphone. If you play a musical instrument, you can also record it in a GarageBand project.

In GarageBand, you record audio from a microphone or a musical instrument, such as an electric guitar or bass, in a Real Instrument track. Real Instrument tracks have blue headers, and the regions you record in them appear purple. You can change track settings and add effects to Real Instrument tracks in the Track Info pane.

In this tutorial, you'll learn how to:
- Add a Real Instrument track and change instrument settings
- Record a Real Instrument
- Record multiple takes
- Tune instruments with the built-in tuner

Adding a Real Instrument Track
To record vocals or instruments in a Real Instrument track, you first add the track to your project and prepare it for recording.

To add a new Real Instrument track:
1. Click the Add Track button, or choose Track > New Track.
2. In the New Track dialog, click Real Instrument Track, then click Create.
   
   A new Real Instrument track appears in the timeline, and the Track Info pane opens to the right of the timeline. The Track Info pane is where you choose different settings for each track.
3. In the Track Info pane, select an instrument type from the list on the left, then select an instrument from the list on the right.
4. From the Input Source pop-up menu, select the audio input to which your microphone or instrument is connected.
The Input Source menu lists all the available inputs for each audio device connected to your computer. If the instrument you are recording has a single input, choose a mono (monophonic) input. If the instrument has both left and right inputs, choose a stereo input. (You can change the audio device in the Audio Input pop-up menu in the Audio/MIDI pane of GarageBand preferences.)

If you want to hear your microphone or instrument as you play, choose On (with or without Feedback Protection) from the Monitor pop-up menu.

Turning on monitoring can cause feedback (loud, sharp noise) if the audio input picks up the output from your speakers. You can choose “On with Feedback Protection” to have GarageBand automatically turn off monitoring if feedback from the input source occurs. You can also avoid feedback by listening with headphones rather than speakers when you play or record. You can reduce possible feedback by making sure the microphone or instrument is pointed away from your speakers, and by turning down the master volume.

You can also add a basic track. A basic track is a stereo Real Instrument track containing no effects. You can change the input source and effects settings of a basic track after adding it to the project.

To add a basic track:

- Choose Track > New Basic Track.

The basic track appears in the timeline, and the Track Info pane opens. You can make the same input settings described in the previous section.

Getting Ready to Record

After you have connected your instrument and added a track to record in, there are a few things to check before you start recording:

- Make sure the microphone or instrument is connected properly and is working.
- Make sure the correct audio drivers are selected in the Audio/MIDI pane of GarageBand preferences. When you add a new audio device, GarageBand asks if you want to use the device for audio input and output.
- Open the Track Info pane to make sure the instrument has the instrument and effects settings you want, and is using the correct input source. See “Changing Real Instrument Settings” on page 44 for more information.
- Sing or play a few notes and watch the track’s level meters in the track mixer to make sure the track is receiving input, and isn’t clipping. If the red dots at the right of the level meters (called clipping indicators) light up, adjust the input level by dragging the Recording Level slider, selecting Automatic Level Control, or lowering the level of the audio device connected to your computer.
- Set the project tempo and key so you won’t have to change them later.
Recording a Real Instrument

Now you’re ready to record your microphone or electric instrument to a Real Instrument track.

To record to a Real Instrument track:
1. Click the header of the Real Instrument track you want to record in, to select the track.
2. Move the playhead to the point in the timeline where you want to start recording.
3. Choose Control > Count In to have the metronome play a one-measure count-in before recording starts to make it easier to start playing on the beat.
   (Alternatively, you can move the playhead a few beats before the point where you want the music to come in.)
4. Click the Record button in the transport controls to start recording.
5. Start playing your instrument or singing into your microphone. As you record, a new region appears in the selected Real Instrument track with the music you record.
6. When you are finished, click the Play button to stop recording.
   After a few moments, an audio waveform appears in the newly recorded region.
   Now you can listen to your new recording to see how you like it.

To hear your new recording:
1. Move the playhead to the point in the timeline where the new region starts (align it with the left edge of the region).
   You can also move the playhead to an earlier point in the project, or to the beginning of the project, to hear the new recording in the context of the project.
2. Click the Play button, or press the Space bar.
Recording Multiple Takes with the Cycle Region

GarageBand lets you record over a specific part of a project by setting a cycle region in the timeline. When you record using the cycle region, you can record multiple versions, or “takes,” and then choose which take you want to use.

To set the cycle region:
1. Click the Cycle button. The cycle region appears as a yellow strip just below the beat ruler.
2. Move the cycle region to the point in the timeline where you want to start recording, then drag the end of the cycle region to the point in the timeline where you want to end recording. You can drag in the cycle region ruler (below the beat ruler) to move the cycle region to a new part of the timeline.

You may want to have the cycle region start a few extra beats before the point where you want to start recording, to make it easier to start playing on the beat, and end a few beats after you want to stop recording, in case your last note extends past the end of the cycle region.

To record multiple takes using the cycle region:
1. Select the Real Instrument track you want to record in.
2. Click the Record button to start recording.
3. Play your musical instrument or sing into your microphone. As you record, a new region appears in the selected Real Instrument track.
4. When you are finished, click the Play button to stop the cycle region.
5. If you want to record additional takes, click the Record button and play the part again.
6. When you have finished using the cycle region, click the Cycle button again to turn it off.

When you record multiple takes, the recorded region has a circle in its upper-left corner showing the selected take (the one you will hear). You can choose and listen to different takes to decide which one you like best.
To choose a different take:
1. In the timeline, click the circled number in the upper-left corner of the loop. 
   A Takes menu appears showing the takes recorded in the region.
2. Choose a different take from the Takes menu.

   When you choose a different take, the loop changes to show the waveform of the new take.

To delete the selected take:
- Choose Delete <take name> from the Takes menu.

   You can also delete all takes except for the selected one.

To delete all unused takes:
- Choose Delete Unused Takes from the Takes menu.

Recording on Several Tracks at the Same Time
You can record up to eight Real Instruments and one Software Instrument at the same time. This lets you record voices and instruments together, and simultaneously record a backing track, for example.

When you select a track, recording is enabled for that track (meaning that recording will start on that track when you click the Record button). You can enable up to seven additional tracks by clicking the round Record Enable button in each track’s header. The Record Enable button turns red to show that the track is enabled for recording.

To disable a track for recording, click the Record Enable button in the track’s header again.

To record multiple Real Instruments at the same time:
1. In the Track Info pane, be sure each Real Instrument track is set to use a different input source.
2. Enable the tracks you want to record by clicking their Record Enable buttons.
3. Click the Record button in the transport controls to start recording.

To record a Software Instrument at the same time as one or more Real Instruments:
1. Enable the Software Instrument track for recording by clicking its Record Enable button.
2. Click the Record button in the transport controls to start recording.

   If you enable more than eight Real Instrument tracks or more than one Software Instrument track, the track farthest from the last track you enable is disabled for recording, so as not to exceed the maximum number of recording tracks.
To record on multiple tracks, you need to have an audio interface with at least two input channels for recording.

**Changing Real Instrument Settings**

When you create a Real Instrument track, you select an instrument for the track in the New Track dialog. You can change the instrument, effects, and input settings in the Track Info pane.

**Changing the Track Instrument**

You can change the track instrument for a Real Instrument track. Each instrument includes preset effects optimized for the instrument.

**To change the track instrument for a Real Instrument track:**

1. Select the track, then click the Track Info button to open the Track Info pane.
2. Select an instrument category from the list on the left, then select a track instrument from the list on the right.
Choosing the Input Source
You can choose the input source for a Real Instrument track. If you have more than one input source (an instrument or an audio interface with multiple channels, for example), you must choose the correct input source before you play or record Real Instruments.

To choose the input source for a Real Instrument track:
- In the Track Info pane for the track, choose the source from the Input Source pop-up menu.

Note: Some audio interfaces have more than one input channel. If you are connecting a microphone or instrument using an audio interface, be sure to choose the correct channel in the Input Source menu. Choose a mono source if your microphone or instrument is connected by a single cable, and choose a stereo source if it is connected by a pair of stereo cables.

Adjusting the Recording Level
You can adjust the recording (input) level for a Real Instrument track. The recording level controls the level of the signal coming from the instrument or microphone. In general, you'll get the best results if you set the recording level as high as possible without causing clipping or distortion.

To adjust the recording level, do one of the following:
- If the instrument or microphone has a volume control, adjust the volume control on the device.
- If the instrument or microphone is connected to an audio interface, adjust the volume control on the audio interface.
- In the Track Info pane, drag the Recording Level slider left to lower the input volume for the selected channel, or drag it right to raise the input volume.

Note: You can't control the volume of some audio interfaces and other devices from GarageBand. If the Volume slider in the Track Info pane is dimmed, you cannot adjust the input volume in GarageBand.

- Select the Automatic Level Control checkbox to have GarageBand automatically lower the input level to avoid clipping, and raise the level to avoid excessive noise when recording.

Note: If “On with Feedback Protection” is chosen in the Monitor pop-up menu, you cannot select Automatic Level Control.

You can also add and adjust effects for a Real Instrument track. For information about using effects, see Chapter 9, “Tutorial 7: Mixing and Adding Effects.”
Tuning Guitars and Other Instruments

GarageBand includes an instrument tuner that you can use to check the tuning of a guitar, bass, or other instrument connected to your computer. The instrument tuner works for any Real Instrument, but not for a Software Instrument.

The instrument tuner shows a horizontal scale with the note name displayed in the center of the scale. When you play a single note on your Real Instrument, the pitch is shown in relation to the correct pitch for the note displayed.

To use the instrument tuner:
1. Make sure the Real Instrument you want to tune is connected to your computer.
2. Select the Real Instrument track for the instrument you want to tune.
3. In the LCD, choose Tuner mode, or choose Control > “Show Tuner in LCD.”
4. Play a single note on your instrument, and watch the tuner.

As you play, the tuner shows the note name of the closest note. If the note is not in tune, the note name and the tuner glow red, and a vertical red bar appears, showing whether the note is sharp or flat.

The bar appears to the right of the note name if the note is sharp, and to the left if the note is flat. When the note is in tune, the note name and the tuner scale glow blue, and the vertical bar disappears.

Be sure to play only a single note at a time while tuning. The instrument tuner can’t tune to a chord, or if you play different notes rapidly.
GarageBand includes an extensive set of Software Instruments, including drums, guitars, pianos, organs, and synthesizers, that you can use in your projects.

Software Instruments are a special kind of instrument. You play the notes (using your computer keyboard, the onscreen keyboard, or a MIDI-compatible music keyboard connected to your computer) and your computer generates the actual sound, depending on which Software Instrument you choose.

You can add effects to a Software Instrument, and edit Software Instrument regions in the editor. You can also add more Software Instruments to the Track Info pane by purchasing one of the Jam Packs available for GarageBand.

In this tutorial, you'll learn how to:
- Play Software Instruments using your computer keyboard, the onscreen keyboard, or a connected music keyboard
- Record a Software Instrument
- Change Software Instrument settings

You play and record a Software Instrument in a Software Instrument track. You can change the instrument for the track, even after you have recorded on it. You start by adding a new Software Instrument track.

To add a new Software Instrument track:
1. Click the Add Track button, or choose Track > New Track.
2. In the New Track dialog, click Software Instrument Track, then click Create.
   A new Software Instrument track with a Grand Piano instrument appears in the timeline, and the Track Info pane opens to the right of the timeline.
3. In the Track Info pane, select an instrument category from the list on the left, then select an instrument from the list on the right.
   The header of the Software Instrument track changes to the name of the instrument you selected.
If you have a USB or MIDI keyboard connected to your computer, you can play notes and hear the Software Instrument right away. Even without a keyboard connected, you can play Software Instruments with the Musical Typing keyboard or onscreen keyboard.

**Playing Software Instruments with Musical Typing**

With Musical Typing, you can play and record Software Instruments using your computer keyboard. When you show the Musical Typing window, you can play the top and middle rows of your computer keyboard just like the keys on a music keyboard to play notes.

**To show the Musical Typing window:**
- Choose Window > Musical Typing (or press Command–Shift–K).

If the onscreen keyboard is visible, you can switch to the Musical Typing window by clicking the Musical Typing button on the left side of the window.

**To play notes using Musical Typing:**
- With the Musical Typing window open, play the keys shown on the Musical Typing keyboard.
  - The keys in the middle row of your computer keyboard play the “white keys” on the Musical Typing keyboard, in a one and one-half octave range from C through F.
  - The keys W, E, T, Y, U, O, and P in the top row of your computer keyboard play the “black keys” (sharps and flats).

**To move up or down by octaves, do one of the following:**
- Press Z to move down by an octave.
- Press X to move up by an octave.
- Click the small keyboard at the top of the Musical Typing window to move to the octave shown, or drag the blue rectangle. The blue rectangle shows the current range of Musical Typing.
To change the velocity level of notes you play using Musical Typing:
- Press C to lower the velocity level.
- Press V to raise the velocity level.

To add pitch bend to notes you play using Musical Typing:
- Press 1 to lower the pitch of notes.
- Press 2 to raise the pitch of notes.
The pitch is bent for as long as you press the key.

To sustain notes you play using Musical Typing:
- Hold down the Tab key.
Notes are sustained for as long as you hold down the Tab key.
- Release the Tab key to stop sustaining notes.

To add modulation to notes you play using Musical Typing:
- Press 4 through 8 to add increasing amounts of modulation. Press 3 to turn off modulation.
The level of modulation lasts until you change it or turn it off by pressing another key.

**Playing Software Instruments with the Onscreen Music Keyboard**

You can use the onscreen music keyboard to play and record Software Instruments. When you show the onscreen music keyboard, by default it displays a four-octave range of keys. You can resize the keyboard to display up to ten octaves.

**To show the onscreen music keyboard, do one of the following:**
- Choose Window > Keyboard (or press Command-K).

![Onscreen Music Keyboard](image)

If the Musical Typing window is visible, you can switch to the onscreen keyboard window by clicking the Keyboard button on the left side of the window.

**To play the onscreen music keyboard:**
- Click the notes on the keyboard. You can click when the project is playing, when it is stopped, or when you are recording.

Clicking a note lower on the key plays the note with a higher velocity (equivalent to pressing the key harder), and clicking a note higher on the key plays the note with a lower velocity (equivalent to pressing the key more softly).
The onscreen keyboard also shows notes you play on your connected keyboard, and shows notes in regions on the selected track when you play the project.

To move the keyboard:
- Place the pointer anywhere in the space above the keys and drag.

To resize the keyboard:
- Drag the resize control in the lower-right corner of the keyboard window.

To change the range of notes you can play:
- Click the small triangle to the left or right of the keys. Clicking the triangle to the left lowers the keys by an octave, and clicking the triangle on the right raises the keys by an octave.

Getting Ready to Record a Software Instrument
If you are recording Software Instruments using a music keyboard, there are a couple of things to check before you start recording:
- Make sure your music keyboard is connected to your computer and is working.
- Select a Software Instrument track and try playing your music keyboard, clicking notes on the onscreen music keyboard, or using Musical Typing. You should hear the Software Instrument as you play.

Recording a Software Instrument
Now you’re ready to record a Software Instrument. You can record one Software Instrument track at a time.

To record a Software Instrument:
1. Click the header of the Software Instrument track you want to record in to select the track.
2. Move the playhead to the point in the timeline where you want to start recording.
3. Choose Control > Count In to have the metronome play a one-measure count-in before recording starts.
   You can also set the playhead a few beats before the point where you want the music to come in to make it easier to start on the beat.
Chapter 6  Tutorial 4: Playing and Recording Software Instruments

4 Click the Record button to start recording.

5 Start playing your music keyboard, clicking notes on the onscreen music keyboard, or using Musical Typing. As you record, a new region appears in the selected Software Instrument track.

6 When you are finished, click the Record button again to stop recording. Click the Play button to stop the project playing.

After you record, you can listen to your new recorded part to see how you like it.

To hear the new recording:
1 Move the playhead to the point in the timeline where the new region starts (align it with the left edge of the region).

You can also move the playhead to an earlier point in the project, or to the beginning of the project, to hear the new recording in the context of the project.

2 Click the Play button, or press the Space bar.

Recording a Software Instrument with the Cycle Region
As with a Real Instrument, you can record a Software Instrument using a cycle region. When you record a Software Instrument with a cycle region, you can keep recording for as many times as the cycle region repeats. By default, each new cycle is added as a new take. You can change the default behavior in the General pane of GarageBand preferences so that multiple recordings you make using the cycle region are merged into a single take.

For information on recording using a cycle region, see “Recording Multiple Takes with the Cycle Region” on page 42.
Changing Software Instrument Settings

When you create a Software Instrument track, you select an instrument for the track in the New Track dialog. You can change the instrument in the Track Info pane.

To change the instrument for a Software Instrument track:
1. Select the track, then click the Track Info button to open the Track Info pane.
2. Select an instrument category from the list on the left, then select a track instrument from the list on the right.

The output of a Software Instrument is always stereo.

You can also add and adjust effects for a Software Instrument track. For information about using effects, see Chapter 9, “Tutorial 7: Mixing and Adding Effects.”
Viewing Note and Chord Names

When you play a Software Instrument, GarageBand can automatically display the names of the notes and chords you play.

To view Software Instrument note and chord names while you play:

1. Select the header of the Software Instrument track you want to play.

2. Click the icon on the left side of the LCD, then choose Chord from the menu that appears (or click the up or down arrow in the LCD until you see the chord display).

Chord names (also called “chord symbols”) include a capital letter for the root note of the chord, the chord quality (in most cases “ma” for major or “m” for minor), and numbers that indicate added notes, such as sevenths, ninths, or suspended fourths.
You can view and edit Software Instrument regions in standard music notation format. In notation view, you can edit notes and other musical events, including adding pedal markings.

In this tutorial, you’ll learn some basics about music notation. You’ll learn how to:

- View Software Instrument regions as music notation
- Choose the note value for notation view
- Add, select, and edit notes in notation view
- Add pedal symbols
- Change the clef sign
- Print music notation

About Notation View
In addition to the editor’s graphic “piano roll” view, you can view Software Instrument regions (both those you record and those from loops) in notation view. In notation view, the notes in a region are shown as musical notes. Notation view includes other musical symbols such as rests, staves, clef signs, time signatures, key signatures, and pedal markings. This section briefly describes some of these symbols, for users unfamiliar with music notation.

- **Notes**: A musical note has several parts, including the note head and stem. The note head (the round part of the note) indicates the note’s duration (how long the note lasts). Notes of shorter duration (shorter than a quarter note) have flags, and sometimes these notes are joined together by beams. Each note shown below is half as long as the note to its left (from left to right, the notes are whole note, half note, quarter note, and eighth note).
• **Rests:** When you are reading music notation while playing, it is as important to know the space between notes as the notes themselves. The silences between notes are shown by rests. Rests, like notes, have different symbols for different lengths of time, and shorter rests use flags. Each rest shown below is half as long as the rest to its left (from left to right, the rests are half rest, quarter rest, eighth rest, and sixteenth rest).

```
- : : :
```

• **Staves:** The set of five horizontal lines on which the notes appear is called a staff (the plural is staves). The lines of the staff let you see the pitch of the notes from high to low, like a grid. By default, GarageBand shows you two staves, similar to piano notation. This format shows a range of over four octaves, with middle C in the center (between the two staves). Most instruments and voices, except for the lowest bass instruments, fall in this range. You can change notation view to show only a single staff.

• **Clefs:** The symbol at the left edge of each staff is called a clef. Clefs indicate the range of notes that the lines of the staff display. The staves in notation view use the two most common clefs, the treble and bass clef. You can change notation view to show a single clef, either treble or bass.

```
\( \text{\textcopyright\textregistered}\) \( \text{\textcopyright}\) \( \text{\textcopyright}\)
```

• **Key signs:** If the project is in a key other than C, the sharps or flats in the key appear between the clef and the time signature. Sharps are raised a semitone above the natural note (so, for instance, C#—“C sharp”—is a semitone higher than C), and flats are lowered a semitone (so Bb—“B flat”—is a semitone lower than B). The symbols for sharps and flats are shown below, followed by the “natural” symbol that cancels a sharp or flat.

```
# \( \text{\textcopyright\textregistered}\) \( \text{\textcopyright}\) \( \text{\textcopyright}\)
```

• **Bar lines:** The vertical lines extending through both staves show the beginning of each measure (measures are also called bars).
In addition to standard music notation symbols, notation view includes the following features to make working easier:

- **Duration bars:** In addition to the musical note itself, each note has a duration bar that graphically displays the note's duration (the amount of time the note lasts).
- **Beat guides:** In notation view, the beat ruler not only shows measures and beats, but also includes beat guides. Beat guides help you see the exact position of notes in time. A beat guide appears as a small gray circle or dot above each note; when you move a note, the beat guide moves with it to indicate the note's position.

**To view a Software Instrument region in notation view:**

1. In the timeline, select a Software Instrument region.
2. Click the Notation View button (the musical note icon) in the lower-right corner of the editor’s Region area.

In music notation, the position of notes is shown in terms of musical values (note values). When you play music, you might play some notes slightly off the beat (ahead of the beat or behind the beat) to achieve different types of feeling. These small differences are not shown in musical notation.

In notation view, GarageBand shows the position of notes “rounded” to the nearest note value. You can choose the note value to round the display of notes to from the timeline grid menu at the upper-right corner of the editor. Rounding does not change how the note plays; it only changes the display, so that notes slightly out of time are shown at the intended position.

**To choose the note value for notation view:**

- Click the Grid button in the upper-right corner of the editor, then choose a note value from the timeline grid menu.

**Editing Notes in Notation View**

You can edit notes and controller information for a Software Instrument region in notation view, just as you can in graphic view. You can:

- Add notes
- Select notes
- Move notes in time
- Cut and copy notes
- Change the pitch of notes
- Change the duration of notes
• Change the velocity of notes
• Add pedal markings to sustain notes
• Change the clef sign

**Adding Notes**
You add a note by choosing the note value for the note, then clicking in the editor.

In notation view, a square Note Value button appears at the upper-right corner of the Advanced area of the editor. The Note Value button displays a musical note showing the current note value.

**To choose a note value:**
- Click the Note Value button, then choose the note value you want from the menu that appears. You can also Control-click anywhere in the notation display to choose a note value.

**To add a note:**
- In the editor, Command-click at the point you want to add the note.

**Selecting Notes**
Before editing notes in notation view, you must first select them.

**To select a note:**
- Click the note head (the round part of the note). You can select multiple notes by Shift-clicking or by dragging around the notes to enclose them.

**Moving Notes**
You can move notes in time in notation view, in the same way as in the editor’s graphic view.

**To move a note in time:**
- Select the note, then drag it left or right. You can also move selected notes by pressing the Left or Right Arrow keys.

Above each note in the beat ruler is a beat guide. As you move a note, the beat guide moves to help you see the note’s exact position in time.
Copying Notes
You can copy notes in notation view.

To copy a note:
- Option-drag the note head to a new position.

Changing the Pitch of Notes
You can change the pitch of, or transpose, notes in notation view.

To change the pitch of a note:
- Select the note, then drag it up or down. You can also change the pitch of selected notes by pressing the Up or Down Arrow keys.

You hear the note's new pitch as it moves.

Changing the Duration of Notes
When you select a note, a duration bar for the note appears. You can change the note's duration (how long the note lasts) using the duration bar.

To change the duration of a note:
1. Select the note.
2. Drag the right edge of the duration bar left (to shorten the note) or right (to lengthen the note). Duration bars work just like the notes in graphic view.

Deleting Notes
You can delete notes that you no longer want to include in your project.

To delete a note:
- Select the note, then press the Delete key.

Changing Note Velocity
For many Software Instruments, the sound changes depending on the note's velocity. You can change the velocity of notes in notation view, in the same way as in graphic view.

To change a note's velocity:
- Select the note, then drag the Velocity slider left (to lower the velocity) or right (to raise the velocity).
Adding Pedal Symbols

Music notation for piano and some other instruments includes symbols for the sustain pedal. When the sustain pedal is down, the instrument sustains all notes until the pedal is released (up). You can add pedal down and pedal up symbols, which control whether the notes are sustained in GarageBand.

To add pedal down and up symbols:
1  Click the Note Value button and choose the pedal symbol from the menu.
2  Hold down the Command key and place the pointer in the editor at the point where you want the pedal down marker.
3  Press the mouse button.
    The pedal down symbol appears at the current position of the pointer. If you release the mouse button, the pedal up symbol is placed shortly after the pedal down symbol.
4  Without releasing the mouse button, drag to the point where you want the pedal up marker.
5  Release the mouse button.
    The pedal up symbol appears at the current position of the pointer.

To move the pedal up symbol:
1  Click the pedal symbol to select it.
    The pedal down and pedal up symbols become green, indicating that they are selected.
2  Drag the pedal up symbol to its new position, then release the mouse button.
Changing the Clef Sign
By default, when you view a Software Instrument track as music notation, it shows the treble and bass clefs in “piano style.” This format is useful for pianos, synthesizers, and other instruments with a wide range of notes. However, some instruments, particularly solo (single-note) instruments such as strings and winds, can use only a single clef, the treble or bass clef.

You can change the notation view display to show only a single treble or bass clef, and later change it back to the “piano style” two-clef display.

To change the clef sign in notation view:
1 Click the clef (or between the clefs) on the left side of the notation display.
   A menu appears showing the different clefs.
2 Choose a new clef from the menu.

Printing Music Notation
You can print a Software Instrument track as music notation. When you print a track as music notation, the track is printed in a standard layout, with the note values currently displayed and using the clef sign currently shown in notation view. The printed music notation includes the project name as the title, the tempo, and the composer name.

To print a Software Instrument track as music notation:
1 Select the Software Instrument track.
   Make sure the grid for the editor is set to show the correct note values, and that the track is set to show the correct clef sign.
2 Choose File > Print.
3 In the Print dialog, choose the correct settings for your printer, then click Print.
   The Software Instrument track is printed as music notation. The project name appears at the top of the page as the title. The tempo appears in the upper left, and the composer name (as set in GarageBand preferences) appears in the upper right. The measure number appears above the first bar of each stave. If the printed notation requires more than one page, the page number appears centered at the bottom of each page.
Tutorial 6: Arranging and Editing Your Music

You build your projects by arranging and editing regions in the timeline and the editor.

After you’ve added some loops and recordings to your project, you can make changes to the regions in the timeline to start building the arrangement of the project. You can arrange regions in the timeline by cutting, copying, and pasting them; by moving, resizing, and looping them; and by splitting and joining them. You can define and rearrange sections of a project using the arrange track. You can also edit regions in the editor in a variety of ways.

In this tutorial, you’ll learn how to:
• Select a single region or multiple regions
• Copy and paste regions
• Loop, resize, and move regions
• Split and join regions
• Use the arrange track to define different sections and rearrange a project
• Rename regions
• Transpose regions
• Enhance the timing of regions
• Speed regions up or slow them down
• Enhance the tuning of Real Instrument regions
• Set Real Instrument regions to keep their original tempo
• Use the timeline grid to snap regions to measures, beats, and other units of time
• Use Undo and Redo in GarageBand
Arranging Basics

Each time you record music in a Real or Software Instrument track, you create a region in the instrument’s track containing the music you record. When you drag a loop to the timeline, you create a region from the loop. Any changes you make to the region, such as splitting or transposing it, do not change the original recording or loop.

Each type of region appears as a different color in the timeline:
- Purple—Real Instrument regions you record
- Blue—Real Instrument regions created from loops
- Orange—Regions from imported audio files
- Green—Software Instrument regions from both recordings and loops

Regions are the building blocks of a project. You create the flow and build the form of a project by arranging regions in the timeline. Ways you can work with regions in the timeline include copying and pasting, moving and resizing, looping, transposing, and splitting and joining them. In most cases, you can edit different types of regions in exactly the same way. In a few situations you must edit them differently; these exceptions are explained in the following sections.

To make changes to a region, you first select it in the timeline.

To select a region, do one of the following:
- Select a single region by clicking it.
- Select multiple regions by Shift-clicking.
- Drag from a point before the first region to a point after the last one to select the regions in between.

The selected regions appear highlighted in the timeline.

Note: To select regions and perform other actions such as looping and resizing, you may need to zoom in on the region so that it is large enough to select.

You can cut, copy, and paste regions using the standard Mac OS menu commands and keyboard shortcuts.

To cut a region:
- Select the region, then choose Edit > Cut.

To copy a region, do one of the following:
- Select the region, then choose Edit > Copy.
- Option-drag the region.
To paste a region:

- Move the playhead to the point in the timeline where you want the region to start, then choose Edit > Paste.

When you paste a region, the playhead moves to the end of the pasted region. You can paste additional copies of the region, and each one starts at the point in the timeline where the previous one ends.

Moving Regions

You can move a region by dragging it to a new point in the timeline. You can also move a region to another track of the same type as the region. (Real Instrument regions can be moved only to Real Instrument tracks, and Software Instrument regions can be moved only to Software Instrument tracks.)

To move a region:

- Drag the region left or right to a new point in the timeline.
- Drag the region up or down to another track of the same type.

As you move a region, alignment guides appear showing you when the left or right edge of the region is aligned with other objects in the timeline. If you don’t want to use alignment guides, you can turn them off in the General pane of GarageBand preferences.

You can also move regions left to fill the space of a deleted region.

To delete a region and move the following regions left:

1. Select the region you want to delete.
2. Choose Edit > “Delete and Move.”

All following regions on the same track move left by the length of the deleted region.

Two regions cannot overlap in the same track. If you drag a region over part of another region, the region being covered is shortened to the edge of the overlapping region. If one region completely covers another region, the region being covered is deleted from the track.

Try adding a new drum or bass loop to the timeline. Move it so it starts at the end of the one you added earlier, and then loop it to create a new rhythmic groove.

Resizing Regions

You can resize regions by either shortening or lengthening them.

- When you shorten a region, only the visible part of the region plays.
- When you lengthen a region, you add silence (blank space) to its beginning or end.
To resize a region:
1 Move the pointer over the lower half of either edge of the region. The pointer changes to a resize pointer, with an arrow pointing away from the region.
2 Drag the edge of the region to shorten it or lengthen it.

Resizing a region by lengthening adds silence to the region. This can be useful if you want to make copies of the region, each lasting for a certain number of beats.

Note: You can’t lengthen a Real Instrument region beyond its original length. Also, Real Instrument regions containing multiple-take recordings can only be resized from the right edge, not the left. Software Instrument regions with multiple-take recordings can be lengthened to the left, but not shortened.

Looping Regions
You can loop a region so that it repeats over time. When you loop a region, it plays for as much time as you extend it in the timeline.

To loop a region:
1 Move the pointer over the upper half of the right edge of the region. The pointer changes to a loop pointer, with a circular arrow.
2 Drag the edge of the region to the point where you want it to stop playing. The region will loop repeatedly to that point.

When you loop a region, the notches at the top and bottom of the region show the beginning and end of each repetition. You can drag to the end of a repetition or to anywhere in the duration of the loop.

Try looping the drum and bass regions you added to the timeline. Rhythm patterns in most popular music last for some multiple of four measures. For example, the verses and choruses of many popular songs often last for 16 or 32 measures each.
### Splitting Regions

You can split a region in the timeline. Splitting a region lets you start playing the region from a point other than the beginning, or use parts of a region in different places in the timeline.

1. Select the region you want to split.
2. Move the playhead over the point in the region where you want to split it.
3. Choose Edit > Split.

The selected region is split into two regions at the playhead. Only the selected region is split, even if regions in other tracks are under the playhead as well. If multiple regions are selected and are under the playhead, they will all be split.

When you split a Software Instrument region, any notes at the split point are shortened to that point.

### Joining Regions

You can join multiple regions into a single region. To be joined, the regions must be adjacent to each other on the same track, with no space between them.

Real Instrument regions from loops (blue) can’t be joined. Recorded Real Instrument regions (purple) can be joined only to other Real Instrument regions, and Software Instrument regions (green) can be joined only to other Software Instrument regions.

To join regions:

1. Make sure the regions are the same type, on the same track, and adjacent to each other.
2. Select the regions.
3. Choose Edit > Join.

When you join Real Instrument regions, a dialog appears asking if you want to create a new audio file. Click Create to join the regions in a new Real Instrument region.

### Using the Arrange Track

The GarageBand timeline includes an arrange track. You can add arrange regions to the arrange track to define different sections of a project, such as the intro, verse, and chorus. You can also move and copy arrange regions to easily rearrange the sections of your project.

When you move or copy an arrange region, the music in all of the tracks in that section of the project is moved or copied. If any automation curves are active in that section of the project, including the master track, their control points are moved or copied as well.
To show the arrange track:
- Choose Track > Show Arrange Region (or press Command-Shift-A).
  The arrange track appears at the top of the timeline, below the beat ruler.

To add an arrange region:
- Click the small plus sign (+) in the track header area of the arrange track.
  When you add an arrange region, it is four measures long, and has the name “untitled”.

To rename an arrange region:
- Click the name of the region, wait a moment, and then type a new name.

To select an arrange region:
- Click the arrange region.
  You can select multiple adjacent arrange regions by Shift-clicking, but you cannot select arrange regions that are not adjacent. You can select all arrange regions by clicking the track header area of the arrange track.
  When you select an arrange region, it appears light blue, and the section of the project defined by it is highlighted.

To resize an arrange region:
- Drag the right edge of the region until it is the size you want.
  Resizing an arrange region does not affect the music in the timeline.

To move an arrange region:
- Drag it to a different part of the arrange track.

To copy an arrange region:
- Select the region, then choose Edit > Copy. You can also copy an arrange region by holding down the Option key as you drag it.
  If you move or copy an arrange region between two existing arrange regions, the region is inserted between the two existing regions. The region later in time moves (along with all its material) to the point in time where the inserted region ends. This lets you quickly repeat similar sections, for instance verses of a song.
If you move or copy an arrange region to a part of the project that is not empty, arrange regions to the right move right to make room for the region.

If you move or copy an arrange region to an empty part of the timeline, an empty arrange region is created between the last existing arrange region and the one you drag.

If you move or copy an arrange region so that the region moves past the end-of-project marker in the beat ruler, the marker moves to accommodate the region.

To split an arrange region:
1. Move the playhead to the point where you want to split the arrange region.
2. Choose Edit > Split (or press Command-T).

To join arrange regions:
1. Make sure the arrange regions are adjacent.

You can exchange two arrange regions, which exchanges all their material in the timeline. You can also replace all or part of one arrange region with another one.

To exchange two arrange regions:
- Drag one of the arrange regions over the other in the arrange track.

To replace one arrange region with another:
- Hold down the Command key as you drag one arrange region over the other.

When you replace one arrange region with another in this way, the part of the region from the left edge of the region you drag is replaced.

Editing Regions in the Editor
In addition to the changes you make to regions in the timeline, you can edit regions in other ways in the editor. You can rename and transpose regions, enhance the timing of regions, enhance the tuning of Real Instrument regions, and also set whether Real Instrument regions keep their original tempo or follow the project tempo. To make advanced edits like these, you must first show the editor below the timeline.

To show the editor:
- Click the Editor button (with scissors cutting a soundwave).
Renaming Regions
You can rename a region in the editor. Naming a region can help you remember when you recorded it, where in the project it belongs, or what feeling you want it to have.

To rename a region:
1. Select the region in the timeline. You can also double-click the region to select it and open the editor.
   The content of the region appears in the editor. For Real Instrument regions, the audio waveform appears. For Software Instrument regions, the graphic note display appears.
2. Select the text in the Name field, then type the new name in the field.

Transposing Regions
When you add a region to the timeline, the region is matched, or transposed, to the key of the project. In most situations, you’ll want regions to be in the same key as the project. You can transpose a region to a different key when you want the project to temporarily move to a new key, or to create tension between the region and the rest of the project (called dissonance).

To transpose a region:
1. Select the region in the timeline.
2. Drag the Pitch slider to transpose the region higher or lower.
   You can also type the number of semitones you want to transpose the region in the field next to the slider. A semitone is the smallest distance between two musical notes.
   Try adding a new bass loop after the one that you already dragged to the timeline, and then transposing it. The most common transpositions are five and seven semitones up or down, but feel free to try whatever sounds good.

Enhancing the Timing of Regions in a Real Instrument Track
You can enhance the timing of regions in a Real Instrument track. This is especially useful with regions that contain the right notes but that are not perfectly in time with the project’s rhythm.

When you enhance timing, all regions on the selected track (both your own recordings and loops) are enhanced. You can enhance the timing of regions with drums, single-note instruments, and chordal instruments.
To enhance the timing of regions in a Real Instrument track:
1. In the timeline, double-click the track with the regions you want to enhance to open it in the editor.
2. In the editor, drag the Enhance Timing slider to the right to increase the effect of timing enhancement, or drag it left to decrease the effect of enhancement.
3. From the pop-up menu below the Enhance Timing slider, choose the note value to use as the basis for timing enhancement.

Enhanced timing can cause a delay under certain conditions. For example, moving the slider while the project is playing can result in a slight delay as playback “catches up” to the new setting. Also, if enhanced timing is active on a track when you are recording, there may be a short delay between when you play and when you hear the sound. Move the slider to the left to deactivate enhanced timing while recording, and then set the level of enhanced timing when you finish recording.

The Enhance Timing slider may not work equally well with all musical material, especially when set to higher values. Listen carefully to the results of using the slider and set it to the value that sounds best.

If you want timing enhancement to be less than full strength, drag the Enhance Timing slider to the left to set the amount of enhancement.

If you don't like the results after you enhance the timing, choose Nothing from the Enhance Timing pop-up menu to return the selected items to their original timing.

Enhancing the Timing of Items in a Software Instrument Track
You can enhance the timing of the regions in a Software Instrument track. You can enhance the timing of all regions in the track, individual selected regions, or individual notes in a region.

By setting the “Auto Align to” slider and choosing an Enhanced Timing note value before recording regions or notes, you can have the timing of the region be enhanced automatically as you record.

To enhance the timing of items in a Software Instrument track:
1. Double-click the header of the Software Instrument track to open it in the editor.
2. To enhance regions, select the regions in the track you want to enhance. To enhance individual notes, select them in the editor.
3. From the Enhance Timing pop-up menu, choose the note value you want to use to enhance the timing of the selected items.

If you want timing enhancement to be less than full strength, drag the Enhance Timing slider to the left to set the amount of enhancement.

If you don't like the results after you enhance the timing, choose Nothing from the Enhance Timing pop-up menu to return the selected items to their original timing.
Enhancing the Tuning of Regions in a Real Instrument Track
You can enhance the tuning of regions in a Real Instrument track. This is especially useful when you record Real Instrument regions that have the right “feel” and timing but that are not perfectly in tune.

When you enhance a track’s tuning, all regions on the selected track (both your own recordings and loops) are enhanced. Enhancing the tuning can produce accurate results only on single-note (monophonic) Real Instrument regions, so be sure the track does not include regions with chords or unpitched sounds.

By default, the Enhance Tuning slider enhances the tuning of notes by moving them to the closest note on the chromatic (12-note) scale. You can limit the enhancement to the notes of the project’s key (as chosen in the Track Info pane for the master track) by selecting the “Limit to key” checkbox.

To enhance the tuning of a Real Instrument track:
1 In the timeline, double-click the Real Instrument track you want to enhance to open it in the editor.
2 Drag the Enhance Tuning slider right to increase the amount of tuning enhancement, or drag it left to decrease the amount of enhancement.
3 To limit tuning enhancement to the chromatic scale, rather than the project’s key, deselect the “Limit to key” checkbox below the slider.

You hear the results immediately as the project plays.

Setting the Enhance Tuning slider to higher values can sometimes lead to undesirable results. Listen carefully to the results of using the slider and set it to the value that sounds best.

Setting Real Instrument Regions to Follow Their Original Tempo and Pitch
By default, Real Instrument recordings (purple) and Real Instrument loops (blue) in the timeline follow the project tempo and key. You can set a Real Instrument region to keep its original tempo and pitch instead.

To set a Real Instrument region to follow its original tempo and pitch:
1 In the timeline, select the Real Instrument region.
2 Open the editor.
3 Deselect the Follow Tempo & Pitch checkbox.

If you decide you want the region to follow the project tempo and key, select the region, then select the Follow Tempo & Pitch checkbox.
The Follow Tempo & Pitch checkbox is unavailable when an audio file (orange), a Real Instrument loop tagged as a “one-shot,” or a Software Instrument region (green) is selected. You can convert a Software Instrument loop to a Real Instrument loop when you add it to the timeline, and then set the Real Instrument loop to keep its original tempo.

**Using Undo and Redo**

As you build your arrangement in the timeline, you might want to undo or redo some of the changes you make. If you decide you don’t like the last change you made to a project, you can usually undo it. After undoing it, if you decide you like the project better with the change, you can redo it.

You can also use the Undo and Redo commands as a quick way of trying out changes to a project. You can make several changes to the project, and then step back through the changes using Undo. If you change your mind after undoing a step, you can recover the changes using Redo. You can undo or redo any number of actions since the last time you saved. At any point, you can save a new version of the project by choosing File > Save As.

To undo the last change:
- Choose Edit > Undo.

To redo the last change:
- Choose Edit > Redo.
GarageBand puts a complete recording studio on your desktop so you can mix your projects and add professional-sounding effects.

In this tutorial, you’ll learn some basics about mixing and effects. You’ll learn how to:
• Set track volume levels and pan position
• Set the master volume
• Add a fade-out at the end of a project
• Add and adjust track effects
• Graphically edit the Visual EQ effect
• Edit and save effect presets
• Add dynamic changes using automation curves

What Is Mixing?
When you’ve built the arrangement of your project, the next step is to mix the project. Mixing is when you step back and listen to the overall sound of the music, and make changes to tracks and the project to balance the different parts, bring the music into focus, and give it the right “sound.”

Mixing typically consists of the following steps:
• Balancing volume levels
• Setting pan positions
• Adding effects to enhance and color the sound
• Creating dynamic changes with automation curves
**Basic Mixing**

The most basic steps in mixing are balancing the volume level of different tracks, setting track pan positions, and setting the master volume.

**Setting Track Volume Levels**

The instruments and loops you use in your project may have different volume (loudness) levels. To hear all the parts you've added, you balance the volume levels so that no track overwhelms the others, and no track is lost in the mix.

This doesn't mean that every track should be set to the same volume level. In commercial mixes, certain tracks (typically the lead vocals, drums, and lead or solo instruments) are louder, while other tracks (the backing instruments and vocals) are softer.

**To set a track’s volume level:**

- In the track’s header, drag the volume slider left to lower the volume level, or drag it right to raise the volume level.
- Hold the Shift key as you drag to set the volume level in finer increments.

**Setting Track Pan Positions**

Setting different tracks to different positions in the stereo field (panning) helps make it easier to distinguish tracks in the mix, and creates a sense of three-dimensional space in your project.

In commercial music, the most important tracks (typically the lead vocals, drums, and lead or solo instruments) are panned to the center or close to center, while other tracks (the backing instruments and vocals) are panned left and right. Panning tracks no farther than 50 percent left or right creates a natural sense of space; in contrast, panning tracks to the extreme left or right creates a more unusual, artificial sound.

**To set a track’s pan position:**

- In the track’s header, drag the pan dial left to pan the track farther to the left, or drag it right to pan the track farther to the right. You can also click along the edge of the dial to set it to a specific position.

*Note:* Dragging inside the pan dial lets you set the pan position in more precise values.
Setting the Overall (Master) Volume
You can set the master volume of a project using the master volume slider, located to the right of the LCD. You should adjust the master volume to a level high enough to eliminate background noise, but not high enough to cause clipping.

Important: The master volume slider controls the volume of the project when it is exported. Use your computer’s volume control to adjust the volume at which you listen to the project play.

To set the master volume:
- Drag the master volume slider left to lower the output volume, or right to raise the output volume. Option-click the slider to return it to a neutral value (0 decibel gain).
- Before you export, play the project from start to finish, watching the master level meters located above the master volume slider. Make sure the small red dots to the right of the level meters are not lit.

These dots (called clipping indicators) light to show that the volume level of the project at some point is too high, which will cause distortion or “clipping” in the exported project.

Adding a Fade-Out
A very common mixing technique is having all the music gradually become softer, or “fade out,” at the end of a song. You can easily add a fade-out to the end of a project.

To add a fade-out:
- Choose Track > Fade Out.

The master track appears at the bottom of the timeline, showing the automation curve for master volume. When you choose Fade Out, control points are added to the master volume automation curve so that it gradually fades to silence over the last 10 seconds of the project (the last 10 seconds before the end-of-project marker).

Now play the project from a point before the fade-out begins. You’ll hear all the tracks in the project fade out gradually to their final volume level.
Adding Effects to a Project
Effects let you shape and enhance the sound of your music in a variety of ways. Anyone who’s listened to popular music on the radio, or listened to the soundtrack of a movie, has heard the different effects used in contemporary music. GarageBand includes a complete set of studio-quality effects that you can use on individual tracks or the overall project to shape the sound of your music.

Types of Effects
GarageBand includes the following types of effects:

Equalization (EQ): EQ is a powerful and versatile effect that lets you change the level of selected frequencies. You can use EQ to make both subtle and dramatic changes to your projects. EQ is likely the most commonly used effect in popular music.

GarageBand includes a special type of EQ called Visual EQ. You can use Visual EQ by choosing an EQ preset, but you can also edit the effect graphically, making it easy to see what part of the sound you are changing.

Dynamics: Dynamics effects, which include compressors and noise gates, let you control the volume of your music over time.

Reverb and Echo: Reverb and echo are both time-based effects. Time-based effects store a copy of the sound and play it back later in time, creating a sense of space.

Modulation: Modulation effects, which include chorus, flangers, and phasers, build on the time-based effects by shifting or modulating when the copied signal plays back. They can also involve detuning the copied signal relative to the original.

Distortion: Distortion effects, which include amp simulation and overdrive (and, of course, distortion), change the tone of the original sound to recreate analog or digital distortion.

Other effects: Other effects included with GarageBand, such as tremolo and Auto Filter, change the sound in different ways.

Adding Effects to a Track
Each Real and Software Instrument track has a set of effects, which include a compressor, Visual EQ, echo, and reverb. You can adjust a track’s effects, and add up to four additional effects, in the Track Info pane. Real Instrument tracks also include a gate (noise gate) effect.

The master track includes its own effects. You can adjust the master effects and add one additional effect to the master track in the Track Info pane.
To add an effect:
1 Click the Track Info button (the letter i) or choose Track > Show Track Info to show the Track Info pane.
2 If needed, click the Details triangle to show the Effects section of the Track Info pane.
3 Choose the effect you want to add from one of the pop-up menus along the left. Instrument tracks have four effect pop-up menus, and the master track has one.

Turning Effects On and Off
You can turn individual effects on or off (turning an effect off temporarily is called bypassing the effect). This has several advantages: you can hear how each effect changes the sound of your music, and you can see which effects have the greatest impact on your computer’s performance.

When you turn off an effect, the effect’s current settings are retained, so any adjustments you have made are not lost.

To turn on an effect:
- In the Effects section of the Track Info pane, select the checkbox next to the effect. Deselect the checkbox to turn the effect off.
Adjusting Effects Settings
Each effect has a slider that you can use to adjust the amount of the effect, or a pop-up menu from which you can choose different effect presets.

To adjust a track’s effects:
1 Select the track, then click the Track Info button to open the Track Info pane.
2 Click the Details triangle to reveal the track’s effects settings.
3 Drag the sliders for the Gate, Echo, and Reverb effects to adjust the amount of each effect. Choose a new preset from the Visual EQ pop-up menu to adjust the equalizer, and choose a new preset from the Compressor pop-up menu to adjust the compressor. If your project is playing, you hear the changes in real time.
4 Choose an effect from one of the effect pop-up menus on the left, then choose an effect preset for the effect from the preset pop-up menu on the right.

Additional effects you can add include treble reduction, bass reduction, amp simulation, chorus, flanging, phase shifting, and tremolo. The available effects are listed in the effect pop-up menu, including any third-party Audio Units effects you have installed on your computer.

Creating and Saving an Effect Preset
Some effects include several presets, which let you easily adjust the effect’s settings together to achieve a particular sound.

To choose an effect preset:
- Choose the preset you want from the pop-up menu to the right of the effect.

You can adjust effect presets to fine-tune the sound of the effect, and save your own presets to use with other instruments or in another project.

To edit an effect preset:
1 Click the Edit button (with the pencil icon) to the right of the effect’s preset pop-up menu.

The effect’s Preset window appears. Each preset setting has a slider, button, or other control, which is labeled to indicate its purpose.

2 Drag the sliders in the Preset window to adjust the settings for the preset.

When you adjust an effect preset, it appears as “Manual” in the pop-up menu, so you know you’ve changed it from the original preset. You can go back and forth between your manual settings and other presets to compare them before saving the new preset. You can create your own effect presets and save them to use on another track or in another project.
To edit the Visual EQ effect graphically:
1. Click the Edit button to the right of the Visual EQ effect’s preset pop-up menu.

   The Preset window for the Visual EQ appears. In the center of the window is the graphic editing area, divided into four bands: Bass, Low Mid, High Mid, and Treble.

2. Place the pointer in one of the four bands in the editing area. Drag the pointer left or right to change the frequency for that band. Drag it up or down to change the gain (how much the frequencies are boosted or cut).

3. To see the numeric values for each band, click the Details triangle. You can adjust values numerically by dragging them up or down.

4. To see the frequency curve for the track in real time, select the Analyzer checkbox, then play the track.

To save an effect preset:
1. Adjust the settings for the preset to get the sound you want.

2. Choose Make Preset from the pop-up menu, then type a name for the preset in the Save dialog.

Creating Changes over Time with Automation Curves
Creating changes over time is called automation. You can add automation curves to tracks in GarageBand, including the master track, and use them to create volume, pan, and other changes.

To show a track’s automation curves:
- Click the triangle to the right of the Solo button in the track’s header.

   A row appears below the track, showing the volume automation curve.
To choose the automation curve you want to edit:

- From the pop-up menu on the left side of the track's automation row, choose the parameter you want to edit.

Now you can automate the parameter by adding control points to the curve, and then dragging the control points to change their value at that point in time.

To add a control point:

- Click the line in the editor at the point in time where you want to add a control point.

  Note: Adding a control point activates the curve if it is not already active. The square button becomes colored to show that the curve is active.

To adjust a control point, do one of the following:

- Drag the control point up or down to a new value.
- Drag the control point left or right to move it to a different point in time.

You can use the vertical lines in the row to align control points with measures and beats in the timeline.

For Real and Software Instrument tracks, you can automate Track Volume and Track Pan. For the master track, you can automate Master Volume, Master Pitch, and Master Tempo. You can also automate parameters for any effect on a track (including the master track) by adding an automation curve for the parameter.

To add an automation curve for an effect parameter:

1. From the pop-up menu on the left side of the track's automation row, choose Add Automation.

   A menu appears, listing all the effects on the track.

2. Click the disclosure triangle for the effect with the parameter you want to automate.

3. Select the checkbox for the parameter you want to automate. You can select multiple parameters.

4. When you are done, click OK.

   The parameter appears in the pop-up menu, and the automation curve switches to show the automation for the last selected effect parameter.

   You can also lock automation control points to regions, so that when you move the region in the timeline, the control points move with it.
To lock automation control points to regions:

- Choose Control > “Lock Automation Curves to Regions.”

All control points are locked to the region corresponding to the automation curve.

The following conditions apply to locking control points to regions:

- Shortening or lengthening a region has no effect on its control points.
- Deleting a region deletes its control points as well.
- If you overlap a region containing control points with another region, both the control points as well as the region are shortened.
- If you drag a region containing no control points over part of a track containing control points, the control points are locked to the new region.
- Looping a region does not loop its control points—instead, copy the region.

To delete an automation curve for an effect parameter:

1. From the pop-up menu on the left side of the track’s automation row, choose Add Automation.
2. When the menu appears, deselect the checkbox for the parameter you want to delete. You can select multiple parameters.
3. When you are done, click OK.

Note: When you delete an automation curve, all the control points on that curve are also deleted. This cannot be undone.
You can create audio and video podcasts in GarageBand, and then send them to iWeb to publish over the Internet.

Podcasts are like radio or TV shows that people can download over the Internet. Users can download an individual podcast episode or subscribe to a podcast series. You can create podcast episodes in GarageBand, and then publish them on the Internet using iWeb or another application.

You can create several different kinds of podcasts in GarageBand:
- **Audio podcast episodes** contain an audio file.
- **Enhanced podcast episodes** contain audio along with markers, artwork, and URLs.
- **Video podcast episodes** contain a movie and can also contain audio.
- **Enhanced video podcast episodes** contain a movie along with audio, markers, and URLs.
In this lesson, you'll learn how to:

- Create audio and video podcasts
- Find and import media files using the Media Browser
- Show the podcast and movie tracks
- Add and edit markers and marker regions
- Add artwork, URLs, URL titles, and chapter titles to markers
- Add episode artwork and episode information
- Edit marker region and episode artwork
- “Duck” backing tracks to make narration and dialogue easier to hear

Creating an Enhanced Podcast Episode
You create an enhanced podcast episode in GarageBand by creating a podcast project, recording your narration, adding podcast sounds and other audio, adding markers, artwork, URLs, and chapter titles, adding episode artwork and information, and ducking backing tracks.

Creating a Podcast Project
1. Open GarageBand, or if it is open, close the current project.

   The GarageBand screen appears.

2. Click Create New Podcast Episode.

   A new, blank podcast project appears in the GarageBand window. In a podcast project, the podcast track appears above the other tracks in the timeline. The Media Browser opens, and the editor shows the marker list, with columns for the start time, artwork, chapter title, URL title, and URL for each marker. Podcast projects include tracks for male and female voices, jingles (musical background tracks), and radio sounds.

   **Note:** A project can have either a podcast track or a movie track, but not both. If you try to show the podcast track for a project that contains a movie track, a dialog appears asking if you want to replace the movie track with a podcast track.

Recording the Podcast Audio
You can create podcasts with only spoken narration or dialogue, or add musical backing tracks, sound effects, and other sounds. You record narration in a Real Instrument track. The podcast project includes two Real Instrument tracks, named Male Voice and Female Voice optimized for recording spoken narration or dialogue.
To record podcast narration or dialogue:

1. Select either the Male Voice or Female Voice track by double-clicking its track header. The Track Info pane opens, showing the track settings.

2. From the Input Source pop-up menu, choose the appropriate input source for the microphone you are using to record your narration or dialogue.

3. Choose “On with Feedback Protection” from the Monitor pop-up menu to hear the sound from the microphone, but with protection from feedback.

4. Move the playhead to the point where you want to start recording.

5. Click the Record button, then start speaking.

6. When you are done recording, click the Play button.

You can add and adjust effects for the narration track, including the Speech Enhancer effect, which is especially useful for recording narration and dialogue using the built-in microphone on your computer. For more information about recording in a Real Instrument track, see Chapter 5, “Tutorial 3: Recording Vocals and Musical Instruments.”

Adding Podcast Sounds

GarageBand includes a set of sounds designed for you to use in podcasts. You can access these sounds, which include jingles, stingers, and sound effects, in the loop browser in podcast sounds view. Podcast sounds view features a different set of keyword buttons so you can easily find and add podcast sounds. You find loops in podcast sounds view in the same way as in button view.

To search for loops in podcast sounds view:

1. If the loop browser is closed, click the Loop Browser button to open it.

2. Click the podcast button (with the radiating sound wave) in the lower-left corner of the loop browser to switch to podcast sounds view.

3. Click a keyword button to show matching loops in the results list. The columns in the results list show the loop name and length for each loop.
   
   For jingles, note that there are several versions of some jingles, of different lengths.

4. To refine your results, click multiple keyword buttons. This narrows the matching loops to only those that match all of the selected keywords.

5. Click a loop to preview it in the loop browser.

6. To end a search, either click the selected keyword again to deselect it, or click the Reset button to deselect all selected keywords.

For more information about searching for loops, see “Tutorial 2: Adding Apple Loops” on page 30.
Importing Media Files
You can import media files from other iLife applications, including iTunes and iPhoto, into a podcast project. You can also import other GarageBand projects that have been saved with an iLife preview. You can find and preview media files in the Media Browser. You can also add other folders to the Media Browser, so you can add media files in the folders to your projects.

To find and preview media files in the Media Browser:
1. Click the Media Browser button (the icon shows different types of media), or choose Control > Show Media Browser.
   The Media Browser opens to the right of the timeline.
2. Do one of the following:
   a. Click the Audio button to view files in the iTunes library, as well as other GarageBand projects.
   b. Click the Photos button to view files in the iPhoto library.
   c. Click the Movies button to view files in the Movie folder on your hard drive.
3. In the Media Browser, navigate to the folder containing the files you want to use. You can also search for files by name by typing in the search field.

To preview audio files and movies in the Media Browser, do one of the following:
   • Select the file in the media list, then click the Play button at the bottom of the Media Browser.
   • Double-click the file in the media list.
The file starts playing.

To stop preview playback:
• Click the Play button in the Media Browser again.

To import an audio file:
• Drag the audio file from the Media Browser to the timeline.

To add a folder to the Media Browser:
• Drag the folder from the Finder to the middle area of the Media Browser.

Adding Music
You can add musical Apple Loops and record Real and Software Instruments to add music to your podcast, as you do with a music project. For information about adding Apple Loops, see “Tutorial 2: Adding Apple Loops” on page 30. For information about recording Real Instruments, see “Tutorial 3: Recording Vocals and Musical Instruments” on page 39. For information about recording Software Instruments, see “Tutorial 4: Playing and Recording Software Instruments” on page 47.
Adding and Editing Markers
You can add markers to a podcast, making it an enhanced podcast. When you add a marker to a podcast, it appears in the podcast track as a marker region. Marker regions show how long the artwork or URLs you add to a marker last. You can move them or resize them to change their duration.

To add a marker:
1 Move the playhead to the place where you want to add the marker.
2 Click the Add Marker button.

The marker appears in the editor, and the start time for the marker appears in the Time column in the marker's row. The marker also appears as a marker region in the podcast track. As with other regions in the timeline, you can edit marker regions to control when artwork and URLs appear and how long they are visible when you play the podcast.

To move a marker region, do one of the following:
• In the podcast track, drag the marker region to a new position.
• In the editor, click the start time for the marker region and enter a new start time.

To resize a marker region:
• Drag either the left or right edge of the marker region to the point where you want to resize it.

You can’t loop a marker region.

Adding Marker Region Artwork
You can add artwork to individual marker regions. When you play the podcast, the marker region artwork appears from the start to the end of the marker region.

To add artwork to a marker region:
1 Open the Media Browser, then click the Photos button.
2 In the Media Browser, locate the artwork you want to add.
3 Drag the artwork from the Media Browser to the Artwork box in the marker’s row in the editor. You can also drag artwork directly to the podcast track, which adds a new marker region with the artwork.

The artwork appears in the marker region in the podcast track and in the Artwork column for the region in the editor. The Displays Artwork checkbox is selected. You can change the artwork for a marker by dragging a new image to the Artwork column in the marker’s row.

Adding a URL to a Marker
You can add a URL to a marker and give the URL a title. When you play the podcast, the URL is visible from the start to the end of the marker region. When you click the URL, your web browser opens and displays the webpage for the URL.

To add a URL to a marker:
1 In the editor, click the placeholder text in the URL column of the marker’s row, then type the URL.

The Displays URL checkbox is selected for the marker.

2 In the editor, click the placeholder text in the URL Title column of the marker’s row, then type the title.

When you add a URL title, the title appears in place of the actual URL when you play the podcast, but clicking the title opens your web browser to the webpage for the URL.

Adding Chapter Titles
You can add a chapter title to a marker, making it a chapter marker. When you play the movie in iTunes, iDVD, or QuickTime Player, you can easily move back and forth between chapters.

To add a chapter title to a marker:
- In the editor, select the placeholder text in the Chapter Title column of the marker’s row, then type a title.

Deleting Markers
You can delete a marker if you decide you no longer want it in your podcast.

To delete a marker, do one of the following:
- In the podcast track, select the marker region, then press the Delete key.
- In the editor, select the marker in the marker list, then press the Delete key.
Adding Episode Artwork
You can add episode artwork to the podcast track. When you play the podcast in iTunes or view it in iWeb, the episode artwork is visible whenever there is no marker region with its own artwork.

To add episode artwork:
1 In the Media Browser, locate the artwork you want to add.
2 Drag the artwork from the Media Browser to the Episode Artwork well in the editor.
   The episode artwork appears in the Episode Artwork well. When you play the podcast, the episode artwork appears when there is no marker region with artwork.

Editing Artwork
You can resize and crop both marker region and episode artwork. In the image editor, you can resize and crop your artwork to show all or part of the original image.

To edit artwork:
1 Double-click artwork in either the Episode Artwork well or the marker list.
   The image editor opens, showing the artwork.
2 Drag the size slider to resize the artwork as large or small as you want. The black square shows what part of the artwork will be displayed when you play the podcast.
3 Drag the artwork so that the part you want to display is within the borders of the square.
4 You can replace the artwork by dragging a new image to the image editor.
5 When you are finished, click Set.

Editing Episode Information
Each podcast episode can contain information, including the episode title, author, and description. An episode can also have a parental advisory, which appears when you play the podcast in iTunes.

To edit episode information:
1 Select the podcast track.
2 Open the Track Info pane by choosing Track > Show Track Info.
   The Track Info pane appears, showing the Episode Info pane.
3 To give the podcast episode a title, click the Title field, then type a title.
4 To add artist information, click the Artist field, then type the artist’s name.
5 Choose None, Clean, or Explicit from the Parental Advisory pop-up menu.
6 To include a description of the podcast episode, click the Description field, then type a description.
Ducking Backing Tracks
When you are creating a podcast, you may sometimes want to lower the volume of backing tracks to hear spoken narration or dialogue more easily. Lowering the volume of some tracks to make others easier to hear is called ducking.

You apply ducking by setting which tracks are lead tracks and which are backing tracks. Whenever there is sound on a lead track, the volume of the backing tracks is lowered while the volume of all other tracks stays the same. You can apply ducking to any Real or Software Instrument track in your podcast.

To make a track a lead track:
1  Choose Control > Ducking.
   A ducking control appears in each track’s header, with arrows pointing up and down.
2  Click the upper part of the track’s ducking control (the arrow pointing up).

To make a track a backing track:
1  Choose Control > Ducking.
   A ducking control appears in each track’s header, with arrows pointing up and down.
2  Click the lower part of the track’s ducking control (the arrow pointing down).

When you play the project, send it to iWeb, or export it, the backing tracks are ducked whenever there is sound on any lead track. You can adjust the amount of ducking (volume reduction) on these tracks by choosing a different Ducker preset in the Track Info pane for the master track.

To adjust the amount of ducking:
1  Open the Track Info pane.
2  Click Master Track, then click the Details triangle.
3  Choose a different preset from the Ducker preset menu. The preset names suggest what they are useful for.
   You can also click the Edit button for the Ducker, and create your own preset by moving the sliders.
Creating Video Podcasts and Movie Projects

Creating a video podcast is similar to creating an audio podcast, except that the video podcast includes a video file and does not include artwork. You can import an iMovie project or other QuickTime-compatible video file, view the video as you add audio, add and edit markers, and send the finished movie (containing both video and audio) to iDVD to burn to a DVD or send it to iWeb to publish as a video podcast. You can also export it as a QuickTime movie.

When you have created your video podcast in GarageBand, you can send it to iWeb or export it and publish it using another application.

Importing a Movie or Video File

You can import an iMovie project or other video file from the Media Browser. The Media Browser lets you quickly locate iMovie projects and other video files in your computer’s Movies folder, as well as other media files. For information about finding and importing iMovie projects and video files using the Media Browser, see “Importing Media Files” on page 84.

When you import a movie, the file appears in the movie track, beginning at the start of the project. You can’t change the position of the movie in a project.

Note: A project can contain only one movie or video file. If you import a movie into a project that already contains one, a dialog appears asking if you want to replace the existing movie with the new one.

Viewing the Movie

When you import a movie into a project, the movie track appears at the top of the timeline, showing still frames from the movie. The Track Info pane appears in place of the Media Browser, with a video preview at the top where you can view the movie as you play the project.

To show the movie track and video preview:

- Choose Track > Show Movie Track.

You can hide the movie track and video preview by choosing Track > Hide Movie Track.

Working with the Movie’s Audio Track

If the movie contains an audio track, a new Real Instrument track named Movie Sound is created below the movie track for the movie’s audio. You can edit the Movie Sound track exactly as you would edit any Real Instrument track: you can mute or solo it, adjust the volume level and pan position, and add effects.

Note: If you mute the Movie Sound track, the movie’s audio will not be included when you send the movie to iDVD or iWeb or when you export it as a QuickTime movie.
Adding Audio
You can record narration in a video podcast in exactly the same way as in an audio podcast. You can add audio files from the loop browser, including both musical and podcast sounds loops. You can also record in Real and Software Instrument tracks, in exactly the same way as in other GarageBand projects.

For more information, see “Adding Podcast Sounds” on page 83, “Importing Media Files” on page 84, and “Adding Music” on page 85.

Adding Markers, Titles, and URLs to a Video Podcast
Markers make it easy to navigate to different parts of the finished movie, and let you add links to webpages. You can add markers to a video podcast project, and add URLs and chapter titles to markers, in exactly the same way as in enhanced audio podcasts. However, you cannot add artwork to a video podcast.

For more information, see “Adding and Editing Markers” on page 86, “Adding a URL to a Marker” on page 87, and “Adding Chapter Titles” on page 87.

After your podcast is finished, there are several ways you can share it with others. For information about sharing podcasts, see the next tutorial, Chapter 11, “Tutorial 9: Sharing Your Projects.”
After you create your project in GarageBand, there are several ways you can share your music.

You can send projects to other iLife applications, such as iTunes, iWeb, and iDVD, or export them to disk. You can also burn a song to a CD.

Sharing Music Projects
You can send a music project to an iTunes playlist. In iTunes, you can listen to the song, download it to an iPod, or burn the playlist to a CD.

To send a song to an iTunes playlist:
- Choose Share > “Send Song to iTunes.”

You can set the name of the iTunes playlist to which files will be exported, and also set the name of the album and composer, in the Export pane of GarageBand preferences.

You can also send a single track, or a group of tracks, to an iTunes playlist. To send a single track, solo the track (or mute all other tracks) before sending the song to iTunes. To send a group of tracks, solo the tracks (or mute all other tracks) before sending the song to iTunes.

To export a song as an audio file:
1. Choose Share > “Export Song to Disk.”
2. In the Export dialog, click Share.

When you export a song to disk, by default the song is exported as an uncompressed AIFF audio file. You can also export it as a compressed audio file. You can choose the type of file and the audio quality.
To export a song as a compressed audio file:
1  Choose Share > “Export Song to Disk.”
2  In the Share dialog, select the Compress checkbox.
   The window expands, showing the Compress Using and Audio Settings pop-up menus.
3  Choose the type of compressed file you want to export from the Compress Using pop-
   up menu.
4  Choose the audio quality you want from the Audio Settings pop-up menu.
5  Click Share.
   You can also burn a single song to a recordable audio CD.

To burn a song to a CD:
1  Insert a blank recordable CD in your computer’s optical drive.
2  Choose Share > “Burn Song to CD.”
   The Burn dialog appears.
3  To choose additional settings, click the triangle in the upper-right corner of the Burn
   dialog.
4  When you are ready, click Burn.
   The song is burned onto the CD.
   Only one song can be burned to a CD using the “Burn Song to CD” menu command. To
   burn multiple songs to a CD, send the songs to an iTunes playlist, and then burn the
   playlist to a CD in iTunes.

Sharing Podcasts
You can share audio and enhanced podcast episodes in several ways. When you share
or export a podcast, you must choose AAC Encoder in the Compress Using pop-up
menu to share or export the podcast as an enhanced podcast.

To send a podcast to iWeb:
- Choose Share > “Send Podcast to iWeb.”
  When you send a podcast to iWeb, you can use iWeb to publish it on the Internet.

To send a podcast to an iTunes playlist:
- Choose Share > “Send Podcast to iTunes.”
To export a podcast to disk:

1. Choose Share > “Export Podcast to Disk.”

When you export a podcast, it is exported as a compressed file. You can change the compression and audio quality settings in the Share dialog.

Note: The choices in the Audio Settings menu are different for podcasts than for songs.

To burn a podcast to a CD:

1. Insert a blank recordable CD in your computer’s optical drive.
2. Choose Share > “Burn Song to CD.”
   The Burn dialog appears.
3. To choose additional settings, click the triangle in the upper-right corner of the Burn dialog.
4. When you are ready, click Burn.
   The podcast is burned onto the CD.

Sharing Video Podcasts

There are several ways you can share video podcasts and other projects containing movies or video. You can send a project containing both video and audio to iDVD so you can burn it to a DVD disc. Viewers watching the DVD can use the chapter markers in the project to move to different parts of the movie. URLs and URL titles will not appear in the movie on DVD.

To send a movie to iDVD:

- Choose Share > “Send Movie to iDVD.”

Note: When you send a project to iDVD, no video compression is applied to the project. In most cases, you’ll want to make these changes in iDVD.

You can send a video podcast to iWeb, and publish it on the Internet. When subscribers view the video podcast, they can click a URL to have a relevant webpage appear in their web browser, and move back and forth between chapters. You send a video podcast to iWeb in just the same way as an audio podcast.

You can also export a project containing a video as a QuickTime movie (.mov). When you export a project as a movie, the exported movie includes both the video and the soundtrack you created in GarageBand. The video’s audio is also included unless the Video Sound track is muted when you export the movie.
To export a project as a QuickTime movie:

- Choose Share > “Export Movie to Disk.”

The project is exported using the current movie compression settings. Movie compression settings compress both the video and audio in the exported movie. You can change the compression settings to suit how you want to use the exported movie. Compression settings are stored as part of the GarageBand project until you change them while the project is open.

To choose the video compression settings:

1. Choose GarageBand > Preferences, then click Export.
2. In the Export pane, choose the settings you want to use from the Movie Settings pop-up menu.

To burn a movie’s audio track to a CD:

1. Insert a blank recordable CD in your computer’s optical drive.
2. Choose Share > “Burn Movie to CD.”
   The Burn dialog appears.
3. To choose additional settings, click the triangle in the upper-right corner of the Burn dialog.
4. When you are ready, click Burn.
   The audio track of the movie is burned onto the CD.

Exporting Projects at the Optimum Loudness

You can have GarageBand automatically export projects at the optimum loudness; that is, at the highest volume level possible without adding distortion. Setting a project to the optimum volume level is called “auto-normalizing.”

To export projects at the optimum volume level:

1. Choose GarageBand > Preferences, and then click Advanced.
2. Select the Auto Normalize checkbox.

   The Auto Normalize feature does not affect the volume level when you play the project in GarageBand. It affects the volume level only when you export the project.
## Keyboard Shortcuts

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Navigation/Moving the playhead</strong></td>
<td></td>
</tr>
<tr>
<td>Play/Pause</td>
<td>Space bar</td>
</tr>
<tr>
<td>Go to beginning</td>
<td>Home or Z</td>
</tr>
<tr>
<td>Go to end</td>
<td>End or Option-Z</td>
</tr>
<tr>
<td>Move back (the amount depends on zoom level)</td>
<td>Left Arrow</td>
</tr>
<tr>
<td>Move forward (the amount depends on zoom level)</td>
<td>Right Arrow</td>
</tr>
<tr>
<td>Move back in larger increments</td>
<td>Option-Left Arrow</td>
</tr>
<tr>
<td>Move forward in larger increments</td>
<td>Option-Right Arrow</td>
</tr>
<tr>
<td>Move back by the visible width of the timeline</td>
<td>Page Up</td>
</tr>
<tr>
<td>Move forward by the visible width of the timeline</td>
<td>Page Down</td>
</tr>
<tr>
<td>Zoom out</td>
<td>Control-Left Arrow</td>
</tr>
<tr>
<td>Zoom in</td>
<td>Control-Right Arrow</td>
</tr>
<tr>
<td><strong>Tracks</strong></td>
<td></td>
</tr>
<tr>
<td>Create new track</td>
<td>Command-Option-N</td>
</tr>
<tr>
<td>Duplicate track</td>
<td>Command-D</td>
</tr>
<tr>
<td>Delete selected track</td>
<td>Command-Delete</td>
</tr>
<tr>
<td>Select next higher track</td>
<td>Up Arrow</td>
</tr>
<tr>
<td>Select next lower track</td>
<td>Down Arrow</td>
</tr>
<tr>
<td>Mute/Unmute selected track</td>
<td>M</td>
</tr>
<tr>
<td>Solo/Unsolo selected track</td>
<td>S</td>
</tr>
<tr>
<td>Show/Hide track automation curve</td>
<td>A</td>
</tr>
<tr>
<td>Lock track</td>
<td>L</td>
</tr>
<tr>
<td>Show/Hide arrange track</td>
<td>Command-Shift-A</td>
</tr>
<tr>
<td>Show/Hide master track</td>
<td>Command-B</td>
</tr>
<tr>
<td>Show/Hide podcast track</td>
<td>Command-Shift-B</td>
</tr>
<tr>
<td>Show/Hide movie track</td>
<td>Command-Option-B</td>
</tr>
<tr>
<td>Turn ducking on/off</td>
<td>Command-Shift-R</td>
</tr>
</tbody>
</table>
## Appendix A

### Keyboard Shortcuts

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Track Info pane</strong></td>
<td></td>
</tr>
<tr>
<td>Show/Hide Track Info</td>
<td>Command-I</td>
</tr>
<tr>
<td>Select next higher category or instrument</td>
<td>Up Arrow (when Track Info pane is open and either a category or an instrument is selected)</td>
</tr>
<tr>
<td>Select next lower category or instrument</td>
<td>Down Arrow (when Track Info pane is open and either a category or an instrument is selected)</td>
</tr>
<tr>
<td>Move from instrument column to category column</td>
<td>Left Arrow (when Track Info pane is open and an instrument is selected)</td>
</tr>
<tr>
<td>Move from category column to instrument column</td>
<td>Right Arrow (when Track Info pane is open and a category is selected)</td>
</tr>
<tr>
<td><strong>Arranging and editing</strong></td>
<td></td>
</tr>
<tr>
<td>Undo</td>
<td>Command-Z</td>
</tr>
<tr>
<td>Redo</td>
<td>Command-Shift-Z</td>
</tr>
<tr>
<td>Cut</td>
<td>Command-X</td>
</tr>
<tr>
<td>Copy</td>
<td>Command-C</td>
</tr>
<tr>
<td>Paste</td>
<td>Command-V</td>
</tr>
<tr>
<td>Delete</td>
<td>Delete</td>
</tr>
<tr>
<td>Select all</td>
<td>Command-A</td>
</tr>
<tr>
<td>Split region</td>
<td>Command-T</td>
</tr>
<tr>
<td>Join selected regions</td>
<td>Command-J</td>
</tr>
<tr>
<td>Snap to grid</td>
<td>Command-G</td>
</tr>
<tr>
<td>Show/Hide alignment guides</td>
<td>Command-Shift-G</td>
</tr>
<tr>
<td>Delete Arrange region with timeline content and close</td>
<td>Command-Option-Delete</td>
</tr>
<tr>
<td>Lock automation curves to regions</td>
<td>Command-Option-A</td>
</tr>
<tr>
<td>Delete selected region and fill in time</td>
<td>Control-Delete</td>
</tr>
<tr>
<td>Add marker to podcast/movie track</td>
<td>P</td>
</tr>
<tr>
<td><strong>Recording</strong></td>
<td></td>
</tr>
<tr>
<td>Record Start/Stop</td>
<td>R</td>
</tr>
<tr>
<td>Turn cycle region on/off</td>
<td>C</td>
</tr>
<tr>
<td>Turn metronome on/off</td>
<td>Command-U</td>
</tr>
<tr>
<td>Turn count in on/off</td>
<td>Command-Shift-U</td>
</tr>
<tr>
<td>Action</td>
<td>Shortcut</td>
</tr>
<tr>
<td>------------------------------------</td>
<td>---------------------------</td>
</tr>
<tr>
<td><strong>Notation view</strong></td>
<td></td>
</tr>
<tr>
<td>Move selected notes to previous</td>
<td>Left Arrow</td>
</tr>
<tr>
<td>grid position</td>
<td></td>
</tr>
<tr>
<td>Move selected notes to next</td>
<td>Right Arrow</td>
</tr>
<tr>
<td>grid position</td>
<td></td>
</tr>
<tr>
<td>Move selected notes back one</td>
<td>Shift-Left Arrow</td>
</tr>
<tr>
<td>measure</td>
<td></td>
</tr>
<tr>
<td>Move selected notes forward one</td>
<td>Shift-Right Arrow</td>
</tr>
<tr>
<td>measure</td>
<td></td>
</tr>
<tr>
<td>Transpose selected notes up a</td>
<td>Up Arrow</td>
</tr>
<tr>
<td>semitone</td>
<td></td>
</tr>
<tr>
<td>Transpose selected notes down a</td>
<td>Down Arrow</td>
</tr>
<tr>
<td>semitone</td>
<td></td>
</tr>
<tr>
<td>Transpose selected notes up an</td>
<td>Shift-Up Arrow</td>
</tr>
<tr>
<td>octave</td>
<td></td>
</tr>
<tr>
<td>Transpose selected notes down an</td>
<td>Shift-Down Arrow</td>
</tr>
<tr>
<td>octave</td>
<td></td>
</tr>
<tr>
<td><strong>Adjusting master volume</strong></td>
<td></td>
</tr>
<tr>
<td>Raise master volume</td>
<td>Command-Up Arrow</td>
</tr>
<tr>
<td>Lower master volume</td>
<td>Command-Down Arrow</td>
</tr>
<tr>
<td><strong>Showing windows and editors</strong></td>
<td></td>
</tr>
<tr>
<td>Show track mixer</td>
<td>Command-Y</td>
</tr>
<tr>
<td>Show Track Info pane</td>
<td>Command-I</td>
</tr>
<tr>
<td>Show loop browser</td>
<td>Command-L</td>
</tr>
<tr>
<td>Show Media Browser</td>
<td>Command-R</td>
</tr>
<tr>
<td>Show editor</td>
<td>Command-E</td>
</tr>
<tr>
<td>Show Tuner in LCD</td>
<td>Command-F (with a Real</td>
</tr>
<tr>
<td></td>
<td>Instrument track selected)</td>
</tr>
<tr>
<td>Show Chords in LCD</td>
<td>Command-F (with a Software</td>
</tr>
<tr>
<td></td>
<td>Instrument track selected)</td>
</tr>
<tr>
<td>Show Time in LCD</td>
<td>Command-Shift-F</td>
</tr>
<tr>
<td>Show Measures in LCD</td>
<td>Command-Option-F</td>
</tr>
<tr>
<td>Show Tempo in LCD</td>
<td>Command-Control-F</td>
</tr>
<tr>
<td>Show onscreen keyboard</td>
<td>Command-K</td>
</tr>
<tr>
<td>Show Musical Typing window</td>
<td>Command-Shift-K</td>
</tr>
<tr>
<td><strong>File menu functions</strong></td>
<td></td>
</tr>
<tr>
<td>New</td>
<td>Command-N</td>
</tr>
<tr>
<td>Open</td>
<td>Command-O</td>
</tr>
<tr>
<td>Close</td>
<td>Command-W</td>
</tr>
<tr>
<td>Save</td>
<td>Command-S</td>
</tr>
<tr>
<td>Save As</td>
<td>Command-Shift-S</td>
</tr>
<tr>
<td><strong>Action</strong></td>
<td><strong>Shortcut</strong></td>
</tr>
<tr>
<td>-----------------------------------</td>
<td>-------------------------</td>
</tr>
<tr>
<td>Application menu functions</td>
<td></td>
</tr>
<tr>
<td>Show GarageBand Preferences</td>
<td>Command-comma (,)</td>
</tr>
<tr>
<td>Hide GarageBand</td>
<td>Command-H</td>
</tr>
<tr>
<td>Hide other applications</td>
<td>Command-Option-H</td>
</tr>
<tr>
<td>Quit GarageBand</td>
<td>Command-Q</td>
</tr>
<tr>
<td>Help menu functions</td>
<td></td>
</tr>
<tr>
<td>GarageBand Help</td>
<td>Command-question mark (?)</td>
</tr>
</tbody>
</table>
Connecting Music Equipment to Your Computer

If you sing or play a musical instrument, you can connect a musical instrument or a microphone to your computer and record your performances in your GarageBand projects.

Each recording appears as a region in a track in the timeline. You can add effects to the track, and edit the region in the editor.

Connecting a Musical Instrument or Microphone
You can connect an electric musical instrument or microphone to your computer and record it in a Real Instrument track.

You can connect a microphone to your computer using the computer’s audio input port, if your computer has one. You can also connect an audio interface to your computer, and then connect instruments and microphones to the audio interface for recording. Audio interfaces are available in a variety of compatible formats, including USB, FireWire, PCI, and PC card formats. You can also connect an audio mixer or console to your computer, and record microphones or instruments through the mixer.

If you use an audio interface to connect musical instruments, check the manufacturer’s specifications to make sure the interface is compatible with Mac OS X 10.2.6 or later. Also make sure the audio interface uses a format supported by your computer. Follow the manufacturer’s instructions, which may include installing the correct driver on your computer.

If you connect an instrument or microphone to your computer’s audio input port, open System Preferences and click Sound, click the Input tab, select Line In in the sound input list, and then drag the Input volume slider to set the input level.
Connecting a Music Keyboard to Your Computer
If you play a keyboard instrument, you can connect a MIDI-compatible music keyboard to your computer to play and record Software Instruments.

To connect a music keyboard to play Software Instruments:
• If the keyboard is a USB MIDI keyboard, connect the USB cable to the keyboard and to your computer.
• If the keyboard is a standard MIDI keyboard, connect the keyboard to a MIDI interface using standard MIDI cables, and connect the interface to your computer.

Be sure to follow the instructions that came with the keyboard, which may include installing the correct driver on your computer.

Connecting Other Music Equipment
You might also want to connect speakers or monitors to your computer to hear your projects play back with greater audio quality than is possible from your computer’s speaker. A variety of monitors and speakers are available, including speakers you can connect directly to your computer’s audio out port, through a USB port, or using an audio interface.

If you connect an audio interface to your computer, you set the audio interface as the audio input device for GarageBand. Before setting the audio input device, be sure to install any necessary driver software for the audio interface.

To set an audio interface as the audio input device:
1 Choose GarageBand > Preferences, then click Audio/MIDI.
2 In the Audio/MIDI pane, choose the audio interface from the Audio Input pop-up menu.

If you connect a microphone, an instrument, or other audio device directly to your computer’s audio input port, you may need to configure input settings for it in the Sound pane of System Preferences.

To configure input settings in System Preferences:
1 Choose Apple  > System Preferences, then click Sound.
2 In the Sound pane, click the Input button.
3 Select Line In from the sound input devices list, then drag the Input volume slider to set the input level.