GarageBand
Getting Started
Includes a complete tour of the GarageBand windows, plus step-by-step lessons on working with GarageBand
## Contents

### Preface
- About GarageBand Getting Started
- What's New In GarageBand
- Before You Begin

### Chapter 1
- GarageBand at a Glance
- GarageBand Window
- Timeline
- Editor
- For Real Instruments
- For Software Instruments–Graphic View
- For Software Instruments–Notation View
- Loop Browser
- Button View
- Column View
- Track Info Window
- Real and Software Instrument Tracks
- Master Track

### Chapter 2
- Working With Songs
- Creating a Song
- Setting the Tempo
- Setting the Time Signature
- Setting the Key
- Setting the Scale
- Opening an Existing Song
- Saving the Song
- Saving a Song as an Archive
- Exporting a Song to an iTunes Playlist

### Chapter 4
- Using Apple Loops
- Finding Loops With the Loop Browser
- Finding Loops in Button View
- Finding Loops in Column View
- Previewing Loops in the Loop Browser
30  Refining Your Searches
30  Displaying Loops From a Jam Pack or Folder
31  Searching by Scale Type
31  Limiting Searches to Nearby Keys
31  Searching for Specific Text
32  Adding Loops to the Timeline
33  Creating Your Own Apple Loops
33  Adding Loops to the Loop Library

Chapter 5 34  Working in the Timeline
34  About Regions
35  Selecting Regions
35  Cutting, Copying, and Pasting Regions
35  Looping Regions
36  Resizing Regions
36  Moving Regions
37  Transposing Regions
37  Fixing the Timing of Software Instrument Regions
38  Splitting Regions
38  Joining Regions
39  Renaming Regions
39  Using the Timeline Grid
39  Using Undo and Redo

Chapter 6 41  Working With Real Instruments
41  Adding a Real Instrument Track
41  Monitoring Real Instrument Input
42  Getting Ready to Record
42  Recording a Real Instrument
43  Recording a Real Instrument With the Cycle Region
44  Recording Multiple Real Instrument Tracks
45  Changing Real Instrument Settings
45  Changing the Instrument
46  Changing the Input Channel
46  Adjusting Input Volume
46  Using the Instrument Tuner
47  Adding an Audio File from the Finder

Chapter 7 48  Working with Software Instruments
48  Using Musical Typing
49  Using the Onscreen Music Keyboard
50  Adding a Software Instrument Track
50  Getting Ready to Record
Chapter 8  Working in the Editor
53  Selecting Regions
53  Editing Real Instrument Regions
54  Moving Real Instrument Regions
54  Cropping Part of a Real Instrument Region
54  Joining Real Instrument Regions
54  Enhancing the Tuning of Real Instrument Tracks
55  Enhancing the Timing of Real Instrument Tracks
56  Editing Software Instrument Regions
56  Editing Notes in a Software Instrument Region
57  Editing Controller Information in a Software Instrument Region

Chapter 9  Working In Notation View
58  About Notation View
60  Editing Notes In Notation View
61  Adding Notes
61  Selecting Notes
61  Moving Notes
61  Copying Notes
61  Changing the Pitch of Notes
62  Changing the Duration of Notes
62  Deleting Notes
62  Changing Note Velocity
62  Adding Pedal Down and Pedal Up Symbols

Chapter 10  Mixing and Adding Effects
64  What Is Mixing?
64  Setting Track Volume Levels
65  Setting Track Pan
65  Using Volume and Pan Curves
66  Setting the Output Volume
66  Adding Fade Ins and Fade Outs
67  Transposing the Song to a Different Key
67  Using Effects
68  Types of Effects
68  Adding Effects
69  Adjusting Effects
70  Turning Effects On and Off
70  Choosing Effect Presets
Contents

70 Editing Effect Presets
71 Saving Effect Presets

Appendix A 72 Keyboard Shortcuts

Appendix B 75 Connecting Music Equipment To Your Computer
75 Connecting a Musical Instrument or Microphone
76 Connecting a Music Keyboard to Your Computer
76 Connecting Other Music Equipment
Welcome to GarageBand Getting Started. This document gives you useful information and step-by-step instructions for creating songs with GarageBand.

The following chapters give you a tour of the GarageBand windows and a series of lessons to help you create your own songs. The chapters in GarageBand Getting Started cover the following topics:

- “GarageBand at a Glance” provides a tour of the windows and controls in GarageBand.
- “Working With Songs” describes how to create a new song, as well as how to save, archive, and export your songs.
- “Using Apple Loops” describes how to find and preview Apple Loops in the loop browser, add them to the timeline, and create your own Apple Loops.
- “Working in the Timeline” describes how to build your song by arranging regions in the timeline.
- “Working With Real Instruments” describes how to add a Real Instrument track, turn on monitoring, set the input channel and format, record a Real Instrument, and change Real Instrument settings.
- “Working with Software Instruments” describes how to add a Software Instrument track, record a Software Instrument, and change Software Instrument settings.
- “Working in the Editor” describes the different ways you can edit Real and Software Instrument regions.
- “Working In Notation View” describes how to view Software Instrument regions as music notation, and how to edit notes, note velocity, and pedal markings in notation view.
- “Mixing and Adding Effects” describes the steps to follow in mixing your song, and how to use the effects included with GarageBand.

GarageBand Getting Started also includes appendixes listing keyboard shortcuts and describing how to connect music equipment to your computer.
What’s New In GarageBand

• You can import MIDI, Apple Lossless, and Sony ACID files into a GarageBand song. MIDI files are imported as Software Instrument regions, Apple Lossless files are imported as Real Instrument regions, and ACID files are imported as Real Instrument loops.

• You can view Software Instrument regions in notation view in the editor. Notation view displays notes, chords, and other musical events in standard music notation. You can also edit notes and controller information, including pedal markings.

• You can record up to eight Real Instruments and one Software Instrument at the same time with an appropriate audio interface connected to your computer.

• You can save both Real and Software Instrument regions you record as Apple Loops, and add your own Apple Loops to the loop browser so you can use them in other songs.

• If you have one or more Jam Packs installed on your computer, you can choose to show only the loops from a specific Jam Pack, or only those included with GarageBand, in the loop browser.

• Musical Typing turns your computer keyboard into a music keyboard so that you can play and record Software Instruments. You can control what octave you play in, and control velocity and other controller information (including mod wheel, pitch bend, and sustain) of the notes you play.

• You can add a pan curve to a Real or Software Instrument track, and add control points to change the track’s pan position over time. Pan curves work in exactly the same way as volume curves.

• You can transpose (change the pitch of) a song to a different key, to add interest and variety to your songs. When you transpose a song using the master pitch curve, Real and Software Instrument regions (both your recordings and loops) are transposed to the new key.

• You can enhance the tuning of Real Instrument tracks that have the right rhythmic feel, but are not perfectly in tune, with the Enhance Tuning slider, located in the Real Instrument editor.

• You can enhance the timing of Real Instrument tracks containing the right notes, but which are not perfectly in time, with the Enhance Timing slider, located in the Real Instrument editor.

• You can check the tuning of any Real Instrument using the built-in instrument tuner. This is especially useful with guitars, basses, and other instruments that may need regular retuning.

• GarageBand features new Software Instruments, including two new synthesizers, Hybrid Basic and Hybrid Morph. You can use these synthesizers, which are based on waveforms, to create rich, complex sounds.

• GarageBand features new effects, including a gender-shifting voice effect, new guitar amp simulations, and bass amp simulations.
Before You Begin
To make it easier to follow the lessons as you work, print each lesson before you start.

In many of the tasks shown in this document you need to choose menu commands. In the lessons, and in GarageBand Help, menu commands appear like this:

Choose Edit > Join Selected.

The first term after Choose is the name of the menu in the GarageBand menu bar. The term (or terms) following the angle bracket are the items you choose from that menu.
“GarageBand at a Glance” introduces you to the features and controls in the GarageBand windows. You use these controls to create your songs in GarageBand.

Take a look at these pages even if you don’t plan to complete the lessons in the following chapters, because knowing the names and functions of the GarageBand controls will make it easier to find answers to your questions in GarageBand Help.

The pages that follow introduce you to the main GarageBand window—including the timeline, the loop browser, and the editor—and to the Track Info window. You record Real and Software Instruments, add loops, and arrange and mix your songs in the main window, and change track instrument, effects, and input settings in the Track Info window.
GarageBand Window

A  **Track headers:** The instrument icon and name are shown on the left of each track's header. Click the name to type a new track name. Click the Record button (with the red circle) to turn on the track for recording. Click the Mute button (with the speaker icon) to silence the track. Click the Solo button (with the headphone icon) to hear the track by itself. Click the Lock Track button to lock the track. Click the triangle to show the track's volume curve.

B  **Track mixer:** Drag the pan dial to adjust the pan position of the track (the left-to-right placement in the stereo field). Drag the volume slider to adjust the track's volume. Watch the level meters to see the track's volume level as you record and play.

C  **Timeline:** Contains the tracks where you record Real and Software Instruments, add loops, and arrange regions. Also includes the beat ruler, which you use to move the playhead and align items in the timeline with beats and measures. See “Timeline” on page 12 for a description of the features and controls in the timeline.

D  **Zoom slider:** Drag the zoom slider to zoom in for a closer view of part of the timeline, or to zoom out to see more of the timeline.

E  **Add Track button:** Click to add a track below the existing tracks in the timeline.

F  **Track Info, Loop Browser, and Editor buttons:** Click to open the Track Info window, loop browser, or editor.

G  **Transport controls:** Click the Record button to start recording. Click the Play button to start or stop the song playing. Click the Go to Beginning, Rewind, or Fast Forward buttons to move the playhead to different parts of the song. Click the Cycle button to turn the cycle region on or off.
**Timeline**

The timeline contains the tracks where you record Real and Software Instruments, add loops, and arrange regions.

**A** Beat ruler: Shows beats and measures, the units of musical time in the timeline. You can click the beat ruler to move the playhead to a specific point in the timeline.

**B** Tracks: You record Real and Software Instruments in tracks, and drag loops to tracks to add them to a song. You arrange the song by working with regions in the tracks in the timeline.

**C** Playhead: Shows the point in the song currently playing, or the point where playback starts when you click the Play button. Also shows where cut and copied items are pasted in the timeline. You can move the playhead to change what part of the song is playing.

**D** Timeline Grid button: Choose a note value for the timeline grid, or choose Automatic to have the value change when you zoom in or out.

**E** Volume and pan curves: Add a volume or pan curve to a track, then add and adjust control points on the volume or pan curve to add dynamic changes to different parts of a song.

**H** Time display/instrument tuner: The time display shows the playhead's position in musical time (measures, beats, ticks) or absolute time (hours, minutes, seconds, fractions). Drag or double-click the numerals to enter a new playhead position.

The right side of the time display shows the song's tempo. Click and hold the tempo, then drag the slider to set a new tempo.

You can also show the instrument tuner in the time display window, and use it to check the tuning of a Real Instrument connected to your computer.

**I** Master volume slider and level meters: Drag the volume slider to adjust the song's master output volume level. Watch the level meters to see if clipping is occurring before you export a song.
### Regions
When you record a Real Instrument or Software Instrument, or add a loop, you create a region in the timeline. You can cut, copy, and paste regions, loop and resize them, move and transpose them, and make other changes to build the arrangement of the song.

### Master track
You can change the sound of the overall song by adding effects or a volume curve to the master track. You can also add a pitch curve to the master track to transpose parts of your song to a different key.

### Playhead Lock button
Click to unlock the playheads in the timeline and the editor, so that you can see different parts of the song in the editor and the timeline.

### Scroll bars
Drag the horizontal scroll bar to move to a different part of a song. Drag the vertical scroll bar to see tracks not currently visible.
Editor

The editor is like a microscope showing a close-up view of part of a track. You can edit Real and Software Instrument regions in a variety of ways in the editor.

For Real Instruments

When you select a Real Instrument track, the editor shows the waveform of the track or selected region. You can move, crop, join, transpose, and rename regions in the editor.

A Region Name field: Type a new name for the selected region in the field.
B Region Pitch slider and field: Drag the slider to transpose the selected Real Instrument region up or down by up to 12 semitones. You can also type the number of semitones in the field.
C Zoom slider: Drag to zoom in for a closer view or to zoom out to see more of the track or selected region. Zooming in the editor is independent of the timeline.
D Beat ruler: Shows beats and measures for the area visible in the editor.
E Playhead: Shows the point in the song currently playing.
F Waveform display: Shows the waveform of the regions in the track.
G Enhance Tuning slider and checkbox: Drag right to increase the amount of tuning enhancement, or drag left to lower the amount. The “Limit to key” checkbox limits tuning enhancement to the song’s key.
H Enhance Timing slider and pop-up menu: Drag right to increase the amount of timing enhancement, or drag left to lower the amount. Choose the note value to use and the basis for timing enhancement from the pop-up menu.
I Scroll bar: Drag the scroll bar to move to a different part of the track.
For Software Instruments—Graphic View

When you select a Software Instrument track, the editor shows a graphic display of the track or selected region. You can edit individual notes in Software Instrument regions, fix the timing of notes, and transpose and rename regions. You can also show and edit controller data for pitch bend, a modulation wheel, or a sustain pedal, recorded when you play your music keyboard.

A  Region Name field: Type a new name for the selected region in the field.

B  Region Pitch slider and field: Drag the slider to transpose the selected Software Instrument region up or down by up to 36 semitones. You can also type the number of semitones in the field.

C  Velocity slider and field: Drag the slider to change the velocity of selected notes. You can also type the velocity value in the field. A note's velocity reflects how hard the key is pressed when you play the note.

D  Zoom slider: Drag to zoom in for a closer view or to zoom out to see more of the track.

E  Graphic/Notation View buttons: Click to change the editor to graphic view or notation view.

F  Display pop-up menu: Choose whether to show notes or controller data in the editor.

G  Fix Timing button: Click to fix the timing of notes in the selected region, or notes selected in the editor, so that notes move to the nearest grid position.

H  Beat ruler: Shows beats and measures for the area visible in the editor.

I  Playhead: Shows the point in the song currently playing.

J  Notes/controller data display: Shows the individual notes of Software Instrument regions in a graphic format. You can move and resize notes to adjust their pitch, where they start playing, and how long they play. Shows controller data when chosen in the Display pop-up menu.

K  Scroll bar: Drag the scroll bar to move to a different part of a track.
For Software Instruments—Notation View

You can also view Software Instrument tracks and regions in notation view. In notation view, notes and other musical events are shown in standard music notation. You can edit notes and edit controller information (including velocity and pedal markings for sustain) in notation view.

A  Region Name field: Type a new name for the selected region in the field.

B  Region Pitch slider and field: Drag the slider to transpose the selected Software Instrument region up or down by up to 36 semitones. You can also type the number of semitones in the field.

C  Velocity slider and field: Drag the slider to change the velocity of selected notes. You can also type the velocity value in the field. A note's velocity reflects how hard the key is pressed when you play the note.

D  Zoom slider: Drag to zoom in for a closer view or to zoom out to see more of the track.

E  Graphic/Notation View buttons: Click to change the editor to graphic view or notation view.

F  Note value button: Click to choose the note value for notes you add.

G  Fix Timing button: Click to fix the timing of notes in the selected region, or notes selected in the editor, so that notes move to the nearest grid position.

H  Beat ruler: Shows beats and measures for the area visible in the editor.

I  Playhead: Shows the point in the song currently playing.

J  Notation display: Shows the musical events of Software Instrument regions in standard music notation. You can move notes to adjust their pitch and where they start playing, and change how long they play.

K  Scroll bar: Drag the scroll bar to move to a different part of a track.
**Loop Browser**

The loop browser lets you quickly find loops to add to your songs. You can find loops using keywords for instrument, musical genre, or mood. You can also perform text searches, and refine your results in several ways. The loop browser shows the tempo, key, and number of beats for each matching loop. You can preview loops in the loop browser before you add them to a song, and add more loops to GarageBand by dragging them onto the loop browser.

The loop browser gives you two ways to find loops: button view and column view.

**Button View**

In button view, the loop browser contains a set of keyword buttons. Click a button to show matching loops in the results list. Clicking multiple buttons narrows the results to those loops that match all of the selected keywords.

---

A **Keyword buttons:** Click a keyword button to display matching loops in the results list. You can click multiple keyword buttons to narrow your results.

B **View buttons:** Click the column button to show column view, or click the grid button to show button view.

C **Scale type pop-up menu:** Choose a scale type to see only loops using that musical scale.

D **Search text field:** Type text in the field to see loops with the text in their file name or path.

E **Preview volume slider:** Drag the slider to adjust the volume of the loop being previewed.

F **Results list:** Shows loops that match the selected keywords. Also displays the tempo, key, and number of beats for each loop. Click a loop in the results list to preview it. Click the Favs checkbox for a loop to add it to your favorites.

G **Loop library pop-up menu:** Choose the loops you want to show in the loop browser from the pop-up menu.
Column View
In column view, the loop browser features columns for keyword type, categories, and keywords. Click a keyword type to show categories for that type, click a category to show keywords, then click a keyword to show matching loops in the results list. Clicking multiple keywords expands the results to those loops matching any of the selected keywords.

A **Keyword type column:** Click a keyword type to show the categories for that keyword type in the middle column.

B **Category column:** Click a category to show keywords for that category in the right column.

C **Keyword column:** Click a keyword to show matching loops in the results list. You can click multiple keywords to expand your results.

D **View buttons:** Click the column button to show column view, or click the grid button to show button view.

E **Scale type pop-up menu:** Choose a scale type to see only loops using that scale.

F **Search text field:** Type text in the field to see loops with the text in their file name or path.

G **Preview volume slider:** Drag the slider to adjust the volume of the loop being previewed.

H **Results list:** Shows the loops that match the selected keywords. Also displays the tempo, key, and number of beats for each loop. Click a loop in the results list to preview it. Click the Favs checkbox for a loop to add it to your favorites.
Chapter 1  GarageBand at a Glance

**Track Info Window**
The Track Info window shows the current instrument, effects, and input settings for the selected track, or the master effects settings for the master track. You can change these settings in the Track Info window.

**Real and Software Instrument Tracks**
Some controls in the Track Info window are different for Real Instrument tracks than for Software Instrument tracks (as noted below).
A Instrument category list: Click an instrument category to see the instruments for that category in the instrument list on the right.

B Instrument library pop-up menu: Choose which instruments you want to see in the category and instrument lists from the pop-up menu.

C Instrument list: Click an instrument from the list.

D Instrument icon pop-up menu: Click to choose an instrument icon from the icon menu.

E Details triangle: Click to show the instrument and effects settings.

F Effect checkboxes, sliders, and pop-up menus: Click an effect checkbox to turn the effect on or off. Drag the sliders to adjust the level of the effects, or choose an item from the pop-up menus. The Track Info window includes the following effects for Real and Software Instruments:
   • Noise gate slider (Real Instrument tracks only): Drag the slider to adjust the amount of gating.
   • Generator and generator preset pop-up menus (Software Instrument tracks only): Choose an instrument generator, and generator preset, from the menus.
   • Compression slider: Drag the slider to adjust the amount of compression.
   • Equalizer pop-up menu: Choose an EQ setting from the pop-up menu.
   • Effect and effect setting pop-up menus: Click a checkbox to turn additional effects on or off. Choose an effect from a pop-up menu on the left, then choose an effect preset from the pop-up menu on the right.
   • Echo slider: Drag the slider to adjust the amount of echo.
   • Reverb slider: Drag the slider to adjust the amount of reverb.

G Input channel pop-up menu and buttons (Real Instrument tracks only): Choose the input channel or channels for the instrument from the Input pop-up menu. Drag the Volume slider to set the input volume for the selected channel. Choose whether monitoring is on or off from the Monitor pop-up.

H Effect edit buttons: Click to show an effect’s preset window, where you can edit the effect preset.

I Save Instrument and Delete Instrument buttons: Click the Save Instrument button to save an instrument. Click the Delete Instrument button to delete a saved instrument.
Master Track
The Track Info window for the master track shows the global song settings and effects settings for the overall song. Global song settings include tempo, time signature, and key. Global effects settings include echo, reverb, equalizer, and compressor settings.

The Echo and Reverb sliders for individual tracks control the amount of echo and reverb that are sent to the global echo and reverb effects. In the Track Info window for the master track, you can change the global echo and reverb presets that control the sound of these effects.

A Master effects category list: Click a category to see the effects for that category in the master effects list on the right.
B Instrument library pop-up menu: Choose which instruments you want to see in the category and instrument lists from the pop-up menu.
C Master effects list: Click a set of master effects from the list.
D Tempo slider: Drag the slider to change the song’s tempo.
E Time pop-up menu and field: Choose a time signature from the pop-up menu, or enter a number in the field.
F Key pop-up menu: Choose a key from the pop-up menu.
G  **Details triangle:** Click to show the global effects settings.

H  **Effect checkboxes, pop-up menus, and slider:** Click an effect checkbox to turn the effect on or off. Choose an item from the pop-up menus, or drag the slider, to adjust an effect. The Track Info window includes the following effects for the master track:

- **Echo pop-up menu:** Choose a global echo preset.
- **Reverb pop-up menu:** Choose a global reverb preset.
- **Effect and effect setting pop-up menus:** Click a checkbox to turn an additional effect on or off. Choose an effect from a pop-up menu on the left, then choose an effect preset from the pop-up menu on the right.
- **Equalizer pop-up menu:** Choose a global equalizer setting from the pop-up menu.
- **Compression slider:** Drag the slider to adjust the amount of global compression.

I  **Effect edit buttons:** Click to show an effect’s preset window, where you can edit the effect preset.

J  **Save Master and Delete Master buttons:** Click the Save Master button to save a set of master effects. Click the Delete Master button to delete a saved set of master effects.
Songs are the documents that hold your music and all the changes you make. You can create and save songs, save a song as an archive, and export a song to iTunes.

Each song has a tempo, a time signature, and a key, which last for the entire length of the song. When you create a song, you set the tempo, time signature, and key in the New Project dialog. You can save a song as an archive, and export a song to an iTunes playlist.

Creating a Song
You start working in GarageBand by creating a new song.

To create a new song:
1 Choose File > New Project.
2 In the New Project dialog, browse to the location where you want to store the song, then type a name for the song in the name field.
3 Set the song's tempo, time signature, and key as described in the following sections.

**Setting the Tempo**
Each song has a speed, or tempo. The tempo defines the rate at which beats, the basic rhythmic pulse, occur in the song. The tempo is measured in beats per minute, or bpm. You can set the tempo to any speed between 60 and 240 bpm. The default tempo is 120 bpm, which is a common tempo used in popular music.

**To set the tempo:**
- In the New Project dialog, drag the Tempo slider left to slow down the tempo, or right to speed up the tempo.

*Note:* You can change the tempo later in the Time display, or in the Track Info window for the master track.

**Setting the Time Signature**
Each song also has a time signature, which controls the relationship between beats and measures. A song’s time signature consists of two numbers separated by a forward slash, which look similar to a fraction. The number on the left controls the number of beats in each measure, and the number on the right controls the beat value (the length of the note that gets one beat).
You can use any of the following time signatures in a GarageBand song: 2/2, 2/4, 3/4, 4/4, 5/4, 7/4, 6/8, 7/8, 9/8, or 12/8. The default is 4/4, the most commonly used time signature.

To set the time signature:
- In the New Project dialog, choose a time signature from the Time pop-up menu.
  
  Note: You can change the time signature later in the Track Info window for the master track.

Setting the Key
Each song has a key, which defines the central note to which the other notes in the music relate, and the scale used (either “major” or “minor”).

To set the key:
1. In the New Project dialog, choose a key from the Key pop-up menu.
2. Choose the scale from the pop-up menu to the right of the Key pop-up menu.
  
  Note: You can change the key later in the Track Info window for the master track.

If you change the key of a song after recording instruments or adding loops, all Software Instrument recordings and loops are transposed to the new key. Real Instrument recordings are not transposed.

Setting the Scale
Along with the key, each song uses a particular scale. The most common scales are the major and minor scales.

To set the key:
- In the New Project dialog, choose a scale from the Scale pop-up menu.

Opening an Existing Song
You can open an existing song to continue working.

To open an existing song:
1. Choose File > Open, locate and select the song you want to open, then click OK.

You can also open a recently open song by choosing File > Open Recent and selecting a song from the shortcut menu.

If you close the currently open song, GarageBand displays a window asking if you want to create a new song or open an existing song.
**Saving the Song**
As you work, it’s important to save your song often so you don’t lose your changes.

**To save a song:**
- Choose File > Save (or press Command-S).

**Saving a Song as an Archive**
You can also save a song as an archive. When you save a song as an archive, all the audio files, loops, and other media the song uses are saved in the song file. This is especially useful in case you want to copy the song to another computer, or are duplicating a song with your own Real Instrument recordings.

**To save a song as an archive:**
- Choose File > Save as Archive.

**Exporting a Song to an iTunes Playlist**
You can export a song to an iTunes playlist, then play your exported songs in iTunes, download them to an iPod, or burn the playlist to a CD. Files are exported to iTunes in AIFF format. You can convert the exported file to another format, such as AAC or MP3, from within iTunes.

**To export a song to an iTunes playlist:**
- Choose File > Export to iTunes. The entire song, from the beginning (measure 1) to the end of the last region, is exported.

If the cycle region is turned on when you export the song, the part of the timeline from the start to the end of the cycle region is exported.

You can set the name of the iTunes playlist to which files will be exported, and also set the name of the album and composer, in the Export pane of GarageBand Preferences.

You can also export a single track, or a group of tracks, to an iTunes playlist. To export a single track, solo the track (or mute all other tracks) before exporting. To export a group of tracks, solo the tracks (or mute all other tracks) before exporting.
You can use Apple Loops to add backing and rhythm tracks to your songs. You can also add Apple Loops to your loop library, and create your own Apple Loops.

Most popular music today is based on repeating rhythmic patterns (sometimes called “grooves” or “riffs”), especially in the drum and bass parts. To create a song in a groove-based style, an effective way of working is to add loops for the drum parts, then add loops for bass and other rhythm parts. This lets you define the rhythmic feel of the song, and also lets you build the basic arrangement of the song by blocking out sections with different grooves. Once the basic rhythm parts are in place, you can record Real and Software Instrument regions to add lead, solo, and harmony parts.

You can quickly define the feel of a song by adding Apple Loops. Apple Loops are prerecorded music files designed to seamlessly repeat a rhythmic pattern. When you add a loop to the timeline, you can extend it to fill any amount of time, making it easy to create drum parts and other rhythm parts.

When you add a loop to a song, GarageBand matches the loop’s tempo and key to the tempo and key of the song. This lets you use loops that were originally recorded at different speeds, and in different keys, and have them sound as though they were made to be played together.

**Finding Loops With the Loop Browser**

GarageBand includes a loop browser that lets you find loops by musical instrument, genre, or mood. You can also perform text searches, and refine your searches for loops in several other ways. No matter how large your collection of loops becomes, you can quickly find loops with the sound you want using the loop browser.

**To show the loop browser:**
- Click the Loop Browser button (the button with the open eye).
The loop browser has two views: button view and column view. In button view, you click keyword buttons to show loops that match the keywords. In column view, you choose from different keyword types, categories, and keywords to show matching loops. In the lower-left corner of the loop browser are two view buttons you use to select button or column view.

To choose button view or column view:
- Click the column button to show column view, or click the grid button to show button view.

Finding Loops in Button View
Button view features a grid of keyword buttons. You click a button to see the loops matching the keyword in the results list to the right. You can narrow your results by clicking multiple buttons.

To find loops in button view:
1. Click the grid button in the lower-left corner of the loop browser to switch to button view.
2. Click a keyword button to show matching loops in the results list. The columns in the results list show the type of loop, name, tempo, key, and number of beats for each loop.
3. To refine your results, click multiple keyword buttons. This narrows the matching loops to only those that match all of the selected keywords.
4. To end a search, either click the selected keyword again to deselect it, or click the Reset button to deselect all selected keywords.

When you click a keyword, incompatible keywords (those that share no loop with the selected keyword) are dimmed.

Now find some drum loops in button view by clicking the Drums keyword button. Scroll through the list to see all the matching loops. Notice that the number of matching loops is shown next to the search field.
Finding Loops in Column View

In column view, clicking a keyword type in the left column shows categories for that keyword type in the middle column. Clicking a category shows keywords for that category in the right column. Clicking a keyword shows matching loops in the results list. You can expand your results by clicking multiple keywords.

To find loops in column view:
1. Click the column button in the lower-left corner of the loop browser to switch to column view.
2. Click a keyword type in the left column.
3. Click a category in the middle column.
4. Click a keyword in the right column to show matching loops in the results list.
5. To refine your results, click multiple categories or keywords. This expands the matching loops to include those that match any of the selected categories or keywords.

Now find some bass loops in column view by first choosing the By Instruments keyword type, then the Bass category, then the Grooving keyword.

When you find loops in either button view or column view, the total number of matching loops is shown next to the search field at the bottom of the loop browser.

Previewing Loops in the Loop Browser

When you find loops that fit the criteria you want, you can preview them in the loop browser to hear which loop will sound best in your song. You can preview the loop by itself (solo), or hear it playing together with the song.

To preview a loop:
- Click the loop in the results list. Click the loop again to stop previewing it.
Once you have added loops or recorded instruments in your song, you can preview a loop together with the song by clicking the Play button before you click the loop. When you preview a loop with a song, GarageBand matches the tempo and key of the loop to the song's tempo and key, and syncs the loop with the song so it starts playing on the beat. 

When you preview a loop, you can also control the volume of the loop using the volume slider in the loop browser.

Drag the volume slider to adjust the volume of the loop.

To adjust the volume of a loop being previewed:
- Drag the volume slider in the loop browser left to lower the loop's volume, or right to raise the loop's volume.

If you adjust the volume of a loop in the loop browser, then add the loop to your song by dragging it to an empty part of the timeline, the volume of the track created for the loop is set to the same volume.

Now try previewing the loops you found earlier, and see which ones you like.

Refining Your Searches
There are several ways you can refine your searches in the loop browser. You can:
- Display only loops from a specific Jam Pack or folder
- Display loops using a particular scale type
- Display only loops in keys near the song's key
- Perform text searches

Displaying Loops From a Jam Pack or Folder
If you have installed one or more of the GarageBand Jam Packs on your computer, your loop library can contain many thousands of loops. To make searching for loops easier, you can choose to display only loops from a specific Jam Pack, or only the loops included with GarageBand. If you have created your own loops or added loops from another source, you can also choose to display only those loops.
To display loops from a specific Jam Pack or folder:

- Choose the Jam Pack or folder with the loops you want to see from the loop library pop-up menu, located to the right of the word “Loops” at the top of the loop browser.

Searching by Scale Type

Most loops other than drum loops are recorded using a particular musical scale. In most cases, when you arrange several loops so that they play together, you’ll want to use loops with the same scale type. The Scale pop-up menu lets you narrow the loops shown in the results list to those using either the major or minor scale, those using neither scale, or those good for both.

To display only loops with a particular scale type:

- Choose the scale type from the Scale pop-up menu.

Drum loops don’t usually have a scale type, so try refining the bass loops you found earlier to show only those using the major scale.

Limiting Searches to Nearby Keys

Loops with melody and harmony instruments are recorded in a specific musical key. When you add a loop to a song, GarageBand matches the loop’s key with the key of the song. The closer the loop’s original key is to the key of the song, the more natural the loop will sound when transposed to the song’s key. When a loop is transposed by a large number of semitones, the result can sometimes sound unnatural or distorted.

To display loops only in keys near the song’s key:

1. Choose GarageBand > Preferences, then click the General tab.
2. In the General pane, click the “Filter for more relevant results” checkbox.

Note: The “Filter for more relevant results” checkbox is turned on by default. To see loops in keys farther away from the song’s key, turn off the checkbox.

Searching for Specific Text

You can quickly find loops with specific text in their file name or path using the search field. This makes it easy to find a loop by name, or to find all loops in a specific folder.

To perform text searches for loops:

- Type the text you want to search for in the search field, then press Return. Loops with the text in either their file name or path will be shown in the results list.

Try refining the drum loops you found earlier by typing “acoustic,” “club,” or “funk” in the search field. You can try typing other words to see what results you get.
You can use several methods together to find specific loops. For instance, you can use keywords with the Scale pop-up menu, or with the search field, to find only bass loops using the major scale, or to find only percussion loops with “latin” in the file name.

### Adding Loops to the Timeline

When you find a loop you want to use in your song, you add the loop to the timeline.

To add a loop to the timeline:
- Drag the loop from the loop browser to an empty part of the timeline where there is no track. A new track of the appropriate type is created, and the loop is added to the new track.

You can also create a new track, then drag a loop of the same type (Real or Software Instrument) to the track. To learn about creating tracks, see Chapters 6 and 7.

There are two types of Apple Loops: Real Instrument loops or Software Instrument loops. In the loop browser, the loop’s icon shows which type each loop is. Real Instrument loops can be dragged only to a Real Instrument track, and Software Instrument loops can be dragged to either a Real or Software Instrument track. Either type can be dragged to an empty part of the timeline to create a new track.

You can also convert a Software Instrument loop to a Real Instrument loop when you drag it to the timeline. Real Instrument loops require less processing power for playback, which can allow you to use more tracks and effects in your song, especially for songs with many loops.

To convert a Software Instrument loop to a Real Instrument loop:
- Option-drag the loop from the loop browser to the timeline.

By default, option-dragging a Software Instrument loop converts it to a Real Instrument loop. You can change the default so that dragging a Software Instrument loop converts it to a Real Instrument loop, and option-dragging does not convert it.

To change the default behavior for converting Software Instrument loops:
1. Choose GarageBand > Preferences, then click the Advanced tab.
2. Turn on the “Convert to Real Instrument” checkbox next to “Adding Loops to the Timeline.”
When you add a loop to a song, a region is created from the loop in the timeline. The edits you make to the region do not change the original loop, so you can always return to the original sound of the loop or use it in another song.

Now try adding some of the drum and bass loops you found earlier to the timeline.

**Creating Your Own Apple Loops**
You can save Real and Software Instrument regions you record as Apple Loops. When you save a region as an Apple Loop, it is added to the loop library and appears in the loop browser, so you can use it in other songs.

Apple Loops you create from recorded regions match the tempo and key of the song, just like the Apple Loops included with GarageBand.

**To save a region as an Apple Loop:**
1. Select the region in the timeline.
2. Choose Edit > Add To Loop Library, or drag the region over the loop browser.
3. In the Add Loop dialog, do the following:
   a. Type a name for the loop.
   b. Choose the scale and genre from the pop-up menus.
   c. Choose an instrument category and instrument name from the list.
   d. Click the appropriate mood buttons for easy searching.
4. Click Create.

For information about recording Real and Software Instruments and creating regions, see Chapters 6 and 7.

**Adding Loops to the Loop Library**
When you install GarageBand, the loops included with the application are installed in the Apple Loops library. When you add more loops to your collection, they are installed in the loop library, and appear in the loop browser for you to use.

**To add Apple Loops to your loop library:**
- Drag the loops, or the folder containing the loops, over the loop browser. The loops are added to the Apple Loops library and are immediately available to use in your songs.
  If you add loops located on a different drive or partition, a dialog appears asking whether you want to copy them to the loop library, or index them in their current location. If you add loops from the desktop, a dialog asks if you want to move them or index them in their current location.

  If you add loops located on a CD or DVD, GarageBand copies them to the loop library.
Working in the Timeline

You build your songs by arranging Real and Software Instrument regions in the timeline.

Once you’ve added several loops to the timeline, you can make changes to their regions in the timeline to start building the arrangement of the song.

There are several ways you can arrange regions in the timeline. You can:
• Cut, copy, and paste them
• Loop them
• Lengthen or shorten them
• Move them to another part of the timeline or to another track
• Transpose them to a different key
• Fix their timing
• Split or join them
• Rename them

About Regions
Each time you record a Real or Software Instrument, you create a region in the instrument’s track containing the music you record. When you drag a loop to the timeline, you create a region from the loop. Any changes you make to the region, such as splitting or transposing it, do not change the original recording or loop.

Real Instrument regions you record are purple, Real Instrument regions created from loops are blue, and Real Instrument regions from imported audio files are orange. Software Instrument regions, both from recordings and from loops, are green.

Regions are the building blocks of a song. You define the feeling, build the structure, and create change and interest in a song by arranging regions in the timeline.
Selecting Regions
In order to make changes to a region, you must first select it in the timeline.

To select a region, do one of the following:
• Select a single region by clicking it.
• Select multiple regions by Shift-clicking.
• Drag from a point before the first region to a point after the last one to select the regions in between.

Note: To select regions and perform other actions such as looping and resizing, you may need to zoom in on the region so that it is large enough to select.

Cutting, Copying, and Pasting Regions
You can cut, copy, and paste regions using the standard Mac OS menu commands and keyboard shortcuts.

To cut a region:
• Select the region, then choose Edit > Cut.

To copy a region, do one of the following:
• Select the region, then choose Edit > Copy.
• Option-drag a loop to create a copy.

To paste a region:
• Move the playhead to the point in the timeline where you want the region to start, then choose Edit > Paste.

When you paste a region, the playhead moves to the end of the pasted region. You can paste additional copies of the region, and each one starts at the point in the timeline where the previous one ends.

Looping Regions
You can loop a region so that it plays repeatedly. When you loop a region, it plays repeatedly from the start point to the end point.

To loop a region:
1 Move the pointer over the upper half of the right edge of the region. The pointer changes to a loop pointer, with a circular arrow.
Drag the edge of the region to the point where you want it to stop playing. The region will loop repeatedly to that point.

When you loop a region, the notches at the top and bottom of the region show the beginning and end of each repetition. You can drag to the end of a repetition, or have it end in the middle of a repetition.

Try looping the drum and bass regions you added to the timeline. Rhythm patterns in most popular music last for some multiple of four measures. For example, the verse and chorus of a popular song often last for 16 or 32 measures each.

Resizing Regions
You can resize regions by either shortening or lengthening them.
- When you shorten a region, only the visible part of the loop plays.
- When you lengthen a region, you add silence (blank space) to its beginning or end.

To resize a region:
1. Move the pointer over the lower half of either edge of the region. The pointer changes to a resize pointer, with an arrow pointing away from the region.
2. Drag the edge of the region to shorten it or lengthen it.

Resizing a region by lengthening adds silence to the region. This can be useful if you want to make copies of the region, each lasting for a certain number of beats.

Note: You can’t lengthen a Real Instrument region beyond its original length.

Moving Regions
You can move a region by dragging it to a new point in the timeline. You can also move a region to another track of the same type as the region (Real Instrument regions can only be moved to Real Instrument tracks, and Software Instrument regions can only be moved to Software Instrument tracks).
To move a region:
• Drag the region left or right to a new point in the timeline.
• Drag the region up or down to another track of the same type.

Two regions cannot overlap in the same track. If you drag a region over part of another region, the region being covered is shortened to the edge of the overlapping region. If one region completely covers another region, the region being covered is deleted from the track.

Try adding a new drum or bass loop to the timeline. Move it so it starts at the end of the one you’ve added earlier, then loop it to create a new rhythmic groove.

Transposing Regions
When you add a region to the timeline, the region is matched, or transposed, to the key of the song. In most situations, you’ll want regions to be in the same key as the song. You can transpose a region to a different key when you want the song to temporarily move to a new key, or to create tension between the region and the rest of the song (called dissonance).

To transpose a region:
1 Select the region in the timeline, then click the Editor button to open the editor. You can also double-click the region to open the editor.
2 Drag the Region pitch slider to transpose the region up or down. You can also type the number of semitones you want to transpose the region in the field next to the slider. A semitone is the smallest distance between two musical notes.

Try adding a new bass loop after the one that you have already dragged to the timeline, then transposing it. The most common transpositions are five and seven semitones up or down, but feel free to try whatever sounds good.

Fixing the Timing of Software Instrument Regions
You can fix the timing of Software Instrument regions you record. When you fix the timing of a region, the notes in the region move to the nearest grid position, as set in the timeline grid menu in the upper-right corner of the editor.

To fix the timing of a recorded region:
• Select the region, then click the Fix Timing button (with the words “Align to” followed by the current note value).
To set the note value for Fix Timing:

- Click the Timeline Grid button, then choose a note value from the menu, or choose Automatic.

Splitting Regions
You can split a region in the timeline. Splitting a region lets you start playing the region from a point other than the beginning, or use parts of a region in different places in the timeline.

1. Select the region you want to split.
2. Move the playhead over the point in the region where you want to split it.
3. Choose Edit > Split.

Only the selected region will be split, even if a region in another track is under the playhead as well. If multiple regions are selected and are under the playhead, they will all be split.

The selected region is split into two regions at the playhead. When you split a Software Instrument region, any notes at the split point are shortened to that point.

Joining Regions
You can join multiple regions into a single region. To be joined, the regions must be adjacent to each other on the same track, with no space between them.

Real Instrument regions from loops (blue) can't be joined. Recorded Real Instrument regions (purple) can only be joined to other Real Instrument regions, and Software Instrument regions (green) can only be joined to other Software Instrument regions.

1. Make sure the regions are the same type, on the same track, and adjacent to each other.
2. Select the regions.
3. Choose Edit > Join Selected.

When you join Real Instrument regions, a dialog appears asking if you want to create a new audio file. Click Create to join the regions in a new Real Instrument region.
Renaming Regions
You can rename a region in the editor.

To rename a region:
1. Click the region in the timeline to select it, then click the Editor button. You can also double-click the region to open the editor. The waveform of the region appears in the editor. Be sure the header over the field says Region before you type the new name.
2. Select the text in the name field, then type the new name in the field.

Using the Timeline Grid
When working with regions in the timeline, you usually want them to align with the beats and measures in the beat ruler, so they start playing on the beat. GarageBand includes a timeline grid that makes it easy to align regions with beats and measures in the beat ruler, and with other musical note values.

When you turn on the grid, the playhead, regions, and other items in the timeline snap to the nearest grid position in the timeline and the editor when you move or resize them.

To turn the grid on or off:
- Choose Control > Snap to Grid.

The grid can be set to any of the following note values:
- 1/4 notes, 1/8 notes, 1/16 notes, or 1/32 notes
- 1/4 note triplets, 1/8 note triplets, or 1/16 note triplets
- 1/8 note swing light or swing heavy, 1/16 note swing light or swing heavy

The grid can also be set to Automatic. When set to Automatic, the grid changes when you zoom in or zoom out. The grid division moves between measures, 1/4 notes, 1/8 notes, 1/16 notes, and 1/32 notes, depending on the zoom level.

To set the timeline grid value:
- Click the Timeline Grid button, then choose a note value from the menu, or choose Automatic.

Using Undo and Redo
As you build your arrangement in the timeline, you may want to undo or redo some of the changes you make. If you decide you don't like the last change you made to a song, it can usually be undone. After undoing it, if you decide you like the song better with the change, you can redo the last command.
You can also use the Undo and Redo commands as a quick way of trying out changes to a song. You can make several changes to the song, then step back through the changes using Undo. If you change your mind after undoing a step, you can recover the changes using Redo. You can undo or redo any number of actions, since the last time you saved. At any point, you can save a new version of the song by choosing File > Save As.

**To undo the last change:**
- Choose Edit > Undo.

**To redo the last change:**
- Choose Edit > Redo.
You can play and record guitars, basses, microphones and other musical instruments connected to your computer in Real Instrument tracks. Each recording appears as a region in the track. You can change input settings and add effects to a Real Instrument track in the Track Info window.

Adding a Real Instrument Track
To record a Real Instrument, you can add a new Real Instrument track or record on an existing Real Instrument track.

To add a Real Instrument track:
1. Click the Add Track button, or choose Track > New Track.
2. In the New Track dialog, click the Real Instrument tab.
3. Select an instrument category from the Category list, then select an instrument from the Instrument list.
4. Select the input format by clicking either the Mono or Stereo format button, then choose the input channel from the Input pop-up menu.
   - If the instrument you are recording has a single input, choose the Mono format. If the instrument has left and right inputs, choose the Stereo format.

You can also add a basic track. A basic track is a stereo Real Instrument track containing no effects. You can change the input format and effects settings of a basic track after adding it to the song.

To add a basic track:
- Choose Track > New Basic Track.

Monitoring Real Instrument Input
Hearing your instrument while you play and record is called monitoring. When you create a Real Instrument track, you can turn on monitoring for the track in the New Track dialog. You can turn monitoring on or off in the Track Info window.
To turn monitoring on or off for a Real Instrument track:

1. Select a Real Instrument track, then click the Track Info button to open the Track Info window.

2. Choose “On” or “Off” from the Monitoring pop-up menu.

Turning on monitoring can produce feedback (loud, sharp noise) if the audio input picks up the sound being output through your speakers. This is the reason monitoring is off by default. You may want to turn off monitoring for a Real Instrument track when you are not singing into the microphone or playing the instrument connected to the track. If you are recording multiple Real Instrument tracks, be sure to turn off monitoring when you finish recording a track to prevent feedback.

Getting Ready to Record

Once you have connected your instrument and added a track to record in, there are a few things to check before you start recording:

- Make sure the microphone or instrument is connected properly and is working.
- Make sure the correct audio drivers are selected in the Audio/MIDI pane of GarageBand Preferences.
- Open the Track Info window to make sure the instrument has the instrument and effects settings you want, and is using the correct input channel (or pair of channels). See “Changing Real Instrument Settings” on page 45 for more information.
- Sing or play a few notes and watch the track’s level meters in the track mixer to make sure the track is receiving input, and isn’t clipping. If the red dots at the right of the level meters (called clipping indicators) light up, try dragging the volume slider to the left a little to lower the input volume.
- You may want to set the song tempo and key before recording a Real Instrument. Real Instrument recordings are fixed in tempo and key, unlike loops and Software Instrument recordings, and cannot be changed after they are recorded.

Recording a Real Instrument

Now you’re ready to record your Real Instrument. You can record one Real Instrument track at a time.

To record a Real Instrument:

1. Click the header of the Real Instrument track you want to record in to select the track.

2. Move the playhead to the point in the timeline where you want to start recording.

3. Choose Control > Count In to have the metronome play a one-measure count-in before recording starts. You can also set the playhead a few beats before the point where you want the music to come in to make it easier to start playing on the beat.
4 Click the Record button to start recording.

5 Start playing your instrument, or singing into your microphone. As you record, a new region appears in the selected Real Instrument track with the music you record.

6 When you are finished, click the Play button to stop recording.

An audio waveform appears in the newly recorded region.

After you record, you can listen to your new recorded part to see how you like it.

**To hear the new recording:**

1 Move the playhead to the point in the timeline where the new region starts (align it with the left edge of the region). You can also move the playhead to an earlier point in the song, or to the beginning of the song, to hear the new recording in the context of the song.

2 Click the Play button, or press the Space bar.

**Recording a Real Instrument With the Cycle Region**

GarageBand lets you record over a specific part of a song. Musicians sometimes call this “punching in” and “punching out,” and call the points where you start and stop recording “punch points.”

To record over a specific part of a song, you set the cycle region in the timeline.

**To set the cycle region:**

1 Click the Cycle button. The cycle region appears as a yellow strip just below the beat ruler.

2 Move the cycle region to the point in the timeline you want to start recording, then drag the end of the cycle region to the point in the timeline you want to end recording. You can drag in the cycle region ruler (below the beat ruler) to move the cycle region to a new part of the timeline.
You may want to have the cycle region start a few extra beats before the point where you want to start recording, to make it easier to start playing on the beat, and end a few beats after you want to stop recording, in case your last note extends past the end of the cycle region.

**To record using a cycle region:**
1. Select the Real Instrument track you want to record in.
2. Click the Record button to start recording.
3. Play your musical instrument, or sing into your microphone. As you record, a new region appears in the selected Real Instrument track.

   Real Instruments only record the first time through the cycle region. When the cycle region repeats, you hear the newly recorded region.
4. When you are finished, click the Play button to stop the cycle region.
5. If you want to replace the recorded region, click the Record button and play the part again.
6. When you have finished using the cycle region, click the Cycle button again to turn it off.

**Recording Multiple Real Instrument Tracks**
You can record up to eight Real Instruments and one Software Instrument at the same time. This lets you record vocals and instruments together, and simultaneously record a backing track, for example.

When you select a track, recording is enabled for that track (meaning that recording will start on that track when you click the Record button). You can enable up to seven additional tracks by clicking the round Record Enable button in each track’s header. The Record Enable button turns red to show that the track is enabled for recording.

To disable a track for recording, click the Record Enable button in the track’s header again.

**To record multiple Real instruments at the same time:**
1. Be sure each Real Instrument track is set to use a different input channel (or pair of channels) in the Track Info window.
2. Enable the tracks you want to record by clicking their Record Enable buttons.
3. Click the Record button in the transport controls to start recording.

**To record a Software Instrument at the same time as one or more Real Instruments:**
1. Enable the Software Instrument track for recording along with the Real Instrument tracks by selecting the track or clicking its Record Enable button.
2. Click the Record button in the transport controls to start recording.
If you enable more than eight Real Instrument tracks or more than one Software Instrument track, the track farthest from the last track you enable is disabled for recording, so as not to exceed the maximum number of recording tracks.

To record on multiple tracks, you need to have an audio interface with at least two input channels for recording.

**Changing Real Instrument Settings**
When you create a Real Instrument track, you select an instrument for the track in the New Track dialog. You can change the instrument in the Track Info window, and also change the effects and input settings.

**Changing the Instrument**
You can change the instrument setting for a Real Instrument track. Each instrument setting includes preset effects optimized for the instrument.

**To change the instrument for a Real Instrument track:**
1. Select the track, then click the Track Info button to open the Track Info window.
2. Select an instrument category from the list on the left, then select a track instrument from the list on the right.
## Changing the Input Channel

When you create a Real Instrument track, you set the input channel (for mono input) or pair of channels (for stereo input). You can change these settings in the Track Info window.

**To change the input channel:**
1. Select the track, then click the Track Info button to open the Track Info window.
2. Choose an input channel, or pair of channels, from the Input pop-up menu.

The number and format of input channels varies, depending on what type of audio interface is connected to your computer.

## Adjusting Input Volume

You can adjust the input volume for a Real Instrument track. The input volume controls the level of the signal from the audio input port or audio interface into GarageBand. In general, set the input volume as high as possible without causing clipping or distortion for the best results.

**To adjust the input volume:**
1. Select the track, then click the Track Info button to open the Track Info window.
2. Drag the Volume slider left to lower the input volume for the selected channel, or drag it right to raise the input volume.

*Note:* Dragging the Volume slider changes the input volume for the selected channel in all audio applications, not just GarageBand.

You can also add and adjust effects for a Real Instrument track. For information about using effects, see “Mixing and Adding Effects” on page 64.

## Using the Instrument Tuner

GarageBand includes an instrument tuner that you can use to check the tuning of any Real Instrument connected to your computer. The tuner is especially helpful when playing and recording guitars, basses, and other instruments that may need regular retuning.

The instrument tuner shows a horizontal scale with zero (0) in the center. The note name is displayed to the left of the scale. When you play a single note on your Real Instrument, the pitch is shown in relation to the correct pitch for the note displayed.
To use the instrument tuner:
1. Make sure the Real Instrument you want to tune is connected to your computer.
2. Select the Real Instrument track for the instrument you want to tune.
3. Click the tuner icon (the tuning fork) at the left of the time display, or choose Control > Show Instrument Tuner.

Be sure to play only a single note while tuning. The instrument tuner can't tune to a chord, or if you play different notes rapidly.

The instrument tuner works for Real Instruments, but not for Software Instruments.

Adding an Audio File from the Finder
In addition to recording audio in a Real Instrument track, you can add audio files from the Finder to your songs. You can add an audio file in any of the following formats:

- AIFF
- WAV (including Sony ACID WAV files)
- AAC (except protected AAC files)
- Apple Lossless
- MP3

When you add an AAC, Apple Lossless, or MP3 file to a song, it is converted to an AIFF file.

To add an audio file:
- Drag the file from the Finder to the timeline, either to a Real Instrument track or to the empty area below the existing tracks.

If you drag an audio file to the empty area below the existing tracks, an new basic track is added to the timeline, and the audio file is placed in the new track.

Note: Audio files you drag from the Finder will not change to match the tempo or key of the song. In order to have the audio file match the song tempo and key, and to use it with other songs, see “Creating Your Own Apple Loops” on page 33.
GarageBand includes an extensive set of Software Instruments, including drums, guitars, pianos, organs, and synthesizers.

You can play and record Software Instruments using the onscreen music keyboard in GarageBand, or by connecting a MIDI-compatible music keyboard to your computer. You can add effects to a Software Instrument, and edit Software Instrument regions in the editor.

Using Musical Typing
You can play and record Software Instruments using your computer keyboard. When you use Musical Typing, use the top and middle row of your computer keyboard just like the keys on a music keyboard to play notes.

To show the Musical Typing keyboard:
• Choose Window > Musical Typing (or press Command–Shift–K).

To play notes using Musical Typing:
• With the Musical Typing window open, play the notes shown on the Musical Typing keyboard.
• The notes in the middle row of your computer keyboard play the “white keys” on the piano keyboard, in a one and one-half octave range from C through F.
• The notes W, E, T, Y, U, O, and P in the top row of your computer keyboard play the “black keys” (sharps and flats).

To move up or down by octaves, do one of the following:
• Press Z to move down by an octave.
• Press X to move up by an octave.
• Click the small keyboard at the top of the Musical Typing window to move to the octave shown, or drag the blue rectangle. The blue rectangle shows the current range of Musical Typing.

To change the velocity level of notes you play using Musical Typing:
• Press C to lower the velocity level.
• Press V to raise the velocity level.

To add pitch bend to notes you play using Musical Typing:
• Press 1 to lower the pitch of notes.
• Press 2 to raise the pitch of notes.
The pitch is bent for as long as you press the key.

To add modulation to notes you play using Musical Typing:
• Press 4 through 8 to add increasing amounts of modulation. Press 3 to turn off modulation.
The level of modulation lasts until you change it or turn it off by pressing another key.

Using the Onscreen Music Keyboard
You can use the onscreen music keyboard to play and record Software Instruments. When you show the onscreen music keyboard, by default it displays a four-octave range of keys. You can resize the keyboard to display up to 10 octaves.

To show the onscreen music keyboard:
• Choose Window > Keyboard.

To play the onscreen music keyboard:
• Click the notes on the keyboard. You can click when the song is playing, when it is stopped, or when recording.

Clicking a note lower on the key plays the note with a higher velocity (equivalent to pressing the key harder), and clicking a note higher on the key plays the note with a lower velocity (equivalent to pressing the key more softly).
To move the keyboard:
- Place the pointer anywhere in the space above the keys and drag.

To resize the keyboard:
- Drag the expansion triangle on the lower-right edge of the keyboard window.

To change the range of notes you can play:
- Click the small triangles to the left or right of the keys. Clicking the triangle to the left lowers the keys by an octave, and clicking the triangle on the right raises the keys by an octave.

Adding a Software Instrument Track
To record a Software Instrument, you can add a new Software Instrument track or record on an existing Software Instrument track.

To add a Software Instrument track:
1. Click the Add Track button, or choose Track > New Track.
2. In the New Track dialog, click the Software Instrument tab.
3. Select an instrument category from the Category list, then select the instrument you want to use from the Instrument list.

Getting Ready to Record
Once you have connected your music keyboard, there are a few things to check before you start recording:
- Make sure your music keyboard is connected to your computer and is working.
- Select a Software Instrument track and try playing your music keyboard, or clicking notes on the onscreen music keyboard. You should hear the Software Instrument as you play.

Recording a Software Instrument
Now you’re ready to record a Software Instrument. You can record one Software Instrument track at a time.

To record a Software Instrument:
1. Click the header of the Software Instrument track you want to record in to select the track.
2. Move the playhead to the point in the timeline you want to start recording.
3. Choose Control > Count In to have the metronome play a one-measure count-in before recording starts. You can also set the playhead a few beats before the point where you want the music to come in to make it easier to start on the beat.
4 Click the Record button to start recording.

5 Start playing your music keyboard, or clicking notes on the onscreen music keyboard. As you record, a new region appears in the selected Software Instrument track.

6 When you are finished, click the Record button again to stop recording. Click the Play button to stop the song playing.

   After you record, you can listen to your new recorded part to see how you like it.

   **To hear the new recording:**
   1 Move the playhead to the point in the timeline where the new region starts (align it with the left edge of the region). You can also move the playhead to an earlier point in the song, or to the beginning of the song, to hear the new recording in the context of the song.
   2 Click the Play button, or press the Space bar.

   **Recording a Software Instrument With the Cycle Region**
   You can record a Software Instrument using a cycle region, similar to how you would with a Real Instrument. When you record a Software Instrument with a cycle region, you can keep recording for as many times as the cycle region repeats. Each new cycle is merged with the region created the first time through the cycle region. For information on recording using a cycle region, see “Recording a Real Instrument With the Cycle Region” on page 43.

   **Changing Software Instrument Settings**
   When you create a Software Instrument track, you select an instrument for the track in the New Track dialog. You can change the instrument in the Track Info window.

   **To change the instrument for a Software Instrument track:**
   1 Select the track, then click the Track Info button to open the Track Info window.
   2 Select an instrument category from the list on the left, then select a track instrument from the list on the right.
The output of a Software Instrument is always stereo.

You can also add and adjust effects for a Software Instrument track. For information about using effects, see “Mixing and Adding Effects” on page 64.
The editor, located below the timeline, is where you edit Real and Software Instrument regions. You can edit each type of region in a variety of ways.

In the editor, Real Instrument regions appear as audio waveforms. Software Instrument regions appear as either a graphic note display, or as music notation, depending which view you select. For both Real and Software Instrument regions, the editor features a beat ruler to help you make precise edits, and a playhead which you can lock to the timeline playhead, or unlock to see a different part of the song in the editor.

Selecting Regions
In order to edit a region in the editor, you first select the region in the timeline.

To select a region, do one of the following:
- Select a single region by clicking it.
- Select multiple regions by Shift-clicking.
- Drag from a point before the first region to a point after the last one to select the regions in between.

Editing Real Instrument Regions
You can edit Real Instrument regions in the editor in several ways. You can:
- Move regions
- Crop part of a region
- Join regions
- Enhance the tuning of single-note (monophonic) regions
- Enhance the timing of regions
Moving Real Instrument Regions
You can move Real Instrument regions in the editor in order to align them precisely with measures and beats, or with other regions.

To move a Real Instrument region in the editor:
1 Move the pointer over the top part of the region, close to the beat ruler.
   The pointer becomes a move pointer (a vertical line with arrows pointing left and right).
2 Drag the region to its new position.

Cropping Part of a Real Instrument Region
You can easily cut part of a Real Instrument region, whether at the beginning, the end, or in the middle of the region. This is especially useful if you want to delete, move, or copy an individual note, chord, or phrase in a region.

To crop part of a Real Instrument region:
1 Move the pointer over the place where you want to cut the region (except at the top).
   The pointer becomes a crop pointer (a crosshair).
2 Drag from the beginning to the end of the part you want to crop.
   The selected part of the region appears darker blue.
3 Click the selected part of the region.
4 The selected part is cropped from the rest of the region, and is now a separate region. You can select it, delete it, move it, or copy it, just as you would any Real Instrument region.

Joining Real Instrument Regions
You can join Real Instrument regions that are next to each other in the editor.

To join regions:
- Select the regions, then choose Edit > Join (or press Command-J).

Enhancing the Tuning of Real Instrument Tracks
You can enhance the tuning of a Real Instrument track. This is especially useful when you record Real Instrument regions that have the right “feel” and timing but are not perfectly in tune.

When you use the Enhance Tuning slider, all regions on the selected track (both your own recordings and loops) are enhanced. Enhance Tuning can only produce accurate results on single-note (monophonic) Real Instrument regions, so be sure the track does not include regions with chords or unpitched sounds.
By default, Enhance Tuning enhances the tuning of notes by moving them to the closest note in the song's key. You can limit the enhancement to the notes of the chromatic scale instead by deselecting the “Limit to key” checkbox.

To enhance the tuning of a Real Instrument track:
1. In the timeline, select the Real Instrument track you want to enhance.
2. Drag the Enhance Tuning slider right to increase the amount of tuning enhancement, or drag it left to decrease the amount of enhancement.
3. To limit tuning enhancement to the chromatic scale, deselect the “Limit to key” checkbox below the slider.

You hear the results immediately as the song plays.

Setting the Enhance Tuning slider to higher values can sometimes lead to undesirable results. Listen carefully to the results of using the slider and set it to the value that sounds best.

Enhancing the Timing of Real Instrument Tracks
You can enhance the timing of a Real Instrument track. This is especially useful when you record Real Instrument regions with the right notes, but which are not perfectly in time with the song.

When you use the Enhance Timing slider, all regions on the selected track (both your own recordings and loops) are enhanced. You can enhance the timing of single-note, chordal, and percussion (unpitched) Real Instrument regions. Enhance Timing works better with regions containing distinct patterns of notes than pads or ambient sounds.

To enhance the timing of a Real Instrument track:
1. In the timeline, select the Real Instrument region you want to enhance.
2. Drag the Enhance Timing slider to the right to increase the amount of timing enhancement, or drag it left to decrease the amount of enhancement.

If you move the Enhance Timing slider while the song is playing, it may take a moment for it to “catch up” with the music.

The Enhance Timing slider may not work equally well with all musical material, especially when set to higher values. Listen carefully to the results of using the slider and set it to the value that sounds best.
Editing Software Instrument Regions
You can edit Software Instrument regions in the editor in several ways. You can:
• Edit individual notes (including the note’s pitch, duration, timing)
• Edit controller information (including velocity, mod wheel, pitch bend, sustain)

Editing Notes in a Software Instrument Region
You can edit individual notes of a Software Instrument region. When you view the region in the editor, individual notes in the region are displayed in a graphic format:
• The left edge of the note shows the point in the timeline it starts playing.
• The width of the note shows how long it plays.
• The vertical position of the note shows its pitch, in relation to the piano keyboard displayed vertically along the left edge of the editor.

You can drag notes to a new starting point, resize notes to shorten or lengthen how long they play, and drag notes up or down to a different pitch. You can also select multiple notes and edit them at the same time.

Note: To edit notes in the editor, you may need to zoom in so that the notes are large enough to select and edit.

To edit notes in a Software Instrument region:
• Drag the note left or right to a new starting point. You can use the beat ruler in the editor to align the note with a specific beat or measure.
• Drag the lower-right corner of the note to resize it.
• Drag the note up or down to raise or lower its pitch. Use the piano keyboard along the left edge of the editor to see the pitches.

You can also select multiple notes in the editor, and edit them at the same time.

To select multiple notes:
• Shift-click or Command-click the notes you want to select.
• You can also select multiple notes by dragging from a point before the first note to a point after the last note, enclosing the notes you want to select.

When you edit multiple notes, each note is changed by the same amount. For example, if you select several notes and drag them to a new starting point, each note is moved by the same number of beats. If you resize several notes at the same time, each note is shortened or lengthened by the same amount. If you drag several notes up or down to a different pitch, each note is changed by the same number of semitones.

You can also fix the timing of individual notes in the editor. When you fix the timing of notes in the editor, the selected notes move to the nearest grid position, as set in the timeline grid menu in the upper-right corner of the editor.

To fix the timing of individual notes:
• Select the notes you want to fix in the editor, then click the Fix Timing button.
Editing Controller Information in a Software Instrument Region

Most music keyboards designed to be used with computer music programs include “controllers” for pitch bend and modulation. These controllers are often circular “wheels” placed at the left end of the keyboard. Some keyboards also include other controllers, such as a sustain pedal, a foot controller, or an expression control.

Moving the pitch bend wheel while you play causes the notes you play to bend up or down in pitch, like a guitar. Moving the modulation wheel creates changes in the sound of the Software Instrument. These are different for different instruments, but often involve changing the frequency, rate, or intensity of a filter applied to the instrument.

If you move a controller while recording a Software Instrument, the movements are recorded in the Software Instrument region. You can see the movements you recorded and edit them in the editor.

To display controller information for a Software Instrument region:

1. Double-click the region to open it in the editor.
2. Choose the type of controller information you want to see from the Display pop-up menu.

Controller information is displayed as a line with “dots” at different points in time. This is similar to the volume curves for tracks in the timeline. Each “dot” (called a control point) shows a change in value (in this case the movements of the controller) at that point in time. You can edit the controller information by adding new control points, and by adjusting control points to change their value or to change where in the timeline they occur.

To add a control point:
- Click the line in the editor at the point in time where you want to add a control point.

To adjust a control point, do one of the following:
- Drag the control point up or down to a new value.
- Drag the control point left or right to move it to a different point in time.

You can also view and edit Software Instrument regions in notation view in the editor. For information about notation view, see “Working In Notation View” on page 58.
You can view and edit Software Instrument regions in standard music notation format. In the editor’s notation view, you can edit notes and other musical events, including adding pedal markings.

About Notation View
In addition to the editor’s graphic “piano roll” view, you can view Software Instrument regions (both those you record and those from loops) in notation view. In notation view, the notes in a region are shown as musical notes. Notation view includes other musical symbols such as rests, staves, clef signs, time signatures, key signatures, and pedal markings. The following section briefly describes some of these symbols, for users unfamiliar with music notation.

- Notes: A musical note has several parts, including the note head and stem. The notehead (the round part of the note) indicates the note’s duration (how long the note lasts). Notes of shorter duration (shorter than a quarter note) have flags, and sometimes these notes are joined together by beams. Each note shown below is half as long as the note to its left (from left to right, the notes are: whole note, half note, quarter note, and eighth note).

```
\n```

Rests: When reading music while playing, it is as important to know the space between notes as the notes themselves. The silences between notes are shown by rests. Rests, like notes, have different symbols for different lengths of time, and shorter rests use flags.
Each rest shown below is half as long as the rest to its left (from left to right, the rests are half rest, quarter rest, eighth rest, and sixteenth rest).

- **Staves:** The set of five horizontal lines on which the notes appear is called a *staff* (the plural is *staves*). The lines of the staff let you see the pitch of the notes from high to low, like a grid. In notation view, GarageBand always shows two staves, similar to piano notation. This shows a range of three octaves with middle C in the center (between the two staves). Most instruments and voices except the lowest bass instruments fall in this range.

- **Clefs:** The symbol at the left edge of each staff is called a *clef*. Clefs indicate the range of notes the lines of the staff display. The staves in notation view use the two most common clefs, the treble and bass clef.

- **Key signs:** If the song is in a key other than C, the sharps or flats in the key appear between the clef and the time signature. Sharps are raised a semitone above the natural note (so, for instance, C# is a semitone higher than C), and flats are lowered a semitone (so Bb is a semitone lower than B). The symbols for sharps and flats are shown below, followed by the ‘natural’ symbol that cancels a sharp or flat.

- **Bar lines:** The vertical lines extending through both staves show the beginning of each measure (measures are also called *bars*).

In addition to standard music notation symbols, notation view includes the following features to make working easier:

- **Duration bars:** In addition to the musical note itself, each note has a duration bar that graphically displays the note's duration (the amount of time the note lasts).
• **Beat guides**: In notation view, the beat ruler not only shows measures and beats, but also includes beat guides. Beat guides help you see the exact position of notes in time. A beat guide appears as a small gray circle or dot above each note; when you move a note, the beat guide moves with it to indicate the note’s position.

To view a Software Instrument region in notation view:
1. In the timeline, select a Software Instrument region.
2. Click the Notation View button (the musical note icon) in the lower-right corner of the editor’s header area.

In music notation, the position of notes is shown in terms of musical values (note values). When you play music, you may play some notes slightly off the beat (ahead of the beat or behind the beat) to achieve different types of feeling. These small differences are not shown in musical notation.

In notation view, GarageBand shows the position of notes “rounded” to the nearest note value. You can choose the note value to round the display of notes to from the editor timeline grid menu. This does not change where the note sounds in time, it only changes the display, so that notes slightly out of time are shown at the intended position.

To choose the note value for notation view:
• Click the Timeline Grid button in the upper-right corner of the editor, then choose a note value from the timeline grid menu.

**Editing Notes In Notation View**
You can edit notes and controller information for a Software Instrument region in notation view, just as you can in graphic view. You can:

• Add notes
• Select notes
• Move notes in time
• Cut and copy notes
• Change the pitch of notes
• Change the duration of notes
• Change the velocity of notes
• Add pedal markings to sustain notes
Adding Notes
You add a note by choosing the note value for the note, then clicking in the editor.

In notation view, a square note value button appears at the upper-right corner of the Advanced area of the editor. The note value button displays a musical note showing the current note value. Clicking the note value button displays a menu from which you can choose a new note value.

To choose the note value:
- Click the note value button, then choose the note value you want from the menu that appears.

To add a note:
- In the editor, Command-click at the point you want to add the note.

Selecting Notes
Before editing notes in notation view, you must first select them.

To select a note:
- Click the notehead (the round part of the note). You can select multiple notes by Shift-clicking or by dragging around the notes to enclose them.

Moving Notes
You can move notes in time in notation view, in the same way as in the editor’s graphic view.

To move a note in time:
- Select the note, then drag left or right. You can also move selected notes by pressing the Left or Right Arrow keys.

Above each note in the beat ruler is a beat guide. As you move a note, the beat guide moves to help you see the note’s exact position in time.

Copying Notes
You can copy notes in notation view.

To copy a note:
- Option-drag the notehead to a new position.

Changing the Pitch of Notes
You can change the pitch of, or transpose, notes in notation view.
To change the pitch of a note:
- Select the note, then drag up or down. You can also change the pitch of selected notes by pressing the Up or Down Arrow keys.
  You hear the note’s new pitch as it moves.

Changing the Duration of Notes
When you select a note, a duration bar for the note appears. You can change the note’s duration (how long the note lasts) using the duration bar.

To change the duration of a note:
1. Select the note.
2. Drag the right edge of the duration bar left (to shorten the note) or right (to lengthen the note). Duration bars work just like the notes in graphic view.

Deleting Notes
You can delete notes that you no longer want to include in your song.

To delete a note:
- Select the note, then press the Delete key.

Changing Note Velocity
For many Software Instruments, the sound changes depending on the note’s velocity. You can change the velocity of notes in notation view, in the same way as in graphic view.

To change a note’s velocity:
- Select the note, then drag the Velocity slider left (to lower the velocity) or right (to raise the velocity). You can also change a selected note’s velocity by holding down the Command key and dragging up or down.

Adding Pedal Down and Pedal Up Symbols
Music notation for piano (and some other instruments) includes symbols for the sustain pedal. When the sustain pedal is down, the instrument sustains all notes until the pedal is released (up). You can add pedal down and pedal up symbols, which control whether the notes are sustained in GarageBand.

When you add pedal symbols, you can either place the pedal up symbol manually, or have GarageBand place the pedal up symbol at the end of the measure.

To add pedal symbols and place the pedal up symbol manually:
1. Click the note value button and choose the pedal symbol from the menu.
2. Hold down the Command key and place the pointer in the notation view editor at the point where you want the pedal down marker.
3. Press the mouse button down.
The pedal down symbol appears at the current position of the pointer.

4 Without releasing the the mouse button, drag to the point where you want the pedal up marker.
5 Release the mouse button.

The pedal up symbol appears at the current position of the pointer.

To add pedal symbols with the pedal up placed automatically:
1 Click the note value button and choose the pedal symbol from the menu.
2 Hold down the Command key and place the pointer in the notation view editor at the point where you want the pedal down marker.
3 Press the mouse button down.

The pedal down symbol appears at the current position of the pointer.

4 Release the mouse button.

The pedal up symbol appears at the next sixteenth note after the pedal down symbol.

Once you have added the symbols, you can move the pedal up symbol.

To move the pedal up symbol:
1 Click the pedal symbol to select it.

The pedal down and pedal up symbols become green, indicating that they are selected.

2 Drag the pedal up symbol to its new position, then release the mouse button.
GarageBand puts a complete recording studio on your desktop, so you can mix your songs and add professional-sounding effects.

What Is Mixing?
When you’ve built the arrangement of your song, the next step is to mix the song. Mixing is where you step back and listen to the overall arrangement, and make changes to tracks and to the overall song to balance the different parts, bring the music into focus, and give it the right “sound.”

Mixing typically consists of the following steps:
• Balancing volume levels
• Setting pan positions
• Creating dynamic changes with volume and pan curves
• Transposing parts of the song to a different key
• Shaping the music with effects

Setting Track Volume Levels
The instruments and loops you use in your project may have different volume (loudness) levels. In order to hear all the parts you’ve added, you balance the volume levels so that no track overwhelms the others, and no track is lost in the mix.

This doesn't mean that every track should be set to the same volume level. In commercial mixes, certain tracks (typically the lead vocals, drums, and lead or solo instruments) are louder, while other tracks (the backing instruments and vocals) are softer.

To set track volume levels:
• For each track, drag the volume slider left to lower the volume level, or drag it right to raise the volume level.
Setting Track Pan
Setting different tracks to different positions in the stereo field (panning) helps make it easier to distinguish each track in the mix, and create a sense of three-dimensional space to your song.

In commercial music, the most important tracks (typically the lead vocals, drums, and lead or solo instruments) are panned to the center or close to center, while other tracks (the backing instruments and vocals) are panned left and right. Panning tracks no farther than 50 percent left or right creates a natural sense of space, while panning tracks to the extreme left or right creates a more unusual, artificial sound.

To set track pan positions:
- For each track, drag the pan dial left to pan the track farther to the left, or drag it right to pan the track farther to the right. You can also click along the edge of the dial to set it to a specific position.

Using Volume and Pan Curves
In addition to setting track volume and pan, you can add volume and pan changes over time using volume curves and pan curves. Making changes over time is called automation, and GarageBand lets you automate volume and pan changes for each track.

To turn on a track’s volume or pan curve:
1. Click the triangle to the right of the Solo button in the track’s header.
   A blank row for the track’s volume and pan curves appears below the track.
2. From the pop-up menu on the left side of the row, choose Track Volume or Track Pan.

   Once you turn on a track’s volume or pan curve, you make changes by adding control points to the curve, then dragging the control points to change the value for volume or pan at that point in time.

   To add a control point:
- Click the line in the editor at the point in time where you want to add a control point.

   To adjust a control point, do one of the following:
- Drag the control point up or down to a new value.
- Drag the control point left or right to move it to a different point in time.

You can use the vertical lines in the row to line control points up with measures and beats in the timeline.
Setting the Output Volume

You can set the output volume of a song using the master volume slider, located below the lower-right corner of the timeline. The master volume slider controls the volume of the song when it is exported. You should adjust the output volume to a level high enough to eliminate background noise, but not high enough to cause clipping.

The master volume slider is intended to control the output, or export, volume of the song. Use your computer’s volume control to adjust the volume at which you listen to the song play.

To set the master volume:
- Drag the master volume slider to adjust the output volume of a song. Drag the slider left to lower the output volume, or right to raise the output volume. Option-click the slider to return it to a neutral value (0 dB gain).
- As the song plays, watch the master level meters located above the master volume slider. Before you export a song, make sure the small red dots to the right of the level meters are not lit. These dots (called clipping indicators) light to show that the volume level of the song at some point is too high, which will cause distortion or “clipping” in the exported song.

Adding Fade Ins and Fade Outs

A very common mixing technique is to add a fade in at the beginning of a song, and a fade out at the end of the song. Fade ins make the music seem to “come out of nowhere,” and fade outs create the feeling that the song continues playing. You can easily add fade ins and fade outs to your songs, and add other volume changes to the song over time.

To add a fade in:
1 Choose Track > Show Master Track.
   The master track appears at the bottom of the timeline.
2 From the pop-up menu on the left side of the row, choose Master Volume.
   The master volume curve appears in the master track.
3 Click the master volume curve at the point you want the fade in to end.
4 Drag the control point at the beginning of the master track down to the volume level at which you want the fade in to start. To start with complete silence, drag it all the way down.

Now play the song from the beginning. You’ll hear all the tracks in the song fade in gradually to their final volume level.

To add a fade out:
1 Choose Track > Show Master Track.
The master track appears at the bottom of the timeline.

2 From the pop-up menu on the left side of the row, choose Master Volume.
   The master volume curve appears in the master track.

3 Click the master volume curve at the point you want the fade out to begin, then click
   at the point you want the fade out to end.

4 Drag the second control point down to the volume level at which you want the fade
   out to end. To end with complete silence, drag it all the way down.

Now play the song from a point before the fade out begins. You’ll hear all the tracks in
the song fade out gradually to their final volume level.

Transposing the Song to a Different Key
Many songs move to different keys at some point in the song; they may stay in the new
key, or return to the original key at a later point in time. You can move an entire song to
a new key, called transposing (or modulating) in the song’s master track.

To transpose a song to a different key:
1 Choose Track > Show Master Track.
   The master track appears at the bottom of the timeline.

2 From the pop-up menu on the left side of the row, choose Master Pitch.
   The master pitch curve appears in the master track.

3 Click the box to the left of the words “Master Pitch” to turn on the master pitch curve.

4 Click the master pitch curve at the point you want to change the pitch of the song.

5 Drag the control point up or down to the new key. Unlike with volume and pan curves,
   the control points on the master pitch curve move in discrete steps of a semitone.

   Note: When you transpose a song to a new key, Real and Software Instruments (both
   those you’ve recorded and loops) are transposed. Any audio files added from the Finder
   are not transposed.

Using Effects
Effects let you shape and enhance the sound of your music in a variety of ways. Anyone
who’s listened to popular music on the radio, or listened to the soundtrack of a movie,
has heard the different effects used in contemporary music. GarageBand includes a
complete set of studio-quality effects that you can use on individual tracks or the
overall song to shape the sound of your music.
Types of Effects
GarageBand includes the following types of effects:

*Equalization (EQ)*: EQ is a powerful and versatile effect that lets you change the level of selected frequencies. You can use EQ to make both subtle and dramatic changes to your songs. EQ is likely the most commonly used effect in popular music.

*Dynamics*: Dynamics effects, which include compressors and noise gates, let you control the volume of your music over time.

*Reverb and Echo*: Reverb and echo are both time-based effects. Time-based effects store a copy of the sound and play it back at a later point in time, creating a sense of space.

*Modulation*: Modulation effects, which include chorus, flangers, and phasers, build on the time-based effects by shifting or modulating when the copied signal plays back. They can also involve detuning the copied signal relative to the original.

*Distortion*: Distortion effects, which include amp simulation and overdrive (and, of course, distortion!), change the tone of the original sound to recreate analog or digital distortion.

*Other effects*: Other effects included with GarageBand, such as tremolo and Auto Filter, change the sound in different ways.

Adding Effects
Each Real and Software Instrument track has a set of effects, which include a compressor, equalizer (EQ), echo, and reverb. You can adjust a track’s effects, and add up to two additional effects, in the Track Info window. Real Instrument tracks also include a noise gate effect.

The master track includes its own effects, and you can adjust the master effects and add one additional effect to the master track in the Master Track Info window.

**To add an effect:**
1. Click the Track Info button (the letter “i”) or choose Track > Show Track Info to show the Track Info window.
2. If needed, click the Details triangle to show the Effects section of the window.
3 Choose the effect you want to add from one of the pop-up menus along the left. Instrument tracks have two effect pop-up menus, and the master track has one.

Adjusting Effects
Each effect has either a slider that you can use to adjust the amount of the effect, or a pop-up menu from which you can choose different effect presets.

To adjust a track’s effects:
1 Select the track, then click the Track Info button to open the Track Info window.
2 Click the Details triangle to reveal the track’s effects settings.
3 Drag the sliders for the Gate, Compressor, Echo, and Reverb effects to adjust the amount of each effect. Choose a new setting from the Equalizer pop-up menu to adjust the equalization. If your song is playing, you hear the changes in real time.
4 Choose an effect from one of the Effect pop-up menus on the left, then choose an effect setting for the effect from the Preset pop-up menu on the right.

Additional effects you can add include treble reduction, bass reduction, amp simulation, chorus, flanging, phase shifting, and tremolo.
Turning Effects On and Off
You can turn individual effects on or off (turning an effect off temporarily is called *bypassing* the effect). This has several advantages: it lets you hear how each effect changes the sound of your music, and lets you see which effects have the greatest impact on your computer’s performance.

When you turn off an effect, the effect’s current settings are retained, so any adjustments you have made are not lost.

**To turn an effect off:**
- In the Effects section of the Track Info window, click the checkbox next to the effect. Click the checkbox again to turn the effect on again.

Choosing Effect Presets
Each effect includes several presets, which let you easily set the effect’s parameters to achieve a particular sound.

**To choose an effect preset:**
- Choose the preset you want from the Preset pop-up menu to the right of the effect’s row.

Editing Effect Presets
Some effects, such as the equalizer and amp simulation effects, include groups of settings called “presets,” which you choose from the effect’s Preset pop-up menu. You can adjust effect presets to fine tune the effect, and save your own presets to use with other instruments or in another song.

**To show the Preset window:**
- Click the Edit button (with the pencil icon) to the right of the effect’s row.

The effect’s Preset window appears. Each preset setting has a slider, button, or other control, and each control is named to indicate what it controls.

**To adjust an effect preset:**
- Drag the sliders in the Preset window to adjust the settings in the preset.

When you adjust an effect preset, it appears as “Manual” in the pop-up menu, so you know you’ve changed it from the original preset. You can go back and forth between your Manual settings and other presets to compare them before saving the new preset.
**Saving Effect Presets**

You can create your own effect presets and save them to use on another track or in another song.

**To save an effect preset:**
1. Adjust the settings for the preset to get the sound that you want.
2. Choose Make Preset from the pop-up menu, then type a name for the preset in the Save dialog.
# Keyboard Shortcuts

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Navigation/Moving the playhead</strong></td>
<td></td>
</tr>
<tr>
<td>Play/Pause</td>
<td>Space bar</td>
</tr>
<tr>
<td>Go to beginning</td>
<td>Home or Z</td>
</tr>
<tr>
<td>Go to end</td>
<td>End or Option-Z</td>
</tr>
<tr>
<td>Move back by one measure</td>
<td>Left Arrow</td>
</tr>
<tr>
<td>Move forward by one measure</td>
<td>Right Arrow</td>
</tr>
<tr>
<td>Move back by the visible width of the timeline</td>
<td>Page Up</td>
</tr>
<tr>
<td>Move forward by the visible width of the timeline</td>
<td>Page Down</td>
</tr>
<tr>
<td>Zoom out</td>
<td>Control-Left Arrow</td>
</tr>
<tr>
<td>Zoom in</td>
<td>Control-Right Arrow</td>
</tr>
<tr>
<td><strong>Tracks</strong></td>
<td></td>
</tr>
<tr>
<td>Create new track</td>
<td>Command-Option-N</td>
</tr>
<tr>
<td>Duplicate track</td>
<td>Command-D</td>
</tr>
<tr>
<td>Delete selected track</td>
<td>Command-Delete</td>
</tr>
<tr>
<td>Select next higher track</td>
<td>Up Arrow</td>
</tr>
<tr>
<td>Select next lower track</td>
<td>Down Arrow</td>
</tr>
<tr>
<td>Mute/Unmute selected track</td>
<td>M</td>
</tr>
<tr>
<td>Solo/Unsolo selected track</td>
<td>S</td>
</tr>
<tr>
<td>Show/Hide track volume curve</td>
<td>A</td>
</tr>
<tr>
<td>Show/Hide master track</td>
<td>Command-B</td>
</tr>
<tr>
<td><strong>Track Info window</strong></td>
<td></td>
</tr>
<tr>
<td>Show/Hide Track Info</td>
<td>Command-I</td>
</tr>
<tr>
<td>Select next higher category or instrument</td>
<td>Up Arrow (when Track Info window is open and either a category or an instrument is selected)</td>
</tr>
<tr>
<td>Action</td>
<td>Shortcut</td>
</tr>
<tr>
<td>-------------------------------------------------------------</td>
<td>--------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Select next lower category or instrument</td>
<td>Down Arrow (when Track Info window is open and either a category or an instrument is selected)</td>
</tr>
<tr>
<td>Move from instrument column to category column</td>
<td>Left Arrow (when Track Info window is open and an instrument is selected)</td>
</tr>
<tr>
<td>Move from category column to instrument column</td>
<td>Right Arrow (when Track Info window is open and a category is selected)</td>
</tr>
<tr>
<td><strong>New Track dialog</strong></td>
<td></td>
</tr>
<tr>
<td>Select next higher category or instrument</td>
<td>Up Arrow (when New Track dialog is open and either a category or an instrument is selected)</td>
</tr>
<tr>
<td>Select next lower category or instrument</td>
<td>Down Arrow (when New Track dialog is open and either a category or an instrument is selected)</td>
</tr>
<tr>
<td>Move from instrument column to category column</td>
<td>Left Arrow (when New Track dialog is open and an instrument is selected)</td>
</tr>
<tr>
<td>Move from category column to instrument column</td>
<td>Right Arrow (when New Track dialog is open and a category is selected)</td>
</tr>
<tr>
<td><strong>Toggle between Real/Software Instrument options</strong></td>
<td>Tab</td>
</tr>
<tr>
<td><strong>Editing and arranging</strong></td>
<td></td>
</tr>
<tr>
<td>Undo</td>
<td>Command-Z</td>
</tr>
<tr>
<td>Redo</td>
<td>Command-Shift-Z</td>
</tr>
<tr>
<td>Cut</td>
<td>Command-X</td>
</tr>
<tr>
<td>Copy</td>
<td>Command-C</td>
</tr>
<tr>
<td>Paste</td>
<td>Command-V</td>
</tr>
<tr>
<td>Delete</td>
<td>Delete</td>
</tr>
<tr>
<td>Select all</td>
<td>Command-A</td>
</tr>
<tr>
<td>Split region</td>
<td>Command-T</td>
</tr>
<tr>
<td>Join selected regions</td>
<td>Command-J</td>
</tr>
<tr>
<td>Snap to grid</td>
<td>Command-G</td>
</tr>
<tr>
<td><strong>Recording</strong></td>
<td></td>
</tr>
<tr>
<td>Record Start/Stop</td>
<td>R</td>
</tr>
<tr>
<td>Turn cycle region on/off</td>
<td>C</td>
</tr>
<tr>
<td>Turn metronome on/off</td>
<td>Command-U</td>
</tr>
<tr>
<td>Action</td>
<td>Shortcut</td>
</tr>
<tr>
<td>--------------------------------------------</td>
<td>---------------------------</td>
</tr>
<tr>
<td>Notation view</td>
<td></td>
</tr>
<tr>
<td>Moves selected notes to previous grid position</td>
<td>Left arrow</td>
</tr>
<tr>
<td>Moves selected notes to next grid position</td>
<td>Right arrow</td>
</tr>
<tr>
<td>Moves selected notes back one measure</td>
<td>Shift-Left arrow</td>
</tr>
<tr>
<td>Moves selected notes forward one measure</td>
<td>Shift-Right arrow</td>
</tr>
<tr>
<td>Transposes selected notes up a semitone</td>
<td>Up arrow</td>
</tr>
<tr>
<td>Transposes selected notes down a semitone</td>
<td>Down arrow</td>
</tr>
<tr>
<td>Transposes selected notes up an octave</td>
<td>Shift-Up arrow</td>
</tr>
<tr>
<td>Transposes selected notes down an octave</td>
<td>Shift-Down arrow</td>
</tr>
<tr>
<td>Adjusting master volume</td>
<td></td>
</tr>
<tr>
<td>Raise master volume</td>
<td>Command-Up Arrow</td>
</tr>
<tr>
<td>Lower master volume</td>
<td>Command-Down Arrow</td>
</tr>
<tr>
<td>Showing windows and editors</td>
<td></td>
</tr>
<tr>
<td>Show track mixer</td>
<td>Command-Y</td>
</tr>
<tr>
<td>Show Track Info window</td>
<td>Command-I</td>
</tr>
<tr>
<td>Show editor</td>
<td>Command-E</td>
</tr>
<tr>
<td>Show loop browser</td>
<td>Command-L</td>
</tr>
<tr>
<td>Show onscreen keyboard</td>
<td>Command-K</td>
</tr>
<tr>
<td>Show Musical Typing window</td>
<td>Command-Shift-K</td>
</tr>
<tr>
<td>File menu functions</td>
<td></td>
</tr>
<tr>
<td>New</td>
<td>Command-N</td>
</tr>
<tr>
<td>Open</td>
<td>Command-O</td>
</tr>
<tr>
<td>Close</td>
<td>Command-W</td>
</tr>
<tr>
<td>Save</td>
<td>Command-S</td>
</tr>
<tr>
<td>Save As</td>
<td>Command-Shift-S</td>
</tr>
<tr>
<td>Application menu functions</td>
<td></td>
</tr>
<tr>
<td>Show/Hide GarageBand Preferences</td>
<td>Command-comma (,)</td>
</tr>
<tr>
<td>Hide GarageBand</td>
<td>Command-H</td>
</tr>
<tr>
<td>Hide other applications</td>
<td>Command-Option-H</td>
</tr>
<tr>
<td>Quit GarageBand</td>
<td>Command-Q</td>
</tr>
<tr>
<td>Help menu functions</td>
<td></td>
</tr>
<tr>
<td>GarageBand Help</td>
<td>Command-question mark (?)</td>
</tr>
</tbody>
</table>
Connecting Music Equipment To Your Computer

If you sing or play a musical instrument, you can connect a musical instrument or a microphone to your computer and record your performances in your GarageBand songs.

Each recording appears as a region in a track in the timeline. You can add effects to the track, and edit the region in the editor.

Connecting a Musical Instrument or Microphone

You can connect an electric musical instrument or microphone to your computer and record it in a Real Instrument track.

You can connect a microphone to your computer using the computer’s audio in port, if your computer has one. You can also connect an audio interface to your computer, then connect instruments and microphones to the audio interface for recording. Audio interfaces are available in a variety of compatible formats, including USB, FireWire, PCI, and PC card formats. You can also connect an audio mixer or console to your computer, and record microphones or instruments through the mixer.

If you use an audio interface to connect musical instruments, check the manufacturer’s specifications to make sure the interface is compatible with Mac OS X 10.2.6 or later. Also make sure the audio interface uses a format supported by your computer. Follow the manufacturer’s instructions, which may include installing the correct driver on your computer.

If you connect an instrument or microphone to your computer’s audio in port, open System Preferences, click the button for Sound preferences, click the Input tab in the Sound pane, select Line In in the sound input list, then drag the Input volume slider to set the input level.
Connecting a Music Keyboard to Your Computer

If you play a keyboard instrument, you can connect a MIDI-compatible music keyboard to your computer to play and record Software Instruments.

To connect a music keyboard to play Software Instruments:
• If the keyboard is a USB MIDI keyboard, connect the USB cable to the keyboard and to your computer.
• If the keyboard is a standard MIDI keyboard, connect the keyboard to a MIDI interface using standard MIDI cables, and connect the interface to your computer.

Be sure to follow the instructions that came with the keyboard, which may include installing the correct driver on your computer.

Connecting Other Music Equipment

You may also want to connect speakers or monitors to your computer to hear your songs play back with greater audio quality than possible from your computer's speaker. A variety of monitors and speakers are available, including speakers you can connect directly to your computer's audio out port, through a USB port, or using an audio interface.

If you connect an audio interface to your computer, you set the audio interface as the audio input device for GarageBand. Before setting the audio input device, be sure to install any necessary driver software for the audio interface.

To set an audio interface as the audio input device:
1 Choose GarageBand > Preferences, then click the Audio/MIDI tab.
2 In the Audio/MIDI pane, choose the audio interface from the Audio Input pop-up menu.

If you connect a microphone, an instrument, or other audio device directly to your computer's audio-in port, you set may need to configure input settings for it in the Sound pane of your computer's System Preferences.

To configure input settings in System Preferences:
1 Choose System Preferences from the Apple menu, then click the button for Sound Preferences.
2 In the Sound Preferences pane, click the Input tab.
3 Select Line In from the sound input devices list, then drag the “Input” volume slider to set the input level.