Getting Started with
ADOBE® ROBOHELP® 8
Notice to U.S. Government End Users. The Software and Documentation are "Commercial Items," as that term is defined at 48 C.F.R. §2.101, consisting of "Commercial Computer Software" and "Commercial Computer Software Documentation," as such terms are used in 48 C.F.R. §12.212 or 48 C.F.R. §227.7202, as applicable. Consistent with 48 C.F.R. §12.212 or 48 C.F.R. §§227.7202-1 through 227.7202-4, as applicable, the Commercial Computer Software and Commercial Computer Software Documentation are being licensed to U.S. Government end users (a) only as Commercial Items and (b) with only those rights as are granted to all other end users pursuant to the terms and conditions herein. Unpublished-rights reserved under the copyright laws of the United States. Adobe Systems Incorporated, 345 Park Avenue, San Jose, CA 95110-2704, USA. For U.S. Government End Users, Adobe agrees to comply with all applicable equal opportunity laws including, if appropriate, the provisions of Executive Order 11246, as amended, Section 402 of the Vietnam Era Veterans Readjustment Assistance Act of 1974 (38 USC 4212), and Section 503 of the Rehabilitation Act of 1973, as amended, and the regulations at 41 C.F.R Parts 60-1 through 60-60, 60-250, and 60-741. The affirmative action clause and regulations contained in the preceding sentence shall be incorporated by reference.

Part number: 90095796 (12/08)
CONTENTS

Getting started
1  Resources
1  Activation and registration
2  Help and support
4  Services, downloads, and extras
5  Introduction to RoboHelp
5  What’s new in RoboHelp 8
GETTING STARTED

RESOURCES
Before you begin working with your software, take a few moments to read an overview of activation and the many resources available to you. You have access to instructional videos, plug-ins, templates, user communities, seminars, tutorials, RSS feeds, and much more.

ACTIVATION AND REGISTRATION
To review complete system requirements and recommendations for your Adobe® RoboHelp® 8 software, see the ReadMe file on the installation disc.

Install the software
1 Close any other Adobe applications open on your computer.
2 Insert the installation disc into your hard drive, and follow the onscreen instructions.

Note: For more information, see the ReadMe file on the installation disc.

Help with installation
For Help with installation issues, see the Installation Support Center at www.adobe.com/support/robohelp.

License activation
During the installation process, your Adobe software contacts an Adobe server to complete the license activation process. No personal data is transmitted. For more information on product activation, visit the Adobe website at www.adobe.com/go/activation.

A single-user retail license activation supports two computers. For example, you can install the product on a desktop computer at work and on a laptop computer at home. If you want to install the software on a third computer, first deactivate it on one of the other two computers. Choose Help > Deactivate.
Register
Register your product to receive complimentary installation support, notifications of updates, and other services.

Note: Register only once for RoboHelp 8.

❖ To register, follow the onscreen instructions in the Registration dialog box, which appears after you install the software.

If you postpone registration, you can register at any time by choosing Help > Registration.

ReadMe
A ReadMe file for your software is available online and on the installation disc. Open the file to read important information about topics such as the following:

- System requirements
- Installation (including removing the software)
- Activation and registration
- Troubleshooting
- Customer support

HELP AND SUPPORT

Community Help
Community Help is an integrated environment on Adobe.com that gives you access to community-generated content moderated by Adobe and industry experts. Comments from users help guide you to an answer. Search Community Help to find the best content on the web about Adobe products and technologies, including these resources:

- Videos, tutorials, tips and techniques, blogs, articles, and examples for designers and developers.
• Complete online Help, which is updated regularly and is more complete than the Help delivered with your product. If you are connected to the Internet when you access Help, you automatically see the latest online Help rather than the set delivered with your product.
• All other content on Adobe.com, including knowledgebase articles, downloads and updates, Adobe Developer Connection, and more.

Use the Help search field in your product user interface to access Community Help. You can search for content within the Adobe.com site and also in websites that have useful information about your product. Moderators continue to identify the most relevant web content for your product. You can add comments to online Help and view comments added by other users. For a video of Community Help, see www.adobe.com/go/learn_community_help_en.

Adobe Help Viewer 2
Adobe Help Viewer 2 is an Adobe® AIR™ application that seamlessly merges the online and offline experience. When online, you get the most recently updated product Help on the web. You can also access an Adobe PDF version of Help. When offline, you access Help installed with the product on your system. Adobe Help Viewer 2 has a user-friendly interface that supports advanced navigation features. For example, you can get overviews of topics through mini TOCs and bookmark local and online content.

The search feature supports both online and offline modes. Adobe Help Viewer 2 searches content in Community Help when you are online and the Help installed with the product when you are offline. Online search suggestions offer relevant results from product Help, Adobe.com, and other websites. Offline search uses indexes to return preferred topics for key terms.

You can use the commenting feature to post your comments to Adobe.com or add notes for your own reference. Your feedback on Help content is welcome.

Note: For a video of Adobe Help Viewer, see www.adobe.com/go/learn_air_viewer2_en.

Other resources
Online Help also includes a link to the complete, updated PDF version of Help.
Visit the Adobe Support website at www.adobe.com/support/robohelp to learn about free and paid technical support options.

SERVICES, DOWNLOADS, AND EXTRAS

You can enhance your product by integrating various services, plug-ins, and extensions in your product. You can also download samples and other assets to help you get your work done.

Adobe Exchange
Visit the Adobe Exchange at www.adobe.com/go/exchange to download samples as well as plug-ins and extensions from Adobe and third-party developers. The plug-ins and extensions can help you automate tasks, customize workflows, create specialized professional effects, and more.

Adobe downloads
Visit www.adobe.com/go/downloads to find free updates, trials, and other useful software.

Adobe Labs
Adobe Labs at www.adobe.com/go/labs gives you the opportunity to experience and evaluate new and emerging technologies and products from Adobe. At Adobe Labs, you have access to resources such as these:

- Prerelease software and technologies
- Code samples and best practices to accelerate your learning
- Early versions of product and technical documentation
- Forums, wiki-based content, and other collaborative resources to help you interact with like-minded users

Adobe Labs fosters a collaborative software development process. In this environment, customers quickly become productive with new products and technologies. Adobe Labs is also a forum for early feedback. The Adobe development teams use this feedback to create software that meets the needs and expectations of the community.
Adobe TV

INTRODUCTION TO ROBOHELP
Adobe RoboHelp 8 software is designed for developing Help systems, eLearning content, policies and procedures, and knowledgebases. Its enhanced editing and layout capabilities enable you to create professional looking content. You can publish this content to multiple channels, including Adobe AIR for an integrated online and offline user experience.

Worldwide, Adobe RoboHelp 8 is a leader of online Help authoring tools through innovation. New features create a more productive experience for technical communicators and their audiences.

WHAT’S NEW IN ROBOHELP 8
Authoring enhancements
XHTML support  RoboHelp creates topic files in Extensible Hypertext Markup Language (XHTML) and project-specific files in XML. Structured authoring in XHTML ensures well-written code, closed tags, no overlapping of tags, properly quoted attributes with explicit values, and no proprietary attributes. RoboHelp upgrades all the old RoboHelp HTML topics to XHTML when it upgrades or imports them.

You can import an XHTML or HTML topic from the File menu and open the topic to edit in HTML view directly. For detailed Help, see “Author in XHTML” in online Help.

Enhanced editing support in Design Editor  The enhanced Design Editor in RoboHelp 8 lets you use advanced list and table styles, drag and drop text in tables, and merge and split table cells. It provides clean code with no proprietary tags. All the RoboHelp specific code is in the form of XML standard processing instructions (PIs). For more information on lists and styles, see “Author in XHTML” in online Help.

World Wide Web 3 Compliance (W3C)  RoboHelp 8 provides an option to validate topics and projects for W3C compliance. It displays error messages or warnings that appear for any noncompliance with W3C. See “W3C compliance” in online Help.
**List and table enhancements**  RoboHelp 8 supports advanced lists and autonumbering. You can apply styles to change the appearance of lists. See “Create and manage list styles” in online Help.

Enhanced table support allows you to insert columns and rows in a table, and cut, copy, and paste columns, rows, and cells. You can merge and split cells and insert a table within a table. See “Create and manage table styles” in online Help.

**Enhanced language support**  RoboHelp 8 provides multiple-language support at the paragraph, topic, and project level. The language defined at a paragraph level takes precedence over the language defined at a topic or project level. The language that takes precedence at a level is called the *effective language*. The effective language is used in spell-checking, the dictionary and thesaurus, generation of the smart index, and preparation of the full-text search, not only at a project level but also at a topic and paragraph level. See “Support for multiple languages” in online Help.

**Insert HTML comments, iframe**  You can insert an HTML comment at any location in a topic. These HTML comments are added in a particular format and viewed in a pop-up window. See “HTML comments in topics” in online Help.

You can insert an iframe in an HTML topic to include another HTML page or PDF file in it. You can also access URL links to view a web page in an iframe. See “Iframes” in online Help.

**Import enhancement features**

**Project-based common import settings**  Create a standard set of conversion settings for importing Adobe® FrameMaker® or Microsoft® Word content into RoboHelp projects and use these settings across multiple projects. These settings include FrameMaker or Word templates, Cascading Style Sheets (CSS) for RoboHelp projects, style mapping between FrameMaker formats or Word styles and RoboHelp styles, and all other settings specified in the Conversion Settings dialog box.

**Direct import of HTML or XHTML files**  You can import HTML or XHTML files directly from File > Import > HTML/XHTML File.

**Enhanced FrameMaker document import**  In RoboHelp 8, you can import and link FrameMaker 8 and 9 books.
RoboHelp 8 maintains content integrity for imported FrameMaker content. RoboHelp retains lists, tables, images, SWF content, conditional text, variables, tables of contents (TOCs), indexes, glossaries, and user-defined markers as processing instructions (PIs). Enhancements in importing FrameMaker files allow for the following:

- Enhanced Add or Import settings from a common user interface
- New workflow
- FrameMaker template support
- Import styles for style mapping (table styles, list styles, and image settings)
- Enhanced import of vector graphics
- Import of alt text for anchored frames
- List conversion option for each style
- Import and export of settings
- Pagination on FrameMaker styles
- Custom HTML tag for each style
- Ignoring empty topics (after pagination)
- Project upgrade

**Enhanced Word document import and linking**  RoboHelp enables you to include Microsoft Word document formats (*.doc, *.docx, *.docm, *.rtf) as source files in RoboHelp 8. You can add Microsoft Word documents to a RoboHelp project, update them when the Word documents change, and generate different single-source outputs. The source documents as well as generated topics, CSS, images, multimedia, the TOC, the index, and the glossary are visible in RoboHelp. You can manage, preview, sync, and control Word documents from RoboHelp. You can link Microsoft Word documents in RoboHelp by copy or reference. See “Importing and linking Microsoft Word documents” in online Help.

**DITA content import**  RoboHelp 8 allows for the import of a DITA map file or a DITA topic into an existing RoboHelp project. You can also import a DITA map file to create a RoboHelp project and publish the desired output. See “Import DITA map files” in online Help.
Single-sourcing features

New CSS editor The style-editing interface is new, letting you change the most common properties quickly. The new Style editor enables you to define new styles such as lists and table styles. You can define multilevel lists and autonumbering in the Style editor. Using the Style editor, you can change images in twisties, and in drop-down and expanding hotspots. See “Manage style sheets” in online Help.

Styles and Formatting pod The Styles and Formatting pod enables you to apply styles and lets you access the Style editor to create a style or edit a style. See “Create a style using the Styles And Formatting pod” in online Help.

Master pages support Master pages separate content from the layout. Master pages also act as a template for a particular HTML topic. In RoboHelp 8, you can define the placement of headers, footers, and HTML text. You can add placeholders for breadcrumbs and mini TOCs in master pages. See “Master pages” in online Help.

Resource Manager pod The Resource Manager stores all the common resources to use across projects and allows for quick access and management of common resource files. See “Resource Manager pod” in online Help.

Formatted user-defined variables A formatted user-defined variable is a single-sourcing inline element containing styling information. Using the new Design Editor especially designed for editing variable styles, you can apply formatting on the text and insert images, multimedia, and FLA files. See “Format a user-defined variable” in online Help.

Apply master pages or CSS in SSL Single-source layouts let you override master pages or the CSS when output is generated. For different output results, you can apply different master pages or a different CSS to all the topics in a project. See “Applying a master page or CSS at the time of generation” in online Help.

Publishing features

Adobe AIR The Adobe AIR output type allows you to generate Help in Adobe AIR format. The cross-platform Adobe AIR Help format provides several enhancements, such as these:

- Easy navigation through breadcrumbs
• New templates and skins
• A rich branding experience, and the ability to insert corporate logos and an About box in Help
• Rich commenting and auto-updates
• Browser-based Help, with both offline and online content
• Ability to add and access RSS feeds
• Enhanced search

See “Adobe AIR” in online Help.

**Search enhancements**   New RoboHelp search supports the following features:

• Ranking of search results
• Keyword search
• Synonym search
• Excluded topic search
• Multiple-language search
• Substring search
• Phrase search
• Customizable search results list
• Topic context in search list
• Baggage file search

See “RoboHelp Search” in online Help.

**Enhanced printed documentation options**   Apply either a Microsoft Word template or a style sheet to the content when you generate output.

**Breadcrumbs and mini TOCs**   Use placeholders for breadcrumbs and mini TOCs in master pages and topics. Generate or preview Help to automatically insert the breadcrumbs and mini TOCs. See “Insert a placeholder” in online Help.
**Glossary enhancements**  In RoboHelp 8, a topic always has the updated definition for a marked term. The Glossary Hotspot wizard inserts markers for the terms defined in the glossary. It does not insert definitions. Instead, RoboHelp adds definitions when you generate previews or output. Thus a topic always has the updated definition for a marked term. See “Glossary hotspots” in online Help.

**Merged project enhancements**  Merged project enhancements introduce the concept of a child project referring to a master TOC. Child projects automatically synchronize with the merged TOC, and you can see the merged TOC in the child projects.

**DHTML effects support in Safari and Firefox**  Some RoboHelp layouts support DHTML effects in Safari and Firefox browsers. The supported DHTML effects include Spiral In, Spiral Out, Zoom In, Zoom Out, Show, Fly In, Fly Out, and Elastic.

**Twisties**  Use twisties in the CSS editor to enhance glossary terms, drop-down text, and expanding text. You can change images in twisties for open and close. RoboHelp displays glossary terms, drop-down text, and expanding text with images to expand or collapse them. See “Twisties” in online Help.

**Productivity features**

**Scripting support**  In RoboHelp 8, you can create your own scripts to automate repetitive tasks and key workflows. The Script Explorer pod enables you to execute and manage scripts, and you can execute your scripts using the command-line parameters.

RoboHelp provides a set of sample scripts that you can use right away or customize for your needs. You can access these sample scripts, such as Word Count, UDV Converter, EclipseHelp.jsx, SaveAsProjectTemplate.jsx, or Link Converter, or create your own scripts using the Script Explorer pod. See “About ExtendScript Toolkit support” in online Help.

Adobe ExtendScript Toolkit 4.0, included with RoboHelp 8, enables you to author and debug scripts.

**Integration with Adobe Captivate 4, RoboSource Control 3.1, and RoboScreenCapture**  Create and edit Adobe Captivate® 4 demos and simulations from within the RoboHelp HTML application.
While installing RoboHelp HTML 8, you have the option to install RoboSource Control™ 3.1 to control the versions of projects.

You can open and edit images using RoboScreenCapture from within the RoboHelp HTML application.

**Custom To Do list**  RoboHelp 8 helps you manage a To Do list, facilitating addition and deletion of To Do items from the project. By default, RoboHelp 8 supports 11 To Do list items. See “Using the To Do list” in online Help.

**Usability features**

**Project Manager enhancements**  In the Project Manager pod, you can customize the ordering of topics in folders to define a chapter layout for the project. The Auto-Create TOC feature uses the ordering to create a logical TOC. You can sort the order of folders and topics alphabetically.

**Option to install RoboHelp for Word**  The RoboHelp 8 installer gives you the option of installing RoboHelp for Word. By default, the option is not selected.

**File type mapping**  In RoboHelp 8, you can associate various file types with applications installed on your system. See “File type mapping” in online Help.

**Re-create the project cache**  The new Re-create Project Cache option re-creates the project CPD file before opening the project. This option ensures that you don’t have to delete the CPD file manually.

**Windows Explorer support**  Locate files and folders on your system using Microsoft® Windows® Explorer. In the Project Manager and Project Set-up pods, right-click and select the Explore option to locate files or folders.

**Desktop icons during installation**  You can opt to create desktop icons during installation.

**Support for Adobe® Flash® content**  In RoboHelp 8, you can insert FLV files and play them in Flash® Player, which is provided with RoboHelp 8.
Additional browser support  In RoboHelp 8, you can open web-based Help in different browsers such as Firefox, Safari, and Microsoft Internet Explorer. This support is improved for Firefox and Safari browsers.

Change default TOC, index, and glossary  In RoboHelp 8, you have an option to set any TOC, index, or glossary as the default.

Topic tab support  You can close a topic from the topic tab by choosing File > Close, or by pressing Ctrl+F4.