Using
ADOBE® FRAMEMAKER® XML AUTHOR
2015 release
Legal notices
Contents

Chapter 1: Getting Started
Activation, registration, and System requirements ........................................... 1
Help and support .................................................................................................. 2
Services, downloads, and extras ......................................................................... 4
What's new in FrameMaker XML Author ......................................................... 5

Chapter 2: About FrameMaker XML Author
Author .................................................................................................................. 9
Collaborate ........................................................................................................ 9
Review ............................................................................................................... 10
Feature Overview .............................................................................................. 10

Chapter 3: FrameMaker XML Author Basics
User interface ..................................................................................................... 13
Accessibility features in FrameMaker XML Author ........................................... 43
Opening, saving, and closing documents ............................................................ 43
Restore last session .......................................................................................... 49
Document direction ........................................................................................... 50

Chapter 4: Variables, line numbers, and document creation
Variables ......................................................................................................... 51
Line numbers ................................................................................................... 59
Create documents ............................................................................................. 60

Chapter 5: Text
Adding and editing text .................................................................................... 62
Working with elements in structured documents .............................................. 63
Search for items ............................................................................................... 81
Check spelling ................................................................................................ 86
Use the Thesaurus ............................................................................................ 92
Multiple Undo/Redo ......................................................................................... 93
Equations ........................................................................................................ 96
Working with multiple languages .................................................................. 132

Chapter 6: Tables
About tables .................................................................................................... 137
Insert, move, or remove a table ....................................................................... 138
Text and graphics in tables ............................................................................. 143

Chapter 7: Graphics
Graphics and objects ....................................................................................... 150
Using color in text and objects ....................................................................... 169
Anchored frames ............................................................................................. 173
Hotspots ........................................................................................................... 185
Object Styles ................................................................. 187
Using RoboScreenCapture ............................................. 188

Chapter 8: Dynamic Documents
Markers ................................................................. 191
Create hypertext links .................................................. 192
Create ways to start, open, and close applications .......... 194
Test and troubleshoot hypertext documents ................. 196
Cross-references ...................................................... 197

Chapter 9: Books and Long Documents
About books ............................................................. 209
Create books ........................................................... 211
Managing books ......................................................... 214
Footnotes and endnotes ................................................. 217
Conditional documents .................................................. 221
Troubleshooting books ................................................ 223

Chapter 10: Working with Documents
Importing and linking files ............................................ 233
Embedding objects ........................................................ 251
3D object part links ...................................................... 255
Interactive Links for 3D/Multimedia Objects ................. 257
Export text and graphics ............................................... 260
Smart paste hypertext and MS® Word contents as structured content ........................................... 262
Managing files using WebDAV ........................................ 264
Package related files into a zip file ................................. 267

Chapter 11: Editing Content
Identify changes by tracking edited text ......................... 269
Track changes at book or map level ............................... 271
Using Dropbox for review and collaborative writing ....... 272
Compare versions to view changes ................................. 274
Determine word and character count ............................. 276
Import PDF comments .................................................. 276
Roundtripping tables, equations, and anchored frames .... 279
Direct OLE support in XML .............................................. 281

Chapter 12: Structured Authoring
Introduction to structured authoring ......................... 282
XML with FrameMaker XML Author ............................... 287
Error console ............................................................. 293
Filter By Attribute ....................................................... 294
Banner text ................................................................. 302
Regular Expression ...................................................... 304
XPath ...................................................................... 304
Simplified XML ........................................................ 306
## Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Working with structure</td>
<td>420</td>
</tr>
<tr>
<td>Element menu</td>
<td>421</td>
</tr>
<tr>
<td>Other useful shortcuts</td>
<td>422</td>
</tr>
</tbody>
</table>
Chapter 1: Getting Started

Before you begin working with your software, take a few moments to read an overview of activation and the many resources available to you. You have access to instructional videos, plug-ins, templates, user communities, seminars, tutorials, RSS feeds, and much more.

Resources
Before you begin working with FrameMaker XML Author, take a few moments to read an overview of activation and the many resources available to you. In addition to the links below, you have access to instructional videos, plug-ins, templates, user communities, seminars, tutorials, RSS feeds, and much more online.

- Activation and registration
- Adobe TV instructional videos for FrameMaker XML Author
- Adobe FrameMaker discussion forum
- Framers -- An email list for FrameMaker discussions

Activation, registration, and System requirements

To review complete system requirements and Adobe Recommendations for your Adobe® FrameMaker XML Author® 12 software, see the product page at www.adobe.com/products/framemaker.

System requirements

Before installing FrameMaker XML Author, make sure that you have the required hardware and software:

- Intel Pentium 4 or faster processor
- Microsoft Windows 7, or 8.1
- 1GB of RAM (2GB recommended)
- 3GB of available hard-disk space for installation; additional free space required during installation (cannot install on a volume that uses a case-sensitive file system or on removable flash storage devices)
- DVD-ROM drive
- 1024x768 screen resolution (1280x800 recommended) with 16-bit video card
- This software does not operate without activation. A broadband Internet connection and registration are required for software activation, validation of subscriptions, and access to Online Services.
  
  Note: Phone activation is not available.

Install the software

1 Close any Adobe applications open on your computer.
2 Insert the installation disc into your disk drive, and follow the onscreen instructions.
Help with installation
For help with installation issues, see the Installation Support Center at www.adobe.com/go/learn_fm_install_en.

License activation
During the installation process, your Adobe software contacts an Adobe server to complete the license activation process. No personal data is transmitted. For more information on product activation, visit the Adobe website at www.adobe.com/go/activation.

Register
Register your product to receive complimentary installation support, notifications of updates, and other services.
❖ To register, follow the onscreen instructions in the Registration dialog box, which appears when you first start the software.

If you postpone registration, you can register at any time by choosing Help > Registration.

Help and support
Visit the Adobe Support website at www.adobe.com/support/framemaker to access documentation, along with tutorials and troubleshooting information. You can also access customer support information from this page.

Online Help also includes a link to the complete, updated PDF version of Help.

Adobe Community Help
Adobe Community Help is an integrated environment on Adobe.com that gives you access to community-generated content moderated by Adobe and industry experts. Think of Community Help as collections of related items rather than books. Adobe continually curates and adds to these collections.

Bookmark the FrameMaker Help hub page to find the best content on the web about FrameMaker XML Author, including these resources:

• Videos, tutorials, tips and techniques, blogs, articles, and examples for designers and developers.
• Complete online Help, which is updated regularly.
• All other content on Adobe.com, including knowledgebase articles, downloads and updates, Adobe Developer Connection, and more.

Accessing FrameMaker XML Author help

Accessing help using a web browser
FrameMaker XML Author help is available on-line at the following location FrameMaker Help. You can view the help using a web browser (Internet Explorer, Safari, Chrome, Firefox, etc.) independent of the product. This means, you do not need to open FrameMaker XML Author to access the online help using a web browser.

The online help includes a search functionality that you use to search for help in the FrameMaker XML Author documentation or across adobe.com.

The online help also includes a PDF that you can download and view when you are offline.
For more information on the offline Help, see Offline Help.

Accessing help from within FrameMaker XML Author
When you are working in FrameMaker XML Author, press F1 to launch the help in a context-sensitive Help viewer.

• If you are online and you launch help from within FrameMaker XML Author, the product launches the online help within the Help viewer. This viewer launches as an independent window. If you are working in a multi-screen environment, you can keep FrameMaker XML Author on one screen and drag the viewer to the other screen.

Since the viewer is context-sensitive, you can go to a help topic corresponding to your context in the application.

For example, if you are in the multi-channel publishing pod, press F1 to go to the corresponding help content for this feature.

Note: You can use the search functionality in the Help viewer to search for topics within FrameMaker XML Author help. To search for help within FrameMaker XML Author and across adobe.com, go to the online help using a web browser.

• If you are offline, the context-sensitive Help launches a Microsoft Help (CHM) viewer. The offline viewer provides you the same in-product, context-sensitive functionality that you experience using the online Help viewer.

Important: The offline Help CHM file is delivered with each new patch that Adobe provides. If FrameMaker XML Author Help is updated between patches, follow the instructions in this knowledge base article to download and install the updated Help file.

Services, downloads, and extras
You can enhance your product by integrating various services, plug-ins, and extensions in your product. You can also download samples and other assets and see various resources to get your work done.

Adobe Exchange
Visit the Adobe Exchange at www.adobe.com/go/exchange to download samples as well as plug-ins and extensions from Adobe and third-party developers. The plug-ins and extensions can help you automate tasks, customize workflows, create specialized professional effects, and more.

Adobe downloads
Visit www.adobe.com/go/downloads to find free updates, trials, and other useful software.

Adobe Labs
Adobe Labs at www.adobe.com/go/labs gives you the opportunity to experience and evaluate new and emerging technologies and products from Adobe. At Adobe Labs, you have access to resources such as these:

• Prerelease software and technologies
• Code samples and best practices to accelerate your learning
• Early versions of product and technical documentation
• Forums, wiki-based content, and other collaborative resources to help you interact with like-minded users

Adobe Labs fosters a collaborative software development process. In this environment, customers quickly become productive with new products and technologies. Adobe Labs is also a forum for early feedback. The Adobe development teams use this feedback to create software that meets the needs and expectations of the community.
Adobe forums
To reach out to experts in the Adobe RoboHelp community, visit http://forums.adobe.com/community/framemaker. If you comment on a Help page, the comment is automatically posted on the forum. The experts and other users can respond to your comment.

Adobe TV

FrameMaker Developer Center
Visit FrameMaker Developer Center for articles written by internal and external RoboHelp users on various user-requested topics.

Other resources
Online Help also includes a link to the complete, updated PDF version of Help.
Visit the Adobe Support website at www.adobe.com/support to learn about free and paid technical support options.
Visit the following resources to interact with the FrameMaker community.
• Adobe Forums: http://forums.adobe.com/community/framemaker
• Adobe Blogs: http://blogs.adobe.com/
• Adobe TV: http://tv.adobe.com/product/framemaker/

Services, downloads, and extras
You can enhance your product by integrating various services, plug-ins, and extensions in your product. You can also download samples and other assets to Help you get your work done.

Adobe downloads
Visit www.adobe.com/go/downloads to find free updates, trials, and other useful software.

Adobe Labs
Adobe Labs at www.adobe.com/go/labs gives you the opportunity to experience and evaluate new and emerging technologies and products from Adobe. At Adobe Labs, you have access to resources such as these:
• Prerelease software and technologies
• Code samples and best practices to accelerate your learning
• Early versions of product and technical documentation
• Forums, wiki-based content, and other collaborative resources to Help you interact with like-minded users
Adobe Labs fosters a collaborative software development process. In this environment, customers quickly become productive with new products and technologies. Adobe Labs is also a forum for early feedback. The Adobe development teams use this feedback to create software that meets the needs and expectations of the community.
Adobe TV
Visit the technical communications channel on Adobe TV at http://tv.adobe.com/channel/technical-communication for instructional videos on authoring.

What’s new in FrameMaker XML Author
Adobe FrameMaker 2015 ships with a number of enhancements.

Structured authoring and XML Enhancements

Simplified XMLAuthor:
FrameMaker now makes it easier for the subject matter experts and casual authors to create valid XML documents without the need to know the underlying XML structure. DITA 1.2 structured application has been enhanced to support the new Simplified XML authoring environment. The new simplified authoring interface provides a form-like easy-to-fill authoring environment.

While authoring, you can also use the Quick Elements Toolbar to easily insert the most commonly used objects, such as numbered list, image, or a section in your document.

Out-of-the-box FrameMaker supports DITA 1.2 topics, however, you can also design your own structured applications to use the Simplified XML authoring environment. You can also customize the appearance of the form fields by updating the associated template.

For more information, see Simplified XML.

DITA 1.3 support
FrameMaker now provides support for DITA 1.3. This means that now you can create troubleshooting DITA topics.

For more information, see Customization.

Structure view enhancements
Working with the Structure View is now more intuitive. Enhancements to the way elements are accessed and displayed makes navigating through your document much easier.

In addition to the triangle insertion point displayed in the Structure View, the element bubble containing the insertion point in your document is now highlighted. If your insertion point is inside an element whose parent is collapsed in the Structure View, the parent element is highlighted to indicate the top level location of your insertion point.

The right-click context menu includes the option to locate your current location in the Structure View. You can also use the Ctrl+Shift+L keystroke to locate your element in the Structure View.

When dragging and dropping elements across the Structure View, the destination pointer changes color based on whether the destination is structurally valid or not. You can, however, still choose to place an element at a location that is structurally invalid. If the target location element is collapsed, hover the mouse over the element to expand the target element.

You can choose to expand and collapse all sibling elements or all child elements in the Structure View. The right-click menu for an element includes an item for expanding and collapsing elements.
When scrolling through your document using the mouse or the scroll bars, FrameMaker also scrolls through the contents in the Structure View. The document view and the Structure View are therefore always synchronized. This synchronization is also maintained when you scroll through the Structure View. This feature is turned off by default. You can choose to activate the synchronization from the FrameMaker Preferences dialog.

For more information, see Working with the Structure View.

**MathML object enhancements**

**Saving PDF documents with MathML equations**

When saving files as PDF documents, MathML objects are now saved with the EPS facet instead of PNG. In addition to making the object text searchable, the EPS facet enhances the clarity of the MathML object.

**MathML object styles**

You can now apply any of the object styles available in your template, to a MathML object. The compose DPI property is not supported for MathML objects. When you open previous versions of FrameMaker files the compose DPI property is not honored.

**Support for inline MathML equations**

By default, when you insert a MathML equation in a document, the equation is placed on the next line after the current insertion point. You can use the inline property to place the MathML equation inline with the paragraph text.

The Ambient property allows you to specify that the following MathML styles will be inherited from the styles of the enclosing text:

- Font color, size, and family
- Background color

You can update the inline and ambient properties of a MathML equation that is included from within the object properties dialog. Alternatively, you edit or create an object style with these properties are already set and then apply this object style to an MathML equation.

For more information, see Format a MathML equation.

**Ditaval support in DITA-OT publishing**

When generating output using the DITA Open Tool kit, you can specify conditional filtering of content using attribute-value pairs in a ditaval file. While the location of the ditaval file could be specified in ditafm.ini, you can now select your ditaval file from the Generate DITA-OT Output dialog.

For more information, see Generate output using DITA OT.

**Preview child map in DITA maps**

If a DITA map includes references to child maps, the Show and Hide options in the DITA map will show or hide the topics referenced in the child maps.

For more information, see Display DITA map content.
Right-to-left language support
FrameMaker now supports right-to-left (RTL) language scripts such as Hebrew and Arabic. You can author the entire document in the RTL script of your choice or you can author a document in both RTL and LTR scripts simultaneously. For example, in an LTR document, you can include selected paragraphs or tables that are authored in an RTL script. You can also author a document containing both RTL and LTR content.

Bi-directional content authoring
FrameMaker provides out-of-the-box document direction support for both unstructured documents (see Set the direction of a document) and DITA topics (see Change text direction). However, for structured documents based on other structured applications, the application developer will need to define the dir property in the EDD. For details, see the Structured applications reference guide.

You can also choose to author multi-directional documents. This means that you can author a document in a specific direction that includes parts authored in the other direction.

You can import Word documents into FrameMaker that contain content that is either LTR or RTL (see Import Microsoft Word files). You can also copy and paste such text to and from FrameMaker documents.

You can also flip objects, such as images, in a document.

Bi-directional content translation
You can also flip objects, such as images, in a document.

See the video, Bidirectional content flipping.

Authoring and productivity enhancements

Table Enhancements

Conditionalize table columns
Apply conditional tags to individual columns in any of your tables. The column reflects the formatting specified in the conditional tag. The columns are either displayed or hidden based on the settings you save from the Show/Hide Conditional Text dialog. The conditional tag state for a column overrides any conditional tags that are applied to the text in the individual cells in the column.

For more information, see Conditional text.

Table usability enhancements
Use one of the multiple table formats available to you when creating a new table. You can choose to use the new formats for existing tables, from the Table Designer or the Table Catalog. Use the Table Designer to modify a table design as required.

For more information, see Insert a table.

Navigate through the cells of a table using either the Tab key or the arrow keys on your keyboard. Pressing Tab when you are in the last cell of the table, creates a new row at the end of the table.

For more information, see Rows and columns.

You may need to reorder the rows and columns in your table. Select the row or column you want to move and hold the Shift key down before you drop the row or column to the desired location. You can select multiple rows and columns for reordering.
For more information, see Copy, move, or reorder rows or columns.

**Auto insert table continuation variables**
Add continuation variables to a table using the Add Variables option from the right-click menu. Apply the variables you created to the current table, to all tables, or to all tables of a certain format.

For more information, see Insert a table.

**Table cell shading with solid fill**
In previous releases, the color tint property of a table, would cause the color to be displayed as a granular pattern. The functionality now changes the color to a shade based on the percentage of the tint.

### User interface enhancements

#### Location of modal pods
FrameMaker now remembers the location of the modal pods in the application.

#### Activate opened pods
If a modeless pod is currently opened and a user opens the pod again (using the menu or shortcut keys), the pod is highlighted as an indicator to the user.

#### Resizable dialogs
The following modal and client dialogs can be resized:

- Set Up Table of Contents (Special > Table of Contents > Standalone TOC)
- Set Up Mini Table of Contents (Special > Table of Contents > Create Mini TOC).
- Set Up Standard Index dialog (Special > Standard Index).
- Set Up Author Index dialog (Special > Index Of > Authors).
- Set Up Subject Index dialog (Special > Index Of > Subjects).
- Set Up Index Of Markers dialog (Special > Index Of > Markers).
- Set Up Index Of References dialog (Special > Index Of > References).
- DITA Conref dialog (DITA > Insert Conref)
- DITA Cross-Reference dialog (Special > Cross-Reference)
- DITA Link dialog

The following modeless dialogs can be resized:

- Show / Hide Conditional Text dialog
- Cross-Reference dialog

#### Redesigned pods
The following pods have been redesigned to improved usability:

#### Pods do not gray out on resize
If pods are docked at the bottom of the screen and a user reduces the size of the FrameMaker window, the pods are grayed out only if the size of the window is reduced to an extent that prevents functioning of the pod.

#### Drag and drop to open files
You can now drag-and-drop files from the Windows Explorer to empty UI areas, toolbars, menu bars, pods, or document window to open them.

#### Conditional tag pod State button
Now when you apply a condition to text in a document, the State checkbox operates as a toggle. This implies that if you apply a condition to text, you need to check the State checkbox. To remove a condition from text, you need to uncheck the State checkbox.

The intermediate state is read-only. This implies that if you select text where the current condition is partially applied, the checkbox displays with the intermediate state.
Chapter 2: About FrameMaker XML Author

FrameMaker XML Author (FMXA) is an XML authoring solution. It is a fully standards-compliant XML editor. In FMXA, you can create XML content based on a standard such as DITA or any custom structure with the easy-to-use and familiar FrameMaker interface.

FMXA is provided for content creators who are authoring entirely in XML. FMXA ships with the WYSIWYG view for writers who prefer not to work in the XML environment. However, for content creators comfortable with raw XML authoring, FMXA also includes the XML and code views. FMXA excludes the FrameMaker functionality that is not specific to XML authoring. For this reason, XML authors will work with a lightweight user interface but with all the FrameMaker tools required for XML authoring.

Author

FMXA is targeted at XML authors - content creators who have the need to author in an XML environment but do not require features such as publishing, template creation, and structure app development. Content creators are provided with the full capability to author in any of the FrameMaker views: WYSIWYG, XML or Code view ("XML view, Author view, and WYSIWYG view" on page 37). You can also add equations to your documents "Using the FrameMaker XML Author Equation Pod" on page 96 or "Using the MathFlow editor from Design Science" on page 128.

For a complete list of features, see the FMXA "Feature List" on page 11.

Collaborate

Since the features in FMXA are a subset of the complete FrameMaker feature set, users of both these products can work in a collaborative environment.

An XML document created either in FrameMaker or FMXA will work seamlessly in the other environment. This means that the decision to choose one environment over the other depends completely on the needs of the user. If the content creator and subject matter experts in a team do not require full FrameMaker capability, they can choose FMXA and still exchange XML documents with the FrameMaker users. FrameMaker users on the team can be tasked with publishing (such as Multi-channel publishing), creating the structured apps, and managing templates.

FMXA allows for integration with a variety of industry-standard CMS:

1 Ships with a native connector to “Adobe Experience Manager (AEM)” on page 348
2 Provides connectors to: "Documentum, SharePoint, DITAExchange" on page 355

FMXA also allows you to share and maintain topics and related files using Dropbox. For details, see “Using Dropbox for review and collaborative writing” on page 272.

For a complete list of features, see the FMXA “Feature List” on page 11.
Review

FMXA is targeted at reviewers working in an XML environment. XML authors can create their content in this environment. The content can then be sent to subject matter experts. While PDF is often used as a means for document review, FMXA provides reviewers with the tool to review, comment, and use track changes to enhance the review process. PDF review, on the other hand, can be used for a larger review audience. After completing a PDF review, you can also use the FMXA “Import PDF comments” on page 276 feature.

For a complete list of features, see the FMXA “Feature List” on page 11.

Feature Overview

From the complete FrameMaker feature set, FMXA takes a large set of features to enable XML authoring. In this regard, it excludes features that are not required by an XML author. For example, FMXA does not include the functionality to create and work with unstructured FrameMaker documents. However, it does include WYSIWYG, Author, and XMLCode views. This allows content creators to perform a large majority of the tasks that they are used to performing in FrameMaker.

While FMXA and FrameMaker are provided as solutions for XML authoring, FrameMaker also supports the FM and MIF formats.
## Feature List

<table>
<thead>
<tr>
<th>Feature</th>
<th>FMXA</th>
<th>FrameMaker</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Authoring</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Open, edit, save FM and MIF files</td>
<td>NO</td>
<td>YES</td>
</tr>
<tr>
<td>Create, edit, save XML files</td>
<td>YES</td>
<td>YES</td>
</tr>
<tr>
<td>Enter and modify attributes</td>
<td>YES</td>
<td>YES</td>
</tr>
<tr>
<td>Validate XML content</td>
<td>YES</td>
<td>YES</td>
</tr>
<tr>
<td>WYSIWYG, Author, and XML Code Views</td>
<td>YES</td>
<td>YES</td>
</tr>
<tr>
<td>XPath and XSLT support</td>
<td>YES</td>
<td>YES</td>
</tr>
<tr>
<td>MathML support</td>
<td>YES</td>
<td>YES</td>
</tr>
<tr>
<td>FrameMaker book files with XML components</td>
<td>YES</td>
<td>YES</td>
</tr>
<tr>
<td>Read structured applications</td>
<td>YES</td>
<td>YES</td>
</tr>
<tr>
<td>Filter content based on attributes and conditional tags</td>
<td>YES</td>
<td>YES</td>
</tr>
<tr>
<td><strong>DITA support</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>DITA 1.2, and 1.1 support</td>
<td>YES</td>
<td>YES</td>
</tr>
<tr>
<td>Filter contents based on DITAVal</td>
<td>YES</td>
<td>YES</td>
</tr>
<tr>
<td>Create and assemble DITA map</td>
<td>YES</td>
<td>YES</td>
</tr>
<tr>
<td>Create composite document from DITA map</td>
<td>NO</td>
<td>YES</td>
</tr>
<tr>
<td>S1000D support</td>
<td>YES</td>
<td>YES</td>
</tr>
<tr>
<td>DocBook support</td>
<td>NO</td>
<td>YES</td>
</tr>
<tr>
<td>xDocBook support</td>
<td>YES</td>
<td>YES</td>
</tr>
<tr>
<td><strong>Design and format</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Design FrameMaker templates</td>
<td>NO</td>
<td>YES</td>
</tr>
<tr>
<td>Prepublish setup: page numbering, book update, adding TOC, index etc.</td>
<td>NO</td>
<td>YES</td>
</tr>
<tr>
<td>Create templates and conditional tags</td>
<td>NO</td>
<td>YES</td>
</tr>
<tr>
<td>Create or edit Master Page</td>
<td>NO</td>
<td>YES</td>
</tr>
<tr>
<td>Create structured applications and edit structapps.fm</td>
<td>NO</td>
<td>YES</td>
</tr>
<tr>
<td>Create TOC, indexes, and list of references</td>
<td>NO</td>
<td>YES</td>
</tr>
<tr>
<td>Designers and catalogs: paragraph, character, table, object</td>
<td>NO</td>
<td>YES</td>
</tr>
<tr>
<td><strong>Publishing</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Format menu: fonts, characters, paragraphs, page layouts</td>
<td>NO</td>
<td>YES</td>
</tr>
<tr>
<td>Publish to PDF</td>
<td>YES</td>
<td>YES</td>
</tr>
<tr>
<td>Mutlichannel publishing (HTML5, EPUB 3, MOBI, KF8, etc.)</td>
<td>NO</td>
<td>YES</td>
</tr>
<tr>
<td><strong>Review and collaboration</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Integration with Microsoft Sharepoint</td>
<td>YES</td>
<td>YES</td>
</tr>
</tbody>
</table>

Last updated 8/18/2015
## About FrameMaker XML Author

<table>
<thead>
<tr>
<th>Feature</th>
<th>FMXA</th>
<th>FrameMaker</th>
</tr>
</thead>
<tbody>
<tr>
<td>Integration with EMC Documentum</td>
<td>YES</td>
<td>YES</td>
</tr>
<tr>
<td>Integration with Adobe Experience Manager</td>
<td>YES</td>
<td>YES</td>
</tr>
<tr>
<td>Integration with Dropbox</td>
<td>YES</td>
<td>YES</td>
</tr>
<tr>
<td>Integration APIs for other CMS</td>
<td>YES</td>
<td>YES</td>
</tr>
<tr>
<td>PDF based reviews</td>
<td>YES</td>
<td>YES</td>
</tr>
<tr>
<td><strong>Miscellaneous</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Attribute config file maker</td>
<td>NO</td>
<td>YES</td>
</tr>
<tr>
<td>Conversion tables</td>
<td>NO</td>
<td>YES</td>
</tr>
</tbody>
</table>

Last updated 8/18/2015
Chapter 3: FrameMaker XML Author Basics

User interface

Basics

The Welcome screen
A Welcome screen is displayed each time you open FMXA:

Adobe FrameMaker XML Author 12

Recent Items
- Open...
- Intro.xml
- ProdDoc.ditamap

Session Restore
- Restore Last Session

Create New
- Book
- DITA Map
- XML
- CMS Connection

Resources
- Getting Started
- Training
- User Guides
- XML and DITA Tutorials

Adobe
- Support
- Product Updates
- Forums

Getting Started Guide
Use the products optimally, be more productive and exceed your own expectations. Get a comprehensive User’s Guide that walks you through all the new features, tips and tricks, short-cuts and time-saving techniques, and reinforces learning through demo videos and illustrations.

Download now: adobe.ly/1a3AHBS

From the Welcome screen, you can perform the following tasks:

- Open recent documents
Workspace overview

A particular arrangement of elements, such as pods that you use frequently while working on documents, is called a workspace. You can dock, stack, minimize, or make these elements free-floating in your workspace. You can select from several preset workspaces or create one of your own. Once you have arranged the panels and pods, you can save the workspace settings for use later.

The FrameMaker XML Author interface has the following components.

- The Application bar across the top contains a workspace switcher, menus, and other application controls.
- The document window displays the file you’re working on. Document windows can be tabbed and, in certain cases, grouped and docked.
- Pods help you monitor and modify your work. Examples include marker, variables, cross-references pods. You can minimize, group, stack, or dock pods.
- The status bar shows text formatting and pagination information for the current document.

Icons

FrameMaker XML Author gives you choice of size and color for the icons. Using preferences, you can set up to use any of the following icons for FrameMaker XML Author interface:

- Large colored icons
- Large grayscale icons
- Regular colored icons
- Regular grayscale icons

**Note:** Large icons’s size is 26x26 pixels and regular icons’ size is 18x18 pixels.

Icons according to various Interface settings in the Preferences dialog
**Change FrameMaker XML Author icons**

You can change FrameMaker XML Author icons between colored\greyscale and large\small.

1. Select Edit > Preferences.
2. In the Preferences dialog, select Interface and choose the preferences for icons.
3. Restart FrameMaker XML Author for the icon preferences to take effect.

**Use your own icons**

You can also add your own custom icons in FrameMaker XML Author.

1. Locate the toolbar.xml file relevant to your view and mode and open it.
2. Create and place all the icon files in AppData\Roaming\Adobe\FrameMakerXMLAuthor\12\.
3. Locate the Action element relevant to the icon you want to customize. The Action element code looks like the following:

   ```xml
   <ACTION command="CenterPara">
     <images base="P_TextAlignCenter_Md"/>
   </ACTION>
   ``

4. Add the base name of the icon in the base attribute of images element.
5. Create at least 2 icon images for normal and rollover state of the icon.

   For example if the icon name is xyz the image names will be xyz_C_S.png and xyz_R_C_S.png. (Here, C= color, S=regular, and R=rollover.) If, however, your icon preferences are set to have large or greyscale icons instead of regular and color, you will use M and L in the icon names.

   You can have 8 image files for the following possible combinations of preferences with the base name as xyz:

<table>
<thead>
<tr>
<th>Preferences</th>
<th>Icon names</th>
</tr>
</thead>
<tbody>
<tr>
<td>Size</td>
<td>Color</td>
</tr>
<tr>
<td>Large (L)</td>
<td>Colored (C)</td>
</tr>
<tr>
<td></td>
<td>Grayscale (M)</td>
</tr>
<tr>
<td>Regular (S)</td>
<td>Colored (C)</td>
</tr>
<tr>
<td></td>
<td>Grayscale (M)</td>
</tr>
</tbody>
</table>

Last updated 8/18/2015
6 You can further add more icon files for icon states, such as dark_normal and dark_rollover by specifying attributes with data in the relevant element. For example:

```xml
<ACTION command="CenterPara">
    <images base="P_TextAlignCenter_Md"
            dark_normal="<icon_name>.png" <!-- for regular sized icons-->
            dark_rollover="<icon_name>.png"
            dark_normal_l="<icon_name>.png"<!-- "_l" suffix for large sized icons-->
            dark_rollover_l="<icon_name>.png"
    />
</ACTION>
```

Preferences dialog
The preferences dialog (Edit > Preferences) has the following settings:

General preferences
Use these preferences to specify settings, such as:
- Product interface
- File saving, naming, and backup
- Handling of embedded objects
General preferences
A. FrameMaker XML Author interface  B. Specify the diagonal size of your monitor  C. Select to create a backup file when you save a file for the first-time  D. Specify the number of minutes after which FrameMaker XML Author automatically saves the open file  E. Select to display errors, if any, when you open a file in FrameMaker XML Author  F. Text size smaller than the one specified in this field is displayed as XXXX  G. Select to automatically lock and check-out a file when you download it  H. Select to check in a file every time you save it  I. Select to display learning resource links on the bottom of the starter page  J. Select the type of cross-platform file naming for FrameMaker XML Author to follow  K. Select to add a FrameImage facet to bitmap graphics imported by copying  L. Select to prevent multiple people from opening the same file  M. Select to remember missing font names  N. Select the file types to be embedded in the PDF

Interface preferences
Use this dialog box to specify whether FrameMaker XML Author should auto-collapse panels to icons or always open documents as tabs.
Default interface properties
A. Select tool tip appearance type: Normal, Fast, or Hidden
B. Switch between dark or light levels of UI brightness
C. When disabled, you must click on the panel tab/panel icon to collapse it. When enabled, just click on another panel or in the document to collapse a panel.
D. Select to hide all docked panels permanently
E. Select to make FrameMaker XML Author application icon grayscale
F. When you close panels they are hidden but are still active in memory. Deselect this option to remove panels when you close them. To display them again, choose them from FrameMaker XML Author menus.
G. Select grayscale or colored icons for the interface
H. Select large or small sized icons for the interface
I. Opens composite documents as tabbed documents. Deselect to open composite document windows as floating windows.
J. When you drag document windows and place them together, they tend to form tabs in a single document window. Select this option to prevent document tabbing.
K. Floating document windows display the document name only in the title bar. Deselect to display document name in title bar and tab bar.
L. Select to open all documents as tabbed documents. Deselect to open document windows as floating windows.

Alerts
These settings control the display of warnings.
Alerts
A. Select to show warnings on actions that clear the history  
B. Specify if you want the warning to appear once for a history clearing command or every time you run that command  
C. Select when you want FrameMaker XML Author to display dialogs with alerts  
D. Select to display non-input alerts, such as missing fonts, on session restore

See also
“Restore last session” on page 49

Pods
The pod location criteria determine what should be displayed in the pod list area for an instance by way of identifying its location in the document.
**Pots**
A. Specify the element names. In FMXA, you can only specify elements styles.  
B. Specify the first element style  
C. Specify the second element style

**Launch**
The Launch preferences help you optimize the startup time of FrameMaker XML Author. Using the Launch preferences, you can optimize the loading of the clients, fonts, language providers, and startup scripts according to your requirement.
Launch preferences

A. Load Adobe Fonts On Startup: Deselect this if you do not require Adobe fonts in a session. B. Delay Load Clients: When you select this option, none of the clients such as MathFlow and PDF import comments are loaded on startup. C. Delay Load Language Provider: When you select this option, only the English language is loaded on startup. D. Don’t Load Startup Scripts: Specify the startup script names in this field that you do not want FrameMaker XML Author to load on startup. Use commas to delimit.

Dropbox

The Dropbox preferences help you set up the Dropbox app to work with FrameMaker XML Author.

The Dropbox preferences

A. Dropbox Folder path: Once you have installed Dropbox, the default path is automatically there as an option in the drop-down. B. Delete files from Dropbox after copying locally: When selected, when you select (File > Dropbox > ) Save Locally or Save Locally With Dependencies, the files are deleted from the Dropbox folder on your machine. C. Create folder structure for dependencies while uploading or downloading: FrameMaker XML Author creates a folder structure in the Dropbox folder for dependencies similar to the one being uploaded, but not when . When this option is selected, FrameMaker XML Author creates a folder structure similar to the
**Documentum®**

Use these preferences to set up Documentum® file versioning, specify DFS SDK path, and add custom CMS properties to FrameMaker XML Author for Documentum®.

- **A.** Specify how existing objects are overwritten and saved
- **B.** Enter the name of a custom attribute to add
- **C.** Select to show hidden objects
- **D.** Select to show private cabinets
- **E.** Specify the path to DFS SDK

**Sharepoint**

Use these preferences to set up Sharepoint file versioning and add custom CMS properties to FrameMaker XML Author for Sharepoint.
Sharepoint preferences
A. Specify how existing objects are overwritten and saved  B. Enter the name and type of a custom attribute to add

Dictionary
Use these preferences to specify Proximity or Hunspell dictionaries for Spelling, Hyphenation, and Thesaurus for various languages.

Spelling options
Use these preferences to set up Spelling Checker.
XML

Use these preferences to set up syntax colors and other display options for XML content in FrameMaker XML Author.

- A. Select the color preferences for various parts of XML syntax
- B. Select the font family for displaying the xml tags and content
- C. Select to display line numbers in the document
- D. Select to word wrap

MathML

Use these preferences to set up the MathFlow Editor install path and specify the licence file path. You can also select the Style or Structure editor from this dialog.
MathML preferences
A. Specify the MathFlow editor installation path. B. Specify the license file. C. Specify the font size of the equations. D. Specify the DPI of the image of the equation. E & F. Select from the Style or Structure editors.

Tabbed documents
When you open more than one file, the document windows are tabbed. You can open documents as floating windows by clearing the Open Documents As Tabs option in the Interface Preferences dialog box.

Publishing Presentations

Documents appear as tabs in the document view.

However, when you add a generated file, such as a Table Of Content, the generated file appears minimized in the lower left corner of your workspace. There are multiple ways in which you can organize floating and tabbed document windows.

• To dock a document window in a group of document windows, drag the window into the group.
• To rearrange the order of tabbed document windows, drag a window’s tab to a new location in the group.
• To undock a document window from a group of windows, drag the window’s tab out of the group.

Note: When you minimize a floating document window, it covers a part of the FrameMaker XML Author status bar. You cannot move the minimized window to a new location.
Tips on working with the new interface

Adjust the UI brightness  Adjust the UI brightness by using the UI Brightness slider under > Interface.

Combine document windows  To consolidate all document windows, floating, minimized, or docked, right-click the tab bar of the docked document window and select Consolidate All To Here from the menu.

Float document windows  Click Arrange Documents icon on the top Application bar and select Float All In Windows. This arranges all the document windows as cascaded floating panels.

Tile documents  Use the Arrange Documents icon to tile document windows vertically or horizontally. This is specially useful for manually comparing documents and layering them side by side.

Bring hidden pods to the front  Sometimes while working with floating document windows or when switching workspaces, the pods may seem difficult to bring to the front.
  • Undock the pods by dragging them out using the pod title bar.
  • Dock all floating document windows. Right-click the docked tab bar and select Consolidate All To Here or drag and dock the floating document windows.

Minimize pods to icons  Right-click on the pods tab bar and select Collapse To Icons from the menu. This option is available only if the pods are floating and not docked. To collapse docked pods, click anywhere in the tab bar.

Reopen the pods  Choose View > Pods and click any pod name. The entire group of pods open at the bottom of the workspace.

Reopen a panel  Choose Windows and select Panels and select the panel you want to reopen.

Collapse all open panel groups to icons  Right-click the tab bar of the panel group and select Collapse To Icons.

Exit the full screen mode  Right-click outside the text frame in the document window and select Toggle Screen Mode.

More Help topics
“Keys for screen modes” on page 375

Using Smart catalogs
You can use the Smart catalog as a convenient shortcut to the catalogs available in FrameMaker XML Author. For example, to add a list in a document, use the Smart catalog to quickly search for and select the type of list (dl, li, ol).

To use the Smart catalog
1  Place the cursor at the required location in the document.
   For elements and attributes, place the pointer at the element insertion location in the structure view.
2  Press the Smart catalog shortcut key. See, the “Smart catalog shortcut keys” on page 27 defined below.
   The Smart catalog dialog displays. The focus of the pointer is now within the text box at the top of the dialog.
3  To search for an item in the current catalog, start typing either the name of the item or the description. As you type, the list in the dialog is narrowed down.
   For example, if you want to insert a list element in a structured document, you can type the name of the list element: ul, ol, or dl. You can, however, also type the description of the element, list, and the dialog list is narrowed down to all the available list items in element catalog.
   Note: The list of displayed items in the dialog is limited to 10. If the list exceeds 10, you can use the scrollbar to navigate up and down the list.
Smart catalog shortcut keys

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Smart Catalog</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl + 1</td>
<td>Element catalog</td>
</tr>
<tr>
<td>Ctrl + 2</td>
<td>Wrap element</td>
</tr>
<tr>
<td>Ctrl + 3</td>
<td>Change element</td>
</tr>
<tr>
<td>Ctrl + 4</td>
<td>Apply condition</td>
</tr>
<tr>
<td>Ctrl + 5</td>
<td>Remove condition</td>
</tr>
<tr>
<td>Ctrl + 7</td>
<td>Attributes catalog</td>
</tr>
</tbody>
</table>

To use the Hierarchical Element insert

Make the following configuration changes:

1. Open the maker.ini file location at:
   `$appdata\Adobe\FrameMakerXMLAuthor\12`
2. Set the following flag to ON:
   `EnableOldSmartInsert`

Customize and manage workspaces

Workspaces in FMXA allow you to set up a custom view of the application with the toolbars, pods, and catalogs displayed and positioned as you want them. For example, you can choose to place the Structure View pod on the right side of the application window and the Elements catalog on the left side. You can choose to only hide all toolbars.

FMXA ships with the Authoring workspace. This is the default workspace for FMXA. However, you can create and manage custom workspaces for your specific requirements.

Save a custom workspace

1. Configure the workspace the way you want it and choose Save Workspace from the workspace switcher on the Application bar.
2. Type a name for the workspace and click OK.

FrameMaker XML Author remembers the last used workspace across sessions. If you were working in the Review workspace and you close and relaunch FrameMaker XML Author, it loads the custom workspace.

Switch workspaces

- Select a workspace from the workspace switcher in the Application bar.
Use the workspace switcher to switch between workspaces designed for your workflow.

**Reset a workspace**

By saving the current configuration of panels as a named workspace, you can restore that workspace even if you move or close a panel. The names of saved workspaces appear in the workspace switcher in the Application bar.

❖ Select the Reset Workspace option from the workspace switcher in the Application bar.

**Rename a custom workspace**

1 Select Manage Workspace from the workspace switcher in the Application bar.

2 Select the workspace and click Rename.

3 Type a new name and click OK twice.

**Delete a custom workspace**

❖ Select Manage Workspace from the workspace switcher in the Application bar, select the workspace, and then click Delete.

**Interface view options**

**Display pages more quickly**

❖ Do the following:

- Open the document by bypassing the update of imported graphics, cross-references, and text insets. (Opening a document without updating references makes a document open faster but can slow down the display of individual pages.)

- Turn off the display of graphics by choosing View > Options, deselecting the Graphics option, and clicking Set.  
  **Important:** If you deselect the Graphics option and generate a PDF, the graphics do not appear in the PDF.

- Display small text as gray bars by choosing File > Preferences > General, entering a point size in the Greek Screen Text Smaller box, and clicking Set. Whenever text in your document is in a point size smaller than the size you specified, it appears on the screen as a gray bar.
Change the preset display units
Some text boxes in dialog boxes require a unit of measurement (such as points or inches) for the value you enter. You can specify the default units for font size and line spacing (font size units) and for other measurements (display units). The default units of measurement appear after the values in the text boxes. If you enter a value without a unit of measurement, FrameMaker XML Author uses the default unit.

- To change the preset units, make the appropriate window is active. Select View > Options. Select the values for Display Units and Font Units, and then click Set.
- To enter different units in a box, make the appropriate window active. Enter an abbreviation for the unit along with the numeric value. Use cm for centimeters, mm for millimeters, " or in for inches, pc, pi, or pica for picas, pt or point for points, dd for didots, cc or cicero for ciceros, Q for Q units (refers to font size and line spacing for the Japanese language only).

FrameMaker XML Author converts the entry to the preset display units when you click a command button in the dialog box. For example, if your document display units are picas and you want to set a paragraph indent of 1 inch, enter 1" in the First Indent box. When you click Apply, the measurement changes to the number of picas that corresponds to 1 inch.

Change the spacing of ruler or grid intervals
1 Make the appropriate document window or book window active. If a book window is active, select the documents you want to affect.
2 Select View > Options. Select a new setting from the Rulers menu or the Grid menu, and click Set.

Show or hide visual guides
You can show several of these visual guides in a document window:

- Borders around text frames, graphic frames, and imported objects
- Markers, paragraph returns, and other symbols in running text
- Rulers along the top and left side of the window

You can also show a grid of horizontal and vertical lines for drawing, resizing, and aligning graphics. All visual guides are nonprinting, so you do not need to hide them when you print.

1 Make the appropriate document window or book window active. If a book window is active, select the documents you want to affect.
2 Do the following:
   - To show or hide borders, select View > Borders.
   - To show or hide the text symbols, select View > Text Symbols.
   - To show or hide the rulers, select View > Rulers.
   - To show or hide grid lines, select View > Grid Lines.
   - To show the element boundaries, select View > Element Boundaries or Element Boundaries (As Tags) in Structured FrameMaker XML Author. FrameMaker XML Author automatically toggles these two options.
Text symbols

<table>
<thead>
<tr>
<th>Text symbol</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>¶</td>
<td>End of paragraph</td>
</tr>
<tr>
<td></td>
<td>End of flow and end of table cell</td>
</tr>
<tr>
<td>}</td>
<td>Tab</td>
</tr>
<tr>
<td>✳</td>
<td>Anchored frame and table anchor</td>
</tr>
<tr>
<td>☑</td>
<td>Marker</td>
</tr>
<tr>
<td>{</td>
<td>Forced return</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>✴</td>
<td>Nonbreaking space</td>
</tr>
<tr>
<td>☐</td>
<td>Discretionary hyphen</td>
</tr>
<tr>
<td>✞</td>
<td>Suppress hyphenation</td>
</tr>
</tbody>
</table>

Display a subset of menu commands

You can display a subset of menu commands called quick menus. The quick menus do not have commands for formatting text, editing some aspects of graphics, and inserting some objects such as markers and variables.

If you do not see the full set of menu commands, the quick menus is probably displayed.

*Note:* If you’re using a structured document, your application developer can change the commands available in the complete menus.

- To display quick menus, select View > Menus > Quick.
- To restore the complete menu, select View > Menus > Complete.
- To customize menus, add, move, or remove menus and commands as described in the online manual Customizing *FrameMaker* on the Adobe website [www.adobe.com/go/lr_FrameMaker_support_en](http://www.adobe.com/go/lr_FrameMaker_support_en).

Display a high-contrast workspace

*FrameMaker* XML Author uses system colors to draw window backgrounds, text, and other graphics. Users who have trouble discerning colors or variations in contrast, or who have low visual acuity, can set high-contrast color schemes and custom text and background colors. This setting makes the information in the user interface easier to view.

1. Open the Windows Control Panel, double-click Accessibility Options, and select the Display tab.
2. Change contrast globally or change the color theme, as follows:
   - To change the appearance of all operating system windows at once, select the Use High Contrast option.
   - To change the color theme, click Settings and select one of the High Contrast Appearance Scheme options.

*Note:* *FrameMaker* XML Author does not adjust colors of all items. Some of these include the background color, and the fill color of graphic objects.
Use status bar controls
The FrameMaker XML Author status bar provides all the navigational controls, pagination information, and zoom controls.

Navigational controls on the status bar
A. First page  B. Previous  C. Go to page number  D. Next  E. Last page  F. Go to line number  G. Go to insertion point  H. Zoom controls

Zoom in and out
- To magnify or decrease magnification, text, and objects, click the + (Increase Zoom) or - (Decrease Zoom) buttons on the status bar. FrameMaker XML Author zooms in or out on the area of the page containing the insertion point or selection. If the document doesn’t contain an insertion point or a selection, FrameMaker XML Author zooms in on the center of the page.
- To display text and objects at a particular magnification, select a percentage from the Zoom pop-up menu.
- To display the entire page in the current window, select Fit Page In Window from the Zoom pop-up menu.
- To fit the page or text frame to the window, select Fit Window To Page or Fit Window To Text Frame from the Zoom pop-up menu. If the view options are set to display facing pages, the window is resized to accommodate two pages side by side.
- To change the available zoom settings, click Set from the Zoom pop-up menu, select the percentage you want to change and enter the new percentage. Enter any percentage from 25% to 1600%. Click Set. To return to the default percentages, click Get Defaults.
- To make 100% zoom match the page size, select File > Preferences > General. For Monitor Size, specify the diagonal size of your monitor, and then click OK. If screen-to-paper fidelity is not critical, leave Monitor Size set to Default, which ensures cross-application compatibility.

Note: You can customize the default zoom settings. For information, see the online manual Customizing FrameMaker on the Adobe website www.adobe.com/go/lr_FrameMaker_support_en.

Turn pages and set scrolling
You can page through a document window using controls in the status bar.

You can also define how FrameMaker XML Author displays pages when you scroll up and down, left and right, or two pages at a time.

If the document you are paging through is part of an open book, FrameMaker XML Author sometimes displays an alert message prompting you to choose to open the next or previous document in the book. For example, if you click Previous Page on the first page of a document, clicking Yes in the alert message box opens the previous document in the book. The last page of that document appears.

1 Make the appropriate document window or book window active. If a book window is active, select the documents you want to affect.
2 Choose View > Options.
3 Choose one of the following options from the Page Scrolling pop-up menu:
   - To display pages from top to bottom (for example, page 2 below page 1), choose Vertical.
   - To display pages from left to right (for example, page 2 to the right of page 1), choose Horizontal.
   - To display pages two at a time, side by side, choose Facing Pages.
• To display as many pages as will fit in the window from left to right, choose Variable.

4 Click Set.

Go to another page
❖ Do one of the following:
• To go to the next page, click the Next Page button.
• To go to the previous page, click the Previous Page button.
• To go to the first page in the document, click the First Page button.
• To go to the last page in the document, click the Last Page button.
• To go to a specific page, click in the Page Number area and specify the page number you want to display.
• To go to a specific line number, click in the Line Number area and specify the line number you want to display.
• To go to the page containing the insertion point, click the Insertion Point button.
• To move quickly through the pages, scroll vertically.

In case of structured documents, click or select in the Structure View to display the corresponding page in the document window. This is often the quickest way to go to the page you want.

Using toolbar shortcuts
You can access all commonly used commands from the following toolbars. You can display a toolbar from the View > Toolbars menu.

Graphics Toolbar Provides shortcuts for graphic creation and edits.
Quick Access Bar Provides commands for opening and saving documents, editing text, graphics, and tables.
Object Alignment Provides commands to change sequence, alignment, and orientation of objects.
Object Properties Provides commands to group objects, change layer order, reshape, scale, and snap objects.
Track Text Edits Provides commands for tracking, accepting, and rejecting text edits.
Quick Element Provides commands inserting and wrapping common structured document elements.

You also have keyboard shortcuts for all commands accessible through the toolbars and menus. For a list of all the keyboard shortcuts see “Keyboard Shortcuts” on page 373.

More Help topics
“Keyboard Shortcuts” on page 373

Using pods

About pods
These frequently used dialog boxes have an interface designed to simplify your work:

• Conditional Tags pod
• Cross-references pod
• Marker pod
• Insets pod
• Variables pod
• Reference pods
• Hotspots pod
• Currently Opened Files pod

Explaining the pod interface
A. Select document  B. Pod-specific toolbar buttons  C. Search pod entries - as you type, FrameMaker XML Author searches through all the columns for matches and keeps displaying them  D. Arrow on column headers indicates sort order  E. Pod list area.  F. Details of each instance include location. You can customize the location using Pods Location Criteria dialog box.

Close pods and tab groups
Pods have a button on the right side of the title bar you can click to close a pod or a tab group (group of pods).

Close pods and tab groups
• Close: Closes just the pod in focus (Marker).
• Close Tab Group: Closes all the pods in the tab group.

Also, by double-clicking in the title of a pod, you can minimize or maximize that pod as well as the whole tab group it is a part of.
About the pod list area
The Select pop-up displays a list of all open documents and DITA maps. If you select All Open Docs, the pod list area displays all the variables from all the open documents. If you select a specific open document, the pod list area displays variables from the selected document even when you switch to other open documents. The pod list area continues to display the list of instances from the selected document.

If you select the Current option, the pod list area displays the list of instances from the selected document. The list area refreshes when you switch between open documents. However, when you switch between pods, you may need to click the Refresh button.

If you select an open document
• Single-click an instance in the pod to display the corresponding instance in the document. For example, if you select an image instance from the Insets pod, the corresponding image is also selected in the document view.
• Double-click an instance to do the following for each pod:
  Conditional Tags pod Displays the Add/Edit Condition Tag panel for the selected condition.
  Cross-references pod Displays the Cross-Reference panel for editing the selected cross-reference.
  Markers pod Displays the Marker panel so that you can edit the selected marker definition.
  Fonts pod Displays the Replace Font panel for selecting a replacement font.
  Insets pod Displays the Object Properties panel for the selected inset.
  Variables pod Adds the selected variable at the insertion point in the current document.
  Reference pod Displays the results of the search for locations where a particular element is referenced. This pod is only relevant for DITA documents.
• Click a column name to sort the data in the list area in ascending or descending order.

Setting pod location criteria
The pod location criteria determine what should be displayed in the pod list area for an instance by way of identifying its location in the document.

Pod location criteria
A. In structured interface, you can specify either the paragraph styles or the element names. B. Specify the first paragraph style. C. Specify the second paragraph style.

1 Choose .
2 Select Panels and Pods.
3 Select Element Name if you want the pod to display the element names in which the instance is located.
4 Specify valid element names and click OK.

The Markers pod displays the setting for marker location:
A. Marker is selected in the document view
B. Paragraph styles that you specify in Pod Location Criteria
C. Markers pod displays the first head3 title and head2 title in which the marker occurs.

**Document window overview**

The first time that you launch FrameMaker XML Author, it prompts you to select the product interface. Subsequently, it opens with the last used interface.
Document window

A document window appears when you open an XML document. The window shows the document text formatted, with graphics and other items in place, and everything laid out in a page design. If more than one document is open, a document window appears for each one.

Structure View window

The Structure View window displays the underlying XML structure. The view uses bubbles to represent elements and their relationship to one another. It also identifies errors in the document structure. In Structure View, you can insert, select, expand, collapse, move, merge, or split elements. When you work with structured documents, you’ll use the document window and the Structure View together. These windows help you organize elements in a valid structure.

Both windows are editable, and anything you do in one is mirrored in the other. You can have the two views open side by side, to keep track of both contents and structure. If you click or select in one view, an insertion point or selection appears at the equivalent place in the other view. Any editing you do in one is reflected in the other. It’s easier to make your changes in Structure View, where you can drag-and-drop bubbles to rearrange elements or select bubbles to edit them in other ways.

❖ To display, choose Structure Tools > Structure View.
Elements catalog
The Elements catalog lists the elements you can use at the current location and provides commands for adding and editing elements. It also displays other information about the current location, such as whether you can type text there. The information in the Elements catalog comes from content rules in the definition for the current element.

The catalog is preset to show only the elements that are valid at the current location, though you can have it display more elements if you want greater flexibility. The catalog is empty if the document has no element definitions or if no more elements are required at the current location.

❖ To display, click the Element Catalog button at the upper-right corner in the document window.

The Element Catalog uses the following symbols to identify whether an element is valid:

Heavy check mark The element is valid at the current location. If you insert the element, the current (parent) element will be correct and complete up to this location.

Plus sign (+) The element is an inclusion (SGML only) in the current element and is valid at the current location. The plus sign always appears next to a heavy check mark. Inclusions are valid only in SGML documents, so this sign does not appear in XML documents.

Question mark (?) The element is a possible replacement for the element right after the insertion point or for the selected elements. It is valid at the current location, but will make child elements after it invalid. If you insert an element with a question mark, the current (parent) element will be complete and correct up to this location, but you’ll have to correct errors after the new element.

Light check mark The element is valid later in the current element. If you insert one of these elements, the current (parent) element will be correct but incomplete up to this location. You’ll have to go back and fill in missing child elements.

No symbol If an element in the catalog has no symbol, it is not valid at the current location or later in the current element. It may be valid earlier in the current element or outside the element.

The Element Catalog may also include the following indicators to provide other information about the current location:

TEXT You can type text at this point.

UNDEFINED The current element does not have a definition in the document. The element was probably pasted from a document with different element definitions. (This does not appear when the catalog is set to display all elements.)

INVALID The contents of the current element are invalid. (This does not appear when the catalog is set to display all elements.)

You can use buttons in the Element Catalog to insert an empty element, wrap an element around contents, and change the type of an existing element.

XML view, Author view, and WYSIWYG view
FrameMaker XML Author has three views that help you author your content:

• XML view allows you to work with the plain XML code of your structured FrameMaker XML Author XML files.
• Author view simplifies structured authoring by keeping out features not relevant for XML authors, such as page numbers.
**XML view**

The XML view allows you to work with the plain XML code of your structured XML files. In the XML view, you can expand/collapse elements.

FrameMaker XML Author indents the child elements by one tab space compared to their parent elements. Word wrap keeps the content of the elements visible in the width of the window. The XML view supports Unicode. You can edit multilingual content in the XML view. You can also copy/paste content from clipboard.

When you edit/change references such as conrefs, links, and cross references in XML Code View, FrameMaker XML Author updates them in the WSIWYG View also. XML view automatically validates the XML content with the DTD and helps you ensure that the content is well formed at all times. While you are working in the XML view, FrameMaker XML Author automatically inserts attribute values and close tags for the tags you insert in the file.

A Find/Change dialog in the XML view helps you search through the XML code. You can also use regular expressions such as with ampersand and pipeline to search through text. XML code view also has support for XPath. You can build and use XPath expressions to locate XML content. For more information on XPath, see XPath.

The following features can be accessed using the Code view only:

- “XPath” on page 304

**Errors console**

The Errors console in the XML view describes the errors, if any, in the open XML files. The error console also displays the filename of the error. To go to the file and location of the error, click an error row.
Display error pod

- To display the Error Pod, select View > Pod > Errors.

Tree view

XML View provides a tree-like outline that allows you to navigate and view the structure of your XML document. The Up and Down arrow keys let you move up and down in the tree view. Left and Right arrow keys respectively allow you to collapse and expand the elements.

Display tree view

- To display the tree view, select View > Outline.

Author view

The Author view provides a WYSIWYM (What You See Is What You Mean) view of your XML documents.

The Author view includes the visual tools for structured authoring, such as the element tags, Structure View, Element Catalog, Attributes editor.

Using XML Author View, you can concentrate on the structure and content of the document rather than the appearance.

WYSIWYG view

WYSIWYG is the classic FrameMaker XML Author view, which supports structured authoring. The WYSIWYG view has all the features of FrameMaker XML Author.
Switch between the views

You can switch between the three views by clicking the relevant icon in the Application bar.

Icons of the three views in the Application bar
A. XML view  B. Author view  C. WYSIWYG view

Working with the Structure View

Expand or collapse structure

In the Structure View, you can expand or collapse elements, showing or hiding a detailed outline of your document. (When elements are expanded or collapsed in Structure View, text in the document window does not change.)

An element is sometimes defined to have attributes, which provide supplemental information about the element. You can also expand and collapse the attributes associated with an element.

Collapse elements to get a higher-level look at the document structure. Collapsed elements are also easier to move around. It’s especially helpful to collapse long lists of items and procedures with many steps.

- To expand or collapse elements, click the plus (+) or minus (-) symbol on the left side of element bubbles.
• To expand or collapse attributes, click the plus (+) or minus (-) symbol on the right side of element bubbles.
• To expand or collapse all child elements or attributes, hold down Shift while you click a plus or minus sign.

View element boundaries in the document window
Element boundaries shown in the document window mark the beginning and end of each element. Working with visible boundaries helps you see how the document content is divided into elements. Viewing the boundaries also makes it easier to place an insertion point properly or to make the right selection.

For most elements, the boundaries appear as opening and closing brackets ([ ] ) or as two boxes with an element tag. For some elements (graphics, footnotes, markers, tables, and equations), the element location is marked only by one box with a tag.

When elements are inside other elements, their brackets or tags nest to show the hierarchy.
• To surround each element with brackets, choose View > Element Boundaries.
• To surround each element with a text label, choose View > Element Boundaries (As Tags).
• If the book window is active, select View > Show Element Boundaries or View > Hide Element Boundaries.
• To hide element boundaries, choose View > Hide Element Boundaries or Element Boundaries (As Tags)

Note: The brackets and tags that mark element boundaries are characters that both print and occupy document space. Hide them before printing to suppress them in print output. Also hide them to see the document layout unaltered by element boundaries.

Expand and collapse elements in document window
If you are viewing element boundaries as tags in the document window, you can perform the following operations:
• Collapse all elements, even in the document view.
• Collapse a parent element to hide the child elements, without collapsing them.
• Collapse child elements, when collapsing the parent element.
• Collapse all elements to the same level, when collapsing an element.
• Select the element, by clicking the element tag.
• Toggle the collapsed state of an element, by double-clicking the element tag.
• View expanded element structure, when any operation (for example, Find/Change) results in a selection, within a collapsed element structure.
• Have the document view and structure view synchronized with respect to the collapsed state of the elements.

Show and hide attributes for new elements
You can show or hide attributes for new elements in Structure View. The view can display all the attributes in the flow, none of the attributes, or only required attributes or attributes that have a value. This setting applies to new elements as you enter them.

1 Make the appropriate document window or book window active. If a book window is active, select the documents you want to affect.
2 Select View > Attribute Display Options, choose the display option you want, and click Set.
Change the scope of elements available in a structured document

When adding elements to a structured document, insert only elements that are valid at the current location. (Valid elements have heavy check marks, heavy check marks and a plus sign, and question marks in the Element Catalog.) If you add elements this way, you can work from the beginning of a document to the end and be sure that its structure is valid at every point along the way.

Sometimes you want to work more loosely, and in these cases you can make more elements available. For example, some draft documents must adhere strictly to a predefined structure but follow the structure only as a guideline. Or, you can plan your document to conform to a structure without having all the information to complete it from start to finish.

When more elements are available, the additional elements appear in the Element Catalog and are available if you insert elements from the keyboard. You can also list inclusions after other valid elements in the catalog.

1 Make the appropriate document window or book window active. If a book window is active, select the documents you want to affect.

2 Select Element > Set Available Elements. You can also click Options in the Element Catalog.

3 Select one of the following options in the Show Tags For area:
   • To show only elements that are valid for the current location, select Valid Elements For Working Start To Finish. Use this option if you plan to go through a document from start to finish and fill in the elements in their correct order and hierarchy.
   • To show elements that are valid for the current location or later in the current element, select Valid Elements For Working In Any Order. Use this setting if you plan to build a valid document but not necessarily by working from start to finish. This is helpful if you don’t have all the information you need.
   • To show elements allowed anywhere in the current element, select Elements Allowed Anywhere In Parent. Use this setting if you want more flexibility for filling in elements. You can insert elements that are invalid and correct the errors later.
   • To show all elements defined for the document, select All Elements. Use this setting if you’re not building a valid document, if you want flexibility and will correct errors later, if you’re wrapping elements around contents, or if you want to see what’s available elsewhere in the document.
   • To show a set of elements that you specify, select Customized List. Use this setting to work with a subset of the elements, to display elements in a fixed order, or to work with a list that is static instead of context sensitive.

4 If you selected Customized List, click Edit and create or change a list of elements.
   To move element tags between the Show and Don’t Show lists, use the arrow buttons or double-click the element tags. Transfer all of the elements from one list to another by holding down Shift as you click an arrow button. Click the Move Up and Move Down buttons to arrange the elements in the Show list in the order you want them to appear in the Element Catalog. Click Set when the list is the way you want it.

   **Note:** A customized list of tags is always the same regardless of the location of the insertion point, so be careful to include all the tags you need. The only indication of validity is a check mark next to a tag.

5 To list inclusions separately in the Element Catalog, turn on List After Other Valid Elements.
   This groups the inclusions right after the other valid elements. Use this setting if you have a large number of inclusions that you rarely need.

6 Click Set.
Accessibility features in FrameMaker XML Author

The FrameMaker XML Author software provides a number of features that improve access for visually impaired users. In particular, it:

- Provides support for high-contrast viewing for users with low visual acuity.
- Supports assistive technology, such as screen reader software for the Windows® platform.

Screen readers let visually impaired users interact with the computer by interpreting what is happening on the screen and sending that information to speech-synthesis devices. The screen reader will follow the logical structure of the document. Screen readers can read FrameMaker XML Author documents viewed in FrameMaker XML Author, or tagged PDF documents viewed in Adobe Acrobat® or Adobe Reader®. Refer to your screen reader documentation for information on installation and use with documents viewed in FrameMaker XML Author or Acrobat.

For more information on accessibility in Adobe Acrobat and Adobe PDF documents, see the Acrobat online Help and the Adobe website.

Launch the soft keyboard

1. From the Start menu, select Programs > Accessories > Accessibility > On-Screen Keyboard.
2. Click OK. You can then start using the onscreen keyboard.

More Help topics

“Display a high-contrast workspace” on page 30

Opening, saving, and closing documents

Open a document

In FMXA, you can open XML and text files.

Open a file

1. Select File > Open.
2. Locate the document and click Open.

Opening a document usually updates graphics imported by reference, text insets, cross-references, and system variables (if any exist). Recently opened files are listed at the bottom of the File menu.

Messages alerting you to possible issues with the file sometimes appear. You can click OK and resolve the problems later.

Open a text file

Text-only files do not contain graphics or formatting information. When you open a text-only file, you are asked to confirm that it is a text file.

1. Select File > Open, and open a .txt file. The Unknown File Type dialog box appears.
2. Select the Text option.
3. Click Convert.
4 Select one of the following options:
   • To break the text into paragraphs only at blank lines, select Merge Lines Into Paragraphs. Use this option for a paragraph-oriented text file, such as a file containing document text.
   • To break the text into paragraphs at the end of each line, select Treat Each Line As A Paragraph. Use this option for a line-oriented text file, such as a file containing computer code.
   • To convert the text into a table, select the Convert Text To Table. Use this option if the content of your source file is tabulated.
      Select additional options in the Convert To Table dialog box, such as number of columns, cell separators, and heading rows, to obtain the data in the appropriate tabular form.

5 Select the desired Encoding scheme. By default, the ANSI (Windows) encoding scheme is selected.

6 Click Read. The text appears in a document that is created from a special template. You can customize the template so that documents created from text files are formatted differently.

Open a document without updating references
A document opens more slowly if it contains many cross-references to other files, large imported graphics, or many text insets. You can open a document faster by bypassing the update of imported graphics, cross-references, and text insets. However, if you use this method to open documents, keep in mind that FrameMaker XML Author does not warn you about missing items or unresolved cross-references. For this reason, it is best to occasionally open a document in the usual way.

1 Choose File > Open, and select the file you want to open.
2 Control-click Open.

After the file is open, FrameMaker XML Author imports and displays graphics as needed on a page-by-page basis. You can manually update cross-references and text insets by using Edit > Update References. If the page display is too slow, reopen the document in the usual way.

In the case of .xml files, control-clicking the Open button opens them as text files. You are prompted to specify the text reading options in the Reading Text File dialog box. Opening these files as text lets you view or edit the markup.

```
<chapter draftversion = "Alpha Draft"><title>Discovering the Doors</title>
<chapname>Doors</chapname></title>
<reviewinfo></reviewinfo>
<chapintro><autohead></autohead>
<chapoverview><autohead></autohead>
<section><head>Procedures in This Chapter</head>
<para>This chapter describes maintenance procedures on the AstroLiner T440B and T442 light rail safety guidelines, an overview of door components</para>
```

Markup in an SGML file

Troubleshooting unavailable fonts
You sometimes get an alert message that indicates the document you are opening uses unavailable fonts. Fonts can become unavailable for a few reasons:
   • The document was edited on a different system using fonts that are not installed on your system.
   • A font is removed or has become damaged.
   • The default printer for your system has changed.
If the Remember Missing Font Names option in the Preferences dialog box is selected, FrameMaker XML Author preserves the names of unavailable fonts. Selecting this option causes the original fonts to reappear when you open the document on a computer that has the fonts installed, even if you save the document with substitute fonts.

To fix the problem of missing fonts, consider the following options:

**Check for damaged fonts** Determine whether the fonts that are unavailable in FrameMaker XML Author are installed on your system and available in another application. If another application can use fonts that FrameMaker XML Author cannot use, the fonts may be damaged. Reinstall them using the original media. For more information on troubleshooting font problems, isolating damaged fonts or a damaged fonts folder, or reinstalling PostScript fonts, see the Adobe website.

**Remap unavailable fonts** If you cannot install or reinstall the unavailable fonts, you may want to permanently remap the unavailable fonts to available fonts, so that the alert message does not appear when you open the document. You do this by deselecting the Remember Missing Font Names option in the Preferences dialog box before you open the file. However, be aware that doing this causes you to lose the original font information referenced in the document.

**Obtain and install the missing fonts** For example, if you and a co-worker are editing the same documents, and you would like to use the same fonts as your co-worker, consider purchasing and installing copies of the fonts.

### Add metadata to a document

FrameMaker XML Author includes built-in support for Extensible Metadata Platform (XMP). Metadata, or file information, is descriptive information that can be searched and processed by a computer. Use it to provide information about the contents of a document, and to preserve information about a document that will be opened in other Adobe applications. If you export the file to PDF, much of this metadata will appear in Acrobat.

Metadata tags travel with the document and describe its content. By embedding them in your documents, you make the documents easier to track, manage, and retrieve.

**Note:** Metadata in a book file sometimes overrides metadata in a document file. If your document is part of a book file, open the book file and select the document before you add metadata.

1. Make the appropriate document window or book window active. If a book window is active, select the documents you want to affect.
2. Choose File > File Info.
3. Enter the desired information in the box next to any or all categories.
4. For Marked, choose Yes if the document is copyrighted, or No if the document is explicitly in the public domain. Choose Unknown if you're not sure.
5. Click Set.

### Save documents

You can save a document using its current name and location, or save a copy of the document using a different name or location. You can save a document in several formats, including Extensible Markup Language (XML), and Portable Document Format (PDF).

When a document or a book has unsaved changes, an asterisk (*) appears in the Page Status area of the status bar. An asterisk indicates unsaved changes.
Save a document
1 Do one of the following:
   • To save changes in the current file, choose File > Save.
   • To save the file in a different folder or with a different filename, choose File > Save As.
2 If you choose the Save As command, or if the file has never been saved, specify the new filename and location. If you want to save the file in a different format, choose the format from the pop-up menu.
3 Click Save. If you choose Text Only format, specify how to treat the text and tables in the document.

Save a book
1 Do one of the following:
   • To overwrite the current version on the disk, choose File > Save Book.
   • To save the file in a different folder or using a different name, choose File > Save Book As.
2 If you choose the Save Book As command, or if the file has never been saved, specify the new filename and location.

Save all open documents
❖ Hold down Shift and choose File > Save All Open Files.

Return to the saved version of your document
❖ Choose File > Revert To Saved and click OK.

File formats you can save in
You can use the Save As command to save a file in the following formats:

PDF Creates a Portable Document Format (PDF) file that can be viewed in Adobe Acrobat® and other applications that support PDF files.

XML Creates an XML document that can be used for data exchange and viewed on the World Wide Web.

Filename extensions for saved files
When you save a file for the first time in Windows, FrameMaker XML Author automatically adds these extensions: .xml for documents and books. With these extensions, the files are recognized as FrameMaker XML Author files by the Windows operating system.

If you don’t want these special extensions added to the filenames you assign, enclose the filenames in double quotation marks. Windows doesn’t recognize a file without one of these extensions as a FrameMaker XML Author file, but you can still open the file in FrameMaker XML Author.

If you assign an extension that’s registered by another application, such as .doc, the extension is not replaced by the FrameMaker XML Author extension and you can still open the file in FrameMaker XML Author.

Back up and save automatically
FrameMaker XML Author can back up and save your work automatically.
1 Choose .
2. In General preferences, do the following:
   - To create a backup file every time you save, select Automatic Backup On Save. This option creates a copy of the file before your latest changes are saved. If a backup file exists, the new backup file overwrites it. (The filenames of backup files contain .backup.)
   - To create an autosave file at regular intervals, select Automatic Save and enter an interval (in minutes) in the box. This causes a copy of the file to be saved periodically without your having to choose File > Save. (The filenames of autosave files contain .auto.) When you save manually or revert to the last saved version with the Revert To Saved command, the autosave file is deleted.

3. Click OK.

**Currently opened files pod**

FrameMaker XML Author prompts you to review and save the open files when you try to exit FrameMaker XML Author. When you try to exit FrameMaker XML Author, FrameMaker XML Author displays the Currently Opened Files pod using which you can:

1. Review and save files with unsaved changes
2. Search for a file with a specific name or files saved in a particular folder
3. Navigate across different files
4. Review the path of the various open files
5. Close specific files after saving or without saving

---

The Currently Opened Files pod
A. Refresh  C. Search - As you type, the pod matches the search criteria with entries in all the columns  D. Clear search criteria  E. The checkbox to select all the currently opened files  F. The checkboxes to select the currently opened files  G. Click to save files and keep them open  H. Click to close the selected files - if there are unsaved changes in the files you are trying to close, the Save Files dialog appears

Even while working on FrameMaker XML Author, you can display a list of currently opened files, review the unsaved files, and save the ones you want to.
Save files on exit or while closing files
FrameMaker XML Author displays the Save Files dialog when you attempt any of the following:

- Exit FrameMaker XML Author by
  - Clicking the Close button
  - Selecting File > Exit
  - Right clicking in the Status Bar and selecting Close all windows
  - Using Alt+F4 on the keyboard
- Select Shift+File and select one of the following options
  - Close All Open Files
  - Close All Files in Book
  - Close All Files in Ditamap
- Try to close files without saving in the Currently Opened Files pod

The Save Files dialog

In the Save Files dialog, you can review and save unsaved changes files. You can also discard the changes by deselecting the files and clicking OK.

Save and close currently opened files
You can see a list of currently open documents in the Currently Opened Files pod. Using the Currently Opened Files pod, you can select the files and changes to save and discard.

Save
1. Do one of the following:
   - Select File > Currently Opened Files.
   - Select View > Pods > Currently Opened Files.

FrameMaker XML Author displays the Currently Opened Files pod. Unsaved files and files with unsaved changes are indicated with asterisk (*). To locate files in a long list, type in the Search box. FrameMaker XML Author matches the text in the name of the file as well as the path.

2. Select the files to be saved and do one of the following:
   - Click Save.
     FrameMaker XML Author saves the selected files. FrameMaker XML Author prompts you to specify the name and path of the files that are not saved to the disk yet.
   - Click Save and Close.
     FrameMaker XML Author saves and closes the selected files.
   - Close Files.
     FrameMaker XML Author closes the selected files. If you choose to close any files with unsaved changes, the List Of All Open Files dialog appears.
FrameMaker XML Author Basics

Last updated 8/18/2015

Restore last session

FrameMaker XML Author allows you to restore the last session you were working on when you last exited FrameMaker XML Author or it crashed. In case of a crash, when you launch FrameMaker XML Author again, FrameMaker XML Author displays an alert where you can choose whether or not to restore the last session. By restoring the last session, you can reinstate the following as you were working on them in the last session:

- View: XML Code, WYSIWYG, or Author
- Workspace
- The document in focus
- The files open in the last session (Except the files open through the CMS connector in the last session)
- Page numbers in focus for different documents
- The scrollspace for the master, body and reference pages
- Tab order of the documents
- Palettes (such as Equation, Templates, and Thesaurus browser)
- stuctapps.fm file: The last read structapps.fm file (On restore, the last read structapps.fm file is read again)

Conditions to restore last session

If all the following conditions are met, you can restore FrameMaker XML Author’s last session:

1. There were files open when you exited FrameMaker XML Author or it crashed. In other words, there is something to restore in the last session. If you exit files FrameMaker XML Author after manually closing the files, there is nothing to restore.

2. There are no open files when you try to restore the last session

To restore the last session

To restore FrameMaker XML Author’s last session, launch FrameMaker XML Author and do one of the following:

- Click Restore Last Session on the starter screen.
- OR
- Select File > Restore Last Session.
- OR
- Use the keyboard shortcut Esc r s.
- OR
- In case FrameMaker XML Author crashes, when you relaunch FrameMaker XML Author, FrameMaker XML Author displays an alert message where you can click Yes to restore the last session.

FrameMaker XML Author restores the last session. If there are some files that could not be restored, FrameMaker XML Author displays an error message and lists the files in the in the console.

Preferences for alerts on restore

In the preferences dialog, you can select whether or not to display the alerts, such as missing fonts and unresolved cross references, on session restore. The alerts that require user action, such as missing graphics, appear even when you have disabled the alerts.
Document direction

FrameMaker allows you to author documents in both left-to-right (LTR) as well as right-to-left (RTL) scripts such as Arabic and Hebrew.

FrameMaker provides out-of-the-box document direction support for DITA topics (see Change text direction). However, for structured documents based on other structured applications, the application developer will need to define the \texttt{dir} property in the EDD. For details, see the Structured applications reference guide.

You can also choose to author multi-directional documents. This means that you can author a document in a specific direction that includes elements authored in the other direction.

You can change the orientation (flip) of the images in a document based on the direction of the document.

Inheritance design

The direction authoring support in FrameMaker is based on an inheritance design. By default, the element in a document inherit the direction of the document. For example, direction of the elements inserted into a RTL document will be RTL. FrameMaker uses this inheritance design to allow you to author multi-directional documents.

Caret location and movement

By default, the cursor in an RTL enabled document moves right to left as you type. FrameMaker now has system of a strong (primary) caret and a weak (secondary) caret. The strong caret indicates where an inserted character will be displayed when that character’s direction is the same as the base direction of the text. The weak caret shows where an inserted character will be displayed when the character’s direction is the opposite to the base direction.

To change the movement behavior of the caret:

1. Open the Preferences dialog (Choose Edit > Preferences).
2. In the Caret Movement group, choose Logical to ensure that the key movement remains the same as the logical order of inserted characters.
   Choose Visual to ensure that the cursor movement is in the direction of the keys. For example, the left key moves the cursor in the left direction.
Chapter 4: Variables, line numbers, and document creation

Variables

About variables
You can include text that frequently changes and appears often in your document as variables. Variables are also useful for providing information that is updated automatically, such as the current date. In FMXA, you have system variables and user variables. System variables are maintained by FMXA, such as current date or filename. User variables are variables that you define in FMXA, such as company name or product name.

System variables
Each system variable has a name and a definition. Although you cannot rename system variables, you can edit their definitions. A system variable definition can contain the following items:

- Building blocks for system information, such as the month, day, year, and filename
- Text characters, such as the comma and the spaces that appear in the date May 1, 2012
- Building blocks for character format changes

For example, the Table Sheet variable that appears in a table title as (Sheet 3 of 5) has the following definition.

You can change the definition—the way the information is displayed—by adding, removing, or rearranging building blocks and by editing the text in the definition. For example, you can change the format used to display the current date.

If you place a system variable on a body, the value is updated only when you open or print the file.

You can also manually update the value of the variable when the file is open. Access the Variables pod and click Update.

Note: Variables and variable names support the Unicode text encoding standard.
Default values for system variables

<table>
<thead>
<tr>
<th>System variable</th>
<th>Default definition (US English version)</th>
<th>Example of display</th>
</tr>
</thead>
<tbody>
<tr>
<td>Current Page #</td>
<td>&lt;$curpagenum&gt;</td>
<td>3</td>
</tr>
<tr>
<td>Page Count</td>
<td>&lt;$lastpagenum&gt;</td>
<td>18</td>
</tr>
<tr>
<td>Current Date (Long)</td>
<td>&lt;$monthname&gt;, &lt;$daynum&gt;, &lt;$year&gt;</td>
<td>October 11, 2012</td>
</tr>
<tr>
<td>Current Date (Short)</td>
<td>&lt;$monthnum&gt;/&lt;$daynum&gt;/&lt;$shortyear&gt;</td>
<td>10/11/12</td>
</tr>
<tr>
<td>Modification Date (Long)</td>
<td>&lt;$monthname&gt;, &lt;$daynum&gt;, &lt;$year&gt;,</td>
<td>September 24, 2011, 10:48 am</td>
</tr>
<tr>
<td></td>
<td>&lt;$hour&gt;:&lt;$minute00&gt; &lt;$ampm&gt;</td>
<td></td>
</tr>
<tr>
<td>Modification Date (Short)</td>
<td>&lt;$monthnum&gt;/&lt;$daynum&gt;/&lt;$shortyear&gt;</td>
<td>9/24/11</td>
</tr>
<tr>
<td>Creation Date (Long)</td>
<td>&lt;$monthname&gt;, &lt;$daynum&gt;, &lt;$year&gt;</td>
<td>July 1, 2012</td>
</tr>
<tr>
<td>Creation Date (Short)</td>
<td>&lt;$monthnum&gt;/&lt;$daynum&gt;/&lt;$shortyear&gt;</td>
<td>7/1/12</td>
</tr>
<tr>
<td>Filename (Long)</td>
<td>&lt;$fullfilename&gt;</td>
<td>c:\Memos\Staffing.fm</td>
</tr>
<tr>
<td>Filename (Short)</td>
<td>&lt;$filename&gt;</td>
<td>Staffing.fm</td>
</tr>
<tr>
<td>Table Continuation</td>
<td>(Continued)</td>
<td>(Continued)</td>
</tr>
<tr>
<td>Table Sheet</td>
<td>(Sheet &lt;$tabsheetnum&gt; of &lt;$tabsheetcount&gt;)</td>
<td>(Sheet 1 of 2)</td>
</tr>
<tr>
<td>Volume Number</td>
<td>&lt;$volnum&gt;</td>
<td>3</td>
</tr>
<tr>
<td>Chapter Number</td>
<td>&lt;$chapnum&gt;</td>
<td>3</td>
</tr>
<tr>
<td>Section Number</td>
<td>&lt;$sectionnum&gt;</td>
<td>3</td>
</tr>
<tr>
<td>Sub Section Number</td>
<td>&lt;$subsectionnum&gt;</td>
<td>3</td>
</tr>
</tbody>
</table>

You can use the <$chaptertitlename> variable to propagate the folder name in the template associated with the folder.

More Help topics
“Add a folder” on page 211

User variables
Each user variable has a name and a definition. A definition includes text and optional building blocks for the character format of the text. For example, suppose you define a variable as follows:

<BookTitleFormat>The Earth Sciences

If the BookTitleFormat character format is defined as italics, this variable appears on the page as The Earth Sciences.

You can change the definition of any user variable, for example, when the book title changes. When you change the definition, all occurrences of the variable in your document are updated to use the new definition.

The standard templates don’t provide any user variables. If you’re using one of these templates, create your own user variables. If you’re using a template created at your site, perhaps it already includes some user variables.

Valid variables in structured documents
You can add a system variable to a structured flow, with or without a special variable element. You do not use special variable elements for user variables but insert them directly in elements defined for text.

Variables in FMXA are exported as entities, and usually the entity name is the same as the variable name. However, if you create a variable whose name is not a valid XML or SGML name, the entity name is not the same as the variable name.
Here are some examples of invalid names:

- A name with multibyte (Asian-language) characters.
- A name that includes anything other than alphanumeric characters, hyphens, or periods.
- A name containing more characters than the number specified by the value of NAMELEN in the XML or SGML declarations for the particular application.

### Working with variables

#### Variables pod

You can use the Variables pod to insert, edit, or delete system and user variables.

1. Select the file
2. Insert a variable in your document
3. Create a new user variable
4. Edit a variable definition
5. Delete a user variable
6. Convert a variable to text
7. Update all system variables
8. Refresh the pod data
9. Search for a variable
10. System variables
11. User variables
12. Variable format
13. Document in which the variable exists

### More Help topics

“Using pods” on page 32

### Insert a variable

You can insert most system variables on a body, reference, or master page.

1. Access the Variables pod from View > Pods > Variables.
2. Click to place the insertion point where you want the variable to appear in the document.
3. Double-click a variable from the Variables pod to insert it in your document. Alternatively, click the Insert icon on the pod toolbar.

The Variables pod contains the variables allowed at the insertion point in the document. For example, if the insertion point is in a text frame on a body page, the scroll list doesn’t contain the Current Page # variable. If the insertion point is in a text frame on a master page, then more variables are displayed in the Variables pod.
**Insert variable elements in structured documents**

You can use an element to insert a variable in a structured flow. You can also insert a variable directly in text, without using a special variable element. For example, you can include the Chapter Title Name as part of a body element.

FMXA comes with a set of system variables. The format rules of a variable element determine which variable to use with it. You cannot change a system variable element to use a different variable.

The values of system variables you insert are updated when you open or print the document. You can also update system variables manually. (System variables in headers or footers are updated when the page is redisplayed.)

1. Click where you want to insert the variable.
2. Select a system variable element in the Element Catalog and click Insert.
3. If the Attributes for the New Element dialog box appears, enter attribute values for the element and click Insert Element.

   The current value of the variable appears at the insertion point. A bubble for the variable appears in the Structure View, with a text snippet that shows the beginning of the variable text.

4. To update all variables in the current document, click Update on the pod toolbar. To update variables in all open documents, first select All Open Docs and then click Update on the pod toolbar.

If your application has user variables already defined, you can insert variable elements in your document. You can insert a user variable directly in text, without using a variable element. Perhaps your application has user variables already defined. You can define and maintain other user variables as needed. If the value of a user variable changes, it is updated automatically wherever it occurs.

**Edit or delete a variable occurrence**

If you edit a variable definition, then all occurrences of the variable in the document are updated.

Alternatively, you can convert a variable to editable text and then edit the text in the document. If you convert the variable to text, however, the text is no longer updated when the variable definition changes.

You can delete variable occurrences from a body page. Also, backspacing the insertion point over a variable in the document doesn’t delete the variable. You can remove or edit a variable in the following ways:

- To delete one occurrence of a variable:
  1. Select the variable name from the Variables pod and click Edit.
  2. From the Add/Edit Variables panel or the Edit System Variables panel, select the instance from the Location list and click Delete.
- To copy or move a variable, select it and choose Edit > Copy, Edit > Cut, or Edit > Paste.
- To replace a variable, select the variable in the Document view, and then double-click a different variable in the Variables pod.
- To delete a variable in a text inset, delete the variable in the source document.

*Note: Deleting a variable definition converts all occurrences of the variable in your document to editable text.*

**Convert a variable to text**

1. Select the variable, click Convert To Text from the Variables pod.
2. Do one of the following:
   - To convert a single occurrence of a variable, click Selected Variable.
• To convert all occurrences of a particular variable, select the variable in the Variables Named scroll list. For structured documents, you can also choose the variable element tag from the Variables With Element Tag pop-up menu.

• To convert all variables in the document, click All Variables.

3 Click Convert.

Create a user variable
A user variable is useful for a product name that can change or for a long manual name that is difficult to type each time. You can add a new variable and edit its definition from the Add/Edit Variable panel.

Add or edit existing user variable definitions from the Add/Edit Variable panel
- **A.** Name of the new variable or variable selected in the Variables pod
- **B.** Specify or edit the format definition for the variable
- **C.** Select from the list of building blocks to define the variable format
- **D.** Name of the file that contains the selected variable instance in the Variables pod
- **E.** Location list displays the location of the selected variable in the document. It displays the page number and the headings under which it appears
- **F.** Add a new user variable
- **G.** Edit the definition of a variable
- **H.** Highlights the selected variable in the Document view. Select an instance from the Location list and click this button
- **I.** Refreshes the data in the Location list
- **J.** Deletes the selected variable instance selected in the Location list from the document.

If you don’t specify a character format in the variable definition, the variable uses the format at the insertion point. If you change the character format for the variable, the change applies only to the variable, not to the text that follows.

1 Click Create New User Variable from the Variables pod.

2 Enter the name and definition of the variable. Use these guidelines:
   - Variable names are case-sensitive.
   - The complete definition, including typed text and character formats, can be up to 255 characters long.
   - You cannot use system variable building blocks for user variables.
   - To include an angle bracket in a variable definition as text, precede it with a backslash (\).
   - Enter a sequence of characters beginning with a backslash (\).
   - To create a multiline variable such as multiline address, append \r for each line. Do not press Enter to insert a line break.
3 To change the character format within the variable definition, do the following:

- To use a character format stored in the Character Catalog, place the insertion point in the Definition box where you want to change the character format. Then click the character format in the Character Formats scroll list. The scroll list includes all the formats in the Character Catalog of the current document.

  **Important:** Don’t use a character format whose tag includes angle brackets.

- To return the character format to the paragraph default font at the end of the variable, place the insertion point in the Definition box where you want to change the character format. Then click `<Default Font>` in the Character Formats scroll list.

4 Click Add.

5 To add more user variables, repeat steps 3 through 5.

**Edit a variable definition**

You can edit both system variables and user variables. For a system variable, you can edit its format by changing its building blocks in the Edit System Variable panel. To do so, select the system variable in the pod and click the Edit button.

![Edit System Variable Panel](image)

*Edit system variable definitions from the Edit System Variable panel*

A. Name of the variable selected in the Variables pod  
B. Displays the format definition for the variable  
C. Select from the list of building blocks to define the variable format  
D. Displays the name of the file that contains the selected variable instance in the Variables pod  
E. Location list displays the location of the selected variable in the document. It displays the page number and the headings under which it appears  
F. Edits the definition of the selected variable  
G. Highlights the selected variable in the document. Select an instance from the Location list and click this button.  
H. Refreshes the data in the Location list  
I. Deletes the selected variable instance selected in the Location list from the document.

For user variables, you can change the variable name and the variable format from the Add/Edit Variable panel.
Variables, line numbers, and document creation

Add or edit existing user variable definitions from the Add/Edit Variable panel
A. Name of the new variable or variable selected in the Variables pod
B. Specify or edit the format definition for the variable
C. Select from the list of building blocks to define the variable format
D. Name of the file that contains the selected variable instance in the Variables pod
E. Location list displays the location of the selected variable in the document. It displays the page number and the headings under which it appears
F. Add a new user variable
G. Edit the definition of a variable
H. Highlights the selected variable in the Document view. Select an instance from the Location list and click this button.
I. Refreshes the data in the Location list
J. Deletes the selected variable instance selected in the Location list from the document.

Note: If a variable is in a text inset that uses the source document formats, change the variable definition in the source document.

1 Select the variable from the Variables pod and click Edit.
2 Do one of the following:
   • For user variables, edit the variable name or change its definition in the Add/Edit Variable panel and click Edit.
   • For system variables, edit the definition and click Edit.

   Insert a building block for system-supplied information or for a character format at the insertion point. Click the building block in the Building Blocks scroll list. Only the building blocks appropriate for the variable appear in the scroll list. For example, <$fullfilename> and <$filename> appear for the filename variables. All the character formats in the Character Catalog appear at the bottom of the scroll list.

   All instances of the variable in the document are updated with the new format.

Changing definitions of date and time variables
FMXA includes both long and short versions of variables for the current date, the date the document was last modified, and the document creation date. FMXA provides the following building blocks for date and time variables.
FMXA uses the language of the current paragraph to determine the language used in date and time variables. For example, the current day name variable sometimes appears as Wednesday in an English paragraph but as Miercoles in a Spanish paragraph. If you change the language of a paragraph, the system variables in the paragraph are updated to use the new language.

If your system supports the typing of Japanese text in documents and dialog boxes, the following additional building blocks are available for Japanese dates.

<table>
<thead>
<tr>
<th>Building block</th>
<th>What it displays</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;$second&gt;</td>
<td>Seconds</td>
<td>8 or 32 08 or 32</td>
</tr>
<tr>
<td>&lt;$second00&gt;</td>
<td></td>
<td>8 or 32 08 or 32</td>
</tr>
<tr>
<td>&lt;$minute&gt;</td>
<td>Minutes</td>
<td>8 or 12 08 or 12 08 or 22</td>
</tr>
<tr>
<td>&lt;$minute00&gt;</td>
<td></td>
<td>8 or 12 08 or 12 08 or 22</td>
</tr>
<tr>
<td>&lt;$hour&gt;</td>
<td>Hours</td>
<td>8 or 12 08 or 12 08 or 22</td>
</tr>
<tr>
<td>&lt;$hour01&gt;</td>
<td></td>
<td>8 or 12 08 or 12 08 or 22</td>
</tr>
<tr>
<td>&lt;$hour24&gt;</td>
<td></td>
<td>8 or 12 08 or 12 08 or 22</td>
</tr>
<tr>
<td>&lt;$ampm&gt;</td>
<td>Morning or evening designation</td>
<td>am or pm A.M. or P.M.</td>
</tr>
<tr>
<td>&lt;$AMPM&gt;</td>
<td></td>
<td>A.M. or P.M.</td>
</tr>
<tr>
<td>&lt;$daynum&gt;</td>
<td>Number of the day</td>
<td>8 or 28 08 or 28</td>
</tr>
<tr>
<td>&lt;$daynum01&gt;</td>
<td></td>
<td>8 or 28 08 or 28</td>
</tr>
<tr>
<td>&lt;$dayname&gt;</td>
<td>Name of the day</td>
<td>Monday Mon</td>
</tr>
<tr>
<td>&lt;$shortdayname&gt;</td>
<td></td>
<td>Monday Mon</td>
</tr>
<tr>
<td>&lt;$monthnum&gt;</td>
<td>Number of the month</td>
<td>8 or 12 08 or 12</td>
</tr>
<tr>
<td>&lt;$monthnum01&gt;</td>
<td></td>
<td>8 or 12 08 or 12</td>
</tr>
<tr>
<td>&lt;$monthname&gt;</td>
<td>Name of the month</td>
<td>August Aug</td>
</tr>
<tr>
<td>&lt;$shortmonthname&gt;</td>
<td></td>
<td>August Aug</td>
</tr>
<tr>
<td>&lt;$year&gt;</td>
<td>Year</td>
<td>1997 97</td>
</tr>
<tr>
<td>&lt;$shortyear&gt;</td>
<td></td>
<td>1997 97</td>
</tr>
<tr>
<td>&lt;$daynumkanjikazu&gt;</td>
<td></td>
<td>月 or 1月</td>
</tr>
<tr>
<td>&lt;$daynumkanjinumeric&gt;</td>
<td></td>
<td>月 or 1</td>
</tr>
<tr>
<td>&lt;$monthnumkanjikazu&gt;</td>
<td></td>
<td>月 or 1月</td>
</tr>
<tr>
<td>&lt;$monthnumkanjinumeric&gt;</td>
<td></td>
<td>月 or 1</td>
</tr>
<tr>
<td>&lt;$imperialyear&gt;</td>
<td></td>
<td>1 or 10</td>
</tr>
<tr>
<td>&lt;$imperialyear01&gt;</td>
<td></td>
<td>01 or 10</td>
</tr>
<tr>
<td>&lt;$imperialyearspecialkanjikazu&gt;</td>
<td></td>
<td>万 or 1万</td>
</tr>
</tbody>
</table>
Japanese dates appear in a variable when the variable uses a Japanese font family and the Language property is set to Nihongo.

## Line numbers

Line numbers in FMXA files help you identify particular lines of content. For XML files, line number properties are derived from their respective template documents.

While using line numbers and change bars, ensure that they do not overlap.

### Insert line numbers

To insert line numbers, complete the following steps:

**Note:** You can also use the View > Line Numbers to display/hide line numbers.

2. In the line number properties dialog, select Show line numbers and specify the following:

   - **Width:** Distance of line numbers from the column. The distance is relative to the columns that contain text.
Some highlights of line numbers

1. Support for multicolumn and multiflow formats: For files with multicolumn formats, line numbers appear for text in each of the columns. For multi-flow documents, the line numbers are calculated according to the text flows and continue accordingly.

2. Recalculation: When you insert text within a paragraph with line numbers are enabled, the line numbers are recalculated to accommodate the new text.

3. Document level property: Line numbers are a document level property. Line numbers can be set at a document level to continue from previous page or restart at each page.

4. Text flows: For multi-flow documents, the line numbers follow the text flows and continue according to the text flows.

5. XML documents: Line numbers do not persist in XML documents. However, you can enable line numbers in the application template.

6. Printing: Line numbers are visible in the print and PDF created using Save As PDF.

Create documents

In FrameMaker XML Author, you create structured (.xml) documents.

Create a document based on a structured application

If you want to create a structured document, make sure that you have an EDD and a structured application available. You can use the EDD file and sample structure application included with FrameMaker XML Author in the Structure folder, or you can create your own. For information on creating a structured application and EDD, see the online manual, Developing Structured Applications with Adobe FrameMaker 9 on the Adobe website, www.adobe.com/go/lr_FrameMaker_support_en.

1. Choose File > New > XML.

2. In the New XML dialog, choose one of the following:
   - Structured Applications: Choose from DITA, S1000D, or any other structured applications set up on FrameMaker XML Author on your computer.
   - DITA: Choose to create a DITA topic, such as Task, Concept, or Reference.
   - S1000D: Choose to create an S1000D module, such as Crew or IPD.

3. Save the document in the desired format.
Create an XML document based on a DTD

You can create a structured document based on the DTD. For the formatting of the document, you need to create an EDD and do further work. For XML roundtripping, you need to create an XML application based on the DTD. For information on creating a structured application and EDD, see the online manual, *Developing Structured Applications with Adobe FrameMaker 9* on the Adobe website, www.adobe.com/go/lr_FrameMaker_support_en.

1. Select File > New > XML.
2. In the New XML dialog, select other XML.
3. Select DTD Based XML and click OK.
4. Specify the following:
   a. Root Element: Specify the name of the root element.
   b. Public ID: Enter a public ID. A public ID in an XML document makes it portable to other computers.
   c. System ID: Specify the path to the relevant DTD. The System ID is the URL of the DTD relevant to an XML file.
5. Click OK.

FrameMaker XML Author makes the elements in the specified DTD available in the document.

Create a blank XML document

You can create a blank XML document without a structured application or a DTD. An XML document without a DTD allows you to create markup tags without having to define them first. XML aware programs can parse a well-formed XML document even when it does not have an associated DTD.

1. Select File > New > XML.
2. In the New XML dialog, select Other XML.
3. Click Empty XML.
4. Click OK.
Chapter 5: Text

Adding and editing text

Add text and special characters

The insertion point marks where you enter or edit text.

You can also insert special text items, such as cross-references, footnotes, variables, and markers from the Special menu. When you click a special text item, such as a cross-reference, variable, or text inset, you select the entire item.

If you can’t place the insertion point in or next to text, consider these possible reasons:

• The text is background text that was typed on a master page.
• The text was automatically generated, as with paragraph autonumbers, cross-references, or headers and footers.

More Help topics

“Search for items” on page 81

Special characters

In addition to standard characters, you can type bullets, dashes, fixed-width spaces, mathematical symbols, international characters, and other special characters.

Note: In FrameMaker XML Author, character (ALT) sequences are not implemented for Dingbats and Symbol fonts because Unicode equivalents of codepage 1252 for these fonts are provided by default. The character (ALT) sequences are implemented for the MakerRoman font family only.

For a list of characters in the Symbol and Zapf Dingbats fonts, a list of accented characters in the standard character set, and information on inserting the Euro currency symbol, see the online manual FrameMaker XML Author Character Sets.

Some special characters are entered or displayed differently in dialog boxes. In Windows, you enter a sequence of characters beginning with a backslash (\), these sequences are listed in “Dialog boxes” on page 376.

Tabs

Each time you press Tab, a tab symbol is embedded in the text. The symbol does not appear in the printed document, but it is visible onscreen when text symbols are visible.

If the current paragraph has tab stops set, FrameMaker XML Author moves the insertion point and text one tab stop each time you press Tab. If tab stops are not set, pressing Tab doesn’t move the insertion point and text. If you press Tab more times than you have tab stops, the Tab symbols overlap. If you later add tab stops to the paragraph, FrameMaker XML Author positions the text correctly at the tab stops.

FrameMaker XML Author uses tab stops that are absolute rather than relative. With relative tab stops, each time you press Tab, the insertion point moves to the next available tab stop. With absolute tab stops, the nth tab on a line moves the insertion point to the nth stop. If that tab stop is to the left of the insertion point, the insertion point does not move.
Copy, move, and delete text

Pasted text retains its character format properties. If the pasted text contains paragraph symbols ¶, the paragraph format associated with each paragraph is also pasted. Otherwise, the pasted text takes the paragraph format of the paragraph in which it is pasted.

You copy text more quickly if you bypass the clipboard, which is possible only if the original text and the new location are visible and exist in the same document. You must use the clipboard to copy and paste text from one document to another.

❖ To copy text without using the clipboard, place the insertion point where you want to insert the copied text, hold down Alt, and select the text you want to copy.

Drag and drop text

FrameMaker XML Author allows you to drag and drop text. You can drag and drop text across various FrameMaker XML Author documents and across other applications that support the drag and drop feature.

In addition, FrameMaker XML Author allows you to drag and drop elements.

• To copy an element, hold the CTRL key while dropping the element in its new location.
• If you drop an element in an invalid location, the cursor changes to a ‘?’ to indicate that the location is invalid.

You can also drag and drop rows and columns of a table.

• In a table, to move a whole row or column, select the column or row, and hold the ALT key while dropping it to the new location.
• In a table, to copy a whole row or column, select the column or row, and hold the CTRL and ALT keys together while dropping it to the new location.

Note: If you do not hold the ALT key while dragging columns or rows, only the contents of the columns and rows are copied.

Working with elements in structured documents

About elements

The basic unit of information in structured documents is called an element. Elements hold other elements, text, graphics, tables, cross-references, and markers.

You can add elements to a document to build its structure, and you can edit existing elements in many ways.

If you create a FrameMaker XML Author document by opening a structured file, you do not need to add elements to it. The document already contains elements. You can edit the document’s elements, and add more elements.

To build a document’s structure, you can either add elements to the document and then fill in the contents, or select existing contents and wrap them in elements.

A structured document has element definitions stored in its Element Catalog. These definitions describe the allowable contents for each type of element the document can have. They sometimes specify attributes and formatting for the elements. If all the elements in a document have contents and attributes that meet these specifications, the document is valid.
Valid contents for elements
An element’s definition has content rules that determine what the element can contain. For example, perhaps the definition of a Section element specifies that a Section must begin with a Head element, then must have a Para element, and then can have any combination of Para, Figure, and other Section elements. A Para element sometimes allows text and CrossRef elements, in any order.

The Element Catalog indicates valid elements for the current location with a heavy check mark. It shows that text is allowed with the <TEXT> tag.

Two classes of elements
Elements fall into two basic classes determined by their allowable contents:

• A container element can hold text, other elements, or both. Container elements, such as heads and paragraphs, build the document’s structure.

• An object element is a single object—a marker, cross-reference, system variable, equation, or anchored frame. You cannot type in these elements or add child elements to them.

A. Containers have round-cornered bubbles. B. Object elements have square-cornered bubbles.

A container element can be defined to remain empty. For example, perhaps a table cell is empty as part of a table’s design. If an element contains only spaces or nonprintable characters such as tabs, its text snippet in the Structure View is <WHITESPACE>.

Attributes for elements
An element can have attributes, which provide information about the element that is not part of the element’s contents. Your document uses attributes for several purposes:

• To control the formatting of an element. For example, perhaps a Type attribute in a List element has two possible values—Bulleted and Numbered.

• To record descriptive information about an element, such as level of classification. An attribute value can even trigger a custom routine that hides the element when the document is displayed.
To store source and destination information for elements, typically for cross-referencing. A Section element sometimes has an ID attribute that stores a unique value. A cross-reference element that points to the Section stores the same value in a Reference attribute, to maintain the connection between the elements.

You typically enter and edit the values for attributes, unless the attributes are defined to be read-only. Cross-reference IDs are often read-only and are generated by FrameMaker XML Author.

**Insert elements**

To add an element to a document, you either insert an empty element and enter contents, or wrap an element around existing contents. Before you can begin, your document must have element definitions in its Element Catalog.

If you haven’t yet fully planned your document, consider inserting just the high-level elements, such as Section and Head elements, and then use this structure as an outline for developing the document.

You can also enter all the elements in their correct order and hierarchy as you go, or concentrate on contents rather than on structure, and then validate later to correct errors.

The Element Catalog shows the elements that are available at the current location. You can change the scope of elements available—for example, to show elements that are not valid at the current location. Ask your application developer for a summary of what each element can contain.

If you have turned on element boundaries, then once you insert or wrap an element, a pair of element boundaries appears in the document window, and a new bubble appears in the Structure View.

**Insert an element using the Element Catalog**

1. Click where you want to insert the element. If you’re inserting it between other elements, work in the Structure View rather than the document window.

2. Select an element tag in the Element Catalog, and click Insert. If only one element appears in the catalog, you can click Insert without selecting it.

   You can also double-click an element tag to insert the element.

   *Note: The Element Catalog always displays only those elements that are valid at the insertion point.*

3. If the Attributes For New Element dialog box appears, enter attribute values for the element and click Insert Element.

   This dialog box appears only if the element has attributes and if an option is set in the New Element Options dialog box to prompt for attribute values when you insert new elements.

4. If you insert a table, a marker, a graphic, or a cross-reference, provide more information about the element in the dialog box that appears.

5. Add content to the elements. You can add content as you insert elements, or after you build the structure of your document.
Press Return to insert elements
In many cases, pressing Return inserts an element automatically. Whenever you press Return, FrameMaker XML Author checks the current element’s definition for the following conditions—in the following order—and sometimes inserts a child element:

One valid element If only one child element is valid at the current location, pressing Return adds that element. For example, after you add a Section, perhaps a Head is the only element permitted next. You can also use this technique to create repeating elements, such as body paragraphs and list items.

More than one valid element If more than one child element is valid, pressing Return highlights the Tag area to prompt you for an element tag. Type until the tag you want appears, and then press Return to insert the element.

End of an element If the insertion point is at the end of an element and no more child elements are valid, pressing Return looks for valid elements in ancestors after this location. If a valid element is found, the insertion point moves to the ancestor and the element is inserted (if only one is valid) or the Tag area is highlighted (if more than one element is valid).

Other conditions If none of the preceding conditions are true, pressing Return causes a beep and no element is inserted.

Set options for inserting new elements
1 Make the appropriate document window or book window active. If a book window is active, select the documents you want to affect.
2 Choose Element > New Element Options.
3 Specify how you want to be prompted for attribute values when you add new elements:
   • To enter all possible attribute values as you add elements, select Always Prompt For Attribute Values.
   • To enter only required attribute values as you add elements, select Prompt For Required Attribute Values.
   • To enter attribute values after adding elements, select Do Not Prompt For Attribute Values.
4 To allow FrameMaker XML Author to insert child elements automatically for new elements, select Allow Automatic Insertion Of Children.
5 Click Set.

To speed up the process of adding new elements, select the Do Not Prompt For Attribute Values and Allow Automatic Insertion Of Children options.

Add text in a structured document
Place the insertion point anywhere inside a text frame in a document window. An insertion point also appears at the corresponding place in the Structure View. To place the insertion point in the middle of text, use the document window rather than the Structure View. When placing the insertion point at the beginning or end of an element, or between elements, click in the Structure View.

The Element Catalog describes what the current element can contain. You can enter text whenever <TEXT> appears in the catalog.

1 Place the insertion point:
   • To place at the beginning or end of text, click to the left or right in the first or second half of the text snippet. After you click, a line on the left or right side of the triangle insertion point indicates that the point is at the beginning or end of text.
To place between two elements, click to the right of the vertical line connecting the elements, between the two bubbles.

Begin typing. Don’t press Return unless you want to insert a new element.

**Edit elements**

You can edit a document’s structure in many ways—including changing an element to a different type, rearranging elements, and splitting and merging elements.

After editing one part of a document, sometimes you edit the document further to correct content errors. For example, if you split a Section element in two, you sometimes need to add a Head element for the new second Section. Use the Structure View as a guide for finding errors as you work, or validate the document when you’re finished.

**Change elements**

You can change an existing element to another element of the same type. For example, you sometimes want to convert a Para element into a Note element, or a series of Para elements into ListItem elements that you can include within a List element.

However, not all elements can be converted to other elements. For example, if you change a Para element containing text to a Marker element containing the same text, the name of the element changes, but the text is not converted to marker text.

---

**Note:** If you want to change contents to a table, use Table > Convert To Table to convert text rather than changing an element.

**Changing elements to another type**

1. Select the element. You can select more than one element, even if the elements do not have the same tag. All the elements are changed to the new type of element. However, the elements’ children are not changed, but they sometimes become invalid because the parent changed.

2. Select an element tag in the Element Catalog and click Change. Sometimes attributes in the element become invalid and need to be corrected.

**Merge elements**

You can merge two or more elements into a single element. Merging places the contents of the second element (including any child elements) at the end of the first element.

---

<table>
<thead>
<tr>
<th>Section</th>
<th>Head</th>
<th>Para</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Insertion point between two elements**

Merging two Sections, before and after

Last updated 8/18/2015
You sometimes must edit the document after merging elements.

1. Select the elements you want to merge. The elements can be of different types, but they must be siblings and next to each other in their parent element.
2. Choose Element > Merge.

Merging retains the attributes for the first element only.

**Split an element**

You can split an element into two elements that have the same tag and are at the same level. For example, perhaps you split a Section element in two.

![Splitting a Section, before and after](image)

You sometimes must edit the document after splitting an element. In the example above, after splitting you would add a Head for the new second Section.

*Note: You cannot split an element that is a table part (such as a row or cell).*

1. Click where you want to split the element. The contents after the insertion point go in the new second element.
2. Choose Element > Split.

Splitting sometimes results in two elements with identical attributes. However, if the original attribute had a Unique ID attribute, the second element loses its ID value.

**Wrap elements around existing content**

You can add structure to content already in a document by wrapping a new element around the content. The content can be any part of a document, including other elements. The element’s content is formatted as specified in the element’s format rules.

*Note: You cannot wrap content in elements that are for parts of tables (such as rows or cells), but you can wrap text or other elements that are within a cell or a table title element. If you want to convert text and elements to a table, use Table > Convert To Table rather than wrapping.*

After wrapping an element, you sometimes must edit the document to correct structure errors. For example, if you wrap Para elements in a Section element that requires a Head element, you'll need to insert the Head element.

**Wrap an element using the Element Catalog**

1. Select the contents you want to wrap in an element. If you’re selecting text, use the document window. If you’re selecting entire elements, use the Structure View.
2. Select an element tag in the Element Catalog, and click Wrap.
3. If the Attributes For New Element dialog box appears, enter attribute values for the element and click Insert Element.
This dialog box appears only if the element has attributes and if an option is set in the New Element Options dialog box to prompt for attribute values when you insert elements.

Wrap elements throughout a document
1 In the document window, wrap text ranges, system variables, and other items that are inside paragraphs. Don’t worry about errors you see in the Structure View. You’ll correct many of these errors when you wrap the lowest levels in parent elements. You can correct the other errors when you’re finished.
2 Wrap paragraphs, headings, and other paragraph-level items in their elements.
3 In the Structure View, wrap the elements you have so far in parent elements, such as Section and List.

When you wrap the first element in the document, the Structure View immediately changes to show a default invalid structure, as follows:
- A highest-level element is added with the tag NoName, unless you begin by wrapping the contents in a valid highest-level element. NoName is a placeholder for your valid highest-level element.
- All tables become structured and are given default element tags, such as TABLE and ROW.
- Objects become elements with default tags such as CROSSREF, GRAPHIC, and EQUATION.
- Footnotes become FOOTNOTE.
- Rubi text becomes RUBI and RUBIGRP elements.

Note: Variables and markers do not become structured object elements.

You can correct the structure of the document when you’re finished wrapping elements.

If your application developer has set up a conversion table for the document, you can apply the table to wrap elements throughout the document all at one time. This is much faster than wrapping text manually.

Unwrapping the contents of elements
Unwrapping deletes an element but leaves its contents in the same place in the document. You usually unwrap elements as part of a larger editing process. For example, if you plan to convert ListItem elements into Para elements, sometimes you must unwrap the parent List element first. Then use Edit > Find/Change to convert the ListItem elements to Para elements.

Unwrapping ListItems, before and after

You sometimes must edit the document after unwrapping an element. For this example, you would change the ListItem elements to valid elements or rewrap them.

Note: You cannot unwrap an element that is a table part (such as a row or cell).

1 Select the element with the contents you want to unwrap.
2 Choose Element > Unwrap.
Move or copy elements
You can move an element to another location in a document by dragging its bubble in the Structure View. When you move or copy an element, its contents, including descendants, all move along with it. This does not affect the contents of the clipboard.

If you’re moving an element that has many descendants, collapse the element first.

You can also move or copy an element by cutting or copying it to the clipboard and pasting, even across documents. If you paste an element from another document, sometimes the element is not defined in your document. If you don’t plan to add a definition for the element, change the element to a valid one. You cannot cut and paste elements in a book file.

❖ Do one of the following:
  • To move an element, drag the bubble to the location you want.
  • To copy an element, hold down Alt and drag the bubble to the location.

As you drag the bubble to copy, the pointer changes to a hollow, stacked up-and-down arrowhead, and a horizontal arrow moves to indicate where the copy goes if you release the mouse button.

As you drag the bubble to move, the pointer changes to a solid up-and-down arrowhead, and an arrow moves to indicate where the bubble goes if you release the mouse button.

If the element is valid in the location where the arrow points, a check mark or question mark appears in the bubble.

Nudge an element one place
❖ Drag the element’s bubble slightly to one side or up or down. As you drag a small distance, the pointer changes to a single arrow. (If you drag too far, the arrow changes to an up-and-down arrowhead.)

When you release, the element moves one place in the indicated direction, as follows:
  • Moving an element up places it right above the sibling right before it. Moving an element down places it below the sibling after it.
  • Moving an element to the left makes it a sibling of its parent. Moving an element to the right makes it a child of the sibling before it.

Hierarchical element insert
Using the Elements quick catalog, you can select and insert multiple levels of elements. When you select an element in the quick catalog, FrameMaker XML Author displays the elements available within the selected element.

Hit Enter and use the pointer or the arrow keys (or the pointer) to select a hierarchy of elements that you want to insert. When you hit Enter, if there is only one valid element at the pointer’s position, FrameMaker XML Author inserts the element.
Use the following keys to navigate through the hierarchy of elements in quick catalogs:

<table>
<thead>
<tr>
<th>Key/Key action</th>
<th>Type of navigation/action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Place cursor in an element and hit Enter</td>
<td>Display the quick catalog</td>
</tr>
<tr>
<td>Right arrow</td>
<td>Display the elements available within the selected element</td>
</tr>
<tr>
<td>Left arrow</td>
<td>Hide one level hierarchy of elements</td>
</tr>
<tr>
<td>tab</td>
<td>scroll down</td>
</tr>
<tr>
<td>shift+tab</td>
<td>scroll up</td>
</tr>
<tr>
<td>Alphabets/combination of alphabets</td>
<td>Type an alphabet or combination of alphabets to select an element. For example, press B to select Body and Type T,O to go to Topic.</td>
</tr>
</tbody>
</table>

The list of elements in the quick catalog appears according to the settings in the Set Available Elements dialog. If Show Element Descriptive Tags is selected, the element tool tips in the catalog display the element descriptions.

Hierarchical element insert takes care of auto insertions for the last selected element in the hierarchy, as specified in the EDD. If there are auto insertion rules in place for elements apart from the last element, they are ignored.

Select and edit text

Select text in flow

❖ To select all the text in a flow, click in the flow and choose Edit > Select All In Flow.
Select text in structured document window
You can select entire elements and any part of the document contents in a document window. A corresponding
selection also appears in the Structure View.

If an element has contents, you can select all or part of the contents without selecting the element itself. If an element
consists of a single object, such as a graphic or a cross-reference, select the entire element.

When you select an entire element, its contents are selected along with it.

To select text in an element, do one of the following:
• To select text without selecting the whole element, drag through the range of text. Be careful not to drag across
an element boundary. If you do, you select the entire element.
• To select one element, drag from anywhere inside the element to outside one of its element boundaries.
• To select more than one elements, drag through the elements. FrameMaker XML Author selects each element
as you drag across one of its boundaries.

Select element content in Structure View
You can select entire elements or the element contents in the Structure View. A corresponding selection also appears
in the document window.

If an element has contents, you can select all of the contents without selecting the element itself. If an element is a single
object, such as a graphic or a cross-reference, you select the entire element. (Elements that are allowed contents have
round-cornered bubbles; elements that are a single object have square-cornered bubbles.)

When you select an entire element, its contents are selected along with it.

To select element content, do one of the following
• To select an element, click the middle of its bubble.
• To select more than one element, click the first bubble and then Shift-click the other bubbles. You can also drag
to the right of the vertical line connecting the elements. Start above the first element you want to select, and drag
down to the last element you want to select.
• To select contents of an element without descendants but not select the entire element, double-click the text
snippet.
• To select the contents of an element with descendants but not select the entire element, double-click to the right
of the vertical line connecting the first level of descendants.

Remove elements
You can remove any element, with or without its contents. For example, you sometimes want to delete a Section
element and its contents, or delete the Section but leave the contents in place, so you can place them in a different
element.

For elements that are defined to contain text or other elements, you can also delete the contents and leave the empty
element in the document. For elements that are single objects without contents, you must delete the entire element.
• To remove an element and its contents, select the element and press Delete.
• To remove an element but not its content, select the element and choose Element > Unwrap. FrameMaker XML Author reformats the contents based on the new context, if necessary.

• To remove the contents of an element but not the element itself, select the contents and press Delete.

• To remove an element and its contents and replace it with another element, select the element. Then select the replacement element in the Element Catalog, and click Insert. A new empty element replaces the selected element and its contents.

• To remove all elements from a document to base it on paragraph and character formats, choose Special > Remove Structure From Flow. If the document has additional structured flows, repeat this command for each flow.

FrameMaker XML Author removes all elements from the current text flow. If the formatting was created or modified by format change lists in the element catalog, the removed elements become format overrides in the document.

Note: To create named formats for each removed element variation and save them in the catalog, use the Create And Apply Formats command.

Assign attribute values

Attributes store supplementary information about an element that does not appear with the contents of the document. You can see attributes and their values in the Structure View.

An attribute’s definition specifies the type of values that are acceptable (such as text or numeric) and sometimes includes a list of possible values or a numeric range.

The definition also determines whether the value is optional, required, or read only. It sometimes provides a default value. You can assign values to an attribute if the attribute is not read only.

If an attribute’s current value does not conform to the specifications in its definition, the attribute is invalid.

Note: FrameMaker XML Author can provide the values for ID and ID Reference attributes used in cross-referencing. (These attributes are often defined to be read only.)

Enter attribute values as you insert elements

You enter some attribute values as you insert elements, particularly for required attributes and attributes that affect formatting. Optional attributes can perhaps wait for a later pass.

Some font property values used in an element definition document (EDD) require that you use specific units. For example, if the Offset Horizontal value is set as a percentage of an em space, typing 5pt creates an offset of 5 em spaces instead of 5 points.

Do not use multibyte (Asian-language) characters when entering attribute values. Sometimes these characters are not exported to SGML correctly because multibyte characters are not supported in the SGML workflow.
**Note:** Attribute names support the Unicode text-encoding standard.

1. Make sure you are prompted for attribute values when you insert elements.

2. Insert the element. If attributes are defined for the element, the Attributes For New Element dialog box appears, listing all the attributes (except read-only ones) defined for the element.

3. For each attribute value to provide, select the attribute in the Attribute Name scroll list, enter the value in the Attribute Value box, and click Set Value. If an attribute is required, you must enter a value for the element to be valid.

   If an attribute has a set of predefined values, choose from the Attribute Value pop-up menu rather than entering a value.

   The value you can enter, such as text or a number, is determined by the attribute’s type.

   A description of the selected attribute (its type, whether a value is required, and so on) appears in the dialog box below the Attribute Value area.

4. Click Insert Element.

**Enter or edit attribute values for elements already in a document**

To change an attribute name rather than a value, use Edit > Find/Change. Sometimes this is necessary if you imported element definitions that use different attribute names with identical meanings, such as Security instead of SecurityLevel. The new attribute name must be defined for the element.

1. Select the element with the attribute value you want to change.

   You can select more than one element of the same type, and apply the change to all. The elements must be contiguous. For example, if several Para elements in a row have a Security attribute, you can change the value of that attribute for all the Para elements at one time.

2. Double-click an attribute name or value in the Structure View to display the Attributes dialog box.

   Alternatively, access the Attributes modal panel from Elements > Edit Attributes.

3. For each attribute value to enter or edit, select the attribute in the Attribute Name scroll list, enter the value in the Attribute Value box, and click Set Value.

   If an attribute has a set of predefined values, choose from the Attribute Value pop-up menu rather than entering a value.

4. Click Done.

**Types of attributes**

An attribute’s type determines the kind of values that are allowed in the attribute. For example, the value *version 1* is not valid for an attribute defined as an integer, but the value *1* is valid. Numeric types (such as integer or real number) can also be limited to a predefined range by their attribute definition.

**Choice** An attribute with a list of predefined values.

**ID Reference** An attribute with a value that is a Unique ID value from another element. It is typically used for element-based cross-references.

**ID References** An attribute with a value of one or more Unique ID values from another element. (Sometimes the developer specifies this attribute if you’re exporting to a structured application that uses multiple values for source information.)
Integer  An attribute with a whole number value (no decimal parts). Examples of valid integers are 22, -22, and +322. An integer can be defined to fall within a range.

Integers  An attribute with a value of one or more integers. Enter each number on a separate line in the Attribute Value box.

Real  An attribute with a real number value, with or without a decimal part (the value can also be expressed in scientific notation). Examples of valid real numbers are 2, 22.4, -0.22, and 2.3e-1. A real number can be defined to fall within a range.

Reals  An attribute with a value of one or more real numbers. Enter each number on a separate line in the Attribute Value box.

String  An attribute with a value of a series of characters (text).

Strings  An attribute with a value of one or more strings. Enter each string on a separate line in the Attribute Value box.

Unique ID  An attribute with a value of a unique text string. An element can have only one ID attribute (which can be of type Unique ID or Unique IDs). All ID values must be unique in the document or book. An element with a Unique ID attribute can be the source for an element-based cross-reference.

Unique IDs  An attribute with a value of one or more unique text strings. Enter each string on a separate line in the Attribute Value box. (Sometimes the developer specifies this attribute if you’re exporting to a structured application that uses multiple values for source information.)

Copy attribute values

You can use the clipboard to copy and paste attribute values from one element to another. If you paste values to an element that does not have corresponding attributes defined, the attributes are invalid. To preserve element-based cross-references, an ID attribute value is not pasted.

If you copy an attribute from another document, the attribute sometimes is not defined in the current document.

1  Select the element with the attribute values you want to copy, and choose Edit > Copy Special > Attribute Values. All attribute values associated with the element are copied to the clipboard.

2  Select a different element and choose Edit > Paste.

3  (Optional) To delete an undefined attribute copied from another document, select the element with the undefined attribute, open the Attributes dialog box, select the attribute, and click Delete Attribute. In the next dialog box that appears, remove the attribute for the current element or for all elements that have the attribute.

Find and edit elements and attributes

You search for elements and attributes in a structured document to keep track of them or to make changes to them quickly. Searching is especially useful when you want to apply the same change to more than one occurrence of an element or attribute.

You can also search for many other items in FrameMaker XML Author, including strings of text, specific formatting, unresolved cross-references, and objects (such as anchored frames) that are not elements.

Note: The Find/Change feature supports the Unicode text-encoding standard.

More Help topics

“Regular Expression” on page 304
Search for element tags, attribute names, or attribute values

You can search for an element tag, attribute name, and attribute value either separately or in combination. For example, you can search for an element tagged List to find each List element, or perhaps you limit the search to find only List elements that have a Security attribute set to Classified.

1 Choose Edit > Find/Change.

2 Choose Element from the Find pop-up menu.

3 Select the options you want in the Find Element dialog box.

   The settings can be used in many combinations. These are a few examples:

   • To find any element, leave all three boxes empty.

   • To find a specific element, type an element tag but leave the Attribute Name and Attribute Value boxes empty.

   • To find any element with a specific attribute, type an attribute name but leave the Element Tag and Attribute Value boxes empty.

   • To find any element with a specific attribute value, type an attribute value but leave the Element Tag and Attribute Name boxes empty.

   • To find a specific combination of element and attribute, type an element tag and choose an attribute name.

   • To find a specific combination of element and attribute value, type an element tag and choose an attribute name and an attribute value. (If the attribute type is Choice, type the value.)

   • To find a specific element with an attribute that has no value, type an element tag, choose an attribute name, and choose <No Value> from the Attribute Value pop-up menu.

   Leave a box empty if you do not want to restrict the search. An empty box has the same effect as searching for any element, or choosing either <Any Attribute> or <Any Value>.

4 Click Set.

5 In the Find/Change dialog box, select Consider Case, Whole Word, Use Wildcards, or Find Backward.

6 Click Find.

   Note: After searching the main flow, FrameMaker XML Author looks at other text frames and text lines. Because a search is flow by flow, it sometimes appears to jump around the document.

More Help topics

“Regular Expression” on page 304

Change elements or attributes you find

After you find an element, attribute, or attribute value, you can change it to another element, attribute, or value. For example, you can quickly and globally change the value of a SecurityLevel attribute from Declassified to Top Secret.

When changing items in a document, you can change each occurrence of the item as it is found or have FrameMaker XML Author automatically make the change throughout the document.

   After pasting material from another document or importing new element definitions, use the Find/Change command to clean up your document. You can use Find/Change to change CELL elements, for example, to TableCell elements.

1 Choose Edit > Find/Change.

2 In the Find/Change dialog box, choose Element from the Find pop-up menu.
3 Select the options you want in the Find Element dialog box, and click Set. Then choose an option from the Change pop-up menu in the Find/Change dialog box, and type the replacement tag or value.

The Find Element dialog box and the Change pop-up menu work together. These are a few examples of combinations you can use:

- To change one element to another, type an element tag in the Find Element dialog box but leave Attribute Name and Attribute Value empty. Then choose Element Tag To in the Change pop-up menu and type an element tag.
- To change one attribute to another, type an attribute name but leave Element Tag and Attribute Value empty. Then choose Attribute Name To and type an attribute name that is defined for this element.
- To change one attribute value to another, type an attribute value but leave Attribute Name and Attribute Value empty. Then choose Attribute Value To and type a value.
- To change an attribute with a specific name to a certain value, type an attribute name but leave Element Tag and Attribute Value empty. Then choose Attribute Value To and type a value.
- To change a specific element with a specific attribute value to another element, type an element tag and choose an attribute name and attribute value. Then choose Element Tag To in the Change pop-up menu and type an element tag.
- To remove an attribute value, type an attribute value but leave Element Tag and Attribute Name empty. Then choose Attribute Value To and leave the Choose box empty.

If you try to make a change that is not allowed—for example, if you try to remove an element tag—an alert message appears explaining the problem.

4 Click Find.

5 When FrameMaker XML Author finds the element or attribute, do one of the following:

- To make the change but not continue searching for other occurrences of the item, click Change.
- To make the change and continue searching for other occurrences, click Change & Find.
- To change all occurrences of the item, specify all occurrences in the document or only occurrences in the current selection and click Change All.

**Find and correct errors in document structure**

An error in a structured flow can be a structure problem, such as an element in an invalid location, or an invalid attribute, such as an attribute with a missing required value. In Structure View, when a collapsed element has invalid content in its structure, the plus sign on the left of the element name is red.

You can also validate a document to find errors. After you know where the errors are located, use the Element Catalog and the Structure View as guides to help you correct them.

If you’ve made any formatting changes to text in elements, the elements perhaps do not conform to their format rules.

**Use the Structure View to find errors**

When an element doesn’t conform to content rules and attribute descriptions in the document’s element definitions, the Structure View identifies the error for you.

**Missing elements** If an element is missing one or more child elements required by the element definitions, a small red hole appears on the vertical line where the child element should be.
At least one required child element is missing.

**Elements at an invalid location** If an element is at a location not allowed by the content rules, the vertical line next to it is broken from the position of that element to the end of the parent element.

The Para element is invalid at this location.

**Undefined elements** If an element is not defined for the document, its bubble is red. This sometimes happens if you have pasted the element from another document.

**Invalid attributes** If an attribute has an invalid value or is not defined for the document, it appears with a red x to the left of the attribute name and its value is red.

The DraftVersion attribute is invalid.

**Attributes missing a required value** If an attribute does not have a value, \(<no value>\) appears to the right of the attribute name. If the attribute requires a value, \(<no value>\) is red and a red hole appears to the left of it.

The XRefLabel attribute is missing a required value.

**Validate a document**

When FrameMaker XML Author validates a document, it searches for elements that do not conform to content and attribute rules in the document’s element definitions. If FrameMaker XML Author finds an error, it selects the element and describes the error.

You can validate an entire document, the current flow, or the current element. If you validate the current element, FrameMaker XML Author does not check the descendants of the element’s child elements. For example, if you validate the Section element below, FrameMaker XML Author makes sure that the Head element, the two Para elements, and the List element are valid, but does not check the List Item elements in List.
If the document has conditional text, only the versions that are showing are validated.

You can also validate an entire book including all its files, only the book file, or only the current element in the book file.

1 Choose Element > Validate.

2 Select Entire Document, Entire Book, Current Flow, or Current Element to specify the scope of the validation.

3 To exclude missing elements or attribute values from the search, select Ignore Missing Elements or Ignore Missing Attribute Values.

   If these settings are selected, FrameMaker XML Author does not look for places where a required child element or a required attribute value is missing. Consider selecting these if you are not trying to build a complete document yet.

4 Click Start Validating.

   FrameMaker XML Author starts checking at the beginning of the current element. If you’re validating only the current element, it checks the element with the insertion point or the selected element. If more than one element is selected, it checks the first element in the selection.

5 If FrameMaker XML Author finds an error, click Start Validating again when you’re ready to continue validating.

   The top of the Element Validation dialog box shows the tag of the element and a brief message about the problem.

   You can correct the error, ignore it, or click Allow As Special Case. If you mark it as a special case, FrameMaker XML Author won’t identify the error the next time you validate the document.

6 Repeat step 5 until FrameMaker XML Author does not find any more errors.

When FrameMaker XML Author reaches the end of the document, it returns to the beginning and continues validating. When FrameMaker XML Author reaches the end of a flow, it continues to the next one.

**Note:** When validating a book, FrameMaker XML Author tells you if a file in the book has invalid content, but for a more detailed evaluation, you must open and validate the file.

Validation of the elements in an EDD includes attributes in if-then clauses. For example, suppose that the possible values of an attribute are A or B or C, and a context rule says if [attrval = "D"]. This is flagged as an error and reported as an invalid structure when the element definitions are imported.

Similarly, if an element’s text formatting rules or prefix/suffix rules use attribute names in the context specifications, the attribute name and case must match the attribute definition in the element’s definition.

If an attribute’s value is changed to the same value it previously had, the action is not flagged as a change. This enhances performance by eliminating unnecessary value checking.

**Clear all special cases**

1 Choose Element > Validate.
2 Click Clear Special Cases. FrameMaker XML Author clears the special cases in the document, the flow, or the element—whichever scope is selected in the dialog box.

Validation error messages

The following error messages can appear at the top of the Element Validation dialog box. (In the descriptions, tag represents an element tag, name represents an attribute name, and value represents an attribute value.)

Element is undefined  The element is not defined in the document. You perhaps copied this element from another document.

Missing element before tag  At least one required element is missing before the specified element.

More contents required at end  At least one more child element is required at the end of the current element.

No current element  There is no insertion point or selection. (This message appears when the scope is set to Current Element.)

No current flow  There is no insertion point or selection. (This message appears when the scope is set to Current Flow.)

Not highest-level element  The element is not permitted at the highest level in the document.

<TEXT> not permitted in this element  The element contains text, but text is not allowed.

<TEXT> not valid at this position  The element is allowed to have text but not at this location.

The name attribute refers to an undefined ID value  The attribute is an ID Reference and refers to a Unique ID value that doesn’t exist in the document (or in the book, if you’re validating a book).

The name attribute is undefined for this element  The definition of this element does not include a name attribute.

This element should be a type  The element is the wrong type, where type can be graphic, marker, cross-reference, equation, or system variable. For example, a cross-reference element sometimes consists of text instead of a cross-reference.

Value must be a type for name attribute  The attribute value is the wrong type for the attribute.

Value for name attribute must be in the range from n to n  The attribute’s numeric value is out of the specified range.

Value for name attribute is not one of the allowed choices  The attribute’s value must match a value from the pop-up menu of valid choices.

Value for name attribute must be unique  A Unique ID value must be unique for all elements in the document or book.

Value required for name attribute  The attribute does not have a required value.

tag excluded in this element  The tag element is not allowed because of an exclusion rule for the parent or one of its ancestors.

tag not permitted in this element  The tag element is not allowed anywhere in the parent element.

tag not valid at this position  The tag element is allowed in the parent element but not at the current location.

Correct errors in elements

After you have identified errors in elements and attributes, use the Element Catalog and Structure View as guides for correcting them:

• To correct an element in an invalid location, move the element to a valid location, or change it to an element that is valid for its current location.

You can select an invalid element, or if you’re validating, FrameMaker XML Author selects the element for you. When the element is selected, the Element Catalog shows which elements are valid at that location.
To correct an element with invalid contents (with the text snippet <INVALID CONTENT>), change it to an element that allows those contents.

To correct a structure with a missing child element, insert the required element.

You can click where an element is missing, or if you’re validating, FrameMaker XML Author places the insertion point there for you. When the insertion point is at the location of the missing element, the Element Catalog shows which elements are valid at that location.

To correct an invalid attribute value, change the value to one that is valid for the attribute.

To remove an undefined attribute, select the element with the undefined attribute, open the Attributes dialog box, select the attribute, and click Delete Attribute. In the next dialog box that appears, remove the attribute for the current element or for all elements that have the attribute.

To resolve a cross-reference with an invalid ID, select the cross-reference, choose Special > Cross-Reference, and change to a source that has a valid ID.

Search for items

Searching documents and books

If you are searching in a document (Edit > Find/Change), FrameMaker XML Author begins searching at the insertion point and continues through the document. It searches only pages of the type the insertion point is on—for example, only body, master, or reference pages. When FrameMaker XML Author reaches the end of the document, it continues the search at the beginning. After searching the main text flow, it searches other text in the document. Because FrameMaker XML Author searches flow by flow rather than page by page, it sometimes appears to jump around within the document while searching.
If you are searching throughout a book, FrameMaker XML Author begins searching from the active document, or from the first document of the book if the book window is active, and continues searching until all documents in the book have been searched. If a document cannot be opened, the document is skipped and a message appears in the Book Error Log.

**Note:** When you are searching through a book, bookmark, or DITA map, you cannot search the master or reference pages.

In addition to text, you can search for any of the following items in a selection, in a document, or throughout an entire book. You can also search in a map from the Resource Manager view.

**Text formats and tags**  Character format properties, or specific paragraph or character tags. In structured FrameMaker XML Author, Element appears right after text, so you can search for element tag, attribute name, attribute value, or simultaneously for all three.

**Markers**  Any markers, regardless of their marker types, markers of a specific type, or markers that contain specified text.

**Cross-references**  Any cross-references, regardless of their formats, cross-references that use a specific format, or unresolved cross-references—cross-references that FrameMaker XML Author is unable to update. When an unresolved cross-reference is found, the marker text of the cross-reference appears in the Find box.

**Text insets**  Any text imported by reference. You can also search for unresolved text insets—insets that cannot be updated from their sources. However, you can’t search for graphics subscribers or OLE linked objects. (To list OLE links, choose Edit > Links.)

**Variables**  Any variables, regardless of their variable names, or specific variables.

**Rubi**  Any rubi text, when Japanese fonts are installed on your system.

**Anchored frames**  Frame that contains graphics and helps you locate them. Graphics placed in non-anchored frames are not found.

**Footnotes**  Any text or table footnotes.

**Tables**  Any tables regardless of their table format tags, or tables with a specific tag.

**Conditional text**  Any conditional text, regardless of its condition tags, text with specific condition tags, or unconditional text. FrameMaker XML Author cannot find conditional table rows or hidden conditional text.

**Automatic hyphen**  Words that are hyphenated automatically.

**Text and character format on the clipboard**  Text that matches the clipboard text, capitalization, and character formatting.

**More Help topics**

“Regular Expression” on page 304

**Searching for Unicode text**

FrameMaker XML Author uses the UTF-8 encoding format. Therefore, every character in a .fm or XML document containing Unicode-encoded text uses multiple bytes. As a result, only the string entered in the Find field is used to perform the search operation.

Searching in a range is applicable only to Unicode characters, and users can search for any character that belongs to the Basic Multilingual Plane (BMP). Unicode code points can also be used for performing search and replace operations. For example, you can provide \uXXXX as the input to locate a character that has code point XXXX. Thus, to search for letter “A” whose code point is u+0041, you can specify \u0041 in the Find/Change dialog box.
A code point is any value in the Unicode codespace, which is a range of integers from 0 to \(10FFFF_{16}\). This particular range is defined for the codespace in the Unicode standard only. Other character-encoding standards sometimes use other codespaces.

You can also use wildcard characters while searching for Unicode text.

*Note:* In Asian documents with multibyte characters, the bracket characters `[ ]` do not work as wildcards.

**More Help topics**

“Regular Expression” on page 304

**Replacing items**

When changing items, keep the following in mind:

- If you choose Change or Change & Find when no text is selected in the document, FrameMaker XML Author inserts or applies the replacement item at the insertion point.
- The Clone Case option in the Find/Change dialog box maintains the capitalization in the source text. For example, if you select Clone Case and type *tea* in the Find box and *coffee* in the Change box, FrameMaker XML Author replaces *tea* with *coffee* and *Tea* with *Coffee*.
- You can type any text, including special characters not found on the keyboard—for example, em spaces and paragraph symbols.
- You can’t change marker text by using the Find/Change dialog box. If FrameMaker XML Author finds the marker text you specify, and if you type different text in the Change box and click Change, FrameMaker XML Author replaces the marker—not the marker text—with the text in the Change box. To change marker text, use the Special > Marker command.

**Search for backslashes and wildcard characters**

You can enter any characters in the Find/Change box. However, the following characters require special treatment:

- For backslashes, specify two backslashes (\) in the box. A single backslash usually indicates a special character.
- For wildcard characters used as ordinary characters, when the Use Wildcards option is selected, precede the wildcard character with a backslash in the box.

**More Help topics**

“Typing in dialog boxes” on page 376

“Regular Expression” on page 304

**Search for character format properties**

1. Copy the text with the character format you want to find. FrameMaker XML Author uses only the first 126 characters copied into the clipboard.
2. Select Edit > Find/Change. In the Find/Change dialog box, choose Text & Character Formats In Clipboard from the Find pop-up menu. Don’t type the text you want to find in the Find box.
3. Click Find.

To prevent FrameMaker XML Author from applying a property to found text, set the property to As Is.
After making some changes in the Change To Character Format dialog box, you can reset the dialog box to match the format of the current text by pressing Ctrl+Shift+F9.

Search for special characters and nonprinting symbols

You can search for any text, including single characters, phrases, and special characters that aren’t on your keyboard. You’ll need to type the backslash sequence.

For example, you could find empty paragraphs by searching for \P\p (beginning of paragraph followed by end of paragraph).

You can use most of these sequences for both searching and replacing—for example, replacing a forced return symbol with an end-of-paragraph symbol. However, you cannot replace with the end-of-flow, start-of-paragraph, start-of-word, or end-of-word sequence.

More Help topics
“Typing in dialog boxes” on page 376

Search for markers

FrameMaker XML Author uses markers for cross-references, indexes, and other purposes. It can find any type of marker or just the marker type you specify. When text symbols are visible, a symbol \T indicates a marker.

FrameMaker XML Author can also find markers with specific marker text.

1 In the Find/Change dialog box, do one of the following:
   • To find any marker in the document, choose Any Marker from the Find pop-up menu, and leave the Find box blank.
   • To find a specific type of marker, choose Marker Of Type from the Find pop-up menu, and enter the marker type in the Find box.
   • To find a marker with specific text, choose Marker Text from the Find pop-up menu, and enter the marker text in the Find box.

2 Click Find. If the Marker dialog box is open (Special > Marker), the marker text for the found marker appears there.

Important: If you want to replace the text in a found marker, use the Marker dialog box to edit the marker text. If you use the Find/Change dialog box, you’ll replace the marker rather than the marker text.

Search for conditional text

You can search for visible text that has specific condition tags. When FrameMaker XML Author finds visible conditional text, it selects all adjacent text that uses these condition tags.

FrameMaker XML Author cannot find conditional table rows.

1 Make sure that the text with the condition tags you want to find is visible.

2 In the Find/Change dialog box, choose Conditional Text from the Find pop-up menu.

3 Do the following:
   • To find text with a particular condition tag, move the condition tag to the In list.
   • To find text that doesn’t have a particular condition tag, move the tag to the Not In scroll list.
   • If you don’t care whether found text has a particular tag, move the tag to the As Is scroll list.
To find all conditional text, move all tags to the As Is scroll list.

To find unconditional text, select Unconditional.

Note: To move a condition tag between scroll lists, select the tag and click an arrow, or double-click the tag. To move all tags from one scroll list to another, select a tag in the list and Shift-click an arrow.

4 Click Set, and then click Find.

Regular expression search and replace

You can use regular expressions in the WYSIWYG view of structured to search for and replace (substitute) text-based items in a document. This means that you can use regular expressions to search for text, marker text, or paragraph tag. However, this search and replace option is disabled for items such as markers and cross references.

To perform a regular expression search

Use a regular expression to search for dates with the dd-mm-yyyy format in a document.

1 Open the Find / Change dialog.

2 Enter the following regular expression in the Find box:

```
[\d]{2}-[\d]{2}-[\d]{4}
```

3 Choose the Regular Expressions find option and click Find.

To perform a regular expression search and replace

Use a regular expression to search for dates with the dd-mm-yyyy format in a document and replace (substitute) dates found in this format to mm-dd-yyyy

1 Open the Find / Change dialog.

2 Enter the following regular expression in the Find box:

```
(\[\d]{2}\) - (\[\d]{2}\) - (\[\d]{4}\)
```

Note: The date, month, year parts of the regular expression are enclosed in parenthesis. This ensures that the regular expression engine remembers these values for each search result.

3 Choose the Regular Expressions find option.

Next, you need to use the regular expression substitution syntax to replace only the parts that you enclosed in parenthesis.

4 In the Change box, enter the following substitution:

```
$2-$1-$3
```

$2 is the second (month) enclosed part. $1 is the first (date) enclosed part. So when using the substitution syntax, you interchange the $1 and $2 results from the search.

Configuring the regular expression engine in FrameMaker XML Author

FrameMaker XML Author uses the boost engine for Regex. For more information on Boost, see boost.org.

You can write the regular expressions using the following syntax:

- Perl (default)
- Grep
- Ergrep
By default, you use the Perl regular expression syntax to write regular expressions in FrameMaker XML Author. However, to use either the Grep or Ergrep regular expression syntax, you need to update the RegularExpressionSyntax flag in the maker.ini

Troubleshoot a search

If you don’t find the item even though you’re sure it is there, check the Find/Change dialog box for the following possible problems:

• Text spelling.
• Number and type of spaces.
• Search options.
• Hidden conditional text.
• Insertion point on master page when searching a master page.
• Selection of Book option when searching entire book.

Check spelling

FrameMaker XML Author dictionaries

FrameMaker XML Author automatically creates a personal dictionary for you and a document dictionary for each of your documents. You can use either the Spelling Checker or Auto Spell Check options, to add or delete words in these dictionaries, or you can manage the dictionaries directly. When you work with a dictionary directly, you can examine and edit its contents or merge it with another dictionary. You can create multiple personal dictionaries and then use them one at a time.

If you make changes either to a personal or to a document dictionary, mark all paragraphs for rechecking before you spell-check the document again.

You perform many of the following tasks in the Dictionary Functions dialog box.

About FrameMaker XML Author dictionaries

The FrameMaker XML Author Spelling Checker uses several dictionaries to check text for spelling errors. When you spell-check a document, FrameMaker XML Author compares each word in it with the words in the following dictionaries:

• The main dictionary contains words found in a standard dictionary. You can’t add words to or delete words from this dictionary.
• The default site dictionary contains some technical terms. You can add words common to your site or workgroup—for example, the company name and product names. The site dictionary is normally in the site.dict file in the FrameMaker XML Author dict folder.
• Your personal dictionary contains words you use often. Because FrameMaker XML Author uses this dictionary whenever you spell-check any document, use this dictionary for words that are neither document-specific nor site-specific (for example, your name). You can add or delete words. You can also create several personal dictionaries and switch between them.
The document dictionary contains words that are acceptable in a particular document. FrameMaker XML Author uses this dictionary regardless of who is editing the document. You can add words to or delete words from it. Unlike the other dictionaries, the document dictionary is part of the document rather than a separate file.

You have editorial control over your document, personal, and site dictionaries. You can choose different dictionaries, merge one dictionary into another, and edit and delete dictionaries.

Dictionaries for other languages
In FrameMaker XML Author, the dictionaries, hyphenation, and Thesaurus are Unicode enabled.

FrameMaker XML Author provides dictionary and hyphenation support for the following languages: Bulgarian, Catalan, Croatian, Czech, Danish, Dutch, Estonian, Finnish, Greek, Hungarian, Italian, Latvian, Lithuanian, Norwegian, Nynorsk, Polish, Portuguese, Romanian, Russian, Slovak, Slovenian, Spanish, Swedish, and Turkish.

Note: By default, dictionaries of all languages supported in FrameMaker XML Author are installed.

FrameMaker XML Author provides full authoring support (without dictionaries and hyphenation) for Japanese, Korean, Traditional Chinese, and Simplified Chinese.

In addition, full authoring support (including language rules, dictionary, hyphenation, and thesaurus) is extended for US English, French, Danish, Dutch, German, Italian, Norwegian, Swedish, Swiss German, Canadian French, and British English.

Choose Dictionary Functions dialog box
1. Make the appropriate document window or book window active.
2. Choose Edit > Spelling Checker.
3. Click Dictionaries.

Delete the contents of the document dictionary
❖ Choose Clear from the Document Dictionary pop-up menu and click OK.

Locate a personal dictionary
❖ To find the name of the personal dictionary, choose Edit > Spelling Checker, and then click Dictionaries.

Import dictionary entries
1. Select Edit > Spelling Checker and click Dictionaries.
2. Select Import Dictionary from the Personal Dictionary pop-up menu and click OK.
3. Locate or specify the name of the file that contains the personal dictionary you want to use and click Use.

Check the spelling of a document without using the personal dictionary
❖ Choose Set To None from the Personal Dictionary pop-up menu and click OK.

Copy the contents of a dictionary to a file
1. Choose Write To File from the Personal Dictionary or Document Dictionary pop-up menu and click OK.
2. Specify the file to which you want to copy the dictionary contents. You can edit this file and then use it as a new dictionary.

If a book window is active when you choose this command, the document dictionaries are copied to a single file.
**Merge the contents of a dictionary with the current personal or document dictionary**

1. Choose Merge From File from the Personal Dictionary or Document Dictionary pop-up menu and click OK.
2. Specify the file you want to merge with the current dictionary.

*You can use the Merge From File command to merge a single dictionary into multiple book files so that all the files in your book share the same dictionary.*

**Create another personal dictionary**

1. Place words, with a hyphen at each hyphenation point, in a document. Type as the first line in the document:
   `<MakerDictionary 3.0>`
2. When you save the file, choose Text Only format and click Save. Then click Only Between Paragraphs and click Save.

**Change site dictionaries**

You can specify a different site dictionary for each of several projects. You can also edit your site dictionary directly.

If FrameMaker XML Author is used across a network at your site, a system administrator probably manages the site dictionary.

- Specify the dictionary in the maker.ini file.

*Note:* Use caution when editing an ini file.

**Edit dictionary files**

1. If you’re editing a personal or document dictionary, use FrameMaker XML Author to write the dictionary contents to a file.
2. Edit the file. If you use FrameMaker XML Author to edit a dictionary, be sure to do the following:
   - When you open the file, select Treat Each Line As A Paragraph in the Reading Text File dialog box and click Read.
   - When you save the file, choose Text Only format and click Save. Then click Only Between Paragraphs and click Save.
3. Merge the dictionary file with another dictionary. If you removed words from the dictionary, delete the original dictionary before merging the file. Otherwise, the deleted words remain in the dictionary.

**Add unknown words to a dictionary**

If your document contains many correctly spelled words that FrameMaker XML Author questions, expedite spell-checking by adding the words to a dictionary in a separate operation before you begin to spell-check.

1. Make the appropriate document window or book window active.
2. Choose Edit > Spelling Checker.
3. Click Dictionaries.
4. Click Write All Unknown Words To File and click OK.
5. Specify a filename for the dictionary file, and click OK or Save. The resulting dictionary file doesn’t include typing errors such as repeated words, capitalization errors, or extra spaces.
6. Edit the dictionary file with a text editor or with FrameMaker XML Author. Delete any words you don’t want to add to your dictionary, such as misspelled words.
7. In the Spelling Checker dialog box, click Dictionaries.
8 Choose Merge From File from the Personal Dictionary or Document Dictionary pop-up menu, and click OK. If you expect the words to appear in several documents, merge the words with a personal dictionary, or merge them into all the files in a book.

9 Name and save the dictionary file.

Note: To add a few words to a dictionary, you can select Learn Word from right click menu. Above method is help if you have many words highlighted by red squiggly line.

Add hyphenated compound words to personal dictionary
A document sometimes contains hyphenated compound words. By default, FrameMaker XML Author spell-checks each word in a hyphenated compound word rather than checking the hyphenated compound word as a whole. For example, when spell-checking the word heavy-duty, FrameMaker XML Author checks heavy and then checks duty. By changing the default settings, you can spell-check hyphenated compound words as single words, and you can add hyphenated compound words to your personal dictionary.

1 Choose Edit > Spelling Checker and click Options.
2 Select Unusual Hyphenation and click Set.
3 In the Word box in the Spelling Checker dialog box, enter the hyphenated compound word you want to add to your personal dictionary. Include a hyphen at the beginning of the compound word, and type a backslash (\) before each hyphen that connects words.

   For example, to add the word heavy-duty, type -heavy\-duty.

4 Click Learn.

Spelling and typing errors
When correcting errors, keep in mind the following:

- If FrameMaker XML Author questions something that you don’t consider to be a typing error, you can turn off the option to find that type of potential error. For example, you can stop FrameMaker XML Author from questioning the use of straight quotation marks.
- If FrameMaker XML Author adds a word that contains uppercase letters to a personal or document dictionary, when Unusual Capitalization is selected in the Spelling Checker Options dialog box, it considers any other capitalization of the word a spelling mistake. For example, if FrameMaker XML Author learns Trinidad, it questions the spelling of trinidad. However, if it learns trinidad, in all lowercase letters, it does not question any type of capitalization of the word.
- FrameMaker XML Author does not spell-check superscript and subscript text or manually micropositioned text, such as text with a manual baseline shift).
- To correct a typing error (for example, repeated words such as and and), make sure that the correctly typed text is in the Correction box and click Correct. FrameMaker XML Author lists only one suggestion for mistyped text. If the suggestion is not correct, you can enter the correct text in the Correction box, or type it directly in the document window.

Spell-check a document, book, or map
The Spelling Checker checks for repeated words, unusual hyphenation or capitalization, punctuation errors, straight quotation marks (when curved must be used), and extra spaces. You can spell-check the current page, the open document, the entire book, bookmark or DITA map, or selected files within the book. However, the spell check only checks on pages of the type you are viewing, for example, master pages or body pages.

Last updated 8/18/2015
FrameMaker XML Author begins spell-checking from the active document or from the first document of the book if the book window is active. It continues spell-checking until all documents in the book have been checked. If a document cannot be opened, the document is skipped and a message appears in the Book Error Log. When spell-checking throughout a book, you cannot spell-check master or reference pages.

An alert message prompts you to save the document before continuing with the next document. When the last document in the book has been checked, a **Spelling OK** or **Finished checking spelling** message appears.

To check the spelling in specific documents of a book or map, you can select them in the resource manager view, and then choose Selection to spell-check only those files, books, or maps if you decide to spell-check the entire book or map.

FrameMaker XML Author draws a red squiggly line under words, to indicate spelling mistakes—words not present in the dictionary. A green squiggly line under the word indicates a punctuation mistake. To correct, right click on a highlighted word and select the desired option.

**Note:** For the words highlighted in green, the options to add to dictionary are not applicable, and hence are not available.

In FrameMaker XML Author, Auto Spell Check feature is enabled by default. If for some reason you disabled it, you can enable it again by going to File > Preferences > General. This option spell checks the open file as soon as it is turned on.

When you spell-check throughout a book or map, words added to your personal dictionary are applied to all documents. Words added to the document dictionary are used only in the current document, not in any other document in the book. When the Spelling Checker finds a questionable word, it suggests the most likely correction along with some other possibilities.

❖ In the document, choose Edit > Spelling Checker and click Start Checking.

**Note:** Auto spell check is session specific and not document specific. If the same document is opened on a different machine, settings for Auto spell checker might differ.

### Correct spelling errors automatically

You can have FrameMaker XML Author automatically correct future occurrences of a misspelled word or typing error. FrameMaker XML Author keeps track of the errors to correct automatically until you exit or until you instruct FrameMaker XML Author to stop making the corrections.

Before changing a particular misspelling or typing error automatically, verify the changes to make. If you use the Automatic Correction option when correcting a repeated word, FrameMaker XML Author corrects every repeated word even though some are correct (such as had had). Similarly, if thst is a misspelling of both test and that, you don’t want to change it automatically to either word.

1. Choose Edit > Spelling Checker and click Start Checking.
2. When FrameMaker XML Author questions a word or typing error, select and click Correct.

### Spell-check text insets

❖ Open the inset source file and check the spelling there.

### Change Spelling Checker options

When you spell-check a document, FrameMaker XML Author also checks for errors that don’t involve spelling—for example, repeated words, extra or misplaced spaces, or unusual capitalization. You can specify the kinds of typing errors to check.
You can also limit the spell-check so that FrameMaker XML Author overlooks certain types of words. For example, perhaps you want to overlook words that contain numbers.

1. Choose Edit > Spelling Checker and click Options.

2. Do the following:
   - In the Find area, specify the kinds of typing errors you want to find. For example, select Unusual Capitalization if you want to find words with uppercase letters in inappropriate locations (for example, Green).
   - In the Ignore area, specify the kinds of words you want to overlook. For example, select Words With Digits if you want to ignore words that contain numbers.

   Keep in mind that the more words FrameMaker XML Author overlooks, the greater the possibility that your document contains mistakes. For example, if you choose to ignore words containing a period, you also skip over a sentence that begins without a space after the preceding period.
   - If you change the Spelling Checker options and then want to reset the default options, click Get Defaults. If you exit FrameMaker XML Author without resetting the default options, your current settings become the default options.

3. Click Set.

**Recheck after changing Spelling Checker options**

FrameMaker XML Author ordinarily rechecks only paragraphs that have been edited since the prior check. If you change options after spell-checking a document, consider running the Spelling Checker again after instructing FrameMaker XML Author to mark all paragraphs for rechecking.

**Assign text to be ignored by Spelling Checker**

To ignore certain text, change its Language property to None. For example, perhaps you don’t want to spell-check paragraphs of computer code.

When you set the language of text to None, FrameMaker XML Author no longer provides hyphenation for it.

**Check spelling in different languages**

All text is assigned a language. When you spell-check, FrameMaker XML Author uses the main dictionary of the language assigned to the text. You can change the language used to spell-check text by changing the language assigned to the text. You can also add Unicode (UTF-8)-encoded words to user and personal dictionaries in FrameMaker XML Author.

The FrameMaker XML Author CD contains dictionaries for all supported languages. However, the default installation contains only one dictionary in a single language.

- To change the language of text in a document, use the Language property in the Default Font properties of the Paragraph Designer to change the language of one of the following:
  - A single paragraph, or all the paragraphs in a document.
  - A range of text within a paragraph, or the language of a text line.

Note the following about Asian-language documents:

- In an Asian-language document, some special characters are not displayed in the Spelling Checker as they are in a Western-language document. For example, a backslash is displayed as a yen symbol, and a nonbreaking hyphen is displayed as a blank.
• In an Asian-language document that contains Roman text, make sure that you turn off the Straight Quotes option in the Spelling Checker dialog box so that the Spelling Checker does not stop on properly spelled words.

**Control hyphenation**
When you add a word to a personal dictionary, FrameMaker XML Author suggests hyphenation points. You can change them before adding the word. You can also specify that a word is always or never hyphenated. For example, you can hyphenate *heavy duty* wherever it appears but never hyphenate your company name.

After making hyphenation changes, rehyphenate the document.

*For strict control over hyphenation (for example, before printing the final draft of a book), consider searching your document for all hyphens that FrameMaker XML Author has inserted automatically. Choose Automatic Hyphen from the Find pop-up menu in the Find/Change dialog box.*

**Change word hyphenation**
1. Show the hyphenation points of the word.
2. Adjust the hyphenation and click Learn. You can add and delete hyphens as necessary.

**Prevent FrameMaker XML Author from hyphenating a word**
1. Enter the word in the Correction box.
2. Click Show Hyphenation.
3. Remove all hyphens from the word.
4. Insert a hyphen at the beginning of the word.
5. Click Learn.

**Rehyphenate an entire document**
1. Make the appropriate document window or book window active.
2. Choose Edit > Spelling Checker.
3. Click Dictionaries.
4. Select Rehyphenate Document and click OK. This option works for an open document.
   In case of a book file, select Rehyphenate All Files In Book and then click OK.

**Use the Thesaurus**

**Look up words in the Thesaurus**
Use the Thesaurus to look up synonyms, related words, and antonyms for words you specify. The Thesaurus lets you improve on a word already in a document or search for the right word to insert.

You can look up any one of the words from the first pass and display its synonyms, related words, and antonyms. FrameMaker XML Author keeps a history of the last 10 words you looked up.

If more information is available than fits, you can use the arrow buttons at the bottom of the dialog box to view the additional information. FrameMaker XML Author displays the synonyms, antonyms, and related words with capitalization that matches the capitalization of the word you looked up.
You can look up words in the following ways:

- To look up a word visible in the document window, select the word and choose Edit > Thesaurus.
- To look up a word not visible in the document window, make sure that no text is selected, then choose Edit > Thesaurus. Enter the word and click Look Up.
- To look up a phrase, make sure that no text is selected and choose Edit > Thesaurus. Enter the phrase, including any hyphens, in the Thesaurus Look Up dialog box, and click Look Up.

**Note:** If you try to specify a phrase by selecting it in the document window, FrameMaker XML Author looks up only the first selected word.

- To look up a synonym, a related word, or an antonym displayed in the Thesaurus dialog box, click the word. Synonyms, related words, and antonyms are shown in bold.
- To look up a word again, choose the word from the Word pop-up menu in the Thesaurus dialog box.

**Choose a language for the Thesaurus**

FrameMaker XML Author uses the language of the current text. If a word isn’t selected or the insertion point isn’t in a paragraph, FrameMaker XML Author uses the language of the interface you chose when you installed FrameMaker XML Author. You can override the default language in new documents by creating your own template for custom new documents.

The Thesaurus for a language is installed along with the dictionary for that language.

**Specify a different language when looking up a word**

1. Click Look Up in the Thesaurus dialog box.
2. Enter the word you want to look up, choose a language, and click Look Up.

**Insert a word from the Thesaurus into the document**

1. Do one of the following:
   - To add the word, place an insertion point in the document.
   - To replace a word in the document, select the word.
2. Control-click the word in the Thesaurus dialog box and click Replace.

**More Help topics**

“Check spelling” on page 86

**Multiple Undo/Redo**

You can undo or redo multiple actions in FrameMaker XML Author. However some actions cannot be undone and you are prompted to confirm the action.

**Undo and Redo commands**

A Redo icon 🔄 appears in the toolbar, next to the Undo icon 🔄. Click this button to redo the most recently undone action in the current document.
A Redo command also appears in the Edit menu and in context menus, under the Undo command, showing the most recent redoable command in the current document.

![Edit menu](image)

*The Edit menu displays the last command as well as the last command that has been undone.*

If no action is available for Undo or Redo in the current document, the corresponding menu options and toolbar buttons are unavailable (dimmed).

The History command opens the command History panel, which allows you to undo or redo an action other than the most recent one, along with all of the subsequent actions.

**Document-level command history**

FrameMaker XML Author maintains a history of undoable commands, so that you can select one or more recent commands to undo or redo.

The command history is available through the Edit menu and context menus. The command history is kept separately for each document, so undoing or redoing an operation in one document does not change the undo capability of another open document.

Cursor movement and object selection actions are not undoable, but when a previous state is restored, it includes the original cursor location and object selection state.

Commands that affect an external file (such as Spelling Checker commands that update the user dictionary) cannot be undone.

**Repeat Last Operation**

FrameMaker XML Author features a powerful Repeat Last Operation feature that makes it easy for you to repeat the previous operation, when working on a FrameMaker XML Author document.

Repeat Last Operation can be performed on a document at the following locations:

- The current insertion point
- The current text selection
- The current object selection

To perform the Repeat operation, select Edit > Repeat [operation/object name] from the FrameMaker XML Author menu.
In addition, you can view the history buffer by selecting Edit > History from the FrameMaker XML Author menu. Click once on an entry in the buffer to perform it. Click once more on the entry to undo the operation.

Repeat Last Operation can be performed for the following actions on the document:

- Typing: Repeat Last Operation history buffer remembers the last chunk of characters that were typed. The typing sequence is broken when:
  - The user clicks in the document.
  - The user switches between tabbed documents.

- Paste: Repeat Last Operation can repeat the last paste operation at the current cursor location for both text and graphic objects in the clipboard. The list of graphic objects that can be pasted with Repeat Last Operation, are as follows: Aframe, Arc, Ellipse, Group, Inset, Line, Math, Polygon, Polyl ine, Rectangle, Rounded Rectangle, TextFrame, TextLine, Unanchored Frame.

  Note: The copy operation is not repeatable.

- Delete: Repeat Last Operation can repeat deletion of both text as well as graphical objects.

  Note: If you delete multiple characters and then use Repeat Last Operation, only a single character is deleted.

  Note: Character deletion and object deletion operations are interchangeable. If you delete a character and then perform a Repeat Last Operation on a graphic object, the graphic object is also deleted.

- Insert Graphic Objects: Repeat Last Operation can reinsert the last inserted graphic object at the current cursor location. This operation works across documents.

  The list of graphic objects that can be inserted are as follows:


- Insert Table: You can use Repeat Last Operation to reinsert the last inserted table at the current cursor location.

- Set Object Properties: When you apply the Repeat Last Operation command to set object properties, FrameMaker XML Author applies the last specified object properties to the new object.

- Insert Footnote/Anchored Frame: You can use the Repeat Last Operation command to insert a previously inserted Footnote/Anchored Frame at the current cursor position.

- Find/Change: When you apply the Repeat Last Operation command to the Find/Change procedure, FrameMaker XML Author performs the last Find/Change operation on any further occurrences of the specified text.

- Apply Conditional Text: Repeat Last Operation can repeat the last applied conditional tag to the currently selected text.

The shortcut key for the Repeat Last Operation action is F6. Repeat Last Operation is session-specific and not document specific.

Repeat Last Operation actions can be turned off by editing maker.ini. Edit the following entries:

- RepeatTypingEnabled: By default this entry is set to ON. Set this entry to OFF to disable the repeat typing operation.

- RepeatEnabled: By default this entry is set to ON. Set this entry to OFF to disable the repeat last operation actions.

  Note: Use caution when editing an ini file.
History panel

The Edit > Undo and Redo menus show the most recent command, but a complete command history is available in the History panel, available from Edit > History. This panel allows you to select an action to undo or redo. The command history is shown only for the active document.

In the History panel, the most recent command is highlighted. Commands listed above the most recent are undoable. Commands listed below the most recent are redoable, and are marked with an asterisk (*).

You can undo and redo actions only in the order in which they were originally performed. When you select a command to undo, all later commands (which have been affected by the selected action) are also undone. FrameMaker XML Author also moves the selected command and all succeeding commands to the Redo list. Similarly, redoing a command moves it and subsequent commands back to the Undo list.

Equations

You can insert an equation into a document:

“Using the FrameMaker XML Author Equation Pod” on page 96
“Using the MathFlow editor from Design Science” on page 128

Using the FrameMaker XML Author Equation Pod

You can insert an equation element inline with paragraph text or in a separate display paragraph.

An equation element provides a frame with an equation object into which you can enter mathematical expressions. Like an anchored frame for graphics, an equation frame is anchored to a specific location in text.
Placing and displaying equations

Inline and display equations

Suppose that the axes of an ellipse lie along the lines $x = x_0$. The ellipse is represented by the following equation.

$$\frac{(x-x_0)^2}{a^2} + \frac{(y-y_0)^2}{b^2} = 1$$

A. Inline equation  B. Display equation

An equation element appears in the document structure where it is anchored to text, regardless of the equation position on the page. In the Structure View, a square-cornered bubble with the snippet <EQUATION> indicates an equation element. The equation itself is not part of the structure.

If you export to SGML or XML, FrameMaker XML Author writes the equation to a separate file (MIF format). Then FrameMaker XML Author adds an entity reference to it from your SGML or XML file.

You can change the file format for equations using a read/write rule. If you change the file format to CGM, FrameMaker XML Author keeps a track of equations and their respective file names. Saving the equation multiple times, still saves it to its one file, instead of creating multiple files as in FrameMaker 9.

For example:

<table>
<thead>
<tr>
<th>New behavior</th>
<th>Old behavior</th>
</tr>
</thead>
<tbody>
<tr>
<td>Equation 1 is saved in file say eq1.mif</td>
<td>Equation 1 is saved in file say eq1.mif</td>
</tr>
<tr>
<td>Editing the FrameMaker XML Author content and subsequently saving the file, saves equation 1 to the same eeq1.mif.</td>
<td>Editing the FrameMaker XML Author content and subsequently saving the file, creates a new file say eq2.mif for the same equation 1.</td>
</tr>
<tr>
<td>FrameMaker XML Author does NOT create new files on every save for the same equation.</td>
<td>FrameMaker XML Author creates new files on every save for the same equation.</td>
</tr>
</tbody>
</table>

Equations in graphic frames

You can also place an equation in an anchored frame that is already inserted for graphics. Do this to combine the equation with graphic objects. If the anchored frame is an element, the element is part of the document structure. However, the frame contents, including the equation, do not appear in the structure.

An equation in an anchored frame with graphics sometimes produces unwanted results if you export to SGML or XML. In general, if you plan to export to SGML or XML, place only one object in a frame.
Equations panel overview

The Equations panel contains the commands to create and change equations. It also contains the symbols, operators, functions, and other math elements you insert in equations. To display the panel, click the Equations button Σ at the upper-right in the document window.

A. The Equations pop-up menu appears on every page. B. This part of the panel changes from page to page. C. The names of the pages appear here, with the current page highlighted.

The Equations panel contains nine pages of math elements and commands. To display a page, click its name at the top of the panel.

Symbols  Greek characters, atomic symbols, diacritical marks, and strings.

Operators  Roots, powers, signs, subscripts, superscripts, and logic symbols.

Large  Sums, products, integrals, intersections, and unions.

Delimiters  Parentheses, brackets, curly brackets, and substitution.

Relations  Equal, less than, greater than, similar to, subset of, superset of, and proportional to.

Calculus  Integrals, derivatives, partial derivatives, gradients, and limits.

Matrices  Matrices and matrix commands.

Functions  Trigonometric, hyperbolic, and logarithmic functions; commands for evaluating expressions; and commands for creating and applying rules.

Positioning  Controls to adjust the position of an expression and the spacing around it, commands to specify alignment, and commands to set and clear manual line breaks.

Create equations

To create an equation, insert an equation object in the document and then insert math elements in the equation.

💡 When working with an equation, zoom in until it’s easy to read.

Create an inline equation

1  Click in text where you want to insert the equation. If the text is in a rotated text frame, unrotate the frame first by selecting the rotated text frame and pressing Esc g 0 (zero).

2  Choose Special > Equations, or click the Equations button Σ at the right side of the document window.

3  On the Equations panel, choose one of the New Equation commands from the Equations pop-up menu. Small, Medium, and Large specify the font sizes used in the new equation.

A new equation object appears as a question mark in a frame anchored below the line with the insertion point. The first math element that you insert replaces the question mark prompt.
4 Insert the math elements in the equation by typing the elements or by clicking items on the Equations panel.

5 Choose Shrink-Wrap Equation from the Equations pop-up menu. This option shrinks the frame around the equation and places the equation in the line of text at the anchor symbol.

6 If the equation seems too close to the text on either side, insert a space before or after the frame. FrameMaker XML Author treats the frame that contains an inline equation as a character and doesn’t provide extra space around it.

7 If the equation is too tall for the line, open up more space above or below the line. Use the Line Spacing pop-up menu on the formatting bar to turn off fixed line spacing.

Create an equation in a paragraph of its own (a display equation)

1 Click in an empty paragraph.

2 Click the Equations button at the right side of the document window.

3 On the Equations panel, choose one of the New Equation commands from the Equations pop-up menu. Small, Medium, and Large specify the font sizes used in the new equation.

   A new equation object appears as a question mark in a frame anchored below the empty paragraph. The first math element you insert replaces the question mark prompt.
4 Insert the math elements in the equation by typing the elements or by clicking items on the Equations panel.

5 Choose Shrink-Wrap Equation from the Equations pop-up menu. This option shrinks the frame around the equation and places the equation in the empty paragraph.

Create an equation in a graphic frame with other objects
1 Click the Equations button Σ at the right side of the document window.
2 Select a graphic frame or an object in a graphic frame.
3 On the Equations panel, choose one of the New Equation commands from the Equations pop-up menu. Small, Medium, and Large specify the font sizes used in the new equation.
A new equation object appears as a question mark inside the frame. The first math element you insert replaces the question mark prompt.

4 Insert the math elements in the equation by typing the elements or by clicking items on the Equations panel.

5 To place the equation exactly where you want it, first select it by Control-clicking the equation.

6 Move the equation by doing one of the following:
   • Drag it with the mouse.
   • Move it with the arrow keys.
   • Position it precisely with the Graphics > Object Properties command.

More Help topics
“Move an object” on page 162
“Create equations in structured documents using elements” on page 126

Insert math elements
An equation contains expressions made up of math elements—characters, text strings, operators, and other mathematical elements from the Equations panel.

After you create an equation object, insert math elements in it by typing them or by clicking them on the Equations panel. The Equations panel can be closed when you insert an item from the keyboard.

Note: Math equations support the Unicode text-encoding standard.

About the scope of operations
When you insert a math element in an equation, FrameMaker XML Author adjusts the mathematical syntax. The result depends on the scope of operation—the selection or the location of the insertion point. For example, when you insert \( x \) in a fraction, the result depends on whether the numerator, the denominator, or the entire fraction is selected.
In the first example, only the 7 is multiplied by \( x \). In the second example, FrameMaker XML Author adds parentheses to show that the entire expression \( 2y + 7 \) is multiplied by \( x \). In the last example, the entire fraction is multiplied by \( x \). The size of the insertion point in the first and last examples indicates the scope.

Many mistakes in equations result from an incorrect scope of operation—having too little or too much selected when inserting an element. Be careful to select the range you want before inserting an element.

### Insert a math element

1. Select an expression or place the insertion point in an equation.

2. Do any of the following:
   - To insert a math element by using the Equations panel, click the element.
   - To insert an alphanumeric character or a symbol that appears on the keyboard, type it. You can type parentheses, brackets, plus signs, equal signs, and so on. If you type an open parenthesis, FrameMaker XML Author inserts the closing parenthesis.
   - To insert an element by typing a backslash sequence, type a backslash (\) and the string that identifies the element, and then press Return. For example, to insert the symbol for infinity \( \infty \), type \( \backslash \text{infty} \) and press Return.
   - Insert a custom math element.

   If an element needs one or more operands, a question mark prompt \( ? \) appears for each operand; otherwise, an insertion point appears. To move from one operand to another, press Tab.

### Insert a text string

A text string is a series of characters that is interpreted as a unit. Unlike characters that make up an expression, the characters in a text string don’t usually appear in italics and aren’t multiplied together.

\[
\text{one electron volt} = 1.60 \times 10^{-19} \text{ joule}
\]

A. Text strings

Text strings have no mathematical meaning in FrameMaker XML Author. For example, evaluation commands can evaluate the function \( \tan \) but not the string “tan”.

1. On the Symbols page of the Equations panel, click Start String. Two double quotation marks (""") appear. You can also type an apostrophe (’) or a double quotation mark (") to start the string.
2 Type the text of the string. The quotation marks disappear, and the text appears as you type. To insert a straight apostrophe or straight double quotation mark as part of the string, hold down Control while pressing the key.

3 Click End String on the Symbols page or press Return.

**Insert, add, or edit a horizontal or vertical list of expressions**

An equation object usually contains one equation or expression. You can set up a horizontal or vertical list in which several expressions are contained in the same object. When you select a list, all the expressions in the list are selected as one object.

![Horizontal and Vertical Lists Example](image)

FrameMaker XML Author aligns the expressions in the list automatically. When you move the list, all the expressions maintain their relative positions.

1 Select the expression you want to be the first item in the list or to add to a list.

2 On the Operators page of the Equations panel, click the horizontal list element or vertical list element. To add a math element, type the elements or click items on the Equations panel. A horizontal or vertical list appears. The selected expression appears as the first item in the list. A second item appears in the list as a question mark prompt.

<table>
<thead>
<tr>
<th>Before clicking</th>
<th>After clicking</th>
</tr>
</thead>
<tbody>
<tr>
<td>?</td>
<td>? ?</td>
</tr>
<tr>
<td>(abc)</td>
<td>(abc)</td>
</tr>
<tr>
<td>(ab)</td>
<td>(ab) (c)</td>
</tr>
</tbody>
</table>

In the first example, a horizontal list is inserted. In the second example, a vertical list is inserted, and the selected expression becomes the first item in the list. In the last example, a vertical list is inserted as part of a larger expression.

**Insert symbols**

The Symbols page on the Equations panel contains the Greek alphabet, other symbols, and diacritical marks.

The Symbols page doesn’t include Greek letters that have Roman-alphabet equivalents, such as the uppercase alpha (A). The following examples show the result of clicking \(\text{\(\alpha\)}\) on the Symbols page.
Diacritical marks appear on the element to the left of the insertion point or on the selected expression. Click the dot or prime button once for each dot or prime diacritical mark you want to insert.

Note: To interpret and mathematically manipulate a summation, product, or partial differential element, insert the element from the Large page or Calculus page. Do not insert from the Symbols page. Elements from the Symbols page are not evaluated.

Insert operators
The Operators page on the Equations panel contains commonly used operators, roots, powers, signs, subscripts, superscripts, and logic symbols.

If an expression is selected when you insert the operator, the expression becomes the first operand. The following examples show the result of clicking the plus sign or the division operator on the Operators page.

<table>
<thead>
<tr>
<th>Before clicking</th>
<th>After clicking</th>
</tr>
</thead>
<tbody>
<tr>
<td>( y + 7 )</td>
<td>( y + 7\pi )</td>
</tr>
<tr>
<td>( y' + 7 )</td>
<td>( (y + 7)\pi )</td>
</tr>
</tbody>
</table>

You can represent the division operator as a slash (/), a horizontal bar \( \div \), or a division sign \( \div \).

FrameMaker XML Author can evaluate exponents mathematically, but not superscripts.

\[ A \frac{x^3 + x + 2}{y^2 - 8} \]

A. Superscript  B. Exponent

Insert large elements
The Large page on the Equations panel contains sums, products, integrals, intersections, and unions.

If an expression is selected when you insert a large element, the expression becomes the first operand. The following examples show the result of clicking the summation symbol \( \sum \) on the Large page.
You can add an operand after inserting a math element from the Large page.

**Insert delimiters**
The Delimiters page contains delimiters such as parentheses, brackets, and curly brackets.

If an expression is selected when you insert a pair of delimiters, the expression is placed inside the delimiters. The following examples show the result of clicking the parentheses on the Delimiters page.

<table>
<thead>
<tr>
<th>Before clicking</th>
<th>After clicking</th>
</tr>
</thead>
<tbody>
<tr>
<td>$2x(\frac{1}{2})$</td>
<td>$2x\sum \frac{1}{2}$</td>
</tr>
<tr>
<td>$(2x)$</td>
<td>$\sum 2x$</td>
</tr>
</tbody>
</table>

You can also represent parentheses as brackets ([ ] ) or curly brackets ( { } ).

**Insert relations**
The Relations page contains relation symbols such as $=, <, >, \leq, \geq, \epsilon, \ni$, and $\in$. All relation symbols—except the binary equal sign $\equiv$—apply to the character to the left or right of the insertion point or to the selection. When you insert a relation symbol between multiplied elements, it applies to the elements on either side of the insertion point.

Binary equal signs $\equiv$ appear to the right of the current expression (as shown in the second example). When the insertion point or selection is in a subscript or superscript, the equal sign appears in the subscript or superscript.

<table>
<thead>
<tr>
<th>Before clicking</th>
<th>After clicking</th>
</tr>
</thead>
<tbody>
<tr>
<td>$abc = \frac{2}{3}$</td>
<td>$ab + 3y = \frac{2}{3}$</td>
</tr>
<tr>
<td>$2x + 3y = \frac{2}{3}$</td>
<td>$2x + \frac{3y}{p} = \frac{2}{3}$</td>
</tr>
</tbody>
</table>

**Insert a binary equal sign at the insertion point**
▶ Press Esc m =

<table>
<thead>
<tr>
<th>Before clicking</th>
<th>After clicking</th>
</tr>
</thead>
<tbody>
<tr>
<td>$a \frac{1}{b}$</td>
<td>$a \frac{1}{(b = ?)}$</td>
</tr>
</tbody>
</table>
Insert calculus elements
The Calculus page contains integrals, derivatives, partial derivatives, gradients, and the limit function.

If an expression is selected when you insert the calculus element, the expression becomes the first operand. The following examples show the result of clicking the integral symbol $\int$ on the Calculus page.

<table>
<thead>
<tr>
<th>Before clicking</th>
<th>After clicking</th>
</tr>
</thead>
<tbody>
<tr>
<td>$x^2$</td>
<td>$\int x^2 , dx$</td>
</tr>
<tr>
<td>$x^2 , dx$</td>
<td>$\int x^2 , dx$</td>
</tr>
</tbody>
</table>

You can change the position of operands and add operands.

Insert matrices
The Matrices page contains elements for matrices ranging in size from 1 by 1 to 3 by 3. After creating a matrix, you can add rows and columns.

If an expression is selected when you insert the matrix element, the expression becomes the first cell in the matrix.

<table>
<thead>
<tr>
<th>Before clicking</th>
<th>After clicking</th>
</tr>
</thead>
<tbody>
<tr>
<td>$3x$</td>
<td>$3 \begin{bmatrix} x \end{bmatrix}$</td>
</tr>
<tr>
<td>$3\begin{bmatrix} x \end{bmatrix}$</td>
<td>$3 \begin{bmatrix} x \end{bmatrix}$</td>
</tr>
</tbody>
</table>

Insert functions
The Functions page contains trigonometric, hyperbolic, and logarithmic functions, and also the sign, limit, and general functions.

FrameMaker XML Author places functions at the insertion point or at the selection. When an expression is selected, the expression becomes the argument of the function—except for the limit and general functions $\lim(x)$ and $\ln(x)$. The following examples show the result of clicking the sin function on the Functions page.

<table>
<thead>
<tr>
<th>Before clicking</th>
<th>After clicking</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\pi$</td>
<td>$\pi \sin \frac{\pi}{2}$</td>
</tr>
<tr>
<td>$\pi \frac{\pi}{2}$</td>
<td>$\sin \pi$</td>
</tr>
</tbody>
</table>

Insert a custom math element
In addition to inserting math elements that are built in FrameMaker XML Author, you can insert custom math elements that have been defined for a document.
Custom math elements have no mathematical meaning in FrameMaker XML Author. For example, a custom math element for an operator is treated as an operator in an equation. However, FrameMaker XML Author cannot evaluate it.

1. On the Equations panel, choose Insert Math Element from the Equations pop-up menu.
2. Select the element name and click Insert.

**Shrinkwrap or unwrap an equation**

Shrinkwrapping an equation shrinks the surrounding anchored frame so that it’s large enough for the equation. The operation changes the frame anchoring position to At Insertion Point, and places the insertion point after the frame.

```
A circle whose center is at the origin and whose radius is r is represented by the equation

\[ x^2 + y^2 = r^2 \]
```

**Before shrinkwrapping**

```
A circle whose center is at the origin and whose radius is r is represented by the equation

\[ x^2 + y^2 = r^2 \]
```

**After shrinkwrapping**

Shrinkwrap an equation when you finish working with it so that the equation takes minimal space and aligns with the baseline of the surrounding text. Unwrap an equation to enlarge the anchored frame for easy editing.

1. Click in the equation or select its frame.
2. On the Equations panel, choose Shrink-Wrap Equation or Unwrap Equation from the Equations pop-up menu.

The edges of a shrinkwrapped equation sometimes do not appear onscreen. They do appear in the printed document.

**Edit equations**

You can edit an equation as you edit text—adding, changing, rearranging, and removing math elements, and cutting, copying, and pasting them. As you edit an equation, the syntax of the equation is adjusted as necessary.

You can change a matrix—add or delete rows and columns, delete brackets, and change row height and column width. You can also choose among several representations for some math elements such as parentheses. You can add operands to others such as integrals and summations.

If your equation is shrinkwrapped, unwrap the equation before editing it. This makes the anchored frame full-sized again, giving you more room to work.

*Note: To edit a rotated equation, first restore the equation or text frame to its unrotated position by pressing Esc g 0 (zero).*
Extend a selection using the keyboard
❖ Press the spacebar. The selection expands to include the next higher expression. The following example shows the result of pressing the spacebar repeatedly.

<table>
<thead>
<tr>
<th>Original selection</th>
<th>$x = \frac{-b \pm \sqrt{b^2 - 4ac}}{2a}$</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pressed once</td>
<td>$x = \frac{-b + \sqrt{b^2 - 4ac}}{2a}$</td>
</tr>
<tr>
<td>Pressed twice</td>
<td>$x = \frac{-b - \sqrt{b^2 - 4ac}}{2a}$</td>
</tr>
</tbody>
</table>

Change the selection
❖ Do one of the following:
  • To change the selection to the next subexpression on the right, press the Right Arrow key.
  • To change the selection to the next subexpression on the left, press the Left Arrow key.
  • To change the selection to the next question mark prompt, press Tab.

Replace or delete a math element or equation
1 Select the element you want to delete and press Delete. A question mark prompt replaces the element.
2 Do one of the following:
  • To replace the element, click the Equations panel or type to insert the replacement.
  • To delete the element, press Delete again. FrameMaker XML Author removes any elements that are no longer necessary—for example, a plus sign or parentheses.
  • Control-click the equation to select the equation, and press Delete.

Remove delimiters
After entering or editing an equation, you sometimes end up with extra delimiters—parentheses, curly brackets, and brackets. You can remove extra delimiters. If you later use evaluation commands, FrameMaker XML Author evaluates the equation as if the delimiters are still present.

• To remove all delimiters, select the expression. On the Delimiters page of the Equations panel, click Remove Parentheses.

<table>
<thead>
<tr>
<th>Before clicking</th>
<th>After clicking</th>
</tr>
</thead>
<tbody>
<tr>
<td>$(2ab(b))$</td>
<td>$2ab$</td>
</tr>
</tbody>
</table>

• To remove one delimiter, place the insertion point to the right of the delimiter and press Delete. If the delimiter has a mate, such as the left parenthesis between $a$ and $b$ in the example, the mate is also removed.
Toggle an element format
You can represent some math elements in more than one way. For example, delimiters can appear as \((x)\), \([x]\), or \{x\}. Division can appear as \(\frac{x}{y}\), \(x/y\), or \(\frac{\text{?}}{y}\).

1 Select the entire element.

2 On the Operators, Large, Delimiters, or Calculus page of the Equations panel, click Toggle Format. The command is the same on all four pages and operates on any element with multiple formats. Click more than once to get the format you want in some cases.

Add an operand to a math element
Radical symbols, gradient symbols, and logarithms can have one or two operands. Integrals and other symbols on the Large and Calculus pages can have one, two, or three operands.

The ellipse is represented by the following equation:

\[
\frac{(x-x_0)^2}{a^2} + \frac{(y-y_0)^2}{b^2} = 1
\]

Operands

You can add operands to these elements without starting over.

1 Click or select anywhere in the expression with the element.

2 Click Add Operand on the Large or Calculus page. A question mark prompt appears where you specify the new operand.

Change matrices
You can change the number of rows or columns in a matrix and add or remove brackets around the matrix. You can allow the column width to vary from column to column, depending on the contents, or specify that all columns are equal width. Similarly, you can allow the row height to vary from row to row.

You can also transpose a matrix and perform matrix algebra.

- To add a row or column to a matrix, place the insertion point in the matrix. On the Matrices page of the Equations panel, choose Add Row or Add Column from the Matrix Commands pop-up menu.

Before Add Column | After Add Column
--- | ---
\[
\begin{bmatrix}
a & b \\
c & d
\end{bmatrix}
\] | \[
\begin{bmatrix}
a & b & ? \\
c & d & ?
\end{bmatrix}
\]

Add Row adds a row at the bottom. Add Column adds a column at the far right.
• To delete a row or column from a matrix, select the row or column and press Delete.
• To add or remove brackets around a matrix, select the entire matrix. On the Matrices page of the Equations panel, click Add/Remove Brackets.
• To change the row height or column width in a matrix, select the matrix. On the Matrices page of the Equations panel, choose All Equal or Proportional from the Matrix Row Height or Matrix Column Width pop-up menu.

![Equal row heights (left) and Proportional row heights (right)](image)

If you choose Proportional, each row is tall enough to hold the tallest cell in the row. Each column is wide enough to hold the widest cell in the column. If you choose All Equal, each row is tall enough to hold the tallest cell in the entire matrix. Each column is wide enough to hold the widest cell in the entire matrix.

**Set line breaks and align equations**
You can control equation breaks across lines and alignment of the lines in a multiline equation, or of the items in a list or matrix. You can also align several equations with one another, even if they appear in different anchored frames.

```
2a + 3b - c = 2x + 1
3a - b = 4x
2b + c = 3x - 7
2a - 3b + 7c - 2 = 2x + 4
```

*Aligned along left side of equal signs*

You can manipulate equation objects as you do other objects. You can automatically and manually align items in a vertical list and lines in a multiline equation. Manual alignment points override automatic alignment.

```
C = 2\pi r = \pi d
A = \pi r^2
```

*Aligned on left side and at manual alignment point*

You can align the items in a horizontal list along their tops, bottoms, or baselines.
You can also align the cells in each row of a matrix along their tops, bottoms, or baselines. You can align the cells in each column at the right, left, or center, or along equal signs.

More Help topics
“Copy and arrange objects” on page 162
“Insert, add, or edit a horizontal or vertical list of expressions” on page 103

Change equation line breaking
When an equation breaks across lines, the entire equation remains in a single anchored frame. You can set where an equation breaks across lines automatically. When you change the line-break width, the equation is reformatted to the new width.

You can also force a line break at a specific location in the equation. However, don’t use manual line breaks to create separate equations. Instead, insert a vertical list of expressions.
You can change line breaking in these ways:

- To change the automatic line break width, click in the equation or select any part of it. Choose Graphics > Object Properties. Edit the value in the Automatic Line Break After box, and click Set. The value is preset to the width of the equation frame.

- To insert a manual line break, click where you want the equation to break into two lines. On the Positioning page of the Equations panel, choose Set Manual from the Line Breaking pop-up menu. A line-break symbol appears at the insertion point when text symbols are visible.

```
(x + 1)^8 = x^8 + 8x^7 + 28x^6 + 56x^5 + \{
  70x^4 + 56x^3 + 28x^2 + 8x + 1
```

- To remove a manual line break, select the part of the equation that contains the line-break symbol. On the Positioning page of the Equations panel, choose Clear Manual from the Line Breaking pop-up menu.

**Align display equations**

The format of the paragraph that contains the equation controls the alignment (left, center, or right) of a display equation.

```
The ellipse is represented by the following equation

\[
\frac{(x - x_0)^2}{a^2} + \frac{(y - y_0)^2}{b^2} = 1
\]
```

1. Click in the paragraph that contains the equation (not in the equation itself).
2. Choose the alignment from the Alignment pop-up menu in the formatting bar or in the Paragraph Designer.

**Set automatic alignment for a vertical list or multiline equation**

1. Click in the equation or list.
2. On the Positioning page of the Equations panel, choose an item from the Left/Right pop-up menu. When you choose Left Of = or Right Of =, the lines are aligned along one side of an equal sign. A line with no equal sign is aligned along its left side.

**Set a manual alignment point for a multiline equation or for an item in a vertical list**

1. Do one of the following:
   - Click in the first line of a multiline equation where you want subsequent lines to align.
   - Click in a vertical list item where you want the item to align with the rest of the list.
2 On the Positioning page of the Equations panel, choose Set Manual from the Left/Right pop-up menu. A manual alignment symbol appears at the insertion point when text symbols are visible. Subsequent lines of a multiline equation are left aligned with the manual alignment point. A vertical list item aligns with other items in the list at the manual alignment point.

Clear a manual alignment point
1 Select the part of the equation that contains the manual alignment point.
2 On the Positioning page of Equations panel, choose Clear Manual from the Left/Right pop-up menu. You can also clear a manual alignment point by setting another.

Align items in a horizontal list
1 Click in the list.
2 On the Positioning page of the Equations panel, choose an item from the Up/Down pop-up menu.

Align cells in a matrix
1 Click in the matrix.
2 On the Positioning page of the Equations panel, choose an item from the Up/Down pop-up menu or from the Left/Right pop-up menu. The Left/Right and Up/Down commands affect the whole matrix. To align individual cells, use micropositioning.

Check alignment settings for a horizontal or vertical list, or for a matrix
1 Do one of the following to select the entire list or matrix:
   • Drag through the list or matrix.
   • Place the insertion point in the matrix and press the spacebar repeatedly.
2 On the Positioning Page of the Equations panel, click Position Settings.

Left-, center-, or right-align equations in a frame
You can align several equation objects with one another in a graphic frame, just as you align other objects. You can also align several equation objects along a manual alignment point, even when they're in separate graphic frames.

\[
\begin{align*}
  x + 2^2 &= x^2 + 4x + 4 \\
  x + 3 &= x^2 + x - 6 
\end{align*}
\]

Equations aligned at manual alignment points

FrameMaker XML Author maintains the alignment of the equation objects as you edit the equations. For example, if two equations are left aligned, the left alignment is maintained as the equations expand or shrink.

1 Select the equations to align by Control-clicking the first equation; Control+Shift-click the other equations.
   Make sure that the last equation you select is the one you want to align with.
2 Choose Graphics > Align.
3 Select the left/right alignment you want, and click Align.
Align equations along a point
1 Set the manual alignment point in one of the equations to align.
   If you don’t set a manual alignment point, FrameMaker XML Author aligns an equation on the left.
2 Click in the equation and choose Graphics > Object Properties.
3 Choose Manual from the Alignment pop-up menu and specify the location of the alignment point within the frame in the Alignment Point Offset area. The left offset is the distance from the left edge of the frame to the manual alignment point.
   Specifying the top offset precisely is unnecessary. You can move the equation up or down later, just as you do any other object.
4 Click Set.
5 Repeat steps 1 through 4 for each equation you want to align. Use the same distance from the left edge for each equation, but change the top offset to position the equation vertically in the frame. If the equations you’re aligning are in different anchored frames, make sure that the left edges align with one another.

Change font settings in equations
A document contains font settings that apply to all equations in it. These settings determine the font sizes and spacing for small, medium, and large equations. They also determine the character format used for Greek characters and for symbols, functions, numbers, strings, and variables.

You can change the preset size of an entire equation. You can also change the character format of individual math elements—for example, to use color or a special font.

You can also change the font sizes and character formats used for all equations in a document.

Change the character format in individual equations
You can’t change the spread, stretch, superscript, subscript, underline, overline, strikethrough, change bar, or pair kerning properties for any element. You also can’t change the font family for individual Greek characters and symbols and for some operators.

• To change the preset size or color of an equation, click in the equation, choose Graphics > Object Properties, and do one of the following:
  • To change the equation size, choose a size from the Size pop-up menu, and click Set. If the equation is shrinkwrapped, FrameMaker XML Author rewraps it.
  • To change the equation color, choose a color from the Color pop-up menu, and click Set.
  • To change character format, select the element or expression, and change as you do for text.
  • To create a superscript or subscript, insert the appropriate operator.
  • To change the spread of characters, microposition them by using the positioning page of the Equations panel.
  • To place a line over or under an expression, use the diacritical marks on the Symbols page of the Equations panel.

Change equation fonts throughout a document
You can change the font size and spacing for all small, medium, and large equations in a document. When you make global font changes, FrameMaker XML Author reformats and rewraps all shrinkwrapped equations in the document.

Greek characters and symbols in equations normally appear in the Symbol font. You can use fonts such as Mathematical Pi and Universal Greek if these fonts are installed on your system.
Functions, numbers, and strings normally appear in Times New Roman or Times. Variables normally appear in italic. You can change the character format of each of these kinds of elements. For example, you can display all elements in Helvetica, with functions in italic and variables in bold.

**Note:** Don’t delete formats from the Character Catalog if you’re using them to specify the character format of math elements. If you delete these character formats, all equations in the document are reformatted using the default font.

Use Equation Sizes from the Equations pop-up menu on the Equations panel for the following change:

- To change equation fonts throughout the document, do one of the following:
  - Specify the font sizes and spread, and click Set. Spread is expressed as a percentage of the font size. Positive spread values cause wider spacing around elements; negative values cause narrower spacing.
  - Click Get Defaults.
- To change the font for Greek characters and symbols, choose one of the available fonts from the Math Symbols pop-up menu, and click Set.
- To change the character format for functions, numbers, strings, and variables, first create the character format you want. Then choose the character format from the Functions, Numbers, Strings, or Variables pop-up menu, and click Set. FrameMaker XML Author displays the format you created in the pop-up menus.

### Evaluating equations

After you create an expression or equation, you can transform it by changing its mathematical representation. For example, you can multiply polynomials, factor terms, simplify expressions, and combine fractions.

<table>
<thead>
<tr>
<th>Original selection</th>
<th>$y = (x + 4)^3$</th>
</tr>
</thead>
<tbody>
<tr>
<td>Expanded</td>
<td>$y = (x + 4)(x + 4)(x + 4)$</td>
</tr>
<tr>
<td>Multiplied out</td>
<td>$y = (x + 4)(x^2 + 8x + 16)$</td>
</tr>
<tr>
<td>Multiplied out again</td>
<td>$y = x^3 + 12x^2 + 48x + 64$</td>
</tr>
</tbody>
</table>

You can also evaluate equations by substituting values and performing computations.

| Original selection | $x^3 \big|_{x=1}$ |
|--------------------|-----------------|
| Expanded | $x^3 \big|_{x=3} - x^3 \big|_{x=1}$ |
| Value substituted | $27 - 1$ |
| Result computed | $26$ |

### Transform or evaluate an expression

1. Select the expression, or part of it.
2. Choose a command on the Matrices or Functions page of the Equations panel. For example, select an expression and then choose Multiply Out from the Multiplication pop-up menu on the Functions page.
3. To transform or evaluate an expression, use the commands on the Matrix Commands pop-up menu of the Matrices page and the commands on the six pop-up menus of the Functions page.

More Help topics
“Change matrices” on page 109

Matrix Commands pop-up menu

Matrix Transpose  Transposes the rows and columns of a selected matrix.

<table>
<thead>
<tr>
<th>Selected matrix</th>
<th>After transposing</th>
</tr>
</thead>
</table>
| \[
\begin{bmatrix}
a & b & c \\
d & e & f
\end{bmatrix}
\] | \[
\begin{bmatrix}
a & d \\
b & e \\
c & f
\end{bmatrix}
\] |

Matrix Algebra  Performs matrix multiplication and addition, and evaluates dot and cross products in a selected matrix.

<table>
<thead>
<tr>
<th>Selected matrix (or matrices)</th>
<th>After matrix algebra</th>
</tr>
</thead>
</table>
| \[
2 \begin{bmatrix}
a & b \\
c & d
\end{bmatrix}
\] | \[
\begin{bmatrix}
2a & 2b \\
2c & 2d
\end{bmatrix}
\] |
| \[
\begin{bmatrix}
2a & 2b \\
2c & 2d
\end{bmatrix}
\] | \[
\begin{bmatrix}
2a + bc & 2b + be \\
a + 2c & d + b + c + 2de
\end{bmatrix}
\] |
| \[
\begin{bmatrix}
2 & b \\
3 & a
\end{bmatrix}
\] | \[
\begin{bmatrix}
2 + 3 & b + a
\end{bmatrix}
\] |
| \[
\begin{bmatrix}
a \\
b \\
c
\end{bmatrix}
\times
\begin{bmatrix}
a \\
b \\
c
\end{bmatrix}
\] | \[
\begin{bmatrix}
2a + b2 + c2
\end{bmatrix}
\] |
| \[
\begin{bmatrix}
1 \\
2 \\
3
\end{bmatrix}
\times
\begin{bmatrix}
a \\
b \\
c
\end{bmatrix}
\] | \[
\begin{bmatrix}
2c - 3b \\
3a - 1c \\
1b - 2d
\end{bmatrix}
\] |

After performing matrix algebra, you can use the Simplify command to combine like terms.

Addition pop-up menu

Add Fractions  Adds selected fractions, expressing the result as a single fraction. This command also combines like terms.
If the selected expression contains the sum of more than two fractions, Add Fractions adds only the first two. Use this command repeatedly to combine all the fractions.

<table>
<thead>
<tr>
<th>Selected fraction</th>
<th>After adding</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \frac{1}{3} + \frac{4}{5} )</td>
<td>( \frac{17}{15} )</td>
</tr>
<tr>
<td>( \frac{a}{4} + \frac{2a}{3} )</td>
<td>( \frac{11a}{12} )</td>
</tr>
<tr>
<td>( \frac{2x}{y} + \frac{3a}{b} )</td>
<td>( \frac{2bx + 3ay}{by} )</td>
</tr>
</tbody>
</table>

Order Sum  Arranges polynomials in decreasing powers of a selected variable.

<table>
<thead>
<tr>
<th>Before factoring</th>
<th>After factoring</th>
</tr>
</thead>
<tbody>
<tr>
<td>( c + bc )</td>
<td>( a \left( c + \frac{bc}{a} \right) )</td>
</tr>
<tr>
<td>( a^2 + 2a + 1 )</td>
<td>( a \left( a + 2 + \frac{1}{a} \right) )</td>
</tr>
</tbody>
</table>

Factor Some  Factors a selected term from only those terms that contain it.
Multiply Out  Simplifies the selected expression, distributes multiplication over addition, and expands a selected term raised to a positive integral power.

<table>
<thead>
<tr>
<th>Selected expression</th>
<th>After multiplying</th>
</tr>
</thead>
<tbody>
<tr>
<td>(a - 3)(2 a + 4)</td>
<td>2a^2 - 2a - 12</td>
</tr>
<tr>
<td>(a + 2b)^2</td>
<td>a^2 + 4ab + 4b^2</td>
</tr>
</tbody>
</table>

The Simplify command also simplifies the selected expression.

Multiply Out Once  Multiplies the first pair of factors on the left side of a selected expression.

<table>
<thead>
<tr>
<th>Selected expression</th>
<th>After multiplying</th>
</tr>
</thead>
<tbody>
<tr>
<td>a(b + c)(2a)</td>
<td>ab(2a) + ac(2a)</td>
</tr>
</tbody>
</table>

If you use this command several times, the results appear in a different form.

Distribute  Performs a variety of operations depending on the expression you select, as shown in the following examples:

- Distributes division over addition.

<table>
<thead>
<tr>
<th>Selected expression</th>
<th>After distributing</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \frac{a + b}{c} )</td>
<td>( \frac{a}{c} + \frac{b}{c} )</td>
</tr>
</tbody>
</table>

Use the Add Fractions command to perform the reverse operation.

- Distributes multiplication over addition.

<table>
<thead>
<tr>
<th>Selected expression</th>
<th>After distributing</th>
</tr>
</thead>
<tbody>
<tr>
<td>a(b + c)</td>
<td>ab + ac</td>
</tr>
</tbody>
</table>

Use the Factor command to perform the reverse operation.

- Transforms products and quotients involving radicals and exponents into a single expression raised to a power.

<table>
<thead>
<tr>
<th>Selected expression</th>
<th>After distributing</th>
</tr>
</thead>
<tbody>
<tr>
<td>ab^2</td>
<td>(\sqrt{ab})^2</td>
</tr>
<tr>
<td>a^{3/2}b^2</td>
<td>(a^{3/2}b)^2</td>
</tr>
<tr>
<td>a^2 \sqrt{b}</td>
<td>\sqrt{a^4b}</td>
</tr>
</tbody>
</table>
Use the Simplify command to perform the reverse operation.

**Distribute Over Equality** Performs the same operation on both sides of an equal sign.

<table>
<thead>
<tr>
<th>Selected expression</th>
<th>After distributing</th>
</tr>
</thead>
<tbody>
<tr>
<td>((x = y)z)</td>
<td>(xz = yz)</td>
</tr>
<tr>
<td>((x = y) - 5)</td>
<td>(x - 5 = y - 5)</td>
</tr>
<tr>
<td>((x = y)^2)</td>
<td>(x^2 = y^2)</td>
</tr>
</tbody>
</table>

**Division pop-up menu**

**Long Division** Performs long division in a fraction that contains a polynomial numerator and denominator.

In the following example, you select an \(x\)—any \(x\)—before choosing Long Division. You select an \(x\) in the fraction of the first result and choose Long Division again to obtain the second result.

<table>
<thead>
<tr>
<th>Before dividing</th>
<th>(\frac{x^2 + 2x + 1}{x + 1})</th>
</tr>
</thead>
<tbody>
<tr>
<td>Divided once</td>
<td>(x + \frac{1}{x + 1})</td>
</tr>
<tr>
<td>Divided twice</td>
<td>(x + 1)</td>
</tr>
</tbody>
</table>

**Remove Division** Converts division to multiplication in a selected expression by changing positive exponents in a denominator to negative and negative exponents in a denominator to positive.

<table>
<thead>
<tr>
<th>Selected expression</th>
<th>After removing division</th>
</tr>
</thead>
<tbody>
<tr>
<td>(\frac{x}{y^2})</td>
<td>(xy^{-2})</td>
</tr>
<tr>
<td>(\frac{b + \frac{c}{d}}{x})</td>
<td>((b + cd^{-1})x^{-1})</td>
</tr>
</tbody>
</table>

To convert negative exponents to division operators, use the Remove Negative Powers command.

**Remove Division 1 Level** Converts division to multiplication, as Remove Division does, but applies only to the first level of operators.
To convert the first level of negative exponents into division operators, use the Remove Negative Powers 1 Level command.

**Remove Negative Powers** Converts negative exponents to positive in a selected expression by replacing multiplication with division and division with multiplication.

<table>
<thead>
<tr>
<th>Selected expression</th>
<th>After removing negative powers</th>
</tr>
</thead>
<tbody>
<tr>
<td>$xy^{-2}$</td>
<td>$\frac{x}{y^2}$</td>
</tr>
<tr>
<td>$(b + c d^{-1})^{-1}$</td>
<td>$\frac{b + \frac{c}{d}}{x}$</td>
</tr>
</tbody>
</table>

**Remove Negative Powers 1 Level** Converts negative exponents to positive, as Remove Negative Powers does, but applies only to the first level. If the selected expression has no negative exponents at the first level, this command has no effect.

<table>
<thead>
<tr>
<th>Selected expression</th>
<th>After removing negative powers</th>
</tr>
</thead>
<tbody>
<tr>
<td>$(b + c^{-1})^{-2}$</td>
<td>$\frac{1}{(b + c^{-1})^2}$</td>
</tr>
<tr>
<td>$xy^{-2}$</td>
<td>$xy^{-2}$ (no effect)</td>
</tr>
</tbody>
</table>

**Evaluation pop-up menu**

**Number Crunch** Changes integers to floating-point numbers in a selected expression and then evaluates the expression.

<table>
<thead>
<tr>
<th>Selected expression</th>
<th>After number crunch</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\frac{3\pi}{\sin \frac{2}{2}}$</td>
<td>$-1$</td>
</tr>
</tbody>
</table>
Show All Digits  Shows the full internal accuracy of a floating-point number.

<table>
<thead>
<tr>
<th>Selected expression</th>
<th>After showing all digits</th>
</tr>
</thead>
<tbody>
<tr>
<td>3.1415927 …</td>
<td>3.1415926535897</td>
</tr>
</tbody>
</table>

Evaluate  Evaluates the selected expression. The operations performed depend on the type of expression selected, as shown in the following examples:

- Rewrites an expression raised to a power less than 20 as a product.

<table>
<thead>
<tr>
<th>Selected expression</th>
<th>After evaluating</th>
</tr>
</thead>
<tbody>
<tr>
<td>$a^3$</td>
<td>$aaa$</td>
</tr>
</tbody>
</table>

- Computes the factorial of an integer. If the result is too large to calculate, the result appears as Infinity.

<table>
<thead>
<tr>
<th>Selected expression</th>
<th>After evaluating</th>
</tr>
</thead>
<tbody>
<tr>
<td>$5!$</td>
<td>120</td>
</tr>
</tbody>
</table>

- Computes the determinant of a 1-by-1 or 2-by-2 matrix.

<table>
<thead>
<tr>
<th>Selected expression</th>
<th>After evaluating</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\begin{bmatrix} a &amp; b \ c &amp; d \end{bmatrix}$</td>
<td>$ad - bc$</td>
</tr>
</tbody>
</table>

- Extracts a term from a sum or product.
- Evaluates a substitution just as the Evaluate Substitution command does.
- Rewrites an Evaluate Between operator as a difference.

<table>
<thead>
<tr>
<th>Selected expression</th>
<th>After evaluating</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\sum_{x=1}^{5} x^3$</td>
<td>$1 + \sum_{x=2}^{5} x^3$</td>
</tr>
</tbody>
</table>

- Rewrites the logarithm of a product as a sum of logarithms and rewrites a logarithm of a power as a product.

<table>
<thead>
<tr>
<th>Selected expression</th>
<th>After evaluating</th>
</tr>
</thead>
<tbody>
<tr>
<td>$x^2</td>
<td>^8_{x=6}$</td>
</tr>
</tbody>
</table>

- Rewrites a logarithm to a base in terms of natural logarithms.

<table>
<thead>
<tr>
<th>Selected expression</th>
<th>After evaluating</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\log 2 + \log x + \log y$</td>
<td>$\log 2 + \log x + \log y$</td>
</tr>
<tr>
<td>$\log a^n$</td>
<td>$n \log a$</td>
</tr>
</tbody>
</table>

- Rewrites a choice function in terms of factorials.

<table>
<thead>
<tr>
<th>Selected expression</th>
<th>After evaluating</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\binom{x}{y}$</td>
<td>$\frac{x!}{y!(x-y)!}$</td>
</tr>
</tbody>
</table>

**Evaluate Substitution** Performs a specified substitution and then simplifies the expression. When an Evaluate Between operator is selected, this command rewrites the expression as a difference.

<table>
<thead>
<tr>
<th>Selected expression</th>
<th>After evaluating</th>
</tr>
</thead>
<tbody>
<tr>
<td>$x^2</td>
<td>^6_{x=1}$</td>
</tr>
<tr>
<td>$\sin(2x)</td>
<td>^p_{x=\pi}$</td>
</tr>
</tbody>
</table>

**Evaluate Integrals** Rewrites a selected integral with a polynomial integrand. This command converts a definite integral into an indefinite integral evaluated between the upper and lower bounds. Use Evaluate Integrals several times to integrate a polynomial fully.
Evaluate Derivatives Evaluates a selected derivative, applying the chain rule to complex expressions when necessary. This command evaluates a partial derivative only when all dependencies are explicitly written.

This command treats elements in a total derivative as if they depended on the variable of differentiation. Use the Evaluate command to expand an $n$th derivative before using Evaluate Derivatives to evaluate it.

<table>
<thead>
<tr>
<th>Selected expression</th>
<th>$\int x^2 , dx$</th>
</tr>
</thead>
<tbody>
<tr>
<td>Evaluated once</td>
<td>$\int (dx) x^2 \bigg</td>
</tr>
<tr>
<td>Evaluated twice</td>
<td>$x^3 \bigg</td>
</tr>
</tbody>
</table>

**Evaluate Derivatives 1 Level** Evaluates only the first level of a selected derivative.

<table>
<thead>
<tr>
<th>Before</th>
<th>After</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\frac{d}{dx}(3x^3 - 2x^2 - 3)$</td>
<td>$9x^2 - 4x$</td>
</tr>
<tr>
<td>$\frac{d}{dx} \sec xy \tan xy$</td>
<td>$(xy^2 \sec^2 xy + y \tan x \tan y) \tan y \tan y$</td>
</tr>
</tbody>
</table>

**Rules pop-up menu**
Use the Rules pop-up menu on the Functions page to store and apply rules that transform expressions.

For example, use Enter Rule to store a rule such as $a = a + 3$. Then use Apply Rule to substitute $a + 3$ for $a$ in another expression.

**Enter Rule** Stores a rule for substituting one expression for another. Select the expression you want to store as a rule before you choose Enter Rule. You can store only one rule at a time.

**Designate Dummy** Designates a selected term to be a dummy variable. Use a dummy variable in a rule to substitute the expression on the right side of the rule for any variable, not just the variable explicitly named on the left. A dummy variable appears in boldface. For example, if you designate $x$ in the rule $x = a$ as a dummy variable, you can substitute $a$ or $x$ for any variable in an expression.

Select the term you want to be a dummy variable before you choose Designate Dummy. Then use the Apply Rule command to replace a selected expression with the expression assigned to the dummy variable.

**Apply Rule** Substitutes one term or set of terms for another in a selected expression, using the rule stored with the Enter Rule command.
Before you apply a rule that contains a dummy variable, select the term you want the variable to replace. In the following example, $x$ is the dummy variable in the rule.

<table>
<thead>
<tr>
<th>Rule entered</th>
<th>$x \leftarrow \sqrt{y}$</th>
</tr>
</thead>
<tbody>
<tr>
<td>Before rule is applied</td>
<td>$a^2 - 2ab + b^2$</td>
</tr>
<tr>
<td>After rule is applied</td>
<td>$a^2 - 2ab + \sqrt{y}^2$</td>
</tr>
</tbody>
</table>

**Other Rewrites pop-up menu**

**Simplify**  Simplifies the selected expression. To evaluate fractions that involve infinity or division by zero, use the Number Crunch command instead of Simplify.

The operations performed depend on the type of expression selected, as shown in the following examples:

- Performs integer arithmetic.

<table>
<thead>
<tr>
<th>Selected expression</th>
<th>After simplifying</th>
</tr>
</thead>
<tbody>
<tr>
<td>$c + 0$</td>
<td>$c$</td>
</tr>
<tr>
<td>$4!$</td>
<td>24</td>
</tr>
<tr>
<td>$\frac{1}{3} + \frac{2}{5}$</td>
<td>$\frac{11}{15}$</td>
</tr>
</tbody>
</table>

When the result is too large to calculate, it appears as Infinity.

- Groups terms in a sum or product.

<table>
<thead>
<tr>
<th>Selected expression</th>
<th>After simplifying</th>
</tr>
</thead>
<tbody>
<tr>
<td>$2ab + 3ab$</td>
<td>$5ab$</td>
</tr>
<tr>
<td>$ab(ac)$</td>
<td>$a^2bc$</td>
</tr>
<tr>
<td>$a^x a^2 x + 3$</td>
<td>$a^3x + 3$</td>
</tr>
</tbody>
</table>

- Divides out common factors in a fraction.
Use the Remove Negative Powers command to remove negative powers from the result.

- Interprets the complex number \( i \), represented by the Greek letter iota \( \iota \).

- Distributes exponentiation across multiplication and division.

Simplifying \( \sqrt{\frac{ab}{c}} \) produces \( \frac{\sqrt{a} \sqrt{b}}{\sqrt{c}} \) rather than \( \frac{\sqrt{ab}}{c} \).

**Simplify Some** Simplifies the selected expression, as the Simplify command does, but does not multiply fractions.

**Isolate Term** Isolates a selected expression on one side of the equal sign. This command does not combine terms or solve for the selected expression.

**Expand First Term** Expands the first term of a selected summation or product.
Expand All Terms  Expands all terms of a selected summation or product.

Create equations in structured documents using elements
You create an equation by inserting an equation element and then entering the mathematical expressions for the equation. To insert an element, you can use the Element Catalog. You can also use a New Equation command from the Equations pop-up menu in the Equations panel.

Note: The term "math element" refers to part of an expression, such as an operator. It is not a structural element.

You can use any equation element for both inline and display equations. Some documents also have a paragraph element defined that provides formatting properties for the display equations.

The format rules for an equation element suggest a set of font sizes for the equation: Small, Medium, or Large. You can change to a different set of font sizes. This change is not considered a format rule override. If you remove format rule overrides in the document, the equation does not return to its original font size.

Create an inline equation using an element
1  Click in text where you want to insert the equation. If the text is in a rotated text frame, unrotate the frame first by pressing Esc g 0 (zero).
2  Select an equation element in the Element Catalog and click Insert.

   The first math item that you enter replaces the question mark prompt of the new equation object.
Enter the equation by typing numerals and other items or by clicking items on the Equations panel.

Choose Shrink-Wrap Equation from the Equations pop-up menu in the panel.

If the equation seems too close to the text on either side, insert a space before or after the frame. FrameMaker XML Author treats a frame that contains an inline equation as a character and doesn’t provide extra space around it.

If an inline equation is too tall for its line, perhaps turn off fixed line spacing for that paragraph.

Create a display equation using an element

1 If your document has a paragraph element defined for formatting display equations, click where you want the equation paragraph. Select the paragraph element in the Element Catalog, and click Insert.

This element sometimes defines space above and below the equation, alignment in the text column, and an autonumbered caption.

2 Click in an empty paragraph element where you want to insert the equation.

3 Select an equation element in the Element Catalog, and click Insert.

4 Enter the equation.

5 Choose Shrink-Wrap Equation from the Equations pop-up menu.
If no equation element is available at the location that you want, perhaps you can use an invalid element. Do one of the following:

- To use an element that is valid in another part of the document, insert the element in a valid location and then move it. You can also use the All Elements setting to make the element available everywhere and then insert the element where you want it.
- To insert an invalid equation element with the default tag EQUATION, choose a New Equation command from the Equations pop-up menu in the Equations panel. The element has a default tag if no defined equation elements are available.

After inserting the element, talk to your developer about making the element valid at this location.

**Create an equation in an anchored frame element**

1. Select an anchored frame or a graphic object in the frame.
2. Choose a New Equation command from the Equations pop-up menu in the panel.

   The first math item you enter replaces the question mark prompt of the new equation object. The equation does not appear in the document structure.

   \[ \sum_{n=1}^{N} A_n \]

   *New equation object in a frame with graphic objects*

3. Enter the equation.

**More Help topics**

“Equations panel overview” on page 98

“Change the scope of elements available in a structured document” on page 42

“Create equations” on page 98

**Using the MathFlow editor from Design Science**

In addition to using the FrameMaker XML Author Equation pod to add equations to your documents, you can also use the MathFlow editor from Design Science to design complex mathematical equations. You can then add these equations to your FrameMaker XML Author documents. You also have the option to later modify these equations in the same MathFlow editor and publish documents containing MathML equations.

MathML equations are available for use in XML documents. These equations are also available for use in FrameMaker XML Author.
FrameMaker XML Author ships with a trail version of the following MathFlow editors:

- **MathFlow™ Style Editor** is for content authors and subject matter experts (SME). It provides precise control over the visual appearance of math expressions, a style toolbar for quickly adjusting fonts, and an easy to use interface for modifying a wide range of equation properties from operator spacing to matrice/table appearance.

  ![Style Editor](image)

- **MathFlow™ Structure Editor** is for XML content professionals. It provides fine control over visual presentation and its underlying MathML structure. There is a Source View enabling the user to add processing instructions and comments directly to the MathML, a ruler for precise layout of the equation, and a tabbed toolbar for storing commonly used equations or fragments.
For a feature comparison of the editors, see MathFlow Editors. Also, for the procedure to upgrade to the full version of the MathFlow editor, see “Configure the installation settings” on page 131.

**To create and insert a MathML equation into a document**
2. Create an equation in the MathFlow Editor window.
   - For details on how to create equations in the MathFlow see the MathFlow help. You can launch the MathFlow help from within the MathFlow Editor window.
3. To add the equation to the document, click OK.
   - The equation is inserted into the document.

**To edit a MathML equation in a document**
1. Double-click the equation in the document or right-click on the equation and choose Edit with MathFlow.
2. Edit the equation in the MathFlow Editor window.
3. To update the equation in the document, click OK.

FrameMaker XML Author also supports the copy-paste and undo-redo operation on equations on MathML equations in a document.

**Important:** You will need to first define an element in the Elements catalog that supports this type of object. FrameMaker XML Author ships with a sample structured app that includes a mathxml element. For details how to use this element, see Using the Sample MathXML structured app.
Configure the MathFlow setting
To configure MathML settings in FrameMaker XML Author, open the Preferences dialog and go to the MathML tab.

Configure the installation settings
FrameMaker XML Author ships with a 30 day trial version of Style and Structure editor of MathFlow from Design Science. You can obtain the full version of the Style or Structure editor from Design Science and integrate that with FrameMaker XML Author.

1 After you have installed the full version of the Style or Structure editor, go to the MathFlow section of the MathML tab.

2 The trial version that ships with FrameMaker XML Author is installed in the Adobe FrameMaker XML Author installation path. If you have installed MathFlow in an alternative path, specify that path.

3 Specify the path to the license file and click OK.
You need to restart FrameMaker XML Author to ensure these changes take effect.

Note: The MathFlow 30 day trial period starts from the first time to invoke the editor. Not from the day you install the version of FrameMaker XML Author that includes the editor.

Format a MathML equation
You can update the formatting of a selected MathML equation in a document or you can change the preferences for all MathML equations. By default, the font size of the equations is set to 14 px. DPI for the images that FrameMaker inserts into a document for each equation defaults to 300 dpi. Also, you can choose to place an equation inline with the enclosing paragraph and you can apply the formatting of the enclosing paragraph to the equation.

To update the formatting of the current selected MathML equation:

1 Select the MathML equation and choose Graphic > Object Properties.
   Or choose Graphic > Object Style Designer.
   These options are also available in the right-click menu.

2 Update the formatting for the current selected MathML equation in the MathML Equation Properties dialog.
   DPI and Font  Change the DPI and Font size settings.
   Inline  Place the image inline with the enclosing paragraph.
   Apply Paragraph Style  Apply the enclosing paragraph formatting to the equation.
You can also apply these settings globally to all MathML equations created subsequently.

1 Open the Preferences dialog (Edit > Preferences).

2 In the MathFlow settings section of the MathML tab, change the equation settings.
These settings take effect immediately. So you do not need to restart FrameMaker.

Configure the equation formatting
By default, the font size of the equations is set to 10 px. Also, DPI for the images that FrameMaker XML Author inserts into a document for each equation defaults to 300 DPI.

1 To change the font size and image DPI go to the MathFlow Settings section of the MathML tab.

2 Update the font and DPI settings and click OK.
These settings take effect immediately. So you do not need to restart FrameMaker XML Author.
Configure the MathFlow editor
The trial version of the MathFlow editor includes the Style and Structure editors. During this period, you can choose between either of these editors.

1. To change the MathFlow editor, go to the Editor Type section of the MathML tab.
2. Choose the required MathFlow editor and click OK.

You need to restart FrameMaker XML Author to ensure these changes take effect.

Note: When installing the full version of MathFlow, you need to choose between the Style and Structure editors. The MathFlow trial integration with FrameMaker XML Author includes both the editors. So you are recommended to use both these editors when trying out this feature.

Sample MathXML structured app
FrameMaker XML Author ships with a sample structured app that includes a mathxml element. This mathxml element has complete support for the MathML equations that are rendered by the MathFlow Style and Structure editors.

Inserting a MathML type element in a document
1. From the File menu, choose New -> XML.
2. In the New XML dialog, go to the Structured Applications tab and choose DITA_1.2_MathML_Sample and click OK.
   A new document is created.
3. Go to any part of the document where you want to insert a MathML equation.
   The MathML element, mathml, is available in the Elements catalog of the sample structured app.
   Note: A mathml element is available at any point in the document where a foreign element is available.
4. Double-click the mathml element to insert it at the point in the document.
5. Go to the XML view of the current document.
   The Xml of the structured document contains a MathML node at the location where you inserted the MathML element.
   Note: Each element within the mathml node has an mml prefix. This prefix is used to avoid name conflicts with other elements used in the Xml either from the Elements catalog of the structured app or from elements defined in the MathML structure.

You also have the option to edit the equation within the mathml node in the XML view. The changes can then be seen in the WSIYWIG view.

Working with multiple languages

About Unicode
Unicode is an industry standard that allows computers to represent text in most of the world's languages in a consistent way. It is implemented by different character encodings, such as UTF-8, UTF-16, and UTF-32. FrameMaker XML Author supports all three encodings but stores files in UTF-8. If you import files encoded in UTF-16 or UTF-32, FrameMaker XML Author automatically converts them to UTF-8.
In text processing, Unicode provides a unique number or code point for each character in a language. The Unicode standard does not specify the typeface or the visual rendering of each character. This is handled through Unicode fonts that may include visual renderings for thousands of Unicode characters thereby providing a single typeface across multilingual documents.

Enable Unicode

The Unicode standard is a character coding system designed to support the worldwide interchange, processing, and display of text in any language or character set. Unicode encoding allows you to create documents containing characters from any number of character sets, and allows sharing of documents between different geographic or linguistic regions.

FrameMaker XML Author supports Unicode text encoding for creating, editing, saving, and publishing documents in multiple languages and for creating multilingual documents. Unicode text is supported in FrameMaker XML Author markers, catalog entries, and dialogs. PDF export supports Unicode text, bookmarks, tags, and comments. You can import or copy Unicode content from other applications.

Unicode assigns a unique number to every single character, no matter which language or type of computer you use.

- **Portable** Letters and numbers do not change when you move the file from one workstation to another. Adding a foreign language to a document doesn’t cause confusion, because foreign characters have their own designations that don’t interfere with the encoding from other languages in the same projects.

- **Robust** Because Unicode-compliant fonts offer a larger number of potential characters, specialty type characters are readily available.

- **Flexible** With Unicode support, substituting a typeface in a project does not result in substituted characters. With a Unicode-compliant font, a γ is a γ no matter which typeface is used.

All of these things make it possible for a French company to do work for a client in Korea and hand the job off to a partner in the United States without having to struggle with the text. The writer or designer must enable the correct language in the operating system, load the foreign-language font, and continue the project.

1. To enable your computer to author content in languages other than English, start your computer in the UTF-8 locale.
2. To enable the dictionaries or open the thesaurus, select the desired language from the Input Method Editor (IME) Language bar.
3. Start typing the content in the selected language.

Certain features support Unicode, such as find and change, markers, hypertext, and catalog entries. You can export to PDF with Unicode bookmarks, tags, comments, and so on. You can import or export Unicode content from other applications. Additional dictionaries help you author content in more languages.

**More Help topics**

“Working with multiple languages” on page 132

**Adding multilingual text in documents**

There are multiple ways to input characters in Unicode in a document. You could configure the regional language or locale settings on your computer to add the required languages for keyboard input. You could also configure and use a soft keyboard layout provided by third-party plug-ins.
Keyboard layouts cannot have simple key combinations for all characters and so FrameMaker XML Author provides two alternative input methods that allow access to the entire range of Unicode characters. One is the Hex palette which allows you to specify the code point in any of the three UTF encodings. The other is through a character map, which is a visual table listing all Unicode characters available in the selected font.

The Microsoft Windows XP Service Pack 2 (SP2) and Windows Vista® operating systems have regional and language settings. Use these settings to add additional languages for keyboard input. These languages and speech settings appear in the Language bar on the desktop. After you select a language and set up a localized keyboard, you can start typing the required text in the document. The keyboard layouts are defined by Microsoft.

You can type words in the selected language or input appropriate Unicode characters.

**Set up input languages**

1. On your computer, open the Control Panel and double-click the Regional And Language Options icon. The Regional And Language Options dialog box appears.
2. Click the Languages tab.
3. Click the Details button. The Text Services And Input Languages dialog box appears.
4. In the Settings tab, click the Add button. The Add Input Language dialog box appears.
5. Select a language from the Input Language list.
6. Click OK. The selected language is included in the Installed Services list.
7. Select the desired language in the Default Input Language list.
8. Click Apply and click OK to save the settings and close the Text Services And Input Languages dialog box.
9. Click the Regional Options tab, and then choose the language you selected in the Default Input Language list.
10. Click Apply and then click OK to save the settings and close the Regional And Language Options dialog box. The Language bar or the Input Method Editor (IME) appears in the system tray of your computer.
11. Open FrameMaker XML Author, and then type the content. The text appears in the selected language.

*Note: If you change the language in the Default Input Language list and the Regional Options tab, the language selected in the Language bar is also updated automatically.*

**Using third-party keyboard layout software**

Several third-party keyboard layout software applications are available for different languages in Windows. When these layouts are activated, FrameMaker XML Author starts receiving input according to the keyboard mappings set by the third-party software. FrameMaker XML Author does not alter any of the key definitions.

**Using the Character palette**

The character palette lists all the Unicode characters in the three character sets.
1. Place the cursor where you want to insert the character in your document.
2. Select File > Utilities > Character Palette.
3. Select the font that supports the language you want to type in. The character palette displays the characters available in the selected font.
4. Click the box containing the character that you want to insert. Use the scroll bar to scan the character palette if needed.
   Each character's code point in UTF-32, UTF-16, and UTF-8 is displayed at the bottom of the character palette.
5. If the character inserted in your document does not match what you selected, ensure that the font in the document is the same as the font selected in the character palette.
6. Click outside the character palette to dismiss it.

**Using the Hex Input palette**

The Hex Input palette allows you to add a Unicode character in your document by specifying its code point.

1. Place the cursor where you want to insert the character in your document.
2. Select File > Utilities > Hex Input to display the Hex Input palette.
3 Type the Unicode number of the character you want to insert. The corresponding character is displayed on the right.

4 To toggle between Unicode character sets, click UTF 32.

5 If you cannot find the character you want to insert, either click the arrow keys to search sequentially or click the character to display the Character palette.

   Also, ensure that you have selected the appropriate font from the Character palette. The character for the same hex value changes depending on the font that you select.

6 Click outside the Hex Input to dismiss it.
Chapter 6: Tables

About tables

You need to define the table’s formats as part of the structured application as since the formats cannot be changed in FMXA.

Working with tables in structured documents

The table element definition determines the table’s structure. When you insert the table, at least some row and cell elements are inserted along with it, ready for you to provide the contents.

Elements for structured tables and table parts

A table and its parts (such as title, rows, and cells) are each represented in an element. You can see and work with these elements in the Structure view.

When you insert a table element, some of the table parts are inserted automatically. You can use the Element Catalog as a guide for building the rest of the table. If you add more table parts, they can also have an initial structure; for example, a new row element contains cell elements. The content rules for table and table-part elements define an initial structure for that element.

A table can also have cells that are defined to remain empty. No valid elements can be inserted in these cells, and you cannot type in them. An empty cell element’s tag describes the use of the cell—look for names such as BlankHeader or SpacerCell.

How structured tables are formatted

The appearance of a structured table is determined by its table format, various settings in the Table menu, and paragraph formats for text.

Table menu commands

The Table menu has commands to:

- Insert a table
- Add rows and columns
- Sort the table
- Convert paragraph to table and table to paragraph
**Paragraph formats**  Paragraph formats define fonts, line spacing, and other properties for text in the cells and the title. Table-part elements can specify paragraph formats.

**DITA support for tables**
DITA topics support two types of tables. The `<table>` element uses the OASIS Exchange Table Model (formerly known as the CALS table model). The OASIS table supports the spanning of multiple rows or columns for special layout or organizational needs, and provides a wide variety of controls over the display properties of the data and even the table structure itself.

The `<table>` element organizes arbitrarily complex relationships of tabular information. This standard table markup allows column or row spanning and table captions or descriptions. An optional title allowed inside the table element provides a caption to describe the table.

The DITA table is based on the OASIS Exchange Table Model, augmented with DITA attributes that enable it for specialization, conref, and other DITA processing. In addition, the table includes a desc element, which enables table description that is parallel with figure description.

In DITA tables, in place of the `expanse` attribute used by other DITA elements, the `pgwide` attribute is used to conform to the OASIS Exchange Table Model. This attribute has a similar semantic (1=page width; 0=resize to galley or column).

*Note:* The `scale` attribute represents a stylistic markup property that is maintained (for now) in tables for legacy purposes. External style sheets should enable less dependency on this attribute. You should use the `scale` attribute judiciously in your topics.

The other table structure in DITA is called `<simpletable>`. As the name implies, it is structurally less complex than the OASIS table, and can be used as a simple, regular table for which close control of formatting is not as important. The main advantage of `simpletable` is for describing lists of data with regular headings, such as telephone directory listings, display adapter configuration data, or API properties.

## Insert, move, or remove a table

### Insert a table element
A table is anchored to a specific location in text. As you edit the text, the table moves in the document along with the text. An anchor symbol 1 appears at the table’s anchor location in the document window.

When you insert a table, you specify where to anchor it. For example, you can anchor a table in a Para element (as a child element to the Para) or you can anchor it in a Section element (as a sibling to Para and other elements in the section). It depends on how the elements are defined for your document.

1. Click where you want to insert the table.
2. Select a table element in the Element Catalog, and click Insert.
   *Note:* To add other table-part elements to the table, use the Element Catalog as a guide.
3. If required, change the number of columns, rows, heading rows, or footer rows.
4. To change the table format, select a format in the scroll list. The table element can have a format preselected, but you can change the format and it is not considered a format rule override.
   Consult your developer before changing a table format. Your element catalog can have a separate element defined for each format you’ll need.
Choose the table variable type (continuation or sheet) to insert. For more details on table variables, see Add continuation text.

Click Insert. FrameMaker inserts an anchor symbol at the insertion point and a table with predefined descendant elements. The Structure view has bubbles for the new elements.

If the Attributes for New Element dialog box appears, enter attribute values for the table element and click Insert Element.

Select cells in the table and then right-click to display a context menu for working with the cells. You can also use the QuickAccess bar as a quick way to apply table commands.

If no table element is available at the location you want, you can use an invalid element. After inserting the table, talk to your developer about making it valid at this location.

Use an invalid table element

- To use a table that is valid in another part of the document, either insert the table in a valid location and then move it, or use the All Elements setting to make the table available everywhere and then insert the table where you want it.
- To insert an invalid table with default tags, choose Table > Insert Table and choose TABLE from the Element Tag pop-up menu. (This option appears in the menu if the document has no defined table elements.) The table and table parts have default tags, such as TABLE, HEADING, and ROW. After replacing the table with a valid table, change the table parts to valid elements.

Changing an invalid table with default tags to a valid table can be a laborious process. It’s best to work with tables that are defined.

More Help topics

“Change the scope of elements available in a structured document” on page 42

Nest a table in a table cell

1 Click in the cell in which you want to nest a table.

2 Do one of the following:
   - Choose Special > Anchored Frame.
     - For XML documents, this command inserts an element. Choose a frame element from the Element Tag pop-up menu in the Anchored Frame panel.
     - (Structured documents) Select a graphic element for empty anchored frames in the Element Catalog, and click New Frame.
   - Choose Special > Anchored Frame (for XML documents).

3 If the anchored frame is wider than the cell, resize the column.

4 Use the Text Frame tool on the Tools panel to draw a text frame in the anchored frame.

5 Click in the text frame and choose Table > Insert Table.

Important: If you export a document to SGML or XML, you can lose the contents of anchored frames in it because they are not part of the main structured flow. Work with your application developer if you plan to export to SGML or XML to avoid losing data in the nested table.

More Help topics

“Anchored frames” on page 173
Copy, move, or remove a table

1 Control-triple-click a cell to select the entire table or click the table bubble in the Structure view.

2 Do one of the following:
   • To copy the table, choose Edit > Copy.
   • To move the table, choose Edit > Cut. If a dialog box appears, click Remove Cells From Table, and click Cut. Then click where you want to move the table, and choose Edit > Paste. See the Element Catalog before pasting to ensure that you paste the table at a valid location.
   • To remove the table (without changing the contents of the clipboard), press Delete.

   You can also drag a table bubble in the Structure view to move the table, or Alt-drag the bubble to copy the table.

Rows and columns

You can easily add, delete, copy, move, or resize rows and columns, either by using the clipboard or by dragging. Sort rows and columns by numbers or letters. You can sort by date or time, as long as the information is entered in the table as text.

Add and delete rows and columns

Adding rows or columns can make the structure of the table invalid. For example, a table set up to contain only three columns will be invalid if you add a fourth. It’s best to use the Element Catalog for adding heading or footing rows, because tables are often defined to have a specific number of these rows.

1 Click in a table cell next to where you want to add the row or column.

2 Choose Table > Add Rows Or Columns, and specify the number of rows or columns you want to add and where you want to insert them.

3 Click Add.

The new rows or columns have the same properties as the current row or column.

Add a row using the Element Catalog

❖ Click where you want to add the row in the Structure view, select a row element in the Element Catalog, and click Insert.

Add a row below the current one

❖ Press Control+Enter.

The new row has the same properties as the previous row.

If the insertion point is in the last cell of the last row, press Tab to create a new row at the end of the table.

Add a row at the end of table

If the pointer is currently in the last row of a table, press the Tab key to insert a new row.

Delete a row or column

1 Select the rows or columns you want to delete, making sure that you select entire rows or columns. (If you don’t, the contents of the selected cells are deleted without a prompt for a decision.)

2 Press Delete, click Remove Cells From Table, and click Clear.
Copy, move, or reorder rows or columns

Copy or move rows or columns

Use the Edit menu

1. Select the rows or columns, and do one of the following:
   - If you are copying them, choose Edit > Copy.
   - If you are moving them, choose Edit > Cut, click Remove Cells from Table, and then click Cut.

2. Click next to where you want to insert the rows or columns, and choose Edit > Paste. You can insert them next to
   the current row or column, or you can replace the current row or column.

If you overwrite the rows or columns in a table, the cells on the clipboard replace the current rows or columns
according to the following rules:

- If the number of rows or columns on the clipboard is equal to the number of selected rows or columns, they are
  replaced exactly.
- If the number on the clipboard is greater than the number you select to replace, only the number of rows or columns
  that fit are pasted.
- If the number on the clipboard is less than the number you select to replace, the clipboard contents are repeated so
  that they fill the rows or columns.

To split a table, cut rows or columns from a table and paste them where you want to make a new table. To combine
two tables, cut the rows and columns from one table and paste them into another.

Using drag-and-drop

1. Select one or more rows or columns to move.

2. Drag the rows or columns to the location where you want to move them.
   To copy the rows or columns, keep the Ctrl key pressed as you drag them.

3. Drop the rows or columns to move or copy.
   When you drag-and-drop a row, the dragged row replaces the row below. Similarly, when you drag-and-drop a
   column, the dragged column replaces the column to the right.

4. To retain the row (below) or column (to the right), keep the Shift key pressed as you drag-and-drop.
   You can also drag a row’s bubble to move the row, or Alt-drag the bubble to copy the row.

Reorder rows or columns

1. Select the rows or columns to reorder in the table.

2. Hold down the Shift key and drag-and-drop the rows or columns to the required alternate location in the table.

Resize rows and columns

Resize a column by dragging

- To change a column width, select a cell in that column and drag its handle until the column is the size you want.
  Select several columns to resize them together.
- To move the border between two columns so one column grows wider and the other narrower, Alt-drag a selection
  handle. The overall width of the table doesn’t change.
Specify a precise column width
1 Select cells in the columns you want to resize (if you’re resizing a single column, just click in it), and choose Table > Resize Columns.
2 Do one of the following:
   • To specify a value for the width, click To Width and enter the value.
   • To set the width to a percentage of the original width, click By Scaling and enter a percentage.
   • To make the column the same width as another column in the table, click To Width of Column Number and enter the column number.
   • To make the widths equal parts of a total, click To Equal Widths Totaling and enter the total width.
   • To specify a total width while still keeping the columns’ proportions the same, click By Scaling to Widths Totalling and enter the total width.
   • To set the width to match the widest paragraph or frame in the selected cells, click To Width Of Selected Cells’ Contents and enter a maximum width.
3 Click Resize.

Copy and paste a column width
1 Click in the column whose width you want to copy.
2 Choose Edit > Copy Special > Table Column Width.
3 Click in the column you want to change and choose Edit > Paste. Only the column width is pasted; the contents of the cells remain unchanged.

Adjust the height of a row
The height of a row changes automatically to fit the cell’s contents, but you can increase the height further if you want.
Adjusting the height of a row does not affect the structure of the table, and it is not a format rule override.
1 Click in the row that has the height you want to increase, and choose Table > Row Format.
2 Enter values for the minimum and maximum row height and then click Set.

Make all rows the same height
1 Determine the height of the tallest row in a table: Hold down Alt+Shift while drawing a selection border around the row.
2 Note the height, which appears in the status bar.
3 Select the entire table, and choose Table > Row Format.
4 Specify this value for the minimum row height and click Set.

Sort rows and columns
When sorting by numbers, currency symbols are ignored, but negative signs are recognized. For example, -9 or (9) sorts before 9 in an ascending sort. The comma and decimal separators displayed in numbers are treated according to the Regional options set for numbers and currencies on your system.
Text always comes after numbers in a sort. Text strings in tables are sorted based on the default system locale.
You can sort by date or time as long as you enter it as text, use a consistent format, and include leading zeros. For example, if you’re using dd/mm/yy and hh:mm:ss formats, enter 04/12/2017 or 09:30:25.

1. Save your document, so that you can revert to your last saved version if the sort gives unexpected results.
2. Make sure the table contains no hidden conditional rows in the table (use Special > Conditional Text).
3. Do one of the following:
   - To sort all columns or all rows in a table, click anywhere in the table.
   - To sort only certain rows, select cells in the rows you want to sort.
4. Choose Table > Sort.
5. If you’re sorting all rows or all columns, click Select All Body Rows.
6. Do any of the following:
   - To sort the rows of the table, click Row Sort. If the rows contain heading or footing cells as well as body cells, only the body cells are sorted.
   - To sort the columns of the table, click Column Sort.
   - To sort uppercase letters apart from lowercase letters, select Consider Case.
7. Choose a primary sort key by selecting from the Sort By box and clicking Ascending Sort or Descending Sort.
   You can sort straddle cells as long as they don’t extend past a row or column that you’re using as a sort key. (Use Table > Unstraddle and try again.)
8. Optionally, choose a second and third sort key from the Then By areas.
9. Click Sort.

Note: FrameMaker correctly sorts numbers preceded by the special symbols ()+-,. and $. However, combining several of these symbols in a cell sometimes adversely affects sorting. For example, a table cell containing -2 will fall correctly between -1 and -3, but a cell containing -2+3 will not (Frame interprets the sequence as -23).

Note: The Table sorting feature supports the Unicode text encoding standard.

Text and graphics in tables

You format text in a table cell just as you format paragraphs in a regular column of text—for example, with paragraph or character formats.

Each table cell can contain text and anchored frames. (Anchored frames, in turn, can contain graphics or other tables.) As you type text or insert an anchored frame in a cell, the cell height expands as needed.

In addition to typing text in a table, you can also insert cross-references, table footnotes, variables, and markers. The tab character is the only character you have to enter in a special way in a table cell.

You can copy, cut, and paste the contents of cells just as you do text and graphics in any other part of a document. Special system variables let you specify continuation text in the titles or heading rows of multipage tables.

For structured documents, you can type text in the current cell when the <TEXT> indicator appears in the Element Catalog. You can also insert footnotes, cross-references, and other text-related elements in the cell. Use the Element Catalog as a guide.
Select text or cells in tables

More Help topics
“Navigating through tables” on page 387

Place the insertion point in a table cell
❖ Click in the cell, or click to the left of the cell’s text snippet in the Structure view.

Select the contents of a cell
❖ Click in the cell and press Esc t h a, or double-click the cell’s bubble in the Structure view. You can also triple-click a cell’s contents if it contains just one paragraph.

Select a single cell
• Control-click the cell.
• (Structured documents) Drag across the cell’s boundary and back, or click the cell’s bubble in the Structure view.

Select multiple cells
• Drag across all the cells, and then Shift-double-click or Shift-click (structured documents) the last cell in the selection.
• To select an entire row, press Esc t h r, or drag across the cells in the row, or click the row’s bubble in the Structure view.

If you click between table-part elements (such as between two rows) in the Structure view, the insertion point appears in the Structure view but not in the document window. A contiguous selection of cells in the document window doesn’t always appear as contiguous bubbles in the Structure view.

• To select an entire column, press Esc t h c, or drag from a heading cell into the first body cell.
• To select the entire table, press Esc t h t.

Add or remove a table title
A table title appears above or below a table and is repeated on all pages of a multipage table. Whether a table has a title and how it’s formatted is defined in the table format.

When you insert a table with a title, an empty text frame appears for the title. If the title format has been defined to include an autonumber, the autonumber text appears.

More Help topics
“Edit a variable definition” on page 56
Add “continuation” text

In a multipage table, you can include special “continuation” text in the title or in heading or footing rows. Your document can have variable elements defined for this purpose, such as one that displays (continued) and another that tells the number of sheets in the table.

1. On the first page of the table, click in the title or in the heading or footing where you want to insert the variable or variable element.

2. Do one of the following:
   - Double-click either the Table Continuation variable or the Table Sheet variable from the Variables pod.
   - (Structured documents) Select a variable element for continuation text in the Element Catalog, and click Insert.

   On the first page of the table, the variable appears as a nonbreaking space \[continued\]. On subsequent pages, the variable displays its text—for example, (continued).

Place graphics in table cells

Place a graphic in a structured document

If your table cells allow graphic elements, you can draw or import graphics in the cells. A new graphic element can be either an empty anchored frame that you can draw in or an anchored frame with an imported graphic.

1. Click where you want to place the graphic in the cell.

2. Select a graphic element in the Element Catalog and click Insert. The element’s definition determines which dialog box appears.

3. Do one of the following:
   - If the Anchored Frame dialog box appears, choose At Insertion Point from the Anchoring Position pop-up menu, and click New Frame.
   - If the Import File dialog box appears, select the file to import, and click Import.

   An anchored frame appears in the cell, and a bubble with the text snippet GRAPHIC appears in the Structure view.

4. If the anchored frame is wider than the cell, resize the column.
   
   4 To resize a column to match its contents, select the column and press Esc t w.

5. If necessary, choose Graphics > Align to center the graphic in the frame.
More Help topics
“Anchored frames” on page 173

Convert between text and tables
You can convert text that’s already in your document to a table, or you can convert text in a text file as you open or import the file. In a structured document, the text is wrapped into a structure of table and table-part elements.

After converting text to a table, you can edit the table, removing blank cells or recombining text that was split into two or more cells. In most cases, you can edit the table directly in the document. However, if you converted text that was imported by reference, you must edit the text in the original file.

You can convert any table to text within FrameMaker XML Author, or you can copy the table as text to another application. You can also convert all the tables in a document at one time.

In structured documents, when you convert tables to text, all the table and table-part elements, except for the cells, are unwrapped. Change the cells to other elements or make other changes to correct the structure of the document.

Convert text to a table
1  Select the text you want to convert.
2  Choose Table > Convert To Table.
3  If you’re working in a structured document, choose a table element from the Element Tag pop-up menu.
   \*Note: In an XML document, the table element will have a preselected format.\*
4  In an XML document, select a format for the table.
5  Specify how you want to convert paragraphs by doing one of the following:
   \* To convert text that uses tabs to separate information, click Tabs.
   \* To convert text that uses spaces to separate information, click Spaces and then enter the minimum number of spaces that indicate a separate cell.
   \* To convert text that uses other characters to separate information, click Other and then type the characters that can be used to separate cells.
   \* To convert each paragraph (such as those in a bulleted list) to a cell, click A Cell and then enter the number of columns you want in the table.
6  In the Heading Rows box, enter the number of heading rows you want in the new table. If the paragraphs you’re converting don’t include headings and you want to fill in the headings later, select Leave Heading Rows Empty.
7  Click Convert.
   \*Note: When working with structured documents, the Structure view has bubbles for the new elements. If the Attributes for New Element dialog box appears, enter attribute values for the table element and click Insert Element.\*

Convert a text file to a table as you open the file
1  Choose File > Open, and select the text file you want to open.
2  If the Unknown File Type dialog box appears, select Text, and then click Convert.
3  Click Convert To Table, and then click Read.
4  Follow the instructions for converting text to a table, starting from step 3.
Convert a text file to a table as you import the file
1. Click where you want to import the file.
2. Choose File > Import > File, and select the text file you want to import and the import method.
3. Click Convert To Table and then click Import.
4. Follow the instructions for converting text to a table, starting from step 3.

If you want to merge a text file into an existing table, import the text file and convert it to a table. Then copy the rows and paste them into the existing table.

Touch up a table after conversion
• To combine text that is split across two or more rows, cut and paste the text from the lower cells into the upper cell, and delete the extra rows.
• To fix half-empty columns, cut and paste the text into the correct locations, and delete the extra columns.
• To fix major errors, you can return to the original text (choose Edit > Undo if necessary), edit the text (for example, by deleting extra tabs and forced returns), and then convert the text to a table again.

Convert a table to text
1. Click in the table you want to convert to text.
2. Choose Table > Convert To Paragraphs.
3. Click Row By Row or Column By Column, and click Convert.

Copy a table to another application as text
1. Copy the table to the clipboard.
2. In another application, choose Edit > Paste. The table is pasted, row by row, with tabs separating table cells, and a paragraph return at the end of each row.

Convert all tables in a document to text
❖ Save the document in Text Only format, and specify how you want the tables converted.

More Help topics
“Nest a table in a table cell” on page 139
“Import unformatted text” on page 238
Run text around a table
Text does not run around a table that’s anchored directly in a column of text. You can, however, run text around a table in an anchored frame or in a text frame that’s disconnected from the main flow. (For structured documents, check to see if your developer has set up this application this way.)

A table in an anchored frame moves with the text it’s anchored to. A table in a disconnected text frame remains in place on a page while other text flows around it. The table does not autonumber with tables in the main flow.

**Important:** The contents of an anchored frame or a disconnected text frame are not part of a document’s main structured flow, so they are not normally exported to SGML. If you plan to export to SGML, work with your application developer to avoid losing data in the table.

![Table in an anchored frame and a table in a disconnected text frame](image)

Run text around a table in an anchored frame (structured documents)
1. Click in text where you want to anchor the table.
2. Select a graphic element for an empty anchored frame in the Element Catalog, and click Insert.
   You can also use Special > Anchored Frame to insert an element. Choose a frame element from the Element Tag pop-up menu in the Anchored Frame panel.
3. Choose Run Into Paragraph from the Anchoring Position pop-up menu, set the width and height of the frame, and click New Frame. Try to set the size of the frame to be slightly larger than the size of the table.
4. Draw a text frame in the anchored frame. Select View > Toolbars > Graphics Toolbar and click the Place A Text Frame tool. Drag to draw the frame, and click Set in the dialog box that appears.
5. Click in the text frame and use Table > Insert Table to insert a table.

Run text around a table that remains stationary on the page
1. Draw a text frame directly on a page and drag it where you want it. This type of text frame is not connected to the main flow.
2. Choose Graphics > Runaround Properties, click Run Around Bounding Box, and click Set.
3. Click in the text frame and choose Table > Insert Table.

Position and autonumber text within cells
When you insert a table, its cell margins—the distance between the cell edge and the cell text frame—are determined by the table format. The indent properties of text in the cell, which are measured from the cell margins, are part of the text’s paragraph format as defined in structured application.
### Tables

A. Left cell margins  B. Paragraph’s left indent

<table>
<thead>
<tr>
<th>Plant</th>
<th>Bloom</th>
</tr>
</thead>
<tbody>
<tr>
<td>Baylily</td>
<td>Spring</td>
</tr>
<tr>
<td>Catsby</td>
<td>Fall</td>
</tr>
<tr>
<td>Dalux</td>
<td>Summer</td>
</tr>
<tr>
<td>Derana</td>
<td>Fall</td>
</tr>
</tbody>
</table>
Chapter 7: Graphics

Graphics and objects

About graphics and objects

When working with structured documents, you use special elements to place graphics. A graphic element provides an anchored frame for holding graphic objects. The frame is anchored to a specific location in text. As you edit the text, the frame and its contents move in the document along with the text. The element appears in the document's structure, but the graphic or equation itself is not part of the structure.

A new graphic element is either an empty anchored frame or an anchored frame with an imported graphic. When you insert the element, its format rules determine whether you see a dialog box for setting up a frame or for importing a graphic file:

• For an element that is an empty anchored frame, you specify the size of the frame, its anchoring position, and some formatting properties such as alignment. You can fill in the frame by drawing, pasting, or importing graphic objects in it.
• For an element that is a frame with an imported graphic, you specify the file to import. The graphic appears below the line with the anchor symbol, in a frame large enough for it.

After you’ve inserted a graphic element, you can place different contents in the frame, resize the frame, change the anchoring position, and edit the frame in other ways. These changes are not considered to be format rule overrides.

More Help topics
“Create anchored frames” on page 173
“Multiple Undo/Redo” on page 93
“Anchored frames” on page 173
“Crop or mask graphics” on page 164
“Add text to graphics” on page 159

Working with illustrations

In FrameMaker XML Author, you can draw rectangles, ovals, and polygons, as well as straight and curved lines. You can create complex illustrations by combining several objects, and include text in illustrations. You can also specify object properties (such as fill pattern, line width, and color), and resize, reshape, rotate, and rearrange objects.

You can place illustrations directly on the page, in anchored graphic frames that move with the text, or in unanchored graphic frames that crop the edges of the illustration.

• Text frames control placement of the document text.
• Graphic frames, which can be anchored or unanchored control the position and appearance of graphics.
• Anchored frames hold graphics related to specific text and move along with the text as you edit it.
• Unanchored frames are used to crop graphics that stay in the same place on the page. You can also use unanchored frames to hold reference art. You draw unanchored graphic frames with the Graphic Frame tool on the Tools panel.
Note: Graphics placed in unanchored frames are not exported to HTML, Microsoft Word, or RTF.

If you want the graphic to appear at a specific location on a page (for example, for a logo or a bleed tab), draw or import the graphic directly on the page. If you need to crop a graphic or include it as reference art on a reference page, you place it in an unanchored graphic frame.

A. Graphic drawn on page  B. Text line  C. Anchored frame  D. Text frame for document text

You can use text frames along with graphics—for example, as callouts or captions. You can also use text frames in anchored frames to create effects such as sidebars. For single lines of text in graphics, you can also use the Text Line tool.

Tools palette overview
You use the dockable Tools panel to select drawing tools and to apply properties. To display the Tools panel, choose Graphics > Tools or View > Toolbars > Graphics Toolbar.

About paths
An object’s path is an imaginary line through the center of the object’s border. The path appears as an outline when you draw an object.
FrameMaker XML Author uses the path to position objects. For example, when you use the Align command to align objects, the objects are aligned along their paths, not along the outside of their borders. When the snap grid is on as you draw, FrameMaker XML Author aligns the path with the snap grid.

**Draw objects**

When you draw an object, the pointer is a cross-hair \(\rightarrow\). After you draw, the pointer normally changes back to an arrow \(\rightarrow\) so you can select objects, or to an I-beam \(\rightarrow\) so you can select or type text. To draw another object, you usually have to click a drawing tool again.

When you draw an object directly on a page, it doesn’t move with the text, although text can run around the object. If you want the object to be “anchored” to surrounding text (that is, to move as you edit the text), you can draw the object in an anchored frame, or draw it on a page and then move it into an anchored frame.

When you draw an object, it uses the drawing properties that are selected on the Tools panel. The object is also selected, to make changing these properties easier.

**More Help topics**

“Apply and change drawing properties” on page 155

“Resize and reshape objects” on page 166

**Draw a straight line**

1. Click the Line tool \(\rightarrow\).
2. Click at the start and end of the line. You can also drag from the beginning to the end of the line. To draw a horizontal or vertical line, or a line at a 45-degree angle, Shift-click, or Shift-drag.

   *To draw several lines that touch one another, use the Polyline tool to draw several connected lines as a single object. You can also use the Line tool to draw the lines and then use the Gravity feature to make sure that they touch one another.*

**Draw a polyline or polygon**

1. Click the Polyline tool \(\rightarrow\) or the Polygon tool \(\rightarrow\).
2 Click at each vertex in turn. To draw a horizontal or vertical segment, or a segment at a 45-degree angle, Shift-click.
3 Double-click at the last vertex.

![Click at each vertex and then double-click to end.]

**Draw an arc**

1 Click the Arc tool.
2 Put the pointer where you want to start the arc and drag along the path of the arc. To draw a circular arc, Shift-drag.

![Drag and then release.]

If the arc isn’t the shape you want (for example, if it’s concave rather than convex), don’t release the mouse button. Drag the cross back to the starting point and draw the arc again, dragging along the path you want the arc to trace. Initially, the angle of the arc will be 90 degrees.

**Draw a freehand curve**

1 Click the Adobe FreeHand tool.
2 Place the pointer where you want to start the freehand curve, and drag along the path of the curve. The snap grid is ignored for all but the first point of a freehand curve; however, you may want the snap grid to be off when you draw the curve.

![Drag and then release.]

When you release the mouse button, FrameMaker XML Author approximates a curve along the path you drew and displays reshape handles and control points so you can reshape the curve.

*For more precise control over the shape of a freehand curve, create a curve by drawing polylines or polygons and then smoothing them.*
Draw a rectangle, a rounded rectangle, or an oval
1. Click the Rectangle tool, the Oval tool, or the Rounded Rectangle tool.
2. Drag diagonally across the area in which you want the object to appear. To draw a square or circle, Shift-drag.

To draw a border around a graphic, draw a rectangle with a fill pattern of None around the graphic.

Draw a regular polygon
1. Draw a circle or square that is slightly larger than the regular polygon you want to create. If you draw a rectangle or an oval, the polygon you create won’t be regular.
2. Select the object and choose Graphics > Set # Sides.
3. Specify the number of sides and the start angle of the polygon, and click Set.

Draw several objects of the same type without clicking the tool each time
❖ Do one of the following:
   • For all objects except text lines, Shift-click the tool. To stop using the tool, click another drawing tool or one of the selection tools on the Tools panel.
   • For text lines, press Return at the end of a text line and continue typing.

Select objects
You can select objects that are on the same page or in the same graphic frame. When you select a graphic frame, any selected objects are deselected. When an object is selected, handles appear around it.

Smart Select tool Allows you to place an insertion point or select text when the pointer is over text, and to select objects when the pointer is over an object. When the Smart Select tool is active, the pointer changes shape as you move it—to an I-beam over text or to a hollow arrow over objects. In general, use the Smart Select tool as you work.

Object Select tool Use the Select Object tool when you’re working with text lines and text frames as objects—for example, when you want to move or resize a text frame. When you click in text with the Select Object tool active, you select the text line or text frame as an object rather than put an insertion point in the text.
Note: After you draw an object, FrameMaker XML Author reverts to the Smart Select tool. If you want to keep the Select Object tool active after drawing an object, Shift-click the tool on the Tools panel.

More Help topics
“Keys for selection” on page 379

Select an object or multiple objects
❖ Do one of the following:
  • To select one object, click it. If the object is transparent—that is, if it has a fill pattern of None—click its border. When you click overlapping objects, FrameMaker XML Author selects the object in the foreground.
  • To select several objects, point outside the objects and drag diagonally to draw a selection border around them. All objects you want to select must be completely within the selection border.

Drag to select several objects.

Note: If you move the object rather than draw a selection border (because the pointer was over an object), immediately choose Edit > Undo. Then press Shift-drag to draw a selection border.

  • To select all objects in a graphic frame, select the frame or any object in the frame, and then choose Edit > Select All in Frame.
  • To select all objects on a page, click outside any objects or text on the page and choose Edit > Select All on Page.

Deselect objects
❖ Do one of the following:
  • To deselect an object, click outside the object.
  • To deselect one of several selected objects, Shift-click the object (not a handle). You can also Control-click the object.
  • To deselect all selected objects, drag-and-drop the page away from any objects.
  • To deselect several objects in the same area, point outside all the objects and Shift-drag diagonally to draw a selection border around the objects. When you release the mouse button, all objects that are completely within the selection border are deselected. If any objects within the selection border were not selected when you began dragging, they are selected.

Apply and change drawing properties
An object’s drawing properties include the fill pattern, pen pattern, line width, line ends, color, and whether the line is solid or dashed. You change drawing properties from pop-up menus on the Tools panel.
You can change drawing properties before you draw an object, or you can select objects that you’ve already drawn and then change their properties. After you change a property, it becomes the current property—that is, it will be applied to any object you draw. For example, if you choose a line width of 1 point, this is applied to all newly drawn objects until you choose another line width or exit FrameMaker XML Author.

You can make objects look alike by applying one object’s properties to another object.

You can also change the colors in the Color pop-up menu and customize the following choices that appear on the Tools panel:

- The values assigned to the line widths that appear in the Line Widths pop-up menu.
- The Line end style, which determines the appearance of any line ends that don’t have an arrowhead.
- The pattern that FrameMaker XML Author uses when you choose the dashed line style from the Line Styles pop-up menu. (The pattern that appears in the pop-up menu doesn’t change, but FrameMaker XML Author uses the new pattern.)

The new line width settings remain until you change them. The other new settings remain until you change them or exit FrameMaker XML Author.

None of the changes described here are applied automatically to existing objects. However, you can apply the new settings to both new and existing objects.

Note: Dashed line pattern and polylines may appear solid on screen and in print if the lines are especially thick and contain acute angles or have round or projecting caps. To make the lines print correctly, change the Line Ends Options setting to Butt, use a smaller line width, or redraw the object using separate lines.

More Help topics
“Change line width settings” on page 158
“Work with color in objects” on page 171
Apply a fill pattern or pen pattern to a selected object
❖ Choose the pattern from the Fill Pattern pop-up menu or Pen Pattern pop-up menu. You can fill any objects except lines, text lines, and equations.

A. Pen pattern  B. Fill pattern

The eight gray fill and pen patterns have the following percentages: 100, 90, 70, 50, 30, 10, 3, and 0 (no ink, typically white).

💡 To make an object transparent (so objects in back of it show through), choose a fill pattern of None. If you don’t want the object to have a border, choose a pen pattern of None. To see the border of an object that uses both a pen and a fill pattern of None, choose View > Borders.

Choose a line width for a line or an object’s border
❖ Choose a width from the Line Widths pop-up menu. You can change the line width of any object except text lines.

Change the ends of an arc, a line, a polyline, or a freehand curve
❖ Choose the line end from the Set Line End Style pop-up menu. You can use no arrowhead or place an arrowhead at the beginning, at the end, or at both ends.

Make a line or object’s borders solid or dashed
❖ Choose a solid or dashed style from the Dashed Line Pattern pop-up menu.

Inspect an object’s drawing properties or apply them to other objects
1 Select the object that has the properties you want to inspect or copy.
2 Hold down Shift and choose Graphics > Pick Up Object Properties. The properties of the selected object become the current properties on the Tools panel. Any object you draw picks up those properties.
3 To apply the properties to existing objects, select the objects you want to change. In the Tools panel, click the current drawing properties you want to apply to the selected objects.
Change line width settings
1 Choose Set from the Line Width pop-up menu on the Tools panel.
2 Do one of the following:
   • To change the line widths, enter the new line widths and click Set. You can enter the values in any order. When you click Set, the line widths are sorted from smallest to largest. The widths that appear in the pop-up menu don’t change.
   • To revert to the line widths you had when you started FrameMaker XML Author, click Get Defaults.

Change the line end style
1 Choose Set from the Set Line End Style pop-up menu on the Tools panel.
2 Select a line end style and click Set.

Change the dashed line style
1 Choose Set from the Set Dashed Line Pattern pop-up menu on the Tools panel.
2 Click one of the patterns and click Set.
You can also create custom dashed line pattern.

To create a dotted line that uses round dots, use a dashed line pattern of short dashes with a round line cap.

Change the arrow style
You can choose from among several preset arrow styles. Arrow styles are determined by their base angle, tip angle, and length.
None of the changes described here are applied automatically to existing objects. However, you can apply the new arrow style to both new and existing objects.

1. Choose Set from the Set Line End Style pop-up menu on the Tools panel.
2. Do one of the following:
   • Click a preset arrow style and click Set.
   • Fill in a custom base angle, tip angle, length, and style, and then click Set. You can use the following values for the custom options.

<table>
<thead>
<tr>
<th>Option</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>Base Angle</td>
<td>Between 10 and 175 degrees (and at least 5 degrees greater than the tip angle)</td>
</tr>
<tr>
<td>Tip Angle</td>
<td>Between 5 and 85 degrees</td>
</tr>
<tr>
<td>Length</td>
<td>Between 0 and 255 points</td>
</tr>
<tr>
<td>Style</td>
<td>Filled, Hollow, Stick</td>
</tr>
</tbody>
</table>

FrameMaker XML Author ignores the Base Angle option when you use Stick. The length you specify applies to objects that have a line width of 1 point. When you use a thicker line width, the arrowhead is longer.

The following table contains sample custom arrows and their settings.

<table>
<thead>
<tr>
<th>Arrow</th>
<th>Base Angle</th>
<th>Tip Angle</th>
<th>Length</th>
</tr>
</thead>
<tbody>
<tr>
<td>➤</td>
<td>70 degrees</td>
<td>30 degrees</td>
<td>10 points</td>
</tr>
<tr>
<td>➤</td>
<td>80 degrees</td>
<td>30 degrees</td>
<td>10 points</td>
</tr>
<tr>
<td>➤</td>
<td>70 degrees</td>
<td>15 degrees</td>
<td>10 points</td>
</tr>
<tr>
<td>➤</td>
<td>70 degrees</td>
<td>30 degrees</td>
<td>5 points</td>
</tr>
<tr>
<td>➤</td>
<td>120 degrees</td>
<td>30 degrees</td>
<td>5 points</td>
</tr>
</tbody>
</table>

**Add text to graphics**

You can add single lines of text or text frames to a graphic.
A text line is a single line of text that FrameMaker XML Author treats independently from other text. Text lines grow or shrink in length as you edit them, but they don’t wrap to the next line. You typically use text lines for single-line callouts and for text you want to resize in the same way that you resize other objects.

You can assign character formats and a spell-checking language to text lines. However, text lines can’t have paragraph formats, and they can’t contain anchored frames, markers, variables, cross-references, or conditional text.

Unlike a text line, a text frame can contain more than one line of text. You use text frames for multiline callouts, paragraphs of text, and any other text you want FrameMaker XML Author to wrap automatically from line to line. When graphics overlap text in a text frame, you can run the text around the graphics.

When you resize a text frame created with the Text Frame tool, the font size remains the same. However, when you resize a text line created with the Text Line tool, the font height and width change proportionally.

More Help topics
“Resize and reshape objects” on page 166

Add a text line to a graphic

1. Click the Text Line tool. The pointer changes to a crossed I-beam when you move it to the document window. The small horizontal line across the pointer indicates the baseline position of the text.

2. Click in the document to place an insertion point, and then type the text. FrameMaker XML Author uses the last character format you typed or selected in the document.

The text line is left aligned on its alignment point (where you clicked).

❖ To create several text lines, press Return at the end of one text line to create another. You can then select the text lines independently and move them as needed.

Add a text frame

1. Click the Text Frame tool.

2. Drag diagonally where you want to add the text frame.

3. Specify the number of columns and the gap between them, and then click Set.

4. Double-click in the text frame to place an insertion point in it, and then type the text.

Fix text frames that overflow

When the text you type overflows the text frame, the insertion point moves below the bottom of the frame and the new text doesn’t appear. The bottom border of the text frame appears as a solid line when borders are visible.
You can enlarge the frame so the text fits, or you can connect the flow of the text frame to another frame. You can also decrease the font size of the text.

1. Control-click the text frame to select it.
2. Drag a handle to enlarge the frame.

Create reverse text in a text frame

You can create reverse text (text that appears in a light color on a dark background) for special emphasis. The reverse text can be in a text frame or a text line.

1. Set the desired fill pattern and color of the text frame.
2. Set the text frame’s pen pattern to None.

Create a reverse text line over an object

1. Draw an object to act as the background for the text. Generally, it’s best to use a nearly black fill pattern for the object.
2. Outside the background object, add a text line and type its text.
3. Control-click the text line to select it.
4. Move the text line so part of it disappears into the background object.
5. Choose a light color from the Color pop-up menu on the Tools panel. The text appears partially cut out of the background object.

   If the text doesn’t appear in front of the object, choose Graphics > Bring to Front. If you still have trouble, make sure that the current color view of the document shows the text line’s color as Cutout.

6. Move the text line so all its letters appear cut out of the background object.
Add a title to an illustration
You can include a text line or text frame in a graphic as a title. You can also use a paragraph above or below an anchored frame as a title for the frame’s graphic. However, you may find it easier to use table commands instead.

Copy and arrange objects

Cut, copy, or paste an object by using the clipboard
1 Select the object and choose Edit > Cut, or Edit > Copy.
2 Do one of the following:
   • To paste the object on a page, click in the margin of the page.
   • To paste the object in an existing graphic frame, click the frame’s border to select the frame.
   • To paste the object in text, click in the text where you want to paste the object.
3 Choose Edit > Paste. When you paste the object in a graphic frame or on a page that is the same size as the one from which you copied or cut the object, FrameMaker XML Author puts the object in the same relative location. Otherwise, FrameMaker XML Author centers the object.

When you paste an object into text, FrameMaker XML Author creates an anchored frame to hold the object, and centers the object in the frame. An anchor symbol appears at the insertion point when text symbols are visible.

Copy an object by dragging
1 Select the object.
2 Point on the object (not on a handle), and Alt-drag the duplicate of the object, or right-drag the object and then choose Copy Here from the menu. To constrain the duplicate’s movement to either a horizontal or vertical direction, hold down Shift while you drag.

Delete an object
❖ Select the object and press Delete.

Move an object
1 Select the object.
2 Do one of the following:
   • Drag in the direction you want to move the object.
   • To move the object horizontally or vertically, Shift-drag.
   • To move an object into a graphic frame, drag it until the pointer is in the frame.
- To move an object out of a graphic frame, drag it until the pointer is outside the frame. As you drag, the frame's border may temporarily crop the object.

When you drag the object, the status bar shows the distance from the upper-left corner of the object to the upper-left corner of the page (or frame, if the object is in a graphic frame). When rulers are visible, lines in the rulers show you the object's position. If the snap grid is on, objects snap to the invisible grid as you drag them.

*If your screen does not redraw properly when moving an object, press Ctrl+L (lowercase L) to redraw the screen.*

- To move an object in small increments, hold down Alt and press an arrow key to move 1 point, or hold down Alt+Shift and press an arrow key to move 6 points. However, do not use an arrow key on the numeric keypad. The preceding distances assume a 100% zoom setting. The actual distance moved depends on the current zoom setting, so you can do finer work when you're zoomed in closer. For example, at 200% zoom, the distance is halved. At 50% zoom, the distance is doubled.

- To specify the exact position of an object, select the object, choose Graphics > Object Properties, do one of the following and apply the changes:
  - For all objects except text lines and equations, specify the offset from the top and left edges of the page or graphic frame in the Offset From area.

```
A. Offset from left  B. Offset from top
```

- For text lines and equations, specify the offset in the Alignment Point Offset area.

```
A. Offset from left  B. Offset from top
```

### Align text lines

When you create a text line, it is left aligned on its alignment point (where you clicked). You can change the alignment to centered or right aligned. FrameMaker XML Author then maintains the text line's alignment when you insert text.

1. Select the text line and choose Graphics > Object Properties.
2. Choose a new alignment from the Alignment pop-up menu and click Align.
Make lines intersect cleanly
Lines intersect cleanly when they are the same thickness, meet at right angles, and use a projecting cap; lines don’t intersect cleanly when they use a projecting cap but don’t intersect at right angles. Notice the different intersections created by using the three line cap styles.

❖ Do one of the following:
  • If the lines don’t meet at a right angle, try a round cap for both lines.
  • If the lines aren’t the same thickness, try a butt cap for the thinner line when the lines meet at their endpoints and for the stem of a T when they meet in a T.

For information on changing the line cap style, see “Change the line end style” on page 158.

More Help topics
“Apply and change drawing properties” on page 155

Crop or mask graphics
When you want to crop the edges of a graphic, place the graphic in an anchored or unanchored graphic frame. An anchored graphic frame moves with the surrounding text. An unanchored graphic frame stays wherever you place it on a page, even when the text around it moves as the result of editing.

Uncropped and cropped graphics in graphic frames

When you want to mask an area of a graphic, particularly if the part you want to mask is in the middle of a graphic, you can cover the area with nonbordered objects.

More Help topics
“Create anchored frames” on page 173

Crop the edges of a graphic frame
1 Do one of the following to create a graphic frame:
   • To create an unanchored frame, click the Graphic Frame tool on the Tools panel and then drag to draw the frame. To draw a square frame, Shift-drag.
   • To create an anchored frame, use Special > Anchored Frame.
2 Do one of the following to put the graphic in the frame:
   • Drag the graphic into the frame.
   • Select the graphic, choose Edit > Copy or Edit > Cut, select the frame border, and then choose Edit > Paste.
3 Resize the frame around the graphic.
Mask an area within a graphic frame
❖ Put graphic objects (such as rectangles and polygons) with a white fill and pen pattern in front of the parts you want to mask.

Measure object size and position
As you arrange and resize objects in an illustration, you may want to know an object’s dimensions and exact position.
The size of an object is the size of the rectangle that encloses its path. The position is the distance from the top and left edges of the page or graphic frame.

Measure an object
❖ Do one of the following:
  • Select the object and choose Graphics > Object Properties. The width and height of the object appear in the Size area of the Object Properties dialog box.
  • With Snap off, select the object, point on one of its handles, and hold down the mouse button. The dimensions appear in the status bar. If you move the mouse by mistake and resize the object, immediately choose Edit > Undo.

View the position of an object
1 Select the object.
2 Choose Graphics > Object Properties. For all objects except equations and text lines, the distance from the upper left corner of the page or graphic frame to the object’s topmost and left-most point appears in the Offset From area. For equations and text lines, the distance from the upper left corner of the page or graphic frame to the alignment point at the baseline of the text line or equation appears in the Alignment Point Offset From area.

View the position of an object as you move it
❖ Look in the status bar. The distance between the object and the upper-left corner of the page or graphic frame appears in the status bar. When rulers are visible, guidelines in the rulers also show the position of the object.

Measure any distance on the page
1 Point where you want to start measuring.
2 Shift+Control-drag to force a selection border to appear, but don’t release the mouse button.
3 When the selection border encompasses the area you want to measure, look in the status bar for the dimensions.
Dimensions appear in the status bar.

In the example, the important dimension is the height (35 points between the bases of the triangles).

**Resize and reshape objects**

As you refine a graphic, you can change the size and shape of objects. Reshaping possibilities are unlimited. For example, you can add a corner to a polyline or polygon, move a corner to change its shape, and smooth a polyline to create a freehand curve.

![Original polygon and then with corner added](image1)

![Corner moved and then smoothed](image2)

You can resize all objects, including text lines. When you resize a text frame created with the Text Frame tool, the text remains the same size. When you resize a text line created with the Text Line tool, the font height and width change proportionally.

![Before and after resizing a text line (not a text frame)](image3)

You can change the shape of lines, polylines, polygons, curves, and arcs as follows:

- Reshape a line, polyline, or polygon by moving its corners one at a time. You can also add and remove corners.
• Reshape a curve by changing the position of its reshape handles (which define the curve and control its location) and its control points (which adjust the curvature). You can also add and remove reshape handles to change the number of points that define the curve.

A. Reshape handle  B. Control point

• You reshape an arc by dragging its endpoints or by changing the percentage of a circle that the arc represents.

**Resize an object by dragging**

❖ Select the object and do one of the following:
  • To change either the width or the height, drag a side handle.
  • To change both the width and the height, drag a corner handle.
  • To increase or decrease the dimensions proportionally, Shift-drag a corner handle.

The object’s dimensions appear in the status bar as you drag.

**Resize an object precisely**

1 Select the object and choose Graphics > Scale.

2 Do one of the following:
  • To increase or decrease the height and width proportionally, enter a scale factor and click Scale. The scale factor is always relative to the object’s current size (100% means no change).
  • To specify the exact dimensions you want, enter the dimensions and click Scale. The dimensions shown when you display the dialog box are the object’s current (unrotated) dimensions.

**Resize imported graphics**

You can resize imported graphics back to the original size. You can also change the size of imported bitmap graphics.

**Resize your imported graphics back to 100%**

1 Select the object and choose Graphics > Object Properties.

2 For Scaling Percent, type 100%, and click Set.

**Change the size of bitmap graphics**

Changing the dpi value or the scaling factor changes the size of a bitmap graphic.

❖ Do one of the following:
  • Select the bitmap, choose Graphics > Object Properties, and click Set dpi.
  • Shift-drag a corner handle of the bitmap. Holding down Shift while you drag maintains the proportions of the graphic.
Note: If the graphic is a TIFF file (or other format that uses dpi settings), scaling must be done through the Object Properties to ensure that the dpi value is not lost when scaled using the Scale dialog.

Move a corner of a polyline or polygon
1 Select the object and choose Graphics > Reshape. Reshape handles appear on the object, replacing the selection handles.
2 Drag a handle. To move the handle horizontally or vertically, Shift-drag.

Add or remove a corner or reshape handle
1 Select the line, polyline, polygon, or curve, and choose Graphics > Reshape.
2 Control-click where you want to add a reshape handle (or corner), or Control-click the handle you want to remove.

Change the corner radius of a rounded rectangle
You can define the curvature of the corners of a rounded rectangle by specifying the radius of an imaginary circle drawn in the corner of a rectangle. The longer the radius, the more curved the corners.

![Radius comparison](image)

When you specify a corner radius, you also change the current drawing properties. New rounded rectangles you draw have this corner radius until you change it with the Object Properties command or until you exit FrameMaker XML Author.
1 Select a rounded rectangle and choose Graphics > Object Properties.
2 Enter the corner radius and click Set. The largest meaningful radius is one-half the length of the shortest rectangle side. For example, if the rectangle is 2 inches by 4 inches, the largest meaningful radius is 1 inch (one-half of 2 inches).

Smooth and unsmooth objects
You can smooth polylines, polygons, rectangles, and rounded rectangles. When you smooth a polyline, polygon, or rectangle, you change its angles to smooth curves. When you unsmooth a curve, you restore its angles.
Each time you smooth a rounded rectangle, you increase the curvature of its corners (its corner radius).

❖ Do one of the following:
  • To smooth an object, select the object and choose Graphics > Smooth. After smoothing a polygon or polyline, reshape handles and control points appear so you can reshape the curve.
  • To unsmooth an object, select the object and choose Graphics > Unsmooth. If you later smooth the object, its shape is sometimes different from the original.

Scaling Images

An image can be resized by changing either the height, width, or the scaling attributes. In a DITA topic, you can access the height, width, and scaling attributes from the Object Properties or Attributes dialog.

Consider the following points while changing the image size attributes in the Object Properties dialog:
  • If you change the height, width, or both, then you must click the Apply button for the changes to take effect.
  • If you change the height, width, and scaling attributes, then the values present in the height and width attributes take precedence over the scaling attribute.
  • If you specify only the scaling attribute, then the height and width of the image is proportionately adjusted. Also, the values in the height and width attributes are updated according to the scaling factor.

Consider the following points while changing the image size attributes in the Attributes dialog:
  • If you specify a value in the height or width attribute and move the focus to any other attribute, the image is resized immediately.
  • To scale an image, you must delete any value present in the height and width attributes, and then specify a value in the scale attribute.
  • If a value is present in the height or width attribute, and you change the scale attribute, then the image would not be scaled. The value present in the height or width attribute takes precedence over the value specified in the scaling attribute.

Using color in text and objects

About color and color models

Before you begin

Applying color to frames and objects is a common publishing task, whether you are publishing in print or exporting to the web. FrameMaker XML Author provides color libraries to choose from colors defined by a color vendor. You define and modify colors by adjusting the color model you’re using or by choosing a predefined ink from a color library based on the color model.
Before applying color to your documents, prepare in these ways:

Identify the output format of your document  The final output of your color document can greatly affect color decisions:

- For online output, use the RGB or HLS color models. Your guide to correct color is how your documents look on your monitor.
- For desktop printing, use the CMYK model to define your colors and test them on the printer you’ll be using.
- For commercial printing, use colors from a library supported by your commercial printer. Don’t rely on the onscreen versions of library colors; use a swatch book.

Learn the limits of the medium  Become familiar with the range of colors available on your monitor or printer. For example, a system set to display 256 colors cannot display tints below 16% accurately in FrameMaker XML Author.

By default, FrameMaker XML Author publishes CMYK values when printing or saving as Adobe PDF. If you opt to use RGB values while saving as a PDF, FrameMaker XML Author converts colour values to RGB and creates separations in equivalent RGB values. EPS graphics, however, are separated according to the color values specified within the EPS graphic itself.

FrameMaker XML Author retains the color values specified within Encapsulated PostScript (EPS) graphic objects, including CMYK colors, RGB colors, grayscale, spot colors, device-independent colors (such as CIE L*a*b color). The graphical information within an EPS file is passed directly into the output PostScript stream, bypassing any Windows GDI processing. EPS graphic objects can be created from text, vector graphics, or images of any type supported by Adobe PostScript. This capability allows EPS graphics to be saved or exported from many Adobe applications, as well as other third-party application programs.

Color models  When you use a color model to define colors, you manually adjust its components, such as the amount of pure red or the amount of saturation.

You can choose from three color models: CMYK, RGB, and HLS.

CMYK  Use the CMYK model to create color separations for four-color process printing. Colors are created by combining cyan, magenta, yellow, and black (CMYK) inks. In color separation, each color component is printed on a separate plate, in a different concentration, depending on the desired color.

RGB  Use the RGB model to create colors that are viewed on a monitor (for example, for online documentation). Colors are created by combining red, green, and blue (RGB) light.

HLS  Use the HLS model if you are familiar with color wheels. This model is most like the one artists use to mix colors and is often used in software color pickers. Colors are created by adjusting hue, lightness, and saturation (HLS). Hue controls the amount of red, green, yellow, blue, and so on. Lightness controls the lightness or darkness of a color. Saturation controls the amount of gray in the color.

Manage color libraries  When you use a color matching system—a color library—you choose from colors defined by a color vendor. Commercial printers can precisely match the formula represented in a vendor swatch book.

Every color from a library is defined as either a spot color or a process color. A spot color is printed on a printing press with premixed inks by using a single printing plate. A process color is printed on a press by overlapping dots of cyan, magenta, yellow, and black (CMYK) on separate plates.

Before choosing a color from a color library, ask your commercial printer for a list of supported libraries. For best results, choose colors from a swatch book, rather than relying on the onscreen representation of the color.
FrameMaker XML Author includes these libraries:

**Crayon** Adobe developed the Crayon library to provide access to common RGB colors using everyday names in alphabetical order. Do not use Crayon colors as spot colors.

**DIC** The DIC Color Guide provides spot colors. It is used mostly in Japan.

**FOCOLTONE** The FOCOLTONE Color System provides 860 process (CMYK) colors.

**Grays** The Grays library, developed by Adobe, provides both process and spot shades of gray in 1% increments.

**MUNSELL** The Munsell System provides colors defined on the RGB model.

**Online** The Online color library provides 216 “web-safe” colors that have a consistent appearance on all platforms when viewed with a web browser.

**PANTONE** Most of the libraries in the PANTONE MATCHING SYSTEM are for spot colors. Only the two PANTONE process libraries are for selecting process colors. Separate PANTONE libraries are available for colors that are printed on coated and uncoated paper. The PANTONE ProSim Euro library uses color definitions that match the printing systems prevalent in Europe.

**TOYO** The TOYO Color Finder provides over 1000 colors based on the most common printing inks in Japan.

**TRUMATCH** The TRUMATCH 4-Color Selector provides over 2000 process colors that cover the CMYK visible color spectrum in even steps.

### Add a color library for use in FrameMaker XML Author

You can add any library file formatted in the ASCII Color Format (.acf), version 2.1 or earlier, or in the Binary Color Format (.bcf), version 2.0. You can’t use FrameMaker XML Author to save a .bcf library file.

✧ Place the library file into the Fminit\Color folder and restart FrameMaker XML Author.

### Work with color in objects

The method you use to apply a color or a lightened version of a color (a tint) depends on the current selection. Any entry in a Color pop-up menu can be applied to FrameMaker XML Author text or objects. FrameMaker XML Author supplies a set of 16 standard colors that you can add to.

You can apply to:

- **Object-level tints** are tints you apply to an object that lighten the original color of the object by a specified percentage.

*Note: You can’t colorize TIFF files.*

### Apply a color or tint to text or an object using formatting features

1. Select the text or object to color or tint.

2. The Tint and Color pop-up menus on the Tools panel. The following table shows what features to use for tasks that vary:

<table>
<thead>
<tr>
<th>To apply color or tint to</th>
<th>Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cells in a table</td>
<td>The Color pop-up menu in the Custom Ruling and Shading dialog box, or in the Table Designer</td>
</tr>
<tr>
<td>Change bars</td>
<td>The Color pop-up menu in the Change Bar Properties dialog box</td>
</tr>
<tr>
<td>Conditional text</td>
<td>The Color pop-up menu and the New Color button in the Edit Condition Tag dialog box</td>
</tr>
<tr>
<td>All drawn objects and text</td>
<td>The Color pop-up menu in the Tools panel (hold down Shift+Alt and choose a color).</td>
</tr>
</tbody>
</table>
Apply a tint to an object using a fill pattern

1. Select the object you want to tint.

2. Choose one of the first eight fill patterns from the Fill pop-up menu on the Tools panel. The fill patterns apply the following percentages to the current color of the object.

<table>
<thead>
<tr>
<th>Fill Pattern</th>
<th>Tint Percentage</th>
</tr>
</thead>
<tbody>
<tr>
<td>[Diagram]</td>
<td>100%</td>
</tr>
<tr>
<td>[Diagram]</td>
<td>90%</td>
</tr>
<tr>
<td>[Diagram]</td>
<td>70%</td>
</tr>
<tr>
<td>[Diagram]</td>
<td>50%</td>
</tr>
<tr>
<td>[Diagram]</td>
<td>30%</td>
</tr>
<tr>
<td>[Diagram]</td>
<td>10%</td>
</tr>
<tr>
<td>[Diagram]</td>
<td>3%</td>
</tr>
<tr>
<td>[Diagram]</td>
<td>0% (color of paper)</td>
</tr>
</tbody>
</table>

Set up and display color views

A color view specifies which colors are visible. For example, if your document uses black and a spot color, one view could display both colors and another view could display only the spot color.

For each view you set up, specify which colors you want to display, which to display as cutouts, and which not to display at all. Cutouts display as white when overlapping different colored objects.

1. Make the appropriate document window or book window active. If a book window is active, select the documents you want to affect.

2. Choose View > Color > Views.

3. Select a view number and move the color names to the appropriate scroll lists. Tints do not appear in this dialog box; they appear along with the color they were based on.
To move a color, select it and click an arrow, or double-click it. To move all colors, select a color and Shift-click an arrow. To reset any changes you’ve made, click Get Default.

Leave View 1 unmodified, with all colors (except white) in the Normal scroll list. When you draw an object in a color that is invisible in the current view, FrameMaker XML Author automatically switches to View 1.

4 Repeat step 3 for each view you want to set up, and then click Set. The currently selected view is displayed.

### Anchored frames

#### About anchored frames

You often want to keep an illustration with particular document text. In FrameMaker XML Author, you do this by putting the illustration in a graphic frame anchored to the text—an anchored frame. When you edit the text, the frame and its contents move along with the text automatically.

You can use an anchored frame for an illustration in a column of text—below the line that contains the anchor symbol ▼, or at the top or bottom of the column. You can use an anchored frame for small graphics that appear in line with paragraph text or for art that appears between columns or in the page margin.

You can also use an anchored frame to achieve special effects such as positioning an anchored frame in the top corner of a paragraph with the paragraph text running around the graphic.

If you want an illustration to stay at a specific place on the page—for example, as a logo on letterhead stationery—don’t use an anchored frame. Instead, draw, paste, or import the illustration directly onto a body page without placing an insertion point in the text. Then move the illustration to the desired position.

By default, an anchored frame has no pen or fill pattern, which makes it invisible on the page unless borders are visible.

#### Create anchored frames

An anchored frame is created automatically when you paste or import a graphic at an insertion point. You can keep the properties assigned to the frame, or you can change them.

When you create an anchored frame using the Special > Anchored Frame command, you specify the location of the frame and its size and position. You can also specify other properties that depend on the frame’s position. For example, when the frame is placed in the line at the insertion point, you can specify its distance from the baseline of the text. When the frame is placed in a column of text, you can specify its alignment. You can change any of the properties, including the frame’s position, at any time.
When you create an anchored frame, you can use Object Properties to set unique tags to your anchor. These tags simply create a structure for the layout of your document. You can uniquely define an element for your frame that maps to tags in PDF format.

When you tag your document, you name each document property. Using tags allows you to easily change the appearance of your document without changing the content.

**Create an anchored frame automatically**

❖ Do one of the following:

- Paste an object into text at the insertion point by cutting or copying the object, clicking in text where you want to insert the anchor symbol, and choosing Edit > Paste.
- Import a graphic into text by clicking in text, choosing File > Import > File, and selecting the graphic file you want to import. You can also import a graphic in other ways, depending on the platform. (See “Import and link methods” on page 233.)

The pasted or imported object appears in an anchored frame that is centered below the current line. After the frame is created, you can change its properties.

**Create an anchored frame with specific options**

1 Click in text where you want to place the anchor symbol and choose Special > Anchored Frame. You can create an anchored frame in a text frame or in a table cell, but not in a text line.

2 Choose the frame’s anchoring position and specify its properties. The properties that appear in the Anchored Frame dialog box depend on the anchoring position.

3 Click New Frame. An anchor symbol appears at the insertion point when text symbols are visible.

**Inline anchored frames**

To position an anchored frame in line with paragraph text—for example, to hold a small graphic such as a picture of a keycap—choose the At Insertion Point anchoring position in the Anchored Frame dialog box. When you put a space on either side of the anchored frame, the frame moves along from one line to another as you edit the document, as if it were a word (rather than being attached to the preceding or following word).

You can adjust the frame’s position up or down relative to the baseline of text by dragging the frame or by specifying a value for the Distance above Baseline option in the Anchored Frame dialog box. A value of zero aligns the bottom of the frame with the baseline of the text. A positive number moves the frame up; a negative number moves it down.

If the frame obscures text in the line above or below, turn off fixed line spacing to allow the line height to change with the contents of the line.

Last updated 8/18/2015
To shrink an anchored frame to the dimensions of its contents and place it in the line at the anchor symbol, select the frame or an object in the frame and press Esc m p. To enlarge a frame and place it below the line that contains the anchor symbol, select the frame or an object in it and press Esc m e.

**Anchored frames in a column of text**

To position an anchored frame in a column of text, choose the Below Current Line, At Top of Column, or At Bottom of Column anchoring position in the Anchored Frame dialog box.

An anchored frame positioned at the top or bottom of the column moves only when its anchor symbol moves to another column.

**Important:** To place an anchored frame below a line that contains a run-in head, place the anchor symbol in the body paragraph, not in the run-in head. Otherwise, the anchored frame obscures the text below the run-in head.

When you choose the Below Current Line, At Top of Column, or At Bottom of Column anchoring position, you can set the following properties.

**Horizontal alignment** Choose the frame’s horizontal alignment from the Alignment pop-up menu. You can align the frame at the left, center, or right. In a double-sided document, you can also align the anchored frame closer to or farther from the binding edge.
**Cropping** To prevent a wide frame from extending beyond the edge of the column, use the Cropped option.

**Floating** Use the Floating option to let the frame float to the next column that can hold it if the frame and its anchor symbol won’t fit in the same column.

When Floating is off, both the frame and anchor symbol move to the first column that can hold them. White space remains at the bottom of the column. When Floating is on, the anchor symbol doesn’t move, but the frame floats to the next column that can hold it. Text from the next column fills the space between the anchor symbol and the frame.

**Anchored frames in multicolumn layouts**
An anchored frame in a multicolumn text frame can straddle columns, and its position may be affected by straddle paragraphs.

**In a straddle paragraph** When a frame is anchored in a straddle paragraph, the frame straddles columns just as the paragraph does.

**Wider than a column** An uncropped anchored frame that extends into a second column of the body area straddles columns in the body area. A frame that extends into the side-head area straddles the side-head area as well.
A cropped anchored frame straddles columns only when it’s anchored in a straddle paragraph.

**At top or bottom of column** When the anchor symbol for a top-of-column anchored frame appears below a straddle paragraph, the frame appears in the column just below the straddle paragraph rather than at the top of the column.

A bottom-of-column anchored frame is positioned similarly when the anchor symbol appears above a straddle paragraph.

You can force the anchored frame to appear at the top or bottom of the column (above or below a straddle paragraph) by making the frame straddle the columns. To do so, turn off Cropped in the Anchored Frame dialog box and resize the anchored frame until it extends into another column.

**Anchored frames outside a column of text**
To position an anchored frame outside a column of text, choose the Outside Column anchoring position in the Anchored Frame dialog box. For information on positioning an anchored frame so it always appears in the page margin, even in a multicolumn document.

When you choose the Outside Column anchoring position, you can set the following properties.

**Side of column** You can position the anchored frame at the left or right side of the column, or along the side that’s closer to or farther from the edge of the page.
Anchored at left and at right

For a double-sided document, you can also position the frame closer to or farther from the binding edge.

Farther from binding

**Distance above baseline** You can adjust the frame’s position up and down relative to the baseline of text by dragging the frame or by specifying a value for the Distance above Baseline option in the Anchored Frame dialog box. A value of zero aligns the bottom of the frame with the baseline of the text. A positive number moves the frame up; a negative number moves it down.

Zero distance and negative distance above baseline

You can’t position the anchored frame above the top or below the bottom of the text frame. If the setting would place the anchored frame above or below the text frame, FrameMaker XML Author puts it as high or as low as possible. If you later edit the text so that the anchor symbol moves away from the top or bottom of the text frame, FrameMaker XML Author adjusts the anchored frame’s position.

**Distance from column** You can adjust the frame’s position left and right relative to the edge of the column by dragging the frame or by specifying a value for the Distance from Column option in the Anchored Frame dialog box. A value of zero aligns the edge of the frame with the edge of the column. A positive number moves the frame away from the column; a negative number moves it into the column.
The distance is always relative to the edge of the column, so the frame may appear between columns on a multicolumn page. You can change the page margins and column layout to widen the gap between columns to make room for the frame. Or, if you’re working in a structured document, see your developer to widen the gap between columns to make room for the frame.

**Anchored frames in the page margins**

To position an anchored frame so it always appears in the margin (even in a multicolumn layout), choose the Outside Text Frame anchoring position in the Anchored Frame dialog box. You can then specify the options described in the previous section. However, the distances you specify are from the edge of the text frame, which may differ from the edge of the text column on multicolumn pages.

In a single-column layout, the Outside Text Frame option has the same effect as the Outside Column option.

**Anchored frames run into paragraph text**

To position an anchored frame in the top corner of a paragraph (with the paragraph text in that column running around the frame), choose the Run into Paragraph anchoring position in the Anchored Frame dialog box. For example, you can set a small graphic or a drop cap at the beginning of a paragraph.

When the anchored frame is taller than the paragraph, the text from subsequent paragraphs runs around the frame unless the paragraph that contains the anchor symbol is a straddle paragraph.
When you choose the Run into Paragraph anchoring position, you can set the following properties:

**Alignment** You can align the anchored frame on the left or right side of the paragraph. For a double-sided document, you can also choose Side Closer to Binding or Side Farther from Binding.

The frame is aligned with the paragraph’s left indent when it appears at the left side of the paragraph, and with the right indent when it appears at the right side. When the paragraph has a first-line indent, the anchored frame does not change the position of the indent.

*Closer to binding*

*Graphic extending beyond first-line indent*

*Larger first-line indent*
When you want to preserve a first-line indent, make the first-line indent setting for the paragraph larger than the width of the anchored frame. Or, if you’re working with a structured document, see your developer about making the first-line indent setting for the paragraph larger than the width of the frame.

**Gap**  You can specify the gap between the anchored frame and the paragraph text that runs around it.

**Insert anchored frames in structured documents**

In a structured document, a graphic element provides an anchored frame for holding graphic objects. The frame is anchored to a specific location in text. As you edit the text, the frame and its contents move in the document along with the text.

When inserting a graphic element, you specify where you want to anchor the element’s frame. For example, you might anchor the frame in a Para element (and the graphic will be a child element to the Para), or you might anchor it in a Section element (as a sibling to Para and other elements in the Section). It depends on how the elements are defined for your document. The formatting properties you set are independent of the element’s format rules, not overrides to them.

In the document window, an anchor symbol **appears at the anchor location in text when View > Text Symbols is turned on. The frame can appear in various positions on the page—including in-line with text, next to or below a paragraph, or in a page margin. You specify an anchoring position relative to the anchor symbol.**

![Several positions for anchored frames](image)

A graphic element appears in the document’s structure where it is anchored to text, regardless of the frame’s position on the page. In the Structure View, the element is represented by a square-cornered bubble with the snippet `<GRAPHIC>`.  

![Graphic element](image)

**Insert an anchored frame element**

1. Click where you want to anchor the frame.
2. Select an anchored frame element in the Element Catalog and click Insert.
   
   You can also use Special > Anchored Frame to insert an element. If more than one frame element is available, choose the one you want from the Element Tag pop-up menu in the Anchored Frame panel.
3. Choose the frame’s anchoring position and specify its size and formatting properties. The properties that appear in the dialog box depend on the anchoring position you choose. See “Inline anchored frames” on page 174 for details.
Click New Frame. The anchored frame appears in the document window, with an anchor symbol at the insertion point when View > Text Symbols is turned on. A bubble with the text snippet <GRAPHIC> appears in the Structure View.

If no anchored frame element is available at the location you want, you might use an invalid element. After inserting the element, talk to your developer about making the element valid at this location.

**Use an invalid anchored frame element**

Do one of the following:

- To use an element that is valid in another part of the document, either insert the element in a valid location and then move it, or use the All Elements setting to make the element available everywhere, and then insert the element where you want it.

- To insert an invalid anchored frame element with a default tag, choose Special > Anchored Frame, and choose GRAPHIC from the Element Tag pop-up menu. (This option appears in the menu if no defined frame elements are available.)

**Fill and edit anchored frames**

You can draw graphics in an anchored frame, drag or paste graphics from another part of the document. Or, import or paste graphics from another document or application. Use these methods to place graphics and text in unanchored graphic frames and in anchored frames.

You can position a graphic in an anchored frame and then use a text frame or text line inside the anchored frame for the figure title. However, you might find it easier to position and number the title consistently if you put the figure in a single-cell table and then set up the table title as a figure title.

An anchored frame’s contents are clipped when they extend into or beyond the frame’s border. Display the frames border by clicking it (if the border isn’t visible, choose View > Borders).

You can change the size of an anchored frame, its anchoring position, and the properties you set when you created the frame. When working with a structured document, these changes do not affect the structure of the document and are independent of the element’s format rules.

You can also manipulate anchored frames as you do other objects. For example, you can change a frame’s drawing properties (such as pen width), and you can duplicate, delete, move, or resize it.

**More Help topics**

“Add a title to an illustration” on page 162

“Add text to graphics” on page 159
Filling anchored frames in structured documents

In a structured document, you can draw graphics in an anchored frame, drag, or paste graphics from another part of the document, or import or paste graphics from another document or application. Although the graphic element is part of the document’s structure, the contents you put in the frame are not.

You can even use an anchored frame to hold text, such as text in a sidebar. To do this, draw a text frame in the anchored frame. Keep in mind, though, that the text is not part of the document’s structure.

A frame’s contents are preserved when you export to XML or SGML. FrameMaker XML Author writes the contents to a separate file and adds an entity reference to it from your XML or SGML file.

Important: To prepare for export to XML or SGML, put only one graphic in each frame for the best results. If your graphics are bitmaps, do not use a display bit depth of 1 bit or 24 bits; reset your display to 8 bits. Ask your application developer for other advice to be sure your frames’ contents will be fully preserved.

After filling a frame with graphics, you can edit the graphics in many ways—for example, by changing line widths, applying fill colors, and aligning, stacking, or grouping several objects.

Put graphics or text in a graphic frame

❖ Do one of the following:

• To draw a graphic or add text, use one of the tools on the Tools panel. 

  Important: Be sure to start drawing the object inside the frame. Otherwise, the object is placed on the page and not in the frame.

• To move a graphic into a frame, drag the graphic until the pointer is within the frame’s borders. The object jumps into the frame when you drag across the frame’s border.

• To paste a graphic into a frame from the Clipboard, select the frame and choose Edit > Paste.

• To import a graphic into a frame, select the frame and choose File > Import. You can also import a graphic in other ways, depending on the platform.

  Note: If a graphic looks as though it’s in the anchored frame, but it doesn’t move with the frame as you edit the surrounding text, the graphic is probably in front of the frame rather than in the frame—perhaps because you pasted it on the page rather than in the frame. Drag the graphic away from the frame and then drag it back into the frame.

Prevent an anchored frame from clipping its contents

❖ Do one of the following:

• If there’s room outside the anchored frame, make the frame larger.

• If there’s room inside the anchored frame, move the object away from the edge of the frame.

• If the contents are clipped only by the width of the border, use the Tools panel to make the anchored frame’s border narrower or to change the pen pattern to None (see “Apply and change drawing properties” on page 155).

• If a frame and its contents are clipped by the edge of a column of text, choose Special > Anchored Frame, turn off Cropped, and then click Edit Frame.
Change a frame’s anchoring position and drawing properties
❖ Select the frame and do one of the following: choose Special > Anchored Frame.
  • To change the frame’s anchoring position, choose Special > Anchored Frame. Change the settings and click Edit Frame.
  • To change the drawing properties, Select the frame and use the Tools panel to specify the properties you want. For example, you can change a frame’s pen pattern to make the frame’s border printable or change its fill pattern to shade the interior of the frame.

Resize an anchored frame
❖ Do one of the following:
  • To resize the frame quickly but approximately, select the frame and drag one of its handles. The size appears in the status bar as you drag.
  • To resize the frame precisely, select the frame and specify its size with the Special > Anchored Frame command.
  • To resize an anchored frame to fit the object in the frame, press Esc M P.

Copy, move, or delete an anchored frame

Copy or move an anchored frame by using copy and paste
1 Select the frame and choose Edit > Copy or Edit > Cut. You don’t need to select the anchor symbol.
2 Click in text where you want to insert the frame and choose Edit > Paste. The anchor symbol appears at the insertion point when text symbols are visible. When working with a structured document, look at the Element Catalog before pasting to verify that the location is valid for graphic elements.

If you’re working with a structured document, you can also drag a frame’s bubble in the Structure View to move the frame or Alt-drag the bubble to copy the frame.

Move an anchored frame without moving its anchor symbol
❖ Do one of the following:
  • For quick but approximate repositioning, drag the frame.
  • For more precise repositioning, move the frame in small increments with the arrow keys.
  • For greatest precision, specify the location of the frame with the Special > Anchored Frame command.

Some anchored frames cannot be moved without moving their anchor symbols. However, you can move a frame vertically when it’s anchored at the insertion point, outside the column of text, or outside the text frame. When a frame is anchored outside the column or text frame, you can’t move it above the top or below the bottom of the text frame.

Note: When you move a frame into a column, the text in the column doesn’t adjust to accommodate the frame. Use the Run into Paragraph anchoring position to move the frame completely inside the column and to run the text around the frame automatically. You can also change the paragraph indents to make room for the frame.

Move a frame’s anchor symbol
1 Select the frame. You don’t need to select the anchor symbol.
2 Choose Edit > Cut, click in text where you want to insert the anchor symbol, and choose Edit > Paste. The anchor symbol appears at the insertion point when text symbols are visible.
In some cases—for example, when the frame is positioned at the top or bottom of a column of text—the frame may not change position even though the anchor symbol moves.

**Delete an anchored frame**
❖ Select the frame and press Delete.

**Add object attributes for tagged PDF**
If you plan to export your document to a tagged PDF or to XML, you can include object attribute information for your anchored frames.

Alt text is different from graphics or standard text. Alt text is typically used for describing an image so that screen readers can read it aloud. Actual text is for reading aloud the actual text, as in the case of a drop cap. For example, if the author is using a drop cap for the letter A in the word “Adobe” but still wants the screen readers to read the word as “Adobe” and not as “dobe,” this can be done by filling in actual text. The attribute will be saved to alt text and actual text in tagged PDF and XML.

When you provide alternate text attribute on an anchored frame, the corresponding figure elements in PDF and graphic elements in XML get an “alt text” attribute. Actual Text attribute is processed only for tagged PDF. XML export ignores this attribute.

*Note:* Object attributes support the Unicode text encoding standard.

1. Select the frame and choose Graphics > Object Properties.
2. Click Object Attributes.
3. In the Text Attributes section, add your alt text and actual text, and then click Set.

*Note:* Screen readers may ignore actual text when alt text is present.

**Hotspots**

A hotspot is an active area in a document that you can link to different areas of the document, to another document, or to a URL. You can apply hotspots to the following objects:

1. Graphic objects
2. Images
3. Anchored frame
4. Graphics frame
5. Text frame
6. Text line
7. Equations

FrameMaker XML Author supports the following shapes for hotspots:

1. Line
2. Arc
3. Polyline
4. Freehand curve
5. Rectangle
You can create hotspots in graphic objects and link them to textual objects in the same or other documents. You can superimpose an invisible hotspot over an image to link to any relevant text or detail in the document.

With hotspots, you can add multiple links in different parts of a graphic without having to divide the graphic into separate parts. For example, in a world map, you can create hotspots in each of the countries linking to more information about that country within a document, in other documents, or at a web address.

Hotspots are supported everywhere in the FrameMaker XML Author documents, including the master pages. A use case for hotspots on master page is a clickable logo for every page of the document that takes the user to a URL.

Hotspots look like other graphic objects. In edit mode, you can select the hotspots and edit the hotspot properties. In view mode, when you hover the mouse over the hotspot, the cursor changes to indicate active, clickable area.

You can link a hotspot in one document to another. PDFs support only rectangular hotspots. Hotspots of any other shape are converted to rectangular hotspots when you create the PDFs. Other outputs, such as HTML support hotspots of other shapes such as oval. If you want to scale, rotate, and translate hotspots with the anchor frame, group the hotspots with the anchor frame. While saving XML, FrameMaker XML Author saves the graphic containing the hotspots in a MIF file. While opening the XML file again, FrameMaker XML Author brings back the hotspot information into the FrameMaker XML Author file from the MIF file. Some other output types that support hotspots are: HTML, Webhelp, FlashHelp, Airhelp, and Multiscreen output.

The hotspot pod displays the available hotspots in a document or all open documents. Using the hotspots pod, you can edit/delete/delink the existing hotspots.

**Create hotspots using hotspot properties**

1. Insert a hypertext marker of type Named Destination. Apart from a Named Destination marker, you can link hotspots to URLs.
2. Right-click an object and in the pop-up menu, select Hotspot Properties.
3. In the Create Hotspot dialog, do one of the following:
   a. Specify the target document for the link. FrameMaker XML Author displays the available markers (Specify Named Destination command instance) in the selected document. Select the appropriate instance.
   b. Enter the target URL. The URL length is limited to 1011 bytes. 1011 bytes can contain 1011 single-byte characters, such as for English, or 506 double-byte characters, such as for Greek.
4. Specify a tool tip. Maximum tool tip length is 1023 bytes. 1023 bytes can contain 1023 single-byte characters, such as for English, or 511 double-byte characters, such as for Greek. Tool tip is optional.
5. Click Save.

You can now test the link by holding Ctrl+Alt keys and clicking the hotspot. You can generate PDF or other outputs.

**Create hotspots using graphics toolbar**

1. In the Graphics toolbar, click HotSpot Mode ( ].
2. Create any graphics object.
   FrameMaker XML Author launches the Hotspot dialog.
3 In the HotSpot dialog, do one of the following:
   a Specify the target document for the link. FrameMaker XML Author displays the available markers (Specify Named Destination command instance) in the selected document. Select the appropriate instance.
   b Enter the target URL. The URL length is limited to 1011 bytes. 1011 bytes can contain 1011 single-byte characters, such as for English, or 506 double-byte characters, such as for Greek.

4 Specify a tool tip. Maximum tool tip length is 1023 bytes. 1023 bytes can contain 1023 single-byte characters, such as for English, or 511 double-byte characters, such as for Greek. Tool tip is optional.

5 Click Save.
   You can now test the link by holding Ctrl+Alt keys and clicking the hotspot. You can generate PDF or other outputs.

### Delink a hotspot

You can delink a hotspot to remove the hotspot information from graphic object.

- In the Hotspot pod, select the hotspot entry and click Delink.
  - Or
    - Select a hotspot and then from the Graphics menu, select Delink Hotspot.
    - Or
      - Right click a hotspot and then from the pop-up menu select Delink Hotspot.

### Create hotspots in vector graphics

You can create multiple hotspots in vector graphics, such as a CGM file, imported in a FrameMaker XML Author document. The various parts of the CGM graphic can be made different hotspots.

### Object Styles

You can save your frequently used object properties as a style. You can apply these object styles to various objects, such as images, anchored frames, and text frames for consistent size and appearance. For example, you can create and apply an object style to all the anchored frames in a document, or across documents, to make them of the same size.

Object styles include the following properties:

- Position and size (width, height, top, left, and angle)
- Fill (fill pattern, tint, and color)
- Stroke (line and arrow style, line width, pen pattern)
- Text line (alignment)
- Text frame (flow properties and column properties)
- Anchored frame (anchoring position and related properties)
- Graphics (scaling and resolution)
- Equation (alignment, size, and automatic line breaks)
- Runaround type and width
Object styles are relevant for the following objects in FrameMaker XML Author:

- Images
- Anchored frame
- Graphic objects
- Text frame
- Text line
- Equations

Create an object style
   Object Designer appears with all the property values blank.
2. In the Object Designer Dialog, type a name for the object style.
3. Edit the property values and click Save.

Create an object style from an object’s properties
1. Select the object based on which you want to create an object style.
2. Select Graphics > Object Style Designer.
   Object Style Designer displays the properties relevant to the selected object and populates the values of these properties from the selected object.
3. In the Object Designer Dialog, type a name for the object style.
4. Edit the property values, if necessary, and click Save.

Apply an object style
1. Select Graphics > Object Style Catalog.
2. Select one or more objects on which you want to apply the style.
3. In the Object Style Catalog, click the name of an object style to apply.

Import object formats from another document
1. Select File > Import > Formats.
2. In the Import Formats dialog, select Object Styles.
3. Select Import.

Using RoboScreenCapture
RoboScreenCapture is a screen capture tool that can be used for capturing and editing images. You can use these images in your help systems like online tutorials, manuals, training handouts, presentations, marketing materials, and web pages.
Integration of FrameMaker XML Author with RoboScreenCapture helps you do the following:

- Open RoboScreenCapture from FrameMaker XML Author.
- Insert images created in RoboScreenCapture into FrameMaker XML Author.
- Edit images imported by reference into FrameMaker XML Author using RoboScreenCapture. You can use the right-click option Edit with RoboScreenCapture for an image to launch and edit the image in RoboScreenCapture. Changes made to the image are reflected in FrameMaker XML Author after the image is saved and closed in RoboScreenCapture.

*Note: This option is available only for image formats supported by RoboScreenCapture.*

You can use RoboScreen Capture to perform the following tasks:

- Capture screens in 10 modes, including Adobe FreeHand, Virtual Screen, and Multi-Region
- Capture screens using a drop-down menu, assign your own keyboard shortcuts, and even control RoboScreenCapture with voice commands
- Capture difficult-to-grab screens such as DirectX, Direct3D, 3Dfx, Voodoo, and Glide mode games
- Capture more than is visible on the screen, such as long Web pages
- Edit images
- Save your screen capture in over 20 image formats
- Automatically save screen captures to image files
- Quickly add image stamps, frames, drop shadows, and more
- Change image colors, flip or rotate images, and crop images to a smaller size
- Add identifying stamps to each screen capture, such as a company name or logo
- Call-out specific areas of your capture with shapes, shadow effects, and more.

### Capturing and inserting images

You can use RoboScreenCapture from FrameMaker XML Author to capture a screenshot from an application running on your computer, and save it in RoboScreenCapture. You can then import the file into an open FrameMaker XML Author document.

1. Open the FrameMaker XML Author document into which you want to insert images.
3. From RoboScreenCapture, capture a screenshot of the desired application using the various options in the Capture menu.
4. Save the file, and close RoboScreenCapture.
6. Select the file created in RoboScreenCapture.
7. Select Import by Reference from the Import dialog box.
8. Click Import.

### Editing imported images

You can use RoboScreenCapture to edit images inserted by reference into FrameMaker XML Author documents.

1. Open FrameMaker XML Author.
2 Select File > Open, and open a document with the image you want to edit.

3 Select the image you want to edit.

4 Right-click the image, and select Edit With RoboScreenCapture. The RoboScreenCapture application opens with the image open for editing.

5 Edit the image.

6 Select File > Save.

7 Select File > Exit to close the RoboScreenCapture application.

The edited image is updated in FrameMaker XML Author and is ready for use in the document.
Chapter 8: Dynamic Documents

Markers

FrameMaker XML Author markers provide you multiple ways in which you can mark your documents. You can choose from pre-defined markers, such as Author, Comment, Conditional Tags, ContextString, Cross-Ref, Equation, Glossary; or create custom markers.

The Markers pod makes it easier to work with and troubleshoot hundreds of markers in a long document or book files. You can display all the markers in the current document, all open documents, selected file, or a book.

Add a marker

To add a marker to a structured document:

1 Choose Special > Marker.
2 Select a marker element in the Element Catalog and click Insert.
3 Choose a marker type from the pop-up menu. You can use any predefined marker type except Conditional Tags. You can also define your own marker types.

*Note:* Consult your developer before changing a marker type. Your document may have a separate element defined for each marker type you’ll need.

*Note:* You can enter a tab character in marker text by typing either \t or the hexadecimal code \x08. However, if you generate a list of markers, only tabs entered as hexadecimal codes appear. If you generate an index of markers, only tabs entered as \t appear.

Delete a marker

Select the marker from the Markers pod and click the Delete icon. The marker is deleted from the document.

Create a custom marker

You can also define custom markers for single-sourcing or automation. For example, you can use custom markers to mark text that can be extracted into a separate reference guide. You can mark graphic objects that require special processing, such as conversion from one format to another. You can then use a script to automatically extract all those graphics marked with the custom marker for further processing.

1 Choose View > Pods > Markers.
2 Click the Insert Icon.
3 From the Marker Type combo box, select Edit.
4 Type a name for the custom marker in the Edit Custom Marker Type box.
5 Click Add and click Done. The new Marker type is added to the list of markers.

Add a custom marker to your document

1 From the Markers pod, click Insert.
2 Select the custom marker type.
3 Type the marker text and click New Marker. A custom marker gets added to your document.

**Create hypertext links**

You can create links to information in different locations in the same document or in different documents. For example, you can create links that jump to specific topics or pages, and you can use FrameMaker XML Author cross-references as links. You can also allow your readers to retrace their jumps.

If your documents are distributed in PDF, some of these commands do not work.

**Create links to specific topics**

You can create a link from one location in a hypertext document to a topic in another location. You use one command to specify the topic you want to display, and you use another to mark the spot on the linked page.

A. Specify the topic to display.  B. Mark the topic.

FrameMaker XML Author can display the linked information in the same window or in a new window (leaving the active window open).

**Identify a linked topic**

❖ Insert a Specify Named Destination command. This command uses the following syntax:

```
newlink linkname
```

A. Jump to Named Destination command: gotolink trombone  B. Specify Named Destination command: newlink trombone
Note: If you omit the Specify Named Destination command, the Jump To Named Destination and Open Document commands do not work when clicked unless they reference a filename. In that case, the other file opens, showing the first page.

Create a link to a specific topic
❖ Insert one of the following hypertext commands:
  • To display the linked information in the same window, insert a Jump to Named Destination command. This command uses the following syntax:
    gotolink filename:linkname
  • To display the linked information in a different window, insert an Open Document command. (The information appears in a new window only if it’s in a different document.) This command uses the following syntax:
    openlink filename:linkname

In this example, filename is the name of the document to display, and linkname is the descriptive word or phrase that you used in the corresponding Specify Named Destination command.

If the linked information is in a document whose page size differs from the current document, display the information in a window that is resized to fit the page. Use the Jump To Named Destination & Fit To Page command or the Open Document & Fit To Page command.

Create links to pages
You can create a link to the first, last, previous, or next page in the same document or in a different document. You can also create a link to a specific page number.

❖ You can create navigation aids for your readers by creating links to the next and previous pages on the master pages of a document.

❖ Insert one of the following hypertext commands:
  • To display the linked page in the same window, insert a Jump to Page Number, Jump to First Page, or Jump to Last Page command. The commands use the following syntax:
    gotopage filename:pagenumber
    gotopage filename:firstpage
    gotopage filename:lastpage
  • To display the linked page in a different window, insert an Open Document At Page Number, Open Document At First Page, or Open Document At Last Page command. The page appears in a new window only if the page is in a different document.) These commands use the following syntax:
    openpage filename:pagenumber
    openpage filename:firstpage
    openpage filename:lastpage

Note: When you insert a hypertext command to display a specific page number, use the actual page number in the document. For example, if the destination document MyDoc uses Roman numerals for page numbers and begins on page v, the command to display the third page is openpage MyDoc:vii.

• To display the next or previous page of the current document, insert a Jump To Previous Page or Jump To Next Page command. (If the first page of the document is already displayed, Jump To Previous Page has no effect. If the last page of the document is displayed, Jump To Next Page has no effect.) These commands use the following syntax:
In these examples, `filename` is the name of the document to display, and `pagenumber` is the number of the page to display. When the page to display is in the current document, don’t include the filename and colon. The following table contains examples of the commands.

<table>
<thead>
<tr>
<th>Command</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>gotopage 8</code></td>
<td>Displays, in the same window, page 8 of the current document</td>
</tr>
<tr>
<td><code>openpage Trombone:8</code></td>
<td>Displays, in a different window, page 8 of the document Trombone in the current folder</td>
</tr>
</tbody>
</table>

**Create links to new documents**
You can create a link to another document and have FrameMaker XML Author open the document in another window as a new, unnamed document. For example, you can create an online system for your site document templates.

❖ Follow the instructions to insert an Open Document As New command. This command uses the following syntax:

```
opennew filename
```

In this example, `filename` is the name of the document you want to use as a template.

**Create links to web pages**
You can create a link to a web page on the Internet or a company intranet.

❖ Insert a Go To URL command. This command uses the following syntax:

```
message URL address
```

In this example, `address` is the name of the URL you want to jump to, such as `http://www.adobe.com`.

**Creating links using cross-references**
You use FrameMaker XML Author cross-references as hypertext links. When the reader clicks a cross-reference in a view-only document, FrameMaker XML Author jumps to the source information. If a cross-reference is present in the same text area as a hypertext command, the cross-reference takes precedence over the hypertext command.

You can use MIF to specify that cross-references are inactive in your hypertext document. You can also specify that clicking an active cross-reference always causes FrameMaker XML Author to open a new window.

**Create ways to start, open, and close applications**
You can use hypertext commands to start other applications. For example, a reader can start a database application from a view-only document to retrieve and display data.

The hypertext commands for closing files and exiting FrameMaker XML Author work in the same way as the commands on the File menu.

If a reader executes a command to close a file that contains unsaved changes, FrameMaker XML Author prompts the reader to save the document before closing.
In addition, you can create hypertext commands that link to a Universal Resource Locator (URL) when the document is converted to Hypertext Markup Language (HTML).

**Create a way to start another application**

❖ Insert a Message Client. This command uses the following syntax:

```
message system application path,windowstate  message winexec application path,windowstate
```

In these examples, `application` is the application filename, `path` is an optional command line parameter, and `windowstate` specifies the state of the window that is opened. The possible `windowstate` values are listed in this table.

<table>
<thead>
<tr>
<th>State</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>SW_HIDE</td>
<td>Hides the window and activates another window</td>
</tr>
<tr>
<td>SW_MAXIMIZE</td>
<td>Maximizes the specified window</td>
</tr>
<tr>
<td>SW_MINIMIZE</td>
<td>Minimizes the specified window and activates the next window in the Alt+Tab order</td>
</tr>
<tr>
<td>SW_RESTORE</td>
<td>Activates and displays the window (if the window is minimized or maximized, Windows restores it to its original size and position.)</td>
</tr>
<tr>
<td>SW_SHOW</td>
<td>Activates the window and displays it in its current size and position</td>
</tr>
<tr>
<td>SW_SHOWDEFAULT</td>
<td>Sets the show state based on the SW_ flag specified in the STARTUPINFO structure passed to the CreateProcess function by the program that started the application</td>
</tr>
<tr>
<td>SW_SHOWMAXIMIZED</td>
<td>Activates the window and displays it as a maximized window</td>
</tr>
<tr>
<td>SW_SHOWMINIMIZED</td>
<td>Activates the window and displays it as a minimized window</td>
</tr>
<tr>
<td>SW_SHOWMINNOACTIVE</td>
<td>Displays the window as a minimized window (The active window remains active.)</td>
</tr>
<tr>
<td>SW_SHOWNA</td>
<td>Displays the window in its current state (The active window remains active.)</td>
</tr>
<tr>
<td>SW_SHOWNOACTIVATE</td>
<td>Displays a window in its most recent size and position (The active window remains active.)</td>
</tr>
<tr>
<td>SW_SHOWNORMAL</td>
<td>Activates and displays a window (if the window is minimized or maximized, Windows restores it to its original size and position.)</td>
</tr>
</tbody>
</table>

If you omit the `windowstate` value, the window state is set to SW_SHOWNORMAL. For more information on window states, see the documentation for the Windows software development kit.

For example, to start PaintBrush and open the Ship.pcx file on drive letter C in a minimized window, you would use the following command:

```
message system pbrush.exe C:/Ship.pcx, SW_MINIMIZE
```

**Create a way to open a file or another application**

❖ Insert a Message Client command. This command uses the following syntax:
message openfile path

In this example, path is the path to the file, application, or AppleScript script.

For example, consider the Tuba.eps file located in the Graphics folder on the drive named HardDrive. To start the application that created the Tuba.eps file and to open the file, use the following command:

message openfile /HardDrive/Graphics/Tuba.eps

To run the DocReport script (located in the Scripts folder on the drive named HardDrive), use the following command:

message openfile /HardDrive/Scripts/DocReport

Create a way to close or exit documents

❖ Insert one of the following hypertext commands:
  • To create a way to close the current view-only document, insert a Close active window command. This command uses the following syntax:
    
    quit

  • To create a way to close all open view-only documents, insert a Close All Hypertext Windows command. The Close All Hypertext Windows command also closes view-only documents that have already been closed to an icon. This command uses the following syntax:
    
    quitall

  • To create a way to exit FrameMaker XML Author, insert an Exit command. This command uses the following syntax:
    
    exit

More Help topics

“Create links to web pages” on page 194

Test and troubleshoot hypertext documents

After writing the document and inserting hypertext commands, test the commands. To speed up testing of hypertext commands, execute commands without first changing a document to View Only format. Also force the destination of a hypertext jump to appear in a separate window.

FrameMaker XML Author validates all the commands in a document.

Errors in hypertext commands or in their placement in the document, or formatting errors in active areas can cause problems with the behavior of the commands. For example, an incorrect linkname prevents a hypertext command from being executed correctly.

Some common hypertext problems and possible solutions:

Clicking an active area has no effect  Check for the following possible problems:

  • The document is not in View Only 9.0 format.
  • If the active area is highlighted correctly when you click, a command sometimes contains a linkname that doesn’t match the corresponding link at the destination.
• If the active area isn’t highlighted when you click, sometimes the marker that contains the hypertext command is not of type Hypertext.
• If the active area is over a graphic, sometimes the text frame containing the hypertext marker is not in front of the graphic.

The jump goes to the wrong page Sometimes the command contains a correct filename but an incorrect linkname or an invalid page number.

Only part of the active area is highlighted Check for the following possible problems:
• If you’re trying to make a range of text active, sometimes the text contains an extra hypertext marker or the character format changes within the range of text.
• If you’re trying to make an entire empty text frame active, sometimes the frame contains an extra empty paragraph, or extra characters or markers.

Items are missing from a pop-up menu The hypertext commands for missing menu commands are incorrect. If the pop-up menu does not appear, no commands are correct.

Force the linked destination to appear in a different window ❖ If the document is view-only, Shift-click an active area. Otherwise, Control-Alt-Shift-click an active area.

Cross-references

FrameMaker XML Author uses a marker (of type Cross-Ref) to keep track of the source of each cross-reference. If you move a marker and then update cross-references, the marker’s new location is used to update the cross-reference.

For paragraph cross-references, the marker text contains a number assigned to the marker, the paragraph tag, and text of the paragraph being cross-referenced. When you insert a paragraph cross-reference, a cross-reference marker is inserted automatically at the beginning of the source paragraph if necessary. (The marker text is not updated, so the tag and text sometimes don’t match the cross-reference.)

FrameMaker XML Author provides two types of cross-references—to paragraphs and to specific spots within paragraphs. In both cases, FrameMaker XML Author uses markers to keep track of the source of cross-references.

For spot cross-references, the marker text is the text you type when creating the marker on the source text. It is important to mark the text in the source first so that it appears in the cross-reference panel at the time you create the spot cross-reference.

It is easier to create and maintain paragraph cross-references because FrameMaker XML Author automatically creates a marker on the paragraph tag in the source files. In the case of spot cross-references, you have to first mark the spot with a marker and then create a cross-reference to the marker.

Note: The Cross-reference feature supports the Unicode text encoding standard.

FrameMaker XML Author keeps cross-references, variables, and footnotes up to date for you. To add a cross-reference in FrameMaker XML Author, you normally use an element designed for that purpose. The cross-reference element points to a location, or source, that can be in the same document or a different document. The source is also normally an element, such as a Chapter, Section, Figure, or Table element.
An element-based cross-reference shows text from the source element.

The source a cross-reference can be either a whole paragraph or a marked spot in text. It is also possible to point to a paragraph or a spot in a structured flow, but it’s best to point to another element. (Cross-reference elements are often defined to be invalid if they point to anything other than an element.)

**ID and ID Reference attributes**

FrameMaker XML Author uses attributes in cross-reference and source elements to maintain the connection between the two elements. The source element has an ID attribute that stores a unique identifier in the document or book. The cross-reference element has an ID Reference attribute that also stores the source’s identifier as a way of keeping track of what the reference points to.

If you insert a cross-reference to a source that has an ID attribute but does not yet have a value for the attribute, FrameMaker XML Author automatically provides the value.

An ID that FrameMaker XML Author generates is an eight-character string that conforms to the XML or SGML reference concrete syntax.

FrameMaker XML Author tries to ensure that your IDs are unique in the following ways:

- When FrameMaker XML Author generates an ID, it is unique within the document. The ID is unique even within the book, because documents in a book have different filenames and part of the generated IDs comes from the filename.
- If you enter an ID that is not unique, the ID is not accepted. FrameMaker XML Author does not test for whether an entered ID is used in a different document in a book but you can validate the book to find duplicate IDs.
- If you paste a copy of an element with a duplicate ID, the pasted element loses its ID.

It is still possible for a document to have IDs that are not unique. For example, duplicate IDs occur if you show hidden conditional tags that contains an element with the same ID as another element. The duplicate IDs are identified as invalid in the Structure View.

An ID Reference attribute is sometimes defined to require a value. If an attribute requires a value but does not have one, the cross-reference probably points to a paragraph or spot within text rather than an element. FrameMaker XML Author identifies the attribute as invalid in the Structure View.
Cross-reference pod overview

The cross-reference pod lists all the cross-references in the current document, selected document, or all open documents. It allows you to add, edit, delete, or search for cross-references from a single panel. You can also filter cross-references to view only external or unresolved cross-references. This helps to troubleshoot unresolved cross-references across multiple open documents.

Insert cross-references

Within a document, when you copy and paste text that contains a cross-reference marker, the marker is not duplicated. The cross-reference still refers to the text in its original location.

Insert a paragraph cross-reference

Paragraph cross-references refer to a heading or some other text that occupies a whole paragraph.

1 If you’re cross-referencing another document, open that document. You must have write permission to the document to add a cross-reference marker to it.

2 Click where you want to insert the cross-reference.

You can insert a cross-reference in text frames but not in text lines (graphic objects created with the Text Line drawing tool).

3 Click the Add icon on the cross-references pod.

4 If you’re cross-referencing information in another document, choose the name of that document from the Document pop-up menu in the cross-reference panel.

5 Choose Paragraphs from the Source Type pop-up menu. All the tags in the document’s Paragraph Catalog appear in the Paragraphs Tags scroll list.

6 In the Paragraph Tags scroll list, select the tag of the paragraph you want to cross-reference. For example, if you’re cross-referencing a paragraph tagged Head1, select Head1 in the Paragraph Tags scroll list. All Head1 paragraphs then appear in the Paragraphs scroll list.

7 In the Paragraphs scroll list, select the paragraph to cross-reference.

8 Choose the format of the cross-reference from the Format pop-up menu.
9 Click Insert. FrameMaker XML Author inserts a cross-reference at the insertion point in your document. In the source document, FrameMaker XML Author adds a marker at the start of the paragraph being cross-referenced. FrameMaker XML Author inserts a marker only if a cross-reference marker isn’t already there.

10 Save both the documents for the cross-reference to work correctly.

If the paragraph extends beyond the page on which it begins, the page number in the cross-reference, if included, is that of the beginning page.

**Insert a cross-reference to a paragraph in a text inset**

If you insert a paragraph cross-reference to a text inset, the cross-reference marker is sometimes lost when the text inset is updated. To prevent the marker from being lost, first insert a cross-reference to the paragraph in the text inset’s source document.

1 Open the source of the inset by double-clicking the inset and then clicking Open Source from the Text Inset Properties panel.

2 Insert a cross-reference to the paragraph anywhere in the source document.

3 Delete the cross-reference text. The marker remains.

4 Save the source document, and then in the document that contains the text inset, update the text inset by choosing Edit > Update References.

5 Insert a spot cross-reference, this time in the document that contains the inset. The cross-reference uses the marker in the updated inset.

**Insert a cross-reference to a word or phrase**

Spot cross-references refer to an individual word or phrase—a spot—in a paragraph. For example, use a spot cross-reference if you have a paragraph that spans two pages and you want to refer to the text on the second page of your reference.

1 Click where you want to insert the marker. For example, click at the start of a word, next to an anchored frame symbol, or anywhere within a column of text.

2 Click the Add icon on the Markers panel.

3 Choose Cross-Ref from the Marker Type pop-up menu.

4 Enter an identifying word or phrase for the marker in the Marker Text box. The marker text can be up to 255 unicode characters long.

   For example, if you insert a marker where *inertia* is defined, you can enter **Definition of inertia**. This text appears in the cross-reference panel to help you identify the source. It doesn’t appear in the cross-reference itself.

5 Click New Marker. A marker symbol appears at the insertion point when text symbols are visible.

6 Insert a spot cross-reference by choosing cross-reference Markers from the Source Type pop-up menu. Then select the marker text in the cross-reference Markers scroll list, choose a cross-reference format, and click Insert.

   *The Markers pod displays the marker text of all markers including Cross-Refs. However, you can also generate a list of all types of Cross-Ref markers from Special > List Of > References.*

**Insert a cross-reference in a document**

When inserting a cross-reference, you normally use a cross-reference element and point the reference to another element. The source element can be an entire section or chapter, a table or graphic, a paragraph, or a location within a paragraph (such as a definition).
FrameMaker XML Author uses attributes to maintain the connection between a cross-reference element and a source element. The source element has an ID attribute with a value that uniquely identifies the location in the document. When you insert a cross-reference to the source, the same value is stored in an IDRef attribute for the cross-reference element.

If you insert a cross-reference to a source that has an ID attribute but does not yet have a value for the attribute, FrameMaker XML Author automatically provides the value.

**Note:** An element can be a source for cross-references only if it has a unique ID attribute. If you want to insert a cross-reference to a source that does not have an ID attribute, ask your application developer to add the attribute to the source element definition.

1. If the source element is in another document, open that document. If the source element does not have a value assigned to its ID attribute, you must have write permission to the other document so that FrameMaker XML Author can provide an ID.

2. Click where you want to insert the cross-reference element. You can insert a cross-reference in text frames but not in text lines (graphic objects created with the Text Line drawing tool).


   You can also use Special > cross-reference to insert an element. If more than one element is available, choose the one you want from the Element Tag pop-up menu in the cross-reference panel.

4. If you’re cross-referencing information in another document, choose the name of that document from the Document pop-up menu.

5. Choose Elements Listed in Order or Elements Listed by ID from the Source Type pop-up menu. The tags of all elements for which an ID attribute is defined (in the source document’s element definitions) appear in the Element Tags scroll list.

   - **List elements by IDs if you provided the IDs and have used values that identify the elements’ contents. (If FrameMaker XML Author provided the IDs, the values are random strings that are helpful in finding the element you want.)**

6. Select the tag of the source element in the Element Tags scroll list. For example, if you’re cross-referencing a Section element, select Section. All Section elements in the source document appear in the Elements scroll list.

   Some elements use context labels to provide information about the element’s location in the structure. For example, if Section elements can be nested within other Section elements, the labels can identify whether the elements are first-, second-, or third-level sections.

   If an element uses context labels, a <no label> entry also appears in the scroll list for occurrences not described by the labels. In the example, Section(<no label>) represents Section elements that are at a fourth level or lower in the document.

7. Select the element you want to cross-reference in the Elements scroll list.

8. To change the cross-reference format, choose from the Format pop-up menu.

   **Note:** Consult your developer before changing a cross-reference format.
9 Click Insert. FrameMaker XML Author places the cross-reference at the insertion point. A bubble for the reference appears in the Structure View, with a text snippet that shows the first part of the text from the reference.

10 If the Attributes for New Element dialog box appears, enter attribute values for the cross-reference, and select Insert Element.

If no cross-reference element is available at the location you want, you can use an invalid element. After inserting the element, talk to your developer about making it valid at this location.

**Use an invalid cross-reference element**

❖ Do one of the following:

- To use an element that is valid in another part of the document, either insert the element in a valid location and then move it, or use the All Elements setting to make the element available everywhere and then insert the element where you want it.
- To insert an invalid cross-reference element with a default tag, choose Special > cross-reference, and choose CROSSREF from the Element Tag pop-up menu. (This option appears in the menu if no defined cross-reference elements are available.)

**Provide a value for an ID attribute**

If the ID attributes are not read only, you can provide the IDs with values that are more meaningful. Give the source elements their IDs before inserting cross-references to them.

❖ Enter an ID in the Attributes dialog box. You can use any combination of characters on your keyboard, up to 255 characters.

*Keep in mind that the ID appears in the cross-reference panel and in the Structure View. Use a brief name that you’ll remember or recognize later. For example, assign the ID value Art to an element for a chapter titled The Art Department.*

If you plan to export to XML, follow the naming rules for the syntax you’ll be using in XML. Ask your developer for recommendations on name length and characters allowed.

You can also edit an ID (unless the attribute is defined to be read only), but any cross-references pointing to the element will be unresolved.

*If you change an element’s ID, you can update existing cross-references to the element. Search for elements that have an ID Reference attribute with the old ID, and replace the old ID with the new one.*

**More Help topics**

“Display the source of a cross-reference” on page 203

“Resolve cross-references” on page 207

**Edit cross-references or display the source**

If you want to edit the text of the cross-reference as you do regular text, you must convert it to text. After conversion, the text can no longer be updated as a cross-reference.

**Convert a cross-reference to text**

1 If you’re converting a single cross-reference, select it; otherwise, click in the document.

2 Choose Special > cross-reference.
3  Click Convert to Text.
4  Indicate the scope of cross-references to convert and click Convert.

Choose a different source or format for a cross-reference
1  Double-click the cross-reference. If the source is located in a different document, click OK to open the source document.
2  Specify a source or format in the same way that you would when inserting a cross-reference, and then click Replace.

Display the source of a cross-reference
- Double-click the cross-reference, and then click Go to Source. FrameMaker XML Author displays the page that contains the source of the cross-reference and places the insertion point at the beginning of the source paragraph.
- (Windows) Alt-Control-click the cross-reference.

Note: If the source is in a different document, hold down Shift while using one of the preceding shortcuts to open the document without closing the current document.

Create and edit cross-reference formats
A cross-reference format defines the appearance of a cross-reference: its wording, the source information it shows, and, optionally, any special text formatting. The building blocks of the format are replaced with source information and are updated when necessary—for example, if the source page number changes.

A. Text that appears literally  B. Building blocks.

FrameMaker XML Author templates include several cross-reference formats. You can change them or create others. If another document contains the cross-reference formats you want, you can import them into your document. Ask your developer to create one or modify an existing format.

1  Choose Special > cross-reference.
2  Click Edit Format.
3  Type a name for the cross-reference format in the Name box. Format names are case-sensitive page and Page would be different formats.
4  Do any of the following:
   - To use text (such as See or on page) in a cross-reference format, click in the Definition box and enter the text.
   - To include a building block that refers to source information, such as a page number, chapter number, or heading text, click in the Definition box and then click the building block in the Building Blocks scroll list. The building block appears at the insertion point.
   - To change the character format within the cross-reference, click in the Definition box and then click the character format at the bottom of the Building Blocks scroll list. The building block appears at the insertion point. To return to the default paragraph format before the end of the cross-reference, insert <Default ¶ Font> in the definition.
5 Click Add and then click Done. The new cross-reference format appears in the Formats pop-up menu in the cross-reference panel.

**Including text in a cross-reference**

You can include specific characters or words in the cross-reference. In most cases, you simply enter the text in the Definition box. But a few characters are entered or displayed differently.

For example, an angle bracket (< or >) in a cross-reference format ordinarily signals a building block. To include an angle bracket as part of the text, precede it with a backslash (\).

**Note:** Some special characters are entered or displayed differently in dialog boxes. Enter a sequence of characters beginning with a backslash (\); these sequences are listed in "Typing in dialog boxes" on page 376.

**Including source information in cross references**

You use building blocks to include information about the source of the cross-reference, such as its paragraph text (but not the cross-reference marker text), paragraph autonumber, or volume, chapter, or page number. Building blocks for source information appear in angle brackets (< and >) and begin with a dollar sign ($). The following building blocks are grouped by the type of information they represent.

**Source file**

FrameMaker XML Author provides the following building blocks for referring to the source file.

<table>
<thead>
<tr>
<th>Building block</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;$filename&gt;</td>
<td>The name of the source document</td>
</tr>
<tr>
<td>&lt;$fullfilename&gt;</td>
<td>The full path of the source document</td>
</tr>
<tr>
<td>&lt;$volnum&gt;</td>
<td>The volume number of the document that includes the source paragraph</td>
</tr>
<tr>
<td>&lt;$chapnum&gt;</td>
<td>The chapter number of the document that includes the source paragraph</td>
</tr>
</tbody>
</table>

**Source paragraph**

FrameMaker XML Author provides the following building blocks for referring to the source paragraph.

<table>
<thead>
<tr>
<th>Building block</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;$pagenum&gt;</td>
<td>The page number of the source paragraph</td>
</tr>
<tr>
<td>&lt;$paratext&gt;</td>
<td>The text of the source paragraph, excluding its autonumber (If the character format of text in the source paragraph was changed by applying a Character Catalog format, the font family, superscript, and subscript properties are preserved in the text of the cross-reference.)</td>
</tr>
<tr>
<td>&lt;$paratag&gt;</td>
<td>The tag of the source paragraph</td>
</tr>
<tr>
<td>&lt;$paranum&gt;</td>
<td>The source paragraph’s entire autonumber, including any text in the autonumber format</td>
</tr>
<tr>
<td>&lt;$paranumonly&gt;</td>
<td>The source paragraph’s autonumber counters, including any characters between them</td>
</tr>
</tbody>
</table>

**Paragraph preceding the source paragraph**

A cross-reference to a subsection often identifies the section that contains it. For example, this cross-reference to a subheading identifies the main heading under which it is found: *See “Types of Plate Boundaries” in “Plate Tectonics.”* In the example, *Types of Plate Boundaries* is the source paragraph, and *Plate Tectonics* is the main heading under which the source paragraph appears.

Last updated 8/18/2015
In each of the building blocks, replace \textit{tag} (in brackets) with the tag of the paragraph to which you want to refer, but don’t delete the brackets. For example, if you want to refer to the text of the preceding paragraph tagged \textit{Head1}, use 

\texttt{<$paratext[Head1]>}.

**Important:** Don’t use a paragraph tag that includes brackets (\{ \}).

**FrameMaker XML Author elements**

Use the following building blocks to create cross-reference formats that refer to structured FrameMaker XML Author elements.

<table>
<thead>
<tr>
<th>Building block</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\langle \text{pagenum} [\text{tag}] \rangle$</td>
<td>The page number of the preceding paragraph with the specified tag \</td>
</tr>
<tr>
<td>$\langle \text{paratext} [\text{tag}] \rangle$</td>
<td>The text of the preceding paragraph with the specified tag, excluding its autonumber (If the character format of text in the source paragraph was changed by applying a Character Catalog format, the font family, superscript, and subscript properties are preserved in the text of the cross-reference.) \</td>
</tr>
<tr>
<td>$\langle \text{paratag} [\text{tag}] \rangle$</td>
<td>The tag of the preceding paragraph with the specified tag \</td>
</tr>
<tr>
<td>$\langle \text{paranum} [\text{tag}] \rangle$</td>
<td>The entire autonumber of the preceding paragraph with the specified tag, including any text in the autonumber format \</td>
</tr>
<tr>
<td>$\langle \text{paranumonly} [\text{tag}] \rangle$</td>
<td>The autonumber counters of the preceding paragraph with the specified tag, including any characters between them \</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Building block</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\langle \text{elempagenum} \rangle$</td>
<td>The page number of the source element</td>
</tr>
<tr>
<td>$\langle \text{elemtext} \rangle$</td>
<td>The text of the source element (up to the first paragraph break), excluding its autonumber, but including any prefix and suffix specified in the element definition</td>
</tr>
<tr>
<td>$\langle \text{elemtextonly} \rangle$</td>
<td>The text of the source element (up to the first paragraph break), excluding its autonumber and any prefix and suffix specified in the element definition</td>
</tr>
<tr>
<td>$\langle \text{elemtag} \rangle$</td>
<td>The tag of the source element</td>
</tr>
<tr>
<td>$\langle \text{elemparanum} \rangle$</td>
<td>The entire autonumber of the source element’s first paragraph (or of the paragraph containing the source element), including any text in the autonumber format</td>
</tr>
<tr>
<td>$\langle \text{elemparanumonly} \rangle$</td>
<td>The autonumber counters of the source element’s first paragraph (or of the paragraph containing the source element), including any characters between the counters</td>
</tr>
<tr>
<td>$\langle \text{attribute[\text{name}] \rangle$</td>
<td>The value of the attribute with the specified name (or, if no value is specified, the default value)</td>
</tr>
</tbody>
</table>

**Including character formats in cross-references**

All formats in the document’s Character Catalog appear at the end of the Building Blocks scroll list. You insert them as you do other building blocks.

If you don’t insert a character format in a cross-reference format, FrameMaker XML Author uses the font at the insertion point when a cross-reference is inserted with that format. If you change the character format for the cross-reference, the change applies only to the cross-reference, not to the text following it in the paragraph.

Don’t use a character tag that includes angle brackets (< >).

**Examples of cross-reference formats**

The first four examples in the following table include building blocks that refer to the source paragraph.
The last example includes a building block that refers to a paragraph preceding the source paragraph. In this example, the cross-reference format could also be the following:

See "<$paratext>" in "<$paratext[Title, Head1]>".

In this case, the cross-reference refers to either the chapter title (Title) or the section heading (Head1), whichever is closer to the Magma source paragraph.

You can use the </> building block as a substitute for <Default Para Font> in cross-reference definitions.

**Edit or delete a cross-reference format**

When you change or delete cross-reference formats, the changes are reflected immediately in all cross-references that use the affected formats.

You can change the format of cross-references in a text inset (text imported by reference) if the inset uses the formats of the document into which it is imported. If the inset uses formats from the source document, change the formats in the source document.

1. Choose Special > cross-reference, and click Edit Format.
2. In the Formats scroll list, select the format you want to edit or delete, and do one of the following:
   - Edit the definition. Click Change, and then click Done. If the Update cross-reference panel appears, indicate the scope of cross-references to update, and then click Update.
   - Click Delete, and then click Done. If cross-references in the document use the format, you are asked whether you want to convert these cross-references to text.

**Update and resolve cross-references**

If you edit the source of a cross-reference or if the pagination of the source document changes, the cross-reference is no longer accurate. You can update cross-references to be sure that they show correct information from the source.

You can use the cross-reference pod to display a list of all the unresolved cross-references in a document or book. You can use this list to troubleshoot unresolved cross-references.

Normally, FrameMaker XML Author updates all cross-references when you open a document. It also updates all internal cross-references and cross-references to open documents when you print a document. You can also update cross-references manually. If the document contains unresolved cross-references—cross-references to sources that FrameMaker XML Author can’t find—you’ll need to Help locate the sources.

FrameMaker XML Author does not update cross-references when opening a document in the following circumstances:

- When cross-references refer to information in hidden conditional tags. Show the text that contains the sources of the cross-references before updating the cross-references.
- When fonts or dictionaries are missing.
- When opening a document saved with an earlier version of FrameMaker XML Author.
- When opening a MIF file.

**Suppress automatic updating of cross-references in a document or book**

If a document contains many cross-references, you can improve its opening time by suppressing automatic updating of the cross-references. After you suppress automatic updating, cross-references are updated only when you print or when you manually give instructions to update. They are no longer updated when you open the document. However, internal cross-references and cross-references to open documents are still updated automatically when you print.

1. Do one of the following
   - To suppress updating in a document, choose Edit > Update References, choose Suppress Automatic Updating Of All cross-references from the Commands pop-up menu. Select Suppress Automatic Updating Of All cross-references and click Set.
   - To suppress updating in a book window, choose Edit > Suppress Automatic Reference Updating, select Suppress Automatic Updating, and then click Set.

2. Click Done.

**Update cross-references manually**

Update a document at any time while you edit it or any other documents that are sources for the cross-references.

1. Choose Edit > Update References.

2. Select All cross-reference and click Update. If FrameMaker XML Author can’t resolve all the cross-references, the Update Unresolved cross-references dialog box appears.

**Resolve cross-references**

Occasionally, FrameMaker XML Author can’t update a cross-reference for the following reasons:

- The marker or source of the cross-reference has been moved to a different file, or the file itself has been moved or renamed.
- The source has been deleted, or if the source is a paragraph or spot, the marker indicating the source has been deleted.
- The file containing the marker is currently open by someone else on the network server.
- The value for the source element’s ID attribute or the cross-reference’s ID Reference attribute has been changed or deleted. The ID value must be the same at both locations.

**Resolve cross-references using the cross-references pod**

You can view the list of all unresolved cross-references from the cross-references pod. The pod list area displays the unresolved cross-reference, format of the cross-reference, document name, page number, source document, and the source type. All unresolved cross-references are indicated by a red cross symbol. You can select any cross-reference from the pod list area and the cross-reference is selected in the document.

- Select Unresolved cross-references from the References list box in the cross-references pod.
Generate a list of unresolved cross-references
You can generate a list of unresolved cross-references. The generated list includes the page number of each unresolved cross-reference and indicates whether each missing source is internal (in the current document) or external (in a different document). The list includes additional information—for example, the ID, element tag, and text of the source element. For spot cross-references, the list includes the marker text.

1. Choose Special > List of > References. When prompted, specify whether you want to create the generated file as a stand-alone document or add it to a book.
2. Move Unresolved Cross-Refs to the Include References scroll list, and then click Set.

Resolve a cross-reference when a marker has been moved to another file or the file has been renamed
1. Choose Edit > Update References.
2. Choose Update Unresolved cross-references from the Commands pop-up menu.
3. In the Total of Unresolved cross-references scroll list, select the file that used to contain the source of the unresolved cross-reference. The text below the scroll list indicates how many cross-references to the selected file are unresolved.
4. In the Look In scroll list, select the file that contains the source, and click Open.
   If FrameMaker XML Author can’t perform the update, select a different file in the Look In scroll list, and then try again.
5. To resolve cross-references to any other file listed in the Total of Unresolved cross-references scroll list, repeat steps 3 and 4. Then click Done.

Resolve a cross-reference when a marker has been deleted
1. Choose Edit > Find/Change.
2. Choose Unresolved cross-reference from the Find pop-up menu and click Find. The Find/Change panel finds the first unresolved cross-reference and provides information to Help you locate the source.
3. Do one of the following:
   • If you do not need the cross-reference, delete it.
   • If FrameMaker XML Author finds an unresolved spot cross-reference, insert a new cross-reference marker in the appropriate text. Use the same marker text that appears in the Find/Change panel.

Resolve a cross-reference when the ID and ID Reference values do not match
❖ Do one of the following:
   • Edit the ID or the ID Reference value so the two values match. ID attribute values are often read-only, so you sometimes have to edit the ID Reference.
   • Re-create the cross-reference.

More Help topics
"Insert a cross-reference in a document" on page 200
Chapter 9: Books and Long Documents

About books

A book file contains the filenames of the documents that make up the book, such as chapters and appendixes, generated files such as a table of contents, and other books. The filename and location of each file are added to the book file and a link is established between the file and the book.

A book can also be organized into a hierarchical setup of related documents using folders and groups. Folders act as chapters, sections, or sub sections depending on their hierarchical level within a book. You can also include related books within a book to build a complex documentation set.

A book file contains pagination and numbering settings for each file in the book. During a book update, FrameMaker XML Author updates the numbering throughout the book and can create and update the generated files as well.

Although books can include non-FrameMaker XML Author documents, such as .mif or .txt files, only .xml files are processed.

**Book building workflow**

2. Organize files into folders or groups if necessary.

**Set up hierarchical books**

In FrameMaker XML Author, you can create hierarchical books that can include multiple books and files organized under folders or groups.
210

USING FRAMEMAKER XML AUTHOR (2015 RELEASE)
Books and Long Documents

Last updated 8/18/2015
Hierarchical mixed FrameMaker XML Author book

Saving a hierarchical book as a FrameMaker 8 book flattens the hierarchical structure. FrameMaker XML Author flattens the hierarchical structure to a single level.

Create books

Create a book
1. Choose File > New > Book. If a document is active, an alert message asks if you want to include it in the book. A new book window appears showing the contents of the book.
2. Choose File > Save Book As. A .book extension is added to the filename.

Add files to a book
1. In the book window, choose Add > Files or click ➔. Add Files to Book...
2. Select the document file or files you want to add to the book, and then click Add.

You can add files by dragging them into a book window.

Note: You can also add files by specifying an HTTP path and filename in the Add Files to Book dialog box. When doing this ensure that you specify a correct path and filename else you may get a message that the file is not in a recognized format and an uneditable dummy file is added to the book.

Associate a structured application with an xml file
You can associate a structured application with the .xml files included in a book.
1. Right-click the .xml file in the book window and select Properties.
2. Select the structured application name from the Use Structured Application list box and click Continue.

Add a folder
You can add folders to your book and organize related documents in it. FrameMaker XML Author treats a folder as a logical container; it does not create a physical folder on the disk. A folder can have one or more folders, groups, or files within it.

Depending on the level at which you add a folder, it can act like a chapter, section, or subsection. You can set special numbering styles for a folder and all its contents. You can also choose to exclude files from being published by selecting Exclude from the context menu.

When you select a file in a book and add another file, the new file is added below and at the same level as the selected file. When you select a folder and add a file, the new file is added at the end of the files in the folder.
A. Select One.fm and add Four.fm. B. Select Folder1 and add A.fm.

Note: If a file is already present in a book, you cannot add it again within a folder.

 Rename a folder
  1 Right-click the folder and select Properties.
  2 Type a new folder name in the Title box and click Set.

 Associate a template with a folder
 Associate a template with a folder to publish a cover page for the files in the folder. Any template associated with a folder is published like any other file in a book. Use the \$chaptertitle\$ variable to include the folder name in the template associated with the folder. You can use this variable for a folder occurring at any level in a book.

  1 Right-click the folder and select Properties.
  2 Select the Template Path checkbox, browse, and select the template filename and click Open.
  3 Click Set. The folder icon changes to indicate that a template is associated with the folder.

      Note: Only XML files can be set as templates.

    Important: A template associated with a folder is published in a PDF like any other file in a book.

    To open a template associated with a folder, right-click on the folder and select Open. This opens all the files under the folder including the template file.

 More Help topics
 “File menu (book window)” on page 380
Add file information for a folder template
You can specify file information, such as author name, file title, keywords for a template associated with a folder.

1. Right-click the folder that has a template associated with it and select File Info.
2. Specify the file information and click Set.

Add a group
You can create groups in a book file. Like folders, groups are also logical containers in a book file; they do not exist on the disk. The difference between a group and a folder is that a group does not change the hierarchy of the files within it. Also you cannot set up numbering styles for a group.

For example, the chapter number increments sequentially if the chapter is in a group. For files organized under a folder, the chapter number remains the same but the section number can increment sequentially. You cannot explicitly change the chapter number for files in a folder as the files inherit this property from the folder.

Book 1
- File 1: Chapter number = 1
- File 2: Chapter number = 2
- File 3: Section number = 2.1
- File 4: Sub-section number = 2.1.1

Group 1
- File 5: Chapter number = 3
- File 6: Chapter number = 4

Folder 1: Chapter number = 5
- File 7: Chapter number = 5; Section number = 1
- File 8: Chapter number = 5; Section number = 2

Add a child book
You can also add books within books. These can be DITA maps. You can now include multiple child books at multiple levels in a book.

1. Open the parent book in which to add a child book.
2. In the book window, choose Add > Files or click

Note: You can click the Browse URL button in the Add File dialog box to select a book residing on a WebDAV server.

A child book is treated as a placeholder within the parent book. You cannot edit a child book from within the parent book view. All maintenance tasks must be performed in the child book separately. For example, any book-wide operation on the parent book, such as spell check or find/replace works only on parent book files and not on the child book files. You should search and update child books separately.

Similarly, when updating a parent book for pagination and cross-references, ensure that you first update the child books and then update the parent book. This is because numbering and pagination information is stored at a book level. A book update on the parent book does not affect the page numbering within the files in a child book if the files in the child book are closed.

However, if the files from the child book are already open, then they are updated but not saved. You should always explicitly save all open files after a book update command or after applying a book-wide command.
When saving a parent book file as a PDF, FrameMaker XML Author updates information for only those files that belong to the parent book. To ensure that the information is correctly represented in the PDF for child books as well, do one of the following:

- First update all child books and then their parent books before saving a book file as a PDF.
- Open all files, including the files in the child books before saving the parent book file as a PDF. After creating the PDF, ensure that you save all the open files to preserve any updates.

### Managing books

#### Manage book files

**Display filenames or heading text in the book window**

- Do one of the following:
  - Click the Display Heading Text icon.
  - Click the Display File Names icon.

**Exclude book components from output**

- Right-click the book component to exclude and select Exclude.
  
  If you exclude a folder or group, all files within the folder or group are excluded from the outputs. When you update a book, the numbering is automatically updated to account for the excluded files.

#### Selecting book components

**Select all book components** Choose Edit > Select > All.

**Select all generated files in a book** Choose Edit > Select > Generated Files.

**Select all non-generated files in a book** Choose Edit > Select > Nongenerated Files.

**Select only FMXA xml files** Choose Edit > Select > FrameMakerXMLAuthor Files.

**Select all excluded files** Choose Edit > Select > Excluded Components

**Select all the files that are not marked as Excluded** Choose Edit > Select > Nonexcluded Components.

**Select all book components at the first hierarchical level** Choose Edit > Select > Chapter Components.

**Select all book components at the second hierarchical level** Choose Edit > Select > Section Components.

**Select all book components at the third hierarchical level** Choose Edit > Select > Sub-section Components.

#### Rearrange and delete files

When working with structured books, you can rearrange and delete files by working with element bubbles in the Structure View. After you update the book, the text snippets identify the files.

If you delete a file from a structured book you’ve updated, the file may retain some structure information inherited from the book. Remove this information from the file to make it a stand-alone document again.

- In the book window, select one or more files. Do either of the following:
  - Drag the selected files to the desired position in the book window.
• Choose Edit > Delete. Filenames are removed from the book window, but the files remain on the disk.

**Rename files**
When you rename a file in a book, FrameMaker XML Author renames the corresponding file on the disk and updates cross-references, hypertext links, and text inset links in other files in the book.

When you add a generated file (such as a table of contents or index) to a book, the file is assigned a name based on the book’s filename. If you leave generated files with the default filename and rename the book, then the filename is changed in the book, but not on disk. If you rename the generated file so it doesn’t have the default name, renaming the book won’t rename the generated file.

For example, in New.book, you have a generated file with the default name NewTOC.fm. If you rename the book to Samples.book, FrameMaker XML Author renames the generated file to SamplesTOC.fm in the book window, but not on disk. But if you rename the generated file as Contents.fm and then rename the book, the generated TOC remains Contents.fm in the book window as well as on disk.

1 Select the file you want to rename, and either choose Edit > Rename or right-click and choose Rename.
2 Type the new name of the file and press Enter. When the alert message appears, click OK to update other files in the book.

**Revert to a previously saved version**
This procedure affects files that have been added or deleted, as well as settings that have been applied to documents in the book, such as numbering, pagination, color definitions, and file setup specifications. The contents of documents are not changed.

❖ Choose File > Revert to Saved Book.

*Note: This command clears the command history. To undo only selected commands, use the History panel instead of Revert To Saved Book.*

**Open, close, or save files**
You can use a book window to open, save, print, and close individual files in a book. You can also open, save, and close all the files in a book and print and update the format of several files or all files.

When you open a non-FrameMaker XML Author document from the book window, the appropriate application, if available, is launched.

❖ Do one of the following:
- To open one file in a book or map, make sure only the file is selected and double-click it.
- To open several files in a book, select the files you want to open and press Enter.
- To open all files in the book, hold down Shift and choose File > Open All Files In Book.

*Note: Using Open All Files in books can be time consuming if there are many cross-references and text insets to update in the file. You can suspend the automatic update of cross-references or text insets by choosing Edit > Suppress Automatic Reference Updating from a book window, selecting the appropriate check box, and then clicking Set. When you open an individual document that has settings for automatic update, cross-references and text insets are still updated.*

- To close all files in a book, hold down Shift and choose File > Close All Files In Book.
- To save all files in a book, hold down Shift and choose File > Save All Files in Book. The book file is also saved.
Compare documents
FrameMaker XML Author can compare two versions of a document to show you what has changed. FrameMaker XML Author compares not only the text in the two versions, but also the footnotes, markers, anchored frames, text insets, variables, and cross-references.

Note: For structured documents, FrameMaker XML Author additionally compares the structure of the two documents and optionally can compare the attributes within those structures.

1 Open both versions of the documents.
2 In the document window of the newer version, choose File > Utilities > Compare Documents.
3 Specify the older version of the document to be compared.
4 Choose the report format. You can either have a summary document or a composite document.
   The summary document gives a report of the differences in the files. Composite documents (which have a CMP suffix) show the differences in the files side by side.
5 To set up the comparison options, click Options. The options screen is displayed as follows:

![Comparison options](image)

Note: To compare attributes within the structures, select Compare Attributes For Elements. If this option is not selected, attributes within the structures are not compared.

6 Click Compare. The results are displayed in the selected reporting format.
7 All differences are displayed with Track Changes. You can accept or reject the changes as desired.

Apply book-wide commands
Many FrameMaker XML Author commands can be used across some or all documents in a book. You can change view options, spell-check, or change the page layout of selected files in the book, among other options.

If the document associated with a book is open, FrameMaker XML Author applies the book-wide command to the document, but the document is not saved or closed. Therefore, in the case of open documents, you should explicitly save the changes before you close them.
If the document associated with the book is closed, FrameMaker XML Author silently opens the document, applies the book-wide commands, then saves and closes the document. If FrameMaker XML Author is unable to open a closed file or if other problems occur when you apply the command to a selected file, a message appears in the Book Error Log.

1. In the book window, select the file or files you want to change.
2. Choose the desired command, such as Edit > Spelling Checker.

   For .xml files, open the files before applying a book-wide command.

In structured documents, you can edit attributes, set available elements, and set new element options in the book.

**Add metadata to books and documents**

Metadata tags travel with a document and describe its content. If you export the file to PDF, much of this metadata will appear in Adobe® Acrobat®.

Metadata, or file information, is descriptive information that can be searched and processed by a computer. Use it to provide information about the contents of a document, and to preserve information about a document that will be opened in other Adobe applications. If you export the file to PDF, much of this metadata will appear in Acrobat.

Metadata tags travel with the document and describe its content. By embedding them in your documents, you make the documents easier to track, manage, and retrieve.


1. Make the appropriate document window or book window active. If a book window is active, select the documents you want to affect.
2. Choose File > File Info.
3. Enter the desired information in the box next to any or all categories.
4. For Marked, choose Yes if the document is copyrighted, or No if the document is explicitly in the public domain. Choose Unknown if you’re not sure.
5. Click Set.

**Footnotes and endnotes**

*Footnotes* are notes placed at the bottom of a page that comments on or cites a reference for a designated part of the text. *Endnotes* are notes placed at the end of a chapter or book that comments on or cites a reference for a designated part of the text.

**Create and edit footnotes**

**Insert, edit, and delete footnotes**

When you insert a footnote reference and footnote, FrameMaker XML Author gives it a number, formats the text of the footnote, and inserts a separator if the footnote is the first one in a column.
As you insert, move, and delete footnotes, FrameMaker XML Author adjusts the numbering. As you edit the surrounding text, FrameMaker XML Author moves the footnotes from page to page as needed. FrameMaker XML Author allows document footnotes to be numbered consecutively across all files in a book.

The footnote reference and the footnote itself usually appear in the same column. When you insert a footnote reference in a table, the footnote appears at the end of the table. If the table flows onto a second page, all the footnotes appear on the second page regardless of the page on which the footnote reference appears.

**Insert a footnote**

*Note: The Footnotes feature supports the Unicode text encoding standard.*

1. Click where you want the footnote reference to appear. You can insert a footnote reference in a column of text or in a table cell.

2. Choose Special > Footnote. FrameMaker XML Author inserts the footnote reference, displays the footnote number at the bottom of the column or below the table, places the insertion point after the footnote number, and renames any footnotes that follow. (Footnotes are numbered consecutively in a text flow. If your document contains several text flows, footnote numbering in each flow will be independent of the others.)

3. Type the text of the footnote at the insertion point. When you finish typing the footnote, return to the main text by clicking in it or by choosing Special > Footnote again.

   *To place two footnote references together, place a space or a comma between them—for example, references 5, 6 or references 5, 6. Otherwise, the second footnote won’t be created. If you place a comma between the footnote references, you should manually format the comma in superscript.*

**Insert a footnote element (structured documents)**

1. Click where you want the footnote reference to appear.

2. Select a footnote element in the Element Catalog and click Insert.

   FrameMaker XML Author inserts the footnote reference, displays a footnote number at the bottom of the column or end of the table, and renumbers any footnotes that follow. A bubble for the footnote appears in the Structure View, with a text snippet that shows the beginning of the footnote text.

   You can also use Special > Footnote to insert a footnote element. If more than one footnote element is available, choose one from the Element Tag pop-up menu in the dialog box that appears.

3. If the Attributes for New Element dialog box appears, enter attribute values for the element and click Insert Element.

4. Type the text of the footnote at the insertion point. When you finish typing the footnote, return to the main text by clicking in it or by choosing Special > Footnote.
Use an invalid footnote element
If no footnote element is available at the location you want, you might use an invalid element. After inserting the element, talk to your developer about making it valid at this location.

❖ Do one of the following:
  - To use an element that is valid in another part of the document, either insert the element in a valid location and then move it, or use the All Elements setting to make the element available everywhere and then insert the element where you want it.
  - To insert an invalid footnote with the default tag FOOTNOTE, choose Special > Footnote. (A default footnote is created if no defined footnote elements are available.)

Edit a footnote
❖ Select the footnote text and edit it as you do other text. You can’t change a footnote number, because FrameMaker XML Author maintains the numbering.

Duplicate, move, or delete a footnote
1 Select the footnote reference (not the footnote text). Alternatively, in Structure View, click the footnote’s bubble.
2 Do one of the following:
  - To duplicate or move the footnote, use Edit > Copy or Edit > Cut, and then Edit > Paste.
  - To delete the footnote, press Delete.

Keeping a footnote in the same column as its reference
FrameMaker XML Author sometimes can’t keep footnotes in the same column as the corresponding footnote reference. For example, if you insert a footnote reference at the bottom of a column of text so there is no space for the footnote below it, FrameMaker XML Author moves the footnote to the bottom of the next column. In such cases, you can force a column or page break before the footnote reference to keep the reference and the footnote together in the same column.

Adding text to a footnote may cause the last footnote in a column or on a page to move to the bottom of the next column or page. To reduce the chance of a footnote not fitting in a column, allocate more space for footnotes in a column.

Insert multiple references to a footnote
You can create a single footnote that has several footnote references—for example, a table footnote with references in several cells.

<table>
<thead>
<tr>
<th>Type</th>
<th>Depth in Kilometers</th>
<th>Greatest Richter Magnitude</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shallow</td>
<td>0-600 km</td>
<td>8.6</td>
</tr>
<tr>
<td>Intermediate</td>
<td>60-300 km</td>
<td>7.5</td>
</tr>
<tr>
<td>Deep</td>
<td>300 or more</td>
<td>6.9</td>
</tr>
</tbody>
</table>

a. Approximately 60% of all earthquakes occur at depths between 0 and 100 kilometers

Two references for one footnote
Important: If you add or remove a footnote that appears before the footnote being cross-referenced, the cross-reference may refer to the wrong number. Choose Edit > Update References to update the numbering.

1. Insert the first footnote reference.
2. If necessary, create a cross-reference format for additional footnote references.

   The cross-reference format must display the footnote number correctly. For example, if footnote references are displayed in superscript, and if the document contains a Superscript character format, a cross-reference format defined as &Superscript;&$paranumonly; displays the autonumber of a paragraph as a superscript. When you use it to refer to a paragraph that contains a footnote, it displays the footnote number in superscript.

3. Click where you want to insert the additional footnote reference.
4. Choose Special > cross-reference to insert a cross-reference to the footnote where you clicked. Use the cross-reference format you created in step 2.
5. Click Insert. FrameMaker XML Author inserts a cross-reference that is identical to the original footnote reference.

Insert multiple references to a footnote (structured documents)

You need to have a special cross-reference element already defined for the additional references. The element should display a reference number in the same way that the original footnote reference does. For example, if the number is in superscript in the original reference, the number in the cross-reference element should also be in superscript.

1. Insert the footnote element.
2. Where you want an additional footnote reference, insert a cross-reference element that was defined to display only a footnote reference.

Create and maintain endnotes

Create an endnote

1. Type the first endnote at the end of the document and assign it the paragraph format for endnotes. The paragraph format should include an autonumber so the endnotes will be numbered consecutively.
2. Click where you want to insert the endnote reference and cross-reference the endnote. Use the cross-reference format you created for endnotes.

   For example, if endnote references are to be displayed in superscript, and if the document contains a Superscript character format, the cross-reference format &Superscript;&$paranumonly; displays the autonumber of the endnote paragraph as a superscript.

Create an endnote in structured documents

1. Insert the endnote element at the end of the document, and type the text of the note.
2. Click where you want to insert the reference to the endnote.
3. Insert a cross-reference element that was defined to display an endnote reference.

   Note: Make sure that the sequence of endnotes is the same as the sequence of references in the document. FrameMaker XML Author does not automatically sequence endnotes as it does with footnotes.

Maintain endnotes

- If you change the order of endnote references while editing the document, rearrange the endnotes to match the order of the references. Then update the cross-references to update the endnote reference numbers.
• If you delete an endnote, delete all references to it. Otherwise, the reference will be an unresolved cross-reference.

**Conditional documents**

**About conditional tags**

Sometimes you author different types of content for different output formats using the same FrameMaker XML Author document. This document can contain conditional tags and conditional graphics for each type of output. For example, to create both a PDF print version and an HTML Help version of a document, mark the different content for each using condition tags.

You can also use conditional tags to include comments to yourself or to your reviewers. You can hide the comments before you print the final copy.

Conditional tags differ from one version of a document to another. Unconditional text is common to all versions.

You can make any unit of text conditional, from one character to entire sections. Anchored graphics, tables, cross-references, footnotes, markers, and table rows can be conditional. You make an item conditional by applying condition tags.

Two versions of a data sheet: Conditional tags can be used to create two data sheets in one document. The text and graphics common to both data sheets are unconditional. The text and graphics that appear in only one data sheet are assigned a condition tag that identifies the data sheet.

A. The art and first paragraph contain both conditional and unconditional information.

B. Unconditional text.

The condition tags of the current selection (or at the insertion point) appear in parentheses in the Tag area of the status bar.

You can change the appearance of conditional tags so that it’s easy to identify by using condition indicators—style and color changes.
You can view all versions of the document or hide selected versions. You can show or hide condition indicators. Whatever you display appears in the printed document.

**Conditional Tags pod**

The Conditional Tags pod:

- Lets you apply and manage conditional tags
- Displays the tags that are applied

### States of conditional tags

When you select a piece of content, the Conditional Tags pod displays the three possible states of conditional tags, applied, not applied, and as is, as following:

<table>
<thead>
<tr>
<th>State</th>
<th>As per the selected text means</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Apply" /></td>
<td>Applied: The conditional tag is applied to the selected content.</td>
</tr>
<tr>
<td><img src="image" alt="Not Apply" /></td>
<td>Not Applied: The conditional tag is not applied to the selected content.</td>
</tr>
</tbody>
</table>
To see the state of the various conditional tags as per selected content, see the State column in the Conditional Tags pod. You can select or deselect the various conditional tags to apply by clicking the check boxes in the state column of the Conditional Tags pod. After you have made selections, the following can appears in the State column:

<table>
<thead>
<tr>
<th>State + asterisk</th>
<th>What happens when you click Apply?</th>
</tr>
</thead>
<tbody>
<tr>
<td>☑</td>
<td>Gets applied to the selected text</td>
</tr>
<tr>
<td>☐</td>
<td>Gets removed from the selected text</td>
</tr>
<tr>
<td>☑</td>
<td>No change</td>
</tr>
</tbody>
</table>

**Planning conditional documents**

When planning a conditional document, assess the nature of the material and the number of people maintaining the document. Plan to treat conditional material consistently to make the document easier to use and maintain. Inform others of the conventions you followed as you applied condition tags.

Use these guidelines when planning a conditional tags project:

**Number of versions** Define how many versions you intend the finished project to contain. For example, to create a manual that describes a program that runs on two platforms, you likely produce at least two versions. Sometimes you want these versions with editorial comments added to text during review. In this case, you can add more versions: UNIX with comments, UNIX without comments, Windows with comments, and Windows without comments.

**Number of condition tags required** Decide how many condition tags you want to produce the desired versions. A unique set of condition tags defines each version of a document. For example, a Windows condition tag showing, a UNIX condition tag hidden, and a Comments condition tag hidden defines a version of a finished Windows manual. In this example, decide whether to use one condition tag for Windows comments and another for UNIX comments. You can also use a single condition tag for both Windows and UNIX comments.

**Organization of content** Assess how much of the document can be conditional and how you can organize the material to simplify development and maintenance. Perhaps you can organize a book so that conditional tags is limited to a few documents. You can keep versions of a chapter in separate files rather than in conditional tags. Then use a different book file for each version of the book. Alternatively, in a structured document, you sometimes want to specify entire chapters of a book for printing only.

**Graphics** If a document contains graphics imported by reference into a conditional anchored frame, create separate folders for the graphics in each version. Creating separate folders simplifies file management when you copy or archive a version of the document with its graphics files.

**Variables** Words and phrases that are used repeatedly in a document are easier to work with as variables than as conditional tags.

Decide whether your conditional documents need different variable definitions for each version. For example, a data sheet can use a variable with the product name, while the conditional document describes two products. You can create
a template for each version of the document. Each template has only one version visible and defines the variables for that version. You can use File > Import > Formats to switch the variable definitions from one version to another.

**Tagging strategy** Determine the smallest unit of conditional text. For example, if a conditional document is translated to another language, a whole sentence is the smallest amount of text you make conditional. Because word order often changes during translation, using conditional tags for part of a sentence complicates translation. Other strategies include these guidelines:

- Decide whether to make spaces and punctuation conditional. If a conditional tag begins or ends with punctuation, make the punctuation conditional. Conditional punctuation makes the text easier to read when you’re viewing more than one version.
- To avoid word spacing problems, set standards for handling spaces following conditional tags. Define them as either always conditional or always unconditional.
- Decide the order in which conditional tags appear and use this order throughout the document. The order can Help subsequent authors maintain the document.

**Multiple authors** If a conditional document has several authors, follow these guidelines:

- Plan document organization and workflow. For example, break a document into small files so several people can work on different parts of the document at the same time.
- Decide how to provide explanatory notes to other authors. To Help explain a conditional document, add helpful comments and apply the predefined Comment condition tag to them.

**Apply and remove condition tags**

To make text conditional, you apply tags, or copy and paste condition tag settings. You can apply multiple tags to text in a FrameMaker XML Author document.

You can distinguish text to which a single condition tag is applied, from text with multiple condition tags.

You apply a new condition tag to selected text to which another condition tag is already applied. In this case, the color of the text is changed to a different color. This color is a new, unique color different from the colors the condition tags that you have already applied to the current text.

You can also use the Find/Change command to paste condition tag settings.

| You can merge two versions of a document into one conditional document. When you merge two versions, FrameMaker XML Author compares them and creates a composite conditional document. |

**Apply a condition tag to an item**

Before you apply conditional tags, you need to understand “States of conditional tags” on page 222.

1. Select the text or item you want to make conditional, as described in the following table:

<table>
<thead>
<tr>
<th>To make this conditional</th>
<th>Select</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text in a text frame, table cell, or footnote</td>
<td>Text</td>
</tr>
<tr>
<td>Anchored frame and its contents</td>
<td>Frame border or anchor symbol</td>
</tr>
<tr>
<td>An entire table</td>
<td>Table anchor symbol</td>
</tr>
<tr>
<td>Table row</td>
<td>Whole row</td>
</tr>
</tbody>
</table>
To apply conditional tags to the selected text or item, check one or more conditional tags in the Conditional Tags pod. When you select one or more conditional tags, the tags that will be applied or removed from the selected text are marked with asterisk. For more information, see “States of conditional tags” on page 222.

3 Click Apply. FrameMaker XML Author applies the settings to the selected text. If you apply a hidden condition tag, the selected text disappears, unless it is also tagged with a condition that is displayed.

FrameMaker XML Author has a new feature that allows you to apply a conditional tag to the whole element, even if only a part of the element is selected. The conditional tags element boundaries feature is only applicable to structured documents.

To enable this feature, edit maker.ini and set the value of ApplyCondTillElementBoundaries to On. Restart FrameMaker XML Author.

Now, selecting some text within an element and applying a condition, will apply the condition to the whole element and not just to the selected text.

Additionally, with this feature, a single cell in a table can be selected and a condition applied. The condition is then applied across the entire corresponding row in the table.

Copy and paste condition tag settings
1 Place the insertion point in text that uses the condition tag settings you want to copy.
2 Choose Edit > Copy Special > Conditional Text Settings.
3 Make a selection or click to place the insertion point.
4 Choose Edit > Paste.

Avoiding unresolved cross-references
Sometimes you insert a cross-reference to a paragraph, and the first word in the paragraph is conditional. The Cross-Ref marker that FrameMaker XML Author inserts is also conditional (with the condition tag settings of the first word). The marker is hidden when you hide the conditions of the first word. As a result, the cross-reference is sometimes unresolved if condition tag settings of the cross-reference and of the cross-reference marker differ.

To avoid this situation, select just the Cross-Ref marker at the beginning of the source paragraph, and make it unconditional. Then the marker is always visible. The cross-reference is resolved no matter which version is visible.

Remove condition tags from an item
Removing a condition tag from an item is different from deleting a tag from a document. When you remove a tag from an item, the tag remains in the document so it can be applied to other items later. When you delete a tag from the document, FrameMaker XML Author removes the condition tag from any text that uses it. Then it deletes the tag from the Conditional Tags pod.

Select the item with the tag you want to remove and choose the Unconditional option from the Conditional Tags pod and click Apply. The item remains in your document but the conditional tag no longer applies to it.
Generate conditional output using Boolean expressions

You can generate conditional output by building a Boolean expression with combinations of condition tags and Boolean operators.

For example, your document contains the Comment, Print, Help, and PDF condition tags. To show text tagged with the Print and PDF condition tags only, click Build Expression, and define the following expression in the Build Expression dialog box:

"Print" AND "PDF"

After you apply this expression, the document displays only text marked with the Print and PDF condition tags. Alternatively, to include text tagged with either the PDF or Print condition tags in the output, you can modify the expression as follows:

"PDF" OR "Print"

Automatic validation and visual cues in the conditional expressions

The Manage Conditional Expression dialog automatically validates your conditional expressions as you are creating them. The Manage Conditional Expression dialog has the following visual cues to help you build the correct conditional expression.

Boolean expressions with parenthesis

You can also use parenthesis in Boolean expressions. Using parenthesis within the Boolean conditional expression simplifies the expression as compared to without the parenthesis.
Parenthesis simplify conditional expressions

With parenthesis, you can create a shorter conditional expression, which is easier to create and to understand.

For example, a document has the following conditional tags applied:

1. Platforms: Win, Mac, and Unix
2. Versions: version1, version2, and version3
3. Output: PDF, HTML, ePub, and RTF

If user wants Windows® or Mac along with all versions except version1 and output format PDF or HTML, using parenthesis you can create the following expression:

The same conditional expression without the parenthesis looks like the following:
"Win" and not "version1" and "PDF" or "Mac" and not "version1" and "PDF" or "Win" and not "version1" and "HTML" or "Mac" and not "version1" and "HTML"

Build a conditional expression
1 Select Show/Hide Conditional Text icon from the Conditional Tags pod.
2 Select the Show As Per Expression option.

Note: All conditional expressions created and applied in the document, are listed in the Expression pop-up menu.
3 Click the Build Expression button.
4 In the Manage Conditional Expressions dialog box, enter a name for the conditional expression.
5 Select a tag from the Condition Tag list and click the arrow button, or double-click the tag you want to add. The tag appears in the Expression area. You can use parenthesis to build sophisticated Boolean conditional expressions. For more information, see “Boolean expressions with parenthesis” on page 226.
6 Click the AND, OR, NOT, or () button. As you use these buttons and other building blocks to create conditional expression, FrameMaker XML Author automatically validates the expression and provides you visual cues to assist you. For more information, see “Automatic validation and visual cues in the conditional expressions” on page 226.
7 Repeat steps 4, 5, and 6 to add tags and build the required expression. Place the cursor in the Expression area to create or edit an expression.
   Click the Clear button in the Build Expression dialog box to completely clear an expression.
8 Click Add.

Apply a conditional expression for a document
1 Select Show/Hide icon from the Conditional Tags pod.
2 Select the Show As Per Expression option.
3 Select the conditional expression from the Expression menu, and click Apply.

Import conditional expressions
You can import conditional expressions that you defined in the source document to one or more target documents. When you import the conditional tags settings, conditional build expressions and the status of the Show As Per Expression setting are added to the target documents. Conditional expressions that exist in the target documents are replaced by those imported from the source document.
1 Select File > Import > Formats.
2 In the Import Formats dialog box, deselect all options, and then select Conditional Text Settings.
3 Select the source document from the Import From pop-up menu, and click import.
   Any conditional expressions defined in the source document are imported into the target documents.

Edit a conditional expression
You can edit an existing conditional expression. You can also redefine an expression. You can quickly create a new conditional expression by editing an expression and then saving it with another name.

Note: Name of an existing conditional expression cannot be changed.
1 Select Show/Hide Conditional Text icon from the Conditional Tags pod.
2 Click the Build Expression button.
3 In the Manage Conditional Expressions dialog box, select the conditional expression you want to edit.
4 Make the required changes, click Edit, and click Done.

**Working in conditional documents**
You can view or print all unconditional and conditional text simultaneously. You can also hide the conditional text of one or more versions. FrameMaker XML Author ignores hidden conditional text when formatting a document. When text symbols are visible, hidden conditional text is represented onscreen by a conditional text marker □.

![](Markers show where conditional text is hidden.)

**Change the view of conditional documents**
A conditional document can display any number of conditions at a time and can have any of its condition indicators on or off. For example, you can change the view to display the condition tags for one particular version, for several versions, or for all versions. To display more than one version, you leave the condition indicators on. Also leave them on if you’re displaying one version and want to see which part is conditional.

You can view conditional text by selecting one of the following options:

- **Show All** Shows all text to which condition tags have been applied.
- **Show As Per Condition** Shows text based on a specific condition tag.
- **Show As Per Expression** Shows text based on an expression that includes a complex combination of condition tags and Boolean operators.

1 To change the view of a conditional document, click Show/Hide Conditional Text from the Conditional Tags pod.
2 Do one of the following to select the conditional tags that you want to show or hide in the document:
   - Select the Show All option.
   - Select the Show As Per Condition option. Move the desired condition tags between scroll lists. If any condition tag in the Show list is applied to text in your document, the relevant conditional tags appear in the document. You can select the Show If All Conditions Applied option only if all condition tags selected in the Show list are applied to that text.
   - Select the Show As Per Expression option, and then select an expression from the pop-up menu.
3 Indicate whether you want to display condition indicators, and click Apply.

*Note: Condition indicators are style and color parameters that are used to distinguish conditional tags from plain text. For example, you can create a Condition Tag called Private Comment and configure its Style as Double Underline, and its Color as Blue.*
Viewing imported conditional tags

When you import text containing passages of conditional tags, all the condition tags applied to text in the source document are also imported. You can use them to show or hide imported conditional tags. Even if you import the text by reference and it appears in a text inset, you can change the view of conditional tags in the inset.

The following conditions determine whether text is shown or hidden:

- When the Show All option is selected in the destination document, all conditional tags appear.
- When the Show As Per Condition option is selected in the destination document, conditional tags matching any selected condition tags in the Show list appears in the document. When the Show If All Conditions Applied option is selected in the destination document, all conditional tags in the document are displayed only if all the tags that you selected in the Show list are applied to text in the document.
- When the Show As Per Expression option is selected in the destination document, only conditional tags based on the selected expression appear.

**Note:** If you don’t select any of these options, conditional tags are initially shown or hidden according to the settings in the destination document. If imported condition tags don’t match tags in the destination document, conditional tags are initially shown or hidden according to the settings in the source document.

Find and edit conditional tags

When you work in a conditional document, FrameMaker XML Author generally ignores hidden text. For example, the Find/Change and Spelling Checker commands check only displayed text. However, you can cut, copy, and paste hidden text by selecting the conditional tags marker and by using the Edit commands.

In a conditional document, work with text symbols turned on. Conditional text markers alert you to text that is in other versions of the document. You can change conditional tags in the following ways:

- To find conditional tags, search for items tagged with a visible condition tag. FrameMaker XML Author finds conditional tags in text frames, graphic frames, and table cells. It also finds conditional table rows.
- Use the Edit menu commands as you normally do.

  When you copy text, FrameMaker XML Author copies its conditional text markers and condition tag settings.
  When you paste text with a condition tag that’s not in the destination document, FrameMaker XML Author adds the tag to the destination document. When you try move or delete hidden conditional tags, FrameMaker XML Author displays an alert message. You can delete the text or cancel the command.

- Use Paragraph and Character Designers to apply format changes to hidden text.
Paragraph and character format changes you apply to selections don’t update conditional tags hidden within the selection. To apply a format change to all paragraphs or characters, including hidden conditional tags, click Update All in the designer. Or, you can choose Update All from the Paragraph Format pop-up menu on the formatting bar. Applying format changes with Import > Formats also updates hidden conditional tags.

- To spell-check or search through all text, show all conditional tags before using Edit > Spelling Checker or Edit > Find/Change.

**Finalizing conditional documents**

Before you produce a finished version of a conditional document, follow these guidelines:

- Change your view of the document to include only the version you want to print, and turn off condition indicators.
- If your document contains variables, make sure that the variable definitions are correct for the version you’re printing.
- Spell-check the document. This feature finds double spaces and punctuation problems caused by incorrectly tagged with conditional tags.
- Update cross-references. If the document contains unresolved cross-references, perhaps they point to cross-reference markers in hidden conditional tags. Show the version and update the cross-references again.
- Create a copy of the document for each version before manually adjusting line and page breaks. Use the copy for each version for making the adjustments and for printing. These adjustments differ with each version. Use the original document for future edits.
- If the document is part of a book, update the book and its generated files. If the book contains documents with different condition indicators for the same tag, FrameMaker XML Author displays an alert message. It also alerts you if some condition tags are displayed in one document but are hidden in another. If this situation occurs, click Cancel to stop book generation. Correct the conditional tags settings of your documents.
- After generating an index, check it for double question marks (??), which indicate missing or incorrect index markers.

**Editing elements in conditional structured documents**

You can insert, wrap, merge, and split elements in conditional structured documents as you can in other documents. FrameMaker XML Author applies the following conditions as needed:

- When you insert an element, the new element takes the condition tags of the location of the insertion point.
- When you wrap an element, the new element generally takes the condition tags of the location of the selection. If the selection crosses boundaries, the next two conditions apply.
- When you wrap a selection that crosses the boundaries of two conditions, the new element does not take any condition tags. The contents of the element keep their tags.
- When you wrap a selection that crosses the boundary of conditional and unconditional text, the new element does not take any condition tags. The contents are still partly conditional and partly unconditional.
- When you merge two or more elements that have different condition tags, the new element does not take any condition tags. The contents of the element keep their tags.
- When you split an element, the two elements have the same condition tags as the original element.

Validate each version in a conditional document showing only one version at a time.
Note: If a filter is applied to a structured document, this expression overrides all conditional tags in the document. When you apply a filter to a structured document to generate output, conditional indicators are disabled. If you switch back to conditional tags to generate the output, re-enable the conditional indicators.

Troubleshooting books

Even though you can update and generate a book without error messages, the book may still have some problems that need correcting.

Generated file is empty  Make sure the name of the generated file is preceded by a generated files icon in the book window. If it isn’t, the file was added as a document to the book file rather than as a generated file (see “Create a book” on page 211). When a file is added as a document file, FrameMaker XML Author won’t generate it. Also check that the setup of the generated file is correct.

Slow performance  To improve performance, open as many files in the book as possible before you use Edit > Update Book or File > Import > Formats in a book window. After using the command, save all the files in the book.

Note: In addition, if you experience slow performance while working with books, minimize or remove the Show/Hide Conditional Text panel from your workspace.

Chapter starts on wrong side  You need to correct your documents’ pagination.

Interpreting error messages

The Book Error Log reports all errors that occur when you apply a command to a book. In addition, many error messages contain hypertext links so that you can click the message in the Error Log to display the location of the error.

Unresolved Cross-Refs  The Book Error Log lists all files that contain unresolved cross-references.

Inconsistent Show/Hide Settings, Inconsistent Use Condition Indicators, or Inconsistent Condition Indicator  The indicated file contains conditional text settings that differ from those in the previous file in the book. You can make the settings in each file the same (by using Special > Conditional Text) or you can update the settings throughout the book at once. To do this, change the settings in one file and then use File > Import > Formats to apply the settings to the entire book.

Inconsistent Numbering Properties  The numbering properties specified in the component are different from the book’s numbering properties. The book’s numbering properties override those of the document.

Inconsistent Color Settings  The indicated file contains color separation settings or color definitions that differ from those in the previous file in the book.

Couldn’t Open File  The Book Error Log will indicate if the file was saved using an older format, if it used unavailable fonts, or if it cannot locate the file. For more information on the problem, open the file to see the alert message that appears.

Book Not Self-Consistent  The contents of generated files, the page count, or cross-references continued to change while generating and updating files in the book. For example, if a book contains both a list of markers and an alphabetical list of markers, and if both contain hypertext links, the number of markers grows each time the files are generated. If this happens, move one of the generated lists out of the Include scroll list when you use the Generate/Update command again.

Inconsistent Element Boundary Settings  In a structured book, element boundaries are showing in some files in the book but not in others. Fix the settings in individual files to make them consistent.
Chapter 10: Working with Documents

Importing and linking files

Import and link methods
You can import other Adobe FrameMaker XML Author documents, documents created in other applications, text files, and graphic files. You can also import SWF files and 3D objects into FrameMaker XML Author documents. An imported object can simply be copied into the document. It can also be linked—such as when you import by reference—so that it remains tied to its source for easy updating.

More Help topics
“Import text” on page 237
“Import graphics” on page 239
“Embedding objects” on page 251

Use the clipboard
Perhaps the easiest way to import text and graphics is by copying to and pasting from the clipboard. When using this method, keep in mind the following:

1. Select the object or text you want to copy and Choose Edit > Copy. The contents is copied to the clipboard.
2. Place the insertion point in the document where you want to paste the content, and then choose Edit > Paste.

When using this method, keep in mind the following:

• You can convert tab-delimited text to a table using the Table > Convert To Table command.
• Text formatting is lost unless you’re pasting into another FrameMaker XML Author document.
• Choosing Edit > Paste Special offers you more options. For example, you can choose to paste text in the RTF format or as an embedded Microsoft Word document. If you want to apply FrameMaker XML Author formats, then paste clipboard content as text. For graphics you can paste clipboard content as an embedded bitmap, a device independent bitmap, or a metafile.

Use drag-and-drop
Import and export are greatly simplified when you can drag an object to its new location.

FrameMaker XML Author supports the following drag-and-drop operations:

• Move a graphic from one open FrameMaker XML Author document window to another by dragging the graphic. You can also copy it by Control-dragging it or display a context (shortcut) menu when you drop it by right-dragging it.
• Drag a graphic between a FrameMaker XML Author document window and any other application that supports drag-and-drop operations.
• Drag a graphic file from a folder or the desktop into an open document window.
• Drag one or more document files into the application window to open the files, or you can drag a single file into a document window to embed that file.
Use the File > Import > File command

Import by copying
Importing by copying makes it easy to transfer the imported material from one location to another, but it increases the document size. In addition, if you change the source material, you need to reimport it to update the document with the latest version.

❖ Choose File > Import > File, choose the file you want to copy, and then select Copy Into Document.

Import by reference
Importing by reference keeps the imported text or graphics linked to the source file. FrameMaker XML Author stores the path to the source file in the document. Each time you open the document, FrameMaker XML Author locates the file on the disk and displays it. If the source file was revised, FrameMaker XML Author updates the document with the latest version. Importing by reference can reduce total file size because it lets you use the same material in several places without storing the contents of imported images or text in the FrameMaker XML Author document. Text imported by reference is called a text inset.

❖ Choose File > Import > File, choose the file you want to copy, and then select Import By Reference

For information on how the path is stored when importing by reference, see “Using paths when importing by reference” on page 237.

Use the File > Import > Object command
The main benefit of using Object Linking and Embedding (OLE) is to display visualizations of data created in programs other than FrameMaker XML Author. The File > Import > Object option associates the imported object with the program used to create it so that you can edit the object in its native software. For example, you can insert a pie-chart created using Microsoft Excel in a FrameMaker XML Author document. Each time you double-click the inserted object, FrameMaker XML Author opens it in Microsoft Excel for you to edit.

Note: You cannot embed or link an object whose native software is not installed on your computer. For example, if you open a document having a Photoshop image embedded through File > Import > Object, you need to have Photoshop installed on your computer to be able to edit this image.

Consider the following factors when deciding whether to import text and graphics by reference or to use OLE to embed or link them instead:

• If the material you want to include comes from another FrameMaker XML Author document, use import by reference. This provides many more import options.
• If you want to collapse a linked file to an icon instead of displaying the full contents of the file in your document, use OLE linking.
• If the material you want to include is in a format that FrameMaker XML Author can’t open, use OLE.
• If you edit or view your document on multiple platforms, use import by reference. OLE works only in Windows.
• If the text or graphics you want to include comes from an application that doesn’t support OLE, use import by reference.

Text insets

Text inset pod
You can use the Insets pod to manage and troubleshoot all objects linked or embedded in your FrameMaker XML Author documents.
**View the properties or source of text insets**

You can view the filename and file type of the source document, the date it was last modified, the date the text inset was last updated, and the inset's update setting. You can also display the source of a text inset.

1. Click the text inset to select it and choose Edit > Text Inset Properties. You can also double-click the inset in the Insets pod.

2. If you want to open the source of the text inset, click Open Source. The source is opened as a FrameMaker XML Author document.

**Control the updating of text insets**

You can control how and when text insets are updated from their source documents. For example, you can specify either automatic or manual updating, and you can manually update a single text inset or several insets in the document.

*Note: Text imported by reference is automatically updated only if its date stamp indicates that it is out of date. However, because the time settings may differ between file systems or networks, it's possible that an out-of-date text inset won't be updated automatically. In this case, you can manually update the inset.*

**Change the updating of a selected text inset**

1. Select the inset to update.

2. Choose Edit > Text Inset Properties and click Settings.

3. Specify manual or automatic updating and click Import.

**Suppress the updating of all text insets in a document**

1. Choose Edit > Update References.

2. Choose Suppress Automatic Updating from the Commands pop-up menu, and then choose the items you don’t want to be updated automatically.

3. Click Set and then click Done.
Suppress the updating of all text insets in selected book files
1 In a book window, select the file or files you want to update.
2 Choose Edit > Suppress Automatic Reference Updating.
3 Select Suppress Automatic Updating and click Set.

Manually update a single text inset
❖ Select the inset, choose Edit > Text Inset Properties, and then click Update Now.

Manually update multiple insets in a document
1 Choose Edit > Update References.
2 Select the types of insets you want to update and click Update.

To interrupt the updating of text insets, press Control+c.

Convert text insets to editable text
When you convert a text inset to editable text, FrameMaker XML Author no longer updates it. You can convert a single text inset or all the text insets in a document.
1 If you’re converting one text inset, click it to select it.
2 Choose Edit > Text Inset Properties. You can also double-click the inset in the Insets pod.
3 Click Convert to Text, specify whether to convert the selected inset or all insets in the document, and then click Convert.

Locate the source of unresolved text insets
If FrameMaker XML Author can’t locate the source file for a text inset during updating (or if the format of the source file has changed since the last update), an alert message appears. After dismissing the alert message, you can use the Insets pod to locate the unresolved text inset and then re-import the text. The Insets pod displays the complete path of a referenced file.
Alternatively, you can also search for unresolved insets.
1 Choose Edit > Find/Change.
2 Choose Unresolved Text Inset from the Find pop-up menu and click Find to select the first unresolved text inset.
3 Choose Edit > Text Inset Properties, note the path and file type of the inset, and then click Cancel.
4 Using the path and file type information, re-import the text.

If a document contains many unresolved text insets, you can generate a list of unresolved text insets.

More Help topics
“Import formatted text” on page 237
“Import unformatted text” on page 238
Using paths when importing by reference

When you import by reference with File > Import > File, the path to the text or graphic can be either absolute or relative. A relative path begins at a current folder or one folder up the hierarchy and specifies the file’s location from there. An absolute path begins at the root of the file system (the topmost folder) and fully specifies the file’s location from there. Following are two examples of absolute paths.

- `d:\Graphics\Mountain.gif`
- `\DocServer\Graphics\Mountain.gif`

FrameMaker XML Author stores relative paths whenever possible so that it can find an imported file even when you move both the document and the source file—as long as you keep the files in the same relative locations. If you save the document in a different folder, FrameMaker XML Author adjusts the paths of the imported files accordingly. However, if the path to the imported file traverses the root (the topmost folder) of the file system, FrameMaker XML Author uses absolute paths that begins at the root.

To ensure that FrameMaker XML Author uses relative paths, make sure that it does not have to traverse the root to locate the file.

Import text

You can use the File > Import > File command to import text on all platforms. This method provides more flexibility than using the clipboard.

However, if you’re working on only one platform, you might want to use a platform-specific approach. For information, see “Embedding objects” on page 251.

The text you import can be formatted or unformatted. Unformatted text contains only the words; it has no information on fonts, indents, spacing, autonumbering, and so on. Formatted text contains these types of information.

Import formatted text

You can import formatted text into a FrameMaker XML Author document by importing from the following sources:

- A text flow from another part of the same document
- A text flow from another FrameMaker XML Author document
- A text flow from another FrameMaker XML Author document that is a Maker Interchange Format (MIF) file
- A file created in another application, such as Microsoft Word, which has an installed filter

When you import text from another FrameMaker XML Author document, you also import cross-references, footnotes, variables, markers, tables, and anchored frames. Conditional tags in the flow is also imported. When you import text from another application, some of these special items may be imported, depending on the capabilities of the other application and the filter used.

1. Click where you want to insert the text and choose File > Import > File.
2. Specify the file that contains the flow you want to import and the import method.
3. Click Import.
4. If the Unknown File Type dialog box appears, select a file type and click Convert. The dialog box that appears next depends on the import method you chose in step 2. The Import Text Flow by Reference dialog box contains settings for specifying how to update the imported flow. Choose a body page flow or a reference page flow. Typically, the text you import will come from body pages. Reference pages can contain flows with boilerplate text or graphics for use on body pages.
5 Specify how to format the imported text by doing one of the following:

- To apply the current document’s formats to the imported text whenever their tags match, click Reformat Using Current Document’s Formats. If the tags don’t match, the formatting of imported text is unaffected. Usually, you would also select the options to remove manual page breaks and other format overrides (such as font properties or tab settings) so that the imported text looks like text in the current document with the same tags.
- To remove the formatting from the imported text and apply the character and paragraph formatting used at the insertion point, click Reformat As Plain Text. (Text in tables or anchored frames retains the formatting it had in the source document.)
- To keep the formatting from the source document, click Retain Source’s Formatting. Formats in the imported text aren’t added to the current document’s format catalogs. If you later modify the current document’s formats, the imported text formats won’t be affected—even if the tags in the current document and imported text match.

6 If you are importing the text by reference, specify how to update the text inset by doing one of the following:

- To update the text inset whenever you open the document, click Automatic.
- To update only when you specify, click Manual.

7 Click Import. If you imported the text by reference, it appears as a text inset. (A text inset is linked to the source document and can’t be edited outside that source document.)

Import unformatted text

When you import the text from an unformatted text file, you specify whether to import it by copying or by reference and how to treat lines in the text file. The imported text adopts the character and paragraph formatting used at the insertion point.

1 Place the insertion point where you want to insert the text, and then choose File > Import > File.

2 Specify the text file you want to import, and the import method.

3 Click Import. The dialog box that appears depends on the import method (Import By Reference or Copy Into Document) you chose.

4 Specify how to treat the imported text by doing one of the following:

- To break the text into paragraphs only at blank lines, click Merge Lines into Paragraphs. Use this option for a paragraph-oriented text file such as a file containing document text.
- To break the text into paragraphs at the end of each line, click Treat Each Line As A Paragraph. Use this option for a line-oriented text file such as a file containing computer code.
- To convert the imported text to a table, click Convert To Table. Specify a table format and other settings. Use this option only if the file contains delimited text, such as text output from a database program.

5 If you are importing the text by reference, specify how to update the text inset by doing one of the following:

- To update the text inset whenever you open the document, click Automatic.
- To update only when you specify, click Manual.

6 If necessary, choose a character encoding from the Text Encoding pop-up menu. Do this only if you know that the preselected encoding is incorrect. If you force an incorrect encoding, character substitution sometimes occurs or some characters appear as question marks.

7 Click Import. If you imported the text by reference, it appears as a text inset.
Import graphics
You can import Adobe® Photoshop®, JPEG 2000, SVG, and Adobe® Illustrator® files into FrameMaker XML Author. Use File > Import > File to import graphics.

You can import a graphic into an anchored or unanchored graphic frame, into a rectangle that serves as a bounding box, or directly onto a page. If you want the graphic to move with text as you edit the document—for example, a graphic in longer documents or documents intended for HTML conversion—import the graphic into an anchored frame. If you want the graphic to stay where you place it—for example, if the graphic is the logo of a letterhead—import it onto the page and position it where you want it.

When you import a graphic, you can specify an import filter on the basis of the graphic’s format. When you import a bitmap image, you also specify its scale in dots per inch (dpi). The larger the dpi value, the smaller the graphic is on the page.

When you copy an image, or copy an image by reference, into a document, you can specify an HTTP path from which to import the graphic. The HTTP path is preserved in the XML roundtrip.

More Help topics
“Using paths when importing by reference” on page 237

Import a graphic
1 Specify the position of the graphic by doing one of the following:
   • To place the imported graphic in a graphic frame, select an existing frame or place an insertion point in a text frame.
   • To place the imported graphic directly on a page, click in the page margin.
   • To use a drawn rectangle to define the size of the imported bitmap graphic, select an existing rectangle or draw one (do not select an anchored or unanchored frame). The graphic replaces the rectangle if the Fit in Selected Rectangle option is selected when you import; however, the aspect ratio of the graphic remains unchanged.
   • To replace an existing graphic, select it.
2 Choose File > Import > File.
3 Select the graphic file you want to import, or specify the HTTP path of the graphic file to import, and the import method.
4 Click Import.
5 If the Unknown File Type dialog box appears when you click Import, select a file type in the scroll list and click Convert.
6 If you're importing a bitmap graphic, choose a scaling option or Fit in Selected Rectangle and click Set.
   
   For the best printed results, choose a dpi value that divides evenly (or leaves only a small remainder) into the resolution of your printer or typesetter. For the best screen representation, choose a dpi value that divides evenly into your screen resolution. (Windows screens typically have a resolution of 96 dpi.)

More Help topics
“Import and link methods” on page 233
“Resize imported graphics” on page 167
“Embedding objects” on page 251
Import JPEG 2000 files
FrameMaker XML Author supports JPEG 2000, a version of the JPEG image-compression format.

When importing JPEG 2000 files, the filter converts the supported color modes of RGB, CMYK, Grayscale, and LAB and discards unsupported modes such as Index. The filter does not support 16-bit-per-channel images.

1. Choose File > Import > File.
2. Specify the file you want to import, and select Import By Reference or Copy Into Document.
3. Click Import. If the Unknown File Type dialog box appears, select JPC, J2C, JPX, JPF, J2K, or JP2, and click Convert.

Import SVG images
When importing a Scalable Vector Graphic (SVG), the SVG Import dialog box allows the user to select the rasterization quality of the image. By increasing the rasterization quality, printed and PDF versions are crisper; however, increasing the rasterization also increases the file size of the image, and it takes longer to import it.

FrameMaker XML Author prints Scalable Vector Graphic (SVG) images to PostScript printers by rendering the images as vector graphics using Encapsulated PostScript (EPS). For non-PostScript printers, FrameMaker XML Author uses the FrameImage format.

In addition, when you create a PDF file from a document containing an SVG image, the image appears as vectors, which improves its look in Acrobat and allows you to zoom in on it without pixelation.

Note: Embedded SVG image animations are not functional in FrameMaker XML Author.

1. Choose File > Import > File.
2. Click Import.
3. Specify the file you want to import, and select Import By Reference or Copy Into Document.
4. Click Import.
5. In the Import SVG dialog box, specify the raster quality.
6. Specify image dimensions if they are different from the default size (you can’t scale proportionally in this dialog box).
7. Click Set.

Note: Depending on the rasterization quality and available memory, it might take several minutes for the SVG image to import.

Import Adobe Photoshop files
FrameMaker XML Author supports importing of Adobe Photoshop (PSD) files. FrameMaker XML Author converts PSD files to native FrameImage format and converts the color space (Photoshop RGB, CMYK, LAB, Indexed, Grayscale, or Bitmap) to RGB.

You import PSD files the same way you import other types of graphics.

Import Adobe Illustrator files
When you import an Adobe Illustrator file into FrameMaker XML Author, the file is treated as a graphic, and only one page can be imported at a time. You can import it either by copy or by reference. Both process and spot colors can be displayed and printed.
Note: Graphics that use transparency do not always print as expected to a PostScript Level 1 or non-PostScript printer. If you run FrameMaker XML Author using the -noapi option, you won’t be able to import PDF files.

1 In FrameMaker XML Author, choose File > Import > File, and specify the Illustrator file you want to import.
2 Select either Import By Reference or Copy Into Document.
3 Click Import.
4 If the file has more than one page, specify the page number you want by typing the page number into the box.
5 Click Select.

Illustrator files are imported at the page size of the file. Resize the anchored frame to crop any white space from the image.

Locate missing graphics
When you open a document that contains graphic files imported by reference, FrameMaker XML Author looks for the referenced graphic files. If it can’t find a graphic file, it displays a dialog box.

Locate a graphic FrameMaker XML Author can’t find
1 When FrameMaker XML Author displays the Missing File dialog box, do one of the following:
   • To find and display the graphic, use the scroll list to select it and click Update Document to Use New Path. FrameMaker XML Author continues to use the new path to try to find other missing files while opening the document. That way, if you move all your graphic files to a new location, you specify the new path only once.
   • To skip the graphic file, click Skip This File. The skipped graphic appears as a gray rectangle in the document. The next time you open the document, FrameMaker XML Author tries to find the file again.
   • To skip other graphic files if they can’t be found, click Ignore All Missing Files.
2 Click Continue.

View an imported graphic’s filename
❖ Select the graphic that has been imported by reference and choose Graphics > Object Properties. The graphic’s name and path appear in the panel.

Insert imported graphic elements into structured documents
Some graphic elements are defined for you to import a graphic along with the element. When you insert the element, FrameMaker XML Author displays an import dialog box. The graphic you import appears in an anchored frame below the line with the anchor symbol, and the frame is automatically sized large enough for the graphic.

After inserting the element, you can edit the frame by moving it, resizing it, and so on.
You can also import a graphic into an existing anchored frame—for example, if you used a graphic element that placed an empty frame in the document.

When you import a graphic element, you can make it part of your document (imported by copying) or keep it linked to its original application or document (imported by reference).

**More Help topics**

“Fill and edit anchored frames” on page 182

“Import and link methods” on page 233

**Insert an imported graphic element**

1. Click where you want to anchor the frame.
2. Select an imported graphic element in the Element Catalog, and click Insert.
   
   You can also use File > Import > File to insert an element. Select a file and click Import. If more than one imported graphic element is available, choose the one you want from the Element Tag pop-up menu in the next dialog box that appears.
3. Select the graphic file you want to import and specify whether to import by copying or by reference.
4. Click Import.
5. If the Unknown File Type dialog box appears, select a file type in the scroll list and click Convert.
6. If the graphic you’re importing is a bitmap, choose a scaling option from the pop-up menu and click Set. The larger the dpi (dots-per-inch) value, the smaller the graphic is on the page.

An anchored frame with the imported graphic appears in the document window, with an anchor symbol at the insertion point. A bubble with the text snippet <GRAPHIC> appears in the Structure View.

If no imported graphic element is available at the location you want, you can use an invalid element. After inserting the element, talk to your developer about making the element valid at this location.

**More Help topics**

“Import by copying” on page 234

“Change the scope of elements available in a structured document” on page 42

**Use an invalid imported graphic element**

❖ Do one of the following:

- To use an element that is valid in another part of the document, either insert the element in a valid location and then move it, or use the All Elements setting to make the element available everywhere and then insert the element where you want it.
- To insert an invalid element with the default tag GRAPHIC, use File > Import > File to import a graphic. (The element has a default tag if no defined imported graphic elements are available.)

**Add an imported graphic to an existing anchored frame**

❖ Select the frame and use File > Import > File to import the graphic.
Import movies, SWF files, and 3D objects
You can import SWF files (for example, Adobe Captivate demos) into FrameMaker XML Author documents by copying or by reference.

You can also import 3D objects (U3D format) into documents by copying or by reference. You can set parameters for the 3D object, such as default view, rendering mode, background color, and lighting scheme. You can also choose to render a 3D object in an anchored or unanchored frame.

For a series of tutorials and demonstrations on using rich media in FrameMaker XML Author authoring, watch the episodes on the Technical Communications channel on Adobe TV.

More Help topics
Rich Media in Technical Documentation

Import movies
You can add movies to documents by embedding media files. FrameMaker XML Author supports the following media formats.

- AIF/AIFF (Audio Interchange File Format) WMV
- ASF (Advanced Systems Format File)
- AU (Audio File)
- AVI (Audio Video Interleave File)
- FLV (Flash Video File)
- IVF (Indeo Video Format File)
- KAR (Karaoke MIDI File)
- M1V (MPEG-1 Video File)
- M3U (Media Playlist File)
- MID (MIDI File)
- MOV (Apple QuickTime Movie)
- MP2 (MPEG Layer II Compressed Audio File)
- MP3 (MP3 Audio File)
- MP4 (MPEG-4 Video file)
- MPA (MPEG-2 Audio File)
- MPE (MPEG Movie File)
- MPEG (MPEG Movie)
- MPG (MPEG Video File)
- QT (Apple QuickTime Movie)
- WAV (DTS-WAV File)
- WMV (Windows Media Video File)

For more information see “Embedding objects” on page 251.

When you print a document containing a QuickTime movie, only the movie title appears.
Note: Don’t move or delete the original QuickTime movie file, even if you used the Copy into Document option when you imported it. Even with this option, the entire QuickTime movie is not copied into your document.

Import a SWF file
Note: Ensure that you have installed Adobe® Flash® Player on your computer to play SWF files.

Note: SWF files embedded inside PDF documents, do not need Adobe Flash Player, to play. Acrobat Pro and Acrobat Reader can play these files.

1 Place the insertion point in your document where you want the SWF file to appear.
2 Select File > Import > File.
3 Navigate to, and select, the SWF file you want to insert.
4 Select the Copy Into Document or Import by Reference option.
5 Click Import.
6 In the Graphic Scaling dialog box, select the desired DPI, and then click Set.

When you click Set, the first frame of the SWF file appears in the document. If you imported the file by reference, double-click the first frame to play the SWF file in a separate Adobe Flash Player window. If you copied the SWF file into the document, a bitmap image of the first frame is displayed. Click the frame to activate the SWF file. If the first frame is blank, the anchored frame containing the SWF file appears blank.

Note: You can’t use any graphic operations on a SWF file in a FrameMaker XML Author document.

Note: In FrameMaker XML Author, SWF files and FLV files are saved as RichMedia objects in PDF.

Import 3D objects
1 Place the insertion point in your document where you want the 3D object to appear.
2 Select File > Import > File.
3 Navigate to and select the U3D file you want to import.
4 Select the Copy Into Document or Import By Reference option.
5 Click Import.
6 Select the desired DPI and click Set.

When you click Set, the bitmap of the 3D object appears in the document. If you imported the 3D object by copying it, the U3D file is embedded in the document as a device-independent bitmap (DIB) in the document. If you imported the 3D object by reference, a bitmap image linked to the source U3D file is inserted in the document. Regardless of the method of importing the 3D file, the file is rendered in the DIB facet in the document.

When you import the 3D object into a document and save it in PDF or XML format, all information about the 3D object is preserved.

Save a document containing 3D objects
You can save a document containing 3D objects in PDF and XML formats.

1 Select File > Open, and then open the FrameMaker XML Author book or file containing 3D objects.
2 Select File > Save As PDF.
3 You can change the save location and the filename if you want, and then click Save.
Click Set in the PDF Setup dialog box to generate PDF with the default settings. Or, set additional options, and then click Set. The U3D file imported into the book or file is saved along with all its views. When you open the PDF, the view you last selected for the 3D object in the document displays in the PDF.

**Note:** By default, FrameMaker XML Author is configured to embed 3D objects in PDFs. However, you can disable this option.

In the PDF, click the 3D object to view the 3D toolbar and to activate the interactive features of the 3D object. The Adobe Acrobat 3D toolbar, which is displayed above every 3D object in a PDF, lets you zoom, pan, rotate, and analyze 3D designs.

**Save documents containing 3D objects as XML**

You can save a FrameMaker XML Author file containing a 3D object as XML. When you open the XML file in FrameMaker XML Author, the 3D object is preserved through XML roundtrip. The 3D object is extracted and saved as an independent U3D file, along with the XML file. When the file is opened again in FrameMaker XML Author, the 3D object appears at the location where it was inserted.

To preserve changes made to a 3D object during a roundtrip in an XML file, add a new attribute called `insetdata` with the following properties in the Graphic section of the DTD file, along with other attributes such as `Offset` and `DPI`:

```xml
<insetdata CDATA #IMPLIED>
```

Similarly, you must add the following lines in the XSD file:

```xml
<xsd:attribute name="insetdata" type="xsd:string" use="optional"/>
```

**Note:** The `insetdata` attribute does not support read/write rules.

If you don’t modify the DTD and XSD files, U3D files can still be exported to XML. However, changes made to the U3D file in FrameMaker XML Author are not preserved during a roundtrip.

1. Select File > Open, and open the FrameMaker XML Author file containing 3D objects.
2. Select File > Save As XML.
3. You can change the save location and the filename, and then click Save.

**Note:** When you open the XML file in a 3D compatible XML Editor, the relevant graphic element contains a reference to the U3D file, with the filename and location of the U3D file. If you open the XML file in FrameMaker XML Author, the 3D object appears as a bitmap image.

**Print a FrameMaker XML Author file with 3D objects**

You can print a document with 3D objects. The 3D objects are printed as bitmap images.

1. Open the document containing 3D objects.
2. Select File > Print.
3. Set the remaining print options as necessary, and then click Print.

**Configure a 3D model imported into FrameMaker XML Author**

You can configure a 3D model you have imported into a document by setting its background color, lighting schemes, changing views, and rendering mode.

**Set the background color for a 3D object**

You can change the color that appears behind a 3D object. The default background color is white.

1. Select a 3D object.
2 Select Graphics > 3D Menu option > Background Color.

3 Select the desired color and click OK.

**Set lighting schemes for a 3D object**
You can select from a wide range of 3D lighting schemes to cast a 3D object using different light sources. The default lighting scheme for all 3D objects is Lights From File.

1 Select a 3D object.

2 Select Graphics > 3D Menu option > Lighting, and choose one of the following light sources: Lights From File, No Lights, White Lights, Day Lights, Bright Lights, Primary Color Lights, Night Lights, Blue Lights, Red Lights, Cube Lights, CAD Optimized Lights, or Headlamp.

**Set views for 3D objects in FrameMaker XML Author**
The 3D object you import into a document can contain predefined views. You can change the view set for the object; the selected view is rendered when the document is saved. When you convert this FrameMaker XML Author document to a PDF, all predefined views of the 3D object are available in the PDF. The last view that you selected in the document before saving becomes the default view in the PDF.

1 Select a 3D object.

2 Select Graphics > 3D Menu option > Show Existing Views, choose a view from the list that appears in the dialog box, and click OK.

*Note: If you save the document as a PDF, all views of the U3D objects are available in the converted document.*

**Render a 3D object in a document**
The rendering modes for 3D objects vary from the Wireframe, Solid, to Transparent Bounding box. The default rendering mode is Solid.

1 Select a 3D object.

2 Select Graphics > 3D Menu option > Rendering Mode, and then choose one of the following rendering modes: Bounding Box, Transparent Bounding Box, Transparent Bounding Box Outline, Vertices, Shaded Vertices, Wireframe, Shaded Wireframe, Solid, Transparent, Solid Wireframe, Transparent Wireframe, Illustration, Solid Outline, Shaded Illustration, or Hidden Wireframe.

**Poster file for a media file**
You can set a poster file to an imported media file. Importing a SWF file into FrameMaker XML Author, displays the first frame of the SWF file as the poster for the SWF file.
For a SWF file whose first frame cannot be read, and for all other media types, FrameMaker XML Author displays the relevant placeholder image.

For structured documents, if an attribute is defined in the DTD with the name `posterfile` for a graphic object, the attribute is automatically mapped to the poster property of the anchored frame. You can also map any attribute to a poster using a rule in the read write file. The file referred in the attribute becomes the poster.

**Set a poster image**
FrameMaker XML Author sets the selected image as the poster. If the image that has been set as a poster is missing, FrameMaker XML Author sets a special image as the poster.

1. Right click the inserted media file.
2. Select Set Poster.
3. Select the image file (JPEG, PNG, BMP, or GIF) and click OK.

**Reset the poster image**
1. Right click the inserted media file.
2. Select Set Default Poster.

**Import other files**
You can import PageMaker, QuarkXPress, PDF, RTF, MIF, Microsoft Word, and Microsoft Excel files into FrameMaker XML Author. Use File > Import > File to import these files.

*Note: FrameMaker XML Author lets you import PageMaker 6.5 or 7.0 and QuarkXPress 3.3 or 4.1 documents.*

**Import PageMaker and QuarkXPress files**
1. In FrameMaker XML Author, choose File > Open, and specify the PageMaker or QuarkXpress file you want to import.
2. Choose the appropriate file type in the Unknown File Type dialog box:
   - If importing a QuarkXPress file, choose QuarkXPress Document (3.3-4.1x).
3. Click Convert. If the Missing File dialog box appears, navigate to the folder that contains the missing file, click the name of the file, and click Continue.
FrameMaker XML Author imports the main components of PageMaker and QuarkXPress files.

**Master Pages** FrameMaker XML Author adds a new master page for each master page in the document you are importing. All master-page items are placed on their corresponding master pages in FrameMaker XML Author. If you have custom-named master pages in PageMaker, FrameMaker XML Author uses the same name.

For QuarkXPress documents, FrameMaker XML Author imports all text objects on master pages as text flows, and preserves all body-page overrides. FrameMaker XML Author drops any overrides for other objects on body pages.

**Sections** FrameMaker XML Author ignores sections and imports their contents only.

**Layers** FrameMaker XML Author treats all layers in an imported document as one layer. The page items are drawn according to their stacking order on the page, starting with items on the master page and then items on the body page.

**Character styles** FrameMaker XML Author creates new character formats for the character styles in the document you’re importing. If a character style has the same name as a character format in FrameMaker XML Author, the attributes in the character format are replaced by the corresponding attributes from the imported file. FrameMaker XML Author doesn’t import PageMaker or QuarkXPress character attributes that aren’t supported by FrameMaker XML Author.

**Paragraph styles** FrameMaker XML Author creates new paragraph formats for the paragraph styles in the document you’re importing. If a paragraph style has the same name as a paragraph format in FrameMaker XML Author, the attributes in the paragraph format are replaced by the corresponding attributes from the imported file. FrameMaker XML Author doesn’t import PageMaker or QuarkXPress paragraph attributes that aren’t supported by FrameMaker XML Author.

Paragaph rules to import paragraphs as single-line frames.

Paragraph rules are applied to the rules, such as line colors, line styles, and so on, are not imported.

**Drawing objects** FrameMaker XML Author imports all drawing objects. If fill and stroke colors are different, the fill color is used for both stroke and fill. The runaround settings are dropped.

**Non-printing objects** FrameMaker XML Author doesn’t import non-printing objects.

**Tate-Chu-Yoko** Because FrameMaker XML Author doesn’t support vertical text, FrameMaker XML Author treats Tate-Chu-Yoko as horizontal text.
Color definitions  FrameMaker XML Author creates color definitions to match custom colors or colors from a color library that are defined in the PageMaker or QuarkXPress file. However, if a color definition with the same name exists in FrameMaker XML Author, the FrameMaker XML Author color is used, and no new color is created.

Graphics  FrameMaker XML Author uses its filters to import linked (referenced) graphics files. If it doesn’t have the appropriate filter, FrameMaker XML Author doesn’t import the graphics files. For embedded graphics, FrameMaker XML Author uses the image data to import the graphics.

When importing a floating graphic, FrameMaker XML Author positions the graphic at the same position as in the original file. When importing an inline graphic, FrameMaker XML Author positions the graphic in the text flow in the same text position as in the original file.

OLE objects  FrameMaker XML Author supports OLE. FrameMaker XML Author imports OLE objects as long as FrameMaker XML Author supports the graphic format.

Grouped objects  FrameMaker XML Author supports hierarchical grouping of objects.

Hyperlinks  FrameMaker XML Author supports hyperlinks. For PageMaker documents, FrameMaker XML Author imports object and page item anchors as cross-references.

Table of contents  FrameMaker XML Author imports the table of contents generated in QuarkXPress or PageMaker as regular text.

Pasteboards  FrameMaker XML Author imports all pasteboard objects inline in their corresponding anchored frame. FrameMaker XML Author creates a separate section in the reference pages for the pasteboard objects it imports.

Indexing  FrameMaker XML Author imports all index entry markers but treats the index as regular text.

Import PDF files  When you import a PDF file into a FrameMaker XML Author document, the PDF file is treated as a graphic. Only one page of the PDF file can be imported into the FrameMaker XML Author document at a time. Both process and spot colors can be displayed and printed.

Graphics that use transparency do not always print as expected on a PostScript Level 1 or non-PostScript printer.

1  Specify the position of the graphic.
2  Choose File > Import > File.
3  Select the PDF file you want to import and click Import.
4  If the PDF file has more than one page, specify the page number in the Select PDF Page dialog box. Use the slider to display a thumbnail image of the page you want, and then click Select.

Import MIF files  MIF is a text format that lets you exchange information between FrameMaker XML Author and other applications. All types of format and page layout information are translated to MIF commands. FrameMaker XML Author interprets the commands in the MIF file, turning them back to formatting and layout properties.

You can import the text of a specified flow of a MIF file as you do any FrameMaker XML Author file. When you import by copying, all reference and master pages are imported as well as the body pages. The body text appears on a disconnected page. For information on MIF, see the online manual MIF Reference.

More Help topics  “Import formatted text” on page 237
Import Microsoft Word files
You can import Microsoft Word documents with DOC or DOCX filename extensions into FrameMaker XML Author documents.

If you saved your Microsoft Word document in the Word 97-2003 format, you can import it using the Microsoft Word or the Microsoft Word 2007 filter. However, if you want to import a Microsoft Word 2007 document, you must use the Microsoft Word 2007 filter. You can import RTF files using the Microsoft RTF 1.6 filter in the Unknown File Type dialog box.

1 Place the insertion point in the document where you want to insert the text, and then choose File > Import > File.
2 Specify the file you want to import, select the Import by Reference or Copy Into Document option, and then select Import.
   Depending on the document you are importing, the Microsoft Word or Microsoft Word 2007 filter is selected in the Unknown File Type dialog box.
3 Click Convert. The Import Text Flow by Copy or the Import Text Flow by Reference dialog box appears.
4 In the Flow to Import area, select a Body Page Flow or a Reference Page Flow.
5 In the Formatting of Imported Flow area, select one of the following options:
   • To select the Remove Manual Page Breaks option and the Other Format Overrides option, click Reformat Using Current Document's Formats.
   • To convert the imported content to plain text and then insert it in the document, click Reformat as Plain Text.
   • To retain the imported content in its original format and then insert it in the document, click Retain Source's Formatting.
6 In the Import Text Flow by Reference dialog box, select one of the following options in the Updating of Imported Flow area:
   • To update the imported flow area automatically, click Automatic.
   • To update the imported flow area manually, click Manual.
7 Click Import.

Note: Bookmarks within Word documents become cross-reference markers; annotations in Word documents become conditional tags with the condition “Comment” when imported by reference; hidden text in Word documents becomes conditional tags with the condition “Hidden” when imported.

Import Microsoft Excel files
You can import Microsoft Excel documents with XLS or XSLX extensions into FrameMaker XML Author documents.

If you saved your Microsoft Excel document in the Excel 97-2003 Workbook format, you can import it using the Microsoft Excel or the Microsoft Excel 2007 filter. However, if you want to import a Microsoft Excel 2007 document, you must use the Microsoft Excel 2007 filter.

1 Click where you want to insert the file, and choose File > Import > File.
2 Specify the file you want to import, select Import by Reference or Copy Into Document option, and click Import.
   Depending on the document you are importing, the Microsoft Excel or Microsoft Excel 2007 filter is selected in the Unknown File Type dialog box.
3 Click Convert. The Import Text Flow By Copy or the Import Text Flow By Reference dialog box appears.
4 In the Flow To Import area, select Body Page Flow or Reference Page Flow.
5 In the Formatting Of Imported Flow area, select one of these options:
   • To select the Remove Manual Page Breaks option and the Other Format Overrides option, click Reformat Using Current Document’s Formats.
   • To convert the imported content to plain text and then insert it in the document, click Reformat As Plain Text.
   • To retain the imported content in its original format and then insert it in the document, click Retain Source's Formatting.

6 In the Import Text Flow By Reference dialog box, select one of the following options displayed in the Updating Of Imported Flow area:
   • To update the imported flow area automatically, click Automatic.
   • To update the imported flow area manually, click Manual.

7 Click Import.

**Embedding objects**

**Embed text and graphics with OLE**
You can use OLE to embed text or graphics in a FrameMaker XML Author document. Embedded material retains its association with the application that created it (but does not retain a dynamic link to its source document). This lets you double-click an embedded object to open the object in the application that created it. Be sure to use an application that supports OLE as a server to create the object you want to embed.

You can also embed multimedia objects such as video or movie files (.avi or .mov files) and sound files (.wav files).

*Note: If you specify an HTTP filename when importing a file as an imbedded object, you get an error indicating that the file does not exist. It is recommended that you save the file to your computer before importing it as an object.*

**Embed only part of a file with OLE**

1 In its own application, open the file and copy the part you want to embed.
2 In FrameMaker XML Author, click where you want to embed the text or graphics, and choose Edit > Paste Special.
3 Click Paste, select a format for the object (look for a format that starts with “embedded”), and then click OK.

**Embed an entire file with OLE**

❖ Click where you want to embed the text or graphics and choose File > Import > Object. You can then embed a new, empty file, or specify an existing one.

**Embed by dragging with OLE**

❖ Do one of the following from an application that supports drag-and-drop features:
   • To move text or graphics into a FrameMaker XML Author document, drag the object.
   • To make a copy of an object instead of moving it, Control-drag the object.
   • To choose between moving or copying when you release the mouse button, right-drag the object.
**Link to a text or graphic object with OLE**

When you link to an OLE text or graphic object in a document, FrameMaker XML Author not only maintains information about the application that created the object but also keeps a dynamic association with the source document. If the source material changes, its representation in the FrameMaker XML Author document is updated as well. Be sure to use an application that supports OLE as a server to create the object you want to link to.

You edit linked text or graphics by editing the original source document.

**Link to part of a file**

1. In its own application, open the file and copy the part you want to link to.
2. In FrameMaker XML Author, click where you want to place the linked text or graphics, and choose Edit > Paste Special.
3. Click Paste Link, select a format for the object (look for a format that starts with “linked”), and then click OK.

**Link to an entire file**

1. Click where you want to place the linked file and choose File > Import > Object. Click Create from File and then select Link.
2. Specify the file you want to link to and click OK.

**Edit OLE objects**

You edit an OLE object by using the application that originally created it. When you finish editing, the changes appear in the FrameMaker XML Author window.

**Edit an embedded OLE object**

❖ Double-click it. The object appears in the creating application where you can edit it.

**Edit a linked OLE object**

❖ Do one of the following:
  - Double-click the OLE object. Either the object appears in a new window in the application that created it or the menus in the FrameMaker XML Author window temporarily merge with the menus of the creating application. In either case, the changes you make are reflected in the original document.
  - Edit the original document outside FrameMaker XML Author, in the application that created it.

**Control the updating of OLE links**

You can control how and when OLE linked objects are updated from their source documents. For example, you can specify either automatic or manual updating, and you can manually update a single linked object or several objects in the document.

You cannot specify updating for OLE embedded objects because an embedded object is not dynamically linked with the original document.

**Change the updating of a linked OLE object**

1. Select the object, and choose Edit > Links.
2. Select the linked source from the list, click either Automatic or Manual as the update type, and then click OK.
Suppress the updating of all linked OLE objects

1. Choose Edit > Update References.
2. Choose Suppress Automatic Updating from the Commands pop-up menu, and then choose the items you don’t want to be updated automatically.
3. Click Set, and then click Done.

Manually update a single OLE link object

❖ Choose Edit > Links, select the source file you want to update, and then click Update Now.

Cancel an OLE link

When you break an OLE link, the text or graphic remains in your document, but is no longer updated when the source changes. The text becomes editable.

❖ Select the object, choose Edit > Links, and then click Break Link.

Import text into documents

You can import text into a FrameMaker XML Author document from the following sources:

- A text flow from another part of the document, from another structured FrameMaker XML Author document, or from a MIF file. Any conditional tags in the flow, cross-references, tables, markers, footnotes, variables, and anchored frames are imported.
- A file created in another application for which an import filter is installed on your system. Special items such as cross-references and tables may also be imported—depending on the application and the filter used.

If the text you import is structured, you can retain or remove the structure. If the text is formatted, you can retain or remove the formatting, or reformat the text using formatting information in the current document.

Imported text can be copied into the document, which is equivalent to using the Copy and Paste commands, or it can be imported by reference as a text inset, in which case it retains a link to its source file. When you import by reference, the text inset displays in the document window but is not editable. If the inset is structured, its structure appears in the Structure View but is not editable.

A text inset remains linked to its source document.

1. Click where you want to insert the text.
2. Choose File > Import > File.
3. Select the file with the text you want to import, and specify whether to import by copying or by reference.
4. If the Unknown File Type dialog box appears, select a file type, and click Convert.
The dialog box that appears next depends on the import method you chose in step 3. The Import Text Flow By Reference dialog box contains settings for updating the imported flow.

5 Choose a body page flow or a reference page flow from a pop-up menu. Most often, you import text on body pages. Reference pages can contain flows with boilerplate text for use on body pages.

6 Specify how to handle the structure and formatting of the imported text by doing the following:
   • To retain the structure of the flow and apply the current document’s formats and element format rules to the text, select Reformat Using Current Document’s Formats. If element tags in the two documents don’t match, the formatting of the imported text is unchanged. Usually, you would select the options for removing page breaks and other format overrides so that the imported text looks like text in the current document.
   • To remove the structure and formatting from the text, and apply the formatting used at the insertion point, select Reformat as Plain Text. (Text in tables or anchored frames retains the formatting it had in the source document.)
   • To remove the structure but retain the formatting, select Retain Source’s Formatting. Formats used in the imported text are not added to the current document’s catalogs. If you later modify the current document’s formats, the imported formats won’t be affected—even if the tags in the current document and imported text match.

7 If you’re importing by reference, specify how to update the text inset by doing one of the following:
   • To update the text inset whenever you open the document, select Automatic.
   • To update only when you specify, select Manual.

8 Click Import.

More Help topics
“Import text” on page 237
Working with QR codes

You can generate a QR code in FrameMaker XML Author and then insert the code into a FrameMaker XML Author document. A QR (Quick Response) code is an optically machine-readable two-dimensional bar code. The code can be scanned by a device, such as a smartphone, that then extracts (and accordingly uses) the information specified in the code.

Generate and insert a QR code

1. From the Special menu, choose Generate QR Code.
   
   The QR Code Builder dialog displays.

2. Specify a file name and path to create the QR code file (.png).
   
   The default dimensions of the image is 186 pixels.

3. To change the dimensions of the image, select an alternative dimension from the Image Dimensions drop-down list.

4. To specify the type of information you want to encode, select an option from the Type drop-down list.
   
   **SMS:** Send an SMS to the encoded phone number with the encoded text
   
   **URL:** Open the encoded URL
   
   **Phone:** Make a phone call to the encoded phone number
   
   **Email:** Send an email to a specified address
   
   **Text:** Read the encoded text

5. For each information type, enter the relevant information and click Insert.

   The QR code with the specified information is generated and inserted into the document.

Edit a QR code in a document

You can edit an existing QR code in a document.

1. In the document, select the QR to edit.

2. From the Special menu, choose Edit QR Code.
   
   The QR Code Builder dialog displays.

   To open the QR Code Builder dialog on an existing QR code, you can also double-click the QR code in the document. Alternatively, you can right-click the QR code and choose Edit QR Code from the context menu.

3. Edit the relevant code details and click Save.

   The QR code with the updated information is saved to the document.

3D object part links

To link a 3D object’s parts to textual objects in the document, use 3D object part links. A use for adding 3D object part links can be to link them to a description of each of the parts.
Create 3D links

You can create 3D object links and link them to Specify Named Destination command or URL.

1. Ensure that your document has Specify Named Destination hypertext. Specify Named Destination hypertext can exist either in the same document or in other documents.

2. Right-click a 3D object and select 3D Menu > Link to Text.

3. In the Link to Text dialog, do the following:
   a. To insert a link, select a part of the 3D object, then select a Marker, and click Insert Link to Text.
   b. To delete a link, select a part name linked to a marker and click Delete Link to Text.
   c. To modify a link, select a part name linked to a marker, select a different marker, and click Update link to Text.
   d. To view linked parts, select Show Only Linked Parts. When you select a linked part, the linked marker is selected.

4. Click OK.
Interactive Links for 3D/Multimedia Objects

About interactive links for 3D/multimedia objects
You can insert links to interactively control embedded U3D (Universal 3D), FLV, and SWF objects in the PDF output. You can insert links to 3D and multimedia objects that control various aspects of these objects:

- **View**: Calls different views of the 3D/multimedia object. (For 3D only)
- **Parts**: Focuses on different parts of the 3D/multimedia object. (For 3D only)
- **Animation**: Calls animation in the 3D/multimedia object. (For 3D only)
- **JavaScript**: Attach custom JavaScript code to the link.

You can also create a multimedia links table for the 3D/multimedia object of the type View, Parts, or Animation. For example, the multimedia links table of the type parts includes links that focus on different parts of the 3D/multimedia object.

You can also set a poster that appears for SWF, FLV, and MP4 files while the video is not playing.

Insert a link to a 3D object
1. Insert a 3D object in your document.
2. Type text for creating the link.
3. Select Graphics > Create link to graphic.
4. In the Create Multimedia Link dialog, specify the following:
   a. **Select Object Type**: Select U3D.
   b. **Select an Object**: Select the name of the object for which you want to insert the links. If there is only one object of the selected object type, FrameMaker XML Author selects the object name automatically.
   c. **Hypertext Element Tag**: If you are working in structured FrameMaker XML Author, specify the element tag for the hypertext for the links.
   d. **Link Type**: For U3D, you can select JavaScript, View, Parts, or Animation. If you select JavaScript, in the Details field add the JavaScript code that you want to execute on the click of hypertext. Otherwise, Details displays the options relevant to the selected link type. Select one of the options.
5. Select Insert.

Insert links to an SWF file
1. Insert an SWF file in your document.
2. Type text for creating the link.
3. Select Graphics > Create link to graphic.
4. In the Create Multimedia Link dialog, specify the following:
   a. **Select Object Type**: Select SWF.
   b. **Select an Object**: Select the name of the object for which you want to insert the links. If there is only one object of the selected object type, FrameMaker XML Author selects the object name automatically.
   c. **Hypertext Element Tag**: If you are working in structured FrameMaker XML Author, specify the element tag for the hypertext for the links.
d Link Type: For SWF, you can select JavaScript™, play, or stop.
5 If you have selected JavaScript™ in Link type, add the JavaScript™ code in Details.
6 Select Insert.

Insert links to an FLV file
1 Insert an FLV file in your document.
2 Type text for creating the link.
3 Select Graphics > Create link to graphic.
4 In the Create Multimedia Link dialog, specify the following:
   a Select Object Type: Select FLV.
   b Select an Object: Select the name of the object for which you want to insert the links. If there is only one object of the selected object type, FrameMaker XML Author selects the object name automatically.
   c Hypertext Element Tag: If you are working in structured FrameMaker XML Author, specify the element tag for the hypertext for the links in the table.
   d Link Type: For FLV, you can select the following:
       • Play: Plays the FLV video
       • Pause: Pauses the video
       • Rewind: Rewinds the video to the starting point
       • Nextcuepoint: Takes the video to the next cue point
       • Prevcuepoint: Takes the video to the previous cue point
       • Seek: Seek helps you select further options for creating defined points.
5 If you have selected Seek in Link type, do one of the following:
   a Defined Points: This option allows you to use the cue points embedded in the video itself.
   b Create Point: This option allows you to create a seek point in the video. After selecting this option, play the video and click Create Link in the video window to insert a seek point.
6 Select Insert.

Set poster for a SWF, FLV, or MP4 files
You can set a poster that appears for SWF, FLV, and MP4 files while the video is not playing.
1 Select a SWF, FLV, and MP4 file.
2 Right-click the file and from the pop-up menu, select Set Poster.
3 For an FLV, SWF, or MP4 file, the Set Poster dialog appears.
   a Select From Media and click Play.
   b While the video is playing, at the appropriate moment click Capture Frame for Poster.
   c Click Save As and save the poster file (.dib) to disc.
   d Click Apply.
Set poster for a 3D object
You can set a poster that appears for U3D files while the video is not playing.
1 Select a 3D object.
2 Right-click the object and from the pop-up menu, select Set Poster.
   The Select Poster File dialog appears.
3 Navigate to a poster file (.jpeg, .png, .gif, .dib, or .bmp format) and select it.

Insert multimedia links table
You can add multimedia links table for U3D and FLV objects.
1 Select Graphics > Create link table for graphic.
   Note: If the Create link table for graphic command is disabled, place your cursor in a text area in the document.
2 In the Insert Multimedia Link Table dialog, select:
   a Select Object Type: Select U3D or FLV.
   b Select an Object: Name of the object for which you want to insert the links.
   c Table Format: Select a table format for the links table.
   d Table Element Tag: If you are working in structured FrameMaker XML Author, specify the element tag for the links table.
   e Hypertext Element Tag: If you are working in structured FrameMaker XML Author, specify the element tag for the hypertext for the links in the table.
   f Select Table Type: Select the type of action for the multimedia links. For U3D the options are View, Parts, or Animation. For FLV, you can choose Seek.
3 Select Insert.

Edit multimedia links
You can edit the multimedia links using the markers pod.
1 Select View > Pods > Markers.
2 In the Markers pod, double-click a hypertext marker of type multimedia.
3 In the Edit Multimedia Link dialog, modify the options as required and click Save.

Attach custom JavaScript™ to a 3D object
You can attach custom JavaScript™ to a 3D object to control it.
1 Right-click a 3D object and in the 3D context menu, select 3D Menu > Select JavaScript™.
2 In the Select JavaScript™ file dialog, navigate to a JavaScript™ file and click Select.
   Note: If you copy-paste a 3D object, the JavaScript™ attached with it is also copied to the new instance of the object.

Use object handle in JavaScript™
You can refer to a 3D, SWF, or FLV object’s name in a JavaScript™ using the FM_prefix.
The following JavaScript™ example uses the FM_ prefix with the object name. This example JavaScript™ code makes the relevant object transparent.

1 Insert an object in FrameMaker XML Author and name it as my3d in properties in the 3D menu.

2 Attach the following JavaScript™ code to the object. The object my3d is referred to in this code as FM_my3d.

   ```javascript
   var i,count,tempObj;
   count=FM_my3d.context3D.scene.meshes.count;
   var selObj;
   for( i=0;i<count;i++){
      selObj=FM_my3d.context3D.scene.meshes.getByIndex(i);
      tempObj=FM_my3d.context3D.scene.nodes.getByName(selObj.name);
      tempObj.renderMode="transparent";
   }
   ```

3 Create the PDF and click the link. The 3D object turns transparent.

**Activate 3D/multimedia objects by default**

When you open a PDF, the 3D/multimedia objects in PDF are not activated by default. Click the objects to activate them. To activate the 3D/multimedia objects in the PDF by default, complete the following steps:

❖ Right-click an FLV, SWF, or 3D object and in the context menu, select PDF View Options > Activate by Default.

**Display 3D/multimedia objects in pop-up windows**

You can choose to display the 3D/multimedia objects in a pop-up, when you click the relevant link. This option is useful when the links and the 3D/multimedia object are on different pages.

❖ Right-click an FLV, SWF, or 3D object and in the context menu, select PDF View Options > Open in Pop up Window.

*Note: You can close the pop-up by clicking the cross in the upper-right corner of the pop-up window.*

**Export text and graphics**

You can use the following techniques to export text and graphics:

- Copy and paste between files and applications.
- Save a document in another format.
- Create a Portable Document Format (PDF) file.
- Save as HTML, which can convert a document’s graphics to GIF, PNG, or JPEG format.
- Save as XML.
- Send the document as an e-mail attachment.
- Use drag-and-drop techniques.

*More Help topics*

“Import Adobe Illustrator files” on page 240

“Use drag-and-drop” on page 233
**Send files in e-mail**

You can send a document as an e-mail attachment if a mail system compatible with the Messaging Application Programming Interface (MAPI) is installed on your computer. If your computer is not yet configured for MAPI, Windows guides you through some dialog boxes when you first try to send a document. If you need assistance, ask your network administrator for help.

*Note: The send e-mail menu and shortcut works only for single documents and not on a book file. You cannot send a book file via e-mail.*

1. Choose File > Send.
2. Pick an e-mail profile to use from the Choose Profile dialog box, and click OK.
3. Fill in the e-mail fields, and then send the message as you normally do.

**Save a document containing SWF files as PDF and XML files**

You can save a document containing SWF files in PDF, HTML, and XML formats. Also, you can print documents containing SWF files.

**Save documents containing SWF files as PDF**

1. Select File > Open, and then open the FrameMaker XML Author book or file containing SWF files.
2. Select File > Save As PDF.
3. You can change the save location and the filename if you want, and then click Save.
4. Click Set in the PDF Setup dialog box to generate a PDF with the default settings. Or, set additional options, and then click Set. The SWF file imported into the book or file and it is saved. If you have installed Flash Player on your computer, you can open the PDF and play the SWF file.

When you open a PDF containing a SWF file, the Manage Trust For Multimedia Content dialog box appears. Select the Play The Multimedia Content This One Time or Play The Multimedia Content And Add This Document To My List Of Trusted Documents option and click Play. Ensure that you have installed Adobe Reader® 8 or later, or Adobe Acrobat 3D version 8 or later, to view the generated PDF containing SWF files.

When the imported media file is saved as a PDF and played, Acrobat plays SWF and FLV files with its own in-built native media player. Playback of all other media files is possible only if the relevant codecs are installed on the system.

**Save documents with SWF files as XML**

You can save a FrameMaker XML Author file containing a SWF file as XML. When you open the XML file in FrameMaker XML Author, the SWF file is preserved through XML roundtrip. To ensure roundtripping of SWF files, make sure that the XML file contains correct read write rules before you save the file as XML.

*Note: Ensure that you create or open an XML file containing a graphic element definition before importing a SWF file into it.*

1. Select File > Open, and then open the XML file containing SWF files.
2. Select File > Save As XML.
3. You can change the save location and the filename if you want, and then click Save.

If the SWF content was embedded in the FrameMaker XML Author file, and the document is saved as XML, the SWF content is saved as an independent SWF file. In addition, a reference to the SWF file is created in the XML.
Save a structured document in SGML or XML

You can save any structured FrameMaker XML Author document as SGML or XML. The contents, elements, and attributes from the document are preserved; however, formatting is not preserved. You can save to a different structured document type than the original (such as SGML to XML), but you may encounter errors due to differences in DTDs.

When you save Unicode content as an XML file, Adobe Product X.0 specifies the encoding automatically. By default, Adobe Product X.0 uses the UTF-8 encoding format.

Before saving a document as SGML or XML, you should validate it and correct any errors in the elements and attributes (see “Validating documents” on page 39). Otherwise, the markup may be invalid.

When saving structured XML documents, make sure valid XML element names start with a letter and contain only alphanumeric characters, periods, or hyphens. Spaces, underscores, and other characters in XML element names are invalid characters, and are either converted to hyphens (-) or generate errors.

Headings, tables, and reference pages are not used in XML export, and the default tag names are simply the format names.

Default encoding settings for exporting structured documents are ISO-8859-1 for SGML and UTF-8 for XML. If the structured document is an imported SGML or XML file, FrameMaker XML Author uses the encoding settings in the original file instead of the default settings.

1 Select File > Save As.
2 Specify a filename and location. You may want to add the appropriate extension (such as .sgm or .xml) to the filename.
3 Select SGML or XML from the pop-up menu and click Save. If the document has an application associated with it, the document is saved.
4 If the Set Structured Application dialog box appears, choose an application name from the Set Structured Application pop-up menu and click Continue. Then do one of the following:
   • To associate an application with the document, choose the name of an application.
   • To use default mapping and no read/write rules, choose <No Application>.

If FrameMaker XML Author finds any structure errors when you save a document, it lists error messages in a view-only error log. If a message refers to an error in the FrameMaker XML Author document, the message is linked to the document. For most errors, you can click the message to go to the location of the problem.

When you open the structured documents, import element definitions into them. You’ll probably need to make a few corrections to their structure.

Smart paste hypertext and MS® Word contents as structured content

FrameMaker XML Author allows you to paste HTML, MS® Word, MS® Excel, and MS® Outlook content as DITA content. You can also create and configure XSLs for other FrameMaker XML Author structured applications. Using XSL, FrameMaker XML Author identifies the content while it is in the clipboard and structures it with the most appropriate hierarchy or sequence of elements. Then you can use the smart paste command to paste it to FrameMaker XML Author as DITA content.
The content you paste is structured according to an XSL specified in the relevant structured application. In FrameMaker XML Author, the XSLs are specified for the following DITA documents:

- Topic
- Task
- Concept
- Reference

The XSL filename and path are specified using the `Stylesheet` element (`Stylesheets > XSLTPreferences > SmartPaste > Stylesheet`).

The smart paste XSLs for DITA are at: `$STRUCTDIR\xml\DITA_1.2\app\technicalContent\xslt`.

**Smart paste content in a DITA file**

1. Copy HTML, MS Word, MS Excel, or MS Outlook content.
2. Place your cursor in one of the following types of DITA topics: topic, task, concept, or reference.
3. Select Smart Paste from the context menu. (keyboard shortcut for Smart Paste: Esc+s+p+t)

   The pasted content is structured in appropriate elements that the structure allows.
Managing files using WebDAV

About WebDAV
WebDAV technology enables you to read and write files over a modified hypertext transfer protocol. Files reside on the server within a directory structure and are checked out to your local machine. Your local machine has a directory structure that mirrors the WebDAV server structure, so when you check out files, the files are downloaded to your machine and placed in the mirrored folder.

FrameMaker XML Author has built-in support for Web Distributed Authoring and Versioning (WebDAV) server technology. WebDAV is a standard protocol that is supported by most Content Management Systems (CMS). Use WebDAV to download and upload documents, and lock documents so others cannot modify them at the same time as you do. Use a WebDAV enabled CMS to work in a collaborative environment without worrying about version control.

In FrameMaker XML Author, you can author and edit XML files, FrameMaker XML Author books and files, and MIF files, located on the WebDAV server. For more information about WebDAV, visit www.webdav.org.

WebDAV server A server implementing the WebDAV protocol. You can store and access files on any WebDAV server using FrameMaker XML Author and a WebDAV client, assuming you have login access to the server.

URL In the context of WebDAV, URL refers to the path to a file (asset) on a WebDAV server. You can open any file on a WebDAV server by specifying its URL in the Browse URL dialog box.

WebDAV offers distinct advantages over traditional file servers.

Multiple users can download copies of a file managed by a WebDAV server, but only one user at a time can check-out the file. Users who check out a file can share their work with other users while keeping a file checked-out by updating the file on the server. However, other users can’t change a checked-out file until it is checked in. This check out/check in system allows multiple users to access the same file but prevents users from overwriting each other’s work.

Because WebDAV works over web accessible networks, location doesn’t matter. Team members can share files regardless of their proximity.

Getting started
You can directly open, update, and save files to the server by specifying the URL of a file.

Advantages of using Browse URL
- You don’t have to explicitly set up the server connection.
- You don’t have to explicitly download all linked and associated files, such as referenced images when you download a file.
- You don’t have to download all book components or files associated with a .xml, such as schema, DTD, or EDD.
- You don’t have to explicitly update or upload a file. A file is automatically updated on the server when you save it and checked-in to the server when you close it.

The Browse URL workflow is also Unicode and IPv6 compliant and integrated with all FrameMaker XML Author workflows.
Using the Browse URL workflow

The Browse URL dialog box is integrated in all FrameMaker XML Author workflows. The Browse URL button appears in all FrameMaker XML Author dialog boxes related to file management.

**New** You can specify the HTTP URL of the template you want to use for a new document. You can either type the complete URL of the template in the New dialog box or use the Browse URL dialog box to select the template.

**Open** You can open any HTTP file on a server by typing its URL in the filename of the file Open dialog box. You can open all the FrameMaker XML Author file types supported through local file paths using HTTP paths. The types include .xml, .ditamap, .bookmap.

**Import** You can import files by specifying their HTTP paths. You can import them by reference or copy them into your document. You can import an HTTP text inset, add a cross-reference to an HTTP file, import graphics, U3D objects, or SWF files by specifying their HTTP paths.

**Save** You can specify a URL in the Save As dialog to upload the file to a WebDAV enabled server. You can save a file as XML or PDF.

**Note:** You cannot do a batch conversion of documents for HTTP WebDAV directories.

Save a WebDAV server connection

When working with Browse URL you don’t have to explicitly set up a server. If a WebDAV server has an authentication process setup, you need to provide login credentials the first time you access a file on the server. If you work frequently with a server, you can save the server connection in the Browse URL for quicker access.

1. Access the Browse URL dialog box and type the HTTP path to the WebDAV enabled server in the filename box.
2. If prompted, specify your login ID and password.
3. To save the server connections, click the Store URL button.
4. Specify a nickname for the server connection and click OK.

Once saved, the server connection is displayed each time you access the Browse URL dialog box.
To delete a saved server connection, click the Remove URL button.

**Setting preferences**

❖ Choose Edit> Preferences and set the following options.

**Checkout HTTP Files On Open** Clear this option if you do not want to check out a file from a WebDAV server when opening the file.

**Upload HTTP Files On Save** Clear this option if you want to check in a file only once when you close the file.

![General preferences with Checkout HTTP Files On Open and Upload HTTP Files On Save selected](image)

**Using HTTP paths to open files**

You can open any file on a WebDAV server by specifying its URL.

For xml files, FrameMaker XML Author silently downloads all HTTP references, such as the xml schema or the DTDs associated with the xml file. Other references, such as text or graphic insets or cross-referenced files are also downloaded.

You can also reference or import graphic file objects in your documents by specifying their URLs. You can include links to documents by specifying their HTTP paths in hypertext markers.

**Add, open, and save documents**

You can create, save, or open files directly from a WebDAV server by specifying the file URL.

**Open a file**

If you selected the Checkout HTTP Files On Open option from the Preferences dialog box, a file is automatically locked and checked-out when you download it. An asterisk symbol appears against the filename indicating that it is checked-out.
Save a file
You can automatically upload changes to the WebDAV server. To do so, ensure that you have selected the Upload HTTP Files On Save option in the Preferences dialog box.

1. Choose File > Save As and click the Browse URL button.
2. Select the server name from the right panel, navigate to the folder, and click Save.

Import files
Import a file: Choose File > Import > File and click the Browse URL button.

Close a file
By default, when you close a file the file is automatically checked-in.

Associate a template with a folder
You can specify the HTTP path of the template when associating it with a folder in a hierarchical book.

1. In the book window, right click the folder for which you want to specify a template and click Properties.
2. Select the Template Path option and click the add template button to browse for a file.
3. Specify the complete HTTP path in the filename box or click Browse URL to locate the file on the server.
4. Click OK, Open, and Set to associate a template for the selected folder.

Package related files into a zip file
You can package a Ditamap, .xml with all its related files into a zip file for distribution or backup. When you choose to create a package with a book or Ditamap in focus, FrameMaker automatically picks up the related files, such as chapter files, images, text insets, conrefs, crossrefs, to a .zip file.

The packaged zip file contains:
1. The Ditamap
2. Chapter\Topic files
3. Files referenced in the chapters\topic files, such as text insets, conrefs, and images

Note: When packaging structured files, their application setup files, such as DTD, structapps.fm, read-write rules, and templates, are not packaged.

Package book or Ditamap files
To package a book or Ditamap, place all their topic, chapter, and dependent files in the same folder or its subfolders. Any files outside the folder are treated as missing files and are not copied in the zip file.

1. With a book or Ditamap in focus, select File > Package.
2. In the Package dialog, do the following:
   a. Edit the filename and path of the zip file, if required. By default, the name and location of the package zip file is the same as the book or Ditamap file.
   b. Click Settings to exclude one or more of the following types of files from the package (zip file): Multimedia, Images, and 3D files, Content References and Cross References, Text Insets, and OLE objects.
c  Select Create Package Even If Files Are Missing to create a package even if chapter, topic, or dependent files are missing.

FrameMaker treats the topic, chapter, or dependent files that exist outside the folder (or subfolders) of the book or Ditamap as missing files. To package a book or Ditamap, you need to have all their topic, chapter, and dependent files in the same folder or its subfolders. Select this option to package a book or Ditamap without their chapter/topic or dependent files in the same folder. Otherwise, package fails for such a book or Ditamap.

d  To view the package file after it is created, select Open Containing Folder After Packaging. After the package is created, the folder containing the zip file opens in Windows® Explorer.

e  To generate an issue log about the package, select Generate Log File.

f  Click Package.

FrameMaker processes the book file and creates a package. Now you can share the zip file with others or back it up.
Chapter 11: Editing Content

Identify changes by tracking edited text

The Track Text Edits feature highlights added and deleted text for visual distinction. Editors and reviewers can use this feature to track, display, and preview changes by showing or hiding the edits. You can set the color for additions and deletions.

You can set the scope for tracking edits to the current document, the current book or DITAMAP, or selected documents from a BOOK or DITAMAP.

FrameMaker tracks the changes with a user name and timestamp of the changes. If you share the document with other writers, such as in a team environment, this allows you to determine the author and time of edits in the document. By default, FrameMaker uses the login name of the current user as the user name.

*Note:* Changes to formatting and element attributes are not tracked.

The following table shows tracked and untracked text edits in Structured documents.

<table>
<thead>
<tr>
<th>Tracked text edits</th>
<th>Untracked text edits</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inserting elements using the Return key</td>
<td>Deleting root element</td>
</tr>
<tr>
<td>Inserting or deleting text within an element</td>
<td>Editing attributes of an element</td>
</tr>
<tr>
<td>Deleting elements</td>
<td>Merging elements</td>
</tr>
<tr>
<td>Cutting, copying, and pasting text</td>
<td>Splitting elements</td>
</tr>
<tr>
<td></td>
<td>Unwrapping and wrapping text</td>
</tr>
<tr>
<td></td>
<td>Dragging or dropping elements in the structure view window</td>
</tr>
</tbody>
</table>

Set color preferences for text edits

You can set the color preferences for text that is added or deleted in addition to the default formatting that FrameMaker applies: text that you add is underlined; deleted text is shown with strikethrough. Avoid setting the same text color that you defined for conditional tags so that text edits are clearly visible. In addition, when you preview or view the text edits, turn off conditional tags indicators to clearly differentiate the text edits.

1. Do one of the following:
   - On the Book window, select View > Track Text Edits > Configure Color.
   - When in the document view, select Special > Track Text Edits > Configure Color.

2. Select or define the colors that you want for added text and deleted text, and click Set.
Set scope for tracking text edits
You can set the scope for tracking edits as either for the current book, DITAMAP, or document. When you open a book or DITAMAP, the scope is set to Book or MAP by default. To set the scope explicitly, do one of the following:

❖ Do one of the following:
  • To set the scope to the entire current book, from the book or DITAMAP view, select View > Track Text Edits > Scope > Book or DITAMAP.
  • To set the scope to entire book or Ditamap when focus is in document, select Special>Track Text Edits>Scope>Book or Ditamap.
  • To set the scope to only the current document, select Special > Track Edits > Scope > Document.
  • If only a document is open, for the current document, select Special > Track Text Edits > Scope > Document.
  • To set the scope to selected files in a book, from the book view, select the files you want, and then select View > Track Text Edits > Scope > Selected Documents.
  • To set the scope to selected documents of Book or Ditamap when focus is in document, select the files and select Special>Track Text Edits>Scope>Selected Documents.

*Note:* You can set the scope to Book or DITAMAP only when they are open.

Turn text edit tracking on or off
By default, the Track Text Edits feature is turned off. Do one of the following:

❖ Do one of the following:
  • In the Book or DITAMAP window, select View > Track Text Edits > Enable. This option toggles on and off.
  • In the Document window, select Special > Track Text Edits > Enable. This option toggles on and off.

*Note:* It is recommended that you have the documents open when you enable track text edits. FrameMaker will not enable track text edits if the document has errors that prevent FrameMaker from opening it.

Manage text edits in a document
• To find specific text edits, select Special > Track Text Edits, and then select Show Next or Show Previous.
• To accept or reject individual text edits, select the text edit, and select Special > Track Text Edits > Accept Edit or Reject Edit.
• To accept or reject all text edits, select Special > Track Text Edits, and then select Accept All or Reject All.

Once you accept a text insertion or deletion, that text edit becomes part of the file. If you accept an insertion of text, the inserted text is retained. If you accept a deletion of text, the deleted text is removed. If you reject an insertion of text, the inserted text is removed. If you reject a deletion of text, the deleted text is retained in the file. The inserted or retained text acquires the formatting of its surrounding text.

Filter edits by author or reviewer name
❖ Select Special > Track Text Edits > Show Reviewer Name> [user name].

After selecting the reviewer name, you can do the following operations:
• Show Next/Previous: Displays changes made by the selected reviewer.
• Accept/Reject All: Accept all changes or reject all changes made by the reviewer.
Note: To populate the reviewer names in a book or a map, open the book or the map, choose the desired scope and click Update Userlist.

Note: The reviewer names are automatically populated for a document.

Preview a document with text edits
Before you accept all text edits, preview the final document to see how the text edits are incorporated in the document. You can also preview the original document without the text edits highlighted in the document.

Preview operations can also be done on all/selected documents of the Book or Ditamap by selecting the appropriate scope.

When you preview a document with text edits, the document display switches from the Tracking mode to the Preview mode. In the Preview mode, avoid making non-trackable changes to your document. For example, do not edit or apply conditions to text in the Preview mode. Such changes are not tracked and you may get an unexpected result in the final document.

By default, the preview of a tracked document is turned off.

Note: When you select the Preview Final or Preview Original option for the first time in your document, the Preview Off option is enabled. You can’t undo the Preview Final or Preview Original command in a document.

• To preview the final document with text edits, select Special > Track Text Edits > Preview Final.
• To preview the original document with text edits, select Special > Track Text Edits > Preview Original.

FrameMaker incorporates accepted edits in the document. It deletes rejected edits and restores the document to its original state.

If you modify the document with the Track Text Edits feature on and Preview Final or Preview Original selected, FrameMaker switches from Preview mode to Tracking mode. In this case, you can’t undo the changes you make.

• To turn off Preview mode, select Special > Track Text Edits > Preview Off.

Saving and publishing a document with text edits
When you save a document after inserting text edits, the suggested edits are retained.

When you publish the document as a PDF, the text edits are retained and published to the output. If the Preview mode is turned on, the document is published based on the Preview Final or Preview Original option you selected.

You can save a document with tracked text edits as XML. You can open the XML document in FrameMaker, enable tracking of text edits, and then edit the document. When you save the FrameMaker document back to XML, the edited information is preserved through the XML roundtrip.

If Conditional Tags roundtripping is disabled, all Track Text Edits information is lost during the XML roundtrip. By default, Conditional Tags roundtripping is enabled for any XML application.

Track changes at book or map level
FrameMaker enables you to track changes across an entire book or a map.

To use this feature:

1. Open a book or a map file in FrameMaker.
2 Set the scope of the track changes. Click View > Track Text Edits > Scope and set the scope as Book or a Map. 

*Note:* Notice that you can set the scope of the track changes from View > Track Text Edits > Scope. You can limit the scope to the currently enabled document, the selected documents or to the whole book (when a book is open).

*Note:* When the document is in focus, you can set the scope of track changes from Special > Track Text Edits.

3 Click View > Track Text Edits > Enable to enable track changes.

4 Optionally, set the colors of the added and deleted text for the track changes from View > Track Text Edits > Configure Color.

*Note:* The set colors apply to the selected scope. For example, if Book is selected as the scope, then the set colors apply to all documents in the book. Conversely, if Document is selected as the scope, the set colors apply only to the current document. All other documents in the book have the default colors for track changes.

5 Make changes to the content as desired across all documents in the book.

6 From the review toolbar, select the scope of the track changes for review. Select Book or Map as the scope.

*Note:* You can also select the scope as Document to limit the scope to the currently selected document, or set the scope to Selected Documents only.

*Note:* The Enable, Disable, and Preview features apply only to the selected scope.

7 Use the review icons (Accept Edit, Reject Edit, Show Next, Show Previous, Accept All and Reject All) to navigate through the review as desired. Notice how FrameMaker moves automatically between all documents in the book for review.

8 Additionally, you can view and edit changes from selected users. Click the Reviewer drop down (see the above screenshot) and select Update User List to refresh the user list. Next, select the users whose changes you want to review from the Reviewer drop down. FrameMaker then navigates through changes only from the selected users.

### Using Dropbox for review and collaborative writing

FrameMaker allows you to share and maintain topics and related files using Dropbox. Using Dropbox’s functionality as supported in FrameMaker, you can share files for:

- Review with Subject Matter Experts and other stakeholders
- Shared work with Technical Writers while they are traveling or are located outside your network

Using the Dropbox app with FrameMaker involves:

- “Install and set up the Dropbox app to work with FrameMaker” on page 272
- “Add files to Dropbox” on page 273
- “Share Dropbox location with other users” on page 273 (writers and Subject Matter Experts)
- “Open a file from the Dropbox folder” on page 273
- “Save locally/Save locally with dependencies - on active doc” on page 273

### Install and set up the Dropbox app to work with FrameMaker

To use Dropbox to share files, the users need to download and set up Dropbox on the machines and create Dropbox accounts:

1 Download and install the Dropbox app on your machine.
In FrameMaker, select Edit > Preferences.

Click Dropbox and set up the following:

a. Dropbox Folder path: Once you have installed Dropbox, the default path is automatically there as an option in the drop-down.

b. Delete files from Dropbox after copying locally: When this option is selected, on selecting save locally or save locally with dependencies, the files are deleted from the Dropbox folder on your machine.

c. Create folder structure for dependencies while uploading or downloading: FrameMaker creates a folder structure in the Dropbox folder similar to the one you are uploading or downloading. When this option is not selected, FrameMaker creates the folder structure only for folders that exist at the same level or below as per the document\book\ditamap that you are uploading\downloading. When selected, FrameMaker creates a similar folder structure from the topmost component (folder\file) even for the folders that exist outside\above the file that you are uploading\downloading.

Add files to Dropbox
Add files to Dropbox to share with other users. Once you’ve added the files to Dropbox, you can “Share Dropbox location with other users” on page 273.

Open a file in FrameMaker.

Select File > Upload or Upload with dependencies. When you select Upload with dependencies, the following also get uploaded to Dropbox:

a. Chapter files for a book file being uploaded

b. Book file for relevant to a chapter file being uploaded

c. Image files

d. Text insets

Share Dropbox location with other users
For other users to be able to share files with you, share a Dropbox location with them. Create a shared folder in Dropbox and share it with other users who need to set up Dropbox in FrameMaker. Or, you can share link to a single file with other users through Dropbox.

Open a file from the Dropbox folder
To open a file from the Dropbox folder.

• Select File > Dropbox > Open.

FrameMaker opens the file from Dropbox. You can edit or save the file.

Save locally/Save locally with dependencies - on active doc
After you open a file from the Dropbox folder, you save it locally to make changes to the file outside the sharing workflow.
Compare versions to view changes

About compare documents
Sometimes you receive a revised document with unmarked changes. You can get specific information on the changes by comparing the new version to an older version. When you compare two versions of a document, FrameMaker creates a composite document and a summary document.

Composite document
The composite document is a conditional document that combines the newer and older versions; it shows the differences side by side. You can specify the condition tag to apply to changed text. You can also specify whether FrameMaker marks changes with change bars.

In the composite document, FrameMaker considers differences to be insertions or deletions. For example, if the contents of a graphic frame have changed, both versions appear in the composite. The older version is marked as deleted; the newer version is marked as inserted. Variables in the composite document use the newer definitions, but they aren’t marked as changed. Only inserted and deleted variables are considered changes.

Summary document
The summary document contains a general summary and a revision list for each type of item being compared. You can create the summary as a hypertext document, with links to the actual pages where the changes occurred. By creating a hypertext summary document, you can quickly display changed pages for reading or editing.

In the summary document (named Summary.fm), differences are considered insertions, deletions, or changes. If an item has moved, it’s marked as deleted and inserted. FrameMaker displays the number of the page on which the change occurs in the newer version, the older version, and the composite document. For insertions, the page number given for the older version is the page where the item would be inserted to match the newer version. For deletions, the page number for the newer version is the page where the item would have appeared if it hadn’t been deleted.

Items compared
When comparing two versions of a document, FrameMaker checks the contents of flows with the same names on body and reference pages. It looks at text, footnotes, anchored frames, tables, variables and their definitions, cross-references and their formats, footnote text, marker types, and marker text. FrameMaker doesn’t compare structure elements; it does compare the element contents.

The following are some specific differences that FrameMaker can find:

Anchored frames FrameMaker compares the objects in the frame. If the objects are different, or if they are in different positions, FrameMaker marks the entire anchored frame as changed.

Cross-references FrameMaker checks whether a cross-reference is external or internal. It also checks the cross-references format name, the marker text at the source, and the path of the referenced file (for external cross-references). If any of these properties are different, FrameMaker marks the cross-reference as changed.

Text insets FrameMaker compares the modification date, the filename, the relative paths of text insets, and the way the inset was imported. For example, for imported insets, it checks whether the lines were merged into paragraphs. If any of these items are different, it marks the entire text inset as changed.

Imported graphics FrameMaker compares the contents and dpi scaling of the imported graphic. For example, it checks whether the object has been flipped or rotated, and compares the size of the bounding box. It also compares how the graphic was imported—by reference or by copying. When you import a graphic by reference, FrameMaker
compares the paths. If any of these properties are different, it marks as changed the line that contains the anchored frame of the imported graphic.

**Equations**  FrameMaker compares the size of the equation, the location of the equation within its graphic frame, and the math expressions. If any of these items are different, it marks the entire equation as changed.

**Tables**  FrameMaker checks the number of rows and columns, whether cells are straddled, and whether cells are rotated. If any of these properties are different, FrameMaker marks as changed the line that contains the table anchor. If text in cells has changed, only the new table appears in the composite document. FrameMaker marks as changed the line in the cell that has changed. If more than 75% of the cells have changed, it marks the entire table as changed.

FrameMaker doesn’t compare these items:

- Master page flows, header and footer flows, or untagged flows
- Graphic objects or text lines not in anchored frames
- Anchored frame positions
- Footnote properties or numbers
- Paragraph, character, or table tags
- Text or table formatting
- Tags in the Paragraph Catalog, Character Catalog, or Table Catalog
- Contents of text insets

FrameMaker doesn’t check the formatting of text or tables. Therefore, it doesn’t notice different ruling or shading in a table or a different color assigned to text.

Both the English version of FrameMaker and the Japanese version running on a Japanese OS can compare Japanese text.

**Compare two versions of a document**

1. Open both versions of the document. If the documents contain conditional tags, all conditions must be visible.
2. In the newer version, choose File > Utilities > Compare Documents.
3. Choose the older version from the pop-up menu, and specify the documents you want FrameMaker to create. All open, named documents, except the current document, are listed in the Older Document pop-up menu.
4. Click Options, do the following, and click Set:
   - Specify how to display inserted text in the Mark Insertions With area. Select the default condition tag (Inserted) or a different condition tag. You can choose not to mark inserted text.
   - Specify how to display deleted text in the Mark Deletions With area. Select the default condition tag (Deleted), a different condition tag, or text that you specify. To omit deleted text from the composite document, click Replacement Text and leave the box empty.
   - To mark all changes (insertions and deletions) with change bars in the composite document, select Mark Changes With Change Bars. FrameMaker uses the current change bar settings for the document.

   ![To add change bars to the newer version of a document, select Mark Changes With Change Bars. Choose Replacement Text in the Mark Deletions With area and leave the Replacement box empty.](image)

5. Click Compare. When the comparison is complete, FrameMaker displays the summary and composite documents.

If the two versions are the same, neither document is created.
6 To make the summary report a hypertext document, select Create Hypertext Links In Summary. When you click the page number of a change in the summary, FrameMaker displays the page. You can display pages of the newer version, the older version, or the composite document that contains that change.

**Comparing documents that contain multiple flows**

You can compare documents with multiple flows. To prevent FrameMaker from comparing the wrong flows, make sure that each flow has a unique tag and that the flows have the same tag.

A document can contain different flows with the same name, such as separate flows named “A” on disconnected pages. In such cases, an alert message lists the duplicate flows when you try to compare the documents. FrameMaker compares flows only if each document contains one flow of the same name.

**Compare documents that contain conditional tags**

FrameMaker ignores hidden text and graphics that are not showing.

1 Do one of the following:
   - To compare the full texts of two documents that contain conditional tags, show all conditions before performing the comparison.
   - To compare specific texts of two documents that contain conditional tags, show conditions based on a specific expression before performing the comparison.
   - To ignore conditional tags while comparing documents, hide all conditions before performing the comparison.

2 Compare the documents.

Any hidden conditional items in the newer document remain, hidden, in the composite document that is produced.

**Determine word and character count**

When reviewing changes, you sometimes want to know the number of words and characters in the document. Counting the number of characters in a document is useful for Asian-language documents with double-width (multibyte) characters. The word count report gives the number of single-width characters, double-width characters, and the total number of characters.

1 Choose File > Utilities > Document Reports.

2 Select Asian Character Count or WordCount, and then click Run.

**Import PDF comments**

You can import comments from a tagged PDF directly into the source FrameMaker document and reduce the time taken to fix comments. You can incorporate suggestions and edits from multiple reviewers participating in a shared PDF review much faster into the source document.

You can import comments only from PDFs created using FrameMaker 9 or above.
Importing comments from PDF after changing the source document

You can change the source in FrameMaker while its PDF output is being reviewed and still import PDF review comments.

You can make the following changes to the source FrameMaker content and still import the PDF review comments:

- Change in the relative position (as per the line numbers) of the paragraph in the source FrameMaker document
- Change in the text around (before/after) the commented text in the paragraph in the source FrameMaker document

Even after changing the relative position of the two edits in the source, the PDF comments still get imported in the PDF correctly.

A. In the PDF review, lowercase s is replaced with uppercase S - the same is imported to the source FrameMaker document as a tracked text edit despite the relative position change of the comment.

B. In the PDF review, a period is inserted at the end of the sentence - the same is imported to the source FrameMaker document as a tracked text edit despite the relative position change of the comment.

C. Text inserted in the source document before import the PDF review comments changes relative position of the edits.

Import PDF comments in edited structured content

To use PDF import comments in the XML content:

1. Assign the IDs to all the elements in your content before you create a PDF for review.
2. Ensure that you select the Generate For Review option in the PDF Setup For Selected File dialog.

For assigning the IDs, you need to ensure that all your elements have an ID attribute (not case sensitive - could be id, Id, ID, or iD) or an attribute with the type UniqueID.

If any of the elements in the document does not have these, you need to make changes to your XML structured application to include the ID or UniqueID attributes in the elements.

More Help topics

“XML schemas, EDDs, and DTDs” on page 283

Conditions for importing PDF comments in edited documents

1. If a PDF review comment spans over two paragraphs and you edit the source within the comment, the comment gets imported on the edited content as well.

2. If due to copy pasting, duplicate IDs exist for multiple elements in the source document, the PDF comments will be imported for the first instance of the ID and the subsequent, duplicate instances are ignored.

3. In a book, if chapters are moved up and down after generating PDF for review, Import PDF comments do not work correctly.

4. If the text that is commented on in the PDF is changed in the source, the comment is imported as a marker with the type comment. You can view these markers in the marker pod.

Types of comments supported

FrameMaker can import the following types of PDF comments and annotations:

- Text additions
• Text deletions
• Text replacements
• Sticky notes
• Underlined text
• Highlighted text

Other types of comments or annotations are not imported.

**Placement of comments**

When you import the PDF comments, they are inserted at the same location in the source FrameMaker document as tracked text edits, tracked markers, or simple text formatting. Text additions, deletions, and replacements are inserted as text edits. Sticky notes are inserted as comment type markers. FrameMaker tracks these text edits and markers irrespective of whether the feature is enabled or disabled.

PDF comments of type Highlight are imported with the highlighting retained due to the implementation of the Text Background Color feature.

If the source document has changed after you sent the PDF for review, the exact insertion points for some comments can be indeterminable. FrameMaker inserts such comments as tracked markers in approximate locations. Comments applied to unnamed text flows, non-text objects, or objects locked for editing are also inserted in approximate locations as markers.

*Note: FrameMaker does not allow insertions into objects like variables, text lines, and graphics. Also, cross-references, text insets, bullets, and numbering are locked for editing in FrameMaker. Comments on these objects are inserted as markers. If a reviewer adds a comment in response to another comment in the PDF, it is inserted as a marker.*

**Import comments**

1. Open the XML file to import PDF comments.
2. Click File > Import > PDF Comments.
3. Read the instructions in the Import Comments From Adobe Acrobat dialog box. Click Yes to proceed.
4. In the Import Comments From PDF dialog box, choose the PDF file from which you want to import comments.
5. Select the types of comments that you want to import.
   - **All comments** Select to import all supported types of comments from the PDF.
   - **Only Insert, Delete, and Replace type of comments** Select to import only text additions, deletions, and replacements.
   - **Apply custom filters** Select to specify filters for the comments that you want to import. You can filter comments by parameters like type, author, status set by the author, checking state, and insertion date.
6. If the source document was modified after you created the PDF for review, FrameMaker confirms whether you want to proceed with the import.
   - If the modification date of the source file is newer than the creation date of the tagged PDF, FrameMaker confirms whether you want to proceed with the import.
7. FrameMaker imports the comments from the PDF and displays an import summary. The summary displays the number of comments that FrameMaker imported and placed in their exact locations, imported and placed in approximate locations, and failed to import.
8 Click OK to close the Import Summary dialog box and return to the document window.

**Structured documents and PDF comments**

Comments on text ranges or objects locked for editing in the structured document are inserted as markers. For example, prefixes or suffixes of elements are locked for editing in a structured document.

A comment or annotation can span multiple elements. FrameMaker does not mark a parent element for deletion if one or more of its child elements fall outside the text range marked for deletion.

Also, you can import comments in books but they do not get imported in child books or DITA maps included in hierarchical books.

**Roundtripping tables, equations, and anchored frames**

You can roundtrip tables, equations, and anchored frames between Structured FrameMaker and XML.

**Roundtripping table properties**

Read-write rules handle the roundtripping of table formatting properties. New R/W rule mapping for the table cell properties is as follows:

<table>
<thead>
<tr>
<th>Property</th>
<th>Non-CALS R/W Rule</th>
<th>CALS R/W Rule</th>
<th>Attribute Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>FP_CellAngle</td>
<td>cell angle</td>
<td>rotate</td>
<td>Integer</td>
</tr>
<tr>
<td>FP_CellOverrideFill</td>
<td>fill override</td>
<td>NA</td>
<td>Integer</td>
</tr>
<tr>
<td>FP_CellUseOverrideFill</td>
<td>use fill override</td>
<td>NA</td>
<td>0 = False</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Nonzero value = True</td>
</tr>
<tr>
<td>FP_CellOverrideShading</td>
<td>shading override</td>
<td>NA</td>
<td>Tag of FO_Color</td>
</tr>
<tr>
<td>FP_CellUseOverrideShading</td>
<td>shading override</td>
<td>NA</td>
<td>0 = False</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Nonzero value = True</td>
</tr>
<tr>
<td>FP_CellOverrideBottomRuling</td>
<td>bottom ruling override</td>
<td>NA</td>
<td>Tag of FO_RulingFmt</td>
</tr>
<tr>
<td>FP_CellUseOverrideBRuling</td>
<td>bottom ruling override</td>
<td>NA</td>
<td>0 = False</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Nonzero value = True</td>
</tr>
<tr>
<td>FP_CellOverrideLeftRuling</td>
<td>left ruling override</td>
<td>NA</td>
<td>Tag of FO_RulingFmt</td>
</tr>
<tr>
<td>FP_CellUseOverrideLRuling</td>
<td>left ruling override</td>
<td>NA</td>
<td>0 = False</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Nonzero value = True</td>
</tr>
<tr>
<td>FP_CellOverrideRightRuling</td>
<td>right ruling override</td>
<td>NA</td>
<td>Tag of FO_RulingFmt</td>
</tr>
<tr>
<td>FP_CellUseOverrideRRuling</td>
<td>right ruling override</td>
<td>NA</td>
<td>0 = False</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Nonzero value = True</td>
</tr>
<tr>
<td>FP_CellOverrideTopRuling</td>
<td>top ruling override</td>
<td>NA</td>
<td>Tag of FO_RulingFmt</td>
</tr>
</tbody>
</table>
The read-write rule mapping for the table row properties is as follows:

<table>
<thead>
<tr>
<th>Property</th>
<th>Non-CALS R/W Rule</th>
<th>CALS R/W Rule</th>
<th>Attribute Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>FP_CellUseOverrideTRuling</td>
<td>top ruling override</td>
<td>NA</td>
<td>0 = False</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Nonzero value = True</td>
</tr>
<tr>
<td>FP_RowKeepWithNext</td>
<td>keep with next</td>
<td>NA</td>
<td>0 = False</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Nonzero value = True</td>
</tr>
<tr>
<td>FP_RowKeepWithPrev</td>
<td>keep with next</td>
<td>NA</td>
<td>0 = False</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Nonzero value = True</td>
</tr>
<tr>
<td>FP_RowStart</td>
<td>row placement</td>
<td>NA</td>
<td>Integer corresponding to FDK values</td>
</tr>
</tbody>
</table>

In the following example, the `prop5` attribute controls the bottom ruling of the table.

```xml
element "tablecell"
{
    is fm table cell element;
    attribute "prop1" is fm property right ruling override;
    attribute "prop2" is fm property use right ruling override;
    attribute "prop3" is fm property top ruling override;
    attribute "prop4" is fm property use top ruling override;
    attribute "prop5" is fm property bottom ruling override;
    attribute "prop6" is fm property use bottom ruling override;
    attribute "prop7" is fm property left ruling override;
    attribute "prop8" is fm property use left ruling override;
    attribute "prop9" is fm property cell angle;
}
```

In the following example, the `att1`, `att2`, `att3`, and `att4` attributes control the shading properties of the table cell:

```xml
element "tablecell2"
{
    is fm table cell element;
    attribute "att1" is fm property shading override;
    attribute "att2" is fm property use shading override;
    attribute "att3" is fm property bottom ruling override;
    attribute "att4" is fm property use bottom ruling override;
    attribute "att5" is fm property fill override;
    attribute "att6" is fm property use fill override;
}
```

## Roundtripping equations and anchored frames

You can roundtrip equations and anchored frames between Structured FrameMaker and XML. When you save a Structured FrameMaker document to XML, FrameMaker creates MIF files for the equations and anchored frames in the document. FrameMaker saves every anchored frame and equation in a different MIF file.

**Note:** To test this feature, you can use the ReportPlain XML application in the samplesStructapps.fm file at: `<installation_directory>/Adobe/AdobeFrameMaker11/Structure`. This XML application has Equation and Frame elements.
You can change the type of files that are created for storing equations and anchored frames by specifying the following flag in the maker.ini file.

To specify the default vector format for xml, edit maker.ini (user area) file and add flag DefaultvectorformatforXMLexport flag. For example, the following sets default vector format for xml to CGM.

```
DefaultvectorformatforXMLexport= CGM
```

**Direct OLE support in XML**

Structured FrameMaker supports round-tripping OLE objects, such as Visio objects and PowerPoint presentations. FrameMaker uses an XML Processing Instruction to handle the OLE object roundtripping.

You can control the OLE support using the DirectOLESupportInXml flag in the maker.ini file. To enable this feature, set the flag as On. The default value of this flag is Off; when this flag is Off, the OLE is saved as a .mif file.

Also, notice the following entries in the maker.ini file:

```
53="pptx" OLE2 OLE2 OLE2 FMGFXImport "pptx" frame.exe ^.pptx
54="VSD" OLE2 OLE2 OLE2 FMGFXImport "VSD" frame.exe ^.vsd
```

These entries assign an automatic filetype filter to a file when it is imported. If necessary, you can add more filters (with respective OLEs).

**Insert an OLE object**

1. Select File > Import > Object. The Insert Object dialog appears.
2. Navigate to the OLE object and select:
   • Create from File
   • Link
3. Click OK.

*Note: You can also paste an OLE object using the Paste Special command and selecting Paste Link.*
Chapter 12: Structured Authoring

Introduction to structured authoring

About structured authoring

Structured authoring is a publishing workflow in which you use technology to define and enforce a consistent organization of information in documents. In traditional unstructured publishing, content is written according to rules and approved styles described in style guides and enforced by editors.

In an unstructured authoring workflow, you create relatively free-flow narrative based documents. For example, you can have headings, followed by paragraphs, or graphics with captions or alternate text. In case of structured authoring the content rules enforce a consistent structure across similar pieces of information. For example, you can decide to enforce these content rules:

- A bulleted list must contain at least three items.
- A heading must be followed by a paragraph.
- A table must have a heading row.
- A graphic must have a caption.

These content rules are defined in either a document type definition (DTD) or an XML schema. Conformance to these content rules is automatically checked against the DTD or schema.

For example, consider the structure of a home address. Suppose that the content rules require address to contain an employee name, house number, street, city, and ZIP code. In unstructured authoring, an address without a house number can be discovered only through editing or review. In structured authoring, the structure is validated and automatically checked for completeness. Consistent organization and sequence are therefore enforced and assured.

Structured authoring improves consistency across documents. Consistency simplifies the management of documents in a content repository. Content can be automatically grouped at specified element levels.

Structured authoring has these benefits:

- Enforces a consistent organization of information
- Automatically validates the organization of information
- Complies with required document structures
- Allows publishing to multiple output formats
- Supports content reuse and exchange with XML
- Uses metadata for versioning
- Simplifies database publishing
- Reduces localization cost

Using FrameMaker XML Author

Using XML and structured authoring, you can define content tags that are divorced from formatting rules.
FrameMaker XML Author provides a useful structured environment for authoring in XML.

- User-friendly WYSIWYG structured authoring environment (authoring visually)
- Easier transition from unstructured to structured FrameMaker XML Author
- Complete DITA and DocBook support
- Ability to create PDF outputs for review and collaboration
- Ability to merge XML content along with FrameMaker XML Author components in books

**About XML, and XHTML**

Using FrameMaker XML Author, you can import and export structured documents in XML (including XHTML 1.0) format. Once you import a structured file, it is no longer an XML file; it is a structured FrameMaker XML Author document. To return it to its original format, save it as an XML file.

**About XML**

Extensible Markup Language (XML) is a generalized format for representing structured information, especially for the web. Like HTML and XML requires the use of elements and structure.

However XML differs from HTML in that it is extensible. You can define not only your tags but also their order, relationships among them, and the way they are processed and displayed. In terms of markup, XML has tags or elements which are similar to HTML markup except that they are defined by you.

Use XML to define and implement a structure that is appropriate for your content. An XML document that conforms to the structure of a DTD is said to be valid. An XML document that uses tags that conform to the standard XML specifications is said to be well-formed.

**About XHTML 1.0**

Extensible Hypertext Markup Language (XHTML) is an extension of HTML that is based on XML and is designed to work with XML-based applications. It can be viewed, edited, and validated with standard XML tools. Using XHTML is an easy way to migrate from HTML to XML while retaining forward and backward compatibility of your content.

**Differences between XML and HTML**

Whereas HTML describes formatting, XML describes content itself. Humans can read HTML documents rendered in a browser. Both machines and humans can read XML.

Instead of style-based, paragraph-oriented word processing and desktop publishing, XML provides a foundation for structured authoring. XML describes content according to elements that are organized in a hierarchical tree. In word-processing environments, the relationship among the various document components is apparent through formatting on the page. The document file, however, does not capture these relationships because a word processor document is made up of a string of paragraphs. Structured authoring, however, does capture the hierarchical relationships among the document components.

**XML schemas, EDDs, and DTDs**
Building blocks of schemas and EDDs

Elements
The basic building blocks of structured documents are elements. Elements represent pieces of a document's content (its text, graphics, and so on) and together make up the document's structure. Elements can be simple elements or complex elements.

A simple element in XML contains just text. A complex element can have attributes and can:
- be empty.
- contain other elements.
- contain only text.
- contain both elements and text.

Elements can have values within a specified range of valid values.

All structured documents in FrameMaker XML Author use elements. Each element has a name, or tag, such as Section, Head, or List. The element tags that are available are determined by the document element definitions.

Attributes
Attributes supply additional information about an element. For example, the DTD designer for a manual could use an attribute called version for its book element to allow the user to specify a book's revision status. In FrameMaker XML Author, the attributes for an element are a part of the definition of the element itself. In XML or SGML, the attributes of an element occur separately in an attribute definition list declaration (ATTLIST) in the DTD.

Attributes can have a default value or a fixed value. Attributes can also be either mandatory or optional. For example, if you have a topic element, the topic ID could be a mandatory attribute for topics being cross-referenced. You can also have value ranges for attributes or enumerate the legal values for an attribute.

Element rules
Following seven rules control how the elements are used in terms of their sequence, number of occurrences, and group.

All Indicates that child elements can appear in any sequence but must appear at least once.

Choice Indicates one or the other child element can occur.

Sequence Indicates the order in which the child elements appear.

minOccurs Indicates the minimum number of times a child element can occur.

maxOccurs Indicates the maximum number of times a child element can occur.

Element Groups Elements can be grouped under a group declaration.

Attribute Groups Attributes can be grouped under a attributeGroup declaration.

XML schemas
An XML schema defines the legal building blocks of an XML document. Unlike the EDD, DTDs and schema files do not provide formatting information.

XML schemas define the following:
- List of elements that can appear in a document
- Attributes that can appear in a document for an element
- Hierarchy of elements - which elements can appear as child elements
• Sequence of child elements
• Number of child elements
• The data types for elements as well as attributes
• Default and fixed values for elements and attributes

**XML namespaces**

XML namespaces allow the same document to contain XML elements and attributes taken from different vocabularies, without naming collisions.

**Opening or importing a schema**

You can import an XML document that references a schema file, and you can specify a schema file in your structure application to use for validating a document upon export to XML.

To specify a schema file for use in exporting to XML, modify the structapps.fm file. The element schema, a child of the XmlApplication element, specifies the schema file path for export.

**Structured application definitions**

Two off-the-shelf structured applications available for technical documentation are DITA and DocBook.

**DITA**

DITA or Darwin Information Typing Architecture provides an off-the-shelf DTD and set of rules designed specifically for writing online documentation, such as software help files. It defines a tag structure suited to authoring, producing, and delivering technical documentation. The types of tags in DITA include `<topic>`, `<title>`, `<shortdesc>`, `<prolog>`, `<body>`, and `<concept>`. Following are some distinguishing DITA features:

• DITA is topic-oriented. Each topic can be a piece of modular writing that can be reused in multiple contexts.
• Because DITA separates content from context, multiple architectures of information are possible in DITA. DITA can also be extended to allow for the definition of information types.
• DITA is topic-based. It provides three basic topic types but it allows for specialization of these topic types for individual needs.
• DITA uses a `ditamap` which contains links to the XML files in the documentation set. Each XML file can be a topic or a collection of topics.
• DITA outputs can be multiple ranging from PDF and HTML to variable documents. However, all output forms require some development work.
• DITA is better suited for larger documentation sets.

**DocBook**

DocBook is also an open standard, designed for technical articles and documentation. DocBook provides a DTD for writing technical books and articles, with a structure that such forms imply. DocBook tags include `<article>`, `<section>`, `<title>`, `<articleinfo>`, and `<pubdate>`.

Following are some distinguishing DocBook features:

• DocBook is more book or section oriented.
• DocBook is hierarchical by nature and has to be developed for true single-sourcing. The content is not independent of its context.
Using the Quick Element Toolbar

The Quick Element Toolbar contains commands that allow users to quickly insert (list, table, image) and wrap (bold, insert) some commonly used elements in a structured authoring document.

The out-of-the-box functionality provided by FrameMaker XML Author supports the DITA element structure. However, you can customize the toolbar to associate the commands with any custom structured application.

The toolbar is supported for XML Author (not supported for the code view). It is specific to a structured workspace-view combination. The icons in the toolbar are enabled / disabled based on the current context (cursor position) of the application.

Customizing the Quick Element Toolbar

You can customize the commands in the Quick Element Toolbar by adding commands associated with other elements from the Element catalog of the structured application. For example, you can add a command to insert a ph (phrase) element in the current document.

Each FrameMaker XML Author view-workspace combination has an associated Quick Element Toolbar configuration XML file (quick_element.xml). Each configuration file contains the information that associates the toolbar with one or more structured apps. The file also contains information that associates toolbar commands with the corresponding elements in the Elements catalog.

Configuration XML file locations

<table>
<thead>
<tr>
<th>FrameMaker XML Author Mode - View</th>
<th>Quick Element Toolbar config file location</th>
</tr>
</thead>
<tbody>
<tr>
<td>FrameMaker XML Author - Author view</td>
<td>fminit\WorkSpaces\XMLAuthor\AuthorView\toolbars</td>
</tr>
<tr>
<td>FrameMaker XML Author - WYSIWYG view</td>
<td>fminit\WorkSpaces\XMLAuthor\WYSIWYGView\toolbars</td>
</tr>
</tbody>
</table>

Important: To make changes to the Quick Element Toolbar, you can edit the corresponding configuration files for each workspace-view. Alternatively, you can make changes only to the toolbar in a specific view.

To create a Quick Element Toolbar for a custom structured app

The following steps include associating a new toolbar with a custom structure app. It also includes associating the commands in the toolbar with elements in the Element catalog of the structured app.

1. Open the quick_element.xml file in a text or XML editor.

   Note: To include the toolbar in all the views, you will need to update the quick_element.xml files in all the above locations.

   The XML file contains one STRUCTURED_APPLICATION node for each structured app.

   This node contains one ELEMENT node for each command in the Quick Element Toolbar.
To create a toolbar for the custom app, you can simply duplicate one of the existing `STRUCTURED_APPLICATION` nodes.

Set the `app_name` attribute to the name of the custom app.

```
<STRUCTURED_APPLICATION app_name="<Custom app name>">
```

From the Element catalog for the custom app, choose the elements for which you want to create commands in the custom app Quick Element Toolbar.

For each element, create one `ELEMENT` node in the `STRUCTURED_APPLICATION` node.

Set the `elemTag` attribute to the new command.

For example, to add a command to insert the `ph` (phrase) element:

```
<ELEMENT elemTag="ph"/>
```

You also need to associate each command to an icon. The steps to set the icon for a command is described in the Customize icons section.

### XML with FrameMaker XML Author

#### Create, open, and save XML files

**Create an XML file**

To create an XML file:

1. Select New > XML from the File menu. The new XML dialog is displayed as follows:

![New XML dialog](image)

New XML dialog
2 In the New XML dialog, select one of the following:
   a Recently used: Displays the types of XML topics you have created recently.
   b Structured Applications: Displays the structured applications set up on FrameMaker XML Author that can create new XML topics, including the DITA topics and S1000D modules
   c DITA: Displays the available DITA templates.
   d S1000D: Displays the available S1000D modules.
   e Other XML: See “Create a blank XML document” on page 288 and “Create a blank XML document based on a DTD” on page 288.
3 Click OK to create the XML file.

Create a blank XML document
1 In the New XML dialog, select XML Document.
2 Select Empty XML Document and click OK.

Create a blank XML document based on a DTD
1 In the New XML dialog, select Other XML.
2 Select DTD-based XML Document and click OK.
3 In the Customize XML dialog, specify the following and click OK:
   a Root element: Based on the DTD, specify a valid root level element for creating your xml document. A DTD may have multiple valid root elements.
   b Public ID: Optionally, specify a unique public ID for the XML document. A public identifier is a way to specify the DTD an XML document was created under.
      A public id is of the format: prefix//owner-identifier//text-class text-description//language//display version
   c System ID: Specify the full path of the DTD. A system ID specifies the exact location of the DTD relevant to the document.

Open an XML file
1 In FrameMaker XML Author, choose File > Open.
2 Select the file you want to open, and click Open.
3 If the Use Structured Application dialog box appears, choose an application name from the Use Structured Application pop-up menu, and click Set. Then do one of the following:
   • To associate an application with the file, choose the name of an application.
   • To use default mapping and no read/write rules, choose <No Application>. (You may want to use this option to browse a file you don’t intend to save.)
The WebDAV feature is extended to allow authoring and editing of XML files located on the WebDAV server.

Save an XML file
• Select File > Save As XML. In the Save Document dialog box, click Save.
• Select File > Save As. In the Save Document dialog box, select XML in the Save as type list, and click Save.
FrameMaker XML Author saves the file in XML format and preserves the .xml extension.
Handling conditional text and XML

FrameMaker XML Author allows you to export and import all conditional text (visible and hidden), along with information about the condition tags, such as their show/hide status, color, and style.

To preserve conditional text when saving and opening XML files, the XML file that FrameMaker XML Author generates contains the following:

- Conditional text tags corresponding to the conditional text present in the document.
- Condition indicators—color and effect—associated with each conditional text tag.
- The status—show or hide—for each condition tag.
- Start and end markers for sections corresponding to each tag.

In addition to normal text, support for conditional text in XML allows an entire table or table rows to be conditional. The same applies to footnotes, markers, and anchored graphics. Also, conditional text can be inside a text inset (XML or text).

Handling Whitespace in XML

When you open an XML file in FrameMaker XML Author’s WYSIWYG or Author view, the white spaces get normalized according to the “White-space normalization standard” on page 289.

White space in XML is any character from the following set: space, tab and blank line/new line (except hard return). White space serves the following purposes:

1. Visually format the document in its source form, such as for code, to denote semantic significance for the XML document.
2. While using a text editor to edit XML, add spaces and line breaks into the element content model for better readability of the XML. This white space is not part of the information conveyed by the document and has no semantic significance for the XML application.

   **Note:** Default pretty printing is disabled in XML view for new and modified documents.

W3C has defined how white space in XML documents should White-space XML applications.

White-space normalization standard

FrameMaker XML Author uses the following rules for white space normalization according to the standard:

1. XML ignores the first sequence of white space immediately after the opening tag and the last sequence of white space immediately before the closing tag.
2. XML translates non-space characters (tab and new-line) into a space character and consolidates all multiple space characters into a single space.
3. XML ignores the sequence of white space occurring between two elements if the parent element is defined to have element content.
4. You can set the `xml:space` attribute of an element to preserve to retain the white spaces. For example, if we normalize the following (as appearing in the XML code view):

   ```
   Hickory [SPACE] [SPACE] [SPACE] dikory dock.
   The mouse [TAB] [SPACE] ran up the clock.
   ```

   It appears as (in WYSIWYG view):

   ```
   Hickory[dikory dock.
   The mouse[ran up the clock.
   ```
White space introduced through expansion of character references (for example Space = & #32; Tab = & #9; Newline = & #10;) is preserved on XML open. It is not considered white space per the above rules.

For example, if FrameMaker XML Author normalizes the following (as appearing in the XML code view):

Hickory & #32; & #32; & #32; dikory dock.
The mouse & #9; & #32; ran up the clock.

After normalization, it appears as the following (in WYSIWYG view):

Hickory [SPACE] [SPACE] [SPACE] dikory dock.
The mouse [TAB] [SPACE] ran up the clock.

**Disable dropping whitespaces on import**

To disable dropping whitespaces, set the property **RemoveExtraWhiteSpacesOnXMLImport** in *maker.ini* to **FALSE**.

*Note: Use caution while editing an ini file.*

**Preserve whitespaces for specific elements**

If the xml:space attribute is set to preserve (xml:space="preserve"), then FrameMaker XML Author preserves all whitespaces. You can use this setting to preserve whitespaces for certain elements alone. This setting lets FrameMaker XML Author drop whitespaces for all other elements in the WYSIWYG and Author views.

**Handling cross-references in XML**

FrameMaker XML Author allows you to generate and retain external cross-references when saving and opening XML files.

For example, if your FrameMaker XML Author file contains a cross-reference to another file, when you save your file in XML, FrameMaker XML Author generates tags representing the cross-reference along with information about the referenced file. When opening the same XML file, FrameMaker XML Author converts the cross-reference tags and the information they contain into a FrameMaker XML Author cross-reference.

FrameMaker XML Author supports a new attribute, **srcfile**, to retain external cross-reference information when generating XML documents.

When you export a file containing an external cross-reference to XML, the **srcfile** attribute of the cross-reference contains the name of the referenced file and the ID of the referenced element in the file.

*Note: FrameMaker XML Author converts file paths in the generated XML to URIs.*

**Change text direction**

The direction (LTR or RTL) of a structured document is defined in the associated structured application. If the structured application supports document direction, you can change the direction of the text in supported elements in the document.

To change the direction of the text of an element:

1. Select the element in the Structure View.
2. Open the Attributes editor and change the **dir** attribute.

*Note: note: FrameMaker provides out-of-the-box direction support for DITA topics (topic, task, concept, and reference).*
Using the configuration file editor

Every structured application may include an XML configuration file. The configuration file is optional and contains attributes and their suggested and default values.

When opening a structured application, FrameMaker XML Author reads the corresponding configuration file (if it exists) and populates the attribute values automatically.

Using the attribute editor

FrameMaker XML Author includes a powerful attribute editor that helps you to edit element attributes easily. To load the editor, click Element > Edit Attributes.... The attribute editor is displayed as follows:

![Attribute editor](image)

The editor reads the attributes from the configuration file supplied when creating a structured application.

- To view just the attributes that are required and specified, click the Required and Specified option.
- To set a value, click the value column of the selected attribute. Enter the value. The value is set automatically.
- To delete a value, click the value of the selected attribute and press Delete.
- To delete all user set values, click Reset All.
- To restore all values to the defaults specified in the config file, click Restore Defaults.

Options for processing XML

FrameMaker XML Author provides options for processing XML. FrameMaker XML Author also allows XML import and export to support XSL transformations (see “XML with XSL transformation” on page 292), and the Schema language for grammar and rule definition (see “XML with schema” on page 293). You can import an XML document that uses schema, automatically creating a Document Type Definition (DTD) from the referenced schema. This release also enables validation against an associated schema upon both import and export.
XML with XSL transformation

XSL (EXtensible Stylesheet Language) is a style sheet language for XML documents. XSLT (Extensible Stylesheet Language Transformation) is the means by which transformations defined in XSL are applied to XML documents.

XSL is a set of the following three specifications:

**XSLT** A language for transforming XML documents.

**XPath** A language for navigating in XML documents.

**XSL-FO** A language for formatting XML documents.

FrameMaker XML Author includes an XSLT processor that allows you to associate an XSLT file with an XML structure application or XML document, and apply the transformations defined in that document when importing from or exporting to XML. FrameMaker XML Author supports W3C XSLT 1.0 recommendations. You can upgrade to Saxon 2.0 processor by editing the maker.ini file.

- New elements in the structure application (XSLTPreferences in the stylesheets element of XMLApplication) allow you to specify an XSLT file as part of your XML structure application, to be used for both import and export.
- The xml-stylesheet processing instruction (PI) now allows you to specify an XSL file in an XML markup document, which supersedes any XSLT specified in the structure application when importing that document.

Upon import, XSL transformations are applied before the default read rules or any additional read rules you have defined. That is, the result of applying an XSL transformation on import is a new file, which (if it is an XML file) is passed to the read/write rules.

Upon export, XSL transformations are applied after the default or explicit write rules. The result of applying read/write rules on export is a new XML file, which, if it is valid, is passed to the XSLT processor.

Upgrade to Saxon 2.0 processor

1. In the maker.ini file, locate the XSLTProcessors section.
2. The entry for the Xalan processor has the suffix: `.Default`.
   ```
   XALAN=fminit\XSLT\XSLTProcessors\xalan\xalan-j_2_7_1-bin\xalan.jar,
   org.apache.xalan.processor.TransformerFactoryImpl, Default
   SAXON=fminit\XSLT\XSLTProcessors\saxon\saxonhe9-3-0-5j\saxon9he.jar,
   net.sf.saxon.TransformerFactoryImpl
   ```
3. Cut and paste to shift the suffix to the Saxon processor’s entry as following:
   ```
   SAXON=fminit\XSLT\XSLTProcessors\saxon\saxonhe9-3-0-5j\saxon9he.jar,
   net.sf.saxon.TransformerFactoryImpl, Default
   ```

XML with Cascading Style Sheets

When an XML document is opened in FrameMaker XML Author, FrameMaker XML Author processes CSS2 by mapping the CSS information to appropriate EDD rules in the EDD document.

The following scenario describe the processing of CSS2 in FrameMaker XML Author:

- When you open an XML file that is associated (using xml-style sheet PI) with style sheets, FrameMaker XML Author reads the DTD and the style sheet associated with the XML document, and then generates a temporary template to use for opening the XML file. However, if a template is already specified in the “Structured Application” (used to open the XML file), FrameMaker XML Author uses that template to open the XML file and will not generate any new template from the DTD and style sheets.
Note: An XML file opened in FrameMaker XML Author can contain multiple CSS files. FrameMaker XML Author supports the author’s style sheet only, and not the user’s style sheet.

XML with schema
FrameMaker XML Author allows you to import XML markup documents that are associated with W3C’s XML Schema language. FrameMaker XML Author automatically creates a DTD and EDD from the schema. FrameMaker XML Author validates the document structure against the associated schema upon both import and export to XML, but does not retain all schema information upon export.

For complete details of how schema is mapped to DTD, see the Structure Application Developer’s Guide.

Note: This release offers support for schema that is equivalent to what was previously available for DTD. That is, EDD has not been extended to accommodate features in schema that are not available in DTD. For this reason, schemas are read-only, and you cannot export the EDD back out to schema.

Schema workflow
You can import an XML document that references a schema file, and you can specify a schema file in your structure application, to use for validating a document upon export to XML.

1 For a specific XML document, you can include the path of the schema file in the XML using attributes - noNamespaceSchemaLocation or schemaLocation depending on whether your schema includes a target namespace or not.

2 To specify a schema file for use in exporting XML, modify the structapps.fm file. Use the Schema element as part of the XMLApplication to provide the schema file path for export.

3 Open the XML in Frame using a structured application. Edit it.

4 Save the XML using a structured application. The Schema element in the structapps.fm file is output in the file and validation is performed against it.

In this workflow, a DTD is generated automatically as an intermediary file from the schema given in the XML document, and you do not modify it.

Error console
While opening a document, the new FrameMaker XML Author error console displays structural and other issues in a document, if any. This console also provides the following information about document issues:

• Exact location of the issue within the document

• Name of invalid elements, if any
Error console displaying error details

From the Error Console, the user can:

- Copy the messages on the console to the Windows clipboard.
- Click the Clear button to clear all the current messages on the console.

**Filter By Attribute**

**About Filter By Attribute**

Elements in a structured document can have one or more attributes associated with them. Using FrameMaker XML Author, you can filter a structured document based on the value of these attributes. Other XML applications may also use the same attribute-value pair to filter the documents. In this way, single sourcing workflows can be preserved across other XML applications.

The Filter by Attribute feature simplifies the task of filtering a structured document for complex output scenarios. You define a filter using a Boolean expression containing attribute-value pairs. You can create multiple filters, save them, and use them for filtering a document based on different output scenarios.

When a filter is applied to the document, elements that have filter attributes that do not meet the filter criteria are filtered out. You can specify how the filtered out content is treated, as hidden, highlighted with a color, or applied with a condition tag. When an element is filtered out, all the child elements are also filtered out.

Each attribute can have more than one value defined, each with its own conditions, such as Equals To, Any, and Contains Only. You can provide a list of values with the delimiter that you defined for attribute settings.

**Note:** You cannot filter a document based on Conditional Tags and Attribute values simultaneously.

The following table compares the Show/Hide feature using Conditional Text and the Show/Hide feature using Filter By Attribute.
Note: The conditional indicators are disabled when a filter is used. It can be enabled only when no filter is applied to the document.

Build a filter

A filter is defined by a Boolean expression of attribute-value pairs. You can build a filter using the Build Expression dialog box, which provides a simple interface to build the expression using Boolean operators. You can define attribute-value pairs using the Define Attribute Values dialog box. You can select multiple values for each attribute.

You can save a filter as a named expression. You can build and save multiple filter expressions in a structured document. However, you can apply only one filter at a time. The last filter you apply in a document is the active filter.

Use the Manage Attribute Expressions dialog box to manage the filters.

1. Select Special > Filter By Attribute. The Manage Attribute Expressions dialog box appears.
2. Click New. The Build Expression dialog box appears.
3. Enter a unique name for the filter in the Expression Tag field.
4. Select an attribute from the Attributes list.
5. Specify a value in the New Value field, and click Add. The new attribute value is included in the Defined Values list.
   
   If you want to remove a value, select it in the Defined Values list, and then click Delete. You can add multiple values to an attribute, each with its own conditions such as Equals To, Any, or Contains Only.

   Note: Attribute names are case-sensitive, but attribute values are not case sensitive.

6. Click Add Attribute to include the attribute in the Expression list.

   Note: Use the Clear button to delete all expressions in the Expression area.

7. Click a button to insert a Boolean operator in the expression. You can build a complex expression through the Boolean operators and multiple attribute-value pairs. Click Clear to clear the expressions built.

8. Click OK to close the Build Expressions dialog box. The new expression is added to the Manage Attribute Expression dialog box. Click OK to complete the procedure.
Guidelines for building a filter

Keep in mind the following points when building a filter:

- Ensure that you enter valid attributes in the filter. All valid attributes are listed in the Attributes list of the Build Expression dialog box.
- Ensure that when you supply more than one value to the attribute, you are using the custom delimiter that you defined for attribute in the attribute Configuration File Settings.
- Enclose the value of the attribute in double quotation marks.
  
  Correct: 
  ```
  (Language="French" OR Language="German" OR Language="Japanese")
  ```

  Incorrect: 
  ```
  (Language=French OR Language=German OR Language=Japanese)
  ```

  Note: FrameMaker XML Author doesn't support expressions where the attribute value is missing. For example, 
  ```
  (Language="")
  ```
  is not supported in an expression.

- By default FrameMaker XML Author encloses all attribute-value pairs within parentheses. All attribute-value pairs for a specific attribute are placed within the same pair of parentheses. To place the attribute-value pairs for a specific attribute in different pairs of parentheses, build the expressions for each value separately.

  Correct: 
  ```
  (Language="French" OR Language="German" OR Language="Japanese")
  ```

  Correct: 
  ```
  (Language="French" OR Language="German" OR Language="Japanese") AND (Version="1.0")
  ```

  Correct: 
  ```
  (Language="French" OR Language="German") AND (Language="Japanese")
  ```

  Incorrect: 
  ```
  Language="French" OR Language="German" OR Language="Japanese"
  ```

- Only use the OR operator between attribute-value pairs for an attribute. Do not use the AND operator.

  Correct: 
  ```
  (Language="French" OR Language="German" OR Language="Japanese") AND (Version="1.0" OR Version="2.0")
  ```

  Incorrect: 
  ```
  (Language=French OR Language=German AND Language=Japanese) AND (Version=1.0 OR Version=2.0)
  ```

- When the NOT operator is used, ensure that it is placed before the opening parenthesis of an attribute-value group.

  Correct: NOT 
  ```
  (Language="French" OR Language="German" OR Language="Japanese") AND (Version="1.0" OR Version="2.0")
  ```

  Correct: 
  ```
  (Language="French" OR Language="German" OR Language="Japanese") OR NOT (Platform="Windows")
  ```

  Incorrect: 
  ```
  (NOT Language="French" OR Language="German" OR Language="Japanese") AND (Version="1.0" OR Version="2.0")
  ```

  Incorrect: 
  ```
  (Language="French" OR Language="German" OR Language="Japanese") OR (Platform="Windows" NOT Platform="UNIX")
  ```

- If you have multiple attributes in a filter, insert the Boolean operator between two groups of attribute-value pairs.

  Correct: 
  ```
  (Language="French" OR Language="German") AND (Platform="Windows" OR Platform="UNIX")
  ```

  Incorrect: 
  ```
  (Language="French" OR Language="German") (Platform="Windows" OR Platform="UNIX")
  ```

Process a filter

FrameMaker XML Author generates customized output of a structured document after processing the filter you applied to the document.
Consider a scenario in which you want the following elements and attributes to be applied to the various paragraphs in a structured document.

<table>
<thead>
<tr>
<th>Paragraph</th>
<th>Element</th>
<th>Attribute</th>
<th>Value assigned</th>
</tr>
</thead>
<tbody>
<tr>
<td>Paragraph 1</td>
<td>TextContent1</td>
<td>Language</td>
<td>Japanese</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Version</td>
<td>2.0</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Platform</td>
<td>Windows</td>
</tr>
<tr>
<td>Paragraph 2</td>
<td>TextContent1</td>
<td>Language</td>
<td>Japanese</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Version</td>
<td>2.0</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Platform</td>
<td>UNIX</td>
</tr>
<tr>
<td>Paragraph 3</td>
<td>TextContent2</td>
<td>Language</td>
<td>Japanese</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Version</td>
<td>2.0</td>
</tr>
<tr>
<td>Paragraph 4</td>
<td>TextContent2</td>
<td>Language</td>
<td>English</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Version</td>
<td>1.0</td>
</tr>
<tr>
<td>Paragraph 5</td>
<td>SysReq</td>
<td>Platform</td>
<td>Windows</td>
</tr>
<tr>
<td>Paragraph 6</td>
<td>SysReq</td>
<td>Platform</td>
<td>UNIX</td>
</tr>
<tr>
<td>Paragraph 7</td>
<td>LegalContent</td>
<td>Copyright</td>
<td>Condensed</td>
</tr>
</tbody>
</table>

1. Copy the “Sample XML code” on page 300, which is based on this scenario, to create an XML file with the elements, attributes, and attribute values listed in the previous table.

2. Open the XML file in FrameMaker XML Author. These elements, attributes, and attribute values appear in the Structure View window.

3. Type text in the relevant elements.

   For example, type Japanese text relevant to version 2.0 on Windows in the TextContent1 element.

4. Create the following filter to generate a Japanese document for the Windows platform:

   (Language="Japanese") AND (Platform="Windows")

**How FrameMaker XML Author processes a filter**

FrameMaker XML Author matches each attribute-value pair in the filter with every element in the document. The result of matching the attribute-value pair with an element is indicated by one of the following values:

**True:** The attribute in the filter is an attribute of the element being matched, and the value in the filter matches the value of the attribute of the element.

**False:** The attribute in the filter is an attribute of the element being matched, but the value in the filter does not match the value of the attribute of the element.

**Don’t-Care:** The attribute in the filter is not an attribute of the element being matched.

The following table demonstrates how the filter is processed:

(Language="Japanese") AND (Platform="Windows")
Based on the results of filter processing as listed in this table, and the rules used to process filters, FrameMaker XML Author computes the final value of the filter to determine whether to include or exclude elements from the output. The overall computation returns one of the following values:

**True (or) Don’t-Care**: The element is included in the output.

**False**: The element is excluded from the output.

The operator precedence that FrameMaker XML Author uses while processing filters is listed in the descending order of precedence:

1 Parenthesis
2 NOT
3 AND
4 OR

### Additional filter processing in the example

For element TextContent1 in Paragraph 1, the filter is processed as follows:

1 The attribute-value pair `Language="Japanese"` evaluates to True and the attribute-value pair `Platform="Windows"` evaluates to True.

2 The result of computing the filter is True and True, and the final computation of the element based on the rules is True. Hence, Paragraph 1 is included in the output.

The following table demonstrates how the entire document is filtered:

<table>
<thead>
<tr>
<th>Paragraph</th>
<th>Element</th>
<th>Attribute</th>
<th>Value assigned</th>
<th>Verification of element based on the filter</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>Version</td>
<td>2.0</td>
<td></td>
<td>True</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Platform</td>
<td>Windows</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Version</td>
<td>2.0</td>
<td></td>
<td>False</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Platform</td>
<td>UNIX</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Paragraph 3</td>
<td>TextContent2</td>
<td>Language</td>
<td>Japanese</td>
<td>Is Language=Japanese?</td>
<td>True</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Version</td>
<td>2.0</td>
<td>Is Platform = Windows?</td>
<td>Don’t-Care</td>
</tr>
<tr>
<td>Paragraph 4</td>
<td>TextContent2</td>
<td>Language</td>
<td>English</td>
<td>Is Language=Japanese?</td>
<td>False</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Version</td>
<td>1.0</td>
<td>Is Platform = Windows?</td>
<td>Don’t-Care</td>
</tr>
<tr>
<td>Paragraph 7</td>
<td>LegalContent</td>
<td>Copyright</td>
<td>Condensed</td>
<td>Is Language=Japanese? Is Platform = Windows?</td>
<td>Don’t-Care</td>
</tr>
</tbody>
</table>
Paragraphs 1, 3, 5, and 7 are included in the output, based on the rules used to process filters.

**Note:** When an element is included in the output, the inclusion or exclusion of each of its child elements is determined by processing each child element. However, when a parent element does not satisfy the filter and is excluded from the output, its child element is also excluded from the output even if the child element satisfies the filter. In addition, FrameMaker XML Author does not process the root element while running the filter. Hence, the root element is always included in the output.

### Rules used to process filters
The following table lists the rules that FrameMaker XML Author uses for processing filters.

<table>
<thead>
<tr>
<th>Rule Description</th>
<th>Operator/Resultant Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;Don't-care&gt; OR &lt;Don't-Care&gt;</td>
<td>&lt;Don't-Care&gt;</td>
</tr>
<tr>
<td>&lt;Don't-care&gt; OR &lt;True&gt;</td>
<td>&lt;True&gt;</td>
</tr>
<tr>
<td>&lt;Don't-care&gt; OR &lt;False&gt;</td>
<td>&lt;False&gt;</td>
</tr>
<tr>
<td>&lt;True&gt; OR &lt;Don't-care&gt;</td>
<td>&lt;True&gt;</td>
</tr>
<tr>
<td>&lt;False&gt; OR &lt;Don't-care&gt;</td>
<td>&lt;False&gt;</td>
</tr>
<tr>
<td>&lt;Don't-care&gt; AND &lt;Don't-Care&gt;</td>
<td>&lt;Don't-Care&gt;</td>
</tr>
<tr>
<td>&lt;Don't-care&gt; AND &lt;True&gt;</td>
<td>&lt;True&gt;</td>
</tr>
<tr>
<td>Rule Description</td>
<td>Operator/Resultant Value</td>
</tr>
<tr>
<td>--------------------------------------</td>
<td>---------------------------</td>
</tr>
<tr>
<td>&lt;Don't-care&gt; AND &lt;False&gt;</td>
<td>&lt;False&gt;</td>
</tr>
<tr>
<td>&lt;True&gt; AND &lt;Don't-care&gt;</td>
<td>&lt;True&gt;</td>
</tr>
<tr>
<td>&lt;False&gt; AND &lt;Don't-care&gt;</td>
<td>&lt;False&gt;</td>
</tr>
<tr>
<td>NOT &lt;Don't-care&gt;</td>
<td>&lt;Don't-care&gt;</td>
</tr>
<tr>
<td>&lt;True&gt; OR &lt;True&gt;</td>
<td>&lt;True&gt;</td>
</tr>
<tr>
<td>&lt;False&gt; OR &lt;True&gt;</td>
<td>&lt;True&gt;</td>
</tr>
<tr>
<td>&lt;True&gt; OR &lt;False&gt;</td>
<td>&lt;True&gt;</td>
</tr>
<tr>
<td>&lt;False&gt; OR &lt;False&gt;</td>
<td>&lt;False&gt;</td>
</tr>
<tr>
<td>&lt;True&gt; AND &lt;True&gt;</td>
<td>&lt;True&gt;</td>
</tr>
<tr>
<td>&lt;False&gt; AND &lt;True&gt;</td>
<td>&lt;False&gt;</td>
</tr>
<tr>
<td>&lt;True&gt; AND &lt;False&gt;</td>
<td>&lt;False&gt;</td>
</tr>
<tr>
<td>&lt;False&gt; AND &lt;False&gt;</td>
<td>&lt;False&gt;</td>
</tr>
<tr>
<td>NOT &lt;True&gt;</td>
<td>&lt;False&gt;</td>
</tr>
<tr>
<td>NOT &lt;False&gt;</td>
<td>&lt;True&gt;</td>
</tr>
</tbody>
</table>

**Sample XML code**

Copy the following code to a FrameMaker XML Author document, and then save it as an XML file.
Apply a filter
Use the following instructions to apply a filter you have created to your structured document.

1 Select Special > Filter By Attribute. The Manage Attribute Expressions dialog box appears.
2 Select Show As Per Expression to preview the elements that satisfy the filter when it is applied to the document.
   
   **Note:** If you select the Show All option, then the active filter, if any, is disabled, and all elements in the document are available for viewing and editing in FrameMaker XML Author. Also, any conditional text that is hidden appears. You can’t undo the Show All operation.
3 Select a filter in the list.
4 In the Filtered Text option, select how the content that does not meet the filter conditions should be treated. You can choose from the following:
   • Hide the content that is filtered out
   • Preview the filtered out content with a specified color.
   • Apply a condition tag to the filtered out content. In addition, you can also remove any condition tag already applied to the filtered out content.
5 Click Apply.
   
   **Note:** You can’t undo the Apply command after applying a filter.
Save a document after applying a filter
When you save a document in the XML format, all filters using attribute values, are saved. However, the attribute values you have defined for this feature aren’t saved.

Modify a filter
Use the following steps to modify a filter:
1. Select Special > Filter By Attribute. The Manage Attribute Expressions dialog box appears.
2. Select a filter from the list.
3. Click Edit. The Build Expression dialog box appears.
4. Modify the filter in the Expression area.
5. Click OK to close the Build Expression dialog box.

The modified content of the filter appears in the Selected Expression area of the Manage Attribute Expressions dialog box.

Delete a filter
Use the following steps to delete a filter:
1. Select Special > Filter By Attribute. The Manage Attribute Expressions dialog box appears.
2. Select a filter in the list.
3. Click Delete.
4. If the filter you are deleting has been applied to the document, FrameMaker XML Author displays a message indicating that the selected expression is currently applied to the document. Click OK.
5. Click OK to confirm the deletion.
6. Click Done to close the Manage Attribute Expressions dialog box.

Note: When you delete an active filter in a document, all elements that were excluded by the filter are again made available for viewing, editing, or generating output.

Disable applying condition tags to filtered content
You can disable the option of applying a condition tag to content filtered with a Filter By Attribute option.

❖ Set ApplyAsCondition=Off in the maker.ini file.

Note: Use caution when editing an ini file.

Banner text
Banner text in a FrameMaker XML Author file instructs you about what to enter in an element. Banner text is controlled using the BannerText element in the EDD. You can control the instructional text you want to display for each of the elements.

FrameMaker XML Author does not treat banner text as real content in the document. Banner text is not included in XML output.
Operations, such as the following, are not relevant to banner text:

- Find/Replace text
- Conditional Text
- Spelling checker
- Track changes
- Copy and cut
- Import PDF comments

The `RedisplayBannerTextForEmptyElements` flag in `maker.ini` determines whether the banner text gets re-displayed after it is deleted once. If this flag is OFF, the banner text doesn’t show up after deleting it or reopening the file after saving it. If the flag is ON, banner text always shows up for empty elements.

**Display\hide banner text**

Element banner text is visible in Author view and WYSIWYG view. Use the following command to display\hide banner text:

- Select View > Element Banner Text.

**Banner text settings in the maker.ini file**

You can configure banner text using the following settings in the `maker.ini` file:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>BannerTextFontFamily</td>
<td>Font family of banner text</td>
</tr>
<tr>
<td>BannerTextFontWeight</td>
<td>Font weight of the banner text</td>
</tr>
<tr>
<td>BannerTextFontAngle</td>
<td>Angle of the banner text,</td>
</tr>
<tr>
<td>BannerTextFontVariation</td>
<td>Any variation of the font width</td>
</tr>
<tr>
<td>BannerTextBKcolor</td>
<td>Banner text background color</td>
</tr>
<tr>
<td>RedisplayBannerTextForEmptyElements</td>
<td>When set as On, the banner text is displayed even when you close and reopen a file. When set as Off, if you close and reopen a file, the banner text in the file is not visible.</td>
</tr>
</tbody>
</table>
Regular Expression

In XML view, Regular Expression (RegEx or RegExp) allows you to search through your XML files in a sophisticated way. Select Regular Expression in the Find/Replace dialog to search through an XML file using the powerful Regular Expression constructs.

Regular Expression examples:

<table>
<thead>
<tr>
<th>RegEx syntax</th>
<th>Locates</th>
</tr>
</thead>
<tbody>
<tr>
<td>Licen[sc]e</td>
<td>License and Licence</td>
</tr>
<tr>
<td>e{2}</td>
<td>Words with two consecutive 'e's, such as in free and week</td>
</tr>
<tr>
<td>[2-3][0-2]</td>
<td>Numbers where 20, 21, 22, 30, 31, or 32 exist, such as 2055, 3155, and 2255.</td>
</tr>
<tr>
<td>[a-c][a-c][a-c]</td>
<td>Words where a, b, and/or c occur back to back, such as in accompanying, applicable, backup, and abbreviation</td>
</tr>
</tbody>
</table>

For more information on Regular Expression, see Peter Grainge’s website.

XPath

What is XPath

XPath consists of path expressions and conditions for querying specific parts of one or more XML documents. Using XPath in FrameMaker XML Author, you can search and open documents with the matching the specified expression (such as //title) or condition (such as //task[@id='shovellingsnow']).

XPath examples:

<table>
<thead>
<tr>
<th>Expression/Condition</th>
<th>Locates</th>
</tr>
</thead>
<tbody>
<tr>
<td>/task</td>
<td>The &lt;task&gt; element where it is a top-level node in an XML file</td>
</tr>
<tr>
<td>//task</td>
<td>The &lt;task&gt; element anywhere in an XML file</td>
</tr>
<tr>
<td>//task[@id='shovellingsnow']</td>
<td>A &lt;task&gt; element where the id attribute has the value shovellingsnow</td>
</tr>
<tr>
<td>task/title</td>
<td>All the &lt;title&gt; elements that are direct decedents of &lt;task&gt; elements</td>
</tr>
<tr>
<td>task/title</td>
<td>All the &lt;title&gt; elements that occur anywhere in a &lt;task&gt; element</td>
</tr>
</tbody>
</table>

For more information on XPath, see http://www.w3.org/TR/xpath/

XPath in FrameMaker XML Author

You can use XPath syntax in the XML code view to search through XML files for nodes or node sets.

You can use the following in FrameMaker XML Author’s XML view to run an XPath query:

- XPath pod
- XPath Toolbar
Search for nodes/node-sets using the XPath toolbar

Use the XPath toolbar to search for XML nodes or node sets in the open XML files:

1. Enter an XPath query. For example, /task searches for task as a root node. //task searches for task element even if it is not a root node.
2. Click Run.

FrameMaker XML Author searches through the file and displays the matching nodes /node sets in the XPath pod. Click the search results to view the matching node/node set.

More Help topics
“Regular Expression” on page 304

Search for nodes/node-sets using the XPath pod

Use the XPath pod when you want to search for XML nodes.

1. Select View > Pods > XPath.
2. In Query Builder, enter an XPath query.

You can use the standard XPath syntax to search for elements. History displays the last 15 queries.
3. Select Enable Auto-Suggest for suggestions on your queries as you type them.
4. To Add Axes to the Auto-suggest list, select Axes.
5. Specify the scope of searching:
   a. Current File: Search the specified xml node in the current file only.
   b. All Open Files: Search across all the open XML files for the specified node and displays the results.
Folder: FrameMaker XML Author lets you select a folder in which the search is performed for the specified node/node set.

6 Click Run.

FrameMaker XML Author searches through the file according to the specified scope and returns the matching nodes/node sets. Click a search results to view the matching node/node set in the XML file. Double-click a result to open the relevant file in FrameMaker XML Author.

7 To save the results of your query, click and specify the name of the XML file. You can save the results of an XPath query in an XML file.

More Help topics
“Regular Expression” on page 304

Simplified XML

The structured authoring environment allows you to enforce consistent structure across similar types of information. To use the structured authoring environment, an author must have a good understanding of the content rules and XML.

The Simplified XML feature eliminates the need to know the underlying content rules or the XML structure to create or work on a structured document. The Simplified XML view provides an interface that is very similar to the WYSIWYG View. However, it contains form fields for every element that an author can work with. The Quick Element Toolbar (QET) is also customized for authoring in Simplified XML view, which allows you to easily insert valid objects in your structured document.

This section covers the following topics:

- Simplified XML user interface
- Use the Simplified XML view
- Customize the Simplified XML authoring environment

Simplified XML user interface

The structured application for DITA 1.3 and 1.2 have been updated to support the Simplified XML view. The following DITA topics are supported in the Simplified XML view:

- Topic (File > New > XML > DITA > topic)
- Task (File > New > XML > DITA > task)
- Concept (File > New > XML > DITA > concept)
- Reference (File > New > XML > DITA > reference)
- Troubleshooting (File > New > XML > DITA > troubleshooting) for DITA 1.3 only

However, to create or view your DITA topics in the Simplified XML view, you need to first enable this feature in FrameMaker.

1 Open the Preferences dialog (Edit > Preferences) and go to the Simplified XML tab.
2 Select the Enable Simplified XML View option.
3 Configure the following options for the Alert messages:

**Alert Before Inserting At The Next Valid Location**  Select this option to show an alert when you try to insert an element not valid at the current location. If you do not select this option, then you can specify whether to always insert the element at the next valid location, or not to insert the element at all.

**Show Alert When Typing At Invalid Location**  Select this option to show an alert when you try to type or insert content at a location where direct typing is not allowed. In such scenario, the alert will prompt you to either press Enter to view a list of valid objects or insert an object from the Quick Element Toolbar.

**Show Alert When Deleting Objects Not Available In The Quick Element Toolbar**  Select this option to show an alert when you try to delete an object that cannot be inserted by using the QET.

4 Click OK to save your preferences.

You need to restart FrameMaker for the change to take effect.

After enabling the Simplified XML feature, you can start authoring the structured documents in the Simplified XML view. You need to click the Author View button in the Application bar to switch to the Simplified XML view and then you can either create a document or open an existing XML file.

The following figure shows a DITA 1.3 topic in the Simplified XML view.

- A. Form field name
- B. Form data entry field
- C. The Quick Element Toolbar in Simplified XML authoring environment

A form-like view of the DITA topic is presented with the form field name at the top followed by the data entry field. For more information about customizing the form fields, see Customize the Simplified XML authoring environment.

To enter data in a field, use the arrow keys to move to the desired field or click inside the field and start typing. For example, if you want to type a title, place the insertion point inside the **Title of your topic field** and enter a title for your document. The title that you enter is wrapped inside a valid element in the background.

### Use the Simplified XML view

The Simplified XML view allows you to easily author DITA (1.3 and 1.2) topics without requiring the knowledge of how your document structure is set up. This view allows for faster authoring as you are given a simple form-like easy-to-fill authoring environment. Also, the structure of your application is maintained by placing elements at the right location and within valid XML tags.

To author content in the Simplified XML view:

The following procedure uses the example of authoring in a DITA topic. However, the steps are applicable for other types of DITA topics (task, concept, reference, or troubleshooting).

1 Select the Enable Simplified XML View option in the Preferences dialog.

2 Click the Author View button in the Application bar.

The view changes to the Simplified XML view.

3 Create a new DITA topic.

   By default, the insertion point is placed in the Title field.

4 Enter the topic title.

   If you invoke the Insert Object pop-up by pressing Ctrl+1, you are shown a list of all elements that are available in the current document. However, if you try to insert an invalid element, FrameMaker blocks the insertion.
5 Use the down arrow key to move the cursor to the Short description field and enter a short description for the topic. In the case of a short description, however, you can apply character formatting such as bold, italic, underline, and teletype. To do so, select the text in the Short description field and change the formatting.

For example, to mark a part of the text as bold, select the text and do one of the following:

- Press Ctrl+b.
- Press Ctrl+1 and choose Bold.
- Click B in the QET.

To remove the bold formatting from the text, select the text and use any of the above mentioned ways.

Perform the same steps to enter the author name in the Enter your name field.

You can move in between the various form fields by using the arrow keys.

6 Move the cursor to the Content of your topic field.

By default, the first element available in the Content field is the paragraph. This implies that if you start typing, the text is wrapped inside the paragraph tag in the background.

If the cursor is visible but you are unable to type text, this implies that typing text is not valid at the current location. You are shown a pop-up prompting you to either press Enter and select an object or select an object from the Quick Element toolbar.

7 Use the QET or the Insert Object pop-up to insert elements.

If you try to insert an item that is not valid at the current location, then the authoring environment automatically identifies such operation and allows you to add the selected element at the next valid location.

The following section provides more details on inserting and using the available objects.

**Working with objects in Simplified XML view**

This section explains the various ways to work with the most commonly used objects.

**Work with ordered and unordered list**

- To create an ordered or unordered list in the document, choose the corresponding button in the QET.
- To create a new list item, place the insertion point at the end of the current item and press Enter.
- Within a list item, to insert an object (such as an image or a table), use the QET or the Insert Object pop-up.
- To convert between ordered list and unordered lists, place the insertion point anywhere inside the list and choose the alternate list type from the QET.
- To exit a list, place the insertion point at the end of the last list item and press the Enter key twice or click the Navigate To End Of Form Element button in the QET.
- To insert a list item between two lists, either place the insertion point at the end of the first list item or at the start of the second list item and press Enter.
- To split a list item into two items, place the insertion point where you want to split an item and press Enter.
- To split a list into two, place the insertion point at the end of the first list item and press Enter twice. A new paragraph is created between the lists.

You can use the Tab, Shift tab keys or List Indent, List Outdent button in the QET to indent (nest) or outdent list items:

- To indent a list item, place the insertion point at the start of the list item and press Tab. Or, place the insertion point anywhere in the list item and click List Indent.
The operations performed by List Indent and List Outdent buttons also work with partially selected text.

- To reduce the indent of the list item, place the insertion point at the start of the list item and press Shift + Tab. Or, place the insertion point anywhere in the list item and click List Outdent.
- If a list has multiple items, to nest some of the items in the list, select the items and press Tab or click List Indent.
- To reduce the indent of any item in a nested list, place the insertion point at the start of the list item and press Shift + Tab. Or, place the insertion point anywhere in the list item and click List Outdent.

If you reduce the indent of any item in a nested list, the other items remain nested.

**Work with tables**

- If you insert a table in your topic, the Simplified XML view displays a Table anchor that allows you to easily select, expand, or collapse the table.
- To insert elements after the table, click the Navigate To End Of Form Element button in the QET.

**To add rows or columns to the table, click in a table cell next to where you want to add the row or column, choose Table > Add Rows or Columns, and specify the number of rows or columns you want to add. You can also move rows or columns within the same or different tables, and sort the rows or columns in a table. For more information, see Rows and columns in the Tables chapter.**

- To add a new row to the table, click Tab at the last column of the last row.
- To move across cells in the table, you can use Tab, Shift+Tab, or arrow keys.
- To move the table, you need to click on the Table anchor and then drag-and-drop the table. You can also select and move (drag-and-drop or copy/cut/paste) table rows and columns, within or across tables.

**Work with images**

- When you are working in a DITA topic, concept, or reference document, click the Figure button in the QET or select the Figure object from the Insert Object pop-up to insert an image.
- When you are working in a DITA task or troubleshooting document, then click the Image button in the QET or select the Image Data object from the Insert Object to insert an image.
- In the Insert Graphic dialog, enter the following details:
  - **File Path**: click Browse and select the image file that you want to insert.
  - **DPI**: select the DPIs (or resolution) from the drop-down menu or enter the resolution at which you want to insert the image.
  - **Title**: *(optional)* For a DITA topic, concept, or reference document, enter the title or caption for the image. The Title field is not available when you are working on a DITA task or troubleshooting type document.
  - If you do not specify the Title, then the graphic is wrapped inside the Image element in the background and you will not be able to add a Title later on. However, if you add a Title, then the graphic is wrapped inside the Figure element allowing you to change the Title anytime later.
  - **Alternate text**: *(optional)* enter the text that is displayed in case the image is not published.
- If you create a DITA task topic, then you are allowed to insert a graphic in the Procedure title, Short description, and Procedure steps fields. This is because in the task topics, the graphic is wrapped inside the `image` element.
- If you insert an image, the Simplified XML view displays an anchor that allows you to easily select, expand, or collapse the image.
• To move the image, you need to click on the Image anchor and then drag-and-drop the image.
• To resize an image, click to select the image object (not the Image anchor) and drag a side handle to change either the width or height.
• To view the object properties of the imported graphic, right click the graphic and choose Object Properties. To view object properties of the anchored frame, click on the anchor and choose Graphic > Object Properties.

Work with MathML
• You can insert MathML equations in DITA 1.3 document types (topic, task, concept, reference, and troubleshooting.)
• To insert a MathML equation, click the MathML Container button in the QET.
• If you insert a MathML equation in your topic, the Simplified XML view displays an Equation anchor that allows you to easily select the MathML equation.
• To move the MathML equation, you need to click on the Equation anchor and then drag-and-drop the equation.

Work with Definition List
• You can insert a definition list element by clicking the Definition List button in the QET.
• To insert a definition list entry, click the Definition List Entry button in the QET.
• To insert elements after a definition list, click the Navigate To End Of Form Element button in the QET.

Work with code block
• You can insert a Code Block element by clicking the Code Block button in the QET.
• To insert elements after a code block, click the Navigate To End Of Form Element button in the QET.
• If you want to apply teletype (monospace) formatting to your content, select the desired text and click Teletype, monospaced button in the QET.

Use Paste and Smart Paste
FrameMaker automatically creates valid structure if you copy and paste content from external applications such as MS Word, Excel, or a browser. However, if pasting an external content results in an invalid DITA file, a prompt appears asking you to either copy the content without formatting or copy one block at a time.

You can also drag-and-drop content within a document. However, if you try to place the dragged content at an invalid location, FrameMaker will show a red icon and block the operation.

Open and save XML files in the Simplified XML view
You can open any DITA topic in the Simplified XML view. If the topic includes elements that are not defined in the form, these elements will be shown but they will be uneditable. You can make changes to the editable content and then save the topic.

FrameMaker provides out-of-the-box support for DITA topic, task, reference and concept. However, any XML file for which the corresponding structured application is configured with the Simplified XML view configuration file can be opened in this view. If the configuration file is defined but template is not specified, the default template defined in the structured application is used and a message is shown in the console when you switch to the Simplified XML view. For more details, see Customize the Simplified XML authoring environment.

You cannot open DITA maps, FrameMaker books, or .fm files in the Simplified XML view.
Customize the Simplified XML authoring environment

You can specify the fields (and their appearance) in the Simplified XML view for a specific structured application. For example, in the DITA topic structured application, you can choose to hide the short description field or show only the topic title and body fields. FrameMaker also allows you to specify a custom template file that is used to render the form fields in the Simplified XML view.

Customize the Simplified XML view form fields

Each structured application that supports the Simplified XML view includes a configuration file (.ini). You can work with the flags in this file to customize the fields in the corresponding Simplified XML view.

If you are currently working in the Simplified XML view of a topic, switch to the WYSIWYG view.

1. Open the following document:

   `<Fm install directory>\Structure\structapps.fm`

   The structured application for each DITA topic type (topic, task, reference, concept, and troubleshooting) in this file includes a Form View field.

   The Form View contains two flags:

   - **Configuration File**: defines the configuration file for the corresponding structured application.
   - **Template**: defines the template file associated with the structured application to render the user interface for the Simplified XML view.

2. To customize the .ini file, you need to copy it to a location outside the current FrameMaker install directory.

3. In the form **Configuration File** field, update the location of the file according to the previous step.

4. The configuration file allows you to work with the following fields.

   - **FormElements** Specify the structured application elements you want to show in the Simplified XML view. The syntax for specifying the FormElements is:

     ```
     body,Body,1,1|
     ```

     Where,

     - **body**: Name of the element defined in the structured template.
     - **Body**: Label that appears at the top of the form field in the Simplified XML view.
     - **0,1**: Specify whether this element is optional (0) or mandatory (1). If you specify an element as mandatory, the user must enter a value for that element before saving the document.
     - **Optional**: Specify whether a field is the body field and Insert Objects catalog is shown on pressing the Enter key in this field. By default, a value of 0 is assigned to a field where this value is not specified.
     - **|** (Pipe) Delimiter for specifying more elements.

     **Example**: FormElements=title,Title of your topic,1|shortdesc,Short description - one paragraph,0|author,Enter your name,1|body,Content of your topic,1,1

   - **FormLabelPgfFormat** The paragraph format defined in the template that is used to display the form labels.

     **Example**: FormLabelPgfFormat=fm-title
**RequiredFormLabelPgfFormat**  The paragraph format defined in the template that is used to display the mandatory form labels.

**Example:** RequiredFormLabelPgfFormat=fm-titlerequired

**FormFieldColor**  Specify the default boundary color for the form field boundary.

**Example:** FormFieldColor=GrayDark

**RequiredFormFieldColor**  Specify the color for the mandatory field boundary.

**Example:** RequiredFormFieldColor=Red

**SelectedFormFieldColor**  Specify the color for the currently selected field boundary.

**Example:** SelectedFormFieldColor=Blue

**ParaElements**  Specify the element to create when the Enter key is pressed in a paragraph element. You can also specify multiple elements separated by a pipe (|). If you have specified multiple elements, FrameMaker will insert the first valid element in the current context. For example, in case of a DITA task, you can map this flag to a paragraph and information elements (p|info). When a user hits the Enter key, FrameMaker will first try to insert a paragraph element at the current location, but if the paragraph is not valid then it will insert the information (info) element.

**Example:** ParaElements=p|info

**OrderedListElement**  Specify the element that is mapped to the ordered list. For example, in a DITA topic, you can map this flag to the ol element to create a new ordered list. However, in case of a DITA task, you can map this flag to the steps element to create a new procedure.

**Example:** OrderedListElement=ol

**OrderedListItemElement**  Specify the default element to create when the Enter key is pressed in an ordered list item. For example, in a DITA topic, you can map this flag to the li element to create a new list item within an ordered list. However, in case of a DITA task, you can map this flag to the step element to create a new step within a procedure.

**Example:** OrderedListItemElement=li

**UnorderedListElement**  Specify the element that is mapped to the unordered list. For example, in a DITA topic, you can map this flag to the ul element to create a new unordered list. However, in case of a DITA task, you can map this flag to the steps-unordered element to create a new nested procedure.

**Example:** UnorderedListElement=ul

**UnorderedListItemElement**  Specify the default element to create when the Enter key is pressed in an unordered list item. For example, in a DITA topic, you can map this flag to the li element to create a new list item within an unordered list. However, in case of a DITA task, you can map this flag to the step element to create a new step within a nested procedure.

**Example:** UnorderedListItemElement=li

**BoldElement**  Specify the element to be used (b) to apply **bold** formatting on text when the key combination **Ctrl+b** is used.

**Example:** BoldElement=b

**ItalicElement**  Specify the element to be used (i) to apply *italic* formatting on text when the key combination **Ctrl+i** is used.

**Example:** ItalicElement=i
**UnderlineElement** Specify the element to be used (u) to apply underline formatting on text when the key combination Ctrl+u is used.

**Example:** UnderlineElement=u

5 After making the required changes to the configuration file, save the file.
6 Reload the current structured application.
   Go to the structapps.fm and choose StructureTools > Read Application Definitions.
7 If any structured topic is currently open, go to the topic and switch to the Author View.
   Any changes to the configuration file are immediately reflected.

**Customize the Simplified XML view template**

Each structured application that supports the Simplified XML view includes a FrameMaker template. This template defines how the various form elements are presented in the Simplified XML view. For example, you can customize the font size and color of the mandatory field labels in your form or define the auto-insertion rules for the elements. Whatever changes you make to this template file are reflected in the Simplified XML view.

If you are currently working in the Simplified XML view of a topic, switch to the WYSIWYG view.

1 In the structapps.fm, the Form View > Template field defines the Simplified XML view template file for the corresponding structured application.
2 To customize the template file, you need to copy it to a location outside the current FrameMaker install directory.
3 In the Template field, update the location of the file according to the previous step.
4 Update the template file as required and save the file.
5 Reload the current structured application.
   Go to the structapps.fm and choose StructureTools > Read Application Definitions.
6 If any structured topic is currently open, go to the topic and switch to the Author View.
   Any changes to the template file are immediately reflected.
Chapter 13: Structured Authoring Using DITA

Why DITA

DITA changes the way content is created, stored, managed, and consumed. It also changes the tools that are used and the way authors have to think about content.

Content reuse and modularity
You can reuse content not just for print and the web but also for multiple custom outputs. Reuse at a heading or line level can be chaotic and challenging to implement and manage, especially at an enterprise-wide level. DITA facilitates reusability at a more manageable content level: the topic. A topic is the smallest chunk of information that can stand alone as meaningful information. Topics are then assembled into documents using DITA maps, which are hierarchical lists of pointers or links to topics. These pointers are called <topicref> elements.

Topics can also be reused in other topics. Each topic is assigned a unique ID. From a topic, you can include a content reference (<conref>) to another topic using its unique ID. At a finer level of granularity, you can also assign property tags to individual topic elements for conditional assembly.

Multichannel publishing
Modular topics allow for dynamic assembly of content at any level of granularity. You can create multiple documents from reusable topics. Assembly can be conditional, dependent on properties or metadata tags that you attach to a topic. For example, the audience property can be <beginner> or <advanced>, and the platform property <Windows> or <Solaris>.

Ease of authoring and publishing
By segregating content from presentation, DITA allows you to reuse modular topics. You can reuse a topic by specifying it in multiple topic maps. For example, you can have the same topic appearing in multiple topic maps and set a new context by using a relationship table. This also aids publishing because the content is independent of format definitions.

Minimalism in content
Minimalism in documentation means providing users only the information they need for accomplishing a specific task. This approach requires the breakdown of sequential information into smaller, concise, and consistent chunks that can be reused.

Information typing
Topics can be specialized into few information types, notably a task type, and two supporting types called concept and reference.

Task A series of steps and explanations that enable users to finish a defined unit of work.
Concept Explanation of key conceptual information related to a task.
Reference Facts relevant to a task. Often reference topics are presented in table or list form to give users quick access to information.
Glossentry  List of glossary terms and definitions.

DITA also provides an architecture for creating new information types based on the existing ones. You can create specific document type definitions through the process of specialization—new structural types or new domains of information. Structural specialization defines new types of structured information, such as new topic types or new map types. Domain specialization creates new markup that can be useful in multiple structural types, such as new kinds of keywords, tables, or lists.

Reduced localization costs
Modular, topic-based content with unique topic IDs allows concurrent authoring and localization of DITA map content. This approach reduces localization costs as well as time to market. In addition to topic orientation and content reuse, these DITA features also reduce localization costs.

- All DITA topics are stored in Unicode.
- DITA provides the ability to specify the language setting on nearly every element in a DITA topic.
- The <translate> attribute allows you to indicate items ready for translation.

Challenges in implementing DITA
Some challenges in migrating to DITA:

- Repurposing existing content
- Preparing content for reuse
- Breaking down sequential content into modular, reusable components
- DITA specialization for specific needs
- Post-processing of outputs

DITA support in FrameMaker XML Author

FrameMaker 10 provides support for DITA v1.2. For more information on DITA integration with FrameMaker XML Author see the online manual Integrating DITA Specialization with Adobe FrameMaker on the Adobe website.

Basic DITA terms

**DITA topic**  A base <topic> element in DITA requires only three elements: a unique ID, a topic title, and a topic body. It can have multiple optional elements, such as paragraphs <p>, unordered lists <ul>, and tables <table>.

**DITA task topic**  A task <topic> type specializes topic element names and topic structure. The root element of a task topic is named <task>, and its body element is <taskbody>. A task topic can have one task prerequisite and one context element followed by steps. Each step must have a command, optional information, a step example, choices, and a step result. You can provide the task result, examples, and any task postrequisites after a set of steps.

**DITA concept topic**  A <concept> topic type specializes topic element names and topic structure. A concept topic can have any number of paragraphs, lists, or tables in the first section or example. Subsequent topic consists of sections and examples which can appear in any order.

The root element of a concept topic is named <concept>, and its body element is <conbody>.

**DITA reference topic**  A <reference> topic type specializes topic element names and topic structure. The root element of a reference topic is <reference>, and its body element is <refbody>. The <refbody> element includes a <properties>
element which is a table of property types, values, and descriptions. The element `<refsyn>`, reference syntax, is a specialization of the `<section>` element.

**DITA glossentry topic** A glossentry topic type is a specialization for glossary entries. It consists of glossary term, `<glossterm>`, and glossary term definition, `<glossdef>` pairs.

**DITA map** The DITA map is like a table of contents listing and linking the topics for a specific output. DITA maps assemble topics into sequence and hierarchy tailored to specific delivery requirements. You can have multiple maps, each one arranging the topics for different requirements, such as a reference manual, a tutorial, or online Help. A DITA map file has the extension `.ditamap`.

**Bookmap** A bookmap is a specialization of a DITA map. You can save a DITA map as a bookmap. In a bookmap, highest-level `<topicref>` elements in your DITA map become chapters in the FrameMaker XML Author book, containing any nested `<topicref>` elements. Formatting is determined according to which structured application you have selected for books in the DITA Options dialog box.

**Relationship table** Links between topics are defined and maintained using relationship tables.

**Conref** DITA implements reuse of content units with the `<conref>` attribute. For example, if the same table appears in multiple topics, you can author it once and include it by reference.

**Xref** References to external sources of information, such as a web page. When you open a file, the DITA feature automatically resolves `<xref>` elements and displays any associated text within FrameMaker XML Author.

**Specialization** DITA allows the addition of new elements through specialization of base DITA elements. Through specialization, DITA can accommodate new topic types and element types as needed for specific industries or companies.

**Open Toolkit** Open Toolkit is a free, open-source, end-to-end, single-source publishing system. It takes your DITA topics and DITA maps and generates multiple output format deliverables, such as print (PDF), web (HTML), and Help.

### Set attribute display options

Attributes are used to help describe XML elements or provide additional information that can be used, for example, to identify an element or apply formatting controls. Before working with attributes, you must be able to identify attributes in a document and expand or collapse them as required.

1. **Select View > Attribute Display Options.**
2. **Do one of the following:**
   - If you want elements to display only attributes that are either required or have values in the Structure View, select Required And Specified Attributes.
   - If you want elements to display all the attributes assigned to them in the Structure View regardless of values or requirements, select All Attributes.
   - If you want all elements to display their attributes collapsed in the Structure View, select No Attributes.
3. **Click Set.**
DITA options

Use the DITA Options dialog box to set general, import, and export-related DITA options. DITA options are global settings for the authoring environment. If you change the DITA settings, you should restart FrameMaker XML Author to have the new settings take effect.

**DITA options**

**Application mapping**

With the FrameMaker XML Author Application Mapping Manager, you can define separate structured applications for each doc type that your XML file contains. These mappings are retained within the DOCTYPE declaration of each XML file. Such individual mapping allows documents to be opened and processed with the correct set of structured applications and type. This means that you can specify a custom combination of doc type and DITA public IDs.

**Add an application mapping**

You can create an application mapping tag. After you define a tag, you can then add or edit mapping for different doc types and their related application and type.

1. On the DITA Options dialog box, click Applications Mappings.
2 On the DITA Applications Mapping Manager dialog box, select New Mapping... from the Mapping Tag pop-up menu.

3 On the DITA Applications Mapping dialog box, do the following, and click OK.

   **Mapping Tag** Enter a name for the custom mapping tag.

   **Mapping Type** Select the type of application mapping. If you are creating a mapping, select APP_MAPPING as the type.

**Edit an application mapping**
You can define how each doc type is mapped to each structured application.

1 On the DITA Applications Mapping Manager dialog box, select the mapping tag.

2 Select the mapping from the Defined Mapping table. You can edit the following:

   **Doctype** Specifies the doc type of the DITA file. Doc types that are defined in the template are available for selection and editing.

   **Application** Specify the structured application that FrameMaker XML Author uses to open the doc type.

   **Type** Specify the type of the document. It can be a Topic, Map, Composite, or None.

3 Click Add/Edit.

**Delete a defined mapping**

1 On the Application Mappings Manager dialog box, select the mapping tag.

2 On the Defined Mappings table, select the mapping you want to delete, and click Delete.

**Delete an application mapping tag**

❖ On the Applications Mapping Manager dialog box, select the mapping tag, and click Delete.

**Set the DITA version**
You can set the DITA version of FrameMaker XML Author. This is a global setting.

By default, FrameMaker XML Author is set to DITA 1.2. Within this option, you can open and work on documents created with earlier version DITA. However, if you add any elements or attributes that are available only with DITA 1.2, the document becomes a DITA 1.2 document. If you open that document later with an earlier version of DITA, you will get validation errors.

**Set the file type for new documents**
You can set the default file type that FrameMaker XML Author will use when you create a new document. The default ‘New’ type specifies the filename extension for a new topic (.xml or .dita). This extension is applied only if you do not specify an extension for the new file.

1 Select DITA > DITA Options.

2 Select *.xml or *.dita in the Default ‘New’ Type list.
Element IDs
You can set FrameMaker XML Author to automatically assign IDs to elements when an ID is a required attribute for the element. When you use this option, you cannot manually assign IDs to topics or elements from FrameMaker XML Author.

The ID value assigned to the selected element is composed of values representing the year, month, day, hours, minutes, and seconds, plus two randomly generated values. It is designed to be unique per-user for 100 years.

Specify the ID format
❖ In the DITA Options dialog box, specify an ID prefix in the Default ID Prefix field. This prefix is associated with new IDs generated by DITA.

Automatically assign IDs to elements
❖ In the DITA Options dialog box, deselect the Auto Add IDs If Required By Element option.

Set File Open options
You can specify how FrameMaker XML Author should treat the references in a document when it opens it. Specify the options to optimize the document open performance.

You can set FrameMaker XML Author to automatically reload the following references when opening a file:
Topicrefs Select Auto Load Topic Refs on File Open if you want the Topicrefs in the DITAMAP to automatically loaded when you open the map in FrameMaker XML Author.
Conrefs Select Auto-Load Conrefs On File Open if you want the content references in the DITAMAP to automatically loaded when you open the map in FrameMaker XML Author.
Xrefs Select Auto-Load Xrefs On File Open if you want the DITA cross-references in the DITAMAP to automatically loaded when you open the map in FrameMaker XML Author.
(For Documentum Connector only) Graphics Select Auto-Load Graphics On File Open if you want the graphics in the DITAMAP to automatically loaded when you open the map in FrameMaker XML Author.

Set Navtitle options
The <navtitle> attribute specifies the navigation title of a topic and this can be different from the first level heading that shows in the main browser window. The <locktitle> attribute ensures that if present, the <navtitle> attribute is always used. If the Always Update Navtitle While Updating Topicref option is not selected, then <navtitle> is displayed if <locktitle> is set to yes when you update references in a DITA map file.
❖ On the DITA Options dialog box, set the following:
• Select the Always Update Navtitle While Updating Topicref option to display the title from the topicref files. The <navtitle> attribute specifies the navigation title of a topic and this can be different from the first level heading that shows in the main browser window. The <locktitle> attribute ensures that if present, the <navtitle> attribute is always used.

If the Always Update Navtitle While Updating Topicref option is not selected, then <navtitle> is displayed if <locktitle> is set to yes when you update references in a DITA map file.
• Select the Always Display NavTitle On File Open option to display <navtitle> if <locktitle> is set to yes when you open a DITA map file. If this option is not selected, then the title from the <topicref> files is displayed and <navtitle> is not updated.
Conditionalize prolog or comments

You can have the prolog, and comments to be hidden from the body of the document when FrameMaker XML Author opens a DITA file.

If you enable conditionalizing prolog and comments, FrameMaker XML Author applies the <DITA-Prolog> or <DITA-Comment> condition tag to these elements when a DITA file is imported. By default, these conditions are set to Hide in the structured template. In addition, the text thus conditionalized is saved (exported) regardless of whether it is showing (“OutputAllTextWithoutPIs”). If, on import, no associated condition tag is found in the structured template, the condition tags are added and set to Show (in red).

If the Conditionalize option is not selected, all <prolog> and <draft-comment> elements are imported and displayed using the formatting from the EDD and structured template with no condition tags applied.

Manage index terms

You can let FrameMaker XML Author convert the <indexterm> elements in the DITA file to FrameMaker XML Author index maker entries when opening a DITA file, and then converting them back to indexterm elements when exporting the FrameMaker XML Author document to DITA file.

❖ On the DITA Options dialog box, select Indexterm To Index Marker Conversion.

Enable active links in PDF for external links

By default, when you create a PDF from a DITA file, external references are not converted to clickable links (active links). To enable clickable links for these references, you must allow FrameMaker XML Author to add hypertext markers to the element, and automatically populate them with the required syntax. Within a DITA file, the external references are created through inserting an <xref> element, and setting its “source” attribute as “external”.

If you use this option, when you open a DITA file, FrameMaker XML Author assigns a <link-asis> character format to the <xref> element, and places a hypertext marker there. FrameMaker XML Author adds the marker text with the value of the <href> of the <xref> element, preceded by “message URL.” This generates an active URL that can be saved as PDF. (Previously, only <fm-xref> elements could produce an active link in a PDF file generated from within FrameMaker XML Author using this application.)

**Note:** This process doesn’t make “internal” <xref> elements clickable in a PDF. To accomplish that, you can use <em>fm-xref</em> wherever the associated text can be gleaned from the source of <em>fm-xref</em>.

❖ On the DITA Options dialog box, select the Add Hypertext Marker To External Xrefs option.

Set table options

You can set FrameMaker XML Author to track the number of columns across tables whole importing a file into a structured document. By default, this option is selected.

❖ On the DITA Options dialog box, select or deselect Select the Count Columns In Tables On File Open option.

DITA topics

DITA provides a standard for structuring topics and content within topics. That standard is based on three broad information categories into which almost all technical information can be classified: task, concept, and reference.
These topic types are considered specializations of the base class of `<topic>`, from which they inherit a consistent core structure. Elements common to the three standard DITA information types are `<title>`, `<description>`, `<prolog>`, and `<body>`. A DITA document must contain at least one topic and can contain many subtopics.

The `<task>`, `<concept>`, and `<reference>` elements inherit common structure from their parent information type, `<topic>`.

<table>
<thead>
<tr>
<th>Task Topic</th>
<th>Concept Topic</th>
<th>Reference Topic</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Common structure</strong></td>
<td><strong>Header:</strong>&lt;br&gt;Title&lt;br&gt;Short description&lt;br&gt;Prolog&lt;br&gt;<strong>Body:</strong>&lt;br&gt;taskbody&lt;br&gt;<strong>Related links</strong>&lt;br&gt;</td>
<td><strong>Header:</strong>&lt;br&gt;Title&lt;br&gt;Short description&lt;br&gt;Prolog&lt;br&gt;<strong>Body:</strong>&lt;br&gt;conbody&lt;br&gt;<strong>Related links</strong>&lt;br&gt;</td>
</tr>
<tr>
<td><strong>Examples of optional elements (within body)</strong></td>
<td><strong>Context</strong>&lt;br&gt;Prerequisites&lt;br&gt;Steps&lt;br&gt;Step-elements&lt;br&gt;Result&lt;br&gt;Examples&lt;br&gt;Post requirements</td>
<td><strong>Section</strong>&lt;br&gt;Paragraph&lt;br&gt;Lists&lt;br&gt;Tables&lt;br&gt;Images&lt;br&gt;Examples</td>
</tr>
</tbody>
</table>

DITA structure supports reuse of independent topics in any arrangement to form new documents. In fact, one of the main reasons for the topic-based nature of DITA is to let authors reuse information.

Content reuse can take any of these forms:

- Compiling independently created and saved topics into new documents
- Automating links and cross-references to, from, and within topics and documents
- Identifying and formatting information for various kinds of distribution
- Formatting information so it can be handled by diverse processes
- Segmenting authoring responsibility across multiple authors or groups

Reuse can occur at the topic level (that is, when you rearrange output through DITA maps). Reuse can also occur at the subtopic level, such as when you reference a specific document component within multiple topics via content reference attributes.

**Create a DITA topic**

The DITA Options dialog box provides an option for automatically wrapping new topic-level elements, such as `<topic>`, `<concept>`, `<reference>`, `<task>`, and `<glossentry>` in a `<dita>` element (the default). Select this option and then create a topic.

1. Select DITA > DITA Options, and choose Wrap New Topics In Dita Element.
2. Click Save.
4 Specify a filename and click Select. A new window appears for your new DITA topic with the default title text TOPIC help.

You can insert any DITA topic type from the Elements Catalog. For example, to build an article, you can include any number of DITA concept, task, or reference topics.

**Note:** If you do not provide a filename extension for the new file, an extension is added based on the type specified in the Default File Type option in the DITA Options dialog box.

**Create a DITA concept, task, reference, or glossary entry**

1 Select DITA > New DITA File > New and then one of these: `<concept>`, `<task>`, `<reference>`, or `<glossentry>`.

2 Specify a filename and click Select. A new window appears for your new DITA topic with some default title text. The default titles are CONCEPT title, TASK title, REFERENCE title, and GLOSSENTRY GLOSSTERM.

**Note:** If you do not provide a filename extension for the new file, an extension is added based on the type specified in the Default File Type option in the DITA Options dialog box. In FrameMaker XML Author, you can also save a DITA file without a title.

**Create a DITA concept**

1 Select DITA > New DITA File > New `<concept>`.

2 Specify a filename and click Select. A new window appears for your new DITA concept with the default title text CONCEPT title.

**Note:** If you do not provide a filename extension for the new file, an extension is added based on the type specified in the Default File Type option in the DITA Options dialog box. In FrameMaker XML Author, you can also save a DITA file without a title.

**Create a DITA task**

1 Select DITA > New DITA File > New `<task>`.

2 Specify a filename and click Select. A new window appears for your new DITA task with the default title text TASK title.

**Create a DITA reference**

You can create a reference topic that includes content, such as additional information, a tip, a warning, or a simple note.

1 Select DITA > New DITA File > New `<reference>`.

2 Specify a filename and click Select. A new document window appears for your DITA reference topic with the default title text REFERENCE title.

The new DITA reference file is saved as an XML file. The Element Catalog displays the valid DITA elements for a reference topic.

**Create a DITA glossentry**

1 Select DITA > New DITA File > New `<glossentry>`.

2 Specify a filename and click Select. A new document window appears for your DITA reference topic with the default title text GLOSSENTRY GLOSSTERM.

You can add glossary terms and glossary definitions.
Using indexterm elements

DITA supports the `<indexterm>` marker elements of FrameMaker XML Author. The API client converts FrameMaker XML Author index markers with colon-delimited subentries to nested XML `<indexterm>` elements for seamless export. It reverses the conversion for seamless import. In addition to support for the basic `<indexterm>` element, these types are supported:

- **Index-see** Include a “See” reference.
- **Index-see-also** Include a “See Also” reference.
- **Index-sort-as** Override the default sort order of the term.
- **Start and End attributes** Define a start and end range for index entries

Assign an ID to an element

You can configure DITA to assign a generated ID to a selected element. The ID value assigned to the selected element is composed of values representing the year, month, day, hours, minutes, and seconds, plus two randomly generated values. It is designed to be unique per user for 100 years. You can specify an ID prefix in the Options dialog box. If you specify an ID prefix for each user, the generated IDs are unique for each member of your team.

1. Select an element in the Structure View.
2. Select DITA > Assign ID To Element, or right-click the element, and select Assign ID To Element.

DITA generates an ID automatically and assigns it to the selected element.

DITA maps and bookmaps

DITA maps

A DITA map file opens as a new Resource Manager panel. The icons on the resource manager toolbar are buttons-specific DITA maps. You use them to add child and sibling `<topicref>` elements and `<conref>` attributes. You can build any number of hierarchical levels in a DITA map. You can also include other DITA maps within a DITA map.
Structured Authoring Using DITA

You can add other types of elements to a DITA map by either switching to the Document view or by using the Structure view with the resource manager. Using the Element Catalog, you can insert other elements valid at the insertion point in a DITA map.

Publishing an Adobe Presentation

- [Publishing Presentations](Publishing Presentations.xml)
  Publishing Presentations
  - [Viewing the published presentation](Viewing the Published Presentation.xml)
    Viewing the published presentation

![DITA map Document View, Structure View, and the Element Catalog](image)
Note: To switch back to the resource manager view from the Document view, select View > Resource Manager option. You can also use the Switch to Resource Manager icon on the menu bar (located to the left of the view mode icons).

Preview DITA map content
FrameMaker XML Author lets you preview your topicrefs from within a DITA map. By previewing the topicrefs in a DITA map, you can see the content within the various files that make up the DITA map.

Note: The preview feature is available for DITA map only and not for bookmaps. The preview feature also is not available for DITA maps embedded inside other DITA maps.

This helps you organize and manage the files in the DITA map more efficiently as compared to opening the various files or generating an output.

Preview content of one topicref
1. In the DITA map, switch to Document View.
2. Right-click on a topicref and select Resolve Topiref(s) > Show Content.
   FrameMaker XML Author displays the relevant topic’s contents in the DITA map. In the Document view of DITA map, FrameMaker XML Author displays > to denote that a topic is a top-level topic in the DITA map. >> denotes a topic is a second-level topic and >>> denotes the topic is at level 3 (and beyond) in the DITA map.

   Topic levels as denoted by >, >>, and >>>
   To open a topic, you can click the expanded preview of a topicref.

Preview content of all the topicrefs in the DITA map
1. In the DITA map, switch to Document View.
2. Right-click anywhere in the DITA map and select Resolve Topiref(s) > Show Content.
3. FrameMaker XML Author displays a confirm message: “No element selected. Do you want to show content of all the topicrefs?” Click Yes.
   FrameMaker XML Author displays all the topic’s contents in the DITA map.

Hide topicref content
1. In the DITA map, switch to Document View.
2. Right-click on an expanded topicref and select Resolve Topiref(s) > Hide Content.
3. FrameMaker XML Author hides the content of the selected topicrefs in the DITA map.
Hide all the expanded topicrefs in a DITA map

1. In the DITA map where you have one or more topicrefs expanded, without selecting any topicrefs right-click and select Resolve Topicref(s) > Hide Content.

   FrameMaker XML Author displays a confirm message “No element selected. Do you want to hide content for all the topicrefs?”

2. Click Yes.

Save a DITA map

You can save a DITA map in multiple outputs depending on your post-processing requirements. You can save a DITA map as a FrameMaker XML Author book file or a composite document to utilize the powerful print capability of FrameMaker XML Author. You can set custom numbering properties and pagination information in a FrameMaker XML Author book file and not in a DITA map or bookmap file.

In addition, you can, at the time of saving, specify a DITAVAL file for generating conditional outputs.

Following is a list of some of the key formats in which you can save a DITA map file.

**Book 10.0 (*.book)** Save the DITA map as a .book with .xml components. In this case, .xml files are not converted to .fm files.

**PDF (*.pdf)** Generate a PDF directly from the DITA map. This option works in the same way as it does for a FrameMaker XML Author document or a FrameMaker XML Author book file.

*Note:* PDF Generation is meant only for review purposes. Since you cannot generate a PDF from ditamap, you first need to create a book from ditamap and then save the book to PDF which can be used for review purposes.

**Saving a DITA map as a PDF**

FrameMaker XML Author provides the ability to directly print a DITA map as a PDF.

1. Open the .ditamap file or the .bookmap file and choose File > Save As PDF.
2. Specify a name for the PDF file and click Save.
   
   You can also specify a DITAVAL file for conditional output.
3. Set PDF options from the PDF Setup dialog box and click Set.

Create a DITA map

1. Select DITA > New DITA File > New <map>. The Enter A New DITA Map filename dialog box appears.
2. In the filename field, specify a unique name for the map file.
   
   *Note:* If you do not provide a filename extension for the new file, a default name is added based on the type specified in the Default File Type option in the DITA Options dialog box. DITA map files are assigned a .ditamap extension.
3. Click Select. A new resource manager window appears for your DITA map with the default title text MAP title.
4. Click the Switch To Document View icon on the DITA map. In the Document View, you can specify a map title or add elements and attributes other than <topicref> and <conref>.
5. In the Document View, select MAP title and specify a title for your DITA map.

Insert a topicref in a DITA map

You can insert a child or sibling <topicref> element in a DITA map. The command inserts a new <topicref> element at the current insertion point of an open DITA map file, or overwrite a selected <topicref> element to reference a new file.
Insert a topicref from the resource manager panel
1 Open a DITA map file.
2 Select the file below which you want to add a <topicref> element.
3 Select Insert Sibling Topicref.
4 Select a file, or in the filename field, specify the name of the topic file.
5 Click Select. The topic reference is inserted in the DITA map file.

*Note:* You can use the arrow icons on the resource manager toolbar to promote a child <topicref> to a sibling <topicref> or convert a sibling <topicref> to a child <topicref>.

Insert from the Document View
1 Open a DITA map file and click to switch to the Document view.
2 Right-click at the desired insertion point and select Insert Topicref.
   Alternatively, select the <topicref> element from the Element Catalog and click Insert. The Select A Topicref File dialog box appears.
3 Select a file, or in the filename field, specify the name of the topic file.
4 Click Select. The topic reference is inserted in the DITA map file.

Open all topic references in a DITA map
1 Open a DITA map file containing topic references.
2 Select DITA > Open All Topicrefs.
3 Click OK to confirm the message displayed. The linked topic reference files are opened in separate windows.

Bookmaps
A bookmap is specialized DITA map that allows you to organize and print your DITA topics as a book. A bookmap also opens in a similar Resource Manager panel. The icons on the resource manager toolbar are identical to the icons for a DITA map.

DITA locktitle and navtitle attributes
The <navtitle> attribute specifies the topic title that appears during navigation. The <locktitle> attribute ensures that the value of the <navtitle> attribute is used during navigation if it is present.

Relationship tables

About relationship tables
In DITA, you can add related topics' links in the end of a topic by:

- Inserting related links element within the topics or
- Inserting one or more relationship tables in a ditamap for all the related topics in that ditamap

Although the outputs of both these approaches appear identical (see graphic), relationship tables are the better of the two approaches.
**Changing the oil in your car**

Once every 6000 kilometers or three months, change the oil in your car. This will help keep the engine in good condition.

**To change the oil:**

**TASK**
1. Remove the old oil filter.
2. Drain the old oil.
3. Install a new oil filter and gasket.
4. Add new oil to the engine.
5. Check the air filter and replace or clean it.
6. Top up the windshield washer fluid.

**Related Links:**
- Workbench
- Windshield washer fluid

---

**Relationship table advantages**

Relationship tables have the following advantages over the in-topic related links:

1. In-topic related links are embedded in the topics and hence affect the reusability of the topics. Using relationship tables, the links are created from outside the topics and the topics remain clean for reuse in different content deliverables.

2. Tracking the in-topic related links is an overhead. You have to manually make sure that the related topics exist in the same ditamap. Moving/deleting a topic later can lead to broken links. Using relationship tables, you can avoid this problem.

3. Using relationship tables, you can manage related links in a centralized, efficient way.

**Relationship table examples**

For clarity on the relationship table rules, see the two simple relationship tables and the links they create in their respective outputs.

**Relationship table rules**

The following rules govern the relationship tables:

- In FrameMaker XML Author, you can insert only one type (such as concept or reference) of DITA topics in a column/cell of a relationship table.

- By default, multiple topic references in the same cell are not linked to each other (not listed under related links for each other) in the output.

*Note:* To link multiple topic references that exist in the same cells, you can set the collection-type attribute of the relcell to family.
Example 1

Relationship table 1

<table>
<thead>
<tr>
<th>Concept</th>
<th>Task</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>oil.xml</code></td>
<td><code>changingtheoil.xml</code></td>
</tr>
<tr>
<td><code>paint.xml</code></td>
<td><code>spraypainting.xml</code></td>
</tr>
</tbody>
</table>

Relationship table 1 output: Related links created in the output in various topics

Last updated 8/19/2015
### Example 2

**Relationship table example 2**

<table>
<thead>
<tr>
<th>Concept</th>
<th>Concept</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Diagram" /></td>
<td><img src="image2" alt="Diagram" /></td>
</tr>
<tr>
<td><img src="image3" alt="Diagram" /></td>
<td><img src="image4" alt="Diagram" /></td>
</tr>
</tbody>
</table>

**Relationship table 2 output:** Related links created in the output in various topics
Parts of a relationship table in FrameMaker XML Author

Following is what a relationship table looks like in FrameMaker XML Author. In this relationship table, two topics are linked to each other: tools.xml and toolbox.xml. In the output of the ditamap which has this table, tools.xml topic will display toolbox as related topic and toolbox.xml topic will display tools as related topic.

A. The reltable element that contains the relationship table is inserted just before the map element ends  
B. The title of the relationship table - add one for your reference, as it is not published in the output  
C. Column heads that specify the type of DITA topics allowed in the columns - to set values of the column heads, set the type attribute for the two relcolspec elements to Concept, Task, Reference, or a specialized topic type  
D. The two topic references inserted using the topicref elements - each of the two is shown as a related topic in the other

The underlying XML code of the relationship table as displayed by the XML view

Create a relationship table

You can add one or more relationship tables at the end of your ditamap.

A column of a relationship table can have only one type of DITA topics: concept, task, reference, or (if applicable) a specialized type. Before you could insert any topic references in the relationship table, you need to specify the type of DITA topic references allowed in each of the two columns of the relationship table (step 2.).

1. Insert a relationship table in a ditamap.
   a. Open a DITA map file and switch to the document view.
      
      **Note:** You can add `<topicref>` elements to a `<reltable>` in the document view only.
   b. Place the insertion point at the end of the Ditamap and insert the reltable (relationship table) element.
The Insert table dialog appears.

![Insert Table dialog](image)

c. Edit the number of columns and rows in the relationship table and click Insert.

A relationship table is added to your ditamap.

2. In the table headings, specify the type of the topic references (task, concept, reference, or a specialized type) valid for the columns.

   To set the valid topic types for each of the columns, set the type attribute of the relcolspec elements to concept, task, reference, or a specialized type.

   For example, a two-column table in which you are linking concept topics to concept topics, the type attribute for both the relcolspec elements (columns) is set to concept.

   **Note:** If you do not specify the type attribute for relcolspec elements, you will not be able to insert the topic references in the relationship table.
3 Link the different topics in the ditamap by inserting topic references in the columns.

To link two topics, insert their references (using the topicref element) in adjacent cells in the same row of the relationship table. In the output, both topics will have each other’s name listed under “Related links.”

While inserting topic references in the relationship tables, consider:

- By default, multiple topic references in the same cell are not linked to each other (listed under related links) in the output.
- To link multiple topic references that exist in the same cells, set the collection-type attribute of the relevant reccell element to family.
- If required, you can create relationship tables with more than two columns.

4 If required, create another table for linking different types of DITA topics.

5 Create an output to see the linking of the topics. To review the related links created by relationship tables, you can publish the ditamap as an output such as PDF, HTML, or Book 11 with FM components. You can also create a composite document and see the related links.

**DITA content references (conrefs)**

FrameMaker XML Author supports both direct and indirect referencing of content as per the DITA 1.2 standard. If your default structured application is based on DITA 1.2, you can use both direct and indirect content referencing. A DITA `conref` attribute inserts a content reference as a text inset and tags it with the `<DITA-Conref>` conditional text tag. The `conref` attribute is used to reference element with an ID or key so that its content can be reused.

**Direct content referencing** You reference an element with its path in `conref` attribute and its unique ID.

**Indirect content referencing** You reference an element with its key in the `conref` attribute and its unique ID.

**Indirect content referencing range** You reference and element with its key in the `conref` attribute and its unique ID, along with the range of subsequent elements. The range of elements to be referenced is specified by the unique ID of the last element in the range as `conrefend` attribute.

**Note:** To specify a range for the content reference, the elements within the range must be of the same type. At least the start and end elements must have unique IDs.
Create a direct content reference

1. Open a DITA file containing a topic type.
2. In Structure View, place your cursor at the appropriate location where the content reference is to be added.
3. Select DITA > Insert Conref.
4. In the DITA Conref dialog box, select file from which the element is to be referenced. By default, the current file is selected.
   
   **Note:** With DITA 1.1, you can only reference elements from a file.
5. Select the element to be referenced. Based on the selection, the available elements in the selected file are listed.
   
   **Note:** By default, FrameMaker XML Author displays only the elements that have IDs assigned. To display all elements, select Show All.
6. Select the ID of the element to be referenced, and click Insert.

Create an indirect content reference

1. Open a DITA file containing a topic type.
2. In Structure View, place your cursor at the appropriate location where the content reference is to be added.
3. Select DITA > Insert Conref.
4. In the DITA Conref dialog box, select Refer To A Key, and click Edit.
5. On the Key Reference dialog box, select the available keyspaces from the list.
6 Select the element type that you want to reference.
7 From the list of elements, select the ID of the element that you want to reference, and then click OK.
8 On the DITA Conref dialog box, click Insert.

Create content reference to a range of elements
1 Open a DITA file containing a topic type.
2 In Structure View, place your cursor at the appropriate location where the content reference is to be added.
3 Select DITA > Insert Conref.
4 In the DITA Conref dialog box, do one of the following:

   Refer to a key  If you have defined keyspaces for the reference target, you can reference a range of elements that are contained in the keyspace.
   1 In the DITA Conref dialog box, select Refer To A Key, and click Edit.
   2 On the Key Reference dialog box, select the key from the Key list.
      Note: If you haven’t specified any keyspaces, click Keypaces... to define keyspaces.
   3 Select the element type that you want to reference.
   4 From the list of elements, select the ID of the element that you want to reference, and then click OK.
   5 On the DITA Conref dialog box, select the end element of the range from the Conref End Element pop-up menu, and click Insert.

   Refer to a file  You can reference a range of elements using their IDs in a referenced file.
   Note: Ensure that Refer To A Key is deselected.
   1 On the DITA Conref dialog box, click Browse next to Refer To A File list, select the file, and click Select in the browse dialog box.
   2 Select the element tag that you want to reference.
   3 From the list of elements, select the ID of the first element in the range that you want to reference.
   4 From the Conref End Element pop-up menu, select the last element in the range of elements that you want to reference, and click Insert.

Create a content reference to a DITA topic
1 Open a DITA topic file.
2 Collapse the <body> element and place the insertion point below it.
3 Select DITA > Insert Conref. The DITA Conref window appears.
4 From the Source File list, select the file from which you want to conref the topic.
   Note: The Source File list displays a list of open files only. Use the Browse button to open a file not already open.
5 In the Element Tag pane, select a tag. The Element Data list displays a list of elements matching the selected element tag from the source file.
6 From the Element Data list, select the desired element and click Insert. The content of the selected element is inserted in your open file.
By default, the text color of an element inserted by reference is blue. However, you can modify it using the structured-template designer.

By default, error messages are generated when you open a file that contains a `<conref>` element or an `<xref>` element that can’t be resolved. Error messages also appear if the file references a file that has an unresolved reference. If you prefer not to receive these messages, choose DITA > DITA Options, and deselect both Auto-Load Conrefs On File Open and Auto-Load Xrefs On File Open.

Create a conref to an image

1. Open the DITA topic file in which to insert a content reference to the image.
2. Place the insertion point at a valid point in the Structure View.
3. Select DITA > Insert Conref.
4. From the Source File list, select the image source file.
5. From the Element Tag pane, select the image tag. The Element Data list displays a list of images in the selected source file. Only those elements that are valid appear in the Element Tag list.
   
   **Note:** If the image you want to reference is not in the Element Data list or if the entry states NO ID|NO CONTENT, the image element does not have an ID assigned to it. Assign it an ID, save the source file, and repeat the steps to insert the content reference.
6. Select the image ID from the Element Data list and click Insert. The image is inserted in your open file.

If you change the image in the source file, click DITA > Update References to reflect the changes in your target file.

Create a conref to a table or its cells

You can create a `<conref>` to a complete table element, table heading, table body, table row, or a table cell.

**Note:** In a simpletable, the table heading is a false element and therefore cannot be conref’d.

**Insert a conref to a table**

1. Open the DITA topic file in which to insert a content reference to a table.
2. Place the insertion point at a valid point in the Structure View.
3. Select DITA > Insert Conref.
4. From the Source File list, select the table source file.
5. From the Element Tag pane, select the type of the source table element, such as `<simpletable>`. The Element Data list displays a list of tables in the selected source file.
   
   **Note:** If the table you want to conref is not in the Element Data list or if the entry states NO ID|NO CONTENT, the table element does not have an ID assigned to it. Assign it an ID, save the source file, and repeat the steps to insert the content reference.
6. Select the table ID from the Element Data list and click Insert. The table is inserted in your open file.

**Insert a conref to a table row**

1. Open the DITA topic file in which to insert a content reference to a table row.
2. Insert a table element in the document. Ensure that it has the same number of columns as the source table.
3. Select the table row in which to insert a content reference.
Note: Selecting the table row in the Document View may select only the individual cells and not the row element. Look at the Structure View and ensure that you have selected the entire table row element, such as `<strow>`.

4. Select DITA > Insert Conref.

5. From the Source File list, select the file that is the source of the table row. Notice that the Element Tag list displays only the table row element, `<strow>`.

6. Select the table row ID from the Element Data list and click Insert. The content of the source table cell is inserted in the selected table row. A blue border is added to the row to indicate that it is a content reference.

Note: The source table row must have an ID assigned to it. If no ID has been assigned to the table row element, it doesn’t appear in the Element Data list even if its cells have individual IDs. Assign an ID to the table row, save the source file, and repeat the steps to insert the content reference.

Insert a conref to a table cell

1. Open the DITA topic file in which to insert a content reference to a table cell.

2. Place the insertion point at a valid point in the Structure View and insert a table element.

3. Select the table cell in which to insert a content reference.

4. Select DITA > Insert Conref.

5. From the Source File list, select the file that contains the source table cell.

6. From the Element Tag list, select the type of the source table element, such as `<stentry>`. The Element Data list displays a list of table cells in the selected source file.

Note: The table cell must have an ID assigned to it. If no ID has been assigned to the table cell element, it does not appear in the Element Data list. Assign it an ID, save the source file, and repeat the steps to insert the content reference.

7. Select the table cell ID from the Element Data list and click Insert. The content of the source table cell is inserted in the selected table cell.

Note: You cannot insert a content reference to a column in a table. If the column doesn’t have too many cells, you can insert content references to individual column cells instead.

DITA cross-references and links

About DITA cross-references

In DITA, an external cross-reference or an `<xref>` is to a website. When you import a DITA file, internal DITA cross-references are converted to FrameMaker XML Author cross-reference objects. When you export, the FrameMaker XML Author cross-reference objects are converted back to DITA cross-references. You can create a FrameMaker XML Author cross-reference to any element that a DITA `<xref>` element can reference from the DITA cross-reference panel.
DITA cross-reference panel
A. Check to reference content using keys (DITA 1.2 only option).  B. Name of key from keyspace (DITA 1.2 only option)  C. Click to access Key Reference dialog box (DITA 1.2 only option).  D. Check to reference a file using path.  E. List of elements to cross-reference.  F. Check to display all elements valid as per DTD.  G. List of DITA <xref> elements. It also lists the specialized <xref> elements.  H. Specify custom display formats.  I. List of Element Data for selected Element Tag.  J. Insert external cross-reference.  K. Insert an internal cross-reference.

You can also troubleshoot internal cross-references using the FrameMaker XML Author cross-reference pod.

Insert cross-references in a DITA file
If the cross-reference element is available in your document, you can define the destination and link text for internal and external <xref> elements.

Insert an internal cross-reference
1 Open the DITA topic or ditamap file in which to insert a cross-reference.
2 Place the insertion point at a valid point in the document.
3 Select Special > cross-reference.
4 From the Source File list, select the file to cross-reference.
5 From the Element Tags list, select the type of the source element, such as <concept>. The Element Data list displays a list of concept elements in the selected source file.
   Note: Select the Show All Elements option to view all element data in the Element Data list.
6 Select the element instance from the Element Data list.
In the Display Using Text field, type a description that is displayed in place of the text of the selected element. Alternatively, select a predefined format for the text from the Format menu.

Click Insert. The Update button is displayed if you are modifying an existing `<xref>` element.

*Note: If the Insert or the External Xref buttons are disabled, the cursor is at a point in the structure where an `<xref>` element is not valid. Look at the Structure View and the Element Catalog to ensure that the cursor is at a valid position before you insert a cross-reference.*

**Insert an external cross-reference**

1. Open the DITA topic or ditamap file in which to insert a cross-reference.
2. Place the insertion point at a valid point in the document.
3. From the Element Catalog, select Xref, and click Insert. The DITA cross-reference panel appears. Alternatively, select Special > cross-reference option.
4. In the Display Using Text field, type a description that is displayed in place of the text of the selected element. Alternatively, select a predefined format for the text from the Format menu.
5. Click External Xref. The DITA External Xref dialog box appears.
6. In the Xref Target (href) field, type the URL of the external website.
7. In the Xref Link Text field, you can type a description that is displayed in place of the actual URL. This step is optional.
8. Click OK. A cross-reference to an external website is created in your document.

*Note: You can edit an external reference by double-clicking it in the Document View.*

**Updating DITA references**

You can configure DITA to update the content of `<topicref>`, `<conref>`, or `<xref>` elements.

**Update DITA maps**

While working in DITA maps, you sometimes have to update one or more `<topicref>` elements, which also updates the DITA maps.

The Update Selected Topicref option is available only when you’ve selected either a `<topicref>` or a DITA map in the resource manager. The Update All Topicrefs In File option is available only when your insertion point is not in a `<topicref>` element. In addition, the Update All Topicrefs In File option honors the setting of the `<locktitle>` attribute. If it is set to Yes, the `<navtitle>` attribute of the `<topicref>` element is not updated.

You can also select the Update All Conrefs In File and Update All Xrefs In File options to update both internal as well as external cross-references.

1. Select DITA > Update References.
2. Do one of the following:
   - If a `<topicref>` element is selected, click the Update Selected Topicref option. DITA updates the content of the selected `<topicref>` element.
   - If a `<topicref>` element is not selected, click the Update All TopicRefs In File option. DITA updates all `<topicref>` elements in the current file to reflect any changes to titles in referenced files.
3. Click OK.
Updating DITA topics
While working in DITA topics, you sometimes have to update all <conref> or <xref> elements.

1 Select DITA > Update References.

2 Do one of the following:
   - Select the Update All Conrefs In File option. DITA updates all <conref> elements in the current file to reflect any changes to the source content.
   - Select the Update All Xrefs In File option. DITA updates all <xref> elements in the current file to reflect any changes to titles in referenced files.

3 Click OK.

About DITA links
The <related-links> is a container element that has a set of <link> elements. A <link> element contains the <linktext> element which is the literal line of text for a link. When importing a DITA file in FrameMaker XML Author, these <linktext> elements are converted to <fm-linktext> which is a FrameMaker XML Author cross-reference object.
You can insert links to:

- DITA topics in the same file or a different file. These links are called internal links. They are represented as a FrameMaker XML Author cross-reference object.

- An external web page, and local or remote files, by providing a URL. These links are called external links. A hypertext marker is used to represent an external DITA link to a URL.

### Insert an internal link

1. Open the DITA topic or ditamap file in which to insert a DITA link.
2. Place the insertion point at a valid point in the document.
3. Insert the `<related-links>` element from the Element Catalog.
4. Double-click the `<link>` element and select the source file.
5. From the Element Tags list, select the type of the source element, such as `<concept>`. The Element Data list displays a list of concept elements in the selected source file.

   **Note:** Select the Show All Elements option to view all element data in the Element Data list.
6. Select the element instance from the Element Data list.
7. In the Display Using Text field, type a description that is displayed in place of the text of the selected element. Alternatively, select a predefined format for the text from the Format menu.
8. Click Insert. The Update button is displayed if you are modifying an existing `<link>` element.

   **Note:** If the Insert or the External Link buttons are disabled, the cursor is at a point in the structure where a `<link>` element is not valid. Look at the Structure View and the Element Catalog to ensure that the cursor is at a valid position before you insert the link.

### Insert an external link

1. Open the DITA topic or ditamap file in which to insert an external link.
2. Place the insertion point at a valid point in the document.
3. Insert the `<related-links>` element from the Element Catalog.
4. Double-click the `<link>` element and click the External Link button in the DITA Link panel.
5 In the Link Target (href) field, type the URL of the external website.
6 In the Link Text field, you can type a description that is displayed in place of the actual URL. This step is optional.
7 Click OK. A link to an external website is created in your document.

Note: You can edit an external reference by double-clicking it in the Document View.

Find References

You can search through a document or recursively through multiple files in a folder for links such as conref, topicref, link, or xref. By default, the Find References dialog box populates the ID of the current topic and element, if any is selected. Typically, you select the element which is referenced elsewhere, and then call this option.

1 Select DITA > Find References. Or, to find the reference of the current element, right-click within the element, and select Find References. The element ID is populated automatically.
2 On the Find References box, enter the ID of the element, if necessary.
3 Optionally, to limit the search within a keyspace, select the keyspace for the current document.
4 Set the search scope. If you select a folder, you can recursively search for references to the element in all the files in the folder.
5 Click Search.

Assign IDs to elements

You can assign IDs to one or all instances of an element in one go across a framemaker file, topicrefs in a ditamap, or in all open files. You can also assign IDs to the instances of the specialization of the selected element.

Assign ID to an element

1 In a FrameMaker XML Author file, select an instance of the element for which you want to assign IDs.
2 Select DITA > Assign ID to Element.
Assign IDs to all instances of an element

1. In a FrameMaker XML Author file, select an instance of the element for which you want to assign IDs.
2. Select DITA > Assign ID to Elements.
   a. If necessary, select the element name in the drop-down. By default, the element selected before selecting Assign ID to Elements is selected in the drop-down.
   b. Select Include specialization to assign IDs to specializations of the selected element. If you are in a DITAMAP, select Process Topicrefs in Ditamap to assign IDs to all instances of the selected element in the topics in the ditamap.
   c. If you have multiple files open, select All Open Files to assign IDs to all the instances of the selected element in all the open files.
   d. Select Assign.

Conditional processing

Using a conditional processing profile, you can filter information based on specific criteria at processing time. Most DITA elements have the following attributes for conditional processing:

- **Product** The product to which the content applies.
- **Platform** The platform on which the product is deployed, such as Windows, UNIX, or Linux.
- **Audience** The intended audience for the content.
- **Rev** The revision number of the content. You can only flag revisions, not exclude them.
- **Otherprops** Any other property.

These attributes allow you to control the inclusion of specific elements based on the attribute values and the conditions specified in a processing file.

**Note:** DITA also provides you the option of flagging elements. FrameMaker XML Author does not support flagging of DITA elements. You can only use the filtering operation of DITA conditional processing in FrameMaker XML Author.

Invalid entries in a ditaval file

- A condition with action different from the standard values, such as ‘include’, ‘exclude’, ‘passthrough’, and ‘flag’ is ignored.
- A condition statement that contains spaces of any kind, such as tab, newline for attribute name, values, or action is ignored. A warning message is displayed on the console.
- A condition with the action specified as ‘flag’ is not processed and does not affect the generated output. A warning message is displayed on the console.
- A condition in the ditaval file that has a missing or blank attribute name is ignored and does not affect the generated output. A warning message is displayed on the console.
- In a ditaval file, you can define only one occurrence of a ‘prop’ element with no ‘att’ attribute specification, including empty value or an all spaces value. If more than one condition statement exists the first valid occurrence is processed and the others ignored.
In a ditaval file, you can define only one occurrence of a 'prop' element with no 'val' value specification. If more than one condition statement for the same attribute exists, the first valid occurrence is processed and the others ignored. A warning message is displayed on the console to notify that a condition has been ignored.

<table>
<thead>
<tr>
<th>Conditions in the ditaval file</th>
<th>Processing time</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;val&gt;</td>
<td>NA</td>
</tr>
<tr>
<td>&lt;prop/&gt;</td>
<td>Ignored. Invalid condition.</td>
</tr>
<tr>
<td>&lt;prop action=&quot;&quot; /&gt;</td>
<td>Ignored. Invalid because the action value is blank.</td>
</tr>
<tr>
<td>&lt;prop action=&quot;include&quot; /&gt;</td>
<td>Valid. Processed correctly.</td>
</tr>
<tr>
<td>&lt;prop action=&quot;filter&quot; /&gt;</td>
<td>Ignored. Invalid action value, filter.</td>
</tr>
<tr>
<td>&lt;prop action=&quot;exclude&quot; /&gt;</td>
<td>Ignored. Repeated condition. First occurrence is processed.</td>
</tr>
<tr>
<td>&lt;prop action=&quot;passthrough&quot; /&gt;</td>
<td>Ignored. Repeated condition. First occurrence is processed.</td>
</tr>
</tbody>
</table>

Similarly, you can define only one occurrence of a 'prop' element with specific 'att' attribute and 'val' value pairs. If more than one condition statement exists, the first valid occurrence is processed and the others ignored. A warning message is displayed on the console to notify that a condition has been ignored.

<table>
<thead>
<tr>
<th>Conditions in the ditaval file</th>
<th>Processing time</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;val&gt;</td>
<td>NA</td>
</tr>
<tr>
<td>&lt;prop att=&quot;audience&quot; /&gt;</td>
<td>Ignored. Invalid condition. Action is not specified.</td>
</tr>
<tr>
<td>&lt;prop att=&quot;audience&quot; action=&quot;&quot; /&gt;</td>
<td>Ignored. Invalid because the action value is blank.</td>
</tr>
<tr>
<td>&lt;prop att=&quot;audience&quot; action=&quot;exclude&quot; /&gt;</td>
<td>Valid. Processed correctly.</td>
</tr>
<tr>
<td>&lt;prop att=&quot;audience&quot; action=&quot;filter&quot; /&gt;</td>
<td>Ignored. Invalid action value, filter.</td>
</tr>
<tr>
<td>&lt;prop att=&quot;audience&quot; action=&quot;include&quot; /&gt;</td>
<td>Ignored. Repeated condition. First occurrence is processed.</td>
</tr>
<tr>
<td>&lt;prop att=&quot;audience&quot; action=&quot;flag&quot; /&gt;</td>
<td>Ignored. Repeated condition. First occurrence is processed.</td>
</tr>
<tr>
<td>&lt;prop att=&quot;audience&quot; val=&quot;student&quot; /&gt;</td>
<td>Valid. But 'flag' is not processed by FrameMaker XML Author.</td>
</tr>
<tr>
<td>&lt;prop att=&quot;audience&quot; val=&quot;student&quot; action=&quot;&quot; /&gt;</td>
<td>Ignored. Invalid because the action value is blank.</td>
</tr>
<tr>
<td>&lt;prop att=&quot;audience&quot; val=&quot;student&quot; action=&quot;flag&quot; /&gt;</td>
<td>Ignored. Invalid action value, filter.</td>
</tr>
<tr>
<td>&lt;prop att=&quot;audience&quot; val=&quot;student&quot; action=&quot;include&quot; /&gt;</td>
<td>Ignored. Repeated condition. First occurrence is processed.</td>
</tr>
<tr>
<td>&lt;prop att=&quot;audience&quot; val=&quot;student&quot; action=&quot;exclude&quot; /&gt;</td>
<td>Ignored. Repeated condition. First occurrence is processed.</td>
</tr>
</tbody>
</table>
Specifying the ditaval file
You can specify a .ditaval file when saving a .ditamap in the following cases:

- Saving as Adobe PDF
- Saving as FrameMaker XML Author Book with FrameMaker XML Author components
- Saving as a Composite Document
- Publishing the current document (When used as part of Adobe Technical Communication Suite only)
- From FrameMaker Publishing Server, publishing to multiple channels

1. Select the .ditamap and choose File > Save As PDF.
2. Select the Prompt For Ditaval File check box and click Save.
3. Browse and select the .ditaval file and click Choose.
4. Click Set to create the PDF file.

Based on the conditions specified in the ditaval file, the output PDF file contains the appropriate content from the ditamap and XML files.

For Print Output, you can enable ditaval filtering feature by specifying ’PromptForDitaval =1’ in the ditafm.ini file. When you enable this option, a dialog box, Choose DitaVal File, appears each time you print a ditamap.

Note: Use caution while editing an ini file.

Note: You can access the ditafm.ini file from the <installation_directory>/Adobe/AdobeFrameMakerXMLAuthor12/fminit/ directory.

Using DITA Open Toolkit to Publish DITA content

You can invoke DITA open toolkit in FrameMaker XML Author to publish your DITA content. FrameMaker XML Author has out-of-the-box support for DITA Open Toolkit 1.8. DITA OT transforms DITA content (maps and topics) into deliverable formats. You can use DITA Open Tookit to generate PDF2 and other outputs from DITA content.

The DITA Open Toolkit (DITA OT) is:

- An open-source publishing system for publishing DITA
- An implementation of the OASIS DITA Technical Committee’s specification for DITA
- A set of Java-based software tools, originally developed by IBM

FrameMaker XML Author has out of the box support for publishing of three outputs:

1. PDF2
2. XHTML
3. CHM (Install HTML Help Workshop to generate CHM)

To generate the following outputs using FrameMaker XML Author through DITA-OT, configure FrameMaker XML Author by editing the DITA initialization file:

- Docbook
- eclipsecontent
- eclipsehelp
Set up Java and HTML Help workshop

To work with DITA OT, install and configure the following on your computer:

- Java runtime environment (JRE) (and also set up the JAVA_HOME environment variable accordingly). For more information, see To Install the JDK Software and Set JAVA_HOME on a Windows System.
- HTML Help Workshop (only if you want to generate CHM using DITA OT)

Generate output using DITA OT

After you have set up JRE and JAVA_HOME variable on your computer, you can generate output from DITA content. To generate CHM, download and install HTML Help workshop too. For more information, see “Set up Java and HTML Help workshop” on page 346.

1 With the appropriate DITA file in focus, select DITA > Generate DITA OT Output.
   The Generate DITA-OT dialog is displayed.

2 Select an output type.

3 By default, the DITA-OT is installed when you install FrameMaker. However, if you have separately installed the toolkit, you can specify the install location in the DITA-OT Directory field. The change to the field is only applicable for the current output. The next time you open the Generate DITA-OT Output dialog, the directory is reset to the FrameMaker default. To change the default directory, see Use a different DITA-OT package.

4 Choose a DitaVal file to specify conditional filtering of content using attribute-value pairs defined in the DitaVal file.
   If you plan to use the same DitaVal file when generating out for multiple documents, you can specify the file name and location in the ditafile.ini. In this case, you do not need to choose a DitaVal file every time you generate the output.
   
   **Note:** If you specify a DitaVal file in both locations (ditafile.ini and Generate DITA-OT dialog), the file chosen in the Generate DITA-OT take precedence.

5 Click Build.
Add new targets in FrameMaker XML Author’s DITA OT

In addition to the three out-of-the-box supported targets, you can add more targets to FrameMaker XML Author’s DITA OT.

To add the new targets, edit the DITA initialization file. The DITA initialization file (ditafm.ini) is at the following path: fminit\ditafm\ditafm.ini.

**Note:** Take a backup of the DITA initialization file before changing anything.

1. Open the DITAFM.ini file. (At fminit\ditafm\ditafm.ini)
2. Locate the following text in the file:
   
   ```
   Count=3
   DitaDir=%FMHOME%minit\ditafm\DITA-OT
   1=xhtml
   2=htmlhelp
   3=pdf2
   ```

3. Modify the value of Count and add more options to the list of outputs, such as the following:

   ```
   Count=5
   DitaDir=%FMHOME%minit\ditafm\DITA-OT
   1=xhtml
   2=htmlhelp
   3=pdf2
   4=eclipsehelp
   5=wordrtf
   ```

   **Note:** You can add the following output types: docbook, eclipsecontent, eclipsehelp, htmlhelp, JavaHelp, net.sourceforge.dita-ot.html, odt, pdf, pdf2, tocjs, troff, wordrtf, and xhtml.

4. Restart FrameMaker XML Author.

Now you can generate these two new output types using the DITA Generate Output dialog.

Customize DITA-OT

FrameMaker XML Author has integrated DITA Open Toolkit 1.8. If you already have a different version of DITA Open Toolkit installed or want to use a different version, you can customize the DITA Open Tookit path by editing the dita initialization file. For a one-time change, you can specify a DITA Open Tookit path while generating output.

To use a different version of DITA OT, do the following:

1. Download a different version of DITA OT to your system and unzip it.
2. Open the DITAFM.ini file. (At fminit\ditafm\ditafm.ini)
3. Locate the following text in the file:
   
   ```
   DitaDir=%FMHOME%minit\ditafm\DITA-OT
   ```

4. Modify the value of DitaDir to point to your unzipped folder of DITA OT. For example, c:\DITA-OT1.7.5_standard_bin.

5. Restart FrameMaker XML Author.

Now the new DITA OT path is populated in the DITA Generate Output dialog. You can select DITA > Generate DITA OT Output to verify.
Chapter 14: Working with Content Management Systems

When working with document, you often find the need to maintain versions of document. This is helpful to manage content, compare changes across document versions. Also, maintaining versions is relevant and imperative in a collaborative authoring environment. In a collaborative environment, more than one writer can be working on the same document. Often even on same parts of one document. To allow you to work in this type of an environment, FrameMaker XML Author ships with connectors to the following content management systems (CMS):

“Adobe Experience Manager (AEM)” on page 348
“Documentum, SharePoint, DITAExchange” on page 355

Adobe Experience Manager (AEM)

Built atop the industry-leading JSR-283-compliant CRX content repository, Adobe Experience Manager (AEM and formerly CQ) provides a complete suite of applications for the Web Experience Management (WEM) of organisations. FrameMaker XML Author ships with an out-of-the-box connector to AEM. FrameMaker XML Author also provides you with an easy-to-use interface that allows you to maintain versions of your documents in a distributed and collaborative environment.

Set up the AEM connector

AEM is a Web content management system that allows you to store digital assets in its DAM (digital asset management) repository. The AEM connector allows you to manage your FrameMaker XML Author documents using the DAM.

Note: You can choose to store your documents in any AEM folder. However, if you use the AEM DAM, you will be able to take advantage of DAM features such as metadata and renditions.

To set up the AEM connector:

1 In FrameMaker XML Author, from the CMS menu, choose Connection Manager.
2 In the Choose Connection drop-down, choose Adobe Experience Manager.
3 In the Connection Details section, enter the following details:
   - **Name** A friendly name for your FM - AEM connection.
   - **Server** Name of the AEM server:
     ```
     http://<server name>:<port number>/crx/server
     ```
   - **User name and password** User name and password.
   - **Workspace** AEM workspace.
     Default workspace: crx.default.
   - You are recommended to create a folder with the DAM workspace. However, you can create a folder at any location in the repository.
4 Click Connect to set up the FM - AEM connector.

The AEM connector displays in the Repository Manager.

Create a CRX folder and upload files
You have the option of adding files at any level of the content folder hierarchy. However, to take advantage of the AEM DAM functionality, you are recommended to create folder within the dam folder. After you have created a folder, you can then upload files and folder to the repository.

1 To create a sub folder within the dam folder, right-click on the dam folder and choose New Folder.

2 Enter the new folder name and click OK.

Before, you can start working with files in the repository, you need to first upload the files.

You can choose to upload a file or upload a folder. If you upload a folder, all the sub-folders and files within the selected folder are uploaded.

3 To upload a file or folder, right-click on the folder into which you want to upload, point to Upload and choose one of the following:
   - **File**: Upload a single file without its dependencies
   - **File With Dependencies**: Upload a single file with the following dependencies:
     - Text Insets
     - Cross references
     - Graphics
   - **Folder**: Upload a folder and its contents

4 Choose the file or folder to upload and click Select.

The file or folder is uploaded to the folder in the AEM repository.

Note: When you upload an asset (file/folder) already present in DAM, FrameMaker XML Author creates a minor version of the asset. This happens only if the present asset in DAM is not locked by a user.

Other operations on the folder
Besides creating folder, uploading files / folders to a folder in the AEM repository, you can also perform the following operations at a folder level:

- **Cut, Copy, Paste**: You can perform these operations to move or replicate folders in your repository.
- **Delete**: Delete a folder and its contents.
- **Show Checkout Files**: Display the list of checked out file in the folder
- **Properties**: Display properties of the folder
- **Refresh**: Refresh the contents of the folder

Working with files
After you upload a file to the repository, you can perform CMS file operations on the file such as check-out, open read-only, and check-in.
Check out a file
When working with files, you can choose to only check out a file or check out and open the file in FrameMaker XML Author.

You check out a file and work on it later. Or you check out a file and open the file in another application. For example, you check out an XML file and choose to open it in an XML editor.

Also, when you check out a file, you also need to choose if you want to check out the selected file or you want to check out the file and its dependencies.

To check out a file:
1. Right-click on a file and point to one of the following:
   - **Checkout and Edit**: Check out the file and open the file in FrameMaker XML Author
   - **Checkout**: Check out the file
2. In the submenu, choose one of the following:
   - **File**: Check out the selected file but not its dependencies
   - **File With Dependencies**: Check out the selected file with its dependencies

   If you choose to check out the file with its dependencies, you are prompted to select from the list of dependencies:
   - Text Insets
   - Cross references
   - Graphics

   When you check out a file, notice the check indicator against the file icon in the Repository Manager.

Check in a file
After you are done with making changes to a checked out file, check the file back into the repository. Check in allows other users to now work with the updated file.

To check in a file:
1. Right-click on a file and point to CheckIn.
2. In the submenu, choose one of the following:
   - **File**: Check in the selected file but not its dependencies
   - **File With Dependencies**: Check in the selected file with its dependencies

   If you choose to check in the file with its dependencies, you are prompted to select from the list of dependencies:
   - Text Insets
   - Cross references
   - Graphics

3. In the Check-in dialog, you can, optionally, set a version label for the check in.

   When you later view the version list of this file, you can use this label as an indicator of the version that you checked in. For example, you might choose to use a specific label for files checked in at the end of a project milestone.

Cancel Check-out of a file
After making changes to a checked out file, you can choose to not check these changes back into the repository. However, you want to release the file for other users to check out. In this case, you can choose to cancel the file check-out.
To cancel the file check out:

1. Right-click on a file and point to Cancel Checkout.
2. In the submenu, choose one of the following:
   - **File**: Cancel checkout the selected file but not its dependencies
   - **File With Dependencies**: Cancel checkout the selected file with its dependencies

   If you choose to cancel the file checkout with its dependencies, you are prompted to select from the list of dependencies:
   - Text Insets
   - Cross references
   - Graphics

The file check out is canceled and other users can now check out this file.

**Other operations on a file**

Besides for the operations described above, you can perform the following operations files in the AEM repository:

- **Cut, Copy, Paste**: You can perform these operations to move or replicate files in your repository.
- **Show Metadata**: Display the metadata associated with the file. You can also associate XMP metadata with a FrameMaker XML Author file, for details see “Associate XMP Metadata” on page 353.
- **Open (Read Only)**: Open the file in the read-only mode without checking out the file.
- **Edit**: If the file is checked out but not open, open the file for updates
- **Delete**: If the file is not checked out, delete the file from the repository
- **Show Dependents**: Display the list of dependent file, if any
- **Show Versions**: Display the list of versions
- **Properties**: Display the list of file properties such as created date, created by, server path
- **Refresh**: Refresh the current state of the file. For example, you view the file as checked out by another user. The user then checks the file in. Refresh the state of the file after the other user checked the file in.

**Searching in the AEM repository**

The AEM search functionality allows you to search for files in the selected AEM folder. The functionality includes:

- “Repository Search (Simple Search)” on page 351
- “Advanced Search” on page 352

**Repository Search (Simple Search)**

To search for a file in the repository:

1. Select a folder in which to search.
2. Enter the search string in the Enter Search String in the Repository Manager and click Search Repository.

   The Search Result dialog displays the filename, server path, version, and date created for each file returned in the search results.
Right-click a file to perform the required operation on the file. For operations that you can perform on a file, see “Working with files” on page 349.

Advanced Search

Advanced search allows users to perform a search based on criteria like name, path, modified date, file type and tags. Such functionality is useful when you have a large number and variety of files in your repository.

To perform an advanced search for files in the AEM repository:

1. Click the Advanced Search button on the Repository Manager.

   ![AEM Advanced Search dialog](image)

   **Important**: None of the search fields in the Advanced Search dialog are mandatory. Also, if you specify a search filter for more than one field, the search uses the **AND** criteria to perform the search.

2. In the Full Text box, enter the search string.

3. The Path box displays the name of the currently selected folder. Use the Browse button to choose an alternative AEM folder to search.

4. Click the Modified checkbox to enable the From and To fields.

   Use the Calendar controls in these fields to specify the file modified date range to search.
5 Click the File Types checkbox to enable the file type fields.
You can choose to include (check) or exclude (uncheck) the file type from the search.

- FrameMaker XML Author Files
- Images
- Multimedia
- Documents

For each of the above file type groups, click the Browser button and choose the file types to include or exclude. For example, from the FrameMaker XML Author Files list, you can choose to include or exclude FrameMaker XML Author Documents, FrameMaker XML Author MIF, and XML.

You can also enter a file type not defined above in the Other Types box.

To define other file types, you will need to specify the mime type of the file. Also, you can specify multiple file types separated by comma.

6 Click the Tags checkbox to enable the metatag fields.
You can choose to include (check) or exclude (uncheck) the metatag from the search.

- Business
- Industry
- Lifestyle
- Nature
- Illustrations/Vectors

For each of the above metatag groups, click the Browser button and choose the metatag to include or exclude. For example, from the Business tag group, you can choose to include or exclude business-related metatags such as Business Abstract, Business Backgrounds, Business Concept.

You can also enter a metatag not defined above in the Other Tags box.

To define multiple metatags, you can specify the metatags separated by comma.

7 After you have filtered the search, click the Search button.

The Search Result dialog displays the file name, server path, version, and date created for each file returned in the search results.

8 Right-click a file to perform the required operation on the file. For operations that you can perform on a file see, “Working with files” on page 349.

**Associate XMP Metadata**

FrameMaker XML Author provides you support for editing and updating AEM metadata of DAM FrameMaker XML Author assets, which simplifies file and version management. XMP metadata is platform independent and you can customize it to meet your CMS needs. For more information about XMP metadata, see Extensible Metadata Platform (XMP).

Both FrameMaker XML Author and AEM support XMP. When you upload a FrameMaker XML Author file (.xml, .ditamap, or .book) to the AEM repository using DAM, the FrameMaker XML Author file information (File -> File Info...) is added to the AEM metadata of the file.
If you right-click and choose Show Metadata on a file in the AEM repository, you can view the XMP metadata associated with the file.

### Manage AEM preferences

You can manage the FrameMaker AEM connector preferences using the CQPreference.xml (located in the FrameMaker XML Author install directory).

To update the preferences, open the xml file in an XML or text editor and make change to the following properties, as needed:

<table>
<thead>
<tr>
<th>Preference</th>
<th>Values</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>ShowOnlyDam</td>
<td><strong>true</strong> displays only the DAM related folders/assets for which you have read permissions in Repository Manager. <strong>false</strong> displays all the folders in Repository Manager. For example, if this field is set to true, and folders is set to &quot;content/apps&quot; FrameMaker XML Author displays only two folders in the content repository: content and apps. If this field is set to true and folders is set to &quot;content/dam&quot; the content repository displays content as top level folder and dam as a sub-folder.</td>
<td><strong>true</strong></td>
</tr>
<tr>
<td>SetUserArea folders</td>
<td>Specify the AEM application folder where all the FrameMaker XML Author files are downloaded from AEM to the local disk. This field is blank by default. When you do not edit this field and keep it blank, the default folder is: <code>%APPDATA%\Adobe\FrameMaker\CQ</code></td>
<td></td>
</tr>
<tr>
<td>SuppressAlert</td>
<td><strong>true</strong> suppresses the alert messages, such as missing dependent file alerts while uploading/checkin/checkout files, and displays the message content in the FM console window file. <strong>false</strong> does not suppress the alert messages.</td>
<td><strong>false</strong></td>
</tr>
<tr>
<td>FileNameRestrictions</td>
<td><strong>anychar=&quot;true&quot;</strong> allows all the characters and special characters in the filenames in the repository. <strong>anychar=&quot;false&quot;</strong> lets you specify the allowed characters in the repository filenames using AlphaNumeric and OtherCharsSpecialChars values. <strong>Note:</strong> By default, Unicode is not supported in filenames. To enable Unicode characters in new folder and filenames, switch off the restrictions. (set FileNameRestrictions anychar = true).</td>
<td><strong>false</strong></td>
</tr>
<tr>
<td>AlphaNumeric</td>
<td><strong>true</strong> allows alphanumerics characters in filenames.. This preference is relevant only when FileNameRestrictions anychar is set to false.</td>
<td><strong>true</strong></td>
</tr>
</tbody>
</table>
To effect these changes, you need to restart the CMS session.

Documentum, SharePoint, DITAExchange

FrameMaker XML Author provides connectors that enable integration with the following content management systems (CMS):

- EMC Documentum® 6.5 SP1, SP2, and SP3 and Documentum® 6.7
- Microsoft® SharePoint Server 2007 SP 2 and Microsoft® SharePoint Server 2010

Once configured, FrameMaker XML Author allows you to perform search, read, write, delete, update, check in, and check out operations on the configured CMS repository.

Configure the connectors

To set up the connectors, complete the following tasks:

<table>
<thead>
<tr>
<th>Preference</th>
<th>Values</th>
<th>Default</th>
</tr>
</thead>
</table>
| SpecialChars values         | List the other characters that are allowed. For example, to allow "-" and ":" in the repository filenames set the value if this field to: "-:"
|                             | This preference is relevant only when FileNameRestrictions anychar is set to false. | none    |
| ShowProgressBar value       | true shows a progress bar for indicating the progress of operations, such as check in, check out, download. false does not display the progress bar. | false   |
| AddHiddenDependencies value | true uploads dependencies, such as cross-references, text inset, graphics, hidden through conditional text or filter attribute while uploading a file. false ignores all hidden dependencies while uploading a file | false   |
| ManageReferences value      | true allows you to customize reference handling with menu and UI options false maintains existing behavior | true    |
| AutoRefreshParent value     | true refreshes the parent node (file or folder) in the Repository Manager after each operation, such as check out. false does not refresh the parent node automatically. Set it to false, if better performance is required. | true    |
Set default file versioning (Documentum, SharePoint, and DITAExchange)
You can specify the versioning scheme to be applied when you use FrameMaker XML Author to upload a document that exists in a Documentum, SharePoint, or DITAExchange repository. The document is overwritten and the specified file versioning settings are applied to the document.

1. In FrameMaker XML Author, Click Edit > Preferences.
2. In CMS, ensure that Overwrite existing object and save as is selected.
3. Select the versioning option per your requirement. You can choose to have the same (Documentum only), next major, or next minor version for the uploaded document.
4. Click OK.

Set the Repository Manager view (Documentum® only)
1. In FrameMaker XML Author, Click Edit > Preferences.
2. In CMS > Documentum®, select Show Hidden Objects to view the hidden files (contained in a repository) in the Repository Manager window.
3. Select Show Private Cabinets to view the private cabinets (contained in a repository) in the Repository Manager window.
4. Click OK.

Download the Powerlink SDK (Documentum® only)
Download the Documentum® Foundational Services SDK from the EMC website.

Note: You need an EMC powerlink login to download the SDK.

Specify the DFS SDK path (Documentum® only)
1. In FrameMaker XML Author, Click Edit > Preferences.
2. In CMS > Documentum*, click Browse.
3. In the Browse For Folder window, navigate to the SDK (e.g. emc-dfs-sdk-6.5) folder.
4. Click OK in the Browse For Folder window.
5. Click OK in the CMS Preferences window.
   A message box prompts you to restart FrameMaker XML Author.

Add the FrameMaker XML Author types and formats on the Server (Documentum® only)
You can add the FrameMaker XML Author types and formats on the Content server using a .dar file.

Add the FrameMaker XML Author types on the Server using the .dar file
To add the FrameMaker XML Author types on the Content server, you need Administrator or Create Type privilege.

❖ Download the .dar file from the following location and use it to add the FrameMaker XML Author types on the Server:
Set up sample Adobe FrameMaker XML Author DITA Applications for EMC Documentum® Server (Documentum® only)

A FrameMaker XML Author sample application pack is available at www.adobe.com/go/learn_fm_sample_dita_app_pack_en. The application pack includes an indicative set of applications to help content administrators configure FrameMaker XML Author to author files on Documentum® server. Download and install the sample application pack to avoid the warnings and XML parser logs when you work with XML files from Documentum® server.

Connect to the content management system

1. In FrameMaker XML Author, select CMS > Connection Manager.
2. Choose the connection type — Documentum, Sharepoint, or DITAExchange.
3. Specify the connection details, such as server name, user name, and password to connect to your CMS. Also, specify a unique name for the connection.

   Note: The value in the Name field uniquely identifies each connection. All connections are added to the favorites list. The list can store a maximum of sixteen favorites. If you try to store the seventeenth connection, the first connection on the list is removed to accommodate it. The connection list works in a first in, first out manner.

   Note: To delete a listed connection, select it from the list and click Remove.
4. (Documentum® only) Specify the name of the Documentum® repository to which FrameMaker XML Author will connect using this connection.
5. Click Connect.

   The Repository Manager lists the contents of the selected server.

Use the Repository Manager

Select CMS > Open Repository to view the Repository Manager window. Use the Repository Manager to:

- Switch between repositories
- Browse files within a repository
- Manage resources
Upload files and folders

Using FrameMaker XML Author, you can upload files and folders to a Documentum, SharePoint, or DITAExchange server.

Upload files

You can upload XML, DITA, FM, MIF, and book files.

The DITAExchange connector, supports two custom document libraries: Map and Topic.

**Note:** If you are using Documentum or SharePoint, ensure that the required applications are configured on the CMS server to upload DITA and XML files. If DITA applications are not available on your CMS, contact your Administrator.

1. Select the server from the Repository Manager window.
   - You can choose to upload an open (step 2) or closed (step 3) file.

2. Upload an open file.
   - **a** Switch between the open documents to select the document to upload.
   - **b** Select CMS > Upload Active Document.
     - The Select CMS Item window is displayed.
   - **c** Specify the upload location.
     - **Note:** Save the file before uploading. If the file is not saved, the dependencies list may not be correctly updated.
d Click OK.
   The selected document and its direct dependencies are uploaded. A message is displayed when the file is successfully uploaded.

e Click OK.

3 Upload a closed file.
   a Perform one of the following:
      • Right-click a list or folder for SharePoint or DITAExchange.
      • Right-click a cabinet or folder for Documentum®.

   b Select Upload Document.
      The Select the file to upload window displays.

   c Specify the file to upload.

   d Click Select.
      The selected file and its direct dependencies are uploaded. A message is displayed when the file is successfully uploaded.

   e Click OK.

Note: The uploaded file remains on the disk and a copy of it is uploaded to the server. To work on the file again, first check out the file from the server.

Upload folders
1 Select the server from the Repository Manager window.

2 Perform one of the following:
   • Right-click a cabinet or folder for Documentum®.
   • Right-click a list or folder for SharePoint or DITAExchange.

3 Select Upload Folder.
   The Browse For Folder window displays.

4 Navigate and select the folder to upload.

5 Click OK.
   The selected folder and all its dependencies are uploaded. A message is displayed when the directory is successfully uploaded.

6 Click OK.

Manage resources
Using FrameMaker XML Author, you can manage the resources, such as cabinets (Documentum®), folders, and files, of your configured Documentum, SharePoint, or DITAExchange server.

Manage cabinets (Documentum® only), folders, and files
You can perform the following operations on your CMS resources.

Add a cabinet Right-click the root node of the Documentum® server and select New Cabinet.

Delete a resource Right-click a cabinet (Documentum® only), folder, or file and select Delete.
When deleting a file in Sharepoint or DITAExchange, a dialog prompts you to keep just the current version of the file and delete all other versions, or to delete all the versions of the file.

![Sharepoint deletion dialog](image)

When deleting a file in Documentum®, a dialog prompts you to delete just the file, all versions of the file, or the file and all its dependencies.

![Documentum® deletion dialog](image)

**Upload a file**  Right-click a cabinet, list, or folder and select Upload Document. FrameMaker XML Author uploads the file and all its dependencies, if any.

**Upload a folder**  Right-click a cabinet, list, or folder and select Upload Folder.

**Add a folder**  Right-click a cabinet, list, or folder select New Folder.

**Show checked out files**  Right-click a cabinet, site, list, or folder and select Show Checkout Files.

**View attributes**  Right-click a cabinet, site, list, or folder and select Properties. The attributes panel is displayed as follows:
View attributes dialog

The dialog allows you to modify the value of an attribute. To modify a value, click the value of the desired attribute and modify it.

Click OK to save the modified value.

**Refresh the view**  Right-click a cabinet, site, list, folder, or the root node and select Refresh.

**Check out files**
1  In the Repository Manager dialog, select the repository.
2  Right-click the file and do one of the following:
   • Select Checkout and Edit to check out and open the file.
   • Select Checkout to check out the file.
Checkout dialog

3. Specify whether to check out all dependent files.
4. Click OK.

DitaExchange server maintains the http references in Dita files as the full http path. This connector has special handling to support http paths for dependencies when you check-out a file. If you check-out a DITA Topic file that contains an image with an href reference that is pointing to HTTP path, the referenced image will also be checked out.

Also, if you cancel the check-out of a DITA Topic file that contains an image with an href reference that is pointing to HTTP path, the check-out on the referenced image will also be canceled.

**Check in files**
1. In the Repository Manager dialog, select the repository.
2. Right-click the file and select Checkin.
3. Specify the version details.
4. Click OK.

*Note:* Select Cancel Checkout to undo the checkout and discard changes made to the file. For Sharepoint or DITAExchange, check out of all dependent files will also be automatically canceled.

*Note:* Save the file before checking in to ensure that all the changes are uploaded correctly. If a file is checked out with its dependents, then all dependent files will also be automatically checked in.

**Manage files**
Using FrameMaker XML Author you can manage XML, DITA, FM, MIF, and book files. In addition to checking out and checking in files, you can perform the following tasks:

- **Open a file** Right-click and select Open (read only) to view the file in read-only mode. If the file is not checked out, double-clicking or pressing Enter on the file, opens the file in read-only mode, and also downloads all the dependents of the file.
Note: DitaExchange server maintains the http references in Dita files as the full http path. This connector has special handling to support http paths for dependencies when you open a file in read-only mode. If you open a DITA Topic file that contains an image with an href reference that is pointing to HTTP path, the referenced image is also opened in read-only mode.

Delete a file  Right-click, select Delete. Select Delete all versions to delete all versions of the file.

View various versions  Right-click and select Show Versions.

View dependencies  Right-click and select Show Dependents.

Note: View dependencies is only valid for virtual documents in the case of Documentum®.

View properties  Right-click and select Properties.

Refresh the view  Right-click and select Refresh.

Search files
FrameMaker XML Author allows you to perform basic and advanced search in the configured Documentum, Sharepoint, and DITAExchange repositories.

Basic Search (Documentum, Sharepoint, and DITAExchange)
Basic search searches on the name of the file. To perform a basic search:

1  In the Repository Manager, select the repository.
2  Enter the search term in the search field and click the search icon.

The results are displayed in the search results window.

Note: Basic search searches the selected item in the repository. If the selected item is a top-level container, then all files and subcontainers within the main container are searched.
Advanced search (Sharepoint or DITAExchange)

To perform an advanced search on a Sharepoint or DITAExchange repository:

1. In the Repository Manager, select the repository.

2. Click the advanced search icon. The advanced search window is displayed as follows:

3. Enter the search term in the search pane.

4. The condition builder allows you to perform complex searches by combining two or more search criteria.
   a. Build a criteria by selecting the property (for example, Created By), the relevant condition (for example, =), and specify a value (for example, Jones). Click Add.
   b. Build another criteria by selecting the operator (AND or OR), the property (for example, File Type), the desired condition (for example, =), and specify a value (for example PDF).
Click Search.

Search results are displayed based on the specified search criteria. In this example, the PDF files created by Jones are displayed.

**Filter files by attributes in DITAExchange**

The DITAExchange connector allows you to filter the files in the Browse Files and File - Open dialog. You can filter the files in these dialogs by any of the available file attributes. For example, you can filter the files by file type or by the author. In a large list of files, this can narrow down the list and make it much easier to find the file or files you are looking for.

1. In the Repository Manager, right-click on a list or folder and choose Browse Fils(s).
2. The Browse File(s) dialogs displays the list of files in the selected list or folder.
   
   For each file, the list also displays all the associated attributes mentioned in the View.
   
   In DITAExchange, if you update the attributes associated with a file on the DITAExchange server, the attributes are dynamically updated in the Browse File(s) or File Open dialogs. This behavior is specific to DITAExchange.
3. To filter the list of files by a specific attribute, hover the mouse pointer over the attribute title.
   
   A pop-up arrow is displayed to the right of the title name.
4. Click the pop-up arrow.
   
   The Filter - <Attribute name> dialog is displayed.
5. To define a filter for the files in the Browse Files dialog, do one of the following:
   
   - Use the checkboxes to the left of the entries in the list. For example, in the above dialog, you can choose to filter the list to display only files modified by the administrator by unchecking the other two options.
   - Filter the list by the text entered in the text box. For example, type ad to filter the list by entries that contain the text ad.
6. Click OK.

   The list of files is filtered by the conditions that you have set in the Filter dialog.

   Note that in the Browse Files dialog, an asterisk appears to the right of the attribute title on which the filter is applied.

   The filter applied on a specific list or folder is retained for the current DITAExchange session. This implies that if you later open the Browse File(s) dialog for the specific list or folder, the file list will be filtered by the conditions that you previously applied.

**Clear applied filters**

You can clear the filters that you have applied in the Browse File(s) dialog at two levels:

- Filters applied to a specific attribute
- Filters applied to all attributes

1. In the Repository Manager, right-click on a list or folder and choose Browse Fils(s).
   
   In the Browse File(s) dialog, notice the asterisk that appears to the right of some of the attribute titles. This is provided by the connector as an indicator for the attributes on which filter are applied.
2. To clear the filter on a specific attribute, hover the mouse pointer over the attribute title and click the pop-up arrow.
3. In the Filter - <Attribute name> dialog, click Clear Filter.
4 The filter is cleared from the file list in the Browse File(s) dialog.
   Also notice the asterisk is not displayed to the right of the attribute title.

5 To clear the filter applied to all attributes, in the Browse File(s) dialog, click Clear All Filters.

**Advanced search (Documentum®,)**

To perform an advanced search on a Documentum® repository:

1 In the Repository Manager, select the repository.

2 Click the advanced search icon. The advanced search icon is displayed as follows:

![Advanced search window (Documentum®)](image)

3 Enter the search term in the search pane.

4 Select the location, file type, date, and file size values as required.

5 The condition builder allows you to perform complex searches by combining two or more search criteria.
   
   a Build a criteria by selecting the property (for example, Title) and the condition (for example, begins with), and
      specify a keyword (for example, Troubleshooting). Click Add.

   b Build another criteria by selecting the operator (AND or OR), property (for example Modified By), condition
      (for example, begins with), and specify a keyword (for example, Daniel).

6 Click Search.

Search results are displayed based on the specified criteria. In this example, elements that have their titles beginning
with Troubleshooting and are modified by users that have their names beginning with Daniel are displayed.
Add custom CMS attributes

You may need to create custom attributes according to your unique requirements in Sharepoint, DITAExchange or Documentum. Once you have created these custom attributes, you can provide support for them in FrameMaker XML Author. You can add the custom attributes in FrameMaker XML Author that exist on your Documentum, Sharepoint, or DITAExchange CMS. You can add the following attribute types in FrameMaker XML Author CMS preferences for Sharepoint or DITAExchange:

- Text
- Note
- Number
- Currency
- Integer
- Boolean
- DateTime
- Lookup
- Choice
- URL
- User

You can add the following data types for Documentum:

- Boolean
- Integer
- String
- Double
- Time
- ID

On file upload, the attributes specified in the CMS preferences are populated in connection manager and search.
Adding custom properties in Sharepoint or DITAExchange
A. Properties added in Sharepoint or DITAExchange using the Preferences dialog of FrameMaker XML Author  B. Adding custom properties in FrameMaker XML Author (SingleLine, MultiLine, and curr)

Add a custom property for Sharepoint or DITAExchange
1 Select Edit > Preferences.
2 In the Preferences dialog, expand CMS and select Sharepoint or DITAExchange and enter the following:
   a Name: Enter a name for the new property.
   b Data Type: Enter data type of the new property: Boolean, Date, Double, Integer, or String.
   c Attribute Type: Enter one of the following: Text, Note, Number, Currency, Integer, Boolean, DateTime, Lookup, Choice, URL, or User.
3 Click OK.

Add a custom property for Documentum*
1 Select Edit > Preferences.
2 In the Preferences dialog, expand CMS and select Documentum*.
3 In List of Attributes, enter the name of the new property and click Add. Repeat to add more properties.
4 Click OK.

To view the added property, right-click a folder or document within the relevant cabinet. Also, when you use Advanced Search, the Add Criteria area has the new property listed in the Property drop-down.
Chapter 15: Scripting in FrameMaker XML Author

What is scripting?

Scripting is a powerful tool that can be used to control and automate many features of Adobe FrameMaker XML Author—saving you so much time and effort that it can completely change the way you approach your work.

Why use scripting?

Your work is characterized by creativity, but many of the actual hands-on tasks are anything but creative. Most likely, you spend much time doing the same or similar procedures over and over again. Would it not be great to have an assistant—one that happily does the mind-numbing tasks, follows your instructions with perfect and predictable consistency, is available any time you need help, works at lightning speed, and never even sends an invoice? Scripting can be that assistant. With a small investment of time, you can learn to script the simple but repetitive tasks that eat up your time. However, while it’s easy to get started, FrameMaker XML Author scripts provide the necessary depth to handle sophisticated jobs. As your scripting skills grow, you may move on to more complex scripts that work all night while you’re sleeping.

Getting started with scripting

A script is a series of statements that tells an application to perform a set of tasks. The trick is writing the statements in a language that the applications understand. FrameMaker XML Author support ExtendScript as its scripting language.

There are two ways of running scripts: from within FrameMaker XML Author and by using the ExtendScript Toolkit (ESTK).

Run scripts from within FrameMaker XML Author

FrameMaker XML Author includes a menu entry that makes it easy to manage and run scripts.

• To run a script:
  1. Click File > Script > Run.
  2. From the Script browser, select the script to be run.
  3. Click Open. The script is run from within FrameMaker XML Author.

• To create a script:
  1. Click File > Script > New Script
  2. Compose your script in the ExtendScript ToolKit (ESTK) that is opened.
  3. Save the script. Either run the script from within ESTK or run it from within FrameMaker XML Author.
Manage your scripts from within FrameMaker XML Author

FrameMaker XML Author includes a script catalog that allows you to easily manage your scripts. Launch the catalog from File > Script > Catalog.

The Catalog looks as follows:

![Scripts Catalog](image)

The catalog lets you manage favorite scripts, autorun scripts, and registered (notification) scripts.

Select the Favorites option in the catalog to manage your favorite scripts.

You can perform the following operations from this screen:

- To add a script as a favorite, click Add. Select the script from the script browser and click Select. The script is then added as a favorite.
- To remove a script from the Favorites list, select the script and then click Remove.
- Click Refresh to refresh the list of favorite scripts.
- To mark a script as an Autorun script, select the script and click Move To AutoRun. The script is then copied from its exiting location into the autorun (startup) folder.

Manage favorite scripts

Select the Favorites option in the catalog to manage your favorite scripts.

You can perform the following operations from this screen:

- To add a script as a favorite, click Add. Select the script from the script browser and click Select. The script is then added as a favorite.
- To remove a script from the Favorites list, select the script and then click Remove.
- Click Refresh to refresh the list of favorite scripts.
- To mark a script as an Autorun script, select the script and click Move To AutoRun. The script is then copied from its exiting location into the autorun (startup) folder.

Manage autorun scripts

Select the Autorun option in the catalog to manage your autorun scripts.
Autorun scripts are run automatically each time FrameMaker XML Author is launched. Any script that is placed in the following directories, becomes an autorun script.

- `<FrameMaker XML Author installation folder>/startup`
- `<user’s home folder>/startup`

All scripts are run in alphabetical order.

You can perform the following operations:

- To add a script as an autorun script, click Add. Select the script from the script browser and click Select. The script is then placed in the startup folder and added to the autorun list.
- To delete a script from the autorun list, select the script and click Delete.
- Click Refresh to refresh the list of favorite scripts.

**Manage registered (notification) scripts**

Select the Registered option in the catalog to manage your registered scripts. Registered scripts are also called as notification scripts. These scripts are run when the events for which they are registered are triggered.

Notification is the internal mechanism through which a script registered for a particular event is run when the event is triggered.

Any script that is registered to run when an event is triggered is displayed in the notifications list in the catalog.

To unregister a notification script, select the script and click Unregister. The script is then unregistered. Once a script is unregistered, the script is not run, when the event for which it was previously registered is triggered.

*Note: To add a notification script, see the section on notifications in the appendix.*

**Other features**

There are two features that are common to every script type that you can manage through the catalog: view and delete broken scripts and select, edit and run a script.

**View and delete broken scripts**

When a script that has already been added to the catalog is moved or deleted from its current location in the file system, it is termed as a broken script.

To view such scripts, select the Show Broken only option in the catalog. The catalog then displays all the scripts that are broken.

You can then delete such scripts from the catalog. When you delete a script, it is only deleted from the catalog and not from its location in the file system.

**Select, edit, and run a script from the catalog**

- To run a script from within the catalog, select the script from the list and click Run.
- To edit a script from within the catalog, select the script from the list and click Edit. The script is opened in the ExtendScript ToolKit editor.
- To run a new script (not added to the catalog yet), select the option marked New and click Run. Then, select the script from the script browser and click Open.
Use the ExtendScript Toolkit

FrameMaker XML Author includes the ExtendScript ToolKit (ESTK). The ESTK is a development and debugging tool for ExtendScript scripts.

The ESTK has many features that make it easier to use than a text editor, including a built-in syntax checker that identifies where the problems are in your script and tries to explain how to fix them, and the ability to run your scripts right from the ESTK without saving the file.

All ExtendScript scripts are JavaScripts. The ESTK also includes a JavaScript debugger that allows you to:

- Single-step through JavaScript scripts (JS or JSX files) inside an application.
- Inspect all data for a running script.
- Set and execute breakpoints.

Note: For more information on ESTK, navigate to http://www.adobe.com/devnet/scripting.

Chapter 16: Keyboard Shortcuts

About keyboard shortcuts

You can perform many tasks by using keyboard shortcuts. The plus sign (“+”) indicates that each key must be pressed simultaneously. For example, Control+z means to press the Control key and the z key simultaneously. If the shortcut keystroke does not contain the plus sign (+), press each key in the order the shortcut states. For example, “Esc m p” means to press and release the Esc (Escape) key, then the m key, and then the p key.

Conventions and function keys

When you use keyboard shortcuts, Caps Lock must be off and, unless otherwise noted, a document window must be active.

The following table lists the terms used for special keys:

<table>
<thead>
<tr>
<th>Notation</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>arrow key</td>
<td>Up, down, right or left arrow keys</td>
</tr>
<tr>
<td>Esc</td>
<td>The key labeled Esc</td>
</tr>
<tr>
<td>Control</td>
<td>The key labeled Ctrl or Control</td>
</tr>
<tr>
<td>Alt</td>
<td>The key labeled Alt</td>
</tr>
<tr>
<td>Shift</td>
<td>The key labeled Shift</td>
</tr>
<tr>
<td>F2</td>
<td>The function key labeled F2. (If you should type F followed by 2, the characters are shown as F 2)</td>
</tr>
<tr>
<td>space</td>
<td>The spacebar</td>
</tr>
<tr>
<td>plus</td>
<td>The key labeled with a plus sign (+)</td>
</tr>
<tr>
<td>minus or hyphen</td>
<td>The key labeled with a hyphen (-)</td>
</tr>
<tr>
<td>period</td>
<td>The key labeled with a period (.)</td>
</tr>
<tr>
<td>comma</td>
<td>The key labeled with a comma (,)</td>
</tr>
<tr>
<td>zero</td>
<td>The key labeled with the numeral 0</td>
</tr>
<tr>
<td>one</td>
<td>The key labeled with the numeral 1</td>
</tr>
<tr>
<td>Win</td>
<td>The key with the Windows logo</td>
</tr>
</tbody>
</table>

Keyboard shortcut sequences

The following table explains the conventions for showing key sequences and key combinations. When an uppercase letter appears in a shortcut, use the Shift key when typing the letter.

When one or more shortcuts accomplish the same action, the shortcuts are separated by commas; for example: Control+n, Shift+Down Arrow. You can use either Control+n or Shift+Down Arrow to accomplish the same action.
### Keyboard Shortcuts

This table shows the result of pressing a function key or pressing a function key and either the Control, Shift, or Alt key simultaneously.

<table>
<thead>
<tr>
<th>Keyboard shortcut sequence</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Esc Shift+t r</td>
<td>Press and release these keys in succession: the Esc key, the uppercase letter T, and the letter r</td>
</tr>
<tr>
<td>Control+e</td>
<td>Press Control and type the letter e</td>
</tr>
<tr>
<td>Control+ Shift+hyphen</td>
<td>Press Shift and Control and type a hyphen</td>
</tr>
</tbody>
</table>

#### Function keys

This table shows the result of pressing a function key or pressing a function key and either the Control, Shift, or Alt key simultaneously.

<table>
<thead>
<tr>
<th>Key</th>
<th>Function</th>
<th>Control</th>
<th>Shift</th>
<th>Alt</th>
</tr>
</thead>
<tbody>
<tr>
<td>F1</td>
<td>Help</td>
<td>Align top</td>
<td></td>
<td></td>
</tr>
<tr>
<td>F2</td>
<td>Align middle</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>F3</td>
<td>Underline</td>
<td>Align bottom</td>
<td>Overline</td>
<td></td>
</tr>
<tr>
<td>F4</td>
<td>Cascade</td>
<td></td>
<td></td>
<td>Exit</td>
</tr>
<tr>
<td>F5</td>
<td>Tile</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>F6</td>
<td>Repeat Last Operation</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>F7</td>
<td>Point on document window</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>F8</td>
<td>Change dialog box settings to As is</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>F9</td>
<td>Transpose characters</td>
<td></td>
<td>Change dialog box settings to match current text</td>
<td></td>
</tr>
<tr>
<td>F10</td>
<td></td>
<td></td>
<td>Display context menu</td>
<td></td>
</tr>
</tbody>
</table>

#### Mouse

The following table lists the terms used for mouse actions.

<table>
<thead>
<tr>
<th>Instruction</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Click</td>
<td>Click the mouse button.</td>
</tr>
<tr>
<td>Right-click</td>
<td>Click the right mouse button.</td>
</tr>
<tr>
<td>Double-click</td>
<td>Click the mouse button twice rapidly without moving the mouse.</td>
</tr>
<tr>
<td>Triple-click</td>
<td>Click the mouse button three times rapidly without moving the mouse.</td>
</tr>
<tr>
<td>Shift-click</td>
<td>Hold down Shift and click the mouse button.</td>
</tr>
</tbody>
</table>
## Navigating through documents

<table>
<thead>
<tr>
<th>To go to</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Last viewed and open document</td>
<td>Control+Tab</td>
</tr>
<tr>
<td>Previous page</td>
<td>Esc p p, Pg Up</td>
</tr>
<tr>
<td>Next page</td>
<td>Esc p n, Pg Dn</td>
</tr>
<tr>
<td>First page</td>
<td>Esc p f, Alt+Pg Up, Shift, and click the Previous Page button</td>
</tr>
<tr>
<td>Last page</td>
<td>Esc p l (lowercase L), Alt+Pg Dn, Shift, and click the Next Page button</td>
</tr>
<tr>
<td>Go To Page dialog box</td>
<td>Esc v p, Control+g</td>
</tr>
<tr>
<td>Source of a cross-reference</td>
<td>Press Alt+Control and click an active area</td>
</tr>
<tr>
<td>A specific page</td>
<td>Press Control+g or click the Page Status area and then type the page number</td>
</tr>
<tr>
<td>Page containing the insertion point</td>
<td>Press Control+g or click the Page Status area and then click Page Containing the Insertion Point</td>
</tr>
<tr>
<td>Start of a word</td>
<td>Control+left arrow</td>
</tr>
<tr>
<td>End of a word</td>
<td>Control+right arrow</td>
</tr>
<tr>
<td>Start of the next word</td>
<td>Esc b w</td>
</tr>
<tr>
<td>Start of a sentence</td>
<td>Control+Home</td>
</tr>
<tr>
<td>End of a sentence</td>
<td>Control+End</td>
</tr>
<tr>
<td>Start of a paragraph</td>
<td>Control+up arrow</td>
</tr>
<tr>
<td>End of the current paragraph</td>
<td>Control+Down Arrow</td>
</tr>
<tr>
<td>Start of the next paragraph</td>
<td>Esc b p</td>
</tr>
<tr>
<td>Top of a column</td>
<td>Control+Pg Up</td>
</tr>
<tr>
<td>Bottom of a column</td>
<td>Control+Pg Dn</td>
</tr>
<tr>
<td>Start of a flow</td>
<td>Alt+ Shift+Pg Up</td>
</tr>
<tr>
<td>End of a flow</td>
<td>Alt+ Shift+Pg Dn</td>
</tr>
<tr>
<td>Start of a line</td>
<td>Control+Pg Up</td>
</tr>
<tr>
<td>End of a line</td>
<td>Control+Pg Dn</td>
</tr>
</tbody>
</table>

## Keys for screen modes

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Standard screen mode</td>
<td>Esc S M s</td>
</tr>
<tr>
<td>Full screen with user interface</td>
<td>Esc S M u</td>
</tr>
<tr>
<td>Full screen mode</td>
<td>Esc S M f</td>
</tr>
<tr>
<td>Toggle screen mode</td>
<td>Esc S M t</td>
</tr>
</tbody>
</table>

Last updated 8/19/2015
## Keys for views

<table>
<thead>
<tr>
<th>Display</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>WYSIWYG view</td>
<td>Esc S 1</td>
</tr>
<tr>
<td>Author view</td>
<td>Esc S 2</td>
</tr>
<tr>
<td>XML view</td>
<td>Esc S 3</td>
</tr>
</tbody>
</table>

## Dialog boxes

### Typing in dialog boxes

In some cases, you must type a character sequence beginning with a backslash (\) to enter a character in a dialog box. The sequence appears in the dialog box, but the character appears correctly in the document. The following table shows the sequences to type in a dialog box.

All key sequences described— here— begin with a backslash (\). To indicate a literal backslash in a dialog box, enter two backslashes (\\). In a few cases, you can choose between two backslash sequences for a character. In these cases, the sequences are separated by a comma.

<table>
<thead>
<tr>
<th>Character name</th>
<th>Graphic</th>
<th>Backslash sequence</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bullet</td>
<td>•</td>
<td>\b</td>
</tr>
<tr>
<td>Circumflex</td>
<td>^</td>
<td>@</td>
</tr>
<tr>
<td>Dagger</td>
<td>†</td>
<td>\d</td>
</tr>
<tr>
<td>Dagger (double)</td>
<td>‡</td>
<td>\Shift+d</td>
</tr>
<tr>
<td>Dash (em)</td>
<td>—</td>
<td>\m</td>
</tr>
<tr>
<td>Dash (en)</td>
<td>—</td>
<td>\e</td>
</tr>
<tr>
<td>Ellipsis</td>
<td>...</td>
<td>\e</td>
</tr>
<tr>
<td>Florin</td>
<td>f</td>
<td>\Shift+f</td>
</tr>
<tr>
<td>Forced return</td>
<td>\r</td>
<td></td>
</tr>
<tr>
<td>Fraction</td>
<td>/</td>
<td>/</td>
</tr>
<tr>
<td>Grave</td>
<td>\</td>
<td>&amp;</td>
</tr>
<tr>
<td>Guilsingl left</td>
<td>&lt;</td>
<td>{</td>
</tr>
<tr>
<td>Guilsingl right</td>
<td>&gt;</td>
<td>}</td>
</tr>
<tr>
<td>Hungarumlaut</td>
<td>‚</td>
<td>&amp;</td>
</tr>
<tr>
<td>Hyphen (discretionary)</td>
<td>`-</td>
<td>- (hyphen)</td>
</tr>
<tr>
<td>Hyphen (nonbreaking)</td>
<td>`-</td>
<td>+</td>
</tr>
<tr>
<td>OE ligature</td>
<td>OE</td>
<td>\Shift+o Shift+e</td>
</tr>
<tr>
<td>oe ligature</td>
<td>oe</td>
<td>\oe</td>
</tr>
</tbody>
</table>

Last updated 8/19/2015
Keyboard Shortcuts

Window manipulation
To use these shortcuts, click in any FrameMaker XML Author window.

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Redisplay a document window</td>
<td>Esc w r, Control+l (lowercase L)</td>
</tr>
<tr>
<td>Close the active window or modeless dialog box</td>
<td>Alt+F4</td>
</tr>
<tr>
<td>Close the document window</td>
<td>Esc f q, Esc f c, Control+F4, Control+w, Control+Shift+w</td>
</tr>
<tr>
<td>Minimize the document window</td>
<td>Esc w c</td>
</tr>
</tbody>
</table>

Display and activation
Use these shortcuts to display a window or dialog box and make it active. If it is already open but is behind another window, these shortcuts bring it to the front.

<table>
<thead>
<tr>
<th>To display this window and make it active</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Current document window</td>
<td>Esc Shift+f i d, Shift+F7</td>
</tr>
<tr>
<td>Find/Change</td>
<td>Esc Shift+f i f</td>
</tr>
<tr>
<td>Hypertext</td>
<td>Esc Shift+f i h</td>
</tr>
<tr>
<td>Marker</td>
<td>Esc Shift+f i m</td>
</tr>
<tr>
<td>Spelling Checker</td>
<td>Esc Shift+f i s</td>
</tr>
</tbody>
</table>
To display this window and make it active | Keyboard shortcut
---|---
Conditional Text | Esc Shift+f i o
Structure View | Esc Shift+f i v
Element Validation | Esc Shift+f i w

**Navigation within dialog boxes**

Use these shortcuts to move to settings within dialog boxes and pods. When you use a keyboard shortcut in a window or dialog box, the shortcut’s effect depends on the active setting. The active setting is highlighted, has a dotted rectangle around it, or both.

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move to the next setting</td>
<td>Tab</td>
</tr>
<tr>
<td>Move to the previous setting</td>
<td>Shift+Tab</td>
</tr>
</tbody>
</table>

**Command buttons**

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Click the default button</td>
<td>Return</td>
</tr>
<tr>
<td>Click the active button</td>
<td>space</td>
</tr>
<tr>
<td>Cancel a dialog box (but not a window)</td>
<td>Esc</td>
</tr>
</tbody>
</table>

**Radio buttons and checkboxes**

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Navigate through a group of radio buttons to turn on a radio button</td>
<td>arrow keys</td>
</tr>
<tr>
<td>Cycle through checkbox states (off, on, As Is)</td>
<td>space</td>
</tr>
</tbody>
</table>

**Pop-up menus**

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move to the previous menu item</td>
<td>up arrow</td>
</tr>
<tr>
<td>Move to the next menu item</td>
<td>Down Arrow</td>
</tr>
<tr>
<td>Search forward and select an item starting with a typed letter</td>
<td>UnShifted key</td>
</tr>
</tbody>
</table>

**Scroll lists**

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move to the previous item in a list</td>
<td>up arrow</td>
</tr>
<tr>
<td>Move to the next item in a list</td>
<td>Down Arrow</td>
</tr>
</tbody>
</table>
**Custom menus**

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display a custom menu bar</td>
<td>Esc v m u</td>
</tr>
</tbody>
</table>

**Keys for selection**

Use these shortcuts to select objects on the current page.

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search forward and select an item starting with a typed letter</td>
<td>UnShifted key</td>
</tr>
<tr>
<td>Move an item in a scroll list to the opposite scroll list</td>
<td>Double-click the item</td>
</tr>
<tr>
<td>Move all items in a scroll list to the opposite scroll list</td>
<td>Press and click arrow between scroll lists</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select a text line or text frame</td>
<td>Press Control and click the text line or text frame</td>
</tr>
<tr>
<td>Extend or shorten the selection</td>
<td>Press Shift and click an object</td>
</tr>
<tr>
<td>Force selection border to appear (when dragging from outside all objects is not possible)</td>
<td>Press Control+ Shift and drag diagonally</td>
</tr>
<tr>
<td>Select the first object in the draw order</td>
<td>Esc o Shift+f</td>
</tr>
<tr>
<td>Select the next object in the draw order</td>
<td>Esc o n</td>
</tr>
<tr>
<td>Extend the selection to the next object in the draw order</td>
<td>Esc o e</td>
</tr>
<tr>
<td>Deselect a text frame or text line and put the insertion point inside it instead</td>
<td>Double-click in the text frame or text line</td>
</tr>
</tbody>
</table>

**Menu commands**

**Context menus**

<table>
<thead>
<tr>
<th>Task</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display a pop-up menu of commands that apply to the current selection or context</td>
<td>Right-click on an object, in a document margin, or in a book window</td>
</tr>
</tbody>
</table>

**File menu (document window)**

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>New&gt;Book</td>
<td>Esc f Shift+n</td>
</tr>
<tr>
<td>Open</td>
<td>Esc f o, Control+o</td>
</tr>
<tr>
<td>Close</td>
<td>Esc f c, Esc f q, Control+w, Control+F4, Control+Shift+w</td>
</tr>
</tbody>
</table>
## File menu (book window)

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>New Document</td>
<td>Esc f n, Control+n</td>
</tr>
<tr>
<td>New Book</td>
<td>Esc f Shift+n</td>
</tr>
<tr>
<td>Open</td>
<td>Esc f o, Control+o</td>
</tr>
<tr>
<td>Open All Files in Book</td>
<td>Esc f Shift+o</td>
</tr>
<tr>
<td>Close Book</td>
<td>Esc f c, Control+w</td>
</tr>
<tr>
<td>Close All Files in Book</td>
<td>Esc f Shift+c</td>
</tr>
<tr>
<td>Save Book</td>
<td>Esc f s, Control+s</td>
</tr>
<tr>
<td>Save All Files in Book</td>
<td>Esc f Shift+s</td>
</tr>
<tr>
<td>Save Book As</td>
<td>Esc f a</td>
</tr>
<tr>
<td>Revert to Saved Book</td>
<td>Esc f r</td>
</tr>
<tr>
<td>Utilities&gt;Compare Books</td>
<td>Esc f b</td>
</tr>
<tr>
<td>Preferences</td>
<td>Esc f Shift+p</td>
</tr>
<tr>
<td>Exit</td>
<td>Alt+F4</td>
</tr>
</tbody>
</table>
## Edit menu (document window)

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo/Redo</td>
<td>Esc e u, Control+z, Control+Shift+z</td>
</tr>
<tr>
<td>Cut</td>
<td>Esc e x, Control+x, Shift+Delete</td>
</tr>
<tr>
<td>Copy</td>
<td>Esc e c, Control+c, Control+Insert</td>
</tr>
<tr>
<td>Paste</td>
<td>Esc e p, Control+v, Shift+Insert</td>
</tr>
<tr>
<td>Paste Special</td>
<td>Control+ Shift+v</td>
</tr>
<tr>
<td>Clear</td>
<td>Esc e b</td>
</tr>
<tr>
<td>Copy Special&gt;Attribute Values</td>
<td>Esc e y a</td>
</tr>
<tr>
<td>Copy Special&gt;Table Column Width</td>
<td>Esc e y w</td>
</tr>
<tr>
<td>Select All in Flow</td>
<td>Esc e a, Control+a</td>
</tr>
<tr>
<td>Find/Change</td>
<td>Esc e f, Control+f</td>
</tr>
<tr>
<td>Find Next</td>
<td>Esc f i n, Esc e Shift+f, Control+ Shift+f</td>
</tr>
<tr>
<td>Spelling Checker</td>
<td>Esc e s</td>
</tr>
<tr>
<td>Thesaurus</td>
<td>Esc e t</td>
</tr>
<tr>
<td>Text Inset Properties</td>
<td>Esc e i</td>
</tr>
<tr>
<td>Update References</td>
<td>Esc e Shift+u</td>
</tr>
<tr>
<td>History</td>
<td>Ctrl K, Esc e h</td>
</tr>
<tr>
<td>Auto Spell Check On/Off</td>
<td>Esc a u s</td>
</tr>
<tr>
<td>Repeat</td>
<td>F6</td>
</tr>
<tr>
<td>Object</td>
<td>(No shortcut available)</td>
</tr>
</tbody>
</table>

## Edit menu (book window)

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo/Redo</td>
<td>Esc e u, Control+z, Control+Shift+z</td>
</tr>
<tr>
<td>History</td>
<td>Esc e h</td>
</tr>
<tr>
<td>Cut</td>
<td>Esc e x, Control+x, Shift+Delete</td>
</tr>
<tr>
<td>Copy</td>
<td>Esc e c, Control+c</td>
</tr>
<tr>
<td>Paste</td>
<td>Esc e p, Control+v</td>
</tr>
<tr>
<td>Clear</td>
<td>Esc e b</td>
</tr>
<tr>
<td>Copy Special&gt;Attribute Values</td>
<td>Esc e y a</td>
</tr>
<tr>
<td>Select&gt;Generated Files</td>
<td>Esc e Shift+a Shift+g</td>
</tr>
<tr>
<td>Select&gt;Nongenerated Files</td>
<td>Esc e Shift+a Shift+n</td>
</tr>
<tr>
<td>Select&gt;FrameMaker Files</td>
<td>Esc e Shift+a Shift+f</td>
</tr>
</tbody>
</table>
Keyboard Shortcuts

Select>Excluded Components  Esc e Shift+a Shift+e
Select>Non-Excluded Components  Esc e Shift+n Shift+e
Select>Chapter Components  Esc c l
Select>Section Components  Esc s l
Select>Sub-Section Components  Esc s s l
Find/Change  Esc e f, Control+f
Find Next  Esc f n, Esc e Shift+f, Control+ Shift+f
Spelling Checker  Esc e s
Delete  Esc f x
Suppress Automatic Reference Updating  Esc e Shift+s

Add menu (book window)

<table>
<thead>
<tr>
<th>Menu command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Files</td>
<td>Esc f f</td>
</tr>
</tbody>
</table>

Element menu

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Merge</td>
<td>Esc Shift+e m</td>
</tr>
<tr>
<td>Split</td>
<td>Esc Shift+e s</td>
</tr>
<tr>
<td>Unwrap</td>
<td>Esc Shift+e u</td>
</tr>
<tr>
<td>Edit Attributes</td>
<td>Esc Shift+e Shift+a</td>
</tr>
<tr>
<td>Element Catalog</td>
<td>Esc Shift+e Shift+c</td>
</tr>
<tr>
<td>Set Available Elements</td>
<td>Esc Shift+e Shift+o Shift+c</td>
</tr>
<tr>
<td>New Element Options</td>
<td>Esc Shift+e Shift+o Shift+i</td>
</tr>
<tr>
<td>Validate</td>
<td>Esc Shift+e v</td>
</tr>
</tbody>
</table>

View menu (document window)

<table>
<thead>
<tr>
<th>Menu command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>QuickAccess Bar</td>
<td>Esc v q</td>
</tr>
<tr>
<td>Track Text Edit Bar</td>
<td>Esc Shift+v e</td>
</tr>
<tr>
<td>Borders</td>
<td>Esc v b</td>
</tr>
<tr>
<td>Text Symbols</td>
<td>Esc v t</td>
</tr>
<tr>
<td>Rulers</td>
<td>Esc v r</td>
</tr>
<tr>
<td>Grid Lines</td>
<td>Esc v g</td>
</tr>
<tr>
<td>Element Boundaries</td>
<td>Esc v Shift+e</td>
</tr>
</tbody>
</table>
## Keyboard Shortcuts

<table>
<thead>
<tr>
<th>Menu command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Element Boundaries (as Tags)</td>
<td>Esc v Shift+t</td>
</tr>
<tr>
<td>Options</td>
<td>Esc v o</td>
</tr>
<tr>
<td>Attribute Display Options</td>
<td>Esc v Shift+a</td>
</tr>
<tr>
<td>Go to Page</td>
<td>Esc v p, Control+g, Control+ Shift+g</td>
</tr>
<tr>
<td>Body Pages</td>
<td>Esc v Shift+b</td>
</tr>
<tr>
<td>Color&gt;Views</td>
<td>Esc v c v</td>
</tr>
<tr>
<td>Menus&gt;Quick</td>
<td>Esc v m q</td>
</tr>
<tr>
<td>Menus&gt;Complete</td>
<td>Esc v m c</td>
</tr>
<tr>
<td>Menus&gt;Modify</td>
<td>Esc v m m</td>
</tr>
<tr>
<td>QuickAccess Bar</td>
<td>Esc v q</td>
</tr>
<tr>
<td>Track Text Edit</td>
<td>Esc Shift+v e</td>
</tr>
<tr>
<td>Borders</td>
<td>Esc Shift+v b s</td>
</tr>
<tr>
<td>Hide Borders</td>
<td>Esc Shift+v b h</td>
</tr>
<tr>
<td>Show Text Symbols</td>
<td>Esc Shift+v t s</td>
</tr>
<tr>
<td>Hide Text Symbols</td>
<td>Esc Shift+v t h</td>
</tr>
<tr>
<td>Show Rulers</td>
<td>Esc Shift+v r s</td>
</tr>
<tr>
<td>Hide Rulers</td>
<td>Esc Shift+v r h</td>
</tr>
<tr>
<td>Show Grid Lines</td>
<td>Esc Shift+v g s</td>
</tr>
<tr>
<td>Hide Grid Lines</td>
<td>Esc Shift+v g h</td>
</tr>
<tr>
<td>Show Graphics</td>
<td>Esc Shift+v v s</td>
</tr>
<tr>
<td>Hide Graphics</td>
<td>Esc Shift+v v h</td>
</tr>
<tr>
<td>Filter By Attribute</td>
<td>Esc a c</td>
</tr>
<tr>
<td>Show Element Boundaries</td>
<td>Esc Shift+v Shift+e s</td>
</tr>
<tr>
<td>Hide Element Boundaries</td>
<td>Esc Shift+v Shift+e h</td>
</tr>
<tr>
<td>Show Element Boundaries (as Tags)</td>
<td>Esc Shift+v Shift+t s</td>
</tr>
<tr>
<td>Options</td>
<td>Esc v o</td>
</tr>
<tr>
<td>Attribute Display Options</td>
<td>Esc v Shift+a</td>
</tr>
<tr>
<td>Zoom&gt;In</td>
<td>Esc z i</td>
</tr>
<tr>
<td>Zoom&gt;Out</td>
<td>Esc z o</td>
</tr>
<tr>
<td>Zoom&gt;100 percent</td>
<td>Esc z 2</td>
</tr>
<tr>
<td>Zoom&gt;Fit Page in Window</td>
<td>Esc z p</td>
</tr>
<tr>
<td>Zoom&gt;Fit Window to Page</td>
<td>Esc z w</td>
</tr>
</tbody>
</table>

### View menu (book window)

<table>
<thead>
<tr>
<th>Menu command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zoom&gt;Fit Page in Window</td>
<td>Esc z p</td>
</tr>
<tr>
<td>Zoom&gt;Fit Window to Page</td>
<td>Esc z w</td>
</tr>
</tbody>
</table>

Last updated 8/19/2015
## Keyboard Shortcuts

<table>
<thead>
<tr>
<th>Menu command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zoom&gt;Fit Window to Text Frame</td>
<td>Esc z f</td>
</tr>
<tr>
<td>Color&gt;Views</td>
<td>Esc v c v</td>
</tr>
<tr>
<td>Menus&gt;Quick</td>
<td>Esc v m q</td>
</tr>
<tr>
<td>Menus&gt;Complete</td>
<td>Esc v m c</td>
</tr>
<tr>
<td>Menus&gt;Modify</td>
<td>Esc v m m</td>
</tr>
</tbody>
</table>

### Special menu

<table>
<thead>
<tr>
<th>Menu command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Anchored Frame</td>
<td>Esc s a</td>
</tr>
<tr>
<td>Footnote</td>
<td>Esc s f</td>
</tr>
<tr>
<td>Cross-Reference</td>
<td>Esc s c</td>
</tr>
<tr>
<td>Variable</td>
<td>Esc s v</td>
</tr>
<tr>
<td>Hypertext</td>
<td>Esc s h</td>
</tr>
<tr>
<td>Marker</td>
<td>Esc s m</td>
</tr>
<tr>
<td>Equations</td>
<td>Esc s e</td>
</tr>
<tr>
<td>Filter By Attribute</td>
<td>Esc a c</td>
</tr>
<tr>
<td>Conditional Text</td>
<td>Esc s Shift+c</td>
</tr>
<tr>
<td>Manage Conditional Text</td>
<td>Esc m Shift+c</td>
</tr>
<tr>
<td>Apply Conditional Text</td>
<td>Esc s Shift+c</td>
</tr>
<tr>
<td>Show/Hide Conditional Text</td>
<td>Esc v Shift+c</td>
</tr>
<tr>
<td>Show Condition Indicator</td>
<td>Esc Shift+v Shift+o s</td>
</tr>
<tr>
<td>Hide Condition Indicator</td>
<td>Esc Shift+v Shift+o h</td>
</tr>
<tr>
<td>Toggle Conditional Indicators On/Off</td>
<td>Esc v Shift+o</td>
</tr>
<tr>
<td>Show One Conditional Text Tag</td>
<td>Esc q Shift+s</td>
</tr>
<tr>
<td>Select Same Condition Tags</td>
<td>Esc h Shift+c</td>
</tr>
<tr>
<td>View the condition applied to the text where the cursor is placed</td>
<td>Esc q Shift+c</td>
</tr>
<tr>
<td>Focus in Conditional Text</td>
<td>Esc Shift+f s o</td>
</tr>
<tr>
<td>Close Conditional Text dialog box</td>
<td>Esc Shift+c o</td>
</tr>
<tr>
<td>Turn on or off the Track Text Edit feature</td>
<td>Esc s t o</td>
</tr>
<tr>
<td>Show Next</td>
<td>Esc s t n</td>
</tr>
<tr>
<td>Show Previous</td>
<td>Esc s t p</td>
</tr>
<tr>
<td>Accept Edit</td>
<td>Esc s t a</td>
</tr>
<tr>
<td>Reject Edit</td>
<td>Esc s t r</td>
</tr>
<tr>
<td>Accept All</td>
<td>Esc s t Shift+a</td>
</tr>
<tr>
<td>Reject All</td>
<td>Esc s t Shift+r</td>
</tr>
</tbody>
</table>
## Keyboard Shortcuts

<table>
<thead>
<tr>
<th>Graphics menu</th>
<th>Menu command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Preview Final</td>
<td>Esc s t Shift+f</td>
<td></td>
</tr>
<tr>
<td>Preview Original</td>
<td>Esc s t Shift+o</td>
<td></td>
</tr>
<tr>
<td>Preview Off</td>
<td>Esc s p o</td>
<td></td>
</tr>
<tr>
<td>Rubi</td>
<td>Esc s r</td>
<td></td>
</tr>
</tbody>
</table>

**Menu command**

- **Tools**: Esc g Shift+t, Esc one w
- **Object Properties**: Esc g o
- **Pick up Properties**: Esc g Shift+o
- **Runaround Properties**: Esc g Shift+r
- **Gravity**: Esc g y
- **Snap**: Esc g p
- **3D Menu Background Color option**: Alt + g + 3 + b
- **3D Menu Lighting option**: Alt + g + 3 + l (lowercase L)
- **Lights From File**: Alt + g + 3 + l + (lowercase L) + l (lowercase L)
- **No Lights**: Alt + g + 3 + l (lowercase L) + n
- **White Lights**: Alt + g + 3 + l (lowercase L) + w
- **Day Lights**: Alt + g + 3 + l (lowercase L) + d
- **Bright Lights**: Alt + g + 3 + l (lowercase L) + b
- **Primary Color Lights**: Alt + g + 3 + l (lowercase L) + p
- **Night Lights**: Alt + g + 3 + l (lowercase L) + i
- **Blue Lights**: Alt + g + 3 + l (lowercase L) + u
- **Red Lights**: Alt + g + 3 + l (lowercase L) + r
- **Cube Lights**: Alt + g + 3 + l (lowercase L) + c
- **CAD Optimized Lights**: Alt + g + 3 + l (lowercase L) + o
- **Headlamp**: Alt + g + 3 + l (lowercase L) + h
- **Show Existing Views**: Alt + g + 3 + s
- **Render Mode option**: Alt + g + 3 + r
- **Bounding Box**: Alt + g + 3 + r + b
- **Transparent Bounding Box**: Alt + g + 3 + r + t
- **Transparent Bounding Box Outline**: Alt + g + 3 + r + o
- **Vertices**: Alt + g + 3 + r + v
- **Shaded Vertices**: Alt + g + 3 + r + s
- **Wireframe**: Alt + g + 3 + r + w

*Last updated 8/19/2015*
Using Framemaker XML Author (2015 Release)

### Keyboard Shortcuts

| Shaded Wireframe | Alt + g + 3 + r + h |
| Solid            | Alt + g + 3 + r + l (lowercase L) |
| Transparent      | Alt + g + 3 + r + r |
| Solid Wireframe  | Alt + g + 3 + r + i |
| Transparent Wireframe | Alt + g + 3 + r + a |
| Illustration     | Alt + g + 3 + r + u |
| Solid Outline    | Alt + g + 3 + r + d |
| Shaded Illustration | Alt + g + 3 + r + e |
| Hidden Wireframe | Alt + g + 3 + r + n |

#### Table menu

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert Table</td>
<td>Esc t i</td>
</tr>
<tr>
<td>Add Rows or Columns</td>
<td>Esc t a</td>
</tr>
<tr>
<td>Sort</td>
<td>Esc t s</td>
</tr>
</tbody>
</table>

#### StructureTools menu

<table>
<thead>
<tr>
<th>Menu command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>StructureTools&gt;Structure View</td>
<td>Alt + r + s</td>
</tr>
<tr>
<td>StructureTools&gt;Read Application Definitions From File</td>
<td>Alt + r + r</td>
</tr>
<tr>
<td>StructureTools&gt;Assign unique ID to elements</td>
<td>Alt + r + a</td>
</tr>
</tbody>
</table>

#### DITA menu

<table>
<thead>
<tr>
<th>Menu command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>DITA&gt; New DITA File&gt;New &lt;map&gt;i</td>
<td>Esc Shift+n Shift+m i</td>
</tr>
<tr>
<td>map&lt;i&gt; refers to an element whose class attribute starts with map/map and can vary from 1 to i.</td>
<td></td>
</tr>
<tr>
<td>DITA&gt; New DITA File&gt;New &lt;topic&gt;i</td>
<td>Esc Shift+n Shift+t 1</td>
</tr>
<tr>
<td>topic&lt;i&gt; refers to an element whose class attribute starts with topic/topic and can vary from 1 to i.</td>
<td></td>
</tr>
<tr>
<td>DITA&gt; New DITA File&gt;New &lt;concept&gt;i</td>
<td>Esc Shift+n Shift+t 2</td>
</tr>
<tr>
<td>DITA&gt; New DITA File&gt;New &lt;task&gt;i</td>
<td>Esc Shift+n Shift+t 1</td>
</tr>
<tr>
<td>DITA&gt; New DITA File&gt;New &lt;reference&gt;i</td>
<td></td>
</tr>
<tr>
<td>DITA&gt; New DITA File&gt;Refresh Menu</td>
<td>Esc Shift+r Shift+m</td>
</tr>
<tr>
<td>DITA&gt; Insert Conref</td>
<td>Esc Shift+i Shift+c</td>
</tr>
<tr>
<td>DITA&gt; Assign ID to Element</td>
<td>Esc Shift+a Shift+i</td>
</tr>
</tbody>
</table>
### Keyboard Shortcuts

<table>
<thead>
<tr>
<th>DITA&gt; Update References</th>
<th>Esc Shift+u Shift+r</th>
</tr>
</thead>
<tbody>
<tr>
<td>DITA&gt; Open all Topicrefs</td>
<td>Esc Shift+o Shift+a</td>
</tr>
<tr>
<td>DITA&gt; Insert Topicref</td>
<td>Esc Shift+i Shift+t</td>
</tr>
<tr>
<td>DITA&gt; Build FM Document From DITA Map</td>
<td>Esc Shift+g Shift+d</td>
</tr>
<tr>
<td>DITA&gt; DITA Options</td>
<td>Esc Shift+d Shift+o</td>
</tr>
</tbody>
</table>

### Window menu

<table>
<thead>
<tr>
<th>Menu command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cascade</td>
<td>Shift+F4</td>
</tr>
<tr>
<td>Tile</td>
<td>Shift+F5</td>
</tr>
<tr>
<td>Arrange Icons</td>
<td>(No shortcut available)</td>
</tr>
<tr>
<td>Refresh</td>
<td>Control+i (lowercase L)</td>
</tr>
</tbody>
</table>

### Tables

#### Selection in tables

<table>
<thead>
<tr>
<th>To select</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>A cell</td>
<td>Press Control and click the cell</td>
</tr>
<tr>
<td>A row</td>
<td>Press Control and double-click column (vertical) border in the row</td>
</tr>
<tr>
<td>A column</td>
<td>Press Control and double-click row (horizontal) border in the row</td>
</tr>
<tr>
<td>Text in the cell above the current cell</td>
<td>Esc t m u a</td>
</tr>
<tr>
<td>Text in the cell below the current cell</td>
<td>Esc t m d a</td>
</tr>
<tr>
<td>All text in current cell</td>
<td>Esc t h a</td>
</tr>
<tr>
<td>Current cell, then next cell</td>
<td>Esc t h e</td>
</tr>
<tr>
<td>Current row, then next row</td>
<td>Esc t h r</td>
</tr>
<tr>
<td>Current column, then next column</td>
<td>Esc t h c</td>
</tr>
<tr>
<td>Body cells in current column, then next body cells</td>
<td>Esc t h b</td>
</tr>
<tr>
<td>Current table</td>
<td>Esc t h t, or press Control and triple-click a cell</td>
</tr>
<tr>
<td>Extend or shorten the election</td>
<td>Press Control+- and click the last cell you want in the selection</td>
</tr>
</tbody>
</table>

### Navigating through tables

Use these shortcuts to move to the indicated cell.
### Keyboard Shortcuts

#### Tab characters in cells

<table>
<thead>
<tr>
<th>To</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type a tab character in a cell</td>
<td>Esc Tab</td>
</tr>
</tbody>
</table>

#### Row and column manipulation

FrameMaker XML Author adds or deletes as many rows or columns as are currently selected.

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add rows above top selected row</td>
<td>Esc t Shift+r a</td>
</tr>
<tr>
<td>Add rows below bottom selected row</td>
<td>Esc t Shift+r b, Control+Return, Control+j</td>
</tr>
<tr>
<td>Add columns to left of leftmost selected column</td>
<td>Esc t c l (lowercase L)</td>
</tr>
<tr>
<td>Add columns to right of rightmost selected column</td>
<td>Esc t c r</td>
</tr>
<tr>
<td>Delete contents of selected rows or columns, but leave cells in table</td>
<td>Esc t c e</td>
</tr>
<tr>
<td>Delete selected rows or columns from table</td>
<td>Esc t c x</td>
</tr>
<tr>
<td>Sort rows and columns</td>
<td>Esc t s</td>
</tr>
</tbody>
</table>
Row and column replacement
If the Clipboard doesn’t contain whole rows or columns, these shortcuts always replace the selected cells.

<table>
<thead>
<tr>
<th>To paste whole rows or columns</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>By replacing selected rows or columns</td>
<td>Esc t p r</td>
</tr>
<tr>
<td>Before current selection (above top selected row or to left of leftmost selected column)</td>
<td>Esc t p b</td>
</tr>
<tr>
<td>After current selection (below bottom selected row or to right of rightmost selected column)</td>
<td>Esc t p a</td>
</tr>
</tbody>
</table>

Vertical alignment in cells
To use these shortcuts, click in the first paragraph in a cell.

<table>
<thead>
<tr>
<th>Alignment</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Top alignment</td>
<td>Esc j t, Control+F1</td>
</tr>
<tr>
<td>Middle alignment</td>
<td>Esc j m, Control+F2</td>
</tr>
<tr>
<td>Bottom alignment</td>
<td>Esc j b, Control+F3</td>
</tr>
</tbody>
</table>

Column width

<table>
<thead>
<tr>
<th>To resize</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Columns so no paragraphs in selected cells wrap</td>
<td>Esc t w</td>
</tr>
<tr>
<td>Selected column without changing table’s width</td>
<td>Press Alt and drag selected cell’s handle</td>
</tr>
<tr>
<td>Copy column width to Clipboard</td>
<td>Esc e y w</td>
</tr>
</tbody>
</table>

Book commands

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>New Book</td>
<td>Esc f Shift+n</td>
</tr>
<tr>
<td>Save Book</td>
<td>Esc f s, Control+s</td>
</tr>
<tr>
<td>Display filenames (in book window)</td>
<td>Esc Shift+v Shift+m</td>
</tr>
<tr>
<td>Display paragraph headings (in book window)</td>
<td>Esc Shift+v Shift+x</td>
</tr>
<tr>
<td>Delete File from Book</td>
<td>Esc f x</td>
</tr>
<tr>
<td>Select All Files</td>
<td>Esc e a</td>
</tr>
<tr>
<td>Save all files in book</td>
<td>Esc f Shift+s</td>
</tr>
<tr>
<td>Close all files in book</td>
<td>Esc f Shift+c</td>
</tr>
<tr>
<td>Select All Non-Generated FrameMaker Files</td>
<td>Esc e Shift+a Shift+n</td>
</tr>
<tr>
<td>Select All Generated FrameMaker Files</td>
<td>Esc e Shift+a Shift+g</td>
</tr>
</tbody>
</table>
### Keyboard Shortcuts

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select a range of files</td>
<td>Shift+click</td>
</tr>
<tr>
<td>Select discontiguous files</td>
<td>Control+click</td>
</tr>
<tr>
<td>Move up a file in book</td>
<td>Esc m u</td>
</tr>
<tr>
<td>Move a file down in book</td>
<td>Esc m d</td>
</tr>
</tbody>
</table>

### Keys for finding and changing

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search forward</td>
<td>Esc f i n, Esc e Shift+f, Control+ Shift+f, Alt+Control+s</td>
</tr>
<tr>
<td>Search backward</td>
<td>Esc f i p, Alt+Control+f, Alt+Control+r</td>
</tr>
<tr>
<td>Change current selection</td>
<td>Esc r o</td>
</tr>
<tr>
<td>Change all occurrences of Find text in document</td>
<td>Esc r g</td>
</tr>
<tr>
<td>Change and search again</td>
<td>Esc r a</td>
</tr>
<tr>
<td>Change settings to As Is in Find Character Format and Change To Character Format dialog boxes</td>
<td>Shift+F8</td>
</tr>
<tr>
<td>Change settings to match selected text in Find Character Format and Change To Character Format dialog boxes</td>
<td>Shift+F9</td>
</tr>
<tr>
<td>Display Set Find/Change Parameters dialog box</td>
<td>Esc f i s</td>
</tr>
</tbody>
</table>

#### Find

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tab symbol</td>
<td></td>
</tr>
<tr>
<td>Forced return</td>
<td></td>
</tr>
</tbody>
</table><pre><code>                                   |
</code></pre>
<p>| End-of-paragraph symbol                   | \p                                       |
| Start of paragraph                        | \P                                       |
| Nonbreaking space                         | \ (space)                                 |
| Thin space                                | \, \lst                                 |</p>

#### Find

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>En space</td>
<td>\N, \sn</td>
</tr>
<tr>
<td>Em space</td>
<td>\M, \sm</td>
</tr>
<tr>
<td>Numeric space</td>
<td>#, \s#</td>
</tr>
<tr>
<td>End-of-flow symbol</td>
<td>\f</td>
</tr>
<tr>
<td>` (grave)</td>
<td>\</td>
</tr>
<tr>
<td>\ (backslash)</td>
<td>\\</td>
</tr>
<tr>
<td>Discretionary hyphen</td>
<td>- (hyphen)</td>
</tr>
<tr>
<td>Nonbreaking hyphen</td>
<td>+</td>
</tr>
</tbody>
</table>
### Keyboard Shortcuts

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Suppress hyphenation symbol</td>
<td>_ (underscore)</td>
</tr>
<tr>
<td>Start of word</td>
<td>&lt;</td>
</tr>
<tr>
<td>End of word</td>
<td>&gt;</td>
</tr>
<tr>
<td><strong>With Use Wildcards turned on...</strong></td>
<td></td>
</tr>
<tr>
<td>Any number of characters</td>
<td>*</td>
</tr>
<tr>
<td>Spaces or punctuation</td>
<td></td>
</tr>
<tr>
<td>Any one character</td>
<td>?</td>
</tr>
<tr>
<td>The beginning of a line</td>
<td>^</td>
</tr>
<tr>
<td>The end of a line</td>
<td>$</td>
</tr>
<tr>
<td>Any one of the bracketed characters <code>ab</code></td>
<td>[ab]</td>
</tr>
<tr>
<td>Any character except <code>ab</code></td>
<td>[^ab]</td>
</tr>
<tr>
<td>Any character from <code>a</code> to <code>f</code></td>
<td>[a-f]</td>
</tr>
</tbody>
</table>

### Documents

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display online Help</td>
<td>Esc f h, F1</td>
</tr>
<tr>
<td>Adobe Online</td>
<td>Esc w w w</td>
</tr>
</tbody>
</table>

### Open

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>A document in a book file</td>
<td>Double-click the filename in the book window</td>
</tr>
<tr>
<td>All files in an active book window</td>
<td>Esc f Shift+o, or press and choose Open All Files in Book from the File menu</td>
</tr>
</tbody>
</table>

### Save and Close

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display the Save Document dialog box</td>
<td>Esc f a</td>
</tr>
<tr>
<td>Save a document or book</td>
<td>Esc f s, Control+s</td>
</tr>
<tr>
<td>Save all open files</td>
<td>Esc f Shift+s, or press and choose Save All Open Files from the File menu</td>
</tr>
</tbody>
</table>
# Keyboard Shortcuts

## Cancel and Undo

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cancel some FrameMaker XML Author commands</td>
<td>Esc</td>
</tr>
<tr>
<td>Undo some FrameMaker XML Author commands</td>
<td>Esc e u, Control+z</td>
</tr>
</tbody>
</table>

## Navigation within a document

<table>
<thead>
<tr>
<th>Display</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Previous page</td>
<td>Esc p p, Page Up</td>
</tr>
<tr>
<td>Next page</td>
<td>Esc p n, Page Down</td>
</tr>
<tr>
<td>First page</td>
<td>Esc p f, Alt+Page Up, or press and click the Previous Page button</td>
</tr>
<tr>
<td>Last page</td>
<td>Esc p l (lowercase L), Alt+Page Down, or press and click the Next Page button</td>
</tr>
<tr>
<td>Go to Page dialog box</td>
<td>Control+g</td>
</tr>
</tbody>
</table>

## Document redisplay

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Redisplay a document</td>
<td>Esc w r, Control+l (lowercase L)</td>
</tr>
</tbody>
</table>

## Zoom

<table>
<thead>
<tr>
<th>Zoom</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>In one zoom setting</td>
<td>Esc z i</td>
</tr>
<tr>
<td>Out one zoom setting</td>
<td>Esc z o</td>
</tr>
<tr>
<td>To fit page in window</td>
<td>Esc z p</td>
</tr>
<tr>
<td>To fit window to page</td>
<td>Esc z w</td>
</tr>
<tr>
<td>To fit window to text frame</td>
<td>Esc z f</td>
</tr>
<tr>
<td>To 100 percent</td>
<td>Esc z z</td>
</tr>
</tbody>
</table>
Hypertext documents

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Go to previous location on the hypertext stack</td>
<td>Esc v Shift+p</td>
</tr>
<tr>
<td>Go to next location on the hypertext stack</td>
<td>Esc v Shift+n</td>
</tr>
<tr>
<td>Activate a hypertext command without locking a document</td>
<td>Press Control+Alt and click an active area</td>
</tr>
<tr>
<td>Lock or unlock a document</td>
<td>Esc Shift+f l (lowercase L) k</td>
</tr>
<tr>
<td>Open Hypertext dialog box</td>
<td>Esc s h</td>
</tr>
<tr>
<td>Move focus to Hypertext dialog box</td>
<td>Esc Shift+f i h</td>
</tr>
<tr>
<td>Close Hypertext dialog box</td>
<td>Esc Shift+c h</td>
</tr>
<tr>
<td>Validate a hypertext command</td>
<td>Esc v h</td>
</tr>
<tr>
<td>Toggle FluidView locked format</td>
<td>Esc Shift+v Shift+f</td>
</tr>
</tbody>
</table>

Document utilities

Spelling Checker

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Check selected text or a word containing the insertion point</td>
<td>Esc l (lowercase L) s, or press Control and click Start Checking in the Spelling Checker dialog box</td>
</tr>
<tr>
<td>Check the entire document</td>
<td>Esc l (lowercase L) e</td>
</tr>
<tr>
<td>Check the current page</td>
<td>Esc l (lowercase L) p</td>
</tr>
<tr>
<td>Correct a word</td>
<td>Esc l (lowercase L) c w</td>
</tr>
<tr>
<td>Add a word to your personal dictionary (learn)</td>
<td>Esc l (lowercase L) a p</td>
</tr>
<tr>
<td>Add a word to the document dictionary</td>
<td>Esc l (lowercase L) a d</td>
</tr>
<tr>
<td>Add a word to automatic corrections</td>
<td>Esc l (lowercase L) a c</td>
</tr>
<tr>
<td>Delete a word from your personal dictionary (unlearn)</td>
<td>Esc l (lowercase L) x p</td>
</tr>
<tr>
<td>Delete a word from the document dictionary</td>
<td>Esc l (lowercase L) x d</td>
</tr>
<tr>
<td>Clear automatic corrections</td>
<td>Esc l (lowercase L) c a</td>
</tr>
<tr>
<td>Display the Spelling Checker Options dialog box</td>
<td>Esc l (lowercase L) Shift+o</td>
</tr>
<tr>
<td>Display the Dictionary Functions dialog box</td>
<td>Esc l (lowercase L) c d</td>
</tr>
<tr>
<td>Create a file of unknown words</td>
<td>Esc l (lowercase L) b</td>
</tr>
<tr>
<td>Mark all paragraphs for rechecking</td>
<td>Esc l (lowercase L) r</td>
</tr>
<tr>
<td>Show a word’s hyphenation</td>
<td>Esc l (lowercase L) hyphen</td>
</tr>
<tr>
<td>Rehyphenate a document</td>
<td>Esc l (lowercase L) Shift+r</td>
</tr>
<tr>
<td>Replace a questioned word</td>
<td>Double-click the word in the Correction scroll list in the Spelling Checker dialog box</td>
</tr>
</tbody>
</table>
**Thesaurus**

To use this shortcut, the document window, not the Thesaurus, must be active.

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Replace a selection with the Thesaurus selection</td>
<td>Esc Shift+t r</td>
</tr>
</tbody>
</table>

**Document comparison**

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display the Compare Documents dialog box</td>
<td>Esc f t c</td>
</tr>
</tbody>
</table>

**Document reports**

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display the Document Reports dialog box</td>
<td>Esc f t r</td>
</tr>
</tbody>
</table>

**Reference Updating**

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display the Suppress Automatic Reference Updating dialog box</td>
<td>Esc e Shift+s</td>
</tr>
</tbody>
</table>

**Text**

**Insertion point movement**

Use these shortcuts to move the insertion point.

<table>
<thead>
<tr>
<th>To move to</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Next character</td>
<td>Right arrow</td>
</tr>
<tr>
<td>Previous character</td>
<td>left arrow</td>
</tr>
<tr>
<td>Beginning of a word</td>
<td>Control+left arrow</td>
</tr>
<tr>
<td>End of a word</td>
<td>Control+right arrow</td>
</tr>
<tr>
<td>Beginning of the next word</td>
<td>Esc b w</td>
</tr>
<tr>
<td>Beginning of a line</td>
<td>Home</td>
</tr>
<tr>
<td>End of a line</td>
<td>End</td>
</tr>
<tr>
<td>Previous line</td>
<td>up arrow</td>
</tr>
<tr>
<td>Next line</td>
<td>Down Arrow</td>
</tr>
<tr>
<td>Beginning of a sentence</td>
<td>Control+Home</td>
</tr>
<tr>
<td>End of a sentence</td>
<td>Control+End</td>
</tr>
<tr>
<td>Beginning of the next sentence</td>
<td>Esc b s</td>
</tr>
</tbody>
</table>
**Keyboard Shortcuts**

**Insertion point placement**

Use these shortcuts to put the insertion point in an unrotated text frame on the current page. The draw order is the order in which FrameMaker XML Author displays objects on a page; the first object in the draw order is the one at the back.

<table>
<thead>
<tr>
<th>To move to</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beginning of a paragraph</td>
<td>Control+up arrow</td>
</tr>
<tr>
<td>End of the current paragraph</td>
<td>Control+Down Arrow</td>
</tr>
<tr>
<td>Beginning of the next paragraph</td>
<td>Esc b p</td>
</tr>
<tr>
<td>Top of a column</td>
<td>Control+Page Up</td>
</tr>
<tr>
<td>Bottom of a column</td>
<td>Control+Page Down</td>
</tr>
<tr>
<td>Beginning of a flow</td>
<td>Alt+Shift+Page Up</td>
</tr>
<tr>
<td>End of a flow</td>
<td>Alt+Shift+Page Down</td>
</tr>
<tr>
<td>Start of first visible text flow</td>
<td>Control+Shift+i</td>
</tr>
</tbody>
</table>

**Text selection**

Click in text before using these shortcuts. If you use a shortcut with text already selected, FrameMaker XML Author extends the selection.

<table>
<thead>
<tr>
<th>To select</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Next character</td>
<td>Esc h c, Esc Shift+h c, Shift+right arrow</td>
</tr>
<tr>
<td>Previous character</td>
<td>Esc Shift+h Shift+c, Shift+left arrow</td>
</tr>
<tr>
<td>Current word, then next word</td>
<td>Esc h w, Esc Shift+h w, Control+Shift+right arrow</td>
</tr>
<tr>
<td>Current word, then previous word</td>
<td>Esc Shift+h Shift+w, Control+Shift+left arrow</td>
</tr>
<tr>
<td>Current sentence, then next sentence</td>
<td>Esc h s, Esc Shift+h s, Control+Shift+End</td>
</tr>
<tr>
<td>Current sentence, then previous sentence</td>
<td>Esc Shift+h Shift+s, Control+Shift+Home</td>
</tr>
<tr>
<td>Current line, then next line</td>
<td>Esc Shift+h l (lowercase L) Esc h l (lowercase L)</td>
</tr>
<tr>
<td>Current line, then previous line</td>
<td>Esc Shift+h Shift+l (L)</td>
</tr>
<tr>
<td>Current paragraph, then next paragraph</td>
<td>Esc h p, Esc Shift+h p, Control+Shift+Down Arrow</td>
</tr>
<tr>
<td>Current paragraph, then previous paragraph</td>
<td>Esc Shift+h Shift+p, Control+Shift+up arrow</td>
</tr>
<tr>
<td>One line width of text, starting at insertion point</td>
<td>Esc h d, Shift+Down Arrow</td>
</tr>
<tr>
<td>One line width of text, ending at insertion point</td>
<td>Esc h u, Shift+up arrow</td>
</tr>
<tr>
<td>To top of a column</td>
<td>Esc h t, Shift+Page Up</td>
</tr>
<tr>
<td>To bottom of a column</td>
<td>Esc h m, Shift+Page Down</td>
</tr>
</tbody>
</table>
### Keyboard Shortcuts

#### To select

<table>
<thead>
<tr>
<th>To</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>To beginning of flow</td>
<td>Esc h g, Control+Shift+Page Up</td>
</tr>
<tr>
<td>To end of flow</td>
<td>Esc h n, Control+Shift+Page Down</td>
</tr>
<tr>
<td>All text around the insertion point that has the same character format</td>
<td>Esc h +Shift+f</td>
</tr>
</tbody>
</table>

#### To Shift the selection

<table>
<thead>
<tr>
<th>To</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Right one character</td>
<td>Esc h f</td>
</tr>
<tr>
<td>Left one character</td>
<td>Esc h b</td>
</tr>
</tbody>
</table>

#### To extend or shorten a text selection

<table>
<thead>
<tr>
<th>To</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Extend or shorten a text selection</td>
<td>Press and click where you want the selection to begin or end</td>
</tr>
<tr>
<td>Remove highlighting</td>
<td>Esc h zero</td>
</tr>
<tr>
<td>Select a word</td>
<td>Double-click the word</td>
</tr>
<tr>
<td>Select a word, then next words</td>
<td>Double-click the word and then drag</td>
</tr>
<tr>
<td>Deselect a text frame or text line and place the insertion point in it</td>
<td>Double-click in the text frame or text line</td>
</tr>
</tbody>
</table>

#### Text editing

<table>
<thead>
<tr>
<th>To</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select a paragraph</td>
<td>Triple-click the paragraph</td>
</tr>
<tr>
<td>Select a paragraph, then next paragraphs</td>
<td>Triple-click the paragraph and then drag</td>
</tr>
<tr>
<td>Transpose characters</td>
<td>Control+F9</td>
</tr>
<tr>
<td>Cut</td>
<td>Esc e x, Control+x, Shift+Delete</td>
</tr>
<tr>
<td>Copy</td>
<td>Esc e c, Control+c</td>
</tr>
<tr>
<td>Paste text that you cut or copied</td>
<td>Esc e p, Control+v, Control+y</td>
</tr>
<tr>
<td>Quick-copy text</td>
<td>Click where you want to place the copied text. Then press Alt and drag through the text you want to copy.</td>
</tr>
</tbody>
</table>

#### Asian text

<table>
<thead>
<tr>
<th>To</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type rubi text</td>
<td>Esc s r</td>
</tr>
</tbody>
</table>
Text deletion

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Previous character</td>
<td>Backspace</td>
</tr>
<tr>
<td>Backward to the end of the previous word</td>
<td>Control+h</td>
</tr>
<tr>
<td>Backward to the end of the previous sentence</td>
<td>Esc k a</td>
</tr>
<tr>
<td>Next character</td>
<td>Delete</td>
</tr>
<tr>
<td>Forward to the end of a word</td>
<td>Esc k f, Control+Delete</td>
</tr>
<tr>
<td>Forward to the end of a line</td>
<td>Control+Shift+Delete</td>
</tr>
<tr>
<td>Forward to the start of the next sentence</td>
<td>Esc k s</td>
</tr>
</tbody>
</table>

Capitalization

Use these shortcuts to change the capitalization of selected text.

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change the current word to all lowercase</td>
<td>Control+Alt+l (lowercase L), Control+Alt+Shift+L</td>
</tr>
<tr>
<td>Change the current word to all uppercase</td>
<td>Control+Alt+u, Control+Alt+Shift+u</td>
</tr>
<tr>
<td>Change the current word to initial caps</td>
<td>Control+Alt+c</td>
</tr>
<tr>
<td>Display the Capitalization dialog box</td>
<td>Esc e Shift+c</td>
</tr>
</tbody>
</table>

Track Text Edit

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Turn on or off the Track Text Edit feature</td>
<td>Esc s t o</td>
</tr>
<tr>
<td>Show Next Text Edit</td>
<td>Esc s t n</td>
</tr>
<tr>
<td>Show Previous Text Edit</td>
<td>Esc s t p</td>
</tr>
<tr>
<td>Accept Edit</td>
<td>Esc s t a</td>
</tr>
<tr>
<td>Reject Edit</td>
<td>Esc s t r</td>
</tr>
<tr>
<td>Accept All</td>
<td>Esc s t Shift+a</td>
</tr>
<tr>
<td>Reject All</td>
<td>Esc s t Shift+r</td>
</tr>
<tr>
<td>Preview Final</td>
<td>Esc s t Shift+f</td>
</tr>
<tr>
<td>Preview Original</td>
<td>Esc s t Shift+o</td>
</tr>
<tr>
<td>Preview Off</td>
<td>Esc s p o</td>
</tr>
</tbody>
</table>
Conditional text display

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display the Show/Hide Conditional Text dialog box</td>
<td>Esc v Shift+c</td>
</tr>
<tr>
<td>Turn condition indicators on or off</td>
<td>Esc v Shift+o</td>
</tr>
<tr>
<td>Select all text around the insertion point that has the same condition tag settings</td>
<td>Esc h Shift+c</td>
</tr>
</tbody>
</table>

Conditional text window

To use these shortcuts, click in the Conditional Text window.

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move all condition tags to the As Is scroll list</td>
<td>Shift+F8</td>
</tr>
<tr>
<td>Change the scroll lists to match the condition tag settings of selected text</td>
<td>Shift+F9</td>
</tr>
<tr>
<td>Move a condition tag between the In and the Not In scroll lists</td>
<td>Double-click the tag</td>
</tr>
<tr>
<td>Move a condition tag from the As Is to the In scroll list</td>
<td>Double-click the tag in the As Is scroll list</td>
</tr>
</tbody>
</table>

Condition tags

Use these shortcuts to change the condition tag settings of selected text or table rows.

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apply a condition tag to selected text by typing the first characters of the tag and then pressing Return</td>
<td>Esc q Shift+c, Control+4</td>
</tr>
<tr>
<td>Remove a condition tag from selected text by typing the first characters of the tag and then pressing Return</td>
<td>Esc q Shift+d, Control+5</td>
</tr>
<tr>
<td>Make the selected text unconditional</td>
<td>Esc q Shift+u, Control+6</td>
</tr>
</tbody>
</table>

Editing text

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cut</td>
<td>Esc e x, Shift+Delete, Control+x</td>
</tr>
<tr>
<td>Copy</td>
<td>Esc e c, Control+c</td>
</tr>
<tr>
<td>Paste</td>
<td>Esc e p, Control+y, Control+v</td>
</tr>
<tr>
<td>Undo/Redo</td>
<td>Esc e u, Control+ Shift+z, Control+ z</td>
</tr>
<tr>
<td>Quick-copy text</td>
<td>Click where you want to put the copied text and then press Alt and drag through the text</td>
</tr>
<tr>
<td>Transpose characters</td>
<td>Click between characters and then press Control+F9</td>
</tr>
<tr>
<td>Make selected text lowercase</td>
<td>Alt+Control+I (lowercase L)</td>
</tr>
</tbody>
</table>
### Keyboard Shortcuts

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Make selected text uppercase</td>
<td>Alt+Control+u</td>
</tr>
<tr>
<td>Make selected text initial caps</td>
<td>Alt+Control+c</td>
</tr>
<tr>
<td>Select a word</td>
<td>Double-click it</td>
</tr>
<tr>
<td>Select a word, then next words</td>
<td>Double-click it and drag, double-click it and Shift-click</td>
</tr>
<tr>
<td>Select current sentence, then next</td>
<td>Press Esc h s, press Control+ Shift+End</td>
</tr>
<tr>
<td>Select current sentence, then previous</td>
<td>Press Esc Shift+h Shift+s, press Control+ Shift+Home</td>
</tr>
<tr>
<td>Select a paragraph</td>
<td>Triple-click it</td>
</tr>
<tr>
<td>Select a paragraph, then next paragraphs</td>
<td>Triple-click it and drag, triple-click it and Shift-click</td>
</tr>
<tr>
<td>Delete previous character</td>
<td>Backspace</td>
</tr>
<tr>
<td>Delete backward to start of the previous word</td>
<td>Esc k b</td>
</tr>
<tr>
<td>Delete backward to end of the previous sentence</td>
<td>Esc k a</td>
</tr>
<tr>
<td>Delete next character</td>
<td>Delete</td>
</tr>
<tr>
<td>Delete forward to end of a word</td>
<td>Esc k f, Control+Delete</td>
</tr>
<tr>
<td>Delete forward to end of a line</td>
<td>Control+Shift+Delete</td>
</tr>
<tr>
<td>Delete forward to start of the next sentence</td>
<td>Esc k s</td>
</tr>
</tbody>
</table>

### Entering special characters

<table>
<thead>
<tr>
<th>Character</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>(bullet)</td>
<td>Control+q %</td>
</tr>
<tr>
<td>† (dagger)</td>
<td>Control+q space</td>
</tr>
<tr>
<td>‡ (double dagger)</td>
<td>Control+q `</td>
</tr>
<tr>
<td>™ (trademark)</td>
<td>Control+q *</td>
</tr>
<tr>
<td>© (copyright)</td>
<td>Control+q )</td>
</tr>
<tr>
<td>® (registered trademark)</td>
<td>Control+q (</td>
</tr>
<tr>
<td>¶ (paragraph symbol)</td>
<td>Control+q &amp;</td>
</tr>
<tr>
<td>§ (section symbol)</td>
<td>Control+q §</td>
</tr>
<tr>
<td>… (ellipsis)</td>
<td>Control+q Shift+i</td>
</tr>
<tr>
<td>(em dash)</td>
<td>Control+q Shift+q</td>
</tr>
<tr>
<td>(en dash)</td>
<td>Control+q Shift+p</td>
</tr>
<tr>
<td>'</td>
<td>Control+’</td>
</tr>
<tr>
<td>“</td>
<td>Esc ”</td>
</tr>
<tr>
<td>(with Smart Quotes off)</td>
<td>Control+q Shift+t</td>
</tr>
<tr>
<td>(with Smart Quotes off)</td>
<td>Control+q Shift+u</td>
</tr>
</tbody>
</table>
### Keyboard Shortcuts

#### Function keys

<table>
<thead>
<tr>
<th>Key</th>
<th>Function</th>
<th>Control</th>
<th>Shift</th>
<th>Alt</th>
</tr>
</thead>
<tbody>
<tr>
<td>F1</td>
<td>Help</td>
<td>Align top</td>
<td></td>
<td></td>
</tr>
<tr>
<td>F2</td>
<td></td>
<td>Align middle</td>
<td></td>
<td></td>
</tr>
<tr>
<td>F3</td>
<td></td>
<td>Align bottom</td>
<td></td>
<td></td>
</tr>
<tr>
<td>F4</td>
<td></td>
<td></td>
<td>Cascade</td>
<td>Exit</td>
</tr>
<tr>
<td>F5</td>
<td></td>
<td></td>
<td></td>
<td>Tile</td>
</tr>
<tr>
<td>F6</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>F7</td>
<td></td>
<td></td>
<td></td>
<td>Point on document window</td>
</tr>
</tbody>
</table>

#### Accent

<table>
<thead>
<tr>
<th>Accent</th>
<th>Press Esc, then type this</th>
<th>Followed by one of these</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>' (acute)</td>
<td>' (apostrophe)</td>
<td>a, A, e, E, i, l, o, O, u, U</td>
<td>É, é</td>
</tr>
<tr>
<td>' (grave)</td>
<td>' (left quote)</td>
<td>a, A, e, E, i, l, o, O, u, U</td>
<td>É, è</td>
</tr>
<tr>
<td>' (tilde)</td>
<td>~ (tilde)</td>
<td>a, A, n, N, a, O</td>
<td>Ñ, ð</td>
</tr>
<tr>
<td>(dieresis)</td>
<td>% (percent)</td>
<td>a, A, e, E, i, l, o, O, u, U, y, Y</td>
<td>Ù, ù</td>
</tr>
<tr>
<td>' (circumflex)</td>
<td>^ (caret)</td>
<td>a, A, e, E, i, l, o, O, u, U</td>
<td>É, è</td>
</tr>
<tr>
<td>' (ring)</td>
<td>* (asterisk)</td>
<td>a, A</td>
<td>Å, å</td>
</tr>
<tr>
<td>(cedilla)</td>
<td>, (comma)</td>
<td>c, C</td>
<td>Ç, ç</td>
</tr>
</tbody>
</table>

#### Character

<table>
<thead>
<tr>
<th>Character</th>
<th>Keyboard shortcut</th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>(with Smart Quotes off)</td>
<td>Control+q Shift+r, Alt+Control+`</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>(with Smart Quotes off)</td>
<td>Control+q Shift+s, Alt+Control+`</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Em space</td>
<td>Esc space m, Control+Shift+space</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Keyboard Shortcuts

<table>
<thead>
<tr>
<th>Keys for drawing</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Tool</strong></td>
</tr>
<tr>
<td>Arc</td>
</tr>
<tr>
<td>Graphic Frame</td>
</tr>
<tr>
<td>Adobe FreeHand</td>
</tr>
<tr>
<td>Last tool selected</td>
</tr>
<tr>
<td>Line</td>
</tr>
<tr>
<td>Object Selection</td>
</tr>
<tr>
<td>Oval</td>
</tr>
<tr>
<td>Polygon</td>
</tr>
<tr>
<td>Polyl ine</td>
</tr>
<tr>
<td>Rectangle</td>
</tr>
<tr>
<td>Rounded Rectangle</td>
</tr>
<tr>
<td>Smart Selection</td>
</tr>
<tr>
<td>Text Frame</td>
</tr>
<tr>
<td>Text Line</td>
</tr>
<tr>
<td>Vertical, horizontal, or diagonal line</td>
</tr>
<tr>
<td>Square</td>
</tr>
<tr>
<td>Circle</td>
</tr>
<tr>
<td>Circular arc</td>
</tr>
<tr>
<td>Display the Tools palette</td>
</tr>
<tr>
<td>Keep a tool active after use</td>
</tr>
<tr>
<td>Return to the Object Selection tool after drawing</td>
</tr>
</tbody>
</table>

Pen patterns

"First," "last," "next," and "previous" refer to positions in the Pen pop-up menu.

<table>
<thead>
<tr>
<th>To change pattern to</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>First pen pattern (solid)</td>
<td>Esc zero p</td>
</tr>
</tbody>
</table>
Keyboard Shortcuts

**Fill patterns**
“First,” “last,” “next,” and “previous” refer to positions in the Fill pop-up menu.

<table>
<thead>
<tr>
<th>To change pattern to</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Last pen pattern (none)</td>
<td>Esc 9 p</td>
</tr>
<tr>
<td>Next pen pattern (if at the last pattern, this does nothing)</td>
<td>Esc plus p</td>
</tr>
<tr>
<td>Previous pen pattern (if at the first pattern, this does nothing)</td>
<td>Esc minus p</td>
</tr>
</tbody>
</table>

**Line widths**
“Next” and “previous” refer to positions in the Line Widths pop-up menu.

<table>
<thead>
<tr>
<th>To change width to</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Thinnest line width</td>
<td>Esc zero w</td>
</tr>
<tr>
<td>Thickest line width</td>
<td>Esc 9 w</td>
</tr>
<tr>
<td>Next line width</td>
<td>Esc plus w</td>
</tr>
<tr>
<td>Previous line width</td>
<td>Esc minus w</td>
</tr>
</tbody>
</table>

**Line styles**
To change an object’s line style, select the style from the Line Styles pop-up menu.

To change the current dashed line style, choose a pattern in the Dashed Line Options dialog box. “First,” “last,” “next,” and “previous” refer to positions in this dialog box.

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apply the solid line style to an object</td>
<td>Esc one d s</td>
</tr>
<tr>
<td>Apply the dashed line style to an object</td>
<td>Esc one d d</td>
</tr>
<tr>
<td>Display the Dashed Line Options dialog box</td>
<td>Esc one d i</td>
</tr>
<tr>
<td>Change to the first dashed line pattern</td>
<td>Esc zero d</td>
</tr>
<tr>
<td>Change to the last dashed line pattern</td>
<td>Esc 9 d</td>
</tr>
<tr>
<td>Change to the next dashed line pattern (if at the last pattern, this does nothing)</td>
<td>Esc plus d</td>
</tr>
<tr>
<td>Change to the previous dashed line pattern (if at the first pattern, this does nothing)</td>
<td>Esc minus d</td>
</tr>
</tbody>
</table>
Server not found in the domain.
Object alignment
If only one object is selected, the object is aligned to the page or to the anchored or graphic frame that encloses the object.

<table>
<thead>
<tr>
<th>To align object along</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tops</td>
<td>Esc j t, Control+F1</td>
</tr>
<tr>
<td>Top/bottom centers</td>
<td>Esc j m, Control+F2</td>
</tr>
<tr>
<td>Bottoms</td>
<td>Esc j b, Control+F3</td>
</tr>
<tr>
<td>Left sides</td>
<td>Esc j l (lowercase L)</td>
</tr>
<tr>
<td>Left/right centers</td>
<td>Esc j c</td>
</tr>
<tr>
<td>Right sides</td>
<td>Esc j r</td>
</tr>
</tbody>
</table>

Object rotation

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rotate 90 degrees clockwise</td>
<td>Esc g plus</td>
</tr>
<tr>
<td>Rotate 90 degrees counterclockwise</td>
<td>Esc g minus</td>
</tr>
<tr>
<td>Rotate precisely by using the Rotate Selected Objects dialog box</td>
<td>Esc g t</td>
</tr>
<tr>
<td>Rotate again</td>
<td>Esc g x</td>
</tr>
<tr>
<td>Return object to its unrotated orientation (zero degrees)</td>
<td>Esc g zero</td>
</tr>
<tr>
<td>Rerotate object from its unrotated orientation to its previous orientation</td>
<td>Esc g one</td>
</tr>
<tr>
<td>Set the current orientation of an object as the new unrotated orientation</td>
<td>Esc g 9</td>
</tr>
<tr>
<td>Rotate an object arbitrarily</td>
<td>Press Alt and drag a corner or reshape handle</td>
</tr>
<tr>
<td>Constrain rotation to 45-degree increments</td>
<td>Press Alt+ and drag a corner or reshape handle</td>
</tr>
<tr>
<td>Rotate a page clockwise</td>
<td>Esc p Shift+o</td>
</tr>
<tr>
<td>Rotate a page counterclockwise</td>
<td>Esc p o</td>
</tr>
<tr>
<td>Unrotate a page</td>
<td>Esc p Shift+u</td>
</tr>
</tbody>
</table>
Graphic frames

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shrink-wrap an anchored frame (shrink the frame to an object and position the frame at the insertion point)</td>
<td>Esc m p</td>
</tr>
<tr>
<td>Unwrap an anchored frame (enlarge the frame)</td>
<td>Esc m e</td>
</tr>
<tr>
<td>Rename a selected reference frame</td>
<td>Click frame name in status bar</td>
</tr>
</tbody>
</table>

Keys for adding color

Color selection

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Keep a color selected after use</td>
<td>Press Shift and choose a color from the Color pop-up menu</td>
</tr>
<tr>
<td>Assign a color to all objects in a document, including text</td>
<td>Press Alt+ Shift and choose a color from the Color pop-up menu in the Tools palette</td>
</tr>
<tr>
<td>Display the Color Definitions dialog box</td>
<td>Press Esc v c d</td>
</tr>
</tbody>
</table>

Color views

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display Define Color Views dialog box</td>
<td>Press Esc v c v</td>
</tr>
<tr>
<td>Choose view number (1, 2, 3, 4, 5, or 6) from the Define Color Views dialog box</td>
<td>Press Esc v and then the number</td>
</tr>
</tbody>
</table>

Keys for equations

Equations pop-up menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Keyboard Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>New Small Equation</td>
<td>Esc m s</td>
</tr>
<tr>
<td>New Medium Equation</td>
<td>Esc m m</td>
</tr>
<tr>
<td>New Large Equation</td>
<td>Esc m l (lowercase L)</td>
</tr>
<tr>
<td>Shrink-Wrap Equation</td>
<td>Esc m p</td>
</tr>
<tr>
<td>Unwrap Equation</td>
<td>Esc m e</td>
</tr>
<tr>
<td>Equation Sizes</td>
<td>Esc p e</td>
</tr>
<tr>
<td>Equation Fonts</td>
<td>Esc m f</td>
</tr>
</tbody>
</table>
### Symbols page

**Greek letters**
Press Return to end the backslash sequence shown in the third column.

<table>
<thead>
<tr>
<th>Element</th>
<th>Keyboard shortcut</th>
<th>Backslash sequence</th>
</tr>
</thead>
<tbody>
<tr>
<td>(\alpha)</td>
<td>Control+Alt+a</td>
<td>(\backslash\alpha)</td>
</tr>
<tr>
<td>(\beta)</td>
<td>Control+Alt+b</td>
<td>(\backslash\beta)</td>
</tr>
<tr>
<td>(\Gamma)</td>
<td>Control+Alt+g</td>
<td>(\backslash\Gamma)</td>
</tr>
<tr>
<td>(\gamma)</td>
<td>Control+Alt+g</td>
<td>(\backslash\gamma)</td>
</tr>
<tr>
<td>(\Delta)</td>
<td>Control+Alt+d</td>
<td>(\backslash\Delta)</td>
</tr>
<tr>
<td>(\delta)</td>
<td>Control+Alt+d</td>
<td>(\backslash\delta)</td>
</tr>
<tr>
<td>(\epsilon)</td>
<td>Control+Alt+e</td>
<td>(\backslash\epsilon)</td>
</tr>
<tr>
<td>(\zeta)</td>
<td>Control+Alt+z</td>
<td>(\backslash\zeta)</td>
</tr>
<tr>
<td>(\eta)</td>
<td>Control+Alt+h</td>
<td>(\backslash\eta)</td>
</tr>
<tr>
<td>(\Theta)</td>
<td>Control+Alt+q</td>
<td>(\backslash\Theta)</td>
</tr>
<tr>
<td>(\theta)</td>
<td>Control+Alt+q</td>
<td>(\backslash\theta)</td>
</tr>
<tr>
<td>(\vartheta)</td>
<td>Control+Alt+i</td>
<td>(\backslash\vartheta)</td>
</tr>
<tr>
<td>(\iota)</td>
<td>Control+Alt+i</td>
<td>(\backslash\iota)</td>
</tr>
<tr>
<td>(\kappa)</td>
<td>Control+Alt+k</td>
<td>(\backslash\kappa)</td>
</tr>
<tr>
<td>(\Lambda)</td>
<td>Control+Alt+l (L)</td>
<td>(\backslash\Lambda)</td>
</tr>
<tr>
<td>(\lambda)</td>
<td>Control+Alt+l</td>
<td>(\backslash\lambda) (\text{(lowercase L)})</td>
</tr>
<tr>
<td>(\mu)</td>
<td>Control+Alt+m</td>
<td>(\backslash\mu)</td>
</tr>
<tr>
<td>(\nu)</td>
<td>Control+Alt+n</td>
<td>(\backslash\nu)</td>
</tr>
<tr>
<td>Element</td>
<td>Keyboard shortcut</td>
<td>Backslash sequence</td>
</tr>
<tr>
<td>---------</td>
<td>------------------</td>
<td>-------------------</td>
</tr>
<tr>
<td>Ξ</td>
<td>Control+Alt+Shift+x</td>
<td>\Xi</td>
</tr>
<tr>
<td>ς</td>
<td>Control+Alt+x</td>
<td>\x</td>
</tr>
<tr>
<td>Π</td>
<td>Control+Alt+Shift+p</td>
<td>\Pi</td>
</tr>
<tr>
<td>π</td>
<td>Control+Alt+p</td>
<td>\pi</td>
</tr>
<tr>
<td>ρ</td>
<td>Control+Alt+r</td>
<td>\rho</td>
</tr>
<tr>
<td>Σ</td>
<td>Control+Alt+Shift+s</td>
<td>\Sigma</td>
</tr>
<tr>
<td>σ</td>
<td>Control+Alt+s</td>
<td>\sigma</td>
</tr>
<tr>
<td>ς</td>
<td>Control+Alt+Shift+e</td>
<td>\varsigma</td>
</tr>
<tr>
<td>τ</td>
<td>Control+Alt+t</td>
<td>\tau</td>
</tr>
<tr>
<td>γ</td>
<td>Control+Alt+Shift+u</td>
<td>\Upsilon</td>
</tr>
<tr>
<td>υ</td>
<td>Control+Alt+u</td>
<td>\upsilon</td>
</tr>
<tr>
<td>Φ</td>
<td>Control+Alt+Shift+f</td>
<td>\Phi</td>
</tr>
<tr>
<td>φ</td>
<td>Control+Alt+f</td>
<td>\phi</td>
</tr>
<tr>
<td>ϕ</td>
<td>Control+Alt+j</td>
<td>\varphi</td>
</tr>
<tr>
<td>χ</td>
<td>Control+Alt+c</td>
<td>\chi</td>
</tr>
<tr>
<td>ψ</td>
<td>Control+Alt+Shift+y</td>
<td>\Psi</td>
</tr>
<tr>
<td>υ</td>
<td>Control+Alt+y</td>
<td>\psi</td>
</tr>
<tr>
<td>Ω</td>
<td>Control+Alt+Shift+o</td>
<td>\Omega</td>
</tr>
<tr>
<td>ω</td>
<td>Control+Alt+o</td>
<td>\omega</td>
</tr>
<tr>
<td>ϖ</td>
<td>Control+Alt+Shift+i</td>
<td>\varpi</td>
</tr>
<tr>
<td>\partial</td>
<td>Control+Alt+7</td>
<td>\cpartial</td>
</tr>
</tbody>
</table>

Other special symbols
Press Return to end the backslash sequence shown in the third column.
## Keyboard Shortcuts

<table>
<thead>
<tr>
<th>Element</th>
<th>Keyboard shortcut</th>
<th>Backslash sequence</th>
</tr>
</thead>
<tbody>
<tr>
<td>\infty</td>
<td>Control+Alt+1</td>
<td>\infty</td>
</tr>
<tr>
<td>\bot</td>
<td>Control+Alt+2</td>
<td>\bot</td>
</tr>
<tr>
<td>...</td>
<td>Control+g period</td>
<td>\ldots</td>
</tr>
<tr>
<td>\aleph</td>
<td>Control+Alt+3</td>
<td>\aleph</td>
</tr>
<tr>
<td>\Im</td>
<td>Control+Alt+4</td>
<td>\Im</td>
</tr>
<tr>
<td>\Re</td>
<td>Control+m $</td>
<td>\Re</td>
</tr>
<tr>
<td>\wp</td>
<td>Control+Alt+5</td>
<td>\wp</td>
</tr>
<tr>
<td>\emptyset</td>
<td>Control+Alt+0</td>
<td>\emptyset</td>
</tr>
<tr>
<td>\nabla</td>
<td>Control+Alt+6</td>
<td>\nabla</td>
</tr>
<tr>
<td>°</td>
<td>Control+m )</td>
<td>\degree</td>
</tr>
<tr>
<td>′</td>
<td>Control+Alt+′</td>
<td>\prime</td>
</tr>
<tr>
<td>″</td>
<td>Control+m &quot;</td>
<td>\pprime</td>
</tr>
</tbody>
</table>

### Strings

<table>
<thead>
<tr>
<th>Command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start String</td>
<td>' or &quot;</td>
</tr>
<tr>
<td>End String</td>
<td>Return</td>
</tr>
</tbody>
</table>

### Diacritical marks

<table>
<thead>
<tr>
<th>Element</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>'</td>
<td>(grave)</td>
</tr>
<tr>
<td>~</td>
<td>(tilde)</td>
</tr>
<tr>
<td>Control+g hyphen</td>
<td>Control+g Shift+v</td>
</tr>
<tr>
<td>Control+g ^</td>
<td>period</td>
</tr>
<tr>
<td>Control+g ~ (tilde)</td>
<td></td>
</tr>
</tbody>
</table>
Keyboard Shortcuts

<table>
<thead>
<tr>
<th>Element</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>\underline{ }</td>
<td>Control+g _ (underline)</td>
</tr>
<tr>
<td>\rightarrow{ }</td>
<td>Control+g right arrow</td>
</tr>
<tr>
<td>\wedge{ }</td>
<td>Control+g @</td>
</tr>
</tbody>
</table>

**Operators page**

Press Return to end the backslash sequence shown in the third column.

<table>
<thead>
<tr>
<th>Element or command</th>
<th>Keyboard shortcut</th>
<th>Backslash sequence</th>
</tr>
</thead>
<tbody>
<tr>
<td>+</td>
<td>plus</td>
<td>\ plus</td>
</tr>
<tr>
<td>_</td>
<td>minus (after an operand)</td>
<td>\ minus</td>
</tr>
<tr>
<td>?x?</td>
<td>Control+m * (asterisk)</td>
<td>\ cross</td>
</tr>
<tr>
<td>? : ?</td>
<td>Control+m period</td>
<td>\ cdot</td>
</tr>
<tr>
<td>? \cdot ?</td>
<td>Control+8</td>
<td>\ bullet</td>
</tr>
<tr>
<td>Toggle Format</td>
<td>Control+Shift+t, Esc m T</td>
<td>\ fract</td>
</tr>
<tr>
<td>? / ?</td>
<td>Control+Alt+/</td>
<td>\ div</td>
</tr>
<tr>
<td>? \div ?</td>
<td>Control+m /</td>
<td>\ over</td>
</tr>
<tr>
<td>\frac{1}{x}</td>
<td>/</td>
<td>\ equal</td>
</tr>
<tr>
<td>?=?</td>
<td>=</td>
<td>\ equal</td>
</tr>
<tr>
<td>? ?</td>
<td>Control+g _ _</td>
<td>\ equal</td>
</tr>
<tr>
<td>? \diamond ?</td>
<td>Control+j</td>
<td>\ jotdot</td>
</tr>
<tr>
<td>? ?</td>
<td>comma</td>
<td>\ comma</td>
</tr>
<tr>
<td>? \times ?</td>
<td>\times</td>
<td>\times</td>
</tr>
<tr>
<td>? \oplus ?</td>
<td>\oplus</td>
<td>\oplus</td>
</tr>
<tr>
<td>? \wedge ?</td>
<td>\wedge</td>
<td>\wedge</td>
</tr>
<tr>
<td>? \vee ?</td>
<td>\vee</td>
<td>\vee</td>
</tr>
<tr>
<td>? \cap ?</td>
<td>Control+m i</td>
<td>\cap</td>
</tr>
<tr>
<td>? \cup ?</td>
<td>Control+m u</td>
<td>\cup</td>
</tr>
<tr>
<td>_ ?</td>
<td>Control+m comma</td>
<td>\ comma</td>
</tr>
<tr>
<td>Element or command</td>
<td>Keyboard shortcut</td>
<td>Backslash sequence</td>
</tr>
<tr>
<td>--------------------</td>
<td>-------------------</td>
<td>--------------------</td>
</tr>
<tr>
<td>; ?</td>
<td>;</td>
<td>\semicolon</td>
</tr>
<tr>
<td>¬ ?</td>
<td>Control+m n</td>
<td>\neg</td>
</tr>
<tr>
<td>-</td>
<td>Control+hyphen</td>
<td>\minus</td>
</tr>
<tr>
<td>± ?</td>
<td>Control+m 1</td>
<td>\mp</td>
</tr>
<tr>
<td>± ?</td>
<td>Control+q 1</td>
<td>\pm</td>
</tr>
<tr>
<td>∇ ?</td>
<td>&lt;Use the Backslash sequence&gt;</td>
<td>\grad</td>
</tr>
<tr>
<td>∇₂ ?</td>
<td>Control+q Shift+q (and add operand)</td>
<td></td>
</tr>
<tr>
<td>Δ ?</td>
<td>Control+m Control+d</td>
<td>\change</td>
</tr>
<tr>
<td>□ ?</td>
<td>Control+m x</td>
<td>\box</td>
</tr>
<tr>
<td>□ • ?</td>
<td>Control+m o</td>
<td>\boxdot</td>
</tr>
<tr>
<td>□² ?</td>
<td>Control+m 2</td>
<td>\box2</td>
</tr>
<tr>
<td>∀ ?</td>
<td>Control+m a</td>
<td>\forall</td>
</tr>
<tr>
<td>∃ ?</td>
<td>Control+m e</td>
<td>\exist</td>
</tr>
<tr>
<td>. : ?</td>
<td>Control+m t</td>
<td>\therefore</td>
</tr>
<tr>
<td>;</td>
<td>Control+a, Esc m v l</td>
<td>\atop (lowercase L)</td>
</tr>
<tr>
<td>. . ?</td>
<td>Control+m ; (semicolon), Esc m h l</td>
<td>\list (lowercase L)</td>
</tr>
<tr>
<td>??</td>
<td>* (asterisk)</td>
<td>\times</td>
</tr>
<tr>
<td></td>
<td>? !</td>
<td>Control+g</td>
</tr>
<tr>
<td>. ?</td>
<td>Esc m ^</td>
<td></td>
</tr>
<tr>
<td>. . ?</td>
<td>Esc m Control+Shift - (hyphen)</td>
<td></td>
</tr>
<tr>
<td>. ?</td>
<td>Control+m Control+^</td>
<td></td>
</tr>
<tr>
<td>. ?</td>
<td>Control+m Control+ Shift - (hyphen)</td>
<td></td>
</tr>
<tr>
<td>√ ?</td>
<td>Control+r</td>
<td>\sqrt</td>
</tr>
<tr>
<td>√ ?</td>
<td>Control+r (and add operand)</td>
<td></td>
</tr>
<tr>
<td>? × 10⁹</td>
<td>Control+Shift+e</td>
<td>\times</td>
</tr>
<tr>
<td>. ?</td>
<td>^</td>
<td>\power</td>
</tr>
</tbody>
</table>
Keyboard Shortcuts

### Large page
Press Return to end the backslash sequence shown in the third column.

Use these shortcuts to type each element on the Large page with only one operand. Then use Add Operand and Toggle Format as needed.

<table>
<thead>
<tr>
<th>Element or command</th>
<th>Keyboard shortcut</th>
<th>Backslash sequence</th>
</tr>
</thead>
<tbody>
<tr>
<td>?^</td>
<td>Control+m d</td>
<td>\dagger</td>
</tr>
<tr>
<td>??</td>
<td>!</td>
<td>\fact</td>
</tr>
<tr>
<td>??*</td>
<td>Control+m s</td>
<td>\last</td>
</tr>
<tr>
<td>\angle</td>
<td>Control+q Shift+p</td>
<td>\angle</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Element or command</th>
<th>Keyboard shortcut</th>
<th>Backslash sequence</th>
</tr>
</thead>
<tbody>
<tr>
<td>\sum</td>
<td>Control+Shift+s</td>
<td>\sum</td>
</tr>
<tr>
<td>\prod</td>
<td>Control+Shift+p</td>
<td>\prod</td>
</tr>
<tr>
<td>\int</td>
<td>Control+i</td>
<td>\int</td>
</tr>
<tr>
<td>\oint</td>
<td>NA</td>
<td>\oint</td>
</tr>
<tr>
<td>\bigcap</td>
<td>Control+m Shift+i</td>
<td>\bigcap</td>
</tr>
<tr>
<td>\bigcup</td>
<td>Control+m Shift+u</td>
<td>\bigcup</td>
</tr>
</tbody>
</table>

Add Operand: Control+Shift+n, Esc m n
Toggle Format: Control+Shift+, Esc m Shift+t

### Delimiters page
Press Return to end the backslash sequence shown in the third column.

<table>
<thead>
<tr>
<th>Element or command</th>
<th>Shortcut</th>
<th>Backslash sequence</th>
</tr>
</thead>
<tbody>
<tr>
<td>{</td>
<td>(</td>
<td>\id</td>
</tr>
<tr>
<td>[</td>
<td>(left bracket)</td>
<td>\langle</td>
</tr>
<tr>
<td>]</td>
<td>(left brace)</td>
<td>\rangle</td>
</tr>
<tr>
<td></td>
<td></td>
<td>(bar)</td>
</tr>
<tr>
<td>\langle</td>
<td>Control+m &lt;</td>
<td>\rangle</td>
</tr>
<tr>
<td>\rangle</td>
<td>Control+g</td>
<td>\langle</td>
</tr>
<tr>
<td>\langle</td>
<td>Control+g</td>
<td>\rangle</td>
</tr>
</tbody>
</table>

Last updated 8/19/2015
### Keyboard Shortcuts

<table>
<thead>
<tr>
<th>Element or command</th>
<th>Shortcut</th>
<th>Backslash sequence</th>
</tr>
</thead>
<tbody>
<tr>
<td>( ?</td>
<td>Control+m (</td>
<td>|paren )</td>
</tr>
<tr>
<td>[ ?</td>
<td>Control+m [ (left bracket)</td>
<td></td>
</tr>
<tr>
<td>{ ?</td>
<td>Control+m { (left brace)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>(bar) (and add operand)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>(bar) (and add operand)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>(bar) (add two operands)</td>
<td></td>
</tr>
<tr>
<td>&lt; ? ]</td>
<td>Control+m b</td>
<td>|bra</td>
</tr>
<tr>
<td>[ ? ]</td>
<td>Control+q i</td>
<td>|ceil</td>
</tr>
<tr>
<td>[ ?, ? ]</td>
<td>Control+m Shift+n</td>
<td>|inprod</td>
</tr>
<tr>
<td>[ ?, ? ]</td>
<td>Control+m Shift+c</td>
<td>|cmut</td>
</tr>
<tr>
<td>[ ?, ? ]</td>
<td>Control+m Shift+a</td>
<td>|cmut</td>
</tr>
<tr>
<td>_ ?</td>
<td>_ (underline)</td>
<td>|overline</td>
</tr>
<tr>
<td>&lt; ? ] ? &gt;</td>
<td>Control+m Shift+b</td>
<td>|bket</td>
</tr>
<tr>
<td>[ ? ]</td>
<td>Control+q k</td>
<td>|floor</td>
</tr>
<tr>
<td>( ? ) ( ? )</td>
<td>Control+m h</td>
<td>|choice</td>
</tr>
<tr>
<td>\xx</td>
<td>Control+m Shift+d</td>
<td>|downbrace</td>
</tr>
<tr>
<td>\xx</td>
<td>Control+m Shift+p</td>
<td>|upbrace</td>
</tr>
</tbody>
</table>

### Toggle Format

- **Toggle Format**: Control+Shift+t, Esc m T
- **Remove Parentheses**: Esc m r p

### Relations page

Press Return to end the backslash sequence shown in the third column.

<table>
<thead>
<tr>
<th>Element</th>
<th>Shortcut</th>
<th>Backslash sequence</th>
</tr>
</thead>
<tbody>
<tr>
<td>? &lt; ?</td>
<td>&lt;</td>
<td>|lessthan</td>
</tr>
<tr>
<td>? &gt; ?</td>
<td>&gt;</td>
<td>|greaterthan</td>
</tr>
<tr>
<td>? = ?</td>
<td>=</td>
<td>|equal</td>
</tr>
</tbody>
</table>

*Last updated 8/19/2015*
<table>
<thead>
<tr>
<th>Element</th>
<th>Shortcut</th>
<th>Backslash sequence</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\sim$</td>
<td>Control+m ~ (tilde)</td>
<td>\sim</td>
</tr>
<tr>
<td>$\subseteq$</td>
<td>Control+q Shift+l (L)</td>
<td>\subset</td>
</tr>
<tr>
<td>$\supseteq$</td>
<td>Control+q plus</td>
<td>\supset</td>
</tr>
<tr>
<td>$\Perp$</td>
<td>Control+m r</td>
<td>\perp</td>
</tr>
<tr>
<td>$\leq$</td>
<td>Control+g &lt;</td>
<td>\leq</td>
</tr>
<tr>
<td>$\geq$</td>
<td>Control+g &gt;</td>
<td>\geq</td>
</tr>
<tr>
<td>$\equiv$</td>
<td>Control+q : (colon)</td>
<td>\equiv</td>
</tr>
<tr>
<td>$\approx$</td>
<td>Control+q ; (semicolon)</td>
<td>\approx</td>
</tr>
<tr>
<td>$\subseteq$</td>
<td>Control+q Shift+j</td>
<td>\subseteqq</td>
</tr>
<tr>
<td>$\supseteq$</td>
<td>Control+q Shift+m</td>
<td>\supseteqq</td>
</tr>
<tr>
<td>$\Leftarrow$</td>
<td>Control+q \</td>
<td>\Leftarrow</td>
</tr>
<tr>
<td>$\Rightarrow$</td>
<td>Control+q ^</td>
<td>\Rightarrow</td>
</tr>
<tr>
<td>$\ll$</td>
<td>Control+q l (lowercase L)</td>
<td>\ll</td>
</tr>
<tr>
<td>$\gg$</td>
<td>Control+q g</td>
<td>\gg</td>
</tr>
<tr>
<td>$\neq$</td>
<td>Control+q =</td>
<td>\notequal</td>
</tr>
<tr>
<td>$\cong$</td>
<td>@</td>
<td>\cong</td>
</tr>
<tr>
<td>$\in$</td>
<td>Control+q Shift+n</td>
<td>\in</td>
</tr>
<tr>
<td>$\ni$</td>
<td>Control+`</td>
<td>\ni</td>
</tr>
<tr>
<td>$\notin$</td>
<td>Control+q Shift+o</td>
<td>\notin</td>
</tr>
</tbody>
</table>
## Keyboard Shortcuts

<table>
<thead>
<tr>
<th>Element or command</th>
<th>Shortcut</th>
<th>Backslash sequence</th>
</tr>
</thead>
<tbody>
<tr>
<td>( f )?</td>
<td>Control+i</td>
<td>\int</td>
</tr>
<tr>
<td>( \oint )?</td>
<td>Control+Shift+i</td>
<td>\oint</td>
</tr>
<tr>
<td>Add Operand</td>
<td>Control+Shift+n, Esc m n</td>
<td></td>
</tr>
<tr>
<td>Toggle Format</td>
<td>Control+Shift+t, Esc m T</td>
<td></td>
</tr>
<tr>
<td>( \frac{d}{dt} )</td>
<td>Control+g t</td>
<td>\optotal</td>
</tr>
<tr>
<td>( \frac{d}{dy} )</td>
<td>Control+g Shift+t</td>
<td></td>
</tr>
<tr>
<td>( \frac{\partial}{\partial y} )</td>
<td>Control+g p</td>
<td>\opartial</td>
</tr>
<tr>
<td>( \frac{\partial}{\partial x} )</td>
<td>Control+g Shift+p</td>
<td></td>
</tr>
<tr>
<td>( \frac{d^2}{dt^2} )</td>
<td>Control+g t (and add operand)</td>
<td></td>
</tr>
<tr>
<td>( \frac{d^2}{dy^2} )</td>
<td>Control+g Shift+t (and add operand)</td>
<td></td>
</tr>
<tr>
<td>( \frac{\partial^2}{\partial y^2} )</td>
<td>Control+g p (and add operand)</td>
<td></td>
</tr>
<tr>
<td>( \frac{\partial^2}{\partial t^2} )</td>
<td>Control+g Shift+p (and add operand)</td>
<td></td>
</tr>
</tbody>
</table>

### Calculus page

Press Return to end the backslash sequence shown in the third column.

Use these shortcuts to type each element on the Large page with only one operand. Then use Add Operand and Toggle Format as needed.
Keyboard Shortcuts

<table>
<thead>
<tr>
<th>Element or command</th>
<th>Shortcut</th>
<th>Backslash sequence</th>
</tr>
</thead>
<tbody>
<tr>
<td>\nabla \ ?</td>
<td>Control+q Shift+q</td>
<td>\grad</td>
</tr>
<tr>
<td>\partial \ ?</td>
<td>Control+Shift+d</td>
<td>\partial</td>
</tr>
<tr>
<td>\nabla \times \ ?</td>
<td>Control+m c</td>
<td>\curl</td>
</tr>
<tr>
<td>\lim \ ?</td>
<td>Control+Shift+l (L)</td>
<td>\lim</td>
</tr>
<tr>
<td>\nabla^2 \ ?</td>
<td>Control+m l (lowercase L)</td>
<td>\lap</td>
</tr>
</tbody>
</table>

Matrices page

To insert a matrix of any size, first insert a 1 by 1 matrix. Then add rows and columns one at a time.

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add/Remove Brackets</td>
<td>Control+Shift+t</td>
</tr>
</tbody>
</table>

Matrix commands pop-up menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create 1 x 1 Matrix</td>
<td>Esc x m</td>
</tr>
<tr>
<td>Add Row</td>
<td>Esc x r</td>
</tr>
<tr>
<td>Add Column</td>
<td>Esc x c, Control+Shift+c</td>
</tr>
<tr>
<td>Matrix Transpose</td>
<td>Esc x t</td>
</tr>
<tr>
<td>Matrix Algebra</td>
<td>Esc x a</td>
</tr>
</tbody>
</table>

Matrix row height pop-up menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Toggle fixed/proportional</td>
<td>Esc m t r</td>
</tr>
</tbody>
</table>

Matrix column width pop-up menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Toggle fixed/proportional</td>
<td>Esc m t c</td>
</tr>
</tbody>
</table>

Functions page

To insert each function (except the general function and limit) from the keyboard, type its name as shown.
### Keyboard Shortcuts

**Addition pop-up menu**

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add Fractions</td>
<td>Esc m a a</td>
</tr>
<tr>
<td>Order Sum</td>
<td>Esc m a o</td>
</tr>
<tr>
<td>Order Sum Reverse</td>
<td>Esc m a Shift+o</td>
</tr>
</tbody>
</table>

**Multiplication pop-up menu**

<table>
<thead>
<tr>
<th>Command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Factor</td>
<td>Esc m u f</td>
</tr>
<tr>
<td>Factor Some</td>
<td>Esc m u Shift+f</td>
</tr>
<tr>
<td>Multiply Out</td>
<td>Esc m u m</td>
</tr>
<tr>
<td>Multiply Out Once</td>
<td>Esc m u Shift+m</td>
</tr>
<tr>
<td>Distribute</td>
<td>Esc m u d</td>
</tr>
<tr>
<td>Distribute Over Equality</td>
<td>Esc m u Shift+d</td>
</tr>
</tbody>
</table>

**Division pop-up menu**

<table>
<thead>
<tr>
<th>Command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Long Division</td>
<td>Esc m d l (lowercase L)</td>
</tr>
<tr>
<td>Remove Division</td>
<td>Esc m d d</td>
</tr>
<tr>
<td>Remove Division 1 Level</td>
<td>Esc m d Shift+d</td>
</tr>
<tr>
<td>Remove Negative Powers</td>
<td>Esc m d n</td>
</tr>
<tr>
<td>Remove Negative Powers 1 Level</td>
<td>Esc m d Shift+n</td>
</tr>
</tbody>
</table>

**Evaluation pop-up menu**

<table>
<thead>
<tr>
<th>Command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number Crunch</td>
<td>Esc m v n</td>
</tr>
<tr>
<td>Show All Digits</td>
<td>Esc m v period</td>
</tr>
<tr>
<td>Evaluate</td>
<td>Esc m v e</td>
</tr>
<tr>
<td>Evaluate Substitution</td>
<td>Esc m v s</td>
</tr>
</tbody>
</table>

---

**Element**

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Backslash sequence</th>
</tr>
</thead>
<tbody>
<tr>
<td>? ( ? )</td>
<td>Control+f</td>
</tr>
<tr>
<td>\lim</td>
<td>\function</td>
</tr>
<tr>
<td>\lim?</td>
<td>Control+Shift+l (L)</td>
</tr>
<tr>
<td>\lim</td>
<td>\lim</td>
</tr>
</tbody>
</table>
## Keyboard Shortcuts

### Rules pop-up menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enter Rule</td>
<td>Esc m r e</td>
</tr>
<tr>
<td>Apply Rule</td>
<td>Esc m r a</td>
</tr>
<tr>
<td>Designate Dummy</td>
<td>Esc m r d</td>
</tr>
</tbody>
</table>

### Other rewrites pop-up menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Simplify</td>
<td>Esc m o s</td>
</tr>
<tr>
<td>Simplify Some</td>
<td>Esc m o Shift+s</td>
</tr>
<tr>
<td>Isolate Term</td>
<td>Esc m o i</td>
</tr>
<tr>
<td>Expand First Term</td>
<td>Esc m o e</td>
</tr>
<tr>
<td>Expand All Terms</td>
<td>Esc m o Shift+e</td>
</tr>
</tbody>
</table>

### Micropositioning

The number of points shown in the following table is based on a zoom setting of 100 percent.

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move up 1 point</td>
<td>Alt+up arrow</td>
</tr>
<tr>
<td>Move down 1 point</td>
<td>Alt+Down arrow</td>
</tr>
<tr>
<td>Move left 1 point</td>
<td>Alt+left arrow</td>
</tr>
<tr>
<td>Move right 1 point</td>
<td>Alt+right arrow</td>
</tr>
<tr>
<td>Move up 6 points</td>
<td>Alt+Shift+up arrow</td>
</tr>
<tr>
<td>Move down 6 points</td>
<td>Alt+Shift+Down Arrow</td>
</tr>
<tr>
<td>Move left 6 points</td>
<td>Alt+Shift+left arrow</td>
</tr>
<tr>
<td>Move right 6 points</td>
<td>Alt+Shift+right arrow</td>
</tr>
<tr>
<td>Remove micropositioning</td>
<td>Alt+Home</td>
</tr>
</tbody>
</table>
### Left/right (alignment) pop-up menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Left</td>
<td>Esc m a l (lowercase L)</td>
</tr>
<tr>
<td>Center</td>
<td>Esc m a c</td>
</tr>
<tr>
<td>Right</td>
<td>Esc m a r</td>
</tr>
<tr>
<td>Left of =</td>
<td>Esc m a plus</td>
</tr>
<tr>
<td>Right of =</td>
<td>Esc m a =</td>
</tr>
<tr>
<td>Set Manual</td>
<td>Esc m a s</td>
</tr>
<tr>
<td>Clear Manual</td>
<td>Esc m a d</td>
</tr>
<tr>
<td>Reset Alignment</td>
<td>Esc m a Shift+r</td>
</tr>
</tbody>
</table>

### Up/down (alignment) pop-up menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Top</td>
<td>Esc m a t</td>
</tr>
<tr>
<td>Baseline</td>
<td>Esc m a Shift+b</td>
</tr>
<tr>
<td>Bottom</td>
<td>Esc m a b</td>
</tr>
</tbody>
</table>

### Line breaking pop-up menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Keyboard Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set Manual</td>
<td>Esc m b s</td>
</tr>
<tr>
<td>Clear Manual</td>
<td>Esc m b c</td>
</tr>
</tbody>
</table>

### Navigating in an equation

#### Moving the insertion point

<table>
<thead>
<tr>
<th>Move</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Left</td>
<td>left arrow</td>
</tr>
<tr>
<td>Right</td>
<td>Right arrow</td>
</tr>
<tr>
<td>From beside a fraction to the numerator</td>
<td>Down Arrow</td>
</tr>
</tbody>
</table>

#### Changing the selection

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select next prompt</td>
<td>Tab</td>
</tr>
<tr>
<td>Increase scope of selection</td>
<td>space</td>
</tr>
<tr>
<td>Select next element to the left</td>
<td>left arrow</td>
</tr>
<tr>
<td>Select next element to the right</td>
<td>Right arrow</td>
</tr>
</tbody>
</table>
Moving math elements while retaining algebraic equivalency

<table>
<thead>
<tr>
<th>Move</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Left</td>
<td>Shift+left arrow</td>
</tr>
<tr>
<td>Right</td>
<td>Shift+right arrow</td>
</tr>
<tr>
<td>Up</td>
<td>Shift+up arrow</td>
</tr>
<tr>
<td>Down</td>
<td>Shift+Down Arrow</td>
</tr>
<tr>
<td>To far left</td>
<td>Control+Alt+left arrow</td>
</tr>
<tr>
<td>To far right</td>
<td>Control+Alt+right arrow</td>
</tr>
<tr>
<td>Left into expression</td>
<td>Control+Shift+left arrow</td>
</tr>
<tr>
<td>Right into expression</td>
<td>Control+Shift+right arrow</td>
</tr>
</tbody>
</table>

Moving math elements without retaining algebraic equivalency

<table>
<thead>
<tr>
<th>Swap</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>With element on left</td>
<td>Control+m Control+left arrow</td>
</tr>
<tr>
<td>With element on right</td>
<td>Control+m Control+right arrow</td>
</tr>
</tbody>
</table>

Filter By Attribute

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open the Manage Attribute Expressions dialog box</td>
<td>Esc a c</td>
</tr>
</tbody>
</table>

Hierarchical element insert

<table>
<thead>
<tr>
<th>Key/Key action</th>
<th>Type of navigation/action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Place cursor in an element and hit Enter</td>
<td>Display the quick catalog</td>
</tr>
<tr>
<td>Right arrow</td>
<td>Display the elements available within the selected element</td>
</tr>
<tr>
<td>Left arrow</td>
<td>Hide one level hierarchy of elements</td>
</tr>
<tr>
<td>tab</td>
<td>scroll down</td>
</tr>
<tr>
<td>shift+tab</td>
<td>scroll up</td>
</tr>
<tr>
<td>Alphabets\combination of alphabets</td>
<td>Type an alphabet or combination of alphabets to select an element. For example, press B to select Body and Type T,O to go to Topic.</td>
</tr>
</tbody>
</table>
Markers and variables

Marker insertion

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert a marker</td>
<td>Esc m k</td>
</tr>
<tr>
<td>Insert a hypertext marker</td>
<td>Esc m h</td>
</tr>
</tbody>
</table>

Variable insertion

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert a variable by typing the first characters of its name and pressing Return</td>
<td>Esc q v, Control+zero</td>
</tr>
</tbody>
</table>

Working with structure

<table>
<thead>
<tr>
<th>Move the insertion point</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>To start of the current element</td>
<td>Esc s Shift+s</td>
</tr>
<tr>
<td>To end of the current element</td>
<td>Esc s Shift+e</td>
</tr>
<tr>
<td>After the next element</td>
<td>Esc s Shift+d, Alt+Control+Down Arrow</td>
</tr>
<tr>
<td>Before the previous element</td>
<td>Esc s Shift+u, Alt+Control+up arrow</td>
</tr>
<tr>
<td>Before the current element’s parent</td>
<td>Esc s Shift+b, Alt+Control+left arrow</td>
</tr>
<tr>
<td>To start of the next element’s contents</td>
<td>Esc s Shift+n, Alt+Control+right arrow</td>
</tr>
</tbody>
</table>

Select

<table>
<thead>
<tr>
<th>Select</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Current element</td>
<td>Esc h Shift+e</td>
</tr>
<tr>
<td>Next element</td>
<td>Esc h Shift+n, Alt+Control+Shift+Down Arrow</td>
</tr>
<tr>
<td>Previous element</td>
<td>Esc h Shift+p, Alt+Control+Shift+up arrow</td>
</tr>
<tr>
<td>Siblings of the current element</td>
<td>Esc h Shift+s</td>
</tr>
<tr>
<td>Parent of the current element</td>
<td>Esc h e Shift+p, Alt+Control+Shift+left arrow</td>
</tr>
<tr>
<td>Up by one element</td>
<td>Alt+Control+Shift+up arrow</td>
</tr>
<tr>
<td>Down by one element</td>
<td>Alt+Control+ Down Arrow</td>
</tr>
</tbody>
</table>

Structure view

<table>
<thead>
<tr>
<th>Structure view</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Expand/Collapse all elements under the selected element</td>
<td>Esc E r</td>
</tr>
<tr>
<td>Expand/Collapse selected element</td>
<td>Esc E x</td>
</tr>
<tr>
<td>Expand / Collapse all sibling elements</td>
<td>Esc E X</td>
</tr>
</tbody>
</table>
### Keyboard Shortcuts

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>To include the parent</td>
<td>Alt+Control+Shift+left arrow</td>
</tr>
<tr>
<td>Insert element</td>
<td>Esc Shift+e i, Control+1 (one)</td>
</tr>
<tr>
<td>Wrap element</td>
<td>Esc Shift+e w, Control+2</td>
</tr>
<tr>
<td>Unwrap element</td>
<td>Esc Shift+e u</td>
</tr>
<tr>
<td>Change element</td>
<td>Esc Shift+e c, Control+3</td>
</tr>
<tr>
<td>Merge into first element</td>
<td>Esc Shift+e m</td>
</tr>
<tr>
<td>Merge into last element</td>
<td>Esc Shift+e Shift+m</td>
</tr>
<tr>
<td>Move element up one level</td>
<td>Esc Shift+e Shift+p</td>
</tr>
<tr>
<td>Move element down one level</td>
<td>Esc Shift+e Shift+d</td>
</tr>
<tr>
<td>Transpose element with previous element</td>
<td>Esc Shift+e Shift+t</td>
</tr>
<tr>
<td>Transpose element with next element</td>
<td>Esc Shift+e t</td>
</tr>
<tr>
<td>Split element</td>
<td>Esc Shift+e s</td>
</tr>
<tr>
<td>Edit attribute value</td>
<td>Control+7</td>
</tr>
<tr>
<td>Repeat last Element Catalog command</td>
<td>Esc e e</td>
</tr>
<tr>
<td>Toggle display of element boundaries (as brackets)</td>
<td>Esc v Shift+e</td>
</tr>
<tr>
<td>Toggle display of element boundaries (as tags)</td>
<td>Esc v Shift+t</td>
</tr>
<tr>
<td>Validate a document</td>
<td>Esc Shift+e v</td>
</tr>
<tr>
<td>Display Structure View</td>
<td>Esc Shift+e Shift+v</td>
</tr>
</tbody>
</table>

### Element menu

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Merge</td>
<td>Esc Shift+e m</td>
</tr>
<tr>
<td>Split</td>
<td>Esc Shift+e s</td>
</tr>
<tr>
<td>Unwrap</td>
<td>Esc Shift+e u</td>
</tr>
<tr>
<td>Edit Attributes</td>
<td>Esc Shift+e Shift+a</td>
</tr>
<tr>
<td>Choose the Element Catalog</td>
<td>Esc Shift+e Shift+c</td>
</tr>
<tr>
<td>Choose Set Available Elements</td>
<td>Esc Shift+e Shift+o Shift+c</td>
</tr>
<tr>
<td>Choose New Element Options</td>
<td>Esc Shift+e Shift+o Shift+i</td>
</tr>
<tr>
<td>Validate</td>
<td>Esc Shift+e v</td>
</tr>
</tbody>
</table>
Other useful shortcuts

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Redraw the document display</td>
<td>Control+l (lowercase L)</td>
</tr>
<tr>
<td>Quick-copy a selected object</td>
<td>Alt and drag the object</td>
</tr>
<tr>
<td>Rotate an object arbitrarily</td>
<td>Alt and use the left or right mouse button to drag a corner or reshape handle</td>
</tr>
<tr>
<td>Move an object along vertical or horizontal axis</td>
<td>Shift and drag object</td>
</tr>
<tr>
<td>Nudge an object 1 point/6 points</td>
<td>Alt+arrow key/Alt+Shift+arrow key</td>
</tr>
<tr>
<td>Fit page in window</td>
<td>Esc z p</td>
</tr>
<tr>
<td>Fit window to page</td>
<td>Esc z w</td>
</tr>
<tr>
<td>Zoom to 100 percent</td>
<td>Esc z z</td>
</tr>
<tr>
<td>Lock or unlock a document or book</td>
<td>Esc Shift+f l (lowercase L) k</td>
</tr>
</tbody>
</table>