Trademarks
1 Step RoboPDF, ActiveEdit, ActiveTest, Authorware, Blue Sky Software, Blue Sky, Breeze, Breezo, Captivate, Central, ColdFusion, Contribute, Database Explorer, Director, Dreamweaver, Fireworks, Flash, FlashCast, FlashHelp, Flash Lite, FlashPaper, Flash Video Encoder, Flex, Flex Builder, Fontographer, FreeHand, Generator, HomeSite, JRun, MacRecorder, Macromedia, MXML, RoboEngine, RoboHelp, RoboInfo, RoboPDF, Roundtrip, Roundtrip HTML, Shockwave, SoundEdit, Studio MX, UltraDev, and WebHelp are either registered trademarks or trademarks of Macromedia, Inc. and may be registered in the United States or in other jurisdictions including internationally. Other product names, logos, designs, titles, words, or phrases mentioned within this publication may be trademarks, service marks, or trade names of Macromedia, Inc. or other entities and may be registered in certain jurisdictions including internationally.

Third-Party Information
This guide contains links to third-party websites that are not under the control of Macromedia, and Macromedia is not responsible for the content on any linked site. If you access a third-party website mentioned in this guide, then you do so at your own risk. Macromedia provides these links only as a convenience, and the inclusion of the link does not imply that Macromedia endorses or accepts any responsibility for the content on those third-party sites.

Speech compression and decompression technology licensed from Nellymoser, Inc. (www.nellymoser.com).

Sorenson™ Spark™ video compression and decompression technology licensed from Sorenson Media, Inc.

Opera ® browser Copyright © 1995-2002 Opera Software ASA and its suppliers. All rights reserved.


Visual SourceSafe is a registered trademark or trademark of Microsoft Corporation in the United States and/or other countries.

Copyright © 2005 Macromedia, Inc. All rights reserved. This manual may not be copied, photocopied, reproduced, translated, or converted to any electronic or machine-readable form in whole or in part without written approval from Macromedia, Inc. Notwithstanding the foregoing, the owner or authorized user of a valid copy of the software with which this manual was provided may print out one copy of this manual from an electronic version of this manual for the sole purpose of such owner or authorized user learning to use such software, provided that no part of this manual may be printed out, reproduced, distributed, resold, or transmitted for any other purposes, including, without limitation, commercial purposes, such as selling copies of this documentation or providing paid-for support services.

Part Number ZPF80M100A

Acknowledgments
Project Management: Sheila McGinn
Writing: Jay Armstrong
Managing Editor: Rosana Francescato
Lead Editor: Lisa Stanziano
Editing: Geta Carlson, Evelyn Eldridge, Mark Nigara
Production Management: Patrice O’Neill, Kristin Conradi, Yuko Yagi
Media Design and Production: Adam Barnett, Aaron Begley, Paul Benkman, John Francis, Geeta Karmarkar, Masayo Noda, Paul Rangel, Arena Reed, Mario Reynoso
Special thanks to Jody Bleyle, Mary Burger, Lisa Friendly, Stephanie Gowin, Bonnie Loo, Mary Ann Walsh, Erick Vera, the beta testers, and the entire Flash and Flash Player engineering and QA teams.

First Edition: September 2005

Macromedia, Inc.
601 Townsend St.
San Francisco, CA 94103
## Contents

**Introduction** ............................................................... 5
- What is Flash ................................................................. 5
- What you can do with Flash ............................................... 7
- Making a simple Flash document ........................................ 8
- About Flash Player .......................................................... 17
- What’s new in Flash ......................................................... 17
- Installing Flash ............................................................... 20

**Chapter 1: Learning Flash** ............................................. 27
- Where to start ............................................................... 28
- Get the most from the Flash documentation ........................... 33
- Accessing the Flash documentation ..................................... 34
- Accessing additional online Flash resources .......................... 39
- Choosing the right help books ........................................... 40
- Using the Flash help system .............................................. 42
- Opening the Help panel ................................................... 42
- Searching the help system ................................................ 43
- Using context-sensitive help ............................................. 44
- Printing the Flash documentation ...................................... 45
- Purchasing printed documentation ...................................... 46
- Discussing the Flash documentation with LiveDocs ............... 46
- Controlling the appearance of the Help panel ........................ 47
- Getting updates to Flash Help .......................................... 48

**Chapter 2: Flash Basics** .................................................. 49
- About Flash files ............................................................ 50
- Getting to know the workspace .......................................... 51
Introduction

Welcome to Macromedia Flash Basic 8 and Macromedia Flash Professional 8. Flash provides everything you need to create and deliver rich web content and powerful applications. Whether you’re designing motion graphics or building data-driven applications, Flash has the tools to produce great results and deliver the best user experience across multiple platforms and devices.

This guide is designed to introduce you to Flash. The tutorial in this guide leads you through the process of creating a simple Flash application.

This chapter contains the following sections:

- What is Flash .................................................. 5
- What you can do with Flash ..................................... 7
- Making a simple Flash document ................................. 8
- About Flash Player ............................................. 17
- What’s new in Flash ............................................ 17
- Installing Flash ................................................ 20

What is Flash

Flash is an authoring tool that designers and developers use to create presentations, applications, and other content that enables user interaction. Flash projects can include simple animations, video content, complex presentations, applications, and everything in between. In general, individual pieces of content made with Flash are called applications, even though they might only be a basic animation. You can make media-rich Flash applications by including pictures, sound, video, and special effects.
Flash is extremely well suited to creating content for delivery over the Internet because its files are very small. Flash achieves this through its extensive use of vector graphics. Vector graphics require significantly less memory and storage space than bitmap graphics because they are represented by mathematical formulas instead of large data sets. Bitmap graphics are larger because each individual pixel in the image requires a separate piece of data to represent it.

To build an application in Flash, you create graphics with the Flash drawing tools and import additional media elements into your Flash document. Next, you define how and when you want to use each of those elements to create the application you have in mind.

When you author content in Flash, you work in a Flash document file. Flash documents have the file extension .fla (FLA). A Flash document has four main parts:

**The Stage** is where your graphics, videos, buttons, and so on appear during playback. The Stage is described further in “Flash Basics” on page 49.

**The Timeline** is where you tell Flash when you want the graphics and other elements of your project to appear. You also use the Timeline to specify the layering order of graphics on the Stage. Graphics in higher layers appear on top of graphics in lower layers.

**The Library** panel is where Flash displays a list of the media elements in your Flash document.

**ActionScript** code allows you to add interactivity to the media elements in your document. For example, you can add code that causes a button to display a new image when the user clicks it. You can also use ActionScript to add logic to your applications. Logic enables your application to behave in different ways depending on the user’s actions or other conditions. Flash includes two versions of ActionScript, each suited to an author’s specific needs. For more information about writing ActionScript, see Learning ActionScript 2.0 in Flash in the Help panel.

Flash includes many features that make it powerful but easy to use, such as prebuilt drag-and-drop user interface components, built-in behaviors that let you easily add ActionScript to your document, and special effects that you can add to media objects.
When you have finished authoring your Flash document, you publish it using the File > Publish command. This creates a compressed version of your file with the extension .swf (SWF). You can then use Flash Player to play the SWF file in a web browser or as a stand-alone application. For an introduction to Flash Player, see “About Flash Player” on page 17.

What you can do with Flash

With the wide array of features in Flash, you can create many types of applications. The following are some examples of the kinds of applications Flash can generate:

**Animations** These include banner ads, online greeting cards, cartoons, and so on. Many other types of Flash applications include animation elements as well.

**Games** Many games are built with Flash. Games usually combine the animation capabilities of Flash with the logic capabilities of ActionScript.

**User interfaces** Many website designers use Flash to design user interfaces. The interfaces include simple navigation bars as well as much more complex interfaces. You can find an example of a navigation bar created with Flash across the top of the www.macromedia.com home page.

**Flexible messaging areas** These are areas in web pages that designers use for displaying information that may change over time. A flexible messaging area (FMA) on a restaurant website might display information about each day’s menu specials. You can find an example of an FMA on the www.macromedia.com home page. The tutorial in “Tutorial: Building Your First Flash Application” on page 95 guides you through the process of building an FMA.

**Rich Internet applications** These include a wide spectrum of applications that provide a rich user interface for displaying and manipulating remotely stored data over the Internet. A rich Internet application could be a calendar application, a price-finding application, a shopping catalog, an education and testing application, or any other application that presents remote data with a graphically rich interface.

You can find many examples of real projects created by Flash users on the Macromedia website at www.macromedia.com/cfusion/showcase/.
To build a Flash application, you typically perform the following basic steps:

1. Decide which basic tasks the application will perform.
2. Create and import media elements, such as images, video, sound, text, and so on.
3. Arrange the media elements on the Stage and in the Timeline to define when and how they appear in your application.
4. Apply special effects to media elements as you see fit.
5. Write ActionScript code to control how the media elements behave, including how the elements respond to user interactions.
6. Test your application to determine if it is working as planned and find any bugs in its construction. Test your application throughout the creation process.
7. Publish your FLA file as a SWF file that can be displayed in a web page and played back with Flash Player.

Depending on your project and your working style, you may use these steps in a different order. As you become familiar with Flash and its workflows, you will discover a style of working that suits you best.

Making a simple Flash document

To illustrate the basic steps of creating any Flash document, this section guides you through the process in a simple tutorial. This short tutorial is just a sample of the Flash workflow. More tutorials are available in “Tutorial: Building Your First Flash Application” and in Flash Tutorials.

The first step is to create a new document in Flash.

To create a new Flash document:

1. Select File > New.
2. In the New Document dialog box, Flash Document is selected by default.
   Click OK.
   In the Property inspector, the Size button displays the current Stage size setting as 550 x 400 pixels.
3. The Background color swatch is set to white. You can change the color of the Stage by clicking the swatch and selecting a different color.

![The Property inspector, showing the Stage size and background color](image)

**Drawing a circle**

After you've created your document, you are ready to add some artwork for the document.

**To draw a circle on the Stage:**

1. Select the Oval tool from the Tools panel.

![The Oval tool in the Tools panel](image)
2. Select the No Color option from the Stroke Color Picker.

![Selecting the No Color option in the Stroke Color Picker](image)

3. Select a color of your choice from the Fill Color Picker.
   Make sure the fill color contrasts well with the Stage color.

4. Draw a circle on the Stage by selecting the Oval tool and Shift-dragging on the Stage.
   Holding the Shift key constrains the Oval tool to a circle.

![The circle shape drawn on the Stage](image)
Creating a symbol

You can turn your new artwork into a reusable asset by converting it to a Flash symbol. A symbol is a media asset that can be reused anywhere in your Flash document without the need to re-create it.

**To create a symbol:**
1. Click the Selection tool in the Tools panel.

   ![Tools panel with the Selection tool selected](image)

2. Click the circle on the Stage to select it.
3. With the circle still selected, select Modify > Convert to Symbol.
4. In the Convert to Symbol dialog box, type `my_circle` into the Name text box.
   
   The default behavior is now Movie Clip.
5. Click OK.

   A square bounding box appears around the circle. You have now created a reusable asset, called a symbol, in your document.
6. The new symbol appears in the Library panel.

   If the Library panel is not open, select Window > Library.
Animating the circle

Now that you have some artwork in your document, you can make it more interesting by animating it to move across the Stage.

**To create an animation with the circle:**

1. Drag the circle to just left of the Stage area.

   ![The circle shape moved to the left of the Stage area](image)

2. Click Frame 20 of Layer 1 in the Timeline.

   ![Selecting Frame 20 of Layer 1 in the Timeline](image)
3. Select Insert > Timeline > Frame.
Flash adds frames to Frame 20, which remains selected.

4. With Frame 20 still selected, select Insert > Timeline > Keyframe.
A keyframe is added in Frame 20. A keyframe is a frame where some property of an object is explicitly changed. In this new keyframe, you will change the circle's location.

5. With Frame 20 still selected in the Timeline, drag the circle to just right of the Stage area.

6. Select Frame 1 of Layer 1 in the Timeline.
7. In the Property inspector (its default location is at the bottom of the Flash application window), select Motion from the Tween pop-up menu.

![Selecting a motion tween in the Property inspector](image)

An arrow appears in the Timeline in Layer 1 between Frame 1 and Frame 20.

![The Timeline with an arrow indicating a motion tween](image)

This step creates a tweened animation of the circle moving from its position in the first keyframe in Frame 1 to its new position in the second keyframe in Frame 20. For more information on tweening, see Chapter 10, “Creating Motion,” in Using Flash.

8. In the Timeline, drag the red playhead back and forth from frame 1 to frame 20 to preview the animation.


10. Choose a location for the file on your hard disk and name the file SimpleFlash.fla.

11. Select Control > Test Movie to test the FLA file.

12. Close the Test Movie window.
Publishing the file

When you finish your Flash document, you are ready to publish it so it can be viewed in a browser. When you publish a FLA file, Flash compresses it into the SWF file format. This is the format that you place in a web page. The Publish command can automatically generate an HTML file with the correct tags in it for you.

To publish the Flash file and view it in a browser:
1. Select File > Publish Settings.
2. In the Publish Settings dialog box, select the Formats tab and verify that only the Flash and HTML options are selected.

This action causes Flash to publish only the Flash SWF file and an HTML file. The HTML file is used to display the SWF file in a web browser.

The Flash and HTML options on the Formats tab
3. In the Publish Settings dialog box, select the HTML tab and verify that Flash Only is selected in the Template pop-up menu.

This template creates a simple HTML file that contains only your SWF file when displayed in a browser window.

![Publish Settings dialog box]

Choosing Flash Only from the Template menu

4. Click OK.

5. Select File > Publish and open your web browser.


7. Navigate to the folder where you saved your FLA file.

   The SimpleFlash.swf and SimpleFlash.html files are there. Flash creates these files when you click Publish.
8. Select the file named SimpleFlash.html.
9. Click Open.

Your Flash document is displayed in the browser window.
Congratulations! You have now completed your first Flash document.

About Flash Player

Flash Player 8, which runs the applications that you create, is installed by default when you install Flash. Flash Player ensures that all Flash SWF files are viewable and available consistently across the broadest range of platforms, browsers, and devices, including mobile phones.

Flash Player is distributed with products from every major software partner, including Microsoft, Apple, Netscape, AOL, and Opera, which brings rich content and applications to over 516 million people worldwide. Flash Player is distributed freely to anyone who wants to use it. You can get the latest version of Flash Player at the Macromedia Flash Player Download Center at www.macromedia.com/go/getflashplayer.

What’s new in Flash

Many new features in Flash are helpful to beginners. This section summarizes those new features. For a comprehensive list of new features for both beginning and advanced Flash users, see “What’s new in Flash” in Using Flash.

New Features in Flash Basic 8 and Flash Professional 8

The following are new features for beginners in Flash Basic 8 and Flash Professional 8.

Gradient enhancements  New controls allow you to apply complex gradients to objects on the Stage. You can add up to 16 colors to a gradient, precisely control the location of the gradient focal point, and apply other parameters to the gradient. Macromedia also simplified the workflow for applying gradients. For more information, see “Transforming gradient and bitmap fills” in Using Flash.
Object Drawing model  Previously in Flash, all shapes in the same layer on the Stage could affect the outlines of other overlapping shapes. You can now create shapes directly on the Stage that do not interfere with other shapes on the Stage. When you create a shape with the new Object Drawing model, the shape does not cause changes to other shapes that exist underneath the new shape. For more information, see “About Flash drawing models” in Using Flash.

FlashType  Text objects on the Stage now have a more consistent appearance in the Flash authoring tool and in Flash Player. For more information, see Chapter 6, “Working with Text” in Using Flash.

Script Assist mode  A new assisted mode in the Actions panel allows you to create scripts without detailed knowledge of ActionScript. For more information, see Chapter 13, “Writing ActionScript with Script Assist” in Using Flash.

Expanded Stage Work Area  You can use the area around the Stage to store graphics and other objects without having them appear on the Stage when you play the SWF file. Macromedia expanded this area, called the work area, to allow you to store more items there. Flash users often use the work area to store graphics they plan to animate on the Stage later, or to store objects that do not have a graphical representation during playback, such as data components.

Macintosh document tabs  You can now open multiple Flash files in the same Flash application window and choose among them by using the document tabs at the top of the window.

Improved Preferences dialog box  Macromedia streamlined the design of the Preferences dialog box and reorganized it for improved clarity and ease of use. For more information, see “Setting preferences in Flash” on page 78.

Single Library panel  You can now use a single Library panel to view the library items of multiple Flash files simultaneously. For more information, see “Managing media assets with the library” in Using Flash.

Improved publishing interface  The Publish Settings dialog box has been streamlined for easier control over your published SWF files. For more information, see Chapter 17, “Publishing” in Using Flash.
Object-level Undo mode  You can now choose to keep track of the changes you make in Flash on a per-object basis. When you use this mode, each object on the Stage and in the library has its own undo list. This allows you to undo the changes you make to an object without having to undo changes to any other object. For more information, see “Using the Undo, Redo, and Repeat menu commands” in Using Flash.

New features in Flash Professional 8 only

The following are new features for beginners available in Flash Professional 8 only:

Custom easing controls  A **tween** is the application of a change to a graphic object over a period of time. For example, you could tween the location of a picture of a car from one side of the Stage to the other to make the car move from side to side. To **ease** a tween is to control the rate at which the change is applied to the object. New easing controls in Flash allow you to precisely control how tweens that you apply in the timeline affect the appearance of tweened objects on the Stage. With the new controls, you can make an object move back and forth on the Stage within a single tween or create other complex tween effects. For more information, see “Applying custom ease in/ease out to motion tweens (Flash Professional only)” in Using Flash.

Graphics effects filters  You can apply graphics filters to objects on the Stage. These are called filters because they pass the image data of the object through an algorithm that filters the data in a specific way. With these filters, you can make objects glow, add drop shadows, and apply many other effects and combinations of effects. For more information, see “About filters (Flash Professional only)” in Using Flash.

Blend modes  You can achieve a variety of compositing effects by using blend modes to change the way the image of one object on the Stage is combined with the images of any objects beneath it. For more information, see “About blend modes (Flash Professional only)” in Using Flash.

Bitmap smoothing  Bitmap images now look much better on the Stage when greatly enlarged or reduced. The appearance of these bitmaps in the Flash authoring tool and in Flash Player is now consistent. For more information about bitmap settings, see “Setting bitmap properties” in Using Flash.
Improved text anti-aliasing  You can now apply new anti-aliasing settings that make normal and small-sized text much clearer and easier to read onscreen. For more information, see “Setting anti-aliasing options for text” in Using Flash.

New video encoder  A new video encoder application is included with Flash Professional 8. It is a separate application that provides an easy way to convert video files into the Flash Video (FLV) format. The application also allows you to perform batch processing of video files. For more information, see “Encoding video” in Using Flash.

Video alpha channel support  You can now use an alpha channel with video objects, allowing you to create transparency effects. For more information about using video in Flash, see Chapter 11, “Working with Video” in Using Flash.

Installing Flash

The following sections describe the process of installing Flash.

System requirements

Complete product system requirements and recommendations are available on the Flash system requirements web page at www.macromedia.com/go/sysreqs.

Installing and activating Flash

Installing Flash is an automated process. After installation, you can choose to run the 30-day trial mode, or you can choose to activate either Flash Basic 8 or Flash Professional 8. You must activate both editions of Flash over the Internet or phone before use, and you need your serial number to activate either edition of Flash unless you want to select the trial mode. Windows 98 SE users must have Microsoft Internet Explorer 5.1 or later in order to activate Flash over the Internet.

NOTE

Installing Macromedia Flash Basic 8 and Flash Professional 8 does not overwrite earlier Flash versions that you might have installed.
To install Flash:

1. Close any running versions of Flash before installing.
2. Do one of the following to start the installation process:
   - (Windows) If you have a CD, insert it in your CD drive. A movie clip guides you through the installation choices.
   - (Macintosh) If you have a CD, insert it in your CD drive and double-click the Installer icon.
   - If you downloaded Flash from the Internet, double-click FlashBasic8Installer.exe or FlashProfessional8Installer (Windows), or double-click the Installer icon (Macintosh) and follow the onscreen instructions.
3. When installation is complete, follow the instructions to select the 30-day trial period, or enter your serial number and activate Flash.

Upgrading from Macromedia Flash Basic 8 to Macromedia Flash Professional 8

If you've purchased Macromedia Flash Basic 8, you can upgrade to Macromedia Flash Professional 8.

To upgrade to Macromedia Flash Professional 8:

1. From Flash, select Help > Upgrade to Flash Professional 8.
2. In the dialog box that appears, do one of the following:
   - Select Buy to open a browser for the Macromedia store.
   - Select Try and follow the instructions to obtain a serial number for a trial upgrade.
     At the end of the trial period, if you do not purchase the upgrade, your application reverts to Macromedia Flash Basic 8.
Switching between trial-mode editions

If you're running the trial mode of one edition of Flash, you can change to another edition during the same trial period.

**To switch between trial modes:**
- From Flash, select Help > Switch to Flash Professional 8 or Switch to Flash Basic 8, depending on which trial mode you're already using, and which mode you want to try.
  
  A dialog box appears indicating that you must restart your computer for the change to take effect.

Purchasing a Flash edition from trial mode

If you're running Flash in trial mode, you can initiate your purchase directly from the application.

**To purchase Flash from trial mode:**
1. From Flash, select Help > Activate Macromedia Flash Basic 8.
2. In the dialog box that appears, select Buy One Online to purchase a serial number.

  A browser window opens at the Macromedia store.

Configuration folders installed with Flash

Flash Basic 8 and Flash Professional 8 place several configuration folders on your system when you install the application. The configuration folders organize files associated with the application into appropriate levels of user access. The configuration folders for Flash are as follows:

**Application-level configuration folder**  
This is the configuration folder found near the application itself. Because it is in the application level, nonadministrative users do not have write access to this directory. Typical paths to this folder are as follows:

- In Windows 2000 or Windows XP, browse to `boot drive\Program Files\Macromedia\Flash 8\language\Configuration\`.  
- On the Macintosh, browse to `Macintosh HD/Applications/ Macromedia Flash 8/Configuration/`.  

First Run folder  This folder is a sibling to the application-level configuration folder, but serves a different purpose. The First Run folder is a simple mechanism, created specifically for the Flash authoring tool, that facilitates the sharing of configuration files among users of the same computer. Folders and files in the First Run folder are automatically copied by Flash to the user-level configuration folder. Any new files placed in the First Run folder are copied to the user-level configuration folder when you start the application.

Typical paths to the First Run folder are as follows:

- In Windows 2000 or Windows XP, browse to `boot drive:\Program Files\Macromedia\Flash 8\language\First Run\`.
- On the Macintosh, browse to `Macintosh HD/Applications/Macromedia Flash 8/First Run/`.

User-level configuration folder  This is the configuration folder found in the user profile area. This folder is always writable by the current user. Typical paths to this folder are as follows:

- In Windows 2000 or Windows XP, browse to `boot drive:\Documents and Settings\username\Local Settings\Application Data\Macromedia\Flash 8\language\Configuration`.
- On the Macintosh, browse to `Macintosh HD/Users/username/Library/Application Support/Macromedia/Flash 8/language/Configuration`.

NOTE  Flash Basic 8 for Windows uses the Local Settings folder for the user-level configuration files. This use differs from Flash MX and the rest of the Studio MX family (including Dreamweaver MX 2004), which all use the Roaming Profile configuration folder for user-level configuration files. Roaming profiles allow network users to automatically store their configuration settings on a network server, and then move to different workstations on the network and always have an application load the same configuration files. The Local Settings folder differs from the Roaming Profile folder in that when the network is set up, files in Local Settings are not saved to a server to support roaming profiles.
All-user-level configuration folder  This is the configuration folder found in the common user profile area. This folder is part of the standard Windows and Macintosh operating system installations and is shared by all users of a particular computer. Any files that are placed in this folder are made available by the operating system to all users of the computer. Typical paths to this folder are as follows:

- In Windows 2000 or Windows XP, browse to \boot drive\Documents and Settings\All Users\Application Data\Macromedia\Flash 8\language\Configuration.

Restricted Users configuration folder  This is the folder for users with restricted privileges on a workstation. Typically, in a networked environment, only system administrators have administrative access to workstations. All other users are given restricted access, which usually means that these users can’t write to application-level files (such as the Program Files directory in Windows or the Applications folder in Macintosh OS X).

Changing or removing Flash Player

You can change or reinstall the current version of Flash Player.

To change or reinstall the ActiveX control for Windows (Internet Explorer or AOL):

1. Close your browser.
2. Remove any currently installed versions of the ActiveX control.
   
   For instructions, see TechNote 14157 on the Macromedia Flash Support Center at www.macromedia.com/go/tn_14157.
3. Run the Install Flash Player 8 AX.exe file in your Players folder to begin installation.
4. Open the browser.
   
   The new version of the ActiveX control should be installed.
To change or reinstall the plug-in for Windows (CompuServe, Firefox, Mozilla, Netscape, or Opera):

1. Close your browser before installing a new version of the plug-in.
2. Remove any currently installed versions of the plug-in.
   For instructions, see TechNote 14157 on the Macromedia Support Center at www.macromedia.com/go/tn_14157.
3. Run the Install Flash Player 8.exe file in your Players folder to begin installation.
4. Open the browser.
   The new version of the plug-in should be installed.

**NOTE**
To verify installation in Netscape, select Help > About Plug-ins from within the browser.

To change or reinstall the plug-in for Macintosh (AOL, CompuServe, Firefox, Internet Explorer for Macintosh, Netscape, Opera, or Safari):

1. Close your browser before installing a new version of the plug-in.
2. Remove currently installed versions of the plug-in.
   For instructions, see TechNote 14157 on the Macromedia Support Center at www.macromedia.com/go/tn_14157.
3. Run Install Flash Player 8 (Mac OS 9.x) or Install Flash Player 8 OS X (Mac OS X.x) in your Players folder to begin installation.
4. Open the browser.
   The new version of the plug-in should be installed.

**NOTE**
To verify installation in Netscape, select Help > About Plug-ins from the browser menu.
Macromedia Flash Basic 8 and Flash Professional 8 include a diverse set of tools with an extremely broad range of uses. Accordingly, the Flash Help contains a large number of books and resources. This chapter is intended to guide you through the process of determining the sections of Flash Help that are relevant to your level of experience and what you are trying to do with Flash. By understanding what Flash Help contains and how it is intended to be used, you can begin the learning process with confidence.

This chapter contains the following sections:

- Where to start ................................................................. 28
- Get the most from the Flash documentation .................... 33
- Accessing the Flash documentation ............................... 34
- Accessing additional online Flash resources .................... 39
- Choosing the right help books ......................................... 40
- Using the Flash help system ........................................... 42
- Opening the Help panel .................................................. 42
- Searching the help system ............................................. 43
- Using context-sensitive help ........................................... 44
- Printing the Flash documentation ................................... 45
- Purchasing printed documentation ................................. 46
- Discussing the Flash documentation with LiveDocs ........ 46
- Controlling the appearance of the Help panel .................. 47
- Getting updates to Flash Help ......................................... 48
Where to start

Because Flash includes several manuals that cover a wide variety of topics, it is helpful to know where to start when learning Flash. This section helps you understand how to approach the documentation, depending on what your background is and what you intend to do with Flash.

If you are completely new to Flash:

1. Begin by reading this Getting Started with Flash guide.
   “Flash Basics” provides a simple introduction to the Flash user interface and “Tutorial: Building Your First Flash Application” includes a tutorial that takes you through the entire process of creating a real-world Flash application.

2. Browse Using Flash, which provides detailed descriptions of the features in Flash and how to use them, including working with various media types, creating animation, and publishing your work.
   Using Flash also describes how to use Script Assist mode, which allows you to create ActionScript code with minimal knowledge of the ActionScript language.

3. If you want to create Flash projects that include more complex ActionScript code, you can move on to Learning ActionScript 2.0 in Flash.
   This book introduces you to the structure and techniques of the ActionScript language, and includes numerous examples. Each section describes a key concept of ActionScript and then presents details of how to accomplish specific tasks in ActionScript as well as real-world code samples that you can use.

4. After you are familiar with the basics of how ActionScript operates, you can use the ActionScript 2.0 Language Reference to find the specific terms and definitions you need for your projects.
   This book presents dictionary-style entries for each term in the ActionScript language.
   The Tutorials section of the Flash documentation contains many detailed tutorials that take you step-by-step through the process of creating various types of projects and effects in Flash.
   The Samples section contains examples of FLA files with descriptions that you can explore to see how a specific feature is implemented in real-world projects.
You are a web or graphic designer who wants to learn Flash, but not ActionScript:

1. Continue to read this *Getting Started with Flash* guide. Chapter 2, “Flash Basics” provides a simple introduction to the Flash user interface and Chapter 3, “Tutorial: Building Your First Flash Application” includes a tutorial that takes you through the entire process of creating a real-world Flash application.

2. Browse *Using Flash*, which provides detailed descriptions of the features in Flash and how to use them, including working with various media types, creating animation, and publishing your work. *Using Flash* also describes how to use Script Assist mode, which allows you to create ActionScript code with minimal knowledge of the ActionScript language.

   The *Tutorials* section of the documentation contains many detailed tutorials that take you step-by-step through the process of creating various types of projects and effects in Flash. The *Samples* section contains examples of FLA files with descriptions that you can explore to see how a specific feature is implemented in real-world projects.

If you are a web or graphic designer wanting to learn ActionScript as your first scripting language:

1. Browse the *Learning ActionScript 2.0 in Flash* guide. This guide will help you become familiar with the basic concepts common to all scripting languages, as well as the fundamentals of ActionScript. It includes many real-world code examples that help you accomplish specific tasks.

2. After you have a basic understanding of the principles of ActionScript, you can use the *ActionScript 2.0 Language Reference*. This reference is a dictionary of ActionScript that provides detailed descriptions of the use and syntax of each term in the ActionScript 2.0 language.

   The *Samples* and *Tutorials* sections of the documentation provide additional examples of specific ways to use ActionScript.
If you have previous experience with coding in a language other than ActionScript and want to learn the Flash development environment:

1. Browse the *Learning ActionScript 2.0 in Flash* guide.
   
   This guide introduces you to the conventions of ActionScript and the Flash Actions panel.

2. You can then use the *ActionScript 2.0 Language Reference* to get detailed information about each element in the ActionScript language.
   
   Each entry in the reference guide contains information on the syntax and ways to use the term, as well as code examples that you can copy and paste into the Flash Actions panel and then execute.
   
   The *Samples* and *Tutorials* sections of the documentation provide additional examples of specific ways to use ActionScript.

If you have experience with ActionScript but want to master the Flash graphic design and animation tools:

1. Browse Chapters 3 and 4 of this *Getting Started with Flash* guide.
   
   “Flash Basics” introduces you to the Flash user interface, including the drawing tools. “Tutorial: Building Your First Flash Application” consists of a tutorial that takes you through the entire process of creating a real-world Flash application.

2. Browse *Using Flash*.
   
   This guide contains chapters on each of the common workflows you will perform in Flash, as well as each of the primary media types that you will use in Flash.
   
   - Chapter 4, “Working with Color, Strokes, and Fills” describes the details of using color in Flash.
   - Chapter 5, “Drawing” describes how to use the various drawing tools in Flash.
   - Chapter 9, “Using Filters and Blends (Flash Professional only)” describes how to apply various special effects to the graphic objects in your Flash documents.
   - Chapter 10, “Creating Motion” teaches you how to create and control animation in Flash.
   
   The *Samples* and *Tutorials* sections of the documentation provide additional examples of specific Flash features and workflows.
If you have some basic understanding of Flash and you need to catch up with changes in the user interface or ActionScript:

1. For a detailed listing of the new features in Flash Basic 8 and Flash Professional 8, see "What's new in Flash" in Using Flash.
4. Read about the new graphic effects features in Chapter 9, “Using Filters and Blends (Flash Professional only)” in Using Flash.
5. Read about how to control the new graphics effects features with ActionScript in Chapter 13, “Animation, Filters, and Drawings” in Learning ActionScript 2.0 in Flash.
6. Read about the new color gradient controls in Chapter 4, “Working with Color, Strokes, and Fills” in Using Flash.
7. Read about FlashType with improved anti-aliasing and text rendering in Flash in Chapter 6, “Working with Text” in Using Flash.
8. See the tutorials listed under “Creating Graphics” in the Flash Tutorials book in Flash Help.

These tutorials demonstrate how to use features such as color gradients, tweening animation, and graphic filters.

If you are primarily interested in working with video:

1. Familiarize yourself with the Flash user interface by reading the rest of this Getting Started with Flash guide.
   Chapter 5 contains a tutorial about using video in Flash.
3. Read Chapter 15, “Working with Images, Sound, and Video” in Learning ActionScript 2.0 in Flash to learn about how to work with video files in ActionScript.
If you are a Flash developer with no mobile or device development experience:

1. Read *Developing Flash Lite Applications* to learn about the specific requirements and workflows of creating applications and content for mobile devices.
   
   Because these devices run Flash Lite player, the content you develop for them needs to be designed somewhat differently than content intended for Flash Player 8. This book describes the details of these differences, including screen size, font, performance, and file size considerations.

2. Read *Learning Flash Lite 1.x ActionScript* to learn about specific technical differences you must be aware of when writing ActionScript code for Flash Lite player.

3. Consult the *Flash Lite 1.x ActionScript Language Reference* for dictionary-style entries for all of the ActionScript elements available to applications running on Flash Lite player.

If you are a mobile or device developer with no Flash experience:

1. Finish reading this *Getting Started with Flash* guide.
   
   This guide introduces you to the Flash interface and provides a tutorial that describes the process of building and publishing an application in Flash.

2. Read *Getting Started with Flash Lite*.
   
   This guide provides an overview of the specific authoring processes for creating Flash Lite content.

3. Look at the key topic list in the *Developing Flash Lite Applications* book.

If you are a Flash Lite 1.1 developer who needs an introduction to Flash Professional 8 workflows:

1. Read *Getting Started with Flash Lite*.
   
   This guide introduces you to the new mobile authoring features in Flash Professional 8.

2. Read Chapter 5, “Testing Flash Lite Content (Flash Professional Only)” in *Developing Flash Lite Applications* to learn about the new Flash Lite emulator and other mobile testing features in Flash Professional 8.

3. See the new *Flash Lite 1.x Language Reference*, a complete language reference for all Flash Lite 1.0 and Flash Lite 1.1 ActionScript, including code examples.
Get the most from the Flash documentation

The Macromedia Flash help system contains a great deal of information and resources that describe the full range of Flash authoring capabilities and the ActionScript language. Many online resources are also available to help you learn Flash. This document is intended to help you navigate these resources and find the information that is most helpful to you in realizing your goals with Flash.

For specific information about using the Flash documentation, see the following sections:

- Accessing the Flash documentation .................. 34
- Choosing the right help books ......................... 40
- Opening the Help panel ............................... 42
- Searching the help system ......................... 43
- Using context-sensitive help ......................... 44
- Printing the Flash documentation ................. 45
- Purchasing printed documentation .................. 46
- Discussing the Flash documentation with LiveDocs .... 46
- Controlling the appearance of the Help panel .......... 47
- Getting updates to Flash Help ....................... 48
- Accessing additional online Flash resources ....... 39
Accessing the Flash documentation

The following tables summarize the documents included in the Flash help system.

You can purchase printed versions of select titles. For more information, see www.macromedia.com/go/buy_books.

### Feature information

<table>
<thead>
<tr>
<th>Title</th>
<th>Description/Audience</th>
<th>Where to Find It</th>
</tr>
</thead>
</table>
| **Getting Started with Flash** | Basic introduction to Flash concepts and interface, with a detailed beginner tutorial. Intended for beginning Flash users. | View in Flash: Select Help > Flash Help  
View online: livedocs.macromedia.com/go/livedocs_flash  
Get the PDF: www.macromedia.com/go/fl_documentation |
| **Using Flash**           | Comprehensive information about all the features of Flash except ActionScript. Intended for all Flash users. | View in Flash: Select Help > Flash Help  
View online: livedocs.macromedia.com/go/livedocs_flash  
Get the PDF: www.macromedia.com/go/fl_documentation |
| **Flash 8 Video Encoder Help** | Complete information about using the Flash 8 Video Encoder application. Intended for Flash designers creating video content. | View in Flash 8 Video Encoder: Select Help > Using Flash Video Encoder  
View online: livedocs.macromedia.com/go/livedocs_flash  
Get the PDF: www.macromedia.com/go/fl_documentation |
## Tutorials and samples

<table>
<thead>
<tr>
<th>Title</th>
<th>Description/Audience</th>
<th>Where to Find It</th>
</tr>
</thead>
<tbody>
<tr>
<td>Flash Tutorials</td>
<td>A collection of step-by-step tutorials that teach a variety of both beginning and advanced Flash techniques. Intended for all Flash users.</td>
<td>• View in Flash: Select Help &gt; Flash Help</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• View online: livedocs.macromedia.com/go/livedocs_flash</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Get the PDF: <a href="http://www.macromedia.com/go/fl_documentation">www.macromedia.com/go/fl_documentation</a></td>
</tr>
<tr>
<td>Flash Samples</td>
<td>A collection of sample files demonstrating various Flash features and techniques, with a detailed description of each one. Intended for all Flash users.</td>
<td>• View in Flash: Select Help &gt; Flash Help</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• View online: livedocs.macromedia.com/go/livedocs_flash</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Get the PDF: <a href="http://www.macromedia.com/go/fl_documentation">www.macromedia.com/go/fl_documentation</a></td>
</tr>
</tbody>
</table>
# ActionScript

<table>
<thead>
<tr>
<th>Title</th>
<th>Description/Audience</th>
<th>Where to Find It</th>
</tr>
</thead>
</table>
| **Learning ActionScript 2.0 in Flash** | A detailed introduction to coding with ActionScript, including extensive reusable code examples. Intended for beginning and intermediate ActionScript users.                                                                 | • View in Flash: Select Help > Flash Help  
• View online: [livedocs.macromedia.com/go/livedocs_flash](livedocs.macromedia.com/go/livedocs_flash)  
• Get the PDF: [www.macromedia.com/go/fl_documentation](www.macromedia.com/go/fl_documentation) |
| **ActionScript 2.0 Language Reference** | Dictionary-style reference entries for each term in the ActionScript language. Intended for all ActionScript users.                                                                                                   | • View in Flash: Select Help > Flash Help  
• View online: [livedocs.macromedia.com/go/livedocs_flash](livedocs.macromedia.com/go/livedocs_flash)  
• Get the PDF: [www.macromedia.com/go/fl_documentation](www.macromedia.com/go/fl_documentation) |
## Components

<table>
<thead>
<tr>
<th>Title</th>
<th>Description/Audience</th>
<th>Where to Find It</th>
</tr>
</thead>
<tbody>
<tr>
<td>Using Components</td>
<td>Information about how to use and customize components in your Flash documents. Intended for all Flash users.</td>
<td>• View in Flash: Select Help &gt; Flash Help&lt;br&gt;• View online: livedocs.macromedia.com/go/livedocs_flash&lt;br&gt;• Get the PDF: <a href="http://www.macromedia.com/go/fl_documentation">www.macromedia.com/go/fl_documentation</a></td>
</tr>
<tr>
<td>Components Language</td>
<td>Dictionary-style reference entries for each term in the ActionScript component API. Intended for all Flash users.</td>
<td>• View in Flash: Select Help &gt; Flash Help&lt;br&gt;• View online: livedocs.macromedia.com/go/livedocs_flash&lt;br&gt;• Get the PDF: <a href="http://www.macromedia.com/go/fl_documentation">www.macromedia.com/go/fl_documentation</a></td>
</tr>
<tr>
<td>Reference</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

## Extending Flash

<table>
<thead>
<tr>
<th>Title</th>
<th>Description/Audience</th>
<th>Where to Find It</th>
</tr>
</thead>
<tbody>
<tr>
<td>Extending Flash</td>
<td>Information about adding functionality to the Flash authoring tool with JavaScript. Intended for JavaScript users and advanced Flash users.</td>
<td>• View in Flash: Select Help &gt; Flash Help&lt;br&gt;• View online: livedocs.macromedia.com/go/livedocs_flash&lt;br&gt;• Get the PDF: <a href="http://www.macromedia.com/go/fl_documentation">www.macromedia.com/go/fl_documentation</a></td>
</tr>
</tbody>
</table>
# Flash Lite

<table>
<thead>
<tr>
<th>Title</th>
<th>Description/Audience</th>
<th>Where to Find It</th>
</tr>
</thead>
</table>
| **Getting Started with Flash Lite** | Introductory information about Flash Lite workflows and authoring considerations. Intended for mobile and device developers and intermediate Flash users. | • View in Flash: Select Help > Flash Help  
• View online: livedocs.macromedia.com/go/livedocs_flash  
• Get the PDF: www.macromedia.com/go/flash_lite_documentation |
| **Developing Flash Lite Applications** | Information about creating Flash content for mobile phones and devices. Intended for mobile and device developers and intermediate Flash users. | • View in Flash: Select Help > Flash Help  
• View online: livedocs.macromedia.com/go/livedocs_flash  
• Get the PDF: www.macromedia.com/go/flash_lite_documentation |
| **Learning Flash Lite 1.x ActionScript** | Information about writing ActionScript for mobile phones and devices. Intended for mobile and device developers and intermediate Flash users. | • View in Flash: Select Help > Flash Help  
• View online: livedocs.macromedia.com/go/livedocs_flash  
• Get the PDF: www.macromedia.com/go/flash_lite_documentation |
| **Flash Lite 1.x ActionScript Language Reference** | Dictionary-style reference entries for each term in the Flash Lite 1.x ActionScript language. Intended for mobile and device developers and intermediate Flash users. | • View in Flash: Select Help > Flash Help  
• View online: livedocs.macromedia.com/go/livedocs_flash  
• Get the PDF: www.macromedia.com/go/flash_lite_documentation |
# Accessing additional online Flash resources

The following table summarizes additional online resources for learning Flash.

<table>
<thead>
<tr>
<th>Resource</th>
<th>Description</th>
<th>Where to Find It</th>
</tr>
</thead>
<tbody>
<tr>
<td>Flash Support Center</td>
<td>TechNotes, plus support and problem-solving information.</td>
<td>• <a href="http://www.macromedia.com/go/flash_support">www.macromedia.com/go/flash_support</a></td>
</tr>
<tr>
<td>Flash Developer Center</td>
<td>Articles and tutorials to help you improve your skills and learn new ones.</td>
<td>• <a href="http://www.macromedia.com/go/flash_devcenter">www.macromedia.com/go/flash_devcenter</a></td>
</tr>
<tr>
<td>Flash Documentation Resource Center</td>
<td>PDF and HTML versions of the Flash documentation.</td>
<td>• <a href="http://www.macromedia.com/go/fl_documentation">www.macromedia.com/go/fl_documentation</a></td>
</tr>
<tr>
<td>Macromedia Online Forums</td>
<td>Discussion and problem-solving information by Flash users, technical support representatives, and the Flash development team.</td>
<td>• <a href="http://www.macromedia.com/go/flash_forums">www.macromedia.com/go/flash_forums</a></td>
</tr>
<tr>
<td>Macromedia Training</td>
<td>Classroom and online instruction offered by Macromedia training partners.</td>
<td>• <a href="http://www.macromedia.com/go/flash_training">www.macromedia.com/go/flash_training</a></td>
</tr>
<tr>
<td>Flash Resource Manager (English only)</td>
<td>An alternative viewer for viewing the Flash help system outside the Flash application.</td>
<td>• <a href="http://www.macromedia.com/go/flash_resource_manager">www.macromedia.com/go/flash_resource_manager</a></td>
</tr>
</tbody>
</table>
Choosing the right help books

Because Flash Help contains many books, it is useful to know what each book is about before deciding which ones to use. The following list describes each book’s purpose and contents in detail:

- *Getting Started with Flash* provides an introduction to what Flash is and what you can do with it. This book also contains an overview of the Flash user interface and a thorough tutorial that guides you through the process of making a real-world Flash project.

- *Using Flash* contains detailed information about using all the tools and features in the Flash authoring tool, including the following important tasks:
  - Setting up projects and documents
  - Drawing
  - Importing media
  - Working with various media types
  - Using text
  - Using the Timeline
  - Creating animation
  - Creating graphic effects
  - Integrating external data sources into projects
  - Creating simple scripts with Script Assist mode
  - Publishing your files

*Using Flash* also covers a variety of more specialized topics, such as creating accessible content for users with disabilities and creating e-learning content.

- *Learning ActionScript 2.0 in Flash* provides a detailed description of the ActionScript language, intended for both new and more experienced scripters. By reading *Learning ActionScript*, you will learn the following:
  - The basic concepts of writing code
  - The types of scripts that can be used in Flash, and when it is appropriate to use each type
  - How to use logic to write code that makes decisions
  - How to make your Flash projects respond to user actions
  - How to write specific code to perform the most common tasks in Flash
ActionScript 2.0 Language Reference includes dictionary-style entries for all of the actions, methods, and properties in the ActionScript 2.0 application programming interface (API). When you understand the basics of how to write ActionScript code, this reference is a fast way to find specific ActionScript terms that will help you accomplish specific tasks. Each entry includes a detailed description of the syntax and functionality of the term as well as real-world code examples that you can paste into the Actions panel in Flash and test for yourself.

Using Components contains information on using and configuring components in a Flash document. Components are reusable user interface elements such as buttons, menus, and so on, that you can use in your own projects without needing to create and script them from scratch. Some components do not have a visual presence, but instead are used to assist you in storing and managing data for your application. Using Components also contains information about creating your own reusable components with ActionScript.

Components Language Reference includes dictionary-style entries for all of the methods and properties that are available to each component included with Flash. You control the behavior of components with these APIs. Once you understand the basics of how to use components, this reference is a fast way to find specific APIs that will help you accomplish specific tasks.

Flash Tutorials includes many tutorials designed to lead you through specific Flash tasks step by step. Each tutorial addresses a specific feature or task in Flash and includes a finished FLA file that you can open and explore to verify your results. The files associated with each tutorial are located in the Flash application directory on your hard drive in the Samples and Tutorials\Tutorial_assets directory.

Flash Samples contains a collection of sample FLA files that illustrate specific features or techniques commonly used in Flash. A sample is different from a tutorial because it consists only of the FLA file that you can open in Flash, a description of how the file is constructed, and the technique it is demonstrating. Samples do not include step-by-step instructions for recreating the file. The FLA files for each sample are located in the Flash application directory on your hard drive in the Samples and Tutorials\Samples directory.
- Developing Flash Lite Applications provides techniques and guidelines for creating content and applications for Flash Lite, the version of Flash Player designed for mobile phones and other devices. Because Flash Lite supports different features than the desktop version of Flash Player supports, the techniques for creating content for Flash Lite are different from those for creating Flash desktop content.

- Learning Flash Lite 1.x ActionScript describes in detail the ActionScript features available in Flash Lite 1.0 and 1.1 and how to perform common scripting tasks when using Flash Lite.

- Flash Lite 1.x ActionScript Reference provides dictionary-style entries for all of the actions, methods, and properties available in Flash Lite 1.0 and 1.1. Each entry includes the details of the term’s syntax and functionality, as well as example code.

Using the Flash help system

The Flash help system includes many features to help you find the information you are looking for. The sections that follow explain how to use the Flash help system most effectively.

Opening the Help panel

The Flash Help panel contains the full set of user-assistance information provided with the Flash application.

To access help and the table of contents:

1. To open the Help panel, select Help > Flash Help or press F1.

2. If the table of contents is not visible, click the Table of Contents button to display the Table of Contents pane.

   A list of help books is displayed.

3. Click a book title to open it and display its topics.

4. Click a topic title to display it.

   The topic hierarchy for the current topic is displayed at the top of each help page.
Searching the help system

Flash Basic 8 and Flash Professional 8 provide thorough search capabilities that help you easily find the information you need. In the Flash Help panel, you can search for help pages that contain specific words or phrases. You can search Flash Help in the following ways:

**Single-word** searches return a list of help pages that contain the specified word. For example, you might type `timeline` in the search text box. This search returns a list of help pages that contain the word `timeline` or `Timeline`.

**Multiple-word** searches return a list of help pages that each contain all of the search terms you enter. In this case the word *and* is implicit in the search. For example, you might type `movie clip` in the search text box. This action returns a list of pages that contain both `movie` and `clip`—that is, `clip movie`, `movie clip`, or `movie...clip`, and so on.

**Explicit AND/OR** searches use the words *and* or *or* to refine the search results. For example, you might type `timeline and keyframe or tween` in the search text box. This action returns a list of help pages that contain `timeline` and `keyframe` and help pages that contain `timeline` and `tween`.

**Exact phrase** searches allow you to use quotation marks to return only pages that contain the specific phrase you enter. For example, you might type "motion tween" in the search text box. This action returns a list of help pages that contain the phrase `motion tween`, but not pages that contain separate instances of `motion` and `tween`.

**Exact phrase with explicit AND/OR** searches allow you to use a combination of quotation marks and the words *and* or *or* to further refine your searches. For example, you might type "motion tween" and "ActionScript" in the search field. This action returns a list of pages that contain both the phrase `motion tween` and the word `ActionScript`.

**To search for a word or phrase in the Help panel:**
1. In the Category menu, select a category of books to search.
   - To search all of the books, select All Books.
2. Enter a word or phrase in the text box, and then click Search.
   - A list of help topics that contain the word or phrase is displayed, organized by book.
3. Click a help topic to select it from the list.
   The topic appears in the Table of Contents pane of the Help panel.
   The table of contents path to the topic appears at the top of each help page.

**NOTE**

Click Clear to return to the Table of Contents view.

To find reference information about a specific ActionScript term, use the "ActionScript 2.0 Language Reference", or use Search.

**To search for a word or phrase within a specific help page:**
1. Locate the help page you want to search.
2. Click in the help page so it has the focus.
3. Press Ctrl+F (Windows) or Command+F (Macintosh).
4. In the Find dialog box, enter the word or phrase you want to search for and click Find Next.
   If the word or phrase exists in the current help page, it is highlighted in the Help panel.

**Using context-sensitive help**

The Help panel contains context-sensitive reference information that you can access from the Actions panel. By clicking an ActionScript term in the Actions panel, you can display help information about that term.

**To access context-sensitive help from the Actions panel:**
1. To select an item for reference, do any one of the following:
   - Select an item in the Actions panel toolbox pane (on the left side of the Actions panel).
   - Select an ActionScript term in the Actions panel in the Script pane.
   - Place the insertion point before an ActionScript term in the Actions panel in the Script pane.
2. To open the Help panel reference page for the selected item, do one of the following:
   ■ Press F1.
   ■ Right-click the item and select View Help.
   ■ Click Reference above the Script pane.

To access context-sensitive help from a Flash panel:
   ■ Click the pop-up menu in the panel and select Help.

To access context-sensitive help from a dialog box:
   ■ Click the Help icon in the dialog box.

The Flash Tutorials book in the Help panel contains many tutorials that introduce you to the features of Flash. These tutorials allow you to practice on isolated examples. If you are new to Flash, or if you have used only a limited set of Flash features, start with the Flash Tutorials book.

Printing the Flash documentation

Printable versions of each of the books in the Flash help system are available on the Macromedia website. You can also print individual help pages from within the Flash Help panel.

To print an individual book or chapter from the Macromedia website:
2. Locate the PDF file for the book you wish to print.
3. Download the PDF file.
4. Open the PDF file in Adobe Reader.
5. Print the file, or a single chapter from the file if you prefer.
   The Flash End User License Agreement allows you to print the documentation PDFs at retail copy stores if you prefer.

To print an individual help page:
1. Click Print in the Help panel toolbar.
2. In the Print dialog box, select the printer and other printing options, and then click Print.

You can also purchase the printed manuals at the Macromedia Online Store at www.macromedia.com/go/books_and_training.
Purchasing printed documentation

To purchase printed versions of the Flash documentation, go to www.macromedia.com/go/books.

Discussing the Flash documentation with LiveDocs

In addition to accessing Flash documentation in the Flash Help panel, you can get the same documentation online in the LiveDocs format. To find that equivalent page on the LiveDocs website, you simply click the View Comments on LiveDocs link at the bottom of a help page in the Help panel. The Flash LiveDocs are available at livedocs.macromedia.com/go/livedocs_flash.

One of the advantages of LiveDocs is the ability to see comments that clarify the documentation, or correct any errata or issues that arise after a software release. LiveDocs is not the place to ask for help requests, such as asking questions about your code that doesn’t work, or how to complete a specific task. LiveDocs is the correct place to provide feedback about the documentation (for example, if you notice a sentence or paragraph that could be clarified).

When you click the link to add a comment on LiveDocs, you see several points about the kinds of comments that are acceptable on the system. Please read these guidelines closely, or your comment might be removed from the website if it does not conform to the guidelines.

If you have a question about Flash, please ask it on the Macromedia Flash web forums: www.macromedia.com/go/flash_forums. The web forums are the best place to ask questions, because many Macromedia employees, Team Macromedia volunteers, Macromedia user group managers and members, and even technical writers monitor these forums.
Controlling the appearance of the Help panel

You can control how the Help panel appears in Flash.

Arranging the Help panel in the Flash workspace

You can arrange the Help panel position in the workspace to optimize its usability. You can easily control the size of the display area, and where and when the Help panel is displayed. For more details about working with panels, see “Using panels and the Property inspector” on page 73.

To arrange the Help panel in a docked position:
1. Dock the Help panel in the desired position.
2. Expand the Help panel if it is not already expanded.
3. Drag the split bar between the panel or panel group and the Document window so you can see the Stage area.
4. Press F1 to collapse and expand the Help panel as needed.

To arrange the Help panel in an undocked (floating) position:
1. Undock the Help panel to the desired position.
2. Expand the Help panel if it is not already expanded.
3. Resize the panel window.
4. Press F1 to close or open the Help panel as needed.
Changing the size of text displayed in the Help panel

If you are using a laptop, you may find it useful to change the text in the Help panel to a larger size. You can change the size of the text in the Help panel by changing the size of the text in your web browser.

To use your browser to change the size of the text displayed in the Help panel:

- Open your browser and edit the preferences to change the size of text in the browser to a larger size. You must restart Flash for the change to take effect.

Getting updates to Flash Help

The Update feature in Flash allows you to update your help system with new and revised documentation, including procedures and lessons. You can click the Update button to see if new information is available.

To update Flash Help:

1. Verify that you’re connected to the Internet.

2. Click Update in the Help panel toolbar and follow the instructions to download the help system update.

When a help update is released, Macromedia creates and posts a new PDF of each updated book on the Macromedia documentation page at www.macromedia.com/go/fl_documentation/.

Tip

In Windows, you can change the size of the text in the Help panel by clicking in a topic, pressing Control, and scrolling the mouse wheel. This also changes the size of text in your web browser.
CHAPTER 2

Flash Basics

The Macromedia Flash Basic 8 and Flash Professional 8 workspace consists of a Stage on which you place media objects, a Property inspector for organizing and modifying media assets, a Tools panel with tools for creating and modifying image content, and many other panels for accessing the wide range of functionality in Flash. For more information on the workspace, see the following sections:

Using the Start page ................................................................. 51
Using the Stage ........................................................................ 52
Using the Timeline ................................................................. 54
Using frames and keyframes .................................................. 58
Using layers ............................................................................ 61
About the main toolbar and edit bar ................................. 67
Using the Tools panel ............................................................. 67
Using the grid, guides, and rulers ........................................... 69
Using panels and the Property inspector ....................... 73

You can select preferences to modify the default Flash workspace. Context menus and keyboard shortcuts provide ways for you to easily navigate the Flash authoring environment. Special workspace accessibility features provide additional keyboard shortcuts that let you navigate panels and dialog boxes without using the mouse. For more information, see the following sections:

Setting preferences in Flash ................................................ 78
Customizing keyboard shortcuts ........................................ 83
Using context menus ............................................................. 86
Accessibility in the Flash authoring environment ............ 86
About Flash files

The primary Flash file type, FLA files, contain three basic types of information that comprise a Flash document. These include the following:

**Media objects** are the various graphic, text, sound and video objects that comprise the content of your Flash document. By importing or creating these elements in Flash and then arranging them on the Stage and in the Timeline, you define what the viewer of your document will see and when they will see it.

**The Timeline** is the place in Flash where you tell Flash when specific media objects should appear on the Stage. The Timeline is like a spreadsheet that progresses from left to right, with the columns representing time. The rows represent layers, with the content in higher layers appearing above lower layers’ contents on the Stage.

**ActionScript code** is the programming code you can add to Flash documents to make them respond to user interactions and to more finely control the behavior of your Flash documents. Much can be accomplished in Flash without ActionScript, but using ActionScript offers many more possibilities.

Flash can be used to work with a variety of file types. Each type has a separate purpose. The following list describes each file type and its uses:

- **FLA files** are the primary files you work with in Flash. These are the files that contain the basic media, timeline, and script information for a Flash document.

- **SWF files** are the compressed versions of FLA files. These files are the ones you display in a web page.

- **AS files** are ActionScript files. You can use these files if you prefer to keep some or all of your ActionScript code outside of your FLA files. These can be helpful for code organization and for projects that have multiple people working on different parts of the Flash content.

- **SWC files** contain the reusable Flash components. Each SWC file contains a compiled movie clip, ActionScript code, and any other assets that the component requires.

- **ASC files** are files used to store ActionScript that will be executed on a computer running Flash Communication Server. These files provide the ability to implement server-side logic that works in conjunction with ActionScript in a SWF file.
■ JSFL files are JavaScript files that you can use to add new functionality to the Flash authoring tool. See *Extending Flash* for more information.

■ FLP files are Flash Project files (Flash Professional only). You can use Flash Projects to manage multiple document files in a single project. Flash Projects allow you to group multiple, related files together to create complex applications.

Getting to know the workspace

The following sections provide a detailed introduction to the tools, panels, and other elements of the Flash workspace.

Using the Start page

Whenever Flash is running with no documents open, the Start page appears. The Start page provides easy access to frequently used actions.

The Start page contains the following four areas:

Open a Recent Item lets you open your most recent documents. You can also display the Open File dialog box by clicking the Open icon.

Create New lists Flash file types, such as Flash documents and ActionScript files. You can quickly create a new file by clicking the desired file type in the list.

Create from Template lists the templates most commonly used to create new Flash documents. You can create a new file by clicking the desired template in the list.

Extend links to the Macromedia Flash Exchange website, where you can download helper applications for Flash, Flash extensions, and related information.

The Start page also offers quick access to Help resources. You can take a tour of Flash, learn about Flash documentation resources, and find Macromedia Authorized Training facilities.

To hide the Start page:

■ On the Start page, select Don’t Show Again.
To display the Start page again, do one of the following:
- (Windows) Select Edit > Preferences and select Show Start Page in the General category.
- (Macintosh) Select Flash > Preferences and select Show Start Page in the General category.

Using the Stage

The Stage is the rectangular area where you place graphic content, including vector art, text boxes, buttons, imported bitmap graphics or video clips, and so on when creating Flash documents. The Stage in the Flash authoring environment represents the rectangular space in Macromedia Flash Player or in a web browser window where your Flash document appears during playback. You can zoom in and out to change the view of the Stage as you work.

![Stage image]

The grid, guides, and rulers help you position content precisely on the Stage. For more information, see “Using the grid, guides, and rulers” on page 69.

Zooming

To view the entire Stage on the screen, or to view a particular area of your drawing at high magnification, you can change the magnification level. The maximum magnification depends on the resolution of your monitor and the document size. The minimum value for zooming out on the Stage is 8%. The maximum value for zooming in on the Stage is 2000%.
To magnify or reduce your view of the Stage, do one of the following:

- To zoom in on a certain element, select the Zoom tool in the Tools panel, and click the element. To switch the Zoom tool between zooming in or out, use the Enlarge or Reduce modifiers (in the options area of the Tools panel when the Zoom tool is selected) or Alt-click (Windows) or Option-click (Macintosh).

- To zoom in on a specific area of your drawing, drag a rectangular selection on the Stage with the Zoom tool. Flash sets the magnification level so that the specified rectangle fills the window.

- To zoom in on or out of the entire Stage, select View > Zoom In or View > Zoom Out.

- To zoom in or out by a specified percentage, select View > Magnification, and select a percentage from the submenu or select a percentage from the Zoom control at the upper-right corner of the Timeline.

- To scale the Stage so it fits completely in the application window, select View > Magnification > Fit in Window.

- To display the contents of the current frame, select View > Magnification > Show All, or select Show All from the Zoom control at the upper-right side of the application window. If the scene is empty, the entire Stage appears.

- To display the entire Stage, select View > Magnification > Show Frame or select Show Frame from the Zoom control at the upper-right corner of the Timeline.

- To display the workspace surrounding the Stage, select View > Work Area. The work area is shown in light gray. Use the Work Area command to view elements in a scene that are partly or completely outside of the Stage area. For example, to have a bird fly into a frame, you would initially position the bird outside of the Stage in the work area and then animate it into the Stage area.
Moving the view of the Stage

When the Stage is magnified, you may not be able to see all of it. The Hand tool lets you move the Stage to change the view without having to change the magnification.

To move the Stage view:
1. In the Tools panel, select the Hand tool. To temporarily switch between another tool and the Hand tool, hold down the Spacebar and click the tool in the Tools panel.
2. Drag the Stage.

Using the Timeline

The Timeline organizes and controls a document's content over time in layers and frames. Like films, Flash documents divide lengths of time into frames. Layers are like multiple film strips stacked on top of one another, each containing a different image that appears on the Stage. The major components of the Timeline are layers, frames, and the playhead.

Layers in a document are listed in a column on the left side of the Timeline. Frames contained in each layer appear in a row to the right of the layer name. The Timeline header at the top of the Timeline indicates frame numbers. The playhead indicates the current frame displayed on the Stage. As a Flash document plays, the playhead moves from left to right through the Timeline.

The Timeline status display at the bottom of the Timeline indicates the selected frame number, the current frame rate, and the elapsed time to the current frame.

NOTE

When an animation is played, the actual frame rate is displayed; this may differ from the document's frame rate setting if the computer can't calculate and display the animation quickly enough.
You can change the way frames appear in the Timeline, as well as display thumbnails of frame content in the Timeline. The Timeline shows where animation occurs in a document, including frame-by-frame animation, tweened animation, and motion paths. For more information on animation, see Chapter 10, “Creating Motion” in Using Flash.

Controls in the layers section of the Timeline let you hide, show, lock, or unlock layers, as well as display layer contents as outlines. For more information, see “Editing layers and layer folders” on page 64.

You can insert, delete, select, and move frames in the Timeline. You can also drag frames to a new location on the same layer or to a different layer. For more information, see “Working with frames in the Timeline” on page 59.

Changing the appearance of the Timeline

By default, the Timeline appears at the top of the main application window, above the Stage. To change its position, you can dock the Timeline to the bottom or either side of the main application window, or display the Timeline as its own window. You can also hide the Timeline.

You can resize the Timeline to change the number of layers and frames that are visible. When there are more layers than can be displayed in the Timeline, you can view additional layers by using the scroll bars on the right side of the Timeline.
To move the Timeline when it is docked to the application window:

- Drag the gripper at the left of the word Timeline in the panel title bar.

To dock an undocked Timeline:

- Drag the Timeline title bar to an edge of the application window. Press Control and drag to prevent the Timeline from docking.

To lengthen or shorten layer name fields:

- Drag the bar separating the layer names and the frames portions of the Timeline.

To resize the Timeline, do one of the following:

- If the Timeline is docked to the main application window, drag the bar separating the Timeline from the Stage area.
- If the Timeline is not docked to the main application window, drag the lower-right corner (Windows) or the size box in the lower-right corner (Macintosh).

Moving the playhead

The playhead moves through the timeline as a document plays to indicate the current frame displayed on the Stage. The Timeline header shows the frame numbers of the animation. To display a frame on the Stage, you move the playhead to the frame in the Timeline.

When you're working with a large number of frames that can't all be displayed in the Timeline at once, you can move the playhead along the Timeline to easily display a specific frame.
To go to a frame:
- Click the frame’s location in the Timeline header, or drag the playhead to the desired position.

To center the Timeline on the current frame:
- Click Center Frame at the bottom of the Timeline.

Changing the display of frames in the Timeline
You can change the size of frames in the Timeline, and add color to sequences of frames to highlight them. You can also include thumbnail previews of frame content in the Timeline. These thumbnails are useful as an overview of the animation, but they require extra screen space.
To change the display of frames in the Timeline:

1. Click Frame View in the upper-right corner of the Timeline to display the Frame View pop-up menu.

2. Select from the following options:
   - To change the width of frame cells, select Tiny, Small, Normal, Medium, or Large. (The Large frame-width setting is useful for viewing the details of sound waveforms.)
   - To decrease the height of frame cell rows, select Short.
   - To turn the tinting of frame sequences on or off, select Tinted Frames.
   - To display thumbnails of the content of each frame scaled to fit the Timeline frames, select Preview. This can cause the apparent content size to vary.
   - To display thumbnails of each full frame (including empty space), select Preview in Context. This is useful for viewing the way elements move within their frames over the course of the animation, but previews are generally smaller than with the Preview option.

Using frames and keyframes

A keyframe is a frame in which you define a change to an object’s properties for an animation or include ActionScript code to control some aspect of your document. Flash can tween, or automatically fill in, the frames between keyframes you define in order to produce fluid animations. Because keyframes let you produce animation without drawing each individual frame, they make creating animation easier. You can easily change the length of a tweened animation by dragging a keyframe in the Timeline.

The order in which frames and keyframes appear in the Timeline determines the order in which they are displayed in a Flash application. You can arrange keyframes in the Timeline to edit the sequence of events in an animation.
Working with frames in the Timeline

In the Timeline, you work with frames and keyframes, placing them in the order you want the objects in the frames to appear. You can change the length of a tweened animation by dragging a keyframe in the Timeline. You can perform the following modifications on frames or keyframes:

■ Insert, select, delete, and move frames or keyframes
■ Drag frames and keyframes to a new location on the same layer or on a different layer
■ Copy and paste frames and keyframes
■ Convert keyframes to frames
■ Drag an item from the Library panel onto the Stage to add the item to the current keyframe

The Timeline provides a view of tweened frames in an animation. For information on editing tweened frames, see “Creating Motion” in Using Flash.

Flash offers two different methods for selecting frames in the Timeline. In frame-based selection (the default) you select individual frames in the Timeline. In span-based selection, the entire frame sequence, from one keyframe to the next, is selected when you click any frame in the sequence. You can specify span-based selection in Flash preferences.

To specify span-based selection:
1. Select Edit > Preferences.
2. Select the General category.
3. In the Timeline section, select Span based selection.
4. Click OK.
For more information, see “Setting preferences in Flash” on page 78.

To insert frames in the Timeline, do one of the following:
■ To insert a new frame, select Insert > Frame.
■ To create a new keyframe, select Insert > Keyframe, or right-click (Windows) or Control-click (Macintosh) the frame where you want to place a keyframe, and select Insert Keyframe from the context menu.
■ To create a new blank keyframe, select Insert > Blank Keyframe, or right-click (Windows) or Control-click (Macintosh) the frame where you want to place the keyframe, and select Insert Blank Keyframe from the context menu.
To select one or more frames in the Timeline:
- To select one frame, click the frame. If you have Span Based Selection enabled in the Preferences dialog box, clicking one frame selects the entire frame sequence between two keyframes. For more information, see “Setting preferences in Flash”.
- To select multiple contiguous frames, Shift-click additional frames.
- To select multiple discontiguous frames, Control-click (Windows) or Command-click (Macintosh) additional frames.

To select all frames in the Timeline:
- Select Edit > Timeline > Select All Frames.

To delete or modify a frame or keyframe, do one of the following:
- To delete a frame, keyframe, or frame sequence, select the frame, keyframe, or sequence and select Edit > Timeline > Remove Frame, or right-click (Windows) or Control-click (Macintosh) the frame, keyframe, or sequence and select Remove Frame from the context menu. Surrounding frames remain unchanged.
- To move a keyframe or frame sequence and its contents, drag the keyframe or sequence to the desired location.
- To extend the duration of a keyframe animation, press Alt and drag (Windows) or press Option and drag (Macintosh) the keyframe to the frame that you want to be the final frame of the sequence.
- To copy a keyframe or frame sequence by dragging, Alt-click (Windows) or Option-click (Macintosh) and drag the keyframe to the new location.
- To copy and paste a frame or frame sequence, select the frame or sequence and select Edit > Timeline > Copy Frames. Select a frame or sequence that you want to replace, and select Edit > Timeline > Paste Frames.
- To convert a keyframe to a frame, select the keyframe and select Edit > Timeline > Clear Keyframe, or right-click (Windows) or Control-click (Macintosh) the keyframe and select Clear Keyframe from the context menu. The Stage contents of the cleared keyframe and all frames up to the subsequent keyframe are replaced with the Stage contents of the frame preceding the cleared keyframe.
■ To change the length of a tweened sequence, drag the beginning or ending keyframe left or right. To change the length of a frame-by-frame animation sequence, see “Creating frame-by-frame animations” in Using Flash.

■ To add an item from the library to the current keyframe, drag the item from the Library panel onto the Stage.

Using layers

Layers are like transparent sheets of acetate stacked on top of each other on the Stage. Layers help you organize the artwork in your document. You can draw and edit objects on one layer without affecting objects on another layer. Where there is nothing on a layer, you can see through it to the layers below.

To draw, paint, or otherwise modify a layer or folder, you select the layer in the Timeline to make it active. A pencil icon next to a layer or folder name in the Timeline indicates that the layer or folder is active. Only one layer can be active at a time (although more than one layer can be selected at a time).

When you create a new Flash document, it contains only one layer. You can add more layers to organize the artwork, animation, and other elements in your document. The number of layers you can create is limited only by your computer's memory, and layers do not increase the file size of your published SWF file. Only the objects you place into layers add to the file size. You can also hide, lock, or rearrange layers.

You can also organize and manage layers by creating layer folders and placing layers in them. You can expand or collapse layer folders in the Timeline without affecting what you see on the Stage. It's a good idea to use separate layers or folders for sound files, ActionScript, frame labels, and frame comments. This helps you find these items quickly when you need to edit them.

In addition, you can use special guide layers to make drawing and editing easier, and mask layers to help you create sophisticated effects.

For an interactive introduction to working with layers in Flash, select Help > Flash Tutorials > Basic Tasks > Work with Layers.
Creating layers and layer folders

When you create a new layer or folder, it appears above the selected layer. The newly added layer becomes the active layer.

To create a layer, do one of the following:
- Click the Insert Layer button at the bottom of the Timeline.
- Select Insert > Timeline > Layer.
- Right-click (Windows) or Control-click (Macintosh) a layer name in the Timeline and select Insert Layer from the context menu.

To create a layer folder, do one of the following:
- Select a layer or folder in the Timeline, and then select Insert > Timeline > Layer Folder.
- Right-click (Windows) or Control-click (Macintosh) a layer name in the Timeline, and then select Insert Folder from the context menu. The new folder appears above the layer or folder you selected.

Viewing layers and layer folders

As you work, you may want to show or hide layers or folders. A red X next to the name of a layer or folder in the Timeline indicates that it is hidden. When you publish a Flash SWF file, any layers that were hidden in the FLA document are preserved and visible in the SWF file.

To help you distinguish which layer an object belongs to, you can display all objects on a layer as colored outlines. You can change the outline color used by each layer.

You can change the height of layers in the Timeline to display more information (such as sound waveforms) in the Timeline. You can also change the number of layers displayed in the Timeline.

To show or hide a layer or folder, do one of the following:
- Click in the Eye column to the right of the layer or folder name in the Timeline to hide that layer or folder. Click in it again to show the layer or folder.
- Click the eye icon to hide all the layers and folders in the Timeline. Click it again to show all layers and folders.
- Drag through the Eye column to show or hide multiple layers or folders.
Alt-click (Windows) or Option-click (Macintosh) in the Eye column to the right of a layer or folder name to hide all other layers and folders. Alt-click or Option-click it again to show all layers and folders.

**To view the contents of a layer as outlines, do one of the following:**

- Click in the Outline column to the right of the layer's name to display all objects on that layer as outlines. Click in it again to turn off outline display.
- Click the outline icon to display objects on all layers as outlines. Click it again to turn off outline display on all layers.
- Alt-click (Windows) or Option-click (Macintosh) in the Outline column to the right of a layer's name to display objects on all other layers as outlines. Alt-click or Option-click in it again to turn off the outline display for all layers.

**To change a layer's outline color:**

1. Do one of the following:
   - Double-click the layer's icon (the icon to the left of the layer name) in the Timeline.
   - Right-click (Windows) or Control-click (Macintosh) the layer name and select Properties from the context menu.
   - Select the layer in the Timeline and select Modify > Layer.
2. In the Layer Properties dialog box, click the Outline Color box and select a new color, enter the hexadecimal value for a color, or click the Color Picker button and select a color.
3. Click OK.

**To change layer height in the Timeline:**

1. Do one of the following:
   - Double-click the layer's icon (the icon to the left of the layer name) in the Timeline.
   - Right-click (Windows) or Control-click (Macintosh) the layer name and select Properties from the context menu.
   - Select the layer in the Timeline and select Modify > Timeline > Layer Properties.
2. In the Layer Properties dialog box, select an option for Layer Height and click OK.
To change the number of layers displayed in the Timeline:
■ Drag the bar that separates the Timeline from the Stage area.

Editing layers and layer folders
You can rename, copy, and delete layers and folders. You can also lock layers and folders to prevent them from being edited.

By default, new layers are named by the order in which they are created: Layer 1, Layer 2, and so on. You can rename layers to better reflect their contents.

To select a layer or folder, do one of the following:
■ Click the name of a layer or folder in the Timeline.
■ Click any frame in the Timeline of the layer you want to select.
■ Select an object on the Stage that is located in the layer you want to select.
■ To select two or more layers or folders, do one of the following:
  ■ To select contiguous layers or folders, Shift-click their names in the Timeline.
  ■ To select discontiguous layers or folders, Control-click (Windows) or Command-click (Macintosh) their names in the Timeline.

To rename a layer or folder, do one of the following:
■ Double-click the name of the layer or folder in the Timeline and enter a new name.
■ Right-click (Windows) or Control-click (Macintosh) the name of the layer or folder and select Properties from the context menu. Enter the new name in the Name text box and click OK.
■ Select the layer or folder in the Timeline and select Modify > Timeline > Layer Properties. In the Layer Properties dialog box, enter the new name in the Name text box and click OK.

To lock or unlock one or more layers or folders, do one of the following:
■ Click in the Lock column to the right of the name of a layer or folder to lock it. Click in the Lock column again to unlock the layer or folder.
■ Click the padlock icon to lock all layers and folders. Click it again to unlock all layers and folders.
■ Drag through the Lock column to lock or unlock multiple layers or folders.
■ Alt-click (Windows) or Option-click (Macintosh) in the Lock column to the right of a layer or folder name to lock all other layers or folders. Alt-click or Option-click in the Lock column again to unlock all layers or folders.

To copy a layer:
1. Click the layer name in the Timeline to select the entire layer.
2. Select Edit > Timeline > Copy Frames.
3. Click the Insert Layer button to create a new layer.
4. Click the new layer and select Edit > Timeline > Paste Frames.

To copy the contents of a layer folder:
1. Click the triangle to the left of the folder name in the Timeline to collapse it, if necessary.
2. Click the folder name to select the entire folder.
3. Select Edit > Timeline > Copy Frames.
4. Select Insert > Timeline > Layer Folder to create a new folder.
5. Click the new folder and select Edit > Timeline > Paste Frames.

To delete a layer or folder:
1. Select the layer or folder by clicking its name in the Timeline or any frame in the layer.
2. Do one of the following:
   ■ Click the Delete Layer button in the Timeline.
   ■ Drag the layer or folder to the Delete Layer button.
   ■ Right-click (Windows) or Control-click (Macintosh) the layer or folder name and select Delete Layer from the context menu.

NOTE When you delete a layer folder, all the enclosed layers and all their contents are also deleted.
Organizing layers and layer folders
You can rearrange layers and folders in the Timeline to organize your document.
Layer folders help organize your workflow by letting you place layers in a tree structure. You can expand or collapse a folder to see the layers it contains without affecting which layers are visible on the Stage. Folders can contain both layers and other folders, allowing you to organize layers in much the same way you organize files on your computer.
The layer controls in the Timeline affect all layers within a folder. For example, locking a layer folder locks all layers within that folder.

To move a layer or layer folder into a layer folder:
- Drag the layer or layer folder name to the destination layer folder name.
  The layer or layer folder appears inside the destination layer folder in the Timeline.

To change the order of layers or folders:
- Drag one or more layers or folders in the Timeline to the desired position above or below other layers in the Timeline.

To expand or collapse a folder:
- Click the triangle to the left of the folder name.

To expand or collapse all folders:
- Right-click (Windows) or Control-click (Macintosh) and select Expand All Folders or Collapse All Folders from the context menu.

Using guide layers
For help in aligning objects when drawing, you can create guide layers. You can then align objects on other layers to the objects you create on the guide layers. Guide layers are not exported and do not appear in a published SWF file. You can make any layer a guide layer. Guide layers are indicated by a guide icon to the left of the layer name.
You can also create a motion guide layer to control the movement of objects in a motion tweened animation. For more information, see “Tweening motion along a path” in *Using Flash*.

**NOTE**

Dragging a normal layer onto a guide layer converts the guide layer to a motion guide layer. To prevent accidentally converting a guide layer, place all guide layers at the bottom of the layer order.

**To designate a layer as a guide layer:**
- Select the layer and right-click (Windows) or Control-click (Macintosh) and select Guide from the context menu. Select Guide again to change the layer back to a normal layer.

**About the main toolbar and edit bar**

The menu bar at the top of the Flash application window displays menus with commands for controlling Flash functionality. The menus include File, Edit, View, Insert, Modify, Text, Commands, Control, Window, and Help.

The edit bar, at the top of the Timeline, contains controls and information for editing scenes and symbols, and for changing the magnification level of the Stage.

For information on changing the Stage magnification level, see “Zooming” on page 52. For information on editing symbols, see Chapter 3, “Using Symbols, Instances, and Library Assets” in *Using Flash*. For information on working with scenes, see “Working with scenes” in *Using Flash*.

**Using the Tools panel**

The tools in the Tools panel let you draw, paint, select, and modify artwork, as well as change the view of the Stage. The Tools panel is divided into four sections:
- The tools area contains drawing, painting, and selection tools.
- The view area contains tools for zooming and panning in the application window.
- The colors area contains modifiers for stroke and fill colors.
- The options area displays modifiers for the currently selected tool. Modifiers affect the tool’s painting or editing operations.
Using the Customize Tools panel dialog box, you can specify which tools to display in the Flash authoring environment. For more information, see “Customizing the Tools panel” on page 68.

For information on using the drawing and painting tools, see “About Flash drawing and painting tools” in Using Flash. For information on using the selection tools, see “Selecting objects” in Using Flash. For information on using the view modification tools, see “Moving the view of the Stage” on page 54.

To show or hide the Tools panel:

■ Select Window > Tools.

Selecting tools

You can select tools by clicking in the Tools panel, or by using a keyboard shortcut.

To select a tool, do one of the following:

■ Click the tool you want to use. Depending on the tool you select, a set of modifiers may be displayed in the options area at the bottom of the Tools panel.

■ Press the tool's keyboard shortcut. You can view the keyboard shortcuts by selecting Edit > Keyboard Shortcuts.

■ To select a tool located in the pop-up menu for a visible tool such as the Rectangle tool, press the icon of the visible tool and select another tool from the pop-up menu.

Customizing the Tools panel

You can customize the Tools panel to specify which tools appear in the authoring environment. You use the Customize Tools panel dialog box to add or remove tools from the Tools panel.

You can display more than one tool in one location. When more than one tool is displayed in a location, the top tool in the group (the most recently used) is displayed with an arrow in the lower-right corner of its icon. When you press and hold the mouse button on the icon, the other tools in the group appear in a pop-up menu. You can then select a tool from the menu.
To customize the Tools panel:

1. To display the Customize Tools panel dialog box, do one of the following:
   - (Windows) Select Edit > Customize Tools panel.
   - (Macintosh) Select Flash > Customize Tools panel.

   The Available Tools menu indicates the tools that are currently available in the Flash. The Current Selection menu indicates the tool (or tools) currently assigned to the selected location in the Tools panel.

2. Click a tool in the Tools panel image or use the arrows to cycle through the tools to specify the location to which you want to assign another tool.

3. To add a tool to the selected location, select the tool in the Available Tools list and click the Add button. It is possible to assign a tool to more than one location.

4. To remove a tool from the selected location, select the tool in the Current Selection scroll list and click the Remove button.

5. Click OK to apply your changes and close the Customize Tools panel dialog box.

To restore the default Tools panel layout:

- Click Restore Default in the Customize Tools panel dialog box.

Using the grid, guides, and rulers

Flash can display rulers and guides that help you draw and lay out objects precisely. You can place guides in a document and snap objects to those guides, or turn on the grid and snap objects to it.

- You can also snap objects to other objects or to pixels, or align objects using specified snap tolerance boundaries. For more information, see “Snapping” in Using Flash.
Using rulers

When rulers are displayed, they appear along the top and left sides of the document. You can change the unit of measure used in the rulers from the default of pixels to some other unit. When you move an element on the Stage with the rulers displayed, lines indicating the element’s dimensions appear on the rulers.

To display or hide rulers:
- Select View > Rulers.

To specify the rulers’ unit of measure for a document:
- Select Modify > Document, and then select a unit from the Ruler Units menu at the lower-left side of the dialog box.

Using guides

You can drag horizontal and vertical guides from the rulers onto the Stage when the rulers are displayed. You can move guides, lock guides, hide guides, and remove guides. You can also snap objects to guides, and change the guide color and snap tolerance (how close objects must be to snap to a guide). Flash allows you to create nested timelines. Draggable guides appear on the Stage only when the Timeline in which they were created is active.

You can clear all the guides in the current editing mode—document-editing mode or symbol-editing mode. If you clear guides in document-editing mode, all the guides in the document are cleared. If you clear guides in symbol-editing mode, all the guides in all symbols are cleared.

To create custom guides or irregular guides, you use guide layers. For more information, see “Using guide layers” on page 66.

To display or hide the drawing guides:
- Select View > Guides > Show Guides.

NOTE

If the grid is visible and Snap to Grid is turned on when you create guides, guides will snap to the grid.
To turn snapping to guides on or off:
■ Select View > Snapping > Snap to Guides.

To move a guide:
1. Make sure rulers are visible by selecting View > Rulers.
2. With the Selection tool, click anywhere on the ruler and drag the guide to the desired place on the Stage.

To remove a guide:
■ With guides unlocked, use the Selection tool to drag the guide to the horizontal or vertical ruler. For information on locking and unlocking guides, see the following procedure.

To lock guides:
■ Select View > Guides > Lock Guides.

To set guide preferences:
1. Select View > Guides > Edit Guides and do any of the following:
   ■ For Color, click the triangle in the color box and select a guide line color from the palette. The default guide color is green.
   ■ Select or deselect Show Guides to display or hide guides.
   ■ Select or deselect Snap to Guides to turn snapping to guides on or off.
   ■ Select or deselect Lock Guides to lock or unlock guides.
   ■ For Snap Accuracy, select an option from the pop-up menu.
   ■ If you want to remove all guides, click Clear All.
   ■ Clear All removes all guides from the current scene.
   ■ If you want to save the current settings as the default, click Save Default.
2. Click OK.
To clear guides:

- Select View > Guides > Clear Guides.
  If you are in document-editing mode, all guides in the document are cleared. If you are in symbol-editing mode, only guides used in symbols are cleared.

Using the grid

When the grid is displayed in a document, it appears as a set of lines behind the artwork in all scenes. You can snap objects to the grid, and you can modify the grid size and grid line color.

To display or hide the drawing grid, do one of the following:

- Select View > Grid > Show Grid.
- Press Control+'' (quote) (Windows) or Command+'' (quote) (Macintosh).

To turn snapping to grid lines on or off:

- Select View > Snapping > Snap to Grid.

To set grid preferences:

1. Select View > Grid > Edit Grid.
2. For Color, click the triangle in the color box and select a grid line color from the palette.
   The default grid line color is gray.
3. Select or deselect Show Grid to display or hide the grid.
4. Select or deselect Snap to Grid to turn snapping to grid lines on or off.
5. For grid spacing, enter values in the text boxes to the right of the horizontal and vertical arrows.
6. For Snap Accuracy, select an option from the pop-up menu.
7. If you want to save the current settings as the default, click Save Default.
Using panels and the Property inspector

Flash offers many ways to customize the workspace to your needs. Using panels and the Property inspector, you can view, organize, and change media and other assets and their attributes. You can show, hide, and resize panels. You can also group panels together and save custom panel sets to make the workspace match your personal preferences. The Property inspector changes to reflect the tool or asset you are working with, giving you quick access to frequently used features.

About the Property inspector

The Property inspector simplifies document creation by making it easy to access the most commonly used attributes of the current selection, either on the Stage or in the Timeline. You can make changes to the object or document attributes in the Property inspector without accessing the menus or panels that also control these attributes.

Depending on what is currently selected, the Property inspector displays information and settings for the current document, text, symbol, shape, bitmap, video, group, frame, or tool. When two or more different types of objects are selected, the Property inspector displays the total number of objects selected.

*The Property inspector showing the properties for the Text tool*

To display the Property inspector, do one of the following:

- Select Window > Properties > Properties.
- Press Control+F3 (Windows) or Command+F3 (Macintosh).
About the Library panel

The Library panel is where you store and organize symbols created in Flash, as well as imported files, including bitmap graphics, sound files, and video clips. The Library panel lets you organize library items in folders, see how often an item is used in a document, and sort items by type. For more information, see “Managing media assets with the library” in Using Flash.

The Library panel showing a movie clip symbol

To display the Library panel, do one of the following:

- Select Window > Library.
- Press Control+L (Windows) or Command+L (Macintosh).

About the Actions panel

The Actions panel lets you create and edit ActionScript code for an object or frame. Selecting a frame, button, or movie clip instance makes the Actions panel active. The Actions panel title changes to Button Actions, Movie Clip Actions, or Frame Actions, depending on what is selected.
For information on using the Actions panel and writing ActionScript code, including switching between editing modes, see "Using the Actions panel and Script window" in *Learning ActionScript 2.0 in Flash*.

![The Actions panel showing a `stop()` action in a frame](image)

**To display the Actions panel, do one of the following:**

- Select Window > Actions.
- Press F9.

**Using panels**

The various panels in Flash help you view, organize, and change elements in a document. The options available in panels control the characteristics of symbols, instances, colors, type, frames, and other elements. You can customize the Flash interface by displaying the panels you need for a specific task and hiding others.

Panels let you work with objects, colors, text, instances, frames, scenes, and entire documents. For example, you use the Color Mixer panel to create colors, and the Align panel to align objects to each other or the Stage. To view the complete list of panels available in Flash, see the Window menu.

Most panels include a pop-up menu with additional options. This pop-up menu is indicated by a control at the right end of the panel's title bar. (If no pop-up menu control appears, there is no pop-up menu for that panel.)

By default, panels appear grouped at the bottom and at the right of the Flash workspace.
To open a panel:

- Select the desired panel from the Window menu.

To close a panel, do one of the following:

- Select the desired panel from the Window menu.
- Right-click (Windows) or Control-click (Macintosh) the panel’s title bar and select Close Panel Group from the context menu.

To use a panel’s pop-up menu:

1. Click the control at the far right in the panel’s title bar to view the pop-up menu.
2. Click an item in the menu.

![Clicking a panel's pop-up menu](image)

To resize a panel:

- Drag the panel’s border (Windows) or drag the size box at the panel’s lower-right corner (Macintosh).

To expand or collapse a panel to its title bar:

- Click the collapse arrow in the title bar. Click the collapse arrow again to expand the panel to its previous size.

![Clicking a panel's collapse arrow](image)

To close all panels:

- Select Window > Hide Panels.

Arranging panels

In Flash, you can organize panels into groups. You can rearrange the order in which panels appear within panel groups. You can also create new panel groups and dock panels to existing panel groups. If you want a panel to appear on its own, separated from other panel groups, you can float the panel. This is particularly useful for panels that you want access to all the time, for example, the Help panel or the Actions panel.
To move a panel:
■ Drag the panel by its gripper (on the left side of the title bar).

To add a panel to an existing panel group:
■ Drag the panel by its gripper onto another panel. A black line appears next to the target panel to show where the panel will be placed.

To display multiple panels in a single panel window:
1. Click a panel’s pop-up menu.
2. Select the Group Panel Name With option.
3. Select another panel to add the current panel to from the submenu.
   The first panel is added as a tab to the second panel.

To float a panel:
■ Drag the panel by its gripper and move it away from other panels.

To create a new panel group:
■ Drag the panel by its gripper, away from other panel groups. Add additional panels to the first panel to form a new group.

Using panel sets
You can create custom panel arrangements, and save these as custom panel sets. You can switch the panel display to the default layout (displaying the Color Mixer, Actions, Property inspector and Library panels) or to a custom layout that you have saved previously.

To save a custom panel set:
1. Select Window > Workspace Layout > Save Current.
2. Enter a name for the layout and click OK.
To select a panel layout:
1. Select Window > Workspace Layout.
2. From the submenu, select Default Layout to reset panels to the default layout, or select a custom layout that you have saved previously.

To delete custom layouts:
1. Select Window > Workspace Layout > Manage.
2. In the Manage Workspace Layouts dialog box, select the panel set you want to delete.
3. Click Delete.
4. Click Yes to confirm the deletion.
5. Click OK.

Setting preferences in Flash
Flash lets you set preferences for general application operations, editing operations, and Clipboard operations. For more information about the drawing preferences, see “Specifying drawing settings” in *Using Flash.*

The General category in the Preferences dialog box
To set preferences:

1. Select Edit > Preferences (Windows) or Flash > Preferences (Macintosh).

2. In the Category list, select the one of the following:
   - General
   - ActionScript
   - Auto Format
   - Clipboard
   - Drawing
   - Text
   - Warning

3. Select from the respective options as described in the procedures that follow. For more information on ActionScript Editor preferences, see “About ActionScript preferences” in Learning ActionScript 2.0 in Flash.

To set General preferences, select from the following options:

- For On Launch options, select an option to specify which document Flash opens when you start the application. Select Show Start Page to display the Start Page. Select New Document to open a new, blank document. Select Last Documents Open to open the documents that were open when you last quit Flash. Select No Document to start Flash without opening a document.

- For Undo, enter a value from 2 to 300 to set the number of undo/redo levels. Undo levels require memory; the more undo levels you use, the more system memory is consumed. The default is 100. Next select Document- or Object-level undo. Document-level undo maintains a single list of all your actions for the entire Flash document. Object-level undo maintains separate lists of your actions for each object in your Flash document. Object-level undo gives you greater flexibility, since you can undo an action on one object without having to also undo actions on other objects that may have been modified more recently than the target object.

- For Printing Options (Windows only), select Disable PostScript if you want to disable PostScript output when printing to a PostScript printer. By default, this option is deselected. Select this option if you have problems printing to a PostScript printer, but keep in mind that this will slow down printing.
For Test Movie Options, select Open Test Movie in Tabs to have Flash open a new document tab in the application window when you select Control > Test Movie. The default is to open the test movie in its own window.

For Selection Options, select or deselect Shift Select to control how Flash handles selection of multiple elements. When Shift Select is off, clicking additional elements adds them to the current selection. When Shift Select is on, clicking additional elements deselects other elements unless you hold down Shift.

Select Show Tooltips to display tooltips when the pointer pauses over a control. Deselect this option if you don’t want to see the tooltips.

Select Contact Sensitive to have objects become selected when any part of them is included in the marquee rectangle when dragging with the Selection or Lasso tools. The default is that objects are only selected when the tool’s marquee rectangle completely surrounds the object.

For Timeline Options, select Span Based Selection to use span-based selection in the Timeline, rather than the default frame-based selection. For more information on span-based and frame-based selection, see “Working with frames in the Timeline” on page 59.

Select Named Anchor on Scenes to have Flash make the first frame of each scene in a document a named anchor. Named anchors let you use the Forward and Back buttons in a browser to jump from scene to scene in a Flash application. For more information, see “Using the Timeline” on page 54.

For Highlight Color, select a color from the panel, or select Use Layer Color to use the current layer’s outline color.

For Project, select Close Files with Project to have all files in a project close when the project file is closed. Select Save Files on Test or Publish Project to have each file in a project saved whenever the project is tested or published. For more information, see “Creating and managing projects (Flash Professional only)” in Using Flash.

To set ActionScript preferences:

See “About ActionScript preferences” in Learning ActionScript 2.0 in Flash.
To set AutoFormat preferences for ActionScript:
- Select any of the check boxes. To see the effect of each selection, look in the Preview pane.

To set Clipboard preferences, select from the following options:
- For Bitmaps (Windows only), select options for Color Depth and Resolution to specify these parameters for bitmaps copied to the Clipboard. Select Smooth to apply anti-aliasing. Enter a value in the Size Limit text box to specify the amount of RAM that is used when placing a bitmap image on the Clipboard. Increase this value when working with large or high-resolution bitmap images. If your computer has limited memory, select None.
- For Gradient Quality (Windows only), select an option to specify the quality of gradient fills placed in the Windows metafile. Choosing a higher quality increases the time required to copy artwork. Use this setting to specify gradient quality when pasting items to a location outside of Flash. When you are pasting within Flash, the full gradient quality of the copied data is preserved regardless of the Gradients on Clipboard setting.
- For PICT Settings (Macintosh only), for Type, select Objects to preserve data copied to the Clipboard as vector artwork, or select one of the bitmap formats to convert the copied artwork to a bitmap. Enter a value for Resolution. Select Include PostScript to include PostScript data. For Gradients, select an option to specify gradient quality in the PICT. Choosing a higher quality increases the time required to copy artwork. Use the Gradients setting to specify gradient quality when pasting items to a location outside of Flash. When you are pasting within Flash, the full gradient quality of the copied data is preserved regardless of the Gradient setting.
- For FreeHand Text, select Maintain Text as Blocks to keep text editable in a pasted FreeHand file.

To set Drawing preferences:
- For Pen Tool options, see “Setting Pen tool preferences” in Using Flash.
- For Drawing Settings, see “Specifying drawing settings” in Using Flash.
To set text preferences, select one of the following options:

- For Font Mapping Default, select a font to use when substituting missing fonts in documents you open in Flash. For more information, see “Substituting missing fonts” in Using Flash.

- For Vertical Text options, select Default Text Orientation to make the default orientation of text vertical, which is useful for some Asian language fonts. By default, this option is deselected. Select Right to Left Text Flow to reverse the default text display direction. This option is deselected by default.

- Select No Kerning to turn off kerning for vertical text. This option is deselected by default but is useful to improve spacing for some fonts that use kerning tables.

- For Input Method, select the appropriate language.

To set warning preferences, select one of the following options:

- Select Warn on Save for Macromedia Flash 8 Compatibility to have Flash warn you when you try to save documents with content that is specific to the Flash Basic 8 or Flash Professional 8 authoring tool as a Flash MX 2004 file. This option is selected by default.

- Select Warn on Missing Fonts to have Flash warn you when you open a Flash document that uses fonts that are not installed on your computer. This option is selected by default.

- Select Warn on URL Changes in Launch and Edit to have Flash warn you if the URL for a document has changed since the last time you opened and edited it.

- Select Warn on Reading Generator Content to have Flash display a red X over any Generator objects as a reminder that Generator objects are not supported in Flash 8.

- Select Warn on Inserting Frames when Importing Content to have Flash alert you when it inserts frames in your document to accommodate audio or video files that you import.

- Select Warn on Encoding Conflicts When Exporting *.as Files to have Flash alert you when selecting Default Encoding could potentially lead to data loss or character corruption. (For example, if you create a file with English, Japanese, and Korean characters and select Default Encoding on an English system, the Japanese and Korean characters will be corrupted.)
■ Select Warn on Conversion of Effect Graphic Objects to have Flash warn you when you attempt to edit a symbol that has timeline effects applied to it.

■ Select Warn on Exporting to Flash Player 6 r65 to have Flash warn you when you export a document to this earlier version of Flash Player.

■ Select Warn on Sites with Overlapped Root Folder to have Flash warn you when you create a site in which the local root folder overlaps with another site.

■ Select Warn on Behavior Symbol Conversion to have Flash warn you when you convert a symbol with a behavior attached to a symbol of a different type—for example, when you convert a movie clip to a button.

■ Select Warn on Symbol Conversion to have Flash warn you when you convert a symbol to a symbol of a different type.

■ Select Warn on Automatically Converting from Drawing Object to Group to have Flash warn you when it converts a graphic object drawn in Object Drawing mode to a group.

■ Select Show Incompatibility Warnings on Feature Controls to have Flash display warnings on controls for features not supported by the Flash Player version that the current FLA file is targeting in its Publish Settings.

Customizing keyboard shortcuts

You can select keyboard shortcuts in Flash to match the shortcuts you use in other applications, or to streamline your Flash workflow. By default, Flash uses built-in keyboard shortcuts designed for the Flash application. You can also select a built-in keyboard shortcut set from one of several popular graphics applications, including Macromedia Fireworks, Adobe Illustrator, and Adobe Photoshop.

To create a custom keyboard shortcut set, you duplicate an existing set, and then add or remove shortcuts from the new set. You can also delete custom shortcut sets.
To view or print the current set of keyboard shortcuts:
1. Select Edit > Keyboard Shortcuts.
2. In the Keyboard Shortcuts dialog box, select the shortcut set you wish to view from the Current pop-up menu.
3. Click the Export Set as HTML button.

4. In the Save As dialog box that appears, select a name and location for the exported HTML file. The default file name is the name of the selected shortcut set.
5. Click Save.
6. Find the exported file in the folder you selected and open the file in a web browser.
7. To print the file, use the browser’s Print command.

To select a keyboard shortcut set:
1. Select Edit > Keyboard Shortcuts (Windows) or Flash > Keyboard Shortcuts (Macintosh).
2. In the Keyboard Shortcuts dialog box, select a shortcut set from the Current Set pop-up menu.

To create a new keyboard shortcut set:
1. Select a keyboard shortcut set as described in the previous procedure.
2. Click the Duplicate Set button.
3. Enter a name for the new shortcut set and click OK.

To rename a custom keyboard shortcut set:
1. In the Keyboard Shortcuts dialog box, select a shortcut set from the Current Set pop-up menu.
2. Click the Rename Set button.
3. In the Rename dialog box, enter a new name and click OK.
To add or remove a keyboard shortcut:
1. Select Edit > Keyboard Shortcuts (Windows) or Flash > Keyboard Shortcuts (Macintosh) and select the set that you want to modify.
2. From the Commands pop-up menu, select Drawing Menu Commands, Drawing Tools, Test Movie Menu Commands, or Workplace Accessibility Commands to view shortcuts for the selected category.
3. In the Commands list, select the command for which you want to add or remove a shortcut.
   An explanation of the selected command appears in the description area in the dialog box.
4. Do one of the following:
   - To add a shortcut, click the Add Shortcut (+) button.
   - To remove a shortcut, click the Remove Shortcut (-) button and proceed to step 6.
5. If you are adding a shortcut, enter the new shortcut key combination in the Press Key text box.
6. Click Change.
7. Repeat this procedure to add or remove additional shortcuts.
8. Click OK.

To delete a keyboard shortcut set:
1. Select Edit > Keyboard Shortcuts (Windows) or Flash > Keyboard Shortcuts (Macintosh). In the Keyboard Shortcuts dialog box, click the Delete Set button.
2. In the Delete Set dialog box, select a shortcut set and click Delete.

**NOTE**
To enter the key combination, simply press the keys on the keyboard. You do not need to spell out key names, such as Control, Option, and so on.

**NOTE**
You cannot delete the built-in keyboard shortcut sets that ship with Flash.
Using context menus

Context menus contain commands relevant to the current selection. For example, when you select a frame in the Timeline window, the context menu contains commands for creating, deleting, and modifying frames and keyframes. Context menus exist for many items and controls in many locations, including on the Stage, in the Timeline, in the Library panel, and in the Actions panel.

To open a context menu:
- Right-click (Windows) or Control-click (Macintosh) an item.

Accessibility in the Flash authoring environment

Accessibility support in the Flash authoring environment provides keyboard shortcuts for navigating and using interface controls, including panels, the Property inspector, dialog boxes, the Stage, and objects on the Stage, so that you can work with these interface elements without using the mouse.

You can customize the keyboard shortcuts for accessibility in the authoring environment using the Workspace Accessibility Commands section of the Keyboard Shortcuts dialog box. For more information, see “Customizing keyboard shortcuts” on page 83.

Some authoring environment accessibility features are unavailable on the Macintosh. For more information, see the following section.

NOTE
 Certain keyboard controls are available only in Windows. For more information, see “About Flash authoring accessibility on the Macintosh” on page 87.
About Flash authoring accessibility on the Macintosh

Accessibility for the Flash authoring environment on the Macintosh has the following limitations:

■ The Panel Focus keyboard shortcut (Command+Option+Tab) is not supported for the Property inspector.
■ The Panel Control Focus keyboard shortcut (Tab) is supported only for the Timeline, not for other panels or the Property inspector.

Selecting panels or the Property inspector with keyboard shortcuts

You can select a panel or the Property inspector (also referred to as applying focus to the panel or Property inspector) by using the keyboard shortcut Control+Alt+Tab (Windows) or Command+Option+Tab (Macintosh).

You can apply focus to a panel or the Property inspector only when the panel or Property inspector is visible in the Flash application window. The panel can be expanded or collapsed.

When you use the keyboard shortcut to select panels, focus is applied to panels using the following criteria:

■ Docked panels are given focus first.
■ If the Timeline is displayed and docked, the Timeline is given focus the first time you press Control+Alt+Tab (Windows) or Command+Option+Tab (Macintosh).
■ If the Timeline is not displayed and docked, or if you press the keyboard shortcut again, focus moves to the rightmost and highest docked panel. Pressing the keyboard shortcut repeatedly then moves the focus through the other docked panels, from right to left and from top to bottom of the workspace.
■ If you move the focus through all the docked panels, or if there are no docked panels displayed, focus then moves to the rightmost and highest floating panel. Pressing the keyboard shortcut repeatedly then moves the focus through the other floating panels, from right to left and from top to bottom of the workspace.
To use keyboard shortcuts to select or deselect, expand, or collapse panels or the Property inspector:

- To move the focus through the panels currently displayed in the workspace, press Control+Alt+Tab (Windows) or Command+Option+Tab (Macintosh). A dotted line appears around the title of the currently focused panel.
- To move the focus to the previously selected panel, press Control+Shift+Alt+Tab (Windows) or Command+Shift+Option+Tab (Macintosh).
- To deselect a panel, press Escape, or move, dock, or undock the panel.
- To move the focus to the panel above or below the current panel in a panel group, press the Up Arrow or Down Arrow key.

To use keyboard shortcuts to expand or collapse panels or the Property inspector:

1. Press Control+Alt+Tab (Windows) or Command+Option+Tab (Macintosh) until the panel you wish to expand or collapse has focus. A dotted line appears around the title of the currently focused panel.
2. Press the Spacebar to expand or collapse the currently selected panel.

To hide all panels and the Property inspector:

- Press F4. Press F4 again to display all panels and the Property inspector.

Selecting controls in a panel or the Property inspector using keyboard shortcuts

When a panel or the Property inspector has the current focus, you can use the Tab key to move the focus through the panel controls. You can use the Spacebar to activate the control that has the current focus (that is, pressing Spacebar is equivalent to clicking a control in the panel).

When you use the keyboard shortcut for panel controls, focus is applied to a control and the control is activated using the following criteria:

- The panel with the current focus must be expanded in order for you to select a control in the panel with the Tab key. If the panel is collapsed, pressing Tab has no effect.
- When the panel with the current focus is expanded, pressing Tab the first time moves the focus to the panel’s pop-up menu.
■ You can use the Right Arrow and Left Arrow keys to move the focus between the pop-up menu and the panel title bar.

■ If the focus is on the pop-up menu, pressing Tab again moves the focus through the other controls in the panel. Pressing Tab again will not return the focus to the panel pop-up menu.

■ When the pop-up menu has the focus, you can press Enter (Windows only) to display the pop-up menu items.

■ In panels that are grouped, you can use the Up Arrow and Down Arrow keys to move the focus between the pop-up menus of the panels in the group.

■ You can move the focus to a panel control only if the control is active. If a control is dimmed (inactive), you cannot apply focus to the control.

To move the focus from a panel title bar to a panel pop-up menu, do one of the following:

■ Press Tab.

■ Press the Right Arrow key. Press the Left Arrow key or Shift+Tab to return the focus to the panel title bar.

■ If the panel is in a group, press the Up Arrow key to move the focus to the pop-up menu of the panel immediately above the panel with the current focus. Press the Down Arrow key to move the focus to the pop-up menu of the panel immediately below the panel with the current focus.

To move the focus through the items in a panel pop-up menu:

1. With the focus currently applied to the panel pop-up menu, press the Spacebar to display the pop-up menu items.

2. Press the Down Arrow key to move through the items in the pop-up menu.

3. Press Enter (Windows) or Return (Macintosh) to activate the currently selected pop-up menu item.
To move the focus through the controls in a panel:
1. Press Tab when the focus is currently applied to the panel pop-up menu. Press Tab repeatedly to move the focus through the controls in the panel.
2. Press Enter (Windows only) to activate the currently selected panel control.

Navigating dialog box controls using keyboard shortcuts (Windows only)

In Windows operating systems, you can use keyboard shortcuts to navigate controls in dialog boxes. You can move from one control to another, apply controls, or cancel and exit the dialog box.

To navigate dialog box controls using keyboard shortcuts:
Do any of the following:
- Press Tab to move through the controls in the dialog box.
- To move through the controls within one section of a dialog box, press the Up Arrow and Down Arrow keys. For example, in the Spelling Setup dialog box, press the Up Arrow and Down Arrow keys to move through the controls within the Document Options section.
- When the focus is applied to a dialog box control button—such as the OK, Cancel, or Apply button—press Enter to activate the button (equivalent to clicking the button).
- When the focus is not applied to any dialog box control button—such as the OK, Cancel, or Apply button—press Enter to apply the current settings and close the dialog box (equivalent to clicking OK).
- Press Escape to close the dialog box without applying the changes (equivalent to clicking Cancel).
- When the focus is applied to the Help button, press Enter or Spacebar to view the Help content for the dialog box (equivalent to clicking Help).
Selecting the Stage or objects on the Stage using keyboard shortcuts

You can select the Stage or an object on the Stage using keyboard shortcuts. Selecting the Stage with a keyboard shortcut is equivalent to clicking on the Stage. Any other element currently selected becomes deselected when the Stage is selected.

Once the Stage is selected, you can use the Tab key to navigate through all objects on all layers, one at a time. You can select instances (including graphic symbols, buttons, movie clips, bitmaps, videos, or sounds), groups, or text boxes. You cannot select shapes (such as rectangles) unless those shapes are instances of symbols. You cannot select more than one object at a time using keyboard shortcuts. Objects are selected on the Stage using the following criteria:

- If an object is currently selected, pressing Shift+Tab selects the previous object.
- Pressing Tab the first time selects the first object that was created on the active frame in the active layer. When the last object on the top layer is selected, pressing Tab moves to the next layer beneath it and selects the first object there, and so on.
- When the last object on the last layer is selected, pressing Tab moves to the next frame and selects the first object on the top layer there.
- Objects on layers that are hidden or locked cannot be selected with the Tab key.

**NOTE**

If you are currently typing text into a text box, you cannot select an object using the keyboard focus. You must first change the focus to the Stage and then select an object.

**To select the Stage:**

- Press Control+Alt+Home (Windows) or Command+Option+Home (Macintosh).

**To select an object on the Stage:**

- With the Stage selected, press Tab.
Navigating tree controls using keyboard shortcuts

You can navigate tree structures, the hierarchical displays of file structures in certain Flash panels, using keyboard shortcuts. You can expand and collapse folders in the tree control and move up and down between parent and child folders.

To navigate tree controls with keyboard shortcuts, do any of the following:

- To expand a collapsed folder, select the folder and press the Right Arrow key.
- To collapse an expanded folder, select the folder and press the Left Arrow key.
- To move to the parent folder of an expanded folder, press the Left Arrow key.
- To move to the child folder of an expanded folder, press the Right Arrow key.

Working with library items using keyboard shortcuts

You can cut, copy, and paste library items using keyboard shortcuts. You can cut or copy an item from the Library panel and paste it onto the Stage or into another library, or paste a folder into another library. If you paste a folder, each item in the folder is included.

You can use keyboard shortcuts to select a library item. For more information, see “Navigating tree controls using keyboard shortcuts” on page 92.

Items are cut, copied, and pasted using the following criteria:

- You can cut or copy one item or multiple items.
- You cannot paste a shape from the Stage into the library.
- You cannot paste a library item into a common library, because common libraries cannot be modified. However, you can create a new common library. For more information, see “Working with common libraries” in Using Flash.
- When you paste a library item onto the Stage, the item is centered.
- To paste a library item into a folder in the destination library, you can click the folder before pasting.
- You can paste a library item into a different location in the same library where it originated.
- If you attempt to paste a library item into a location containing another item by the same name, you can select whether to replace the existing item.

To cut, copy, and paste library items using keyboard shortcuts:
- To copy or paste a selected library item, press Control+X (Windows) or Command+X (Macintosh) to cut the item, or press Control+C (Windows) or Command+C (Macintosh) to copy the item.
- To paste a cut or copied item, click the Stage or in another library to set the insertion point, and press Control+V (Windows) or Command+V (Macintosh) to paste in the center of the Stage, or press Control+Shift+C (Windows) or Command+Shift+C (Macintosh) to paste in place (in the same location as the original).
CHAPTER 3

Tutorial: Building Your First Flash Application

This tutorial guides you through the process of creating a simple application using some of the authoring features in Macromedia Flash Basic 8 and Flash Professional 8. A Flash application, broadly defined, can be as simple as content that offers interactivity, or as elaborate as a robust application that interacts with a variety of data sources.

If you have not already done so, Macromedia recommends that before you take this tutorial you read “Flash basics” on page 57.

In this tutorial, you will complete the following tasks:

- Review your task .......................................................... 96
- Examine the completed application ............................... 96
- Create a working folder ................................................ 98
- Create a new document ................................................ 99
- Create symbols ............................................................... 102
- Edit a symbol Timeline .................................................. 106
- Add actions to frames .................................................... 108
- Add labels to frames ...................................................... 109
- Add motion tweens ....................................................... 110
- Edit the main Timeline ................................................ 112
- Create the border ........................................................ 113
- Add a symbol ................................................................. 119
- Add a text box ............................................................... 120
- Add the movie clip to the Stage .................................... 123
- Add a button component .............................................. 124
- Add ActionScript code ................................................. 125
- Publish your document .................................................. 131
Review your task

In this tutorial, you will create a type of application known as a flexible messaging area, or FMA for the web site of a fictional restaurant called Cafe Townsend. An FMA is a common type of Flash application used for displaying content that conveys some kind of informational or marketing message to the audience. In this case, the FMA displays photographs of items from a restaurant menu. At Macromedia’s website, an FMA is used to display information about new software products and other advertising messages. These are called flexible messaging areas because they usually occupy an area of the web page that is set aside for content that can change depending on the needs of the business or website. For example, if the fictional restaurant Cafe Townsend has a special event planned, its FMA could change to display the details of that event instead of the restaurant’s menu items.

In this tutorial, after examining a finished version of the FMA, you’ll begin by creating a new Flash document and end by publishing the application for web playback. The tutorial should take approximately 30 minutes to complete.

The completed FMA

Examine the completed application

As you examine the finished version of the application you’ll create, you will also gain some familiarity with the Flash workspace.

In subsequent sections of this tutorial, you’ll follow the steps to create the application yourself.
Run the completed application

To better understand the type of application you’ll create as you work through this tutorial, you can look at a completed FLA file version of the application in the Flash authoring tool. FLA files are the type of files you work on in Flash. You can also play the SWF version of the file in Flash Player. The SWF version is the version of the file that you would publish in a web page.

To play the SWF version of the file in Flash Player:
1. In Flash, select File > Open.
2. Browse to the completed file using one of the following paths:
   - In Windows, browse to boot drive\Program Files\Macromedia\Flash 8\Samples and Tutorials\Tutorial Assets\cafe_townsend\completed files\flash and double-click flash_fma_finished.swf.
   - On the Macintosh, browse to the Macintosh HD/Applications/Macromedia Flash 8/Samples and Tutorials/Tutorial Assets/cafe_townsend/completed_files/flash and double-click flash_fma_finished.swf.

   The completed application runs in Flash Player. Click Next to watch the images of food change with the animation.
3. After viewing the application, close the Flash Player window.

Open the authoring document

It’s helpful to look at the completed authoring FLA file to see how the author designed the application.

To view the authoring version of the file in Flash:
1. In Flash, select File > Open.
2. Browse to the authoring document using one of the following paths:
   - In Windows, browse to boot drive\Program Files\Macromedia\Flash 8\Samples and Tutorials\Tutorial Assets\cafe_townsend\completed files\flash and double-click flash_fma_finished.fla.
You now see the completed tutorial application in the Flash authoring environment.

3. After you have the file open, you can explore the Stage, the Library panel, and the Timeline.
   - On the Stage you will see a variety of graphic shapes, which you will learn to create later in this tutorial.
   - In the Library panel, you will see a list of symbols, or reusable assets, that the document uses.
   - In the Timeline, you will see a representation of how and when those symbols appear on the Stage.
   - In the Actions panel, you will see ActionScript code that controls navigation in the Flash document and imports image files for display when the Flash document plays.

You will learn more about the role of each of these parts of Flash as you complete the tutorial.

4. When you are finished viewing the finished document, close it and be sure not to save any changes to the file.

Create a working folder

Before you begin, you must create a working folder that includes the sample files used in the tutorials in *Getting Started with Flash*. This task consists of creating the working folder on your hard disk and copying the sample files from the Flash application folder to the working folder.

1. Create a new folder called local_sites somewhere on your hard disk. For example, create a folder called local_sites in either of the following locations:
   - (Windows) C:\Documents and Settings\your_user_name\My Documents\local_sites
   - (Macintosh) Hard Disk/Users/your_user_name/Documents/local_sites

   On the Macintosh, there’s a folder called Sites already in your user folder. Don’t use that Sites folder as your local folder; the Sites folder is where you place your pages to make them publicly accessible when you’re using the Macintosh as a web server.
2. Locate the cafe_townsend folder in the Flash application folder on your hard disk. If you installed Flash to its default location, the path to the folders is as follows:
   - (Windows) C:\Program Files\Macromedia\Flash 8\Samples and Tutorials\Tutorial_assets\cafe_townsend
   - (Macintosh) /Applications/Macromedia Flash 8/Samples and Tutorials/Tutorial_assets/cafe_townsend

3. Copy the cafe_townsend folder to your local_sites folder.

Create a new document

Now that you have seen the finished application you will create, it is time to create your own Flash document.

If you haven't already set up a working folder, you must do so before you begin. For instructions, see “Create a working folder” on page 98.

To learn how to create an application in Flash, you'll start with the very first step in the process: creating a new file.

Open a new document

Now you're ready to create your own version of the FMA.

To create a new document:
1. Select File > New.
2. In the New Document dialog box, select Flash Document and then click OK.
3. Select File > Save.
4. Name the file flash_fma.fla and save the file in the cafe_townsend folder you copied to the local_sites folder on your hard disk.

NOTE: As you complete the tutorial, remember to save your work frequently.
Define document properties

Configuring document properties is a common first step in Flash authoring. You can change the document properties at any time, but it is helpful to make certain decisions, such as the Stage size and background color, at the beginning of the process.

Document properties are properties that affect the entire Flash document, such as the size of the Stage or the background color. You can use the Property inspector to specify these settings.

To define document properties:

1. If the Property inspector isn’t open, select Window > Properties > Properties. (The default location of the Property inspector is at the bottom of the Flash application window.)

   The Property inspector

   If the Property inspector is not fully expanded, click the white triangle in the lower-right corner.

2. In the Property inspector, enter 60 in the Frame Rate text box.

   The application will play at 60 frames per second, an optimal frame rate for playing animations smoothly.

3. Click Size to set the Stage size.

   About the Property inspector   The Property inspector lets you view and change the specifications for selected objects. The specifications depend on the type of object selected. If you select a text object, for example, the Property inspector displays settings for viewing and modifying text attributes. Because you just opened a new document, the Property inspector shows the document settings.
4. In the Document Properties dialog box, enter 700 in the width text box and 150 in the height text box, and then click OK.
Flash automatically inserts the px (for pixel) after the number.

![Document Properties dialog box]

5. In the Timeline, click the value in the Zoom menu and enter 75%.
This makes it easier to see your entire document in the Document window.
Press Enter (Windows) or Return (Macintosh).

6. Save your work.
For more information about setting document properties, see “Creating or opening a document and setting properties” in Using Flash.
Create symbols

Next, you will create some symbols or reusable assets. Symbols allow you to use the same asset more than once without storing multiple copies of it in your FLA file. You store the symbol in the Library panel, and drag instances of the symbol to the Stage when you need them.

To create the symbol:
1. Select Insert > New Symbol.
2. In the Create New Symbol dialog box, type imageHolder in the Name text box.
   The default value for Behavior is Movie Clip. Leave this unchanged.
3. Click OK.
   The new symbol is added to the Library panel (Window > Library) and Flash enters symbol-editing mode.
4. In symbol-editing mode, Select the Rectangle tool from the Tools panel (Window > Tools).
5. Select white (#FFFFFF) from the Stroke Color Picker on the Tools panel.
6. Select light gray (#CCCCCC) from the Fill Color Picker in the Tools panel.

In symbol-editing mode, the Stage disappears and the main portion of the Flash application window becomes a drawing area where you can draw and edit the symbol.

About Symbols and the Library panel
Symbols are reusable assets that allow you to use a single asset more than once in your Flash document without duplicating the asset in the file. By keeping only one copy of the symbol in the Flash document, you keep the document file size low. A symbol can be as simple as a button or a graphic, or as complex as a movie clip. After you create a symbol, you store it in the Library panel. The Library panel stores and organizes all the symbols in your document. To reuse a symbol, you drag it from the Library panel to the Stage. When you do this, Flash creates a new instance of the symbol on the Stage. An instance is really just a reference to the original symbol; it tells Flash to “Draw a copy of the specified symbol here”. By using symbols and instances, you can keep your assets well-organized and your Flash file size low. In addition, you can update the appearance or behavior of all the instances of a specific symbol by editing the symbol. These changes are then reflected in all the instances of the symbol throughout your document.
7. Drag in the drawing area to draw a wide, flat rectangle.

8. Select the Selection tool from the Tools panel.

9. Double-click the rectangle you drew to select both its fill and its stroke.

10. In the Property inspector, enter 0 in both the X and Y text boxes. This locates the upper-left corner of the symbol in the upper-left corner of the Stage.

11. Enter 700 in the Width (W) text box and 150 in the Height (H) text box and press Enter (Windows) or Return (Macintosh).

The Property inspector with the correct width, height, X, and Y values

Individual instances of this first symbol that you created become the container for individual images your FMA will display. This is why you named it imageHolder. Next, you create another symbol that becomes a container for a stack of five instances of the imageHolder symbol. Later, you will animate this new symbol vertically to change the image that appears on the visible part of the Stage.

To create the second symbol with five imageHolder instances:
1. Select Insert > New Symbol.
2. In the Create New Symbol dialog box, enter slides in the Name text box and click OK.
   You remain in symbol-editing mode.
3. Select 25% from the Zoom menu in the Timeline.
4. In the Library panel (Window > Library), drag the imageHolder symbol to the drawing area.

You have now created an instance of the imageHolder symbol. This instance is part of the new slides symbol you are creating.

5. With the new instance still selected on the Stage, in the Property inspector, enter holder0 in the Instance Name text box.

This gives the instance its own name that is separate from the symbol name.

6. Also in the Property inspector, enter 0 in both the X and Y text boxes and press Enter (Windows) or Return (Macintosh).

This locates the upper-left corner of the holder0 instance at the upper-left corner of the slides symbol.

7. Drag the imageHolder symbol from the Library panel to the drawing area and place it just below the holder0 instance.

8. In the Property inspector, enter holder1 in the Instance Name text box.

9. Enter 0 in the X text box and 150 in the Y text box and press Enter or Return.

10. Repeat the process for a third, fourth, and fifth instance of the imageHolder symbol.

In the Property inspector, give the new instances the following properties:

Third instance:
- Instance Name = holder2
- X = 0
- Y = 300

Fourth instance:
- Instance Name = holder3
- X = 0
- Y = 450

Fifth instance:
- Instance Name = holder4
- X = 0
- Y = 600
You have now finished creating the symbol called slides. Next, you will create a third symbol that will contain an instance of the slides symbol. As you can see, nesting symbol instances inside other symbols is a common technique of Flash authoring.

**The completed slides symbol**

**To create the third symbol:**
1. Select Insert > New Symbol.
2. In the Create New Symbol dialog box, enter `slideShow` in the Name text box and click OK.
3. Drag the slides symbol you created in the previous section from the Library panel to the drawing area of the new slideShow symbol.
   
   This creates an instance of the slides symbol within the new slideShow symbol.

**The Library panel with the slides and slideShow symbols**
4. With the symbol instance still selected, in the Property inspector, enter 0 in the X and Y text boxes.

5. Still in the Property inspector, enter `slides_mc` in the `instanceName` text box.

### Edit a symbol Timeline

Now that you have created the three symbols, you will edit the `slideShow` symbol by adding animation to its Timeline. This animation causes the images of food in the completed document to slide upward when the user clicks a button that you will add later.

**To edit the `slideShow` symbol:**

1. Without leaving symbol-editing mode, click Insert Layer in the Timeline.

   ![The Insert Layer button in the `slideShow` symbol’s Timeline](image)

   This adds a layer to the `slideShow` symbol’s Timeline.

---

**About movie clips and nested Timelines**

Each movie clip symbol can have its own timeline that allows the movie clip to contain animation or ActionScript of its own. This is why you see the name of the symbol you are editing at the top of the Timeline when you are in symbol-editing mode.

Using symbols and nested timelines gives you great flexibility in how you build your Flash document and organize its functionality. A typical example of this is a car moving across the Stage with spinning wheels. The animation of the car moving across the Stage could be in the main Timeline of the Flash document. Each of the spinning wheels could be an instance of a movie clip symbol with its own timeline. The spinning animation of the wheels would be implemented in the movie clip timeline. This approach is much simpler to implement than creating an animation in the main timeline of the wheels, which are both spinning and moving across the Stage.
2. In the Timeline, select Frame 20 of Layers 1 and 2.

3. Select Modify > Timeline > Convert to Keyframes. This adds frames to the Timeline and adds keyframes to the selected frames (Frame 20).

4. Repeat the process by selecting Layers 1 and 2 in Frame 40 and selecting Modify > Timeline > Convert to Keyframes.

5. Repeat the process in Frames 60 and 80. You may need to use the scroll bar at the bottom of the Timeline to see these frames.
Add actions to frames

In this section, you will add a small amount of ActionScript to control how the playhead moves through the Timeline of the slideShow movie clip. By adding stop() methods, you cause the playhead to stop and wait at certain frames. Later you will add ActionScript code to make the playhead move again.

To add the ActionScript code:
1. In the Timeline, select Frame 1 of Layer 2.
2. Select Modify > Timeline > Convert to Keyframes.
   This adds a keyframe to the frame, so now there are keyframes in Frames 1 and 2 of Layer 2.
3. Select Frame 1 of Layer 2.
4. Open the Actions panel (Window > Actions).
   If the Actions panel is in Script Assist mode (you will see the text “To add an item, double-click or drag the item to the Script window” and will be unable to type in the Script window), click the Script Assist button in the Actions panel to exit Script Assist mode.
5. In the Actions panel, type the following ActionScript:
   stop();
   This code causes the playhead to stop playing the slideShow movie clip whenever it reaches Frame 1. A small ‘a’ appears in Frame 1 of Layer 1 of the Timeline. This indicates that ActionScript is present in that frame.
6. In the Timeline, select Frame 20 of Layer 2.
7. Select Modify > Timeline > Convert to Keyframes.
8. Select Frame 20 of Layer 2.
9. In the Actions panel, type the stop(); ActionScript.
10. In the Timeline, select frame 40 of Layer 2.
11. Select Modify > Timeline > Convert to Keyframes.
12. Select frame 40 of Layer 2.
13. In the Actions panel, type the stop(); ActionScript.
15. Select Modify > Timeline > Convert to Keyframes.
16. Select frame 60 of Layer 2.
17. In the Actions panel, type the stop(); ActionScript.
18. In the Timeline, select frame 80 of Layer 2.
19. In the Actions panel, type the stop(); ActionScript.

Add labels to frames

Now you will add labels to specific frames. By labeling a frame, you make it possible to refer to that frame in ActionScript. This allows you to write ActionScript code that performs actions on those frames. Later, you will add ActionScript code that makes the playhead jump to these labeled frames.

To add the frame labels:
1. In the Timeline, select Frame 2 of Layer 2.
2. In the Property inspector, enter slide0 in the Frame Label text box.
   A small flag icon and the frame label appear in Frame 2 of Layer 2 in the Timeline.
3. In the Timeline, select Frame 21 of Layer 2.
4. In the Property inspector, enter slide1 in the Frame Label text box.
5. In the Timeline, select Frame 41 of Layer 2.
6. In the Property inspector, enter slide2 in the Frame Label text box.
7. In the Timeline, select Frame 61 of Layer 2.
8. In the Property inspector, enter slide3 in the Frame Label text box.

The Timeline with the completed frame labels
Add motion tweens

A motion tween is a type of animation in which an object moves from one position to another. In this project, you will make the images of food animate upward when the user clicks on a button, which you will add later.

To add the motion tweens:
1. In the Timeline, select Frame 1 of Layer 1.
2. In the Property inspector, select Motion from the Tween menu.
   Frames 1 to 19 in Layer 1 become a motion tween. An arrow appears in those frames in the Timeline.
3. In the Property inspector, drag the slider next to the Ease text box until the value in the text box is 100.
   This number causes the tween to be eased at the end of the motion.
   This means the motion starts suddenly and ends more slowly.
4. In the Timeline, select Frame 20 in Layer 1.
5. In the Property inspector, select Motion from the Tween menu.
6. Drag the Ease slider up until the Ease value is 100.
7. Click the slides_mc movie clip instance on the Stage to select it.

About motion tweens
The name motion tween comes from the fact that the animation includes motion, and from the way that motion is created. The term tween is short for in between. You define motion-tweened animations by defining starting and ending positions for the object being animated, and then letting Flash calculate all of the in-between positions for the object. In this way, you can create smooth motion animations simply by setting the start and end positions of the object you are animating.

About easing animations
The default behavior of motion tweens is for the animation to proceed at the same speed throughout its entire duration. Often however, this doesn’t look very good to the eye. Just as a car doesn’t go from 0 to 50 mph instantly, your animations shouldn’t either. Easing an animation is the same as accelerating a car slowly. The term easing comes from the idea that you ease a car into motion, or ease it to a stop. By adding an easing value, you cause your motion tweens to begin or end more gradually.
8. In the Property inspector, enter -150 in the Y text box. This moves the slideshow movie clip instance upward 150 pixels in the keyframe in Frame 20. The motion tween from Frame 1 to Frame 20 slides the movie clip upward smoothly instead of causing the movie clip to jump from one position to the next.

9. In the Timeline, select Frame 40 in Layer 1.

10. In the Property inspector, select Motion from the Tween menu.

11. Drag the Ease slider up until the Ease value is 100.

12. Click the slides_mc movie clip instance on the Stage to select it.

13. In the Property inspector, enter -300 in the Y text box.

14. In the Timeline, select Frame 60 in Layer 1.

15. In the Property inspector, select Motion from the Tween menu.

16. Drag the Ease slider up until the Ease value is 100.

17. Click the slides_mc movie clip instance on the Stage to select it.

18. In the Property inspector, enter -450 in the Y text box.

19. In the Timeline, select Frame 80 in Layer 1.

20. Click the slides_mc movie clip instance on the Stage to select it.

21. In the Property inspector, enter -600 in the Y text box.

22. In the Timeline, click the number 1 in the Frame Number bar.

23. Press Enter (Windows) or Return (Macintosh).

A preview of the animation plays on the Stage. The stop(); ActionScript you entered previously is ignored in preview mode.

You have now finished creating the slideShow symbol, which contains its own complex internal timeline. Next, you will edit the main Timeline of your FLA file.

---

*The Timeline with the completed motion tweens*
Edit the main Timeline

Now you will return to the main Timeline of your Flash document to add details that affect the entire document.

To add layers to the main Timeline:
1. Click the Scene 1 icon at the top of the Timeline.
   You exit symbol-editing mode and return to the main Timeline of your FLA file.
2. Click the Insert Layer button at the bottom of the Timeline.
   A new layer appears above the existing layer in the Timeline.
3. Click Insert Layer three more times to insert three more layers.
   You now have four layers in the main Timeline.
4. Double-click the layer name Layer 5 to make the name editable.
5. Enter the name actions as the new layer name and press Enter (Windows) or Return (Macintosh).
6. Double-click the layer name Layer 4 and rename the layer nextButton.
7. Double-click the layer name Layer 3 and rename the layer border.
8. Double-click the layer name Layer 2 and rename the layer blueArea.
9. Double-click the layer name Layer 1 and rename the layer slideShow.

The 5 properly named layers in the Timeline

Now that you have added layers to the main Timeline, you are ready to add the slideShow movie clip to the Stage.
To add the slideShow movieClip to the Stage:
1. Click the slideShow layer name to make that layer active.
2. Drag the slideShow symbol from the Library panel to the Stage and align its upper-left corner with the upper left corner of the Stage.
3. With the new movie clip instance still selected on the Stage, go to the Property inspector and set the X and Y values to 0 to align the upper-left corner of the movie clip exactly with the corner of the Stage.
4. Still in the Property inspector, enter `slideShow_mc` as the instance name for the movie clip.
5. Save your work.

Create the border

Next, you will create a border for the Stage that will make the FMA look more visually appealing when you view it in a web page.

To create the border:
1. In the Timeline, select 100% from the Zoom menu.
2. In the Timeline, select the border layer by clicking the layer name.
3. Select the Rectangle tool in the Tools panel.
4. In the Tools panel, select no color from the Stroke Color Picker.

![Selecting No Stroke from the Stroke Color Picker](image)
5. Select the color black (#000000) from the Fill Color Picker.

![Selecting black from the Fill Color Picker](image)

6. Draw a rectangle on the Stage that is approximately the same shape as the Stage.

![Drawing a black rectangle the shape of the Stage](image)

7. In the Tools panel, select the Selection tool.
8. On the Stage, click the rectangle you just drew to select it.
9. Select Window > Align to open the Align panel.
10. In the Align panel, click the To Stage option so it is selected. This allows the Align panel to align the selected rectangle with the Stage area.

The Align panel with the To Stage option selected

11. In the Align panel, find the Match-size area and click the Match Width and Height button. Your rectangle becomes the same size as the Stage area.

Clicking the Match Width and Height button

12. With the rectangle still selected, click the Align Vertical Center button in the Align panel. Use the tooltips to find the correct button in the Align panel.

Clicking the Align Vertical Center button
13. Still in the Align panel, click the Align Horizontal Center button.

![Clicking the Align Horizontal Center button](image1)

*Clicking the Align Horizontal Center button*

The rectangle is now precisely centered on the Stage.

![The black rectangle centered on the Stage](image2)

*The black rectangle centered on the Stage*

14. Click outside the Stage to deselect the black rectangle.

15. In the Tools panel, select the Rectangle tool.
16. Still in the Tools panel, select the color blue with the hexadecimal value #0000FF from the Fill Color Picker.

![Fill Color Picker](image)

17. In the Tools panel, double-click the Rectangle tool.
18. In the Rectangle Settings dialog box, enter 16 in the Corner Radius text box and click OK.

![Rectangle Settings](image)

19. Select View > Snapping > Snap to Pixels to turn on pixel snapping. This causes the edges of shapes that you draw to snap to the nearest pixel as you draw.

20. With the Rectangle tool still selected in the Tools panel, draw a rectangle on the Stage as close to the same size as the Stage as possible.

![Blue Rounded Rectangle](image)

*The blue rounded-corner rectangle on the Stage*
21. In the Tools panel, click the Selection tool.
22. Click the blue rectangle to select it.
23. With the blue rectangle selected, go to the Property inspector panel and enter the following values in the text boxes:
   - W: 700
   - H: 150
   - X: 0
   - Y: 0

   ![The properly sized blue rectangle on the Stage](image)

24. Double-click the blue rectangle again to select it.
25. Press Delete to delete the blue rectangle.

   A white rectangle appears in the middle of the black rectangle you drew earlier. The blue rectangle functioned as a mask in this step. You now have a black border at the top and bottom of the Stage.

   ![The Stage with only the black corners remaining](image)
Add a symbol

In this section, you will add a blue-colored area to the right side of the Stage. This is where the text that describes each menu item and the button for switching menu items will appear.

To add a new symbol with a blue shape:
1. Click the blueArea layer name in the Timeline.
2. Select Insert > New Symbol.
3. In the Create New Symbol dialog box, enter menu in the Name text box and click OK.
   You enter symbol-editing mode and the Timeline panel switches to displaying the Timeline of the new blueArea movie clip.
4. In the Tools panel, select the Rectangle tool.
5. Select No Stroke from the Stroke Color Picker.
6. Click the Fill Color swatch to display the Fill Color Picker.
7. In the Fill Color Picker, enter 80% in the Alpha text box.
8. Still in the Fill Color Picker, enter 343469 in the Color text box and press Enter (Windows) or Return (Macintosh).
   This creates a grayish-blue color.
9. In the Tools panel, double-click the Rectangle tool.
10. In the Rectangle Settings dialog box, enter 0 in the Corner Radius text box and click OK.
11. With the Rectangle tool, draw a flat, wide rectangle on the Stage.
12. In the Tools panel, click the Selection tool.
13. Double-click the rectangle you drew on the Stage to select it.
14. In the Property inspector panel, enter the following values for the rectangle shape:
   ■ W: 415
   ■ H: 150
   ■ X: 0
   ■ Y: 0
15. Press Enter or Return.
16. In the Tools panel, click the Subselection tool.

17. Move the mouse over the lower-left corner of the rectangle until a tiny white box appears next to the arrow pointer.

18. Drag the corner of the rectangle to the right so that the left side of the rectangle becomes a diagonal line at approximately a 30º angle.

19. In the Tools panel, click the Selection tool.

This deselects the control points on the rectangle.

**Add a text box**

Now that you have added the blue background to the menu movie clip, you are ready to add the text that describes each menu item. You will add two text boxes. The ActionScript code you add later will insert the text into these text boxes.
To add the text box for the menu item title:

1. In the Tools panel, click the Text tool.

2. In the Property inspector, select Dynamic Text from the Text Type menu.

3. Still in the Property inspector, enter 14 in the Font Size text box.

4. With the Text tool, draw a wide flat text rectangle in the top part of the gray-blue shape you just created.
   The rectangle should be almost as wide as the blue shape. Don't worry about the exact placement of the rectangle. You will adjust that later.

5. In the Tools panel, click the Selection tool.

6. Click the text box you just drew to select it.

7. In the Property inspector panel, enter the following values:
   - Text Type: Dynamic Text
   - InstanceName: title_txt
   - X: 60
   - Y: 10
   - Font: Verdana
   - Font Size: 14
   - Text (fill) color: White
   - Style: Bold
   - Line Type: Single line

8. Save your document.
Add the second text box

Now you will add the second text box, which will hold the description text for each menu item.

**To add a text box for the descriptions:**

1. Click outside the Stage to deselect the text box you created in the previous section.
2. In the Tools panel, click the Text tool.
3. In the Property inspector, enter 12 in the Font Size text box.
4. Still in the Property inspector, deselect the bold icon.
5. Select Multiline from the Line Type menu.
6. With the Text tool, draw another text rectangle on the Stage, filling the lower part of the blue shape you created earlier, below the rectangle you drew in “To add the text box for the menu item title:” on page 121.
7. In the Tools panel, click the Selection tool.
8. With the second text rectangle still selected, go to the Property inspector panel and enter the following values:
   
   - Text Type: Dynamic Text
   - InstanceName: `description_txt`
   - X: 85
   - Y: 45
   - Font: Verdana
   - Font Size: 12
   - Color: White

*The Property inspector with the correct values entered*
9. In the Tools panel, click the Selection tool.

10. Click in the Stage area outside the shapes you have drawn to deselect them.

11. In the Timeline, click the Scene 1 link to exit symbol-editing mode and return to the main Timeline of the Flash document.

   You exit symbol-editing mode and the Stage with the black borders reappears.

12. Save your document.

Add the movie clip to the Stage

Now that you have completed the menu movie clip, you are ready to add it to the Stage in the main Timeline.

To add the menu movie clip to the Stage:
1. In the Tools panel, click the Selection tool to ensure that the tool is active.

2. In the Library panel (Window > Library), drag the menu movie clip and place it on the right side of the Stage.

3. With the menu movie clip still selected on the Stage, go to the Property inspector and enter the following values:
   InstanceName: menu_mc
   W: 415
   H: 150
   X: 285
   Y: 0

4. With the menu movie clip still selected, go to the Property inspector and select Alpha from the Color menu.

5. Drag the Alpha Amount slider until the value is 90%.
Add a button component

Now you are ready to add the button that allows the user to switch from one slide to the next in the slide show.

To add the Next button:

1. In the Timeline, click the nextButton layer name to make that layer active.
   This is the layer that holds the button component you are about to add.

2. Open the Components panel if it is not already open by selecting Window > Components.

3. In the Components panel, open the User Interface category by clicking the plus sign (+) next to the User Interface category name.

4. Drag the Button component from the Components panel to the lower part of the blue rectangle on the Stage.
   The button stays selected on the Stage unless you click elsewhere.

5. With the button still selected, go to the Property inspector panel and enter the following values:
   InstanceName: next_btn
   X: 590
   Y: 120

6. In the Property inspector panel, click the Parameters tab.

7. In the Label text box, replace the name Button with the name Next and press Enter (Windows) or Return (Macintosh).
   The label on the button changes to Next.

8. Save your document.
Add ActionScript code

You have now added all the graphic and text elements that your FMA requires. The last step is to add the ActionScript code that displays the proper text and image for each slide in the slideShow movie clip.

Test an ActionScript sample

First, you'll add some simple ActionScript code to see it work.

**To add the test ActionScript:**

1. In the Timeline, click the layer name actions to activate that layer.
2. Select Window > Actions to open the Actions panel.
3. In the Actions panel, type the following ActionScript code. You can copy and paste the following code from the Flash Help panel:
   
   ```actionscript
   function testFunc(eventObj:Object) {
       menu_mc.title_txt.text = "Testing the title";
       menu_mc.description_txt.text = "Testing the description";
   }
   // add the event listener for the button
   next_btn.addEventListener("click", testFunc);
   
   This ActionScript code adds some text to the title and description text boxes that you added to the menu movie clip earlier.
   ```
4. Select Control > Test Movie.
   The Flash document opens and plays in a new window.
5. In the Test Movie window, click Next.
   The test title and test description text you entered as part of the ActionScript code appears in the blue rectangle on the right side of the document.
Enter ActionScript code for the slide show

Now you will enter the ActionScript code that makes the slideshow animate each new slide into place when the Next button is clicked. After you add the code, your Flash document will be complete.

To add the ActionScript code to the Flash document:
1. In the Timeline, make sure Frame 1 of the actions layer is still selected.
2. In the Actions panel, delete all the code you entered in “Test an ActionScript sample” on page 125.
   The Actions panel should now be empty of code.
3. Copy the following code and paste it into the Actions panel.

```actionscript
/*The following four sections contain the data
   for each menu item.
*/
var image0title:String = "Summer salad";
var image0desc:String = "Butter lettuce with apples, blood orange segments, gorgonzola, and raspberry vinaigrette.";
var image0uri:String = "images/image0.jpg";

/* 1 */
var image1title:String = "Turkey and Sun-dried Tomato Sandwich";
var image1desc:String = "Fresh roasted turkey with sun-dried tomatoes, garlic aioli, and havarti.";
var image1uri:String = "images/image1.jpg";

/* 2 */
var image2title:String = "Seared Salmon";
var image2desc:String = "Filet of wild salmon with caramelized onions, new potatoes, and caper and tomato salsa.";
var image2uri:String = "images/image2.jpg";

/* 3 */
var image3title:String = "New York Cheesecake";
var image3desc:String = "Creamy traditional cheesecake served with chocolate sauce and strawberries.";
var image3uri:String = "images/image3.jpg";

var currImage:Number = 0;
var totalImages:Number = 4;

menu_mc.title_txt.text = this["image"+currImage+"title"];```
menu_mc.description_txt.text =
   this["image"+currImage+"desc"]; 

for (var i:Number = 0; i<totalImages; i++) {
   slideshow_mc.slides_mc["holder"+i].loadMovie(this["image" 
   +(i)+"uri"],slideshow_mc.slides_mc.getNextHighestDepth 
   ());
}

slideshow_mc.slides_mc["holder4"].loadMovie(this["image0u 
   ri"],slideshow_mc.slides_mc.getNextHighestDepth());

// function for the Next button
function nextMenuItem(eventObj:Object) {
   slideshow_mc.gotoAndPlay("slide"+(currImage));
   if ((currImage+1)>=totalImages) {
      currImage = 0;
   } else {
      currImage++;
   }
   menu_mc.title_txt.text =
      this._parent["image"+currImage+"title"];
   menu_mc.description_txt.text =
      this._parent["image"+currImage+"desc"]; 
}

// add the event listener for the button
next_btn.addEventListener("click", nextMenuItem);

"Review the ActionScript code" on page 127 explains this code
in detail.

4. Save your document.
5. Select Control > Test Movie.
6. In the Test Movie window, click Next to watch the animated images of
   food and see the titles and descriptions update for each slide.
7. Close the Test Movie window.

**Review the ActionScript code**

This section explains what the ActionScript you just added to the Actions
panel is doing. If you prefer, you can skip this section and move on to
publishing your document for display in a web browser.

Complete information about working with ActionScript can be found in
*Learning ActionScript 2.0 in Flash.*
The first section of code contains variables that store information about the images that will appear in each section of the `slideShow` movie clip.

```actionscript
/* 0 */
var image0title:String = "Summer salad";
var image0desc:String = "Butter lettuce with apples, blood orange segments, gorgonzola, and raspberry vinaigrette.";
var image0uri:String = "images/image0.jpg";

/* 1 */
var image1title:String = "Turkey and Sun-dried Tomato Sandwich";
var image1desc:String = "Fresh roasted turkey with sun-dried tomatoes, garlic aioli, and havarti.";
var image1uri:String = "images/image1.jpg";

/* 2 */
var image2title:String = "Seared Salmon";
var image2desc:String = "Filet of wild salmon with caramelized onions, new potatoes, and caper and tomato salsa.";
var image2uri:String = "images/image2.jpg";

/* 3 */
var image3title:String = "New York Cheesecake";
var image3desc:String = "Creamy traditional cheesecake served with chocolate sauce and strawberries.";
var image3uri:String = "images/image3.jpg";
```

This code declares four sets of three variables each. Each set of three variables represents one of the four images that your Flash document displays. The only difference between the variable names for the four different images is the number that is included in the variable names. The numbering starts with the number 0 instead of 1. This is because lists in ActionScript are zero-based. This means that the first item in the list is always referred to by the number 0 rather than the number 1.

The three variables that are declared for each image are as follows. Remember that the number in the middle of each variable name changes for each image:

- `image0title` contains a string that is the name of the dish that appears in the `title_txt` text box in the `menu` movie clip.
- `image0desc` contains a string that is the description of the dish that appears in the `description_txt` text box in the `menu` movie clip.
image0uri contains a string that is the Universal Resource Identifier for the image file that is loaded and displayed in each section of the slides movie clip.

The next two lines of code declare two more variables:

```actionscript
var currImage:Number = 0;
var totalImages:Number = 4;
```

The first variable, currImage, stores the number of the current image that is being displayed in the slides movie clip. The second variable, totalImages, stores the total number of images that are available to be displayed. By storing this last number in a variable, you make it easier to change the number if you want to add more images to the slide show later. You would also need to modify the slideShow movie clip in that case.

The next line of code sets the text of the title text box to the text in the variable whose name corresponds to the current image number.

```actionscript
menu_mc.title_txt.text = this["image"+currImage+"title"];  
```

This code uses dot syntax to set the text property of the title_txt text box in the menu_mc movie clip instance to the value of a variable. In this case the variable name is constructed from the word image plus the value of the currImage variable, plus the word title. The variable name becomes image0title or one of the other similar variable names, depending on the number contained in the currImage variable. The word this indicates to Flash that the variable was declared inside this same script.

The following line of code is similar to the previous one:

```actionscript
menu_mc.description_txt.text = this["image"+currImage+"desc"];
```

This line of code sets the text of the description text box in the menu_mc movie clip instance to the text in the desc variable that corresponds to the current image number.

The following lines of code set up a for loop to load external JPG image files into the holder movie clip instances, which are in the slides movie clip in the slideShow movie clip. The file paths to each external JPG file are stored in the image*uri variables declared in the beginning of this ActionScript code block, as follows:

```actionscript
for (var i:Number = 0; i<totalImages; i++) {
    slideShow_mc.slides_mc["holder"+i].loadMovie(this["image"+(i )+"uri"],slideShow_mc.slides_mc.getNextHighestDepth());
}
```
A for loop is a block of code surrounded by a set of braces {} that repeats for each increment of the i variable. In this case, i increments from 0 to 4 because the value of totalImages is 4. The loadMovie() method can be used to load a Flash file or an image file into the movie clip. In this case it is loading the external JPG files.

The next line of code loads the first image, stored in the image0uri variable, into the holder4 movie clip instance, as follows:

```
slideShow_mc.slides_mc["holder4"].loadMovie(this["image0uri"],slideShow_mc.slides_mc.getNextHighestDepth());
```

The following lines of code implement the functionality of the Next button:

```
function nextMenuItem(eventObj:Object) {
    slideShow_mc.gotoAndPlay("slide"+(currImage));
    if ((currImage+1)>=totalImages) {
        currImage = 0;
    } else {
        currImage++;
    }
    menu_mc.title_txt.text = this._parent["image"+currImage+"title"];  
    menu_mc.description_txt.text = this._parent["image"+currImage+"desc"];
}
```

The code for the Next button is contained in the nextMenuItem function. A function is a block of code that is set up to execute when a particular event occurs. In this case, the function will run whenever the user releases the mouse button over the Next button on the Stage.

Inside the function is the gotoAndPlay() method, which directs the playhead to jump to a specific frame label in the Timeline. The Frame label specified in this case is constructed from the word slide and the current value of the currImage variable.

The next line contains an if statement that checks to see if the value of the currImage variable plus 1 is equal to the value of the totalImages variable. If this is true, the code sets the value of currImage to 0, otherwise the code increments the value of currImage by 1.

The last two lines in the function set the text of the title and description text boxes to the strings stored in the image*title and image*desc variables that correspond to the value of the currImage variable.
The line of code immediately after the function definition tells Flash to execute the `nextMenuItem` function when the `next_btn` instance receives a mouse click.

```javascript
next_btn.addEventListener("click", nextMenuItem);
```

Because the `nextMenuItem` function is now set up to listen for mouse clicks, it is called an event listener. This is why the `addEventListener()` method is used to tell flash to execute the function when the mouse click event occurs.

While the code described in this section is relatively simple, it still relies on a number of ActionScript concepts that are beyond the scope of this tutorial to describe. For a thorough introduction to these concepts and additional ActionScript tutorials, see *Learning ActionScript 2.0 in Flash* and *Flash Tutorials*.

### Publish your document

Now that you have completed your Flash document, you are ready to publish it in a web page. The first step in this process is to save the FLA version of your document as a compressed SWF version of the file. This SWF version has a much smaller file size; because of this, it loads easily in a web browser.

**To publish your document as a SWF file:**

1. Select File > Publish Settings.
2. In the Publish Settings dialog box, select the Formats tab and verify that only the HTML and Flash check boxes are selected.
   This causes Flash to publish only the SWF file and an HTML file to display it in a web browser.
3. Still in the Publish Settings dialog box, select the Flash tab and verify that Flash Player 8 is selected in the Version menu.
   This causes Flash to export the SWF file in Flash 8 format.
4. Select the HTML tab and verify that Flash Only is selected from the Template menu.
   This causes Flash to generate only a simple HTML file to display the Flash document in a browser.
5. Click Publish.
   Flash saves a SWF file copy of your document and an HTML file in
   the folder that contains your working FLA file. This should be the
cafe_townsend directory.

6. Click OK to close the Publish Settings dialog box.

Now that you have completed the Flash FMA that will be used in the
cafe_townsend website, you can go on to Chapter 4, “Tutorial: Building a
Video Player (Flash Professional only),” on page 135.

Resources

Macromedia has excellent resources to help you discover more about Flash,
get support, and send feedback to the company.

Registration

Register to receive the latest news about upgrades and new products,
technical support, and more. To register online, go to
www.macromedia.com/software/register/ and select Help > Online
Registration. You can also print the registration form from the Help menu.

Release Notes

For late-breaking information and known issues about Flash, check the
Release Notes in the Flash Support Center at www.macromedia.com/
support/flash/releasenotes.html.

Flash support

Get the answers you need, day or night, with high-quality Flash support
from knowledgeable product support engineers. To learn more, go to the
Flash Support Center at www.macromedia.com/support/flash/.
Flash training and certification

Boost your Flash skills with hands-on tasks and real-world scenarios. Flash training allows you to roll up your sleeves and get right to work. Choose between instructor-led and online training, or combine them to create a learning path that is most effective for you. To learn more, go to Macromedia Training at www.macromedia.com/go/flash_training.

Flash Developers Center

Stay up to date with the latest Macromedia Flash development trends and techniques. Tutorials, articles, and sample applications give you the information you need to stay competitive, innovative, and efficient. To learn more, go to the Flash Developers Center at www.macromedia.com/go/flash_devcenter.

On Demand seminars

Evaluating a new product can be difficult, and each version introduces new features to navigate. The Macromedia On Demand seminars help you get up to speed quickly. The Macromedia seminars feature multimedia presentations and demos designed to help you maximize your evaluation experience with Macromedia products. To learn more, go to Macromedia On Demand at www.macromedia.com/macromedia/events/online/ondemand/index.html.

Sample applications

Flash includes sample files that you can examine in order to learn various design and development concepts. To view FLA and SWF versions of the sample files, along with a description, see Flash Samples in Flash Help (with Flash open, select Help > Flash Help). Some of the samples are complete applications, while others are simple and intended to introduce a basic concept. To view the authoring version (FLA file) for a given sample, open the file from within Flash. You’ll find the sample files in the Samples folder, which is in your Flash application directory. You can find additional samples in the Flash Developers Center at www.macromedia.com/go/flash_devcenter.
Additional resources

The following Macromedia web pages include reference materials and links to third-party Flash resources:

■ Websites devoted to Macromedia Flash and Flash developers can be found at www.macromedia.com/go/tn_12046.

■ Macromedia Press (Macromedia's publishing division) can be found at www.macromedia.com/support/mmpress/.
CHAPTER 4

Tutorial: Building a Video Player (Flash Professional only)

This tutorial guides you through the process of creating a simple video player by using some of the authoring features in Macromedia Flash Basic 8 and Flash Professional 8. After it is created, you can deploy the video player in a web page.

If you have not already done so, Macromedia recommends that before you take this tutorial you read “Flash basics” on page 57.

In this tutorial, you will complete the following tasks:

- Review your task ........................................... 136
- Examine the completed application .................. 136
- Create a working folder .................................. 138
- Encode a video file ........................................ 139
- Create a new Flash document ......................... 140
- Add a media component ................................ 142
- Publish your document .................................. 145
Review your task

In this tutorial, you will create a type of application known as a flexible messaging area, or FMA. An FMA is a common type of Flash application used for displaying content that conveys some kind of informational or marketing message to the audience. In this case, the FMA displays photographs of items from the restaurant menu. At Macromedia's website, an FMA is used to display information about new software products and other advertising messages. These are called flexible messaging areas because they usually occupy an area of the web page that is set aside for content that can change depending on the needs of the business or website. For example, if Café Townsend has a special event planned, the FMA could change to display the details of that event instead of the restaurant's menu items.

In this tutorial, after examining an existing Flash document, you'll begin by creating a new Flash document and end by publishing the application for web playback. The tutorial should take approximately 20 to 30 minutes to complete.

Examine the completed application

As you examine the finished version of an application you'll create, you will also look at the Flash workspace.

In subsequent sections you'll follow the steps to create the application yourself.

Run the completed application

To better understand the type of application you'll create as you work through this tutorial, you can look at a completed FLA file version of the application in the Flash authoring tool. FLA files are the files you work on in Flash. You can also play the SWF version of the file in Flash Player. The SWF version is the version of the file that you would publish in a web page.
To play the SWF version of the file in Flash Player:

1. In Flash, select File > Open.
2. Use one of the following paths to browse to the completed file:
   - In Windows, browse to boot drive\Program Files\Macromedia\Flash 8\Samples and Tutorials\Tutorial Assets\cafe_townsend\completed files\flash and double-click video_pod_finished.swf.
   - On the Macintosh, browse to the Macintosh HD/Applications/Macromedia Flash 8/Samples and Tutorials/Tutorial Assets/cafe_townsend/completed_files/flash and double-click video_pod_finished.swf.

   The completed application runs in Flash Player. Click the playback controls at the bottom of the window to watch the video.
3. After viewing the application, close the Flash Player window.

Open the authoring document

It’s helpful to look at the completed authoring FLA file to see how the author designed the application.

To view the authoring version of the file in Flash:

1. In Flash, select File > Open.
2. Browse to the authoring document using one of the following paths:
   - In Windows, browse to boot drive\Program Files\Macromedia\Flash 8\Samples and Tutorials\Tutorial Assets\cafe_townsend\completed files\flash and double-click video_pod_finished.fla.

   You now see the completed tutorial application in the Flash authoring environment.
3. After you have the file open, you can explore the Stage, Library panel, and the Timeline.

- On the Stage you will see a FLVPlayback component, which you will learn more about later in this tutorial.
- In the Library panel, you will see a list of symbols, or reusable assets, that the document uses.
- In the Timeline, you will see a representation of how and when those symbols appear on the Stage.

You will learn more about the role of each of these parts of Flash as you complete the tutorial. For detailed information about each of these elements, see “Flash Basics” on page 49.

Create a working folder

Before you begin, you must create a working folder that includes the sample files used in the tutorials in this guide, Getting Started with Flash. This task consists of creating the working folder on your hard disk and copying the sample files from the Flash application folder to the working folder.

1. Create a new folder called local_sites somewhere on your hard disk. For example, create a folder called local_sites in either of the following locations:

- (Windows) C:_documents and Settings\your_user_name\My Documents\local_sites
- (Macintosh) Hard Disk/Users/your_user_name/Documents/local_sites

**NOTE**

On the Macintosh, a folder called Sites is already in your user folder. Don’t use that Sites folder as your local folder; the Sites folder is where you place your pages to make them publicly accessible when you’re using the Macintosh as a web server.
2. Locate the cafe_townsend folder in the Flash application folder on your hard disk. If you installed Flash to its default location, the path to the folders is as follows:
   - In Windows, C:\Program Files\Macromedia\Flash 8\Samples and Tutorials\Tutorial_assets\cafe_townsend
   - On the Macintosh, Macintosh HD/Applications/Macromedia Flash 8/Samples and Tutorials/Tutorial_assets/cafe_townsend

3. Copy the cafe_townsend folder to your local_sites folder.

**Encode a video file**

The first thing you will do is convert a QuickTime video file (MOV) to a Flash video file (FLV).

**To convert the video file:**
1. Start the Flash Video Encoder application.
2. Drag the cafe_townsend_chef.mov file from the cafe_townsend folder onto the Flash Video Encoder application window.

![The Flash Video Encoder window](image)

3. Click Settings.
4. In the Flash Video Encoding Settings dialog box, select Flash 8 - Medium Quality (400kbps) from the Flash Video Encoding Profile menu. This setting is the default. This action applies only a small amount of compression to the file.

5. Click OK to close the Settings dialog box.

6. Click Start Queue.

   The Flash Video Encoder converts the file and saves it in the same folder as the original cafe_townsend_chef.mov file.

   You are now ready to use the FLV file in a Flash document.

7. Close the Flash Video Encoder application.

Create a new Flash document

Now that you have seen the finished application you will create, it is time to create your own Flash document.

If you haven't already set up a working folder, you must do so before you begin. For instructions, see “Create a working folder” on page 138.

To learn how to create an application in Flash, you'll start with the very first step in the process: creating a new file.
Open a new document

Now you’re ready to create your own version of the FMA.

To create a new document:
1. Start Flash.
2. Select File > New.
3. In the New Document dialog box, select Flash Document and then click OK.
4. Select File > Save.
5. Name the file video_pod.fla and save the file in the cafe_townsend folder you copied to your hard disk.

As you complete the tutorial, remember to save your work frequently.

Define document properties

Configuring document properties is a common first step in authoring. You can change the document properties at any time, but it is helpful to make certain decisions, such as the Stage size and background color, at the beginning of the process.

Document properties are properties that affect the entire Flash document. You can use the Property inspector to specify these settings.

To define document properties:
1. If the Property inspector isn’t open, select Window > Properties > Properties.

If the Property inspector is not fully expanded, click the white triangle in the lower-right corner.

2. In the Property inspector, click Size.
3. In the Document Properties dialog box, enter the following values:
   - Width: 360
   - Height: 240
4. Click OK.

5. Save your work.

For more information about setting document properties, see “Creating or opening a document and setting properties” in *Using Flash*.

Add a media component

Next, you will add a media playback component to the Stage. This component will contain the video display and provide playback controls.

**About components**  Components in Flash are prebuilt objects that you can use in your own Flash documents. Most components are user interface elements such as buttons, menus, and so on. Some are not meant to be seen on the Stage and are used instead to perform data-handling functions. By using a component, you can avoid the need to build complex user interface elements yourself. Components are implemented in Flash as movie clips with their own internal ActionScript code. You use the Components panel to set the properties of the component. This tells Flash how you want the component to behave. For the FLVPlayback component, you will tell Flash the location of the FLV file you want to play, and how you want the playback controls to appear.
To add a media component:

1. Select Window > Components to open the Components panel.

2. In the Components panel, click the plus sign (+) next to the FLV Playback - Player 8 category.

3. Drag an FLVPlayback component to the Stage.
   The new component remains selected on the Stage by default.
4. With the new component still selected on the Stage, enter the following values in the Property inspector:
   - W: 360
   - H: 240
   - X: 0
   - Y: 0
   This makes the component the same size as the Stage and centers it on the Stage.

5. With the new component still selected on the Stage, select Window > Component Inspector to open the Component inspector.

6. In the Component inspector’s Parameters tab, click the `contentPath` parameter.

7. Click the magnifying glass icon that appears next to it.

8. In the Content Path dialog box, enter `cafe_townsend_chef.flv` and click OK.

9. Still in the Component inspector, set the `autoRewind` parameter to `false`.
10. Save your work.

11. To test your document, select Control > Test Movie.
    The document plays in the Test Movie window. You can control the playback of the video file with the controls at the bottom of the Stage.

Publish your document

The next step is to publish your FLA file as a SWF file that can be displayed in a web browser.

To publish your Flash document:
1. Select File > Publish.
   Flash saves a SWF version of your file and a simple HTML file in the cafe_townsend folder where you saved the video_pod.fla file. Flash also saves a SWF file called ClearOverPlaySeekMute.swf that contains the graphics for the video controller overlay that appears on top of the video. This SWF file must be located in the same folder as the video_pod.swf file in order for the video controls to appear when you play the SWF file.
   You can customize the look of these video controls. For more information see “About skinning components” in Using Components.
2. In your web browser, select File > Open.
3. Navigate to the cafe_townsend folder and open the video_pod.html file.
   The HTML file opens in the web browser and displays your Flash document.
The next steps

Now that you have completed the Flash video player, you would normally insert the SWF file into a real-world web page.

This illustration demonstrates what a web page containing the video_pod.swf file might look like.

The video_pod.swf file inserted in a web page
Index

A
accessibility, in the Flash authoring environment 86
accessing Flash documentation 34
Actions panel 74
activating Flash 20
applications, sample 133
arranging the Help panel 47
authoring environment accessibility 86

B
bitmap images, anti-aliasing 81
Bitmaps on Clipboard preference (Windows only) 81
Blank Keyframe command 59
building an application, tutorial 95, 135

C
Center Frame button 57
certification and training 133
choosing among help books 40
Clear Keyframe command 60
Clipboard preferences 81
text contexts, about 86
text context sensitive help 44
Copy Frames command 60
copying
layer folder contents 65
layers 65
Customize Shortcuts dialog box 84
Customize Toolbar command 69

D
Default Layout command, for panels 78
deleting
frames or keyframes 60
layers and layer folders 65
discussing the help 46
document, creating new 99, 140
document-editing mode 70

E
edit bar 67
editing layers and layer folders 64

F
file extensions
.fla 6
.swf 7
FLA (.fla file) 6
Flash
about 5
activating and installing 20
getting started 5
system requirements 20
Timeline 52–61
Flash documentation
accessing 34
Flash MX 2004 system requirements 20
Flash MX Professional 2004 system requirements 20
Flash online resources, accessing 39
Flash Player
about 17
changing or uninstalling 24
FMA (flexible messaging area) 7
Font Mapping Default preference 82
Frame command 59
Frame View button 58
Frame View menu 58
frames
  centering the playhead in 57
  changing the view 57
  converting keyframes into 60
  copying and pasting 60
  copying by dragging 60
  displayed in Timeline 54
  displaying 56
  displaying contents 53
  dragging in Timeline 60
  editing in Timeline 59
  inserting 59
  removing 60
  showing thumbnails 58
  thumbnail display 57
  using 58
FreeHand Text on Clipboard preference 81

FreeHand Text on Clipboard preference 81
Gradients on Clipboard preference (Windows only) 81

G
grids
  editing 72
  showing 72
  snapping to 72
  using 72
guide layers 66
guides
  clearing 72
  locking 71
  moving 71
  removing 71
  setting preferences 71
  showing 70
  snapping to 71
  using 70

H
Hand tool 54
help
  accessing 42
  choosing help books 40
  context sensitive 44
  discussing 46
  printing 45
  printing a page 45
  purchasing printed versions 46
  help book descriptions 40
Help panel
  arranging 47
  opening 42
  searching 43
  table of contents 42
  text size 48
  updating 48
  updating help content 48
Highlight Color preference 80

I
Insert Blank Keyframe command 59
Insert Keyframe command 59
Insert Layer command 62
installing Flash 20, 27

K
keyboard shortcuts
  adding and removing 85
  customizing 83
  deleting 85
  for dialog box controls 90
  for library items 92
  for panel controls 88
  for panels 87
  for Property inspector 87
  for Property inspector controls 88
  for the Stage 91
  for tree controls 92
Keyframe command 59
keyframes
  converting into frames 60
  creating blank 59
  dragging in tweened frame sequences 61
  inserting 59
  removing 60
  using 58

L
Layer command 62
layer folders
  changing order of 66
  copying contents of 65
  creating 62
  deleting 65
  editing 64
locking 64
organizing 66
renaming 64
layers
  Add Layer button 62
  adding layer folder 62
  changing layer height 63
  changing number of layers displayed 64
  changing order of 66
  changing outline color 63
  copying 65
  creating 62
  deleting 65
  editing 64
  guide layers 66
  hiding and showing 62
  locking 64
  organizing 66
  renaming 64
  selecting 64
  using 61
  viewing as outlines 63
library
  keyboard shortcuts for items 92
Library panel
  about 74
LiveDocs 46
locking layers and layer folders 64

M
Macromedia Flash Development Center 133
Macromedia Flash support 132
magnification (zooming) 53
main toolbar 67

N
Named Anchor on Scene preference 80
Named Anchor on Scenes preference 80
new features 19

O
On Launch preferences 79
online resources, accessing 39
opening help 42
outlines
  changing color on layers 63
  viewing layer contents as 63

P
Panel Sets command 78
panels
  Actions 74
  arranging 76
  closing 76
  collapsing 76
  creating new group 77
  default layout 78
  deleting custom layout 78
  docking 77
  dragging 77
  expanding 76
  grouping 77
  keyboard shortcuts 87
  keyboard shortcuts for tree controls 92
Library 74
  opening 75
  resetting layout of 78
  resizing 76
  saving custom set 77
  selecting layout 78
  sets 77
  ungrouping 77
  using 75
  using options menu 76
  viewing list of 75
Paste Frames command 60
picking help books 40
PICT Settings for Clipboard preference (Macintosh only) 81
playhead, moving 56
preferences
  Bitmaps on Clipboard (Windows only) 81
  Clipboard 81
  editing 81
  Font Mapping Default 82
  FreeHand Text on Clipboard 81
  general 79
  Gradients on Clipboard (Windows only) 81
  Highlight Color 80
  Named Anchor on Scenes 80
  On Launch options 79
  PICT Settings for Clipboard (Macintosh only) 81
  Printing Options (Windows only) 79
  setting 78
  Shift Select 80
  Show Tooltips 80
  Span Based Selection 80
  Timeline Options 80

Index 149
Undo Levels 79
Preferences command 79
previewing frame thumbnails 57
printing help 45
Printing Options preference (Windows only) 79
Property inspector
  about 73
  keyboard shortcuts 87
  using panels and 73
purchasing printed help manuals 46

R
registration 132
release notes 132
Remove Frame command 60
renaming layers and layer folders 64
resources 132, 134
rulers
  changing units of 70
  showing and hiding 70
  using 70

S
searching help 43
selecting layers 64
seminars 133
Shift Select preference 80
Show All command 53
Show Frame command 53
Show Grid command 72
Show Guides command 70
Show Tooltips preference 80
Snap to Grid command 72
Snap to Guides command 71
snapping
  to grid 72
  to guides 71
Span Based Selection preference 80
Stage
  displaying entire 53
  keyboard shortcuts for selecting 91
  zooming 52
Start page 51
SWF (.swf file) 7
symbol-editing mode 70
system requirements
  Flash MX 2004 20
  Flash MX Professional 2004 20
T
table of contents 42
third-party resources 133, 134
Timeline
  appearance of, changing 55
  Center Frame button 57
  converting keyframes into frames 60
  copying and pasting frames 60
  deleting frames or keyframes 60
  docking to the application window 56
  dragging 56
  dragging frames 60
  editing frames 59
  frame display, changing 57
  frames 58
  hiding layers in 62
  inserting frames 59
  keyframes 58
  layer folder order, changing 66
  layer height, changing 63
  layer name fields in 56
  layer order, changing 66
  locking layer folders in 64
  locking layers in 64
  number of layers displayed, changing 64
  playhead 56
  Preview in Context option 57
  Preview option 58
  resizing 56
  showing frame thumbnails 57, 58
  using 54
  viewing layers as outlines 63
  working with frames 54
toolbar
  customizing 68
  showing and hiding 68
tools
  customizing the toolbar 68
  Hand 54
  selecting 68
  viewing 67
  Zoom 53
Tools panel
  using 67
training and certification 133

tree controls, keyboard shortcuts for 92

trial mode
  purchasing Flash 22
  switching between editions 22

tutorials, building an application 95, 135

tutorials, Flash 45
tweened frames, dragging keyframes in 61

U

Undo Levels preference 79

updating the Help panel 48

upgrading from Macromedia Flash MX 2004 21

W

warning preferences 82

work area, showing and hiding 53

Z

Zoom tool 53

zooming 52