Using
ADOBE® DREAMWEAVER® CS5 & CS5.5
Legal notices
# Contents

## Chapter 1: What’s New
- What’s New ................................................................. 1

## Chapter 2: Workspace
- Dreamweaver workflow and workspace ................................ 4
- Working in the Document window ........................................ 17
- Using toolbars, inspectors, and context menus ............................. 20
- Customizing the Dreamweaver CSS workspace ............................ 22
- Keyboard shortcuts .......................................................... 32
- Extensions ........................................................................... 34

## Chapter 3: Working with Dreamweaver sites
- About Dreamweaver sites .................................................... 36
- Set up a local version of your site .......................................... 37
- Connect to a remote server .................................................. 38
- Set up a testing server ........................................................ 45
- Version Control and Advanced settings .................................. 47
- Manage Sites dialog box options .......................................... 48
- Import and export Dreamweaver site settings ............................ 49
- Edit an existing remote website ............................................ 50
- Set site preferences for transferring files ................................ 51
- Managing Contribute sites .................................................. 52

## Chapter 4: Creating and Managing Files
- Creating and opening documents .......................................... 59
- Managing files and folders ................................................... 72
- Getting and putting files to and from your server ...................... 80
- Checking in and checking out files ........................................ 85
- Synchronizing files ............................................................ 93
- Comparing files for differences ............................................. 94
- Rolling back files (Contribute users) ....................................... 97
- Cloaking files and folders in your Dreamweaver site ................... 97
- Storing file information in Design Notes .................................. 100
- Testing your Dreamweaver site ............................................. 102

## Chapter 5: Managing assets and libraries
- About assets and libraries .................................................... 106
- Working with assets .......................................................... 107
- Creating and managing a list of favorite assets ......................... 111
- Working with library items .................................................. 113

## Chapter 6: Creating pages with CSS
- Understanding Cascading Style Sheets .................................. 118
- The CSS Styles panel ........................................................ 122
Contents

Enhancements to CSS3 support in the CSS styles panel (CS5.5) .................................................. 126
Set CSS Styles preferences ........................................................................................................... 128
Create a new CSS rule .................................................................................................................. 128
Set CSS properties ...................................................................................................................... 129
Edit a CSS rule ........................................................................................................................... 135
Add a property to a CSS rule ....................................................................................................... 136
Apply, remove, or rename CSS class styles .................................................................................. 136
Move/export CSS rules ............................................................................................................... 137
Convert inline CSS to a CSS rule ............................................................................................... 138
Link to an external CSS style sheet ............................................................................................. 139
Edit a CSS style sheet .................................................................................................................. 140
Format CSS code ....................................................................................................................... 140
Disable/Enable CSS .................................................................................................................... 141
Inspect CSS in Live view ............................................................................................................ 142
Check for cross-browser CSS rendering issues ........................................................................... 142
Use Design-Time style sheets .................................................................................................... 144
Use Dreamweaver sample style sheets ....................................................................................... 145
Update CSS style sheets in a Contribute site ............................................................................. 145
Laying out pages with CSS .......................................................................................................... 146
Working with div tags ................................................................................................................. 152

Chapter 7: Laying out pages with HTML
Using visual aids for layout ........................................................................................................... 167
Presenting content with tables .................................................................................................... 170
Using Frames ............................................................................................................................... 185

Chapter 8: Adding content to pages
Use the Insert panel ..................................................................................................................... 198
Set page properties ..................................................................................................................... 201
Set CSS link properties for an entire page .................................................................................. 202
Set CSS heading properties for an entire page ........................................................................... 203
Set title and encoding properties for a page ............................................................................... 203
Use a tracing image to design a page .......................................................................................... 204
Understanding document encoding ............................................................................................ 204
Select and view elements in the Document window .................................................................... 205
Colors ............................................................................................................................................ 207
Zoom in and out ............................................................................................................................ 208
Set download time and size preferences ..................................................................................... 209
Working with text ....................................................................................................................... 210
Set text properties in the Property inspector ............................................................................. 217
Spell check a web page .............................................................................................................. 220
Import tabular data .................................................................................................................... 220
Import Microsoft Office documents (Windows only) .................................................................. 221
Create a link to a Word or Excel document .................................................................................. 221
Use HTML Formatting ................................................................................................................. 222
Use horizontal rules ..................................................................................................................... 224
Modify font combinations .......................................................................................................... 224

Last updated 12/7/2011
Contents

Insert dates ................................................................. 225
Adding and modifying images ........................................ 226
Adding video ............................................................ 237
Inserting SWF files ...................................................... 242
Adding web widgets ..................................................... 245
Adding Sound .......................................................... 246
Adding media objects .................................................. 247
Automating tasks ....................................................... 255

Chapter 9: Linking and navigation
About linking and navigation .......................................... 261
Linking ................................................................. 263
Jump menus ............................................................ 270
Navigation bars ......................................................... 272
Image maps ............................................................. 272
Troubleshooting links .................................................. 274

Chapter 10: Previewing pages
Previewing pages ....................................................... 276

Chapter 11: Working with page code
General information about coding in Dreamweaver ............ 281
Setting up your coding environment ................................. 285
Setting coding preferences .......................................... 287
Writing and editing code .............................................. 292
Collapsing code ........................................................ 308
Optimizing and debugging code ................................... 310
Editing code in Design view ........................................ 315
Working with head content for pages ............................... 321
Working with server-side includes ................................. 325
Managing tag libraries ............................................... 328
Importing custom tags into Dreamweaver ......................... 330

Chapter 12: Adding JavaScript behaviors
Using JavaScript behaviors (general instructions) ............... 333
Applying built-in JavaScript behaviors .............................. 336

Chapter 13: Working with other applications
Cross-application integration ........................................ 347
Working with Fireworks and Dreamweaver ....................... 348
Working with Photoshop and Dreamweaver ..................... 353
Working with Flash and Dreamweaver ............................ 362
Working with Adobe Bridge and Dreamweaver .................. 362
Working with Device Central and Dreamweaver ............... 365
Working with ConnectNow and Dreamweaver ................... 366
AIR Extension for Dreamweaver .................................. 367

Last updated 12/7/2011
Chapter 1: What’s New

What’s New

Important: This page provides a list of new features in Dreamweaver CS5 and Dreamweaver CS5.5. This page does NOT tell you how to use those features. For more information about any of the new features, click the corresponding links provided. You can also watch a CS5 feature overview, or a CS5.5 feature overview on AdobeTV.

What’s new (CS5.5)

Multiscreen support
Preview your designs in standard screen resolutions, or use media queries to define resolution. When testing for devices that change page orientation based on how the device is held, use the landscape and portrait options during preview. For more information, see “Designing for multiple screens and devices” on page 462.

Media query support
Use media queries to customize the appearance of your site for different screen resolutions. For more information, see “Creating media queries (CS5.5 and later)” on page 462.

Web applications for mobile devices
Quickly design a web application that works on most mobile devices using the jQuery Mobile widget. For more information, see “Creating web applications for mobile devices (CS5.5 and later)” on page 464.

Package web applications for Android, iPhone, and iPad
Package your web applications in Dreamweaver, and deploy them to Android™ and iOS-based devices. For more information, see “Packaging web applications” on page 467.

HTML5, CSS3, and jQuery support
Dreamweaver supports code hinting for HTML5, CSS3, and jQuery.

Starter layouts are also available for building HTML5 pages from scratch. Dreamweaver supports the HTML5 feature to embed videos in HTML pages. For more information, see “Embed videos in web pages (HTML5)” on page 237.

The CSS panel has been enhanced to support commonly used CSS3 properties. For more information, see “Code hints” on page 292 and “Enhancements to CSS3 support in the CSS styles panel (CS5.5)” on page 126.

FTPS support
Transfer data using FTPS. FTPS (FTP over SSL) provides both encryption and authentication support as compared to SFTP that supports only encryption. For more information, see “FTPS connections (CS5.5)” on page 41.

W3C validator support
Create standards-compliant HTML and XHTML pages using the W3C validator in Dreamweaver. For more information, see “Validate documents using W3C validator (CS5.5)” on page 312.
What’s new (CS5)

Adobe BrowserLab
Dreamweaver CS5 integrates with Adobe BrowserLab, one of the new CS Live online services, which provides a fast and accurate solution for cross-browser compatibility testing. With BrowserLab you can preview web pages and local content using multiple viewing and comparison tools. See "BrowserLab" on page 471.

Business Catalyst integration
Adobe Business Catalyst is a hosted application that replaces traditional desktop tools with one, central platform for web designers. The application works hand-in-hand with Dreamweaver, and lets you build everything from basic data-driven websites to powerful online stores. See http://www.adobe.com/go/business_catalyst_get_extension_en.

CSS enhancements

CSS Disable/Enable
CSS Disable/Enable lets you disable and re-enable CSS properties directly from the CSS Styles panel. Disabling a CSS property simply comments out the specified property without actually deleting it. See “Disable/Enable CSS” on page 141.

CSS Inspection
Inspect mode lets you visually display the CSS box model properties—including padding, border, and margin—in detail without reading code or requiring a separate third-party utility such as Firebug. See “Inspect CSS in Live view” on page 142.

CSS starter layouts
Dreamweaver CS5 includes updated and simplified CSS starter layouts. The complex descendent selectors from the CS4 layouts have been removed and replaced with simplified, easy-to-understand classes. See “Create a page with a CSS layout” on page 150.

Dynamically-Related Files
The Dynamically-Related Files feature lets you discover all of the external files and scripts necessary to assemble PHP-based Content Management System (CMS) pages, and displays their filenames in the Related Files toolbar. By default Dreamweaver supports file discovery for the Wordpress, Drupal, and Joomla! CMS frameworks. See “Open Dynamically-Related Files” on page 70.

Live view navigation
Live view navigation activates links in Live view, allowing you to interact with server-side applications and dynamic data. The feature also allows you to enter a URL to inspect pages served from a live web server and edit pages you have browsed to if they exist in one of your locally defined sites. See “Previewing pages in Dreamweaver” on page 276.

PHP custom class code hinting
PHP custom class code hinting displays the proper syntax for PHP functions, objects, and constants, helping you type more accurate code. Code hinting also works with your own custom functions and classes, as well as third-party frameworks, such as the Zend framework.
Simplified site setup
The newly redesigned Site Definition dialog box (now the Site Setup dialog box) makes it easier to set up a local Dreamweaver site so that you can start building web pages right away. The remote server category lets you specify your remote and testing servers in one view. See “Set up a local version of your site” on page 37 and “Connect to a remote server” on page 38.

Site-specific code hints
The Site-specific code hints feature lets you customize your coding environment when working with third-party PHP libraries and CMS frameworks such as WordPress, Drupal, Joomla!, or other frameworks. Theme files for blogs and other custom PHP files and directories can be included or excluded as sources for code-hints. See “Site-specific code hints” on page 294.

Subversion support enhancements
Dreamweaver CS5 expands its support for Subversion, allowing you to move, copy, and delete files locally, and then synchronize changes with your remote SVN repository. The new Revert command allows you to quickly correct tree conflicts or rollback to a previous version of a file. Additionally, a new extension allows you to specify which version of Subversion you would like to work with on a given project. See “Use Subversion (SVN) to get and check in files” on page 88.

Deprecated features
The following features have been deprecated as of Dreamweaver CS5:

- Accessibility validation report
- ASP/JavaScript server behaviors
- Check Browser JavaScript behavior
- Connect to FTP/RDS server without defining a site
- Control Shockwave or SWF JavaScript behavior
- Create Web Photo Album
- Hide Pop-up Menu JavaScript behavior
- InContext Editing Manage Available CSS Classes
- Insert FlashPaper
- Insert/Remove Mark of the Web
- Microsoft Visual SourceSafe integration
- Navigation bars
- Play Sound JavaScript behavior
- Show Events menu (Behaviors panel)
- Show Pop-up Menu JavaScript behavior
- Timeline JavaScript behaviors
- Validate tags
- View Live Data
Chapter 2: Workspace

Dreamweaver workflow and workspace

Dreamweaver workflow overview
You can use several approaches to create a website. This is one approach:

Plan and set up your site
Determine where the files will go and examine site requirements, audience profiles, and site goals. Additionally, consider technical requirements such as user access, as well as browser, plug-in, and download restrictions. After you’ve organized your information and determined a structure, you can begin creating your site. (See “Working with Dreamweaver sites” on page 36.)

Organize and manage your site files
In the Files panel you can easily add, delete, and rename files and folders to change the organization as needed. The Files panel also has many tools for managing your site, transferring files to and from a remote server, setting up a Check In/Check Out process to prevent files from being overwritten, and synchronizing the files on your local and remote sites. From the Assets panel, you can easily organize the assets in a site; you can then drag most assets directly from the Assets panel into a Dreamweaver document. You can also use Dreamweaver to manage aspects of your Adobe®Contribute® sites. (See “Managing files and folders” on page 72 and “Managing assets and libraries” on page 106.)

Lay out your web pages
Choose the layout technique that works for you, or use the Dreamweaver layout options in conjunction with one another to create your site’s look. You can use Dreamweaver AP elements, CSS positioning styles, or predesigned CSS layouts to create your layout. The table tools let you design pages quickly by drawing and then rearranging the page structure. If you want to display multiple elements at once in a browser, you can use frames to lay out your documents. Finally, you can create new pages based on a Dreamweaver template, then update the layout of those pages automatically when the template changes. (See “Creating pages with CSS” on page 118 and “Laying out pages with HTML” on page 167.)

Add content to pages
Add assets and design elements such as text, images, rollover images, image maps, colors, movies, sound, HTML links, jump menus, and more. You can use built-in page-creation features for such elements as titles and backgrounds, type directly in the page, or import content from other documents. Dreamweaver also provides behaviors for performing tasks in response to specific events, such as validating a form when the visitor clicks the Submit button or opening a second browser window when the main page has finished loading. Finally, Dreamweaver provides tools for maximizing website performance and for testing pages to ensure compatibility with different web browsers. (See “Adding content to pages” on page 198.)

Create pages by hand coding
Coding web pages by hand is another approach to creating pages. Dreamweaver provides easy-to-use visual editing tools, but it also provides a sophisticated coding environment; you can use either approach, or both, to create and edit your pages. (See “Working with page code” on page 281.)
Set up a web application for dynamic content
Many websites contain dynamic pages that allow visitors to view information stored in databases, and usually allow some visitors to add new information and edit information in the databases. To create such pages, you must first set up a web server and application server, create or modify a Dreamweaver site, and connect to a database. (See “Preparing to build dynamic sites” on page 504.)

Create dynamic pages
In Dreamweaver, you can define a variety of sources of dynamic content, including recordsets extracted from databases, form parameters, and JavaBeans components. To add the dynamic content to a page, simply drag it onto the page.

You can set your page to display one record or many records at a time, display more than one page of records, add special links to move from one page of records to the next (and back), and create record counters to help users keep track of the records. You can encapsulate application or business logic using technologies such as Adobe® ColdFusion® and web services. If you need more flexibility, you can create custom server behaviors and interactive forms. (See “Making pages dynamic” on page 532.)

Test and publish
Testing your pages is an ongoing process that happens throughout the development cycle. At the end of the cycle, you publish the site on a server. Many developers also schedule periodic maintenance to ensure that the site remains current and functional. (See “Getting and putting files to and from your server” on page 80.)

For a video tutorial on what you can do with Dreamweaver, see www.adobe.com/go/lrvid4040_dw.

Workspace layout overview
The Dreamweaver workspace lets you view documents and object properties. The workspace also places many of the most common operations in toolbars so that you can quickly make changes to your documents.

In Windows®, Dreamweaver provides an all-in-one-window integrated layout. In the integrated workspace, all windows and panels are integrated into a single larger application window.
On Mac OS®, Dreamweaver can display multiple documents in a single window with tabs that identify each document. Dreamweaver can also display a floating workspace in which each document appears in its own individual window. Panel groups are initially docked together, but can be undocked into their own windows. When panel groups are docked and the document area is maximized, resizing or showing and hiding panels auto-sizes the main document, just as it does on Windows.
Workspace elements overview

The workspace includes the following elements.

**Note:** Dreamweaver provides many other panels, inspectors, and windows. To open the panels, inspectors, and windows, use the Window menu.

**The Welcome screen** Lets you open a recent document or create a new document. From the Welcome screen, you can also learn more about Dreamweaver by taking a product tour or a tutorial.

**The Application bar** Across the top of the application window contains a workspace switcher, menus (Windows only), and other application controls.

**The Document toolbar** Contains buttons that provide options for different views of the Document window (such as Design view and Code view), various viewing options, and some common operations such as previewing in a browser.

**The Standard toolbar** (Not displayed in the default workspace layout.) Contains buttons for common operations from the File and Edit menus: New, Open, Browse in Bridge, Save, Save All, Print Code, Cut, Copy, Paste, Undo, and Redo. To display the Standard toolbar, select View > Toolbars > Standard.

**The Coding toolbar** (Displayed in Code view only.) Contains buttons that let you perform many standard coding operations.

**The Style Rendering toolbar** (Hidden by default.) Contains buttons that let you see how your design would look in different media types if you use media-dependent style sheets. It also contains a button that lets you enable or disable Cascading Style Sheets (CSS) styles.

For a tutorial on working with different Dreamweaver workspaces, see [www.adobe.com/go/lrvid4042_dw](http://www.adobe.com/go/lrvid4042_dw).
**The Document window** Displays the current document as you create and edit it.

**The Property inspector** Lets you view and change a variety of properties for the selected object or text. Each object has different properties. The Property inspector is not expanded by default in the Coder workspace layout.

**The Tag selector** Located in the Status bar at the bottom of the Document window. Shows the hierarchy of tags surrounding the current selection. Click any tag in the hierarchy to select that tag and all its contents.

**Panels** Help you monitor and modify your work. Examples include the Insert panel, the CSS Styles panel, and the Files panel. To expand a panel, double-click its tab.

**The Insert panel** Contains buttons for inserting various types of objects, such as images, tables, and media elements, into a document. Each object is a piece of HTML code that lets you set various attributes as you insert it. For example, you can insert a table by clicking the Table button in the Insert panel. If you prefer, you can insert objects using the Insert menu instead of the Insert panel.

**The Files panel** Lets you manage your files and folders, whether they are part of a Dreamweaver site or on a remote server. The Files panel also lets you access all the files on your local disk, much like Windows Explorer (Windows) or the Finder (Macintosh).

**Document window overview**

The Document window shows the current document. You can select any of the following views:

**Design view** A design environment for visual page layout, visual editing, and rapid application development. In this view, Dreamweaver displays a fully editable, visual representation of the document, similar to what you would see when viewing the page in a browser.

**Code view** A hand-coding environment for writing and editing HTML, JavaScript, server-language code—such PHP or ColdFusion Markup Language (CFML)—and any other kind of code.

**Split Code view** A split version of Code view that lets you scroll to work on different sections of the document at the same time.

**Code and Design view** Lets you see both Code view and Design view for the same document in a single window.

**Live view** Similar to Design view, Live view displays a more realistic representation of what your document will look like in a browser, and lets you interact with the document exactly as you would in a browser. Live view is not editable. However, you can edit in Code view and refresh Live view to see your changes.

**Live Code view** Only available when viewing a document in Live view. Live Code view displays the actual code that a browser uses to execute the page, and can dynamically change as you interact with the page in Live view. Live Code view is not editable.

When a Document window is maximized (the default), tabs appear at the top of the Document window showing the filenames of all open documents. Dreamweaver displays an asterisk after the filename if you’ve made changes that you haven’t saved yet.

To switch to a document, click its tab.

Dreamweaver also displays the Related Files toolbar below the document’s tab (or below the document’s title bar if you’re viewing documents in separate windows). Related documents are documents associated with the current file, such as CSS files or JavaScript files. To open one of these related files in the Document window, click its filename in the Related Files toolbar.
More Help topics
“Working in the Document window” on page 17
“About Live view” on page 276
“Open Related Files” on page 68
“General information about coding in Dreamweaver” on page 281

Document toolbar overview

The Document toolbar contains buttons that let you toggle between different views of your document quickly. The toolbar also contains some common commands and options related to viewing the document and transferring it between the local and remote sites. The illustration below shows the expanded Document toolbar.

The following options appear in the Document toolbar:

Show Code View  Displays only the Code view in the Document window.

Show Code and Design Views  Splits the Document window between the Code and the Design views. When you select this combined view, the option Design View on Top becomes available in the View Options menu.

Show Design View  Displays only the Design view in the Document window.

Note: If you are working with XML, JavaScript, CSS, or other code based file types, you cannot view the files in Design view and the Design and Split buttons are dimmed out.

Live View  Displays a non-editable, interactive, browser based view of the document.

Live Code View  Displays the actual code used by the browser to execute the page.

Document Title  Allows you to enter a title for your document, to be displayed in the browser’s title bar. If your document already has a title, it appears in this field.

File Management  Displays the File Management pop-up menu.

Preview/Debug in Browser  Allows you to preview or debug your document in a browser. Select a browser from the pop-up menu.

Refresh Design View  Refreshes the document’s Design view after you make changes in Code view. Changes you make in Code view don’t automatically appear in Design view until you perform certain actions, such as saving the file or clicking this button.

Note: Refreshing also updates code features that are DOM (Document Object Model) dependent, such as the ability to select a code block’s opening or closing tags.

View Options  Allows you to set options for Code view and Design view, including which view you want to appear above the other. Options in the menu are for the current view: Design view, Code view, or both.

Visual Aids  Lets you use different visual aids to design your pages.

Validate Markup  Lets you validate the current document or a selected tag.

Check Browser Compatibility  Lets you check if your CSS is compatible across different browsers.
More Help topics
“Preview pages in Live view” on page 276
“Setting coding preferences” on page 287
“View and edit head content” on page 321
“Using visual aids for layout” on page 167

Standard toolbar overview
The Standard toolbar contains buttons for common operations from the File and Edit menus: New, Open, Browse in Bridge, Save, Save All, Print Code, Cut, Copy, Paste, Undo, and Redo. Use these buttons just as you would use the equivalent menu commands.

Style Rendering toolbar overview
The Style Rendering toolbar (hidden by default) contains buttons that let you see how your design would look in different media types if you use media-dependent style sheets. It also contains a button that lets you enable or disable CSS styles. To display the toolbar, select View > Toolbars > Style Rendering.

This toolbar only works if your documents use media-dependent style sheets. For example, your style sheet might specify a body rule for print media and a different body rule for handheld devices. For more information on creating media-dependent style sheets, see the World Wide Web Consortium website at www.w3.org/TR/CSS21/media.html.

By default, Dreamweaver displays your design for the screen media type (which shows you how a page is rendered on a computer screen). You can view the following media type renderings by clicking the respective buttons in the Style Rendering toolbar.

**Render Screen Media Type**  Shows you how the page appears on a computer screen.

**Render Print Media Type**  Shows you how the page appears on a printed piece of paper.

**Render Handheld Media Type**  Shows you how the page appears on a handheld device, such as a mobile phone or a BlackBerry device.

**Render Projection Media Type**  Shows you how the page appears on a projection device.

**Render TTY Media Type**  Shows you how the page appears on a teletype machine.

**Render TV Media Type**  Shows you how the page appears on a television screen.

**Toggle Displaying Of CSS Styles**  Lets you enable or disable CSS styles. This button works independently of the other media buttons.

**Design-time Style Sheets**  Lets you specify a Design-time style sheet.

For a tutorial on designing style sheets for print and handheld devices, see www.adobe.com/go/vid0156.

Browser Navigation toolbar overview
The Browser Navigation toolbar becomes active in Live view, and shows you the address of the page you’re looking at in the Document window. As of Dreamweaver CS5, Live view acts like a regular browser, so even if you browse to a site outside of your local site (for example, http://www.adobe.com), Dreamweaver will load the page in the Document window.
By default, links are not active in Live view. Having links non-active lets you select or click link text in the Document window without being taken to another page. To test links in Live view, you can enable one-time clicking or continuous clicking by selecting Follow Links or Follow Links Continuously from the View options menu to the right of the address box.

More Help topics
“Previewing pages in Dreamweaver” on page 276

Coding toolbar overview
The Coding toolbar contains buttons that let you perform many standard coding operations, such as collapsing and expanding code selections, highlighting invalid code, applying and removing comments, indenting code, and inserting recently used code snippets. The Coding toolbar appears vertically on the left side of the Document window, and is only visible when Code view is showing.

You cannot undock or move the Coding toolbar, but you can hide it (View > Toolbars > Coding).

You can also edit the Coding toolbar to display more buttons (such as Word Wrap, Show Hidden Characters, and Auto Indent), or hide buttons that you don’t want to use. To do so, however, you must edit the XML file that generates the toolbar. For more information, see Extending Dreamweaver.

More Help topics
“Insert code with the Coding toolbar” on page 296
Status bar overview

The Status bar at the bottom of the Document window provides additional information about the document you are creating.

A. Tag selector  B. Select tool  C. Hand tool  D. Zoom tool  E. Set magnification  F. Window size pop-up menu  G. Document size and estimated download time  H. Encoding indicator

Tag selector  Shows the hierarchy of tags surrounding the current selection. Click any tag in the hierarchy to select that tag and all its contents. Click `<body>` to select the entire body of the document. To set the `class` or `ID` attributes for a tag in the tag selector, right-click (Windows) or Control-click (Macintosh) the tag and select a class or ID from the context menu.

Select tool  Enables and disables the Hand tool.

Hand tool  Lets you click the document and drag it in the Document window.

Zoom tool and Set Magnification pop-up menu  Let you set a magnification level for your document.

Window size pop-up menu  (Not available in Code view.) Lets you resize the Document window to predetermined or custom dimensions. When you change the view size of a page in design or live view only the dimensions of the view size change. The document size is unaltered.

In addition to predetermined and custom sizes, Dreamweaver also lists sizes specified in a media query. When you select a size corresponding to a media query, Dreamweaver uses the media query to display the page. You can also change the page orientation to preview the page for mobile devices where the page layout changes based on how the device is held.

Document size and download time  Shows the estimated document size and estimated download time for the page, including all dependent files such as images and other media files.

Encoding indicator  Shows the text encoding for the current document.

More Help topics

“Set window size and connection speed” on page 20

“Zoom in and out” on page 208

“Resize the Document window” on page 18

“Set download time and size preferences” on page 209
Property inspector overview

The Property inspector lets you examine and edit the most common properties for the currently selected page element, such as text or an inserted object. The contents of the Property inspector vary depending on the element selected. For example, if you select an image on your page, the Property inspector changes to show properties for the image (such as the file path to the image, the width and height of the image, the border around the image, if any, and so on).

The Property inspector is at the lower edge of the workspace by default, but you can undock it and make it a floating panel in the workspace.

More Help topics
“Dock and undock panels” on page 23
“Use the Property inspector” on page 21

Insert panel overview

The Insert panel contains buttons for creating and inserting objects such as tables, images, and links. The buttons are organized into several categories, which you can switch by selecting the desired category from the Category pop-up menu. Additional categories appear when the current document contains server code, such as ASP or CFML documents.
Some categories have buttons with pop-up menus. When you select an option from a pop-up menu, it becomes the default action for the button. For example, if you select Image Placeholder from the Image button’s pop-up menu, the next time you click the Image button, Dreamweaver inserts an image placeholder. Anytime you select a new option from the pop-up menu, the default action for the button changes.

The Insert panel is organized in the following categories:

**The Common category**  Lets you create and insert the most commonly used objects, such as images and tables.

**The Layout category**  Lets you insert tables, table elements, div tags, frames, and Spry widgets. You can also choose two views for tables: Standard (default) and Expanded Tables.

**The Forms category**  Contains buttons for creating forms and inserting form elements, including Spry validation widgets.

**The Data category**  Lets you insert Spry data objects as well as other dynamic elements like recordsets, repeated regions, and record insertion and update forms.

**The Spry category**  Contains buttons for building Spry pages, including Spry data objects and widgets.

**The InContext Editing category**  Contains buttons for building InContext editing pages, including buttons for Editable Regions, Repeating Regions, and managing CSS classes.

**The Text category**  Lets you insert a variety of text- and list-formatting tags, such as b, em, p, h1, and ul.

**The Favorites category**  Lets you group and organize the Insert panel buttons you use the most in one common place.

**Server-code categories**  Available only for pages that use a particular server language, including ASP, CFML Basic, CFML Flow, CFML Advanced, and PHP. Each of these categories provides server-code objects that you can insert in Code view.

Unlike other panels in Dreamweaver, you can drag the Insert panel out of its default dock position and drop it into a horizontal position at the top of the Document window. When you do so, it changes from a panel to a toolbar (though you cannot hide and display it in the same way as other toolbars).

**More Help topics**

“Use the Insert panel” on page 198
Files panel overview

Use the Files panel to view and manage the files in your Dreamweaver site.

When you view sites, files, or folders in the Files panel, you can change the size of the viewing area, and expand or collapse the Files panel. When the Files panel is collapsed, it displays the contents of the local site, the remote site, the testing server, or the SVN repository as a list of files. When expanded, it displays the local site and either the remote site, the testing server, or the SVN repository.

For Dreamweaver sites, you can also customize the Files panel by changing the view—either your local or remote site—that appears by default in the collapsed panel.

(CS5.5) The Files panel interacts with the server at regular intervals to update its content. An error message is displayed when you try to perform an action in the Files panel when it is running these auto-updates. To disable auto-updates, open the Files panel options menu, and deselect Auto-Update in the View menu.

To update the contents of the panel manually, use the Refresh button in the panel. The current check-out status of files, however, is updated only when auto-updates are enabled.

More Help topics
“Work with files in the Files panel” on page 75
CSS Styles panel overview

The CSS Styles panel lets you track the CSS rules and properties affecting a currently selected page element (Current mode), or the rules and properties affecting an entire document (All mode). A toggle button at the top of the CSS Styles panel lets you switch between the two modes. The CSS Styles panel also lets you modify CSS properties in both All and Current mode.

You can resize any of the panes by dragging the borders between the panes.

In Current mode, the CSS Styles panel displays three panes: a Summary for Selection pane that displays the CSS properties for the current selection in the document, a Rules pane that displays the location of selected properties (or a cascade of rules for the selected tag, depending on your selection), and a Properties pane that lets you edit CSS properties for the rule defining the selection.

In All mode, the CSS Styles panel displays two panes: an All Rules pane (on top), and a Properties pane (on bottom). The All Rules pane displays a list of rules defined in the current document as well as all rules defined in style sheets attached to the current document. The Properties pane lets you edit CSS properties for any selected rule in the All Rules pane. Any changes you make in the Properties pane are applied immediately, letting you preview your work as you go.

Visual guides overview

Dreamweaver provides several kinds of visual guides to help you design documents and predict approximately how they appear in browsers. You can do any of the following:

- Instantly snap the Document window to a desired window size to see how the elements fit on the page.
- Use a tracing image as the page background to help you duplicate a design created in an illustration or image-editing application such as Adobe® Photoshop® or Adobe® Fireworks®.
- Use rulers and guides to provide a visual cue for precise positioning and resizing of page elements.
- Use the grid for precise positioning and resizing of absolutely positioned elements (AP elements).
  Grid marks on the page help you align AP elements, and when snapping is enabled, AP elements automatically snap to the closest grid point when moved or resized. (Other objects, such as images and paragraphs, do not snap to the grid.) Snapping works regardless of whether the grid is visible.
More Help topics
“Using visual aids for layout” on page 167

GoLive users
If you have been using GoLive and want to switch to working with Dreamweaver, you can find an online introduction to the Dreamweaver workspace and workflow, as well as a discussion of ways to migrate your sites to Dreamweaver.

More Help topics
Dreamweaver for GoLive users tutorial

Working in the Document window

Switch between views in the Document window
You can view a document in the Document window in Code view, Split Code view, Design view, Code and Design views (Split view), or Live view. You also have the option of viewing Split Code view or Code and Design views horizontally or vertically. (Horizontal display is the default.)

Switch to Code view
❖ Do one of the following:
  • Select View > Code.
  • In the Document toolbar, click the Show Code View button.

Switch to Split Code view
Split Code view splits your document in two so that you can work on two sections of the code at once.
❖ Select View > Split Code.

Switch to Design view
❖ Do one of the following:
  • Select View > Design.
  • In the Document toolbar, click the Show Design View button.

Show both Code and Design views
❖ Do one of the following:
  • Select View > Code and Design.
  • In the Document toolbar, click the Show Code and Design Views button.
By default, Code view appears at the top of the Document window and Design view appears at the bottom. To display Design view on top, select View > Design View on Top.

**Toggle between Code view and Design view**

❖ Press Control+backquote (‘).

If both views are showing in the Document window, this keyboard shortcut changes keyboard focus from one view to the other.

**Split views vertically**

This option is only available for Split Code view and Code and Design views (Split view). It is disabled for Code view and Design view.

1. Make sure that you are in Split Code view (View > Split Code) or Code and Design views (View > Code and Design).
2. Select View > Split Vertically.

If you are in Code and Design views, you have the option of displaying Design view on the left (View > Design View on Left).

**More Help topics**

“Document window overview” on page 8

“Preview pages in Live view” on page 276

**Cascade or tile Document windows**

If you have many documents open at once, you can cascade or tile them.

**More Help topics**

“Manage windows and panels” on page 22

“Display tabbed documents (Dreamweaver Macintosh)” on page 28

**Cascade Document windows**

❖ Select Window > Cascade.

**Tile Document windows**

• (Windows) Select Window > Tile Horizontally or Window > Tile Vertically.
• (Macintosh) Select Window > Tile.

**Resize the Document window**

The Status bar displays the Document window’s current dimensions (in pixels). To design a page that looks its best at a specific size, you can adjust the Document window to any of the predetermined sizes, edit those predetermined sizes, or create sizes.

When you change the view size of a page in design or live view only the dimensions of the view size change. The document size is unaltered.
In addition to predetermined and custom sizes, Dreamweaver also lists sizes specified in a media query. When you select a size corresponding to a media query, Dreamweaver uses the media query to display the page. You can also change the page orientation to preview the page for mobile devices where the page layout changes based on how the device is held.

### Resize the Document window to a predetermined size

- Select one of the sizes from the Window Size pop-up menu at the bottom of the Document window. Dreamweaver CS5.5 and later offers an extended list of choices, including choices for common mobile devices (as pictured below).

![Media Queries](image)

The window size shown reflects the inside dimensions of the browser window, without borders; the monitor size or mobile device is listed to the right.

- **For less precise resizing, use your operating system’s standard methods of resizing windows, such as dragging the lower-right corner of a window.**

**Note:** (Windows only) Documents within the Document window are maximized by default, and you can’t resize a document when it’s maximized. To de-maximize the document, click the de-maximize button in the upper right corner of the document.

### Change the values listed in the Window Size pop-up menu

1. Select Edit Sizes from the Window Size pop-up menu.
2. Click any of the width or height values in the Window Sizes list, and type a new value.

To make the Document window adjust only to a specific width (leaving the height unchanged), select a height value and delete it.

3. Click the Description box to enter descriptive text about a specific size.

### Add a new size to the Window Size pop-up menu

1. Select Edit Sizes from the Window Size pop-up menu.
2. Click the blank space below the last value in the Width column.
3. Enter values for Width and Height.

To set the Width or Height only, simply leave one field empty.

4. Click the Description field to enter descriptive text about the size you added.
For example, you might type **SVGA** or **average PC** next to the entry for an 800 x 600 pixel monitor, and **17-in. Mac** next to the entry for an 832 x 624 pixel monitor. Most monitors can be adjusted to a variety of pixel dimensions.

**Set window size and connection speed**

1. Select **Edit > Preferences** (Windows) or **Dreamweaver > Preferences** (Macintosh).
2. Select **Status Bar (CS5)** or **Window Sizes (CS5.5 and later)** from the Category list on the left.
3. Set any of the following options:
   - **Window Sizes** lets you customize the window sizes that appear in the Status bar’s pop-up menu.
   - **Connection Speed** determines the connection speed (in kilobits per second) used to calculate the download size. The download size for the page is displayed in the Status bar. When an image is selected in the Document window, the image’s download size is displayed in the Property inspector.

**More Help topics**

“**Status bar overview**” on page 12

“**Resize the Document window**” on page 18

**Reports in Dreamweaver**

You can run reports in Dreamweaver to find content, troubleshoot, or test content. You can generate the following types of reports:

- **Search** Lets you search for tags, attributes, and specific text within tags.
- **Reference** Lets you search for helpful reference information.
- **Validation** Lets you check for code or syntax errors.
- **Browser Compatibility** Lets you test the HTML in your documents to see if any tags or attributes are unsupported by your target browsers.
- **Link Checker** Lets you find and fix broken, external, and orphaned links.
- **Site Reports** Enable you to improve workflow and test HTML attributes in your site. Workflow reports include checked out by, recently modified, and design notes; HTML reports include combinable nested font tags, accessibility, missing Alt text, redundant nested tags, removable empty tags, and untitled documents.
- **FTP Log** Enables you to view all FTP file-transfer activity.
- **Server Debug** Lets you view information to debug an Adobe® ColdFusion® application.

**Using toolbars, inspectors, and context menus**

**Display toolbars**

Use the Document and Standard toolbars to perform document-related and standard editing operations; the Coding toolbar to insert code quickly; and the Style Rendering toolbar to display your page as it would appear in different media types. You can choose to display or hide the toolbars as necessary.

- Select **View > Toolbars**, and then select the toolbar.
- Right-click (Windows) or Control-click (Macintosh) any of the toolbars and select the toolbar from the context menu.
**Note:** To display or hide the Coding toolbar in the Code inspector (Window > Code Inspector), select Coding Toolbar from the View Options pop-up menu at the top of the inspector.

**More Help topics**
- “Document toolbar overview” on page 9
- “Standard toolbar overview” on page 10
- “Coding toolbar overview” on page 11
- “Style Rendering toolbar overview” on page 10

**Use the Property inspector**
The Property inspector lets you examine and edit the most common properties for the currently selected page element, such as text or an inserted object. The contents of the Property inspector vary depending on the element(s) selected.

To access help for a particular Property inspector, click the help button in the upper right corner of the Property inspector, or select Help from a Property inspector’s Options menu.

**Note:** Use the Tag inspector to view and edit every attribute associated with a given tag’s properties.

**More Help topics**
- “Property inspector overview” on page 13
- “Set text properties in the Property inspector” on page 217
- “Dock and undock panels” on page 23
- “Change attributes with the Tag inspector” on page 316

**Show or hide the Property inspector**
- Select Window > Properties.

**Expand or collapse the Property inspector**
- Click the expander arrow in the lower-right corner of the Property inspector.

**View and change properties for a page element**
1. Select the page element in the Document window.
   You might have to expand the Property inspector to view all the properties for the selected element.
2. Change any of the properties in the Property inspector.
   **Note:** For information on specific properties, select an element in the Document window, and then click the Help icon in the upper-right corner of the Property inspector.
3. If your changes are not immediately applied in the Document window, apply the changes in one of these ways:
   - Click outside the property-editing text fields.
   - Press Enter (Windows) or Return (Macintosh).
   - Press Tab to switch to another property.
Use context menus
Context menus provide convenient access to the most useful commands and properties related to the object or window you’re working with. Context menus list only those commands that pertain to the current selection.

1. Right-click (Windows) or Control-click (Macintosh) the object or window.
2. Select a command from the context menu.

Customizing the Dreamweaver CS5 workspace

Manage windows and panels
You can create a custom workspace by moving and manipulating Document windows and panels. You can also save workspaces and switch among them. For Fireworks, renaming custom workspaces can lead to unexpected behavior.

Note: The following examples use Photoshop for demonstration purposes. The workspace behaves the same in all the products.

Rearrange, dock, or float document windows
When you open more than one file, the Document windows are tabbed.

- To rearrange the order of tabbed Document windows, drag a window’s tab to a new location in the group.
- To undock (float or untab) a Document window from a group of windows, drag the window’s tab out of the group.
**Note:** In Photoshop you can also choose Window > Arrange > Float in Window to float a single Document window, or Window > Arrange > Float All In Windows to float all of the Document windows at once. See tech note kb405298 for more information.

**Note:** Dreamweaver does not support docking and undocking Document windows. Use the Document window’s Minimize button to create floating windows (Windows), or choose Window > Tile Vertically to create side-by-side Document windows. Search “Tile Vertically” in Dreamweaver Help for more information on this topic. The workflow is slightly different for Macintosh users.

- To dock a Document window to a separate group of Document windows, drag the window into the group.
- To create groups of stacked or tiled documents, drag the window to one of the drop zones along the top, bottom, or sides of another window. You can also select a layout for the group by using the Layout button on the Application bar.
  **Note:** Some products do not support this functionality. However, your product may have Cascade and Tile commands in the Window menu to help you lay out your documents.
- To switch to another document in a tabbed group when dragging a selection, drag the selection over the document’s tab for a moment.
  **Note:** Some products do not support this functionality.

### Dock and undock panels

A *dock* is a collection of panels or panel groups displayed together, generally in a vertical orientation. You dock and undock panels by moving them into and out of a dock.

- To dock a panel, drag it by its tab into the dock, at the top, bottom, or in between other panels.
- To dock a panel group, drag it by its title bar (the solid empty bar above the tabs) into the dock.
- To remove a panel or panel group, drag it out of the dock by its tab or title bar. You can drag it into another dock or make it free-floating.

`Navigator panel being dragged out to new dock, indicated by blue vertical highlight`
You can prevent panels from filling all the space in a dock. Drag the bottom edge of the dock up so it no longer meets the edge of the workspace.

**Move panels**

As you move panels, you see blue highlighted drop zones, areas where you can move the panel. For example, you can move a panel up or down in a dock by dragging it to the narrow blue drop zone above or below another panel. If you drag to an area that is not a drop zone, the panel floats freely in the workspace.

*Note: The position of the mouse (rather than the position of the panel), activates the drop zone, so if you can’t see the drop zone, try dragging the mouse to the place where the drop zone should be.*

- To move a panel, drag it by its tab.
- To move a panel group, drag the title bar.

Press Ctrl (Windows) or Command (Mac OS) while moving a panel to prevent it from docking. Press Esc while moving the panel to cancel the operation.

**Add and remove panels**

If you remove all panels from a dock, the dock disappears. You can create a dock by moving panels to the right edge of the workspace until a drop zone appears.

- To remove a panel, right-click (Windows) or Control-click (Mac) its tab and then select Close, or deselect it from the Window menu.
- To add a panel, select it from the Window menu and dock it wherever you want.
**Manipulate panel groups**

- To move a panel into a group, drag the panel’s tab to the highlighted drop zone in the group.

![Adding a panel to a panel group](image)

- To rearrange panels in a group, drag a panel’s tab to a new location in the group.
- To remove a panel from a group so that it floats freely, drag the panel by its tab outside the group.
- To move a group, drag the title bar (the area above the tabs).

**Stack floating panels**

When you drag a panel out of its dock but not into a drop zone, the panel floats freely. The floating panel allows you to position it anywhere in the workspace. You can stack floating panels or panel groups so that they move as a unit when you drag the topmost title bar.

![Free-floating stacked panels](image)

- To stack floating panels, drag a panel by its tab to the drop zone at the bottom of another panel.
- To change the stacking order, drag a panel up or down by its tab.

  **Note:** Be sure to release the tab over the narrow drop zone between panels, rather than the broad drop zone in a title bar.

- To remove a panel or panel group from the stack, so that it floats by itself, drag it out by its tab or title bar.

**Resize panels**

- To minimize or maximize a panel, panel group, or stack of panels, double-click a tab. You can also double-click the tab area (the empty space next to the tabs).
- To resize a panel, drag any side of the panel. Some panels, such as the Color panel in Photoshop, cannot be resized by dragging.

**Collapse and expand panel icons**

You can collapse panels to icons to reduce clutter on the workspace. In some cases, panels are collapsed to icons in the default workspace.
Panels collapsed to icons

Panels expanded from icons

- To collapse or expand all panel icons in a column, click the double arrow at the top of the dock.
- To expand a single panel icon, click it.
- To resize panel icons so that you see only the icons (and not the labels), adjust the width of the dock until the text disappears. To display the icon text again, make the dock wider.
- To collapse an expanded panel back to its icon, click its tab, its icon, or the double arrow in the panel’s title bar.
  
  *In some products, if you select Auto-Collapse Icon Panels from the Interface or User Interface Options preferences, an expanded panel icon collapses automatically when you click away from it.*

  - To add a floating panel or panel group to an icon dock, drag it in by its tab or title bar. (Panels are automatically collapsed to icons when added to an icon dock.)
  - To move a panel icon (or panel icon group), drag the icon. You can drag panel icons up and down in the dock, into other docks (where they appear in the panel style of that dock), or outside the dock (where they appear as floating icons).

**Save and switch workspaces**

By saving the current size and position of panels as a named workspace, you can restore that workspace even if you move or close a panel. The names of saved workspaces appear in the workspace switcher in the Application bar.

**Save a custom workspace**

1. With the workspace in the configuration you want to save, do one of the following:
   - (Illustrator) Choose Window > Workspace > Save Workspace.
   - (Dreamweaver) Choose Window > Workspace Layout > New Workspace.
• (Flash) Choose New Workspace from the workspace switcher in the Application bar.
• (Fireworks) Choose Save Current from the workspace switcher in the Application bar.

2 Type a name for the workspace.

3 (Photoshop, InDesign) Under Capture, select one or more options:
   Panel Locations Saves the current panel locations (InDesign only).
   Keyboard shortcuts Saves the current set of keyboard shortcuts (Photoshop only).
   Menus or Menu Customization Saves the current set of menus.

Display or switch workspaces
❖ Select a workspace from the workspace switcher in the Application bar.

In Photoshop, you can assign keyboard shortcuts to each workspace to navigate among them quickly.

Delete a custom workspace
• Select Manage Workspaces from the workspace switcher in the Application bar, select the workspace, and then click Delete. (The option is not available in Fireworks.)
• (Photoshop, InDesign, InCopy) Select Delete Workspace
• Delete Workspace
• from the workspace switcher.
• (Illustrator) Choose Window > Workspace > Manage Workspaces, select the workspace, and then click the Delete icon.
• (Photoshop, InDesign) Choose Window > Workspace >
• Delete Workspace
• , select the workspace, and then click Delete.

Restore the default workspace
1 Select the Default or Essentials workspace from the workspace switcher in the application bar. For Fireworks, see the article http://www.adobe.com/devnet/fireworks/articles/workspace_manager_panel.html.

   Note: In Dreamweaver, Designer is the default workspace.

2 For Fireworks (Windows), delete these folders:
   Windows Vista \Users\<username>\AppData\Roaming\Adobe\Fireworks CS4\n   Windows XP \Documents and Settings\<username>\Application Data\Adobe\Fireworks CS4
3 (Photoshop, InDesign, InCopy) Select Window > Workspace > Reset [Workspace Name].

(Photoshop) Restore a saved workspace arrangement
In Photoshop, workspaces automatically appear as you last arranged them, but you can restore the original, saved arrangement of panels.
• To restore an individual workspace, choose Window > Workspace > Reset Workspace Name.
• To restore all the workspaces installed with Photoshop, click Restore Default Workspaces in the Interface preferences.
To rearrange the order of workspaces in the application bar, drag them.

Display tabbed documents (Dreamweaver Macintosh)
You can view multiple documents in a single Document window by using tabs to identify each document. You can also display them as part of a floating workspace, in which each document appears in its own window.

Open a tabbed document in a separate window
❖ Control-click the tab and select Move To New Window from the context menu.

Combine separate documents into tabbed windows
❖ Select Window > Combine As Tabs.

Change the default tabbed document setting
1 Select Dreamweaver > Preferences, and then select the General category.
2 Select or deselect Open Documents in Tabs, and click OK.
Dreamweaver does not alter the display of documents that are currently open when you change preferences. Documents opened after you select a new preference, however, display according to the preference you selected.

Turn on color icons
By default, Dreamweaver CS4 and later uses black and white icons that turn into colored icons when you hover over them. You can turn color icons on permanently so that no hovering is required.
❖ Do one of the following:
  • Choose View > Color Icons.
  • Switch to the Classic or Coder workspace.
To turn color icons off again, deselect Color Icons in the View menu, or switch to a different workspace.

More Help topics
“Display or switch workspaces” on page 27

Hide and display the Dreamweaver Welcome screen
The Welcome screen appears when you start Dreamweaver and anytime that you do not have any documents open. You can choose to hide the Welcome screen, and then later display it again. When the Welcome screen is hidden and no documents are open, the Document window is blank.

Hide the Welcome screen
❖ Select the Don’t Show Again option on the Welcome screen.

Display the Welcome screen
1 Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).
2 In the General category, select the Show Welcome Screen option.
About customizing Dreamweaver in multiuser systems

You can customize Dreamweaver to suit your needs even in a multiuser operating system such as Windows XP or Mac OS X.

Dreamweaver prevents any user’s customized configuration from affecting any other user’s customized configuration. To accomplish this goal, the first time you run Dreamweaver in one of the multiuser operating systems that it recognizes, the application creates copies of a variety of configuration files. These user configuration files are stored in a folder that belongs to you.

For example, in Windows XP, they’re stored in C:\Documents and Settings\username\Application Data\Adobe\Dreamweaver\en_US\Configuration, which is hidden by default. To show hidden files and folders, select Tools > Folder Options in Windows Explorer, click the View tab, and select the Show Hidden Files and Folders option.

In Windows Vista, they’re stored in C:\Users\username\AppData\Roaming\Adobe\Dreamweaver\en_US\Configuration, which is hidden by default. To show hidden files and folders, select Tools > Folder Options in Windows Explorer, click the View tab, and select the Show Hidden Files and Folders option.

In Mac OS X, they’re stored inside your Home folder; specifically, in Users/username/Library/Application Support/Adobe/Dreamweaver/Configuration.

If you reinstall or upgrade Dreamweaver, Dreamweaver automatically makes backup copies of existing user configuration files, so if you customized those files by hand, you still have access to the changes you made.

Set General preferences for Dreamweaver

1 Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).

2 Set any of the following options:

**Open Documents In Tabs** Opens all documents in a single window with tabs that let you switch between documents (Macintosh only).

**Show Welcome Screen** Displays the Dreamweaver Welcome screen when you start Dreamweaver or when you don’t have any documents open.

**Reopen Documents on Startup** Opens any documents that were open when you closed Dreamweaver. If this option is not selected, Dreamweaver displays the Welcome screen or a blank screen when you start (depending on your Show Welcome Screen setting).

**Warn When Opening Read-Only Files** Alerts you when you open a read-only (locked) file. Choose to unlock/check out the file, view the file, or cancel.

**Enable Related Files** Lets you see which files are connected to the current document (for example, CSS or JavaScript files). Dreamweaver displays a button for each related file at the top of the document, and opens the file if you click the button.
Discover Dynamically-Related Files  Lets you select whether Dynamically-Related Files appear in the Related Files toolbar automatically, or after manual interaction. You can also choose to disable the discovery of Dynamically-Related Files.

Update Links When Moving Files  Determines what happens when you move, rename, or delete a document within your site. Set this preference to always update links automatically, never update links, or prompt you to perform an update. (See “Update links automatically” on page 268.)

Show Dialog When Inserting Objects  Determines whether Dreamweaver prompts you to enter additional information when inserting images, tables, Shockwave movies, and certain other objects by using the Insert panel or the Insert menu. If this option is off, the dialog box does not appear and you must use the Property inspector to specify the source file for images, the number of rows in a table, and so on. For rollover images and Fireworks HTML, a dialog box always appears when you insert the object, regardless of this option setting. (To temporarily override this setting, Control-click (Windows) or Command-click (Macintosh) when creating and inserting objects.)

Enable Double-Byte Inline Input  Lets you enter double-byte text directly into the Document window if you are using a development environment or language kit that facilitates double-byte text (such as Japanese characters). When this option is deselected, a text input window appears for entering and converting double-byte text; the text appears in the Document window after it is accepted.

Switch To Plain Paragraph After Heading  Specifies that pressing Enter (Windows) or Return (Macintosh) at the end of a heading paragraph in Design view creates a new paragraph tagged with a p tag. (A heading paragraph is one that’s tagged with a heading tag such as h1 or h2.) When the option is disabled, pressing Enter or Return at the end of a heading paragraph creates a new paragraph tagged with the same heading tag (allowing you to type multiple headings in a row and then go back and fill in details).

Allow Multiple Consecutive Spaces  Specifies that typing two or more spaces in Design view creates nonbreaking spaces that appear in a browser as multiple spaces. (For example, you can type two spaces between sentences, as you would on a typewriter.) This option is designed mostly for people who are used to typing in word processors. When the option is disabled, multiple spaces are treated as a single space (because browsers treat multiple spaces as single spaces).

Use <strong> and <em> in Place of <b> and <i>  Specifies that Dreamweaver applies the strong tag whenever you perform an action that would normally apply the b tag, and applies the em tag whenever you perform an action that would normally apply the i tag. Such actions include clicking the Bold or Italic buttons in the text Property inspector in HTML mode and choosing Format > Style > Bold or Format > Style > Italic. To use the b and i tags in your documents, deselect this option.

Note: The World Wide Web Consortium discourages use of the b and i tags; the strong and em tags provide more semantic information than the b and i tags do.

Warn when placing editable regions within <p> or <h1> - <h6> tags  Specifies whether a warning message is displayed whenever you save a Dreamweaver template that has an editable region within a paragraph or heading tag. The message tells you that users will not be able to create more paragraphs in the region. It is enabled by default.

Centering  Specifies whether you want to center elements using div align="center" or the center tag when you click the Align Center button in the Property inspector.

Note: Both of these approaches to centering have been officially deprecated as of the HTML 4.01 specification; you should use CSS styles to center text. Both of these approaches are still technically valid as of the XHTML 1.0 Transitional specification, but they’re no longer valid in the XHTML 1.0 Strict specification.

Maximum Number of History Steps  Determines the number of steps that the History panel retains and shows. (The default value should be sufficient for most users.) If you exceed the given number of steps in the History panel, the oldest steps are discarded.
For more information, see “Task automation” on page 255.

**Spelling Dictionary** lists the available spelling dictionaries. If a dictionary contains multiple dialects or spelling conventions (such as American English and British English), the dialects are listed separately in the Dictionary pop-up menu.

**More Help topics**
“Workspace layout overview” on page 5
“Update links automatically” on page 268

**Set Fonts preferences for documents in Dreamweaver**

A document’s encoding determines how the document appears in a browser. Dreamweaver font preferences let you view a given encoding in the font and size you prefer. The fonts you select in the Fonts Preferences dialog, however, only affect the way fonts appear in Dreamweaver; they do not affect the way the document appears in a visitor’s browser. To change the way fonts appear in a browser, you need to change the text by using the Property inspector or by applying a CSS rule.

For information on setting a default encoding for new documents, see “Creating and opening documents” on page 59.

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).
2. Select Fonts from the Category list on the left.
3. Select an encoding type (such as Western European or Japanese) from the Font Settings list.

*Note: To display an Asian language, you must be using an operating system that supports double-byte fonts.*

4. Select a font and size to use for each category of the selected encoding.

*Note: To appear in the font pop-up menus, a font must be installed on your computer. For example, to see Japanese text you must have a Japanese font installed.*

**Proportional Font** The font that Dreamweaver uses to display normal text (for example, text in paragraphs, headings, and tables). The default depends on your system’s installed fonts. For most U.S. systems, the default is Times New Roman 12 pt. (Medium) on Windows and Times 12 pt. on Mac OS.

**Fixed Font** The font Dreamweaver uses to display text within `pre`, `code`, and `tt` tags. The default depends on your system’s installed fonts. For most U.S. systems, the default is Courier New 10 pt. (Small) on Windows and Monaco 12 pt. on Mac OS.

**Code View** The font used for all text that appears in the Code view and Code inspector. The default depends on your system’s installed fonts.

**More Help topics**
“Understanding document encoding” on page 204

**Customize Dreamweaver highlighting colors**

Use the Highlighting preferences to customize the colors that identify template regions, library items, third-party tags, layout elements, and code in Dreamweaver.
More Help topics
“Use the color picker” on page 208
“Change the highlight color of div tags” on page 154

Change a highlighting color
1. Select Edit > Preferences and select the Highlighting category.
2. Beside the object you want to change the highlighting color for, click the color box, and then use the color picker to select a new color, or enter a hexadecimal value.

Activate or deactivate highlighting for an object
1. Select Edit > Preferences and select the Highlighting category.
2. Beside the object you want to activate or deactivate highlighting color for, select or deselect the Show option.

Restore default preferences
For procedures on restoring default Dreamweaver preferences, see Tech Note 83912.

Keyboard shortcuts

Create a reference sheet for the current shortcut set
A reference sheet is a record of the current shortcut set. The information is stored in HTML table format. You can view the reference sheet in a web browser or print it.
1. Select Edit > Keyboard Shortcuts (Windows) or Dreamweaver > Keyboard Shortcuts (Macintosh).
2. Click the Export Set As HTML button, which is the third button in the set of four at the top of the dialog box.
3. In the Save dialog box that appears, enter the name for the reference sheet, and select the appropriate location for saving the file.

Customize keyboard shortcuts
Use the Keyboard Shortcut Editor to create your own shortcut keys, including keyboard shortcuts for code snippets. You can also remove shortcuts, edit existing shortcuts, and select a predetermined set of shortcuts in the Keyboard Shortcut Editor.

More Help topics
“Work with code snippets” on page 304

Create a keyboard shortcut
Create your own shortcut keys, edit existing shortcuts, or select a predetermined set of shortcuts.
1. Select Edit > Keyboard Shortcuts (Windows) or Dreamweaver > Keyboard Shortcuts (Macintosh).
2 Set any of the following options and click OK:

**Current Set** Allows you to choose a set of predetermined shortcuts included with Dreamweaver, or any custom set you've defined. The predetermined sets are listed at the top of the menu. For example, if you are familiar with the shortcuts found in HomeSite or BBEdit, you can use those shortcuts by choosing the corresponding predetermined set.

**Commands** Allows you to select a category of commands to edit. For example, you can edit menu commands, such as the Open command, or code editing commands, such as Balance Braces.

INFO: To add or edit a keyboard shortcut for a code snippet, select Snippet from the Commands pop-up menu.

**The command list** Displays the commands associated with the category you selected from the Commands pop-up menu, along with the assigned shortcuts. The Menu Commands category displays this list as a tree view that replicates the structure of the menus. The other categories list the commands by name (such as Quit Application), in a flat list.

**Shortcuts** Displays all shortcuts assigned to the selected command.

**Add Item (+)** Adds a new shortcut to the current command. Click this button to add a new blank line to the Shortcuts. Enter a new key combination and click Change to add a new keyboard shortcut for this command. You can assign two different keyboard shortcuts for each command; if there are already two shortcuts assigned to a command, the Add Item button does nothing.

**Remove Item (-)** Removes the selected shortcut from the list of shortcuts.

**Press Key** Displays the key combination you enter when you're adding or changing a shortcut.

**Change** Adds the key combination shown in the Press Key to the list of shortcuts, or changes the selected shortcut to the specified key combination.

**Duplicate Set** Duplicates the current set. Give the new set a name; the default name is the current set's name with the word *copy* appended.

**Rename Set** Renames the current set.

**Export as HTML File** Saves the current set in an HTML table format for easy viewing and printing. You can open the HTML file in your browser and print the shortcuts for easy reference.

**Delete Set** Deletes a set. (You cannot delete the active set.)

**Remove a shortcut from a command**

1 Select Edit > Keyboard Shortcuts (Windows) or Dreamweaver > Keyboard Shortcuts (Macintosh).

2 From the Commands pop-up menu, select a command category.

3 In the Commands list, select a command and then select a shortcut.

4 Click the Remove Item (-) button.

**Add a shortcut to a command**

1 Select Edit > Keyboard Shortcuts (Windows) or Dreamweaver > Keyboard Shortcuts (Macintosh).

2 From the Commands pop-up menu, select a command category.

3 In the Commands list, select a command.

INFO: To add a keyboard shortcut for a code snippet, select Snippet from the Commands pop-up menu.

The shortcuts assigned to the command appear in the Shortcuts.
4 Prepare to add a shortcut by doing one of the following:
   - If there are fewer than two shortcuts already assigned to the command, click the Add Item (+) button. A new blank line appears in the Shortcuts and the insertion point moves to the Press Key.
   - If there are already two shortcuts assigned to the command, select one of them (that one will be replaced by the new shortcut). Then click in the Press Key.

5 Press a key combination. The key combination appears in the Press Key.

   *Note: If there is a problem with the key combination (for example, if the key combination is already assigned to another command), an explanatory message appears just below the Shortcuts and you may be unable to add or edit the shortcut.*

6 Click Change. The new key combination is assigned to the command.

**Edit an existing shortcut**

1 Select Edit > Keyboard Shortcuts (Windows) or Dreamweaver > Keyboard Shortcuts (Macintosh).
2 From the Commands pop-up menu, select a command category.
3 In the Commands list, select a command and then select a shortcut to change.
4 Click in the Press Key and enter a new key combination.
5 Click the Change button to change the shortcut.

   *Note: If there is a problem with the key combination (for example, if the key combination is already assigned to another command), an explanatory message appears just below the Shortcuts field and you may be unable to add or edit the shortcut.*

**About keyboard shortcuts and non-U.S. keyboards**

The default Dreamweaver keyboard shortcuts work primarily on U.S.-standardized keyboards. Keyboards from other countries (including those produced in the United Kingdom), may not provide the functionality necessary for utilizing these shortcuts. If your keyboard does not support certain Dreamweaver-enabled shortcuts, Dreamweaver disables their functionality.

To customize keyboard shortcuts that work with non-U.S.-standardized keyboards, see “Changing keyboard shortcut mappings” in *Extending Dreamweaver*.

**Extensions**

**Add and manage extensions in Dreamweaver**

Extensions are new features that you can add easily to Dreamweaver. You can use many types of extensions; for example, there are extensions that let you reformat tables, connect to back-end databases, or help you write scripts for browsers.

*Note: To install extensions that all users have access to in a multiuser operating system, you must be logged in as Administrator (Windows) or root (Mac OS X).*

To find the latest extensions for Dreamweaver, use the
Adobe Exchange

website at www.adobe.com/go/dreamweaver_exchange/. Once there, you can log in and download extensions (many of which are free), join discussion groups, view user ratings and reviews, and install and use the Extension Manager. You must install the Extension Manager before you can install extensions.

The Extension Manager is a separate application that lets you install and manage extensions in Adobe applications. Start the Extension Manager from Dreamweaver by choosing Commands > Manage Extensions.

1 On the Adobe Exchange website, click the download link for an extension.

Your browser might let you choose to open and install it directly from the site or save it to disk.

- If you are opening the extension directly from the site, the Extension Manager handles the installation automatically.
- If you are saving the extension to disk, a good place to save the extension package file (.mxp or .mxi) is the Downloaded Extensions folder within the Dreamweaver application folder on your computer.

4 Double-click the extension package file, or open the Extension Manager and select File > Install Extension. (Some extensions aren’t accessible until you restart the application.

Note: Use the Extension Manager to remove extensions or to see more information about an extension.

More Help topics
“About customizing Dreamweaver in multiuser systems” on page 29
Chapter 3: Working with Dreamweaver sites

A Adobe® Dreamweaver® CS5 site is a collection of all of the files and assets in your website. You can create web pages on your computer, upload them to a web server, and maintain the site by transferring updated files whenever you save them. You can also edit and maintain websites that were created without Dreamweaver.

About Dreamweaver sites

What is a Dreamweaver “site”?
In Dreamweaver the term “site” refers to a local or remote storage location for the documents that belong to a website. A Dreamweaver site provides a way to organize and manage all of your web documents, upload your site to a web server, track and maintain your links, and manage and share files. You should define a site to take full advantage of Dreamweaver features.

Note: To define a Dreamweaver site, you only need to set up a local folder. To transfer files to a web server or to develop web applications, you must also add information for a remote site and testing server.

A Dreamweaver site consists of as many as three parts, or folders, depending on your development environment and the type of website you are developing:

Local root folder Stores the files you’re working on. Dreamweaver refers to this folder as your “local site.” This folder is typically on your local computer, but it can also be on a network server.

Remote folder Stores your files for testing, production, collaboration, and so on. Dreamweaver refers to this folder as your “remote site” in the Files panel. Typically, your remote folder is on the computer where your web server is running. The remote folder holds the files that users access on the Internet.

Together, the local and remote folders enable you to transfer files between your local hard disk and web server, making it easy to manage files in your Dreamweaver sites. You work on files in the local folder, and then publish them to the remote folder when you want other people to view them.

Testing server folder The folder where Dreamweaver processes dynamic pages.

For a tutorial on defining a Dreamweaver site, see www.adobe.com/go/learn_dw_comm08_en.

Understanding local and remote folder structure

When you want to use Dreamweaver to connect to a remote folder, you specify the remote folder in the Servers category of the Site Setup dialog box. The remote folder that you specify (also referred to as the “host directory”) should correspond to the local root folder of your Dreamweaver site. (The local root folder is the top-level folder of your Dreamweaver site.) Remote folders, like local folders, can have any title, but commonly, Internet Service Providers (ISPs) name the top-level remote folders for individual user accounts public_html, pub_html, or something similar. If you are in charge of your own remote server, and can name the remote folder anything you want, it is a good idea for your local root folder and remote folder to have the same name.
The following example shows a sample local root folder on the left and a sample remote folder on the right. The local root folder on the local machine maps directly to the remote folder on the web server, rather than to any of the remote folder’s sub folders, or folders that exist above the remote folder in the directory structure.

Note: The above example illustrates one local root folder on the local machine, and one top-level remote folder on the remote web server. If, however, you are maintaining a number of Dreamweaver sites on your local machine, you would need an equal number of remote folders on the remote server. In such a case the above example would not apply, and you would instead create different remote folders within the public_html folder, and then map them to their corresponding local root folders on your local machine.

When you first establish a remote connection, the remote folder on the web server is usually empty. Then, when you use Dreamweaver to upload all of the files in your local root folder, the remote folder populates with all of your web files. The directory structure of the remote folder and the local root folder should always be the same. (That is, there should always be a one-to-one correspondence between the files and folders in your local root folder, and the files and folders in your remote folder.) If the structure of the remote folder doesn’t match the structure of the local root folder, Dreamweaver uploads files to the wrong place, where they might not be visible to site visitors. Additionally, image and link paths can easily break when folder and file structures are not in synch.

The remote folder must exist before Dreamweaver can connect to it. If you don’t have a designated folder that acts as your remote folder on the web server, create one or ask your ISP’s server administrator to create one for you.

Set up a local version of your site

To set up a local version of your site, all you need to do is specify the local folder where you’ll store all of your site files. The local folder can be on your local computer or on a network server.

1 Identify or create the folder on your computer where you want to store the local version of your site files. (The folder can be anywhere on your computer.) You’ll specify this folder as your local site in Dreamweaver.

2 In Dreamweaver, choose Site > New Site.

3 In the Site Setup dialog box, make sure the Site category is selected. (It should be selected by default.)

4 In the Site Name text box, enter a name for your site. This name appears in the Files panel and in the Manage Sites dialog box; it does not appear in the browser.

5 In the Local Site Folder text box, specify the folder you identified in step one—the folder on your computer where you want to store the local version of your site files. You can click the folder icon to the right of the text box to browse to the folder.

6 Click Save to close the Site Setup dialog box. You can now begin working on your local site files in Dreamweaver.
When you’re ready, you can fill out the other categories in the Site Setup dialog box, including the Servers category, where you can specify a remote folder on your remote server.

For a video tutorial on setting up a new Dreamweaver site, see www.adobe.com/go/learn_dw_comm08_en.

**Connect to a remote server**

Once you’ve specified a local site in Dreamweaver, you can specify a remote server for your site as well. The remote server (often referred to as the web server) is where you publish your site files so that people can view them online. The remote server is simply another computer like your local computer with a collection of files and folders on it. You’ll specify a folder for your site on the remote server, just as you specified a folder for your local site on your local computer.

Dreamweaver refers to the specified remote folder as your *remote site*.

When you set up a remote folder, you must select a connection method for Dreamweaver to upload and download files to and from your web server. The most typical connection method is FTP, but Dreamweaver also supports local/network, FTPS, SFTP, WebDav, and RDS connection methods. If you don’t know which connection method to use, ask your ISP or your server administrator.

*Note:* Dreamweaver also supports connections to IPv6-enabled servers. Supported connection types include FTP, SFTP, WebDav, and RDS. For more information, see [www.ipv6.org/](http://www.ipv6.org/)

**Specify a connection method**

**FTP connections**

Use this setting if you connect to your web server using FTP.

1. Select Site > Manage Sites.
2. Click New to set up a new site, or select an existing Dreamweaver site and click Edit.
3. In the Site Setup dialog box, select the Servers category and do one of the following:
   - Click the Add New Server button to add a new server
   - Select an existing server and click the Edit Existing Server button

The following illustration shows the Basic screen of the Server category with the text fields already populated.
4 In the Server Name text box, specify a name for the new server. The name can be anything of your choosing.

5 Select FTP from the Connect Using pop-up menu.

6 In the FTP Address text box, enter the address of the FTP server to which you upload files for your website. Your FTP address is the full Internet name of a computer system, such as ftp.mindspring.com. Enter the full address without any additional text. In particular, don’t add a protocol name in front of the address.

If you do not know your FTP address, contact your web hosting company.

Note: Port 21 is the default port for receiving FTP connections. You can change the default port number by editing the text box to the right. The result when you save your settings is a colon and the new port number appended to your FTP address (for example, ftp.mindspring.com:29).

7 In the Username and Password text boxes, enter the username and password that you use to connect to the FTP server.

8 Click Test to test your FTP address, username, and password.

Note: You must obtain the FTP address, username and password information from the system administrator for the company hosting your site. No one else has access to this information. Enter the information exactly as your system administrator gives it to you.

9 Dreamweaver saves your password by default. Deselect the Save option if you prefer that Dreamweaver prompt you for a password each time you connect to the remote server.

10 In the Root Directory text box, enter the directory (folder) on the remote server where you store documents that are visible to the public.

If you’re uncertain about what to enter as the root directory, contact the server’s administrator or leave the text box blank. On some servers, your root directory is the same as the directory you first connect to with FTP. To find out, connect to the server. If a folder with a name like public_html, or www, or your user name, appears in the Remote File view in your Files panel, that’s probably the directory you should enter in the Root Directory text box.
In the Web URL text box enter the URL of your website (for example, http://www.mysite.com). Dreamweaver uses the Web URL to create site root-relative links, and to verify links when you use the link checker.

For a more extensive explanation of this option, see “Advanced Settings category” on page 47.

Expand the More Options section if you still need to set more options.

Select Use Passive FTP if your firewall configuration requires use of passive FTP.

Passive FTP enables your local software to set up the FTP connection rather than requesting the remote server to set it up. If you’re not sure whether you use passive FTP, check with your system administrator, or try both checking and unchecking the Use Passive FTP option.

For more information, see TechNote 15220 on the Adobe website at www.adobe.com/go/tn_15220.

Select Use IPv6 Transfer Mode if you are using an IPv6-enabled FTP server.

With the deployment of version 6 of the Internet Protocol (IPv6), EPRT and EPSV have replaced the FTP commands PORT and PASV, respectively. Thus, if you are trying to connect to an IPv6-enabled FTP server, you must use the extended passive (EPSV) and the extended active (EPRT) commands for your data connection.

For more information, see www.ipv6.org/.

Select Use Proxy if you want to specify a proxy host or proxy port.

For more information, click the link to go to the Preferences dialog box, and then click the Help button in the Site category of the Preferences dialog.

Click Save to close the Basic screen. Then in the Servers category, specify whether the server you just added or edited is a remote server, a testing server, or both.

For help with troubleshooting FTP connectivity problems, see TechNote kb405912 on the Adobe website at www.adobe.com/go/kb405912.

SFTP connections

Use Secure FTP (SFTP) if your firewall configuration requires use of secure FTP. SFTP uses encryption and public keys to secure a connection to your testing server.

Note: Your server must be running an SFTP service for you to select this option. If you don’t know whether your server is running SFTP, check with your server administrator.

Select Site > Manage Sites.

Click New to set up a new site, or select an existing Dreamweaver site and click Edit.

In the Site Setup dialog box, select the Servers category and do one of the following:

• Click the Add New Server button to add a new server
• Select an existing server and click the Edit Existing Server button

In the Server Name text box, specify a name for the new server. The name can be anything of your choosing.

Select SFTP from the Connect Using pop-up menu.

The rest of the options are the same as the options for FTP connections. See the above section for more information.

Note: Port 22 is the default port for receiving SFTP connections.
FTPS connections (CS5.5)

FTPS (FTP over SSL) provides both encryption and authentication support as compared to SFTP that offers only encryption support.

When using FTPS for data transfer, you can choose to encrypt your credentials, and also the data being transmitted to the server. In addition, you can choose to authenticate the server’s credentials and connections. The credentials of a server are validated against the current set of trusted CA server certificates in the Dreamweaver database. Certificate Authorities (CAs), which include companies like VeriSign, Thawte, and so on, issue digitally signed server certificates.

Note: This procedure describes options specific to FTPS. For information on regular FTP options, see the previous section.

1. Select Site > Manage Sites.
2. Click New to set up a new site, or select an existing Dreamweaver site and click Edit.
3. In the Site Setup dialog box, select the Servers category and do one of the following:
   - Click the “+” (Add New Server) button to add a new server.
   - Select an existing server and click the Edit Existing Server button.
4. In Server Name, specify a name for the new server.
5. In Connect Using, select one of the following based on your requirement.
   - **FTP over SSL/TLS (Implicit Encryption)** The server terminates the connection if the security request is not received.
   - **FTP over SSL/TLS (Explicit Encryption)** If the client does not request security, the server can choose to proceed with an insecure transaction, or refuse/limit the connection.
6. In Authentication, choose one of the following options:
   - **None** The server’s credentials, signed or self-signed, are displayed. If you accept the server’s credentials, the certificate is added to a certificate store, `trustedSites.db`, in Dreamweaver. When you connect to the same server the next time, Dreamweaver directly connects to the server.
     
     Note: If the credentials of a self-signed certificate have changed on the server, you are prompted to accept the new credentials.
   - **Trusted** The presented certificate is validated with the current set of trusted CA server certificates in the Dreamweaver database. The list of trusted servers is stored in the `cacerts.pem` file.
     
     Note: An error message is displayed if you select Trusted Server, and connect to a server with a self-signed certificate.
7. Expand the More Options section to set more options.
   - **Encrypt Only Command Channel** Select this option if you want to encrypt only the commands that are being transmitted. Use this option when the data being transmitted is already encrypted, or does not contain sensitive information.
   - **Encrypt Only User Name and Password** Select this option if you want to encrypt only your user name and password.
8. Click Save to close the Basic screen. Then in the Servers category, specify whether the server you added or edited is a remote server, a testing server, or both.

For help with troubleshooting FTP connectivity problems, see TechNote kb405912 on the Adobe website at [www.adobe.com/go/kb405912](http://www.adobe.com/go/kb405912).
Local or network connections

Use this setting to connect to a network folder, or if you are storing files or running your testing server on your local computer.

1. Select Site > Manage Sites.
2. Click New to set up a new site, or select an existing Dreamweaver site and click Edit.
3. In the Site Setup dialog box, select the Servers category and do one of the following:
   - Click the Add New Server button to add a new server
   - Select an existing server and click the Edit Existing Server button
4. In the Server Name text box, specify a name for the new server. The name can be anything of your choosing.
5. Select Local/Network from the Connect Using pop-up menu.
6. Click the folder icon beside the Server Folder text box to browse to and select the folder where you store your site files.
7. In the Web URL text box enter the URL of your website (for example, http://www.mysite.com). Dreamweaver uses the Web URL to create site root-relative links, and to verify links when you use the link checker.
   For a more extensive explanation of this option, see “Advanced Settings category” on page 47.
8. Click Save to close the Basic screen. Then in the Servers category, specify whether the server you just added or edited is a remote server, a testing server, or both.

WebDAV connections

Use this setting if you connect to your web server using the Web-based Distributed Authoring and Versioning (WebDAV) protocol.

For this connection method, you must have a server that supports this protocol, such as Microsoft Internet Information Server (IIS) 5.0 or an appropriately configured installation of Apache web server.

Note: If you select WebDAV as your connection method, and you are using Dreamweaver in a multiuser environment, you should also make sure that all of your users select WebDAV as the connection method. If some users select WebDAV, and other users select other connection methods (FTP, for example), Dreamweaver's check-in/check-out feature will not work as expected, since WebDAV uses its own locking system.

1. Select Site > Manage Sites.
2. Click New to set up a new site, or select an existing Dreamweaver site and click Edit.
3. In the Site Setup dialog box, select the Servers category and do one of the following:
   - Click the Add New Server button to add a new server
   - Select an existing server and click the Edit Existing Server button
4. In the Server Name text box, specify a name for the new server. The name can be anything of your choosing.
5. Select WebDAV from the Connect Using pop-up menu.
6. For the URL, enter the complete URL to the directory on the WebDAV server you want to connect to.
   This URL includes the protocol, port, and directory (if not the root directory). For example, http://webdav.mydomain.net/mysite.
7. Enter your username and password.
   This information is for server authentication and is not related to Dreamweaver. If you are not sure of your username and password, check with your system administrator or webmaster.
8. Click Test to test your connection settings.
9. Select the Save option if you want Dreamweaver to remember your password each time you start a new session.
10. In the Web URL text box enter the URL of your website (for example, http://www.mysite.com). Dreamweaver uses the Web URL to create site root-relative links, and to verify links when you use the link checker.

For a more extensive explanation of this option, see “Advanced Settings category” on page 47.

11. Click Save to close the Basic screen. Then in the Servers category, specify whether the server you just added or edited is a remote server, a testing server, or both.

**RDS connections**

Use this setting if you connect to your web server using Remote Development Services (RDS). For this connection method, your remote server must be on a computer running Adobe® ColdFusion®

1. Select Site > Manage Sites.
2. Click New to set up a new site, or select an existing Dreamweaver site and click Edit.
3. In the Site Setup dialog box, select the Servers category and do one of the following:
   - Click the Add New Server button to add a new server
   - Select an existing server and click the Edit Existing Server button
4. In the Server Name text box, specify a name for the new server. The name can be anything of your choosing.
5. Select RDS from the Connect Using pop-up menu.
6. Click the Settings button and provide the following information in the Configure RDS Server dialog box:
   - Enter the name of the host computer where your web server is installed. The host name is probably an IP address or a URL. If you are unsure, ask your administrator.
     - Enter the port number that you connect to.
     - Enter your root remote folder as the host directory.
     - Enter your RDS username and password.
   - Select the Save option if you want Dreamweaver to remember your settings.
7. Click OK to close the Configure RDS Server dialog box.
8. In the Web URL text box enter the URL of your website (for example, http://www.mysite.com). Dreamweaver uses the Web URL to create site root-relative links, and to verify links when you use the link checker.

For a more extensive explanation of this option, see “Advanced Settings category” on page 47.

9. Click Save to close the Basic screen. Then in the Servers category, specify whether the server you just added or edited is a remote server, a testing server, or both.

**Microsoft Visual SourceSafe connections**

Support for Microsoft Visual SourceSafe has been deprecated as of Dreamweaver CS5.
Set Advanced server options
1. Select Site > Manage Sites.
2. Click New to set up a new site, or select an existing Dreamweaver site and click Edit.
3. In the Site Setup dialog box, select the Servers category and do one of the following:
   - Click the Add New Server button to add a new server
   - Select an existing server and click the Edit Existing Server button
4. Specify Basic options as necessary, and then click the Advanced button.
5. Select Maintain Synchronization Information if you want to automatically synchronize your local and remote files. (This option is selected by default.)
6. Select Automatically Upload Files to Server on Save if you want Dreamweaver to upload your file to your remote site when you save the file.
7. Select Enable File Check Out if you want to activate the Check In/Out system.
8. If you are using a Testing server, select a server model from the Server Model pop-up menu. For more information, see “Set up a testing server” on page 45.

Connect to or disconnect from a remote folder with network access
❖ You don’t need to connect to the remote folder; you’re always connected. Click the Refresh button to see your remote files.

Connect to or disconnect from a remote folder with FTP access
❖ In the Files panel:
   - To connect, click Connects to Remote Host in the toolbar.
   - To disconnect, click Disconnect in the toolbar.

Troubleshoot the remote folder setup
The following list provides information on common problems you may encounter in setting up a remote folder, and how to resolve them.

There is also an extensive tech note that specifically provides FTP troubleshooting information on the Adobe website at www.adobe.com/go/kb405978.

❖ The Dreamweaver FTP implementation might not work properly with certain proxy servers, multilevel firewalls, and other forms of indirect server access. If you encounter problems with FTP access, ask your local system administrator for help.
❖ For a Dreamweaver FTP implementation, you must connect to the remote system’s root folder. Be sure to indicate the remote system’s root folder as the host directory. If you’ve specified the host directory using a single slash (/), you might need to specify a relative path from the directory you are connecting to and the remote root folder. For example, if the remote root folder is a higher level directory, you may need to specify a ..../ for the host directory.
❖ Use underscores in place of spaces, and avoid special characters in file and folder names wherever possible. Colons, slashes, periods, and apostrophes in file or folder names can sometimes cause problems.
❖ If you encounter problems with long filenames, rename them with shorter names. On the Mac OS, filenames cannot be more than 31 characters long.
Many servers use symbolic links (UNIX), shortcuts (Windows), or aliases (Macintosh) to connect a folder on one part of the server’s disk with another folder elsewhere. Such aliases usually have no effect on your ability to connect to the appropriate folder or directory; however, if you can connect to one part of the server but not another, there might be an alias discrepancy.

If you encounter an error message such as “cannot put file,” your remote folder may be out of space. For more detailed information, look at the FTP log.

Note: In general, when you encounter a problem with an FTP transfer, examine the FTP log by selecting Window > Results (Windows) or Site > FTP Log (Macintosh), then clicking the FTP Log tag.

Set up a testing server

If you plan to develop dynamic pages, Dreamweaver needs the services of a testing server to generate and display dynamic content while you work. The testing server can be your local computer, a development server, a staging server, or a production server.

For a detailed overview about the purposes of a testing server, see David Powers’s Dreamweaver Developer Center article, Setting up a local testing server in Dreamweaver CS5.

More Help topics
“Choosing an application server” on page 513
“Preparing to build dynamic sites” on page 504

Set up a testing server
1 Select Site > Manage Sites.
2 Click New to set up a new site, or select an existing Dreamweaver site and click Edit.
3 In the Site Setup dialog box, select the Servers category and do one of the following:
   • Click the Add New Server button to add a new server
   • Select an existing server and click the Edit Existing Server button
4 Specify Basic options as necessary, and then click the Advanced button.
   Note: You must specify a Web URL in the Basic screen when specifying a testing server. For more information, see the next section.
5 Under Testing Server, select the server model you want to use for your web application.
   Note: As of Dreamweaver CS5, Dreamweaver no longer installs ASP.NET, ASP JavaScript, or JSP server behaviors. (You can manually re-enable the deprecated server behaviors if you wish, but keep in mind that Dreamweaver no longer officially supports them.) If you’re working on ASP.NET, ASP JavaScript, or JSP pages, however, Dreamweaver will still support Live view, code coloring, and code hinting for those pages. You do not need to select ASP.NET, ASP JavaScript or JSP in the Site Definition dialog box for any of these features to work.
6 Click Save to close the Advanced screen. Then in the Servers category, specify the server you just added or edited as a testing server.
About the Web URL for the testing server

You must specify a Web URL so Dreamweaver can use the services of a testing server to display data and to connect to databases while you work. Dreamweaver uses the design-time connection to provide you with useful information about the database, such as the names of the tables in your database and the names of the columns in your tables.

A Web URL for a testing server comprises the domain name and any of your website’s home directory's subdirectories or virtual directories.

Note: The terminology used in Microsoft IIS may vary from server to server, but the same concepts apply to most web servers.

**The home directory** The folder on the server mapped to your site’s domain name. Suppose the folder you want to use to process dynamic pages is `c:\sites\company\`, and this folder is your home directory (that is, this folder is mapped to your site’s domain name—for example, `www.mystartup.com`). In that case, the URL prefix is `http://www.mystartup.com/`.

If the folder you want to use to process dynamic pages is a subfolder of your home directory, simply add the subfolder to the URL. If your home directory is `c:\sites\company\`, your site’s domain name is `www.mystartup.com`, and the folder you want to use to process dynamic pages is `c:\sites\company\inventory`. Enter the following Web URL:

`http://www.mystartup.com/inventory/`

If the folder you want to use to process dynamic pages is not your home directory or any of its subdirectories, you must create a virtual directory.

**A virtual directory** A folder that is not physically contained in the home directory of the server even though it appears to be in the URL. To create a virtual directory, specify an alias for the folder’s path in the URL. Suppose your home directory is `c:\sites\company`, your processing folder is `d:\apps\inventory`, and you define an alias for this folder called warehouse. Enter the following Web URL:

`http://www.mystartup.com/warehouse/`

**Localhost** Refers to the home directory in your URLs when the client (usually a browser, but in this case Dreamweaver) runs on the same system as your web server. Suppose Dreamweaver is running on the same Windows system as the web server, your home directory is `c:\sites\company`, and you defined a virtual directory called warehouse to refer to the folder you want to use to process dynamic pages. The following are the Web URLs you would enter for selected web servers:

<table>
<thead>
<tr>
<th>Web server</th>
<th>Web URL</th>
</tr>
</thead>
<tbody>
<tr>
<td>ColdFusion MX 7</td>
<td><code>http://localhost:8500/warehouse/</code></td>
</tr>
<tr>
<td>IIS</td>
<td><code>http://localhost/warehouse/</code></td>
</tr>
<tr>
<td>Apache (Windows)</td>
<td><code>http://localhost:80/warehouse/</code></td>
</tr>
<tr>
<td>Jakarta Tomcat (Windows)</td>
<td><code>http://localhost:8080/warehouse/</code></td>
</tr>
</tbody>
</table>

Note: By default the ColdFusion MX 7 web server runs on port 8500, the Apache web server runs on port 80, and the Jakarta Tomcat web server runs on port 8080.

For Macintosh users running the Apache web server, your personal home directory is `Users/MyUserName/Sites`, where MyUserName is your Macintosh user name. An alias called ~MyUserName is automatically defined for this folder when you install Mac OS 10.1 or higher. Therefore, your default Web URL in Dreamweaver is as follows:

`http://localhost/~MyUserName/`
If the folder you want to use to process dynamic pages is Users:MyUserName:Sites:inventory, then the Web URL is as follows:

http://localhost/~MyUserName/inventory/

**Version Control and Advanced settings**

Access the Version Control and Advanced settings categories in the Site Setup dialog box by choosing Site > Manage Sites, selecting the site you want to edit, and clicking Edit.

**Version Control category**

You can get and check in files using Subversion. For more information, see “Use Subversion (SVN) to get and check in files” on page 88.

**Advanced Settings category**

**Local Info**

**Default Images Folder** The folder in which you want to store images for your site. Enter the path to the folder, or click the folder icon to browse to the folder. Dreamweaver uses the path to the folder when you add images to documents.

**Links Relative To** Specifies the kind of links Dreamweaver creates when you create links to other assets or pages in your site. Dreamweaver can create two kinds of links: document-relative and site root-relative. For more information on the differences between the two, see “Absolute, document-relative, and site root-relative paths” on page 261.

By default, Dreamweaver creates document-relative links. If you change the default setting and select the Site Root option, make sure the correct Web URL for the site is entered in the Web URL text box (see below). Changing this setting does not convert the path of existing links; the setting will only apply to new links you create visually with Dreamweaver.

*Note:* Content linked by site-root relative links does not appear when you preview documents in a local browser unless you specify a testing server, or select the Preview Using Temporary File option in Edit > Preferences > Preview In Browser. This is because browsers don’t recognize site roots—servers do.

**Web URL** The URL of your website. Dreamweaver uses the Web URL to create site root-relative links, and to verify links when you use the link checker.

Site root-relative links are useful if you are uncertain about the final location in the directory structure of the page you’re working on, or if you think you might later relocate or reorganize files that contain links. Site root-relative links are links whose paths to other site assets are relative to the site root, not the document, so if you move the document at some point, the path to the assets remains correct.

For example, let’s say that you’ve specified http://www.mysite.com/mycoolsite (the remote server’s site root directory) as the Web URL, and that you also have an images folder in the mycoolsite directory on the remote server (http://www.mysite.com/mycoolsite/images). Let’s also say that your index.html file is in the mycoolsite directory.

When you create a site root-relative link from the index.html file to an image in the images directory, the link looks as follows:

```html
<img src="/mycoolsite/images/image1.jpg" />
```

This is different from a document-relative link, which would simply be:
The appendage of /mycoolsite/ to the image source links the image relative to the site root, not the document. Assuming the image stays in the image directory, the file path to the image (/mycoolsite/images/image1.jpg), will always be correct, even if you move the index.html file to another directory.

For more information, see “Absolute, document-relative, and site root-relative paths” on page 261.

With regard to link verification, the Web URL is necessary for determining whether a link is internal or external to the site. For example, if your web URL is http://www.mysite.com/mycoolsite, and the link checker finds a link with a URL of http://www.yoursite.com on your page, the checker determines that the latter link is an external link and reports it as such. Similarly, the link checker uses the Web URL to determine if links are internal to the site, and then checks to see if those internal links are broken.

**Case-sensitive Links Checking** Checks that the case of the links matches the case of the filenames when Dreamweaver checks links. This option is useful on UNIX systems where filenames are case-sensitive.

**Enable Cache** Indicates whether to create a local cache to improve the speed of link and site management tasks. If you do not select this option, Dreamweaver asks you if you want to create a cache again before it creates the site. It is a good idea to select this option because the Assets panel (in the Files panel group) only works if a cache is created.

**Cloaking and other categories**
For more information on the Cloaking, Design Notes, File View Columns, Contribute, Templates, or Spry categories, click the Help button in the dialog box.

### Manage Sites dialog box options

The Manage Sites dialog box is your gateway into various Dreamweaver site functions. From this dialog box, you can initiate the process for creating a new site, editing an existing site, duplicating a site, removing a site, or importing or exporting a site’s settings.

**Note:** The Manage Sites dialog box does not let you connect to or publish files to a remote server. For instructions on connecting to a remote server, see “Connect to a remote server” on page 38. If you are trying to connect to an existing website, see “Edit an existing remote website” on page 50.

1. Select Site > Manage Sites and select a site from the list on the left.
2. Click a button to select one of the options, make any changes you need to make, and click Done.

**New** Enables you to create a new site. When you click the New button the Site Setup dialog box opens, letting you name and specify the location for your new site. For more information, see “Set up a local version of your site” on page 37.

**Edit** Enables you to edit information such as username, password, and server information for an existing Dreamweaver site. Select the existing site in the site list on the left and click the Edit button to edit the existing site. For more information on editing existing site options, see “Connect to a remote server” on page 38.

**Duplicate** Creates a copy of an existing site. To duplicate a site, select the site in the site list on the left and click the Duplicate button. The duplicated site appears in the site list with the word “copy” appended to the name of the site. To change the name of the duplicated site, leave the site selected and click the Edit button.

**Remove** Deletes the selected site and all of its setup information from your list of Dreamweaver sites; it does not delete the actual site files. (If you want to remove the site files from your computer, you need to do that manually.) To delete a site from Dreamweaver, select the site in the site list and then click the Remove button. You cannot undo this action.
Export/Import Enables you to either export the selected site's settings as an XML file (*.ste), or import a site's settings. For more information, see "Import and export Dreamweaver site settings" on page 49.

Note: The import feature only imports site settings that have previously been exported. It does not import site files to create a new Dreamweaver site. For information on creating a new site in Dreamweaver, see "Set up a local version of your site" on page 37.

More Help topics
"About Dreamweaver sites" on page 36
"Edit an existing remote website" on page 50

Import and export Dreamweaver site settings

You can export your site settings as an XML file that you can later import into Dreamweaver. Exporting/importing sites enables you to transfer site settings to other machines and product versions, share site settings with other users, and back up site settings.

The import/export feature does not import or export site files. It only imports/exports site settings to save you the time of recreating sites in Dreamweaver. For information on creating a new site in Dreamweaver, see "Set up a local version of your site" on page 37.

Export your site settings regularly so that you have a backup copy if anything happens to the site.

More Help topics
"About Dreamweaver sites" on page 36

Backing up and restoring site definitions

Export your site settings

1. Select Site > Manage sites.
2. Select one or more sites whose settings you want to export and click Export:
   - To select more than one site, Control-click (Windows) or Command-click (Macintosh) each site.
   - To select a range of sites, Shift-click the first and last site in the range.
3. If you want to back up your site settings for yourself, select the first option in the Exporting Site dialog box and click OK. Dreamweaver saves remote server login information, such as the user name and password, as well as local path information.
4. If you want to share your settings with other users, select the second option in the Exporting Site dialog box and click OK. (Dreamweaver does not save information that would not work for other users, such as your remote server login information and local paths.)
5. For each site whose settings you want to export, browse to a location where you want to save the site file and click Save. (Dreamweaver saves each site’s settings as an XML file, with an .ste file extension.)
6. Click Done.

Note: Save the *.ste file to your site root folder or to your desktop to make it easy to find. If you cannot remember where you put it, do a file search on your computer for files with the *.ste extension to locate it.
Import site settings
1. Select Site > Manage sites.
2. Click Import.
3. Browse to and select one or more sites—defined in files with an .ste file extension—whose settings you want to import.
To select more than one site, Control-click (Windows) or Command-click (Macintosh) each .ste file. To select a range of sites, Shift-click the first and last file in the range.
4. Click Open and then click Done.
After Dreamweaver imports the site settings, the site names appear in the Manage Sites dialog box.

Edit an existing remote website
You can use Dreamweaver to copy an existing remote site (or any branch of a remote site) to your local disk and edit it there, even if you didn’t use Dreamweaver to create the original site. You must have the correct connection information, and connect to the site’s remote server, before you can edit the site.
1. Create a local folder to contain the existing site and set up the folder as the local folder for the site. (See “Set up a local version of your site” on page 37.)

   Note: You must locally duplicate the entire structure of the relevant branch of the existing remote site.

2. Set up a remote folder, using the remote access information about the existing site. You must connect to the remote site to download the files to your computer before you can edit them. (See “Connect to a remote server” on page 38.)
Make sure to choose the correct root folder for the remote site.
3. In the Files panel (Window > Files), click the Connects To Remote Host button (for FTP access) or the Refresh button (for network access) in the toolbar to view the remote site.
4. Edit the site:
   • If you want to work with the entire site, select the root folder of the remote site in the Files panel, and click Get File(s) in the toolbar to download the entire site to your local disk.
   • If you want to work with just one of the files or folders of the site, locate the file or folder in the Remote view of the Files panel, and click Get File(s) in the toolbar to download that file to your local disk.
Dreamweaver automatically duplicates as much of the remote site’s structure as is necessary to place the downloaded file in the correct part of the site hierarchy. When editing only one part of a site, you should generally include dependent files, such as image files.

More Help topics
“About Dreamweaver sites” on page 36
Editing an existing website (Dreamweaver blog)
Set site preferences for transferring files

You select preferences to control file transfer features that appear in the Files panel.

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).
2. In the Preferences dialog box, select Site from the category list on the left.
3. Set the options and click OK.

**Always Show**  Specifies which site (remote or local) is always shown, and in which Files panel pane (left or right) the local and remote files appear.

By default, the local site always appears on the right. Whichever pane is not chosen (the left one by default) is the changeable pane: this pane can display the files in the other site (the remote site by default).

**Dependent Files**  Displays a prompt for transferring dependent files (such as images, external style sheets, and other files referenced in the HTML file) that the browser loads when it loads the HTML file. By default, both Prompt on Get/Check Out and Prompt on Put/Check In are selected.

It’s usually a good idea to download dependent files when checking out a new file, but if the latest versions of the dependent files are already on the local disk, there’s no need to download them again. This is also true for uploading and checking in files: no need if up-to-date copies are already at the destination.

*If you deselect these options, your dependent files are not transferred. Therefore, to force the Dependent Files dialog box to appear even when these options are deselected, hold down Alt (Windows) or Option (Macintosh) while choosing the Get, Put, Check In, or Check Out commands.*

**FTP Connection**  Determines whether the connection to the remote site is terminated after the specified number of minutes have passed with no activity.

**FTP Time Out**  Specifies the number of seconds in which Dreamweaver attempts to make a connection with the remote server.

If there is no response after the specified amount of time, Dreamweaver displays a warning dialog box alerting you to this fact.

**FTP Transfer options**  Determines whether Dreamweaver selects the default option, after a specified number of seconds, when a dialog box appears during a file transfer and there is no user response.

**Proxy Host**  Specifies the address of the proxy server through which you connect to outside servers if you are behind a firewall.

If you are not behind a firewall, leave this space blank. If you are behind a firewall, select the Use Proxy option in the Site Definition dialog box (Servers > Edit Existing Server (pencil icon) > More Options).

**Proxy Port**  Specifies the port in your proxy or firewall through which you pass to connect to the remote server. If you connect through a port other than 21 (the default for FTP), enter the number here.

**Put Options: Save Files Before Putting**  Indicates that unsaved files are saved automatically before being put onto the remote site.

**Move Options: Prompt Before Moving Files on Server**  Alerts you when you attempt to move files on the remote site.

**Manage Sites**  Opens the Manage Sites dialog box, where you can edit an existing site or create a new one.
Managing Contribute sites

Adobe® Contribute® CS4 combines a web browser with a web-page editor. It enables your colleagues or clients to browse to a page in a site that you created, and to edit or update the page if they have permission to do so. Contribute users can add and update basic web content, including formatted text, images, tables, and links. Contribute site administrators can limit what ordinary (non-administrator) users can do in a site.

Note: This topic assumes that you are a Contribute administrator.

As the site administrator, you give non-administrators the ability to edit pages by creating a connection key and sending it to them (for information on how to do this, see Contribute Help. You can also set up a connection to a Contribute site using Dreamweaver, which lets you or your site designer connect to the Contribute site and use all of the editing capabilities available in Dreamweaver.

Contribute adds functionality to your website with Contribute Publishing Server (CPS), a suite of publishing applications and user management tools that lets you integrate Contribute with your organization’s user directory service—for example, Lightweight Directory Access Protocol (LDAP) or Active Directory. When you enable your Dreamweaver site as a Contribute site, Dreamweaver reads Contribute’s administration settings whenever you connect to the remote site. If Dreamweaver detects that CPS is enabled, it inherits some of the functionality of CPS, such as file rollback and event logging.

You can use Dreamweaver to connect to and modify a file in a Contribute site. Most Dreamweaver capabilities work the same way with a Contribute site as they do with any other site. However, when you use Dreamweaver with a Contribute site, Dreamweaver automatically performs certain file-management operations, such as saving multiple revisions of a document, and logging certain events in the CPS Console.

For more information, see Contribute Help.

Site structure and page design for a Contribute site

To enable Contribute users to edit your website, keep the following points in mind when you structure it:

• Keep your site structure simple. Don’t nest folders too deeply. Group related items together in a folder.

• Set up appropriate read and write permissions for folders on the server.

• Add index pages to folders as you create them, to encourage Contribute users to place new pages in the correct folders. For example, if Contribute users provide pages containing meeting minutes, create a folder in the site root folder named meeting_minutes, and create an index page in that folder. Then provide a link from your site’s main page to the index page for meeting minutes. A Contribute user can then navigate to that index page and create a new page of minutes for a specific meeting, linked from that page.

• On each folder’s index page, provide a list of links to the individual content pages and documents in that folder.

• Keep page designs as simple as possible, minimizing fancy formatting.
• Use CSS rather than HTML tags and name your CSS styles clearly. If the Contribute users use a standard set of styles in Microsoft Word, use the same names for the CSS styles, so that Contribute can map the styles when a user copies information from a Word document and pastes it into a Contribute page.

• To prevent a CSS style from being available to Contribute users, change the name of the style so that the name starts with mmhide_. For example, if you use a style named RightJustified in a page but you don’t want Contribute users to be able to use that style, rename the style to mmhide_RightJustified.

  *Note:* You have to add mmhide_ to the style name in Code view; you cannot add it in the CSS panel.

• Use as few CSS styles as possible, to keep things simple and clean.

• If you use server-side includes for HTML page elements, such as headers or footers, create an unlinked HTML page that contains links to the include files. Contribute users can then bookmark that page and use it to navigate to the include files and edit them.

**More Help topics**

“Creating a Dreamweaver template” on page 382

“Working with server-side includes” on page 325

**File transfer to and from a Contribute site**

Contribute uses a system much like the Dreamweaver Check In/Check Out system to ensure that only one user at a time can edit a given web page. When you enable Contribute compatibility in Dreamweaver, the Dreamweaver Check In/Check Out system is automatically enabled.

To transfer files to and from a Contribute site using Dreamweaver, always use the Check In and Check Out commands. If you instead use the PUT and GET commands to transfer files, you might overwrite the modifications that a Contribute user has recently made to a file.

When you check a file in to a Contribute site, Dreamweaver makes a backup copy of the previous checked-in version of the file in the _baks folder and adds your user name and a date stamp to a Design Notes file.

**More Help topics**

“Checking in and checking out files” on page 85

**Contribute file and folder permissions on the server**

Contribute provides a way to manage file and folder permissions for each user role you define; however, Contribute doesn’t provide a way to manage the underlying read and write permissions assigned to files and folders by the server. In Dreamweaver, you can manage those permissions directly on the server.

If a Contribute user doesn’t have read access on the server to a dependent file, such as an image displayed in a page, the contents of the dependent file don’t appear in the Contribute window. For example, if a user doesn’t have read access to an images folder, the images in that folder appear as broken image icons in Contribute. Similarly, Dreamweaver templates are stored in a subfolder of the site’s root folder, so if a Contribute user doesn’t have read access to the root folder, they can’t use templates in that site unless you copy the templates to an appropriate folder.

When you set up a Dreamweaver site, you must give users read access on the server to the /_mm folder (the _mm subfolder of the root folder), the /Templates folder, and all of the folders containing assets that they will need to use.

If, for security reasons, you can’t give users read access to the /Templates folder, you can still enable Contribute users to access templates. See "Enable Contribute users to access templates without root folder access" on page 57.
For more information about Contribute permissions, see Administering Contribute in Contribute Help.

**Contribute special files**

Contribute uses a variety of special files that aren’t intended to be viewed by visitors to your site:

- The shared settings file, which has an obfuscated filename with a CSI extension, appears in a folder named _mm in the root folder of the site, and contains information that Contribute uses to manage the site
- Older versions of files, in folders named _baks
- Temporary versions of pages, so that users can preview changes
- Temporary lock files, indicating that a given page is being edited or previewed
- Design Notes files containing metadata about the site’s pages

In general, you shouldn’t edit any of these Contribute special files using Dreamweaver; Dreamweaver manages them automatically.

If you don’t want these Contribute special files to appear on your publicly accessible server, you can set up a staging server where Contribute users work on pages. Then periodically copy those web pages from the staging server to a production server that’s on the web. If you take this staging-server approach, copy only web pages to the production server, not any of the above-listed Contribute special files. In particular, don’t copy the _mm and _baks folders to the production server.

**Note:** For information about setting up a server to prevent visitors from seeing files in folders that begin with an underscore, see “Website security” in Contribute Help.

Occasionally you might need to manually delete Contribute special files. For example, there might be circumstances in which Contribute fails to delete temporary preview pages when the user is finished previewing; in that case, you would have to manually delete those temporary pages. Temporary preview pages have filenames that begin with TMP.

Similarly, under some circumstances an outdated lock file may be accidentally left on the server. If that happens, you must manually delete the lock file to allow others to edit the page.

**Prepare a site for use with Contribute**

If you’re preparing an existing Dreamweaver site for Contribute users, you need to explicitly enable Contribute compatibility to use Contribute-related features; Dreamweaver does not prompt you to do this; however, when you connect to a site that’s been set up as a Contribute site (that has an administrator), Dreamweaver prompts you to enable Contribute compatibility.

Not all connection types support Contribute compatibility. The following restrictions apply to connection types:

- If your remote site connection uses WebDAV, you can’t enable Contribute compatibility, because those source-control systems aren’t compatible with the Design Notes and Check In/Check Out systems that Dreamweaver uses for Contribute sites.
- If you use RDS to connect to your remote site, you can enable Contribute compatibility, but you must customize your connection before you can share it with Contribute users.
- If you’re using your local computer as a web server, you must set up the site using an FTP or network connection to your computer (rather than just a local folder path) to be able to share your connection with Contribute users.

When you enable Contribute compatibility, Dreamweaver automatically enables Design Notes (including the Upload Design Notes For Sharing option) and the Check In/Check Out system.
If Contribute Publishing Server (CPS) is enabled on the remote site you are connecting to, Dreamweaver notifies the CPS every time you trigger a network operation such as checking in, rolling back, or publishing a file. The CPS will log these events, and you can view the log in the CPS Administration Console. (If you disable CPS, these events are not logged.) You enable CPS using Contribute. For more information, see Adobe Contribute Help.

**Note:** You can make a site Contribute compatible without having Contribute on your computer; but if you want to be able to start Contribute Administrator from Dreamweaver, you must have Contribute installed on the same computer as Dreamweaver and you must be connected to the remote site before you enable Contribute compatibility. Otherwise, Dreamweaver cannot read Contribute’s administrative settings to determine whether CPS and Rollback are enabled.

**Important:** You must make sure that the shared settings file (CSI file) that Contribute uses to administer the site is on the remote server and uncorrupted. Contribute automatically creates this file (and overwrites old versions of it) whenever you administer in Contribute Administrator. If the shared settings file is not on the server or is corrupted, Dreamweaver returns the error, “The file required for Contribute compatibility does not exist on the server” whenever you attempt a network operation (such as put). To ensure that the correct file is on the server, disable the connection to the server in Dreamweaver, start Contribute Administrator, make an administration change, and then reconnect to the server in Dreamweaver. For more information, see Adobe Contribute Help.

1. Select Site > Manage Sites.
2. Select a site, then click Edit.
3. In the Site Setup dialog box, expand Advanced Settings, select the Contribute category, and then select Enable Contribute Compatibility.
4. If a dialog box appears saying that you must enable Design Notes and Check In/Check Out, click OK.
5. If you haven’t already provided your Check In/Check Out contact information, type your name and e-mail address in the dialog box, and then click OK. Rollback status, CPS status, the Site Root URL text box, and the Administer Site in Contribute button appear in the Site Definition dialog box.
   - If Rollback is enabled in Contribute, you’ll have the ability to roll back to previous versions of files that you’ve changed in Dreamweaver.
6. Check the URL in the Site Root URL text box and correct it if necessary. Dreamweaver constructs a site root URL based on other site-definition information you’ve provided, but sometimes the constructed URL isn’t quite right.
7. Click the Test button to verify that you’ve entered the correct URL.
   - **Note:** If you are ready to send a connection key or perform Contribute site administration tasks now, skip the remaining steps.
8. Click Administer Site in Contribute if you want to make administration changes. Remember, you must have Contribute installed on the same machine if you want to open Contribute Administrator from Dreamweaver.
9. Click Save and then click Done.

**More Help topics**
“Rolling back files (Contribute users)” on page 97

**Administer a Contribute site using Dreamweaver**

After you enable Contribute compatibility, you can use Dreamweaver to start Contribute to perform site administration tasks.

**Note:** Contribute must be installed on the same computer as Dreamweaver.
As an administrator of a Contribute site, you can:

- Change the administrative settings for the site.
  Contribute administrative settings are a collection of settings that apply to all users of your website. These settings enable you to fine-tune Contribute to provide a better user experience.

- Change the permissions granted to user roles in Contribute.

- Set up Contribute users.
  Contribute users need certain information about the site to be able to connect to it. You can package all of this information in a file called a connection key to send to Contribute users.

  **Note:** A connection key is not the same as a Dreamweaver exported site file.

Before you give Contribute users the connection information they need to edit pages, use Dreamweaver to create the basic folder hierarchy for your site, and to create any templates and CSS style sheets needed for the site.

1. Select Site > Manage Sites.
2. Select a site, and then click Edit.
3. In the Site Setup dialog box, expand Advanced Settings and select the Contribute category.
4. Click the Administer Site in Contribute button.

  **Note:** This button does not appear if you have not enabled Contribute compatibility.

5. If prompted, enter the administrator password, and then click OK.

The Administer Website dialog box appears.

- To change administrative settings, select a category from the list on the left, and then change settings as necessary.
- To change role settings, in the Users and Roles category, click Edit Role Settings, and then make changes as necessary.
- To send a connection key to set up users, in the Users and Roles category, click Send Connection Key, and then complete the Connection Wizard.

6. Click Close, click OK, and then click Done.

For more information about administrative settings, managing user roles, or creating a connection key, see Contribute Help.

**More Help topics**

“Import and export Dreamweaver site settings” on page 49

---

**Delete, move, or rename a remote file in a Contribute site**

Deleting a file from the remote server that hosts a Contribute site works much like deleting a file from the server for any Dreamweaver site. However, when you delete a file from a Contribute site, Dreamweaver asks whether to delete all older versions of the file. If you choose to keep the older versions, Dreamweaver saves a copy of the current version in the _baks folder so you can restore it later.

Renaming a remote file or moving it from one folder to another in a Contribute site works the same way it works in any Dreamweaver site. In a Contribute site, Dreamweaver also renames or moves the associated previous versions of the file that are saved in the _baks folder.

1. Select the file in the Remote pane of the Files panel (Window > Files), and then press Backspace (Windows) or Delete (Macintosh).
A dialog box appears asking you to confirm that you want to delete the file.

2 In the confirmation dialog box:

- To delete all previous versions of the file as well as the current version, select the Delete Rollback Versions option.
- To leave previous versions on the server, deselect the Delete Rollback Versions option.

3 Click Yes to delete the file.

Enable Contribute users to access templates without root folder access
In a Contribute site, you manage underlying file and folder permissions directly on the server. If, for security reasons, you can’t give users read access to the /Templates folder, you can still make the templates available to users.

1 Set up the Contribute site so that its root folder is the folder you want users to see as the root.

2 Manually copy the template folder from the main site’s root folder into the Contribute site’s root folder, using the Files panel.

3 After you update templates for the main site, recopy the changed templates into appropriate subfolders as needed.

If you take this approach, don’t use site root-relative links in the subfolders. Site root-relative links are relative to the main root folder on the server, not to the root folder you define in Dreamweaver. Contribute users can’t create site root-relative links.

If links in a Contribute page appear to be broken, it’s possible that there’s a problem with folder permissions, particularly if the links link to pages outside of the Contribute user’s root folder. Check read and write permissions for folders on the server.

More Help topics
“Absolute, document-relative, and site root-relative paths” on page 261

Troubleshoot a Contribute site
If a remote file in a Contribute site appears to be checked out, but the file isn’t actually locked on the user’s computer, you can unlock the file to enable users to edit it.

When you click any button related to Contribute site administration, Dreamweaver verifies that it can connect to your remote site and that the Site Root URL you’ve given for the site is valid. If Dreamweaver can’t connect, or if the URL isn’t valid, an error message appears.

If the administration tools aren’t working properly, there might be something wrong with the _mm folder.

Unlock a file in a Contribute site
Note: Before following this procedure, make sure that the file really isn’t checked out. If you unlock a file while a Contribute user is editing it, multiple users might edit the file simultaneously.

1 Do one of the following:

- Open the file in the Document window, and then select Site > Undo Check Out.
- In the Files panel (Window > Files), right-click (Windows) or Control-click (Macintosh), and then select Undo Check Out.

A dialog box might appear, indicating who has the file checked out and asking you to confirm that you want to unlock the file.

2 If the dialog box appears, click Yes to confirm.
The file is unlocked on the server.

**Troubleshoot connection problems for a Contribute site**

1. Check the Site Root URL in the Contribute category of the Site Definition dialog box by opening that URL in a browser, to make sure that the correct page opens.

2. Use the Test button in the Remote Info category of the Site Definition dialog box to make sure that you can connect to the site.

3. If the URL is correct but the Test button results in an error message, ask your system administrator for help.

**Troubleshoot Contribute administration tools**

1. On the server, make sure that you have read and write permissions, and executable permissions if necessary, for the _mm folder.

2. Make sure that the _mm folder contains a shared settings file with a CSI extension.

3. If it doesn’t, use the Connection Wizard (Windows) or Connection Assistant (Macintosh) to create a connection to the site and to become an administrator for the site. The shared settings file is created automatically when you become an administrator. For more information about becoming an administrator for an existing Contribute website, see *Administering Contribute* in Contribute Help.
Chapter 4: Creating and Managing Files

Creating and opening documents

About creating Dreamweaver documents
Dreamweaver offers a flexible environment for working with a variety of web documents. In addition to HTML documents, you can create and open a variety of text-based documents, including ColdFusion Markup Language (CFML), ASP, JavaScript, and Cascading Style Sheets (CSS). Source code files, such as Visual Basic, .NET, C#, and Java, are also supported.

Dreamweaver provides several options for creating a new document. You can create any of the following:

- A new blank document or template
- A document based on one of the predesigned page layouts that comes with Dreamweaver, including over 30 CSS-based page layouts
- A document based on one of your existing templates

You can also set document preferences. For example, if you typically work with one type of document, you can set it as the default document type for new pages you create.

You can easily define document properties, such as meta tags, document title, and background colors, and several other page properties in either Design view or Code view.

Dreamweaver file types
You can work with a variety of file types in Dreamweaver. The primary kind of file you will work with is the HTML file. HTML files—or Hypertext Markup Language files—contain the tag-based language responsible for displaying a web page in a browser. You can save HTML files with either the .html or .htm extension. Dreamweaver saves files using the .html extension by default.

Dreamweaver lets you create and edit HTML5-based web pages. Starter layouts are also available for building HTML5 pages from scratch.

Following are some of the other common file types you might use when working in Dreamweaver:

CSS  Cascading Style Sheet files have a .css extension. They are used to format HTML content and control the positioning of various page elements.

GIF  Graphics Interchange Format files have a .gif extension. GIF format is a popular web graphic format for cartoons, logos, graphics with transparent areas, and animations. GIFs contain a maximum of 256 colors.

JPEG  Joint Photographic Experts Group files (named after the organization that created the format) have a .jpg extension, and are usually photographs or high-color images. The JPEG format is best for digital or scanned photographs, images using textures, images with gradient color transitions, and any images that require more than 256 colors.

XML  Extensible Markup Language files have a .xml extension. They contain data in a raw form that can be formatted using XSL (Extensible Stylesheet Language).
**XSL**  Extensible Stylesheet Language files have a .xsl or .xslt extension. They are used to style XML data that you want to display on a web page.

**CFML**  ColdFusion Markup Language files have a .cfm extension. They are used to process dynamic pages.

**PHP**  Hypertext Preprocessor files have a .php extension and are used to process dynamic pages.

**More Help topics**

“Displaying XML data with XSLT” on page 477

“Building applications visually” on page 583

“Understanding Cascading Style Sheets” on page 118

**Create a blank page**

You can create a page that contains a predesigned CSS layout, or create a completely blank page and then create a layout of your own.

1. Select File > New.

2. In the Blank Page category of the New Document dialog box, select the kind of page you want to create from the Page Type column. For example, select HTML to create a plain HTML page, select ColdFusion to create a ColdFusion page, and so on.

3. If you want your new page to contain a CSS layout, select a predesigned CSS layout from the Layout column; otherwise, select None. Based on your selection, a preview and description of the selected layout appears on the right side of the dialog box.

The predesigned CSS layouts provide the following types of columns:

**Fixed**  Column width is specified in pixels. The column does not resize based on the size of the browser or the site visitor’s text settings.

**Liquid**  Column width is specified as a percentage of the site visitor’s browser width. The design adapts if the site visitor makes the browser wider or narrower, but does not change based on the site visitor’s text settings.

Dreamweaver also offers two HTML5 CSS layouts: two- and three-column fixed.

4. Select a document type from the DocType pop-up menu. In most cases, you can use the default selection, XHTML 1.0 Transitional.

Selecting one of the XHTML document type definitions from the DocType (DTD) menu makes your page XHTML-compliant. For example, you can make an HTML document XHTML-compliant by selecting XHTML 1.0 Transitional or XHTML 1.0 Strict from the menu. XHTML (Extensible Hypertext Markup Language) is a reformulation of HTML as an XML application. Generally, using XHTML gives you the benefits of XML, while ensuring the backward and future compatibility of your web documents.

**Note:** For more information about XHTML, see the World Wide Web Consortium (W3C) website, which contains the specification for XHTML 1.1 - Module-Based XHTML (www.w3.org/TR/xhtml11/) and XHTML 1.0 (www.w3c.org/TR/xhtml1/), as well as XHTML validator sites for web-based files (http://validator.w3.org/) and local files (http://validator.w3.org/file-upload.html).

Dreamweaver also offers HTML5 as a doctype option.

5. If you selected a CSS layout in the Layout column, select a location for the layout’s CSS from the Layout CSS pop-up menu.

**Add To Head**  Adds CSS for the layout to the head of the page you’re creating.
Create New File  Adds CSS for the layout to a new external CSS file and attaches the new style sheet to the page you’re creating.

Link To Existing File  Lets you specify an existing CSS file that already contains the CSS rules needed for the layout. To do this, click the Attach Style Sheet icon above the Attach CSS file pane and select an existing CSS style sheet. This option is particularly useful when you want to use the same CSS layout (the CSS rules for which are contained in a single file) across multiple documents.

(Optional) You can also attach CSS style sheets to your new page (unrelated to the CSS layout) when you create the page. To do this, click the Attach Style Sheet icon above the Attach CSS file pane and select a CSS style sheet.

For a detailed walk-through of this process, see David Powers’s article, Automatically attaching a style sheet to new documents.

Select Enable InContext Editing if you want to create a page that becomes InContext Editing-enabled as soon as you save it.

An InContext Editing-enabled page must have at least one \texttt{div} tag that can be specified as an editable region. For example, if you’ve selected the HTML page type, you must select one of the CSS layouts for your new page, since these layouts already contain pre-defined \texttt{div} tags. The InContext Editing editable region is automatically placed on the \texttt{div} tag with the \texttt{content} ID. You can later add more editable regions to the page if you like.

Click Preferences if you want to set default document preferences, such as a document type, encoding, and a file extension.

Click Get More Content if you want to open Dreamweaver Exchange where you can download more page design content.

Click the Create button.

Save the new document (File > Save).

In the dialog box that appears, navigate to the folder where you want to save the file.

It’s a good idea to save your file in a Dreamweaver site.

In the File Name box, type a name for the file.

Avoid using spaces and special characters in file and folder names, and do not begin a filename with a numeral. In particular, do not use special characters (such as é, ç, or ¥) or punctuation marks (such as colons, slashes, or periods) in the names of files you intend to put on a remote server; many servers change these characters during upload, which will cause any links to the files to break.

More Help topics

“XHTML code” on page 282

“Laying out pages with CSS” on page 146

“Set default document type and encoding” on page 66

“Business Catalyst InContext Editing” on page 471

Create a blank template

You can use the New Document dialog box to create Dreamweaver templates. By default, templates are saved in the Templates folder of your site.

Select File > New.
2 In the New Document dialog box, select the Blank Template category.

3 Select the kind of page you want to create from the Template Type column. For example, select HTML template to create a plain HTML template, select ColdFusion template to create a ColdFusion template, and so on.

4 If you want your new page to contain a CSS layout, select a predesigned CSS layout from the Layout column; otherwise, select None. Based on your selection, a preview and description of the selected layout appears on the right side of the dialog box.

The predesigned CSS layouts provide the following types of columns:

**Fixed** Column width is specified in pixels. The column does not resize based on the size of the browser or the site visitor’s text settings.

**Liquid** Column width is specified as a percentage of the site visitor’s browser width. The design adapts if the site visitor makes the browser wider or narrower, but does not change based on the site visitor’s text settings.

5 Select a document type from the DocType pop-up menu. In most cases, you will want to leave this selected to the default selection, XHTML 1.0 Transitional.

Selecting one of the XHTML document type definitions from the DocType (DTD) menu makes your page XHTML-compliant. For example, you can make an HTML document XHTML-compliant by selecting XHTML 1.0 Transitional or XHTML 1.0 Strict from the menu. XHTML (Extensible Hypertext Markup Language) is a reformulation of HTML as an XML application. Generally, using XHTML gives you the benefits of XML, while ensuring the backward and future compatibility of your web documents.

**Note:** For more information about XHTML, see the World Wide Web Consortium (W3C) website, which contains the specification for XHTML 1.1 - Module-Based XHTML ([www.w3.org/TR/xhtml11/](http://www.w3.org/TR/xhtml11/)) and XHTML 1.0 ([www.w3c.org/TR/xhtml1/](http://www.w3c.org/TR/xhtml1/)), as well as XHTML validator sites for web-based files ([http://validator.w3.org/](http://validator.w3.org/)) and local files ([http://validator.w3.org/file-upload.html](http://validator.w3.org/file-upload.html)).

6 If you selected a CSS layout in the Layout column, select a location for the layout’s CSS from the Layout CSS pop-up menu.

**Add to Head** Adds CSS for the layout to the head of the page you’re creating.

**Create New File** Adds CSS for the layout to a new external CSS styles sheet and attaches the new style sheet to the page you’re creating.

**Link To Existing File** Lets you specify an existing CSS file that already contains the CSS rules needed for the layout. To do this, click the Attach Style Sheet icon above the Attach CSS file pane and select an existing CSS style sheet. This option is particularly useful when you want to use the same CSS layout (the CSS rules for which are contained in a single file) across multiple documents.

7 (Optional) You can also attach CSS style sheets to your new page (unrelated to the CSS layout) when you create the page. To do this, click the Attach Style Sheet icon above the Attach CSS file pane and select a CSS style sheet.

8 Select Enable InContext Editing if you want to create a page that becomes InContext Editing-enabled as soon as you save it.

An InContext Editing-enabled page must have at least one **div** tag that can be specified as an editable region. For example, if you’ve selected the HTML page type, you must select one of the CSS layouts for your new page, since these layouts already contain pre-defined **div** tags. The InContext Editing editable region is automatically placed on the **div** tag with the *content* ID. You can later add more editable regions to the page if you like.

9 Click Preferences if you want to set default document preferences, such as a document type, encoding, and a file extension.

10 Click Get More Content if you want to open Dreamweaver Exchange where you can download more page design content.
11 Click the Create button.

12 Save the new document (File > Save). If you haven’t added editable regions to the template yet, a dialog box appears telling you that there are no editable regions in the document. Click OK to close the dialog box.

13 In the

14 Save As

15 dialog box, select a site in which to save the template.

16 In the File Name box, type a name for the new template. You do not need to append a file extension to the name of the template. When you click Save, the .dwt extension is appended to the new template, which is saved in the Templates folder of your site.

Avoid using spaces and special characters in file and folder names and do not begin a filename with a numeral. In particular, do not use special characters (such as é, ç, or ¥) or punctuation (such as colons, slashes, or periods) in the names of files you intend to put on a remote server; many servers change these characters during upload, which will cause any links to the files to break.

More Help topics
“XHTML code” on page 282
“Laying out pages with CSS” on page 146
“Creating and managing templates” on page 374
“Working with Dreamweaver sites” on page 36
“Set default document type and encoding” on page 66
“Business Catalyst InContext Editing” on page 471

Create a page based on an existing template
You can select, preview, and create a new document from an existing template. You can either use the New Document dialog box to select a template from any of your Dreamweaver-defined sites or use the Assets panel to create a new document from an existing template.

More Help topics
“Creating and managing templates” on page 374
“Working with Dreamweaver sites” on page 36
“Set default document type and encoding” on page 66

Create a document based on a template
1 Select File > New.

2 In the New Document dialog box, select the Page From Template category.

3 In the Site column, select the Dreamweaver site that contains the template you want use, and then select a template from the list on the right.

4 Deselect Update Page When Template Changes if you don’t want to update this page each time you make changes to the template on which this page is based.

5 Click Preferences if you want to set default document preferences, such as a document type, encoding, and a file extension.
6 Click Get More Content if you want to open Dreamweaver Exchange where you can download more page design content.

7 Click Create and save the document (File > Save).

**Create a document from a template in the Assets panel**
1 Open the Assets panel (Window > Assets), if it is not already open.
2 In the Assets panel, click the Templates icon on the left to view the list of templates in your current site.

   *If you just created the template you want to apply, you might need to click the Refresh button to see it.*

3 Right-click (Windows) or Control-click (Macintosh) the template you want to apply, then select New From Template.
   The document opens in the Document window.
4 Save the document.

**Create a page based on a Dreamweaver sample file**
Dreamweaver comes with several professionally developed frame page layout and CSS design files. You can use these sample files as starting points for designing pages in your sites. When you create a document based on a sample file, Dreamweaver creates a copy of the file.

You can preview a sample file and read a brief description of a document’s design elements in the New Document dialog box. In the case of CSS style sheets, you can copy a predesigned style sheet and apply it to your documents.

*Note: If you create a document based on a predefined frameset, only the frameset structure is copied, not the frame contents; additionally, you must save each frame file separately.*

1 Select File > New.
2 In the New Document dialog box, select the Page From Sample category.
3 In the Sample Folder column, select CSS Style Sheet or Frameset; then select a sample file from the list on the right.
4 Click the Create button.
   The new document opens in the Document window (Code and Design views). If you selected CSS Style Sheet, the CSS style sheet opens in Code view.
5 Save the document (File > Save).
6 If the Copy Dependent Files dialog box appears, set the options, and then click Copy to copy the assets to the selected folder.

You can choose your own location for the dependent files or use the default folder location Dreamweaver generates (based on the sample file’s source name).

**More Help topics**
“Understanding Cascading Style Sheets” on page 118
“Save frame and frameset files” on page 192

Last updated 12/7/2011
Create other kinds of pages
The Other category of the New Document dialog box lets you create various types of pages that you might want to use in Dreamweaver, including C#, VBScript, and text-only pages.

1. Select File > New.
2. In the New Document dialog box, select the Other category.
3. Select the kind of document you want to create from the Page Type column and click the Create button.
4. Save the document (File > Save).

Save and revert documents
You can save a document using its current name and location, or save a copy of a document using a different name and location.

When naming files, avoid using spaces and special characters in file and folder names. In particular, do not use special characters (such as é, ç, or ¥) or punctuation (such as colons, slashes, or periods) in the names of files you intend to put on a remote server; many servers change these characters during upload, which will cause any links to the files to break. Also, do not begin a filename with a numeral.

More Help topics
“Create a blank page” on page 60

Save a document
1. Do one of the following:
   • To overwrite the current version on the disk, and save any changes you have made, select File > Save.
   • To save the file in a different folder or using a different name, select File > Save As.
      • In the dialog box that appears, navigate to the folder where you want to save the file.
   • In the File Name text box, type a name for the file.
      • Click Save to save the file.

Save all open documents
1. Select File > Save All.
2. If there are any unsaved documents open, the Save As dialog box is displayed for each unsaved document.
3. In the dialog box that appears, navigate to the folder where you want to save the file.
4. In the File Name box, type a name for the file and click Save.
Revert to the last saved version of a document

1. Select File > Revert.

A dialog box asks if you want to discard your changes, and revert to the previously saved version.

2. Click Yes to revert to the previous version; click No to keep your changes.

Note: If you save a document, and then exit Dreamweaver, you cannot revert to the previous version of the document when you restart Dreamweaver.

Set default document type and encoding

You can define which document type is used as a default document for a site.

For example, if most pages in your site are of a specific file type (such as Cold Fusion, HTML, or ASP documents), you can set document preferences that automatically create new documents of the specified file type.

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).

   You can also click the Preferences button in the New Document dialog box to set new document preferences when you create a new document.

2. Click New Document from the category list on the left.

3. Set or change preferences as necessary, and click OK to save them.

Default Document  Select a document type that will be used for pages that you create.

Default Extension  Specify the file extension you prefer (.htm or .html) for new HTML pages you create.

Note: This option is disabled for other file types.

Default Document Type (DDT)  Select one of the XHTML document type definitions (DTD) to make new pages XHTML-compliant. For example, you can make an HTML document XHTML-compliant by selecting XHTML 1.0 Transitional or XHTML 1.0 Strict from the menu.

Default Encoding  Specify the encoding to be used when a new page is created, as well as when a document is opened that does not specify any encoding.

If you select Unicode (UTF-8) as the document encoding, entity encoding is not necessary because UTF-8 can safely represent all characters. If you select another document encoding, entity encoding may be necessary to represent certain characters. For more information on character entities, see www.w3.org/TR/REC-html40/sgml/entities.html.

If you select Unicode (UTF-8) as a default encoding, you can include a Byte Order Mark (BOM) in the document by selecting the Include Unicode Signature (BOM) option.

A BOM is 2-4 bytes at the beginning of a text file that identifies a file as Unicode, as well as the byte order of the following bytes. Because UTF-8 has no byte order, adding a UTF-8 BOM is optional. For UTF-16 and UTF-32, it is required.

Unicode Normalization Form  Select one of these options if you select Unicode (UTF-8) as a default encoding.

There are four Unicode Normalization Forms. The most important is Normalization Form C because it’s the most common one used in the Character Model for the World Wide Web. Adobe provides the other three Unicode Normalization Forms for completeness.

Show New Document Dialog Box on Control+N  Deselect this option (“on Command+N” for Macintosh) to automatically create a document of the default document type when you use the key command.
In Unicode, there are characters that are visually similar but can be stored within the document in different ways. For example, “ë” (e-umlaut) can be represented as a single character, “e-umlaut,” or as two characters, “regular Latin e” + “combining umlaut.” A Unicode combining character is one that gets used with the previous character, so the umlaut would appear above the “Latin e.” Both forms result in the same visual typography, but what is saved in the file is different for each form.

Normalization is the process of making sure all characters that can be saved in different forms are all saved using the same form. That is, all “ë” characters in a document are saved as single “e-umlaut” or as “e” + “combining umlaut,” and not as both forms in one document.

For more information on Unicode Normalization and the specific forms that can be used, see the Unicode website at www.unicode.org/reports/tr15.

More Help topics
“XHTML code” on page 282
“Understanding document encoding” on page 204

Converting HTML5 to an older doctype
Using File > Convert to switch from HTML5 to an older DOCTYPE doesn’t remove HTML5 elements or attributes. Only the DOCTYPE changes, and trailing slashes (for XHTML) are inserted.

Semantic tags, such as `<header>` and `<article>`, and attributes such as `required`, `placeholder`, and `type="number"` are not affected.

Set the default file extension of new HTML documents
You can define the default file extension of HTML documents created in Dreamweaver. For example, you can use an .htm or .html extension for all new HTML documents.

1 Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).

💡 You can also click the Preferences button in the New Document dialog box to set new document preferences when you create a new document.

2 Click New Document from the category list on the left.

3 Make sure that HTML is selected in the Default Document pop-up menu.

4 In the Default Extension box, specify the file extension you want for new HTML documents created in Dreamweaver.

For Windows, you can specify the following extensions: .html, .htm, .shtml, .shtm, .stm, .tpl, .lasso, .xhtml.

For Macintosh, you can specify the following extensions: .html, .htm, .shtml, .shtm, .tpl, .lasso, .xhtml, .ssi.

Open and edit existing documents
You can open an existing web page or text-based document, whether or not it was created in Dreamweaver, and edit it in either Design view or Code view.

If the document you open is a Microsoft Word file that was saved as an HTML document, you can use the Cleanup Word HTML command to remove the extraneous markup tags that Word inserts into HTML files.

To clean up HTML or XHTML that was not generated by Microsoft Word, use the Cleanup HTML command.
You can also open non-HTML text files, such as JavaScript files, XML files, CSS style sheets, or text files saved by word processors or text editors.

1. Select File > Open.

You can also use the Files panel to open files.

2. Navigate to and select the file you want to open.

**Note:** If you haven’t already done so, it’s a good idea to organize files you plan to open and edit in a Dreamweaver site, instead of opening them from another location.

3. Click Open.

The document opens in the Document window. JavaScript, text, and CSS Style Sheets open in Code view by default. You can update the document while working in Dreamweaver, and save the changes in the file.

**More Help topics**

“Clean up code” on page 310

“Start an external editor for media files” on page 248

“Work with files in the Files panel” on page 75

**Open Related Files**

Dreamweaver lets you view files related to your main document, without losing the main document’s focus. For example, if you have CSS and JavaScript files attached to a main document, Dreamweaver lets you view and edit these related files in the Document window while keeping the main document visible.

**Note:** Dynamically Related Files (such as PHP files in Content Management Systems) are covered in the next Help section.

By default, Dreamweaver displays the names of all files related to a main document in a Related Files toolbar below the main document’s title. The order of the buttons in the toolbar follows the order of related files links that exist within the main document.

**Note:** If a related file is missing, Dreamweaver still displays the corresponding button in the Related Files toolbar. If you click the button, however, Dreamweaver does not display anything.

Dreamweaver supports the following kinds of related files:

- Client-side script files
- Server Side Includes
- Spry data set sources (XML and HTML)
- External CSS style sheets (including nested style sheets)

For a video overview from the Dreamweaver engineering team about working with related files, see [www.adobe.com/go/dw10relatedfiles](http://www.adobe.com/go/dw10relatedfiles).

For a video tutorial on working with Live View, related files, and the Code Navigator, see [www.adobe.com/go/lrvid4044_dw](http://www.adobe.com/go/lrvid4044_dw).
Open a related file from the Related Files toolbar

Do one of the following:

- In the Related Files toolbar at the top of the document, click the filename of the related file you want to open.
- In the Related Files toolbar, right-click the filename of the related file you want to open and select Open as Separate File from the context menu. When you open a related file by this method, the main document does not remain simultaneously visible.

Open a related file from the Code navigator

1. Place the insertion point on a line or in an area that you know is affected by a related file.
2. Wait for the Code Navigator indicator to appear, and then click it to open the Code Navigator.
3. Hover over the items in the Code Navigator to see more information about them. For example, if you want to change a particular CSS color property, but don’t know which rule it resides in, you can find the property by hovering over the available rules in the Code Navigator.
4. Click the item you’re interested in to open the corresponding related file.

Return to the source code of the main document

❖ Click the Source Code button in the Related Files toolbar.

Change the display of related files

You can view related files in a number of ways:

- When you open a related file from Design view or Code and Design views (Split view), the related file displays in a split view above the Design view of the main document.
  
  You can select View > Design View on Top if you want the related file to display at the bottom of the Document window instead.

- When you open a related file from vertically split Code and Design views (View > Split vertically), the related file displays in a split view alongside the Design view of the main document.
  
  You can select or deselect Design View on Left (View > Design View on Left), depending on where you want the Design view.

- When you open a related file from Split Code view or Vertical Split Code view (View > Split Code view, and View > Split vertically), the related file displays in a split view beneath, above, or alongside the source code for the main document, depending on the options you have selected.
  
  The “code view” in the display option refers to the source code of the main document. For example, if you select View > Code View on Top, Dreamweaver displays the source code of the main document in the top half of the Document window. If you select View > Code View on Left, Dreamweaver displays the source code of the main document on the left side of the Document window.

- Standard Code view does not let you display related Documents at the same time as the main document’s source code.

Disable related files

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).
2. In the General category, deselect Enable Related Files.
More Help topics
“Switch between views in the Document window” on page 17
“Navigate to related code” on page 302
“Previewing pages in Dreamweaver” on page 276
Related files tutorial

Open Dynamically-Related Files
The Dynamically-Related Files feature extends the functionality of the Related Files feature by allowing you to see the related files of dynamic pages in the Related Files toolbar. Specifically, the Dynamically-Related Files feature lets you see the numerous dynamic includes that are required to generate the runtime code for popular open-source PHP Content Management System (CMS) frameworks such as WordPress, Drupal and Joomla!

To use the Dynamically-Related Files feature, you must have access to a local or remote PHP application server running WordPress, Drupal, or Joomla!. One common approach for testing pages is to set up a localhost PHP application server, and test the pages locally.

Before you test pages, you'll need to perform the following steps:

• Set up a Dreamweaver site and make sure that you have filled out the Web URL text box the Site Setup dialog box.
• Set up a PHP application server.
  Important: The server must be running before you attempt to work with Dynamically-Related Files in Dreamweaver.
• Install WordPress, Drupal, or Joomla! on the application server. For more information, see:
  • WordPress Installation
  • Drupal Installation
  • Joomla Installation
• In Dreamweaver, define a local folder where you'll download and edit your CMS files.
• Define the location of the installed WordPress, Drupal, or Joomla! files as your remote and testing folder.
• Download (Get) your CMS files from the remote folder.

More Help topics
www.adobe.com/go/dwcs5drf_en

Set Dynamically-Related Files preferences
When you open a page that is associated with Dynamically-Related Files, Dreamweaver can discover the files automatically, or let you discover the files manually (which you do by clicking a link in the Info bar above the page). The default setting is manual discovery.

1 Choose Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh OS).
2 In the General category, make sure the Enable Related Files option is selected.
3 Select Manually or Automatically from the Dynamically-Related Files pop-up menu. You can also disable the discovery entirely by selecting Disabled.
Discover Dynamically-Related Files
1 Open a page that has Dynamically-Related Files associated with it—for example, the site root index.php page of a WordPress, Drupal, or Joomla! site.
2 If the discovery of Dynamically-Related Files is set to manual (the default), click the Discover link in the Info bar that appears above the page in the Document window.
   If the discovery of Dynamically-Related Files is automatically enabled, then a list of Dynamically-Related Files appears in the Related Files toolbar.

The order of Related and Dynamically-Related Files in the Related Files toolbar is as follows:
• Static related files (i.e. related files that do not require any sort of dynamic processing)
• External related files (i.e. .css and .js files) that are attached to dynamic path server include files
• Dynamic path server include files (i.e. .php, .inc, and .module files)

Filter Related Files
Because Related Files and Dynamically-Related Files can often be numerous, Dreamweaver lets you filter Related Files so that you can precisely locate the files you want to work with.
1 Open a page that has Related Files associated with it.
2 Discover Dynamically-Related Files if necessary.
3 Click the Filter Related Files icon at the right side of the Related Files toolbar.
4 Select the types of files you want to see in the Related Files toolbar. By default, Dreamweaver selects all Related Files.
5 To create a custom filter, click the Filter Related Files icon and choose Custom Filter.
   The Custom Filter dialog only allows for the filtering of exact file names (style.css), file extensions (.php), and wildcard expressions using asterisks (*menu*). You can filter on multiple wildcard expressions by separating each expression with a semi-colon (for example, style.css;*.js;*tpl.php).

Note: Filter settings do not persist once you close the file.

Clean up Microsoft Word HTML files
You can open documents saved by Microsoft Word as HTML files, and then use the Clean Up Word HTML command to remove the extraneous HTML code generated by Word. The Clean Up Word HTML command is available for documents saved as HTML files by Word 97 or later.

The code that Dreamweaver removes is primarily used by Word to format and display documents in Word and is not needed to display the HTML file. Retain a copy of your original Word (.doc) file as a backup, because you may not be able to reopen the HTML document in Word once you've applied the Clean Up Word HTML feature.

To clean up HTML or XHTML that was not generated by Microsoft Word, use the Cleanup HTML command.
1 Save your Microsoft Word document as an HTML file.
Note: In Windows, close the file in Word to avoid a sharing violation.
2 Open the HTML file in Dreamweaver.
To view the HTML code generated by Word, switch to Code view (View > Code).
3 Select Commands > Clean Up Word HTML.
Note: If Dreamweaver is unable to determine which version of Word was used to save the file, select the correct version from the pop-up menu.
4 Select (or deselect) options for the cleanup. The preferences you enter are saved as default cleanup settings. Dreamweaver applies the cleanup settings to the HTML document and a log of the changes appears (unless you deselected that option in the dialog box).

**Remove All Word Specific Markup** Removes all Microsoft Word-specific HTML, including XML from HTML tags, Word custom metadata and link tags in the head of the document, Word XML markup, conditional tags and their contents, and empty paragraphs and margins from styles. You can select each of these options individually using the Detailed tab.

**Clean Up CSS** Removes all Word-specific CSS, including inline CSS styles when possible (where the parent style has the same style properties), style attributes beginning with “mso,” non-CSS style declarations, CSS style attributes from tables, and all unused style definitions from the head. You can further customize this option using the Detailed tab.

**Clean Up <font> Tags** Removes HTML tags, converting the default body text to size 2 HTML text.

**Fix Invalidly Nested Tags** Removes the font markup tags inserted by Word outside the paragraph and heading (block-level) tags.

**Apply Source Formatting** Applies the source formatting options you specify in HTML Format preferences and SourceFormat.txt to the document.

**Show Log On Completion** Displays an alert box with details about the changes made to the document as soon as the cleanup is finished.

5 Click OK, or click the Detailed tab if you want to further customize the Remove All Word Specific Markup and Clean Up CSS options, and then click OK.

More Help topics
“Clean up code” on page 310
“Import Microsoft Office documents (Windows only)” on page 221

Managing files and folders

**About managing files and folders**
Dreamweaver includes a Files panel that helps you manage and transfer files to and from a remote server. When you transfer files between local and remote sites, parallel file and folder structures between the sites are maintained. When transferring files between sites, Dreamweaver creates corresponding folders if they do not yet exist in a site. You can also synchronize the files between your local and remote sites; Dreamweaver copies files in both directions as necessary and removes unwanted files when appropriate.

**Using the Files panel**
The Files panel enables you to view files and folders, whether they are associated with a Dreamweaver site or not, and perform standard file maintenance operations, such as opening and moving files.

*Note: In previous versions of Dreamweaver the Files panel was called the Site panel.*

You can move the Files panel as necessary and set preferences for the panel.

Use this panel to perform the following tasks:

- Access sites, a server, and local drives
• View files and folders
• Manage files and folders in the Files panel

For Dreamweaver sites, use the following options to display or transfer files:

Expanded Files panel options.
A. Site pop-up menu  B. Connect/Disconnect  C. Refresh  D. View site FTP log  E. Site files view  F. Testing server  G. Repository view  H. Get File(s)  I. Put File(s)  J. Check Out File(s)  K. Check In File(s)  L. Synchronize  M. Expand/Collapse

**Note:** The Site Files view, Testing Server view, and Synchronize buttons appear only in the expanded Files panel.

**The Site pop-up menu** Lets you select a Dreamweaver site and display that site’s files. You can also use the Site menu to access all the files on your local disk, much like

Windows Explorer

(Windows) or the Finder (Macintosh).

**Connect/Disconnect** (FTP, RDS, and WebDAV protocol) Connects to or disconnects from the remote site. By default, Dreamweaver disconnects from the remote site if it has been idle for more than 30 minutes (FTP only). To change the time limit, select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh), then select Site from the category list on the left.

**Refresh** Refreshes the local and remote directory lists. Use this button to manually refresh the directory lists if you deselected either Refresh Local File List Automatically or Refresh Remote File List Automatically in the Site Definition dialog box.

**Site Files view** Displays the file structure of the remote and local sites in the panes of the Files panel. (A preference setting determines which site appears in the left pane and which appears in the right pane.) Site Files view is the default view for the Files panel.

**Testing Server view** Displays the directory structure of the testing server and the local site.

**Repository view** Displays the Subversion (SVN) Repository.

**Get File(s)** Copies the selected files from the remote site to your local site (overwriting the existing local copy of the file, if any). If Enable File Check In And Check Out is enabled, the local copies are read-only; the files remain available on the remote site for other team members to check out. If Enable File Check In and Check Out is disabled, the file copies will have both read and write privileges.

**Note:** The files Dreamweaver copies are the files you select in the active pane of the Files panel. If the Remote pane is active, the selected remote or testing server files are copied to the local site; if the Local pane is active, Dreamweaver copies the remote or testing server version of the selected local files to the local site.

**Put File(s)** Copies the selected files from the local site to the remote site.

**Note:** The files Dreamweaver copies are the files you select in the active pane of the Files panel. If the Local pane is active, the selected local files are copied to the remote site or testing server; if the Remote pane is active, Dreamweaver copies the local versions of the selected remote server files to the remote site.

If you are putting a file that doesn’t already exist on the remote site, and Enable File Check In and Out is enabled, the file is added to the remote site as "checked out." Click the Check In Files button if you want to add a file without the checked out status.
Check Out File(s)  Transfers a copy of the file from the remote server to your local site (overwriting the existing local copy of the file, if any) and marks the file as checked out on the server. This option is not available if Enable File Check In and Check Out in the Site Definitions dialog box is disabled for the current site.

Check In File(s)  Transfers a copy of the local file to the remote server and makes the file available for editing by others. The local file becomes read-only. This option is not available if the Enable File Check In and Check Out option in the Site Definitions dialog box is disabled for the current site.

Synchronize  Synchronizes the files between the local and remote folders.

The Expand/Collapse button  Expands or collapses the Files panel to display one or two panes.

More Help topics
“Files panel overview” on page 15  
“Working with Dreamweaver sites” on page 36  
“Check files into and out of a remote folder” on page 86  
“Put files on a remote server” on page 83  
“Get files from a remote server” on page 81  
“Synchronizing files” on page 93

View files and folders
You can view files and folders in the Files panel, whether they are associated with a Dreamweaver site or not. When you view sites, files, or folders in the Files panel, you can change the size of the viewing area, and, for Dreamweaver sites, you can expand or collapse the Files panel.

For Dreamweaver sites, you can also customize the Files panel by changing the view—either your local or remote site—that appears by default in the collapsed panel. Or, you can switch the content views in the expanded Files panel using the Always Show option.

Open or close the Files panel
❖  Select Window > Files.

Expand or collapse the Files panel (Dreamweaver sites only)
❖  In the Files panel (Window > Files), click the Expand/Collapse button in the toolbar.

Note: If you click the Expand/Collapse button to expand the panel while it is docked, the panel maximizes so that you cannot work in the Document window. To return to the Document window, click the Expand/Collapse button again to collapse the panel. If you click the Expand/Collapse button to expand the panel while it is not docked, you can still work in the Document window. Before you can dock the panel again, you must first collapse it.

When the Files panel is collapsed it displays the contents of the local site, the remote site, or the testing server as a list of files. When expanded, it displays the local site and either the remote site or testing server.

Change the size of the view area in the expanded Files panel
❖  In the Files panel (Window > Files), with the panel expanded, do one of the following:
•  Drag the bar that separates the two views to increase or decrease the view area of the right or left pane.
•  Use the scroll bars at the bottom of the Files panel to scroll through the views' contents.
Change the site view in Files panel (Dreamweaver sites only)

❖ Do one of the following:

• In the collapsed Files panel (Window > Files), select Local View, Remote View, Testing Server, or Repository View from the Site View pop-up menu.

**Note:** Local View appears in the Site View menu by default.

• In the expanded Files panel (Window > Files), click the Site Files button (for the remote site), the Testing Server button, or the Repository Files button.

![Files Panel](image)

A. Site Files  B. Testing Server  C. Repository Files

**Note:** Before you can view a remote site, testing server or repository, you must set up a remote site, testing server, or SVN repository.

View files outside of a Dreamweaver site

❖ Navigate your computer using the Site pop-up menu, much as you would if you were using

❖ Windows Explorer

❖ (Windows) or the Finder (Macintosh).

Work with files in the Files panel

You can open or rename files; add, move, or delete files; or refresh the Files panel after you make changes.

For Dreamweaver sites, you can also determine which files (on either the local or remote site) have been updated since the last time they were transferred.

More Help topics

“Synchronizing files” on page 93

“Access sites, a server, and local drives” on page 78

Open a file

1 In the Files panel (Window > Files), select a site, server, or drive from the pop-up menu (where the current site, server, or drive appears).

2 Navigate to the file you want to open.

3 Do one of the following:

• Double-click the file's icon.

• Right-click (Windows) or Control-click (Macintosh) the file's icon, then select Open.

Dreamweaver opens the file in the Document window.
Create a file or folder
1 In the Files panel (Window > Files), select a file or folder.
Dreamweaver will create the new file or folder inside the currently selected folder, or in the same folder as the currently selected file.
2 Right-click (Windows) or Control-click (Macintosh), then select New File or New Folder.
3 Enter a name for the new file or folder.
4 Press Enter (Windows) or Return (Macintosh).

Delete a file or folder
1 In the Files panel (Window > Files), select the file or folder you want to delete.
2 Right-click (Windows) or Control-click (Macintosh), then select Edit > Delete.

Rename a file or folder
1 In the Files panel (Window > Files), select the file or folder you want to rename.
2 Do one of the following to activate the name of the file or folder:
   • Click in the filename, pause, then click again.
   • Right-click (Windows) or Control-click (Macintosh) the file’s icon, then select Edit > Rename.
3 Type the new name over the existing name.
4 Press Enter (Windows) or Return (Macintosh).

Move a file or folder
1 In the Files panel (Window > Files), select the file or folder you want to move.
2 Do one of the following:
   • Copy the file or folder, then paste it in a new location.
   • Drag the file or folder to a new location.
3 Refresh the Files panel to see the file or folder in its new location.

Refresh the Files panel
❖ Do one of the following:
   • Right-click (Windows) or Control-click (Macintosh) any file or folder, then select Refresh.
   • (Dreamweaver sites only) Click the Refresh button in the Files panel toolbar (this option refreshes both panes).

Note: Dreamweaver refreshes the Files panel when you make changes in another application, then return to Dreamweaver.

Find files in your Dreamweaver site
Dreamweaver makes it easy to find selected, open, checked out, or recently modified files in your site. You can also find files that are newer in your local or remote site.

More Help topics
“Use reports to test your site” on page 104
### Find an open file in your site

1. Open the file in the Document window.
2. Select Site > Locate in Site.

Dreamweaver selects the file in the Files panel.

*Note: If the open file in the Document window is not part of the current site in the Files panel, Dreamweaver attempts to determine which of your Dreamweaver sites the file belongs to; if the current file belongs to only one local site, Dreamweaver opens that site in the Files panel, then highlights the file.*

### Locate and select checked out files in a Dreamweaver site

- In the collapsed Files panel (Window > Files), click the Options menu in the upper-right corner of the Files panel, then select Edit > Select Checked Out Files.

Dreamweaver selects the files in the Files panel.

### Find a selected file in your local or remote site

1. Select the file in the Local or Remote view of the Files panel (Window > Files).
2. Right-click (Windows) or Control-click (Macintosh), then select Locate in Local Site or Locate in Local Site (depending on where you selected the file).

Dreamweaver selects the file in the Files panel.

### Locate and select files that are newer in the local site than in the remote site

- In the collapsed Files panel (Window > Files), click the Options menu in the upper-right corner of the Files panel, then select Edit > Select Newer Local.

Dreamweaver selects the files in the Files panel.

### Locate and select files that are newer in the remote site than in the local site

- In the collapsed Files panel (Window > Files), click the Options menu in the upper-right corner of the Files panel, then select Edit > Select Newer Remote.

Dreamweaver selects the files in the Files panel.

### Find recently modified files in your site

1. In the collapsed Files panel (Window > Files), click the Options menu in the upper-right corner of the Files panel, and then select Edit > Select Recently Modified.
2. Do one of the following to indicate search dates for the report:
   - To report on all files modified in the last several days, select Files Created or Modified in the Last and enter a number in the box.
   - To report on all files modified within a specific time frame, click the Files Created or Modified in the Between radio button, then specify a date range.
3. (Optional) Enter a user name in the Modified By box to limit your search to files modified by a specific user between the dates you indicated.

*Note: This option is only available for reports on Contribute sites.*
4  Select a radio button to indicate where you want to view files listed in the report, if necessary:

Local Machine  if the site contains static pages.

Testing Server  if the site contains dynamic pages.

**Note:** This option assumes you defined a Testing Server in the Site Definition dialog box (XREF). If you have not defined a Testing Server and entered a URL prefix for that server, or if you are running the report for more than one site, this option is not available.

Other Location  if you want to enter a path in the text box.

5  Click OK to save your settings.

Dreamweaver highlights the files that were modified within the selected time frame in the Files panel.

**Identify and delete unused files**

You can identify and delete files that are no longer used by other files in your site.

1  Select Site > Check Links Sitewide.

Dreamweaver checks all the links in your site and displays the broken ones in the Results panel.

2  Select Orphaned Files from the menu on the Link Checker panel.

Dreamweaver displays all the files with no incoming links. This means that no files in your site link to these files.

3  Select the files you want to delete and press Delete.

**Important:** Although no other file in the site links to these files, some of the listed files may link to other files. Use caution when deleting the files.

**More Help topics**

“Enable and disable site cloaking” on page 98

**Access sites, a server, and local drives**

You can access, modify, and save files and folders in your Dreamweaver sites, as well as files and folders that are not part of a Dreamweaver site. In addition to Dreamweaver sites, you can access a server, a local drive, or your desktop.

Before you can access a remote server, you must set up Dreamweaver to work with that server.

**Note:** The best way to manage your files is to create a Dreamweaver site.

**Open an existing Dreamweaver site**

❖  In the Files panel (Window > Files), select a site from the menu (where the current site, server, or drive appears).
Open a folder on a remote FTP or RDS server
1. In the Files panel (Window > Files), select a server name from the menu (where the current site, server, or drive appears).

Note: Server names appear for servers you've configured Dreamweaver to work with.

2. Navigate to and edit files as you normally do.

Access a local drive or your desktop
1. In the Files panel (Window > Files), select Desktop, Local Disk, or CD Drive from the menu (where the current site, server, or drive appears).

2. Navigate to a file, then do any of the following:
   - Open files in Dreamweaver or another application
   - Rename files
   - Copy files
   - Delete files
   - Drag files

When you drag a file from one Dreamweaver site to another or to a folder that is not part of a Dreamweaver site, Dreamweaver copies the file to the location where you drop it. If you drag a file within the same Dreamweaver site, Dreamweaver moves the file to the location where you drop it. If you drag a file that is not part of a Dreamweaver site to a folder that is not part of a Dreamweaver site, Dreamweaver moves the file to the location where you drop it.

Note: To move a file that Dreamweaver copies by default, hold down the Shift key (Windows) or the Command key (Macintosh) while you drag. To copy a file that Dreamweaver moves by default, hold the Control key (Windows) or the Option key (Macintosh) while you drag.

Customize the file and folder details displayed in the expanded Files panel
When you view a Dreamweaver site in the expanded Files panel, information about the files and folders is displayed in columns. For example, you can see the file type or the date a file was modified.

You can customize the columns by doing any of the following (some operations are only available for columns you add, not default columns):

- Reorder or realign columns
- Add new columns (for a maximum of 10 columns)
- Hide columns (except the filename column)
- Designate columns to be shared with all users connected to a site
• Delete columns (custom columns only)
• Rename columns (custom columns only)
• Associate columns with a Design Note (custom columns only)

Change the order of the columns
❖ Select a column name, and then click the up or down arrow button to change the position of the selected column.

*Note:* You can change the order of any column except Name, which is always the first column.

Add, delete, or change detail columns
1 Select Site > Manage Sites.
2 Select a site, then click Edit.
3 Expand Advanced Settings and select the File View Columns category.
4 Select a column and click the Plus (+) button to add a column, or the Minus (–) button to delete a column.

*Note:* The column is deleted immediately and without confirmation, so make certain that you want to delete the column before clicking the Minus (–) button.
5 In the Column Name box, enter a name for your column.
6 Select a value from the Associate with Design Notes menu, or type in your own.

*Note:* You must associate a new column with a Design Note, so that there is data to display in the Files panel.
7 Select an alignment to determine how text is aligned within the column.
8 Select or deselect Show to reveal or hide the column.
9 Select Share with All Users of This Site to share the column with all users connected to the remote site.

Sort by any detail column in the Files panel
❖ Click the heading for the column you want to sort.

Click the heading again to reverse the order (ascending or descending) by which Dreamweaver sorts the column.

Getting and putting files to and from your server

File transfer and dependent files
If you’re working in a collaborative environment, use the Check In/Check Out system to transfer files between local and remote sites. If you’re the only person working on the remote site, however, you can use the Get and Put commands to transfer files without checking them in or out.

When you transfer a document between a local and remote folder using the Files panel, you have the option of transferring the document’s dependent files. Dependent files are images, external style sheets, and other files referenced in your document that a browser loads when it loads the document.

*Note:* It’s usually a good idea to download dependent files when checking out a new file, but if the latest versions of the dependent files are already on the local disk, there’s no need to download them again. This is also true for uploading and checking in files: no need if up-to-date copies are already at the remote site.
Library items are treated as dependent files.

Some servers report errors when putting library items. However, you can cloak these files to prevent them from being transferred.

**More Help topics**
“Checking in and checking out files” on page 85
“Enable and disable site cloaking” on page 98

**About background file transfers**
You can perform other, non-server-related, activities while you’re getting or putting files. Background file transfer works for all of the transfer protocols supported by Dreamweaver: FTP, SFTP, LAN, WebDAV, Subversion, and RDS.

Non-server-related activities include common operations like typing, editing external style sheets, generating site-wide reports, and creating new sites.

Server-related activities that Dreamweaver cannot perform during file transfers include the following:

- Put/Get/Check in/Check out files
- Undo check-out
- Create a database connection
- Bind dynamic data
- Preview data in Live view
- Insert a web service
- Delete remote files or folders
- Preview in a browser on a testing server
- Save a file to a remote server
- Insert an image from a remote server
- Open a file from a remote server
- Auto put files upon saving
- Drag files to the remote site
- Cut, copy, or paste files on the remote site
- Refresh Remote view

By default, the Background File Activity dialog box is open during file transfers. You can minimize the dialog box by clicking the Minimize button in the upper right corner. Closing the dialog box during file transfers results in a cancelation of the operation.

**Get files from a remote server**
Use the Get command to copy files from the remote site to your local site. You can use the Files panel or the Document window to get files.

Dreamweaver creates a log of file activity during the transfer that you can view and save.

**Note:** You cannot turn background file transfer off. If you have the detail log open in the Background File Activity dialog box, you can close that to improve performance.
Dreamweaver also records all FTP file transfer activity. If an error occurs when you are transferring a file using FTP, the Site FTP log can help you determine the problem.

More Help topics
“Checking in and checking out files” on page 85
“Synchronizing files” on page 93

Get files from a remote server using the Files panel
1 In the Files panel (Window > Files), select the desired files to download.

Usually you select these files in the Remote view, but you can select the corresponding files in the Local view if you prefer. If the Remote view is active, then Dreamweaver copies the selected files to the local site; if the Local view is active, then Dreamweaver copies the remote versions of the selected local files to the local site.

Note: To get only those files for which the remote version is more recent than the local version, use the Synchronize command.

2 Do one of the following to get the file:
   • Click the Get button in the Files panel toolbar.
   • Right-click (Windows) or Control-click (Macintosh) the file in the Files panel, then select Get from the context menu.

3 Click Yes in the Dependent Files dialog box to download dependent files; if you already have local copies of the dependent files, click No. The default is to not download dependent files. You can set this option at Edit > Preferences > Site.

Dreamweaver downloads the selected files, as follows:
   • If you’re using the Check In/Check Out system, getting a file results in a read-only local copy of the file; the file remains available on the remote site or testing server for other team members to check out.
   • If you’re not using the Check In/Check Out system, getting a file results in a copy that has both read and write privileges.

   Note: If you’re working in a collaborative environment—that is, if others are working on the same files—you should not disable Enable File Check In and Check Out. If other people are using the Check In/Check Out system with the site, you should use that system as well.

To stop the file transfer at any time, click the Cancel button in the Background File Activity dialog box.

Get files from a remote server using the Document window
1 Make sure the document is active in the Document window.

2 Do one of the following to get the file:
   • Select Site > Get.
   • Click the File Management icon in the Document window toolbar, then select Get from the menu.

Note: If the current file is not part of the current site in the Files panel, Dreamweaver attempts to determine which locally defined site the current file belongs to. If the current file belongs to only one local site, Dreamweaver opens that site, then performs the Get operation.

Display the FTP log
1 Click the Options menu in the upper right corner of the Files panel.

2 Select View > Site FTP Log.
Note: In the Expanded Files Panel, you can click the FTP Log button to display the log.

Put files on a remote server

You can put files from the local site to the remote site, generally without changing the file's checked out status.

There are two common situations in which you might use the Put command instead of Check In:

- You’re not in a collaborative environment and you aren’t using the Check In/Check Out system.
- You want to put the current version of the file on the server but you’re going to keep editing it.

Note: If you put a file that didn’t previously exist on the remote site and you’re using the Check In/Check Out system, the file is copied to the remote site and is then checked out to you so that you can continue editing.

You can use the Files panel or the Document window to put files. Dreamweaver creates a log of file activity during the transfer that you can view and save.

Note: You cannot turn background file transfer off. If you have the detail log open in the Background File Activity dialog box, you can close that to improve performance.

Dreamweaver also records all FTP file transfer activity. If an error occurs when you are transferring a file using FTP, the Site FTP log can help you determine the problem.

For a tutorial on putting files on a remote server, see www.adobe.com/go/vid0163.

For a tutorial on troubleshooting publishing problems, see www.adobe.com/go/vid0164.

More Help topics
“Synchronizing files” on page 93
“About the Check In/Check Out system” on page 85
Putting files tutorial
Troubleshoot publishing problems tutorial

Put files on a remote or testing server using the Files panel

1 In the Files panel (Window > Files), select the files to upload.

Usually you select these in the Local view, but you may select the corresponding files in the Remote view if you prefer.

Note: You can put only those files for which the local version is more recent than the remote version.

2 Do one of the following to put the file on the remote server:

- Click the Put button in the Files panel toolbar.
- Right-click (Windows) or Control-click (Macintosh) the file in the Files panel, then select Put from the context menu.

3 If the file hasn’t been saved, a dialog box appears (if you set this preference in the Site category of the Preferences dialog box) allowing you to save the file before putting it on the remote server. Click Yes to save the file or No to put the previously saved version on the remote server.

Note: If you do not save the file, any changes you’ve made since the last time you saved will not be put onto the remote server. However, the file remains open, so you can still save the changes after putting the file on the server if you want.

4 Click Yes to upload dependent files along with the selected files, or click No to refrain from uploading dependent files. The default is to not upload dependent files. You can set this option at Edit > Preferences > Site.
Note: It's usually a good idea to upload dependent files when checking in a new file, but if the latest versions of the dependent files are already on the remote server, there's no need to upload them again.

To stop the file transfer at any time, click the Cancel button in the Background File Activity dialog box.

**Put files on a remote server using the Document window**

1. Make sure the document is active in the Document window.
2. Do one of the following to put the file:
   - Select Site > Put.
   - Click the File Management icon in the Document window toolbar, then select Put from the menu.

Note: If the current file is not part of the current site in the Files panel, Dreamweaver attempts to determine which locally defined site the current file belongs to. If the current file belongs to only one local site, Dreamweaver opens that site, then performs the Put operation.

**Display the FTP log**

1. Click the Options menu in the upper right corner of the Files panel.
2. Select View > Site FTP Log.

Note: In the Expanded Files Panel, you can click the FTP Log button to display the log.

**Manage file transfers**

You can view the status of file transfer operations, as well as a list of transferred files and their outcomes (transfer successful, skipped, or failed). You can also save a log of the file activity.

Note: Dreamweaver lets you perform other non-server-related activities while you’re transferring files to or from a server.

**Cancel a file transfer**

- Click the Cancel button in the Background File Activity dialog box. If the dialog box isn’t showing, click the File Activity button at the bottom of the Files panel.

**Show the Background File Activity dialog box during transfers**

- Click the File Activity or Log button at the bottom of the Files panel.

Note: You cannot hide or remove the Log button. It’s a permanent part of the panel.

**View details of the last file transfer**

1. Click the Log button at the bottom of the Files panel to open the Background File Activity dialog box.
2. Click the Details expander arrow.

**Save a log of the last file transfer**

1. Click the Log button at the bottom of the Files panel to open the Background File Activity dialog box.
2. Click the Save Log button and save the information as a text file.

You can review the file activity by opening the log file in Dreamweaver or in any text editor.
Checking in and checking out files

About the Check In/Check Out system

If you’re working in a collaborative environment, you can check files in and out from local and remote servers. If you’re the only person working on the remote server, you can use the Put and Get commands without checking files in or out.

Note: You can use Get and Put functionality with a testing server, but you cannot use the Check In/Check Out system with a testing server.

Checking out a file is the equivalent of declaring “I’m working on this file now—don’t touch it!” When a file is checked out, the name of the person who checked out the file is displayed in the Files panel, along with a red check mark (if a team member checked out the file) or green check mark (if you checked out the file) next to the file’s icon.

Checking in a file makes the file available for other team members to check out and edit. When you check in a file after editing it, your local version becomes read-only and a lock symbol appears beside the file in the Files panel to prevent you from making changes to the file.

Dreamweaver does not make checked-out files read-only on the remote server. If you transfer files with an application other than Dreamweaver, you can overwrite checked-out files. However, in applications other than Dreamweaver, the LCK file is visible next to the checked-out file in the file hierarchy to help prevent such accidents.

More Help topics

“Getting and putting files to and from your server” on page 80

Set up the Check In/Check Out system

Before you can use the Check In/Check Out system, you must associate your local site with a remote server.

1 Select Site > Manage Sites.
2 Select a site and click Edit.
3 In the Site Setup dialog box, select the Servers category and do one of the following:
   • Click the Add New Server button to add a new server
   • Select an existing server and click the Edit Existing Server button
4 Specify Basic options as necessary, and then click the Advanced button.
5 Select Enable File Check Out if you are working in a team environment (or working alone but from several different machines). Deselect this option if you want to disable file check in and check out for your website.

This option is useful to let others know that you checked out a file for editing, or to alert yourself that you may have left a more recent version of a file on another machine.

If you do not see Check In/Out options, it means that you have not set up a remote server.

6 Select the Check Out Files when Opening option if you want to automatically check out files when you double-click to open them from the Files panel.

Using File > Open to open a file doesn’t check the file out even when this option is selected.

7 Set the remaining options:

Check Out Name The check-out name appears in the Files panel alongside any files that are checked out; this enables team members to communicate with the right person if a file they need is checked out.
Note: If you work alone from several different machines, use a different check-out name on each machine (for example, AmyR-HomeMac and AmyR-OfficePC) so you’ll know where the latest version of the file is if you forget to check it in.

**Email Address**  If you enter an e-mail address, when you check out a file, your name appears in the Files panel as a link (blue and underlined) next to that file. If a team member clicks on the link, their default e-mail program opens a new message with the user’s e-mail address and a subject that corresponds to the file and site name.

### Check files into and out of a remote folder

After you set up the Check In/Check Out system, you can check in and check out files on a remote server using the Files panel or from the Document window.

#### Check out files using the Files panel

1. In the Files panel (Window > Files), select files to check out from the remote server.

**Note:** You can select files in the Local or Remote view, not the Testing Server view.

A red check mark indicates that another team member has the file checked out and a lock symbol indicates that the file is read-only (Windows) or locked (Macintosh).

2. Do one of the following to check out the file(s):
   - Click the Check Out button in the Files panel toolbar.
   - Right-click (Windows) or Control-click (Macintosh), then select Check Out from the context menu.

3. In the Dependent Files dialog box, click Yes to download dependent files along with the selected files, or click No to refrain from downloading dependent files. The default is to not download dependent files. You can set this option at Edit > Preferences > Site.

**Note:** It's usually a good idea to download dependent files when checking out a new file, but if the latest versions of the dependent files are already on the local disk, there's no need to download them again.

A green check mark appears beside the local file’s icon indicating that you have checked it out.

**Important:** If you check out the currently active file, the currently open version of the file is overwritten by the new checked-out version.

#### Check in files using the Files panel

1. In the Files panel (Window > Files), select checked-out or new file(s).

**Note:** You can select files in the Local or Remote view, but not the Testing Server view.

2. Do one of the following to check in the file(s):
   - Click the Check In button in the Files panel toolbar.
   - Right-click (Windows) or Control-click (Macintosh), then select Check In from the context menu.

3. Click Yes to upload dependent files along with the selected files, or click No to refrain from uploading dependent files. The default is to not upload dependent files. You can set this option at Edit > Preferences > Site.

**Note:** It’s usually a good idea to upload dependent files when checking in a new file, but if the latest versions of the dependent files are already on the remote server, there’s no need to upload them again.

A lock symbol appears beside the local file’s icon indicating that the file is now read-only.

**Important:** If you check in the currently active file, the file may be automatically saved before it’s checked in, depending on the preference options you’ve set.

Last updated 12/7/2011
Check in an open file from the Document window

1. Make sure the file you want to check in is open in the Document window.

   **Note:** You can check in only one open file at a time.

2. Do one of the following:
   - Select Site > Check In.
   - Click the File Management icon in the Document window toolbar, then select Check In from the menu.

   If the current file is not part of the active site in the Files panel, Dreamweaver attempts to determine which locally defined site the current file belongs to. If the current file belongs to a site other than the one that’s active in the Files panel, Dreamweaver opens that site, then performs the check in operation.

   **Important:** If you check in the currently active file, the file may be automatically saved before it's checked in, depending on the preference options you’ve set.

Undo a file check-out

If you check out a file, then decide not to edit it (or decide to discard the changes you made), you can undo the check-out operation and the file returns to its original state.

To undo a file check-out, do one of the following:

- Open the file in the Document window, then select Site > Undo Check Out.
- In the Files panel (Window > Files), right-click (Windows) or Control-click (Macintosh), then select Undo Check Out.

   The local copy of the file becomes read-only, and any changes you’ve made to it are lost.

Use WebDAV to check in and check out files

Dreamweaver can connect to a server that uses WebDAV (Web-based Distributed Authoring and Versioning), which is a set of extensions to the HTTP protocol that allow users to collaboratively edit and manage files on remote web servers. For more information, see [www.webdav.org](http://www.webdav.org).

1. If you have not already done so, define a Dreamweaver site that specifies the local folder you use to store your project files.

2. Select Site > Manage Sites, and then double-click your site in the list.

3. In the Site Setup dialog box, select the Servers category and do one of the following:
   - Click the Add New Server button to add a new server
   - Select an existing server and click the Edit Existing Server button

4. In the Basic screen, select WebDAV from the Connect Using pop-up menu, and complete the rest of the Basic screen options, as necessary.

5. Click the Advanced button.

6. Select the Enable File Check Out option and enter the following information:
   - In the Check Out Name box, enter a name identifying you to other team members.
   - In the Email Address box, enter your e-mail address.

   The name and e-mail addresses are used to identify ownership on the WebDAV server and appear in the Files panel for contact purposes.

7. Click Save.
Dreamweaver configures the site for WebDAV access. When you use the Check In or Check Out command on any site file, the file is transferred using WebDAV.

**Note:** WebDAV may be unable to properly check out any files with dynamic content like PHP tags or SSIs because the HTTP GET renders these as they are checked out.

### Use Subversion (SVN) to get and check in files

Dreamweaver can connect to a server that uses Subversion (SVN), a versioning control system that lets users collaboratively edit and manage files on remote web servers. Dreamweaver is not a full SVN client, but does let users get the latest versions of files, make changes, and commit the files.

**Important:** Dreamweaver CS5 uses the Subversion 1.6.6 client library, and Dreamweaver CS5.5 uses the 1.6.9 client library. Later versions of the Subversion client library are not backward-compatible. Be aware, if you update a third-party client application (for example, TortoiseSVN) to work with a later version of Subversion, the updated Subversion application will update local Subversion meta data, and Dreamweaver will no longer be able to communicate with Subversion. This issue is not affected by updates to the Subversion server as those updates are backward-compatible. If you do upgrade to a third-party client application that works with Subversion 1.7 or later, you’ll need to check with Adobe for updates before you can use Subversion with Dreamweaver again. For more information on this issue, see [www.adobe.com/go/dw_svn_en](http://www.adobe.com/go/dw_svn_en).

Adobe recommends that you use a third-party file comparison tool as you work with SVN version-controlled files. When you compare files for differences, you can learn exactly what kinds of changes other users made to the files. For more information on file comparison tools, use a web search engine such as Google Search to search for “file comparison” or “diff” tools. Dreamweaver works with most third-party tools.

For a video overview of working with SVN and Dreamweaver, see [www.adobe.com/go/lrvid4049_dw](http://www.adobe.com/go/lrvid4049_dw).

### Set up an SVN connection

Before you use Subversion (SVN) as a version control system with Dreamweaver, you must set up a connection to an SVN server. You set up a connection to an SVN server in the Version Control category of the Site Definition dialog box.

The SVN server is a repository of files from which you and other users can get and commit files. It is different from the remote server you typically use with Dreamweaver. When using SVN, the remote server remains the “live” server for your web pages, and the SVN server exists to hold the repository of files over which you want to maintain version control. The typical workflow is to get and commit files back and forth between the SVN server, and then publish them to your remote server from Dreamweaver. The remote server setup is completely separate from the SVN set up.

You must have access to an SVN server and an SVN repository before you begin this set up. For more information about SVN, see the Subversion website at [http://subversion.apache.org/](http://subversion.apache.org/).

To set up the SVN connection, follow these steps:

1. Choose Sites > Manage Sites, select the site you want to set up version control for, and click the Edit button.

   **Note:** If you haven’t already set up local and remote folders for a Dreamweaver site, you’ll at least need to set up a local site before proceeding. (The remote site is not required at this stage, but you will eventually need to set it up before publishing your files to the Web.) For more information, see “Working with Dreamweaver sites” on page 36.

2. In the Site Setup dialog box, select the Version Control category.

3. Select Subversion from the Access pop-up menu.

4. Set access options as follows:

   - Select a protocol from the Protocol pop-up menu. The available protocols are HTTP, HTTPS, SVN, and SVN+SSH.
Note: Using the SVN+SSH protocol requires special configuration. For more information, see www.adobe.com/go/learn_dw_svn_ssh_en.

- Enter the address for the SVN server in the Server address text box (typically in the form of servername.domain.com).
- Enter the path to your repository on the SVN server in the Repository path text box (typically something like /svn/your_root_directory. It is up to the server administrator to name the root folder for the SVN repository.)
- (Optional) If you want to use a server port other than the default server port, select Non Default and enter the port number in the text box.
- Enter your SVN server user name and password.

5 Click Test to test your connection, or click OK to close the dialog box. Then click Done to close the Manage Sites dialog box.

Once the connection with the server established, your SVN repository is available for viewing in the Files panel. To view it, you can select Repository View from the View pop-up menu, or click the Repository Files button in the expanded Files panel.

More Help topics
“Working with Dreamweaver sites” on page 36
“Using the Files panel” on page 72

Get the latest versions of files
When you get the latest version of a file from the SVN repository, Dreamweaver merges the contents of that file with the contents of its corresponding local copy. (In other words, if someone else has updated the file since you last committed it, those updates are merged into the local version of the file on your computer.) If the file does not yet exist on the local hard drive, Dreamweaver simply gets the file.

Note: When getting files for the first time from the repository, you should work with a local directory that is empty, or a local directory that does not contain files with the same names as files in the repository. Dreamweaver will not mount repository files to the local drive upon first try if the local drive contains files whose names match files in the remote repository.

1 Make sure that you’ve successfully set up an SVN connection.

2 Do one of the following:
- Display the local version of your SVN files in the Files panel by selecting Local view from the View pop-up menu. (If you are working in the expanded Files panel, the Local view is automatically displayed.) Then right-click (Windows) or Control-click (Macintosh) the file or folder you’re interested in and select Version Control > Get Latest Versions.
- Display the SVN repository files by selecting Repository View from the View pop-up menu in the Files panel, or by clicking the Repository Files button in the expanded Files panel. Then right-click (Windows) or Control-click (Macintosh) the file or folder you’re interested in and select Get Latest Versions.

Note: You can also either right-click a file and choose Check Out from the context menu, or select the file and click the Check Out button to get the latest version. Because SVN does not support a check-out workflow, however, this action does not actually check out the file in the traditional sense.

Commit files
1 Make sure that you’ve successfully set up an SVN connection.
2 Do one of the following:
   • Display the local version of your SVN files in the Files panel by selecting Local view from the View pop-up menu. (If you are working in the expanded Files panel, the Local view is automatically displayed.) Then select the file you want to commit and click the Check In button.
   • Display the SVN repository files by selecting Repository View from the View pop-up menu in the Files panel, or by clicking the Repository Files button in the expanded Files panel. Then right-click (Windows) or Control-click (Macintosh) the file you want to commit and select Check In.

3 Review the actions in the Commit dialog box, make changes if necessary, and click OK.

   You can change actions by selecting the file whose action you want to change, and clicking the buttons at the bottom of the Commit dialog box. Two choices are available: commit and ignore.

   **Note:** A green check mark on a file in the Files panel denotes a changed file that has not yet been committed to the repository.

**Update status of files or folders in the repository**

You can update the SVN status of a single file or folder. The update does not refresh the entire display.

1 Make sure that you’ve successfully set up an SVN connection.

2 Display the SVN repository files by selecting Repository View from the View pop-up menu in the Files panel, or by clicking the Repository Files button in the expanded Files panel.

3 Right-click (Windows) or Control-click (Macintosh) any folder or file in the repository and select Update Status.

**Update status of local file or folders**

You can update the SVN status of a single file or folder. The update does not refresh the entire display.

1 Make sure that you’ve successfully set up an SVN connection.

2 Display the local version of your SVN files in the Files panel by selecting Local view from the View pop-up menu. (If you are working in the expanded Files panel, the Local view is automatically displayed.)

3 Right-click (Windows) or Control-click (Macintosh) any folder or file in the Files panel and select Update Status.

**View revisions for a file**

1 Make sure that you’ve successfully set up an SVN connection.

2 Do one of the following:
   • Display the local version of your SVN files in the Files panel by selecting Local view from the View pop-up menu. (If you are working in the expanded Files panel, the Local view is automatically displayed.) Then right-click (Windows) or Control-click (Macintosh) the file you want to see revisions for and select Version Control > Show Revisions.
   • Display the SVN repository files by selecting Repository View from the View pop-up menu in the Files panel, or by clicking the Repository Files button in the expanded Files panel. Then right-click (Windows) or Control-click (Macintosh) the file you want to see revisions for and select Show Revisions.

3 In the Revision History dialog box, select the revision or revisions you’re interested in and do one of the following:
   • Click Compare to Local to compare the selected revision with the local version of the file.

   **Note:** You must install a third-party file comparison tool before you can compare files. For more information on file comparison tools, use a web search engine such as Google Search to search for “file comparison” or “diff” tools. Dreamweaver works with most third-party tools.
• Click Compare to compare two selected revisions. Control-click to select two revisions simultaneously.
• Click View to view the selected revision. This action does not overwrite the current local copy of the same file. You can save the selected revision to your hard drive just as you would save any other file.
• Click Promote to make the selected revision the most current revision in the repository.

**Lock and unlock files**

Locking a file in the SVN repository lets other users know that you are working on a file. Other users can still edit the file locally, but will not be able to commit the file until you’ve unlocked it. When you lock a file in the repository, you’ll see an open-lock icon on the file. Other users see a completely locked icon.

1 Make sure that you’ve successfully set up an SVN connection.
2 Do one of the following:
   • Display the SVN repository files by selecting Repository View from the View pop-up menu in the Files panel, or by clicking the Repository Files button in the expanded Files panel. Then right-click (Windows) or Control-click (Macintosh) the file you’re interested in and select Lock or Unlock.
   • Display the local version of your SVN files in the Files panel by selecting Local view from the View pop-up menu. (If you are working in the expanded Files panel, the Local view is automatically displayed.) Then right-click (Windows) or Control-click (Macintosh) the file you’re interested in and select Lock or Unlock.

**Add a new file to the repository**

A blue plus sign on a file in the Files panel denotes a file that does not yet exist in the SVN repository.

1 Make sure that you’ve successfully set up an SVN connection.
2 In the Files panel, select the file you want to add to the repository and click the Check In button.
3 Make sure that the file is selected for Commit in the Commit dialog box and click OK.

**Move, copy, delete, or revert files**

• To move a file, drag the file to the destination folder in your local site.
  When you move a file, Dreamweaver marks the file in the new location with an Add With History sign, and marks the file in the old location with a Delete sign. When you Commit these files, the file in the old location disappears.
• To copy a file, select the file, copy it (Edit > Copy), and paste (Edit > Paste) the file in the new location.
  When you copy and paste a file, Dreamweaver marks the file in the new location with an Add With History sign.
• To delete a file, select the file and press delete.
  Dreamweaver gives you the option of whether you want to delete the local version of the file only, or both the local version and the version on the SVN server. If you select to delete the local version only, the file on the SVN server is not affected. If you select to delete the version on the SVN server as well, the local version is marked with a Delete sign, and you must commit the file for the deletion to take place.
• To revert a copied or moved file to its original location, right-click the file and select Version Control > Revert.
Resolve conflicting files
If your file conflicts with another file on the server, you can edit it and then mark it as resolved. For example, if you try to check in a file that conflicts with another user’s changes, SVN will not let you commit the file. You can get the latest version of the file from the repository, manually make changes to your working copy, and then mark your file as resolved so that you can commit it.

1 Make sure that you’ve successfully set up an SVN connection.
2 Display the local version of your SVN files in the Files panel by selecting Local view from the View pop-up menu. (If you are working in the expanded Files panel, the Local view is automatically displayed.)
3 Right-click (Windows) or Control-click (Macintosh) the file you want to resolve and select Version Control > Mark as Resolved.

Go offline
You might find it useful to avoid repository access during other file-transfer activities by going off-line. Dreamweaver will reconnect to the SVN repository as soon as you invoke an activity that requires a connection (Get Latest Versions, Commit, and so on).

1 Make sure that you’ve successfully set up an SVN connection.
2 Display the local version of your SVN files in the Files panel by selecting Local view from the View pop-up menu. (If you are working in the expanded Files panel, the Local view is automatically displayed.)
3 Right-click (Windows) or Control-click (Macintosh) any file or folder in the Files panel and select Version Control > Go Offline.

Clean up a local SVN site
This command lets you remove locks on files so that you can resume unfinished operations. You should use this command to remove old locks if you receive “working copy locked” errors.

1 Make sure that you’ve successfully set up an SVN connection.
2 Display the local version of your SVN files in the Files panel by selecting Local view from the View pop-up menu. (If you are working in the expanded Files panel, the Local view is automatically displayed.)
3 Right-click (Windows) or Control-click (Macintosh) the file you want to clean up and select Version Control > Clean Up.

About moving files and folders in Subversion-controlled sites
When you move the local versions of files or folders in a Subversion-controlled site, you run the risk of creating problems for other users who might be synching to the SVN repository. For example, if you move a file locally, and don’t commit that file to the repository for a few hours, another user might try to get the latest version of the file from the file’s old location. For this reason, you should always commit files back to the SVN server immediately after you’ve moved them locally.

Files and folders remain on the SVN server until you’ve manually deleted them. So even if you move a file to a different local folder and commit it, the old version of the file remains in the previous location on the server. To avoid confusion, delete the old copies of files and folders that you’ve moved.

When you move a file locally and commit it back to the SVN server, the file’s version history is lost.
Synchronizing files

Synchronize the files on your local and remote sites
After you’ve created files in your local and remote sites, you can synchronize the files between the two sites.

*Note: If your remote site is an FTP server (rather than a networked server), then synchronizing your files uses FTP.*

Before you synchronize your sites, you can verify which files you want to put, get, delete, or ignore. Dreamweaver also confirms which files have been updated after you complete the synchronization.

More Help topics
“Manage file transfers” on page 84
“Check files into and out of a remote folder” on page 86
“Get files from a remote server” on page 81
“Put files on a remote server” on page 83
“Comparing files for differences” on page 94

Check which files are newer on the local or remote site, without synchronizing
❖ In the Files panel, do one of the following:

- Click the Options menu in the upper-right corner, and then select Edit > Select Newer Local or Edit > Select Newer Remote.

- In the Files panel, right-click (Windows) or Control-click (Macintosh), and then select Select > Newer Local or Select > Newer Remote.

Display detailed synchronization information for a particular file
❖ In the Files panel, right-click (Windows) or Control-click (Macintosh) the file you want information about, and then select Display Synchronize information.

*Note: You must have the Maintain Synchronization Information option selected in the Remote category of the Site Definition dialog box for this feature to be available.*

Synchronize your files
1 In the Files panel (Window > Files), select a site from the menu where the current site, server, or drive appears.
2 (Optional) Select specific files or folders or go to the next step to synchronize the entire site.
3 Click the Options menu in the upper-right corner of the Files panel and select Site > Synchronize.

You can also click the Synchronize button at the top of the Files panel to synchronize files.

4 In the Synchronize menu, do one of the following:

- To synchronize the entire site, select Entire Site Name Site.
- To synchronize selected files only, select Selected Local Files Only (or Selected Remote Files Only if the Remote view of the Files panel was where you made the most recent selection).
Select the direction in which you want to copy the files:

**Put Newer Files To Remote** Uploads all the local files that don’t exist on the remote server or have changed since the last upload.

**Get Newer Files From Remote** Downloads all the remote files that don’t exist locally or have changed since the last download.

**Get And Put Newer Files** Places the most recent versions of all the files on both the local and the remote sites.

Select whether to delete the files on the destination site that don’t have counterparts on the origin site. (This is not available if you select Get and Put from the Direction menu.)

If you select Put Newer Files to Remote and you select the Delete option, then any files in your remote site for which there are no corresponding local files are deleted. If you select Get Newer Files from Remote, then any files in your local site for which there are no corresponding remote files are deleted.

Click Preview.

**Note:** Before you can synchronize the files, you must preview the actions Dreamweaver performs to accomplish this task.

If the newest version of each chosen file is already in both locations and nothing needs to be deleted, an alert appears informing you that no synchronization is necessary. Otherwise, the Synchronize dialog box appears to let you change the actions (put, get, delete, and ignore) for those files before executing the synchronization.

Verify the action that will be performed for each file.

To change the action for a particular file, select the file, and then click one of the action icons at the bottom of the preview window.

**Compare** The Compare action works only if you installed and specified a file comparison tool in Dreamweaver. If the action icon is grayed out, the action cannot be performed.

**Mark Selected Files As Already Synched** This option lets you specify that the selected file or files are already synchronized.

Click OK to synchronize the files. You can view or save the details of the synchronization to a local file.

---

**Comparing files for differences**

**Compare local and remote files for differences**

Dreamweaver can work with file comparison tools (also known as “diff tools”) to compare the code of local and remote versions of the same file, two different remote files, or two different local files. Comparing local and remote versions is useful if you’re working on a file locally and you suspect the copy of the file on the server has been modified by someone else. Without leaving Dreamweaver, you can view and merge the remote changes into your local version before putting the file to the server.

Comparing two local files or two remote files is also useful if you keep previous, renamed versions of your files. If you’ve forgotten the changes made to a file from a previous version, a quick comparison will remind you.

Before you start, you must install a third-party file comparison tool on your system. For more information on file comparison tools, use a web search engine such as Google Search to search for “file comparison” or “diff” tools. Dreamweaver works with most third-party tools.
Specify a comparison tool in Dreamweaver
1. Install the file comparison tool on the same system as Dreamweaver.
2. In Dreamweaver, open the Preferences dialog box by selecting Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh), and then select the File Compare category.
3. Do one of the following:
   • In Windows, click the Browse button and select the application that compares files.
   • On the Macintosh, click the Browse button and select the tool or script that launches the file comparison tool from the command line, not the actual comparison tool itself.

Launch tools or scripts are typically located in the /usr/bin folder on your Macintosh. For example, if you want to use FileMerge, browse to /usr/bin and select opendiff, which is the tool that launches FileMerge.

The following table lists common file comparison tools for the Macintosh and the location of their launch tools or scripts on your hard disk:

<table>
<thead>
<tr>
<th>If you use</th>
<th>Select the following file</th>
</tr>
</thead>
<tbody>
<tr>
<td>FileMerge</td>
<td>/usr/bin/opendiff (or /Developer/usr/bin/opendiff)</td>
</tr>
<tr>
<td>BBEdit</td>
<td>/usr/bin/bbdiff</td>
</tr>
<tr>
<td>TextWrangler</td>
<td>/usr/bin/twdiff</td>
</tr>
</tbody>
</table>

Note: The usr folder is normally hidden in Finder. However, you can access it with the Browse button in Dreamweaver.

Note: The actual results displayed depends on the diff tool you are using. Check the user manual for your tool to understand how to interpret the results.

Compare two local files
You can compare two files located anywhere on your computer.
1. In the Files panel, Control-click (Windows) or Command-click (Macintosh) the two files to select them.
   
   To select files outside your defined site, select your local disk from the left pop-up menu in the Files panel and then select the files.

2. Right-click one of the selected files and select Compare Local Files from the context menu.
Note: If you have a one-button mouse, Control-click one of the selected files instead.

The file comparison tool starts and compares the two files.

Compare two remote files
You can compare two files located on your remote server. You must define a Dreamweaver site with remote settings before you can accomplish this task.
1. In the Files panel, display the files on the remote server by selecting Remote View from the right pop-up menu.
2. Control-click (Windows) or Command-click (Macintosh) the two files to select them.
3. Right-click one of the selected files and select Compare Remote Files from the context menu.
Note: If you have a one-button mouse, Control-click one of the selected files instead.

The file comparison tool starts and compares the two files.
Compare a local file to a remote file
You can compare a local file to a file located on your remote server. To do this, you must first define a Dreamweaver site with remote settings.

❖ In the Files panel, right-click a local file and select Compare With Remote from the context menu.

*Note:* If you have a one-button mouse, Control-click the local file instead.

The file comparison tool starts and compares the two files.

Compare a remote file to a local file
You can compare a remote file to a local file. You must define a Dreamweaver site with remote settings before accomplishing this task.

1 In the Files panel, display the files on the remote server by selecting Remote View from the right pop-up menu.
2 Right-click a file in the panel and select Compare with Local from the context menu.

*Note:* If you have a one-button mouse, Control-click the file instead.

Compare an open file to a remote file
You can compare a file open in Dreamweaver to its counterpart on the remote server.

❖ In the Document window, select File > Compare with Remote.

The file comparison tool starts and compares the two files.

 Underline You can also right-click the document tab along the top of the Document window and select Compare with Remote from the context menu.

Compare before putting files
If you edit a file locally and then try to upload it to your remote server, Dreamweaver will notify you if the remote version of the file has changed. You have the option of comparing the two files before you upload the file and overwrite the remote version.

Before you start, you must install a file comparison tool on your system and specify it in Dreamweaver.

1 After editing a file in a Dreamweaver site, put the file (Site > Put) to your remote site.
If the remote version of the file has been modified, you’ll receive a notification with the option of seeing the differences.
2 To view the differences, click the Compare button.
The file comparison tool starts and compares the two files.
If you haven’t specified a file comparison tool, you are prompted to specify one.
3 After you’ve reviewed or merged the changes in the tool, you can proceed with the Put operation or cancel it.

Compare files when synchronizing
You can compare the local versions of your files with the remote versions when you synchronize your site files with Dreamweaver.

Before you start, you must install a file comparison tool on your system and specify it in Dreamweaver.

1 Right-click anywhere in the Files panel and select Synchronize from the context menu.
2 Complete the Synchronize Files dialog box and click Preview.
After you click Preview, the selected files and the actions that will be taken during synchronization are listed.

3 In the list, select each file you want to compare and click the Compare button (the icon with two small pages).

*Note: The file must be text-based, such as HTML or ColdFusion files.*

Dreamweaver starts the comparison tool, which compares the local and remote versions of each file you selected.

**More Help topics**

“Synchronizing files” on page 93

---

**Rolling back files (Contribute users)**

**Roll back files (Contribute users)**

Dreamweaver automatically saves multiple versions of a document when you have Adobe Contribute compatibility enabled.

*Note: You must have Contribute installed on the same machine as Dreamweaver.*

File rollback must also be enabled in Contribute’s administrative settings. For more information, see *Administering Contribute*.

1 Right-click (Windows) or Control-click (Macintosh) a file in the Files panel.

2 Select Roll Back Page.

If there is any previous version of the page to roll back, the Rollback dialog box appears.

3 Select the version of the page you want to roll back to and click Roll Back.

**More Help topics**

“Prepare a site for use with Contribute” on page 54

“Delete, move, or rename a remote file in a Contribute site” on page 56

---

**Cloaking files and folders in your Dreamweaver site**

**About site cloaking**

Site cloaking enables you to exclude files and folders from operations such as Get or Put. You can also cloak all files of a particular type (JPEG, FLV, XML, and so on) from site operations. Dreamweaver remembers your settings for each site so that you don’t have to make selections each time you work on that site.

For example, if you’re working on a large site and you don’t want to upload your multimedia files each day, you can use site cloaking to cloak your multimedia folder. Dreamweaver will then exclude files in that folder from site operations you perform.

You can cloak files and folders on the remote or local site. Cloaking excludes cloaked files and folders from the following operations:

- Performing Put, Get, Check In, and Check Out operations
Generating reports

Finding newer local and newer remote files

Performing sitewide operations, such as checking and changing links

Synchronizing

Working with Asset panel contents

Updating templates and libraries

Note: You can still perform an operation on a specific cloaked folder or file by selecting the item in the Files panel and performing an operation on it. Performing an operation directly on a file or folder overrides cloaking.

Note: Dreamweaver excludes cloaked templates and library items from Get and Put operations only. Dreamweaver does not exclude these items from batch operations, because it might cause them to become out of sync with their instances.

Enable and disable site cloaking

Site cloaking enables you to exclude folders, files, and file types in a site from sitewide operations such as Get or Put, and is enabled by default. You can disable cloaking permanently or just temporarily to perform an operation on all files, including cloaked files. When you disable site cloaking, all cloaked files are uncloaked. When you enable site cloaking again, any previously cloaked files become cloaked again.

Note: You can also use the Uncloak All option to uncloak all files, but this does not disable cloaking; also there is no way to re-cloak all files and folders that were previously cloaked, except to set cloaking again for each folder, file, and file type.

1 In the Files panel (Window > Files) select a file or folder.

2 Right-click (Windows) or Control-click (Macintosh), and do one of the following:
   - Select Cloaking > (deselect to disable).
   - Select Cloaking > Settings to open the Cloaking category of the Site Setup dialog box. Select or deselect , and select or deselect Cloak Files Ending With to enable or disable cloaking for specific file types. You can enter or delete file suffixes in the text box that you want to cloak or uncloak.

Cloak and uncloak site files and folders

You can cloak specific files and folders, but you cannot cloak all files and folders or cloak an entire site. When you cloak specific files and folders, you can cloak multiple files and folders at the same time.

1 In the Files panel (Window > Files), select a site that has site cloaking enabled.

2 Select the folder(s) or file(s) you want to cloak or uncloak.

3 Right-click (Windows) or Control-click (Macintosh), then select Cloaking > Cloak or Cloaking > Uncloak from the context menu.

A red line through the file or folder icon appears or disappears, indicating that the folder is cloaked or uncloaked.

Note: You can still perform an operation on a specific cloaked file or folder by selecting the item in the Files panel and performing an operation on it. Performing an operation directly on a file or folder overrides cloaking.
Cloak and uncloak specific file types
You can indicate specific file types to cloak, so that Dreamweaver cloaks all files ending with a specified pattern. For example, you can cloak all files ending with the .txt extension. The file types that you enter do not have to be file extensions; they can be any pattern at the end of a filename.

Cloak specific file types within a site
1 In the Files panel (Window > Files), select a site that has site cloaking enabled.
2 Right-click (Windows) or Control-click (Macintosh), then select Cloaking > Settings.
3 Select the Cloak Files Ending With option, enter the file types to cloak in the box, and click OK.
For example, you might enter .jpg to cloak all files with names ending in .jpg in your site.
Separate multiple file types with one space; do not use a comma or semicolon.
In the Files panel, a red line appears through the affected files, indicating that they are cloaked.

Note: Some software creates backup files ending in a particular suffix, such as .bak. You can cloak such files.

Uncloak specific file types within a site
1 In the Files panel (Window > Files), select a site that has site cloaking enabled.
2 Right-click (Windows) or Control-click (Macintosh), then select Cloaking > Settings.
3 In the Advanced Site Definition dialog box, do one of the following:
   • Deselect the Cloak Files Ending With option to uncloak all the file types listed in the box.
   • Delete specific file types from the box to uncloak those file types.
4 Click OK.
The red lines disappear from the affected files, indicating that they are uncloaked.

Uncloak all files and folders
You can uncloak all files and folders in a site at the same time. This action cannot be undone; there is no way to re-cloak all items that were previously cloaked. You have to re-cloak items individually.

If you want to temporarily uncloak all folders and files, then re-cloak those items, disable site cloaking.
1 In the Files panel (Window > Files), select a site that has site cloaking enabled.
2 Select any file or folder in that site.
3 Right-click (Windows) or Control-click (Macintosh), then select Cloaking > Uncloak All.
Note: This step also deselects the Cloak Files Ending With option in the Cloaking category of the Site Definition dialog box.
The red lines through folder and file icons disappear, indicating that all files and folders in the site are uncloaked.
Storing file information in Design Notes

About Design Notes
Design Notes are notes that you create for a file. Design Notes are associated with the file they describe, but stored in a separate file. You can see which files have Design Notes attached in the expanded Files panel: A Design Notes icon appears in the Notes column.

You can use Design Notes to keep track of extra file information associated with your documents, such as image source-filenames and comments on file status. For example, if you copy a document from one site to another, you can add Design Notes for that document, with the comment that the original document is in the other site folder.

You can also use Design Notes to keep track of sensitive information that you can’t put inside a document for security reasons, such as notes on how a particular price or configuration was chosen, or what marketing factors influenced a design decision.

If you open a file in Adobe® Fireworks® or Flash, and export it to another format, Fireworks and Flash automatically save the name of the original source file in a Design Notes file. For example, if you open myhouse.png in Fireworks and export it to myhouse.gif, Fireworks creates a Design Notes file called myhouse.gif.mno. This Design Notes file contains the name of the original file, as an absolute file: URL. So, the Design Notes for myhouse.gif might contain the following line:

```
fw_source="file:///Mydisk/sites/assets/orig/myhouse.png"
```

A similar Flash Design Note might contain the following line:

```
fl_source="file:///Mydisk/sites/assets/orig/myhouse.fla"
```

*Note: To share Design Notes, users should define the same site-root path (for example, sites/assets/orig).*

When you import the graphic into Dreamweaver, the Design Notes file is automatically copied into your site along with the graphic. When you select the image in Dreamweaver and choose to edit it using Fireworks, Fireworks opens the original file for editing.

More Help topics
“Start an external editor for media files” on page 248

Enable and disable Design Notes for a site
Design Notes are notes associated with a file, but stored in a separate file. Use Design Notes to keep track of extra file information associated with your documents, such as image source-filenames and comments on file status.

You enable and disable Design Notes for a site in the Design Notes category of the Site Definition dialog box. When you enable Design Notes, you can also choose to share them with others, if you want.

1. Select Site > Manage Sites.
2. In the Manage Sites dialog box, select a site, then click Edit.
3. In the Site Setup dialog box, expand Advanced Settings and select the Design Notes category.
4. Select Maintain Design Notes to enable Design Notes (deselect to disable them).
5. If you want to delete all local Design Notes files for your site, click Clean Up, and then click Yes. (If you want to delete remote Design Notes files, you’ll need to delete them manually).
**Note:** The Clean Up Design Notes command only deletes MNO (Design Notes) files. It does not delete the _notes folder or the dwsync.xml file inside the _notes folder. Dreamweaver uses the dwsync.xml file to maintain information about site synchronization.

6 Select Enable Upload Design Notes For Sharing to upload Design Notes associated with your site with the rest of your documents and click OK.

- If you select this option, you can share Design Notes with the rest of your team. When you put or get a file, Dreamweaver automatically puts or gets the associated Design Notes file.
- If you do not select this option, Dreamweaver maintains Design Notes locally but does not upload them with your files. If you work alone on your site, deselecting this option improves performance. Design Notes will not be transferred to the remote site when you check in or put your files and you can still add and modify the Design Notes for your site locally.

**Associate Design Notes with files**

You can create a Design Notes file for each document or template in your site. You can also create Design Notes for applets, ActiveX controls, images, Flash content, Shockwave objects, and image fields in your documents.

**Note:** If you add Design Notes to a template file, documents you create with the template do not inherit the Design Notes.

1 Do one of the following:

- Open the file in the Document window and select File > Design Notes.
- In the Files panel, right-click (Windows) or Control-click (Macintosh) the file, and select Design Notes.

**Note:** If the file resides in a remote site, you must first check out or get the file, and then select it in the local folder.

2 In the Basic Info tab, select a status for the document from the Status menu.

3 Click the date icon (above the Notes box) to insert the current local date in your notes.

4 Type comments in the Notes box.

5 Select Show When File Is Opened to make the Design Notes file appear every time the file is opened.

6 In the All Info tab, click the Plus (+) button to add a new key-value pair; select a pair and click the Minus (–) button to remove it.

For example, you might name a key **Author** (in the Name box) and define the value as **Heidi** (in the Value box).

7 Click OK to save the notes.

Dreamweaver saves your notes to a folder called _notes, in the same location as the current file. The filename is the document’s filename, plus the extension .mno. For example, if the filename is index.html, the associated Design Notes file is named index.html.mno.

**More Help topics**

“Getting and putting files to and from your server” on page 80

“Check files into and out of a remote folder” on page 86

**Work with Design Notes**

After you associate a Design Note with a file, you can open the Design Note, change its status, or delete it.
Open Design Notes associated with a file
❖ Do one of the following to open the Design Notes:
  - Open the file in the Document window, then select File > Design Notes.
  - In the Files panel, right-click (Windows) or Control-click (Macintosh) the file, then select Design Notes.
  - In the Notes column of the Files panel, double-click the yellow Design Notes icon.

Note: To show the yellow Design Notes icons, select Site > Manage Sites > [your site name] > Edit > Advanced Settings > File View Columns. Select Notes in the list panel and choose the Show option. When you click the Expand button on the Files toolbar to show both the local and remote site, you have a Notes column in your local site that shows a yellow note icon for any file with a Design Note.

Assign a custom Design Notes status
1 Open Design Notes for a file or object (see the previous procedure).
2 Click the All Info tab.
3 Click the Plus (+) button.
4 In the Name field, enter the word status.
5 In the Value field, enter the status.

If a status value already existed, it’s replaced with the new one.
6 Click the Basic Info tab and note that the new status value appears in the Status pop-up menu.

Note: You can have only one custom value in the status menu at a time. If you follow this procedure again, Dreamweaver replaces the status value you entered the first time with the new status value you enter.

Delete unassociated Design Notes from your site
1 Select Site > Manage Sites.
2 Select the site and click Edit.
3 In the Site Definition dialog box, select Design Notes from the category list on the left.
4 Click the Clean Up button.

Dreamweaver prompts you to verify that it should delete any Design Notes that are no longer associated with a file in your site.

If you use Dreamweaver to delete a file that has an associated Design Notes file, Dreamweaver deletes the Design Notes file too; so usually orphan Design Notes files occur only if you delete or rename a file outside of Dreamweaver.

Note: If you deselect the Maintain Design Notes option before you click Clean Up, Dreamweaver deletes all Design Notes files for your site.

Testing your Dreamweaver site

Site testing guidelines
Before uploading your site to a server and declaring it ready for viewing, it’s a good idea to test it locally. (In fact, it’s a good idea to test and troubleshoot your site frequently throughout its construction—you can catch problems early and avoid repeating them.)
You should make sure that your pages look and work as expected in the browsers you’re targeting, that there are no broken links, and that the pages don’t take too long to download. You can also test and troubleshoot your entire site by running a site report.

The following guidelines will help you create a good experience for visitors to your site:

1. **Make sure your pages function in the browsers you’re targeting.**
   Your pages should be legible and functional in browsers that do not support styles, layers, plug-ins, or JavaScript. For pages that fail badly in older browsers, consider using the Check Browser behavior to automatically redirect visitors to another page.

2. **Preview your pages in different browsers and platforms.**
   This gives you an opportunity to see differences in layout, color, font sizes, and default browser window size that cannot be predicted in a target browser check.

3. **Check your site for broken links and fix them.**
   Other sites undergo redesign and reorganization too, and the page you’re linking to may have been moved or deleted. You can run a link check report to test your links.

4. **Monitor the file size of your pages and the time they take to download.**
   Keep in mind that if a page consists of one large table, in some browsers, visitors will see nothing until the entire table finishes loading. Consider breaking up large tables; if this is not possible, consider putting a small amount of content—such as a welcome message or an advertising banner—outside the table at the top of the page so users can view this material while the table downloads.

5. **Run a few site reports to test and troubleshoot the entire site.**
   You can check your entire site for problems, such as untitled documents, empty tags, and redundant nested tags.

6. **Validate your code to locate tag or syntax errors.**

7. **Update and maintain the site after its published.**
   Publishing your site—that is, making it live—can be accomplished in several ways and is an ongoing process. An important part of the process is defining and implementing a version-control system, either with the tools Dreamweaver includes or through an external version-control application.

8. **Use the discussion forums.**
   The Dreamweaver discussion forums can be found on the Adobe website at www.adobe.com/go/dreamweaver_newsgroup.
   
   The forums are a great resource for getting information on different browsers, platforms, and so on. You can also discuss technical issues and share helpful hints with other Dreamweaver users.
   
   For a tutorial on troubleshooting publishing problems, see www.adobe.com/go/vid0164.

**More Help topics**

“Fix broken links” on page 275

“Test links in Dreamweaver” on page 270

“Apply the Check Browser behavior” on page 337
Use reports to test your site

You can run site reports on workflow or HTML attributes. You can also use the Reports command to check links in your site.

Workflow reports can improve collaboration among members of a web team. You can run workflow reports that display who has checked out a file, which files have Design Notes associated with them, and which files have been modified recently. You can further refine Design Note reports by specifying name/value parameters.

Note: You must have a remote site connection defined to run the workflow reports.

HTML reports enable you to compile and generate reports for several HTML attributes. You can check combinable nested font tags, missing Alt text, redundant nested tags, removable empty tags, and untitled documents.

After you run a report, you can save it as an XML file, then import it into a template instance or a database or spreadsheet and print it, or display it on a website.

Note: You can also add different report types to Dreamweaver through the Adobe Dreamweaver Exchange website.

More Help topics

“Reports in Dreamweaver” on page 20

“Test links in Dreamweaver” on page 270

“Add and manage extensions in Dreamweaver” on page 34

Run reports to test a site

1 Select Site > Reports.
2 Select what to report on from the Report On pop-up menu and set any of the report types to run (workflow or HTML).

You cannot run a Selected Files In Site report unless you have already selected files in the Files panel.

3 If you selected a workflow report, click Report Settings. Otherwise, skip this step.

Note: If you selected more than one workflow report, you need to click the Report Settings button for each report. Select a report, click Report Settings, and enter settings; then, repeat the process for any other workflow reports.

Checked Out By Creates a report listing all documents checked out by a specific team member. Enter the name of a team member, and then click OK to return to the Reports dialog box.

Design Notes Creates a report listing all Design Notes for selected documents or for the site. Enter one or more name and value pairs, then select comparison values from the corresponding pop-up menus. Click OK to return to the Reports dialog box.

Recently Modified Creates a report listing files that have changed during a specified time frame. Enter date ranges and location for the files you want to view.

4 If you selected an HTML report, select from the following reports:

Combinable Nested Font Tags Creates a report that lists all nested font tags that can be combined to clean up the code.
For example, `<font color="#FF0000">STOP!</font>` is reported.

**Missing Alt Text**  Creates a report listing all the `img` tags that don’t have alternate text.

Alternate text appears in place of images for text-only browsers or for browsers that have been set to download images manually. Screen readers read alternate text, and some browsers display alternate text when the user mouses over the image.

**Redundant Nested Tags**  Creates a report detailing nested tags that should be cleaned up.

For example, `<i>The rain <i>in</i> Spain stays mainly in the plain</i>` is reported.

**Removable Empty Tags**  Creates a report detailing all empty tags that can be removed to clean up the HTML code.

For example, you may have deleted an item or image in Code view, but left behind the tags that applied to that item.

**Untitled Documents**  Creates a report listing all the untitled documents found within the selected parameters.

Dreamweaver reports all documents with default titles, multiple title tags, or missing title tags.

5 Click Run to create the report.

Depending on the type of report you run, you might be prompted to save your file, define your site, or select a folder (if you haven’t already done so).

A list of results appears in the Site Reports panel (in the Results panel group).

**Use and save a report**

1 Run a report (see the previous procedure).

2 In the Site Reports panel, do any of the following to view the report:
   - Click the column heading you want to sort results by.
   - You can sort by filename, line number, or description. You can also run several different reports and keep the different reports open.
   - Select any line in the report, then click the More Info button on the left side of the Site Reports panel for a description of the problem.
   - Double-click any line in the report to view the corresponding code in the Document window.
   - **Note:** If you are in Design view, Dreamweaver changes the display to split view to show the reported problem in code.

3 Click Save Report to save the report.

When you save a report, you can import it into an existing template file. You can then import the file into a database or spreadsheet and print it, or use the file to display the report on a website.

_After running HTML reports, use the Clean Up HTML command to correct any HTML errors the reports listed._
Chapter 5: Managing assets and libraries

About assets and libraries

About assets
You can use Adobe® Dreamweaver® CS5 to keep track of and preview assets stored in your site, such as images, movies, colors, scripts, and links. You can also drag an asset directly to insert it in a page of the current document.

You obtain assets from various sources. For example, you might create assets in an application such as Adobe® Fireworks® or Adobe® Flash®, receive them from a co-worker, or copy them from a clip-art CD or graphics website.

Dreamweaver also provides access to two special types of assets—libraries and templates. Both are linked assets: when you edit a library item or template, Dreamweaver updates all documents that use those assets. Library items generally represent small design assets, such as a site logo or copyright. To control a larger design area, use a template instead.

More Help topics
“About Dreamweaver templates” on page 374

About library items
A library is a special Dreamweaver file containing a collection of individual assets or copies of assets that you can place in your web pages. The assets in a library are called library items. Items that you can store in a library include images, tables, sounds, and files created with Adobe Flash. You can automatically update all the pages that use a library item whenever you edit the item.

For example, suppose you’re building a large site for a company that wants a slogan to appear on every page. You can create a library item to contain the slogan and use that library item on every page. If the slogan changes, you can change the library item and automatically update every page that uses it.

Dreamweaver stores library items in a Library folder within the local root folder for each site. Each site has its own library.

You can create a library item from any element in the body section of a document, including text, tables, forms, Java applets, plug-ins, ActiveX elements, navigation bars, and images.

For linked items such as images, the library stores only a reference to the item. The original file must remain at the specified location for the library item to work correctly.

It can still be useful to store an image in a library item, though. For example, you could store a complete img tag in a library item, which would allow you to easily change the image’s alt text, or even its src attribute, throughout the site. (Don’t use this technique to change an image’s width and height attributes, though, unless you also use an image editor to change the actual size of the image.)

Note: If the library item contains links, the links may not work in the new site. Also, images in a library item aren’t copied to the new site.

When you use a library item, Dreamweaver inserts a link to it, rather than the item itself, in the web page. That is, Dreamweaver inserts a copy of the HTML source code for that item into the document and adds an HTML comment containing a reference to the original, external item. It is this external reference that makes automatic updating possible.
When you create a library item that includes an element with a Dreamweaver behavior attached to it, Dreamweaver copies the element and its event handler (the attribute that specifies which event triggers the action, such as `onClick`, `onLoad`, or `onMouseOver`, and which action to call when the event occurs) to the library item file. Dreamweaver does not copy the associated JavaScript functions into the library item. Instead, when you insert the library item into a document, Dreamweaver automatically inserts the appropriate JavaScript functions into the `head` section of that document (if they aren't already there).

**Note:** If you hand-code JavaScript (that is, if you create it without using Dreamweaver behaviors), you can make it part of a library item if you use the Call JavaScript behavior to execute the code. If you don't use a Dreamweaver behavior to execute the code, the code isn't retained as part of the library item.

There are special requirements for editing the behaviors in library items. Library items cannot contain style sheets, because the code for those elements is part of the `head` section.

**More Help topics**

“Edit a behavior in a library item” on page 117

---

### Working with assets

#### Assets panel overview

Use the Assets panel (Window > Assets) to manage assets in the current site. The Assets panel displays assets for the site associated with the active document in the Document window.

**Note:** You must define a local site before you can view assets in the Assets panel.

![Asset panel with Site list displayed. Category icons are at left, and preview area is above list.](image)

The Assets panel provides two ways to view assets:

- **Site list** Shows all of the assets in your site, including colors and URLs that are used in any document in your site.
- **Favorites list** Shows only the assets you've explicitly chosen.

To switch between these two views, select either the Site or Favorites radio button above the preview area. (These two views are not available for the Templates and Library categories.)

**Note:** Most of the Assets panel operations work the same in both lists. There are a few tasks, however, that you can perform only in the Favorites list.
In both lists, assets fall into one of the following categories:

- **Images**: Image files in GIF, JPEG, or PNG formats.
- **Colors**: Colors used in documents and style sheets, including colors of text, backgrounds, and links.
- **URLs**: External links in your current site documents, including FTP, gopher, HTTP, HTTPS, JavaScript, e-mail (mailto), and local file (file://) links.
- **Flash**: Files in any version of Adobe Flash. The Assets panel displays only SWF files (compressed files created with Flash), but not FLA (Flash source) files.
- **Shockwave**: Files in any version of Adobe Shockwave.
- **Movies**: QuickTime or MPEG files.
- **Scripts**: JavaScript or VBScript files. Scripts in HTML files (rather than in independent JavaScript or VBScript files) do not appear in the Assets panel.
- **Templates**: Master page layouts used on multiple pages. Modifying a template automatically modifies all pages attached to it.
- **Library items**: Design elements that you use in multiple pages; when you modify a library item, all pages containing that item are updated.

**Note:** To appear in the Assets panel, a file must fall into one of these categories. Some other types of files are sometimes called assets, but they aren’t shown in the panel.

By default, assets in a category are listed alphabetically by name, but you can sort them by type and several other criteria. You can also preview assets and resize the columns and the preview area.

**More Help topics**

- “Creating and managing a list of favorite assets” on page 111
- “Working with library items” on page 113

**View an asset in the preview area**

- Select the asset in the Assets panel.

For example, when you select a movie asset, the preview area shows an icon. To view the movie, click the Play button (the green triangle) in the upper-right corner of the preview area.

**Display assets in a category**

- Click a category icon on the left side of the Assets panel.

**Sort assets**

- Click a column heading.

For example, to sort the list of images by type (so that all the GIF images are together, all the JPEG images are together, and so on), click the Type column heading.

**Resize a column**

- Drag the line separating two column headings.

**Resize the preview area**

- Drag the splitter bar (between the preview area and the list of assets) up or down.

Last updated 12/7/2011
**Refresh the Assets panel**

It can take a few seconds to create the Site list because Dreamweaver must first read the site cache.

Certain changes don’t appear immediately in the Assets panel. For instance, when you add or remove an asset from your site, the changes don’t appear in the Assets panel until you refresh the Site list by clicking the Refresh Site List button. If you add or remove an asset outside Dreamweaver—using Windows Explorer

or the Finder, for example—you must rebuild the site cache to update the Assets panel.

When you remove the only instance of a particular color or URL in your site, or when you save a new file that contains a color or URL that isn’t already used in the site, the changes don’t appear in the Assets panel until you refresh the Site list.

- To refresh the Site list manually, click the Refresh Site List button ⏳. Dreamweaver creates the site cache or updates it as necessary.
- To refresh the Site list and manually rebuild the site cache, right-click (Windows) or Command-click (Macintosh) in the Assets list, then select Refresh Site List.

**Add an asset to a document**

You can insert most assets into a document by dragging them into the Code view or Design view in the Document window, or by using the Insert button in the panel. You can either insert colors and URLs or apply them to selected text in the Design view. (URLs can also be applied to other elements in the Design view, such as images.)

1. In Design view, place the insertion point where you want the asset to appear.
2. In the Assets panel, select from the asset category buttons at the left.

*Note: Select any category except Templates. A template is applied to an entire document; it can’t be inserted into a document.*

3. Select either Site or Favorites at the top of the panel, then select the asset. There are no Site or Favorites lists for library items; skip this step if you’re inserting a library item.
4. Do one of the following:
   - Drag the asset from the panel to the document.
   - Select the asset in the panel and click Insert.

If the inserted asset is a color, it applies to text appearing after the insertion point.

**Apply a color to text using the Assets panel**

The Assets panel shows the colors you’ve already applied to various elements, such as text, table borders, backgrounds, and so on.

1. Select the text in the document.
2. In the Assets panel, select the Colors category 🌈.
3. Select the desired color and click Apply.
More Help topics
“Add or remove favorite assets” on page 112

Apply a URL to an image or text using the Assets panel
1. Select the text or image.
2. In the Assets panel, select the URLs category in either the Sites or Favorites view, depending on where the URL is stored.

Note: URLs for your site’s files are stored in the Sites view by default. The Favorites view holds URLs that you have added yourself.
3. Select the URL.
4. Do one of the following:
   - Drag the URL from the panel to the selection in the Design view.
   - Select the URL, then click Insert.

Select and edit assets
The Assets panel allows you to select multiple assets at once. It also provides a quick way to begin editing assets.

More Help topics
“Start an external editor for media files” on page 248

Select multiple assets
1. In the Assets panel, select an asset.
2. Select the other assets in one of the following ways:
   - Shift-click to select a consecutive series of assets.
   - Control-click (Windows) or Command-click (Macintosh) to add an individual asset to the selection (whether or not it’s adjacent to the existing selection). Control-click or Command-click a selected asset to deselect it.

Edit an asset
When you edit an asset in the Assets panel, the behavior varies according to the asset type. For some assets, such as images, you use an external editor, which opens automatically if you have defined an editor for that asset type. You can edit colors and URLs in the Favorites list only. When you edit templates and library items, you make the changes within Dreamweaver.
1. In the Assets panel, do one of the following:
   - Double-click the asset.
   - Select the asset, then click the Edit button.

Note: If the asset must be edited in an external editor and one doesn’t open automatically, select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh), select the File Types/Editors category, and make sure you have defined an external editor for that asset type.
2. Make your changes.
3. When you finish, do one of the following:
   - If the asset is file-based (anything other than a color or URL), save it (in the editor you used), and close it.
• If the asset is a URL, click OK in the Edit URL dialog box.

**Note:** If the asset is a color, the color picker closes automatically after you pick a color. To dismiss the color picker without picking a color, press Esc.

### Reuse assets in another site

The Assets panel shows all the assets (of recognized types) in your current site. To use an asset from the current site in another site, you must copy it to the other site. You can copy an individual asset, a set of individual assets, or an entire Favorites folder at once.

You may need to locate the file in the Files panel that corresponds to an asset in the Assets panel before you transfer the asset to or from your remote site.

**Note:** The Files panel might show a different site from the one that the Assets panel shows. This is because the Assets panel is associated with the active document.

#### Locate an asset file in the Files panel

1. In the Assets panel, select the category of the asset you want to find.
2. Right-click (Windows) or Control-click (Macintosh) the asset’s name or icon in the Assets panel, then select Locate In Site from the context menu.

**Note:** Locate In Site is unavailable for colors and URLs, which do not correspond to files in the site.

The Files panel opens, with the asset file selected. The Locate In Site command locates the file corresponding to the asset itself; it does not locate files that use that asset.

#### Copy assets from the Asset panel to another site

1. In the Assets panel, select the category of the asset you want to copy.
2. Right-click (Windows) or Control-click (Macintosh) one or more assets in either the Site list or Favorites list, select Copy To Site, and select the target site name from the submenu listing all the sites you’ve defined.

**Note:** In the Favorites list, you can copy a Favorites folder as well as individual assets.

The assets are copied to their corresponding locations in the target site. Dreamweaver creates new folders in the target site’s hierarchy as needed. The assets are also added to the target site’s Favorites list.

**Note:** If the asset you copied is a color or a URL, it appears only in the target site’s Favorites list. Because colors and URLs don’t correspond to files, there’s no file to copy into the other site.

### Creating and managing a list of favorite assets

#### Managing favorite assets

The complete list of all recognized assets list can become cumbersome for some large sites. You can add frequently used assets to a Favorites list, group related assets together, give them nicknames to remind yourself what they’re for, and find them easily in the Assets panel.

**Note:** Favorite assets are not stored as separate files on your disk; they’re references to the assets in the Site list. Dreamweaver keeps track of which assets from the Site list to display in the Favorites list.
Most of the operations of the Assets panel are the same in the Favorites list as in the Site list. However, there are several tasks that you can perform only in the Favorites list.

**Add or remove favorite assets**

There are several ways to add assets to your site's Favorites list in the Assets panel.

Adding a color or URL to the Favorites list requires an extra step. You can’t add new colors or URLs to the Site list; the Site list contains only assets that are already in use in your site.

*Note: There are no Favorites lists for templates and library items.*

**More Help topics**

“Assets panel overview” on page 107

“Use the color picker” on page 208

**Add assets to the Favorites list**

Do one of the following:

- Select one or more assets in the Site list of the Assets panel, then click the Add To Favorites button.
- Select one or more assets in the Site list of the Assets panel, right-click (Windows) or Control-click (Macintosh), then select Add To Favorites.
- Select one or more files in the Files panel, right-click (Windows) or Control-click (Macintosh), then select Add To Favorites.
- Right-click (Windows) or Control-click (Macintosh) an element in the Document window’s Design view, then select the context menu command to add the element to a Favorites category.

The context menu for text contains either Add To Color Favorites or Add To URL Favorites, depending on whether the text has a link attached. You can add only those elements that match one of the categories in the Assets panel.

**Add a new color or URL to the Favorites list**

1. In the Assets panel, select the Colors or URLs category.
2. Select the Favorites option at the top of the panel.
3. Click the New Color or New URL button.
4. Do one of the following:
   - Select a color using the color picker, then give the color a nickname if desired.
To close the color picker without selecting a color, press Esc or click the gray bar at the top of the color picker.
• Enter a URL and a nickname in the Add New URL dialog box, then click OK.

**Remove assets from the Favorites list**
1. In the Assets panel, select the Favorites option at the top of the panel.
2. Select one or more assets (or a folder) in the Favorites list.
3. Click the Remove From Favorites button.

The assets are removed from the Favorites list, but not from the Site list. If you remove a Favorites folder, the folder and all its contents are removed.

**Create a nickname for a favorite asset**
You can give nicknames (for instance, PageBackgroundColor rather than #999900) to assets only in the Favorites list. The Site list retains their real filenames (or values, in the case of colors and URLs).

1. In the Assets panel (Window > Assets), select the category that contains your asset.
2. Select the Favorites option at the top of the panel.
3. Do one of the following:
   • Right-click (Windows) or Control-click (Macintosh) the asset’s name or icon in the Assets panel, then select Edit Nickname.
   • Click the asset’s name once, pause, then click it again. (Do not double-click; double-clicking opens the item for editing.)
4. Type a nickname for the asset, then press Enter (Windows) or Return (Macintosh).

**More Help topics**
“**Assets panel overview**” on page 107

**Group assets in a Favorites folder**
Placing an asset in Favorites folder does not change the location of the asset’s file on your disk.

1. In the Assets panel, select the Favorites option at the top of the panel.
2. Click the New Favorites Folder button.
3. Type a name for the folder, then press Enter (Windows) or Return (Macintosh).
4. Drag assets into the folder.

**Working with library items**

**Create a library item**
Library items are elements that you want to reuse or update frequently throughout your website.

**More Help topics**
“**About library items**” on page 106
Create a library item based on a selection
1 In the Document window, select a portion of a document to save as a library item.
2 Do one of the following:
   • Drag the selection into the Library category ☜.
   • Click the New Library Item button ☞ at the bottom of the Library category.
   • Select Modify > Library > Add Object To Library.
3 Type a name for the new library item, then press Enter (Windows) or Return (Macintosh).
Dreamweaver saves each library item as a separate file (with the file extension .lbi) in the Library folder of the site’s local root folder.

Create an empty library item
1 Make sure nothing is selected in the Document window.
If something is selected, it will be placed in the new library item.
2 In the Assets panel, select the Library category ☞.
3 Click the New Library Item button ☞ at the bottom of the panel.
4 While the item is still selected, enter a name for it, then press Enter (Windows) or Return (Macintosh).

Insert a library item into a document
When you add a library item to a page, the actual content is inserted in the document along with a reference to the library item.
1 Place the insertion point in the Document window.
2 In the Assets panel, select the Library category ☞.
3 Do one of the following:
   • Drag a library item from the Assets panel to the Document window.
   To insert the contents of a library item without including a reference to the item in the document, press Control (Windows) or Option (Macintosh) while dragging an item out of the Assets panel. If you insert an item this way, you can edit the item in the document, but the document won’t be updated when you update pages that use that library item.
   • Select a library item, and click Insert.

Edit library items and update documents
When you edit a library item, you can update all documents that use that item. If you choose not to update, the documents remain associated with the library item; you can update them later.
You can rename items to break their connection with documents or templates, delete items from the site’s library, and recreate a missing library item.

Note: The CSS Styles panel is unavailable as you edit a library item, because library items can contain only body elements and Cascading Style Sheets (CSS) code is inserted in the head section of a document. The Page Properties dialog box is also unavailable, because a library item can’t include a body tag or its attributes.

Edit a library item
1 In the Assets panel, select the Library category ☞.
2 Select a library item.
3 Either Click the Edit button or double-click the library item.

Dreamweaver opens a new window, similar to the Document window, for editing the library item. The gray background indicates that you're editing a library item instead of a document.

4 Make and then save your changes.
5 Specify whether to update the documents on the local site that use the library item. Select Update to update immediately. If you select Don’t Update, documents won’t be updated until you choose Modify > Library > Update Current Page or Update Pages.

**Update the current document to use the current version of all library items**

Select Modify > Library > Update Current Page.

**Update the entire site or all documents that use a particular library item**

1 Select Modify > Library > Update Pages.

2 In the Look In pop-up menu, specify what to update:
   - To update all pages in the selected site to use the current version of all library items, select Entire Site, then select the site name from the adjacent pop-up menu.
   - To update all pages in the current site that use the library item, select Files That Use, then select a library item name from the adjacent pop-up menu.

3 Make sure that Library Items is selected in the Update option.

   *To update templates at the same time, select Templates as well.*

4 Click Start.

Dreamweaver updates the files as indicated. If you selected the Show Log option, Dreamweaver generates a report showing whether files were updated successfully, along with other information.

**Rename a library item**

1 In the Assets panel, select the Library category.

2 Select the library item, pause, and then click again. (Do not double-click; double-clicking opens the item for editing.)

3 Enter a new name.

4 Click elsewhere, or press Enter (Windows) or Return (Macintosh).

5 Specify whether to update documents that use the item by choosing either Update or Don’t Update.

**Delete a library item from a library**

When you delete a library item, Dreamweaver removes it from the library but doesn’t change the contents of any documents that use the item.

1 In the Assets panel, select the Library category.

2 Select the library item.

3 Either click the Delete button or press the Delete key, then confirm that you want to delete the item.

*Important: If you delete a library item, you can’t use Undo to retrieve it. You may be able to recreate it, however.*
**Recreate a missing or deleted library item**
1. Select an instance of the item in one of your documents.
2. Click the Recreate button in the Property inspector (Window > Properties).

**Customize highlighting of library items**
You can customize the highlight color of library items and show or hide highlighting by setting Highlighting preferences.

**More Help topics**
“Use the color picker” on page 208

**Change the highlight color of library items**
1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).
2. Select the Highlighting category from the list on the left of the Preferences dialog box.
3. Click the Library Items color box, then select a highlight color using the color picker (or enter the hexadecimal color value in the text box).
4. Select Show to display the highlight color in the Document window.
5. Click OK.

**To show or hide highlighting in the Document window**
❖ To show highlighting, select View > Visual Aids > Invisible Elements. To hide highlighting, deselect Invisible Elements.

**Edit the properties of a library item**
You can use the Property inspector to open a library item for editing, detach a selected library item from its source file, or overwrite an item with the currently selected library item.
1. Select a library item in a document.
2. Select one of these options in the Property inspector (Window > Properties):
   - **Src** Displays the filename and location of the source file for the library item. You can’t edit this information.
   - **Open** Opens the library item’s source file for editing. This is equivalent to selecting the item in the Assets panel and clicking the Edit button.
   - **Detach From Original** Breaks the link between the selected library item and its source file. You can edit the detached item in the document, but it’s no longer a library item and isn’t updated when you change the original.
   - **Recreate** Overwrites the original library item with the current selection. Use this option to re-create library items if the original library item is missing or has been accidentally deleted.

**Make library items editable in a document**
If you’ve added a library item to your document and you want to edit the item specifically for that page, you must break the link between the item in the document and the library. Once you’ve made an instance of a library item editable, that instance isn’t updated when the library item changes.
1. Select a library item in the current document.
2 Click Detach From Original in the Property inspector (Window > Properties).

**Edit a behavior in a library item**

To edit a behavior in a library item, you must first insert the item in a document, then make the item editable in that document. After you've made the changes, you can re-create the library item, replacing the item in the library with the edited item from your document.

1 Open a document that contains the library item. Note the name of the library item, as well as the exact tags it contains. You'll need this information later.
2 Select the library item, and then click Detach From Original in the Property inspector (Window > Properties).
3 Select the element that has the behavior attached to it.
4 In the Behaviors panel (Window > Behaviors), double-click the action you want to change.
5 In the dialog box that appears, make your changes, then click OK.
6 In the Assets panel, select the Library category. Record the exact name and capitalization of the original library item; select it, then click the Delete button.
7 In the Document window, select all the elements that make up the library item. Be careful to select exactly the same elements that were in the original library item.
9 In the Assets panel, click the New Library Item button, then give the new item the same name as the item you deleted, using the same spelling and capitalization.
10 To update the library item in your site’s other documents, select Modify > Library > Update Pages.
11 In the Look In pop-up menu, select Files That Use.
12 In the adjacent pop-up menu, select the name of the library item you just created.
13 In the Update option, make sure Library Items is selected, then click Start.
14 When the updates are complete, click Close.

**More Help topics**

“Using JavaScript behaviors” on page 321
Chapter 6: Creating pages with CSS

Understanding Cascading Style Sheets

About Cascading Style Sheets

Cascading Style Sheets (CSS) is a collection of formatting rules that control the appearance of content in a web page. Using CSS styles to format a page separates content from presentation. The content of your page—the HTML code—resides in the HTML file, and the CSS rules defining the presentation of the code reside in another file (an external style sheet) or in another part of the HTML document (usually the head section). Separating content from presentation makes it much easier to maintain the appearance of your site from a central location because you don't need to update every property on every page whenever you want to make a change. Separating content from presentation also results in simpler and cleaner HTML code, which provides shorter browser loading times, and simplifies navigation for people with accessibility issues (for example, those using screen readers).

CSS gives you great flexibility and control over the exact appearance of your page. With CSS you can control many text properties including specific fonts and font sizes; bold, italics, underlining, and text shadows; text color and background color; link color and link underlining; and much more. By using CSS to control your fonts, you can also ensure a more consistent treatment of your page layout and appearance in multiple browsers.

In addition to text formatting, you can use CSS to control the format and positioning of block-level elements in a web page. A block-level element is a standalone piece of content, usually separated by a new line in the HTML, and visually formatted as a block. For example, h1 tags, p tags, and div tags all produce block-level elements on a web page. You can set margins and borders for block-level elements, position them in a specific location, add background color to them, float text around them, and so on. Manipulating block-level elements is in essence the way you lay out pages with CSS.

More Help topics

“Working with div tags” on page 152

“Laying out pages with CSS” on page 146

Understanding CSS tutorial

About CSS rules

A CSS formatting rule consists of two parts—the selector and the declaration (or in most cases, a block of declarations). The selector is a term (such as p, h1, a class name, or an id) that identifies the formatted element, and the declaration block defines what the style properties are. In the following example, h1 is the selector, and everything that falls between the braces ({}) is the declaration block:

```
h1 {
  font-size: 16 pixels;
  font-family: Helvetica;
  font-weight:bold;
}
```

An individual declaration consists of two parts, the property (such as font-family) and value (such as Helvetica). In the previous CSS rule, a particular style has been created for h1 tags: the text for all h1 tags linked to this style will be 16 pixels in size, Helvetica font, and bold.
The style (which comes from a rule, or a collection of rules) resides in a place separate from the actual text it’s formatting—usually in an external style sheet, or in the head portion of an HTML document. Thus, one rule for h1 tags can apply to many tags at once (and in the case of external style sheets, the rule can apply to many tags at once on many different pages). In this way, CSS provides extremely easy update capability. When you update a CSS rule in one place, the formatting of all the elements that use the defined style are automatically updated to the new style.

You can define the following types of styles in Dreamweaver:

- **Class styles** let you apply style properties to any element or elements on the page.
- **HTML tag styles** redefine the formatting for a particular tag, such as h1. When you create or change a CSS style for the h1 tag, all text formatted with the h1 tag is immediately updated.
- **Advanced styles** redefine the formatting for a particular combination of elements, or for other selector forms as allowed by CSS (for example, the selector td h2 applies whenever an h2 header appears inside a table cell.) Advanced styles can also redefine the formatting for tags that contain a specific id attribute (for example, the styles defined by #myStyle apply to all tags that contain the attribute-value pair id="myStyle").

CSS rules can reside in the following locations:

- **External CSS style sheets** Collections of CSS rules stored in a separate, external CSS (.css) file (not an HTML file). This file is linked to one or more pages in a website using a link or an @import rule in the head section of a document.
- **Internal (or embedded) CSS style sheets** Collections of CSS rules included in a style tag in the head portion of an HTML document.
- **Inline styles** Defined within specific instances of tags throughout an HTML document. (Using Inline styles is not recommended.)

Dreamweaver recognizes styles defined in existing documents as long as they conform to CSS style guidelines. Dreamweaver also renders most applied styles directly in Design view. (Previewing the document in a browser window, however, gives you the most accurate “live” rendering of the page.) Some CSS styles are rendered differently in Microsoft Internet Explorer, Netscape, Opera, Apple Safari, or other browsers, and some are not currently supported by any browser.

To display the O’Reilly CSS reference guide included with Dreamweaver, select Help > Reference and select O’Reilly CSS Reference from the pop-up menu in the Reference panel.

**More Help topics**

“Apply, remove, or rename CSS class styles” on page 136

Last updated 12/7/2011
**About cascading styles**

The term *cascading* refers to the way a browser ultimately displays styles for specific elements on a web page. Three different sources are responsible for the styles you see on a web page: the style sheet created by the author of the page, the user’s customized style selections (if any), and the default styles of the browser itself. The previous topics describe creating styles for a web page as the author of both the web page and the style sheet attached to that page. But browsers also have their own default style sheets that dictate the rendering of web pages, and in addition to that, users can customize their browsers by making selections that adjust the display of web pages. The final appearance of a web page is the result of the rules of all three of these sources coming together (or “cascading”) to render the web page in an optimal way.

A common tag—the paragraph tag, or `<p>` tag—illustrates the concept. By default, browsers come with style sheets that define the font and font size for paragraph text (that is, text that falls between `<p>` tags in the HTML code). In Internet Explorer, for example, all body text, including paragraph text, displays in Times New Roman, Medium font by default. As the author of a web page, however, you can create a style sheet that overrides the browser’s default style for paragraph font and font size. For example, you can create the following rule in your style sheet:

```css
p {
  font-family: Arial;
  font-size: small;
}
```

When a user loads the page, the paragraph font and font size settings set by you as the author override the default paragraph text settings of the browser.

Users can make selections to customize the browser display in an optimal way for their own use. In Internet Explorer, for example, the user can select View > Text Size > Largest to expand the page font to a more readable size if they think the font is too small. Ultimately (at least in this case), the user’s selection overrides both the default browser styles for paragraph font size and the paragraph styles created by the author of the web page.

Inheritance is another important part of the cascade. Properties for most elements on a web page are inherited—for example, paragraph tags inherit certain properties from body tags, span tags inherit certain properties from paragraph tags, and so on. Thus, if you create the following rule in your style sheet:

```css
body {
  font-family: Arial;
  font-style: italic;
}
```

All paragraph text on your web page (as well as text that inherits properties from the paragraph tag) will be Arial and italic because the paragraph tag inherits these properties from the body tag. You can, however, become more specific with your rules, and create styles that override the standard formula for inheritance. For example, if you create the following rules in your style sheet:

```css
body {
  font-family: Arial;
  font-style: italic;
}

p {
  font-family: Courier;
  font-style: normal;
}
```
All body text will be Arial and italic except paragraph (and its inherited) text, which will display as Courier normal (non-italic). Technically, the paragraph tag first inherits the properties that are set for the body tag, but then ignores those properties because it has properties of its own defined. In other words, while page elements generally inherit properties from above, the direct application of a property to a tag always causes an override of the standard formula for inheritance.

The combination of all of the factors discussed above, plus other factors like CSS specificity (a system that gives different weight to particular kinds of CSS rules), and the order of CSS rules, ultimately create a complex cascade where items with higher priorities override properties that have lower priorities. For more information on the rules governing the cascade, inheritance, and specificity, visit www.w3.org/TR/CSS2/cascade.html.

**About text formatting and CSS**

By default, Dreamweaver uses Cascading Style Sheets (CSS) to format text. The styles that you apply to text using the Property inspector or menu commands create CSS rules that are embedded in the head of the current document.

You can also use the CSS Styles panel to create and edit CSS rules and properties. The CSS Styles panel is a much more robust editor than the Property inspector, and displays all CSS rules defined for the current document, whether those rules are embedded in the head of the document or in an external style sheet. Adobe recommends that you use the CSS Styles panel (rather than the Property inspector) as the primary tool for creating and editing your CSS. As a result, your code will be cleaner and easier to maintain.

In addition to styles and style sheets you create, you can use style sheets that come with Dreamweaver to apply styles to your documents.

For a tutorial about formatting text with CSS, see www.adobe.com/go/vid0153.

**More Help topics**

“The CSS Styles panel” on page 122

“Create a new CSS rule” on page 128

Formatting text with CSS tutorial

**About Shorthand CSS properties**

The CSS specification allows for the creation of styles using an abbreviated syntax known as *shorthand CSS*. Shorthand CSS lets you specify the values of several properties using a single declaration. For example, the `font` property lets you set `font-style`, `font-variant`, `font-weight`, `font-size`, `line-height`, and `font-family` properties on a single line.

A key issue to note when using shorthand CSS, is that values omitted from a shorthand CSS property are assigned their default value. This may cause pages to be incorrectly displayed when two or more CSS rules are assigned to the same tag.

For example, the `h1` rule shown below uses longhand CSS syntax. Note that the `font-variant`, `font-stretch`, `font-size-adjust`, and `font-style` properties have been assigned their default values.

---

Last updated 12/7/2011
Rewritten as a single, shorthand property, the same rule might appear as follows:

```css
h1 { font: bold 16pt/18pt Arial }
```

When written using shorthand notation, omitted values are automatically assigned their default values. Thus, the previous shorthand example omits the `font-variant`, `font-style`, `font-stretch`, and `font-size-adjust` tags.

If you have styles defined in more than one location (for example, both embedded in an HTML page and imported from an external style sheet) using both the short and long forms of CSS syntax, be aware that omitted properties in a shorthand rule may override (or cascade) properties that are explicitly set in another rule.

For this reason, Dreamweaver uses the long form of CSS notation by default. This prevents possible problems caused by a shorthand rule overriding a longhand rule. If you open a web page that was coded with shorthand CSS notation in Dreamweaver, be aware that Dreamweaver will create any new CSS rules using the longhand form. You can specify how Dreamweaver creates and edits CSS rules by changing the CSS editing preferences in the CSS Styles category of the Preferences dialog box (Edit > Preferences in Windows; Dreamweaver > Preferences on the Macintosh).

**Note:** The CSS Styles panel creates rules using only longhand notation. If you create a page or CSS style sheet using the CSS Styles panel, be aware that hand coding shorthand CSS rules may result in the shorthand properties overriding those created in longhand form. For this reason, use longhand CSS notation to create your styles.

### The CSS Styles panel

The CSS Styles panel lets you track the CSS rules and properties affecting a currently selected page element (Current mode), or all of the rules and properties that are available to the document (All mode). A toggle button at the top of panel lets you switch between the two modes. The CSS Styles panel also lets you modify CSS properties in both All and Current mode.
The CSS Styles panel in Current mode

In Current mode, the CSS Styles panel displays three panes: a Summary for Selection pane that displays the CSS properties for the current selection in the document, a Rules pane that displays the location of selected properties (or a cascade of rules for the selected tag, depending on your selection), and a Properties pane that lets you edit CSS properties for the rule applied to the selection.

You can resize any of the panes by dragging the borders between the panes, and can resize columns by dragging dividers.

The Summary for Selection pane displays a summary of CSS properties and their values for the item currently selected in the active document. The summary shows the properties for all rules that directly apply to the selection. Only set properties are shown.

For example, the following rules create a class style and a tag (in this case paragraph) style:

```
.foo{
  color: green;
  font-family: 'Arial';
}
p{
  font-family: 'serif';
  font-size: 12px;
}
```

When you select paragraph text with a class style of .foo in the Document window, the Summary for Selection pane displays the relevant properties for both rules, because both rules apply to the selection. In this case, the Summary for Selection pane would list the following properties:

```
font-size: 12px
font-family: 'Arial'
color: green
```
The Summary for Selection pane arranges properties in increasing order of specificity. In the above example, the tag style defines the font size and the class style defines the font family and the color. (The font family defined by the class style overrides the font family defined by the tag style because class selectors have higher specificity than tag selectors. For more information on CSS specificity, see www.w3.org/TR/CSS2/cascade.html.)

The Rules pane displays two different views—About view or Rules view—depending on your selection. In About view (the default view), the pane displays the name of the rule that defines the selected CSS property, and the name of the file containing the rule. In Rules view, the pane displays a cascade, or hierarchy, of all rules that apply directly or indirectly to the current selection. (The tag to which the rule directly applies appears in the right column.) You can toggle between the two views by clicking the Show Information and Show Cascade buttons in the upper-right corner of the Rules pane.

When you select a property in the Summary for Selection pane, all of the properties for the defining rule appear in the Properties pane. (The defining rule is also selected in the Rules pane, if Rules view is selected.) For example, if you have a rule called .maintext that defines a font family, font size, and color, then selecting any of those properties in the Summary for Selection pane will display all of the properties defined by the .maintext rule in the Properties pane, as well as the selected .maintext rule in the Rules pane. (Additionally, selecting any rule in the Rules pane displays that rule’s properties in the Properties pane.) You can then use the Properties pane to quickly modify your CSS, whether it is embedded in the current document or linked by means of an attached style sheet. By default, the Properties pane shows only those properties that have already been set, and arranges them in alphabetical order.

You can choose to display the Properties pane in two other views. Category view displays properties grouped into categories, such as Font, Background, Block, Border, and so on, with set properties at the top of each category, displayed in blue text. List view displays an alphabetical list of all available properties, and likewise sorts set properties to the top, displaying them in blue text. To switch between views, click the Show Category View, Show List View, or Show Only Set Properties button, located at the lower-left corner of the Properties pane.

In all views, set properties are displayed in blue; properties irrelevant to a selection are displayed with a red strike-through line. Holding the mouse over a rule that is irrelevant displays a message explaining why the property is irrelevant. Typically a property is irrelevant because it’s overridden or not an inherited property.

Any changes you make in the Properties pane are applied immediately, letting you preview your work as you go.

More Help topics
“Open the CSS Styles panel” on page 126
The CSS Styles panel in All mode

In All mode, the CSS Styles panel displays two panes: an All Rules pane (on top), and a Properties pane (on bottom). The All Rules pane displays a list of rules defined in the current document as well as all rules defined in style sheets attached to the current document. The Properties pane lets you edit CSS properties for any selected rule in the All Rules pane.

You can resize either pane by dragging the border between the panes, and can resize the Properties columns by dragging their divider.

When you select a rule in the All Rules pane, all of the properties that are defined in that rule appear in the Properties pane. You can then use the Properties pane to quickly modify your CSS, whether it is embedded in the current document or linked in an attached style sheet. By default, the Properties pane shows only those properties that have been previously set, and arranges them in alphabetical order.

You can choose to display properties in two other views. Category view displays properties grouped into categories, such as Font, Background, Block, Border, and so on, with set properties at the top of each category. List view displays an alphabetical list of all available properties, and likewise sorts set properties to the top. To switch between views, click the Show Category View, Show List View, or Show Only Set Properties button, located at the lower-left corner of the Properties pane. In all views, set properties are displayed in blue.

Any changes you make in the Properties pane are applied immediately, letting you preview your work as you go.

More Help topics

“Open the CSS Styles panel” on page 126

CSS Styles panel buttons and views

In both All and Current modes, the CSS Styles panel contains three buttons that let you alter the view in the Properties pane (the bottom pane):
Category View  Divides the Dreamweaver-supported CSS properties into eight categories: font, background, border, box, list, positioning, and extensions. Each category’s properties are contained in a list that you expand or collapse by clicking the Plus (+) button next to the category name. Set properties appear (in blue) at the top of the list.

List View  Displays all of the Dreamweaver-supported CSS properties in alphabetical order. Set properties appear (in blue) at the top of the list.

Set Properties View  Displays only those properties that have been set. Set Properties view is the default view.

In both All and Current modes, the CSS Styles panel also contains the following buttons:

Attach Style Sheet  Opens the Link External Style Sheet dialog box. Select an external style sheet to link to or import into your current document.

New CSS Rule  Opens a dialog box in which you can select the type of style you’re creating—for example, to create a class style, redefine an HTML tag, or to define a CSS selector.

Edit Style  Opens a dialog box in which you can edit the styles in the current document or in an external style sheet.

Delete CSS Rule  Removes the selected rule or property from the CSS Styles panel, and removes the formatting from any element to which it was applied. (It does not, however, remove class or ID properties referenced by that style). The Delete CSS Rule button can also detach (or “unlink”) an attached CSS style sheet.

Right-click (Windows) or Control-click (Macintosh) the CSS Styles panel to open a context menu of options for working with CSS style sheet commands.

Open the CSS Styles panel
You use the CSS Styles panel to view, create, edit, and remove CSS styles, as well as to attach external style sheets to documents.

Do one of the following:

• Select Window > CSS Styles.
• Press Shift+F11.
• Click the CSS button in the Property inspector.

Enhancements to CSS3 support in the CSS styles panel (CS5.5)
A pop-up panel has been introduced in the CSS panel for the following properties:

• text-shadow
• box-shadow
• border-radius
• border-image

The options in the pop-up panel ensure that you apply the property correctly even if you are unfamiliar with their W3C syntax.

The pop-up panel displaying options for the CSS3 property border-image

Apply CSS3 properties using the pop-up panel
❖ Click the “+” icon corresponding to these properties. Use the options in the pop-up panel to apply the property.

Specifying multiple value-sets

CSS3 properties like text-shadow support multiple value sets. For example:

text-shadow: 3px 3px #000, -3px -3px #0f0;

When you specify multiple value-sets in the code view and open the pop-up panel for editing, only the first value-set is displayed. If you edit this value-set in the pop-up panel, only the first value-set in the code is affected. The other value-sets are unaffected, and applied as specified in the code.

Locate properties in the Category view

In the category view, text-shadow is listed under the Font category. box-shadow, border-radius, and border-image are listed under the Border category.

Ensuring compliance with browsers

Dreamweaver CS5.5 also supports browser (webkit, Mozilla) specific implementation of box-shadow, border-radius, and border-image properties.

In the Category view, use the options under the respective browser category to ensure browser compliance for these properties. For example, to comply with Mozilla’s implementation of the border-image property, edit -moz-border-image in the Mozilla category.

Preview changes in Live view

Changes made to CSS properties are not displayed in the Design view. Switch to Live view to preview changes. You can also make quick edits to CSS3 properties in the Live view, and the changes are immediately reflected in this view.
The following CSS3 properties are supported in Live View:

- text-shadow
- border-radius
- -webkit-box-shadow
- -webkit-border-image

**Set CSS Styles preferences**

CSS style preferences control how Dreamweaver writes the code that defines CSS styles. CSS styles can be written in a shorthand form that some people find easier to work with. Some older versions of browsers, however, do not correctly interpret the shorthand.

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh) and from the Category list select CSS Styles.
2. Set the CSS style options you want to apply:
   - **When Creating CSS Rules Use Shorthand For** Lets you select which CSS style properties Dreamweaver writes in shorthand.
   - **When Editing CSS Rules Use Shorthand** Controls whether Dreamweaver rewrites existing styles in shorthand.
     - Select If Original Used Shorthand to leave all styles as they are.
     - Select According to Settings Above to rewrite styles in shorthand for the properties selected in Use Shorthand For.
   - **When Double-Clicking In CSS Panel** Lets you select a tool for editing CSS rules.
3. Click OK.

**Create a new CSS rule**

You can create a CSS rule to automate the formatting of HTML tags or a range of text identified by `class` or `ID` attributes.

1. Place the insertion point in the document, and then do one of the following to open the New CSS Rule dialog box:
   - Select Format > CSS Styles > New.
   - In the CSS Styles panel (Window > CSS Styles), click the New CSS Rule (+) button located in the lower-right side of the panel.
   - Select text in the Document window, select New CSS Rule from the Targeted Rule pop-up menu in the CSS Property inspector (Window > Properties); then click the Edit Rule button or select an option from the Property inspector (for example, click the Bold button), to initiate a new rule.
2. In the New CSS Rule dialog box, specify the selector type for the CSS rule you want to create:
   - To create a custom style that can be applied as a `class` attribute to any HTML element, select the Class option from the Selector Type pop-up menu and then enter a name for the style in the Selector Name text box.

   **Note:** Class names must begin with a period and can contain any combination of letters and numbers (for example, `.myhead1`). If you don’t enter a beginning period, Dreamweaver automatically enters it for you.
• To define the formatting for a tag that contains a specific ID attribute, select the ID option from the Selector Type pop-up menu and then enter the unique ID (for example, containerDIV) in the Selector Name text box.  

Note: IDs must begin with a pound (#) sign and can contain any combination of letters and numbers (for example, #myID1). If you don’t enter a beginning pound sign, Dreamweaver automatically enters it for you.

• To redefine the default formatting of a specific HTML tag, select the Tag option from the Selector Type pop-up menu; then enter an HTML tag in the Selector Name text box or select one from the pop-up menu.

• To define a compound rule that affects two or more tags, classes, or IDs simultaneously, select the Compound option and enter the selectors for your compound rule. For example if you enter div p, all p elements within div tags will be affected by the rule. A description text area explains exactly which elements the rule will affect as you add or delete selectors.

3 Select the location in which you want to define the rule, and then click OK:

• To place the rule in a style sheet that is already attached to the document, select the style sheet.

• To create an external style sheet, select New Style Sheet File.

• To embed the style in the current document, select This Document Only.

4 In the CSS Rule Definition dialog box, select the style options you want to set for the new CSS rule. For more information, see the next section.

5 When you are finished setting style properties, click OK.

Note: Clicking OK without setting style options results in a new, empty rule.

Set CSS properties

You can define properties for CSS rules such as text font, background image and color, spacing and layout properties, and the appearance of list elements. First create a new rule, then set any of the following properties.

Define CSS type properties

You use the Type category in the CSS Rule Definition dialog box to define basic font and type settings for a CSS style.

1 Open the CSS Styles panel (Shift + F11) if it isn’t already open.

2 Double-click an existing rule or property in the top pane of the CSS Styles panel.

3 In the CSS Rule Definition dialog box, select Type, and then set the style properties.

Leave any of the following properties empty if they are not important to the style:

Font-family Sets the font family (or series of families) for the style. Browsers display text in the first font in the series that is installed on the user’s system. For compatibility with Internet Explorer 3.0, list a Windows font first. The font attribute is supported by both browsers.

Font-size Defines the size of the text. You can choose a specific size by selecting the number and the unit of measurement, or you can choose a relative size. Pixels work well to prevent browsers from distorting your text. The size attribute is supported by both browsers.

Font-style Specifies Normal, Italic, or Oblique as the font style. The default setting is Normal. The style attribute is supported by both browsers.
**Line-height** Sets the height of the line on which the text is placed. This setting is traditionally called *leading*. Select Normal to have the line height for the font size calculated automatically, or enter an exact value and select a unit of measurement. The line height attribute is supported by both browsers.

**Text-decoration** Adds an underline, overline, or line-through to the text, or makes the text blink. The default setting for regular text is None. The default setting for links is Underline. When you set the link setting to none, you can remove the underline from links by defining a special class. The decoration attribute is supported by both browsers.

**Font-weight** Applies a specific or relative amount of boldface to the font. Normal is equivalent to 400; Bold is equivalent to 700. The weight attribute is supported by both browsers.

**Font-variant** Sets the small caps variant on text. Dreamweaver does not display this attribute in the Document window. The variant attribute is supported by Internet Explorer but not Navigator.

**Text-transform** Capitalizes the first letter of each word in the selection or sets the text to all uppercase or lowercase. The case attribute is supported by both browsers.

**Color** Sets the text color. The color attribute is supported by both browsers.

4 When you are finished setting these options, select another CSS category on the left side of the panel to set additional style properties, or click OK.

**Define CSS style background properties**

Use the Background category of the CSS Rule Definition dialog box to define background settings for a CSS style. You can apply background properties to any element in a web page. For example, create a style which adds a background color or background image to any page element, for example behind text, a table, the page, and so on. You can also set the positioning of a background image.

1 Open the CSS Styles panel (Shift+F11) if it isn’t already open.

2 Double-click an existing rule or property in the top pane of the CSS Styles panel.

3 In the CSS Rule Definition dialog box, select Background, then set the style properties.

Leave any of the following properties empty if they are not important to the style:

**Background Color** Sets the background color for the element. The background color attribute is supported by both browsers.

**Background Image** Sets the background image for the element. The background image attribute is supported by both browsers.

**Background Repeat** Determines whether and how the background image is repeated. The Repeat attribute is supported by both browsers.

- No Repeat displays the image once at the beginning of the element.
- Repeat tiles the image horizontally and vertically behind the element.
- Repeat-x and Repeat-y display a horizontal and vertical band of images, respectively. Images are clipped to fit within the boundaries of the element.

**Note:** Use the Repeat property to redefine the `<body>` tag and set a background image that does not tile or repeat.

**Background Attachment** Determines whether the background image is fixed at its original position or scrolls along with the content. Note that some browsers may treat the Fixed option as Scroll. This is supported by Internet Explorer but not Netscape Navigator.

**Background Position (X) and Background Position (Y)** Specify the initial position of the background image in relation to the element. This can be used to align a background image to the center of the page, both vertically (Y) and
horizontally (X). If the attachment property is Fixed, the position is relative to the Document window, not to the
element.

4 When you are finished setting these options, select another CSS category on the left side of the panel to set
additional style properties, or click OK.

**Define CSS style block properties**

You use the Block category of the CSS Rule Definition dialog box to define spacing and alignment settings for tags and
properties.

1 Open the CSS Styles panel (Shift+F11) if it isn’t already open.

2 Double-click an existing rule or property in the top pane of the CSS Styles panel.

3 In the CSS Rule Definition dialog box, select Block, then set any of the following style properties. (Leave the
property blank if it is not important to the style.)

- **Word Spacing** Sets the spacing between words. To set a specific value, in the pop-up menu, select Value, then enter a
numeric value. In the second pop-up menu, select a measurement unit (for example, pixel, points, and so on).

  **Note:** You can specify negative values, but the display depends on the browser. Dreamweaver does not display this
attribute in the Document window.

- **Letter Spacing** Increases or decreases space between letters or characters. To decrease the space between
characters specify a negative value, for example (-4). Letter spacing settings override justified text settings. The Letter Spacing
attribute is supported by Internet Explorer 4 and later and Netscape Navigator 6.

- **Vertical Align** Specifies the vertical alignment of the element to which it is applied. Dreamweaver displays this
attribute in the Document window only when it is applied to the `<img>` tag.

- **Text Align** Sets how text is aligned within the element. The Text Align attribute is supported by both browsers.

- **Text Indent** Specifies how far the first line of text indents. A negative value may be used to create an outdent, but the
display depends on the browser. Dreamweaver displays this attribute in the Document window only when the tag is
applied to block-level elements. The Text Indent attribute is supported by both browsers.

- **Whitespace** Determines how white space within the element is handled. Select from three options: Normal collapses
white space; Pre handles it as if the text were enclosed in `<pre>` tags (that is, all white space, including spaces, tabs, and
returns, is respected); Nowrap specifies that the text only wraps when a `<br>` tag is encountered. Dreamweaver does not
display this attribute in the Document window. The Whitespace attribute is supported by Netscape Navigator and
Internet Explorer 5.5.

- **Display** Specifies whether an element is displayed and if so how it is displayed. None disables the display of an element
to which it is assigned.

4 When you are finished setting these options, select another CSS category on the left side of the panel to set
additional style properties, or click OK.

**Define CSS style box properties**

Use the Box category of the CSS Rule Definition dialog box to define settings for tags and properties that control the
placement of elements on the page.

You can apply settings to individual sides of an element when applying padding and margin settings, or use the Same
For All setting to apply the same setting to all sides of an element.

1 Open the CSS Styles panel (Shift + F11) if it isn’t already open.
2 Double-click an existing rule or property in the top pane of the CSS Styles panel.

3 In the CSS Rule Definition dialog box, select Box, and set any of the following style properties. (Leave the property blank if it is not important to the style.)

   **Width and Height** Sets the width and height of the element.

   **Float** Sets which side other elements, such as text, AP Divs, tables and so on, will float around an element. Other elements wrap around the floating element as usual. The Float attribute is supported by both browsers.

   **Clear** Defines the sides that do not allow AP elements. If an AP element appears on the clear side, the element with the clear setting moves below it. The Clear attribute is supported by both browsers.

   **Padding** Specifies the amount of space between the content of an element and its border (or margin if there is no border). Deselect the Same For All option to set the padding for individual sides of the element.

   **Same For All** Sets the same padding properties to the Top, Right, Bottom, and Left of the element to which it is applied.

   **Margin** Specifies the amount of space between the border of an element (or the padding if there is no border) and another element. Dreamweaver displays this attribute in the Document window only when it is applied to block-level elements (paragraphs, headings, lists, and so on). Deselect Same For All to set the margin for individual sides of the element.

   **Same For All** Sets the same margin properties to the Top, Right, Bottom, and Left of the element to which it is applied.

4 When you are finished setting these options, select another CSS category on the left side of the panel to set additional style properties, or click OK.

### Define CSS style border properties

Use the Border category of the CSS Rule Definition dialog box to define settings, such as width, color, and style, for the borders around elements.

1 Open the CSS Styles panel (Shift+F11) if it isn’t already open.

2 Double-click an existing rule or property in the top pane of the CSS Styles panel.

3 In the CSS Rule Definition dialog box, select Border, and set any of the following style properties. (Leave the property blank if it is not important to the style.)

   **Type** Sets the style appearance of the border. The way the style appears depends on the browser. Deselect Same For All to set the border style for individual sides of the element.

   **Same For All** Sets the same border style properties to the Top, Right, Bottom, and Left of the element to which it is applied.

   **Width** Sets the thickness of the element’s border. The Width attribute is supported by both browsers. Deselect Same For All to set the border width for individual sides of the element.

   **Same For All** Sets the same border width to the Top, Right, Bottom, and Left of the element to which it is applied.

   **Color** Sets the color of the border. You can set each side’s color independently, but the display depends on the browser. Deselect Same For All to set the border color for individual sides of the element.

   **Same For All** Sets the same border color to the Top, Right, Bottom, and Left of the element to which it is applied.

4 When you are finished setting these options, select another CSS category on the left side of the panel to set additional style properties, or click OK.
**Define CSS style list properties**

The List category of the CSS Rule Definition dialog box defines list settings, such as bullet size and type, for list tags.

1. Open the CSS Styles panel (Shift+F11) if it isn’t already open.
2. Double-click an existing rule or property in the top pane of the CSS Styles panel.
3. In the CSS Rule Definition dialog box, select List, and set any of the following style properties. (Leave the property blank if it is not important to the style.)
   - **List style type** Sets the appearance of bullets or numbers. Type is supported by both browsers.
   - **List style image** Lets you specify a custom image for bullets. Click Browse (Windows) or Choose (Macintosh) to browse to an image, or type the image’s path.
   - **List style position** Sets whether list item text wraps and indents (outside) or whether the text wraps to the left margin (inside).
4. When you are finished setting these options, select another CSS category on the left side of the panel to set additional style properties, or click OK.

**Define CSS style positioning properties**

The Positioning style properties determine how the content related to the selected CSS style is positioned on the page.

1. Open the CSS Styles panel (Shift+F11) if it isn’t already open.
2. Double-click an existing rule or property in the top pane of the CSS Styles panel.
3. In the CSS Rule Definition dialog box, select Positioning, and then set the style properties you want.

Leave any of the following properties empty if they are not important to the style:

- **Position** Determines how the browser should position the selected element as follows:
  - *Absolute* places the content using the coordinates entered in the Placement boxes relative to the nearest absolutely- or relatively-positioned ancestor, or, if no absolutely- or relatively-positioned ancestor exists, to the upper-left corner of the page.
  - *Relative* places the content block using the coordinates entered in the Placement boxes relative to block’s position in the text flow of the document. For example, giving an element a relative position and top and left coordinates of 20px each will shift the element 20px to the right and 20px down from its normal position in the flow. Elements can also be positioned relatively, with or without top, left, right, or bottom coordinates, to establish a context for absolutely-positioned children.
  - *Fixed* places the content using the coordinates entered in the Placement boxes, relative to the top left corner of the browser. The content will remain fixed in this position as the user scrolls the page.
  - *Static* places the content at its location in the text flow. This is the default position of all positionable HTML elements.

- **Visibility** Determines the initial display condition of the content. If you do not specify a visibility property, by default the content inherits the parent tag’s value. The default visibility of the body tag is visible. Select one of the following visibility options:
  - *Inherit* inherits the visibility property of the content’s parent.
  - *Visible* displays the content, regardless of the parent’s value.
  - *Hidden* hides the content, regardless of the parent’s value.
Z-Index Determines the stacking order of the content. Elements with a higher z-index appear above elements with a lower z-index (or none at all). Values can be positive or negative. (If your content is absolutely positioned, it’s easier to change the stacking order using the AP Elements panel).

Overflow Determines what happens if the contents of a container (for example, a DIV or a P) exceed its size. These properties control the expansion as follows:

- Visible increases the container’s size so that all of its contents are visible. The container expands down and to the right.
- Hidden maintains the container’s size and clips any content that doesn’t fit. No scroll bars are provided.
- Scroll adds scroll bars to the container regardless of whether the contents exceed the container’s size. Specifically providing scroll bars avoids confusion caused by the appearance and disappearance of scroll bars in a dynamic environment. This option is not displayed in the Document window.
- Auto makes scroll bars appear only when the container’s contents exceed its boundaries. This option is not displayed in the Document window.

Placement Specifies the location and size of the content block. How the browser interprets the location depends on the setting for Type. Size values are overridden if the content of the content block exceeds the specified size.

The default units for location and size are pixels. You can also specify the following units: pc (picas), pt (points), in (inches), mm (millimeters), cm (centimeters), (ems), (exs), or % (percentage of the parent’s value). The abbreviations must follow the value without a space: for example, 3mm.

Clip Defines the part of the content that is visible. If you specify a clipping region, you can access it with a scripting language such as JavaScript and manipulate the properties to create special effects such as wipes. These wipes can be set up by using the Change Property behavior.

When you are finished setting these options, select another CSS category on the left side of the panel to set additional style properties, or click OK.

Define CSS style extension properties

Extensions style properties include filters, page break, and pointer options.

Note: There are a number of other extension properties available in Dreamweaver, but to access them, you need to go through the CSS Styles panel. You can easily see a list of extension properties available by opening the CSS Styles panel (Windows > CSS Styles), clicking the Show Category View button at the bottom of the panel, and expanding the Extensions category.

1 Open the CSS Styles panel (Shift + F11) if it isn’t already open.
2 Double-click an existing rule or property in the top pane of the CSS Styles panel.
3 In the CSS Rule Definition dialog box, select Extensions, and set any of the following style properties. (Leave the property blank if it is not important to the style.)

Page break before Forces a page break during printing either before or after the object controlled by the style. Select the option you want to set in the pop-up menu. This option is not supported by any 4.0 browser, but support may be provided by future browsers.

Cursor Changes the pointer image when the pointer is over the object controlled by the style. Select the option you want to set in the pop-up menu. Internet Explorer 4.0 and later, and Netscape Navigator 6 support this attribute.

Filter Applies special effects to the object controlled by the style, including blur and inversion. Select an effect from the pop-up menu.
4. When you are finished setting these options, select another CSS category on the left side of the panel to set additional style properties, or click OK.

**Edit a CSS rule**

You can easily edit both internal and external rules that you have applied to a document.

When you edit a CSS style sheet that controls the text in your document, you instantly reformat all of the text controlled by that CSS style sheet. Edits to an external style sheet affect all the documents linked to it.

You can set an external editor to use for editing style sheets.

**Edit a rule in the CSS Styles panel (Current mode)**

1. Open the CSS Styles panel by selecting Window > CSS Styles.
2. Click the Current button at the top of the CSS Styles panel.
3. Select a text element in the current page to display its properties.
4. Do one of the following:
   - Double-click a property in the Summary for Selection pane to display the CSS Rule Definition dialog box, and then make your changes.
   - Select a property in the Summary for Selection pane, and then edit the property in the Properties pane below.
   - Select a rule in the Rules pane, and then edit the rule’s properties in the Properties pane below.

*Note:* You can change the double-clicking behavior for editing CSS, as well as other behaviors, by changing Dreamweaver preferences.

**Edit a rule in the CSS Styles panel (All mode)**

1. Open the CSS Styles panel by selecting Window > CSS Styles.
2. Click the All button at the top of the CSS Styles panel.
3. Do one of the following:
   - Double-click a rule in the All Rules pane to display the CSS Rule Definition dialog box, and then make your changes.
   - Select a rule in the All Rules pane, and then edit the rule’s properties in the Properties pane below.
   - Select a rule in the All Rules pane, and then click the Edit Style button in the lower-right corner of the CSS Styles panel.

*Note:* You can change the double-clicking behavior for editing CSS, as well as other behaviors, by changing Dreamweaver preferences.

**Change the name of a CSS selector**

1. In the CSS Styles panel (All mode) select the selector you want to change.
2. Click the selector again to make the name editable.
3. Make your changes and press Enter (Windows) or Return (Macintosh).
More Help topics
“Set text properties in the Property inspector” on page 217

Add a property to a CSS rule

You can use the CSS Styles panel to add properties to rules.

1  In the CSS Styles panel (Window > CSS), select a rule in the All Rules pane (All mode), or select a property in the Summary for Selection pane (Current mode).

2  Do one of the following:
   •  If Show Only Set Properties view is selected in the Properties pane, click the Add Properties link and add a property.
   •  If Category view or List view is selected in the Properties pane, fill in a value for the property you want to add.

Apply, remove, or rename CSS class styles

Class styles are the only type of CSS style that can be applied to any text in a document, regardless of which tags control the text. All class styles associated with the current document are displayed in the CSS Styles panel (with a period [. ] preceding their name) and in the Style pop-up menu of the text Property inspector.

You’ll see most styles updated immediately, however, you should preview your page in a browser to verify a style was applied as expected. When you apply two or more styles to the same text, the styles may conflict and produce unexpected results.

💡 When previewing styles defined in an external CSS style sheet, be sure to save the style sheet to ensure that your changes are reflected when you preview the page in a browser.

More Help topics
“About Cascading Style Sheets” on page 118
“About cascading styles” on page 120
“The CSS Styles panel” on page 122

Apply a CSS class style

1  In the document, select the text to which you want to apply a CSS style.

Place the insertion point in a paragraph to apply the style to the entire paragraph.

If you select a range of text within a single paragraph, the CSS style affects only the selected range.

To specify the exact tag to which the CSS style should be applied, select the tag in the tag selector located at the lower left of the Document window.

2  To apply a class style, do one of the following:
   •  In the CSS Styles panel (Window > CSS Styles), select All mode, right-click the name of the style you want to apply, and select Apply from the context menu.
   •  In the HTML Property inspector, select the class style you want to apply from the Class pop-up menu.
In the Document window, right-click (Windows) or Control-click (Macintosh) the selected text, and in the context menu, select CSS Styles and then select the style you want to apply.

Select Format > CSS Styles, and in the submenu select the style you want to apply.

Remove a class style from a selection
1. Select the object or text you want to remove the style from.
2. In the HTML Property inspector (Window > Properties), select None from the Class pop-up menu.

Rename a class style
1. In the CSS styles panel, right-click the CSS class style you want to rename and select Rename Class.

   You can also rename a class by selecting Rename Class from the CSS Styles panel options menu.

2. In the Rename Class dialog box, make sure that the class you want to rename is selected in the Rename Class pop-up menu.
3. In the New Name text box, enter the new name for the new class and click OK.

   If the class you’re renaming is internal to the head of the current document, Dreamweaver changes the class name as well as all instances of the class name in the current document. If the class you’re renaming is in an external CSS file, Dreamweaver opens and changes the class name in the file. Dreamweaver also launches a site-wide Find and Replace dialog box so that you can search for all instances of the old class name in your site.

Move/export CSS rules

The CSS management features in Dreamweaver make it easy for you to move or export CSS rules to different locations. You can move rules from document to document, from the head of a document to an external style sheet, between external CSS files, and more.

   Note: If the rule you’re trying to move conflicts with a rule in the destination style sheet, Dreamweaver displays the Rule With Same Name Exists dialog box. If you elect to move the conflicting rule, Dreamweaver places the moved rule immediately adjacent to the conflicting rule in the destination style sheet.

More Help topics
“Insert code with the Coding toolbar” on page 296

Move/export CSS rules to a new style sheet
1. Do one of the following:
   - In the CSS Styles panel, select the rule or rules you want to move. Then right-click the selection and select Move CSS Rules from the context menu. To select multiple rules, Control-click (Windows) or Command-click (Macintosh) the rules you want to select.
   - In Code view, select the rule or rules you want to move. Then right-click the selection and select CSS Styles > Move CSS Rules from the context menu.
   
   Note: Partial selection of a rule will result in the relocation of the entire rule.

2. In the Move To External Style Sheet dialog box, select the new style sheet option and click OK.

Last updated 12/7/2011
In the Save Style Sheet File As dialog box, enter a name for the new style sheet and click Save. When you click Save, Dreamweaver saves a new style sheet with the rules you selected and attaches it to the current document.

You can also move rules by using the Coding toolbar. The Coding toolbar is available in Code view only.

**Move/export CSS rules to an existing style sheet**

1. Do one of the following:
   - In the CSS Styles panel, select the rule or rules you want to move. Then right-click the selection and select Move CSS Rules from the context menu. To select multiple rules, Control-click (Windows) or Command-click (Macintosh) the rules you want to select.
   - In Code view, select the rule or rules you want to move. Then right-click the selection and select CSS Styles > Move CSS Rules from the context menu.

   **Note:** Partial selection of a rule will result in the relocation of the entire rule.

2. In the Move To External Style Sheet dialog box, select an existing style sheet from the pop-up menu or browse to an existing style sheet and click OK.

   **Note:** The pop-up menu displays all style sheets that are linked to the current document.

   You can also move rules by using the Coding toolbar. The Coding toolbar is available in Code view only.

**Rearrange or move CSS rules by dragging**

- In the CSS Styles panel (All mode), select a rule and drag it rule to the desired location. You can select and drag to re-order rules within a style sheet, or move a rule to another style sheet or the document head.

   You can move more than one rule at a time by Control-clicking (Windows) or Command-clicking (Macintosh) multiple rules to select them.

**Select multiple rules before moving them**

- In the CSS Styles panel, Control-click (Windows) or Command-click (Macintosh) the rules you want to select.

**Convert inline CSS to a CSS rule**

In-line styles are not recommended best practices. To make your CSS cleaner and more organized, you can convert inline styles to CSS rules that reside in the head of the document or in an external style sheet.

1. In Code view (View > Code), select the entire style attribute that contains the inline CSS you want to convert

2. Right-click and select CSS Styles > Convert Inline CSS to Rule.

3. In the Convert Inline CSS dialog box, enter a class name for the new rule, and then do one of the following:
   - Specify a style sheet where you want the new CSS rule to appear and click OK.
   - Select the head of the document as the location where you want the new CSS rule to appear and click OK.

   You can also convert rules by using the Coding toolbar. The Coding toolbar is available in Code view only.
Link to an external CSS style sheet

When you edit an external CSS style sheet, all documents linked to that CSS style sheet are updated to reflect those edits. You can export the CSS styles found in a document to create a new CSS style sheet, and attach or link to an external style sheet to apply the styles found there.

You can attach to your pages any style sheet that you create or copy into your site. In addition, Dreamweaver is shipped with prebuilt style sheets that can be automatically moved into your site and attached to your pages.

1. Open the CSS Styles panel by doing one of the following:
   • Select Window > CSS Styles.
   • Press Shift + F11.
2. In the CSS Styles panel, click the Attach Style Sheet button. (It’s in the lower-right corner of the panel.)
3. Do one of the following:
   • Click Browse to browse to an external CSS style sheet.
   • Type the path to the style sheet in the File/URL box.
4. For Add As, select one of the options:
   • To create a link between the current document and an external style sheet, select Link. This creates a link `href` tag in the HTML code, and references the URL where the published style sheet is located. This method is supported by both Microsoft Internet Explorer and Netscape Navigator.
   • You cannot use a link tag to add a reference from one external style sheet to another. If you want to nest style sheets, you must use an import directive. Most browsers also recognize the import directive within a page (rather than just within style sheets). There are subtle differences in how conflicting properties are resolved when overlapping rules exist within external style sheets that are linked versus imported to a page. If you want to import, rather than link to, an external style sheet, select Import.
5. In the Media pop-up menu, specify the target medium for the style sheet.

For more information on media-dependent style sheets, see the World Wide Web Consortium website at www.w3.org/TR/CSS21/media.html.

6. Click the Preview button to verify that the style sheet applies the styles you want to the current page.

If the styles applied are not what you expect them to be, click Cancel to remove the style sheet. The page will revert to its previous appearance.

7. Click OK.

More Help topics

“Create a page based on a Dreamweaver sample file” on page 64
Edit a CSS style sheet

A CSS style sheet typically includes one or more rules. You can edit an individual rule in a CSS style sheet using the CSS Styles panel, or if you prefer, you can work directly in the CSS style sheet.

1. In the CSS Styles panel (Window > CSS Styles), select All mode.
2. In the All rules pane, double-click the name of the style sheet you want to edit.
3. In the Document window, modify the style sheet as desired, and then save the style sheet.

Format CSS code

You can set preferences that control the format of your CSS code whenever you create or edit a CSS rule using the Dreamweaver interface. For example, you can set preferences that will place all CSS properties on separate lines, place a blank line between CSS rules, and so on.

When you set CSS code formatting preferences, the preferences you select are automatically applied to all new CSS rules that you create. You can, however, also apply these preferences manually to individual documents. This might be useful if you have an older HTML or CSS document that needs formatting.

Note: CSS code formatting preferences apply to CSS rules in external or embedded style sheets only (not to in-line styles)

More Help topics
“Change the code format” on page 288

Set CSS code formatting preferences

1. Select Edit > Preferences.
2. In the Preferences dialog box, select the Code Format category.
3. Next to Advanced Formatting, click the CSS button.
4. In the CSS Source Format Options dialog box, select the options that you want to apply to your CSS source code. A preview of the CSS as it would look according to the options you’ve selected appears in the Preview window below.

Indent Properties With Sets the indentation value for properties within a rule. You can specify tabs or spaces.
Each Property On A Separate Line Places each property within a rule on a separate line.
Opening Brace On Separate Line Places the opening brace for a rule on a separate line from the selector.
Only If More Than One Property Places single-property rules on the same line as the selector.
All Selectors For A Rule On Same Line Places all selectors for the rule on the same line.
Blank Line Between Rules Inserts a blank line between each rule.
5. Click OK.

Note: CSS code formatting also inherits the Line Break Type preference that you set in the Code Format category of the Preferences dialog box.
Format CSS code in a CSS style sheet manually
1. Open a CSS style sheet.
2. Select Commands > Apply Source Formatting.

The formatting options you set in CSS code formatting preferences are applied to the entire document. You cannot format individual selections.

Format embedded CSS code manually
1. Open an HTML page that contains CSS embedded in the head of the document.
2. Select any part of the CSS code.
3. Select Commands > Apply Source Formatting To Selection.

The formatting options you set in CSS code formatting preferences are applied to all CSS rules in the head of the document only.

Note: You can select Commands > Apply Source Formatting to format the entire document according to your specified code formatting preferences.

Disable/Enable CSS
The Disable/Enable CSS Property feature lets you comment out portions of CSS from the CSS Styles panel, without having to make changes directly in the code. When you comment out portions of the CSS, you can see what kinds of effects particular properties and values have on your page.

When you disable a CSS property, Dreamweaver adds CSS comment tags and a [disabled] label to the CSS property you've disabled. You can then easily re-enable or delete the disabled CSS property according to your preference.

For a video overview from the Dreamweaver engineering team about working with CSS Disable/Enable, see www.adobe.com/go/dwcs5css_en.

1. In the Properties pane of the CSS Styles panel (Window > CSS Styles), select the property you want to disable.
2. Click the Disable/Enable CSS Property icon in the lower-right corner of the Properties pane. The icon also appears if you hover to the left of the property itself.
   
   Once you click the Disable/Enable CSS Property icon, a Disabled icon appears to the left of the property. To re-enable the property, click the Disabled icon, or right-click (Windows) or Control-click (Macintosh OS) the property and select Enable.

3. (Optional) To enable or delete all of the disabled properties in a selected rule, right-click (Windows) or Control-click (Macintosh OS) any rule or property in which properties are disabled, and select

4. Enable All
5. Disabled in Selected Rule, or Delete all Disabled in Selected rule.
Inspect CSS in Live view

Inspect mode works together with Live View to help you quickly identify HTML elements and their associated CSS styles. With Inspect mode turned on, you can hover over elements on your page to see the CSS box model attributes for any block-level element.

Note: For more information on the CSS box model, see the CSS 2.1 specification.

In addition to seeing a visual representation of the box model in Inspect mode, you can also use the CSS Styles panel as you hover over elements in the Document window. When you have the CSS Styles panel open in Current mode and hover over an element on the page, the rules and properties in the CSS Styles panel automatically update to show you the rules and properties for that element. Additionally, any view or panel related to the element you’re hovering over updates as well (for example, Code view, the Tag selector, the Property inspector, and so on).

1 With your document open in the Document window, click the Inspect button (next to the Live View button in the Document toolbar).

Note: If you’re not already in Live view, Inspect mode automatically enables it.

2 Hover over elements on the page to see the CSS box model. Inspect mode highlights different colors for the border, margin, padding, and content.

3 (Optional) Press the left arrow on your computer keyboard to highlight the parent of the currently highlighted element. Press the right arrow to return to highlighting for the child element.

4 (Optional) Click an element to lock a highlight selection.

Note: Clicking an element to lock a highlight selection turns off Inspect mode.

More Help topics
“Previewing pages in Dreamweaver” on page 276
“The CSS Styles panel” on page 122

Check for cross-browser CSS rendering issues

The Browser Compatibility Check (BCC) feature helps you locate combinations of HTML and CSS that have problems in certain browsers. When you run a BCC on an open file, Dreamweaver scans the file and reports any potential CSS rendering issues in the Results panel. A confidence rating, indicated by a quarter, half, three-quarter, or completely filled circle, indicates the likelihood of the bug’s occurrence (a quarter-filled circle indicating a possible occurrence, and a completely-filled circle indicating a very likely occurrence). For each potential bug that it finds, Dreamweaver also provides a direct link to documentation about the bug on Adobe CSS Advisor, a website that details commonly known browser rendering bugs, and offers solutions for fixing them.

By default, the BCC feature checks against the following browsers: Firefox 1.5; Internet Explorer (Windows) 6.0 and 7.0; Internet Explorer (Macintosh) 5.2; Netscape Navigator 8.0; Opera 8.0 and 9.0; Safari 2.0.

This feature replaces the former Target Browser Check feature, but retains the CSS functionality of that feature. That is, the new BCC feature still tests the code in your documents to see if any of the CSS properties or values are unsupported by your target browsers.
Three levels of potential browser-support problems can arise:

- An error indicates CSS code that might cause a serious visible problem in a particular browser, such as causing parts of a page to disappear. (Error is the default designation for browser support problems, so in some cases, code with an unknown effect is also marked as an error.)
- A warning indicates a piece of CSS code that isn’t supported in a particular browser, but that won’t cause any serious display problems.
- An informational message indicates code that isn’t supported in a particular browser, but that has no visible effect.

Browser compatibility checks do not alter your document in any way.

More Help topics
“Validate XML documents” on page 311

CSS Advisor

Run a browser compatibility check
❖ Select File > Check Page > Browser Compatibility.

Select the element affected by a found issue
❖ Double-click the issue in the Results panel.

Jump to the next or previous found issue in the code
❖ Select Next Issue or Previous Issue from the Browser Compatibility Check menu in the Document toolbar.

Select browsers for Dreamweaver to check against
1 In the Results panel (Window > Results), select the Browser Compatibility Check tab.
2 Click the green arrow in the upper-left corner of the Results panel and select Settings.
3 Select the checkbox next to each browser you want to check against.
4 For each selected browser, select a minimum version to check against from the corresponding pop-up menu.

For example, to see if CSS rendering bugs might appear in Internet Explorer 5.0 and later and Netscape Navigator 7.0 and later, select the checkboxes next to those browser names, and select 5.0 from the Internet Explorer pop-up menu and 7.0 from the Netscape pop-up menu.

Exclude an issue from the browser compatibility check
1 Run a browser compatibility check.
2 In the Results panel, Right-click (Windows) or Control-click (Macintosh) the issue that you want to exclude from future checking.
3 Select Ignore Issue from the context menu.

Edit the Ignored Issues list
1 In the Results panel (Window > Results), select the Browser Compatibility Check tab.
2  Click the green arrow in the upper-left corner of the Results panel and select Edit Ignored Issues List.
3  In the Exceptions.xml file, find the issue that you want deleted from the Ignored Issues list and delete it.
4  Save and close the Exceptions.xml file.

Save a browser compatibility check report
1  Run a browser compatibility check.
2  Click the Save Report button on the left side of the Results panel.

Hover over buttons in the Results panel to see button tool tips.

Note: Reports are not saved automatically; if you want to keep a copy of a report, you must follow the above procedure to save it.

View a browser compatibility check report in a browser
1  Run a browser compatibility check.
2  Click the Browse Report button on the left side of the Results panel.

Hover over buttons in the Results panel to see button tool tips.

Open the Adobe CSS Advisor website
1  In the Results panel (Window > Results), select the Browser Compatibility Check tab.
2  Click the link text at the bottom right of the panel.

Use Design-Time style sheets

Design-Time style sheets allow you to show or hide design applied by a CSS style sheet as you work in a Dreamweaver document. For example, you can use this option to include or exclude the effect of a Macintosh-only or a Windows-only style sheet as you design a page.

Design-Time style sheets only apply while you are working in the document; when the page is displayed in a browser window, only the styles that are actually attached to or embedded in the document appear in a browser.

Note: You can also enable or disable styles for an entire page using the Style Rendering toolbar. To display the toolbar, select View > Toolbars > Style Rendering. The Toggle Displaying of CSS Styles button (the right-most button) works independently of the other media buttons on the toolbar.

To use a Design-time style sheet, follow these steps.
1  Open the Design-Time Style Sheets dialog box by doing one of the following:
   •  Right-click in the CSS Styles panel, and in the context menu select Design-time.
   •  Select Format > CSS Styles > Design-time.
2  In the dialog box, set options to show or hide a selected style sheet:
   •  To display a CSS style sheet at design-time, click the Plus (+) button above Show Only At Design Time, then in the Select a Style Sheet dialog box, browse to the CSS style sheet you want to show.
To hide a CSS style sheet, click the Plus (+) button above Hide At Design-Time, then in the Select a Style Sheet dialog box, browse to the CSS style sheet you want to show.

To remove a style sheet from either list, click the style sheet you want to remove, then click the appropriate Minus (–) button.

3 Click OK to close the dialog box.

The CSS Styles panel updates with the selected style sheet's name along with an indicator, "hidden" or "design," to reflect the style sheet's status.

More Help topics
“Style Rendering toolbar overview” on page 10

Use Dreamweaver sample style sheets

Dreamweaver provides sample style sheets that you can apply to your pages or that you can use as starting points to develop your own styles.

1 Open the CSS Styles panel by doing one of the following:
   • Select Window > CSS Styles.
   • Press Shift+F11.
2 In the CSS Styles panel, click the Attach External Style Sheet button. (It's in the lower-right corner of the panel.)
3 In the Attach External Style Sheet dialog box, click Sample Style Sheets.
4 In the Sample Style Sheets dialog box, select a style sheet from the list box.
   As you select style sheets within the list box, the Preview pane displays the text and color formatting of the selected style sheet.
5 Click the Preview button to apply the style sheet and verify that it applies the styles you want to the current page.
   If the styles applied are not what you expect them to be, select another style sheet from the list, and click Preview to see those styles.
6 By default, Dreamweaver saves the style sheet in a folder named CSS just below the root of the site you defined for your page. If that folder does not exist, Dreamweaver creates it. You can save the file to another location by clicking Browse and browsing to another folder.
7 When you find a style sheet whose formatting rules meet your design criteria, click OK.

Update CSS style sheets in a Contribute site

Adobe Contribute users can’t make changes to a CSS style sheet. To change a style sheet for a Contribute site, use Dreamweaver.

1 Edit the style sheet using the Dreamweaver style-sheet-editing tools.
2 Tell all of the Contribute users who are working on the site to publish pages that use that style sheet, then re-edit those pages to view the new style sheet.
The following are important factors to keep in mind when updating style sheets for a Contribute site:

- If you make changes to a style sheet while a Contribute user is editing a page that uses that style sheet, the user won’t see the changes to the style sheet until they publish the page.
- If you delete a style from a style sheet, the style name is not deleted from pages that use that style sheet, but since the style no longer exists, it isn’t displayed the way the Contribute user may expect. Thus, if a user tells you that nothing happens when they apply a particular style, the problem may be that the style has been deleted from the style sheet.

## Laying out pages with CSS

### About CSS page layout

A CSS page layout uses the Cascading Style Sheets format, rather than traditional HTML tables or frames, to organize the content on a web page. The basic building block of the CSS layout is the div tag—an HTML tag that in most cases acts as a container for text, images, and other page elements. When you create a CSS layout, you place div tags on the page, add content to them, and position them in various places. Unlike table cells, which are restricted to existing somewhere within the rows and columns of a table, div tags can appear anywhere on a web page. You can position div tags absolutely (by specifying x and y coordinates), or relatively (by specifying their distance from other page elements). You can also position div tags by specifying floats, paddings, and margins—the preferred method by today’s web standards.

Creating CSS layouts from scratch can be difficult because there are so many ways to do it. You can create a simple two-column CSS layout by setting floats, margins, paddings, and other CSS properties in a nearly infinite number of combinations. Additionally, the problem of cross-browser rendering causes certain CSS layouts to display properly in some browsers, and display improperly in others. Dreamweaver makes it easy for you to build pages with CSS layouts by providing 16 pre-designed layouts that work across different browsers.

Using the pre-designed CSS layouts that come with Dreamweaver is the easiest way to create a page with a CSS layout, but you can also create CSS layouts using Dreamweaver absolutely-positioned elements (AP elements). An AP element in Dreamweaver is an HTML page element—specifically, a div tag, or any other tag—that has an absolute position assigned to it. The limitation of Dreamweaver AP elements, however, is that since they are absolutely positioned, their positions never adjust on the page according to the size of the browser window.

If you are an advanced user, you can also insert div tags manually and apply CSS positioning styles to them to create page layouts.

### About CSS page layout structure

Before proceeding with this section, you should be familiar with basic CSS concepts.

The basic building block of the CSS layout is the div tag—an HTML tag that in most cases acts as a container for text, images, and other page elements. The following example shows an HTML page that contains three separate div tags: one large “container” tag, and two other tags—a sidebar tag, and a main content tag—within the container tag.
Using Dreamweaver

Creating pages with CSS

A.

Container div

B.

Sidebar div

C.

Main Content div

Following is the code for all three div tags in the HTML:

```html
<!--container div tag-->
<div id="container">
  <!--sidebar div tag-->
  <div id="sidebar">
    <h3>Sidebar Content</h3>
    <p>Lorem ipsum dolor sit amet, consectetuer adipiscing elit.</p>
    <p>Maecenas urna purus, fermentum id, molestie in, commodo porttitor, felis.</p>
  </div>
  <!--mainContent div tag-->
  <div id="mainContent">
    <h1> Main Content </h1>
    <p>Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Praesent aliquam, justo convallis luctus rutrum.</p>
    <p>Phasellus tristique purus a augue condimentum adipiscing. Aenean sagittis. Etiam leo pede, rhoncus venenatis, tristique in, vulputate at, odio.</p>
    <h2>H2 level heading</h2>
    <p>Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Praesent aliquam, justo convallis luctus rutrum, erat nulla fermentum diam, at nonummy quam ante ac quam.</p>
  </div>
</div>
```

In the above example, there is no “styling” attached to any of the div tags. Without CSS rules defined, each div tag and its contents fall into a default location on the page. However, if each div tag has a unique id (as in the above example), you can use the ids to create CSS rules that, when applied, change the style and positioning of the div tags.

The following CSS rule, which can reside in the head of the document or in an external CSS file, creates styling rules for the first, or “container” div tag on the page:

```css
#container {
  width: 780px;
  background: #FFFFFF;
  margin: 0 auto;
  border: 1px solid #000000;
  text-align: left;
}
```

The #container rule styles the container div tag to have a width of 780 pixels, a white background, no margin (from the left side of the page), a solid, black, 1-pixel border, and text that is aligned left. The results of applying the rule to the container div tag are as follows:
Container div tag, 780 pixels, no margin
A. Text aligned left  B. White background  C. 1-pixel solid black border

The next CSS rule creates styling rules for the sidebar div tag:

```
#sidebar {
float: left;
width: 200px;
background: #EBEBEB;
padding: 15px 10px 15px 20px;
}
```

The #sidebar rule styles the sidebar div tag to have a width of 200 pixels, a gray background, a top and bottom padding of 15 pixels, a right padding of 10 pixels, and a left padding of 20 pixels. (The default order for padding is top-right-bottom-left.) Additionally, the rule positions the sidebar div tag with float: left—a property that pushes the sidebar div tag to the left side of the container div tag. The results of applying the rule to the sidebar div tag are as follows:

```
Sidebar div, float left
A. Width 200 pixels  B. Top and bottom padding, 15 pixels
```

Lastly, the CSS rule for the main container div tag finishes the layout:

```
#mainContent {
margin: 0 0 0 250px;
padding: 0 20px 20px 20px;
}
```
The \#mainContent rule styles the main content div with a left margin of 250 pixels, which means that it places 250 pixels of space between the left side of the container div, and the left side of the main content div. Additionally, the rule provides for 20 pixels of spacing on the right, bottom, and left sides of the main content div. The results of applying the rule to the mainContent div are as follows:

The complete code looks as follows:

```html
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<title>Untitled Document</title>
<style type="text/css">
#container {
  width: 780px;
  background: #FFFFFF;
  margin: 0 auto;
  border: 1px solid #000000;
  text-align: left;
}
#sidebar {
  float: left;
  width: 200px;
  background: #EBEBEB;
  padding: 15px 10px 15px 20px;
}
#mainContent {
  margin: 0 0 0 250px;
  padding: 0 20px 20px 20px;
}
</style>
</head>
<body>
<!--container div tag-->
```
<div id="container">

<!--sidebar div tag-->
<div id="sidebar">
<h3>Sidebar Content</h3>
<p>Lorem ipsum dolor sit amet, consectetuer adipiscing elit.</p>
<p>Maecenas urna dolor, fermentum id, molestie in, commodo porttitor, felis.</p>
</div>  

<!--mainContent div tag-->
<div id="mainContent">
<h1> Main Content </h1>
<p>Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Praesent aliquam, justo convallis luctus rutrum.</p>
<p>Phasellus tristique purus a augue condimentum adipiscing. Aenean sagittis. Etiam leo pede, rhoncus venenatis, tristique in, vulputate at, odio.</p>
<h2>H2 level heading</h2>
<p>Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Praesent aliquam, justo convallis luctus rutrum, erat nulla fermentum diam, at nonummy quam ante ac quam.</p>
</div>
</div>

Note: The above example code is a simplified version of the code that creates the two-column fixed left sidebar layout when you create a new document using the predesigned layouts that come with Dreamweaver.

More Help topics
“Understanding Cascading Style Sheets” on page 118

Create a page with a CSS layout
When creating a new page in Dreamweaver, you can create one that already contains a CSS layout. Dreamweaver comes with 16 different CSS layouts that you can choose from. Additionally, you can create your own CSS layouts and add them to the configuration folder so that they appear as layout choices in the New Document dialog box.

Dreamweaver CSS layouts render correctly in the following browsers: Firefox (Windows and Macintosh) 1.0, 1.5, 2.0, and 3.6; Internet Explorer (Windows) 5.5, 6.0, 7.0, and 8.0; Opera (Windows and Macintosh) 8.0, 9.0, and 10.0; Safari 2.0, 3.0, and 4.0; and Chrome 3.0.

For an informational article that explains how to use the CSS layouts that come with Dreamweaver, see the Dreamweaver Developer Center.

There are also more CSS layouts available on the Adobe Dreamweaver Exchange.

More Help topics
“Create a blank page” on page 60
“Set default document type and encoding” on page 66
“Link to an external CSS style sheet” on page 139

Create a page with a CSS layout
1 Select File > New.
2 In the New Document dialog box, select the Blank Page category. (It’s the default selection.)
3 For Page Type, select the kind of page you want to create.
Note: You must select an HTML page type for the layout. For example, you can select HTML, ColdFusion®, PHP, and so on. You cannot create an ActionScript™, CSS, Library Item, JavaScript, XML, XSLT, or ColdFusion Component page with a CSS layout. Page types in the Other category of the New Document dialog box are also restricted from including CSS page layouts.

4 For Layout, select the CSS layout you want to use. You can choose from 16 different layouts. The Preview window shows the layout and gives a brief description of the selected layout.

The predesigned CSS layouts provide the following types of columns:

Fixed  Column width is specified in pixels. The column does not resize based on the size of the browser or the site visitor’s text settings.

Liquid  Column width is specified as a percentage of the site visitor’s browser width. The design adapts if the site visitor makes the browser wider or narrower, but does not change based on the site visitor’s text settings.

5 Select a document type from the DocType pop-up menu.

6 Select a location for the layout’s CSS from the Layout CSS in pop-up menu.

Add To Head  Adds CSS for the layout to the head of the page you’re creating.

Create New File  Adds CSS for the layout to a new external CSS stylesheet and attaches the new stylesheet to the page you’re creating.

Link To Existing File  Lets you specify an existing CSS file that already contains the CSS rules needed for the layout. This option is particularly useful when you want to use the same CSS layout (the CSS rules for which are contained in a single file) across multiple documents.

7 Do one of the following:

• If you selected Add to Head from the Layout CSS in pop-up menu (the default option), click Create.

• If you selected Create New File from the Layout CSS pop-up menu, click Create, and then specify a name for the new external file in the Save Style Sheet File As dialog box.

• If you selected Link to Existing File from the Layout CSS in pop-up menu, add the external file to the Attach CSS file text box by clicking the Add Style Sheet icon, completing the Attach External Style Sheet dialog box, and clicking OK. When you’re finished, click Create in the New Document dialog box.

Note: When you select the Link to Existing File option, the file you specify must already have the rules for the CSS file contained within it.

When you put the layout CSS in a new file or link to an existing file, Dreamweaver automatically links the file to the HTML page you’re creating.

Note: Internet Explorer conditional comments (CCs), which help work around IE rendering issues, remain embedded in the head of the new CSS layout document, even if you select New External File or Existing External File as the location for your layout CSS.

8 (Optional) You can also attach CSS style sheets to your new page (unrelated to the CSS layout) when you create the page. To do this, click the Attach Style Sheet icon above the Attach CSS file pane and select a CSS style sheet.

For a detailed walk-through of this process, see David Powers’s article, Automatically attaching a style sheet to new documents.

Add custom CSS layouts to the list of choices

1 Create an HTML page that contains the CSS layout you’d like to add to the list of choices in the New Document dialog box. The CSS for the layout must reside in the head of the HTML page.
To make your custom CSS layout consistent with the other layouts that come with Dreamweaver, you should save your HTML file with the .htm extension.

2 Add the HTML page to the Adobe Dreamweaver CS5\Configuration\BuiltIn\Layouts folder.

3 (Optional) Add a preview image of your layout (for example a .gif or .png file) to the Adobe Dreamweaver CS5\Configuration\BuiltIn\Layouts folder. The default images that come with Dreamweaver are 227 pixels wide x 193 pixels high PNG files.

Give your preview image the same file name as your HTML file so that you can easily keep track of it. For example, if your HTML file is called myCustomLayout.htm, call your preview image myCustomLayout.png.

4 (Optional) Create a notes file for your custom layout by opening the Adobe Dreamweaver CS5\Configuration\BuiltIn\Layouts\_notes folder, copying and pasting any of the existing notes files in the same folder, and renaming the copy for your custom layout. For example, you could copy the oneColElsCtr.htm.mno file, and rename it myCustomLayout.htm.mno.

5 (Optional) After you’ve created a notes file for your custom layout, you can open the file and specify the layout name, description, and preview image.

Working with div tags

Insert and edit div tags

You can create page layouts by manually inserting div tags and applying CSS positioning styles to them. A div tag is a tag that defines logical divisions within the content of a web page. You can use div tags to center blocks of content, create column effects, create different areas of color, and much more.

If you’re unfamiliar using div tags and Cascading Style Sheets (CSS) to create web pages, you can create a CSS layout based on one of the pre-designed layouts that come with Dreamweaver. If you’re uncomfortable working with CSS, but are familiar with using tables, you can also try using tables.

Note: Dreamweaver treats all div tags with an absolute position as AP elements (absolutely positioned elements), even if you didn’t create those div tags using the AP Div drawing tool.

More Help topics

“About AP elements in Dreamweaver” on page 156

“Create a page with a CSS layout” on page 150

“Presenting content with tables” on page 170

Insert div tags

You can use div tags to create CSS layout blocks and position them in your document. This is useful if you have an existing CSS style sheet with positioning styles attached to your document. Dreamweaver enables you to quickly insert a div tag and apply existing styles to it.

1 In the Document window, place the insertion point where you want the div tag to appear.

2 Do one of the following:
   • Select Insert > Layout Objects > Div Tag.
   • In the Layout category of the Insert panel, click the Insert Div Tag button. 

Last updated 12/7/2011
3 Set any of the following options:

**Insert** Lets you select the location of the div tag and the tag name if it is not a new tag.

**Class** Displays the class style currently applied to the tag. If you attached a style sheet, classes defined in that style sheet appear in the list. Use this pop-up menu to select the style you want to apply to the tag.

**ID** Lets you change the name used to identify the div tag. If you attached a style sheet, IDs defined in that style sheet appear in the list. IDs for blocks that are already in your document are not listed.

*Note:* Dreamweaver alerts you if you enter the same ID as another tag in your document.

**New CSS Rule** Opens the New CSS Rule dialog box.

4 Click OK.

The div tag appears as a box in your document with placeholder text. When you move the pointer over the edge of the box, Dreamweaver highlights it.

If the div tag is absolutely positioned, it becomes an AP element. (You can edit div tags that aren’t absolutely positioned.)

**More Help topics**

“About AP elements in Dreamweaver” on page 156

“Create a page with a CSS layout” on page 150

**Edit div tags**

After you insert a div tag, you can manipulate it or add content to it.

*Note:* Div tags that are absolutely positioned become AP elements.

When you assign borders to div tags, or when you have CSS Layout Outlines selected, they have visible borders. (CSS Layout Outlines is selected by default in the View > Visual Aids menu.) When you move the pointer over a div tag, Dreamweaver highlights the tag. You can change the highlight color or disable highlighting.

When you select a div tag, you can view and edit rules for it in the CSS Styles panel. You can also add content to the div tag by simply placing your insertion point inside the div tag, and then adding content just as you would add content to a page.

**More Help topics**

“About AP elements in Dreamweaver” on page 156

“Open the CSS Styles panel” on page 126

**View and edit rules applied to a div tag**

1 Do one of the following to select the div tag:

- Click the border of the div tag.

  *Look for the highlighting to see the border.*

- Click inside the div tag, and press Control+A (Windows) or Command+A (Macintosh) twice.

- Click inside the div tag, then select the div tag from the tag selector at the bottom of the Document window.

2 Select Window > CSS Styles to open the CSS Styles panel if it is not already open.
Rules applied to the `div` tag appear in the panel.

3 Make edits as necessary.

**Place the insertion point in a div tag to add content**
- Click anywhere inside the tag’s borders.

**Change the placeholder text in a div tag**
- Select the text, and then type over it or press Delete.

*Note:* You can add content to the `div` tag just as you would add content to a page.

**Change the highlight color of div tags**
When you move the pointer over the edge of a `div` tag in Design view, Dreamweaver highlights the borders of the tag. You can enable or disable highlighting as necessary, or change the highlight color in the Preferences dialog box.

1 Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).
2 Select Highlighting from the category list on the left.
3 Make either of the following changes and click OK:
   - To change the highlighting color for `div` tags, click the Mouse-Over color box, and then select a highlight color using the color picker (or enter the hexadecimal value for the highlight color in the text box).
   - To enable or disable highlighting for `div` tags, select or deselect the Show checkbox for Mouse-Over.

*Note:* These options affect all objects, such as tables, that Dreamweaver highlights when you move the pointer over them.

**CSS layout blocks**

**Visualizing CSS layout blocks**
You can visualize CSS layout blocks while you work in Design view. A CSS layout block is an HTML page element that you can position anywhere on your page. More specifically, a CSS layout block is either a `div` tag without `display:inline`, or any other page element that includes the `display:block`, `position:absolute`, or `position:relative` CSS declarations. Following are a few examples of elements that are considered CSS layout blocks in Dreamweaver:

- A `div` tag
- An image with an absolute or relative position assigned to it
- An `a` tag with the `display:block` style assigned to it
- A paragraph with an absolute or relative position assigned to it

*Note:* For purposes of visual rendering, CSS layout blocks do not include inline elements (that is, elements whose code falls within a line of text), or simple block elements like paragraphs.

Dreamweaver provides a number of visual aids for viewing CSS layout blocks. For example, you can enable outlines, backgrounds, and the box model for CSS layout blocks while you design. You can also view tooltips that display properties for a selected CSS layout block when you float the mouse pointer over the layout block.

The following list of CSS layout block visual aids describes what Dreamweaver renders as visible for each:

**CSS Layout Outlines** Displays the outlines of all CSS layout blocks on the page.
CSS Layout Backgrounds  Displays temporarily assigned background colors for individual CSS layout blocks, and hides any other background colors or images that normally appear on the page.

Whenever you enable the visual aid to view CSS layout block backgrounds, Dreamweaver automatically assigns each CSS layout block a distinct background color. (Dreamweaver selects the colors using an algorithmic process—there is no way for you to assign the colors yourself.) The assigned colors are visually distinctive, and are designed to help you differentiate between CSS layout blocks.

CSS Layout Box Model  Displays the box model (that is, padding and margins) of the selected CSS layout block.

View CSS layout blocks
You can enable or disable CSS layout block visual aids as necessary.

View CSS layout block outlines
❖ Select View > Visual Aids > CSS Layout Outlines.

View CSS layout block backgrounds
❖ Select View > Visual Aids > CSS Layout Backgrounds.

View CSS layout block box models
❖ Select View > Visual Aids > CSS Layout Box Model.

You can also access CSS layout block visual aid options by clicking the Visual Aids button on the Document toolbar.

Use visual aids with non-CSS layout block elements
You can use a Design-time style sheet to display the backgrounds, borders, or box model for elements that aren’t normally considered CSS layout blocks. To do so, you must first create a Design-time style sheet that assigns the display:block attribute to the appropriate page element.

1  Create an external CSS style sheet by selecting File > New, selecting Basic page in the Category column, selecting CSS in the Basic page column, and clicking Create.

2  In the new style sheet, create rules that assign the display:block attribute to the page elements you want to display as CSS layout blocks.

For example, if you wanted to display a background color for paragraphs and list items, you could create a style sheet with the following rules:

```css
p{
  display:block;
}
li{
  display:block;
}
```

3  Save the file.

4  In Design view, open the page to which you want to attach the new styles.

5  Select Format > CSS Styles > Design-time.

6  In the Design-time Style Sheets dialog box, click the plus (+) button above the Show Only at Design Time text box, select the style sheet you just created, and click OK.

7  Click OK to close the Design-time Style Sheets dialog box.
The style sheet is attached to your document. If you had created a style sheet using the previous example, all paragraphs and list items would be formatted with the `display:block` attribute, thereby allowing you to enable or disable CSS layout block visual aids for paragraphs and list items.

**More Help topics**
“Use Design-Time style sheets” on page 144

**Working with AP elements**

**About AP elements in Dreamweaver**
An AP element (absolutely positioned element) is an HTML page element—specifically, a `div` tag, or any other tag—that has an absolute position assigned to it. AP elements can contain text, images, or any other content that you can place in the body of an HTML document.

With Dreamweaver, you can use AP elements to lay out your page. You can place AP elements in front of and behind each other, hide some AP elements while showing others, and move AP elements across the screen. You can place a background image in one AP element, then place a second AP element, containing text with a transparent background, in front of that.

AP elements will usually be absolutely positioned div tags. (These are the kinds of AP elements Dreamweaver inserts by default.) But remember, you can classify any HTML element (for example, an image) as an AP element by assigning an absolute position to it. All AP elements (not just absolutely positioned div tags) appear in the AP elements panel.

**HTML code for AP Div elements**
Dreamweaver creates AP elements using the `div` tag. When you draw an AP element using the Draw AP Div tool, Dreamweaver inserts a `div` tag in the document and assigns the `div` an id value (by default `apDiv1` for the first `div` you draw, `apDiv2` for the second `div` you draw, and so on). Later, you can rename the AP Div to anything you want using the AP elements panel or the Property inspector. Dreamweaver also uses embedded CSS in the head of the document to position the AP Div, and to assign the AP Div its exact dimensions.

The following is sample HTML code for an AP Div:
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<title>Sample AP Div Page</title>
<style type="text/css">
<!--
#apDiv1 {
    position:absolute;
    left:62px;
    top:67px;
    width:421px;
    height:188px;
    z-index:1;
}
-->
</style>
</head>
<body>
<div id="apDiv1">

</div>
</body>
</html>

You can change properties for AP Divs (or any AP element) on your page, including x and y coordinates, z-index (also called the stacking order), and visibility.

**Insert an AP Div**

Dreamweaver lets you easily create and position AP Divs on your page. You can also create nested AP Divs.

When you insert an AP Div, Dreamweaver displays an outline of the AP Div in Design view by default, and highlights the block when you move the pointer over it. You can disable the visual aid that shows AP Div (or any AP element) outlines by disabling both AP Element Outlines and CSS Layout Outlines in the View > Visual Aids menu. You can also enable backgrounds and the box model for AP elements as a visual aid while you design.

After you create an AP Div, you can add content to it by simply placing your insertion point in the AP Div, and then adding content just as you would add content to a page.

**More Help topics**

“Select AP elements” on page 162

“Change the highlight color of div tags” on page 154

“Visualizing CSS layout blocks” on page 154

**Draw a single AP Div or multiple AP Divs consecutively**

1 In the Layout category of the Insert panel, click the Draw AP Div button.

2 In the Document window’s Design view, do one of the following:
   - Drag to draw a single AP Div.
   - Control-drag (Windows) or Command-drag (Macintosh) to draw multiple AP Divs consecutively.

You can continue to draw new AP Divs as long as you do not release the Control or Command key.

**Insert an AP Div at a particular place in the document**

Place the insertion point in the Document window, and then select Insert > Layout Objects > AP Div.
Note: This procedure places the tag for the AP Div wherever you clicked in the Document window. The visual rendering of the AP Div may thus affect other page elements (like text) that surround it.

Place the insertion point in an AP Div
❖ Click anywhere inside the AP Div’s borders.

The AP Div’s borders are highlighted, and the selection handle appears, but the AP Div itself is not selected.

Show AP Div borders
❖ Select View > Visual Aids and select either AP Div Outlines or CSS Layout Outlines.

Note: Selecting both options simultaneously has the same effect.

Hide AP Div borders
❖ Select View > Visual Aids and deselect both AP Div Outlines and CSS Layout Outlines.

Work with nested AP Divs
A nested AP Div is an AP Div that has code contained within the tags of another AP Div. For example, the following code shows two AP Divs that are not nested, and two AP Divs that are nested:

```
<div id="apDiv1"></div>
<div id="apDiv2"></div>
<div id="apDiv3">
    <div id="apDiv4"></div>
</div>
```

The graphical depiction for either set of AP Divs might look as follows:

In the first set of div tags, one div is sitting on top of the other on the page. In the second set, the apDiv4 div is actually inside of the apDiv3 div. (You can change AP Div stacking order in the AP Elements panel.)

Nesting is often used to group AP Divs together. A nested AP Div moves with its parent AP Div and can be set to inherit visibility from its parent.

You can enable the Nesting option to automatically nest when you draw an AP Div starting inside another AP Div. To draw inside or over another AP Div, you must also have the Prevent Overlaps option deselected.

Draw a nested AP Div
1 Make sure Prevent Overlaps is deselected in the AP Elements panel (Window > AP Elements).
2 In the Layout category of the Insert panel, click the Draw AP Div button.
3 In the Document window’s Design view, drag to draw an AP Div inside an existing AP Div.
If Nesting is disabled in AP Elements preferences, Alt-drag (Windows) or Option-drag (Macintosh) to nest an AP Div inside an existing AP Div.

Nested AP Divs may appear differently in different browsers. When you create nested AP Divs, check their appearance in various browsers frequently during the design process.

Insert a nested AP Div
1. Make sure Prevent Overlaps is deselected.
2. Place the insertion point inside an existing AP Div in the Document window’s Design view, then select Insert > Layout Objects > AP Div.

Nest AP Divs automatically when you draw an AP Div inside another AP Div
❖ Select the Nesting option in the AP Elements preferences.

View or set AP element preferences
Use the AP Elements category in the Preferences dialog box to specify the default settings for new AP elements you create.

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).
2. Select AP elements from the Category list on the left and specify any of the following preferences, and then click OK.

Visibility Determines whether AP elements are visible by default. The options are default, inherit, visible, and hidden.

Width and Height Specify a default width and height (in pixels) for AP elements you create using Insert > Layout Objects > AP Div.

Background Color Specifies a default background color. Select a color from the color picker.

Background Image Specifies a default background image. Click Browse to locate the image file on your computer.

Nesting: Nest When Created Within An AP Div Specifies whether an AP Div that you draw starting from a point within the boundaries of an existing AP Div should be a nested AP Div. Hold down Alt (Windows) or Option (Macintosh) to temporarily change this setting while you’re drawing an AP Div.

View or set properties for a single AP element
When you select an AP element, the Property inspector displays AP element properties.

1. Select an AP element.
2. In the Property inspector (Window > Properties), click the expander arrow in the lower-right corner, if it isn’t already expanded, to see all properties.

3. Set any of the following options:

CSS-P Element Specifies an ID for the selected AP element. The ID identifies the AP element in the AP Elements panel and in JavaScript code.
Use only standard alphanumeric characters; do not use special characters such as spaces, hyphens, slashes, or periods. Every AP element must have its own unique ID.

*Note:* The CSS-P Property inspector presents the same options for relatively-positioned elements.

**L and T (left and top)** Specify the position of the AP element’s upper-left corner relative to the upper-left corner of the page, or of the parent AP element if nested.

**W and H** Specify the width and height of the AP element.

*Note:* If the content of the AP element exceeds the specified size, the bottom edge of the AP element (as it appears in the Design view in Dreamweaver) stretches to accommodate the content. (The bottom edge doesn’t stretch when the AP element appears in a browser, unless the Overflow property is set to Visible.)

The default unit for position and size is pixels (px). You can instead specify the following units: pc (picas), pt (points), in (inches), mm (millimeters), cm (centimeters), or % (percentage of the parent AP element’s corresponding value). The abbreviations must follow the value without a space: for example, 3mm indicates 3 millimeters.

**Z-Index** Determines the z-index, or stacking order, of the AP element.

In a browser, higher-numbered AP elements appear in front of lower-numbered AP elements. Values can be positive or negative. It’s easier to change the stacking order of AP elements using the AP Elements panel than to enter specific z-index values.

**Vis** Specifies whether the AP element is initially visible or not. Select from the following options:

- Default does not specify a visibility property. When no visibility is specified, most browsers default to Inherit.
- Inherit uses the visibility property of the AP element’s parent.
- Visible displays the AP element contents, regardless of the parent’s value.
- Hidden hides the AP element contents, regardless of the parent’s value.

Use a scripting language, such as JavaScript, to control the visibility property and dynamically display AP element contents.

**Bg Image** Specifies a background image for the AP element.

Click the folder icon to browse to and select an image file.

**Bg Color** Specifies a background color for the AP element.

Leave this option blank to specify a transparent background.

**Class** Specifies the CSS class used to style the AP element.

**Overflow** Controls how AP elements appear in a browser when the content exceeds the AP element’s specified size.

Visible indicates that the extra content appears in the AP element; effectively, the AP element stretches to accommodate it. Hidden specifies that extra content is not displayed in the browser. Scroll specifies that the browser should add scroll bars to the AP element whether they’re needed or not. Auto causes the browser to display scroll bars for the AP element only when needed (that is, when the AP element’s contents exceed its boundaries.)

*Note:* The *overflow* option has uneven support across browsers.

**Clip** Defines the visible area of an AP element.

Specify left, top, right, and bottom coordinates to define a rectangle in the coordinate space of the AP element (counting from the upper-left corner of the AP element). The AP element is “clipped” so that only the specified rectangle is visible. For example, to make an AP element’s contents invisible except for a 50-pixel-wide, 75-pixel-high visible rectangle at the upper-left corner of the AP element, set L to 0, T to 0, R to 50, and B to 75.
Note: Although CSS specifies different semantics for clip, Dreamweaver interprets clip the way that most browsers do.

4 If you entered a value in a text box, press Tab or Enter (Windows) or Return (Macintosh) to apply the value.

View or set properties for multiple AP elements
When you select two or more AP elements, the Property inspector displays text properties and a subset of the full AP element properties, allowing you to modify several AP elements at once.

Select multiple AP elements
❖ Hold down Shift while selecting AP elements.

View and set properties for multiple AP elements
1 Select multiple AP elements.
2 In the Property inspector (Window > Properties), click the expander arrow in the lower-right corner, if it isn’t already expanded, to see all properties.

3 Set any of the following properties for multiple AP elements:
   L and T (left and top) Specify the position of the AP elements’ upper-left corners relative to the upper-left corner of the page, or of the parent AP element if nested.
   W and H Specify the width and height of the AP elements.

   Note: If the content of any AP element exceeds the specified size, the bottom edge of the AP element (as it appears in the Design view in Dreamweaver) stretches to accommodate the content. (The bottom edge doesn’t stretch when the AP element appears in a browser, unless the Overflow property is set to Visible.)

   The default unit for position and size is pixels (px). You can instead specify the following units: pc (picas), pt (points), in (inches), mm (millimeters), cm (centimeters), or % (percentage of the parent AP element’s corresponding value). The abbreviations must follow the value without a space: for example, 3mm indicates 3 millimeters.
   Vis Specifies whether the AP elements are initially visible or not. Select from the following options:
   • Default does not specify a visibility property. When no visibility is specified, most browsers default to Inherit.
   • Inherit uses the visibility property of the AP elements’ parent.
   • Visible displays the AP elements’ contents, regardless of the parent’s value.
   • Hidden hides the AP element contents, regardless of the parent’s value.

   Use a scripting language, such as JavaScript, to control the visibility property and dynamically display AP element contents.
   Tag Specifies the HTML tag used to define the AP elements.
   Bg image Specifies a background image for the AP elements.

Click the folder icon to browse to and select an image file.
**Bg Color**  Specifies a background color for the AP elements. Leave this option blank to specify a transparent background.

4  If you entered a value in a text box, press Tab or Enter (Windows) or Return (Macintosh) to apply the value.

**AP Elements panel overview**

You use the AP Elements panel (Window > AP Elements) to manage the AP elements in your document. Use the AP Elements panel to prevent overlaps, to change the visibility of AP elements, to nest or stack AP elements, and to select one or more AP elements.

*Note:* An AP element in Dreamweaver is an HTML page element—specifically, a `div` tag, or any other tag—that has an absolute position assigned to it. The AP Elements panel does not display relatively-positioned elements.

AP elements are displayed as a list of names, in order of `z`-index; by default, the first created AP element (with a `z`-index of 1) appears at the bottom of the list, and the most recently created AP element appears at the top. You can, however, change the `z`-index of an AP element by changing its place in the stacking order. For example, if you created eight AP elements and wanted to move the fourth AP element to the top, you could assign it a higher `z`-index than the others.

**Select AP elements**

You can select one or more AP elements to manipulate them or change their properties.

**Select an AP element in the AP elements panel**

❖  In the AP elements panel (Window > AP Elements), click the name of the AP element.

**Select an AP element in the Document window**

❖  Do one of the following:
  •  Click an AP element’s selection handle.
  If the selection handle isn’t visible, click anywhere inside the AP element to make the handle visible.
  •  Click an AP element’s border.
  •  Control-Shift-click (Windows) or Command-Shift-click (Macintosh) inside an AP element.
  •  Click inside an AP element and press Control+A (Windows) or Command+A (Macintosh) to select the contents of the AP element. Press Control+A or Command+A again to select the AP element.
  •  Click inside an AP element and select its tag in the tag selector.

**Select multiple AP elements**

❖  Do one of the following:
  •  In the AP Elements panel (Window > AP Elements), Shift-click two or more AP element names.
  •  In the Document window, Shift-click inside or on the border of two or more AP elements.

**Change the stacking order of AP elements**

Use the Property inspector or the AP Elements panel to change the stacking order of AP elements. The AP element at the top of the AP Elements panel list is at the top of the stacking order, and appears in front of the other AP elements.
In HTML code, the stacking order, or z-index, of the AP elements determines the order in which they are drawn in a browser. The higher the z-index of an AP element, the higher that AP element is in the stacking order. (For example, an element with a z-index of 4 will appear on top of an element with a z-index of 3; 1 is always the lowest number in the stacking order.) You can change the z-index for each AP element using the AP Elements panel or Property inspector.

**Change the stacking order of AP elements using the AP Elements panel**
1. Select Window > AP Elements to open the AP Elements panel.
2. Double-click the z-index number next to the AP element whose z-index you want to change.
3. Change the number and press Return/Enter.
   - Type a higher number to move the AP element up in the stacking order.
   - Type a lower number to move the AP element down in the stacking order.

**Change the stacking order of AP elements using the Property inspector**
1. Select Window > AP Elements to open the AP Elements panel to see the current stacking order.
2. In the AP Elements panel or in the Document window, select the AP element whose z-index you want to change.
3. In the Property inspector (Window > Properties), type a number in the Z-Index text box.
   - Type a higher number to move the AP element up in the stacking order.
   - Type a lower number to move the AP element down in the stacking order.

**Show and hide AP elements**
While working on your document, you can show and hide AP elements manually, using the AP Elements panel, to see how the page will appear under different conditions.

*Note:* The currently selected AP element always becomes visible and appears in front of other AP elements while it’s selected.

**Change AP element visibility**
1. Select Window > AP Elements to open the AP Elements panel.
2. Click in the eye icon column for an AP element to change its visibility.
   - An open eye means the AP element is visible.
   - A closed eye means the AP element is invisible.
   - If there is no eye icon, usually the AP element inherits visibility from its parent. (When AP elements are not nested, the parent is the document body, which is always visible.)

Also, no eye icon appears when no visibility is specified (which appears in the Property inspector as Default visibility).

**Change the visibility of all AP elements at once**
- In the AP Elements panel (Window > AP Elements), click the header eye icon at the top of the column.

*Note:* This procedure can set all AP elements to visible or hidden, but not to inherit.

**Resize AP elements**
You can resize an individual AP element, or simultaneously resize multiple AP elements to make them the same width and height.
If the Prevent Overlaps option is on, you will not be able to resize an AP element so that it overlaps with another AP element.

More Help topics
“Use the layout grid” on page 169

Resize an AP element
1 In Design view, select an AP element.
2 Do one of the following to resize the AP element:
   • To resize by dragging, drag any of the AP element’s resize handles.
   • To resize one pixel at a time, hold down Control (Windows) or Option (Macintosh) while pressing an arrow key. The arrow keys move the right and bottom borders of the AP element; you can’t resize using the top and left borders with this technique.
   • To resize by the grid snapping increment, hold down Shift-Control (Windows) or Shift-Option (Macintosh) while pressing an arrow key.
   • In the Property inspector (Window > Properties), type values for width (W) and height (H).

Resizing an AP element changes the width and height of the AP element. It does not define how much of the AP element’s content is visible. You can define the visible region within an AP element in preferences.

Resize multiple AP elements at once
1 In the Design view, select two or more AP elements.
2 Do one of the following:
   • Select Modify > Arrange > Make Same Width Or Modify > Arrange > Make Same Height. The first selected AP elements conform to the width or height of the last selected AP element.
   • In the Property inspector (Window > Properties), under Multiple CSS-P Element, enter width and height values. The values are applied to all selected AP elements.

Move AP elements
You can move AP elements in the Design view in much the same way that you move objects in most basic graphics applications.

If the Prevent Overlaps option is on, you will not be able to move a AP element so that it overlaps another AP element.
1 In the Design view, select an AP element or multiple AP elements.
2 Do one of the following:
   • To move by dragging, drag the selection handle of the last selected AP element (highlighted in black).
   • To move one pixel at a time, use the arrow keys. Hold down the Shift key while pressing an arrow key to move the AP element by the current grid-snapping increment.

More Help topics
“Use the layout grid” on page 169
Align AP elements
Use the AP element alignment commands to align one or more AP elements with a border of the last AP element selected.

When you align AP elements, child AP elements that aren’t selected may move because their parent AP element is selected and moved. To prevent this, don’t use nested AP elements.

1 In the Design view, select the AP element.
2 Select Modify > Arrange, and then select an alignment option.

For example, if you select Top, all of the AP elements move so that their top borders are in the same vertical position as the top border of the last selected AP element (highlighted in black).

Converting AP elements to tables
Instead of using tables to create your layout, some web designers prefer to work with AP elements. Dreamweaver enables you to create your layout using AP elements, then (if you want) convert them into tables. For example, you might need to convert your AP elements to tables if you need to support browsers before version 4.0. Converting AP elements to tables, however, is highly discouraged because it can result in tables with a large number of empty cells, not to mention bloated code. If you need a page layout that uses tables, it is best to create that page layout using the standard table layout tools available in Dreamweaver.

You can convert back and forth between AP elements and tables to adjust the layout and optimize page design. (When you convert a table back to AP elements, however, Dreamweaver converts the table back to AP Divs, regardless of the type of AP element you might have had on the page before the conversion to tables.) You cannot convert a specific table or AP element on a page; you must convert AP elements to tables and tables to AP Divs for an entire page.

Note: You can’t convert AP elements to tables or tables to AP Divs in a template document or in a document to which a template has been applied. Instead, create your layout in a non-template document and convert it before saving it as a template.

Convert between AP elements and tables
You can create your layout using AP elements, then convert the AP elements to tables so that your layout can be viewed in older browsers.

Before you convert to tables, make sure AP elements do not overlap. Also, make sure you’re in Standard Mode (View > Table Mode > Standard Mode).

Convert AP elements to a table
1 Select Modify > Convert > AP Divs To Table.
2 Specify any of the following options and click OK:
   Most Accurate Creates a cell for every AP element, plus any additional cells that are necessary to preserve the space between AP elements.
   Smallest: Collapse Empty Cells Specifies that the AP elements’ edges should be aligned if they are positioned within the specified number of pixels.

If you select this option, the resulting table will have fewer empty rows and columns, but may not match your layout precisely.

Use Transparent GIFs Fills the table’s last row with transparent GIFs. This ensures that the table is displayed with the same column widths in all browsers.
When this option is enabled, you cannot edit the resulting table by dragging its columns. When this option is disabled, the resulting table will not contain transparent GIFs, but the widths of the columns may vary from browser to browser.

**Center On Page** Centers the resulting table on the page. If this option is disabled, the table starts at the left edge of the page.

### Convert tables to AP Divs

1. Select Modify > Convert > Tables to AP Divs.
2. Specify any of the following options and click OK:
   - **Prevent AP Element Overlaps** Constrains the positions of AP elements when they are created, moved, and resized so that they don’t overlap.
   - **Show AP Elements Panel** Displays the AP elements panel.
   - **Show Grid and Snap To Grid** Let you use a grid to help position AP elements.

The tables are converted to AP Divs. Empty cells are not converted to AP elements unless they have background colors.

*Note:* Page elements that were outside of tables are also placed in AP Divs.

### Prevent AP element overlaps

Because table cells cannot overlap, Dreamweaver cannot create a table from overlapping AP elements. If you plan to convert the AP elements in a document to tables, use the Prevent Overlap option to constrain AP element movement and positioning so that AP elements don’t overlap.

When this option is on, an AP element can’t be created in front of, moved or resized over, or nested within an existing AP element. If you activate this option after creating overlapping AP elements, drag each overlapping AP element to move it away from other AP elements. Dreamweaver does not automatically fix existing overlapping AP elements in the page when you enable Prevent AP element Overlaps.

When this option and snapping are enabled, an AP element won’t snap to the grid if it would cause two AP elements to overlap. Instead, it will snap to the edge of the closest AP element.

*Note:* Certain actions allow you to overlap AP elements even when the Prevent Overlaps option is enabled. If you insert an AP element using the Insert menu, enter numbers in the Property inspector, or reposition AP elements by editing the HTML source code, you can cause AP elements to overlap or nest while this option is enabled. If overlaps happen, drag overlapping AP elements in the Design view to separate them.

- In the AP Elements panel (Window > AP Elements), select the Prevent Overlaps option.
- In the Document window, select Modify > Arrange > Prevent AP Element Overlaps.
Chapter 7: Laying out pages with HTML

Using visual aids for layout

Set rulers
Rulers help you measure, organize, and plan your layout. They can appear on the left and top borders of the page, marked in pixels, inches, or centimeters.

- To toggle rulers on and off, select View > Rulers > Show.
- To change the origin, drag the ruler-origin icon (at the upper-left corner of the Design view of the Document window) anywhere on the page.
- To reset the origin to its default position, select View > Rulers > Reset Origin.
- To change the unit of measure, select View > Rulers, and then select Pixels, Inches, or Centimeters.

Set layout guides
Guides are lines that you drag onto the document from the rulers. They help you place and align objects more precisely. You can also use guides to measure the size of page elements, or emulate the folds (visible areas) of web browsers.

To help you align elements, you can snap elements to guides, and snap guides to elements. (Elements must be absolutely positioned in order for the snap feature to work.) You can also lock guides to prevent them from being accidentally moved by another user.

Create a horizontal or vertical guide
1 Drag from the corresponding ruler.
2 Position the guide in the Document window and release the mouse button (reposition the guide by dragging it again).

Note: By default, guides are recorded as absolute pixel measurements from the top or left side of the document, and are shown relative to the origin of the ruler. To record the guide as a percentage, press the Shift key while you create or move the guide.

Show or hide guides
❖ Select View > Guides > Show Guides.

Snap elements to guides
- To snap elements to guides, select View > Guides > Snap to Guides.
- To snap guides to elements, select View > Guides > Guides Snap to Elements.

Note: When you resize elements, such as absolutely-positioned elements (AP elements), tables, and images, the resized elements snap to guides.

Lock or unlock all guides
❖ Select View > Guides > Lock Guides.
View and move a guide to a specific position
1 Hold the mouse pointer over the guide to view its position.
2 Double-click the guide.
3 Enter the new position in the Move Guide dialog box and click OK.

View the distance between guides
❖ Press Control (Windows) or Command (Macintosh) and hold the mouse pointer anywhere between the two guides.

Note: The unit of measure is the same as the unit of measure used for the rulers.

Emulate the fold (visible area) of a web browser
❖ Select View > Guides, and then select a preset browser size from the menu.

Remove a guide
❖ Drag the guide off the document.

Change guide settings
❖ Select View > Guides > Edit Guides, set the following options, and click OK.

Guide color Specifies the color of the guide lines. Click the color swatch and select a color from the color picker, or type a hexadecimal number in the text box.

Distance Color Specifies the color of the lines that appear as distance indicators when you hold the mouse pointer between guides. Click the color swatch and select a color from the color picker, or type a hexadecimal number in the text box.

Show Guides Makes guides visible in Design view.

Snap to Guides Makes page elements snap to guides as you move elements around the page.

Lock Guides Locks guides in place.

Guides Snap to Elements Snaps guides to elements on the page as you drag guides.

Clear All Clears all guides from the page.

Using guides with templates
When guides are added to a Dreamweaver template, all instances of the template inherit the guides. Guides in template instances, however, are treated as editable regions, so users can modify them. Modified guides in template instances are restored to their original location whenever the instance is updated with the master template.

You can also add your own guides to instances of a template. Guides added in this manner are not overwritten when the template instance is updated with the master template.

More Help topics
“Align AP elements” on page 165
“Move AP elements” on page 164

Last updated 12/7/2011
Use the layout grid

The grid displays a system of horizontal and vertical lines in the Document window. It is useful for placing objects precisely. You can make absolutely-positioned page elements automatically snap to the grid as you move them, and change the grid or control the snapping behavior by specifying grid settings. Snapping works whether or not the grid is visible.

More Help topics
“Align AP elements” on page 165
“Move AP elements” on page 164

Show or hide the grid
❖ Select View > Grid > Show Grid.

Enable or disable snapping
❖ Select View > Grid > Snap to Grid.

Change grid settings
1 Select View > Grid > Grid Settings.
2 Set the options and click OK to apply the changes.

Color Specifies the color of the grid lines. Click the color swatch and select a color from the color picker, or type a hexadecimal number in the text box.

Show GridMakes the grid visible in Design view.

Snap to GridMakes page elements snap to the lines of the grid.

SpacingControls how far apart the grid lines are. Enter a number and select Pixels, Inches, or Centimeters from the menu.

DisplaySpecifies whether the grid lines appear as lines or dots.

Note: If Show Grid is not selected, the grid does not appear in the document and no changes are visible.

Use a tracing image
You can use a tracing image as a guide to re-create a page design that was created in a graphics application such as Adobe Freehand or Fireworks.

A tracing image is a JPEG, GIF, or PNG image that is placed in the background of the Document window. You can hide the image, set its opacity, and change its position.

The tracing image is visible only in Dreamweaver; it is not visible when you view the page in a browser. When the tracing image is visible, the page’s real background image and color are not visible in the Document window; however, the background image and color will be visible when the page is viewed in a browser.

Place a tracing image in the Document window
1 Do one of the following:
   • Select View > Tracing Image > Load.
   • Select Modify > Page Properties, then click Browse (next to the Tracing Image text box).
2 In the Select Image Source dialog box, select an image file and click OK.
3. In the Page Properties dialog box, specify the transparency for the image by dragging the Image Transparency slider, then click OK.

To switch to another tracing image or change the transparency of the current tracing image at any time, select Modify > Page Properties.

**Show or hide the tracing image**
- Select View > Tracing Image > Show.

**Change the position of a tracing image**
- Select View > Tracing Image > Adjust Position.
  - To precisely specify the position of the tracing image, enter coordinate values in the X and Y text boxes.
  - To move the image 1 pixel at a time, use the arrow keys.
  - To move the image 5 pixels at a time, press Shift and an arrow key.

**Reset the position of the tracing image**
- Select View > Tracing Image > Reset Position.

The tracing image returns to the upper-left corner of the Document window (0,0).

**Align the tracing image to a selected element**
2. Select View > Tracing Image > Align with Selection.

The upper-left corner of the tracing image is aligned with the upper-left corner of the selected element.

### Presenting content with tables

#### About tables
Tables are a powerful tool for presenting tabular data and for laying out text and graphics on an HTML page. A table consists of one or more rows; each row consists of one or more cells. Although columns aren’t usually explicitly specified in HTML code, Dreamweaver enables you to manipulate columns as well as rows and cells.

Dreamweaver displays the table width and the column width for each table column when the table is selected or when the insertion point is in the table. Next to the widths are arrows for the table header menu and the column header menus. Use the menus for quick access to common table-related commands. You can enable or disable the widths and menus.

If you do not see a width for the table or for a column, then that table or column does not have a specified width in the HTML code. If two numbers appear, then the visual width as it appears in Design view doesn’t match the width specified in the HTML code. This can happen when you resize a table by dragging its lower-right corner or when you add content to a cell that’s larger than its set width.

For example, if you set a column’s width to 200 pixels and then add content that stretches the width to 250 pixels, two numbers appear for that column: 200 (the width specified in the code) and (250) in parentheses (the visual width of the column as it’s rendered on your screen).

*Note: You can also lay out your pages using CSS positioning.*
Table formatting precedence in HTML

When formatting tables in Design view, you can set properties for the entire table or for selected rows, columns, or cells in the table. When a property, such as background color or alignment, is set to one value for the whole table and another value for individual cells, cell formatting takes precedence over row formatting, which in turn takes precedence over table formatting.

The order of precedence for table formatting is as follows:

1. Cells
2. Rows
3. Table

For example, if you set the background color for a single cell to blue, then set the background color of the entire table to yellow, the blue cell does not change to yellow, since cell formatting takes precedence over table formatting.

**Note:** When you set properties on a column, Dreamweaver changes the attributes of the *td* tag corresponding to each cell in the column.

About splitting and merging table cells

You can merge any number of adjacent cells—as long as the entire selection is a line or a rectangle of cells—to produce a single cell that spans several columns or rows. You can split a cell into any number of rows or columns, regardless of whether it was previously merged. Dreamweaver automatically restructures the table (adding any necessary *colspan* or *rowspan* attributes) to create the specified arrangement.

In the following example, the cells in the middle of the first two rows have been merged into a single cell that spans two rows.

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Insert a table and add content

Use the Insert panel or the Insert menu to create a new table. Then, add text and images to table cells the same way that you add text and images outside of a table.

**Note:** The Layout mode feature is deprecated as of Dreamweaver CS4 and later. Layout mode created page layouts using layout tables, which are no longer recommended by Adobe. For more information on Layout mode and why it was deprecated, see the Dreamweaver Team Blog.

1. In the Design view of the Document window, place the insertion point where you want the table to appear.

**Note:** If your document is blank, you can place the insertion point only at the beginning of the document.

- Select Insert > Table.
- In the Common category of the Insert panel, click Table.
2 Set the attributes of the Table dialog box and click OK to create the table.

**Rows** Determines the number of table rows.

**Columns** Determines the number of table columns.

**Table Width** Specifies the width of the table in pixels, or as a percentage of the browser window's width.

**Border Thickness** Specifies the width, in pixels, of the table's borders.

**Cell Spacing** Determines the number of pixels between adjacent table cells.

*When you don’t explicitly assign values for border thickness or cell spacing and cell padding, most browsers display the table border thickness and cell padding set to 1 and cell spacing were set to 2. To ensure that browsers display the table with no border, padding or spacing, set Cell Padding and Cell Spacing to 0.*

**Cell Padding** Determines the number of pixels between a cell’s border and its contents.

**None** Does not enable column or row headings for the table.

**Left** Makes the first column of the table a column for headings, so that you can enter a heading for each row of the table.

**Top** Makes the first row of the table a row for headings, so that you can enter a heading for each column of the table.

**Both** Enables you to enter column and row headings in the table.

*It’s a good idea to use headers in case any of your website visitors use screen readers. Screen readers read table headings and help screen-reader users keep track of table information.*

**Caption** Provides a table title which displays outside of the table.

**Align Caption** Specifies where the table caption appears in relation to the table.

**Summary** Provides a table description. Screen readers read the summary text, but the text does not appear in the user’s browser.

**More Help topics**

“Adding and modifying images” on page 226

---

**Import and export tabular data**

You can import tabular data that has been created in another application (such as Microsoft Excel) and saved in a delimited text format (with items separated by tabs, commas, colons, or semicolons) into Dreamweaver and format it as a table.

You can also export table data from Dreamweaver into a text file, with the contents of adjacent cells separated by a delimiter. You can use commas, colons, semicolons, or spaces as delimiters. When you export a table, the entire table is exported; you cannot select portions of a table to export.

*If you want only some of the data from a table—for example, the first six rows or the first six columns—then copy the cells containing that data, paste those cells outside of the table (to create a new table), and export the new table.*

**Import table data**

1 Do one of the following:

- Select File > Import > Tabular Data.
- In the Data category of the Insert panel, click the Import Tabular Data icon.
- Select Insert > Table Objects > Import Tabular Data.
2 Specify the options for the tabular data and click OK.

**Data File** The name of the file to import. Click the Browse button to select a file.

**Delimiter** The delimiter used in the file you’re importing.

If you select Other, a text box appears to the right of the pop-up menu. Enter the delimiter used in your file.

*Note:* Specify the delimiter that was used when the data file was saved. If you don’t do this, the file will not be imported properly, and your data will not be correctly formatted in a table.

**Table Width** The width of the table.

- Select Fit to Data to make each column wide enough to fit the longest text string in the column.
- Select Set to specify a fixed table width in pixels or as a percentage of the browser window’s width.

**Border** Specifies the width, in pixels, of the table’s borders.

**Cell Padding** The number of pixels between a cell’s content and the cell boundaries.

**Cell Spacing** The number of pixels between adjacent table cells.

If you don’t explicitly assign values for borders, cell spacing, and cell padding, most browsers display the table with borders and cell padding set to 1, and cell spacing set to 2. To ensure that browsers display the table with no padding or spacing, set Cell Padding and Cell Spacing to 0. To view cell and table boundaries when the border is set to 0, select View > Visual Aids > Table Borders.

**Format Top Row** Determines what formatting, if any, is applied to the top row of the table. Select from four formatting options: no formatting, bold, italic, or bold italic.

### Export a table

1 Place the insertion point in any cell of the table.

2 Select File > Export > Table.

3 Specify the following options:

**Delimiter** Specifies which delimiter character should be used to separate items in the exported file.

**Line Breaks** Specifies which operating system you’ll be opening the exported file in: Windows, Macintosh, or UNIX. (Different operating systems have different ways of indicating the end of a line of text.)

4 Click Export.

5 Enter a name for the file and click Save.

### Select table elements

You can select an entire table, row, or column at once. You can also select one or more individual cells.

When you move your pointer over a table, row, column, or cell, Dreamweaver highlights all the cells in that selection so that you know which cells will be selected. This is useful when you have tables without borders, cells that span multiple columns or rows, or nested tables. You can change the highlight color in preferences.

If you position the pointer over a table’s border, then hold the Control key (Windows) or Command key (Macintosh), the entire structure of the table—that is, all cells in the table—is highlighted. This is useful when you have nested tables and want to see the structure of one of the tables.
Select an entire table
❖ Do one of the following:
  • Click the upper-left corner of the table, anywhere on the top or bottom edge of the table, or on a row or column’s border.

  Note: The pointer changes to the table grid icon \( \text{\textbullet} \) when you can select the table (unless you click a row or column border).
  • Click in a table cell, then select the `<table>` tag in the tag selector at the lower-left corner of the Document window.
  • Click in a table cell, then select Modify > Table > Select Table.
  • Click in a table cell, click the table header menu, then select Select Table. Selection handles appear on the selected table’s lower and right edges.

Select individual or multiple rows or columns
1 Position the pointer to point to the left edge of a row or the top edge of a column.
2 When the pointer changes to a selection arrow, click to select a row or column, or drag to select multiple rows or columns.

Select a single column
1 Click in the column.
2 Click the column header menu and choose Select Column.

Select a single cell
❖ Do one of the following:
  • Click in the cell, then select the `<td>` tag in the tag selector at the lower-left corner of the Document window.
  • Control-click (Windows) or Command-click (Macintosh) in the cell.
  • Click in the cell and select Edit >
  • Select All
  • .

Select Edit >
Select All
again when a cell is selected to select the entire table.
Select a line or a rectangular block of cells
❖ Do one of the following:
• Drag from a cell to another cell.
• Click in one cell, Control-click (Windows) or Command-click (Macintosh) in the same cell to select it, then Shift-click another cell.

All of the cells within the linear or rectangular region defined by the two cells are selected.

Select nonadjacent cells
❖ Control-click (Windows) or Command-click (Macintosh) the cells, rows, or columns you want to select.

If each cell, row, or column you Control-click or Command-click isn’t already selected, it’s added to the selection. If it is already selected, it’s removed from the selection.

Change the highlight color for table elements
1 Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).
2 Select Highlighting from the category list on the left, make either of the following changes, and click OK.
• To change the highlighting color for table elements, click the Mouse-Over color box, then select a highlight color using the color picker (or enter the hexadecimal value for the highlight color in the text box).
• To enable or disable highlighting for table elements, select or deselect the Show option for Mouse-Over.

Note: These options affect all objects, such as absolutely-positioned elements (AP elements), that Dreamweaver highlights when you move the pointer over them.

Set table properties
You can use the Property inspector to edit tables.
1 Select a table.
2 In the Property inspector (Window > Properties), change properties as necessary.

Table Id  An ID for the table.
Rows and Cols  The number of rows and columns in the table.
W  The width of the table in pixels, or as a percentage of the browser window’s width.

Note: You usually don’t need to set the height of a table.

CellPad  The number of pixels between a cell’s content and the cell boundaries.
CellSpace  The number of pixels between adjacent table cells.
Align  Determines where the table appears, relative to other elements in the same paragraph, such as text or images.
Left aligns the table to the left of other elements (so that text in the same paragraph wraps around the table to the right); Right aligns the table to the right of other elements (with text wrapping around it to the left); and Center centers the table (with text appearing above and/or below the table). Default indicates that the browser should use its default alignment.
When alignment is set to Default, other content is not displayed next to the table. To display a table next to other content, use Left or Right alignment.

**Border** Specifies the width, in pixels, of the table’s borders.

If you don’t explicitly assign values for the border, cell spacing, and cell padding, most browsers display the table with the border and cell padding set to 1 and cell spacing set to 2. To ensure that browsers display the table with no padding or spacing, set Border to 0, Cell Padding and Cell Spacing to 0. To view cell and table boundaries when the border is set to 0, select View > Visual Aids > Table Borders.

**Class** sets a CSS class on the table.

**Note:** You might need to expand the Table Property inspector to see the following options. To expand the Table Property inspector, click the expander arrow in the lower-right corner.

**Clear Column Widths** and Clear Row Heights delete all explicitly specified row height or column width values from the table.

**Convert Table Widths To Pixels** and Convert Table Heights To Pixels set the width or height of each column in the table to its current width in pixels (also sets the width of the whole table to its current width in pixels).

**Convert Table Widths To Percent** and Convert Table Heights To Percent set the width or height of each column in the table to its current width expressed as a percentage of the Document window’s width (also sets the width of the whole table to its current width as a percentage of the Document window’s width).

If you entered a value in a text box, press Tab or Enter (Windows) or Return (Macintosh) to apply the value.

### Set cell, row, or column properties

You can use the Property inspector to edit cells and rows in a table.

1. Select the column or row.
2. In the Property inspector (Window > Properties), set the following options:

   **Horz** Specifies the horizontal alignment of the contents of a cell, row, or column. You can align the contents to the left, right, or center of the cells, or you can indicate that the browser should use its default alignment (usually left for regular cells and center for header cells).

   **Vert** Specifies the vertical alignment of the contents of a cell, row, or column. You can align the contents to the top, middle, bottom, or baseline of the cells, or indicate that the browser should use its default alignment (usually middle).

   **W and H** The width and height of selected cells in pixels, or as a percentage of the entire table’s width or height. To specify a percentage, follow the value with a percent symbol (%). To let the browser determine the proper width or height based on the contents of the cell and the widths and heights of the other columns and rows, leave the field blank (the default).

   By default, a browser chooses a row height and column width to accommodate and the widest image or the longest line in a column. This is why a column sometimes becomes much wider than the other columns in the table when you add content to it.

   **Note:** You can specify a height as a percentage of the total table height, but the row may not display at the specified percentage height in browsers.

   **Bg** The background color for a cell, column, or row, chosen with the color picker.

   **Merge Cells** Combines selected cells, rows, or columns into one cell. You can merge cells only if they form a rectangular or linear block.
**Split Cell**  Divides a cell, creating two or more cells. You can split only one cell at a time; this button is disabled if more than one cell is selected.

**No Wrap**  Prevents line wrapping, keeping all the text in a given cell on a single line. If No Wrap is enabled, cells widen to accommodate all data as you type it or paste it into a cell. (Normally, cells expand horizontally to accommodate the longest word or widest image in the cell, then expand vertically as necessary to accommodate other contents.)

**Header**  Formats the selected cells as table header cells. The contents of table header cells are bold and centered by default.

*You can specify widths and heights as either pixels or percentages, and you can convert from pixels to percentages and back.*

**Note:** When you set properties on a column, Dreamweaver changes the attributes of the `td` tag corresponding to each cell in the column. When you set certain properties for a row, however, Dreamweaver changes the attributes of the `tr` tag rather than changing the attributes of each `td` tag in the row. When you’re applying the same format to all the cells in a row, applying the format to the `tr` tag produces cleaner, more concise HTML code.

3  Press Tab or Enter (Windows) or Return (Macintosh) to apply the value.

**Use Expanded Tables mode for easier table editing**

Expanded Tables mode temporarily adds cell padding and spacing to all tables in a document and increases the tables’ borders to make editing easier. This mode enables you to select items in tables or precisely place the insertion point.

For example, you might expand a table to place the insertion point to the left or right of an image, without inadvertently selecting the image or table cell.

![Table in Standard mode](image1)

![Table in Expanded tables mode](image2)

*A. Table in Standard mode  B. Table in Expanded tables mode*

**Note:** After you make your selection or place the insertion point, you should return to the Standard mode of Design view to make your edits. Some visual operations, such as resizing, will not give expected results in Expanded Tables mode.

**Switch to Expanded Tables mode**

1  If you are working in Code view, select View > Design or View > Code And Design (you cannot switch to Expanded Tables mode in Code view).

2  Do one of the following:

   - Select View > Table Mode > Expanded Tables Mode.
   - In the Layout category of the Insert panel, click Expanded Tables Mode.

A bar labeled Expanded Tables Mode appears across the top of the Document window. Dreamweaver adds cell padding and spacing to all tables on the page and increases the tables’ borders.

**Switch out of Expanded Tables mode**

*  Do one of the following:

   - Click Exit in the bar labeled Expanded Tables Mode at the top of the Document window.
• Select View > Table Mode > Standard Mode.
• In the Layout category of the Insert panel, click Standard Mode.

Format tables and cells
You can change the appearance of tables by setting properties for the table and its cells or by applying a preset design to the table. Before you set table and cell properties, be aware that the order of precedence for formatting is cells, rows, and tables.

To format the text inside a table cell, use the same procedures you would use to format text outside of a table.

Change the format of a table, row, cell, or column
1 Select a table, cell, row, or column.
2 In the Property inspector (Window > Properties), click the expander arrow in the lower-right corner and change properties as necessary.
3 Change the properties as necessary.
For more information on the options, click the Help icon on the Property inspector.

Note: When you set properties on a column, Dreamweaver changes the attributes of the \texttt{td} tag corresponding to each cell in the column. When you set certain properties for a row, however, Dreamweaver changes the attributes of the \texttt{tr} tag rather than changing the attributes of each \texttt{td} tag in the row. When you're applying the same format to all the cells in a row, applying the format to the \texttt{tr} tag produces cleaner, more concise HTML code.

Add or edit accessibility values for a table in Code view
➢ Edit the appropriate attributes in the code.

To quickly locate the tags in the code, click in the table, then select the \texttt{<table>} tag in the tag selector at the bottom of the Document window.

Add or edit accessibility values for a table in Design view
• To edit the table caption, highlight the caption and type a new caption.
• To edit the caption alignment, place the insertion point in the table caption, right-click (Windows) or Control-click (Macintosh), then select Edit Tag Code.
• To edit the table summary, select the table, right-click (Windows) or Control-click (Macintosh), then select Edit Tag Code.

Resizing tables, columns, and rows

Resizing tables
You can resize an entire table or individual rows and columns. When you resize an entire table, all of the cells in the table change size proportionately. If a table's cells have explicit widths or heights specified, resizing the table changes the visual size of the cells in the Document window but does not change the specified widths and heights of the cells.

You can resize a table by dragging one of its selection handles. Dreamweaver displays the table width, along with a table header menu, at the top or bottom of the table when the table is selected or the insertion point is in the table.
Sometimes the column widths set in the HTML code do not match their apparent widths on the screen. When this happens, you can make the widths consistent. Table and column widths and header menus appear in Dreamweaver to help you lay out your tables; you can enable or disable the widths and menus as necessary.

**Resizing columns and rows**
You can change the width of a column or the height of a row in the Property inspector or by dragging the borders of the column or row. If you have trouble resizing, you can clear the column widths or row heights and start over.

*Note: You can also change cell widths and heights directly in the HTML code using Code view.*

Dreamweaver displays column widths, along with column header menus, at the tops or bottoms of columns when the table is selected or the insertion point is in the table; you can enable or disable the column header menus as necessary.

**More Help topics**
“Working with page code” on page 281

**Resize tables, columns, and rows**

**Resize a table**
❖ Select the table.

- To resize the table horizontally, drag the selection handle on the right.
- To resize the table vertically, drag the selection handle on the bottom.
- To resize the table in both dimensions, drag the selection handle at the lower-right corner.

**Change a column’s width and keep the overall table width**
❖ Drag the right border of the column you want to change.

The width of the adjacent column also changes, so you actually resize two columns. Visual feedback shows you how the columns will adjust; the overall table width does not change.

*Note: In tables with percentage-based widths (not pixels), if you drag the right border of the rightmost column, the entire table’s width changes, and all of the columns grow wider or narrower proportionately.*

**Change a column’s width and maintain the size of the other columns**
❖ Hold the Shift key and drag the column’s border.
The width of one column changes. Visual feedback shows you how the columns will adjust; the overall table width changes to accommodate the column you are resizing.

**Change a row’s height visually**
❖ Drag the lower border of the row.

**Make column widths in code consistent with visual widths**
1 Click in a cell.
2 Click the table header menu, then select Make All Widths Consistent.

Dreamweaver resets the width specified in the code to match the visual width.

**Clear all set widths or heights in a table**
1 Select the table.
2 Do one of the following:
   • Select Modify > Table > Clear Cell Widths, or Modify > Table > Clear Cell Heights.
   • In the Property inspector, (Window > Properties), click the Clear Row Heights button or the Clear Column Widths button.
   • Click the table header menu, then select
     • Clear All
     • Heights or
     • Clear All
     • Widths.

**Clear a column’s set width**
❖ Click in the column, click the column header menu, and select Clear Column Width.

**Enable or disable table and column widths and menus**
1 Select View > Visual Aids > Table Widths.
2 Right-click (Windows) or Control-click (Macintosh) in the table, then select Table > Table Widths.

**Add and remove rows and columns**
To add and remove rows and columns, use the Modify > Table or column header menu.

*Pressing Tab in the last cell of a table automatically adds another row to the table.*

**Add a single row or column**
❖ Click in a cell and do one of the following:
• Select Modify > Table > Insert Row or Modify > Table > Insert Column.
A row appears above the insertion point or a column appears to the left of the insertion point.
• Click the column header menu, and then select Insert Column Left or Insert Column Right.

**Add multiple rows or columns**
1 Click in a cell.
2 Select Modify > Table > Insert Rows Or Columns, complete the dialog box, and click OK.

**Delete a row or column**
❖ Do one of the following:
• Click in a cell within the row or column you want to delete, then select Modify > Table > Delete Row, or Modify > Table > Delete Column.
• Select a complete row or column, then select Edit > Clear or press Delete.

**Add or delete rows or columns using the Property inspector**
1 Select the table.
2 In the Property inspector (Windows > Properties), do one of the following:
• To add or delete rows, increase or decrease the Rows value.
• To add or delete columns, increase or decrease the Cols value.

*Note: Dreamweaver does not warn you if you are deleting rows and columns that contain data.*

**Split and merge cells**
Use the Property inspector or the commands in the Modify > Table submenu to split or merge cells.
Merge two or more cells in a table

1. Select the cells in a contiguous line and in the shape of a rectangle.

In the following illustration, the selection is a rectangle of cells, so the cells can be merged.

<table>
<thead>
<tr>
<th>Location Name</th>
<th>City</th>
<th>State or Country</th>
</tr>
</thead>
<tbody>
<tr>
<td>Baltimore-Washington Interna</td>
<td>Baltimore</td>
<td>MD</td>
</tr>
<tr>
<td>Cairo International</td>
<td>Cairo</td>
<td>Egypt</td>
</tr>
<tr>
<td>Canberra</td>
<td>Canberra</td>
<td>Australia</td>
</tr>
<tr>
<td>Cairns</td>
<td>Cairns</td>
<td>Queensland</td>
</tr>
<tr>
<td>Cape Town Airport</td>
<td>Cape Town</td>
<td>South Africa</td>
</tr>
</tbody>
</table>

In the following illustration, the selection is not a rectangle, so the cells can't be merged.

<table>
<thead>
<tr>
<th>Location Name</th>
<th>City</th>
<th>State or Country</th>
</tr>
</thead>
<tbody>
<tr>
<td>Baltimore-Washington Interna</td>
<td>Baltimore</td>
<td>MD</td>
</tr>
<tr>
<td>Cairo International</td>
<td>Cairo</td>
<td>Egypt</td>
</tr>
<tr>
<td>Canberra</td>
<td>Canberra</td>
<td>Australia</td>
</tr>
<tr>
<td>Cairns</td>
<td>Cairns</td>
<td>Queensland</td>
</tr>
<tr>
<td>Cape Town Airport</td>
<td>Cape Town</td>
<td>South Africa</td>
</tr>
</tbody>
</table>

2. Do one of the following:
   - Select Modify > Table > Merge Cells.
   - In the expanded HTML Property inspector (Window > Properties), click Merge Cells.

   **Note:** If you don't see the button, click the expander arrow in the lower-right corner of the Property inspector so that you see all the options.

   The contents of the individual cells are placed in the resulting merged cell. The properties of the first cell selected are applied to the merged cell.

Split a cell

1. Click in the cell and do one of the following:
   - Select Modify > Table > Split Cell.
   - In the expanded HTML Property inspector (Window > Properties), click Split Cell.

   **Note:** If you don't see the button, click the expander arrow in the lower-right corner of the Property inspector so that you see all the options.

2. In the Split Cell dialog box, specify how to split the cell:

   - **Split Cell Into** Specifies whether to split the cell into rows or columns.
   - **Number Of Rows/Number Of Columns** Specifies how many rows or columns to split the cell into.

Increase or decrease the number of rows or columns spanned by a cell

- Do one of the following:
  - Select Modify > Table > Increase Row Span, or Modify > Table > Increase Column Span.
  - Select Modify > Table > Decrease Row Span, or Modify > Table > Decrease Column Span.
Copy, paste, and delete cells

You can copy, paste, or delete a single table cell or multiple cells at once, preserving the cells’ formatting.

You can paste cells at the insertion point or in place of a selection in an existing table. To paste multiple table cells, the contents of the Clipboard must be compatible with the structure of the table or the selection in the table in which the cells will be pasted.

Cut or copy table cells

1. Select one or more cells in a contiguous line and in the shape of a rectangle.

In the following illustration, the selection is a rectangle of cells, so the cells can be cut or copied.

<table>
<thead>
<tr>
<th>Location Name</th>
<th>City</th>
<th>State or Country</th>
</tr>
</thead>
<tbody>
<tr>
<td>Baltimore-Washington International</td>
<td>Baltimore</td>
<td>MD</td>
</tr>
<tr>
<td>Cairo International</td>
<td>Cairo</td>
<td>Egypt</td>
</tr>
<tr>
<td>Canberra</td>
<td>Canberra</td>
<td>Australia</td>
</tr>
<tr>
<td>Cairns</td>
<td>Cairns</td>
<td>Queensland</td>
</tr>
<tr>
<td>Cape Town Airport</td>
<td>Cape Town</td>
<td>South Africa</td>
</tr>
</tbody>
</table>

In the following illustration, the selection is not a rectangle, so the cells can’t be cut or copied.

<table>
<thead>
<tr>
<th>Location Name</th>
<th>City</th>
<th>State or Country</th>
</tr>
</thead>
<tbody>
<tr>
<td>Baltimore-Washington International</td>
<td>Baltimore</td>
<td>MD</td>
</tr>
<tr>
<td>Cairo International</td>
<td>Cairo</td>
<td>Egypt</td>
</tr>
<tr>
<td>Canberra</td>
<td>Canberra</td>
<td>Australia</td>
</tr>
<tr>
<td>Cairns</td>
<td>Cairns</td>
<td>Queensland</td>
</tr>
<tr>
<td>Cape Town Airport</td>
<td>Cape Town</td>
<td>South Africa</td>
</tr>
</tbody>
</table>

2. Select Edit > Cut or Edit > Copy.

Note: If you selected an entire row or column and you select Edit > Cut, the entire row or column is removed from the table (not just the contents of the cells).

Paste table cells

1. Select where you want to paste the cells:
   - To replace existing cells with the cells you are pasting, select a set of existing cells with the same layout as the cells on the clipboard. (For example, if you’ve copied or cut a 3 x 2 block of cells, you can select another 3 x 2 block of cells to replace by pasting.)
   - To paste a full row of cells above a particular cell, click in that cell.
   - To paste a full column of cells to the left of a particular cell, click in that cell.

Note: If you have less than a full row or column of cells in the clipboard, and you click in a cell and paste the cells from the clipboard, the cell you clicked in and its neighbors may (depending on its location in the table) be replaced with the cells you are pasting.
   - To create a new table with the pasted cells, place the insertion point outside of the table.

2. Select Edit > Paste.
If you are pasting entire rows or columns into an existing table, the rows or columns are added to the table. If you are pasting an individual cell, the contents of the selected cell are replaced. If you are pasting outside a table, the rows, columns, or cells are used to define a new table.

**Remove cell content but leave the cells intact**

1. Select one or more cells.

*Note: Make sure the selection does not consist entirely of complete rows or columns.*

2. Select Edit > Clear or press Delete.

*Note: If only complete rows or columns are selected when you select Edit > Clear or press Delete, the entire rows or columns—not just their contents—are removed from the table.*

**Delete rows or columns that contain merged cells**

1. Select the row or column.

2. Select Modify > Table > Delete Row, or Modify > Table > Delete Column.

**Nest tables**

A nested table is a table inside a cell of another table. You can format a nested table as you would any other table; however, its width is limited by the width of the cell in which it appears.

1. Click in a cell of the existing table.

2. Select Insert > Table, set the Insert Table options, and click OK.

**Sort tables**

You can sort the rows of a table based on the contents of a single column. You can also perform a more complicated table sort based on the contents of two columns.

You cannot sort tables that contain `colspan` or `rowspan` attributes—that is, tables that contain merged cells.

1. Select the table or click in any cell.

2. Select Commands > Sort Table, set the options in the dialog box, and click OK.

**Sort By** Determines which column’s values will be used to sort the table’s rows.

**Order** Determines whether to sort the column alphabetically or numerically, and whether to sort it in ascending order (A to Z, lower numbers to higher numbers) or descending order.

When the contents of a column are numbers, select Numerically. An alphabetic sort applied to a list of one- and two-digit numbers results in the numbers being sorted as if they were words (resulting in ordering such as 1, 10, 2, 20, 3, 30) rather than being sorted as numbers (resulting in ordering such as 1, 2, 3, 10, 20, 30).

**Then By/Order** Determines the sorting order for a secondary sort on a different column. Specify the secondary-sort column in the Then By pop-up menu, and the secondary sort order in the Order pop-up menus.

**Sort Includes The First Row** Specifies that the first row of the table should be included in the sort. If the first row is a heading that should not be moved, do not select this option.

**Sort Header Rows** Specifies to sort all the rows in the table’s `thead` section (if any) using the same criteria as the body rows. (Note that `thead` rows remain in the `thead` section and still appear at the top of the table even after sorting.) For information about the `thead` tag, see the Reference panel (select Help > Reference).
Sort Footer Rows  Specifies to sort all the rows in the table’s tfoot section (if any) using the same criteria as the body rows. (Note that tfoot rows remain in the tfoot section and still appear at the bottom of the table even after sorting.) For information about the tfoot tag, see the Reference panel (select Help > Reference).

Keep All Row Colors The Same After The Sort Has Been Completed  Specifies that table row attributes (such as color) should remain associated with the same content after the sort. If your table rows are formatted with two alternating colors, do not select this option to ensure that the sorted table still has alternating-colored rows. If the row attributes are specific to the content of each row, then select this option to ensure that those attributes remain associated with the correct rows in the sorted table.

Using Frames

How frames and framesets work
A frame is a region in a browser window that can display an HTML document independent of what’s being displayed in the rest of the browser window. Frames provide a way to divide a browser window into multiple regions, each of which can display a different HTML document. In the most common use of frames, one frame displays a document containing navigation controls, while another frame displays a document with content.

A frameset is an HTML file that defines the layout and properties of a set of frames, including the number of frames, the size and placement of the frames, and the URL of the page that initially appears in each frame. The frameset file itself doesn’t contain HTML content that displays in a browser, except in the noframes section; the frameset file simply provides information to the browser about how a set of frames should look and what documents should appear in them.

To view a set of frames in a browser, enter the URL of the frameset file; the browser then opens the relevant documents to display in the frames. The frameset file for a site is often named index.html, so that it displays by default if a visitor doesn’t specify a filename.
The following example shows a frame layout consisting of three frames: one narrow frame on the side that contains a navigation bar, one frame that runs along the top, containing the logo and title of the website, and one large frame that takes up the rest of the page and contains the main content. Each of these frames displays a separate HTML document.

In this example, the document displayed in the top frame never changes as the visitor navigates the site. The side frame navigation bar contains links; clicking one of these links changes the content of the main content frame, but the contents of the side frame itself remain static. The main content frame on the right displays the appropriate document for the link the visitor clicks on the left.

A frame is not a file; it’s easy to think of the document that currently appears in a frame as an integral part of the frame, but the document isn’t actually part of the frame. The frame is a container that holds the document.

Note: A “page” refers either to a single HTML document or to the entire contents of a browser window at a given moment, even if several HTML documents appear at once. The phrase “a page that uses frames,” for example, usually refers to a set of frames and the documents that initially appear in those frames.

A site that appears in a browser as a single page comprising three frames actually consists of at least four HTML documents: the frameset file, plus the three documents containing the content that initially appears in the frames. When you design a page using framesets in Dreamweaver, you must save each of these four files in order for the page to work properly in the browser.

For more comprehensive information about Frames, consult Thierry Koblentz’s website at www.tjkdesign.com/articles/frames/.

Deciding whether to use frames

Adobe discourages the use of frames for web page layout. Some of the disadvantages of using frames include:

- Precise graphical alignment of elements in different frames can be difficult.
- Testing the navigation can be time-consuming.
- The URLs of the individual framed pages don’t appear in browsers, so it can be difficult for a visitor to bookmark a specific page (unless you provide server code that enables them to load a framed version of a particular page).
For a full treatment of why you should not use frames, see Gary White’s explanation at http://apptools.com/rants/framesevil.php.

The most common use of frames, if you do decide to use them, is for navigation. A set of frames often includes one frame containing a navigation bar and another frame to display the main content pages. Using frames in this way has a couple of advantages:

- A visitor’s browser doesn’t need to reload the navigation-related graphics for every page.
- Each frame has its own scroll bar (if the content is too large to fit in a window), so a visitor can scroll the frames independently. For example, a visitor who scrolls to the bottom of a long page of content in a frame doesn’t need to scroll back up to the top to use the navigation bar if the navigation bar is in a different frame.

In many cases, you can create a web page without frames that accomplishes the same goals as a set of frames. For example, if you want a navigation bar to appear on the left side of your page, you can either replace your page with a set of frames, or just include the navigation bar on every page in your site. (Dreamweaver helps you create multiple pages that use the same layout.) The following example shows a page design with a framelike layout that doesn’t use frames.

Poorly designed sites use frames unnecessarily, such as a frameset that reloads the contents of the navigation frames every time the visitor clicks a navigation button. When frames are used well (for example, to keep navigation controls static in one frame while allowing the contents of another frame to change), they can be very useful for a site.

Not all browsers provide good frame support, and frames may be difficult for visitors with disabilities to navigate, so if you do use frames, always provide a noframes section in your frameset, for visitors who can’t view them. You might also provide an explicit link to a frameless version of the site.

For more comprehensive information about Frames, consult Thierry Koblentz’s website at www.tjkdesign.com/articles/frames/.
Nested framesets

A frameset inside another frameset is called a nested frameset. A single frameset file can contain multiple nested framesets. Most web pages that use frames are actually using nested frames, and most of the predefined framesets in Dreamweaver also use nesting. Any set of frames in which there are different numbers of frames in different rows or columns requires a nested frameset.

For example, the most common frame layout has one frame in the top row (where the company’s logo appears) and two frames in the bottom row (a navigation frame and a content frame). This layout requires a nested frameset: a two-row frameset, with a two-column frameset nested in the second row.

Dreamweaver takes care of nesting framesets as needed; if you use the frame-splitting tools in Dreamweaver, you don’t need to worry about the details of which frames are nested and which are not.

There are two ways to nest framesets in HTML: the inner frameset can be defined either in the same file as the outer frameset, or in a separate file of its own. Each predefined frameset in Dreamweaver defines all of its framesets in the same file.

Both kinds of nesting produce the same visual results; it’s not easy to tell, without looking at the code, which kind of nesting is being used. The most likely situation in which an external frameset file would be used in Dreamweaver is when you use the Open in Frame command to open a frameset file inside a frame; doing this may result in problems with setting targets for links. It’s generally simplest to keep all framesets defined in a single file.

Work with framesets in the Document window

Dreamweaver enables you to view and edit all of the documents associated with a set of frames in one Document window. This approach enables you to see approximately how the framed pages will appear in a browser as you edit them. However, some aspects of this approach can be confusing until you get used to them. In particular, each frame displays a separate HTML document. Even if the documents are empty, you must save them all before you can preview them (because the frameset can be accurately previewed only if it contains the URL of a document to display in each frame).

To ensure that your frameset appears correctly in browsers, follow these general steps:

1. Create your frameset and specify a document to appear in each frame.
2 Save every file that’s going to appear in a frame. Remember that each frame displays a separate HTML document, and you must save each document, along with the frameset file.

3 Set the properties for each frame and for the frameset (including naming each frame, setting scrolling and non-scrolling options).

4 Set the Target property in the Property inspector for all your links so that the linked content appears in the correct area.

Create frames and framesets

There are two ways to create a frameset in Dreamweaver: You can select from several predefined framesets or you can design it yourself.

Choosing a predefined frameset sets up all the framesets and frames needed to create the layout and is the easiest way to create a frames-based layout quickly. You can insert a predefined frameset only in the Document window’s Design view.

You can also design your own frameset in Dreamweaver by adding “splitters” to the Document window.

Before creating a frameset or working with frames, make the frame borders visible in the Document window’s Design view by selecting View > Visual Aids > Frame Borders.

More Help topics
“Dreamweaver and accessibility” on page 659

Create a predefined frameset and display an existing document in a frame

1 Place the insertion point in a document and do one of the following:
   • Choose Insert > HTML > Frames and select a predefined frameset.
   • In the Layout category of the Insert panel, click the drop-down arrow on the Frames button and select a predefined frameset.

The frameset icons provide a visual representation of each frameset as applied to the current document. The blue area of a frameset icon represents the current document, and the white areas represent frames that will display other documents.

2 If you have set up Dreamweaver to prompt you for frame accessibility attributes, select a frame from the pop-up menu, enter a name for the frame, and click OK. (For visitors who use screen readers, the screen reader will read this name when it encounters the frame in a page.)

Note: If you click OK without entering a new name, Dreamweaver gives the frame a name that corresponds to its position (left frame, right frame, and so on) in the frameset.

Note: If you press Cancel, the frameset appears in the document, but Dreamweaver does not associate accessibility tags or attributes with it.

Select Window > Frames to view a diagram of the frames you are naming.

Create an empty predefined frameset

1 Select File > New.

2 In the New Document dialog box, select the Page from Sample category.

3 Select the Frameset folder in the Sample Folder column.

4 Select a frameset from the Sample Page column and click Create.
If you have activated the frame accessibility attributes in Preferences, the Frame Tag Accessibility Attributes dialog box appears; complete the dialog box for each frame and click OK.

**Note:** If you press Cancel, the frameset appears in the document, but Dreamweaver does not associate accessibility tags or attributes with it.

### Create a frameset

- Select Modify > Frameset, then select a splitting item (such as Split Frame Left or Split Frame Right) from the submenu.

Dreamweaver splits the window into frames. If you had an existing document open, it appears in one of the frames.

### Split a frame into smaller frames

- To split the frame where the insertion point is, select a splitting item from the Modify > Frameset submenu.
- To split a frame or set of frames vertically or horizontally, drag a frame border from the edge into the middle of the Design view.
- To split a frame using a frame border that isn’t at the edge of the Design view, Alt-drag (Windows) or Option-drag (Macintosh) a frame border.
- To divide a frame into four frames, drag a frame border from one of the corners of the Design view into the middle of a frame.

**Tip:** To create three frames, start with two frames, then split one of them. It’s not easy to merge two adjacent frames without editing the frameset code, so changing four frames into three frames is harder than changing two frames into three frames.

### Delete a frame

- Drag a frame border off the page or to a border of the parent frame.

If there’s unsaved content in a document in a frame that’s being removed, Dreamweaver prompts you to save the document.

**Note:** You can’t remove a frameset entirely by dragging borders. To remove a frameset, close the Document window that displays it. If the frameset file has been saved, delete the file.

### Resize a frame

- To set approximate sizes for frames, drag frame borders in the Document window’s Design view.
- To specify exact sizes, and to specify how much space the browser allocates to a row or column of frames when the browser window size doesn’t allow the frames to display at full size, use the Property inspector.

### Select frames and framesets

To make changes to the properties of a frame or frameset, begin by selecting the frame or frameset you want to change. You can select a frame or frameset either in the Document window or by using the Frames panel.
The Frames panel provides a visual representation of the frames within a frameset. It shows the hierarchy of the frameset structure in a way that may not be apparent in the Document window. In the Frames panel, a very thick border surrounds each frameset; each frame is surrounded by a thin gray line and is identified by a frame name.

In the Document window’s Design view, when a frame is selected, its borders are outlined with a dotted line; when a frameset is selected, all the borders of the frames within the frameset are outlined with a light dotted line.

**Note:** Placing the insertion point in a document that’s displayed in a frame is not the same as selecting a frame. There are various operations (such as setting frame properties) for which you must select a frame.

**Select a frame or frameset in the Frames panel**

1. Select Window > Frames.
2. In the Frames panel:
   - To select a frame, click the frame. (A selection outline appears around the frame in both the Frames panel and the Document window’s Design view.)
   - To select a frameset, click the border that surrounds the frameset.

**Select a frame or frameset in the Document window**

- To select a frame, Shift-Alt-click (Windows) or Shift-Option-click (Macintosh) inside a frame in Design view.
- To select a frameset, click one of the frameset’s internal frame borders in Design view. (Frame borders must be visible to do this; select View > Visual Aids > Frame Borders to make frame borders visible if they aren’t.)

**Note:** It’s generally easier to select framesets in the Frames panel than in the Document window. For more information, see the above topics.
Select a different frame or frameset

- To select the next or previous frame or frameset at the same hierarchical level as the current selection, press Alt+Left Arrow or Alt+Right Arrow (Windows), or Command+Left Arrow or Command+Right Arrow (Macintosh). Using these keys, you can cycle through frames and framesets in the order in which they’re defined in the frameset file.
- To select the parent frameset (the frameset that contains the current selection), press Alt+Up Arrow (Windows) or Command+Up Arrow (Macintosh).
- To select the first child frame or frameset of the currently selected frameset (that is, first in the order in which they’re defined in the frameset file), press Alt+Down Arrow (Windows) or Command+Down Arrow (Macintosh).

Open a document in a frame

You can specify the initial content of a frame by either inserting new content into an empty document in a frame, or opening an existing document in a frame.

1. Place the insertion point in a frame.
2. Select File > Open in Frame.
3. Select a document to open in the frame, and click OK (Windows) or Choose (Macintosh).
4. (Optional) To make this document the default document to display in the frame when the frameset is opened in a browser, save the frameset.

Save frame and frameset files

Before you can preview a frameset in a browser, you must save the frameset file and all of the documents that will display in the frames. You can save each frameset file and framed document individually, or you can save the frameset file and all documents appearing in frames at once.

*Note:* When you use visual tools in Dreamweaver to create a set of frames, each new document that appears in a frame is given a default filename. For example, the first frameset file is named UntitledFrameset-1, while the first document in a frame is named UntitledFrame-1.

Save a frameset file

- Select the frameset in the Frames panel or the Document window.
- To save the frameset file, select File > Save Frameset.
- To save the frameset file as a new file, select File > Save Frameset As.

*Note:* If the frameset file has not previously been saved, these two commands are equivalent.

Save a document that appears in a frame

- Click in the frame, then select File > Save Frame or File > Save Frame As.

Save all files associated with a set of frames

- Select File > Save All Frames.

This saves all open documents in the frameset, including the frameset file and all framed documents. If the frameset file has not yet been saved, a heavy border appears around the frameset (or the unsaved frame) in the Design view, and you can select a filename.
**Note:** If you used File > Open in Frame to open a document in a frame, then when you save the frameset, the document you opened in the frame becomes the default document to be displayed in that frame. If you don’t want that document to be the default, don’t save the frameset file.

**View and set frame properties and attributes**

Use the Property inspector to view and set most frame properties, including borders, margins, and whether scroll bars appear in frames. Setting a frame property overrides the setting for that property in a frameset.

You may also want to set some frame attributes, such as the title attribute (which is not the same as the name attribute), to improve accessibility. You can enable the accessibility authoring option for frames to set attributes when you create frames, or you can set attributes after inserting a frame. To edit accessibility attributes for a frame, use the Tag inspector to edit the HTML code directly.

**More Help topics**

“Dreamweaver and accessibility” on page 659

**View or set frame properties**

1. Select a frame by doing one of the following:
   - Alt-click (Windows) or Shift-Option-click (Macintosh) a frame in the Document window’s Design view.
   - Click a frame in the Frames panel (Window > Frames).
2. In the Property inspector (Window > Properties), click the expander arrow in the lower-right corner to see all of the frame properties.
3. Set the frame Property inspector options.

**Frame Name** The name used by a link’s target attribute or by a script to refer to the frame. A frame name must be a single word; underscores (_) are allowed, but hyphens (-), periods (.), and spaces are not. A frame name must start with a letter (as opposed to a numeral). Frame names are case-sensitive. Don’t use terms that are reserved words in JavaScript (such as top or navigator) as frame names.

💡 To make a link change the contents of another frame, you must name the target frame. To make it easier to create cross-frame links later, name each of your frames when you create it.

**Src** Specifies the source document to display in the frame. Click the folder icon to browse to and select a file.

**Scroll** Specifies whether scroll bars appear in the frame. Setting this option to Default doesn’t set a value for the corresponding attribute, allowing each browser to use its default value. Most browsers default to Auto, meaning that scroll bars appear only when there is not enough room in a browser window to display the full contents of the current frame.

**No Resize** Prevents visitors from dragging the frame borders to resize the frame in a browser.

**Borders** Shows or hides the borders of the current frame when it’s viewed in a browser. Selecting a Borders option for a frame overrides the frameset’s border settings.

Border options are Yes (show borders), No (hide borders), and Default; most browsers default to showing borders, unless the parent frameset has Borders set to No. A border is hidden only when all frames that share the border have Borders set to No, or when the parent frameset’s Borders property is set to No and the frames sharing the border have Borders set to Default.
Border Color  Sets a border color for all of the frame’s borders. This color applies to all borders that touch the frame, and overrides the specified border color of the frameset.

Margin Width  Sets the width in pixels of the left and right margins (the space between the frame borders and the content).

Margin Height  Sets the height in pixels of the top and bottom margins (the space between the frame borders and the content).

Note: Setting the margin width and height for a frame is not the same as setting margins in the Modify > Page Properties dialog box.

To change the background color of a frame, set the background color of the document in the frame in page properties.

Set accessibility values for a frame
1  In the Frames panel (Window > Frames), select a frame by placing the insertion point in one of the frames.
2  Select Modify > Edit Tag <frameset>.
3  Select Style Sheet/Accessibility from the category list on the left, enter values, and click OK.

Edit accessibility values for a frame
1  Display Code view or Code and Design views for your document, if you’re currently in Design view.
2  In the Frames panel (Window > Frames), select a frame by placing the insertion point in one of the frames. Dreamweaver highlights the frame tag in the code.
3  Right-click (Windows) or Control-click (Macintosh) in the code, and then select Edit Tag.
4  In the tag editor, make your changes and click OK.

Change the background color of a document in a frame
1  Place the insertion point in the frame.
2  Select Modify > Page Properties.
3  In the Page Properties dialog box, click the Background color menu, and select a color.

View and set frameset properties
Use the Property inspector to view and set most frameset properties, including the frameset title, borders, and frame sizes.

Set a title for a frameset document
1  Select a frameset by doing one of the following:
   • Click a border between two frames in the frameset in the Document window’s Design view.
   • Click the border that surrounds a frameset in the Frames panel (Window > Frames).
2  In the Title box of the Document toolbar, type a name for the frameset document.

When a visitor views the frameset in a browser, the title appears in the browser’s title bar.
View or set frameset properties

1. Select a frameset by doing one of the following:
   - Click a border between two frames in the frameset in the Document window’s Design view.
   - Click the border that surrounds a frameset in the Frames panel (Window > Frames).

2. In the Property inspector (Window > Properties), click the expander arrow in the lower-right corner and set the frameset options.

   **Borders** Determines whether borders should appear around frames when the document is viewed in a browser. To display borders, select Yes; to prevent the browser from displaying borders, select No. To allow the browser to determine how borders are displayed, select Default.

   **Border Width** Specifies a width for all the borders in the frameset.

   **Border Color** Sets a color for the borders. Use the color picker to select a color, or type the hexadecimal value for a color.

   **RowCol Selection** Sets frame sizes for rows and columns of the selected frameset, click a tab on the left side or top of the RowCol Selection area; then enter a height or width in the Value text box.

3. To specify how much space the browser allocates to each frame, select from the following choices in the Units menu:

   **Pixels** Sets the size of the selected column or row to an absolute value. Choose this option for a frame that should always be the same size, such as a navigation bar. Frames with sizes specified in pixels are allocated space before frames with sizes specified as percent or relative. The most common approach to frame sizes is to set a left-side frame to a fixed pixel width and to set a right-size frame to relative, which enables the right frame to stretch to take up all the remaining space after the pixel width is allocated.

   **Note:** If all of your widths are specified in pixels, and a visitor views the frameset in a browser that’s too wide or too narrow for the width you specified, then the frames stretch or shrink proportionately to fill the available space. The same applies to heights specified in pixels. Thus, it’s generally a good idea to specify at least one width and height as relative.

   **Percent** Specifies that the selected column or row should be a percentage of the total width or height of its frameset. Frames with units set to Percent are allocated space after frames with units set to Pixels, but before frames with units set to Relative.

   **Relative** Specifies that the selected column or row be allocated the rest of the available space after Pixels and Percent frames have had space allocated; that remaining space is divided proportionally among the frames with sizes set to Relative.

   **Note:** When you select Relative from the Units menu, any number you’ve entered in the Value field disappears; if you want to specify a number, you must re-enter it. If there’s only one row or column set to Relative, though, there’s no need to enter a number, since that row or column receives all the remaining space after the other rows and columns have space allocated. To be certain of full cross-browser compatibility, you can enter 1 in the Value field; that’s equivalent to entering no value.
Control frame content with links

To use a link in one frame to open a document in another frame, you must set a target for the link. The target attribute of a link specifies the frame or window in which the linked content opens.

For example, if your navigation bar is in the left frame, and you want the linked material to appear in the main content frame on the right, you must specify the name of the main content frame as the target for each of the navigation bar links. When a visitor clicks a navigation link, the specified content opens in the main frame.

1. In Design view, select text or an object.
2. In the Link box in the Property inspector (Window > Properties), do one of the following:
   - Click the folder icon and select the file to link to.
   - Drag the Point to File icon to the Files panel and select the file to link to.
3. In the Target menu in the Property inspector, select the frame or window in which the linked document should appear:
   - _blank opens the linked document in a new browser window, leaving the current window untouched.
   - _parent opens the linked document in the parent frameset of the frame the link appears in, replacing the entire frameset.
   - _self opens the link in the current frame, replacing the content in that frame.
   - _top opens the linked document in the current browser window, replacing all frames.

Frame names also appear in this menu. Select a named frame to open the linked document in that frame.

Note: Frame names appear only when you're editing a document within a frameset. When you edit a document in its own Document window, frame names do not appear in the Target pop-up menu. If you're editing a document outside of the frameset, you can type the target frame's name in the Target text box.

If you're linking to a page outside of your site, always use target="_top" or target="_blank" to ensure that the page doesn't appear to be part of your site.

Provide content for browsers without frame support

Dreamweaver lets you specify content to display in text-based browsers and in older graphical browsers that do not support frames. This content is stored in the frameset file, wrapped in a noframes tag. When a browser that doesn't support frames loads the frameset file, the browser displays only the content enclosed by the noframes tag.

Note: Content in the noframes area should be more than just a note saying "You should upgrade to a browser that can handle frames." Some site visitors use systems that don't allow them to view frames.

1. Select Modify > Frameset > Edit NoFrames Content.
Dreamweaver clears the Design view, and the words "NoFrames Content" appear at the top of the Design view.
2. Do one of the following:
   - In the Document window, type or insert the content just as you would for an ordinary document.
   - Select Window > Code Inspector, place the insertion point between the body tags that appear inside the noframes tags, then type the HTML code for the content.
3. Select Modify > Frameset > Edit NoFrames Content again to return to the normal view of the frameset document.
Using JavaScript behaviors with frames

There are several JavaScript behaviors and navigation-related commands that are particularly appropriate for use with frames:

**Set Text Of Frame**  Replaces the content and formatting of a given frame with the content you specify. The content can include any valid HTML. Use this action to dynamically display information in a frame.

**Go To URL**  Opens a new page in the current window or in the specified frame. This action is particularly useful for changing the contents of two or more frames with one click.

**Insert Jump Menu**  Sets up a menu list of links that open files in a browser window when clicked. You can also target a particular window or frame in which the document opens.

For more information, see “Adding JavaScript behaviors” on page 333.

**More Help topics**

“Apply the Set Text Of Frame behavior” on page 342

“Apply the Go To URL behavior” on page 339

“Apply the Set Nav Bar Image behavior” on page 342

“Apply the Jump Menu behavior” on page 340
Chapter 8: Adding content to pages

Use the Insert panel

The Insert panel contains buttons for creating and inserting objects such as tables and images. The buttons are organized into categories.

More Help topics
“Insert panel overview” on page 13
“Edit tags with Tag editors” on page 300
“Select and view elements in the Document window” on page 205

Hide or show the Insert panel
❖ Select Window > Insert.

Note: If you are working with certain types of files, such as XML, JavaScript, Java, and CSS, the Insert panel and the Design view option are dimmed because you cannot insert items into these code files.

Show the buttons in a particular category
❖ Select the category name from the Category pop-up menu. For example, to show buttons for the Layout category, select Layout.

Display the pop-up menu for a button
❖ Click the down arrow beside the button’s icon.
Insert an object
1 Select the appropriate category from the Category pop-up menu of the Insert panel.
2 Do one of the following:
   • Click an object button or drag the button’s icon into the Document window.
   • Click the arrow on a button, then select an option from the menu.
Depending on the object, a corresponding object-insertion dialog box may appear, prompting you to browse to a file or specify parameters for an object. Or, Dreamweaver may insert code into the document, or open a tag editor or a panel for you to specify information before the code is inserted.
For some objects, no dialog box appears if you insert the object in Design view, but a tag editor appears if you insert the object in Code view. For a few objects, inserting the object in Design view causes Dreamweaver to switch to Code view before inserting the object.

Note: Some objects, such as named anchors, are not visible when the page is viewed in a browser window. You can display icons in Design view that mark the locations of such invisible objects.

Bypass the object-insertion dialog box and insert an empty placeholder object
❖ Control-click (Windows) or Option-click (Macintosh) the button for the object.
For example, to insert a placeholder for an image without specifying an image file, Control-click or Option-click the Image button.

Note: This procedure does not bypass all object-insertion dialog boxes. Many objects, including AP elements and framesets, do not insert placeholders or default-valued objects.

Modify preferences for the Insert panel
1 Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).
2 In the General category of the Preferences dialog box, deselect Show Dialog When Inserting Objects to suppress dialog boxes when you insert objects such as images, tables, scripts, and head elements or by holding down the Control key (Windows) or the Option key (Macintosh) while creating the object.

When you insert an object with this option off, the object is given default attribute values. Use the Property inspector to change object properties after inserting the object.

Add, delete, or manage items in the Favorites category of the Insert panel
1 Select any category in the Insert panel.
2 Right-click (Windows) or Control-click (Macintosh) in the area where the buttons appear, and then select Customize Favorites.
3 In the Customize Favorite Objects dialog box, make changes as necessary, and click OK.
   • To add an object, select an object in the Available Objects pane on the left, and then click the arrow between the two panes or double-click the object in the Available Objects pane.

Note: You can add one object at a time. You cannot select a category name, such as Common, to add an entire category to your favorites list.
• To delete an object or separator, select an object in the Favorite Objects pane on the right, and then click the Remove Selected Object in Favorite Objects List button above the pane.

• To move an object, select an object in the Favorite Objects pane on the right, and then click the Up or Down arrow button above the pane.

• To add a separator below an object, select an object in the Favorite Objects pane on the right, and then click the Add Separator button below the pane.

4 If you’re not in the Favorites category of the Insert panel, select that category to see your changes.

**Insert objects using buttons in the Favorites category**

❖ Select the Favorites category from the Category pop-up menu of the Insert panel, and then click the button for any Favorites object that you added.

**Display the Insert panel as a horizontal Insert bar**

Unlike other panels in Dreamweaver, you can drag the Insert panel out of its default dock position and drop it into a horizontal position at the top of the Document window. When you do so, it changes from a panel to a toolbar (though you cannot hide and display it in the same way as other toolbars).

1 Click the Insert panel’s tab and drag it to the top of the Document window.

2 When you see a horizontal blue line across the top of the Document window, drop the Insert panel into position.

*Note:* The horizontal Insert bar is also a default part of the Classic workspace. To switch to the Classic workspace, select Classic from the workspace switcher in the Application bar.
Return the horizontal Insert bar to a panel group

1. Click the horizontal Insert bar’s gripper (on the left side of the Insert bar) and drag the bar to the place where your panels are docked.

2. Position the Insert panel and drop it. A blue line indicates where you can drop the panel.

Show horizontal Insert bar categories as tabs

❖ Click the arrow beside the category name on the left end of the horizontal Insert bar, and then select Show as Tabs.

Show horizontal Insert bar categories as a menu

❖ Right-click (Windows) or Control-click (Macintosh) a category tab in the horizontal Insert bar, and then select Show as Menus.

Set page properties

For each page you create in Dreamweaver, you can specify layout and formatting properties using the Page Properties dialog box (Modify > Page Properties). The Page Properties dialog box lets you specify the default font family and font size, background color, margins, link styles, and many other aspects of page design. You can assign new page properties for each new page you create, and modify those for existing pages. Changes you make in the Page Properties dialog box apply to the entire page.

Dreamweaver gives you two methods for modifying page properties: CSS or HTML. Adobe recommends using CSS to set backgrounds and modify page properties.

Note: The page properties you choose apply only to the active document. If a page uses an external CSS style sheet, Dreamweaver does not overwrite the tags set in the style sheet, as this affects all other pages using that style sheet.

Set CSS page font, background color, and background image properties

Use the Page Properties dialog box to specify several basic page layout options for your web pages, including the font, background color, and background image.

1. Select Modify > Page Properties, or click the Page Properties button in the text Property inspector.

2. Select the Appearance (CSS) category and set the options.

Page Font Specifies the default font family to use in your web pages. Dreamweaver uses the font family you specify unless another font is specifically set for a text element.

Size Specifies the default font size to use in your web pages. Dreamweaver uses the font size you specify unless another font size is specifically set for a text element.

Text Color Specifies the default color to render fonts with.

Background Color Sets a background color for your page. Click the Background color box and select a color from the Color Picker.

Background Image Sets a background image. Click the Browse button, then browse to and select the image. Alternatively, enter the path to the background image in the Background Image box.

Dreamweaver tiles (repeats) the background image if it does not fill the entire window, just as browsers do. (To prevent the background image from tiling, use...
Cascading Style Sheets to disable image tiling.)

**Repeat** Specifies how the background image will be displayed on the page:
- Select the No-repeat option to display the background image only once.
- Select the Repeat option to repeat, or tile, the image both horizontally and vertically.
- Select the Repeat-x option to tile the image horizontally.
- Select the Repeat-y option to tile the image vertically.

**Left Margin and Right Margin** Specify the size of the left and right page margins.

**Top Margin and Bottom Margin** Specify the size of the top and bottom page margins.

### Set HTML page properties

Setting properties in this category of the Page Properties dialog box results in HTML rather than CSS formatting of your page.

1. Select Modify > Page Properties, or click the Page Properties button in the text Property inspector.
2. Select the Appearance (HTML) category and set the options.

**Background Image** Sets a background image. Click the Browse button, then browse to and select the image. Alternatively, enter the path to the background image in the Background Image box.

Dreamweaver tiles (repeats) the background image if it does not fill the entire window, just as browsers do. (To prevent the background image from tiling, use Cascading Style Sheets to disable image tiling.)

**Background** Sets a background color for your page. Click the Background color box and select a color from the Color Picker.

**Text** Specifies the default color to render fonts with.

**Link** Specifies the color to apply to link text.

**Visited Links** Specifies the color to apply to visited links.

**Active Links** Specifies the color to apply when a mouse (or pointer) clicks on a link

**Left Margin and Right Margin** Specify the size of the left and right page margins.

**Top Margin and Bottom Margin** Specify the size of the top and bottom page margins.

### Set CSS link properties for an entire page

You can specify fonts, font sizes, colors, and other items for your links. By default, Dreamweaver creates CSS rules for your links and applies them to all links you use on the page. (The rules are embedded in the head section of the page.)

**Note:** If you want to customize individual links on a page, you need to create individual CSS rules, and then apply them to the links separately.

1. Select Modify > Page Properties, or click the Page Properties button in the text Property inspector.
2 Choose the Links (CSS) category and set the options.

**Link Font** Specifies the default font family to use for link text. By default, Dreamweaver uses the font family specified for the entire page unless you specify another font.

**Size** Specifies the default font size to use for link text.

**Link Color** Specifies the color to apply to link text.

**Visited Links** Specifies the color to apply to visited links.

**Rollover Links** Specifies the color to apply when a mouse (or pointer) hovers over a link.

**Active Links** Specifies the color to apply when a mouse (or pointer) clicks on a link.

**Underline Style** Specifies the underline style to apply to links. If your page already has an underline link style defined (through an external CSS style sheet for example), the Underline Style menu defaults to a “don’t change” option. This option alerts you to a link style that has been defined. If you modify the underline link style using the Page Properties dialog box, Dreamweaver will change the previous link definition.

---

**Set CSS heading properties for an entire page**

You can specify fonts, font sizes, and colors for your page headings. By default, Dreamweaver creates CSS rules for your headings and applies them to all headings you use on the page. (The rules are embedded in the `head` section of the page.)

Headings are available for selection in HTML Property inspector.

1 Select Modify > Page Properties, or click the Page Properties button in the text Property inspector.

2 Choose the Headings (CSS) category and set the options.

**Heading Font** Specifies the default font family to use for headings. Dreamweaver will use the font family you specify unless another font is specifically set for a text element.

**Heading 1 through Heading 6** Specify the font size and color to use for up to six levels of heading tags.

---

**Set title and encoding properties for a page**

The Title/Encoding Page Properties options let you specify the document encoding type that is specific to the language used to author your web pages as well as specify which Unicode Normalization Form to use with that encoding type.

1 Select Modify > Page Properties, or click the Page Properties button in the text Property inspector.

2 Choose the Title/Encoding category and set the options.

**Title** Specifies the page title that appears in the title bar of the Document window and most browser windows.

**Document Type (DTD)** Specifies a document type definition. For example, you can make an HTML document XHTML-compliant by selecting XHTML 1.0 Transitional or XHTML 1.0 Strict from the pop-up menu.

**Encoding** Specifies the encoding used for characters in the document.

If you select Unicode (UTF-8) as the document encoding, entity encoding is not necessary because UTF-8 can safely represent all characters. If you select another document encoding, entity encoding may be necessary to represent certain characters. For more information on character entities, see [www.w3.org/TR/REC-html40/sgml/entities.html](http://www.w3.org/TR/REC-html40/sgml/entities.html).

**Reload** Converts the existing document, or reopens it using the new encoding.
Unicode Normalization Form  Enabled only if you select UTF-8 as a document encoding. There are four Unicode Normalization Forms. The most important is Normalization Form C because it’s the most common form used in the Character Model for the World Wide Web. Adobe provides the other three Unicode Normalization Forms for completeness.

In Unicode, some characters are visually similar but can be stored within the document in different ways. For example, “ë” (e-umlaut) can be represented as a single character, “e-umlaut,” or as two characters, “regular Latin e” + “combining umlaut.” A Unicode combining character is one that gets used with the previous character, so the umlaut would appear above the “Latin e.” Both forms result in the same visual typography, but what is saved in the file is different for each form.

Normalization is the process of making sure all characters that can be saved in different forms are all saved using the same form. That is, all “ë” characters in a document are saved as single “e-umlaut” or as “e” + “combining umlaut,” and not as both forms in one document.

For more information on Unicode Normalization and the specific forms that can be used, see the Unicode website at www.unicode.org/reports/tr15.

Include Unicode Signature (BOM)  Includes a Byte Order Mark (BOM) in the document. A BOM is 2 to 4 bytes at the beginning of a text file that identifies a file as Unicode, and if so, the byte order of the following bytes. Because UTF-8 has no byte order, adding a UTF-8 BOM is optional. For UTF-16 and UTF-32, it is required.

Use a tracing image to design a page

You can insert an image file to use as a guide in designing your page. The image appears as a background image, which you can “design over” as you lay out your page.

1  Select Modify > Page Properties, or click the Page Properties button in the text Property inspector.

2  Choose the Tracing Image category and set the options.

Tracing Image  Specifies an image to use as a guide for copying a design. This image is for reference only, and does not appear when the document is displayed in a browser.

Transparency  Determines the opacity of the tracing image, from completely transparent to completely opaque.

Understanding document encoding

Document encoding specifies the encoding used for characters in the document. Document encoding is specified in a meta tag in the head of the document; it tells the browser and Dreamweaver how the document should be decoded and what fonts should be used to display the decoded text.

For example, if you specify Western European (Latin1), this meta tag is inserted:

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">.

Dreamweaver displays the document using the fonts you specify in Fonts Preferences for the Western European (Latin1) encoding; a browser displays the document using the fonts the browser user specifies for the Western European (Latin1) encoding.

If you specify Japanese (Shift JIS), this meta tag is inserted:
Dreamweaver displays the document using the fonts you specify for the Japanese encoding; a browser displays the document using the fonts the browser user specifies for the Japanese encodings.

You can change document encoding for a page and change the default encoding that Dreamweaver uses to create new documents, including the fonts used to display each encoding.

**More Help topics**

“Set default document type and encoding” on page 66

---

**Select and view elements in the Document window**

To select an element in the Design view of the Document window, click the element. If an element is invisible, you must make it visible before you can select it.

Some HTML code doesn’t have a visible representation in a browser. For example, comment tags don’t appear in browsers. However, it can be useful while you’re creating a page to be able to select such invisible elements, edit them, move them, and delete them.

Dreamweaver enables you to specify whether it shows icons marking the location of invisible elements in the Design view of the Document window. To indicate which element markers appear, you can set options in Invisible Elements preferences. For example, you can specify that named anchors be visible, but not line breaks.

You can create certain invisible elements (such as comments and named anchors) using buttons in the Common category of the Insert panel. You can then modify these elements using the Property inspector.

**More Help topics**

“Viewing code” on page 286

“Use the Insert panel” on page 198

---

**Select elements**

- To select a visible element in the Document window, click the element or drag across the element.
- To select an invisible element, select View > Visual Aids > Invisible Elements (if that menu item isn’t already selected) and then click the element’s marker in the Document window.

Some objects appear on the page in a place other than where their code is inserted. For example, in Design view an absolutely-positioned element (AP element) can be anywhere on the page, but in Code view the code defining the AP element is in a fixed location. When invisible elements are showing, Dreamweaver displays markers in the Document window to show the location of the code for such elements. Selecting a marker selects the entire element; for example, selecting the marker for an AP element selects the entire AP element.

- To select a complete tag (including its contents, if any), click a tag in the tag selector at the lower left of the Document window. (The tag selector appears in both Design view and Code view.) The tag selector always shows the tags that contain the current selection or insertion point. The leftmost tag is the outermost tag containing the current selection or insertion point. The next tag is contained in that outermost tag, and so on; the rightmost tag is the innermost one that contains the current selection or insertion point.
In the following example, the insertion point is in a paragraph tag, `<p>`. To select the table containing the paragraph you want to select, select the `<table>` tag to the left of the `<p>` tag.

View the HTML code associated with the selected text or object

❖ Do one of the following:
  • In the Document toolbar, click the Show Code View button.
  • Select View > Code.
  • In the Document toolbar, click the Show Code and Design Views button.
  • Select View > Code and Design.
  • Select Window > Code Inspector.

When you select something in either code editor (Code view or the Code inspector), it’s generally also selected in the Document window. You may need to synchronize the two views before the selection appears.

Show or hide marker icons for invisible elements

❖ Select View > Visual Aids > Invisible Elements.

Note: Showing invisible elements may slightly change the layout of a page, moving other elements by a few pixels, so for precision layout, hide the invisible elements.

Set invisible elements preferences

Use Invisible Elements preferences to specify which kinds of elements will be visible when you select View > Visual Aids > Invisible Elements.

1 Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh), then click Invisible Elements.
2 Select which elements should be made visible and click OK.

Note: A check mark next to the name of the element in the dialog box means the element is visible when View > Visual Aids > Invisible Elements is selected.

Named Anchors Displays an icon that marks the location of each named anchor (`a` name = `""`) in the document.

Scripts Displays an icon that marks the location of JavaScript or VBScript code in the body of the document. Select the icon to edit the script in the Property inspector or to link to an external script file.

Comments Displays an icon that marks the location of HTML comments. Select the icon to see the comment in the Property inspector.

Line Breaks Displays an icon that marks the location of each line break (`<br>`). This option is deselected by default.

Client-Side Image Maps Displays an icon marking the location of each client-side image map in the document.

Embedded Styles Displays an icon showing the location of CSS styles embedded in the body section of the document. If CSS styles are placed in the head section of a document, they do not appear in the Document window.

Hidden Form Fields Displays an icon that marks the location of form fields that have the `type` attribute set to "hidden".
**Form Delimiter**  Displays a border around a form so you can see where to insert form elements. The border shows the extent of the `form` tag, so any form elements inside that border are properly enclosed in `form` tags.

**Anchor Points For AP elements**  Displays an icon that marks the location of code defining an AP element. The AP element itself can be anywhere on the page. (AP elements are not invisible elements; only the code defining the AP element is invisible.) Select the icon to select the AP element; you can then see the contents of the AP element even if the AP element is marked as hidden.

**Anchor Points For Aligned Elements**  Displays an icon showing the location of HTML code for elements that accept the `align` attribute. These include images, tables, ActiveX objects, plug-ins, and applets. In some cases, the code for the element may be separated from the visible object.

**Visual Server Markup Tags**  Displays the location of server markup tags (such as Active Server Pages tags and ColdFusion tags) whose content cannot be displayed in the Document window. These tags typically generate HTML tags when processed by a server. For example, a `<CFGRAPH>` tag generates an HTML table when processed by a ColdFusion server. Dreamweaver represents the tag with a ColdFusion invisible element since Dreamweaver cannot determine the final, dynamic output of the page.

**Nonvisual Server Markup Tags**  Displays the location of server markup tags (such as Active Server Pages tags and ColdFusion tags) whose content cannot be displayed in the Document window. These tags are typically set-up, processing, or logic tags (for example, `<CFSET>`, `<CFWDDX>`, and `<CFXML>`) that do not generate HTML tags.

**CSS Display: None**  Displays an icon showing the location of content that's hidden by the `display:none` property in the linked or embedded stylesheet.

**Show Dynamic Text As**  Displays any dynamic text on your page in the format of `{Recordset:Field}` by default. If the length of these values is long enough to distort your page's formatting, you can change the display to `[]` instead.

**Server-Side Includes**  Displays the actual contents of each server-side include file.

**Colors**

**Web-safe colors**

In HTML, colors are expressed either as hexadecimal values (for example, `#FF0000`) or as color names (red). A web-safe color is one that appears the same in Safari and Microsoft Internet Explorer on both Windows and Macintosh systems when running in 256-color mode. The conventional wisdom is that there are 216 common colors, and that any hexadecimal value that combines the pairs 00, 33, 66, 99, CC, or FF (RGB values 0, 51, 102, 153, 204, and 255, respectively) represents a web-safe color.

Testing, however, reveals that there are only 212 web-safe colors rather than a full 216, because Internet Explorer on Windows does not correctly render the colors `#0033FF (0,51,255)`, `#3300FF (51,0,255)`, `#00FF33 (0,255,51)`, and `#33FF00 (51,255,0)`.

When web browsers first made their appearance, most computers displayed only 265 colors (8 bits per channel (bpc)). Today, the majority of computers display thousands or millions of colors (16- and 32-bpc), so the justification for using the browser-safe palette is greatly diminished if you are developing your site for users with current computer systems.

One reason to use the web-safe color palette is if you are developing for alternative web devices such as PDA and cell phone displays. Many of this devices offer only black and white (1-bpc) or 256 color (8-bpc) displays.

The Color Cubes (default) and the Continuous Tone palettes in Dreamweaver use the 216-color web-safe palette; selecting a color from these palettes displays the color's hexadecimal value.

Last updated 12/7/2011
To select a color outside the web-safe range, open the system color picker by clicking the Color Wheel button in the upper-right corner of the Dreamweaver color picker. The system color picker is not limited to web-safe colors.

UNIX versions of browsers use a different color palette than the Windows and Macintosh versions. If you are developing exclusively for UNIX browsers (or your target audience is Windows or Macintosh users with 24-bpc monitors and UNIX users with 8-bpc monitors), consider using hexadecimal values that combine the pairs 00, 40, 80, BF, or FF, which produce web-safe colors for SunOS.

**Use the color picker**

In Dreamweaver, many of the dialog boxes, as well as the Property inspector for many page elements, contain a color box, which opens a color picker. Use the color picker to select a color for a page element. You can also set the default text color for your page elements.

1. Click a color box in any dialog box or in the Property inspector. The color picker appears.
2. Do one of the following:
   - Use the eyedropper to select a color swatch from the palette. All colors in the Color Cubes (default) and Continuous Tone palettes are web-safe; other palettes are not.
   - Use the eyedropper to pick up a color from anywhere on your screen—even outside the Dreamweaver windows. To pick up a color from the desktop or another application, press and hold the mouse button; this allows the eyedropper to retain focus, and select a color outside of Dreamweaver. If you click the desktop or another application, Dreamweaver picks up the color where you clicked. However, if you switch to another application, you may need to click a Dreamweaver window to continue working in Dreamweaver.
   - To expand your color selection, use the pop-up menu at the upper-right corner of the color picker. You can select Color Cubes, Continuous Tone, Windows OS, Mac OS, and Grayscale.

   *Note:* The Color Cubes and Continuous Tone palettes are web-safe, whereas Windows OS, Mac OS and Grayscale are not.
   - To clear the current color without choosing a different color, click the Default Color button.
   - To open the system color picker, click the Color Wheel button.

**Zoom in and out**

Dreamweaver lets you increase the magnification (zoom in) in the Document window so that you can check the pixel accuracy of graphics, select small items more easily, design pages with small text, design large pages, and so on.

*Note:* The zooming tools are only available in Design view.

**More Help topics**

“Status bar overview” on page 12

**Zoom in or out on a page**

1. Click the Zoom tool (the magnifying glass icon) in the lower-right corner of the Document window.
2. Do one of the following:
   - Click the spot on the page you want to magnify until you’ve achieved the desired magnification.
• Drag a box over the area on the page that you want to zoom in on and release the mouse button.
• Select a preset magnification level from the Zoom pop-up menu.
• Type a magnification level in the Zoom text box.

You can also zoom in without using the Zoom tool by pressing Control+= (Windows) or Command+= (Macintosh).

3 To zoom out (reduce magnification), select the Zoom tool, press Alt (Windows) or Option (Macintosh) and click on the page.

You can also zoom out without using the Zoom tool by pressing Control+- (Windows) or Command+- (Macintosh).

Edit a page after zooming
❖ Click the Select tool (the pointer icon) in the lower-right corner of the Document window, and click inside the page.

Pan a page after zooming
1 Click the Hand tool (the hand icon) in the lower-right corner of the Document window.
2 Drag the page.

Fill the Document window with a selection
1 Select an element on the page.
2 Select View > Fit Selection.

Fill the Document window with an entire page
❖ Select View >
❖ Fit All
❖ .

Fill the Document window with the entire width of a page
❖ Select View >
❖ Fit Width
❖ .

Set download time and size preferences

Dreamweaver calculates size based on the entire contents of the page, including all linked objects, such as images and plug-ins. Dreamweaver estimates download time based on the connection speed entered in Status Bar preferences. Actual download time varies depending on general Internet conditions.

A good guideline to use when checking download times for a particular web page is the 8-second rule. That is, most users will not wait longer than 8 seconds for a page to load.

1 Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).
2. Select Status Bar from the Category list on the left.

3. Select a connection speed with which to calculate download time and click OK.

More Help topics
“Set window size and connection speed” on page 20

Working with text

Add text to a document
To add text to a Dreamweaver document, you can type text directly in the Document window, or you can cut and paste text. You can also import text from other documents.

When you paste text into a Dreamweaver document, you can use either the Paste or the Paste Special command. The Paste Special command lets you specify the format of pasted text in different ways. For example, if you wanted to paste text from a formatted Microsoft Word document into your Dreamweaver document, but wanted to strip out all of the formatting so that you could apply your own CSS style sheet to the pasted text, you could select the text in Word, copy it to your Clipboard, and use the Paste Special command to select the option that lets you paste text only.

When using the Paste command to paste text from other applications, you can set paste preferences as default options. Note: Control+V (Windows) and Command+V (Macintosh) always paste text only (no formatting) in Code view.

- Add text to your document by doing one of the following:
  - Type text directly into the Document window.
  - Copy text from another application, switch to Dreamweaver, position the insertion point in the Design view of the Document window, and select Edit > Paste or Edit > Paste Special.

When you select Edit > Paste Special, you can select several paste formatting options.

You can also paste text using the following keyboard shortcuts:

<table>
<thead>
<tr>
<th>Paste option</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Paste</td>
<td>Control+V (Windows) Command+V (Macintosh)</td>
</tr>
<tr>
<td>Paste Special</td>
<td>Control+Shift+V (Windows) Command+Shift+V (Macintosh)</td>
</tr>
</tbody>
</table>

Insert special characters
Certain special characters are represented in HTML by a name or a number, referred to as an entity. HTML includes entity names for characters such as the copyright symbol (©), the ampersand (&), and the registered-trademark symbol (®). Each entity has both a name (such as &copy;) and a numeric equivalent (such as &#169;).

HTML uses the angle brackets <> in its code, but you may need to express the special characters for greater than or less than without Dreamweaver interpreting them as code. In this case, use &gt; for greater than (>) and &lt; for less than (<).
Unfortunately, many older browsers don’t properly display many of the named entities.

1. In the Document window, place the insertion point where you want to insert a special character.

2. Do one of the following:
   - Select the name of the character from the Insert > HTML > Special Characters submenu.
   - In the Text category of the Insert panel, click the Characters button and select the character from the submenu.
   
   There are many other special characters available; to select one of them, select Insert > HTML > Special Characters > Other or click the Characters button in the Text category of the Insert panel and select the Other Characters option. Select a character from the Insert Other Character dialog box, and click OK.

### Add space between characters

HTML only allows for one space between characters; to add additional space in a document you must insert a non-breaking space. You can set a preference to automatically add non-breaking spaces in a document.

#### Insert a non-breaking space

- Do one of the following:
  - Select Insert > HTML > Special Characters > Non-Breaking Space.
  - Press Control+Shift+Spacebar (Windows) or Option+Spacebar (Macintosh).
  - In the Text category of the Insert panel, click the Characters button and select the Non-Breaking Space icon.

#### Set a preference to add non-breaking spaces

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).
2. In the General category make sure Allow Multiple Consecutive Spaces is checked.

### Add paragraph spacing

Dreamweaver works similarly to many word processing application: you press Enter (Windows) or Return (Macintosh) to create a new paragraph. Web browsers automatically insert a blank line of space between paragraphs. You can add a single line of space between paragraphs by inserting a line break.

#### Add a paragraph return

- Press Enter (Windows) or Return (Macintosh).

#### Add a line break

- Do one of the following:
  - Press Shift+Enter (Windows) or Shift+Return (Macintosh).
  - Select Insert > HTML > Special Characters > Line Break.
  - In the Text category of the Insert panel, click the Characters button and select the Line Break icon.

### Create bulleted and numbered lists

You can create numbered (ordered) lists, bulleted (unordered) lists, and definition lists from existing text or from new text as you type in the Document window.
Definition lists do not use leading characters like bullet points or numbers and are often used in glossaries or descriptions. Lists can also be nested. Nested lists are lists that contain other lists. For example, you might want an ordered or bulleted list nested within another numbered or ordered list.

You use the List Properties dialog box to set the appearance of an entire list or for an individual list item. You can set number style, reset numbering, or set bullet style options for individual list items or for the entire list.

More Help topics
“Set CSS properties” on page 129

Create a new list
1 In the Dreamweaver document, place the insertion point where you want to add a list, then do one of the following:
   • In the HTML Property inspector, click either the Bulleted or Numbered List button.
   • Select Format > List and select the type of list desired—Unordered (bulleted) List, Ordered (numbered) List, or Definition List.
The leading character for the specified list item appears in the Document window.
2 Type the list item text, then press Enter (Windows) or Return (Macintosh) to create another list item.
3 To complete the list, press Enter twice (Windows) or press Return twice (Macintosh).

Create a list using existing text
1 Select a series of paragraphs to make into a list.
2 In the HTML Property inspector, click the Bulleted or Numbered List button, or select Format > List and select the type of list desired—Unordered List, Ordered List, or Definition List.

Create a nested list
1 Select the list items you want to nest.
2 In the HTML Property inspector, click the Blockquote button, or select Format > Indent.
Dreamweaver indents the text and creates a separate list with the original list’s HTML attributes.
3 Apply a new list type or style to the indented text by following the same procedure used above.

Set list properties for an entire list
1 In the Document window, create at least one list item. The new style will automatically apply to additional items you add to the list.
2 With the insertion point in the list item’s text, select Format > List > Properties to open the List Properties dialog box.
3 Set the options you want to define the list:
   List Type Specifies list properties while List Item specifies an individual item in a list. Use the pop-up menu to select a bulleted, numbered, directory, or menu list. Depending on the List Type you select different options appear in the dialog box.
   Style Determines the style of numbers or bullets used for a numbered or bulleted list. All items in the list will have this style unless you specify a new style for items within the list.
   Start Count Sets the value for the first item in a numbered list.
4 Click OK to set the choices.
Set list properties for a list item

1. In the Document window, place the insertion point in the text of a list item you want to affect.

2. Select Format > List > Properties.

3. Under List Item, set the options you want to define:

   - **New Style**: Specifies a style for the selected list item. Styles in the New Style menu are related to the type of list displayed in the List Type menu. For example, if the List Item menu displays Bulleted List, only bullet options are available in the New Style menu.

   - **Reset Count To**: Sets a specific number from which to number list item entries.

4. Click OK to set the options.

Search for and replace text

You can use the Find And Replace command to search for text and for HTML tags and attributes in a document or a set of documents. The Search panel, in the Results panel group, shows the results of a Find All search.

*Note*: To search for files in a site, use different commands: Locate In Local Site and Locate In Remote Site.

More Help topics

- “Viewing code” on page 286
- “Regular expressions” on page 283

Search for and replace text

1. Open the document to search in, or select documents or a folder in the Files panel.

2. Select Edit > Find And Replace.

3. Use the Find In option to specify which files to search:

   - **Selected Text**: Confines the search to the text that’s currently selected in the active document.

   - **Current Document**: Confines the search to the active document.

   - **Open Documents**: Searches all documents that are currently open.

   - **Folder**: Confines the search to a specific folder. After choosing Folder, click the folder icon to browse to and select a folder to search.

   - **Selected Files In Site**: Confines the search to the files and folders that are currently selected in the Files panel.

   - **Entire Current Local Site**: Expands the search to all the HTML documents, library files, and text documents in the current site.

4. Use the Search pop-up menu to specify the kind of search you want to perform:

   - **Source Code**: Searches for specific text strings in the HTML source code. You can search for specific tags using this option, but the Specific Tag search provides a more flexible approach to searching for tags.

   - **Text**: Searches for specific text strings in the text of the document. A text search ignores any HTML that interrupts the string. For example, a search for the **black** dog would match both the black dog and the &lt;i&gt;black&lt;/i&gt; dog.

   - **Text (Advanced)**: Searches for specific text strings that are either within or not within a tag or tags. For example, in a document that contains the following HTML, searching for **tries** and specifying Not Inside Tag and the i tag would find only the second instance of the word **tries**: John
tries to get his work done on time, but he doesn't always succeed. He tries very hard.

**Specific Tag**  Searches for specific tags, attributes, and attribute values, such as all `td` tags with `valign` set to `top`.

**Note:** Pressing Control+Enter or Shift+Enter (Windows), or Control+Return, Shift+Return, or Command+Return (Macintosh), adds line breaks within the text search fields, allowing you to search for a Return character. When performing such a search, deselect the Ignore Whitespace Differences option if you're not using regular expressions. This search finds a Return character in particular, not simply the occurrence of a line break; for instance, it doesn't find a `<br>` tag or a `<p>` tag. Return characters appear as spaces in the Design view, not as line breaks.

5  Use the following options to expand or limit the search:

**Match Case**  Limits the search to text that exactly matches the case of the text you want to find. For example, if you search for the `brown derby`, you will not find The Brown Derby.

**Ignore Whitespace**  Treats all whitespace as a single space for the purposes of matching. For example, with this option selected, this text would match this text and this text but not this text. This option is not available when the Use Regular Expressions option is selected; you must explicitly write your regular expression to ignore whitespace. Note that `<p>` and `<br>` tags do not count as whitespace.

**Match Whole Word**  Limits the search to text that matches one or more complete words.

**Use Regular Expressions**  Causes certain characters and short strings (such as ?, *, \w, and \b) in your search string to be interpreted as regular expression operators. For example, a search for the `b\w*\b dog` will match both the black dog and the barking dog.

**Note:** If you are working in Code view and make changes to your document, and try to find and replace anything other than source code, a dialog box appears letting you know that Dreamweaver is synchronizing the two views before doing the search.

6  To search without replacing, click Find Next or Find All:

**Find Next**  Jumps to and selects the next occurrence of the search text or tags in the current document. If there are no more instances of the tag in the current document, Dreamweaver proceeds to the next document, if you are searching in more than one document.

**Find All**  Opens the Search panel in the Results panel group. If you are searching a single document, Find All displays all occurrences of the search text or tags, with some surrounding context. If you are searching a directory or site, Find All displays a list of documents that contain the tag.

7  To replace found text or tags, click Replace or Replace All.

8  When you’re finished, click Close.

**Search again without displaying the Find And Replace dialog box**

❖  Press F3 (Windows) or Command+G (Macintosh).

**View a particular search result in context**

1  Select Window > Results to display the Search panel.

2  Double-click a line in the Search panel.
If you’re searching the current file, the Document window displays the line containing that search result. If you’re searching a set of files, the file containing that search result opens.

**Perform the same search again**
- Click the Find And Replace button.

**Stop a search in progress**
- Click the Stop button.

**Search for a specific tag**
Use the Find And Replace dialog box to search for text or tags in a document, and to replace the found material with other text or tags.

1. Select Edit > Find And Replace.
2. In the Search pop-up menu, select Specific Tag.
3. Select a specific tag or [any tag] from the pop-up menu next to the Search pop-up menu, or type a tag name in the text box.
4. (Optional.) Limit the search with one of the following tag modifiers:
   - **With Attribute** Specifies an attribute that must be in the tag for it to match. You can specify a particular value for the attribute or select [any value].
   - **Without Attribute** Selects an attribute that must not be in the tag for it to match. For example, select this option to search for all `img` tags with no `alt` attribute.
   - **Containing** Specifies text or a tag that must be contained within the original tag for it to match. For example, in the code `<b><font size="4">heading 1</font></b>`, the `font` tag is contained within the `b` tag.
   - **Not Containing** Specifies text or a tag that must not be contained within the original tag for it to match.
   - **Inside Tag** Specifies a tag that the target tag must be contained in for it to match.
   - **Not Inside Tag** Specifies a tag that the target tag must not be contained in for it to match.
5. (Optional.) To limit the search further, click the Plus (+) button and repeat step 3.
6. If you didn’t apply any tag modifiers in steps 3 and 4, then click the Minus (-) button to remove the tag modifiers pop-up menu.
7. If you want to perform an action when the tag is found (such as removing or replacing the tag), select the action from the Action pop-up menu and, if applicable, specify any additional information necessary to perform the action.

**Search for specific text (Advanced)**
Use the Find and Replace dialog box to search for text or tags in a document, and to replace the found material with other text or tags.

1. Select Edit > Find and Replace.
2. In the Search pop-up menu, select Text (Advanced).
3. Enter text in the text field adjacent to the Search pop-up menu.
   - For example, type the word *Untitled*.
4 Select Inside Tag or Not Inside Tag, and then select a tag from the adjacent pop-up menu. For example, select Inside Tag and then title.

5 (Optional.) Click the Plus (+) button to limit the search with one of the following tag modifiers:
   With Attribute Specifies an attribute that must be in the tag for it to match. You can specify a particular value for the attribute or select [any value].
   Without Attribute Selects an attribute that must not be in the tag for it to match. For example, select this option to search for all img tags with no alt attribute.
   Containing Specifies text or a tag that must be contained within the original tag for it to match. For example, in the code `<b><font size="4">heading 1</font></b>`, the font tag is contained within the b tag.
   Not Containing Specifies text or a tag that must not be contained within the original tag for it to match.
   Inside Tag Specifies a tag that the target tag must be contained in for it to match.
   Not Inside Tag Specifies a tag that the target tag must not be contained in for it to match.

6 (Optional.) To limit the search further, repeat step 4.

Define abbreviations and acronyms

HTML provides tags that let you define the abbreviations and acronyms you use in your page for search engines, spell checkers, language translation programs, or speech synthesizers. For example, you might want to specify that the abbreviation ME in your page stands for mechanical engineer, or the acronym WHO stands for World Health Organization.

1 Select the abbreviation or acronym in the text of your page.
2 Select Insert > HTML > Text Objects > Abbreviation, or Insert > HTML > Text Objects > Acronym.
3 Enter the full text of the acronym or abbreviation.
4 Enter the language, such as en for English, de for German, or it for Italian.

Set copy and paste preferences

You can set special paste preferences as default options when using Edit > Paste to paste text from other applications. For example, if you always want to paste text as text only, or text with basic formatting, you can set the default option in the Copy/Paste Preferences dialog box.

Note: When you paste text into a Dreamweaver document, you can use either the Paste or the Paste Special command. The Paste Special command lets you specify the format of pasted text in different ways. For example, if you wanted to paste text from a formatted Microsoft Word document into your Dreamweaver document, but wanted to strip out all of the formatting so that you could apply your own CSS style sheet to the pasted text, you could select the text in Word, copy it to your Clipboard, and use the Paste Special command to select the option that lets you paste text only.

Note: Preferences set in the Copy/Paste Preferences dialog box apply only to material pasted into Design view.

1 Select Edit > Preferences (Windows) or Dreamweaver Preferences (Macintosh).
2 Click the Copy/Paste category.
3 Set the following options and click OK.
   Text Only Lets you paste unformatted text. If the original text is formatted, all formatting, including line breaks and paragraphs, will be removed.
Text With Structure  Lets you paste text that retains structure, but does not retain basic formatting. For example, you can paste text and retain the structure of paragraphs, lists, and tables, without retaining bold, italics, and other formatting.

Text With Structure Plus Basic Formatting  Lets you paste both structured and simple HTML-formatted text (e.g., paragraphs and tables, as well as text formatted with the $b$, $i$, $u$, $strong$, $em$, $hr$, $abbr$, or $acronym$ tag).

Text With Structure Plus Full Formatting Lets you paste text that retains all structure, HTML formatting, and CSS styles.

Note: The Full Formatting option cannot retain CSS styles that come from an external style sheet, nor can it retain styles if the application from which you are pasting does not retain styles upon pasting to the Clipboard.

Retain Line Breaks  Lets you keep line breaks in pasted text. This option is disabled if you have selected Text Only.

Clean Up Word Paragraph Spacing  Select this option if you selected Text With Structure or Text With Structure Plus Basic Formatting, and want to eliminate extra space between paragraphs when you paste your text.

Set text properties in the Property inspector

You can use the text Property inspector to apply HTML formatting or Cascading Style Sheet (CSS) formatting. When you apply HTML formatting, Dreamweaver adds properties to the HTML code in the body of your page. When you apply CSS formatting, Dreamweaver writes properties to the head of the document or to a separate style sheet.

Note: When you create CSS inline styles, Dreamweaver adds style attribute code directly to the body of the page.

About formatting text (CSS versus HTML)

Formatting text in Dreamweaver is similar to using a standard word processor. You can set default formatting styles (Paragraph, Heading 1, Heading 2, and so on) for a block of text, change the font, size, color, and alignment of selected text, or apply text styles such as bold, italic, code (monospace), and underline.

Dreamweaver has two Property inspectors, integrated into one: the CSS Property inspector and the HTML Property inspector. When you use the CSS Property inspector, Dreamweaver formats text using Cascading Style Sheets (CSS). CSS gives web designers and developers greater control over web page design, while providing improved features for accessibility and reduced file size. The CSS Property inspector lets you access existing styles, as well as create new ones.

Using CSS is a way to control the style of a web page without compromising its structure. By separating visual design elements (fonts, colors, margins, and so on) from the structural logic of a web page, CSS gives web designers visual and typographic control without sacrificing the integrity of the content. In addition, defining typographic design and page layout from within a single, distinct block of code—without having to resort to image maps, font tags, tables, and spacer GIFs—allows for faster downloads, streamlined site maintenance, and a central point from which to control design attributes across multiple web pages.

You can store styles created with CSS directly in the document, or for more power and flexibility, you can store styles in an external style sheet. If you attach an external style sheet to several web pages, all the pages automatically reflect any changes you make to the style sheet. To access all CSS rules for a page, use the CSS Styles panel (Window > CSS Styles). To access rules that apply to a current selection, use the CSS Styles panel (Current mode) or the Targeted Rule pop-up menu in the CSS Property inspector.
If you prefer, you can use HTML markup tags to format text in your web pages. To use HTML tags instead of CSS, format your text using the HTML Property inspector.

**Note:** You can combine CSS and HTML 3.2 formatting within the same page. Formatting is applied in a hierarchical manner: HTML 3.2 formatting overrides formatting applied by external CSS style sheets, and CSS embedded in a document overrides external CSS.

**More Help topics**

“Open the CSS Styles panel” on page 126

“Understanding Cascading Style Sheets” on page 118

### Edit CSS rules in the Property inspector

1. Open the Property inspector (Window > Properties), if it isn’t already open and click the CSS button.

2. Do one of the following:
   - Place the insertion point inside a block of text that’s been formatted by a rule you want to edit. The rule appears in the Targeted Rule pop-up menu.
   - Select a rule from the Targeted Rule pop-up menu.

3. Make changes to the rule by using the various options in the CSS Property inspector.

**Targeted Rule** Is the rule you are editing in the CSS Property inspector. When you have an existing style applied to text, the rule affecting the text’s format appears when you click inside the text on the page. You can also use the Targeted Rule pop-up menu to create new CSS rules, new in-line styles, or apply existing classes to selected text. If you’re creating a new rule, you’ll need to complete the New CSS Rule dialog box. For more information, see the links at the end of this topic.

**Edit Rule** Opens the CSS Rule Definition dialog box for the targeted rule. If you select New CSS Rule from the Targeted Rule pop-up menu and click the Edit Rule button, Dreamweaver opens the New CSS Rule definition dialog box instead.

**CSS Panel** Opens the CSS Styles panel and displays properties for the targeted rule in Current view.

**Font** Changes the font of the targeted rule.

**Size** Sets the font size for the targeted rule.

**Text Color** Sets the selected color as the font color in the targeted rule. Select a web-safe color by clicking the color box, or enter a hexadecimal value (for example, #FF0000) in the adjacent text field.

**Bold** Adds the bold property to the targeted rule.

**Italic** Adds the italics property to the targeted rule.

**Left, Center, and Right Align** Adds the respective alignment properties to the targeted rule.

**Note:** The Font, Size, Text Color, Bold, Italic, and Alignment properties always display the properties for the rule that applies to the current selection in the Document window. When you change any of these properties, you affect the targeted rule.

For a video tutorial about working with the CSS Property inspector, see [www.adobe.com/go/lrvid4041_dw](http://www.adobe.com/go/lrvid4041_dw).

### Set HTML formatting in the Property inspector

1. Open the Property inspector (Window > Properties), if it isn’t already open, and click the HTML button.

2. Select the text you want to format.
3 Set the options you want to apply to the selected text:

**Format**  Sets the paragraph style of the selected text. Paragraph applies the default format for a `<p>` tag, Heading 1 adds an `h1` tag, and so on.

**ID**  Assigns an ID to your selection. The ID pop-up menu (if applicable) lists all of the document’s unused, declared IDs.

**Class**  Displays the class style that is currently applied to the selected text. If no styles have been applied to the selection, the pop-up menu shows No CSS Style. If multiple styles have been applied to the selection, the menu is blank.

Use the Style menu to do any of the following:

- Select the style you want to apply to the selection.
- Select None to remove the currently selected style.
- Select Rename to rename the style.
- Select Attach Style Sheet to open a dialog box that lets you attach an external style sheet to the page.

**Bold**  Applies either `<b>` or `<strong>` to the selected text according to the style preference set in the General category of the Preferences dialog box.

**Italic**  Applies either `<i>` or `<em>` to the selected text according to the style preference set in the General category of the Preferences dialog box.

**Unordered List**  Creates a bulleted list of the selected text. If no text is selected, a new bulleted list is started.

**Ordered List**  Creates a numbered list of the selected text. If no text is selected, a new numbered list is started.

**Blockquote and Remove Blockquote**  Indent or remove indentation from the selected text by applying or removing the `blockquote` tag. In a list, indenting creates a nested list and removing the indentation unnests the list.

**Link**  Creates a hypertext link of the selected text. Click the folder icon to browse to a file in your site; type the URL; drag the Point-To-File icon to a file in the Files panel; or drag a file from the Files panel into the box.

**Title**  Specifies the textual tooltip for a hypertext link.

**Target**  Specifies the frame or window in which the linked document will load:

- `_blank` loads the linked file in a new, unnamed browser window.
- `_parent` loads the linked file in the parent frameset or window of the frame that contains the link. If the frame containing the link is not nested, the linked file loads into the full browser window.
- `_self` loads the linked file in the same frame or window as the link. This target is implied, so you generally don’t need to specify it.
- `_top` loads the linked file in the full browser window, thereby removing all frames.

**Rename a class from the HTML Property inspector**

Dreamweaver displays all of the classes available to your page in the Class menu of the HTML Property inspector. You can rename styles in this list by selecting the Rename option at the end of the list of class styles.

1 Select Rename from the text Property inspector Style pop-up menu.
2 Select the style you want to rename from the Rename Style pop-up menu.
3 Enter a new name in the New Name text field and click OK.
Spell check a web page

Use the Check Spelling command to check the spelling in the current document. The document must be a web page (for example, an HTML, ColdFusion, or PHP page). The Check Spelling command does not work on text files or XML files.

Additionally, the Check Spelling command ignores HTML tags and attribute values.

Note: Dreamweaver can only spell check the file that is currently open in the Document window. It cannot spell check all of the files in a site simultaneously.

By default, the spelling checker uses the U.S. English spelling dictionary. To change the dictionary, select Edit > Preferences > General (Windows) or Dreamweaver > Preferences > General (Macintosh), then in the Spelling Dictionary pop-up menu select the dictionary you want to use.

1. Select Commands > Check Spelling or press Shift+F7.
   When Dreamweaver encounters an unrecognized word, the Check Spelling dialog box appears.

2. Select the appropriate option based on how you want the discrepancy handled.
   - **Add To Personal** Adds the unrecognized word to your personal dictionary.
   - **Ignore** Ignores this instance of the unrecognized word.
   - **Change** Replaces this instance of the unrecognized word with text that you type in the Change To text box or with the selection in the Suggestions list.
   - **Ignore All** Ignores all instances of the unrecognized word.
   - **Change All** Replaces all instances of the unrecognized word in the same manner.

Note: Dreamweaver does not provide a way of deleting entries that have been added to personal dictionaries.

Import tabular data

You can import tabular data into your document by first saving the files (such as Microsoft Excel files or database files) as delimited text files.

You can import and format tabular data and import text from Microsoft Word HTML documents.

You can also add text from Microsoft Excel documents to a Dreamweaver document by importing the contents of the Excel file into a web page.

1. Select File > Import > Import Tabular Data, or Insert > Table Objects > Import Tabular Data.
2. Browse for the file you want or enter its name in the text box.
3. Select the delimiter used when the file was saved as delimited text. Your options are Tab, Comma, Semicolon, Colon, and Other.
   If you select Other, a blank field appears next to the option. Enter the character that was used as a delimiter.
4. Use the remaining options to format or define the table into which the data will be imported and click OK.
Import Microsoft Office documents (Windows only)

You can insert the full contents of a Microsoft Word or Excel document in a new or existing web page. When you import a Word or Excel document, Dreamweaver receives the converted HTML and inserts it into your web page. The file’s size, after Dreamweaver receives the converted HTML, must be less than 300K.

Instead of importing the entire contents of a file, you can also paste portions of a Word document and preserve the formatting.

*Note: If you use Microsoft Office 97, you cannot import the contents of a Word or Excel document; you must insert a link to the document.*

1. Open the web page into which you want to insert the Word or Excel document.
2. In Design view, do one of the following to select the file:
   - Drag the file from its current location to the page where you want the content to appear.
   - Select File > Import > Word Document or File > Import > Excel Document.
3. In the Insert Document dialog box, browse to the file you want to add, select any of the formatting options from the Formatting pop-up menu at the bottom of the dialog box, and then click Open.

   - **Text Only** inserts unformatted text. If the original text is formatted, all formatting will be removed.
   - **Text With Structure** inserts text that retains structure, but does not retain basic formatting. For example, you can paste text and retain the structure of paragraphs, lists, and tables, without retaining bold, italics, and other formatting.
   - **Text With Structure Plus Basic Formatting** inserts both structured and simple HTML-formatted text (e.g., paragraphs and tables, as well as text formatted with the *b*, *i*, *u*, *strong*, *em*, *hr*, *abbr*, or *acronym* tag).
   - **Text With Structure Plus Full Formatting** inserts text that retains all structure, HTML formatting, and CSS styles.
   - **Clean Up Word Paragraph Spacing** eliminates extra space between paragraphs when you paste your text if you selected Text With Structure or Basic Formatting.

The contents of the Word or Excel document appear in your page.

Create a link to a Word or Excel document

You can insert a link to a Microsoft Word or Excel document in an existing page.

1. Open the page where you want the link to appear.
2. Drag the file from its current location to your Dreamweaver page, positioning the link wherever you want.
3. Select Create A Link, and then click OK.
4. If the document you are linking to is located outside of your site’s root folder, Dreamweaver prompts you to copy the document to the site root.
By copying the document to the site’s root folder, you ensure that the document will be available when you publish the website.

5. When you upload your page to your web server, make sure to upload the Word or Excel file, too.

Your page now contains a link to the Word or Excel document. The link text is the name of the linked file; you can change the link text in the Document window if you wish.

**Use HTML Formatting**

While CSS is the preferred method for formatting text, Dreamweaver still lets you format text with HTML.

**Format paragraphs**

Use the Format pop-up menu in the HTML Property inspector or the Format > Paragraph Format submenu to apply the standard paragraph and heading tags.

1. Place the insertion point in the paragraph, or select some of the text in the paragraph.
2. Using the Format > Paragraph Format submenu or the Format pop-up menu in the Property inspector, select an option:
   - Select a paragraph format (for example, Heading 1, Heading 2, Preformatted Text, and so on). The HTML tag associated with the selected style (for example, h1 for Heading 1, h2 for Heading 2, pre for Preformatted text, and so on) is applied to the entire paragraph.
   - Select None to remove a paragraph format.

When you apply a heading tag to a paragraph, Dreamweaver automatically adds the next line of text as a standard paragraph. To change this setting, select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh); then in the General category, under Editing Options, make sure Switch To Plain Paragraph After Heading is not selected.

**More Help topics**

“Set text properties in the Property inspector” on page 217

“Set CSS properties” on page 129

**Change the color of text**

You can change the default color of all the text in a page, or you can change the color of selected text in the page.

**More Help topics**

“Use the color picker” on page 208

**Define default text colors for a page**

- Select Modify > Page Properties > Appearance (HTML) or Links (HTML), and then select colors for the Text Color, Link Color, Visited Links, and Active Links options.

*Note: The active link color is the color that a link changes to while it’s being clicked. Some web browsers may not use the color you specify.*
Change the color of selected text
❖ Select Format > Color, select a color from the system color picker, and then click OK.

Align text
You align text with HTML using the Format > Align submenu. You can center any element on a page using the Format > Align > Center command.

Align text on a page
1 Select the text you want to align or simply insert the pointer at the beginning of the text.
2 Select Format > Align and select an alignment command.

Center page elements
1 Select the element (image, plug-in, table, or other page element) you want to center.
2 Select Format > Align > Center.

Note: You can align and center complete blocks of text; you cannot align or center part of a heading or part of a paragraph.

Indent text
Using the Indent command applies the blockquote HTML tag to a paragraph of text, indenting text on both sides of the page.
1 Place the insertion point in the paragraph you want to indent.
2 Select Format > Indent or Outdent, or select List > Indent or Outdent from the context menu.

Note: You can apply multiple indents to a paragraph. Each time you select this command, the text indents further from both sides of the document.

Apply font styles
You can use HTML to apply text formatting to one letter, or to entire paragraphs and blocks of text in a site. Use the Format menu to set or change font characteristics for selected text. You can set the font type, style (such as bold or italic), and size.
1 Select the text. If no text is selected, the option applies to subsequent text you type.
2 Select from the following options:
   • To change the font, select a font combination from the Format > Font submenu. Select Default to remove previously applied fonts. Default applies the default font for the selected text (either the browser default font or the font assigned to that tag in the CSS style sheet).
   • To change the font style, select a font style (Bold, Italic, Underline, and so on) from the Format > Style submenu.

More Help topics
“Creating pages with CSS” on page 118
“Create a new CSS rule” on page 128
Use horizontal rules

Horizontal rules (lines) are useful for organizing information. On a page, you can visually separate text and objects with one or more rules.

Create a horizontal rule
1 In the Document window, place the insertion point where you want to insert a horizontal rule.
2 Select Insert > HTML > Horizontal Rule.

Modify a horizontal rule
1 In the Document window, select the horizontal rule.
2 Select Window > Properties to open the Property inspector, and modify the properties as desired:
   The ID text box  Lets you specify an ID for the horizontal rule.
   W and H  Specify the width and height of the rule in pixels or as a percentage of the page size.
   Align  Specifies the alignment of the rule (Default, Left, Center, or Right). This setting applies only if the width of the rule is less than the width of the browser window.
   Shading  Specifies whether the rule is drawn with shading. Deselect this option to draw the rule in a solid color.
   Class  Lets you attach a style sheet, or apply a class from an already attached style sheet.

Modify font combinations

Use the Edit Font List command to set the font combinations that appear in the Property inspector and the Format > Font submenu.

Font combinations determine how a browser displays text in your web page. A browser uses the first font in the combination that is installed on the user’s system; if none of the fonts in the combination is installed, the browser displays the text as specified by the user’s browser preferences.

Modify font combinations
1 Select Format > Font > Edit Font List.
2 Select the font combination from the list at the top of the dialog box.

The fonts in the selected combination are listed in the Chosen Fonts list in the lower-left corner of the dialog box. To the right is a list of all available fonts installed on your system.
3 Do one of the following:
   • To add or remove fonts from a font combination, click the arrows button (<< or >>) between the Chosen Fonts list and the Available Fonts list.
   • To add or remove a font combination, click the Plus (+) and Minus (-) buttons at the top of the dialog box.
   • To add a font that is not installed on your system, type the font name in the text field below the Available Fonts list and click the << button to add it to the combination. Adding a font not installed on your system is useful, for example, for specifying a Windows-only font when you are developing pages on a Macintosh.
To move the font combination up or down in the list, click the arrow buttons at the top of the dialog box.

**Add a new combination to the font list**
1. Select Format > Font > Edit Font List.
2. Select a font from the Available Fonts list and click the << button to move the font to the Chosen Fonts list.
3. Repeat step 2 for each subsequent font in the combination.

   To add a font that is not installed on your system, type the font name in the text field below the Available Fonts list and click the << button to add the font to the combination. Adding a font not installed on your system is useful, for example, for specifying a Windows-only font when you are developing pages on a Macintosh.

4. When you have finished selecting specific fonts, select a generic font family from the Available Fonts menu and click the << button to move the generic font family to the Chosen Fonts list.

   Generic font families include cursive, fantasy, monospace, sans-serif, and serif. If none of the fonts in the Chosen Fonts list are available on the user’s system, the text appears in the default font associated with the generic font family. For example, the default monospace font on most systems is Courier.

**Insert dates**

Dreamweaver provides a convenient Date object, which inserts the current date in whatever format you prefer (with or without the time) and provides the option of updating that date whenever you save the file.

*Note: The dates and times shown in the Insert Date dialog box are not the current date, nor do they reflect the dates/times that a visitor sees when they display your site. They are examples only of the way you want to display this information.*

1. In the Document window, place the insertion point where you want the date to be inserted.
2. Do one of the following:
   - Select Insert > Date.
   - In the Common category of the Insert panel, click the Date button.
3. In the resulting dialog box, select a format for the name of the day of the week, a format for the date, and a format for the time.
4. If you want the inserted date to be updated every time you save the document, select Update Automatically On Save. If you want the date to become plain text when it’s inserted, and never update automatically, deselect that option.
5. Click OK to insert the date.

*If you have selected Update Automatically On Save, you can edit the date format after it has been inserted into the document by clicking on the formatted text and selecting Edit Date Format in the Property inspector.*
Adding and modifying images

About images
Many different types of graphic file formats exist, but three graphic file formats are generally used in web pages—GIF, JPEG, and PNG. GIF and JPEG file formats are the best supported and can be viewed by most browsers.

**GIF (Graphic Interchange Format)**  GIF files use a maximum of 256 colors, and are best for displaying noncontinuous-tone images or those with large areas of flat colors, such as navigation bars, buttons, icons, logos, or other images with uniform colors and tones.

**JPEG (Joint Photographic Experts Group)**  The JPEG file format is the superior format for photographic or continuous-tone images, because JPEG files can contain millions of colors. As the quality of a JPEG file increases, so does the file size and the file download time. You can often strike a good balance between the quality of the image and the file size by compressing a JPEG file.

**PNG (Portable Network Group)**  The PNG file format is a patent-free replacement for GIFs that includes support for indexed-color, gray scale, and true-color images, and alpha channel support for transparency. PNG is the native file format of Adobe® Fireworks®. PNG files retain all the original layer, vector, color, and effects information (such as drop shadows), and all elements are fully editable at all times. Files must have the .png file extension to be recognized as PNG files by Dreamweaver.

Insert an image
When you insert an image into a Dreamweaver document, a reference to the image file is generated in the HTML source code. To ensure that this reference is correct, the image file must be in the current site. If it is not in the current site, Dreamweaver asks whether you want to copy the file into the site.

You can also insert images dynamically. Dynamic images are those images that change often. For example, advertising banner rotation systems need to randomly select a single banner from a list of potential banners, and then dynamically display the selected banner’s image when a page is requested.

After you insert an image, you can set image tag accessibility attributes that can be read by screen readers for visually impaired users. These attributes can be edited in HTML code.

For a tutorial on inserting images, see [www.adobe.com/go/vid0148](http://www.adobe.com/go/vid0148).

1. Place the insertion point where you want the image to appear in the Document window and do one of the following:
   - In the Common category of the Insert panel, click the Images icon.
   - In the Common category of the Insert panel, click the Images button and select the Image icon. With the Image icon displayed in the Insert panel, you can drag the icon to the Document window (or to the Code view window if you are working in the code).
   - Select Insert > Image.
   - Drag an image from the Assets panel (Window > Assets) to the desired location in the Document window; then skip to step 3.
   - Drag an image from the Files panel to the desired location in the Document window; then skip to step 3.
   - Drag an image from the desktop to the desired location in the Document window; then skip to step 3.

2. In the dialog box that appears, do one of the following:
   - Select File System to choose an image file.
   - Select Data Source to choose a dynamic image source.
• Click the Sites And Servers button to choose an image file in a remote folder of one of your Dreamweaver sites.

3 Browse to select the image or content source you want to insert.

If you are working in an unsaved document, Dreamweaver generates a file:// reference to the image file. When you save the document anywhere in the site, Dreamweaver converts the reference to a document-relative path.

Note: When inserting images it’s also possible to use an absolute path to an image that resides on a remote server (i.e., an image that is not available on the local hard drive). If you experience performance problems while working, however, you might want to disable viewing the image in Design view by deselecting Commands > Display External Files.

4 Click OK. The Image Tag Accessibility Attributes dialog box appears if you have activated the dialog box in Preferences (Edit > Preferences).

5 Enter values in the Alternate Text and Long Description text boxes, and click OK.
• In the Alternate Text box, enter a name or brief description for the image. The screen reader reads the information you enter here. You should limit your entry to around 50 characters. For longer descriptions, consider providing a link, in the Long Description text box, to a file that gives more information about the image.
• In the Long Description box, enter the location of a file that displays when the user clicks the image or click the folder icon to browse to the file. This text box provides a link to a file that is related to, or gives more information about, the image.

Note: You can enter information in one or both text boxes depending on your needs. The screen reader reads the Alt attribute for the image.

Note: If you click Cancel, the image appears in the document, but Dreamweaver does not associate accessibility tags or attributes with it.

6 In the Property inspector (Window > Properties), set properties for the image.

More Help topics
“Make images dynamic” on page 558
“Image maps” on page 272
“Optimize the work space for accessible page design” on page 660
“Set page properties” on page 201

Inserting images tutorial

Set image properties
The Images Property inspector allows you to set properties for an image. If you do not see all of the image properties, click the expander arrow in the lower-right corner.

1 Select Window > Properties to view the Property inspector for a selected image.

2 In the text box below the thumbnail image, enter a name so you can refer to the image when using a Dreamweaver behavior (such as Swap Image) or when using a scripting language such as JavaScript or VBScript.
3 Set any of the image options.

**W and H** The width and height of the image, in pixels. Dreamweaver automatically updates these text boxes with the image’s original dimensions when you insert an image in a page.

If you set W and H values that do not correspond to the actual width and height of the image, the image may not display properly in a browser. (To restore the original values, click the W and H text box labels, or the Reset image size button that appears to the right of the W and H text boxes in entering a new value.)

*Note:* You can change these values to scale the display size of this image instance, but this does not reduce download time, because the browser downloads all image data before scaling the image. To reduce download time and to ensure that all instances of an image appear at the same size, use an image-editing application to scale images.

**Src** Specifies the source file for the image. Click the folder icon to browse to the source file, or type the path.

**Link** Specifies a hyperlink for the image. Drag the Point-To-File icon to a file in the Files panel, click the folder icon to browse to a document on your site, or manually type the URL.

**Align** Aligns an image and text on the same line.

**Alt** Specifies alternative text that appears in place of the image for text-only browsers or for browsers that have been set to download images manually. For visually impaired users who use speech synthesizers with text-only browsers, the text is spoken out loud. In some browsers, this text also appears when the pointer is over the image.

**Map Name and Hotspot tools** Allow you to label and create a client-side image map.

**V Space and H Space** Add space, in pixels, along the sides of the image. V Space adds space along the top and bottom of an image. H Space adds space along the left and right of an image.

**Target** Specifies the frame or window in which the linked page should load. (This option is not available when the image isn’t linked to another file.) The names of all the frames in the current frameset appear in the Target list. You can also choose from the following reserved target names:

- `_blank` loads the linked file into a new, unnamed browser window.
- `_parent` loads the linked file into the parent frameset or window of the frame that contains the link. If the frame containing the link is not nested, the linked file loads into the full browser window.
- `_self` loads the linked file into the same frame or window as the link. This target is the default, so you usually don’t need to specify it.
- `_top` loads the linked file into the full browser window, thereby removing all frames.

**Border** The width, in pixels, of the image’s border. The default is no border.

**Edit** Starts the image editor you specified in External Editors preferences and opens the selected image.

**Edit image settings** Opens the Image Preview dialog box and lets you optimize the image.

**Crop** Trims the size of an image, removing unwanted areas from the selected image.

**Resample** Resamples a resized image, improving its picture quality at its new size and shape.

**Brightness and Contrast** Adjusts the brightness and contrast settings of an image.

**Sharpen** Adjusts the sharpness of an image.

**Reset Size** Resets the W and H values to the original size of the image. This button appears to the right of the W and H text boxes when you adjust the values of the selected image.
Edit image accessibility attributes in code
If you inserted accessibility attributes for an image, you can edit those values in the HTML code.

1. In the Document window, select the image.
2. Do one of the following:
   • Edit the appropriate image attributes in Code view.
   • Right-click (Windows) or Control-click (Macintosh), and then select Edit Tag.
   • Edit the Alt value in the Property inspector.

Align an image
You can align an image to text, another image, a plug-in, or other elements in the same line. You can also set the horizontal alignment of an image.

1. Select the image in Design view.
2. Set the alignment attributes of the image in the Property inspector with the Align popup menu.

You can set the alignment in relation to other elements in the same paragraph or line.

Note: HTML does not provide a way to wrap text around the contours of an image, as you can with some word processing applications.

The alignment options are as follows:

Default  Specifies a baseline alignment. (The default may vary depending on the site visitor’s browser.)

Baseline and Bottom  Align the baseline of the text (or other element in the same paragraph) to the bottom of the selected object.

Top  Aligns the top of an image to the top of the tallest item (image or text) in the current line.

Middle  Aligns the middle of the image with the baseline of the current line.

Text Top  Aligns the top of the image with the top of the tallest character in the text line.

Absolute Middle  Aligns the middle of the image with the middle of the text in the current line.

Absolute Bottom  Aligns the bottom of the image with the bottom of the line of text (which includes descenders, as in the letter g).

Left  Places the selected image on the left margin, wrapping text around it to the right. If left-aligned text precedes the object on the line, it generally forces left-aligned objects to wrap to a new line.

Right  Places the image on the right margin, wrapping text around the object to the left. If right-aligned text precedes the object on the line, it generally forces right-aligned objects to wrap to a new line.

Visually resize an image
You can visually resize elements such as images, plug-ins, Shockwave or SWF files, applets, and ActiveX controls in Dreamweaver.
Visually resizing an image helps you see how the image affects the layout at different dimensions but it does not scale the image file to the proportions that you specify. If you visually resize an image in Dreamweaver without using an image-editing application (such as Adobe Fireworks) to scale the image file to the desired size, the user’s browser scales the image when the page is loaded. This might cause a delay in page download time and the improper display of the image in the user’s browser. To reduce download time and to ensure that all instances of an image appear at the same size, use an image-editing application to scale images.

When you resize an image in Dreamweaver, you can **resample** it to accommodate its new dimensions. Resampling adds or subtracts pixels from a resized JPEG and GIF image files to match the appearance of the original image as closely as possible. Resampling an image reduces its file size and improves download performance.

### More Help topics

“Edit images in Dreamweaver” on page 232

### Visually resize an element

1. Select the element (for example, an image or SWF file) in the Document window.

Resize handles appear at the bottom and right sides of the element and in the lower-right corner. If resize handles don’t appear, click somewhere other than the element you want to resize and then reselect it, or click the appropriate tag in the tag selector to select the element.

2. Resize the element by doing one of the following:
   - To adjust the width of the element, drag the selection handle on the right side.
   - To adjust the height of the element, drag the bottom selection handle.
   - To adjust the width and the height of the element at the same time, drag the corner selection handle.
   - To preserve the element’s proportions (its width-to-height ratio) as you adjust its dimensions, Shift-drag the corner selection handle.
   - To adjust the width and height of an element to a specific size (for example, 1 x 1 pixel), use the Property inspector to enter a numeric value. Elements can be visually resized to a minimum of 8 x 8 pixels.

3. To return a resized element to its original dimensions, in the Property inspector, delete the values in the W and H text boxes, or click the Reset Size button in the image Property inspector.

### Revert an image to its original size

❖ Click the Reset size button in the image Property inspector.

### Resample a resized image

1. Resize the image as described above.

2. Click the Resample button in the image Property inspector.

*Note:* You cannot resample image placeholders or elements other than bitmap images.

### Insert an image placeholder

An image placeholder is a graphic you use until final artwork is ready to be added to a web page. You can set the placeholder’s size and color, as well as provide it with a text label.

1. In the Document window, place the insertion point where you want to insert a placeholder graphic.

2. Select Insert > Image Objects > Image Placeholder.
3 For Name (Optional), enter text you want to appear as a label for the image placeholder. Leave the text box blank if you do not want a label to appear. The name must begin with a letter and can contain only letters and numbers; spaces and high ASCII characters are not allowed.

4 For Width and Height (Required), type a number to set the image size in pixels.

5 For Color (Optional), do one of the following to apply a color:
   • Use the color picker to select a color.
   • Enter the color's hexadecimal value (for example, #FF0000).
   • Enter a web-safe color name (for example, red).

6 For Alternate Text (Optional), enter text to describe the image for viewers using a text-only browser.

   Note: An image tag is automatically inserted into the HTML code containing an empty src attribute.

7 Click OK.

The placeholder's color, size attributes, and label appear as follows:

When viewed in a browser, the label and size text do not appear.

More Help topics
“Visually resize an image” on page 229
“Use Fireworks to modify Dreamweaver image placeholders” on page 349

Replace an image placeholder
An image placeholder does not display an image in a browser. Before you publish your site you should replace any image placeholders you’ve added with web-friendly image files, such as GIFs or JPEGs.

If you have Fireworks, you can create a new graphic from the Dreamweaver image placeholder. The new image is set to the same size as the placeholder image. You can edit the image, then replace it in Dreamweaver.

1 In the Document window, do one of the following:
   • Double-click the image placeholder.
   • Click the image placeholder to select it; then in the Property inspector (Window > Properties), click the folder icon next to the Src text box.

2 In the Image Source dialog box, navigate to the image you want to replace the image placeholder with and click OK.

More Help topics
“Use Fireworks to modify Dreamweaver image placeholders” on page 349

Set image placeholder properties
To set properties for an image placeholder, select the placeholder in the Document window; then select Window > Properties to display the Property inspector. To see all properties, click the expander arrow in the lower-right corner.
Use the Property inspector to set a name, width, height, image source, alternate text description, alignment and color for a placeholder image.

In the placeholder Property inspector, the gray text box and the Align text box are disabled. You can set these properties in the image Property inspector when you replace the placeholder with an image.

❖ Set any of the following options:

**W and H** Set the width and height of the image placeholder, in pixels.

**Src** Specifies the source file for the image. For a placeholder image, this text box is empty. Click the Browse button to select a replacement image for the placeholder graphic.

**Link** Specifies a hyperlink for the image placeholder. Drag the Point-to-File icon to a file in the Files panel, click the folder icon to browse to a document on your site, or manually type the URL.

**Alt** Specifies alternative text that appears in place of the image for text-only browsers or for browsers that have been set to download images manually. For visually impaired users who use speech synthesizers with text-only browsers, the text is spoken out loud. In some browsers, this text also appears when the pointer is over the image.

**Create** Starts Fireworks to create a replacement image. The Create button is disabled unless Fireworks is also installed on your computer.

**Reset Size** Resets the W and H values to the original size of the image.

**Color** Specifies a color for the image placeholder.

More Help topics

“Use Fireworks to modify Dreamweaver image placeholders” on page 349

Edit images in Dreamweaver

You can resample, crop, optimize, and sharpen images in Dreamweaver. You can also adjust their brightness and contrast.

**Image-editing features**

Dreamweaver provides basic image-editing features that let you modify images without having to use an external image-editing application such as Fireworks or Photoshop. The Dreamweaver image-editing tools are designed to let you easily work with content designers responsible for creating image files for use on your website.

**Note:** *You do not need to have Fireworks or other image-editing applications installed on your computer to use the Dreamweaver image-editing features.*

❖ Select Modify > Image. Set any of these Dreamweaver image-editing features:

**Resample** Adds or subtracts pixels from a resized JPEG and GIF image files to match the appearance of the original image as closely as possible. Resampling an image reduces its file size and improves download performance.

When you resize an image in Dreamweaver, you can resample it to accommodate its new dimensions. When a bitmap object is resampled, pixels are added to or removed from the image to make it larger or smaller. Resampling an image
to a higher resolution typically causes little loss of quality. Resampling to a lower resolution, however, always causes data loss and usually a drop in quality.

**Crop** Edit images by reducing the area of the image. Typically, you’ll want to crop an image to place more emphasis on the subject of the image, and remove unwanted aspects surrounding the center of interest in the image.

**Brightness and Contrast** Modifies the contrast or brightness of pixels in an image. This affects the highlights, shadows, and midtones of an image. You typically use Brightness/Contrast when correcting images that are too dark or too light.

**Sharpen** Adjusts the focus of an image by increasing the contrast of edges found within the image. When you scan an image, or take a digital photo, the default action of most image capturing software is to soften the edges of objects in the image. This prevents extremely fine details from becoming lost in the pixels from which digital images are composed. However, to bring out the details in digital image files, it is often necessary to sharpen the image, thereby increasing edge contrast, and making the image appear sharper.

*Note: Dreamweaver image-editing features apply only to JPEG, GIF, and PNG image file formats. Other bitmap image file formats cannot be edited using these image-editing features.*

**Crop an image**

Dreamweaver lets you crop (or trim) bitmap file images.

*Note: When you crop an image, the source image file is changed on disk. For this reason, you may want to keep a backup copy of the image file in the event you need to revert to the original image.*

1 Open the page containing the image you want to crop, select the image, and do either of the following:
   - Click the Crop Tool icon in the image Property inspector.
   - Select Modify > Image > Crop.

Crop handles appear around the selected image.

2 Adjust the crop handles until the bounding box surrounds the area of the image that you want to keep.

3 Double-click inside the bounding box or press Enter to crop the selection.

4 A dialog box informs you that the image file you are cropping will be changed on disk. Click OK. Every pixel in the selected bitmap outside the bounding box is removed, but other objects in the image remain.

5 Preview the image and ensure that it meets your expectations. If not, select Edit > Undo Crop to revert to the original image.

*Note: You can undo the effect of the Crop command (and revert to the original image file) up until the time that you quit Dreamweaver, or edit the file in an external image-editing application.*

**Optimize an image**

You can optimize images in your web pages from within Dreamweaver.

1 Open the page containing the image you want to optimize, select the image, and do either of the following:
   - Click the Edit image settings button in the image Property inspector.
   - Select Modify > Image > Optimize.

2 Make your edits in the Image Preview dialog box and click OK.
Sharpen an image
Sharpening increases the contrast of pixels around the edges of objects to increase the image’s definition or sharpness.

1. Open the page containing the image you want to sharpen, select the image, and do either of the following:
   • Click the Sharpen button in the image Property inspector.
   • Select Modify > Image > Sharpen.

2. You can specify the degree of sharpening Dreamweaver applies to the image by dragging the slider control, or entering a value between 0 and 10 in the text box. As you adjust the sharpness of the image using the Sharpness dialog box, you can preview the change to the image.

3. Click OK when you are satisfied with the image.

4. Save your changes by selecting File > Save, or revert to the original image by selecting Edit > Undo Sharpen.

   **Note:** You can only undo the effect of the Sharpen command (and revert to the original image file) prior to saving the page containing the image. After you save the page, the changes made to the image are permanently saved.

Adjust the brightness and contrast of an image
Brightness/Contrast modifies the contrast or brightness of pixels in an image. This affects the highlights, shadows, and midtones of an image. You typically use Brightness/Contrast when correcting images that are too dark or too light.

1. Open the page containing the image you want to adjust, select the image, and do either of the following:
   • Click the Brightness/Contrast button in the image Property inspector.
   • Select Modify > Image > Brightness/Contrast.

2. Drag the Brightness and Contrast sliders to adjust the settings. Values range from -100 to 100.

3. Click OK.

Create a rollover image
You can insert rollover images in your page. A rollover is an image that, when viewed in a browser, changes when the pointer moves across it.

You must have two images to create the rollover: a primary image (the image displayed when the page first loads) and a secondary image (the image that appears when the pointer moves over the primary image). Both images in a rollover should be the same size; if the images are not the same size, Dreamweaver resizes the second image to match the properties of the first image.

Rollover images are automatically set to respond to the onMouseOver event. You can set an image to respond to a different event (for example, a mouse click) or change a rollover image.

For a tutorial on creating rollovers, see [www.adobe.com/go/vid0159](http://www.adobe.com/go/vid0159).

1. In the Document window, place the insertion point where you want the rollover to appear.

2. Insert the rollover using one of these methods:
   • In the Common category of the Insert panel, click the Images button and select the Rollover Image icon. With the Rollover Image icon displayed in the Insert panel, you can drag the icon to the Document window.
   • Select Insert > Image Objects > Rollover Image.

3. Set the options and click OK.

   **Image Name**  The name of the rollover image.
**Original image**  The image you want to display when the page loads. Enter the path in the text box, or click Browse and select the image.

**Rollover Image**  The image you want to display when the pointer rolls over the original image. Enter the path or click Browse to select the image.

**Preload Rollover Image**  Preloads the images in the browser’s cache so no delay occurs when the user rolls the pointer over the image.

**Alternate Text**  (Optional) Text to describe the image for viewers using a text-only browser.

**When clicked, Go to URL**  The file that you want to open when a user clicks the rollover image. Enter the path or click Browse and select the file.

*Note:* If you don’t set a link for the image, Dreamweaver inserts a null link (#) in the HTML source code to which the rollover behavior is attached. If you remove the null link, the rollover image will no longer work.

1. Select File > Preview in Browser or press F12.
2. In the browser, move the pointer over the original image to see the rollover image.

*Note:* You cannot see the effect of a rollover image in Design view.

**More Help topics**
“Apply the Swap Image behavior” on page 344
Rollover tutorial

**Use an external image editor**

While in Dreamweaver, you can open a selected image in an external image editor; when you return to Dreamweaver after saving the edited image file, any changes you made to the image are visible in the Document window.

You can set up Fireworks as your primary external editor. You can also set which file types an editor opens; and you can select multiple image editors. For example, you can set preferences to start Fireworks when you want to edit a GIF, and to start a different image editor when you want to edit a JPG or JPEG.

**More Help topics**
“Working with Photoshop and Dreamweaver” on page 353
“Working with Fireworks and Dreamweaver” on page 348
“Start an external editor for media files” on page 248

**Start the external image editor**

- Do one of the following:
  - Double-click the image you want to edit.
  - Right-click (Windows) or Control-click (Macintosh) the image you want to edit, then select Edit With > Browse and select an editor.
  - Select the image you want to edit, and click Edit in the Property inspector.
  - Double-click the image file in the Files panel to start the primary image editor. If you haven’t specified an image editor, Dreamweaver starts the default editor for the file type.
Using Dreamweaver

Adding content to pages

Note: When you open an image from the Files panel, the Fireworks integration features are not in effect; Fireworks does not open the original PNG file. To use the Fireworks integration features, open images from within the Document window.

If you don’t see an updated image after returning to the Dreamweaver window, select the image and then click the Refresh button in the Property inspector.

Set an external image editor for an existing file type

You can select an image editor for opening and editing graphic files.

1. Open the File Types/Editors Preferences dialog box by doing one of the following:
   - Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh), and select File Types/Editors in the Category list on the left.
   - Select Edit > Edit with External Editor and select File Types/Editors.
2. In the Extensions list, select the file extension you want to set an external editor for.
3. Click the Add (+) button above the Editors list.
4. In the Select External Editor dialog box, browse to the application you want to start as an editor for this file type.
5. In the Preferences dialog box, click Make Primary if you want this editor to be the primary editor for this file type.
6. If you want to set up an additional editor for this file type, repeat steps 3 and 4.

Dreamweaver automatically uses the primary editor when you edit this image type. You can select the other listed editors from the context menu for the image in the Document window.

Add a new file type to the Extensions list

1. Open the File Types/Editors Preferences dialog box by doing one of the following:
   - Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh), and select File Types/Editors in the Category list on the left.
   - Select Edit > Edit with External Editor and select File Types/Editors.
2. In the File Types/Editors Preferences dialog box, click the Add (+) button above the Extensions list.
   A text box appears in the Extensions list.
3. Type the file extension of the file type you want to start an editor for.
4. To select an external editor for the file type, click the Add (+) button above the Editors list.
5. In the dialog box that appears, select the application you want to use to edit this image type.
6. Click Make Primary if you want this editor to be the primary editor for the image type.

Change an existing editor preference

1. Open the File Types/Editors Preferences dialog box by doing one of the following:
   - Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh), and select File Types/Editors in the Category list on the left.
   - Select Edit > Edit with External Editor and select File Types/Editors.
2. In the File Types/Editors preferences dialog box, in the Extensions list select the file type you are changing to view the existing editor(s).
3 In the Editors list, select the editor you want to want to affect, then do one of the following:
   • Click the Add (+) or Delete (−) buttons above the Editors list to add or remove an editor.
   • Click the Make Primary button, to change which editor starts by default for editing.

### Applying behaviors to images

You can apply any available behavior to an image or image hotspot. When you apply a behavior to a hotspot, Dreamweaver inserts the HTML source code into the area tag. Three behaviors apply specifically to images: Preload Images, Swap Image, and Swap Image Restore.

**Preload Images** Loads images that do not appear on the page right away (such as those that will be swapped in with behaviors, AP elements, or JavaScript) into the browser cache. This prevents delays caused by downloading when it is time for the images to appear.

**Swap Image** Swaps one image for another by changing the SRC attribute of the img tag. Use this action to create button rollovers and other image effects (including swapping more than one image at a time).

**Swap Image Restore** Restores the last set of swapped images to their previous source files. This action is automatically added whenever you attach the Swap Image action to an object by default; you should never need to select it manually.

You can also use behaviors to create more sophisticated navigation systems, such as jump menus.

**More Help topics**

“Insert a jump menu” on page 270

“Apply the Swap Image behavior” on page 344

“Apply the Preload Images behavior” on page 341

### Adding video

**Embed videos in web pages (HTML5)**

HTML5 supports video and audio tags that allow users to play video and audio files in a browser, without an external plug-in or player. Dreamweaver supports code hints for adding video and audio tags.

Live View renders the video, providing a preview of the video that you are embedding in the web page.

**Note:** Although you can embed any video in your web page, Live View does not always render all videos. The audio and video tags are supported in Dreamweaver using the Apple QuickTime plug-in. In Windows, if the Apple QuickTime plug-in is not installed, then the web page does not render the media content.

### Inserting FLV files

**Insert FLV files**

You can easily add FLV video to your web pages without using the Flash authoring tool. You must have an encoded FLV file before you begin.
Dreamweaver inserts a SWF component that displays the FLV file; when viewed in a browser, this component displays the selected FLV file, as well as a set of playback controls.

Dreamweaver gives you the following options for delivering FLV video to your site visitors:

**Progressive Download Video**  Downloads the FLV file to the site visitor’s hard disk and then plays it. Unlike traditional “download and play” methods of video delivery, however, progressive download allows the video file to start playing before the download is complete.

**Streaming Video**  Streams the video content and plays it on a web page after a short buffer period that ensures smooth playback. To enable streaming video on your web pages, you must have access to Adobe® Flash® Media Server.

You must have an encoded FLV file before you can use it in Dreamweaver. You can insert video files created with two kinds of codecs (compression/decompression technologies): Sorenson Squeeze and On2.

As with regular SWF files, when you insert an FLV file, Dreamweaver inserts code that detects whether the user has the correct version of Flash Player to view the video. If the user does not have the correct version, the page displays alternative content that prompts the user to download the latest version of Flash Player.

**Note:** To view FLV files, users must have Flash Player 8 or later installed on their computers. If a user does not have the required version of Flash Player installed, but does have Flash Player 6.0 r65 or later installed, the browser displays a Flash Player express installer instead of the alternative content. If the user declines the express install, the page then displays the alternative content.

For more information about working with video, visit the Video Technology Center at www.adobe.com/go/flv_devcenter.

**Insert an FLV file**

1. Select Insert > Media > FLV.
2. In the Insert FLV dialog box, select Progressive Download or Streaming Video from the Video Type pop-up menu.
3. Complete the rest of the dialog box options and click OK.

**Note:** Microsoft Internet Information Server (IIS) does not process nested object tags. For ASP pages, Dreamweaver uses nested object/embed code instead of nested object code when inserting SWF or FLV files.
Set options for progressive download video
The Insert FLV dialog box lets you set options for progressive download delivery of an FLV file inserted in a web page.

1. Select Insert > Media > FLV (or click the FLV icon in the Media category of the Common insert bar).
2. In the Insert FLV dialog box, select Progressive Download Video from the Video Type menu.
3. Specify the following options:
   - **URL**: Specifies a relative or absolute path to the FLV file. To specify a relative path (for example, mypath/myvideo.flv), click the Browse button, navigate to the FLV file, and select it. To specify an absolute path, type the URL (for example, http://www.example.com/myvideo.flv) of the FLV file.
   - **Skin**: Specifies the appearance of the video component. A preview of the selected skin appears beneath the Skin pop-up menu.
   - **Width**: Specifies the width of the FLV file, in pixels. To have Dreamweaver determine the exact width of the FLV file, click the Detect Size button. If Dreamweaver cannot determine the width, you must type a width value.
   - **Height**: Specifies the height of the FLV file, in pixels. To have Dreamweaver determine the exact height of the FLV file, click the Detect Size button. If Dreamweaver cannot determine the height, you must type a height value.
   
   **Note**: Total Width Skin is the width and height of the FLV file plus the width and height of the selected skin.
   - **Constrain**: Maintains the same aspect ratio between the width and height of the video component. This option is selected by default.
   - **Auto Play**: Specifies whether to play the video when the web page is opened.
   - **Auto Rewind**: Specifies whether the playback control returns to starting position after the video finishes playing.
4. Click OK to close the dialog box and add the FLV file to your web page.

The Insert FLV command generates a video player SWF file and a skin SWF file that are used to display your video content on a web page. (To see the new files, you may need to click the Refresh button in the Files panel.) These files are stored in the same directory as the HTML file to which you’re adding video content. When you upload the HTML page containing the FLV file, Dreamweaver uploads these files as dependent files (as long as you click Yes in the Put Dependent Files dialog box).

Set options for streaming video
The Insert FLV dialog box lets you set options for streaming video download of an FLV file inserted in a web page.

1. Select Insert > Media > FLV (or click the FLV icon in the Media category of the Common insert bar).
2. Select Streaming Video from the Video Type pop-up menu.
   - **Server URI**: Specifies the server name, application name, and instance name in the form rtmp://www.example.com/app_name/instance_name.
   - **Stream Name**: Specifies the name of the FLV file that you want to play (for example, myvideo.flv). The .flv extension is optional.
   - **Skin**: Specifies the appearance of the video component. A preview of the selected skin appears beneath the Skin pop-up menu.
   - **Width**: Specifies the width of the FLV file, in pixels. To have Dreamweaver determine the exact width of the FLV file, click the Detect Size button. If Dreamweaver cannot determine the width, you must type a width value.
   - **Height**: Specifies the height of the FLV file, in pixels. To have Dreamweaver determine the exact height of the FLV file, click the Detect Size button. If Dreamweaver cannot determine the height, you must type a height value.
   
   **Note**: Total Width Skin is the width and height of the FLV file plus the width and height of the selected skin.
Constrain  Maintains the same aspect ratio between the width and height of the video component. This option is selected by default.

Live Video Feed  Specifies whether the video content is live. If Live Video Feed is selected, Flash Player plays a live video feed streamed from Flash® Media Server. The name of the live video feed is the name specified in the Stream Name text box.

Note: When you select Live Video Feed, only the volume control appears on the component’s skin, because you cannot manipulate live video. Additionally, the Auto Play and Auto Rewind options have no effect.

Auto Play  Specifies whether to play the video when the web page is opened.

Auto Rewind  Specifies whether the playback control returns to starting position after the video finishes playing.

Buffer Time  Specifies the time, in seconds, required for buffering before the video starts playing. The default buffer time is set to 0 so that the video starts playing instantly after the Play button is clicked. (If Auto Play is selected, the video starts playing as soon as a connection is made with the server.) You might want to set a buffer time if you are delivering video that has a higher bit rate than the site visitor’s connection speed, or when Internet traffic might cause bandwidth or connectivity problems. For example, if you want to send 15 seconds of video to the web page before the web page starts to play the video, set the buffer time to 15.

3  Click OK to close the dialog box and add the FLV file to your web page.

The Insert FLV command generates a video player SWF file and a skin SWF file that are used to display your video on a web page. The command also generates a main.asc file that you must upload to your Flash Media Server. (To see the new files, you may need to click the Refresh button in the Files panel.) These files are stored in the same directory as the HTML file to which you’re adding video content. When you upload the HTML page containing the FLV file, don’t forget to upload the SWF files to your web server, and the main.asc file to your Flash Media Server.

Note: If you already have a main.asc file on your server, check with your server administrator before uploading the main.asc file generated by the Insert FLV command.

You can easily upload all of the required media files by selecting the video component placeholder in the Dreamweaver Document window, and clicking the Upload Media button in the Property inspector (Window > Properties). To see a list of required files, click Show required files.

Note: The Upload Media button does not upload the HTML file that contains the video content.

Edit Flash Player download information

When you insert an FLV file in a page, Dreamweaver inserts code that detects whether the user has the correct version of Flash Player. If not, the page displays default alternative content that prompts the user to download the latest version. You can change this alternative content at any time.

This procedure also applies to SWF files.

Note: If a user does not have the required version but does have Flash Player 6.0 r65 or later, the browser displays a Flash Player express installer. If the user declines the express install, the page then displays the alternative content.

1  In the Design view of the Document window, select the SWF file or FLV file.

2  Click the eye icon in the tab of the SWF file or FLV file.

You can also press Control + ] to switch to alternative content view. To return to SWF/FLV view, press Control + [ until all of the alternative content is selected. Then press Control + [ again.

3  Edit the content just as you would edit any other content in Dreamweaver.

Note: You cannot add SWF files or FLV files as alternative content.

4  Click the eye icon again to return to the SWF or FLV file view.
Troubleshoot FLV files
This section details some of the most common causes of problems with FLV files.

Viewing problems caused by absence of related files
The code generated by Dreamweaver CS4 and later relies on four dependent files, different from the FLV file itself:

- swfobject_modified.js
- expressInstall.swf
- FLVPlayer_Progressive.swf
- The skin file (for example Clear_Skin_1.swf)

Note that there are two more dependent files for Dreamweaver CS4 and later, compared to Dreamweaver CS3.

The first two of these files (swfobject_modified.js and expressInstall.swf) are installed in a folder called Scripts, which Dreamweaver creates in the root of your site if it doesn’t already exist.

The second two files (FLVPlayer_Progressive.swf and the skin file) are installed in the same folder as the page in which the FLV is embedded. The skin file contains the controls for the FLV, and its name depends on the skin chosen in the options described in Dreamweaver Help. For example, if you choose Clear Skin, the file is named Clear_Skin_1.swf.

All four dependent files MUST be uploaded to your remote server for the FLV to display correctly.

Forgetting to upload these files is the most common cause of FLV files failing to run correctly in a web page. If one of the files is missing, you might see a "white box" on the page.

To ensure that you've uploaded all of the dependent files, use the Dreamweaver Files panel to upload the page in which the FLV appears. When you upload the page, Dreamweaver asks you if you want to upload dependent files (unless you’ve turned off this option). Click yes to upload dependent files.

Viewing problems when previewing pages locally
Because of security updates in Dreamweaver CS4, you cannot use the Preview in Browser command to test a page with an embedded FLV unless you define a local testing server in your Dreamweaver site definition and use the testing server to preview the page.

Normally, you require a testing server only if you are developing pages with ASP, ColdFusion, or PHP (see “Set up your computer for application development” on page 511). If you are building websites that use only HTML, and haven’t defined a testing server, pressing F12 (Windows) Opt+F12 (Macintosh) produces a jumble of skin controls onscreen. The workaround is either to define the testing server and use the testing server to preview your page, or upload your files to a remote server and view them there.

Note: It’s possible that security settings may also be responsible for an inability to preview local FLV content, but Adobe has not been able to confirm this. You can try changing your security settings to see if it helps. For more information on changing your security settings, see Tech Note 117502.

Other possible causes for problems with FLV files
- If you are having trouble previewing locally, make sure the Preview using temporary file option is deselected under Edit > Preferences > Preview in Browser
- Make sure you have the latest FlashPlayer plug-in
- Be wary of moving files and folders around outside of Dreamweaver. When you move files and folders outside of Dreamweaver, Dreamweaver cannot guarantee the correct paths to FLV-related files.
- You can temporarily replace the FLV file that’s giving you trouble with a known working FLV file. If the replacement FLV file works, then the problem is with the original FLV file, and not with your browser or computer.
Edit or delete an FLV component
Change the settings for the video on your web page, by selecting the video component placeholder in the Dreamweaver Document window and using the Property inspector. Another way is to delete the video component and reinsert it by selecting Insert > Media > FLV.

Edit the FLV component
1. Select the video component placeholder in the Dreamweaver Document window by clicking the FLV icon at the center of the placeholder.
2. Open the Property inspector (Window > Properties) and make your changes.

Note: You cannot change video types (from progressive download to streaming, for example) by using the Property inspector. To change the video type, delete the FLV component, and reinsert it by selecting Insert > Media > FLV.

Delete the FLV component
❖ Select the FLV component placeholder in the Dreamweaver Document window and press Delete.

Remove FLV detection code
For Dreamweaver CS4 and later, Dreamweaver inserts Flash Player detection code directly in the object tag that contains the FLV file. For Dreamweaver CS3 and earlier, however, the detection code resides outside the FLV file’s object tag. For this reason, if you want to delete FLV files from pages created with Dreamweaver CS3 and earlier, you must remove the FLV files and use the Remove FLV detection command to remove the detection code.
❖ Select Commands > Remove Flash Video Detection.

Inserting SWF files

About FLA, SWF, and FLV file types
Before you use Dreamweaver to insert content created with Adobe Flash, you should be familiar with the following different file types:

FLA file (.fla) The source file for any project and created in the Flash authoring tool. This type of file can only be opened in Flash (not in Dreamweaver or in browsers). You can open the FLA file in Flash, then publish it as a SWF or SWT file to use in browsers.

SWF file (.swf) A compiled version of the FLA (.fla) file, optimized for viewing on the web. This file can be played back in browsers and previewed in Dreamweaver, but cannot be edited in Flash.

FLV file (.flv) A video file that contains encoded audio and video data for delivery through Flash® Player. For example, if you had a QuickTime or Windows Media video file, you would use an encoder (such as Flash® Video Encoder, or Sorenson Squeeze) to convert the video file to an FLV file. For more information, visit the Video Technology Center at www.adobe.com/go/flv_devcenter.

More Help topics
“Working with Flash and Dreamweaver” on page 362
“Inserting FLV files” on page 237
Insert and preview SWF files

Use Dreamweaver to add SWF files to your pages, and then preview them in a document or a browser. You can also set properties for SWF files in the Property inspector.

For a tutorial on adding SWF files to web pages, see www.adobe.com/go/vid0150.

More Help topics
“Working with Flash and Dreamweaver” on page 362
“Edit a SWF file from Dreamweaver in Flash” on page 362
SWF files and DHTML layers
“Insert Shockwave movies” on page 250
“Inserting FLV files” on page 237
Working with Flash tutorial

Insert a SWF file
1  In the Design view of the Document window, place the insertion point where you want to insert the content, then do one of the following:
   •  In the Common category of the Insert panel, select Media and click the SWF icon.
   •  Select Insert > Media > SWF.
2  In the dialog box that appears, select a SWF file (.swf).
   A SWF file placeholder appears in the Document window.

The placeholder has a tabbed blue outline. The tab indicates the type of asset (SWF file) and the ID of the SWF file. The tab also displays an eye icon. It acts as toggle between the SWF file and the download information users see when they don’t have the correct version of Flash Player.

3  Save the file.

Dreamweaver informs you that two dependent files, expressInstall.swf and swfobject_modified.js, are being saved to a Scripts folder in your site. Don’t forget to upload these files when you upload the SWF file to your web server. Browsers can’t display the SWF file properly unless you have also uploaded these dependent files.

Note: Microsoft Internet Information Server (IIS) does not process nested object tags. For ASP pages, Dreamweaver uses nested object/embed code instead of nested object code when inserting SWF or FLV files.

Edit Flash Player download information

When you insert a SWF file in a page, Dreamweaver inserts code that detects whether the user has the correct version of Flash Player. If not, the page displays default alternative content that prompts the user to download the latest version. You can change this alternative content at any time.
This procedure also applies to FLV files.

**Note:** If a user does not have the required version but does have Flash Player 6.0 r65 or later, the browser displays a Flash Player express installer. If the user declines the express install, the page then displays the alternative content.

1. In the Design view of the Document window, select the SWF file or FLV file.
2. Click the eye icon in the tab of the SWF file or FLV file.
   
   You can also press Control + ] to switch to alternative content view. To return to SWF/FLV view, press Control + [ until all of the alternative content is selected. Then press Control + ] again.
3. Edit the content just as you would edit any other content in Dreamweaver.
   
   **Note:** You cannot add SWF files or FLV files as alternative content.
4. Click the eye icon again to return to the SWF (or FLV) file view.

**Preview SWF files in the Document window**

1. In the Document window, click the SWF file placeholder to select the content.
2. In the Property inspector (Window > Properties), click the Play button. Click Stop to end the preview. You can also preview the SWF file in a browser by pressing F12.
   
   To preview all SWF files in a page, press Control+Alt+Shift+P (Windows) or Command+Option+Shift+P (Macintosh). All SWF files are set to Play.

**Set SWF file properties**

You can set properties for SWF files using the Property inspector. The properties are also applicable to Shockwave movies.

- Select a SWF file or a Shockwave movie and set the options in the Property inspector (Window > Properties). To see all properties, click the expander arrow in the lower-right corner of the Property inspector.

  **ID** Specifies a unique ID for the SWF file. Enter an ID in the unlabeled text box on the far left side of the Property inspector. As of Dreamweaver CS4, a unique ID is required.

  **W and H** Specify the width and height of the movie, in pixels.

  **File** Specifies the path to the SWF file or Shockwave file. Click the folder icon to browse to a file, or type a path.

  **Src** Specifies the path to the source document (the FLA file), when Dreamweaver and Flash are both installed on your computer. To edit a SWF file, update the movie’s source document.

  **Bg** Specifies a background color for the movie area. This color also appears while the movie is not playing (while loading and after playing).

  **Edit** Starts Flash to update a FLA file (a file created in the Flash authoring tool). This option is disabled if you do not have Flash installed on your computer.

  **Class** Lets you apply a CSS class to the movie.

  **Loop** Makes the movie play continuously. When Loop is not selected, the movie plays once and stops.

  **Autoplay** Automatically plays the movie when the page loads.

  **V Space and H Space** Specifies the number of pixels of white space above, below, and on both sides of the movie.

  **Quality** Controls anti-aliasing during playback of the movie. High settings improve the appearance of movies. However, at high settings movies require a faster processor to render correctly on the screen. Low favors speed over
appearance, whereas High favors appearance over speed. Auto Low favors speed at first but improves appearance when possible. Auto High favors both qualities equally at first but later sacrifices appearance for speed if necessary.

**Scale**  Determines how the movie fits into the dimensions set in the width and height text boxes. The Default setting displays the entire movie.

**Align**  Determines how the movie is aligned on the page.

**Wmode**  Sets the Wmode parameter for the SWF file to avoid conflicts with DHTML elements, such as Spry widgets. The default value is Opaque, which allows DHTML elements to appear on top of SWF files in a browser. If the SWF file includes transparencies and you want DHTML elements to appear behind them, select the Transparent option. Select the Window option to remove the Wmode parameter from the code and allow the SWF file to appear on top of other DHTML elements.

**Play**  Plays the movie in the Document window.

**Parameters**  Opens a dialog box for entering additional parameters to pass to the movie. The movie must be designed to receive these additional parameters.

**Insert FlashPaper documents**

The Insert FlashPaper feature has been deprecated as of Dreamweaver CS5.

**Adding web widgets**

A web widget is a web page component comprised of HTML, CSS, and JavaScript. Examples of web widgets include accordions, tabbed panels, and calendars.

You can make your own personal selection of web widgets available in Dreamweaver by using the Adobe Widget Browser—an AIR application that lets you browse, configure, and preview widgets using a visual interface.

1. Select Insert > Widget.
2. In the Widget dialog box, select a widget and preset (if applicable) and click OK.

You can also add a web widget to a Dreamweaver page (CS5.5 and later) by doing the following:

1. In the Widget Browser, navigate to My Widgets.
2. Select the widget you want to add.
3. Click and hold the Drag and Drop in Dreamweaver icon at the upper left corner of the Live View tab. Drag the widget to Dreamweaver into Design view (Windows) or Design or Code view (Macintosh OS).

You cannot drag and drop the widget into Live view, but you can use Live view to test the widget once you’ve dropped it into the page.

**More Help topics**

Adobe Widget Browser Help

“Working with Spry widgets (general instructions)” on page 407
Adding Sound

Audio file formats

You can add sound to a web page. There are several different types of sound files and formats, including .wav, .midi, and .mp3. Some factors to consider before deciding on a format and method for adding sound are its purpose, your audience, file size, sound quality, and differences in browsers.

Note: Sound files are handled very differently and inconsistently by different browsers. You may want to add a sound file to a SWF file and then embed the SWF file to improve consistency.

The following list describes the more common audio file formats along with some of the advantages and disadvantages of each for web design.

.midi or .mid (Musical Instrument Digital Interface)  This format is for instrumental music. MIDI files are supported by many browsers and don’t require a plug-in. Although their sound quality is very good, it can vary depending on a visitor’s sound card. A small MIDI file can provide a long sound clip. MIDI files cannot be recorded and must be synthesized on a computer with special hardware and software.

.wav (Waveform Extension)  These files have good sound quality, are supported by many browsers, and don’t require a plug-in. You can record your own WAV files from a CD, tape, microphone, and so on. However, the large file size severely limits the length of sound clips that you can use on your web pages.

.aif (Audio Interchange File Format, or AIFF)  The AIFF format, like WAV format, has good sound quality, can be played by most browsers, and doesn’t require a plug-in; you can also record AIFF files from a CD, tape, microphone, and so on. However, the large file size severely limits the length of sound clips that you can use on your web pages.

.mp3 (Motion Picture Experts Group Audio, or MPEG-Audio Layer-3)  A compressed format that makes sound files substantially smaller. The sound quality is very good: if an mp3 file is recorded and compressed properly, its quality can rival that of a CD. mp3 technology lets you “stream” the file so that a visitor doesn’t have to wait for the entire file to download before hearing it. However, the file size is larger than a Real Audio file, so an entire song could still take quite a while to download over a typical dial-up (telephone line) modem connection. To play mp3 files, visitors must download and install the RealPlayer helper application or plug-in, such as QuickTime, Windows Media Player or RealPlayer.

.ra, .ram, .rpm, or Real Audio  This format has a high degree of compression, with smaller file sizes than mp3. Entire song files can be downloaded in a reasonable amount of time. Because the files can be “streamed” from a normal web server, visitors can begin listening to the sound before the file has completely downloaded. Visitors must download and install the RealPlayer helper application or plug-in to play these files.

.qt, .qtm, .mov or QuickTime  This format is both an audio and video format developed by Apple Computer. QuickTime is included with Apple Macintosh operating systems, and is used by most Macintosh applications that use audio, video, or animation. PCs can also play files in QuickTime format, but require a special QuickTime driver. QuickTime supports most encoding formats, including Cinepak, JPEG, and MPEG.

Note: In addition to the more common formats listed above, there are many different audio and video file formats available for use on the web. If you encounter a media file format that you are unfamiliar with, locate the creator of the format for information on how best to use and deploy it.

More Help topics

“Insert and edit media objects” on page 247
**Link to an audio file**

Linking to an audio file is a simple and effective way to add sound to a web page. This method of incorporating sound files lets visitors choose whether they want to listen to the file, and makes the file available to the widest audience.

1. Select the text or image you want to use as the link to the audio file.
2. In the Property inspector, click the folder icon next to the Link text box to browse for the audio file, or type the file’s path and name in the Link text box.

**Embed a sound file**

Embedding audio incorporates the sound directly into the page, but the sound only plays if visitors to your site have the appropriate plug-in for the chosen sound file. Embed files if you want to use the sound as background music, or if you want to control the volume, the way the player looks on the page, or the beginning and ending points of the sound file.

> When incorporating sound files in your web pages, carefully consider their appropriate use in your web site, and how visitors to your site use these media resources. Always provide a control to either enable or disable the playing of the sound, in the event that visitors don’t want to listen to the audio content.

1. In Design view, place the insertion point where you want to embed the file and do one of the following:
   - In the Common category of the Insert panel, click the Media button and select the Plugin icon  from the pop-up menu.
   - Select Insert > Media > Plugin.
2. Browse for the audio file and click OK.
3. Enter the width and height by entering the values in the appropriate text boxes in the Property inspector or by resizing the plug-in placeholder in the Document window.

These values determine the size at which the audio controls are displayed in the browser.

**Adding media objects**

**Insert and edit media objects**

In addition to SWF and FLV files, you can insert QuickTime or Shockwave movies, Java applets, ActiveX controls, or other audio or video objects in a Dreamweaver document. If you inserted accessibility attributes with a media object, you can set the accessibility attributes and edit those values in the HTML code.

1. Place the insertion point in the Document window where you want to insert the object.
2. Insert the object by doing one of the following:
   - In the Common category of the Insert panel, click the Media button and select the icon for the type of object you want to insert.
   - Select the appropriate object from the Insert > Media submenu.
   - If the object you want to insert is not a Shockwave, Applet, or ActiveX object, select Plugin from the Insert > Media submenu.

A dialog box appears letting you select a source file and specify certain parameters for the media object.
To prevent such dialog boxes from appearing, select Edit > Preferences > General (Windows) or Dreamweaver > Preferences > General (Macintosh) and deselect the Show Dialog When Inserting Objects option. To override whatever preference is set for showing dialog boxes, hold down the Control (Windows) or Option (Macintosh) key while inserting the object. (For example, to insert a placeholder for a Shockwave movie without specifying the file, hold down Control or Option, and either click the Shockwave button in Media pop-up menu of the Common Insert panel, or select Insert > Media > Shockwave.)

3 Complete the Select File dialog box, and click OK.

Note: The Accessibility Attributes dialog box appears if you have chosen to show attributes when inserting media in the Edit > Preferences dialog box.

4 Set the accessibility attributes.

Note: You can also edit media object attributes by selecting the object and editing the HTML code in Code view, or right-clicking (Windows) or Control-clicking (Macintosh), and selecting Edit Tag Code.

Title Enter a title for the media object.

Access Key Enter a keyboard equivalent (one letter) in the text box to select the form object in the browser. This lets a visitor to the site use the Control key (Windows) with the Access Key to access the object. For example, if you enter B as the Access Key, use Control+B to select the object in the browser.

Tab Index Enter a number for the tab order of the form object. Setting a tab order is useful when you have other links and form objects on the page and need the user to tab through them in a specific order. If you set tab order for one object, be sure to set the tab order for all of them.

5 Click OK to insert the media object.

Note: If you click Cancel, a media object placeholder appears in the document, but Dreamweaver does not associate accessibility tags or attributes with it.

To specify a source file, or to set dimensions and other parameters and attributes, use the Property inspector for each object. You can edit accessibility attributes for an object.

More Help topics
“Optimize the work space for accessible page design” on page 660

Start an external editor for media files

You can start an external editor from Dreamweaver to edit most media files. You can also specify the editor you want Dreamweaver to start to edit the file.

1 Make sure the media file type is associated to an editor on your system.

To find out what editor is associated with the file type, select Edit > Preferences in Dreamweaver and select File Types/Editors from the Category list. Click the file’s extension in the Extensions column to view the associated editor or editors in the Editors column. You can change the editor associated to a file type.

2 Double-click the media file in the Files panel to open it in the external editor.

The editor that starts when you double-click the file in the Files panel is called the primary editor. If you double-click an image file, for example, Dreamweaver opens the file in the primary external image editor such as Adobe Fireworks.
3. If you don’t want to use the primary external editor to edit the file, you can use another editor on your system to edit the file by doing one of the following:
   - In the Files panel, right-click (Windows) or Control-click (Macintosh) the filename and select Open With.
   - From the context menu.
   - In Design view, right-click (Windows) or Control-click (Macintosh) the media element within the current page, and select Edit With from the context menu.

Specify the editor to start from Dreamweaver

You can specify the editor you want Dreamweaver to use for editing a file type, and add or delete file types that Dreamweaver recognizes.

Explicitly specify which external editors should be started for a given file type

1. Select Edit > Preferences and select File Types/Editors from the Category list.
   Filename extensions, such as .gif, .wav, and .mpg, are listed on the left under Extensions. Associated editors for a selected extension are listed on the right under Editors.

2. Select the file type extension in the Extensions list and do one of the following:
   - To associate a new editor with the file type, click the Plus (+) button above the Editors list and complete the dialog box that appears.
     For example, select the application icon for Acrobat to associate it with the file type.
   - To make an editor the primary editor for a file type (that is, the editor that opens when you double-click the file type in the Files panel), select the editor in the Editors list and click Make Primary.
   - To dissociate an editor from a file type, select the editor in the Editors list and click the Minus (-) button above the Editors list.

Add a new file type and associated editor

1. Click the Plus (+) button above the Extensions list and enter a file type extension (including the period at the beginning of the extension) or several related extensions separated by spaces.
   For example, you might enter .xml .xsl if you wanted to associate them with an XML editor installed on your system.

2. Select an editor for the file type by clicking the Plus (+) button above the Editors list and completing the dialog box that appears.

Remove a file type

- Select the file type in the Extensions list and click the Minus (-) button above the Extensions list.

Note: You can't undo after removing a file type, so be sure that you want to remove it.

Use Design Notes with media objects

As with other objects in Dreamweaver, you can add Design Notes to a media object. Design Notes are notes associated with a particular file, that are stored in a separate file. You can use Design Notes to keep track of extra file information associated with your documents, such as image source filenames and comments on file status.

1. Right-click (Windows) or Control-click (Macintosh) the object in the Document window.
Note: You must define your site before adding Design Notes to any object.

2 Select Design Notes for Page from the context menu.
3 Enter the information you want in the Design Note.

You can also add a Design Note to a media object from the Files panel by selecting the file, revealing the context menu, and choosing Design Notes from the context menu.

More Help topics
“Enable and disable Design Notes for a site” on page 100
“Storing file information in Design Notes” on page 100

Insert Shockwave movies
You can use Dreamweaver to insert Shockwave movies into your documents. Adobe® Shockwave®, a standard for interactive multimedia on the web, is a compressed format that allows media files created in Adobe® Director® to be downloaded quickly and played by most popular browsers.

1 In the Document window, place the insertion point where you want to insert a Shockwave movie and do one of the following:
   • In the Common category of the Insert panel, click the Media button and select the Shockwave icon from the popup menu.
   • Select Insert > Media > Shockwave.
2 In the dialog box that appears, select a movie file.
3 In the Property inspector, enter the width and height of the movie in the W and H text boxes.

More Help topics
“Set SWF file properties” on page 244

Add video (non-FLV)
You can add video to your web page in different ways and using different formats. Video can be downloaded to the user or it can be streamed so that it plays while it is downloading.

1 Place the clip in your site folder.
These clips are often in the AVI or MPEG file format.
2 Link to the clip or embed it in your page.
To link to the clip, enter text for the link such as “Download Clip”, select the text, and click the folder icon in the Property inspector. Browse to the video file and select it.

Note: The user must download a helper application (a plug-in) to view common streaming formats like Real Media, QuickTime, and Windows Media.

Insert plug-in content
You can create content such as a QuickTime movie for a browser plug-in, and then use Dreamweaver to insert that content into an HTML document. Typical plug-ins include RealPlayer and QuickTime, while some content files include mp3s and QuickTime movies.
You can preview movies and animations that rely on browser plug-ins directly in the Design view of the Document window. You can play all plug-in elements at one time to see how the page will look to the user, or you can play each one individually to ensure that you have embedded the correct media element.

**Note:** You cannot preview movies or animations that rely on ActiveX controls.

After inserting content for a plug-in, use the Property inspector to set parameters for that content. To view the following properties in the Property inspector, select a plug-in object.

The Property inspector initially displays the most commonly used properties. Click the expander arrow in the lower-right corner to see all properties.

### Insert plug-in content and set its properties

1. In the Design view of the Document window, place the insertion point where you want to insert the content, then do one of the following:
   - In the Common category of the Insert panel, click the Media button and select the Plugin icon from the menu.
   - Select Insert > Media > Plugin.
2. In the dialog box that appears, select a content file for a plug-in and click OK.
3. Set the plug-in options in the Property inspector.

   - **Name** Specifies a name to identify the plug-in for scripting. Enter a name in the unlabeled text box on the far left side of the Property inspector.
   - **W and H** Specify, in pixels, the width and height allocated to the object on the page.
   - **Src** Specifies the source data file. Click the folder icon to browse to a file, or enter a filename.
   - **Plg Url** Specifies the URL of the pluginspace attribute. Enter the complete URL of the site where users can download the plug-in. If the user viewing your page does not have the plug-in, the browser tries to download it from this URL.
   - **Align** Determines how the object is aligned on the page.
   - **V Space and H Space** Specify the amount of white space in pixels above, below, and on both sides of the plug-in.
   - **Border** Specifies the width of the border around the plug-in.
   - **Parameters** Opens a dialog box for entering additional parameters to pass to the plug-in. Many plug-ins respond to special parameters.

You can also view the attributes assigned to the selected plug-in by clicking the Attribute button. You can edit, add, and delete attributes such as width and height in this dialog box.

### Play plug-in content in the Document window

1. Insert one or more media elements using one of the methods described in the previous section.
2. Do one of the following:
   - Select one of the media elements you have inserted, and select View > Plugins > Play or click the Play button in the Property inspector.
   - Select View > Plugins > Play All to play all of the media elements on the selected page that rely on plug-ins.

**Note:** Play All only applies to the current document; it does not apply to other documents in a frameset, for example.

### Stop playing plug-in content

- Select a media element and select View > Plugins > Stop, or click the Stop button in the Property inspector.
You can also select View > Plugins > Stop All to stop all plug-in content from playing.

Troubleshooting plug-ins
If you have followed the steps to play plug-in content in the Document window, but some of the plug-in content does not play, try the following:

- Make sure the associated plug-in is installed on your computer, and that the content is compatible with the version of the plug-in you have.
- Open the file Configuration/Plugins/UnsupportedPlugins.txt in a text editor and look to see if the problematic plug-in is listed. This file keeps track of plug-ins that cause problems in Dreamweaver and are therefore unsupported. (If you experience problems with a particular plug-in, consider adding it to this file.)
- Check that you have enough memory. Some plug-ins require an additional 2 to 5 MB of memory to run.

Insert an ActiveX control
You can insert an ActiveX control in your page. ActiveX controls (formerly known as OLE controls) are reusable components, somewhat like miniature applications, that can act like browser plug-ins. They run in Internet Explorer with Windows, but they don’t run on the Macintosh browsers. The ActiveX object in Dreamweaver lets you supply attributes and parameters for an ActiveX control in your visitor’s browser.

After inserting an ActiveX object, use the Property inspector to set attributes of the object tag and parameters for the ActiveX control. Click Parameters in the Property inspector to enter names and values for properties that don’t appear in the Property inspector. There is no widely accepted standard format for parameters for ActiveX controls; to find out which parameters to use, consult the documentation for the ActiveX control you’re using.

❖ In the Document window, place the insertion point where you want to insert the content and do one of the following:
  - In the Common category of the Insert panel, click the Media button and select the ActiveX icon 🎉.
  - In the Common category of the Insert panel, click the Media button and select the ActiveX icon. With the ActiveX icon displayed in the Insert panel, you can drag the icon to the Document window.
  - Select Insert > Media > ActiveX. An icon marks where the ActiveX control will appear on the page in Internet Explorer.

ActiveX properties
The Property inspector initially displays the most commonly used properties. Click the expander arrow in the lower-right corner to see all properties.

Name Specifies a name to identify the ActiveX object for scripting. Enter a name in the unlabeled text box on the far left side of the Property inspector.

W and H Specify the width and height of the object, in pixels.

Class ID Identifies the ActiveX control to the browser. Enter a value or select one from the pop-up menu. When the page is loaded, the browser uses the class ID to locate the ActiveX control required for the ActiveX object associated with the page. If the browser doesn’t locate the specified ActiveX control, it attempts to download it from the location specified in Base.

Embed Adds an embed tag within the object tag for the ActiveX control. If the ActiveX control has another plug-in equivalent, the embed tag activates the plug-in. Dreamweaver assigns the values you entered as ActiveX properties to their plug-in equivalents.
Align  Determines how the object is aligned on the page.

Parameters  Opens a dialog box for entering additional parameters to pass to the ActiveX object. Many ActiveX controls respond to special parameters.

Src  Defines the data file to be used for a plug-in if the Embed option is turned on. If you don’t enter a value, Dreamweaver attempts to determine the value from the ActiveX properties entered already.

V Space and H Space  Specify the amount of white space, in pixels, above, below, and on both sides of the object.

Base  Specifies the URL containing the ActiveX control. Internet Explorer downloads the ActiveX control from this location if it has not been installed in the visitor’s system. If you don’t specify a Base parameter and if your visitor doesn’t already have the relevant ActiveX control installed, the browser can’t display the ActiveX object.

Alt Img  Specifies an image to be displayed if the browser doesn’t support the object tag. This option is available only when the Embed option is deselected.

Data  Specifies a data file for the ActiveX control to load. Many ActiveX controls, such as Shockwave and RealPlayer, do not use this parameter.

Insert a Java applet
You can insert a Java applet into an HTML document using Dreamweaver. Java is a programming language that allows the development of lightweight applications (applets) that can be embedded in web pages.

After inserting a Java applet, use the Property inspector to set parameters. To view the following properties in the Property inspector, select a Java applet.

1 In the Document window, place the insertion point where you want to insert the applet, and then do one of the following:
   • In the Common category of the Insert panel, click the Media button and select the Applet icon.
   • Select Insert > Media > Applet.
2 Select a file containing a Java applet.

Java applet properties
The Property inspector initially displays the most commonly used properties. Click the expander arrow in the lower-right corner to see all properties.

Name  Specifies a name to identify the applet for scripting. Enter a name in the unlabeled text box on the far left side of the Property inspector.

W and H  Specify the width and height of the applet, in pixels.

Code  Specifies the file containing the applet’s Java code. Click the folder icon to browse to a file, or enter a filename.

Base  Identifies the folder containing the selected applet. When you select an applet, this text box is filled automatically.

Align  Determines how the object is aligned on the page.

Alt  Specifies alternative content (usually an image) to be displayed if the user’s browser doesn’t support Java applets or has Java disabled. If you enter text, Dreamweaver inserts the text as the value of the applet’s alt attribute. If you select an image, Dreamweaver inserts an img tag between the opening and closing applet tags.

V Space and H Space  Specify the amount of white space in pixels above, below, and on both sides of the applet.

Parameters  Opens a dialog box for entering additional parameters to pass to the applet. Many applets respond to special parameters.
Using behaviors to control media
You can add behaviors to your page to start and stop various media objects.

**Control Shockwave Or Flash**  Play, stop, rewind, or go to a frame in a Shockwave movie or SWF file.

**Play Sound**  Lets you play a sound; for example, you can play a sound effect whenever the user moves the mouse pointer over a link.

**Check Plugin**  Lets you check to see if visitors to your site have the required plug-in installed, then route them to different URLs, depending on whether they have the right plug-in. This only applies to plug-ins, as the Check Plugin behavior does not check for ActiveX controls.

More Help topics
“Apply the Control Shockwave or SWF behavior” on page 337
“Apply the Play Sound behavior” on page 341
“Apply the Check Plugin behavior” on page 337

Use parameters to control media objects
Define special parameters to control Shockwave and SWF files, ActiveX controls, plug-ins, and Java applets. Parameters are used with the `object`, `embed`, and `applet` tags. Parameters set attributes specific to different types of objects. For example, a SWF file can use a quality parameter `<param name="quality" value="best">` for the `object` tag. The Parameter dialog box is available from the Property inspector. See the documentation for the object you’re using for information on the parameters it requires.

**Note:** There is no widely accepted standard for identifying data files for ActiveX controls. Consult the documentation for the ActiveX control you’re using to find out which parameters to use.

Enter a name and value for a parameter
1. Select an object that can have parameters (such as a Shockwave movie, an ActiveX control, a plug-in, or a Java applet) in the Document window.
2. Open the dialog box using one of the following methods:
   • Right-click (Windows) or Control-click (Macintosh) the object, and select Parameters from the context menu.
   • Open the Property inspector if it isn’t already open, and click the Parameters button found in the lower half of the Property inspector. (Make sure the Property inspector is expanded.)
3. Click the Plus (+) button and enter the parameter name and value in the appropriate columns.

Remove a parameter
♭ Select a parameter and press the minus (–) button.

Reorder parameters
♭ Select a parameter, and use the up and down arrow buttons.
Automating tasks

Task automation
The History panel records the steps you take when you complete a task. Automate a frequently performed task by replaying those steps from the History panel or creating a new command that performs the steps automatically.

Certain mouse movements, such as selecting by clicking in the Document window, can’t be played back or saved. When you make such a movement, a black line appears in the History panel (the line does not become obvious until you perform another action). To avoid this, use the arrow keys instead of the mouse to move the insertion point within the Document window.

Some other steps also aren’t repeatable, such as dragging a page element to somewhere else on the page. When you perform such a step, an icon with a small red X appears in the History panel.

Saved commands are retained permanently (unless you delete them), while recorded commands are discarded when you exit from Adobe® Dreamweaver® CS5, and copied sequences of steps are discarded when you copy something else.

Use the History panel
The History panel (Window > History) shows a list of the steps you’ve performed in the active document since you created or opened that document (but not steps you’ve performed in other frames, in other Document windows, or in the Site panel). Use the History panel to undo multiple steps at once and to automate tasks.

The slider, or thumb, in the History panel initially points to the last step that you performed.

Note: You can’t rearrange the order of steps in the History panel. Don’t think of the History panel as an arbitrary collection of commands; think of it as a way to view the steps you’ve performed, in the order in which you performed them.

Undo the last step
❖ Do one of the following:
• Select Edit > Undo.
• Drag the History panel slider up one step in the list.

Note: To scroll automatically to a particular step, you must click to the left of the step; clicking the step itself selects the step. Selecting a step is different from going back to that step in your undo history.

Undo multiple steps at once
❖ Drag the slider to point to any step, or click to the left of a step along the path of the slider.
The slider scrolls automatically to that step, undoing steps as it scrolls.

*Note:* As with undoing a single step, if you undo a series of steps and then do something new in the document, you can no longer redo the undone steps; they disappear from the History panel.

**Set the number of steps that the History panel retains and shows**

The default number of steps is sufficient for most users' needs. The higher the number, the more memory the History panel requires, which can affect performance and slow your computer significantly.

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).
2. Select General from the Category list on the left.
3. Enter a number for Maximum Number Of History Steps.

When the History panel reaches this maximum number of steps, the earliest steps are discarded.

**Erase the history list for the current document:**

- In the History panel's context menu, select Clear History.

This command also clears all undo information for the current document; after choosing Clear History, you can't undo the steps that are cleared. Clear History does not undo steps; it merely removes the record of those steps from memory.

**Repeat steps**

Use the History panel to repeat the last step you performed, repeat a series of adjacent steps, or repeat a series of nonadjacent steps. Replay the steps directly from the History panel.

**Repeat one step**

- Do one of the following:
  - Select Edit > Redo.
  - In the History panel, select a step and click the Replay button. The step is replayed and a copy of it appears in the History panel.

**Repeat a series of steps**

1. Select steps in the History panel:
   - To select adjacent steps, drag from one step to another (don’t drag the slider; just drag from the text label of one step to the text label of another step), or select the first step, and then Shift-click the last step.
   - To select nonadjacent steps, select a step, and then Control-click (Windows) or Command-click (Macintosh) to select or deselect other steps.

The steps played are the selected (highlighted) steps, not necessarily the step the slider currently points to.

*Note:* Although you can select a series of steps that includes a black line indicating a step that can't be recorded, that step is skipped when you replay the steps.

2. Click Replay.

The steps are replayed in order, and a new step, Replay Steps, appears in the History panel.

**Make or extend a selection**

- Hold down the Shift key while pressing an arrow key.
If a black mouse-movement indicator line appears while you're performing a task you want to repeat later, you can undo back to before that step and try another approach, perhaps using the arrow keys.

Apply steps in the History panel to objects
You can apply a set of steps from the History panel to any object in the Document window.

If you select multiple objects and then apply steps to them from the History panel, the objects are treated as a single selection and Dreamweaver attempts to apply the steps to that combined selection; however, you can apply a set of steps only to a single object at a time.

To apply the steps to each object in a set of objects, you must make the last step in the series select the next object in the set. The second procedure demonstrates this principle in a specific scenario: setting the vertical and horizontal spacing of a series of images.

Apply steps to one other object
1. Select the object.
2. Select the relevant steps in the History panel, and click Replay.

Apply steps to multiple objects
1. Start with a document in which each line consists of a small image (such as a graphical bullet or an icon) followed by text.

The goal is to set the images off from the text and from the other images above and below them.

Locations
Special Offers
Customer Service

2. Open the Property inspector (Window > Properties), if it isn’t already open.
3. Select the first image.
4. In the Property inspector, enter numbers in the V Space and H Space boxes to set the image’s spacing.
5. Click the image again to make the Document window active without moving the insertion point.
6. Press the Left Arrow key to move the insertion point to the left of the image.
7. Press the Down Arrow key to move the insertion point down one line, leaving it just to the left of the second image in the series.
8. Press Shift+Right Arrow to select the second image.

---

Note: Do not select the image by clicking it, or you won’t be able to replay all the steps.

9. In the History panel, select the steps that correspond to changing the image’s spacing and selecting the next image. Click Replay to replay those steps.
The current image's spacing changes, and the next image is selected.

10 Continue to click Replay until all the images are spaced correctly.

**Copy and paste steps between documents**

Each open document has its own history of steps. You can copy steps from one document and paste them into another.

Closing a document clears its history. If you know you will want to use steps from a document later, copy or save the steps before you close the document.

1 In the document containing the steps you want to reuse, select the steps in the History panel.

2 Click Copy Steps in the History panel.

*Note: The Copy Steps button in the History panel is different from the Copy command in the Edit menu. You can't use Edit > Copy to copy steps, although you do use Edit > Paste to paste them.*

Be careful when you copy steps that include a Copy or a Paste command:

- Don't use Copy Steps if one of the steps is a Copy command; you may not be able to paste such steps the way you want.
- If your steps include a Paste command, you can't paste those steps, unless the steps also include a Copy command before the Paste command.

3 Open the other document.

4 Place the insertion point where you want it, or select an object to apply the steps to.

5 Select Edit > Paste.

The steps are played back as they’re pasted into the document’s History panel. The History panel shows them as only one step, called Paste Steps.

If you pasted steps into a text editor or into Code view or the Code inspector, they appear as JavaScript code. This can be useful for learning to write your own scripts.

**More Help topics**

“Writing and editing code” on page 292

**Create and use commands from history steps**

Save a set of history steps as a named command, which then becomes available in the Commands menu. Create and save a new command if you might use a set of steps again, especially the next time you start Dreamweaver.

**Create a command**

1 Select a step or set of steps in the History panel.

2 Click the
3 Save As
4 Command button, or select
5 Save As
6 Command from the History panel’s context menu.
7 Enter a name for the command and click OK.
The command appears in the Commands menu.

Note: The command is saved as a JavaScript file (or sometimes an HTML file) in your
Dreamweaver/Configuration/Commands folder. If you are using Dreamweaver on a multiuser operating system, the file
is saved in the specific user’s Commands folder.

Use a saved command
1 Select an object to apply the command to, or place the insertion point where you want to apply the command.
2 Select the command from the Commands menu.

Edit a command name
1 Select Commands > Edit Command List.
2 Select a command to rename, enter a new name for it, and then click Close.

Delete a name from the Commands menu
1 Select Commands > Edit Command List.
2 Select a command.
3 Click Delete, and then click Close.

Record and save commands
Record a temporary command for short-term use, or record and save a command to use later. Dreamweaver retains
only one recorded command at a time; as soon as you start recording a new command, the old command is lost, unless
you save it before recording the new command.

Temporarily record a series of steps
1 Select Commands > Start Recording, or press Control+Shift+X (Windows) or Command+Shift+X (Macintosh).
The pointer changes to indicate that you’re recording a command.
2 When you finish recording, select Commands > Stop Recording, or press Control+Shift+X (Windows) or
Command+Shift+X (Macintosh).

Play back a recorded command
❖ Select Commands > Play Recorded Command.

Save a recorded command
1 Select Commands > Play Recorded Command.
2 Select the Run Command step that appears in the History panel’s step list, and then click the
3 Save As
4 Command button.
5 Enter a name for the command, and click OK.
The command appears in the Commands menu.
Chapter 9: Linking and navigation

About linking and navigation

About links
After you’ve set up a Dreamweaver site to store your website documents and have created HTML pages, you’ll want to create connections from your documents to other documents.

Dreamweaver provides several ways to create links to documents, images, multimedia files, or downloadable software. You can establish links to any text or image anywhere within a document, including text or images in a heading, list, table, absolutely-positioned element (AP element), or frame.

There are several different ways of creating and managing links. Some web designers prefer to create links to nonexistent pages or files as they work, while others prefer to create all the files and pages first and then add the links. Another way to manage links is to create placeholder pages, in which you add and test links before completing all your site pages.

More Help topics
"Test links in Dreamweaver" on page 270

Absolute, document-relative, and site root-relative paths
Understanding the file path between the document you’re linking from and the document or asset you’re linking to is essential to creating links.

Each web page has a unique address, called a Uniform Resource Locator (URL). However, when you create a local link (a link from one document to another on the same site), you generally don’t specify the entire URL of the document you’re linking to; instead, you specify a relative path from the current document or from the site’s root folder.

There are three types of link paths:
• Absolute paths (such as http://www.adobe.com/support/dreamweaver/contents.html).
• Document-relative paths (such as dreamweaver/contents.html).
• Site root–relative paths (such as /support/dreamweaver/contents.html).

Using Dreamweaver, you can easily select the type of document path to create for your links.

Note: It is best to use the type of linking you prefer and are most comfortable with—either site root- or document-relative. Browsing to links, as opposed to typing in the paths, ensures that you always enter the right path.

More Help topics
“Set the relative path of new links” on page 266
“Working with Dreamweaver sites” on page 36
**Absolute paths**

Absolute paths provide the complete URL of the linked document, including the protocol to use (usually http:// for web pages), for example, http://www.adobe.com/support/dreamweaver/contents.html. For an image asset, the complete URL might be something like http://www.adobe.com/support/dreamweaver/images/image1.jpg.

You must use an absolute path to link to a document or asset on another server. You can also use absolute paths for local links (to documents in the same site), but that approach is discouraged—if you move the site to another domain, all of your local absolute-path links will break. Using relative paths for local links also provides greater flexibility if you need to move files within your site.

*Note:* When inserting images (not links), you can use an absolute path to an image on a remote server (that is, an image that is not available on the local hard drive).

**Document-relative paths**

Document-relative paths are usually best for local links in most websites. They’re particularly useful when the current document and the linked document or asset are in the same folder and are likely to remain together. You can also use a document-relative path to link to a document or asset in another folder by specifying the path through the folder hierarchy from the current document to the linked document.

The basic idea of document-relative paths is to omit the part of the absolute path that is the same for both the current document and the linked document or asset, providing only the portion of the path that differs.

For example, suppose you have a site with the following structure:

```
my_site (root folder)
  support
    contents.html
    hours.html
    resources
      tips.html
  products
    catalog.html
  index.html (home page)
```

- To link from contents.html to hours.html (both in the same folder), use the relative path hours.html.
- To link from contents.html to tips.html (in the resources subfolder), use the relative path resources/tips.html. At each slash (/), you move down one level in the folder hierarchy.
- To link from contents.html to index.html (in the parent folder, one level above contents.html), use the relative path ../index.html. Two dots and a slash (../) moves you up one level in the folder hierarchy.
- To link from contents.html to catalog.html (in a different subfolder of the parent folder), use the relative path ../products/catalog.html. Here, ../ moves you up to the parent folder, and products/ moves you down to the products subfolder.

When you move files as a group—for example, when you move an entire folder, so that all the files inside that folder retain the same relative paths to each other—you don’t need to update document-relative links between those files. However, when you move an individual file that contains document-relative links, or an individual file targeted by a document-relative link, you do need to update those links. (If you move or rename files using the Files panel, Dreamweaver updates all relevant links automatically.)
Site root–relative paths
Site root–relative paths describe the path from the site's root folder to a document. You may want to use these paths if you are working on a large website that uses several servers, or one server that hosts several sites. However, if you are not familiar with this type of path, you may want to stick to document-relative paths.

A site root–relative path begins with a leading forward slash, which stands for the root folder of the site. For example, /support/tips.html is a site root–relative path to a file (tips.html) in the support subfolder of the site's root folder.

A site root–relative path is often the best way to specify links if you frequently move HTML files from one folder to another in your website. When you move a document that contains site root–relative links, you don’t need to change the links since the links are relative to the site root, and not to the document itself; for example, if your HTML files use site root–relative links for dependent files (such as images), then if you move an HTML file, its dependent-file links are still valid.

However, when you move or rename the documents targeted by site root–relative links, you must update those links, even if the documents' paths relative to each other haven’t changed. For example, if you move a folder, you must update all site root–relative links to files in that folder. (If you move or rename files using the Files panel, Dreamweaver updates all relevant links automatically.)

Linking

Linking files and documents
Before creating a link, make sure you understand how absolute, document-relative, and site root–relative paths work. You can create several types of links in a document:

- A link to another document or to a file, such as a graphic, movie, PDF, or sound file.
- A named anchor link, which jumps to a specific location in a document.
- An e-mail link, which creates a new blank e-mail message with the recipient’s address already filled in.
- Null and script links, which you use to attach behaviors to an object or to create a link that executes JavaScript code.

You can use the Property inspector and the Point-To-File icon to create links from an image, an object, or text to another document or file.

Dreamweaver creates the links to other pages in your site using document-relative paths. You can also tell Dreamweaver to create new links using site root–relative paths.

Important: Always save a new file before creating a document-relative path; a document-relative path is not valid without a definite starting point. If you create a document-relative path before saving the file, Dreamweaver temporarily uses an absolute path beginning with file:// until the file is saved; when you save the file, Dreamweaver converts the file:// path to a relative path.

For a tutorial on creating links, see www.adobe.com/go/vid0149.

More Help topics
“Absolute, document-relative, and site root-relative paths” on page 261
Creating links tutorial
Attaching JavaScript behaviors to links

You can attach a behavior to any link in a document. Consider using the following behaviors when you insert linked elements into documents:

**Set Text Of Status Bar**  Determines the text of a message and displays it in the status bar at the lower left of the browser window. For example, you can use this behavior to describe the destination of a link in the status bar instead of showing the URL associated with it.

**Open Browser Window**  Opens a URL in a new window. You can specify the properties of the new window, including its name, size, and attributes (whether it is resizable, has a menu bar, and so on).

**Jump Menu**  Edits a jump menu. You can change the menu list, specify a different linked file, or change the browser location in which the linked document opens.

More Help topics
“Applying built-in JavaScript behaviors” on page 336

Link to documents using the Property inspector

You can use the Property inspector’s folder icon or Link box to create links from an image, an object, or text to another document or file.

1  Select text or an image in the Document window’s Design view.
2  Open the Property inspector (Window > Properties) and do one of the following:
   •  Click the folder icon to the right of the Link box to browse to and select a file. The path to the linked document appears in the URL box. Use the Relative To pop-up menu in the Select HTML File dialog box to make the path document-relative or root-relative, and then click Select. The type of path you select applies only to the current link. (You can change the default setting of the Relative To box for the site.)
   •  Type the path and filename of the document in the Link box. To link to a document in your site, enter a document-relative or site root–relative path. To link to a document outside your site, enter an absolute path including the protocol (such as http://). You can use this approach to enter a link for a file that hasn’t been created yet.
3  From the Target pop-up menu, select a location in which to open the document:
   •  _blank loads the linked document in a new, unnamed browser window.
   •  _parent loads the linked document in the parent frame or parent window of the frame that contains the link. If the frame containing the link is not nested, then the linked document loads in the full browser window.
   •  _self loads the linked document in the same frame or window as the link. This target is the default, so you usually don’t have to specify it.
   •  _top loads the linked document in the full browser window, thereby removing all frames.

*If all the links on your page will be set to the same target, you can specify this target once by selecting Insert > HTML > Head Tags > Base and selecting the target information. For information about targeting frames, see “Control frame content with links” on page 196.*

More Help topics
“Absolute, document-relative, and site root-relative paths” on page 261

Last updated 12/7/2011
Link to documents using the Point-To-File icon

1. Select text or an image in the Document window’s Design view.

2. Create a link in one of two ways:
   - Drag the Point-To-File icon (target icon) at the right of the Link box in the Property inspector and point to a visible anchor in the current document, a visible anchor in another open document, an element that has a unique ID assigned to it, or a document in the Files panel.
   - Shift-drag from the selection and point to a visible anchor in the current document, a visible anchor in another open document, an element that has a unique ID assigned to it, or a document in the Files panel.

   Note: You can link to another open document only if your documents are not maximized in the Document window. To tile documents, select Window > Cascade or Window > Tile. When you point to an open document, that document moves to the foreground of your screen while you are making your selection.

More Help topics
“Link to a specific place in a document” on page 266

Add a link using the Hyperlink command

The Hyperlink command lets you create a text link to an image, an object, or to another document or file.

1. Place the insertion point in the document where you want the link to appear.

2. Do one of the following to display the Insert Hyperlink dialog box:
   - Select Insert > Hyperlink.
   - In the Common category of the Insert panel, click the Hyperlink button.

3. Enter the text of the link and, after Link, the name of the file to link to (or click the folder icon to browse to the file).

4. In the Target pop-up menu, select the window in which the file should open or type its name.

   The names of all the frames you’ve named in the current document appear in the pop-up list. If you specify a frame that doesn’t exist, the linked page opens in a new window that has the name you specified. You can also select from the following reserved target names:
   - _blank loads the linked file into a new, unnamed browser window.
   - _parent loads the linked file into the parent frameset or window of the frame that contains the link. If the frame containing the link is not nested, the linked file loads into the full browser window.
   - _self loads the linked file into the same frame or window as the link. This target is the default, so you usually don’t need to specify it.
   - _top loads the linked file into the full browser window, thereby removing all frames.

5. In the Tab Index box, enter a number for the tab order.

6. In the Title box, enter a title for the link.

7. In the Access Key box, enter a keyboard equivalent (one letter) to select the link in the browser.

8. Click OK.
Set the relative path of new links
By default, Dreamweaver creates links to other pages in your site using document-relative paths. To use site root-relative path instead, you must first define a local folder in Dreamweaver by choosing a local root folder to serve as the equivalent of the document root on a server. Dreamweaver uses this folder to determine the site root-relative paths to files.

1. Select Site > Manage Sites.
2. In the Manage Sites dialog box, double-click your site in the list.
3. In the Site Setup dialog box, expand Advanced Settings and select the Local Info category.
4. Set the relative path of new links by selecting the Document or Site Root option.

Changing this setting will not convert the path of existing links after you click OK. The setting applies only to new links you create with Dreamweaver.

Note: Content linked with a site root-relative path does not appear when you preview documents in a local browser unless you specify a testing server, or select the Preview Using Temporary File option in Edit > Preferences > Preview In Browser. This is because browsers don’t recognize site roots—servers do. A quick way to preview content linked with site root-relative paths is to put the file on a remote server, then select File > Preview In Browser.

5. Click Save.

The new path setting applies only to the current site.

More Help topics
“Absolute, document-relative, and site root-relative paths” on page 261
“Working with Dreamweaver sites” on page 36

Link to a specific place in a document
You can use the Property inspector to link to a particular section of a document by first creating named anchors. Named anchors let you set markers in a document, which are often placed at a specific topic or at the top of a document. You can then create links to these named anchors, which quickly take your visitor to the specified position.

Creating a link to a named anchor is a two-step process. First, you create a named anchor; then you create a link to the named anchor.

Note: You can’t place a named anchor in an absolutely-positioned element (AP element).

Create a named anchor
1. In the Document window’s Design view, place the insertion point where you want the named anchor.
2. Do one of the following:
   • Select Insert > Named Anchor.
   • Press Control+Alt+A (Windows) or Command+Option+A (Macintosh).
   • In the Common category of the Insert panel, click the Named Anchor button.
3. In the Anchor Name box, type a name for the anchor, and click OK. (The anchor name can’t contain spaces). The anchor marker appears at the insertion point.

Note: If you do not see the anchor marker, select View > Visual Aids > Invisible Elements.
Link to a named anchor
1 In the Document window's Design view, select text or an image to create a link from.
2 In the Link box of the Property inspector, type a number sign (#) and the name of the anchor. For example, to link to an anchor named "top" in the current document, type #top. To link to an anchor named "top" in a different document in the same folder, type filename.html#top.

Note: Anchor names are case-sensitive.

Link to a named anchor using the Point-To-File method
1 Open the document containing the named anchor.

Note: If you don't see the anchor, select View > Visual Aids > Invisible Elements to make it visible.
2 In the Document window's Design view, select text or an image you want to link from. (If this is another open document, you must switch to it.)
3 Do one of the following:
   • Click the Point-To-File icon (target icon) to the right of the Link box in the Property inspector and drag it to the anchor you want to link to: either an anchor within the same document or an anchor in another open document.
   • Shift-drag in the Document window from the selected text or image to the anchor you want to link to: either an anchor within the same document or an anchor in another open document.

Create an e-mail link
An e-mail link opens a new blank message window (using the mail program associated with the user's browser) when clicked. In the e-mail message window, the To box is automatically updated with the address specified in the e-mail link.

Create an e-mail link using the Insert Email Link command
1 In the Document window's Design view, position the insertion point where you want the e-mail link to appear, or select the text or image you want to appear as the e-mail link.
2 Do one of the following to insert the link:
   • Select Insert > Email Link.
   • In the Common category of the Insert panel, click the Email Link button.
3 In the Text box, type or edit the body of the e-mail.
4 In the Email box, type the e-mail address, then click OK.

Create an e-mail link using the Property inspector
1 Select text or an image in the Document window's Design view.
2 In the Link box of the Property inspector, type mailto: followed by an e-mail address.

Do not type any spaces between the colon and the e-mail address.

Auto-populate the subject line of an e-mail
1 Create an e-mail link using the Property inspector as outlined above.
2 In the Link box of the Property inspector, add ?subject= after the email, and type a subject after the equals sign.

Do not type any spaces between the question mark and the end of the e-mail address.
Create null and script links

A null link is an undesignated link. Use null links to attach behaviors to objects or text on a page. For instance, you can attach a behavior to a null link so that it swaps an image or displays an absolutely-positioned element (AP element) when the pointer moves over the link.

Script links execute JavaScript code or call a JavaScript function and are useful for giving visitors additional information about an item without leaving the current web page. Script links can also be used to perform calculations, validate forms, or do other processing tasks when a visitor clicks a specific item.

More Help topics

“Apply a behavior” on page 334

Create a null link

1 Select text, an image, or an object in the Document window’s Design view.
2 In the Property inspector, type javascript:; (the word javascript, followed by a colon, followed by a semicolon) in the Link box.

Create a script link

1 Select text, an image, or an object in the Document window’s Design view.
2 In the Link box of the Property inspector, type javascript: followed by some JavaScript code or a function call. (Do not type a space between the colon and the code or call.)

Update links automatically

Dreamweaver can update links to and from a document whenever you move or rename the document within a local site. This feature works best when you store your entire site (or an entire self-contained section of it) on your local disk. Dreamweaver does not change files in the remote folder until you put the local files on or check them in to the remote server.

To make the updating process faster, Dreamweaver can create a cache file in which to store information about all the links in your local folder. The cache file is updated invisibly as you add, change, or delete links on your local site.

Enable automatic link updates

1 Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).
2 In the Preferences dialog box, select General from the category list on the left.
3 In the Document Options section of the General preferences, select an option from the Update Links When Moving Files pop-up menu.
   - **Always**: Automatically updates all links to and from a selected document whenever you move or rename it.
   - **Never**: Does not automatically update all links to and from a selected document when you move or rename it.
   - **Prompt**: Displays a dialog box that lists all the files affected by the change. Click Update to update the links in these files, or click Don’t Update to leave the files unchanged.
4 Click OK.

Create a cache file for your site
1 Select Site > Manage Sites.
2 Select a site, and then click Edit.
3 In the Site Setup dialog box, expand Advanced Settings and select the Local Info category.
4 In the Local Info category, select Enable Cache.

The first time you change or delete links to files in your local folder after starting Dreamweaver, Dreamweaver prompts you to load the cache. If you click Yes, Dreamweaver loads the cache and updates all the links to the file you just changed. If you click No, the change is noted in the cache, but Dreamweaver does not load the cache or update links.

It may take a few minutes to load the cache on larger sites because Dreamweaver must determine whether the cache is up to date by comparing the timestamps of the files on the local site against the timestamps recorded in the cache. If you have not changed any files outside Dreamweaver, you can safely click the Stop button when it appears.

Re-create the cache
❖ In the Files panel, select Site > Advanced > Recreate Site Cache.

Change a link sitewide
In addition to having Dreamweaver update links automatically whenever you move or rename a file, you can manually change all links (including e-mail, FTP, null, and script links) so that they point somewhere else.

This option is most useful when you want to delete a file that other files link to, but you can use it for other purposes. For example, suppose you link the words "this month’s movies" to /movies/july.html throughout your site. On August 1 you would change those links so that they point to /movies/august.html.

1 Select a file in the Local view of the Files panel.

Note: If you are changing an e-mail, FTP, null, or script link, you do not need to select a file.
2 Select Site > Change Link Sitewide.
3 Complete these options in Change Link Sitewide dialog box:
   Change All Links To Click the folder icon to browse to and select the target file from which to unlink. If you are changing an e-mail, FTP, null, or script link, type the full text of the link you are changing.
   Into Links to Click the folder icon to browse to and select the new file to link to. If you are changing an e-mail, FTP, null, or script link, type the full text of the replacement link.
4 Click OK.

Dreamweaver updates any documents that link to the selected file, making them point to the new file, using the path format already used in the document (for example, if the old path was document-relative, the new path is also document-relative).

After you change a link sitewide, the selected file becomes an orphan (that is, no files on your local disk point to it). You can safely delete it without breaking any links in your local Dreamweaver site.

Important: Because these changes occur locally, you must manually delete the corresponding orphan file in the remote folder and put or check in any files in which links were changed; otherwise, visitors to your site won’t see the changes.
Test links in Dreamweaver

Links are not active within Dreamweaver; that is, you cannot open a linked document by clicking the link in the Document window.

❖ Do one of the following:
  • Select the link and select Modify > Open Linked Page.
  • Press Control (Windows) or Command (Macintosh) and double-click the link.

*Note:* The linked document must reside on your local disk.

More Help topics

“Find broken, external, and orphaned links” on page 274

“Fix broken links” on page 275

Jump menus

About jump menus

A *jump menu* is a pop-up menu in a document, visible to your site visitors, listing links to documents or files. You can create links to documents in your website, links to documents on other websites, e-mail links, links to graphics, or links to any file type that can be opened in a browser.

Each option in a jump menu is associated with a URL. When users choose an option, they are redirected (“jump”) to the associated URL. Jump menus are inserted within the Jump Menu form object.

A jump menu can contain three components:

• (Optional) A menu selection prompt, such as a category description for the menu items, or instructions, such as “Choose one”.

• (Required) A list of linked menu items: a user selects an option and a linked document or file opens.

• (Optional) A Go button.

More Help topics

“Apply the Jump Menu behavior” on page 340

“Apply the Jump Menu Go behavior” on page 340

Insert a jump menu

1 Open a document, and then place the insertion point in the Document window.

2 Do one of the following:
  • Select Insert > Form > Jump Menu.
  • In the Forms category of the Insert panel, click the Jump Menu button.

3 Complete the Insert Jump menu dialog box and click OK. Here is a partial list of options:

*Plus and Minus buttons*  Click Plus to insert an item; click Plus again to add another one. To delete an item, select it and click Minus.
Arrow buttons  Select an item and click the arrows to move it up or down in the list.

Text  Type the name of an unnamed item. If your menu includes a selection prompt (such as “Choose one”), type it here as the first menu item (if so, you must also choose the Select First Item After URL Change option at the bottom).

When Selected Go To URL  Browse to the target file or type its path.

Open URLs In  Specify whether to open the file in the same window or in a frame. If the frame you want to target doesn’t appear in the menu, close the Insert Jump Menu dialog box and name the frame.

Insert Go Button After Menu  Select to insert a Go button rather than a menu selection prompt.

Select First Item After URL Change  Select if you inserted a menu selection prompt (“Choose one”) as the first menu item.

More Help topics
“View and set frame properties and attributes” on page 193

Edit jump menu items
You can change the order of items in the menu or the file an item links to, and you can add, delete, or rename an item.

To change the location in which a linked file opens, or to add or change a menu selection prompt, you must apply the Jump Menu behavior from the Behaviors panel.

1  Open the Property inspector (Window > Properties) if it isn’t already open.

2  In the Document window’s Design view, click the jump menu object to select it.

3  In the Property inspector, click the List Values button.

4  Use the List Values dialog box to make your changes to the menu items, and then click OK.

More Help topics
“Apply the Jump Menu behavior” on page 340

Troubleshooting jump menus
After a user selects a jump menu item, there is no way to reselect that menu item if the user navigates back to that page, or if the Open URL In box specifies a frame. There are two ways to work around this problem:

• Use a menu selection prompt, such as a category, or a user instruction, such as “Choose one”. The menu selection prompt is reselected automatically after each menu selection.

• Use a Go button, which allows a user to revisit the currently chosen link. When you use a Go button with a jump menu, the Go button becomes the only mechanism that “jumps” the user to the URL associated with the selection in the menu. Selecting a menu item in the jump menu no longer re-directs the user automatically to another page or frame.

Note: Select only one of these options per jump menu, in the Insert Jump Menu dialog box, because they apply to an entire jump menu.
Navigation bars

About navigation bars
The navigation bar feature has been deprecated as of Dreamweaver CS5.

Adobe recommends using the Spry Menu Bar widget if you want to create a navigation bar.

More Help topics
“Working with the Spry Menu Bar widget” on page 412

Image maps

About image maps
An image map is an image that has been divided into regions called hotspots; when a user clicks a hotspot, an action occurs (for example, a new file opens).

Client-side image maps store the hypertext link information in the HTML document—not in a separate map file as server-side image maps do. When a site visitor clicks a hotspot in the image, the associated URL is sent directly to the server. This makes client-side image maps faster than server-side image maps, because the server does not need to interpret where the visitor clicked. Client-side image maps are supported by Netscape Navigator 2.0 and later versions, NCSA Mosaic 2.1 and 3.0, and all versions of Internet Explorer.

Dreamweaver does not alter references to server-side image maps in existing documents; you can use both client-side image maps and server-side image maps in the same document. However, browsers that support both types of image maps give priority to client-side image maps. To include a server-side image map in a document, you must write the appropriate HTML code.

Insert client-side image maps
When you insert a client-side image map, you create a hotspot area and then define a link that opens when a user clicks the hotspot area.

Note: You can create multiple hotspot areas, but they are part of the same image map.

1 In the Document window, select the image.
2 In the Property inspector, click the expander arrow in the lower-right corner to see all properties.
3 In the Map Name box, enter a unique name for the image map. If you are using multiple image maps in the same document, make sure each map has a unique name.
4 To define the image map areas, do one of the following:
   • Select the circle tool and drag the pointer over the image to create a circular hotspot.
   • Select the rectangle tool and drag the pointer over the image to create a rectangular hotspot.
   • Select the polygon tool and define an irregularly shaped hotspot by clicking once for each corner point. Click the arrow tool to close the shape.

After you create the hotspot, the hotspot Property inspector appears.
5 In the hotspot Property inspector’s Link box, click the folder icon to browse to and select the file you want to open when the user clicks the hotspot, or type the path.

6 In the Target pop-up menu, select the window in which the file should open or type its name.

The names of all the frames you’ve named in the current document appear in the pop-up list. If you specify a frame that doesn’t exist, the linked page loads into a new window that has the name you specified. You can also select from the following reserved target names:

- _blank loads the linked file into a new, unnamed browser window.
- _parent loads the linked file into the parent frameset or window of the frame that contains the link. If the frame containing the link is not nested, the linked file loads into the full browser window.
- _self loads the linked file into the same frame or window as the link. This target is the default, so you usually don’t need to specify it.
- _top loads the linked file into the full browser window, thereby removing all frames.

Note: The target option isn’t available until the selected hotspot contains a link.

7 In the Alt box, type alternative text for display in text-only browsers or browsers that download images manually. Some browsers display this text as a tooltip when the user moves the pointer over the hotspot.

8 Repeat steps 4 through 7 to define additional hotspots in the image map.

9 When you finish mapping the image, click a blank area in the document to change the Property inspector.

Modify image map hotspots

You can easily edit the hotspots you create in an image map. You can move a hotspot area, resize hotspots, or move a hotspot forward or back in an absolutely-positioned element (AP element).

You can also copy an image with hotspots from one document to another, or copy one or more hotspots from an image and paste them on another image; hotspots associated with the image are also copied to the new document.

Select multiple hotspots in an image map

1 Use the pointer hotspot tool to select a hotspot.

2 Do one of the following:
   - Shift-click the other hotspots you want to select.
   - Press Control+A (Windows) or Command+A (Macintosh) to select all of the hotspots.

Move a hotspot

1 Use the pointer hotspot tool to select the hotspot.

2 Do one of the following:
   - Drag the hotspot to a new area.
   - Use the Control + arrow keys to move a hotspot by 10 pixels in the selected direction.
   - Use the arrow keys to move a hotspot by 1 pixel in the selected direction.

Resize a hotspot

1 Use the pointer hotspot tool to select the hotspot.

2 Drag a hotspot selector handle to change the size or shape of the hotspot.
Troubleshooting links

Find broken, external, and orphaned links
Use the Check Links feature to search for broken links and _orphaned_ files (files that still exist in the site but that aren’t linked to by any other files in the site). You can search an open file, a portion of a local site, or an entire local site.

Dreamweaver verifies links only to documents within the site; Dreamweaver compiles a list of external links in the selected document or documents but does not verify them.

You can also identify and delete files that are no longer used by other files in your site.

**More Help topics**
“Identify and delete unused files” on page 78

**Check links in the current document**
1. Save the file to a location within your local Dreamweaver site.
2. Select File > Check Page > Links.

The Broken Links report appears in the Link Checker panel (in the Results panel group).

3. In the Link Checker panel, select External Links from the Show pop-up menu to view another report.

The External Links report appears in the Link Checker panel (in the Results panel group).

💡 You can check for orphaned files when you check links across an entire site.

4. To save the report, click the Save Report button in the Link Checker panel. The report is a temporary file; it will be lost if you don’t save it.

**Check links in part of a local site**
1. In the Files panel, select a site from the Current Sites pop-up menu.
2. In Local view, select the files or folders to check.
3. Initiate the check by doing one of the following:
   - Right-click (Windows) or Control-click (Macintosh) one of the selected files, and then select Check Links > Selected Files/Folders from the context menu.
   - Select File > Check Page > Links.

The Broken Links report appears in the Link Checker panel (in the Results panel group).

4. In the Link Checker panel, select External Links from the Show pop-up menu to view another report.

The External Links report appears in the Link Checker panel (in the Results panel group).

💡 You can check for orphaned files when you check links across an entire site.

5. To save a report, click the Save Report button in the Link Checker panel.

**Check links across the entire site**
1. In the Files panel, select a site from the Current Sites pop-up menu.
2 Select Site > Check Links Sitewide.
The Broken Links report appears in the Link Checker panel (in the Results panel group).

3 In the Link Checker panel, select External Links or Orphaned Files from the Show pop-up menu to view another report.
A list of files that fit the report type you selected appears in the Link Checker panel.

Note: If you select Orphaned Files as your report type, you can delete orphaned files from the Link Checker panel directly by selecting a file from the list and pressing the Delete key.

4 To save a report, click the Save Report button in the Link Checker panel.

Fix broken links
After you run a links reports, you can fix broken links and image references directly in the Link Checker panel, or you can open files from the list and fix links in the Property inspector.

Fix links in the Link Checker panel
1 Run a link check report.
2 In the Broken Links column (not the Files column) of the Link Checker panel (in the Results panel group), select the broken link.
A folder icon appears next to the broken link.
3 Click the folder icon next to the broken link and browse to the correct file, or type the correct path and filename.
4 Press Tab or Enter (Windows) or Return (Macintosh).
If there are other broken references to this same file, you are prompted to fix the references in the other files as well. Click Yes to have Dreamweaver update all the documents on the list that reference this file. Click No to have Dreamweaver update the current reference only.

Note: If Enable File Check In And Check Out is enabled for the site, Dreamweaver attempts to check out files that require changes. If it cannot check out a file, Dreamweaver displays a warning dialog box and leaves broken references unchanged.

Fix links in the Property inspector
1 Run a link check report.
2 In the Link Checker panel (in the Results panel group), double-click an entry in the File column.
Dreamweaver opens the document, selects the broken image or link, and highlights the path and filename in the Property inspector. (If the Property inspector is not visible, select Window > Properties to open it.)
3 To set a new path and filename in the Property inspector, click the folder icon to browse to the correct file, or type over the highlighted text.
If you are updating an image reference and the new image appears at the incorrect size, click the W and H labels in the Property inspector or click the Refresh button to reset the height and width values.
4 Save the file.
As links are fixed, their entries disappear from the Link Checker list. If an entry still appears in the list after you enter a new path or filename in the Link Checker (or after you save changes in the Property inspector), Dreamweaver cannot find the new file and still considers the link broken.
Chapter 10: Previewing pages

Previewing pages

Design view gives you an idea of how your page will look on the web but does not render pages exactly as browsers do. Live view presents a more accurate depiction, and lets you work in Code view so that you can see changes to the design. The Preview in Browser feature lets you see how your pages will look in specific browsers.

Previewing pages in Dreamweaver

About Live view

Live view differs from the traditional Dreamweaver design view in that it provides a non-editable, more realistic rendering of what your page will look like in a browser. Live view does not replace the Preview in Browser command, but rather provides another way of seeing what your page looks like “live” without having to leave the Dreamweaver workspace.

You can switch to Live view any time you are in Design view. Switching to Live view, however, is not related to switching between any of the other traditional views in Dreamweaver (Code/Split/Design). When you switch to Live view from Design view, you are simply toggling the Design view between editable and “live”.

While Design view remains frozen once you enter Live view, Code view remains editable, so you can change your code, and then refresh Live view to see your changes take effect. When you’re in Live view, you have the additional option of viewing live code. Live Code view is like Live view in that it displays a version of the code that the browser is executing in order to render the page. Like Live view, Live Code view is a non-editable view.

An additional advantage of Live view is the ability to freeze JavaScript. For example, you can switch to Live view and hover over Spry-based table rows that change color as the result of user interaction. When you freeze JavaScript, Live view freezes the page in its current state. You can then edit your CSS or JavaScript and refresh the page to see the changes take effect. Freezing JavaScript in Live view is useful if you want to see and change properties for the different states of pop-up menus or other interactive elements that you can’t see in traditional Design view.

For a video overview from the Dreamweaver engineering team about working with Live View, see www.adobe.com/go/dw10liveview.

For a video overview from the Dreamweaver engineering team about working with Live view navigation, see www.adobe.com/go/dwcs5livenav_en.

For a video tutorial on working with Live View, related files, and the Code Navigator, see www.adobe.com/go/lrvid4044_dw.

Preview pages in Live view

1. Make sure that you are in Design view (View > Design) or Code and Design views (View > Code and Design).
2. Click the Live view button.
3. (Optional) Make your changes in Code view, in the CSS Styles panel, in an external CSS style sheet, or in another related file.
Previewing pages

Even though you can’t edit in Live view, your options for making edits in other areas (for example, in the CSS Styles panel or in Code view) change as you click in Live view.

You can work with related files (such as CSS style sheets) while keeping Live view in focus by opening the related file from the Related Files toolbar at the top of the document.

4 If you’ve made changes in Code view or in a related file, refresh Live view by clicking the Refresh button in the Document tool bar, or by pressing F5.

5 To return to the editable Design view, click the Live view button again.

**Preview Live Code**

The code displayed in Live Code view is similar to what you would see if you viewed the page source from a browser. While such page sources are static, providing you with only the source of the page from the browser, Live Code view is dynamic, and updates as you interact with the page in Live view.

1 Make sure that you are in Live view.

2 Click the Live Code button.

Dreamweaver displays the live code that the browser would use to execute the page. The code is highlighted in yellow and is uneditable.

When you interact with interactive elements on the page, Live Code highlights the dynamic changes in the code.

3 To turn off highlighting for changes in Live Code view, choose View > Live View Options > Highlight Changes in Live Code.

4 To return to the editable Code view, click the Live Code button again.

To change Live Code preferences, choose Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh OS), and select the Code Coloring category.

**Freeze JavaScript**

Do one of the following:

- Press F6
- Select Freeze JavaScript from the Live View button’s pop-up menu.

An info bar at the top of the document tells you that JavaScript is frozen. To close the info bar, click the close link.

**Live view options**

Besides the Freeze JavaScript option, there are some other options available from the Live View button’s pop-up menu, or from the View > Live View Options menu item.

**Freeze JavaScript** Freeze elements affected by JavaScript in their current state.

**Disable JavaScript** Disables JavaScript and re-renders the page as it would look if a browser did not have JavaScript enabled.

**Disable Plug-ins** Disables plug-ins and re-renders the page as it would look if a browser did not have plug-ins enabled.

**Highlight Changes in Live Code** Turns highlighting for changes in Live Code on or off.
**Edit the Live View Page in a New Tab**  Lets you open new tabs for site documents you browse to using the Browser Navigation toolbar or the Follow Link(s) feature. You must browse to the document first, then select Edit the Live View Page in a New Tab to create a new tab for it.

**Follow Link**  Makes the next link you click in Live View active. Alternatively you can Control-click a link in Live view to make it active.

**Follow Links Continuously**  Makes links in Live View continuously active until you disable them again, or close the page.

**Automatically Sync Remote Files**  Automatically syncs the local and remote file when you click the Refresh icon in the Browser Navigation toolbar. Dreamweaver puts your file to the server before refreshing so that both files are in sync.

**Use Testing Server for Document Source**  Used mainly by dynamic pages (such as ColdFusion pages), and selected by default for dynamic pages. When this option is selected, Dreamweaver uses the version of the file on the site’s testing server as the source for the Live view display.

**Use Local Files for Document Links**  The default setting for non-dynamic sites. When this option is selected for dynamic sites that use a testing server, Dreamweaver uses the local versions of files that are linked to the document (for example, CSS and JavaScript files), instead of the files on the testing server. You can then make local changes to related files so that you can see how they look before putting them to the testing server. If this option is deselected, Dreamweaver uses the testing server versions of related files.

**HTTP Request Settings**  Takes you to an advanced settings dialog box where you can enter values for displaying live data. For more information, click the Help button in the dialog box.

---

**More Help topics**

“Browser Navigation toolbar overview” on page 10

“Switch between views in the Document window” on page 17

“Open Related Files” on page 68

“Viewing live data” on page 571

Live View video tutorial

---

**Previewing pages in browsers**

**Preview in a browser**

You can preview a page in a browser at any time; you don't have to upload it to a web server first. When you preview a page, all browser-related functions should work, including JavaScript behaviors, document-relative and absolute links, ActiveX® controls, and Netscape Navigator plug-ins, provided that you installed the required plug-ins or ActiveX controls in your browsers.

Before previewing a document, save the document; otherwise, the browser does not display your most recent changes.

1. Do one of the following to preview the page:
   - Select File > Preview In Browser, and then select one of the listed browsers.
   - Press F12 (Windows) or Option+F12 (Macintosh) to display the current document in the primary browser.
   - Press Control+F12 (Windows) or Command+F12 (Macintosh) to display the current document in the secondary browser.

---

Last updated 12/7/2011
2 Click links and test content in your page.

*Note:* Content linked with a site root-relative path does not appear when you preview documents in a local browser unless you specify a testing server, or select the Preview Using Temporary File option in Edit > Preferences > Preview In Browser. This is because browsers don’t recognize site roots—servers do.

💡 To preview content linked with root-relative paths, put the file on a remote server, and then select File > Preview In Browser to view it.

3 Close the page in the browser when you finish testing.

**More Help topics**
“Site root–relative paths” on page 263

**Set browser preview preferences**
You can set preferences for the browser to use when previewing a site and define default primary and secondary browsers.

1 Select File > Preview In Browser > Edit Browser List.
2 To add a browser to the list, click the Plus (+) button, complete the Add Browser dialog box, and then click OK.
3 To delete a browser from the list, select the browser, and then click the Minus (-) button.
4 To change settings for a selected browser, click the Edit button, make changes in the Edit Browser dialog box, and then click OK.
5 Select the Primary Browser or the Secondary Browser option to specify whether the selected browser is the primary or secondary browser.

F12 (Windows) or Option+F12 (Macintosh) opens the primary browser; Control+F12 (Windows) or Command+F12 (Macintosh) opens the secondary browser.

6 Select Preview Using Temporary File to create a temporary copy for previewing and server debugging. (Deselect this option if you want to update the document directly.)

**Previewing pages in mobile devices**
To preview pages created in Dreamweaver on various mobile devices, use Device Central with its built-in Opera Small-Screen Rendering feature. Different devices have different browsers installed, but the preview can give a good impression of how content will look and behave on a selected device.

1 Start Dreamweaver.
2 Open a file.
3 Do one of the following:
   - Select File > Preview in Browser > Device Central.
   - On the document window toolbar, click and hold the Preview/Debug In browser button 🔄, and select Preview In Device Central.

The file is displayed in the Device Central Emulator tab. To continue testing, double-click the name of a different device in the Device Sets
or
Available Devices

More Help topics
“Working with Device Central and Dreamweaver” on page 365
Chapter 11: Working with page code

General information about coding in Dreamweaver

More Help topics
“Code hints” on page 292
“Setting coding preferences” on page 287
“Customizing keyboard shortcuts” on page 287
“Make pages XHTML-compliant” on page 313
“Search for tags, attributes, or text in code” on page 306
“Save and recall search patterns” on page 306
“Optimizing the workspace for visual development” on page 532
“Displaying database records” on page 562

Supported languages
In addition to text-editing capabilities, Adobe® Dreamweaver® CS5 provides various features, such as code hints, to help you code in the following languages:

- HTML
- XHTML
- CSS
- JavaScript
- ColdFusion Markup Language (CFML)
- VBScript (for ASP)
- C# and Visual Basic (for ASP.NET)
- JSP
- PHP

Other languages, such as Perl, are not supported by the language-specific coding features in Dreamweaver; for example, you can create and edit Perl files, but code hints don’t apply to that language.

Invalid markup
If your document contains invalid code, Dreamweaver displays that code in Design view and optionally highlights it in Code view. If you select the code in either view, the Property inspector displays information about why it’s invalid and how to fix it.

Note: The option to highlight invalid code in Code view is turned off by default. To turn it on, switch to Code View (View > Code) and then select View > Code View Options > Highlight Invalid Code.

You can also specify preferences for automatically rewriting various kinds of invalid code when you open a document.
Automatic code modification

You can set options that instruct Dreamweaver to automatically clean up your hand-written code according to criteria that you specify. However, your code is never rewritten unless the code rewriting options are enabled or you perform an action that changes the code. For example, Dreamweaver does not alter your white space or change the case of attributes unless you use the Apply Source Formatting command.

A few of these code rewriting options are enabled by default.

The Roundtrip HTML capabilities in Dreamweaver let you move your documents back and forth between a text-based HTML editor and Dreamweaver with little or no effect on the content and structure of the document’s original HTML source code. These capabilities include the following:

- Use a third-party text editor to edit the current document.
- By default, Dreamweaver does not make changes in code created or edited in other HTML editors, even if the code is invalid, unless you enable code-rewriting options.
- Dreamweaver does not change tags it doesn’t recognize—including XML tags—because it has no criteria by which to judge them. If an unrecognized tag overlaps another tag (for example, `<MyNewTag><em>text</MyNewTag></em>`), Dreamweaver marks it as an error but doesn’t rewrite the code.
- Optionally, you can set Dreamweaver to highlight invalid code in Code view (in yellow). When you select a highlighted section, the Property inspector displays information on how to correct the error.

XHTML code

Dreamweaver generates new XHTML code and cleans up existing XHTML code in a way that meets most of the XHTML requirements. The tools that you need to meet the few XHTML requirements that remain are also provided.

*Note: Some of the requirements also are required in various versions of HTML.*

The following table describes the XHTML requirements that Dreamweaver meets automatically:

<table>
<thead>
<tr>
<th>XHTML requirement</th>
<th>Actions Dreamweaver performs</th>
</tr>
</thead>
</table>
| There must be a DOCTYPE declaration in the document prior to the root element, and the declaration must reference one of the three Document Type Definition (DTD) files for XHTML (strict, transitional, or frameset). | Adds an XHTML DOCTYPE to an XHTML document:  
```
<DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
```
Or, if the XHTML document has a frameset:
```
<DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Frameset//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-frameset.dtd">
```
| The root element of the document must be html, and the html element must designate the XHTML namespace. | Adds the namespace attribute to the html element, as follows:  
```
<html xmlns="http://www.w3.org/1999/xhtml">
```
| A standard document must have the head, title, and body structural elements. A frameset document must have the head, title, and frameset structural elements. | In a standard document, includes the head, title, and body elements. In a frameset document, includes the head, title, and frameset elements. |
| All elements in the document must nest properly:  
```
<p>This is a bad example.</p>
```
```
<p>This is a good example.</p>
```
| Generates correctly nested code and, when cleaning up XHTML, corrects nesting in code that was not generated by Dreamweaver. |
### Regular expressions

Regular expressions are patterns that describe character combinations in text. Use them in your code searches to help describe concepts such as lines that begin with “var” and attribute values that contain a number.

The following table lists the special characters in regular expressions, their meanings, and usage examples. To search for text containing one of the special characters in the table, escape the special character by preceding it with a backslash. For example, to search for the actual asterisk in the phrase `some conditions apply*`, your search pattern might look like this: `apply\*`. If you don’t escape the asterisk, you’ll find all the occurrences of “apply” (as well as any of “appl”, “applly”, and “appllyy”), not just the ones followed by an asterisk.
<table>
<thead>
<tr>
<th>Character</th>
<th>Matches</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>^</td>
<td>Beginning of input or line.</td>
<td>^T matches “T” in “This good earth” but not in “Uncle Tom’s Cabin”</td>
</tr>
<tr>
<td>$</td>
<td>End of input or line.</td>
<td>$h$ matches “h” in “teach” but not in “teacher”</td>
</tr>
<tr>
<td>*</td>
<td>The preceding character 0 or more times.</td>
<td>um* matches “um” in “rum”, “umm” in “yummy”, and “u” in “huge”</td>
</tr>
<tr>
<td>+</td>
<td>The preceding character 1 or more times.</td>
<td>um+ matches “um” in “rum” and “umm” in “yummy” but nothing in “huge”</td>
</tr>
<tr>
<td>?</td>
<td>The preceding character at most once (that is, indicates that the preceding character is optional).</td>
<td>st?on matches “son” in “Johnson” and “ston” in “Johnston” but nothing in “Appleton” or “tension”</td>
</tr>
<tr>
<td>.</td>
<td>Any single character except newline.</td>
<td>.an matches “ran” and “can” in the phrase “bran muffins can be tasty”</td>
</tr>
<tr>
<td>x</td>
<td>y</td>
<td>Either x or y.</td>
</tr>
<tr>
<td>[n]</td>
<td>Exactly n occurrences of the preceding character.</td>
<td>o{2} matches “oo” in “loom” and the first two o’s in “mooooo” but nothing in “money”</td>
</tr>
<tr>
<td>(n,m)</td>
<td>At least n, and at most m, occurrences of the preceding character.</td>
<td>F{2,4} matches “FF” in “#FF0000” and the first four Fs in “#FFFFFF”</td>
</tr>
<tr>
<td>[abc]</td>
<td>Any one of the characters enclosed in the brackets. Specify a range of characters with a hyphen (for example, [a-f] is equivalent to [abcdef]).</td>
<td>[aei0] matches “e” in “bed”, “f” in “folly”, and “g” in “guard”</td>
</tr>
<tr>
<td>[^abc]</td>
<td>Any character not enclosed in the brackets. Specify a range of characters with a hyphen (for example, [^a-f] is equivalent to [^abcdef]).</td>
<td>[^aeiou] initially matches “r” in “orange”, “b” in “book”, and “k” in “eek!”</td>
</tr>
<tr>
<td>\b</td>
<td>A word boundary (such as a space or carriage return).</td>
<td>\bb matches “b” in “book” but nothing in “goobler” or “snob”</td>
</tr>
<tr>
<td>\B</td>
<td>Anything other than a word boundary.</td>
<td>\Bb matches “b” in “goobler” but nothing in “book”</td>
</tr>
<tr>
<td>\d</td>
<td>Any digit character. Equivalent to [0-9].</td>
<td>\d matches “3” in “C3PO” and “2” in “apartment 2G”</td>
</tr>
<tr>
<td>\D</td>
<td>Any nondigit character. Equivalent to [^0-9].</td>
<td>\D matches “S” in “9005” and “Q” in “Q45”</td>
</tr>
<tr>
<td>\f</td>
<td>Form feed.</td>
<td></td>
</tr>
<tr>
<td>\n</td>
<td>Line feed.</td>
<td></td>
</tr>
<tr>
<td>\r</td>
<td>Carriage return.</td>
<td></td>
</tr>
<tr>
<td>\s</td>
<td>Any single white-space character, including space, tab, form feed, or line feed.</td>
<td>\sbook matches “book” in “blue book” but nothing in “notebook”</td>
</tr>
<tr>
<td>\S</td>
<td>Any single non-white-space character.</td>
<td>\Sbook matches “book” in “notebook” but nothing in “blue book”</td>
</tr>
<tr>
<td>\t</td>
<td>A tab.</td>
<td></td>
</tr>
</tbody>
</table>
Use parentheses to set off groupings within the regular expression to be referred to later. Then use $1, $2, $3, and so on in the Replace With field to refer to the first, second, third, and later parenthetical groupings.

**Note:** In the Search For box, to refer to a parenthetical grouping earlier in the regular expression, use \1, \2, \3, and so on instead of $1, $2, $3.

For example, searching for \(\d+\)/\(\d+\)/\(\d+\) and replacing it with $2/$1/$3 swaps the day and month in a date separated by slashes, thereby converting between American-style dates and European-style dates.

### Server behavior code

When you develop a dynamic page and select a server behavior from the Server Behaviors panel, Dreamweaver inserts one or more code blocks into your page to make the server behavior work.

If you manually change the code within a code block, you can no longer use panels such as the Bindings and Server Behaviors panels to edit the server behavior. Dreamweaver looks for specific patterns in the page code to detect server behaviors and display them in the Server Behaviors panel. If you change a code block’s code in any way, Dreamweaver can no longer detect the server behavior and display it in the Server Behaviors panel. However, the server behavior still exists on the page, and you can edit it in the coding environment in Dreamweaver.

### Setting up your coding environment

#### Using coder-oriented workspaces

You can adapt the coding environment in Dreamweaver to fit the way you work. For example, you can change the way you view code, set up different keyboard shortcuts, or import and use your favorite tag library.

Dreamweaver comes with several workspace layouts designed for an optimal coding experience. From the workspace switcher on the Application bar, you can select from Application Developer, Application Developer Plus, Coder, and Coder Plus workspaces. All of these workspaces show Code view by default (in either the entire Document window, or in Code and Design views), and have panels docked on the left side of the screen. All but Application Developer Plus eliminate the Property inspector from the default view.

If none of the pre-designed workspaces offer exactly what you need, you can customize your own workspace layout by opening and docking panels where you want them, and then saving the workspace as a custom workspace.
Viewing code

You can view the source code for the current document in several ways: you can display it in the Document window by enabling Code view, you can split the Document window to display both the page and its associated code, or you can work in the Code inspector, a separate coding window. The Code inspector works just like Code view; you can think of it as a detachable Code view for the current document.

More Help topics
“Change the code format” on page 288
“Set code hints preferences” on page 294
“Set the code colors” on page 291

View code in the Document window
❖ Select View > Code.

Code and edit a page simultaneously in the Document window
1 Select View > Code and Design.
   The code appears in the top pane and the page appears in the bottom pane.
2 To display the page on top, select Design View On Top from the View Options menu on the Document toolbar.
3 To adjust the size of the panes in the Document window, drag the splitter bar to the desired position. The splitter bar is located between the two panes.

Code view is updated automatically when you make changes in Design view. However, after making changes in Code view, you must manually update the document in Design view by clicking in Design view or pressing F5.

View code in a separate window with the Code inspector
The Code inspector lets you work in a separate coding window, just like working in Code view.
❖ Select Window > Code Inspector. The toolbar includes the following options:
File Management  Puts or gets the file.
Preview/Debug In Browser  Previews or debugs your document in a browser.
Refresh Design View  Updates the document in Design view so that it reflects any changes you made in the code. Changes you make in the code don’t automatically appear in Design view until you perform certain actions, such as saving the file or clicking this button.
Reference  Opens the Reference panel. See “Use language-reference material” on page 307.
Code Navigation  Lets you move quickly in the code. See “Go to a JavaScript or VBScript function” on page 303.
View Options  Lets you determine how the code is displayed. See “Set the code appearance” on page 287.
To use the Coding toolbar along the left side of the window, see “Insert code with the Coding toolbar” on page 296.

**Customizing keyboard shortcuts**

You can use your favorite keyboard shortcuts in Dreamweaver. If you’re accustomed to using specific keyboard shortcuts—for example, Shift+Enter to add a line break, or Control+G to go to a specific position in the code—you can add them to Dreamweaver using the Keyboard Shortcut Editor.

For instructions, see “Customize keyboard shortcuts” on page 32.

**More Help topics**

“Work with code snippets” on page 304

**Open files in Code view by default**

When you open a file type that normally doesn’t contain any HTML (for example, a JavaScript file), the file opens in Code view (or Code inspector) instead of Design view. You can specify which file types open in Code view.

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).
2. Select File Types/Editors from the Category list on the left.
3. In the Open In Code View box, add the filename extension of the file type you want to open automatically in Code view. Type a space between filename extensions. You can add as many extensions as you like.

**More Help topics**

“Use an external editor” on page 291

“Set Validator preferences” on page 313

**Setting coding preferences**

**About coding preferences**

You can set coding preferences such as code formatting and coloring, among others, to meet your specific needs.

*Note: To set advanced preferences, use the Tag Library editor (see “Managing tag libraries” on page 328).*

**Set the code appearance**

You can set word wrapping, display line numbers for the code, highlight invalid code, set syntax coloring for code elements, set indenting, and show hidden characters from the View > Code View Options menu.

1. View a document in Code view or the Code inspector.
2. Do one of the following:
   - Select View > Code View Options
   - Click the View Options button in the toolbar at the top of Code view or the Code inspector.
3 Select or deselect any of the following options:

**Word Wrap** Wraps the code so that you can view it without scrolling horizontally. This option doesn’t insert line breaks; it just makes the code easier to view.

**Line Numbers** Displays line numbers along the side of the code.

**Hidden Characters** Displays special characters in place of white space. For example, a dot replaces each space, a double chevron replaces each tab, and a paragraph marker replaces each line break.

*Note:* Soft line breaks that Dreamweaver uses for word wrapping are not displayed with a paragraph marker.

**Highlight Invalid Code** Causes Dreamweaver to highlight in yellow all HTML code that isn’t valid. When you select an invalid tag, the Property inspector displays information on how to correct the error.

**Syntax Coloring** Enables or disables code coloring. For information on changing the coloring scheme, see “Set the code colors” on page 291.

**Auto Indent** Makes your code indent automatically when you press Enter while writing code. The new line of code indents to the same level as the previous line. For information on changing the indent spacing, see the Tab Size option in “Change the code format” on page 288.

**More Help topics**
- “Viewing code” on page 286
- “Coding toolbar overview” on page 11
- “Set code hints preferences” on page 294

**Change the code format**

You can change the look of your code by specifying formatting preferences such as indentation, line length, and the case of tag and attribute names.

All the Code Format options, except the Override Case Of option, are automatically applied only to new documents or additions to documents that you subsequently create.

To reformat existing HTML documents, open the document, and select Commands > Apply Source Formatting.

1 Select Edit > Preferences.
2 Select Code Format from the Category list on the left.
3 Set any of the following options:

**Indent** Indicates whether code generated by Dreamweaver should be indented (according to the indentation rules specified in these preferences) or not.

*Note:* Most of the indentation options in this dialog box apply only to code generated by Dreamweaver, not to code that you type. To make each new line of code that you type indent to the same level as the previous line, select View > Code View Options Auto-Indent option. For more information, see “Set the code appearance” on page 287.

**With** (Text box and pop-up menu) Specifies how many spaces or tabs Dreamweaver should use to indent code that it generates. For example, if you type 3 in the box and select Tabs in the pop-up menu, then code generated by Dreamweaver is indented using three tab characters for every level of indentation.

**Tab Size** Determines how many characters wide each tab character appears in Code view. For example, if Tab Size is set to 4, then each tab is displayed in Code view as a four-character-wide blank space. If, additionally, Indent With is set to 3 Tabs, then code generated by Dreamweaver is indented using three tab characters for every level of indentation, which appears in Code view as a twelve-character-wide blank space.
Note: Dreamweaver indents using either spaces or tabs; it doesn’t convert a run of spaces to a tab when inserting code.

**Line Break Type** Specifies the type of remote server (Windows, Macintosh, or UNIX) that hosts your remote site. Choosing the correct type of line break characters ensures that your HTML source code appears correctly when viewed on the remote server. This setting is also useful when you are working with an external text editor that recognizes only certain kinds of line breaks. For example, use CR LF (Windows) if Notepad is your external editor, and use CR (Macintosh) if SimpleText is your external editor.

Note: For servers that you connect to using FTP, this option applies only to binary transfer mode; the ASCII transfer mode in Dreamweaver ignores this option. If you download files using ASCII mode, Dreamweaver sets line breaks based on the operating system of your computer; if you upload files using ASCII mode, the line breaks are all set to CR LF.

**Default Tag Case and Default Attribute Case** Control the capitalization of tag and attribute names. These options are applied to tags and attributes that you insert or edit in Design view, but they are not applied to the tags and attributes that you enter directly in Code view, or to the tags and attributes already in a document when you open it (unless you also select one or both of the Override Case Of options).

Note: These preferences apply only to HTML pages. Dreamweaver ignores them for XHTML pages because uppercase tags and attributes are invalid XHTML.

**Override Case Of: Tags and Attributes** Specifies whether to enforce your specified case options at all times, including when you open an existing HTML document. When you select one of these options and click OK to dismiss the dialog box, all tags or attributes in the current document are immediately converted to the specified case, as are all tags or attributes in each document you open from then on (until you deselect this option again). Tags or attributes you type in Code view and in the Quick Tag Editor are also converted to the specified case, as are tags or attributes you insert using the Insert panel. For example, if you want tag names always to be converted to lowercase, specify lowercase in the Default Tag Case option, and then select the Override Case Of: Tags option. Then when you open a document that contains uppercase tag names, Dreamweaver converts them all to lowercase.

Note: Older versions of HTML allowed either uppercase or lowercase tag and attribute names, but XHTML requires lowercase for tag and attribute names. The web is moving toward XHTML, so it’s generally best to use lowercase tag and attribute names.

**TD Tag: Do Not Include A Break Inside The TD Tag** Addresses a rendering problem that occurs in some older browsers when white space or line breaks exist immediately after a `<td>` tag, or immediately before a `</td>` tag. When you select this option, Dreamweaver does not write line breaks after a `<td>` or before a `</td>` tag, even if the formatting in the Tag Library indicates that the line break should be there.

**Advanced Formatting** Lets you set formatting options for

Cascading Style Sheets

( <CSS> code and for individual tags and attributes in the Tag Library Editor.

**White Space Character** (Japanese version only) Lets you select either &nbsp; or Zenkaku space for HTML code. The white space selected in this option will be used for empty tags when creating a table and when the “Allow Multiple Consecutive Spaces” option is enabled in Japanese Encoding pages.

**More Help topics**

“Format CSS code” on page 140

“Set code hints preferences” on page 294
Set the code rewriting preferences

Use the code rewriting preferences to specify how and whether Dreamweaver modifies your code while opening documents, when copying and pasting form elements, and when entering attribute values and URLs using tools such as the Property inspector. These preferences have no effect when you edit HTML or scripts in Code view.

If you disable the rewriting options, invalid-markup items are displayed in the Document window for HTML that it would have rewritten.

1 Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).
2 Select Code Rewriting from the Category list on the left.
3 Set any of the following options:

**Fix Invalidly Nested and Unclosed Tags** Rewrites overlapping tags. For example, `<b><i>text</b></i>` is rewritten as `<b><i>text</i></b>`. This option also inserts closing quotation marks and closing brackets if they are missing.

**Rename Form Items When Pasting** Ensures you don’t have duplicate names for form objects. This option is enabled by default.

*Note:* Unlike the other options in this preferences dialog box, this option does not apply when you open a document, only when you copy and paste a form element.

**Remove Extra Closing Tags** Deletes closing tags that have no corresponding opening tag.

**Warn When Fixing Or Removing Tags** Displays a summary of technically invalid HTML that Dreamweaver attempted to correct. The summary notes the location of the problem (using line and column numbers) so that you can find the correction and ensure that it’s rendering as intended.

**Never Rewrite Code: In Files With Extensions** Allows you to prevent Dreamweaver from rewriting code in files with the specified filename extensions. This option is particularly useful for files that contain third-party tags.

**Encode `<`, `>`, `, `&`, and `"` In Attribute Values Using &** Ensures that attribute values that you enter or edit using Dreamweaver tools such as the Property inspector contain only legal characters. This option is enabled by default.

*Note:* This option and the following options do not apply to URLs that you type in Code view. Also, *they do not cause existing code already in a file to change.*

**Do Not Encode Special Characters** Prevents Dreamweaver from changing URLs to use only legal characters. This option is enabled by default.

**Encode Special Characters In URL Using &** Ensures that when you enter or edit URLs using Dreamweaver tools such as the Property inspector, those URLs contain only legal characters.

**Encode Special Characters In URL Using %** Operates the same way as the preceding option, but uses a different method of encoding special characters. This encoding method (using the percent sign) may be more compatible with older browsers, but doesn’t work as well with characters from some languages.

**More Help topics**

“Clean up Microsoft Word HTML files” on page 71

“Set code hints preferences” on page 294
Set the code colors
Use the code coloring preferences to specify colors for general categories of tags and code elements, such as form-related tags or JavaScript identifiers. To set color preferences for a specific tag, edit the tag definition in the Tag Library editor.

1 Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).
2 Select Code Coloring from the Category list on the left.
3 Select a document type from the Document type list. Any edits you make to code coloring preferences will affect all documents of this type.
4 Click the Edit Coloring Scheme button.
5 In the Edit Coloring Scheme dialog box, select a code element from the Styles For list, and set its text color, background color, and (optional) style (bold, italic, or underline). The sample code in the Preview pane changes to match the new colors and styles.

Click OK to save your changes and close the Edit Coloring Scheme dialog box.

6 Make any other necessary selections in Code Coloring preferences and click OK.

**Default background** sets the default background color for Code view and the Code inspector.

**Hidden characters** sets the color for hidden characters.

**Live Code background** sets the background color for Live Code view. The default color is yellow.

**Live Code changes** sets the highlighting color of code that changes in Live Code view. The default color is pink.

**Read only background** sets the background color for read only text.

**More Help topics**
“Customize code coloring preferences for a template” on page 405
“Edit libraries, tags, and attributes” on page 329
“Preview Live Code” on page 277
“Set code hints preferences” on page 294

Use an external editor
You can specify an external editor to use for editing files with specific filename extensions. For example, you can start a text editor such as BBEdit, Notepad, or TextEdit from Dreamweaver to edit JavaScript (JS) files.

You can assign different external editors for different filename extensions.

**More Help topics**
“Open files in Code view by default” on page 287

Set an external editor for a file type
1 Select Edit > Preferences.
2 Select File Types/Editors from the Category list on the left, set the options, and click OK.

**Open In Code View** Specifies the filename extensions that automatically open in Code view in Dreamweaver.

**External Code Editor** Specifies the text editor to use.
**Reload Modified Files**  Specifies the behavior when Dreamweaver detects that changes were made externally to a document that is open in Dreamweaver.

**Save On Launch**  Specifies whether Dreamweaver should always save the current document before starting the editor, never save the document, or prompt you to ask whether to save or not each time you start the external editor.

**Fireworks**  Specifies editors for various media file types.

**Start an external code editor**

дел Селект Edit > Edit with External Editor.

### Writing and editing code

#### Code hints

The code hints feature helps you insert and edit code quickly and without mistakes. As you type characters in Code view, you see a list of candidates that automatically complete your entry. For example, when you type the first characters of a tag, attribute, or CSS property name, you see a list of options beginning with those characters. This feature simplifies the insertion and editing of code. You can also use it to see the available attributes for a tag, the available parameters for a function, or the available methods for an object.

Code hints are available for several kinds of code. When you type the beginning character of a particular code type, you see a list of appropriate candidates. For example, to display a list of code hints for HTML tag names, type a right angle bracket (<). Similarly, to display JavaScript code hinting, type a period (dot operator) after an object.

*For best results, especially when using code hints for functions and objects, set the Delay option in the Code Hints preferences dialog box to 0 seconds.*

The code hinting feature also recognizes custom JavaScript classes that are not built in to the language. You can write these custom classes yourself or add them through third-party libraries like Prototype.

The list of code hints disappears when you press Backspace (Windows) or Delete (Macintosh).

For a video tutorial on code hinting, see [www.adobe.com/go/lrvid4048_dw](http://www.adobe.com/go/lrvid4048_dw).

For a video overview from the Dreamweaver engineering team about JavaScript support in Dreamweaver, see [www.adobe.com/go/dw10javascript](http://www.adobe.com/go/dw10javascript).

#### Supported languages and technologies

Dreamweaver supports code hinting for the following languages and technologies:

- Adobe ColdFusion
- Ajax
- ASP JavaScript
- ASP.NET C#
- ASP.NET VB
- ASP VBScript
- CSS2 and CSS3
- DOM (Document Object Model)
USING DREAMWEAVER

Using code hints

- HTML4 and HTML5
- jQuery (CS5.5 and later)
- JavaScript (includes custom class hinting)
- JSP
- PHP MySQL
- Spry

Display a code hints menu

The code hints menu appears automatically as you type in Code view. But you can also display the code hints menu manually, without typing.

1. In Code view (Window > Code), place the insertion point inside a tag.
2. Press Control+Spacebar.

Insert code in Code view by using code hints

1. Type the beginning of a piece of code. For example, to insert a tag, type a right angle bracket (>). To insert an attribute, place the insertion point immediately after a tag name and press Spacebar.

A list of items (such as tag names or attribute names) appears.

To close the list at any time, press Esc.

2. Scroll through the list by using the scroll bar or the Up Arrow and Down Arrow keys.
3. To insert an item from the list, double-click it, or select it and press Enter (Windows) or Return (Macintosh).

If a recently created CSS style doesn’t appear in a code hints list of CSS styles, select Refresh Style List from the code hints list. If Design view is visible, sometimes invalid code appears in Design view temporarily after you select Refresh Style List. To remove that invalid code from Design view, press F5 to refresh after you finish inserting the style.

4. To insert a closing tag, type </ (slash).

Note: By default, Dreamweaver determines when a closing tag is needed and inserts it automatically. You can change this default behavior so that Dreamweaver inserts a closing tag after you type the final angle bracket (>) of the opening tag. Alternatively, the default behavior can be to insert no closing tag at all. Select Edit > Preferences > Code Hints, and then select one of the Close Tags options.

Edit a tag by using code hints

- To replace an attribute with a different attribute, delete the attribute and its value. Then add a new attribute and its value as described in the previous procedure.
- To change a value, delete the value, and then add a new value as described in the previous procedure.

Refreshing JavaScript code hints

Dreamweaver automatically refreshes the list of available code hints as you work in JavaScript files. For example, suppose you are working in a primary HTML file and switch to a JavaScript file to make a change. That change is reflected in the list of code hints when you return to the primary HTML file. However, automatic updating works only if you edit your JavaScript files in Dreamweaver.

If you edit your JavaScript files outside Dreamweaver, press Control+period to refresh the JavaScript code hints.
**Code hinting and syntax errors**

Code hints sometimes don’t work properly if Dreamweaver detects syntax errors in your code. Dreamweaver alerts you to syntax errors by displaying information about them in a bar at the top of the page. The Syntax Error Information Bar displays the first line of code on which Dreamweaver encounters the error. As you fix errors, Dreamweaver continues to display any errors that occur later.

Dreamweaver provides additional help by highlighting (in red) the line numbers where syntax errors occur. The highlight appears in the Code view of the file that contains the error.

Dreamweaver displays syntax errors not only for the current page but also for related pages. For example, suppose you are working on an HTML page that uses an included JavaScript file. If the included file contains an error, Dreamweaver displays an alert for the JavaScript file as well. You can easily open the related file containing the error by clicking its name at the top of the document.

You can disable the Syntax Error Information Bar by clicking the Syntax Error Alerts button in the Coding toolbar.

**Set code hints preferences**

You can change default preferences for code hints. For example, if you don’t want to show CSS property names or Spry code hints, you can deselect them in code hints preferences. You can also set preferences for code hint delay time and closing tags.

> Even if code hints are disabled, you can still display a pop-up hint in Code view by pressing Control+Spacebar.

1. Select Edit > Preferences.
2. Select Code Hints from the Category list on the left.
3. Set any of the following options:
   - **Close Tags** Specifies how you want Dreamweaver to insert closing tags. By default, Dreamweaver inserts the closing tag automatically after you type the characters </. You can change this default behavior so that the closing tag is inserted after you type the final angle bracket (>), or so that no closing tag is inserted at all.
   - **Enable Code Hints** Displays code hints while you enter code in Code view. Drag the Delay slider to set the time in seconds before appropriate hints are displayed.
   - **Enable Description Tooltips** Displays an extended description (if available) of the selected code hint.
   - **Menus** Sets exactly which type of code hints you want displayed while typing. You can use all or some of the menus.

**More Help topics**

“Use the hints menu in the Quick Tag Editor” on page 318

W3C Document Object Model

Code hinting tutorial

**Site-specific code hints**

Dreamweaver CS5 lets developers working with Joomla, Drupal, Wordpress or other frameworks, to view PHP code hints as they write in Code view. To display these code hints, you first need to create a configuration file using the Site-Specific Code Hints dialog box. The configuration tells Dreamweaver where to look for code hints that are specific to your site.

For a video tutorial on working with Site-specific code hints, see [www.adobe.com/go/learn_dw_comm13_en](http://www.adobe.com/go/learn_dw_comm13_en).
Create the configuration file

Use the Site-Specific Code Hints dialog box to create the configuration file needed to display code hints in Dreamweaver.

By default, Dreamweaver stores the configuration file in the Adobe Dreamweaver CS5\configuration\Shared\Dinamico\Presets directory.

*Note:* The code hints you create are specifically for the site selected in the Dreamweaver Files panel. In order for the code hints to display, the page you are working on must reside in the currently selected site.

1. Select Site > Site-Specific Code Hints.

   By default, the Site-Specific Code Hints feature scans your site to determine which Content Management System (CMS) framework you’re using. Dreamweaver supports three frameworks by default: Drupal, Joomla, and Wordpress.

   The four buttons to the right of the Structure pop-up menu let you import, save, rename, or delete framework structures.

   *Note:* You cannot delete or rename the existing default framework structures.

2. In the sub-root text box, specify the sub-root folder where you store your framework’s files. You can click the folder icon next to the text box to browse to the framework files’ location.

   Dreamweaver displays a file tree structure of folders that contain your framework files. If the folders and/or files you want to scan are all displayed, click OK to run the scan. If you want to customize the scan, go on to the next steps.

3. Click the plus (+) button above the Files window to select a file or folder that you want to add to the scan. In the Add Files/Folders dialog box, you can specify particular file extensions that you want to include.

   *Note:* Specifying particular file extensions speeds up the scanning process.

4. To remove files from the scan, select the files you don’t want scanned, and then click the minus (-) button above the Files window.

   *Note:* If Drupal or Joomla is the selected framework, the Site-Specific Code Hints dialog box displays an additional path to a file within your Dreamweaver configuration folder. Don’t delete this—it’s required when using these frameworks.

5. To customize how the Site-Specific Code Hints feature treats a particular file or folder, select it from the list and do one of the following:
   - Select Scan This Folder to include the selected folder in the scan.
   - Select Recursive to include all files and folders within a selected directory.
   - Click the Extensions button to open the Find Extensions dialog box, where you can specify the file extensions you want included in your scan for a particular file or folder.

Save site structure

You can save the customized site structure you’ve created in the Site-Specific Code Hints dialog box.

1. Create the structure of files and folders as you want it, adding and deleting files and folders as necessary.

2. Click the Save Structure button in the upper right-hand corner of the dialog box.

3. Specify a name for your site structure and click Save.

   *Note:* If the name you specify is already in use, Dreamweaver prompts you to enter a different name, or to confirm that you want to overwrite the structure with the same name. You cannot overwrite any of the default framework structures.
Rename site structures
When renaming your site structure, keep in mind that you cannot use the names of any of the three default site framework structures, or the word "custom".

1  Display the structure that you want to rename.
2  Click the Rename Structure icon button in the upper right-hand corner of the dialog box.
3  Specify a new name for the structure and click Rename.

*Note:* If the name you specify is already in use, Dreamweaver prompts you to enter a different name, or to confirm that you want to overwrite the structure with the same name. You cannot overwrite any of the default framework structures.

Add files or folders to a site structure
You can add any files or folders that are associated with your framework. After that, you can specify the file extensions of the files you want to scan. (See the next section.)

1  Click the plus (+) button above the Files window to open the Add File/Folder dialog box.
2  In the Add File/Folder text box, enter the path to the file or folder you want to add. You can also click the folder icon next to the text box to browse to a file or folder.
3  Click the plus (+) button above the Extensions window to specify the file extensions of files you want to scan.

*Note:* Specifying particular file extensions speeds up the scanning process.

4  Click Add.

Scan a site for file extensions
Use the Find Extensions dialog box to view and edit file extensions that are included in the site structure.

1  In the Site-Specific Code Hints dialog box, click the Extensions button.
   The Find Extensions dialog box lists the current scannable extensions.
2  To add another extension to the list, click the plus (+) button above the Extensions window.
3  To delete an extension from the list, click the minus (-) button.

Insert code with the Coding toolbar

1  Make sure you are in Code view (View > Code).
2  Position the insertion point in the code, or select a block of code.
3  Click a button in the Coding toolbar, or select an item from a pop-up menu in the toolbar.

To find out what each button does, position the pointer over it until a tooltip appears. The Coding toolbar displays the following buttons by default:

- **Open Documents** Lists the documents that are open. When you select one, it is displayed in the Document window.
- **Show Code Navigator** Displays the Code Navigator. For more information, see “Navigate to related code” on page 302.
- **Collapse Full Tag** Collapses the content between a set of opening and closing tags (for example, the content between `<table>` and `</table>`). You must place the insertion point in the opening or closing tag and then click the Collapse Full Tag button to collapse the tag.
Using Dreamweaver

Working with page code

You can also collapse the code outside a full tag by placing the insertion point in an opening or closing tag and Alt-clicking (Windows) or Option-clicking (Macintosh) the Collapse Full Tag button. Additionally, Control-clicking this button disables “smart collapse” so that Dreamweaver doesn’t adjust the content it collapses outside full tags. For more information, see “About collapsing code” on page 308.

**Collapse Selection** Collapses the selected code.

You can also collapse the code outside a selection by Alt-clicking (Windows) or Option-clicking (Macintosh) the Collapse Selection button. Additionally, Control-clicking this button disables “smart collapse” so that you can collapse exactly what you selected without any manipulation from Dreamweaver. For more information, see “About collapsing code” on page 308.

**Expand All** Restores all collapsed code.

**Select Parent Tag** Selects the content and surrounding opening and closing tags of the line in which you’ve placed the insertion point. If you repeatedly click this button, and your tags are balanced, Dreamweaver eventually selects the outermost `html` and `/html` tags.

**Balance Braces** Selects the content and surrounding parentheses, braces, or square brackets of the line in which you placed the insertion point. If you repeatedly click this button, and your surrounding symbols are balanced, Dreamweaver eventually selects the outermost braces, parentheses, or brackets in the document.

**Line Numbers** Lets you hide or show numbers at the beginning of each line of code.

**Highlight Invalid Code** Highlights invalid code in yellow.

**Syntax Error Alerts in Info Bar** Enables or disables an information bar at the top of the page that alerts you to syntax errors. When Dreamweaver detects a syntax error, the Syntax Error Information Bar specifies the line in the code where the error occurs. Additionally, Dreamweaver highlights the error’s line number on the left side of the document in Code view. The info bar is enabled by default, but only appears when Dreamweaver detects syntax errors in the page.

**Apply Comment** Lets you wrap comment tags around selected code, or open new comment tags.

- **Apply HTML Comment** wraps the selected code with `<!--` and `-->`, or opens a new tag if no code is selected.
- **Apply // Comment** inserts `//` at the beginning of each line of selected CSS or JavaScript code, or inserts a single `//` tag if no code is selected.
- **Apply /* */ wraps the selected CSS or JavaScript code with `/*` and `*/`.
- **Apply ‘ Comment** is for Visual Basic code. It inserts a single quotation mark at the beginning of each line of a Visual Basic script, or inserts a single quotation mark at the insertion point if no code is selected.
- **When you are working in a ASP, ASP.NET, JSP, PHP, or ColdFusion file and you select the Apply Server Comment option, Dreamweaver automatically detects the correct comment tag and applies it to your selection.**

**Remove Comment** Removes comment tags from the selected code. If a selection includes nested comments, only the outer comment tags are removed.

**Wrap Tag** Wraps selected code with the selected tag from the Quick Tag Editor.

**Recent Snippets** Lets you insert a recently used code snippet from the Snippets panel. For more information, see “Work with code snippets” on page 304.

**Move or Convert CSS** Lets you move CSS to another location, or convert inline CSS to CSS rules. For more information, see “Move/export CSS rules” on page 137 and “Convert inline CSS to a CSS rule” on page 138.

**Indent Code** Shifts the selection to the right.

**Outdent Code** Shifts the selection to the left.

Last updated 12/7/2011
Format Source Code  Applies previously specified code formats to selected code, or to the entire page if no code is selected. You can also quickly set code formatting preferences by selecting Code Formatting Settings from the Format Source Code button, or edit tag libraries by selecting Edit Tag Libraries.

The number of buttons available in the Coding toolbar varies depending on the size of the Code view in the Document window. To see all of the available buttons, resize the Code view window or click the expander arrow at the bottom of the Coding toolbar.

You can also edit the Coding toolbar to display more buttons (such as Word Wrap, Hidden Characters, and Auto Indent) or hide buttons that you don’t want to use. To do this, however, you must edit the XML file that generates the toolbar. For more information, see Extending Dreamweaver.

*Note:* The option to view hidden characters, which is not a default button in the Coding toolbar, is available from the View menu (View > Code View Options > Hidden Characters).

More Help topics

“Verify tags and braces are balanced” on page 311

“Coding toolbar overview” on page 11

“Display toolbars” on page 20

Insert code with the Insert panel

1  Position the insertion point in the code.
2  Select an appropriate category in the Insert panel.
3  Click a button in the Insert panel or select an item from a pop-up menu in the Insert panel.

When you click an icon, the code may appear in your page immediately, or a dialog box may appear requesting more information to complete the code.

To find out what each button does, position the pointer over it until a tooltip appears. The number and type of buttons available in the Insert panel varies depending on the current document type. It also depends on whether you’re using Code view or Design view.

Although the Insert panel provides a collection of frequently used tags, it is not comprehensive. To choose from a more comprehensive selection of tags, use the Tag Chooser.

More Help topics

“Use the Insert panel” on page 198

Insert tags with the Tag Chooser

Use the Tag Chooser to insert in your page any tag in the Dreamweaver tag libraries (which include ColdFusion and ASP.NET tag libraries).

1  Position the insertion point in the code, right-click (Windows) or Control-click (Macintosh), and select Insert Tag.

The Tag Chooser appears. The left pane contains a list of supported tag libraries, and the right pane shows the individual tags in the selected tag library folder.

2  Select a category of tags from the tag library, or expand the category and select a subcategory.
3  Select a tag from the right pane.
To view syntax and usage information for the tag in the Tag Chooser, click the Tag Info button. If available, information about the tag appears.

To view the same information about the tag in the Reference panel, click the <?> icon. If available, information about the tag appears.

To insert the selected tag into your code, click Insert.

If the tag appears in the right pane with angle brackets (for example, `<title></title>`), it doesn’t require additional information, and it’s immediately inserted into the document at the insertion point.

If the tag does require additional information, a tag editor appears.

If a tag editor opens, enter the additional information, and click OK.

Click the Close button.

More Help topics
“About Dreamweaver tag libraries” on page 328

Insert HTML comments
A comment is descriptive text that you insert in HTML code to explain the code or provide other information. The text of the comment appears only in Code view and is not displayed in a browser.

Insert a comment at the insertion point
❖ Select Insert > Comment.

In Code view, a comment tag is inserted and the insertion point is placed in the middle of the tag. Type your comment.

In Design view, the Comment dialog box appears. Enter the comment and click OK.

Display comment markers in Design view
❖ Select View > Visual Aids > Invisible Elements.

Make sure that the Comments option is selected in the Invisible Elements preferences or the comment marker does not appear.

Edit an existing comment
❖ In Code view, find the comment and edit its text.
❖ In Design view, select the Comment marker, edit the comment’s text in the Property inspector, and then click in the Document window.

Copy and paste code
1 Copy the code from Code view or from another application.
2 Place the insertion point in Code view, and select Edit > Paste.

More Help topics
“Paste and move collapsed code fragments” on page 309
**Edit tags with Tag editors**

Use Tag editors to view, specify, and edit the attributes of tags.

1. Right-click (Windows) or Control-click (Macintosh) a tag in Code view or an object in Design view, and select Edit Tag from the pop-up menu. (The contents of this dialog box change depending on the selected tag.)

2. Specify or edit attributes for the tag and click OK.

   *To get more information about the tag within the Tag editor, click Tag Info.*

**Edit code with the Coding context menu**

1. In Code view, select some code and right-click (Windows) or Control-click (Macintosh).

2. Select the Selection submenu, and select any of the following options:

   - **Collapse Selection** Collapses the selected code.
   - **Collapse Outside Selection** Collapses all of the code outside the selected code.
   - **Expand Selection** Expands the selected code fragment.
   - **Collapse Full Tag** Collapses the content between a set of opening and closing tags (for example, the content between `<table>` and `</table>`).
   - **Collapse Outside Full Tag** Collapses the content outside a set of opening and closing tags (for example, the content outside `<table>` and `</table>`).
   - **Expand All** Restores all collapsed code.
   - **Apply HTML Comment** Wraps the selected code with `<!--` and `-->`, or opens a new tag if no code is selected.
   - **Apply /* */ Comment** Wraps the selected CSS or JavaScript code with `/*` and `*/`.
   - **Apply // Comment** Inserts `//` at the beginning of each line of selected CSS or JavaScript code, or inserts a single `//` tag if no code is selected.
   - **Apply ' Comment** Inserts a single quotation mark at the beginning of each line of a Visual Basic script, or inserts a single quotation mark at the insertion point if no code is selected.
   - **Apply Server Comment** Wraps the selected code. When you are working in a ASP, ASP.NET, JSP, PHP, or ColdFusion file and you select the Apply Server Comment option, Dreamweaver automatically detects the correct comment tag and applies it to your selection.
   - **Apply Backslash-comment Hack** Wraps the selected CSS code with comment tags that will cause Internet Explorer 5 for Macintosh to ignore the code.
   - **Apply Caio Hack** Wraps the selected CSS code with comment tags that will cause Netscape Navigator 4 to ignore the code.
   - **Remove Comment** Removes comment tags from the selected code. If a selection includes nested comments, only the outer comment tags are removed.
   - **Remove Backslash-comment Hack** Removes comment tags from the selected CSS code. If a selection includes nested comments, only the outer comment tags are removed.
   - **Remove Caio Hack** Removes comment tags from the selected CSS code. If a selection includes nested comments, only the outer comment tags are removed.

   *Convert Tabs to Spaces* Converts each tab in the selection to a number of spaces equal to the Tab Size value set in Code Format preferences. For more information, see "Change the code format" on page 288.
CONVERT SPACES TO TABS  Converts runs of spaces in the selection to tabs. Each run of spaces that has a number of spaces equal to the tab size is converted to one tab.

**Indent**  Indents the selection, shifting it to the right. For more information, see “Indent code blocks” on page 301.

**Outdent**  Shifts the selection to the left.

**Remove All Tags**  Removes all the tags in the selection.

**Convert Lines To Table**  Wraps the selection in a *table* tag with no attributes.

**Add Line Breaks**  Adds a *br* tag at the end of each line of the selection.

**Convert To Uppercase**  Converts all letters in the selection (including tag and attribute names and values) to uppercase.

**Convert To Lowercase**  Converts all letters in the selection (including tag and attribute names and values) to lowercase.

**Convert Tags To Uppercase**  Converts all tag and attribute names and attribute values in the selection to uppercase.

**Convert Tags To Lowercase**  Converts all tag and attribute names and attribute values in the selection to lowercase.

**More Help topics**

“Collapse and expand code fragments” on page 308

**Edit a server-language tag with the Property inspector**

Edit the code in a server-language tag (such as an ASP tag) without entering Code view by using the code Property inspector.

1  In Design view, select the server-language tag visual icon.

2  In the Property inspector, click the Edit button.

3  Make changes to the tag code, and click OK.

**More Help topics**

“Set up your computer for application development” on page 511

**Indent code blocks**

As you write and edit code in Code view or the Code inspector, you can change the indentation level of a selected block or line of code, shifting it right or left by one tab.

**Indent the selected block of code**

- Press Tab.
- Select Edit > Indent Code.

**Unindent the selected block of code**

- Press Shift+Tab.
- Select Edit > Outdent Code.
Navigate to related code

The Code Navigator displays a list of code sources related to a particular selection on your page. Use it to navigate to related code sources, such as internal and external CSS rules, server-side includes, external JavaScript files, parent template files, library files, and iframe source files. When you click a link in the Code Navigator, Dreamweaver opens the file containing the relevant piece of code. The file appears in the related files area, if it is enabled. If you don’t have related files enabled, Dreamweaver opens the selected file as a separate document in the Document window.

If you click a CSS rule in the Code Navigator, Dreamweaver takes you directly to that rule. If the rule is internal to the file, Dreamweaver displays the rule in Split view. If the rule is in an external CSS file, Dreamweaver opens the file and displays the rule in the related files area above the main document.

You can access the Code Navigator from Design, Code, and Split views, as well as from the Code inspector.

For a video overview from the Dreamweaver engineering team about working with the Code Navigator, see www.adobe.com/go/dw10codenav.

For a video tutorial on working with Live View, related files, and the Code Navigator, see www.adobe.com/go/lrvid4044_dw.

Open the Code Navigator

❖ Alt+click (Windows) or Command+Option+Click (Macintosh) anywhere on the page. The Code Navigator displays links to the code affecting the area you clicked.

Click outside the Code Navigator to close it.

Note: You can also open the Code Navigator by clicking the Code Navigator indicator 🌟. This indicator appears near the insertion point on your page when the mouse has been idle for 2 seconds.

Navigate to code with the Code Navigator

1 Open the Code Navigator from the area of the page that you’re interested in.
2 Click the piece of code you want to go to.

The Code Navigator groups related code sources by file and lists the files alphabetically. For example, suppose that CSS rules in three external files affect the selection in your document. In this case, the Code Navigator lists those three files as well as the CSS rules relevant to the selection. For CSS related to a given selection, the Code Navigator functions like the CSS Styles panel in Current Mode.

💡 When you hover over links to CSS rules, the Code Navigator displays tool tips of the properties in the rule. These tool tips are useful when you want to distinguish between many rules that share the same name.

Disable the Code Navigator indicator

1 Open the Code Navigator.
2 Select Disable Indicator in the lower-right corner.
3 Click outside the Code Navigator to close it.

To re-enable the Code Navigator indicator, Alt+Click (Windows) or Command+Option+Click (Macintosh) to open the Code Navigator and deselect the Disable Indicator option.

More Help topics

“Open Related Files” on page 68
Code Navigator tutorial
Go to a JavaScript or VBScript function
In Code view and the Code inspector, you can view a list of all of the JavaScript or VBScript functions in your code and jump to any one of them.

1 View the document in Code view (View > Code) or the Code inspector (Window > Code Inspector).
2 Do one of the following:
   • In Code view, right-click (Windows) or Control-click (Macintosh) anywhere in Code view, and select the Functions submenu from the context menu.
      The Functions submenu does not appear in Design view.
Any JavaScript or VBScript functions in your code appear in the submenu.
To see the functions listed in alphabetical order, Control-right-click (Windows) or Option-Control-click (Macintosh) in Code view, and then select the Functions submenu.
   • In the Code inspector, click the Code Navigation button (||) on the toolbar.
3 Select a function name to jump to the function in your code.

Extract JavaScript
The JavaScript Extractor (JSE) removes all or most of the JavaScript from your Dreamweaver document, exports it to an external file, and links the external file to your document. The JSE can also remove event handlers such as onclick and onmouseover from your code and then unobtrusively attach the JavaScript associated with those handlers to your document.

You should be aware of the following limitations of the JavaScript Extractor before using it:
   • The JSE does not extract script tags in the body of the document (except in the case of Spry widgets). There is a chance that externalizing these scripts could cause unexpected results. By default, Dreamweaver lists these scripts in the Externalize JavaScript dialog box, but does not select them for extraction. (You can manually select them if you want.)
   • The JSE does not extract JavaScript from editable regions of .dwt (Dreamweaver template) files, non-editable regions of template instances, or Dreamweaver Library items.
   • After you extract JavaScript using the Externalize JavaScript and Attach Unobtrusively option, you can no longer edit Dreamweaver behaviors in the Behaviors panel. Dreamweaver cannot inspect and populate the Behaviors panel with behaviors that it has attached unobtrusively.
   • You cannot undo your changes once you close the page. You can, however, undo changes as long as you remain in the same editing session. Select Edit > Undo Externalize JavaScript to undo.
   • Some very complex pages might not work as expected. Use care when extracting JavaScript from pages with document.write() in the body and global variables.

For a video overview from the Dreamweaver engineering team about JavaScript support in Dreamweaver, see www.adobe.com/go/dw10javascript.

To use the JavaScript Extractor:
1 Open a page that contains JavaScript (for example, a Spry page).
2 Select Commands > Externalize JavaScript.
In the Externalize JavaScript dialog box, edit the default selections if necessary.

- Select Only Externalize JavaScript if you want Dreamweaver to move any JavaScript to an external file, and to reference that file in the current document. This option leaves event handlers such as `onclick` and `onload` in the document, and leaves Behaviors visible in the Behaviors panel.

- Select Externalize JavaScript and Attach Unobtrusively if you want Dreamweaver to 1) move JavaScript to an external file and reference it in the current document, and 2) remove event handlers from the HTML and insert them at runtime using JavaScript. When you select this option, you can no longer edit Behaviors in the Behaviors panel.

- In the Edit column, deselect any edits you do not want to make, or select edits that Dreamweaver did not select by default.

  By default, Dreamweaver lists but does not select the following edits:

  - Script blocks in the head of the document that contain `document.write()` or `document.writeln()` calls.
  - Script blocks in the head of the document that contain function signatures related to EOLAS handling code, which is known to use `document.write()`.
  - Script blocks in the body of the document, unless the blocks contain only Spry widget or Spry data set constructors.
  - Dreamweaver automatically assigns IDs to elements that don’t already have IDs. If you don’t like these IDs, you can change them by editing the ID text boxes.

4 Click OK.

The summary dialog provides a summary of extractions. Review the extractions and click OK.

5 Save the page.

Dreamweaver creates a SpryDOMUtils.js file, as well as another file that contains the extracted JavaScript. Dreamweaver saves the SpryDOMUtils.js file in a SpryAssets folder in your site, and saves the other file at the same level as the page from which you extracted the JavaScript. Don’t forget to upload both of these dependent files to your web server when you upload the original page.

More Help topics

“Building Spry pages visually” on page 407

Work with code snippets

Code snippets let you store content for quick reuse. You can create, insert, edit, or delete snippets of HTML, JavaScript, CFML, ASP, PHP, and more. You can also manage and share your code snippets with team members. Some predefined snippets that you can use as a starting point are available.

Snippets that contain `<font>` tags and other deprecated elements and attributes are in the Legacy folder in the Snippets panel.

Insert a code snippet

1 Place the insertion point where you want to insert the code snippet, or select code to wrap a snippet around.

2 In the Snippets panel (Window > Snippets), double-click the snippet.

You can also right-click (Windows) or Control-click (Macintosh) the snippet, and then select Insert from the pop-up menu.
Create a code snippet
1 In the Snippets panel, click the New Snippet icon at the bottom of the panel.
2 Enter a name for the snippet.

Note: Snippet names can't contain characters that are invalid in filenames, such as slashes (/ or \), special characters, or double quotes (").

3 (Optional) Enter a text description of the snippet. This makes it easier for other team members to use the snippet.
4 For Snippet Type, select Wrap Selection or Insert Block.
   a If you chose Wrap Selection, add code for the following options:
      Insert Before Type or paste the code to insert before the current selection.
      Insert After Type or paste the code to insert after the current selection.
      To set default spacing for the blocks, use line breaks; press Enter (Windows) or Return (Macintosh) inside the text boxes.
      Note: Because snippets can be created as start and end blocks, you can use them to surround other tags and content. This is useful for inserting special formatting, links, navigation elements, and script blocks. Simply highlight the content you want to surround, then insert the snippet.
   b If you chose Insert Block, type or paste the code to insert.
5 (Optional) Select a Preview Type: Code or Design.
   Design Renders the code and displays it in the Preview pane of the Snippets panel.
   Code Displays the code in the Preview pane.
6 Click OK.

Edit or delete a code snippet
❖ In the Snippets panel, select a snippet, and click the Edit Snippet button or the Remove button at the bottom of the panel.

Create code snippet folders and manage code snippets
1 In the Snippets panel, click the New Snippet Folder button at the bottom of the panel.
2 Drag snippets to the new folder or other folders, as desired.

Add or edit a keyboard shortcut for a snippet
1 In the Snippets panel, right-click (Windows) or Control-click (Macintosh) and select Edit Keyboard Shortcuts.
The Keyboard Shortcuts Editor appears.
2 In the Commands pop-up menu, select Snippets.
   A list of snippets appears.
3 Select a snippet and assign a keyboard shortcut to it.
   For more information, see “Customize keyboard shortcuts” on page 32.

Share a snippet with other members of your team
1 Find the file corresponding to the snippet that you want to share in the Configuration/Snippets folder in the Dreamweaver application folder.
Copy the snippet file to a shared folder on your computer or a network computer.

Have the other members of the team copy the snippet file to their Configuration/Snippets folder.

**Search for tags, attributes, or text in code**

You can search for specific tags, attributes, and attribute values. For example, you can search for all `img` tags that have no `alt` attribute.

You can also search for specific text strings that are within or not within a set of container tags. For example, you can search for the word `Untitled` contained in a `title` tag to find all the untitled pages on your site.

1. Open the document to search in, or select documents or a folder in the Files panel.
2. Select `Edit > Find And Replace`.
3. Specify which files to search in, and then specify the kind of search to perform, and text or tags to search for. Optionally, specify replacement text as well. Then click one of the Find buttons or one of the Replace buttons.
4. Click the Close button.
5. To search again without displaying the Find And Replace dialog box, press F3 (Windows) or Command+G (Macintosh).

**More Help topics**

“Regular expressions” on page 283

“Search for and replace text” on page 213

**Save and recall search patterns**

You can save search patterns and reuse them later.

**More Help topics**

“Regular expressions” on page 283

“Search for and replace text” on page 213

**Save a search pattern**

1. In the Find And Replace dialog box (`Edit > Find And Replace`), set the parameters for the search.
2. Click the Save Query button (the disk icon).
3. In the dialog box that appears, navigate to the folder where you want to save queries. Then type a filename that identifies the query, and click Save.

For example, if the search pattern involves looking for `img` tags with no `alt` attribute, you might name the query `img_no_alt.dwr`.

**Note:** Saved queries have the filename extension `.dwr`. Some saved queries from older versions of Dreamweaver may have the extension `.dwq`.

**Recall a search pattern**

1. Select `Edit > Find And Replace`.
2. Click the Load Query button (the folder icon).
Navigate to the folder where your queries are saved. Then select a query file and click Open.

Click Find Next, Find All, Replace, or Replace All to initiate the search.

**Use language-reference material**

The Reference panel provides you with a quick reference tool for markup languages, programming languages, and CSS styles. It provides information on the specific tags, objects, and styles that you are working with in Code view (or the Code inspector). The Reference panel also provides example code that you can paste into your documents.

**Open the Reference panel**

1. Do one of the following in Code view:
   - Right-click (Windows) or Control-click (Macintosh) a tag, attribute, or keyword, and then select Reference from the context menu.
   - Place the insertion point in a tag, attribute, or keyword, and then press Shift+F1.

   The Reference panel opens and displays information about the tag, attribute, or keyword you clicked.

2. To adjust the text size in the Reference panel, select Large Font, Medium Font, or Small Font from the options menu (the small arrow at the upper right of the panel).

**Paste example code into your document**

1. Click anywhere in example code in the reference content.

   The entire code example is highlighted.

2. Select Edit > Copy, and then paste the example code into your document in Code view.

**Browse the reference content in the Reference panel**

1. To display tags, objects, or styles from another book, select a different book from the Book pop-up menu.

2. To view information about a specific item, select it from the Tag, Object, Style, or CFML pop-up menu (depending on which book you selected).

3. To view information about an attribute of the selected item, select the attribute from the pop-up menu next to the Tag, Object, Style, or CFML pop-up menu.

   This menu contains the list of attributes for the item you select. The default selection is Description, which displays a description of the chosen item.

**Print code**

You can print your code to edit it offline, archive it, or distribute it.

1. Open a page in Code view.

2. Select File > Print Code.
Collapsing code

About collapsing code

You can collapse and expand code fragments so that you can view different sections of your document without having to use the scroll bar. For example, to see all of the CSS rules in the `<head>` tag that apply to a `<div>` tag farther down the page, you can collapse everything between the `<head>` tag and the `<div>` tag so that you can see both sections of code at once. Although you can select code fragments by making selections in Design view or Code view, you can collapse code only in Code view.

*Note:* Files created from Dreamweaver templates display all code as fully expanded, even if the template file (.dwt) contains collapsed code fragments.

More Help topics

“Paste and move collapsed code fragments” on page 309

“Insert code with the Coding toolbar” on page 296

“Clean up code” on page 310

Collapse and expand code fragments

When you select code, a set of collapse buttons is displayed next to the selection (Minus symbols in Windows; vertical triangles on the Macintosh). Click the buttons to collapse and expand the selection. When the code is collapsed, the collapse buttons change to an expand button (a Plus button in Windows; a horizontal triangle on the Macintosh).

Sometimes, the exact fragment of code that you selected is not collapsed. Dreamweaver uses “smart collapse” to collapse the most common and visually pleasing selection. For example, if you selected an indented tag and then selected the indented spaces before the tag as well, Dreamweaver would not collapse the indented spaces, because most users would expect their indentations to be preserved. To disable smart collapse and force Dreamweaver to collapse exactly what you selected, hold down the Control key before collapsing your code.

Also, a warning icon on collapsed code fragments is displayed if a fragment contains errors or code that is unsupported by certain browsers.

1 Select some code.
2 Select Edit > Code Collapse, and select any of options.

More Help topics

“Edit code with the Coding context menu” on page 300

“Insert code with the Coding toolbar” on page 296

Select a collapsed code fragment

❖ In Code view, click the collapsed code fragment.
Note: When you make a selection in Design view that is part of a collapsed code fragment, the fragment is automatically expanded in Code view. When you make a selection in Design view that is a complete code fragment, the fragment remains collapsed in Code view.

View the code in a collapsed code fragment without expanding it
❖ Hold the mouse pointer over the collapsed code fragment.

Use keyboard shortcuts to collapse and expand code
❖ You can also use the following keyboard shortcuts:

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Macintosh</th>
</tr>
</thead>
<tbody>
<tr>
<td>Collapse Selection</td>
<td>Control+Shift+C</td>
<td>Command+Shift+C</td>
</tr>
<tr>
<td>Collapse Outside Selection</td>
<td>Control+Alt+C</td>
<td>Command+Alt+C</td>
</tr>
<tr>
<td>Expand Selection</td>
<td>Control+Shift+E</td>
<td>Command+Shift+E</td>
</tr>
<tr>
<td>Collapse Full Tag</td>
<td>Control+Shift+J</td>
<td>Command+Shift+J</td>
</tr>
<tr>
<td>Collapse Outside Full Tag</td>
<td>Control+Alt+J</td>
<td>Command+Alt+J</td>
</tr>
<tr>
<td>Expand All</td>
<td>Control+Alt+E</td>
<td>Command+Alt+E</td>
</tr>
</tbody>
</table>

Paste and move collapsed code fragments
You can copy and paste collapsed code fragments, or move collapsed code fragments by dragging.

More Help topics
“Insert code with the Coding toolbar” on page 296
“Clean up code” on page 310

Copy and paste a collapsed code fragment
1 Select the collapsed code fragment.
2 Select Edit > Copy.
3 Place the insertion point where you want to paste the code.
4 Select Edit > Paste.

Note: You can paste into other applications, but the collapsed state of the code fragment is not preserved.

Drag a collapsed code fragment
1 Select the collapsed code fragment.
2 Drag the selection to the new location.

To drag a copy of the selection, Control-drag (Windows) or Alt-drag (Macintosh).

Note: You cannot drag to other documents.
Optimizing and debugging code

Clean up code
You can automatically remove empty tags, combine nested font tags, and otherwise improve messy or unreadable HTML or XHTML code.

For information on how to clean up HTML generated from a Microsoft Word document, see “Open and edit existing documents” on page 67.

1 Open a document:
   • If the document is in HTML, select Commands > Clean Up HTML.
   • If the document is in XHTML, select Commands > Clean Up XHTML.

For an XHTML document, the Clean Up XHTML command fixes XHTML syntax errors, sets the case of tag attributes to lowercase, and adds or reports the missing required attributes for a tag in addition to performing the HTML cleanup operations.

2 In the dialog box that appears, select any of the options, and click OK.

Note: Depending on the size of your document and the number of options selected, it may take several seconds to complete the cleanup.

Remove Empty Container Tags  Removes any tags that have no content between them. For example, <b></b> and <font color="#FF0000"></font> are empty tags, but the <b> tag in <b>some text</b> is not.

Remove Redundant Nested Tags  Removes all redundant instances of a tag. For example, in the code <b>This is what I really wanted to say</b>, the b tags surrounding the word really are redundant and would be removed.

Remove Non-Dreamweaver HTML Comments  Removes all comments that were not inserted by Dreamweaver. For example, <!--begin body text--> would be removed, but <!--TemplateBeginEditable name="doctitle"--> wouldn’t, because it’s a Dreamweaver comment that marks the beginning of an editable region in a template.

Remove Dreamweaver Special Markup  Removes comments that Dreamweaver adds to code to allow documents to be automatically updated when templates and library items are updated. If you select this option when cleaning up code in a template-based document, the document is detached from the template. For more information, see “Detach a document from a template” on page 401.

Remove Specific Tag(s)  Removes the tags specified in the adjacent text box. Use this option to remove custom tags inserted by other visual editors and other tags that you don’t want to appear on your site (for example, blink). Separate multiple tags with commas (for example, font,blink).

Combine Nested <font> Tags When Possible  Consolidates two or more font tags when they control the same range of text. For example, <font size="7" color="#FF0000">big red</font> would be changed to <font size="7" color="#FF0000">big red</font>.

Show Log On Completion  Displays an alert box with details about the changes made to the document as soon as the cleanup is finished.
Verify tags and braces are balanced
You can check to make sure the tags, parentheses (( ))), braces ({}), and square brackets ([ ])) in your page are balanced. Balanced means that every opening tag, parenthesis, brace, or bracket has a corresponding closing one, and vice versa.

Check for balanced tags
1. Open the document in Code view.
2. Place the insertion point in the nested code you want to check.

The enclosing matching tags (and their contents) are selected in your code. If you keep selecting Edit > Select Parent Tag, and your tags are balanced, eventually Dreamweaver will select the outermost html and /html tags.

Check for balanced parentheses, braces, or square brackets
1. Open the document in Code view.
2. Place the insertion point in the code you want to check.

All of the code between the enclosing parentheses, braces, or square brackets is selected. Choosing Edit > Balance Braces again selects all of the code inside the parentheses, braces, or square brackets that enclose the new selection.

Check for browser compatibility
The Browser Compatibility Check (BCC) feature helps you locate combinations of HTML and CSS that can trigger browser rendering bugs. This feature also tests the code in your documents for any CSS properties or values that are unsupported by your target browsers.

Note: This feature replaces the former Target Browser Check feature, but retains the CSS functionality of that feature.

More Help topics
“Check for cross-browser CSS rendering issues” on page 142

Validate XML documents
You can set preferences for the Validator, the specific problems that the Validator should check for, and the types of errors that the Validator should report.

1. Do one of the following:
   • For an XML or XHTML file, select File > Validate > As XML.
   • The Validation tab of the Results panel displays a “No errors or warnings” message or lists the syntax errors it found.

2. Double-click an error message to highlight the error in the document.
3. To save the report as an XML file, click the Save Report button.
To view the report in your primary browser (which lets you print the report), click the Browse Report button.

**Validate documents using W3C validator (CS5.5)**

Dreamweaver CS5.5 and later helps you create standards-compliant web pages with its in-built support for the W3C validator. The W3C validator validates your HTML documents for conformance to HTML or XHTML standards. You can validate both open documents, and files posted on a live server.

Use the report that is generated after validation to fix errors in your file.

*Note: The W3C validator feature is available in Dreamweaver CS5.5 and later only. The previous version of the feature, available in Dreamweaver CS4, was deprecated for Dreamweaver CS5. See the [Dreamweaver CS4 documentation](#) for more information about the previous version of the feature.*

**Validate an open document**

1. Select Window > Results > W3C validation.
2. Select File > Validate > Validate Current Document (W3C).

**Validate a live document**

For live documents, Dreamweaver validates code received by the browser. This code is displayed when you right-click in your browser, and choose the option to view the source code. Validating live documents is especially useful when validating dynamic pages using PHP, JSP, and so on.

The Validate Live Document option is enabled only when the URL of the page being validated begins with `http`.

1. Select Window > Results > W3C validation.
2. Click Live View.

For live documents, when you double-click an error in the W3C validation panel, a separate window opens. The window displays the browser-generated code, and the line with the error is highlighted.

**Customize validation settings**

1. Select Window > Results > W3C validation.
2. In the W3C Validation panel, click the W3C Validation (Play) icon. Select Settings.
3. Select a DOCTYPE for validation if a DOCTYPE has not been explicitly specified for the document.
4. If you do not want errors and warnings displayed, clear the options.
5. Click Manage if you want to delete any warnings or errors that you have hidden using the W3C Validation panel.
   When you remove warnings and errors, they are not displayed when you select Show All in the W3C validation panel.
6. Select Don’t Show W3C Validator Notification Dialog if you do not want the W3C Validator Notification dialog displayed when you begin validation.

**Working with validation reports**

After validation is complete, the validation reports are displayed in the W3C Validation panel.

- For more information on the error or warning, select the error/warning in the W3C Validation panel. Click More Info.
- To save the report as an XML file, click Save Report.
• To view the entire report in HTML, click Browse Report. The HTML report provides the complete list of errors and warnings along with a summary.

• To jump to the location in the code containing the error, select the error in the W3C Validation panel. Click the Options button, and select Go to Line.

• To hide errors/warnings, select the error/warning. Click the Options button, and select Hide Error.

• To view all the errors and warnings, including the hidden errors, click the Options button. Select Show All. Any hidden errors and warnings you deleted in the Preferences dialog are not listed.

• To clear all the results in the W3C validation panel, click the Options button. Select Clear Results.

Set Validator preferences

The Validate tags feature has been deprecated as of Dreamweaver CS5. However, Dreamweaver still supports external code validators that you install as extensions. When you install an external validator extension, Dreamweaver lists its preferences in the Validator category of the Preferences dialog box.

1 Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).

2 Select Validator from the Category list on the left.

3 Select tag libraries to validate against.

You can’t select multiple versions of the same tag library or language; for example, if you select HTML 4.0, you can’t also select HTML 3.2 or HTML 2.0. Select the earliest version you want to validate against; for example, if a document contains valid HTML 2.0 code, it will also be valid HTML 4.0 code.

4 Click Options, and set options for those libraries.

5 Select Display options for the types of errors and warnings that you want the Validator report to include.

6 Select items the Validator should check for:

   Quotes In Text Indicates that Dreamweaver should warn you about each use of quotation marks in the text of the document; you should use the &quot; entity instead of quotation marks in the text of HTML documents.

   Entities In Text Indicates that Dreamweaver should recommend changing certain characters (such as ampersand (&), less-than (<), and greater-than (>)) to their HTML entity equivalents.

7 Click OK to close the Validator Options dialog box, and click OK again to set the preferences.

Make pages XHTML-compliant

When you create a page, you can make it XHTML-compliant. You can also make an existing HTML document XHTML-compliant.

More Help topics

“XHTML code” on page 282

Create XHTML-compliant documents

1 Select File > New.

2 Select a category and type of page to create.

3 Select one of the XHTML document type definitions (DTD) from the DocType pop-up menu on the far right of the dialog box, and click Create.
For example, you can make an HTML document XHTML-compliant by selecting XHTML 1.0 Transitional or XHTML 1.0 Strict from the pop-up menu.

*Note: Not all document types can be made XHTML-compliant.*

### Create XHTML-compliant documents by default

1. Select Edit > Preferences or Dreamweaver > Preferences (Mac OS X), and select the New Document category.
2. Select a default document and select one of the XHTML document type definitions from the Default Document Type (DTD) pop-up menu, and click OK.

For example, you can make an HTML document XHTML-compliant by selecting XHTML 1.0 Transitional or XHTML 1.0 Strict from the pop-up menu.

### Make an existing HTML document XHTML-compliant

1. Open a document, and do one of the following:
   - For a document without frames, select File > Convert, and then select one of the XHTML document type definitions.
   - For a document with frames, select a frame and select File > Convert, and then select one of the XHTML document type definitions.

2. To convert the whole document, repeat this step for every frame and the frameset document.

*Note: You can't convert an instance of a template, because it must be in the same language as the template on which it's based. For example, a document based on an XHTML template will always be in XHTML, and a document based on a non-XHTML-compliant HTML template will always be HTML and can't be converted to XHTML or any other language.*

### Use the ColdFusion debugger (Windows only)

If you're a ColdFusion developer using ColdFusion as your Dreamweaver testing server, you can view ColdFusion debugging information without leaving Dreamweaver.

*Note: This feature is not supported on the Macintosh. Macintosh developers can use Preview In Browser (F12) to open a ColdFusion page in a separate browser. If the page contains errors, information about the possible causes for the errors appears at the bottom of the page.*

If you're running ColdFusion MX 6.1 or earlier, make sure debugging settings are enabled in the ColdFusion Administrator before you begin debugging. If you're running ColdFusion MX 7 or later, Dreamweaver enables the settings for you.

Also, make sure your Dreamweaver testing server is running ColdFusion. For more information, see “Set up a testing server” on page 45.

💡 To ensure the debug information is refreshed every time a page is displayed in the internal browser, make sure Internet Explorer checks for newer versions of the file every time the file is requested. In Internet Explorer, select Tools > Internet Options, select the General tab, and click the Settings button in the Temporary Internet Files area. In the Settings dialog box, select the Every Visit to Page option.

1. Open the ColdFusion page in Dreamweaver.
2. Click the Server Debug icon on the Document toolbar.
Dreamweaver requests the page from the ColdFusion server and displays it in an internal Internet Explorer browser window. If the page contains errors, possible causes for the errors appear at the bottom of the page.

At the same time, a Server Debug panel opens. The panel provides a large amount of useful information, such as all the pages the server processed to render the page, all the SQL queries executed on the page, and all the server variables and their values, if any. The panel also provides a summary of execution times.

3 If an Exceptions category appears in the Server Debug panel, click the Plus (+) icon to expand the category. The Exceptions category appears if the server encountered a problem or problems with the page. Expand the category to find out more about the problem.

4 Switch back to Code view (View > Code) or Design view (View > Design) and fix the error.

5 Save the file and click the Server Debug icon again. Dreamweaver renders the page in the internal browser again and updates the Server Debug panel. If there are no more problems with the page, the Exceptions category does not reappear in the panel.

6 To leave debug mode, switch to Code view (View > Code) or Design view (View > Design).

More Help topics
“Using ColdFusion components” on page 623

Editing code in Design view

About editing code in Design view
Dreamweaver lets you visually create and edit web pages without worrying about the underlying source code, but there are times when you might need to edit the code for greater control or to troubleshoot your web page. Dreamweaver lets you edit some code while working in Design view.

This section is designed for people who prefer to work in Design view, but who also want quick access to the code.

Selecting child tags in Design view
If you select an object in Design view that contains child tags—for example, an HTML table—you can quickly select the first child tag of that object by selecting Edit > Select Child.

Note: This command is only enabled in Design view.

For example, the <table> tag normally has <tr> child tags. If you select a <table> tag in the tag selector, you can select the first row in the table by selecting Edit > Select Child. Dreamweaver selects the first <tr> tag in the tag selector. Since the <tr> tag itself has child tags, namely <td> tags, selecting Edit > Select Child again selects the first cell in the table.

Edit code with the Property inspector
You can use the Property inspector to inspect and edit the attributes of text or of objects on your page. The properties shown in the Property inspector generally correspond to attributes of tags; changing a property in the Property inspector generally has the same effect as changing the corresponding attribute in Code view.
Note: The Tag inspector and the Property inspector both let you view and edit a tag's attributes. The Tag inspector lets you to view and edit every attribute associated with a given tag. The Property inspector shows only the most common attributes, but provides a richer set of controls for changing those attributes' values, and lets you edit certain objects (such as table columns) that don't correspond to specific tags.

1 Click in the text or select an object on the page.

The Property inspector for the text or object appears below the Document window. If the Property inspector is not visible, select Window > Properties.

2 Make changes to the attributes in the Property inspector.

Edit CFML with the Property inspector

Use the Property inspector to inspect and modify ColdFusion markup in Design view.

1 In the Property inspector, click the Attributes button to edit the tag's attributes or to add new ones.
2 If the tag holds content between its opening and closing tags, click the Content button to edit the content.

The Content button appears only if the selected tag is not an empty tag (that is, if it has both an opening and a closing tag).

3 If the tag contains a conditional expression, make changes to it in the Expression box.

Change attributes with the Tag inspector

Use the Tag inspector to edit or add attributes and attributes' values. The Tag inspector lets you edit tags and objects by using a property sheet similar to the ones found in other integrated development environments (IDEs).

1 Do one of the following in the Document window:
   • In Code view (or the Code inspector), click anywhere in a tag's name or in its contents.
   • In Design view, select an object, or select a tag in the Tag Selector.

2 Open the Tag inspector (Window > Tag Inspector), and select the Attributes tab.

The selection's attributes and their current values appear in the Tag inspector.

3 Do any of the following in the Tag inspector:
   • To view the attributes organized by category, click the Show Category View button
   • To view the attributes in an alphabetical list, click the Show List View button.
   • To change the attribute's value, select the value and edit it.
   • To add a value for an attribute with no value, click in the attribute-value column to the right of the attribute and add a value.
   • If the attribute takes pre-defined values, select a value from the pop-up menu (or the color picker) to the right of the attribute-value column.
   • If the attribute takes a URL value, click the Browse button or use the Point-To-File icon to select a file, or type the URL in the box.
   • If the attribute takes a value from a source of dynamic content (such as a database), click the Dynamic Data button to the right of the attribute-value column. Then select a source.
   • To delete the attribute's value, select the value and press Backspace (Windows) or Delete (Macintosh).
   • To change the name of an attribute, select the attribute name and edit it.
Note: If you change the name of a standard attribute and then add a value for that attribute, the attribute and its new value move to the appropriate category.

- To add a new attribute not already listed, click in the empty space below the last listed attribute name and type a new attribute name.

4 Press Enter (Windows) or Return (Macintosh), or click elsewhere in the Tag inspector, to update the tag in your document.

More Help topics
“Using JavaScript behaviors (general instructions)” on page 333
“Defining sources of dynamic content” on page 543

Quick Tag Editor overview
You use the Quick Tag Editor to quickly inspect, insert, and edit HTML tags without leaving Design view.

If you type invalid HTML in the Quick Tag Editor, Dreamweaver attempts to correct it for you by inserting closing quotation marks and closing angle brackets where needed.

To set the Quick Tag Editor options, open the Quick Tag Editor by pressing Control-T (Windows) or Command-T (Macintosh).

The Quick Tag Editor has three modes:
- Insert HTML mode is used to insert new HTML code.
- Edit Tag mode is used to edit an existing tag.
- Wrap Tag mode is to wrap a new tag around the current selection.

Note: The mode in which the Quick Tag Editor opens depends on the current selection in Design view.

In all three modes, the basic procedure for using the Quick Tag Editor is the same: open the editor, enter or edit tags and attributes, and then close the editor.

You can cycle through the modes by pressing Control+T (Windows) or Command+T (Macintosh) while the Quick Tag Editor is active.

More Help topics
“Use the hints menu in the Quick Tag Editor” on page 318

Edit code with the Quick Tag Editor
Use the Quick Tag Editor to quickly insert and edit HTML tags without leaving Design view.

More Help topics
“Write and edit scripts in Design view” on page 320

Insert an HTML tag
1 In Design view, click in the page to place the insertion point where you want to insert code.

2 Press Control+T (Windows) or Command+T (Macintosh).
The Quick Tag Editor opens in Insert HTML mode.

3. Enter the HTML tag and press Enter.
   The tag is inserted into your code, along with a matching closing tag if applicable.

4. Press Escape to exit without making any changes.

**Edit an HTML tag**

1. Select an object in Design view.
   You can also select the tag you want to edit from the tag selector at the bottom of the Document window. For more information, see “Edit code with the tag selector” on page 319.

2. Press Control+T (Windows) or Command+T (Macintosh).
   The Quick Tag Editor opens in Edit Tag mode.

3. Enter new attributes, edit existing attributes, or edit the tag’s name.

4. Press Tab to move forward from one attribute to the next; press Shift+Tab to move back.
   **Note:** By default, changes are applied to the document when you press Tab or Shift+Tab.

5. To close the Quick Tag Editor and apply all the changes, press Enter.

6. To exit without making any further changes, press Escape.

**Wrap the current selection with HTML tags**

1. Select unformatted text or an object in Design view.
   **Note:** If you select text or an object that includes an opening or closing HTML tag, the Quick Tag Editor opens in Edit Tag mode instead of Wrap Tag mode.

2. Press Control+T (Windows) or Command+T (Macintosh), or click the Quick Tag Editor button in the Property inspector.
   The Quick Tag Editor opens in Wrap Tag mode.

3. Enter a single opening tag, such as `strong`, and press Enter (Windows) or Return (Macintosh).
   The tag is inserted at the beginning of the current selection, and a matching closing tag is inserted at the end.

4. To exit without making any changes, press Escape.

**Use the hints menu in the Quick Tag Editor**

The Quick Tag Editor includes an attributes hint menu that lists all the valid attributes of the tag you are editing or inserting.

You can also disable the hints menu or adjust the delay before the menu pops up in the Quick Tag Editor.

To see a hints menu that lists valid attributes for a tag, pause briefly while editing an attribute name in the Quick Tag Editor. A hints menu appears, listing all the valid attributes for the tag you’re editing.
Similarly, to see a hints menu listing valid tag names, pause briefly while entering or editing a tag name in the Quick Tag Editor.

*Note:* The Quick Tag Editor code hints preferences are controlled by the normal code hints preferences. For more information, see “Set code hints preferences” on page 294.

**More Help topics**

“Quick Tag Editor overview” on page 317

**Use a hints menu**

1. Do one of the following:
   - Begin to type a tag or attribute name. The selection in the Code Hints menu jumps to the first item that starts with the letters you typed.
   - Use the Up and Down Arrow keys to select an item.
   - Use the scroll bar to find an item.
2. Press Enter to insert the selected item, or double-click an item to insert it.
3. To close the hints menu without inserting an item, press Escape or continue typing.

**Disable the hints menu or change the delay before it appears**

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh) and select Code Hints. The Code Hints Preferences dialog box appears.
2. To disable the hints menu, deselect the Enable Code Hints option.
3. To change the delay before the menu appears, adjust the Delay slider, and click OK.

**Edit code with the tag selector**

You can use the tag selector to select, edit, or remove tags without leaving Design view. The tag selector is located in the status bar at the bottom of the Document window and shows a series of tags, as follows:

`<body> <form> <table> <tr>`

**Edit or delete a tag**

1. Click in the document.

   The tags that apply at the insertion point appear in the tag selector.

2. Right-click (Windows) or Control-click (Macintosh) a tag in the tag selector.
3. To edit a tag, select Edit Tag from the menu. Make your changes in the Quick Tag Editor. For more information, see “Edit code with the Quick Tag Editor” on page 317.
4. To delete a tag, select Remove Tag from the menu.

**Select an object corresponding to a tag**

1. Click in the document.

   The tags that apply at the insertion point appear in the tag selector.

2. Click a tag in the tag selector.
The object represented by the tag is selected on the page.

*Use this technique to select individual table rows (*tr* tags) or cells (*td* tags).*

### Write and edit scripts in Design view

You can work with client-side JavaScripts and VBScripts in both Code and Design views, in the following ways:

- Write a JavaScript or VBScript script for your page without leaving Design view.
- Create a link in your document to an external script file without leaving Design view.
- Edit a script without leaving Design view.

  Before starting, select View > Visual Aids > Invisible Elements to ensure that script markers appear on the page.

#### Write a client-side script

1. Place the insertion point where you want the script.
2. Select Insert > HTML > Script Objects > Script.
3. Select the scripting language from the Language pop-up menu.
4. Type or paste your script code into the Content box.

   You don’t need to include the opening and closing *script* tags.
5. Type or paste HTML code into the No Script box. Browsers that don’t support the chosen scripting language display this code instead of running the script.
6. Click OK.

#### Link to an external script file

1. Place the insertion point where you want the script.
2. Select Insert > HTML > Script Objects > Script.
3. Click OK without typing anything in the Content box.
5. In the Property inspector, click the folder icon and browse to and select the external script file, or type the filename in the Source box.

#### Edit a script

1. Select the script marker.
2. In the Property inspector, click the Edit button.

   The script appears in the Script Properties dialog box.

   If you linked to an external script file, the file opens in Code view, where you can make your edits.

   **Note:** If there is code between the script tags, the Script Properties dialog box opens even if there is also a link to an external script file.

3. In the Language box, specify either JavaScript or VBScript as the language of the script.
4. In the Type pop-up menu, specify the type of script, either client-side or server-side.
5 (Optional) In the Source box, specify an externally linked script file. Click the folder icon or the Browse button to select a file, or type the path.

6 Edit the script, and click OK.

**Edit ASP server-side scripts in Design view**

Use the ASP script Property inspector to inspect and modify ASP server-side scripts in Design view.

1 In Design view, select the server-language tag visual icon.

2 In the ASP script Property inspector, click the Edit button.

3 Edit the ASP server-side script, and click OK.

**Edit scripts on the page by using the Property inspector**

1 In the Property inspector, select the scripting language from the Language pop-up menu, or type a language name in the Language box.

   *Note: If you are using JavaScript and are unsure of the version, select JavaScript rather than JavaScript1.1 or JavaScript1.2.*

2 In the Type pop-up menu, specify the type of script, either client-side or server-side.

3 (Optional) In the Source box, specify an externally linked script file. Click the folder icon to select the file, or type the path.

4 Click Edit to modify the script.

**More Help topics**

“Write and edit scripts in Design view” on page 320

**Using JavaScript behaviors**

You can easily attach JavaScript (client-side) behaviors to page elements by using the Behaviors tab of the Tag inspector. For more information, see “Applying built-in JavaScript behaviors” on page 336.

**Working with head content for pages**

Pages contain elements that describe the information on the page, which is used by search browsers. You can set the properties of `head` elements to control how your pages are identified.

**View and edit head content**

You can view the elements in the `head` section of a document by using the View menu, the Document window’s Code view, or the Code inspector.

**View elements in the head section of a document**

- Select View > Head Content. For each element of the `head` content, a marker appears at the top of the Document window in Design view.

   *Note: If your Document window is set to show only Code view, View > Head Content is dimmed.*
Insert an element into the head section of a document
1 Select an item from the Insert > HTML > Head Tags submenu.
2 Enter options for the element in the dialog box that appears, or in the Property inspector.

Edit an element in the head section of a document
1 Select View > Head Content.
2 Click one of the icons in the head section to select it.
3 Set or modify the properties of the element in the Property inspector.

Set the meta properties for the page
A meta tag is a head element that records information about the current page, such as the character encoding, author, copyright, or keywords. These tags can also be used to give information to the server, such as the expiration date, refresh interval, and POWDER rating for the page. (POWDER, the Protocol for Web Description Resources, provides a method for assigning ratings, such as movie ratings, to web pages.)

Add a meta tag
1 Select Insert > HTML > Head Tags > Meta.
2 Specify the properties in the dialog box that appears.

Edit an existing meta tag
1 Select View > Head Content.
2 Select the Meta marker that appears at the top of the Document window.
3 Specify the properties in the Property inspector.

Meta tag properties
❖ Set the meta tag properties as follows:

Attribute specifies whether the meta tag contains descriptive information about the page (name) or HTTP header information (http-equiv).

Value specifies the type of information you’re supplying in this tag. Some values, such as description, keywords, and refresh, are already well defined (and have their own individual Property inspectors in Dreamweaver), but you can specify practically any value (for example, creationdate, documentID, or level).

Content specifies the actual information. For example, if you specified level for Value, you might specify beginner, intermediate, or advanced for Content.

Set the page title
There is only one title property: the title of the page. The title appears in the title bar of the Document window in Dreamweaver as well as in the browser’s title bar when you view the page in most browsers. The title also appears in the Document window toolbar.

Specify the title in the Document window
❖ Enter the title in the Title text box in the Document window toolbar.
**Specify the title in the head content**
1. Select View > Head Content.
2. Select the Title marker that appears at the top of the Document window.
3. Specify the page title in the Property inspector.

**Specify keywords for the page**
Many search-engine robots (programs that automatically browse the web gathering information for search engines to index) read the contents of the Keywords `meta` tag and use the information to index your pages in their databases. Because some search engines limit the number of keywords or characters they index, or ignore all keywords if you go beyond the limit, it’s a good idea to use just a few well-chosen keywords.

**Add a Keywords meta tag**
1. Select Insert > HTML > Head Tags > Keywords.
2. Specify the keywords, separated by commas, in the dialog box that appears.

**Edit a Keywords meta tag**
1. Select View > Head Content.
2. Select the Keywords marker that appears at the top of the Document window.
3. In the Property inspector, view, modify, or delete keywords. You can also add keywords separated by commas.

**Specify descriptions for the page**
Many search-engine robots (programs that automatically browse the web gathering information for search engines to index) read the contents of the Description `meta` tag. Some use the information to index your pages in their databases, and some also display the information on the search results page (instead of displaying the first few lines of your document). Some search engines limit the number of characters they index, so it’s a good idea to limit your description to a few words (for example, *Pork barbecue catering in Albany, Georgia*, or *Web design at reasonable rates for clients worldwide*).

**Add a Description meta tag**
1. Select Insert > HTML > Head Tags > Description.
2. Enter descriptive text in the dialog box that appears.

**Edit a Description meta tag**
1. Select View > Head Content.
2. Select the Description marker that appears at the top of the Document window.
3. In the Property inspector, view, modify, or delete the descriptive text.

**Set the refresh properties of the page**
Use the Refresh element to specify that the browser should automatically refresh your page—by reloading the current page or going to a different one—after a certain amount of time. This element is often used to redirect users from one URL to another, often after displaying a text message that the URL has changed.
Add a Refresh meta tag
1 Select Insert > HTML > Head Tags > Refresh.
2 Set the Refresh meta tag properties in the dialog box that appears.

Edit a Refresh meta tag
1 Select View > Head Content.
2 Select the Refresh marker that appears at the top of the Document window.
3 In the Property inspector, set the Refresh meta tag properties.

Set the Refresh meta tag properties
❖ Specify the Refresh meta tag properties as follows:

**Delay** The time in seconds to wait before the browser refreshes the page. To make the browser refresh the page immediately after it finishes loading, enter 0 in this box.

**URL or Action** Specifies whether the browser should go to a different URL or refresh the current page, after the specified delay. To make a different URL open (rather than refreshing the current page), click the Browse button, then browse to and select the page to load.

Set the base URL properties of the page
Use the Base element to set the base URL that all document-relative paths in the page are considered relative to.

Add a Base meta tag
1 Select Insert > HTML > Head Tags > Base.
2 Specify the Base meta tag properties in the dialog box that appears.

Edit a Base meta tag
1 Select View > Head Content.
2 Select the Base marker that appears at the top of the Document window.
3 In the Property inspector, specify the Base meta tag properties.

Specify the Base meta tag properties
❖ Specify the Base meta tag properties as follows:

**Href** The base URL. Click the Browse button to browse to and select a file, or type a path in the box.

**Target** Specifies the frame or window in which all linked documents should open. Select one of the frames in the current frameset, or one of the following reserved names:

- _blank loads the linked document in a new, unnamed browser window.
- _parent loads the linked document into the parent frameset or window of the frame that contains the link. If the frame containing the link is not nested, then this is equivalent to _top; the linked document loads into the full browser window.
- _self loads the linked document in the same frame or window as the link. This target is the default, so you usually don’t have to specify it.
- _top loads the linked document in the full browser window, thereby removing all frames.
Set the link properties of the page

Use the link tag to define a relationship between the current document and another file.

*Note:* The link tag in the head section is not the same thing as an HTML link between documents in the body section.

Add a Link meta tag

1. Select Insert > HTML > Head Tags > Link.
2. Specify the Link meta tag properties in the dialog box that appears.

Edit a Link meta tag

1. Select View > Head Content.
2. Select the Link marker that appears at the top of the Document window.
3. In the Property inspector, specify the Link meta tag properties.

Specify the Link meta tag properties

❖ Set the Link meta tag properties as follows:

**Href** The URL of the file that you are defining a relationship to. Click the Browse button to browse to and select a file, or type a path in the box. Note that this attribute does not indicate a file that you’re linking to in the usual HTML sense; the relationships specified in a Link element are more complex.

**ID** Specifies a unique identifier for the link.

**Title** Describes the relationship. This attribute has special relevance for linked style sheets; for more information, see the External Style Sheets section of the HTML 4.0 specification on the World Wide Web Consortium website at www.w3.org/TR/REC-html40/present/styles.html#style-external.

**Rel** Specifies the relationship between the current document and the document in the Href box. Possible values include Alternate, Stylesheet, Start, Next, Prev, Contents, Index, Glossary, Copyright, Chapter, Section, Subsection, Appendix, Help, and Bookmark. To specify more than one relationship, separate values with a space.

**Rev** Specifies a reverse relationship (the opposite of Rel) between the current document and the document in the Href box. Possible values are the same as those for Rel.

Working with server-side includes

About server-side includes

You can use Dreamweaver to insert server-side includes in your pages, edit the includes, or preview pages containing includes.

A server-side include is a file that the server incorporates into your document when a browser requests your document from the server.
When a visitor’s browser requests the document that contains the include instruction, your server processes the include instruction and creates a new document in which the include instruction is replaced by the contents of the included file. The server then sends this new document to the visitor’s browser. When you open a local document directly in a browser, however, there’s no server to process the include instructions in that document, so the browser opens the document without processing those instructions, and the file that’s supposed to be included doesn’t appear in the browser. Thus, it can be difficult, without using Dreamweaver, to look at local files and see them as they’ll appear to visitors after you’ve put them on the server.

With Dreamweaver you can preview documents just as they’ll appear after they’re on the server, both in the Design view and when you use the Preview in Browser feature. To do so, however, you must make sure you are previewing the file that contains the include as a temporary file. (Select Edit > Preferences, select the Preview in Browser category, and make sure the Preview using temporary file option is selected.)

**Note:** If you are using a testing server, such as Apache or Microsoft IIS, to preview your files on your local drive, you do not need to preview the file as a temporary file because the server does the processing for you.

Placing a server-side include in a document inserts a reference to an external file; it doesn’t insert the contents of the specified file in the current document. The contents of the specified file should only contain the content that you want to include. That is, the include file should not contain any `head` tags, `body` tags, or `html` tags (meaning the `<html>` tag—formatting HTML tags, such as `p` tags, `div` tags, and so on, are fine). If it does, these tags will conflict with the tags in the original document, and Dreamweaver won’t display the page properly.

You cannot edit the included file directly in a document. To edit the contents of a server-side include, you must directly edit the file that you’re including. Any changes to the external file are automatically reflected in every document that includes it.

There are two types of server-side includes: Virtual and File. Dreamweaver inserts File type includes by default, but you can use the Property inspector to select the one that is appropriate for the type of web server you use:

- If your server is an Apache web server, select Virtual. In Apache, Virtual works in all cases, while File works only in some cases.
- If your server is a Microsoft Internet Information Server (IIS), select File. (Virtual works with IIS only in certain circumstances.)

  **Note:** Unfortunately, IIS won’t let you include a file in a folder above the current folder in the folder hierarchy, unless special software has been installed on the server. If you must include a file from a folder higher in the folder hierarchy on an IIS server, ask your system administrator if the necessary software is installed.

- For other kinds of servers, or if you don’t know what kind of server you’re using, ask your system administrator which option to use.

Some servers are configured to examine all files to see if they contain server-side includes; other servers are configured to examine only files with a particular file extension, such as `.shtml`, `.shtm`, or `.inc`. If a server-side include isn’t working for you, ask your system administrator if you need to use a special extension in the name of the file that uses the include. (For example, if the file is named canoe.html, you may have to rename it to canoe.shtml.) If you want your files to retain `.html` or `.htm` extensions, ask your system administrator to configure the server to examine all files (not just files with a certain extension) for server-side includes. Parsing a file for server-side includes takes a little extra time, so pages that the server parses are served a little more slowly than other pages; therefore, some system administrators won’t provide the option of parsing all files.

### Insert server-side includes

You can use Dreamweaver to insert server-side includes in your page.
Insert a server-side include
1 Select Insert > Server-Side Include.
2 In the dialog box that appears, browse to and select a file.

By default, a File type of include is inserted.

3 To change the type of the include, select the server-side include in the Document window and change the type in the Property inspector (Window > Properties), as follows:
   • If your server is an Apache web server, select Virtual. In Apache, Virtual works in all cases, while File works only in some cases.
   • If your server is a Microsoft Internet Information Server (IIS), select File. (Virtual works with IIS only in certain specific circumstances.)

Note: Unfortunately, IIS won’t allow you to include a file in a folder above the current folder in the folder hierarchy, unless special software has been installed on the server. If you need to include a file from a folder higher in the folder hierarchy on an IIS server, ask your system administrator if the necessary software is installed.

   • For other kinds of servers, or if you don’t know what kind of server you’re using, ask your system administrator which option to use.

Change which file is included
1 Select the server-side include in the Document window.
2 Open the Property inspector (Window > Properties).
3 Do one of the following:
   • Click the folder icon and browse to and select a new file to include.
   • In the box, type the path and filename of the new file to include.

Edit the contents of server-side includes
You can use Dreamweaver to edit server-side includes. To edit the content associated with the included file, you must open the file.
1 Select the server-side include in either Design view or Code view, and click Edit in the Property inspector.

The included file opens in a new Document window.
2 Edit the file, and then save it.

The changes are immediately reflected in the current document and in any subsequent document you open that includes the file.
3 Upload the include file to the remote site if necessary.
Managing tag libraries

About Dreamweaver tag libraries

A tag library, in Dreamweaver, is a collection of tags of a particular type, along with information about how Dreamweaver should format the tags. Tag libraries provide the information about tags that Dreamweaver uses for code hints, target browser checks, the Tag Chooser, and other coding capabilities. Using the Tag Library editor, you can add and delete tag libraries, tags, attributes, and attribute values; set properties for a tag library, including format (for easy identification in the code); and edit tags and attributes.

More Help topics

“Importing custom tags into Dreamweaver” on page 330
“Setting coding preferences” on page 287

Open and close the Tag Library editor

1 Select Edit > Tag Libraries to open the Tag library editor.

The Tag Library Editor dialog box appears. (The options of this dialog box change depending on the selected tag.)

2 Close the Tag Library editor in one of the following ways:

• To save changes, click OK.
• To close the editor without saving changes, click Cancel.

Note: When you click Cancel, all changes you’ve made in the Tag Library editor are discarded. If you deleted a tag or tag library, it’s restored.

Add libraries, tags, and attributes

You can use the Tag Library editor to add tag libraries, tags, and attributes to the tag libraries in Dreamweaver.

More Help topics

“Setting coding preferences” on page 287
“Importing custom tags into Dreamweaver” on page 330

Add a tag library

1 In the Tag Library editor (Edit > Tag Libraries), click the Plus (+) button, and select New Tag Library.

2 In the Library Name box, type a name (for example, Miscellaneous Tags), and click OK.

Add tags to a tag library

1 In the Tag Library editor (Edit > Tag Libraries), click the Plus (+) button and select New Tags.

2 Select Tag Library pop-up menu, and select a tag library.

3 Type the name of the new tag. To add more than one tag, separate the tags’ names with a comma and a space (for example: cfgraph, cfgraphdata).

4 If the new tags have corresponding end tags (</...>), select Have Matching End Tags.

5 Click OK.
Add attributes to a tag
1 In the Tag Library editor (Edit > Tag Libraries), click the Plus (+) button and select New Attributes.
2 In the Tag Library pop-up menu, select a tag library.
3 In the Tag pop-up menu, select a tag.
4 Type the name of the new attribute. To add more than one attribute, separate attributes’ names with a comma and a space (for example: \texttt{width, height}).
5 Click OK.

Edit libraries, tags, and attributes
Use the Tag Library editor to set properties for a tag library and edit tags and attributes in a library.

More Help topics
“Setting coding preferences” on page 287

Set properties for a tag library
1 In the Tag Library editor (Edit > Tag Libraries), select a tag library (not a tag) in the Tags list.

\textbf{Note:} The properties for tag libraries appear only when a tag library is selected. Tag libraries are represented by the top-level folders in the Tags list; for example, the HTML Tags folder represents a tag library, while the abbr folder within the HTML Tags folder represents a tag.

2 In the Used In list, select every document type that should use the tag library.

The document types you select here determine which document types provide code hints for the given tag library. For example, if the HTML option is not selected for a given tag library, code hints for that tag library don’t appear in HTML files.

3 (Optional) Enter the prefix for the tags in the Tag Prefix box.

\textbf{Note:} A prefix is used to identify a tag in the code as part of a particular tag library. Some tag libraries don’t use prefixes.

4 Click OK.

Edit a tag in a tag library
1 In the Tag Library editor (Edit > Tag Libraries), expand a tag library in the Tags list and select a tag.

2 Set any of the following Tag Format options:

\textbf{Line Breaks} Specifies where Dreamweaver inserts line breaks for a tag.

\textbf{Contents} Specifies how Dreamweaver inserts the contents of a tag: that is, if it applies line break, formatting, and indentation rules to the content.

\textbf{Case} Specifies the case for a specific tag. Select from Default, Lowercase, Uppercase, or Mixed Case. If you select Mixed Case, the Tag Name Mixed Case dialog box appears. Type the tag with the case Dreamweaver should use when inserting it (for example, \texttt{getProperty}) and click OK.

\textbf{Set Default} Sets the default case for all tags. In the Default Tag Case dialog box that appears, select \texttt{UPPERCASE} or \texttt{lowercase}, and click OK.

\textbullet You might want to set your default case to be lowercase to comply with XML and XHTML standards.
**Edit an attribute for a tag**
1. In the Tag Library editor (Edit > Tag Libraries), expand a tag library in the Tags box, expand a tag, and select a tag attribute.
2. In the Attribute Case pop-up menu, select the Default, Lowercase, Uppercase, or Mixed Case option.
3. If you select Mixed Case, the Attribute Name Mixed Case dialog box appears. Type the attribute with the case Dreamweaver should use when inserting it (for example, `onClick`), and click OK.
4. Click the Set Default link to set the default case for all attribute names.
5. In the Attribute Type pop-up menu, select the type of the attribute.

If you select Enumerated, type every allowed value for the attribute in the Values box. Separate the values with commas, but no spaces. For example, the enumerated values of the `showborder` attribute of the `cfchart` tag are listed as `yes, no`.

**Delete libraries, tags, and attributes**
1. In the Tag Library editor (Edit > Tag Libraries), select a tag library, tag, or attribute in the Tags box.
2. Click the Minus (-) button.
3. Click OK to permanently delete the item.
4. Click OK to close the Tag Library editor and complete the deletion.

**More Help topics**
“Setting coding preferences” on page 287

**Importing custom tags into Dreamweaver**

**About importing custom tags into Dreamweaver**
You can import custom tags into Dreamweaver so that they become an integral part of the authoring environment. For example, when you start typing an imported custom tag in Code view, a code hints menu appears, listing the tag’s attributes and letting you select one.

**Import tags from XML files**
You can import tags from an XML Document Type Definition (DTD) file or a schema.
1. Open the Tag Library editor (Edit > Tag Libraries).
2. Click the Plus (+) button and select DTD Schema > Import XML DTD or Schema File.
3. Enter the filename or URL of the DTD or schema file.
4. Enter the prefix to be used with the tags.
Note: A prefix is used to identify a tag in the code as part of a particular tag library. Some tag libraries don’t use prefixes.

5 Click OK.

Import custom ASP.NET tags

You can import custom ASP.NET tags into Dreamweaver.

Before you begin, make sure that the custom tag is installed on the testing server defined in the Site Definition dialog box (see “Set up a testing server” on page 45). Compiled tags (DLL files) must be placed in the site root’s /bin folder. Noncompiled tags (ASCX files) can reside in any virtual directory or subdirectory on the server. For more information, see the Microsoft ASP.NET documentation.

1 Open an ASP.NET page in Dreamweaver.
2 Open the Tag Library editor (Edit > Tag Libraries).
3 Click the Plus (+) button, select one of the following options, and click OK:
   • To import all the ASP.NET custom tags from the application server, select ASP.NET > Import All ASP.NET Custom Tags.
   • To import only certain custom tags from the application server, select ASP.NET > Import Selected ASP.NET Custom Tags. Control-click (Windows) or Command-click (Macintosh) tags from the list.

Import JSP tags from a file or server (web.xml)

Import a JSP tag library into Dreamweaver from a variety of file types or a JSP server.

1 Open a JSP page in Dreamweaver.
2 Open the Tag Library editor (Edit > Tag Libraries).
3 Click the Plus (+) button, and select JSP > Import From File (*.tld, *.jar, *.zip), or JSP > Import from Server (web.xml.)
4 Click the Browse button or enter a filename for the file that contains the tag library.
5 Enter a URI to identify the tag library.
   The URI (Uniform Resource Identifier) often consists of the URL of the organization maintaining the tag library. The URL is not used to view the organization’s website; it is used to uniquely identify the tag library.
6 (Optional) Enter the prefix to be used with the tags. Some tag libraries use a prefix to identify a tag in the code as part of a particular tag library.
7 Click OK.

Import JRun tags

If you use Adobe® JRun™, you can import your JRun tags into Dreamweaver.

1 Open a JSP page in Dreamweaver.
2 Open the Tag Library editor (Edit > Tag Libraries).
3 Click the Plus (+) button and select JSP > Import JRun Server Tags From Folder.
4 Enter a folder name for the folder that contains the JRun tags.
5 Enter a URI to identify the tag library.

The URI (Uniform Resource Identifier) often consists of the URL of the organization maintaining the tag library. The URL is not used to view the organization’s website; it is used to uniquely identify the tag library.

6 (Optional) Enter the prefix to be used with the tags. Some tag libraries use a prefix to identify a tag in the code as part of a particular tag library.

7 Click OK.
Chapter 12: Adding JavaScript behaviors

Using JavaScript behaviors (general instructions)

About JavaScript behaviors
Adobe® Dreamweaver® CS5 behaviors place JavaScript code in documents so that visitors can change a page in various ways or initiate certain tasks. A behavior is a combination of an event and an action triggered by that event. In the Behaviors panel, you add a behavior to a page by specifying an action and then specifying the event that triggers that action.

Note: Behavior code is client-side JavaScript code; that is, it runs in browsers, not on servers.

Events are, effectively, messages generated by browsers indicating that a visitor to your page has done something. For example, when a visitor moves the pointer over a link, the browser generates an onMouseOver event for that link; the browser then checks whether it should call some JavaScript code (specified in the page being viewed) in response. Different events are defined for different page elements; for example, in most browsers onMouseOver and onClick are events associated with links, whereas onLoad is an event associated with images and with the body section of the document.

An action is pre-written JavaScript code for performing a task, such as opening a browser window, showing or hiding an AP element, playing a sound, or stopping an Adobe Shockwave movie. The actions provided with Dreamweaver provide maximum cross-browser compatibility.

After you attach a behavior to a page element, the behavior calls the action (JavaScript code) associated with an event whenever that event occurs for that element. (The events that you can use to trigger a given action vary from browser to browser.) For example, if you attach the Popup Message action to a link and specify that it will be triggered by the onMouseOver event, then your message pops up whenever someone places the pointer over that link.

A single event can trigger several different actions, and you can specify the order in which those actions occur.

Dreamweaver provides about two dozen actions; additional actions can be found on the Exchange website at www.adobe.com/go/dreamweaver_exchange as well as on third-party developer sites. You can write your own actions if you are proficient in JavaScript.

Note: The terms behavior and action are Dreamweaver terms, not HTML terms. From the browser’s point of view, an action is just like any other piece of JavaScript code.

Behaviors panel overview
You use the Behaviors panel (Window > Behaviors) to attach behaviors to page elements (more specifically to tags) and to modify parameters of previously attached behaviors.

Behaviors that have already been attached to the currently selected page element appear in the behavior list (the main area of the panel), listed alphabetically by event. If several actions are listed for the same event, they will be executed in the order in which they appear on the list. If no behaviors appear in the behavior list, no behaviors have been attached to the currently selected element.

The Behaviors panel has the following options:

Show Set Events Displays only those events that have been attached to the current document. Events are organized into client-side and server-side categories. Each category’s events are in a collapsible list. Show Set Events is the default view.
Show All Events  Displays an alphabetical list of all events for a given category.

Add Behavior (+)  Displays a menu of actions that can be attached to the currently selected element. When you select an action from this list, a dialog box appears in which you can specify parameters for the action. If all the actions are dimmed, no events can be generated by the selected element.

Remove Event (–)  Removes the selected event and action from the behavior list.

Up and down arrow buttons  Move the selected action up or down in the behavior list for a particular event. You can change the order of actions only for a particular event—for example, you can change the order in which several actions occur for the onLoad event, but all the onLoad actions stay together in the behavior list. The arrow buttons are disabled for actions that can’t be moved up or down in the list.

Events  Displays a pop-up menu, visible only when an event is selected, of all the events that can trigger the action (this menu appears when you click the arrow button next to the selected event name). Different events appear depending on the object selected. If the events you expect don’t appear, make sure that the correct page element or tag is selected. (To select a specific tag, use the tag selector at the lower-left corner of the Document window.)

Note: Event names in parentheses are available only for links; selecting one of these event names automatically adds a null link to the selected page element, and attaches the behavior to that link instead of to the element itself. The null link is specified as href="javascript:;" in the HTML code.

About events

Each browser provides a set of events that you can associate with the actions listed in the Behavior panel’s Actions (+) menu. When a visitor to your web page interacts with the page—for example, by clicking an image—the browser generates events; those events can be used to call JavaScript functions that perform an action. Dreamweaver supplies many common actions that you can trigger with these events.

For names and descriptions of the events provided by each browser, see the Dreamweaver Support Center at www.adobe.com/go/dreamweaver_support.

Different events appear in the Events menu depending on the selected object. To find out what events a given browser supports for a given page element, insert the page element in your document and attach a behavior to it, then look at the Events menu in the Behaviors panel. (By default, events are drawn from the HTML 4.01 events list, and are supported by most modern browsers.) Events may be disabled (dimmed) if the relevant objects do not yet exist on the page or if the selected object cannot receive events. If the expected events don’t appear, make sure the correct object is selected.

If you’re attaching a behavior to an image, some events (such as onMouseOver) appear in parentheses. These events are available only for links. When you select one of them, Dreamweaver wraps an <a> tag around the image to define a null link. The null link is represented by javascript:; in the Property inspector’s Link box. You can change the link value if you want to turn it into a real link to another page, but if you delete the JavaScript link without replacing it with another link, you will remove the behavior.

To see which tags you can use with a given event in a given browser, search for the event in one of the files in the Dreamweaver/Configuration/Behaviors/Events folder.

Apply a behavior

You can attach behaviors to the entire document (that is, to the <body> tag) or to links, images, form elements, and several other HTML elements.

The target browser you select determines which events are supported for a given element.
You can specify more than one action for each event. Actions occur in the order in which they’re listed in the Actions column of the Behaviors panel, but you can change that order.

1  Select an element on the page, such as an image or a link.

To attach a behavior to the entire page, click the `<body>` tag in the tag selector at the lower-left corner of the Document window.

2  Choose Window > Behaviors.

3  Click the Plus (+) button and select an action from the Add Behavior menu.

Actions that are dimmed in the menu can’t be chosen. They may be dimmed because a required object doesn’t exist in the current document. For example, the Control Shockwave or SWF action is dimmed if the document contains no Shockwave or SWF files.

When you select an action, a dialog box appears, displaying parameters and instructions for the action.

4  Enter parameters for the action, and click OK.

All actions provided in Dreamweaver work in modern browsers. Some actions do not work in older browsers, but they will not cause errors.

**Note:** Targeted elements require a unique ID. For example, if you want to apply the Swap Image behavior to an image, the image requires an ID. If you don’t have an ID specified for the element, Dreamweaver automatically specifies one for you.

5  The default event to trigger the action appears in the Events column. If this is not the trigger event you want, select another event from the Events pop-up menu. (To open the Events menu, select an event or action in the Behaviors panel, and click the downward-pointing black arrow that appears between the event name and the action name.)

### Change or delete a behavior

After attaching a behavior, you can change the event that triggers the action, add or remove actions, and change parameters for actions.

1  Select an object with a behavior attached.

2  Choose Window > Behaviors.

3  Make your changes:
   - To edit an action’s parameters, double-click its name, or select it and press Enter (Windows) or Return (Macintosh); then change parameters in the dialog box and click OK.
   - To change the order of actions for a given event, select an action and click the Up or Down arrow. Alternatively, you can select the action and cut and paste it into the desired location among the other actions.
   - To delete a behavior, select it and click the Minus (−) button or press Delete.

### Update a behavior

1  Select an element that has the behavior attached to it.

2  Choose Window > Behaviors and double-click the behavior.

3  Make your changes and click OK in the behavior’s dialog box.

All occurrences of that behavior in that page are updated. If other pages on your site have that behavior, you must update them page by page.
Using built-in JavaScript behaviors

**Using built-in behaviors**

The behaviors included with Dreamweaver have been written to work in modern browsers. The behaviors fail silently in older browsers.

*Note: The Dreamweaver actions have been carefully written to work in as many browsers as possible. If you remove code from a Dreamweaver action by hand, or replace it with your own code, you may lose cross-browser compatibility.*

Although the Dreamweaver actions were written to maximize cross-browser compatibility, some browsers do not support JavaScript at all, and many people who browse the web keep JavaScript turned off in their browsers. For best cross-platform results, provide alternative interfaces enclosed in `<noscript>` tags so that people without JavaScript can use your site.

**Apply the Call JavaScript behavior**

The Call JavaScript behavior executes a custom function or line of JavaScript code when an event occurs. (You can write the script yourself, or you can use code provided by various freely available JavaScript libraries on the web.)

1. Select an object and choose Call JavaScript from the Add Behavior menu of the Behaviors panel.
2. Type the exact JavaScript to be executed, or type the name of a function.
   
   For example, to create a Back button, you might type `if (history.length > 0){history.back();}`. If you have encapsulated your code in a function, type only the function name (for example, `hGoBack()`).
3. Click OK and verify that the default event is correct.

**Apply the Change Property behavior**

Use the Change Property behavior to change the value of one of an object’s properties (for example, the background color of a div or the action of a form).

*Note: Use this behavior only if you are very familiar with HTML and JavaScript.*

1. Select an object and choose Change Property from the Add Behavior menu of the Behaviors panel.
2. From the Type Of Element menu, select an element type to display all the identified elements of that type.
3. Select an element from the Element ID menu.
4. Select a property from the Property menu, or enter the name of the property in the box.
5 Enter the new value for the new property in the New Value field.
6 Click OK and verify that the default event is correct.

**Apply the Check Browser behavior**
This behavior has been deprecated as of Dreamweaver CS5.

**Apply the Check Plugin behavior**
Use the Check Plugin behavior to send visitors to different pages depending on whether they have the specified plug-in installed. For example, you might want visitors to go to one page if they have Shockwave and another page if they do not.

*Note: You cannot detect specific plug-ins in Internet Explorer using JavaScript. However, selecting Flash or Director will add the appropriate VBScript code to your page to detect those plug-ins in Internet Explorer on Windows. Plug-in detection is impossible in Internet Explorer on Mac OS.*

1 Select an object and choose Check Plugin from the Add Behavior menu of the Behaviors panel.
2 Select a plug-in from the Plugin menu, or click Enter and type the exact name of the plug-in in the adjacent box. You must use the exact name of the plug-in as specified in bold on the About Plug-ins page in Netscape Navigator. (In Windows, select Navigator’s Help > About Plug-ins command; on Mac OS, select About Plug-ins from the Apple menu.)
3 In the If Found, Go To URL box, specify a URL for visitors who have the plug-in. If you specify a remote URL, you must include the http:// prefix in the address. If you leave the field blank, visitors will stay on the same page.
4 In the Otherwise, Go To URL box, specify an alternative URL for visitors who don’t have the plug-in. If you leave the field blank, visitors will stay on the same page.
5 Specify what to do if plug-in detection is not possible. By default, when detection is impossible, the visitor is sent to the URL listed in the Otherwise box. To instead send the visitor to the first (If Found) URL, select the option Always Go To First URL If Detection Is Not Possible. When selected, this option effectively means “assume that the visitor has the plug-in, unless the browser explicitly indicates that the plug-in is not present.” In general, select this option if the plug-in content is integral to your page; if not leave it deselected.

*Note: This option applies only to Internet Explorer; Netscape Navigator can always detect plug-ins.*
6 Click OK and verify that the default event is correct.

**Apply the Control Shockwave or SWF behavior**
This behavior has been deprecated as of Dreamweaver CS5.

**Apply the Drag AP Element behavior**
The Drag AP Element behavior lets the visitor drag an absolutely positioned (AP) element. Use this behavior to create puzzles, slider controls, and other movable interface elements.

You can specify in which direction the visitor can drag the AP element (horizontally, vertically, or in any direction), a target to which the visitor should drag the AP element, whether to snap the AP element to the target if the AP element is within a certain number of pixels of the target, what to do when the AP element hits the target, and more.
Because the Drag AP Element behavior must be called before the visitor can drag the AP element, you should attach Drag AP Element to the body object (with the onLoad event).

1 Select Insert > Layout Objects > AP Div or click the Draw AP Div button on the Insert panel and draw an AP Div in the Document window’s Design view.

2 Click <body> in the tag selector at the lower-left corner of the Document window.

3 Select Drag AP Element from the Add Behavior menu of the Behaviors panel.

If Drag AP Element is unavailable, you probably have an AP element selected.

4 In the AP Element pop-up menu, select the AP element.

5 Select either Constrained or Unconstrained from the Movement pop-up menu.

Unconstrained movement is appropriate for puzzles and other drag-and-drop games. For slider controls and moveable scenery such as file drawers, curtains, and mini-blinds, select constrained movement.

6 For constrained movement, enter values (in pixels) in the Up, Down, Left, and Right boxes.

Values are relative to the starting position of the AP element. To constrain movement within a rectangular region, enter positive values in all four boxes. To allow only vertical movement, enter positive values for Up and Down and 0 for Left and Right. To allow only horizontal movement, enter positive values for Left and Right and 0 for Up and Down.

7 Enter values (in pixels) for the drop target in the Left and Top boxes.

The drop target is the spot to which you want the visitor to drag the AP element. An AP element is considered to have reached the drop target when its left and top coordinates match the values you enter in the Left and Top boxes. Values are relative to the top left corner of the browser window. Click Get Current Position to automatically fill the text boxes with the current position of the AP element.

8 Enter a value (in pixels) in the Snap If Within box to determine how close the visitor must get to the drop target before the AP element snaps to the target.

Larger values make it easier for the visitor to find the drop target.

9 For simple puzzles and scenery manipulation, you can stop here. To define the drag handle for the AP element, track the movement of the AP element while it is being dragged, and trigger an action when the AP element is dropped, click the Advanced tab.

10 To specify that the visitor must click a particular area of the AP element to drag the AP element, select Area within element from the Drag Handle menu; then enter the left and top coordinates and the width and height of the drag handle.

This option is useful when the image inside the AP element contains an element that suggests dragging, such as a title bar or drawer handle. Do not set this option if you want the visitor to be able to click anywhere in the AP element to drag it.

11 Select any While Dragging options that you want to use:

- Select Bring Element To Front if the AP element should move to the front of the stacking order while it is being dragged. If you select this option, use the pop-up menu to select whether to leave the AP element in front or restore it to its original position in the stacking order.

- Enter JavaScript code or a function name (for example, monitorAPelement()) in the Call JavaScript box to repeatedly execute the code or function while the AP element is being dragged. For example, you could write a function that monitors the coordinates of the AP element and displays hints such as “you’re getting warmer” or “you’re nowhere near the drop target” in a text box.
12 Enter JavaScript code or a function name (for example, `evaluateAPelementPos()` in the second Call JavaScript box to execute the code or function when the AP element is dropped. Select Only If Snapped if the JavaScript should be executed only if the AP element has reached the drop target.

13 Click OK and verify that the default event is correct.

Gathering information about the draggable AP element

When you attach the Drag AP element behavior to an object, Dreamweaver inserts the `MM_dragLayer()` function into the `head` section of your document. (The function retains the old naming convention for AP elements [that is, “Layer”] so that layers created in previous versions of Dreamweaver will remain editable.) In addition to registering the AP element as draggable, this function defines three properties for each draggable AP element—`MM_LEFTRIGHT`, `MM_UPDOWN`, and `MM_SNAPPED`—that you can use in your own JavaScript functions to determine the relative horizontal position of the AP element, the relative vertical position of the AP element, and whether the AP element has reached the drop target.

Note: The information provided here is intended for experienced JavaScript programmers only.

For example, the following function displays the value of the `MM_UPDOWN` property (the current vertical position of the AP element) in a form field called `curPosField`. (Form fields are useful for displaying continuously updated information because they are dynamic—that is, you can change their contents after the page has finished loading.)

```javascript
function getPos(layerId) {
    var layerRef = document.getElementById(layerId);
    var curVertPos = layerRef.MM_UPDOWN;
    document.tracking.curPosField.value = curVertPos;
}
```

Instead of displaying the values of `MM_UPDOWN` or `MM_LEFTRIGHT` in a form field, you could use those values in a variety of other ways. For example, you could write a function that displays a message in the form field depending on how close the value is to the drop zone, or you could call another function to show or hide an AP element depending on the value.

It is especially useful to read the `MM_SNAPPED` property when you have several AP elements on the page, all of which must reach their targets before the visitor can advance to the next page or task. For example, you could write a function to count how many AP elements have an `MM_SNAPPED` value of `true` and call it whenever an AP element is dropped. When the snapped count reaches the desired number, you could send the visitor to the next page or display a message of congratulations.

Apply the Go To URL behavior

The Go To URL behavior opens a new page in the current window or in the specified frame. This behavior is useful for changing the contents of two or more frames with one click.

1 Select an object and choose Go To URL from the Add Behavior menu of the Behaviors panel.

2 Select a destination for the URL from the Open In list.

The Open In list automatically lists the names of all frames in the current frameset as well as the main window. If there are no frames, the main window is the only option.

Note: This behavior may produce unexpected results if any frame is named top, blank, self, or parent. Browsers sometimes mistake these names for reserved target names.

3 Click Browse to select a document to open, or enter the path and filename of the document in the URL box.

4 Repeat steps 2 and 3 to open additional documents in other frames.
5 Click OK and verify that the default event is correct.

**Apply the Jump Menu behavior**

When you create a jump menu by using Insert > Form > Jump Menu, Dreamweaver creates a menu object and attaches the Jump Menu (or Jump Menu Go) behavior to it. There is usually no need to attach the Jump Menu behavior to an object by hand.

You can edit an existing jump menu in either of two ways:

- You can edit and rearrange menu items, change the files to jump to, and change the window in which those files open, by double-clicking an existing Jump Menu behavior in the Behaviors panel.
- You can edit the items in the menu just as you would edit items in any menu, by selecting the menu and using the List Values button in the Property inspector.

1 Create a jump menu object if there isn’t one already in your document.
2 Select the object and choose Jump Menu from the Add Behavior menu of the Behaviors panel.
3 Make changes as desired in the Jump Menu dialog box and then click OK.

**More Help topics**

“Jump menus” on page 270

“Insert or change a dynamic HTML form menu” on page 642

**Apply the Jump Menu Go behavior**

The Jump Menu Go behavior is closely associated with the Jump Menu behavior; Jump Menu Go lets you associate a Go button with a jump menu. (Before you use this behavior, a jump menu must already exist in the document.) Clicking the Go button opens the link that’s selected in the jump menu. A jump menu doesn’t normally need a Go button; selecting an item from a jump menu generally causes a URL to load without any need for further user action. But if the visitor selects the same item that’s already chosen in the jump menu, the jump doesn’t occur. In general, that doesn’t matter, but if the jump menu appears in a frame, and the jump menu items link to pages in other frames, a Go button is often useful, to allow visitors to re-select an item that’s already selected in the jump menu.

**Note:** When you use a Go button with a jump menu, the Go button becomes the only mechanism that “jumps” the user to the URL associated with the selection in the menu. Selecting a menu item in the jump menu no longer re-directs the user automatically to another page or frame.

1 Select an object to use as the Go button (generally a button image), and choose Jump Menu Go from the Add Behavior menu of the Behaviors panel.
2 In the Choose Jump Menu menu, select a menu for the Go button to activate and click OK.

**Apply the Open Browser Window behavior**

Use the Open Browser Window behavior to open a page in a new window. You can specify the properties of the new window, including its size, attributes (whether it is resizable, has a menu bar, and so on), and name. For example, you can use this behavior to open a larger image in a separate window when the visitor clicks a thumbnail image; with this behavior, you can make the new window the exact size of the image.
If you specify no attributes for the window, it opens at the size and with the attributes of the window from which it was opened. Specifying any attribute for the window automatically turns off all other attributes that are not explicitly turned on. For example, if you set no attributes for the window, it might open at 1024 x 768 pixels and have a navigation bar (showing the Back, Forward, Home and Reload buttons), location toolbar (showing the URL), status bar (showing status messages, at the bottom), and menu bar (showing File, Edit, View and other menus). If you explicitly set the width to 640 and the height to 480 and set no other attributes, the window opens at 640 x 480 pixels, without toolbars.

1. Select an object and choose Open Browser Window from the Add Behavior menu of the Behaviors panel.
2. Click Browse to select a file, or enter the URL you want to display.
3. Set the options for window width and height (in pixels) and for the incorporation of various toolbars, scroll bars, resize handles, and the like. Give the window a name (use no spaces or special characters) if you want it to be the target of links or want to control it with JavaScript.
4. Click OK and verify that the default event is correct.

**Apply the Play Sound behavior**
This behavior has been deprecated as of Dreamweaver CS5.

**Apply the Popup Message behavior**
The Popup Message behavior displays a JavaScript alert with the message you specify. Because JavaScript alerts have only one button (OK), use this behavior to give the user information rather than to present a choice.

You can embed any valid JavaScript function call, property, global variable, or other expression in the text. To embed a JavaScript expression, place it inside braces ({}). To display a brace, precede it with a backslash (\{}).

Example:
The URL for this page is \{window.location\}, and today is \{new Date()\}.

**Note:** The browser controls the appearance of the alert. If you want more control over the appearance, consider using the Open Browser Window behavior.

1. Select an object and choose Popup Message from the Add Behavior menu of the Behaviors panel.
2. Enter your message in the Message box.
3. Click OK and verify that the default event is correct.

**Apply the Preload Images behavior**
The Preload Images behavior shortens display time by caching images that are not shown when the page first appears (for instance, images that will be swapped in with behaviors or scripts).

**Note:** The Swap Image behavior automatically preloads all highlight images when you select the Preload Images option in the Swap Image dialog box, so you do not need to manually add Preload Images when using Swap Image.

1. Select an object and choose Preload Images from the Add Behavior menu of the Behaviors panel.
2. Click Browse to select an image file, or enter the path and filename of an image in the Image Source File box.
3. Click the Plus (+) button at the top of the dialog box to add the image to the Preload Images list.
4. Repeat steps 2 and 3 for all remaining images that you want to preload on the current page.
5. To remove an image from the Preload Images list, select it and click the Minus (–) button.
Click OK and verify that the default event is correct.

**Apply the Set Nav Bar Image behavior**
This behavior has been deprecated as of Dreamweaver CS5.

**Apply the Set Text Of Frame behavior**
The Set Text Of Frame behavior allows you to dynamically set the text of a frame, replacing the content and formatting of a frame with the content you specify. The content can include any valid HTML code. Use this behavior to display information dynamically.

Although the Set Text Of Frame behavior replaces the formatting of a frame, you can select Preserve Background Color to preserve the page background and text color attributes.

You can embed any valid JavaScript function call, property, global variable, or other expression in the text. To embed a JavaScript expression, place it inside braces (`{}`). To display a brace, precede it with a backslash (`\`).

Example:
The URL for this page is `{window.location}`, and today is `{new Date()}`.

1. Select an object and choose Set Text > Set Text Of Frame from the Add Behavior menu of the Behaviors panel.
2. In the Set Text Of Frame dialog box, select the target frame from the Frame menu.
3. Click the Get Current HTML button to copy the current contents of the target frame’s body section.
4. Enter a message in the New HTML box.
5. Click OK and verify that the default event is correct.

**More Help topics**
“Create frames and framesets” on page 189

**Apply the Set Text Of Container behavior**
The Set Text Of Container behavior replaces the content and formatting of an existing container (that is, any element that can contain text or other elements) on a page with the content you specify. The content can include any valid HTML source code.

You can embed any valid JavaScript function call, property, global variable, or other expression in the text. To embed a JavaScript expression, place it inside braces (`{}`). To display a brace, precede it with a backslash (`\`).

Example:
The URL for this page is `{window.location}`, and today is `{new Date()}`.

1. Select an object and select Set Text > Set Text Of Container from the Add Behavior menu of the Behaviors panel.
2. In the Set Text Of Container dialog box, use the Container menu to select the target element.
3. Enter the new text or HTML in the New HTML box.
4. Click OK and verify that the default event is correct.

Last updated 12/7/2011
Apply the Set Text Of Status Bar behavior

The Set Text Of Status Bar behavior shows a message in the status bar at the lower-left corner of the browser window. For example, you can use this behavior to describe the destination of a link in the status bar instead of showing the URL associated with it. Visitors often ignore or overlook messages in the status bar (and not all browsers provide full support for setting the text of the status bar); if your message is important, consider displaying it as a pop-up message or as the text of an AP element.

**Note:** If you use the Set Text Of Status Bar behavior in Dreamweaver, the text of the status bar in the browser is not guaranteed to change because some browsers require special adjustments when changing status bar text. Firefox, for example, requires that you change an Advanced option that lets JavaScript change status bar text. For more information, see your browser’s documentation.

You can embed any valid JavaScript function call, property, global variable, or other expression in the text. To embed a JavaScript expression, place it inside braces ({}). To display a brace, precede it with a backslash (\{}\).

Example:

The URL for this page is {window.location}, and today is {new Date()}.

1. Select an object and choose Set Text > Set Text Of Status Bar from the Add Behavior menu of the Behaviors panel.
2. In the Set Text Of Status Bar dialog box, type your message in the Message box. Keep the message concise. The browser truncates the message if it doesn’t fit in the status bar.
3. Click OK and verify that the default event is correct.

Apply the Set Text Of Text Field behavior

The Set Text Of Text Field behavior replaces the content of a form’s text field with the content you specify.

You can embed any valid JavaScript function call, property, global variable, or other expression in the text. To embed a JavaScript expression, place it inside braces ({}). To display a brace, precede it with a backslash (\{}\).

Example:

The URL for this page is {window.location}, and today is {new Date()}.

Create a named text field

1. Select Insert > Form > Text Field. If Dreamweaver prompts you to add a form tag, click Yes.
2. In the Property inspector, type a name for the text field. Make sure the name is unique on the page (don’t use the same name for multiple elements on the same page, even if they’re in different forms).

Apply Set Text Of Text Field

1. Select a text field and choose Set Text > Set Text Of Field from the Add Behavior menu of the Behaviors panel.
2. Select the target text field from the Text Field menu and enter your new text.
3. Click OK and verify that the default event is correct.
Apply the Show-Hide Elements behavior
The Show-Hide Elements behavior shows, hides, or restores the default visibility of one or more page elements. This behavior is useful for displaying information as the user interacts with the page. For example, as the user moves the pointer over an image of a plant, you could show a page element giving details about the plant’s growing season and region, how much sun it needs, how large it can grow, and so on. The behavior only shows or hides the pertinent element—it does not actually remove the element from the flow of the page when it is hidden.

1 Select an object and select Show-Hide Elements from the Add Behavior menu of the Behaviors panel. If Show-Hide Elements is unavailable, you probably have an AP element selected. Because AP elements do not accept events in both 4.0 browsers, you must select a different object—such as the <body> tag or a link (<a>) tag.

2 From the Elements list, select the element you want to show or hide and click Show, Hide, or Restore (which restores the default visibility).

3 Repeat step 2 for all remaining elements whose visibility you want to change. (You can change the visibility of multiple elements with a single behavior.)

4 Click OK and verify that the default event is correct.

Apply the Show Pop-Up Menu behavior
This behavior has been deprecated as of Dreamweaver CS5.

Add, remove, and rearrange pop-up menu items
This behavior has been deprecated as of Dreamweaver CS5.

Format a pop-up menu
This behavior has been deprecated as of Dreamweaver CS5.

Position a pop-up menu in a document
This behavior has been deprecated as of Dreamweaver CS5.

Modify a pop-up menu
This behavior has been deprecated as of Dreamweaver CS5.

Apply the Swap Image behavior
The Swap Image behavior swaps one image for another by changing the src attribute of the <img> tag. Use this behavior to create button rollovers and other image effects (including swapping more than one image at a time). Inserting a rollover image automatically adds a Swap Image behavior to your page.

Note: Because only the src attribute is affected by this behavior, you should swap in an image that has the same dimensions (height and width) as the original. Otherwise, the image you swap in shrinks or expands to fit the dimensions of the original image.
There is also a Swap Image Restore behavior, which restores the last set of swapped images to their previous source files. This behavior is automatically added whenever you attach the Swap Image behavior to an object; if you leave the Restore option selected while attaching Swap Image, you should never need to select the Swap Image Restore behavior manually.

1 Select Insert > Image or click the Image button on the Insert panel to insert an image.

2 In the Property inspector, enter a name for the image in the leftmost text box.

It isn’t mandatory to name images; they’re named automatically when you attach the behavior to an object. However, it is easier to distinguish images in the Swap Image dialog box if you name all the images beforehand.

3 Repeat steps 1 and 2 to insert additional images.

4 Select an object (generally the image you’re going to swap) and choose Swap Image from the Add Behavior menu of the Behaviors panel.

5 From the Images list, select the image whose source you want to change.

6 Click Browse to select the new image file, or enter the path and filename of the new image in the Set Source To box.

7 Repeat steps 5 and 6 for any additional images you want to change. Use the same Swap Image action for all the images you want to change at once; otherwise, the corresponding Swap Image Restore action won’t restore all of them.

8 Select the Preload Images option to cache the new images when the page is loaded.

This prevents downloading delays when it is time for the images to appear.

9 Click OK and verify that the default event is correct.

Apply the Validate Form behavior

The Validate Form behavior checks the contents of specified text fields to ensure that the user has entered the correct type of data. Attach this behavior to individual text fields with the `onBlur` event to validate the fields as the user is filling out the form, or attach it to the form with the `onSubmit` event to evaluate several text fields at once when the user clicks the Submit button. Attaching this behavior to a form prevents the submission of forms with invalid data.

1 Select Insert > Form or click the Form button in the Insert panel to insert a form.

2 Select Insert > Form > Text Field or click the Text Field button in the Insert panel to insert a text field.

Repeat this step to insert additional text fields.

3 Choose a validation method:
   - To validate individual fields as the user fills out the form, select a text field and select Window > Behaviors.
   - To validate multiple fields when the user submits the form, click the `<form>` tag in the tag selector at the lower-left corner of the Document window and choose Window > Behaviors.

4 Select Validate Form from the Add Behavior menu.

5 Do one of the following:
   - If you are validating individual fields, select the same field that you selected in the Document window from the Fields list.
   - If you are validating multiple fields, select a text field from the Fields list.

6 Select the Required option if the field must contain some data.

7 Select one of the following Accept options:
   - **Use Anything**: Checks that a required field contains data; the data can be of any type.
**Use E-mail address**  Checks that the field contains an @ symbol.

**Use Number**  Checks that the field contains only numerals.

**Use Number From**  Checks that the field contains a number in a specific range.

8  If you have chosen to validate multiple fields, repeat steps 6 and 7 for any additional fields that you want to validate.

9  Click OK.

If you are validating multiple fields when the user submits the form, the **onSubmit** event automatically appears in the Events menu.

10  If you are validating individual fields, check that the default event is **onBlur** or **onChange**. If not, select one of those events.

Both events trigger the Validate Form behavior when the user moves away from the field. The difference is that **onBlur** occurs whether or not the user has typed in the field, and **onChange** occurs only if the user changed the contents of the field. The **onBlur** event is preferred if the field is required.
Chapter 13: Working with other applications

Cross-application integration

About Photoshop, Flash, and Fireworks integration

Photoshop, Fireworks, and Flash are powerful web-development tools for creating and managing graphics and SWF files. You can tightly integrate Dreamweaver with these tools to simplify your web design workflow.

Note: There is also limited integration with some other applications. For example, you can export an InDesign file as XHTML and continue working on it in Dreamweaver. For a tutorial on this workflow, see www.adobe.com/go/vid0202.

You can easily insert images and content created with Adobe Flash (SWF and FLV files) in a Dreamweaver document. You can also edit an image or SWF file in its original editor after you insert it in a Dreamweaver document.

Note: To use Dreamweaver in conjunction with these Adobe applications, you must have these applications installed on your computer.

For Fireworks and Flash, product integration is achieved through roundtrip editing. Roundtrip editing ensures that code updates are transferred correctly between Dreamweaver and these other applications (for example, to preserve rollover behaviors or links to other files).

Dreamweaver also relies on Design Notes for product integration. Design Notes are small files that allow Dreamweaver to locate the source document for an exported image or SWF file. When you export files from Fireworks, Flash, or Photoshop directly to a Dreamweaver defined site, Design Notes containing references to the original PSD, PNG, or Flash authoring file (FLA) are automatically exported to the site along with the web-ready file (GIF, JPEG, PNG, or SWF).

In addition to location information, Design Notes contain other pertinent information about exported files. For example, when you export a Fireworks table, Fireworks writes a Design Note for each exported image file in the table. If the exported file contains hotspots or rollovers, the Design Notes include information about the scripts for them.

As part of the export operation, Dreamweaver creates a folder named _notes in the same folder as the exported asset. This folder contains the Design Notes that Dreamweaver needs to integrate with Photoshop, Flash, or Fireworks.

Note: In order to use Design Notes, you must make sure they are not disabled for your Dreamweaver site. They are enabled by default. However, even if they are disabled, when you insert a Photoshop image file, Dreamweaver creates a Design Note to store the location of the source PSD file.

For a tutorial on Dreamweaver and Fireworks integration, see www.adobe.com/go/vid0188.

For a tutorial on Dreamweaver and Photoshop integration, see www.adobe.com/go/lrvid4043_dw.

More Help topics

“About Design Notes” on page 100

“Enable and disable Design Notes for a site” on page 100

Dreamweaver InDesign tutorial
Working with Fireworks and Dreamweaver

Insert a Fireworks image

Dreamweaver and Fireworks recognize and share many of the same file-editing procedures, including changes to links, image maps, table slices, and more. Together, the two applications provide a streamlined workflow for editing, optimizing, and placing web graphics files in HTML pages.

You can place a Fireworks exported graphic directly in a Dreamweaver document using the Insert Image command, or you can create a new Fireworks graphic from a Dreamweaver image placeholder.

1 In the Dreamweaver document, place the insertion point where you want the image to appear, then do one of the following:
   • Select Insert > Image.
   • In the Common category of the Insert panel, click the Image button or drag it to the document.
2 Navigate to the desired Fireworks exported file, and click OK (Windows) or Open (Macintosh).

Note: If the Fireworks file is not in the current Dreamweaver site, a message appears asking whether you want to copy the file to the root folder. Click Yes.

More Help topics
“About Photoshop, Flash, and Fireworks integration” on page 347

Edit a Fireworks image or table from Dreamweaver

When you open and edit an image or an image slice that is part of a Fireworks table, Dreamweaver starts Fireworks, which opens the PNG file from which the image or table was exported.

Note: This assumes that Fireworks is set as the primary external image editor for PNG files. Fireworks is often also set as the default editor for JPEG and GIF files, although you may wish to set Photoshop as the default editor for these file types.

When the image is part of a Fireworks table, you can open the entire Fireworks table for edits, as long as the <!--fw table--> comment exists in the HTML code. If the source PNG file was exported from Fireworks to a Dreamweaver site using the Dreamweaver Style HTML And Images setting, the Fireworks table comment is automatically inserted in the HTML code.

1 In Dreamweaver, open the Property inspector (Window > Properties) if it isn’t already open.
2 Click the image or image slice to select it.

When you select an image that was exported from Fireworks, the Property inspector identifies the selection as a Fireworks image or table and displays the name of the PNG source file.

3 To start Fireworks for editing, do one of the following:
   • In the Property inspector, click Edit.
   • Hold down Control (Windows) or Command (Macintosh) and double-click the selected image.
   • Right-click (Windows) or Control-click (Macintosh) the selected image and select Edit With Fireworks from the context menu.

Note: If Fireworks cannot locate the source file, you are prompted to locate the PNG source file. When you work with the Fireworks source file, changes are saved to both the source file and the exported file; otherwise, only the exported file is updated.
In Fireworks, edit the source PNG file and click Done.

Fireworks saves the changes in the PNG file, exports the updated image (or HTML and images), and returns focus to Dreamweaver. In Dreamweaver, the updated image or table appears.

For a tutorial about Dreamweaver and Fireworks integration, see www.adobe.com/go/vid0188.

More Help topics
“Use an external image editor” on page 235

Dreamweaver Fireworks tutorial

Optimize a Fireworks image from Dreamweaver
You can use Dreamweaver to make quick changes to Fireworks images and animations. From within Dreamweaver, you can change optimization settings, animation settings, and the size and area of the exported image.

1 In Dreamweaver, select the desired image and do one of the following:
   • Select Command > Optimize Image
   • Click the Edit
   • Image Settings
   • button in the Property inspector.
2 Make your edits in the Image Preview dialog box:
   • To edit optimization settings, click the Options tab.
   • To edit the size and area of the exported image, click the File tab.
3 When you finish, click OK.

More Help topics
“Setting Image Preview dialog box options” on page 358

Use Fireworks to modify Dreamweaver image placeholders
You can create a placeholder image in a Dreamweaver document and then start Fireworks to design a graphic image or Fireworks table to replace it.

To create a new image from an image placeholder, you must have both Dreamweaver and Fireworks installed on your system.

1 Make sure you've already set Fireworks as the image editor for PNG files.
2 In the Document window, click the image placeholder to select it.
3 Start Fireworks in Editing From Dreamweaver mode by doing one of the following:
   • In the Property inspector, click Create.
   • Press Control (Windows) or Command (Macintosh) then double-click the image placeholder.
   • Right-click (Windows) or Control-click (Macintosh) the image placeholder, then select Create Image In Fireworks.
4 Use Fireworks options to design the image.
Fireworks recognizes the following image placeholder settings you may have set while working with the image placeholder in Dreamweaver: image size (which correlates to Fireworks canvas size), image ID (which Fireworks uses as the default document name for the source file and export file you create), and text alignment. Fireworks also recognizes links and certain behaviors (such as swap image, pop-up menu, and set text) you attached to the image placeholder while working in Dreamweaver.

**Note:** Although Fireworks doesn’t show links you’ve added to an image placeholder, they are preserved. If you draw a hotspot and add a link in Fireworks, it will not delete the link you added to the image placeholder in Dreamweaver; however, if you cut out a slice in Fireworks in the new image, Fireworks will delete the link in the Dreamweaver document when you replace the image placeholder.

Fireworks doesn’t recognize the following image placeholder settings: image alignment, color, Vspace and Hspace, and maps. They are disabled in the image placeholder Property inspector.

5. When you finish, click Done to display the save prompt.

6. In the Save In text box, select the folder you defined as your Dreamweaver local site folder.

If you named the image placeholder when you inserted it in the Dreamweaver document, Fireworks populates the File Name box with that name. You can change the name.

7. Click Save to save the PNG file.

The Export dialog box appears. Use this dialog box to export the image as a GIF or JPEG file, or, in the case of sliced images, as HTML and images.

8. For Save In, select the Dreamweaver local site folder.

The Name box automatically displays the name you used for the PNG file. You can change the name.

9. For

10. Save As

11. Type, select the type of file or files you want to export; for example, Images Only or HTML And Images.

12. Click Save to save the exported file.

The file is saved, and focus returns to Dreamweaver. In the Dreamweaver document, the exported file or Fireworks table replaces the image placeholder.

### About Fireworks pop-up menus

Fireworks lets you quickly and easily create CSS-based pop-up menus.

In addition to being extensible and fast to download, the pop-up menus you create with Fireworks give you the following advantages:

- The menu items can be indexed by search engines.
- The menu items can be read by screen readers, making your pages more accessible.
- The code generated by Fireworks complies to standards and can be validated.

You can edit Fireworks pop-up menus with Dreamweaver or with Fireworks, but not both. Changes made in Dreamweaver are not preserved in Fireworks.
Edit Fireworks pop-up menus in Dreamweaver

You can create a pop-up menu in Fireworks 8 or later and then edit it with Dreamweaver or with Fireworks (using roundtrip editing), but not with both. If you edit your menus in Dreamweaver and then edit them in Fireworks, you will lose all your previous edits except for the text content.

If you prefer to edit your menus with Dreamweaver, you can use Fireworks to create the pop-up menu and then use Dreamweaver exclusively to edit and customize the menu.

If you prefer to edit the menus in Fireworks, you can use the roundtrip editing feature in Dreamweaver, but you should not edit the menus directly in Dreamweaver.

1. In Dreamweaver, select the Fireworks table that contains the pop-up menu, and then click Edit in the Property inspector.

   The source PNG file opens in Fireworks.

2. In Fireworks, edit the menu with the Pop-up Menu Editor, and then click Done on the Fireworks toolbar.

   Fireworks sends the edited pop-up menu back to Dreamweaver.

If you created a pop-up menu in Fireworks MX 2004 or earlier, you can edit it in Dreamweaver using the Show Pop-Up Menu dialog box, available from the Behaviors panel.

Edit a pop-up menu created in Fireworks MX 2004 or earlier

1. In Dreamweaver, select the hotspot or image that triggers the pop-up menu.

2. In the Behaviors panel (Shift+F3), double-click Show Pop-Up Menu in the Actions list.

3. Make your changes in the Pop-Up Menu dialog box and click OK.

More Help topics

“Apply the Show Pop-Up Menu behavior” on page 344

Specify launch-and-edit preferences for Fireworks source files

When you use Fireworks to edit images, the images in your web pages are normally exported by Fireworks from a source PNG file. When you open an image file in Dreamweaver to edit it, Fireworks automatically opens the source PNG file, prompting you to locate the PNG file if it cannot be found. If you prefer, you can set preferences in Fireworks to have Dreamweaver open the inserted image, or you can have Fireworks give you the option of using the inserted image file or the Fireworks source file every time you open an image in Dreamweaver.

Note: Dreamweaver recognizes the Fireworks launch-and-edit preferences only in certain cases. Specifically, you must be opening and optimizing an image that is not part of a Fireworks table and contains a correct Design Notes path to a source PNG file.

1. In Fireworks, select Edit > Preferences (Windows) or Fireworks > Preferences (Macintosh) and then click the Launch And Edit tab (Windows) or select Launch And Edit from the pop-up menu (Macintosh).

2. Specify the preference options to use when editing or optimizing Fireworks images placed in an external application:

   Always Use Source PNG  Automatically opens the Fireworks PNG file that is defined in the Design Note as the source of the placed image. Updates are made to the source PNG file and its corresponding placed image.

   Never Use Source PNG  Automatically opens the placed Fireworks image, whether or not a source PNG file exists. Updates are made to the placed image only.
**Ask When Launching** Displays a message asking whether to open the source PNG file. You can also specify global launch-and-edit preferences from this message.

**Insert Fireworks HTML code in a Dreamweaver document**
From Fireworks, you can use the Export command to export and save optimized images and HTML files to a location inside a Dreamweaver site folder. You can then insert the file in Dreamweaver. Dreamweaver lets you insert Fireworks-generated HTML code, complete with associated images, slices, and JavaScript, into a document.

1 In Dreamweaver document, place the insertion point where you want to insert the Fireworks HTML code.
2 Do one of the following:
   - Select Insert > Image Objects > Fireworks HTML.
   - In the Common category of the Insert panel, click the Images button and choose Insert Fireworks HTML from the popup menu.
3 Click Browse to select a Fireworks HTML file.
4 If you will have no further use for the file, select Delete File After Insertion. Selecting this option has no effect on the source PNG file associated with the HTML file.

*Note:* If the HTML file is on a network drive, it is permanently deleted—not moved to the Recycle Bin or Trash.

5 Click OK to insert the HTML code, along with its associated images, slices, and JavaScript, into the Dreamweaver document.

**Paste Fireworks HTML code into Dreamweaver**
A fast way to place Fireworks-generated images and tables in Dreamweaver is to copy and paste Fireworks HTML code directly into a Dreamweaver document.

**Copy and paste Fireworks HTML code into Dreamweaver**
1 In Fireworks, select Edit > Copy HTML Code.
2 Follow the wizard as it guides you through the settings for exporting your HTML and images. When prompted, specify your Dreamweaver site folder as the destination for the exported images.

The wizard exports the images to the specified destination and copies the HTML code to the Clipboard.

3 In Dreamweaver document, place the insertion point where you want to paste the HTML code, and select Edit > Paste Fireworks HTML.

All HTML and JavaScript code associated with the Fireworks files you exported is copied into the Dreamweaver document, and all links to images are updated.

**Export and paste Fireworks HTML code into Dreamweaver**
1 In Fireworks, select File > Export.
2 Specify your Dreamweaver site folder as the destination for the exported images.
3 In the Export pop-up menu, select HTML And Images.
4 In the HTML pop-up menu, select Copy To Clipboard, and then click Export.
In the Dreamweaver document, place the insertion point where you want to paste the exported HTML code, and select Edit > Paste Fireworks HTML.

All HTML and JavaScript code associated with the Fireworks files you exported is copied into the Dreamweaver document, and all links to images are updated.

**Update Fireworks HTML code placed in Dreamweaver**

In Fireworks, the File > Update HTML command provides an alternative to the launch-and-edit technique for updating Fireworks files placed in Dreamweaver. With Update HTML, you can edit a source PNG image in Fireworks and then automatically update any exported HTML code and image files placed in a Dreamweaver document. This command lets you update Dreamweaver files even when Dreamweaver is not running.

1. In Fireworks, open the source PNG file and make your edits.
2. Select File > Save.
3. In Fireworks, select File > Update HTML.
4. Navigate to the Dreamweaver file containing the HTML you want to update, and click Open.
5. Navigate to the folder destination where you want to place the updated image files, and click Select (Windows) or Choose (Macintosh).

Fireworks updates the HTML and JavaScript code in the Dreamweaver document. Fireworks also exports updated images associated with the HTML and places the images in the specified destination folder.

If Fireworks cannot find matching HTML code to update, it gives you the option of inserting new HTML code into the Dreamweaver document. Fireworks places the JavaScript section of the new code at the beginning of the document and places the HTML table or link to the image at the end.

**Create a web photo album**

The Create Web Photo Album feature has been deprecated as of Dreamweaver CS5.

**Working with Photoshop and Dreamweaver**

**About Photoshop integration**

You can insert Photoshop image files (PSD format) into web pages in Dreamweaver and let Dreamweaver optimize them as web-ready images (GIF, JPEG, and PNG formats). When you do this, Dreamweaver inserts the image as a Smart Object and maintains a live connection to the original PSD file.

You can also paste all or part of a multi-layered or multi-sliced Photoshop image into a web page in Dreamweaver. When you copy and paste from Photoshop, however, no live connection to the original file is maintained. To update the image, make your changes in Photoshop, and copy and paste again.

*Note: If you use this integration feature often, you may want to store your Photoshop files in your Dreamweaver site for easier access. If you do, be sure to cloak them to avoid exposure of the original assets, as well as unnecessary transfers between the local site and the remote server.*

For a tutorial about the Smart Object workflow in Photoshop and Dreamweaver, see [www.adobe.com/go/lrvid4043_dw](http://www.adobe.com/go/lrvid4043_dw).
About Smart Objects and Photoshop-Dreamweaver workflows

There are two main workflows for working with Photoshop files in Dreamweaver: the copy/paste workflow, and the Smart Objects workflow.

Copy/paste workflow
The copy/paste workflow lets you select slices or layers in a Photoshop file, and then use Dreamweaver to insert them as web-ready images. If you want to update the content later on, however, you must open the original Photoshop file, make your changes, copy your slice or layer to the clipboard again, and then paste the updated slice or layer into Dreamweaver. This workflow is only recommended when you want to insert part of a Photoshop file (for example, a section of a design comp) as an image on a web page.

Smart Objects workflow
When working with complete Photoshop files, Adobe recommends the Smart Objects workflow. A Smart Object in Dreamweaver is an image asset placed on a web page that has a live connection to an original Photoshop (PSD) file. In Dreamweaver Design view, a Smart Object is denoted by an icon in the upper left corner of the image.

![Smart Object](image)

When the web image (that is, the image on the Dreamweaver page) is out of sync with the original Photoshop file, Dreamweaver detects that the original file has been updated, and displays one of the Smart Object icon’s arrows in red. When you select the web image in Design view and click the Update from Original button in the Property inspector, the image updates automatically, reflecting any changes that you made to the original Photoshop file.

When you use the Smart Objects workflow, you do not need to open Photoshop to update a web image. Additionally, any updates you make to a Smart Object in Dreamweaver are non-destructive. That is, you can change the web version of the image on your page while keeping the original Photoshop image intact.

You can also update a Smart Object without selecting the web image in Design view. The Assets panel lets you update all Smart Objects, including images that might not be selectable in the Document window (for example, CSS background images).
Image optimization settings
For both the copy/paste and the Smart Object workflows, you can specify optimization settings in the Image Preview dialog box. This dialog box lets you set things like file format, image quality, and so on. If you are copying a slice or a layer for the first time, or inserting a Photoshop file as a Smart Object for the first time, Dreamweaver displays this dialog so that you can easily create the web image.

If you copy and paste an update to a particular slice or layer, Dreamweaver remembers the original settings and recreates the web image with those settings. Likewise, when you update a Smart Object using the Property inspector, Dreamweaver uses the same settings you used when you first inserted the image. You can change an image’s settings at any time by selecting the web image in Design view, and then clicking the Edit Image Settings button in the Property inspector.

Storing Photoshop files
If you've inserted a web image, and have not stored the original Photoshop file in your Dreamweaver site, Dreamweaver recognizes the path to the original file as an absolute local file path. (This is true for both the copy/paste and Smart Object workflows.) For example, if the path to your Dreamweaver site is C:\Sites\mySite, and your Photoshop file is stored in C:\Images\Photoshop, Dreamweaver will not recognize the original asset as part of the site called mySite. This will cause problems if you ever want to share the Photoshop file with other team members because Dreamweaver will only recognize the file as being available on a particular local hard drive.

If you store the Photoshop file inside your site, however, Dreamweaver establishes a site-relative path to the file. Any user with access to the site will also be able to establish the correct path to the file, assuming that you have also provided the original file for them to download.

For a video tutorial on the Smart Objects workflow in Photoshop and Dreamweaver, see www.adobe.com/go/lrvid4043_dw.

Create a Smart Object
When you insert a Photoshop image (PSD file) into your page, Dreamweaver creates a Smart Object. A Smart Object is a web-ready image that maintains a live connection to the original Photoshop image. Whenever you update the original image in Photoshop, Dreamweaver gives you the option of updating the image in Dreamweaver with the click of a button.

1. In Dreamweaver (Design or Code view), place the insertion point on your page where you want the image inserted.
2. Select Insert > Image.
   
   You can also drag the PSD file to the page from the Files panel if you’re storing your Photoshop files in your website. If you do so, you’ll skip the next step.

3. Locate your Photoshop PSD image file in the Select Image Source dialog box by clicking the Browse button and navigating to it.
4. In the Image Preview dialog box that appears, adjust optimization settings as needed and click OK.
5. Save the web-ready image file to a location within your website’s root folder.

Dreamweaver creates the Smart Object based on the selected optimization settings and places a web-ready version of the image on your page. The Smart Object maintains a live connection to the original image and lets you know when the two are out of sync.

Note: If you decide later that you want to change the optimization settings for an image placed in your pages, you can select the image, click the Edit button in the Property inspector.
Note: Image Settings

Note: button in the Property inspector, and make changes in the Image Preview dialog box. Changes made in the Image Preview dialog box are applied non-destructively. Dreamweaver never modifies the original Photoshop file, and always re-creates the web image based on the original data.

For a video tutorial about working with Photoshop Smart Objects, see www.adobe.com/go/lrvid4043_dw.

Update a Smart Object

If you change the Photoshop file to which your Smart Object is linked, Dreamweaver notifies you that the web-ready image is out of sync with the original. In Dreamweaver, Smart Objects are denoted by an icon at the upper left corner of the image. When the web-ready image in Dreamweaver is in sync with the original Photoshop file, both of the arrows in the icon are green. When the web-ready image is out of sync with the original Photoshop file, one of the icon's arrows turns red.

❖ To update a Smart Object with the current contents of the original Photoshop file, select the Smart Object in the Document window, and then click the Update from Original button in the Property inspector.

Note: You do not need Photoshop installed to make the update from Dreamweaver.

Update multiple Smart Objects

You can update multiple Smart Objects at once using the Assets panel. The Assets panel also lets you see Smart Objects that might not be selectable in the Document window (for example, CSS background images).

1 In the Files panel, click the Assets tab to view site assets.

2 Make sure that Images view is selected. If it isn’t, click the Images button.

3 Select each image asset in the Assets panel. When you select a Smart Object, you’ll see the Smart Object icon in the upper left corner of the image. Regular images do not have this icon.

4 For each Smart Object that you want to update, right-click the filename and select Update from Original. You can also Control-click to select multiple filenames and update them all at once.

Note: You do not need Photoshop installed to make the update from Dreamweaver.

Resize a Smart Object

You can resize a Smart Object in the Document window just as you would any other image.

1 Select the Smart Object in the Document window and drag the resize handles to resize the image. You can maintain the width and height proportions by holding down the Shift key as you drag.

2 Click the Update from Original button in the Property inspector.

When you update the Smart Object, the web image non-destructively re-renders at the new size, based on the current contents of the original file, and the original optimization settings.

Edit a Smart Object’s original Photoshop file

After you create a Smart Object on your Dreamweaver page, you can edit the original PSD file in Photoshop. After you make your changes in Photoshop, you can then easily update the web image in Dreamweaver.

Note: Make sure that you have Photoshop set as your primary external image editor.

1 Select the Smart Object in the Document window.
2 Click the Edit button in the Property inspector.
3 Make your changes in Photoshop and save the new PSD file.
4 In Dreamweaver, select the Smart Object again and click the Update from Original button.

Note: If you changed the size of your image in Photoshop, you need to reset the size of the web image in Dreamweaver. Dreamweaver updates a Smart Object based only on the contents of the original Photoshop file, and not its size. To sync the size of a web image with the size of the original Photoshop file, right-click the image and select Reset Size To Original.

**Smart Object states**
The following table lists the various states for Smart Objects.

<table>
<thead>
<tr>
<th>SmartObject state</th>
<th>Description</th>
<th>Recommended action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Images synched</td>
<td>The web image is in sync with the current contents of the original Photoshop file. Width and height attributes in the HTML code match the dimensions of the web image.</td>
<td>None</td>
</tr>
<tr>
<td>Original asset modified</td>
<td>The original Photoshop file has been modified after the creation of the web image in Dreamweaver.</td>
<td>Use the Update From Original button in the Property inspector to sync the two images.</td>
</tr>
<tr>
<td>Dimensions of web image are different from selected HTML width and height</td>
<td>The width and height attributes in the HTML code are different from the width and height dimensions of the web image that Dreamweaver created upon insertion. If the web image's dimensions are smaller than the selected HTML width and height values, the web image can appear pixelated.</td>
<td>Use the Update From Original button in the Property inspector to re-create the web image from the original Photoshop file. Dreamweaver uses the currently specified HTML width and height dimensions when it re-creates the image.</td>
</tr>
<tr>
<td>Dimensions of original asset are too small for selected HTML width and height</td>
<td>The width and height attributes in the HTML code are larger than the width and height dimensions of the original Photoshop file. The web image can appear pixelated.</td>
<td>Don't create web images with dimensions larger than the dimensions of the original Photoshop file.</td>
</tr>
<tr>
<td>Original asset not found</td>
<td>Dreamweaver cannot find the original Photoshop file specified in the Original text box of the Property inspector.</td>
<td>Correct the file path in the Original text box of the Property inspector, or move the Photoshop file to the location that's currently specified.</td>
</tr>
</tbody>
</table>

**Copy and paste a selection from Photoshop**
You can copy all or some of a Photoshop image and paste the selection into your Dreamweaver page as a web-ready image. You can copy a single layer or a set of layers for a selected area of the image or you can copy a slice of the image. When you do this, however, Dreamweaver does not create a Smart Object.

Note: While the Update from Original functionality is not available for pasted images, you can still open and edit the original Photoshop file by selecting the pasted image and clicking the Edit button in the Property inspector.

1 In Photoshop, do one of the following:
   - Copy all or part of a single layer by using the Marquee tool to select the portion you want to copy, and then choose Edit > Copy. This copies only the active layer for the selected area into the clipboard. If you have layer-based effects, they are not copied.
   - Copy and merge multiple layers by using the Marquee tool to select the portion you want to copy, and then choose Edit > Copy Merged. This flattens and copies all the selected area’s active and lower layers into the clipboard. If you have layer-based effects associated with any of these layers, they are copied.
   - Copy a slice by using the Slice Select tool to select the slice, and then choose Edit > Copy. This flattens and copies all the slice’s active and lower layers into the clipboard.
You can choose Select > All to quickly select all of an image for copying.

2 In Dreamweaver (Design or Code view), place the insertion point on your page where you want the image inserted.

3 Select Edit > Paste.

4 In the Image Preview dialog box, adjust optimization settings as needed and click OK.

5 Save the web-ready image file to a location within your website’s root folder.

Dreamweaver defines the image according to your optimization settings and places a web-ready version of your image in your page. Information about the image, such as the location of the original PSD source file, is saved in a Design Note, regardless of whether you have enabled Design Notes for your site. The Design Note allows you to return to edit the original Photoshop file from Dreamweaver.

For a tutorial on copying and pasting between different applications, including Dreamweaver and Photoshop, see www.adobe.com/go/vid0193.

Edit pasted images

After you paste Photoshop images in your Dreamweaver pages, you can edit the original PSD file in Photoshop. When using the copy/paste workflow, Adobe recommends that you always make your edits to the original PSD file (rather than the web-ready image itself), and then repaste to maintain single sourcing.

Note: Make sure that you have Photoshop set as your primary external image editor for the file type you want to edit.

1 In Dreamweaver, select a web-ready image that was originally created in Photoshop and do one of the following:
   • Click the Edit button in the image’s Property inspector.
   • Press Control (Windows) or Command (Macintosh) as you double-click the file.
   • Right-click (Windows) or Control-click (Macintosh) an image, choose Edit Original With from the context menu, and then choose Photoshop.

Note: This assumes that Photoshop is set as the primary external image editor for PSD image files. You may also want to set Photoshop as the default editor for JPEG, GIF, and PNG file types.

2 Edit the file in Photoshop.

3 Return to Dreamweaver and paste the updated image or selection into your page.

If you want to reoptimize the image at any time, you can select the image and click the Edit Image Settings button in the Property inspector.

Setting Image Preview dialog box options

Image Preview dialog box options

When you create a Smart Object or paste a selection from Photoshop, Dreamweaver displays the Image Preview dialog box. (Dreamweaver also displays this dialog box for any other kind of image if you select the image and click the Edit Image Settings button in the Property inspector.) This dialog box lets you define and preview settings for web-ready images using the right mix of color, compression, and quality.
A web-ready image is one that can be displayed by all modern web browsers and looks the same no matter what system or browser the viewer is using. When you insert a Photoshop image, the Image Preview dialog box lets you adjust various settings for optimal web publication. In general, the settings result in a trade-off between quality and file size.

### Image Preview dialog box

- **Options tab**: lets you define which file format to use and set preferences such as color.
- **File tab**: lets you set the scale factor and target file size of the image.
- **Preview panel**: lets you see a version of the image with your current settings.

Many image options are available in the Options tab and they vary depending on the file format you choose. Several sets of GIF and JPEG image options are available for your convenience in the Saved Settings pop-up menu.

#### JPEG image options

You can optimize a JPEG image by setting its compression and smoothing options. You cannot edit its color palette.

- **Quality**: Use the slider to increase or decrease the quality of the image. Better quality results in a larger file.
- **Smoothing**: Allows you to increase the smoothing as needed. Lower quality images may require a higher value.

**Note**: Whatever settings you select only affect the exported version of the image file. The original Photoshop PSD or Fireworks PNG file always remains untouched.
Progressive Browser Display Displays an image initially at low resolution and progressively increases the resolution during download. Not selected by default.

Sharpen Color Edges Allows you to get a higher quality image.

Matte Allows you to set the background of the image. You can maintain the transparency of a 32-bpc (bits per channel) PNG by clicking the transparency icon in the Matte dialog box. You can also use Matte to anti-alias soft-edged objects that lie directly above the canvas by matching the matte color to the target background.

Remove Unused Colors Reduces file size by removing colors not used in the image.

Optimize to Size Specifies the image size, in kilobytes. For 8-bpc images, the wizard attempts to achieve the requested file size by adjusting the number of colors or dithering.

GIF and PNG image options
In the Options tab, you can set a transparency value for individual colors in GIF and 8-bpc PNG images so that the background of the web page is visible through areas with those colors. Do this by adjusting the color palette on the left of the Options tab. PNG images that have 32-bpc format automatically contain transparency, though you won’t see a transparency option for 32-bpc PNGs in the Optimize panel.

Palette Set to Adaptive by default. Select one of the saved color palette settings from the pop-up menu if you want to use a preset set of options

Loss Set to 0 by default. Not applicable to PNG images.

Dither Approximates colors not in the current palette by alternating similar-colored pixels so that they appear to blend to the missing color. Dithering is especially helpful when exporting images with complex blends or gradients, or when exporting photographic images to an 8-bpc graphic format such as GIF. Not selected by default.

Note: Dithering can greatly increase file size.

Number Of Colors List Set to 256 by default. The number of colors is dependent on the current behavior of the palette. For example, the "Web 216" palette only displays 216 colors.

Color palette The display of colors varies depending on the selected palette behavior and maximum number of colors.

Palette Tools Click any pixel in the palette and then click these icons to change, add, or delete color, or to make a color transparent, web safe, or locked.

Select Transparency Color Icons These buttons allow you to select, add, or remove a palette color. For example, if you choose the Select Transparency Color option, you can click any pixel in the palette or on a point of color in the preview panel to render it transparent.

Transparency Pop-Up Menu Allows you to set index, alpha, or no transparency. A gray-and-white checkerboard on document previews denotes transparent areas. To see how your choices affect the image, choose 2-up or 4-up in the image preview and click an image other than the original.

• Index Use index transparency when exporting GIF images that contain transparent areas. With index transparency, you set specific colors to be transparent upon export. Index transparency turns on or turns off pixels with specific color values.

• Alpha Use alpha transparency when exporting 8-bpc PNG images that contain transparent areas. Alpha transparency allows gradient transparency and semi-opaque pixels.

Matte Lets you set the background of the image. You can maintain the transparency of a 32-bpc PNG by clicking the transparency icon in the Matte dialog box. You can also use Matte to anti-alias soft-edged objects that lie directly above the canvas by matching the matte color to the target background.

Remove Unused Colors Reduces file size by removing colors not used in the image.
**Interlaced Browser Display**  Displays an interlaced image initially at low resolution and progressively increases to full resolution during download. Not selected by default.

**Optimize To Size**  Lets you specify a size, in kilobytes, for the image. For 8-bpc images, the wizard attempts to achieve the requested file size by adjusting the number of colors or dithering.

**Saved settings**
Dreamweaver provides several option settings for your convenience. Depending on the saved settings you choose, the file-type-specific image options described above may change.

**GIF Web 216**  Forces all colors to web-safe colors. The color palette contains up to 216 colors.

**GIF Websnap 256**  Converts web-unsafe colors to their closest web-safe color. The color palette contains up to a maximum of 256 colors.

**GIF Websnap 128**  Converts web-unsafe colors to their closest web-safe color. The color palette contains up to 128 colors.

**GIF Adaptive 256**  A color palette that contains only the actual colors used in the graphic. The color palette contains up to a maximum of 256 colors.

**JPEG - Better Quality**  Sets quality to 80 and smoothing to 0, resulting in a high-quality but larger graphic.

**JPEG - Smaller File**  Sets quality to 60 and smoothing to 2, resulting in a graphic less than half the size of a Better Quality JPEG but with reduced quality.

**Optional** Change the image’s scale or export area options on the File tab

1 Select the File tab.

2 Shrink or expand the image in one of the following ways:
   - Specify a scale percentage.
   - Enter absolute pixel values for width or height.

3 Select Constrain to maintain the image’s original proportions as you rescale it.

4 Change the shape of the placed image by choosing the Export Area option and doing one of the following:
   - Drag the dotted border around the previewed image as needed. You can drag the image within the borders to move hidden areas into view.
   - Enter pixel coordinates for the image’s boundaries.

**Optional** Preview and adjust images in the Preview panel

1 In the Image Preview dialog box, select the Preview option if you want to see what the image looks like with your settings. If performance is an issue, you may want to deselect this option.

2 Select one of the saved color palette settings from the Saved Settings pop-up menu if you want to use a preset set of options.

3 If your image is larger than the preview area, use the pointer tool to grab the previewed image and pan it to see different parts.

4 Use the crop tool to reduce the image’s size. You may need to first zoom out to see the entire image.

5 Choose a value from the Zoom pop-up menu to expand or reduce your view of the previewed image. You can also choose the Zoom tool and click to zoom in; Alt-click (Windows) or Option-click (Macintosh) to zoom out.

6 You can preview two or four different optimizations by clicking the 2-up or 4-up button at the bottom of the preview panel and choosing different color palettes for each pane.
Note: The animation controls in the Image Preview dialog box are always disabled for Photoshop images.

Working with Flash and Dreamweaver

Edit a SWF file from Dreamweaver in Flash

If you have both Flash and Dreamweaver installed, you can select a SWF file in a Dreamweaver document and use Flash to edit it. Flash does not edit the SWF file directly; it edits the source document (FLA file) and re-exports the SWF file.

1 In Dreamweaver, open the Property inspector (Window > Properties).
2 In the Dreamweaver document, do one of the following:
   • Click the SWF file placeholder to select it; then in the Property inspector click Edit.
   • Right-click (Windows) or Control-click (Macintosh) the placeholder for the SWF file, and select Edit With Flash from the context menu.

Dreamweaver switches the focus to Flash, and Flash attempts to locate the Flash authoring file (FLA) for the selected SWF file. If Flash cannot locate the Flash authoring file, you are prompted to locate it.

Note: If the FLA file or SWF file is locked, check out the file in Dreamweaver.

3 In Flash, edit the FLA file. The Flash Document window indicates that you are modifying the file from within Dreamweaver.
4 When you finish making edits, click Done.

Flash updates the FLA file, re-exports it as a SWF file, closes, and then returns the focus to the Dreamweaver document.

Note: To update the SWF file and keep Flash open, in Flash select File > Update for Dreamweaver.

5 To view the updated file in the document, click Play in the Dreamweaver Property inspector or press F12 to preview your page in a browser window.

Working with Adobe Bridge and Dreamweaver

About Adobe Bridge

Dreamweaver provides seamless integration with Adobe Bridge, the cross-platform file browser included with Adobe Creative Suite 5 components. Adobe Bridge helps you locate, organize, and browse the assets you need to create print, web, video, and mobile content. You can start Adobe Bridge from any Creative Suite component (except Acrobat 9), and use it to access both Adobe and non-Adobe asset types.

From Adobe Bridge, you can:

• Preview, search, sort, and process files without opening individual Creative Suite applications. You can also edit metadata for files and use Adobe Bridge to place files into your documents, projects, or compositions.
• Import and edit photos from a digital camera card, group related photos into stacks, and open and edit Camera Raw files without starting Photoshop.
• Perform automated tasks, such as batch commands.
• Synchronize color settings across color-managed Creative Suite components.

More Help topics
Creative Suite 5 - Bridge

Start Adobe Bridge from Dreamweaver
You can start Adobe Bridge from Dreamweaver to view your files before placing them or dragging them in your page layout.
❖ You can start Adobe Bridge in several different ways:
• Select File >
• Browse In Bridge
• .
• Click the
• Browse In Bridge
• button in the Standard toolbar.
• Press the
• Browse In Bridge
• shortcut from the keyboard: Control+Alt+O (Windows) or Command+Option+O (Macintosh).
Adobe Bridge opens in File Browser mode, showing the contents of the last-opened folder in Dreamweaver. If Adobe Bridge was already open, it becomes the active window.

Note: Adobe Bridge is only installed with Dreamweaver CS5 when you install Creative Suite CS5; it is not included with the standalone version of Dreamweaver CS5. However, Adobe Bridge was included if you previously installed Dreamweaver CS3 or CS4, so if you still have Adobe Bridge installed from those versions, Dreamweaver CS5 can access it and use it.

Placing files into Dreamweaver from Adobe Bridge
You can insert files into Dreamweaver pages by inserting them or by dragging them from Adobe Bridge into your page. The Dreamweaver document in which you want to insert the file must be open and in Design view to use this feature.

You can insert most file types into your pages, but Dreamweaver handles them differently:
• If you insert a web-ready image (JPEG, GIF, or PNG), Dreamweaver inserts the image files directly into your page and places a copy in your website’s default images folder.
• If you insert a Photoshop PSD file, you need to define its optimization settings before Dreamweaver can place it in your page.
• If you insert a non-image file, such as mp3, PDF, or a file with an unknown file type, Dreamweaver inserts a link to the source file.
• If you insert an HTML file, Dreamweaver inserts a link to the source file.
• (Windows only) If you have Microsoft Office installed and you are inserting a Microsoft Word or Excel file, you must specify if you want to insert the file itself or insert a link to the source file. If you want to insert the file, you can specify how much of the file’s formatting you want to keep.
More Help topics
“Create a Smart Object” on page 355
“Working with Photoshop and Dreamweaver” on page 353

Place an Adobe Bridge file in your page
1 In Dreamweaver (Design view), place the insertion point on your page where you want the file inserted.
2 In Adobe Bridge, select the file and choose File > Place In Dreamweaver.
3 If the file is not in your site’s root folder, you are prompted to copy it there.
4 If you have set Edit > Preferences > Accessibility to show attributes when inserting images, the Image Tag Accessibility Attributes dialog box is displayed when you insert web-ready images such as JPEG and GIF.

Note: If your insertion point is in Code view, Adobe Bridge starts as usual but cannot place the file. You can only place files in Design view.

Drag a file from Bridge into your page
1 In Dreamweaver (Design view), place the insertion point on your page where you want the image inserted.
2 Start Adobe Bridge if it isn’t already open.
3 In Adobe Bridge, select one or more files and drag them into your Dreamweaver page.
4 If a file is not in your site’s root folder, you are prompted to copy it there.
5 If you have set Edit > Preferences > Accessibility to show attributes when inserting images, the Image Tag Accessibility Attributes dialog box is displayed when you insert web-safe images such as JPEG and GIF.

Note: If your insertion point is in Code view, Adobe Bridge starts as usual but cannot place the file. You can only place files in Design view.

Start Dreamweaver from Adobe Bridge
❖ Select a file in Adobe Bridge and do one of the following:
  • Select File >
  • Open With
  • > Adobe Dreamweaver.
  • Right-click (Control-click on Macintosh) and then choose
  • Open With
  • > Adobe Dreamweaver from the context menu.

Note: If Dreamweaver is already open, this action makes the program active. If Dreamweaver is not open, Adobe Bridge starts it, bypassing the Welcome Screen.
Working with Device Central and Dreamweaver

Using Adobe Device Central with Dreamweaver

Device Central enables Dreamweaver web designers and developers to preview how Dreamweaver files will look on a wide variety of mobile devices. Device Central uses Opera’s Small-Screen Rendering™ to give designers and developers an impression of how their web page looks on a small screen. It also enables designers and developers to test if their CSS behaves correctly.

For example, a web developer may have a customer who wants to make a website available on mobile phones. The web developer can use Dreamweaver to create preliminary pages and use Device Central to test how those pages look on different devices.

More Help topics

Adobe Device Central Help

Preview mobile content with Adobe Device Central and Dreamweaver

To preview pages created in Dreamweaver on various mobile devices, use Device Central with its built-in Opera Small-Screen Rendering feature. Different devices have different browsers installed, but the preview can give a good impression of how content will look and behave on a selected device.

1. Start Dreamweaver.
2. Open a file.
3. Do one of the following:
   - Select File > Preview in Browser > Device Central.
   - On the document window toolbar, click and hold the Preview/Debug In browser button and select Preview In Device Central.

The file is displayed in the Device Central Emulator tab. To continue testing, double-click the name of a different device in the Device Sets or Available Devices lists.

Tips for creating Dreamweaver web content for mobile devices

Device Central previews web pages created in Dreamweaver using Opera’s Small-Screen Rendering. This preview can give you a good idea of what a web page looks like on a mobile device.

Note: Opera’s Small-Screen Rendering may or may not be pre-installed on any individual emulated device. Device Central simply gives a preview of how the content would look if Opera’s Small-Screen Rendering was installed.

Use the tips below to ensure that web pages created in Dreamweaver display well on mobile devices.

- If you use the Adobe® Spry framework to develop content, add the following line of HTML to your pages so they can render CSS and execute JavaScript™ correctly in Device Central:
Opera’s Small-Screen Rendering does not support frames, pop-ups, underlining, strikethrough, overlining, blink, and marquee. Try to avoid these design elements.

- Keep web pages for mobile devices simple. In particular, use a minimum number of fonts, font sizes, and colors.
- Scaling down image sizes and reducing the number of colors required increase the chances that the images will appear as intended. Use CSS or HTML to specify an exact height and width for each image used. Provide alt text for all images.

**Note:** The Opera software website is a good source of information about optimizing web pages for mobile devices.

For more tips and techniques for creating content for mobile phones and devices, see [www.adobe.com/go/learn_cs_mobilewiki_en](http://www.adobe.com/go/learn_cs_mobilewiki_en).

---

**Working with ConnectNow and Dreamweaver**

**Working with ConnectNow**

Adobe® ConnectNow provides you with a secure, personal online meeting room where you can meet and collaborate with others via the web in real time. With ConnectNow, you can share and annotate your computer screen, send chat messages, and communicate using integrated audio. You can also broadcast live video, share files, capture meeting notes, and control an attendee’s computer.

You can access ConnectNow directly from the application interface.

2. In the Sign In to Adobe CS Live dialog box, enter your email address and password, and click Sign In.
3. If you don’t have an Adobe ID, click the Create Adobe ID button.
4. To share your screen, click the Share My Computer Screen button at the center of the ConnectNow application window.

For complete instructions on using ConnectNow, see Adobe ConnectNow Help.

For a video tutorial about using ConnectNow, see Using ConnectNow to share your screen (7:12). (This demonstration is in Dreamweaver.)
AIR Extension for Dreamweaver

The Adobe® AIR® Extension for Dreamweaver® lets you transform a web-based application into a desktop application. Users can then run the application on their desktops and, in some cases, without an Internet connection.

You can use the extension with Dreamweaver CS3 and later. It is not compatible with Dreamweaver 8.

Note: Adobe AIR

Note: does not support Adobe InContext Editing. If you use the AIR Extension for Dreamweaver to export an application that contains InContext Editing regions, the InContext Editing functionality will not work.

Installing the AIR Extension for Dreamweaver

The AIR Extension for Dreamweaver helps you to create rich Internet applications for the desktop. For example, you might have a set of web pages that interact with each other to display XML data. You can use the Adobe AIR Extension for Dreamweaver to package this set of pages into a small application that can be installed on a user’s computer. When the user runs the application from their desktop, the application loads and displays the website in its own application window, independent of a browser. The user can then browse the website locally on their computer without an Internet connection.

Dynamic pages such as Adobe® ColdFusion® and PHP pages won’t run in Adobe AIR.

The runtime only works with HTML and JavaScript. However, you can use JavaScript in your pages to call any web service exposed on the Internet—including ColdFusion- or PHP-generated services—with Ajax methods such as XMLHTTPRequest or Adobe AIR-specific APIs.

System requirements

To use the Adobe AIR Extension for Dreamweaver, the following software must be installed and properly configured:

- Dreamweaver CS3 or later
- Adobe® Extension Manager CS3 or later
- Java JRE 1.4 or later (necessary for creating the Adobe AIR file). The Java JRE is available at http://java.sun.com/.

The preceding requirements are only for creating and previewing Adobe AIR applications in Dreamweaver. To install and run an Adobe AIR application on the desktop, you must also install Adobe AIR.
on your computer. To download the runtime, see www.adobe.com/go/air.

**Install the Adobe AIR Extension for Dreamweaver**

2. Double-click the .mxp extension file in Windows Explorer.
3. Follow the onscreen instructions to install the extension.
4. After you’re finished, restart Dreamweaver.
   
   For information about using the Adobe AIR Extension for Dreamweaver, see Using the AIR Extension for Dreamweaver.

**Creating an AIR application in Dreamweaver**

To create an HTML-based AIR application in Dreamweaver, you select an existing site to package as an AIR application.

1. Make sure that the web pages you want to package into an application are contained in a defined Dreamweaver site.
2. In Dreamweaver, open the home page of the set of pages you want to package.
3. Select Site > Air Application Settings.
4. Complete the AIR Application and Installer Settings dialog box, and then click Create AIR File.
   
   For more information, see the dialog box options listed below.

   The first time you create an Adobe AIR file, Dreamweaver creates an application.xml file in your site root folder. This file serves as a manifest, defining various properties of the application.

The following describes the options in the AIR Application and Installer Settings dialog box:

- **Application File Name** is the name used for the application executable file. By default, the extension uses the name of the Dreamweaver site to name the file. You can change the name if you prefer. However, the name must contain only valid characters for files or folder names. (That is, it can only contain ASCII characters, and cannot end with a period.) This setting is required.

- **Application Name** is the name that appears on installation screens when users install the application. Again, the extension specifies the name of the Dreamweaver site by default. This setting does not have character restrictions, and is not required.

- **Application ID** identifies your application with a unique ID. You can change the default ID if you prefer. Do not use spaces or special characters in the ID. The only valid characters are 0-9, a-z, A-Z, . (dot), and - (dash). This setting is required.

- **Version** specifies a version number for your application. This setting is required.
**Initial Content** specifies the start page for your application. Click the Browse button to navigate to your start page and select it. The chosen file must reside inside the site root folder. This setting is required.

**Description** lets you specify a description of the application to display when the user installs the application.

**Copyright** lets you specify a copyright that is displayed in the About information for Adobe AIR applications installed on the Macintosh. This information is not used for applications installed on Windows.

**Window Style** specifies the window style (or chrome) to use when the user runs the application on their computer. System chrome surrounds the application with the operating system standard window control. Custom chrome (opaque) eliminates the standard system chrome and lets you create a chrome of your own for the application. (You build the custom chrome directly in the packaged HTML page.) Custom chrome (transparent) is like Custom chrome (opaque), but adds transparent capabilities to the edges of the page, allowing for application windows that are not rectangular in shape.

**Window Size** specifies the dimensions of your application window when it opens.

**Icon** lets you select custom images for the application icons. (The default images are Adobe AIR images that come with the extension.) To use custom images, click the Select Icon Images button. Then, in the Icon Images dialog box that appears, click the folder for each icon size and select the image file you want to use. AIR only supports PNG files for application icon images.

*Note: Selected custom images must reside in the application site, and their paths must be relative to the site root.*

**Associated File Types** lets you associate file types with your application. For more information, see the section that follows.

**Application Updates** determines whether the Adobe AIR Application Installer or the application itself performs updates to new versions of Adobe AIR applications. The check box is selected by default, which causes the Adobe AIR Application Installer to perform updates. If you want your application to perform its own updates, deselect the checkbox. Keep in mind that if you deselect the checkbox, you then need to write an application that can perform updates.

**Included Files** specifies which files or folders to include in your application. You can add HTML and CSS files, image files, and JavaScript library files. Click the Plus (+) button to add files, and the folder icon to add folders. You should not include certain files such as _mmServerScripts, _notes, and so on. To delete a file or folder from your list, select the file or folder and click the Minus (-) button.

**Digital Signature** Click Set to sign your application with a digital signature. This setting is required. For more information, see the section that follows.

**Program Menu Folder** specifies a subdirectory in the Windows Start Menu where you want the application’s shortcut created. (Not applicable on Macintosh.)
**Destination** specifies where to save the new application installer (.air file). The default location is the site root. Click the Browse button to select a different location. The default file name is based on the site name with an .air extension added to it. This setting is required.

The following is an example of the dialog box with some basic options set:

![AIR Application and Installer Settings dialog box](image)

**Signing an application with a digital certificate**

A digital signature provides an assurance that the code for an application has not been altered or corrupted since its creation by the software author. All Adobe AIR applications require a digital signature, and can’t be installed without one. You can sign your application with a purchased digital certificate, create your own certificate, or prepare an Adobe AIRI file (an Adobe AIR intermediate file) that you’ll sign at a later time.

1. In the AIR Application and Installer Settings dialog box, click the Set button next to the Digital Signature option.
In the Digital Signature dialog box, do one of the following:

- To sign an application with a pre-purchased digital certificate, click the Browse button, select the certificate, enter the corresponding password, and click OK.

- To create your own self-signed digital certificate, click the Create button and complete the dialog box. The certificate Type option refers to the level of security: 1024-RSA uses a 1024-bit key (less secure), and 2048-RSA uses a 2048-bit key (more secure). When you're finished click OK. Then enter the corresponding password in the Digital Signature dialog box and click OK.

- Select Prepare an AIR Intermediate (AIRI) package that will be signed later and click OK. This option lets you create an AIR Intermediate (AIRI) application without a digital signature. A user is not able to install the application, however, until you add a digital signature.

**About Timestamping**

When you sign an Adobe AIR application with a digital certificate, the packaging tool queries the server of a timestamp authority to obtain an independently verifiable date and time of signing. The timestamp obtained is embedded in the AIR file. As long as the signing certificate is valid at the time of signing, the AIR file can be installed, even after the certificate has expired. On the other hand, if no timestamp is obtained, the AIR file ceases to be installable when the certificate expires or is revoked.

By default, the Adobe AIR Extension for Dreamweaver obtains a timestamp when creating an Adobe AIR application. You can, however, turn timestamping off by deselecting the Timestamp option in the Digital Signature dialog box. (You might want to do this, for example, if a timestamping service is unavailable.) Adobe recommends that all publically distributed AIR files include a timestamp.

The default timestamp authority used by the AIR packaging tools is Geotrust. For more information on timestamping and digital certificates, see [Digitally signing an AIR file](#).

**Editing associated AIR file types**

You can associate different file types with your Adobe AIR application. For example, if you want file types with an .avf extension to open in Adobe AIR when a user double-clicks them, you can add the .avf extension to your list of associated file types.

1 In the AIR Application and Installer Settings dialog box, click the Edit list button next to the Associated File Types option.

2 In the Associated File Types dialog box, do one of the following:

- Select a file type and click the minus (-) button to delete the file type.
- Click the plus (+) button to add a file type.
  
  If you click the plus button to add a file type, the
File Type

Settings dialog box appears. Complete the dialog box and click OK to close it.

Following is a list of options:

- **Name** specifies the name of the file type that appears in the Associated File Types list. This option is required, and can only include alphanumeric ASCII characters (a-z, A-Z, 0-9) and dots (for example, adobe.VideoFile). The name must start with a letter. The maximum length is 38 characters.

- **Extension** specifies the extension of the file type. Do not include a preceding dot. This option is required, and can only include alphanumeric ASCII characters (a-z, A-Z, 0-9). The maximum length is 38 characters.

- **Description** lets you specify an optional description for the file type.

- **Content Type** specifies the MIME type or media type for the file (for example text/html, image/gif, and so on).

- **Icon File Locations** lets you select custom images for the associated file types. (The default images are Adobe AIR images that come with the extension.)

**Editing AIR application settings**

You can edit the settings for your Adobe AIR application at any time.

- Select Site > AIR Application Settings and make your changes.

**Previewing a web page in an AIR application**

You can preview an HTML page in Dreamweaver as it would appear in an Adobe AIR application. Previewing is useful when you want to see what a web page will look like in the application without having to create the entire application.

- On the Document toolbar, click the Preview/Debug in Browser button, and then select Preview In AIR.
  
  You can also press Ctrl+Shift+F12 (Windows) or Cmd+Shift+F12 (Macintosh).

**Using AIR code hinting and code coloring**

The Adobe AIR Extension for Dreamweaver also adds code hinting and code coloring for Adobe AIR language elements in Code view in Dreamweaver.

- Open an HTML or JavaScript file in Code view and enter
- Adobe AIR
- code.
Note: The code hinting mechanism only works inside `<script>` tags, or in `.js` files.

For more information on the Adobe AIR language elements, see the developer documentation in the rest of this guide.

**Accessing the Adobe AIR documentation**

The Adobe AIR extension adds a Help menu item in Dreamweaver that lets you access Developing AIR Applications with HTML and Ajax.

- Select Help >
- Adobe AIR
- Help.
Chapter 14: Creating and managing templates

About Dreamweaver templates

Understanding Dreamweaver templates
A template is a special type of document that you use to design a “fixed” page layout; you can then create documents based on the template that inherit its page layout. As you design a template, you specify as “editable” which content users can edit in a document based on that template. Templates enable template authors to control which page elements template users—such as writers, graphic artists, or other web developers—can edit. There are several types of template regions the template author can include in a document.

*Note:* Templates enable you to control a large design area and reuse complete layouts. If you want to reuse individual design elements, such as a site’s copyright information or a logo, create library items.

Using templates enables you to update multiple pages at once. A document that is created from a template remains connected to that template (unless you detach the document later). You can modify a template and immediately update the design in all documents based on it.

*Note:* Templates in Dreamweaver differ from templates in some other Adobe Creative Suite

*Note:* software in that page sections of Dreamweaver templates are fixed (or uneditable) by default.

More Help topics
“Managing assets and libraries” on page 106
“Creating a Dreamweaver template” on page 382

Types of template regions
When you save a document as a template, most regions of a document are locked. As a template author, you specify which regions of a template-based document will be editable by inserting editable regions or editable parameters in the template.

As you create the template, you can make changes to both editable and locked regions. In a document based on the template, however, a template user can make changes only in the editable regions; the locked regions can’t be modified.

There are four types of template regions:

- **An editable region** An unlocked region in a template-based document—a section a template user can edit. A template author can specify any area of a template as editable. For a template to be effective, it should contain at least one editable region; otherwise, pages based on the template can’t be edited.

- **A repeating region** A section of the document layout that is set so that the template user can add or delete copies of the repeating region in a document based on the template as necessary. For example, you can set a table row to repeat. Repeating sections are editable so that the template user can edit the content in the repeating element, while the design itself is under the control of the template author.
There are two types of repeating regions you can insert in a template: repeating region and repeating table.

**An optional region** A section of a template that holds content—such as text or an image—that may or may not appear in a document. In the template-based page, the template user usually controls whether the content is displayed.

**An editable tag attribute** Lets you unlock a tag attribute in a template, so the attribute can be edited in a template-based page. For example, you can “lock” which image appears in the document but let the template user set the alignment to left, right, or center.

**More Help topics**
- “Editing content in a template-based document” on page 402
- “Creating editable regions in templates” on page 385
- “Creating repeating regions in templates” on page 387
- “Using optional regions in templates” on page 389
- “Defining editable tag attributes in templates” on page 391

**Links in templates**
When you create a template file by saving an existing page as a template, the new template in the Templates folder, and any links in the file are updated so that their document-relative paths are correct. Later, when you create a document based on that template and save it, all the document-relative links are updated again to continue to point to the correct files.

When you add a new document-relative link to a template file, it’s easy to enter the wrong path name if you type the path into the link text box in the Property inspector. The correct path in a template file is the path from the Templates folder to the linked document, not the path from the template-based document’s folder to the linked document. Ensure that the correct paths for links exist by using either the folder icon or the Point-to-file icon in the Property inspector when creating links in templates.

**Dreamweaver 8.01 link update preference**
Previous to Dreamweaver 8 (that is, Dreamweaver MX 2004 and earlier), Dreamweaver did not update links to files that resided in the Templates folder. (For example, if you had a file called main.css in the Templates folder, and had written href="main.css" as a link in the template file, Dreamweaver would not update this link when creating a template-based page.)

Some users took advantage of the way Dreamweaver treated links to files in the Templates folder, and used this inconsistency to create links that they intentionally did not want to update when creating template-based pages. For example, if you are using Dreamweaver MX 2004, and have a site with different folders for different applications—Dreamweaver, Flash, and Photoshop. Each product folder contains a template-based index.html page, and a unique version of the main.css file at the same level. If the template file contains the document-relative link href="main.css" (a link to a version of the main.css file in the Templates folder), and you want your template-based index.html pages also to contain this link as written, you can create the template-based index.html pages without having to worry about Dreamweaver updating those particular links. When Dreamweaver MX 2004 creates the template-based index.html pages, the (un-updated) href="main.css" links refer to the main.css files that reside in the Dreamweaver, Flash, and Photoshop folders, not to the main.css file that resides in the Templates folder.
In Dreamweaver 8, however, this behavior was changed so that all document-relative links are updated when creating template-based pages, regardless of the apparent location of the linked files. In this scenario, Dreamweaver examines the link in the template file (href="main.css") and creates a link in the template-based page that is relative to the location of the new document. For example, if you are creating a template-based document one level up from the Templates folder, Dreamweaver would write the link in the new document as href="Templates/main.css". This update in Dreamweaver 8 broke links in pages created by those designers who had taken advantage of Dreamweaver’s former practice of not updating links to files in the Templates folder.

Dreamweaver 8.01 added a preference that enables you to turn the update relative links behavior on and off. (This special preference only applies to links to files in the Templates folder, not to links in general.) The default behavior is to not update these links (as in Dreamweaver MX 2004 and before), but if you want Dreamweaver to update these kinds of links when creating template-based pages, you can deselect the preference. (You would only do this if, for example, you had a

Cascading Style Sheets

(CSS) page, main.css, in your Templates folder, and you wanted a template-based document to contain the link href="Templates/main.css"; but this is not recommended practice as only Dreamweaver template (DWT) files should reside in the Templates folder.)

To have Dreamweaver update document-relative paths to non-template files in the Templates folder, select the Templates category in the Site Setup dialog box (it’s under Advanced Settings), and deselect the Don’t Rewrite Document Relative Paths option.

For more information, see the Dreamweaver TechNote on the Adobe website at www.adobe.com/go/f55d8739.

More Help topics

“Link to documents using the Point-To-File icon” on page 265

“Document-relative paths” on page 262

Server scripts in templates and template-based documents

Some server scripts are inserted at the very beginning or end of the document (before the <html> tag or after the </html> tag). Such scripts require special treatment in templates and template-based documents. Normally, if you make changes to script code before the <html> tag or after the </html> tag in a template, the changes are not copied to documents based on that template. This can cause server errors if other server scripts, within the main body of the template, depended on the scripts that are not copied. An alert warns you if you change scripts before the <html> tag or after the </html> tag in a template.

To avoid this problem, you can insert the following code in the head section of the template:

<!-- TemplateInfo codeOutsideHTMLIsLocked="true" -->

When this code is in a template, changes to scripts before the <html> tag or after the </html> tag are copied to documents based on that template. However, you will no longer be able to edit those scripts in documents based on the template. Thus, you can choose to either edit these scripts in the template, or in documents based on the template, but not both.
**Template parameters**

Template parameters indicate values for controlling content in documents based on a template. Use template parameters for optional regions or editable tag attributes, or to set values you want to pass to an attached document. For each parameter, you select a name, a data type, and a default value. Each parameter must have a unique name that is case sensitive. They must be one of five permitted data types: text, boolean, color, URL, or number.

Template parameters are passed to the document as instance parameters. In most cases, a template user can edit the parameter’s default value to customize what appears in a template-based document. In other cases, the template author might determine what appears in the document, based on the value of a template expression.

**More Help topics**

“Using optional regions in templates” on page 389

“Defining editable tag attributes in templates” on page 391

**Template expressions**

Template expressions are statements that compute or evaluate a value.

You can use an expression to store a value and display it in a document. For example, an expression can be as simple as the value of a parameter, such as $$\text{@}@\text{(Param)}$$, or complex enough to compute values which alternate the background color in a table row, such as $$\text{@}@((\text{index} & 1) \ ? \ \text{red} : \ \text{blue})$$.

You can also define expressions for if and multiple-if conditions. When an expression is used in a conditional statement, Dreamweaver evaluates it as `true` or `false`. If the condition is true, the optional region appears in the template-based document; if it is false, it doesn’t appear.

You can define expressions in Code view or in the Optional Region dialog box when you insert an optional region.

In Code view, there are two ways to define template expressions: use the `<!!-- TemplateExpr expr="your expression"--->` comment or `@@(your expression)@@`. When you insert the expression in the template code, an expression marker appears in Design view. When you apply the template, Dreamweaver evaluates the expression and displays the value in the template-based document.

**More Help topics**

“Template expression language” on page 377

“Multiple If condition in template code” on page 378

**Template expression language**

The template expression language is a small subset of JavaScript, and uses JavaScript syntax and precedence rules. Use JavaScript operators to write an expression like this:

$$\text{@}@\text{(firstName+lastName)}$$

The following features and operators are supported:

- numeric literals, string literals (double-quote syntax only), Boolean literals (`true` or `false`)
- variable reference (see the list of defined variables later in this section)
- field reference (the “dot” operator)
- unary operators: `+`, `-`, `!`
- binary operators: `+`, `-`, `*`, `/`, `%`, `|`, `^`, `&`, `&&`, `||`, `<`, `<=`, `>`, `>=`, `==`, `!=`, `<<`, `>>`
• conditional operator: ?:
• parentheses: ()

The following data types are used: Boolean, IEEE 64-bpc floating point, string, and object. Dreamweaver templates do not support the use of JavaScript “null” or “undefined” types. Nor do they allow scalar types to be implicitly converted into an object; thus, the expression "abc".length would trigger an error, instead of yielding the value 3.

The only objects available are those defined by the expression object model. The following variables are defined:

_document  Contains the document-level template data with a field for each parameter in the template.

_repeat  Only defined for expressions which appear inside a repeating region. Provides built-in information about the region

_index  The numerical index (from 0) of the current entry

_numRows  The total number of entries in this repeating region

_isFirst  True if the current entry is the first entry in its repeating region

_isLast  True if the current entry is the last entry in its repeating region

_prevRecord  The _repeat object for the previous entry. It is an error to access this property for the first entry in the region.

_nextRecord  The _repeat object for the next entry. It is an error to access this property for the last entry in the region.

_parent  In a nested repeated region, this gives the _repeat object for the enclosing (outer) repeated region. It is an error to access this property outside of a nested repeated region.

During expression evaluation, all fields of the _document object and _repeat object are implicitly available. For example, you can enter title instead of _document.title to access the document's title parameter.

In cases where there is a field conflict, fields of the _repeat object take precedence over fields of the _document object. Therefore, you shouldn't need to explicitly reference _document or _repeat except that _document might be needed inside a repeating region to reference document parameters that are hidden by repeated region parameters.

When nested repeated regions are used, only fields of the innermost repeated regions are available implicitly. Outer regions must be explicitly referenced using _parent.

Multiple If condition in template code
You can define template expressions for if and multiple-if conditions. This example demonstrates defining a parameter named "Dept", setting an initial value, and defining a multiple-if condition which determines which logo to display.

The following is an example of the code you might enter in the head section of the template:

```html
<!-- TemplateParam name="Dept" type="number" value="1" -->
```

The following condition statement checks the value assigned to the Dept parameter. When the condition is true or matches, the appropriate image is displayed.
When you create a template-based document, the template parameters are automatically passed to it. The template user determines which image to display.

More Help topics
“Modify template properties” on page 402

Recognizing templates and template-based documents

Recognizing templates in Design view
In Design view, editable regions appear in the Document window surrounded by rectangular outlines in a preset highlight color. A small tab appears at the upper-left corner of each region, showing the name of the region.

You can identify a template file by looking at the title bar in the Document window. The title bar for a template file contains the word ‘<<Template>>’ in the title bar, and the filename extension for the file is .dwt.
Recognizing templates in Code view

In Code view, editable content regions are marked in HTML with the following comments:

```html
<!-- TemplateBeginEditable> and <!-- TemplateEndEditable -->
```

💡 You can use code color preferences to set your own color scheme so you can easily distinguish template regions when you view a document in Code view.

Everything between these comments will be editable in documents based on the template. The HTML source code for an editable region might look like this:

```html
<table width="75%" border="1" cellspacing="0" cellpadding="0">
  <tr bgcolor="#333366">
    <td>Name</td>
    <td><font color="#FFFFFF">Address</font></td>
    <td><font color="#FFFFFF">Telephone Number</font></td>
  </tr>
  <!-- TemplateBeginEditable name="LocationList" -->
  <tr>
    <td>Enter name</td>
    <td>Enter Address</td>
    <td>Enter Telephone</td>
  </tr>
  <!-- TemplateEndEditable -->
</table>
```

**Note:** When you edit template code in Code view, be careful not to change any of the template-related comment tags that Dreamweaver relies on.

More Help topics

“Customize code coloring preferences for a template” on page 405

Recognizing template-based documents in Design view

In a document based on a template (a template-based document), editable regions appear in the Design view of the Document window surrounded by rectangular outlines in a preset highlight color. A small tab appears at the upper-left corner of each region, showing the name of the region.
In addition to the editable-region outlines, the entire page is surrounded by a different-colored outline, with a tab in the upper-right corner giving the name of the template that the document is based on. This highlighted rectangle reminds you that the document is based on a template and that you can’t change content outside the editable regions.

More Help topics
“Set highlighting preferences for template regions” on page 406

Recognizing template-based documents in Code view
In Code view, editable regions of a document derived from a template appear in a different color than code in the non-editable regions. You can make changes only to code in the editable regions or editable parameters but you cannot type in locked regions.

Editable content is marked in HTML with the following Dreamweaver comments:

```html
<!-- InstanceBeginEditable>

Everything between these comments is editable in a template-based document. The HTML source code for an editable region might look like this:
The default color for non-editable text is gray; you can select a different color for the editable and non-editable regions in the Preferences dialog box.

More Help topics
“Customize code coloring preferences for a template” on page 405

Creating a Dreamweaver template

About creating Dreamweaver templates
You can create a template from an existing document (such as an HTML, Adobe ColdFusion, or Microsoft Active Server Pages document) or you can create a template from a new document.

After you create a template, you can insert template regions, and set template preferences for code color and template region highlight color.

💡 You can store additional information about a template (such as who created it, when it was last changed, or why you made certain layout decisions) in a Design Notes file for the template. Documents based on a template do not inherit the template’s Design Notes.

Note: Templates in Adobe Dreamweaver differ from templates in some other Adobe products.

Note: Products in that page sections of Dreamweaver templates are fixed (or uneditable) by default.

For a tutorial on creating templates, see www.adobe.com/go/vid0157.

For a tutorial on using templates, see www.adobe.com/go/vid0158.

More Help topics
“Types of template regions” on page 374
“Setting authoring preferences for templates” on page 405
“Associate Design Notes with files” on page 101

Last updated 12/7/2011
Create a template from an existing document
You can create a template from an existing document.

1. Open the document you want to save as a template.
2. Do one of the following:
   - Select File > Save As Template.
   - In the Common category of the Insert panel, click the Templates button, then select Make Template from the pop-up menu.

   Note: Unless you selected Don’t Show This Dialog Again in the past, you’ll receive a warning that says the document you’re saving has no editable regions. Click OK to save the document as a template, or click Cancel to exit this dialog box without creating a template.

3. Select a site to save the template in from the Site pop-up menu, and then enter a unique name for the template in the Save As box.
4. Click Save. Dreamweaver saves the template file in the site’s Templates folder in the local root folder of the site, with a .dwt filename extension. If the Templates folder does not already exist in the site, Dreamweaver automatically creates it when you save a new template.

   Note: Do not move your templates out of the Templates folder, or put any non-template files in the Templates folder. Also, do not move the Templates folder out of your local root folder. Doing so causes errors in paths in the templates.

More Help topics
“Create a blank template” on page 61
“Creating and opening documents” on page 59

Use the Assets panel to create a new template
1. In the Assets panel (Window > Assets), select the Templates category on the left side of the panel.
2. Click the New Template button at the bottom of the Assets panel.

A new, untitled template is added to the list of templates in the Assets panel.

3. While the template is still selected, enter a name for the template, then press Enter (Windows) or Return (Macintosh).

Dreamweaver creates a blank template in the Assets panel and in the Templates folder.

About creating templates for Contribute sites
Using Dreamweaver, you can create templates to help Adobe® Contribute® users create new pages, to provide a consistent look and feel for your site, and to enable you to update the layout of many pages at once.
When you create a template and upload it to the server, it becomes available to all Contribute users who connect to your site, unless you’ve set restrictions on template use for certain Contribute roles. If you have set restrictions on template use, you might need to add each new template to the list of templates a Contribute user can use (see Administering Contribute).

Note: Make sure that the site root folder defined in each Contribute user’s site definition is the same as the site root folder defined in your site definition in Dreamweaver. If a user’s site root folder doesn’t match yours, that user won’t be able to use templates.

In addition to Dreamweaver templates, you can create non-Dreamweaver templates using the Contribute administration tools. A non-Dreamweaver template is an existing page that Contribute users can use to create new pages; it’s similar to a Dreamweaver template, except that pages that are based on it don’t update when you change the template. Also, non-Dreamweaver templates can’t contain Dreamweaver template elements such as editable, locked, repeating, and optional regions.

When a Contribute user creates a new document within a site containing Dreamweaver templates, Contribute lists the available templates (both Dreamweaver and non-Dreamweaver templates) in the New Page dialog box.

To include pages that use encodings other than Latin-1 in your site, you might need to create templates (either Dreamweaver templates or non-Dreamweaver templates). Contribute users can edit pages that use any encoding, but when a Contribute user creates a new blank page, it uses the Latin-1 encoding. To create a page that uses a different encoding, a Contribute user can create a copy of an existing page that uses a different encoding, or can use a template that uses a different encoding. However, if there are no pages or templates in the site that use other encodings, then you must first create a page or a template in Dreamweaver that uses that other encoding.

Create a template for a Contribute site

1. Select Site > Manage Sites.
2. Select a site and click Edit.
3. In the Site Setup dialog box, select the Contribute category.
4 If you haven’t already done so, you need to enable Contribute compatibility. Select Enable Contribute Compatibility, and then enter a site root URL.

5 Click Administer Site In Contribute.

6 If prompted, enter the administrator password, and then click OK.

7 In the Users And Roles category, select a role, and then click the Edit Role Settings button.

8 Select the New Pages category, and then add existing pages to the list under Create A New Page By Copying A Page From This List.

For more information, see Administering Contribute.

9 Click OK twice to close the dialog boxes.

More Help topics
“Prepare a site for use with Contribute” on page 54

Creating editable regions in templates

Insert an editable region
Editable template regions control which areas of a template-based page a user can edit. Before you insert an editable region, save the document you are working in as a template.

Note: If you insert an editable region in a document rather than a template file, an alert warns you that the document will automatically be saved as a template.

You can place an editable region anywhere in your page, but consider the following points if you are making a table or an absolutely-positioned element (AP element) editable:

- You can mark an entire table or an individual table cell as editable, but you can’t mark multiple table cells as a single editable region. If a <td> tag is selected, the editable region includes the region around the cell; if not, the editable region affects only content inside the cell.

- AP elements and AP element content are separate elements; making an AP element editable lets you change the position of the AP element as well as its contents, but making an AP element’s contents editable lets you change only the content of the AP element, not its position.

1 In the Document window, do one of the following to select the region:
- Select the text or content that you want to set as an editable region.
- Place the insertion point where you want to insert an editable region.

2 Do one of the following to insert an editable region:
- Select Insert > Template Objects > Editable Region.
- Right-click (Windows) or Control-click (Macintosh), then select Templates > New Editable Region.
- In the Common category of the Insert panel, click the Templates button, then select Editable Region from the pop-up menu.

3 In the Name box, enter a unique name for the region. (You cannot use the same name for more than one editable region in a particular template.)

Note: Do not use special characters in the Name box.
4 Click OK. The editable region is enclosed in a highlighted rectangular outline in the template, using the highlighting color that is set in preferences. A tab at the upper-left corner of the region shows the name of the region. If you insert an empty editable region in the document, the name of the region also appears inside the region.

More Help topics
“Creating a Dreamweaver template” on page 382
“Set highlighting preferences for template regions” on page 406

Select editable regions
You can easily identify and select template regions in both the template document and template-based documents.

Select an editable region in the Document window
❖ Click the tab in the upper-left corner of the editable region.

Find an editable region and select it in the document
❖ Select Modify > Templates, then select the name of the region from the list at the bottom of that submenu.

Note: Editable regions that are inside a repeated region do not appear in the menu. You must locate these regions by looking for tabbed borders in the Document window.

The editable region is selected in the document.

Remove an editable region
If you’ve marked a region of your template file as editable and you want to lock it (make it noneditable in template-based documents) again, use the Remove Template Markup command.

1 Click the tab in the upper-left corner of the editable region to select it.

2 Do one of the following:
   • Select Modify > Templates > Remove Template Markup.
   • Right-click (Windows) or Control-click (Macintosh), then select Templates > Remove Template Markup.

The region is no longer editable.

Change an editable region’s name
After you insert an editable region, you can later change its name.

1 Click the tab in the upper-left corner of the editable region to select it.

2 In the Property inspector (Window > Properties), enter a new name.

3 Press Enter (Windows) or Return (Macintosh).
Creating repeating regions in templates

About template repeating regions
A repeating region is a section of a template that can be duplicated many times in a template-based page. Typically, repeating regions are used with tables but you can define a repeating region for other page elements.

Repeating regions enable you to control your page layout by repeating certain items, such as a catalog item and description layout, or a row for data such as a list of items.

There are two repeating region template objects you can use: repeating region and repeating table.

Create a repeating region in a template
Repeating regions enable template users to duplicate a specified region in a template as often as desired. A repeating region is not necessarily an editable region.

To make content in a repeating region editable (for example, to allow a user to enter text in a table cell in a template-based document), you must insert an editable region in the repeating region.

1 In the Document window, do one of the following:
   • Select the text or content you want to set as a repeating region.
   • Place the insertion point in the document where you want to insert the repeating region.

2 Do one of the following:
   • Select Insert > Template Objects > Repeating Region.
   • Right-click (Windows) or Control-click (Macintosh), then select Templates > New Repeating Region.
   • In the Common category of the Insert panel, click the Templates button, then select Repeating Region from the pop-up menu.

3 In the Name box, enter a unique name for the template region. (You cannot use the same name for more than one repeating region in a template.)

   Note: When you name a region, do not use special characters.

4 Click OK.

Insert a repeating table
You can use a repeating table to create an editable region (in table format) with repeating rows. You can define table attributes and set which table cells are editable.

1 In the Document window, place the insertion point in the document where you want to insert the repeating table.

2 Do one of the following:
   • Select Insert > Template Objects > Repeating Table.
In the Common category of the Insert panel, click the Templates button, and then select Repeating Table from the pop-up menu.

3 Specify the following options and click OK.

- **Rows**: Determines the number of rows the table has.
- **Columns**: Determines the number of columns the table has.
- **Cell Padding**: Determines the number of pixels between a cell's content and the cell boundaries.
- **Cell Spacing**: Determines the number of pixels between adjacent table cells.

⚠️ If you don’t explicitly assign values for cell padding and cell spacing, most browsers display the table as if cell padding were set to 1 and cell spacing were set to 2. To ensure that browsers display the table with no padding or spacing, set Cell Padding and Cell Spacing to 0.

- **Width**: Specifies the width of the table in pixels, or as a percentage of the browser window’s width.
- **Border**: Specifies the width, in pixels, of the table’s borders.

⚠️ If you don’t explicitly assign a value for border, most browsers display the table as if the border were set to 1. To ensure that browsers display the table with no border, set Border to 0. To view cell and table boundaries when the border is set to 0, select View > Visual Aids > Table Borders.

- **Repeat Rows of the Table**: Specify which rows in the table are included in the repeating region.
- **Starting Row**: Sets the row number entered as the first row to include in the repeating region.
- **Ending Row**: Sets the row number entered as the last row to include in the repeating region.
- **Region Name**: Lets you set a unique name for the repeating region.

### Set alternating background colors in a repeating table

After you insert a repeating table in a template, you can customize it by alternating the background color of the table rows.

1 In the Document window, select a row in the repeating table.

2 Click the Show Code View or Show Code And Design Views button in the Document toolbar so you can access the code for the selected table row.

3 In Code view, edit the `<tr>` tag to include the following code:

   `<tr bgcolor="@@( _index & 1 ? '#FFFFFF' : '#CCCCCC')@@">`

You can replace the `#FFFFFF` and `#CCCCCC` hexadecimal values with other color choices.

4 Save the template.

The following is a code example of a table that includes alternating background table row colors:
Using optional regions in templates

About template optional regions
An optional region is a region in a template that users can set to show or to hide in a template-based document. Use an optional region when you want to set conditions for displaying content in a document.

When you insert an optional region, you can either set specific values for a template parameter or define conditional statements (if...else statements) for template regions. Use simple true/false operations, or define more complex conditional statements and expressions. You can later modify the optional region if necessary. Based on the conditions you define, template users can edit the parameters in template-based documents they create and control whether the optional region is displayed.

You can link multiple optional regions to a named parameter. In the template-based document, both regions will show or hide as a unit. For example, you can show a “closeout” image and sales price text area for a sale item.

More Help topics
“Modify template properties” on page 402
“Types of template regions” on page 374

Insert an optional region
Use an optional region to control content that may or may not be displayed in a template-based document. There are two types of optional regions:

- Non-editable optional regions, which enable template users to show and hide specially marked regions without enabling them to edit the content.
- Editable optional regions, which enable template users to set whether the region shows or hides, and enable users to edit content in the region.

For example, if the optional region includes an image or text, the template user can set whether the content is displayed, as well as make edits to the content if desired. An editable region is controlled by a conditional statement.
Insert a non-editable optional region
1 In the Document window, select the element you want to set as an optional region.
2 Do one of the following:
   • Select Insert > Template Objects > Optional Region.
   • Right-click (Windows) or Control-click (Macintosh) the selected content, then select Templates > New Optional Region.
   • In the Common category of the Insert panel, click the Templates button, then select Optional Region from the pop-up menu.
3 Enter a name for the optional region, click the Advanced tab if you want to set values for the optional region, and then click OK.

Insert an editable optional region
1 In the Document window, place the insertion point where you want to insert the optional region.
   You cannot wrap a selection to create an editable optional region. Insert the region, then insert the content in the region.
2 Do one of the following:
   • Select Insert > Template Objects > Editable Optional Region.
   • In the Common category of the Insert panel, click the Templates button, then select Editable Optional Region from the pop-up menu.
3 Enter a name for the optional region, click the Advanced tab if you want to set values for the optional region, and click OK.

Set values for an optional region
You can edit optional region settings after you’ve inserted the region in a template. For example, you can change whether the default setting for the content is to be displayed or not, to link a parameter to an existing optional region, or to modify a template expression.

Create template parameters and define conditional statements (If...else statements) for template regions. You can use simple true/false operations, or define more complex conditional statements and expressions.
In the Advanced tab you can link multiple optional regions to a named parameter. In the template-based document, both regions will show or hide as a unit. For example, you can show a “closeout” image and sales price text area for a sale item.

You can also use the Advanced tab to write a template expression that evaluates a value for the optional region and shows it or hides it based on the value.
1 In the Document window, do one of the following:
   • In Design view, click the template tab of the optional region you want to modify.
   • In Design view, place the insertion point in the template region; then in the tag selector at the bottom of the Document window, select the template tag, `<mmtemplate:if>`.
   • In Code view, click the comment tag of the template region you want to modify.
2 In the Property inspector (Window > Properties), click Edit.
3 In the Basics tab, enter a name for the parameter in the Name box.
4 Select Show By Default to set the selected region to show in the document. Deselect it to set the default value to false. 
   *Note: To set a different value for the parameter, in Code view locate the parameter in the section of the document and edit the value.*
5 (Optional) Click the Advanced tab, then set the following options:
   • If you want to link optional region parameters, click the Advanced tab, select Use Parameter, then from the pop-up menu select the existing parameter you want to link the selected content to.
   • If you want to write a template expression to control the display of an optional region, click the Advanced tab, select Enter Expression, then enter the expression in the box.
   *Note: Dreamweaver inserts double-quatation marks around the text you enter.*
6 Click OK.

When you use the Optional Region template object, Dreamweaver inserts template comments in the code. A template parameter is defined in the `head` section, as in the following example:

```html
<!-- TemplateParam name="departmentImage" type="boolean" value="true" -->
```

At the location where the optional region is inserted, code similar to the code below appears:

```html
<!-- TemplateBeginIf cond="departmentImage" -->
<p><img src="/images/airfare_on.gif" width="85" height="22"></p>
<!-- TemplateEndIf -->
```

You can access and edit template parameters in the template-based document.

**More Help topics**

“Modify template properties” on page 402

“Template expressions” on page 377

## Defining editable tag attributes in templates

### Specify editable tag attributes in a template

You can allow a template user to modify specified tag attributes in a document created from a template.

For example, you can set a background color in the template document, yet enable template users to set a different background color for pages they create. Users can update only the attributes you specify as editable.

You can also set multiple editable attributes in a page so that template users can modify the attributes in template-based documents. The following data types are supported: text, Boolean (`true/false`), color, and URL.

Creating an editable tag attribute inserts a template parameter in the code. An initial value for the attribute is set in the template document; when a template-based document is created, it inherits the parameter. A template user can then edit the parameter in the template-based document.

*Note: If you make the link to a style sheet an editable attribute, then the attributes of the style sheet are no longer available for either viewing or editing in the template file.*

1 In the Document window, select an item you want to set an editable tag attribute for.
2 Select Modify > Templates > Make Attribute Editable.

3 In the Attribute box, enter a name or select an attribute in the Editable Tag Attributes dialog box by doing one of the following:

- If the attribute you want to make editable is listed in the Attribute pop-up menu, select it.
- If the attribute you want to make editable isn’t listed in the Attribute pop-up menu, click Add, and in the dialog box that opens, enter the name of the attribute you want to add, then click OK.

4 Make sure the Make Attribute Editable option is selected.

5 In the Label box, enter a unique name for the attribute.

6 In the Type menu, select the type of value allowed for this attribute by setting one of the following options:

   - To enable a user to enter a text value for the attribute, select Text. For example, you can use text with the align attribute; the user can then set the attribute’s value to left, right, or center.
   - To insert a link to an element, such as the file path to an image, select URL. Using this option automatically updates the path used in a link. If the user moves the image to a new folder, the Update Links dialog box appears.
   - To make the color picker available for selecting a value, select Color.
   - To enable a user to select a true or false value on the page, select True/False.
   - To enable a template user to type a numerical value to update an attribute (for example, to change the height or width values of an image), select Number.

7 The Default Value box displays the value of the selected tag attribute in the template. Enter a new value in this box to set a different initial value for the parameter in the template-based document.

8 (Optional) If you want to make changes to another attribute of the selected tag, select the attribute and set the options for that attribute.

9 Click OK.

More Help topics

“Modify template properties” on page 402

Make an editable tag attribute uneditable

A tag previously marked as editable can be marked as uneditable.

1 In the template document, click the element associated with the editable attribute or use the tag selector to select the tag.

2 Select Modify > Templates > Make Attribute Editable.

3 In the Attributes pop-up menu, select the attribute you want to affect.

4 Deselect Make Attribute Editable and click OK.

5 Update documents based on the template.
Creating a nested template

About nested templates
A nested template is a template whose design and editable regions are based on another template. Nested templates are useful for controlling content in pages of a site that share many design elements, but have a few variations between pages. For example, a base template might contain broader design areas and be usable by many content contributors for a site, while a nested template might further define the editable regions in pages for a specific section in a site.

Editable regions in a base template are passed through to the nested template, and remain editable in pages created from a nested template unless new template regions are inserted in these regions.

Changes to a base template are automatically updated in templates based on the base template, and in all template-based documents that are based on the main and nested templates.

In the following example, the template trioHome contains three editable regions, named Body, NavBar, and Footer:
To create a nested template, a new document based on the template was created and then saved as a template and named TrioNested. In the nested template, two editable regions have been added in the editable region named Body.

When you add a new editable region in an editable region passed through to the nested template, the highlighting color of the editable region changes to orange. Content you add outside the editable region, such as the graphic in the editableColumn, is no longer editable in documents based on the nested template. The blue highlighted editable areas, whether added in the nested template or passed through from the base template, remain editable in documents that are based on the nested template. Template regions that do not contain an editable region pass through to template-based documents as editable regions.

More Help topics
Nested Templates

Create a nested template
Nested templates let you create variations of a base template. You can nest multiple templates to define increasingly specific layouts.

By default, all editable template regions from the base template pass through the nested template to the document based on the nested template. That means that if you create an editable region in a base template, then create a nested template, the editable region appears in documents based on the nested template (if you did not insert any new template regions in that region in the nested template).
395

USING DREAMWEAVER
Creating and managing templates

Note: You can insert template markup inside an editable region so that it won’t pass through as an editable region in
documents based on the nested template. Such regions have an orange border instead of a blue border.
1 Create a document from the template on which you want to base the nested template by doing one of the following:

• In the Assets panel’s Templates category, right-click (Windows) or Control-click (Macintosh) the template you
want to create a new document from, then select New From Template from the context menu.

• Select File > New. In the New Document dialog box, select the Page from Template category, then select the site
that contains the template you want to use; in the Template list, double-click the template to create a new document.
2 Select File >
3 Save As
4

Template to save the new document as a nested template:

5 Enter a name in the
6 Save As
7

box and click OK.

More Help topics
“Server scripts in templates and template-based documents” on page 376

Prevent an editable region from passing through to a nested template
In nested templates, pass-through editable regions have a blue border. You can insert template markup inside an
editable region so that it won’t pass through as an editable region in documents based on the nested template. Such
regions have an orange border instead of a blue border.
1 In Code view, locate the editable region you want to prevent from passing through.

Editable regions are defined by template comment tags.
2 Add the following code to the editable region code:
@@("")@@

This template code can be placed anywhere within the <!-InstanceBeginEditable --><!-- InstanceEndEditable --> tags that surround the editable region. For

example:
<!-- InstanceBeginEditable name="EditRegion1" -->
<p>@@("")@@ Editable 1 </p>
<!-- InstanceEndEditable -->

Editing, updating, and deleting templates
About editing and updating templates
When you make changes to and save a template, all the documents based on the template are updated. You can also
manually update a template-based document or the entire site if necessary.
Note: To edit a template for a Contribute site, you must use Dreamweaver; you cannot edit templates in Contribute.

Last updated 12/7/2011


Use the Templates category of the Assets panel to manage existing templates, including renaming template files and deleting template files.

You can perform the following template management tasks with the Assets panel:

- Create a template
- Edit and update templates
- Apply or remove a template from an existing document

Dreamweaver checks template syntax when you save a template but it’s a good idea to manually check the template syntax while you’re editing a template.

**More Help topics**
“Creating a Dreamweaver template” on page 382
“Check template syntax” on page 405
“Applying or removing a template from an existing document” on page 400

**Open a template for editing**

You can open a template file directly for editing, or you can open a template-based document, then open the attached template for editing.

When you make a change to a template, Dreamweaver prompts you to update the documents based on the template.

*Note: You can also manually update the documents for template changes if necessary.*

**More Help topics**
“Check template syntax” on page 405

**Open and edit a template file**

1. In the Assets panel (Window > Assets), select the Templates category on the left side of the panel.

   The Assets panel lists all of the available templates for your site and displays a preview of the selected template.

2. In the list of available templates, do one of the following:
   - Double-click the name of the template you want to edit.
   - Select a template to edit, then click the Edit button at the bottom of the Assets panel.

3. Modify the contents of the template.

   To modify the template’s page properties, select Modify > Page Properties. (Documents based on a template inherit the template’s page properties.)

4. Save the template. Dreamweaver prompts you to update pages based on the template.

5. Click Update to update all documents based on the modified template; click Don’t Update if you don’t want to update documents based on the modified template.

Dreamweaver displays a log indicating the files that were updated.

**Open and modify the template attached to the current document**

Using Dreamweaver
Creating and managing templates

2 Do one of the following:
   • Select Modify > Templates > Open Attached Template.
   • Right-click (Windows) or Control-click (Macintosh), then select Templates > Open Attached Template.
3 Modify the contents of the template.
   ! To modify the template’s page properties, select Modify > Page Properties. (Documents based on a template inherit the template’s page properties.)
4 Save the template. Dreamweaver prompts you to update pages based on the template.
5 Click Update to update all documents based on the modified template; click Don’t Update if you don’t want to update documents based on the modified template.
Dreamweaver displays a log indicating the files that were updated.

Rename a template
1 In the Assets panel (Window > Assets), select the Templates category on the left side of the panel.
2 Click the name of the template to select it.
3 Click the name again so that the text is selectable, then enter a new name.
This method of renaming works in the same way as renaming a file in Windows Explorer (Windows) or the Finder (Macintosh). As with Windows Explorer and the Finder, be sure to pause briefly between clicks. Do not double-click the name, because that opens the template for editing.
4 Click in another area of the Asset panel, or press Enter (Windows) or Return (Macintosh) for the change to take effect.
An alert asks if you want to update documents that are based on this template.
5 To update all documents in the site that are based on this template, click Update. Click Don’t Update if you do not want to update any document based on this template.

More Help topics
“Creating a Dreamweaver template” on page 382
“Applying or removing a template from an existing document” on page 400

Change a template description
The template description appears in the New Document dialog box when you’re creating a page from an existing template.
1 Select Modify > Templates > Description.
2 In the Template Description dialog box, edit the description and click OK.

More Help topics
“Creating a Dreamweaver template” on page 382

Last updated 12/7/2011
Manually update documents based on templates
When you make a change to a template, Dreamweaver prompts you to update the documents based on the template, but you can manually update the current document or the entire site if necessary. Manually updating template-based documents is the same as reapplying the template.

Apply template changes to the current template-based document
1 Open the document in the Document window.
2 Select Modify > Templates > Update Current Page.
Dreamweaver updates the document with any template changes.

Update the entire site or all documents that use a specified template
You can update all the pages in the site, or only update pages for a specific template.
1 Select Modify > Templates > Update Pages.
2 In the Look In menu, do one of the following:
   • To update all the files in the selected site to their corresponding templates, select Entire Site, then select the site name from the adjacent pop-up menu.
   • To update files for a specific template, select Files That Use, then select the template name from the adjacent pop-up menu.
3 Make sure Templates is selected in the Update option.
4 If you don’t want to see a log of the files Dreamweaver updates, deselect the Show Log option; otherwise, leave that option selected.
5 Click Start to update the files as indicated. If you selected the Show Log option, Dreamweaver provides information about the files it attempts to update, including information on whether they were updated successfully.
6 Click Close.

Update templates in a Contribute site
Contribute users can’t make changes to a Dreamweaver template. You can, however, use Dreamweaver to change a template for a Contribute site
Keep these factors in mind when updating templates in a Contribute site:
   • Contribute retrieves new and changed templates from the site only when Contribute starts up and when a Contribute user changes their connection information. If you make changes to a template while a Contribute user is editing a file based on that template, the user won’t see the changes to the template until they restart Contribute.
   • If you remove an editable region from a template, a Contribute user editing a page based on that template might be confused about what to do with the content that was in that editable region.

To update a template in a Contribute site, complete the following steps.
1 Open the Contribute template in Dreamweaver, edit it, and then save it. For instructions, see “Open a template for editing” on page 396.
2 Notify all of the Contribute users who are working on the site to restart Contribute.

Delete a template file
1 In the Assets panel (Window > Assets), select the Templates category on the left side of the panel.
2 Click the name of the template to select it.
3 Click the Delete button at the bottom of the panel, then confirm that you want to delete the template.

Important: After you delete a template file, you can’t retrieve it. The template file is deleted from your site.

Documents that are based on a deleted template are not detached from the template; they retain the structure and editable regions that the template file had before it was deleted. You can convert such a document into an HTML file without editable or locked regions.

More Help topics
“Detach a document from a template” on page 401
“Applying or removing a template from an existing document” on page 400
“Creating a Dreamweaver template” on page 382

Exporting and importing template content

About template XML content
You can think of a document based on a template as containing data represented by name-value pairs. Each pair consists of the name of an editable region, and the contents of that region.

You can export the name-value pairs into an XML file so that you can work with the data outside of Dreamweaver (for example, in an XML editor or a text editor, or a database application). Conversely, if you have an XML document that’s structured appropriately, you can import the data from it into a document based on a Dreamweaver template.

Export a document’s editable regions as XML
1 Open a template-based document that contains editable regions.
2 Select File > Export > Template Data As XML.
3 Select one of the Notation options:
   • If the template contains repeating regions or template parameters, select Use Standard Dreamweaver XML Tag.
   • If the template does not contain repeating regions or template parameters, select Use Editable Region Names as XML Tags.
4 Click OK.
5 In the dialog box that appears, select a folder location, enter a name for the XML file, and then click Save.

An XML file is generated that contains the material from the document’s parameters and editable regions, including editable regions inside repeating regions or optional regions. The XML file includes the name of the original template, as well as the name and contents of each template region.

Note: Content in the non-editable regions is not exported to the XML file.

Import XML content
1 Select File > Import > Import XML into Template.
2 Select the XML file and click Open.
Dreamweaver creates a new document based on the template specified in the XML file. It fills in the contents of each editable region in that document using the data from the XML file. The resulting document appears in a new Document window.

If your XML file isn’t set up exactly the way Dreamweaver expects, you might not be able to import your data. One solution to this problem is to export a dummy XML file from Dreamweaver, so that you’ll have an XML file with exactly the right structure. Then copy the data from your original XML file into the exported XML file. The result is an XML file with the correct structure that contains the appropriate data, ready to be imported.

Export a site without template markup
You can export template-based documents in a site to another site without including the template markup.

1. Select Modify > Templates > Export Without Markup.
2. In the Folder box, enter the file path to the folder you want to export the file to or click Browse and select the folder.
   Note: You must select a folder outside of the current site.
3. If you want to save an XML version of exported template-based documents, select Keep Template Data Files.
4. If you want to update changes to previously exported files, select Extract Only Changed Files and click OK.

Applying or removing a template from an existing document

Apply a template to an existing document
When you apply a template to a document which contains existing content, Dreamweaver attempts to match the existing content to a region in the template. If you are applying a revised version of one of your existing templates, the names are likely to match.

If you apply a template to a document that hasn’t had a template applied to it, there are no editable regions to compare and a mismatch occurs. Dreamweaver tracks these mismatches so you can select which region or regions to move the current page’s content to, or you can delete the mismatched content.

You can apply a template to an existing document using the Assets panel or from the Document window. You can undo a template application if necessary.

Important: When you apply a template to an existing document, the template replaces the document’s contents with the template’s boilerplate content. Always back up a page’s contents before applying a template to it.

Apply a template to an existing document using the Assets panel
1. Open the document you want to apply the template to.
2. In the Assets panel (Window > Assets), select the Templates category on the left side of the panel.
3. Do one of the following:
   • Drag the template you want to apply from the Assets panel to the Document window.
   • Select the template you want to apply, then click the Apply button at the bottom of the Assets panel.
If content exists in the document that can’t be automatically assigned to a template region, the Inconsistent Region Names dialog box appears.
4 Select a destination for the content by using the Move Content to New Region menu to select one of the following:
   • Select a region in the new template to move the existing content to.
   • Select Nowhere to remove the content from the document.
5 To move all unresolved content to the selected region, click Use For All.
6 Click OK to apply the template or click Cancel to cancel the application of the template to the document.

Important: When you apply a template to an existing document, the template replaces the document’s contents with the template’s boilerplate content. Always back up a page’s contents before applying a template to it.

Apply a template to an existing document from the Document window
1 Open the document you want to apply the template to.
2 Select Modify > Templates > Apply Template to Page.
   The Select Template dialog box appears.
3 Choose a template from the list, then click Select.
   If content exists in the document that can’t be automatically assigned to a template region, the Inconsistent Region Names dialog box appears.
4 Select a destination for the content by using the Move Content to New Region menu to select one of the following:
   • Select a region in the new template to move the existing content to.
   • Select Nowhere to remove the content from the document.
5 To move all unresolved content to the selected region, click Use For All.
6 Click OK to apply the template or click Cancel to cancel the application of the template to the document.

Important: When you apply a template to an existing document, the template replaces the document’s contents with the template’s boilerplate content. Always back up a page’s contents before applying a template to it.

Undo the template changes
✓ Select Edit > Undo Apply Template.
   The document reverts to its state before the template was applied.

Detach a document from a template
To make changes to the locked regions of a document based on a template, you must detach the document from the template. When the document is detached, the entire document becomes editable.

Note: You cannot convert a template file (.dwt) to a normal file by simply resaving the template file as an HTML (.html) file. Doing so does not delete the template code that appears throughout the document. If you want to convert a template file to a normal file, you can save the document as a normal HTML file, but must then manually delete all of the template code in Code view.

1 Open the template-based document you want to detach.
2 Select Modify > Templates > Detach from Template.
   The document is detached from the template and all template code is removed.
Editing content in a template-based document

About editing content in template-based documents

Dreamweaver templates specify regions that are locked (uneditable) and others that are editable for template-based documents.

In pages based on templates, template users can edit content in editable regions only. You can easily identify and select editable regions to edit content. Template users cannot edit content in locked regions.

*Note:* If you try to edit a locked region in a document based on a template when highlighting is turned off, the mouse pointer changes to indicate that you can’t click in a locked region.

Template users can also modify properties and edit entries for a repeating region in template-based documents.

More Help topics

“Create a page based on an existing template” on page 63

“About Dreamweaver templates” on page 374

“Select editable regions” on page 386

Modify template properties

When template authors create parameters in a template, documents based on the template automatically inherit the parameters and their initial value settings. A template user can update editable tag attributes and other template parameters (such as optional region settings).

More Help topics

“Template parameters” on page 377

“Using optional regions in templates” on page 389

“Defining editable tag attributes in templates” on page 391

Modify an editable tag attribute

1. Open the template-based document.
2. Select Modify > Template Properties.

The Template Properties dialog box opens, showing a list of available properties. The dialog box shows optional regions and editable tag attributes.

3. In the Name list, select the property.

The bottom area of the dialog box updates to show the selected property's label and its assigned value.

4. In the field to the right of the property label, edit the value to modify the property in the document.

*Note:* The field name and updateable values are defined in the template. Attributes that do not appear in the Name list are not editable in the template-based document.

5. Select Allow Nested Templates To Control This if you want to pass the editable property along to a documents based on the nested template.
Modify optional region template parameters

1. Open the template-based document.
2. Select Modify > Template Properties.

The Template Properties dialog box opens, showing a list of available properties. The dialog box shows optional regions and editable tag attributes.
3. In the Name list, select a property.

The dialog box updates to show the selected property’s label and its assigned value.
4. Select Show to display the optional region in the document, or deselect Show to hide the optional region.

*Note: The field name and default setting are defined in the template.*
5. Select Allow Nested Templates To Control This if you want to pass the editable property along to a document based on the nested template.

Add, delete, and change the order of a repeating region entry

Use repeating region controls to add, delete, or change the order of entries in template-based documents. When you add a repeating region entry, a copy of the entire repeating region is added. To update the content in the repeating regions, the original template must include an editable region in the repeating region.

More Help topics

“Creating repeating regions in templates” on page 387

Add, delete, or change the order of a repeating region

1. Open the template-based document.
2. Place the insertion point in the repeating region to select it.
3. Do one of the following:
   - Click the Plus (+) button to add a repeating region entry below the currently selected entry.
   - Click the Minus (–) button to delete the selected repeating region entry.
   - Click the Down Arrow button to move the selected entry down one position.
   - Click the Up Arrow button to move the selected entry up one position.

*Note: Alternatively, you can select Modify > Template, then select one of the repeating entry options near the bottom of the context menu. You can use this menu to insert a new repeating entry or move the selected entry’s position.*

Cut, copy, and delete entries

1. Open the template-based document.
2 Place the insertion point in the repeating region to select it.

3 Do one of the following:
   - To cut a repeating entry, select Edit > Repeating Entries > Cut Repeating Entries.
   - To copy a repeating entry, select Edit > Repeating Entries > Copy Repeating Entries.
   - To remove a repeating entry, select Edit > Repeating Entries > Delete Repeating Entries.
   - To paste a repeating entry, select Edit > Paste.

   *Note: Pasting inserts a new entry; it does not replace an existing entry.*

**Template syntax**

**General syntax rules**

Dreamweaver uses HTML comment tags to specify regions in templates and template-based documents, so template-based documents are still valid HTML files. When you insert a template object, template tags are inserted in the code.

General syntax rules are as follows:

- Wherever a space appears, you can substitute any amount of white space (spaces, tabs, line breaks). The white space is mandatory except at the very beginning or end of a comment.
- Attributes can be given in any order. For example, in a TemplateParam, you can specify the type before the name.
- Comment and attribute names are case sensitive.
- All attributes must be in quotation marks. Single or double quotes can be used.

**Template tags**

Dreamweaver uses the following template tags:

```html
<!-- TemplateBeginEditable name="..." -->
<!-- TemplateEndEditable -->
<!-- TemplateParam name="..." type="..." value="..." -->
<!-- TemplateBeginRepeat name="..." -->
<!-- TemplateEndRepeat -->
<!-- TemplateBeginIf cond="..." -->
<!-- TemplateEndIf -->
<!-- TemplateBeginPassthroughIf cond="..." -->
<!-- TemplateEndPassthroughIf -->
<!-- TemplateBeginMultipleIf -->
<!-- TemplateEndMultipleIf -->
<!-- TemplateBeginIfClause cond="..." -->
<!-- TemplateEndIfClause -->
<!-- TemplateBeginPassthroughIfClause cond="..." -->
<!-- TemplateEndPassthroughIfClause -->
<!-- TemplateExpr expr="..." --> (equivalent to @@...@@)
<!-- TemplatePassthroughExpr expr="..." -->
<!-- TemplateInfo codeOutsideHTMLIsLocked="..." -->
```

Last updated 12/7/2011
Instance tags

Dreamweaver uses the following instance tags:

<!-- InstanceBegin template="..." codeOutsideHTMLIsLocked="..." -->
<!-- InstanceEnd -->
<!-- InstanceBeginEditable name="..." -->
<!-- InstanceEndEditable -->
<!-- InstanceParam name="..." type="..." value="..." passthrough="..." -->
<!-- InstanceBeginRepeat name="..." -->
<!-- InstanceEndRepeat -->
<!-- InstanceBeginRepeatEntry -->
<!-- InstanceEndRepeatEntry -->

Check template syntax

Dreamweaver checks the template syntax when you save a template, but you can manually check the template syntax prior to saving a template. For example, if you add a template parameter or expression in Code view, you can check that the code follows correct syntax.

1 Open the document you want to check in the Document window.
2 Select Modify > Templates > Check Template Syntax.

An error message appears if the syntax is badly formed. The error message describes the error and refers to the specific line in the code where the error exists.

More Help topics

“Recognizing templates and template-based documents” on page 379
“Template expressions” on page 377

Setting authoring preferences for templates

Customize code coloring preferences for a template

Code color preferences control the text, background color, and style attributes of the text displayed in Code view. You can set your own color scheme so you can easily distinguish template regions when you view a document in Code view.

1 Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).
2 Select Code Coloring from the category list on the left.
3 Select HTML from the Document Type list, then click the Edit Coloring Scheme button.
4 In the Styles For list select Template Tags.
5 Set color, background color, and style attributes for the Code view text by doing the following:
   • If you want to change the text color, in the Text Color box type the hexadecimal value for the color you want to apply to the selected text, or use the color picker to select a color to apply to the text. Do the same in the Background field to add or change an existing background color for the selected text.
   • If you want to add a style attribute to the selected code, click the B (bold), I (italic), or U (underline) buttons to set the desired format.
6 Click OK.
Note: If you want to make global changes, you can edit the source file that stores your preferences. On Windows XP, this is located at C:\Documents and Settings\%username%\Application Data\Adobe\Dreamweaver 9\Configuration\CodeColoring\Colors.xml. On Windows Vista, this is located at C:\Users\%username%\Application Data\Adobe\Dreamweaver 9\Configuration\CodeColoring\Colors.xml.

Set highlighting preferences for template regions
You can use the Dreamweaver highlighting preferences to customize the highlight colors for the outlines around the editable and locked regions of a template in Design view. The editable region color appears in the template as well as in documents based on the template.

More Help topics
“Recognizing template-based documents in Design view” on page 380
“Recognizing templates in Design view” on page 379

Change template highlight colors
1 Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).
2 Select Highlighting from the category list on the left.
3 Click the Editable Regions, Nested Regions, or Locked Regions color box, then select a highlight color using the color picker (or enter the hexadecimal value for the highlight color in the box).

For information about using the color picker, see “Use the color picker” on page 208.
4 (Optional) Repeat the process for other template region types, as necessary.
5 Click the Show option to enable or disable displaying colors in the Document window.

Note: Nested Region does not have a Show option; its display is controlled by the Editable Region option.
6 Click OK.

View highlight colors in the Document window
❖ Select View > Visual Aids > Invisible Elements.

Highlight colors appear in the document window only when View > Visual Aids > Invisible Elements is enabled and the appropriate options are enabled in Highlighting preferences.

Note: If invisible elements are showing but the highlight colors are not, select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh), and then select the Highlight category. Make sure that the Show option next to the appropriate highlight color is selected. Also make sure that the desired color is visible against the background color of your page.
Chapter 15: Building Spry pages visually

The Spry framework is a JavaScript library that provides web designers with the ability to build web pages that offer richer experiences to their site visitors. With Spry, you can use HTML, CSS, and a minimal amount of JavaScript to incorporate XML data into your HTML documents, create widgets such as accordions and menu bars, and add different kinds of effects to various page elements. The Spry framework is designed so that markup is simple and easy to use for those users who have basic knowledge of HTML, CSS, and JavaScript.

The Spry framework is meant primarily for users who are web design professionals or advanced nonprofessional web designers. It is not intended as a full web application framework for enterprise-level web development (though it can be used in conjunction with other enterprise-level pages).

About the Spry framework

The Spry framework is a JavaScript library that provides web designers with the ability to build web pages that offer richer experiences to their site visitors. With Spry, you can use HTML, CSS, and a minimal amount of JavaScript to incorporate XML data into your HTML documents, create widgets such as accordions and menu bars, and add different kinds of effects to various page elements. The Spry framework is designed so that markup is simple and easy to use for those who have basic knowledge of HTML, CSS, and JavaScript.

The Spry framework is meant primarily for users who are web design professionals or advanced nonprofessional web designers. It is not intended as a full web application framework for enterprise-level web development (though it can be used in conjunction with other enterprise-level pages).

For more information on the Spry framework, see www.adobe.com/go/learn_dw_spryframework.

More Help topics

Spry Developer Guide

Working with Spry widgets (general instructions)

About Spry widgets

A Spry widget is a page element that provides a richer user experience by enabling user interaction. A Spry widget comprises the following parts:

- **Widget structure**: An HTML code block that defines the structural composition of the widget.
- **Widget behavior**: JavaScript that controls how the widget responds to user-initiated events.
- **Widget styling**: CSS that specifies the appearance of the widget.

The Spry framework supports a set of reusable widgets written in standard HTML, CSS, and JavaScript. You can easily insert these widgets—the code is HTML and CSS at its simplest—and then style the widget. The behaviors in the framework include functionality that lets users show or hide content on the page, change the appearance (such as color) of the page, interact with menu items, and much more.
Each widget in the Spry framework is associated with unique CSS and JavaScript files. The CSS file contains everything necessary for styling the widget, and the JavaScript file gives the widget its functionality. When you insert a widget by using the Dreamweaver interface, Dreamweaver automatically links these files to your page so that your widget contains functionality and styling.

The CSS and JavaScript files associated with a given widget are named after the widget, so it’s easy for you to know which files correspond to which widgets. (For example, the files associated with the Accordion widget are called SpryAccordion.css and SpryAccordion.js). When you insert a widget in a saved page, Dreamweaver creates a SpryAssets directory in your site, and saves the corresponding JavaScript and CSS files to that location.

More Help topics
“Understanding Cascading Style Sheets” on page 118

Spry widgets resources and tutorials
The following on-line resources provide more information on customizing Spry widgets.
Spry widget samples
Customizing Spry Menu Bars in Dreamweaver
Spry Validation widgets (video tutorial)

Insert a Spry widget
❖ Select Insert > Spry, and select the widget to insert.
When you insert a widget, Dreamweaver automatically includes the necessary Spry JavaScript and CSS files in your site when you save the page.

Note: You can also insert Spry widgets by using the Spry category in the Insert panel.

Select a Spry widget
1 Hold the mouse pointer over the widget until you see the widget’s blue tabbed outline.
2 Click the widget’s tab at the upper-left corner of the widget.

Edit a Spry widget
❖ Select the widget to edit and make your changes in the Property inspector (Window > Properties).
For details on making changes to specific widgets, see the appropriate sections for each widget.

Style a Spry widget
❖ Locate the appropriate CSS file for the widget in the SpryAssets folder of your site, and edit the CSS according to your preferences.
For details on styling specific widgets, see the appropriate customization sections for each widget.

You can also format a Spry widget by editing styles in the CSS panel, just as you would for any other styled element on the page.
Get more widgets
There are many more web widgets available than the Spry widgets that install with Dreamweaver. The Adobe Exchange provides web widgets that have been developed by other creative professionals.

❖ Choose Browse for Web Widgets from the Extend Dreamweaver menu in the Application bar.

For a video overview from the Dreamweaver engineering team about working with web widgets, see www.adobe.com/go/dw10widgets.

Change the default Spry assets folder
When you insert a Spry widget, data set, or effect in a saved page, Dreamweaver creates a SpryAssets directory in your site, and saves the corresponding JavaScript and CSS files to that location. You can change the default location where Dreamweaver saves Spry assets if you prefer to save them somewhere else.

1 Select Sites > Manage Sites.
2 Select your site in the Manage Sites dialog box and click Edit.
3 In the Site Setup dialog box, expand Advanced Settings and select the Spry category.
4 Enter a path to the folder you want to use for Spry assets and click OK. You can also click the folder icon to browse to a location.

More Help topics
“Working with Dreamweaver sites” on page 36

Working with the Spry Accordion widget

About the Accordion widget
An Accordion widget is a set of collapsible panels that can store a large amount of content in a compact space. Site visitors hide or reveal the content stored in the accordion by clicking the tab of the panel. The panels of the accordion expand or contract accordingly as the visitor clicks different tabs. In an accordion, only one content panel is open and visible at a given time. The following example shows an Accordion widget, with the first panel expanded:
The default HTML for the Accordion widget comprises an outer `div` tag that contains all of the panels, a `div` tag for each panel, and a header `div` and content `div` within the tag for each panel. An Accordion widget can contain any number of individual panels. The HTML for the Accordion widget also includes `script` tags in the head of the document and after the accordion’s HTML markup.

For a more comprehensive explanation of how the Accordion widget works, including a full anatomy of the Accordion widget’s code, see www.adobe.com/go/learn_dw_spryaccordion.

For a tutorial on working with the Accordion widget, see www.adobe.com/go/vid0167.

---

**Insert and edit the Accordion widget**

**Insert the Accordion widget**

❖ Select Insert > Spry > Spry Accordion.

*Note: You can also insert an Accordion widget by using the Spry category in the Insert panel.*

**Add a panel to an Accordion widget**

1. Select an Accordion widget in the Document window.
2. Click the Panels Plus (+) button in the Property inspector (Window > Properties).
3. (Optional) Change the name of the panel by selecting the panel’s text in Design view and altering the text.

**Delete a panel from an Accordion widget**

1. Select an Accordion widget in the Document window.
2. In the Panels menu of the Property inspector (Window > Properties), select the name of the panel to delete, and click the Minus (-) button.

**Open a panel for editing**

❖ Do one of the following:

   • Move the mouse pointer over the tab of the panel to open it in Design view, and click the eye icon that appears at the right of the tab.

   • Select an Accordion widget in the Document window, and then click the name of the panel to edit it in the Panels menu of the Property inspector (Window > Properties).

**Change the order of panels**

1. Select an Accordion widget in the Document window.
2. In the Property inspector (Window > Properties), select the name of the Accordion panel you want to move.
3. Click the up or down arrows to move the panel up or down.

**Customize the Accordion widget**

Although the Property inspector enables you to make simple edits to an Accordion widget, it does not support customized styling tasks. You can alter the CSS rules for the Accordion widget and create an accordion that is styled to your liking.

For a quick reference on changing the colors of the Accordion widget, see David Powers’s Quick guide to styling Spry tabbed panels, accordions, and collapsible panels.
For a more advanced list of styling tasks, see www.adobe.com/go/learn_dw_spryaccordion_custom.

All CSS rules in the following topics refer to the default rules located in the SpryAccordion.css file. Dreamweaver saves the SpryAccordion.css file in the SpryAssets folder of your site whenever you create a Spry Accordion widget. This file also contains commented information about various styles that apply to the widget, so you might find it helpful to consult the file as well.

Although you can easily edit rules for the Accordion widget directly in the CSS file, you can also use the CSS Styles panel to edit the accordion's CSS. The CSS Styles panel is helpful for locating the CSS classes assigned to different parts of the widget, especially if you use the panel's Current mode.

More Help topics
“The CSS Styles panel in Current mode” on page 123

Style Accordion widget text
You can style the text of an Accordion widget by setting properties for the entire Accordion widget container, or by setting properties for the components of the widget individually.

❖ To change the text styling of an Accordion widget, use the following table to locate the appropriate CSS rule, and then add your own text styling properties and values:

<table>
<thead>
<tr>
<th>Text to change</th>
<th>Relevant CSS rule</th>
<th>Example of properties and values to add</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text in the entire accordion (includes both tab and content panel)</td>
<td>.Accordion or .AccordionPanel</td>
<td>font: Arial; font-size:medium;</td>
</tr>
<tr>
<td>Text in accordion panel tabs only</td>
<td>.AccordionPanelTab</td>
<td>font: Arial; font-size:medium;</td>
</tr>
<tr>
<td>Text in accordion content panels only</td>
<td>.AccordionPanelContent</td>
<td>font: Arial; font-size:medium;</td>
</tr>
</tbody>
</table>

Change Accordion widget background colors
❖ To change the background colors of different parts of an Accordion widget, use the following table to locate the appropriate CSS rule, and then add or change background color properties and values:

<table>
<thead>
<tr>
<th>Part of widget to change</th>
<th>Relevant CSS rule</th>
<th>Example of property and value to add or change</th>
</tr>
</thead>
<tbody>
<tr>
<td>Background color of accordion panel tabs</td>
<td>.AccordionPanelTab</td>
<td>background-color: #CCCCCC; (This is the default value.)</td>
</tr>
<tr>
<td>Background color of accordion content panels</td>
<td>.AccordionPanelContent</td>
<td>background-color: #CCCCCC;</td>
</tr>
<tr>
<td>Background color of the open accordion panel</td>
<td>.AccordionPanelOpen .AccordionPanelTab</td>
<td>background-color: #EEEEEE; (This is the default value.)</td>
</tr>
<tr>
<td>Background color of panel tabs on hover</td>
<td>.AccordionPanelTabHover</td>
<td>color: #555555; (This is the default value.)</td>
</tr>
<tr>
<td>Background color of open panel on hover</td>
<td>.AccordionPanelOpen .AccordionPanelTabHover</td>
<td>color: #555555; (This is the default value.)</td>
</tr>
</tbody>
</table>

Constrain the width of an accordion
By default, the Accordion widget expands to fill available space. You can constrain the width of an Accordion widget, however, by setting a width property for the accordion container.

1 Locate the .Accordion CSS rule by opening up the SpryAccordion.css file. This is the rule that defines properties for the main container element of the Accordion widget.
2 Add a width property and value to the rule, for example width: 300px;.

### Working with the Spry Menu Bar widget

#### About the Menu Bar widget

A Menu Bar widget is a set of navigational menu buttons that display submenus when a site visitor hovers over one of the buttons. Menu Bars let you display a large amount of navigational information in a compact space, and also give visitors to the site a sense of what is available on the site without having to browse it extensively.

Dreamweaver lets you insert two kinds of Menu Bar widgets: vertical and horizontal. The following example shows a horizontal Menu Bar widget, with the third menu item expanded:

![Menu Bar widget (consists of <ul>, <li>, and <a> tags)](image)

A. Menu item has submenu  
B. Submenu item has submenu

The HTML for the Menu Bar widget comprises an outer `ul` tag that contains an `li` tag for each of the top-level menu items. The top-level menu items (`li` tags) in turn contain `ul` and `li` tags that define submenus for each of the items, and submenus can likewise contain submenus. Top-level menus and submenus can contain as many submenu items as you like.

For a more comprehensive explanation of how the Menu Bar widget works, including a full anatomy of the Menu Bar widget’s code, see [www.adobe.com/go/learn_dw_sprymenubar](www.adobe.com/go/learn_dw_sprymenubar).

For a tutorial on creating a Spry Menu Bar, see [www.adobe.com/go/vid0168](www.adobe.com/go/vid0168).

### More Help topics

- [Spry Menu Bar tutorial](#)

### Insert and edit the Menu Bar widget

#### Insert the Menu Bar widget

1 Select Insert > Spry > Spry Menu Bar.
2 Select Horizontal or Vertical, and click OK.

*Note: You can also insert a Menu Bar widget using the Spry category of the Insert panel.*

Last updated 12/7/2011
Note: The Spry Menu Bar widget uses DHTML layers to display sections of HTML on top of other sections. If your page contains content created with Adobe Flash, this might cause a problem because SWF files are always displayed on top of all other DHTML layers, so the SWF file might be displayed on top of your submenus. The workaround for this situation is to change the parameters for the SWF file to use `wmode="transparent"`. You can easily do this by selecting the SWF file in the Document window, and setting the `wmode` option in the Property inspector to `transparent`. For more information, see www.adobe.com/go/15523.

Add or delete menus and submenus
Use the Property inspector (Window > Properties) to add or delete menu items to and from the Menu Bar widget.

Add a main menu item
1 Select a Menu Bar widget in the Document window.
2 In the Property inspector, click the plus button above the first column.
3 (Optional) Rename the new menu item by changing the default text in either the Document window or the Text box of the Property inspector.

Add a submenu item
1 Select a Menu Bar widget in the Document window.
2 In the Property inspector, select the name of the main menu item to which you want to add the submenu.
3 Click the plus button above the second column.
4 (Optional) Rename the new submenu item by changing the default text in either the Document window or the Text box of the Property inspector.

To add a submenu to a submenu, select the name of the submenu item to which you want to add another submenu item, and click the plus button above the third column in the Property inspector.

Note: Dreamweaver only supports two levels of submenus in Design view, but you can add as many submenus as you want in Code view.

Delete a main menu or submenu item
1 Select a Menu Bar widget in the Document window.
2 In the Property inspector, select the name of the main menu or submenu item you want to delete and click the minus button.

Change the order of menu items
1 Select a Menu Bar widget in the Document window.
2 In the Property inspector (Window > Properties), select the name of the menu item you want to reorder.
3 Click the up or down arrows to move the menu item up or down.

Change the text of a menu item
1 Select a Menu Bar widget in the Document window.
2 In the Property inspector (Window > Properties) select the name of the menu item whose text you want to change.
3 Make your changes in the Text box.
Link a menu item
1. Select a Menu Bar widget in the Document window.
2. In the Property inspector (Window > Properties) select the name of the menu item to which you want to apply a link.
3. Type the link in the Link text box, or click the folder icon to browse to a file.

Create a tool tip for a menu item
1. Select a Menu Bar widget in the Document window.
2. In the Property inspector (Window > Properties) select the name of the menu item for which you want to create a tool tip.
3. Type the text for the tool tip in the Title text box.

Assign a target attribute for a menu item
The target attribute specifies where to open a linked page. For example, you can assign a target attribute to a menu item so that the linked page opens in a new browser window when the site visitor clicks the link. If you are using framesets, you can also specify the name of a frame where you want the linked page to open.

1. Select a Menu Bar widget in the Document window.
2. In the Property inspector (Window > Properties), select the name of the menu item to which you want to assign a target attribute.
3. Enter one of the four attributes in the Target box:
   - _blank Opens the linked page in a new browser window.
   - _self Loads the linked page in the same browser window. This is the default option. If the page is in a frame or frameset, the page loads within that frame.
   - _parent Loads the linked document in the immediate frameset parent of the document.
   - _top Loads the linked page in the topmost window of a frameset.

Turn off styles
You can disable the styling of a Menu Bar widget so that you can better see the HTML structure of the widget in Design view. For example, when you disable styles, menu bar items are displayed in a bulleted list on the page, rather than as the styled items of the menu bar.

1. Select a Menu Bar widget in the Document window.
2. Click the Turn Styles Off button in the Property Inspector (Window > Properties).

Change the orientation of a Menu Bar widget
You can change the orientation of a Menu Bar widget from horizontal to vertical, and vice versa. All you need to do is alter the HTML code for the menu bar and make sure you have the correct CSS file in your SpryAssets folder.

The following example changes a horizontal Menu Bar widget to a vertical Menu Bar widget.

1. In Dreamweaver, open the page that contains a horizontal Menu Bar widget.
2. Insert a vertical Menu Bar widget (Insert > Spry > Spry Menu Bar) and save the page. This step ensures that the correct CSS file for a vertical menu bar is included in your site.
Using Dreamweaver
Building Spry pages visually

Note: If your site already has a vertical Menu Bar widget somewhere else, you don’t need to insert a new one. You can simply attach the SpryMenuBarVertical.css file to the page instead by clicking the Attach Style Sheet button in the CSS Styles panel (Windows > CSS Styles).

3 Delete the vertical Menu Bar.

4 In Code view (View > Code), locate the MenuBarHorizontal class and change it to MenuBarVertical. The MenuBarHorizontal class is defined in the container ul tag for the menu bar (<ul id="MenuBar1" class="MenuBarHorizontal">).

5 After the code for the menu bar, locate the menu bar constructor:


6 Remove the imgDown preload option (and comma) from the constructor:

var MenuBar1 = new Spry.Widget.MenuBar("MenuBar1", {imgRight:"SpryAssets/SpryMenuBarRightHover.gif");

Note: If converting from a vertical menu bar to a horizontal one, add the imgDown preload option and comma instead.

7 (Optional) If your page no longer contains any other horizontal Menu Bar widgets, delete the link to the former MenuBarHorizontal.css file in the head of the document.

8 Save the page.

Customize the Menu Bar widget

Although the Property inspector enables you to make simple edits to a Menu Bar widget, it does not support customized styling tasks. You can alter the CSS rules for the Menu Bar widget and create a menu bar that is styled to your liking.

All CSS rules in the topics below refer to the default rules located in the SpryMenuBarHorizontal.css or SpryMenuBarVertical.css file (depending on your selection). Dreamweaver saves these CSS files in the SpryAssets folder of your site whenever you create a Spry Menu Bar widget. These files also contain useful commented information about various styles that apply to the widget.

Although you can easily edit rules for the Menu Bar widget directly in the accompanying CSS file, you can also use the CSS Styles panel to edit the menu bar’s CSS. The CSS Styles panel is helpful for locating the CSS classes assigned to different parts of the widget, especially if you use the panel’s Current mode.

More Help topics
“The CSS Styles panel in Current mode” on page 123

Change text styling of a menu item

The CSS attached to the <a> tag contains the information for text styling. There are also several relevant text styling class values attached to the <a> tag that pertain to different menu states.

❖ To change the text styling of a menu item, use the following table to locate the appropriate CSS rule, and then change the default value:
USING DREAMWEAVER
Building Spry pages visually

<table>
<thead>
<tr>
<th>Style to change</th>
<th>CSS rule for vertical or horizontal menu bar</th>
<th>Relevant properties and default values</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default text</td>
<td>ul.MenuBarVertical a, ul.MenuBarHorizontal a</td>
<td>color: #333; text-decoration: none;</td>
</tr>
<tr>
<td>Text color when mouse pointer moves over it</td>
<td>ul.MenuBarVertical a:hover, ul.MenuBarHorizontal a:hover</td>
<td>color: #FFF;</td>
</tr>
<tr>
<td>Text color when in focus</td>
<td>ul.MenuBarVertical a:focus, ul.MenuBarHorizontal a:focus</td>
<td>color: #FFF;</td>
</tr>
<tr>
<td>Menu Bar item color when mouse pointer moves over it</td>
<td>ul.MenuBarVertical a.MenuBarItemHover, ul.MenuBarHorizontal a.MenuBarItemHover</td>
<td>color: #FFF;</td>
</tr>
<tr>
<td>Submenu item color when mouse pointer moves over it</td>
<td>ul.MenuBarVertical a.MenuBarItemSubmenuHover, ul.MenuBarHorizontal a.MenuBarItemSubmenuHover</td>
<td>color: #FFF;</td>
</tr>
</tbody>
</table>

Change the background color of a menu item
The CSS attached to the <a> tag contains the information for a menu item’s background color. There are also several relevant background color class values attached to the <a> tag that pertain to different menu states.
❖ To change the background color of a menu item, use the following table to locate the appropriate CSS rule, and then change the default value:

<table>
<thead>
<tr>
<th>Color to change</th>
<th>CSS rule for vertical or horizontal menu bar</th>
<th>Relevant properties and default values</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default background</td>
<td>ul.MenuBarVertical a, ul.MenuBarHorizontal a</td>
<td>background-color: #EEE;</td>
</tr>
<tr>
<td>Background color when mouse pointer moves over it</td>
<td>ul.MenuBarVertical a:hover, ul.MenuBarHorizontal a:hover</td>
<td>background-color: #33C;</td>
</tr>
<tr>
<td>Background color when in focus</td>
<td>ul.MenuBarVertical a:focus, ul.MenuBarHorizontal a:focus</td>
<td>background-color: #33C;</td>
</tr>
<tr>
<td>Menu Bar item color when mouse pointer moves over it</td>
<td>ul.MenuBarVertical a.MenuBarItemHover, ul.MenuBarHorizontal a.MenuBarItemHover</td>
<td>background-color: #33C;</td>
</tr>
<tr>
<td>Submenu item color when mouse pointer moves over it</td>
<td>ul.MenuBarVertical a.MenuBarItemSubmenuHover, ul.MenuBarHorizontal a.MenuBarItemSubmenuHover</td>
<td>background-color: #33C;</td>
</tr>
</tbody>
</table>

Change the dimension of menu items
You change the dimension of menu items by changing the width properties of the menu item’s li and ul tags.
2. Change the width property to a desired width (or change the property to auto to remove a fixed width, and add the property and value white-space: nowrap; to the rule).
4. Change the width property to a desired width (or change the property to auto to remove a fixed width).
6. Add the following properties to the rule: float: none; and background-color: transparent;.
7. Delete the width: 8.2em; property and value.
Position submenus
The position of Spry Menu Bar submenus is controlled by the margin property on submenu ul tags.

1. Locate the ul.MenuBarVertical ul or ul.MenuBarHorizontal ul rule.
2. Change the margin: -5% 0 0 95%; default values to the desired values.

Working with the Spry Collapsible Panel widget

About the Collapsible Panel widget
A Collapsible Panel widget is a panel that can store content in a compact space. Users hide or reveal the content stored in the Collapsible Panel by clicking the tab of the widget. The following example shows a Collapsible Panel widget, expanded and collapsed:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Tab</th>
</tr>
</thead>
<tbody>
<tr>
<td>Panel content</td>
<td>Panel content</td>
</tr>
<tr>
<td>Panel content</td>
<td>Panel content</td>
</tr>
<tr>
<td>Panel content</td>
<td>Panel content</td>
</tr>
<tr>
<td>A. Expanded</td>
<td>B. Collapsed</td>
</tr>
</tbody>
</table>

The HTML for the Collapsible Panel widget comprises an outer div tag that contains the content div tag and the tab container div tag. The HTML for the Collapsible Panel widget also includes script tags in the head of the document and after the Collapsible Panel’s HTML markup.

For a more comprehensive explanation of how the Collapsible Panel widget works, including a full anatomy of the Collapsible Panel widget’s code, see www.adobe.com/go/learn_dw_sprycollapsiblepanel.

Insert and edit the Collapsible Panel widget

Insert the Collapsible Panel widget
❖ Select Insert > Spry > Spry Collapsible Panel.

Note: You can also insert a Collapsible Panel widget by using the Spry category in the Insert panel.

Open or close the Collapsible Panel in Design view
❖ Do one of the following:
  • Move the mouse pointer over the tab of the panel in Design view and click the eye icon that appears at the right of the tab.
  • Select a Collapsible Panel widget in the Document window, and then select Open or Closed from the Display pop-up menu in the Property inspector (Window > Properties).
Set the default state of a Collapsible Panel widget
You can set the default state (open or closed) of the Collapsible Panel widget when the web page loads in a browser.

1. Select a Collapsible Panel widget in the Document window.
2. In the Property inspector (Window > Properties), select Open or Closed from the Default state pop-up menu.

Enable or disable animation for the Collapsible Panel widget
By default, when you enable animation for a Collapsible Panel widget, the panel gradually and smoothly opens and closes when the site visitor clicks the panel’s tab. If you disable animation, the collapsible panel snaps open and closed abruptly.

1. Select a Collapsible Panel widget in the Document window.
2. In the Property inspector (Window > Properties), select or deselect Enable Animation.

Customize the Collapsible Panel widget
Although the Property inspector enables you to make simple edits to a Collapsible Panel widget, it does not support customized styling tasks. You can alter the CSS for the Collapsible Panel widget and create a collapsible panel that is styled to your liking.

For a quick reference on changing the colors of the Collapsible Panel widget, see David Powers’s Quick guide to styling Spry tabbed panels, accordions, and collapsible panels.

For a more advanced list of styling tasks, see www.adobe.com/go/learn_dw_sprycollapsiblepanel_custom.

All CSS rules in the topics below refer to the default rules located in the SpryCollapsiblePanel.css file. Dreamweaver saves the SpryCollapsiblePanel.css file in the SpryAssets folder of your site whenever you create a Spry Collapsible Panel widget. This file also contains useful commented information about various styles that apply to the widget.

While you can easily edit rules for the Collapsible Panel widget directly in the accompanying CSS file, you can also use the CSS Styles panel to edit the collapsible panel’s CSS. The CSS Styles panel is helpful for locating the CSS classes assigned to different parts of the widget, especially if you use the panel’s Current mode.

More Help topics
“The CSS Styles panel in Current mode” on page 123

Style Collapsible Panel widget text
You can style the text of a Collapsible Panel widget by setting properties for the entire Collapsible Panel widget container, or by setting properties for the components of the widget individually.

To change the text format of a Collapsible Panel widget, use the following table to locate the appropriate CSS rule, and then add your own text styling properties and values:

<table>
<thead>
<tr>
<th>Style to change</th>
<th>Relevant CSS rule</th>
<th>Example of properties and values to add or change</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text in the entire collapsible panel</td>
<td>.CollapsiblePanel</td>
<td>font: Arial; font-size:medium;</td>
</tr>
<tr>
<td>Text in panel tab only</td>
<td>.CollapsiblePanelTab</td>
<td>font: bold 0.7em sans-serif; (This is the default value.)</td>
</tr>
<tr>
<td>Text in content panel only</td>
<td>.CollapsiblePanelContent</td>
<td>font: Arial; font-size:medium;</td>
</tr>
</tbody>
</table>
Change Collapsible Panel widget background colors

❖ To change the background colors of different parts of a Collapsible Panel widget, use the following table to locate the appropriate CSS rule, and then add or change background color properties and values to your liking:

<table>
<thead>
<tr>
<th>Color to change</th>
<th>Relevant CSS rule</th>
<th>Example of property and value to add or change</th>
</tr>
</thead>
<tbody>
<tr>
<td>Background color of panel tab</td>
<td>.CollapsiblePanelTab</td>
<td>background-color: #DDD; (This is the default value.)</td>
</tr>
<tr>
<td>Background color of content panel</td>
<td>.CollapsiblePanelContent</td>
<td>background-color: #DDD;</td>
</tr>
<tr>
<td>Background color of tab when panel is open</td>
<td>.CollapsiblePanelOpen .CollapsiblePanelTab</td>
<td>background-color: #EEE; (This is the default value.)</td>
</tr>
<tr>
<td>Background color of open panel tab when the mouse pointer moves over it</td>
<td>.CollapsiblePanelTabHover .CollapsiblePanelOpen .CollapsiblePanelTabHover</td>
<td>background-color: #CCC; (This is the default value.)</td>
</tr>
</tbody>
</table>

Constrain the width of a collapsible panel

By default, the Collapsible Panel widget expands to fill available space. You can constrain the width of a Collapsible Panel widget, however, by setting a width property for the collapsible panel container.

1. Locate the .CollapsiblePanel CSS rule by opening the SpryCollapsible Panel.css file. This rule defines properties for the main container element of the Collapsible Panel widget.
   
   You can also locate the rule by selecting the Collapsible Panel widget, and looking in the CSS Styles panel (Window > CSS Styles). Make sure the panel is set to Current mode.

2. Add a width property and value to the rule, for example width: 300px;.

Working with the Spry Tabbed Panels widget

About the Tabbed Panels widget

A Tabbed Panels widget is a set of panels that can store content in a compact space. Site viewers hide or reveal the content stored in the Tabbed Panels by clicking the tab of the panel they want to access. The panels of the widget open accordingly as the visitor clicks different tabs. In a Tabbed Panels widget, only one content panel is open at a given time. The following example shows a Tabbed Panels widget, with the third panel open:

The HTML code for the Tabbed Panels widget comprises an outer div tag that contains all of the panels, a list for the tabs, a div to contain the content panels, and a div for each content panel. The HTML for the Tabbed Panels widget also includes script tags in the head of the document and after the Tabbed Panel widget’s HTML markup.
For a more comprehensive explanation of how the Tabbed Panels widget works, including a full anatomy of the widget’s code, see www.adobe.com/go/learn_dw_sprytabbedpanels.

**Insert and edit the Tabbed Panels widget**

**Insert the Tabbed Panels widget**

❖ Select Insert > Spry > Spry Tabbed Panels.

*Note: You can also insert a Tabbed Panels widget by using the Spry category in the Insert panel.*

**Add a panel to a Tabbed Panels widget**

1 Select a Tabbed Panels widget in the Document window.
2 Click the Panels plus button in the Property inspector (Window > Properties).
3 (Optional) Change the tab name by selecting the tab’s text in Design view and altering it.

**Delete a panel from a Tabbed Panels widget**

1 Select a Tabbed Panels widget in the Document window.
2 In the Panels menu of the Property inspector (Window > Properties), select the name of the panel you want to delete and click the minus button.

**Open a panel for editing**

❖ Do one of the following:

- Move the mouse pointer over the tab of the panel you want to open in Design view and click the eye icon that appears at the right of the tab.
- Select a Tabbed Panels widget in the Document window and click the name of the panel you want to edit in the Panels menu of the Property inspector (Window > Properties).

**Change the order of panels**

1 Select a Tabbed Panels widget in the Document window.
2 In the Panels menu of the Property inspector (Window > Properties), select the name of the panel you want to move.
3 Click the up or down arrows to move the panel up or down.

**Set the default open panel**

You can set which panel of the Tabbed Panels widget opens by default when the page opens in a browser.

1 Select a Tabbed Panels widget in the Document window.
2 In the Property inspector (Window > Properties), select the panel you want open by default from the Default panel pop-up menu.

**Customize the Tabbed Panels widget**

Although the Property inspector enables you to make simple edits to a Tabbed Panels widget, it does not support customized styling tasks. You can alter the CSS rules for the Tabbed Panels widget and create a widget that is styled to your liking.
For a quick reference on changing the colors of the Tabbed Panels widget, see David Powers’s Quick guide to styling Spry tabbed panels, accordions, and collapsible panels.

For a more advanced list of styling tasks, see www.adobe.com/go/learn_dw_sprytABBedpanels_custom.

All CSS rules in the topics below refer to the default rules located in the SpryTabbedPanels.css file. Dreamweaver saves the SpryTabbedPanels.css file in the SpryAssets folder of your site whenever you create a Spry Tabbed Panels widget. This file also contains useful commented information about various styles that apply to the widget.

Although you can easily edit rules for the Tabbed Panels widget directly in the accompanying CSS file, you can also use the CSS Styles panel to edit the widget’s CSS. The CSS Styles panel is helpful for locating the CSS classes assigned to different parts of the widget, especially if you use the panel’s Current mode.

More Help topics
“The CSS Styles panel in Current mode” on page 123

Style Tabbed Panels widget text
You can style the text of a Tabbed Panels widget by setting properties for the entire Tabbed Panels widget container, or by setting properties for the components of the widget individually.

❖ To change the text styling of a Tabbed Panels widget, use the following table to locate the appropriate CSS rule, and then add your own text styling properties and values:

<table>
<thead>
<tr>
<th>Text to change</th>
<th>Relevant CSS rule</th>
<th>Example of properties and values to add</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text in the entire widget</td>
<td>.TabbedPanels</td>
<td>font: Arial; font-size:medium;</td>
</tr>
<tr>
<td>Text in panel tabs only</td>
<td>.TabbedPanelsTabGroup or .TabbedPanelsTab</td>
<td>font: Arial; font-size:medium;</td>
</tr>
<tr>
<td>Text in content panels only</td>
<td>.TabbedPanelsContentGroup or .TabbedPanelsContent</td>
<td>font: Arial; font-size:medium;</td>
</tr>
</tbody>
</table>

Change Tabbed Panels widget background colors
❖ To change the background colors of different parts of a Tabbed Panels widget, use the following table to locate the appropriate CSS rule, and then add or change background color properties and values to your liking:

<table>
<thead>
<tr>
<th>Color to change</th>
<th>Relevant CSS rule</th>
<th>Example of property and value to add or change</th>
</tr>
</thead>
<tbody>
<tr>
<td>Background color of panel tabs</td>
<td>.TabbedPanelsTabGroup or .TabbedPanelsTab</td>
<td>background-color: #DDD; (This is the default value.)</td>
</tr>
<tr>
<td>Background color of content panels</td>
<td>.TabbedPanelsContentGroup or .TabbedPanelsContent</td>
<td>background-color: #EEE; (This is the default value.)</td>
</tr>
<tr>
<td>Background color of selected tab</td>
<td>.TabbedPanelsTabSelected</td>
<td>background-color: #EEE; (This is the default value.)</td>
</tr>
<tr>
<td>Background color of panel tabs when the mouse pointer moves over them</td>
<td>.TabbedPanelsTabHover</td>
<td>background-color: #CCC; (This is the default value.)</td>
</tr>
</tbody>
</table>
Constrain the width of tabbed panels
By default, the Tabbed Panels widget expands to fill available space. You can constrain the width of a Tabbed Panels widget, however, by setting a width property for the accordion container.

1. Locate the .TabbedPanels CSS rule by opening the SpryTabbedPanels.css file. This rule defines properties for the main container element of the Tabbed Panels widget.
   
   You can also locate the rule by selecting the Tabbed Panels widget, and looking in the CSS Styles panel (Window > CSS Styles). Make sure the panel is set to Current mode.

2. Add a width property and value to the rule, for example width: 300px;.

Working with the Spry Tooltip widget

About the Tooltip widget
The Spry tooltip widget displays additional information when a user hovers over a particular element on a web page. The additional content disappears when the user stops hovering. You can also set tooltips to stay open for longer periods of time so that users can interact with content inside the tooltip.

A Tooltip widget consists of the following three elements:

- The tooltip container. This is the element that contains the message or content that you want to display when the user activates the tooltip.
- The page element(s) that activates the tooltip.
- The constructor script. This is JavaScript that tells Spry to create the tooltip functionality.

When you insert a Tooltip widget, Dreamweaver creates a tooltip container using div tags, and wraps the “trigger” element (the page element that activates the tooltip) with span tags. Dreamweaver uses these tags by default, but the tags for the tooltip and the trigger element can be any tags, as long as they are within the body of the page.

Keep the following points in mind when working with the Tooltip widget:

- An open tooltip will close before the next one opens.
- Tooltips persist while users hover over the trigger area.
- There are no limitations as to what kinds of tags you can use for triggers and for tooltip content. (Block level elements are always advisable, however, to avoid possible cross-browser rendering problems.)
- By default, the tooltip appears 20 pixels down and to the right of the cursor. You can use the Horizontal and Vertical offset options in the Property inspector to set a custom appearance point.
- Currently there is no way to have a tooltip open when a page loads in a browser.

The tooltip widget requires very little CSS. Spry uses JavaScript to show, hide, and position the tooltip. You can achieve any other styling for the tooltip with standard CSS techniques, as your page requires. The only rule contained in the default CSS file is a workaround for Internet Explorer 6 problems so that the tooltip appears above form elements or Flash objects.

For a more comprehensive explanation of how the Spry Tooltip widget works, including a full anatomy of the widget’s code, see www.adobe.com/go/learn_dw_sprytooltip_en.

For a video tutorial on working with the Spry Tooltip widget, see www.adobe.com/go/lrvid4046_dw.
### Insert the Tooltip widget

- Select Insert > Spry > Spry Tooltip.

**Note:** You can also insert a Tooltip widget by using the Spry category in the Insert panel.

This action inserts a new Tooltip widget with a container for the tooltip content, and a placeholder sentence that acts as the tooltip trigger.

You can also select an existing element on the page (for example, an image), and then insert the tooltip. When you do this, the element you selected acts as the new tooltip’s trigger. The selection must be a full tag element (for example an `<img>` tag or a `<p>` tag) so that Dreamweaver can assign an ID to it if it does not already have one.

### Edit Tooltip widget options

You can set options that let you customize the Tooltip widget’s behavior.

1. Hover over or place the insertion point in the tooltip content on the page.
2. Click the Tooltip widget’s blue tab to select it.
3. Set options in the Tooltip widget Property inspector as desired.

- **Name** The name of the tooltip container. The container holds the content of the tooltip. By default Dreamweaver uses a `<div>` tag as the container.
- **Trigger** The element on the page that activates the tooltip. By default Dreamweaver inserts a placeholder sentence, surrounded by `<span>` tags, as the trigger, but you can select any element on the page that has a unique ID.
- **Follow Mouse** When selected, this option causes the tooltip to follow the mouse while hovering over the trigger element.
- **Hide on Mouse Out** When selected, this option keeps the tooltip open as long as the mouse is hovering over the tooltip (even if the mouse leaves the trigger element). Keeping the tooltip open is useful if you have links or other interactive elements in your tooltip. If this option is not selected, the tooltip element closes when the mouse leaves the trigger area.
- **Horizontal Offset** Computes the tooltip’s horizontal position in relation to the mouse. The offset value is in pixels, and the default offset is 20 pixels.
- **Vertical Offset** Computes the tooltip’s vertical position in relation to the mouse. The offset value is in pixels, and the default offset is 20 pixels.
- **Show Delay** The delay in milliseconds before the tooltip appears after it has entered the trigger element. The default value is 0.
- **Hide Delay** The delay in milliseconds before the tooltip disappears after it has left the trigger element. The default value is 0.
- **Effect** The type of effect you want to use when the tooltip appears. Blind simulates a window blind that moves up and down to reveal and hide the tooltip. Fade fades the tooltip in and out. The default value is none.

### Working with the Spry Validation Radio Group widget

#### About the Validation Radio Group widget

The **Validation Radio Group widget** is a group of radio buttons with validation support for the selection. The widget enforces the selection of one radio button from the group.
The following example shows a Validation Radio Group widget in various states.

![Validation Radio Group widget error messages](image_a.png) ![Validation Radio Group widget group](image_b.png)

A. Validation Radio Group widget error messages  B. Validation Radio Group widget group

The Validation Radio Group widget includes three states beyond the initial state: valid, invalid, and required value. You can alter the properties of these states by editing the corresponding CSS file (SpryValidationRadio.css), depending on the desired validation results. A Validation Radio Group widget can validate at various points: when the user clicks outside the widget, as the user makes selections, or when the user tries to submit the form.

- **Initial state**  When the page loads in the browser, or when the user resets the form.
- **Valid state**  When the user makes a selection, and the form can be submitted.
- **Required state**  When the user fails to make a required selection.
- **Invalid state**  When the user selects a radio button whose value is not acceptable.

Whenever a Validation Radio Group widget enters one of these states through user interaction, the Spry framework logic applies a specific CSS class to the HTML container for the widget at run time. For example, if a user tries to submit a form, but makes no selections, Spry applies a class to the widget that causes it to display the error message, “Please make a selection.” The rules that control the style and display states of error messages reside in the file that accompanies the widget, SpryValidationRadio.css.

The default HTML code for the Validation Radio Group widget, usually inside a form, is made up of a container span tag that surrounds the input type="radio" tag of the radio group. The HTML code for the Validation Radio Group widget also includes script tags in the head of the document and after the widget’s HTML code.

For a more comprehensive explanation of how the Validation Radio Group widget works, including a full anatomy of the Validation Radio Group widget’s code, see www.adobe.com/go/learn_dw_spryradio_en.

**Insert and edit the Validation Radio Group widget**

**Insert the Validation Radio Group widget**

2. In the Name text box, enter a name for the radio group.
3. Add or subtract radio buttons from the group by clicking the plus (+) or minus (-) buttons.
4. In the Label column, click the name of each radio button to make the field editable, and assign unique names to each radio button.
5. In the Value column, click each value to make the field editable, and assign a unique value to each radio button.
6. (Optional) Click a radio button or its value to select a specific row, and then click the up and down arrows to move the row up or down.
7 Select a layout type for the radio group.

**Line breaks** Places each radio button on a separate line using line breaks (`\n` tags).

**Table** Places each radio button on a separate line using individual table rows (`\t` tags).

8 Click OK.

*Note: You can also insert a Radio Group widget by using the Spry category in the Insert panel.*

**Specify when validation occurs**
You can set the point at which validation occurs—when the user clicks outside the widget, as the user makes selections, or when the user tries to submit the form.

1 Select a Validation Radio Group widget in the Document window by clicking its blue tab.

2 In the Property inspector (Window > Properties), select the option that indicates when you want validation to occur. You can select all of the options or Submit only.

**Blur** Validates whenever the user clicks outside the radio group.

**Change** Validates as the user makes selections.

**Submit** Validates when the user tries to submit the form. The submit option is selected by default, and cannot be deselected.

**Display widget states in Design view**

1 Select a Validation Radio Group widget in the Document window by clicking its blue tab.

2 In the Property inspector (Window > Properties), select the state you want to see from the Preview States pop-up menu. For example, select Initial to see the widget in its initial state.

**Change required status of radio buttons**
By default, Validation Radio Group widgets require the user to make a selection before submitting the form. You can, however, make selections optional for the user.

1 Select a Validation Radio Group widget in the Document window by clicking its blue tab.

2 In the Property inspector (Window > Properties), deselect the Required option.

**Specify an empty or invalid value**
You can specify a value that registers as empty or invalid if the user selects a radio button that is associated with one of those values. If the user selects a radio button with an empty value, the browser returns the error message "Please make a selection." If the user selects a radio button with an invalid value, the browser returns the error message "Please select a valid value."
Radio Group widget with empty value radio button.

1. Select the radio button in your Radio Group widget that you want to use for the empty or invalid radio button. When specifying empty or invalid values for the widget, there must be corresponding radio buttons with those values already assigned.

2. In the Radio Button Property inspector (Window > Properties), assign the radio button a checked value. To create a radio button with an empty value, type `none` in the Checked Value text box. To create a radio button with an invalid value, type `invalid` in the Checked Value text box.

3. Select the entire Validation Radio Group widget by clicking the widget’s blue tab.

4. In the Property inspector, specify empty or invalid values. To create a widget that displays the empty value error message “Please make a selection,” type `none` in the Empty Value text box. To create a widget that displays the invalid value error message “Please select a valid value,” type `invalid` in the Invalid Value text box.

Remember, both the radio button itself and the Radio Group widget must have the none or invalid values assigned for the error messages to display properly.

**Customize the Radio Group widget**

Although the Property inspector enables you to make simple edits to a Validation Radio Group widget, it does not support customized styling tasks. You can alter the CSS for the Validation Radio Group widget so that you can create a widget that is styled to your liking. For a more advanced list of styling tasks, see www.adobe.com/go/learn_dw_spryradio_custom_en.

All CSS rules in the topics below refer to the default rules located in the SpryValidationRadio.css file. Dreamweaver saves the SpryValidationRadio.css file in the SpryAssets folder of your site whenever you create a Spry Validation Radio Group widget. Consulting this file is helpful because it contains commented information about various styles that apply to the widget.

**More Help topics**

“The CSS Styles panel in Current mode” on page 123

**Style a Validation Radio Group widget (general instructions)**

1. Open the SpryValidationRadio.css file.

2. Locate the CSS rule for the part of the widget to change. For example, to change the background color of the Radio Group widget’s required state, edit the `radioRequiredState` rule in the SpryValidationRadio.css file.

3. Make your changes to the CSS rule and save the file.
The SpryValidationRadio.css file contains extensive comments, explaining the code and the purpose for certain rules. For further information, see the comments in the file.

**Style Validation Radio Group widget error message text**

By default, error messages for the Validation Radio Group widget appear in red with a 1-pixel solid border surrounding the text.

❖ To change the text styling of Validation Radio Group widget error messages, use the following table to locate the appropriate CSS rule, and then change the default properties, or add your own text-styling properties and values.

<table>
<thead>
<tr>
<th>Text to style</th>
<th>Relevant CSS rule</th>
<th>Relevant properties to change</th>
</tr>
</thead>
<tbody>
<tr>
<td>Error message text</td>
<td>.radioRequiredState .radioInvalidState .radioInvalidMsg</td>
<td>color: #CC3333; border: 1px solid #CC3333;</td>
</tr>
</tbody>
</table>

### Working with the Spry Validation Text Field widget

**About the Validation Text Field widget**

A Spry Validation Text Field widget is a text field that displays valid or invalid states when the site visitor enters text. For example, you can add a Validation Text Field widget to a form in which visitors type their e-mail addresses. If they fail to type the “@” symbol and a period in the e-mail address, the widget returns a message stating that the information the user entered is invalid.

The following example shows a Validation Text Field widget in various states:

A. Textfield widget, hint activated  B. Textfield widget, valid state  C. Textfield widget, invalid state  D. Textfield widget, required state

The Validation Text Field widget includes a number of states (for example, valid, invalid, required value, and so on). You can alter the properties of these states using the Property Inspector, depending on the desired validation results. A Validation Text Field widget can validate at various points—for example, when the visitor clicks outside the widget, when they type, or when they try to submit the form.

**Initial state** The widget state when the page loads in the browser, or when the user resets the form.

**Focus state** The widget state when the user places the insertion point in the widget.

**Valid state** The widget state when the user has entered information correctly, and the form can be submitted.

**Invalid state** The widget state when the user has entered text in an invalid format. (For example, 06 for a year instead of 2006).
**Required state** The widget state when the user has failed to enter required text in the text field.

**Minimum Number Of Characters state** The widget state when the user has entered fewer than the minimum number of characters required in the text field.

**Maximum Number Of Characters state** The widget state when the user has entered greater than the maximum number of characters allowed in the text field.

**Minimum Value state** The widget state when the user has entered a value that is less than the value required by the text field. (Applies to integer, real, and data type validations.)

**Maximum Value state** The widget state when the user has entered a value that is greater than the maximum value allowed by the text field. (Applies to integer, real, and data type validations.)

Whenever a Validation Text Field widget enters one of these states through user interaction, the Spry framework logic applies a specific CSS class to the HTML container for the widget at run time. For example, if a user tries to submit a form, but has entered no text in a required text field, Spry applies a class to the widget that causes it to display the error message, “A value is required”. The rules that control the style and display states of error messages exist in the CSS file that accompanies the widget, SpryValidationTextField.css.

The default HTML for the Validation Text Field widget, usually inside of a form, comprises a container `<span>` tag that surrounds the `<input>` tag of the text field. The HTML for the Validation Text Field widget also includes script tags in the head of the document and after the widget’s HTML markup.

For a more comprehensive explanation of how the Validation Text Field widget works, including a full anatomy of the Validation Text Field widget’s code, see [www.adobe.com/go/learn_dw_sprytextfield](http://www.adobe.com/go/learn_dw_sprytextfield).

---

**Insert and edit the Validation Text Field widget**

**Insert the Validation Text Field widget**

1 Select Insert > Spry > Spry Validation Text Field.

2 Complete the Input Tag Accessibility Attributes dialog box and click OK.

*Note: You can also insert a Validation Text Field widget by using the Spry category in the Insert panel.*

**More Help topics**

“Create accessible HTML forms” on page 645

**Specify a validation type and format**

You can specify different validation types for the Validation Text Field widget. For example, you can specify a credit card validation type if the text field will receive credit card numbers.

1 Select a Validation Text Field widget in the Document window.

2 In the Property inspector (Window > Properties), select a validation type from the Type menu.

3 If applicable, select a format from the Format pop-up menu.

Most validation types cause the text field to expect a standard format. For example, if you apply the integer validation type to a text field, the widget won’t validate unless the user has entered numbers in the text field. Some validation types, however, let you choose the kind of format your text field will accept. The following table lists validation types and formats that are available through the Property inspector:
Specify when validation occurs
You can set the point at which validation occurs—when the site visitor clicks outside the widget, as the visitor types, or when the visitor tries to submit the form.

1 Select a Validation Text Field widget in the Document window.

2 In the Property inspector (Window > Properties) select the option that indicates when you want validation to occur. You can select all of the options or Submit only.

Blur Validates whenever the user clicks outside the text field.

Change Validates as the user changes text inside the text field.

Submit Validates when the user tries to submit the form. The submit option is selected by default, and cannot be deselected.

Specify a minimum and maximum number characters
This option is only available for None, Integer, E-mail Address, and URL validation types.

1 Select a Validation Text Field widget in the Document window.

2 In the Property inspector (Window > Properties), enter a number in the Min Chars or Max Chars box. For example, if you enter 3 in the Min Chars box, the widget only validates if the user enters three or more characters.
Specify minimum and maximum values
This option is only available for Integer, Time, Currency, and Real Number/Scientific Notation validation types.

1. Select a Validation Text Field widget in the Document window.
2. In the Property inspector (Window > Properties), enter a number in the Min Value or Max Value box. For example, if you enter 3 in the Min Value box, the widget only validates if the user enters the number 3 or a value greater (4, 5, 6, and so on) in the text field.

Display widget states in Design view
1. Select a Validation Text Field widget in the Document window.
2. In the Property inspector (Window > Properties), select the state you want to see from the Preview States pop-up menu. For example, if you want to see the widget in its valid state, select Valid.

Change required status of a text field
By default, all Validation Text Field widgets that you insert with Dreamweaver require user input when published on a web page. You can, however, make the completion of text fields optional for the user.

1. Select a Validation Text Field widget in the Document window.
2. In the Property inspector (Window > Properties), select or deselect the Required option, depending on your preference.

Create a hint for a text field
Because there are so many different kinds of formats for text fields, it is helpful to give your users a hint as to what format they need to enter. For example, a text field set with the Phone Number validation type will only accept phone numbers in the form (000) 000-0000. You can enter these sample numbers as a hint so that the text field displays the correct format when the user loads the page in a browser.

1. Select a Validation Text Field widget in the Document window.
2. In the Property inspector (Window > Properties), enter a hint in the Hint text box.

Block invalid characters
You can prevent your users from entering invalid characters in a Validation Text Field widget. For example, if you select this option for a widget set with the Integer validation type, nothing appears in the text field if the user tries to type a letter.

1. Select a Validation Text Field widget in the Document window.
2. In the Property inspector (Window > Properties), select the Enforce Pattern option.

Customize the Validation Text Field widget
Although the Property inspector enables you to make simple edits to a Validation Text Field widget, it does not support customized styling tasks. You can alter the CSS for the Validation Text Field widget so that you can create a widget that is styled to your liking. For a more advanced list of styling tasks, see [www.adobe.com/go/learn_dw_sprytextfield_custom](http://www.adobe.com/go/learn_dw_sprytextfield_custom).

All CSS rules in the topics below refer to the default rules located in the SpryValidationTextField.css file. Dreamweaver saves the SpryValidationTextField.css file in the SpryAssets folder of your site whenever you create a Spry Validation Text Field widget. Consulting this file is helpful because it contains commented information about various styles that apply to the widget.
Although you can easily edit rules for the Validation Text Field widget directly in the accompanying CSS file, you can also use the CSS Styles panel to edit the widget's CSS. The CSS Styles panel is helpful for locating the CSS classes assigned to different parts of the widget, especially if you use the panel's Current mode.

More Help topics
“The CSS Styles panel in Current mode” on page 123

Style Validation Text Field widget error message text

By default, error messages for the Validation Text Field widget appear in red with a 1-pixel border surrounding the text.

❖ To change the text styling of Validation Text Field widget error messages, use the following table to locate the appropriate CSS rule, and then change the default properties, or add your own text-styling properties and values:

<table>
<thead>
<tr>
<th>Text to change</th>
<th>Relevant CSS rule</th>
<th>Relevant properties to change</th>
</tr>
</thead>
<tbody>
<tr>
<td>Error message text</td>
<td>.textfieldRequiredState .textfieldRequiredMsg, .textfieldInvalidFormatState .textfieldInvalidFormatMsg, .textfieldMinValueState .textfieldMinValueMsg, .textfieldMaxValueState .textfieldMaxValueMsg, .textfieldMinCharsState .textfieldMinCharsMsg, .textfieldMaxCharsState</td>
<td>color: #CC3333; border: 1px solid #CC3333;</td>
</tr>
</tbody>
</table>

Change Validation Text Field widget background colors

❖ To change the background colors of the Validation Text Field widget in various states, use the following table to locate the appropriate CSS rule, and then change the default background color values:

<table>
<thead>
<tr>
<th>Color to change</th>
<th>Relevant CSS rule</th>
<th>Relevant property to change</th>
</tr>
</thead>
<tbody>
<tr>
<td>Background color of widget in valid state</td>
<td>.textfieldValidState input, input.textfieldValidState</td>
<td>background-color: #B8F5B1;</td>
</tr>
<tr>
<td>Background color of widget in invalid state</td>
<td>input.textfieldRequiredState, .textfieldRequiredState input, input.textfieldInvalidFormatState, .textfieldInvalidFormatState input, input.textfieldMinValueState, .textfieldMinValueState input, input.textfieldMaxValueState, .textfieldMaxValueState input, input.textfieldMinCharsState, .textfieldMinCharsState input, input.textfieldMaxCharsState, .textfieldMaxCharsState input</td>
<td>background-color: #FF9F9F;</td>
</tr>
<tr>
<td>Background color widget in focus</td>
<td>.textfieldFocusState input, input.textfieldFocusState</td>
<td>background-color: #FFFFCC;</td>
</tr>
</tbody>
</table>

Working with the Spry Validation Text Area widget

About the Validation Text Area widget

A Spry Validation Text Area widget is a text area that displays valid or invalid states when the user enters a few sentences of text. If the text area is a required field and the user fails to enter any text, the widget returns a message stating that a value is required.

The following example shows a Validation Text Area widget in various states:
The Validation Text Area widget includes a number of states (for example, valid, invalid, required value, and so on). You can alter the properties of these states using the Property inspector, depending on the desired validation results. A Validation Text Area widget can validate at various points—for example, when the user clicks outside the widget, as the user types, or when the user tries to submit the form.

**Initial state**  The widget state when the page loads in the browser, or when the user resets the form.

**Focus state**  The widget state when the user places the insertion point in the widget.

**Valid state**  The widget state when the user has entered information correctly, and the form can be submitted.

**Required state**  The widget state when the user has failed to enter any text.

**Minimum Number Of Characters state**  The widget state when the user has entered fewer than the minimum number of characters required in the text area.

**Maximum Number Of Characters state**  The widget state when the user has entered more than the maximum number of characters allowed in the text area.

Whenever a Validation Text Area widget enters one of these states through user interaction, the Spry framework logic applies a specific CSS class to the HTML container for the widget at run time. For example, if a user tries to submit a form, but has not entered text in the text area, Spry applies a class to the widget that causes it to display the error message, “A value is required.” The rules that control the style and display states of error messages exist in the CSS file that accompanies the widget, SpryValidationTextArea.css.

The default HTML for the Validation Text Area widget, usually inside of a form, comprises a container `<span>` tag that surrounds the `<textarea>` tag of the text area. The HTML for the Validation Text Area widget also includes script tags in the head of the document and after the widget’s HTML markup.

For a more comprehensive explanation of how the Validation Text Area widget works, including a full anatomy of the Validation Text Area widget’s code, see [www.adobe.com/go/learn_dw_sprytextarea](http://www.adobe.com/go/learn_dw_sprytextarea).

### Insert and edit the Validation Text Area widget

**Insert the Validation Text Area widget**

1. Select Insert > Spry > Spry Validation Textarea.
2. Complete the Input Tag Accessibility Attributes dialog box and click OK.

*Note*: You can also insert a Validation Text Area widget by using the Spry category in the Insert panel.

**More Help topics**
“Create accessible HTML forms” on page 645

**Specify when validation occurs**
You can set the point at which validation occurs—when the user clicks outside the widget, as the user types, or when the user tries to submit the form.

1. Select a Validation Text Area widget in the Document window.
2. In the Property inspector (Window > Properties), select the Validate On option that indicates when you want validation to occur. You can select all of the options or Submit only.

- **Blur** Validates whenever the user clicks outside the text field.
- **Change** Validates as the user changes text inside the text field.
- **Submit** Validates when the user tries to submit the form. The submit option is selected by default, and cannot be deselected.

**Specify a minimum and maximum number of characters**
1. Select a Validation Text Area widget in the Document window.
2. In the Property inspector (Window > Properties), enter a number in the Min Chars or Max Chars box. For example, if you enter 20 in the Min Chars box, the widget only validates if the user enters 20 or more characters in the text area.

**Add a character counter**
You can add a character counter that lets your users know how many characters they have typed, or how many characters are remaining when entering text in the text area. By default, when you add a character counter, the counter appears outside the lower-right corner of the widget.

1. Select a Validation Text Area widget in the Document window.
2. In the Property inspector (Window > Properties), select either the Chars Count or Chars Remaining option.

*Note*: The Chars Remaining option is only available if you’ve already set a maximum number of characters allowed.

**Display widget states in Design view**
1. Select a Validation Text Area widget in the Document window.
2. In the Property inspector (Window > Properties), select the state you want to see from the Preview States pop-up menu. For example, if you want to see the widget in its valid state, select Valid.

**Change required status of a text area**
By default, all Validation Text Area widgets that you insert with Dreamweaver require user input when published on a web page. You can, however, make text areas optional for validation.

1. Select a Validation Text Area widget in the Document window.
2. In the Property inspector (Window > Properties), select or deselect the Required option, depending on your preference.
Create a hint for a text area
You can add a hint to the text area (for example, “Type your description here”), to let your users know the kind of information they should enter in the text area. The text area displays the hint text when the user loads the page in a browser.

1. Select a Validation Text Area widget in the Document window.
2. In the Property inspector (Window > Properties), enter a hint in the Hint text box.

Block extra characters
You can prevent your users from entering more than the maximum number of allowed characters in a Validation Text Area widget. For example, if you select this option for a widget set to accept no more than 20 characters, the user will not be able to type more than 20 characters in the text area.

1. Select a Validation Text Area widget in the Document window.
2. In the Property inspector (Window > Properties), select the Block Extra Characters option.

Customize the Validation Text Area widget
Although the Property inspector enables you to make simple edits to a Validation Text Area widget, it does not support customized styling tasks. You can alter the CSS for the Validation Text Area widget so that you can create a widget that is styled to your liking. For a more advanced list of styling tasks, see www.adobe.com/go/learn_dw_sprytextarea_custom.

All CSS rules in the topics below refer to the default rules located in the SpryValidationTextArea.css file. Dreamweaver saves the SpryValidationTextArea.css file in the SpryAssets folder of your site whenever you create a Spry Validation Text Area widget. Consulting this file is helpful because it contains commented information about various styles that apply to the widget.

Although you can easily edit rules for the Validation Text Area widget directly in the accompanying CSS file, you can also use the CSS Styles panel to edit the widget’s CSS. The CSS Styles panel is helpful for locating the CSS classes assigned to different parts of the widget, especially if you use the panel’s Current mode.

More Help topics
“The CSS Styles panel in Current mode” on page 123

Style Validation Text Area widget error message text
By default, error messages for the Validation Text Area widget appear in red with a 1-pixel border surrounding the text.

❖ To change the text styling of Validation Text Area widget error messages, use the following table to locate the appropriate CSS rule, and then change the default properties, or add your own text-styling properties and values:

<table>
<thead>
<tr>
<th>Text to change</th>
<th>Relevant CSS rule</th>
<th>Relevant properties to change</th>
</tr>
</thead>
<tbody>
<tr>
<td>Error message text</td>
<td>.textareaRequiredState .textareaRequiredMsg, .textareaMinCharsState .textareaMinCharsMsg, .textareaMaxCharsState .textareaMaxCharsMsg</td>
<td>color: #CC3333; border: 1px solid #CC3333;</td>
</tr>
</tbody>
</table>

Change Validation Text Area widget background colors
❖ To change the background colors of the Validation Text Area widget in various states, use the following table to locate the appropriate CSS rule, and then change the default background color values:
Working with the Spry Validation Select widget

About the Validation Select widget

A Spry Validation Select widget is a drop-down menu that displays valid or invalid states when the user makes a selection. For example, you can insert a Validation Select widget that contains a list of states, grouped into different sections and divided by horizontal lines. If the user accidentally selects one of the divider lines as opposed to one of the states, the Validation Select widget returns a message to the user stating that their selection is invalid.

The following example shows an expanded Validation Select widget, as well as the collapsed form of the widget in various states:

The Validation Select widget includes a number of states (for example, valid, invalid, required value, and so on). You can alter the properties of these states using the Property inspector, depending on the desired validation results. A Validation Select widget can validate at various points—for example, when the user clicks outside the widget, as the user makes selections, or when the user tries to submit the form.

- **Initial state**  The widget state when the page loads in the browser, or when the user resets the form.
- **Focus state**  The widget state when the user clicks the widget.
- **Valid state**  The widget state when the user has selected a valid item, and the form can be submitted.
- **Invalid state**  The widget state when the user has selected an invalid item.
- **Required state**  The widget state when the user has failed to select a valid item.
Whenever a Validation Select widget enters one of the above states through user interaction, the Spry framework logic applies a specific CSS class to the HTML container for the widget at run time. For example, if a user tries to submit a form, but has not selected an item from the menu, Spry applies a class to the widget so that it displays the error message, “Please select an item.” The rules that control the style and display states of error messages reside in the CSS file that accompanies the widget, SpryValidationSelect.css.

The default HTML for the Validation Select widget, usually inside of a form, comprises a container <span> tag that surrounds the <select> tag of the text area. The HTML for the Validation Select widget also includes script tags in the head of the document and after the widget’s HTML markup.

For a more comprehensive explanation of how the Validation Select widget works, including a full anatomy of the Validation Select widget’s code, see www.adobe.com/go/learn_dw_spryselect.

**Insert and edit the Validation Select widget**

**Insert the Validation Select widget**

1. Select Insert > Spry > Spry Validation Select.
2. Complete the Input Tag Accessibility Attributes dialog box and click OK.
3. In Code view, add option tags that contain menu items and values. Dreamweaver does not do this for you automatically. For more information, see the previous topic.

*Note:* You can also insert a Validation Select widget by using the Spry category in the Insert panel.

**More Help topics**

“Create accessible HTML forms” on page 645

**Specify when validation occurs**

You can set the point at which validation occurs—when the user clicks outside the widget, as the user types, or when the user tries to submit the form.

1. Select a Validation Select widget in the Document window.
2. In the Property inspector (Window > Properties) select the option that indicates when you want validation to occur. You can select all of the options or Submit only.

*Blur* Validates whenever the user clicks outside the widget.

*Change* Validates as the user makes selections.

*Submit* Validates when the user tries to submit the form. The submit option is selected by default, and cannot be deselected.

**Display widget states in Design view**

1. Select a Validation Select widget in the Document window.
2. In the Property inspector (Window > Properties), select the state you want to see from the Preview States pop-up menu. For example, if you want to see the widget in its valid state, select Valid.
Prohibit or allow blank values
By default, all Validation Select widgets that you insert with Dreamweaver require that users select menu items that have an associated value when the widget is published on a web page. You can, however, disable this option.

1 Select a Validation Select widget in the Document window.
2 In the Property inspector (Window > Properties), select or deselect the Do Not Allow Blank Values option, depending on your preference.

Specify an invalid value
You can specify a value that will register as invalid if the user selects a menu item that is associated with that value. For example, if you specify -1 as an invalid value, and you assign the value to an option tag, the widget will return an error message if the user selects that menu item.

<option value="-1"> ------------------- </option>

1 Select a Validation Select widget in the Document window.
2 In the Property inspector (Window > Properties), enter a number to use as in invalid value in the Invalid Value box.

Customize the Validation Select widget
Although the Property inspector enables you to make simple edits to a Validation Select widget, it does not support customized styling tasks. You can alter the CSS for the Validation Select widget so that you can create a widget that is styled to your liking.

All CSS rules in the topics below refer to the default rules located in the SpryValidationSelect.css file. Dreamweaver saves the SpryValidationSelect.css file in the SpryAssets folder of your site whenever you create a Spry Validation Select widget. Consulting this file is helpful because it contains commented information about various styles that apply to the widget.

Although you can easily edit rules for the Validation Select widget directly in the accompanying CSS file, you can also use the CSS Styles panel to edit the widget’s CSS. The CSS Styles panel is helpful for locating the CSS classes assigned to different parts of the widget, especially if you use the panel’s Current mode.

More Help topics
“The CSS Styles panel in Current mode” on page 123

Style Validation Select widget error message text
By default, error messages for the Validation Select widget appear in red with a 1-pixel border surrounding the text.

❖ To change the text styling of Validation Select widget error messages, use the following table to locate the appropriate CSS rule, and then change the default properties, or add your own text-styling properties and values:

<table>
<thead>
<tr>
<th>Text to style</th>
<th>Relevant CSS rule</th>
<th>Relevant properties to change</th>
</tr>
</thead>
<tbody>
<tr>
<td>Error message text</td>
<td>.selectRequiredState .selectRequiredMsg,</td>
<td>color: #CC3333; border: 1px solid #CC3333;</td>
</tr>
<tr>
<td></td>
<td>.selectInvalidState .selectInvalidMsg</td>
<td></td>
</tr>
</tbody>
</table>

Change Validation Select widget background colors
❖ To change the background colors of the Validation Select widget in various states, use the following table to locate the appropriate CSS rule, and then change the default background color values:
A Spry Validation Checkbox widget is a check box or group of check boxes in an HTML form that display valid or invalid states when the user selects or fails to select a check box. For example, you can add a Validation Checkbox widget to a form in which a user might be required to make three selections. If the user fails to make all three selections, the widget returns a message stating that the minimum number of selections has not been met.

The following example shows a Validation Checkbox widget in various states:

![Image of Validation Checkbox widget in various states]

A. Validation checkbox widget group, minimum number of selections state  B. Validation Checkbox widget, required state

The Validation Checkbox widget includes a number of states (for example, valid, invalid, required value, and so on). You can alter the properties of these states using the Property inspector, depending on the desired validation results.

**Initial state**  The widget state when the page loads in the browser, or when the user resets the form.

**Valid state**  The widget state when the user has made a selection, or the correct number of selections, and the form can be submitted.

**Required state**  The widget state when the user has failed to make a required selection.

**Minimum Number Of Selections state**  The widget state when the user has selected fewer than the minimum number of check boxes required.

**Maximum Number Of Selections state**  The widget state when the user has selected more than the maximum number of check boxes allowed.
Whenever a Validation Checkbox widget enters one of these states through user interaction, the Spry framework logic applies a specific CSS class to the HTML container for the widget at run time. For example, if a user tries to submit a form, but has made no selections, Spry applies a class to the widget that causes it to display the error message, “Please make a selection.” The rules that control the style and display states of error messages reside in the CSS file that accompanies the widget, SpryValidationCheckbox.css.

The default HTML for the Validation Checkbox widget, usually inside of a form, comprises a container <span> tag that surrounds the <input type="checkbox"> tag of the check box. The HTML for the Validation Checkbox widget also includes script tags in the head of the document and after the widget’s HTML markup.

For a more comprehensive explanation of how the Validation Checkbox widget works, including a full anatomy of the Validation Checkbox widget’s code, see www.adobe.com/go/learn_dw_sprycheckbox.

**Insert and edit the Validation Checkbox widget**

**Insert the Validation Checkbox widget**

1. Select Insert > Spry > Spry Validation Checkbox.
2. Complete the Input Tag Accessibility Attributes dialog box and click OK.

*Note: You can also insert a Validation Checkbox widget by using the Spry category in the Insert panel.*

**More Help topics**

“Create accessible HTML forms” on page 645

**Specify when validation occurs**

You can set the point at which validation occurs—when the user clicks outside the widget, as the user makes selections, or when the user tries to submit the form.

1. Select a Validation Checkbox widget in the Document window.
2. In the Property inspector (Window > Properties), select the option that indicates when you want validation to occur. You can select all of the options or Submit only.

- **Blur** Validates whenever the user clicks outside the check box.
- **Change** Validates as the user makes selections.
- **Submit** Validates when the user tries to submit the form. The submit option is selected by default, and cannot be deselected.

**Specify a minimum and maximum selection range**

By default, a Validation Checkbox widget is set to required by default. If you insert a number of check boxes on your page, however, you can specify a minimum and maximum selection range. For example, if you have six check boxes within the <span> tag for a single Validation Checkbox widget, and you want to make sure that the user selects at least three check boxes, you can set such a preference for the entire widget.

1. Select a Validation Checkbox widget in the Document window.
2. In the Property inspector (Window > Properties), select the Enforce Range option.
3. Enter a minimum or maximum number (or both) of check boxes that you want the user to select.
Display widget states in Design view
1. Select a Validation Checkbox widget in the Document window.
2. In the Property inspector (Window > Properties), select the state you want to see from the Preview States pop-up menu. For example, select Initial to see the widget in its initial state.

Customize Validation Checkbox widget error messages
By default, error messages for the Validation Checkbox widget appear in red with a 1-pixel border surrounding the text. You can alter the CSS for the Validation Checkbox widget so that you can create a widget that is styled to your liking. For a more advanced list of styling tasks, see [www.adobe.com/go/learn_dw_sprycheckbox_custom](http://www.adobe.com/go/learn_dw_sprycheckbox_custom).

1. Open the SpryValidationCheckbox.css file.

Dreamweaver saves the SpryValidationCheckbox.css file in the SpryAssets folder of your site whenever you create a Spry Validation Checkbox widget. It’s helpful to consult this file because it contains commented information about various styles that apply to the widget.

2. Use the following table to locate the appropriate CSS rule, and then change the default properties, or add your own text-styling properties and values:

<table>
<thead>
<tr>
<th>Text to style</th>
<th>Relevant CSS rule</th>
<th>Relevant properties to change</th>
</tr>
</thead>
<tbody>
<tr>
<td>Error message text</td>
<td>.checkboxRequiredState .checkboxRequiredMsg, .checkboxMinSelectionsState .checkboxMinSelectionsMsg, .checkboxMaxSelectionsState .checkboxMaxSelectionsMsg</td>
<td>color: #CC3333; border: 1px solid #CC3333;</td>
</tr>
</tbody>
</table>

Although you can easily edit rules for the Validation Checkbox widget directly in the accompanying CSS file, you can also use the CSS Styles panel to edit the widget’s CSS. The CSS Styles panel is helpful for locating the CSS classes assigned to different parts of the widget, especially if you use the panel’s Current mode.

More Help topics
“The CSS Styles panel in Current mode” on page 123

Working with the Spry Validation Password widget

About the Validation Password widget
The Spry Validation Password widget is a password text field that you can use to enforce password rules (for example, number and type of characters). The widget provides warning or error messages based upon a user’s input.

Note: You should be familiar with Spry validation widgets before you work with the Password widget. If you’re not familiar with them, see “Working with the Spry Validation Text Field widget” on page 427, or any of the other validation widget overviews before proceeding. This overview does not present all basic validation widget concepts.

The following example shows a Validation Password widget in various states:
The Validation Password widget includes a number of states (for example, valid, required, minimum number of characters, and so on). You can alter the properties of these states by editing the corresponding CSS file (SpryValidationPassword.css), depending on the desired validation results. A Validation Password widget can validate at various points—for example, when the site visitor clicks outside the text field, when they type, or when they try to submit the form.

**Initial state**  When the page loads in the browser, or when the user resets the form.

**Focus state**  When the user places the insertion point in the widget.

**Valid state**  When the user enters information correctly, and the form can be submitted.

**Invalid strength state**  When the user enters text that does not match the strength criteria for the password text field. (For example, if you’ve specified that a password must contain at least two uppercase letters, and the entered password contains no or only one uppercase letter).

**Required state**  When the user fails to enter required text in the text field.

**Minimum Number Of Characters state**  When the user enters fewer than the minimum number of characters required in the password text field.

**Maximum Number Of Characters state**  When the user enters more than the maximum number of characters allowed in the password text field.

For a more comprehensive explanation of how Validation Password widgets work, as well as additional information about widget structure, see [www.adobe.com/go/learn_dw_sprypassword_en](http://www.adobe.com/go/learn_dw_sprypassword_en).

**More Help topics**

Validation Password widget samples

---

**Insert and edit the Validation Password widget**

**Insert the Validation Password widget**

1. Select Insert > Spry > Spry Validation Password.
2. Complete the Input Tag Accessibility Attributes dialog box and click OK.

*Note: You can also insert a Validation Password widget by using the Spry category in the Insert panel.*

**More Help topics**

“Create accessible HTML forms” on page 645
Change required status of a Validation Password widget
By default, all Validation Password widgets that you insert with Dreamweaver require user input when published on a web page. You can, however, make the completion of password text fields optional for the user.

1. Select a Validation Password widget in the Document window by clicking its blue tab.
2. In the Property inspector (Window > Properties), select or deselect the Required option, depending on your preference.

Display widget states in Design view
1. Select a Validation Password widget in the Document window by clicking its blue tab.
2. In the Property inspector (Window > Properties), select the state you want to see from the Preview States pop-up menu. For example, if you want to see the widget in its valid state, select Valid.

Specify when validation occurs
You can set the point at which validation occurs—when the site visitor clicks outside the widget, as the visitor types, or when the visitor tries to submit the form.

1. Select a Validation Password widget in the Document window by clicking its blue tab.
2. In the Property inspector (Window > Properties), select the option that indicates when you want validation to occur. You can select all of the options or Submit only.

Blur Validates whenever the user clicks outside the password text field.

Change Validates as the user changes text inside the password text field.

Submit Validates when the user tries to submit the form. The submit option is selected by default, and cannot be deselected.

Set password strength
Password strength refers to the degree to which combinations of certain characters match the requirements for a password text field. For example, if you’ve created a form in which users are selecting a password, you might want to force your users to include a certain number of uppercase letters in the password, a certain number of special characters, and so on.

Note: By default, none of the available options are set for the Password widget.

1. Click the Validation Password widget’s blue tab to select it.
2. Set options in the Property inspector (Window > Properties) as desired. The numbers that you enter into the option fields are the numbers required for the widget to validate. For example, if you enter 8 in the Minimum characters box, the widget will not validate unless the user has entered at least eight characters in the password text field.

Minimum/Maximum characters Specifies the minimum and maximum number of characters required for the password to be valid.

Minimum/Maximum letters Specifies the minimum and maximum number of letters (a, b, c, and so on) required for the password to be valid.

Minimum/Maximum numbers Specifies the minimum and maximum number of numbers (1, 2, 3, and so on) required for the password to be valid.

Minimum/Maximum uppercase Specifies the minimum and maximum number of uppercase letters (A, B, C, and so on) required for the password to be valid.
**Minimum/Maximum special characters** Specifies the minimum and maximum number of special characters (!, @, #, and so on) required for the password to be valid.

Leaving any of the above options blank causes the widget not to validate against that criterion. For example, if you leave the Minimum/Maximum numbers option blank, the widget does not look for numbers in the password string.

**Customize the Validation Password widget**

Although the Property inspector enables you to make simple edits to a Validation Password widget, it does not support customized styling tasks. You can alter the CSS for the Validation Password widget so that you can create a widget that is styled to your liking. For a more advanced list of styling tasks, see [www.adobe.com/go/learn_dw_sprypassword_custom_en](http://www.adobe.com/go/learn_dw_sprypassword_custom_en).

All CSS rules in the topics below refer to the default rules located in the SpryValidationPassword.css file. Dreamweaver saves the SpryValidationPassword.css file in the SpryAssets folder of your site whenever you create a Spry Validation Password widget. Consulting this file is helpful because it contains commented information about various styles that apply to the widget.

Although you can easily edit rules for the Validation Password widget directly in the accompanying CSS file, you can also use the CSS Styles panel to edit the widget’s CSS. The CSS Styles panel is helpful for locating the CSS classes assigned to different parts of the widget, especially if you use the panel’s Current mode.

**More Help topics**

“The CSS Styles panel in Current mode” on page 123

**Style a Validation Password widget (general instructions)**

1. Open the SpryValidationPassword.css file.
2. Locate the CSS rule for the part of the widget to change. For example, to change the background color of the Password widget’s required state, edit the `input.passwordRequiredState` rule in the SpryValidationPassword.css file.
3. Make your changes to the CSS and save the file.

The SpryValidationPassword.css file contains extensive comments, explaining the code and the purpose for certain rules. For further information, see the comments in the file.

**Style Validation Password widget error message text**

By default, error messages for the Validation Password widget appear in red with a 1-pixel solid border surrounding the text.

❖ To change the text styling of Validation Password widget error messages, use the following table to locate the appropriate CSS rule, and then change the default properties, or add your own text-styling properties and values.

<table>
<thead>
<tr>
<th>Text to change</th>
<th>Relevant CSS rule</th>
<th>Relevant properties to change</th>
</tr>
</thead>
<tbody>
<tr>
<td>Error message text</td>
<td>.passwordRequiredState .passwordRequiredMsg,</td>
<td>color: #CC3333; border: 1px solid #CC3333;</td>
</tr>
<tr>
<td></td>
<td>.passwordMinCharsState .passwordMinCharsMsg,</td>
<td></td>
</tr>
<tr>
<td></td>
<td>.passwordMaxCharsState .passwordMaxCharsMsg,</td>
<td></td>
</tr>
<tr>
<td></td>
<td>.passwordInvalidStrengthState .passwordInvalidStrengthMsg,</td>
<td></td>
</tr>
<tr>
<td></td>
<td>.passwordCustomState .passwordCustomMsg,</td>
<td></td>
</tr>
</tbody>
</table>
Change Validation Password widget background colors

To change the background colors of the Validation Password widget in various states, use the following table to locate the appropriate CSS rule, and then change the default background color values.

<table>
<thead>
<tr>
<th>Color to change</th>
<th>Relevant CSS rule</th>
<th>Relevant property to change</th>
</tr>
</thead>
<tbody>
<tr>
<td>Background color of widget in valid state</td>
<td>.passwordValidState input, input.passwordValidState</td>
<td>background-color: #B8F5B1;</td>
</tr>
<tr>
<td>Background color of widget in invalid state</td>
<td>input.passwordRequiredState, .passwordRequiredState input, input.passwordInvalidStrengthState, .passwordInvalidStrengthState input, input.passwordMinCharsState, .passwordMinCharsState input, input.passwordCustomState, .passwordCustomState input, input.passwordMaxCharsState, .passwordMaxCharsState input</td>
<td>background-color: #FF9F9F;</td>
</tr>
<tr>
<td>Background color of widget in focus</td>
<td>.passwordFocusState input, input.passwordFocusState</td>
<td>background-color: #FFFFCC;</td>
</tr>
</tbody>
</table>

Working with the Spry Validation Confirm widget

About the Validation Confirm widget

The Validation Confirm Widget is a text field or a password form field that displays valid or invalid states when a user enters a value that does not match the value of a similar field in the same form. For example, you can add a Validation Confirm widget to a form that requires a user to retype the password they’ve specified in a previous field. If the user fails to type the password exactly as they’ve specified it previously, the widget returns an error message stating that the values do not match.

You can also use a Validation Confirm widget in conjunction with a Validation Text Field widget to validate email addresses.

**Note:** You should be familiar with Spry validation widgets before you work with the Confirm widget. If you’re not familiar with them, see "Working with the Spry Validation Text Field widget" on page 427, or any of the other validation widget overviews before proceeding. This overview does not present all basic validation widget concepts.

The following illustration shows a typical setup for a Confirm widget:

![Typical setup for a Confirm widget](image)

A. A password field or Spry Password Validation widget  B. Confirm widget

The Validation Confirm widget includes a number of states (for example, valid, invalid, required, and so on). You can alter the properties of these states by editing the corresponding CSS file (SpryValidationConfirm.css), depending on the desired validation results. A Validation Confirm widget can validate at various points—for example, when the site visitor clicks outside the widget, when they type, or when they try to submit the form.

**Initial state** When the page loads in the browser, or when the user resets the form.

**Focus state** When the user places the insertion point in the widget.
Valid state  When the user enters information correctly, and the form can be submitted.

Invalid state  When the user enters text that does not match the text entered in a previous text field, Validation Text Field widget, or Validation Password widget.

Required state  When the user fails to enter required text in the text field.

For a more comprehensive explanation of how Validation Confirm widgets work, as well as additional information about widget structure, see www.adobe.com/go/learn_dw_spryconfirm_en.

More Help topics
Validation Confirm widget samples

Insert and edit the Validation Confirm widget

Insert the Validation Confirm widget
1  Select Insert > Spry > Spry Validation Confirm.
2  Complete the Input Tag Accessibility Attributes dialog box and click OK.

Note: You can also insert a Validation Confirm widget by using the Spry category in the Insert panel.

More Help topics
“Create accessible HTML forms” on page 645

Change required status of a Validation Confirm widget
By default, all Validation Confirm widgets that you insert with Dreamweaver require user input when published on a web page. You can, however, make the completion of confirm text fields optional for the user.

1  Select a Validation Confirm widget in the Document window by clicking its blue tab.
2  In the Property inspector (Window > Properties), select or deselect the Required option, depending on your preference.

Specify the text field to validate against
1  Select a Validation Confirm widget in the Document window by clicking its blue tab.
2  In the Property inspector (Window > Properties), select the text field you want to validate against by selecting a text field from the Validate Against pop-up menu. All text fields with unique IDs assigned to them appear as options in the pop-up menu.

Display widget states in Design view
1  Select a Validation Confirm widget in the Document window by clicking its blue tab.
2  In the Property inspector (Window > Properties), select the state you want to see from the Preview States pop-up menu. For example, if you want to see the widget in its valid state, select Valid.

Specify when validation occurs
You can set the point at which validation occurs—when the site visitor clicks outside the widget, as the visitor types, or when the visitor tries to submit the form.

1  Select a Validation Confirm widget in the Document window by clicking its blue tab.
2 In the Property inspector (Window > Properties), select the option that indicates when you want validation to occur. You can select all of the options or Submit only.

**Blur** Validates whenever the user clicks outside the confirm text field.

**Change** Validates as the user changes text inside the confirm text field.

**Submit** Validates when the user tries to submit the form. The submit option is selected by default, and cannot be deselected.

### Customize the Confirm widget

Although the Property inspector enables you to make simple edits to a Validation Confirm widget, it does not support customized styling tasks. You can alter the CSS for the Validation Confirm widget so that you can create a widget that is styled to your liking. For a more advanced list of styling tasks, see [www.adobe.com/go/learn_dw_spryconfirm_custom_en](http://www.adobe.com/go/learn_dw_spryconfirm_custom_en).

All CSS rules in the topics below refer to the default rules located in the SpryValidationConfirm.css file. Dreamweaver saves the SpryValidationConfirm.css file in the SpryAssets folder of your site whenever you create a Spry Validation Confirm widget. Consulting this file is helpful because it contains commented information about various styles that apply to the widget.

> Although you can easily edit rules for the Validation Confirm widget directly in the accompanying CSS file, you can also use the CSS Styles panel to edit the widget's CSS. The CSS Styles panel is helpful for locating the CSS classes assigned to different parts of the widget, especially if you use the panel's Current mode.

### More Help topics

“[The CSS Styles panel in Current mode](#)” on page 123

### Style a Validation Confirm widget (general instructions)

1 Open the SpryValidationConfirm.css file.

2 Locate the CSS rule for the part of the widget to change. For example, to change the background color of the Confirm widget’s required state, edit the `input.confirmRequiredState` rule in the SpryValidationConfirm.css file.

3 Make your changes to the CSS and save the file.

The SpryValidationConfirm.css file contains extensive comments, explaining the code and the purpose for certain rules. For further information, see the comments in the file.

### Style Validation Confirm widget error message text

By default, error messages for the Validation Confirm widget appear in red with a 1-pixel solid border surrounding the text.

To change the text styling of Validation Confirm widget error messages, use the following table to locate the appropriate CSS rule, and then change the default properties, or add your own text-styling properties and values.

<table>
<thead>
<tr>
<th>Text to change</th>
<th>Relevant CSS rule</th>
<th>Relevant properties to change</th>
</tr>
</thead>
<tbody>
<tr>
<td>Error message text</td>
<td>.confirmRequiredState .confirmRequiredMsg, .confirmInvalidState .confirmInvalidMsg</td>
<td>color: #CC3333; border: 1px solid #CC3333</td>
</tr>
</tbody>
</table>

### Change Validation Confirm widget background colors

To change the background colors of the Validation Confirm widget in various states, use the following table to locate the appropriate CSS rule, and then change the default background color values.
Displaying data with Spry

About Spry data sets

A Spry data set is fundamentally a JavaScript object that holds a collection of data that you specify. With Dreamweaver you can quickly create this object and load data from a data source (such as an XML file or HTML file) into the object. The data set results in an array of data in the form of a standard table containing rows and columns. As you’re creating a Spry data set with Dreamweaver, you can also specify how you want to display the data on a web page.

You can think of a data set as a virtual holding container whose structure is rows and columns. It exists as a JavaScript object whose information is only visible when you specify exactly how to display it on the web page. You can display all of the data in this holding container, or you might choose to display only selected pieces of it.

For complete information on how Spry data sets work, see www.adobe.com/go/learn_dw_sdg_sprydataset_en.

For a video overview from the Dreamweaver engineering team about working with Spry data sets, see www.adobe.com/go/dw10datasets.

For a video tutorial on working with Spry data sets, see www.adobe.com/go/lrvid4047_dw.

Create a Spry data set

Create a Spry HTML data set

1. If you are only creating a data set, you do not need to worry about the insertion point. If you are creating a data set and also inserting a layout, make sure that the insertion point is where you want to insert the layout on the page.

2. Choose Insert > Spry > Spry Data Set.

3. In the Specify Data Source screen, do the following:
   • Select HTML from the Select Data Type pop-up menu. (It’s selected by default.)
   • Specify a name for the new data set. The default name is ds1 the first time you create a data set. The data set name can contain letters, numbers, and underscores, but cannot start with a number.
   • Specify the HTML elements in your data source that you want Dreamweaver to detect. For example, if you’ve organized your data inside a div tag, and you want Dreamweaver to detect div tags instead of tables, select Divs from the Detect pop-up menu. The Custom option lets you type any tag name that you want to detect.
   • Specify the path to the file that contains your HTML data source. The path can be a relative path to a local file in your site (for example, data/html_data.html), or an absolute URL to a live web page (using HTTP or HTTPS). You can click the Browse button to navigate to a local file and select it.
Dreamweaver renders the HTML data source in the Data Selection window, and displays visual markers for the elements that are eligible as containers for the data set. The element you want to use must already have a unique ID assigned to it. If it doesn’t, Dreamweaver will display an error message, and you’ll need to go back to the data source file and assign a unique ID. Additionally, eligible elements in the data source file cannot reside in Spry regions, or contain other data references.

Alternatively you can specify a Design Time Feed as your data source. For more information, see “Use a design-time feed” on page 454.

- Select the element for your data container by clicking one of the yellow arrows that appears in the Data Selection window, or by choosing an ID from the Data Containers pop-up menu.

For lengthy files, you can click the Expand/Collapse arrow at the bottom of the Data Selection window to see more of the data.

Once you select the container element for the data set, Dreamweaver displays a preview of the data set in the Data Preview window.

- (Optional) Select Advanced Data Selection if you want to specify CSS data selectors for the data set. For example, if you specified .product in the Row Selectors text box, and .boximage in the Column Selectors text box, the data set would include only those rows with the .product class assigned to them, and only those columns with the .boximage class assigned to them.

  If you want to type more than one selector in a given text box, separate the selectors with a comma.

  For more information, see “About Spry data selectors” on page 454.

- When you’re finished in the Specify Data Source screen, click Done to create the data set right away, or click Next to go on to the Set Data Options screen. If you click Done, the data set becomes available in the Bindings panel (Window > Bindings).
4 In the Set Data Options screen, do the following:

- (Optional) Set data set column types by selecting a column, and choosing a column type from the Type pop-up menu. For example, if a column in the data set contains numbers, select the column and choose number from the Type pop-up menu. This option is only important if you want your user to be able to sort the data by that column.

You can select a data set column by clicking its header, by choosing it from the Column Name pop-up menu, or by navigating to it using the left and right arrows in the upper-left corner of the screen.

- (Optional) Specify how you want to sort the data by selecting the column you want to sort by from the Sort Columns pop-up menu. Once you’ve selected the column, you can specify whether to sort it in ascending or descending order.

- (Optional: tables only) Deselect Use First Row as Header if you want to use generic column names (that is column0, column1, column 2, and so on) instead of the column names specified in your HTML data source.

**Note:** If you’ve selected something other than a table for the container element of your data set, this option and the next option are not available. Dreamweaver automatically uses column0, column1, column2, and so on, for the column names of non-table-based data sets.

- (Optional: tables only) Select Use Columns as Rows to reverse the horizontal and vertical orientation of the data in the data set. If you select this option, columns will be used as rows.

- (Optional) Select Filter out Duplicate rows to exclude duplicate rows of data from the data set.

- (Optional) Select Disable Data Caching if you always want to have access to the most recent data in the data set. If you want data to autorefresh, select Autorefresh Data and specify a refresh time in milliseconds.

When you’re finished in the Set Data Options screen, click Done to create the data set right away, or click Next to go on to the Choose Insert Options screen. If you click Done, the data set becomes available in the Bindings panel (Window > Bindings).

5 In the Choose Insert Options screen, do one of the following:

- Select a layout for the new data set, and specify the appropriate setup options. For more information, see “Choose a layout for the data set” on page 451.

- Select Do Not Insert HTML. If you select this option, Dreamweaver creates the data set, but does not add any HTML to the page. The data set becomes available from the Bindings panel (Window > Bindings), and you can manually drag pieces of data from the data set to the page.

6 Click Done.

Dreamweaver creates the data set and, if you selected a layout option, displays the layout and data placeholders on your page. If you look in Code view, you’ll see that Dreamweaver has added references in the header to the SpryData.js file and the SpryHTMLDataSet.js file. These files are important Spry assets that work in conjunction with the page. Be sure not to remove this code from your page or the data set will not function. When you upload your page to a server, you’ll also need to upload these files as dependent files.

**Create a Spry XML data set**

1 If you are only creating a data set, you do not need to worry about the insertion point. If you are creating a data set and also inserting a layout, make sure that the insertion point is where you want to insert the layout on the page.

2 Choose Insert > Spry > Spry Data Set.

3 In the Specify Data Source screen, do the following:

- Select XML from the Select Data Type pop-up menu.
• Specify a name for the new data set. The default name is ds1 the first time you create a data set. The data set name can contain letters, numbers, and underscores, but cannot start with a number.

• Specify the path to the file that contains your XML data source. The path can be a relative path to a local file in your site (for example, datafiles/data.xml), or an absolute URL to a page on the web (using HTTP or HTTPS). You can click the Browse button to navigate to a local file and select it.

Dreamweaver renders the XML data source in the Row Elements window, displaying the XML tree of data elements available for selection. Repeating elements are marked with a plus (+) sign, and child elements are indented.

Alternatively you can specify a Design Time Feed as your data source. For more information, see "Use a design-time feed" on page 454.

• Select the element that contains the data you want to display. Typically this element is a repeating element, such as <menu_item>, with several children elements, such as <item>, <link>, <description>, and so on.

Once you select the container element for the data set, Dreamweaver displays a preview of the data set in the Data Preview window. The XPath text box displays an expression that shows where the selected node is located in the XML source file.

**Note:** XPath (XML Path Language) is a syntax for addressing portions of an XML document. It is used mostly as a query language for XML data, just as the SQL language is used to query databases. For more information on XPath, see the XPath language specification on the W3C website at [www.w3.org/TR/xpath](http://www.w3.org/TR/xpath).

• When you’re finished in the Specify Data Source screen, click Done to create the data set right away, or click Next to go on to the Set Data Options screen. If you click Done, the data set becomes available in the Bindings panel (Window > Bindings).
4 In the Set Data Options screen, do the following:

- (Optional) Set data set column types by selecting a column, and choosing a column type from the Type pop-up menu. For example, if a column in the data set contains numbers, select the column and choose number from the Type pop-up menu. This option is only important if you want your user to be able to sort the data by that column.

  You can select a data set column by clicking its header, by choosing it from the Column Name pop-up menu, or by navigating to it using the left and right arrows in the upper-left corner of the screen.

- (Optional) Specify how you want to sort the data by selecting the column you want to sort by from the Sort Column pop-up menu. Once you've selected the column, you can specify whether to sort it in ascending or descending order.

- (Optional) Select Filter Out Duplicate rows to exclude duplicate rows of data from the data set.

- (Optional) Select Disable Data Caching if you always want to have access to the most recent data in the data set. If you want to autorefresh data, select Autorefresh Data and specify a refresh time in milliseconds.

- When you're finished in the Set Data Options screen, click Done to create the data set right away, or click Next to go on to the Choose Insert Options screen. If you click Done, the data set becomes available in the Bindings panel (Window > Bindings).

5 In the Choose Insert Options screen, do one of the following:

- Select a layout for the new data set, and specify the appropriate setup options. For more information, see “Choose a layout for the data set” on page 451.

- Select Do Not Insert HTML. If you select this option, Dreamweaver creates the data set, but does not add any HTML to the page. The data set becomes available from the Bindings panel (Window > Bindings), and you can manually drag pieces of data from the data set to the page.

6 Click Done.

Dreamweaver creates the data set and, if you selected a layout option, displays the layout and data placeholders on your page. If you look in Code view, you’ll see that Dreamweaver has added references in the header to the xpath.js file and the SpryData.js file. These files are important Spry assets that work in conjunction with the page. Be sure not to remove this code from your page or the data set will not function. When you upload your page to a server, you’ll also need to upload these files as dependent files.

Choose a layout for the data set

The Choose Insert Options screen lets you select different display options for how you want to display values from the data set on the page. You can display data using a dynamic Spry Table, a master/detail layout, a stacked containers (single column) layout, or a stacked containers with spotlight area (two-column) layout. A thumbnail depiction of what each layout looks like appears in the Choose Insert Options screen.

Dynamic Table layout

Select this option if you want to display your data in a dynamic Spry Table. Spry Tables allow for dynamic column sorting and other interactive behaviors.

Once you've selected this option, click the Set Up button to open the Insert Table dialog box and follow these steps:

1 In the Columns panel, adjust the columns for your table by doing the following:

- Select a column name and click the minus (-) sign to delete the column from the table. Click the plus (+) sign and select a column name to add new columns to the table.
• Select a column name and click the up or down arrows to move the column. Moving a column up moves it further left in the displayed table; moving a column down moves it to the right.

2 To make a column sortable, select the column in the Columns panel and select Sort Column When Header Is Clicked. By default, all columns are sortable.

If you want to make a column unsortable, select its column name in the Columns panel, and deselect Sort Column When Header Is Clicked.

3 If you have CSS styles associated with your page, either as an attached style sheet or as a set of individual styles in your HTML page, you can apply a CSS class for one or more of the following options:

   **Odd Row Class** Changes the appearance of the odd-numbered rows in the dynamic table according to the selected class style.

   **Even Row Class** Changes the appearance of the even-numbered rows in the dynamic table according to the selected class style.

   **Hover Class** Changes the appearance of a table row when you move the mouse over it according to the selected class style.

   **Select Class** Changes the appearance of a table row when you click it according to the selected class style.

   **Note:** The order of the odd, even, hover, and select classes in your style sheet is very important. The rules should be in the exact order indicated above (odd, even, hover, select). If the hover rule appears below the select rule in the style sheet, the hover effect won’t appear until the user mouses over a different row. If the hover and select rules appear above the even and odd rules in the style sheet, the even and odd effects will not work at all. You can drag rules in the CSS panel to order them correctly, or you can manipulate the CSS code directly.

4 If the table you are creating is going to become a dynamic Spry master table, select Update Detail Region When Row Is Clicked. For more information, see “About dynamic Spry master tables and updating detail regions” on page 455.

5 Click OK to close the dialog box and then click Done in the Choose Insert Options screen.

   If you’re in Design view you’ll see the table appear with a row of headers and a row of data references. The data references are highlighted and enclosed in curly brackets ({}).

**Master/Detail layout**

Select this option if you want to display your data using a master/detail layout. Master/detail layouts let users click an item in the master (left) region that updates the information in the detail (right) region. Typically the master region contains a long list of names, for example a list of available products. When the user clicks one of the product names, the detail region displays much more detailed information about the selection.

Once you’ve selected this option, click the Set Up button to open the Insert Master/Detail Layout dialog box and follow these steps:

1 In the Master Columns panel, adjust the content of your master region by doing the following:

   • Select a column name and click the minus (-) sign to delete the column from the master region. Click the plus (+) sign and select a column name to add new columns to the master region. By default Dreamweaver populates the master region with data from the first column in the data set.

   • Select a column name and click the up or down arrows to move the column. Moving a column up or down in the Master Columns panel sets the order of the data’s appearance in the master region on the page.

2 Repeat the above steps for the Detail Columns panel. By default Dreamweaver populates the detail region with all of the data that is not in the master region (that is, all columns except for the first column in the data set).
3. (Optional) Set different container types for data in the detail region. To do so, select the name of a detail column, and select the container you want to use for it from the Container Type pop-up menu. You can choose from DIV, P, SPAN, or H1–H6 tags.

4. Click OK to close the dialog box and then click Done in the Choose Insert Options screen.

If you’re in Design view you’ll see the master/detail regions appear, populated with your selected data references. The data references are highlighted and enclosed in curly brackets ({}).

**Stacked Containers layout**

Select this option if you want to display your data using a repeating container structure on the page. For example, if you have four columns of data in the data set, each container can include all four columns, and the container structure will repeat itself for each row in the data set.

Once you’ve selected this option, click the Set Up button to open the Insert Stacked Containers dialog box and follow these steps:

1. In the Columns panel, adjust the content of your stacked containers by doing the following:
   - Select a column name and click the minus (-) sign to delete the column from the stacked containers. Click the plus (+) sign and select a column name to add new columns to the containers. By default Dreamweaver populates the stacked containers with data from every column in the data set.
   - Select a column name and click the up or down arrows to move the column. Moving a column up or down in the Columns panel sets the order of the data’s appearance in the stacked containers on the page.

2. (Optional) Set different container types for data in the stacked container. To do so, select the name of a data set column, and select the container you want to use for it from the Container Type pop-up menu. You can choose from DIV, P, SPAN, or H1–H6 tags.

3. Click OK to close the dialog box and then click Done in the Choose Insert Options screen.

If you’re in Design view you’ll see the container, populated with your selected data references. The data references are highlighted and enclosed in curly brackets ({}).

**Stacked Containers with Spotlight Area layout**

Select this option if you want to display your data using a repeating container structure on the page with a spotlight area in each container. Typically, the spotlight area contains a picture. The Spotlight Area layout is similar to the Stacked Containers layout, the difference being that in the Spotlight Area layout, the data display is divided into two separate columns (within the same container).

Once you’ve selected this option, click the Set Up button to open the Insert Spotlight Area Layout dialog box and follow these steps:

1. In the Spotlight Columns panel, adjust the content of your spotlight area by doing the following:
   - Select a column name and click the minus (-) sign to delete the column from the spotlight area. Click the plus (+) sign and select a column name to add new columns to the spotlight area. By default Dreamweaver populates the spotlight area with data from the first column in the data set.
   - Select a column name and click the up or down arrows to move the column. Moving a column up or down in the Spotlight Columns panel sets the order of the data’s appearance in the spotlight area on the page.

2. (Optional) Set different container types for data in the spotlight area. To do so, select the name of a data set column, and select the container you want to use for it from the Container Type pop-up menu. You can choose from DIV, P, SPAN, or H1–H6 tags.
3 Repeat the above steps for the Stacked Columns panel. By default Dreamweaver populates the stacked columns with all of the data that is not in the spotlight area (that is, all columns except for the first column in the data set).

4 Click OK to close the dialog box and then click Done in the Choose Insert Options screen.

   If you’re in Design view you’ll see the spotlight area with stacked containers alongside of it, populated with your selected data references. The data references are highlighted and enclosed in curly brackets ({}).

Do Not Insert HTML
Select this option if you want to create a data set, but do not want Dreamweaver to insert an HTML layout for the data set. The data set becomes available from the Bindings panel (Window > Bindings), and you can manually drag pieces of the data set to the page.

Even if you create a data set without inserting a layout, you can still insert one of the available HTML layouts at any time. To do so, double-click the name of the data set in the Bindings panel, click through to the Choose Insert Options screen, select your layout, and click Done.

   Note: You can also drag the name of the data set from the Bindings panel to the insertion point on the page. When you do so, the Choose Insert Options screen opens. Make your layout selection and click Done.

Edit a data set
After you create a Spry data set, you can edit it at any time.

   ✦ In the Bindings panel (Window > Bindings), double-click the name of your data set, and make your edits.

   Note: When you edit a data set, and select a new layout in the Choose Insert Options screen, Dreamweaver does not replace whatever layout is on the page, but rather inserts a new one.

Use a design-time feed
If you are working with data that is still being developed, you may find it useful to use a design-time feed. For example, if the server developer is still finalizing the database behind your XML data file, you can use a test version of the file to design your page separately from the database development.

When you use a design-time feed, Dreamweaver only populates your work environment with data from that feed. References to the data source that exist in the page code remain references to the real data source you want to use.

1 Begin creating a Spry Data Set (see previous procedures for instructions).

2 In the Specify a Data Source screen, click the Design-time feed link.

3 Click the Browse button to locate the design-time feed and click OK.

About Spry data selectors
When you use Dreamweaver to create a Spry data set, Dreamweaver includes all of the data in a selected container by default. You can refine this selection by using CSS data selectors. CSS data selectors let you include only a portion of the data from the data source by allowing you to specify CSS rules that are attached to certain pieces of data. For example, if you specify .product in the Row Selectors text box of the Specify Data Source screen, Dreamweaver creates a data set that only contains rows with the .product class assigned to them.

   You must select the Advance Data Selection option in the Specify Data Source screen for the data selectors boxes to become active. If you enter data selectors and deselect the option, Dreamweaver retains what you typed in the boxes, but does not use them as filters for the data set.
About dynamic Spry master tables and updating detail regions

One of the most common uses of Spry data sets is to create one or more HTML tables that dynamically update other page data in response to a user action. For example, if a user selects a product from a list of products in a table, the data set can immediately update data elsewhere on the page with detailed information about the selected product. With Spry, these updates do not require a page refresh.

These separate page regions are referred to as master and detail regions. Typically, one area on the page (the master region) displays a list of categorized items (for example, a list of products), and another area of the page (the detail region) displays more information about a selected record.

Each data set maintains the notion of a current row, and by default, the current row is set to the first row of data in the data set. When a user makes different selections in a master region (again, taking the example of a list of different products), Spry actually changes the data set’s current row. Because the detail region is dependent on the master region, any changes that occur from user interaction with the master region (for example, selecting different products), result in changes to the data displayed in the detail region.

Dreamweaver creates master/detail layouts for you automatically, so that all of the correct associations between master and detail regions are in place. But if you want to create a dynamic master table on your own, you have the option of preparing it for association with a detail region later. When you select the Update Detail Regions When Row is Clicked Option (in the Insert Table dialog box), Dreamweaver inserts a `spry:setrow` tag inside the tag for the repeating row of your dynamic table. This attribute prepares the table as a master table that has the ability of resetting the current row of the data set as the user interacts with the table.

For more information on creating master/detail regions by hand, see the Spry Developer Guide at www.adobe.com/go/learn_dw_sdg_masterdetail_en.

Create a Spry region

The Spry framework uses two types of regions: one is a Spry Region that wraps around data objects such as tables and repeat lists, and the other is a Spry Detail Region that is used in conjunction with a master table object to allow dynamic updating of data on a Dreamweaver page.

All Spry data objects must be enclosed in a Spry Region. (If you try to add a Spry data object before adding a Spry region to a page, Dreamweaver prompts you to add a Spry region.) By default, Spry regions are in HTML `<div>` containers. You can add them before you add a table, add them automatically when you insert a table or repeat list, or you can wrap them around existing tables or repeat list objects.

If you are adding a detail region, typically you add the master table object first and select the Update Detail Regions option (see “Dynamic Table layout” on page 451). The only value that is different and specific for a detail region is the Type option in the Insert Spry Region dialog box.

1 Select Insert > Spry > Spry Region.

You can also click the Spry Region button in the Spry category in the Insert panel.

2 For the object container, select the `<div>` or `<span>` option. The default is to use a `<div>` container.

3 Choose one of the following options:
   • To create a Spry Region, select Region (the default) as the type of region to insert.
   • To create a Spry Detail Region, select the Detail Region option. You would only use a detail region if you want to bind dynamic data that updates as data in another Spry region changes.

Important: You need to insert a detail region in a different `<div>` from the master table region. You might need to use Code view to place the insertion point precisely.

Last updated 12/7/2011
4 Choose your Spry data set from the menu.

5 If you want to create or change the region defined for an object, select the object and choose one of the following:

**Wrap Selection** Puts a new region around an object.

**Replace Selection** Replaces an existing region for an object.

6 When you click OK, Dreamweaver puts a region placeholder into your page with the text “Content for Spry Region Goes Here.” You can replace this placeholder text with a Spry data object such as a table or repeat list, or with dynamic data from the Bindings panel (Window > Bindings).

![Image of Bindings panel]

The Bindings panel displays the available data from the data set.

**Note:** In the Bindings panel, there are some built-in Spry elements, ds_RowID, ds_CurrentRowID, and ds_RowCount, also listed. Spry uses these to define the row a user clicked in when determining how to update dynamic detail regions.

7 To replace the placeholder text with a Spry data object (for example, a Spry Table), click the appropriate Spry data object button in the Spry category of the Insert panel.

8 To replace the placeholder text with dynamic data, use one of the following methods:

- Drag one or more elements from the Bindings panel on top of the selected text.
- In Code view, type the code for one or more elements directly. Use this format: `{dataset-name::element-name}`, as in `{ds1::category}` or `{dsProducts::desc}`. If you are only using one data set in your file, or if you are using data elements from the same data set that you defined for the region, you can omit the data set name and simply write `{category}` or `{desc}`.

Regardless of which method you use to define the contents of your region, the following lines are added to your HTML code:

```html
<div spry:region="ds1">{name}{category}</div>
<div spry:region="ds2">{ds1::name}{ds1::descheader}</div>
```

### Create a Spry repeat region

You can add repeat regions to display your data. A repeat region is a simple data structure that you can format as needed to present your data. For example, you can use a repeat region to display a set of photograph thumbnails one after another within a page layout object such as an AP div element.

1 Select Insert > Spry > Spry Repeat.

   You can also click the Spry Repeat button in the Spry category in the Insert panel.

2 For the object container, select the `<div>` or `<span>` option depending on the type of tag you want. The default is to use a `<div>` container.

3 Select the Repeat (default) or Repeat Children option.
If you want more flexibility, you may want to use the Repeat Children option where data validation is done for each line in a list at the child level. For instance, if you have a `<ul>` list, the data is checked at the `<li>` level. If you choose the Repeat option, the data is checked at the `<ul>` level. The Repeat Children option may be especially useful if you use conditional expressions in your code.

4 Choose your Spry data set from the menu.

5 If you already have text or elements selected, you can wrap or replace them.

6 Click OK to display a repeat region on your page.

**Note:** All Spry data objects must be within regions, so make sure you’ve created a Spry region on your page before inserting a repeat region.

7 When you click OK, Dreamweaver inserts a region placeholder into your page with the text “Content for Spry Region Goes Here.” You can replace this placeholder text with a Spry data object such as a table or repeat list or with dynamic data from the Bindings panel (Window > Bindings).

8 To replace the placeholder text with a Spry data object, click the appropriate Spry data object button in the Insert panel.

9 To replace the placeholder text with one or more dynamic data, use one of the following methods:
   - Drag one or more elements from the Bindings panel on top of the selected text.
   - In Code view, type the code for one or more elements directly. Use this format: `{dataset-name::element-name}`, as in `{ds1::category}`. If you are only using one data set in your file, or if you are using data elements from the same data set that you defined for the region, you can omit the data set name and simply write `{category}` or `{desc}`.

Regardless of which method you use to define the contents of your region, the following lines of code are added to your HTML code:

```html
<div spry:region="ds1">{name}{category}</div>
<div spry:region="ds2">{ds1::name}{ds1::descheader}</div>
```

**Create a Spry repeat list region**

You can add repeat lists to display your data as an ordered list, an unordered (bulleted) list, a definition list, or a drop-down list.

1 Select Insert > Spry > Spry Repeat List.
You can also click the Spry Repeat List button in the Spry category in the Insert panel.

2 Select the container tag you want to use: UL, OL, DL, or SELECT. The other options vary depending on which container you choose. If you choose SELECT, you must define the following fields:

- Display Column: This is what users see when they view the page in their browsers.
- Value Column: This is the actual value sent to the background server.

For example, you can create a list of states and show users Alabama and Alaska, but send AL or AK to the server. You can also use the SELECT as a navigational tool and show product names such as “Adobe Dreamweaver” and “Adobe Acrobat” to users, but send URLs such as “support/products/dreamweaver.html” and “support/products/acrobat.html” to the server.

3 Choose your Spry data set from the menu.

4 Choose the columns you want to display.

5 Click OK to display a repeat list region on your page. In Code View, you can see that HTML <ul>, <ol>, <dl> or FORM select tags are inserted into your file.

Note: If you try to insert a repeat list region but you haven’t created a region, Dreamweaver prompts you to add one before inserting the table. All Spry data objects must be contained within regions.

Adding Spry effects

Spry effects overview

Spry effects are visual enhancements that you can apply to almost any element on an HTML page using JavaScript. Effects are often used to highlight information, create animated transitions, or alter a page element visually for a duration of time. You can apply effects to HTML elements without needing additional custom tags.

Note: To apply an effect to an element, it must be currently selected or it must have an ID. If, for example, you are applying highlighting to a div tag that is not currently selected, the div must have a valid ID value. If the element doesn’t already, you will need to add one to the HTML code.

Effects can alter an element’s opacity, scale, position, and styling properties such as background color. You can create interesting visual effects by combining two or more properties.

Because these effects are Spry-based, when a user clicks on an element with an effect, only that element is dynamically updated, without refreshing the entire HTML page.

Spry includes these effects:

- **Appear/Fade** Makes an element appear or fade away.
- **Highlight** Changes the background color of an element.
- **Blind** Simulates a window blind that goes up or down to hide or reveal the element.
- **Slide** Moves the element up or down.
- **Grow/Shrink** Increases or reduces the size of the element.
- **Shake** Simulates shaking the element from left to right.
- **Squish** Makes the element disappear into the upper-left corner of the page.
**Important:** When you use an effect, various lines of code are added to your file in the Code view. One line identifies the SpryEffects.js file, which is necessary to include the effects. Do not remove this line from your code or the effects will not work.

For a comprehensive overview of the Spry effects available in the Spry framework, visit [www.adobe.com/go/learn_dw_spryeffects](http://www.adobe.com/go/learn_dw_spryeffects).

**Apply an Appear/Fade effect**

**Note:** You can use this effect with any HTML elements except `applet`, `body`, `iframe`, `object`, `tr`, `tbody`, or `th`.

1. (Optional) Select the content or layout element you want to apply the effect to.
2. In the Behaviors panel (Window > Behaviors), click the Plus (+) button and select Effects > Appear/Fade from the menu.
3. Select the element’s ID from the target element menu. If you already selected an element, choose `<Current Selection>`.
4. In the Effect Duration box, define the time it takes for the effect to occur, in milliseconds.
5. Select the effect you want to apply: Fade or Appear.
6. In the Fade From box, define the percentage of opacity you want the effect to have when it appears.
7. In the Fade To box, define the percentage of opacity you want to fade to.
8. Select Toggle Effect if you want the effect to be reversible, going from fade to appear and back again with successive clicks.

**Apply a Blind effect**

**Note:** You can only use this effect with these HTML elements: `address`, `dd`, `div`, `dl`, `dt`, `form`, `h1`, `h2`, `h3`, `h4`, `h5`, `h6`, `p`, `ol`, `ul`, `li`, `applet`, `center`, `dir`, `menu`, or `pre`.

1. (Optional) Select the content or layout element you want to apply the effect to.
2. In the Behaviors panel (Window > Behaviors), click the Plus (+) button and select Effects > Blind from the menu.
3. Select the element’s ID from the target element menu. If you already selected an element, choose `<Current Selection>`.
4. In the Effect Duration box, define the time it takes for the effect to occur, in milliseconds.
5. Select the effect you want to apply: Blind Up or Blind Down.
6. In the Blind Up From/Blind Down From box, define the blind-scrolling starting point as a percentage or as a pixel number. These values are calculated from the top of the element.
7. In the Blind Up To/Blind Down To field, define the blind-scrolling end point as a percentage or as a pixel number. These values are calculated from the top of the element.
8. Select Toggle Effect if you want the effect to be reversible, scrolling up and down with successive clicks.

**Apply a Grow/Shrink effect**

**Note:** You can use this effect with these HTML elements: `address`, `dd`, `div`, `dl`, `dt`, `form`, `p`, `ol`, `ul`, `applet`, `center`, `dir`, `menu`, or `pre`.

1. (Optional) Select the content or layout element you want to apply the effect to.
2. In the Behaviors panel (Window > Behaviors), click the Plus (+) button and select Effects > Grow/Shrink from the popup menu.
3 Select the element’s ID from the target element pop-up menu. If you have already selected an element, choose <Current Selection>.

4 In the Effect Duration field, define the time it takes for the effect to occur, in milliseconds.

5 Select the effect you want to apply: Grow or Shrink.

6 In the Grow/Shrink From box, define the element’s size when the effect starts. This is a percentage of the size or a pixel value.

7 In the Grow/Shrink To box, define the element’s size when the effect ends. This is a percentage of the size or a pixel value.

8 If you choose pixels for either the Grow/Shrink From or To boxes, the wide/high field becomes visible. Depending on the option you choose, the element will grow or shrink proportionately.

9 Select whether you want the element to grow or shrink to the upper-left corner of the page or into the page’s center.

10 Select Toggle Effect if you want the effect to be reversible, growing and shrinking with successive clicks.

**Apply a Highlight effect**

*Note: You can use this effect with any HTML elements except applet, body, frame, frameset, or noframes.*

1 (Optional) Select the content or layout element you want to apply the effect to.

2 In the Behaviors panel (Window > Behaviors), click the Plus (+) button and select Effects > Highlight from the menu.

3 Select the element’s ID from the target element menu. If you already selected an element, choose <Current Selection>.

4 In the Effect Duration box, define how long you want the effect to last, in milliseconds.

5 Select the color you want the highlight to start with.

6 Select the color you want the highlight to end with. This color lasts only as long as the duration you define in Effect Duration.

7 Select the color for the element after the highlight has finished.

8 Select Toggle Effect if you want the effect to be reversible, cycling through the highlight colors with successive clicks.

**Apply a Shake effect**

*Note: You can use this effect with these HTML elements: address, blockquote, dd, div, dl, dt, fieldset, form, h1, h2, h3, h4, h5, h6, iframe, img, object, p, ol, ul, li, applet, dir, hr, menu, pre, or table.*

1 (Optional) Select the content or layout element you want to apply the effect to.

2 In the Behaviors panel (Window > Behaviors), click the Plus (+) button and select Effects > Shake from the menu.

3 Select the element’s ID from the target element menu. If you have already selected an element, choose <Current Selection>.

**Apply a Slide effect**

For the Slide effect to work properly the target element must be wrapped in a container tag that has a unique ID. The container tag with which you wrap the target element must be a blockquote, dd, form, div, or center tag.
The target element tag must be one of the following: blockquote, dd, div, form, center, table, span, input, textarea, select, or image.

1. (Optional) Select the container tag of the content you want to apply the effect to.
2. In the Behaviors panel (Window > Behaviors), click the Plus (+) button and select Effects > Slide from the menu.
3. Select the container tag’s ID from the target element menu. If the container is already selected, choose <Current Selection>.
4. In the Effect Duration field, define the time it takes for the effect to occur, in milliseconds.
5. Select the effect you want to apply: Slide Up or Slide Down.
6. In the Slide Up From box, define the sliding starting point as a percentage or as a pixel number.
7. In the Slide Up To box, define the sliding end point as a percentage or as a positive pixel number.
8. Select Toggle Effect if you want the effect to be reversible, sliding up and down with successive clicks.

Apply a Squish effect

Note: You can only use this effect with these HTML elements: address, dd, div, dl, dt, form, img, p, ol, ul, applet, center, dir, menu, or pre.

1. (Optional) Select the content or layout element you want to apply the effect to.
2. In the Behaviors panel (Window > Behaviors), click the Plus (+) button and select Effects > Squish from the menu.
3. Select the element’s ID from the target element menu. If you have already selected an element, choose <Current Selection>.

Add an additional effect

You can associate multiple effect behaviors with the same element to produce interesting results.

1. (Optional) Select the content or layout element you want to apply the effect to.
2. In the Behaviors panel (Window > Behaviors), click the Plus (+) button and select an effect from the Effects menu.
3. Select the element’s ID from the target element menu. If you have already selected an element, choose <Current Selection>.

Delete an effect

You can remove one or more effect behaviors from an element.

1. (Optional) Select the content or layout element you want to apply the effect to.
2. In the Behaviors panel (Window > Behaviors), click the effect you want to delete from the list of behaviors.
3. Do one of the following:
   - Click the Remove Event button in the subpanel title bar (-).
   - Right-click (Windows) or Control-click (Macintosh) the behavior, and select Delete Behavior.
Chapter 16: Designing for multiple screens and devices

Creating media queries (CS5.5 and later)

You can use media queries to specify CSS files based on the reported characteristics of a device. The browser on a device checks the media query and uses the corresponding CSS file to display the web page.

For example, the following media query specifies the phone.css file for devices that are 300-320 pixels wide.

```html
<link href="css/orig/phone.css" rel="stylesheet" type="text/css" media="all and (min-width: 300px) and (max-width: 320px)">
```

For an extensive introduction to media queries see Don Booth’s article on the Adobe Developer Center


For more information on media queries from the W3C see www.w3.org/TR/css3-mediaqueries/.

Create a media query

In Dreamweaver, you can create a site-wide media query file, or a document-specific media query.

**Site-wide media query file** Specifies display settings for all pages in your site that include the file.

The site-wide media query file acts as the central repository for all media queries in your site. After you create this file, link to it from pages in your site that must use the media queries in the file for their display.

**Document-specific media query** The media query is inserted directly into the document, and the page is displayed based on the inserted media query.

1 Create a web page.
2 Select Modify > Media Queries.
3 Do one of the following:
   - To create a site-wide media query file, select Site Wide Media Queries File.
   - To create a document-specific media query, select This Document.
4 For site-wide media query, do the following:
   a Click Specify.
   b Select Create New File.
   c Specify a name for the file, and click OK.
5 It is possible that some devices do not report their actual width. To force devices to report their actual width, ensure that the option Force Devices To Report Actual Width is enabled.
   The following code is inserted into your file when you choose this option.

   ```html
   <meta name="viewport" content="width=device-width">
   ``
6 Do one of the following:
   - Click "+" to define the properties for the media query file.
• Click Default Presets if you want to begin with standard presets.

7 Select rows in the table, and edit their properties using the options under Properties.

**Description** The description of the device for which the CSS file must be used. For example, phone, TV, tablet, and so on.

**Min Width and Max width** The CSS file is used for devices whose reported width is within the specified values.

*Note:* Leave either Min Width or Max Width blank if you do not want to specify an explicit range for a device. For example, it is common to leave Min Width blank if you want to target phones, which are 320px wide, or less.

**CSS file** Select Use Existing File, and browse to the CSS file for the device.

If you want to specify a CSS file that you are yet to create, select Create New File. Enter the name of the CSS file. The file is created when you press OK.

8 Click OK.

9 For site-wide media query, a new file is created. Save it.

Site-wide media query: For existing pages, ensure that you include the media query file in all the pages in the `<head>` tag. Example of a media query link where mediaquery_adobedotcom.css is the site-wide media query file for the site www.adobe.com:

```html
<link href="mediaquery_adobedotcom.css" rel="stylesheet" type="text/css">
```

### Use an existing media queries file

1 Create a web page, or open an existing page.

2 Select Modify > Media Queries.

3 Select Site-Wide Media Queries File.

4 Click Specify.

5 Select Use Existing File if you have already created a CSS file with the Media Query.

6 Click the browse icon to navigate to, and specify the file. Click OK.

7 Select Site-Wide Media Queries File.

8 To force devices to report their actual width, ensure that the option Force Devices To Report Actual Width is enabled. The following code is inserted into your file when you choose this option.

```html
<meta name="viewport" content="width=device-width">
```

9 Click OK.

### Choose a different site-wide media queries file

Use this procedure to change the site-wide media queries file that you have set in the Media Queries dialog box.

1 Select Site > Manage Sites.

2 In the Manage Sites dialog, select your site.

3 Click Edit. The Site Setup dialog box is displayed.

4 Under Advanced Settings in the left panel, select Local Info.

5 In Site-Wide Media Query File on the right panel, click Browse to select the media query CSS file.
Note: Changing the site-wide media queries file does not affect documents linked to a different or previous site-wide media query file.

6 Click Save.

Viewing web pages based on media query
Dimensions specified in a media query appear in the options for Multiscreen button/window size. When you select a dimension from the menu, the following changes are seen:

- The view size changes to reflect the specified dimensions. The document frame size is unaltered.
- The CSS file specified in the media query is used to display the page.

Change page orientation for mobile devices (CS5.5 and later)
In most advanced mobile devices, the orientation of a page changes based on how the device is held. When the user holds the phone vertically, the portrait view is displayed. When the user flips the device horizontally, the page readjusts itself to fit the landscape dimensions.

In Dreamweaver, the option to view a page in either Portrait or Landscape orientation is available in both Live View and Design View. Using these options you can test how your page adapts to these settings. You can then, if necessary, modify your CSS file such that the page is displayed as intended in both these orientations.

❖ Select View > Window Size > Orientation Landscape, or Orientation Portrait.

Creating web applications for mobile devices (CS5.5 and later)
Dreamweaver’s integration with jQuery Mobile helps you quickly design a web application that works on most mobile devices while adapting itself to the dimensions of the device.

More Help topics
http://jquerymobile.com/demos/1.0a3/

Creating a web application using jQuery Mobile

1. Open a jQuery Mobile starter page, or create a HTML5 page
Use the jQuery Mobile starter pages in Dreamweaver to create your application. Alternatively, you can start creating your web application with a new HTML5 page.

The jQuery Mobile starter pages include the HTML, CSS, JavaScript, and image files that help you get started with designing your application. You can use the CSS and JavaScript files hosted on a CDN, your own server, or files installed along with Dreamweaver.

Note: To identify the location of the linked files, see the <link> and <script src> tags in code view.
2. Insert jQuery Mobile components from the Insert panel

Insert jQuery Mobile components from the Insert panel into the HTML page. The jQuery Mobile CSS and JavaScript files define the style and behavior of the components.

About CDNs and local jQuery Mobile files

CDNs

A CDN (content delivery network) is a computer network containing copies of data placed at various points in the network. When you create a web application using the URL for a CDN, the CSS and JavaScript files specified in the URL are used for your application. By default, Dreamweaver uses the jQuery Mobile CDN.

Alternatively, you can use URLs of CDNs from other sites such as Microsoft and Google. In code view, edit the server location of the CSS and JavaScript files specified in the `<link>` and `<script src>` tags.

The files downloaded from a CDN are read-only.

More Help topics

http://docs.jquery.com/Downloading_jQuery#CDN_Hosted_jQuery

Local jQuery Mobile files

When you install Dreamweaver, a copy of the jQuery Mobile files is copied to your computer. The HTML page that opens when you choose the jQuery Mobile (local) starter page is linked to local CSS, JavaScript, and image files.

Starter pages for jQuery Mobile

Dreamweaver provides you with the following starter pages to create your web application:

- **jQuery Mobile (CDN)** Use this starter page if you plan to host the jQuery Mobile library on a CDN.
- **jQuery Mobile (Local)** Use this starter page if you plan to host the assets yourself, or if your application doesn’t rely on an Internet connection.
- **jQuery Mobile (PhoneGap)** Use this starter page if your web application, when deployed as a mobile application, accesses features native to mobile devices. For more information, see “Packaging web applications” on page 467.

Use starter pages to create an application for mobile devices

1. Select File > New.

2. Select one of the following based on your requirement:

   - Page From Sample > Mobile Starters > jQuery Mobile (CDN).
   - Page From Sample > Mobile Starters > jQuery Mobile (Local).

3. Click Create.

   In the page that appears, enable Follow Links Continuously (View > Live View Options), and switch to Live View. Use the navigation components to test how the application works.

   Use the options in the Multiscreen menu to see how the design is displayed in devices with various dimensions. Disable Live view, and switch back to the Design view.

4. In the Insert panel (Window > Insert), select jQuery Mobile. The components that you can add to the web application are displayed.
5 In Design view, place the cursor at the location where you want to insert the component, and click the component in the Insert Panel. In the dialog box that appears, customize the components using the options.

6 (jQuery Mobile - Local) After you save the HTML file, the jQuery Mobile files, including image files, are copied to a folder in the HTML file location.

Preview the page in Live view. Some of the CSS classes are applied only in the Live view.

More Help topics
http://en.wikipedia.org/wiki/Content_delivery_network
http://docs.jquery.com/Downloading_jQuery

Create a web application for mobile devices from a new page
The Page component acts as the container for all the other jQuery Mobile components. Add the Page component before you proceed to insert other components.

1 Select File > New.
2 Select Blank Page > HTML.

Some of the jQuery Mobile components use HTML5-specific attributes. To ensure HTML5 compliance during validation, ensure that you select HTML5 as your DocType.

3 In the Insert panel (Window > Insert), select jQuery Mobile from the menu. The jQuery Mobile components appear in the panel.
4 From the Insert panel, drag the Page component to Design view.
5 In the jQuery Mobile Files dialog, select one of the following:

Remote (CDN) If you want to connect to a remote CDN server hosting the jQuery Mobile files. Use the default option for the jQuery site if you have not configured a site containing jQuery Mobile files. You can also choose to use other CDN servers.

Local The files that are available in Dreamweaver are displayed. To specify a different folder, click Browse, and navigate to the folder containing the jQuery Mobile files.

The CSS and JavaScript files are copied to a local temp directory until you save the HTML file to your computer. After you save the HTML file, all associated jQuery Mobile and image files are copied to a folder in the site’s root folder.

6 Enter the properties for the Page component.
7 In Design view, place the cursor at the location where you want to insert the component, and click the component in the Insert Panel. In the dialog box that appears, customize the components using the options.

Preview the page in Live view. Some of the CSS classes are applied only in the Live view.

Using custom files and folders
You can choose to create custom CSS and JS files for your application. Ensure that your files are named jquery.mobile.js, jquery.mobile.css, and jquery.js

If you are using custom folders, do the following:

1 Download the uncompressed version of the jQuery 1.5 core library from http://docs.jquery.com/Downloading_jQuery#Download_jQuery.
2 Save the file to the core folder containing the other resources.
Packaging web applications

Packaging web applications as native mobile applications (CS5.5 and later)

Dreamweaver’s integration with jQuery Mobile and PhoneGap helps you create and package web applications for deployment on Android™ and iOS-based devices. Dreamweaver uses PhoneGap SDKs to create the package (.apk file for Android/.xcodeproj for iPhone/iPad)

Once you’ve packaged a mobile application with Dreamweaver, you can view it in a device emulator, or deploy it to your own device.

**Important:** The mobile application you package with Dreamweaver is an application for debugging purposes only. The application will run in the Android and iOS emulators, or on your personal mobile device if you make the transfer, but you cannot upload the debug mobile apps to the Apple and Android stores. In order to upload iOS or Android apps, you must take the additional step of signing them outside of Dreamweaver. For more information about uploading applications to the Apple and Android stores, see the Android documentation, or the Program User Guide on the Apple iOS Provisioning Portal. (Before you can access the Apple iOS Provisioning Portal you must register with the Apple Developer Program [free] and enroll in the iOS Developer Program [annual fee].)

More Help topics

http://www.phonegap.com/about

http://jquerymobile.com/demos/1.0a2/

http://docs.phonegap.com/

Create a web application using the starter page

You can use any of the starter pages to create your Web application. However, if your web application, when deployed as a mobile application, accesses features native to mobile devices, use the jQuery Mobile (PhoneGap) page.

The jQuery Mobile (PhoneGap) starter page contains the phonegap.js file in addition to the other jQuery Mobile files. The phonegap.js file contains the APIs required to work with the native mobile features such as GPS, accelerometer, camera, and so on.

1 Select File > New.
2 Select Page From Sample > Mobile Starters > jQuery Mobile (PhoneGap).
3 Click Create.
4 In the Insert panel (Window > Insert), select jQuery Mobile. The components that you can add to the web application are displayed.
5 In Design view, place the cursor at the location where you want to insert the component, and click the component in the Insert Panel. In the dialog box that appears, customize the components using the options.

**Note:** To edit the PhoneGap.js file, configure the application framework and application settings. For more information, see the topics on creating application packages.

Preview the page in Live view. Some of the CSS classes are applied only in Live view.

System requirements for packaging applications

You must ensure that you meet the following system requirements before you can proceed with packaging an application.

Last updated 12/7/2011
MAC OS - iOS
• Mac OS X Snow Leopard version 10.6.x or later
• Xcode 3.2.x with the iOS SDK (Install instructions below.)

MAC OS - Android
• Mac OS X 10.5.8 or later (x86 only)
• Android SDK (Install instructions below.)

Windows - iOS
• iOS is only available for users with an Apple computer

Windows - Android
• Windows XP (32-bit), Vista (32- or 64-bit), or Windows 7 (32- or 64-bit)
• Android SDK (Install instructions below.)

Create an application package (Windows)
For information on creating a web application, including sample files, see this tutorial on the Dreamweaver Developer Center.

1 Open the web application that you want to convert to a mobile application. Ensure that your web application is set up as a site in Dreamweaver, and the size of your site is smaller than 25 MB.

   Note: Ensure that the application contains only HTML5, CSS, and JavaScript files.

2 Select Site > Mobile Applications > Configure Application Framework.

3 Click Easy Install to install the Android SDK.

   Note: If the Easy Install fails, please see tech note 90408.

4 Select a location to install the SDK files, and click Select. After the installation is complete, click Save.

5 Select Site > Mobile Applications > Application Settings.

6 For Bundle ID, enter a name for the package using the information in the dialog box.

7 Enter a name for the application, and the name of the person who designed the application.

8 Optionally, specify the following:
   a In Application Icon PNG, specify a PNG file to be used as the icon for the application. Dreamweaver resizes the icon to the standard size if you haven’t resized it already.
   b Specify a target path for the package.
   c To download and install the latest SDK components from Google, click Manage AVDs. Use the Android SDK and AVD Manager to update the Android SDK. For information on using the manager, see http://developer.android.com/sdk/adding-components.html.

   Note: When you click Save, the phonegap.js file is copied to the site root.

9 Do one of the following:
   • If you are directly deploying your application to a device, select Site > Mobile Applications > Build. Select a platform/device for the build.
   • If you want to see how the build looks on an emulator before you build it, select Site > Mobile Applications > Emulate and Build.
Create an application package (Mac OS)

For a tutorial on creating a web application, including sample files, see this article on the Dreamweaver Developer Center.

1. Open the web application that you want to convert to a mobile application. Ensure that your web application is set up as a site in Dreamweaver, and the size of your site is lesser than 25 MB.

   *Note: Ensure that the application contains only HTML5, CSS, and JavaScript files.*

2. Select Site > Mobile Applications > Configure Application Framework.

3. Install the SDK for iOS or Android based on your requirements:
   - Click the Apple iOS Dev Center link to download and install the xcode and iOS SDK. The application is, by default, installed to the OS <version number>/developer directory.
     
     Log in to the Dev Center using your Apple ID. Registration is free. Create an account if you are not a registered user.

     *Note: You can use the SDK package that you download from the Apple dev center for testing. However, to upload your application to the Apple store, register yourself as an Apple developer after paying the required fee.*

   - Click Easy Install to install the Android SDK.

     *Note: If the Easy Install fails, please see tech note 90408.

4. Click Save.

5. Select Site > Mobile Applications > Application Settings.

6. In Bundle ID, enter a name for the package using the information in the dialog box.

7. Enter a name for the application, and the name of the person who designed the application.

8. Optionally, do the following:
   - (Android) In Application Icon PNG, specify a PNG file to be used as the icon for the Android application. Dreamweaver resizes the icon to the standard size if you haven’t resized it already.
   - (Mac OS 10.6.x) In Startup Screen PNG, specify a PNG file to be used as the icon for the iOS application. Dreamweaver resizes the icon to the standard size if you haven’t resized it already.
   - (Mac OS 10.6.x) Select a version of the iPhone/iPod Touch/iPad for which you are creating the package.
   - Define a different target path for the package.

     *Note: When you click Save, the phonegap.js file is copied to the site root.*

9. Do one of the following:
   - If you are directly deploying your application to a device, select Site > Mobile Applications > Build. Select a platform/device for the build.
   - If you want to see how the build looks like on an emulator before you build it, select Site > Mobile Applications > Emulate and Build.

More Help topics

Packaging web applications tutorial
Preview pages using the Multiscreen Preview panel

Multiscreen preview in Dreamweaver provides a preview of the page that you are currently editing as it would appear on devices supporting different screen resolutions.

To open the Multiscreen Preview panel, select File > Multiscreen preview.

Multiscreen preview supports the following screen types:

- **Phone** (default screen size: 320x300 pixels)
- **Tablet** (default screen size: 768x300 pixels)
- **Desktop** (default screen width: 1126 pixels)

**Note:** If you know the dimensions of any other devices that you want to target, you can specify different styles for different devices. For example, you can create a screen dimension of 480x272 pixels for a Sony PSP device.

The phone, tablet, and desktop dimensions used for previewing are set to default sizes. However, you can change the default sizes by clicking the Viewport Sizes button in the Multiscreen Preview panel.

**Note:** Do not use the Multiscreen Preview panel as a browser. It is not intended to display dynamic media such as movies and audio clips.

### Change the Viewport sizes

1. Select File > Multiscreen Preview to open the Multiscreen Preview panel.
2. In the Multiscreen panel, click Viewport Sizes.
3. Specify viewport sizes and click OK. For example, specify 480 as the width and 272 as the height to target a Sony PSP device.
4. (Optional) Reset settings to their default values by clicking Reset to defaults.

### Add media queries

See “Creating media queries (CS5.5 and later)” on page 462.

### Navigate links

The Multiscreen Preview panel does not sync automatically with Design View or Live View. If you edit in one of these views, click the Refresh button in the Multiscreen Preview panel.

**Note:** If you navigate away from the original file in Live View, the Multiscreen Preview panel does not display the file that you navigated to, even if you click the Refresh button.

Navigate within the Multiscreen Preview panel to navigate away from the original file. Dreamweaver updates all three panes as you navigate within the Multiscreen Preview panel. If you switch between different top-level tabs in Dreamweaver, click the Refresh button in the Multiscreen Preview panel to render the currently selected file.
Chapter 17: Using Adobe Online Services

Using Dreamweaver with Adobe Online services

Adobe online services are hosted web applications that work similarly to traditional desktop tools. The advantage of online services, however, is that they are always up to date because they are hosted on the web, as opposed to on your computer.

Dreamweaver integrates directly with Adobe® BrowserLab and Adobe® Business Catalyst InContext Editing. Help for working with those services is included in the Help sections that follow.

Dreamweaver also integrates with Adobe® CS Live online services (which includes BrowserLab). For more information on working with CS Live, see Using Adobe CS Live.

For information on managing Adobe online services, see the Adobe website at www.adobe.com/go/learn_creativeservices_en.

BrowserLab

Adobe BrowserLab lets you preview local web content from within Dreamweaver, without requiring you to post it to a publicly-accessible server first. You can preview files from your local Dreamweaver site, or from a remote or testing server.

For information about using the BrowserLab online service, including information about using BrowserLab with Dreamweaver, see www.adobe.com/go/lr_abl_en.

Business Catalyst InContext Editing

Business Catalyst InContext Editing

Adobe Business Catalyst InContext Editing is an editing component of Adobe Business Catalyst that lets users make simple content changes within a web browser. To change a web page, users simply browse to the page, log into InContext Editing, and edit the page. The editing options are simple and elegant, and using them requires no previous knowledge of HTML code or web editing.

Before you enable users to make live changes on the web, however, you use Dreamweaver to make your HTML pages editable. You do this by specifying regions on the page that you want to allow users to edit. For example, you might have a news page with titles and blurbs for articles. You can select this content and then transform it into an InContext Editing editable region so that when a user logs into InContext Editing, they can edit the titles and blurbs directly in a browser.

This documentation tells you how to work with InContext Editing editable regions in Dreamweaver; but Adobe also provides other resources to help you work with InContext Editing:

- For documentation on using InContext Editing to edit pages in a browser, see www.adobe.com/go/learn_dw_incontextediting_browser_en.
- For documentation on working with the InContext Editing Administration Panel, see www.adobe.com/go/learn_dw_incontextediting_administration_guide_en.

For more information about Adobe Business Catalyst, visit www.businesscatalyst.com.
Note: Adobe AIR

Note: does not support Adobe Business Catalyst InContext Editing. If you use the AIR Extension for Dreamweaver to export an application that contains InContext Editing regions, the InContext Editing functionality will not work.

Create an InContext Editing editable region

An InContext Editing editable region is a pair of HTML tags that includes the `ice:editable` attribute in the opening tag. The editable region defines an area on the page that a user can edit directly in a browser.

Note: If you are adding an InContext Editing editable region to a page that’s based on a Dreamweaver template, the new InContext Editing editable region must exist within a region that is already editable.

1 Do one of the following:
   - Select a `div`, `th`, or `td` tag that you want to transform into an editable region.
   - Place the insertion point where you want to insert a new editable region on the page.
   - Select exactly one editable region in a Dreamweaver template (DWT file).
   - Select other content on your page that you want to make editable (for example, a block of text).

2 Choose Insert > InContext Editing > Create Editable Region.

3 Your options vary, depending on your selection.
   - If you selected a `div`, `th`, or `td` tag, Dreamweaver transforms the tag into an editable region without any further steps.
   - If you’re inserting a new, blank editable region do one of the following:
     - Select Insert New Editable Region at the Current Insertion Point and click OK. Dreamweaver inserts a `div` tag in your code with the `ice:editable` attribute in the opening tag.
     - Select Transform the Parent Tag Into an Editable Region if you want Dreamweaver to make the parent tag of the selection the container element for the region. Only certain HTML tags are transformable: `div`, `th`, and `td`. Note: This second option is only available when the parent node meets the exact criteria for transformation. For example, it must be one of the listed transformable tags, and it must not be subject to any of the errors listed in “InContext Editing Error messages” on page 475.
   - If you selected a Dreamweaver template editable region, click OK in the Create Editable Region dialog box. Dreamweaver wraps the template editable region with a `div` tag that acts as a container for the new InContext Editing editable region.
   - If you selected other content that you want to make editable, do one of the following:
     - Select Wrap Current Selection With a DIV Tag and Then Transform It if you want to wrap whatever you selected with a `div` tag and turn it into an editable region. The `div` tag with which Dreamweaver wraps the content acts as the container for the editable region.
       Note: Adding `div` tags to pages might alter page rendering and the effects of CSS rules. For example, if you have a CSS rule that applies a red border around `div` tags, you would see a red border around your current selection when Dreamweaver wraps it with a `div` tag and transforms it. If you want to avoid this type of conflict, you can rewrite the CSS rules that affect the current selection, or you can undo the transformation (Edit > Undo), and then select and transform a supported tag that Dreamweaver doesn’t need to wrap with a `div` tag.
     - Select Transform the Parent Tag Into an Editable Region if you want Dreamweaver to make the parent tag of the selection the container element for the editable region. Only certain HTML tags are transformable: `div`, `th`, and `td`.

4 In Design view, click the blue tab of the editable region to select it if it’s not already selected.
Note: If you are working in a Dreamweaver template, be sure to select the InContext Editing editable region (the container region), and not the Dreamweaver template editable region.

5 Select or deselect options in the Editable Regions Property inspector. The options you select will be available to a user when they edit the contents of the editable region in a browser. For example, if you select the Bold option, the user will be able to make text bold; if you select the Numbered List and Bulleted List option, the user will be able to create numbered and bulleted lists; if you select the Link option, the user will be able to create links; and so on. Hover over the icon of each option to see a tooltip of what the option enables.

6 Save the page.

If this is the first time you’re adding InContext Editing functionality to a page, Dreamweaver informs you that it is adding InContext Editing supporting files to your site: ice.conf.js, ice.js, and ide.html. Be sure to upload these files to the server when you upload your page, otherwise InContext Editing functionality will not work in a browser.

Create an InContext Editing repeating region

An InContext Editing repeating region is a pair of HTML tags that includes the ice:repeating attribute in the opening tag. The repeating region defines an area on the page that a user can “repeat” and add content to when editing in a browser. For example, if you have a heading and a paragraph of text that follows it, you can transform these elements into a repeating region that a user can then duplicate on a page.

Repeating regions as seen in an editable InContext Editing browser window. The lower region is selected and can be duplicated again, deleted, or moved up and down.

In addition to adding repeating regions based on the original region, you can also give the user the option to delete regions, add completely new regions (not based on the content of the original region), and to move the regions up or down.

When you create a repeating region, Dreamweaver wraps it in another container called a repeating regions group. This container—a div tag with the ice:repeatinggroup attribute added to the opening tag—acts as the container for all of the editable repeating regions that a user might add to the group. You cannot move repeating regions outside of their repeating regions group containers. Additionally, you should not manually add repeating regions group tags to your page. Dreamweaver adds them for you automatically when necessary.
To create a repeating region in Dreamweaver, follow these steps.

1. Do one of the following:
   - Select a tag that you want to transform into a repeating region. The list of possible tags is extensive: a, abbr, acronym, address, b, big, blockquote, center, cite, code, dd, dfn, dir, div, dl, dt, em, font, h1, h2, h3, h4, h5, h6, hr, i, img, ins, kbd, label, li, menu, ol, p, pre, q, s, samp, small, span, strong, sub, sup, table, tbody, tr, tt, u, ul, and var.
     
     **Note:** Only div tags can contain the editable region and repeating region attributes simultaneously.
   - Place the insertion point where you want to insert a new repeating region on the page.
   - Select exactly one repeating region in a Dreamweaver template (DWT file).
   - Select other content on your page that you want to make repeatable (for example, a heading and a block of text).

2. Choose Insert > InContext Editing > Create Repeating Region.

3. Your options vary, depending on your selection.
   - If you selected a transformable tag, Dreamweaver transforms the tag into a repeating region without any further steps.
   - If you're inserting a new, blank repeating region, do one of the following:
     - Select Insert New Repeating Region at the Current Insertion Point and click OK.
     - Select Transform the Parent Tag Into a Repeating Region if you want Dreamweaver to make the parent tag of the selection the container element for the region. Only certain HTML tags are transformable: a, abbr, acronym, address, b, big, blockquote, center, cite, code, dd, dfn, dir, div, dl, dt, em, font, h1, h2, h3, h4, h5, h6, hr, i, img, ins, kbd, label, li, menu, ol, p, pre, q, s, samp, small, span, strong, sub, sup, table, tbody, tr, tt, u, ul, and var.
     
     **Note:** This second option is only available when the parent node meets the exact criteria for transformation. For example, it must be one of the listed transformable tags, and it must not be subject to any of the errors listed in “InContext Editing Error messages” on page 475.
   - If you selected a Dreamweaver template repeating region, click OK in the Create Repeating Region dialog box. Dreamweaver wraps the template repeating region with a div tag that acts as a container for the new InContext Editing repeating region.
   - If you selected other content that you want to make repeatable, do one of the following:
     - Select Wrap Current Selection With a DIV Tag and Then Transform It if you want to wrap whatever you selected with a div tag and turn it into a repeating region. The div tag with which Dreamweaver wraps the content acts as the container for the repeating region.

*Note: When creating a repeating region from a table row (tr tag), Dreamweaver applies the repeating regions group attribute to the parent tag (for example, the table tag), and does not insert a div tag.

If you are working on a page that already contains a repeating regions group, and you try to add a repeating region immediately after the existing group, Dreamweaver detects that a repeating regions group precedes the region you are trying to add, and gives you the option of adding the new region to the existing group. You can choose to add the new repeating region to the existing group, or create an entirely new repeating regions group.

*Note: If you are adding an InContext Editing repeating region to a page that's based on a Dreamweaver template, the new InContext Editing repeating region must exist within a region that is already editable.*

Last updated 12/7/2011
• Select Transform the Parent Tag Into a Repeating Region if you want Dreamweaver to make the parent tag of the selection the container element for the repeating region. Only certain HTML tags are transformable: `a`, `abbr`, `acronym`, `address`, `b`, `big`, `blockquote`, `center`, `cite`, `code`, `dd`, `dfn`, `dir`, `div`, `dl`, `dt`, `em`, `font`, `h1`, `h2`, `h3`, `h4`, `h5`, `h6`, `hr`, `i`, `img`, `ins`, `kbd`, `label`, `li`, `menu`, `ol`, `p`, `pre`, `q`, `s`, `samp`, `small`, `span`, `strike`, `strong`, `sub`, `sup`, `table`, `tbody`, `tr`, `tt`, `u`, `ul`, and `var`.

4 In Design view, click the blue tab of the repeating region to select it if it’s not already selected. Notice that Dreamweaver actually forces you to select the tab for the repeating regions group. This is because all repeating regions exist within a repeating regions group, and you must set options for repeating regions by setting options for the entire group.

5 Select or deselect options in the Repeating Regions Group Property inspector. Two options are available: Reorder and Add/Remove. When you select Reorder, users will be able to move repeating regions up or down when editing in a browser. When you select Add/Remove, users will be able to add or remove repeating regions when editing in a browser. Both options are selected by default, and you must always have at least one of them selected.

6 Save the page.

If this is the first time you’re adding InContext Editing functionality to a page, Dreamweaver informs you that it is adding InContext Editing supporting files to your site: `ice.conf.js`, `ice.js`, and `ide.html`. Be sure to upload these files to the server when you upload your page, otherwise InContext Editing functionality will not work in a browser.

Delete a region
It’s best to delete a region by using the region’s Property inspector. Using the region’s Property inspector ensures that you delete all of the code associated with the region.

1 Select an editable region, a repeating region, or a repeating regions group.

2 In the region’s Property inspector, click the Remove Region button.

Specify CSS classes for formatting
The InContext Editing Manage Available CSS Classes feature has been deprecated as of Dreamweaver CS5.

InContext Editing Error messages

Cannot apply InContext Editing to tags containing script tags or server-side block(s) of code
If your selection contains server-side code, Dreamweaver does not allow you to transform it into an editable or repeating region. This issue has to do with how InContext Editing saves editable pages when the user is working in the browser. When a user saves the page after editing, InContext Editing removes server-side code from the region.

Current selection cannot be transformed or wrapped with a DIV tag because the parent node doesn’t allow DIV as child tag
When the selection you want to transform on your page can’t be transformed directly, Dreamweaver needs to wrap the selection with div tags that will act as the container for your new editable or repeating region. For this reason, the parent tags of what you want to transform must allow div tags as children. If the parent tag of the tag you’re trying to transform doesn’t permit child div tags, Dreamweaver will not allow you to perform the transformation.

Current selection already contains or is inside of an Editable Region. Nested Editable Regions are not allowed.
If your selection is inside an editable region, or if there is an editable region within the selection, Dreamweaver does not allow you to perform the transformation. InContext Editing does not support nested editable regions.
Editable Regions should not contain Repeating Regions or Repeating Regions Groups
InContext Editing editable regions cannot contain any other InContext Editing functionality. If you try to add a repeating region or a repeating regions group to an editable region, Dreamweaver does not allow you to perform the transformation.

Repeating Regions should not be inside Editable Regions or contain Repeating Regions Groups
InContext Editing editable regions cannot contain any other InContext Editing functionality. If you try to add a repeating region or a repeating regions group to an editable region, Dreamweaver does not allow you to perform the transformation. Additionally, Dreamweaver will not transform an element into an editable or repeating region if it already contains a repeating regions group.

Current selection already contains or is inside of a Repeating Region. Nested Repeating Regions are not allowed.
If your selection is inside a repeating region, or if there is a repeating region within the selection, Dreamweaver does not allow you to perform the transformation. InContext Editing does not support nested repeating regions.

Selection must contain exactly one Dreamweaver template editable/repeating region, or be inside any Dreamweaver template editable region
When working with Dreamweaver template files (.dwt files), you must follow certain rules. To transform a Dreamweaver template editable/repeating region into an InContext Editing editable/repeating region, you must select exactly one Dreamweaver template editable/repeating region on the page and then transform it. To transform another selection on the page (for example, a block of text), the selection must be within a Dreamweaver template editable region.

Only DIV tags can have both Editable Region and Repeating Region functionality applied at the same time
If your selection is not a div tag, and already has a repeating region attribute applied to it, Dreamweaver will not allow you to apply the editable region attribute to that tag as well. Only div tags can have the editable region and repeating region attributes applied simultaneously.

Dreamweaver detected that a Repeating Regions Group tag precedes the Repeating Region
All InContext Editing repeating regions must exist within a repeating regions group. When you add a new repeating region to a page, Dreamweaver detects if there is already a repeating regions group immediately before it. If there is, Dreamweaver gives you the option of adding the new repeating region to the repeating regions group that is already there, or creating a new repeating regions group to contain the new repeating region.
Chapter 18: Displaying XML data with XSLT

About XML and XSLT

Using XML and XSL with web pages

Extensible Markup Language (XML) is a language that lets you structure information. Like HTML, XML lets you structure your information using tags, but XML tags are not predefined as HTML tags are. Instead, XML lets you create tags that best define your data structure (schema). Tags are nested within others to create a schema of parent and child tags. Like most HTML tags, all tags in an XML schema have an opening and closing tag.

The following example shows the basic structure of an XML file:

```xml
<?xml version="1.0">
<mybooks>
  <book bookid="1">
    <pubdate>03/01/2004</pubdate>
    <title>Displaying XML Data with Adobe Dreamweaver</title>
    <author>Charles Brown</author>
  </book>
  <book bookid="2">
    <pubdate>04/08/2004</pubdate>
    <title>Understanding XML</title>
    <author>John Thompson</author>
  </book>
</mybooks>
```

In this example, each parent `<book>` tag contains three child tags: `<pubdate>`, `<title>`, and `<author>`. But each `<book>` tag is also a child tag of the `<mybooks>` tag, which is one level higher in the schema. You can name and structure XML tags in any way, provided that you nest tags accordingly within others, and assign each opening tag a corresponding closing tag.

XML documents do not contain any formatting—they are simply containers of structured information. Once you have an XML schema, you can use the Extensible Stylesheet Language (XSL) to display the information. In the way that Cascading Style Sheets (CSS) let you format HTML, XSL lets you format XML data. You can define styles, page elements, layout, and so forth in an XSL file and attach it to an XML file so that when a user views the XML data in a browser, the data is formatted according to whatever you’ve defined in the XSL file. The content (the XML data) and presentation (defined by the XSL file) are entirely separate, providing you with greater control over how your information appears on a web page. In essence, XSL is a presentation technology for XML, where the primary output is an HTML page.

Extensible Stylesheet Language Transformations (XSLT) is a subset language of XSL that actually lets you display XML data on a web page, and “transform” it, along with XSL styles, into readable, styled information in the form of HTML. You can use Dreamweaver to create XSLT pages that let you perform XSL transformations using an application server or a browser. In a server-side XSL transformation, the server does the work of transforming the XML and XSL, and displaying it on the page. In a client-side transformation, a browser (such as Internet Explorer) does the work.
The approach you ultimately take (server-side transformations versus client-side transformations) depends on what you are trying to achieve as an end result, the technologies available to you, the level of access you have to XML source files, and other factors. Both approaches have their own benefits and limitations. For example, server-side transformations work in all browsers while client-side transformations are restricted to modern browsers only (Internet Explorer 6, Netscape 8, Mozilla 1.8, and Firefox 1.0.2). Server-side transformations let you display XML data dynamically from your own server or from anywhere else on the web, while client-side transformations must use XML data that is locally hosted on your own web server. Finally, server-side transformations require that you deploy your pages to a configured application server, while client-side transformations only require access to a web server.

For a tutorial about understanding XML, see www.adobe.com/go/vid0165.

More Help topics
XML tutorial

Server-side XSL transformations
Dreamweaver provides methods for creating XSLT pages that let you perform server-side XSL transformations. When an application server performs the XSL transformation, the file containing the XML data can reside on your own server, or anywhere else on the web. Additionally, any browser can display the transformed data. Deploying pages for server-side transformations, however, is somewhat complex, and requires that you have access to an application server.

When working with server-side XSL transformations, you can use Dreamweaver to create XSLT pages that generate full HTML documents (entire XSLT pages), or XSLT fragments that generate a portion of an HTML document. An entire XSLT page is similar to a regular HTML page. It contains a `<body>` tag and a `<head>` tag, and lets you display a combination of HTML and XML data on the page. An XSLT fragment is a piece of code, used by a separate document, that displays formatted XML data. Unlike an entire XSLT page, it is an independent file that contains no `<body>` or `<head>` tag. If you want to display XML data on a page of its own, you would create an entire XSLT page, and bind your XML data to it. If, on the other hand, you wanted to display XML data in a particular section of an existing dynamic page—for example, a dynamic home page for a sporting goods store, with sports scores from an RSS feed displayed on one side of the page—you would create an XSLT fragment and insert a reference to it in the dynamic page. Creating XSLT fragments, and using them in conjunction with other dynamic pages to display XML data, is the more common scenario.

The first step in creating these types of pages is to create the XSLT fragment. It is a separate file that contains the layout, formatting, and so on of the XML data that you eventually want to display in the dynamic page. Once you create the XSLT fragment, you insert a reference to it in your dynamic page (for example, a PHP or ColdFusion page). The inserted reference to the fragment works much like an Server Side Include (SSI) — the formatted XML data (the fragment) resides in a separate file, while in Design view, a placeholder for the fragment appears on the dynamic page itself. When a browser requests the dynamic page containing the reference to the fragment, the server processes the included instruction and creates a new document in which the formatted contents of the fragment appear instead of the placeholder.
You use the XSL Transformation server behavior to insert the reference to an XSLT fragment in a dynamic page. When you insert the reference, Dreamweaver generates an includes/MM_XSLTransform/ folder in the site’s root folder that contains a runtime library file. The application server uses the functions defined in this file when transforming the specified XML data. The file is responsible for fetching the XML data and XSLT fragments, performing the XSL transformation, and outputting the results on the web page.

The file containing the XSLT fragment, the XML file containing your data, and the generated run-time library file must all be on the server for your page to display correctly. (If you select a remote XML file as your data source—one from an RSS feed, for example—that file must of course reside somewhere else on the Internet.)

You can also use Dreamweaver to create entire XSLT pages for use with server-side transformations. An entire XSLT page works in exactly the same way as an XSLT fragment, only when you insert the reference to the entire XSLT page using the XSL Transformation server behavior, you are inserting the full contents of an HTML page. Thus, the dynamic page (the .cfm, .php, or .asp page that acts as the container page) must be cleared of all HTML before you insert the reference.

Dreamweaver supports XSL transformations for ColdFusion, ASP, and PHP pages.

**Note:** Your server must be correctly configured to perform server-side transformations. For more information, contact your server administrator.

**More Help topics**

“Performing XSL transformations on the server” on page 484

**Client-side XSL transformations**

You can perform XSL transformations on the client without the use of an application server. You can use Dreamweaver to create an entire XSLT page that will do this; however, client-side transformations require manipulation of the XML file that contains the data you want to display. Additionally, client-side transformations will only work in modern browsers (Internet Explorer 6, Netscape 8, Mozilla 1.8, and Firefox 1.0.2). For more information on browsers that do and don’t support XSL transformations, see [www.w3schools.com/xsl/xsl_browsers.asp](http://www.w3schools.com/xsl/xsl_browsers.asp).
First, create an entire XSLT page and attach an XML data source. (Dreamweaver prompts you to attach the data source when you create the new page.) You can create an XSLT page from scratch, or you can convert an existing HTML page to an XSLT page. When you convert an existing HTML page to an XSLT page you must attach an XML data source using the Bindings panel (Window > Bindings).

After you’ve created your XSLT page, you must link it to the XML file containing the XML data by inserting a reference to the XSLT page in the XML file itself (much like you would insert a reference to an external CSS style sheet in the <head> section of an HTML page). Your site visitors must view the XML file (not the XSLT page) in a browser. When your site visitors view the page, the browser performs the XSL transformation and displays the XML data, formatted by the linked XSLT page.

The relationship between the linked XSLT and XML pages is conceptually similar, yet different from the external CSS/HTML page model. When you have an HTML page that contains content (such as text), you use an external style sheet to format that content. The HTML page determines the content, and the external CSS code, which the user never sees, determines the presentation. With XSLT and XML, the situation is reversed. The XML file (which the user never sees in its raw form), determines the content while the XSLT page determines the presentation. The XSLT page contains the tables, layout, graphics, and so forth that the standard HTML usually contains. When a user views the XML file in a browser, the XSLT page formats the content.

1. Browser requests XML file
2. Server responds by sending XML file to browser
3. Browser reads XML directive and calls XSLT file
4. Server sends XSLT file to browser
5. Browser transforms XML data and displays it in browser

When you use Dreamweaver to link an XSLT page to an XML page, Dreamweaver inserts the appropriate code for you at the top of the XML page. If you own the XML page to which you’re linking (that is, if the XML file exclusively lives on your web server), all you need to do is use Dreamweaver to insert the appropriate code that links the two pages. When you own the XML file, the XSL transformations performed by the client are fully dynamic. That is, whenever you update the data in the XML file, any HTML output using the linked XSLT page will be automatically updated with the new information.

**Note:** The XML and XSL files you use for client-side transformations must reside in the same directory. If they don’t, the browser will read the XML file and find the XSLT page for the transformation, but will fail to find assets (style sheets, images, and so on) defined by relative links in the XSLT page.
If you don’t own the XML page to which you’re linking (for example, if you want to use XML data from an RSS feed somewhere out on the web), the workflow is a bit more complicated. To perform client-side transformations using XML data from an external source, you must first download the XML source file to the same directory where your XSLT page resides. When the XML page is in your local site, you can use Dreamweaver to add the appropriate code that links it to the XSLT page, and post both pages (the downloaded XML file and the linked XSLT page) to your web server. When the user views the XML page in a browser, the XSLT page formats the content, just like in the previous example.

The disadvantage of performing client-side XSL transformations on XML data that comes from an external source is that the XML data is only partially “dynamic.” The XML file that you download and alter is merely a “snapshot” of the file that lives elsewhere on the web. If the original XML file out on the web changes, you must download the file again, link it to the XSLT page, and repost the XML file to your web server. The browser only renders the data that it receives from the XML file on your web server, not the data contained in the original XML source file.

More Help topics
“Performing XSL transformations on the client” on page 500

XML data and repeating elements
The Repeating Region XSLT object lets you display repeating elements from an XML file within a page. Any region containing an XML data placeholder can be turned into a repeated region. However, the most common regions are a table, a table row, or a series of table rows.
The following example shows how the Repeating Region XSLT object is applied to a table row that displays menu information for a restaurant. The initial row displays three different elements from the XML schema: item, description, and price. When the Repeating Region XSLT object is applied to the table row, and the page is processed by an application server or a browser, the table is repeated with unique data inserted in each new table row.

When you apply a Repeating Region XSLT object to an element in the Document window, a thin, tabbed, gray outline appears around the repeated region. When you preview your work in a browser (File > Preview in Browser), the gray outline disappears and the selection expands to display the specified repeating elements in the XML file, as in the previous illustration.

When you add the Repeating Region XSLT object to the page, the length of the XML data placeholder in the Document window is truncated. This is because Dreamweaver updates the XPath (XML Path language) expression for the XML data placeholder so that it is relative to the path of the repeating element.

For example, the following code is for a table that contains two dynamic placeholders, without a Repeating Region XSLT object applied to the table:

```xml
<table width="500" border="1">
  <tr>
    <td><xsl:value-of select="rss/channel/item/title"/></td>
  </tr>
  <tr>
    <td><xsl:value-of select="rss/channel/item/description"/></td>
  </tr>
</table>
```
The following code is for the same table with the Repeating Region XSLT object applied to it:

```xml
<xsl:for-each select="rss/channel/item">
  <table width="500" border="1">
    <tr>
      <td><xsl:value-of select="title"/></td>
    </tr>
    <tr>
      <td><xsl:value-of select="description"/></td>
    </tr>
  </table>
</xsl:for-each>
```

In the previous example, Dreamweaver has updated the XPath for the items that fall within the Repeating Region (title & description) to be relative to the XPath in the enclosing `<xsl:for-each>` tags, rather than the full document.

Dreamweaver generates context-relative XPath expressions in other cases as well. For example, if you drag an XML data placeholder to a table that already has a Repeating Region XSLT object applied to it, Dreamweaver automatically displays the XPath relative to the existing XPath in the enclosing `<xsl:for-each>` tags.

**More Help topics**
“Display repeating XML elements” on page 488

**Previewing XML data**

When you use Preview in Browser (File > Preview in Browser) to preview XML data that you've inserted in an XSLT fragment or an entire XSLT page, the engine that performs the XSL transformation differs from situation to situation. For dynamic pages containing XSLT fragments, the application server always performs the transformation. At other times, either Dreamweaver or the browser might be performing the transformation.

The following table summarizes the situations when using Preview in Browser, and the engines that perform the respective transformations:

<table>
<thead>
<tr>
<th>Type of page previewed in browser</th>
<th>Data transformation performed by</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dynamic page containing XSLT fragment</td>
<td>Application server</td>
</tr>
<tr>
<td>XSLT fragment or entire XSLT page</td>
<td>Dreamweaver</td>
</tr>
<tr>
<td>XML file with link to entire XSLT page</td>
<td>Browser</td>
</tr>
</tbody>
</table>

The following topics provide guidelines for helping you determine the appropriate previewing methods, based on your needs.

**Previewing pages for server-side transformations**

In the case of server-side transformations, the content the site visitor ultimately sees is transformed by your application server. When building XSLT and dynamic pages for use with server-side transformations, it is always preferable to preview the dynamic page that contains the XSLT fragment instead of the XSLT fragment itself. In the former scenario, you make use of the application server, which ensures that your preview is consistent with what your site visitors will see when they visit your page. In the latter scenario, Dreamweaver performs the transformation, and could provide slightly inconsistent results. You can use Dreamweaver to preview your XSLT fragment while you are building it, but you'll be able to see the most accurate results of the data rendering if you use the application server to preview your dynamic page after you've inserted the XSLT fragment.
Previewing pages for client-side transformations
In the case of client-side transformations, the content the site visitor ultimately sees is transformed by a browser. You accomplish this by adding a link from the XML file to the XSLT page. If you open the XML file in Dreamweaver and preview it in a browser, you force the browser to load the XML file and perform the transformation. This provides you with the same experience as that of your site visitor.

Using this approach, however, makes it more difficult to debug your page because the browser transforms the XML and generates the HTML internally. If you select the browser’s View Source option to debug the generated HTML, you will only see the original XML that the browser received, not the full HTML (tags, styles, and so forth) responsible for the rendering of the page. To see the full HTML when viewing source code, you must preview the XSLT page in a browser instead.

Previewing entire XSLT pages and XSLT fragments
When creating entire XSLT pages and XSLT fragments, you’ll want to preview your work to make sure that your data is being displayed correctly. If you use Preview in Browser to display an entire XSLT page or an XSLT fragment, Dreamweaver performs the transformation using a built-in transformation engine. This method gives you quick results, and makes it easier for you to incrementally build and debug your page. It also provides a way for you to view the full HTML (tags, styles, and so forth) by selecting the View Source option in the browser.

Note: This previewing method is commonly used when you begin building XSLT pages, regardless of whether you use the client or the server to transform your data.

Performing XSL transformations on the server

Workflow for performing server-side XSL transformations
You can perform server-side XSL transformations on the server. Read about server-side and client-side XSL transformations and about using XML and XSL with web pages before building pages that display XML data.

Note: Your server must be correctly configured to perform server-side transformations. For more information, contact your server administrator.

The general workflow for performing server-side XSL transformations is as follows (each step is described in other topics):

1. Set up a Dreamweaver site.
2. Choose a server technology and set up an application server.
3. Test the application server.
   For example, create a page that requires processing, and make sure that the application server processes the page.
4. Create an XSLT fragment or page, or convert an HTML page to an XSLT page.
   • In your Dreamweaver site, create an XSLT fragment or an entire XSLT page.
   • Convert an existing HTML page to an entire XSLT page.
5. Attach an XML data source to the page.

6. Display XML data by binding the data to the XSLT fragment or to the entire XSLT page.

7. If appropriate, add a Repeating Region XSLT object to the table or table row that contains the XML data placeholders.

8. Insert references.
   • To insert a reference to the XSLT fragment in your dynamic page, use the XSL Transformation server behavior.
   • To insert a reference to the entire XSLT page in the dynamic page, delete all of the HTML code from a dynamic page, and then use the XSL Transformation server behavior.

9. Post the page and the fragment.
Post both the dynamic page and the XSLT fragment (or entire XSLT page) to your application server. If you are using a local XML file, you will need to post that as well.

10. View the dynamic page in a browser.
When you do so, the application server transforms the XML data, inserts it in the dynamic page, and displays it in the browser.

More Help topics
“Working with Dreamweaver sites” on page 36
“Choosing an application server” on page 513
“Using XML and XSL with web pages” on page 477
“Client-side XSL transformations” on page 479
“Server-side XSL transformations” on page 478

Create an XSLT page
You can create XSLT pages that let you display XML data on web pages. You can create either an entire XSLT page—an XSLT page that contains a <body> tag and a <head> tag—or you can create an XSLT fragment. When you create an XSLT fragment, you create an independent file that contains no body or head tag—a simple piece of code that is later inserted in a dynamic page.

Note: If you are starting with an existing XSLT page, you need to attach an XML data source to it.

1. Select File > New.

2. In the Blank Page category of the New Document dialog box, select one of the following from the Page Type column:
   • Select XSLT (Entire page) to create an entire XSLT page.
   • Select XSLT (Fragment) to create an XSLT fragment.

3. Click Create and do one of the following in the Locate XML Source dialog box:
   • Select Attach A Local File, click the Browse button, browse to a local XML file on your computer, and click OK.
   • Select Attach A Remote File, enter the URL of an XML file on the Internet (such as one coming from an RSS feed), and click OK.
Note: Clicking the Cancel button generates a new XSLT page with no attached XML data source.

The Bindings panel is populated with the schema of your XML data source.

<table>
<thead>
<tr>
<th>Element</th>
<th>Represents</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;&gt;</td>
<td>Required non-repeating XML element</td>
<td>An element that appears exactly once within its parent node</td>
</tr>
<tr>
<td>&lt;&gt;+</td>
<td>Repeating XML element</td>
<td>An element that appears one or more times within its parent node</td>
</tr>
<tr>
<td>&lt;&gt;+</td>
<td>Optional XML element</td>
<td>An element that appears zero or more times within its parent node</td>
</tr>
<tr>
<td>Element node in boldface type</td>
<td>Current context element</td>
<td>Normally the repeating element when the insertion point is inside a repeating region</td>
</tr>
<tr>
<td>@</td>
<td>XML attribute</td>
<td></td>
</tr>
</tbody>
</table>

4  Save your new page (File > Save) with the .xsl or .xslt extension (.xsl is the default).

Convert HTML pages to XSLT pages

You can also convert existing HTML pages to XSLT pages. For example, if you have a predesigned static page to which you want to add XML data, you can convert the page to an XSLT page, instead of creating an XSLT page and redesigning the page from scratch.

1  Open the HTML page that you want to convert.

2  Select File > Convert > XSLT 1.0.

A copy of the page opens in the Document window. The new page is an XSL style sheet, saved with the .xsl extension.

Attach XML data sources

If you are starting with an existing XSLT page, or if you don’t attach an XML data source when creating a new XSLT page with Dreamweaver, you must attach an XML data source using the Bindings panel.

1  In the Bindings panel (Window > Bindings), click the XML link.
Note: You can also click the Source link at the upper-right corner of the Bindings panel to add an XML data source.

2 Do one of the following:
   - Select Attach A Local File, click the Browse button, browse to a local XML file on your computer, and click OK.
   - Select Attach A Remote File, and enter the URL of an XML file on the Internet (such as one coming from an RSS feed).

3 Click OK to close the Locate XML Source dialog box.

The Bindings panel is populated with the schema of your XML data source.

Display XML data in XSLT pages

After you’ve created an XSLT page and attached an XML data source, you can bind data to the page. To do this, you add an XML data placeholder to your page and then use the XPath Expression Builder or the Property inspector to format selected data that will be displayed on the page.

1 Open an XSLT page with an attached XML data source.

2 (Optional) Select Insert > Table to add a table to the page. A table helps you organize your XML data.

Note: In most cases, you use the Repeating Region XSLT object to display repeating XML elements on a page. In this case, you might want to create a single-row table with one or more columns, or a two-row table if you want to include a table header.

3 In the Bindings panel, select an XML element and drag it to the place on the page where you want to insert data.

An XML data placeholder appears on the page. The placeholder is highlighted and in curly brackets. It uses the XPath (XML Path language) syntax to describe the hierarchical structure of the XML schema. For example, if you drag the child element title to the page, and that element has the parent elements rss, channel, and item, then the syntax for the dynamic content placeholder will be {rss/channel/item/title}.

Double-click the XML data placeholder on the page to open the XPath Expression Builder. The XPath Expression Builder lets you format selected data, or select other items from the XML schema.
(Optional) Apply styles to your XML data by selecting an XML data placeholder and applying styles to it like any other piece of content using the Property inspector or the CSS Styles panel. Alternatively, you can use Design-time style sheets to apply styles to XSLT fragments. Each of these methods has its own set of benefits and limitations.

Preview your work in a browser (File > Preview in Browser).

Note: When you preview your work using Preview in Browser, Dreamweaver performs an internal XSL transformation without the use of an application server.

More Help topics
“Previewing XML data” on page 483
“Presenting content with tables” on page 170

Display repeating XML elements
The Repeating Region XSLT object lets you display repeating elements from an XML data source in a web page. For example, if you are displaying article titles and descriptions from a news feed, and that news feed contains between 10 and 20 articles, each title and description in the XML file would probably be a child element of a repeating element.

Any region in Design view containing an XML data placeholder can be changed to a repeated region. However, the most common regions are tables, table rows, or a series of table rows.

In Design view, select a region that contains an XML data placeholder or placeholders.

The selection can be anything, including a table, a table row, or even a paragraph of text.

To select a region on the page precisely, you can use the tag selector in the lower-left corner of the Document window. For example, if the region is a table, click inside the table on the page, and then click the tag in the tag selector.

Do one of the following
- Select Insert > XSLT Objects > Repeating Region.
- In the XSLT category of the Insert panel, click the Repeating Region button.
3 In the XPath Expression Builder, select the repeating element, indicated by a small plus sign.

In the XPath Expression Builder, select the repeating element, indicated by a small plus sign.

4 Click OK.

In the Document window, a thin, tabbed, gray outline appears around the repeated region. When you preview your work in a browser (File > Preview in Browser), the gray outline disappears and the selection expands to display the specified repeating elements in the XML file.

When you add the Repeating Region XSLT object to the page, the XML data placeholder in the Document window is truncated. This is because Dreamweaver truncates the XPath for the XML data placeholder so that it is relative to the path of the repeating element.

More Help topics
“Use the XPath Expression Builder to add expressions for XML data” on page 496
“XML data and repeating elements” on page 481

Set Repeating Region (XSL) properties
In the Property inspector, you can select a different XML node to create the repeating region.

❖ In the Select box, enter a new node, and then press the lightning bolt icon and select the node from the XML schema tree that appears.

Edit a Repeating Region XSLT object
After you've added a Repeating Region XSLT object to a region, you can edit it using the Property inspector.

1 Select the object by clicking the gray tab that surrounds the repeated region.
2 In the Property inspector (Window > Properties), click the dynamic icon next to the Select text field.
3 In the XPath Expression Builder, make your changes and click OK.
Insert XSLT fragments in dynamic pages

After you have created an XSLT fragment, you can insert it in a dynamic web page using the XSL Transformation server behavior. When you add the server behavior to your page and view the page in a browser, an application server performs a transformation that displays the XML data from the selected XSLT fragment. Dreamweaver supports XSL transformations for ColdFusion, ASP, or PHP pages.

Note: If you want to insert the contents of an entire XSLT page in a dynamic page, the procedure is exactly the same. Before using the XSL Transformation server behavior to insert the entire XSLT page, delete all HTML code from the dynamic page.

1. Open an existing ColdFusion, ASP, or PHP page.
2. In Design view, place the insertion point in the location where you want to insert the XSLT fragment.

   Note: When inserting XSLT fragments, you should always click the Show Code And Design Views button after placing the insertion point on the page so that you can ensure that the insertion point is in the correct location. If it isn’t, you might need to click somewhere else in Code view to place the insertion point where you want it.

3. In the Server Behaviors panel (Window > Server Behaviors), click the Plus (+) button and select XSL Transformation.

4. In the XSL Transformation dialog box, click the Browse button and browse to an XSLT fragment or an entire XSLT page. Dreamweaver populates the next text field with the file path or URL of the XML file that is attached to the specified fragment. To change it, click the Browse button and browse to another file.

5. (Optional) Click the Plus (+) button to add an XSLT parameter.

6. Click OK to insert a reference to the XSLT fragment in the page. The fragment is not editable. You can double-click the fragment to open the fragment’s source file and edit it.

An includes/MM_XSLTransform/ folder is also created in the site’s root folder that contains a runtime library file. The application server uses the functions defined in this file to perform the transformation.
7 Upload the dynamic page to your server (Site > Put) and click Yes to include dependent files. The file containing the XSLT fragment, the XML file containing your data, and the generated run-time library file must all be on the server for your page to display correctly. (If you selected a remote XML file as your data source, that file must reside somewhere else on the Internet.)

More Help topics
“Create an XSLT page” on page 485
“Server-side XSL transformations” on page 478

Delete XSLT fragments from dynamic pages
You can remove an XSLT fragment from a page by deleting the XSL Transformation server behavior used to insert the fragment. Deleting the server behavior deletes the XSLT fragment only—it does not delete the associated XML, XSLT, or run-time library files.

1 In the Server Behaviors panel (Window > Server Behaviors), select the XSL Transformation server behavior that you want to delete.
2 Click the minus (-) button.

Note: You should always remove server behaviors in this fashion. Manually deleting the generated code only partially removes the server behavior, even though the server behavior may disappear from the Server Behaviors panel.

Edit XSL Transformation server behaviors
After you’ve added an XSLT fragment to a dynamic web page, you can edit the XSL Transformation server behavior at any time.

1 In the Server Behaviors panel (Window > Server Behaviors), double-click the XSL Transformation server behavior that you want to edit.
2 Make your changes and click OK.

Create a dynamic link
You can create a dynamic link on your XSLT page that links to a specific URL when the user clicks a specified word or group of words from your XML data. For full instructions, see the Dreamweaver errata at www.adobe.com/go/dw_documentation.

Applying styles to XSLT fragments
When you create an entire XSLT page (that is, an XSLT page that contains <body> and <head> tags), you can display XML data on the page and then format the data like any other piece of content using the Property inspector or the CSS Styles panel. When you create an XSLT fragment for insertion in a dynamic page, however (for example, a fragment for insertion in an ASP, PHP, or Cold Fusion page), the rendering of styles in the fragment and in the dynamic page becomes more complicated. Although you work on an XSLT fragment separately from the dynamic page, it is important to remember that the fragment is intended for use within the dynamic page, and that the output from the XSLT fragment ultimately resides somewhere within the <body> tags of the dynamic page. Given this workflow, it is important to make sure that you do not include <head> elements (such as style definitions or links to external style sheets) in XSLT fragments. Doing so will cause the application server to place these elements into the <body> of the dynamic page, thereby generating invalid markup.
For example, you might want to create an XSLT fragment for insertion in a dynamic page and format the fragment using the same external style sheet as the dynamic page. If you attach the same style sheet to the fragment, the resulting HTML page contains a duplicate link to the style sheet (one in the `<head>` section of the dynamic page, and another in the `<body>` section of the page, where the content of the XSLT fragment appears). Instead of this approach, you should use Design-time style sheets to reference the external style sheet.

When formatting the content of XSLT fragments, use the following workflow:

- First, attach an external style sheet to the dynamic page. (This is a best practice for applying styles to the content of any web page).
- Next, attach the same external style sheet to the XSLT fragment as a Design-time style sheet. As the name implies, Design-time style sheets only work in the Dreamweaver Design view.

After you have completed the two previous steps, you can create new styles in your XSLT fragment using the same style sheet that you’ve attached to your dynamic page. The HTML output will be cleaner (because the reference to the style sheet is only valid while working in Dreamweaver), and the fragment will still display the appropriate styles in Design view. Additionally, all of your styles will be applied to both the fragment and the dynamic page when you view the dynamic page in Design view, or preview the dynamic page in a browser.

**Note:** If you preview the XSLT fragment in a browser, the browser does not display the styles. Instead you should preview the dynamic page in the browser to see the XSLT fragment within the context of the dynamic page.

**More Help topics**
“Use Design-Time style sheets” on page 144

**Use parameters with XSL transformations**
You can define parameters for your XSL transformation when adding the XSL Transformation server behavior to a web page. A parameter controls how XML data is processed and displayed. For example, you might use a parameter to identify and list a specific article from a news feed. When the page loads in a browser, only the article you specified with the parameter appears.

**Add an XSLT parameter to an XSL transformation**
1. Open the XSL Transformation dialog box. You can do this by double-clicking an XSL Transformation server behavior in the Server Behaviors panel (Window > Server Behaviors), or by adding a new XSL Transformation server behavior.
2. In the XSL Transformation dialog box, click the Plus (+) button next to XSLT Parameters.
In the Add Parameters dialog box, enter a name for the parameter in the Name box. The name can only contain alphanumeric characters. It cannot contain spaces.

Do one of the following:

- If you want to use a static value, enter it in the Value box.
- If you want to use a dynamic value, click the dynamic icon next to the Value box, complete the Dynamic Data dialog box, and click OK. For more information, click the Help button in the Dynamic Data dialog box.

In the Default Value box, enter the value you want the parameter to use if the page receives no run-time value, and click OK.

**Edit an XSLT parameter**
1. Open the XSL Transformation dialog box. You can do this by double-clicking an XSL Transformation server behavior in the Server Behaviors panel (Window > Server Behaviors), or by adding a new XSL Transformation server behavior.
2. Select a parameter from the XSLT parameters list.
3. Click the Edit button.
4. Make your changes and click OK.

**Delete an XSLT parameter**
1. Open the XSL Transformation dialog box. You can do this by double-clicking an XSL Transformation server behavior in the Server Behaviors panel (Window > Server Behaviors), or by adding a new XSL Transformation server behavior.
2. Select a parameter from the XSLT parameters list.
3. Click the minus (-) button.

**Create and edit conditional XSLT regions**
You can create simple conditional regions or multiple conditional regions on an XSLT page. You can either select an element in Design view and apply a conditional region to the selection, or you can insert a conditional region wherever the insertion point is in the document.

For example, if you wanted to display the word "Unavailable" next to the price of an item when the item is unavailable, you type the text "Unavailable" on the page, select it, and then apply a conditional region to the selected text. Dreamweaver surrounds the selection with `<xsl:if>` tags, and only displays the word "Unavailable" on the page when the data match the conditions of the conditional expression.

**Apply a conditional XSLT region**
You can write a simple conditional expression to insert into your XSLT page. If content is selected when you open the Conditional Region dialog box, the content will be wrapped in an `<xsl:if>` block. If you content is not selected, the `<xsl:if>` block is added at the insertion point on the page. It's a good idea to use the dialog box to get started and then customize the expression in Code view.

The `<xsl:if>` element is similar to the `if` statement in other languages. The element provides a way for you to test a condition and take a course of action based on the result. The `<xsl:if>` element allows you to test an expression for a single true or false value.

1. Select Insert > XSLT Objects > Conditional Region or click the Conditional Region icon in the XSLT category of the Insert panel.
2 In the Conditional Region dialog box, enter the conditional expression to use for the region.
In the following example, you want to test to see if the context node’s @available attribute value is true.

![Conditional Region dialog box](image)

3 Click OK.
The following code is inserted in your XSLT page:

```xml
<xsl:if test="@available='true'">  
  Content goes here  
</xsl:if>
```

**Note:** You must surround string values such as true in quotes. Dreamweaver encodes the quotes for you (&apos;) so that they are entered as valid XHTML.

In addition to testing nodes for values, you can use any of the supported XSLT functions in any conditional statement. The condition is tested for the current node within your XML file. In the following example, you want to test for the last node in the result set:

![Conditional Region dialog box](image)

For more information and examples on writing conditional expressions, see the `<xsl:if>` section in the Reference panel (Help > Reference).

**Apply multiple conditional XSLT regions**
You can write a simple conditional expression to insert into your XSLT page. If content is selected when you open the Conditional Region dialog box, the content is wrapped in an `<xsl:choose>` block. If you do not select content, the `<xsl:choose>` block is added at the insertion point on the page. It’s a good idea to use the dialog box to get started and then customize the expression in Code view.

The `<xsl:choose>` element is similar to the `case` statement in other languages. The element provides a way for you to test a condition and take a course of action based on the result. The `<xsl:choose>` element allows you to test for multiple conditions.

1 Select Insert > XSLT Objects > Multiple Conditional Region or click the Multiple Conditional Region icon in the XLST category of the Insert panel.
2 In the Multiple Conditional Region dialog box, enter the first condition.
In the following example, you want to test to see if the context node’s price subelement is less than 5.

3 Click OK.

In the example, the following code is inserted in your XSLT page:

```xml
<xsl:choose>
  <xsl:when test="price<5">
    Content goes here
  </xsl:when>
  <xsl:otherwise>
    Content goes here
  </xsl:otherwise>
</xsl:choose>
```

4 To insert another condition, place the insertion point in Code view between `<xsl:when>` tag pairs or just before the `<xsl:otherwise>` tag, and then insert a conditional region (Insert > XSLT Objects > Conditional Region).

After you specify the condition and click OK, another `<xsl:when>` tag is inserted in the `<xsl:choose>` block.

For more information and examples on writing conditional expressions, see the `<xsl:choose>` sections in the Reference panel (Help > Reference).

**Set conditional region (If) properties**

The purpose of the Set Conditional Region Property inspector is to change the condition used in a conditional region in your XSL page. The conditional region tests the condition and takes a course of action based on the result.

❖ In the Test box, enter a new condition, and then press Enter.

**Set conditional (When) properties**

The purpose of the Set Conditional Region Property inspector is to change the condition used in a multiple conditional region in your XSL page. The multiple conditional region tests the condition and takes a course of action based on the result.

❖ In the Test box, enter a new condition, and then press Enter.

**Insert XSL comments**

You can add XSL comment tags to a document, or you can wrap a selection in XSL comment tags.

**Add XSL comment tags to a document**

❖ Do one of the following:

- In Design view, select Insert > XSLT Objects > XSL Comment, type the contents of the comment (or leave the box blank), and click OK.
- In Code view, select Insert > XSLT Objects > XSL Comment.
You can also click on the XSL Comment icon in the XSLT category of the Insert panel.

Wrap a selection in XSL comment tags
1. Switch to Code view (View > Code).
2. Select the code you want to comment.
3. In the Coding toolbar, click the Apply Comment button and select Apply <xsl:comment></xsl:comment> Comment.

Use the XPath Expression Builder to add expressions for XML data
XPath (XML Path Language) is a non-XML syntax for addressing portions of an XML document. It is used mostly as a query language for XML data, just as the SQL language is used to query databases. For more information on XPath, see the XPath language specification on the W3C website at www.w3.org/TR/xpath.

The XPath Expression Builder is a Dreamweaver feature that lets you build simple XPath expressions for identifying specific nodes of data and for repeating regions. The advantage of using this method instead of dragging values from the XML schema tree is that you can format the value that is displayed. The current context is identified based on the position of the insertion point in the XSL file when the XPath Expression Builder dialog box is opened. The current context is in boldface type in the XML schema tree. As you make selections within this dialog box, the correct XPath statements, relative to your current context, are generated. This simplifies the process of writing correct XPath expressions for beginners and advanced users.

Note: This feature is designed to help you build simple XPath expressions to identify a specific node or for repeating regions. It does not allow you to edit the expressions by hand. If you need to create complex expressions, use the XPath Expression Builder to get started and then customize your expressions in Code view or with the Property inspector.

Create an XPath expression to identify a specific node
1. Double-click the XML data placeholder on the page to open the XPath Expression Builder.
2. In the XPath Expression Builder (Dynamic Text) dialog box, select any node in the XML schema tree.

The correct XPath expression is written in the Expression box to identify the node.

Note: If you select a different node in the XML schema tree, the expression changes to reflect your choice.
In the following example, you want to display the `price` subelement of the `item` node:

This selection would insert the following code in your XSLT page:

```xml
<xsl:value-of select="price"/>
```

3 (Optional) Select a formatting option from the Format pop-up menu.

Formatting a selection is useful when the value of your node returns a number. Dreamweaver provides a predefined list of formatting functions. For a complete list of available formatting functions and examples, see the Reference panel.

In the following example, you want to format the `price` subelement as a currency with two decimal places:

These options would insert the following code in your XSLT page:

```xml
<xsl:value-of select="format-number(provider/store/items/item/price,'$#.00')"/>
```

4 Click OK.
To display the value of each node in the XML file, apply a repeating region to the element containing the dynamic text (for example, an HTML table row or a paragraph).

For more information and examples on selecting nodes to return a value, see the `<xsl:value-of/>` section in the Reference panel.

**Select a node to repeat**

You can select a node to repeat over and, optionally, to filter the results. In the XPath Expression Builder dialog box, your selected content will be wrapped inside an `<xsl:for-each>` block. If you have not selected content, the `<xsl:for-each>` block will be entered at the insertion point of your cursor.

1. Double-click the XML data placeholder on the page to open the XPath Expression Builder.
2. In the XPath Expression Builder (Repeating Region) dialog box, select the item to repeat in the XML schema tree. The correct XPath expression is written in the Expression box to identify the node.

*Note: Repeating items are identified with a Plus (+) symbol in the XML schema tree.*

In the following example, you want to repeat each `item` node within the XML file.

![XPath Expression Builder (Repeating Region)](image)

When you click OK, the following code is inserted in your XSLT page:

```xml
<xsl:for-each select="provider/store/items/item">
  Content goes here
</xsl:for-each>
```

In some cases, you may want to work with a subset of the repeating nodes—for example, you may only want items where an attribute has a specific value. In this case, you need to create a filter.

**Filter the data to be repeated**

Use a filter to identify repeating nodes that have specific attribute values.

1. In the XML schema tree, select a node to repeat.
2. Click the Build Filter expander button.
3. Click the Plus (+) button to create an empty filter.
4 Enter the filter criteria in the following fields:

Filter By Specifies the repeating node that contains the data you want to filter by. The pop-up menu provides a list of ancestor nodes relative to the node you selected in the XML schema tree.

Where Specifies the attribute or subelement of the Filter By node that will be used to limit the results. You can select an attribute or subelement from the pop-up menu, or you can enter your own XPath expression in this field to identify children that exist deeper within the schema tree.

Operator Specifies the comparison operator to use in the filter expression.

Value Specifies the value to check for in the Filter By node. Enter the value. If dynamic parameters are defined for your XSLT page, you can select one from the pop-up menu.

5 To specify another filter, click the Plus (+) button again.

As you enter values or make selections in the pop-up menus, the XPath expression in the Expression box changes.

In the following example, you want to restrict the result set to those item nodes where the value of the @available attribute is true.

When you click OK, the following code is inserted in your XSLT page:

```xml
<xsl:for-each select="provider/store/items/item[@available = &apos;true&apos;"]>
  Content goes here
</xsl:for-each>
```

**Note:** You need to surround string values such as true in quotes. Dreamweaver encodes the quotes for you (&apos;true&apos;) so that they are entered as valid XHTML.
You can create more complex filters that allow you to specify parent nodes as part of your filter criteria. In the following example, you want to restrict the result set to those item nodes where the store’s @id attribute is equal to 1 and the item’s price node is greater than 5.

When you click OK, the following code is inserted in your XSLT page:

```xml
<xsl:for-each select="provider/store[@id = 1]/items/item[price &gt; 5]">
    Content goes here
</xsl:for-each>
```

For more information and examples of repeating regions, see the `<xsl:for-each>` section in the Reference panel.

### Performing XSL transformations on the client

#### Workflow for performing client-side XSL transformations

You can perform client-side XSL transformations. Read about server-side and client-side XSL transformations and about using XML and XSL with web pages before building pages that display XML data.

The general workflow for performing client-side XSL transformations is as follows (each step is described in other topics):

1. **Set up a Dreamweaver site.**
2. **Create an XSLT page or convert an HTML page to XSLT.**
   - In your Dreamweaver site, create an entire XSLT page.
   - Convert an existing HTML page to an entire XSLT page.
3. Attach an XML data source to the page (if you haven’t already done so).
The XML file that you attach must reside in the same directory as the XSLT page.

4. Bind your XML data to the XSLT page.

5. Display XML data by binding the data to the entire XSLT page.

6. If appropriate, add a Repeating Region XSLT object to the table or table row that contains the XML data placeholder(s).

7. Attach the XSLT page to the XML page.

8. Post both the XML page and the linked XSLT page to your web server.

9. View the XML page in a browser.
When you do so, the browser transforms the XML data, formats it with the XSLT page, and displays the styled page in the browser.

More Help topics
“Working with Dreamweaver sites” on page 36
“Choosing an application server” on page 513
“Link an XSLT page to an XML page” on page 502
“Using XML and XSL with web pages” on page 477
“Client-side XSL transformations” on page 479
“Server-side XSL transformations” on page 478

Creating entire XSLT pages and displaying data
You must use an entire XSLT page for client-side transformations. (XSLT fragments don’t work for this type of transformation.) Follow these general steps for creating, binding XML data to, and formatting XSLT pages for client-side transformations:

1. Create the XSLT page.

2. Display data in the XSLT page.

3. Display repeating elements in the XSLT page.

More Help topics
“Create an XSLT page” on page 485
“Display XML data in XSLT pages” on page 487
“Display repeating XML elements” on page 488
Link an XSLT page to an XML page

After you have an entire XSLT page with dynamic content placeholders for your XML data, you must insert a reference to the XSLT page in the XML page.

Note: The XML and XSL files you use for client-side transformations must reside in the same directory. If they don’t, the browser will read the XML file and find the XSLT page for the transformation, but will fail to find assets (style sheets, images, and so on) defined by relative links in the XSLT page.

1. Open the XML file that you want to link to your XSLT page.
2. Select Commands > Attach an XSLT Stylesheet.
3. In the dialog box, click the Browse button, browse to the XSLT page you want to link to, select it, and click OK.
4. Click OK to close the dialog box and insert the reference to the XSLT page at the top of the XML document.

Missing character entities for XSLT

Specify a missing character entity

In XSLT, some characters are not allowed in certain contexts. For example, you cannot use the less than sign (<) and the ampersand (&) in the text between tags or in an attribute value. The XSLT transformation engine will give you an error if those characters are used incorrectly. To solve the problem, you can specify character entities to replace the special characters.

A character entity is a string of characters that represents other characters. Character entities are either named or numbered. A named entity begins with an ampersand (&) followed by the name or characters, and ends with a semicolon (;). For example, &lt; represents the left angle bracket character (<). Numbered entities also start and end the same way, except that a hash sign (#) and a number specify the character.

XSLT has the following five predefined entities:

<table>
<thead>
<tr>
<th>Character</th>
<th>Entity Code</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt; (less-than)</td>
<td>&lt;</td>
</tr>
<tr>
<td>&amp; (ampersand)</td>
<td>&amp;</td>
</tr>
<tr>
<td>&gt; (greater-than)</td>
<td>&gt;</td>
</tr>
<tr>
<td>' (quote)</td>
<td>&quot;</td>
</tr>
<tr>
<td>' (apostrophe)</td>
<td>'</td>
</tr>
</tbody>
</table>

If you use other character entities in an XSL file, you need to define them in the DTD section of the XSL file. Dreamweaver provides several default entity definitions that you can see at the top of an XSL file created in Dreamweaver. These default entities cover a broad selection of the most commonly used characters.

When you preview your XSL file in a browser, Dreamweaver checks the XSL file for undefined entities and notifies you if an undefined entity is found.

If you preview an XML file attached to an XSLT file or if you preview a server-side page with an XSLT transformation, the server or browser (instead of Dreamweaver) notifies you of an undefined entity. The following is an example of a message you may get in Internet Explorer when you request an XML file transformed by an XSL file with a missing entity definition:
Reference to undefined entity 'auml'. Error processing resource 'http://localhost/testthis/list.xsl'. Line 28, Position 20

To correct the error in your page, you must add the entity definition to your page manually.

**Specify a missing entity definition**

1. Look up the missing character in the character entity reference page on the W3C website at [www.w3.org/TR/REC-html40/sgml/entities.html](http://www.w3.org/TR/REC-html40/sgml/entities.html).

This web page contains the 252 allowed entities in HTML 4 and XHTML 1.0.

For example, if the character entity Egrave is missing, search for "Egrave" on the W3C web page. You will find the following entry:

```xml
<!ENTITY Egrave CDATA "&#200;" -- latin capital letter E with grave, U+00C8 ISOlat1 -->
```

2. Make a note of the entity name and entity code in the entry.

In the example, Egrave is the entity name, and `&#200` is the entity code.

3. With this information, switch to Code view and enter the following entity tag at the top of your XSL file (following the Doctype declaration and with the other entity tags):

```xml
<!ENTITY entityname "entitycode;">
```

In the example, you would enter the following entity tag:

```xml
<!ENTITY Egrave "&#200;"> 
```

4. Save your file.

If you repeatedly use the same character entities, you may want to permanently add their definitions in the XSL files Dreamweaver creates by default when you use File > New.

**Add entity definitions to the XSL files Dreamweaver creates by default**

1. Locate the following configuration file in the Dreamweaver application folder and open it in any text editor:

   `Configuration/DocumentTypes/MMDocumentTypeDeclarations.xml`

2. Locate the declaration called `mm_xslt_1`:

   ```xml
   <documenttypedeclaration id="mm_xslt_1"> 
   ```

3. Enter the new entity tag or tags in the list of entity tags, as follows:

   ```xml
   <!ENTITY entityname "entitycode;">
   ```

4. Save the file and restart Dreamweaver.
Chapter 19: Preparing to build dynamic sites

Before you begin building dynamic web pages, there are a few preparations that must be done, including setting up a web application server and connecting to a database for Coldfusion, ASP, and PHP applications. Adobe® Dreamweaver® CS5 handles database connections differently depending on your server technology.

Understanding web applications

About web applications

A web application is a website that contains pages with partly or entirely undetermined content. The final content of a page is determined only when the visitor requests a page from the web server. Because the final content of the page varies from request to request based on the visitor’s actions, this kind of page is called a dynamic page.

Web applications are built to address a variety of challenges and problems. This section describes common uses for web applications and gives a simple example.

Common uses for web applications

Web applications have many uses for both site visitors and developers, including the following:

• Let visitors find information quickly and easily on a content-rich website.
  
  This kind of web application gives visitors the ability to search, organize, and navigate content as they see fit. Examples include company intranets, Microsoft MSDN (www.msdn.microsoft.com), and Amazon.com (www.amazon.com).

• Collect, save, and analyze data provided by site visitors.
  
  In the past, data entered in HTML forms was sent as e-mail messages to employees or CGI applications for processing. A web application can save form data directly into a database and also extract the data and create web-based reports for analysis. Examples include online banking pages, store check-out pages, surveys, and user-feedback forms.

• Update websites that have constantly changing content.
  
  A web application frees the web designer from continually updating the site’s HTML. Content providers such as news editors provide the web application with content, and the web application updates the site automatically. Examples include the Economist (www.economist.com) and CNN (www.cnn.com).

Web application example

Janet is a professional web designer and longtime Dreamweaver user responsible for maintaining the intranet and Internet sites of a medium-sized company of 1000 employees. One day, Chris from Human Resources comes to her with a problem. HR administers an employee fitness program that gives employees points for every mile walked, biked, or run. Each employee must report his or her monthly mile totals in an e-mail to Chris. At the end of the month, Chris gathers all the e-mail messages and awards employees small cash prizes according to their point totals.
Chris’s problem is that the fitness program has grown too successful. So many employees now participate that Chris is inundated with e-mails at the end of each month. Chris asks Janet if a web-based solution exists.

Janet proposes an intranet-based web application that performs the following tasks:
- Lets employees enter their mileage on a web page using a simple HTML form
- Stores the employees’ mileage in a database
- Calculates fitness points based on the mileage data
- Lets employees track their monthly progress
- Gives Chris one-click access to point totals at the end of each month

Janet gets the application up and running before lunchtime using Dreamweaver, which has the tools she needs to build this kind of application quickly and easily.

**How a web application works**

A web application is a collection of static and dynamic web pages. A *static web page* is one that does not change when a site visitor requests it: The web server sends the page to the requesting web browser without modifying it. In contrast, a *dynamic web page* is modified by the server before it is sent to the requesting browser. The changing nature of the page is why it’s called dynamic.

For example, you could design a page to display fitness results, while leaving certain information (such as employee name and results) to be determined when the page is requested by a particular employee.

The next sections describe how web applications work in greater detail.

**Processing static web pages**

A static website comprises a set of related HTML pages and files hosted on a computer running a web server.

A web server is software that serves web pages in response to requests from web browsers. A page request is generated when a visitor clicks a link on a web page, selects a bookmark in a browser, or enters a URL in a browser’s address text box.

The final content of a static web page is determined by the page designer and doesn’t change when the page is requested. Here’s an example:

```html
<html>
  <head>
    <title>Trio Motors Information Page</title>
  </head>
  <body>
    <h1>About Trio Motors</h1>
    <p>Trio Motors is a leading automobile manufacturer.</p>
  </body>
</html>
```

Every line of the page’s HTML code is written by the designer before the page is placed on the server. Because the HTML doesn’t change once it’s on the server, this kind of page is called a static page.

**Note:** Strictly speaking, a “static” page may not be static at all. For example, a rollover image or Flash content (a SWF file) can make a static page come alive. However, this documentation refers to a page as static if it is sent to the browser without modifications.

When the web server receives a request for a static page, the server reads the request, finds the page, and sends it to the requesting browser, as the following example shows:
In the case of web applications, certain lines of code are undetermined when the visitor requests the page. These lines must be determined by some mechanism before the page can be sent to the browser. The mechanism is discussed in the following section.

**Processing dynamic pages**

When a web server receives a request for a static web page, the server sends the page directly to the requesting browser. When the web server receives a request for a dynamic page, however, it reacts differently: It passes the page to a special piece of software responsible for finishing the page. This special software is called an application server.

The application server reads the code on the page, finishes the page according to the instructions in the code, and then removes the code from the page. The result is a static page that the application server passes back to the web server, which then sends the page to the requesting browser. All the browser gets when the page arrives is pure HTML. Here's a view of the process:

1. Web browser requests dynamic page.  
2. Web server finds page and passes it to application server.  
3. Application server scans page for instructions and finishes page.  
4. Application server passes finished page back to web server  
5. Web server sends finished page to requesting browser
Accessing a database

An application server lets you work with server-side resources such as databases. For example, a dynamic page may instruct the application server to extract data from a database and insert it into the page’s HTML. For more information, see www.adobe.com/go/learn_dw_dbguide.

Using a database to store content allows you to separate your website’s design from the content you want to display to site users. Instead of writing individual HTML files for every page, you only need to write a page—or template—for the different kinds of information you want to present. You can then upload content into a database and then have the website retrieve that content in response to a user request. You can also update information in a single source, and then populate that change throughout the website without having to manually edit each page. You can use Adobe® Dreamweaver® CS5 to design web forms to insert, update, or delete data from the database.

The instruction to extract data from a database is called a database query. A query consists of search criteria expressed in a database language called SQL (Structured Query Language). The SQL query is written into the page’s server-side scripts or tags.

An application server cannot communicate directly with a database because the database’s proprietary format renders the data undecipherable in much the same way that a Microsoft Word document opened in Notepad or BBEdit may be undecipherable. The application server can communicate with the database only through the intermediary of a database driver: software that acts like an interpreter between the application server and the database.

After the driver establishes communication, the query is executed against the database and a recordset is created. A recordset is a set of data extracted from one or more tables in a database. The recordset is returned to the application server, which uses the data to complete the page.

Here’s a simple database query written in SQL:

```
SELECT lastname, firstname, fitpoints
FROM employees
```

This statement creates a three-column recordset and fills it with rows containing the last name, first name, and fitness points of all employees in the database. For more information, see www.adobe.com/go/learn_dw_sqlprimer.

The following example shows the process of querying a database and returning data to the browser:
1. Web browser requests dynamic page. 2. Web server finds page and passes it to application server. 3. Application server scans page for instructions. 4. Application server sends query to database driver. 5. Driver executes the query against the database. 6. Recordset is returned to driver. 7. Driver passes recordset to application server. 8. Application server inserts data in page, and then passes the page to the web server. 9. Web server sends finished page to requesting browser.

You can use almost any database with your web application, as long as the appropriate database driver for it is installed on the server.

If you plan to build small low-cost applications, you can use a file-based database, such as one created in Microsoft Access. If you plan to build robust, business-critical applications, you can use a server-based database, such as one created in Microsoft SQL Server, Oracle 9i, or MySQL.

If your database is located on a system other than your web server, make sure you have a fast connection between the two systems so that your web application can operate quickly and efficiently.

More Help topics
Beginner’s guide to databases

Authoring dynamic pages

Authoring a dynamic page consists of writing the HTML first, and then adding the server-side scripts or tags to the HTML to make the page dynamic. When you view the resulting code, the language appears embedded in the page’s HTML. Accordingly, these languages are known as HTML embedded programming languages. The following basic example uses ColdFusion Markup Language (CFML):

```html
<HTML>
<p data
</HTML>
```
The embedded instructions on this page perform the following actions:

1. Create a variable called `department` and assign the string "Sales" to it.
2. Insert the variable's value, "Sales", in the HTML code.

The application server returns the following page to the web server:

```html
<html>
<head>
  <title>Trio Motors Information Page</title>
</head>
<body>
  <h1>About Trio Motors</h1>
  <p>Trio Motors is a leading automobile manufacturer.</p>
  <cfset department="Sales">
  <cfoutput>
    <p>Be sure to visit our #department# page.</p>
  </cfoutput>
</body>
</html>
```

The web server sends the page to the requesting browser, which displays it as follows:

**About Trio Motors**

*Trio Motors is a leading automobile manufacturer.*

*Be sure to visit our Sales page.*

You choose a scripting or tag-based language to use depending on the server technology available on your server. Here are the most popular languages for the server technologies supported by Dreamweaver:

<table>
<thead>
<tr>
<th>Server technology</th>
<th>Language</th>
</tr>
</thead>
<tbody>
<tr>
<td>ColdFusion</td>
<td>ColdFusion Markup Language (CFML)</td>
</tr>
<tr>
<td>Active Server Pages (ASP)</td>
<td>VBScript</td>
</tr>
<tr>
<td></td>
<td>JavaScript</td>
</tr>
<tr>
<td>PHP</td>
<td>PHP</td>
</tr>
</tbody>
</table>

Dreamweaver can create the server-side scripts or tags necessary to make your pages work, or you can write them by hand in the Dreamweaver coding environment.
Web application terminology

This section defines frequently used terms relating to web applications.

**An application server**  Software that helps a web server process web pages containing server-side scripts or tags. When such a page is requested from the server, the web server hands the page off to the application server for processing before sending the page to the browser. For more information, see “How a web application works” on page 505.

Common application servers include ColdFusion and PHP.

**A database**  A collection of data stored in tables. Each row of a table constitutes one record and each column constitutes a field in the record, as shown in the following example:

<table>
<thead>
<tr>
<th>Number</th>
<th>LastName</th>
<th>FirstName</th>
<th>Position</th>
<th>Goal</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**A database driver**  Software that acts as an interpreter between a web application and a database. Data in a database is stored in a proprietary format. A database driver lets the web application read and manipulate data that would otherwise be undecipherable.

**A database management system**  (DBMS, or database system) Software used to create and manipulate databases. Common database systems include Microsoft Access, Oracle 9i, and MySQL.

**A database query**  The operation that extracts a recordset from a database. A query consists of search criteria expressed in a database language called SQL. For example, the query can specify that only certain columns or only certain records be included in the recordset.

**A dynamic page**  A web page customized by an application server before the page is sent to a browser.

**A recordset**  A set of data extracted from one or more tables in a database, as in the following example:
A relational database  A database containing more than one table, with the tables sharing data. The following database is relational because two tables share the DepartmentID column.

A server technology  The technology that an application server uses to modify dynamic pages at runtime.

The Dreamweaver development environment supports the following server technologies:

- Adobe® ColdFusion®
- Microsoft Active Server Pages (ASP)
- PHP: Hypertext Preprocessor (PHP)

You can also use the Dreamweaver coding environment to develop pages for any other server technology not listed.

A static page  A web page that is not modified by an application server before the page is sent to a browser. For more information, see “Processing static web pages” on page 505.

A web application  A website that contains pages with partly or entirely undetermined content. The final content of these pages is determined only when a visitor requests a page from the web server. Because the final content of the page varies from request to request based on the visitor’s actions, this kind of page is called a dynamic page.

A web server  Software that sends out web pages in response to requests from web browsers. A page request is generated when a visitor clicks a link on a web page in the browser, selects a bookmark in the browser, or enters a URL in the browser’s address text box.

Popular web servers include Microsoft Internet Information Server (IIS) and Apache HTTP Server.

Set up your computer for application development

What you need to build web applications

To build web applications in Adobe® Dreamweaver® CS5, you need the following software:

- A web server
- An application server that works with your web server

  Note: In the context of web applications, the terms web server and application server refer to software, not hardware.

  If you want to use a database with your application, you require the following additional software:

- A database system
- A database driver that supports your database
Several web hosting companies offer plans that let you use their software to test and deploy web applications. In some cases, you can install the required software on the same computer as Dreamweaver for development purposes. You can also install the software on a network computer (typically a Windows 2000 or XP computer) so that other developers on your team can work on a project.

If you want to use a database with your web application, you must first connect to it.

More Help topics
“Setting up a ColdFusion development environment” on page 514
“Setting up a PHP development environment” on page 514
“Setting up an ASP development environment” on page 514

Web server basics
To develop and test dynamic web pages, you need a functioning web server. A web server is software that serves web pages in response to requests from web browsers. A web server is sometimes called an HTTP server. You can install and use a web server on your local computer.

If you’re a Macintosh user, you can use the Apache web server already installed on your Macintosh.

Note: Adobe does not provide technical support for third-party software such as Microsoft Internet Information Server. If you need assistance with a Microsoft product, please contact Microsoft technical support.

If you use Internet Information Server (IIS) to develop web applications, the default name of your web server is the name of your computer. You can change the server name by changing the name of your computer. If your computer has no name, the server uses the word localhost.

The server name corresponds to the server’s root folder, which (on a Windows computer) is most likely C:\Inetpub\wwwroot. You can open any web page stored in the root folder by entering the following URL in a browser running on your computer:

http://your_server_name/your_file_name

For example, if the server name is mer_noire and a web page called soleil.html is stored in C:\Inetpub\wwwroot, you can open the page by entering the following URL in a browser running on the local computer:

http://mer_noire/soleil.html

Note: Remember to use forward slashes, not backslashes, in URLs.

You can also open any web page stored in any subfolder of the root folder by specifying the subfolder in the URL. For example, suppose the soleil.html file is stored in a subfolder called gamelan, as follows:

C:\Inetpub\wwwroot\gamelan\soleil.html

You can open this page by entering the following URL in a browser running on your computer:

http://mer_noire/gamelan/soleil.html

When the web server is running on your computer, you can replace the server name with localhost. For example, the following URLs open the same page in a browser:

http://mer_noire/gamelan/soleil.html
http://localhost/gamelan/soleil.html
Note: Another expression you can use instead of the server name or localhost is 127.0.0.1 (for example, http://127.0.0.1/gamelan/soleil.html).

More Help topics
“Setting up a ColdFusion development environment” on page 514
“Setting up a PHP development environment” on page 514
“Setting up an ASP development environment” on page 514

Choosing a web server
To develop and test web applications, you can choose from a number of common web servers including Microsoft Internet Information Server (IIS) and Apache HTTP Server.

If you’re not using a web hosting service, choose a web server and install it on your local computer for development purposes. Windows and Macintosh users who want to develop ColdFusion web applications can use the web server included in the developer edition of the ColdFusion 8 application server, which you can install and use for free.

Other Windows users can run a web server on their local computer by installing IIS. This web server may already be installed on your system. Check your folder structure to see if it contains a C:\Inetpub or D:\Inetpub folder. IIS creates this folder during installation.

Mac OS users can use the local Apache web server installed with the operating system.

For information on installing and configuring other web servers, see the server vendor’s documentation or your system administrator.

Choosing an application server
An application server is software that helps a web server process dynamic pages. When choosing an application server, you should consider several factors, including your budget, the server technology you want to use (ColdFusion, ASP, or PHP), and the type of web server.

Budget Some vendors sell high-end application servers that are expensive to buy and administer. Others vendors provide easier, more cost-effective solutions (an example is ColdFusion). Some application servers are built into web servers (such as Microsoft IIS) and others can be downloaded for free from the Internet (such as PHP).

Server technology Application servers use different technologies. Dreamweaver supports three server technologies: ColdFusion, ASP, and PHP. The following table shows common application servers available for the server technologies supported by Dreamweaver:

<table>
<thead>
<tr>
<th>Server technology</th>
<th>Application server</th>
</tr>
</thead>
<tbody>
<tr>
<td>ColdFusion</td>
<td>Adobe ColdFusion 8</td>
</tr>
<tr>
<td>ASP</td>
<td>Microsoft IIS</td>
</tr>
<tr>
<td>PHP</td>
<td>PHP server</td>
</tr>
</tbody>
</table>

To learn more about ColdFusion, select ColdFusion Help from the Help menu.


To learn more about PHP, visit the PHP website at www.php.net/.
Choosing a database

Databases come in many forms depending upon the amount and the complexity of the data they must store. When choosing a database, you should consider several factors, including your budget and the number of users you anticipate will access the database.

**Budget** Some vendors produce high-end application database servers that are expensive to buy and administer. Others vendors provide easier, more cost-effective solutions, such as Microsoft Access or the open-source database MySQL.

**Users** If you anticipate a large user community accessing the site, select a database designed to support your site’s intended user base. For websites requiring greater flexibility in their data modeling, and the ability to support large, concurrent user communities, consider server-based relational databases (typically referred to as RDBMS) like Microsoft SQL Server and Oracle.

Setting up a ColdFusion development environment

For detailed instructions on setting up a ColdFusion development environment for Dreamweaver on your Windows or Mac computer, see the Adobe website at [www.adobe.com/devnet/dreamweaver/articles/setup_cf.html](http://www.adobe.com/devnet/dreamweaver/articles/setup_cf.html).


*Note:* The Developer Edition is for non-commercial use for developing and testing web applications. It is not licensed for deployment. It supports requests from the local host and two remote IP addresses. You can use it to develop and test your web applications as long as you want; the software does not expire. For more information, see ColdFusion help (Help > ColdFusion Help).

During installation, you can configure ColdFusion to use the web server built into ColdFusion or another web server installed on your system. Generally, it’s best to match your development environment to your production environment. Therefore, if you have an existing web server such as Microsoft IIS on your development computer, you may want to use it instead of the built-in ColdFusion web server.

Setting up a PHP development environment

For detailed instructions on setting up a PHP development environment for Dreamweaver on your Windows or Mac computer, see the Adobe website at [www.adobe.com/devnet/dreamweaver/articles/setup_php.html](http://www.adobe.com/devnet/dreamweaver/articles/setup_php.html).

Editions of the PHP application server exist for Windows, Linux, UNIX, HP-UX, Solaris, and Mac OS X systems. For more information on the application server, see the PHP documentation, which you can also download from the PHP website at [www.php.net/download-docs.php](http://www.php.net/download-docs.php).

Setting up an ASP development environment

For detailed instructions on setting up an ASP development environment for Dreamweaver on your Windows or Mac computer, see the Adobe website at [www.adobe.com/devnet/dreamweaver/articles/setup_asp.html](http://www.adobe.com/devnet/dreamweaver/articles/setup_asp.html).

To run ASP pages, you need an application server that supports Microsoft Active Server Pages 2.0., such as Microsoft IIS (Internet Information Services), which comes with Windows 2000 and Windows XP Professional. Windows XP Professional users can install and run IIS on their local computer. Macintosh users can use a web hosting service with an ASP plan or install IIS on a remote computer.
Creating a root folder for the application

After signing up with a web hosting company or setting up the server software yourself, create a root folder for your web application on the computer running the web server. The root folder can be local or remote, depending on where your web server is running.

The web server can serve any file in this folder or in any of its subfolders in response to an HTTP request from a web browser. For example, on a computer running ColdFusion 8, any file in the \ColdFusion8\wwwroot folder or any of its subfolders can be served to a web browser.

The following are the default root folders of selected web servers:

<table>
<thead>
<tr>
<th>Web server</th>
<th>Default root folder</th>
</tr>
</thead>
<tbody>
<tr>
<td>ColdFusion 8</td>
<td>\ColdFusion8\wwwroot</td>
</tr>
<tr>
<td>IIS</td>
<td>\inetpub\wwwroot</td>
</tr>
<tr>
<td>Apache (Windows)</td>
<td>\apache\htdocs</td>
</tr>
<tr>
<td>Apache (Macintosh)</td>
<td>Users:MyUserName:Sites</td>
</tr>
</tbody>
</table>

To test the web server, place a test HTML page in the default root folder and attempt to open it by entering the page’s URL in a browser. The URL comprises the domain name and the filename of the HTML page, as follows: www.example.com/testpage.htm.

If the web server is running on your local computer, you can use localhost instead of a domain name. Enter one of the following localhost URLs to match your web server:

<table>
<thead>
<tr>
<th>Web server</th>
<th>Localhost URL</th>
</tr>
</thead>
<tbody>
<tr>
<td>ColdFusion 8</td>
<td><a href="http://localhost:8500/testpage.htm">http://localhost:8500/testpage.htm</a></td>
</tr>
<tr>
<td>IIS</td>
<td><a href="http://localhost/testpage.htm">http://localhost/testpage.htm</a></td>
</tr>
<tr>
<td>Apache (Windows)</td>
<td><a href="http://localhost:80/testpage.htm">http://localhost:80/testpage.htm</a></td>
</tr>
<tr>
<td>Apache (Macintosh)</td>
<td><a href="http://localhost/~MyUserName/testpage.htm">http://localhost/~MyUserName/testpage.htm</a> (where MyUserName is your Macintosh user name)</td>
</tr>
</tbody>
</table>

**Note:** By default the ColdFusion web server runs on port 8500 and the Apache web server for Windows runs on port 80.

If the page doesn’t open as expected, check for the following errors:

- The web server is not started. Consult the web server’s documentation for starting instructions.
- The file does not have an .htm or .html extension.
- You entered the page’s file path (for example, c:\ColdFusion8\wwwroot\testpage.htm), not its URL (for example, http://localhost:8500/testpage.htm), in the browser’s address text box.
- The URL contains a typing mistake. Check for errors and make sure the filename is not followed by a slash, such as http://localhost:8080/testpage.htm/.

After creating a root folder for your application, define a Dreamweaver site to manage your files.

**More Help topics**

“Web server basics” on page 512

“Working with Dreamweaver sites” on page 36
About defining a Dreamweaver site
After configuring your system to develop web applications, define a Dreamweaver site to manage your files.

Before you start, make sure you meet the following requirements:

- You have access to a web server. The web server can be running on your local computer, on a remote computer such as a development server, or on a server maintained by a web hosting company.
- An application server is installed and running on the system running your web server.
- You created a root folder for your web application on the system running your web server.

Defining a Dreamweaver site for your web application consists of three steps:

1. Define a local folder
The local folder is the folder you use to store working copies of site files on your hard disk. You can define a local folder for each new web application you create. Defining a local folder also gives you the ability to manage your files and to transfer files to and from your web server easily.

2. Define a remote folder
Define a folder located on the computer running your web server as a Dreamweaver remote folder. The remote folder is the folder you created for your web application on the web server.

3. Define a testing folder
Dreamweaver uses this folder to generate and display dynamic content and connect to databases while you work. The testing server can be your local computer, a development server, a staging server, or a production server. As long as it can process the kind of dynamic pages you plan to develop, the choice doesn’t matter.

After the Dreamweaver site is defined, you can start building your web application.

More Help topics
“Working with Dreamweaver sites” on page 36

Database connections for ColdFusion developers

Connecting to a ColdFusion database
When developing a ColdFusion web application in Dreamweaver, you connect to a database by selecting a ColdFusion data source defined in Dreamweaver or in ColdFusion Administrator, the server’s management console.

Before connecting to a database, you must set up a ColdFusion web application. You must also set up a database on your local computer or on a system to which you have network or FTP access.

Make sure that Dreamweaver knows where to find the ColdFusion data sources. To retrieve the ColdFusion data sources at design time, Dreamweaver places scripts in a folder on the computer running ColdFusion. You must specify this folder in the Testing Server category of the Site Definition dialog box.

Next, you must create a ColdFusion data source in Dreamweaver or in ColdFusion Administrator (if one doesn’t already exist). After creating a ColdFusion data source, you can use it in Dreamweaver to connect to the database.
Create or modify a ColdFusion data source

Before you can use database information in your page, you must create a ColdFusion data source. If you’re running ColdFusion MX 7 or later, you can create or modify the data source directly in Dreamweaver. If you’re running ColdFusion MX, you must use the server’s management console, ColdFusion MX Administrator, to create or modify the data source. You can still use Dreamweaver to open ColdFusion MX Administrator in that case.

More Help topics
“Set up a testing server” on page 45
“Enable the ColdFusion enhancements” on page 647

Create or modify a ColdFusion data source if running ColdFusion MX 7 or later

1. Make sure a computer running ColdFusion MX 7 or later is defined as a testing server for your site.
2. Open any ColdFusion page in Dreamweaver.
3. To create a new data source, click the Plus (+) button in the Databases panel (Windows > Databases) and enter the parameter values specific to the database driver.
   Note: Dreamweaver displays the Plus (+) button only if you’re running ColdFusion MX 7 or later.
4. To modify a data source, double-click the database connection in the Databases panel and make your changes.
   You can edit any parameter except the name of the data source. For more information, see the driver vendor’s documentation or consult your system administrator.

Create or modify a ColdFusion data source if running ColdFusion MX 6.1 or 6.0

1. Open any ColdFusion page in Dreamweaver.
2. In the Databases panel (Window > Databases) in Dreamweaver, click Modify Data Sources in the panel toolbar.
3. Log in to ColdFusion MX Administrator, and create or modify the data source.
   For instructions, see ColdFusion help (Help > ColdFusion Help).
   You must provide certain parameter values to create the ColdFusion data source. For the parameter values specific to your database driver, see the driver vendor’s documentation or consult your system administrator.
   After you create a ColdFusion data source, you can use it in Dreamweaver.

Connecting to the database in Dreamweaver

After creating a ColdFusion data source, use it to connect to the database in Dreamweaver.

Open any ColdFusion page in Dreamweaver, then open the Databases panel (Window > Databases). Your ColdFusion data sources should appear in the panel.

If the data sources do not appear, complete the checklist in the panel. Make sure that Dreamweaver knows where to find the ColdFusion data sources. In the Testing Server category of the Site Definition dialog box, specify the site’s root folder on the computer running ColdFusion.

More Help topics
“Troubleshooting database connections” on page 526
Database connections for ASP developers

About ASP database connections

An ASP application must connect to a database through an open database connectivity (ODBC) driver or an object linking and embedding database (OLE DB) provider. The driver or provider acts as an interpreter that lets the web application communicate with the database. The following table shows some drivers you can use with Microsoft Access, Microsoft SQL Server, and Oracle databases:

<table>
<thead>
<tr>
<th>Database</th>
<th>Database driver</th>
</tr>
</thead>
<tbody>
<tr>
<td>Microsoft Access</td>
<td>Microsoft Access Driver (ODBC)</td>
</tr>
<tr>
<td></td>
<td>Microsoft Jet Provider for Access (OLE DB)</td>
</tr>
<tr>
<td>Microsoft SQL Server</td>
<td>Microsoft SQL Server Driver (ODBC)</td>
</tr>
<tr>
<td></td>
<td>Microsoft SQL Server Provider (OLE DB)</td>
</tr>
<tr>
<td>Oracle</td>
<td>Microsoft Oracle Driver (ODBC)</td>
</tr>
<tr>
<td></td>
<td>Oracle Provider for OLE DB</td>
</tr>
</tbody>
</table>

You can use a data source name (DSN) or a connection string to connect to the database. You must use a connection string if you’re connecting through an OLE DB provider or an ODBC driver not installed on a Windows system.

A DSN is a one-word identifier, such as myConnection, that points to the database and contains all the information needed to connect to it. You define a DSN in Windows. You can use a DSN if you’re connecting through an ODBC driver installed on a Windows system.

A connection string is a hand-coded expression that identifies the database and lists the information needed to connect to it, as shown in the following example:

```
Driver={SQL Server};Server=Socrates;Database=AcmeMktg;
UID=wiley;PWD=roadrunner
```

**Note:** You can also use a connection string if you’re connecting through an ODBC driver installed on a Windows system, but using a DSN is easier.

More Help topics

“Accessing a database” on page 507

About OLE DB connections

You can use an OLE DB provider to communicate with your database (OLE DB is available only on Windows NT, 2000, or XP). Creating a direct database-specific OLE DB connection can improve the speed of your connection by eliminating the ODBC layer between your web application and the database.

If you don’t specify an OLE DB provider for your database, ASP uses the default OLE DB provider for ODBC drivers to communicate with an ODBC driver, which in turn communicates with the database.

Different OLE DB providers exist for different databases. You can obtain OLE DB providers for Microsoft Access and SQL Server by downloading and installing the Microsoft Data Access Components (MDAC) 2.5 and 2.7 packages on the Windows computer running IIS. You can download the MDAC packages for free from the Microsoft website at [http://msdn.microsoft.com/data/mdac/downloads/](http://msdn.microsoft.com/data/mdac/downloads/).

**Note:** Make sure you install MDAC 2.5 before installing MDAC 2.7.
You can download OLE DB providers for Oracle databases from the Oracle website at www.oracle.com/technology/software/tech/windows/ole_db/index.html (registration is required).

In Dreamweaver, you create an OLE DB connection by including a Provider parameter in a connection string. For example, here are parameters for common OLE DB providers for Access, SQL Server, and Oracle databases, respectively:

Provider=Microsoft.Jet.OLEDB.4.0;...
Provider=SQLOLEDB;...
Provider=OraOLEDB;...

For the parameter value of your OLE DB provider, see your provider vendor's documentation, or consult your system administrator.

About connection strings

A connection string combines all the information your web application needs to connect to a database. Dreamweaver inserts this string in your page's server-side scripts for later processing by your application server.

A connection string for Microsoft Access and SQL Server databases consists of a combination of the following parameters separated by semicolons:

Provider Specifies the OLE DB provider for your database. For example, here are parameters for common OLE DB providers for Access, SQL Server, and Oracle databases, respectively:

Provider=Microsoft.Jet.OLEDB.4.0;...
Provider=SQLOLEDB;...
Provider=OraOLEDB;...

For the parameter value of your OLE DB provider, see your provider vendor's documentation, or consult your system administrator.

If you don’t include a Provider parameter, then the default OLE DB provider for ODBC is used and you must specify an appropriate ODBC driver for your database.

Driver Specifies the ODBC driver to use if you don’t specify an OLE DB provider for your database.

Server Specifies the server hosting the SQL Server database if your web application runs on a different server.

Database The name of a SQL Server database.

DBQ The path to a file-based database such as one created in Microsoft Access. The path is the one on the server hosting the database file.

UID Specifies the user name.

PWD Specifies the user password.

DSN The data source name, if you use one. Depending on how you define the DSN on your server, you can omit the connection string's other parameters. For example, DSN=Results can be a valid connection string if you define the other parameters when you create the DSN.

Connection strings for other kinds of databases may not use the parameters listed above, or will have different names or uses for the parameters. For more information, see your database vendor's documentation, or consult your system administrator.

Here's an example of a connection string that will create an ODBC connection to an Access database called trees.mdb:

Driver={Microsoft Access Driver (*.mdb)};
DBQ=C:\Inetpub\wwwroot\Research\trees.mdb
Here’s an example of a connection string that will create an OLE DB connection to a SQL Server database called Mothra located on a server called Gojira:

Provider=SQLOLEDB;Server=Gojira;Database=Mothra;UID=jsmith;PWD=orlando8

**Create a connection using a local DSN**

*Note: This section assumes you have set up an ASP application. It also assumes a database is set up on your local computer or on a system to which you have network or FTP access.*

You can use a data source name (DSN) to create an ODBC connection between your web application and your database. A DSN is a name containing all the parameters needed to connect to a specific database using an ODBC driver.

Because you can only specify an ODBC driver in a DSN, you must use a connection string if you want to use an OLE DB provider.

You can use a locally defined DSN to create a database connection in Dreamweaver.

1. Define a DSN on the Windows computer running Dreamweaver.

   For instructions, see the following articles on the Microsoft website:

   - If the computer runs Windows 2000, see Microsoft Knowledge Base Article 300596 at [http://support.microsoft.com/default.aspx?scid=kb;en-us;300596](http://support.microsoft.com/default.aspx?scid=kb;en-us;300596)
   - If the computer runs Windows XP, see Microsoft Knowledge Base Article 305599 at [http://support.microsoft.com/default.aspx?scid=kb;en-us;305599](http://support.microsoft.com/default.aspx?scid=kb;en-us;305599)

2. Open an ASP page in Dreamweaver, and then open the Databases panel (Window > Databases).

3. Click the Plus (+) button on the panel and select Data Source Name (DSN) from the menu.

4. Enter a name for the new connection, without spaces or special characters.

5. Select the Using Local DSN option and choose the DSN you want to use from the Data Source Name (DSN) menu.

   If you want to use a local DSN but haven’t defined one yet, click Define to open the Windows ODBC Data Source Administrator.

6. Complete the User Name and Password boxes.

7. You can restrict the number of database items Dreamweaver retrieves at design time by clicking Advanced, and entering a schema or catalog name.

   *Note: You cannot create a schema or catalog in Microsoft Access.*

8. Click Test to connect to the database, and then click OK. If the connection fails, double-check the connection string or check the settings for the test folder Dreamweaver uses to process dynamic pages.

**More Help topics**

“Restrict database information displayed in Dreamweaver” on page 534

“Set up your computer for application development” on page 511

“Troubleshooting database connections” on page 526
Create a connection using a remote DSN

Note: This section assumes you have set up an ASP application. It also assumes a database is set up on your local computer or on a system to which you have network or FTP access.

Note: Dreamweaver can retrieve only server DSNs created with the Windows ODBC Data Source Administrator.

You can use a DSN defined on a remote computer to create a database connection in Dreamweaver. If you want to use a remote DSN, the DSN must be defined on the Windows computer running your application server (probably IIS).

Note: Because you can only specify an ODBC driver in a DSN, you must use a connection string if you want to use an OLE DB provider.

1 Define a DSN on the remote system running your application server.

For instructions, see the following articles on the Microsoft website:

• If the remote computer runs Windows 2000, see Microsoft Knowledge Base Article 300596 at http://support.microsoft.com/default.aspx?scid=kb;en-us;300596

• If the remote computer runs Windows XP, see Microsoft Knowledge Base Article 305599 at http://support.microsoft.com/default.aspx?scid=kb;en-us;305599

2 Open an ASP page in Dreamweaver, then open the Databases panel (Window > Databases).

3 Click the Plus (+) button on the panel and select Data Source Name (DSN) from the menu.

4 Enter a name for the new connection, without spaces or special characters.

5 Select Using DSN On Testing Server.

Note: Macintosh users can ignore this step because all database connections use DSNs on the application server.

6 Enter the DSN or click the DSN button to connect to the server and select the DSN for the database you want, then complete the options.

7 Complete the User Name and Password boxes.

8 You can restrict the number of database items Dreamweaver retrieves at design time by clicking Advanced and entering a schema or catalog name.

Note: You cannot create a schema or catalog in Microsoft Access.

9 Click Test to connect to the database, and then click OK. If the connection fails, double-check the connection string or check the settings for the testing folder Dreamweaver uses to process dynamic pages.

More Help topics

“Set up your computer for application development” on page 511

“Restrict database information displayed in Dreamweaver” on page 534

“Troubleshooting database connections” on page 526

Create a connection using a connection string

You can use a DSN-less connection to create an ODBC or OLE DB connection between your web application and your database. You use a connection string to create this kind of connection.

1 Open an ASP page in Dreamweaver, and then open the Databases panel (Window > Databases).

2 Click the Plus (+) button on the panel, select Custom Connection String from the menu, complete the options, and click OK.
3 Enter a name for the new connection without spaces or special characters.

4 Enter a connection string to the database. If you do not specify an OLE DB provider in the connection string—that is, if you don’t include a Provider parameter—ASP will automatically use the OLE DB provider for ODBC drivers. In that case, you must specify an appropriate ODBC driver for your database.

If your site is hosted by an ISP and you don’t know the full path to your database, use the MapPath method of the ASP server object in your connection string.

5 If the database driver specified in the connection string is not installed on the same computer as Dreamweaver, select Using Driver On Testing Server.

Note: Macintosh users can ignore this step because all database connections use the application server.

6 You can restrict the number of database items Dreamweaver retrieves at design time by clicking Advanced and entering a schema or catalog name.

Note: You cannot create a schema or catalog in Microsoft Access.

7 Click Test to connect to the database, and then click OK. If the connection fails, double-check the connection string or check the settings for the testing folder Dreamweaver uses to process dynamic pages.

More Help topics
“Connecting to a ColdFusion database” on page 516
“Restrict database information displayed in Dreamweaver” on page 534
“Troubleshooting database connections” on page 526

Connecting to a database on an ISP
If you’re an ASP developer working with a commercial Internet service provider (ISP), you often don’t know the physical path of the files you upload, including your database file or files.

If your ISP doesn’t define a DSN for you or is slow to do so, you must find another way to create the connections to your database files. One alternative is to create a DSN-less connection to a database file, but you can define such a connection only if you know the physical path of the database file on the ISP server.

You can obtain the physical path of a database file on a server by using the MapPath method of the ASP server object.

Note: The techniques discussed in this section apply only if your database is file-based, such as a Microsoft Access database where data is stored in an .mdb file.

Understanding physical and virtual paths
After using Dreamweaver to upload your files to a remote server, the files reside in a folder in the server’s local directory tree. For example, on a server running Microsoft IIS, the path to your home page could be as follows:

```
c:\Inetpub\wwwroot\accounts\users\jsmith\index.htm
```

This path is known as the physical path to your file.

The URL to open your file, however, does not use the physical path. It uses the name of the server or domain followed by a virtual path, as in the following example:

```
www.plutoserve.com/jsmith/index.htm
```

The virtual path, /jsmith/index.htm, stands in for the physical path, c:\Inetpub\wwwroot\accounts\users\jsmith\index.htm.
Find a file’s physical path with the virtual path

If you work with an ISP, you don’t always know the physical path to the files you upload. ISPs typically provide you with an FTP host, possibly a host directory, and a login name and password. ISPs also specify a URL to view your pages on the Internet, such as www.plutoserve.com/jsmith/.

If you know the URL, then you can get the file’s virtual path—it’s the path that follows the server or domain name in a URL. Once you know the virtual path, you can get the file’s physical path on the server using the MapPath method.

The MapPath method takes the virtual path as an argument and returns the file’s physical path and filename. Here’s the method’s syntax:

```csharp
Server.MapPath("/virtualpath")
```

If a file’s virtual path is /jsmith/index.htm, then the following expression returns its physical path:

```csharp
Server.MapPath("/jsmith/index.htm")
```

You can experiment with the MapPath method as follows.

1. Open an ASP page in Dreamweaver and switch to Code view (View > Code).
2. Enter the following expression in the page’s HTML code.

   ```csharp
   <%Response.Write(stringvariable)%>
   ```

3. Use the MapPath method to obtain a value for the stringvariable argument.

   Here’s an example:

   ```csharp
   <% Response.Write(Server.MapPath("/jsmith/index.htm")) %
   ```

4. Switch to Live view (View > Live View) to view the page.

The page displays the physical path of the file on the application server, for example:

c:\Inetpub\wwwroot\accounts\users\jsmith\index.htm

For more information on the MapPath method, consult the online documentation that comes with Microsoft IIS.

Use a virtual path to connect to a database

To write a DSN-less connection string to a database file located on a remote server, you must know the physical path to the file. The following example is a typical DSN-less connection string for a Microsoft Access database:

```sql
Driver={Microsoft Access Driver (*.mdb)};
DBQ=c:\Inetpub\wwwroot\accounts\users\jsmith\data\statistics.mdb
```

If you don’t know the physical path of your files on the remote server, you can get the path by using the MapPath method in your connection string.

1. Upload the database file to the remote server and make a note of its virtual path—for example, /jsmith/data/statistics.mdb.
2. Open an ASP page in Dreamweaver, then open the Databases panel (Window > Databases).
3. Click the Plus (+) button on the panel and select Custom Connection String from the menu.
4. Enter a name for the new connection, without spaces or special characters.
5. Enter the connection string and use the MapPath method to supply the DBQ parameter.

Suppose that the virtual path to your Microsoft Access database is /jsmith/data/statistics.mdb; the connection string can be expressed as follows if you use VBScript as your scripting language:
"Driver={Microsoft Access Driver (*.mdb)};DBQ=" & Server.MapPath("/*\jsmith/data/statistics.mdb")

The ampersand (&) is used to concatenate (combine) two strings. The first string is enclosed in quotation marks and the second is returned by the Server.MapPath expression. When the two strings are combined, the following string is created:

Driver={Microsoft Access Driver (*.mdb)};
DBQ=C:\Inetpub\wwwroot\accounts\users\jsmith\data\statistics.mdb

If you use JavaScript, the expression is identical except that you use a Plus (+) sign instead of an ampersand (&) to concatenate the two strings:

"Driver={Microsoft Access Driver (*.mdb)};DBQ=" + Server.MapPath("/*\jsmith/data/statistics.mdb")

6 Select Using Driver On Testing Server, click Test, and then click OK.

Note: Macintosh users can ignore this step because all database connections use the application server.

Note: If the connection fails, double-check the connection string or contact your ISP to make sure that the database driver you specified in the connection string is installed on the remote server. Also check that the ISP has the most recent version of the driver. For example, a database created in Microsoft Access 2000 will not work with Microsoft Access Driver 3.5. You need Microsoft Access Driver 4.0 or later.

7 Update the database connection of existing dynamic pages (open the page in Dreamweaver, double-click the recordset name in the Bindings panel or Server Behaviors panel, and select the connection you just created from the Connection menu) and use the new connection with any new page you build.

**Edit or delete a database connection**

When you create a database connection, Dreamweaver stores the connection information in an include file in the Connections subfolder in the site’s local root folder. You can edit or delete the connection information in the file manually or as follows.

**Edit a connection**

1 Open an ASP page in Dreamweaver and then open the Databases panel (Window > Databases).
2 Right-click (Windows) or Control-click (Macintosh) the connection and select Edit Connection from the menu.
3 Edit the connection information and click OK.

Dreamweaver updates the include file, which updates all the pages in the site that use the connection.

**Delete a connection**

1 Open an ASP page in Dreamweaver and then open the Databases panel (Window > Databases).
2 Right-click (Windows) or Control-click (Macintosh) the connection and select Delete Connection from the menu.
3 In the dialog box that appears, confirm that you want to delete the connection.

Note: To avoid receiving errors after deleting a connection, update every recordset that uses the old connection by double-clicking the name of the recordset in the Bindings panel and choosing a new connection.
Database connections for PHP developers

About PHP database connections
For PHP development, Dreamweaver only supports the MySQL database system. Other database systems such as Microsoft Access or Oracle are not supported. MySQL is open-source software you can download for free from the Internet for non-commercial use. For more information, see the MySQL website at http://dev.mysql.com/downloads/.

This section assumes you have set up a PHP application. It also assumes a MySQL database is set up on your local computer or on a system to which you have network or FTP access.

For development purposes, download and install the Windows Essentials version of the MySQL database server.

More Help topics
“Setting up a PHP development environment” on page 514

Connect to a database
To connect to a database when developing a PHP application in Dreamweaver, you must have one or more MySQL databases and the MySQL server must be started.

1. Open a PHP page in Dreamweaver, and then open the Databases panel (Window > Databases).
2. Click the Plus (+) button on the panel, select MySQL Connection from the menu, and complete the dialog box.
   • Enter a name for the new connection, without spaces or special characters.
   • In the MySQL Server box, enter an IP address or a server name for the computer hosting MySQL. If MySQL is running on the same computer as PHP, you can enter localhost.
   • Enter your MySQL user name and password.
   • In the Database box, enter the name of the database, or click Select and select the database from the list of MySQL databases, and click Test.

Dreamweaver attempts to connect to the database. If the connection fails, double-check the server name, user name, and password. If the connection still fails, check the settings for the testing folder Dreamweaver uses to process dynamic pages.

Dreamweaver makes a best guess at auto-populating the value for the URL prefix in the Testing Server category of the Site Definition dialog box, but sometimes you will have to adjust the URL prefix to get your connection to work. Make sure that the URL prefix is the URL that users type in their browsers to open the web application, minus the file name (or start page) of the application.

3. Click OK.

Note: If you encounter the error message “Client does not support authentication protocol requested. Consider upgrading MySQL client” when testing a PHP database connection to MySQL 4.1, see “Troubleshooting MySQL error messages” on page 531.

Edit or delete a database connection
When you create a database connection, Dreamweaver stores the connection information in an include file in the Connections subfolder in the site’s local root folder. You can edit or delete the connection information in the file manually or as follows.
Edit a connection
1. Open a PHP page in Dreamweaver, and then open the Databases panel (Window > Databases).
2. Right-click (Windows) or Control-click (Macintosh) the connection and select Edit Connection from the menu.
3. Edit the connection information and click OK.

Dreamweaver updates the include file, which updates all the pages in the site that use the connection.

Delete a connection
1. Open a PHP page in Dreamweaver, and then open the Databases panel (Window > Databases).
2. Right-click (Windows) or Control-click (Macintosh) the connection and select Delete Connection from the menu.
3. In the dialog box that appears, confirm that you want to delete the connection.

Note: To avoid getting errors after deleting a connection, update every recordset that uses the old connection by double-clicking the name of the recordset in the Bindings panel and selecting a new connection in the Recordset dialog box.

Troubleshooting database connections

Troubleshooting permissions problems
One of the most common problems is insufficient folder or file permissions. If your database is located on a Windows 2000 or Windows XP computer and you receive an error message when you try to view a dynamic page in a web browser or in Live view, the error might be due to a permissions problem.

The Windows account attempting to access the database doesn’t have sufficient permissions. The account might be either the anonymous Windows account (by default, IUSR_computername) or a specific user account, if the page has been secured for authenticated access.

You must change the permissions to give the IUSR_computername account the correct permissions so the web server can access the database file. In addition, the folder containing the database file must also have certain permissions set to write to that database.

If the page is meant to be accessed anonymously, give the IUSR_computername account full control to the folder and database file, as described in the procedure below.

Additionally, if the path to the database is being referenced using UNC (\Server\Share), make sure the Share Permissions give the IUSR_computername account full access. This step applies even if the share is on the local web server.

If you copy the database from another location, it may not inherit the permissions from its destination folder and you may have to change the permissions for the database.

Check or change the database file permissions (Windows XP)
1. Make sure that you have administrator privileges on the computer.
2. In Windows Explorer
3. , locate the database file or the folder containing the database, right-click the file or folder, and select Properties.
4. Select the Security tab.
Note: This step applies only if you have an NTFS file system. If you have an FAT file system, the dialog box won't have a Security tab.

6 If the IUSR_computername account is not listed in the Group or User Names list, click the Add button to add it.
7 In the Select Users or Groups dialog box, click Advanced. The dialog box changes to show more options.
8 Click Locations and select the computer's name.
9 Click Find Now to display a list of account names associated with the computer.
10 Select the IUSR_computername account and click OK; then click OK again to clear the dialog box.
11 To assign the IUSR account full permissions, select Full Control and click OK.

Check or change the database file permissions (Windows 2000)
1 Make sure that you have administrator privileges on the computer.
2 In Windows Explorer, locate the database file or the folder containing the database, right-click the file or folder, and select Properties.
3 Select the Security tab.
Note: This step applies only if you have an NTFS file system. If you have an FAT file system, the dialog box won't have a Security tab.

6 If the IUSR_computername account is not listed among the Windows accounts in the File Permissions dialog box, click the Add button to add it.
7 In the Select Users, Computers, or Groups dialog box, select the computer name from the Look In menu to display a list of account names associated with the computer.
8 Select the IUSR_computername account and click Add.
9 To assign the IUSR account full permissions, select Full Control from the Type Of Access menu and click OK.

For added security, permissions can be set so that Read permission is disabled for the web folder containing the database. Browsing the folder won't be permitted, but web pages will still be able to access the database.

For more information about the IUSR account and web server permissions, see the following TechNotes on the Adobe Support Center:
• Understanding anonymous authentication and the IUSR account at www.adobe.com/go/authentication
• Setting IIS web server permissions at www.adobe.com/go/server_permissions

Troubleshooting Microsoft error messages
These Microsoft error messages can occur when you request a dynamic page from the server if you use Internet Information Server (IIS) with a Microsoft database system such as Access or SQL Server.

Note: Adobe does not provide technical support for third-party software such as Microsoft Windows, and IIS. If this information does not fix your problem, please contact Microsoft technical support or visit the Microsoft support website at http://support.microsoft.com/.

[Reference] 80004005—Data source name not found and no default driver specified

This error occurs when you attempt to view a dynamic page in a web browser or in Live view. The error message may vary depending on your database and web server. Other variations of the error message include:

- 80004005—Driver’s SQLSetConnectAttr failed
- 80004005—General error unable to open registry key ‘DriverId’

Here are possible causes and solutions:

- The page can’t find the DSN. Make sure a DSN has been created on both the web server and on the local machine.
- The DSN might have been set up as a user DSN, not as a system DSN. Delete the user DSN and create a system DSN to replace it.

**Note:** If you don’t delete the user DSN, the duplicate DSN names produce a new ODBC error.

If you use Microsoft Access, the database file (.mdb) might be locked. The lock might be due to a DSN with a different name accessing the database. In Windows Explorer, search for the lock file (.ldb) in the folder containing the database file (.mdb) and delete the .ldb file. If another DSN is pointing to the same database file, delete the DSN to prevent the error in the future. Reboot the computer after making any changes.

[Reference] 80004005—Couldn’t use ‘(unknown)’; file already in use

This error occurs when you use a Microsoft Access database and attempt to view a dynamic page in a web browser or in Live view. Another variation of this error message is “80004005—Microsoft Jet database engine cannot open the file (unknown).”

The probable cause is a permissions problem. Here are some specific causes and solutions:

- The account being used by Internet Information Server (usually IUSR) might not have the correct Windows permissions for a file-based database or for the folder containing the file. Check the permissions on the IIS account (IUSR) in the user manager.
- You might not have permission to create or destroy temporary files. Check the permissions on the file and the folder. Make sure that you have permission to create or destroy any temporary files. Temporary files are usually created in the same folder as the database, but the file may also be created in other folders such as /Winnt.
- In Windows 2000, the time-out value may need to be changed for the Access database DSN. To change the time-out value, select Start > Settings > Control Panel > Administrative Tools > Data Sources (ODBC). Click the System tab, highlight the correct DSN, and click the Configure button. Click the Options button and change the Page Timeout value to 5000.

If you still have problems, see the following Microsoft Knowledge Base articles:

[Reference] 80004005—Logon Failed()
This error occurs when you use Microsoft SQL Server and attempt to view a dynamic page in a web browser or in Live view.

This error is generated by SQL Server if it doesn’t accept or recognize the logon account or password being submitted (if you’re using standard security), or if a Windows account does not map to a SQL account (if you’re using integrated security).

Here are possible solutions:

- If you use standard security, the account name and password might be incorrect. Try the system Admin account and password (UID= "sa" and no password), which must be defined in the connection string line. (DSNs do not store user names and passwords.)
- If you use integrated security, check the Windows account calling the page and find its mapped SQL account (if any).
- SQL Server does not allow an underscore in SQL account names. If someone manually maps the Windows IUSR_machinename account to a SQL account of the same name, it will fail. Map any account that uses an underscore to an account name on SQL that does not use an underscore.

[Reference] 80004005—Operation must use an updateable query
This error occurs when an event is updating a recordset or inserting data in a recordset.

Here are possible causes and solutions:

- The permissions set on the folder containing the database are too restrictive. IUSR privileges must be set to read/write.
- The permissions on the database file itself does not have full read/write privileges in effect.
- The database might be located outside the Inetpub/wwwroot directory. Though you can view and search the data, you might not be able to update it unless the database is located in the wwwroot directory.
- The recordset is based on a non-updateable query. Joins are good examples of non-updateable queries within a database. Restructure your queries so they are updateable.

For more information on this error, see “PRB: ASP 'Error The Query Is Not Updateable' When You Update Table Record,” in the Microsoft Knowledge Base at http://support.microsoft.com/default.aspx?scid=kb%3ben-us%3bQ174640.

[Reference] 80040e07—Data type mismatch in criteria expression
This error occurs when the server tries to process a page containing an Insert Record or Update Record server behavior, and the server behavior attempts to set the value of a Date/Time column in a Microsoft Access database to an empty string (""").

Microsoft Access has strong data typing; it imposes a rigorous set of rules on given column values. The empty string value in the SQL query cannot be stored in an Access Date/Time column. Currently, the only known workaround is to avoid inserting or updating Date/Time columns in Access with empty strings (""") or with any other value that does not correspond to the range of values specified for the data type.

[Reference] 80040e10—Too few parameters
This error occurs when a column specified in your SQL query does not exist in the database table. Check the column names in your database table against the SQL query. The cause of this error is often a typographical error.
[Reference]80040e10—COUNT field incorrect
This error occurs when you preview a page containing an Insert Record server behavior in a web browser and try to use it to insert a record in a Microsoft Access database.

You might be trying to insert a record into a database field that has a question mark (?) in its field name. The question mark is a special character for some database engines, including Microsoft Access, and should not be used for database table names or field names.

Open your database system and delete the question mark (?) from the field names, and update the server behaviors on your page that refer to this field.

[Reference]80040e14—Syntax error in INSERT INTO statement
This error occurs when the server tries to process a page containing an Insert Record server behavior.

This error typically results from one or more of the following problems with the name of a field, object, or variable in the database:

• Using a reserved word as a name. Most databases have a set of reserved words. For example, “date” is a reserved word and cannot be used for column names in a database.

• Using special characters in the name. Examples of special characters include:
  . / * : ! # & - ?

• Using a space in the name.

  The error can also occur when an input mask is defined for an object in the database, and the inserted data does not conform to the mask.

  To fix the problem, avoid using reserved words such as “date”, “name”, “select”, “where,” and “level” when specifying column names in your database. Also, eliminate spaces and special characters.

  See the following web pages for lists of reserved words for common database systems:
  • Microsoft Access at [http://support.microsoft.com/default.aspx?scid=kb;en-us;Q209187](http://support.microsoft.com/default.aspx?scid=kb;en-us;Q209187)

[Reference]80040e21—ODBC error on Insert or Update
This error occurs when the server tries to process a page containing an Update Record or Insert Record server behavior. The database cannot handle the update or insert operation the server behavior is trying to perform.

Here are possible causes and solutions:

• The server behavior is trying to update a database table’s auto-number field or to insert a record into an auto-number field. Because auto-number fields are populated automatically by the database system, any attempt to externally populate them with a value fails.

• The data the server behavior is updating or inserting is the wrong type for the database field, such as inserting a date into a Boolean (yes/no) field, inserting a string into a numeric field, or inserting an improperly formatted string into Date/Time field.

[Reference]800a0bcd—Either BOF or EOF is true
This error occurs when you attempt to view a dynamic page in a web browser or in Live view.
The problem occurs when the page tries to display data from an empty recordset. To solve the problem, apply the Show Region server behavior to the dynamic content to be displayed on the page, as follows:

1. Highlight the dynamic content on the page.
2. In the Server Behaviors panel, click the Plus (+) button and select Show Region > Show Region If Recordset Is Not Empty.
3. Select the recordset supplying the dynamic content and click OK.
4. Repeat steps 1 to 3 for each element of dynamic content on the page.

**Troubleshooting MySQL error messages**

One common error message that you might encounter when testing a PHP database connection to MySQL 4.1 is “Client does not support authentication protocol requested. Consider upgrading MySQL client.”

You may have to revert to an earlier version of MySQL, or install PHP 5 and copy some dynamic link libraries (DLLs). For detailed instructions, see “Setting up a PHP development environment” on page 514.

**Removing connection scripts**

**Using the Remove Connection Scripts command**

You can use the Remove Connection Scripts command to remove scripts that Dreamweaver places in a remote folder to access databases. These scripts are only needed for design-time authoring in Dreamweaver.

When you select the Using Driver On Testing Server option or the Using DSN On Testing Server option in the Database Connections dialog box, Dreamweaver uploads an MMHTTPDB script file to the testing server. This allows Dreamweaver to manipulate the remote database driver with the HTTP protocol, which in turn allows Dreamweaver to get the database information it needs to help you create your site. However, this file does make it possible to see the data source names (DSNs) defined on the system. If the DSNs and databases are not password protected, the script also enables an attacker to issue SQL commands to the database.

The MMHTTPDB script files are located in the _mmServerScripts folder, which is located in the root of your website.

**Note:** The Dreamweaver file browser (the Files panel) hides the _mmServerScripts folder. You can see the _mmServerScripts folder if you use a third-party FTP client or the file browser.

In some configurations these scripts are not necessary at all. The scripts are not involved when serving web pages to visitors to your website, so they should not be placed on a production server.

If you’ve uploaded the MMHTTPDB scripts file to a production server, you should delete the MMHTTPDB scripts file. The Remove Connection Scripts command automatically removes the script files for you.
Chapter 20: Making pages dynamic

You can create dynamic pages that display information from dynamic content sources such as databases and session variables. Adobe® Dreamweaver® CS5 supports dynamic page development for ColdFusion, ASP, and PHP server models.

You can also use an Ajax-based framework called Spry to create dynamic pages that display and process XML data. Using prebuilt Spry form elements lets you build dynamic pages that don’t require a full-page refresh.

Optimizing the workspace for visual development

Displaying web-application development panels

Select the Data category from the Category pop-up menu of the Insert panel to display a set of buttons that let you add dynamic content and server behaviors to your page.

The number and type of buttons that appear vary depending upon the document type opened in the Document window. Move your mouse over an icon to display a tooltip that describes what that button does.

The Insert panel includes buttons to add the following items to the page:

- Recordsets
- Dynamic text or tables
- Record navigation bars

If you switch to Code view (View > Code), additional panels might appear in their own Insert panel category, allowing you to insert code in the page. For example, if you view a ColdFusion page in Code view, a CFML panel becomes available in the CFML category of the Insert panel.

Several panels provide ways for you to create dynamic pages:

- Select the Bindings panel (Window > Bindings) to define sources of dynamic content for your page and add the content to the page.
- Select the Server Behaviors panel (Window > Server Behaviors) to add server-side logic to your dynamic pages.
- Select the Databases panel (Window > Databases) to explore databases or create database connections.
- Select the Components panel (Window > Components) to inspect, add, or modify code for ColdFusion components.

*Note:* The Components panel is enabled only if you open a ColdFusion page.

A server behavior is the set of instructions inserted in a dynamic page at design time and executed on the server at run time.

For a tutorial on setting up the development workspace, see [www.adobe.com/go/vid0144](http://www.adobe.com/go/vid0144).

More Help topics

“Bindings panel” on page 541

“Server Behaviors panel” on page 542
View your database within Dreamweaver

After connecting to your database, you can view its structure and data within Dreamweaver.

1. Open the Databases panel (Window > Databases).

The Databases panel displays all the databases for which you created connections. If you’re developing a ColdFusion site, the panel displays all the databases that have data sources defined in the ColdFusion Administrator.

Note: Dreamweaver looks at the ColdFusion server you defined for the current site.

If no database appears in the panel, you must create a database connection.

2. To display the tables, stored procedures, and views in the database, click the Plus (+) sign beside a connection in the list.

3. To display the columns in the table, click a table name.

The column icons reflect the data type and indicate the primary key of the table.

4. To view the data in a table, right-click (Windows) or Control-click (Macintosh) the table name in the list, and select View Data from the pop-up menu.

More Help topics

“Setting up a ColdFusion development environment” on page 514
“Setting up a PHP development environment” on page 514
“Setting up an ASP development environment” on page 514

Previewing dynamic pages in a browser

Web application developers often debug their pages by checking them often in a web browser. You can quickly view dynamic pages in a browser without first manually uploading them to a server (press F12).

To preview dynamic pages, you must complete the Testing Server category of the Site Definition dialog box.

You can specify that Dreamweaver use temporary files instead of the original files. With this option, Dreamweaver runs a temporary copy of the page on a web server before displaying it in your browser. (Dreamweaver then deletes the temporary file from the server.) To set this option, select Edit > Preferences > Preview In Browser.

The Preview In Browser option does not upload related pages such as a results or a detail page, dependent files such as image files, or server-side includes. To upload a missing file, select Window > Site to open the Site panel, select the file under Local Folder, and click the blue up arrow in the toolbar to copy the file to the web server folder.

More Help topics

“Set up a testing server” on page 45
Restrict database information displayed in Dreamweaver

Advanced users of large database systems like Oracle should restrict the number of database items retrieved and displayed by Dreamweaver at design time. An Oracle database may contain items that Dreamweaver cannot process at design time. You can create a schema in Oracle and use it in Dreamweaver to filter out unnecessary items at design time.

Note: You cannot create a schema or catalog in Microsoft Access.

Other users may benefit from restricting the amount of information Dreamweaver retrieves at design time. Some databases contain dozens or even hundreds of tables, and you might prefer not to list them all while you work. A schema or catalog can restrict the number of database items that are retrieved at design time.

You must create a schema or catalog in your database system before you can apply it in Dreamweaver. Consult your database system documentation or your system administrator.

Note: You cannot apply a schema or catalog in Dreamweaver if you’re developing a ColdFusion application, or using Microsoft Access.

1. Open a dynamic page in Dreamweaver; then open the Databases panel (Window > Databases).
2. If the database connection exists, right-click (Windows) or Control-click (Macintosh) the connection in the list, and select Edit Connection from the pop-up menu.
3. If the connection does not exist, click the Plus (+) button at the top of the panel and create it.
4. In the dialog box for the connection, click Advanced.
5. Specify your schema or catalog, and click OK.

Set the Property inspector for ColdFusion stored procedures and ASP commands

Modify the selected stored procedure. The available options vary depending on the server technology.

❖ Edit any of the options. When you select a new option in the inspector, Dreamweaver updates the page.

More Help topics
“Edit dynamic content” on page 560

Input Name options
This Property inspector appears when Dreamweaver encounters an unrecognized input type. Typically this occurs because of a typing or other data entry error.

If you change the field type in the Property inspector to a value that Dreamweaver recognizes—for example, if you correct the spelling error—the Property inspector updates to show the properties for the recognized type. Set any of the following options in the Property inspector:

Input Name Assigns a name to the field. This box is required, and the name must be unique.
Type Sets the input type of the field. The contents of this box reflect the input type value that currently appears in your HTML source code.
Value Sets the value of the field.
Parameters Opens the Parameters dialog box so you can view the current attributes of the field, as well as add or remove attributes.
Designing dynamic pages

Dreamweaver and dynamic page design

Follow these general steps to successfully design and create a dynamic website.

1 Design the page.

A key step in designing any website—whether static or dynamic—is the visual design of the page. When adding dynamic elements to a web page, the design of the page becomes crucial to its usability. You should carefully consider how users will interact with both individual pages and the website as a whole.

A common method of incorporating dynamic content into a web page is to create a table to present content, and import dynamic content into one or more of the table’s cells. Using this method you can present information of various types in a structured format.

2 Create a source of dynamic content.

Dynamic websites require a content source from which to extract data before they can display it on a web page. Before you can use content sources in a web page, you must do the following:

- Create a connection to the dynamic content source (such as a database) and the application server processing the page. Create the data source by using the Bindings panel; then you can select and insert the data source in the page.
- Specify what information in the database you want to display, or what variables to include in the page by creating a recordset. You can also test the query from within the Recordset dialog box, and make any needed adjustments before adding it to the Bindings panel.
- Select and insert dynamic content elements into the selected page.

3 Add dynamic content to a web page.

After you define a recordset or other data source, and add it to the Bindings panel, you can insert the dynamic content the recordset represents into the page. The Dreamweaver menu-driven interface makes adding dynamic content elements as easy as selecting a dynamic content source from the Bindings panel, and inserting it into an appropriate text, image, or form object within the current page.

When you insert a dynamic content element or other server behavior into a page, Dreamweaver inserts a server-side script into the page’s source code. This script instructs the server to retrieve data from the defined data source and render it within the web page. To place dynamic content within a web page, you can do one of the following:

- Place it at the insertion point in either Code or Design view.
- Replace a text string or other placeholder.
  Insert it into an HTML attribute. For example, dynamic content can define the src attribute of an image or the value attribute of a form field.

4 Add server behaviors to a page.

In addition to adding dynamic content, you can incorporate complex application logic into web pages by using server behaviors. Server behaviors are predefined pieces of server-side code that add application logic to web pages, providing greater interaction and functionality.

The Dreamweaver server behaviors let you add application logic to a website without having to write the code yourself. The server behaviors supplied with Dreamweaver support ColdFusion, ASP, and PHP document types. The server behaviors are written and tested to be fast, secure, and robust. The built-in server behaviors support cross-platform web pages for all browsers.
Dreamweaver provides a point-and-click interface that makes applying dynamic content and complex behaviors to a page as easy as inserting textual and design elements. The following server behaviors are available:

- Define a recordset from an existing database. The recordset you define is then stored in the Bindings panel.
- Display multiple records on a single page. You select either an entire table or individual cells or rows that contain dynamic content, and specify the number of records to display on each page view.
- Create and insert a dynamic table into a page, and associate the table with a recordset. You can later modify both the table’s appearance and the repeating region by using the Property inspector and Repeating Region Server Behavior, respectively.
- Insert a dynamic text object into a page. The text object you insert is an item from a predefined recordset, to which you can apply any of the data formats.
- Create record navigation and status controls, master/detail pages, and forms for updating information in a database.
- Display more than one record from a database record.
- Create recordset navigation links that allow users to view the previous or next records from a database record.
- Add a record counter to help users keep track of how many records were returned, and where they are in the returned result.

You can also extend Dreamweaver server behaviors by writing your own, or installing server behaviors written by third parties.

5 Test and debug the page.

Before making a dynamic page—or an entire website—available on the web, you should test its functionality. You should also consider how your application’s functionality might affect people with disabilities.

**More Help topics**

“Presenting content with tables” on page 170

“Adding and modifying images” on page 226

“Inserting SWF files” on page 242

**Dynamic content sources overview**

**About dynamic content sources**

A *dynamic content source* is a store of information from which you can retrieve and display dynamic content for use in a web page. Sources of dynamic content include not only information stored in a database, but values submitted by HTML forms, values contained in server objects, and other content sources.

Dreamweaver lets you easily connect to a database and create a recordset from which to extract dynamic content. A *recordset* is the result of a database query. It extracts the specific information you request and allows you to display that information within a specified page. You define the recordset based on the information contained in the database and the content you want to display.

Different technology vendors may use different terminology for a recordset. In ASP and ColdFusion, a recordset is defined as a *query*. If you are using other sources of data, such as user input or server variables, the name of the data source that is defined in Dreamweaver is the same as the data source name itself.
Dynamic websites require a data source from which to retrieve and display dynamic content. Dreamweaver lets you use databases, request variables, URL variables, server variables, form variables, stored procedures, and other sources of dynamic content. Depending on the data source, you can either retrieve new content to satisfy a request, or modify the page to meet the needs of users.

Any content source that you define in Dreamweaver is added to the list of content sources in the Bindings panel. Then you can insert the content source into the currently selected page.

**About recordsets**

Web pages can’t directly access the data stored in a database. Instead, they interact with a recordset. A recordset is a subset of the information (records), extracted from the database using a database query. A query is a search statement designed to find and extract specific information from a database.

When using a database as a content source for a dynamic web page, you must first create a recordset in which to store the retrieved data. Recordsets serve as an intermediary between the database storing the content and the application server generating the page. Recordsets are temporarily stored in the application server’s memory for faster data retrieval. The server discards the recordset when it is no longer needed.

A query can produce a recordset that includes only certain columns, only certain records, or a combination of both. A recordset can also include all the records and columns of a database table. However, because applications rarely need to use every piece of data in a database, you should strive to make your recordsets as small as possible. Because the web server temporarily holds the recordset in memory, using a smaller recordset uses less memory, and can potentially improve server performance.

Database queries are written in Structured Query Language (SQL, pronounced “sequel”), a simple language that allows you to retrieve, add, and delete data to and from a database. The SQL builder included with Dreamweaver lets you create simple queries without having to understand SQL. However, if you want to create complex SQL queries, a basic knowledge of this language lets you create more advanced queries, and provides you with greater flexibility in designing dynamic pages.

Before you define a recordset for use with Dreamweaver, you must create a connection to a database and—if no data exists yet—enter data into the database. If you have not yet defined a database connection for your site, refer to the database connection chapter for the server technology you are developing for, and follow the instructions on creating a database connection.

**More Help topics**

“Define a recordset without writing SQL” on page 543

**About URL and form parameters**

URL parameters store retrieved information input by users. To define a URL parameter you create a form or hypertext link that uses the GET method to submit data. The information is appended to the URL of the requested page and communicated to the server. When using URL variables, the query string contains one or more name-value pairs that are associated with the form fields. These name-value pairs are appended to the URL.

Form parameters store retrieved information that is included in the HTTP request for a web page. If you create a form that uses the POST method, the data submitted by the form is passed to the server. Before you begin, make sure you pass a form parameter to the server.
About session variables

Session variables let you store and display information maintained for the duration of a user’s visit (or session). The server creates a different session object for each user and maintains it for a set period of time or until the object is explicitly terminated.

Because session variables last throughout the user’s session and persist when the user moves from page to page within the website, they’re ideal for storing user preferences. Session variables can also be used for inserting a value in the page’s HTML code, assigning a value to a local variable, or providing a value to evaluate a conditional expression.

Before defining session variables for a page, you must create them in the source code. After you create a session variable in the web application’s source code, you can use Dreamweaver to retrieve its value and use it in a web page.

How session variables work

Session variables store information (usually form or URL parameters submitted by users) and make it available to all of a web application’s pages for the duration of the user’s visit. For example, when users log on to a web portal that provides access to e-mail, stock quotes, weather reports, and daily news, the web application stores the login information in a session variable that identifies the user throughout the site’s pages. This allows the user to see only the types of content they have selected as they navigate through the site. Session variables can also provide a safety mechanism by terminating the user’s session if the account remains inactive for a certain period of time. This also frees server memory and processing resources if the user forgets to log off a website.

Session variables store information for the life of the use session. The session begins when the user opens a page within the application and ends when the user does not open another page in the application for a certain period of time, or when the user explicitly terminates the session (typically by clicking a “log-off” link). While it exists, the session is specific to an individual user, and every user has a separate session.

Use session variables to store information that every page in a web application can access. The information can be as diverse as the user’s name, preferred font size, or a flag indicating whether the user has successfully logged in. Another common use of session variables is to keep a running tally, such as the number of questions answered correctly so far in an online quiz, or the products the user selected so far from an online catalog.

Session variables can only function if the user’s browser is configured to accept cookies. The server creates a session ID number that uniquely identifies the user when the session is first initiated, then sends a cookie containing the ID number to the user’s browser. When the user requests another page on the server, the server reads the cookie in the browser to identify the user and to retrieve the user’s session variables stored in the server’s memory.

Collecting, storing, and retrieving information in session variables

Before creating a session variable, you must first obtain the information you want to store, and then send it to the server for storage. You can gather and send information to the server using HTML forms or hypertext links containing URL parameters. You can also obtain information from cookies stored on the user’s computer, from the HTTP headers sent by the user’s browser with a page request, or from a database.

A typical example of storing URL parameters in session variables is a product catalog that uses hard-coded URL parameters created using a link to send product information back to the server to be stored in a session variable. When a user clicks the “Add to shopping cart” link, the product ID is stored in a session variable while the user continues to shop. When the user proceeds to the check-out page, the product ID stored in the session variable is retrieved.
A form-based survey is a typical example of a page that stores form parameters in session variables. The form sends the selected information back to the server, where an application page scores the survey and stores the responses in a session variable to be passed to an application that might tally up the responses gathered from the survey population. Or the information might be stored in a database for later use.

After information is sent to the server, you store the information in session variables by adding the appropriate code for your server model to the page specified by the URL or form parameter. Referred to as the destination page, this page is specified in either the action attribute of the HTML form or the href attribute of the hypertext link on the starting page.

After you store a value in a session variable, you can use Dreamweaver to retrieve the value from session variables and use it in a web application. After you define the session variable in Dreamweaver, you can insert its value in a page.

The HTML syntax for each appears as follows:

```html
<form action="destination.html" method="get" name="myform"> </form>
<param name="href" value="destination.html">
```

Both the server technology used and the method you use to obtain the information determines the code used to store the information in a session variable. The basic syntax for each server technology is as follows:

**ColdFusion**

```coldfusion
<CFSET session.variable_name = value>
```

**ASP**

```asp
<% Session("variable_name") = value %>
```

The value expression is usually a server expression such as `Request.Form("lastname")`. For example, if you use a URL parameter called `product` (or an HTML form with the GET method and a text field called `product`) to gather information, the following statements store the information in a session variable called `prodID`:

**ColdFusion**

```coldfusion
<CFSET session.prodID = url.product>
```

**ASP**

```asp
<% Session("prodID") = Request.QueryString("product") %>
```

If you use an HTML form with the post method and a text field called `txtProduct` to gather the information, then the following statements store the information in the session variable:

**ColdFusion**

```coldfusion
<CFSET session.prodID = form.txtProduct>
```

**ASP**

```asp
<% Session("prodID") = Request.Form("txtProduct") %>
```
Example of information stored in session variables

You’re working on a site with a large audience of senior citizens. In Dreamweaver, add two links to the Welcome screen that let users customize the size of the site’s text. For larger, easy-to-read text, the user clicks one link, and for regular-size text, the user clicks another link.

Each link has a URL parameter called `fontsize` that submits the user’s text preference to the server, as the following Adobe ColdFusion example shows:

```
<a href="resort.cfm?fontsize=large">Larger Text</a>
<a href="resort.cfm?fontsize=small">Normal Text</a>
```

Store the user’s text preference in a session variable and use it to set the font size on each page the user requests.

Near the top of the destination page, enter the following code to create a session called `font_pref` that stores the user’s font size preference.

**ColdFusion**

```
<CFSET session.font_pref = url.fontsize>
```

**ASP**

```
<% Session("font_pref") = Request.QueryString("fontsize") %>
```

When the user clicks the hypertext link, the page sends the user’s text preference in a URL parameter to the destination page. The code on the destination page stores the URL parameter in the `font_pref` session variable. For the duration of the user’s session, all the pages of the application retrieve this value and display the selected font size.

More Help topics

“Adding dynamic content to pages” on page 556

“Define session variables” on page 550

ASP and ColdFusion application variables

In ASP and ColdFusion, you can use application variables to store and display information that is maintained for the lifetime of the application and persists from user to user. The application’s lifetime lasts from the time the first user requests a page in the application to the time the web server is stopped. (An application is defined as all the files in a virtual directory and its subdirectories.)

Because application variables last for the lifetime of the application, and persist from user to user, they’re ideal for storing information that must exist for all users, such as the current time and date. The value of the application variable is defined in the application’s code.
ASP server variables
You can define the following ASP server variables as sources of dynamic content: Request.Cookie, Request.QueryString, Request.Form, Request.ServerVariables, and Request.ClientCertificates.

More Help topics
“Define server variables” on page 552

ColdFusion server variables
You can define the following ColdFusion server variables:

Client variables  Associate data with a specific client. Client variables maintain the application’s state as the user moves from page to page in the application, as well as from session to session. “Maintaining state” means to preserve information from one page (or session) to the next so that the application remembers the user, and the user’s previous choices and preferences.

Cookie variables  Access cookies passed to the server by the browser.

CGI variables  Provide information about the server running ColdFusion, the browser requesting a page, and other information about the processing environment.

Server variables  Can be accessed by all clients and applications on the server. They persist until the server is stopped.

Local variables  Created with the CFSET tag or CFPARAM tag within a ColdFusion page.

More Help topics
“Define server variables” on page 552

Dynamic content panels

Bindings panel
Use the Bindings panel to define and edit sources of dynamic content, add dynamic content to a page, and apply data formats to dynamic text.

You can perform the following tasks with this panel:

- “Defining sources of dynamic content” on page 543
- “Adding dynamic content to pages” on page 556
- “Change or delete content sources” on page 555
- “Use predefined data formats” on page 570
- “Attach XML data sources” on page 486
- “Display XML data in XSLT pages” on page 487
- “URL parameters” on page 631
- “Define session variables” on page 550
- “Define application variables for ASP and ColdFusion” on page 551
- “Define server variables” on page 552
USING DREAMWEAVER
Making pages dynamic

- “Cache content sources” on page 555
- “Copy a recordset from one page to another page” on page 556
- “Make HTML attributes dynamic” on page 558

Server Behaviors panel
Use the Server Behavior panel to add Dreamweaver server behaviors to a page, edit server behaviors, and create server behaviors.

You can perform the following tasks with this panel:
- “Displaying database records” on page 562
- “Defining sources of dynamic content” on page 543
- “Build master and detail pages in one operation” on page 589
- “Building search and results pages” on page 590
- “Building a record insert page” on page 596
- “Building an update record page” on page 599
- “Building a delete record page” on page 604
- “Building a page that only authorized users can access” on page 619
- “Building a registration page” on page 615
- “Building a login page” on page 617
- “Building a page that only authorized users can access” on page 619
- “Add a stored procedure (ColdFusion)” on page 613
- “Delete dynamic content” on page 560
- “Adding custom server behaviors” on page 572

Databases panel
Use the Databases panel to create database connections, to inspect databases, and to insert database-related code in your pages.

You can view and connect to your database with this panel:
- “View your database within Dreamweaver” on page 533
- “Database connections for ColdFusion developers” on page 516
- “Database connections for ASP developers” on page 518
- “Database connections for PHP developers” on page 525

Components panel
Use the Components panel to create and inspect components, and to insert component code in your pages.

Note: The panel does not work in Design view.

You can perform the following tasks with this panel:
❖ “Using ColdFusion components” on page 623
Defining sources of dynamic content

Define a recordset without writing SQL

You can create a recordset without manually entering SQL statements.

1. In the Document window, open the page that will use the recordset.
2. Select Windows > Bindings to display the Bindings panel.
3. In the Bindings panel, click the Plus (+) button and select Recordset (Query) from the pop-up menu.
   The simple Recordset dialog box appears. If you are developing a ColdFusion site, the Recordset dialog box is slightly different. (If the advanced Recordset dialog appears instead, click the Simple button to switch to the simple Recordset dialog box.)
4. Complete the Recordset dialog box for your document type.
   For instructions, see the topics below.
5. Click the Test button to execute the query and ensure that it retrieves the information you intended.
   If you defined a filter that uses parameters input by users, enter a value in the Test Value box, and click OK. If an instance of the recordset is successfully created, a table appears that displays data extracted from the recordset.
6. Click OK to add the recordset to the list of available content sources in the Bindings panel.

Options for the simple Recordset dialog box (PHP, ASP)

1. In the Name box, enter a name for the recordset.
   A common practice is to add the prefix rs to recordset names to distinguish them from other object names in the code, for example: rsPressReleases.
   Recordset names can only contain letters, numbers, and the underscore character (_). You cannot use special characters or spaces.
2. Select a connection from the Connection pop-up menu.
   If no connection appears in the list, click Define to create one.
3. In the Table pop-up menu, select the database table that will provide data to the recordset.
   The pop-up menu displays all tables in the specified database.
4. To include a subset of the table’s columns in the recordset, click Selected and choose the desired columns by Control-clicking (Windows) or Command-clicking (Macintosh) them in the list.
5. To further limit the records returned from the table, complete the Filter section:
   • From the first pop-up menu, select a column in the database table to compare against a test value you define.
   • From the second pop-up menu, select a conditional expression to compare the selected value in each record against the test value.
   • From the third pop-up menu, select Entered Value.
   • In the box, enter the test value.
   If the specified value in a record meets your filtering condition, the record is included in the recordset.
6. (Optional) To sort the records, select a column to sort by, and then specify whether the records should be sorted in ascending order (1, 2, 3... or A, B, C...) or descending order.
7 Click Test to connect to the database and create an instance of the data source, and click OK to close the data source. A table appears displaying the returned data. Each row contains a record and each column represents a field in that record.

8 Click OK. The newly defined recordset appears in the Bindings panel.

**Options for the simple Recordset dialog box (ColdFusion)**

Define a recordset for ColdFusion document types as a source of dynamic content without you having to hand code SQL statements.

1 In the Name box, enter a name for the recordset.

   A common practice is to add the prefix `rs` to recordset names to distinguish them from other object names in your code. For example: `rsPressReleases`

   Recordset names can only contain letters, numbers, and the underscore character (_). You cannot use special characters or spaces.

2 If you’re defining a recordset for a ColdFusion component (that is, if a CFC file is currently open in Dreamweaver), select an existing CFC function from the Function pop-up menu, or click the New Function button to create a new function.

   *Note:* The Function pop-up menu is only available if a CFC file is the current document and you have access to a computer running ColdFusion MX 7 or better.

   The recordset is defined in the function.

3 Select a data source from the Data Source pop-up menu.

   If no data source appears in the pop-up menu, you must create a ColdFusion data source.

4 In the Username and Password boxes, enter the user name and password for the ColdFusion application server if required.

   Data sources in ColdFusion may require a user name and password to access them. If you do not have the user name and password to access a data source in ColdFusion, contact your organization’s ColdFusion administrator.

5 In the Table pop-up menu, select the database table that will provide data to the recordset.

   The Table pop-up menu displays all tables in the specified database.

6 To include a subset of the table’s columns in the recordset, click Selected and choose the desired columns by Control-clicking (Windows) or Command-clicking (Macintosh) them in the list.

7 To further limit the records returned from the table, complete the Filter section:

   - From the first pop-up menu, select a column in the database table to compare against a test value you define.
   - From the second pop-up menu, select a conditional expression to compare the selected value in each record against the test value.
   - From the third pop-up menu, select Entered Value.
   - In the box, enter the test value.

   If the specified value in a record meets your filtering condition, the record is included in the recordset.

8 (Optional) To sort the records, select a column to sort by, and then specify whether the records should be sorted in ascending (1, 2, 3... or A, B, C...) or descending order.

9 Click Test to connect to the database and create an instance of the data source.
A table appears displaying the returned data. Each row contains a record and each column represents a field in that record. Click OK to close the test recordset.

10 Click OK. The newly defined ColdFusion recordset appears in the Bindings panel.

**Define an advanced recordset by writing SQL**

Write your own SQL statements by using the advanced Recordset dialog box, or create a SQL statement by using the graphical Database Items tree.

1 In the Document window, open the page that will use the recordset.

2 Select Windows > Bindings to display the Bindings panel.

3 In the Bindings panel, click the Plus (+) button and select Recordset (Query) from the pop-up menu.

The advanced Recordset dialog box appears. If you are developing a ColdFusion site, the Recordset dialog box is slightly different. (If the simple Recordset dialog box appears instead, switch to the advanced Recordset dialog box by clicking the Advanced button.)

4 Complete the advanced Recordset dialog box.

For instructions, see the topics below.

5 Click the Test button to execute the query and ensure that it retrieves the information you intended.

If you defined a filter that uses parameters input by users, the Test button displays the Test Value dialog box. Enter a value in the Test Value box and click OK. If an instance of the recordset is successfully created, a table displaying the data from the recordset appears.

6 Click OK to add the recordset to the list of available content sources in the Bindings panel.

**More Help topics**

“Create SQL queries using the Database Items tree” on page 548

“Database connections for ASP developers” on page 518

“Database connections for PHP developers” on page 525

“Defining sources of dynamic content” on page 543

“Add a stored procedure (ColdFusion)” on page 613

**SQL primer**

**Options for the advanced Recordset dialog box (PHP, ASP)**

Define a recordset as a source of dynamic content by writing a custom SQL statement, or by creating a SQL statement using the graphical Database Items tree.

1 In the Name box, enter a name for the recordset.

A common practice is to add the prefix `rs` to recordset names to distinguish them from other object names in the code. For example: `rsPressRelease`

Recordset names can only contain letters, numbers, and the underscore character (_). You cannot use special characters or spaces.

2 Select a connection from the Connection pop-up menu.
3 Enter a SQL statement in the SQL text area or use the graphical Database Items tree at the bottom of the dialog box to build a SQL statement from the chosen recordset.

Do the following to use the Database Items tree to build the SQL statement:

- Ensure the SQL text area is blank.
- Expand the branches of the tree until you find the database object you need—a column in a table, for example, or a stored procedure in the database.
- Select the database object and click one of the buttons on the right side of the tree.

For example, if you select a table column, the available buttons are SELECT, WHERE, and ORDER BY. Click one of the buttons to add the associated clause to your SQL statement.

You can also use a predefined SQL statement in a stored procedure by selecting the stored procedure from the Database Items tree and clicking the Procedure button. Dreamweaver automatically fills in the SQL and Variable areas.

4 If the SQL statement contains variables, define their values in the Variables area by clicking the Plus (+) button and entering the variable’s name, type (integer, text, date, or floating point number), default value (the value the variable should take if no run-time value is returned), and run-time value.

**Note:** When using variables in a SQL statement in PHP, Dreamweaver automatically adds a leading dollar sign to the variable name, so you should omit the dollar sign (e.g., colname, instead of $colname).

If the SQL statement contains variables, make sure the Default Value column of the Variables box contains valid test values.

The run-time value is usually a URL or form parameter entered by a user in an HTML form field.

**URL parameters in the Run-time Value column:**

<table>
<thead>
<tr>
<th>Server Model</th>
<th>Run-Time value expression for URL parameter</th>
</tr>
</thead>
<tbody>
<tr>
<td>ASP</td>
<td>Request.QueryString(&quot;formFieldName&quot;)</td>
</tr>
<tr>
<td>PHP</td>
<td>$_GET['formFieldName']</td>
</tr>
</tbody>
</table>

**Form parameters in the Run-time Value column:**

<table>
<thead>
<tr>
<th>Server Model</th>
<th>Run-Time value expression for form parameter</th>
</tr>
</thead>
<tbody>
<tr>
<td>ASP</td>
<td>Request.Form(&quot;formFieldName&quot;)</td>
</tr>
<tr>
<td>PHP</td>
<td>$_POST['formFieldName']</td>
</tr>
</tbody>
</table>

5 Click Test to connect to the database and create an instance of the recordset.

If the SQL statement contains variables, make sure the Default Value column of the Variables box contains valid test values before clicking Test.

If successful, a table appears displaying the data in your recordset. Each row contains a record and each column represents a field in that record. Click OK to clear the recordset.

6 If satisfied with your work, click OK.

**Options for the advanced Recordset dialog box (ColdFusion)**

Use the advanced Recordset dialog box to write custom SQL queries, or use the Database Items tree to author SQL queries using a point-and-click interface.

1 In the Name box, enter a name for the recordset.
A common practice is to add the prefix `rs` to recordset names to distinguish them from other object names in your code. For example: `rsPressReleases`

Recordset names can only contain letters, numbers, and the underscore character (_). You cannot use special characters or spaces.

If you’re defining a recordset for a ColdFusion component (that is, if a CFC file is currently open in Dreamweaver), select an existing CFC function from the Function pop-up menu, or click the New Function button to create a new function.

**Note:** The Function pop-up menu is only available if a CFC file is the current document and you have access to a computer running ColdFusion MX 7 or better.

The recordset is defined in the function.

2 Select a data source from the Data Source pop-up menu.

If no data source appears in the pop-up menu list, you will need to first create a ColdFusion data source.

3 In the Username and Password boxes, enter the user name and password for the ColdFusion application server if required.

Data sources in ColdFusion may require a user name and password to access them. If you do not have the user name and password to access a data source in ColdFusion, contact your organization’s ColdFusion administrator.

4 Enter a SQL statement in the SQL text area or use the graphical Database Items tree at the bottom of the dialog box to build a SQL statement from the chosen recordset.

5 (Optional) Do the following to use the Database Items tree to build the SQL statement:
   - Ensure the SQL text area is blank.
   - Expand the branches of the tree until you find the database object you need—for example, a column in a table.
   - Select the database object and click one of the buttons on the right side of the tree.

For example, if you select a table column, the available buttons are Select, Where, and Order By. Click one of the buttons to add the associated clause to your SQL statement.

If your SQL statement contains parameters, define their values in the Parameters area by clicking the Plus (+) button and entering the parameter’s name and default value (the value the parameter should take if no run-time value is returned).

If the SQL statement contains parameters, make sure the Default Value column of the Parameters box contains valid test values.

The Page Parameters allow you to provide default values for run-time value references in the SQL you write. For example, the following SQL statement selects an employee record based on the value of the employee’s ID. You can assign a default value to this parameter, ensuring that a run-time value is always returned. In this example, `FormFieldName` refers to a form field in which the user enters an employee ID:

```
SELECT * FROM Employees WHERE EmpID = + (Request.Form('FormFieldName'))
```

The Add Page Parameters dialog box would contain a name-value pairing similar to:

<table>
<thead>
<tr>
<th>Name</th>
<th>Default values</th>
</tr>
</thead>
<tbody>
<tr>
<td>FormFieldName</td>
<td>0001</td>
</tr>
</tbody>
</table>

The run-time value is usually a URL or form parameter entered by a user in an HTML form field.

6 Click Test to connect to the database and create an instance of the recordset.
If the SQL statement contains run-time references, make sure the Default Value column of the Page Parameters field contains valid test values before clicking Test.

If successful, a table appears displaying the data in your recordset. Each row contains a record and each column represents a field in that record. Click OK to clear the recordset.

7 If satisfied with your work, click OK.

**Define parameters in a SQL statement (ColdFusion)**
Define parameters in a SQL statement; the default value is the value that the parameter should use if no run-time value is returned.

1 Select a parameter name from the Name pop-up menu.
2 Enter a default value for the parameter in the Default Parameter box, and click OK.

**Define parameters in a SQL statement (PHP)**
Define parameters in a SQL statement; the default value is the value that the parameter should use if no run-time value is returned.

1 Enter a parameter name in the Name box.
2 Enter a default value for the parameter in the Default Parameter box.
3 Enter a run-time value for a parameter in the Run-time Value box, and click OK.

**Create SQL queries using the Database Items tree**
Instead of manually typing SQL statements into the SQL box, you can use the Database Item’s point-and-click interface to create complex SQL queries. The Database Items tree lets you select database objects and link them using the SQL SELECT, WHERE, and ORDER BY clauses. After you create a SQL query, you can define any variables using the Variables area of the dialog box.

The next two examples describe two SQL statements and the steps for creating them using the advanced Recordset dialog box’s Database Items tree.

**Example: Selecting a table**
This example selects the entire contents of the Employees table. The SQL statement defining the query appears as follows:

```
SELECT * FROM Employees
```

To create this query, follow these steps.

1 Expand the Tables branch to display all of the tables in the selected database.
2 Select the Employees table.
3 Click the Select button.
4 Click OK to add the recordset to the Bindings panel.

**Example: Selecting specific rows from a table and ordering the results**
The following example selects two rows from the Employees table, and selects the job type using a variable that you must define. The results are then ordered by employee name.
USING DREAMWEAVER
Making pages dynamic

```
SELECT emplNo, emplName
FROM Employees
WHERE emplJob = 'varJob'
ORDER BY emplName

1 Expand the Tables branch to display all of the tables in the selected database; then expand the Employees table to display the individual table rows.

2 Build the SQL statement as follows:
   • Select emplNo, and click the Select button.
   • Select emplName, and click the Select button.
   • Select emplJob, and click the Where button.
   • Select emplName, and click the Order By button.

3 Place the insertion point after WHERE emplJob in the SQL text area and type = 'varJob' (include the equal sign).

4 Define the variable ‘varJob’ by clicking the Plus (+) button in the Variables area and entering the following values in the Name, Default Value, and Run-Time Value columns: varJob, CLERK, Request("job").

5 Click OK to add the recordset to the Bindings panel.

Define URL parameters

URL parameters store retrieved information input by users. Before you begin, make sure you pass a form or URL parameter to the server. After you define the URL variable, you can use its value in the currently selected page.

1 In the Document window, open the page that will use the variable.

2 Select Windows > Bindings to display the Bindings panel.

3 In the Bindings panel, click the Plus (+) button and select one of the following from the pop-up menu:

<table>
<thead>
<tr>
<th>Document Types</th>
<th>Menu item in Bindings panel for URL variable</th>
</tr>
</thead>
<tbody>
<tr>
<td>ASP</td>
<td>Request Variable &gt; Request.QueryString</td>
</tr>
<tr>
<td>ColdFusion</td>
<td>URL Variable</td>
</tr>
<tr>
<td>PHP</td>
<td>URL Variable</td>
</tr>
</tbody>
</table>

4 In the URL Variable dialog box, enter the name of the URL variable in the box, and click OK.

The URL variable name is normally the name of the HTML form field or object used to obtain its value.

5 The URL variable appears in the Bindings panel.

More Help topics

“About URL and form parameters” on page 537
“Adding dynamic content to pages” on page 556
“URL parameters” on page 631
“ColdFusion server variables” on page 541

Last updated 12/7/2011
Define form parameters
Form parameters store retrieved information that is included in the HTTP request for a web page. If you create a form that uses the POST method, the data submitted by the form is passed to the server. Before you begin, make sure you pass a form parameter to the server. After you define the form parameter as a content source, you can use its value in your page.

1 In the Document window, open the page that will use the variable.
2 Select Windows > Bindings to display the Bindings panel.
3 In the Bindings panel, click the Plus (+) button and select one of the following from the pop-up menu:

<table>
<thead>
<tr>
<th>Document Types</th>
<th>Menu item in Bindings panel for form variable</th>
</tr>
</thead>
<tbody>
<tr>
<td>ASP</td>
<td>Request Variable &gt; Request.Form</td>
</tr>
<tr>
<td>ColdFusion</td>
<td>Form Variable</td>
</tr>
<tr>
<td>PHP</td>
<td>Form Variable</td>
</tr>
</tbody>
</table>

4 In the Form Variable dialog box, enter the name of the form variable, and click OK. The form parameter name is normally the name of the HTML form field or object used to obtain its value.

The form parameter appears in the Bindings panel.

More Help topics
“About dynamic content sources” on page 536
“About URL and form parameters” on page 537
“Define server variables” on page 552

Define session variables
You can use session variables to store and display information maintained for the duration of a user’s visit (or session). The server creates a different session object for each user and maintains it for a set period of time or until the object is explicitly terminated.

Before defining session variables for a page, you must create them in the source code. After you create a session variable in the web application’s source code, you can use Dreamweaver to retrieve its value and use it in a web page.

1 Create a session variable in the source code, and assign a value to it.

For example, this ColdFusion example instantiates a session called username, and assigns it the value Cornelius:

```<CFSET session.username = Cornelius>```

2 Select Window > Bindings to display the Bindings panel.
3 Click the Plus (+) button, and select Session Variable from the pop-up menu.
4 Enter the name of the variable you defined in the application’s source code, and click OK.

More Help topics
“Using forms to collect information from users” on page 630
“How session variables work” on page 538
“Collecting, storing, and retrieving information in session variables” on page 538

Define application variables for ASP and ColdFusion
In ASP and ColdFusion, you can use application variables to store and display information that is maintained for the lifetime of the application and persists from user to user. After you define the application variable, you can use its value in a page.

Note: There are no application variable objects in PHP.

1 Open a dynamic document type in the Document window.
2 Select Window > Bindings to display the Bindings panel.
3 Click the Plus (+) button, and select Application Variable from the pop-up menu.
4 Enter the name of the variable as defined in the application’s source code, and click OK.
The application variable appears in the Bindings panel under the Application icon.

More Help topics
“About adding dynamic content” on page 556
“Define server variables” on page 552

Use a variable as a data source for a ColdFusion recordset
When you define a recordset for a page in the Bindings panel, Dreamweaver enters the name of the ColdFusion data source in the cfquery tag on the page. For more flexibility, you can store a data source name in a variable and use the variable in the cfquery tag. Dreamweaver provides a visual method of specifying such a variable in your recordsets.

1 Make sure a ColdFusion page is active in the Document window.
2 In the Bindings panel, click the Plus (+) button and select Data Source Name Variable from the pop-up menu.
The Data Source Name Variable dialog box appears.
3 Define a variable, and click OK.
4 When defining the recordset, select the variable as the data source for the recordset.

In the Recordset dialog box, the variable appears in the Data Source pop-up menu along with the ColdFusion data sources on the server.
5 Complete the Recordset dialog box, and click OK.
6 Initialize the variable.

Dreamweaver does not initialize the variable for you so that you can initialize it how and where you want. You can initialize the variable in the page code (before the `cfquery` tag), in an include file, or in some other file as a session or application variable.

### Define server variables

You define server variables as sources of dynamic content for use within a web application. Server variables vary from document type to document type and include form variables, URL variables, session variables, and application variables.

Server variables can be accessed by all clients that access the server, and by any applications running on the server. The variables persist until the server is stopped.

**More Help topics**

“Adding dynamic content to pages” on page 556

“URL parameters” on page 631

“HTML form parameters” on page 630

“ColdFusion server variables” on page 541

### Define ColdFusion server variables

1 Open the Bindings panel (Window > Bindings). In the Server Variable dialog box, enter the name of the server variable, and click OK.

2 Click the Plus (+) button and select the server variable from the pop-up menu.

3 Enter the name of the variable, and click OK. The ColdFusion server variable appears in the Bindings panel.

The following table lists the built-in ColdFusion server variables:

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>Server.ColdFusion.ProductName</code></td>
<td>ColdFusion product name.</td>
</tr>
<tr>
<td><code>Server.ColdFusion.SerialNumber</code></td>
<td>Serial number of currently installed version of ColdFusion.</td>
</tr>
<tr>
<td><code>Server.OS.Name</code></td>
<td>Name of operating system running on the server (Windows XP, Windows 2000, Linux).</td>
</tr>
<tr>
<td><code>Server.OS.AdditionalInformation</code></td>
<td>Additional information about installed operating system (service packs, updates).</td>
</tr>
<tr>
<td><code>Server.OS.Version</code></td>
<td>Version of installed operating system.</td>
</tr>
<tr>
<td><code>Server.OS.BuildNumber</code></td>
<td>Build number of installed operating system.</td>
</tr>
</tbody>
</table>
Define a ColdFusion local variable

Local variables are variables created with the \texttt{CFSET} or \texttt{CFPARAM} tag within a ColdFusion page. The defined local variable appears in the Bindings panel.

❖ In the Local Variable dialog box, enter the name of the local variable and click OK.

Define ASP server variables

You can define the following ASP server variables as sources of dynamic content: \texttt{Request.Cookie}, \texttt{Request.QueryString}, \texttt{Request.Form}, \texttt{Request.ServerVariables}, and \texttt{Request.ClientCertificates}.

1 Open the Bindings panel (Window > Bindings).
2 Click the Plus (+) button, and select Request Variable from the pop-up menu.
3 In the Request Variable dialog box, select one of the following request collections from the Type pop-up menu:

   - The QueryString collection retrieves information appended to the sending page’s URL, such as when the page has an HTML form using the \texttt{GET} method. The query string consists of one or more name-value pairs (for example, \texttt{last=Smith,first=Winston}) appended to the URL with a question mark (?). If the query string has more than one name-value pair, they are combined with ampersands (\&).
   - The Form collection retrieves form information included in the body of the HTTP request by an HTML form using the \texttt{POST} method.
   - The ServerVariables collection retrieves the values of predefined environment variables. The collection has a long list of variables, including \texttt{CONTENT_LENGTH} (the length of content submitted in the HTTP request, which you can use to see if a form is empty), and \texttt{HTTP_USER_AGENT} (provides information about the user’s browser).

   For example, \texttt{Request.ServerVariables("HTTP_USER_AGENT")} contains information about the submitting browser, such as \texttt{Mozilla/4.07 [en] (WinNT; I)}, which denotes a Netscape Navigator 4.07 browser.

   For a complete list of ASP server environment variables, see the online documentation installed with Microsoft Personal Web Server (PWS) or Internet Information Server (IIS).
   - The Cookies collection retrieves the values of the cookies sent in an HTTP request. For example, suppose the page reads a cookie called “readMe” on the user’s system. On the server, the values of the cookie are stored in the variable \texttt{Request.Cookies("readMe")}.
   - The ClientCertificate collection retrieves the certification fields from the HTTP request sent by the browser. The certification fields are specified in the X.509 standard.

4 Specify the variable in the collection that you want to access, and click OK.

For example, if you want to access the information in the \texttt{Request.ServerVariables("HTTP_USER_AGENT")} variable, enter the argument \texttt{HTTP_USER_AGENT}. If you want to access the information in the \texttt{Request.Form("lastname")} variable, enter the argument \texttt{lastname}.

The request variable appears in the Bindings panel.

Define PHP server variables

Define server variables as a source of dynamic content for PHP pages. The PHP server variables appear in the Bindings panel.

1 Open the Bindings panel (Window > Bindings).
2 Click the Plus (+) button, and select the variable from the pop-up menu.
3 In the Request Variable dialog box, enter the name of the variable (for example, REQUEST_METHOD), and click OK.
For more information, search for the keyword \$_SERVER in the PHP documentation.

**Define a ColdFusion client variable**
Define a ColdFusion client variable as a source of dynamic content for the page. The newly defined ColdFusion client variables appear in the Bindings panel.

- In the Client Variable dialog box, enter the name of the variable, and click OK.

For example, to access the information in the `Client.LastVisit` ColdFusion variable, enter `LastVisit`.

*Client variables* are variables created in the code to associate data with a specific client. Client variables maintain the application's state as the user moves from page to page within the application, as well as from session to session.

Client variables can be user-defined or built-in. The following table lists the built-in ColdFusion client variables:

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Client.CFID</td>
<td>An incremental ID for each client that connects to the server.</td>
</tr>
<tr>
<td>Client.CFTOKEN</td>
<td>A randomly generated number used to uniquely identify a particular client.</td>
</tr>
<tr>
<td>Client.URLToken</td>
<td>A combination of CFID and CFTOKEN to be passed between templates when cookies are not used.</td>
</tr>
<tr>
<td>Client.LastVisit</td>
<td>Records the timestamp of the last visit made by a client.</td>
</tr>
<tr>
<td>Client.HitCount</td>
<td>The number of page requests tied to a single client (tracked using CFID and CFTOKEN).</td>
</tr>
<tr>
<td>Client.TimeCreated</td>
<td>Records the timestamp when CFID and CFTOKEN were first created for a particular client.</td>
</tr>
</tbody>
</table>

**Define a ColdFusion cookie variable**
Cookie variables are created in the code, and access information contained in cookies passed to the server by a browser. The defined cookie variable appears in the Bindings panel.

- In the Cookie Variable dialog box, enter the name of the cookie variable, and click OK.

**Define a ColdFusion CGI variable**
The defined CGI variable appears in the Bindings panel.

- In the CGI Variable dialog box, enter the name of the variable, and click OK.

For example, if you want to access the information in the `CGI.HTTP_REFERER` variable, enter `HTTP_REFERER`.

The following table lists the most common ColdFusion CGI variables that are created on the server:

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SERVER_SOFTWARE</td>
<td>The name and version of the information server software answering the request (and running the gateway). Format: name/version.</td>
</tr>
<tr>
<td>SERVER_NAME</td>
<td>The server's hostname, DNS alias, or IP address as it appears in self-referencing URLs.</td>
</tr>
<tr>
<td>GATEWAY_INTERFACE</td>
<td>The revision of the CGI specification to which this server complies. Format: CGI/revision.</td>
</tr>
<tr>
<td>SERVER_PROTOCOL</td>
<td>The name and revision of the information protocol this request came in with. Format: protocol/revision.</td>
</tr>
<tr>
<td>SERVER_PORT</td>
<td>The port number to which the request was sent.</td>
</tr>
<tr>
<td>REQUEST_METHOD</td>
<td>The method with which the request was made. For HTTP, this is Get, Head, Post, and so on.</td>
</tr>
</tbody>
</table>
The following table lists the most common CGI variables created by the browser and passed to the server:

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>PATH_INFO</td>
<td>The extra path information, as given by the client. Scripts can be accessed by their virtual pathname, followed by extra information at the end of this path. The extra information is sent as PATH_INFO.</td>
</tr>
<tr>
<td>PATH_TRANSLATED</td>
<td>The server provides a translated version of PATH_INFO, which takes the path and does any virtual-to-physical mapping to it.</td>
</tr>
<tr>
<td>SCRIPT_NAME</td>
<td>A virtual path to the script being executed; used for self-referencing URLs.</td>
</tr>
<tr>
<td>QUERY_STRING</td>
<td>The query information that follows the question mark (?) in the URL that referenced this script.</td>
</tr>
<tr>
<td>REMOTE_HOST</td>
<td>The hostname making the request. If the server does not have this information, it sets REMOTE_ADDR and does not set REMOTE_HOST.</td>
</tr>
<tr>
<td>REMOTE_ADDR</td>
<td>The IP address of the remote host making the request.</td>
</tr>
<tr>
<td>AUTH_TYPE</td>
<td>If the server supports user authentication, and the script is protected, this is the protocol-specific authentication method used to validate the user.</td>
</tr>
<tr>
<td>REMOTE_USER AUTH_USER</td>
<td>If the server supports user authentication, and the script is protected, this is the user name they have authenticated as. (Also available as AUTH_USER.)</td>
</tr>
<tr>
<td>REMOTE_IDENT</td>
<td>If the HTTP server supports RFC 931 identification, this variable is set to the remote user name retrieved from the server. Use this variable for logging only.</td>
</tr>
<tr>
<td>CONTENT_TYPE</td>
<td>For queries that have attached information, such as HTTP POST and PUT, this is the content type of the data.</td>
</tr>
<tr>
<td>CONTENT_LENGTH</td>
<td>The length of the content as given by the client.</td>
</tr>
</tbody>
</table>

The following table lists the most common CGI variables created by the browser and passed to the server:

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>HTTP_REFERER</td>
<td>The referring document. This is the document that linked to or submitted form data.</td>
</tr>
<tr>
<td>HTTP_USER_AGENT</td>
<td>The browser the client is currently using to send the request. Format: software/version library/version.</td>
</tr>
<tr>
<td>HTTP_IF_MODIFIED_SINCE</td>
<td>The last time the page was modified. This variable is sent at the discretion of the browser, usually in response to the server having sent the LAST_MODIFIED HTTP header. It can be used to take advantage of browser-side caching.</td>
</tr>
</tbody>
</table>

### Cache content sources

You can cache—or store—sources of dynamic content in a Design Note. This lets you work on a site even if you don’t have access to the database or application server storing the sources of dynamic content. Caching may also speed up development by eliminating repeated access across a network to the database and application server.

- Click the arrow button in the top right corner of the Bindings panel and toggle Cache in the pop-up menu.

If you make changes to one of the content sources, you can refresh the cache by clicking the Refresh button (the circle-arrow icon) in the upper-right corner of the Bindings panel. (Expand the panel if you don’t see the button.)

### Change or delete content sources

You can change or delete any existing source of dynamic content—that is, any content source listed in the Bindings panel.

Changing or deleting a content source in the Bindings panel does not change or delete any instance of that content on the page. It merely changes or deletes it as a possible source of content for the page.
Change a content source in the Bindings panel
1. In the Bindings panel (Window > Bindings), double-click the name of the content source you want to edit.
2. Make your changes in the dialog box that appears.
3. If satisfied with your work, click OK.

Delete a content source from the Bindings panel
1. In the Bindings panel (Window > Bindings), select the content source from the list.
2. Click the Minus (-) button.

Copy a recordset from one page to another page
You can copy a recordset from one page to another within a defined site.
1. Select the recordset in either the Bindings panel or the Server Behaviors panel.
2. Right-click the recordset, and select Copy from the pop-up menu.
3. Open the page you want to copy the recordset to.
4. Right-click the Bindings panel or the Server Behaviors toolbar, and select Paste from the pop-up menu.

More Help topics
“About dynamic content sources” on page 536
“Change or delete content sources” on page 555

Adding dynamic content to pages

About adding dynamic content
After you define one or more sources of dynamic content, you can use the sources to add dynamic content on the page. Content sources can include a column in a recordset, a value submitted by an HTML form, the value contained in a server object, or other data.

In Dreamweaver, you can place dynamic content almost anywhere in a web page or its HTML source code. You can place dynamic content at the insertion point, replace a text string, or insert it as an HTML attribute. For example, dynamic content can define the src attribute of an image, or the value attribute of a form field.

You can add dynamic content to a page by selecting a content source in the Bindings panel. Dreamweaver inserts a server-side script in the page’s code instructing the server to transfer the data from the content source to the page’s HTML code when the page is requested by a browser.

There is often more than one way to make a given page element dynamic. For example, to make an image dynamic you can use the Bindings panel, the Property inspector, or the Image command in the Insert menu.

By default, an HTML page can display only one record at a time. To display the other records in the recordset, you can add a link to move through the records one at a time, or you can create a repeating region to display more than one record on a single page.
About dynamic text
Dynamic text adopts any text formatting applied to the existing text or to the insertion point. For example, if a Cascading Style Sheet (CSS) style affects the selected text, the dynamic content replacing it is also affected by the style. You can add or change the text format of dynamic content by using any of the Dreamweaver text formatting tools.

You can also apply a data format to dynamic text. For example, if your data consists of dates, you can specify a particular date format such as 04/17/00 for U.S. visitors, or 17/04/00 for Canadian visitors.

Make text dynamic
You can replace existing text with dynamic text, or you can place dynamic text at a given insertion point on the page.

More Help topics
“About recordsets” on page 537
“Use predefined data formats” on page 570

Add dynamic text
1 In Design view, select text on the page, or click where you want to add dynamic text.
2 In the Bindings panel (Window > Bindings), select a content source from the list. If you select a recordset, specify the column you want in the recordset.

The content source should contain plain text (ASCII text). Plain text includes HTML. If no content sources appear in the list, or if the available content sources don’t meet your needs, click the Plus (+) button to define a new content source.
3 (Optional) Select a data format for the text.
4 Click Insert, or drag the content source onto the page.

A dynamic content placeholder appears. (If you selected text on the page, the placeholder replaces the text selection.) The placeholder for recordset content uses the syntax {RecordsetName.ColumnName}, where Recordset is the name of the recordset and ColumnName is the name of the column you chose from the recordset.

Sometimes, the length of the placeholders for dynamic text distorts the page’s layout in the Document window. You can solve the problem by using empty curly braces as placeholders, as described in the next topic.

Display placeholders for dynamic text
1 Select Edit > Preferences > Invisible Elements (Windows) or Dreamweaver > Preferences > Invisible Elements (Macintosh).
2 In the Show Dynamic Text As pop-up menu, select { }, and click OK.
Make images dynamic
You can make images on your page dynamic. For example, suppose you design a page to display items for sale at a charity auction. Each page would include descriptive text and a photo of one item. The page’s general layout would remain the same for each item, but the photo (and descriptive text) could change.

1 With the page open in Design view (View > Design), place the insertion point where you want the image to appear on the page.
2 Select Insert > Image.
The Select Image Source dialog box appears.
3 Click the Data Sources option (Windows) or the Data Source button (Macintosh).
   A list of content sources appears.
4 Select a content source from the list, and click OK.
The content source should be a recordset that contains the paths to your image files. Depending on the file structure of your site, the paths can be absolute, document relative, or root relative.
   Note: Dreamweaver does not currently support binary images stored in a database.
If no recordsets appear in the list, or if the available recordsets don’t meet your needs, define a new recordset.

More Help topics
“Define a recordset without writing SQL” on page 543

Make HTML attributes dynamic
You can dynamically change the appearance of a page by binding HTML attributes to data. For example, you can change the background image of a table by binding the table’s background attribute to a field in a recordset.

You can bind HTML attributes with the Bindings panel or with the Property inspector.

Make HTML attributes dynamic with the Bindings panel
1 Open the Bindings panel by choosing Window > Bindings.
2 Ensure that the Bindings panel lists the data source you want to use.
The content source should contain data that’s appropriate for the HTML attribute you want to bind. If no sources of content appear in the list, or if the available content sources don’t meet your needs, click the Plus (+) button to define a new data source.
3 In Design view, select an HTML object.
   For example, to select an HTML table, click inside the table and click the <table> tag in the tag selector on the bottom-left of the Document window.
4 In the Bindings panel, select a content source from your list.
5 In the Bind To box, select an HTML attribute from the pop-up menu.
6 Click Bind.
The next time the page runs on the application server, the value of the data source will be assigned to the HTML attribute.
Make HTML attributes dynamic with the Property inspector
1 In Design view, select an HTML object and open the Property inspector (Window > Properties).
   For example, to select an HTML table, click inside the table and click the `<table>` tag in the tag selector on the bottom-left of the Document window.

2 How you bind a dynamic content source to the HTML attribute depends on where it is located.
   • If the attribute you want to bind has a folder icon next to it in the Property inspector, click the folder icon to open a file selection dialog box; then click the Data Sources option to display a list of data sources.
   • If the attribute you want to bind does not have a folder icon next to it, click the List tab (the lower of the two tabs) on the left side of the inspector.
   The Property inspector’s List view appears.
   • If the attribute you want to bind is not listed in the List view, click the Plus (+) button; then enter the attribute’s name or click the small arrow button and select the attribute from the pop-up menu.

3 To make the attribute’s value dynamic, click the attribute; then click the lightning-bolt icon or folder icon at the end of the attribute’s row.
   If you clicked the lightning bolt icon, a list of data sources appears.
   If you clicked the folder icon, a file selection dialog box appears. Select the Data Sources option to display a list of content sources.

4 Select a source of content from the list of content sources, and click OK.
   The content source should hold data that’s appropriate for the HTML attribute you want to bind. If no content sources appear in the list, or if the available content sources don’t meet your needs, define a new content source.
   The next time the page runs on the application server, the value of the data source will be assigned to the HTML attribute.

Make ActiveX, Flash, and other object parameters dynamic
You can make the parameters of Java applets and plug-ins dynamic, as well as the parameters of ActiveX, Flash, Shockwave, Director, and Generator objects.

Before starting, make sure the fields in your recordset hold data that’s appropriate for the object parameters you want to bind.

1 In Design view, select an object on the page and open the Property inspector (Window > Properties).
2 Click the Parameters button.
3 If your parameter does not appear in the list, click the Plus (+) button and enter a parameter name in the Parameter column.
4 Click the parameter’s Value column, and then click the lightning-bolt icon to specify a dynamic value.
   A list of data sources appears.
5 Select a data source from the list, and click OK.
   The data source should hold data that’s appropriate for the object parameter you want to bind. If no data sources appear in the list, or if the available data sources don’t meet your needs, define a new data source.

More Help topics
“Defining sources of dynamic content” on page 543
Changing dynamic content

About dynamic content
You can change the dynamic content on your page by editing the server behavior that provides the content. For example, you can edit a recordset server behavior to provide more records to your page.

Dynamic content on a page is listed in the Server Behaviors panel. For example, if you add a recordset to your page, the Server Behaviors panel lists it as follows:

```
Recordset(myRecordset)
```

If you add another recordset to your page, the Server Behaviors panel lists both recordsets as follows:

```
Recordset(mySecondRecordset)Recordset(myRecordset)
```

Edit dynamic content

1. Open the Server Behaviors panel (Window > Server Behaviors).
2. Click the Plus (+) button to display the server behaviors, and double-click the server behavior in the panel. The dialog box that you used to define the original data source appears.
3. Make your changes in the dialog box, and click OK.

Delete dynamic content

❖ After adding dynamic content to a page, delete it in one of the following ways:
   - Select the dynamic content on the page, and press Delete.
   - Select the dynamic content in the Server Behaviors panel, and click the Minus (-) button.

   **Note:** This operation removes the server-side script in the page that retrieves the dynamic content from the database. It does not delete the data in the database.

Test dynamic content

You can preview and edit dynamic content using Live view.

While dynamic content is displayed, you can perform the following tasks:

- Adjust the page's layout using the page-design tools
- Add, edit, or delete dynamic content
- Add, edit, or delete server behaviors

1. Click the Live view button to display dynamic content.
2. Make the necessary changes to the page. You'll need to toggle between Live view and Design or Code view to make changes and see how they take effect.

More Help topics

“HTML form parameters” on page 630
“URL parameters” on page 631
“How session variables work” on page 538

Last updated 12/7/2011
Let Adobe Contribute users edit dynamic content

When a Contribute user edits a page containing dynamic content or invisible elements (such as scripts and comments), Contribute displays the dynamic content and invisible elements as yellow markers. By default, Contribute users can’t select or delete these markers.

If you want Contribute users to be able to select and delete dynamic content and other invisible elements from a page, you can change permission-group settings to allow them to do so; Contribute users normally can never edit dynamic content, even when you allow them to select it.

Note: Using some server technologies, you can display static text using a server tag or function. To allow Contribute users to edit the static text in a dynamic page that uses such a server technology, place the static text outside of the server tags. For more information, see Administering Adobe Contribute.

1 Select Site > Administer Contribute Site.
2 If certain required options for Contribute compatibility aren’t enabled, a dialog box appears, asking if you want to enable those options. Click OK to enable those options and Contribute compatibility.
3 If prompted, enter the administrator password, and then click OK.
The Administer Website dialog box appears.
4 In the Users And Roles category, select a role, and then click the Edit Role Settings button.
5 Select the Editing category, and deselect the option to protect scripts and forms.
6 Click OK to close the Edit Settings dialog box.
7 Click Close to close the Administer Website dialog box.

More Help topics
“Managing Contribute sites” on page 52
“Create a template for a Contribute site” on page 384

Modify recordsets with the Property inspector

Use the Property inspector to modify the selected recordset. The available options vary depending on the server model.

1 Open the Property inspector (Window > Properties) and then select the recordset in the Server Behaviors panel (Window > Server Behavior).
2 Edit any of the options. When you select a new option in the inspector, Dreamweaver updates the page.

More Help topics
“Edit dynamic content” on page 560
Displaying database records

About database records
Displaying database records involves retrieving information stored in a database or other source of content, and rendering that information to a web page. Dreamweaver provides many methods of displaying dynamic content, and provides several built-in server behaviors that let you both enhance the presentation of dynamic content, and allow users to more easily search through and navigate information returned from a database.

Databases and other sources of dynamic content provide you with more power and flexibility in searching, sorting, and viewing large stores of information. Using a database to store content for websites makes sense when you need to store large amounts of information, and then retrieve and display that information in a meaningful way. Dreamweaver provides you with several tools and prebuilt behaviors to help you effectively retrieve and display information stored in a database.

Server behaviors and formatting elements
Dreamweaver provides the following server behaviors and formatting elements to let you enhance the display of dynamic data:

**Formats** let you apply different types of numerical, monetary, date/time, and percentage values to dynamic text.

For example, if the price of an item in a recordset reads 10.989, you can display the price on the page as $10.99 by selecting the Dreamweaver “Currency - 2 Decimal Places” format. This format displays a number using two decimal places. If the number has more than two decimal places, the data format rounds the number to the closest decimal. If the number has no decimal places, the data format adds a decimal point and two zeros.

**Repeating Region** server behaviors let you display multiple items returned from a database query, and let you specify the number of records to display per page.

**Recordset Navigation** server behaviors let you insert navigation elements that allow users to move to the next or previous set of records returned by the recordset. For example, if you choose to display 10 records per page using the Repeating Region server object, and the recordset returns 40 records, you can navigate through 10 records at a time.

**Recordset Status Bar** server behaviors let you include a counter that shows users where they are within a set of records relative to the total number of records returned.

**Show Region** server behaviors let you choose to show or hide items on the page based on the relevance of the currently displayed records. For example, if a user has navigated to the last record in a recordset, you can hide the Next link, and display only the Previous records link.

Applying typographic and page layout elements to dynamic data
A powerful feature of Dreamweaver is the ability to present dynamic data within a structured page, and to apply typographic formatting using HTML and CSS. To apply formats to dynamic data in Dreamweaver, format the tables and placeholders for the dynamic data using the Dreamweaver formatting tools. When the data is inserted from its data source, it automatically adopts the font, paragraph, and table formatting you specified.

More Help topics
“Presenting content with tables” on page 170
Navigating database recordset results

Recordset navigation links let users move from one record to the next, or from one set of records to the next. For example, after designing a page to display five records at a time, you might want to add links such as Next or Previous that let users display the five next or previous records.

You can create four types of navigation links to move through a recordset: First, Previous, Next, and Last. A single page can contain any number of these links, provided they all work on a single recordset. You can’t add links to move through a second recordset on the same page.

Recordset navigation links require the following dynamic elements:

- A recordset to navigate
- Dynamic content on the page to display the record or records
- Text or images on the page to serve as a clickable navigation bar
- A Move To Record set of server behaviors to navigate the recordset

You can add the last two elements by using the Record Navigation Bar server object, or you can add them separately by using the design tools and the Server Behaviors panel.

Create a recordset navigation bar

You can create a recordset navigation bar in a single operation using the Recordset Navigation Bar server behavior. The server object adds the following building blocks to the page:

- An HTML table with either text or image links
- A set of Move To server behaviors
- A set of Show Region server behaviors

The text version of the Recordset Navigation Bar looks like this:

The image version of the Recordset Navigation Bar looks like this:

Before placing the navigation bar on the page, make sure the page contains a recordset to navigate and a page layout in which to display the records.

After placing the navigation bar on the page, you can use the design tools to customize the bar to your liking. You can also edit the Move To and Show Region server behaviors by double-clicking them in the Server Behaviors panel.

Dreamweaver creates a table that contains text or image links that allow the user to navigate through the selected recordset when clicked. When the first record in the recordset is displayed, the First and Previous links or images are hidden. When the last record in the recordset is displayed, the Next and Last links or images are hidden.

You can customize the layout of the navigation bar by using the design tools and the Server Behaviors panel.

1. In Design view, place the insertion point at the location on the page where you want the navigation bar to appear.
3. Select the recordset you want to navigate from the Recordset pop-up menu.
From the Display Using section, select the format to display the navigation links on the page, and click OK.

- **Text**: Places text links on the page.
- **Images**: Includes graphical images as links. Dreamweaver uses its own image files. You can replace these images with image files of your own after placing the bar on the page.

### Custom recordset navigation bars

You can create your own recordset navigation bar that uses more complex layout and formatting styles than the simple table created by the Recordset Navigation Bar server object.

To create your own recordset navigation bar, you must:

- Create navigation links in text or images
- Place the links in the page in Design view
- Assign individual server behaviors to each navigation link

This section describes how to assign individual server behaviors to the navigation links.

#### Create and assign server behaviors to a navigation link

1. In Design view, select the text string or image on the page you want to use as a record navigation link.
2. Open the Server Behaviors panel (Window > Server Behaviors), and click the Plus (+) button.
3. Select Recordset Paging from the pop-up menu; then select a server behavior appropriate to that link from the listed server behaviors.

If the recordset contains a large number of records, the Move To Last Record server behavior can take a long time to run when the user clicks the link.

4. In the Recordset pop-up menu, select the recordset that contains the records, and click OK.

The server behavior is assigned to the navigation link.

#### Set the Move To (server behavior) dialog box options

Add links that let the user navigate through records in a recordset.

1. If you didn’t select anything on the page, select a link from the pop-up menu.
2. Select the recordset that contains the records to page through, and click OK.

*Note: If the recordset contains a large number of records, the Move To Last Record server behavior can take a long time to run when the user clicks the link.*

### Navigation bar design tasks

When creating a custom navigation bar, begin by creating its visual representation using the Dreamweaver page-design tools. You don’t have to create a link for the text string or image, Dreamweaver creates one for you.

The page you create the navigation bar for must contain a recordset to navigate. A simple recordset navigation bar might look like this, with link buttons created out of images, or other content elements:
After you have added a recordset to a page, and have created a navigation bar, you must apply individual server behaviors to each navigation element. For example, a typical recordset navigation bar contains representations of the following links matched to the appropriate behavior:

<table>
<thead>
<tr>
<th>Navigation link</th>
<th>Server behavior</th>
</tr>
</thead>
<tbody>
<tr>
<td>Go to first page</td>
<td>Move to first page</td>
</tr>
<tr>
<td>Go to previous page</td>
<td>Move to previous page</td>
</tr>
<tr>
<td>Go to next page</td>
<td>Move to next page</td>
</tr>
<tr>
<td>Go to last page</td>
<td>Move to last page</td>
</tr>
</tbody>
</table>

**Display and hide regions based on recordset results**

You can also specify that a region be displayed or hidden based on whether the recordset is empty. If a recordset is empty (for example, no records were found matching the query), you can display a message informing the user that no records were returned. This is especially useful when creating search pages that rely on user input search terms to run queries against. Similarly, you can display an error message if there is a problem connecting to a database, or if a user’s user name and password do not match those recognized by the server.

The Show Region server behaviors are:

- Show If Recordset Is Empty
- Show If Recordset Is Not Empty
- Show If First Page
- Show If Not First Page
- Show If Last Page
- Show If Not Last Page

1. In Design view, select the region on the page to show or hide.
2. In the Server Behaviors panel (Window > Server Behaviors), click the Plus (+) button.
3. Select Show Region from the pop-up menu, select one of the listed server behaviors, and click OK.

**Display multiple recordset results**

The Repeating Region server behavior lets you display multiple records from a recordset within a page. Any dynamic data selection can be turned into a repeating region. However, the most common regions are a table, a table row, or a series of table rows.

1. In Design view, select a region that contains dynamic content.

The selection can be anything, including a table, a table row, or even a paragraph of text.
To select a region on the page precisely, you can use the tag selector on the left corner of the document window. For example, if the region is a table row, click inside the row on the page, then click the rightmost `<tr>` tag in the tag selector to select the table row.

2 Select Window > Server Behaviors to display the Server Behaviors panel.
3 Click the Plus (+) button, and select Repeating Region.
4 Select the name of the recordset to use from the pop-up menu.
5 Select the number of records to display per page, and click OK.

In the Document window, a thin, tabbed, gray outline appears around the repeating region.

More Help topics

“About database records” on page 562
“Edit dynamic content” on page 560

Modify repeating regions in the Property inspector

- Modify the selected repeating region by changing any of the following options:
  - The name of the repeating region.
  - The recordset providing the records for the repeating region.
  - The number of records displayed

When you select a new option, Dreamweaver updates the page.

Reuse PHP recordsets

For a tutorial on reusing PHP recordsets, see David Powers’s tutorial, How Do I Reuse a PHP Recordset in More Than One Repeat Region?
Create a dynamic table

The following example illustrates how the Repeating Region server behavior is applied to a table row, and specifies that nine records are displayed per page. The row itself displays four different records: city, state, street address, and ZIP code.

To create a table such as the one in the previous example, you must create a table that contains dynamic content, and apply the Repeating Region server behavior to the table row containing the dynamic content. When the page is processed by the application server, the row is repeated the number of times specified in the Repeating Region server object, with a different record inserted in each new row.

1. Do one of the following to insert a dynamic table:
   - Select Insert > Data Objects > Dynamic Data > Dynamic Table to display the Dynamic Table dialog box.
   - From the Data category of the Insert panel, click the Dynamic Data button and select the Dynamic Table icon from the pop-up menu.
2. Select the recordset from the Recordset pop-up menu.
3. Select the number of records to display per page.
4. (Optional) Input values for the table border, cell padding, and cell spacing.

   The Dynamic Table dialog box retains the values you enter for table borders, cell padding, and cell spacing.

   **Note:** If you are working on a project that requires several dynamic tables with the same appearance, enter the table layout values, which further simplifies page development. You can adjust these values after inserting the table by using the table Property inspector.

5. Click OK.
A table and placeholders for the dynamic content defined in its associated recordset are inserted into the page.

In this example, the recordset contains four columns: AUTHORID, FIRSTNAME, LASTNAME, and BIO. The table’s heading row is populated with the names of each column. You can edit the headings using any descriptive text, or replace them with representative images.

### Create record counters

Record counters give users a reference point when they are navigating through a set of records. Typically, record counters display the total number of records returned, and the current records being viewed. For example, if a recordset returns 40 individual records, and 8 records are displayed per page, the record counter on the first page would indicate “Displaying records 1-8 of 40.”

Before you create a record counter for a page, you must create a recordset for the page, an appropriate page layout to contain the dynamic content, and then a recordset navigation bar.

#### More Help topics

- “About recordsets” on page 537
- “Create a recordset navigation bar” on page 563
- “Display multiple recordset results” on page 565
- “Create a dynamic table” on page 567

### Create simple record counters

Record counters let users know where they are within a given set of records relative to the total number of records returned. For this reason record counters are a useful behavior that can significantly add to the usability of a web page.

Create a simple record counter by using the Recordset Navigation Status server object. This server object creates a text entry on the page to display the current record status. You can customize the record counter by using Dreamweaver page-design tools.

1. Place the insertion point where you want to insert the record counter.
2. Select Insert > Data Objects > Display Record Count > Recordset Navigation Status, select the recordset from the Recordset pop-up menu, and click OK.

The Recordset Navigation Status server object inserts a text record counter that appears similar to the following example:

```
Records {Employees_first} to {Employees_last} of {Employees_total}
```

When viewed in Live view, the counter appears similar to the following example:

```
Records 1 to 1 of 22
```
Build and add the record counter to the page
❖ In the Insert Recordset Navigation Status dialog box, select the recordset to track, and click OK.

Create custom record counters
You use individual record count behaviors to create custom record counters. Creating a custom record counter lets you create a record counter beyond the simple, single row table inserted by the Recordset Navigation Status server object. You can arrange design elements in a number of creative ways, and apply an appropriate server behavior to each element.

The Record Count server behaviors are:
❖ Display Starting Record Number
❖ Display Ending Record Number
❖ Display Total Records

Before you create a custom record counter for a page, you must first create a recordset for the page, an appropriate page layout to contain the dynamic content, and a recordset navigation bar.

This example creates a record counter that appears similar to the example in “Simple record counters.” In this example, the text in sans-serif font represents the record count placeholders that will be inserted in the page. The record counter in this example appears as follows:

Displaying records StartRow through EndRow of RecordSet.RecordCount.

1 In Design view, enter the counter’s text on the page. The text can be anything you want, for example:
Displaying records thru of.

2 Place the insertion point at the end of the text string.

3 Open the Server Behaviors panel (Window > Server Behaviors).

4 Click the Plus (+) button in the upper-left corner, and click Display Record Count. Within this submenu, select Display Total Records. The Display Total Records behavior is inserted into the page, and a placeholder is inserted where the insertion point was. The text string now appears as follows:
Displaying records thru of {Recordset1.RecordCount}.

5 Place the insertion point after the word records, and select the Display Starting Record Count Number from the Server Behaviors > Plus (+) button > Record Count panel. The text string now appear as follows:
Displaying records {StartRow_Recordset1} thru of {Recordset1.RecordCount}.

6 Now place the insertion point between the words thru and of, and select the Display Starting Record Count Number from the Server Behaviors > Plus (+) button > Record Count panel. The text string now appear as follows:
Displaying records {StartRow_Recordset1} thru {EndRow_Recordset1} of {Recordset1.RecordCount}.

7 Confirm that the counter functions correctly by viewing the page in Live view; the counter is similar to the following example:
Displaying records 1 thru 8 of 40.

If the results page has a navigation link to move to the next set of records, clicking the link updates the record counter to read as follows:
Showing records 9 thru 16 of 40.
Use predefined data formats
Dreamweaver includes several predefined data formats that you can apply to dynamic data elements. The data format styles include date and time, currency, numerical, and percentage formats.

Apply data formats to dynamic content
1. Select the dynamic content placeholder in the Document window.
2. Select Window > Bindings to display the Bindings panel.
3. Click the down arrow button in the Format column.
   If the down arrow is not visible, expand the panel.
4. From the Format pop-up menu, select the data format category you want.
   Ensure that the data format is appropriate for the type of data you are formatting. For example, the Currency formats work only if the dynamic data consists of numerical data. Note that you cannot apply more than one format to the same data.
5. Verify that the format was applied correctly by previewing the page in Live view.

Customize a data format
1. Open a page that contains dynamic data in Design view.
2. Select the dynamic data whose format you want to customize.
   The bound data item whose dynamic text you selected is highlighted in the Bindings panel (Window > Bindings). The panel displays two columns for the selected item—Binding and Format. If the Format column is not visible, widen the Bindings panel to reveal it.
3. In the Bindings panel, click the down arrow in the Format column to expand the pop-up menu of available data formats.
   If the down arrow is not visible, widen the Bindings panel more.
4. Select Edit Format List from the pop-up menu.
5. Complete the dialog box, and click OK.
   a. Select the format from the list, and click Edit.
   b. Change any of the following parameters in the Currency, Number, or Percent dialog boxes, and click OK.
      • The number of digits to display after the decimal point
      • Whether to place a leading zero in front of fractions
      • Whether to use parentheses or a minus sign for negative values
      • Whether to group digits
   c. To delete a data format, click the format in the list, and click the Minus (-) button.

Create a data format (ASP only)
1. Open a page containing dynamic data in Design view.
2. Select the dynamic data you want to create a custom format for.
3. Select Window > Bindings to display the Bindings panel, and click the down arrow in the Format column. If the down arrow is not visible, expand the panel.
4. Select Edit Format List from the pop-up menu.
Click the Plus (+) button, and select a format type.

Define the format, and click OK.

Enter a name for the new format in the Name column, and click OK.

Note: Though Dreamweaver only supports creating data formats for ASP pages, ColdFusion and PHP users can download formats that other developers created, or create server formats and post them to the Dreamweaver Exchange. For more information on the Server Format API, see Extending Dreamweaver.

Note: Extending Dreamweaver

Note: Extending Dreamweaver

Viewing live data

The View Live Data feature has been deprecated as of Dreamweaver CS5. It has been replaced by the more streamlined Live view feature.

To view live data in Live view, make sure that you have done the following:

- Define a folder to process dynamic pages (for example, a root folder on a ColdFusion server, either on your computer or on a remote machine).
  - If the page displays an error message when you enter Live View, make sure the Web URL in the Site Definition dialog box is correct.
- Copy related files (if any) to the folder.
- Provide the page with any parameters a user would normally provide.

Provide the page with live data in Live view

1. Open the Live View Settings dialog box (View > Live View Options > HTTP Request Settings).
2. In the URL Request area, click the Plus (+) button and enter a parameter your page expects.
3. Specify a name and a test value for each parameter.
4. In the Method pop-up menu, select the HTML form method your page expects: POST or GET.
5. To save your settings for the current page, select Save Settings For This Document, and click OK.

Note: To save the settings, you must enable Design Notes (File > Design Notes).

Troubleshooting live data in Live view

Many problems viewing live data in Live view can be traced back to missing or incorrect values in the Site Definition dialog box (Site > Edit Sites).
Check the settings for the server that you've specified as your testing server. You need to specify a folder capable of processing dynamic pages where the Site Definition dialog asks for a server folder or root directory. Here's an example of a suitable server folder if you're running IIS or PWS on your hard disk:

C:\Inetpub\wwwroot\myapp\

Verify that the Web URL box specifies a URL that corresponds (maps) to the server folder. For example, if PWS or IIS is running on your local computer, then the following remote folders have the following Web URLs:

<table>
<thead>
<tr>
<th>Remote folder</th>
<th>Web URL</th>
</tr>
</thead>
<tbody>
<tr>
<td>C:\Inetpub\wwwroot\</td>
<td><a href="http://localhost/">http://localhost/</a></td>
</tr>
<tr>
<td>C:\Inetpub\wwwroot\myapp\</td>
<td><a href="http://localhost/myapp/">http://localhost/myapp/</a></td>
</tr>
<tr>
<td>C:\Inetpub\wwwroot\fs\planes</td>
<td><a href="http://localhost/fs/planes">http://localhost/fs/planes</a></td>
</tr>
</tbody>
</table>

**More Help topics**

“Switch between views in the Document window” on page 17

“Preview pages in Live view” on page 276

“Previewing dynamic pages in a browser” on page 533

**Adding custom server behaviors**

**About custom server behaviors**

Dreamweaver comes with a set of built-in server behaviors that lets you easily add dynamic capabilities to a site. You can extend the Dreamweaver functionality by creating server behaviors to suit your development needs, or by obtaining server behaviors from the Dreamweaver Exchange website.

Before creating your own server behaviors, you should check the Dreamweaver Exchange website to see if another party has already created a server behavior that supplies the functionality you’d like to add to your website. Often, a third-party developer has created and tested a server behavior that will address your needs.

**Access Dreamweaver Exchange**

1. In Dreamweaver, access Dreamweaver Exchange in one of these ways:
   - Select Help > Dreamweaver Exchange.
   - Select Window > Server Behaviors, click the Plus (+) button, and select Get More Server Behaviors.
   The Dreamweaver Exchange web page opens in your browser.

2. Log on to the Exchange using your Adobe ID

3. , or, if you have not yet created a Dreamweaver Exchange ID for yourself, follow the instructions to open an Adobe account.

**Install a server behavior or other extension in Dreamweaver**

1. Start the Extension Manager by selecting Commands > Manage Extensions.

2. Select File > Install Package in the Extension Manager.
For more information, see *Using the Extension Manager*.

**Custom server behaviors workflow**

If you are a web developer proficient in ColdFusion, JavaScript, VBScript, or PHP, you can write your own server behaviors. The steps to create a server behavior include the following tasks:

- Write one or more code blocks that perform the required action.
- Specify where the code block should be inserted within the page’s HTML code.
- If the server behavior requires that a value be specified for a parameter, create a dialog box that prompts the web developer applying the behavior to supply an appropriate value.
- Test the server behavior before making it available to others.

**More Help topics**

“Request a parameter for the server behavior” on page 579

“Testing server behaviors” on page 582

**Use the Server Behavior Builder**

Use the Server Behavior Builder to add the code block or blocks that the behavior inserts into a page.

1. In the Server Behaviors panel (Window > Server Behaviors), click the Plus (+) button, and select New Server Behavior.
2. From the Document Type pop-up menu, select the document type that you are developing the server behavior for.
3. In the Name box, enter a name for the server behavior.
4. (Optional) To copy an existing server behavior to add to the behavior you are creating, select the Copy Existing Server Behavior option, and then select the server behavior in the Behavior to Copy pop-up menu. Click OK.

The Server Behavior Builder dialog box is displayed.

5. To add a new code block, click the Plus (+) button, enter a name for the code block, and click OK.

The name you enter appears in the Server Behavior Builder, with the appropriate scripting tags visible in the Code Block box.

6. In the Code Block box, enter the run-time code necessary to implement the server behavior.

*Note: When entering code in the Code Block box, you can only insert a single tag or code block for each named code block (for example, myBehavior_block1, myBehavior_block2, myBehavior_blockn, etc.). If you have to enter multiple tags or code blocks, create an individual code block for each one. You can also copy and paste code from other pages.*

7. Place the insertion point in the code block where you’d like to insert the parameter, or select a string to replace with a parameter.

8. Click the Insert Parameters in Code Block button.

9. Enter a name for the parameter in the Parameter Name box (for example, Session), and click OK.

The parameter is inserted into the code block at the location where you placed the insertion point prior to defining the parameter. If you selected a string, every instance of the selected string in the code block is replaced with a parameter marker (for example, @@Session@@).

10. Select an option from the Insert Code pop-up menu specifying where to embed the code blocks.
11 (Optional) To specify additional information about the server behavior, click the Advanced button.

12 To create more code blocks, repeat steps 5 through 11.

13 If the server behavior requires that parameters be supplied to it, you must create a dialog box that accepts parameters from the person applying the behavior. See the link below.

14 After you perform the required steps to create the server behavior, click OK.

The Server Behaviors panel lists the server behavior.

15 Test the server behavior and ensure that it functions properly.

More Help topics
“Repeating code blocks with the loop directive” on page 577
“Coding guidelines” on page 581
“Request a parameter for the server behavior” on page 579
“Adding custom server behaviors” on page 572

Advanced options
After you specify the source code and insert location for each code block, the server behavior is completely defined. In most cases, you don’t need to specify any additional information.

If you are an advanced user, you can set any of the following options:

Identifier Specifies whether the code block should be treated as an identifier.

By default, every code block is an identifier. If Dreamweaver finds an identifier code block anywhere in a document, it lists the behavior in the Server Behaviors panel. Use the Identifier option to specify whether the code block should be treated as an identifier.

At least one of the server behavior’s code blocks must be an identifier. A code block should not be an identifier if one of the following conditions applies: the same code block is used by some other server behavior; or the code block is so simple that it might occur naturally on the page.

Server Behavior Title Specifies the title of the behavior in the Server Behaviors panel.

When the page designer clicks the Plus (+) button on the Server Behaviors panel, the new server behavior’s title will appear in the pop-up menu. When a designer applies an instance of a server behavior to a document, the behavior appears in the list of applied behaviors in the Server Behaviors panel. Use the Server Behavior Title box to specify the contents of the Plus (+) pop-up menu and the list of applied behaviors.

The initial value in the box is the name you supplied in the New Server Behavior dialog box. As parameters are defined, the name is automatically updated so that the parameters appear inside parentheses after the server behavior name.

Set Session Variable (@@Name@@, @@Value@@)

If the user accepts the default value, everything before the parentheses appears in the Plus (+) pop-up menu (for example, Set Session Variable). The name plus the parameters will appear in the list of applied behaviors—for example, Set Session Variable (“abcd”, “5”).

Code Block to Select Specifies what code block is selected when the user selects the behavior in the Server Behaviors panel.

When you apply a server behavior, one of the code blocks within the behavior is designated the “code block to select.” If you apply the server behavior and then select the behavior in the Server Behaviors panel, the designated block is selected in the Document window. By default, Dreamweaver selects the first code block that is not above the html tag.
If all the code blocks are above the `html` tag, then the first one is selected. Advanced users can specify which code block is the selected one.

**Creating code blocks**

The code blocks you create in the Server Behavior Builder are encapsulated in a server behavior that appears in the Server Behaviors panel. The code can be any valid run-time code for the specified server model. For example, if you choose ColdFusion as the document type for your custom server behavior, the code you write must be valid ColdFusion code that runs on a ColdFusion application server.

You can create the code blocks either directly in the Server Behavior Builder, or you can copy and paste the code from other sources. Each code block you create in the Server Behavior Builder must be a single tag or script block. If you must insert multiple tag blocks, split them into separate code blocks.

**Conditions in code blocks**

Dreamweaver lets you develop code blocks that incorporate control statements that execute conditionally. The Server Behavior Builder uses `if`, `elseif`, and `else` statements, and may also contain server behavior parameters. This enables you to insert alternate text blocks based on the values of OR relationships among server behavior parameters.

The following example shows the `if`, `elseif`, and `else` statements. The square brackets ([ ]) denote optional code and the asterisk (*) denotes zero or more instances. To execute a portion of a code block or the entire code block only if a certain condition or conditions apply, use the following syntax:

```xml
<@ if (expression1) @>conditional text1[@ elseif (expression2) @>conditional text2]*[@ else @>
    conditional text3</@ endif @>
```

Condition expressions can be any JavaScript expression that can be evaluated using the JavaScript `eval()` function, and may include a server behavior parameter marked by @@’s. (The @@’s distinguish the parameter from JavaScript variables and keywords.)

**Effectively using conditional expressions**

When using `if`, `else`, and `elseif` directives within the `insertText` XML tag, the participant text is preprocessed to resolve the `if` directives and to determine which text to include in the result. The `if` and `elseif` directives take the expression as an argument. The condition expression is the same as that for JavaScript condition expressions, and can also contain server behavior parameters. Directives such as this allow you to choose between alternative code blocks based on the values of, or relationships between, server behavior parameters.

For example, the following JSP code comes from a Dreamweaver server behavior that uses a conditional code block:

```jsp
@@rsName@@.close();
@@ if (@callbableName@@ != '') @@
@@callbableName@@.execute();
@@rsName@@ = @@callbableName@@.getResultSet();@@ else @@
@@rsName@@ = Statement@@rsName@@.executeQuery();
@@ endif @@
@@rsName@@_hasData = @@rsName@@.next();
```

The conditional code block starts with `@@ if (@callbableName@@ != '') @@` and ends with `@@ endif @@`. According to the code, if the user enters a value for the `@callbableName@@` parameter in the server behavior’s Parameter dialog box—in other words, if the `@callbableName@@` parameter value is not null, or `(@callbableName@@ != '')`—then the conditional code block is replaced with the following statements:

```jsp
@callbableName@@.execute();
@@rsName@@ = @@callbableName@@.getResultSet();
```
Otherwise, the code block is replaced with the following statement:

```java
@@rsName@@ = Statement@@rsName@@.executeQuery();
```

**More Help topics**

“Repeating code blocks with the loop directive” on page 577

---

**Positioning a code block**

When you create code blocks using the Server Behavior Builder, you must specify where to insert them in the page’s HTML code.

For example, if you insert a code block above the opening `<html>` tag, you must then specify the code block’s position relative to other tags, scripts, and server behaviors in that section of the page’s HTML code. Typical examples include positioning a behavior either before or after any recordset queries that might also exist in the page code above the opening `<html>` tag.

When you select a positioning option from the Insert Code pop-up menu, the options available in the Relative Position pop-up menu change to provide relevant options for that part of the page. For example, if you select Above The `<html>` Tag In The Insert Code pop-up menu, the positioning options available in the Relative Position pop-up menu reflect choices relevant for that part of the page.

The following table shows the code block insert options, and the relative positioning options available for each:

<table>
<thead>
<tr>
<th>Insert Code options</th>
<th>Relative position options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Above the <code>&lt;html&gt;</code> Tag</td>
<td>• At the beginning of the file</td>
</tr>
<tr>
<td></td>
<td>• Just before the recordsets</td>
</tr>
<tr>
<td></td>
<td>• Just after the recordsets</td>
</tr>
<tr>
<td></td>
<td>• Just above the <code>&lt;html&gt;</code> tag</td>
</tr>
<tr>
<td></td>
<td>• Custom position</td>
</tr>
<tr>
<td>Below the <code>&lt;/html&gt;</code> Tag</td>
<td>• Before the end of the file</td>
</tr>
<tr>
<td></td>
<td>• Before the recordset close</td>
</tr>
<tr>
<td></td>
<td>• After the recordset close</td>
</tr>
<tr>
<td></td>
<td>• After the <code>&lt;/html&gt;</code> tag</td>
</tr>
<tr>
<td></td>
<td>• Custom position</td>
</tr>
<tr>
<td>Relative to a Specific Tag</td>
<td>Select a tag from the Tag pop-up menu, and then choose from the tag positioning options.</td>
</tr>
<tr>
<td>Relative to the Selection</td>
<td>Before the selection</td>
</tr>
<tr>
<td></td>
<td>After the selection</td>
</tr>
<tr>
<td></td>
<td>Replace the selection</td>
</tr>
<tr>
<td></td>
<td>Wrap the selection</td>
</tr>
</tbody>
</table>

To specify a custom position, you must assign a weight to the code block. Use the Custom Position option when you need to insert more than one code block in a particular order. For example, to insert an ordered series of three code blocks after the code blocks that open recordsets, you would enter a weight of 60 for the first block, 65 for the second, and 70 for the third.
By default, Dreamweaver assigns a weight of 50 to all recordset-opening code blocks inserted above the `<html>` tag. If the weight of two or more blocks match, Dreamweaver randomly sets the order among the blocks.

**More Help topics**

“Request a parameter for the server behavior” on page 579

“Coding guidelines” on page 581

“About custom server behaviors” on page 572

“Creating code blocks” on page 575

“Testing server behaviors” on page 582

**Position a code block (general instructions)**

1. Using the Server Behavior Builder, write a code block.
2. In the Server Behavior Builder dialog box, select a position in which to insert the code block from the Insert Code pop-up menu.
3. In the Server Behavior Builder dialog box, select a position relative to that which you selected in the Insert Code pop-up menu.
4. If you complete the authoring of the code block, click OK.

The server behavior is listed in the Server Behaviors panel (Window > Server Behavior); click the Plus (+) button to view the server behavior.

5. Test the server behavior and ensure that it functions properly.

**Position a code block relative to another tag on the page**

1. In the Insert Code pop-up menu, select Relative To A Specific Tag.
2. In the Tag box, enter the tag or select one from the pop-up menu.

If you enter a tag, don’t include the angled brackets (`<>`).

3. Specify a location relative to the tag by choosing an option in the Relative Position pop-up menu.

**Position a code block relative to a tag selected by the page designer**

1. In the Insert Code pop-up menu, select Relative To The Selection.
2. Specify a location relative to the selection by choosing an option in the Relative Position pop-up menu.

You can insert your code block just before or just after the selection. You can also replace the selection with your code block, or you can wrap the code block around the selection.

To wrap the code block around a selection, the selection must consist of an opening and closing tag with nothing in between, as follows:

```
<CFIF Day="Monday"></CFIF>
```

Insert the opening tag piece of the code block before the selection’s opening tag and the closing tag piece of the code block after the selection’s closing tag.

**Repeating code blocks with the loop directive**

To repeat a portion of a code block or the entire code block a number of times, use the following syntax:
When creating server behaviors, you can use looping constructs to repeat a code block a specified number of times.

```
<@ loop (@@param1@@,@@param2@@) @>code block<@ endloop @>
```

The loop directive accepts a comma-separated list of parameter arrays as arguments. In this case, parameter array arguments allow a user to supply multiple values for a single parameter. The repeating text is duplicated \( n \) times, where \( n \) is the length of the parameter array arguments. If more than one parameter array argument is specified, all the arrays must have the same length. On the \( i \)th evaluation of the loop, the \( i \)th elements of the parameter arrays replace the associated parameter instances in the code block.

When you create a dialog box for the server behavior, you can add a control to the dialog box that lets the page designer create parameter arrays. Dreamweaver includes a simple array control that you can use to create dialog boxes. This control, called Text Field Comma Separated List, is available through the Server Behavior Builder. To create user interface elements of greater complexity, see the API documentation to create a dialog box with a control to create arrays (a grid control, for example).

You can nest any number of conditionals or a loop directive within a conditional directive. For example, you can specify that if an expression is true to execute a loop.

The following example shows how such repeating code blocks can be used to create server behaviors (the example is a ColdFusion behavior used to access a stored procedure):

```
<CFSTOREDPROC procedure="AddNewBook"
    datasource=#MM_connection_DSN#
    username=#MM_connection_USERNAME#
    password=#MM_connection_PASSWORD#>
<CFPROCPARAM type="IN" dbvarname="@CategoryId" value="#Form.CategoryID#"
    cfsqltype="CF_SQL_INTEGER"> 
<CFPROCPARAM type="IN" dbvarname="@ISBN" value="#Form.ISBN#"
    cfsqltype="CF_SQL_VARCHAR">
</CFSTOREDPROC>
```

In this example, the `CFSTOREDPROC` tag can include zero or more `CFPROCPARAM` tags. However, without support for the loop directive, there is no way to include the `CFPROCPARAM` tags within the inserted `CFSTOREDPROC` tag. If this were to be created as a server behavior without the use of the loop directive, you would need to divide this example into two participants: a main `CFSTOREDPROC` tag, and a `CFPROCPARAM` tag whose participant type is multiple.

Using the loop directive, you can write the same procedure as follows:

```
<CFSTOREDPROC procedure="@@procedure@@"
    datasource=#MM_@@conn@@_DSN#
    username=#MM_@@conn@@_USERNAME#
    password=#MM_@@conn@@_PASSWORD#>
<@ loop (@@paramName@@,@@value@@,@@type@@) @>
    <CFPROCPARAM type="IN"
        dbvarname="@@paramName@@"
        value="@@value@@"
        cfsqltype="@@type@@"> 
<@ endloop @>
</CFSTOREDPROC>
```

**Note:** New lines after each `"@>` are ignored.

If the user entered the following parameter values in the Server Behavior Builder dialog box:
procedure = "proc1"
conn = "connection1"
paramName = ["@CategoryId", "@Year", "@ISBN"]
value = ["#Form.CategoryId#", "#Form.Year#", "#Form.ISBN#"]
type = ["CF_SQL_INTEGER", "CF_SQL_INTEGER", "CF_SQL_VARCHAR"]

The server behavior would insert the following run-time code in the page:

```cfml
<CFSTOREDPROC procedure="proc1"
    datasource=#MM_connection1_DSN#
    username=#MM_connection1_USERNAME#
    password=#MM_connection1_PASSWORD#>
    <CFPROCPARAM type="IN" dbvarname="@CategoryId" value="#Form.CategoryId#"
        cfsqltype="CF_SQL_INTEGER">
    <CFPROCPARAM type="IN" dbvarname="@Year" value="#Form.Year#"
        cfsqltype="CF_SQL_INTEGER">
    <CFPROCPARAM type="IN" dbvarname="@ISBN" value="#Form.ISBN#"
        cfsqltype="CF_SQL_VARCHAR">
</CFSTOREDPROC>
```

*Note: Parameter arrays cannot be used outside of a loop except as part of a conditional directive expression.*

**Using the loop directive’s _length and _index variables**

The loop directive includes two built-in variables that you can use for embedded if conditions. The variables are: _length and _index. The _length variable evaluates to the length of the arrays processed by the loop directive, while the _index variable evaluates to the current index of the loop directive. To ensure that the variables are only recognized as directives, and not as actual parameters to be passed into the loop, do not enclose either variable in @@s.

An example of using built-in variables is to apply them to the import attribute of the page directive. The import attribute requires comma separation of packages. If the loop directive extends around the entire import attribute, you would only output the attribute name import= on the first iteration of the loop—this includes the closing double quote (”)—and not output a comma on the last iteration of the loop. Using the built-in variable, you can express this as follows:

```cfml
<@loop (@@Import@@)@>
    <@ if (_index == 0)@>import=""<@endif@>
    @@Import@@<@if (_index == _length-1)@>"<@else@>,
    <@ endif @>
    <@endloop@>
```

**Request a parameter for the server behavior**

Server behaviors often require that the page designer supply a parameter value. This value must be inserted before the server behavior’s code is inserted into the page.

You create the dialog box by defining the designer-supplied parameters in the code. Then you generate a dialog box for the server behavior, which prompts the page designer for a parameter value.

*Note: A parameter is added to your code block without your intervention if you specify that your code should be inserted relative to a specific tag chosen by the page designer (that is, you chose Relative to a Specific Tag in the Insert Code pop-up menu). The parameter adds a tag menu to the behavior’s dialog box to let the page designer select a tag.*

**Define the parameter in the server behavior code**

1. Enter a parameter marker in the code where you want to insert the supplied parameter value. The parameter has the following syntax:
Enclose the `formParam` string in parameter markers (`@@`):

```jsp
<% Session("lang_pref") = Request.Form("@@formParam@@"); %>
```

For example, if the server behavior contains the following code block:

```jsp
<% Session("lang_pref") = Request.Form("Form_Object_Name"); %>
```

To require the page designer to supply the value of `Form_Object_Name`, enclose the string in parameter markers (`@@`):

```jsp
<% Session("lang_pref") = Request.Form("@@Form_Object_Name@@"); %>
```

You can also highlight the string and click the Insert Parameter In Code Block button. Enter a parameter name and click OK. Dreamweaver replaces every instance of the highlighted string with the specified parameter name enclosed in parameter markers.

Dreamweaver uses the strings that you enclose in parameter markers to label the controls in the dialog box it generates (see the following procedure). In the previous example, Dreamweaver creates a dialog box with the following label:

![Insert Parameter In Code Block](image)

**Note:** Parameter names in the server behavior code cannot have any spaces. Therefore, the dialog box labels cannot have any spaces. If you want to include spaces in the label, you can edit the generated HTML file.

### Create a dialog box for your server behavior to request the parameter value

1. In the Server Behavior Builder, click Next.
2. To change the display order of the dialog box controls, select a parameter and click the up and down arrows.
3. To change a parameter’s control, select the parameter and select another control in the Display As column.
4. Click OK.

Dreamweaver generates a dialog box with a labeled control for each designer-supplied parameter that you defined.

### View the dialog box

1. Click the Plus (+) button in the Server Behaviors panel (Window > Server Behaviors), and select your custom server behavior from the pop-up menu.

### Edit the dialog box you created for the server behavior

1. In the Server Behaviors panel (Window > Server Behaviors), click the Plus (+) button, and select Edit Server Behaviors from the pop-up menu.
2. Select your server behavior from the list, and click Open.
3. Click Next.

A dialog box appears listing all the designer-supplied parameters that you defined in your code.

4. To change the display order of the dialog box controls, select a parameter and click the up and down arrows.
5. To change a parameter’s control, select the parameter and select another control in the Display As column.
6 Click OK.

**Edit and modify server behaviors**

You can edit any server behavior created with the Server Behavior Builder, including server behaviors you download from the Dreamweaver Exchange website, and other third-party developers.

If you apply a server behavior to a page and then edit the behavior in Dreamweaver, instances of the old behavior no longer appear in the Server Behaviors panel. The Server Behaviors panel searches the page for code that matches the code of known server behaviors. If the code of a server behavior changes, the panel does not recognize earlier versions of the behavior on that page.

**More Help topics**

“Use the Server Behavior Builder” on page 573

“Positioning a code block” on page 576

**Retain the old and new versions of the behavior in the panel**

- Click the Plus (+) button on the Server Behaviors panel (Window > Server Behaviors), select New Server Behavior, and create a copy of the old server behavior.

**Edit the code of a server behavior created with the Server Behavior Builder**

1 In the Server Behaviors panel (Window > Server Behaviors), click the Plus (+) button and select Edit Server Behaviors from the pop-up menu.

The Edit Server Behaviors dialog box displays all the behaviors for the current server technology.

2 Select the server behavior and click Edit.

3 Select the appropriate code block and modify the code, the parameter marks, or the position of the code block to be inserted in pages.

4 If the modified code does not contain any designer-supplied parameters, click OK.

Dreamweaver regenerates the server behavior without a dialog box. The new server behavior appears in the Plus (+) pop-up menu of the Server Behaviors panel.

5 If the modified code does contain designer-supplied parameters, click Next.

Dreamweaver asks you whether you want to create a new dialog box, overwriting the old one. Make your changes and click OK.

Dreamweaver saves all changes in the server behavior’s EDML file.

**Coding guidelines**

In general, your server behavior’s code should be compact and robust. Web application developers are very sensitive to the code added to their pages. Follow generally accepted coding practices for the document type’s language (ColdFusion, JavaScript, VBScript, or PHP). When writing comments, consider the different technical audiences that might need to understand the code, such as web and interaction designers, or other web application developers. Include comments that accurately describe the purpose of the code, and any special instructions for including it within a page.

Last updated 12/7/2011
Keep in mind the following coding guidelines when you create server behaviors:

**Error checking**  An important requirement. The server behavior’s code should handle error cases gracefully. Try to foresee every possibility. For example, what if a parameter request fails? What if no records are returned from a query?

**Unique names**  Help to ensure that your code is clearly identifiable and avoids name collisions with existing code. For example, if the page contains a function called `hideLayer()` and a global variable called `ERROR_STRING`, and your server behavior inserts code that uses those names too, the server behavior may conflict with the existing code.

**Code prefixes**  Allow you to identify your own run-time functions and global variables in a page. One convention is to use your initials. Never use the `MM_` prefix, as it is reserved for Dreamweaver use only. Dreamweaver precedes all functions and global variables with the prefix `MM_` to prevent them from conflicting with any code that you write.

```javascript
var MM_ERROR_STRING = "...";
function MM_hideLayer() {

```

**Avoid similar code blocks**  so that the code you write doesn’t resemble too closely the code in other blocks. If a code block looks too much like another code block on the page, the Server Behaviors panel might mistakenly identify the first code block as an instance of the second code block (or conversely). A simple solution is to add a comment to a code block to make it more unique.

**More Help topics**

“About custom server behaviors” on page 572

“Custom server behaviors workflow” on page 573

**Testing server behaviors**

The Dreamweaver Exchange recommends performing the following tests on each server behavior you create:

- Apply the behavior from the Server Behaviors panel. If it has a dialog box, enter valid data in each field and click OK. Verify that no error occurs when the behavior is applied. Verify that the run-time code for the server behavior appears in the Code inspector.

- Apply the server behavior again and enter invalid data in each field of the dialog box. Try leaving the field blank, using large or negative numbers, using invalid characters (such as /, ?, :, *, and so on), and using letters in numeric fields. You can write form validation routines to handle invalid data (validation routines involve hand-coding, which is beyond the scope of this book).

After successfully applying your server behavior to the page, verify the following:

- Check the Server Behaviors panel to make sure the name of the server behavior appears in the list of behaviors added to the page.

- If applicable, verify that server-side script icons show up on the page. The generic server-side script icons are gold shields. To see the icons, enable Invisible Elements (View > Visual Aids > Invisible Elements).

- In Code view (View > Code), verify that no invalid code is generated.

In addition, if your server behavior inserts code in the document establishing a connection to a database, create a test database to test the code inserted in the document. Verify the connection by defining queries that produce different sets of data, and different sizes of data sets.

Finally, upload the page to the server and open it in a browser. View the page’s HTML source code and verify that no invalid HTML has been generated by the server-side scripts.
Chapter 21: Building applications visually

In Adobe® Dreamweaver® CS5, you can use Adobe ColdFusion, PHP, or ASP to build pages that let you search, insert, delete, and update database records, display master and detail information, and restrict access to certain users.

Building master and detail pages

About master and detail pages

Master and detail pages are sets of pages used to organize and display recordset data. These pages provide a visitor to your site with both an overview and a detailed view. The master page lists all of the records and contains links to detail pages that display additional information about each record.
You can build master and detail pages by inserting a data object to create a master page and detail page in one operation or by using server behaviors to build the master and detail pages in a more customized way. When using server behaviors to build master and detail pages, you first create a master page to list the records and then add links from the list to the detail pages.

**More Help topics**

“About search and results pages” on page 590

**Build a master page**

Before you start, ensure that you define a database connection for your site.

1. To create a blank page, select File > New > Blank Page, select a page type, and click Create. This page becomes the master page.

2. Define a recordset.

   In the Bindings panel (Windows > Bindings), click the Plus (+) button, select Recordset, and choose options. If you want to write your own SQL statement, click Advanced.

   Ensure that the recordset contains all the table columns you need to create your master page. The recordset must also include the table column containing the unique key of each record—that is, the record ID column. In the following example, the Code column contains the unique key of each record.
Typically, the recordset on the master page extracts a few columns from a database table while the recordset on the detail page extracts more columns from the same table to provide the extra detail.

The recordset can be defined by the user at run time. For more information, see “Building search and results pages” on page 590.

3 Insert a dynamic table to display the records.

Place the insertion point where you want the dynamic table to appear on the page. Select Insert > Data Objects > Dynamic Data > Dynamic Table, set the options, and click OK.

If you don’t want to show record IDs to users, you can delete the column from the dynamic table. Click anywhere on the page to move the focus to the page. Move the cursor near the top of the column in the dynamic table until the column cells are outlined in red, and then click to select the column. Press Delete to delete the column from the table.

More Help topics

“Define a recordset without writing SQL” on page 543

“Define an advanced recordset by writing SQL” on page 545

“Create a dynamic table” on page 567

Create links to the detail page

After building the master page and adding the recordset, you create links that open the detail page. You then modify the links to pass the IDs of the records the user selects. The detail page uses this ID to find the requested record in the database and display it.

Note: You create links to update pages using the same process. The results page is similar to a master page, and the update page is similar to a detail page.

More Help topics

“Building an update record page” on page 599
Open the detail page and pass a record ID (ColdFusion, PHP)

1. In the dynamic table, select the content placeholder for text that will serve as a link.

2. In the Property inspector, click the folder icon beside the Link box.

3. Browse and select the detail page. The detail page appears in the Link box in the Property inspector.

4. On the master page, select the link in the dynamic table.

5. (ColdFusion) In the Link box in the Property inspector, add the following string at the end of the URL:

   `?recordID=#recordsetName.fieldName#`

   The question mark tells the server that what follows is one or more URL parameters. The word recordID is the name of the URL parameter (you can make up any name you like). Make a note of the name of the URL parameter because you’ll use it in the detail page later.

   The expression after the equal sign is the value of the parameter. In this case, the value is generated by a ColdFusion expression that returns a record ID from the recordset. A different ID is generated for each row in the dynamic table.

   In the ColdFusion expression, replace recordsetName with the name of your recordset, and replace fieldName with the name of the field in your recordset that uniquely identifies each record. In most cases, the field will consist of a record ID number. In the following example, the field consists of unique location codes.

   `locationDetail.cfm?recordID=#rsLocations.CODE#`

   When the page runs, the values of the recordset’s CODE field are inserted in the corresponding rows in the dynamic table. For example, if the Canberra, Australia, rental location has the code CBR, the following URL is used in the Canberra row in the dynamic table:

   `locationDetail.cfm?recordID=CBR`

6. (PHP) In the Link field in the Property inspector, add the following string at the end of the URL:

   `?recordID=<?php echo $row_recordsetName['fieldName']; ?>`

   The question mark tells the server that what follows is one or more URL parameters. The word recordID is the name of the URL parameter (you can use any name you like). Make a note of the name of the URL parameter because you’ll use it in the detail page later.

   The expression after the equal sign is the value of the parameter. In this case, the value is generated by a PHP expression that returns a record ID from the recordset. A different ID is generated for each row in the dynamic table. In the PHP expression, replace recordsetName with the name of your recordset, and replace fieldName with the name of the field in your recordset that uniquely identifies each record. In most cases, the field will consist of a record ID number. In the following example, the field consists of unique location codes.

   `locationDetail.php?recordID=<?php echo $row_rsLocations['CODE']; ?>`
When the page runs, the values of the recordset’s CODE field are inserted in the corresponding rows in the dynamic table. For example, if the Canberra, Australia, rental location has the code CBR, the following URL is used in the Canberra row in the dynamic table:

`locationDetail.php?recordID=CBR`

7 Save the page.

**Open the detail page and pass a record ID (ASP)**

1 Select the dynamic content to double as a link.

2 In the Server Behaviors panel (Window > Server Behaviors), click the Plus (+) button, and select Go to Detail Page from the pop-up menu.

3 In the Detail Page box, click Browse and locate the page.

4 Specify the value you want to pass to the detail page by selecting a recordset and a column from the Recordset and Column pop-up menus. Typically the value is unique to the record, such as the record’s unique key ID.

5 If desired, pass existing page parameters to the detail page by selecting the URL Parameters or Form Parameters options.

6 Click OK.

A special link surrounds the selected text. When the user clicks the link, the Go To Detail Page server behavior passes a URL parameter containing the record ID to the detail page. For example, if the URL parameter is called id and the detail page is called customerdetail.asp, the URL looks something like the following when the user clicks on the link:

```
http://www.mysite.com/customerdetail.asp?id=43
```

The first part of the URL, `http://www.mysite.com/customerdetail.asp`, opens the detail page. The second part, `?id=43`, is the URL parameter. It tells the detail page what record to find and display. The term id is the name of the URL parameter and 43 is its value. In this example, the URL parameter contains the record’s ID number, 43.

**Find and display the requested record on the detail page**

In order to display the record requested by the master page, you must define a recordset to hold a single record and bind the recordset columns to the detail page.

1 Switch to the detail page. If you don’t have a detail page yet, create a blank page (File > New).

2 In the Bindings panel (Window > Bindings), click the Plus (+) button and select Recordset (Query) or DataSet (Query) from the pop-up menu.

The simple Recordset or DataSet dialog box appears. If the advanced dialog box appears instead, click Simple.

3 Name the recordset, and select a data source and the database table that will provide data to your recordset.

4 In the Columns area, select the table columns to include in the recordset.

The recordset can be identical to or different from the recordset on the master page. Usually a detail page recordset has more columns to display more detail.

If the recordsets are different, make sure the recordset on the detail page contains at least one column in common with the recordset on the master page. The common column is usually the record ID column, but it can also be the join field of related tables.

To include only some of the table’s columns in the recordset, click Selected and choose the desired columns by Control-clicking (Windows) or Command-clicking (Macintosh) them in the list.
5 Complete the Filter section as to find and display the record specified in the URL parameter passed by the master page:

- From the first pop-up menu in the Filter area, select the column in the recordset containing values that match the value of the URL parameter passed by the master page. For example, if the URL parameter contains a record ID number, select the column containing record ID numbers. In the example discussed in the previous section, the recordset column called CODE contains the values that match the value of the URL parameter passed by the master page.
- From the pop-up menu beside the first menu, select the equal sign (it should already be selected).
- From the third pop-up menu, select URL Parameter. The master page uses a URL parameter to pass information to the detail page.
- In the fourth box, enter the name of the URL parameter passed by the master page.
6 Click OK. The recordset appears in the Bindings panel.
7 Bind the recordset columns to the detail page by selecting the columns in the Bindings panel (Window > Bindings) and dragging them onto the page.

After uploading both the master and detail pages to the server, you can open the master page in a browser. After clicking a detail link on the master page, the detail page opens with more information about the selected record.

More Help topics
“Set up a testing server” on page 45

Find a specific record and display it on a page (ASP)
You can add a server behavior that finds a specific record in a recordset so that you can display the record data on the page. The server behavior is only available when using the ASP server model.

1 Create a page that has the following prerequisites:
   - A record ID contained in a URL parameter passed by another page to the current page. You can create URL parameters on the other page with HTML hyperlinks or with an HTML form. For more information, see “Using forms to collect information from users” on page 630.
   - A recordset defined for the current page. The server behavior extracts the record details from this recordset. For instructions, see “Define a recordset without writing SQL” on page 543 or “Define an advanced recordset by writing SQL” on page 545.
   - Recordset columns bound to the page. The specific record must be displayed on the page. For more information, see “Make text dynamic” on page 557.
2 Add the server behavior to find the record specified by the URL parameter by clicking the Plus (+) button on the Server Behaviors panel (Window > Server Behaviors) and selecting Recordset Paging > Move to Specific Record.
3 In the Move To Record In pop-up menu, select the recordset you defined for the page.
4 In the Where Column pop-up menu, select the column that contains the value passed by the other page. For example, if the other page passes a record ID number, select the column containing record ID numbers.
5 In the Matches URL Parameter box, enter the name of the URL parameter passed by the other page. For example, if the URL the other page used to open the detail page is id=43, enter id in the Matches URL Parameter box.
6 Click OK.

The next time the page is requested by a browser, the server behavior will read the record ID in the URL parameter passed by the other page and move to the specified record in the recordset.
Build master and detail pages in one operation

When developing web applications, you can quickly build master and detail pages using the Master Detail Page Set data object.

1. To create a blank dynamic page, select File > New > Blank Page, select a dynamic page from the Page Type list, and click Create. This page becomes the master page.

2. Define a recordset for the page. Make sure the recordset contains not only all the columns you’ll need for the master page, but also all the columns you’ll need for the detail page. Typically, the recordset on the master page extracts a few columns from a database table while the recordset on the detail page extracts more columns from the same table to provide the extra detail.

3. Open the master page in Design view, and select Insert > Data Objects > Master Detail Page Set.

4. In the Recordset pop-up menu, make sure the recordset containing the records you want to display on the master page is chosen.

5. In the Master Page Fields area, select the recordset columns to display on the master page. By default, all the columns in the recordset are selected. If your recordset contains a unique key column such as `recordID`, select it and click the Minus (-) button so that it is not displayed on your page.

6. To change the order in which the columns appear on the master page, select a column in the list and click the up or down arrow. On the master page, the recordset columns will be arranged horizontally in a table. Clicking the up arrow moves the column to the left; clicking the down arrow moves the column to the right.

7. In the Link To Detail From pop-up menu, select the column in the recordset that will display a value that also serves as a link to the detail page.

   For example, if you want each product name on your master page to have a link to the detail page, select the recordset column containing product names.

8. In the Pass Unique Key pop-up menu, select the column in the recordset containing values identifying the records. Usually, the column chosen is the record ID number. This value is passed to the detail page so that it can identify the record chosen by the user.

9. Deselect the Numeric option if the unique key column is not numeric.

   **Note:** This option is selected by default; it does not appear for all server models.

10. Specify the number of records to display on the master page.

11. In the Detail Page Name box, click Browse and locate the detail page file you created, or enter a name and let the data object create one for you.

12. In the Detail Page Fields area, select the columns to be displayed on the detail page. By default, all the columns in the master page’s recordset are selected. If the recordset contains a unique key column such as `recordID`, select it and click the Minus (-) button so that it is not displayed on the detail page.

13. To change the order in which the columns appear on the detail page, select a column in the list and click the up or down arrow.

   On the detail page, the recordset columns are arranged vertically in a table. Clicking the up arrow moves the column up; clicking the down arrow moves the column down.

14. Click OK.
The data object creates a detail page (if you didn’t already create one) and adds dynamic content and server behaviors to both the master and detail pages.

15 Customize the layout of the master and detail pages to suit your needs.

You can fully customize the layout of each page by using the Dreamweaver page-design tools. You can also edit the server behaviors by double-clicking them in the Server Behaviors panel.

After creating master and detail pages with the data object, use the Server Behaviors panel (Window > Server Behaviors) to modify the various building blocks the data object inserts into the pages.

More Help topics
“Edit dynamic content” on page 560
“Defining sources of dynamic content” on page 543

Building search and results pages

About search and results pages
You can use Dreamweaver to build a set of pages to let users search your database and view the search results.

In most cases, you need at least two pages to add this feature to your web application. The first page is a page that contains an HTML form in which users enter search parameters. Although this page doesn’t do any actual searching, it is referred to as the search page.

The second page you need is the results page, which performs most of the work. The result’s page does the following tasks:

- Reads the search parameters submitted by the search page
- Connects to the database and searches for records
- Builds a recordset with the records found
- Displays the contents of the recordset

Optionally, you can add a detail page. A detail page gives users more information about a particular record on the results page.

If you have only one search parameter, Dreamweaver lets you add search capabilities to your web application without using SQL queries and variables. Simply design your pages and complete a few dialog boxes. If you have more than one search parameter, you need to write a SQL statement and define multiple variables for it.

Dreamweaver inserts the SQL query in your page. When the page runs on the server, each record in the database table is checked. If the specified field in a record meets your SQL query conditions, the record is included in a recordset. The SQL query in effect builds a recordset containing only the search results.

For example, field sales staff might have information about customers in a certain area who have incomes above a certain level. In a form on a search page, the sales associate enters a geographical area and a minimum income level, and then clicks the Submit button to send the two values to a server. On the server, the values are passed to the results page’s SQL statement, which then creates a recordset containing only customers in the specified area with incomes above the specified level.
Build the search page

A search page on the web typically contains form fields in which the user enters search parameters. At minimum, your search page must have an HTML form with a Submit button.

To add an HTML form to a search page, complete the following procedure.

1. Open the search page or a new page, and select Insert > Form > Form.

An empty form is created on the page. You might need to enable Invisible Elements (View > Visual Aids > Invisible Elements) to see the form’s boundaries, which are represented by thin red lines.

2. Add form objects for users to enter their search parameters by selecting Form from the Insert menu.

Form objects include text fields, menus, options, and radio buttons. You can add as many form objects as you want to help users refine their searches. However, keep in mind that the greater the number of search parameters on the search page, the more complex your SQL statement will be.

3. Add a Submit button to the form (Insert > Form > Button).

4. (Optional) Change the label of the Submit button by selecting the button, opening the Property inspector (Window > Properties), and entering a new value in the Value box.

Next, you’ll tell the form where to send the search parameters when the user clicks the Submit button.

5. Select the form by selecting the `<form>` tag in the tag selector at the bottom of the Document window, as the following image shows:

6. In the Action box in the form’s Property inspector, enter the filename of the results page that will conduct the database search.

7. In the Method pop-up menu, select one of the following methods to determine how the form sends data to the server:

   - GET sends the form data by appending it to the URL as a query string. Because URLs are limited to 8192 characters, don’t use the GET method with long forms.
   - POST sends the form data in the body of a message.
   - Default uses the browser’s default method (usually GET).

The search page is done.

More Help topics

“About search and results pages” on page 590

“Creating web forms” on page 633
Build a basic results page

When the user clicks the form's Search button, the search parameters are sent to a results page on the server. The results page on the server, not the search page on the browser, is responsible for retrieving records from the database. If the search page submits a single search parameter to the server, you can build the results page without SQL queries and variables. You create a basic recordset with a filter that excludes records that don’t meet the search parameter submitted by the search page.

**Note:** If you have more than one search condition, you must use the advanced Recordset dialog box to define your recordset (see "Build an advanced results page" on page 593).

More Help topics

“About search and results pages” on page 590

“Build the search page” on page 591

“Create a detail page for a results page” on page 595

Create the recordset to hold the search results

1. Open your results page in the Document window.

If you don’t have a results page yet, create a blank dynamic page (File > New > Blank Page).

2. Create a recordset by opening the Bindings panel (Window > Bindings), clicking the Plus (+) button, and selecting Recordset from the pop-up menu.

3. Make sure the simple Recordset dialog box appears.

4. Enter a name for the recordset, and select a connection.

The connection should be to a database containing data you want the user to search.

5. In the Table pop-up menu, select the table to be searched in the database.

**Note:** In a single-parameter search, you can search for records in only a single table. To search more than one table at a time, you must use the advanced Recordset dialog box and define a SQL query.
To include only some of the table's columns in the recordset, click Selected and select the desired columns by Control-clicking (Windows) or Command-clicking (Macintosh) them in the list.

You should include only the columns containing information you want to display on the results page.

Leave the Recordset dialog box open for now. You'll use it next to retrieve the parameters sent by the search page and create a recordset filter to exclude records that don't meet the parameters.

**Create the recordset filter**

1. From the first pop-up menu in the Filter area, select a column in the database table in which to search for a match. For example, if the value sent by the search page is a city name, select the column in your table that contains city names.

2. From the pop-up menu beside the first menu, select the equal sign (it should be the default).

3. From the third pop-up menu, select Form Variable if the form on your search page uses the **POST** method, or **URL Parameter** if it uses the **GET** method.

The search page uses either a form variable or a URL parameter to pass information to the results page.

4. In the fourth box, enter the name of the form object that accepts the search parameter on the search page.

The name of the object doubles as the name of the form variable or URL parameter. You can get the name by switching to the search page, clicking the form object on the form to select it, and checking the object's name in the Property inspector.

For example, suppose you want to create a recordset that includes only adventure trips to a specific country. Assume you have a column in the table called **TRIPLOCATION**. Also assume the HTML form on your search page uses the **GET** method and contains a menu object called Location that displays a list of countries. The following example shows how your Filter section should look:

5. (Optional) Click Test, enter a test value, and click OK to connect to the database and create an instance of the recordset.

The test value simulates the value that would otherwise have been returned from the search page. Click OK to close the test recordset.

6. If you’re satisfied with the recordset, click OK.

A server-side script is inserted on your page that checks each record in the database table when it runs on the server. If the specified field in a record meets the filtering condition, the record is included in a recordset. The script builds a recordset that contains only the search results.

The next step is to display the recordset on the results page. For more information, see “Display the search results” on page 595.

**Build an advanced results page**

If the search page submits more than one search parameter to the server, you must write a SQL query for the results page and use the search parameters in SQL variables.
Note: If you have only one search condition, you can use the simple Recordset dialog box to define your recordset (see “Build a basic results page” on page 592).

1. Open the results page in Dreamweaver, and then create a recordset by opening the Bindings panel (Window > Bindings), clicking the Plus (+) button, and selecting Recordset from the pop-up menu.

2. Make sure the advanced Recordset dialog box appears.

The advanced dialog box has a text area to enter SQL statements. If the simple dialog box appears instead, switch to the advanced dialog box by clicking the Advanced button.

3. Enter a name for the recordset, and select a connection.

The connection should be to a database containing data you want the user to search.

4. Enter a Select statement in the SQL text area.

Make sure the statement includes a WHERE clause with variables to hold the search parameters. In the following example, the variables are called `varLastName` and `varDept`:

```sql
SELECT EMPLOYEEID, FIRSTNAME, LASTNAME, DEPARTMENT, EXTENSION FROM EMPLOYEE ¬
WHERE LASTNAME LIKE 'varLastName' ¬
AND DEPARTMENT LIKE 'varDept'
```

To reduce the amount of typing, you can use the tree of database items at the bottom of the advanced Recordset dialog box. For instructions, see “Define an advanced recordset by writing SQL” on page 545.

For help on SQL syntax, see the SQL primer at www.adobe.com/go/learn_dw_sqlprimer.

5. Give the SQL variables the values of the search parameters by clicking the Plus (+) button in the Variables area and entering the variable's name, default value (the value the variable should take if no run-time value is returned), and run-time value (usually a server object holding a value sent by a browser, such as a request variable).

In the following ASP example, the HTML form on the search page uses the `GET` method and contains one text field called `LastName` and another called `Department`:

In ColdFusion, the run-time values would be `#LastName#` and `#Department#`. In PHP, the run-time values would be `$_REQUEST["LastName"]` and `$_REQUEST["Department"]`.

6. (Optional) Click Test to create an instance of the recordset using the default variable values.

The default values simulate the values that would otherwise have been returned from the search page. Click OK to close the test recordset.

7. If you're satisfied with the recordset, click OK.

The SQL query is inserted in your page.

The next step is to display the recordset on the results page.
Display the search results

After creating a recordset to hold the search results, you must display the information on the results page. Displaying the records can be a simple matter of dragging individual columns from the Bindings panel to the results page. You can add navigation links to move forward and backward through the recordset, or you can create a repeating region to display more than one record on the page. You can also add links to a detail page.

For more information on methods of displaying dynamic content on a page other than displaying results in a dynamic table, see “Displaying database records” on page 562.

1. Place the insertion point where you want the dynamic table to appear on the results page, and select Insert > Data Objects > Dynamic Data > Dynamic Table.
2. Complete the Dynamic Table dialog box, selecting the recordset you defined to hold the search results.
3. Click OK. A dynamic table that displays search results is inserted on the results page.

Create a detail page for a results page

Your set of search and results pages can include a detail page to display more information about specific records on the results page. In this situation, your results page also doubles as the master page in a master-detail page set.

More Help topics

“Build master and detail pages in one operation” on page 589
“Build the search page” on page 591
“Build a basic results page” on page 592

Create a link to open a related page (ASP)

You can create a link that opens a related page and that passes existing parameters to that page. The server behavior is only available when using the ASP server model.

Before adding a Go To Related Page server behavior to a page, make sure the page receives form or URL parameters from another page. The job of the server behavior is to pass these parameters to a third page. For example, you can pass search parameters received by a results page to another page and save the user from entering the search parameters again.

Also, you can select text or an image on the page to serve as the link to the related page, or you can position your pointer on the page without selecting anything, and the link text is inserted.

1. In the Go To Related Page box, click Browse and locate the related page file. If the current page submits data to itself, enter the current page’s file name.
2. If the parameters you want to pass were received directly from an HTML form using the GET method, or are listed in the page’s URL, select the URL Parameters option.
3. If the parameters you want to pass were received directly from an HTML form using the POST method, select the Form Parameters option.
4. Click OK.

When the new link is clicked, the page passes the parameters to the related page using a query string.

More Help topics

“Using forms to collect information from users” on page 630
Building a record insert page

About building record insert pages
Your application can contain a page that lets users insert new records in a database.

An insert page consists of two building blocks:

- An HTML form that lets users enter data
- An Insert Record server behavior that updates the database

When a user clicks Submit on a form, the server behavior inserts records in a database table.

You can add these building blocks in a single operation using the Record Insertion Form data object or you can add them separately using the Dreamweaver form tools and the Server Behaviors panel.

**Note:** The insert page can contain only one record-editing server behavior at a time. For example, you cannot add an Update Record or a Delete Record server behavior to the insert page.

Build an insert page block by block
You can also build an insert page by using the forms tools and server behaviors.

More Help topics
“Creating web forms” on page 633

Add an HTML form to an insert page
1. Create a dynamic page (File > New > Blank Page), and lay out your page using the Dreamweaver design tools.
2. Add an HTML form by placing the insertion point where you want the form to appear and selecting Insert > Form > Form.

An empty form is created on the page. You may have to enable Invisible Elements (View > Visual Aids > Invisible Elements) to see the form's boundaries, which are represented by thin red lines.

3. Name the HTML form by clicking the `<form>` tag at the bottom of the Document window to select the form, opening the Property inspector (Window > Properties), and entering a name in the Form Name box.

You don’t need to specify an `action` or `method` attribute for the form to tell it where and how to send the record data when the user clicks the Submit button. The Insert Record server behavior sets these attributes for you.

4. Add a form object such as a text field (Insert > Form > Text Field) for each column in the database table you want to insert records into.

The form objects are for data entry. Text fields are common for this purpose, but you can also use menus, options, and radio buttons.

5. Add a Submit button to the form (Insert > Form > Button).

You can change the label of the Submit button by selecting the button, opening the Property inspector (Window > Properties), and entering a new value in the Label box.

Add a server behavior to insert records in a database table (ColdFusion)
1. In the Server Behaviors panel (Window > Server Behaviors), click the Plus (+) button and select Insert Record from the pop-up menu.
2 Select a form from the Submit Values From pop-up menu.

3 In the Data Source pop-up menu, select a connection to the database.

4 Enter your user name and password.

5 In the Insert Into Table pop-up menu, select the database table to insert the record in.

6 Specify a database column to insert the record in, select the form object that will insert the record from the Value pop-up menu, and then select a data type for the form object from the Submit As pop-up menu. The data type is the kind of data the column in your database table is expecting (text, numeric, Boolean option values). Repeat the procedure for each form object in your form.

7 In the After Inserting, Go To box, enter the page to open after the record is inserted in the table or click the Browse button to browse to the file.

8 Click OK.

Dreamweaver adds a server behavior to the page that lets users insert records in a database table by filling out the HTML form and clicking the Submit button.

**Add a server behavior to insert records in a database table (ASP)**

1 In the Server Behaviors panel (Window > Server Behaviors), click the Plus (+) button and select Insert Record from the pop-up menu.

2 In the Connection pop-up menu, select a connection to the database.

Click the Define button if you need to define a connection.

3 In the Insert Into Table pop-up menu, select the database table into which the record should be inserted.

4 In the After Inserting, Go To box, enter the page to open after the record is inserted into the table or click Browse to browse to the file.

5 In the Get Values From pop-up menu, select the HTML form used to enter the data. Dreamweaver automatically selects the first form on your page.

6 Specify a database column to insert the record in, select the form object that will insert the record from the Value pop-up menu, and then select a data type for the form object from the Submit As pop-up menu. The data type is the kind of data the column in your database table is expecting (text, numeric, Boolean option values). Repeat the procedure for each form object in your form.

7 Click OK.

Dreamweaver adds a server behavior to the page that lets users insert records in a database table by filling out the HTML form and clicking the Submit button.

To edit the server behavior, open the Server Behaviors panel (Window > Server Behaviors) and double-click the Insert Record behavior.

**Add a server behavior to insert records in a database table (PHP)**

1 In the Server Behaviors panel (Window > Server Behaviors), click the Plus (+) button and select Insert Record from the pop-up menu.

2 Select a form from the Submit Values From pop-up menu.

3 In the Connection pop-up menu, select a connection to the database.

4 In the Insert Table pop-up menu, select the database table to insert the record in.
Specify a database column to insert the record in, select the form object that will insert the record from the Value pop-up menu, and then select a data type for the form object from the Submit As pop-up menu. The data type is the kind of data the column in your database table is expecting (text, numeric, Boolean option values). Repeat the procedure for each form object in your form.

In the After Inserting, Go To box, enter the page to open after the record is inserted in the table or click the Browse button to browse to the file.

Click OK.

Dreamweaver adds a server behavior to the page that lets users insert records in a database table by filling out the HTML form and clicking the Submit button.

**Build the insert page in one operation**

1. Open the page in Design view, and select Insert > Data Objects > Insert Record > Record Insertion Form Wizard.
2. In the Connection pop-up menu, select a connection to the database. Click Define if you need to define a connection.
3. In the Insert Into Table pop-up menu, select the database table into which the record should be inserted.
4. If you use ColdFusion, enter a user name and password.
5. In the After Inserting, Go To box, enter the page to open after the record is inserted into the table or click the Browse button to browse to the file.
6. In the Form Fields area, specify the form objects you want to include on the insert page’s HTML form, and which columns in your database table each form object should update.

By default, Dreamweaver creates a form object for each column in the database table. If your database automatically generates unique key IDs for each new record created, remove the form object corresponding to the key column by selecting it in the list and clicking the Minus (-) button. This eliminates the risk that the user of the form will enter an ID value that already exists.

You can also change the order of the form objects on the HTML form by selecting a form object in the list and clicking the up or down arrow on the right side of the dialog box.

Specify how each data-entry field should be displayed on the HTML form by clicking a row in the Form Fields table and entering the following information in the boxes below the table:

- In the Label box, enter a descriptive label to display beside the data-entry field. By default, Dreamweaver displays the table column’s name in the label.
- In the Display As pop-up menu, select a form object to serve as the data-entry field. You can select Text Field, Text Area, Menu, Checkbox, Radio Group, and Text. For read-only entries, select Text. You can also select Password Field, File Field, and Hidden Field.

*Note: Hidden fields are inserted at the end of the form.*

- In the Submit As pop-up menu, select the data format accepted by your database table. For example, if the table column only accepts numeric data, select Numeric.
- Set the form object’s properties. You have different options depending on the form object you select as your data-entry field. For text fields, text areas, and text, you can enter an initial value. For menus and radio groups, you open another dialog box to set the properties. For options, select the Checked or Unchecked option.

Click OK.
Dreamweaver adds both an HTML form and an Insert Record server behavior to your page. The form objects are laid out in a basic table, which you can customize using the Dreamweaver page design tools. (Make sure all the form objects remain within the form’s boundaries.)

To edit the server behavior, open the Server Behaviors panel (Window > Server Behaviors) and double-click the Insert Record behavior.

**Building an update record page**

**About record update pages**

Your application can contain a set of pages that lets users update existing records in a database table. The pages normally consist of a search page, a results page, and an update page. The search and results page let users retrieve the record and the update page lets users modify the record.

**Search for the record to update**

When users want to update a record, they must first find that record in the database. Accordingly, you need a search and a results page to work with the update page. The user enters search criteria in the search page and selects the record on the results page. When the user clicks the record on the results page, the update page opens and displays the record in an HTML form.

**More Help topics**

“Building search and results pages” on page 590

**Create links to the update page**

After creating the search and results pages, you create links on the results page to open the update page. You then modify the links to pass the IDS of the records the user selects. The update page uses this ID to find the requested record in the database and display it.

You use the same process to open the update page and pass a record ID that you do to open a detail page and pass a record ID. For more information, see “Create links to the detail page” on page 585.

**More Help topics**

“URL parameters” on page 631

**Retrieve the record to update**

After the results page passes a record ID to the update page identifying the record to update, the update page must read the parameter, retrieve the record from the database table, and store it temporarily in a recordset.

1. Create a page in Dreamweaver and save it.
   The page will become your update page.

2. In the Bindings panel (Window > Bindings), click the Plus (+) button and select Recordset.
   If the advanced dialog box appears, click Simple. The advanced dialog box has a text area to enter SQL statements; the simple one does not.
3 Name the recordset and specify where the data you want to update is located using the Connection and Table pop-up menus.

4 Click Selected, and select a key column (usually the record ID column) and the columns that contain the data to be updated.

5 Configure the Filter area so that the value of your key column equals the value of the corresponding URL parameter passed by the results page.

This kind of filter creates a recordset that contains only the record specified by the results page. For example, if your key column contains record ID information and is called PRID, and if the results page passes the corresponding record ID information in the URL parameter called \textit{id}, the Filter area should look like the following example:

6 Click OK.

When the user selects a record on the results page, the update page generates a recordset containing only the selected record.

**Complete the update page block by block**

An update page has three building blocks:

- A filtered recordset to retrieve the record from a database table
- An HTML form to let users modify the record’s data
- An Update Record server behavior to update the database table

You can add the final two basic building blocks of an update page separately using the form tools and the Server Behaviors panel.

**More Help topics**

“Retrieve the record to update” on page 599

“Creating web forms” on page 633

**Add an HTML form to an update page**

1 Create a page (File > New > Blank Page). This becomes your update page.

2 Lay out your page using the Dreamweaver design tools.

3 Add an HTML form by placing the insertion point where you want the form to appear and selecting Insert > Form > Form.

An empty form is created on the page. You may have to enable Invisible Elements (View > Visual Aids > Invisible Elements) to see the form’s boundaries, which are represented by thin red lines.

4 Name the HTML form by clicking the \texttt{<form>} tag at the bottom of the Document window to select the form, opening the Property inspector (Window > Properties), and entering a name in the Form Name box.

You don’t have to specify an \texttt{action} or \texttt{method} attribute for the form to tell it where and how to send the record data when the user clicks the Submit button. The Update Record server behavior sets these attributes for you.
5 Add a form object such as a text field (Insert > Form > Text Field) for each column you want to update in the database table. The form objects are for data entry. Text fields are common for this purpose, but you can also use menus, options, and radio buttons.

Each form object should have a corresponding column in the recordset you defined earlier. The only exception is the unique key column, which should have no corresponding form object.

6 Add a Submit button to the form (Insert > Form > Button).

You can change the label of the Submit button by selecting the button, opening the Property inspector (Window > Properties), and entering a new value in the Label box.

Display the record in the form

1 Make sure you defined a recordset to hold the record the user wants to update.

See “Retrieve the record to update” on page 599.

2 Bind each form object to data in the recordset, as described in the following topics:
   • “Display dynamic content in HTML text fields” on page 642
   • “Dynamically preselect an HTML check box” on page 643
   • “Dynamically preselect an HTML radio button” on page 643
   • “Insert or change a dynamic HTML form menu” on page 642
   • “Make existing HTML form menus dynamic” on page 642

Add a server behavior to update the database table

1 In the Server Behaviors panel (Window > Server Behaviors), click the Plus (+) button and select Update Record from the pop-up menu.

The Update Record dialog box appears.

2 Select a form from the Submit Values From pop-up menu.

3 In the Data Source or Connection pop-up menu, select a connection to the database.

4 Enter your user name and password if applicable.

5 In the Update Table pop-up menu, select the database table that contains the record you are updating.

6 (ColdFusion, PHP) Specify a database column to update, select the form object that will update the column from the Value pop-up menu, select a data type for the form object from the Submit As pop-up menu, and select Primary Key if you want to identify this column as the primary key.

The data type is the kind of data the column in your database table is expecting (text, numeric, Boolean option values).

Repeat the procedure for each form object in your form.

7 (ASP) In the Select Record From pop-up menu, specify the recordset that contains the record displayed in the HTML form. In the Unique Key Column pop-up menu, select a key column (usually the record ID column) to identify the record in the database table. Select the Numeric option if the value is a number. A key column usually accepts only numeric values, but sometimes accepts text values.

8 In the After Updating or On Success, Go To box, enter the page to open after the record updates in the table or click the Browse button to browse to the file.
9 (ASP) Specify a database column to update, select the form object that will update the column from the Value pop-up menu, and then select a data type for the form object from the Submit As pop-up menu. The data type is the kind of data the column in your database table is expecting (text, numeric, Boolean option values). Repeat the procedure for each form in your form.

10 Click OK.

Dreamweaver adds a server behavior to the page that lets users update records in a database table by modifying the information displayed in the HTML form and clicking the Submit button.

To edit the server behavior, open the Server Behaviors panel (Window > Server Behaviors) and double-click the Update Record behavior.

**Complete the update page in one operation**

An update page has three building blocks:

- A filtered recordset to retrieve the record from a database table
- An HTML form to let users modify the record's data
- An Update Record server behavior to update the database table

You can add the final two building blocks of an update page in a single operation using the Record Update Form data object. The data object adds both an HTML form and an Update Record server behavior to the page.

Before you can use the data object, your web application must be able to identify the record to update, and your update page must be able to retrieve it.

After the data object places the building blocks on the page, you can use the Dreamweaver design tools to customize the form to your liking, or the Server Behaviors panel to edit the Update Record server behavior.

**Note:** The update page can contain only one record-editing server behavior at a time. For example, you cannot add an Insert Record or a Delete Record server behavior to the update page.

1 Open the page in Design view, and select Insert > Data Objects > Update Record > Record Update Form Wizard. The Record Update Form dialog box appears.

2 In the Connection pop-up menu, select a connection to the database.

3 Click the Define button if you need to define a connection.

4 In the Table To Update pop-up menu, select the database table that contains the record to update.

5 In the Select Record From pop-up menu, specify the recordset that contains the record displayed in the HTML form.

6 In the Unique Key Column pop-up menu, select a key column (usually the record ID column) to identify the record in the database table.

7 In the After Updating, Go To box, enter the page to open after the record updates in the table.

8 In the Form Fields area, specify which columns in your database table each form object should update.

By default, Dreamweaver creates a form object for each column in the database table. If your database automatically generates unique key IDs for each new record created, remove the form object corresponding to the key column by selecting it in the list and clicking the Minus (-) button. This eliminates the risk that the user of the form will enter an ID value that already exists.
You can also change the order of the form objects on the HTML form by selecting a form object in the list and clicking the up or down arrow on the right side of the dialog box.

8 Specify how each data-entry field should appear on the HTML form by clicking a row in the Form Fields table and entering the following information in the boxes below the table:

- In the Label box, enter a descriptive label to display beside the data-entry field. By default, Dreamweaver displays the table column’s name in the label.
- In the Display As pop-up menu, select a form object to serve as the data-entry field. You can select Text Field, Text Area, Menu, Checkbox, Radio Group, and Text. For read-only entries, select Text. You can also select Password Field, File Field, and Hidden Field.

*Note:* Hidden fields are inserted at the end of the form.

- In the Submit As pop-up menu, select the data format expected by your database table. For example, if the table column only accepts numeric data, select Numeric.
- Set the form object’s properties. You have different options depending on the form object you select as your data-entry field. For text fields, text areas, and text, you can enter an initial value. For menus and radio groups, you open another dialog box to set the properties. For options, select the Checked or Unchecked option.

9 Set the properties of other form objects by selecting another Form Fields row and entering a label, Display As value, and Submit As value.

For menus and radio groups, open another dialog box to set the properties. For options, define a comparison between the current record’s value for the option and a given value to determine whether the option is checked when the record is displayed.

10 Click OK.

Dreamweaver adds both an HTML form and an Update Record server behavior to your page.

The data object adds both an HTML form and an Update Record server behavior to your page. The form objects are laid out in a basic table, which you can customize using the Dreamweaver page design tools. (Make sure all the form objects remain within the form’s boundaries.)

To edit the server behavior, open the Server Behaviors panel (Window > Server Behaviors) and double-click the Update Record behavior.

**More Help topics**

“Retrieve the record to update” on page 599

“Insert or change a dynamic HTML form menu” on page 642

**Form Element Properties options**

The purpose of the Form Element Properties dialog box is to set the options for form elements on pages that let users update records in a database.

1 Select either Manually or From Database, depending on how you plan to create the form element.

2 Click the Plus (+) button to add an element.

3 Enter a label and value for the element.

4 In the Select Value Equal To box, if you want a particular element selected when the page opens in a browser or when a record displays in the form, enter a value equal to the element’s value.
You can enter a static value or you can specify a dynamic value by clicking the lightning bolt icon, and selecting a dynamic value from the list of data sources. In either case, the value you specify should match one of the element’s values.

### Building a delete record page

#### About record delete pages

Your application can contain a set of pages that lets users delete records in a database. The pages normally consist of a search page, a results page, and a delete page. A delete page is usually a detail page working in tandem with a results page. The search and results pages let the user retrieve the record and the delete page lets the user confirm and delete the record.

After creating the search and results pages, you add links on the results page to open the delete page and then build a delete page that displays the records and a Submit button.

#### Search for the record to delete

When users want to delete a record, they must first find that record in the database. Accordingly, you need a search and a results page to work with the delete page. The user enters search criteria in the search page and selects the record on the results page. When the user clicks the record, the delete page opens and displays the record in an HTML form.

**More Help topics**

“Building search and results pages” on page 590

#### Create links to a delete page

After creating the search and results pages, you must create links on the results page to open the delete page. You then modify the links to pass the IDs of the records the user wants to delete. The delete page uses this ID to find and display the record.

**More Help topics**

“URL parameters” on page 631

**To create the links manually**

1. On the results page, create a column in the table used to display records by clicking inside the last table column and selecting Modify > Table > Insert Rows or Columns.
2. Select the Columns option and the After Current Column option, and click OK. A column is added to the table.
3. In the newly created table column, enter the string Delete in the row containing the dynamic content placeholders. Make sure you enter the string inside the tabbed repeating region.
   You can also insert an image with a word or symbol for delete.
4. Select the Delete string to apply a link to it.
5. In the Property inspector, enter the delete page in the Link box. You can enter any filename.
After clicking outside the Link box, the Delete string appears linked in the table. If you Live view, you can see that the link is applied to the same text in every table row.

6. Select the Delete link on the results page.

7. (ColdFusion) In the Link box in the Property inspector, add the following string at the end of the URL:
   ?recordID=#recordsetName.fieldName#

   The question mark tells the server that what follows is one or more URL parameters. The word recordID is the name of the URL parameter (you can make up any name you like). Note the name of the URL parameter because you'll use it in the delete page later.

   The expression after the equal sign is the value of the parameter. In this case, the value is generated by a ColdFusion expression that returns a record ID from the recordset. A different ID is generated for each row in the dynamic table. In the ColdFusion expression, replace recordsetName with the name of your recordset, and replace fieldName with the name of the field in your recordset that uniquely identifies each record. In most cases, the field will consist of a record ID number. In the following example, the field consists of unique location codes:
   confirmDelete.cfm?recordID=#rsLocations.CODEx#

   When the page runs, the values of the recordset's CODE field are inserted in the corresponding rows in the dynamic table. For example, if the Canberra, Australia, rental location has the code CBR, the following URL is used in the Canberra row in the dynamic table:
   confirmDelete.cfm?recordID=CBR

8. (PHP) In the Link field in the Property inspector, add the following string at the end of the URL:
   ?recordID=<?php echo $row_recordsetName['fieldName']; ?>

   The question mark tells the server that what follows is one or more URL parameters. The word recordID is the name of the URL parameter (you can make up any name you like). Note the name of the URL parameter because you'll use it in the delete page later.

   The expression after the equal sign is the value of the parameter. In this case, the value is generated by a PHP expression that returns a record ID from the recordset. A different ID is generated for each row in the dynamic table. In the PHP expression, replace recordsetName with the name of your recordset, and replace fieldName with the name of the field in your recordset that uniquely identifies each record. In most cases, the field will consist of a record ID number. In the following example, the field consists of unique location codes:
   confirmDelete.php?recordID=<?php echo $row_rsLocations['CODE']; ?>

   When the page runs, the values of the recordset's CODE field are inserted in the corresponding rows in the dynamic table. For example, if the Canberra, Australia, rental location has the code CBR, the following URL is used in the Canberra row in the dynamic table:
   confirmDelete.php?recordID=CBR

9. (ASP) In the Link field in the Property inspector, add the following string at the end of the URL:
   ?recordID=<%=(recordsetName.Fields.Item("fieldName").Value)%>

   The question mark tells the server that what follows is one or more URL parameters. The word recordID is the name of the URL parameter (you can make up any name you like). Note the name of the URL parameter because you'll use it in the delete page later.
The expression after the equal sign is the value of the parameter. In this case, the value is generated by an ASP expression that returns a record ID from the recordset. A different ID is generated for each row in the dynamic table. In the ASP expression, replace `recordsetName` with the name of your recordset, and replace `fieldName` with the name of the field in your recordset that uniquely identifies each record. In most cases, the field will consist of a record ID number. In the following example, the field consists of unique location codes:

```asp
confirmDelete.asp?recordID=<%=(rsLocations.Fields.Item("CODE").Value)%>
```

When the page runs, the values of the recordset's CODE field are inserted in the corresponding rows in the dynamic table. For example, if the Canberra, Australia, rental location has the code CBR, the following URL is used in the Canberra row in the dynamic table:

`confirmDelete.asp?recordID=CBR`

10 Save the page.

**To create the links visually (ASP only)**

1. On the results page, create a column in the table used to display records by clicking inside the last table column and selecting Modify > Table > Insert Rows or Columns.
2. Select the Columns option and the After Current Column option, and click OK.
   A column is added to the table.
3. In the newly created table column, enter the string `Delete` in the row containing the dynamic content placeholders.
   Make sure you enter the string inside the tabbed repeating region.
4. You can also insert an image with a word or symbol for delete.
5. Select the `Delete` string to apply a link to it.
6. In the Server Behaviors panel (Window > Server Behaviors), click the Plus (+) button, and select Go to Detail Page from the pop-up menu.
7. In the Detail Page box, click Browse and locate the delete page.
8. In the Pass URL Parameter box, specify the name of your parameter, such as `recordID`.
   You can make up any name you like, but take note of the name because you’ll use it in the delete page later.
9. Specify the value you want to pass to the delete page by selecting a recordset and a column from the Recordset and Column pop-up menus. Typically the value is unique to the record, such as the record’s unique key ID.
10. Select the URL Parameters option.
11. Click OK.

A special link surrounds the selected text. When the user clicks the link, the Go To Detail Page server behavior passes a URL parameter containing the record ID to the specified delete page. For example, if the URL parameter is called `recordID` and the delete page is called `confirmdelete.asp`, the URL looks something like the following when the user clicks on the link:

```
http://www.mysite.com/confirmdelete.asp?recordID=43
```

The first part of the URL, `http://www.mysite.com/confirmdelete.asp`, opens the delete page. The second part, `?recordID=43`, is the URL parameter. It tells the delete page what record to find and display. The term `recordID` is the name of the URL parameter and 43 is its value. In this example, the URL parameter contains the record’s ID number, 43.
Build the delete page

After completing the page listing the records, switch to the delete page. The delete page shows the record and asks the user if they're sure they want to delete it. When the user confirms the operation by clicking the form button, the web application deletes the record from the database.

Building this page consists of creating an HTML form, retrieving the record to display in the form, displaying the record in the form, and adding the logic to delete the record from the database. Retrieving and displaying the record consists of defining a recordset to hold a single record—the record the user wants to delete—and binding the recordset columns to the form.

Note: The delete page can contain only one record-editing server behavior at a time. For example, you cannot add an Insert Record or an Update Record server behavior to the delete page.

Create an HTML form to display the record

1. Create a page and save it as the delete page you specified in the previous section.

You specified a delete page when you created the Delete link in the previous section. Use this name when saving the file for the first time (for example, deleteConfirm.cfm).

2. Insert an HTML form on the page (Insert > Form > Form).

3. Add a hidden form field to the form.

The hidden form field is required to store the record ID passed by the URL parameter. To add a hidden field, place the insertion point in the form and select Insert > Form > Hidden Field.

4. Add a button to the form.

The user will click the button to confirm and delete the displayed record. To add a button, place the insertion point in the form and select Insert > Form > Button.

5. Enhance the design of the page any way you want and save it.

Retrieve the record the user wants to delete

1. In the Bindings panel (Window > Bindings), click the Plus (+) button and select Recordset (Query) from the pop-up menu.

The simple Recordset or DataSet dialog box appears. If the advanced Recordset dialog box appears instead, click Simple.

2. Name the recordset, and select a data source and the database table that contains the records that users can delete.

3. In the Columns area, select the table columns (record fields) you want to display on the page.

To display only some of the record’s fields, click Selected and choose the desired fields by Control-clicking (Windows) or Command-clicking (Macintosh) them in the list.

Make sure to include the record ID field even if you won’t be displaying it.

4. Complete the Filter section as follows to find and display the record specified in the URL parameter passed by the results page:

- From the first pop-up menu in the Filter area, select the column in the recordset containing values that match the value of the URL parameter passed by the page with the Delete links. For example, if the URL parameter contains a record ID number, select the column containing record ID numbers. In the example discussed in the previous section, the recordset column called CODE contains the values that match the value of the URL parameter passed by the page with the Delete links.

- From the pop-up menu beside the first menu, select the equal sign, if not already selected.
From the third pop-up menu, select URL Parameter. The page with the Delete links uses a URL parameter to pass information to the delete page.

In the fourth box, enter the name of the URL parameter passed by the page with the Delete links.

5  Click OK.

The recordset appears in the Bindings panel.

**Display the record the user wants to delete**

1  Select the recordset columns (record fields) in the Bindings panel, and drag them to the delete page.

Make sure you insert this read-only dynamic content within the form boundaries. For more information on inserting dynamic content in a page, see “Make text dynamic” on page 557.

Next, you must bind the record ID column to the hidden form field.

2  Make sure Invisible Elements are enabled (View > Visual Aids > Invisible Elements), and then click the yellow shield icon that represents the hidden form field.

The hidden form field is selected.

3  In the Property inspector, click the lightning bolt icon beside the Value box.

4  In the Dynamic Data dialog box, select the record ID column in the recordset.

In the following example, the record ID column, CODE, contains unique store codes.
5 Click OK and save the page.

Add logic to delete the record

After displaying the selected record on the delete page, you must add logic to the page that deletes the record from the database when the user clicks the Confirm Deletion button. You can add this logic quickly and easily by using the Delete Record server behavior.

To add a server behavior to delete the record (ColdFusion, PHP)

1 Make sure the ColdFusion or PHP delete page is open in Dreamweaver.
2 In the Server Behaviors panel (Window > Server Behaviors), click the Plus (+) button, and select Delete Record.
3 In the First Check If Variable Is Defined box, make sure Primary Key Value is selected.

You specify the primary key value later in the dialog box.
In the Connection or Data Source (ColdFusion) pop-up menu, select a connection to the database so that the server behavior can connect to the affected database.

In the Table pop-up menu, select the database table that contains the records that will be deleted.

In the Primary Key Column pop-up menu, select the table column that contains record IDs.

The Delete Record server behavior searches this column for a match. The column should contain the same record ID data as the recordset column you bound to the hidden form field on the page.

If the record ID is numeric, select the Numeric option.

In the Primary Key Value pop-up menu, select the variable on your page that contains the record ID identifying the record to be deleted.

The variable is created by your hidden form field. It has the same name as the name attribute of the hidden field and is either a form or URL parameter, depending on the form’s method attribute.

In the After Deleting, Go To box, or the On Success, Go To box, specify a page to open after the record has been deleted from the database table.

You can specify a page that contains a brief success message to the user, or a page listing the remaining records so that the user can verify that the record has been deleted.

Click OK, and save your work.

**To add a server behavior to delete the record (ASP)**

1. Make sure the ASP delete page is open in Dreamweaver.
2. In the Server Behaviors panel (Window > Server Behaviors), click the Plus (+) button, and select Delete Record.
3. In the Connection pop-up menu, select a connection to the database so that the server behavior can connect to the affected database.

Click the Define button if you need to define a connection.

4. In the Delete from Table pop-up menu, select the database table that contains the records to be deleted.
5. In the Select Record From pop-up menu, specify the recordset that contains the records to be deleted.
6. In the Unique Key Column pop-up menu, select a key column (usually the record ID column) to identify the record in the database table.

If the value is a number, select the Numeric option. A key column usually accepts only numeric values, but sometimes it accepts text values.

Click OK, and save your work.
7 In the Delete By Submitting pop-up menu, specify the HTML form with the Submit button that sends the delete command to the server.

8 In the After Deleting, Go To box, specify a page to open after the record has been deleted from the database table. You can specify a page that contains a brief success message to the user, or a page listing the remaining records so that the user can verify that the record has been deleted.

9 Click OK, and save your work.

Test your delete pages
1 Upload the search, results, and delete pages to your web server, open a browser and search for a disposable test record to delete.

When you click a Delete link on the results page, the delete page should appear.

2 Click the Confirm button to delete the record from the database.

3 Verify that the record has been deleted by searching for the record again. The record should no longer appear in the results page.

Building pages with advanced data manipulation objects (ColdFusion, ASP)

About ASP command objects
An ASP command object is a server object that performs some operation on a database. The object can contain any valid SQL statement, including one that returns a recordset, or one that inserts, updates, or deletes records in a database. A command object can alter the structure of a database if the SQL statement adds or deletes a column in a table. You can also use a command object to run a stored procedure in a database.

A command object can be reusable, in the sense that the application server can reuse a single compiled version of the object to execute the command a number of times. You make a command reusable by setting the Prepared property of the Command object to true, as in the following VBScript statement:

```vbscript
mycommand.Prepared = true
```

If you know the command will be executed more than a few times, having a single compiled version of the object can make database operations more efficient.

Note: Not all database providers support prepared commands. If your database does not support it, it might return an error when you set this property to true. It might even ignore the request to prepare the command and set the Prepared property to false.

A command object is created by scripts on an ASP page, but Dreamweaver lets you create command objects without writing a line of ASP code.

Use ASP commands to modify a database
You can use Dreamweaver to create ASP command objects that insert, update, or delete records in a database. You supply the command object with the SQL statement or stored procedure that performs the operation on the database.

1 In Dreamweaver, open the ASP page that will run the command.

2 Open the Server Behaviors panel (Window > Server Behaviors), click the Plus (+) button, and select Command.
3 Enter a name for the command, select a connection to the database that contains the records you want to edit, and select the editing operation that you want the command to perform—Insert, Update, or Delete.

Dreamweaver starts the SQL statement, based on the type of operation you select. For example, if you select Insert, the dialog box looks like the following example:

![SQL statement example](image)

4 Complete the SQL statement.

For information on writing SQL statements that modify databases, consult a Transact-SQL manual.

5 Use the Variables area to define any SQL variables. Provide the name and run-time value. Specifying the type and size of each variable prevents injection attacks.

The following example shows an Insert statement that contains three SQL variables. The values of these variables are provided by URL parameters passed to the page, as defined in the Run-Time Value column of the Variables area.

![Variables example](image)

To get the Size value, use the Databases panel in Dreamweaver. Find your database in the Databases panel and expand it. Next, find the table you’re working with and expand it. The table lists the sizes for your fields. For example, it might say ADDRESS (WChar 50). In this example, 50 is the size. You can also find the size in your database application.

**Note:** Numeric, Boolean and date/time data types always use -1 as the size.

To determine the Type value, see the following table:

<table>
<thead>
<tr>
<th>Type in database</th>
<th>Type in Dreamweaver</th>
<th>Size</th>
</tr>
</thead>
<tbody>
<tr>
<td>Numeric (MS Access, MS SQL Server, MySQL)</td>
<td>Double</td>
<td>-1</td>
</tr>
<tr>
<td>Boolean, Yes/No (MS Access, MS SQL Server, MySQL)</td>
<td>Double</td>
<td>-1</td>
</tr>
<tr>
<td>Date/Time (MS Access, MS SQL Server, MySQL)</td>
<td>DBTimeStamp</td>
<td>-1</td>
</tr>
</tbody>
</table>
Dreamweaver inserts ASP code in your page that, when run on the server, creates a command that inserts, updates, or deletes records in the database.

By default, the code sets the Prepared property of the Command object to `true`, which makes the application server reuse a single compiled version of the object every time the command is run. To change this setting, switch to Code view and change the Prepared property to `false`.

Create a page with an HTML form so users can enter record data. In the HTML form, include three text fields (txtCity, txtAddress, and txtPhone) and a submit button. The form uses the `GET` method and submits the text field values to the page that contains your command.

### About stored procedures

Although you can use server behaviors to build pages that modify databases, you can also use database manipulation objects such as stored procedures or ASP command objects to build the pages.

A stored procedure is a reusable database item that performs some operation on the database. A stored procedure contains SQL code that can, among other things, insert, update, or delete records. Stored procedures can also alter the structure of the database itself. For example, you can use a stored procedure to add a table column or even delete a table.

A stored procedure can also call another stored procedure, as well as accept input parameters and return multiple values to the calling procedure in the form of output parameters.

A stored procedure is reusable in the sense that you can reuse a single compiled version of the procedure to execute a database operation a number of times. If you know a database task will be executed more than a few times—or the same task will be executed by different applications—using a stored procedure to execute that task can make database operations more efficient.

*Note:* MySQL and Microsoft Access databases do not support stored procedures.

### Add a stored procedure (ColdFusion)

You can use a stored procedure to modify a database. A stored procedure is a reusable database item that performs some operation on the database.

Before you use a stored procedure to modify a database, make sure the stored procedure contains SQL that modifies the database in some way. To create and store one in your database, consult your database documentation and a good Transact-SQL manual.

1. In Dreamweaver, open the page that will run the stored procedure.
2. In the Bindings panel (Window > Bindings), click the Plus (+) button, and then select Stored Procedure.
3. In the Data Source pop-up menu, select a connection to the database containing the stored procedure.

For more information on the type and size of SQL variables, see [www.adobe.com/go/4e6b330a](http://www.adobe.com/go/4e6b330a).
4. Enter the ColdFusion Data Source user name and password.
5. Select a stored procedure from the Procedures pop-up menu. Dreamweaver automatically fills in any parameters.
6. Select a parameter, and click Edit if you have to make changes. The Edit Stored Procedure Variable dialog box appears. The name of the variable you are editing appears in the Name box.

**Note:** You must enter test values for any stored procedure input parameters.

7. Make changes as necessary:
   - Select a Direction from the pop-up menu. A stored procedure might have input values, output values, or both input and output values.
   - Select a SQL type from the pop-up menu. Enter a return variable, a run-time value, and a test value.
8. If the stored procedure takes a parameter, click the Plus (+) button to add a page parameter.

**Note:** You must enter corresponding page parameters for each stored procedure parameter return value. Do not add page parameters unless there is a corresponding return value.

Click the Plus (+) button again to add another page parameter, if necessary.

9. Select a page parameter, and click the Minus (-) button to delete the parameter if necessary or click Edit to make changes to the parameter.

10. Select the Returns Recordset Named option, and then enter a name for the recordset; if the stored procedure returns a recordset, click the Test button to see the recordset that the stored procedure returns.

Dreamweaver runs the stored procedure and displays the recordset, if any.

**Note:** If the stored procedure returns a recordset and takes parameters, you must enter a value in the Default Value column in the Variables box to test the stored procedure.

You can use different test values to generate different recordsets. To change test values, click the Edit button for Parameter, and change the test value, or click the Edit button for Page Parameter and change the default value.

11. Select the Returns Status Code Named option, enter a name for the status code, if the stored procedure returns a status code return value. Click OK.

After you close the box, Dreamweaver inserts ColdFusion code in your page that calls a stored procedure in the database, when the code runs on the server. The stored procedure in turn performs a database operation, such as inserting a record.

If the stored procedure takes parameters, you can create a page that gathers the parameter values and submits them to the page with the stored procedure. For example, you may create a page that uses URL parameters or an HTML form to gather parameter values from users.

**More Help topics**
“Define an advanced recordset by writing SQL” on page 545

**Run a stored procedure (ASP)**

With ASP pages, you must add a command object to a page to run a stored procedure. For more information on command objects, see “About ASP command objects” on page 611.

1. In Dreamweaver, open the page that will run the stored procedure.
2 In the Bindings panel (Window > Bindings), click the Plus (+) button, and then select Command (Stored Procedure).

The Command dialog box appears.

3 Enter a name for the command, select a connection to the database containing the stored procedure, and then select Stored Procedure from the Type pop-up menu.

4 Select your stored procedure by expanding the Stored Procedures branch in the Database Items box, selecting the stored procedure from the list, and clicking the Procedure button.

5 Enter any required parameters in the Variables table.

You don’t need to enter any parameters for any RETURN_VALUE variable.

6 Click OK.

After you close the dialog box, ASP code is inserted in your page. When the code runs on the server, the code creates a command object that runs a stored procedure in the database. The stored procedure in turn performs a database operation, such as inserting a record.

By default, the code sets the Prepared property of the Command object to true, which makes the application server reuse a single compiled version of the object every time the stored procedure is run. If you know the command will be executed more than a few times, having a single compiled version of the object can improve the efficiency of database operations. However, if the command will only be executed one or two times, using one might actually slow down your web application because the system has to pause to compile the command. To change the setting, switch to Code view and change the Prepared property to false.

Note: Not all database providers support prepared commands. If your database does not support it, you might get an error message when you run the page. Switch to Code view and change the Prepared property to false.

If the stored procedure takes parameters, you might create a page that gathers the parameter values and submits them to the page with the stored procedure. For example, you may create a page that uses URL parameters or an HTML form to gather parameter values from users.

Building a registration page

About registration pages

Your web application can contain a page that requires users to register the first time they visit your site.

A registration page is made up of the following building blocks:

- A database table to store login information about the users
- An HTML form that lets users select a user name and password
  - You can also use the form to obtain other personal information from users.
- An Insert Record server behavior to update the database table of site users
- A Check New Username server behavior to make sure the user name entered by the user is not taken by another user
Storing login information about users

A registration page requires a database table to store the login information entered by users.

- Make sure your database table contains a user name and a password column. If you want logged-in users to have different access privileges, include an access privilege column.
- If you want to set a common password for all users of the site, configure your database application (Microsoft Access, Microsoft SQL Server, Oracle, and so on) to enter the password in each new user record by default. In most database applications, you can set a column to a default value each time a new record is created. Set the default value to the password.
- You can also use the database table to store other useful information about the user.

The next step in creating a registration page is to add an HTML form to the registration page to let users choose a user name and password (if applicable).

More Help topics
“Store access privileges in the user database” on page 621

Add an HTML form for selecting a user name and password

You add an HTML form to the registration page to let users select a user name and password (if applicable).

1. Create a page (File > New > Blank Page) and lay out your registration page using the Dreamweaver design tools.
2. Add an HTML form by placing the insertion point where you want the form to appear and selecting Form from the Insert menu.

An empty form is created on the page. You may have to enable Invisible Elements (View > Visual Aids > Invisible Elements) to see the form’s boundaries, which are represented by thin red lines.

3. Name the HTML form by clicking the <form> tag at the bottom of the Document window to select the form, opening the Property inspector (Window > Properties), and entering a name in the Form Name box.

You don’t have to specify an action or method attribute for the form to tell it where and how to send the record data when the user clicks the Submit button. The Insert Record server behavior sets these attributes for you.

4. Add text fields (Insert > Form > Text Field) to let the user enter a user name and password.

The form can also have more form objects to record other personal data.

You should add labels (either as text or images) beside each form object to tell users what they are. You should also line up the form objects by placing them inside an HTML table. For more information on form objects, see “Creating web forms” on page 633.

5. Add a Submit button to the form (Insert > Form > Button).

You can change the label of the Submit button by selecting the button, opening the Property inspector (Window > Properties), and entering a new value in the Value box.
The next step in creating a registration page is to add the Insert Record server behavior to insert records in the table of users in the database.

**Update the database table of users**
You must add an Insert Record server behavior to the registration page to update the table of users in the database.

1. In the Server Behaviors panel (Window > Server Behaviors), click the Plus (+) button and select Insert Record from the pop-up menu.

   The Insert Record dialog box appears.

2. Complete the dialog box, making sure to specify the table of users in the database into which the user data will be inserted. Click OK.

   The final step in creating a registration page is to make sure the user name is not used by another registered user.

**More Help topics**
“Build an insert page block by block” on page 596

**Add a server behavior to ensure a unique user name**
You can add a server behavior to a user registration page that verifies that the user name is unique before adding that user to your database of registered users.

When the user clicks the Submit button on the registration page, the server behavior compares the user name entered by the user against the user names stored in a database table of registered users. If no matching user name is found in the database table, the server behavior carries out the insert record operation normally. If a matching user name is found, the server behavior cancels the insert record operation and opens a new page (usually a page alerting the user that the user name is already taken).

1. In the Server Behaviors panel (Window > Server Behaviors), click the Plus (+) button and select User Authentication > Check New Username from the pop-up menu.

2. In the Username Field pop-up menu, select the form text field that your visitors use to enter a user name.

3. In the If Already Exists, Go To box, specify a page to open if a matching user name is found in the database table, and click OK.

   The opened page should alert the user that the user name is already taken and let the user try again.

**Building a login page**

**About login pages**
Your web application can contain a page that lets registered users log in to the site.

A login page is made up of the following building blocks:
- A database table of registered users
- An HTML form to let users enter a user name and password
- A Log In User server behavior to make sure the entered user name and password are valid
  A session variable consisting of the user name is created for the user when the user logs in successfully.
Create a database table of registered users

You need a database table of registered users to verify that the user name and password entered in the login page are valid.

❖ Use your database application and a registration page to create the table. For instructions, see the related topic link below.

The next step in building a login page is to add an HTML form to the page to let users log in. See the next topic for instructions.

More Help topics
“Building a registration page” on page 615

Add an HTML form to let users log in

You add an HTML form to the page to let users log in by entering a user name and password.

1 Create a page (File > New > Blank Page), and lay out your login page using the Dreamweaver design tools.

2 Add an HTML form by placing the insertion point where you want the form to appear and choosing Form from the Insert menu.

An empty form is created on the page. You may have to enable Invisible Elements (View > Visual Aids > Invisible Elements) to see the form’s boundaries, which are represented by thin red lines.

3 Name the HTML form by clicking the <form> tag at the bottom of the Document window to select the form, opening the Property inspector (Window > Properties), and entering a name in the Form Name box.

You don’t have to specify an action or method attribute for the form to tell it where and how to send the record data when the user clicks the Submit button. The Log In User server behavior sets these attributes for you.

4 Add a user name and a password text field (Insert > Form > Text Field) to the form.

Add labels (either as text or images) beside each text field, and line up the text fields by placing them inside an HTML table and setting the table’s border attribute to 0.

5 Add a Submit button to the form (Insert > Form > Button).

You can change the label of the Submit button by selecting the button, opening the Property inspector (Window > Properties), and entering a new value in the Label box.

The next step in building a login page is to add the Log In User server behavior to verify that the entered user name and password are valid.

Verify the user name and password

You must add a Log In User server behavior to the login page to ensure that the user name and password that a user enters are valid.
When a user clicks the Submit button on the login page, the Log In User server behavior compares the values entered by the user against the values for registered users. If the values match, the server behavior opens one page (usually the site’s Welcome screen). If the values do not match, the server behavior opens another page (usually a page alerting the user that the login attempt failed).

1. In the Server Behaviors panel (Window > Server Behaviors), click the Plus (+) button and select User Authentication > Log In User from the pop-up menu.

2. Specify the form and the form objects that visitors use to enter their user name and password.

3. (ColdFusion) Enter your user name and password if applicable.

4. Specify the database table and columns that contain the user names and passwords of all the registered users.
   The server behavior compares the user name and password a visitor enters on the login page against the values in these columns.

5. Specify a page to open if the login process succeeds.
   The specified page is usually the site’s Welcome screen.

6. Specify a page to open if the login process fails.
   The specified page usually alerts the user that the login process failed and lets the user try again.

7. If you want users forwarded to the login page after attempting to access a restricted page to return to that restricted page after logging in, select the Go To Previous URL option.
   If a user tries to access your site by opening a restricted page without first logging in, the restricted page can forward the user to the login page. After the user logs in successfully, the login page redirects the user to the restricted page that forwarded them to the login page in the first place.

   *When you complete the dialog box for the Restrict Access To Page server behavior on these pages, ensure that you specify your login page in the If Access Denied, Go To box.*

8. Specify whether to grant access to the page based on user name and password alone, or based on authorization level too, and click OK.
   A server behavior is added to the login page that ensures the user name and password entered by a visitor are valid.

More Help topics

“Redirect unauthorized users” on page 620

“Building a page that only authorized users can access” on page 619

Building a page that only authorized users can access

About protected pages

Your web application can contain a protected page that only authorized users can access.

For example, if a user attempts to bypass the login page by typing the protected page’s URL in a browser, the user is redirected to another page. Similarly, if you set the authorization level for a page to Administrator only users with Administrator access privileges can view the page. If a logged-in user attempts to access the protected page without the proper access privileges, the user is redirected to another page.
You can also use authorization levels to review newly registered users before granting them full access to the site. For example, you may want to receive payment before allowing a user access to the member pages of the site. To do so, you can protect the member pages with a Member authorization level and only grant newly registered users Guest privileges. After receiving payment from the user, you can upgrade the user’s access privileges to Member (in the database table of registered users).

If you do not plan to use authorization levels, you can protect any page on your site simply by adding a Restrict Access To Page server behavior to the page. The server behavior redirects to another page any user who has not successfully logged in.

If you do plan to use authorization levels, you can protect any page on your site with the following building blocks:

- A Restrict Access To Page server behavior to redirect unauthorized users to another page
- An extra column in your users database table to store each user’s access privileges

Regardless of whether you use authorization levels, you can add a link to the protected page that lets a user log out and clears any session variables.

More Help topics
“Securing a folder in your application (ColdFusion)” on page 622

Redirect unauthorized users
To prevent unauthorized users from accessing a page, add a Restrict Access To Page server behavior to it. The server behavior redirects the user to another page if the user attempts to bypass the login page by typing the protected page’s URL in a browser, or if the user is logged in but attempts to access the protected page without the proper access privileges.

Note: The Restrict Access To Page server behavior can only protect HTML pages. It does not protect other site resources such as image files and audio files.

If you want to give many pages on your site the same access rights, you can copy and paste access rights from one page to another.

Redirect unauthorized users to another page
1. Open the page you want to protect.
2. In the Server Behaviors panel (Window > Server Behaviors), click the Plus (+) button and select User Authentication > Restrict Access To Page from the pop-up menu.
3. Select the level of access for the page. To allow only users with certain access privileges to view the page, select the Username, Password, and Access Level option and specify the authorization levels for the page.

For example, you can specify that only users with Administrator privileges can view the page by selecting Administrator in the authorization levels list.

4. To add authorization levels to the list, click Define. In the Define Access Levels list that appears, enter a new authorization level, and click the Plus (+) button. The new authorization level is stored for use with other pages.

Ensure that the string for the authorization level matches exactly the string stored in your user database. For example, if the authorization column in your database contains the value "Administrator", enter Administrator, not Admin, in the Name box.

5. To set more than one authorization level for a page, Control-click (Windows) or Command-click (Macintosh) the levels in the list.
For example, you can specify that any user with Guest, Member, or Administrator privileges can view the page.

6 Specify the page to open if an unauthorized user attempts to open the protected page.
Ensure that the page you choose is not protected.

7 Click OK.

**Copy and paste a page’s access rights to other pages on the site**
1 Open the protected page and select the Restrict Access To Page server behavior listed in the Server Behaviors panel (not the one in the Plus (+) pop-up menu).
2 Click the arrow button in the upper-right corner of the panel, and select Copy from the pop-up menu.
The Restrict Access To Page server behavior is copied to your system’s Clipboard.
3 Open another page you want to protect in the same way.
4 In the Server Behaviors panel (Window > Server Behaviors), click the arrow button in the upper-right corner, and select Paste from the pop-up menu.
5 Repeat steps 3 and 4 for each page you want to protect.

**Store access privileges in the user database**
This building block is required only if you want certain logged-in users to have different access privileges. If you simply require users to log in, you don’t have to store access privileges.

1 To provide certain logged-in users with different access privileges, make sure your database table of users contains a column specifying each user’s access privileges (Guest, User, Administrator, and so on). The access privileges of each user should be entered in the database by the site administrator.
In most database applications, you can set a column to a default value each time a new record is created. Set the default value to the most common access privilege on your site (for example, Guest); then manually change the exceptions (for example, changing Guest to Administrator). The user now has access to all administrator pages.

2 Make sure each user in the database has a single access privilege, such as Guest or Administrator, not multiple privileges like User, Administrator. To set multiple access privileges for your pages (for example, all guests and administrators can see this page), set those privileges at the page level, not the database level.

**Log out users**
When a user logs in successfully, a session variable is created that consists of the user name. When the user leaves your site, you can use the Log Out User server behavior to clear the session variable and redirect the user to another page (usually a goodbye or thank you page).

You can invoke the Log Out User server behavior when the user clicks a link or when a specific page loads.

**Add a link to let users log out**
1 Select text or an image on a page to serve as the link.
2 In the Server Behaviors panel (Window > Behaviors), click the Plus (+) button and select User Authentication > Log Out User.
3 Specify a page to open when the user clicks the link, and click OK.
The page is usually a goodbye or thank you page.
Log out users when a specific page loads
1. Open the page that will load in Dreamweaver.
   The page is usually a goodbye or thank you page.
2. In the Server Behaviors panel, click the Plus (+) button and select User Authentication > Log Out User.
3. Select the Log Out When Page Loads option, and click OK.

Securing a folder in your application (ColdFusion)

Secure a folder or site on the server (ColdFusion)
You can use Dreamweaver to password-protect a specific folder in your ColdFusion application, including the application’s root folder. When a visitor to your site requests any page in the specified folder, ColdFusion prompts the visitor for a user name and password. ColdFusion stores the user name and password in session variables so the visitor doesn’t need to enter them again during the session.

Note: This feature is available only if you have access to a computer running ColdFusion MX 7 or later.

1. With a ColdFusion document open in Dreamweaver, select Commands > ColdFusion Login Wizard.
2. Complete the ColdFusion Login Wizard.
   a. Specify the full path to the folder you want to secure and click Next.
   b. In the next screen, select one of the following authentication types:
      
      Simple Authentication  Secures your application with a single user name and password for all users.
      
      Windows NT Authentication  Secures your application using NT user names and passwords.
      
      LDAP Authentication  Secures your application with user names and passwords stored on an LDAP server.
      
   c. Specify whether you want users to log in using a ColdFusion login page or a pop-up menu.
   d. In the next screen, specify the following settings:
      • If you selected simple authentication, specify the user name and password that each visitor must enter.
      • If you selected Windows NT authentication, specify the NT domain to validate against.
      • If you selected LDAP authentication, specify the LDAP server to validate against.
3. Upload the new files to your remote site. The files are located in your local site folder.

More Help topics
“Enable the ColdFusion enhancements” on page 647
“Building a page that only authorized users can access” on page 619
“Securing a folder in your application (ColdFusion)” on page 622
Using ColdFusion components

About ColdFusion components
ColdFusion component (CFC) files let you encapsulate application and business logic into self-contained, reusable units. CFCs also provide a fast, easy way to create web services.

A CFC is a reusable software unit written in ColdFusion markup language (CFML), which makes it easy to reuse and maintain your code.

You can use Dreamweaver to work with CFCs. For information on CFC tags and syntax, see the ColdFusion documentation from within Dreamweaver (Help > Using ColdFusion).

Note: You can use CFCs only with ColdFusion MX or later. CFCs are not supported in ColdFusion 5.

CFCs are meant to provide a simple yet powerful way for developers to encapsulate elements of their websites. Generally, you should use components for application or business logic. Use customs tags for presentation elements such as customized greetings, dynamic menus, and so on.

As with many other types of construction, dynamic sites can often benefit from interchangeable parts. For example, a dynamic site may run the same query repeatedly, or calculate the total price of shopping cart pages and recalculate it every time an item is added. These tasks can be handled by components. You can fix, improve, extend, and even replace a component with minimal impact to the rest of your application.

Suppose an online store calculates shipping charges based on the price of orders. For orders under $20, the shipping charge is $4; for orders between $20 and $40, the shipping charge is $6, and so on. You could insert the logic for calculating the shipping charge in both the shopping cart page and the checkout page, but that would mix HTML presentation code and CFML logic code and generally make the code difficult to maintain and reuse.

You decide to create a CFC called Pricing that has, among other things, a function called ShippingCharge. The function takes a price as an argument and returns a shipping charge. For example, if the value of the argument is 32.80, the function returns 6.

In both the shopping cart page and the checkout page, you insert a special tag to invoke the ShippingCharge function. When the page is requested, the function is invoked and a shipping charge is returned to the page.

Later, the store announces a special promotion: free shipping for all orders above $100. You make the change to the shipping rates in one place—the ShippingCharge function of the Pricing component—and all the pages using the function automatically get accurate shipping charges.

Components panel overview (ColdFusion)
Use the Components panel (Window > Components) to view and edit ColdFusion components, and add code in the page that invokes the function when the CFM page is requested.

Note: The Components panel is available only when viewing a ColdFusion page in Dreamweaver.

More Help topics
"Build web pages that use CFCs" on page 626

Create or delete a CFC in Dreamweaver
You can use Dreamweaver to visually define a CFC and its functions. Dreamweaver creates a .cfc file and inserts the necessary CFML tags for you.
**Note:** Depending on the component, you may have to complete some code by hand.

1. Open a ColdFusion page in Dreamweaver.
2. In the Components panel (Window > Components), select CF Components from the pop-up menu.
3. Click the Plus (+) button, and complete the Create Components dialog box, and click OK.
   a. In the Components section, enter the details about the component. Here is a partial list:
      - **Name** Specifies the filename of the component. The name must contain only alphanumeric characters and underscores (_). Don’t specify the .cfc file extension when entering the name.
      - **Component Directory** Specifies where the component is saved. Select the web application’s root folder (such as \Inetpub\wwwroot\myapp\) or any of its subfolders.
   b. To define one or more functions for the component, select Functions from the Section list, click the Plus (+) button, and enter the details of the new function.
      Ensure that you specify the type of the value returned by the function in the Return Type option.
      - *If you select remote from the Access menu, the function becomes available as a web service.*
   c. To define one or more arguments for a function, select Arguments from the Section list, select the function from the pop-up menu, click the Plus (+) button, and enter the details of the new argument on the right.
4. If you use a remote development server, upload the CFC file and any dependent files (such as those used to implement a function or include files) to the remote server.

Uploading the files ensures that Dreamweaver features such as Live view and Preview In Browser work properly.

Dreamweaver writes a CFC file and saves it in the folder you specified. The new component also appears in the Components panel (after clicking Refresh).

5. To remove a component, you must delete the CFC file manually from the server.

**More Help topics**

“Build web pages that use CFCs” on page 626

“About ColdFusion components” on page 623

**View CFCs in Dreamweaver**

Dreamweaver provides a way to visually examine the ColdFusion components (CFCs) located in your site folder or on the server as a whole. Dreamweaver reads the CFC files and displays information about them in an easy-to-navigate tree view in the Components panel.

Dreamweaver looks for the components on your testing server (see “Connecting to the database in Dreamweaver” on page 517). If you create CFCs or make changes to existing CFCs, make sure to upload the CFC files to the testing server so they are accurately reflected in the Components panel.

To view components located on another server, change the testing server settings.

You can view any of the following information about your CF components:

- List all of the ColdFusion components defined on the server.
- If you’re running ColdFusion MX 7 or later, filter the list to show only the CFCs located in your site folder.
- Explore the functions and arguments of each component.
Inspect the properties of functions that serve as web services.

To use Dreamweaver to inspect CFCs residing in the server root while also managing your site files in a different website root, you can define two Dreamweaver sites. Set the first site to point to the server root and the second to point to the website root. Use the site pop-up menu on the Files panel to switch quickly between the two sites.

To view CFCs in Dreamweaver, follow these steps:

1. Open any ColdFusion page in Dreamweaver.
2. In the Components panel (Window > Components), select CF Components from the pop-up menu.
3. Click the Refresh button in the panel to retrieve the components.

The components package is displayed on the server. A component package is a folder that contains CFC files.

If existing component packages do not appear, click the Refresh button in the panel toolbar.

4. To display only the CFCs located in your site folder, click the Show Only Current Site’s CFCs button in the Components panel toolbar.

Note: This feature is available only if you’ve defined a computer running ColdFusion MX 6 or later as a testing server for Dreamweaver.

Note: If the current site is listed in a virtual folder on the remote server, the filtering does not work.

5. Click the Plus (+) button beside the package name to view the components stored in the package.
   • To list the functions of a component, click the Plus (+) button beside the component name.
   • To see the arguments a function takes, as well as the arguments’ type and whether they are required or optional, open the function’s branch in the tree view.

Functions that take no arguments have no Plus (+) button beside them.

   • To quickly view the details of an argument, a function, a component, or a package, select the item in the tree view, and click the Get Details button in the panel toolbar.

You can also right-click (Windows) or Control-click (Macintosh) the item and select Get Details from the pop-up menu.

Details about the item are displayed in a message box.

More Help topics
   “Set up a testing server” on page 45
   “Enable the ColdFusion enhancements” on page 647
   “Build web pages that use CFCs” on page 626

Edit CFCs in Dreamweaver

Dreamweaver provides a streamlined way of editing the code of the ColdFusion components defined for your site. For example, you can add, change, or delete any component function without leaving Dreamweaver.

To use this feature, your development environment must be set up as follows:

   • ColdFusion must be running locally.
   • In the advanced Site Definition dialog box in Dreamweaver, the Access type specified in the Testing Server category must be Local/Network.
In the advanced Site Definition dialog box, the path of your local root folder must be the same as the path of the testing server folder (for example, c:\Inetpub\wwwroot\cf_projects\myNewApp\). You can examine and change these paths by selecting Site > Edit Sites.

The component must be stored in the local site folder or any of its subfolders on your hard disk.

Open any ColdFusion page in Dreamweaver and display the components in the Components panel. To display the components, open the Components panel (Window > Components), select CF Components from the panel’s pop-up menu, and click the Refresh button on the panel.

Because ColdFusion is running locally, Dreamweaver displays component packages on your hard disk.

Use the following procedure to edit a component.

1. Open any ColdFusion page in Dreamweaver and display the components in the Components panel (Window > Components).
2. Select CF Components from the panel’s pop-up menu, and click the Refresh button on the panel.

Because ColdFusion is running locally, Dreamweaver displays component packages on your hard disk.

Note: To edit the CFC recordset visually, double-click it in the Bindings panel.

3. To edit a component file generally, open the package and double-click the component name in the tree view.
   The component’s file opens in Code view.
4. To edit a specific function, argument, or property, double-click the item in the tree view.
5. Make your changes by hand in Code view.
6. Save the file (File > Save).
7. To see any new function in the Components panel, refresh the view by clicking the Refresh button on the panel toolbar.

More Help topics
“View CFCs in Dreamweaver” on page 624

Build web pages that use CFCs

One way to use a component function in your web pages is to write code in the page that invokes the function when the page is requested. You can use Dreamweaver to help you write this code.

Note: For other ways to use components, see the ColdFusion documentation from within Dreamweaver (Help > Using ColdFusion).

1. In Dreamweaver, open the ColdFusion page that will use the component function.
2. Switch to Code view (View > Code).
3. Open the Components panel (Window > Components), and select CF Components from the panel’s pop-up menu.
4. Find the component you want and insert it using one of the following techniques:
   • Drag a function from the tree view to the page. Code is inserted in the page to invoke the function.
   • Select the function in the panel and click the Insert button on the panel toolbar (the second button on the right). Dreamweaver inserts the code in the page at the insertion point.
5. If you insert a function that has arguments, complete the argument code by hand.

For more information, see the ColdFusion documentation from within Dreamweaver (Help > Using ColdFusion).
Define a recordset in a CFC

Dreamweaver can help you define a recordset (also known as a ColdFusion query) in a ColdFusion component (CFC). By defining a recordset in a CFC, you don’t need to define the recordset on each page that uses it. You define the recordset once in the CFC and use the CFC on different pages.

Note: This feature is available only if you have access to a computer running ColdFusion MX 7 or later. For more information, see “Enable the ColdFusion enhancements” on page 647.

1 Create or open an existing CFC file in Dreamweaver.
2 In the Bindings panel (Window > Bindings), click the Plus (+) button and select Recordset (Query) from the pop-up menu.

The Recordset dialog box appears. You can work in either the simple or the advanced Recordset dialog boxes.
3 To use an existing function in the CFC, select the function from the Function pop-up menu and skip to step 5.

The recordset is defined in the function.
4 To define a new function in the CFC, click the New Function button, enter a name for the function in the dialog box that appears, and then click OK.

The name must contain only alphanumeric characters and underscores (_).
5 To define a recordset for the function, complete the Recordset dialog box options.

The new function is inserted into the CFC that defines the recordset.

More Help topics

“Create or delete a CFC in Dreamweaver” on page 623

Use a CFC recordset as a source of dynamic content

You can use a ColdFusion component (CFC) as a source of dynamic content for your pages if the component contains a function defining a recordset.

Note: This feature is available only if you have access to a computer running ColdFusion MX 7 or later. For more information, see Enable the ColdFusion enhancements.

1 Open a ColdFusion page in Dreamweaver.
2 In the Bindings panel (Window > Bindings), click the Plus (+) button and select Recordset (Query) from the pop-up menu.

The Recordset dialog box appears. You can work in either the simple or the advanced Recordset dialog box.
3 Click the CFC Query button.
4 Complete the CFC query dialog box, click OK, and then click OK again to add the CFC recordset to the list of available content sources in the Bindings panel.
5 Use the Bindings panel to bind the recordset to various page elements.

For more information, see “Adding dynamic content to pages” on page 556.
Define dynamic content by using a CFC

You can define a recordset as a source of dynamic content in Dreamweaver by using a CFC that contains a recordset definition.

1. In the Name box, enter a name for the CFC recordset.

A common practice is to add the prefix `rs` to recordset names to distinguish them from other object names in the code, for example: `rsPressRelease`.

Recordset names must contain only alphanumeric characters and underscores (_). You cannot use special characters or spaces.

2. Select a package from the ones already defined on the server.

If the package does not appear in the pop-up menu, you can refresh the list of packages by clicking the Refresh button near the pop-up menu.

Make sure you upload your CFCs to the testing server first. Only CFCs on the testing server are displayed.

3. Select a component from the ones defined in the currently selected package.

If the Component pop-up menu does not contain any components, or if none of your previously created components appear in the menu, you should upload the CFC files to the testing server.

4. (Optional) To create a component, click the Create New Component button.

   a. In the Name box, enter the name for the new CFC. The name must contain only alphanumeric characters and underscores (_).

   b. In the Component Directory box, enter the location for your CFC, or browse to locate the folder.

   **Note:** The folder must be the relative path to the site root folder.

5. From the Function pop-up menu, select the function that contains the recordset definition.

The Function pop-up menu contains only the functions defined in the currently selected component. If no function appears in this pop-up menu, or if your last changes are not reflected in the currently listed functions, check that your last changes were saved and uploaded to server.

**Note:** The Connection and SQL boxes are read-only.

6. Edit each parameter (type, value, and default value) that must be passed as a function argument by clicking the Edit button.

   a. Enter a value for the current parameter by selecting the value type from the Value pop-up menu and entering the value in the box to the right.

   The value type can be a URL parameter, a form variable, a cookie, a session variable, an application variable, or an entered value.

   b. Enter a default value for the parameter in the Default Value box.

   If no run-time value is returned, the default parameter value is used.

   c. Click OK.

You cannot modify the database connection and the SQL query for the recordset. These fields are always disabled—the connection and SQL query are displayed for your information.

7. Click Test to connect to the database and create an instance of the recordset.
If the SQL statement contains page parameters, ensure that the Default Value column of the Parameters box contains valid test values before clicking Test.

If the query was executed successfully, a table displays the recordset. Each row contains a record and each column represents a field in that record.

Click OK to clear the CFC Query.

8 Click OK.
Chapter 22: Building forms

When a visitor enters information into a web form displayed in a web browser and clicks the submit button, the information is sent to a server where a server-side script or application processes it. The server responds by sending the processed information back to the user (or client), or by performing some other action based on the form’s contents.

You can use Dreamweaver to create forms that submit data to most application servers, including PHP, ASP, and ColdFusion. If you use ColdFusion, you can also add ColdFusion-specific form controls to your forms. Your forms can have text fields, password fields, radio buttons, check boxes, pop-up menus, clickable buttons, and other form objects. Dreamweaver can also write code that validates the information a visitor provides. For example, you can check that an e-mail address that a user enters contains an “@” symbol, or that a required text field contains a value.

Using forms to collect information from users

About collecting information from users

You can use web forms or hypertext links to gather information from users, store that information in the server’s memory, and then use the information to create a dynamic response based on the user’s input. The most common tools for gathering user information are HTML forms and hypertext links.

**HTML forms** Let you gather information from users and store it in the server’s memory. An HTML form can send the information either as form parameters or as URL parameters.

**Hypertext links** Let you gather information from users and store it in the server’s memory. You specify a value (or values) to be submitted when a user clicks a link—a preference, for example—by appending the value to the URL specified in the anchor tag. When a user clicks the link, the browser sends the URL and the appended value to the server.

**HTML form parameters**

Form parameters are sent to the server by means of an HTML form using either the POST or GET method.

When using the POST method, parameters are sent to the web server as part of the document’s header, and are not visible or accessible to anyone who’s viewing the page using standard methods. The POST method should be used for values that affect database content (for example inserting, updating, or deleting records), or for values that are sent by email.

The GET method appends parameters to the requested URL. The parameters are in turn visible to anyone viewing the page. The GET method should be used for search forms.

You can use Dreamweaver to quickly design HTML forms that send form parameters to the server. Be aware of the method you use to transmit information from the browser to the server.

Form parameters take the names of their corresponding form objects. For example, if your form contains a text field named `txtLastName`, then the following form parameter is sent to the server when the user clicks the Submit button:

```
txtLastName=enteredvalue
```
In cases where a web application expects a precise parameter value (for example, when it performs an action based on one of several options), use a radio button, check box, or list/menu form object to control the values the user can submit. This prevents users from typing information incorrectly and causing an application error. The following example depicts a pop-up menu form offering three choices:

Each menu choice corresponds to a hard-coded value that is submitted as a form parameter to the server. The List Values dialog box in the following example matches each list item to a value (Add, Update, or Delete):

After a form parameter is created, Dreamweaver can retrieve the value and use it in a web application. After defining the form parameter in Dreamweaver, you can insert its value within a page.

**More Help topics**

“Creating web forms” on page 633

“Adding dynamic content to pages” on page 556

“Accessing a database” on page 507

**URL parameters**

URL parameters let you pass user-supplied information from the browser to the server. When a server receives a request and parameters are appended to the URL of the request, the server gives the requested page access to the parameters before serving that page to the browser.

A URL parameter is a name-value pair appended to a URL. The parameter begins with a question mark (?) and takes the form `name=value`. If more than one URL parameter exists, each parameter is separated by an ampersand (&). The following example shows a URL parameter with two name-value pairs:

http://server/path/document?name1=value1&name2=value2
In this example workflow, the application is a web-based storefront. Because the developers of the site want to reach the widest possible audience, the site is designed to support foreign currencies. When users log in to the site, they can select the currency in which to view the prices of the available items.

1. The browser requests the report.cfm page from the server. The request includes the URL parameter Currency="euro". The Currency="euro" variable specifies that all monetary amounts retrieved be displayed as the European Union euro.

2. The server temporarily stores the URL parameter in memory.

3. The report.cfm page uses the parameter to retrieve the cost of items in euros. These monetary amounts can either be stored in a database table of different currencies, or converted from a single currency associated with each item (any currency supported by the application).

4. The server sends the report.cfm page to the browser and displays the value of items in the requested currency. When this user ends the session, the server clears the value of the URL parameter, freeing server memory to hold new user requests.

URL parameters are also created when the HTTP GET method is used in conjunction with an HTML form. The GET method specifies that the parameter value be appended to the URL request when the form is submitted.

Typical uses of URL parameters include personalizing websites based on user preferences. For example, a URL parameter consisting of a user name and password can be used to authenticate a user, displaying only information that user has subscribed to. Common examples of this include financial websites that display individual stock prices based on stock market symbols the user has previously chosen. Web application developers commonly use URL parameters to pass values to variables within applications. For example, you could pass search terms to SQL variables in a web application to generate search results.

Creating URL parameters using HTML links

You create URL parameters within an HTML link by using the href attribute of the HTML anchor tag. You can enter the URL parameters directly in the attribute in Code view (View > Code), or by appending the URL parameters at the end of the link URL in the Property inspector Link box.

In the following example, three links create a single URL parameter (action) with three possible values (Add, Update, and Delete). When the user clicks a link, a parameter value is sent to the server, and the requested action is performed.
<a href="http://www.mysite.com/index.cfm?action=Add">Add a record</a>
<a href="http://www.mysite.com/index.cfm?action=Update">Update a record</a>
<a href="http://www.mysite.com/index.cfm?action=Delete">Delete a record</a>

The Property inspector (Window > Properties) lets you create the same URL parameters by selecting the link and appending the URL parameter values at the end of the link URL in the Link box.

![Property inspector](image)

After a URL parameter is created, Dreamweaver can retrieve the value and use it in a web application. After defining the URL parameter in Dreamweaver, you can insert its value within a page.

**More Help topics**
- “About URL and form parameters” on page 537
- “Linking” on page 263
- “Define form parameters” on page 550
- “Adding dynamic content to pages” on page 556
- “Accessing a database” on page 507

### Creating web forms

**About web forms**

When a visitor enters information into a web form displayed in a web browser and clicks the submit button, the information is sent to a server where a server-side script or application processes it. The server responds by sending the processed information back to the user (or client), or by performing some other action based on the form’s contents.

You can create forms that submit data to most application servers, including PHP, ASP, and ColdFusion. If you use ColdFusion, you can also add ColdFusion-specific form controls to your forms.

**Note:** You can also send form data directly to an e-mail recipient.

**More Help topics**
- “Using forms to collect information from users” on page 630
- “Building ColdFusion forms” on page 646
Form objects

In Dreamweaver, form input types are called *form objects*. Form objects are the mechanisms that allow users to input data. You can add the following form objects to a form:

**Text fields** Accept any type of alphanumeric text entry. The text can be displayed as a single line, multiple lines, and as a password field where entered text is replaced by asterisks or bullets to hide the text from onlookers.

![Image of text fields]

*Note:* Passwords and other information sent to a server using a password field are not encrypted. The transferred data can be intercepted and read as alphanumeric text. For this reason, you should always provide encryption for data you want to keep secure.

**Hidden fields** Store information entered by a user, such as a name, e-mail address, or viewing preference, and then use that data when the user next visits the site.

**Buttons** Perform actions when clicked. You can add a custom name or label for a button, or use one of the predefined “Submit” or “Reset” labels. Use a button to submit form data to the server or to reset the form. You can also assign other processing tasks that you define in a script. For example, the button might calculate the total cost of items selected based on assigned values.

**Check boxes** Allow multiple responses within a single group of options. A user can select as many options as apply. The following example shows three check box items selected: Surfing, Mountain Biking, and Rafting.

![Image of check boxes]
Radio buttons  Represent exclusive choices. Selecting a button within a radio button group deselects all others in the group (a group consists of two or more buttons that share the same name). In the example below, Rafting is the currently selected option. If the user clicks Surfing, the Rafting button is automatically cleared.

![Radio Buttons](image)

List menus  Display option values within a scrolling list that allows users to select multiple options. The List option displays the option values in a menu that allows users to select only a single item. Use menus when you have a limited amount of space, but must display many items, or to control the values returned to the server. Unlike text fields where users can type anything they want, including invalid data, you set the exact values returned by a menu.

**Note:** A pop-up menu on an HTML form is not the same as a graphical pop-up menu. For information on creating, editing, and showing and hiding a graphical pop-up menu, see the link at the end of this section.

Jump menus  Navigational lists or pop-up menus that let you insert a menu in which each option links to a document or file.

File fields  Let users browse to a file on their computer and upload the file as form data.

Image fields  Let you insert an image in a form. Use image fields to make graphical buttons such as Submit or Reset buttons. Using an image to perform tasks other than submitting data requires attaching a behavior to the form object.

More Help topics

“Apply the Show Pop-Up Menu behavior” on page 344

Create an HTML form

1. Open a page and place the insertion point where you want the form to appear.
2. Select Insert > Form, or select the Forms category in the Insert panel and click the Form icon.

In Design view, forms are indicated by a dotted red outline. If you don’t see this outline, select View > Visual Aids > Invisible Elements.

3. Set the properties of the HTML form in the Property inspector (Window > Properties):
   a. In the Document window, click the form outline to select the form.
   b. In the Form Name box, type a unique name to identify the form.

Naming a form makes it possible to reference or control the form with a scripting language, such as JavaScript or VBScript. If you do not name the form, Dreamweaver generates a name using the syntax formn, and increments the value of n for each form added to the page.

   c. In the Action box, specify the page or script that will process the form data by typing the path, or clicking the folder icon to navigate to the appropriate page or script. Example: processorder.php.
In the Method pop-up menu, specify the method to transmit the form data to the server. Set any of the following options:

**Default** Uses the browser’s default setting to send the form data to the server. Typically, the default value is the **GET** method.

**GET** Appends the value to the URL requesting the page.

**POST** Embeds the form data in the HTTP request.

Do not use the **GET** method to send long forms. URLs are limited to 8192 characters. If the amount of data sent is too large, data will be truncated, leading to unexpected or failed processing results.

Dynamic pages generated by parameters passed by the **GET** method can be bookmarked because all the values needed to regenerate the page are contained in the URL displayed in the browser’s Address box. In contrast, dynamic pages generated by parameters passed by the **POST** method cannot be bookmarked.

If you collect confidential user names and passwords, credit card numbers, or other confidential information, the **POST** method may appear more secure than the **GET** method. However, the information sent by the **POST** method is not encrypted and can easily be retrieved by a hacker. To ensure security, use a secure connection to a secure server.

(Optional) In the Enctype pop-up menu, specify the MIME encoding type of the data submitted to the server for processing.

The default setting of `application/x-www-form-urlencoded` is typically used in conjunction with the **POST** method. If you are creating a file-upload field, specify the `multipart/form-data` MIME type.

(Optional) In the Target pop-up menu, specify the window in which to display the data returned by the invoked program.

If the named window is not already open, a new window with that name opens. Set any of the following target values:

- **_blank** Opens the destination document in a new unnamed window.
- **_parent** Opens the destination document in the parent window of the one displaying the current document.
- **_self** Opens the destination document in the same window as the one in which the form was submitted.
- **_top** Opens the destination document in the body of the current window. This value can be used to ensure that the destination document takes over the full window even if the original document was displayed in a frame.

Insert form objects in the page:

- Place the insertion point where the form object should appear in the form.
- Select the object in the Insert > Form menu, or in the Forms category of the Insert panel.
- Complete the Input Tag Accessibility Attributes dialog box. For more information, click the Help button in the dialog box.

**Note:** If you don’t see the Input Tag Accessibility Attributes dialog box, you might have had the Insertion point in Code view when you tried to insert the form object. Make sure the Insertion point is in Design view and try again. For more information on this topic, see David Powers’s article *Creating HTML forms in Dreamweaver*.

Set the properties of the objects.

Enter a name for the object in the Property inspector.

Every text field, hidden field, check box, and list/menu object must have a unique name that identifies the object in the form. Form object names cannot contain spaces or special characters. You can use any combination of alphanumeric characters and an underscore (_). The label you assign to the object is the variable name that stores the value (the entered data) of the field. This is the value sent to the server for processing.
Note: All radio buttons in a group must have the same name.

To label the text field, check box, or radio button object on the page, click beside the object and type the label.

Adjust the layout of the form.

Use line breaks, paragraph breaks, preformatted text, or tables to format your forms. You cannot insert a form in another form (that is, you cannot overlap tags), but you can include more than one form in a page.

When designing forms, remember to label the form fields with descriptive text to let users know what they’re responding to—for example, “Type your name” to request name information.

Use tables to provide structure for form objects and field labels. When using tables in forms make sure all the table tags are included between the form tags.

For a tutorial on creating forms, see www.adobe.com/go/vid0160.

For a tutorial on styling forms with CSS, see www.adobe.com/go/vid0161.

More Help topics
“Using forms to collect information from users” on page 630
“Define form parameters” on page 550
“Define URL parameters” on page 549
“Building ColdFusion forms” on page 646
“Building Spry pages visually” on page 407
Creating forms tutorial
Styling forms tutorial

Text Field object properties
Select the text field object, and set any of the following options in the Property inspector:

Char Width  Specifies the maximum number of characters that can be displayed in the field. This number can be less than Max Chars, which specifies the maximum number of characters that can be entered in the field. For example, if the Char Width is set to 20 (the default value) and a user enters 100 characters, only 20 of those characters will be viewable in the text field. Although you cannot view the characters in the field, they are recognized by the field object and are sent to the server for processing.

Max Chars  Specifies the maximum number of characters that the user can enter in the field for single-line text fields. Use Max Chars to limit zip codes to 5 digits, limit passwords to 10 characters, and so on. If you leave the Max Chars box blank, users can enter any amount of text. If the text exceeds the character width of the field the text will scroll. If a user exceeds the maximum number of characters, the form produces an alert sound.

Num Lines  (Available when the Multiline option is selected) Sets the height of the field for multiple-line text fields.

Disabled  Disables the text area.

Read-only  Makes the text area a read-only text area.

Type  Designates the field as a single-line, multiple-line, or password field.

- Single-line  Results in an input tag with its type attribute set to text. The Char Width setting maps to the size attribute, and the Max Chars setting maps to the maxlength attribute.

- Multi-line  Results in a textarea tag. The Char Width setting maps to the cols attribute, and the Num Lines setting maps to the rows attribute.
• **Password**  Results in an input tag with its type attribute set to password. The Char Width and Max Chars settings map to the same attributes as in single-line text fields. When a user types in a password text field, the input appears as bullets or asterisks to protect it from observation by others.

**Init val**  Assigns the value displayed in the field when the form first loads. For example, you might indicate that the user enters information in the field by including a note or example value.

**Class**  Lets you apply CSS rules to the object.

### Button object options

**Button Name**  Assigns a name to the button. Two reserved names, Submit and Reset, tell the form to submit the form data to the processing application or script, or to reset all the form fields to their original values, respectively.

**Value**  Determines the text that appears on the button.

**Action**  Determines what happens when the button is clicked.

• **Submit Form**  Submits the form data for processing when the user clicks the button. The data is submitted to the page or script specified in the form’s Action property.

• **Reset Form**  Clears the contents of the form when the button is clicked.

• **None**  Specifies the action to be performed when the button is clicked. For example, you can add a JavaScript behavior that opens another page when the user clicks the button.

**Class**  Applies CSS rules to the object.

### Check Box object options

**Checked Value**  Sets the value to be sent to the server when the check box is checked. For example, in a survey you might set a value of 4 for strongly agree and a value of 1 for strongly disagree.

**Initial State**  Determines whether the check box is selected when the form loads in the browser.

**Dynamic**  Lets the server dynamically determine the initial state of the check box. For example, you can use check boxes to visually present the Yes/No information stored in a database record. At design time, you don’t know that information. At run time the server reads the database record and selects the check box if the value is Yes.

**Class**  Applies CSS rules to the object.

### Single radio button object options

**Checked Value**  Sets the value to be sent to the server when the radio button is selected. For example, you might type **skiing** in the Checked Value box to indicate a user chose skiing.

**Initial State**  Determines whether the radio button is selected when the form loads in the browser.

**Dynamic**  Lets the server dynamically determine the initial state of the radio button. For example, you can use radio buttons to visually present information stored in a database record. At design time, you don’t know that information. At run time the server reads the database record and checks the radio button if the value matches one you specified.

**Class**  Applies CSS rules to the object.

### Menu options

**List/Menu**  Assigns a name to the menu. The name must be unique.
Type Indicates whether the menu drops down when clicked (the Menu option) or displays a scrollable list of items (the List option). Select the Menu option if you want only one option to be visible when the form is displayed in a browser. To display the other choices, the user must click the down arrow.

Select the List option to list some or all the options when the form is displayed in a browser, to let users select multiple items.

Height (List type only) Sets the number of items displayed in the menu.

Selections (List type only) Indicates whether the user can select multiple items from the list.

List Values Opens a dialog box that lets you add the items to a form menu:

1. Use the Plus (+) and Minus (–) buttons to add and remove items in the list.
2. Enter label text and an optional value for each menu item.
   - Each item in the list has a label (the text that appears in the list) and a value (the value that is sent to the processing application if the item is selected). If no value is specified, the label is sent to the processing application instead.
3. Use the up and down arrow buttons to rearrange items in the list.
   - Items appear in the menu in the same order as they appear in the List Values dialog box. The first item on the list is the selected item when the page is loaded in a browser.

Dynamic Lets the server dynamically select an item in the menu when it is first displayed.

Class Lets you apply CSS rules to the object.

Initially Selected Sets the items selected in the list by default. Click the item or items in the list.

Insert file-upload fields

You can create a file-upload field that lets users select a file on their computer—such as a word processing document or graphics file—and upload the file to the server. A file field looks like other text fields except it also contains a Browse button. The user either manually enters the path to the file they want to upload, or uses the Browse button to locate and select the file.

Before you can use file-upload fields, you must have a server-side script or a page capable of handling file submissions. Consult the documentation of the server technology you use to process form data. For example, if you use PHP, see “Handling files uploads” in the online PHP Manual at http://us2.php.net/features.file-upload.php.

File fields require that you use the POST method to transmit files from the browser to the server. The file is posted to the address you specify in the form’s Action box.

Note: Contact your server’s administrator to confirm that anonymous file uploads are allowed before using the file field.

1. Insert a form in the page (Insert > Form).
2. Select the form to display its Property inspector.
3. Set the form Method to POST.
4. From the Enctype pop-up menu, select multipart/form-data.
5. In the Action box, specify the server-side script or page capable of handling the uploaded file.
6. Place the insertion point inside the form outline, and select Insert > Form > File Field.
7. Set any of the following options in the Property inspector:
   - File Field Name Specifies the name for the file field object.
   - Char Width Specifies the maximum number of characters that can be displayed in the field.
Max Chars  Specifies the maximum number of characters the field will hold. If the user browses to locate the file, the filename and path can exceed the specified Max Chars value. However, if the user attempts to type in the filename and path, the file field will only allow the number of characters specified by the Max Chars value.

**Insert an image button**
You can use images as button icons. Using an image to perform tasks other than submitting data requires attaching a behavior to the form object.

1  In the document, place the insertion point inside the form outline.
2  Select Insert > Form > Image Field.

The Select Image Source dialog box appears.
3  Select the image for the button in the Select Image Source dialog box, and click OK.
4  Set any of the following options in the Property inspector:

   - **ImageField**  Assigns a name to the button. Two reserved names, Submit and Reset, tell the form to submit the form data to the processing application or script, or to reset all the form fields to their original values, respectively.
   - **Src**  Specifies the image you want to use for the button.
   - **Alt**  Lets you enter descriptive text in case the image fails to load in the browser.
   - **Align**  Sets the align attribute of the object.
   - **Edit Image**  Starts your default image editor and opens the image file for editing.
   - **Class**  Lets you apply CSS rules to the object.

5  To attach a JavaScript behavior to the button, select the image, and then select the behavior in the Behaviors panel (Window > Behaviors).

### Hidden field object options

- **HiddenField**  Specifies the name for the field.
- **Value**  Assigns a value to the field. This value is passed to the server when the form is submitted.

**Insert a group of radio buttons**

1  Place the insertion point inside the form outline.
2  Select Insert > Form > Radio Group.
3  Complete the dialog box and click OK.
   a  In the Name box, enter a name for the radio button group.
   b  Click the Plus (+) button to add a radio button to the group. Enter a label and checked value for the new button.
   c  Click the up or down arrows to reorder the buttons.
   d  To set a particular radio button to be selected when the page opens in a browser, enter a value equal to the radio button’s value in the Select Value Equal To box.
Enter a static value or specify a dynamic one by clicking the lightning bolt icon beside the box and selecting a recordset that contains possible checked values. In either case, the value you specify should match the checked value of one of the radio buttons in the group. To view the checked values of the radio buttons, select each radio button and open its Property inspector (Window > Properties).

e Select the format in which you want Dreamweaver to lay out the buttons.

Lay out the buttons using line breaks or a table. If you select the table option, Dreamweaver creates a single-column table, and places the radio buttons on the left and the labels on the right.

You can also set the properties in the Property inspector or directly in Code view.

**Insert a group of check boxes**

1. Place the insertion point inside the form outline.
2. Select Insert > Form > Checkbox Group.
3. Complete the dialog box and click OK.

a In the Name box, enter a name for the check box group.

If you set the check boxes to pass parameters back to the server, the parameters are associated with the name. For example, if you name the group `myGroup` and set the form method to `GET` (that is, you want the form to pass URL parameters instead of form parameters when the user clicks the submit button), the expression `myGroup="CheckedValue"` is passed in the URL to the server.

b Click the Plus (+) button to add a check box to the group. Enter a label and checked value for the new check box.

c Click the up or down arrows to reorder the check boxes.

d To set a particular check box to be selected when the page opens in a browser, enter a value equal to the check box’s value in the Select Value Equal To box.

Enter a static value or specify a dynamic one by clicking the lightning bolt icon beside the box and selecting a recordset that contains possible checked values. In either case, the value you specify should match the checked value of one of the check boxes in the group. To view the checked values of the check boxes, select each check box and open its Property inspector (Window > Properties).

e Select the format in which you want Dreamweaver to lay out the check boxes.

Lay out the check boxes using line breaks or a table. If you select the table option, Dreamweaver creates a single-column table, and places the check boxes on the left and the labels on the right.

You can also set the properties in the Property inspector or directly in Code view.

**About dynamic form objects**

A **dynamic form object** is a form object whose initial state is determined by the server when the page is requested from the server, not by the form designer at design time. For example, when a user requests a PHP page that contains a form with a menu, a PHP script in the page automatically populates the menu with values stored in a database. The server then sends the completed page to the user’s browser.

Making form objects dynamic can simplify site maintenance. For example, many sites use menus to present users with a set of options. If the menu is dynamic, you can add, remove, or change menu items in a single place—the database table in which the items are stored—to update all instances of the same menu on the site.

**More Help topics**

“Defining sources of dynamic content” on page 543
Insert or change a dynamic HTML form menu
You can dynamically populate an HTML form menu or list menu with entries from a database. For most pages, you can use an HTML menu object.

Before you begin, you must insert an HTML form in a ColdFusion, PHP, or ASP page, and you must define a recordset or other source of dynamic content for the menu.

1 Insert an HTML List/Menu form object in your page:
   a Click inside the HTML form on the page (Insert > Form > Form).
   b Select Insert > Form > List/Menu to insert the form object.

2 Do one of the following:
   • Select the new or an existing HTML List/Menu form object, and then click the Dynamic button in the Property inspector.
   • Select Insert > Data Objects > Dynamic Data > Dynamic Select List.

3 Complete the Dynamic List/Menu dialog box, and click OK.
   a In the Options From Recordset pop-up menu, select the recordset to use as a content source. You also use this menu to edit both static and dynamic list/menu items later.
   b In the Static Options area, enter a default item in the list or menu. Also, use this option to edit static entries in a list/menu form object after adding dynamic content.
   c (Optional) Use the Plus (+) and Minus (–) buttons to add and remove items in the list. Items are in the same order as in the Initial List Values dialog box. The first item on the list is the selected item when the page is loaded in a browser. Use the up and down arrow buttons to rearrange items in the list.
   d In the Values pop-up menu, select the field containing the values of the menu items.
   e In the Labels pop-up menu, select the field containing the labels for the menu items.
   f (Optional) To specify that a particular menu item is selected when the page opens in a browser or when a record is displayed in the form, enter a value equal to the menu item’s value, in the Select Value Equal To box.

You can enter a static value or you can specify a dynamic one by clicking the lightning bolt icon beside the box, and selecting a dynamic value from the list of data sources. In either case, the value you specify should match one of the menu item values.

Make existing HTML form menus dynamic
1 In Design view, select the list/menu form object.
2 In Property inspector, click the Dynamic button.
3 Complete the dialog box, and click OK.

Display dynamic content in HTML text fields
You can display dynamic content in HTML text fields when the form is viewed in a browser.

Before you begin, you must create the form in a ColdFusion, PHP, or ASP page, and you must define a recordset or other source of dynamic content for the text field.

1 Select the text field in the HTML form on your page.
2 In the Property inspector, click the lightning bolt icon beside the Init Val box to display the Dynamic Data dialog box.
3 Select the recordset column that will supply a value to the text field, and then click OK.

**Set the Dynamic Text Field dialog box options**

1 Select the text field to make dynamic from the Text Field pop-up menu.
2 Click the lightning bolt icon beside the Set Value To box, select a data source from the list of data sources, and click OK. The data source should contain textual information. If no data sources appear in the list, or if the available data sources don’t meet your needs, click the Plus (+) button to define a new data source.

**More Help topics**

“Defining sources of dynamic content” on page 543

**Dynamically preselect an HTML check box**

You can let the server decide whether to select a check box when the form is displayed in a browser.

Before you begin, you must create the form in a ColdFusion, PHP, or ASP page, and you must define a recordset or other source of dynamic content for the check boxes. Ideally, the source of content should contain Boolean data, such as Yes/No or true/false.

1 Select a check box form object on your page.
2 In the Property inspector, click the Dynamic button.
3 Complete the Dynamic CheckBox dialog box, and click OK:
   • Click the lightning bolt icon beside the Check If box and select the field from the list of data sources.
   The data source must contain Boolean data such as Yes and No, or true and false. If no data sources appear in the list, or if the available data sources don’t meet your needs, click the Plus (+) button to define a new data source.
   • In the Equal To box, enter the value the field must have for the check box to appear selected.
   For example, for the check box to appear selected when a specific field in a record has a value of Yes, enter Yes in the Equal To box.

   **Note:** This value is also returned to the server if the user clicks the form’s Submit button.

**Dynamically preselect an HTML radio button**

Dynamically preselect an HTML radio button when a record is displayed in the HTML form in a browser.

Before you begin, you must create the form in a ColdFusion, PHP, or ASP page, and insert at least one group of HTML radio buttons (Insert > Form > Radio Group). You must also define a recordset or other source of dynamic content for the radio buttons. Ideally, the source of content should contain Boolean data, such as Yes/No or true/false.

1 In Design view, select a radio button in the radio group.
2 In the Property inspector, click the Dynamic button.
3 Complete the Dynamic Radio Group dialog box, and click OK.

**Set the Dynamic Radio Group dialog box options**

1 In the Radio Button Group pop-up menu, select a form and radio button group in the page.
The Radio Button Value box displays the values of all radio buttons in the group.
2 Select a value to dynamically preselect from the list of values. This value is displayed in the Value box.

3 Click the lightning bolt icon beside the Select Value Equal To box and select a recordset that contains possible checked values for the radio buttons in the group.

The recordset you select contains values that match the radio buttons' checked values. To view the checked values of the radio buttons, select each radio button and open its Property inspector (Window > Properties).

4 Click OK.

**Set the Dynamic Radio Group dialog box options (ColdFusion)**

1 Select a radio group and form from the Radio Group pop-up menu.

2 Click the lightning bolt icon next to Select Value Equal To box.

3 Complete the Dynamic Data dialog box, and click OK.

   a Select a data source from the list of data sources.

   b (Optional) Select a data format for the text.

   c (Optional) Modify the code that Dreamweaver inserts in your page to display the dynamic text.

4 Click OK to close the Dynamic Radio Group dialog box, and insert the dynamic content placeholder in the Radio Group.

**Validate HTML form data**

Dreamweaver can add JavaScript code that checks the contents of specified text fields to ensure that the user has entered the correct type of data.

You can use Spry form widgets to build your forms and validate the contents of specified form elements. For more information, consult the Spry topics listed below.

You can also build ColdFusion forms in Dreamweaver that validate the contents of specified fields. For more information, consult the ColdFusion chapter listed below.

1 Create an HTML form that includes at least one text field and one Submit button.

Make sure every text field that you want to validate has a unique name.

2 Select the Submit button.

3 In the Behaviors panel (Window > Behaviors), click the Plus (+) button and select the Validate Form behavior from the list.

4 Set the validation rules for each text field, and click OK.

For example, you might specify that a text field for a person's age accepts only numbers.

*Note:* The Validate Form behavior is available only if a text field has been inserted into the document.

**More Help topics**

“Working with the Spry Validation Text Field widget” on page 427

“Working with the Spry Validation Text Area widget” on page 431

“Working with the Spry Validation Select widget” on page 435

“Working with the Spry Validation Checkbox widget” on page 438

“Validate ColdFusion form data” on page 658
**Attach JavaScript behaviors to HTML form objects**
You can attach JavaScript behaviors stored in Dreamweaver to HTML form objects such as buttons.

1. Select the HTML form object.
2. In the Behaviors panel (Window > Behaviors), click the Plus (+) button, and select a behavior from the list.

**Attach custom scripts to HTML form buttons**
Some forms use JavaScript or VBScript to perform form processing or some other action on the client as opposed to sending the form data to the server for processing. You can use Dreamweaver to configure a form button to run a specific client-side script when the user clicks the button.

1. Select a Submit button in a form.
2. In the Behaviors panel (Window > Behaviors), click the Plus (+) button, and select Call JavaScript from the list.
3. In the Call JavaScript box, enter the name of the JavaScript function to run when the user clicks the button, and click OK.

For example, you can enter the name of a function that doesn’t exist yet, such as `processMyForm()`.

4. If your JavaScript function doesn’t exist in the head section of the document yet, add it now.

For example, you could define the following JavaScript function in the head section of the document to display a message when the user clicks the Submit button:

```javascript
function processMyForm()
{
    alert('Thanks for your order!');
}
```

**More Help topics**
“Apply the Call JavaScript behavior” on page 336

**Create accessible HTML forms**
When you insert an HTML form object, you can make the form object accessible, and change the accessibility attributes later.

**Add an accessible form object**
1. The first time you add accessible form objects, activate the Accessibility dialog box for form objects (see “Optimizing the workspace for visual development” on page 532).

This is a one-time-only step.
2. In the document, place the insertion point where you want the form object to appear.
3. Select Insert > Form, and select a form object to insert.

The Input Tag Accessibility Attributes dialog box appears.

4. Complete the dialog box, and click OK. Here is a partial list of options:

   **Note:** The screen reader reads the name you enter as the Label attribute for the object.

   **ID** assigns an ID to the form field. This value can be used to refer to the field from JavaScript; it's also used as the value of the `for` attribute if you choose the Attach Label Tag Using For option under the Style options.

   **Wrap With Label Tag** Wraps a label tag around the form item, as follows:
<label>
<input type="radio" name="radiobutton" value="radiobutton">
RadioButton1</label>

**Attach Label Tag Using For** Uses the `for` attribute to wrap a label tag around the form item, as follows:

<input type="radio" name="radiobutton" value="radiobutton" id="radiobutton">
<label for="radiobutton">RadioButton2</label>

This choice causes the browser to render text associated with a check box and radio button with a focus rectangle, and enables the user to select the check box and radio button by clicking anywhere in the associated text instead of just the check box or radio button control.

**Note:** This is the preferred option for accessibility; however, the functionality may vary depending on the browser.

**No Label Tag** Does not use a label tag, as follows:

<input type="radio" name="radiobutton" value="radiobutton">
RadioButton3

**Access Key** Uses a keyboard equivalent (one letter) and the Alt key (Windows) or the Control key (Macintosh) to select the form object in the browser. For example, if you enter `B` as the Access Key, users with a Macintosh browser could type Control+B to select the form object.

**Tab Index** Specifies a tab order for the form objects. If you set tab order for one object, you must set the tab order for all objects.

Setting a tab order is useful when you have other links and form objects on the page and need the user to tab through them in a specific order.

5 Click Yes to insert a form tag.

The form object appears in the document.

**Note:** If you press Cancel, the form object appears in the document, but Dreamweaver does not associate accessibility tags or attributes with it.

**Edit accessibility values for a form object**

1 In the Document window, select the object.

2 Do one of the following:
   - Edit the appropriate attributes in Code view.
   - Right-click (Windows) or Control-click (Macintosh), and then select Edit Tag.

---

**Building ColdFusion forms**

**About ColdFusion forms**

ColdFusion forms provide you with several built-in mechanisms to validate form data. For example, you can check to make sure a user has entered a valid date. Some form controls have additional features. Several do not have HTML counterparts, and others directly support dynamically populating the control from data sources.
Dreamweaver provides a number of enhancements for ColdFusion developers who use ColdFusion MX 7 or later as their development server. These enhancements include more Insert panel buttons, menu items, and Property inspectors so that you can rapidly build and set the properties of ColdFusion forms. You can also generate code that validates the information provided by site visitors. For example, you can check that the e-mail address provided by a user contains the @ symbol, or that a required text field contains a certain type of value.

Enable the ColdFusion enhancements

Some of these enhancements require that you define a computer running ColdFusion MX 7 or later as a testing server for Dreamweaver. For example, the Property inspectors for form controls are available only if you specify the correct testing server.

You define a testing server only once. Dreamweaver then automatically detects the testing server version and makes the enhancements available if it detects ColdFusion.

1. If you haven’t already done so, define a Dreamweaver site for your ColdFusion project.
2. Select Site > Manage Sites, select your site from the list, and click Edit.
3. Select the Servers category and specify a computer running ColdFusion MX 7 or later as the testing server for your Dreamweaver site. Ensure that you specify a valid Web URL.
4. Open any ColdFusion document.

You won’t see any visible changes to the Dreamweaver workspace until you open a ColdFusion document.

More Help topics
“Securing a folder in your application (ColdFusion)” on page 622
“Working with Dreamweaver sites” on page 36
“Set up a testing server” on page 45

Create ColdFusion forms

You can use a number of Insert panel buttons, menu items, and Property inspectors to rapidly create ColdFusion forms and set their properties in Dreamweaver.

Note: These enhancements are available only if you have access to a computer running ColdFusion MX 7 or later.

1. Open a ColdFusion page and place the insertion point where you want the ColdFusion form to appear.
2. Select Insert > ColdFusion Objects > CFForm > CFForm, or select the CFForm category from the Insert panel and click the CF Form icon.

Dreamweaver inserts an empty ColdFusion form. In Design view, the form is indicated by a dotted red outline. If you don’t see this outline, make sure that View > Visual Aids > Invisible Elements is selected.

3. Ensure that the form is still selected, and then use the Property inspector to set any of the following form properties.

CFForm Sets the name of the form.

Action Lets you specify the name of the ColdFusion page to be processed when the form is submitted.

Method Lets you define the method that the browser uses to send the form data to the server:

• POST Sends the data using the HTTP post method; this method sends the data in a separate message to the server.
• GET Sends the data using the HTTP get method, placing the form field contents in the URL query string.

Target Lets you to modify the value of the target attribute of the cfform tag.
Encoding Type  Specifies the encoding method used for transmitting the form data.

Note: Encoding type does not refer to character encoding. This attribute specifies the content type used to submit the form to the server (when the value of method is post). The default value for this attribute is application/x-www-form-urlencoded.

Format  Determines what kind of form is created:

- **HTML** Generates an HTML form and sends it to the client. The cfgrid and cftree child controls can be in Flash or applet format.

- **Flash** Generates a Flash form and sends it to the client. All controls are in Flash format.

- **XML** Generates XForms XML and puts the results in a variable with the ColdFusion form name. Does not send anything to the client. The cfgrid and cftree child controls can be in Flash or applet format.

Style  Lets you specify a style for the form. For more information, see the ColdFusion documentation.

Flash/XML Skin  Lets you specify a halo color to stylize the output. The theme determines the color used for highlighted and selected elements.

Preserve Data  Determines whether to override the initial control values with submitted values when the form posts to itself.

- **If False**, values specified in the control tag attributes are used.
- **If True**, submitted values are used.

Scripts src  Specifies the URL, relative to the web root, of the JavaScript file that contains client-side code used by the tag and its child tags. This attribute is useful if the file is not in the default location. This attribute may be required in some hosting environments and configurations that block access to the /CFIDE directory. The default location is set in the ColdFusion Administrator; by default, it is /CFIDE/scripts/cfform.js.

Archive  Specifies the URL of downloadable Java classes for cfgrid, cfslider, and cftree applet controls. The default location is /CFIDE/classes/cfapplets.jar.

Height  Specifies the height of the form.

Width  Specifies the width of the form.

Display Tag Editor for cfform  Lets you edit properties not listed in the Property inspector.

4  Insert ColdFusion form controls.

Place the insertion point where you want the ColdFusion form control to appear in the ColdFusion form, and then select the control from the Insert menu (Insert > ColdFusion Objects > CFForm), or from the CFForm category in the Insert panel.

5  If required, set the properties of the control with the Property inspector.

Make sure the control is selected in Design view and then set the properties in the Property inspector. For more information on the properties, click the Help icon in the Property inspector.

6  Adjust the layout of the ColdFusion form.

If you’re creating an HTML-based form, you can use line breaks, paragraph breaks, preformatted text, or tables to format your forms. You cannot insert a ColdFusion form in another ColdFusion form (that is, you cannot overlap tags), but you can include more than one ColdFusion form in a page.

If you’re creating a Flash-based form, use

Cascading Style Sheets
Building forms

(CSS) styles to lay out your form. ColdFusion ignores any HTML in the form.

Remember to label the ColdFusion form fields with descriptive text to let users know what they are responding to. For example, create a “Type your name label” to request name information.

More Help topics
“Validate ColdFusion form data” on page 658
“Create an HTML form” on page 635

Insert ColdFusion form controls
Use the Insert panel or Insert menu to quickly insert ColdFusion form controls into a ColdFusion form. You need to create a blank ColdFusion form before inserting controls in it.

Note: These enhancements are only available if you have access to a computer running ColdFusion MX 7 or later.

1 In Design view, place the insertion point inside the form outline.
2 Select the control from the Insert menu (Insert > ColdFusion Objects > CFForm), or from the CFForm category in the Insert panel.
3 Click the control on the page to select it and then set its properties in the Property inspector.

For information on the properties of specific controls, see the topics about the controls.

More Help topics
“Modify ColdFusion form controls” on page 657
“Validate ColdFusion form data” on page 658

Insert ColdFusion text fields
You can visually insert a ColdFusion text field or password field into your form, and then set its options.

Note: This enhancement is available only if you have access to a computer running ColdFusion MX 7 or later.

Visually insert a ColdFusion text field
1 In Design view, place the insertion point inside the form outline.
2 In the CFForm category of the Insert panel, click the CF Text Field icon or select Insert > ColdFusion Objects > CFForm > CFtextfield.

A text field appears in the form.
3 Select the text field and set its properties in the Property inspector.
4 To label the text field on the page, click beside it and enter text for the label.

Visually insert a password field
1 Repeat steps 1 and 2 in the previous procedure for inserting a text field.
2 Select the inserted text field to display its Property inspector.
3 Select the Password value from the Text Mode pop-up menu in the Property inspector.
CFTextField options (ColdFusion)
To set the options of a ColdFusion text or password field, set any of the following options in the CFTextField Property inspector:

**CFTextField** Sets the id attribute of the `<cfinput>` tag.

**Value** Lets you specify text to be displayed in the field when the page first opens in a browser. The information can either be static or dynamic.

To specify a dynamic value, click the lightning bolt icon beside the Value box and select a recordset column in the Dynamic Data dialog box. The recordset column supplies a value to the text field when you view the form in a browser.

**Text Mode** Lets you switch between the standard text input field and the password input field. The attribute modified by this control is `type`.

**Read Only** Lets you make the displayed text read-only.

**Max Length** Sets the maximum number of characters accepted by the text field.

**Mask** Lets you specify a mask for your requested text. You use this property to validate the user input. The mask format is composed of A, 9, X and ? characters.

*Note:* The mask attribute is ignored for the `cfinput type="password"` tag.

**Validate** Specifies the type of validation for the current field.

**Validate At** Specifies when the field is validated: onSubmit, onBlur or onServer.

**Label** Lets you specify a label for the text field.

**Pattern** Lets you specify a JavaScript regular expression pattern to validate input. Omit leading and trailing slashes.

For more information, see the ColdFusion documentation.

**Height** Lets you specify the height of the control, in pixels.

**Width** Lets you specify the width of the control, in pixels.

**Size** Lets you specify the size of the control.

**Required** Lets you specify whether the text field must contain data before the form is submitted to the server.

**Display Tag Editor** Lets you edit properties not listed in the Property inspector.

Insert ColdFusion hidden fields
You can visually insert a ColdFusion hidden field into your form and set its properties. Use hidden fields to store and submit information that the user does not enter. The information is hidden from the user.

*Note:* This enhancement is available only if you have access to a computer running ColdFusion MX 7 or later.

1. In Design view, place the insertion point inside the form outline.
2. In the CFForm category of the Insert panel, click the CF Hidden Field icon.

A marker appears in the ColdFusion form. If you don't see the marker, select View > Visual Aids > Invisible Elements.

3. Select the hidden field on the page and set any of the following options in the Property inspector:

**Cfhiddenfield** Lets you specify the unique name for the hidden field.

**Value** Lets you specify a value for the hidden field. The data can either be static or dynamic.

To specify a dynamic value, click the lightning bolt icon beside the Value box and select a recordset column in the Dynamic Data dialog box. The recordset column supplies a value to the text field when you view the form in a browser.
**Validate** Specifies the type of validation for the current field.

**Validate At** Specifies when the field is validated: onSubmit, onBlur or onServer.

**Label** Lets you specify a label for the control. This property is ignored by the ColdFusion server at run time.

**Pattern** Lets you specify a JavaScript regular expression pattern to validate input. Omit leading and trailing slashes. For more information, see the ColdFusion documentation.

**Height** Lets you specify the height of the control, in pixels. This property is ignored by the ColdFusion server at run time.

**Width** Lets you specify the width of the control, in pixels. This property is ignored by the ColdFusion server at run time.

**Size** Lets you specify the size of the control. This property is ignored by the ColdFusion server at run time.

**Required** Lets you specify whether the hidden field must contain data before the form is submitted to the server.

**Display Tag Editor** Lets you edit properties not listed in the Property inspector.

**More Help topics**

“Modify ColdFusion form controls” on page 657

---

**Insert ColdFusion text areas**

You can visually insert a ColdFusion text area into your form and set its properties. A text area is an input element that consists of multiple lines of text.

**Note:** This enhancement is available only if you have access to a computer running ColdFusion MX 7 or later.

1. Place the insertion point inside the form outline.
2. In the CFForm category of the Insert panel, click the CF Text Area icon.
A text area appears in the ColdFusion form.
3. Select the text area on the page and set any of the following options in the Property inspector:

**Cftextarea** Lets you specify a unique name for the control.

**Char Width** Lets you set the number of characters per line.

**Num Lines** Lets you set the number of rows to display in the text area.

**Wrap** Lets you specify how you want the text entered by users to wrap.

**Required** Lets you specify whether the user must enter data in the field (checked) or not (unchecked).

**Initial Value** Lets you specify text to display in the text area when the page is initially opened in a browser.

**Validate** Specifies the type of validation for the field.

**Validate At** Specifies when the field is validated: onSubmit, onBlur, or onServer.

**Label** Lets you specify a label for the control.

**Style** Lets you specify a style for the control. For more information, see the ColdFusion documentation.

**Height** Lets you specify the height of the control, in pixels. This property is ignored by the ColdFusion server at run time.

**Width** Lets you specify the width of the control, in pixels. This property is ignored by the ColdFusion server at run time.

**Display Tag Editor** Lets you edit properties not listed in the Property inspector.
To label the text area, click beside it and enter text for the label.

More Help topics
“Validate ColdFusion form data” on page 658
“Modify ColdFusion form controls” on page 657

Insert ColdFusion buttons
You can visually insert a ColdFusion button into your form and set its properties. ColdFusion buttons control ColdFusion form operations. Buttons can be used to submit ColdFusion form data to the server or to reset the ColdFusion form. Standard ColdFusion buttons are typically labeled Submit, Reset, or Send. You can also assign other processing tasks that you defined in a script. For example, the button might calculate the total cost of selected items based on assigned values.

Note: This enhancement is available only if you have access to a computer running ColdFusion MX 7 or later.

1 Place the insertion point inside the ColdFusion form outline.
2 In the CFForm category of the Insert panel, click the CF Button icon.
A button appears in the ColdFusion form.
3 Select the button on the page and set any of the following options in the Property inspector:
Cfbutton Lets you specify a unique name for the control.
Action Lets you specify the type of button to create.
Display Tag Editor Lets you edit properties not listed in the Property inspector.
The other properties are ignored by the ColdFusion server at run time.

More Help topics
“Modify ColdFusion form controls” on page 657

Insert ColdFusion check boxes
You can visually insert a ColdFusion check box into your form and set its properties. Use check boxes to let users select more than one option from a set of options.

Note: This enhancement is available only if you have access to a computer running ColdFusion MX 7 or later.

1 Place the insertion point inside the form outline.
2 In the CFForm category of the Insert panel, click the CF Checkbox icon.
A check box appears in the ColdFusion form.
3 Select the check box on the page and set any of the following options in the Property inspector:
Cfcheckbox Lets you specify a unique name for the control.
Checked Value Lets you specify a value to be returned by the check box if the user checks it.
Initial State Lets you specify whether the check box is checked when the page first opens in a browser.
Validate Specifies the type of validation for the check box.
Validate At Specifies when the check box is validated: onSubmit, onBlur, or onServer.
Label  Lets you specify a label for the check box.

Pattern  Lets you specify a JavaScript regular expression pattern to validate input. Omit leading and trailing slashes. For more information, see the ColdFusion documentation.

Height  Lets you specify the height of the control, in pixels. This property is ignored by the ColdFusion server at run time.

Width  Lets you specify the width of the control, in pixels. This property is ignored by the ColdFusion server at run time.

Size  Lets you specify the size of the control. This property is ignored by the ColdFusion server at run time.

Required  Lets you specify whether the checkbox must be checked before the form is submitted to the server.

Display Tag Editor  Lets you edit properties not listed in the Property inspector.

4  To label the check box, click next to the check box on the page and enter text for the label.

More Help topics
“Modify ColdFusion form controls” on page 657
“Validate ColdFusion form data” on page 658

Insert ColdFusion radio buttons
You can visually insert a ColdFusion radio button into your form and set its properties. Use radio buttons when you want users to select only one choice from a set of options. Radio buttons are typically used in groups. All radio buttons in a group must have the same name.

Note: This enhancement is available only if you have access to a computer running ColdFusion MX 7 or later.

1  Place the insertion point inside the form outline.

2  Select Insert > ColdFusion Objects > CFForm > CFradiobutton.
A radio button appears in the ColdFusion form.

3  Select the radio button on the page and set any of the following options in the Property inspector:

Cfradiobutton  Lets you specify a unique name for the control.

Checked Value  Lets you specify a value to be returned by the radio button if the user checks it.

Initial State  Lets you specify whether the radio button is checked when the page first opens in a browser.

Validate  Specifies the type of validation for the radio button.

Validate At  Specifies when the radio button is validated: on Submit, on Blur, or on Server.

Label  Lets you specify a label for the radio button.

Pattern  Lets you specify a JavaScript regular expression pattern to validate input. Omit leading and trailing slashes. For more information, see the ColdFusion documentation.

Height  Lets you specify the height of the control, in pixels. This property is ignored by the ColdFusion server at run time.

Width  Lets you specify the width of the control, in pixels. This property is ignored by the ColdFusion server at run time.

Size  Lets you specify the size of the control. This property is ignored by the ColdFusion server at run time.

Required  Lets you specify whether the radio button must be checked before the form is submitted to the server.

Display Tag Editor  Lets you edit properties not listed in the Property inspector.

4  To label the radio button, click beside it on the page and enter text for the label.
Insert ColdFusion select boxes

You can visually insert a ColdFusion select box into your form and set its properties. A select box lets a visitor select one or more items from a list. Select boxes are useful when you have a limited amount of space, but need to display many items. They're also useful when you want to control the values returned to the server. Unlike text fields, where users can type anything they want, including invalid data, with select boxes, you can set the exact values returned by a menu.

You can insert two types of select boxes into a form: a menu that “drops down” when the user clicks it, or a menu that displays a scrollable list of items that the user can select.

Note: This enhancement is available only if you have access to a computer running ColdFusion MX 7 or later.

1. Place the insertion point inside the form outline.
2. In the CFForm category of the Insert panel, click the CF Select icon.
   A select box appears in the ColdFusion form.
3. Select the select box on the page and set any of the following options in the Property inspector:

   **Cfselect**  Lets you specify a unique name for the control.
   **Type**  Lets you choose between a pop-up menu or a list. If you select the list type, the List Height and Allow Multiple List Selections options become available.
   **List Height**  Lets you specify the number of lines to display in the list menu. Available only if you select the list type.
   **Allow Multiple List Selections**  Lets you specify whether the user can select more than one option from the list at a time. Available only if you select the list type.
   **Edit Values**  Opens a dialog box that lets you add, edit, or remove options from the select box.
   **Initially Selected**  Lets you specify which option is selected by default. You can select more than one option if you selected the Allow Multiple List Selections option.
   **Recordset**  Lets you specify the name of the ColdFusion query you want to use to populate the list or menu.
   **Display Column**  Lets you specify the recordset column to supply the display label of each list element. Used with Recordset property.
   **Value Column**  Lets you specify the recordset column to supply the value of each list element. Used with the Recordset property.
   **Flash Label**  Lets you specify a label for the select box.
   **Flash Height**  Lets you specify the height of the control, in pixels. This property is ignored by the ColdFusion server at run time.
   **Flash Width**  Lets you specify the width of the control, in pixels. This property is ignored by the ColdFusion server at run time.
   **Message**  Specifies the message to be displayed if the Required property is set to Yes and the user failed to make a selection before submitting the form.
   **Required**  Lets you specify whether a menu item must be selected before the form is submitted to the server.
   **Display Tag Editor**  Lets you edit properties not listed in the Property inspector.
Insert ColdFusion image fields

You can visually insert a ColdFusion image field into your form and set its options. Use image fields to make custom buttons.

**Note:** This enhancement is available only if you have access to a computer running ColdFusion MX 7 or later.

1. In Design view, place the insertion point inside the form outline.
2. In the CFForm category of the Insert panel, click the CF Image Field icon. Browse to select the image to insert, and click OK. Alternatively, you can enter the path of the image file in the Src box.

**Note:** If the image is outside the site root folder, you should copy the image to the root folder. Images outside the root folder might not be accessible when you publish the site.

3. Select the image field on the page and set any of the following options in the Property inspector:

   - **Cfimagefield** lets you specify a unique name for the control.
   - **Src** lets you specify the URL of the inserted image.
   - **Alt** lets you specify a message when the image cannot be displayed.
   - **Align** lets you specify the alignment of the picture.
   - **Border** lets you set the width of the image border.
   - **Edit Image** opens the image in your default image editor.

   To define a default image editor, select Edit > Preferences > File Types / Editors. Otherwise, the Edit Image button does not perform any action.

   - **Validate** specifies the type of validation for the image field.
   - **Validate At** specifies when the field is validated: onSubmit, onBlur, or onServer.
   - **Label** lets you specify a label for the radio button.
   - **Pattern** lets you specify a JavaScript regular expression pattern to validate input. Omit leading and trailing slashes. For more information, see the ColdFusion documentation.
   - **Height** lets you specify the height of the control, in pixels.
   - **Width** lets you specify the width of the control, in pixels.
   - **Size** lets you specify the size of the control. This property is ignored by the ColdFusion server at run time.
   - **Required** lets you specify whether the control must contain data before the form is submitted to the server.
   - **Display Tag Editor** lets you edit properties not listed in the Property inspector.

More Help topics

“Modify ColdFusion form controls” on page 657

“Validate ColdFusion form data” on page 658
Insert ColdFusion file fields

You can visually insert a ColdFusion file field into your form and set its properties. Use a file field to let users select a file from their computer, such as a word processing document or a graphics file, and upload it to the server. A ColdFusion file field looks like other text fields, except it also has a Browse button. Users can manually enter the path to the file they want to upload, or use the Browse button to locate and select the file.

File fields require that you use the POST method to transmit files from the browser to the server. The file is posted to the address that you specify in the form’s Action box. Contact your server administrator to confirm that anonymous file uploads are allowed before using a file field in your form.

File fields also require that the form encoding be set to multipart/form. Dreamweaver sets this automatically when you insert a file field control.

Note: This enhancement is available only if you have access to a computer running ColdFusion MX 7 or later.

1 In Design view, select the CFForm to display its Property inspector.

To quickly select the form, click anywhere in the form outline and click the <cfform> tag in the tag selector at the bottom of the Document window.

2 In the Property inspector, set the form method to POST.

3 From the Enctype pop-up menu, select multipart/form-data.

4 Position the insertion point inside the form outline where you want to file field to appear.

5 Select Insert > ColdFusion Objects > CFForm > CFfilefield.

A file field appears in the document.

6 Select the file field on the page and set any of the following properties in the Property inspector:

   - Cffilefield Lets you specify a unique name for the control.
   - Max Length Lets you specify the maximum number of characters that the path to the file can have.
   - Validate Specifies the type of validation for the field.
   - Validate At Specifies when the field is validated: onSubmit, onBlur, or onServer.
   - Label Lets you specify a label for the field.
   - Pattern Lets you specify a JavaScript regular expression pattern to validate input. Omit leading and trailing slashes. For more information, see the ColdFusion documentation.
   - Height Lets you specify the height of the control, in pixels. This property is ignored by the ColdFusion server at run time.
   - Width Lets you specify the width of the control, in pixels. This property is ignored by the ColdFusion server at run time.
   - Size Lets you specify the size of the control.
   - Required Lets you specify whether the file field must contain data before the form is submitted to the server.
   - Display Tag Editor Lets you edit properties not listed in the Property inspector.

More Help topics

“Modify ColdFusion form controls” on page 657

“Validate ColdFusion form data” on page 658
Insert ColdFusion date fields

Although you can’t visually insert a ColdFusion date field in Dreamweaver, you can visually set its properties. A ColdFusion date field is a special type of text field that lets users select a date from a pop-up calendar to insert it in the text field.

*Note: This enhancement is available only if you have access to a computer running ColdFusion MX 7 or later.*

1. In Design view, select the CFForm to display its Property inspector.
   
   To quickly select the form, click anywhere in the form outline and click the `<cfform>` tag in the tag selector at the bottom of the Document window.

2. In the Property inspector, set the form’s Format property to Flash.
   
   The date field control can only be rendered in Flash-based ColdFusion forms.

3. Switch to Code view (View > Code) and enter the following tag anywhere between the opening and closing CFForm tags:
   ```html
   <cfinput name="datefield" type="datefield">
   ```

4. Switch to Design view, select the date field on the page, and then set any of the following options in the Property inspector:

   - **Cfdatefield**  Lets you specify a unique name for the control.
   - **Value**  Lets you specify a date to be displayed in the field when the page first opens in a browser. The date can either be static or dynamic.
     
     To specify a dynamic value, click the lightning bolt icon beside the Value box and select a recordset column in the Dynamic Data dialog box. The recordset column supplies a value to the date field when you view the form in a browser.
   - **Validate**  Specifies the type of validation for the field.
   - **Validate At**  Specifies when the field is validated: onSubmit, onBlur, or onServer.
   - **Label**  Lets you specify a label for the field.
   - **Pattern**  Lets you specify a JavaScript regular expression pattern to validate input. Omit leading and trailing slashes. For more information, see the ColdFusion documentation.
   - **Height**  Lets you specify the height of the control, in pixels.
   - **Width**  Lets you specify the width of the control, in pixels.
   - **Size**  Lets you specify the size of the control.
   - **Required**  Lets you specify whether the date field must contain a value before the form is submitted to the server.
   - **Display Tag Editor**  Lets you edit properties not listed in the Property inspector.

More Help topics

“Validate ColdFusion form data” on page 658

Modify ColdFusion form controls

You can visually change the properties of ColdFusion form controls whether you’re working in Design view or Code view.

*Note: This enhancement is available only if you have access to a computer running ColdFusion MX 7 or later.*

1. In Design view, select the form control on the page; in Code view, click anywhere inside the control’s tag.
   
   The Property inspector displays properties of the form control.
2 Change the control’s properties in the Property inspector.
   For more information, click the Help icon in the Property inspector.

3 To set more properties, click the Display Tag Editor button in the Property inspector and set the properties in the
   Tag editor that appears.

**Validate ColdFusion form data**
You can build ColdFusion forms in Dreamweaver that check the contents of specified fields to ensure the user entered
the correct data type.

*Note: This enhancement is available only if you have access to a computer running ColdFusion MX 7 or later.*

1 Create a ColdFusion form that includes at least one input field and one Submit button. Ensure that every
   ColdFusion field that you want to validate has a unique name.

2 Select a field in the form that you want to validate.

3 In the Property inspector, specify how you want to validate the field.

   The lower part of each input Property inspector contains controls to help you define the specific validation rule. For
   example, you might want to specify that a text field should contain a telephone number. To do this, select Telephone
   from the Value pop-up menu in the Property inspector. You can also specify when to validate from the Validate At
   pop-up menu.
Chapter 23: Accessibility

Dreamweaver and accessibility

About accessible content
Accessibility refers to making websites and web products usable for people with visual, auditory, motor, and other disabilities. Examples of accessibility features for software products and websites include screen reader support, text equivalents for graphics, keyboard shortcuts, change of display colors to high contrast, and so on. Dreamweaver provides tools that make it accessible to use and tools that help you author accessible content.

For Dreamweaver developers who need to use accessibility features, the application offers screen reader support, keyboard navigation, and operating system accessibility support.

For web designers who need to create accessible content, Dreamweaver assists you in creating accessible pages that contain useful content for screen readers and comply with federal government guidelines. For example, dialog boxes prompt you to enter accessibility attributes—such as text equivalents for an image—when you insert page elements. Then, when the image appears on a page for a user with visual disabilities, the screen reader reads the description.

Note: For more information about two significant accessibility initiatives, see the World Wide Web Consortium Web Accessibility Initiative (www.w3.org/wai) and Section 508 of the U.S. Federal Rehabilitation Act (www.section508.gov).

No authoring tool can automate the development process. Designing accessible websites requires you to understand accessibility requirements and make ongoing decisions about how users with disabilities interact with web pages. The best way to ensure that a website is accessible is through deliberate planning, development, testing, and evaluation.

Using screen readers with Dreamweaver
A screen reader recites text that appears on the computer screen. It also reads non-textual information, such as button labels or image descriptions in the application, provided in accessibility tags or attributes during authoring.

As a Dreamweaver designer, you can use a screen reader to assist you in creating your web pages. The screen reader starts reading from the upper-left corner of the Document window.

Dreamweaver supports JAWS for Windows, from Freedom Scientific (www.freedomscientific.com), and WindowEyes screen readers, from GW Micro (www.gwmicro.com).

Support for operating system accessibility features
Dreamweaver supports accessibility features in both the Windows and Macintosh operating systems. For example, on the Macintosh you set the visual preferences in the Universal Access Preferences dialog box (Apple > System Preferences). Your settings are reflected in the Dreamweaver work space.

The Windows operating system’s high contrast setting is also supported. You activate this option through the Windows Control Panel and it affects Dreamweaver as follows:

• Dialog boxes and panels use system color settings. For example, if you set the color to White on Black, all Dreamweaver dialog boxes and panels appear with a white foreground color and black background.

• Code view uses the system and window text color. For example, if you set the system color to White on Black, and then change text colors in Edit > Preferences > Code Coloring, Dreamweaver ignores those color settings and displays the code text with a white foreground color and black background.
Design view uses the background and text colors you set in Modify > Page Properties so that pages you design render colors as a browser will.

**Optimize the work space for accessible page design**

When you create accessible pages, you need to associate information, such as labels and descriptions, with your page objects to make your content accessible to all users.

To do this, activate the Accessibility dialog box for each object, so that Dreamweaver prompts you for accessibility information when you insert objects. You can activate a dialog box for any of the objects in the Accessibility category in Preferences.

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).
2. Select Accessibility from the Category list on the left, select an object, set any of the following options, and click OK.
   - **Show Attributes When Inserting**: Select the objects for which you want to activate accessibility dialog boxes. For example, form objects, frames, media, and images.
   - **Keep Focus In The Panel**: Maintains focus on the panel, which makes it accessible to the screen reader. (If you don’t select this option, the focus remains in Design or Code view when a user opens a panel.)
   - **Offscreen Rendering**: Select this option when using a screen reader.

   *Note: Accessibility attributes appear in the Insert Table dialog box when you insert a new table.*

**Dreamweaver accessibility validation report feature**

The Dreamweaver accessibility validation report feature has been deprecated as of Dreamweaver CS5.

**Navigate Dreamweaver using the keyboard**

You can use the keyboard to navigate panels, inspectors, dialog boxes, frames, and tables without a mouse.

*Note: Tabbing and the use of arrow keys are supported for Windows only.*

**Navigate panels**

1. In the Document window, press Control+F6 to shift focus to a panel.

   A dotted line around the panel title indicates that focus is on that panel. The screen reader reads the panel title bar that has focus.

2. Press Control+F6 again to shift focus until you have focus on the panel you want to work in. (Press Control+Shift+F6 to shift focus to the previous panel.)

3. If the panel you want to work in is not open, use the keyboard shortcuts in the Windows menu to display the appropriate panel; then press Control+F6.

   If the panel you want to work in is open, but not expanded, place focus on the panel title bar, and then press the Spacebar. Press the Spacebar again to collapse the panel.

4. Press the Tab key to move through the options in the panel.

5. Use the arrow keys as appropriate:

   - If an option has choices, use the arrow keys to scroll through the choices, and then press the Spacebar to make a selection.
If there are tabs in the panel group to open other panels, place focus on the open tab, and then use the left or right arrow key to open another tabs. Once you open a new tab, press the Tab key to move through the options in that panel.

**Navigate the Property inspector**
1. Press Control+F3 to display the Property inspector, if it is not visible.
2. Press Control+F6 (Windows only) until you shift focus to the Property inspector.
3. Press the Tab key to move through the Property inspector options.
4. Use the arrow keys as appropriate to move through option choices.
5. Press Control+Down arrow/Up arrow (Windows) or Command Down arrow/Up arrow (Macintosh) to open and close the expanded section of the Property inspector, as necessary, or, with focus on the expander arrow in the lower-right corner, press the Spacebar.

*Note:* Keyboard focus must be inside the Property inspector (and not on the panel title) for expanding and collapsing to work.

**Navigate a dialog box**
1. Press the Tab key to move through the options in a dialog box.
2. Use the arrow keys to move through choices for an option.
3. If the dialog box has a Category list, press Control+Tab (Windows) to shift focus to the category list, and then use the arrow keys to move up or down the list.
4. Press Control+Tab again to shift to the options for a category.
5. Press Enter to exit the dialog box.

**Navigate frames**
❖ If your document contains frames, you can use the arrow keys to shift focus to a frame.

**Select a frame**
1. Press Alt+Down Arrow to place the insertion point in the Document window.
2. Press Alt+Up Arrow to select the frame that currently has focus.
3. Continue pressing Alt+Up Arrow to shift focus to the frameset, and then to the parent framesets, if there are nested framesets.
4. Press Alt+Down Arrow to shift focus to a child frameset or a single frame within the frameset.
5. With focus on a single frame, press Alt+Left or Right Arrow to move between frames.

**Navigate a table**
1. Use the arrow keys or press Tab to move to other cells in a table as necessary.
   *Pressing Tab in a right-most cell adds another row to the table.*
2. To select a cell, press Control+A (Windows only) while the insertion point is in the cell.
3. To select the entire table, press Control+A twice if the insertion point is in a cell, or once if a cell is selected.
4. To exit the table, press Control+A three times if the insertion point is in a cell, twice if the cell is selected, or once if the table is selected, and then press the Up, Left, or Right Arrow key.