# Contents

**Chapter 1: Getting started**
- Adobe Help ........................................................................................................... 1
- Resources ............................................................................................................ 3

**Chapter 2: Introducing Adobe Device Central**
- Using Adobe Device Central .................................................................................. 7
- Change preferences ............................................................................................... 9

**Chapter 3: Managing device profiles**
- Working with devices ............................................................................................ 11
- Search the Available Devices list .......................................................................... 12
- Work with devices and device sets ........................................................................ 13

**Chapter 4: Create, preview, and test content in Adobe Device Central**
- Creating and previewing mobile content with Adobe Device Central .................... 16
- Tips for creating content for mobile devices ......................................................... 20
- Testing with the Emulator tab ............................................................................... 30
- Using the Testing panels ...................................................................................... 32
- Testing information for Flash ................................................................................ 36

**Index** .................................................................................................................... 42
Chapter 1: Getting started

Before you begin working with your software, take a few moments to read an overview of Adobe® Help and of the many resources available to users. You have access to instructional videos, plug-ins, templates, user communities, seminars, tutorials, RSS feeds, and much more.

Adobe Help

Adobe Help resources
Documentation for your Adobe software is available in a variety of formats.

In-product and LiveDocs Help
In-product Help provides access to all documentation and instructional content available at the time the software ships. It is available through the Help menu in your Adobe software.

LiveDocs Help includes all the content from in-product Help, plus updates and links to additional instructional content available on the web. For some products, you can also add comments to the topics in LiveDocs Help. Find LiveDocs Help for your product in the Adobe Help Resource Center, at www.adobe.com/go/documentation.

Most versions of in-product and LiveDocs Help let you search across the Help systems of multiple products. Topics may also contain links to relevant content on the web or to topics in the Help of another product.

Think of Help, both in the product and on the web, as a hub for accessing additional content and communities of users. The most complete and up-to-date version of Help is always on the web.

PDF documentation
The in-product Help is also available as a PDF that is optimized for printing. Other documents, such as installation guides and white papers, may also be provided as PDFs.

All PDF documentation is available through the Adobe Help Resource Center, at www.adobe.com/go/documentation. To see the PDF documentation included with your software, look in the Documents folder on the installation or content DVD.

Printed documentation

A printed workflow guide is included with all Adobe Creative Suite® 3 products, and stand-alone Adobe products may include a printed getting started guide.

Using Help in the product
In-product Help is available through the Help menu. After you start the Adobe Help Viewer, click Browse to see Help for additional Adobe products installed on your computer.

These Help features facilitate cross-product learning:

- Topics may contain links to the Help systems of other Adobe products or to additional content on the web.
• Some topics are shared across two or more products. For instance, if you see a Help topic with a Photoshop® icon and an After Effects® icon, you know that the topic either describes functionality that is similar in the two products or describes cross-product workflows.

• You can search across the Help systems of multiple products.

  If you search for a phrase, such as “shape tool,” enclose it in quotation marks to see only those topics that include all the words in the phrase.

**Accessibility features**
Adobe Help content is accessible to people with disabilities—such as mobility impairments, blindness, and low vision. In-product Help supports these standard accessibility features:

• The user can change text size with standard context menu commands.
• Links are underlined for easy recognition.
• If link text doesn’t match the title of the destination, the title is referenced in the Title attribute of the Anchor tag. For example, the Previous and Next links include the titles of the previous and next topics.
• Content supports high-contrast mode.
• Graphics without captions include alternate text.
• Each frame has a title to indicate its purpose.
• Standard HTML tags define content structure for screen reading or text-to-speech tools.
• Style sheets control formatting, so there are no embedded fonts.

**Keyboard shortcuts for Help toolbar controls (Windows)**
- **Back button**  Alt+Left Arrow
- **Forward button**  Alt+Right Arrow
- **Print**  Ctrl+P
- **About button**  Ctrl+I
- **Browse menu**  Alt+Down Arrow or Alt+Up Arrow to view Help for another application
- **Search box**  Ctrl+S to place cursor in Search box

**Keyboard shortcuts for Help navigation (Windows)**
• To move between panes, press Ctrl+Tab (forward) and Shift+Ctrl+Tab (backward).
• To move through and outline links in a pane, press Tab (forward) or Shift+Tab (backward).
• To activate an outlined link, press Enter.
• To make text bigger, press Ctrl+equal sign.
• To make text smaller, press Ctrl+hyphen.
Resources

Adobe Video Workshop
The Adobe Creative Suite® 3 Video Workshop offers over 200 training videos covering a wide range of subjects for print, web, and video professionals.

You can use the Video Workshop to learn about any Creative Suite 3 product. Many videos show you how to use Adobe applications together.

When you start the Video Workshop, you choose the products you want to learn and the subjects you want to view. You can see details about each video to focus and direct your learning.

Community of presenters
With this release, Adobe Systems invited the community of its users to share their expertise and insights. Adobe and lynda.com present tutorials, tips, and tricks from leading designers and developers such as Joe Lowery, Katrin Eismann, and Chris Georgenes. You can see and hear Adobe experts such as Lynn Grillo, Greg Rewis, and Russell Brown. In all, over 30 product experts share their knowledge.

Tutorials and source files
The Video Workshop includes training for novices and experienced users. You’ll also find videos on new features and key techniques. Each video covers a single subject and typically runs about 3-5 minutes. Most videos come with an illustrated tutorial and source files, so you can print out detailed steps and try the tutorial on your own.

Using Adobe Video Workshop
You can access Adobe Video Workshop using the DVD included with your Creative Suite 3 product. It’s also available online at www.adobe.com/go/learn_videotutorials. Adobe will regularly add new videos to the online Video Workshop, so check in to see what’s new.

Adobe Device Central 1.1 videos
Adobe Video Workshop covers many subjects for Adobe Device Central 1.1, including these:
- Using Device Central with Photoshop
- Using Device Central with Flash®
- Using Device Central and Bridge
- Creating mobile content

To access Adobe Creative Suite 3 video tutorials, visit Adobe Video Workshop at www.adobe.com/go/learn_videotutorials.

Extras
You have access to a wide variety of resources that will help you make the most of your Adobe software. Some of these resources are installed on your computer during the setup process; additional helpful samples and documents are included on the installation or content DVD. Unique extras are also offered online by the Adobe Exchange community, at www.adobe.com/go/exchange.
Installed resources
During software installation, a number of resources are placed in your application folder. To view those files, navigate to the application folder on your computer.

- **Windows**: [startup drive]/Program files/Adobe/Adobe [application]
- **Mac OS**: [startup drive]/Applications/Adobe [application]

The application folder may contain the following resources:

**Plug-ins**  Plug-in modules are small software programs that extend or add features to your software. Once installed, plug-in modules appear as options in the Import or Export menu; as file formats in the Open, Save As, and Export Original dialog boxes; or as filters in the Filter submenus. For example, a number of special effects plug-ins are automatically installed in the Plug-ins folder inside the Photoshop CS3 folder.

**Presets**  Presets include a wide variety of useful tools, preferences, effects, and images. Product presets include brushes, swatches, color groups, symbols, custom shapes, graphic and layer styles, patterns, textures, actions, workspaces, and more. Preset content can be found throughout the user interface. Some presets (for example, Photoshop Brush libraries) become available only when you select the corresponding tool. If you don't want to create an effect or image from scratch, go to the preset libraries for inspiration.

**Templates**  Template files can be opened and viewed from Adobe Bridge, opened from the Welcome Screen, or opened directly from the File menu. Depending on the product, template files range from letterheads, newsletters, and websites to DVD menus and video buttons. Each template file is professionally constructed and represents a best-use example of product features. Templates can be a valuable resource when you need to jump-start a project.

**Samples**  Sample files include more complicated designs and are a great way to see new features in action. These files demonstrate the range of creative possibilities available to you.

**Fonts**  Several OpenType® fonts and font families are included with your Creative Suite product. Fonts are copied to your computer during installation:

- **Windows**: [startup drive]/Program Files/Common Files/Adobe/Fonts
- **Mac OS X**: [startup drive]/Library/Application Support/Adobe/Fonts

For information about installing fonts, see the Read Me file on the installation DVD.

**DVD content**
The installation or content DVD included with your product contains additional resources for use with your software. The Goodies folder contains product-specific files such as templates, images, presets, actions, plug-ins, and effects, along with subfolders for Fonts and Stock Photography. The Documentation folder contains a PDF version of the Help, technical information, and other documents such as specimen sheets, reference guides, and specialized feature information.

**Adobe Exchange**
For more free content, visit [www.adobe.com/go/exchange](http://www.adobe.com/go/exchange), an online community where users download and share thousands of free actions, extensions, plug-ins, and other content for use with Adobe products.

**Bridge Home**
Bridge Home, a new destination in Adobe Bridge CS3, provides up-to-date information on all your Adobe Creative Suite 3 software in one convenient location. Start Adobe Bridge, then click the Bridge Home icon at the top of the Favorites panel to access the latest tips, news, and resources for your Creative Suite tools.

*Note: Bridge Home may not be available in all languages.*
Adobe Design Center
Adobe Design Center offers articles, inspiration, and instruction from industry experts, top designers and Adobe publishing partners. New content is added monthly.

You can find hundreds of tutorials for design products and learn tips and techniques through videos, HTML tutorials, and sample book chapters.

New ideas are the heart of Think Tank, Dialog Box, and Gallery:

- Think Tank articles consider how today's designers engage with technology and what their experiences mean for design, design tools, and society.
- In Dialog Box, experts share new ideas in motion graphics and digital design.
- The Gallery showcases how artists communicate design in motion.


Adobe Developer Center
Adobe Developer Center provides samples, tutorials, articles, and community resources for developers who build rich Internet applications, websites, mobile content, and other projects using Adobe products. The Developer Center also contains resources for developers who develop plug-ins for Adobe products.

In addition to sample code and tutorials, you'll find RSS feeds, online seminars, SDKs, scripting guides, and other technical resources.


Customer support
Visit the Adobe Support website, at www.adobe.com/support, to find troubleshooting information for your product and to learn about free and paid technical support options. Follow the Training link for access to Adobe Press books, a variety of training resources, Adobe software certification programs, and more.

Downloads
Visit www.adobe.com/go/downloads to find free updates, tryouts, and other useful software. In addition, the Adobe Store (at www.adobe.com/go/store) provides access to thousands of plug-ins from third-party developers, helping you to automate tasks, customize workflows, create specialized professional effects, and more.

Adobe Labs
Adobe Labs gives you the opportunity to experience and evaluate new and emerging technologies and products from Adobe.

At Adobe Labs, you have access to resources such as these:

- Prerelease software and technologies
- Code samples and best practices to accelerate your learning
- Early versions of product and technical documentation
- Forums, wiki-based content, and other collaborative resources to help you interact with like-minded developers
Adobe Labs fosters a collaborative software development process. In this environment, customers quickly become productive with new products and technologies. Adobe Labs is also a forum for early feedback, which the Adobe development teams use to create software that meets the needs and expectations of the community.


**User communities**

User communities feature forums, blogs, and other avenues for users to share technologies, tools, and information. Users can ask questions and find out how others are getting the most out of their software. User-to-user forums are available in English, French, German, and Japanese; blogs are posted in a wide range of languages.

To participate in forums or blogs, visit www.adobe.com/communities.
Chapter 2: Introducing Adobe Device Central

Adobe Device Central offers a new way for developers of mobile content to test their work on a wide variety of mobile devices. Device Central works with content developed on many different Adobe products as well.

Using Adobe Device Central

About Adobe Device Central
Adobe® Device Central provides mobile content developers and testers with an easy way to create and preview mobile content on a variety of devices. Adobe Device Central displays realistic skins of a wide range of mobile devices that show you what the devices look like and how your content appears on those devices. This enables you to interact with the emulated devices in a way that simulates real-world interactions, including testing different performance levels, memory, battery power levels, and types of lighting.

Adobe Device Central provides a library of devices to choose from. Each device has a profile that contains information about the device, including the media and content types it supports (that is, the content that can be used on an individual device such as screen savers, wallpaper, and stand-alone Adobe Flash® Player). You can search through available devices, compare multiple devices, and create custom sets of the devices you use most.

Adobe Device Central supports different media formats including Adobe Flash®, bitmap, video, and web formats. You can use different media formats to create different types of content such as screen savers or wallpaper.

See also
“About content types” on page 32
“Working with devices” on page 11
“Testing with the Emulator tab” on page 30

Work area components
The following are the main components of the Adobe Device Central work area:

Device Sets panel Initially displays a default set of generic devices named Example FL Phones. In most cases, the devices available for testing depend on the content type specified when you create or preview mobile content, or use the emulator. If originating from Flash, an additional device set appears that contains the devices specified when you create the FLA file. (The new Flash-specific device set is named after the FLA file.) To create custom device sets, drag icons (or copy and paste) from the Available Devices list into the Device Sets panel. Over time, you will probably create custom sets to test content and projects. To share device sets among team members, import and export sets.

When you create a mobile document for Flash using Adobe Device Central and select one or more devices in the Available Devices list, a new device set is created and listed in the Device Sets panel the next time you test that file in the emulator.
If you are working with a device set and testing content, the individual device shown in the Emulator tab is always listed in the Device Sets panel with a special icon.

**Available Devices panel** Shows all the mobile devices that are installed with Adobe Device Central. You can think of the Available Devices panel as a repository of devices that you can use to test content.

By default, the devices in the Available Devices panel are grouped by manufacturer and sorted by name. To group the devices using different criteria, click the Group By pop-up menu and choose from the list. If you select None, all available devices are shown as one list, sorted alphabetically by name.

In each group, devices are, by default, listed alphabetically by name and additional columns provide information specific to each device. To see all information, move the slider to the right until the Name, Display Size, Flash Lite, and Color Depth columns appear.

To sort devices in a group, click a column header. For example, you can group by manufacturer, and in the manufacturer groups you can click a header, such as color depth, to have color depth sorting applied in all the manufacturer groups.

**Device Profiles tab** Shows detailed information about devices. Different screens show general information and specific details for Flash, bitmap, video, and web. The Device Profiles tab can show one or multiple devices. (The same information is displayed about a device whether you view the device individually or as part of the multiple view.)

When one device is shown on the tab, the first line of information across the top lists the media types that the device supports, such as General, Flash, Bitmap, Video, and Web. Click a media type to show a second line of information that lists the content types supported (for instance, click on the media type Bitmap and the content types Fullscreen, Screen Saver, and Wallpaper might appear). The Generic mobile phones in the Available Devices panel always show all of the media types in the Device Profiles panel, but they support only the stand-alone Flash Player content type.

When you select multiple devices to view on the Device Profiles tab, you can change the order in which the devices are displayed by dragging devices to a new location on the tab. (You can also drag any device from the Device Profiles tab into a set in the Device Sets panel.)

**New Document tab** Displays the interface for creating a mobile document in Flash, Adobe Photoshop®, or Adobe Illustrator®. This tab appears when you issue the command to create a mobile document in one of the three applications listed. For example, in Flash the command is Create New > Flash Mobile Document. (Alternatively, you can create a Flash file and display the New Document tab from Adobe Device Central by selecting File > New Document In > Flash.)

The options that appear on the New Document tab depend on the type of document you are creating. For example, when you create a new Flash document, you select a Flash Player version, an ActionScript™ version, and content type.

**Emulator tab** Shows the testing interface. The Emulator tab is designed to simulate how content (for instance, Flash file, Photoshop image, video clip, and so on) appears on a specific mobile device. The Emulator tab opens when you are working in a component like Flash or Photoshop and issue the command to export or test the file. For example, in Flash the command is Control > Test Movie. Only one device can be emulated at a time. To select a different device, double-click a device name in the Device Sets panel or the Available Devices panel.

**Testing panels** A number of collapsible panels for testing and performance tuning appear on the right of the emulator window. The panels that appear depend on what type of file you are testing:

- Content Type (Flash, Adobe Dreamweaver®, Photoshop, Illustrator, Adobe After Effects®, and Adobe® Premiere® Pro)
- File Info (Flash, Dreamweaver, Photoshop, Illustrator, After Effects, and Adobe Premiere Pro)
- Display (Flash, Photoshop, Illustrator, After Effects, and Adobe Premiere Pro)
• Memory (Flash)
• Performance (Flash)
• Device Status (Flash)
• Network (Flash)
• Persistent Storage (Flash)
• Rendering (Dreamweaver)
• Scaling (Photoshop, Illustrator, After Effects, Adobe Premiere Pro)
• Alignment (Photoshop, Illustrator, After Effects, Adobe Premiere Pro)
• Sound (After Effects, Adobe Premiere Pro)

Note: A Message panel displays error and other types of messages.

For a tutorial on the Device Central workspace, see http://www.adobe.com/go/vid0184

See also
“Working with devices” on page 11
“Testing with the Emulator tab” on page 30

Change preferences

Change the default phone ID
The default phone ID is the International Mobile Equipment Identity (IMEI) number of the device that Device Central is emulating. Each Global System for Mobile Communications (GSM) and Universal Mobile Telecommunications System (UMTS) mobile device has a unique IMEI number. The 15-digit number identifies the origin, model, and serial number of the mobile device.

Specifying a default phone ID instructs Adobe Device Central to use that number as the default IMEI for any device tested.

1 Select Edit > Preferences.
2 Enter a new number in the Default Phone ID text field.

Change undo levels
Use the Undo Levels option to change the number of times you can revert to a previous state. For example, the default setting of 20 enables you to revert through your last 20 actions.

1 Select Edit > Preferences.
2 Enter a new number in the Undo Levels text field.
**Change the application language**

The default language for Adobe Device Central can be changed to English, French, German, Japanese, Spanish, Italian, Dutch, Swedish, Korean, Chinese Traditional, or Chinese Simplified. After you restart your computer, the Device Central user interface contains text in your selected language.

1. Select Edit > Preferences.
2. Select a new language from the Application Language pop-up menu.

**See also**

“About language settings in Device Central” on page 38

**Change the font mapping**

Use the font mapping option to define the device fonts used when emulating a device. In a Flash file, you can specify generic device fonts such as sans, serif, or typewriter. Adobe Flash® Lite™ automatically tries to match the selected generic font to an available font on the device at run-time. If you know the device fonts available on a device, you can select those, or similar, fonts from the Assigned Fonts drop-down lists.

*Note: On an actual mobile device, the native font of the device's operating system is used to render the SWF text.*

1. Select Edit > Preferences.
2. Select a new language from the Language pop-up menu.
3. Select new sans, serif, and typewriter fonts from the pop-up menus.

**See also**

“About language settings in Device Central” on page 38
Chapter 3: Managing device profiles

Adobe Device Central contains a library of mobile devices, including separate profiles for each device. The profiles contain detailed information about the device that is helpful when creating mobile content.

Working with devices

About device profiles
Adobe® Device Central® provides a built-in library of mobile devices. Each device has a profile that contains technical details about the device and information about the content types supported. View a single profile or a chart showing multiple profiles. Often, it can be useful to display multiple profiles and compare several devices at the same time. For example, you might have four target devices for Adobe Flash content you are developing. View the profiles of the four devices at the same time to determine the best addressable screen size and which FSCommands are supported by all devices.

See also
“Work area components” on page 7

View device profiles
1 In the Available Devices panel, expand a folder.
2 Do one of the following:
   • To view the profile of a single device, select the device name.
   • To view multiple devices simultaneously, Shift-click the device names for a continuous selection, or Ctrl-click (Windows®) or Command-click (Mac OS) for a discontinuous selection.
Group devices by different criteria
❖ In the Available Devices panel, click the Group By button ➤ and choose an option.

To change the sort order of devices in the Available Devices panel, click on the column headers. (By default, devices are sorted by manufacturer.)

Group devices by content type
If you are creating a specific content type, it can be useful to group devices by content type. Adobe Device Central shows the devices that support the selected content type and dims devices that do not.

❖ In the Available Devices list, click the Group By button ➤ and select Content Type from the pop-up menu.

The content types appear as folders. Expand a folder to see the devices that support the content type. For example, expand the Screen Saver folder to see the devices for which screen savers can be created.

See also
“About content types” on page 32

Search the Available Devices list

Search for a specific device
The Adobe Device Central Search feature lets you quickly search for a particular device in the Available Devices panel. You can search by device name or several other criteria. You can also group devices by manufacturer name or screen size, or have Adobe Device Central display only those devices that support a specific content type.

The search feature is dynamic, so as you enter search criteria, the list of matching devices automatically updates. Each time you add more criteria, the search becomes more specialized.

1 In the Available Devices panel, click the Search Devices button ➤.

2 In the Search For text field, enter a manufacturer or model number. If you don't want to search by manufacturer or model, leave this field blank.

3 To narrow your search, click the plus sign (+) to add search criteria. Click the plus sign again to add additional criteria. Each time you add criteria, it is an “and” operation, so your search becomes more and more specific. (Click the minus sign (-) to remove criteria.)

Note: The search criteria you define remain until you perform a new search; click the Search Devices button at any time to see what criteria created the current list of devices.
To close the Search box, click anywhere outside of the Search box, or click the Close button in the upper-right corner of the Search box.

**Save search results as a new device set**

After you do a search, you can save the search results as a new device set. This is an efficient way to work and makes it easy to group certain devices for a specific project.

1. After a search, right-click on the search results and choose Select All.
2. Do one of the following:
   - Select all of the search results, right-click on the results, and select New Device Set Selection.
   - Select Devices > Save Search Result As Set.

**Clear search results**

When you enter search criteria, the Available Devices panel displays only those devices that match your criteria. You can, however, clear the search results and return to the full list of devices.

1. The Clear Search Results button is not active while the Search box is open. To make the Clear Search Results button active, click outside the box or click the Close button in the upper-right corner of the box to close the Search box.
2. Click the Clear Search Result button at the top of the Available Devices panel.

**Work with devices and device sets**

**Select an individual device**

When you select a device in the Available Devices panel or Device Sets panel, Adobe Device Central displays detailed information about the device in the Device Profiles panel. Adobe Device Central also determines which sizes to propose for document creation on the New Document tab. After sending a file for testing from an application like Flash or Adobe Photoshop (or opening a file in a mobile format from Device Central), you can double-click on a device in the Available Devices panel or Device Sets panel to have Adobe Device Central load the device information on the Emulator tab and start content playback.

*Note: The supported mobile formats are: SWF, JPG, JPEG, PNG, GIF, WBM, MOV, 3GP, 3G2, M4V, MP4, MPG, MPEG, AVI, HTM, HTML, XHTML, CHTML, URL, and WEBLOC.*

You can navigate between applications and Adobe Device Central without losing your device selection. Adobe Device Central preselects the device of the most recently created file when you export your file for testing. In Flash, if you bypass document creation in Adobe Device Central and send a document for testing, Adobe Device Central uses stand-alone Flash Player as the default content type and uses the device that was selected in the last emulation session.

**See also**

“About content types” on page 32
Create a device set
Adobe Device Central lets you group devices into custom folders. For example, you might create a device set that contains the devices you use for a particular project or you might create a device set containing all devices that support a particular content type. Device sets appear in the Device Sets panel.

The content type selected for emulation or document creation filters the devices in the Device Sets and Available Devices panels. Devices that do not support the selected content type are dimmed. (When the Device Profiles tab is shown, all devices in the Device Sets and Available Devices panels are enabled so you can view profile information.)

❖ To create a device set, do one of the following:
• Right-click the My Favorites folder in the Device Sets panel and select New Device Set.
• Click the New Device Set button in the upper-right corner of the Device Sets panel.
• Select Devices > New Device Set.

An Untitled Set appears. Enter a name for the new device set. If an “Untitled Set” already exists, Adobe Device Central adds a number to the name (Untitled Set (1), Untitled Set (2), and so on).

Note: After creating a new Device Set folder, you can drag the folder up and down to a new location under the My Favorites folder.

Create a device subset
1 Select the device set to be the subset.
2 Drag the device set below another device set (the indicator arrow should be beneath the folder icon).

Add a device to a device set
When you copy a device to a location where the same device already exists, Adobe Device Central creates a duplicate, and names it by adding a number to the device name.

❖ Do one of the following:
• Drag the device (or a group of devices) from the Available Devices panel or the Profile Info tab to the Device Sets panel.
• Right-click a device and choose Copy. Right-click a device set and choose Paste.

Note: To copy devices between sets, press Ctrl (Windows) or Option (Macintosh) while dragging. A plus sign (+) next to the pointer indicates copying.

Delete a device or device set
❖ Do one of the following:
• With the device, device set, or individual devices selected, click the Delete Selection button in the upper-right corner of the Device Sets panel
• Right-click your selection and choose Delete.
• With a device or device set selected, click Delete on your keyboard.
Move a device in the device sets panel
If you move a device that already exists at the destination location, Adobe Device Central adds a number in parentheses to the device name.
❖ Select a device and drag the device to a different location in the list.

Note: To copy a device from one set to another, press Ctrl (Windows) or Option (Macintosh) while dragging.

Obtain device profile updates
To obtain updated information about devices, using the following procedure.

Note: Device updates are also available as part of the Adobe Update Manager process. For more information, see “Downloads” on page 5.

1 Select Devices > Check For Device Updates.
2 On the Adobe.com Device Central page, download the update.
3 Double-click the downloaded .adpp file.
4 In the Install Device Profile Package dialog box, select the devices to import.
5 Click Install & Relaunch.

Export a device set
If you created a device set, you can export the set to others on your team. This can save time and ensure that everyone is creating and testing content using the same set of devices.

1 In the Device Sets panel, select the Device Set to export.
2 Select Devices > Export Device Set.
3 In the Export Device Set dialog box, edit the default name (Adobe Device Central uses the extension .advs) and browse to a destination location.
4 Click Save.

Import a device set
Importing a device set is useful if you are sharing information with others. If someone has already created a device set, you can import the set instead of recreating the same set on your computer.

When you share a device set by importing it, Adobe Device Central does not import the actual device profiles (XML files including all the respective device data). Adobe Device Central imports only the information about which devices are included in the project set. If you do not have all of the device profiles in your version of Adobe Device Central, you are alerted that you must run an update to obtain the missing profiles.

1 Select Devices > Import Device Set.
2 Navigate to the .advs file and select the file.
3 Click Open.
Chapter 4: Create, preview, and test content in Adobe Device Central

You can use Adobe Device Central to create and preview mobile content developed in Adobe products. There are also many options for testing mobile content in Device Central, enabling you to emulate a wide variety of mobile devices and scenarios.

Creating and previewing mobile content with Adobe Device Central

Access Adobe components from Adobe Device Central

1. Start Device Central.
2. Select File > New Document In > Flash, Illustrator, or Photoshop.

In Device Central, the New Document panel appears with the correct options to create a new mobile document in the selected application.

3. Make any necessary changes, such as selecting a new Player Version, ActionScript Version, or Content type.
4. Do one of the following:
   • Select the Custom Size for All Selected Devices option and add a width and height (in pixels).
   • Select a device or multiple devices from the Device Sets list or Available Devices list.
5. If you selected multiple devices, Device Central selects a size for you. If you want to select a different size, click on a different device or set of devices.
6. Click Create.

The selected application opens with a new mobile document ready to edit.

Create mobile content with Adobe Device Central and Flash CS3

1. Start Flash.
2. On the main Flash screen, select Create New > Flash File (Mobile).

Flash opens Device Central and displays the New Document tab.

3. In Device Central, select a Player version and ActionScript version.

The Available Devices list on the left is updated. Devices that do not support the selected Player version and ActionScript version are dimmed.

4. Select a content type.

The Available Devices list on the left is updated and shows the devices that support the content type (as well as the Player version and ActionScript version) selected.
5 In the Available Devices list, select a single target device or multiple devices (or select a set or individual device in the Device Sets list).

Device Central lists proposed document sizes based on the device or devices you selected (if the devices have different display sizes). Depending on the design or content you are developing, you can create a separate mobile document for each display size or try to find one size appropriate for all devices. When choosing the second approach, you may want to use the smallest or largest suggested document size as a common denominator. You can even specify a custom size at the bottom of the tab.

6 Click Create.

Flash starts up and creates a document with preset publish settings from Device Central, including the correct size for the device (or group of devices) specified.

7 Add content to the new Flash document.

8 To test the document, select Control > Test Movie.

The new document is displayed in the Device Central Emulator tab. If one or more devices were selected in the Available Devices list in step 5, a new device set is created (named according to the FLA file) and listed in the Device Sets panel. The device shown in the Emulator tab is listed in the Device Sets panel with a special icon 🌐. To test the new Flash document on another device, double-click the name of a different device in the Device Sets or Available Devices lists.


---

**Create mobile content with Adobe Device Central and Photoshop**

1 Start Photoshop.

2 Select File > New.

3 Click Device Central to close the dialog box in Photoshop and open Device Central.

4 Select a content type.

The Available Devices list on the left is updated and shows the devices that support the content type selected.

5 In the Available Devices list, select a single target device or multiple devices (or select a set or individual device in the Device Sets list).

Device Central lists proposed document sizes based on the device or devices you selected (if the devices have different display sizes). Depending on the design or content you are developing, you can create a separate mobile document for each display size or try to find one size appropriate for all devices. When choosing the second approach, you may want to use the smallest or largest suggested document size as a common denominator. You can even specify a custom size at the bottom of the tab.

6 Click Create.

A blank PSD file with the specified size opens in Photoshop. The new file has the following parameters set by default:

- Color Mode: RGB/8bit
- Resolution: 72 ppi
- Color Profile: SRGB IEC61966-2.1

7 Fill the blank PSD file with content in Photoshop.

8 When you finish, select File > Save For Web & Devices.
In the Save For Web & Devices dialog box, select the desired format and change other export settings as desired.

Click Device Central.

A temporary file with the export settings specified is displayed in the Device Central Emulator tab. To continue testing, double-click the name of a different device in the Device Sets or Available Devices lists.

If, after previewing the file in Device Central, you need to make changes to the file, go back to Photoshop.

In the Photoshop Save For Web & Devices dialog box, make adjustments, such as selecting a different format or quality for export.

To test the file again with the new export settings, click the Device Central button.

When you are satisfied with the results, click Save in the Photoshop Save For Web & Devices dialog box.

Note: To simply open Device Central from Photoshop (instead of creating and testing a file), select File > Device Central.

For a tutorial about creating content using Photoshop and Device Central, see http://www.adobe.com/go/vid0185.

Create mobile content with Adobe Device Central and Illustrator

Start Illustrator.

Select File > New.

In New Document Profile, select Mobile and Devices.

Click Device Central to close the dialog box in Illustrator and open Device Central.

Select a content type.

The available Devices list on the left is updated and shows the devices that support the content type selected.

In Device Central, select a device, several devices, or a device set.

Based on the device(s) selected and content type, Device Central suggests one or multiple artboard sizes to be created. To create one document at a time, select a suggested document size (or select the Custom Size for all selected Devices option and enter custom values for Width and Height).

Click Create.

A blank AI file of the specified size opens in Illustrator. The new file has the following parameters set by default:

- Color Mode: RGB
- Raster Resolution: 72 ppi

Fill the blank AI file with content in Illustrator.

When you finish, select File > Save For Web & Devices.

In the Save for Web & Devices dialog, select the desired format and change other export settings as desired.

Click Device Central.

A temporary file with the export settings specified is displayed in the Device Central Emulator tab. To continue testing, double-click the name of a different device in the Device Sets or Available Devices lists.

If, after previewing the file in Device Central, you need to make changes to the file, go back to Illustrator.

On the Illustrator Save for Web & Devices dialog, make adjustments such as selecting a different format or quality for export.

To test the file again with the new export settings, click the Device Central button.
When you are satisfied with the results, click Save in the Illustrator Save for Web & Devices dialog.

*Note: To simply open Device Central from Illustrator (instead of creating and testing a file), select File > Device Central.*

For a tutorial about creating content with Illustrator and Device Central, see [http://www.adobe.com/go/vid0207](http://www.adobe.com/go/vid0207).

**Preview a movie on a virtual mobile device using Adobe Premiere Pro**

Using Adobe Device Central, you can preview movies formatted for mobile devices in emulations of those devices. This option is available for most of the H.264 formats listed in the Adobe Media Encoder.

1. On Windows computers, make sure QuickTime is installed.
2. Start Adobe Premiere Pro.
3. Open the file to preview.
4. Select the file in the project area or Timeline.
6. In the Export Settings area of the Export Settings Window, select H.264 from the Format drop-down menu.
7. Select a mobile preset (e.g., 3GPP).
   - Open in Device Central should be checked by default.
8. Click OK.
9. Name and save the file.
   - The file is rendered.
10. A temporary file is displayed in the Device Central Emulator tab. To continue testing, double-click the name of a different device in the Device Sets or Available Devices lists.

**Preview a movie on a virtual mobile device using After Effects**

Using Adobe Device Central, you can preview movies formatted for mobile devices in emulations of those devices. This option is available for most of the H.264 formats listed in the Adobe Media Encoder.

1. Start After Effects.
2. In the Project panel, select the composition to preview.
3. Choose Composition > Add to Render Queue.
4. In the Render Queue panel, click the underlined text to the right of Output Module, or select Custom from the Output Module menu.
5. In the Output Modules Settings dialog box, choose H.264 from the Format menu.
6. In the Export Settings section of the H.264 dialog box, select Open in Device Central.
7. Modify other settings as desired and click OK.
8. Click OK to close the Output Module Settings dialog box.
9. In the Render Queue panel, click Render.
   - Rendering may take a few minutes, depending on the size of the file. When rendering is complete, a temporary file is displayed in the Adobe Device Central Emulator tab. To continue testing, double-click the name of a different device in the Device Sets or Available Devices lists.
Preview mobile content with Adobe Device Central and Dreamweaver

To preview pages created in Dreamweaver on various mobile devices, use Device Central with its built-in Opera Small-Screen Rendering feature. Different devices have different browsers installed, but the preview can give a good impression of how content will look and behave on a selected device.

1. Start Dreamweaver.
2. Open a file.
3. Do one of the following:
   • Select File > Preview in Browser > Device Central.
   • On the document window toolbar, click and hold the Preview/Debug In browser button and select Preview In Device Central.

The file is displayed in the Device Central Emulator tab. To continue testing, double-click the name of a different device in the Device Sets or Available Devices lists.

Access Adobe Device Central from Adobe Bridge

To access Device Central from Adobe Bridge, select an individual file. The supported formats are: SWF, JPG, JPEG, PNG, GIF, WBM, MOV, 3GP, M4V, MP4, MPEG, AVI, HTM, HTML, XHTML, CHTML, URL, and WEBLOC.

1. Start Adobe Bridge.
2. Do one of the following:
   • Select a file and click File > Test in Device Central.
   • Right-click a file and select Test in Device Central.

The file is displayed in the Device Central Emulator tab. To continue testing, double-click the name of a different device in the Device Sets or Available Devices lists.

Note: To browse device profiles or to create mobile documents, select Tools > Device Central. Device Central opens with the Devices Profiles tab shown.

For a tutorial about using Adobe Bridge and Device Central, see http://www.adobe.com/go/vid0208.

Tips for creating content for mobile devices

Creating Flash content for use on mobile devices

To create Flash content for mobile devices, follow some basic principles. For example, Flash developers often avoid extremely complex artwork and excessive tweening or transparency.

Flash Lite developers face additional challenges because performance on mobile devices varies greatly. If content must be published to many different devices, developers sometimes have to author for the lowest common denominator.
Optimizing mobile content requires making trade-offs. For example, one technique may make the content look better, while another results in better performance. As you evaluate these trade-offs, you will be going back and forth repeatedly between testing in the emulator and testing on the target device. You must see your content on the actual device to evaluate the trueness of colors, text readability, physical interactions, UI responsiveness, and other aspects of the real mobile experience.

For more tips and techniques for creating content for mobile phones and devices, see www.adobe.com/go/learn_cs_mobilewiki_en.

**Flash Lite guidelines for animation in mobile devices**

When creating animated content for a mobile devices, keep device CPU limitations in mind. Following these guidelines can help prevent Flash Lite content from running slowly:

- When creating a new Flash Lite file, check that the document is set up correctly. Although Flash files scale smoothly, performance can suffer if the file is not running at its native Stage size and has to scale in the player. Try to set the document Stage size to match the resolution of the target device. Also set Flash Player to the correct version of Flash Lite and select an appropriate device profile in Device Central.

- Flash Lite can render vector graphics at low, medium, and high quality. The higher the rendering quality, the more smoothly and accurately Flash Lite renders vector graphics and the greater the demand on the device's CPU. To provide complex animation, experiment with changing the player's quality setting and then thoroughly test the SWF file. To control the rendering quality of a SWF file, use the _quality property or the setQuality command. Valid values for the _quality property are LOW, MEDIUM, and HIGH.

- Limit the number of simultaneous tweens. Reduce the number of tweens, or sequence the animation so that one begins when another ends.

- Use transparency (alpha) effects on symbols sparingly because they are CPU intensive. In particular, avoid tweening symbols with alpha levels that are not fully opaque (less than 100%).

- Avoid CPU-intensive visual effects, such as large masks, extensive motion, alpha blending, extensive gradients, and complex vectors.

- Experiment with combinations of tweens, keyframe animations, and ActionScript-driven movement to produce the most efficient results.

- Rendering vector ovals and circles is much more memory intensive than rendering quadrangles. Using round and oval strokes also greatly increases CPU use.

- Test animations frequently on actual target devices.

- When Flash draws an animated region, it defines a rectangular bounding box around the area. Optimize the drawing by making that rectangle as small as possible. Avoid overlapping tweens, because Flash interprets the merged area as a single rectangle, resulting in a larger total region. Use Flash’s Show Redraw Region feature to optimize the animation.

- Avoid using _alpha = 0 and _visible = false to hide on-screen movie clips. If you simply turn a movie clip’s visibility off or change its alpha to zero, it is still included in line-rendering calculations, which can affect performance.

- Similarly, do not try to hide a movie clip by obscuring it behind another piece of artwork. It will still be included in the player’s calculations. Instead, move movie clips completely off the Stage or remove them by calling removeMovieClip.

For more tips and techniques for creating content for mobile phones and devices, see www.adobe.com/go/learn_cs_mobilewiki_en.
**Flash Lite bitmap and vector graphics in mobile devices**

Flash Lite can render both vector and bitmap graphics. Each type of graphic has its advantages and disadvantages. The decision to use vector rather than bitmap graphics is not always clear and often depends on several factors.

Vector graphics are compactly represented in SWF files as mathematical equations and rendered at run time by the Flash Lite player. In contrast, bitmap graphics are represented as arrays of picture elements (pixels), which require more bytes of data. Therefore, using vector graphics in a file can help reduce file size and memory usage.

Vector graphics also maintain their smooth shapes when scaled in size. Bitmap images can appear boxy, or pixelated, when scaled.

Compared to bitmaps, vector graphics require more processing power to render, especially vector graphics that have many complex shapes and fills. Consequently, heavy use of vector shapes can sometimes reduce overall file performance. Because bitmap graphics do not require as much processing time to render as vector graphics, they are better choice for some files, for example, a complex road map meant to be animated and scrolled on a mobile phone.

Keep these considerations in mind:

- Avoid using outlines on vector shapes. Outlines have an inner and outer edge (fills have only one) and are twice the work to render.
- Corners are simpler to render than curves. When possible, use flat edges, especially with very small vector shapes.
- Optimization is especially helpful with small vector shapes such as icons. Complex icons may lose their details upon rendering, and the work of rendering the details is wasted.
- As a general rule, use bitmaps for small, complex images (such as icons) and vector graphics for larger and simpler ones.
- Import bitmap graphics at the correct size; don't import large graphics and scale them down in Flash, because this wastes file size and run-time memory.
- The Flash Lite player does not support bitmap smoothing. If a bitmap is scaled or rotated, it will have a chunky appearance. If it is necessary to scale or rotate a graphic, consider using a vector graphic instead.
- Text is essentially just a very complex vector shape. Of course, text is often critical, so it can rarely be avoided entirely. When text is needed, avoid animating it or placing it over an animation. Consider using text as a bitmap. For multiline dynamic and input text, the line break of the text string is not cached. Flash breaks lines at run time and recalculates the breaks every time the text field needs to be redrawn. Static text fields are not problematic, because the line breaking is precalculated at compile time. For dynamic content, using dynamic text fields is unavoidable, but when possible, consider using static text fields instead.
- Minimize the use of transparency in PNG files; Flash must calculate redraws even for the transparent portions of the bitmap. For example, with a transparent PNG file that represents a foreground element, don’t export the transparent PNG at the full size of the screen. Instead, export it at the actual size of the foreground element.
- Try to group bitmap layers together and vector layers together. Flash needs to implement different renderers for bitmap and vector content, and switching between renderers takes time.

For more tips and techniques for creating content for mobile phones and devices, see www.adobe.com/go/learn_cs_mobilewiki_en.

**Flash Lite video in mobile devices**

When using embedded video, keep the video length as short as possible to avoid overwhelming the device’s memory. Also, don’t use video clips with an audio track, as there are synchronization issues with the video due to the fact that playback is simply mapped to the SWF file’s frame rate.
Set compression of Flash Lite bitmaps for mobile devices

When using bitmaps, you can set image-compression options (on a per-image basis or globally for all bitmap images) that reduce SWF file size.

For more tips and tricks about using Adobe Device Central with other Adobe products, see www.adobe.com/go/learn_cs_mobilewiki_en.

Set compression options for an individual bitmap file

1. Start Flash and create a document.
2. Select a bitmap in the Library window.
3. Right-click (Windows) or Control-click (Macintosh) the bitmap icon in the Library window, and select Properties from the context menu to open the Bitmap Properties dialog box.
4. In the Compression pop-up menu, select one of the following options:
   • Select the Photo (JPEG) option for images with complex color or tonal variations, such as photographs or images with gradient fills. This option produces a JPEG file. Select the Use Imported JPEG Data check box to use the default compression quality specified for the imported image. To specify a new quality compression setting, deselect Use Imported JPEG Data and enter a value between 1 and 100 in the Quality text box. A higher setting produces an image of higher image quality but also a larger file, so adjust the value accordingly.
   • Select the Lossless (PNG/GIF) option for images with simple shapes and a few colors. This option compresses the image using lossless compression, which discards no data.
5. Click Test to determine the results of the file compression. Compare the original file size to the compressed file size to decide whether the selected compression setting is acceptable.

Set compression for all bitmap images

1. Select File > Publish Settings, and then click the Flash tab to display compression options.
2. Adjust the JPEG quality slider, or enter a value. A higher JPEG quality value produces an image of higher image quality but a larger SWF file. A lower image quality produces a smaller SWF file. Try different settings to determine the best trade-off between size and quality.

Optimizing Flash Lite frames for mobile devices

• Most devices that support Flash Lite play back content at about 15 to 20 frames per second (fps). The frame rate can be as low as 6 fps. During development, set the document frame rate to approximate the playback speed of the target device. This shows how the content will run on a device with limited performance. Before publishing a final SWF file, set the document frame rate to at least 20 fps or higher to avoid limiting performance in case the device supports a higher frame rate.
• When using gotoAndPlay, remember that every frame between the current frame and the requested frame needs to be initialized before Flash plays the requested frame. If many of these frames contain different content, it could be more efficient to use different movie clips rather than using the Timeline.
• Although preloading all content by putting it at the beginning of the file makes sense on the desktop, preloading on a mobile device can delay file startup. Space content throughout the file so that movie clips are initialized as they are used.

For more tips and techniques for creating content for mobile phones and devices, see www.adobe.com/go/learn_cs_mobilewiki_en.
Optimizing ActionScript for Flash Lite content on mobile devices

Because of the processing speed and memory limitations on most mobile devices, follow these guidelines when developing ActionScript for Flash Lite content used on mobile devices:

- Keep the file and its code as simple as possible. Remove unused movie clips, delete unnecessary frame and code loops, and avoid too many frames or extraneous frames.

- Using FOR loops can be expensive because of the overhead incurred while the condition is checked with each iteration. When the costs of the iteration and the loop overhead are comparable, execute multiple operations individually instead of using a loop. The code may be longer, but performance will improve.

- Stop frame-based looping as soon as it is no longer needed.

- When possible, avoid string and array processing because it can be CPU-intensive.

- Always try to access properties directly rather than using ActionScript getter and setter methods, which have more overhead than other method calls.

- Manage events wisely. Keep event listener arrays compact by using conditions to check whether a listener exists (is not null) before calling it. Clear any active intervals by calling clearInterval, and remove any active listeners by calling removeListener before removing content using unloadapplication or removeapplicationClip. Flash does not re-collect SWF data memory (for example, from intervals and listeners) if any ActionScript functions are still referencing the SWF data when a movie clip is unloaded.

- When variables are no longer needed, delete them or set them to null, which marks them for garbage collection. Deleting variables helps optimize memory use during run time, because unneeded assets are removed from the SWF file. It is better to delete variables than to set them to null.

- Explicitly remove listeners from objects by calling removeListener before garbage collection.

- If a function is being called dynamically and passing a fixed set of parameters, use call instead of apply.

- Make namespaces (such as paths) more compact to reduce startup time. Every level in the package is compiled to an IF statement and causes a new Object call, so having fewer levels in the path saves time. For example, a path with the levels com.xxx.yyy.aaa.bbb.ccc.funtionName causes an object to be instantiated for com.xxx.yyy.aaa.bbb.ccc. Some Flash developers use preprocessor software to reduce the path to a unique identifier, such as 58923409876.functionName, before compiling the SWF code.

- If a file consists of multiple SWF files that use the same ActionScript classes, exclude those classes from select SWF files during compilation. This can help reduce file download time and run-time memory requirements.

- Avoid using Object.watch and Object.unwatch, because every change to an object property requires the player to determine whether a change notification must be sent.

- If ActionScript code that executes on a keyframe in the timeline requires more than 1 second to complete, consider splitting up that code to execute over multiple keyframes.

- Remove trace statements from the code when publishing the SWF file. To do this, select the Omit Trace Actions check box on the Flash tab in the Publish Settings dialog box.

- Inheritance increases the number of method calls and uses more memory: a class that includes all the functionality it needs is more efficient at run time than a class that inherits some of its functionality from a superclass. Therefore, you may need to make a design trade-off between extensibility of classes and efficiency of code.

- When one SWF file loads another SWF file that contains a custom ActionScript class (for example, foo.bar.CustomClass) and then unloads the SWF file, the class definition remains in memory. To save memory, explicitly delete any custom classes in unloaded SWF files. Use the delete statement and specify the fully qualified class name, such as: delete foo.bar.CustomClass.
• Limit the use of global variables, because they are not marked for garbage collection if the movie clip that defined them is removed.

• Avoid using the standard user interface components (available in the Components panel in Flash). These components are designed to run on desktop computers and are not optimized to run on mobile devices.

• Whenever possible, avoid deeply nested functions.

• Avoid referencing nonexistent variables, objects, or functions. Compared to the desktop version of Flash Player, Flash Lite 2 looks up references to nonexistent variables slowly, which can significantly affect performance.

• Avoid defining functions using anonymous syntax. For example, `myObj.eventName = function{ ...`. Explicitly defined functions are more efficient, such as `function myFunc { ...}; myObj.eventName = myFunc;`.

• Minimize the use of Math functions and floating-point numbers. Calculating these values slows performance. If you must use the Math routines, consider precalculating the values and storing them in an array of variables. Retrieving the values from a data table is much faster than having Flash calculate them at run time.

For more tips and techniques for creating content for mobile phones and devices, see [www.adobe.com/go/learn_cs_mobilewiki_en](http://www.adobe.com/go/learn_cs_mobilewiki_en).

**Managing Flash Lite file memory for mobile devices**

Flash Lite regularly clears from memory any objects and variables that a file no longer references. This is known as garbage collection. Flash Lite runs its garbage-collection process once every 60 seconds, or whenever usage of file memory increases suddenly by 20% or more.

Although you cannot control how and when Flash Lite performs garbage collection, you can still free unneeded memory deliberately. For timeline or global variables, use the `delete` statement to free the memory that ActionScript objects use. For local variables—for example, a variable defined within a function definition—you can’t use the `delete` statement to free an object’s memory, but you can set to `null` the variable that references the object. This frees the memory that the object uses, provided there are no other references to that object.

The following two code examples show how to free memory that objects use by deleting the variable that references those objects. The examples are identical, except that the first example creates a timeline variable and the second creates a global variable.
// First case: variable attached to a movie or movie clip timeline
// Create the Date object.
var mcDateObject = new Date();
// Returns the current date as a string.
trace(mcDateObject);
// Delete the object.
delete mcDateObject;
// Returns undefined.
trace(mcDateObject);

// Second case: global variable attached to a movie or movie clip timeline
// Create the Date object.
_global.gDateObject = new Date();
// Returns the current date as a string.
trace(_global.gDateObject);
// Delete the object.
delete _global.gDateObject;
// Returns undefined.
trace(_global.gDateObject);

As mentioned previously, you can't use the delete statement to free memory that a local function variable uses. Instead, set the variable reference to null, which has the same effect as using delete.

function func()
{
    // Create the Date object.
    var funcDateObject = new Date();
    // Returns the current date as a string.
    trace(funcDateObject);
    // Delete has no effect.
delete funcDateObject;
    // Still returns the current date.
    trace(funcDateObject);
    // Set the object reference to null.
    funcDateObject = null;
    // Returns null.
    trace(funcDateObject);
}
// Call func() function.
func();

For more tips and techniques for creating content for mobile phones and devices, see www.adobe.com/go/learn_cs_mobilewiki_en.

Loading data for mobile devices in Flash Lite
When developing files for mobile devices, minimize the amount of data you attempt to load at one time. If you are loading external data into a Flash Lite file (for example, using XML.load), the device's operating system may generate a "memory failure" error if insufficient memory is allocated for the incoming data. This situation can occur even if the total amount of remaining memory is sufficient.
For example, suppose a file attempts to load an XML file that's 100 KB, but the device's operating system has allocated only 30 KB to handle that incoming data stream. In this case, Flash Lite displays an error message to the user, indicating that not enough memory is available.

To load large amounts of data, group the data in smaller pieces—for example, in several XML files—and make several data-loading calls for each piece. The size of each piece of data, and therefore the number of data-loading calls you need to make, varies by device and file. To determine an appropriate balance between the number of data requests and the likelihood of a memory failure, test files on a variety of target devices.

For optimum performance, avoid loading and parsing XML files if possible. Instead, store data in simple name/value pairs and load the data from a text file using loadVars or from precompiled SWF files.

For more tips and techniques for creating content for mobile phones and devices, see www.adobe.com/go/learn_cs_mobilewiki_en

**Exclude classes from compilation for Flash Lite**

To reduce the size of a SWF file, consider excluding classes from compilation but retaining the ability to access and use them for type checking. For example, try this if you are developing a file that uses multiple SWF files or shared libraries, especially those that access many of the same classes. Excluding classes helps avoid duplicating classes in those files.

2. Name the XML file FLA_filename_exclude.xml, where FLA_filename is the name of the FLA file without the .fla extension. For example, if the FLA file is sellStocks.fla, the XML filename must be sellStocks_exclude.xml.
3. Save the file in the same directory as the FLA file.
4. Place the following tags in the XML file:
   ```xml
   <excludeAssets>
     <asset name="className1" />
     <asset name="className2" />
   </excludeAssets>
   
   The values specified for the name attributes in the <asset> tags are the names of classes that should be excluded from the SWF file. Add as many as required for the file. For example, the following XML file excludes the mx.core.UIObject and mx.screens.Slide classes from the SWF file:
   ```xml
   <excludeAssets>
     <asset name="mx.core.UIObject" />
     <asset name="mx.screens.Slide" />
   </excludeAssets>
   
   For more tips and techniques for creating content for mobile phones and devices, see www.adobe.com/go/learn_cs_mobilewiki_en.

**Tips for creating Photoshop images for mobile devices**

To ensure that images created in Photoshop display well on mobile devices, do the following:

- Open Device Central, select a specific device, and then click the Create button to open a new file in Photoshop, retaining all the settings that Photoshop automatically provides. After selecting a device, Photoshop sets options, including size and color space, that are appropriate for the selected device.
- WBMP format is the standard format for optimizing images for mobile devices. WBMP supports 1-bit color, which means that WBMP images contain only black and white pixels.
• Try to reduce the number of colors in images as much as possible and consider using grayscale. The majority of devices currently on the market still support only 16-bit color (thousands), not 24- or 32-bit (millions). Thus, special color effects may not display properly. For example, gradients often appear as banded stripes of solid color instead of a smooth graduated transition.

• For photos, try applying the Sharpen filter one or more times to increase the contrast between colors.

• Make images small enough to fit the addressable screen size of your target mobile device. (Device Central lists the addressable screen size of each device in its library.) Scrolling is often impossible on mobile devices, so if an image does not fit the screen, portions of the image may simply be inaccessible to viewers.

For more tips and techniques for creating content for mobile phones and devices, see www.adobe.com/go/learn_cs_mobilewiki_en.

Tips for creating Illustrator images for mobile devices
To optimize graphical content for mobile devices, save artwork created in Illustrator in any SVG format, including SVG-t, which is especially designed for mobile devices.

Use the following tips to ensure that images created in Illustrator display well on mobile devices:

• Use the SVG standard to create content. Using SVG to publish vector graphics on mobile devices results in a small file size, display independence, superior color control, zooming ability, and editable text (within the source code). Also, because SVG is XML-based, you can incorporate interactivity into images, such as highlighting, tool tips, special effects, audio, and animation.

• Work within the final dimensions of your target mobile device(s) from the beginning. Although SVG is scalable, working within the correct size will ensure that final graphics are optimized in quality and size for the target device(s).

• Set Illustrator color mode to RGB. SVG is viewed on RGB raster display devices, such as a monitors.

• To reduce file size, try reducing the number of objects (including groups) or making it less complex (fewer points). Using fewer points significantly reduces the amount of textual information needed to describe the artwork in the SVG file. To reduce points, select Object > Path > Simplify and try different combinations to find a balance between quality and number of points.

• Use symbols when possible. Symbols define the vectors that describe an object once, instead of multiple times. This is useful if artwork contains objects like button backgrounds that are reused.

• When animating graphics, limit the number of objects used and try to reuse objects whenever possible to reduce file size. Apply animations to groups of objects instead of to individual objects to avoid code repetition.

• Consider using SVGZ, the compressed gzipped version of SVG. Compression can reduce file size dramatically, depending on the content. Text can usually be heavily compressed, but binary-encoded content, such as embedded rasters (JPEG, PNG, or GIF files), cannot be compressed significantly. SVGZ files can be uncompressed by any application that expands files compressed with gzip. To use SGVZ successfully, check that your target mobile device can decompress gzip files.

For more tips and techniques for creating content for mobile phones and devices, see www.adobe.com/go/learn_cs_mobilewiki_en.
Tips for creating video for mobile devices

Use these tips when shooting content for mobile devices:

- Tight shots are better. Try to keep the subject separated from the background; the colors and values between background and subject should not be too similar.

- Be aware of lighting. Poor lighting is a greater problem with mobile devices and can reduce visibility on small screens. Shoot and adjust with this limitation in mind.

- Avoid excessive panning or rolling.

Use the following tips when editing video with Adobe Premiere Pro and After Effects:

- Set the frame rate for the output movie according to output device or output type. For example, a commercial in After Effects might be rendered at 15 frames per second (fps) for distribution on mobile devices, but at 29.97 fps for broadcast television in the USA. In general, use a lower frame rate. A frame rate of 22 fps is a good compromise for reducing file size without losing quality.

- Make the movie as small as possible and remove any extraneous content, especially empty frames. Many actions can be done pre-encoding to limit file size. Some of them apply to shooting techniques, while others (for instance, using motion-stabilization tools in After Effects or applying a noise-reduction or blur effect) are post-production tasks that facilitate the compression portion of the encoder.

Note: For tips on making movies smaller, see the online Help for After Effects and Adobe Premiere Pro.

- Match the color palette to the correct mobile devices. Mobile devices, in general, have a limited color range. Previewing in Device Central can help determine if the colors used are optimal for an individual device or range of devices.

- Adjust clips. Grayscale view is helpful to compare values.

- Use the presets available in Adobe Media Encoder. Several presets are designed for export to 3GPP mobile devices in Adobe Media Encoder. 3GPP presets come in standard sizes: 176 x 144 (QCIF), 320 x 240, and 352 x 288.

- Crop wisely. A common practice is to work at standard DV project settings and output to a combination of DV, DVD, Flash, WMV and mobile 3GPP. Use the usual presets, but at encoding time manage the difference between 4:3 or 16:9 video and the 11:9 aspect ratio of mobile 3GPP. The AME crop tool allows constraint to arbitrary proportions in the same manner as Photoshop's Crop tool and adds an 11:9 constraint preset to the existing 4:3 and 16:9.

- Work at an aspect ratio consistent with mobile output. New project presets (available only on Windows) make this easy. The frame dimensions are larger than the ultimate output size (working at 176 x 144 can be difficult, for example, for titling), but they match the output-frame aspect ratio to facilitate easy encoding. Each Windows project preset renders to uncompressed video, but most computers can manage the data rate at these reduced frame sizes and halved frame rates. (This process is for projects where the only output is for mobile devices.) Two frame aspect ratios account for the majority of support in mobile devices: 4:3 (QVGA, VGA etc.) and 11:9 (CIF, QCIF, Sub-QCIF). These two common project settings are included in the Adobe Media Encoder “Mobile & Presets” folder.

Note: Do not use the device data in Device Central to determine how to configure a custom preset. Device Central does not have information about video or audio support (frame sizes, codecs, bit rates, and so on). The frame size data in Device Central refers to screen size and wallpaper and screen saver sizes, which are different from video sizes.

For more tips and techniques for creating content for mobile phones and devices, see www.adobe.com/go/learn_cs_mobilewiki_en.
Tips for creating Dreamweaver web content for mobile devices

Device Central previews web pages created in Dreamweaver using Opera's Small-Screen Rendering. This preview can give you a good idea of what a web page looks like on a mobile device.

Note: Opera's Small-Screen Rendering may or may not be pre-installed on any individual emulated device. Device Central simply gives a preview of how the content would look if Opera's Small-Screen Rendering were installed.

Use the tips below to ensure that web pages created in Dreamweaver display well on mobile devices.

• If you use the Adobe® Spry framework to develop content, add the following line of HTML to your pages so they can render CSS and execute JavaScript™ correctly in Device Central:

  `<link href="SpryAccordion.css" media="screen" rel="stylesheet" type="text/css"/>
  <link href="SpryAccordion2.css" media="handheld" rel="stylesheet" type="text/css"/>

• Opera's Small-Screen Rendering does not support frames, pop-ups, underlining, strikethrough, overlining, blink, and marquee. Try to avoid these design elements.

• Keep web pages for mobile devices simple. In particular, use a minimum number of fonts, font sizes, and colors.

• Scaling down image sizes and reducing the number of colors required increase the chances that the images will appear as intended. Use CSS or HTML to specify an exact height and width for each image used. Provide alt text for all images.

Note: The Opera software website is a good source of information about optimizing web pages for mobile devices.

For more tips and techniques for creating content for mobile phones and devices, see www.adobe.com/go/learn_cs_mobilewiki_en.

Testing with the Emulator tab

Open the Emulator tab

The Emulator tab in Adobe® Device Central® is designed to simulate content on mobile devices in a realistic way. You can test various media types such as Flash, bitmap, and video, and apply them as different content types, such as stand-alone player, wallpaper, or screen saver.

Note: Testing with the Emulator tab cuts the cost and time of testing on mobile devices, but should never replace testing on actual devices. Use Device Central for initial tests as you develop content and then use real devices for final testing.

If you are testing Flash content, for a content file to appear on the Emulator tab on a specific device, the device must support the Flash Lite version and content type that the file uses. For example, if you have a SWF file created in Flash that requires Flash Lite 2 and you try to test the file on the Emulator tab on a device that only supports Flash Lite 1.1, the file does not appear. (In this case, try going to the Available Devices list, group the devices by Flash Lite version, and double-click one of the devices that supports Flash Lite 2.)

❖ Do one of the following:

• From Adobe Device Central, select File > Open, navigate to a file, and double-click the file.

• In a supported Adobe application, select to export content for testing, preview the content, or save the content for devices. For example, in Flash the command is Control > Test Movie and in Photoshop the command is File > Save for Web & Devices.
See also

“About content types” on page 32

“Work area components” on page 7

Use the Emulator tab keys with your keyboard

You can use your mouse to click the Emulator tab keypad directly, or you can use the following equivalent keyboard shortcuts:

- The arrow keys on the keyboard (left, right, up, down) map to the corresponding navigation keys on the Emulator tab navigation keypad.
- The Enter, or Return, key corresponds to the Emulator tab select key.
- The Page Up and Page Down keys correspond to the Emulator tab left and right soft keys, respectively.
- The number keys on your keyboard map to the corresponding number keys on the Emulator tab keypad.

Change to a different test device

❖ In the Device Sets or Available Devices list, double-click a new device. Note the following:
- You can emulate only one device at a time.
- If you double-click one device in a current selection, an icon appears next to the double-clicked device. The Emulator tab plays the content from the beginning.
- If you double-click a device other than a current selection, Adobe Device Central removes the selection and selects that device instead. The active device icon $ appears next to the new selected device, which is loaded into the Emulator tab. The Emulator tab plays the content from the beginning.

See also

“Working with devices” on page 11

Rotate the display

❖ Click the Rotate Clockwise button $ or the Rotate Counterclockwise button $ . Click the button repeatedly to rotate each additional 90 degrees.

Zoom in or out

❖ Click the Zoom In button $ or Zoom Out button $ .

Note: Clicking the button repeatedly zooms in or out in the following increments: 25%; 33.33%; 50%, 66.67%, 100%; 200%; 300%; 400%.

Use the detached view on the Emulator tab

The Emulator tab offers a detached view that is useful for testing devices that do not allow you to view the content at 100%, such as clam-shell style mobile phones. (With this style of phone, the normal emulator view might not show all of the content or allow access to the keypad on the skin without scrolling.)

❖ Do one of the following:
- Click the Detached View button $.
• Select View > Detached.

Using the Testing panels

About the testing panels
A number of collapsible panels for testing and performance tuning appear on the right of the Emulator tab. Each panel has options for different media types. The panels that appear depend on what media type you are testing:

• Content Type (Flash, bitmap, video, and web)
• File Info (Flash, bitmap, video, and web)
• Display (Flash, bitmap, and video)
• Memory (Flash)
• Performance (Flash)
• Device Status (Flash)
• Network (Flash)
• Persistent Storage (Flash)
• Rendering (web)
• Scaling (bitmap and video)
• Alignment (bitmap and video)

Use the panels to change settings while testing emulated content.

About content types
Each device supports one or more content types that the device manufacturer determines. In Adobe Device Central, the Device Profiles tab shows what content types are supported for each individual device. Examples of content types are stand-alone player, wallpaper, and screen saver. For each content type that a device supports, the device profile shows relevant settings. When planning the content to deliver, consider the content types that a device supports.

When you preview and test Flash content in Adobe Device Central, the Emulator tab uses the information in the exported file to determine the content type. If you change the content type on the Emulator tab, Adobe Device Central writes the change back to Flash.

Note: Files sent by an application other than Flash and files that you open directly from Device Central (even SWF files) do not have the information about the content types or devices for which they were originally created.
The Flash and bitmap options have multiple content types; web and video each have only one content type. For Flash and bitmap, content type does the following:

- defines the features that are supported on a device
- defines the addressable size, which can be different than display size

**Note:** The content type, paired with the display size of a specific device, determines the addressable area on the screen. The addressable area is the maximum screen width and height in pixels for the content.

In Adobe Device Central, you select a content type on the New Document tab or the Emulator tab. After you select a content type, all devices that do not support the selected content type (or Player version) are dimmed in the Device Sets list and the Available Devices list.

**About content types in Flash Lite** Each Flash Lite installation supports one or more content types. For example, some devices use Flash Lite to enable screen savers or animated ring tones. Other devices use Flash Lite to render content that is embedded in mobile web pages. Not all content types support all Flash Lite features.

Each Flash Lite content type, paired with a specific device, defines a specific set of Flash features that are available to your application. For example, a Flash Lite application that is running as a screen saver is not typically allowed to make network connections or download data.

The Emulator tab lets you test multiple devices and different content types. This ability lets you determine if your application uses features that are not available for the type of content that you are targeting.

If you change the content type during emulation, the Emulator tab reloads the player and plays the application back from the beginning.

If no content-type information is available, the Emulator tab uses the default Standalone Player setting.

**Note:** For additional, up-to-date information about Flash Lite content type availability, see [http://www.adobe.com/go/mobile_supported_devices](http://www.adobe.com/go/mobile_supported_devices).

**About content types in Photoshop, Illustrator, After Effects, and Adobe Premiere Pro** Adobe Device Central supports the full-screen (full pixel size of screen), wallpaper, and screen saver content types for bitmap. The default content type for bitmap media is full screen.

**Note:** The wallpaper and screen saver content types might provide a smaller screen size than the full-screen content type. If you use Photoshop or Illustrator to create mock-ups, prototypes, or assets that are added to another application like Flash, you should start with a full-screen document.

**View file information**

If you are testing any type of content, use the File Information panel to see important details about your file such as name, size, format, and dimensions.

1. Open the Emulator tab by doing one of the following:
   - From Adobe Device Central, select File > Open, navigate to a file, and double-click the file.
   - In a supported Adobe application, specify whether to export content for testing, preview the content, or save the content for devices. For example, in Flash the command is Control > Test Movie and in Photoshop the command is File > Save for Web & Devices.

2. On the Adobe Device Central Emulator tab, expand the File Info panel.
About display options
The options that the Emulator tab provides let you simulate display conditions that might occur on a mobile device. These include conditions that set phone parameters determine, such as the backlight or time out, and conditions that the environment in which the phone might be used determines, such as sunlight on the screen. All display options remain in effect until you change them. The Emulator tab does not retain the Backlight, Timeout, and Reflections display settings for individual devices. (However, the Gamma and Contrast settings are saved for each individual device.)

Change display options
1 Open the Emulator tab by doing one of the following:
   • From Adobe Device Central, select File > Open, navigate to a file, and double-click the file.
   • In a supported Adobe application, open a file and select Control > Test Movie.
2 On the Adobe Device Central Emulator tab, expand the Display panel.
3 Change the following options as necessary:
   Backlight The Backlight slider lets you decrease the brightness of the backlight as it would normally do when going into sleep mode. Some mobile device users also purposely lower their backlight brightness to save battery power. When designing mobile content, check if the content is visible with low backlight. (If you change the backlight settings, the settings stay in place as you open different devices for testing on the Emulator tab.)
   Note: If the Timeout function is enabled, the Backlight slider is disabled. To enable the Backlight slider, turn the Timeout option off.
   Timeout Lets you automatically test the time-out function. The default is unchecked. Checking this option enables the backlight time-out function. In the text fields, set how many seconds before the backlight times out. The default setting is four seconds. Like on the actual device, after the backlight goes out because of inactivity on the device, it turns on again as soon as activity resumes. To ignore any time-out settings while you test, deselect the check box again.
   Contrast Lets you change the display contrast to test the visual appearance of the contents under different contrast conditions. Defaults to 0 with a range of 100 to -100.
   Gamma Lets you change the display gamma to test the visual appearance of the contents with different gamma conditions. Defaults to 0 with a range of 100 to -100.
   Reflections Lets you simulate different environmental conditions in which to test the visual appearance of your content.

Use Opera’s Small-Screen Rendering
If you are testing Dreamweaver content, use the Rendering panel to see how an HTML file appears on a device that supports Opera’s Small-Screen Rendering.
1 Open the Emulator tab by doing one of the following:
   • From Adobe Device Central, select File > Open, navigate to a file, and double-click the file.
   • In Dreamweaver, open a file and select File > Preview In Browser > Device Central.
2 On the Adobe Device Central Emulator tab, expand the Rendering panel.
3 Select Small Screen Rendering.
Turn Small Screen Rendering on and off to see the differences between how your file appears with or without Opera's Small-Screen Rendering.

**Note:** You can enter any website address into the URL box to browse the Internet and preview a real, online website.

**See also**
“Preview mobile content with Adobe Device Central and Dreamweaver” on page 20

### Change or scale image or video file

The Emulator tab either scales or crops the content to fit on the device, according to the information in the device profile.

1. Open the Emulator tab by doing one of the following:
   - From Adobe Device Central, select File > Open, navigate to an image file, and double-click the file.
   - In Photoshop or Illustrator, open a file. Select Save For Web And Devices and click Device Central.
   - In Adobe Premiere Pro or After Effects, open a file. Select File > Export > Adobe Media Encoder. Select H.264 from the Format drop-down menu, check Open in Device Central, and click OK.

2. On the Adobe Device Central Emulator tab, expand the Scaling panel.

3. To test different scaling behaviors, change the following options as necessary:
   - **Use Original Size** Emulates the image in original size.
   - **Stretch to Screen** Resizes the content unproportionally to fit the addressable screen size.
   - **Fit Proportionally** Resizes the content proportionally to fit the addressable screen. Select one of the buttons: Fit Width And Height, Fit Width, or Fit Height.
   - **Scale To** Move the Scale To slider bar to the left (to scale down) or to the right (to scale up).
   - **Fullscreen Mode** (For video content only) Emulates switching the device to Fullscreen mode. For video playback, many mobile devices offer a full-screen setting to enable devices with portrait orientation to better display video files with a landscape orientation. Selecting the Fullscreen Mode option rotates the video 90 degrees in either a clockwise or counter-clockwise direction. (Direction information comes from the device profile and might differ between devices.) To rotate the device, click the Rotate buttons at the bottom of the Emulator tab.
     
     **Note:** In Adobe Device Central, the Fullscreen option is only available for devices that support full-screen mode.

### Change image or video alignment

Alignment sets the position of an image or video file when it appears on a mobile device. Alignment can be important for an image or video file that does not fill the addressable screen size.

1. Open the Emulator tab by doing one of the following:
   - From Adobe Device Central, select File > Open, navigate to an image file, and double-click the file.
   - In Photoshop or Illustrator, open a file. Select Save for Web and Devices and click Device Central.
   - In Adobe Premiere Pro or After Effects, open a file. Select File > Export > Adobe Media Encoder. Select H.264 from the Format drop-down menu, check Open in Device Central, and click OK.

2. On the Adobe Device Central Emulator tab, expand the Alignment panel.

3. Click a horizontal and a vertical alignment button.
Note: Scaling and alignment changes are saved until a device is reloaded. Whenever you reload a device (by double-clicking it), the device returns to the default alignment and scaling settings defined in the profile.

Testing information for Flash

About the Memory panel
Use the Memory panel to monitor application memory use and to adjust various performance parameters in your Flash file to achieve maximum performance. Static and Dynamic Heap values default to the respective sizes included in the device profiles. For example, some devices do not have dynamic heap at all.

The Memory panel appears on the Emulator tab whenever you test a Flash application. A graph reflects static and dynamic heap sizes with differently colored curves. The rightmost point in the curve reflects the current memory usage (also expressed in KB below the curve). In addition, a process bar indicates the currently used memory as a percentage of available memory.

You can use the Memory panel to make testing Flash content more effective. For example, if you have a large Flash file that is too large to test on a specific device, change the static or dynamic memory to a larger number so the file can be viewed. Return to Flash and optimize the file to reduce the size. Test the file again in Adobe Device Central, reducing the static or dynamic memory to see if the file appears accurately. As you test the file, you can watch the graph on the Memory panel to visually locate the large parts of the file. Another way to use the Memory panel is to lower the dynamic heap number to simulate when other activities are taking place on a mobile device, such as a phone call being received.

See also
“Create mobile content with Adobe Device Central and Flash CS3” on page 16

Change the static or dynamic heap size
When you change heap values, the changes are application-wide and not saved on a per-device basis. Resetting to default sizes sets all heap sizes back to their respective defaults as specified in the profiles.

1 Open the Emulator tab by doing one of the following:
   • From Adobe Device Central, select File > Open, navigate to a Flash SWF file, and double-click the file.
   • In Flash, open a file and select Control > Test Movie.

2 On the Adobe Device Central Emulator tab, expand the Memory panel.

3 If testing your file requires a change in the actual heap size available on the device, click Edit.

4 Change the amount in the Static Heap or Dynamic Heap boxes and click OK.

The new amounts appear on the panel in red to show that they are customized and are no longer the correct, default amounts for the selected device. To return to the default, accurate heap sizes for the selected device, click Reset. (This resets both heap sizes to the defaults. To reset a single heap size, click Edit and then click the Reset icon next to the respective heap size field.)

About device calibration
During the initial device emulation (that is, Emulate Performance is not checked), the Emulator tab runs with full desktop or laptop speed. To accurately emulate device performance, calibrate each device on the Emulator tab.
To calibrate the device, the Emulator tab runs a test application and compares the test result with the result stored in the database, which was obtained by running the same test application on the actual device. Device Central derives an index number based on the comparison. This enables Device Central to know how much to slow down the desktop or laptop computer to emulate the device. It also gives Device Central a way to group devices into Performance Index categories. The categories let you compare device performance (i.e., a high index number indicates a high-performing device). Player version, display size, heap size, monitor size, and the computer's memory consumption all affect the calibration result.

Most of the Performance options, except for Rendering and Calibrate, remain disabled for any device that is not calibrated. After you perform the first calibration for a device, all performance options are enabled for that device.

To achieve accurate emulation results, perform device calibration frequently because other processes running on your computer affect performance.

**Calibrate a device**

1. Open the Emulator tab by doing one of the following:
   - From Adobe Device Central, select File > Open, navigate to a Flash SWF file, and double-click the file.
   - In Flash, open a file and select Control > Test Movie.
2. On the Adobe Device Central Emulator tab, expand the Performance panel.
3. Click Calibrate.
   
   A progress bar appears as the calibration proceeds.
4. To enable all options, select Simulate Performance.

**Test content performance**

To tune your content file for maximum performance, adjust any combination of speed, rendering quality, and memory use before you run the emulation.

1. Select a device that you have calibrated.
2. If memory is a factor, open the Memory panel, click Edit, and change the value for Static Heap, Dynamic Heap, or both.

You can enter values higher or lower than the default. You might set the static heap value, which is guaranteed, to a value higher than the default. This setting allows you to downsize the application, step by step, until it meets the device constraints. You can reduce the dynamic heap size to emulate cases where other processes on the device could consume the dynamic memory.
3 Select Simulate Performance.

4 If execution speed is a factor, adjust the speed. On the Performance panel, move the Speed slider to the right or left, to increase or decrease the execution speed. The default application execution speed is 100%, which is relative to the performance category as defined in the database.

Note: The slider position is saved on a per-device basis.

5 If rendering quality is a factor, adjust the rendering quality. The default is Medium. Increasing quality results in better visual appearance, but usually at the cost of a slower refresh rate (performance).

If the application uses enough memory to exceed either heap size you specified on the memory panel, the player stops, but the frame at which the player stopped remains displayed to show you where the high memory usage occurred. The Output window appears with an Out Of Memory error.

6 To show performance on the selected mobile device (not your computer), click Emulate Performance.

Note: The category listed on the Performance panel is derived from the calibration process and is the way that Adobe groups devices based on performance. Comparing the categories of different mobile devices shows which are higher performing devices.

About language settings in Device Central

Changing the Language setting displays the emulated content using the fonts that are associated with the device in your preferences (File menu > Preferences). The Emulator tab displays fonts that are as similar as possible to those used on the actual device. If you have the actual device font, change your font mapping to that font to emulate the content as accurately as possible.

When you change the Language setting on the Device Status panel, ensure that a matching font is installed on your computer and that the font is mapped to the language in Preferences. For example, if you change the Adobe Device Central language setting to Japanese, but do not have any Japanese fonts installed or mapped in Preferences, the Emulator cannot display text in Japanese.

Note: The Device Central Language setting is comparable to the Flash Locale setting. The setting applies to values returned from the host environment such as Flash Player or the device operating system.

The language setting also controls the formatting applied to date and time. For example, with language set to German, the date and time appears as 20. Maerz 2006, but set to English it appears as March 20, 2006.

Note: Advanced users familiar with XML can extend the list of languages provided through the Language combo box. To do this, edit the DeviceLanguages.lng file in the Devices folder where Adobe Device Central is installed. On Windows® XP, the default location is C:\Documents and Settings\username\Local Settings\Application Data\Adobe\Adobe Device Central CS3. On Windows® Vista™, the default location is C:\Users\username\AppData\Local\Adobe\Adobe Device Central CS3. On Mac OS, the default location is: user folder/Library/Application Support/Adobe/Adobe Device Central CS3/Devices/devicelanguages.lng.
See also

“Change the application language” on page 10

**Change the language, time zone, date, or time**

For Flash applications, the Emulator tab provides a Device Status panel. The data on the Device Status panel can be accessed through FSCommands in Flash Lite content. The Emulator tab keeps Device Status settings with the application; they are not saved with the device.

Setting the time zone issues a `GetTimezoneOffset()` FSCommand. You might want to test a script that performs a specific action when you switch time zones, for example. The time zone options provided follow the same pattern as the Time Zone settings on the Windows system control panel.

Setting the date or time issues a `getDate()` or `getTime()` FSCommand. These commands provide the date and time information in the device's operating system to the Flash application.

❖ On the Device Status panel, choose a different language, time zone, date, or time.

**Change the volume or battery level**

You can change the volume or battery level to simulate actual conditions on a device. For example, you can change the battery level to 10% without having to wait until the battery actually decreases to 10% power. This is helpful, for example, to test that a low battery indicator appears when the battery reaches a certain level.

1 Open the Emulator tab by doing one of the following:
   • From Adobe Device Central, select File > Open, navigate to a Flash file, and double-click the file.
   • In Flash, open a file and select Control > Test Movie.
2 On the Adobe Device Central Emulator tab, expand the Device Status panel.
3 Move the Volume or Battery level slider bar to increase or decrease the level.

**Simulate an external power source**

1 Open the Emulator tab by doing one of the following:
   • From Adobe Device Central, select File > Open, navigate to a Flash file, and double-click the file.
   • In Flash, open a file and select Control > Test Movie.
2 On the Adobe Device Central Emulator tab, expand the Device Status panel.
3 Select Charger.

**Network options and Flash Lite FSCommands**

In Flash Lite you can add commands and properties to obtaining connectivity and network status information. The options on the Adobe Device Central Network panel issue the following `fscommand2()` commands:

- `+GetNetworkName`
- `+GetNetworkGeneration`
- `+GetNetworkStatus`
- `+GetNetworkConnectStatus`

*Note: For details about these commands, see the Flash Lite documentation.*
The Adobe Device Central Network panel options are related to the following `fmcommand2()` commands:

- `+Name=>GetNetworkName` (type any custom network name for the emulator to return for testing)
- `+Generation=>GetNetworkGeneration`
- `+Connection=>GetNetworkConnectStatus`
- `+Status=>GetNetworkStatus`

**Change network information**

The Network panel does not simulate actual network conditions (because so many variables are involved), but it can test certain conditions such as ActionScript code in the content file designed to display an alert if there is no network available on the mobile device.

1. Open the Emulator tab by doing one of the following:
   - From Adobe Device Central, select File > Open, navigate to a Flash file, and double-click the file.
   - In Flash, open a file and select Control > Test Movie.
2. On the Adobe Device Central Emulator tab, expand the Network panel.
3. Change the settings as necessary.

**About persistent storage**

The Flash Lite version of the SharedObject class offers persistent data storage on the device. It allows SWF files to save data to the device when it is closed and load that data from the device when it is played again. For more information, see the Flash Lite 2.0 documentation.

You can use the Adobe Device Central Persistent Storage panel to determine how full storage is on a device. The Used/Free indicator is a per-device value, so if multiple SWF files write to the persistent storage, the value is the sum of all their data.

**Change persistent storage amount**

1. Open the Emulator tab by doing one of the following:
   - From Adobe Device Central, select File > Open, navigate to a Flash file, and double-click the file.
   - In Flash, open a file and select Control > Test Movie.
2. On the Adobe Device Central Emulator tab, expand the Persistent Storage panel.
3. To clear the storage for the device you are emulating, click Empty.

The Emulator tab removes all persistent objects for all content that ran on that device, and runs your content again.

*Note: The Flash Lite version of the SharedObjects class does not support sharing data between different SWF files and even considers a modified version of the same file as a different file. As a result, when testing the same file over and over again, the persistent storage can grow large quickly.*
Obtain information from the Flash Output window

The Flash Output window in Adobe Device Central and the Output window in Flash track the same messages in parallel. In Flash, the Output panel is used in test mode and shows information that is helpful when troubleshooting a SWF file. In Adobe Device Central, the Flash Output window is a floating window that automatically opens when an error occurs in the Flash file you are testing. The Flash Output window in Adobe Device Central can show four different types of messages: Trace, Info, Warning, and Errors.

Note: Detailed information about trace, info, warning, and error messages can be found in the Flash help system.

1. Open a Flash file in Adobe Device Central.
2. Select View > Flash Output > Show.
3. Do any of the following, as required:
   • To show or hide a particular type of message, select View > Flash Output > Show again and select or deselect Trace, Information, or Warnings.
   • To change how long lines of text are displayed, select View > Flash Output > Show again and select or deselect Word Wrap. (If word wrap is selected, long lines of text in the Output window wrap automatically so you do not have to use the horizontal scroll bar to view all the text.)
   • To clear the content, click the pop-up menu button above the vertical scrollbar and select Clear.
   • To copy text, select the text in the Output window, click the pop-up menu button above the vertical scrollbar and select Copy.
Index

A
accessibility of Help 2
ActionScript in mobile devices 24
Adobe After Effects
content types 33
optimizing After Effects content for mobile devices 29
testing mobile content created in 19
testing panels 8
Adobe Design Center 5
Adobe Dreamweaver
optimizing Dreamweaver content for mobile devices 30
testing mobile content created in 20
testing panels 8
Adobe Flash
creating mobile content in 16
optimizing Flash content for mobile devices 20
testing panels 8
Adobe Help 1
Adobe Illustrator
content types 33
optimizing Illustrator content for mobile devices 28
testing mobile content created in 18
testing panels 8
Adobe Photoshop
content types 33
optimizing Photoshop content for mobile devices 27
testing mobile content created in 17
testing panels 8
Adobe Premiere Pro
content types 33
optimizing Premiere Pro content for mobile devices 29
testing mobile content created in 19
testing panels 8
Adobe Video Workshop 3
After Effects. See Adobe After Effects
alignment (image and video files) 35
Animations panel 8
animations in mobile devices 21
application language 10
Available Devices panel 8
B
backlight setting 34
battery level 39
bitmap images
compressing for mobile devices 22, 23
in mobile devices 22
Bridge Home 4
brightness setting 34
C
calibration, mobile device 36
classes excluding from compilation 27
compression for mobile devices 22, 23
content performance testing 37
Content Type panel 8
content types about 32
Flash Lite 33
grouping devices by 12
contrast setting 34
cropping 35
D
date formatting 39
Design Center 5
device calibration 36
device profiles 11, 15
Device Profiles tab 8
device sets adding devices 14
creating 13, 14
creating subsets 14
deleting 14
exporting 15
importing 15
moving devices in 15
Device Sets panel 7
Device Status panel 8
devices fonts 10
grouping 12
searching for 12
updating list 15
display options 34
Display panel 8
downloads
updates, plug-ins, and tryouts 5
Dreamweaver. See Adobe Dreamweaver
dynamic heap size 36, 37
E
Emulator tab 8, 30, 31
environmental settings 34
exporting device sets 15
external power sources 39
Extras 3
F
File Information panel 8, 33
file size
 reducing for mobile devices 27
Flash
fscommands 39
testing files 36
Flash Lite 33
Flash Player 32
Flash. See Adobe Flash
font mapping 10
frames in mobile devices 23
fscommands 39
Fullscreen mode 35
G
gamma setting 34
H
heap size 36, 37
Help 1
HTML files 34

I
Illustrator. See Adobe Illustrator
image files 35
IMEI numbers 9
importing device sets 15

K
keyboard shortcuts 31
keyboard shortcuts in Help 2

L
language (application) 10
language setting 39
light settings 34
LiveDocs 1
loading data in mobile devices 26

M
mapping fonts 10
media formats 7
memory 37
managing in mobile devices 25
Memory panel 8, 36
mobile devices
optimizing After Effects content
for 29
optimizing Dreamweaver content
for 30
optimizing Flash content for 20
optimizing Illustrator content
for 28
optimizing Photoshop content
for 27
optimizing Premiere Pro content
for 29

N
navigation shortcuts 2
Network panel 8
network setting 40
New Document tab 8, 33

O
Opera’s Small-Screen Rendering 34

P
Performance panel 8
performance testing 37
Persistent Storage panel 8, 40
phone IDs 9
Photoshop. See Adobe Photoshop
plug-ins 4
in Adobe Store 5
power sources 39
preferences 9

R
reflections setting 34
rendering 37
Rendering panel 8, 34
resizing 35
rotating (in Emulator tab) 31

S
scaling 35
screen savers 32
searching (device list) 12, 13
Small-Screen Rendering 34
software downloads 5
Sound panel 8
speed testing 37
stand-alone Flash Player 32
static heap size 36, 37
stretching (image and video files) 35

testing panels 8, 32
text
in mobile devices 22
time formatting 39
timeout setting 34
tryouts 5

U
undo levels 9
updates 5
updating device list 15

V
vector graphics
in mobile devices 22
video files 35
for mobile devices 29

W
wallpaper 32

Z
zooming 31

Video Workshop 3
volume level 39