Notice to U.S. government end users. The software and documentation are "Commercial Items," as that term is defined at 48 C.F.R. §2.101, consisting of "Commercial Computer Software" and "Commercial Computer Software Documentation," as such terms are used in 48 C.F.R. §12.212 or 48 C.F.R. §227.7202, as applicable. Consistent with 48 C.F.R. §12.212 or 48 C.F.R. §227.7202-1 through 227.7202-4, as applicable, the Commercial Computer Software and Commercial Computer Software Documentation are being licensed to U.S. Government end users (a) only as Commercial items and (b) with only those rights as are granted to all other end users pursuant to the terms and conditions herein. Unpublished-rights reserved under the copyright laws of the United States. Adobe Systems Incorporated, 345 Park Avenue, San Jose, CA 95110-2704, USA. For U.S. Government End Users, Adobe agrees to comply with all applicable equal opportunity laws including, if appropriate, the provisions of Executive Order 11246, as amended, Section 402 of the Vietnam Era Veterans Readjustment Assistance Act of 1974 (38 USC 4212), and Section 503 of the Rehabilitation Act of 1973, as amended, and the regulations at 41 CFR Parts 60-1 through 60-60, 60-250, and 60-741. The affirmative action clause and regulations contained in the preceding sentence shall be incorporated by reference.
# Contents

## Chapter 1: Getting Started
- Resources ................................................................. 1
- Activation and registration ........................................... 1
- Help and support ....................................................... 2
- Services, downloads, and extras .................................... 3
- What’s new in Adobe Captivate 4 .................................. 3

## Chapter 2: Workspace
- Adobe Captivate views .................................................. 5
- Timeline ........................................................................ 9
- Toolbars ....................................................................... 12
- Panels ......................................................................... 13
- Adobe Captivate Library ............................................... 13
- Grids ........................................................................... 14
- Shortcut keys ............................................................... 15
- Undoing and redoing actions ......................................... 19
- Disable confirmation messages ...................................... 20

## Chapter 3: Creating Projects
- About Adobe Captivate projects ................................... 21
- Create projects ............................................................ 22
- Enable backup file creation .......................................... 26

## Chapter 4: Recording Projects
- Automatic recording ..................................................... 27
- Full motion recording ................................................. 30
- Manual recording ....................................................... 31
- Hide recording icons and info in the recording window .... 31
- Record additional slides .............................................. 31
- Pause while recording projects ..................................... 32
- Set recording preferences ........................................... 32
- Automate the recording process ................................... 36
- Recording tips ............................................................ 37

## Chapter 5: Slides
- Slide properties ............................................................ 39
- Add slides ................................................................. 41
- Delete and edit slides .................................................... 45
- Lock slides ............................................................... 47
- Hide slides ............................................................... 47
- Group slides ............................................................ 47
- Change slide order ..................................................... 48
- Slide notes ............................................................... 48

Updated 19 May 2009
Chapter 6: Adding and Managing Objects
Types of objects ................................................................. 52
Controlling the visibility of objects ..................................... 52
Import objects ................................................................. 53
Manage Library objects ..................................................... 54
Managing objects with the Stage toolbar ............................ 55
Copy, paste, and duplicate objects .................................... 55
Align objects ................................................................. 56
Resize and reposition objects by pixel ................................ 59
Change the display order of objects ................................... 59
Merge objects into a slide ................................................ 60
Edit object information in the Advanced Interaction dialog box 60

Chapter 7: Noninteractive Objects and Media
Text captions ................................................................. 62
Rollover captions ........................................................... 72
Highlight boxes .............................................................. 74
Mouse ........................................................................... 75
Rollover slidelets ........................................................... 79
Zoom areas .................................................................... 82
Images and rollover images ............................................. 84
Drawing tools .................................................................. 87
Animations ...................................................................... 90
Video ............................................................................. 93
Set audio for noninteractive objects ................................. 96
Fix size and position of noninteractive objects .................. 96

Chapter 8: Interactive Objects
Defining project navigation ............................................... 97
Click boxes ..................................................................... 98
Text entry boxes ............................................................ 101
Buttons .......................................................................... 105

Chapter 9: Widgets
About widgets .................................................................. 113
Create widgets ................................................................ 116
Defining visibility mode for widgets ................................. 119
Using XML in widgets .................................................... 121
Using variables in widgets .............................................. 122
Using ActionScript 3.0 in widgets ..................................... 122
Accessing Adobe Captivate movie properties .................... 123
Question widgets ........................................................... 125
Add widgets .................................................................... 126
Troubleshooting widgets ................................................ 127

Updated 19 May 2009
Chapter 10: Audio
Adding audio ............................................................................................................ 128
Recording in sync ..................................................................................................... 128
Insert audio .............................................................................................................. 133
Preview audio ......................................................................................................... 135
Edit audio ................................................................................................................ 136
View audio details .................................................................................................. 141
Export audio ............................................................................................................ 142

Chapter 11: Variables and Advanced Actions
Variables .................................................................................................................. 143
Advanced actions .................................................................................................... 146
Tutorial on scripting ............................................................................................... 148
ActionScript .......................................................................................................... 150
Assign multiple actions to an event ...................................................................... 151

Chapter 12: Creating a Quiz
Preferences ............................................................................................................. 152
General workflow for question slides .................................................................. 155
Create question slides .......................................................................................... 157
Question pools and random questions ................................................................. 161

Chapter 13: Advanced Editing and Project Reviews
Projects and project preferences ........................................................................... 165
Edit FMR files ....................................................................................................... 169
Create design templates ....................................................................................... 170
Skins ....................................................................................................................... 172
Table of contents (TOC) ...................................................................................... 175
Preview projects .................................................................................................... 179
Combining multiple SWF files with aggregator .................................................. 179
Combining multiple SCOs with aggregator .......................................................... 181
Resize projects ...................................................................................................... 182
Spelling and search .............................................................................................. 183
Link Adobe Captivate projects ............................................................................ 186
View bandwidth utilization ................................................................................... 186
Creating accessible projects ............................................................................... 187
Localizing Adobe Captivate projects .................................................................. 191
Import, export, and delete content ....................................................................... 193
Using the AIR Review application .................................................................... 195

Chapter 14: Publishing Projects
Change the default location of published files .................................................... 200
Set publishing preferences ................................................................................... 200
Publish a project as a SWF file ............................................................................. 201
Publish the project as an executable file or AVI file ............................................. 203
Publish projects to the web using FTP ................................................................ 204
Send projects using e-mail ................................................................................... 205
Get reports by e-mail ............................................................................................ 206
Chapter 15: Using Adobe Captivate with Other Applications
Microsoft PowerPoint ................................................................. 208
Microsoft Word ........................................................................... 213
Learning management system (LMS) ............................................ 216
Adobe Acrobat Connect Pro ......................................................... 220
Questionmark Perception ............................................................. 224
Adobe Flash ................................................................................ 225
RoboHelp .................................................................................... 227

Chapter 16: Troubleshooting
Adobe Captivate project startup .................................................. 229
Animation timing ......................................................................... 229
Application distortion when recording ........................................... 229
Capturing while recording a web application ................................. 230
Capture of elevated applications in Windows Vista ....................... 230
Choppy full motion recording ...................................................... 230
Correcting colors in slides ........................................................... 230
Fonts on transparent captions ...................................................... 231
Adobe Captivate output .............................................................. 231
Video errors ................................................................................ 232
Text viewed in a browser .............................................................. 232
Font size in text entry boxes ......................................................... 233
Button sizes while resizing projects ............................................. 233
The number of slides in a project ................................................ 233
Publishing projects ...................................................................... 234
Quizzing errors ........................................................................... 234
Exporting projects to Flash ........................................................ 234
JavaScript that does not appear .................................................... 235
The Skin Editor ............................................................................ 235
Uninstalling Adobe Captivate ....................................................... 235
Security warning with Flash Player 8 .......................................... 236
Recording audio produces recording(Clip).wav file ....................... 236
Slide Notes .................................................................................. 236

Index ............................................................................................ 238
Chapter 1: Getting Started

Resources

Before you begin working with your software, take a few moments to read an overview of activation and the many resources available to you. You have access to instructional videos, plug-ins, templates, user communities, seminars, tutorials, RSS feeds, and much more.

Activation and registration

To review complete system requirements and recommendations for your Adobe® Captivate® software, see the ReadMe file on the installation disc.

Install the software

1. Close any other Adobe applications open on your computer.
2. Insert the installation disc into your hard drive, and follow the onscreen instructions.

Note: For more information, see the ReadMe file on the installation disc.

Help with installation

For help with installation issues, see the Installation Support Center at www.adobe.com/go/learn_cp_install_en.

License activation

During the installation process, your Adobe software contacts an Adobe server to complete the license activation process. No personal data is transmitted. For more information on product activation, visit the Adobe website at www.adobe.com/go/activation.

A single-user retail license activation supports two computers. For example, you can install the product on a desktop computer at work and on a laptop computer at home. If you want to install the software on a third computer, first deactivate it on one of the other two computers. Choose Help > Deactivate.

Register

Register your product to receive complimentary installation support, notifications of updates, and other services.

- To register, follow the onscreen instructions in the Registration dialog box, which appears after you install the software.

If you postpone registration, you can register at any time by choosing Help > Registration.
ReadMe
A ReadMe file for your software is available online and on the installation disc. Open the file to read important information about topics such as the following:

- System requirements
- Installation (including removing the software)
- Activation and registration
- Troubleshooting
- Customer support

Help and support

Community Help
Community Help is an integrated environment on Adobe.com that gives you access to community-generated content moderated by Adobe and industry experts. Comments from users help guide you to an answer. Search Community Help to find the best content on the web about Adobe products and technologies, including these resources:

- Videos, tutorials, tips and techniques, blogs, articles, and examples for designers and developers.
- Complete online Help, which is updated regularly and is more complete than the Help delivered with your product. If you are connected to the Internet when you access Help, you automatically see the latest online Help rather than the set delivered with your product.
- All other content on Adobe.com, including knowledgebase articles, downloads and updates, Adobe Developer Connection, and more.

Use the Help search field in your product’s user interface to access Community Help. You can search for content within the Adobe.com site and also in websites that have useful information about your product. Moderators continue to identify the most relevant web content for your product. You can add comments to online Help and view comments added by other users. For a video of Community Help, see www.adobe.com/go/learn_community_help_en.

Adobe Help Viewer 2
Adobe Help Viewer 2 is an Adobe® AIR™ application that seamlessly merges the online and offline experience. When online, you get the most recently updated product Help on the web. You can also access an Adobe PDF version of Help. When offline, you access Help installed with the product on your system. Adobe Help Viewer 2 has a user-friendly interface that supports advanced navigation features. For example, you can get overviews of topics through mini TOCs and bookmark local and online content.

The search feature supports both online and offline modes. Adobe Help Viewer 2 searches content in Community Help when you are online and the Help installed with the product when you are offline. Online search suggestions offer relevant results from product Help, Adobe.com, and other websites. Offline search uses indexes to return preferred topics for key terms.

You can use the commenting feature to post your comments to Adobe.com or add notes for your own reference. Your feedback on Help content is welcome.

Note: For a video of Adobe Help Viewer, see www.adobe.com/go/learn_air_viewer2_en.
Other resources
Online Help also includes a link to the complete, updated PDF version of Help.
Visit the Adobe Support website at www.adobe.com/support to learn about free and paid technical support options.

Services, downloads, and extras
You can enhance your product by integrating various services, plug-ins, and extensions in your product. You can also download samples and other assets to help you get your work done.

Adobe Exchange
Visit the Adobe Exchange at www.adobe.com/go/exchange to download samples as well as plug-ins and extensions from Adobe and third-party developers. The plug-ins and extensions can help you automate tasks, customize workflows, create specialized professional effects, and more.

Adobe downloads
Visit www.adobe.com/go/downloads to find free updates, trials, and other useful software.

Adobe Labs
Adobe Labs at www.adobe.com/go/labs gives you the opportunity to experience and evaluate new and emerging technologies and products from Adobe. At Adobe Labs, you have access to resources such as these:
• Prerelease software and technologies
• Code samples and best practices to accelerate your learning
• Early versions of product and technical documentation
• Forums, wiki-based content, and other collaborative resources to help you interact with like-minded users
Adobe Labs fosters a collaborative software development process. In this environment, customers quickly become productive with new products and technologies. Adobe Labs is also a forum for early feedback. The Adobe development teams use this feedback to create software that meets the needs and expectations of the community.

Adobe TV

What's new in Adobe Captivate 4
Adobe® Captivate® 4 software is packed with new features that help you work faster, collaborate more effectively, and create more realistic and engaging e-Learning content with advanced interactivity, software and scenario simulations, quizzes, tables of contents, widgets, and more—all without programming or multimedia skills.

Updated 19 May 2009
Here are the top new features of Adobe Captivate 4:

**SWF commenting** Accelerate content creation cycles with real-time reviews in Adobe Captivate Reviewer, an Adobe AIR™ application. Reviewers can add comments to your SWF files while playing them without having Adobe Captivate installed, and comments will be imported to the appropriate slides in your project.

**Project templates** Use enhanced project templates that make it easy for subject-matter experts to contribute instructionally sound content without compromising structure.

**Customizable widgets** Create more compelling learning experiences by including widgets such as games, question types, and more. Create widgets in Adobe Flash® Professional software, easily share them via Adobe Exchange®, and customize them to meet your content needs.

**Round-trip PowerPoint workflow** Leverage existing Microsoft® PowerPoint® 2007 (PPTX format) slides in your projects. Import slides with audio and interactivity, and easily update the imported content from Adobe Captivate, keeping your PowerPoint and Adobe Captivate files in sync with the linked import option.

**Table of Contents and Aggregator** Enable learners to easily navigate through content and track their progress with a multilevel Table of Contents. Also, use the Aggregator to combine multiple content modules to create a complete e-Learning course.

**Text-to-speech functionality** Keep learners tuned in to your content thanks to automatic voice-over functionality that turns text to high-quality speech.

**Variables and Advanced Actions** Use Variables to personalize the learning experience by using learner-provided data, such as the learner’s name, throughout a scenario. Use Advanced Actions to further configure and modify the experience by enabling conditional actions, or more than one action in an interaction.

**Expanded output options** Embed Adobe Captivate movies in Adobe PDF files to enliven text-based instructional content, or embed your movies in Adobe® Flex® content using Adobe® ActionScript® 3.0 publishing. Output AVI files for streaming on the web or publishing to YouTube™.

**Adobe Photoshop layer support** Preserve layers in imported Adobe® Photoshop® (PSD) files so you can easily edit or animate individual image areas for the effect you want.

**Streamlined workflows and enhanced usability** Use workflow and usability enhancements, including inline editing of text captions, templates to standardize the look and feel of projects, panning to optimize viewing on small screens and devices, support for right-clicking in simulations, drawing tools and image editing, and improved accessibility features.
Chapter 2: Workspace

The Adobe Captivate workspace is designed to help you create a movie in the shortest possible time.

Adobe Captivate views

Adobe Captivate has three main views: Storyboard, Edit, and Branching. Use the view menu, or press Control+Tab to navigate between views. Each view features a window at the bottom of the screen where you can view, add, and edit notes about individual slides in your project. The notes are visible to viewers viewing the source files. They do not appear in the published output.

Storyboard view

This view appears when you open a project from the Start page. In Storyboard view, you can see all the slides and slide groups in the project. The slides are arranged in the order in which they are displayed in the movie. The storyboard view is made of four panels:

- **Slide Tasks** You can use the various options in this panel to change the properties of selected slides in the slide panel.

- **Information** Provides details about the project. The following information is available in the panel:
  - **Size** Size of the SWF file that is generated using the project. The size does not take into account the compression techniques used before publishing the file. So, there could be a difference between the mentioned size and the size of the SWF file generated after publishing. The time taken for the SWF file to download at the specified streaming is also displayed in kilobits per second.
  - **Time** Time, in seconds, required to play the movie completely. The total number of frames that are displayed in this interval is also displayed.
  - **Audio** The combined size of the audio files in the movie. The download speed of the audio file at the specified streaming is also displayed in kilobits per second.
  - **Video** The size of the SWF file excluding the size of the audio files in the project. The download speed of the audio file at the specified streaming is also displayed in kilobits per second.
  - **Lowest Stream** The value used to calculate the download speed of the audio and SWF files. For example, Broadband indicates that broadband speed is being used to calculate the download time.
  - **Resolution** Dimensions of the project, in pixels.
  - **Slides** Number of slides in the project including hidden slides.

- **Slides** Displays the slides in the project. You can use this panel to move slides to their desired locations in the project. The slides are displayed in the movie in the order of their slide numbers. It is always a good idea to name slides because their numbers change when they are moved to another location.

- **Slide Notes** If you want to add additional information about the selected slide for yourself or for other people viewing the source files, add slide notes. The notes are not displayed when the movie is played. For more information, see “Slide notes” on page 48.

You can do the following in Storyboard view:

- Move slides to other locations. The numbering of the slides automatically changes when you move the slides.
• Group slides.
• View project information.
• Set various properties for the slides using the Slide Tasks menu.

You can change the properties of multiple slides at the same time. To select multiple slides, hold down the Shift or Control key while clicking slides. To select all slides, press Control+A.

**Edit view**

This view appears when you double-click a slide in Storyboard or Branching view. After recording an Adobe Captivate project, you will probably spend most of your time in Edit view. You can close any panel in the Edit View using the Window menu. The panel containing the slide however, cannot be hidden.

The Edit view consists of the following panels:

**Menu bar**  Lists all the options that you can use when working with Adobe Captivate. Adobe Captivate has a dynamic menu bar in that the options in the menu change according to the selected object.

**Toolbar**  The toolbar displays icons that act as a shortcut to the options available in the menu bar.

**Filmstrip**  Displays a thumbnail view of the slides in the movie in the order of their appearance. You can use this view to move slides as you can in Storyboard view. When you select a slide in the Filmstrip, the corresponding slide appears in the Slides panel.

You can increase the size of the Slides panel by reducing the size of the Filmstrip. To change the size of the Filmstrip, drag the splitter bar toward the outside of the program window.

• The Filmstrip displays all of the slides in your project in viewing order. You can change the slide order by dragging a slide to a new location within the project. (To select multiple slides, hold down the Shift or Control key when clicking on slides; to select all slides, press Control+A.)

• If a slide has a label (short title) assigned, the label appears under the slide. It might be easier to move slides and jump to a specific slide if you have assigned labels instead of just using the slide number.
• If a slide has an audio file associated with it, the audio icon appears in the lower-right corner of the slide. You can click the sound icon to show a menu with sound options such as Play, Import, and Edit.

![Slide with audio](image1)

• If a slide is locked, the lock icon appears in the lower-right corner of the slide. You can click the lock icon to unlock the slide.

![Locked slide](image2)

• If a slide contains mouse movement, the mouse icon appears in the lower-right corner of the slide.

![Slide with mouse movement](image3)

• When the display for the Question Pool tab has been turned on, you can change the view in the Filmstrip between the main project and the question pools by clicking the appropriate tabs.

**Slides**  Displays the slide that has been selected in the Filmstrip. You can edit the slide by adding, deleting, or modifying objects in this view.

_for maximum editing space, open a project and press F11 to display Adobe Captivate in full-screen edit view._

**Timeline**  Displays the Timeline for the specified slide. The slide and its objects appear as different layers in the Timeline. You can do the following using the Timeline:

• Change the time during which the object or slide plays during the movie.
• Change the order of appearance of the objects on the slide.
• Hide objects on the slide.
• Lock objects on the slide that you do not want edited.

![Timeline](image4)

**Slide Notes**  Similar in appearance and functionality to the slide notes in Storyboard view. For more information, see “Slide notes” on page 48.

**Object Toolbar**  Displays shortcuts to the various objects that you can add to the slide.

**Library**  Displays the list of images, audio, and video files that you have previously inserted into the project. You can drag objects from the Library to the slide instead of inserting them.
In addition to the above panels, the Edit view might also contain other windows that you have opened.

**Branching view**

This view appears when you click the Branching tab. The Branching view gives you a visual representation of all links between the slides in a project and lets you quickly edit those links. The main pane displays the type of link between slides and lets you find and select the slide you want to review. The bottom pane displays and lets you add notes for the slide selected in the main pane.

The Branching view is particularly helpful when creating instructional materials containing question slides and specifying different paths for right and wrong answers. For example, you can set one action (such as “Go to the next slide”) when a user supplies a correct answer, and you can set a different action (such as “Open URL or file”) when a user supplies an incorrect answer. Using the Branching view, you can easily make changes to the branching design.

You can export the Branching view of an existing Adobe Captivate project into a BMP, JPEG, or JPG file.

**Properties** The Properties panel shows the link properties of the selected slide or link, and lets you edit the navigation type. Click a slide or the arrow between slides to view and edit the properties of the link. When you’ve made changes to that link, click Apply. Links between interactive objects (such as a button to send e-mail or open JavaScript) have icons between slides instead of arrows. The Legend panel shows the various arrows and icons and their meanings.

**Overview** The Overview panel indicates which portion of the project you’re reviewing in the main Branching pane.

**Legend** The Legend panel defines how each type of link between slides is displayed in the main Branching pane.

**Tools** The Tools panel has icons that act as shortcuts for the various actions you can perform in the Branching view:

- **Edit Slide** Opens the selected slide in Edit view.
- **Expand Slide Path** All the slides are opened up for display. Use the same icon to toggle between the expanded and collapsed views.
- **Create Slide Group** Combines the selected slides into a single group.
- **Edit Slide Group** Opens a dialog box that you can use to name the group and assign a border color for the slides in that group.
- **Expand** Displays all the slides belonging to the group. The slides in a group are usually in a collapsed state.
- **Remove Slide Group** Ungroups the grouped slides.
- **Zoom In /Zoom Out** Displays a magnified view of the branching when zoomed in.
- **Zoom Left/Zoom Right/Zoom Up/Zoom Down** Moves the slides in the specified direction.
- **Browse Forward** Branching view displays slides starting from the selected slide.
- **Browse Back** Slides from the previous view are displayed. For example, if you had browsed into slide number 12 earlier, the Branching view now displays slides starting with slide number 1.
- **Export Branching View** Export the Branching view as a JPEG or BMP file using the dialog box that appears.

**Slide Notes** Similar in appearance and functionality to the slide notes in Storyboard view.
Timeline

The Timeline is a visual representation of all objects on slides. The Timeline provides an easy way to view, at a high level, all objects on a slide and their relationship to each other. With the Timeline, you can organize objects and precisely control the timing of objects. For example, on a slide that contains a caption, an image, and a highlight box, you can display the caption, then the image 4 seconds later, and then the highlight box 2 seconds after that. The Timeline also shows any audio associated with the slide or with objects on the slide, letting you easily coordinate the timing of audio with objects.

The Timeline header shows time, in seconds (1s for 1 second, 2s for 2 seconds, and so on), so you see exactly when objects appear.

The major components of the Timeline are objects, the header, and the playhead. The objects on a slide are displayed as stacked bars in the right pane of the Timeline. The header at the top of the Timeline indicates time in seconds (and parts of seconds). The playhead shows the point in time in which the slide is being viewed.

You can use the Timeline to hide or lock objects easily. This is useful when a slide contains many objects and you need to edit the objects separately.

Rest the mouse pointer over any bar in the Timeline and use the hint message that appears to view details about the timing of that object.

Show or hide the Timeline

1. Open an Adobe Captivate project.
2. Double-click any slide to open Edit view.

   By default, the Timeline appears along the top of the slide.
   
   a. If it is not open already, select Window > Timeline.
      
      If you are not able to see the Timeline even after doing this, click the splitter bar arrow.
   b. To close the Timeline, select Window > Timeline again.
   c. To expand the Timeline, click the small, black display arrow. To close the Timeline, click the display arrow again.

Change the location of the Timeline

By default, the Timeline appears docked at the top of the slide in Edit view. To customize it, first open a project and double-click any slide to open Edit view.

*Note: Adobe Captivate remembers the position of the Timeline (location and size). If the Timeline is displayed when Adobe Captivate closes, the Timeline appears in the same location the next time Adobe Captivate is opened.*

- To dock the window Timeline, click the title bar of the Timeline and drag the Timeline to the top or bottom edge of the slide.
To place a Timeline that is docked at the top of a window at the bottom (or vice versa), move the mouse over the four vertical dots to the left of the Timeline display arrow until a four-pointed arrow appears. Then drag the Timeline to a new location (either the top or bottom of the slide).

To display the Timeline in a new window, move the mouse over the four vertical dots to the left of the Timeline display arrow until a four-pointed arrow appears and drag the Timeline slightly to the left. Release the mouse. The Timeline should appear in a new window above the main Adobe Captivate application window.

To hide the Timeline, select Window > Timeline.

To resize the Timeline if the Timeline is docked to the main application window, drag the bar separating the Timeline from the application window. If the Timeline is not docked to the main application window, drag the lower-right corner.

To increase or decrease the zoom level, click in the Timeline ruler and spin the mouse wheel. (Alternatively, click the ruler then press Control+[ or Control+] or Control+[-.)

**Magnify the time layer**

You can adjust the zoom level of the Timeline easily. Click the ruler and then press Control+[ to decrease the zoom level, or Control+] to increase the zoom level.

**Change the order of object layers**

The Timeline shows all the objects that you have placed on the slide. The objects on a slide are displayed as stacked bars in the right pane of the Timeline. If any objects on the slide overlap other objects on the slide, it is important to set their stacking order on the Timeline to control what objects appear in front of others.

1. In an open project, double-click a slide that contains objects.
2. Move the mouse over one of the objects on the Timeline until the hand icon appears and drag the object up or down to reposition it.
3. If you have two objects that overlap on the slide, you need to select the object you want to appear in front by setting the stacking order. Changing the stacking order consists of moving objects to the back and front of the slide Stage. The key point to remember is that objects at the back of the Stage appear behind other objects. Use one of the following methods to set the stacking order:
   - In Edit view, right-click an object on the slide and select one of the object order options. If necessary, right-click other objects on the slide and adjust their order.
     - **Bring To Front** This option brings the selected object to the top. When the project plays, the object appears on top of all others.
     - **Send To Back** This option sends the selected object to the background. When the project plays, the object appears behind all others.
     - **Bring Forward** This option moves the object one layer forward.
     - **Send Backward** This option moves the object one layer back.
   - In Edit view, on the Timeline, move the mouse over an object until the hand appears and drag the object up or down to change its position in the stacking order. Moving an object higher in the stacking order moves it to the front of the Stage, while moving an object lower moves it to the back of the Stage.
Hide objects during editing
❖ In the Timeline, click the dot below the eye icon in the layer that you want to hide.

The object disappears from the slide and an X icon appears in the column. To display the object on the slide, click the X icon.

When you hide an object layer, it is hidden only on the Stage. You can still view the layer when it is previewed or published.

Timeline for slidelets
A slidelet is a slide within a slide. A slidelet has its own Timeline. All the objects in the slidelet are displayed in its Timeline. When you select a slidelet, the Timeline changes automatically to that for the slidelet. To display the Timeline for the slide containing the slidelet, click anywhere outside the slidelet. For more information on slidelets, see “Rollover slidelets” on page 79.

Lock objects
❖ In the Timeline, click the dot below the lock icon in the layer that you want to hide.

The layer and its corresponding object cannot be edited or moved until you unlock the layer. To unlock the layer, click the lock icon.

Set time for objects and slides using the Timeline
You can change the amount of time an object or slide appears in the movie using its Properties dialog box or by using the Timeline. You may find this feature useful in several situations. For example, you may want to set exact object timing when coordinating a voice-over with a highlight box; you might want the highlight box to appear only when the voice-over says, “Enter the date here.”

• Move the mouse over the left or right edge of the slide or object on the Timeline until the resize pointer appears. Click and drag the edge to the required position in the Timeline.

• To set two objects to appear at the same time, align their left and right edges. For example, you can set a highlight box to appear at the same time as an image so that the highlight box can appear over the image.

• To adjust the display time of interactive objects (such as text entry boxes, click boxes, and buttons) rest the pointer over the line between Active and Inactive in the bar until the slider handle appears. Drag the slider to adjust the display time.

You can select multiple objects and move them at the same time. Hold down the Shift key and click objects to select consecutive stacked objects in the Timeline, or to select nonconsecutive objects, hold down the Control key and click the objects to move.

You can determine whether keystrokes are played slowly or quickly in a project. If the project has many keystrokes, increasing the speed will make the pace of the project faster. However, if keystrokes are critical in the project, you may want them to play slowly so users can view them clearly. Use the Timeline to change keystroke speed. Keystrokes are contained in a Timeline object named Typing.

You determine the speed at which the mouse moves on any individual slide in a project. A high mouse speed increases the pace at which the project plays. However, if mouse movements are complicated, you may want to decrease the mouse speed so users can view all movements. Mouse movement is contained in a Timeline object named Mouse. To shorten the amount of time it takes for the mouse movement to play, move the mouse pointer over the left edge of the Mouse object until the resize pointer appears. Click and drag the edge to the left.
Preview a slide using the playhead

The playhead moves through the Timeline to indicate how the currently displayed slide appears in the project. It is a quick and efficient way to preview a single slide and check object timing. To see how the playhead functions, press F3. The red line that moves across the Timeline is the playhead. You can stop a playhead when it is playing by clicking it. To drag the playhead to a required position, move the mouse over its “head” in the area displaying the time. When the pointer appears, drag the playhead to the required position.

❖ Do one of the following:
  • “Scrub” the slide by dragging the playhead to the left or right. As you move the playhead, objects appear and fade as they will when users view the slide. Scrubbing gives you the ability to control the pace and view the slide at any speed from very slowly to very quickly.
  • With the playhead in any location on the Timeline, press the Spacebar or F3 to begin playing the slide.
  • With the playhead in any location on the Timeline, press Play in the lower-left corner of the Timeline. (To end playback, press Stop, or to wait, press Pause.)

Toolbars

Toolbars provide you an easier way of adding projects or performing a procedure. Click the various buttons on the toolbar instead of navigating the menu to perform the desired task. You can choose to display or hide toolbars according to your requirements.

The following toolbars are available in Adobe Captivate. Select Window > Toolbars, and select the corresponding option to display the toolbar for that option.

Main  Shortcuts to frequently performed actions like Save, Record, Preview, and so on.
Object  Shortcuts for adding Adobe Captivate objects.
Advanced  Shortcuts for the following:
  • Opening the skin editor
  • Setting project preferences
  • Setting audio properties for mouse-clicks
  • Setting mouse options.
Drawing  Shortcuts for creating drawing objects.
Workspace  Shortcut for displaying the menu that helps you switch between different views.
Alignment  Shortcuts for aligning the different objects on the slide. For more information, see “Align objects” on page 56.
Text Edit  Shortcuts for editing the properties of the selected text on the slide.
Labels On Toolbar  Clear this option if you are familiar with the Adobe Captivate icons on the toolbar, and do not require the labels. You can optimize the space on your toolbar using this option.

Show and hide toolbars

• In an open project, select Window > Toolbars, and select or clear the toolbar that you want to display or hide.
Move toolbars and panels to a different location

You can dock toolbars or panels into a single stack, or you can disconnect a toolbar from the stack, and have the toolbar float in its own separate window.

1 In an open project, move the mouse over the left or top edge of a toolbar or panel until a four-point arrow appears.

2 Drag the toolbar to an edge of the program window where it can dock or to the middle of the program window where it can float. (If you want, you can always drag toolbars back to their original locations.)

Panels

Adobe Captivate consists of the following types of dockable panels:

- **Library** The library panel consists of reusable objects that are organized in different folders. You can drag objects from the library panel to the slide. For more information, see “Adobe Captivate Library” on page 13.
- **Comments** The comments provided by reviewers are displayed in this panel. You can filter comments using the options in the panel. For more information, see “View or sort comments in the Adobe Captivate project” on page 198.
- **Design Template** Consists of design templates that you can apply to individual slides or to your entire project. For more information, see “Create design templates” on page 170.
- **Widget** Displays widgets available in the widget gallery that you can add to the slide. For more information, see “About widgets” on page 113.
- **Image Edit** Consists of various options to edit the selected image on the slide. The options are disabled if you have not selected the image. For more information, see “Properties of images and rollover images” on page 84.

Adobe Captivate Library

Library overview

The Adobe Captivate Library, which is available in Edit view, lists media items in a project and lets you easily view and reuse the images, backgrounds, audio, and animation in your project.

To open the library, select Window > Library.

You can also open items for editing from the Library. For example, you can right-click an image in the Library, select Edit With from the menu, and browse to your favorite image editing program. The image opens in the program, and you can edit and save the updated image in the project.

You can float the Library outside the program window or move it to a different location in the window. To do so, rest the pointer over the top-left corner of the Library pane until a four-point arrow appears; then drag the Library to an edge of the program window where it can dock or to the middle of the program window where it can float. (If you want, you can always drag the Library back.)

For each item, the Library displays the following columns: Name, Type, Size (in kilobytes), Use Count, and Date Modified. (Use Count is the number of times the item is used in the project.) Click the title of any of these columns to sort the list of items within each item category folder.

You can only see the Library location when you’re in Edit view. If you switch to a different view, you cannot see the Library. When you move back to Edit view, the Library reappears in the same location.

Updated 19 May 2009
New items appear in the Library whenever you add an item to the project. An item remains in the Library and is available for reuse even if you delete the slide in which that item was originally located.

If you use an item in one slide and then drag it from the Library to another slide, you can alter the item properties in the subsequent slide without affecting the first instance of the item.

The Library toolbar appears at the top of the main Library pane, below the Library preview pane. Use the following toolbar options to perform their corresponding actions:

**Open Library** Opens another Adobe Captivate project’s Library. This allows you to reuse any item from that project’s Library in your current project.

**Import** Imports a copy of an item from the Library of another project.

**Export** Saves a copy of an item to a location outside of the project.

**Edit** Opens an item in the editing application you previously selected for the file type. This option is not enabled until you select an editing application for the specific file type through the Edit With option in a Library item’s context menu.

**Properties** Opens the Properties dialog box for the selected item.

**Usage** Displays the list of slides on which the selected item is used.

**Update** Updates Library items that have been edited outside of the project.

**Select Unused Items** Highlights all items in the Library that are not currently used in the project.

**Delete** Deletes the selected item or items from the project.

*Note: If you do not see the Library toolbar, select Window > Library.*

**Import objects to a Library**

You can import objects from other Adobe Captivate projects or templates into the Library of your current project.

1. Select File > Import > External Library.
2. In the Open dialog box, navigate to and select the Adobe Captivate project or project template from which you want to import objects.
3. Click Open.

The objects in the project or project template are added to the Library of your current project.

**Grids**

The Snap To Grid option helps you position objects accurately on a page. A grid is a set of lines to which the objects “stick” when the Snap To Grid feature is enabled. When you bring an object close to a grid line, the object snaps to the line much in the same way as iron sticks to a magnet. For example, you can stack objects accurately one above the other using a grid.

**Work with grids**

* Select View > Show Grid. The grid is displayed as a matrix of dots on the slide.
* Select View > Snap To Grid.

Try moving the objects on the slide, and see how they snap to the grid.

Updated 19 May 2009
Change the dimensions of a grid

1. Select Edit > Preferences.
2. In the Preferences dialog box, select General Settings from the Global menu.
3. Change the value for the grid size in the Global panel. The smaller the value, the smaller is the gap between the dots in the grid.

Shortcut keys

Shortcut keys provide an easier and quicker way to navigate and use Adobe Captivate. They let you use keyboard key combinations instead of a mouse or program menu. The common shortcut keys are listed in the table.

<table>
<thead>
<tr>
<th>Shortcut key</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>F1</td>
<td>Open Adobe Captivate Help (To access dialog-box-level help, click the Help button on individual dialog boxes.)</td>
</tr>
<tr>
<td>F3</td>
<td>Test view the current slide (Edit view only)</td>
</tr>
<tr>
<td>F4</td>
<td>Preview the project</td>
</tr>
<tr>
<td>F5</td>
<td>Record audio</td>
</tr>
<tr>
<td>F6</td>
<td>Import audio</td>
</tr>
<tr>
<td>F7</td>
<td>Perform a spelling and grammar check</td>
</tr>
<tr>
<td>F8</td>
<td>Preview project from current slide</td>
</tr>
<tr>
<td>F9</td>
<td>Show the Advanced Interaction dialog box</td>
</tr>
<tr>
<td>F10</td>
<td>Preview the current slide and the following &quot;N&quot; slides</td>
</tr>
<tr>
<td>F11</td>
<td>View Adobe Captivate in full screen</td>
</tr>
<tr>
<td>F12</td>
<td>Preview the project in a web browser</td>
</tr>
<tr>
<td>Alt+Up, Down, Left, Right Arrows</td>
<td>Click the object, click a resize handle, and use these options to resize the object in the selected direction</td>
</tr>
<tr>
<td>Control+A</td>
<td>Select all</td>
</tr>
<tr>
<td>Control+B</td>
<td>Find audio in the Library</td>
</tr>
<tr>
<td>Control+C</td>
<td>Copy (slide in Storyboard view or Filmstrip, and selected object in Edit view)</td>
</tr>
<tr>
<td>Control+D</td>
<td>Duplicate (slide in Storyboard view or Filmstrip, and selected object in Edit view)</td>
</tr>
<tr>
<td>Control+E</td>
<td>Extend the length of the object display time to the end of the slide on the Timeline (Edit view only)</td>
</tr>
<tr>
<td>Control+F</td>
<td>Open the Find And Replace dialog box</td>
</tr>
<tr>
<td>Control+F</td>
<td>Find/replace a particular object in the project Library</td>
</tr>
<tr>
<td>Control+G</td>
<td>Change the slide to optimized quality</td>
</tr>
<tr>
<td>Control+H</td>
<td>Change the slide to high quality</td>
</tr>
<tr>
<td>Control+I</td>
<td>Increase the indent (selected object in Edit view)</td>
</tr>
<tr>
<td>Control+J</td>
<td>Change the slide to JPEG quality</td>
</tr>
<tr>
<td>Shortcut key</td>
<td>Action</td>
</tr>
<tr>
<td>-------------</td>
<td>--------</td>
</tr>
<tr>
<td>Control+K</td>
<td>Lock the slide</td>
</tr>
<tr>
<td>Control+L</td>
<td>Sync the selected object to the playhead</td>
</tr>
<tr>
<td>Control+M</td>
<td>Merge the selected object with the background</td>
</tr>
<tr>
<td>Control+N</td>
<td>Move to the Slide Notes pane</td>
</tr>
<tr>
<td>Control+O</td>
<td>Open the project</td>
</tr>
<tr>
<td>Control+P</td>
<td>Align the selected object with the playhead on the Timeline (Edit view only)</td>
</tr>
<tr>
<td>Control+Q</td>
<td>Insert a random question slide</td>
</tr>
<tr>
<td>Control+R</td>
<td>Print the project (through the Publish dialog box)</td>
</tr>
<tr>
<td>Control+S</td>
<td>Save</td>
</tr>
<tr>
<td>Control+T</td>
<td>Change the slide to standard quality</td>
</tr>
<tr>
<td>Control+U</td>
<td>Edit with (in project Library)</td>
</tr>
<tr>
<td>Control+V</td>
<td>Paste what is on the clipboard (for example, slide, image, object, and so on)</td>
</tr>
<tr>
<td>Control+W</td>
<td>Close the project</td>
</tr>
<tr>
<td>Control+X</td>
<td>Cut (selected object in Edit view)</td>
</tr>
<tr>
<td>Control+Y</td>
<td>Redo</td>
</tr>
<tr>
<td>Control+Z</td>
<td>Undo</td>
</tr>
<tr>
<td>Control + =</td>
<td>Zoom in</td>
</tr>
<tr>
<td>Control + -</td>
<td>Zoom out</td>
</tr>
<tr>
<td>Control + Up</td>
<td>Shift the object upward in the grid</td>
</tr>
<tr>
<td>Control+Tab</td>
<td>Shift between Storyboard, Edit, and Branching views</td>
</tr>
<tr>
<td>Control+Alt+A</td>
<td>Export PowerPoint slides as animation</td>
</tr>
<tr>
<td>Control+Alt+B</td>
<td>Show thumbnails (Edit view only)</td>
</tr>
<tr>
<td>Control+Alt+C</td>
<td>Show the Closed Captioning dialog box</td>
</tr>
<tr>
<td>Control+Alt+D</td>
<td>Update the Library</td>
</tr>
<tr>
<td>Control+Alt+E</td>
<td>Edit the slide group and edit points of polygon drawing object</td>
</tr>
<tr>
<td>Control+Alt+F</td>
<td>Find in the Library</td>
</tr>
<tr>
<td>Control+Alt+G</td>
<td>Create a slide group and autoadjust the rollover area</td>
</tr>
<tr>
<td>Control+Alt+H</td>
<td>Hide the selected object</td>
</tr>
<tr>
<td>Control+Alt+I</td>
<td>Find PowerPoint slides in the Library</td>
</tr>
<tr>
<td>Control+Alt+L</td>
<td>Show the Library (Edit view only)</td>
</tr>
<tr>
<td>Control+Alt+M</td>
<td>Show/hide the Image Edit pane</td>
</tr>
<tr>
<td>Control+Alt+N</td>
<td>Show slide notes (Edit view only)</td>
</tr>
<tr>
<td>Control+Alt+O</td>
<td>Record additional slides</td>
</tr>
<tr>
<td>Control+Alt+P</td>
<td>Remove a slide group.</td>
</tr>
</tbody>
</table>

Updated 19 May 2009
<table>
<thead>
<tr>
<th>Shortcut key</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Control+Alt+Q</td>
<td>Show the Question Pools Manager dialog box</td>
</tr>
<tr>
<td>Control+Alt+R</td>
<td>Reset to the original size</td>
</tr>
<tr>
<td>Control+Alt+S</td>
<td>Edit PowerPoint slide</td>
</tr>
<tr>
<td>Control+Alt+T</td>
<td>Show the Timeline (Edit view only)</td>
</tr>
<tr>
<td>Control+Alt+U</td>
<td>Library usage</td>
</tr>
<tr>
<td>Control+Alt+V</td>
<td>Show/hide the Design Templates panel</td>
</tr>
<tr>
<td>Control+Alt+W</td>
<td>Redraw the shape of the rollover slidelet</td>
</tr>
<tr>
<td>Control+Alt+X</td>
<td>Show/hide the SWF-Commenting pane</td>
</tr>
<tr>
<td>Control+Alt+Z</td>
<td>Show/hide the Widget panel</td>
</tr>
<tr>
<td>Shift+F8</td>
<td>Preferences dialog box</td>
</tr>
<tr>
<td>Shift+F9</td>
<td>Actions dialog box</td>
</tr>
<tr>
<td>Shift+F10</td>
<td>Table of contents</td>
</tr>
<tr>
<td>Shift+F11</td>
<td>Skin Editor dialog box</td>
</tr>
<tr>
<td>Shift+F12</td>
<td>Publish the file</td>
</tr>
<tr>
<td>Shift+Up</td>
<td>Shift the object upwards by 10 pixels</td>
</tr>
<tr>
<td>Shift+Control+A</td>
<td>Add an animation object (Edit and Storyboard views only)</td>
</tr>
<tr>
<td>Shift+Control+B</td>
<td>Add a new button (Edit and Storyboard views only)</td>
</tr>
<tr>
<td>Shift+Control+C</td>
<td>Add a new text caption (Edit and Storyboard views only)</td>
</tr>
<tr>
<td>Shift+Control+D</td>
<td>View slide properties</td>
</tr>
<tr>
<td>Shift+Control+E</td>
<td>Insert a new zoom area (Edit and Storyboard views only)</td>
</tr>
<tr>
<td>Shift+Control+F</td>
<td>Insert an FLV file (Edit and Storyboard views only)</td>
</tr>
<tr>
<td>Shift+Control+G</td>
<td>Show the Go To Slide dialog box</td>
</tr>
<tr>
<td>Shift+Control+H</td>
<td>Hide/show slide</td>
</tr>
<tr>
<td>Shift+Control+I</td>
<td>Decrease the indent (selected object in Edit view)</td>
</tr>
<tr>
<td>Shift+Control+J</td>
<td>Insert a blank slide (Edit and Storyboard views only)</td>
</tr>
<tr>
<td>Shift+Control+K</td>
<td>Add a new click box (Edit and Storyboard views only)</td>
</tr>
<tr>
<td>Shift+Control+L</td>
<td>Insert a highlight box</td>
</tr>
<tr>
<td>Shift+Control+M</td>
<td>Add a new image</td>
</tr>
<tr>
<td>Shift+Control+N</td>
<td>Add a new animation slide</td>
</tr>
<tr>
<td>Shift+Control+O</td>
<td>Add a new rollover image</td>
</tr>
<tr>
<td>Shift+Control+P</td>
<td>Import PPT</td>
</tr>
<tr>
<td>Shift+Control+Q</td>
<td>Insert a question slide</td>
</tr>
<tr>
<td>Shift+Control+R</td>
<td>Insert a rollover caption</td>
</tr>
<tr>
<td>Shift+Control+S</td>
<td>Insert an image slide</td>
</tr>
</tbody>
</table>
### Shortcut keys for recording

The following table lists the default shortcut keys used during recording. These shortcuts should be used only after you start the recording process. The same keys function differently when you are editing a project.

<table>
<thead>
<tr>
<th>Shortcut key</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>End</td>
<td>Stop recording</td>
</tr>
<tr>
<td>Pause</td>
<td>Pause or resume recording</td>
</tr>
<tr>
<td>F8</td>
<td>Resume rerecording</td>
</tr>
<tr>
<td>Print Screen</td>
<td>Capture a screenshot manually</td>
</tr>
<tr>
<td>F9</td>
<td>Start full motion recording</td>
</tr>
<tr>
<td>F10</td>
<td>Stop full motion recording</td>
</tr>
<tr>
<td>F4</td>
<td>Automatic panning</td>
</tr>
<tr>
<td>F3</td>
<td>Manual panning</td>
</tr>
<tr>
<td>F7</td>
<td>Stop panning</td>
</tr>
<tr>
<td>F11</td>
<td>Snap the recording window to the mouse</td>
</tr>
<tr>
<td>F12</td>
<td>Toggle mouse capture in full motion recording</td>
</tr>
</tbody>
</table>
Change shortcut keys for recording

1. Select Edit > Preferences.
2. In the Preferences dialog box, select Keys from the Recording menu.
3. To change keys, click once in one of the text boxes and, on the keyboard, press the key or key combination you want to use. For example, click inside the Stop Recording text box and then press Shift+Alt+4. The key combination you entered now appears in the Stop Recording text box. You can use almost any key, including the Control, Alt, Shift+Control, and Shift+Alt keys. For example, you could change the stop recording key to Alt+R.

Change shortcut key for an object

Use the Shortcut Key dialog box to select a new shortcut key combination. The dialog box appears when you click the Select Keys button available for some of the objects in their Properties dialog box. Using the check boxes, key list, and pop-up menus in this dialog box, you can set almost any key combination that is possible on a standard computer keyboard as a shortcut key. Examples include Control+Shift+K, Control+Right Arrow, or Backspace+M.

- **Allow Mouse Clicks** Select this option to allow users to click in the control.
- **Attach A Shortcut** Select this option to add a shortcut to the selected key.
- **Include Numeric Keypad (0–9) Keys** Select this option to include the numeric keypad keys as part of the shortcut key combination.
- **CTRL** Select this option to include the Control key as part of the shortcut key combination.
- **SHIFT** Select this option to include the Shift key as part of the shortcut key combination.
- **ALT** Select this option to include the Alt key as part of the shortcut key combination.
- **Key List** Select any key from the list to include as part of the shortcut key combination. Use the scroll bar on the right to view the entire list of keys.
- **Letter Or Number** Click the pop-up menu to select any letter or number as part of the shortcut key combination.

**Note:** The Control, Shift, and Alt keys map to the relevant Macintosh® keys.

- **Current Shortcut** This item lists the current shortcut key combination assigned to the task. As you make selections in the dialog box, this item automatically updates so you can view the complete combination you have created.

**Note:** If your Adobe Captivate movie will be displayed in a browser, set shortcut keys that do not conflict with common browser shortcuts. For example, F1 is frequently used as a keyboard shortcut to display Help.

Undoing and redoing actions

You can reverse the previous action by using the Undo command.

- From the Edit menu, select Undo or press Control+Z.
  
  Each click reverses one more action. Continue clicking Undo (or pressing Control+Z) to remove as many of the previous changes as necessary.
  
  When the Undo command is unavailable (dimmed), you cannot undo the previous action.
  
  Adobe Captivate tracks actions from the time you open a project until the time you close the project. Therefore, you can undo as many times as you need to, as long as the project remains open.

Updated 19 May 2009
You can reverse the action of the Undo command by using the Redo command.

- After you have used the Undo command, from the Edit menu, select Redo or press Control+Y.

## Disable confirmation messages

Confirmation messages appear when you perform important, and often permanent, actions in Adobe Captivate. The confirmation messages give you an opportunity to change your mind when deleting information or changing key attributes. If you find that certain messages are not necessary for the way you work or are slowing down your development time, you might want to disable confirmation messages for actions that you perform frequently.

1. In an open project, select Edit > Preferences.
2. In the Category panel, select General Settings from the Global menu.
3. Click Confirmation Messages in the General Settings panel.
4. In the Confirmation Messages dialog box, deselect the options for which you do not require confirmation messages.

Updated 19 May 2009
Chapter 3: Creating Projects

About Adobe Captivate projects

An Adobe Captivate project is a set of slides that are played in a desired sequence as a movie.

Start creating an Adobe Captivate project from one of the following:

**Software simulation** Record events in an application or a screen area on your computer screen using Adobe Captivate. A series of screenshots is captured and placed sequentially in separate slides. A mouse, keyboard, or system event is the usual trigger for a new slide. During recording, use the application or website you want to demonstrate as you would normally—by moving the mouse, using the keyboard, and navigating through menus.

**Project templates** When working on similar projects or modules within a larger project, you could create projects from templates. Project templates ensure consistency and improve the efficiency of people working in a collaborative setup. For more information, see “Create project templates” on page 24.

**Blank project** You can start from a blank project with the selected project dimensions. You could add Adobe Captivate objects, import Microsoft PowerPoint presentations, images, audio, video, and animations, or even record a software demonstration or simulation. For more information, see “Create a project starting with blank slides” on page 23.

**Microsoft PowerPoint Slides** You can import an entire PowerPoint presentation, or only selected slides, into an Adobe Captivate project. You can later edit the PowerPoint presentations from within Adobe Captivate. For more information, see “Microsoft PowerPoint” on page 208.

**Image slide show** Import a set of images to create an image slideshow. For more information, see “Create a project from images” on page 23.

**Mobile projects (only if Adobe eLearning Suite is installed)** Create an Adobe Captivate project for mobile devices by selecting the target mobile device in Adobe Device Central. Use the screen resolution of the device as the dimensions for your project. Use Adobe Device Central to test the project on the target device.

You can add voice-over during recording, or at the editing stage.

After you create a project, you can edit it by doing the following:

- Edit content on the slides.
- Add Adobe Captivate objects such as text captions, buttons, text entry boxes, rollover captions, rollover slidelets, highlight boxes and mouse pointers to the project.
- Add different media files, such as images, audio, video, and animations in multiple formats.
- Change the display times of slides and objects.
- Change the order of slides and objects.
- Add different kinds of slides, such as PowerPoint slides, image slides, and slides from other Adobe Captivate projects to the project.
- Add quizzes to your project by adding question slides of different types, including multiple choice, matching, fill in the blanks and image hot-spots. Randomize the questions to provide an entirely new set of questions to the learners every time they take the course.
- Add narration to the project, either by recording audio or by converting text to speech.
To get feedback on the edited file, send it out to one or more reviewers. Reviewers can comment on the SWFs while playing them in the Adobe Captivate Reviewer, an Adobe AIR application. The comments are automatically imported into the project and displayed on the timeline, and in the SWF Commenting panel.

You can make the required changes to the project and publish it in multiple formats, including SWF, PDF and AVI files. You can use the LMS settings in Adobe Captivate to publish a LMS-ready file.

You can do the following to improve efficiency when creating similar Adobe Captivate projects:

- Achieve consistency across projects using project templates.
- Ensure a consistent appearance for projects using design templates.
- Use rerecording scripts to automate the recording process for similar sequences for web applications.

You can enhance the potential of Adobe Captivate by using it with other software such as Adobe® Flash®, Microsoft® PowerPoint®, RoboScreen Capture®, and Acrobat Connect®.

See also
“Overview of project editing” on page 165
“Publishing Projects” on page 200

Create projects

Create a project by recording
You can create an Adobe Captivate project by recording events in an application or screen area on your computer. The following modes of recording are available.

**Automatic Recording** Adobe Captivate captures screenshots automatically and places them in separate slides. For more information, see “Use autorecording” on page 27.

**Full Motion Recording** Adobe Captivate records the entire set of events in real time as a video. For more information, see “Full motion recording” on page 30.

**Manual Recording** You can manually capture screenshots using this option. The chosen set of screenshots appears sequentially in separate slides after the recording is complete. For more information, see “Manual recording” on page 31.

For more information, see “Recording Projects” on page 27.

Create a project from PowerPoint presentations
You can import an entire PowerPoint presentation, or only selected slides into an Adobe Captivate project. Each PowerPoint slide is imported as a separate slide in the Adobe Captivate project. You can later edit the PowerPoint presentations from within Adobe Captivate.

See also
“Microsoft PowerPoint” on page 208
Create a project from images
Projects created from images can be viewed as a slideshow. Each image is imported into a separate slide.

1. Select File > New > Project.
3. Set the dimensions of the project.
4. Click Browse, and select the images that you want to add to your project.
5. If the Resize/Crop image dialog box appears, set the following options:

   - **Note:** You see the Crop/Resize dialog box only when an image exceeds the height or width limits of the project. If you are inserting more than one slide, only those images that exceed the dimension limits are displayed in the dialog box.

   - **Fit To Stage** Resizes the image to fit the dimensions of the slide.

   - **Crop** Displays a bounding box with dimensions corresponding to that of the project. Resize the handles of the box to select the area that you want displayed on the slide. If you selected Constrain Proportions, Adobe Captivate maintains the height-to-width ratio of the bounding box.

   - **Zoom** You can zoom in and zoom out of the image by moving the slider. Alternatively, you can choose from a list of standard zoom sizes from the menu.

   - **Constrain Proportions** Maintains the height-to-width ratio of the bounding box used to crop the image. This option is enabled only when you choose to crop the image. When you disable this option, resize the bounding box, and enable the option again; the new dimensions are used thereafter to calculate the ratio.

See also
"Images and rollover images" on page 84

Create a project starting with blank slides
You can start with a blank project, and then import slides or images from PowerPoint presentations, images, or other Adobe Captivate projects. You can also add a software demonstration, or interactive simulation by recording additional slides.

1. Select File > New > Project.
2. In the New Project dialog box, select Blank Project.
3. Set the dimensions of the project.
4. Click OK.

Create template-based projects
Adobe Captivate templates allow you to improve consistency across similar projects or modules of a project and reduce the effort required to create new projects.

Create a storyboard and workflow
No matter what project you want to create, it is helpful to do some planning before you start taking screenshots. Consider first what you want the user to do, learn, or achieve as a result of viewing your project. Defining this goal allows you to create a comprehensive plan for success. Once you have defined the action you want the audience to take, you can create the “core” of the project.
Every movie tells a story. A storyboard is a written version of that story either in the form of text or graphics. It tells you whether you have a clear understanding of what you are about to present to your audience. You can use the 5W, 1H rule adopted in journalism to get your story straight—who, what, when, where, why, and how.

You can create a workflow readily when you have a storyboard in place. A workflow is the flow of information in a project that follows the rules you create for it. For example, you can have a nonlinear presentation in which you can move back and forth between slides, skip slides, or set rules for slide sequence. Defining the workflow in advance helps you complete your project earlier, with minimal changes during the editing cycle.

If your project includes a great deal of text (captions), a script is the best place to begin. Scripts use text-based pages. They are like pages in a book: logical, sequential, and containing as much detail as you care to provide.

Create project templates

When you want to create similar projects or similar modules in a project, use project templates to ensure consistency and save time. Project templates are especially useful when multiple authors are working on different project modules or on similar projects.

You can apply design templates to project templates to ensure a uniform appearance for your projects.

Project templates help achieve the following:

- Consistency across Adobe Captivate projects.
- Reduced development time for multiple projects due to reuse of design.
- Reuse of project preferences across multiple projects.

In a collaborative environment where the designers work separately from the people creating the content, designers use templates to ensure consistency across projects. Content developers do not have to worry about the workflow of the project, the various standards involved, or the creation of the layout. All they have to do is follow the instructions in the template and provide the required content in the relevant placeholders.

Creating a repository of templates requires a disciplined effort involving all stakeholders. However, the effort pays for itself over time in terms of reduced development time for projects.

An Adobe Captivate project template consists of the following:

- Slides with placeholders for various Adobe Captivate objects
- Placeholders for the following:
  - Recording slides
  - Question slides.

When you create a project using a template, the placeholders in the template are marked with a placeholder icon. The icon disappears when you insert an object into a placeholder.

Note: The placeholder objects are not visible when you preview or publish a project created with a project template.

In addition to placeholders, you can add all Adobe Captivate objects and supported media to templates. The template serves as guidance only. Users can change the objects and placeholders without any restriction when creating a project from the template.

To make a project template more effective, add slide notes providing information or instructions. Include information on the recommended types and properties of objects, media, or slides that users are to insert in the placeholders.

Note: You can apply a design template to a project template. The properties defined for objects in the design template are applied to the respective objects constructed from the placeholder.

1 Select File > New > Project.
2 Select Project Template in the Create tab.

3 Specify the dimensions of the project template, and click OK.

4 To insert placeholders for various objects in the slides, select Insert > Placeholder, and choose the placeholder that you want to insert. You can also insert placeholders for recording and quiz slides using this menu.

   Object and media placeholders define the size and position of the object/media that can be inserted. The user can alter these parameters when creating a project based on the template.

5 Specify the properties for the various placeholder objects that you have inserted.

6 In addition to placeholders, you can also do the following:
   • Set the properties for the slide, such as background, navigation, and audio.
   • Use drawing tools to color and demarcate different sections of the slide.
   • Set preferences for that template using the Preferences dialog box. The preferences are automatically applied when you use the project template to create a project.

7 Insert other Adobe Captivate objects, and supported media types.

   Best practice is to add all objects or media that don’t change from project to project (for example, a logo) as actual objects. Use placeholders for objects or media that are specific to the project.

8 Save the file with a.cptl extension.

**Create projects from project templates**

1 Select File > New > Project.

2 Select From Template in the Create tab.

3 Click Browse, and navigate to the template file.

4 Double-click the placeholder and do the following:
   • For placeholder objects, use the respective dialog box to add objects to the placeholder. The placeholder is converted to a concrete object.
   • For recording slide placeholders, double-click the placeholder slide to start recording.
   • For question slide placeholders, double-click the placeholder slide to insert a question slide.

**See also**

“Create design templates” on page 170

**Add custom project size to the Select Size list**

You can add your custom project size to the list of options available in the Select Size menu.

1 Select File > New > Project.

2 In the New Project dialog box, select Project Template.

3 In the Select Size menu, select Customize. The Custom Project Sizes dialog box appears.

4 Click Add.

5 In Description, enter a description for the size. For example, you could enter, “Size for Adobe Projects.”

6 Set the custom width and height of the project.
Enable backup file creation

Adobe Captivate creates a backup file for your project when you save it. When you re-save the project, the changes are saved to the backup file too. The backup file is saved with a .bak extension.

If your project file gets corrupt, use the backup file to recover your project. Rename the backup file using a .cp extension, and open it. Changes that you made after the last save, however, are not reflected in the backup file.

The provision to create a backup file is enabled by default in the Preferences dialog box. You can choose to disable the option if it interferes with the speed of saving the project.

Note: The size of the backup file might be larger than that of your main project.

1. Select Edit > Preferences.

2. In the Preferences dialog box, select General Settings from the Global menu.

3. Select Generate Project Backup.
Chapter 4: Recording Projects

Automatic recording

Use autorecording
When you record using automatic recording, Adobe Captivate captures screenshots automatically and places them on separate slides. Mouse, keyboard, or system events are the common triggers for capturing screenshots. Automatic recording is the most commonly used recording method in Adobe Captivate.

1 Select File > New > Project.
2 In the Record tab, set the recording area according to your preferences. For more information, see “Set recording area” on page 32.
3 Click OK after you have completed recording your preferences.
4 When the recording window appears, click anywhere on the margins of the recording window to set its position.
5 Select Automatic Recording Mode.
6 Select one or more recording modes in which you want to record the project.
7 Optionally, do the following:
   • Select a panning mode if you want the recording window to follow your movements across the screen. For more information, see “Panning” on page 33.
   • If you are adding commentary during recording, select the type of audio input.
   • To change the default settings that Adobe Captivate uses when recording, click Settings. For more information on customizing recording preferences, see “Set recording preferences” on page 32.
   • Click Advanced when you want to do one of the following:
     • Generate text captions in languages other than English.
     • Capture the actions performed as a rerecording script.
     • Run the project using a previously recorded script. When you choose this option, the project gets created using the actions defined in the script without your intervention.
     For more information on rerecording scripts, see “Automate the recording process” on page 36.
8 Click the Record In Selected Mode button. Alternatively, press Alt+R.
Adobe Captivate starts recording events on your screen.
9 Press End when you have completed the procedure. The Save Project Files dialog box appears.

Note: Alternatively, click the task icon or the system tray icon to stop recording.

a In the Project Name field, enter a name for the project.
b In the Project Location field, specify a location for your saved project.
c Enter a name in the following fields to save the project in the corresponding mode:
   • Demo Project Name
   • Assessment Project Name
• Training Project Name
• Custom Project Name

Note: The fields are enabled depending on the modes that you selected before recording the project (Step 6).

d In the Project To Open field, select the project that you want to open for editing.
e Enter a name for the rerecording script. This option is enabled if you select the rerecording option before recording the project (step 7).

Autorecording modes
When autorecording projects, you can record a procedure in one or more of the following modes in a single recording:

• Demonstration mode
• Training simulation mode
• Assessment simulation mode
• Custom mode

Depending on the mode, one or more of the following objects are added automatically during the recording. You can change recording preferences for the various modes. The descriptions for the various modes assume that you have not changed the default recording preferences.

Text Captions  Text captions are used to point out certain areas on a slide, explain concepts, or provide users with additional information. Text captions can be created automatically or manually. If you are autorecording a project, you can have Adobe Captivate automatically create text captions. Text captions are generated for the various mouse and keyboard events.

The text captions use the labels in the application to describe a step. For example, if the user clicks File in the menu bar, a text caption with the text, "Select the File menu" is created automatically. You can later edit the captions to your requirements. When the user views the movie, the actions performed during recording are displayed along with the captions.

Text Entry Boxes  Text entry boxes are Adobe Captivate objects that require user input. During recording in some of the modes, text entry boxes with default hint, success, or failure captions are added to the slides. You can later edit the text in these captions.

Click Boxes  A click box is an object in Adobe Captivate that designates an area around the place where the mouse was clicked during recording. Click boxes help users try out an application or website using the movie. After viewers click a click box, you can have the project perform different actions. For example, the project resumes playing, opens a new project, or opens a specific website.

Highlight boxes  Highlight boxes are transparent, colored rectangles that can be placed over areas on a slide to draw attention to the area. You can edit the formatting, color, transparency, and size of all highlight boxes. If you automatically record a project or slides, Adobe Captivate creates a highlight box for the area on which a mouse or keyboard event occurs. If you have an existing project, you can also add highlight boxes manually.

See also
“Text captions” on page 62
“Highlight boxes” on page 74
“Click boxes” on page 98
“Text entry boxes” on page 101

Updated 19 May 2009
Demonstration mode
Use the demonstration mode when you want to demonstrate a procedure or feature. The movie produced in this mode however, does not provide any scope for user interaction. The user can only passively view actions that were performed when the project was recorded.

When recording a movie in the demonstration mode, Adobe Captivate does the following:

- Adds text captions using the labels of the controls in the application. For example, if the user clicks File in the menu bar, a text caption with the text, “Select the File menu” is created automatically.
- Adds highlight boxes to highlight those areas where the mouse is clicked.
- Adds text that is typed manually during the recording.

Training Mode
Use the training mode when you want the user to try the procedure during the movie. The movie moves to the next slide only after the user has performed the previous action correctly.

When recording slides in training mode, Adobe Captivate does the following:

- Adds click boxes at places where the user must click the mouse.
- Adds text entry boxes for user input. The success, failure, and hint captions are added to each text entry box.

Assessment mode
Use the assessment mode when you want to test how well the user has understood a procedure. You can set a score for every correct click. You can also set the number of times the user can attempt a procedure. When the user fails to click the right option in the number of attempts provided, the movie moves to the next step. The user does not get any score for the failed attempt.

When recording slides in assessment mode, Adobe Captivate does the following:

- Adds click boxes at places where the user must click the mouse.
- Adds text entry boxes for user input. The success and failure captions are added to each text entry box.

Custom mode
Use the custom mode when working on a project where you need a mix of features available in the other modes. This mode allows you to achieve the highest level of customization in Adobe Captivate. Using the custom mode, you can create a project that is part demo, part training, and also provide for assessment. None of the Adobe Captivate objects are added by default during recording in the Custom mode.

For example, let us consider a movie meant for training the user on editing a file. In the first few slides for simpler tasks like opening the application and opening the file, you can retain the slides created in the demo mode. Most users wouldn’t appreciate being guided through the simpler tasks. When you move to the slides describing the procedure for editing, you can add the various objects with which the user can interact. Finally, you can provide for assessment slides at the end of the project.

See also
“Set recording preferences” on page 32
Multimode recording
When you record an Adobe Captivate project, you can choose to record in more than one mode. Multimode recording helps you save time when working on projects that require outputs in more than one autorecording mode.

Full motion recording
During full motion recording (FMR), the entire set of events is captured in real time as a video. Use FMR for movies that demonstrate complex procedures, like drawing or reshaping an object. FMR movies are also useful when demonstrating visual cues, such as the change in the shape of the pointer when it moves over certain objects. A handy cam icon is displayed on slides generated using FMR.

In the automatic recording mode, actions like drag-and-drop and mouse movements are automatically captured in the FMR mode. You can change this setting using the Preferences dialog box.

When the FMR mode is disabled during autorecording, you can selectively capture FMR slides by pressing F9 to shift to FMR mode. To end FMR mode, press F10. The full motion recorded movie is placed into one slide of a project and plays like a “mini movie” within the larger project.

You know that full motion recording has begun by looking at the Adobe Captivate icon in the system tray (lower-right corner of your computer screen). When you are recording normally, the icon appears as a regular icon. When full motion recording automatically begins, the icon flashes.

Note: FMR files increase the size of the project.

1. Select File > New > Project.
2. In the Record tab, set the recording area according to your preferences. For more information, see “Set recording area” on page 32.
3. Click OK after you have completed recording your preferences.
4. When the recording window appears, click anywhere on the margins of the recording window to set its position.
5. Select Full Motion Recording Mode.
6. Optionally do the following:
   • Select a panning mode if you want the recording window to follow your movements across the screen. For more information, see “Panning” on page 33.
   • If you are adding commentary during recording, select the type of audio input.
   • To change the default settings that Adobe Captivate uses when recording, click Settings. For more information on customizing recording preferences, see “Set recording preferences” on page 32.
7. Click the Record In Selected Mode button. Alternatively, press Alt+R.
8. Press End when you have completed the procedure.

Note: Alternatively, click the task icon or the system tray icon to stop recording.
Manual recording

You can construct a project by manually taking screenshots during recording. Use manual recording when you want to pick and choose a few screenshots during the recording process. The procedure can get tedious for complicated procedures involving many steps.

1. Select File > New > Project.
2. In the Record tab, set the recording area according to your preferences. For more information, see “Set recording area” on page 32.
3. Click OK after you have completed recording your preferences.
4. When the recording window appears, click anywhere on the margins of the recording window to set its position.
5. Select Manual Recording Mode.
6. Optionally do the following:
   - Select a panning mode if you want the recording window to follow your movements across the screen. For more information, see “Panning” on page 33.
   - If you are adding commentary during recording, select the type of audio input.
   - To change the default settings that Adobe Captivate uses when recording, click Settings. For more information on customizing recording preferences, see “Set recording preferences” on page 32.
7. Click the Record In Selected Mode button. Alternatively, press Alt+R.
8. Press Print Screen every time you want to take a screenshot during the procedure.
9. Press End when you have completed the procedure.

   Note: Alternatively, click the task icon or the system tray icon to stop recording.

See also

“Set recording area” on page 32

“Set recording preferences” on page 32

“Recording in sync” on page 128

Hide recording icons and info in the recording window

Press Alt+H if you want to hide the icons and other info that is displayed in the recording window. Press Alt+H again to make them visible.

Record additional slides

You can record new slides and insert them into an existing project.

You can add new slides to the end of the project, or click a slide in the list, and start recording. The new slides generated after recording are inserted after the selected slide.

1. In the project in which you want to record and insert new slides, select File > New > Additional Slides.
2 Select the slide after which to add the new slides. Click OK.
3 Set the recording options, and start recording.
4 Press End when you have completed recording.

   Note: You can position the capture area anywhere on your screen. You cannot, however, resize the capture area because it is set to the same size as the project to which you are adding the slides.

The newly recorded slides are inserted into your project at the specified location.

You can also add slides by importing them from other Adobe Captivate projects or PowerPoint presentations.

Pause while recording projects

You can pause while recording an Adobe Captivate project. Any action performed after a project is paused is not recorded.

1 Open Adobe Captivate and begin recording a new project or slide.
2 When you want to pause recording, press the Pause/Break key on the keyboard. When you want to restart recording, press Pause/Break again.

   Note: You can change the keys that you want to use for pausing or resuming projects in the Preferences dialog box.

Set recording preferences

Adobe Captivate uses a default set of preferences for panning and other settings when recording or creating projects. You can customize these preferences using the various options available in the Preferences dialog box.

Set recording area

A rectangular area with red borders called the recording window indicates the recording area. You can record a project by performing actions on any area of your computer screen. The capture modes help you set the capture area on your screen for recording.

When the size of the recording area is lesser than the size of the screen you are recording, use panning. In the panning mode, the recording window can be made to move according to the movement of the mouse. This way, you can capture actions across your computer screen within the limited confines of the recording window.

When you choose Custom Size, resizing the recording window changes the project dimensions. In the other options Available under Application, resizing the application automatically resizes the recording window.

The recording window cannot be resized when you choose the Full Screen option.

1 Select File > New > Project.
2 Set the options in the Record tab according to your preferences.

   Application Select this option if you want to specify the application which you want to record as part of your project. In the Select Application menu, select the application or website on your computer that you want to record.

   • Custom Size Select this option if you want to customize the dimensions of the recorded project. You can choose from a list of standard sizes, or define a custom size. The selected application is automatically resized to fit inside
the boundaries of the recording area. Best practice is to have a clear idea of the dimensions of the project before you start recording it.

- **Application Window** Select this option if you want to record the entire application window. The dimensions of the application are not altered. The recording rectangle is resized to fit the application.

- **Application Region** Select this option if you want to record defined areas in an application. For example, if you are recording a window that has three frames, the recording window snaps to individual frames when the mouse moves over them. The dimensions of the application are not altered. The recording rectangle is resized to fit the defined area in the application.

**Screen Area** Select this option when you want to capture all events that occur within an area on the screen.

- **Custom Size** Select this option if you want to record your project using a specified dimension. You can choose from a list of standard sizes, or create your own custom size window.

- **Full Screen** Select this option if you want to set the size of the recording window to the size of your computer monitor. The entire computer screen is treated as the recording window. If you work on dual monitors, you can choose the monitor that you want to use for recording. Recording in this mode can potentially produce very large projects and output file sizes due to the large screen resolution on monitors.

*Note: You can also resize the project during recording using the recording handles of the recording window.*

**See also**

“Use autorecording” on page 27

“Full motion recording” on page 30

“Manual recording” on page 31

**Panning**

Use panning when you want the recording window to follow the movement of your mouse pointer across the screen. It is like capturing a moving object by changing the angle of the recording device. Panning helps you capture events across a large screen even when the recording window is smaller than the size of the screen.

The following panning options are available in Adobe Captivate:

- **Automatic Panning** The recording window automatically moves along with the pointer whenever you move the mouse during recording.

- **Manual Panning** You must manually move the recording window to the area where the next event takes place. In all other respects, it is like the automatic panning option.

**See also**

“Use autorecording” on page 27

“Full motion recording” on page 30

“Manual recording” on page 31

**Set global recording preferences**

Select Edit > Preferences. In the Preferences dialog box, select Settings from the Recording menu.
### Set Full Motion Recording preferences

Adobe Captivate automatically captures some actions in the FMR mode during autorecording. You can choose to disable this feature in the Preferences dialog box. You can also set options to optimize the size of the FMR SWF file and set the color mode for the SWF file.

Select Edit > Preferences. In the Preferences dialog box, select Full Motion Recording from the Recording menu.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show mouse</td>
<td>Displays mouse movements when the FMR movie is run.</td>
</tr>
<tr>
<td>Disable hardware acceleration</td>
<td>Use this option when recording videos from media players like Windows Media Player®, RealPlayer®, or QuickTime®. Otherwise, a blank screen is recorded. Turning hardware acceleration off results in better FMR quality. If you select this option, your computer screen briefly flickers when you begin and end full motion recording. The screen flicker does not harm your computer and does not appear in the final project.</td>
</tr>
</tbody>
</table>
Change keyboard shortcuts for recording

You can choose your own keyboard shortcuts for actions that are involved when recording a project using the Preferences dialog box. For example, the End key is used to stop recording a project in Adobe Captivate. You can change that by entering a different key in the dialog box.

1. Select Edit > Preferences.
2. In the Preferences dialog box, select Keys from the Recording menu.
3. Click inside the field that you want to change.
4. Type the keyboard shortcut.

Set Preferences for the different modes

Some of the options for recording modes are disabled in Adobe Captivate. The reason for disabling the options is based on the logic for recording in that mode. However, you can still enable some of the options if you have a special requirement.

For example, one wouldn’t usually add text captions in an assessment movie. So, the options for text captions are not enabled in Adobe Captivate. You can enable them in the Preferences dialog box if you have a special requirement.

1. Select Edit > Preferences.
2. In the Preferences dialog box, select Mode(s) from the Recording menu.
3. In the Mode menu, select the recording mode you want to customize.

## Option Description

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Working folder</td>
<td>Location of the generated FMR SWF file on your computer.</td>
</tr>
<tr>
<td>Video color mode</td>
<td>Select this option to set your video color to 16 bit or 32 bit. Selecting 16 bit results in a smaller file size, but also a smaller range of colors. Selecting 32 bit creates a larger file with a wider range of colors. The video color of most computers is set to 32 bit.</td>
</tr>
</tbody>
</table>
| FMR mode                    | Depending on your requirements for the quality and size of the final FMR file, use the slider to choose the corresponding option.  
                              |   • Video. The highest-quality FMR files are produced in the Video option. The resulting SWF file is considerably larger than files produced with the other options.  
                              |   • Application And Low SWF Size. More splitting of SWF files occurs, and the frame rate is reduced during capture. The resulting SWF file is smaller than files produced with the Video option.  
                              |   • Safe. If you are not sure about which option to use, choose Safe. Adobe Captivate automatically calculates the available system resources and captures the movie at an optimum setting. |
| Add text captions           | Automatically creates captions based on user and system actions performed during autorecording. The text captions use the labels in the application to describe a step. For example, if the user clicks File in the menu bar, a text caption with the text, “Select the File menu” is created automatically. |
| Convert tool tips to rollover captions | Automatically converts any tool tips on the screens you are capturing to rollover captions. Tool tips are small floating text windows that appear when the mouse hovers over buttons. This option is not selected by default for any of the recording modes. |
| Show mouse location and movement | Displays mouse movements during autorecording. |
Change recording defaults for text captions and highlight boxes
Adobe Captivate uses a default set of styles when inserting text captions and highlight boxes during recording. You can change these default settings using the Preferences dialog box.

Select Edit > Preferences. In the Preferences dialog box, select Defaults from the Recording menu. Change the styles for the various text captions, and highlight boxes using this panel.

See also
“Text captions” on page 62
“Highlight boxes” on page 74

Automate the recording process
You can automate recording for procedures with similar steps using rerecording scripts. When you run a rerecording script, the actions recorded in the file are performed in the order mentioned in the script without your intervention. To use rerecording scripts, select the option to generate rerecording information when you record a new Adobe Captivate project. A rerecording script is created as an XML file with the cprr extension.

Note: Rerecording scripts are only supported in Internet Explorer 6. If you are using a later version, downgrade to Internet Explorer 6 before recording any browser-based actions.

Rerecording scripts are especially useful when localizing a project in several languages. When you run the script by selecting a language for the autogenerated text captions, a project with the text captions in the selected language is created. You can then save the project in the relevant language directories.

Editing rerecording scripts
You can edit a rerecording script file by doing the following:

- Debug rerecording errors by inserting <BREAK> and </BREAK> and <SKIP> and </SKIP> tags. When you insert BREAK tags you can switch between manual and automatic rerecording. Use the SKIP tags to skip lines in the script.
- Change editable content or translate localizable terminology by editing terms defined within <trans-unit> tags.
When you insert the `<BREAK>` and `</BREAK>` tags in the script file, the rerecording script skips all operations between these tags. However, Adobe Captivate records all manual operations that you perform in the running client while the script waits. Press a predefined key to switch back to the automatic rerecording mode. When you insert the `<SKIP>` and `</SKIP>` tags, the script automatically skips the operations between these tags and continues rerecording.

During rerecording, Adobe Captivate enforces breakpoints after waiting for a predefined duration and then displays a message with the following information:

**Reason for the break** The message can include any of the following reasons for breaking:

- The layout of the recorded page is different from the layout of the page that you are rerecording.
- The order of the elements in the recorded page is different from the order in the page that you are rerecording.
- The wait time for opening a new window has been exceeded.
- The wait time for opening a dialog box has been exceeded.
- The wait time for downloading a document or web page from the Internet has been exceeded.

**Script index** Adobe Captivate assigns an automatically generated number for every action and includes it in the message.

**Corrective actions to choose to perform** You can choose to perform one of the following corrective actions:

- **Retry Current Action** Click this button if a new window or dialog box failed to open or if a web page failed to download. This button is disabled when the error pertains to a page mismatch.

- **Continue From Next Element** Click this button if the window or dialog box opened or if the web page downloaded after the message appeared. This button is disabled when the error pertains to a page mismatch.

- **Switch To Manual Mode** If a manual action is required to open the window or download or refresh the web page, click Switch To Manual Mode. Ensure that the new window is open, or that the web page is downloaded, and then press the predefined key. The automatic rerecording continues, starting with the next action in the rerecording script.

**Create projects from rerecording scripts**

When recording a project in the autorecording mode, click Advanced, and do one of the following:

- To run a previously recorded script, click Browse, and open the script. Select a language for the text in the autogenerated text captions. Adobe Captivate automatically records a project using the sequence of actions defined in the script, and the text captions in the selected language.

- To create a rerecording script, select Re-recording Information, and choose a language for recording the script. When you save the project after recording, choose the option to save the rerecording script. The script is saved along with the project at the same location.

**Recording tips**

The following tips and tricks can help you create Adobe Captivate projects quickly and easily, while also giving you professional, high-quality results:

**Use automatic recording as far as possible** Even for projects that need a few manually generated screenshots, consider automatic recording. Set the autorecord option, but press Print Screen whenever you want to take an extra screenshot. This method is effective if you are recording a website that contains many pop-ups, frames, and special effects. Adobe
Captivate plays a camera shutter sound each time a screenshot is automatically captured. To generate a screenshot at a place where you do not hear the sound, press Print Screen to manually take a screenshot.

For example, if you are recording Microsoft Internet Explorer, there can be dynamic HTML or Flash menus that appear only when the mouse rolls over them. Adobe Captivate does not automatically capture the change that occurs on mouse rollover. Press Print Screen to manually capture the change.

**Go slowly when recording, particularly when recording websites in Internet Explorer** Perform actions more slowly than you would normally during recording. It is especially important to go slowly when capturing actions on a website in Internet Explorer. If you are manually recording, ensure that each web page is loaded before capturing a screenshot.

**Wait for the camera shutter sound** During autorecording, wait for the shutter sound before performing another action.

If you are manually recording, Adobe Captivate captures screenshots each time you press a designated key or key combination. The default capture key is the Print Screen key. Each time you want to capture a screenshot, press the Print Screen key; you’ll hear the camera shutter sound.
Chapter 5: Slides

Adobe Captivate projects are composed of slides that are played in succession as a movie. A slide is the smallest unit of a project.

Much of the work you do in Adobe Captivate is done at the slide level. In fact, after you have set your preferences and completed your recording, you will probably work nearly exclusively at the slide level until you are ready to preview and publish your project.

Adobe Captivate has different types of slides. You can include some or all of the following slide types in a single project:

- Blank slides are useful when you want to create a slide from scratch.
- Image slides contain an image in JPG, JPEG, GIF, PNG, BMP, ICO, EMF, or WMF format inserted as a background. You can create an entire project from image slides and use it as an album.
- Question slides contain quizzing functionality.
- PowerPoint slides are slides imported from a PowerPoint presentation.
- Animation slides contain an animation in SWF, GIF, or AVI format.

Slide properties

You can set the properties for a slide using its Properties dialog box. Double-click the slide to display its Properties dialog box.

Slide tab

Label  The name of the slide. The slide label appears under the slide in the Filmstrip and in Storyboard view. It is a good practice to name slides. When multiple users are working on the same project, naming slides helps to identify them easily.

Display Time  The duration for which the slide plays. The maximum value is 1 hour (3600 seconds).

Transition  Specifies the transition effect for the slide. You can choose from the many options available in Adobe Captivate. Adding transition effects breaks the monotony of slide transition.

Quality  Specifies the quality level for the slide. Use the pop-up menu to select one of four quality options: Low (8-bit), Optimized, JPEG, and High Quality.

Note: Selecting the Optimized, JPEG, or High Quality format may increase the file size and the time needed to download your project. You should only use a format other than Low (8-bit) when appropriate.

Color  Specifies the color of the slide. Select Project to have the color of the slide match the project background color. Select Custom and click the color box to set virtually any color.

Hide Slide  Select this option to retain the slide in the project but hide it from view when the project is played.

Lock Slide  Select this option to lock ("freeze") all of the objects on the slide so they cannot be deleted or changed. (Locking objects does not lock the slide, so even if you lock objects, the slide can still be edited, moved, deleted, and so on.)

Change Background Image  Select this option to change the background image on the slide by selecting an image from the project’s Library.
Navigation  You can define the navigation options every time the user views a slide or moves away from the slide. The On Slide Enter menu displays the actions that you can set for the slide when it is displayed. The On Slide Exit menu displays actions that you can set when the user exits the slide. The following list describes actions available in both the menus:

Note: The options Go To Previous Slide, Go To Next Slide, Go To Last Visited Slide, and Jump To Slide are available only in the On Slide Exit menu.

- **Continue** The movie moves to the next defined action.
- **Open URL Or File** A web browser opens with the specified web page if the user has Internet connectivity. Alternatively, you could open a specified file for the user.
- **Open Other Project** Opens the specified Adobe Captivate project.
- **Send E-mail To** A draft of the default e-mail editor opens with the e-mail address specified in the To field.
- **Execute JavaScript** Adobe Captivate runs the specified JavaScript.
- **Execute Advanced Actions** Adobe Captivate runs the script written using the application.
- **Show** When the user performs the required action, the specified hidden object is made visible
- **Hide** When the user performs the required action, the specified object is hidden from the user.
- **Enable** When the user performs the required action, it activates another object in the project. This option is available only for interactive objects.
- **Disable** When the user performs the required action, it disables another object in the project. This option is available only for interactive objects.
- **Assign** When the user performs the required action, the value of the specified variable is set inside the text caption.
- **Increment** When the user performs the required action, the value of the specified variable is incremented accordingly.
- **Decrement** When the user performs the required action, the value of the specified variable is decremented accordingly.
- **Multiple Actions** When the user performs the required action, multiple actions are performed in the order specified by the user.
- **Go To Previous Slide** The movie moves to the previous slide.
- **Go To Next Slide** The movie moves to the next slide.
- **Go To Last Visited Slide** The movie moves to the previously viewed slide.
- **Jump To Slide** The movie moves to the specified slide.
- **No Action** Nothing happens when the user exits the slide.

Notes  Click to display the Slide Notes dialog box, which lets you write information about the slide. Slide notes are not seen by users who are viewing your project, but are an organizational tool for Adobe Captivate authors. The notes can be seen in two places: in the Record Audio dialog box and in the handouts that you publish.

Accessibility  Click to open the Slide Accessibility dialog box, which lets you add or type in text that can be read to users with disabilities who use screen readers. You can choose to enable accessibility for text entered on slides, slide notes, and closed captioned text. Note that the corresponding buttons are enabled only when such text exists in your project. For more information, see “Add accessibility text to slides” on page 190.

Apply To All  Applies the settings specified in the Settings menu to all slides.
**Settings**  Click this button to select how to apply property changes in the project. To apply all your changes, select Apply Only Changed Properties. To apply all the slide settings, select Apply All Properties. You can apply the slide settings to all slides, the current slide only, or to slides of the same type.

*Note: If you change the settings in this dialog box, they become the default settings, and any new slides you create use the new settings.*

**Audio tab**

Use this tab to add audio to a slide or edit audio that is already associated with a slide.

- **Record New Audio**  Opens the Record Audio dialog box. Recording audio requires some basic equipment.
- **Stop Audio**  Stops playing the audio file.
- **Play Audio**  Plays the audio file.
- **Import**  Import an audio file from your computer or network.
- **Library**  Opens the Audio Library, which lists all audio files that are already part of the currently open Adobe Captivate project.
- **Edit**  Opens the Edit Audio dialog box. This dialog box lets you edit the audio file in a variety of ways, such as inserting silent periods and adjusting the volume.
- **Closed Captioning**  Click to open the Closed Captioning dialog box, where you can enter captions for slide audio files for hearing-impaired users. The text is displayed along with the audio when the slide is played. This option is only available for slide audio, and is not available for other types of audio files.
- **Delete**  Removes the audio file associated with the slide.
- **Fade In [#] Seconds**  Specifies the time for audio to fade in to full volume.
- **Fade Out [#] Seconds**  Specifies the time for audio to fade out to silence.
- **Settings**  Opens the Audio Settings dialog box where you can define audio settings such as input source, quality level, and calibration.
- **Loop Audio**  Plays the audio file continuously till the slide exits.
- **Stop Background Audio**  Stops playing any background audio associated with the slide.
- **Apply To All**  Applies the settings specified in the Settings menu to all slides in the project.

*Note: If you change the settings in this dialog box, they become the default settings, and any new slides you create use the new settings.*

**Add slides**

Adobe Captivate offers a wide variety of options for adding slides to a project, including recording, importing, and copying. You can add different types of slides such as blank, image, quiz, or animation.
Record additional slides for a project
There may be cases in which you record an Adobe Captivate project and begin working at the slide level, only to realize that you need to record a few more slides. In this case, you probably don’t want to rerecord the entire project but just a few actions. Adobe Captivate allows you to do this by recording new slides and inserting the slides in an existing project.

1. In an open project in which you want to record and insert new slides, select File > New > Additional Slides.
2. Specify the location for the new slides.
   - Select Record Slides At The End Of This Project to add new slides to the end of the project.
   - Click a slide in the list after which you want to insert the recorded slides, and select Record Slides And Insert After The Slide Selected Below.
3. Select the application that you want to record from the Select Application menu. Ensure that you have opened the application on your computer before you try to record it.
4. Select Snap To Window if you want the Recording window to snap to the borders of the application.
5. When you finish, click OK. The Recording window appears.
6. Select a recording mode, and click Record.
   - Note: You can position the capture area anywhere on your screen. You cannot, however, resize the capture area because it is set to the same size as the project to which you are adding the slides.
7. When you are finished recording, press End (or another key combination you have designated) on the keyboard to stop recording.

The newly recorded slides are inserted into your project in the specified location.

Import slides
Adobe Captivate allows you to import slides from one Adobe Captivate project into another. This can save you valuable development time.

1. In an open project to which you want to add existing slides, select File > Import > Slides/Objects.
2. Select the project that contains the slides to import and click Open.
3. Use the following options according to your requirement:
   - Select All: Use the options in this menu to select all slides or all objects in the project.
     - When you want to import most of the slides in the project, use this option to select all slides. Click the slides that you do not want to import one by one, and select Do Not Import from the Import menu.
   - Clear All: Use the options in this menu to clear any previous selections you made of the slides or objects.
     - When you want to import a few slides in the project, use this option to clear all slides. Click the slides that you want to import one by one, and select Slide Only, or Slide And Objects from their Import menu.
   - Import: Use the options in the menu to import the slide, its objects, or both the slide and its objects.
   - Place Objects On: This option is available only if you have chosen the Objects Only option in the Import menu. Select the slide in your project into which you want to place the imported objects.

Copy slides
You can copy and paste slides in Storyboard view or Edit view (with the thumbnails enabled in the Filmstrip.)

Updated 19 May 2009
You can select multiple slides by pressing Shift or Control on the keyboard while clicking the desired slides. To select all slides, press Control+A or select Edit > Select All Slides.

1. In an open project, right-click the slide to copy.
2. Select Copy Slide from the pop-up menu.
3. Open an Adobe Captivate project.
4. Right-click the slide after which you want the new slide or slides to appear. (For example, if you want to paste the copied slide as Slide 6 of your project, click the slide currently labeled Slide 5.)
5. Select Paste Slide from the pop-up menu.

Copy slides from other projects
You can copy and paste slides from other projects. This can save you a great deal of time. For example, if you have a detailed slide with captions containing important reusable text, simply copy and paste this slide into any new projects you create.

You can select multiple slides by pressing Shift or Control on the keyboard while clicking the desired slides. To select all slides, press Control+A or select Edit > Select All Slides.

1. In an open project, right-click the slide you want to copy.
2. Select Copy Slide from the pop-up menu.
3. Open the Adobe Captivate project to which you want to add the slide that you copied in the previous steps.
4. Right-click the slide after which you want the new slide or slides to appear. (For example, if you want to paste the copied slide in as Slide 6 of your project, click the slide currently labeled Slide 5.)
5. Select Paste Slide from the pop-up menu.

Enable rescaling of slides during import
Adobe Captivate can automatically resize the content of imported slides according to the dimensions of the project to which the slide is being imported.

1. Select Edit > Preferences.
2. Select General Settings from the Global menu.
3. Select Rescale Imported/Pasted slide.

Duplicate slides
You can duplicate slides in Storyboard view or Edit view (with the Filmstrip enabled). Duplicating slides is an easy way to expand your projects. For example, if you carefully design a slide with a certain background color, layout, caption, and highlight box, you can simply duplicate that slide and change some of the elements or text to add more information to your project.

❖ In an open project, do one of the following:
  • Right-click the slide to copy and select Duplicate Slide.
  • Select a slide and press Control+D.

To select multiple slides, press Shift or Control on the keyboard while clicking the desired slides. To select all slides, press Control+A or select Edit > Select All Slides.
The slide or slides you selected are duplicated and placed in the project. You can edit and work with the new slides just like the original slides.

**Insert blank slides**

1. In an open project, right-click the slide after which you want the new blank slide or slides to appear.
2. Select Insert > Blank Slide.

The new slide is added to your project. You can edit and work with the new slide just like other slides in the project.

**Insert images as slides**

Image slides are slides that have an image inserted into their background.

1. Open an Adobe Captivate project.
2. Right-click the slide after which you want the new image slide or slides to appear.
3. Select Insert > Other Slide(s) > Image Slide.
4. Browse to and select the image that you want to import in the Open dialog box.
5. If the image that you are trying to import is larger in dimensions than that of your slide, the Resize/Crop Image dialog box appears. Do one of the following:
   - Select Fit To Stage if you want to resize the image to the dimensions of the slide.
   - Select Crop, and resize the handles of the rectangular box that appears to select the portion of the image that you want displayed.

**Insert slides from a PowerPoint presentation**

You can add PowerPoint slides to the end of a project or within a project.

1. In an open project, select Insert > Other Slide(s) > PowerPoint slide.
2. Select a PowerPoint presentation and click Open.
3. Do one of the following:
   - Select Import Slides At The End Of This Project to add new slides to the end of the project.
   - Select Import Slides and Insert After The Slide Selected Below to add new slides after the slide you select from the list.

**Insert animation slides**

You can insert a SWF, AVI, or animated GIF file as a new slide.

*Note: Adding animation as a slide is most appropriate with larger animation files.*

1. In an open project select Insert > Other Slide(s) > Animation Slide.
2. Navigate to the animation file you want to insert (SWF, AVI, or animated GIF) and click Open. The animation slide is generated and added to the project.

It is important to set the correct frame rate. All imported animation files play at the rate selected in the Project Preferences dialog box, regardless of the rate prior to when the file is imported. The default setting is 30 Flash frames per second and is appropriate in most cases. You may need to change the rate if you are embedding your Adobe Captivate SWF file in another SWF file that has a frame rate different than 30.
When you create an animation slide, the amount of time the slide is displayed in the project automatically defaults to the length of the animation file itself. For example, if the animation file that you use to create a new animation slide is only 1.2 seconds in length, the animation slide appears for 1.2 seconds. To change the amount of time the slide is displayed, open the slide in Edit view, select Slide > Properties, and enter a new number of seconds in Display Time. Or use the Timeline to change the slide display time.

**Delete and edit slides**

**Delete slides**
Deleting a slide permanently removes the slide from the project. You can delete slides in Storyboard view or Edit view (with the Filmstrip enabled).

- Do one of the following:
  - Right-click the slide you want to delete, and select Delete Slide from the menu.
  - Select the slide, and press Delete.

**Change background color of slides**

1. Double-click the slide whose background color you want to change.
2. Select Slide > Properties.
3. In the Color Setting options, select Custom, and do one of the following:
   - Pick a color from the basic colors palette.
   - Click More Colors to design a custom color.
   - Click the eyedropper to select and copy any color on your screen.
   - In the text field, enter the value for the color you want and press Enter.
4. If you want to apply the color to all slides, select Apply To All and then click Settings to choose how to apply the change.
5. Click OK.

*Note: To use the project color on a slide, open the Slide Properties dialog box (on the Slide menu, click Properties). In the Color area, click Project. To change the background color for a project, select Edit > Preferences, and click Settings in the Project menu. In the Project panel on the right, select a background color for the project in the Project Background Color list.*

**Edit slides in an image editor**
Adobe Captivate provides an easy way to copy slides to the clipboard. You can then paste the slide into a graphics editing program (for example, Fireworks® or Photoshop), edit the image, and then paste it back into Adobe Captivate. This is especially useful when you want to make a small change to a recorded slide but do not want to rerecord it.

1. In Edit view in an open project, right-click the slide that you want to copy.
2. Select Copy Background from the menu.
3. Open a graphics editing program and paste the slide into the program by pressing Control+V.
4. Make any desired changes to the slide.
5. Copy the image in the graphics program by pressing Control+C so the image is saved to the clipboard.
In Adobe Captivate, select the slide that you had copied, and select Edit > Paste As Image. The new, updated slide (as an image) is placed in the project. If the original slide contained objects such as captions or highlight boxes, they appear on the new slide.

In Adobe Captivate, you can edit background images directly from the Library. To edit a background image, in the Library, right-click the image you want to edit, and select the image editor from the menu.

**Add plain text to a slide**

As you edit a project, you may want to add some text to the slide but not have the text appear as a text caption over the slide. There is an easy trick you can use to add plain text to a slide: simply add the text as a transparent text caption.

1. In Storyboard view, double-click the slide to which you want to add a transparent text caption.
2. Select Insert > Standard Object(s) > Text Caption.
3. In Caption Type, click the pop-up menu and select [transparent].
4. Change other text caption options as required.

*Note:* If you create a transparent caption, avoid underlining text. Underlined text might affect the quality of the text.

**Edit text recorded on a slide**

When you record text being typed, a new slide is created for every line break. Each line of typed text is treated as a single object and appears as a separate layer on the Timeline. You can replace text recorded on a slide with new text along with typing effects. For example, if you have recorded text being typed in an editing program and you want to change the recorded text on the slide later, you can use this option.

Before you record text being typed, ensure that the option to record keystrokes has been enabled. For more information, see “Set global recording preferences” on page 33.

1. In an open project, right-click the Typing layer in the Timeline, and select Replace With Text Animation.
2. Select one of the options in the Effect menu:
   - **Typing Text** Play text without any typing sound.
   - **Typing Text With Sound** Play text with a typing sound.
3. In the Text box, type the replacement text on the slide, and then click OK.

   The text on the slide is replaced with the entered text. In the Timeline, the typing text object is replaced with the text animation object, and the overwritten text appears on the object in the Timeline.

**Name slides**

It is easier to identify and keep track of slides using their name instead of their slide number. The name of the slide appears under the slide.

1. Double-click the slide you want to name. The Slide Properties dialog box appears.
2. In Label, type a name for the slide.

**Move to a specific slide**

Press Control+Shift+G and specify a slide number in the Go To Slide dialog box to jump directly to the specified slide. Alternatively, you can use Edit > Go To Slide to move to the specified slide.
Lock slides

Adobe Captivate gives you the option to lock individual slides. When you lock a slide, all objects on the slide can be viewed but not edited. This feature is useful if you want to send your project to others for review but do not want them to make changes to objects.

You can tell that a slide is locked by looking for the small lock icon. This icon appears below a locked slide in Storyboard view and in the Filmstrip.

❖ In an open project, right-click the slide you want to lock and select Lock Slide.

To select multiple slides, press Shift or Control on the keyboard while clicking on the desired slides. To select all slides, press Control+A or select Edit > Select All Slides.

Hide slides

Adobe Captivate allows you to hide an individual slide in a project; the slide stays in the project but is hidden from view when the project is played. This option is useful in several situations, such as if others are reviewing the project, but information on certain slides is changing so you want to hide the slides until they are correct.

Hide slides

❖ Do one of the following:

❖ Right-click a slide and select Hide Slide.
❖ In Storyboard view, select the slide, and click Hide Slide in the Slide Tasks panel.

The slide is dimmed in Storyboard view.

Include or exclude hidden slides when publishing handouts

1 In an open project, select File > Publish.
2 Select Print on the left panel.
3 In Type, select Handouts.
4 In the Handout Layout Options area, select Include Hidden Slides. (If a green check mark appears next to Include Hidden Slides, the hidden slides are included in the Word document; remove the check mark to exclude the hidden slides from the handouts.)
5 Click Publish.

Group slides

When the number of slides becomes unmanageable, you can group them. By expanding and collapsing groups, you can view subsets of the slides instead of all slides at once. Groups also provide a useful overview for the project, and they provide a convenient way of deleting or hiding multiple slides at once (for example, slides that you don’t want to publish).

To help associate slides with their group, you can mark grouped slides with the same border color. The color is visible from any of the three views (Storyboard, Edit, or Branching), but it doesn’t show when the project is run.

Updated 19 May 2009
**Create a slide group**

1. In an open project, click a slide that you want to group, and use Control-click or Shift-click to select the other slides for the group.
2. Select Slide > Group > Create.
   
The selected slides are grouped into a single group slide with their numbers and descriptions displayed on it.

**Name slide groups and mark them**

1. Click a slide group.
2. Select Slide > Group > Edit.
3. From the Color pop-up menu, select a color for all of the slides in the group. This color is not displayed when the project is run.
4. In the Title box, type a name for the group. This title appears at the bottom of the grouped slide.
5. Click OK.

**Expand or collapse a slide group**

1. Click a slide group.
2. Do one of the following:
   - Select Slide > Group > Expand.
   - Select Slide > Group > Collapse.
   
   A faster way is to click the arrow icon on top of the group slide.

**Ungroup slides**

1. Select a slide group.
2. Select Slide > Group > Remove.

**Change slide order**

To reorder slides, select them and drag them to the new position. You can change slide order only in Storyboard view and in the Filmstrip.

You can select multiple slides by pressing Shift or Control on the keyboard while clicking the desired slides. To select all slides, press Control+A or select Edit > Select All Slides.

**Slide notes**

You can add slide notes and convert them into an audio file using the text-to-speech converter in Adobe Captivate. You can also convert slide notes to closed captioned text. Unlike slide notes, closed captioned text appears on the slide during runtime.
You can also use slide notes to communicate with users who do not have any audio equipment or are hearing impaired. Slide notes are a good location for adding extra information about a slide, such as numerical details, supporting materials, or footnote text.

Add slide notes
You can add notes to slides in one of the following ways:

- Type text directly into the Slide Notes panel. Enter your notes in the Slide Notes column.
  
  **Note:** If you do not see the panel, click the arrow icon at the bottom of the slide window.

- Click Notes in the Slide Properties dialog box. Enter the text in the Slide Notes dialog box that appears.

- You can add slide notes to an audio file using the Record Audio dialog box. Slide notes are useful in the Record Audio dialog box because you can read the text directly from the dialog box as you record. After you insert an audio file into the slide that you have recorded using slide notes, the slide notes are added to the Slide Notes column.

- Slide notes are automatically imported when you import slides from Microsoft PowerPoint.

Slide notes could act as instructions for developers or as reminders for unfinished items. Notes are not displayed when the movie is played.

If you export your project to Microsoft Word to create handouts, you have the option to include slide notes in the document. This can be useful when you want to add extra information for reviewers when you publish the project as a Microsoft Word document.

Install text to speech converter
If you have not installed the text-to-speech software during installation, do one of the following:

- Re-run the installation CD. Click Install Text To Speech Voices in the autoplay options.

- Run the EXE file for the text-to-speech software. This file is in the Goodies folder on your installation disc.

If you have problems installing the text to speech software, see Rick Stone’s movie Installing Text to Speech.

Convert slide notes to speech or closed captioned text
You can convert text in the slide notes into an audio file using text-to-speech software from NeoSpeech™. The audio file is inserted into the corresponding slide. Multiple slide notes are merged into a single audio file and appear on the Timeline as a single object. You can also convert slide notes in the panel to closed captions in a single click.

The audio file pauses at locations where you have inserted commas or periods in the slide notes.

When you edit a slide note, you must click Convert To Speech for the changes to be applied.

When you play the movie:

- The slide notes are read aloud to the user.
- The closed caption text on the slide is displayed to the user.

In the Slide Notes section, enter the required text in the Slide Notes column. To add another row, double-click in the Slide Notes column.

You can add as many rows of text as slide notes. However, Adobe Captivate reads text only from the last row. If you want to add a chunk of text as a slide note, insert the text into a single row.
2 Click the green dot ▶ in the Speech column. The green dot ▶ changes to a green check mark ✔. To convert text in all the rows to speech, click the Text To Speech header.

3 Click Convert To Speech.

   **Note:** If you do not have the required software installed on your computer, the Download Voice button is displayed instead.

4 In the Speech Agent dialog box, select the voice that you want to use for reading the text.

5 Click the green dot in the Closed Caption column if you want to convert the slide notes to closed captioned text. This text is displayed when the user plays the movie. Click the Closed Caption header to select all the rows in that column.

   To prevent slide notes from being read aloud when the movie is played, click the check mark.

**Resolving the, “unable to decode and import the selected wav - mp3 file” error**

This error might be displayed when you are using Adobe Captivate on Windows Vista. You must register the Adobe DLL to fix this error.

1 Close Adobe Captivate.

2 Run Command Prompt in the admin mode.

3 Enter the location of the directory where you have installed Adobe Captivate.

4 Run regsvr32 NSAudio.dll. The message, “Registration of DLL successful” is displayed.

5 Right-click Adobe Captivate in the Program Files menu, and select Run As Administrator.

**Add speech text to multiple slides**

You can add speech text to multiple slides using the Speech Management dialog box. To add variety to the movie, you can choose different speech agents for different slides. For example you could use a male voice and a female voice for alternate slides.

1 Select Audio > Speech Management.

2 In the Speech Text column of the Speech Management dialog box, click Browse (…) 

3 In the Slide Text To Audio dialog box, enter the text that you want to convert to speech.

4 From the Speech Agent column, select a speech agent for the slide.

5 Repeat the procedure for other slides.

**Disable closed captions in a slide**

You can prevent closed captions from appearing when the movie is played. Click the check mark icon ✔ in the corresponding row of the Closed Caption column.

**Delete closed captions/slide notes from a slide**

To delete closed captions/slide notes from a slide, click ✗ in their corresponding rows.
Slide transitions

Transitions are special effects that appear when one slide changes to another. Transitions signal the end of one slide and the beginning of another.

1. Double-click the slide to which you want to add a transition.
2. Select Slide > Properties.
3. From the Transition menu, choose one of the transition options.
4. If you want to apply the transition to all slides, select Apply To All and then click Settings to choose how to apply the change.

Tips for introductory slides

- Add sound. Adobe Captivate makes it easy to add sound to projects, and sound is very powerful in an introduction. You can add existing sound files or record your own voice-over. You can include a welcome message or play some appropriate music.

  Adobe Captivate contains a gallery that has buttons, sounds, and animations (in SWF format) for you to use in your projects. By default, the gallery is stored in the following location when you install Adobe Captivate: C:\Program Files\Adobe\Adobe Captivate 4\Gallery.

- Use special effects. If you are going to use special effects in your project, why not start off with them? Special effects (such as fading, for example) create a polished and professional look right from the start.

- Use animated text. For an easy and impressive introductory slide, use the Adobe Captivate animated text feature. This is a fast way to create a sophisticated look for your project.

- Use captions strategically. Add multiple captions to your introductory slide and then carefully set their timing so they fade in and out, one at a time.
Chapter 6: Adding and Managing Objects

Objects are different elements that you can add to Adobe Captivate slides. Adobe Captivate has many different types of objects.

Types of objects

Adobe Captivate provides various objects that you can use to enhance the usability and interactivity of your Adobe Captivate project.

Adobe Captivate objects can be broadly classified as follows:

Interactive objects  Objects that perform an action when the user interacts with them using a mouse or keyboard. You can assign a score for user interactions with such objects.

For example, a click box is an interactive object that performs a defined action when the user clicks it. You can assign points for every correct click. The following interactive objects are available in Adobe Captivate:

- “Click boxes” on page 98
- “Text entry boxes” on page 101
- “Buttons” on page 105
- “Widgets” on page 113

Noninteractive objects  Objects that are used to display information to the user. You cannot assign scores to noninteractive objects.

The following noninteractive objects are available in Adobe Captivate:

- “Text captions” on page 62
- “Rollover captions” on page 72
- “Highlight boxes” on page 74
- “Mouse” on page 75
- “Rollover slidelets” on page 79
- “Zoom areas” on page 82
- “Images and rollover images” on page 84
- “Drawing tools” on page 87
- “Animations” on page 90
- “Animated text” on page 92
- “Video” on page 93

Controlling the visibility of objects

You can hide an object on a slide, and define conditions that must be satisfied for the object to be displayed.
The following example illustrates how to hide an image on a slide until the user clicks the Show Image button.

1. Select Insert > Image to insert an image on the slide.
2. Right-click the image, and select Properties from the menu.
3. In the Image dialog box, click the Options tab.
   a. In the Item Name field, enter My_Image.
   b. Deselect the Visible option.
   c. Click OK.
5. In the New Button dialog box, do the following:
   a. In the If The User Clicks On The Button: On Success menu, select Show.
   b. In the Show menu, select My_Image.
   c. Click OK.

When you play the movie, the image appears only when you click the button.

### Import objects

You can import objects from one Adobe Captivate project into another. This feature is useful in two situations. First, you might want to delete an existing project, but keep the objects to add to another project. Second, you might need to redo slides in a project, but want to keep the existing objects to save time.

*Note: If you want to reuse individual media objects from another Adobe Captivate project, you can open that project Library from within your current project Library. Then drag objects directly onto a slide or into the current project Library for easy reuse.*

1. In an open project to which you want to add existing objects, select File > Import > Slides/Objects.
2. Select the project that contains the objects to import, and click Open.
   
   The Import Project dialog box appears.

3. Select the objects you want to add to your current project. For each slide click the Import pop-up menu and select an option. Use the slider bar, or Tab (next slide) and Shift-Tab (previous slide) to navigate through all the slides in the project. Click Select All-Objects to select all objects in the project. Click Clear All-Objects to clear all objects in the project. To import objects only, select the Objects Only option.
   
   Selecting the Objects Only option lets you specify exactly which slide you want to add the objects to in the current project. Click the pop-up menu next to Place Objects On and select a current project slide number.

4. When you finish, click OK.
   
   The objects are added to the open project.

5. Open different slides in Edit view to see the objects that were imported.
Manage Library objects

View objects in the Library
1 In an open project, click the Edit tab to move to Edit view.
2 Select Window > Library.
   The Library panel appears.
3 Double-click one of the folders (Audio, Backgrounds, Images, Media) to view the objects in that category.
4 Click an individual object to display it in the Library preview pane.
   In addition to viewing image files, you can play audio and animation files in the Library preview pane.

Reuse an object listed in the Library
1 In Edit view, select the slide to which you want to add the object.
2 If the Library is hidden, select Window > Library.
3 In the Library, expand the folder for the category of object you want to reuse.
4 Click the object that you want to reuse and preview the object in the preview pane.
5 Drag the object to the selected slide or slidelet. The object becomes a part of the slide or slidelet depending on where it is placed.
   Note: After you copy the object to the slide, editing the properties of the object won’t affect that object in other slides.

Reuse an object in a different project Library
1 In Edit view, select the slide to which you want to add the object.
2 If the Library is hidden, select Window > Show Library.
3 In the toolbar of the library panel, click Open Library.
4 Navigate to, and select, the project that contains the objects you want to reuse and click Open.
   The library for the other project opens in a separate and expandable window.
5 Click to select the object that you want to reuse.
6 Drag the object to the selected slide stage or to the appropriate folder in your current project Library.
7 Select and drag any additional objects that you want to reuse, and then click the Close button.
   The new objects now appear in your current project Library, even if you dragged them directly onto a slide. You can reuse them as many times as you want.
   Note: After you open the Library of another Adobe Captivate project, that project stays in the Open Library menu. You can quickly access that project Library at any time.

See also
   “Adobe Captivate Library” on page 13
Managing objects with the Stage toolbar

The Stage toolbar, available in Edit view, contains the following icons to help you manage objects:

- Slide properties. Click this option to open the Slide Properties dialog box. This toolbar option changes to Edit Question or Edit Results if a question slide or results slide is selected.
- Cut, copy, paste, delete, and duplicate
- Open properties of selected object
- Bring selected object to front
- Send selected object to back
- Show/hide grid
- Snap to grid
- Size and position controls
- Zoom
- Redraw shape when rollover slidelet is selected.

Copy, paste, and duplicate objects

After you have created an object, you can copy that object and paste it onto the same slide, a different slide in your project, or several slides in your project at the same time. This can save you a great deal of time, especially if you create intricate objects with specific sizes, colors, and formatting.

💡 You can also copy and paste objects between different projects.

*Note: To reuse media objects that appear in the Library, simply drag the object from the Library onto the slide.*

When objects from a slide are copied into a slidelet, the following properties of the object are modified:

- If timing for the object is specified as Rest Of Slide or Rest Of Project, it is changed to Rest Of Slidelet.
- The option Synchronize With Project loses its validity for FLV files.

Copy an object to a different slide

1. In storyboard view in an open project, double-click the slide that contains the object you want to copy. Alternatively, go to Edit view and click the slide that contains the object.
2. Right-click the object and select Copy.
3. Open the slide to which you want to copy the object. If the Filmstrip is displayed, you can click any slide. Alternatively, click the Storyboard tab and then double-click an individual slide.
4. Right-click the slide and select Paste Object.

Copy an object to multiple slides

1. In storyboard view in an open project, double-click the slide that contains the object you want to copy. Alternatively, go to Edit view and click the slide that contains the object.
2 Right-click the object and select Copy.

3 Select the slides to which you want to copy the object. Hold down the Shift key and click consecutive slides, or hold down the Control key and select any slides, even if they are not consecutive. You can use the Storyboard view or the Filmstrip panel in Edit view.

4 Right-click a selected slide and select Paste Object.

**Copy objects from other projects**

You can copy and paste objects from other projects. This strategy can save you a great deal of time. For example, suppose you have created a detailed object in another project. Simply copy and paste the object into any new projects you create.

*Note: To reuse media objects from another Adobe Captivate project, open that project Library from within your current project Library. Then drag objects directly onto a slide or into the current project Library for easy reuse.*

1 Open the Adobe Captivate project that contains the object you want to copy.
2 Right-click the object, and select Copy.
3 Open the Adobe Captivate project to which you want to add the object copied in the previous steps.
4 Right-click the slide to which you want to add the object.
5 Select Paste Object.

*You can also import an object or multiple objects from another project.*

**Duplicate objects**

You can duplicate objects while in Edit view. Duplicating objects is an easy way to reuse content. For example, you can duplicate a detailed caption and change some of the text to quickly add more information to your project.

*Note: To reuse media objects that appear in the Library, simply drag the object from the Library onto the slide.*

1 In an open project, double-click the slide that contains the object you want to duplicate.
2 Right-click the object and select Duplicate.

The object you selected is duplicated and the new object is placed on the slide. You can edit and work with the new object just like the original object.

**Align objects**

**Align multiple objects on a slide**

If you have multiple objects on a slide, Adobe Captivate can automatically and perfectly align the objects for you. This is an easy way to create precise and professional-looking project slides.
You have many options for aligning objects both vertically and horizontally. Some of the alignment options depend upon the location of the anchor object. The anchor object is simply the first object you select. You might want to select the largest object or the object that appears first as the anchor object. So that you can easily identify the anchor object, it appears with white resizing handles, while any subsequent objects you select appear with black resizing handles.

1. In an open project, open a slide that contains more than one object, such as two captions. You can also open a slide and add more than one object to the slide.

2. If the alignment toolbar is not displayed, select Window > Toolbars > Alignment.

3. Select the objects on the slide by holding down the Shift key and clicking the individual objects.

4. Do one of the following:
   - Click an alignment option on the alignment toolbar.
   - Right-click the selected objects, choose Align, and select the appropriate option from the pop-up menu.

   The x (horizontal) and y (vertical) coordinates of the mouse are automatically displayed in the lower-right corner of the Adobe Captivate project window as you move the mouse. Knowing exact coordinates can help you place objects in a precise location on a slide. When aligning objects, it can be helpful to display the grid.

   You can move objects using only the keyboard. Select an object and press an arrow key on your keyboard to move 1 pixel at a time. To move an item by the number of pixels defined in the grid, select an object and press Control+arrow key.

   To change the height or width of an object by 1 pixel, hold Shift and press an arrow key. Similarly, hold Alt+Shift and an arrow key to change the size 15 pixels at a time.

   In the new Stage toolbar, the size and position options are helpful for aligning objects.

### Aligning objects on the Timeline

The Timeline lets you align objects easily. For example, you can align objects to the playhead, the start of a slide, the end of a slide, another object, or a point in time.

#### Display the Adobe Captivate Timeline

1. In an open project, double-click a slide that contains objects you want to align.

2. If it is not open already, show the Timeline by clicking the splitter bar. To expand the Timeline, click the display arrow. You can also open the Timeline from the View menu by selecting the Show Timeline option, or using Control+Alt+T.

#### Align an object to the playhead

When you sync an object to the playhead, the object moves to the location of the playhead in the Timeline.

   - Right-click an object on the Timeline and select Sync With Playhead.

#### Align an object to the start of a slide

   - Click an object on the Timeline and drag it to the left side of the Timeline.
Extend the playing time of an object to the end of a slide
- Right-click an object on the Timeline and select Show For Rest Of Slide.

Align an object to a point in time
- Click an object on the Timeline and drag it to the left or right so that the left edge of the object bar aligns with the correct time in the header.

  For example, if you have a caption that currently appears at the same time the slide displays, but you want a slight delay, drag the caption so that its left edge aligns with 2s (a 2-second delay) or 4s (a 4-second delay) in the header.

You can select multiple objects and move them at the same time. Hold down the Shift key and click objects to select consecutive stacked objects in the Timeline or to select nonconsecutive objects, hold down the Control key and click the objects to move.

You can adjust the zoom level of the Timeline easily. Click in the Timeline ruler and spin the mouse wheel on your mouse to increase or decrease the zoom level. Alternatively, use keystrokes to change the zoom level. Click the ruler and then press Control+[- to decrease the zoom level, Control+] to increase the zoom level, or Control+W to set the zoom level so that all objects will fit in the current Timeline.

Align objects with the grid
Adobe Captivate contains an optional grid that you can display while working on individual slides in Edit view. The grid lets you more accurately place and position objects on a slide.

You can also select the Snap To Grid option if you want objects that are placed near grid lines to automatically “snap” to the nearest lines.

Display the grid
1 In an open project, double-click any slide to open Edit view.
2 Select View > Show Grid.

  The grid, a light pattern of dots, appears on the slide.

Align objects with grid lines
1 In an open project, double-click any slide to open Edit view.
2 Select View > Snap to Grid.
3 To test the snap-to-grid behavior, add an object such as a highlight box to the slide, and then move the box. As you move the box, it automatically lines up with the grid lines.

Change the grid scale
1 In an open project, select Edit > Preferences.
2 In the Category panel, select Global.
3 In the Grid Size field, enter a new value for Grid size. Larger numbers display fewer grid lines; smaller numbers display many grid lines for more precise object placement.

The x (horizontal) and y (vertical) coordinates of the mouse are automatically displayed in the lower-right corner of the Adobe Captivate project window as you move the mouse. Knowing exact coordinates can help you place objects in a precise location on a slide.

You can move objects using only the keyboard. Select an object and press an arrow key on your keyboard to move 1 pixel at a time. To move an item by the number of pixels defined in the grid, select an object and press Control+arrow key.
You can also access the Show Grid and Snap To Grid options by clicking the Options menu and selecting Preferences. These options also appear in the new toolbar above the Stage area.

**Resize and reposition objects by pixel**

You can specify the position of an individual object by adjusting the pixel value of the left and top alignment, and the size by adjusting the pixel value of the height and width of the object.

When you select an object on a slide in Edit view, four text boxes appear in the toolbar above the slide. The L, T, W, and H text boxes are for left and top alignment and width and height. The lock symbol to the right of the text boxes is to constrain the proportions of the object. When Constrain Proportions is active, the lock appears closed; when Constrain Proportions is not selected for the object, the lock appears open.

*Note: These options also appear on the Size And Position tab of each object’s properties dialog box, which you can access by right-clicking an object and selecting Properties.*

**Change the display order of objects**

Adobe Captivate lets you add multiple objects, such as captions, highlight boxes, animations, or images to slides. You specify the order in which objects appear. Use the Timeline to precisely adjust the timing of all objects on a slide.

1. In an open project, navigate to the slide that contains the objects whose order you want to change.
2. If it is not open already, show the Timeline by clicking the splitter bar. To expand the Timeline, click the display arrow. You can also open the Timeline using View > Show Timeline or Control+Alt+T.
3. Change the order and timing of objects as required.

For example, move the mouse over the left or right edge of an object on the Timeline until the resize cursor appears. Then drag the edge left or right to change when and for how long the object appears.

If you have an object that currently appears at the same time the slide appears, but you want a slight delay, move the mouse over the center of the object on the Timeline until the hand appears; then drag the entire object so the left edge aligns with 2s (a 2-second delay) or 4s (a 4-second delay) in the header.

4. If you have two overlapping objects on the slide, specify the object you want to appear frontmost by setting the stacking order. To change the stacking order, move objects to the back or front of the slide Stage. The key point to remember is that objects at the back of the Stage appear behind other objects. Use one of the following methods to set the stacking order:
   - In Edit view, right-click an object on the slide and select one of the object order options. If necessary, right-click other objects on the slide and adjust their order.
   - In Edit view, on the Timeline, move the pointer over an object until the hand appears. Then drag the object up or down to change its position in the stacking order. Moving an object higher in the stacking order moves it to the front of the Stage. Moving an object lower moves it to the back of the Stage.

*Note: If the order for a slidelet is changed, the objects it contains are also moved back or forward along with the slidelet.*
Merge objects into a slide

You can merge any object that you create and place on a slide, including images, captions, click boxes, highlight boxes, text entry boxes, and buttons. Merging permanently removes the interactivity of the object, making it an image of the object.

The merging feature is useful in several situations. For example, suppose you import a large image into a slide that contains other objects. You can merge the image into the slide so that it becomes a static background for the other objects. You can also make text a permanent part of a slide by creating a transparent text caption and then merging the caption.

1 In an open project, double-click the slide that contains the object you want to merge.
2 Right-click the object that you want to merge into the slide, for example, an image, caption, or click box.
3 Select Merge Into Background from the pop-up menu.
4 The object is merged into the slide.

Note: Merging objects in a slidelet into the background will merge the object into the slidelet background.

Edit object information in the Advanced Interaction dialog box

In the Advanced Interaction dialog box, you can view and edit all interactive objects in your project. The Advanced Interaction dialog box opens in a separate window. When you're done reviewing and changing the interactive object properties, click Close.

Note: The dialog box is complex. To make reviewing the project information easier, print the dialog box by clicking Print.

1 In an open project, select Project > Advanced Interaction, or press F9.
   The Advanced Interaction dialog box appears, populated with a collapsible list of all interactive objects in the project.
2 Filter the list by clicking the button at the top of the dialog box that corresponds to the object type that you want to view.
   Note: You can choose to filter by all scorable objects, click boxes, text entry boxes, buttons, questions, or hidden slides.
3 Click a slide title or object to select it.
   Note: You can also select a specific slide by scrolling and clicking that slide in the Filmstrip in the left pane of the dialog box. To remove Print from the view, click the Print button.
4 To view or edit the properties or results of a slide or object, click the Browse button wherever it appears. You can also select or clear options, and change the selections in pop-up menus; the properties appear in the following columns:

   Slide/Object This column shows the slide or object name. Click the Browse button to view the properties dialog box for the object or slide.

   On Success This column shows the navigation that follows the slide if the user successfully completes an object’s action. For more information, see “Defining project navigation” on page 97.

   Attempts This column shows the maximum number of attempts you have set as a limit for an interactive object.
On Failure  If an object or slide has the possibility of failure (for example, if an incorrect answer is selected in a multiple-choice question), this column shows where the slide leads after failure. For more information, see “Defining project navigation” on page 97.

Shortcut  View and edit keyboard shortcuts for a slide or object in this column.

Time Limit  This column shows the time limit for specific objects.

Points  This column shows the total points associated with each slide.

Add To Total  This column allows you to add or remove scored objects from the total points.

Track score  This option allows the interactive object to carry a score for the overall project quiz. If you select this option, Adobe Captivate adds the score from the object to the overall score. (Selecting this option selects the Include In Quiz option on the Reporting tab of the object’s Properties dialog box.)

Report Answer  This option enables your project quiz scores to be integrated with a learning management system (LMS). (Selecting this option selects the Report Answers option on the Reporting tab of the object’s Properties dialog box.)

Objective ID and Interaction ID  These columns contain the ID numbers, if you assign them, for integration with a learning management system (LMS).

When you’re done reviewing and changing the interactive object properties, click Close.
Chapter 7: Noninteractive Objects and Media

This chapter describes the noninteractive objects available in Adobe Captivate. Noninteractive objects are used to display information to the user. You cannot assign scores to noninteractive objects.

Text captions

You can use text captions for the following:

- **Draw attention to specific areas of the slide**  Use text captions to point out menu options or icons or to focus user attention on easily overlooked details. When you are not using voice-over narration, you can use text captions instead.

- **Add text to a slide**  The only way in which you can add plain text to a slide in Adobe Captivate is using transparent text captions. For more information, see “Add plain text to a slide” on page 64.

You decide how text captions appear (font, size, color, and so on). Adobe Captivate provides a wide variety of predefined text caption styles, but you can also create custom styles that match the standards of your company.

The following types of captions are available in Adobe Captivate:

- **Regular**  Use regular captions to “talk” to the viewer about features on the screen. You can have Adobe Captivate automatically generate text captions based upon what is recorded. For example, when you click the File menu during recording, Adobe Captivate creates a text caption that says “Select the File menu item.” It then places the text caption on the slide showing the action. Alternatively, you can insert such text captions into the slides manually and edit them.

- **Captions for interactive objects**  Interactive objects are associated with success, failure, and hint captions. These captions are automatically generated for the objects when you record in some of the modes.
  - **Success**  The success caption is displayed when the user performs the desired action on the object.
  - **Failure**  The failure caption is displayed when the user performs an action other than what is set in the application.
  - **Hint**  You can use hint captions to help users when they are unable to perform a certain task. Hint captions are displayed when the user moves the mouse over the object.

Tips for creating text captions

Here are some tips for creating captions:

- If the caption is strictly text on the slide, use the Transparent caption style.
- Don’t use fonts that are not available on most computers. For example, if you use FF Confidential, and the user doesn’t have it on the local computer, some other font is substituted.
- Create a style sheet by formatting a caption and selecting the Apply Properties To All Captions In The Movie check box in the Text Caption dialog box. All captions in the SWF file or captions you create use the font, alignment, and caption style you set.
- Captions can be used as a script for narrations. When you click the Audio button on the main toolbar to open the Record Audio dialog box, click the Captions And Slide Notes option. If a caption is attached to the slide, you see it in the Record Audio dialog box as a script.
Narrating a caption actually adds an extra degree of accessibility to the demo. When setting the size of the text in a caption, be aware that Adobe Captivate makes captions large. Such large captions can overpower the text in the slide. To get around this issue, use a font size that is a couple of points smaller than you would normally use. Text in Adobe Captivate is rasterized and aliased. This is a known issue. To avoid it, don’t place light text on a transparent background in a slide containing a solid dark background color.

Text caption properties

Use the Properties dialog box of a text caption to customize it.

The Properties dialog box for text captions has the following tabs:

- Text Caption
- Options
- Audio
- Size And Position

**Note:** If you change the settings in this dialog box, they become the default settings, and any new text captions that you create use the new settings.

Text Caption tab

**Caption Type** Displays the types of captions available in Adobe Captivate. Each text caption type is named, and a small thumbnail image shows what the text caption looks like.

**Note:** When adding or modifying a text caption, select the caption type before setting the style and format of text in a caption. This ensures that style and format changes to text are retained.

**Caption Style** Five text caption types are available. Many of the text caption styles contain text captions with directional callouts. You can select a text caption that points in the most appropriate direction.

- **Font** Font of the text caption.
- **Size** Font size of the caption text.
- **Font Color** Font color of the caption text.
- **Highlight** Color for highlighting the text.
- **Insert Variable** Add a system or user-defined variable that acts as a placeholder for the text.
- **Display Options** Font properties of the text in the text caption. You can align text, format it, and insert symbols, using the various options.
- **Type Caption Text Here** Text that is displayed on the text caption.

Options tab

**Item Name** Enter a unique name for the object. You can use this name when defining the visibility conditions for the object.

- **Visible** Deselect this option if you want the object to be invisible on the slide. The object can be made visible using the Show option. For more information, see “Controlling the visibility of objects” on page 52.

**Display For (Time)** Duration for which the text caption is displayed in the slide. From the pop-up menu, select one of the following options:

- **Specific Time** The duration for which the text caption appears on the slide. Set the time in seconds by typing the value in the field, or by using the scroll arrows.
• **Rest Of Slide** The text caption is displayed for the entire duration of the slide.

• **Rest Of Project** The text caption is displayed for the entire duration of the project. For example, you can use this option to display a text caption that displays the name of the company.

**Appear After [#] Seconds** The text caption appears on the slide after the specified duration.

**Effect** Transition effect for the highlight box. You can apply a fade in or fade out effect and set the time for the fading effects.

**In [#] Seconds** Time for the caption to fully fade into view.

**Out [#] Seconds** Time for the caption to completely disappear.

**See also**
“Set audio for noninteractive objects” on page 96
“Fix size and position of noninteractive objects” on page 96

### Add text and text captions

#### Add a text caption

If you change the settings in the Properties dialog box for text captions, they become the default settings. Any text captions that you create use the new settings.

If you create a transparent caption, avoid underlining text because doing so can decrease text quality when the project is viewed.

*If you add a transparent text caption, avoid using bold text; regular text appears clearer than bold text on most monitors.*

1. In an open project, select the slide to which you want to add a text caption.

2. Select Insert > Standard Objects > Text Caption. You can also right-click in the slide, choose Insert from the pop-up menu, then choose Text Caption.

3. Set the various options for the text caption.

4. Use the Settings menu to select how to apply property changes in the project. To apply all your changes, select Apply Only Changed Properties. To apply all the text caption settings, select Apply All Properties. You can apply the text caption settings to the current slide only or to all slides. And you can choose to apply the text caption settings to all captions or only the text captions of the same type as the current one.

5. Select Apply To All to apply settings specified in the Settings menu to all slides.

#### Add plain text to a slide

To add text to the slide without making it appear as a text caption, add the text as a transparent text caption.

*Note: If you create a transparent caption, avoid underlining text because doing so can decrease text quality when the project is viewed.*

*After adding the transparent text caption, you may want to merge the caption with the slide background.*

1. In an open project, select the slide to which you want to add a transparent text caption.

2. Select Insert > Standard Objects > Text Caption.
In the Caption Type area of the Caption Properties dialog box, select [Transparent].

Change other options as required.

To add superscript to a slide, select the text, and press Control + shift + “+”. To add a subscript, select the text, and press Control + “_”.

**Insert text as a variable**

1. In an open project, right-click the text caption and select Properties.
2. In the Text Caption tab, move the cursor to the position in the text where you want to insert the variable.
3. Click the Insert Variable icon 📜.
4. Select one of the following in the Variable Type menu:
   - To insert a variable that you have previously created, select User. Select the variable from the Variables menu. For more information, see “Create a user-defined variable” on page 144.
   - To insert a system variable, select System. Select a system variable from the Variables menu. To filter system variables by their category, select the corresponding option from the View By menu. When you do not choose a category, all the system variables are listed in the menu.

5. To change the maximum number of characters that the variable can accommodate, enter a value in the Maximum Length field. If the number of characters exceed the value specified in this field, the extra characters are not displayed.

   **Note:** Spaces are also considered for the character count.

6. To create a variable or to change the values of a selected variable, click Actions Dialog.
7. Click OK.

When you preview the project, the value of the variable is displayed inside the text caption.

**Insert symbols and special characters**

1. Select Insert > Standard Objects > Text Caption.
2. Click Insert Symbol.
3. Select a symbol that you want to insert from the menu.
4. For more options, click Other.
5. In the Insert Special Characters dialog box, select the character that you want to insert, and click OK.

**Add text captions automatically during recording**

When you record projects or record additional slides for projects, Adobe Captivate can automatically create text captions based upon the action recorded. For example, if you record the action of selecting the File menu, Adobe Captivate can automatically add a text caption that reads “Select File menu” on the same slide.

Actions that generate text captions include the following: selecting menus and menu items; pressing buttons; changing values in locations such as lists, combo boxes, or check boxes; and opening child windows.

1. In an open project, select Edit > Preferences.
2. In the Preferences dialog box, select Mode(s) under the Recording menu.
3. In the Mode menu under the Recording panel, select the mode of recording for which you want to automatically generate the text captions.
4. Select Automatically Add Text Captions.
After you finish recording and the project is generated (including the automatically created captions), view the individual slides in Edit mode to see the captions.

**Note:** Adobe Captivate can automatically generate text captions for all standard Windows user interface elements. It might not, however, support nonstandard user interface elements, including menu text in applications created with Delphi.

### Edit text captions

#### Edit a text caption
If you are resizing a text caption, you cannot make the text caption smaller than the bitmap used to create the text caption. For example, the text caption style “Pill” uses bitmaps sized approximately 18 pixels (wide) x 16 pixels (high), so these bitmaps could not be resized to 15 x 12 pixels. However, any of the text caption bitmaps can be made larger.

To edit a text caption, right-click the text caption, and select Properties. Make the required changes in the Properties dialog box for the text caption.

*If you have a detailed slide that contains text captions and other objects, you might want to make the text caption a permanent part of the background.*

#### Copy text captions
You can copy and paste text captions between slides. This is a great time-saver, especially if you use the same text caption on multiple slides.

1. In an open project, select the slide containing the text caption you want to copy.
2. Right-click the text caption and select Copy.
3. Navigate to the slide where you want to paste the caption.
4. Right-click in the slide and select Paste Object.

*You can copy and paste more than one text caption at a time. To select multiple text captions, press Control and click the text captions. Right-click one of the selected text captions and choose Copy.*

#### Moving and resizing text captions
You can resize text captions manually or automatically and move text captions to new locations on a slide. To move text captions on a slide, select the text caption, and drag it to the new location.

**Note:** If you are resizing a text caption, you cannot make the caption smaller than the bitmap used to create the caption. For example, the caption style “Pill” uses bitmaps sized approximately 18 pixels (wide) x 16 pixels (high), so these bitmaps could not be resized to 15 x 12 pixels. However, any of the caption bitmaps can be made larger. If you need very small captions, consider creating custom captions.

#### Manually resize a text caption
To manually resize a text caption, select the text caption, and move the pointer over the selection handles. When the pointer becomes a resize handle, drag the mouse to resize the object.
Automatically resize text captions
Adobe Captivate can automatically resize a text caption according to the amount of text in the text caption. If you edit the text, the caption is resized to accommodate the altered text. This is an easy way to keep your text captions looking balanced and proportional.

1. In an open project, select Edit > Preferences.
2. In the Category panel, select Defaults from the Global menu.
3. In the Global panel, select Autosize Captions.

Change text caption order using the Timeline
Adobe Captivate lets you add multiple captions to each slide. You can specify the order in which these captions appear using the Timeline. The Timeline enables you to precisely adjust the timing of all objects, including captions, on a slide.

1. In an open project, navigate to the slide containing the captions whose order you want to change.
2. If it is not open already, show the Timeline by clicking the splitter bar. To expand the Timeline, click the display arrow.
3. Change the order and timing of captions as required.
   - For example, move the mouse over the left or right edge of a caption on the Timeline until the resize cursor appears. Then drag the edge left or right. This changes when the caption appears or disappears and how long it is shown.
   - Alternatively, suppose a caption and its slide appear concurrently, but you want a slight delay. To achieve this effect, move the mouse over the center of the caption on the Timeline until the hand cursor appears. Then drag the entire caption so the left edge aligns with 2s (a 2-second delay) or 4s (a 4-second delay) in the header.
4. If two captions overlap on the slide, select the caption you want to appear in front by setting the stacking order. To change the stacking order, moving captions to the back or front of the slide Stage. The key point to remember is that captions at the back of the Stage appear behind other captions. Use one of the following methods to set the stacking order:
   - In Edit view, right-click a caption on the slide and select one of the caption order options. If necessary, right-click other captions on the slide and adjust their order.
   - In Edit view, select a caption. On the Edit view toolbar (next to Slide Properties), click Bring Selected Objects Forward In Z-Order or Send Selected Objects Backward In Z-Order.
   - In Edit view, on the Timeline, move the mouse over a caption until the hand pointer appears. Drag the caption up or down to change its position in the stacking order. Moving a caption higher in the stacking order moves it to the front of the Stage. Moving a caption lower moves it to the back of the Stage.

Captions in other languages

Adding a language for text captions
You can add new languages to the list of existing languages in which text captions are recorded. The list of existing languages is available in the Recording dialog box. Text captions of events are stored as CaptureTextTemplates_<language>.rdl files in the \Program Files\Adobe\Adobe Captivate 4 directory. For example, the RDL file for Chinese-Simplified is CaptureTextTemplates_Chinese-Simplified.rdl. You can use the existing RDL files to record text captions in a desired language.
Record text captions in another language
1 Open Windows Explorer, and navigate to the \Program Files\Adobe\Adobe Captivate <version number> directory.
2 Copy a file with an RDL extension.
3 Paste the file in the same location, and rename it according to the new language. For example, if you want to record in Polish, rename the file CaptureTextTemplates_Polish.rdl.
4 Open the RDL file in any text editor.
5 In the Object Name and the Event Name tags, change the text for Default Template And Template Attributes to the specified language.
6 Save the file.
7 Select File > Record/Create > New Project to open the Recording dialog box.
8 Set the Recording preferences.
9 Click Advanced.
10 Select the added language in the Captions In pop-up menu.
11 Click Record.
The text captions are generated in the specified language.

Type text in another language
1 Open the Microsoft Windows Control Panel and double-click the Regional And Language Options icon. The Regional And Language Options dialog box appears.
2 Click the Languages tab.
3 Click the Details button.
4 In the Settings tab of the Text Services And Input Languages dialog box, click the Add button.
5 In the Add Input Language dialog box, select a language from the Input Language list.
6 Click OK. The selected language is included in the Installed Services list.
7 Select the desired language in the Default Input Language list.
8 Click Apply and click OK to save the settings and close the Text Services And Input Languages dialog box.
9 Click the Regional Options tab, and choose the language you selected in the Default Input Language list.
10 Click Apply and click OK to save the settings and close the Regional And Language Options dialog box. The Language bar or the Input Method Editor (IME) appears on the desktop of your computer.
11 Type content in the RDL file. The text appears in the selected language.

   If you change the language in the Default Input Language list and the Regional Options tab, the language selected in the Language bar is also updated automatically.

Localizing text captions
If you are localizing a project that contains text captions, you can export text captions to make the process more efficient.
1 Create the initial ("source language") version of the project, including all necessary text captions.
2 Open the completed project.
3 Select File > Export > Project Captions And Closed Captions.
4 By default, the Word (DOC) file is saved to your My Documents\My Adobe Captivate Projects folder. Change the location if you want. Also, the Word file is named [ProjectName] Captions.doc. You can change the name of the file, if necessary, by clicking directly in the File name text box and entering a new name. (Retain the.doc filename extension.) Click Save.

5 The Word file is generated with the name you specified and saved to the location you selected. A dialog box appears asking if you want to view the document. Click Yes to view the document in Word.

6 The Word document contains the slide ID, item ID, original caption text, and the slide number. You can change the caption text in the Updated Text Caption Data column. Provide a copy of the Word document to the localizer/translator.

7 The localizer/translator should open the Word document and edit the caption text directly in the Updated Text Caption Data column, replacing the source language text with the new text.

8 While the localizer/translator is translating the text, make a copy of the original Adobe Captivate project for the new language.

   Note: When you create a copy of the original project, be sure to keep the original text captions (in the source language) in the new project. The original text captions act as placeholders and are overwritten when you import the new (localized) text captions.

9 When the text captions are localized, open the copy of the project you created in step 8.

10 Select File > Import > Project Captions And Closed Captions.

11 Navigate to the localized text captions Word (DOC) file, select the file, and click Open.

12 The new, localized text captions are imported into the project, and all formatting is retained. A dialog box appears showing a successful import message. Click OK.

13 Test the new text captions by opening different slides in Edit view and reading the new caption text.

Creating custom text caption styles

You can create custom text caption styles for your Adobe Captivate projects with a graphics program, such as Adobe® Fireworks® or Adobe® Photoshop®.

Custom text captions must be in BMP (bitmap) format. In general, each Adobe Captivate text caption has five associated bitmap images.

Naming custom text caption styles

When creating custom text caption styles, be sure to follow the correct naming conventions. Each caption style has a unique name, and you must use this name at the beginning of each associated bitmap filename. For example, if you create a text caption style named “Brightblue,” the five bitmap images that constitute the new style should be named as follows:

- Brightblue1.bmp, an image with no callouts
- Brightblue2.bmp, an image with a callout to the right or upper-right
- Brightblue3.bmp, an image with a callout to the left or upper-left
- Brightblue4.bmp, an image with a callout to the lower right
- Brightblue5.bmp, an image with a callout to the lower left
Storing custom text caption styles
You must store all the bitmap images for a custom text caption style in the Adobe Captivate Captions folder (located in C:\Program Files\Adobe\Adobe Captivate 4\Gallery\Captions). After you add the five new bitmaps to the captions folder, Adobe Captivate recognizes the bitmap files as a new text caption style. The next time you add a new text caption, your new custom style appears in the text caption style list.

Create custom text for caption styles
You can create a custom style for the text that appears in the text captions. These preferences are applied only if you did not set a style for the text caption earlier.

1. Open the fonts.ini file, stored in the \Program Files\Adobe\Adobe Captivate 4\Gallery\Captions folder, in a text editor.
2. Customize the style for the text caption using the procedure described in the file.
3. Save the file.
4. In an open Adobe Captivate project, select Insert > Standard Objects > Text Caption.
5. In Caption Type, select the caption that you have customized.
6. Edit the text in the text area.
7. Click OK.

Change text alignment on custom text captions
Sometimes text in custom text captions can appear out of alignment. To solve this problem, set the left, right, top, and bottom margins.

Each of the five text caption styles requires different margin settings because text appears in slightly different places in each text caption.

The margin settings are stored in a text file with the extension.fcm. You can use Notepad or WordPad to create or edit FCM files.

1. Using Windows Explorer, navigate to C:\Program Files\Adobe\Adobe Captivate 4\Gallery\Captions. All the text caption BMP and corresponding FCM files are located in this folder.
2. Right-click the FCM file you want to edit, and select Open With.
3. Select Notepad or WordPad.
4. Edit the following values as necessary:
   - Left Margin is the number of pixels from the left side of the bitmap to the text.
   - Right Margin is the number of pixels from the right side of the bitmap to the text.
   - Top Margin is the number of pixels from the top of the bitmap to the text.
   - Bottom Margin is the number of pixels from the bottom of the bitmap to the text.
5. (Optional) If necessary, you can edit the MarginX and MarginY settings. This can be important if you are adding captions automatically.
   - MarginX is the number of pixels horizontally from the nearest corner to the tip of the caption callout.
   - Margin Y is the number of pixels vertically from the nearest corner to the tip of the caption callout.
Note: The nearest corner is identified in the file open in Notepad or WordPad under "Corner." For example, Corner=right, top.

6 From the File menu, select Save.
   A dialog box may appear, asking whether you want to replace the original file. Click Yes.

7 Close the program (Notepad or WordPad).

Design tips for custom text captions
Colors Don’t use the transparent colors for captions. The upper-left pixel determines which color is transparent. For example, if the color in the upper-left pixel is yellow, everything that is the same yellow will be transparent in the text caption. Also, the text caption itself can have a gradient background, but the area around (“behind”) the text caption, must be a solid color.

Anti-alias Do not anti-alias the edges of your text captions. Your text captions will appear on different screenshots, and the anti-alias can cause a jagged halo effect on some screenshots.

Import and export text captions

Import text captions
You can import text captions from a DOC file. First, you export the text captions from your Adobe Captivate project. Adobe Captivate creates a DOC file that preserves all the formatting from the text captions. While the text captions are in DOC format, you can make text and formatting changes in a word-processing program. Then you can import the text captions back into the Adobe Captivate project using the following steps.

Note: If you export text captions to a DOC file, that DOC file can only be imported back into the original project.

Importing and exporting text captions to and from a DOC file can be useful in several situations. For example, if you have to edit many captions, it is easier and faster to work in DOC files instead of navigating from slide to slide.

1 In an open project that contains text captions, select File > Export > Project Captions And Closed Captions.

2 Make the necessary changes while the text captions are in DOC format (in the Updated Text Caption Data column), and save the DOC file.

3 Select File > Import > Project Captions And Closed Captions.

4 Select the DOC file that contains the exported text captions.

5 Click Open.

6 An Information dialog box appears, confirming that the import was successful. Click OK.

Export text captions
You can export text captions from an existing Adobe Captivate project into a DOC file if you have Microsoft Word installed on your computer. All formatting done in Adobe Captivate is preserved when the text captions open as a DOC file. Make text and formatting changes to the text captions while they are in DOC format. Then import them back into the Adobe Captivate project.

Note: If you export text captions to a DOC file, that DOC file can only be imported back into the original project.

Exporting text captions can be useful in several situations:

• If you intend to record and voice-over narration and create a script, exported text captions can provide the foundation for the script.
• If you want to provide printed step-by-step instructions, you can export text captions and print the DOC file.
• If a project must be localized, you can export text captions into a DOC file and give it to a translator.

1 In an open project, select File > Export > Project Captions And Closed Captions.
2 In the Save As dialog box, enter a filename for the new DOC file.
   Note the default directory where the file will be saved. If you want, navigate to a different location in which to save
the file.
3 Click Save.
4 The text captions from the project are converted into DOC format. A dialog box appears, confirming that the text
captions were exported to Word and asking if you would like to view the document. Click Yes.
5 A new DOC file that contains the caption text opens in Word. Make any necessary text changes in the Updated Text
Caption Data column. The slide number is also included as a reference.
6 Save the document.

Restored default settings for text captions
If you changed the appearance of text captions, you can restore all text caption settings to their defaults. (For example,
you change the font for text captions to Times New Roman and the font color to green. Click Restore To Default to
change the font back to the default font Arial and the color to the default blue.)

1 In an open project, select Edit > Preferences.
2 In the Category panel, select Mode(s) under the Recording menu.
3 In the Recording menu, > Mode(s) area, click Restore Defaults.

Rollover captions
Use rollover captions when you want to display the caption only when the user moves the mouse over a designated
area on the slide. Rollover captions consist of a caption and a rectangle that marks the designated area, also called the
rollover area. The caption appears when the user moves the mouse over the rollover area at run time.

Add rollover captions
1 In Storyboard view in an open project, select the slide to which you want to add a rollover caption.
2 Select Insert > Standard Objects > Rollover Caption.
3 Set the various options for the caption in the Rollover Caption dialog box. See “Text caption properties” on page 63
for more information.
4 Click OK. The text caption and the rollover area appear on the slide.
5 Right-click the rollover area and select Properties. Set the properties for the rollover area.
6 To snap the rollover area to the edges of an object, press Alt and move the rollover area over that object.
7 Use the Settings menu to select how to apply property changes in the project. To apply all your changes, select Apply
Only Changed Properties. To apply all the rollover caption settings, select Apply All Properties. You can apply the
rollover caption settings to the current slide only or to all slides. And you can choose to apply the rollover caption
settings to all captions or only the rollover captions of the same type as the current one.
Note: If you change the settings in this dialog box, they become the default settings, and any new rollover captions you create use the new settings.

8 Select Apply To All to apply settings specified from the Settings menu to all slides.
9 Click OK.

Edit rollover area

Rollover captions and rollover images consist of a caption or image and a rollover area (the “hot” area). The rollover area defines where the mouse must be for the caption or image to appear.

1 Open an Adobe Captivate project.
2 In Storyboard view, select the slide containing the rollover caption or image.
   • To change the size of the rollover area, click one of the handles and drag.
   • To move the rollover area to another location, move the mouse over the rollover area until the hand cursor appears. Drag the box to the desired location.
   • To modify the rollover area attributes, right-click the rollover area, and select Properties. Make the required changes in the Properties dialog box.
   • You can customize the following for the rollover area in its Properties dialog box:
     Frame Color  Border color for the rollover area.
     Fill Color  Fill color for the rollover area.
     Frame Width  Thickness of the border of the rollover area.
     Fill Transparency  Degree of transparency for the fill color. A value of 10% is less transparent (more solid) than a value of 90%.
     Fill Outer Area  Select this option to fill the area outside the boundaries of the rollover area with the color selected in Fill Color. When you choose this option, the area within the rollover area is not colored.
     Note: You can observe the fill color around the rollover area only when you preview or publish the project.

The other tabs in the Properties dialog box are similar to those for text captions. See “Text captions” on page 62 for more information.

Preview  This area displays the settings you selected in the Appearance area.

Convert tooltips to rollover captions

When you record a new project or record additional slides for an existing project, you can set a recording option that requires Adobe Captivate to convert tooltips to rollover captions. When this option is selected, Adobe Captivate creates a rollover caption for every tooltip that is selected during the recording process.

Converting tooltips to rollover captions is an easy way to automatically create an appropriate and descriptive caption for action taking place in a project.

1 In an open project, select Edit > Preferences.
2 In the Preferences dialog box, select Mode(s) in the Recording menu.
3 Select Convert Tooltips To Rollover Captions.
4 Click OK.
5 Click Record to begin recording a new project and automatically converting tooltips to rollover captions.
See also
“Set audio for noninteractive objects” on page 96
“Edit rollover area” on page 73
“Fix size and position of noninteractive objects” on page 96

Highlight boxes

Use highlight boxes to spotlight areas within a slide. Highlight boxes focus the user’s attention on the required areas of the slide.

Properties of highlight boxes

Use the Properties dialog box of the highlight box to customize it.

The Properties dialog box for highlight boxes has the following tabs:

- Highlight Box
- Options
- Audio
- Size And Position

Highlight Box tab

Frame Color  Border color for the highlight box.
Fill Color  Fill color for the highlight box.
Frame Width  Thickness of the border of the highlight box.
Fill Transparency  Degree of transparency for the fill color. Select a value from 0% to 100%. A value of 10% is less transparent (more solid) than a value of 90%.
Fill Outer Area  Fills the area outside the boundaries of highlight box with the color selected in Fill Color. When you choose this option, the area within the highlight box is not colored.

Note: You can observe the fill color around the highlight box only when you preview or publish the project.

Preview  Displays the settings you selected in the Appearance area.

Options tab

Item Name  Enter a unique name for the object. You can use this name when defining the visibility conditions for the object.

- Visible  Deselect this option if you want the object to be invisible on the slide. The object can be made visible using the Show option. For more information, see “Controlling the visibility of objects” on page 52.

Display For [Time]  Specifies the duration for which the highlight box is displayed on the slide.

Appear After [#] Seconds  The highlight box appears on the slide after the specified duration.

Effect  Transition effect for the highlight box. You can apply a fade in or fade out effect and set the time for the fading effects.

- In [#] Seconds  Time for the highlight box to fully fade into view.

Updated 19 May 2009
• **Out [#] Seconds**  Time for the highlight box to completely disappear.

**Add highlight boxes**
1. Open the slide to which you want to add the highlight box in Edit mode.
2. Select Insert > Standard Objects > Highlight Box.
3. Set the various options for the highlight box.
4. Use the Settings menu to select how to apply property changes in the project. To apply all your changes, select Apply Only Changed Properties. To apply all the highlight box settings, select Apply All Properties. You can apply the highlight box settings to the current slide only or to all slides.
   
   **Note:** *If you change the settings in this dialog box, they become the default settings, and new highlight boxes that you create use the new settings.*
5. Select Apply To All to apply settings specified in the Settings menu to all slides.
6. Click OK.

   The highlight box appears on the slide.

**See also**
“Set audio for noninteractive objects” on page 96
“Fix size and position of noninteractive objects” on page 96

**Mouse**

**Change mouse properties**
You can change the properties of the mouse object using its Properties dialog box. The Properties dialog box has two tabs: Options and Timing.

**Options tab**

- **Available Mouse Pointers List**  Displays the available pointers. Click Browse to navigate to a custom file (CUR file format).
- **Double Mouse Size**  Doubles the size of the pointer.
- **Show Mouse Click**  Adds a visual click effect to the mouse movement.
- **Default**  Displays a quick, small burst of color when the user clicks the slide. You can select a color for the color burst.
- **Custom**  Select this option to use a SWF file as a visual click effect. Adobe Captivate includes two effects you can use. Test them by clicking the pop-up menu, selecting one, and then clicking Play. View the effect in the small preview window on the right.
- **Mouse Click Sound**  Select this option to play a sound when the pointer reaches its destination. Click the pop-up menu to select a sound (Single Click or Double Click). You can also select Browse and navigate to a sound file.
- **Straight Pointer Path**  Select this option to have the pointer follow a straight path between its start and end points. (By default, the pointer follows a curved path that gives the motion a more realistic look. You can change to a straight path if, for example, your project is a demonstration showing how to draw a line in a graphics program.)
Reduce Speed Before Click  Select this option to slow the mouse movement down before the click occurs. This option is useful for a long mouse path that moves quickly and stops suddenly.

See also
“Set audio for noninteractive objects” on page 96
“Fix size and position of noninteractive objects” on page 96

Timing tab
Display Time  The time during which the pointer is displayed on the slide.
Appear After  Delay between the first appearance of the slide and the first appearance of the slide pointer.

Pointers

Change the pointer shape
You can change the pointer for a particular slide or project. Select any system pointer or existing CUR file as the pointer image. Open an Adobe Captivate project in Storyboard view or Edit view. From the Slide menu, select Mouse > Use Current Mouse Pointer For All Slides.

Note: Some pointers from other applications may be displayed incorrectly in Adobe Captivate.

1  In an open project, open the slide you want in Edit view.
2  Select Slide > Mouse > Project Pointers or Slide > Mouse > Current Theme Pointers.
3  From the menu, select a new pointer shape.
   Note: The choices on the Current Theme Pointers pop-up menu reflect the Windows theme you are currently using. If you change the Windows theme, the choices on this menu change. Because the pointer files are included in the Adobe Captivate project, users do not need to have the selected Windows theme installed.

Select a custom pointer
1  In an open project, open the slide you want in Edit view.
2  Do one of the following:
   •  Select Slide > Mouse > Project Pointers > Browse.
   •  Select Insert > Mouse, and click Browse in the Mouse Properties dialog box.
3  Select a custom pointer from the list.
4  Click Open.

Change pointer size
You can double the size of the pointer. Large pointers emphasize mouse movement and are also helpful if you are creating accessible projects.

Pointer size is set on a slide-by-slide basis, so you choose exactly the slides that require the larger pointer.

1  In an open project, open the slide containing the pointer in Edit view.
2  Select Slide > Mouse > Properties.
3  In the Mouse Properties dialog box, select the Options tab. The following option is also available on the Options tab:
   Double Mouse Size  Doubles the size of the pointer.
4 Click OK.

The new double-sized mouse is displayed on the slide.

*Note:* To change the pointer size for a mouse that has already been added, double-click it on the slide to open the Mouse Properties dialog box.

*Note:* To restore the original pointer size, follow the steps above and clear Double Mouse Size.

**Hide the pointer in an individual slide**

1 In an open project, open a slide in Edit view.

2 Do one of the following:
   - Select Slide > Mouse > Show Mouse.
   - Right-click and select Show Mouse.

**Hide the pointer for the entire project**

1 In an open project, select Edit > Preferences.

2 In the Category panel, expand Project, and select Publish Settings.

3 In the Publish Settings panel, clear the option Include Mouse.

**Change mouse movements**

You can change mouse movements for an individual slide. For example, you may want to emphasize mouse movement in a screenshot so that it is more obvious to the viewer.

1 In an open project, open a slide in Edit view.

2 Using the mouse, move the pointer over the end of the mouse line on the slide until the pointer turns into a hand.

3 Click the left mouse button and drag the pointer to a new location on the slide.

If you change the pointer on a slide, the starting pointer location changes on the next slide. Preview your project to ensure that mouse movement flows smoothly from slide to slide.

You can’t align mouse movement to a previous slide. Make sure that you manually change the starting point of the mouse on the first project slide containing mouse movements.

**Mouse paths**

**Align mouse paths**

You may need the pointer to be completely still during the playback of a slide and have it align properly with the previous or next slide. In this case, it is difficult to manually position the pointer correctly. Adobe Captivate can solve the problem by automatically aligning the pointer to the same position as the previous or next slide in the project.

1 In an open project, open a slide in Edit view.

2 Right-click and select Align To Previous Slide or Align To Next Slide.

3 Preview your project to see how the pointer is aligned between slides.

*Note:* If you have mouse movement on the first slide of your project, you can manually change the start point of the mouse movement (because you cannot align to a previous slide).
Change shape of mouse paths

By default, Adobe Captivate creates curved mouse paths on slides for a realistic, natural feel. However, a straight mouse path is sometimes preferable, for example, showing movement across a toolbar.

You can set the curved or straight mouse movement option for an individual slide.

1 In an open project, open the slide you want in Edit view.
2 Select Slide > Mouse > Straight Pointer Path.

This option acts like a toggle. Select it again to restore curved paths.

Note: To change the pointer size of a mouse that has already been added, double-click it on the slide to open the Mouse Properties dialog box.

Set mouse click effect

You can set a mouse click color or effect. Use this option to add a quick burst of color or special effect around the pointer to emphasize mouse clicks during project playback.

1 In an open project, select a slide containing mouse movement.
2 Select Slide > Mouse > Properties.
3 Select Show Mouse Pointer.
4 In the Options tab, select Show Mouse Click.
5 Do one of the following:
   • Select Default Click. Click the color box to open the Color dialog box. Select a color and click OK.
   • Select Custom. Select an option from the pop-up menu. Several options are provided: BlueCircle, GreenRing, OrangeCircle, OrangeRing, VisualClick, and VisualdblClick. To preview these options, select one and click Play. The SWF file plays in the small Preview window on the right. You can also select Browse in the pop-up menu and navigate to a SWF file.
6 Click OK.

To view the mouse click color, preview the project.

To change the mouse click effect for a mouse that has already been added, double-click it on the slide to open the Mouse Properties dialog box.

Change mouse click sounds on an individual slide

You can change the default mouse click sound that plays whenever the mouse reaches the end of its movement path. For example, you can change from single clicks to double clicks to reflect the correct action in a workflow. You can also suppress all click sounds.

1 In an open project, open the slide you want in Edit view.
2 Select Slide > Mouse > Properties.
3 Select Show Mouse Pointer.
4 In the Options tab, select an option in the Mouse Click Sound menu:
   • If you do not want a mouse click sound to play, remove the check mark from the box next to Mouse Click Sound.
   • For a single-click sound (the sound of a mouse button being pressed once), select the box next to Mouse Click Sound. When a green check mark appears, click the arrow and select Single Click.
For a double-click sound (the sound of a mouse button being pressed twice), select the box next to Mouse Click Sound. When a green check mark appears, click the arrow and select Double Click.

To browse to an alternative sound for a mouse click, select the box next to Mouse Click Sound. When a green check mark appears, click the arrow and select Browse. The Open dialog box appears, letting you browse to an mp3 file.

To preview the selected mouse click sound, click the Play button.

When you finish, click OK.

Enable the mouse wheel

When recording, you can choose to enable mouse wheel movement to initiate full motion recording. The project starts recording in FMR mode when there is mouse wheel movement during recording.

1. In an open project, Select Edit > Preferences.
2. In the Category panel of Preferences, expand Recording, and select Settings.
3. Select Automatically Use Full Motion Recording For Mouse Wheel Actions and click OK.

Rollover slidelets

In Adobe Captivate, a rollover slidelet is a space on a slide that displays an associated slidelet (a slide within a slide) when the mouse is moved over the space. You can insert and display objects in the slidelet using the same procedure as that for the slides.

For example, you can create a rollover slidelet for a state on a map so that the demographics of the state are displayed when the mouse moves over it.

Note: You cannot create rollover slidelets on question slides or quiz review slides.

The following is further information about slidelets:

- A slidelet is always linked to a rollover slidelet and is created along with the rollover slidelet.
- You can insert most of the Adobe Captivate objects into a slidelet.
- You can place more than one type of object into a slidelet. The objects become visible when the mouse is moved over the rollover slidelet.
- You can drag audio and movie files from the Library into a slidelet.
- If a slidelet times out while an audio or movie file from the slide is running, the file stops running.
- When a slidelet or any of its objects is selected, the displayed Timeline and the corresponding menu options for the slide change to that for the slidelet.
- Objects within a slidelet can be hidden or locked, but not the slidelet itself. To hide or lock a slidelet, hide or lock the corresponding rollover slidelet from the slide Timeline.
- Slidelet objects cannot be dragged outside of the slidelet boundaries.
- When a slidelet is deleted, its associated objects are also deleted, and the Timeline reverts to the slide Timeline.
- Clicking an area outside the slidelet, or on the Filmstrip, reverts the Timeline to that for the corresponding slide.
Properties of slidelets
You can set the following properties using the Properties dialog box of a slidelet.

Rollover Slidelet tab
Border Color  Border color for the slidelet.
Border Width  The thickness of the slidelet border.
Fill Color  Fill color of the slidelet.
Fill Transparency  The transparency of the fill color. The greater the value, the higher the transparency of the color.
Select Image  Background image of the slidelet.
Clear  Remove any previously selected image.
Preview  A preview of the slidelet is displayed in this area every time you change an option.

Options tab
Item Name  Enter a unique name for the object. You can use this name when defining the visibility conditions for the object.
Visible  Deselect this option if you want the object to be invisible on the slide. The object can be made visible using the Show option. For more information, see “Controlling the visibility of objects” on page 52
Display For  The duration for which the slidelet is displayed on the slide.

The following options are in the Transition area:
Effect  The transition effect for the slidelet when it appears and exits the slide.
In and Out boxes  The time (in seconds) for the fading effects.

The following option is in the Effects area:
Show Runtime Shadow  Select this option to display a shadow below the slidelet during run time. The shadow gives a three-dimensional feel to the slidelet.

Advanced tab
You can define the action that takes place when the user moves the mouse over the rollover slidelet. For more information, see “Defining project navigation” on page 97.

See also
“Set audio for noninteractive objects” on page 96
“Fix size and position of noninteractive objects” on page 96

Properties of rollover slidelets
You can set the following properties using the Properties dialog box of a rollover slidelet.

Rollover Slidelet tab
Border Color  Border color for the rollover slidelet.
Show Border  Displays the border of the rollover slidelet. The border is not displayed if you disable this option.
Fill Color  Fill color for the rollover slidelet.
Fill Transparency  The transparency of the fill color. The greater the value, the higher the transparency of the color.

Stick Slidelet  The slidelet continues to be displayed even when you move the mouse away from the rollover slidelet area.

Navigate  Define the action to take when the user clicks the rollover slidelet by selecting one of the options in the On Click menu.

Select Keys  You can specify a keyboard shortcut for the mouse-click. Users can use the keyboard shortcut instead of using the mouse. For example, if you select Control+Shift+Enter as the keyboard shortcut for the mouse-click, the click is treated as correct (click within the box) when the users press this combination. If they press the wrong combination, it is treated as a click outside the box.

Note: If your Adobe Captivate project is displayed in a browser, set keyboard shortcuts that do not conflict with common browser shortcuts. For example, F1 is frequently used as a keyboard shortcut to display Help. The Control, Alt, and Shift keys map to the Control, Option, and Shift keys on Macintosh® computers, respectively.

Options tab
Item Name  Enter a unique name for the object. You can use this name when defining the visibility conditions for the object.

- Visible  Deselect this option if you want the object to be invisible on the slide. The object can be made visible using the Show option. For more information, see “Controlling the visibility of objects” on page 52.

Display For  The duration for which the rollover slidelet is displayed.

Appear After  Delay between the first appearance of the slide and the first appearance of the rollover slidelet.

Hover Delay  The time delay before the appearance of the slidelet when the mouse moves over the rollover slidelet.

Effect  The transition effect for the slidelet when it appears and exits the slide.

In and Out boxes  The time (in seconds) for the fading effects.

The following option is in the Effects area:

Show Runtime Border  When the mouse moves over the rollover slidelet, a border is displayed with the specified color.

Create a rollover slidelet
1  In an open project, double-click a slide to open it in Edit view.
2  Select Insert > Standard Objects > Rollover Slidelet. The New Slidelet dialog box appears.
3  Set the options for the rollover slidelet as required.
4  (Optional) To apply properties to all slidelets in the project, select Apply To All.
5  Click Settings to select whether to apply all the properties or only the changed properties to the respective slidelet or to all the slidelets.
6  Click Apply.
7  Click OK.

The rollover slidelet along with the associated slidelet appears on the slide.

To change the properties of a slidelet, right-click it and select Properties from the pop-up menu.

Note: Whenever a new rollover slidelet is inserted, the default timing is Rest Of Slide.
Insert objects within a slidelet
1. Select the slidelet by clicking it.
2. Select Insert and choose the object that you want to insert.
3. In the corresponding dialog box that opens, follow the procedure to insert the object.
4. Click OK.

*Note: You cannot insert a rollover slidelet, mouse, text entry box, click box, or button within a slidelet.*

Change properties of a rollover slidelet
You can change the properties of a rollover slidelet using the various options provided by Adobe Captivate.
1. Right-click the rollover slidelet, and select Properties.
2. Set the options for the rollover slidelet as required.
3. (Optional) To apply properties to all rollover slidelets in the project, select Apply To All.
4. Click Settings to select whether to apply all the properties or only the changed properties to the respective rollover slidelet or to all the slidelets.

*To select all objects in a slidelet, right-click an object within a slidelet, and choose Select All from the pop-up menu.*

Zoom areas
Zoom areas help you draw the learner’s attention to important sections of a slide. For example, if you create a simulation that includes a step that might be easily overlooked, you can add a zoom area to highlight the step. After you add a zoom area, you can add timing, transition, and audio options to the zoom effect. Zoom areas consist of the following:

- **Zoom area** The area of the slide that you want to magnify.
- **Zoom destination area** The area in which the magnified portion of the slide is displayed.

Properties of zoom destination areas
You can set the properties for a zoom destination area using its Properties dialog box. These are the options in the Zoom Destination Area tab:

**Zoom Destination Area tab**
- **Frame Color** Border color of the Zoom Destination Area box.
- **Fill Color** Color of the area within the Zoom Destination Area box.
- **Frame Width** Thickness of the border of the Zoom Destination Area box.
- **Fill Transparency** Transparency of the fill color. The higher the number, the more transparent the box.
- **Select Image** Image for the zoom destination area.

Use the Preview area to view the effects of the changes you make.
Note: You can also change the size and position of the zoom area or zoom destination area directly on the slide. Select the box you want to change. When the hand cursor is visible, you can adjust the position of the box. When the double-headed arrow cursor is visible, you can adjust the size.

Properties of zoom areas
You can set the properties for a zoom area using its Properties dialog box.

Zoom Area tab
Frame Color  Border color of the Zoom Area box.
Fill Color  Color of the area within the Zoom Area box.
Frame Width  Thickness of the border of the Zoom Area box.
Fill Transparency  Transparency of the fill color. The higher the number, the more transparent the box.
Fill Outer Area  Select this option to fill the area outside the boundaries of the Zoom Area box with the color selected in Fill Color. When you choose this option, the area within the Zoom Area box is not colored.

Use the Preview area to view the effects of the changes you make.

Note: You can observe the fill color around the zoom area only when you preview or publish the project.

Options tab
Item Name  Enter a unique name for the object. You can use this name when defining the visibility conditions for the object.

• Visible  Deselect this option if you want the object to be invisible on the slide. The object can be made visible using the Show option. For more information, see “Controlling the visibility of objects” on page 52

Display For [Time]  Specifies the duration for which the zoom area is displayed.

Appear After [#] Seconds  Delay between the first appearance of the slide and the first appearance of the zoom area.

Zoom For  The duration of the zoom, in tenths of a second.

Effect  The transition effect for the slidelet when it appears and exits the slide.

In and Out boxes  The time (in seconds) for the fading effects.

See also
“Set audio for noninteractive objects” on page 96
“Fix size and position of noninteractive objects” on page 96

Add zoom areas
1  In an open project, select the slide to which you want to add a zoom area.
2  Select Insert > Standard Objects > Zoom Area.
3  Set the options for the zoom area as required. Click OK after you are done. The Zoom Area box along with the corresponding zoom destination area is placed on the slide.
4  Double-click the zoom destination area and set its properties using the Zoom Destination Area dialog box that appears.
5  Select Apply To All to apply settings specified in the Settings menu to all slides.

Updated 19 May 2009
6 Use the Settings menu to select how to apply property changes in the project. To apply all your changes, select Apply All Changed Properties. To apply all the Zoom Destination Area settings, select Apply All Properties. You can apply the Zoom Destination Area settings to the current slide only or to all slides.

Note: If you change the settings in this dialog box, they become the default settings, and any subsequent slides that you create use the new settings.

7 Click Apply to view your changes without closing the dialog box.

8 Click OK to accept changes and close the dialog box.

Note: The Zoom Destination Area dialog box always appears on the top layer no matter where it is placed on the Timeline of a slide.

Images and rollover images

You can incorporate images into projects as logos, startup screens, pointers, backgrounds, buttons, and more. You can add images in the following formats: JPG, JPEG, GIF, PNG, BMP, ICO, EMF, POT, or WMF.

Rollover images consist of an image and a rollover area (the “hot” area). Rollover images appear when the end user moves the pointer over the rollover area at run time. They are useful for heavily detailed slides or for slides that contain buttons or toolbars that require explanation.

You can use the same type of graphics for rollover images that you use for traditional images. You can also customize the location, outline, and size of the rollover area for rollover images.

Adobe Captivate contains a gallery of buttons, sounds, and animations (in SWF format) for you to use in your projects. By default, the gallery is stored in the following location when you install Adobe Captivate: C:\Program Files\Adobe\Adobe Captivate 4\Gallery.

Properties of images and rollover images

You can change the properties of an image using the Image Edit panel (Window > Image Edit). The options in the Image Edit panel are enabled only when you select an image on the slide.

Brightness  The brightness of the image. When you increase the value for brightness, the selected image appears brighter.

Sharpness  Sharpening enhances the definition of edges in an image. Whether your images come from a digital camera or a scanner, most images can benefit from sharpening. The degree of sharpening needed varies according to the quality of the digital camera or scanner. Keep in mind that sharpening cannot correct a severely blurred image.

Contrast  The contrast between the light and dark areas of an image. When you increase the contrast of an image, the brighter areas appear brighter, and the darker areas appear darker.

Transparency  The transparency of the image. At 0% transparency, the image is opaque. At 100% transparency, the image is invisible.

Hue  You can change the colors of an image by changing the values for its hue.

Saturation  The intensity of colors in the image. When you increase the saturation value, you increase the intensity of the colors.

Mosaic  The mosaic effect uses squares in a pattern to create a picture. You can split up an image into such separate squares to achieve the mosaic effect in Adobe Captivate. You can achieve the required mosaic effect by changing the mosaic value.
Gray Scale  In a basic sense, you can convert a colored image to monochrome using this effect. Grayscale mode uses different shades of gray in an image. In 8-bit images, there can be up to 256 shades of gray. Every pixel of a grayscale image has a brightness value ranging from 0 (black) to 255 (white). In 16-bit and 32-bit images, the number of shades in an image is much greater than in 8-bit images.

Invert Colors  Inverts the colors in an image. When you invert an image, the brightness value of each pixel in the channels is converted to the inverse value on the 256-step color-values scale. For example, a pixel in a positive image with a value of 255 is changed to 0, and a pixel with a value of 5, to 250.

Flip  Flipping an image produces its mirror image. You can flip an image vertically or horizontally.

Rotate  Rotate an image either clockwise or counterclockwise 90 at a time.

Crop  Use the handles of the rectangular box to select the area of the image that you want displayed.

The following options are available in the Image tab of the Image dialog box that appears when you click the Properties button:

Transparent Background  All occurrences of one particular color in an image can be made transparent. For example, you can make all occurrences of red (#FF0000) transparent.

Reset To Original Size  Restores the image to its original size.

Preview  Displays the image. If you edit the image, such as by changing the transparency, the preview reflects your changes immediately.

Select Image From Library  Select this option to reuse an image in your project file. Select the image and click OK.

Import  Import an image stored on your computer or on a network location.

Crop  Use the handles of the rectangular box to select the area of the image that you want displayed.

The Options tab has the following options:

Item Name  Enter a unique name for the object. You can use this name when defining the visibility conditions for the object.

Visible  Deselect this option if you want the object to be invisible on the slide. Use the Show option to make the object visible. For more information, see “Controlling the visibility of objects” on page 52.

Display For [Time]  Specifies how long the image is displayed on the slide.

Appear After [#] Seconds  Delay between the first appearance of the slide and the first appearance of the image.

Effect  Transition effect for the image. You can have the image fade in and fade out of the slide during its entry and exit.

In [#] Seconds  Specifies the amount of time for the image to fully fade into view.

Out [#] Seconds  Specifies the amount of time for the image to completely disappear from view.

See also
“Set audio for noninteractive objects” on page 96
“Fix size and position of noninteractive objects” on page 96

Add an image or rollover image
1  In Storyboard view in an open project, double-click the slide to which you want to add an image.
2  Select Insert > Image, or Insert > Standard Objects > Rollover Image.
3  Select an image from the list or browse to a new location for a different image. Click Open.
4 When the height or width of the image is bigger than that of the project, the Resize/Crop Image dialog box appears. If you are inserting more than one slide, only those images whose dimensions are bigger than that of the project are displayed in the dialog box.

Set the following options.

**Fit To Stage** Resizes the image to fit the dimensions of the slide.

**Crop** Displays a bounding box with dimensions corresponding to that of the project. Resize the handles of the box to select the area that you want displayed on the slide. If you have selected Constrain Proportions, the height-to-width ratio of the bounding box is maintained.

**Zoom** You can zoom in and zoom out of the image by moving the slider. Alternatively, you can choose from a list of standard zoom sizes from the menu.

**Constrain proportions** Maintains the height-to-width ratio of the bounding box used to crop the image. This option is enabled only when you choose to crop the image. When you disable this option, resize the bounding box, and enable the option again; the new dimensions are used thereafter to calculate the ratio.

5 Set properties and options as required.

6 To snap the rollover area to the edges of an object, press Alt and move the rollover area over that object.

7 Click Apply To All to apply the latest settings specified to all slides.

8 Click OK.

The image is added to the slide. If you added a rollover image, the rollover area is also added. Drag the image to the desired location and adjust the rollover area as needed.

💡 You can create a watermark image using a transparency trick. Insert an image and set the transparency to 50%. This setting works well with many company logos.

### Import a PSD file

You can import a Photoshop (PSD) file into your Adobe Captivate project, while preserving Photoshop features. You can select and import separate layers of the PSD file, or you can flatten selected layers and import them as a single image. Each imported layer is treated as a separate image within the Adobe Captivate project. In the library, each imported layer is stored in PNG format as a separate object in the Images folder.

You can resize the imported images to the size of your Adobe Captivate project. You can also apply all other available image-editing properties of Adobe Captivate.

When importing a PSD file, you can select and import layer comps. A layer comp is a Photoshop feature that allows you to create, manage, and view multiple versions of a layout in a single Photoshop file. See Photoshop Help for more information on this feature.

1 In an open project, select File > Import > Photoshop File.

2 In the Importing dialog box, do one of the following:
   - To select separate layers of the PSD file, select the As Layers option and select each layer that you want to import. To merge the selected layers before importing, select Merge Layers.
     
     **Note:** Importing each layer separately increases the size of your image file. To reduce the size of the image, you can merge the layers. When you merge layers, the data on the top layers replaces any data it overlaps on the lower layers.
   - To flatten the layers and then import them as a single image, select As Flattened Image.
When you flatten layers, you cannot edit each layer separately within Adobe Captivate. Use this option only if you are sure that layer editing is not required and the image is ready to use.

- To import any inherent layer comps, click the Select menu and choose the layer comp that you want to import.

Select Scale According To Stage Size to automatically resize the image to the size of your Adobe Captivate project.

Create watermark images

You can create a watermark image by setting the transparency of an image.

1. In an open project, select Insert > Image.
2. Select an image or browse to a new location for a different image. Click Open. The New Image dialog box appears.
3. Set the image transparency to 50% or higher in the Transparency text box. (A high number results in a dim version of the image and a lower number displays a brighter image.)
4. Position the image on the slide as required.

Change JPEG quality

Adobe Captivate automatically sets the quality of JPEG images in projects. However, you can adjust this setting depending upon the images used in your project. Using higher percentage values allows high-quality images but also increases file size.

1. In an open project, select Edit > Preferences.
2. In the Category panel, select SWF Size And Quality from the Project menu.
3. Enter your preferred value in the JPEG Image Quality text box.

Drawing tools

You can use the drawing tools in Adobe Captivate to create artwork for your projects. Drawing tools help you create basic shapes within Adobe Captivate so that you don’t have to create and import them from other applications. Drawing objects are converted to Flash drawing objects when they are imported into Flash.

Note: You can search for drawing objects, and text within them, using the Find dialog box.

If the drawing toolbar is not visible, select Window > Toolbars > Drawing.

The following drawing tools are available in Adobe Captivate:

**Selection Tool** – To select, move, and resize objects. It is used to toggle the different drawing modes. You can exit the drawing mode at any time using the selection tool. The selection tool is enabled by default in the drawing mode when you are not working with the other drawing tools.

**Draw Line** – To draw straight lines.

**Draw Free-Form Polygon** – To create free-form polygons.

**Draw Rectangle** – To draw rectangles and squares.

**Draw Oval** – To draw oval shaped objects and circles.

**Set Stroke Color** – To change the stroke color of an object.

**Set Fill Color** – To change the fill color of an object.
Set Stroke/Fill To Black/White

To change the stroke color of an object to black and its fill color to white.

Swap Fill/Stroke Colors

To interchange the color of the stroke and fill for the selected object.

**Drawing objects**

To draw an object once, click the corresponding icon in the toolbar and drag the pointer on the Stage to create the object. Adobe Captivate resets to the Select tool after an object is created on Stage. To draw the same type of object many times over (multiple drawing mode), click the corresponding icon on the drawing toolbar while pressing the Control key.

**Free-form polygons**

For free-form polygons, define the sides by clicking where you want the node to appear. To complete drawing the polygon, double-click the final node to automatically join it to the starting node. To redraw a free-form polygon, select it, and click Redraw Shape in the slide toolbar.

**Squares and circles**

To draw a square or circle, click the rectangle or oval icon, press Shift, and draw the object. If you want to create a rectangle or square with rounded corners, double-click the rectangular object, and increase the value of the corner radius.

**Horizontal, vertical, and diagonal lines**

You can rotate lines by 45 using the selection tool. Hold the end of the line, press Shift, and move the mouse at different angles. This way, you can draw horizontal, vertical, and diagonal lines.

**Note:** An object is not visible on a slide with a white background if both the stroke and fill of objects are set to white.

To exit the drawing or multiple drawing mode, do one of the following:

- Click the selection icon.
- Press Escape.
- Click the Stage.
- Right-click outside the Stage.

**Change the stroke and fill properties of drawing objects**

Double-click the object, and set the fill and stroke properties for the object in the dialog box that appears. You can change the fill/stroke properties of legacy objects like highlight boxes and rollover objects using the fill/stroke options in the drawing toolbar.

You can set the following stroke properties for straight lines:

- Transparency of the line
- Style of the stroke, such as dashes or dots
- Color of the stroke
- Thickness (width) of the stroke
- Arrowheads, circles, diamonds, or squares at the ends of a line

You can set the following stroke and fill properties for the other drawing objects:

- Fill color
- Transparency of the fill color
- Style of the stroke, such as dashes or dots
- Color of the stroke
- Width of the stroke

Updated 19 May 2009
• Corners of the object: You can smooth the corners of a rectangle or square to varying degrees by changing the values for its corner radius.

To change the stroke color of object to black, and its fill color to white, click Set Stroke/Fill To Black/White in the Drawing toolbar.

To interchange the color options set for the stroke and fill for the object, click Swap Fill/Stroke Colors.

**Resize drawing objects**

• To manually resize objects, use the selection tool. Adobe Captivate does not have a separate transformation tool. You can resize any object after selecting it. Move the cursor over the corners of objects, and when the relevant cursor appears, resize the object to the required dimensions.

• To resize an object to specific dimensions, select the object, and change the dimensions in the Stage toolbar.

**Resize rollover area to the bounding box of drawing objects**

❖ Right-click the rollover area, and select Auto Adjust Rollover Area.

When you now move the rollover area over an object, it assumes the shape of the bounding box of that object.

**Edit free-form polygons**

When you edit the free-form polygon, the sides of the polygon are displayed along with the connecting nodes. You can alter the shape of the polygon by dragging the nodes. The clarity provided by this skeletal structure is especially useful when editing complex polygons.

1 Select the free-form polygon.

2 Click Edit Points in the Stage toolbar. The skeletal structure of the polygon is displayed.

3 Drag the required nodes.

4 To restore the fill and stroke, click outside the polygon.

You can redraw a selected polygon by doing one of the following:

• Click Redraw Shape in the drawing toolbar.

• Right-click the object, and select Redraw Shape.

• Press Control+Alt+W.

**Duplicate drawing objects**

Select the object that you want to duplicate, and do one of the following:

• Click the Duplicate Selected Objects icon in the standard toolbar.

• Press Control+D.

**Place text inside drawing objects**

1 Select the object, and click Add Text in the Stage toolbar.

2 Add text in the text area that appears within the object, and use the text edit toolbar to format the text.

To edit text within objects, click the Add Text icon. The text in the text area within the object is made available for editing. The text option is not available when you have selected the line tool.
Snap lines to objects

When drawing straight lines, you can make them snap to the contours of other Adobe Captivate objects, including free-form objects. Use this option when you want to precisely connect the end of a straight line to the periphery of an object.

To snap lines to objects, do the following:

1. Draw the object (rectangle, oval, free-form polygon, and so on).
2. Click the Snap To Object icon.

When you now draw a straight line, the line snaps to the contours of objects with which it comes in contact.

Animations

Adobe Captivate lets you add animation to Adobe Captivate SWF files. This introduces an element of motion that is effective and eye-catching for users. Add existing animation files to a slide or use the animated text feature in Adobe Captivate.

- You can add SWF, AVI, FLA, or GIF animation files directly to a slide. Slides containing an animation file can be edited just like other slides containing an object.

  Adobe Captivate contains a gallery that has buttons, sounds, and animations (in SWF format) for you to use in your projects. By default, the gallery is stored in the following location when you install Adobe Captivate: C:\Program Files\Adobe\Adobe Captivate 4\Gallery.

  **Note:** If you want to add a Flash animation file (FLA), you must first convert it to a SWF file. To do this conversion you must have the latest Flash version installed on your computer.

- To add animated text, select from a number of interesting effects included with Adobe Captivate. Experiment with different fonts, colors, and effects to achieve the right look. Slides containing animated text, with their combination of text, movement, and sound (if you choose to add audio) make great opening slides for projects.

  **Note:** Device fonts are not displayed in Adobe Captivate. If you import an animation file containing text created with device fonts, the animation appears in Adobe Captivate, but the text does not. For animations that will be imported into Adobe Captivate, try to use embedded fonts for text.

Properties of animation objects

You can change the properties of animation objects using their Properties dialog box.

Animation tab

- **Statistics** Lists key information about the animation file you selected including version, width, height, and the number of frames that compose the file. The total duration of the animation file is also shown.

- **Transparency** The transparency of the animation file. A low transparency value results in a bright version of the animation file and a higher value in a dimmer animation.

- **Library** Animations stored in your project file. When you add an animation file to your project, it automatically gets added to the library.

- **Import** Import an animation file from your computer or network.
**Options tab**

**Item Name**  Enter a unique name for the object. You can use this name when defining the visibility conditions for the object.

- **Visible**  Deselect this option if you want the object to be invisible on the slide. The object can be made visible using the Show option. For more information, see “Controlling the visibility of objects” on page 52.

**Display For [Time]**  The time the animation plays in the project.

- **Rest Of Slide**  The animation plays until the slide stops playing. The animation plays once, unless the Loop option is selected.
- **Rest Of Project**  The animation plays for the length of the project, even on other slides. The animation plays once, unless the Loop option is selected.
- **Duration Of Animation**  The animation plays for its entire length once.
- **Specific Time**  The animation plays for the specified time.

**Appear After [#] Seconds**  Delay between the first appearance of the slide and the first appearance of the animation.

**Synchronize With Project**  Synchronizes the speed at which the animation file plays with the Timeline speed. If you find that the animation file is not playing smoothly, test with this option selected and cleared to see which setting gives you better results.

**Place Object On Top**  The video file starting from the time it appears on the top of all other objects until the project stops playing.

**Loop**  Select this option to have the animation file loop (replay continuously).

**Effect**  Specify a transition effect for the animation. You can make an animation fade in during its entry, and fade out during its exit.

**In [#] Seconds**  Specifies the amount of time for the animation to fully fade into view.

**Out [#] Seconds**  Specifies the amount of time for the animation to completely disappear from view.

**See also**

“Set audio for noninteractive objects” on page 96

“Fix size and position of noninteractive objects” on page 96

**Add animations**

1. In an open project, select Insert > Animation.
2. Navigate to the animation file you want to add to the slide, select it, and click Open.
3. Set properties and options as required.
4. Use the Settings menu to select how to apply property changes in the project. To apply all your changes, select Apply Only Changed Properties. To apply all the new animation settings, select Apply All Properties. You can apply the new animation settings to the current slide only or to all slides.
   
   **Note:** If you change the settings in this dialog box, they become the default settings, and any new animations you create use the new settings.

5. Select Apply To All to apply settings specified in the Settings menu to all slides.
6. When you finish, click OK.

The animation is added to the slide.
Note: Device fonts are not displayed in Adobe Captivate. If you import an animation file containing text created with device fonts, the animation appears in Adobe Captivate, but the text will not. For animations that will be imported into Adobe Captivate, try to use embedded fonts for text.

Animated text

Animated text is text that has applied special effects. Adobe Captivate offers a wide variety of text animation effects that you can experiment with. For example, on the opening slide of a project you can have text fly in or fade in for an eye-catching start.

Slides containing animated text are displayed in Adobe Captivate Storyboard view, Edit view, and in the Filmstrip (an option in Edit view) just like other slides.

Properties of animated text

Use the Properties dialog box of the animated text to set its properties.

Text Animation tab

Set font, transparency, and delay options:

Effect The animation effect that is applied to the text.

Text The text to which the animation is applied.

Change Font Specifies font options such as font name, style, size, effects, and colors.

Transparency Specifies a transparency level for the animated text. For a very dim animated text effect, select a high number such as 90. For darker text, select a low number such as 10.

Delay (Frames) The time elapsed, in Flash frames, between the display of one animated letter and the next. If you set a low number (for example, 0 or 1), all the letters appear quickly, one after the other. If you set a higher number (for example, 30 or 40), each letter appears more distinctly. Try different numbers and watch the text in the Preview window to select an appropriate number.

Note: The number you specify in Delay does not change the absolute amount of time the animated text feature appears. For example, suppose you specify, in the Options tab) a total animation time of 8 seconds. The value of the Delay option, whether it is 1 or 30, does not change the absolute time of 8 seconds.

Options tab

Item Name Enter a unique name for the object. You can use this name when defining the visibility conditions for the object.

- Visible Deselect this option if you want the object to be invisible on the slide. The object can be made visible using the Show option. For more information, see “Controlling the visibility of objects” on page 52.

Display For [Time] Specifies the timing of the animated text. Click the pop-up menu and select an option. If you select the specific time option, you can enter the exact number of seconds for the animated text to appear.

Appear After [#] Seconds Displays the animated text after the slide has been displayed for the selected number of seconds.

Loop Select this option to have the animation file continuously loop (play over and over again) as the project plays.

Effect Specify a transition effect for the animation. You can make an animation fade in during its entry, and fade out during its exit.

In [#] Seconds Specifies the amount of time for the animation to fully fade into view.
Out [#] Seconds  Specifies the amount of time for the animation to completely disappear from view.

See also
“Set audio for noninteractive objects” on page 96
“Fix size and position of noninteractive objects” on page 96

Add animated text
1  In an open project, open the slide to which you want to add animated text.
2  Select Insert > Text Animation.
3  Click the Text Animation tab.
4  In the Text box, enter the text to animate.
   The text appears in the preview window.
5  Set the various options according to your requirements.
6  Use the Settings menu to select how to apply property changes in the project. To apply all your changes, select Apply Only Changed Properties. To apply all the text animation settings, select Apply All Properties. You can apply the text animation settings to the current slide only or to all slides.
   Note: If you change the settings in this dialog box, they become the default settings, and any new animated text you create uses the new settings.
7  Select Apply To All to apply settings specified in the Settings menu to all slides.
8  Click OK.

Video
You can add FLV files to make your projects more interesting.

Properties of video files
Set the properties for a video file using its Property dialog box.

Flash Video tab
Video Type  The type of video that you want to insert:
- Progressive Download Video  Loads external FLV files into your Adobe Captivate project and plays them during run time. Because the video content is kept external to the other Adobe Captivate content and the video playback controls, it’s relatively easy to update video content without having to rebuild the Adobe Captivate project. When the movie is played, the video begins playing as soon as the first segment has been downloaded and cached to the local computer’s hard disk.
- Streaming Video  Streaming video either from your own server running Adobe Flash® Media Server or from a host Flash Video Streaming Service provides the most complete, consistent, and robust delivery option for both audio and video files. When streaming, each Flash client opens a persistent connection to the Flash Communication Server, and there is a controlled relationship between the video being delivered and the client interaction. Streaming video is the only delivery option that allows you to include a live video feed in your Adobe Captivate project.

Updated 19 May 2009
Flash Video Streaming Service  This option provides the most effective way to deliver FLV files to the largest possible audience without the inconvenience of setting up and maintaining your own streaming server hardware and network.

Note: If your Adobe Captivate project contains FLV files, ensure that the files contain metadata for the video player to function correctly. FLV files created with Flash Communication Server 1.5.2, FLV Exporter version 1.2, and Sorenson Squeeze® 4.0 automatically contain metadata. Sorenson Squeeze 4.0 is included with the Flash Video Kit. If you import an FLV file that does not have any metadata, the file will not play correctly in your project.

File Link (appears only when the selected video type is Progressive Download Video)  The absolute or relative path to the FLV file.

Browse (appears only when the selected video type is Progressive Download Video)  Click to navigate to the FLV file.

Server URI (appears only when the selected video type is Streaming Video)  The server name, application name, and instance name.

Stream Name (appears only when the selected video type is Streaming Video)  The stream name.

URL (appears only when the selected video type is Flash Video Streaming Services)  The direct file link provided by your Flash Video Streaming Service.

Skin  The skin (playbar) for the inserted video. A preview of the skin you select appears directly below the Skin menu.

Width  The width of the video window within the project window.

Height  The height of the video window within the project window.

Constrain  Maintains the height-to-width ratio of the video.

Detect Size  Displays the existing size of the inserted video.

Total With Skin  The total size of the video, including the skin you selected, appears here.

Live Video Feed (appears only when the selected video type is Streaming Video)  Select this option to insert a live video feed.

Auto Play  The video begins playing automatically as soon as it appears on the slide.

Auto Rewind  The video automatically rewinds to the start position after it completes playing.

Buffer Time (appears only when the selected video type is Streaming Video or Flash Video Streaming Service)  Enter the amount (time) of video that must be loaded before the video plays in the Adobe Captivate project. (The length of actual time it takes to stream video varies depending on the user’s bandwidth.)

Options tab

Item Name  Enter a unique name for the object. You can use this name when defining the visibility conditions for the object.

Visible  Deselect this option if you want the object to be invisible on the slide. The object can be made visible using the Show option. For more information, see "Controlling the visibility of objects" on page 52.

Display For  Specifies the time for which the video file is displayed on the slide.

Specific Time  Play the FLV file for a specified time interval.

Rest Of Slide  Play the FLV file for the duration of the slide.

Rest Of Project  Play the FLV file for the duration of the project.

Duration Of File  Play the FLV file until its completion.

Appear After  The time after which the video file appears on the slide after it starts playing.
Loop (option disabled if you selected Rest Of Slide or Duration Of Video from the Display For menu)  Select this option if you want the video to play continuously.

Synchronize With Project (option disabled if you selected Rest Of Slide from the Display For menu)  Select this option if you want the video to synchronize with your project.

Pause Slide Till End Of Video (option enabled only if you selected Rest Of Slide from the Display For menu)  Select this option to pause the slide that contains the video until the video has finished playing. This option is enabled only when you select Rest Of Slide in the Display For menu.

Effect  Specify a transition effect for the video file. You can make the video file fade in during its entry, and fade out during its exit.

In [#] Seconds  Specifies the amount of time for the video file to fully fade into view.

Out [#] Seconds  Specifies the amount of time for the video file to completely disappear from view.

See also
“Set audio for noninteractive objects” on page 96
“Fix size and position of noninteractive objects” on page 96

Add a video file
You can easily add an existing FLV file to your project.

Note: Only FLV files with metadata play in Adobe Captivate projects. If the inserted file does not have metadata, use third-party software like FLVMDI to add metadata to the file.

1  In an open project, select Insert > Flash Video.
2  In the New Flash Video dialog box, set the required options.
3  To apply the settings or setting changes to all FLV files in your project, select Apply To All.

Change video quality
In general, color is rendered correctly in Adobe Captivate projects. However, sometimes colors are rendered inaccurately, such as when the color scheme varies radically between slides.

You can fix most of these problems by changing the video quality of the slide. Adobe Captivate provides four levels of video quality, even though only the Standard option is suggested for most uses.

1  In an open project, double-click the slide containing the colors you want to correct.
2  Select Slide > Video Quality and choose one of the following video options:
   Standard  The default format for slides. Standard is the most efficient choice for most screenshots because it uses 256 optimized colors. Standard slides also compress well, which results in smaller file sizes.
   Optimized  This option gives you the highest JPEG quality possible.
   JPEG  This option is best used when the slide contains a photograph. You can change the quality and compression ratio for JPEG images on the Project Preferences dialog box.
   High Quality  Compared to the Standard format of 256 colors, this format uses 16 million colors for the slides. Use this option only if the Standard and Optimized options do not offer the correct color depth. This option increases file size substantially.
**Note:** Selecting the JPEG, High Quality, or Optimized format may increase the file size and the time it takes to download your project. Use a format other than Standard only when necessary and appropriate.

## Set audio for noninteractive objects

You can add an audio file to noninteractive objects. The audio file is played when the object appears on the slide.

- **Record New Audio**  
  Opens the Record Audio dialog box. (Recording audio requires some basic equipment.)

- **Stop Audio**  
  Stops playing the audio file.

- **Play Audio**  
  Plays the audio file.

- **Import**  
  Displays the Import Audio dialog box. This dialog box lets you browse to an audio file and import it.

- **Library**  
  Opens the Library. The Library lists all audio files that are already part of the currently open Adobe Captivate project.

- **Edit**  
  Displays the Edit Audio dialog box. This dialog box lets you edit the audio file in various ways, such as inserting silent periods and adjusting the volume.

- **Delete Audio**  
  Removes the audio file from the highlight box.

- **Stop Slide Audio When Slidelet Appears (for Rollover Slidelet)**  
  Any audio associated with the slide stops playing when the slidelet appears in the movie.

- **Fade In [#] Seconds**  
  Specifies the time for the audio to fade in to full volume.

- **Fade Out [#] Seconds**  
  Specifies the time for the audio to fade out to silence.

- **Settings**  
  Opens the Audio Settings dialog box. You can change audio settings such as input source, quality level, and calibration. Click the Settings button to make your selections.

## Fix size and position of noninteractive objects

To specify the exact size and position of the object, click the Size And Position tab. Using these options instead of dragging the object helps you create consistent objects throughout your project.

- **Left**  
  Specifies the position of the left border of the object, in pixels.

- **Top**  
  Specifies the position of the top of the object, in pixels.

- **Width**  
  Specifies the horizontal width of the object, in pixels.

- **Height**  
  Specifies the vertical height of the object, in pixels.

- **Constrain Proportions**  
  Maintains the height-to-width ratio of the object. If either the height or width of the object is changed, the other dimension is changed to maintain the relative proportion of the object.
Chapter 8: Interactive Objects

Interactive objects collect data from users, and provide feedback based on such data.

Defining project navigation

You can define the navigation options for interactive objects according to the following:

- When the user performs the action as defined in the application
- When the user performs an action other than that defined in the application

The following list describes actions available in both the On Slide Enter and On Slide Exit menus.

*Note:* The options Go To Previous Slide, Go To Next Slide, Go To Last Visited Slide, and Jump To Slide are available only in the On Slide Exit menu.

- **Continue**  The movie moves to the next defined action.
- **Go To Previous Slide**  The previous slide is displayed to the user.
- **Go To Next Slide**  The movie moves to the next slide.
- **Go To Last Visited Slide**  The movie moves to the previously viewed slide.
- **Jump To Slide**  The movie moves to the specified slide.
- **Open URL Or File**  A web browser opens with the specified web page if the user has internet connectivity. Alternatively, you could open a specified file for the user.
- **Open Other Project**  Opens the specified Adobe Captivate project.
- **Send E-mail To**  A draft of the default e-mail editor opens with the e-mail address specified in the To field.
- **Execute JavaScript**  Adobe Captivate runs the specified JavaScript.
- **Execute Advanced Actions**  Adobe Captivate runs the script written in Adobe Captivate.
- **Show**  When the user performs the required action, the specified hidden object is made visible
- **Hide**  When the user performs the required action, the specified object is hidden from the user.
- **Enable**  When the user performs the required action, it activates another object in the project.
- **Disable**  When the user performs the required action, it disables another object in the project.
- **Assign**  When the user performs the required action, the value of the specified variable is set inside the object.
- **Increment**  When the user performs the required action, the value of the specified variable is incremented accordingly.
- **Decrement**  When the user performs the required action, the value of the specified variable is decremented accordingly.
- **Multiple Actions**  When the user performs the required action, multiple actions are performed in the order specified by the user.
- **No Action**  Nothing happens when the user exits the slide.

Updated 19 May 2009
Click boxes

Click boxes are areas on the slide where the user must click before the next action can take place. You can use click boxes to demonstrate an application's functionality, for example, by placing them on menus or buttons where the user must click. You can determine what happens after the user performs a successful click. For example, the project can advance to the next slide, open a URL, or send an e-mail message.

You can insert the following types of click boxes in Adobe Captivate:

- Right-click box
- Left-click box
- Double-click box

Unless specified as a double-click or right-click box in the Properties dialog box, click boxes act as left-click boxes. You can recognize the different kinds of click boxes by their associated icons.

Right-click boxes are not supported in the following cases and act as left-click boxes after you publish the Adobe Captivate project:

- Publishing a project for Flash Player versions earlier than 8.0.
- Publishing a project using ActionScript 3.0.
- Publishing a project with 508 compliance enabled.
- Publishing a project to a PDF file.
- In Adobe Captivate projects published as EXE files, right-click works only if the project is published as AS2.

After you have added a click box to your project, you can view and edit its properties using the Advanced Interaction dialog box. Select Project > Advanced Interaction. This dialog box displays the properties of all interactive objects in your project.

Properties of click boxes

The Properties dialog box for click boxes has the following tabs:

- Click Box
- Options
- Audio
- Size And Position
- Reporting

Click Box tab

This tab lets you determine how the project responds to user interaction. The options are divided into two basic categories: what happens when the user clicks inside the click box and what happens when the user clicks outside the click box.

The following options are in the If The User Clicks Inside The Click Box area:

**On Success**  Specifies the event that occurs when a user clicks inside the box. For more information, see “Defining project navigation” on page 97.

**Disable Click Sound**  Disables the click sound that is played when users click inside the click box area.

The following options are available in the If The User Clicks Outside The Click Box area:
Allow User [#] Attempts  Specifies the number of times the user can attempt the question before the specified action takes place. The Infinite Attempts option is selected by default. To enter a specific number of attempts, first clear the Infinite Attempts option.

Infinite Attempts  Allows users an unlimited number of attempts.

After Last Attempt  Specifies the event that should take place after the last attempt. For more information, see “Defining project navigation” on page 97.

- If you select Open URL Or File or Open Other Project, click the pop-up menu to select the window in which the URL, file, or project appears. Select from Current, New, Parent, and Top. (If you choose New, Parent, or Top, you also have the option to continue playing the original project when the URL, file, or project opens.)
- If you select Send E-mail To, you have the option to continue playing the project while the e-mail message is prepared and sent.
- If you select the Open URL Or File option and specify a URL, the URL is visible when you edit the slide in Adobe Captivate. However, it is not visible to the user. To show the URL, create a simple image with the URL text on the image. Then add the image to your slide, and place a click box over the image.

Select Keys  You can specify a keyboard shortcut for the mouse-click. Users can use the keyboard shortcut instead of the mouse. For example, suppose you select Control+Shift+Enter as the keyboard shortcut for the mouse-click. The click is treated as correct (a click within the box) when users press this combination. If they press the wrong combination, it is treated as a click outside the box.

Note: If your Adobe Captivate project is displayed in a browser, set keyboard shortcuts that do not conflict with common browser shortcuts. For example, F1 is frequently used as a keyboard shortcut to display Help. The Control, Alt, and Shift keys map to the Control, Option, and Shift keys on Macintosh computers, respectively.

Options tab
Click the Options tab. This tab lets you design how the click box looks. Select from the following options:

Item Name  Enter a unique name for the object. You can use this name when defining the visibility conditions for the object.

- Visible  Deselect this option if you want the object to be invisible on the slide. The object can be made visible using the Show option. For more information, see “Controlling the visibility of objects” on page 52.

Display For [Time]  Specifies the time for which the click box appears on the slide.

Appear After [#] Seconds  The time after which the click-box appears on the slide after the slide starts playing.

Success Caption  The caption displayed when the user clicks inside the click box.

Failure Caption  The caption displayed when the user clicks outside the click box.

Hint Caption  The caption providing a hint to the user. The hint is displayed when the user moves the mouse over the click box.

Show Hand Cursor Over Hit Area  Changes the pointer to a pointing hand when the user moves the pointer over the click box.

Stop Slide Audio When Clicked  Audio stops playing when the user clicks the click box. This option stops only the slide audio, not the background audio. Also, only a mouse click stops the audio; using a keyboard shortcut does not stop the audio.

Pause Project Until User Clicks  Project starts playing only after the user clicks the click box.

Double Mouse Click  Users must double-click the click box.
Right Mouse Click  Users must right-click on the click box.

Pause For Success/Failure Captions  Pauses the project until all success and failure captions are displayed.

Audio tab
Record New Audio  Opens the Record Audio dialog box. (Recording audio requires some basic equipment.)
Stop Audio  Stops playing the audio file.
Play Audio  Plays the audio file.
Import  Displays the Import Audio dialog box. This dialog box lets you browse to an audio file and import it.
Library  Opens the Library. The Library lists all audio files that are already part of the currently open Adobe Captivate project.
Edit  Displays the Edit Audio dialog box. This dialog box lets you insert silent periods and adjust the volume.
Delete  Removes the audio file associated with the click box.
Fade In [#] Seconds  Specifies the time for the audio to fade in to full volume.
Fade Out [#] Seconds  Specifies the time for the audio to fade out to silence.
Settings  Opens the Audio Settings dialog box. You can change audio settings such as input source, quality level, and calibration. Click the Settings button to make your selections.
Stop Slide Audio When Clicked  Stops playing the audio file associated with the slide when you click inside the click box area. This option stops only the slide audio, not the background audio. Also, using a keyboard shortcut does not stop the audio.
Stop Slide Audio When Paused  Stops playing the audio file associated with the slide when the project is paused. For example, if you have used the Options tab to enable the Pause Project Until User Clicks option, the slide audio stops until the user clicks inside the click-box area.

Reporting tab
You can assign a score to every correct mouse-click and coordinate the score with a learning management system.
Include In Quiz  Considers the click box as a question in the current quiz. The points assigned to this click box are added to the score results of the current quiz.
Report Answers  Sends the quiz score to the learning management system (LMS).
Objective ID  This parameter is an optional. If the click box question is related to an objective set in your learning management system, enter the objective here.
Interaction ID  Sends tracking information to your learning management system. Use the interaction ID specified by your learning management system.
Points  The score that you want to assign to the question. The maximum is 100 points, the minimum is 0. The points assigned to this click box are added to the score results of the current quiz.
Add To Total  Includes the points for the correct click in the total score.

See also
“Learning management system (LMS)” on page 216

Updated 19 May 2009
Size And Position tab
You can specify the exact size or location of the click box in terms of pixels in the Size And Position tab.

Left  Position of the left border of the object.
Top   Position of the top of the object.
Width Width of the object.
Height Height of the object.
Constrain Proportions  Maintains the height-to-width ratio of the click box when you resize it.

See also
“Defining project navigation” on page 97

Add a click box
1  In an open project, select the slide to which you want to add a click box.
2  Select Insert > Standard Objects > Click Box.
3  Specify the settings for the click box using the options in the dialog box.
4  Use the Settings menu to select how to apply property changes in the project. To apply all your changes, select Apply Only Changed Properties. To apply all the click box settings, select Apply All Properties. You can apply the click box settings to the current slide only or to all slides.

   Note: If you change the settings in this dialog box, they become the default settings and new click boxes that you create use the new settings.
5  Select Apply To All to apply settings specified in the Settings menu to all slides.
6  Click OK.
   The click box appears on the slide.
7  Size and drag the click box as desired.
8  If you selected the Success, Failure, or Hint caption options, double-click the text boxes to edit the text.

Text entry boxes
Text entry boxes are text fields into which users can enter text. Text entry boxes are a great way to test user knowledge. After the user answers a question, Adobe Captivate matches the answer with the answers that you have set when creating the text entry box. You can even provide a hint to the user if you want to.

Properties of text entry boxes
The Properties dialog box for the text entry box has the following tabs:

   • Text Entry Box
   • Options
   • Audio
   • Reporting
• Size And Position
• Advanced

**Text Entry Box tab**
The following options are in the Settings area:

- **Default Text**  The default text that appears in the text entry box. The user can overwrite the displayed text. For example, you can set a default text for the text entry box saying, “Enter the answer here.”

- **Retain Text**  Allows users to view their previously entered answer if they return to this slide using the Back button.

The following options are in the If The User Enters The Text Correctly area:

- **Correct Entries**  The answer for the question. You can enter multiple correct answers.

- **Font**  Font properties for the text entered in the text entry box.

- **Add**  Use this button to specify more than one correct entry.

- **Delete**  Removes a selected answer from the list.

- **On Success**  Specifies the event after a user enters the correct text in the text entry box. For more information, see “Defining project navigation” on page 97.

The following options are in the If The User Enters The Text Incorrectly area:

- **Allow User [#] Attempts**  Specifies the number of times the user can attempt the question before the specified action takes place. The Infinite Attempts option is selected by default. To enter a specific number of attempts, clear the Infinite Attempts option.

- **Infinite Attempts**  Allows users an unlimited number of attempts.

- **After Last Attempt**  Specifies the event that should take place after the last attempt. For more information, see “Defining project navigation” on page 97.

  • If you select Open URL Or File or Open Other Project, click the pop-up menu to select the window in which the URL, file, or project should appear; select from Current, New, Parent, and Top. (If you choose New, Parent, or Top, you also have the option to continue playing the original project when the URL, file, or project opens.)

  • If you select Send E-mail To, you have the option to continue playing the project while the e-mail message is prepared and sent.

  • If you select the Open URL Or File option and specify a URL, the URL is visible when you edit the slide in Adobe Captivate. However, it is not visible to the user. To show the URL, create a simple image with the URL text on the image, add the image to your slide, and place a click box over the image.

- **Set Shortcut Key**  You can specify a keyboard shortcut for the Submit button associated with the text entry box. Users can use the keyboard shortcut instead of using the mouse to click the Submit button.

  *Note: If your Adobe Captivate project is displayed in a browser, set keyboard shortcuts that won’t conflict with common browser shortcuts. For example, F1 is frequently used as a keyboard shortcut to display Help. The Control, Alt, and Shift keys map to the Control, Option, and Shift keys on Macintosh computers, respectively.*

**Options tab**

- **Item Name**  Enter a unique name for the object. You can use this name when defining the visibility conditions for the object.

  • **Visible**  Deselect this option if you want the object to be invisible on the slide. The object can be made visible using the Show option. For more information, see “Controlling the visibility of objects” on page 52.
**Display For [Time]**  Specifies how long the text entry box is displayed on the slide.

**Appear After [#] Seconds**  Specifies the delay between the first appearance of the slide and the first appearance of the text entry box.

**Pause After [#] Seconds**  Specifies the point at which the project pauses so that the user can enter text in the text entry box. The project continues only after the user submits the correct answer.

**Effect**  Transition effect for the text entry box. You can apply a fade in or fade out effect and set the time for the fading effects.

**Transparency**  Degree of transparency for the text entry box. Select a value from 0% to 100%. A value of 10% is less transparent (more solid) than a value of 90%.

The transparency effect does not appear when you view the text entry box in Edit view. To test the transparency effect, press F4 to preview the slide.

**Background Color**  Background color of the text entry box.

**Validate User Input**  If this option is disabled, Adobe Captivate does not validate the text in the text entry box. The box behaves like a form field and accepts any user input.

  - **Success Caption**  The caption displayed when the user clicks inside the click box.
  - **Failure Caption**  The caption displayed when the user clicks outside the click box.

**Hint Caption**  The caption providing a hint to the user. The hint is displayed when the user moves the pointer over the click box.

**Pause For Success/Failure Captions**  Pauses the project until all success and failure captions are displayed.

**Show Button**  Adds a Submit button to the text entry box. You can change the label for the button.

**Show Text Box Frame**  Enables visibility of the text entry box. If you do not select this option, only the text is displayed to the user.

**Password**  The text entry box mimics a password field.

**Case-sensitive**  Text entered in the text entry box is considered case sensitive. Users must provide answers with the correct combination of lowercase and uppercase letters.

**Show Scrollbar**  Displays a scroll bar when the user exceeds the space available in the text entry box.

**Audio tab**

**Record New Audio**  Opens the Record Audio dialog box. (Recording audio requires some basic equipment.)

**Stop Audio**  Stops playing the audio file.

**Play Audio**  Plays the audio file.

**Import**  Displays the Import Audio dialog box. You can browse to an audio file and import it.

**Library**  Click to open the Library. The Library lists all audio files that are already part of the currently open Adobe Captivate project.

**Edit**  Displays the Edit Audio dialog box. This dialog box lets you insert silent periods and adjust the volume.

**Delete**  Removes the audio file from the highlight box.

**Fade In [#] Seconds**  Specifies the number of seconds until the audio fades in to full volume.

**Fade Out [#] Seconds**  Specifies the number of seconds until the audio fades out to silence.
Settings  Opens the Audio Settings dialog box. You can change audio settings such as input source, quality level, and calibration. Click the Settings button to make your selections.

Reporting tab
If you want to keep score for the text entry box or coordinate the score with a learning management system, use the Reporting tab. Select from the following options:

Include In Quiz  The points assigned to the text entry box are added to the score results for the current quiz.
Report Answers  Sends the score to the learning management system (LMS).
Objective ID  Maps to an objective ID set in your learning management system.
Interaction ID  Sends tracking information to the learning management system based on the interaction ID specified by the learning management system.
Points  Score when the user answers the question correctly. The maximum is 100 points, the minimum is 0.
Add To Total  The score of the text entry box is added to the quiz total.

See also
“Learning management system (LMS)” on page 216

Size And Position tab
If you want to define the exact size or location of the text entry box in terms of pixels, click the Size And Position tab. Select from the following options:

Left  Specifies the position of the left border of the object, in pixels.
Top  Specifies the position of the top of the object, in pixels.
Width  Specifies the width of the object, in pixels.
Height  Specifies the height of the object, in pixels.
Constrain Proportions  Maintains the height-to-width ratio when the click box is resized.

Advanced tab
Variable Associated  The text entered in the text box is stored in this variable.
On Focus Lost  Select the action that should be performed when the user presses Enter or Tab, or moves the pointer away from the object.

See also
“Defining project navigation” on page 97

Add a text entry box
1  In an open project, select the slide to which you want to add a text entry box.
2  Select Insert > Objects > Text Entry Box.
   The New Text Entry Box dialog box appears.
3  Specify the options for the text entry box using the options in the dialog box.
4 Use the Settings menu to select how to apply property changes in the project. To apply all your changes, select Apply Only Changed Properties. To apply all the text entry box settings, select Apply All Properties. You can apply the text entry box settings to the current slide only or to all slides.

Note: If you change the settings in this dialog box, they become the default settings, and new text entry boxes that you create use the new settings.

5 Select Apply To All to apply settings specified in the Settings menu to all slides.

6 Click OK.

A text entry box appears on the slide.

7 Size and drag the text entry box as desired.

8 If you selected the Success, Failure, or Hint caption options, double-click the text boxes to edit the text.

Buttons

You can increase the interactivity of your Adobe Captivate projects by adding buttons. To quickly add a button, use the default button style (a plain, white rectangle) or import custom button images you have created. You can size and position buttons on a slide. You determine what happens after the user clicks the button. After you add a button to your project, you can view and edit the object’s properties in the Advanced Interaction dialog box. Selecting Project > Advanced Interaction. This dialog box displays the properties of all interactive objects in your project

Note: Best practice is to resize buttons before resizing the project. Resizing a project does not resize the buttons automatically.

Properties of buttons

The Button Properties dialog box has the following tabs:

- Button
- Options
- Audio
- Reporting
- Size And Position

See also

“Learning management system (LMS)” on page 216

“Defining project navigation” on page 97

Button tab

This tab lets you determine how the Adobe Captivate project responds to user interaction. The options are divided into two basic categories: what happens when the user clicks the button and what happens when the user clicks outside the button.

Use the Type menu to select the button you want to create:

Text Button Button with text displayed on it.

- Button Text Type text that you want displayed on the button.
• Font The font properties of the button.

• Transparent Makes the button transparent. When a text button is transparent, only its text appears on the slide.

**Transparent Button** Sets the button transparency. Adobe Captivate recognizes the color of the upper-left pixel in the image and makes that color transparent throughout the button.

• Frame Color Color for the border of the button.

• Fill Color Color of the button.

• Frame Width Thickness of the border around the button.

• Fill Transparency Transparency level for the button. For a very dim button, select a high number such as 90. For a darker button, select a low number such as 10.

**Image Button** Use an image as a button. You can browse to an image available in the gallery or choose from the Button Style menu

• Transparent Button Creates a button that is completely or partially transparent. You can select the degree of transparency.

**On Success** Specifies the event after a user clicks the button after performing the correct action. For more information, see “Defining project navigation” on page 97.

The following options are in the If The User Enters The Text Incorrectly area:

**Disable Click Sound** Use this option when you do not want the click sound to be heard when the user clicks the button.

**Allow User [#] Attempts** Specifies the number of times the user can attempt the question before the specified action takes place. The Infinite Attempts option is selected by default. To enter a specific number of attempts, first clear the Infinite Attempts option.

**Infinite Attempts** Allows users an unlimited number of attempts.

**After Last Attempt** Specifies the event that should take place after the last attempt. For more information, see “Defining project navigation” on page 97.

• If you select Open URL Or File or Open Other Project, click the pop-up menu to select the window in which the URL, file, or project should appear. Select from Current, New, Parent, or Top. (If you choose New, Parent, or Top, you also have the option to continue playing the original project when the URL, file, or project opens.)

• If you select Send E-mail To, you have the option to continue playing the project while the e-mail message is prepared and sent.

• If you select the Open URL Or File option and specify a URL, the URL is visible when you edit the slide in Adobe Captivate. However, it is not visible to the user. To show the URL, create a simple image with the URL text on the image, add the image to your slide, and place a click box over the image.

**Select Keys** You can specify a keyboard shortcut for the button. Users can use the keyboard shortcut instead of using the mouse. For example, if you select Control+Shift+Enter as the keyboard shortcut for the button, users can press this combination instead of manually clicking the button.

**Note:** If your Adobe Captivate project is displayed in a browser, set keyboard shortcuts that do not conflict with common browser shortcuts. For example, F1 is frequently used as a keyboard shortcut to display Help. The Control, Alt, and Shift keys map to the Control, Option, and Shift keys on Macintosh® computers, respectively.
Options tab
Click the Options tab. This tab enables you to design the button’s appearance. Select from the following options:

- **Item Name** Enter a unique name for the object. You can use this name when defining the visibility conditions for the object.

- **Visible** Deselect this option if you want the object to be invisible on the slide. The object can be made visible using the Show option. For more information, see "Controlling the visibility of objects” on page 52.

- **Display For [Time]** Specifies the time for which the button appears on the slide.

- **Appear After [#] Seconds** Specifies the delay between the first appearance of the slide and the first appearance of the button.

- **Pause After [#] Seconds** Specifies the point at which the project pauses and waits for user input.

- **Success Caption** The caption displayed when the user clicks inside the click box.

- **Failure Caption** The caption displayed when the user clicks outside the click box.

- **Hint Caption** The caption providing a hint to the user. The hint is displayed when the user moves the mouse over the click box.

- **Double Mouse Click** The user must double-click the mouse for the defined action to take place.

- **Show Hand Mouse Cursor When Over Button** Changes the pointer to a hand when the user moves the pointer over the button.

- **Pause for Success/Failure captions** The user can click the button only after the success/failure captions appear on the slide. This option is enabled only when you have added a text entry box with captions to the slide.

Audio tab
If you want to add audio to the button, click the Audio tab. Select from the following options:

- **Record New** Opens the Record Audio dialog box. (Recording audio requires some basic equipment.)

- **Stop** Stops playing the audio file.

- **Play** Plays the audio file.

- **Import** Displays the Import Audio dialog box. This dialog box lets you browse to an audio file and import it.

- **Library** Opens the Audio Library. The Library lists all audio files that are already part of the currently open Adobe Captivate project.

- **Edit** Displays the Edit Audio dialog box. This dialog box lets you edit the audio file in various ways, such as inserting silent periods and adjusting the volume.

- **Delete** Removes the audio file associated with the button.

- **Fade In [#] Seconds** Specifies the number of seconds for the audio to fade in to full volume.

- **Fade Out [#] Seconds** Specifies the number of seconds for the audio to fade out to silence.

- **Settings** Opens the Audio Settings dialog box. You can change audio settings such as input source, quality level, and calibration. Click the Settings button and make your selections.

- **Stop Slide Audio When Clicked** The slide audio stops playing when the user clicks the button. This option stops only the slide audio, not the background audio. Also, using a keyboard shortcut does not stop the audio.
Stop Slide Audio When Paused   Stops playing the audio file associated with the slide when the project is paused. For example, if you have enabled the option Pause For Success/Failure Captions in the Options tab, the slide audio stops playing until the captions are displayed.

Reporting tab
If you want to keep score for the button or coordinate the score with a learning management system, use the Reporting tab.

Include In Quiz   The points assigned to the button are added to the score results for the current quiz.

Report Answers   Sends the score to the learning management system, (LMS).

Objective ID   Maps to an objective ID set in your learning management system.

Interaction ID   Sends tracking information to the learning management system based on the interaction ID specified by the learning management system.

Points   Score when the user answers the question correctly. The maximum is 100 points, minimum is 0.

Add To Total   The score of the button is added to the quiz total.

Size And Position tab
If you want to define the exact size or location of the buttons in terms of pixels, click the Size And Position tab. Select from the following options:

Left   Position of the left border of the object.

Top   Position of the top of the object.

Width   The width of the object.

Height   The height of the object.

Constrain Proportions   Maintains the height-to-width ratio when the object is resized.

Settings menu
Use the Settings menu to select how to apply property changes in the project. To apply all your changes, select Apply Only Changed Properties. To apply all the button settings, select Apply All Properties. You can apply the button settings to the current slide only or to all slides.

Note: If you change the settings in this dialog box, they become the default settings, and any new buttons you create use the new settings.

Properties of review buttons
The Review button is present on the quiz results slide. When users click the Review button, they are presented with a slide that provides a report of the questions that were answered correctly and incorrectly. It also provides the correct answers to all the questions. The properties of review buttons are similar to those of normal buttons.

See also
“Set quiz preferences” on page 152

Add a button
Note: Resize any buttons before resizing the project. Resizing a project does not resize the buttons automatically.

1   In an open project, select the slide to which you want to add a button.
2 Select Insert > Standard Objects > Button.
   
   **Note:** You can delete a button at any time by selecting it and pressing the Delete key. When you delete a button, all associated objects (such as success and failure captions) are also deleted.

3 In the New Button dialog box, set the values for the various options.

4 Select Apply To All to apply settings specified in the Settings menu to all slides.

5 Click OK.

6 The button appears on the slide.

7 Size and drag the button as desired.

8 If you selected the Success, Failure, or Hint caption options, double-click the text boxes to edit the text.

### Automatically resize buttons

Adobe Captivate can automatically resize a button or caption according to the amount of text in the button. If you edit the text, the button changes size to accommodate the new text. This is an easy way to keep your buttons looking balanced and proportional.

1 In an open project, select Edit > Preferences

2 In the Preferences dialog box, select Defaults under the Global menu.

3 Select Autosize Buttons in the Global panel on the right.

### Modify buttons on question slides

You can modify some properties of buttons on question slides. The standard buttons are Clear, Back, Submit, and Skip.

1 Right-click the question button that you want to modify.

2 Select Properties.

3 In the Button dialog box, set the values for the various options.

4 Select Apply To All to apply settings specified in the Settings menu to all slides.

5 Click OK.

The Properties dialog box for buttons for question slides have the following tabs:

- `<Name Of The Button>` Button. For example, the tab for the clear button is labeled Clear Button.
- Size And Position

**Note:** Resizing any buttons before resizing the project. Resizing a project does not resize the buttons automatically.

### Button tab

Use the Type pop-up menu to select the type of button you want to create. (The type you select determines the options that are available.)

- **Text Button** Creates a button with a label on it. You can set the following options:
  - **Button Text** The text that should appear on the button.
  - **Font** The font type, style, size, effects, and color.
  - **Transparent** When a button is transparent, only the button text is visible.
Transparent Button  Creates a button that exists on the slide but is not visible. You can set the following options:

- **Frame Color**  Sets the color for the outside edges of the button.)
- **Fill Color**  The color used inside the button.
- **Frame Width**  Thickness of the borders of the button.
- **Fill Transparency**  The transparency of the button. A transparency of 0% fills the button with the exact color selected in the color menu. As you increase the percentage, the fill color becomes lighter and fainter.

Image Button  Creates a button that appears as an image. Choose from any of the standard images available in the pop-up menu or click Browse to select an image from your computer.

- **Transparent Buttons**  Makes the button transparent.

Select Keys  You can specify a keyboard shortcut for the button. Users can use the keyboard shortcut instead of using the mouse. For example, if you select Control+Shift+Enter as the keyboard shortcut for the button, users can press this combination instead of manually clicking the button.

**Note:** If your Adobe Captivate project is displayed in a browser, set keyboard shortcuts that do not conflict with common browser shortcuts. For example, F1 is frequently used as a keyboard shortcut to display Help. The Control, Alt, and Shift keys map to the Control, Option, and Shift keys on Macintosh® computers, respectively.

Settings  Select whether to apply all the properties or only the changed properties to the respective slide or to all the slides.

**Note:** If you change the settings in this dialog box, any new buttons you create use the new settings.

Apply To All  Apply properties to all slides in the project.

Size And Position tab

- **Left**  Position of the left border of the button.
- **Top**  Position of the top of the button.
- **Width**  Width of the button.
- **Height**  Height of the button.

Constrain Proportions  Select to maintain the height-to-width ratio when you resize.

Settings  Select how to apply properties. Select Apply Only Changed Properties, or, to apply all current and changed button settings, select Apply All Properties. You can apply button settings to the current slide only or to all slides.

Apply To All  Select Apply To All to apply settings specified in the Settings menu to all slides.

Add JavaScript to boxes and buttons

You can add JavaScript to click boxes, text entry boxes, and buttons in Adobe Captivate projects. The JavaScript can run when a user clicks inside or outside the box or button. Using JavaScript gives you the opportunity to extend projects in numerous ways while adding interactivity.

You can add JavaScript when you create a box or button, or add JavaScript to an existing box or button.

1  In an open project, select the slide to which you want to add a box or button with JavaScript.
2 Either select an existing button or create one:
   • To add JavaScript to an existing box or button, double-click it.
   • To create a box or button, select Insert > Standard Objects > Click Box or Text Entry Box or Button.
3 In either On Success or After Last Attempt, select the Execute JavaScript option.
4 In JavaScript, click the Browse (...) button.
5 Enter your JavaScript code in the text box. If you have the JavaScript in another location, you can copy it and paste it into the text box.

Add audio to boxes and buttons
You can import an audio file to use with buttons, highlight boxes, click boxes, or text entry boxes. The audio file plays when the object is clicked. You can also use the Library to add an audio file that is already in your current project.

Import an audio file
1 In an open project, select the slide that contains the button or box to which you want to add audio. Right-click the button or box and select Properties from the pop-up menu.
2 Click the Audio tab.
3 Click Import.
   Adobe Captivate contains a gallery that has buttons, sounds, and animations (in SWF format) for you to use in your projects. By default, the gallery is stored in the following location when you install Adobe Captivate:
   C:\Program Files\Adobe\Adobe Captivate 4\Gallery.
4 Browse to the audio file you want to add, select the file, and click Open.
5 (Optional) To listen to and test the audio file, click Play.
6 Set other options as necessary.
   • To edit the audio file (for example, change volume, add silence, change length, and so on), click Edit.
   • If you want the audio to fade in or fade out, set the number of seconds using the arrows in the Fade In and Fade Out options.
7 When you finish, click OK.
   Note: To use the Library option, the Adobe Captivate project must contain one or more audio files. If the project has no audio files, the Library option is unavailable.

Select an audio file from the Library
1 In an open project, select the slide that contains the button or box to which you want to add audio. Right-click the button or box and select Properties from the pop-up menu.
2 Click the Audio tab.
3 Click Library.
4 In the Select Audio From Library dialog box, select the audio file, and click OK.
5 Click the Settings button to open the Audio Settings dialog box. You can change audio settings such as input devices, quality level, or calibration. Click the Settings button and make your selections.
6  (Optional) To listen to the audio file, click Play.

7  To add the selected audio file to the button or box, click OK.

You can also record a new audio file to use with boxes and buttons.

You can attach an audio file to a button or click box. You can choose to play the audio play when the user clicks the button or click box instead of when the button or click box appears. To do this, create the button or click box, and select the Success caption option. Make the success caption transparent and do not add any text. Add an audio file to the success caption.
Chapter 9: Widgets

About widgets

In Adobe Captivate, widgets are configurable SWF objects created in Flash. Widgets can help provide enhanced interactivity and rich content rapidly.

Developers creating widgets build the content structure, with interactivity, and provide some parameters for customization through Adobe Captivate. When users of Adobe Captivate insert a widget, they can customize these parameters based on the course content. For example, users of a pie chart widget can customize the size and colors of the different segments of the chart.

The base code for creating different types of widgets for Adobe Captivate is available in Flash. Developers can use this base code for widgets inserted in Adobe Captivate.

*Note:* Animated SWF files, unlike SWF files for widgets, are not configurable.

Developers can do the following:

- Control the visibility of the widget. Developers can choose to make certain facets of the widget available to the users in Adobe Captivate for preview or customization.
- Define the behavior of the widget in response to user input.

*Note:* You must have Flash CS3 or Flash CS4 installed on your computers to create widgets for Adobe Captivate.

Types of widgets

Static widget

Static widgets are not interactive. They are meant to display information.

For example, you can use the certificate widget to create a certificate with the following information:

- Name of the person taking the course
- Name of the course
- Score of the person taking the course
- Grade achieved by the person taking the course
- Date on which the course was taken

When you insert the certificate widget after the result slide, the certificate picks up the information from the result slide and displays it on the certificate. This way, you can automatically generate a certificate for people who have obtained a passing score.

To use this widget, do the following:

1. Create a user-defined variable.
   a. Select Project > Actions.
   b. Select User from the Type menu.
   c. Click Add New.
In the Name field, enter v_Name.

Insert a blank slide, and add a text entry box to it.

- In the Options tab, deselect Validate User Input.
- In the Advanced tab, select v_Name from the Variable Associated menu.

Insert a minimum of one question slide.

Insert a blank slide after the results slide.

Insert the Certificate.swf file from the Widget panel in the inserted slide.

When you preview the movie, enter your name in the text entry box on the first slide. After you complete the quiz, click Continue on the Results slide. A certificate is displayed containing your name along with your score.

If you are a developer trying to create a static widget in Flash, you can explore the code for the certificate widget. The code gives you an idea of how to create static widgets. Look for the Certificate.fla file on your computer in the ...Certificate.wdgt folder.

**Interactive widget**

Interactive widgets change their appearance or function based on user input.

If you are a developer trying to create an interactive widget in Flash, you can explore the code for the button widget. The code gives you an idea of how to create interactive widgets. Look for the button widget, FlashButton.fla, on your computer in the ...FlashButton.wdgt folder.

The button widget glows when the user moves the pointer over it.

1. Insert a blank slide.
2. Insert the FlashButton.swf file from the Widget panel in the slide.
3. Preview the slide. When you move the pointer over the button, the Button widget glows.

**Question widget**

You can use question widgets to add new question types in Adobe Captivate.

If you are a developer trying to create a question widget in Flash, you can explore the code for the sequence question widget. The code gives you an idea of how to create question widgets. Look for the question widget, SequencingQuestion.fla on your computer in the ...SequencingQuestion.wdgt folder.

The sequence question slide contains an anagram. The user must rearrange the letters by moving them to their correct positions in the blue boxes.

1. Insert a blank slide.
2. Insert the widget SequencingQuestion.swf from the Widget panel to the slide.
3. In the Words To Be Jumbled field, enter the word, “user.”
4. Preview the project. The letters of the word, “user” appear jumbled in the orange boxes. Move the letters to their correct positions by dragging them to the empty blue boxes.
5. Click Submit.
Widget panel

The Widget panel displays all the widgets that are present in the \Program Files\Adobe\Adobe Captivate <version number>\Gallery\Widgets folder. You can add widgets to a slide by dragging the widget from the panel to the slide. Alternatively, you can select a widget in the panel and click Insert. A preview of the widget is displayed in the Preview panel when you select a slide. Developers creating widgets can define the image that users see in the preview panel.

Display the Widget panel

- Select Window > Widget.

View widgets created using a different ActionScript version

The Widget panel displays widgets that have been created using a particular ActionScript version. Change the settings in the Preferences dialog box to view widgets created using other versions.

1 Select Edit > Preferences.
2 In the Preferences dialog box, select Publish Settings from the Project menu.
3 Select the ActionScript version in the Publish Settings panel.

Sort widgets in the Widget panel

You can sort widgets according to their type in the Widget panel.

- Use the menu at the bottom of the panel to select the type of widgets that you want displayed. The following options are available: All, Static, Interactive, Question.

Add new widgets to the Widget panel

1 Click Browse on the Widget panel.
2 In the Browse For Widgets dialog box, navigate to the widget that you want to add to the panel.
3 Select the widget, and click Open.

Change the default location of the Widget panel

The widgets in the Widget panel are picked up from the \Program files\Adobe\Adobe Captivate <Version number>\Gallery\Widgets folder. You can change this default location by pointing the Widget panel to an alternative folder.

- Click Change Path. In the Browse For Folder dialog box, select a folder from which to populate the Widget panel.

Download widgets from Adobe Captivate Exchange

You can download widgets from Adobe Captivate Exchange to the Widget panel.

- Click Adobe Captivate Exchange. Download the widget from the Adobe Captivate Exchange website.

Linked widgets

If you have a widget that references other widgets, do the following to display the widget in the Widget panel.

1 Save all the related widgets in a single folder.
2 Create a description.xml file that provides information about the linking of SWF files.

Updated 19 May 2009
The description.xml file contains the following tags:

- **Description**: Description of the widget.
- **Type**: Type of the widget: Static, Interactive, or Question.
- **Name**: Name of the main SWF file that uses the linked SWF files.
- **Linkedfiles**: Name of the SWF files that are linked to the main SWF file. Use semicolons to separate the names.

3. Compress the folder and name the ZIP file, giving it a .wdgt extension.

4. Place the ZIP file in the Widgets folder. The path to this folder is `\Program Files\Adobe\Adobe Captivate <version number>\Gallery`.

## Create widgets

### Create static widgets

1. In Adobe Captivate, select File > New > Widget in Flash.
2. In the Create New Widget dialog box, do the following:
   a. In the Widget menu, select Static.
   b. In the ActionScript Version menu, select the ActionScript version that you plan to use when writing the widget code in Flash.
   c. Click OK.
3. In Flash, right-click the Actions layer in the Timeline, and select Actions.
4. The Actions panel appears with the template code for the static widget. Customize this code to create your widget.

### Create interactive widgets

1. In an open project, select File > New > Widget In Flash.
2. In the Create New Widget dialog box, do the following:
   a. In the Widget menu, select Interactive.
   b. In the ActionScript Version menu, select the ActionScript version that you plan to use when writing the widget code in Flash.
   c. Click OK.
3. In Flash, right-click the Actions layer in the Timeline, and select Actions.
4. The Actions panel appears with the template code for the interactive widget. Customize this code to create your widget.

### Create question widgets

1. Select File > New > Widget In Flash.
2. In the Create New Widget dialog box, do the following:
   a. In the Widget menu, select Question.
b In the ActionScript Version menu, select the ActionScript version that you plan to use when writing the widget code in Flash.

c Click OK.

3 In Flash, right-click the Actions layer in the Timeline, and select Actions.

4 The Actions panel appears with the template code for the question widget. Customize this code to create your widget.

Note: You can add question widgets to question pools. They are treated as any other question slide.

Create a .wdgt file
A WDGT file is a widget format in which the widget uses linked files.

The WDGT file is a file with .wdgt extension containing linked SWF files, and a description.xml file that contains information about the linking.

1 Publish the FLA as a SWF file in Flash.

2 Create a description.xml file. If the main SWF file, ABC.swf, uses two linked files PQR.swf and XYZ.swf, the description.xml file is in the following format:

```xml
<?xml version="1.0" encoding="ISO-8859-1" ?>
<widget>
<Description>This is an ABC widget (static)</Description>
<Type>isStatic</Type>
<Name>ABC.swf</Name>
<linkedfiles>PQR.swf</linkedfiles>
<linkedfiles>XYZ.swf</linkedfiles>
</widget>
```

3 Do one of the following:

a Create a folder, and copy the SWF files and the description.xml files into the folder. Change the extension of the folder to .wdgt, and place it the Widgets folder of the Captivate installation folder.

Note: If you create a widget in this method, you can insert the widget only from the Widget panel.

b ZIP the file, and change the extension of the zipped file to .wdgt.

Note: If you create a widget in this method, the widget is not listed in the Widget panel. You can insert the widget only by selecting Insert > Widget.

Properties of widgets
In addition to the parameters defined by the widget developer, Adobe Captivate allows you to set properties for widgets. You can modify the properties of a widget when inserting it, or using its Properties dialog box.

Widget tab

Transparency The transparency of the widget. At 0% transparency, the widget is opaque, and at 100%, transparency, it is invisible.

On Success The options available if the user successfully fulfills the criteria specified in the widget. For more information, see “Defining project navigation” on page 97.

After Last Attempt The options available if the user fails to fulfill the criteria specified in the widget in the defined number of attempts. For more information, see “Defining project navigation” on page 97.
Options tab

- **Item Name**: Enter a unique name for the object. You can use this name when defining the visibility conditions for the object.
- **Visible**: Deselect this option if you want the object to be invisible on the slide by default. Use the Show action to make the widget visible. For more information, see “Controlling the visibility of objects” on page 52.

- **Display For [Time]**: Specifies how long the widget appears on the slide.
- **Appear After [#] Seconds**: Specifies the delay between the first appearance of the slide and the first appearance of the widget.
- **Pause After [#] Seconds**: Specifies the point at which the project pauses so that the user can follow the instructions in the widget.
- **Effect**: Transition effect for the widget. You can apply a fade in or fade out effect, and set the time for the fading effects.
- **Success Caption**: The caption displayed when the user successfully completes the task assigned by the widget.
- **Failure Caption**: The caption displayed when the user does not provide the input required by the widget.
- **Hint Caption**: The caption providing a hint to the user. The hint is displayed when the user moves the pointer over the widget.
- **Pause For Success/Failure Captions**: Pauses the project until all success and failure captions are displayed.

Audio tab

If you want to add audio to the widget, click the Audio tab. Select from the following options:

- **Record New Audio**: Opens the Record Audio dialog box. (Recording audio requires some basic equipment.)
- **Stop**: Stops playing the audio file.
- **Play**: Plays the audio file.
- **Import**: Displays the Import Audio dialog box. This dialog box lets you browse to an audio file and import it.
- **Library**: Opens the Audio Library. The Library lists all audio files that are already part of the currently open Adobe Captivate project.
- **Edit**: Displays the Edit Audio dialog box. This dialog box lets you edit the audio file in various ways, such as inserting silences and adjusting the volume.
- **Delete**: Removes the audio file associated with the button.
- **Fade In [#] Seconds**: Specifies the number of seconds until the audio fades in to full volume.
- **Fade Out [#] Seconds**: Specifies the number of seconds until the audio fades out to silence.
- **Settings**: Opens the Audio Settings dialog box. You can change audio settings such as input source, quality level, and calibration. Click the Settings button and make your selections.

Reporting tab

If you want to keep score for the widget or coordinate the score with a learning management system (LMS), use the Reporting tab.

- **Include In Quiz**: The points assigned to the widget are added to the score results for the current quiz.
- **Report Answers**: Sends the score to the learning management system (LMS).
- **Objective ID**: Maps to an objective ID set in your LMS.
**Interaction ID** Sends tracking information to the LMS based on the interaction ID specified by the LMS.

**Points** Points assigned to a correct answer. The maximum is 100 points; minimum is 0.

**Add To Total** The score of the button is added to the quiz total.

**Size And Position tab**
To define the exact size or location of the widget in terms of pixels, click the Size And Position tab. Select from the following options:

- **Left** Position of the left border of the object.
- **Top** Position of the top of the object.
- **Width** The width of the object.
- **Height** The height of the object.
- **Constrain Proportions** Maintains the height-to-width ratio when the object is resized.

**Widget Parameters tab**
The Widget Parameters tab includes parameters that you can use to customize the widget. These parameters are available only if the developer creating the widget has made provisions for customizing the widget. A snapshot of the widget may be displayed in this tab.

**See also**
“Defining project navigation” on page 97
“Learning management system (LMS)” on page 216

**Defining visibility mode for widgets**
By defining the visibility of widgets, developers can make certain facets of the widget available to users for preview or customization.

The visibility status of a widget can be set for the following views:

- Widget tab in the property panel (Stage state): Developers can display a snapshot of the widget in this tab.
- Widget Parameters tab in the property panel (Edit state): The snapshot of the object is usually hidden in this mode, and only the parameters that can be customized are displayed.
- During run time: Developers can define the visibility of an object based on certain parameters.
- Preview panel: To display the SWF file in preview mode, set $wm==preview$ in the code.

The visibility state is undefined for widgets. Use the `movieHandle.widgetParams` property to set the visibility state.

Use the following tips when making visibility decisions:

- Decide whether the widget is visible in the following cases:
  - Edit area
  - Property Inspector
  - During run time

Updated 19 May 2009
• Optimize the code for drawing. Excessive use of this code can slow down the player. The widget dialog box might not disappear even after the OK button is clicked.
  • Optimize the code in the OnEnterFrame function for the widget so that CPU use is kept to a minimum.
  • The drawing code is CPU intensive. Store states inside variables and use them to draw only when required.
• To test for Flash-related issues, you can simulate the way the widget appears in the Edit or Stage mode within Flash without launching Captivate. Hard-code \texttt{wm = 'Stage'} and \texttt{wm = 'Edit'} in the OnEnterFrame function. Similarly, to simulate the behavior of the widget at run time using Flash, hard-code \texttt{widgetParam}, and then test.
• Use the \texttt{trace} command to debug SWF files. Ensure that you delete the command during final testing as it degrades performance.
  • Ensure that you publish to the following only:
    • Flash 8 and later
    • ActionScript 2.0 or ActionScript 3.0.

\textbf{Defining the preview movie}

You can provide a dummy SWF file that appears in the preview area when the user selects a widget in the Widget panel. The dummy SWF file gives users an idea of how the widget works.

Explore the PieChart.fla to get a better understanding of the procedure for defining a preview movie.

1. Open the PieChart FLA file for the pie chart in Flash. This file is available on your computer in the \texttt{\Program Files\Adobe\Adobe Captivate <Version number>\Gallery\Widgets} folder.
2. In the Property Inspector, select the movie outside the Stage. The name of the movie \texttt{PieChart_prvw} is displayed in the Property inspector.
3. Right-click the frame containing the action, and select Actions.
4. Locate the following piece of code.

   \begin{verbatim}
   if (wm == 'Preview')
   {
     PieChart_prvw._visible = true;
   }
   \end{verbatim}

The code sets the movie to preview mode and displays the movie in the preview area when the user selects the widget. If you set the visibility to \texttt{false}, the widget is not displayed in the preview area.
Sample code for defining visibility for different modes

```javascript
function cpSetValue( variable:String, val ) {
    if(variable == 'movieHandle') {
        movieHandle = val;
        mainmov = movieHandle.getMovieProps().variablesHandle;
    }
    if (variable == 'widgetMode') {
        widgetMode = val;
    }
}
this.onEnterFrame = function() {
    var wm:String = widgetMode;//this variable will be provided by Captivate App or Captivate Movie
    if(wm == undefined) {
        wm = widgetMode;
    }
    if(wm == undefined) {
        wm = 'Stage';
    }
    if(wm == 'Edit') {//Property inspection inside Captivate app
        button1._visible=true;
    }
    else if (wm == 'Preview') {
        button1._visible=false;
    }
    else { //this is the stage mode
        button1._visible=true;
    }
}
```

Using XML in widgets

Widgets use XML to pass data from Flash to Captivate. The following examples illustrate widgets called by Adobe Captivate.

**Example 1: Creating objects inside Flash ActionScript**

```javascript
var _parameters: Object = new Object();
_parameters.country = txtCountry.text;
return _parameters;
```

This code segment creates an object named _parameters and assigns the field country to it. When the _parameters object returns, Adobe Captivate stores it in XML format for future use (for example, for publishing in a certain language).
Example 2: Playing a movie containing a widget

```actionscript
if(movieHandle.widgetParams !== undefined && movieHandle.widgetParams !== '') // at runtime inside Captivate movie
{
    trace("widgetParams = " + movieHandle.widgetParams);
    var x:XML = new XML(movieHandle.widgetParams);
    var countryName = x.firstChild.firstChild.firstChild.firstChild.nodeValue;
    ShowRandomizedCountryName(countryName);
    initDone = true;
}
```

The visibility state is undefined for widgets. You set this state using the `movieHandle.widgetParams` property, which contains values derived from Adobe Captivate.

The `trace` command prints `widgetParams`, which is a string in XML format. You can access the nodes of the string using XML. Read the code to understand how your data is stored so that you can reach the node you need. To parse the string, use XML that is an ActionScript construct. For more information, see the ActionScript documentation in Flash.

**See also**

Flash ActionScript Dictionary

Using variables in widgets

To use an Adobe Captivate variable in widgets, specify the variable within `$$. You can use both user-defined and system variables in widgets. The widget can get and set variables within the Captivate demo.

For example, the user-defined variable `$$username$$` in a Certificate widget fetches the name of the user and displays it in the certificate.

Using ActionScript 3.0 in widgets

Changes in ActionScript from version 2 to version 3 warrant changes in how constructs access Adobe Captivate demos. Some of the changes are documented here.

• To declare `onEnterFrame` specify `this.addEventListener("enterFrame",onEnterFrame);`

• Use `void` instead of `Void`

• External interface takes only two parameters now. For example,
  ```actionscript
  ExternalInterface.addCallback("isStatic", isStatic);
  ```

• Use `parent` instead of `_parent`

• Use the following code in the ActionScript file:
function cpSetValue(variable:String, val):void
{
    if (variable == 'widgetMode')
    {
        widgetMode = val;
    }
}

ExternalInterface.addCallback("cpSetValue", cpSetValue);

- The way to get `widgetParam` has changed in ActionScript 3.0 because of changes in the structure of Captivate demos:
  ```actionscript
  var slide:Object = parent.parent.parent;
  var slideXML:XMLList = XMLList(slide.slideXML);
  var parname:String = parent.parent.name;
  var ItemXML:XMLList = XMLList(slideXML.ItemList.Item.(@name == parname));
  widgetParam:String = ItemXML.widgetParams;
  ```
- Understand the new way of parsing XML.

*Note:* Ensure that the version of ActionScript for the widget matches the ActionScript version used for the Captivate demo. ActionScript 2.0 widgets do not work in movies published using ActionScript 3.0, and the other way around.

### Accessing Adobe Captivate movie properties

**MovieHandle**

Adobe Captivate passes a handle to the widget during runtime using the `cpSetValue` function. The widget has to implement something like the following inside its `cpSetValue` function.

```actionscript
function cpSetValue( variable:String , val )
{
    if(variable == 'movieHandle' ) {
        this.movieHandle = val;
    }
}
```

**Methods and properties**

Using `MovieHandle`, the following properties can be accessed.

- **widgetParams** The widget parameter provided by the widget during edit time. In AS3 it is a function, `movieHandle.widgetParams()`, and in AS2 it is a property, `movieHandle.widgetParams`.
- **replaceVariables(var:String)** Any string with variable names enclosed in `$$` is replaced with the value of the variable at runtime. For example, `movieHandle.replaceVariables( $$JohnDoe$$ scored $$cpQuizInfoPointsscored$$ out of $$cpQuizInfoTotalQuizPoints$$)` returns "JohnDoe scored 10 out of 100" assuming that JohnDoe scored 10 points out of the total 100 that was set in Adobe Captivate.
- **getContainerProps()** Returns the properties of the container.
- **containerType** Returns one of the following: Slide, Slidelet, Zoom Destination Slide, Zoom Destination Slidelet, Movie (in case of rest of project widget)
getSlideProps() Returns the properties of the slide containing the widget. The returned object has the following members:

- slideType Returns one of the following: Normal Slide, Question Slide, or Random Question Slide.
- slideHandle Handle to the slide functions. slideHandle supports the following functions: AddNoSkipFrame, startFrame, and endFrame.

AddNoSkipFrame(frameNum:Number): No frame is skipped at runtime. frameNum refers to the frame number with respect to the slide indexed from 1.

The Adobe Captivate SWF uses a functionality called “pacemaker” at runtime. When there are insufficient system resources, the pacemaker skips frames in a way that the user does not notice any glitch in the movie. However, it is possible that a frame containing actions might get skipped in the process. AddNoSkipFrame is used to ensure that pacemaker does not skip the specified frame.

startFrame returns the frame number at which the slide begins. The indexing begins with zero.

endFrame returns the frame number at which the slide ends. Indexing begins with 0.

getMovieProps Returns the properties of the Adobe Captivate movie that is closest to the hierarchy of the widget. The returned object has the following members:

- contentWidth Width of the movie's content.
- contentHeight Height of the movie’s content.
- variablesHandle Some Adobe Captivate System variables are accessed from here. For example,
  movieHandle.GetMovieProps().variableHandle.myVar = 10;

movieHandle <deprecated> Handle to the main movie object(rdMovie) in captivate runtime. Only some Adobe Captivate system variables are available here.

IsWidgetVisible Returns if the widget is currently visible on stage.

isWidgetEnabled Returns whether the widget is enabled. A widget is considered as enabled when it is present on the slide or on the Timeline. All functions discussed work only if isWidgetEnabled() returns true.

Guidelines for using movieHandle in widgets

The value of movieHandle must be updated by the widget whenever cpSetValue('movieHandle', val) is called. When it is called multiple times, the value might not be the same every time. The variables must be updated for every call.

GetSlideProps and GetMovieProps consume a lot of memory resources. So, use these calls sparingly. Best practice is to cache the return value to a variable and use the variable. Refer to the following example.
var slideProps:Object;
var movieHandle:Object;
function cpSetValue( variable:String , val ) {
    if ( variable == 'movieHandle' ) {
        movieHandle = val;
    }
}
function onWidgetEnabled(){
    slideProps = movieHandle.GetSlideProps();
}
function myWidgetFunction (){  
    if(slideProps.slideType == "Question Slide") {
        myLabel.Text = "" ;
    }
}

Ensure that operations are carried out during Adobe Captivate runtime only when the widget is enabled. Operations on movieHandle (particularly variablesHandle) when the widget is not enabled might lead to unexpected results.

Question widgets

Question widgets should implement the following functions in addition to the functions discussed in this topic.

getWidgetQuestionState() This method is called when the user clicks Submit on the question slide. The method provides the widget with an option to restore its state when the quiz is restored in an LMS. This function should return a non-empty string in a way that it can restore its state when the widget is reloaded.

setWidgetQuestionState() Restores the widget to its previous state. setWidgetQuestionState() is called when the widget is reloaded in the LMS.

function getWidgetQuestionState()
{
    trace("get Widget Question State");
    return ";"+var1+"<var1>"+var2+"<var2>"+var2+"<var2>";
    //Should be a non-empty String. Should not contain _ and ;
}
function setWidgetQuestionState( val:String)
{
    trace("Set Widget Question State()" + val );
}

For example, let us consider that the state of the variables is var1=10, var2="Captivate" when Submit is pressed and the function is called. Open the Adobe Captivate quiz in LMS, attempt the question, and press Submit. The getWidgetQuestionState function is called. Re-open the quiz in LMS. When the widget question is shown, function setWidgetQuestion is called with the same string: ";<var1>10</var1><var2>Captivate</var2>"

answers() Displays the review feedback. The function returns an array of Objects() with the following properties.

- answerID A unique ID for every answer.
- chosenAnswer String representing the answer chosen by the learner.
- correctAnswer String representing the correct answer.

For example,
function answers():Array {
    var answers:Array = new Array();
    var ans : Object = new Object();
    var ans2 :Object = new Object();
    ans.answerID = "10";
    ans.chosenAnswer = "Hi..Hi...";
    ans.correctAnswer = "Hello...Hello...";
    answers["firstanswer"] = ans;
    ans2.answerID = "12";
    ans2.chosenAnswer = "Hi2..Hi2...";
    ans2.correctAnswer = "Hello2...Hello2...";
    answers["first2answer"] = ans2;
    return answers; }

Add widgets

Add a widget from the Widget panel

By default, the widgets available in the Widget gallery appear in the Widget panel. The Widget gallery is created in the
\Program files\Adobe\Adobe Captivate <Version number>\Gallery\Widgets folder when you install the application. The Widget panel shows only those widgets created using the ActionScript version set in the Publish Settings menu of the Preferences dialog box. To display widgets of another ActionScript version, change the settings in the Preferences dialog box.

1 Open a project in Edit mode.
2 Select Window > Widget.
3 In the Widget panel, select a widget. A preview of the widget is displayed in the Widget panel.

Note: You can sort the widgets in the Widget panel as Static, Interactive, or Question by selecting the corresponding option in the menu.

4 Do one of the following:
   • Click Insert.
   • Double-click the widget
   • Drag the widget to the slide.
5 In the Widget dialog box, specify the options for the widget in the Widget tab and Widget Parameters tab. For more information, see “Properties of widgets” on page 117.

Add a widget from the Insert menu

1 Select Insert > Widget.
2 In the Open dialog box, browse to the folder containing the widget, and open it.
3 In the Widget dialog box, specify the options for the widget in the Widget tab and Widget Parameters tab. For more information, see “Properties of widgets” on page 117.

Add a widget from the object toolbar

1 Click the Widget icon on the Object toolbar.

Updated 19 May 2009
In the Widget dialog box, specify the options for the widget in the Widget tab and Widget Parameters tab. For more information, see “Properties of widgets” on page 117.

Troubleshooting widgets

Use the trace command to print values of widgets. When the command is tested using Flash, the print statements appear in the output window.

In Adobe Captivate, you can print the trace messages to a text file using the instructions given at http://www.adobe.com/devnet/flex/articles/client_debug_print.html. The document is for Flex, but it is valid for Flash also. http://kb.adobe.com/selfservice/viewContent.do?externalId=tn_19323.

Alternatively, you can also devote a text area in a widget to viewing the debugging messages.

Updated 19 May 2009
Chapter 10: Audio

Adding audio

You can add audio to your project by doing one of the following:

• Narrating the movie into a microphone as you record the project.
• Importing audio files into the movie after you complete recording it.
• Converting slide notes to speech using the Convert to Speech option.

You can add audio to any of the following in Adobe Captivate:

• Slides
• Project
• Objects

The audio file plays when the slide, project, or object appears in the movie.

Recording in sync

Add sync sound (synchronized sound recording) to your projects by narrating the movie into a microphone as you record it. The movie is recorded in the stereo format.

Recording equipment

Having the right audio equipment makes a big difference in the quality of recorded audio.

Computer with sound card  The sound card installed with your computer acts as a digital recorder for audio.

Microphone  If possible, avoid using the inexpensive microphone packaged with your computer. Also, use a proper microphone cable and a stand to hold the microphone while you are recording.

Microphone preamplifier  A preamplifier boosts the signal of the microphone. The microphone input of your sound card probably includes a preamplifier, but it is most likely of poor quality. When purchasing a preamplifier, you can choose a small mixer or a stand-alone version. Mixers let you connect several microphones and devices to one location and adjust their volumes independently. Stand-alone preamplifiers are considered better than mixers at filtering out unwanted noises.

Speakers  The speakers that came with your computer are probably good enough for recording purposes. You can change some of your speaker settings if required. However, if you are working on a laptop, use standard desktop computer speakers instead of the built-in laptop speakers.

Note: In Microsoft Windows, the speaker settings are located in the Control Panel.

Headphones  Headphones are important because when the microphone is on, speakers can cause distracting feedback. Additionally, it is best to use closed-ear headphones that prevent leaking sound (which can be picked up by the microphone).

Media players  Any software that can play audio files on your system.
Recording software A wide range of recording software is available. Important software features include editing functionality (to fix mistakes), music and sound effect options, and the capability to create the file format you require (such as mp3 or WAV).

Recording area After you have acquired the necessary audio equipment, the most important action you can take before recording is an obvious one: find a quiet place to record. Try closing doors, turning off any unnecessary computer equipment, turning off or lowering lights, turning off phone ringers, beepers, and pagers. Inform your coworkers that recording is in progress.

Tips for recording audio

Follow these tips to ensure that you are recording the highest quality audio possible.

Setup After you have acquired the necessary audio recording equipment, ensure that it is set up properly. First, plug your microphone into your mixer or preamplifier, and then plug the output of that device into your computer sound card’s "line in." Plug your headphones into your computer. Then, set the volume on your mixer or preamplifier. Begin speaking to test the volume levels, and carefully raise the volume until it shows just under zero.

Sound card settings Open the software application that controls the sound card. The sound settings are located in the Control Panel. Select the recording source (Line In) and adjust the volume to 100%. You control the actual recording level with your mixer or preamplifier.

Audio recording software settings Start your audio recording software. Change the settings as necessary. Note that mixers and preamplifiers do not have sound-level controls, so you rely on the meters when recording. While recording, ensure that you do not exceed zero on the meters, or the sound will be distorted.

Microphone placement Positioning your microphone correctly can make a big difference in the finished audio file. First, get close to the microphone (within 4 to 6 inches), so any other nearby sounds have less chance of being recorded. Don’t speak down to the microphone; instead, position it above your nose and pointed down at your mouth. Finally, position the microphone slightly to the side of your mouth, because this can help soften the sound of the letters S and P.

Microphone technique Have a glass of water nearby so you can avoid “dry mouth.” Before recording, turn away from the microphone, take a deep breath, exhale, take another deep breath, open your mouth, turn back toward the microphone, and start speaking. This trick can eliminate breathing and lip-smacking sounds frequently recorded at the beginning of audio tracks. Speak slowly and carefully. You may feel that you are speaking artificially slowly, but you should be able to adjust the speed later by using your audio recording software. Finally, bear in mind that you don’t have to get everything right the first time. You can listen and evaluate each recording and rerecord if required.

Audio editing Editing sound is similar to editing text. Listen carefully to your recording. Delete any extraneous sounds and then use the options available in your software to polish the track. Add any music or sound effects you require. Make sure you save your audio track in the correct format (mp3 or WAV files).

Adding audio files to Adobe Captivate When you are finished recording the audio file, add it to the Adobe Captivate project.

Additional feedback After you add the audio to the Adobe Captivate project, listen to it again. Play the project as users normally would. Finally, ask others to preview the Adobe Captivate SWF/audio file. If necessary, edit the audio file again.

Set audio recording preferences

Audio files present the common challenge of balancing quality against size. The higher the sound quality, the larger the file size. The more you compress a sound and the lower the sampling rate, the smaller the size and lower the quality. Adobe Captivate lets you control the way sound is recorded and compressed based upon your input and output requirements.
Creating audio in Adobe Captivate is essentially a two-part process. You record audio in WAV format, and then Adobe Captivate converts the WAV file into an mp3 file. When files are in WAV format, they have a degree of flexibility. You can edit and adjust them “downward,” compressing them into mp3 files uniquely tailored to their playback scenario.

When working with audio, keep your users in mind. If a user is likely to access the Adobe Captivate project by using a dial-up modem, use a higher compression/lower sampling rate, such as 56 Kbps. However, if you are distributing the project on a CD-ROM, you can use a lower compression/higher sampling rate, such as 144 Kbps. In the best development case, experiment to find the optimal balance between sound quality and file size for your users.

Using Adobe Captivate, you can record an audio file for a single slide, group of slides, or for the entire project.

**Note:** For slides with unique audio files, the Timeline of the slide is stretched to meet that of the audio file. However, audio files for a project are cut short if they exceed the project Timeline.

1. In an open project, select Audio > Record.
2. In the Record Audio dialog box, configure the following according to your preferences:
   - **Project** Record the audio file for the entire project.
   - **This Slide** Record the audio file for the selected slide.
   - **Slide** Record the audio file for a group of slides starting with the selected one. To finish defining the range of slides included in the group, enter a slide number in the To field of the Record Audio dialog box.
   - **Movie Preview** The recording window displays a Preview panel where you can view the project as the audio gets recorded.
   - **Continuous Play** Select this option if you want the file to play until the end of all the selected slides or the end of the project.
   - **Preview Pane** You can preview the slides as they are being recorded in this panel.
   - **Captions and Slide Notes** Use these options when you want to record voice-over narration that matches the caption text or slide note text. Read aloud the text that you have added to these areas when recording audio.
   - **Record New Audio** Click to begin recording audio.
   - **Play Audio** Click Play Audio to play the audio file after you have completed the recording.
   - **Stop Audio** Click Stop Audio to stop playing the audio file.
   - **Edit Audio** Click to open the Edit Audio dialog box, which lets you make the following changes to the audio file:
     - Select portions of the audio file and copy them.
     - Delete portions of the audio file.
     - Insert silence.
     - Export to podcast to save the file in WAV or mp3 format.
   - **Settings** Click to open the Audio Settings dialog box, which lets you set recording device and audio quality.
   - **Input Devices** Specifies the type of device you are using to create audio. The options available in your computer are listed in the menu.
   - **Encoding Bitrate** In the Encoding Bitrate area, you can select the bitrate at which audio encoding must be performed. Select one of the following options based on the audio encoding quality you require:
     - **CD Bitrate (128 Kbps)** Specifies the amount of audio information (in Kbps) that will be stored per second of a recording, which is of CD quality.
• **Near CD Bitrate (96 Kbps)**  Specifies the amount of audio information (in Kbps) that will be stored per unit second of a recording, which is of a near-CD quality. By default, this option is selected.

• **FM Radio Bitrate (64 Kbps)**  Specifies the amount of audio information (in Kbps) that will be stored per second of a recording, which is of FM radio quality.

• **Custom Bitrate**  Specifies the amount of audio information that will be stored per second of a recording, which is of a user-defined quality. You can drag the slider bar to set the required bitrate.

**Encoding Frequency**  The sampling frequency that is used when the audio file is published. Encoding frequency is the sampling rate of the audio file. The higher the frequency, the better is the quality of the published audio file. However, the increase in quality also results in an increase in the size of the audio file. For normal audio files, a lower frequency might not change the quality of the audio file significantly. However, for higher quality audio files, like those for music, a higher encoding frequency is desirable.

Note that the encoding frequency does not affect the file that is recorded. Adobe Captivate records and stores all audio files using the encoding frequency of 44.100 KHz.

**Encoding Speed**  The speed at which the encoder converts the WAV file to an mp3 file. Higher encoding speeds might reduce the quality of the final output. The speed of publishing the project might increase when you choose a higher encoding speed.

**Calibrate Audio Input**  Click to display the Calibrate Audio Input dialog box. You are prompted to read a sentence into the recording device if you are using a microphone. Adobe Captivate uses the sample recording to detect optimal recording sensitivity levels. It is important to calibrate your recording device for optimal sound quality.

**Fade In and Fade Out**  Set a time, in seconds, for the audio file to fade in and fade out at the beginning and end of the project.

**Lower Background Audio Volume On Slides With Additional Audio**  Automatically reduces the background audio volume on slides that have individual audio files assigned, such as voice-over narration.

**Loop Audio**  The background audio file replays continuously.

**Stop Audio At End Of Project**  Stops the background audio when the project ends.

### Calibrate microphone

If you are recording audio for a project, you must set the microphone or recording device to the correct recording level. This process is called calibrating the recording device. Adobe Captivate can detect optimal microphone and recording sensitivity levels automatically.

**Note:** Adobe Captivate must be able to detect a recording device before trying to calibrate. Check that a microphone or recording device using “line in” is connected to your computer properly and is turned on before calibrating.

1. In an open project, select Audio > Settings.
2. Click Calibrate Audio Input.
3. To set the correct recording device level, read the following sentence into the microphone until the red recording window becomes green:
   
   “I am setting my microphone recording level for use with Adobe Captivate.”
4. When you finish, click OK.
Record audio

If you have a microphone connected to your computer, you can record audio to be included on a slide. You can use audio for many types of narration or instruction.

1. In an open project, select Audio > Record from the main menu, and select one of the available options: This Slide, Project, or Slide.

2. If you want to set recording options, click Settings and make the necessary changes. Depending on the type of recording (voice-over, music, and so on) and the desired playback (within an EXE file, over the Internet, and so on), you may need to adjust audio settings.

3. (Optional) If you have created text captions or slide notes that can be used as a script, add them to the fields in the Captions and Slide Notes tabs.

4. Click Record New Audio to begin recording.

5. Speak into the microphone or recording device. Or, if you are using a line-in device (such as a CD) or a system file, run the file you want to record.

6. When you finish, click Stop Audio.

   The audio is converted to mp3 format.

7. Click Play Audio to listen to the recording.

8. (Optional) If you want to add silence or adjust the volume for the audio file, click Edit Audio and use the options to change the settings.

9. When you finish, click OK.

Record audio while creating a project

Adobe Captivate lets you record an audio track at the same time you record a new Adobe Captivate project. This can be a very efficient way to create a full-featured project quickly.

The following procedure describes how to record audio while creating an Adobe Captivate project about an application.

1. Open the application you want to record. (You must do this before recording.)

2. Prepare your recording equipment.

3. Open Adobe Captivate.

4. Select File > New > Project.

5. In the New Project dialog box, select the Record tab.

6. Do the following:
   - Select a recording mode
   - Select the window you would like to record
   - Customize the other available options.

7. In the recording window, select the type of recording, and choose the type of audio input from the Audio menu.

8. Click Record New Audio.

   If this is the first time you are recording audio, a dialog box appears asking if you would like to test audio levels. Click Yes to calibrate the recording device for optimal recording. Follow the instructions and when you finish, click OK.

Updated 19 May 2009
As you record the project, speak into your microphone or recording device to create an audio sound track. For example, you can explain the actions you are taking or read the text on captions.

When you finish recording, press the End key (or other designated key) to stop recording.

The slides are generated and your new project appears in Storyboard view. The audio files you recorded are assigned to the correct slide and saved as individual mp3 files. You can view the files in the Library.

*Note: If you need to pause the recording process, press the Pause/Break key. To restart project recording, press the Pause/Break key again.*

**Record audio for objects**

You can record an audio file to use with buttons, highlight boxes, click boxes, or text entry boxes. Recording audio requires some basic equipment.

*Note: You can also add existing audio to text entry boxes, captions, slides, slidelets, and so on.*

1. Right-click the object to which you want to add audio, and select Properties.
2. Select the Audio tab.
3. Click Record New Audio.
4. When you finish recording, click Stop Audio.
5. To listen to and test the audio file, click Play Audio.

**Insert audio**

Adobe Captivate lets you add narration, music, step-by-step instructions, or almost any sound to your projects.

You can use audio in Adobe Captivate projects in a variety of ways. For example, you can do the following, all in the same project:

- Add a background track that plays for the duration of the project.
- Add sound to an individual slide.
- Add sound to a specific object, such as a caption, click box, highlight box, or button.

Adobe Captivate lets you record your own audio files (using some simple equipment) or import existing files. You can record audio files at the same time you record the project, or you can add an audio file later. Imported files can be in WAV or mp3 format. (If you add a WAV file to a project, Adobe Captivate automatically converts the WAV file to mp3 format when you publish the project.)

After you add audio to a project, you can adjust the timing of objects to fit the sound file precisely. Adobe Captivate also contains features for adding silence to audio files and for normalizing audio for all slides so the sound level is consistent.

Adobe Captivate contains a gallery that has buttons, sounds, and animations (in SWF format) for you to use in your projects. By default, the gallery is stored in the following location when you install Adobe Captivate: C:\Program files\Adobe\Adobe Captivate 4\Gallery.

You can attach an audio file to a button or click box and have the audio play when the user clicks the button or click box instead of when the button or click box is displayed. To do this, create the button or click box and select the Success Caption option. Make the Success Caption transparent and do not add any text. Add an audio file to the Success Caption.
**Import audio**

You can import an audio file to use with slides, buttons, highlight boxes, click boxes, or text entry boxes. You can also use the Library to add an audio file that is already in your current project.

1. In an open project, double-click the slide or object to which you want to add audio.
2. Click the Audio tab.
3. Click Import.

   *Adobe Captivate contains a gallery that has buttons, sounds, and animations (in SWF format) for you to use in your projects. By default, the gallery is stored in the following location when you install Adobe Captivate: C:\Program Files\Adobe\Adobe Captivate 4\Gallery.*

4. Browse to the audio file you want to add, select the file, and click Open.
5. (Optional) To listen to and test the audio file, click Play Audio.
6. Set other options as necessary.
   - To edit the audio file (for example, change volume, add silence, change length, and so on), click Edit.
   - If you want the audio to fade in or fade out, set the number of seconds using the arrows in Fade In and Fade Out.
7. When you finish, click OK.

**Add audio from library**

You can reuse existing audio files for slides in a project. When you insert a new object (such as an image or video) into your project, Adobe Captivate enables the Library button on the Audio tab of the New Item dialog box. You can then browse the Library for an existing audio file.

1. In an open audio project, click the Audio tab or the Background Audio tab, or select Audio > Edit > Slide.

   *Note: Edit option is enabled if a question slide or a project slide contains an audio file. It is disabled for question pools and random question slides.*

2. Click Library.
3. Select a file from the list of Library files.

**Create background audio**

You can create background audio for your projects. The audio plays while the slides of your project are shown. Background audio can be music, sound effects, or almost any kind of sound you can import or record.

You can use background audio together with individual slide audio for a truly professional effect. Adobe Captivate provides an option to lower the volume of background audio when a slide with audio assigned plays. For example, you can import a music file and set it to loop continuously as background audio. In that same project, you can record voice-over narration for individual slides, and when the voice-over audio plays, the music volume is lowered.

1. In an open project, select Audio > Background Audio.
2. Do one of the following:
   - Import an existing audio file by clicking Import, navigating to the file, selecting the file, and clicking Open. (If you want to use an audio file that is already in your project, click Select Audio From Library.)
   - Click Record New Audio and follow the instructions to record the background audio.
3. (Optional) click Play Audio to listen to the audio file.
4 Select from the following options:

- **Fade In and Fade Out**  
  Lets you set a time, in seconds, for the audio file to fade in and fade out at the beginning and end of the project.

- **Lower Background Audio Volume On Slides With Audio**  
  Automatically reduces the background audio volume on slides that have individual audio files assigned, such as voice-over narration.

- **Loop Audio**  
  The background audio file replays continuously.

- **Stop Audio At End Of Project**  
  Stops the background audio when the project ends.

### Use a custom keyboard tap sound

Adobe Captivate includes a feature that records a keyboard tap sound whenever you press keys on the keyboard while recording a project. You can include or exclude the tap sounds. You can also create a custom keyboard tap sound to use.

1 Create a new sound for keystrokes, or use an existing mp3 file (for example, one of the Windows sound files.)

2 Name the new sound file KeyClick.mp3.

3 Save the file and note the location to which the file is saved.

4 Using Windows Explorer, browse to the Adobe Captivate sound effects folder. (The default location is \Program Files\Adobe\Adobe Captivate 4\Gallery\SoundEffects.)

5 Locate the file named KeyClick.mp3. This is the Adobe Captivate default keystroke sound file.

  **Note:** Before overwriting the file, you may want to copy and place the original KeyClick.mp3 file in a backup folder so it can be used again if necessary.

6 Copy the new keyboard tap sound from the location in step 3 above, and paste it into the Adobe Captivate sound effects folder.

7 Check that the keyboard tap sounds option is selected.

   **Note:** To delete a tap sound, deselect Play Tap Audio For Recorded Typing in the Category panel of preferences.

### Preview audio

After you add an audio file, you can preview the audio to test it.

There are two methods for previewing audio. First, you can preview the entire Adobe Captivate project and listen to the audio associated with an object, a slide, or the background. This lets you see exactly where the audio begins and ends in the project and enables you to experience the audio as your users will.

Second, if you need to preview only the audio without hearing it in the context of the project, you can open an object, slide, or background audio and play the audio file.

### Preview object audio

1 In an open project, double-click a slide containing an object with associated audio.

2 Double-click the object with associated audio.

3 Click the Audio tab.

4 Click Play Audio to listen to the audio file.
Preview slide audio
1 In an open project, double-click a slide containing audio.
2 Select Audio > Record.
3 In the Record Audio dialog box choose one of the following options: This Slide, Slide, or Project.
4 Click the Play button to listen to the audio file.

Preview background audio
1 In an open project, select Audio > Background Audio.
2 Click Play Audio to listen to the audio file.

Edit audio

Edit audio files
You can edit the audio files in your Adobe Captivate project at any time. Using the Edit Audio dialog box, you can listen to an audio file, insert silence, adjust volume, and change numerous other options.

1 From Storyboard view or the Filmstrip in Edit view in an open project, find a slide containing audio.
2 Do one of the following depending on your requirement:
   • Select Audio > Edit > Slide.
   • Select Audio > Edit > Project.
   
   Note: The Edit option is enabled if a question slide or a project slide contains an audio file. It is disabled for question pools and random question slides.
3 Make any necessary edits in the Edit Audio dialog box. You can cut and paste sections of the audio file, insert periods of silence to lengthen the audio file, adjust volume, import a different audio file, and use more options.
   
   Cut Selection  Click to cut the selected portion of the audio file.
   Copy Selection  Click to copy the selected portion of the audio file.
   Paste Selection  Click to paste information from the clipboard. (For example, if you select a section of the audio file, and then click the Cut Selection or Copy Selection button, the selected audio is placed on the clipboard. You can then use the Paste Selection feature to place the audio located on the clipboard back into any location within the audio file.)
   Delete Selection  Click to remove the selected portion of the audio file.
   Undo  Click to undo the last action taken.
   Redo  Click to redo the last action taken.
   Insert Silence  Select the portion of the audio file where you want to insert silence, and click Insert Silence. Choose from one of the following options:
      • Current Selection  Replaces the selected portion of the audio with silence.
      • Start Of Audio  Adds silence to the beginning of the audio file.
      • End Of Audio  Adds silence to the end of the audio file.
• **Playhead Position**  This option is available only when you have not selected a portion of the audio file. The silence is inserted at the playhead position. Use this option when you want to insert an extremely brief period of silence.

  **Adjust Volume**  Click to increase or decrease the sound level of the audio file. There is also an option to fine-tune quieter portions of the audio file.

• **Normalize**  Select this option to have Adobe Captivate adjust the sound volume automatically. Normalizing audio helps keep the sound level consistent between slides.

• **Dynamics**  Select this option to amplify quiet sections of the audio to help compensate for variations in audio volume.

• **Ratio**  Specifies the maximum amplification that will be used. The default setting of 2.0 sets the quietest sections of the audio to be amplified by a factor of 2. A higher setting can improve projects with large differences between quiet and loud sections, but can also amplify background noise.

• **Threshold**  Controls the amplification of background noise. Anything quieter than the noise threshold is not amplified. If background noise is amplified too much, setting a higher noise threshold may help solve the problem. (Note that the Dynamics option does not work well with high noise levels.)

  **Zoom In**  Click to enlarge the waveform.

  **Zoom Out**  Click to shrink the waveform.

• **Settings**  Click to set various options such as recording device, audio quality level, and recording device calibration.

• **Export To Podcast**  Export the audio file as a WAV or mp3. You can later use these files for podcasting. Podcasting refers to distributing files over the Internet through web feeds to portable media players, and computers.

• **Waveform**  Displays the audio file graphically. The waveform is a visual representation of the audio file.

• **Record/Insert New Audio**  Click to begin recording audio. (To record, you need a microphone.)

• **Stop**  Click to stop playing the audio file.

• **Play**  Click to play the audio file.

• **Status**  Displays the status of the audio file as playing, ready, and so on.

• **Playhead**  Displays the selected location, in seconds, within the audio file. For example, if you are working with an audio file that is 10 seconds long and you click in the middle of the file, this playhead area displays approximately 00.05.00, or 5 seconds.

• **Duration**  Displays the total amount of time it takes for the audio file to play.

• **Selected**  Displays the total amount of time selected. For example, suppose you have an audio file that is 20 seconds long. If you click at the beginning of the file and drag to the middle, you will have selected approximately a 10-second span of the file.

• **Scale**  Displays the scale at which the waveform is displayed. (To change the scale, click Zoom In or Zoom Out.)

• **Library**  Displays the Select Audio From Library dialog box, where you can browse to a new audio file and import it.

  4  Click Select Audio From Library to import an audio file from the project’s Library.

  5  When you finish editing the audio file, click OK.

### Edit audio timing

Adobe Captivate lets you edit the timing of audio files after you record or import them. Having control over the timing of audio files gives you the ability to use audio files of different lengths and incorporate them smoothly into projects.
After you record or import an audio file, the file appears as a waveform in the Edit Audio Timing dialog box. If your project contains multiple audio files, you can see which audio files are assigned to specific slides.

❖ In an open project that contains one or more audio files, do one of the following:
  • Select Audio > Edit > Slide.
  • Select Audio > Edit > Project.

*Note: Edit is enabled if a question slide or a project slide contains an audio file. It is disabled for question pools and random question slides.*

Audio files in the Adobe Captivate project are displayed as waveforms. Slide numbers are shown along the top of the waveform so you can see exactly how the audio files are currently distributed across the slides.

• To change how audio files are distributed across slides, click a slide divider and move it to the left or right. The waveform remains static, but you change where the audio file begins to play within the Adobe Captivate project. This option is particularly useful if you have a long audio file and need to experiment with assigning the file to one slide or having it play over multiple slides.

• To listen to audio, click a location within the waveform and then click Play Audio. The audio plays from the location you selected to the end of all the audio in the project. (You can stop the playback at any time by clicking Stop.)

• To zoom in on a particular area of the waveform, click in the waveform and then click Zoom In or Zoom Out. (Alternatively, click in the waveform and roll your mouse wheel to zoom in and out.) The scale at which you are viewing the waveform is shown in the Scale information box near the lower-right corner of the dialog box.

• To cut or copy and paste audio, select a section of an audio file directly in the waveform, click Cut Selection or Copy Selection, click in a different location on the waveform, and click Paste Selection.

• To delete audio, select a section of an audio file directly in the waveform and click Delete Selection.

• You can insert a silent period within an audio file. If you want the silent period to begin in a specific location within an audio file, click the location directly in the waveform. Click Insert silence. Type in the length of the silent period you want to add and then select from the pop-up menu a location for the silent period: the location you clicked in the waveform, the beginning of audio, or the end of audio.

• To adjust the sound level of audio files, click Adjust Volume. Use the slider bar to increase or decrease the volume and select audio processing options.

• To set recording device and audio quality options, click Settings.

• To add a new audio file, click a location within the waveform, click Select Audio From Library, navigate to a file, and click Open. The audio file is imported directly into the Adobe Captivate project in the location you specified.

### Add silence to an audio file

You can add a period of silence to any audio file that is part of an Adobe Captivate project. This feature is particularly useful if you have imported an audio file and need to synchronize the audio with objects and slides. By adding silent periods, you can make the existing audio file work in an Adobe Captivate project without having to edit the audio extensively.

1 In an open project, select a slide that contains one or more audio files, and do one of the following:
  • Select Audio > Edit > Slide.
  • Select Audio > Edit > Project.

2 You can add silence to the beginning of the audio file, to the end, or to a specific location within the audio file. If you want to add silence within the file, click the exact location directly on the waveform.
Note: The Playhead and Selected information boxes near the bottom of the dialog box can help you choose a precise location in the audio file. For example, if you want to add a silent period four seconds into the audio file, click the waveform until the Playhead information box displays a number close to four seconds (that is, 00:04.00).

3 Click Insert Silence.

4 Select the portion of the audio file where you want to insert silence, and click Insert Silence. Choose from one of the following options:

   - **Current Selection** Replaces the selected portion of the audio with silence.
   - **Start Of Audio** Adds silence to the beginning of the audio file.
   - **End Of Audio** Adds silence to the end of the audio file.
   - **Playhead Position** This option is available only when you have not selected a portion of the audio file. The silence is inserted at the playhead position. Use this option when you want to insert an extremely brief period of silence.

   Note: When you select a part of an audio file, and then click Insert Silence, the pop-up menu lists the Current Selection option instead of the Playhead Position option.

5 Click OK.

The silent period is added to the audio file and you can see the silent period in the waveform. The audio file with added silence is saved under a new file name.

6 To test the audio file with the silent period added, click Play Audio in the bottom left corner.

   If you find that you frequently want to add silence at the same position and of the same duration, press Alt+S to add it without using the Insert Silence dialog box.

**Edit audio using Adobe Soundbooth**

You can use Soundbooth to edit audio when you want to go beyond the audio editing options available in Adobe Captivate. You can batch process audio files by opening multiple audio files for editing in Soundbooth using the Library panel.

1 Select Window > Library to open the Library.

2 Select the files in the library that you want to edit in Soundbooth.

3 Right-click the audio files that you want to edit in Soundbooth.

4 Select Edit With.

5 Select Soundbooth.

**Add closed captions to an audio file**

You can improve the accessibility of your project by adding closed captioning. Closed captioning lets you create transcripts for audio files associated with the slides in your project. When an audio file is played for a slide, the transcripts are displayed, thus aiding hearing-impaired users.

The option that enables closed captioning is available in the Skin Editor dialog box. For more information, see “Slides” on page 39.

1 Select a slide that contains an audio file to which you want to add a closed caption.

2 Select Audio > Audio Management.

3 Click the Closed Caption button.

Updated 19 May 2009
The following options are available in the Closed Captioning dialog box:

**Add** Click to add a caption. A new row appears in the caption window below. Type the closed caption text in the Caption column.

**Remove** Click to delete a selected caption row.

**Zoom In** Click to increase magnification of the waveform.

**Zoom Out** Click to decrease magnification of the waveform.

**Playbar** Use these controls to preview the audio file.

**Caption Window** Each caption appears as a row in this window, with the start time, end time, and caption text. Click any row to edit or delete the text or timing.

4 If you want to preview the audio file, click the Play button.

5 Click the specific spot in the waveform where you want to add a caption and click “+.”

A new caption row appears with the start time you selected on the waveform.

6 Enter the caption you want to attach to the audio file.

7 To add another row to the caption for the audio file, click add. To remove a row from the caption for the audio file, click “-.”

   **Note:** For more precision, you can drag the end and start time markers of your caption if you want to manually adjust the timing of each caption.

8 When you have added all the rows you want, click OK.

You can also open the Closed Captioning dialog box in one of the following ways:

- In Edit or Storyboard view, select a slide thumbnail, click the Audio icon, and select the Closed Captioning option.
- In the Timeline, right-click the Audio layer, and select the Closed Captioning option.
- From the Slide menu, select Properties, and in the Slide Properties dialog box, go to the Audio tab, and click the Closed Captioning button.

   **Note:** Multiple closed captions must be contiguous. If you do not want a closed caption for an intermediate duration, add a blank closed caption for that duration.

### Delete audio from a slide

1 In an open project, do one of the following.
   - In Storyboard view, select a slide and click the audio symbol in the lower-right corner of the slide.
   - In Edit view, navigate to the relevant slide in the Filmstrip and then click the audio symbol in the lower-right corner of the slide.

2 Select Remove.

### Delete background audio

1 In an open project, select Audio > Background Audio.

2 Click the Delete button.
View audio details

You can view all audio details (Audio > Audio Management) in one convenient location in Adobe Captivate. This is an easy way to see the playing time, size, and other attributes of all the audio files in a single project.

Audio details

- **Slide/Object** The slide name.
- **Sound** The presence (Yes or No) of a sound file.
- **Duration** The length of the sound file, in seconds.
- **Fade In** The presence (Yes or No) of a fade-in effect.
- **Fade Out** The presence (Yes or No) of a fade-out effect.
- **Size** The size of the sound file.
- **Original Filename** The original name of the sound file.
- **Display Name** The name of the file after you have renamed it in Adobe Captivate. If you have not renamed the file, the original name is displayed.

Audio Sample Rate (kHz) This rate is the number of times per second the original waveform is translated into digital form. A higher sample rate results in a more accurate digital representation of the sound. The sample rate for CD-quality audio is 44,100 samples per second.

Bitrate (Kbps) This rate is the number of bits a digital file uses in a specific time period, usually expressed as kilobits per second. The higher the bit rate at which an audio file is encoded, the higher the sound quality; 128 Kbps is a commonly used rate.

**CC** Indicates whether a transcript of the dialogue or sound effects has been included in the audio file.

Slide settings

- **Play** Plays the audio for the selected slide.
- **Stop** Stops the audio from playing.
- **Remove/Delete** Removes or deletes the audio for the selected slide.
- **Export** Opens a Browse For Folder dialog box and lets you export the selected audio file to a folder.
- **Update** Pulls an updated version of the audio file.

Closed Caption Allows you to enter a transcript of the dialogue or sound effects included in the audio file. Closed captioning improves the accessibility of your project for hearing-impaired users.

Show Object Level Audio Displays any audio files associated with objects (click boxes, captions, buttons, highlight boxes, and so on) in the project.

Include MP3 Files In Export Includes mp3 files when you export audio.

Include WAVE Files In Export Includes WAV files when you export audio.

Updated 19 May 2009
Export audio

Export audio from slide
1 In an open project, select Audio > Audio Management.
2 Scroll down and click the slide that contains the audio file you want to export.
3 If you want to export mp3 files, select Include MP3 Files In Export.
4 Click Export.
5 Navigate to the destination folder you want and click OK.

Export audio from project
You can export audio files that have been inserted or recorded. The exported audio files can be used for podcasting.
1 Select the slide whose audio you want to export.
2 Select File > Export > To Podcast.
3 Save the file in WAV or MP3 format.
Chapter 11: Variables and Advanced Actions

Variables

Variables in Adobe Captivate act as placeholders for data. The relevant data is associated with the variable during user input or when the output SWF is played. The data can be used for the following:

- Provide feedback to the user
- Create advanced actions
- Configure widgets

For information on using variables in captions, advanced actions, and widgets, see the respective Help sections.

In Adobe Captivate, you can use variables when working with the following:

- Text captions
- Actions and Advanced actions
- Widgets
- Getting/setting variables in Adobe Captivate SWF files using JavaScript
- Movie navigation

There are two types of variables available in Adobe Captivate: system variables, and user-defined variables.

**System** Variables that are available in the system that you can use. You can also customize the values for some of the system variables.

System variables help you pick up data from your computer and manipulate it through scripting. In Adobe Captivate, system variables are classified as follows:

- **MovieControl** Lists variables for events that control the movie like pause, resume, previous, next slide, and so on.
- **MovieInformation** Lists variables related to the movie such as variables for the current slide, current frame, and so on.
- **MovieMetaData** Lists variables that provide information about the project such as project name, author, and company. You can set values for the variables in this list. You can also set this information using the Preferences dialog box under Project > Info. In project templates, when you set these values using variables, the values are used for the project to which the template is applied.
- **SystemInformation** Lists variables that can be picked up from your computer such as current date and current time.
- **Quizzing** Lists variables related to quizzing, such as the variables that capture the number of attempts and the percentage of questions answered correctly.

For example, you can use the system variable `cpInfoCurrentTime` in quiz slides to display the time remaining for the user to complete answering the question. You can also use the variable in a widget to provide a progress bar or a time ticker.

**User-defined** Variables that you create and to which you assign a name and value.

You can use user-defined variables to store data that is used or updated many times in the Adobe Captivate project. Each variable has a unique name, and a value corresponding to the text that is stored in it. When you modify the value...
of a variable, the changes to the corresponding text are reflected throughout the project. Apart from saving time, variables help achieve consistency and minimize errors in a project.

For example, you can use user-defined variables to specify version numbers of products. At all places where you want to add the version number in a project, add the variable instead. When you set the value for the version number in the corresponding variable, the value is displayed at all places where you inserted the variable. Similarly, when you want to modify the version number, you just have to change the value of the variable.

When you use system variables for this purpose, you do not have to manually correct the slide number when the slides are reordered.

Variables extend the reach of Adobe Captivate by allowing you to do the following:

- Customize Adobe Captivate to your requirements: You can use variables in advanced actions to provide advanced interactivity in your Adobe Captivate projects.
- Integrate Adobe Captivate with other applications: You can use get/set variables in Adobe Captivate from other applications.

**Create a user-defined variable**

1. Select Project > Actions.
2. Select the Variables tab.
3. In the Type menu, select User.
4. Click Add New, and enter the following information:
   - **Name**: Specify a unique name for the variable. Ensure that the name is intuitive enough to help users guess its content. For example, a variable storing the version number of a product would have the name ProductVersion or VersionNumber.
   - **Value**: Specify a value for the variable. The value that you specify occurs at all instances of occurrence of the variable in the document. You can also choose to set the value later by leaving this field blank. Variables with undefined values appear as blank spaces in the project.
   - **Description**: Optionally, add a description for the variable. For example, you could add a note for the authors instructing them about when to use the variable.
5. Click Save.

Some of the variable names are reserved by ActionScript. Do not use the following variable names when creating your variable: abstract, as, boolean, break, byte, case, cast, catch, char, class, const, continue, debugger, default, delete, do, double, dynamic, each, else, enum, export, extends, false, final, finally, float, for, function, get, goto, if, implements, import, in, include, instanceof, interface, internal, intrinsic, is, long, name, namespace, native, new, null, override, package, private, protected, prototype, public, return, set, short, static, super, switch, synchronized, this, throw, throws, to, transient, true, try, type, typeof, use, var, virtual, void, volatile, while, with.

**Customize a system variable**

1. Select Project > Actions.
2. Select the Variables tab.
3. In the Type menu, select System.
4. In the View By menu, select MovieMetaData.
5 Select the variable that you want to modify, and change its value. For example, to assign the name of your company to the `cpInfoCompany` variable, select it from the list. In the Value field, enter the name of your company.

6 Click Update.

**Edit/delete a user-defined variable**

1 Select Project > Actions.
2 Select the Variables tab.
3 In the list of variables, select the variable you want to edit.
4 Do one of the following:
   - To edit the variable, modify the value/description of the variable, and click Update.
   - To delete the variable from the list, click Remove.

*Note:* You cannot delete system variables or variables that are being used by text captions. Removing a variable referenced by an action resets the action to Continue.

**Controlling Adobe Captivate projects with variables**

You can control Adobe Captivate projects with variables that you can set on the Timeline. Controlling a project with variables is useful if you want to create custom SWF playback controls or if you are putting a project into a FLA file.

Using variables is an advanced feature that should be implemented only by users with a solid background in Flash.

*To control the project through the skin file, add the prefix `cpSkinLoader_mc` to the variables.*

The following commands are used by playback controls and preview:

- `rdcmdnPrevious` Set to 1 to go to the previous slide.
- `rdcmdnNextSlide` Set to 1 to go to the next slide.
- `rdcmdnPause` Set to 1 to pause the project.
- `rdcmdnResume` Set to 1 to resume showing a paused project.
- `rdcmdnRewindAndStop` Set to 1 to rewind and stop the project.
- `rdcmdnRewindAndPlay` Set to 1 to rewind and play the project.
- `rdcmdnGotoFrame` Go to a specific frame.
- `rdcmdnExit` Set to 1 to exit.
- `rdcmdnInfo` Display the information window.

The following variables provide information currently used by playback controls and preview:

- `rdinfoFrameCount` Total number of SWF frames in the project (this is not the number of frames in the main Timeline, but the sum of all slide frames).
- `rdinfoCurrentFrame` Current frame (goes from 1 to `rdinfoFrameCount` when you play the project).
- `rdinfoCurrentSlide` Slide currently playing (zero based).
- `rdinfoSlideCount` Number of slides in the project (not including hidden slides).
- `rdIsMainMovie` Can be used to identify whether the SWF file corresponds to the main Adobe Captivate project.
See also
“Text captions” on page 62
“Widgets” on page 113
“Advanced actions” on page 146

Advanced actions

You can use scripting in Adobe Captivate to do the following:

- Enhance the interactivity of Adobe Captivate projects by handling complex, and condition-based interaction scenarios.
- Control the movie.

Advanced Actions model

The scripting for the advanced actions model in Adobe Captivate is based on the Object-Event-Action model. Events on an interactive object, such as mouse-clicks, trigger actions that are defined for that event. You can handle complex interaction scenarios by scripting your own actions and applying them to the various interactive objects. The scripting editor in Adobe Captivate helps you script custom actions for interactive objects.

You can use the following options to define actions for interactive objects in Adobe Captivate:

**Condition** Provide if … else conditions with and/or operators when scripting actions.

**Assignment** Use both system and user variables to define actions. You can use any number of variables during scripting.

**Standard Action** Use a single script to run multiple actions in a sequence. Although the user interface provides a way to run multiple actions, it is restricted to the actions available in Adobe Captivate. During scripting, it is possible for you to combine actions defined during scripting with predefined actions in Adobe Captivate.

Best practice is that you go through the tutorial to get a better understanding of the possibilities of scripting in Adobe Captivate.

Create scripts

1. Select Project > Actions.
2. Select the Advanced Actions tab.
3. In the Edit/Create Action menu, select Create A New Script.
4. In New Action Name menu, enter a name for the action.
5. Double-click Add Statement.
7. Select one of the following options from the menu:
   - **Condition** To create an if … else condition for your script.
   - **Assignment** To assign a variable or value for the condition.
   - **Standard Action** To customize one of the predefined actions in Adobe Captivate.
8 Complete writing the code with the supplied options. Any option that has not been assigned a value is marked in red. Ensure that you set these values before saving the script.

9 You can change the value of variable or literal after you reset it. To reset a variable or literal, click the variable or literal, and click Change Type.

10 Click Save to save the script.

Edit scripts
When editing a script, you can do the following:
• To delete a statement (a line of code), click the arrow icon at the beginning of the statement, and click Remove Selected.
• To change the type from Variable to Literal, or the other way round, select the variable or literal, and click Change Type.
• To remove a condition, select the condition, and click Remove Selected.

Edit/delete/duplicate scripts
1 Select Project > Actions.
2 In the Edit/Create Action menu, select a script that you want to modify or delete.
3 Do one of the following:
   • To update the script, edit it in the Advanced Actions window, and click Save.
   • To start working from a copy of the script, click Duplicate.
   • To delete the script, select the script, and click Delete.

Finding slides in which the script is used
1 Select Project > Actions.
2 In the Advanced Actions tab, select the script from the Edit/Create Action menu.
3 Click Usage.
The slides in the project that use the selected script are displayed.

Apply scripts to slides
1 Double-click the slide to which you want to apply the script.
2 In the Navigation menu for Slide Enter or Slide Exit, select Execute Advanced Actions.
3 Select the script that you want to run from the Action menu.

Apply scripts to interactive objects
1 Double-click the object to which you want to apply the script.
2 In the Action menu, select Execute Advanced Actions. Examples of action menus are On Success, On Failure, Lose Focus, and so on.
3 Select the script that you want to run from the Action menu.
Tutorial on scripting

The following tutorial helps you get started with using scripting in Adobe Captivate.

You have been asked to create a login slide with fields to enter the user name and password.

When the user enters the correct values, the following actions take place:

- The project moves to the next slide.
- A text caption in the next slide displays the message, "Welcome <user name>".
- The default e-mail editor opens with the e-mail ID of the person that must be informed of the login.

When the user enters incorrect information, a text caption is displayed asking the user to reenter information.

Create variables for the project

1. Select Project > Actions.
2. Create a variable named varUserName, with the value user. For more information, see “Create a user-defined variable” on page 144.
3. Create a variable named varPassword with the value password.

Create objects for the slides

1. In Edit mode in an open project, insert two text entry boxes for the user name and password. The text entry boxes must be set to act as form fields.
   
   **Note:** To set a text entry box to act as a form field, deselect Validate User Input in the Options tab of its Properties dialog box.

2. Delete the Submit button from the User Name field.
3. Double-click the text entry field for the user name and set the following options:
   - In the On Success field, select No Action.
   - Deselect Infinite Attempts.
   
   **Note:** This option is disabled automatically when you disable Validate User Input.
   - In the After Last Attempt menu, select Continue.
   - Associate the field with the variable varUserName in the Advanced tab.

4. Double-click the text entry field for the password, and set the following options:
   - In the On Success field, select Continue.
   - Deselect Infinite Attempts.
   - In the After Last Attempt menu, select Continue.
• Associate the field with the variable varPassword in the Advanced tab.

5 Insert a text caption and do the following:
  • Enter the following text on the caption: Invalid username/password. Please try again.
  • In the Options tab of the Properties dialog box for the caption, change the name of the caption to FailureCaption. Deselect the Visible option. Doing so hides the caption until the conditions in the script enable the caption.

6 Insert a blank slide.

7 Insert a text caption with the text Welcome and the variable varUserName in the format Welcome $$varUserName$$.

8 Save the project as variables.cp.

Create a script for the login slide
The script for the login slide must do the following:
  • Check whether the correct information has been entered in the login and password fields.
  • Move to the next slide if the information is correct.
  • Stay at the login slide if the information is incorrect and display a text caption requesting the user to reenter the login information.

1 Select Project > Actions.

2 In the script window, create a script named validate with the following code:

   Check If [varUserName is equal to user] AND [varPassword is equal to password]
   begin
   Continue
   end
   OrElse
   begin
   Jump to slide Slidel
   Show FailureCaption
   end

Now look at individual lines of the code to understand what they do.

Check If [varUserName is equal to user] AND [varPassword is equal to password]

The code checks whether the user has used the user and password login credentials in the respective fields.

Continue

This project moves to the next slide if the user name and password are entered correctly.

OrElse

Begin
Jump to slide Slidel
Show FailureCaption

If the user information is incorrect, the project stays at the login slide. The text caption with the name FailureCaption is displayed.

Create a script for the e-mail and welcome slide
  • In the script window, create a script named sequential action with the following code:
Send e-mail to test@xyz.com in current window and continue playback
Show WelcomeCaption

Now look at individual lines of the code to understand what they do.

Send e-mail to test@xyz.com in current window and continue playback

On successful login, the code opens up the default e-mail editor with the e-mail ID test@xyz.com displayed in the To field.

Show WelcomeCaption

Displays the text caption containing the text, "Welcome <login name>".

**Apply the script to the login slide**

- Double-click the login slide, and set the following options in the Slide Properties dialog box:
  - In the Navigation menu under Slide Enter, select Continue.
  - In the Navigation menu under Slide Exit, select Execute Advanced Actions, and in the Action menu, select Validate.

**Apply the script to the next slide after login**

- Double-click the display slide, and in the Slide Properties dialog box, do the following:
  - In the Navigation menu for Slide Enter, select Execute Advanced Action, and choose sequential action in the Action menu.
  - In the Navigation menu for Slide Exit, select Go To Next Slide.

Run the project, and check whether the aims of the project have been achieved.

**ActionScript**

If you are using Adobe Captivate projects within other applications like Adobe Flash, Adobe AIR applications, and Flex, it is important that you specify the version of ActionScript for the SWF file before publishing it. You cannot set variables within an Adobe Captivate movie if you publish it using an ActionScript version that is not supported by the application. Adobe AIR and Flex support only ActionScript 3.0 whereas Adobe Flash supports both ActionScript 2.0 and ActionScript 3.0.

Users must have Flash Player 9 or later installed on their computers to view Adobe Captivate movies created using ActionScript 3.0.

1. Select Edit > Preferences.
2. In the Category panel, select Publish Settings from the project options.
3. In the Publish Settings panel, select an ActionScript version from the options under ActionScript Version.
Assign multiple actions to an event

You can define multiple actions that are performed sequentially after the occurrence of an event. You can assign multiple actions for the following:

**Interactive objects** You can define the sequence of actions after the user performs an action on an object.

**Slides** You can define the sequence of actions when the user enters or exits a slide.

**Question Slides** You can define the sequence of actions after the user completes answering a question.

For more information on the actions available in Adobe Captivate, see “Defining project navigation” on page 97.

1 In the Navigation menu, select Multiple Actions.
2 Click Browse (...).
3 In the Set Multiple Actions dialog box, select options from the Available Actions list, and add them to the Actions Added list. The actions are performed in the order in which they are added. You can configure some of the actions using the options that are displayed when they are selected.

**Assign** Assigns a value to the variable when the event occurs. Select a variable from the Assign menu, and enter its value.

**Decrement** Decrements the value of a variable with the specified value when the event occurs. Select a user variable from the Decrement menu, and enter a value by which it should be decremented.

**Execute JavaScript** Runs the JavaScript when the event occurs. Enter the JavaScript in the field below the lists.

**Go To Last Visited Slide** Similar to a Back button. The user is taken to the previously visited slide.

**Go To Next Slide** Takes the user to the next slide in the movie.

**Go To Previous Slide** Takes the user to the previous slide in the movie.

**Increment** Increments the value of a variable with the specified value when the event occurs. Select a user variable from the Increment menu, and enter a value by which it should be incremented.

**Jump To Slide** Takes the user to the specified slide. Select a slide from the Slide menu.

**No Action** No action is performed when the event occurs.

**Open Other Project** Opens the project specified in the Project menu. If your project is not listed in the menu, click Browse (...), and navigate to your project.

**Open URL Or File** The movie opens the specified URL or file when the event occurs. Enter a URL or click Browse (...) to select a file.

**Send E-mail To** Sends an e-mail to the address specified in the address field.

**Show** When the user performs the required action, the specified hidden object is made visible

**Hide** When the user performs the required action, the specified object is hidden from the user.

**Enable** When the user performs the required action, it activates another object in the project.

**Disable** When the user performs the required action, it disables another object in the project.

4 Click OK.
You can create a quiz to assess the user’s understanding of the demonstrated feature. Adobe Captivate provides a wide variety of question slides that you can incorporate into your quiz. You can keep your quiz unpredictable by picking questions from a question pool, or by shuffling the answers for a question every time the slide is displayed. You can extend the variety of question slides available in Adobe Captivate by creating question widget slides in Adobe Flash, and inserting them into Adobe Captivate projects.

Preferences

Set quiz preferences
You can configure a general set of preferences that is applied to all the question slides in a project.

1. Select Edit > Preferences.
2. In the Preferences dialog box, select Settings from the Quiz menu.
3. Enter information in the following fields:
   - **Name**  Enter a name for your quiz. In a project with more than one quiz, naming helps identify a quiz easily.
   - **Required**  Select one of the following options from the menu:
     - **Optional – The User Can Skip This Quiz**  Allows users to skip the quiz and move on with the project.
     - **Required – The User Must Take The Quiz To Continue**  The project moves to the next slide only after the user has moved through all the question slides.
     - **Pass Required – The User Must Pass This Quiz To Continue**  The project moves to the next slide only after the user has scored the required points in the quiz.
     - **Answer All – The User Must Answer Every Question To Continue**  The project moves to the next slide only after the user has answered all the question slides.
   - **Objective ID**  The ID of the quiz to which the question slide belongs. In a master quiz containing multiple quizzes, an objective ID helps identify the quiz to which the question belongs.
   - **Interaction ID Prefix**  Every action that the user performs on a question slide is assigned a unique interaction ID. For example, when the user attempts a question incorrectly the first time, and gets it right the next time round, Adobe Captivate generates two interaction IDs. Use this field if you want to customize the generated interaction IDs by prefixing them with the assigned characters.
   - **Shuffle Answers**  For question slides with multiple answers, the answers are shuffled when the user attempts the same question slide the next time.
   - **Allow Backward Movement**  The user can visit the slides that were attempted previously.
   - **Allow User To Review Quiz**  Users can review a quiz after they have completed attempting it and the score has been displayed. This option allows users to find out questions they answered incorrectly, and their correct answers. You can customize the messages provided in the feedback. Click Question Review Messages to customize the feedback messages:
     - **Correct**  For correct answers.
• **Incomplete** For incomplete answers.

• **Incorrect** The answer entered by the user, and the correct answer.

**Show Score At End Of Quiz** Select this option to let users view their score at the end of the quiz. You can customize the message that appears when the user passes or fails the quiz. Click Quiz Result Messages to customize the messages. You can also customize the options that you want displayed on the score slide.

• **Pass Message** Customize the text that you want displayed when the user passes the quiz. Alternatively, you can disable this option if you do not want to display a message to the user.

• **Fail Message** Customize the text that you want displayed when the user fails the quiz. Alternatively, you can disable this option if you do not want to display a message to the user.

• **E-mail Button Text** Specifies the text for the E-mail button. Users can click the button to send an e-mail message to an address you specify.

• **Display Score** Displays the user’s score on the Results slide.

• **Display Maximum Possible Score** The maximum score possible if all questions were answered correctly.

• **Display Number of Correct Questions** The number of questions the user answered correctly.

• **Display Total Number of Questions** The number of questions the user answered.

• **Display Accuracy** The user’s score as a percentage.

• **Display Number Of Quiz Attempts** The number of user attempts.

**Show Progress** Select this option to show users which question number they are currently working on within the quiz.

### Set pass or fail preferences

You can set the minimum score required to pass a quiz. You can also define the action that should take place after the user passes or fails a test.

1. Select Edit > Preferences.
2. In the Preferences dialog box, select Pass or Fail from the Quiz menu.
3. In the Pass Fail options, do one of the following:
   - Set the minimum percentage that the user must score to pass the quiz.
   - Set the minimum points that the user must score to pass the quiz.
4. To decide the course of the project after the user passes a quiz, select an action in the If Passing Grade section.
   - **Continue** The movie moves to the next defined action.
   - **Go To Previous Slide** The previous slide is displayed to the user.
   - **Go To Next Slide** The movie moves to the next slide.
   - **Go To Last Visited Slide** Similar to a back button. The movie moves to the previously viewed slide.
   - **Jump To Slide** The movie moves to the specified slide.
   - **Open URL Or File** A web browser opens with the specified web page if the user has internet connectivity. Alternatively, you could open a specified file for the user.
   - **Open Other Project** Opens the specified Adobe Captivate project.
   - **Send E-mail To** A draft of the default e-mail editor opens with the e-mail address specified in the To field.
   - **Execute JavaScript** Adobe Captivate runs the specified JavaScript.
Execute Advanced Action  Adobe Captivate runs the script written using the application.

Show  When the user performs the required action on the object, the specified hidden object is made visible

Hide  When the user performs the required action on the object, the specified object is hidden from the user.

Enable  When the user performs the required action on the object, it activates another object in the project.

Disable  When the user performs the required action on the object, it disables another object in the project.

Assign  When the user performs the required action on the object, the value of the specified variable is set inside the text caption.

Increment  When the user performs the required action on the object, the value of the specified variable is incremented accordingly.

Decrement  When the user performs the required action on the object, the value of the specified variable is decremented accordingly.

Multiple Actions  When the user performs the required action on the object, multiple actions are performed in the order specified by the user.

No Action  Nothing happens when the user exits the slide.

To decide the course of the project after the user fails a quiz, select an action in the If Failing Grade section. The actions are similar to those in the If Passing Grade section.

Set question slide preferences

1  Select Edit > Preferences.

2  In the Preferences dialog box, select Default Labels from the Quiz menu.

3  Change the default labels that appear on the Submit, Clear, Skip, and Back buttons in the Default Question Button Labels section. The four buttons are displayed on any question slide unless you have disabled them in the Properties dialog box for that slide.

4  You can choose to provide feedback to users when they are taking the quiz.

   Correct Message  Appears when the user provides a correct answer.

   Incorrect Message  Appears when the user provides a wrong answer.

   Retry Message  Appears when the user provides a wrong answer, but can attempt the question one more time.

   Incomplete Message  Appears when the user does not provide the complete answer to the question.

   Timeout Message  Appears when the user does not answer the question in the specified time. You can set the time using the Properties dialog box of the question slide.

Set progress indicator preferences

The progress bar displays the user’s progress through the questions. On the question slide, look for the label Question N Of N. Double-click the label to set the options.

Type  Specifies how the progress bar displays the user’s progress through the questions. Relative Progress lists the current question and the total number of questions (for example, “Question 3 out of 10”). Absolute Progress lists just the question number (for example, “Question 3”).

Font  Use the font, size, and unlabeled text options to customize the appearance of the text for your progress bar.

Updated 19 May 2009
See also
“Fix size and position of noninteractive objects” on page 96

General workflow for question slides

1. In an open project, select the slide after which you want to insert a question slide.
2. Select Quiz > Question Slide.
3. Select the question type:
   - **Multiple Choice** Users select one or more correct answers from a list.
   - **True/False** Users choose either True or False (or Yes or No).
   - **Fill-In-The-Blank** Users complete a blank in a sentence or phrase.
   - **Short Answer** Users supply a word or phrase.
   - **Matching** Users match entries in two lists.
   - **Hot Spot** Users move the pointer over areas on the slide.
   - **Sequence** Users arrange listed items in the correct sequence.
   - **Rating Scale (Likert)** Users indicate their level of agreement with statements.
   *Note: You can add a widget question slide only to question pools.*
4. Create a question using the various options available for that slide. See the sections on the respective question slides for more information.
5. Specify whether the question is a graded or survey question.
   - **Graded Question** Use this option if you are trying to evaluate the user using the score you have assigned for the question.
   - **Survey Question** Use this option if you are trying to get user feedback.
6. Type the name of the question into the text box.
   *If you are creating many questions of the same type in a single project, enter unique names for each so that you can distinguish them easily.*
7. Type the question into the text box.
8. Assign a score (from 1 to 100) to the question.
9. Enter the correct answer or answers. This step varies according to the type of question. See topics on the respective question slides for more information.
10. Specify the numbering style (uppercase letters, lowercase letters, or numbers).
11. Specify whether to include Clear, Back, and Skip buttons.
   - **Show Clear Button** Resets the slide to the initial view. It allows the user to start answering the questions on a slide by clearing the entered answers.
   - **Show Back Button** Takes the user to the previously attempted question slide.
   - **Show Skip Button** Allows the user to skip the question slide and move to the next slide.
12. Complete the If Correct Answer area. The options are described below.
13 Complete the If Wrong Answer area. The options are described below.
14 Select the Reporting tab. Reporting options are described below.
15 Click OK.

**If Correct Answer options**

**Action** Select the action that should take place after the user provides the correct answer. The following options are available:

- **Continue** The movie moves to the next defined action.
- **Go To Previous Slide** The previous slide is displayed to the user.
- **Go To Next Slide** The movie moves to the next slide.
- **Go To Last Visited Slide** Similar to a back button. The movie moves to the previously viewed slide.
- **Jump To Slide** The movie moves to the specified slide.
- **Open URL Or File** A web browser opens with the specified web page if the user has internet connectivity. Alternatively, you could open a specified file for the user.
- **Open Other Project** Opens the specified Adobe Captivate project.
- **Send E-mail To** A draft of the default e-mail editor opens with the e-mail address specified in the To field.
- **Execute JavaScript** Adobe Captivate runs the specified JavaScript.
- **Execute Advanced Action** Adobe Captivate runs the script written using the application.
- **Show** When the user performs the required action on the object, the specified hidden object is made visible
- **Hide** When the user performs the required action on the object, the specified object is hidden from the user.
- **Assign** When the user performs the required action on the object, the value of the specified variable set inside the text caption.
- **Increment** When the user performs the required action on the object, the value of the specified variable is incremented accordingly.
- **Decrement** When the user performs the required action on the object, the value of the specified variable is decremented accordingly.
- **Multiple Actions** When the user performs the required action on the object, multiple actions are performed in the order specified by the user.

**Show Correct Message** Provide a text message when the user supplies a correct answer. Clear this option to provide no feedback for a correct answer.

**If Wrong Answer options**

**Allow User [#] Attempts** Use the arrows to select the number of times the user can attempt the question. After this number of attempts, the action you select from the Action pop-up menu occurs.

**Infinite Attempts** The user can attempt the question any number of times.

**Failure Levels** Specify the number of attempts for which the incorrect message is displayed. For example, if the level is set to 2, the error message is displayed for the first two attempts.

**Action** The options are the same as for the If Correct Answer area.
Show Retry Message  Display a message when the user supplies an incorrect answer but there are remaining attempts available (for example, “Please try again.”). This option is disabled if failure levels have been set.

Show Incomplete Message  Display a message (for example, “Please select an answer before continuing.”) when the user doesn’t supply an answer. This option is disabled if you have chosen the Drag Drop option.

Show Timeout Message  Displays a timeout message when the user fails to answer the question in the specified time.

Reporting options

Report Answers  Keep a quiz score.

Note: Interactive details like interaction ID, objective ID, and interaction type are not sent to the learning management system (LMS) if this option is not selected. However, details of the quiz, such as the total score, result, and quiz state, are still sent to the LMS.

Objective ID  If the quiz question is related to an objective set in your LMS, enter the objective ID.

Interaction ID  If you want the Adobe Captivate project (SWF file) to send tracking information to your LMS, enter the interaction ID specified by your LMS.

Time Limit  Set a limit for the time users have to answer the question. In the box, type the limit as hours:minutes:seconds.

Create question slides

Create a multiple-choice question slide

Follow the general workflow for creating a question slide.

1  Select Multiple Choice.
2  In the Question area, type the question.
3  In the Answers area, click Add and enter the choices.
4  Select Shuffle Answers if you want the choices to appear in a different order each time the user returns to this question.
5  If there is a single correct answer, select Single Response in the Type pop-up menu and select the correct answer.
6  If there is more than one correct answer, select Multiple Responses in the Type pop-up menu and select the correct answers.
7  Click OK.

See also
“General workflow for question slides” on page 155

Create a true-or-false question slide

Follow the general workflow for creating a question slide.

1  Select True/False.
2  In the Question area, type the question.
3 In the Answers area, establish which answer is correct by selecting either True or False.
4 In the Type area, select True/False, or Yes/No.
5 Click OK.

See also
“General workflow for question slides” on page 155

Create a fill-in-the-blank question slide
Follow the general workflow for creating a question slide.
1 Select Fill-In-The-Blank.
2 In the Phrase text box, type a sentence or phrase.
3 Select a word or phrase in the sentence you just typed. Then click Add Blank.
4 Select an option for how users will respond:
   • Users provide an answer on their own.
   • Users select an answer from a list.
5 Enter the word or phrase that correctly fills in the blank.
6 Create a list of words or phrases for the user to choose from.
7 Select Shuffle List Answers if you want the choices to appear in a different order each time the user returns to this question.
8 Select Hide Numbering if you do not want the serial number displayed for the list of answers at runtime.
9 Click OK.

See also
“General workflow for question slides” on page 155

Create a short-answer question slide
Follow the general workflow for creating a question slide.
1 Select Short Answer.
2 Type the question into the text box. If you want to create a survey question rather than a graded question, choose Survey Question when first adding the question. (Alternatively, on the Options tab choose Survey from the Type menu.)
3 Enter the phrases or sentences that constitute correct answers.
4 Click OK.

See also
“General workflow for question slides” on page 155
Create a matching question slide

Follow the general workflow for creating a question slide.

1. Select Matching.

2. Type the question into the text box. For example, "Match the job titles in column 1 with the correct departments in column 2."

3. In the Answer area, click Add under each column and type the words or phrases to match.

4. Select Shuffle Answers if you want the choices to appear in a different order each time the user returns to this question.

5. To establish the correct matches, click an item in one column, click an item in the other column, and then click Match.

   To establish matches quickly, you can “draw” a line between the items in Column 1 and Column 2 by dragging.

6. Click OK.

See also
“General workflow for question slides” on page 155

Create a hotspot question slide

Hotspot slides contain areas that the user must identify. For example, you can ask the user to identify company products from images displayed on the slide.

Answers to hotspot questions are correct if all the correct hotspots are clicked and none of the incorrect hotspots are clicked.

See also
“General workflow for question slides” on page 155

Create a slide

1. Select Hot Spot.

2. Type the question.

3. In the Hot Spots box, enter the number of hotspots to be placed on the slide.

4. (Optional) To disable mouse clicks on slide areas other than hotspots, select Allow Clicks On Hot Spots Only.

5. (Optional) To customize the animation that appears after the user clicks the hotspot, click Select.

6. Click OK.

   The hotspot area appears on the slide. You can place this hotspot area over any object on the slide.

   Note: To edit messages you’ve selected to show to the user, select Edit > Preferences. In the Quiz menu, select Default Labels.
**Set hot spot properties**
You can change the properties of a hotspot and its location on the slide:

1. Right-click the hotspot, and select Properties from the pop-up menu.
   - The Hot Spot dialog box appears with the Hot Spot tab displayed.
2. From the Frame Color pop-up menu, select a border color for the hotspot.
   - **Note:** The border color isn’t displayed if the frame width is set to zero.
3. In the Frame Width box, enter a number or use the arrow keys to set the thickness of the hotspot border.
4. From the Fill Color pop-up menu, select a fill color for the hotspot.
   - **Note:** The fill color isn’t displayed if the fill transparency is set to 100%.
5. In the Fill Transparency box, enter a number or use the arrow keys to set the transparency percentage.
6. If clicking the hotspot is to be marked as a correct answer, select Correct Answer.
7. To make the hand icon appear when the mouse is moved over the hotspot, select Show Hand Cursor Over “Hit” Area.
8. To specify a shortcut key for the hotspot, click Select Keys and use the options, and then click OK.
9. Click Settings to select whether to apply all the properties or only the changed properties to the respective slide or to all the slides.
10. (Optional) To apply properties to all slides in the project, select Apply To All.
11. Click OK.
12. Click the Size And Position tab to specify the exact size and position of the Review area.

**Create a sequence question slide**
A sequence slide provides a list of items to be arranged in the correct order. For example, you can display a list of Polish kings and ask the user to arrange them chronologically.

Follow the general workflow for creating a question slide.

1. Select Sequence.
2. Type the question in the text field of the question box.
3. Enter the list in the correct order. (During presentation, the answers will be shown in a random sequence.)
4. Click OK.

**See also**
“General workflow for question slides” on page 155

**Create a rating scale (Likert) question slide**
A rating scale slide displays a statement to which users specify their level of agreement. For example, you can add the statement, “I learned valuable information from this presentation” and give the user a range of responses to choose from: disagree, somewhat disagree, am neutral, somewhat agree, or agree.

Rating scale questions are not graded and have no right or wrong answers. You can’t assign a point value or create branching on the basis of correctness. You can, however, decide what happens after the user completes the rating scale, such as continuing to the next slide, opening another project, or displaying a URL.
Follow the general workflow for creating a question slide.

1. Select Rating Scale (Likert).
2. Type the question directly into the text box of the Questions area.
3. In the Answers area you can accept the default answer text, edit the text, or add new answer types. To edit the text, double-click existing text (such as "Neutral") and type new text. To add more answer types, click Add and type new text.
4. Complete the After Survey specification. The After Survey area is the same as the If Correct Answer area as described in the general workflow.
5. Click OK.

See also
“General workflow for question slides” on page 155

Insert a question widget slide

You can insert question widgets created as SWF files in Flash into Adobe Captivate. Developers creating the question widget in Flash must use a template code for efficient integration of the question widget into Adobe Captivate. For more information, see “Create question widgets” on page 116.

1. Select Insert > Widget.
2. In the Open dialog box, select the question widget that you want to insert.
3. In the Widget Question dialog box, do the following:
   1. In the Name field, enter a name for the widget.
   2. In the Question field, enter the question.
   3. Assign the points that should be awarded to the user who answers the question correctly.
4. Follow the instructions in the Widget Parameters section to create the question.

See also
“Properties of widgets” on page 117

Question pools and random questions

Create a random question slide

Random question slides display questions that are randomly selected from a question pool to which they are linked. These slides help avoid quiz predictability. Random question slides do not have a Timeline of their own but use the timing of the question slide chosen at run time.

Note: When working with question pool slides, the view in the Filmstrip changes to Question Pools Slides. To revert to the main project, click the Slides tab on the Filmstrip.

You can use the following features to make your work easier and faster when working with question pools:

- Questions can be dragged across pools inside the Question Pools Manager.
- Questions can be copied and pasted within the Question Pools Manager.
• Questions can be locked, unlocked, hidden, and shown from within the Question Pools Manager by using the menu options.

• Questions can be edited from within the Question Pools Manager by double-clicking the question, or from context menu.

Random question slides cannot be exported into Flash 8 or Flash CS3.

Question pools cannot be exported into XML.

1 Select Quiz > Random Question Slide.

The New Random Question dialog box appears.

2 On the Question tab, do the following:

• In the Name box, type a name for the random question.

• In the Points box, type a number or use the arrows to assign a point value. The range is 0 - 100.

• From the Question Pool menu, select the pool from which the question will be randomly selected.

3 On the Options tab, do the following:

• From the Type menu, specify whether the question is a graded or survey question.

• In the If Correct Answer and If Wrong Answer areas, use the menu to select one of the following actions:

  - **Continue** The movie moves to the next defined action.
  
  - **Go To Previous Slide** The previous slide is displayed to the user.
  
  - **Go To Next Slide** The movie moves to the next slide.
  
  - **Go To Last Visited Slide** Similar to a back button. The movie moves to the previously viewed slide.
  
  - **Jump To Slide** The movie moves to the specified slide.
  
  - **Open URL Or File** A web browser opens with the specified web page if the user has internet connectivity. Alternatively, you could open a specified file for the user.
  
  - **Open Other Project** Opens the specified Adobe Captivate project.
  
  - **Send E-mail To** A draft of the default e-mail editor opens with the e-mail address specified in the To field.
  
  - **Execute JavaScript** Adobe Captivate runs the specified JavaScript.
  
  - **Execute Advanced Action** Adobe Captivate runs the script written using the application.

  - **Assign** When the user performs the required action on the object, the value of the specified variable set inside the text caption.

  - **Increment** When the user performs the required action on the object, the value of the specified variable is incremented accordingly.

  - **Decrement** When the user performs the required action on the object, the value of the specified variable is decremented accordingly.

  - **Multiple Actions** When the user performs the required action on the object, multiple actions are performed in the order specified by the user.

4 Click OK.

**Note:** To change the question pool for a slide after it has been created, right-click the slide and choose Edit Question from the pop-up menu. Use the Random Question dialog box to change the setting.
Create a question pool

1. Select Quiz > Questions Pools Manager.

   **Note:** The view in the Filmstrip changes to Question Pool Slides. To view slides in the main project, click the Edit tab.

2. Click the add button (+) above the left panel to add a question pool.

3. In the text box that appears, type a name for the question pool.

4. Click the add button (+) above the right panel to add questions to the question pool.

   The Question Types dialog box appears.

5. Select a question type.

6. Click Graded Question or Survey Question, and use the options in the displayed dialog box to set the question.

7. Repeat the procedure to add more questions to the question pool.

8. Click Close.

   You can click the remove button (−) in the right or left panel to remove questions from the question pools or question list.

   Question pools can be added, deleted, and renamed only from within the Question Pools Manager.

Moving question slides to a question pool

You can move a question slide or a group of question slides to a question pool. The question slide is removed from the main project and placed in the question pool. Alternatively, you can move question slides from a question pool into the main project, or to other question pools.

Question pools do not support slide grouping, so all grouping information is lost when grouped slides are moved into pools. Consequently, when the question slides are moved back to the main project, they are not associated with any group.

To move question slides from a mixed group into a question pool, expand the group, select the question slides, and move them to the question pool.

   **Note:** You cannot undo the movement of question slides to question pools or to the main project.

Move a question slide from the main project to a question pool

1. In Edit view in an open project, click the Question Pool Slides bar in the left panel, and select the slide after which you want the question slide from the main project to be inserted.

2. Click the Slides bar in the left panel, and select the question slide that has to be moved to the question pool. To select more than one slide in the Filmstrip, use Control-click or Shift-click.

3. Right-click the slide, select Move Question To, and select the pool to which you want to move the slide.

Move a question from one question pool to another or to the main project

1. In Edit view in an open project, click the Slides bar in the left panel, and select the slide after which you want the question slide from the question pool to be inserted.

2. Click the Question Pool Slides bar in the left panel, and select the question slide that has to be moved to the question pool. To select more than one slide in the Filmstrip, use Control-click or Shift-click.

3. Right-click the slide, select Move Question To, and select either Main Project or Pool #.

Updated 19 May 2009
Import questions from question pools in other projects
1 Select File > Import > Question Pools.
2 Select the project to import, and click Open.
   The question pools appear in the left panel of the Import Question Pools dialog box, and their corresponding questions appear in the right panel.
3 Select the questions to import into the current project, and click OK.
Chapter 13: Advanced Editing and Project Reviews

Projects and project preferences

Overview of project editing
When you record or create a project, you provide it with the required framework. To provide your project with a professional touch and to meet any standards set by the client or company, you can edit it. Editing a project involves the following:

- Adding additional slides and objects
- Editing slides and objects
- Reordering slides
- Deleting slides and objects that are not required
- Changing the timing of slides and objects
- Adding a skin
- Adding a table of contents
- Changing the dimensions of the project
- Changing the file size of the completed project.

You can set various project preferences in the Project menu of the Preferences (Edit > Preferences) dialog box. Any preferences you select are for the currently open project only, enabling you to set different preferences for different projects.

Edit project preferences
You can set project preferences that are applied to all the slides in the project. Some of these settings can overrule specific settings that you have set at the slide level. Use the Project menu in the Preferences (Edit > Preferences) dialog box to make the changes.

Edit project information
Use the Preferences dialog box to set various project properties. Project properties are visible to users from the Information button that is included with all playback controls. It is important to set project properties if you are creating 508-compliant accessible projects.

Author  Name of the author or authors of the project.
Company  Name of the company or organization responsible for the content in the document.
E-mail  E-mail address for the company or, if appropriate, of your customer service department.
Website  Website address of the company.
Copyright  Copyright information for your project.
Project Name  A distinctive and descriptive name for your project.
Description Short description of the contents of the project. For example, “This project is a brief overview of Product ZYX.”

Change project size and quality
Antialias Transparent Captions Anti-aliasing smoothens out the text edges in the published file. Selecting this option affects the size of the SWF file when the project is published. The transparent caption text in the published file is anti-aliased.

Compress Full Motion Recording SWF File This option compresses the full motion recording SWF file to a smaller size. Choosing this option can increase the time taken to preview or publish the project.

Settings You can select the quality of the SWF file that is published by moving the slider bar to the corresponding option: High, Medium, Low, or Custom. When you choose High, Medium, or Low, Adobe Captivate uses its internal settings to set the quality of the file. Files of a higher quality are compressed to a lesser extent, and therefore might be of a greater file size. You can customize the options for quality when you move the slider to the Custom level.

Retain Slide Quality Settings Select this option to use the slide quality settings defined in the Slide Properties dialog box for the slide.

BMP Image Quality The screenshots generated during recording are in the bitmap format. Reducing the image quality reduces the file size but can affect the quality of the color in the images. Any bitmap files that you have inserted in the project are also affected.

JPEG Image Quality JPEG files that you have inserted in the project are affected when you choose this option. Reducing the image quality reduces the file size but can affect the quality of the color in the images. JPEG images are detailed and contain many colors, so greatly lowering their quality is not advised.

Audio Quality Audio files are converted to mp3 format before they are published. A file with higher quality does not affect the file size drastically but significantly improves the audio quality.

Advanced Project Compression During publishing, Adobe Captivate takes into account only the difference between two slides instead of publishing both the slides. The compression reduces the size of the published project. Choosing this option can increase the time taken to preview or publish the project. Compressed projects sometimes do not play as intended in Flash Player.

Compress SWF File Compresses the published SWF file. Compressed SWF files can be played only with Flash Player 6 or later. Choosing this option can increase the time taken to preview or publish the project.

Define how a project starts and ends
Auto Play The movie starts playing as soon as it is downloaded. If you want the movie to play only after the user clicks the Play button, deselect this option. You can display an image until the user starts playing the movie. Click Browse (...) to select the image. If you do not select an image, the first slide of the movie is displayed.

Preloader You can add a loading screen to the beginning of your project. A loading screen is useful if the first slide of the project is large or contains audio and takes a few moments to appear.

Adobe Captivate includes predefined loading screen images that you can use. Also, you can create a custom image to use as a loading screen. To make a custom image available as a loading screen option, copy the image into the following folder: \Program Files\Adobe\Adobe Captivate <version number>\Gallery\Preloaders.

You can also create a SWF file to use as a loading screen. In the Adobe Captivate Preloaders folder, there is a sample SWF file and FLA file named DefaultPreloader. You can use these files as templates to create your own SWF file. If you add a custom loading screen, Adobe Captivate calls the following functions if they exist on the main Timeline of the SWF file:
Note: The preloaders available in Adobe Captivate are located in the `\ProgramFiles\Adobe\Adobe Captivate 4\Gallery\Preloaders` folder.

```javascript
function initialize(projectWidth:Number,
  projectHeight:Number)
function
onProgress(loadedBytes:Number,totalBytes:Number,preloadPercent:Number)
function isDone():Boolean
Preload% The percentage of the SWF file that must be downloaded before the file starts playing. After the required portion of SWF file has been downloaded, the preloader disappears, and the SWF file starts playing.
Password Protect Project Password that users must enter before they can view the project. Click Browse to customize the message that is displayed when the user enters the incorrect password. You can also specify a different label for the button that appears in the message.
Project Expiry Date Expiry date for the project. When a project expires, it can no longer be viewed.
Message Line 1 The message is displayed to the user when the project has reached its expiration date.
Message Line 2 The second line of text in the project expiration message.
Fade In On The First Slide Provides a fade-in effect to the first slide of the project.
Project End Options The following options are in the Project End Options area:
  Action  Click the menu and select an action to take place at the end of the project.
    • Stop Project  Stops the project after it plays once.
    • Loop Project  Continuously plays the project.
    • Close Project  Closes the movie after it stops playing.
    • Open URL Or File  Opens the specified website in a web browser after the movie stops playing.
To load a URL, type the full path to a website (for example, http://www.website.com). Click the pop-up menu to select the window in which to display the URL, then choose Current, New, Parent, or Top.
To load a file, click the Browse button (...), browse to the file, select the file, and click Open. Click the pop-up menu to select the window in which to display the file, then choose Current, New, Parent, or Top.
    • Execute JavaScript  Runs the specified JavaScript after the movie stops playing. Click Browse (...) to enter the JavaScript you would like to execute.
    • Open Other Project  Opens another project after the movie stops playing. Click Browse (...), browse to the project file (with the extension .swf, .rd, or .cp), select the file, and click Open. Click the Down Arrow to select the window in which to display the file, then choose Current, New, Parent, or Top.
    • Send E-mail To  Sends an e-mail to the specified e-mail address after the movie stops playing. The default mail editor is used to send the message.
Fade Out On The Last Slide Select this option to have the last slide in the project fade out of view.
Edit default preferences for slides and objects
The changes that you make in the Preferences dialog box are applied to all the slides in the project.
1 Select Edit > Preferences.
2 In the Preferences dialog box, select Defaults from the Global menu.
3 In the Slide Duration field, change the default time for which slides are displayed in the movie.
4 Set a background color for the slides in the project using the Background Color menu.

5 To change the number of slides displayed in a preview, change the value of the Preview Next “N” slides field. The default value is 5.

6 Select an object from the Select menu, and do the following according to your requirements.
   • Change the default time for which the selected object appears on the slide.
   • Change the default time after which the selected object appears on the slide.
   • Change the transition effect applied to the slides when they appear and exit the movie.
   • Change the time allotted to the transition effect during entry and exit of the slide.

7 To resize a text caption according to the amount of text available in it, select Autosize Captions. The text caption resizes automatically to accommodate all the text. When you don’t choose this option, the extra data is hidden. Manually resize the text caption to display the hidden data.

8 To resize a button according to the amount of text available in it, select Autosize Buttons. The button resizes automatically to accommodate the extra data. When you don’t choose this option, the extra data is hidden. Manually resize the button to display the hidden data.

9 If you want to set the time of the caption automatically in accordance with the amount of data in it, select Calculate Caption Timing. Adobe Captivate calculates the time that the viewer requires to read the text and applies it to the text caption.

**Save project preferences**

By saving project preferences you can reuse your set of preferences across projects. You can save the preferences you have set in the Preferences dialog box, and export them to a CPR file. When the CPR file is imported into a project, the preferences mentioned in the CPR file are set in the Preferences dialog box.

1 Select File > Export > Export Preferences.

2 In the Save As dialog box, save your preferences as a CPR file.

3 Click Save.

When you want to import preferences into another project, select File > Import > Import Preferences. Open the file from the location where you saved the CPR file.

**Set project background color**

You can set the background color for the project. Whether the background color appears on all slides depends on the type of slide and how a screenshot is captured.

1 In an open project, select Edit > Preferences.

2 In the Category panel, select Defaults from the Global menu.

3 In the Global panel, select a color using the Background Color menu. Do one of the following:
   • Pick a color from the Basic Colors panel.
   • Click More Colors to design a custom color.
   • Click the Pick Color icon to select and copy any color on your screen.
   • In the text field, enter the value for the color you want and press Enter.

4 Click OK.
Hide projects on the Start page
Adobe Captivate lets you hide a project on the Start page. The project remains in the My Adobe Captivate Projects folder (located within the My Documents folder). However, it is hidden when Adobe Captivate starts up.

- In Adobe Captivate, under Open A Recent Project, right-click a project, and select Hide Project.

  Note: Up to ten project names can appear in the Open A Recent Project list on the Adobe Captivate Start page.

Edit FMR files
You can use the FMR editor in Adobe Captivate to do the following:

- Delete frames in an FMR file
- Combine FMR files
- Split an FMR file
- Preview and play the edited FMR file.

  Note: Use Adobe Captivate FMR editor to edit FMR SWFs created using Adobe Captivate versions later than Adobe Captivate 3. Using the editor to edit FMR SWFs created using other applications or other versions of Adobe Captivate could lead to unpredictable results.

Open the FMR SWF file in the editor
1 Locate the FMR SWF file that you want to edit in the Library panel under the media folder
2 Right-click the file, and select Edit With FMREditor from the menu.

Delete frames in the FMR SWF file
1 Ensure that the timeline is in the Delete mode. The mode is displayed in the timeline header. If the timeline is in the Insert/Split mode, click the Toggle Marker button. The timeline shifts to the Delete mode. In this mode, the markers are displayed as two right angled blue triangles.
2 Drag the two selection markers (blue triangles) on the timeline to set the range for the initial and final frames you want to delete.
3 Select Edit > Delete Frames.

Insert SWF files in an FMR file
1 Ensure that the timeline is in the Insert/Split mode. The mode is displayed in the timeline header. If the timeline is in the Delete mode, click the Toggle Marker button. The timeline shifts to the Insert/Split mode. In this mode, the markers are displayed as a single blue triangle.
2 Select Edit > Insert SWF.
3 In the Open dialog box, navigate to the SWF file that you want to add.
4 Select the file and click Open.
   The selected file is inserted at the point specified by the marker. This process can take some time depending on the size of the inserted file.
Split FMR SWF into two parts

1. Ensure that the timeline is in the Insert/Split mode. The mode is displayed in the timeline header. If the timeline is in the Delete mode, click the Toggle Marker button. The timeline shifts to the Insert/Split mode. In this mode, the markers are displayed as a single blue triangle.

2. Drag the selection marker to the point where you want to split the FMR SWF.

3. Select Edit > Split SWF or right-click the stage and select Split SWF from the pop-up menu. The Split File dialog box appears.

4. In File To Open, specify the SWF file that should remain open for editing after the splitting is complete.

5. Click OK.

Import the edited FMR SWF

You must save the edited FMR SWF file before importing it into the Adobe Captivate project using File > Save. The changes are reflected in the FMR file that in the library.

Note: The edited files are imported as animated files into the project. If you have chosen to externalize animation files in the Preferences dialog box, such FMR SWF files are also externalized.

1. Navigate to the slide where you want to insert the FMR file. You could alternatively create a blank slide for the FMR SWF file.

2. Select Insert > Animation.

3. In the Open dialog box, navigate to and select the FMR SWF file that you want to import.

4. Click Open.

Create design templates

Design templates help provide a standard look and functionality for Adobe Captivate projects to which they are applied. They are useful when you need to create different modules of a project or when all projects that you create need to adhere to visual design guidelines.

A design template in Adobe Captivate is a set of custom visual properties for the following objects:

- Button: Transparent, Text, Image
- Text caption
- Click box
- Highlight box
- Mouse
- Question slide
- Quiz results slide
- Rollover captions
- Slides
- Slidelet
- Text animation
A design template is represented as a set of slides, with each slide containing a subset of these objects. You can set properties for each of these objects in the template. When you apply a template to a project, the properties are applied to all the corresponding objects in the project.

Question slides and quiz result slides are separate entities in the template with their own set of configurable properties. Changes to slide properties of normal slides do not affect these slides. Changes made to the properties of an answer label are applied to answer labels across the project. Similarly, changes made to a single score label or score result label are applied to all similar labels.

**Set properties at the project level**

In addition to setting properties for individual objects, you can also set properties at the project level, for example recording defaults, skins, and the loading screen.

You cannot delete, move, or copy template objects. You can, however, move slides within the template.

*Note:* Only those object properties that can be customized for the template are available to you.

1. Do one of the following:
   b. Click Design Template on the welcome screen.

   A set of slides containing all the objects that can be customized for the template appear.

2. Change the properties of the slides and objects as you would in a normal Adobe Captivate project. Only the properties that you can change are enabled.

3. To change the background and transition properties of the slide, click Properties in the main menu bar. Set the properties using the Slide Properties dialog box that appears.

4. To change the properties of objects in the template, select the object from the Find pop-up menu. The selected object is highlighted in the template. Double-click the object, and use the dialog box that appears to change the properties.

5. To change the recording defaults and the loading screen for the project, select Edit > Preferences. Use the Preferences dialog box to set these properties at the project level.

6. To change the skin properties, select Project > Skin Editor. Set your preferences for the skin using the Skin Editor dialog box.

7. Save the template as a.cptd file.

**Apply design templates**

Design templates can be applied to Adobe Captivate projects using the Design Template panel. You can also apply a design template to a project template. The object properties are applied to the placeholders in the project template.

The Design Template panel contains the templates available in the Design Template folder. This folder is present in the My Documents folder under My Adobe Captivate Projects. If you have created a template outside this folder, you can add it using the Browse Template button in the panel. If the added template exists in the panel, it is not copied to the panel again. When you add such a template, it is selected in the panel, and its thumbnail appears in the Preview panel.

You can change the folder from which the panel picks the templates. Click Change Template Directory in the panel and browse to the folder from which you want to import the templates.
The Adobe Design Center contains templates that you can download for free. Click Adobe Captivate Exchange to download templates from the Adobe Design Center. Download the ZIP file, and extract the contents to your design template folder.

When you move the mouse over a design template in the panel, a thumbnail of the first slide of the template is displayed. To preview all the slides in a template, select it in the panel, and scroll the Preview panel to preview all the slides in the template.

Any background image in the project is not overwritten by the template. However, if you have not specified a background for the project, the background used in the template is used for the project slides. The background image set using a template is overwritten when a template with a different background image is applied to the project.

You can apply design templates to individual slides or to an entire project.

- When the template is applied at the project level, properties set in the template are applied to all slides and objects in the project. When you insert new objects or slides in the project, the properties set in the template are applied to them. Any properties set for the project, like recording defaults, skin, and the loading screen, are applied too. You can, however, choose to overrule the template properties when working in the project.

- When the template is applied at the slide level, new slides and objects use the properties set in the project. The template properties are not applied to the new slides and objects.

You can preview a design template like any other project in Adobe Captivate, but you cannot publish it.

*Note: When you modify a template, reapply it to the presentations to which it has been applied.*

1. Open the project to which you want to apply the template.
2. Select Window > Design Template.
   In the Design Template panel, move your mouse over a template. A preview of the first thumbnail of the design template is displayed in the Preview panel.
3. To add a template to the panel, click Browse Template.
4. Select/hover/right-click the template thumbnail that you want to apply, and choose one of the following:
   - Select Apply to apply the template to the selected slide. The properties defined in the template are applied to all the objects in the selected slides.
   - Select Apply All to apply the template to all the slides in the project. The properties defined in the template are applied to all the slides and objects. Project-specific properties like recording defaults, skin, and loading screen are also applied to the project.

## Skins

Adobe Captivate is shipped with a default set of skins. You can create a customized skin by changing the various options in the Skin Editor and saving the changes as a theme. Skins in Adobe Captivate include the following elements: playback controls, border, and table of contents.

### Playback controls

The playback controls, consisting of a playbar and a progress bar, allow users to control the movie when it is played. The playbar displays buttons that control the movement of a movie. The progress bar tracks progress through the movie, showing the location of the current slide.
You can change the appearance of playback controls using the Skin Editor (Project > Skin Editor). You can customize the following options for playback controls:

**Playbar**  Consists of buttons that control the movie when it is played. The Playbar menu lists the available playbars in Adobe Captivate.

**Position**  The position of the playbar with respect to the movie. You can place the playbar at any of the four sides of the movie.

**Layout**  The alignment of the toolbar with respect to the movie. You can also make the movie stretch across the entire slide.

**Play/Pause**  Allows your users to pause and resume the project.

**Rewind**  Replays the movie starting from the first slide.

**Forward**  Moves the playhead to the next slide.

**Closed Captioning**  Displays closed captions in your project. Use the Closed Captioning Settings dialog box to change the appearance of text in the closed captions.

**Back**  Returns to the previous slide.

**Close/Exit**  Include this button to allow users to exit the project. This button is important for full-screen projects because it allows the user to close the window quickly.

**Mute**  Allows users to turn off the audio.

**Progressbar**  Include this option to allow users to see their progress as they move through the project. They can also move back and forth in the project by dragging the playhead on the progress bar.

**Fast Forward**  Plays the movie at twice or four times the normal speed.

**Transparency**  The transparency of the background of the playbar.

**Playback Colors**  You can customize the playbar by selecting colors for the background and the buttons.

**No Tooltips At Runtime**  You can choose to turn off tool-tips if you think they do not fit the style of your presentation.

**Project border**

You can specify the style, size, texture, and width of the border around your project using the Skin Editor dialog box.

**Border**  The buttons represent the sides of the project window to which you want to add borders. You can have borders on any combination of sides.

**Style**  You can choose to have a border with sharp or rounded edges.

**Texture**  Choosing an image from the Texture list overrides any color choice for your border. If you want to choose a specific color for your border, select None from the Texture list.

**Width**  Thickness of the project border.

**Color**  Color of the project border. You can use the color palette or use the eyedropper to select and copy a color on your screen.

**HTML Background Color**  Color for the background area around the project.
Custom Flash playback controls

You can create custom Flash playback controls for your project. Use either Flash CS3 or Flash CS4 to open the SWF file and modify buttons, add colors, and so on. The file that contains the SWF playbars is located here: C:\Program Files\Adobe\Adobe Captivate 4\Templates\PlaybackFLA. The SWF images are stored in the C:\Program Files\Adobe\Adobe Captivate 4\Gallery\PlaybackControls\SwfBars folder.

When creating custom SWF playback controls, follow these guidelines:

- Store the source FLA file of the skin in the following location: C:\Program Files\Adobe\Adobe Captivate 4\Templates\PlaybackFLA.
- Don’t change the control names or symbols.
- The playbar must be present on the Stage with the instance name pbcBar_mc.
- The playbar must have the cpPlaybar identifier in the Library.
- The Export For ActionScript option must be selected for cpPlaybar in the Library.
- The actions at the action layer must not be changed.
- Store all buttons must be stored at the Library root.
- Don’t change the registration points. The registration point for every symbol is at the center (important for editing), except for the following symbols:
  - icoProgress (upper-left)
  - icoThumb (top-center)
  - icoThumbBase (upper-left)
- Store the published SWF file of the skin in the following location:
  <root Directory>\Program Files\Adobe\Adobe Captivate 4\Gallery\PlaybackControls\SwfBars (The Skin Editor picks the file from this location.)

Flash button-naming conventions

Each SWF button contains three layers: a button, an icon, and an action layer.

The SWF filename consists of the following elements:

- Acronym for playback control (“pbc”)
- Playback element identifier (“Btn” for button, “Bar” for bar, and so on)
- Name of the button (“play”).

Localize the Flash playbar

English is the default language for Flash playbars. Adobe Captivate also installs localized Flash playbars in French, German, Italian, Spanish, and Japanese. These Flash playbars are stored in \\Program Files\Adobe\Adobe Captivate 4\Gallery\PlaybackControls\SwfBars\Localisation\.

When you copy any of these Flash playbars to the folder C:\Program Files\Adobe\Adobe Captivate 4\Gallery\PlaybackControls\SwfBars\, the localized versions appear in the Playbar pop-up menu in the Skin Editor dialog box. The tool tips for these playbars appear in the selected language.

You can also add a new language if it is not available. The default SWF playbar file is stored in C:\Program Files\Adobe\Adobe Captivate 4\Templates\PlaybackFLA.
Previewing skins
You can preview the changes you’ve made to your project skin from the Skin Editor dialog box. Whenever you set the button colors, add or remove menus, or configure the positions of playbars, the preview reflects the changes immediately.

The skin preview displays the first slide of the project. It displays the background image (if present) or the slide color. No objects on the first slide are visible in the skin preview.

The skin preview is slow if it has a large background image. To overcome this performance issue, when configuring the skins, you can insert a blank slide and set it as the first slide. Then, open the Skin Editor dialog box and configure the skin changes. After making these changes, you can hide the first slide. The next slide that has the background image appears in the skin preview for final viewing.

See also
“Table of contents (TOC)” on page 175

Create a custom skin
After you have customized the options in the Skin Editor, you can save your customized set of options as a theme. The theme is added to the Skin menu in the Skin Editor. The next time you want to use your customized skin for a project, select it from the menu.

1 Select Project > Skin Editor.
2 Customize the settings in the dialog box according to your preferences.
3 Click Save As, and enter a name for your theme. Click OK.
4 Verify whether the theme has been added to the Skin menu.

See also
“Table of contents (TOC)” on page 175

Table of contents (TOC)
You can generate a table of contents (TOC) automatically for your Adobe Captivate project. The hierarchy of slides in the project is preserved in the TOC. Grouped slides are displayed as subentries under the group name. The name of the slides and the group are automatically added as in the project.

If you have applied a design template or added a skin to your project, the TOC is displayed with the selected skin.

You can specify the position of the TOC with respect to the main slide during editing. At run time, clicking the various headings in the TOC displays the corresponding slides in the main panel.

You can configure the appearance of the TOC using the various available options. You can then save the TOC as a theme along with the other skin items like playback controls and borders.

The TOC entry corresponding to the slide displayed is highlighted in the TOC panel as the movie runs through the slides.

A check mark in the Status panel indicates the slides that the user has completed viewing. You can choose to configure the project for self-paced learners so that they can start viewing slides from where they left off earlier.

Updated 19 May 2009
**Create a table of contents (TOC)**

1. Select Project > Table Of Contents.
2. Select Show TOC if you want to generate the TOC and display it in the project. The slide groups and slides are displayed in the same order as they appear in your project, along with their titles.

**Organize a table of contents (TOC)**

Grouped slides are classified according to their hierarchy in the project. The slides of a group appear under the group name in the TOC in the same order.

You can change the hierarchy and classification of the slides in the TOC. The reorganization affects only the TOC and not the order of the slides in the project. You can also choose to hide certain slide entries in the TOC. These entries are not displayed in the TOC when the project is played.

Depending on your preferences, you can reorganize the TOC using one or more of the following procedures:

- To move a slide to the next sublevel in the hierarchy, click Move TOC Entry Right .
- To move a slide to a previous level in the hierarchy, click Move TOC Entry Left .
- To move the slide entries up and down, click Move TOC Entry Up or Move TOC Entry Down .

*Note:* You can also move the TOC entries by dragging them to another location.

- To create a group within the TOC, click Create Folder . Rename the topic in the TOC, and organize slides under it. You can create up to five sublevels in the TOC menu.

*Note:* Grouping slides in the TOC does not group them in the project.

- To remove a TOC entry, select the entry in the TOC, and click Delete TOC Entry .

*Note:* Hiding a TOC entry does not delete the slide from the project.

- To hide the TOC entry for a slide when the project is played, deselect the option for that slide under the eye icon. The slide is not removed from the project.

- To discard your changes to the TOC, and display the default entries, click Reset TOC.

When you reorganize a project after creating the TOC, the changes are not automatically reflected. Reset the TOC to view the changes. Any new slide added after creating the TOC is displayed as a hidden entry after you reset the TOC. Enable the TOC entry by selecting the check box under the eye icon.

*Note:* If you do not want to preview changes to the skin when you change an option in the Settings panel, deselect the Autopreview option.

**Customize the table of contents (TOC)**

You can customize the following for the TOC:

- Appearance of the TOC.
- Position of the table of contents with relation to the main panel playing the movie. You can also choose to overlay the TOC on the main panel playing the movie or display the TOC as a separate panel during run time.
- Display the project information such as the details of the company or the person creating the project in the TOC panel.
- Display the status of the slides for users during run time. When the Status option is turned on, a check mark appears next to slides that the users have completed viewing.
• Allow users to start viewing the project from the slide at which they left off previously when they run the project again.

**Customize TOC appearance**

1. Select Project > Table Of Contents.
2. Click Settings in the TOC panel.
3. Set the options in the color section for the following:
   - **Background** Background color of the TOC panel.
   - **Default** Background color of the TOC menu.
   - **Active** Background color of the active TOC entry during run time. During run time, the TOC entry corresponding to the slide displayed is highlighted in the TOC panel. This entry is called the active TOC entry.
   - **Rollover** Background color of the TOC entry when the user moves the pointer over the entry at run time.
   - **Heading** Background color of the header and footer.
   - **Outline** Border color of the TOC menu.
   - **Transparency** Transparency of the background of the TOC menu.
4. Set the options in the Font section to define the font style for various heading levels in the project. Select a level in the Level menu, and set the font properties for the text.

*Use the Transparency option to create visually striking TOC panels. You can define an optimum level of transparency for the background color of the TOC panel and menu.*

**Define a position and layout for the TOC panel**

1. Select Project > Skin Editor.
2. Click Settings in the TOC panel.
3. In the options under Position, do one of the following:
   - Select Left to position the TOC panel to the left of the main movie panel.
   - Select Right to position the TOC panel to the right of the main movie panel.
4. In the options under Style, do one of the following:
   - Select Overlay to overlay the TOC panel on the main movie panel. Ensure that the contents of the movie are not hidden when you choose this option. You can use background transparency to achieve optimum results for slides with overlay.
   - Select Separate to display the TOC panel separately from the main movie panel.

**Display project information in the TOC panel**

When the Status option is selected, a check mark appears next to slides that you have completed viewing.

1. Select Project > Table of Contents.
2. Click Info in the TOC panel.
3. Enter the details of the author or company in the respective fields.
4. Click Project Info to use the information that you set in the Project Info menu of the Preferences dialog box. The information from the Preferences dialog box is added to the corresponding fields.
5. Click Clear Info to clear information that you have entered in the different fields.
6 Select Auto Preview to have the Preview panel reflect a change as soon as you complete that change in a dialog box.
7 Click Browse (…) to select an image to display on the panel. This image could be the logo of the company publishing the project, or a snapshot a prominent slide in the project.
8 Click Advanced to specify the font style for the project information.

**Display the duration and status of the slides during run time**
When the Status option is selected, a check mark appears next to slides that you have completed viewing.

1 Select Project > Table Of Contents.
2 Click Settings in the TOC panel.
3 In Runtime Options, select Show Duration to display the duration of the slides when the movie plays.
4 Select Status Flag to flag slides that have been viewed with a check mark.
5 Select Clear Button to display the Clear Button to the user during run time. Clicking the Clear button removes all the status flags from the movie.

**Enable search in the TOC**
Adobe Captivate searches for content both within the slides and their labels. Question slides are searched only if you enable the option in the settings panel.

1 Select Project > Table Of Contents.
2 Click Settings in the TOC panel.
3 Select Show Search to provide users with a search field in the TOC.
4 Select Search Quiz to allow users to search content in question slides.

**Enable or disable navigation**
When you disable navigation, users can’t navigate on their own using the TOC.

1 Select Project > Table Of Contents.
2 Click Settings in the TOC panel.
3 Use the Enable Navigation toggle.

**Enable or disable preview**
The Preview panel displays the appearance of the TOC every time you make edits in the Settings dialog box or the TOC Information dialog box. Previewing helps you explore various options before you arrive at one that best suits your requirements. If you have already decided on the settings for the TOC, you can disable this option in the corresponding dialog box.

1 Select Project > Table Of Contents.
2 Click Settings in the TOC panel.
3 In the Skin TOC Settings dialog box, uncheck Auto Preview.
Allow users to resume sessions
In a self-paced learning scenario, you can set an option to allow users to resume viewing a project from where they left off earlier. The status flag is not reset after the project is closed. When the user plays the movie again, the project resumes playing from the first slide that is not flagged.

1. Select Project > Table Of Contents.
2. Click Settings in the TOC panel.

Save the TOC settings as a part of the theme
Changes to the TOC settings, along with other skin settings such as playback controls, borders, and info, can be saved as a theme. Themes, like templates, can be applied to an entire project.

1. After you change the TOC panel and other options in the Skin dialog box, click Save As.
2. Enter a unique name for the theme.

See also
“Skins” on page 172
“Create a custom skin” on page 175

Preview projects
Before and during the editing of a project, previewing it helps you notice the changes that are required. This way, you can be sure of your final output before you publish it.

1. Open the Adobe Captivate project that you want to preview.
2. In the main toolbar, click Preview, and select one of the following options:
   - **Play This Slide**  Plays only the current slide.
   - **Project**  Plays the entire project.
   - **From This Slide**  Plays the project from the currently displayed slide to the end.
   - **Next 5 Slides**  Plays five slides starting with the current slide.
   - **In Web Browser**  Opens and plays the project in your default web browser.
   - **Device Central**  Opens the project within the display of a mobile phone of a mobile phone simulation software.

   **Note:** You can change the number from 5 to your desired number of slides using the Preferences dialog box.

Combining multiple SWF files with aggregator
You can combine multiple projects published as SWF files using the Aggregator. You can publish the combined files in the Aggregator as SWF output, EXE file, PDF or HTML. The Aggregator creates a table of contents (TOC) using the names of the separate modules (SWF files). TOCs of individual modules are displayed under their module name.

The Aggregator currently supports SWF files that are published using Adobe Captivate and that use the same ActionScript version.
When creating a project with multiple modules that require a consistent appearance and approach, instructional designers can create a design template for use across modules. Individual content creators can use this template when creating their modules.

To ensure uniformity of TOC settings across a movie, you can set a SWF file as the master movie. The TOC settings of the master movie are applied to all the other movies in the Aggregator. Any changes made to the TOC settings by individual content creators can be undone using a master movie.

**Create an aggregator file**

1. Select File > New > Aggregator Project.
2. In the Aggregator dialog box, click New.
3. In the Create New Project dialog box, select the ActionScript version that was chosen when the movies were published. Ensure that the movies were created using the same ActionScript version.
4. Click OK.
5. In the Aggregator dialog box, click Add Module.
6. In the Open dialog box, select the SWF file that you want to add to the Aggregator.
7. Repeat steps 4 and 5 to add more SWF files to the Aggregator.
8. To set a SWF file as the master movie, select Set As Master Movie. The TOC settings of the SWF file are applied to the other files in the Aggregator. The project information of the master movie is applied to the Aggregator file.
9. Optionally, do the following:
   - If you do not want to display the name of the SWF file in the movie, deselect Include SWF Title.
   - To change the position of a SWF file in the menu, select the name of the file. Use the Up and Down Arrow keys to relocate the movie to the desired location in the menu.
   - To delete a movie from the list, select the movie, and click Remove.
   - To override the project information set in the TOC of the master movie, click Info. In the TOC Info dialog box, select Override TOC Info, and change the settings. The TOC information is displayed above the TOC menu of the Aggregator in the published file. For more information, see “Display project information in the TOC panel” on page 177.
10. Click Save, and save the file as a.aggr file.

**Publish the aggregator file**

After you have created and saved the aggregator file, you can publish it as a SWF file or as an EXE file.

1. Select File > New > Aggregator Project.
2. Do one of the following:
   - Create an aggregator file.
   - Open an existing aggregator file.
3. Click Publish.
4. In the Publish dialog box, do the following:
   a. In the File Type section, select Flash (SWF), or Standalone (EXE), to publish the aggregator file as a SWF file or an EXE file.
   b. In the Project Title field, specify a unique name for the published file.
c In the Folder field, enter the path to which the files are published. Alternatively, click Browse to specify the path. Select Publish Files To A Folder if you want Adobe Captivate to create a default folder into which the files are published.

5 Select Zip Files if you want to publish the files as a single ZIP file. This option is especially useful when you want to create a single ZIP file that can be uploaded to a learning management system (LMS) directly.

6 Select Export HTML if you want to insert the SWF into an HTML file and publish it.

7 Select Export PDF if you want to insert the SWF file into a PDF file and publish it.

Combining multiple SCOs with aggregator

You can combine multiple projects containing interactions (SCOs or scorable objects) using the Aggregator. When you publish the Aggregator file containing multiple SCOs, a ZIP file containing all the SCOs and a manifest file are generated. You can directly upload the generated ZIP file to an LMS. The TOC menu of the aggregator file is similar to that generated for SWF files. For more information, see “Combining multiple SWF files with aggregator” on page 179.

An SCO can be created in one of the following ways:

- Publish an Adobe Captivate project containing at least one scorable object as a SWF file.
- Publish a Flash movie containing a quiz created using a quiz template as a SWF file.
- Publish a Flash movie containing learning interaction objects as a SWF file.

Note: The SCO must be created using Flash that is part of the e-learning suite.

Adobe Captivate aggregator projects can combine only such SCOs that have been created using Flash that is part of the e-learning suite.

SWF files created using Flash do not have an associated manifest file. Adobe Captivate prompts you to enter manifest details when you try to add such SWF files into the Aggregator. A manifest file is then created using this information, and later bundled into the published ZIP file.

Create an aggregator file

1 Select File > New > Aggregator Project.

2 In the Aggregator dialog box, click New.

3 In the Create New Project dialog box, select Multiple-SCO project.

4 Click OK.

5 In the Aggregator dialog box, click Add Module.

6 In the Open dialog box, select the SWF file that you want to add to the Aggregator.

7 If the SCO has been created in Flash, the SCO Manifest Details dialog box appears. Enter the details. The SCO Identifier is a mandatory field. For more information, see “Create an LMS-ready file in Adobe Captivate” on page 216.

8 Repeat steps 4 to 7 to add more SWF files to the Aggregator.

9 In the Open dialog box, select the SWF file that you want to add to the Aggregator.

10 Click Save, and save the file with the .aggr extension.
Publish the aggregator file
After you have created and saved the aggregator file, you can publish it as a SWF file or as an EXE file.

1. Select File > New > Aggregator Project
2. Do one of the following:
   • Create an aggregator file
   • Open an existing aggregator file
3. In the Publish SCO Package dialog box, enter a name for the project in the Project Title field.
4. Click Browse to publish your file to an alternative location.
5. Click Publish.

The aggregator file is published as a ZIP file. You can directly upload the ZIP file to an LMS.

Resize projects
You can resize Adobe Captivate projects, even after you have recorded them. Resizing can save you from having to rerecord an entire project. For example, suppose you record your project at a width of 640 and height of 480, but then decided you need a slightly smaller or larger size.

Resizing a project cannot be “undone” with a toolbar button or key combination such as Control+Z.

Resizing a project numerous times can result in quality deterioration. As far as possible, try to resize a project only once.

Resize a project
1. In an open project, select Project > Rescale.
2. Under Size, enter an exact custom size in pixels in the Width and Height text boxes (minimum size 100 x 100). Alternatively, enter a percentage for width and height, with the current size being 100%. (For example, to make the project slightly bigger, enter 110%; to make the project much smaller, enter 50%.) You can also select the Preset Size option and choose a commonly used size, such as 640 x 480, from the pop-up menu.

   If you want, select the Maintain Aspect Ratio option, which maintains the height and width proportions when the image is resized. This option ensures that the image is displayed accurately and is not distorted.

3. If you want to choose from a standard set of sizes, select Preset Size, and choose from the options.
4. You have different options depending on whether the new size you specified is larger or smaller than the original size.

   The following options are in the If New Size Is Larger area:
   
   **Rescale Project To Fit New Size**  This option resizes the entire project to the new larger size you specified. To also rescale any objects in the project, select the Rescale Captions, Highlight Boxes, And Other Objects option.

   **Keep Project The Same Size And Fill Background With Color**  This option keeps the project the same size, but creates a project background at the size that you specified earlier. For example, if your original project is 550 x 400 pixels and you set the new size to 640 x 480, this option keeps the project at 550 x 400 and creates extra space around the project of 90 x 80. You can select any background color and choose a position for the project on the background, such as center or upper right.

   The following options are in the If The New Size Is Smaller area:
**Rescale Project To Fit New Size**  This option resizes and resamples the project to provide a good quality project. To also rescale any objects in the project, select the Rescale Captions, Highlight Boxes, And Other Objects option.

**Crop**  Crops the project to the new size. If you select the Crop option, click Next to open the Crop Area dialog box where you can define a crop area.

- **Select Crop Position**  Specifies the area to crop. Click the floating crop window and move it over the area of the slide you want to retain. You can navigate through each slide of the project and position the floating crop window in a different location on each slide.

- **Arrows**  Move backward or forward one slide at a time through the project.

- **Slide**  Lists all the slides in the project. Click the drop-down arrow to select an individual slide.

- **Apply To All Slides**  Applies the crop area you defined in the Select Crop Position option to all slides in the project. For example, if you have the floating crop window positioned in the upper-left corner of the slide, click Apply To All Slides to crop the same area on all slides.

**Rescale Captions, Highlight Boxes, And Other Objects**  Select this option to have Adobe Captivate automatically rescale all objects in your project such as captions, highlight boxes, click boxes, and text entry boxes to the new, smaller size.

5 Click Finish.

The project is resized according to your choices.

*Note: Resize buttons before resizing the project. Resizing a project does not resize the buttons automatically.*

**View project dimensions**

- In an open project, select Project > Rescale. The dimensions of the project are mentioned in the Original Project Size section of the Rescale dialog box.

**Spelling and search**

**Check spelling**

You can check spelling in most places where text occurs in your projects, including captions, slide notes, slide names, text animations, and quizzes.

*Before checking spelling, set the options for spelling checking.*

1 Open an Adobe Captivate project.

2 Select Project > Check Spelling. Alternatively, you can press F7.

3 When Adobe Captivate encounters an unrecognized word, the word appears in the Not In Dictionary text box. Select the appropriate options based on how you want the discrepancy handled:

- **Ignore Once**  Ignores this instance of the unrecognized word.

- **Ignore All**  Ignores all instances of the unrecognized word.

- **Add To Dictionary**  Adds the unrecognized word to your personal dictionary. The personal dictionary Userdic.tlx can be found on your computer at `\Documents and Settings\<user name>\Local Settings\Application`
Set spelling check options
Adobe Captivate lets you check spelling in most places where text occurs in your projects, including captions, slide notes, slide names, text animations, and quizzes. Before using the spelling checking feature, review the spelling check options and change them if necessary.

1 In Adobe Captivate, select Edit > Preferences.
2 In the Preferences dialog box, select General Settings from the Global menu.
3 Click Spelling Preferences in the Global menu.
4 In the Spelling Options dialog box, set the following options:

   **Ignore Capitalized Words**  Omit any words from the spelling check that begin with a capital letter such as “Adobe.” Consider this option if your text contains many proper nouns.

   **Ignore All-Caps Words**  Omit any words from the spelling check composed of all uppercase letters such as “MIDI.” Consider this option if your text contains many acronyms.

   **Ignore Words Containing Numbers**  Omit any words from the spelling check that contain digits such as Q2. Consider this option if your text contains many symbols or code with numbers.

   **Ignore Mixed Case Words**  Omit any words from the spelling check composed of uppercase and lowercase letters such as “ActionScript.”

   **Ignore Domain Names**  Omit any words from the spelling check that appear to be Internet domain names such as www.adobe.com.

   **Report Doubled Words**  Notifies you during the spelling check of any words that appear twice in a row such as “the the.”

   **Case Sensitive**  Analyzes capitalized and lowercase versions of words separately. For example, “chicago” and “Chicago” would each be checked and the lowercase spelling would be identified as a misspelled word.

   **Phonetic Suggestions**  Provides alternative words based on phonetic similarity to the misspelled word.

   **Typographical Suggestions**  Provides alternative words based on typographical similarity to the misspelled word.

   **Suggest Split Words**  Provides two-word suggestions for any misspelled word that appears to be two joined words such as suggesting “press the” for “press the.”

   **Main Dictionary Language**  Specifies the dictionary language used during the spelling check. The default dictionary is English. To change the language, click the pop-up menu and select a new language.

5 When you finish, click OK.
Change dictionary
By default, the spelling checker uses the English (United States) dictionary. You can change to any dictionary installed on your computer at any time.

1. In Adobe Captivate, select Edit > Preferences.
2. In the Category Panel, select Global.
3. In the Spelling Preferences area, click Change Language from the Spelling Options dialog box.
4. From the Main Dictionary Language pop-up menu, select the dictionary you want to use. All dictionaries installed on your computer are listed.
5. Click OK.
6. Click OK again.

Search slides and replace content
You can use the numerous options available in the Adobe Captivate Find feature to search for information on your slides. Besides text, you can locate different kinds of objects, such as text animation or a rollover image.

1. Select Edit > Find And Replace.
   The Find And Replace dialog box appears.
2. Select the type of search from the Search In pop-up menu. The type selection determines which fields are enabled on the dialog box.
3. In the Find field, enter the text or object to search for.
   Note: The Find field is enabled for All Controls, Text Entry, Button, and Text Animation searches only.
4. (Optional) In the Replace field, enter the text that replaces the search string.
   Note: The Replace option is enabled for All Controls, Text Entry, Button, and Text Animation searches only.
5. Select any of the following options:
   - **Whole Word**  Skip variations of the text. For example, find special, but not specialist.
   - **Match Case**  For example, find Chair, but not chair.
   - **Quiz Slides**  Include quiz slides in the search.
   - **Hidden Slides/Controls**  Include hidden slides or controls in the search.
   - **Locked Slides/Controls**  Include locked slides or controls in the search.
6. Click any of the following buttons:
   - **Find Next**  The focus moves to the next occurrence of the text or object.
   - **Find All**  The search result lists all instances of the text or object.
   - **Replace**  The selected found text is replaced with the text in the Replace field.
   - **Replace All**  All instances of the text in the Find field are replaced with the text in the Replace field.

**Important:** Use Replace All only when you are sure that the other words in the project are not affected adversely. For example, if you choose to replace all instances of “to” with “too,” the word “together,” after the replace operation, is converted to “together.”

Updated 19 May 2009
Link Adobe Captivate projects

You can interlink Adobe Captivate projects or link them to other files when using the following features:

- Interactive objects: text entry boxes, click boxes, and buttons
- Question slides
- Slide navigation
- Project action

Make sure all the linked projects or files are in the same folder before you use the procedure to link them.

Link Adobe Captivate projects to other projects

1. In Edit view in an open project, insert any of the interactive objects into the slide using the options in the Insert menu.
2. Right-click the interactive object and select Properties from the menu.
3. In the On Success pop-up menu, select one of the following options:
   - Open URL Or File
   - Open Other Project
4. Click the Browse (...) button, and use the Open dialog box to link to the file or project.
5. Delete the system path, if any, to make sure that only the filename is displayed in the URL/Project field.

Link Adobe Captivate projects using question slides

1. In Edit view in an open project, select Quiz > Question Slide.
2. Click Graded Question.
3. In the Action pop-up menu, select one of the following options:
   - Open URL Or File
   - Open Other Project
4. Click the Browse (...) button, and use the Open dialog box to link to the file or project.
5. Delete the system path, if any, to make sure that only the filename is displayed in the URL/Project field.

View bandwidth utilization

Use the Bandwidth Analyzer to view the bandwidth required by the project and its object. You can see how much bandwidth each slide or object requires and how well the slides stream over various connections. With this knowledge, you can make the required changes to your project.

You can reduce the impact on the project by extending the timing for high-bandwidth frames or the preceding frames. Apply this fix only if bandwidth is limited and you notice distracting pauses during playback over the Internet.

1. In an open project, select Project > Bandwidth Analyzer. The Bandwidth Analyzer dialog box appears. This dialog box contains three tabs: Slide Summary, Graph, and Project Summary.
2. Navigate through the tabs for the required information.
3  (Optional) Click Print to print information in all the tabs. The Bandwidth Analyzer dialog box contains the following tabs:

**Slide Summary tab** Provides information about the speed and size of the slide.
- **Slide** Displays the slide number.
- **KB Per Sec** (Kilobytes per second) As a rule, any frame that requires less than 3 KB per second streams well over a modem Internet connection. Larger frames can, depending upon several factors, cause playback to pause. If previous frames require lower bandwidth, the higher-bandwidth frame can download at an acceptable speed. The first frame in a project always has a higher KB-per-second value, because additional project information must load with it.
- **Seconds** The frame duration, in seconds.
- **Video (KB)** The size of any included video.
- **Audio (KB)** The size of any included audio.

**Graph** Shows how the project streams across time for different modem and broadband speeds. You can view high-bandwidth frames and note how they appear on common connection types.

**Project Summary** Displays project summary information. Both the size and KB-per-second value are listed for each project item. Size is much less significant than KB-per-second value. For example, a 500-KB project running for 60 seconds streams at 8.3 KB per second. This project requires a broadband connection. By contrast, a 2000-KB project running for 10 minutes streams at 3.3 KB per second. This project streams well even over a low-speed modem connection.

**Slide Info** Displays information about slides and their objects. Objects are listed under the slides to which they belong. Objects aren’t listed if they represent less than 10% of the size of the slide.
- **Object** Name of the slide or object. The word “reused” next to the name of an object indicates a copy of the object. The word “linked” next to the name of an object indicates that it was not published in the final SWF file.
- **Type** The nature of the object. The object can be a video, graphic, animation, widget, drawing, or a standard Adobe Captivate object.
- **Size (Kb)** The size of the slide or object, in kilobits.
- **128k Speed (Sec)** Time required, in seconds, to download the object at a network speed of 128 Kbps.
- **56k Speed (Sec)** Time required, in seconds, to download the object at a network speed of 56 Kbps.
- **33k Speed (Sec)** Time required, in seconds, to download the object at a network speed of 33 Kbps.

**Creating accessible projects**

You can create Adobe Captivate projects that are in compliance with Section 508 of the United States Rehabilitation Act for users who have visual or hearing impairments, mobility impairments, or other types of disabilities.

**Accessibility and Adobe Captivate**

You can create output that is compliant with Section 508 for users who have visual or hearing impairments, mobility impairments, or other types of disabilities. You can also take steps at the design level to remove obstacles for people with disabilities viewing your Adobe Captivate projects.

These solutions support government agencies in meeting their users’ needs through Section 508 compliance, as well as companies who are committed to improving accessibility.
Worldwide accessibility standards

Many countries, including the United States, Australia, Canada, Japan, and countries in the European Union, have adopted accessibility standards based on those developed by the World Wide Web Consortium (W3C). W3C publishes the Web Content Accessibility Guidelines, a document that prioritizes actions designers should take to make web content accessible. For information about the Web Accessibility Initiative, see the W3C website at www.w3.org/WAI.

In the United States, the law that governs accessibility is commonly known as Section 508, which is an amendment to the U.S. Rehabilitation Act. Section 508 prohibits federal agencies from buying, developing, maintaining, or using electronic technology that is not accessible to those with disabilities. In addition to mandating standards, Section 508 allows government employees and the public to sue agencies in federal court for noncompliance.

For additional information about Section 508, see the following websites:


What is Section 508-compliance?

Section 508 is part of the Rehabilitation Act of 1973 requiring that federal agencies develop, maintain, acquire, or use electronic and information technology to make the systems accessible to people with disabilities. The most recent (1998) version of Section 508 establishes enforceable, government-wide standards.

What does accessible mean?

In general, an information technology system is accessible for people with disabilities if it can be used in various ways that do not depend on a single sense or ability. For example, users should be able to navigate with a keyboard, in addition to a mouse (not with a mouse only). Also, the visual and auditory elements of a user interface must accommodate both hearing-impaired and visually impaired users.

What other types of assistive software do end users need?

Screen readers or text-to-speech utilities (which read the contents of the active window, menu options, or text you have typed) and screen review aids translate onscreen text to speech or to a dynamic, refreshable, Braille display. This assistive technology can provide keyboard assistance or shortcuts, captions for speech and sound, and visual warnings such as flashing toolbars. Tools available include Windows Eye and JAWS.

What does Adobe Captivate do to be Section 508 compliant?

Selecting the 508 Compliance option makes certain elements in Adobe Captivate projects accessible or open to accessibility technology. For example, if you select the 508 Compliance and you have filled in the project name and project description text boxes in the Project Properties dialog box, a screen reader will read the name and description when the Adobe Captivate SWF file is played.

The following Adobe Captivate elements are accessible when the 508 Compliance option is selected:

- Project name (derived from Project Properties)
- Project description (derived from Project Properties)
- Slide accessibility text
- Slide label (derived from Slide Properties)
- Buttons
- Playback controls (The function of each button is read by screen readers)
• Password protection (If an Adobe Captivate SWF file is password protected, the prompt for a password is read by screen readers)

• Question slides (Title, question, answers, button text, and scoring report are read by screen readers)

Output generated with the Section 508 option is displayed by all supported browsers. However, your output may not be Section 508-compliant unless it is viewed with Internet Explorer. Internet Explorer is the only browser with support for MSAA (Microsoft Active Accessibility).

To access Flash files using a screen reader, users must have Flash Player 6 or later installed.

The Access Board is an independent federal agency committed to accessibility for people with disabilities. For more information about making your output compliant, see the Access Board website (www.access-board.gov/508.htm).

Adobe Captivate accessibility web page
For the latest information on creating and viewing accessible Adobe Captivate content, visit the Adobe Captivate Accessibility Overview page on the Adobe website at www.adobe.com/go/learn_cp_accessibility_en.

Creating accessible content

Create 508-compliant projects
Create an Adobe Captivate project using the Section 508 option to view and test the output. Generating the Adobe Captivate project updates source files containing information about your project and creates output files that you can publish for users. Read the tips for authoring and use the following procedure.

1 In an open project that you want to publish as 508-compliant, select Edit > Preferences.
2 In the Category panel, expand Project, and select Publish Settings.
3 Select Enable Accessibility in the Project panel.

Tips for creating 508-compliant Adobe Captivate SWF files
While Adobe Captivate Section 508 output is compliant for navigation, also make sure that other elements are compliant in your topics. Assistive software must be able to “read” elements on the screen to visually impaired users. Use these tips to help you design accessible projects.

• In the Project Properties dialog box, write a meaningful name and description for your Adobe Captivate projects.

• For users with hearing impairment, add text equivalents for audio elements. For example, when delivering narrative audio, it is important to provide captions at the same time. One option is to place a transparent caption in a fixed location on slides, then synchronize the text with the audio using the Timeline.

• If your project contains visual multimedia, provide information about the multimedia for users with visual impairment. If a name and description are given for visual elements, Adobe Captivate can send the information to the user through the screen reader. Make sure that audio in your Adobe Captivate projects does not prevent users from hearing the screen reader.

• Supply text for individual slides that screen readers can read.

• Ensure that color is not the only means of conveying information. For example, if you use blue to indicate active links, also use bold, italics, underlining, or some other visual clue. In addition, make sure that foreground and background contrast sufficiently to make text readable by people with low vision or color blindness.

• For users with either visual or mobility impairment, ensure that controls are device independent or accessible by keyboard.
• Users with cognitive impairments often respond best to uncluttered design that is easily navigable.
• If mouse movement is critical in your Adobe Captivate project, consider making the pointer twice its normal size for easier viewing.
• Document methods of accessibility for users.
• Avoid looping objects. When a screen reader encounters content meant for Flash Player, the screen reader notifies the user with audio, such as "Loading....load done." As content in a project changes, Flash Player sends an event to the screen reader notifying it of a change. In response, the screen reader returns to the top of the page and begins reading again. Therefore, a looping text animation on a slide, for example, can cause the screen reader to continually return to the top of the page.
• If you are creating click boxes, you can make them more accessible by adding sound. The sound can play when users tab to the click box or hover over it. To add this accessibility feature, attach a sound file to the hint caption. (If you do not want the hint caption to appear on the slide, you can make the caption transparent and add no text.)
• Accessibility in Adobe Captivate demos works better when all the slides have interactive content. If you are using JAWS 6.1 or later, be aware that JAWS sometimes does not clear the Microsoft Active Accessibility (MSAA) tree. As a result, the content of previous slides can replay when slides are continuous. This problem does not occur in JAWS 4.5.

See also
“Learning management system (LMS)” on page 216

Add accessibility text to slides
A screen reader can read aloud text that appears on the computer screen. Screen readers are useful for people with visual impairment. In Adobe Captivate, you can write text describing each slide for screen readers to read aloud.

1 In an open project, double-click the slide to which you want to add accessible text.
2 Select Slide > Properties.
3 Click Accessibility.
4 Do one of the following:
   • Type the text that you want the screen reader to read aloud.
   • If you want the screen reader to read text on the slide, such as text in captions, click Insert Slide Text.
   • If you want the screen reader to read slide notes, click Insert Slide Notes.
   • If you want the screen reader to read closed caption text for the audio that you have inserted, click Insert Closed Captioning Text.

Customize accessibility text for objects
You can add accessible text to individual objects on a slide. When the object appears in the movie, the screen reader reads that text aloud. If you do not specify accessible text for an object, the screen reader reads the default text. For example, if the object is an image, it reads Graphics Image. This default text is generally not sufficiently descriptive to help a visually impaired user. Also, objects other than text captions and text entry boxes do not contain any text. Accessible text for such objects can help users understand their purpose in the movie.

1 Right-click the object whose accessibility text you want to customize.
2 Select Properties from the menu.
3 In the dialog box for that object, click Accessibility.
Deselect Auto Label. When Auto Label is selected, the text in the object is read aloud by the screen reader.

In the Item Accessibility dialog box, do the following:

**Accessibility Name** Enter the accessibility name. For a text caption, you can enter “This text is in a caption,” for example.

**Accessibility Description** Add a description to clarify information for the person using the screen reader. For example, consider the text caption “Select File > Edit Image.” You can change the text to “From the File menu, select the Edit Image command. This command is available only when an image is selected on the slide.”

## Testing accessible content

### Tips for testing

If you are designing your Adobe Captivate project to work with screen readers, download several screen readers. Then test your project by playing it in a browser with the screen reader enabled. Make sure that the screen reader is not attempting to “talk over” places in your project where you have inserted separate audio. Several screen reader applications provide a demonstration version of the software as a free download. Try as many as you can to ensure compatibility across screen readers.

If you are creating interactive content, test it and verify that users can navigate your content effectively using only the keyboard. This requirement can be especially challenging, because different screen readers work in different ways when processing input from the keyboard. For this reason, your Adobe Captivate content might not receive keystrokes as you intended. Make sure to test all keyboard shortcuts.

### About screen reader technology

Screen readers are programs designed to navigate through a website and read the web content aloud. Visually impaired users often rely on this technology.

JAWS®, or Job Access with Speech, from Freedom Scientific, is one example of a screen reader. You can access the JAWS page of the Freedom Scientific website at www.hj.com/fs_products/software_jaws.asp. Another commonly used screen reader is Window-Eyes®, from GW Micro®. To access the latest information on Window-Eyes, visit the GW Micro website at www.gwmicro.com. For Windows users, Microsoft provides a free, downloadable product called Microsoft Reader that contains a text-to-speech component. For more information, visit the Microsoft website at www.microsoft.com.

Because different screen readers use varying methods to translate information into speech, the way your content is presented to users can vary. As you design accessible projects, keep in mind that you have no control over how a screen reader behaves. You have control only over the content, not the screen readers. You cannot force screen readers to read specific text at specific times or control the manner in which that content is read. It is important to test your projects with various screen readers to ensure that they perform as you expect.

## Localizing Adobe Captivate projects

Localization is the process of adapting information for use in a specific country. The term localization is often used as a synonym for translation. However, localization also entails editing information for a particular cultural context.
Using Adobe Captivate with a localized user interface

If you are creating Adobe Captivate projects that show a website or application that has been created in several languages, you can create localized projects for each language.

To create localized Adobe Captivate projects:
1. Create an Adobe Captivate project in your source language using a source language version of the website or application. For example, if you created your application in English, you can produce an English-language Adobe Captivate project that shows the English application.
2. Export any captions in the project and translate the caption text into the languages you require. Continuing the example from step 1, you can take the English-language captions in the English project, export them, and give the text to localizers so they can translate it into other languages such as German and Japanese.
3. Open the website or application in the localized forms and record the same steps that were recorded in the source language version of the project. When you record the projects, do not automatically include objects. In this example, you record Adobe Captivate projects (using the same steps in the English project) of the application after the localizers have translated the application user interface into German and Japanese.
4. Import all objects from the source language version of the project. In this example, you import all objects from the English version of the project into the German and Japanese projects.
5. Import the localized captions created by translators in step 2. In this example, you open the German and Japanese projects and import the Microsoft Word file of the captions that have been translated.
6. Test the localized versions of the project. In this example, open the German and Japanese projects and ensure that the correct user interface is shown, that captions are properly translated and appear on the correct slide, and that timing is accurate. If necessary, adjust the timing or resize the captions so that Adobe Captivate displays all the translated text correctly.

Localize text captions

If you are localizing a project that contains text captions and closed captions, you can export text captions to make the process more efficient.

1. Create the initial ("source language") version of the project, including all necessary text captions.
2. Open the completed project.
3. Select File > Export > Project Captions And Closed Captions.
4. By default, the Word (DOC) file is saved to your My Documents\My Adobe Captivate Projects folder. You can change the location if you want. If the project file was saved, the location of the default Word file, named [ProjectName] Captions.doc, is in the same directory as the one in which the project has been saved. You can change the name of the file, if necessary, by clicking directly in the File Name text box and entering a new name. (Retain the.doc filename extension.) Click Save.
5. The Word file is generated with the name you specified and saved to the location you selected. A dialog box appears, asking if you want to view the document. Click Yes to view the document in Word.
6. The Word document contains the slide ID, item ID, original caption text, and slide number. There is also a column named “Updated Text Caption Data” where you can change the caption text. Provide a copy of the Word document to the localizer/translator.
7. The localizer/translator opens the Word document and edits the caption text directly in the “Updated Text Caption Data” column, replacing the source language text.
While the localizer/translator is translating the text, make a copy of the original Adobe Captivate project for the new language.

*Note: When you create a copy of the original project, keep the original text captions and closed captions (in the source language) in the new project. The original captions act as placeholders and are overwritten when you import the new (localized) text captions and closed captions.*

When the text captions are localized, open the copy of the project you created.

Select File > Import > Project Captions And Closed Captions.

*Note: The Import Project Captions And Closed Captions option is enabled only after you export the captions. You can import only those edited caption files that you originally exported from the same project.*

Navigate to the localized text captions Word (DOC) file, select the file, and click Open.

The localized text captions and closed captions are imported into the project and all formatting is retained. A dialog box appears showing a successful import message. Click OK.

Test the new text captions by opening different slides in Edit view and reading the new caption text.

### Import, export, and delete content

#### Import project content to XML

*Note: After translating the content of the XML file to the required language, import the updated XML file into Adobe Captivate. The project content then appears in the required localized language.*

If you want to rerecord the project, ensure that you do so before importing the XML file.

1. In an open project, select File > Import > From XML.
2. In the Open box, enter the filename of the XML file or navigate to the XML file.
3. Click Open.
   
   The XML content is imported into the Adobe Captivate project. A dialog box appears, confirming that the XML import was successful.
4. Click OK.
   
   *Note: If the XML file was sent to you by e-mail, open the e-mail message and save the XML file in the required directory. Translate its contents to the required language.*

#### Export project content to XML

An Adobe Captivate project file can have the following types of content:

**Static content** Examples include images (bitmaps, buttons, backgrounds), audio, FLV files, and videos (SWF files). To customize static content for different languages, create new files with translated content.

**Dynamic content or localizable content** Examples include text captions, button text, and slide notes, which can be localized in different languages.

When you export the dynamic content of an Adobe Captivate project to an XML file, you can edit and translate content in the objects using the XML file. You can edit and translate many objects, including project properties, the Menu Manager slides and slide information, and so on. You can export audio items only for closed captions.

1. Open an Adobe Captivate project and save it with a new filename for a new language.
2 Select File > Export > To XML.

3 In the Save As dialog box, enter a filename for the new XML file.

4 Make a note of the default directory where you save the file. You can navigate to a different location if desired.

5 Click Save.

Relevant objects in the project are converted into XML format. A dialog box appears, confirming that the XML export was successful. Choose whether you want to view the XML file. If you click Yes, the XML file opens in your default XML viewer.

6 Open the XML file, and translate all terms specified in the <source> </source> tags inside the <trans-unit> </trans-unit> tags.

For RTF data (such as text captions), the actual translatable text is present within <g> </g> tags. To change the text to a different language, change the font-family field in css-style attribute, and add the corresponding character set.

Instead of exporting a project to XML, you can publish the project you want to edit and localize. You can then send the content in the XML format to an e-mail address. The XML file is sent as an attachment to the e-mail address. You can also compress the XML file and send it by e-mail.

Ensure that the Adobe Captivate project file is edited before exporting the XML file.

Note: The Info, Blabber, and Skin tool tips are not exported to XML because such information is stored in Flash Authoring Files. After localization, separately create Info, Playbars, and Skin tool tips for the relevant localized version of the Adobe Captivate project.

Import and export project preferences

You can export preferences set in one Adobe Captivate project and import them into other Adobe Captivate projects. Preferences are exported as an XML file with a .cpr extension. When this file is imported into another Adobe Captivate project, the preferences defined in the file are set.

Note: All preferences in your current project are modified according to those set in the preferences file.

Export project preferences

1 Select File > Export > Export Preferences.

2 In the File Name field, type a name for the CPR file.

3 Click Save.

Import project preferences

1 Select File > Import > Import Preferences.

2 Select the CPR file that contains the preferences you want to import.

3 Click Open.

Delete projects or templates

You can delete Adobe Captivate projects (CP files) or templates (CPTL) at any time. When you create Adobe Captivate projects and templates, they are saved, by default, to the following locations:

- Projects are saved in \My Documents\My Adobe Captivate Projects. If you are using Windows® Vista®, the path is \Users\<Current User>\Documents\My Adobe Captivate Projects.
• Templates are saved in \My Documents\My Adobe Captivate Projects\Templates. If you are using Windows Vista, the path is \Users\<Current User>\Documents\My Adobe Captivate Projects\Templates.

To delete projects or templates, perform the following steps.

1. Open Windows Explorer.
2. Navigate to the location of the Adobe Captivate project or template (see the default locations listed previously).
3. Right-click the project or template and select Delete.

Up to ten project names can appear in the Open A Recent Project list on the Adobe Captivate Start page.

You can hide a project on the Start page without deleting the project from your computer.

Using the AIR Review application

Creating reviews for Adobe Captivate projects

You can review Adobe Captivate projects by playing the published SWFs in the Adobe Captivate Reviewer, an AIR application. This application can be installed on an machine which has AIR installed; the reviewers need not have Adobe Captivate installed to review content and provide comments.

After creating and editing an Adobe Captivate project, the author can publish the project for review. The project is published as a CREV file. The CREV file is a custom SWF file that is used for review. It must be opened using Adobe Captivate Reviewer, an AIR application. The installer for the application, AdobeCaptivateReviewer.air, is present in the location where Adobe Captivate is installed. Authors sending the file for review must ensure that the installer for the Adobe Captivate Reviewer is sent along with the CREV file. Reviewers have to install the Adobe Captivate Reviewer to add comments on the published CREV file. They don’t need to have Adobe Captivate installed on their machines.

In a shared review where the author and the reviewers are on a common network, each of them can view comments posted by the other. The author, in addition, can accept, reject, or ask for feedback for the comments posted by the reviewers.

Reviewers who are not a part of the shared network can export their comments to an XML file and send it to the author. The author can import the XML file into the project, and view comments in the timeline of the slides where the reviewers posted them.

Note: Adobe AIR must be installed before any AIR application is installed. Adobe AIR can be downloaded for free from the Adobe website http://get.adobe.com/air/.

Reviewers must install the Adobe Captivate Reviewer, and open the CREV file using the application. They can then use the various commenting features to comment on the contents in the file. Comments from individual reviewers are stored as separate XML files at the location specified by the author during publishing.

Note: Installing the AIR application is a one-time effort.

During the review cycle, the author and reviewers can view the latest comments posted by refreshing the contents of the application.
Publishing a project for review

You can publish Adobe Captivate projects for review either by clicking the Send For Review button on the Main toolbar or by opening the Publish dialog box and navigating to the Review tab. You can optionally suggest a shared folder for storing the review comments. Comments from all the reviewers are posted to this shared folder, and the author can access review comments from this location. You can send an e-mail to the reviewers, optionally with the generated review file (CREV) and the Adobe Captivate Reviewer installer.

Publish the project and send it by e-mail

1. Do one of the following:
   - Select File > Publish
   - Click Send For Review in the main toolbar.
2. In the Publish dialog box, select Review on the left panel.
3. Use the following options to create the CREV file:
   - **Review File Name (.crev)** Enter a name for the review file.
   - **Publish Folder** The location where the CREV file is published. Click Browse if you want to specify a different location for the generated files.
   - **Project Comments Folder** Select this option and choose a shared folder, either on your computer or on the network, for storing the comments. Ensure that you provide write permissions to the folder. The path to the shared location must begin with a double backslash (\\). If reviewers do not have access to a shared folder, you can choose not to specify a location for the comments. In this case, you can ask the reviewers to export their comments to an XML file and send the file to you.

   When there is no shared network, you can choose not to specify a location. The reviewer must export the comments and send them to you. When you import the contents of the XML file, the comments are embedded in your project.
4. Select Send Mail, and do the following:
   - Select Attach Review (.crev) File if you want to send the CREV file as an attachment along with the mail. Use this option when the size of the CREV file is small enough to be sent by e-mail. E-mail filters are usually configured to block e-mails that are larger than a specified size.
   - Select Attach Adobe Captivate Reviewer if you want to send the AIR installer as an attachment. Use this option the first time that you send the CREV file to a reviewer.
5. Click Publish.

A draft of your default e-mail application with the specified attachment opens. The body of the draft contains a message providing instructions on installing the AIR application.

6. Customize the body of the draft if you want to provide additional instructions to reviewers.
7. Enter e-mail addresses of reviewers in the To field of the draft, and click Send.

**Important:** Best practice is not to edit the Adobe Captivate project during the review. If the project changes during the review, the posted comments might not appear at the intended locations. If you must edit the project, ask the reviewers to stop their work. Then start a fresh review after editing the project.

Set default project comments folder

You can set your preference for the Project Comments Folder in the Preferences dialog box. When you create new projects, the location specified in the Preferences dialog box is used when you publish a project for review.

1. Select Edit > Preferences.
2 Select General Settings from the Global menu.
3 Specify a location for the project comments folder in the Comments At field.

**Reviewing Adobe Captivate projects**

Ensure that you complete the following procedures before you review a project using the CREV file:

- Install the Adobe AIR application on your computer. The installer is provided to you by the author of the Adobe Captivate project. If you have Adobe Captivate 4 installed on your computer, you can locate the installer, AdobeCaptivateReviewer.air, at the location where you installed Adobe Captivate.

**Install the AIR application**

1 Double-click the AdobeCaptivateReviewer.air installer.
2 Click Install.
3 (Optional) Customize your installation preferences, and specify a location on your computer where to install the AIR application.

**Open the CREV file using the AIR application**

You can save the CREV file to your computer before opening it, or you can open it directly from the inbox.

1 Do one of the following:
   - Double-click the CREV file.
   - Open Adobe Captivate Reviewer.
2 In the Adobe Captivate Reviewer window, click Load Captivate Movie, and open the CREV file from your computer.
   
   If the author has not specified a location for storing comments, a dialog box appears asking you to specify a location for the comments. Select a local folder to store your comments, and click OK. Your comments are stored in this location as an XML file. After completing your review, e-mail the XML file to the author.

**Add comments to the SWF file**

1 Click Play. The seek slider starts moving through the movie.
2 Click Add Comment at the point where you want to add your comment.
3 Add your comment in the Add Comment window.
4 Click Add to add the comment. A marker, indicated by a white dot, is added at this location in the commenting bar. Your comments are not published until you click Save in the main toolbar.
5 Click Play Movie to continue playing the movie.
6 Click Save Comments in the main toolbar to publish your comments.

*Note: When reviewing AS2 movies, close any open dialog box in the Adobe Captivate Reviewer application before interacting with interactive objects and hotspots in the movie.*
**Edit or delete comments in the SWF file**

Comments added to the project are indicated as markers (white dots) at the specific location in the seek bar. To locate the comment that you want to edit, move your pointer over the markers. The comment added at a location is displayed when the pointer moves over it.

1. Click the marker on the seek bar whose comment you want to edit or delete. The comment is displayed in a pop-up window.

![Comment marker on seek bar](image)

2. Do one of the following:
   - Click Edit, and edit the comment.
   - Click Delete.

**Import comments from an XML file**

Authors and reviewers can import comments from XML files sent to them. Comments imported from XML files appear at the same location in the Timeline if the author has not edited the file during the review process.

1. Click Import Comments.
2. Browse to the location of the XML file.
3. Click Open.

Authors can alternatively import comments from XML files using the Comments panel in Adobe Captivate.

**Export comments to an XML file**

Reviewers can export comments to an XML file and send it to the author. The author can import the XML file, provide feedback, export the file, and send it to the reviewers.

1. Click Export Comments.
2. In the Browse For Folder dialog box, select the folder where you want to save the XML file, and click OK.

Authors can alternatively export comments to XML files using the Comments panel in Adobe Captivate.

**View or sort comments in the AIR application**

The author and reviewers can view and sort comments using the AIR application.

Do one of the following:
- To view all comments added to the file, click Show All Comments.
- To sort comments by reviewer name, click Filter Comments. In the Reviewers pop-up menu, select names of the reviewers to view comments posted by those reviewers.

**View or sort comments in the Adobe Captivate project**

Authors can view and sort comments in the Adobe Captivate project as well as the AIR application. Some of the options available for sorting are available only when the author uses Adobe Captivate to review the project.

1. To view comments added to the file, select Window > SWF Comment. The SWF Commenting panel appears. Comments posted by reviewers are displayed in the panel.
In the View By menu, select one of the following options:

a. Select Creation Time to sort comments chronologically.

b. Select Reviewers to sort comments by reviewer name.

c. Select Status to sort comments according to their status (New, Accepted, or Rejected.)

**View the latest comments**

- To view the latest comments posted by reviewers, click Refresh Comments.

**Provide feedback on comments by reviewers**

The author can accept, reject, or reply to comments posted by reviewers. Reviewers can view feedback posted by the author when they refresh the contents of their application.

Comments are also visible on the timeline of individual slides. Authors can use Preview > Play This Slide to view the exact location of comments.

1. Open the project sent for review in Adobe Captivate.

2. Select Window > SWF Comment. The Comments panel appears. Comments posted by reviewers are displayed in the panel.

3. Select one or more comments for which you want to provide feedback, and do one of the following:

   - Click Reject Comments to ignore the comment. Optionally, enter a reason for ignoring the comment in the pop-up window, and click Submit.

   - Click Accept Reviewer’s Comments to accept the comment. Optionally, enter your feedback in the pop-up window, and click Submit.

   *Note:* After you accept or reject a comment, the corresponding icon is displayed for the comment in the review application, along with any comments.

   - Click Reply To Reviewers Comments to request clarification on the comment.
Chapter 14: Publishing Projects

After you create a project, you publish your project so others can view it. Adobe Captivate contains many publishing options, and you can publish the project in many formats.

Change the default location of published files

The Adobe Captivate projects are published to the \Documents and Settings\<user name>\My Documents\My Adobe Captivate Projects folder if you have not made any changes to the settings when publishing the project. You can change this default location in the Preferences dialog box.

1. In Adobe Captivate, select Edit > Preferences.
2. In the Preferences dialog box, select General Settings from the Global menu.
3. Click the Browse button corresponding to the Publish At field.
4. In the Browse For Folder dialog box, select the folder in which you want the Adobe Captivate projects to be published.

Set publishing preferences

1. Select Edit > Preferences.
2. In the Preferences dialog box, select Publish Settings from the Project menu.
3. Set the various options according to your requirements.

   **Frames Per Second**  This option sets the number of Flash frames that appear per second. The default setting is 30 frames per second and is appropriate in most cases. For example, with the default setting, a caption that appears for 1 second requires 30 Flash frames. Dividing the number of frames in a project by 30 gives you the length of the project in seconds. You may need to change the rate if you are embedding your Adobe Captivate SWF file in another SWF file that has a frame rate other than 30.

   **Publish Adobe Acrobat Connect Pro Metadata**  Adds information to your Adobe Captivate project file (SWF) that makes it easier to integrate the project into Adobe Acrobat Connect Pro. The embedded data links the Adobe Captivate CP file to the SWF file when you publish the project to Connect Server and makes it easier for the Adobe Captivate output file to be found during searches done in Adobe Acrobat Connect Pro. For more information see “Adobe Acrobat Connect Pro” on page 220.

   **Note:** Selecting this option increases the size of the project. If you are not going to use the project with Adobe Acrobat Connect Pro, you can clear the option and decrease the size of the finished project file (SWF). However, if there is the possibility that the output file (SWF) may be used in Adobe Acrobat Connect Pro, it is a good idea to select the Include Metadata option.

   **Include Mouse**  Includes any recorded mouse movement in the project.

   **Include Audio**  Includes any audio files that have been added to the project.

   **Play Tap Audio For Recorded Typing**  This option plays tapping sounds in the final project to represent recorded keystrokes. (For example, if you recorded an e-mail message being sent, you most likely typed an address to which
the e-mail should be sent. The sound of the keys being pressed to enter the address was recorded, and using this option, a tapping sound can be played for each of the keystrokes.)

**Enable Accessibility** Enable this option if you want to make your project accessible to visually impaired users. The text in your project is read aloud when users accept the help of a screen reader when viewing the project. In addition, any other accessibility options that you have configured in the project are also enabled.

**ActionScript Version** If you are using Adobe Captivate projects within other applications like Adobe Flash, Adobe AIR applications, or Flex, it is important that you specify the version of ActionScript for the SWF file before publishing it. You cannot set variables within a Captivate movie if you publish it using an ActionScript version that is not supported by the application.

Adobe AIR and Flex support only ActionScript 3.0 whereas Adobe Flash supports both ActionScript 2.0 and ActionScript 3.0. Users must have Flash Player 9 or later installed on their computers to view Adobe Captivate movies created using ActionScript 3.0.

**Externalize Resources** When you publish a project as a SWF file, a single SWF file is produced. To reduce the size of the SWF file, you can choose to externalize some of its objects (skin, widgets, FMR SWF file, animations). After publishing, the externalized resources reside outside the SWF file, and are referenced by it.

## Publish a project as a SWF file

### Publish a SWF file

*Note: To run projects that you have published using Flash, you must have the same or later version of Flash Player.*

You can publish Adobe Captivate projects as SWF files in one of the following formats:

- Flash 7, 8, 9, or 10
- Flash Lite 3.0, or 3.1

After publishing your project as a SWF file, you can use these SWF files independently or include them in web pages.

1. In an open project, select File > Publish.
2. In the Publish dialog box, select Flash (SWF), and configure the following options:

   - **Project Title** Enter the desired name without the filename extension (.swf).
   - **Folder** Enter the full path for the folder in which to save the file or click Browse to locate the folder. A folder is created with the same name as the title, and all published files are moved inside it. If you do not want to create a separate folder and want to place the published SWF file in the same folder as the source file, clear the option Publish Files To A Folder.

   For example, if you have chosen to publish your project variables.swf to the desktop, a folder named variables is created on the desktop, and the files are published into this folder. When this option is not chosen, all the published files are published directly to the desktop.

   - **Zip Files** Creates a ZIP file containing the Flash content (SWF file) and other associated files like the HTML file required to display the SWF file, and a JavaScript for loading the SWF file into the HTML file. When you have enabled AICC/SCORM, other supporting files are created. This option is especially useful when you want to create a single file for uploading to a learning management system (LMS). For more information, see ”Create an LMS-ready file in Adobe Captivate “ on page 216.

   - **Full Screen** Opens the file in full screen mode. (You can’t apply this option if you select AICC or SCORM options for the project.)
**Note:** If you select the full screen option, Adobe Captivate generates two HTML files to accommodate the Windows XP Service Pack 2 release. Use both HTML files with the SWF file so that when you publish your project users won’t receive a Service Pack 2 warning message. You should link to the HTML file with “fs” added, for example, “myproject_fs.htm.” The HTML file with “fs” automatically links to the second HTML file, which, in turn, plays your project.

**Generate Autorun For CD**  Runs the output file automatically when the CD is inserted into the computer.

**Export HTML**  Creates a standard JavaScript file that helps embed the SWF file into the generated HTML file.

**Send PENS Notification**  Verifies PENS compliance. For more information, see “Set PENS options” on page 220.

**Export PDF**  The generated SWF file is inserted into a PDF file and published. This option is useful to share content over email or any other means where the learner doesn’t have access to the content through the Flash Player in a browser.

**Flash Player Version**  Adobe Captivate generates the SWF file in the Flash version that you choose.

The Project Information area displays useful statistics about the project including the size (resolution), number of slides, audio information, e-learning details, accessibility compliance, and the playback control assigned to the project.

To change any of the options listed in this area, click the blue text. To change preferences, click the Preferences button.

**Reduce the size of a SWF file**

You can reduce the size of the published Flash (SWF) file during the publishing process. However, the quality of the published file is compromised.

1. In an open project, select File > Publish.
2. In the left panel, select Flash (SWF).
3. In Flash (SWF) Size And Quality under Project Information in the right panel, click Custom.
4. In the Settings area, use the slider bar to customize the quality of the file and the file size. For more information, see “Change project size and quality” on page 166.

**Note:** The quality of the file increases as you move to the top of the slider, with a corresponding increase in file size.

5. To use the changed setting whenever the file is published, click Retain Slide Quality Settings.
6. Click OK.

**See also**

“Learning management system (LMS)” on page 216

“Set publishing preferences” on page 200
Publish the project as an executable file or AVI file

Publish the project as an executable file

You can create stand-alone, executable files of your Adobe Captivate projects. This publishing option enables you to create a Windows executable file (EXE).

1. Select File > Publish.
2. In the Publish dialog box, select Media, and configure the following options:
   - **Select Type** From the menu, select Windows Executable (*.exe).
   - **Project Title** Enter a name for the executable file without adding the extension (.exe).
   - **Folder** Enter the full path to the folder in which to save the file, or click Browse to locate the folder.
   - **Custom Icon** You can customize the icon that is displayed for the executable file. Click Browse (...) to add a custom icon for your file. Ensure that the icon file has a .ico extension.

You can create a custom icon file using any software meant for that purpose. Ensure that the file you create contains ten images of the following dimensions:
   - 256x256 32-bit color uncompressed
   - 48x48 32-bit color uncompressed
   - 48x48 8-bit color uncompressed
   - 48x48 4-bit color uncompressed
   - 32x32 32-bit color uncompressed
   - 32x32 8-bit color uncompressed
   - 32x32 4-bit color uncompressed
   - 16x16 32-bit color uncompressed
   - 16x16 8-bit color uncompressed
   - 16x16 4-bit color uncompressed

3. Select from the following Output Options:
   - **Zip Files** Creates a ZIP file containing the EXE file.
   - **Full Screen** Runs the executable file in full screen mode.

   **Note:** If you select AICC or SCORM options for the project, you can’t apply the full screen publishing option.

   - **Generate Autorun For CD** An autorun.inf file is generated in the publish directory. The file starts playing as soon as the CD is inserted into the computer.
   - **Flash Player Version** Adobe Captivate generates the SWF file in the Flash version that you choose.

The Project Information area displays useful statistics about the project including the size (resolution), number of slides, audio information, e-learning details, accessibility compliance, and playback control assigned to the project. To change any of the options listed in this area, click the blue text. To change preferences, click the Preferences button.

Publish the project as an AVI file

You can publish your Adobe Captivate project as an AVI file. Open the published AVI file in any of the media players that support the AVI format.

Updated 19 May 2009
You can use any of the encoders available on your operating system for publishing. Alternatively, you can use a third party software that you have installed on your computer.

**Note:** All interactivity in your project is lost when you convert the project to an AVI file.

1. Select File > Publish.
2. In the Publish dialog box, select Media, and configure the following options:
   - **Select Type** From the menu, select Video (*.avi)
   - **Project Title** Enter a name for the AVI file without adding the extension (.avi).
   - **Folder** Enter the full path to the folder in which to save the file, or click Browse to locate the folder.
3. Select from the following output options:
   - **Video Format** The list of encoders available on your system is available here. Select an encoder for publishing the project in the AVI format.
   - **Audio Format** Adobe Captivate uses pulse code modulation (PCM) for audio files. Simply put, PCM converts analog files to binary (digital) files.

The Project Information area displays useful statistics about the project including the size (resolution), number of slides, audio information, e-learning details, accessibility compliance, and playback control assigned to the project. To change any of the options listed in this area, click the blue text. To change preferences, click the Preferences button.

See also
“Set publishing preferences” on page 200

### Publish projects to the web using FTP

You can publish your Adobe Captivate projects directly to a website through FTP.

1. In an open project, select File > Publish.
2. In the Publish dialog box, select FTP and set the following options.
   - **Project Title** Enter the desired name.
   - **Server** Select the name of the server that hosts the FTP site on which you want to publish your project. To add an FTP server to the list, click the browse (...) button, and add or delete servers using the options in the FTP Servers dialog box.
   - **Note:** You will not have to create a separate FTP server list for every project because Adobe Captivate saves changes made to the FTP list automatically. These changes are also captured when you import and export preferences.
   - **Directory** Enter the specific directory on the server listed above to which to upload the files.
   - **User name** Enter a user name with permissions to publish files to the server listed above.
   - **Password** Enter a valid password for the user name.
   - **Port** Enter the correct port number to which you should upload your files. (Port number 21 is commonly used.)
3. Select a file type.
   - **SWF File** Select this option to create a Flash SWF file to FTP.
**Project Files** Select this option to create Adobe Captivate project files (CP) to FTP. This is useful if you want to share the project with someone else who needs to open and edit the project.

4 (Optional) Click Test Settings to test the settings you entered for the server. You will receive either a confirmation message stating that the connection succeeded or an error message explaining why the connection cannot be made.

5 Select from the following output options:

- **Zip Files** This option creates a ZIP file. (A program like WinZip can be used to open the files.)
- **Full Screen** This option opens the file in full screen mode.
- **Export HTML** This option creates a standard JavaScript file that helps embed the SWF file into the HTML file.
- **Send PENS notification** Verifies PENS compliance. For more information, see "Set PENS options" on page 220.

*Note: PENS is enabled only if reporting is enabled. To enable reporting, from the Edit menu, choose Preferences. In the Quiz menu, click Reporting, and select Enable Reporting.*

- **Flash Player Version** Adobe Captivate generates the SWF file in the Flash version that you choose.

6 The Project Information area displays useful statistics about the project including the size (resolution), number of slides, audio information, e-learning details, accessibility compliance, and the playback control assigned to the project. To change any of the options listed in this area, click the blue text. To change preferences, click the Preferences button.

7 Click Publish.

You are notified when the process is complete.

*Note: After the files are uploaded, you can view the project from your web browser by entering the web address http://www.yourwebaddress.com/filename.htm where www.yourwebaddress.com is the URL and filename.htm is the filename you entered in step 2.*

**See also**

“Learning management system (LMS)” on page 216

“Set publishing preferences” on page 200

---

**Send projects using e-mail**

You can send Adobe Captivate projects in a variety of formats through e-mail. You can choose to send an Adobe Captivate (CP) file, a Windows executable file, a SWF file (to bypass many firewall protection systems), or an XML file (XLIFF file).

1 In an open project, select File > Publish.

2 In the Publish dialog box, select E-Mail.

3 In Project Title, enter the desired filename.

4 In File type, select the type of file to create:

- **SWF File** This option sends the necessary Flash project file to the selected mail recipient.
- **Project Files** This option sends the Adobe Captivate project file to the selected mail recipient.
- **XML File** This option sends the XML file as an attachment to the selected mail recipient.
Note: Instead of publishing an Adobe Captivate project as an XML file, you can export the project content to the XML format and use the XML file to edit and localize to the required language. You can then import the localized XML file to the relevant Adobe Captivate project.

5 Select Output Options.

Zip Files  This option creates a ZIP file containing the SWF file.

Full Screen  This option opens the SWF file in full screen mode.

If you select AICC or SCORM options for the project, the full screen publishing option cannot be applied.

If you select the full screen option, Adobe Captivate generates two HTML files to accommodate the Windows XP Service Pack 2 release.

Note: Use both HTML files with the SWF file so that when you publish your project users won’t receive a Service Pack 2 warning message. You should link to the HTML file with “fs” added, for example, “myproject_fs.htm.” The HTML file with “fs” automatically links to the second HTML file, which, in turn, plays your project.

Export HTML  This option creates a standard JavaScript file that helps embed the SWF file into the HTML file.

Flash Player Version  Adobe Captivate generates the SWF file in the Flash version that you choose.

6 The Project Information area displays useful statistics about the project including the size (resolution), number of slides, audio information, e-learning details, and the playback control assigned to the project. To change any of the options listed in this area, click the blue text. To change preferences, click the Preferences button.

7 When you are done, click Publish.

Adobe Captivate builds the project and opens your default e-mail program.

8 Enter the desired e-mail address in the appropriate field and send the e-mail message.

See also
“Set publishing preferences” on page 200

Get reports by e-mail

Get reports
You can receive the results of the assessment taken by the user through e-mail. The result is sent as a comma-separated value (CSV) file to the specified e-mail address. You can open the CSV file in Microsoft Excel to view the report.

Specify e-mail as the reporting option in the Preferences dialog box to enable reports to be sent by e-mail.

After setting your preferences, do the following:

• Publish the project using the SWF option.
• Post the published files to a web server.
• Send the URL to the users taking the test.

After the users complete the test, they must click the Send E-mail button. Adobe Captivate creates an e-mail message and sends it to your e-mail address. This process happens in the background and usually requires no user intervention.

Updated 19 May 2009
Specify e-mail preferences

1. Select Edit > Preferences.

2. In the Preferences dialog box, select Reporting from the Quiz menu.

3. Select E-mail, and specify the e-mail address to which the reports are sent. The e-mail address is usually not disclosed to the user.

4. Specify whether the CSV content must be sent in the body of the e-mail, or as an attachment.

   *Note: The CSV content is sent as an attachment with the .att extension. Rename the file to a .csv extension and open it in Microsoft Excel.*

5. Click OK.
Chapter 15: Using Adobe Captivate with Other Applications

You can integrate Adobe Captivate with other applications such as the following:

- Adobe Flash
- RoboHelp
- Microsoft Power Point
- Learning Management Systems (LMSs), such as Adobe Acrobat Connect Pro, or Questionmark Perception.

Microsoft PowerPoint

You can import and edit Microsoft PowerPoint presentations in Adobe Captivate. Imported slides can be edited in a Microsoft PowerPoint environment from within Adobe Captivate. You can choose to link to the source PowerPoint presentation to keep it in sync with the Adobe Captivate project.

When a PowerPoint presentation is linked to an Adobe Captivate project, Adobe Captivate creates a reference to the source presentation. When the linked presentation is opened in Adobe Captivate for editing, the source presentation is loaded into Adobe Captivate. Because the source presentation is referenced, and not embedded into the project, linking to presentations does not affect the file size of the Adobe Captivate project.

When you import a presentation into Adobe Captivate without linking to it, the entire source presentation is embedded into the project. Editing an embedded presentation does not affect its source file. However, embedding increases the file size of the Adobe Captivate project. You can embed the presentation when the location of the Microsoft PowerPoint presentation is not fixed. Embedding is also useful when the Adobe Captivate project must be opened on a computer that doesn’t have access to the Microsoft PowerPoint presentation.

Adobe Captivate supports PowerPoint presentations with the extensions .ppt, .pps, .pptx, and .ppsx. You can import PPT and PPS slides even if you do not have PowerPoint installed on your computer. However, you can’t edit them after import. To import PPTX and PPXS slides, you must have PowerPoint installed on your system. Adobe Captivate converts PPTX files to PPT files during import. The information loss that occurs during such conversion is documented on the Microsoft website http://office.microsoft.com/en-us/powerpoint/HA101023491033.aspx.

Some of the actions in Microsoft PowerPoint are not supported in Adobe Captivate. Custom animations applied to SmartArt graphics in PowerPoint 2007 are not supported in Adobe Captivate.

Note: Best practice is to install PowerPoint using the default options.

<table>
<thead>
<tr>
<th>Scenario</th>
<th>PowerPoint version required</th>
</tr>
</thead>
<tbody>
<tr>
<td>Import PPT file</td>
<td>It is not necessary to install PowerPoint if you are importing slides from a PPT file.</td>
</tr>
</tbody>
</table>
Open, edit, and save the PowerPoint file in PowerPoint before importing it into Adobe Captivate. Performing this procedure ensures that the PowerPoint version installed on your computer is stable.

**PowerPoint tips**

Follow these guidelines when you work with Adobe Captivate and PowerPoint:

- Avoid parallel edits. For example, suppose you edit a linked PowerPoint file within Adobe Captivate and a copy of it outside the application simultaneously. In such cases, the results are unpredictable.

- Avoid updates with older PPT versions. If you want to edit an embedded PPT file outside of Adobe Captivate, export the file from the resource Library and then edit the file. The edited file can then be updated in Adobe Captivate.

- Disable installation of interactive PowerPoint plug-ins which start automatically.

- Avoid linking to PowerPoint files over the network on a shared network drive. The results are unpredictable if you lose connectivity while working with the shared file.

**Import PowerPoint presentations into Adobe Captivate**

1. In an open project, Select File > Import > PowerPoint Slides.

2. Navigate to and select the PowerPoint presentation file format that you want to import.

3. Click Open.

4. Decide where to place the imported PowerPoint slides in the Adobe Captivate project. Add the slides to the end of the project, or click a slide in the list and add the PowerPoint slides after that slide.

5. Click OK.

6. In the Convert PowerPoint Presentations dialog box, do the following:
   a. Select the PowerPoint slides to convert to Adobe Captivate project slides.
   b. Set navigation preferences for the selected slides.
   c. If you want to link to the PowerPoint presentation, select Linked. If you want to embed the PowerPoint presentation, deselect Linked.

7. Click OK.

   The PowerPoint slides are imported into the Adobe Captivate project and appear in the designated location. If necessary, you can change the order of the slides.
Narration in a PowerPoint presentation slide is imported as a sound object and appears as a separate object on the Timeline. Even in the linked mode, changes made to the audio file in Adobe Captivate after import are not reflected in the respective Microsoft PowerPoint presentation. Similarly, changes made to the audio file in Microsoft PowerPoint are not reflected in the Adobe Captivate project. Object sounds are retained in the SWF file that is created from slides containing such objects.

Slide labels and notes are imported only during the first import. Any subsequent changes to the labels and notes in PowerPoint are not reflected in Adobe Captivate.

Create Adobe Captivate projects from PowerPoint presentations

1. In an open project, Select File > New > Project.
2. Select From MS PowerPoint, and click Browse.
3. Navigate to and select the PowerPoint presentation file format that you want to import.
4. In the Convert PowerPoint Presentations dialog box, do the following:
   a. Enter the name of the project.
   b. Select a size for the new Adobe Captivate project. The size displayed is the actual size of the slide in PowerPoint. Best practice is not to change the size.
   c. Select the PowerPoint slides to convert to Adobe Captivate project slides.
   d. Set navigation preferences for the selected slides.
   e. If you want to link to the PowerPoint presentation, select Linked. If you want to embed the PowerPoint presentation, deselect Linked.
5. Click OK.

Insert Adobe Captivate projects into PowerPoint presentations

You can insert Adobe Captivate projects into Microsoft PowerPoint presentations in a few simple steps. Publish an Adobe Captivate project as a SWF file. Then open a PowerPoint presentation and insert the published SWF file into a slide.

*Note: For information on inserting Adobe Captivate projects into Microsoft PowerPoint 2007, see the topic on PowerPoint 2007 on the Microsoft website.*

1. Create and edit the project in Adobe Captivate.
2. Publish the project as a SWF file.
3. Note the location of the saved SWF file.
4. Open the PowerPoint presentation to which you want to add the Adobe Captivate project.
5. In the Developer menu, select More Controls from the Control Toolbox.
7. From the list of objects, select Shockwave Flash Object.
8. Drag diagonally to create a box for the project.
   - You can resize the box in which the project appears. Return to the slide that contains the project in PowerPoint, and drag the resizing handles.
9. Right-click the box and select Properties.
10. In the Properties dialog box, click once on the top line, Custom.
11 Click once on the Ellipsis button.

The Property Pages dialog box appears.

12 In Movie URL, enter the location of the SWF file to add. Type the full path, including the filename (for example, C:\My Documents\MyFile.swf) or URL to the SWF file that you want to play.

13 Click OK.

14 In the PowerPoint Properties dialog box (opened in step 9), set the following properties:
   - Set the Playing property to True to play the file automatically when the slide is displayed. If the SWF file has a Start/Rewind control built in to it, you can set the Playing property to False.
   - If you don’t want the animation to play repeatedly, set the Loop property to False. (Click the cell to display a down arrow; then click the arrow and select False.)
   - Set Embed Movie to True to ensure that the Adobe Captivate project is always included with the PowerPoint presentation.

15 When you finish setting options, close the Properties dialog box.

16 Test the project. From the View menu, select Slide Show. (In Microsoft Windows 2003, click the Slide Show menu and select View Show.)

17 To exit the slide show and return to normal view, press Esc.

**Edit imported PowerPoint slides within Adobe Captivate**

You can edit an individual slide or the entire set of slides imported from a PowerPoint presentation within Adobe Captivate without launching PowerPoint. If you want to edit only a few slides, edit each slide individually. It is faster than editing the entire presentation.

When you send an Adobe Captivate project with linked slides for editing, send the PowerPoint presentation along with the project. Sometimes the recipient has to relink the presentation before editing it.

1 Import the PowerPoint presentation into your project.

2 Open the slides in Edit mode. Navigate to a slide imported from PowerPoint.

3 Click Edit PPT and select one of the following options.
   - **Edit Slide** Edit the selected slide
   - **Edit Presentation** Edit the entire presentation.
   - **Find Presentation In Library** Locate the presentation in the library. When you select this option, the presentation is highlighted in the library.
   - **Export Animation** Convert the selected slide to a SWF file. After conversion, Adobe Captivate prompts you to save the SWF file.

4 When you select Edit Slide or Edit Presentation, the PowerPoint editing environment opens within the Adobe Captivate window. You can edit the slides in Microsoft PowerPoint.

5 After you complete editing, click Save PPT.

6 The Adobe Captivate editing environment appears.

7 Save the project.
**Update PowerPoint presentation changes made outside Adobe Captivate**
Updating is necessary when the PowerPoint file is linked and the changes are made directly in Microsoft PowerPoint.

1. Open the Adobe Captivate project in Edit mode and navigate to a slide that was imported from the PowerPoint presentation.
2. Click Edit PPT and select Find Presentation In Library. When you select this option, the PowerPoint presentation containing the slide is highlighted in the library.
3. Right-click the presentation in the Presentation folder.
4. Select Update.

**Change link type after importing the presentation**

1. Open the Adobe Captivate project in Edit mode and navigate to a slide that was imported from the PowerPoint presentation.
2. Click Edit PPT and select Find Presentation In Library. When you select this option, the PowerPoint presentation containing the slide is highlighted in the library.
3. In the Library panel, right-click the presentation in the Presentation folder.
4. Do one of the following:
   a. Select Change To Linked if you have not linked to (embedded) the presentation during import. Specify a location for the linked file on your computer.
   b. Select Change To Embedded to embed the linked file into your project.

**Change the link to the presentation after importing**
When you send an Adobe Captivate project for editing, the recipient sometimes has to relink the presentation to the project.

1. Open the Adobe Captivate project in Edit mode and navigate to a slide that was imported from the PowerPoint presentation.
2. Click Edit PPT and select Find Presentation In Library. When you select this option, the PowerPoint presentation containing the slide is highlighted in the library.
3. Right-click the presentation and select Properties.
4. Click the hypertext link pointing to the location of the presentation.
5. In the error message, click OK to choose another location.
6. Navigate to the presentation and click Open.

**Reduce file size of projects with embedded slides**
You can import a presentation into an Adobe Captivate project without linking (embedded mode). The entire presentation is embedded into the Adobe Captivate project. Slides that are not selected during import are also imported into the Adobe Captivate project, but they are not visible in the project. When you choose to reduce the file size, Adobe Captivate deletes such slides permanently from the project. This process is irreversible.

1. Open the Adobe Captivate project in Edit mode and navigate to a slide that was imported from the PowerPoint presentation.
2 Click Edit PPT and select Find Presentation In Library. When you select this option, the PowerPoint presentation containing the slide is highlighted in the library.

3 In the Library panel, right-click the presentation in the Presentation folder.

4 Select Compact.

Note: The Compact option is disabled for linked presentations.

Microsoft Word

If you have Microsoft® Word® installed on the same computer as Adobe Captivate, you can publish Adobe Captivate projects in Microsoft Word. Your output can be published in various formats: handout, lesson, step-by-step, and storyboard.

Publish projects as handouts

You can publish Adobe Captivate projects as handouts in Microsoft Word format. An Adobe Captivate project is published into a Word document showing all the slides as they would appear with the options you choose.

1 Open an Adobe Captivate project.

2 Select File > Publish.

3 In the Publish dialog box, select Print.

4 In Project Title, enter the desired name without the filename extension (.doc).

5 In Folder, enter the full path for the folder in which to save the file or click Browse to locate the folder.

6 Select an Export range. The export range is made up of the slides that you want to export to Word. You can select all slides, the current slide, a selection, or a range of slides.

7 In Type, select Handouts.

8 Select from the following Handout Layout options:

   Use Tables In The Output Specify the number of slides printed on each page.

   Slides Per Page Specify the number of slides printed on each page of the Word document. A small thumbnail image to the right shows a preview of the page layout selected.

   Caption Text Print the text of captions underneath the slides on which they appear.

   Add Blank Lines For Notes Print blank lines with each slide of your project in the Word document. The lines appear under the slide if you select Use Tables in the output. If you deselect that option, the blank lines appear to the right of the slide.

   Slide Notes Include slide notes in your Word document. (Users who view your project don’t see these notes.)

   Include Objects And Question Slides Include captions, images, click boxes, highlight boxes, and other objects on slides.

   Include Hidden Slides Include slides marked as hidden. (Hidden slides do not appear when the project is viewed.)

   Include Mouse Path Include mouse paths that appear on slides.

   Include Question Pool Slides Includes question slides from the question pool.

9 When you finish, click Publish.

Microsoft Word opens with the new project document. Modify the file as desired and save it.
Note: The DOC file is created using a Microsoft Word template named AdobeCaptivate.dot. This template contains a header with the date and a footer with page numbers. If you want to change or remove the information in the header or footer, you can edit the DOT file by opening it in Word. When you install Adobe Captivate, the AdobeCaptivate.dot template is automatically placed in the program folder: \Program Files\Adobe\Adobe Captivate 4.

See also
“Edit project preferences” on page 165

Publish projects as lessons
You can publish Adobe Captivate projects as lessons in Microsoft Word format. An Adobe Captivate project is published in a Word document as a lesson, complete with your questions and an answer key.

1 In an open project, select File > Publish.
2 In the Publish dialog box, select Print.
3 In Project Title, enter the desired name without the filename extension (.doc).
4 In Folder, enter the full path for the folder in which to save the file or click Browse to locate the folder.
5 Select an export range. The export range is made up of the slides that you want to export to Word. You can select all slides, only the current slide, only the current selection, or a range of slides.
6 In Type, select Lesson.
7 Select from the following Template options:
   Header Text Enter text that you want to appear in the header of the project.
   Footer Text Enter text that you want to appear in the footer of the project.
   Include Hidden Slides Select this option if you want hidden slides to appear in the published project.
   Include Quiz Question Slides Select this option if you want to include quiz question slides in the published project.
   Include Question Pool Slides Select this option if you want the published project to include question slides from the question pool.
8 When you finish, click Publish.

Microsoft Word opens with the new project document. Modify the file as desired and save it.

Note: The Lesson, Storyboard, and Step By Step templates are stored in the Gallery (C:\Program Files\Adobe\Adobe Captivate 4\Gallery\PrintOutPut). When Adobe Captivate is first launched, these templates are copied to the user profile (for example, C:\Documents and Settings\<User>\My Documents\My Adobe Captivate Projects\Templates\PrintOutput).

Publish projects as step-by-step guides
You can publish Adobe Captivate projects as a step-by-step guide in Microsoft Word format. An Adobe Captivate project is published in a Word document that lists a summary of the steps taken in the project. For example, if the project teaches a user how to navigate to a website, the step-by-step guide lists the steps taken to get there. The step-by-step guide does not include images of the project slides, but does include images of objects (buttons, links, and so on).

1 Open an Adobe Captivate project.
2 Select File > Publish.
3 In the Publish dialog box, select Print.

Updated 19 May 2009
4. In Project Title, enter the desired name without the filename extension (.doc).
5. In Folder, enter the full path for the folder in which to save the file or click Browse to locate the folder.
6. Select an export range. The export range is made up of the slides that you want to export to Word. You can select all slides, only the current slide, only the current selection, or a range of slides.
7. In Type, select Step By Step.
8. Select from the following Template options:
   - **Header Text**: Enter text that you want to appear in the header of the project.
   - **Footer Text**: Enter text that you want to appear in the footer of the project.
   - **Include Hidden Slides**: Select this option if you want hidden slides to appear in the published project.
9. When you finish, click Publish.

Microsoft Word opens with the new project document. Modify the file as desired and save it.

**Note:** The Lesson, Storyboard, and Step By Step templates are stored in the Gallery (for example, C:\Program Files\Adobe\Adobe Captivate 4\Gallery\PrintOutput). When Adobe Captivate is first launched, these templates are copied to the user profile (for example, C:\Documents and Settings\<User>\My Documents\My Adobe Captivate Projects\Templates\PrintOutput).

### Publish projects as storyboards

You can publish Adobe Captivate projects as storyboards in Microsoft Word format. The project is published as a Word document that includes a summary of project properties and a detailed view of each slide. Project properties include the number of slides used, score setting details, length of the slides, and so on. The detailed view of each slide has a summary of slide properties.

If the project has a quiz and you choose Storyboard output, the answers are shown next to the question. There is no answer key.

1. Open an Adobe Captivate project.
2. Select File > Publish.
3. In the Publish dialog box, select Print.
4. In Project Title, enter the desired name without the filename extension (.doc).
5. In Folder, enter the full path for the folder in which to save the file or click Browse to locate the folder.
6. Select an export range. The export range is made up of the slides that you want to export to Word. You can select all slides, only the current slide, only the current selection, or a range of slides.
7. In Type, select Storyboard.
8. Select from the following Template options:
   - **Header Text**: Enter text that you want to appear in the header of the project.
   - **Footer Text**: Enter text that you want to appear in the footer of the project.
   - **Include Hidden Slides**: Select this option if you want the published project to include hidden slides.
   - **Include Quiz Question Slides**: Select this option if you want the published project to include quiz question slides.
   - **Include Question Pool Slides**: Select this option if you want the project to include question slides from the question pool.
9. When you are done, click Publish.

Microsoft Word opens with the new project document. Modify the file as desired and save it.
Learning management system (LMS)

You can use a learning management system (LMS) to distribute a computer-based tutorial created using Adobe Captivate over the Internet. A learning management system is used to provide, track, and manage web-based training.

The project that you upload to the LMS must be compliant with the SCORM/AICC standards. When you publish a project after setting the required SCORM/AICC options, Adobe Captivate creates the necessary files required for compliance to these standards. You can directly upload the published package to an LMS.

The following workflow is usually used for creating an LMS-ready package using Adobe Captivate and uploading it to an LMS.

1. Create an Adobe Captivate project with at least one slide containing an interactive object, and for which reporting has been enabled.
2. Set the SCORM/AICC options using the Preferences dialog box.
3. Publish the project as a SWF file after enabling the Export HTML option. Best practice is also to select compression in a ZIP file. This way, you can upload the package as a single file to the LMS.
4. Do one of the following:
   - Upload the published project files or the ZIP file directly to the LMS.
   - Publish the Adobe Captivate project and upload it to an HTTP location (your content server). Use the PENS settings in Adobe Captivate to load content from the content server to the LMS.

PENS (Package Exchange Notification Services) is a protocol that enables single-click publishing between systems that support e-learning such as authoring tools and an LMS. The published content must be compliant with AICC or ADL SCORM content package formats.

SCORM (Shareable Content Object Reference Model) is a set of specifications used to produce reusable e-learning objects. It defines communication between a client (such as Adobe Captivate) and a host (usually an LMS). SCORM is distributed by Advanced Distributed Learning, an organization under the US Department of Defense.

AICC (Aviation Industry CBT [Computer-Based Training] Committee) standards define how content for e-learning is developed, delivered, and evaluated.

Create an LMS-ready file in Adobe Captivate

To create an LMS-ready file in Adobe Captivate, do the following:

- Enable reporting for the project in the SCORM/AICC format using the Preferences dialog box.
- Publish the Adobe Captivate project using the Flash (SWF) option.

When you enable reporting for the project by setting the SCORM options, Adobe Captivate creates the following files when the project is published:

**Manifest File** This file is used to import the Adobe Captivate project into the LMS. The manifest file, imsmanifest.xml, contains the metadata of the project and its course structure.

**HTML File** Launches the Adobe Captivate project from the LMS.
Using Adobe Captivate with Other Applications

JavaScript File  Acts as a link between the SWF file and the LMS. Adobe Captivate sends tracking data to the LMS using the JavaScript APIs.

SWF File  The contents of the published project are stored in the SWF file.

Other supporting Files (.xsd Files)  Contain other information required by the LMS.

SCORM_support Folder  The files in this folder ensure compliance to the SCORM standards during run time.

When you enable reporting for the project using the AICC option, the information required by AICC is stored in the SWF file itself. The JavaScript that is generated for AICC is the standard JavaScript that is published for an Adobe Captivate project.

1  In an open project, select Quiz > Quiz Preferences.
2  In the Project Preferences dialog box, select Reporting from the Quiz menu.
3  Select Enable Reporting For This Project.
4  Select Standard.
5  Select SCORM from the menu.
6  Click Manifest.
7  Set the SCORM version by clicking the pop-up menu and selecting 1.2 or 2004.
8  In the Course area, set the following manifest options:

   SCORM Version  The runtime files (HTML, SWF files) that are generated after publishing are the same irrespective of the version that you select. However, the packaging files generated during publishing depend on the specified version number. Packaging files are the files that Adobe Captivate generates in addition to the runtime files. Packaging files help import the Adobe Captivate project into an LMS.

   Identifier  (Required field) The identifier used by the LMS to identify different manifests. A default identifier based on the name of your Adobe Captivate project is automatically added to this field. You can change the identifier at any time by selecting the text and typing in new text.

   Title  (Required field) The title of your project that is displayed to the user viewing the project using an LMS. A default title based on the name of your Adobe Captivate project is automatically added to this field. You can change the title at any time by selecting the text and typing in new text.

   Description  (Required field) The text that the LMS displays to describe your project. A default description based on the name of your Adobe Captivate project is automatically added to this field. You can edit the description at any time.

   Version  (Required field) The version specifies a number that can be used to differentiate manifests with the same identifier. For example, if you are uploading the same project after modifying it, use a different version number.

   Duration  (Optional field) Specify the approximate time it takes to work with this particular Adobe Captivate project.

   Subject  (Optional field) Select this option to write a short description of the Adobe Captivate project using keywords or phrases. For example, if the project is about animals, you can specify the subject as zoology.

9  In the SCO area, you can set the following manifest options:

   Identifier  (Required field) The LMS uses the identifier to identify different shareable content objects (SCOs). In the Adobe Captivate context, SCO refers to the Adobe Captivate project. A default identifier based on the name of your Adobe Captivate project is automatically added to this field. You can change the identifier at any time by selecting the text and typing in new text.
Note: A course can contain more than one project. Each project is treated as a distinct SCO. However, Adobe Captivate does not support more than one project in a course.

**Title**  (Required field) A default title based on the name of your Adobe Captivate project is automatically added to this field. You can change the title at any time by selecting the text and typing in new text.

**Mastery Score**  (Optional field) The passing score for the project. The score is a number from 0 through 100. This field is enabled for projects containing score-reporting objects, such as quiz slides, text entry boxes, click boxes, or buttons.

**Time Allowed**  (Optional field) The maximum time allowed to complete the project.

**Time Limit Action**  (Optional field) The action taken when the maximum time allowed to complete the project has been exceeded. Use the options to define the action that takes place if the user exceeds the specified time:

- **Exit With Message**  The project closes after displaying a message to users that they have exceeded the time limit for the project.
- **Exit Without Message**  The project closes without displaying any message to the user.
- **Continue With Message**  The project continues to play after displaying a message to the user.
- **Continue Without Message**  The project continues to play without informing the user of the extended time.

**Launch Data**  (Optional field) The initialization data that the SCO expects from the LMS. Because a SWF file cannot be modified based on the initialization data, this option can be left blank for Adobe Captivate projects.

10 Click OK to return to the Preferences dialog box.
11 Select an LMS from the menu. If the LMS to which you are connecting is not listed in the menu, select Default.
12 Select the condition for the report status. The report status is sent after every user attempt to the LMS.

- **Complete/Incomplete**  The report status is sent as complete or incomplete depending on the options set in the Choose Report Data section.
- **Pass/Fail**  The report status is sent as pass or fail depending on the options set in the Choose Report Data section.

13 Select an option in Choose Report Data. The report status is set depending on the options you choose.

- **Quiz Results Only**  The status is sent as Fail/Incomplete after every user interaction until the user achieves the minimum score required to pass the exam. From then on, the status is reported as Pass/Complete to the LMS.
- **Adobe Acrobat Connect Pro**  The report is generated in the Adobe Acrobat Connect Pro format.
- **User Access Only**  The status is sent as Pass/Complete even if a single user interaction occurs.
- **Slide Views Only**  The status is sent as Pass/Complete only after the user has completed viewing the prescribed number of slides.
- **Quiz Results And Slide Views**  The status is sent as Pass/Complete only after the user has achieved the minimum score and has viewed the prescribed number of slides.

14 You can choose to send the score to the LMS in points or as a percentage. Choose the Percent option because of its better compliance with LMS.

15 You can choose to send information on the interaction and the final score or just the final score. The entire course of user interaction until the end of the project is tracked if you choose Interaction And Score.

16 Click LMS Customization Settings, and select options in the LMS Customization Settings dialog box:

- **Never Send Resume Data**  The project notifies the LMS when users resume a session after taking a break. Users see the page at which they left off earlier. If this option is enabled, users see the first page when they resume the project.

Updated 19 May 2009
Escape Version And Session ID  Converts the version and session ID to its URL encoded values.

Don’t Escape Characters  Supports the escape version and session ID option. Type the characters that should not be included in the escape version and session ID.

17 Click OK.

The manifest file is generated. To see the manifest file, publish your Adobe Captivate project and create a SWF file. If you used the default save location, you see the SWF file and imsmanifest.xml file in your My Documents\My Adobe Captivate 4 Projects folder.

Note: If necessary, you can create a package interchange file (PIF). The PIF packages the Adobe Captivate project output files and manifest file (with additional files if you are using the SCORM 2004 option).

Publish the project for an LMS

After you set the SCORM/AICC options, you must publish the project as a SWF file.

When you choose to zip the published files, the entire set of published files is compressed into a single ZIP file. The ZIP file containing the manifest file is also called a PIF (Package Interchange File). SCORM guidelines recommend, but do not require, the use of a PIF for transporting content packages between systems. However, some LMSs require you to upload the project as a PIF. In any case, it is always simpler to upload a single file to the LMS rather than many files.

1  Open an Adobe Captivate project.
2  Select File > Publish.
3  On the left of the Publish dialog box, select Flash (SWF).
4  In Project Title, enter the name without the filename extension (.swf).
5  In the Folder text box, enter the full path to the folder in which to save the file or click Browse to locate the folder.
6  In Output Options, select Zip Files And Export HTML. This option packages the course into a PIF by creating a ZIP file containing the Flash (SWF) file and the HTML file.
7  Click Publish.

Upload the project

You can upload the created project directly to an LMS or host it on your content server. Specify the required information for PENS in Adobe Captivate if you want to upload the project from the content server to an LMS.

1  In an open project, select Edit > Preferences.
2  In the Preferences dialog box, select PENS from the Quiz menu.
3  In the Package section, enter the following information that the LMS requires to connect to and publish the project.
   Source URL  The location (URL) of the project on the content server.
   User ID And Password  Specify the login details for the LMS to connect to the specified URL on the content server.
   URL Expiry  Specify the date and time after which the URL expires. At that point, the LMS can no longer access the URL.
4  In the LMS section, specify the following details for the LMS.
   Target URL  URL of the Learning Management Server where the project from the content server is published.
   User ID and Password  Login credentials to publish the project from the content server to the target URL.
Send Using  Select the method (HTTP-GET or HTTP-POST) that the LMS uses to transmit the learning content package.

Set PENS options
PENS allows for coordination between Adobe Captivate and e-Learning publishing and management systems. PENS allows you to automate the notification, transfer, and delivery of content packages between Adobe Captivate and LMSs.

1  In an open project, select Edit > Preferences.
2  Select PENS from the Quiz menu.
3  Enter information for the following options in the Package section of the Quiz panel:
   Source URL  Enter the location where the learning content package is stored.
   User ID And Password  Enter a required user ID and password.
   URL Expiry  Enter the expiration date and time for the learning content package. Default date and time is 24 hours from the time that you set PENS data.
4  Enter information for the following options in the LMS section of the Quiz panel:
   Target URL  Enter the location of the publishing/management server.
   User ID and Password  Enter the user ID and password required by the publishing/management server.
   Send Using  Select the method (HTTP-GET or HTTP-POST) that the LMS uses to transmit the package.
   Command  Select one of the following commands:
      - Collect  Uploads a new project to the LMS.
      - Delete  Deletes a project from the LMS.
      - Revise  Updates the existing project in the LMS with the new version.
Note: The PENS protocol currently supports only the Collect command.
   Receipt E-mail  Specify the e-mail address to which the notification should be sent after the source package is uploaded to the LMS.
   Receipt URL  You can choose to have a standard web page displayed after the upload to the LMS is complete. For example, the web page could have a single-line message saying, “The file has been successfully uploaded to the LMS.” Enter the URL for the page that will be displayed in this field.
   Receive Alerts While LMS Is Processing The Package  Select this option if you want to be informed of any alerts when the package is being uploaded to the LMS. The alert is sent to you using the option you have set in the Receipt URL field.
   Preview  Click this button to see a summary of the PENS information.

Adobe Acrobat Connect Pro
Use Adobe® Acrobat® Connect™ Pro to host online meetings, presentations, and training over the Internet. The integration between Acrobat Connect Pro and Adobe Captivate allows you to include interactive software simulations and demonstrations in Connect meetings.
The key integration features include the following:

**Acrobat Connect Pro And Adobe® Connect™ Training** Increase meeting and training effectiveness by adding Adobe Captivate demonstrations and interactive simulations. Presenters can use the Sync button to make their actions visible to all participants. If the presenter turns off the Sync option, participants can fully interact with the Adobe Captivate demonstration or simulation on their individual computers.

**Deliver and publish with ease** Deliver Adobe Captivate simulations and demonstrations through standard web browsers. Acrobat Connect Pro users can publish Adobe Captivate projects directly to Acrobat Connect Pro, making them accessible to others.

**Use options for integrating Adobe Captivate and Acrobat Connect Pro** In Adobe Captivate, you can select two options that help Adobe Captivate and Acrobat Connect Pro work together smoothly. The Include Adobe Acrobat Connect Metadata option adds Connect information to the Adobe Captivate project files. When this option is set, users can search the Adobe Captivate project and its contents from Acrobat Connect Pro. You can also select Acrobat Connect Pro as your quiz reporting output option. Use this option in Acrobat Connect Pro to track how users work with quizzes and interactive objects in Adobe Captivate projects. You can also place the project into a ZIP file for easier uploading. With Acrobat Connect Pro integration, you can also update video files easily.

**Using Acrobat Connect Pro as an LMS**
Adobe Acrobat Connect Pro has a built-in learning management system that you can use to provide training and assess the progress of users. Do the following to upload an Adobe Captivate project to an Acrobat Connect Pro server:

- Specify Acrobat Connect Pro as the LMS in the Preferences dialog box.
- Publish the project to the Adobe Acrobat Connect Pro server.

**Specify Adobe Acrobat Connect Pro as the LMS**
1. Select Edit > Preferences.
2. In the Preferences dialog box, select Reporting from the Quiz menu.
4. Click OK.

**Publish project to Adobe Acrobat Connect Pro**
Apart from the SWF file, you can choose to upload source files and any external FLV files to the server. You can also choose to upload the project as a single zip file.
1. Select File > Publish.
2. Select Adobe Acrobat Connect Pro.
3. Click Change Server and add the name and URL of the Acrobat Connect Server.
4. In the Adobe Acrobat Connect Pro Server dialog box, click Add.
5. Enter the name and URL of the Acrobat Connect Server to which you want to load the project.
6. In the Publish dialog box, select the options as required.
   - **Publish Project Files (*.cp)** The source file is uploaded to the server.
   - **Zip Project File** All the published files are uploaded to the server as a single zip file.
   - **Publish Video Files (*.flv)** Publishes any video files that you have imported into the Adobe Captivate project.
7. Click Publish.
8 In the Adobe Acrobat Connect Pro window, enter your login credentials.

9 Click New Folder, and create a folder where you want to upload the project file. Alternatively, you can select any existing folder from the list.

10 Click Publish To This Folder.

11 In the Adobe Acrobat Connect Pro Server window, do the following:
   a Enter a name for your project in the Title field.
   b If you want to customize the URL for the project, enter a name in the Custom URL field. The URL prefix http://<servername>/ is added.
   c Enter a description for your project.
   d Select the language in which your project has been created.
   e Click Finish.

After you have uploaded the content to Adobe Acrobat Connect Pro, you can make it a part of an existing course or a new course.

Add an Adobe Captivate demo to an Acrobat Connect Pro meeting

You can bring an Adobe Captivate project into an Acrobat Connect Pro meeting using two different methods:

- Publish the Adobe Captivate project directly to Acrobat Connect Pro. Add the project from the Connect Content library to an Adobe Acrobat Connect Pro meeting. (Adobe recommends using this option. Adding the Adobe Captivate project from the Content library ensures that all Adobe Captivate features work properly within Acrobat Connect Pro.)

- Publish the Adobe Captivate project to create a ZIP file stored on your computer and then add the ZIP file to an Acrobat Connect Pro meeting.

Presenters can use the Sync button so that all participants can view their actions. As the presenter moves the mouse or interacts with the demonstration, all meeting participants see the actions on their computers. Presenters can also turn off the Sync option so participants can fully interact with the Adobe Captivate demonstration or simulation on their individual computers. Presenters can turn the Sync feature off and on as many times as necessary.

Note: The Sync button in Acrobat Connect Pro is not displayed if the Adobe Captivate project contains the _skin file.

If you want to include multiple files in an Acrobat Connect Pro, ensure that you do the following:

1 Select Edit > Preferences.
2 In the Category panel, expand Project, and select Publish Settings.
3 Select Publish Adobe Connect Pro Metadata in the Project panel.
4 Click OK.
5 Select File > Publish.
6 Select Flash (SWF).
7 In Output Options, select ZIP Files.
   Upload the ZIP file to an Adobe Acrobat Connect Pro meeting.

Add an Adobe Captivate project from the Connect Content library to a meeting

1 In Adobe Captivate, create a project.
2 Publish the project to Acrobat Connect Pro.
3. Open an existing meeting or create a meeting.
4. Send the meeting URL to the people you want to invite.
5. Enter the meeting room.
6. Select Pods > Share > Select From Content Library.
7. Select the Adobe Captivate project, and click Open.
8. (Optional) Click the Sync button as necessary so participants either see actions taken by the presenter or they have control on their individual computers.
9. Click Stop Sharing to return to the Acrobat Connect Pro meeting room.

**Add an Adobe Captivate project from your desktop to a meeting**

1. In Adobe Captivate, create a project.
2. Publish the project to Flash to create a SWF file.
3. Note the location of the SWF file.
4. Log in to Acrobat Connect Pro.
5. Open an existing meeting or create a meeting.
6. Send the meeting URL to the people you want to invite.
7. Enter the meeting room.
8. Select Pods > Share > Select From My Computer.
9. Navigate to the Adobe Captivate SWF file, select the file, and click Open.
10. The upload message appears. When the SWF file has been uploaded, click the Play button on the Adobe Captivate playbar to start the project.
11. (Optional) Click the Sync button as necessary so participants either see actions taken by the presenter or they have control on their individual computers.
12. Click Stop Sharing to return to the Acrobat Connect Pro meeting room.

**Add Acrobat Connect Pro tracking**

You can track how users interact with an Adobe Captivate simulation added to an Adobe Acrobat Connect Pro meeting. To simplify tracking, specify Adobe Acrobat Connect Pro as the project output option. Access this option from the Quiz settings in the Preferences dialog box.

1. Open an Adobe Captivate project.
2. Select Quiz > Quiz Preferences.
3. From the Quiz menu, select Reporting.
4. Select Enable Reporting For This Project.
5. Select Adobe Acrobat Connect Pro.
6. Click OK.

**Enable Acrobat Connect Pro search features**

If you enable search, users can search for the Adobe Captivate project from Acrobat Connect Pro.

1. Open an Adobe Captivate project.
2 Select Edit > Preferences.
3 In the Category panel, expand Project and select Publish Settings.
4 Select Publish Adobe Acrobat Connect Pro Metadata.
5 Click OK.

*Note: The Include Adobe Connect Metadata option is selected by default. This option increases the size of the project. If you are not going to use the project with Acrobat Connect Pro, deselect this option.*

**Questionmark Perception**

You can import Adobe Captivate projects into Questionmark Perception. Questionmark Perception is third-party LMS software that is used for scheduling and managing tests. It also offers a higher level of security for the tests.

To import an Adobe Captivate project into Questionmark Perception, do the following:

- Specify Questionmark Perception preferences in the Preferences dialog box.
- Publish the project using the SWF option.

The published folder contains a QML file that you must import into Questionmark Perception.

**Specify Questionmark Perception preferences**

1 Select Edit > Preferences.
2 In the Preferences dialog box, select Reporting From The Quiz Menu.
3 Select Enable Reporting For This Project.
4 Select Questionmark Perception.
5 Select the other options as required, and click OK.

**Publish the project for Questionmark Perception**

1 Select File > Publish.
2 Select Flash (SWF).
3 Enter a name for the project.
4 Specify a location for the published files.
5 Deselect Zip Files.
6 Click OK.

**Upload the project to Questionmark Perception**

1 Copy the SWF file to the \authoring\resources\multimedia\ folder of your Perception authoring software installation.
2 Open Questionmark Manager.
3 Select File > Import > QML, and import the published QML file.
Adobe Flash

If you are a Flash developer, use Adobe Captivate to record a SWF file. Then use the features of Flash to edit the file. Adobe Captivate 4 supports Flash CS3 and Flash CS4.

Import Adobe Captivate projects into Adobe Flash

You can import Adobe Captivate projects into Flash only when Adobe Captivate and Flash are installed on the same computer. Slides in the movie are imported as movie clips.

Note: You must have used Flash and Adobe Captivate at least once before performing an import or export operation.

1. Open Adobe Flash.
2. Select File > New.
4. Select File > Import > Import To Stage.
5. In the Import dialog box, select Adobe Captivate Projects (*.cp) from the Files Of Type menu.
6. Navigate to the project file, select it, and click Open.
7. In the Adobe Captivate Options dialog box, select the Adobe Captivate elements to import.
8. Click Import.
   The selected Adobe Captivate project (CP) file is imported into Flash.
9. Save the project as a Flash file. You can now begin editing your Adobe Captivate project in Flash.

Import an Adobe Captivate project into the Flash library

1. Open Adobe Flash.
2. Select File > Import > Import To Library.

Note: You must have used Flash and Adobe Captivate at least once before performing an import or export operation.

3. In the Import To Library dialog box, select Adobe Captivate Projects (*.cp) from the Files Of Type menu.
4. Navigate to a file, select the file, and click OK.
   The Adobe Captivate file is imported into Flash as a movie clip in a new layer. When the clip is placed in the new layer, the first screen is blank if the fade-in effect is on.

Export from Adobe Captivate to Flash

You can export a project from Adobe Captivate to Flash. After the project is in Flash, you can enhance it, add scripting, or integrate it into a larger project.

Note: You must have used Flash and Adobe Captivate at least once before performing an import or export operation.

When you export an Adobe Captivate project into Adobe Flash, the project is imported directly to the Stage or into the Library as a movie clip. The imported project contains layers for each type of object. Appropriate Flash methods are used to enable any Adobe Captivate special effects (for example, tweens to move the mouse pointer). The Flash Library panel shows all objects created for the Adobe Captivate project, organized logically into folders.
Most elements in your projects are converted so they look and operate the same in Flash as in Adobe Captivate, but here are a few exceptions:

- Question slides
- Imported mouse paths are linear, and not curved like in Adobe Captivate.
- Advanced compression
- Playback controller
- 508 compliance
- Most of the drawing objects are supported. Arrows and stroke styles are however, not supported. After import, an Adobe Captivate drawing object is converted to a Flash drawing object.
- Interactive objects are not completely supported.
- Slide transitions (fade between slides)
- Real-time synchronization.

1. In an open project, select File > Export > Project To > Flash CS3 or Flash CS4.
   - If you have not saved your project yet, a prompt appears. Click Yes and select a filename and location for the project.
2. In the Adobe Captivate Options dialog box, select the elements to import. These options are self-explanatory, but note that Hints are a Flash feature, not an Adobe Captivate element that is imported into Flash. Hints are not included in the project SWF file.
3. When the import is complete, save the new project as a Flash (*.fla) file.

**Modifying Adobe Captivate projects in Flash**

Use the Flash Library and movie clip objects to create reusable elements from the original project.

When you become familiar with the structure of the project in Flash, you can easily change your entire project or place Adobe Captivate elements in it. All the Adobe Captivate project elements are stored in the Flash Library and organized into folders. Navigate through these folders to select elements for editing.

The following layers are seen in the Timeline when you open an Adobe Captivate project in Flash.

- **Preloader** This is the file that plays until the movie is downloaded to the user’s computer. For example, you could have a GIF file that informs the player that the movie is being downloaded until the download is complete.
- **Actions** The global actions defined in a movie. You can define global variables and declarations using the Actions layer in the Timeline.
- **Slide Context** Actions that are defined for that particular slide. You can edit the code for the action.
- **Slides** Contains the imported slides in the order in which they appear in the movie.
- **Project Background** Contains any background image for the project.

When you double-click the slide, the Timeline in the next view contains objects corresponding to that slide. Use the Timeline to edit the various objects on the slide. Keep double-clicking an object to edit its different parts. The Timeline changes to reflect the various parts of the object.
Navigating through projects in Flash

Remember these points when you navigate:

- In the Library panel, a folder named Adobe Captivate Objects contains all slides and objects in the project. (You can ignore the objects listed with the prefix "xrd"; these objects are images and sounds that are used in other objects.) To edit your project, double-click a library item and edit it. The “xrd” files are shown in a folder in the library.

- Another way to navigate is to double-click elements on the Stage (in Flash). For example, to edit a movie, double-click the movie on the Stage. To navigate to an element on a slide, click in the Timeline. Position the playhead to show an object on the slide (such as a caption or highlight box). Then double-click the object to edit it. This method has the advantage of showing each element and object in the context in which it is used.

- Unlike Adobe Captivate, Flash does not show all objects at one time; Flash uses the Timeline to represent when different objects are shown. Click in the Timeline or drag the playhead to preview the project.

- The Library panel organizes your project and all of the elements it contains, such as slides, captions, and sounds, into a hierarchy of folders.

RoboHelp

To add an Adobe Captivate project to a RoboHelp project, create the Adobe Captivate project, add it to the RoboHelp project, and select among several display options.

Add an Adobe Captivate project to a RoboHelp HTML online Help system

1. Create an Adobe Captivate project.
2. Publish the project as a Flash SWF file. Select the Export HTML option during the export process and note the folder location where the SWF file is stored.
3. In RoboHelp, open the Help project to which you want to add the Adobe Captivate project.
4. In the Project Manager, double-click the Project Files folder.
5. From the File menu, select Import > HTML/XHTML File.
6. Navigate to the HTML file of your Adobe Captivate project (created in step 2) and select it.
7. Click Open.

The HTML file and the FLA file (SWF file) are imported into your RoboHelp project. The SWF file is added to the Project Files folder, and a new topic (with the title of the project) is created.

Note: The HTML file (with the title of the project) that is added to your RoboHelp project is important. If you delete the topic, the related SWF file is also deleted from the project. You can, however, leave the topic in your Help project as a “hidden” topic. Hidden topics can’t be linked to and don’t appear in the table of contents. Their index markers don’t appear in the index.

Determining how the Adobe Captivate project appears

After you add the FLA file (SWF file) to your RoboHelp project, specify how to display the project. You can place an Adobe Captivate project in a new RoboHelp topic and then link to that topic from any other topic in Help.
Display the project within an existing topic
1 In RoboHelp, open the topic you want to use to start the project.
2 Click in the topic. From the Insert menu, select Adobe Captivate Demo.
3 Browse to the location of your Adobe Captivate file, select it, and click OK.
4 Preview the topic to see what the project looks like, or generate and view your Help system to see how the project looks.

Display the project in a window or panel
1 In RoboHelp, create a topic.
2 Add the Adobe Captivate project to the topic. From the Insert menu, select Adobe Captivate Demo.
3 Browse to the location of your Adobe Captivate file, select it, and click OK.
4 Save the topic.
5 Open the topic you want to use to start the project.
6 Select the text or image to use as a hypertext link. From the Insert menu, select Hyperlink/Popup.
7 In the Select Destination (File or URL) list, select the topic containing the Adobe Captivate project.
8 In Hyperlink Properties, specify how to display the project:
   Display In Auto-Sizing Pop-Up Displays the project in a window that adjusts to accommodate the height and width of the project.
   Display In Custom-Sized Pop-Up Select a width and height by using the arrows or typing a number.
   Display In Frame You have the choice of displaying in a new window or in the same slide as the link from the topic. From the pop-up menu next to Display In Frame, select either New Window or Same Slide. If you choose New Window, the project appears in the user’s default browser. If you choose Same Slide, your topic replaces the topic the user is currently viewing.
9 Click OK.
10 Preview the topic to see what the project looks like, or generate Help.

Note: You can edit the SWF file you have inserted into RoboHelp only if you have the associated Adobe Captivate project saved on your computer.
Chapter 16: Troubleshooting

Consider these troubleshooting tips for some common questions and scenarios.

Adobe Captivate project startup

When you open Adobe Captivate, the Start page displays information on the right bottom portion of the panel asking the user to look up information on Adobe Captivate. This information is a SWF file that is loaded by Adobe Captivate using the value set for the ConnectToInternetOnStartUp key. For values other than zero, Adobe Captivate searches the Internet for the SWF file. The field remains blank until the file is found on the Internet.

You can modify this behavior so that Adobe Captivate searches for the local SWF file stored in the EXE file. For this, the value of the ConnectToInternetOnStartUp key must be set to zero.

To edit the ConnectToInternetOnStartUp DWORD key in the registry:

1. Open the Registry Editor (regedit.exe).
2. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Adobe\Adobe Captivate.
3. Change the value of the ConnectToInternetOnStartUp DWORD key to 0.
4. Close the Registry Editor.
5. Close Adobe Captivate and open it again.

If the key does not exist, you must create the ConnectToInternetOnStartUp registry key of type REG_DWORD, and set its value to 0. After the value is set, a default SWF file will be used to display the update information on the bottom right side of the project.

Animation timing

If you notice when previewing a project that an animation file you added as an object is displayed for a longer or shorter period of time than the duration of the animation file, you can synchronize the animation with the Adobe Captivate Timeline to give you greater control over the timing. To synchronize the animation, double-click the animation to open the Animation dialog box, click the Options tab, and select Synchronize With Project.

Note: If the animation file was originally recorded with an audio track, you may find that the audio track is choppy after selecting the Synchronize With Project option. The best solution is to separate the animation file and audio so they can be used as two distinct objects in the project.

Application distortion when recording

Application distortion can occur with certain combinations of Microsoft Windows and video cards. The problem can be solved by setting the hardware acceleration on your computer to None. You can change this setting in the following location: Start Menu > Settings > Control Panel > Display > Settings > Advanced > Troubleshoot.

Important: Turning off the hardware acceleration may turn off the display in some computers.
Capturing while recording a web application

When you capture a web-based application or a website from a browser, sometimes the slide does not have the correct image.

Whenever you capture a screen, you must listen for the shutter sound. The shutter sound occurs when Adobe Captivate has successfully taken the screenshot. When you are capturing from a website or a web-based application and you have to click several links, you will hear the shutter sound on every click. After you click a link and a new page is loaded, wait for the page to load completely. After the page is fully loaded, you will hear the shutter sound of Adobe Captivate. In case you do not hear the shutter sound when the page is fully loaded, press the Print Screen key, which will take the screenshot manually. It is recommended that you use Internet Explorer as the browser when capturing a website or a web-based application. Following these simple guidelines will enable you to achieve the best results.

Capture of elevated applications in Windows Vista

You will have to set administrator permissions for the AdobeCaptivate.exe file to record or capture applications running in elevated or administrator mode.

To set administrator permissions for AdobeCaptivate.exe:

1. Locate AdobeCaptivate.exe in your installation directory. If you have not changed any settings during installation, you can locate this in the \Program Files\Adobe\Adobe Captivate 4 folder.
2. Right-click the file, and select Run As Administrator. The User Account Control (UAC) dialog box appears.
3. Click Allow.

Choppy full motion recording

You can create a smoother full motion project, particularly better mouse movement, by disabling hardware acceleration. When hardware acceleration is enabled, it can use a great deal of system resources and result in "choppy" full motion recording. Disabling hardware acceleration results in better full motion recording quality.

To disable hardware acceleration when recording a full motion project, select the Disable Hardware Acceleration option from the Full Motion Recording tab of the Recording Options dialog box. If you select this option, your computer screen will briefly flicker when you begin and end full motion recording. This screen flicker does not harm your computer and does not appear in the final project.

Correcting colors in slides

In general, color should appear correctly in Adobe Captivate projects. However, there are cases in which colors may appear inaccurately, such as when the color scheme varies radically between slides. So if Slide A uses color palette ABC, and Slide B uses color palette XYZ, and the two palettes are radically different, Slide B might resort to using palette ABC.

Most of these problems can be fixed by changing the video quality of the slide. Adobe Captivate provides four levels of video quality, even though only the Standard option is suggested for most uses.

Updated 19 May 2009
To change video quality in a slide:

1. In an open project, double-click the slide containing the colors you want to correct.
2. From the Slide menu, select Video Quality and one of the video options:
   - **Standard**: The default format for slides. Standard is the most efficient choice for the majority of screenshots because it uses 256 optimized colors. Standard slides also compress well, which results in smaller file sizes.
   - **Optimized**: This option gives you the highest JPEG quality possible.
   - **JPEG**: This option is best used when the slide contains a photograph. You can change the quality and compression ratio for JPEG images on the Project Preferences dialog box.
   - **High Quality**: Compared to the Standard format of 256 colors, this format uses 16 million colors for the slides. This option should be used only if the Standard and Optimized options do not offer the correct color depth. The file size increases dramatically using this option.

   **Note**: Selecting the JPEG or High Quality format may increase the file size and the time it takes to download your project. You should use a format other than Standard only when necessary and appropriate.

### Fonts on transparent captions

Problems can occur if transparent captions are created and the system setting for font smoothing (anti-aliasing) is enabled. To fix the font appearance, turn off the font smoothing option.

**If you use Windows XP:**
1. From the Start menu, select Settings > Control Panel.
2. Double-click Display.
3. Click the Appearance tab.
4. Click Effects.
5. If the option **Use The Following Method To Smooth Edges Of Screen Fonts** is selected (a check mark appears to the left of the option), click the check mark to clear it and deselect the setting.

**If you use Windows 2000 or earlier versions of Windows:**
1. From the Start menu, select Settings > Control Panel.
2. Double-click Display.
3. Click the Effects tab.
4. If the option **Smooth Edges Of Screen Fonts** is selected (a check mark appears to the left of the option), click the check mark to clear it and deselect the setting.

### Adobe Captivate output

Adobe Captivate was built with low bandwidth in mind. A typical project with sound (some narration) and a modest screen size of 512 x 384 streams at approximately 2–3 kilobytes per second. Your viewers can play this project using a 56 Kbps (or slower) dial-up modem without waiting more than a few seconds for the project to start. Additionally, there are no pauses during playback.
A project that streams well might have the following characteristics:

- File size: 777 KB
- Length: 6 minutes, 12 seconds
- Audio: 286 KB
- Video: 491 KB
- Screen size: 608 x 460

**Note:** File size depends on several factors. Larger files contain elements such as photos, images, sound tracks, large screen sizes, rapid screen transitions, and higher quality video and audio settings.

There are a number of ways to improve the file size of Adobe Captivate output:

- One important factor is the kilobytes per second ratio. Check the bandwidth analysis to find this factor. Don’t despair if your project is large; it is possible for a large project to stream well over the Internet. For example, a 400 KB file might seem large, but if it plays for 5 minutes, it streams easily over a 28.8 Kbps modem. The first slide in a project always has a longer kilobytes per second ratio, because it is the first slide to load and additional project information must load with it.

- Consider your color settings and the images included in your project. Two quick tips for reducing file size are to avoid color gradients and to avoid photo images.

- If you are not going to upload your SWF files to Adobe® Connect™ Enterprise, you can turn off the Include Adobe Connect Metadata option in the project preferences. This option is on by default, and it adds data to your project that allows for better integration with Adobe Acrobat Connect Professional. If you do not use Acrobat Connect Professional, turn this option off to reduce project size.

### Video errors

Adobe Captivate output does not play if it is published over the network with Flash video (FLV) files in it.

Also, FLV files do not play when the Adobe Captivate project containing progressive FLV is published to a network share and viewed by clicking the View Output button. You can play the FLV file in the Adobe Captivate output by mapping the network drive in Microsoft Windows Explorer.

The FLV file must contain metadata for the video player to function correctly. FLV files created with Flash Communication Server 1.5.2, FLV Exporter version 1.2, and Sorenson Squeeze 4.0 automatically contain metadata. Sorenson Squeeze 4.0 is included with the Flash Video Kit.

FLV files will not play when an Adobe Captivate project is hosted on a Windows 2003 web server.

### Text viewed in a browser

If text in a project is not displaying properly in a browser, the problem could be that a link is calling the Adobe Captivate project SWF file instead of the HTM file that corresponds to the SWF file. If you are adding your project to a web page, do not link directly to the SWF file. If you link directly to the SWF file, the browser does not know the size at which it should display the SWF file, so it simply shows the SWF file at the same size as the browser window. This can result in distortions, especially text distortion that causes text to become unreadable.

To display the SWF file in a browser properly, use the HTM file that can be generated with the SWF file. The HTM file contains code that tells the browser the correct size for the project.
When you publish your project as a SWF file, select the Export HTML option. The HTM file will be saved in the same location you specified for the SWF file. The HTM file will have the same name as the SWF file but will have the .htm extension.

If you have installed Adobe® Flash® Player 8 or later, previewing an Adobe Captivate project using a browser causes a security settings warning to be displayed. This is because of the security settings configured in Flash Player 8 or later.

Font size in text entry boxes

After upgrading a Captivate 1 project to Adobe Captivate, the font in text entry boxes appears large in Adobe Captivate. This is because of a bug in Captivate 1 and Flash Player. The font used while editing and publishing the SWF file was not the same as the original font. This bug has been fixed in Adobe Captivate. However, Captivate 1 projects will continue to have a large font in text entry boxes when the projects are upgraded to Adobe Captivate.

There are two possible workarounds to fix this issue.

Workaround 1 (Recommended)

1. After upgrading a Captivate 1 project to Adobe Captivate, open the upgraded project.
2. Edit the font in a text entry box.
3. Use the Apply To All option to apply the change to all text entry boxes in the project.

Workaround 2

1. Upgrade all the Captivate 1 projects to Adobe Captivate 3.0.
2. From the Start menu, click Run, type REGEDIT, and click OK.
3. The Registry Editor appears.
5. Change the value of the FudgeFactor key to 1. The default value of the key is 1.4.
6. Close the Registry Editor.
7. The changes are applied after you restart Adobe Captivate.
8. Preview or publish the Adobe Captivate projects.

*Note: After publishing the Captivate 1 projects, ensure that you reset the value of the FudgeFactor key to 1 for new projects in Adobe Captivate.*

Button sizes while resizing projects

Resize any buttons before resizing the project; buttons are not automatically resized when a project is resized.

The number of slides in a project

Technically, there is no maximum number of slides allowed in an Adobe Captivate project. The number of slides depends on the amount of RAM you are using. Some projects created on a 256 MB computer have had more than 300 slides. There is also no limit on mp3 size for audio in slides.
By default, projects are set to 30 frames per second. Therefore, a caption that appears for 1 second requires 30 frames. Dividing the number of frames in a project by 30 gives you the number of seconds the project plays.

There is an easy way to see how many frames are in an Adobe Captivate project.

To determine how many frames are in a project:

1. Open an Adobe Captivate project.
2. In Storyboard view, the number for Slides corresponds to the number of frames.

**Publishing projects**

Adobe Captivate appears to stop responding for a few moments while publishing a project containing a large size full motion recording. When a large full motion recording is captured in an Adobe Captivate project, the preview and publish operations take a long time.

If you frequently want to preview the project that contains a large full motion recording, set the value of the Compress SWF File option to Off (disabled) in the Preferences tab of the Project Preferences dialog box. This will reduce the time taken to preview the output. After previewing the output, you can change the value of the Compress SWF File option to On (enabled), and then publish your project.

**Quizzing errors**

The user should not be able to navigate to the result slides without answering the quiz in the question slides.

When designing an Adobe Captivate project containing result slides, make sure that you do not allow the user to navigate or jump to the result slides directly without working through the question slides, or the slides containing interactive objects, and that you enable the Reporting option (set to On). It’s important to design the project to help the user complete the quiz before navigating to the result slide.

**Exporting projects to Flash**

Two problems can occur when you export Adobe Captivate projects to Flash:

**An error message occurs during export** To support exporting of projects to Flash 8, the RDMFISTUB.DLL file was provided in Macromedia Captivate 1. This DLL, which was manually copied to the Captivate installation folder, is not removed when Adobe Captivate is installed. If you encounter an error message while exporting the Adobe Captivate project to Flash, locate the DLL, move it to another folder, and copy RDMFISTUB8.dll from \Program Files\Adobe\Adobe Captivate 4\ to the same location.

**The required files are missing after export** To avoid any missing files after you export Adobe Captivate output to Flash, you should first save the project in Adobe Captivate and preview or publish the project before exporting the project to Flash. This ensures that all the files are exported.
JavaScript that does not appear

JavaScript does not appear while you preview Adobe Captivate output.

If the Execute JavaScript option is selected in the Project End options of the Project Preferences dialog box, Adobe Captivate may not display an error message when the JavaScript is previewed. This is because the Show Borders option as set to On (enabled), by default. When this option is on, Adobe Captivate creates multiple SWF files—skin SWF files and content SWF files.

To preview JavaScript, set the value of the Show Borders option to Off (disable it) in the Borders tab of the Skin Editor dialog box.

The Skin Editor

The Skin Editor dialog box shows the skin preview of the first slide of the project. The preview contains the background color of the slide (if any) or the background image. You may experience performance issues when the skin preview shows the background image because every setting in the Skin Editor dialog box is applied to the preview immediately.

To avoid this delay of preview update while editing a skin in the Skin Editor dialog box, you can insert a blank slide as the first slide. Then open the Skin Editor dialog box and define all your skin configurations like playbar controls, positions menu, and borders. After finalizing the skin configuration, you can hide the first slide (the blank slide inserted) and open the Skin Editor dialog box again to preview the final changes. The skin preview will always show the first project slide that is not hidden.

Uninstalling Adobe Captivate

It is relatively simple to uninstall Adobe Captivate. When you uninstall Adobe Captivate, all of the files you have saved in your My Documents\My Adobe Captivate Projects folder are retained.

To uninstall Adobe Captivate:

1. From the Windows Start menu, select Settings > Control Panel.
2. Double-click Add Or Remove Programs.
3. Click the Install/Uninstall tab (if your version of Windows contains this tab).
4. From the list of programs you can remove, select Adobe Captivate x.x.
5. Click Add/Remove.
6. Click Yes to confirm that you want to remove the program.
   The uninstall program removes program files, folders, and registry entries. When the files are removed, the uninstall program indicates that the process is complete.
7. Click OK.
Security warning with Flash Player 8

A security warning appears when you launch an external file from a SWF file created in Adobe Captivate. The same security warning appears when you launch Flash Help created in either RoboHelp HTML or RoboHelp for Word. This is because Flash Player 8 includes the new Settings Manager, which allows you to manage global privacy settings, storage settings, security settings, and automatic notification settings.

To permanently change the settings:
1. Click Settings.
2. Select Edit Locations.
3. Select Add Location.
4. Under Trust This Location, enter the location of the folder that contains your published project.
5. Click Confirm.

Recording audio produces recording(Clip).wav file

The CLIP file appears when a single audio file is distributed over several slides. The CLIP file is generated under the following circumstances:

- Recording narration for several slides / projects in continuous play mode
- Inserting audio on a slide and then distributing it over several slides.
- Inserting audio, retaining current slide timing, and distributing remaining audio over several slides.

To identify which recording(Clip).wav is being used on which particular slide, use the Audio Management dialog (Audio > Audio management). The column “Display name” displays the audio file linked to the particular slide.

Slide Notes

Error: This operation could not be completed. Retry using another workflow.

This error is mostly encountered when you are working with blank rows that are inserted between slide notes. We suggest that you try an alternative workflow when you encounter this error.

We have identified the following scenarios in which you might encounter this error.

Scenario 1
When you try a cut-paste operation from a slide note to a blank row between two slide notes.

Scenario 2
1. Select Text To Speech in a row containing the slide notes.
2. Click Convert To Speech.
3. Select Closed Caption for the entry.
At the end of the slide note press Enter to create a new row below the slide note.

Deselect Closed Caption for the new entry.

Replace the default text in the Slide Notes column with your custom text.

Click outside the slide notes area.
Index

A
accessibility 49, 187
AICC 216
animation text 92
animations 90
answers 158
APs 216
audio library 41, 100
audio settings 41, 100
autoplay 225
AVI 203

B
background audio 134
background color 45
black 87
branching 8
buttons 105

C
calibration 41
caption colors 62
caption transparency 64
closed captions 139
code 122
comments 196
Community Help 2
Community search engine 2
Connect 3
Connect Pro 220
customize 27

Eedit background 45
edit media 136
edit video 93
elearning 23
elements 188
email 206
export 93

F
filmstrips 5
Flash 90
Flash Player 236
FLV 90
full motion recording 30

H
highlight boxes 74

I
images 84
import Flash 93
interaction 97
interactive object 97
iPod 133

J
JavaScript 105

L
library 13
Likert 160
links 5
LMS 216
merging objects 60
metadata 93
microphone calibration 128
movie problems 231
mp3 files 133

N
navigation 97

O
objects 52

P
panning 33
PDF linking 201
PENS 220
PIF 219
playback controls 172
PowerPoint 208
previews 172
progress bars 172
projects 21
publish Word documents 213

Q
question types 155
quiz email 206
quiz scores 155

R
recording movies 27
reporting 206
resolution 5
rollover 72

S
save 22
scores 60
SCORM 216
screen captures 18
screen recordings 22
screen resolution 5
screenshots 37
script files 36
simulations 220
slide length 165
slides 79
slides 39
sound files 133
spelling dictionary 183
storyboards 5
streaming video 93
symbols 174

templates 170
text 46
text-to-speech 48
themes 175
timelines 9
tool tips 32
toolbars 12
tooltips 32
transition effects 39

Updated 19 May 2009
U
unavailable fonts 233

V
variables 143

W
WAV 128
web integration 204
Windows 203
Word documents 213

X
XML 193

Z
zoom 82