Contents

Chapter 1: Getting started
Installation and registration ........................................... 1
Adobe Help Center ....................................................... 2
Using Help ........................................................................ 3
Tips and training .......................................................... 6
What's new ..................................................................... 10

Chapter 2: Tutorials
Tutorials ..................................................................... 12

Chapter 3: Work area
Working with windows and editors ................................. 24
Palettes, tools, and menus .............................................. 27
Previewing and zooming documents ............................. 31
Customizing the work area ............................................ 34
Setting preferences ...................................................... 34
Reverting and restoring changes to pages ...................... 36

Chapter 4: Adobe Bridge
The basics of Bridge ..................................................... 37
Files and folders in Bridge ............................................ 43
Bridge Center ............................................................... 50
Running automated tasks with Bridge ......................... 52
Metadata in Bridge ....................................................... 53
Using Version Cue with Bridge .................................... 59

Chapter 5: Adobe Stock Photos
Adobe Stock Photos ...................................................... 61
Comp images ............................................................... 64
Buying stock photos .................................................... 65
Stock Photos accounts .................................................. 67

Chapter 6: Adobe Version Cue
Using Adobe Version Cue ............................................. 71
Working with Version Cue projects ............................... 76
Working with files in Version Cue ................................. 84
Disconnecting from projects ......................................... 95
Deleting files, folders, and projects .............................. 97
Version Cue versions ................................................... 101
Version Cue alternates ................................................ 106
Editing and synchronizing offline files ......................... 110
Using Version Cue in GoLive ...................................... 113
The Version Cue Administration utility ......................... 123
Building a site map using graphical views ........................................227
Editing links and URLs sitewide ..................................................232
Fixing site errors ........................................................................234
Creating and running queries .........................................................237
Providing file status information ..................................................240

Chapter 10: Laying out pages
Page layout for the web .................................................................243
CSS layout objects .................................................................245
Layout grids ..............................................................................247
Grouping and arranging objects on layout grids ................................250
Converting table-based layout grids to tables ...................................252
Creating layers ........................................................................253
Selecting, resizing, and positioning layers .......................................255
Managing layers ......................................................................257
Animating layers ......................................................................260
Understanding frames ...............................................................263
Setting up frame sets ..................................................................264
Setting up individual frames .........................................................266
Special page elements ..................................................................270

Chapter 11: Tables
Understanding tables ......................................................................274
Creating tables ........................................................................275
Selecting tables, rows, columns, or cells ........................................276
Moving, adding, or deleting rows or columns ....................................279
Resizing and fixing tables .............................................................280
Formatting tables with table styles ...............................................282
Formatting tables with the Table Inspector ......................................284
Formatting tables with cascading stylesheets .................................287
Text in tables ............................................................................289
Sorting in tables ..........................................................................290

Chapter 12: Formatting text
Formatting text in web pages ........................................................292
Adding and selecting text ................................................................293
Formatting paragraphs with HTML text attributes .............................294
Formatting text inline ...................................................................298
Changing fonts ........................................................................299
Changing the size and color of text ..................................................300
Using HTML text styles ...............................................................304
Spelling ....................................................................................307
Searching text and HTML source code ..........................................308
Non-roman characters ..................................................................315

Chapter 13: Cascading stylesheets
Understanding cascading stylesheets .............................................318
Creating and viewing stylesheets ........................................ 320
Using external stylesheets ................................................. 323
Creating CSS styles in stylesheets ....................................... 325
Defining style properties .................................................. 330
Applying styles .............................................................. 338

Chapter 14: Adding images and multimedia
Pre-optimized images ....................................................... 340
Setting basic image options ............................................... 341
Creating rollovers ........................................................... 342
Assigning rollover images automatically .............................. 345
Using actions with rollovers ............................................... 346
Creating image maps ....................................................... 346
Low source images ......................................................... 347
Building a web page using tracing images ......................... 348
Adding multimedia to web pages ..................................... 349
Multimedia plug-in options ............................................... 351
Java applets and W3C object controls ................................. 356

Chapter 15: Working with Smart Objects
Understanding Smart Objects ............................................ 358
Adding and copying Smart Objects ..................................... 360
Updating and editing Smart Objects ................................... 361
Resizing and cropping Smart Objects .................................. 363
Optimizing and saving web graphics .................................. 365
Working with slices during optimization .............................. 368
Web graphics formats and options ..................................... 369
Output settings for web graphics ....................................... 375

Chapter 16: Adding content from Adobe applications
Adding Adobe Photoshop images ........................................ 377
Adding Adobe Illustrator artwork ...................................... 380
Adding Adobe InDesign content ........................................ 385
Using the InDesign package window ................................... 387
Adding graphics and images from InDesign packages .......... 389
Adding text and tables from InDesign packages ................... 390
Exporting InDesign packages to HTML ............................. 391

Chapter 17: Working with PDF documents
Displaying and navigating PDF documents ......................... 394
PDF comments .............................................................. 396
Editing PDF link regions .................................................. 397
Exporting web pages to PDF .............................................. 399
Setting global options for PDF documents ......................... 402

Chapter 18: Forms
Creating forms .............................................................. 411
Adding form elements .............................................412
Adding form navigation ........................................415
Advanced form elements and properties .................417

Chapter 19: Site assets
Understanding site assets ..................................420
Creating page templates ....................................420
Applying and updating page templates ..................424
Stationery ..........................................................426
Components .......................................................427
Snippets ............................................................429
Site colors ..........................................................430
Font sets ............................................................432
Site URLs and e-mail addresses .........................433
Collections .........................................................435
Site samples .......................................................437

Chapter 20: Publishing websites
Preparing to publish a site ..................................439
Uploading and downloading files .........................441
Exporting sites ....................................................448
Setting up distributed websites .........................449
Managing websites with WebDAV .....................450

Chapter 21: Building and updating Co-Author sections
Understanding co-authoring .................................453
Web designer phase: creating Co-Author sections and items ........................................454
Co-author phase: updating a co-authored website ..........458

Chapter 22: Authoring mobile content
Authoring for mobile devices ................................461
Creating MMS messages ......................................462
Creating SVG Tiny files .......................................466
XHTML Basic and Mobile .......................................468
i-mode HTML .....................................................470
WML .................................................................473
Working with WML cards and templates .................474
Working with WML elements .................................475
Working with events and tasks in WML decks ..........477
Getting user input in WML decks .........................479
Using hypertext links and timers with WML cards ..........481
Previewing XHTML, i-mode HTML, or WML in a phone emulator (Windows only) ............482

Chapter 23: Authoring SMIL presentations
Understanding SMIL ...........................................484
Creating SMIL presentations ...............................487
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adding, grouping, and repeating media items</td>
<td>488</td>
</tr>
<tr>
<td>Laying out SMIL presentations</td>
<td>492</td>
</tr>
<tr>
<td>Setting the timing of items and containers</td>
<td>495</td>
</tr>
<tr>
<td>Adding links to presentations</td>
<td>499</td>
</tr>
<tr>
<td>Creating hotspots in a presentation</td>
<td>500</td>
</tr>
<tr>
<td>Changing the display or position of hotspots</td>
<td>502</td>
</tr>
<tr>
<td>Setting the timing of hotspots</td>
<td>503</td>
</tr>
<tr>
<td>Animating items and adding transitions</td>
<td>504</td>
</tr>
<tr>
<td>Matching presentations to a viewer’s system and preferences</td>
<td>506</td>
</tr>
<tr>
<td>Working with regions in SMIL presentations</td>
<td>508</td>
</tr>
<tr>
<td>Adding SMIL presentations to a site</td>
<td>510</td>
</tr>
<tr>
<td>Creating RealPlayer presentations</td>
<td>513</td>
</tr>
<tr>
<td>Creating RealPix presentations</td>
<td>515</td>
</tr>
<tr>
<td>Using effects in a RealPix presentation</td>
<td>520</td>
</tr>
<tr>
<td>Adjusting images in RealPix presentations</td>
<td>522</td>
</tr>
<tr>
<td>Chapter 24: Editing QuickTime movies</td>
<td></td>
</tr>
<tr>
<td>QuickTime in GoLive</td>
<td>525</td>
</tr>
<tr>
<td>Creating and opening QuickTime movies</td>
<td>526</td>
</tr>
<tr>
<td>Editing and previewing movies in the movie viewer window</td>
<td>526</td>
</tr>
<tr>
<td>Editing movies in the Timeline Editor</td>
<td>528</td>
</tr>
<tr>
<td>Working with tracks</td>
<td>531</td>
</tr>
<tr>
<td>Animating tracks</td>
<td>536</td>
</tr>
<tr>
<td>Movie tracks</td>
<td>538</td>
</tr>
<tr>
<td>Picture tracks</td>
<td>541</td>
</tr>
<tr>
<td>Sprite tracks</td>
<td>543</td>
</tr>
<tr>
<td>Using Photoshop images as sprites</td>
<td>548</td>
</tr>
<tr>
<td>SWF tracks</td>
<td>550</td>
</tr>
<tr>
<td>Streaming tracks</td>
<td>551</td>
</tr>
<tr>
<td>3D and MPEG tracks</td>
<td>553</td>
</tr>
<tr>
<td>Sound, music, and instrument tracks</td>
<td>553</td>
</tr>
<tr>
<td>Folder and chapter tracks</td>
<td>554</td>
</tr>
<tr>
<td>Text and HREF tracks</td>
<td>555</td>
</tr>
<tr>
<td>Filter tracks</td>
<td>558</td>
</tr>
<tr>
<td>Using actions to control tracks</td>
<td>566</td>
</tr>
<tr>
<td>Scripting with QuickTime Wired Action Programming Language</td>
<td>570</td>
</tr>
<tr>
<td>Making movies with XML</td>
<td>574</td>
</tr>
<tr>
<td>Saving and exporting movies</td>
<td>576</td>
</tr>
<tr>
<td>Chapter 25: Editing source code</td>
<td></td>
</tr>
<tr>
<td>Source code editors and preferences</td>
<td>578</td>
</tr>
<tr>
<td>Source code mangement tools</td>
<td>580</td>
</tr>
<tr>
<td>Using the Visual Tag Editor</td>
<td>581</td>
</tr>
<tr>
<td>Using the Outline Editor</td>
<td>583</td>
</tr>
<tr>
<td>Adding new elements to source code</td>
<td>588</td>
</tr>
<tr>
<td>Working with source code</td>
<td>589</td>
</tr>
</tbody>
</table>
Chapter 1: Getting started

Installation and registration

To install
1 Close any Adobe® applications that are open.
2 Insert the product CD into your computer's CD drive.
3 Double-click the CD icon, and then follow the on-screen instructions.

After the installation, you may be prompted to activate your copy of the product. (See “To activate” on page 1.)

For more detailed instructions about installing the product, see the How To Install file on the product CD. For instructions about uninstalling the product, see the How To Uninstall file on the product CD.

To activate

Activation is a simple, anonymous process you must complete within 30 days of installing the product. Activation allows you to continue using the product, and it helps prevent casual copying of the product onto more computers than the license agreement allows. To learn more about activation, visit the Adobe website at www.adobe.com/activation/main.html.

1 Start the product to access the Activation dialog box. (If you've just installed Adobe Creative Suite or Adobe Photoshop®, the Activation dialog box appears automatically.)
2 Follow the on-screen instructions.

Important: If you intend to install the product on a different computer, you must first transfer the activation to that computer. To transfer an activation, choose Help > Transfer Activation.

For more detailed instructions about activating the product and transferring an activation, see the How To Install file on the product CD.

To register

Register your Adobe product to receive complimentary support on installation and product defects and notifications about product updates. Registering your product also gives you access to the wealth of tips, tricks, and tutorials in Adobe Studio® and access to Adobe Studio Exchange, an online community where users download and share thousands of free actions, plug-ins, and other content for use with Adobe products. Adobe Studio is available in English, French, German, and Japanese. Find it from the home page of the Adobe website.

❖ Do one of the following:

• Install and activate the software to access the Registration dialog box, and then follow the on-screen instructions. An active Internet connection is required.
• Register at any time by choosing Help > Registration.
Adobe Help Center

About Adobe Help Center
Adobe Help Center is a free, downloadable application that includes three primary features.

Product Help  Provides Help topics for Adobe Photoshop Elements and Adobe CS2 products installed on your system. (If none of these products are installed, Help topics for them aren’t available.) Help topics are updated periodically and can be downloaded through Adobe Help Center preferences.

Expert Support  Provides information about Adobe Expert Support plans and lets you store details about plans you’ve purchased. If you have an active support plan, you can also use the Expert Support section to submit web cases—questions sent to Adobe support professionals over the web. To access links in the Expert Support section, you must have an active Internet connection.

More Resources  Provides easy access to the extensive resources on Adobe.com, including support pages, user forums, tips and tutorials, and training. You can also use this area to store contact information for friends, colleagues, or support professionals, or even websites you turn to for inspiration or troubleshooting information.

To check for updates
Adobe periodically provides updates to software and to topics in Adobe Help Center. You can easily obtain these updates through Adobe Help Center. An active Internet connection is required.

1  Click the Preferences button.

2  In the Preferences dialog box, click Check For Updates. If updates are available, follow the on-screen directions to download and save them.
To set Adobe Help Center preferences
1  Click the Preferences button 🏷. Set any of the following options:
   Region  Specifies your geographical location. Changing this option may affect which services are available to you.
   Language  Specifies the language in which Expert Support content is displayed.
   Display Renewal Reminders For Expert Support Contracts  Displays reminder screens when your Expert Support plan has almost expired. Deselect this option if you'd like to turn off these reminders.
   Enable Auto Login For Web Case Submission  Allows you to submit support questions over the web. This option is available only if you have an active Expert Support plan.
   User Interface Language  Specifies the language in which Adobe Help Center interface text is displayed.
   Check For Updates  Searches for new updates to software and Help topics as they become available from Adobe.
   Network Administrators  Displays options for network administration.
2  Click OK.

To display More Resources
The More Resources section in Adobe Help Center provides easy access to some of the content and services available from the Adobe website, including support, training, and tutorials.
   ❖ To display this section, click More Resources.

To add contact information in More Resources
1  Click More Resources, and then click Personal Contacts.
2  Do any of the following:
   • To add a contact, click New, type the contact information you want to save, and click OK.
   • To edit a contact, click a contact in the list, click Edit, make changes to the information, and click OK.
   • To delete a contact, click a contact in the list, and then click Delete. To confirm the deletion, click Yes when prompted, or click No to cancel.

Using Help

Using Help
The complete documentation for using your Adobe product is available in Help, a browser-based system you can access through Adobe Help Center. Help topics are updated periodically, so you can always be sure to have the most recent information available. For more information, see “To check for updates” on page 2.

Important: Adobe Help systems include all of the information in the printed user guides, plus additional information not included in print. The Resources and Extras CD included with the software also includes a PDF version of the complete Help content, optimized for printing.
To navigate Help

❖ Do any of the following:

- To view Help for a product, choose the product name from the Help For menu. (To view only topics that apply across all Creative Suite products, choose Adobe Creative Suite.)

- To expand or collapse a section, click the blue triangle to the left of the section name.

- To display a topic, click its title.

See also

“To use bookmarks” on page 6
To search Help topics
Search using words or phrases to quickly find topics. You can search Help for one product or for all Adobe products you’ve installed. If you find a topic that you may want to view again, bookmark it for quick retrieval.

1 In Adobe Help Center, click Product Help.

2 Type one or more words in the Search box. To search across Help for all Adobe products you have installed, click the black triangle to the left of the Search box and choose Search All Help.

3 Click Search. Topics matching the search words appear in the navigation pane.

4 To view a topic, click its title.

5 To return to the navigation pane, do one of the following:
   • Click the Home button.
   • Click the Back button.
   • Click Next Topic or Previous Topic.

See also
“To print a topic from Help” on page 5
“To use bookmarks” on page 6

Search tips
Adobe Help search works by searching the entire Help text for topics that contain all of the words typed in the Search box. These tips can help you improve your search results in Help:

• If you search using a phrase, such as “shape tool,” put quotation marks around the phrase. The search returns only those topics containing all words in the phrase.

• Make sure that the search terms are spelled correctly.

• If a search term doesn’t yield results, try using a synonym, such as “web” instead of “Internet.”

To print a topic from Help
1 Select the topic you want to print, and click the Print button.

2 Choose the printer you’d like to use, and then click Print.
To change the view

By default, Adobe Help Center opens in Full view. Full view gives you access to the Product Help, Expert Support, and More Resources sections. Switch to Compact view when you want to see only the selected Help topic and you want to keep the Help window on top of your product workspace.

❖ Click the view icon to switch between Full and Compact views.

To use bookmarks

You can bookmark especially helpful topics for easy access, just as you bookmark pages in a web browser, and reread them at another time.

1 Click the Bookmarks tab in the navigation pane to view the bookmarks.

2 Do any of the following in the Bookmarks pane:

• To create a bookmark, select the topic you want to mark, and click the Bookmark button . When the Bookmark dialog box appears, type a new name in the text box if desired, and then click OK.
• To delete a bookmark, select it and click the Delete button. Click Yes to confirm the deletion.
• To rename a bookmark, select it and then click the Rename button . In the dialog box, type a new name for the bookmark and then click OK.
• To move a bookmark, select it and then click the Move Up button or the Move Down button .

Tips and training

Learning resources

Adobe provides a wide range of resources to help you learn and use Adobe products.

• “Total Training Video Workshop CD” on page 7: Professional training videos from experts.
• “Adobe Studio” on page 7: Videos, tips and tricks, and other learning material on Adobe products.
• Adobe Creative Suite Design Guide (Adobe Creative Suite only): A full-color printed book about using Adobe Creative Suite 2 as a complete design and publishing toolbox, including five guided projects on print, web, and mobile workflows.
• “Technical information” on page 8: Reference material, scripting guides, and other in-depth information.
• “Other resources” on page 9: Training, books, user forums, product certification, and more.
• Support: Complimentary and paid technical support options from Adobe.
• “Extras” on page 9: Downloadable content and software.

See also

“About Adobe Help Center” on page 2
**Tutorials in Help**

The Help system for each Adobe CS2 product includes several step-by-step tutorials on key features and concepts. These tutorials are also available in the complete, printable, PDF version of the Help contents, included on the Resources and Extras CD.

To use these tutorials with the product, select the tutorial you want from the Contents pane in Adobe Help Center, and click the View icon to switch to Compact view. Compact view keeps the Help window on top of the application windows, regardless of what window or application is selected. Drag an edge or a corner of the Help window to resize it.

**See also**

“Adobe Studio” on page 7

“Total Training Video Workshop CD” on page 7

“Other resources” on page 9

**Total Training Video Workshop CD**

Presented by experts in their fields, Total Training videos provide overviews, demos of key new features, and many useful tips and techniques for beginning and advanced users. Look for accompanying step-by-step instructions to selected Total Training videos in monthly updates to Adobe Studio.

Short Total Training web videos on a variety of products and topics are also available in Adobe Studio, and complete Total Training courseware can be purchased online from the Adobe Store.

**See also**

“Adobe Studio” on page 7

“Other resources” on page 9

**Adobe Studio**

Adobe Studio provides a huge wealth of tips and tricks, tutorials, and instructional content in video, Adobe PDF, and HTML, authored by experts from Adobe and its publishing partners. You can search the entire collection or sort by product, topic, date, and type of content; new content is added monthly. Adobe Studio is available in English, French, German, and Japanese. Find it from the home page of the Adobe website.
Technical information

The Technical information folder on the Resources and Extras CD included with your Adobe product includes several useful documents in PDF, fully searchable and optimized for printing. These documents provide conceptual and reference material on various in-depth topics, such as scripting, transparency, and high-end printing. For complete developer documentation and resources, visit the Developers area of the Adobe website at http://partners.adobe.com/public/developer/main.html. For additional backgrounders and instructional content, visit Adobe Studio.

The Resources and Extras CD also includes the entire Help content optimized for printing. Note that the Help content includes everything in the printed Adobe user guides, plus much more.

See also

“Adobe Studio” on page 7
“Other resources” on page 9
Other resources
Additional sources of information and help are available for Adobe products.

- Visit the Training area of the Adobe website for access to Adobe Press books; online, video, and instructor-led training resources; Adobe software certification programs; and more.

- Visit the Adobe user forums, where users share tips, ask questions, and find out how others are getting the most out of their software. User forums are available in English, French, German, and Japanese on the main Support page of your local Adobe website.

- Visit the Support area of the Adobe website for additional information about free and paid technical support options. Top issues are listed by product on the Adobe U.S. and Adobe Japan websites.

- Visit the Developers area of the Adobe website to find information for software and plug-in developers, including SDKs, scripting guides, and technical resources.

- Click More Resources in Adobe Help Center to access many of the resources on the Adobe website and to create your own list of frequently visited user groups and websites and valuable contacts.

- Look in Bridge Center for RSS feeds on the latest technical announcements, tutorials, and events. To access Bridge Center, select it in the Favorites panel in Adobe Bridge. (Bridge Center is available with Adobe Creative Suite only.)

See also
“To display More Resources” on page 3
“Learning resources” on page 6

Extras
The Resources and Extras CD included with your CS2 product includes a Goodies folder that contains bonus content and files for use with your Adobe product. For more free content and add-ons, visit Adobe Studio Exchange, an online community where users download and share thousands of free actions, plug-ins, and other content for use with Adobe products. To visit Adobe Studio Exchange, go to Adobe Studio from the home page of the Adobe website.

In addition, your CS2 product includes Adobe Stock Photos, an integrated service available within Adobe Bridge that lets you search, view, try, and buy royalty-free stock photography from leading stock libraries. Because of the tight integration between Stock Photos and CS2 products, you can download images directly into your Adobe Illustrator®, Adobe InDesign®, and Adobe GoLive® projects. From Photoshop, you can open any downloaded image.

See also
“Adobe Studio” on page 7
“About Adobe Stock Photos” on page 61
“About Adobe Bridge” on page 37

Other downloads
The Downloads area of the Adobe website includes free updates, tryouts, and other useful software. In addition, the Plug-ins section of the Adobe Store provides access to thousands of plug-ins from third-party developers, helping you automate tasks, customize workflows, create specialized professional effects, and more.
See also
“About Adobe Stock Photos” on page 61
“Other resources” on page 9

What’s new

New features

Mobile authoring
Mobile workspaces  Automatically configure the workspace for mobile formats when you create a new document. See “Designing for mobile devices” on page 461.

Small screen rendering  Preview mobile content in GoLive’s built-in LiveRendering browser. See “Designing for mobile devices” on page 461.

CSS integration  Create flexible designs that work well in both standard and mobile browsers. See “Using cascading stylesheets for flexible page designs” on page 461.

MMS messages  Create sophisticated multimedia messages for mobile devices. See “About MMS messages” on page 462.

Copy HTML to XHTML  Create mobile-compatible copies of web pages quickly and easily. See “To copy HTML pages to XHTML Mobile” on page 469.

SVG previews  Edit SVG and add JavaScript interactivity with an intuitive, visual interface. See “About SVG Tiny format” on page 466.

Updated CSS
Liquid layouts  Create flexible layouts with CSS layout objects and the CSS layout grid. See “About CSS layout objects” on page 245.

CSS site management  With the CSS tab in the site window, update class file names throughout a site and view referenced HTML files in the In & Out Links palette. See “About the site window” on page 202.

Enhanced CSS editor  View source code and check syntax while you edit stylesheets. See “View options for the CSS Editor” on page 321.

Automatic style conversion  Replace HTML styles with CSS styles, or vice versa. See “To replace HTML or CSS styles” on page 307.

Default CSS files  Apply a default stylesheet to all new files you create in a site. See “To set an external stylesheet as the site default” on page 322.

InDesign integration
Streamlined workflow  Optimize images and text with one click, and customize formatting in the CSS editor. See “Adding images from InDesign packages” on page 389 and “Adding text and tables from InDesign” on page 390.

Import layers  Show and hide InDesign layers in GoLive’s Layers palette. See “About InDesign packages” on page 385.
Organize assets View text and image thumbnails, or categorize assets with XML tags. See “To add a package asset to a web page” on page 387.

Export to HTML Optimize entire layouts for HTML, and apply templates to link exported pages. See “Exporting packages to HTML” on page 391.

Shared Adobe features

Swatches Open swatch libraries in separate palettes, and share colors with other applications using the Adobe Swatch Exchange format (.ase). See “To use the Swatches palette or a swatch library palette” on page 176.

Color management Use the familiar Adobe Color Picker, and ensure consistent color with the Color Settings dialog box. See “To color-manage swatches and the Color Picker” on page 176.

PDF presets Edit and share presets with other applications. See “About Adobe PDF presets” on page 402.

Help Find content for all Adobe Creative Suite applications in one combined system.

Site publishing
Secure FTP Transfer files via the Secure Sockets Layer (SSL) or Secure Sockets Shell (SSH) protocol. See “To set up access to a publish server” on page 440.

Version control Collaborate across applications with systems such as Adobe Version Cue and CVS. Or quickly and easily provide built-in version control for GoLive workgroups. See “About version control” on page 150.

Nested page templates Create complex, consistent designs by inserting template pages into template regions. See “Nested page templates” on page 423.

Dynamic collections Attach queries to collections using a streamlined workflow. See “To create a dynamic collection” on page 437.

Quick Search Search for files directly in the Site window. See “To find files within a site” on page 237.

Cropped components Customize text components for different audiences. See “To crop text in a component” on page 428.

Smart Favorite icons Automatically optimize page icons for the Favorites or Bookmarks menu of a browser. See “Smart Favorite icons” on page 166.

New document creation
Previews and descriptions Identify exactly the document you need. See “About the New dialog box” on page 24.

Samples Choose from predesigned pages, frame sets, scripts, style sheets, and more. See “To create a site from a site sample” on page 147.

Favorites Quickly access frequently-used document types. See “To create a new page in a site” on page 154.

Extended functionality
Updated, pre-installed SDK Create powerful new GoLive features with standard JavaScript. To access the SDK, open the GoLive CS2/Adobe GoLive SDK folder on your hard disk.

Chapter 2: Tutorials

Tutorials

The following tutorials provide a quick tour of the basic Adobe GoLive CS2 features. Before you get started, be sure you are familiar with the basic concepts of GoLive.

As you work through these tutorials, you may have new ideas and questions. To assist you with learning GoLive, Adobe provides a variety of resources. For more information, see “Learning resources” on page 6.

For more advanced GoLive tutorials, visit the Adobe website at www.adobe.com/products/tips/golive.html.

See also

“Design and lay out a web page” on page 16

“Create and manage links” on page 18

“Publish a site” on page 21

Create and structure a site

Adobe GoLive CS2 makes it easy to create complex, multipage websites using the Site Creation Wizard and the site diagram feature. The Site Creation Wizard walks you through the process of setting up a new website, and the site diagram feature lets you quickly prototype the site, and then convert the prototype to actual pages.

In the steps that follow, you’ll use the Site Creation Wizard, diagramming tools, and the site window to create a new single-user website with multiple pages and folders.
1. **Create a new blank site.**

   Start GoLive and choose File > New. Choose Site > Create Site to open the Site Creation Wizard. Select Blank Site, and click Next. Enter a name for the site in the Name box, and then click Browse to specify a location on your hard drive to store the site files and folders. Click Next. Select Don't Use Version Control in the Use A Version Control System window, and click Next (you may want to specify version control settings later, especially if you’re working on the site as part of a team). Select Specify Server Later in the Publish Server Options window (you can set options for publish servers after you’ve set up the site), and then click Finish to create the new site. That’s all there is to creating a new site.

   GoLive creates a project folder on your hard drive. The project folder contains the site's project file, a web-content folder, which contains an index.html file, a web-data folder, and a web-settings folder, which GoLive uses to manage the site and its assets.

2. **Create a diagram and add a page.**

   With the site window active, choose Diagram > New Diagram and enter a diagram name in the New Diagram dialog box to create a new diagram. Click the Diagrams tab of the site window and double-click the diagram you just created. Drag a Page icon from the Diagram set of the objects toolbox to the design view to add a new page named *untitled.html*. Click the page’s name, and then enter a new name, such as *Products.html*. 
3. **Add new child pages.**

With the page in the design view selected, choose Diagram > New Pages. In the New Pages dialog box, enter the number of new child pages to create and a base file name for the new pages. For example, enter 4 to create four pages, and then enter Models in the Filenames box to add pages named `Models.html`, `Models1.html`, `Models2.html`, and `Models3.html`. Click Create.

4. **Anchor the diagram to a page in the site.**

Drag the index.html page from the Files tab of the site window to the design view. Index.html becomes an anchor page in the diagram and is indicated by an anchor symbol.

Anchoring the diagram specifies the diagram's location in the site's hierarchy.
5. **Submit the diagram to the site.**

Choose Diagram > Staging > Submit All. GoLive converts the diagram's pages to HTML pages in the site. In the Files tab of the site window, you can see the new pages in the site.

6. **Structure the site.**

Organize your pages and images in separate folders so that you can keep track of files and update them easily. With the Files tab of the site window active, click the Create New Folder button in the toolbar. Rename the new untitled folder Pages. You'll place all your HTML pages in this folder. Click in an empty area of the Files tab and click the Create New Folder button. Rename the new folder Images. You'll place all your images in this folder. Select Products.html and its child pages (models.html, models1.html, etc.), and drag them into the Pages folder (Shift-click to select multiple files).

If your site is very complex, you may want to create subfolders within these folders to easily organize your files. Whenever you move, rename, or add pages, or create a new folder in the Files tab, GoLive automatically makes the change in the site's web-content folder.
Design and lay out a web page

Adobe GoLive makes it easy to design and lay out visually compelling web pages. You can create simple or complex professional-quality web pages without writing any code.

Once you’ve designed your page, you can save it as a page template. New pages created from a page template remain linked to the template—when you change the template, GoLive automatically updates the pages without affecting any content that has been added to them.

1. Set page dimensions and add a CSS layout object.

Open a site, choose File > New, and then select Web > Pages > HTML Page. (For information about creating a site, see “About GoLive sites” on page 145.) Choose 720 x * from the Status Page Dimensions menu at the bottom center of the document window to display the current page at 720 pixels wide, the standard width for 17-inch monitors. (If the page dimension doesn’t appear at the bottom of the document window, choose Show > Page Dimensions from the menu.) Drag one of the CSS layout objects from the CSS set of the objects toolbox to the page. Adjust the height and width of the columns, rows, frames, or boxes of the CSS layout object as desired in the CSS Object Inspector.

Setting a default page size helps prevent you from adding objects, such as large graphic banners, that are too wide to display on a standard page. CSS layout objects let you create liquid layouts that adjust to the new size when a user resizes a web browser window (for more information about CSS layout objects, see “About CSS layout objects” on page 245).
2. Add a background color to the page.

Click the Show Page Properties icon in the upper right corner of the document window. In the Page tab of the Page Inspector, select Background Color and click the lower right corner of the color field. Choose a background color for your page from the swatches that appear, or choose a swatch library from the list and then click the corner of the color field again to choose a background color from those swatches.

You can apply a color or an image to the background of your page to visually enhance it. Although colors that you choose for page backgrounds override the default colors used by most web browsers, viewers can change browser preferences to override your page background colors. You can also select an image for the page background, but keep in mind that web browsers treat the image as a tile and repeat it to cover the entire page.

3. Add and format text.

Click inside the CSS layout object to create an insertion point and type some placeholder text. On the toolbar, click the Align Center button, and then choose Heading 2 from the Set Paragraph Format menu.

In GoLive, you can format text in a variety of ways: use paragraph styles, such as Header 1 and Header 2, to format paragraphs; use physical styles, such as Bold and Italic, to emphasize text; and use structural styles, such as Emphasis and Strong, to both emphasize and classify text. (For more information about formatting text, see “Methods of formatting text” on page 292.) You can also apply fonts, type sizes, and color to text using CSS (cascading stylesheets), which contain a set of stylistic rules that describe how HTML documents should appear to viewers. If you need to update a CSS style, you simply edit the style rule and all content that hosts the style will automatically reflect the new properties. For more information about CSS, see “About cascading stylesheets” on page 318.
4. Add a Smart Object.

Drag a Smart Generic icon from the Smart set of the objects toolbox to the CSS layout object. Select the icon in the document window, and click the Browse button in the Source section of the Basic tab of the Smart Generic Image Inspector to navigate to a JPEG file on your hard drive (Smart Generic objects also support a variety of other image formats. See “Adding Smart Objects” on page 360 for more information.) Choose options in the Save For Web dialog box, and then save the target file in your site's web-content folder. (Don't worry if you don't have a JPEG file; you can link an image file to the Smart Generic object in the document window at any time.)

When you use Smart objects, you create a link to a source file in a format such as Photoshop, Illustrator®, PDF, or EPS, and then GoLive creates a target file in a web-optimized format. GoLive maintains the link to the source file. When you move, resize, or reoptimize a Smart Object, you're manipulating the target file—the source file doesn't change. This workflow lets you generate multiple image variations from a single source file.

5. Save the file as a page template.

Choose File > Save As, and choose Templates from the Site Folder menu. Type a name for the template in the Save As dialog box, and click Save.

Page templates are predesigned page layouts that you can use as the basis for new pages. You can mark regions of the page as editable: any part of the template that isn't marked as an editable region is automatically locked. When you update a template, you automatically update all pages based on that template. For more information about templates, see “Page templates” on page 420.

Create and manage links

In this tutorial you’ll create navigational links from which viewers can jump to other pages in your site (internal links) or to other sites on the web (external links).

Adobe GoLive's powerful site management features make it easy to maintain links between pages, and because GoLive collects and updates URLs in the External tab of the site window, you can quickly create links across the web.
1. Create an internal link.

Open a GoLive site, and then open the page that you want to serve as the source of the link. Select a short block of text and click the Create Link button in the toolbar. In the Text Inspector, drag the pick whip to the destination page in the site window.

You can also create internal links by using the Browse button in the Text Inspector to locate a page, or by typing the relative path to the page in the URL box in the Inspector. It’s best, however, to use the pick whip when creating links to avoid mistakenly linking to pages outside of the site’s web-content folder.

2. Test the link.

Click the Preview In Browser button in the toolbar to preview the page with the link in your web browser. Click the link and make sure that the destination page appears in the browser window.

3. Update the internal link.

With the Files tab of the site window active, click the Create New Folder button in the toolbar. Drag the link’s destination page into the new folder. GoLive displays the Move Files dialog box, which lists the page that serves as the source of the link, and prompts you to update the file. Click OK.

GoLive updates links in your site when you move or rename files in the site window. To avoid broken links in your site, perform all such site management tasks in the GoLive site window, not directly in your site’s web-content folder in Microsoft Windows’ Explorer or the Mac OS’ Finder.
4. **Add a URL to the External tab of the site window.**

Drag the URL icon from the Site set of the objects toolbox to the External tab of the site window. Rename the untitled URL Adobe URL. Type http://www.adobe.com in the URL box of the External Inspector.

The External tab of the site window contains URLs and e-mail addresses. Storing a URL in the External tab is useful when you want to use the URL on more than one page in your site. If you later need to update a URL in the External tab, GoLive automatically updates it wherever it appears in the site.

5. **Create an external link.**

Open the page that you want to serve as the source of the link. Select a short block of text, and click the Create Link button in the toolbar. In the Text Inspector, drag the pick whip to the Adobe URL in the External tab of the site window.

6. **Test the link.**

Click the Preview In Browser button in the toolbar to preview the page containing the link in your web browser. Click the link and make sure that the Adobe website appears in the browser window.
7. Update the external link.

Select the Adobe URL in the External tab of the site window. Type http://www.adobe.com/products/golive/main.html in the URL box of the External Inspector, and then press Enter (Windows) or Return (Mac OS). GoLive displays the Change Reference dialog box, which lists the page that serves as the source of the link, and prompts you to update the file. Click OK to update the reference.

GoLive provides other tools for updating internal and external links. For example, to edit links sitewide, use the In & Out Links palette or the Change References dialog box (see “Changing all site URLs or links at once” on page 232).

---

Publish a site

Before visitors can view your website, you need to transfer it to a publish server (a server that hosts your site files, such as an FTP server). This tutorial demonstrates how to use GoLive to transfer your site files to a publish server for the first time. Before you start this tutorial, contact your Internet service provider (ISP) to determine the settings you’ll need to access the publish server, including the publish server address, the server’s protocol, the location of your directory on the publish server, and your user name and password.

GoLive makes it easy to transfer your site to a publish server with the Publish Server tab in the site window. Once you've transferred a site, updating it is easy using modified-item uploads and synchronized uploads. GoLive takes the guesswork out of determining which files need updating by comparing the modification dates of local files with those on the server.

---

1. Configure a publish server.

Open a site and choose Site > Publish Server > Set Up Server (if you’ve already set up a server for a site, choose Site > Publish Server > Settings). Click the New Server button in the Site Settings dialog box and type an easily recognizable nickname for your server in the Nickname box (nicknames prevent confusion if you add more than one server to the list). Choose a protocol from the Protocol menu and fill in the Server, Directory, Username, and Password boxes based on the publish server information you obtained from your ISP; then click OK. (Click Advanced to configure advanced FTP options, such as security.)
Once you’ve configured a publish server in GoLive, you can use it for any site by clicking the Add To Favorites button in the Publish Server section of the Site Settings dialog box. If you change information about the publish server, GoLive updates all sites that use that server.

2. **Connect to the publish server.**
   
   Click the Connect To Publish Server button in the toolbar. GoLive brings the Publish Server tab in the site window to the front.

3. **Upload a new file.**
   
   In the Files tab of the site window, select the file you want to upload and choose Site > Publish Server > Upload Selection (don’t select the home page of the site—you’ll delete this file later in the tutorial). GoLive uploads the file and displays it in the Publish Server tab.

   You can use the Publish Server command to upload selected files, all files in your site, or only new files and files that have been modified locally since the last upload.

4. **Upload a modified file.**
   
   In the Files tab of the site window, select and open the file you uploaded in step 3. Make a change to the file, and then save and close it. Click the Upload Modified Files button on the toolbar (if the button tool tip reads Upload All or Upload Selection, click the triangle at the lower right of the button and choose Upload Modified Command from the Change Button To menu). In the Upload dialog box, note that the file you’ve just modified is marked with a green arrow, meaning GoLive will upload it to the publish server. Click OK to perform the modified-item upload.

   When GoLive uploads files, it saves the modification time for the local site files and the files on the server. When you perform a modified-item upload, GoLive compares the modification times and transfers only new files and files that have been modified locally since the last upload.
5. **Synchronize all files in the site.**

In the Files tab of the site window, select the file you uploaded in step 3, and then click the Delete Selected Item button in the toolbar. Click Yes to confirm the deletion. Click the Synchronize With Publish Server button on the toolbar. The Synchronize dialog box appears and displays files on the local site and on the publish server. The file you deleted locally is marked with a Delete icon. If you want to assign a different synchronization action to the file (or to any other file listed in the Synchronize dialog box), select the file and cycle through the synchronization actions by clicking the Synchronization Action icon displayed in the column next to the file. Click OK to delete the file from the publish server and synchronize the site.

Synchronizing a site ensures that the local site and the site on the server match. When you synchronize a site, you can upload files to the publish server, download them from the server to the local site, skip files completely, or delete them. You can exclude files from upload by setting their publish state to Never in the File Inspector. (See “Assigning publish states to files and folders” on page 240.)
Chapter 3: Work area

Working with windows and editors

About the Welcome screen and work area
When you first start Adobe GoLive, a Welcome screen appears with options to create or open a new document. You can deselect the option to show the screen at startup and later reselect the option in the Preferences dialog box.

The GoLive work area includes the site window (one for every site project), document windows for each open web page, and a variety of editors, toolbars, and palettes for working with everything in your site. You can stack or tile windows on your screen, and group, ungroup, or rearrange palettes, as well as save custom workspaces.

![GoLive work area diagram]

GoLive work area
A. Toolbar  B. Document window  C. Site window  D. Objects toolbox  E. Inspector  F. Library palette

See also
“About preferences” on page 34

About the New dialog box
When you click New Document in the Welcome screen or choose File > New, GoLive displays the New dialog box.
The New dialog box lets you choose from several categories (Site, Web, Mobile, and Scripting) and to add files of several types (including HTML pages, cascading stylesheets, images, QuickTime movies, or RealPlayer documents) to a Favorites category. When you select a category, GoLive displays a list of file or site types from which you can choose. When you select a file or site type, you can either choose a specific file or site sample, or begin creating a site by using the Site Creation Wizard.

You can set options for files, such as doctype and encoding, in the Options section of the New dialog box.

**See also**

“To create a new page in a site” on page 154

“Methods for creating sites in GoLive” on page 146

**To edit descriptions in the New dialog box**

GoLive displays descriptions of files in the New dialog box. You can edit these descriptions in the Description dialog box.

1. Select the file in the New dialog box.
2. From the pop-up menu next to the file, choose Edit Description.
3. In the Description dialog box, make changes as desired.
**Note:** Can Change Markup Type, Can Change Doctype, or Can Change Encoding enable modifications of the markup type, doctype, or character encoding.

**See also**
“About site assets” on page 420

**Displaying the site and document windows**
The site window (with both sides open), the objects toolbox, the toolbar, and the Inspector should always be open for building, revising, and uploading a site.

You can display multiple site and document windows at one time—GoLive keeps track of the pages with their corresponding sites—so you can easily copy things from page to page and site to site.

**To display site and document windows**
- To display the document window, open an XHTML or HTML page, or create a new page.
- To display the site window, open the site file (.site).
- To collapse the site window to a single pane, click the Toggle Split View icon at the bottom of the window. (To expand the site window to two panes, click the button again.)
- To display the head section pane in the document window, select the Layout tab, and then click the Toggle Head Section icon in the upper left corner of the document window (next to the Head label).
- To display the source code pane in the Layout Editor, select the Layout tab, and then click the Show/Hide Split Source icon in the lower left corner of the window.

**Note:** You can also display the source code pane in the Frame Editor and Outline Editor.

- To display the source code pane to a new vertical or horizontal position in the Layout Editor, Alt-click (Windows) or Option-click (Mac OS) the Show/Hide Split Source icon.

**To display an editor or preview**
❖ From within the document window, click any of the following tabs:

- **Layout Editor tab** Lets you add content to a document.
- **Frame Editor tab** Lets you create a frameset and lay out frames that display individual web pages.
- **Source Code Editor tab** Lets you work directly with your document's source code.
- **Outline Editor tab** Lets you view source code in a hierarchical, structured view.
- **Layout Preview tab** Lets you preview your document and test links in GoLive.
- **PDF Preview tab** Lets you preview and export a web page to PDF.

**To arrange windows and editors**
❖ Select a document window, site window, graphical site view window, or editor and choose Tile Horizontally, Tile Vertically, or Cascade from the Window > Cascade And Tile menu.
To switch between windows or editors
❖ Do any of the following tasks:
  • Click the desired window or editor to select it.
  • Choose the desired window or editor from the bottom of the Window menu.
  • Click the Select Window button on the toolbar to toggle between the foremost window or editor and the site window.
  • Choose the desired window or editor from the Select Window button's pop-up menu on the toolbar.

Different states of the Select Window button
A. Click to return to document window.  B. Click to return to site window.  C. Press and hold to display a list of open windows or editors.

  • If you're creating a link to a page or object in another window, drag the pick whip to the Select Window button on the toolbar to bring the other window to the front. Then, continue to drag to the destination in the open window.

  If a window or editor is off-screen and not visible (for example, if you changed your monitor's resolution or dragged the window or editor off the screen edge), choose Window > Cascade and Tile > Cascade to return the window or editor to view.

See also
“Specifying the destination URL for a link” on page 169

To display rulers in the Layout Editor
When you place an object in the Layout Editor, white areas on the rulers indicate the current position and size of the selected object. When you move the pointer in the document window, lines in the rulers move along to indicate the current position of the pointer.
❖ To show or hide the layout rulers, choose View > Show Rulers.

Palettes, tools, and menus

Displaying palettes and tabs
When you first start GoLive, several palettes are displayed by default in groups. You can move palettes between groups or to their own windows, collapse them into tabs on the side of the screen, dock them so that multiple palettes share a single title bar, and resize them to make better use of your work area. You can save the way palettes are displayed as custom workspaces.

Palettes are listed in the Window menu. A check mark next to the palette's name indicates that the palette is showing at the front of its group.
Tabs in the site window and graphical site views behave the same way as palettes; that is, you can rearrange and organize them into new groups.

**To open and arrange palettes**
- To show a palette and any palettes in its group, choose the palette's name from the Window menu. (To hide the palette and its group, choose the name again from the Window menu.)
- To bring a palette to the front of its group, click the palette's name in the group or choose the palette's name from the Window menu.
- To hide all palettes, choose Window > Workspace > Hide All Palettes.
- To return palettes to their default sizes and positions, choose Window > Workspace > Default Workspace.

*Note: The Default Workspace command restores only the default palettes (the objects toolbox, the Inspector, and the Color, Swatches, CSS, Layers, Table, Library, and View palettes). GoLive will close any other open palettes.*

- To separate the tools and objects and to display the objects toolbox horizontally, click the Separate Tools And Objects button in the objects toolbox. Click the button again to undo these changes.
- To dock palettes, drag the palette's tab to the bottom of another palette until the bottom of the target palette is highlighted.

*Note: You can dock the objects toolbox only when it is displayed horizontally.*

**To move a palette or tab between groups**
- Do any of the following tasks:
  - Drag the palette's name in a group to another group.
  - Drag the tab's name from one pane to another in the site window or from the site window to a graphical site view window (navigation or links view).
  - Drag the Navigation tab or the Links tab to a pane in the site window.

*Note: You can move the objects toolbox into another group only when it is displayed horizontally.*

**To move a group or docked group of palettes or tabs**
- To move a group, drag the title bar of the group window.
- To move a docked group, drag the group's title bar.
To move a palette or tab so that it appears in its own window, drag the palette or tab’s name away from the group or site window.

To rearrange palettes and tabs within a group, drag the palette or tab name to a new position. (For example, drag a palette to the right of another palette in its group, or drag a tab in the site window to the left of another tab in its group.)

To bring a tab to the front of its group in the site window
❖ Do any of the following tasks:
  • Click the tab.
  • Choose the tab from the site window’s menu.
  • Drag an appropriate item to the tab, pause while the body of the tab comes to the front, and then continue dragging into the body itself. (For example, drag formatted text to the Fonts tab, pause, and continue dragging into the body of the tab.)

Pausing with the pointer on the Font Sets tab brings the body of the tab to the front.

To collapse palettes into side tabs
• To collapse a palette into side tabs, select the palette’s name and drag it to the left or right side of your computer screen.

Note: In Mac OS, you cannot drag the palette to the side of the screen that contains the Dock.

• To collapse multiple palettes into a side tab, collapse a palette, and then drag another palette’s tab over the tab of the collapsed palette on the edge of the screen.

• To slide open or close the collapsed palette, click the side tab.

• To separate the collapsed palette from the screen edge, drag the tab out to the center of your screen or into a palette group.

• To adjust the size of a collapsed palette, drag the bottom of the palette up or down.

Note: You can collapse the objects toolbox into a side tab only when it is displayed horizontally.
To use palette and window menus
Palette and window menus display options specific to the palette or window.

❖ Click the triangle in the upper right corner of the palette or window, and choose an option from the menu that appears.

Tools
GoLive includes tools for working with objects, layers, grid text boxes, and color. By default, tools are grouped with the objects toolbox. To separate tools from the objects toolbox, click the Separate Tools And Objects button in the objects toolbox.

Standard Editing tool Lets you perform common editing tasks.
Object Selection tool Lets you select anything but text on the page.
Layer tool Lets you draw and position layers on a page.
Grid Text Box tool Lets you draw and position text boxes on a layout grid

Note: If the Grid Text Box tool isn't visible, click and hold the Layer tool to display it.
Eyedropper tool Lets you extract color from text or an object on a page.
Hand tool Lets you scroll the page view.
Zoom tool Lets you magnify a document.

See also
“To magnify or reduce a document” on page 33
“About GoLive layers” on page 253
“To add text to a layout grid” on page 249
“To use the Color palette” on page 176

Toolbars
The main toolbar appears below the command menus at the top of the screen. It contains buttons and pop-up menus that change depending on what you have selected in the work area. In addition to the main toolbar, the Source Code toolbar is available when you work with source code in the document window.

The Version Control toolbar to the right of the main toolbar has buttons that are available when you use a version control system with GoLive.
To display toolbars

- To show or hide the Main, Document, Version Control, or Adobe Services toolbar, choose Window > Toolbars > [Toolbar]. (A check mark next to the toolbar in the Window menu indicates that it is showing.)

- To move the Main toolbar, drag the lower left corner. Once you’ve moved the toolbar from its default position below the command menus at the top of the screen, drag the toolbar by its title bar (Windows) or by the left corner (Mac OS).

- To show or hide the Source Code toolbar, right-click (Windows) or Control-click (Mac OS) in the source code window and choose View > Toolbar from the context menu.

See also

“About version control” on page 150

To use a context menu

Context-sensitive menus display commands relating to the active window or selection. You can use these context menus as a quick way to choose commonly used commands.

❖ Right-click (Windows) or Control-click (Mac OS) the active window or selection.

Previewing and zooming documents

Previewing web pages

You can preview web pages and test links directly in GoLive. You can also preview QuickTime movies, animated GIFs, or any other plug-in media items that GoLive supports. Using the Live Rendering browser, you can preview changes you make in the Layout Editor on the fly. Use the Small Screen Rendering (SSR) option in the Live Rendering browser to approximate what your page looks like when it's published to a mobile device. Layout preview approximates what your page looks like when it's published on the Web.

You can also preview PDF files you create or open in GoLive.

In addition to previewing your page in GoLive, you should always preview it using a variety of browsers, browser versions, and platforms. You’ll need to use browsers to determine potential browser differences and to preview JavaScript, DHTML, or other items for which GoLive doesn't provide native support. If desired, you can start a browser such as Safari, Opera, Netscape Navigator, or Microsoft Internet Explorer from within GoLive by first adding it to the Preview In Browser menu in the toolbar.

You can also view a browser simulation of your page in the Layout Editor by choosing the profile of a specific web browser in the View palette.

See also

“To set view options for page layout” on page 159

“Exporting pages to PDF” on page 399
To preview your page in Layout Preview

1. Make sure that Preview Mode is activated in the Modules preferences: Choose Edit > Preferences (Windows) or GoLive > Preferences (Mac OS), select Modules from the list on the left, and make sure that Preview Mode is selected. Click OK.

2. Click the Layout Preview tab in the document window.

3. To check your page layout, scroll the document window. To test your links, click all of the hot spots on your page. GoLive opens each referenced page in the Preview pane.

To preview your page in the Live Rendering browser

❖ Do any of the following tasks:

- Open the page you want to preview and choose File > Preview In > Live Rendering.
- Choose File > Preview In > Live Rendering, and use the pick whip or click the Browse button to open a page.
- Choose File > Preview In > Live Rendering, choose Load from the Live Rendering window menu, and then select a page in the Choose File To Render dialog box.

To preview your page as it will appear on a mobile device, click SSR in the Live Rendering browser, or open the page you want to preview and choose File > Preview In > Small Screen Rendering.

Changes you make in the Layout Editor are reflected in the Live Rendering browser after you click in the Live Rendering browser. If you have multiple document windows open, the Live Rendering browser previews the currently selected document.

To set Live Rendering browser options

❖ Choose an option from the Live Rendering window menu:

Load Open a file from the Choose File To Render dialog box.

Reload Reflects changes you’ve made in the Layout Editor (use this option if you’ve deselected Auto Update).

Auto Update Ensures that the Live Rendering browser displays changes you make in the Layout Editor when you click in the Live Rendering browser (this option is selected by default). If Auto Update isn’t selected, you’ll need to choose Reload after you make a change in the Layout Editor.

Bound Binds the Live Rendering browser to a specific document: select the open document you want to preview, and then choose Bound from the Live Rendering window menu.

To specify browsers for previewing

1. Make sure that each browser is installed on your hard disk and that all plug-ins you need for previewing are placed in the browser’s Plug-ins folder (or any other location your browser uses for multimedia extensions).

2. Choose Edit > Preferences (Windows) or GoLive > Preferences (Mac OS), and select the Browsers icon from the list on the left.

3. Do one of the following tasks to populate the list of browsers:

   - To add all browsers on your hard disk to the browser list, click Find All.
   - To add a single browser to the list, click Add. Then locate and select the browser and click Open (Windows) or Choose (Mac OS).
4 Select one or more browsers that you want to be started when you click the Preview In Browser button on the toolbar or when you choose File > Preview In > Default Browser.

**Note:** Most browsers only allow you to open one version at a time. For example, you can open Netscape Navigator and Microsoft Internet Explorer at the same time, but not Netscape Navigator 6.0 and 7.0.

5 (Optional) To delete a browser from the scrolling window, select it and click Remove.

6 Click OK.

If you select two or more types of browsers, a generic browser icon appears on the toolbar. If you select only a single type of browser, the program icon for that browser appears on the toolbar.

**To preview your page in a browser**

- To preview the page in all of the browsers selected in the Browsers preferences, click the Preview In Browser button on the toolbar, or choose File > Preview In > Default Browser.

- To preview the page in a single browser from the Browsers preferences, click and hold the Preview In Browser button on the toolbar, and then choose the browser from the menu that appears. Or, choose a browser from the File > Preview In submenu.

**To magnify or reduce a document**

- Do one of the following tasks:
  - Click the Zoom tool in the objects toolbox and click in the document window. Alt-click (Windows) or Option-click to reduce the view.
  - Click the Zoom In button or the Zoom Out button at the bottom of the document window.
  - Choose a magnification value from the Zoom Values menu at the bottom of the document window.
  - Choose Edit from the Zoom Values menu at the bottom of the document window, enter a zoom value percentage in the Zoom To dialog box, and then click OK.
Customizing the work area

To save and use a custom workspace
You can save the current sizes and positions of palettes on the screen as custom workspaces. Custom workspaces are useful for working on different types of pages, such as regular web pages or pages with cascading style sheets, which require different palettes to be visible.

1. Open, close, resize, and arrange the palettes as desired on the screen.
2. Choose Window > Workspace > Save Workspace.
3. Do one of the following tasks:
   • Type a name for a new workspace in the text box.
   • Choose the name of an existing workspace to replace from the pop-up menu.
4. (Optional) To use your custom workspace, choose it from the Window > Workspace submenu.

To edit the list of custom workspaces
1. Choose Window > Workspace > Manage Workspaces.
2. Select a name in the list of workspaces and do any of the following tasks:
   • To add a new workspace, click the Create New Workspace button.
   • To change the name of the workspace, type a new name in the box and press Enter.
   • To remove the workspace, click the Remove Selected Workspaces button.

Setting preferences

About preferences
You can change most of the program settings using the Preferences dialog box, giving you control over the way GoLive looks and behaves. For example, you can set display options, options for importing images, options for activating modules, options for selecting default web browsers that you start from GoLive, and spelling checker options.

The GoLive preferences file is located in the Documents and Settings/[user]/Application Data/Adobe/Adobe GoLive folder (Windows) and the Mac OS X/Users/[username]/Library/Preferences folder (Mac OS).

Note: Some preferences also appear in the Site Settings dialog box (such as URL Handling options) and can be overridden by settings you make for a specific site.

See also
“Specifying preferences and settings for websites” on page 201
To set options in the Preferences dialog box
1. Choose Edit > Preferences (Windows) or GoLive > Preferences (Mac OS).
2. Select an icon or name from the list on the left. If needed, click the triangle or + symbol next to the icon to display a list of names below the icon.
3. Specify options on the right side of the Preferences dialog box.
4. Click OK. The new settings take effect the next time you start GoLive.

To set General preferences
Set the General preferences to control the overall working behavior of GoLive.
1. Choose Edit > Preferences (Windows) or GoLive > Preferences (Mac OS).
2. Select General from the list on the left.
3. Set any of the following options, and click OK:
   - **Launch Other Applications To Edit Media Files** Specifies whether files that you double-click open in GoLive or in another application that you specify in the File Mappings tab in the Web Settings window.
   - **Show Tooltips** Specifies whether tool tips appear when you place the pointer over an icon, button, or tool.
   - **Write "Generator Adobe GoLive"** Specifies that the meta information "<meta name="generator" content="Adobe GoLive ">"></meta> will appear in each file that you create or save.
   - **At Launch** Specifies what window GoLive opens when it launches. Choose Create New Document to open a new file at launch. Choose Show Welcome Screen to open a window that offers the choice of opening a new page or site, an existing file, or tutorials and extras. Choose Do Nothing to launch without any file or window opening.
   - **Default Mode** Specifies which document window tab (such as the Source tab) is visible when you initially open a document.

See also
"Setting up pages" on page 157
"Stationery" on page 426
"File Mappings options" on page 649

To activate or deactivate program modules
Use the Modules preferences to disable or enable selected modules and extend scripts on an as-needed basis—improving the GoLive application's launch time, responsiveness, and overall memory requirements.
1. Choose Edit > Preferences (Windows) or GoLive > Preferences (Mac OS).
2. Select Modules from the list on the left.
3. To read a description of a module, select it in the right pane and click the triangle next to Show Item Information at the bottom of the window.
4. To select or deselect modules, click the check boxes. Program modules that are currently installed are checked by default.
5. Click OK, and then restart GoLive.
Reverting and restoring changes to pages

Using the History palette
The History palette records the changes that you make to a page in the Layout Editor or Source Code Editor and changes you make to files in the site window. Each time that you make a change, the new state of the page or site is added to the History palette. You can revert to a previous state of the page or site or you can restore changes that you made to that state.

When you switch between open documents or site windows, the contents of the History palette adjust accordingly. However, the content is cleared and you lose the information when you click a different tab in the document window.

You can set the maximum number of states that the History palette displays for a page or site (20 states by default).

To undo and redo changes using the History palette
1. Choose Window > History.

The History palette lists the previous states of the document, with the oldest state at the top of the list and the newest state at the bottom.

2. In the History palette, click the state of the document to which you want to revert.

3. To restore the changes that you made to that document state, choose a newer state in the History palette. (The newer states of the document are dimmed.)

In Mac OS, press Shift+Command+Z to restore the changes that you made to a document state incrementally.

To set the maximum number of states listed in the History palette
❖ In the History palette, choose History Options from the palette menu, enter a number between 1 and 1600 in the Maximum History States box, and click OK.

To clear the History palette of all states
❖ In the History palette, choose Clear History from the palette menu.

To undo, redo, and revert actions
1. To undo an action, do one of the following tasks:
   - Choose Edit > Undo. The menu command describes the last action you performed. Each time you choose the command from the menu and undo the action, the description changes to match what has now become the last action you performed. When no actions remain, the menu command is dimmed.
   - Choose Undo from the palette menu.

2. To redo the action, do one of the following tasks:
   - Choose Edit > Redo. The menu command describes the last action that you can redo. Each time you choose the command from the menu and redo the action, the description changes to match what has now become the last action you can redo. When all of the actions are redone, the menu command is dimmed.
   - Choose Redo from the palette menu.

3. To revert to the way the page was when you last saved it, choose File > Revert To Saved.
Chapter 4: Adobe Bridge

The basics of Bridge

About Adobe Bridge
Adobe Bridge is the control center for Adobe Creative Suite. You use it to organize, browse, and locate the assets you need to create content for print, the web, and mobile devices. Adobe Bridge keeps native PSD, AI, INDD, and Adobe PDF files as well as other Adobe and non-Adobe application files available for easy access. You can drag assets into your layouts as needed, preview them, and even add metadata to them. Bridge is available independently, as well as from within Adobe Photoshop, Adobe Illustrator, Adobe InDesign, and Adobe GoLive.

File browsing From Bridge you can view, search, sort, manage, and process image files. You can use Bridge to create new folders; rename, move, and delete files; edit metadata; rotate images; and run batch commands. You can also view information about files and data imported from your digital camera.

Version Cue If you have Adobe Creative Suite, you can use Bridge as a central location from which to use Adobe Version Cue. From Bridge, you can browse all the files in a project in one place without having to start the native application for each file, including non-Adobe application files. Also, you can create new Version Cue projects, delete projects, create versions, save alternates, and set access privileges in Bridge. See “Working with Version Cue in Bridge” on page 59.

Bridge Center If you have Adobe Creative Suite, Adobe Bridge includes Bridge Center, the “dashboard” of Adobe Creative Suite, where you can view news readers in your web browser, see your most recent activity, read about tips and tricks for using Adobe products, save groups of files, and more. Adobe Creative Suite users can also use Bridge to specify color management settings and access scripts that help automate your workflow. See “About Bridge Center” on page 50.

Camera Raw If you have Adobe Photoshop installed, you can open and edit camera raw files from Bridge and save them in a Photoshop-compatible format. You can edit the image settings directly in the Camera Raw dialog box without starting Photoshop. If you don’t have Photoshop installed, you can still preview the camera raw files in Bridge. See “To open files in Bridge” on page 45.

Stock Photos Click Adobe Stock Photos from the Favorites pane in Bridge to search leading stock libraries for royalty-free images. You can download low-resolution, complementary versions of the images and try them out in your projects before purchasing them. See “About Adobe Stock Photos” on page 61.

Color management You can use Bridge to synchronize color settings across applications. This synchronization ensures that colors look the same no matter which Creative Suite application you view them in. See “To synchronize color settings across Adobe applications” on page 656.

See also
“The Bridge work area” on page 37

The Bridge work area
These are the main components of the Adobe Bridge window:
The menu bar  Contains commands specific to Bridge. In Windows®, the menu bar is at the top of the Bridge window. In Mac OS®, the menu bar is located at the top of the screen.

The Look In menu  Lists the folder hierarchy, as well as favorite and recent folders. This menu gives you a quick way to find folders containing the items you want to display. The menu is at the top of the Bridge window.

The shortcut buttons  Help you work efficiently with your files. They are located to the right of the Look In menu, at the top of the Bridge window.

The Favorites panel  Gives you quick access to folders as well as to Version Cue, Adobe Stock Photos, collections, and Bridge Center (Adobe Creative Suite only). Like all panels, it’s located on the left side of the Bridge window.

The Folders panel  Shows the folder hierarchy. Use it to navigate to the correct folder.

The Preview panel  Displays a preview of the selected file, separate from and typically larger than the thumbnail image displayed in the content area. You can reduce or enlarge the preview.

The Metadata panel  Contains metadata information for the selected file. If multiple files are selected, shared data (such as keywords, date created, and exposure setting) is listed.

The Keywords panel  Helps you organize your images by attaching keywords to them.

The content area  Displays thumbnail previews of the items in the current folder, along with information about those items.

The bottom of the Bridge window displays status information and contains buttons for toggling the display of the panels, a slider for setting the size of thumbnails, and buttons for specifying the type of display in the content area.
To start and quit Bridge, and to return to an application

Do any of the following:

- To open Bridge from an application, choose File > Browse from your application.
- (Windows) To open Bridge directly, choose Adobe Bridge from the Start menu.
- (Mac OS) To open Bridge directly, double-click the Adobe Bridge icon 🎨. By default, this is located in the Applications/Adobe Bridge folder.
- To quit Bridge, choose File > Exit (Windows) or Bridge > Quit Bridge (Mac OS).
- To return to the last open application that started Bridge, choose File > Return To [Application].

See also

“About Adobe Bridge” on page 37
“To manage files with Bridge” on page 46

To create and close Bridge windows

Do one of the following:

- Choose File > New Window to create a full-size Bridge window.
- Choose File > Close Window. In Windows, this command quits Bridge as well.

See also

“The Bridge work area” on page 37
“To use Bridge in Compact mode” on page 39

To use Bridge in Compact mode

Switch to Compact mode when you want to shrink the Bridge window, hiding the panels and simplifying the content area. A subset of common Bridge commands remains available from the pop-up menu at the top right of the window.
By default, the Compact mode Bridge window floats on top of all windows. (In Full mode, the Bridge window can move behind application windows.) This floating window is useful because it is always visible and usable as you work in different applications. For instance, you might use Compact mode after you select the files you plan to use, and then drag them into the application as you need them.

1. Click the Switch To Compact Mode button 📦.

2. Do any of the following:
   - Choose commands from the menu at the top right of the Bridge window.
   - Click the Switch To Ultra Compact Mode button 📦 to hide the content area, further minimizing the Bridge window. You can click the button again to return to Compact mode.
   - Click the Switch To Full Mode button 📦 to return to Full mode, displaying the content area and the panels, and letting Bridge move behind the current application window.

See also
“The Bridge work area” on page 37

To adjust the Bridge window
You can adjust the Bridge window by moving and resizing the panels. For example, you can enlarge the Preview panel to display bigger thumbnails. You can’t, however, move panels outside the Bridge window.

❖ Do any of the following:
   - Drag a panel by its tab up or down into another panel area.
   - Drag the horizontal divider bar between panels to make them larger or smaller.
   - Drag the vertical divider bar between the panels and the content area right or left to resize the panels or content area.
   - Click the Show/Hide Panes button ⬇️ at the lower left of the Bridge window to display or hide the panels.
   - Choose View, followed by the name of the panel you want to display or hide.

See also
“The Bridge work area” on page 37

To select Bridge workspaces
A Bridge workspace is a certain configuration or layout of the work area. You can select either a premade one or a custom one that you have previously saved. You can use a preset configuration or switch between different configurations best suited for specific tasks, such as sorting photos.

Note: A Bridge workspace is different from a Version Cue Workspace. Your work in Bridge workspaces has no effect on the Version Cue Workspaces.

❖ Choose Window, followed by the name of the workspace you want, or choose Window > Workspace, followed by one of the following commands:

Lightbox Displays just the content area of Bridge, so that you can concentrate on viewing the files.

File Navigator Displays the content area in Thumbnails view, along with the Favorites panel and Folder panel.
Metadata Focus Displays the content area in Thumbnails view, along with the Metadata panel prominently shown.

Filmstrip Focus Displays just the content area, in Filmstrip view.

See also
“To save and delete Bridge workspaces” on page 41

To save and delete Bridge workspaces
You can save the current Bridge layout (that is, the work area configuration) as a workspace and reuse it later. By saving Bridge in various configurations, you can work in (and quickly switch between) different layouts of the work area. For instance, you might use one workspace to sort new photos and another to work with Adobe InDesign files.

Note: A Bridge workspace is different from a Version Cue Workspace. Your work in Bridge workspaces has no effect on Version Cue Workspaces.

❖ Choose Window > Workspace, followed by one of these commands:

Save Workspace Saves the current Bridge layout as a workspace so that you can reuse it later, even if you move a panel or change the view in the content area. If you choose this command, enter a name for the workspace and click Save. You can also assign a keyboard shortcut to the workspace and specify whether to save the location of the Bridge window as part of the workspace.

Delete Workspace Deletes the saved workspace. If you choose this command, choose the workspace from the menu, and click Delete.

Reset To Default Workspace Restores the workspace to the default configuration.

See also
“To select Bridge workspaces” on page 40

To set Bridge preferences
1 Choose Edit > Preferences (Windows) or Bridge > Preferences (Mac OS).

2 Select any of the preferences categories on the left:

General Controls the general appearance settings. You can use this category to specify such preferences as how dark to make the content area for thumbnails, what information to show with thumbnails, and what to include in the Favorites panel. See “Bridge General preferences” on page 42.

Metadata Controls which sections and fields are displayed in the Metadata panel.

Labels Assigns names to each color label and specifies whether you need to press Control as part of the keyboard shortcut combination to apply labels and ratings to files.

File Type Associations Specifies which application to use from Bridge to open files of the named type. For any file type, you can click the name of the application (or None) and click Browse to locate an application to use. You can also reset the file type associations to their default settings as well as hide any file types that don’t have an associated application. This affects only those files that you open with Bridge, and overrides the Explorer (Windows) and Finder (Mac OS) settings.

Advanced  Specifies advanced settings, including cache options and language options. See “Bridge Advanced preferences” on page 42.

3  Click OK.

Bridge General preferences
Set any of the following General preferences and click OK:

Background  Specifies the darkness of the content area in which thumbnails are shown.

Show Tooltips  Specifies whether to display Bridge help information when you position the pointer over an item. (This preference does not affect settings for Version Cue tool tips, which display metadata for items.)

Additional Lines Of Thumbnail Metadata  Specifies whether to show additional metadata information with thumbnails in the content area. If you select this option, you can choose the type of metadata to show from the associated menu. You can display up to three extra lines of information.

Favorites Items  Specifies what items to show in the Favorites panel. Certain options are dimmed if you do not have those items.

Reveal Scripts In Finder  Opens the folder that contains scripts (the commands available in the Tools menu).

Reset All Warning Dialogs  Resets warning notices in Bridge to their default settings.

See also
“To set Bridge preferences” on page 41

Bridge Advanced preferences
Set any of the following Advanced preferences and click OK:

Do Not Process Files Larger Than  Specifies the maximum file size of documents for which Bridge automatically creates thumbnails. Displaying large files can slow performance.

Number Of Recently Visited Folders To Display In The Look In Popup  Sets the number of most recently viewed folders that appear in the Look In menu.

Language  Sets the language used in the Bridge interface. Select Automatic to set the language to the one specified for Bridge by the program that installed it.

Show Camera Raw Interface On Open  Opens camera raw files in the Adobe Camera Raw dialog box in Adobe Photoshop.

Use A Centralized Cache File  Places the two cache files created for each folder you view in a centralized folder. A centralized cache is generally easier to use than a distributed cache. For instance, when the cache is centralized, you don't have to search in multiple, distributed locations if you want to remove the cache. To specify a new name or location for this centralized cache folder, click Choose.

Use Distributed Cache Files When Possible  Places the two cache files created for each folder you view in the viewed folder, if possible. For instance, it's not possible to place the cache files in the viewed folder if that folder is on a burned CD. In that case, Bridge places the cache files in the centralized folder instead. However, if you are burning a CD, using a distributed cache means that you don't have to export the cache to the CD, because it is already in the
folder you are burning to the CD. Also, using distributed cache files preserves the cache in a folder if you rename that folder. See “To work with the cache in Bridge” on page 43.

**Note:** Cache files are hidden files. To view them in Bridge, choose View > Show Hidden Files.

**See also**

“To set Bridge preferences” on page 41

**To work with the cache in Bridge**

The cache stores thumbnail, metadata, and file information to shorten loading times when you return to a previously viewed folder. However, storing the cache takes up disk space.

**Note:** Purging the cache deletes the metadata cache and thumbnail cache. If the metadata can't be written to a file, label and rating information is lost as well.

❖ Choose any of the following commands from the Tools > Cache submenu:

**Build Cache For Subfolders** Builds, as a background process, a cache for the selected folder and all the folders within it (except aliases/shortcuts to other folders), shortening the time spent waiting for the cache to be displayed as you look in subfolders.

**Purge Cache For This Folder** Clears the cache for the selected folder. This command is useful if you suspect that the cache for a folder is old and needs to be regenerated.

**Purge Central Cache** Clears the entire centralized cache and any distributed cache in the currently viewed folder, freeing room on the hard drive. The command does not otherwise clear local caches.

**Export Cache** Exports the cache, allowing you to burn a CD with the cache already generated. Because the folder cache is written into the folder, the thumbnail cache and metadata cache are available after you burn the CD. This option is active only if you chose Use A Centralized Cache File in the Preferences dialog box.

**See also**

“About Adobe Bridge” on page 37

**Files and folders in Bridge**

**To view file and folder thumbnails in Bridge**

The content area of Bridge displays thumbnails of the files and folders of the selected folder, along with information about them (depending on your view).

You can specify how you want files and folders are displayed in the content area; for instance, you can decide how big thumbnails should be, how they should appear, and whether file information should be displayed.

❖ Do any of the following:

- Drag the Thumbnail slider at the bottom of the Bridge window to adjust the size of thumbnails. You can also click the buttons at either side of the Thumbnail slider to minimize or maximize the thumbnails.
- Click the Thumbnail View button at the bottom of the Bridge window or choose View > As Thumbnails to display items in a grid.
• Click the Filmstrip View button or choose View > As Filmstrip to display thumbnails in a scrolling list along with an extra-large thumbnail of the currently selected item. Click the Back button or Forward button directly below the extra-large thumbnail to go to the previous or next thumbnail. Click the Switch Filmstrip Orientation button to change from a horizontal slide show to a vertical one. Note that you can page through a PDF preview in Filmstrip view.

• Click the Details View button or choose View > As Details to display a scrollable list of thumbnails along with information about the selected file, such as its creation date, file type, pixel size, and file size. For Version Cue files, there is additional information about the number of versions or alternates as well as enhanced status information along with the current version comment.

• Click the Versions And Alternates View button or choose View > As Versions And Alternates to display a scrollable list of thumbnails along with thumbnails of any Version Cue alternates and versions for each item. (Only the current file appears unless you have created an alternates group containing the file or created previous versions of the file.) Click Alternates View or Versions View at the top right of the content area to display thumbnails of alternates or versions. In Alternates View, you can also create alternates groups containing files that are not in the current folder.

• Choose View > Show Thumbnail Only to view thumbnails without any text information listed. However, Version Cue tool tips still display Version Cue information when you position the pointer over the thumbnail.

• Choose View > Slideshow to view thumbnails as a slide show that takes over the entire screen. This is a quick and easy way to display and work with large versions of all the graphics files in a folder. Instructions on how to use the slide show are displayed on the screen when you choose this command.

Depending on the view you're in, you can display extra file information by positioning the pointer over a thumbnail in the content area. For files in Version Cue projects, you can also choose File > Versions or File Alternate. This command opens a dialog box that lets you work with the file's versions or alternates without having to select that view in the Bridge content area.

To specify how files and folders are shown in Bridge
You can specify what type of files and folders you want to display as thumbnails in the content area, as well as the order in which to display them.

❖ Choose any of the following commands from the View menu:

• Sort, followed by the order in which you want to sort files. Choose Ascending to sort in ascending rather than descending order. Choose Manually to sort by the last order in which you dragged the files.

• Show Hidden Files to display hidden files, such as cache files and Version Cue files that have been provisionally removed (not permanently deleted) from Version Cue projects.

• Show Folders to display folders as well as individual files.

• Show All Files to display all files regardless of type, even non-Adobe files that Bridge doesn't normally display.

• Show Graphic Files Only to display only files in graphic file formats, such as EPS, JPEG, BMP, PS, TIFF, and GIF.

• Show Camera Raw Files Only to display only camera raw files.

• Show Vector Files Only to display only files created with drawing programs such as Adobe Illustrator, and EPS and PS files.

• Refresh (or choose Refresh from the Folders panel menu) to update the content area. This is useful, for instance, when you perform certain Version Cue actions that don't automatically refresh the view in the content area. Closing and reopening Bridge also refreshes the view.
You can also click Unfiltered at the top right of the Bridge window and choose the files you want to display based on their rating or label. The Unfiltered menu operates independently of the View > Sort commands.

**To navigate folders and files with Bridge**

❖ Do any of the following:
  - Select the Folders panel and click to select the folder you want. Click the plus sign (Windows) or triangle (Mac OS) next to a folder or double-click the folder to open subfolders within it.
  - Select the Favorites panel and click to select the folder you want.
  - Choose a folder from the Look In menu. You can click the Go Back button, Go Forward button, or Go Up button next to the menu to navigate within the current folder listed in the menu.

**See also**

“To specify how files and folders are shown in Bridge” on page 44

**To select files in Bridge**

Before you can work with a file, you need to select it. You can select more than one file at a time.

❖ Do one of the following in the current folder:
  - Click the thumbnail of a file.
  - To select contiguous files, Shift-click them.
  - To select noncontiguous files, Ctrl-click (Windows) or Command-click (Mac OS) them.
  - To select all the files, choose Edit > Select All.
  - To select all labeled files, choose Edit > Select Labeled.
  - To select all unlabeled files, choose Edit > Select Unlabeled.
  - To select the opposite of the current selection, choose Edit > Invert Selection.
  - To deselect all selected files, choose Edit > Deselect All.

**See also**

“To manage files with Bridge” on page 46

“To manage folders with Bridge” on page 47

**To open files in Bridge**

You can open files in Bridge, even files that were not made with Adobe Creative Suite applications.

1 Select the file in the current folder.
2 Do one of the following:
   - Choose File > Open.
   - Press Enter (Windows) or Return (Mac OS).
   - Double-click the file in the content area or Preview panel.
   - Choose File > Open With, followed by the name of the application with which to open the file.
• Drag the file into the working area of an application, such as an open Illustrator document.
• Drag the file onto the application icon.
• Choose File > Open With Camera Raw to edit the Adobe camera raw settings for the file.

See also
“To manage files with Bridge” on page 46
“To manage folders with Bridge” on page 47

To manage files with Bridge
Adobe Bridge makes it easy to drag and drop files, move them between folders, copy and duplicate them, and otherwise manipulate them.

Note: From Bridge, you can also use Adobe Version Cue to manage files you author in Adobe Creative Suite applications. You can create and manage revisions to files kept in Version Cue projects. Version Cue is also a convenient environment for collaborative file management in workgroups. You can manage not only Adobe Creative Suite files but also non-Adobe files.

❖ Do any of the following:
  To delete files  Select the files and click the Delete button 🗑️, click Delete on your keyboard, choose File > Send To Recycle Bin (Windows), choose File > Move To Trash (Mac OS), drag the file to the Recycle Bin or Trash, or choose Edit > Cut.
  To copy files and folders  Select the files or folders and choose Edit > Copy, or Ctrl-drag (Windows) or Option-drag (Mac OS) the file or folders to a different folder.
  To duplicate files  Select the files and choose Edit > Duplicate.
  To paste files  Choose Edit > Paste.
  To move files to another folder  Select the files and drag them to a different folder. (When you search for Adobe Stock Photos, you can’t drag images to other areas, because some images may be comp thumbnails. To drag a comp image, first download it and then drag it from the downloaded comp’s folder.)
To quickly attach an image to an e-mail message, drag the image from Bridge and drop it into the e-mail message.

To rename files  Click the file name, type a new name, and press Enter (Windows) or Return (Mac OS).

To manually reorder files in the content area  Drag the file to a new location in the content area.

To display the location of a file in the operating system  Select the file and choose File > Reveal In Explorer (Windows) or File > Reveal In Finder (Mac OS).

To find the location of a file in a collection  Select a file and choose File > Reveal In Bridge. By default, if you select a file in a collection, it is listed as being located in the folder “File Results.” Selecting Reveal In Bridge moves you to the folder in which the file is located.

To place files into an application  Select the files and choose File > Place, followed by the name of the application. Depending on the file, the document into which you want to place it may need to be open first.

To eject attached media such as CDs and DVDs  Select the medium and choose File > Eject.

To drag files out of Bridge  Select the files and drag them onto the desktop or into another folder. This action copies the file (Windows) or moves the file (Mac OS) onto the desktop or folder.

To drag files into Bridge  Select one or more files on the desktop, in a folder, or in another application that supports drag and drop, and drag them into the content area in Bridge. The files are moved from their current folder into the one displayed in Bridge. (If the file you are dragging is in a different mounted volume than Bridge, the file is copied into Bridge.)

Drag a file or folder onto the Preview panel to display the contents of the folder in Bridge.

See also
"To search for files and folders with Bridge” on page 49
"To batch-rename files with Bridge” on page 53
"To run automated tasks with Bridge” on page 52
"Working with Version Cue in Bridge” on page 59

To manage folders with Bridge
❖ Do any of the following:

To create new folders  Click the Create A New Folder button or Choose File > New Folder. Then, enter a name when the folder appears in the content area.

To delete folders  Select the folder and click the Delete button , press Delete on your keyboard, or choose File > Move To Recycle Bin (Windows) or File > Move To Trash (Mac OS).

To add folders to Favorites  Choose a folder from the Look In menu or Folders panel or select it in the content area. Then choose File > Add To Favorites. You can also drag the folder from the content area to the Favorites panel.

To remove folders from Favorites  In the Favorites panel, select the folder you want to remove. Then choose File > Remove From Favorites.
To reorganize folders in the Favorites panel Drag the folder to the desired location in the panel.

To rename folders Click the folder name, type a new name, and press Enter (Windows) or Return (Mac OS).

See also
“About Adobe Bridge” on page 37
“To manage files with Bridge” on page 46

To rotate images with Bridge
You can rotate the view of JPEG, PSD, TIFF, and camera raw file images in Bridge. Rotating an image in Bridge may rotate it in the application in which it was created as well. Rotating does not affect the data in the image file.

1 Select one or more images in the content area.
2 Do one of the following:
   • To rotate the images 90˚ clockwise, click the Rotate 90˚ Clockwise button or choose Edit > Rotate 90˚ Clockwise.
   • To rotate the images 90˚ counterclockwise, click the Rotate 90˚ Counterclockwise button or choose Edit > Rotate 90˚ Counterclockwise.
   • To rotate the image 180˚, choose Edit > Rotate 180˚.

See also
“About Adobe Bridge” on page 37
“To manage files with Bridge” on page 46

To label files with Bridge
Labeling files with a color is a flexible way to quickly mark a large number of files. Using the View > Sort menu or Unfilter button, you can choose to view files according to their label.

For example, suppose you’ve just imported a large number of images and are viewing them in Bridge. As you review each new image, you can label those you want to keep. After this initial pass, you can use the Unfilter button to display and work on files you’ve labeled with a particular color.

You can assign names to labels through the Preferences dialog box. The name is then added to the file’s metadata when you apply the label.

Note: When you view folders, Bridge shows both labeled and unlabeled files until you choose another option. Also, purging the cache deletes labels from files that don’t support XMP write (such as BMP, DCS, Pict, PS6 PDF, and PSB files), locked files, or read-only files (such as files on CDs).

1 Select one or more files.
2 Do one of the following:
   • To label files, choose a color from the Label menu.
   • To remove labels from files, choose Label > No Label.
To rate files with Bridge
You can assign ratings to files, awarding from zero to five stars. Using the View > Sort menu or Unfilter button, you can choose to view files according to their rating.

For example, suppose you’ve just imported a large number of images and are viewing them in Bridge. As you review each new image, you can rate them from best to worst. After this initial pass, you can view only files you’ve rated with four or five stars and work on those.

1. Select one or more files.
2. Do any of the following:
   • In Thumbnail view, click the dot representing the number of stars you want to give the file. (Dots do not appear in very small thumbnail views. If necessary, rescale the thumbnail view until the dots appear.)
   • Choose a rating from the Label menu.
   • To add one star, choose Label > Increase Rating.
   • To remove one star, choose Label > Decrease Rating.
   • To remove all stars, choose Label > No Rating or click the No Rating icon on the thumbnail of the file.

To search for files and folders with Bridge
You can perform searches with Bridge. You can narrow your search by adding multiple search criteria. You can even save your search criteria as a collection, so that you can perform the same search again later.

Note: For information on searching for Adobe Stock Photos with Bridge, see Help.

1. Choose Edit > Find.
2. In the Find dialog box, choose a source folder from the Look In menu. By default, the menu displays the currently active folder. Click the Browse button to navigate to another folder.
3. (Optional) Select Include All Subfolders to expand the search to any subfolders in the source folder.
4. (Optional) Select Search Past Versions Of Version Cue Files to include past versions of Adobe Version Cue files, as well as current ones, in the search.
5. (Optional) Select Show Find In A New Browser Window to display the search results in a new Bridge window. If left unselected, the search results appear in the content area of the current window.
6. Choose a criterion for your search by selecting an option from the leftmost Criteria menu.
7. Select a limiter from the center Criteria menu.
8. Enter the search text in the text box at the right, if needed. You can enter basic search terms such as AND, OR, and * (for wild cards).
9 To add search criteria, click the plus sign button. To remove search criteria, click the minus sign button.

10 Click Find. Bridge displays the files that match the search criteria, and you can navigate through the files.

11 (Optional) To save the search criteria to perform the same search again, click Save As Collection. Enter a name for the collection. Select Start Search From Current Folder to search from the same folder in the future. Then, click Save. The search criteria are saved in the Collections folder listed in the Favorites panel.

See also

“To manage files with Bridge” on page 46

“To search with criteria saved as collections” on page 50

To search with criteria saved as collections

If you saved search criteria by using the Save As Collection option in the Find dialog box, you can run that search again by using that collection.

1 Select Collections in the Favorites panel or Look In menu.

2 Double-click the collection you want.

A new Bridge window appears containing the results of the search.

See also

“To manage files with Bridge” on page 46

“To search for files and folders with Bridge” on page 49

Bridge Center

About Bridge Center

If you are working with the Adobe Creative Suite, Bridge Center gives you quick access to your most recent files and folders, RSS newsreaders for the latest information, tips and tricks for using Adobe products, color management features, and Help documentation. It even lets you start new Version Cue projects.

To display Bridge Center, select it in the Favorites panel.

Note: If you don’t see Bridge Center in the Favorites panel, make sure that Center is selected in the General preferences. See “To set Bridge preferences” on page 41.

Adobe Stock Photos  Opens the Adobe Stock Photos home page in Bridge.

Saved File Groups  Lists sets of files that you have saved as a group, even if they are being used in separate applications. When you create a saved file group, you assemble and name a set of files, which Bridge then closes. When you open a saved file group, Bridge reopens the current version of those files, launching the appropriate Adobe Creative Suite applications as needed. See “To work with saved file groups in Bridge Center” on page 51.

Note: Saved file groups do not preserve versions of files; groups always contain the most current version of the files. For instance, suppose you include the file logo.jpg in a saved file group. If you open the saved file group later, edit the logo.jpg file, and save it in another group, both saved file groups will contain the same logo.jpg file.
Recent Folders  Lists your most recently visited folders. See “To use recent folders or files from Bridge Center” on page 51.

Recent Files  Displays the most recently opened files.

RSS Reader  RSS displays shared web content, such as headlines from different websites and the latest information on products from Adobe. RSS stands for Really Simple Syndication and is an XML format used to gather and distribute web content while reducing traffic to websites. See “To use RSS content in Bridge Center” on page 52.

Tips And Tricks  Lists helpful tips and tricks for getting the most out of Adobe Creative Suite and other Adobe applications. Click the Next button or Previous button to go to the next or previous tips and tricks topic.

Note: Click Close or Open located above the bottom tabs to hide or reveal the RSS Reader area and Tips And Tricks area.

New Version Cue Project  Opens the New Version Cue project and displays a dialog box for creating a new project.

Color Management/Open Color Settings  Opens the Color Settings dialog box so that you can manage color for Adobe Creative Suite applications. Also displays the Adobe Creative Suite Color Settings state (Synchronize or Unsynchronize).

Open Help  Starts Adobe Help Center.

To work with saved file groups in Bridge Center

1  Click Bridge Center in the Favorites panel.

Note: Bridge Center is available with Adobe Creative Suite only.

2  In the Saved File groups, do any of the following:

• To save your currently open files as a group, click the text Save Open Files into a File Group.
• To open a saved file group, select the group and click the text Open this File Group.
• To display a group in the content area, click the name of that file group.
• To delete a saved file group, select the group and click Delete at the bottom.

To use recent folders or files from Bridge Center

1  Click Bridge Center in the Favorites panel.

Note: Bridge Center is available with Adobe Creative Suite only.

2  In the Recent Folders or Recent Files Group, do any of the following:

• To display a folder in the content area, click that folder.
• To sort the folders by name or date, click Name or Date.
• To open a file in the default application, click the file thumbnail or file name.
• To display the folder that contains a file, click the Shell icon next to the file name. The folder is displayed in the content area.
• To sort the folders by name, date, or type, click Name, Date, or Type.
To use RSS content in Bridge Center

RSS (Really Simple Syndication) is an XML format for gathering and distributing web content. It displays web content, such as the latest information on Adobe products.

1 Click Bridge Center in the Favorites panel.

**Note:** Bridge Center is available with Adobe Creative Suite only.

2 In the RSS Reader section, do any of the following:
   - To view content, click to select an RSS site from the list on the left, and then click to select a specific topic from the list on the right. If you want, click More to start your default web browser and display further information on the topic from that RSS website.
   - To add the URL of an RSS site, click the plus sign (+) at the top of the tab.
   - To delete an RSS site from the list, select the site and click the minus sign (-).
   - To specify how often to check RSS sites for updates, click Open Settings and enter a number specifying the interval, in hours.
   - To check the RSS sites for updates manually, Click Update Now.

Running automated tasks with Bridge

To run automated tasks with Bridge

The Tools menu contains submenus for various commands available in the different Adobe Creative Suite applications. For instance, if you have Adobe Photoshop installed, you can use the commands under the Tools > Photoshop submenu to make picture packages and create Photomerge panoramas using photos you select in Bridge. Running these tasks from Bridge saves time because you don't have to open each file individually.

**Note:** Third parties can also create and add their own items to the Tools menu for added functionality in Bridge. For information about creating your own scripts, see Bridge JavaScript Scripting Reference.

1 Select the files or folders you want to use. If you select a folder, the command is applied where possible to all files in the folder.

2 Choose Tools > [Application], followed by the command you want. (If your application doesn't have any automated tasks available, no application name appears in the menu.)

For information about a particular command, see the documentation for that application.

**See also**

“About Adobe Bridge” on page 37

“To manage files with Bridge” on page 46

“To batch-rename files with Bridge” on page 53
To batch-rename files with Bridge

You can rename files and folders in a group, or batch. When you batch-rename files, you can choose the same settings for all the selected files, saving time.

1 Do one of the following:
   - Select the files that you want to rename.
   - Select a folder in the Folders panel. The new setting will apply to all the files in the folder.

2 Choose Tools > Batch Rename.

3 Set the following options and click Rename:
   - For Destination Folder, select whether you want to place the renamed files in the same folder or in a different folder, move them to another folder, or place a copy in another folder. If you select Move To Other Folder or Copy To Other Folder, click Browse to select the folder.
   - For New Filenames, choose elements from the menus or enter text into the text boxes. The specified elements and text are combined to create the new file name. You can click the + button or - button to add or delete elements. A preview of the new file name appears at the bottom of the dialog box.

Note: If you choose Sequence Number, enter a number. The number is automatically incremented for each file named.

   - Select Preserve Current File Name In XMP Metadata if you want to retain the original file name in the metadata.
   - For Compatibility, select the operating systems with which you want renamed files to be compatible. The current operating system is selected by default, and you can't deselect it.

See also

"About Adobe Bridge" on page 37
“To manage files with Bridge” on page 46

Metadata in Bridge

About metadata

Metadata is information about the file, such as its author, resolution, color space, copyright, and keywords applied to it. You can use metadata to streamline your workflow and organize your files. This information is stored in a standardized way using the Extensible Metadata Platform (XMP) standard on which Adobe Bridge and the Adobe Creative Suite applications are built. XMP is built on XML, and in most cases the information is stored in the file so that it isn't lost. If it is not possible to store the information in the file itself, XMP metadata is stored in a separate file called a sidecar file.

Many of the powerful Bridge features that allow you to organize, search, and keep track of your files and versions depend on XMP metadata in your files. Bridge provides two ways of working with metadata: through the Bridge Metadata panel and through the File Info dialog box. These methods provide different views into the XMP metadata stored in the file. In some cases, multiple views may exist for the same property; for example, a property may be labeled Author in one view and Creator in another, but both refer to the same underlying property. Even if you customize these views for specific workflows, they remain standardized through XMP. The Advanced view in the File Info dialog box displays the fundamental values being stored.
Metadata that is stored in other formats, such as EXIF, IPTC (IIM), GPS, and TIFF, is synchronized and described with XMP so that it can be more easily viewed and managed. Other applications and features (for example, Adobe Version Cue) also use XMP to communicate and store information such as version comments. For instance, when you save a file in Version Cue, you might add the comment that you rotated the file when you worked on it. Later on, you could use Bridge to navigate to that Version Cue project and search for the term “rotate” to locate that file.

In most cases the metadata remains with the file even when the file format changes, for example, from PSD to JPG. Metadata is also retained when those files are placed in an Adobe InDesign layout.

You can use the XMP Software Development Kit to customize the creation, processing, and interchange of metadata. For example, you can use the XMP SDK to add fields to the File Info dialog box. More information on XMP and the XMP SDK is available from the Adobe Solutions Network (www.adobe.com/xmp).

About the Metadata panel in Bridge

From the Metadata panel, you can view and edit the metadata for selected files, use metadata to search for files, and use templates to append and replace metadata. Metadata preserves information about the contents, copyright status, origin, and history of documents. Version Cue uses metadata to manage files.

You can specify the types of metadata displayed in the Metadata panel.

Note: If you have applied metadata to an Adobe Acrobat PDF file, some keywords may not appear; however, these keywords are still attached to the PDF file.

Depending on the selected file, the following types of metadata appear in the Bridge Metadata panel:

- **File Properties**  Describes the characteristics of the file, including the size, creation date, and modification date.
- **IPTC Core**  Displays editable metadata. You can add captions to your files as well as copyright information. IPTC Core is a new specification that was approved by IPTC (International Press Telecommunications Council) in October 2004. It differs from the older IPTC (IIM, legacy) in that new properties have been added, some property names have changed, and some properties have been deleted. You can display the older IPTC (IIM, legacy) metadata by selecting it from the Metadata options in the Preferences dialog box.
- **IPTC (IIM, legacy)**  Displays editable metadata. As with IPTC Core, you can add captions to your files as well as copyright information. This set of metadata is hidden by default, because it has been superseded by IPTC Core. However, you can choose it by selecting it from the Metadata options in the Preferences dialog box.
- **Fonts**  Lists the fonts used in Adobe InDesign files.
- **Swatches**  List the swatches used in Adobe InDesign files.
- **Camera Data (Exif)**  Displays information assigned by digital cameras. EXIF information includes the camera settings used when the image was taken.
- **GPS**  Displays navigational information from a global positioning system (GPS) available in some digital cameras. Photos without GPS information don’t have GPS metadata.
- **Camera Raw**  Displays settings applied by the Camera Raw plug-in.
- **Edit History**  Keeps a log of changes made to images with Photoshop.
- **Adobe Stock Photos**  Lists information about images obtained from Adobe Stock Photos.
- **Version Cue**  Lists any Version Cue version information about the file.

Note: Depending on the applications you are using, custom panels for various properties may appear here as well.
See also

“To add metadata using the File Info dialog box” on page 56

“To view metadata with Bridge” on page 55

“To specify the metadata displayed in the Metadata panel” on page 56

To view metadata with Bridge

❖ Do any of the following:

• Select one or more files and view the information in the Metadata panel. If you select multiple files, only metadata that is common to the files appears. Use the scroll bars to view hidden categories. Click the triangle to display everything within a category.

   You can change the font size in the panel by choosing Increase Font Size or Decrease Font Size from the panel menu.

• Select one or more files and choose File > File Info. Then, select any of the categories listed on the left.

• Choose View > As Details or View > As Versions And Alternates to display the metadata next to the thumbnails in the content area. This is especially useful for viewing Version Cue files.

• Position the pointer over a thumbnail in the content area. (Metadata appears in a tool tip only if Show Tooltips is selected in General preferences.)

See also

“About Adobe Bridge” on page 37

“To create and close Bridge windows” on page 39

"About the Metadata panel in Bridge” on page 54

To edit metadata with Bridge

1 Click the pencil icon to the far right of the metadata field you want to edit.

2 Type in the text box to edit or add metadata.

3 Press Tab to move through metadata fields.

4 When you have finished editing the metadata, click the Apply button ✔ at the bottom of the Metadata panel. To cancel any changes you've made, click the Cancel button ❌ at the bottom of the panel.

See also

“About the Metadata panel in Bridge” on page 54

“To work with metadata templates in Bridge” on page 57

“To apply metadata templates to files in Bridge” on page 58
To specify the metadata displayed in the Metadata panel

1. Do one of the following:
   - Choose Preferences from the Metadata panel menu.
   - Choose Edit > Preferences (Windows) or Bridge > Preferences (Mac OS), and then click Metadata from the list on the left side of the dialog box.
2. Select the metadata fields that you want to display in the Metadata panel.
3. Select the Hide Empty Fields option if you don't want to view fields with no information in them.
4. Click OK.

See also

“About Adobe Bridge” on page 37
“‘To create and close Bridge windows” on page 39
“About the Metadata panel in Bridge” on page 54

To add metadata using the File Info dialog box

The File Info dialog box displays camera data, other file properties, an edit history, copyright and authorship information (if any), and custom metadata panels (if the application has installed them). You can add metadata directly from the File Info dialog box. If you select multiple files, the dialog box shows where different values exist for a text field. Any information you add to a field is applied to all selected files.

Note: You can also view metadata in the Metadata panel, in certain views in the content area, and by placing the pointer over the thumbnail in the content area.

1. Select one or more files.
2. Choose File > File Info.
3. Select any of the following from the list on the left side of the dialog box:
   - Description lets you enter document information about the file, such as document title, author, description, and keywords that can be used to search for the document. You can also choose text from the menu to the right of the text fields. To specify copyright information, select Copyrighted from the Copyright Status pop-up menu. Then enter the copyright notice string and the URL of the person or company holding the copyright.
   - Categories lets you enter information based on Associated Press categories. You can also choose text from the menu to the right of the text fields. The Categories option appears only if Adobe Photoshop is installed.
   - History displays Adobe Photoshop history log information for images saved with Photoshop. The History option appears only if Adobe Photoshop is installed.
   - Camera Data 1 displays read-only information about the camera and settings used to take the photo, such as make, model, shutter speed, and f-stop. The Camera Data 1 option appears only if Adobe Photoshop is installed.
   - Camera Data 2 lists read-only file information about the photo, including pixel dimensions and resolution. The Camera Data 2 option appears only if Adobe Photoshop is installed.
   - Adobe Stock Photos lists read-only information about images obtained from Adobe Stock Photos.
Origin  Lets you enter file information that is useful for news outlets, including when and where the file was created, transmission information, special instructions for handling the file, and headline information. You can also choose text from the menu to the right of the text fields.

Advanced  Displays fields and structures for storing metadata using namespaces and properties, such as file format and XMP, EXIF, and PDF properties. You can do any of the following with the information listed:

- Click Save to export the metadata to a text (.xmp) file.
- Click Replace to replace the metadata in the existing files with metadata saved in an .xmp file. Values in existing properties are replaced with the new values.
- Click Append to add the metadata in the existing files to metadata saved in an .xmp file. Values in existing properties are not replaced, and new values are appended or inserted where appropriate.
- Click Delete to remove the currently selected Advanced property. You can Shift-click to select multiple properties.

Note: Hold down the Option key to change these commands to Replace All, Append All, and Delete All. These commands then affect all information in the file; that is, EXIF information that is not modifiable by the user, such as the f-stop and the Photoshop file ID information, as well as user-modifiable information, such as document title and keywords. Holding down Option also displays the Reset button to restore the previous settings.

4  Click OK to apply the changes.

See also
“About Adobe Bridge” on page 37
“To create and close Bridge windows” on page 39
“About the Metadata panel in Bridge” on page 54

To work with metadata templates in Bridge
You can modify the metadata in the File Info dialog box and save it as a template for use with other files.

1  Create a new file using an Adobe Creative Suite application. This creates a file without metadata from any other source.
2  Select the file.
3  Choose File > Info.
4  Enter the desired information in the File Info dialog box.
5  Choose any of the following from the menu at the upper right of the File Info dialog box:

- To save the metadata in the File Info dialog box as a template for use with other files, choose Save Metadata Template. Enter a name for the template and click Save.
- To delete an existing metadata template, choose Delete Metadata Template. Choose the template you want to delete from the menu in the dialog box and click Delete.
- To open the folder containing metadata templates, choose Show Templates.
6  Click OK. You can now also apply metadata templates to files with the Append Metadata and Replace Metadata commands in the Tools menu and in the Metadata panel menu.
See also

“About the Metadata panel in Bridge” on page 54

“To apply metadata templates to files in Bridge” on page 58

To apply metadata templates to files in Bridge
After you have saved metadata for one file, you can apply it to others.

1. Select one or more files.
2. Choose either of the following commands from the Metadata panel menu or the Tools menu:
   - Append Metadata, followed by the name of the template. This command applies the template metadata only where no metadata value or property currently exists in the file.
   - Replace Metadata, followed by the name of the template. This command completely replaces any existing metadata in the file with the metadata in the template.

See also

“About the Metadata panel in Bridge” on page 54

“To add metadata using the File Info dialog box” on page 56

To apply keywords to files with Bridge
The Keyword panel lets you create and apply Bridge keywords to files. Keywords can be organized into categories called keyword sets. Using keywords, you identify files based on their content. Later, you can view all files with shared keywords as a group.

Note: Bridge keywords are distinct from XMP keywords created with the File Info dialog box. The latter are displayed in Version Cue files in the “Other Metadata” section of the File Info dialog box.

❖ Do any of the following:
   - To add a keyword to files, select one or more files. In the Keywords panel, click the box next to the name of the keyword you want to add. A check mark appears in the box next to the keyword when it’s added to a file.
   - To add a set of keywords to files, select one or more files. In the Keywords panel, click the box next to the name of the keyword set. A check mark appears in the box next to the keyword set when it’s added to a file.

Create a group of frequently used keywords so that you can apply them as a group.

- To remove keywords from a file, select the file, and then click the box next to the name of the keyword or keyword set that you want to remove.
- To create a new keyword, click the New Keyword button at the bottom of the panel or choose New Keyword from the panel menu. A new default keyword name appears in the panel. To create the new keyword, type over the default name and press Return.
- To create a new keyword set, click the New Keyword Set button at the bottom of the panel or choose New Keyword Set from the panel menu. A new default keyword set name appears in the panel. To create the new keyword set, type over the default name and press Return.
- To rename a keyword or keyword set, select the keyword or keyword set and choose Rename from the panel menu. Then, type over the name in the panel and press Return.
Note: When you rename a keyword, the keyword's name isn't changed in files that currently contain it. The original name stays in the file.

- To move a keyword to a different keyword set, drag the keyword from one set to another.
- To delete a keyword, select the keyword by clicking its name, and then click the Delete Keyword button at the bottom of the panel or choose Delete from the panel menu.

Note: Keywords that you get from other users appear in the Other Keywords category until you recategorize them. To make these keywords permanent in Bridge, select the keyword and then choose Persistent from the context menu.

- To find a file using the keyword, choose Find from the panel menu.

Note: You can't modify keywords in search results for Adobe Stock Photos.

See also

"About Adobe Bridge” on page 37

“To search for files and folders with Bridge” on page 49

Using Version Cue with Bridge

Working with Version Cue in Bridge

Adobe Bridge and Version Cue work together to give you an intuitive way to access and manage Version Cue files and projects.

Bridge provides comprehensive visualization of and centralized command over all aspects of Version Cue files and projects. You can use Bridge to access Version Cue Workspaces, create a project in any of those workspaces, and create a project folder hierarchy. You can drag files into project folders and drag files from a project folder into non-project folders on your hard drive. You can also copy and move files within and between project folders.

The search capabilities of Bridge enable you to locate project files using file information such as version comments, or keywords or fonts contained in your files. You can view files that have been deleted (but not permanently deleted) in projects and you can restore deleted files using Bridge.

Working with versions in Bridge  As you save versions of project files as they evolve, you can use the Versions View in Bridge to see all previous versions of the files, delete previous versions, and promote previous versions. You can get information not only about the current version of a file, but also about the version comment for each previous version without having to open the files in their native applications. However, if you need to view a previous version in more detail, you can use Bridge and Version Cue to open that version. You can view Version Cue file info
(metadata) in the Details view, Versions And Alternates view, in tooltips, and in the Metadata panel. Bridge is instrumental in helping you create and track versions of non-Adobe file types that are in the projects in your Version Cue Workspace. When you use Bridge to open a file in a project, you can create a Version Cue version even if an application doesn’t have a Save A Version command. You can manage and use those versions as you would if they were created from files made by Adobe Creative Suite components.

**Working with alternates in Bridge** Bridge also makes it easy to work with Version Cue alternates. You can use Bridge to designate files as alternates of each other, or to generate alternates from previous versions of a file. In the Alternates view, you can see the complete group of alternates that have been designated for a project file as well as which of these alternates is the primary (preferred) member of the group. A file’s inclusion in a group of alternates is indicated by an icon in all Bridge views as well as by text indications in the Details and Versions And Alternates views. Alternates don’t have to be located within a single folder, and you can use Bridge to add files to an alternates group no matter where they are located in a project. In Alternates View, it’s easy to navigate to the folders that contain alternates. You can remove files from a group of alternates as well as dissolve the group completely in Bridge.

**Viewing Workspace, project, and file information** Because you may not always be connected to the network on which a particular Version Cue Workspace is located, Bridge indicates the availability of the workspaces and projects you’ve accessed by displaying different icons of workspaces and projects. When your Version Cue Workspace is online, you can view up-to-date status for all files you’ve created with Adobe Creative Suite components. This helps you understand whether a file is already in use, or whether another user has created a newer version. Normally, when you start editing a project file in a Version Cue Workspace, the file’s status changes to In Use because you’re making changes to the file. However, you can use Bridge to mark a file In Use without having to open the file. You can cancel the Mark In Use indication at any time. You can also use Mark In Use to prepare project files for offline editing when you know you’ll be disconnected from a remote Version Cue Workspace. When you come back online, you can use Bridge to synchronize your files with your workspace once the workspace is available again. For more information about working with Version Cue, see “Adobe Version Cue” in Help.

**Version Cue Workspace and project icons in Bridge** Bridge displays status icons for Version Cue Workspaces and projects to let you know if they’re available, shared, local, or remote.

- Available and Not Shared Indicates a project that’s available and not shared with other users.
- Available and Shared Indicates a project that’s available and shared with other users.
- Local Files Only Indicates a project that contains only local files.
- Workspace Not Available Indicates a workspace that’s offline.
- Workspace On Own Hard Drive Indicates a workspace that’s local to your computer.
- Remote Workspace Online Indicates a remote workspace that’s available.
Chapter 5: Adobe Stock Photos

Adobe Stock Photos

About Adobe Stock Photos
Welcome to Adobe Stock Photos, the newest way to view, try, and buy royalty-free images from leading stock libraries. With Adobe Stock Photos, you won’t have to interrupt your design process to find quality images. Instead, from inside your favorite applications, you can use the powerful search capabilities of Adobe Stock Photos to find and download images.

From Bridge, the Favorites pane gives you quick access to these stock images. With your computer connected to the Internet, simply click the Adobe Stock Photos icon to start browsing thousands of available images. Because of the tight integration between Stock Photos and Adobe Creative Suite components, you can download images from Adobe Stock Photos directly into your Illustrator, InDesign, and GoLive projects. From Photoshop, you can open any downloaded image.

In the design process, you need the flexibility to try different images before deciding which one you want. Adobe Stock Photos gives you the option to download low-resolution, complementary (comp) versions of images you’re considering. You can work with the comps until you make your final decision, at which point you can purchase and download a high-resolution image.

For maximum convenience, you can open an account with Adobe. The benefit of opening an account is that you enter your personal information only once, greatly simplifying the checkout process. You can also look back at previous purchases, and even download photos again after you purchase them.

See also
“About comp images” on page 64
“Benefits of Stock Photos accounts” on page 67
“Buying stock photos” on page 65

Searching for images in Adobe Stock Photos
There are a few ways to search for images in Stock Photos. If you need help getting a project started, a broad search may yield a fund of possibilities and suggest areas to explore. If you have a clear idea of what you need, then you can use Advanced Search to narrow the field.

Related keywords also help you find photos. After you find photos, you can start a new search by selecting one or more related keywords. Each image is associated with keywords that help you find similar images. The more keywords you select, the narrower the search results.

Photos matching the search criteria appear as thumbnails in the main window. You can resize the thumbnail by dragging the Thumbnail slider at the bottom of the screen. When you click an image in search results, a comp image appears in the Preview pane (it may take several seconds for the image to appear in the pane). To enlarge the comp, simply resize the Preview pane. You can view metadata information about the image in the Metadata pane under Adobe Stock Photos Metadata.
Your previous searches are automatically saved in Stock Photos in the Favorites pane. Click Previous Searches to display the list. To see the search results, double-click a search. To delete a search, select it and press the Delete key (Windows), right-click the search and then choose Send To Recycle Bin (Windows), or Control-click the search and choose Move To Trash (Mac OS).

All thumbnails from recent searches are saved on your computer. Having the thumbnails available offline is helpful if you want to browse through the images when your computer isn’t connected to the Internet. However, the thumbnails do take up some space on your hard drive. At some point, if you want to delete these thumbnails, delete the searches (as described above), or remove them manually from the default file location: My Documents/AdobeStockPhotos/Previous Searches (Windows), or Documents/AdobeStockPhotos/Previous Searches (Mac OS).

See also
“To adjust the Bridge window” on page 40
“To view file and folder thumbnails in Bridge” on page 43

To search for stock photos
1 In Bridge, click Adobe Stock Photos in the Favorites pane.
2 In the text box at the top of the screen, type the word or phrase that describes the subject of the photos you want to search for.
3 Click the Search button or press Enter.

Images matching the search criteria are displayed in batches. (There is a preference for changing the number of images displayed in a batch.) To view more images, click More Results. Click a photo to view more information, such as its price and keywords associated with it.

See also
“Search tips” on page 63
“To view image price and keywords” on page 63

To use Advanced Search
Advanced Search is a powerful tool that helps you find exactly the right photo. You can combine several search criteria to narrow your results.

1 In Bridge, click Adobe Stock Photos in the Favorites pane.
2 Click the Advanced Search button .
3 Search using any combination of the following options:
   • Type a descriptive keyword or keywords in the text box to find related images. Alternatively, type an image ID, if you know the ID of the photo you want to use.
   • To restrict searches to a specific media type, choose one or more options under Media Types.
   • To search by the orientation of the photo, select the acceptable shapes under Orientation.
   • Select the name of one or more providers to limit the search.
4 Click the Search button to display images matching the search criteria.
To search with related keywords
1 In Bridge, click Adobe Stock Photos from the Favorites pane.
2 In the text box at the top of the screen, type the word or phrase that describes the subject of the photos you want to search for.
3 In the search results, click a photo to select it.
4 Do one of the following:
   • Click the Get Price & Keywords button.
   • Right-click the image (Windows) and choose Get Price & Keywords from the menu.
5 When the Price & Keywords dialog box appears, select keywords under Keywords For This Image. The more keywords you select, the narrower the search.
6 When you finish selecting keywords, click the Search Again button to begin a new search using the keywords.

To view image price and keywords
You can view size and price information, as well as related keywords, in the Image Detail dialog box.
1 In the search results window, click an image to select it.
2 Do one of the following:
   • Click the Get Price & Keywords button.
   • Right-click the image (Windows) and choose Get Price & Keywords from the menu.
3 To close the dialog box, click the Close button.

Note: The currency displayed in the Price & Keywords dialog box may not be the native currency of your billing country; it is the supported currency for purchases made from your country. When you purchase photos from Adobe Stock Photos, your credit card will be billed in the supported currency.

Search tips
Here are some helpful pointers for refining your searches:

Misspelled words Double-check your search entries to make sure they’re spelled correctly.

Trademarked names Brand names may not return full search results. Instead, search for the item by its general name.

Exact phrase searches To view images that exactly match a phrase, type the whole phrase in the Search text box. You can enter Boolean operators such AND, OR, or NOT to narrow your search.

Search by subject To search for a specific subject, use nouns that describe the main subject of a photo, such as “bicycle” or “house,” as well as adjectives that modify the nouns, such as “vintage” or “red.” To narrow the search further, use verbs that describe an action in the photo.
Search by concept  Try searching with concepts, or perceptions, such as “romance,” “vitality,” “frustration,” or “excitement,” to find an inspiring image.

Search by style  To find photos that reflect a specific photographic or artistic technique, try searching on terms such as “profile,” “studio shot,” or “clipping path.”

Comp images

About comp images
Comp images are free, nonwatermarked, low-resolution versions of stock photos that you can download to use in mock-ups or other preliminary work. You can use comps to capture a feeling, idea, or concept before choosing the final image for a project. Comps are not licensed for production, but you can use them in mock-ups or other preliminary work. Because comps are low-resolution images, they’re not suitable for printing or publishing. After an evaluation period, you can purchase a high-resolution version of the image to continue working with the photo.

Metadata is bundled with comp images. This metadata is read by Photoshop, InDesign, Illustrator, and GoLive, and is used in each application to recognize images as stock photos, even if you rename them. Metadata allows you to purchase high-resolution versions of images later, even after you move a comp to a project folder or create other versions of the image. If you are about to send the photo to be printed, InDesign and Illustrator display a warning that you are using a comp image.

You can view your downloaded comps by clicking Downloaded Comps in the Favorites pane, or you can navigate to the default folder where comps are saved: My Documents/AdobeStockPhotos (Windows) or Documents/AdobeStockPhotos (Mac OS). You can move downloaded comps to any folder you want. To delete a comp in the Stock Photos window, right-click it and then choose Send To Recycle Bin (Windows) or Control-click it and choose Move To Trash (Mac OS).

For more information on using comps, see the terms of service (TOS), which describe when and for how long you can use a comp. A Terms Of Service link is available on the main Adobe Stock Photos screen.

To download comps from Adobe Stock Photos
1  In the search results, click a photo to select it.
2  Do one of the following:
   • Click the Download Comp button.
   • Right-click the photo (Windows) and select Download Comp from the menu.
   • Click Get Prices & Keywords and select Free Comp Image in the dialog box. Click the icon to download the comp.

To view comps in an Adobe Creative Suite application
From Adobe Stock Photos, you can open and edit a comp in Photoshop, Illustrator, InDesign, or GoLive. You can also drag a comp into an application.
1  In the search results window, right-click the image you want to open.
2  In the context menu, position the pointer over Open With, and then choose the name of the application in which you want to view a comp version of the image.
To view saved comps in Stock Photos
To help you keep track of downloaded comps, you can view them in Bridge. If you decide to purchase a comp, put the comp in your shopping cart.

1. In the Favorites pane, click Adobe Stock Photos.
2. Click Downloaded Comps to see the comps.

Buying stock photos

Buying stock photos
It's simple to buy images through Adobe Stock Photos. When you find the photos you want to buy, put them in your shopping cart. The photos remain in your cart until you're ready to complete your purchase. When you finish browsing, you can check out and have your images automatically downloaded to your computer.

Having an account with Adobe speeds the checkout process. Because your contact and billing information is saved, you can complete your purchase with just a few clicks.

Adobe Stock Photos maintains a secure site, and you can rest assured that your personal information is kept in strict confidence. Any information you enter is used only for Adobe Stock Photos purposes.

To view your photos, click Purchased Images in the Favorites pane, or navigate to the default Stock Photos folder: My Documents/AdobeStockPhotos (Windows) or Documents/AdobeStockPhotos (Mac OS).

See also
“To buy photos” on page 65
“To buy photos directly from InDesign or Illustrator” on page 66

To place photos in the shopping cart
As you find photos you want to purchase, add them to the shopping cart until you're ready to check out.

1. In the search results window, right-click a photo, and then choose Add To Cart from the context menu. You see a dialog box confirming that the photo is your shopping cart.
2. Click OK to continue, or click View Shopping Cart to see the contents of your cart.
If you want to disable this dialog box, select Don't Show Again.

To buy photos
1. To access your shopping cart, click the Shopping Cart icon.
2. Choose a resolution for the photos you want to buy. (You can remove an item from the shopping cart at any time by clicking the Delete icon X.)
3. Click Check Out.
4 Do one of the following:
   • If you have an Adobe account, enter your ID and password.
   • If you want to open an Adobe account, click Set Up An Account. You are prompted to enter your billing and
     account information.
   • If you want to buy the images without an account, click Continue As Guest. You are prompted to enter your billing
     information. Click Continue.

5 Do one of the following:
   • If you have an Adobe account, confirm your billing information and click Continue.
   • If you don't have an Adobe account, enter your billing information and click Continue.

6 In the Order Summary page, confirm your choices. To delete a photo from the shopping cart, click the Delete icon.

7 If you have a promotion code, enter it in the Promotion Code text box and click Apply. You see any changes made
to your order as a result of applying the promotion code.

8 Click the check box to accept the terms of the Adobe Stock Photos License Agreement (click the blue text to read
the agreement).

9 Finally, click the Purchase Now button to complete the checkout process. Your purchase is processed, then you're
prompted to download your photos.

10 Click Start Download. After the photos are saved, click View Purchased Images if you want to start working with
them right away.

11 To view the receipt for your purchase, in the Thank You page click View Receipt. You can also monitor the
progress of the download by clicking Open Download Status. When you finish, click Find More Images if you want
to find new photos, or click Go To Your Account.

If you have been working with a comp version of the image you purchased, you need to replace the comp with the
high-resolution image in your art.

Note: To delete the list of high-resolution images waiting for download from the Download Status screen, choose Edit >
Preferences (Windows) or Bridge > Preferences (Mac OS). Select Adobe Stock Photos, and then click the Clear Now
button.

See also
“To create a Stock Photos account” on page 67
“To set Adobe Stock Photos preferences” on page 70

To buy photos directly from InDesign or Illustrator
To seamlessly integrate Adobe Stock Photos into your design process, you can use the Place command to use
downloaded comps in your work. When you're ready to purchase a photo, you can start the process from InDesign
or Illustrator. Then, you can use the Links palette to replace the comp with the full image.

1 In Illustrator or InDesign, right-click a comp image and then choose Purchase This Image from the menu.

2 Adobe Stock Photos starts, and the photo is automatically placed in your shopping cart.

3 After purchasing the image, return to Illustrator or InDesign, and then click Re-link in the Links palette.
4 Navigate to the Purchased Images folder in the Adobe Stock Photos folder: My Documents/AdobeStockPhotos (Windows), or Documents/AdobeStockPhotos (Mac OS).

5 Select the purchased image and then click OK. The comp is replaced with the full version of the photo.

**To view order details**
A benefit of having an Adobe account is that you can go back and view your previous orders.

1 In Adobe Stock Photos, click the Your Account button.

2 In the Your Account page, click View Order History.

3 The Your Order History page shows all of your previous orders. To view details about a particular order, click the order number (highlighted in blue).

4 In the Order Detail page, you can see the billing information, as well as a description of the photos you purchased. Click Return To Your Account if you're done, or click Return To Order History if you want to review other orders. You can also redownload the photos you purchased.

**Stock Photos accounts**

**Benefits of Stock Photos accounts**
Creating an Adobe account makes purchasing photos quick and easy. When you log in with your e-mail address and password, you can work with your account in several ways:

**Manage your profile** After you complete the registration process, modify your account information anytime by clicking the Your Account link in the navigation bar.

**See your order history** Track orders made through Adobe Creative Suite Stock Photos to check the specific items ordered, the total cost of the purchase, or the order date.

**Download previously purchased items again** Access your order history and click Re-download to replace a lost or corrupted file for up to one year from the original purchase date.

**Shop with ease** Purchase photos without providing profile information. Adobe Stock Photos automatically enters your name and address when you make any purchases. All your personal information is securely stored.

**To create a Stock Photos account**
1 In Adobe Stock Photos, do one of the following:
   - Click the Your Account button, and then click the Continue button under Set Up An Account.
   - If you have photos in the shopping cart, click the Shopping Cart icon, and then click Checkout. Click Set Up An Account.

2 If you haven't chosen your billing country, you see a dialog box with a list of countries. Choose the country of your billing address and click Continue.

3 In the text boxes, type your e-mail address and choose a password (at least six characters long and containing a mix of letters and numbers).
4. Enter your billing address, and then type your payment information. The billing address must exactly match the address where your credit card statements are mailed.

5. When you finish, click Continue.

After you create your account, Adobe Stock Photos sends a confirmation e-mail to the address you entered.

**To log into your Stock Photos Account**

1. In Adobe Stock Photos, click the Your Account button.

2. When prompted, type your e-mail address and password, and then click Continue. If your login is successful, the Your Account page appears.

If you're having trouble logging into your account, make sure that you have spelled your e-mail address and password correctly. Also make sure that you haven't pressed the Caps Lock or Number Lock keys.

**To edit your Stock Photos account profile**

Your account profile includes your name and password settings.

1. Click the Your Account button.

2. Log into your account.

3. In the Your Account page, click Edit Your Profile. Do any of the following:

   - To change your password, type a new word in the Password text box. Passwords can contain only letters and numbers and must be at least six characters long.
   - To sign up to get e-mail from Adobe Stock Photos about promotions or other special information, select the check box.

4. To confirm your changes, click Save. To go back to the main Your Account page without saving changes, click Return To Your Account.

**To change Stock Photos account address information**

You can change your default billing address or add other addresses. Make sure that any new addresses match the address on your credit card billing statements exactly to avoid any problems.

1. Click the Your Account button.

2. Log into your account.

3. In the Your Account page, click Edit Your Address.
4 Do any of the following:

- To change the nickname associated with the default address, type a new name in the Billing Address Nickname text box.
- Type any changes to the default address in the text boxes.
- To add a new address to your account, click Add New Address, and then enter the information in the text boxes.
- To edit a non-default address, click Edit under the address, and make any changes.
- To make an address the default, click Set Default under the address.
- To delete an address, click Delete under the address.

5 To confirm your changes, click Save. To go back to the main Your Account page without saving changes, click Return To Your Account.

**To change Stock Photos account payment information**

You can change your saved credit card information, or add additional credit cards. Enter your credit card number without spaces or dashes. You can give each credit card a nickname to keep track of which card you're using.

1 Click the Your Account button.
2 Log into your account.
3 In the Your Account page, click Edit Your Payment Information.
4 Do any of the following:
   - To change the nickname of the default credit card, type a new name in the Payment Nickname text box.
   - To change the default credit card number, type the new number in the Credit Card Number text box, and then choose the expiration date for the new card from the month and year menus.
   - To add a new card to your account, click Add New Payment Method, and then type a nickname and the card number. Enter the expiration date.
   - To delete a payment method, click Delete under the payment nickname.
5 To confirm your changes, click Save. To go back to the main Your Account page without saving changes, click Return To Your Account.

**To download previously purchased images from Stock Photos**

To download images, you need to have a Stock Photos Account. You can download images onto a different computer than the one you used to purchase the photos originally (see the license agreement for information about restrictions).

1 Click the Your Account button.
2 In the Your Account page, click View Order History.
3 In the Your Order History page, click the order number (highlighted in blue) of the photo you want to download again.
4 In the Order Detail page, click the arrow under Download. The photo is downloaded. By default, purchased images are located at My Documents/AdobeStockPhotos/PurchasedItems (Windows) or Documents/AdobeStockPhotos/PurchasedItems (Mac OS).
To set Adobe Stock Photos preferences

1. In Adobe Bridge, choose Edit > Preferences (Windows) or Bridge > Preferences (Mac OS).
2. Select Adobe Stock Photos from the list on the left.
3. Set any of the following preferences, and then click Save:

   **Thumbnails displayed per group** To set how many thumbnail images are displayed in a search group, choose an option from the Thumbnails Per Search Group menu.

   **Search language** To search using a different language, select the language from the Search Language menu. Note that you get the best results from most providers if you search in English. This setting doesn’t affect the interface display language.

   **Destination folder for downloads** To select a new default folder in which to store photos, downloaded comps, and purchased photos, click Change Location. Click Reset to restore the default location.

   **Billing Country** To change your default billing country, choose the name of the country from the Billing Country menu. The currency displayed next to the Billing Country menu may not be the native currency of that country (not all currencies are supported). Instead, it’s the currency Adobe allows for that country. Your credit card is billed in the supported currency.

   **Alert messages** To enable or disable the messages that appear when you download a comp or add a photo to your shopping cart, select or deselect Display Message After Downloading Comp or Display Message After Adding Image To Shopping Cart.

   **Automatic downloading to default folder** To save your photos automatically to your default folder, select Auto-Download Images After Purchasing Them. Deselect this option if you want to choose a location in which to save the photos (for example, in a Version Cue project or other project-specific folder on your computer).

   **Downloading after lost connection** To resume downloading automatically after a connection is lost, select Resume Interrupted Downloads When Bridge Starts.
Chapter 6: Adobe Version Cue

Using Adobe Version Cue

Version Cue managed projects
Adobe Version Cue® is an innovative set of features designed to increase your productivity when you work alone or collaborate with others. Version Cue integrates design management into your existing workflows within and across Adobe Creative Suite components, including Adobe Photoshop CS2, Adobe InDesign CS2, Adobe Illustrator CS2, Adobe GoLive CS2, Adobe Acrobat 7, and Adobe Bridge. You can also work with Version Cue in Adobe InCopy CS2.

Version Cue streamlines the following tasks in Adobe Creative Suite:
- Creating historical versions and branched alternates of your files.
- Maintaining file security.
- Organizing files into private or shared projects.
- Browsing with file thumbnails, and searching file information and version comments.
- Reviewing file information, comments, and file status in private and shared projects while you browse.

In addition, you can use the Version Cue Workspace Administration for more advanced tasks:
- Initiating and managing online reviews of PDF documents.
- Duplicating, exporting, backing up, and restoring projects.
- Viewing information about projects in the Version Cue Workspace.
- Importing files to the Version Cue Workspace using FTP or WebDAV.
- Deleting file versions in batches and removing file locks.
- Creating a roster of project users and defining their project privileges.
- Restricting access to a specific project.

See also
"Availability of Version Cue features” on page 71

Availability of Version Cue features
Different Version Cue features are available in different environments:
- If you use Adobe Creative Suite, you have access to the full set of Version Cue features, including Version Cue Administration.
- If you use only one component of Adobe Creative Suite, or if you use InCopy and not Adobe Creative Suite, you have access to the features of the Adobe dialog box only. You can use Bridge, rather than the Adobe dialog box, for file browsing.
Note: Acrobat 7 and GoLive access Version Cue features differently than other Adobe Creative Suite components and don't use the Adobe dialog box.

- If you don't have Adobe Creative Suite, you can gain access to the full Version Cue feature set by participating in a shared project; that is, if another user on your network installs Adobe Creative Suite and gives you access to a Version Cue project in a Version Cue Workspace.

See also
“About the Adobe dialog box” on page 73
“Getting the most out of Version Cue” on page 72

Getting the most out of Version Cue

In Version Cue, you create projects that you and other users access through Adobe Creative Suite components. Projects keep related files together in one place. Version Cue manages the files in these projects. Because Version Cue works in all Adobe Creative Suite components, your design process isn't interrupted when you work on individual files within a project.

You can use Version Cue in a single application, such as Photoshop CS2, to track changes to a file as you work on it. In addition, workgroups or an individual worker can use Version Cue across applications. Multiple users can manage projects that contain files from all Adobe Creative Suite components. Projects can include non-Adobe files, such as text documents, billing forms, or spreadsheets. When you keep all managed files related to a project in one place, you eliminate the task of tracking down important files.

Here's an example of how you might use Version Cue with Adobe Creative Suite: You start by creating a new project and adding a Photoshop file containing the main image for a printed piece. Then, you add art from Illustrator and text from InDesign. Next, you add GoLive web elements to leverage your printed content for use in a web page. As you and your team work on each piece of the project, Version Cue creates versions to keep track of changes. When it's time to present the project, you create a PDF of each project file and use the Version Cue Administration utility to set up an online PDF review. Your customers, supervisors, or peer reviewers view and comment on the project using Acrobat.

Working with Version Cue in GoLive

Version Cue is tightly integrated with GoLive to manage the tasks specific to web page creation. Although you access Version Cue differently in GoLive than in Photoshop, Illustrator, InCopy, and InDesign, most of the same features are available.

Working with Version Cue in Acrobat

You access Version Cue from within Acrobat 7 much as you do in the other Adobe Creative Suite components; however, there are some differences. Most Version Cue features are available in Acrobat 7. For more information on using Version Cue in Acrobat 7, see Acrobat 7 Help.

See also
“Creating or opening Version Cue projects” on page 113
“Availability of Version Cue features” on page 71
About the Adobe dialog box

In Adobe Creative Suite 2.0 components (except for GoLive and Acrobat 7) and InCopy CS2, you can use the Adobe dialog box when you choose the Open, Import, Export, Place, Save, or Save As commands, even if you don’t use Version Cue. The Adobe dialog box displays additional information, including thumbnails, which make it easy to identify files. You can use the Adobe dialog box when working with both Adobe and non-Adobe files.

*Note:* In InDesign, if you deselect *Always Save Preview Images With Documents* in either the File Handling preferences or the Save As dialog box, you won’t see thumbnails for InDesign files in the Adobe dialog box or in Bridge.

By default, when you choose the Open, Import, Export, Place, Save, or Save As commands, the operating system (OS) dialog box appears. To use the Adobe dialog box instead and set it as the default, click Use Adobe Dialog. Use the View menu options to customize the display. You can change back to the OS dialog box at any time by clicking Use OS Dialog.

You can use the Adobe dialog box to accomplish these tasks:

- Add frequently used files and folders to the Favorites panel for quick access.
- View thumbnail images of files.
- Determine whether a file is open in another Adobe Creative Suite application on your computer.
- Rename or delete files (Mac OS only).
- Connect to Bridge by using the Reveal In Bridge command.
- View metadata about files in the Properties panel. Metadata includes author, keyword, and copyright information.
- Access Version Cue projects and files as well as non-Version Cue files.
- View detailed information about Version Cue projects, such as the status of individual files.
- View and work with Version Cue versions and alternates.
- Search for files in a Version Cue project.
- Move Version Cue files to the Project Trash.
- Determine which Version Cue files are in use, and who is using them.
- Create a new Version Cue project, or connect to an existing Version Cue project.
See also

“To view Version Cue Workspace, project, and file information” on page 79

“Availability of Version Cue features” on page 71

What’s new in Version Cue CS2

In addition to enhanced performance and reliability, here are some key new features in Version Cue CS2:

Integration with Adobe Bridge View Version Cue projects, work with versions, and make groups of alternates, all from one central place. From Bridge, you can search for and view all Version Cue files without opening individual Adobe Creative Suite components. You can manipulate files directly in Bridge to avoid delays as files open or as the components start up.

Alternates Alternates allow you to leverage an asset and take your designs in a different direction. For example, if you want to radically transform a photo that is currently used in a project, but you don’t want to alter the original, you can create an alternate and work with it instead. Use alternates, in addition to versions, to manage your assets. See “About Version Cue alternates” on page 106.

Version Cue PDF Review Host online PDF reviews from your own computer or another Version Cue Workspace. You can include in the review any PDF file in the project, and use the Automatic e-mail generation to quickly invite users to the review. Review comments are collected in the Version Cue Workspace where all reviewers can see and reference them as the review progresses.

Ability to manage non-Adobe files Store non-Adobe files, such as text documents, schedule spreadsheets, and billing forms, in a Version Cue project. You can also create versions of non-Adobe files. See “To save a version of a non-Adobe file” on page 102.

See also

“Initiating a Version Cue PDF review” on page 140

“Availability of Version Cue features” on page 71

“Working with Version Cue in Bridge” on page 59

To set Version Cue Workspace preferences

Note: You can perform this task only if you have access to the full Version Cue feature set, which is available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

Use Version Cue preferences to turn Version Cue off (it is on by default), specify Version Cue Workspace settings, choose the locations of Version Cue folders that hold data and backup files, export projects in your workspace, and check for updates to Version Cue.

1 Do one of the following to access Version Cue CS2 preferences:
   - In Windows, double-click the Version Cue icon in the system tray at the bottom right of the screen.
   - In Mac OS, click the Version Cue icon in the menu bar at the top of the screen and choose Version Cue CS2 Preferences from the menu.

2 Choose an option from the Version Cue CS2 menu. Choose On to turn on the Version Cue Workspace, or Off to turn the workspace off.

3 To automatically turn on Version Cue when the computer starts (recommended), select Turn Version Cue CS2 On When The Computer Starts.
4 Choose one of the following from the Workspace Access menu:

This Workspace Is Visible To Others  Gives others access to your shared Version Cue projects.

This Workspace Is Private  Keeps your Version Cue Workspace hidden from other users.

Note: If Version Cue is installed on a computer that uses a firewall and you want to share the workspace with others, make sure that TCP ports 3703 and 427 are left open and deselect the Internet Connection Firewall option (Windows only). For information, see Windows Help.

5 In the Settings tab, do any of the following:

- From the Workgroup Size menu, choose the number of people who use the Version Cue Workspace on a typical day. This setting controls how the workspace handles the potential load.

- From the Optimize For menu, choose the type of project you generally create. By default, this option is set to Mixed Media, to support workflows that involve both print media (such as InDesign files) and web content (created in GoLive). If you typically produce only print media, or if you create only web content, choose either Print Media or Web Media from the Optimize menu.

- In the Memory Usage text box, enter the amount of RAM that you want to make available to Version Cue. The default is 128 MB. This setting allocates RAM to optimize interoperability between Version Cue and Adobe Creative Suite components. For more robust requirements, such as a larger workgroup or many assets, set the RAM to 256 MB or higher.

6 Select Show Version Cue CS2 Tray Icon (Windows) or Show Version Cue CS2 Status In Menu Bar (Mac OS) to keep the Version Cue menu icon visible, giving you quick access to Version Cue Administration and preferences.

7 Click the Locations tab and do one of the following:

- To move the Data folder, where projects, file versions, and user IDs are stored, click the Choose button next to the current folder location. Select a new location (not a network drive) for the folder. You must choose a location on the computer in which the Version Cue Workspace is installed. Click OK.

- To move the Backup folder, where project backups are stored, click the Choose button next to the current folder location. Select a new location for the folder. You must choose a location on the computer in which the Version Cue Workspace is installed. Click OK.

Important: The workspace must be turned off before you change the folder locations. Do not attempt to move these folders manually or edit any of the files in the Version Cue Data folder. The Data folder contains files that maintain the integrity of the Version Cue file versions, metadata, and project information.

8 To export workspace data, click the Export tab, choose an export version and a location for the exported data, and then click Export.

9 Click the Updates tab, and then click Check For Updates to see whether any updates are available online. If so, you're prompted to install the updates.

10 Click OK (Windows) or Apply Now (Mac OS).

If prompted, click Yes (Windows) or Restart (Mac OS) to restart the Version Cue Workspace. (If Version Cue was running when you changed the settings, you are prompted to restart.)

See also

“To export a Version Cue project to your computer” on page 132
To turn Version Cue on or off

By default, access to Version Cue is turned on in InCopy CS2 and in all Adobe Creative Suite components, except for Acrobat 7. If you disable Version Cue, you won’t have access to any Version Cue Workspace, which could affect files in a project. If you disable or enable Version Cue in any Adobe Creative Suite component, that change affects all other Adobe Creative Suite components except Acrobat 7 (you must always enable or disable Version Cue manually in Acrobat 7), Bridge, and GoLive (Version Cue is always enabled in Bridge and GoLive), and the Version Cue Workspace (this is controlled through the Version Cue CS 2 preferences).

Photoshop CS2  Choose Edit > Preferences > File Handling (Windows) or Photoshop > Preferences > File Handling (Mac OS). Then select or deselect Enable Version Cue Workgroup File Management, and click OK.

Illustrator CS2  Choose Edit > Preferences > File Handling & Clipboard (Windows) or Illustrator > Preferences > File Handling & Clipboard (Mac OS). Then select or deselect Enable Version Cue, and click OK.

InDesign CS2  Choose Edit > Preferences > File Handling (Windows) or InDesign > Preferences > File Handling (Mac OS). Then select or deselect Enable Version Cue, and click OK.

InCopy CS2  Choose Edit > Preferences > File Handling (Windows) or InCopy > Preferences > File Handling (Mac OS). Then select or deselect Enable Version Cue, and click OK.

Acrobat 7  You must manually turn Version Cue on in Acrobat 7 to use it. Choose Edit > Preferences > General (Windows) or Acrobat > Preferences > General (Mac OS). Then select or deselect Enable Version Cue Workgroup File Management.

Bridge  Version Cue is always turned on in Bridge.

GoLive  Version Cue is always turned on in GoLive.

See also

“Availability of Version Cue features” on page 71

Working with Version Cue projects

About Version Cue projects

Version Cue uses projects to store related files and folders. If you work independently, you create a project to gather all the files you need, view the files in Bridge, and use Version Cue features such as versions and alternates. In a workgroup, depending on your workflow, you can create one Version Cue project for files that everyone in your workgroup collaborates on, a different project for files that don't require collaboration, and yet another project restricted to specific users.

When you first open a Version Cue project, Version Cue creates a folder named “Version Cue” in your My Documents (Windows) or Documents (Mac OS) folder, and adds a folder for the project to it. When you open a file from that project, Version Cue adds a working copy of the file to the project folder. As you edit and save intermediate changes to your file, you are actually editing in the working copy; the original file on the Version Cue Workspace is protected.

After you open a Version Cue project, a shortcut to that project appears in the list with other Version Cue Workspaces in Bridge, or in the Open, Place, or Save dialog boxes. Remote Version Cue Workspaces also appear in this list after you access them.
Version Cue uses a special folder for each project: the *documents* folder. This folder is where Version Cue stores non-GoLive files for each project. When you access the project from Bridge, InCopy, or any Adobe Creative Suite component except Acrobat 7, Version Cue automatically opens the documents folder and temporarily displays the project title as the folder name. (If you access the project using Acrobat 7, the folder is named “documents”.) You’ll also see the documents folder if you open the working copies folder.

If you create a new Version Cue project from GoLive, or if you add a new or existing website to a project, Version Cue creates three additional folders for that project:

**Web-content folder** Contains the home page (index.html) as well as any website content, including pages, images, styles, and scripts. You can create separate Pages, Images, and Styles subfolders if necessary. Any files or folders uploaded to a production server should be stored in the web-content folder. Because GoLive uses this folder to manage a site as it’s created, be careful not to store other types of files in this folder. You can create any type and number of subfolders in the web-content folder.

**Web-data folder** Stores different types of reusable site objects, such as Smart Objects, components, and templates. This folder contains data used to create the final site. To avoid broken links, missing styles, and similar problems, never store final website content in the web-data folder.

**Web-settings folder** Stores only the saved settings in the GoLive Site Window and Site Settings dialog boxes.

To open a project

*Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.*

1 Do one of the following:

- In Illustrator, InCopy, InDesign, or Photoshop choose File > Open. If the button is visible, click Use Adobe Dialog (if you see the Use OS Dialog button, you are already using the Adobe dialog box). Click Version Cue in the Favorites panel.
- In Bridge, click Version Cue in the Favorites panel. Double-click Workspaces to view all available workspaces.
- In Acrobat 7, choose File > Open. Click Version Cue.
2 To open a Version Cue Workspace, double-click it.

Note: If you don’t see a desired Version Cue Workspace, choose Refresh from the Tools menu.

3 To open a project, double-click it.

Note: If the Use Adobe Dialog button doesn’t appear in the Open, Save As, Save A Copy, or Place dialog boxes, make sure that you’ve turned on the Version Cue preference in InCopy or in the Adobe Creative Suite component you’re using.

See also

“About the Adobe dialog box” on page 73

“To connect to a remote project” on page 78

“Adding files and folders to a project” on page 89

“To set Version Cue Workspace preferences” on page 74

To connect to a remote project

Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

When you need to work on Version Cue projects that are located remotely, on a different subnet, you can use the IP address of the computer to access that Version Cue Workspace. Workspaces on computers within your subnet should be visible automatically.

1 Do one of the following:
   - In Illustrator, InCopy, InDesign, or Photoshop, choose File > Open. If you are using the OS Dialog box, click Use Adobe Dialog. Click Version Cue in the Favorites panel. Choose Connect To from the Project Tools menu.
   - In Bridge, choose Tools > Version Cue > Connect To.
   - In Acrobat, choose File > Open. Click Version Cue. Choose Connect To from the Project Tools menu.
2 In the Connect To dialog box, enter the Version Cue Client URL (the Version Cue IP or DNS address), a colon, and the port number (3703), for example, http://153.32.235.230:3703. If you have connected to the workspace before, it’s not necessary to enter the port number.

   You can display the Version Cue Workspace Administration utility login page to identify the Version Cue Client URLs that remote users and WebDAV applications need to access the workspace.

3 Click OK. After you connect to a remote Version Cue Workspace, the dialog box displays all available Version Cue projects in that workspace.

A shortcut to the remote workspace is automatically included in your list of available Version Cue Workspaces.

See also

“About the Adobe dialog box” on page 73

“To log into Version Cue Administration from an Adobe Creative Suite component” on page 125
To connect to a project using WebDAV

The Version Cue Workspace can communicate with applications that are WebDAV enabled. When Version Cue is running on a server, you can use it as a WebDAV server. However, Version Cue's native versioning features are more sophisticated than those available through WebDAV. WebDAV capabilities are provided for legacy workflows.

❖ Refer to your application's documentation for information on using its WebDAV features, and then use the Version Cue WebDAV Client URL, the port number (3703), “webdav”, and the project name to identify the project you want to work with, for example, http://153.32.235.230:3703/webdav/project_name

See also

"Availability of Version Cue features" on page 71

To view Version Cue Workspace, project, and file information

Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See "Availability of Version Cue features" on page 71 for more information.

For help on viewing information in Acrobat 7, see Acrobat Help.

1 In Illustrator, InCopy, InDesign, or Photoshop, choose File > Open.

2 If the button is available, click Use Adobe Dialog (if you see the Use OS Dialog button instead, you are already using the Adobe dialog box).

3 Click Version Cue in the Favorites panel.

   You can resize the Favorites panel to display items with long names: place your cursor over the vertical line to the right of the Favorites panel and drag it to the right.

4 To change the display of Version Cue Workspaces, projects, or files in the dialog box, do any of the following:
   • To view the properties of a file, click the toggle to display the Properties panel.
   • To change the display of project, choose a display option from the View menu.
   • To sort items in a column, while in detail view, click the column heading. Click the column heading again to reverse the order.
   • To show or hide columns of information while in list view, right-click (Windows) or Control-click (Mac OS) the Name column heading, and choose Show All, Hide All, or a column name. (The Name column can't be hidden.) Visible columns have a check mark to the left of the column name.
   • To change the location of a column, drag the column heading to the left or right of another column heading (Windows), or press Command+Option and drag the column heading to the left or right of another column heading (Mac OS). The Name column can't be moved.
   • To resize a column of information, drag the vertical dividing line between column headings or double-click the line to automatically resize the column to fit the widest item in it.

5 To display information about a file, project, or Version Cue Workspace, do one of the following:
   • Place the pointer over the item. A summary of file information appears in a tool tip.
   • Right-click (Windows) or Control-click (Mac OS) the file and choose Versions (to display information about a file's versions) or Alternates (to display information about a file's alternates).

Note: If you've already opened the file in an Adobe Creative Suite component, file status information appears at the bottom of the file's window.
To view Version Cue Workspace, project, and file information in Bridge

*Note:* You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

In Bridge, you can choose between two display views: Versions And Alternates View and Details View. Use the Versions And Alternates View to view thumbnails of files along with thumbnails of Version Cue alternates and versions. Use the Details View to view thumbnails as well as information about the number of versions or alternates, enhanced status information, and the current version comment.

1. Start Bridge, and then click Version Cue in the Favorites panel.
2. Click the Version Cue Workspace, project, or file to view its information, or place the pointer over the item to display a summary of information in a tool tip.

Creating and editing projects

To begin using Version Cue, you need to create a Version Cue project. When you work with Version Cue, you decide what a project entails. For example, you can create a project to organize files for an entire publishing effort, or you can create a project to manage files for specific aspects of an advertising campaign. You can use a project to organize assets related to a particular customer or use a project to separate private files from files that are worked on collaboratively. You can add files to projects at any time by using Bridge, InCopy, or any Adobe Creative Suite component.

When you create a Version Cue project, you specify a project name, the Version Cue Workspace that hosts the project, and a project description. You specify whether to share the project or keep it private. Shared projects are available to other users; however, you can password-protect shared projects to restrict access to specific users. You can create private projects on a workspace installed on your computer. If you create a project on a computer that is used as a server, it must be shared to be accessible.

You can create projects by using Bridge, InCopy, any Adobe Creative Suite component, or the Version Cue Administration utility. The Version Cue Administration utility provides options for specifying advanced project properties. You create new Version Cue projects with it by importing a folder of files. These files are used as the project starting point.
The Project Tools menu contains frequently used commands.

See also

“To create a project” on page 81
“To edit Version Cue project properties” on page 130
“To create a new Version Cue project from a folder” on page 129
“To share or unshare a project” on page 83
“To share or unshare a project from Bridge” on page 84
“Availability of Version Cue features” on page 71

To create a project

Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

For information on creating a project in Acrobat 7, see Acrobat Help.

1 In Illustrator, InCopy, InDesign, or Photoshop, choose File > Open. Click Use Adobe Dialog if you’re using the OS dialog box.

2 Click Version Cue in the Favorites panel.

3 Choose New Project from the Project Tools menu.

4 Choose a location for the project from the Location menu.

5 Enter a name for the project in the Project Name box and a description in the Project Info box. (The description you enter appears as a tool tip when the pointer is over the project in the list of workspaces.)
6 To make this project and its files available to others, select Share This Project With Others. (If the Version Cue Workspace is on a computer other than your own, the Version Cue project is shared by default.)

7 Click OK.

See also
"About the Adobe dialog box" on page 73

To create a project in Bridge

Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

1 Start Bridge, and then click Version Cue in the Favorites panel.

2 Choose Tools > Version Cue > New Project.

3 Choose a location for the project from the Location menu.

4 Enter a name for the project in the Project Name box and a description in the Project Info box. The description you enter appears as a tool tip when the pointer is over the project in the list of workspaces.

5 To make this project and its files available to others, select Share This Project With Others. (If the Version Cue Workspace is on a computer being used as a server, the Version Cue project is shared by default.)

6 Click OK. The project opens automatically. No Items To Display appears in the Content Area until you add files to the project.

See also
“To add a file or folder to a project in Bridge” on page 90

To edit the properties of a project

Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

1 Do one of the following:

- In Illustrator, InCopy, InDesign, or Photoshop, choose File > Open. Click Use Adobe Dialog if you’re using the OS dialog box. Double-click the host Version Cue Workspace. Select the project, and then choose Edit Properties from the Project Tools menu.
- In Bridge, select the project and then choose Tools > Version Cue > Edit Properties.
- In Acrobat 7, choose File > Open. Click Version Cue. Select the project, and then choose Edit Properties from the Project Tools menu.

2 In the Edit Properties dialog box, do any of the following, and click Save:

- To change the project name, enter a name in the Project Name text box. The new name will not be reflected on your (or your workgroup’s) working copies project folder until you disconnect from and reconnect to the project.
- To change the description of the project, enter text in the Project Info box.
- To make this project and its files available to other users, select Share This Project With Others. (If the Version Cue Workspace is on a computer being used as a server, the Version Cue project is shared by default.) To unshare a
shared project, deselect Share This Project With Others. Note, however, that this action does not delete any working copies currently in project folders on the workgroup's computers.

- To view the location of working copies on your computer, expand Local Project Files. To open the folder, choose Show Files (Windows) or Show Files in Finder (Mac OS). To change the location of the files, click Change Location and choose the new location for working copies.

Note: Make sure that you use the Change Location feature to relocate working copies, rather than moving the project folder manually in the file system.

- Click Advanced Administration to enable lock protection, edit or assign users, or require users to log into the project. When prompted, log into Version Cue Administration. Depending on your privileges, this option may not be available.

3 Click Cancel to close the Open dialog box (Version Cue saves your settings even though you clicked Cancel).

See also
“Disconnecting from projects” on page 95
“Deleting files and folders” on page 97
“To log into Version Cue Administration from an Adobe Creative Suite component” on page 125

To share or unshare a project

Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

At any time, you can change a project's shared status. Projects on a Version Cue Workspace that other users can access are shared by default and can't be made private. Note that unsharing a project does not delete any working copies currently in the working copies project folders of your workgroup.

Note: If the Version Cue Workspace is installed on a computer that uses a firewall and you want to share the workspace with others, make sure that TCP ports 3703 and 427 are left open. If you're using a Windows machine, deselect the Internet Connection Firewall option. (For information on the Internet Connection Firewall option, see Windows Help.)

1 Do one of the following:
   - In Illustrator, InCopy, InDesign, or Photoshop, choose File > Open. Click Use Adobe Dialog if you're using the OS Open dialog box.
   - In Acrobat 7, choose File > Open.

2 Click Version Cue in the Favorites panel, and then double-click the host Version Cue Workspace.

3 Select the project, and then do one of the following:
   - To share the project, choose Share Project from the Project Tools menu.
   - To unshare the project, choose Unshare Project from the Project Tools menu.
   - Choose Edit Properties from the Project Tools menu. Select or deselect Share This Project With Others, and click Save. After you edit the project properties, click Cancel to close the Open dialog box (your settings are saved even though you clicked Cancel).
See also
“About the Adobe dialog box” on page 73
“To view Version Cue Workspace, project, and file information” on page 79

To share or unshare a project from Bridge

Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

At any time, you can make a project shared or unshared. You can keep a Version Cue project unshared only if it is on your own computer. Projects that you create on a Version Cue Workspace that is not located on your own computer are shared by default and can’t be made private. Note that unsharing a project does not delete any working copies that others may already have in the working copies project folder on their own computer.

1 Start Bridge, and then click Version Cue in the Favorites panel.
2 Double-click Workspaces.
3 Right-click (Windows) or Ctrl-click (Mac OS) the project and choose either Share Project or Unshare Project from the menu.

You can also choose Edit > Properties, and then select or deselect Share This Project With Others, and click Save.

See also
“To view Version Cue Workspace, project, and file information in Bridge” on page 80

Working with files in Version Cue

Using working copies

Version Cue projects and files reside in the Version Cue Workspace on the host computer. The master copies of files added to the project, including file versions and other file data, such as comments, version dates, and user IDs, are saved on this host computer. When you work in files from a Version Cue project, you’re editing a working copy of the master file on your computer, not the master file on the Version Cue Workspace, which remains protected and untouched.

As you work, use the Save command to save changes periodically. This command does not create a new version of the master file but updates your working copy. A new version is created only when you choose the Save A Version command. This command first updates the working copy, and then adds a new version to the master file on the Version Cue Workspace. When the working copy of a file matches (is the same version as) the current version in the workspace, the file is synchronized.

Using working copies of master files, several people can work with the most recent version of a master file. For example, if two people need access to the same illustration during overlapping periods of time, Version Cue lets each person work with a working copy of the most recent file version. The second person to access the illustration is informed that the file is already in use. At that time, the second person can decide whether to continue working with the file. Working copies give everyone flexible access to project files and allow work to proceed concurrently when necessary.

Note: Two users can’t edit a file simultaneously in InCopy.
Working copies allow you to work on a file even when the host workspace is unavailable, or offline. Though some features, such as versions and alternates, can't be used when you're working offline, you can edit files and save your work. When the workspace is online again, you can save a version to update the master file.

There are times when you may wish to delete the working copies of your project files. For example, you may want to free up space on your hard drive, or are completely finished working on the project. Version Cue lets you delete your working copies of project files by disconnecting from the project. Disconnecting from a project deletes the working copies project folder on your hard drive. You can do this at any time if none of the working copies are In Use by you. If you accidentally disconnect from a project, new working copies are recreated the next time you access the project files. If a project is deleted from either the host workspace or your local computer, you can use working copies to recreate the project with the most current versions of the files.

To relocate working copies of a project, edit the project's properties and use the Change Location feature. For instructions, see “To edit the properties of a project” on page 82.

*Note:* Make sure that you use the Change Location feature to relocate working copies, rather than moving the project folder manually in the file system.

**See also**

“Creating and editing projects” on page 80

“To create a project” on page 81

“Disconnecting from projects” on page 95

“Deleting files and folders” on page 97

“Editing and synchronizing offline files” on page 110

“To restore a file or folder deleted from a project” on page 100

“Version Cue file statuses” on page 86

“Availability of Version Cue features” on page 71

**File protection in Version Cue**

Version Cue automatically informs others that a file is being edited. Version Cue assigns In Use status to a file when you open and edit a file that isn't being edited by another user. When you save a version, Version Cue removes the file's In Use status.

*Note:* In InCopy, you must choose File > Checkin after saving a version to remove the file's In Use status.

At times two people may need to work with a file simultaneously. For example, User A may begin editing a file but be called away before saving a version. If User B works on the file while User A is away, Version Cue ensures that the two files don't overwrite each other in the project. User A's working copy won't reflect the changes made by User B, and vice versa. When finished with the file, both users can save a new version of the file to the Version Cue Workspace. Version Cue alerts all current users of the file about the presence of a new version in the Version Cue Workspace and gives them the option of downloading the latest version or continuing their current edits. Alternatively, users can save their edits as an alternate.(Version Cue alerts users who have the file open or who re-open a file that was previously closed while In Use.)

*Note:* Two users can't edit a file simultaneously in InCopy.
You can use the Version Cue Workspace Administration utility to assign lock protection to a Version Cue project. Only the first user to begin editing an available file in a lock-protected project can save the next version of that file to the Version Cue project. Other users who edit that file simultaneously can't save changes to a new version of that file, even after the first user saves a version. These other users must save the changes as completely new files with their own version thread; however, they can designate their file as an alternate of the original file.

The ability to access a file in a lock-protected project provides the flexibility to create proofs or experiment with the design, for example, and then close the file without saving changes.

See also

“Using working copies” on page 84
“Availability of Version Cue features” on page 71

Version Cue file statuses

Files that are managed by Version Cue are always marked with a status icon that describes the state of the file on the Version Cue Workspace. You can view a file's status while browsing the files in a Version Cue project, in Bridge, and also in the document window's Status area after opening a file from the Version Cue Workspace in an Adobe Creative Suite component. In Acrobat, the status is displayed in the title bar. A file can have more than one status at the same time (in some cases only one status is shown).

Each file status has a corresponding icon:

Open 📖 The file is open on your computer. This status lets you make informed decisions about whether it's appropriate, for example, to place a file into a layout while the file is still being edited. The Open status is indicated only for files on your computer.

In Use By Me 🤔 You are editing the file. Version Cue assigns this status to a file when you make an edit to the file that changes its content. You can manually mark a file in use before you edit it to indicate to others that you intend to make changes to the content.

Synchronized 😌 The latest known version of the file is available for editing and you have a working copy of it on your computer. Version Cue assigns this status when you save a version of the file you're editing, or when you manually synchronize a project.

No Working Copy 🚧 No local copy of the file exists. This status indicates that it will take a few moments to create a working copy before you can edit the file.

In Use By <user name> 🤔 Another user is editing the file and has not yet saved a new version.

Conflicted Copies 💥 There is a version conflict, or both you and another user are editing the file.

Only Copy 🚧 The file in the working copies folder is the only copy known to Version Cue and has not been synchronized with the Version Cue Workspace. This scenario can occur when a file has been saved in an existing project for the first time while the workspace is offline. Because the workspace is offline, Version Cue displays the Offline Copy status until the workspace is back online, and then changes the status to Only Copy. Version Cue also displays this status if you drag a file from one folder into the working copies folder using the file system instead of Bridge (not recommended). You can edit the file, but it's important to synchronize (upload the file to the workspace) after you save your changes.

Offline Copy 🚧 There is a local copy of the file in your working copies folder, but the Version Cue Workspace is offline. There is no way of checking whether the local copy is synchronized with the latest version on the workspace.
You can edit an offline copy and save these changes; however, you must save a version or synchronize the file once the workspace comes back online.

**Outdated Copy** A local copy exists, but there is a newer version of the file in the workspace. This status indicates that it will take a few moments to create an up-to-date working copy before you can edit the file.

**Unavailable** The Version Cue Workspace is offline or you don’t have access privileges. There is no way of checking the status of the local copy with the workspace. You can edit the local copy and save these changes; however, you must save a version or synchronize the file once the workspace comes back online.

**Deleted** The file or folder has been deleted from the project, but not yet permanently erased. (You can restore a deleted file or folder).

**See also**

“Using working copies” on page 84

“To synchronize files” on page 112

“To edit a file in use by another user” on page 88

“Deleting files and folders” on page 97

“Availability of Version Cue features” on page 71

---

**To open a file from a project**

**Note:** You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

After you add or save a file to a Version Cue project, the file is automatically managed by Version Cue. Managed files can’t be overwritten. If you open a file that’s in use by another user or that has been previously edited and saved as a new version, you are prompted to edit the most recent version.

1 Do one of the following:

   • In Illustrator, InCopy, InDesign, or Photoshop, choose File > Open. Click Use Adobe Dialog if you’re using the OS dialog box, and then click Version Cue in the Favorites panel.

   • In Acrobat 7, choose File > Open, and then click Version Cue in the dialog box that appears.

   • In Bridge, click Version Cue in the Favorites panel.

2 Double-click the host Version Cue Workspace.

3 Double-click the project that contains the file you want to open.

4 Select the file and click Open.

**See also**

“To edit a file in use by another user” on page 88

“To update a file with the most recent version” on page 88

“About the Adobe dialog box” on page 73

“To search for files in a project” on page 95
To reveal a file in Bridge
❖ Right-click (Windows) or Ctrl-click (Mac OS) the file in the Open dialog box in InCopy or an Adobe Creative Suite component, and choose Reveal In Bridge.

The file appears in the Bridge window.

To edit a file in use by another user

Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

If you don’t notice that a file’s status is In Use when you open it, Version Cue displays an In Use By alert to remind you that someone else is already editing a working copy of the file.

Note: In InCopy, you can’t edit a file that’s in use by another user.

1 Open the file, and click one of the following options when the In Use By alert appears:
   No, Close Document  Closes the file without any alterations.
   Yes, Keep Open  Keeps the file open so you can work on the document.

2 If you continue working with the document and make a change to the content, Version Cue displays an alert to remind you that there is the possibility of creating conflicting copies. Click one of the following:
   Discard Changes  Displays the most recent version of the file from the Version Cue Workspace and discards your changes to the working copy.
   Continue Editing  Lets you edit the working copy without overwriting the changes made in another user’s working copy of the same file (Version Cue will prompt each user to save a new version of the file).

3 If the project doesn’t have lock protection applied to it, you can save a new version of your edits. Version Cue displays an alert warning you that conflicting edits will occur if you continue. Click one of the following:
   Cancel  Returns you to the open document without saving a version.
   Save Version Anyway  Updates the master file in the Version Cue Workspace with the new version. (Version Cue displays an alert to the other user to note that a newer version of the file has been created by you.)

At any point, you can close the document and discard any changes you’ve made.

See also
“‘To update a file with the most recent version’ on page 88

To update a file with the most recent version

Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.
If another user creates a new version of a file that you have open or that is still marked In Use By Me, Version Cue prompts you to update your document with the latest version when you open it or attempt to make changes to it, or when you bring the document window frontmost in a group of documents.

❖ When the prompt appears, click one of the following:

**Discard Changes** Updates the document with the most recent version from the Version Cue project. You can continue editing the file after it is updated. You lose any changes you’ve made even if you have already saved those changes to the working copy with a Save command.

**Continue Editing** Leaves the document as is. You can continue editing the file without overwriting the changes in the more recent version. Instead, you’re prompted to either save a new version of the file when you close it, or to discard your changes.

**See also**

“To edit a file in use by another user” on page 88

---

**Adding files and folders to a project**

To save versions of a file and take advantage of Version Cue file management, you must add or save the file to a Version Cue project. You can add assets such as swatch libraries to projects to share them with your workgroup. You can also add non-Adobe files to Version Cue projects. You can add files using any of the following methods:

- Add files one at a time from within InCopy or in Adobe Creative Suite.
- Drag one or more files or folders to a Version Cue project using Bridge. Use this method to copy files from one Version Cue project to another.
- Drag files and folders from open windows on your computer’s desktop to a Version Cue project displayed in a Bridge window.
- Place files directly in the project’s working copies folder, and then synchronize the project to add the files. For more information, see “About Version Cue projects” on page 76.

**See also**

“To create a new Version Cue project from a folder” on page 129

“Availability of Version Cue features” on page 71

---

**To add a file to a project**

*Note:* You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

For information on adding a file to a project in Acrobat 7, see Acrobat Help.

1. Open the file in Illustrator, InCopy, InDesign, or Photoshop.
2. Choose File > Save As. Click Use Adobe Dialog if you’re using the OS dialog box.
3. Double-click the host Version Cue Workspace.
4. Double-click the project to open it.
5. Enter a comment for the first version in the Version Comments box, and click Save.
See also
“About the Adobe dialog box” on page 73

To add a file or folder to a project in Bridge
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

1 Start Bridge. In Folders (in the Favorites panel), navigate to the folder in the Version Cue project to which you want to add files.
2 Navigate to the folder that contains the files or folders you want to add to the project.
3 Select one or more files or folders, and drag them to the Version Cue folder icon you navigated to in step 1.

Note: To copy (not move) the files to a project, hold down Ctrl (Windows) or Option (Mac OS) as you drag the files to the project.

See also
“The Bridge work area” on page 37

To add a file or folder from a desktop folder to a project in Bridge
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

1 Start Bridge, and click Version Cue in the Favorites panel.
2 Double-click Workspaces.
3 Double-click the Version Cue project and browse to the folder to which you want to add files.
4 Select files and folders in the open folder on your desktop.
5 Drag these items from the open folder to the Bridge content area displaying the Version Cue folder to which you want to add files.

Note: To copy (not move) the files to a project, hold down Ctrl (Windows) or Option (Mac OS) as you drag the files to the project.

See also
“The Bridge work area” on page 37

To add files to a project folder without Bridge
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.
It's best to add files using Bridge, but you can add files by dragging them into the documents folder of a Version Cue project.

1 Do one of the following:
   • Locate the project folder inside the My Documents/Version Cue (Windows) or Documents/Version Cue (Mac OS) folder on your computer.
   • If the project folder isn't already in the My Documents/Version Cue (Windows) or Documents/Version Cue (Mac OS) folder on your hard disk, create a new folder inside the Version Cue folder. Give the folder the same name as the existing Version Cue project on the Version Cue Workspace. Inside the new project folder, create a new folder and name it documents.
   
   Note: These steps work only if the project already exists. You cannot create a new project using this method.

2 Move or copy the items you want to add to the documents folder.

3 In Illustrator, InCopy, InDesign, Photoshop, or Acrobat, choose File > Open. Click Use Adobe Dialog if you're using the OS dialog box.

4 Click Version Cue in the Favorites panel. Open the Version Cue Workspace, and select the project.

5 Choose Synchronize from the Project Tools menu. (Alternatively, you can select the project in Bridge and synchronize it.) Once the synchronization is complete, the files are added to the project.

See also
“Editing and synchronizing offline files” on page 110

“About the Adobe dialog box” on page 73

“About Version Cue projects” on page 76

To copy or move files between projects or from a project to a desktop folder

Do one of the following:

• To copy a file between projects, start Bridge and navigate to the project folder that contains the file you want to copy. Choose File > New Window to open a new Bridge window, and navigate to the project folder to which you want to add the file. Drag the file from the first project folder to the destination project folder in the second Bridge window.

• To copy a file from a project to a desktop folder, drag it from the project folder in Bridge to the desktop folder.

   Note: When you copy a file between projects or from a project to a desktop folder, Version Cue copies only the most current version.

• To move a file between projects, copy it from one project folder to another in Bridge, and then permanently delete the file from the first project folder. For instructions on permanently deleting files, see “To delete files or folders from a project” on page 99 and “To delete a file or folder permanently” on page 100.

• To move a file from a project to a desktop folder, drag it from the project folder in Bridge to the desktop folder, and then permanently delete the file from the first project folder. For instructions on permanently deleting files, see “To delete files or folders from a project” on page 99 and “To delete a file or folder permanently” on page 100.

To save changes to a file

Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.
If you want to save changes, but aren’t ready to save a new version as you edit a file you have opened from a Version Cue project, you can use the File > Save command to save your changes to the working copy on your computer. Until you save a new version to the shared Version Cue Workspace, these changes won’t be available to any other user. You can also close the file once you save changes to a file, and then reopen it and save a version later.

❖ To save changes to your working copy, choose File > Save.

To place a file from a project into a document

Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

While you’re working with a Version Cue project in Illustrator, InCopy, InDesign, or Photoshop, you can add a file to a document just as you normally would—by using the Place command. The Links palette (in Illustrator, InCopy, and InDesign) displays additional information about placed files from Version Cue projects, identifying whether a linked file is being edited, which user is doing the editing, whether it is a member of a group of alternates, and if so, whether it is the primary (preferred) alternate. You can also use the Links palette to determine whether the linked file needs to be updated to a newer version from the Version Cue Workspace.

1 In Illustrator, InCopy, InDesign, or Photoshop, choose File > Place.
2 Click Version Cue in the Favorites panel.
3 Double-click the host Version Cue Workspace.
4 Double-click the project containing the file you want to place.
5 Select the file, and click Place.

For complete information on placing files into documents in Adobe Creative Suite, see the specific application’s Help.

Note: When you place a file from a Version Cue project, a copy of that file is placed in your My Documents/Version Cue (Windows) or Documents/Version Cue (Mac OS) folder of working copies for that project. As a result, you can edit that file offline, while it’s disconnected from the Version Cue Workspace

See also

“Using the Links palette with project files” on page 93
"About Version Cue alternates” on page 106

To place a non-Version Cue file into a document

Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

1 With the document open in Illustrator, InCopy, InDesign, or Photoshop, navigate to the file you want to place.
2 Select the file, and click Place (Illustrator) or Open.

For complete information on placing files into documents in Adobe Creative Suite, see the specific application’s Help.

💡 You should always add assets to a Version Cue project before placing them in a Version Cue-managed file. When you place a non-Version-Cue managed file into a managed file, you cannot keep track of the placed asset’s versions, alternates, or status.
Using the Links palette with project files

When Version Cue is enabled in Illustrator, InCopy, or InDesign, the Links palette identifies who is editing a linked file from a Version Cue project. It also displays a linked file's versions and alternates so that you can promote and use previous versions, update the document with the linked file's alternates; you can even create versions of linked non-Adobe files.

The Links palette, including the File Status column, functions the same with Version Cue-managed files as it does with non-Version Cue-managed files. For example, if a newer version of a linked file is on the Version Cue Workspace, the Modified Artwork icon ✲ appears; if a file is missing, the Missing Artwork icon ❌ appears. To update a linked file from a Version Cue project, you use the same procedures used for files that aren't managed by Version Cue.

The Version Cue Edit Status column in the Links palette displays nothing if the linked file is available, or it displays a status icon.

See Illustrator Help, InCopy Help, or InDesign Help for more information about working with the Links palette and placed files.

See also

“Availability of Version Cue features” on page 71
“To view alternates and versions in the Links palette” on page 93
“Truncate Kludge Version Cue features” on page 71
“Truncate Kludge Version Cue features” on page 71
“Truncate Kludge Version Cue features” on page 71
“Truncate Kludge Version Cue features” on page 71

To view alternates and versions in the Links palette

**Note**: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

When Version Cue is enabled in Illustrator, InCopy, or InDesign, you can view versions and alternates of a placed file from the Links palette.

❖ Do one of the following:

• To view versions of a placed file, choose Versions from the Links palette menu.

• To view alternatives of a placed file, choose Alternates from the Links palette menu.

See also

“Using the Links palette with project files” on page 93
“Truncate Kludge Version Cue features” on page 94
“Truncate Kludge Version Cue features” on page 94
“Truncate Kludge Version Cue features” on page 94
“Truncate Kludge Version Cue features” on page 94
To replace a placed file with an alternate
1 In Illustrator, InCopy, or InDesign, select the file in the Links palette.
2 Choose Alternates from the Links palette menu.
3 Choose an alternate, and click Relink.

See also
“Using the Links palette with project files” on page 93
“To view alternates and versions in the Links palette” on page 93
“To replace a placed file with an alternate version” on page 94
“To replace a placed file with an alternate derived from a previous version” on page 94

To replace a placed file with an alternate derived from a previous version
1 In Illustrator, InCopy, or InDesign, select the file in the Links palette.
2 Click Edit Original and edit the file in its native application.
3 Choose File > Save As, and select Save As Alternate (rename the file if you save it in the original folder).
4 Close the file.
5 In Illustrator, InCopy, or InDesign, select the placed file in the Links palette.
6 Choose Alternates from the Links palette menu.
7 Select the Alternate you created in step 3, and click Relink.

See also
“Using the Links palette with project files” on page 93
“To view alternates and versions in the Links palette” on page 93
“To replace a placed file with an alternate version” on page 94
“To replace a placed file with an alternate derived from a previous version” on page 94

To replace a placed file with a previous version
1 In Illustrator, InCopy, or InDesign, select the file in the Links palette.
2 Choose Versions from the Links palette menu.
3 Select a version and click Promote To Current. Enter a version comment if desired, and click Save.

See also
“Using the Links palette with project files” on page 93
“To view alternates and versions in the Links palette” on page 93
“To replace a placed file with an alternate version” on page 94
“To replace a placed file with an alternate derived from a previous version” on page 94
To search for files in a project

Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See "Availability of Version Cue features" on page 71 for more information.

Metadata is automatically added to Version Cue project files as you work with them. In addition, you can manually add other information to files in Adobe Creative Suite through the File Info dialog box. You can quickly locate files in a Version Cue project by searching for specific information such as titles, authors, copyright data, keywords, dates, and locations. The search feature searches through existing files, as well as files deleted from projects. For information on searching in Acrobat 7, see Acrobat Help. You can also search for Version Cue project files in Bridge, both by version comment and past versions.

1. In Illustrator, InCopy, InDesign, or Photoshop, choose File > Open.
2. If the button is visible, click Use Adobe Dialog (if you see the Use OS Dialog button instead, you are already using the Adobe dialog box).
3. Click Version Cue in the Favorites panel.
4. Double-click the host Version Cue Workspace.
5. Double-click the project you want to search.
6. Click Project Search 🕵️.
7. Enter information in Project Search.

If you open an older version of a file found as the result of a search, the file name will be prefaced with Version <X> -.

Note: It is best to treat older versions as view-only when opened as the result of a search. Although you can edit an older version in its native application, do so only if you intend for this version to become a separate asset or to be used as an alternate. To edit a previous version, first promote it to the new, current version, and then make changes.

See also

“About the Adobe dialog box” on page 73
“Version Cue file statuses” on page 86
“To search for files and folders with Bridge” on page 49
“Viewing and comparing versions” on page 102
“To view a previous version in its native application” on page 104

Disconnecting from projects

Disconnecting from projects

Disconnecting from a project erases the working copies of files on your computer while leaving the master copies on the Version Cue Workspace intact. Disconnecting also removes shortcuts to the project from Bridge and the Adobe dialog box. You may want to disconnect to free up more space on your hard drive. Or, you might disconnect from a project if someone else in your workgroup deletes a project from the Version Cue Workspace (your working copies are not touched by that deletion).
As long as you have saved a version of the working copies there is no harm in discarding them by disconnecting. When you access the project again, new working copies will be created for the current versions of the files you open. If you have working copies with the In Use By Me status, you will not be permitted to disconnect from a project until you have saved a version of those files.

When you disconnect from a project, only the working copies and shortcuts on your computer are erased. Leaving the project intact on the workspace allows others, as well as yourself, to access the master files. When you delete a project, all working copies and shortcuts on your own computer, along with the master copies of files and folders in the Version Cue Workspace, are erased. However, any working copies and shortcuts on other computers your co-workers or you previously used to access the project are not erased. To completely remove the project and erase those working copies and shortcuts, you must select the shortcut or project folder and disconnect, even though the project has already been deleted.

You can disconnect from a Version Cue project by using Bridge, Photoshop CS2, Illustrator CS2, InCopy CS2, or InDesign CS2. GoLive CS2 uses a different method for deleting working copies of site files. Disconnect is not available in Acrobat 7.

See also
“Deleting files and folders” on page 97
“To disconnect from a project in Bridge” on page 96
“To disconnect from a project” on page 96
“Using working copies” on page 84
“Availability of Version Cue features” on page 71

To disconnect from a project

Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

Disconnecting from a project removes the files from your computer but doesn’t delete the project from the host Version Cue Workspace. Disconnect is not available in Acrobat 7.

1 In Illustrator, InCopy, InDesign, or Photoshop, choose File > Open. Click Use Adobe Dialog if you’re using the OS dialog box.

2 Click Version Cue in the Favorites panel.

3 Open the Version Cue Workspace and select the project from which you want to disconnect.

4 Choose Disconnect from the Project tools menu.

Note: You can select any project icon or shortcut to the project when you want to disconnect.

To disconnect from a project in Bridge

Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.
Disconnecting from a project removes working copies of the project files from your computer but doesn't delete the project from the host Version Cue Workspace.

1. Start Bridge, and click Version Cue in the Favorites panel.
2. Double-click Workspaces, and navigate to the project from which you want to disconnect.
3. Right-click (Windows) or Ctrl-click (Mac OS) the project, and then choose Disconnect from the menu.

*Note:* You can select any project icon or shortcut to the project when you want to disconnect.

## Deleting files, folders, and projects

### Deleting files and folders

Deleting a file or folder from Version Cue is a two-step process that safeguards against accidental deletions. The first step is deleting the file or folder and giving it the Deleted status. Deleting hides the file or folder from normal view but does not erase it. The second step is permanently deleting and erasing the file or folder and its previous versions.

When you delete a folder, the folder and all folders and files nested inside it are hidden and given a Deleted status. When you permanently delete a folder, its entire contents are erased.

Any user with appropriate privileges can delete files and folders unless the files or folders are marked In Use. In a workgroup, if a user is editing a file that you need to delete, you can reset the file's lock by using the Version Cue Administration utility.

You can restore files or folders that have a Deleted status. Restoring reinstates Version Cue management. Restored files and folders appear in their previous location in the project folder hierarchy. (Deleted files and folders maintain their relationship within the project hierarchy until they are permanently deleted.)

In Bridge, InCopy, and in Adobe Creative Suite, you can show hidden and deleted files or folders, and view them in search results. Additionally, Version Cue has a Project Trash view from which you can view all deleted files in a project. Use Project Trash to view and handle all deleted files without navigating through the project folder hierarchy. You can delete individual files or folders in Bridge, InCopy, or any Adobe Creative Suite component.

### See also

- “Using working copies” on page 84
- “To delete a project in Bridge” on page 98
- “To disconnect from a project in Bridge” on page 96
- “To delete a Version Cue project in the Version Cue Administration utility” on page 131
- “Availability of Version Cue features” on page 71
Deleting projects
Deleting a project from Version Cue permanently erases all of its master files (including versions and alternates) and folders from the Version Cue Workspace. This is a one-step process (with confirmation). Deleting a project automatically deletes the working copies of files on your computer as well as any shortcuts to that project. However, the working copies of files created on other users’ computers are not deleted until they disconnect from the deleted project. You cannot restore deleted projects directly in Version Cue, nor can you delete a project if any user has files that are marked In Use. You can delete an entire Version Cue project in Bridge, InCopy, or any Adobe Creative Suite component. You can also delete projects by using the Version Cue Administration utility, if you have privileges to do so.

To delete a project
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

For information about deleting a project from Acrobat 7, see Acrobat Help.

1 In Illustrator, InCopy, InDesign, or Photoshop, choose File > Open. Click Use Adobe Dialog if you’re using the OS dialog box.
2 Click Version Cue in the Favorites panel.
3 Do one of the following:
   • Double-click the host Version Cue Workspace and select the project.
   • Click the project shortcut.
4 Choose Delete from the Project Tools menu.
5 Click OK in the confirmation dialog box.
You can also delete projects using the Version Cue Administration utility.

See also
“To delete a Version Cue project in the Version Cue Administration utility” on page 131
“To disconnect from a project” on page 96
“About the Adobe dialog box” on page 73

To delete a project in Bridge
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

1 Start Bridge, and then click Version Cue in the Favorites panel.
2 Double-click Workspaces.
3 Right-click the project or the project shortcut, and then choose Delete Project from the menu.
4 Click OK to confirm the deletion.
To remove working copies of the files from the deleted project, you need to disconnect from the project.
To delete files or folders from a project

Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

Once you delete a file or folder from a project, you can then choose to permanently delete it or restore it with its original data, including file versions and related information. For information about deleting files or folders from Acrobat 7, see Acrobat Help.

1 In Illustrator, InCopy, InDesign, or Photoshop, choose File > Open. Click Use Adobe Dialog if you’re using the OS dialog box.

2 Click Version Cue in the Favorites panel.

3 Double-click the host Version Cue Workspace.

4 Double-click the project that contains the file or folder you want to delete.

5 Select the file or folder you want to delete.

6 Do one of the following:
   - Choose Delete from the Project Tools menu
   - Drag the file to the Project Trash.

Note: If Show Deleted files is not selected in the Project Tools menu, the file will become hidden and removed from view. If Show Deleted Files is selected, the file or folder will remain visible with the status Deleted.

See also

“To view Version Cue Workspace, project, and file information” on page 79

To delete files from a project in Bridge

Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

Once you delete a file from a project, you can then choose to permanently delete it or restore it with its original data, including file versions and related information.

1 In Bridge, click Version Cue in the Favorites panel, then double-click Workspaces.

2 Double-click the host Version Cue Workspace.

3 Double-click the project that contains the file you want to delete.

4 Select the file and click the Delete Item icon in the toolbar.

Note: If Show Hidden and Deleted files is not selected in the View menu, the file will become hidden and removed from view. If Show Hidden and Deleted Files is selected, the file will remain visible with the status Deleted.

See also

“To view Version Cue Workspace, project, and file information” on page 79
To restore a file or folder deleted from a project

**Note:** You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

For information on restoring files or folders in Acrobat 7, see Acrobat Help.

1. In Illustrator, InCopy, InDesign, or Photoshop, choose File > Open. Click Use Adobe Dialog if you’re using the OS dialog box.
2. Click Version Cue in the Favorites panel.
3. Double-click the host Version Cue Workspace.
4. Double-click the project that contains the file or folder you want to restore and do one of the following:
   - Click Project Trash in the Favorites panel, select the file you want to restore, and choose Restore from the Project Tools menu.
   - Choose Show Deleted Items from the Project Tools menu (deleted file and folder names appear in gray in the dialog box). Select the file or folder you want to restore, and choose Restore from the Project Tools menu.
5. Choose Refresh from the Project Tools menu to update the dialog box.

The file or folder is restored to its original location in the Version Cue project.

**Note:** To restore a file in a previously deleted folder, you must first restore the folder. Doing so restores the folder and all its contents.

To delete a file or folder permanently

**Note:** You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

You can permanently delete and erase files or folders that have a Deleted status. For information about deleting a file or folder permanently in Acrobat 7, see Acrobat Help.

1. In Illustrator, InCopy, InDesign, or Photoshop, choose File > Open. Click Use Adobe Dialog if you’re using the OS dialog box.
2. Click Version Cue in the Favorites panel.
3. Open the Version Cue Workspace and project that contains the file or folder you want to delete permanently.
4. Choose Show Deleted Items from the Project tools menu.
5. Select the file or folder you want to permanently delete, and choose Delete Permanent from the Project Tools menu.
6. Click OK.

To delete a file permanently in Bridge

**Note:** You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

You can permanently delete and erase files that have a Deleted status.

1. Start Bridge. In the Favorites panel, click Version Cue.
2. Double-click Workspaces, then double-click the project that contains the file you want to delete permanently.
3 Right-click (Windows) or Control-click (Mac OS) the file, and choose Delete Permanent.
4 Click OK to confirm the deletion.

Version Cue versions

About Version Cue versions
Versions provide a convenient method of retaining work that was performed in different stages. At any point in your design process, you can save a version of the file, which Version Cue saves and tracks. Each version is a snapshot of the file. You can use versions to review ideas or changes with team members or a client before selecting a final version, or to recover from destructive changes.

Version Cue prevents users from overwriting each other’s work. With this protection capability, multiple users can work on a file simultaneously. When more than one user is working on a file, Version Cue alerts them all when one user saves a new version, allowing everyone to update the file and work in the latest version.

Note: Two users cannot edit a file simultaneously in InCopy.

You don't have to save a version every time you save your changes. Using the File > Save command works the same way in Version Cue-managed files as in non-Version Cue files. You need only save a version when you want to create a snapshot of the file. For example, if you change the background color or some text in the layout, and then save a version, you can go back to the previous version without damaging your file. Instead of choosing File > Save As and saving a new copy of a design, you save a version, which allows you to track changes as they occur.

If you want to continue your work using a previous version instead of the current version, promote the previous version to the next current version (do this instead of opening the previous version directly). This process keeps the previous version intact, should you decide to return to it again in the future. If you want a previous version, along with the current version, to be available for use in a project, you can save the previous version as a separate asset. When you do this, you can then make the previous version a member of a group of alternates, if desired.

You can view previous versions in their native applications. When you no longer need to keep previous versions of files, you can delete them individually or in batches.

See also
“Viewing and comparing versions” on page 102
“To save a version of a non-Adobe file” on page 102
“About the Metadata panel in Bridge” on page 54
“Availability of Version Cue features” on page 71

To save a version
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.
To save a new version of a file, you use the Save A Version command, which saves your changes to the Version Cue Workspace. Versions of a file can be subsequently compared using thumbnails, and viewed, deleted, or promoted using the Versions command.

1. Do one of the following:
   - In Bridge, choose Tools > Version Cue > Save A Version.

2. In the Save A Version dialog box, enter comments you want to associate with this version.

3. Click Save.

To save a version of a non-Adobe file

Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See "Availability of Version Cue features" on page 71 for more information.

Bridge opens files in their native applications so that you can make changes. You can save versions of non-Adobe files only if (1) the files are in a Version Cue project and (2) the files have been opened through Bridge. After you create versions with this procedure, you can access them from the Versions dialog box in Adobe Creative Suite components, from InCopy, and from the Versions View of Bridge.

1. Start Bridge.

2. In the Favorites panel, click Version Cue, and then navigate to the project containing the file you want to save as a version.

3. Double-click the file to open it.

4. When the file opens in its native application, make your changes, and save and close the file.

5. In Bridge, choose Tools > Version Cue > Save A Version.

6. In the Save A Version dialog box, enter comments you want to associate with the version, and then click Continue.

Note: You can save versions of nonembedded graphics, image, and text files in InCopy, InDesign, and Illustrator by using the Edit Original command in the Links palette. After editing the file, save it in its native application. Then, in the Links palette, select the file and use the Save Link Version command to save a version in the Version Cue project. For more information, see InCopy Help, InDesign Help, or Illustrator Help.

Viewing and comparing versions

Versions are always available for you to view and compare. Each version is treated as a separate file, which you can access through the Versions dialog box in all Adobe Creative Suite components and in InCopy. The Versions dialog box displays thumbnails of all file versions alongside comments, dates, and the login name of the user who created the version. Each version is numbered sequentially. You can view any version at any time. You can also promote a version, that is, make a previous version the current one. You can also delete versions if they are irrelevant or if you need to save disk space. When you delete older versions, the version numbers of the remaining versions remain the same.

The Versions And Alternates view in Bridge displays versions of all the files in a project. This view is useful for comparing versions, because all the versions are available in one place for you to view or promote—you don’t need to search your hard drive for saved files. When you want to compare details of versions, you can choose to view each version in its native application.
The commenting features of Version Cue maintain a descriptive history of files. Each time you save or promote a version, you can describe what changes you made. This history helps you track changes made at different stages. Also, your version comments are searchable; you can search for a particular word to find a version quickly.

Viewing versions in Bridge

See also
“See also
“To view file and folder thumbnails in Bridge” on page 43
“Availability of Version Cue features” on page 71

To view versions

Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

After opening a file from a Version Cue Workspace, you can quickly access the previous version thumbnails, version comments, and version dates by using the Versions dialog box.

1 In Illustrator, InCopy, InDesign, or Photoshop, choose File > Open. Click Use Adobe Dialog if you're using the OS dialog box.

2 Click Version Cue in the Favorites panel.

3 Double-click the host Version Cue Workspace. Double-click the project to open it.

4 Click the name of the file whose versions you want to view.

5 Choose Versions from the Project Tools menu .

6 In the Versions dialog box, do any of the following:
   - To create a new file version from an older version, select the version and click Promote To Current Version.
   - To open an earlier version in its own window and view details only or create a separate asset from the earlier version, click View Version. The version number appears in the file's title bar to remind you that you shouldn't edit it.
   - To delete a version, select the version and click Delete.
In Acrobat 7, you can view the Versions dialog box by choosing File > Versions when a Version Cue-managed PDF file is open.

You can view versions of a file while it's open in an Adobe Creative Suite component: Choose Versions from the status menu at the bottom of the file window.

See also

“About the Adobe dialog box” on page 73

“About Version Cue versions” on page 101

To view versions in Bridge

Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

In Bridge, you can use the Versions And Alternates view to see all versions of all files in a project.

1 Start Bridge, and then select Version Cue in the Favorites panel.

2 Choose View > As Versions And Alternates, or click the Versions And Alternates View icon (located at the lower right corner).

3 Click the Versions View button in the upper right corner of the window.

4 Double-click a project to view the files.

You can also see previous versions of a file while in other Bridge views. Right-click (Windows) or Ctrl-click (Mac OS) any file in a Version Cue project and choose Versions.

To view a previous version in its native application

Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

❖ Do one of the following:

- In the Versions dialog box, click the version you want to open and click View.

  Note: The version number appears in the file's title bar to remind you that it is not the current version and you shouldn't edit the file. The file status is Never Saved, because the previous version is only a snapshot of a previous stage of a file.

- In Bridge, use the Versions And Alternates view, click the Versions View button in the upper-right corner of the window, right-click (Windows) or Control-click (Mac OS) a version, and choose View from the menu.

Version Cue opens the previous version in its own window. You can then edit the previous version and save it as a new asset or as an alternate. If you edit the previous version, your changes won't be reflected in the current version unless you promote the earlier version.

See also

“To view versions in Bridge” on page 104

To promote a version

Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.
Promoting a previous version automatically saves a copy of that previous version as the current version. Any changes made between its creation and promotion don't appear in the new current version.

1 Do one of the following:
   • In the Versions dialog box, select the version you want to promote, and click Promote To Current Version.
   • In Bridge, using the Versions and Alternates view, click the Versions View button in the upper right corner of the window, right-click (Windows) or Control-click (Mac OS) a version, and then choose Promote To Current Version from the menu. If you have a working copy of the file, the status of the file changes to Outdated Copy until you open the file or synchronize.

2 Type a version comment in the Save A Version dialog box. Then click Continue to complete the promotion.

To revert to the last version in Bridge

Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

❖ In Bridge, choose Tools > Version Cue > Revert To Last Version.

See also
“To delete file versions in a project” on page 133
“To edit Version Cue project properties” on page 130

To delete a version

Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

❖ Do one of the following:
   • In the Versions dialog box, click the version you want to delete and click Delete. To delete multiple versions, Shift-click (Windows) or Control-click (Mac OS) the versions and click Delete. When prompted, confirm the deletion.
   • In Bridge, use the Versions And Alternates view, click the Versions View button in the upper right corner of the window, Right-click (Windows) or Control-click (Mac OS) the version, and then choose Delete from the menu.

Note that the remaining versions are not renumbered.

❖ Using the Version Cue Administration utility, you can delete multiple previous versions of all files in a project simultaneously if you have access privileges. By using this method, you can retain past versions by date or by number of versions to keep.

See also
“To delete file versions in a project” on page 133
“To edit Version Cue project properties” on page 130
“About the Version Cue Administration utility” on page 123
Version Cue alternates

About Version Cue alternates

Version Cue makes it easy to manage variations of a design through the use of *alternates*. For example, you can create alternates for variations of a design based on different versions or completely different photos for different editions of a publication.

You can use alternates in several ways. For instance, if you make extensive changes to a file, it may make more sense to save it as an alternate than a version. When you use alternates, your original file remains untouched and you're free to continue your design work in a new direction. You can also create alternates for art you're planning to use in different media, for example, a high-resolution alternate for print and a lower-resolution alternate for web use. Or, you can make alternates from files with totally different content. For example, suppose you are creating an article about fruit production. You might use a photo of an orange for the California edition, a photo of a banana for the Florida edition, and a photo of an apple for the Washington edition. You can save each photo as an alternate.

You can access alternates from Bridge or directly from the Links palette in InCopy, InDesign, or Illustrator, making it easy to present a variety of design ideas to clients and creative directors. Version Cue protects alternates the same way as other assets. When you save an alternate, it appears as a separate file in its project, but Version Cue maintains a relationship between the original file and any alternates you create.

Version Cue maintains relationships between alternates by creating *alternates groups*, which you can view together in the Alternates dialog box. You can manually group files into an alternates group by using the Make Alternates command. You create alternates from files in different folders by dragging them between Bridge windows. Using this method you can add files from additional folders to the group as well. Thus, an alternates group can contain multiple files from multiple folders. You can make an alternate the primary, or preferred, alternate in a group. The primary alternate is designated by a special status icon, and its name is in bold in the Alternates View. In the Alternates dialog box that appears in Adobe Creative Suite components and in InCopy (in the Links palette or Open dialog box), the primary alternate appears at the top of the list in the Alternates dialog box.

You can change the primary alternate and remove alternates from the group by using Bridge or the Alternates dialog box in Adobe Creative Suite components or in InCopy.

*Note:* Although you can create many alternates groups, a given file can be included in only one of these groups. Also, alternates must be located within a single project. Alternates are not available in Acrobat 7.

[Image: Viewing alternates in Bridge]
To save an alternate

**Note:** You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

If you have a file open and want to create your current work as an alternate to the previous versions, you must use the Save As command.

1. Choose File > Save As.
2. In the Save As dialog box, select the Save As Alternate option at the bottom of the dialog box.
3. Click Save, and do one of the following:
   - If you want to keep the same file name, save the alternates to a different folder.
   - If you want to save the alternate in the same folder, change the file name.

The alternate is saved in the project file.

**Note:** If you don’t change the folder or file name, Version Cue prompts you to create a new version of the file (not an alternate).

To view alternates from Bridge

**Note:** You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

To quickly see which files have alternates, use the Versions And Alternates view in Bridge. This view includes thumbnails of each alternate, shows the number of alternates, and indicates which alternate is the primary alternate in the group. From this view, you can make changes to the alternates groups.

1. Start Bridge, and then select Version Cue in the Favorites panel.
2. Click the Versions And Alternates View icon. Then click Alternates View at the top of the screen.
3. Double-click a project to view alternates. To reveal an alternate’s location, right-click (Windows) or Control-click (Mac OS) the alternate and choose Show File In Browser.

A file’s inclusion in a group of alternates is indicated by the Alternates icon and status information that displays how many alternates are associated with the file and whether the file is the primary alternate.

You can also see alternates of a file while in other Bridge views. Right-click (Windows) or Ctrl-click (Mac OS) any file in a Version Cue project Select and choose Alternates.

To view alternates

**Note:** You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.
You can identify files with alternates in the Open, Place, Save, Import, and Export dialog boxes by looking in the Alternates column, where the number of alternates is displayed. Alternates aren't available in Acrobat 7.

1. In Illustrator, InCopy, InDesign, or Photoshop, choose File > Open. Click Use Adobe Dialog if you're using the OS dialog box.

2. Click Version Cue in the Favorites panel.

3. Double-click the host Version Cue Workspace and the project containing the alternates.

4. Click the file for the alternates you want to view.

5. Choose Alternates from the Project Tools menu.

Note: You can also view alternates from the Links palette in Illustrator or InDesign, or from the status menu at the bottom of a file window while the file is open in an Adobe Creative Suite component. To view alternates from the Links palette, choose Alternates from the Links palette menu. To view alternates while a file is open in an Adobe Creative Suite component, choose Alternates from the menu at the bottom of the file's window.

To make an alternate the primary

Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

❖ Do one of the following:
   - In Bridge, click the Versions And Alternates View icon, and then click Alternates View at the top of the screen. Right-click (Windows) or Control-click (Mac OS) an alternate, and then choose Make Primary Alternate from the menu.
   - In the Alternates dialog box, select the alternate and then click Make Primary Alternate. Click Done to close the dialog box. (To learn how to access the Alternates dialog box, see “To view alternates” on page 107.)
   - In the Open, Save, Place, Import, and Export dialog boxes, right-click (Windows) or Ctrl-click (Mac OS) a file in a Version Cue project and choose Make Primary Alternate.

See also

“View alternates from Bridge” on page 107

“View alternates” on page 107

To remove an alternate

Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

❖ Do one of the following:
   - In Bridge, click the Versions And Alternates View icon, and then click Alternates View at the top of the screen. Right-click (Windows) or Control-click (Mac OS) an alternate from the group on the right side of the window, and then choose Remove From Alternates Group.
   - In the Alternates dialog box, select the alternate, and then click Remove. Click Done to close the dialog box. (To learn how to access the Alternates dialog box, see “To view alternates” on page 107.)
   - In Open, Save, Place, Import and Export dialog boxes, right-click (Windows) or Ctrl-click (Mac OS) a file in a Version Cue project and choose Remove Alternate.
See also

“To view alternates from Bridge” on page 107
“To view alternates” on page 107

To use the Make Alternates command

Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

When you use the Make Alternates command, you can make different files alternates of each other in an alternates group. You can select multiple files from more than one folder to make alternates.

1 In Illustrator, InCopy, InDesign, or Photoshop choose File > Open.

2 Navigate to the project containing the files you want to make alternates.

3 Shift-click or Control-click to select the files you want to make alternates. To view files in more than one folder, click the triangle to the left of the folder name.

4 Right-click (Windows) or Control-click (Mac OS) one of the selected files, and then choose Make Alternates from the menu.

Note: Although it is possible to reveal files in different projects by using the disclosure triangles, only files within a single project can be made alternates of each other.

See also

“To view alternates from Bridge” on page 107
“To view alternates” on page 107

To make alternates in Bridge

Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

When you make alternates in Bridge, you can make different files alternates of each other in an alternates group. Alternates are not available in Acrobat 7.

❖ To make alternates in Bridge, do one of the following:

• To make alternates from files in one folder in Bridge, navigate to the project containing the files you want to make alternates. In the Bridge window, Shift-click or Control-click to select the files you want to make alternates and choose Tools > Version Cue > Make Alternates.

• To make alternates from files in multiple folders in Bridge, navigate to the project containing the files you want to make alternates, and click Alternates View in the upper right corner of the Bridge window. If Alternates View doesn’t appear, click Versions and Alternates View in the lower right corner of the window.) Choose File > New Window, and navigate to a different folder in the same Version Cue project. Shift-click or Control-click to select the files you want to make alternates, and drag them to the right of the larger thumbnail showing the file being viewed in the Alternates view of the first Bridge window.

• To make alternates from a past version of a file in Bridge, navigate to the project containing the file you want to make an alternate. Right-click the file and choose View. When the file opens in its native application, choose File > Save As, and either save the file in a different folder or change the file name. Select Alternates, and then click Save.
**See also**

“To view alternates from Bridge” on page 107

“To view alternates” on page 107

**To move an alternate to another alternates group**

*Note:* You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

A file cannot be a member of more than one alternates group. To move an alternate to another group, you must first remove it from its original group and then add it to a new group.

1. Remove the alternate from its group. For instructions, see “To remove an alternate” on page 108.

2. Add the file to a new alternates group. For instructions, see “To save an alternate” on page 107 or “To make alternates in Bridge” on page 109.

**Editing and synchronizing offline files**

**Editing and synchronizing offline files**

When you need to work on files from a Version Cue project while the Version Cue Workspace is unavailable on the network, you can edit working copies on your computer. When the Version Cue Workspace is available again, you must synchronize your files with the workspace to save your latest version to the Version Cue Workspace. You can synchronize an entire project, just a folder in the project, or a selected file.

Working copies are normally copied on your computer when you open a project from an online workspace. However, if you haven't yet edited the file, you can prepare to work offline by synchronizing the entire Version Cue project, or just the files you need, while the workspace is still online to ensure that you have working copies.

When you are working offline, you can't create multiple versions because the Save A Version command is unavailable.

In Version Cue CS2, if you intend to work on a file offline, you can manually mark the file In Use before you take your work offline. When you mark a file In Use, Version Cue creates a working copy of the file for you. (You can mark a file In Use even if you don't intend to work offline.) Typically, when you're editing a file, In Use appears when other users access a file. When a file's status is In Use, Version Cue protects the file. When you synchronize your file, the status of the file returns to Synchronized. Mark In Use is not available in Acrobat 7.

*If you have edited an offline file recently, you can open it from the File > Open Recent menu.*

**See also**

“Availability of Version Cue features” on page 71
To manually mark a file as In Use

**Note:** You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

1. Do one of the following:
   - In Bridge, click Version Cue in the Favorites panel. Navigate to the file. Select one or more files. Right-click (Windows) or Ctrl-click (Mac OS) a file, and then choose Mark In Use.
   - In Illustrator, InCopy, InDesign, or Photoshop, choose File > Open. Click Version Cue in the Favorites panel, and then navigate to the file. Select one or more files. Right-click (Windows) or Control-click (Mac OS) a file, and then choose Mark In Use. (Mark In Use is not available in Acrobat 7.)

2. When you finish editing the file offline and the Version Cue workspace is again available, synchronize the file in Bridge or in any Adobe Creative Suite component. Version Cue automatically creates a new version of the file. If the workspace becomes available while you still have the file open, simply save a version.

If you haven’t made any changes, you can manually cancel the In Use By Me status, by choosing Cancel Mark In Use from the context menu.

**See also**

“To synchronize files” on page 112

“To synchronize files in Bridge” on page 112

To edit working copies of files from an offline project

**Note:** You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

For information on editing offline files in Acrobat 7, see Acrobat Help.

1. In Illustrator, InCopy, InDesign, or Photoshop, choose File > Open. Click Use Adobe Dialog if you’re using the OS dialog box.

2. Click Version Cue in the Favorites panel.

3. Double-click the host Version Cue Workspace.

4. Double-click the Version Cue project that contains the file. It may take Version Cue a few seconds to verify that a Version Cue Workspace or project is unavailable.

5. Double-click a file to open it (the Offline Copy status allows you to open the file).

6. When you finish editing the file, choose File > Save to save the changes to the working copy. When the Version Cue Workspace becomes available again, synchronize your files.

**See also**

“Editing and synchronizing offline files” on page 110

“To synchronize files” on page 112

“To synchronize files in Bridge” on page 112
**To synchronize files in Bridge**

*Note:* You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See "Availability of Version Cue features" on page 71 for more information.

1. Start Bridge. In the Favorites panel, click Version Cue.
2. Double-click Workspaces.
3. Select the project that contains the master file, and do one of the following:
   - To synchronize the entire project, right-click (Windows) or Control-click (Mac OS) the project, and then choose Synchronize.
   - To synchronize a file in the project, open the project, right-click (Windows) or Control-click (Mac OS) the folder or file, and choose Synchronize from the Project Tools menu.
4. If the master file on the Version Cue Workspace is newer than your working copy and you've edited the working copy, a File Conflict dialog box appears. Specify one or more of the following:
   - **Apply The Following Action To All Subsequent Conflicts**  Automatically applies the selected option every time there is a file conflict.
   - **Save A Version**  Saves your working copy as a new file version to the Version Cue Workspace.
   - **Skip This File**  Prevents the most recent version from the Version Cue Workspace from being downloaded. (This option also prevents a version of your working copy from being saved to the workspace.) Choose this option only if you want to keep your edits and disregard the other changes in the master file.

**To synchronize files**

*Note:* You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See "Availability of Version Cue features" on page 71 for more information.

For information on synchronizing files in Acrobat, see Acrobat Help.

1. In Illustrator, InCopy, InDesign, or Photoshop, choose File > Open. Click Use Adobe Dialog if you're using the OS dialog box.
2. Click Version Cue in the Favorites panel.
3. Select the project that contains the master file, and do one of the following:
   - To synchronize the entire project, choose Synchronize from the Project Tools menu.
   - To synchronize just a folder or one or more files, open the project, select the folder or files that you want to synchronize, and choose Synchronize from the Project Tools menu.
4. If the master file on the Version Cue Workspace is newer than your working copy and you've edited the working copy, a File Conflict dialog box appears. Specify one or more of the following:
   - **Apply The Following Action To All Subsequent Conflicts**  Automatically applies the selected option every time there is a file conflict.
   - **Save a Version**  Saves your working copy as a new file version to the Version Cue Workspace.
   - **Skip This File**  Prevents the most recent version from the Version Cue Workspace from being downloaded. (This option also prevents a version of your working copy from being saved to the workspace.) Choose this option only if you want to keep your edits and disregard the other changes in the master file.
Using Version Cue in GoLive

Creating or opening Version Cue projects

Working with Version Cue projects in GoLive is a bit different than in other Adobe Creative Suite components. In GoLive, Version Cue projects contain website files. You can create blank Version Cue projects in GoLive, or you can use existing files, or an existing GoLive site, to create a project. You can also add GoLive site files to an existing Version Cue project. You work with Version Cue-managed files in the site window, just as you do with non-Version Cue files.

When you create a Version Cue project in GoLive, the standard GoLive site folders (web-content, web-data, and web-settings) and a site project file (.site) are created on the Version Cue Workspace. The web-content folder is the root folder of the website and contains master files that are kept on the Version Cue Workspace.

When you mount or connect to a Version Cue project, a full copy of the project is copied to your computer (the .site file, web-content, web-data, web-settings folders). This copy ensures that the project is always available on both the host Version Cue Workspace and your computer. This workflow allows you to publish the site project from either your local computer or the Version Cue Workspace.

At any time you can synchronize your working copies to the Version Cue project to make sure that they are up to date. It’s important to synchronize on a regular basis to make sure that you always have the latest files from the Version Cue Workspace.

See also

“Using working copies” on page 84
“Getting the most out of Version Cue” on page 72
“About GoLive sites” on page 145
“To put an existing site under version control” on page 151
“Availability of Version Cue features” on page 71

To create a new blank Version Cue project

Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

1 In GoLive, choose File > New.
2 Click Site.
3 Select Create Site.
4 Select Blank Site, and click Next.
5 Specify the name and the destination location of the new site, and then click Next.
6 When asked whether you want to use a version control system, click Use Version Control, and then choose Version Cue from the Version Control System menu. Do any of the following:
   • Accept the server displayed in the Server text box, or click the triangle next to the server box and choose a new server from the menu.
   • Type a project name in the Project box.
• Accept the user name, or type a new name in the Username box.
• Leave the Port set to 3703.
7 Click Next.
8 Set publish server options as described in GoLive Help.
9 Click Finish to create the new project.

You can put an existing site under Version Cue control. See GoLive Help.

See also
“To create a new blank site” on page 146
“To add an existing file to a site” on page 156
“To put an existing site under version control” on page 151
“To create a site from a local folder of existing files” on page 147
“To create a site from a site sample” on page 147

To mount a project

Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

Before you begin working with an existing Version Cue project in GoLive, you need to mount the project on your computer, which creates a GoLive site (including the .site file, the web-content folder, the web-data folder, and the web-setting folder) for the project. If you've already mounted and created a site file for a Version Cue project, choose File > Open to open the .site file on your local computer.

1 Choose File > Connect To Version Cue.
2 To display the list of projects in a Version Cue Workspace, click to the left of the workspace hosting the Version Cue project that you want to open.
3 Select the Version Cue project.
4 To specify a location for the working copy of the Version Cue project, click Browse, select a location, and click OK. (If you've already opened this project in GoLive or any other Adobe Creative Suite component, the Browse option isn't available.)
5 Click OK.

Note: To subsequently open the site window and work with the project, you can open the *.site project file on your computer.

See also
“To connect to a version-controlled project on an HTTP or FTP server” on page 150

Logging into Version Cue

Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.
You may be asked to log into the Version Cue Workspace when you use the GoLive Site Creation wizard either to create a new Version Cue project or to access an existing Version Cue project, even if the Version Cue project doesn't require users to log in.

When prompted, do any of the following:

- If you have a Version Cue user ID and password, enter them in the Username and Password boxes.
- If you want to log in as the system administrator, enter system in the Username box and the system password in the Password box. (The default system password is system).
- If you don't have a Version Cue user ID and password, enter the user name you use on your current computer and leave the Password box blank.

**To change your Version Cue user ID**

*Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.*

1. With the site window open in GoLive, choose Site > Version Control System > Change User.
2. In the Change User dialog box, enter a user ID and password.
3. Click OK.

**Viewing Version Cue information in the site window**

The GoLive site window displays additional Version Cue information. In addition to the User Activity tab, the Files tab contains a Version Status column and an Alternates column, and the Extras tab displays the site folders as well as the Version Cue project's Documents folder when the project contains files from Illustrator, InDesign, Photoshop, Acrobat 7, or any non-Adobe application.

**Files** The Files tab in the Version Cue site window displays all the files in the Version Cue project that you have downloaded to your local computer when you synchronized. Working copies of the site files are kept in the Version Cue project site folder on your computer. The Status column indicates the current state of the file, for example, if a file contains broken links, or if the file is empty, or if the file is missing from the web-content folder. The Version Status indicates the status of your working copy in relation to the Version Cue master file; for example, if your working copy is outdated because a newer version exists, or if there is an editing conflict. The Alternates tab lists the number of alternates for each file.

**User Activity** The User Activity tab in the Version Cue site window lists all Version Cue users who have accessed the Version Cue Workspace, as well as their activities.

**See also**

“Availability of Version Cue features” on page 71

**To display user activity**

*Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.*
In GoLive, you can display a list of all the users and their file activities in the site window.

1. Do one of the following:
   - Click the Show User Activity icon in the Version Cue toolbar.
   - Click the User Activity tab in the site window.
   - Choose Site > Version Control System > Show User Activity.

2. Any files that a user is editing are listed under that user’s ID. Click next to a user ID to see a list of files that the user is editing.

**To change Version Cue site settings**

*Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.*

1. With the site window open in GoLive, click Open Site Settings Dialog in the toolbar.
2. In the Site Settings dialog box, click Version Control.
3. To change the user ID and password you use to access the project, enter them in the Username and Password boxes.
4. Do any of the following:
   - Accept the server displayed in the Server text box, or click the triangle next to the server box and choose a new server from the menu. If you change the server, any links between your local copies and the host workspace are cut.
   - Type a project name in the Project box.
   - Accept the user name, or type a new name in the Username box.
   - Type a password in the Password box to save your information. This saved you from having to enter your password manually each time login is required.
   - Leave the Port set to 3703 (which is the default Version Cue port).
   - Select Multiple Checkout Is Allowed to let more than one user work in the file. Deselect the option to disallow. This option is unavailable if the project is created on a private workspace.
   - Select Detailed Synchronization Report to view information about synchronizations. Deselect the option to skip the report.
5. Click OK.

**Working with files and versions in a Version Cue site**

When you open a Version Cue project in GoLive, in the site window the Files tab displays the files and folders you downloaded from the project on the Version Cue Workspace. When you want to edit a file, you need to use the Mark In Use command. When you mark a file in use, other users are informed that you’re editing the file. Or you can simply begin editing a file; Version Cue automatically prompts you to check the file out.

As you work, use the File > Save command periodically to save your changes. Then, you should save a version when you want to create the snapshot of the file. Saving a version uploads your changes to the master file on the host workspace. Versions allow you to step through changes. When you make a change, like changing the color of the background, for example, saving a version allows you to go back to the previous version without damaging your file.
The status of a file is displayed with an icon in the status area in the lower left of the document window, and in the Version Status column of the site window's Files tab. The status changes as you save a version. When you finish editing a file from a Version Cue site, you need to save the file to the Version Cue site folder using the File > Save command, and then save a version of the file to the Version Cue Workspace by using the Site > Version Control System > Save A Version command.

Note: The maximum size for a single file in a Version Cue project is 2 GB.

See also

“Availability of Version Cue features” on page 71

To add files to a Version Cue site

Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

You can use any method of adding files to a GoLive site to add files to a Version Cue site. When you add files to a Version Cue site, the files are added to the local site web-content folder, and the new files must be synchronized to the Version Cue Workspace. When you synchronize the added files, you can use the version comment to provide information about the file or project, which can be searched by using the Version Cue search feature. When you add a new file, the file's status is Only Copy until you save a version.

1 Use any method of adding files to a site.

2 Do one of the following to synchronize the added files:
   • Click Synchronize With Version Control System in the toolbar to synchronize the entire project.
   • Select the file or files, and then choose Site > Version Control System > Synchronize Selection.
   • Select the file or files, and then choose Site > Version Control System > Save An Initial Version.

3 Do one of the following:
   • If the Synchronize dialog box appears, click OK to synchronize the files.
   • If the Save A Version dialog box appears, enter any comments, and then click OK.

See also

“To synchronize a site” on page 153

“To create a new page in a site” on page 154

“To add an existing file to a site” on page 156

“To perform a synchronized upload for an entire site” on page 443

Using the version control toolbar

The version control toolbar in GoLive gives you easy access to commonly used commands. You can mark files In Use, save a version, synchronize a file, view user activity, show information about all versions of a file, and compare the source code of web page versions from the toolbar. If you don't see the toolbar, you can access it from the Windows > Toolbar menu.
The Version Control toolbar contains the following buttons:

**Mark In Use** 
Marks one or more selected files in use, or marks the currently open active document in use.

**Save A Version** 
Saves the local version of a file as a new version to the Version Cue Workspace, and removes your ID from the file on the workspace.

**Cancel Mark In Use** 
Discards any changes to one or more files, reverts the file to the most recent file version, and removes your user ID from the file's Version Cue edit status on the host Version Cue Workspace.

**Synchronize With Version Control System** 
Synchronizes the working copy with Version Cue Workspace.

**Compare To Latest Version On Version Cue** 
Reports that a working copy is identical to the file on the Version Cue Workspace or displays the source code for working and Version Cue Workspace file versions of a web page in the Compare Local Version to Latest Version dialog box.

**Versions** 
Displays a summary of a file's versions, including version thumbnails, version comments, and version authors. Also allows you to compare the source code of two versions of a web page or a web page version and a working copy, and create a new version based upon an existing version.

**Show User Activity** 
Displays the User Activity tab in the Version Cue site window, which lists the project's users and any files each user is editing.

**See also**

“To view versions” on page 120

“Availability of Version Cue features” on page 71

**Editing and saving versions**

Before you edit a file in GoLive, you need to use the Mark In Use command to lock the file. You can use the Version Control toolbar to manually mark a file In Use to edit in GoLive, or you can open and begin editing a file and mark the file in use when prompted by Version Cue. When the file opens, In Use By Me appears at the end of the file name.

While you edit a file, your changes affect only the working copy in the web-content folder on your computer until you save a version. Saving a version updates the master file on the Version Cue Workspace, and removes the lock on the workspace so other users can access the file.

**See also**

“Availability of Version Cue features” on page 71
To edit a Version Cue file

Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

1. In GoLive, choose File > Open, select the site project file for the Version Cue project, and click Open.

2. With the project site open, select one or more files in the Files tab of the site window and do one of the following:
   - Click Mark In Use in the Version Control toolbar
   - Choose Site > Version Control System > Mark In Use

3. Open the file and edit it. As you edit, use the File > Save command to save your work on the local copy. You can save versions as necessary, however, saving a version removes your lock on the file. To continue editing, mark the file in use again.

   If you open a file without first marking it in use, Version Cue prompts you to do so when you attempt to edit the file.

To save a version to the Version Cue Workspace

Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

1. In GoLive, open and edit a file.

2. Do one of the following:
   - Click Save A Version in the Version Control toolbar
   - Choose Site > Version Control System > Save A Version.

To synchronize files

Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

Synchronizing files in GoLive is important because it ensures that your local working copies and the files on the Version Cue Workspace are kept up to date. The Synchronize dialog box gives you options to download and upload files.

1. Do one of the following:
   - To synchronize all edited files, click Synchronize With Version Control System in the toolbar.
   - To synchronize selected files, select one or more files and click Synchronize With Version Control System, or choose Site > Version Control System > Synchronize Selection.
   - To synchronize all files, choose Site > Version Control System > Synchronize All.

2. When the Synchronize dialog box appears, click OK, or select another synchronization action for the file.

3. In the Save A Version dialog box, if you'd like, type a comment in the text box. Click OK.

See also

“To synchronize a site” on page 153
To view versions

Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

The Versions dialog box in GoLive displays all versions, version comments, version authors, and version dates for any file in a Version Cue site in GoLive. You can open any version in a new window, compare the source code of a working copy to the code of the master file on the Version Cue Workspace, and create a new version based on an existing version.

1 With the site window open in GoLive, do one of the following:
   • Open the file and click Versions in the Version Control toolbar.
   • Select the file in the site window, and click Versions in the Version Control toolbar

2 Do any of the following in the Versions dialog box:
   • To compare the source code of a working copy to the source code of the master file, select the version, and click Compare To Local.
   • To compare the source code of two web page versions, select both versions, and click Compare Selected Versions.
   • To open a version in its own document window, select the version, and click View Version.
   • To create a new file version from an older version, select the version, and click Promote To Current Version.
   • To close the Versions dialog box, click Done.

To compare a working copy to the master file

Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

1 In GoLive, choose File > Open, select the site project file for the Version Cue project, and click Open.

2 Do one of the following:
   • Open the file.
   • Select the file in the site window.

3 Do one of the following:
   • Click Compare To Latest Version On Version Cue in the toolbar
   • Choose Site > Version Control System > Compare To Latest Version. Right-click (Windows) or Ctrl-click (Mac OS) the file and choose Compare to Latest Version from the context menu.

4 In the Compare Local Version To Latest Version dialog box, differences between the working copy and master file are highlighted. In the dialog box, do any of the following:
   • To remove blank lines from the view, select Skip Empty Lines.
   • To visually parse the code, select Show Different Colors to make it easier.
   • To remove lines that are exactly the same in the working copy and master file from the view, select Hide Identical Lines.
   • To scroll through each window separately, deselect Synchronize Scrolling.
   • To click through the highlighted differences, click Next Difference or Previous Difference.

5 When you’re finished, click Close.
To create an alternates group

**Note:** You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

In GoLive, you can create alternates groups of files in Version Cue. To make an alternates group, each file must have a version available on the workspace.

1. Select at least two files that you'd like to use to create an alternates group.
2. Choose Site > Version Control System > Alternates > Make Alternate.

**See also**

“About Version Cue alternates” on page 106

To view alternates

**Note:** You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

1. In GoLive, click the name of the file whose alternates you want to view.
2. Choose Site > Version Control System > Alternates > Show Alternates.

**See also**

“To view alternates from Bridge” on page 107

To work with alternates

**Note:** You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

❖ In GoLive, select the alternate, and then do one of the following:
   - To make the alternate the primary, choose Site > Version Control System > Alternates > Make Primary Alternate.
   - To remove the alternate, choose Site > Version Control System > Alternates > Remove Alternate.

**See also**

“Working offline in a Version Cue site” on page 107

To view alternates from Bridge

If the Version Cue Workspace is turned off or you can't access the workspace on a network, you can edit working copies in a GoLive Version Cue site on your computer. Because you have working copies of all the project files on your computer, your workflow isn't impaired.

Before working on a file offline, synchronize the project to make sure that you have the latest files, and then use the Mark In Use command to edit the files. The Mark In Use command not only synchronizes the file before you edit it but also alerts other users that you intend to work in the file. When you mark the file manually, the Version Cue Workspace protects it. After using the Mark In Use command, choose the Work Offline command to update the files' status on the workspace. When the Version Cue Workspace is available to you again, you can synchronize the files to save new versions to the Version Cue Workspace.
While working offline, you won’t be able to get any updated Version Status information. You also can’t mark an offline file In Use or save a version to the Version Cue Workspace. Also, while offline, you can’t use Alternates features. However, because you have all the site files on your computer, you can publish files to the Publish Server even when you’re working offline. By default, when choosing Site > Publish Server > Upload Selection/Modified Files/All, the files will be uploaded from your local computer to the Publish Server. It’s especially important to synchronize before you go offline if you’d like to publish from your working copies. Synchronizing ensures that you have the latest versions (any changes to files on the Version Cue Workspace since you last synchronized are not reflected in your working copies), and that the site on the host workspace is in sync with the site on the Publish Server.

See also
“Editing and synchronizing offline files” on page 110
“Availability of Version Cue features” on page 71

To work offline with a Version Cue project

Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

❖ In GoLive, do one of the following:
• Select the files you’d like to work with offline in the site window, and click Mark In Use in the Version Control toolbar. The files are marked In Use By Me in the workspace and a copy of each selected file is added to the site’s web-content folder on your computer.
• Choose Site > Version Control System > Work Offline to work on your local copies without access to the host Version Cue Workspace. The master files remain available to other users.
• To download one or more files without checking them out, select the files in the site window, and choose Site > Version Control System > Force Download. A copy of each selected file is added to the site’s web-content folder on your computer, and the file remains available for all—so other users can change the files without regard to your edits.

To view, restore, or delete files deleted from the server

Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 71 for more information.

In GoLive, you can restore or permanently delete deleted files from Version Cue. The two step deletion process avoids accidental deletion. When you restore a file, it is returned to its previous location in the project.

1 With the site window open, choose Site > Version Control System > Deleted Server Files.
The Deleted Files dialog box appears.

2 Select the deleted file in the dialog box, and then click the triangle at the bottom right of the icon in the Action column and choose one of the following:

Restore On Server Restores the file to its previous position in the project hierarchy.

Restore On Server And Download Restores the file and save a working copy of the file on your computer.

Delete Permanently Completely removes the file from the project.

GoLive automatically restores the file to its original location in the site. Refresh the site view (Site > Refresh View) to ensure that all files are correctly displayed.
The Version Cue Administration utility

About the Version Cue Administration utility
Using the Version Cue Administration utility, you can do more advanced tasks that affect a specified project or an entire Version Cue Workspace.

The following table lists the Version Cue-related tasks that you can accomplish through an Adobe Creative Suite component and those that you can accomplish through the Version Cue Administration utility.

<table>
<thead>
<tr>
<th>Task</th>
<th>Adobe Creative Suite components</th>
<th>Version Cue Administration</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create, edit, and delete Version Cue projects</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Share a project with anyone who is using Adobe Creative Suite, an Adobe Creative Suite component, or a WebDAV-enabled application</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Delete a file version</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Delete multiple file versions at once</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Create Version Cue projects from remote files via FTP</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Create Version Cue projects from remote files via WebDAV</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Import Version Cue 1.0 projects</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Back up Version Cue projects and restore backup versions of a project</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>View the amount of disk space a project uses, its lock protection status, its creator, and its creation date</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Duplicate or export Version Cue projects</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Edit Version Cue Workspace preferences</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Add and edit users, and define their project privileges</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Change the properties of a Version Cue project to require users to log in before accessing it</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>View all users and their privileges for all projects in the Version Cue Workspace</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Task</td>
<td>Adobe Creative Suite components</td>
<td>Version Cue Administration</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>---------------------------------</td>
<td>-----------------------------</td>
</tr>
<tr>
<td>Remove all In Use locks in a project or those created by a specified user</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>View Version Cue Workspace logs and reports</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Add files to an existing project</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Create file versions</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>View file comments and other information</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Search for files using file information (metadata)</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Initiate and manage a web-based review of PDF files in Version Cue projects</td>
<td>No</td>
<td>Yes</td>
</tr>
</tbody>
</table>

**Logging into and out of the Version Cue Administration utility**

When you install Version Cue on your computer, Version Cue automatically creates a default user login ID with administrator privileges. You should change the password for this default user login, as it is publicly available for initial installation and setup. Until you change the default password, the default user login ID can only be used directly from the computer the Version Cue workspace is located on, not across a network. If the Administration utility is installed on your computer, you can start using the web-based Version Cue Administration utility with the Version Cue default login ID (system) and password (system).

Users working in a group with a login ID and password can log into the Version Cue Administration utility. The tasks that workgroup users can perform are limited by the privileges assigned to their Version Cue login ID by the administrator. However, users whose access level is set to None can’t log into the Version Cue Administration utility.

You can display the Version Cue Administration login web page in the following ways:

- By opening the Version Cue preferences and clicking the Advanced Administration button.
- By clicking the Advanced Administration button in GoLive CS2, Illustrator CS2, InCopy CS2, InDesign CS2, Photoshop CS2, or Acrobat 7.
- By typing the IP address of the Version Cue Workspace directly into a web browser.
- By selecting Advanced Administration from the Version Cue system tray icon (Windows) or the Version Cue menu (Mac OS).

**See also**

“Choosing user privileges” on page 137
To log into Version Cue Administration from an Adobe Creative Suite component
You can log in the same way from InCopy CS2, InDesign CS2, Illustrator CS2, Photoshop CS2, and Acrobat 7.

1. Choose File > Open, and click the Use Adobe Dialog button in the dialog box.
2. Select the Version Cue Workspace you want to administer.
3. Choose Edit Properties from the Tools menu.
5. Type your assigned Version Cue login ID and password in the text boxes. (The default for both the ID and password is system.)
6. Click Log In.

To log into Version Cue Administration from GoLive CS
1. Open the Version Cue site file.
2. Choose Site > Version Control System > Open Version Cue Administration.
3. Type your assigned Version Cue login ID and password in the text boxes. (The default for both the ID and password is system.)
4. Click Log In.

To log into Version Cue Administration from a web browser
1. In a web browser, type the IP or DNS address of the computer on which the Version Cue Workspace is installed. Precede the address with http:// and follow it with a colon and the port number, for example, http://153.32.235.230:3703 (IP) or http://myserver.mycompany.com:3703 (DNS). The default port number is 3703.
   Note: If you have Version Cue 1.0 installed on your computer, the default port number for Version Cue 2.0 is 50800. Once Version Cue 1.0 is uninstalled, Version Cue 2.0 defaults to 3703.
2. A browser window displays the Adobe Version Cue Administration login page. Type your assigned Version Cue login ID and password in the text boxes. (The default for both the ID and password is system.)
3. Click Log In.

To log into Version Cue Administration from the Version Cue Preferences dialog box
1. Do one of the following:
   • (Windows) Double-click the Version Cue icon in the system tray. In the Edit Project Properties dialog box, click Advanced Administration.
   • (Windows) Right-click the Version Cue icon in the system tray and then choose Version Cue CS2 Preferences.
   On Windows, double-click the Version Cue icon to open the preferences dialog box.
   • (Mac OS) Click the Version Cue icon at the top of the screen, and then choose Advanced Administration from the menu.
   • (Mac OS) Control-click the Version Cue icon and choose Version Cue CS2 preferences.
On Mac OS, choose Version Cue CS2 Preferences to open the preferences dialog box.

2 Type your assigned Version Cue login ID and password in the text boxes. (The default for both the ID and password is system.)

3 Click Log In.

To log out of Version Cue Administration
❖ Click Log Off at the top of the page.

About Version Cue Administration integrity checks
Each time the Version Cue Workspace restarts, it performs an integrity check and performs repairs if necessary. To ensure best performance, restart the Version Cue Workspace periodically so it can perform the integrity check and self-repair.

To set Version Cue Workspace Administration preferences
1 Log into the Version Cue Administration utility.

2 Do one of the following:
   • Click the Advanced tab, and then click Preferences.
   • On the Home page, click Perform Advanced Tasks, and then click Preferences.

3 Set any of the following options:

Workspace Name  To change the Version Cue Workspace name, type a name in the text box. This name identifies the Version Cue Workspace in Adobe Creative Suite components using Version Cue.

Make This Version Cue Workspace Visible To Others.  When selected, gives other computers access to the Version Cue Workspace.

Note: If the Version Cue Workspace is installed on a Windows computer that uses a firewall and you want to share the workspace with others, make sure that TCP ports 3703 and 427 are left open and deselect the Internet Connection Firewall option (see Windows Help).

Only Grant Access To Existing Users  Specifies whether Version Cue projects are available to a user. Make sure to set access properties for each desired project and to edit the project’s list of assigned users.

Log Level  Defines the amount of information in reports generated by the Version Cue Workspace system. Choose a log level: Error to list only Version Cue Workspace errors; Warning to list workspace errors and warnings; or Info to list errors, warnings, and information about tasks performed.

Log Size  Sets the maximum size, in kilobytes, for a system report. To reduce the log file size by saving it as a compressed GZ file, select Compress Log File.
FTP Proxy  Specifies the default FTP Proxy server for users importing projects from or exporting projects to an FTP server, or publishing with GoLive to an FTP server.

HTTP Proxy  Specifies the default HTTP Proxy server for users importing projects from or exporting projects to a WebDAV server, or publishing with GoLive to a WebDAV server.

Color Scheme  Sets the background colors of the tabs.

4  Click Save, and then restart Version Cue Administration.

Migrating from Version Cue 1.0 to Version Cue 2.0
If you currently use Version Cue 1.0, you need to migrate your projects and user data to Version Cue 2.0. Keep the following in mind:

- Version Cue 1.0 and Version Cue 2.0 Workspaces can be installed and function on the same computer simultaneously.
- If Version Cue 1.0 and Version Cue 2.0 Workspaces are installed on the same computer, Adobe Creative Suite 1.0 components work only with the Version Cue 1.0 Workspace, because they can communicate only with the port that the Version Cue 1.0 Workspace uses.

Note: If you uninstall the Version Cue 1.0 Workspace and then restart the Version Cue 2.0 Workspace, the Version Cue 2.0 Workspace then uses the Version Cue 1.0 Workspace's port, allowing Adobe Creative Suite 1.0 components and Adobe Creative Suite 2.0 components to work with the Version Cue 2.0 Workspace.

- If only the Version Cue 2.0 Workspace is installed, Adobe Creative Suite 1.0 components will work with it.
- Adobe Creative Suite 2.0 components work only with Version Cue 2.0 Workspaces.
- Adobe Creative Suite 1.0 components work with both Version Cue 1.0 and Version Cue 2.0 Workspaces simultaneously as long as the workspaces are not located on the same computer.
- You can import Version Cue 1.0 projects and users using the Administration utility (see “To migrate from Version Cue 1.0 to Version Cue 2.0” on page 127).

To migrate from Version Cue 1.0 to Version Cue 2.0
1  After installing Version Cue 2.0, restart the Version Cue 1.0 Workspace. The activates a migration plug-in.
2  Log into the Version Cue Administration utility.
3  Click the Advanced tab, and then click Import Version Cue 1.0 Data.
4  Select the data you'd like to migrate to Version Cue 2.0:
   - Projects and users. Click Next. Select the check box next to the name of any projects you want to import, and click Next. Then, select the check box next to the name of any users you want to import, and click Next.
   - Only projects. Click Next. Then, select the individual projects you want to import, and choose whether to import all the users assigned to those projects (at this point, you cannot select individual users; you must import either all users or no users). Click Next. If you choose to import the users, select the users you want to import, and click Next.
   - Only users. Click Next, and, in the next page, select the check box next to the name of any users you want to import.
5  When the migration process is complete, verify the information you're importing, and confirm the migration.
6 Uninstall Version Cue 1.0.

7 Restart the Version Cue 2.0 Workspace. This resets the port to allow access from both Adobe Creative Suite 1.0 and Adobe Creative Suite 2.0 components.

Creating and editing projects in Version Cue Administration

To create a new blank Version Cue project

1 Do one of the following:
   • In the Home tab, click Create A Project.
   • Click the Projects tab, and then click New.

2 In the New Project content frame, click Blank Project to create an empty Version Cue project. Click Next to display the Create Blank Project content frame.

3 Type a name for your project in the Project Name box.

4 To specify how to treat the imported content's URL encoding, choose an option from the URL Encoding menu.

5 Set any of the following options:
   - **Share This Project With Others** Gives other users access to the project. Users can be on your subnetwork, or they can be given the Version Cue Workspace IP or DNS address and port number to gain access to the Version Cue Workspace.
   - **Require Login For This Project** Ensures that only users with a Version Cue login ID and password have access to the project.
   - **Enable Lock Protection For This Project** Restricts file versioning to sequential versions.
   - **URL Encoding** Specifies how the content's URL encoding is treated. UTF-8 is the default setting.
   - **%HH Escaping** Requires that a nonsafe character be encoded as a percent symbol (%) followed by two hexadecimal digits.

6 Click Save.

7 If you chose to require login, do any of the following in the Assigned Users content frame, and then click Save:
   • Choose an option next to each user name in the Privileges column or choose an option from the Set All To menu to define each user's access. These options won't work unless you select Require Login For This Project.
   • To let a user publish the project with GoLive CS2 to a specified FTP or WebDAV server, select the check box in the Publishing Privilege column next to the user name.
To create a new Version Cue project from a folder

You can create a Version Cue project from the files in a folder on the computer where the Version Cue Workspace is installed.

1. Log into Version Cue Administration.
2. Do one of the following:
   - In the Home tab, click Create A Project.
   - Click the Projects tab, and then click New.
3. In the New Project content frame, click Import From Folder.
4. Click Next to display the Import Project From Folder content frame. If the content you're importing is a website, select Import Folder As A Website to import the content to the project's web-content folder. To specify the folder to import from, click Browse and select any file in the folder; then click Open. Alternatively, you can type the path to the desired Version Cue Workspace folder in the text box.
5. Type a name for your project in the Project Name box.
6. Set any of the following options:
   - **Share This Project With Others**  Gives other users access to the project. Users can be on your subnetwork, or they can be given the Version Cue Workspace IP or DNS address and port number to gain access to the workspace.
   - **Require Login For This Project**  Ensures that only users with a Version Cue login ID and password have access to the project. Note that if you select this option after a user gains access, the user can still gain access without logging in. Make sure that you change privileges as needed in the project's list of users.
   - **Enable Lock Protection For This Project**  Restricts file versioning to sequential versions.
   - **URL Encoding**  Specifies how the content's URL encoding is treated. UTF-8 is the default setting.
   - **%HH Escaping**  Requires that a nonsafe character be encoded as a percent symbol (%) followed by two hexadecimal digits.
   - **Comments**  Stores any remarks you type about the project.
7. Do any of the following in the Assigned Users content frame, and then click Save:
   - To define each user's access to the project, choose an option next to each user name in the Privileges column or choose an option from the Set All To menu. These options won't work unless you select Require Login For This Project.
   - To let a user publish the project with GoLive CS to a specified FTP or WebDAV server, select the check box in the Publishing Privilege column next to the user name.

To create a new Version Cue project from a WebDAV server or FTP server

1. Log into Version Cue Administration.
2. Do one of the following:
   - In the Home tab, click Create A Project.
   - Click the Projects tab, and then click New.
3. In the New Project content frame, do one of the following:
   - Click Import From WebDAV Server.
   - Click Import From FTP Server.
4 Click Next to display the Import Project From Server content frame.

5 If the content you’re importing is a website, select Import FTP/WebDAV As A Website to import the content to the project's web-content folder.
   • In the FTP Server or WebDAV Server box, specify the WebDAV server from which to import files, and type the port number in the Port box.
   • To specify a folder, type its path in the Directory box.
   • If a user name and password are required to access the server, type that information in the User Name and Password boxes.
   • To use a proxy server to connect to the server, select Proxy.

6 Type a name for your project in the Project Name box.

7 To specify how to treat the imported content’s URL encoding, choose an option from the URL Encoding menu.

8 To comply with the URL syntax requiring nonsafe characters to be encoded as a percent symbol (%) followed by two hexadecimal digits, select %HH Escaping.

9 Do any of the following, and then click Next:
   • To give other Version Cue or WebDAV users access to the project, select Share This Project With Others. (Users must either be on your subnetwork or be given the Version Cue Workspace IP or DNS address and port number.)
   • To require users to log in with a Version Cue login ID and password before accessing the project, select Require Login For This Project. If selected, this option ensures that only Version Cue users you specify can log in and access the project.

Note: If you select this option after other users have already accessed the project without being authenticated, those users can still access the project without logging into it. Make sure that you change their privileges as needed in the project's list of assigned users.

   • To restrict file versioning to sequential versions, select Enable Lock Protection For This Project.
   • To include remarks regarding the project, type them in the Comments box.

10 Do any of the following in the Assigned Users content frame, and then click Save:
   • To define each user's access to the project, choose an option next to each user name in the Privileges column or choose an option from the Set All To menu.
   • To let a user publish the project with GoLive to a specified FTP or WebDAV server, select the check box in the Publishing Privilege column next to the user name.

Note: You don't need to assign users in order to give others access to your Version Cue project. Just make sure to deselect Require Login For This Project in the project properties.

To edit Version Cue project properties

1 Log into the Version Cue Administration utility.

2 Click the Projects tab, and then click a project name.
3 Set any of the following options:

**Share This Project With Others**  Gives other users access to the project. Users can be on your subnetwork, or be given the Version Cue Workspace IP or DNS address and port number.

**Require Login For This Project**  Ensures that only users with a Version Cue login ID and password have access to the project. Note that if you select this option after a user gains access, the user can still gain access without logging in. Make sure that you change privileges as needed in the project's list of users.

**Enable Lock Protection For This Project**  Restricts file versioning to sequential versions.

**Comments**  Stores any remarks you type about the project.

**Backup Configuration**  Allows you to back up your project or edit backup settings.

4 Click Save, or click Reset to return the properties to their original values.

**See also**

“To back up a Version Cue project” on page 134

**To duplicate a Version Cue project**

Duplicate a project to start new project with the same users and privileges. Version Cue duplicates the folder hierarchy within the project structure, and you can use that as a basis for the new project. Delete any files from the duplicated project that are no longer necessary.

1 Log into the Version Cue Administration utility.

2 Click the Projects tab.

3 Select the check box next to the name of the project, and click Duplicate.

4 In the Duplicate Project content frame, type a unique name for the project.

5 Edit the project properties.

6 Click Duplicate.

**To delete a Version Cue project in the Version Cue Administration utility**

1 Log into the Version Cue Administration utility.

2 Click the Projects tab, and do one of the following:

- To delete one or more projects, select the check box next to the name of each project you want to delete.
- To delete all listed projects, select the check box next to the Project Name column label.

3 Click Delete. The Delete Project content frame appears. Click Delete again, or click Cancel to cancel the deletion.
To export a Version Cue project to your computer

You can export the most recent version of all project files from the Version Cue Workspace. You can use this export to move these files from one host computer (or server) to another or to create a package of the most recent files for output or simply to create an archive of the final versions. Version Cue still manages projects moved between computers. If you want to move a project, you should decide whether to back it up (so that all past versions are also moved) or export (so that only the current versions of project files are moved). For more information about backing up a project, see “Backing up and restoring projects in the Version Cue Administration utility” on page 133.

1 Log into the Version Cue Administration utility.
2 Do one of the following:
   • Click the Projects tab. Select the check box next to the project you want to export, and click Export.
   • Click the Advanced tab, and then click Export Project. The Export Project content frame appears. Select the project you want to export from the Project Name menu.
3 In the Export Project page, choose the name of the project you want to export, and then choose File from the Protocol menu.
4 Click Browse, and specify the folder to which you want to export the project. Select any file in the folder, and click Open.
5 Click Export.

You can also export a project by using the Version Cue preferences. For more information, see “To set Version Cue Workspace preferences” on page 74.

To export a Version Cue project to an FTP or WebDAV server

1 Log into the Version Cue Administration utility.
2 Do one of the following:
   • Click the Projects tab. Select the check box next to the project you want to export, and click Export.
   • Click the Advanced tab, and then click Export Project. The Export Project content frame appears. Choose the project you want to export from the Project Name menu.
3 In the Export Project page, choose the name of the project you want to export and then choose either FTP or WebDAV from the Protocol menu.
4 Specify the FTP or WebDAV server address in the Server Address text box. You don’t need to precede the address with the chosen protocol. If you want, you can change the default port number in the Port box.
5 To specify a folder, type its path in the Directory box.
6 If a user name and password are required to access the server, type that information in the User Name and Password boxes.
7 To use a proxy server to connect to the server, select Proxy.
8 If you are connecting to the server through a firewall, or if you specified a port other than 21, select Use Passive Mode. (This is an option only if you choose FTP in the Protocol menu.)
9 Click Export.
To remove file locks from a Version Cue project
A user with system administrator privileges or with project-specific Administer privileges can remove file locks. Removing file locks forces the removal of In Use status of files designated by specific project or by user throughout all the projects.

1. Log into the Version Cue Workspace Administration utility.
2. Click the Advanced tab, and then click Reset Locks (under Maintenance).
3. Do any of the following:
   • Choose a project from the Project Name menu.
   • Choose a user from the User Name menu.
4. Click Reset Locks to remove the specified file locks.

To delete file versions in a project
Each time you save a file version, the version is stored on the Version Cue Workspace database. This database creates a file version history that lets you quickly return to any former state of the file. Although a version history is useful, an extensive history takes up a lot of disk space and can degrade the performance of the Version Cue Workspace. It's a good idea to clean up versions to improve performance.

1. Log into the Version Cue Workspace Administration page.
2. Click the Advanced tab, and then click Remove Old Versions.
3. Choose a project from the Project Name menu.
4. To delete versions, select Delete All Versions Older Than, and then choose a month, day, and year.
5. To specify the maximum number of versions to remain in the workspace after you click Delete, select Number Of Versions To Keep, and then type a number in the text box.
6. Click Delete.

Backing up and restoring from Version Cue Administration

Backing up and restoring projects in the Version Cue Administration utility
The Version Cue Administration utility creates backups of all the information in a Version Cue project. Project backups are stored on the Version Cue file system, in the Backups folder. You can then easily restore a backup copy that represents a Version Cue project as it was on a specific date. Restored project backups do not replace the original Version Cue project; restored projects are given different project names. You can use a project backup to move a project from one Version Cue Workspace to another while retaining all the versions of that project.

You can customize a backup configuration for your projects. You can back up a project using a new configuration or an existing configuration. A backup configuration includes the ability to schedule a recurring backup for the project.
To back up a Version Cue project

The backup configuration used to back up a project is set in the Version Cue project preferences.

1. Log into the Version Cue Administration utility.
2. Click the Projects tab.
3. Select the check box next to the project name, and then click Backup.
4. In the Backup Name text box, accept the name, or type a new name.
5. Choose the project components you want to back up: Files (which is always selected), Project File Versions to back up all versions of the files, Project Metadata to back up embedded information entered in Adobe Creative Suite components, and Users/User Assignments to back up information about the users and their project privileges.
6. Click Backup. When the backup is complete, a status page appears.

See also

“To edit Version Cue project properties” on page 130

To restore a Version Cue project backup copy

1. Log into the Version Cue Administration utility.
2. Click the Projects tab.
3. Click Backup List.
4. Click the name of the backup that you want to restore.
5. In the New Project Name box, type a name that is different from those of other projects in the Version Cue Workspace.
6. Do any of the following, and then click Restore:
   - To retain the list of users that were assigned to the project, select Restore Users.
   - To retain the same privileges for each assigned user, select Restore User Assignments.
   - To add remarks, type them in the Comments box.

To create a new backup configuration

New backup configurations are created in the project’s preferences. When you create a new configuration, it becomes the default for the project.

1. Log into the Version Cue Administration utility.
2. Click the Projects tab.
3. Select the name of the project for which you want to create a new backup configuration.
5. Type a name for the backup configuration in the Configuration Name box.
6. Select what you want to back up in the Include list of options: Files (which is always selected), Project File Versions to back up all the versions of the project, Project Metadata to back up embedded information entered in Adobe Creative Suite components, and Users/User Assignments to back up information about the users and their project privileges.
7. (Optional) Add remarks to the backup file in the Comments box.
Choose an option from the Repeat menu if you want backups to occur automatically (choose Don't Repeat if you want to back up the project manually).

9 Click Save to save the new configuration and to see a list of backup configurations.

To back up all data in the Version Cue Workspace
It's important to back up projects in a Version Cue Workspace from time to time. Rather than doing this project by project, you can instead back up the complete Version Cue Workspace. You can also use this backup to move a complete workspace from one computer to another. If you restore a backup copy of the Version Cue Workspace, all current data on the workspace, including Version Cue projects, files, and versions, is replaced by the backup.

Workspace backup files are saved to the default Backups folder in the Version Cue application folder.

1 Log into the Version Cue Administration utility.
2 Click the Advanced tab, and then click Backup Version Cue Data.
3 To add remarks about the workspace backup, type them in the Comments box.
4 Click Save. After the back up is complete, click OK to view the list of workspace backups.

To replace a project with a previous backup
To replace current projects on a Version Cue Workspace with a previous version, you first restore the backup. When you do this, Version Cue Administration turns off automatically. You must restart Version Cue on the host workspace; it cannot be done remotely.

1 Log into the Version Cue Administration utility.
2 Click the Advanced tab, and then click Administer Backups.
3 Click the name of the backup you want to restore. Click Restore. The Version Cue Workspace turns off. Close the browser. (Notice that the Version Cue icon in the system tray indicates that it's off.)
4 Turn on the Version Cue Workspace.
5 Log into the Version Cue Administration utility.

Working with users and privileges

Creating and editing users
All users with a Version Cue user name and login (except those whose access level is set to None) can log into the Version Cue Workspace Administration utility. However, the tasks they can perform are limited by the privileges assigned to their user names.

To restrict the Version Cue projects that a user can access, you can edit the project's existing user names. Or, to restrict access further, you can create new Version Cue user names and assign them to a specific project. Creating new names gives you the most control over a project.

*Note: Only users who have system administrator privileges can create new user names.*
If you've configured the Version Cue Workspace to be visible to others in the Version Cue Administration utility, you don't need to create and assign Version Cue user names to let other Adobe Creative Suite or WebDAV users access your Version Cue projects and the Version Cue Workspace. The users simply need either to be on your subnetwork or be given the Version Cue Workspace IP or DNS address and port number. After a user accesses the Version Cue Workspace without using a Version Cue user name, the user name for the user's own computer is automatically added to the list of users in the Version Cue Workspace, and the password is left blank.

If you've configured the Version Cue Workspace so it grants access only to existing users, you'll need to create Version Cue user names to let other Adobe Creative Suite or WebDAV users access your Version Cue projects and the Version Cue Workspace.

**To create new Version Cue user names**

To create new user names in a Version Cue Workspace, you need system administrator privileges.

1. Log into the Version Cue Administration utility.
2. Do one of the following:
   - From the Home page, click Add A User.
   - Click the Users tab, and then click New in the content frame.
3. In the New User content frame, choose the level of access to give the user from the Admin Access Level menu:
   - **None** Denies the user access to the Version Cue Workspace Administration utility, however, the user can access Version Cue projects while working in an Adobe Create Suite component.
   - **User** Gives the user access to some administrator privileges, such as viewing other users’ information, creating new projects, and backing up and restoring projects.
   - **System Administrator** Grants the user all privileges.
4. Type the user's name in the User Name box.
5. Type a unique login in the Login box. The login is needed in Adobe Creative Suite components, if a project requires it, to log into the Version Cue Workspace Administration utility.
6. Type a password for the user in the Password box, and type it again in the Verify Password box.
7. (Optional) Type a phone number, an e-mail address, and comments in the remaining text boxes. Make sure to enter an e-mail address if the user will participate in Version Cue PDF reviews and will receive invitation e-mails.
8. To define the user's project access, choose the user's project privileges next to each project name in the Privileges column. To give the user the same privileges for every project, choose an option from the Set All To menu.
9. To let a user publish a project to a specified FTP or WebDAV server, select the check box in the Publishing Privilege column next to the project name.
10. Click Save.
To edit a Version Cue user name
To edit a user’s privileges, you need system administrator privileges.

1 Log into the Version Cue Workspace Administration page.
2 Do one of the following:
   • Click Edit Users in the Home page.
   • Click the Users tab.
3 Click the user name of the user name you want to edit.
4 Edit the user properties and privileges.
5 Click Save.

To duplicate or delete a Version Cue user name
You can duplicate a Version Cue user to set up a new user with the same project privileges as the original user. Complete this procedure, and then change the duplicate user name and login as required.

1 Log into the Version Cue Workspace Administration page.
2 Click the Users tab.
3 Select the check box next to each user name you want to duplicate or delete. To select all listed user names, select the check box next to the User Name column label.
4 Do one of the following:
   • Click Duplicate. Edit the user’s properties in the Duplicate User content frame and click Save.
   • Click Delete. To confirm the deletion, click Delete in the Delete User content frame.

Choosing user privileges
Version Cue user logins are associated with one of three levels of privilege: None, User, or System Administrator. Users with privileges set to None can’t access the Version Cue Workspace Administration utility but can access Version Cue projects while working in an Adobe Creative Suite component or an application that supports WebDAV. The following table describes the privileges associated with the User and System Administrator levels.

<table>
<thead>
<tr>
<th>Administration utility task</th>
<th>User</th>
<th>System Administrator</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create and update Version Cue user login IDs</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Read other Version Cue users’ login information</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Update own user login information excluding login ID privilege level</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Duplicate and delete user IDs</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Import and export user lists</td>
<td>No</td>
<td>Yes</td>
</tr>
</tbody>
</table>
To export a list of users

If you want to add a set of users to another computer with a Version Cue Workspace, you can export the list and then copy it to the UsersExport folder in the Version Cue application folder of another computer with a Version Cue Workspace.

1. Log into the Version Cue Administration utility.
2. Click the Users tab.
3. Select the check box next to each user name you want to export. To select all listed user names, select the check box next to the User Name column label.
4. Click Export List. The Export Users content frame displays the list of users to be exported.
5. Click Next, and type a name for the list in the Name box. If you like, type remarks in the Comments box.
6. Click Save. The Export Users content frame displays the list of exported users.
7. The location of the user list appears under the Export Users heading. To import this list into another Version Cue Workspace, copy this file into the destined workspace’s Data/UsersExport folder in the Version Cue application folder. Note that this folder can be moved and may be in a different location on the workspace.

To import users from a list

1. Log into the Version Cue Administration utility.
2. Click the Users tab, and then click Import List.

<table>
<thead>
<tr>
<th>Administration utility task</th>
<th>User</th>
<th>System Administrator</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create new projects (users must have Project Creation Allowed selected in their privileges)</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Delete or restore project backups</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Perform all tasks listed in the Advanced content frame</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Change the Administration utility color scheme in the Advanced preferences</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Reset locks and remove file versions from projects to which the user is assigned and also granted Administrator privileges</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Back up, delete, and restore all Version Cue Workspace data</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>View Version Cue Workspace information, logs, and reports; and save reports</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Delete reports for projects to which the user is assigned and also granted Administrator privileges</td>
<td>Yes</td>
<td>Yes</td>
</tr>
</tbody>
</table>
3 Click the name of the user list you want to import.
4 Select the check box next to each user name you want to import, or select the check box next to the User Name column label to select all listed user names.
5 Click Next.

### Viewing logs, reports, and workspace information

**Viewing Version Cue Workspace information and reports**

You can display the Version Cue Workspace version, name, licensee, serial number, Java version, database version, Version Cue client URL (IP or DNS address), WebDAV client URL, copyright, and patent information with the Version Cue Workspace Administration utility.

*Users who are working in Adobe Creative Suite can use the Version Cue Client URL to connect to Version Cue projects when they're not on the workspace's subnetwork. Users who are working in applications that support WebDAV can use the WebDAV Client URL to connect to Version Cue projects.*

You can also display and manage three kinds of reports (import, export, and publish) and the Version Cue Workspace log file, which tracks all server operations according to the level of detail you specify.

Display time varies according to the size of the log file. The default log file size is 1024K. If the log file exceeds a specified size limit, the system creates a new log file and saves the old one. Log files are saved in the Logs folder, located in the Version Cue application folder.

**To view Version Cue Workspace information**

1 Log into the Version Cue Administration utility.
2 Do any of the following:
   - Click the Home tab. Workspace information is listed under About This Workspace.
   - Click the Advanced tab, and then select Workspace Info.
   - Click About at the top of the page to display copyright and patent information. A window opens, listing information about the Version Cue Workspace.

**To view the Version Cue Workspace log file**

1 Log into the Version Cue Administration utility.
2 Click the Advanced tab, and then select Workspace Log. The Workspace Log content frame displays information about the Version Cue Workspace history.
3 Do any of the following:
   - To change the number of rows displayed, choose an option from the Rows To Display menu.
   - To navigate to a different page of the log, click Next, End, Beginning, or Previous, if available.

**To view a Version Cue report**

1 Log into the Version Cue Administration utility.
2 Click the Advanced tab, and then select Reports.
3 Choose the type of report you want to view from the Reports menu.

4 To view available reports from a single project, choose the project name from the Filter By menu. To view available reports from all projects on the Version Cue Workspace, choose All.

5 Click the project’s name in the Project Name column. The content frame displays the report. Choose options from the available menus to change how the report appears.

6 To save an HTML copy of the report to your computer, click Save, and specify a location.

7 To return to the report list, click Report List.

**To delete Version Cue reports**

1 Log into the Version Cue Administration utility.

2 Click the Advanced tab, and then select Reports.

3 Choose the type of report you want to delete from the Reports menu:
   - To delete all reports from a single project, choose the project name from the Filter By menu.
   - To delete all reports from two or more projects on the Version Cue Workspace, choose All.

4 Select the check box next to each project whose reports you want to delete. To select all project reports, select the check box next to the Project Name column label.

5 Click Delete.

**Version Cue PDF reviews**

**About Version Cue PDF reviews**

Using Version Cue you can set up and conduct web-based reviews of PDF documents that are in a Version Cue Workspace. You can invite selected reviewers by e-mail, create the e-mail message in your e-mail program, and include a direct link to the review document in the e-mail. Invited reviewers only need Adobe Acrobat software and a Version Cue login to access the PDF document using their web browser. As the review progresses, reviewers upload their comments to the Version Cue Workspace. In an open review, all reviewers can see each other’s comments in the PDF document as the review progresses.

You can specify when the review ends or stop a review at any time. When a review is complete, you can view all comments either in the context of the original document or as a list in the Version Cue Administration utility. When you view the comments in the context of the PDF document, all of the Acrobat commenting tools are available, including printing.

Version Cue PDF reviews are especially useful in the late stages of a project when there isn’t time to arrange a traditional paper-based review. They are also useful when reviewers are dispersed over a wide geographical area. Aggregated comments make it easy to summarize comments and track the progress of the review.

**Initiating a Version Cue PDF review**

You use the Version Cue Administration utility to initiate and manage a Version Cue PDF review. From the Version Cue PDF review area in the utility, you can start reviews and invite reviewers, find reviews in which you’re participating, search for review documents, view review comments (as well as filter the comments by reviewer), stop reviews, and delete finished reviews. You can also reopen completed reviews.
Keep in mind the following requirements for using Version Cue PDF review:

- To use Version Cue PDF review, reviewers need a Version Cue login name and privileges that allow them to log into the Version Cue Workspace hosting the review.
- To view the PDF and add comments, users need Acrobat 7.0 Professional. For more information about commenting in Acrobat, see Acrobat Help.
- To access a review, users need an Internet connection.

**To start a new Version Cue PDF review**

You can start a Version Cue PDF review for any version of any PDF document that is in a Version Cue Workspace, provided that you have appropriate privileges to access the Version Cue Administration utility. Only one version of a PDF document may be in active review at any point in time.

At any time, to return to the main Version Cue CS2 Review page, click the Home button 🏠. To return to Version Cue Administration, click Version Cue CS2 Administration.

1. Log into the Version Cue Administration utility. (For instructions, see “To log into Version Cue Administration from the Version Cue Preferences dialog box” on page 125 and “To log into Version Cue Administration from a web browser” on page 125.)
2. Click the Version Cue CS2 Review link at the top of the page.
3. Do one of the following:
   - In the main Version Cue CS2 Review page, click Start A Review.
   - Click the Documents tab, and choose Not Started from the Review Status menu.
4. In the Document List, click the name of the PDF document you want to review.
5. Choose the version you want to review, and then click Start Review.
6. In the Start Review page, enter review information:
   - To set an end date for the review, select Deadline, and then choose the end date from the Year, Month, and Day menus.
   - To let reviewers see each other's comments, select Open under Review Mode. Select Private if you want reviewers to see only their own comments.
   - If you want to add a description of the review, type the information in the Description box.
   - To add reviewers, select the reviewers' names in the Reviewers section (click the check box next to the Reviewers column label to select or deselect all reviewers).

**Note:** *If a reviewer is outside your everyday workgroup and doesn't have a Version Cue login, you'll need to set one up in advance. You must also provide network access—typically through a firewall—for outside reviewers.*

7. Click Next.
8. To send an e-mail invitation to reviewers, select Send E-Mail Invitation, and then modify the Mail Subject and Mail Message as desired. In the E-Mail Recipients section, choose reviewers you wish to invite by e-mail.
9. Click Start Review to activate the review.
10. If you chose to invite reviewers by e-mail, Version Cue starts your e-mail program and displays an e-mail message addressed to the reviewers. The e-mail includes a direct link to the document being reviewed. Confirm the contents of the review e-mail, and send it.
To locate PDF reviews
After you locate a PDF review, you can open it, view or delete review comments, stop or restart a review, or delete the review from the Version Cue Workspace.

1 Log into the Version Cue Administration utility.
2 Click the Version Cue CS2 Review link at the top of the page.
3 Do one of the following:
   - If you don’t know the name of the PDF document under review, or want to view all active reviews, click Active Reviews in the Home tab. Alternatively, click the Documents tab and choose Active from the Review Status menu.
   - If you don’t know the name of the PDF document for which a review has been completed, or want to view all completed reviews, click Finished Reviews in the Home tab. Alternatively, click the Documents tab and choose Finished from the Review Status menu.
   - If you want to search for a PDF document that is under review or for which a review has been completed, click Search Documents in the Home tab, and choose search criteria from the Project Name, Review Status, and List Entries menus. To find a PDF document by its name, enter the name or part of it in the Document Name field and press Search.

To set viewing options in the Document List
You can filter the Document List in the Documents tab by doing one or more of the following:

- To display only PDF documents in a specific project, choose that project from the Project menu.
- To limit the number of documents displayed, choose an option from the List Entries menu (use the arrows to the right of the List Entries menu to view additional files).
- To limit the list according to document name, enter part of a document name in the Document Name field and press Enter (Windows) or Return (Mac OS). (To view all files again, delete the text in the Document Name field and press Enter or Return.)
- To sort the list by the entries in a column, click the column heading. (Click the heading again to reverse the sort order.)

To open an active or completed PDF review
1 Locate the active or completed review (see “To locate PDF reviews” on page 142).
2 Click the PDF document name in the Document List, and then select any of the versions in the Document History list.

To stop a PDF review
1 Locate the active review (see “To locate PDF reviews” on page 142).
2 Click the PDF document name in the Document List.
3 In the Document History list, select the active review and click Stop Review.
To restart a completed PDF review
1  Locate the completed review (see “To locate PDF reviews” on page 142).
2  Click the PDF document name in the Document List.
3  In the Document History list, select the completed review and click Start Review. Adjust review settings as desired.

Note: After you click Start Review, you see a series of screens that refer to starting, rather than restarting, a review. However, this procedure does restart the review of the existing document.

See also
“To start a new Version Cue PDF review” on page 141

To delete a PDF review
When you delete a review, Version Cue permanently removes the review comments. However, review comments for a PDF file are also deleted if you permanently delete the file itself from the Version Cue Workspace. Note that if you delete only a version of a PDF file from the workspace, the review comments for that version are deleted.
1  Locate the active or completed review (see “To locate PDF reviews” on page 142).
2  Click the PDF document name in the Document List.
3  In the Document History list, select a version and click Delete Review.
4  When Version Cue prompts you to delete the review, click Delete.

See also
“Deleting files and folders” on page 97

To edit review settings
1  Locate the active or completed review (see “To locate PDF reviews” on page 142).
2  Click the PDF document name in the Document List.
3  Select one of the versions in the Document History list, and click Edit Review Settings.
4  Do any of the following:
   • To set or change an end date for the review, select Deadline, and then choose the end date from the Year, Month, and Day menus.
   • To let reviewers see each other’s comments, select Open under Review Mode. Select Private if you want reviewers to see only their own comments.
   • If you want to add or edit a description of the review, type the information in the Description box.
   • To add or remove reviewers, select or deselect the reviewers’ names in the Reviewers section (click the check box next to the Reviewers column heading to select or deselect all reviewers).
5  Click Next.
6  To send an e-mail invitation to reviewers, select Send E-Mail Invitation, and then modify Mail Subject and Mail Message as desired. In the E-Mail Recipients section, choose reviewers you wish to invite by e-mail
7  Click Save Review. If you chose to invite reviewers by e-mail, Version Cue starts your e-mail program and displays an e-mail message addressed to the reviewers. This e-mail includes a direct link to the document being reviewed. Confirm the contents of the review e-mail, and send it.
About PDF review comments

Review comments include, in addition to the text of the comment itself, information about who created the comment and when, what type of comment was created, and what page of the document the comment appears on. Different comment types are distinguished by their icons. You can use any of the Acrobat commenting tools in a Version Cue PDF review.

Version Cue stores review comments in the Version Cue Workspace. You can view comments in the Version Cue Administration utility or directly in the PDF document. To view all review comments directly in the document, you must access the document either by using the link from the review invitation or by opening the review document from the Version Cue Administration utility. (If you open the review document from the Open dialog box in Acrobat or from Bridge, the review comments aren’t visible.)

For more information about Acrobat commenting tools, search for “commenting” in Acrobat Help.

To view or delete PDF review comments

1. Locate the review (see “To locate PDF reviews” on page 142).
2. Click the PDF document in the Document List.
3. Do one of the following:
   • To view all review comments directly in the PDF document, click the version name.
   • To view review comments in the Version Cue Administration utility, select the version in the Document History list and click View Comments.
      To view any of the comments in the context of the PDF document, select a comment and then click Open In Acrobat.
   • To delete review comments in the Version Cue Administration utility, select the comment and click Delete Comments. (To select all comments, click the check box next to the Page column heading.)
Chapter 7: Setting up sites and pages

Creating sites

About GoLive sites
When you use the Site Creation Wizard to create a website, GoLive creates a site file (with the .site extension) to manage and control the site contents. GoLive also creates three folders to hold the web pages, media files, and other resource files needed for building and maintaining the site. When you create a blank site, GoLive creates a blank index.html page and a project folder that contains everything, including the three site folders and the site file.

If you name the new site Mysite, the site file is named Mysite.site. The project folder is named Mysite and contains the site file and three folders:

**Web-content** Contains web pages, image files, external cascading stylesheets, and other source files. GoLive lists the contents of the web-content folder in the Files tab of the site window and uploads the contents of the web-content folder when you upload the site to a publish server.

**Web-data** Contains reusable GoLive site assets, such as components and page template files. GoLive lists the contents of the web-data folder in the Extras tab of the site window.

**Web-settings** Stores settings you make in the site window and the Site Settings dialog box.

The site file and contents of the web-data and web-settings folders are not uploaded when you upload the site to a publish server.

GoLive site named "Mysite"

A. Project folder  B. Site file  C. Web-content folder  D. Web-data folder  E. Web-settings folder

Whether you create the site in Windows or Mac OS, the site file you create can be opened and used on both platforms.
See also
“Specifying preferences and settings for websites” on page 201

Methods for creating sites in GoLive
You can create or import sites by using any of the following methods:

Create a site from scratch You can use the Site Creation Wizard to create a blank site from which you can design your web pages from scratch either solely within GoLive or in combination with other graphics applications, like Adobe Photoshop.

Import a site from a local folder of existing files GoLive creates a new site based on a folder of existing files on your computer. GoLive uses the folder of existing files as the basis for the new site’s web-content folder, and adds new folders for the site’s web-data and web-settings files. GoLive asks you to specify a location for the site file, name it (it should always have the .site extension), and create a folder to put it in.

Create a site from a site sample GoLive creates a new site based on a site sample.

Import a site from files downloaded from a remote server GoLive creates a new site that is a copy of a site downloaded from an FTP or HTTP server. If you want to connect to a site as you work on it (not download a copy of the site, but mount the site and work on it from the server), use the following method.

Import a site from workgroup projects on a version control system GoLive connects to a server and mounts the target site on your computer. It checks in or checks out a file in your name to prevent other users from writing over your changes. Use this method when you are part of a workgroup where version control is necessary, or if you want to use version control for a single-user site, which lets you revert to previous versions.

To create a new blank site
1 Choose File > New.
2 Choose Site > Create Site.
3 Select Blank Site, and click Next.
4 Specify a name and site location. To specify how the new site will handle encoding and case sensitivity checking in URLs, click Advanced and specify options as desired. (See “Advanced URL handling options” on page 148.)
5 Click Next, and then specify Version Control options:
   • If you plan to add the site to a workgroup or want to take advantage of versioning features, select Use Version Control, choose a version control system, and specify server and user information.
   • If you don’t want to use versioning features, select Don’t Use Version Control.
6 Click Next, and then specify Publish Server options:
   • If you know the server to which you’ll publish the site, select Specify Server Now, and then enter the appropriate server information. For more information, see “To set up access to a publish server” on page 440.
   • If you don’t have server information, select Specify Server Later.
7 Click Finish.

See also
“To change version control settings” on page 154

“About version control” on page 150
To create a site from a local folder of existing files

You can also use this procedure to import sites from other applications.

Note: Because GoLive uses the folder of existing files as the basis for the new site, you may want to make a copy to import rather than use the original folder and its contents.

2. Choose Site > Create Site.
3. Select Site From Existing Content, and click Next.
4. Select From A Local Folder Of Existing Files, and click Next.
5. Click the Browse button beneath the Folder section to navigate to the local folder that contains the site files that you want to use.
6. Click the Browse button beneath the Home Page Of The New Site section to locate the home page of the existing site (if you don't specify a home page, GoLive creates a blank home page in the site's web-content folder).
7. Click Next, and then designate a location for the new site in the Specifying A Site Name And Location box. To specify how the new site will handle characters in URLs and case sensitivity, click Advanced. (See “Advanced URL handling options” on page 148.)
8. Click Finish.

To create a site from a site sample

2. Choose Site and select a samples category.
3. Select a site sample, and click Next.
4. Specify a name and location for the site. To specify how the new site will handle characters in URLs, click Advanced and specify options as desired. (See “Advanced URL handling options” on page 148.)
5. Click Next, and then specify version control options:
   - If you plan to add the site to a workgroup or want to take advantage of versioning features, select Use Version Control, choose a version control system, and specify the appropriate server and user information.
   - If you don't want to use versioning features, select Don't Use Version Control.
6. Click Next, and then specify Publish Server options:
   - If you know the server to which you’ll publish the site, select Specify Server Now, and then enter the appropriate server information. For more information, see “To set up access to a publish server” on page 440.
   - If you don’t have publish server information, select Specify Server Later.
7. Click Finish.

See also

"Importing sites from FTP or HTTP servers” on page 148
“Site samples” on page 437
“About version control” on page 150
To open a GoLive CS, 6.0, or 5.0 site
❖ Open the site in GoLive CS2. GoLive automatically updates it to a GoLive CS2 site, creating a GoLive CS2 site file, and backs up the site file.

Note: If you want to archive the entire previous site, not just the site file, copy it, archive the copy, and then open the site file of the original site.

Advanced URL handling options
Advanced URL handling options let you specify how the site handles characters in URLs. After you create the site, you can change the URL character encoding (but not the URL case sensitive checking) in the Site Settings dialog box.

Make URLs Case-Sensitive  Specifies whether the site reference links will differentiate between upper and lower case letters.

URL Encoding  Specifies the type of character encoding that you would like your site to use for its URLs. Unicode's UTF8 encoding is the most widely used, covering all major languages and platforms. Contact the administrator of the web server to which you’ll be publishing to learn which character encoding the server uses.

Win Script (Windows) or Mac Script (Mac OS)  This option is available only if you choose System Specific from the URL Encoding menu.

Apply %HH Escaping  Specifies the circumstances under which your site will replace, or escape, unallowed characters in your URLs. For example, the figure “%20” is used to escape spaces, which are not allowed in URLs.

See also
“Specifying preferences and settings for websites” on page 201

Importing sites from remote servers

Importing sites from FTP or HTTP servers
Using the Site Creation Wizard, you can create GoLive sites based on other sites imported from FTP or HTTP servers. To import sites from a remote server, you must create a single user site and download the files to your local hard disk. Once you’ve imported a remote site, you can create a site locator file that contains the login and character encoding information necessary to create the site.

Once you've created a single user site and downloaded files to your local hard disk, you can put the site under version control. See "About version control" on page 150

Accessing login information for imported sites
To create sites based on files imported from an FTP server, you need valid account information to log into the server—including the name of the server, and your FTP user name and password. Use the Advanced FTP Options dialog box in the Site Creation Wizard to either change the port number or use passive mode if the site is protected by a firewall.

To create sites by importing sites from HTTP servers, you only need access to the Internet and a valid home page URL. See your Internet service provider or system administrator for login information.
**To download sites from HTTP and FTP servers**

Using the Site Creation Wizard, you can import an entire website into GoLive, including every linked page that branches out to multiple HTTP servers and every source file (such as images) referenced by the pages. Because large sites can take a long time to download, you can restrict the number of page levels in the page-link hierarchy to import.

>Note: If you already have an ongoing workgroup project that employs version control, and you wish to continue the collaboration, connect to the existing site instead of using this procedure.

2. Select Site > Create Site.
3. Select Site From Existing Content, and click Next.
4. Select By Downloading Files From A Remote Server, and click Next.
5. Choose the server type (FTP or HTTP) from the Type Of Server menu.
6. If you are downloading from an HTTP server, specify the home page URL of the server in the URL box and then do one of the following:
   - To download only the pages that are located in the same folder (or a subfolder) that contains the home page URL, select Only Get Pages Under Same Path.
   - To download only those pages that are on the same server as the home page URL, select Stay On Same Server. GoLive downloads from other servers any source files that are referenced by the pages it downloads, whether or not this option is selected.
7. If you are downloading from an FTP server, enter the FTP server information. Click Advanced to set security and passive mode options. (See “To set up access to a publish server” on page 440.)
8. Click Next, and then specify a name and location for the downloaded files. To specify how the new site will handle encoding and case sensitivity checking in URLs, click Advanced. (See “Advanced URL handling options” on page 148.)
9. Click Finish.

GoLive imports only the pages on the levels you specify and the source files for images and other objects on those pages. GoLive converts any remaining page links that go to other levels into external URLs and lists them in the External tab of the site window. After you create the site, you can individually download the pages from these external URLs by choosing Download from a URL’s context menu.

**To download a page from an external link**

❖ Right-click (Windows) or Control-click (Mac OS) the external link in the External tab in the site window or in the In & Out Links palette, and choose Download from the menu that appears.

When you download a page and its source files from an external link, GoLive adds the page and the referenced source files (such as images) to a folder named NewFiles in the Files tab in the site window.

**See also**

“Downloading a web page” on page 446
To export a site locator file
A site locator file describes the location of a site on a remote server and lets you quickly import remote sites. It contains all the login and character encoding information necessary to create the site.

1. Open the site you want to copy.
2. Choose File > Export > Site Locator.
3. Choose a name and location for the site locator file in the Save Site Locator File dialog box, and then click Save.

To create a site by importing a site locator file
1. Connect to the Internet.
2. Choose File > Import > New Site From Site Locator.
3. Select the site locator file in the Load Site Locator File dialog box, and then click Open.
4. Specify a destination folder for the site files in the Browse For Folder dialog box, and then click OK.
5. Select files to be downloaded from the server in the Download dialog box, and click OK.

Version control sites

About version control
Workgroups can use version control to manage files and ensure that only one person at a time is working on a file. You can also use version control for a single-user site if, for example, you want the ability to revert to previous versions of your site. When you connect to a project that employs version control, you can check out or check in the target files. When you check out a file, the version control system marks it as being used and locks it from other users so they can’t edit it. When you check in a file, you save changes to the master file and unlock it so that other users may access it.

GoLive supports Version Cue and CVS version control systems. In addition, GoLive offers its own set of version control features that you can use to work with files in a versioning repository on your local hard drive or on an FTP server.

To connect to a version-controlled project on an HTTP or FTP server
2. Select Site, and then do one of the following:
   - Select Connect To Site.
   - Select Create Site, and then choose Site From Existing Content. Click Next, select By Connecting To A Project On A Version Control System, and click Next.
3. Choose Version Cue or CVS from the Version Control System menu and enter the appropriate information for that system in the Server, Project, Username, Password, and Port boxes. If you’re using CVS, choose an authoring type from the Authoring Type menu.
4. Click Next.
5. Specify a local mount location, and click Finish.
6. Follow the on-screen instructions to complete the connection process.
Once you've connected to a version controlled project in GoLive, use the commands in the Site > Version Control System menu and in the Version Control toolbar to work with version controlled files.

See also
“Toolbars” on page 30

To put an existing site under version control
1. Open the site.
2. Choose Site > Version Control System > Enable Version Control.
3. In the Version Control section of the Site Settings dialog box, select Use Version Control.
4. Choose Version Cue or CVS from the Version Control System menu.
5. Specify a server, a name for the project, a user name, your password, and port information. If you're using CVS, choose an authoring type from the Authoring Type menu.
6. Select other options as desired.
7. Click OK.

About GoLive version control
GoLive lets you create a version control workspace in a folder on the local hard drive or on an FTP server, without using third-party version control software. You can define any folder on your computer or on an FTP server as a version control workspace to which you and co-workers can check files in and out.

GoLive version control lets you check files in and out, view and track versions of files and revert to previous versions, and synchronize local files against those in the version control system. By default, files that you check in are read-only, and you can check out only one file at a time. If you try to edit a file that is part of a version controlled project, GoLive prompts you to check out the file. The Version Status column in the Files tab of the site window displays the versioning state of all files.

Note: For a full set of version control features, use Adobe Version Cue.

The GoLive version control workflow
Before you can use version control features in GoLive, you must create a version control workspace and check files in to the workspace. Once you’ve done so, you can check out files and check them back in, synchronize the site with the version control workspace, and compare and revert to different versions of version controlled files.

To create a GoLive version control workspace for an existing site
1. Open the site for which you want to create a version control workspace.
2. Choose Site > Version Control System > Enable Version Control.
3. In the Version Control section of the Site Settings dialog box, select Use Version Control.
4. Choose one of the following options from the Version Control System menu:
   • Directory in File System to create a version control workspace on the local hard drive.
   • FTP Server to create a version control workspace on an FTP server.
5 Do one of the following tasks:

- If you’re creating a version control workspace on the local hard drive, enter a name for the project, enter a user name, and reference a folder on the local hard drive in the Directory box (don’t reference the site folder—the folder in which GoLive creates a version control workspace must be separate from the site folder).

- If you’re creating a version control workspace on an FTP server, specify the server in the Server box, and specify a user name, password, directory, and project in the Access Data section. Click Advanced to set advanced FTP options.

6 Set options as desired.

7 Click OK.

To create a GoLive version control workspace for a new site

1 Choose File > New, and select Site > Create Site.

   You can also connect to an existing GoLive version control workspace: Choose Site > Connect To Site in the New dialog box.

2 In the Site Creation Wizard, choose Blank Site.

3 Follow the on-screen instructions until GoLive displays the Use A Version Control System window. Select Use Version Control.

4 Choose one of the following options from the Version Control System menu:

- Directory in File System to create a version control workspace on the local hard drive.

- FTP Server to create a version control workspace on an FTP server.

5 Do one of the following tasks:

- If you’re creating a version control workspace on the local hard drive, type a name for the project in the Project box and reference a folder on the local hard drive in the Directory box (don’t reference the site folder—the folder in which GoLive creates a version control workspace must be separate from the site folder).

- If you’re creating a version control workspace on an FTP server, specify the server in the Server box, and specify a user name, password, directory, and project name. Click Advanced to set advanced FTP options.

6 Click Next, and follow the on-screen instructions to complete the site creation.

To perform an initial check-in

Once you’ve created a version control workspace, you must check in all the site files to the version control workspace.

1 Choose Site > Version Control System > Check In All.

2 In the Version Control File Checkin dialog box, select the files you want to check in and click Check In (to use version control for the entire site, select all files).

To check out a file

❖ Select a file and do one of the following:

- Choose Site > Version Control System > Check Out.

- Click the Check Out button ✏️ in the Version Control toolbar.
GoLive displays the In Use By Me icon in the Version Status column of the Files tab in the site window. To undo a checkout, choose Site > Version Control System > Undo Check Out or click the Undo Check Out button in the Version Control toolbar.

**To check in a file**

1. Select a file and do one of the following:
   - Choose Site > Version Control System > Check In.
   - Click the Check In button in the Version Control toolbar.

2. In the Version Control File Checkin dialog box, click Check In.

**To synchronize a site**

You can synchronize the local site with the latest versions of files in the version control workspace.

You can also choose Site > Version Control System > Force Download to replace the local copy of a file with the latest version of a file from the version control workspace.

1. Choose Site > Version Control System > Synchronize All, or click the Synchronize With Version Control System button in the Version Control toolbar. The Synchronize With Version Control System dialog box indicates which files will be uploaded to the version control workspace, which files will be downloaded to the local copy of the site, and which files will be deleted.

2. Do any of the following tasks:
   - To display files that aren't selected for synchronization, select Show Skipped Items.
   - To view the files as they exist on the server in folders, select Show Folder Structure.
   - To display detailed information about a file, select it. GoLive displays local and version control workspace information about the file in the two text areas at the bottom of the dialog box.
   - To exclude a synchronization action, deselect it in the Perform Actions section. For example, deselect Deletions to prevent GoLive from deleting any files during the synchronization.

3. In the Synchronize With Version Control System dialog box, confirm the synchronization actions assigned to individual files. If you want to assign a different synchronization action to a file, select the file and cycle through the synchronization options by clicking the Synchronization Action icon displayed in the column next to the file:
   - Upload to upload the file to the version control workspace.
   - Download to download the file from the version control workspace to the local site.
   - Delete to remove the file.

4. Click OK to start the synchronization process.

**To compare a file to the checked in version in the version control workspace**

Select a file and choose Site > Version Control System > Compare to Server Version.
To compare checked in versions of a file
1 Select a file and choose Site > Version Control System > Show Versions, or click the Show Versions button in the Version Control toolbar. GoLive displays thumbnails of all checked in versions of a file in the Versions Of [File Name] dialog box.

2 Do one or more of the following tasks:
   • To view a full-sized version of the file, select it and click View Version.
   • To compare a version of the file to the local version, click Compare To Local. GoLive displays the Compare Versions To Local window with the checked in version and the local version.
   • To promote an older version of the file to the current version, click Promote To Current Version.
   • To compare selected versions, Shift-click to select multiple versions of a file and then click Compare Selected Versions. GoLive displays the Compare Versions window with the selected versions.

To show user activity
❖ Click the Show User Activity button in the Version Control toolbar. GoLive displays user names and a list of files each user has checked out in the User Activity tab in the site window.

To change version control settings
You can change the version control settings of any site that you are working on.
1 With a site open, choose Site > Version Control System > Settings.
2 Make changes to the fields in the Version Control Settings dialog box and click OK.

To stop using version control for a site
1 With the site open, choose Site > Version Control System > Settings.
2 Deselect Use Version Control, and click OK.

Adding files to sites

To create a new page in a site
You can create documents in a variety of special formats, including XHTML, QuickTime, Real, and SMIL. You can create a new HTML document based on a page template or stationery that you’ve set up for the site, or create a text document, cascading stylesheet, or JavaScript file. The Web section of the New dialog box lists many page template samples on which you can base new pages.
Note: When you create a special HTML, XHTML, MMS, WML Deck, or SMIL document, GoLive automatically adds a doctype declaration to the source code with a reference to the appropriate Document Type Definition (DTD).

❖ Do one of the following:

- With the site window open, choose Site > New > Document and select Web. Choose a page type in the New dialog box, and then click OK. GoLive adds an untitled file to the Files tab of the site window.

- With the site window open, choose Site > New > From Favorites and select a file type. GoLive adds an untitled file to the Files tab of the site window. The From Favorites menu lists files included in the Favorites category in the New dialog box.

   To add a file to the Favorites category in the New dialog box, select the file and choose Add To Favorites from the pop-up menu next to the file in the New dialog box.

- Select the Files tab or Extras tab in the site window and if desired, select a folder listed in the tab. Click the Create New Page icon in the toolbar. The new page is added to the bottom of the list in the tab or in the folder you selected.

- Select a page in the Files tab in the site window and choose Edit > Duplicate to create a copy of the existing page.

- With the site window open, choose File > New, and select Web. Choose a page type in the New dialog box, and then click OK. GoLive creates an untitled file and displays it in the Layout Editor of the document window. Choose File > Save As. In the Save As dialog box, name the page, choose Root from the Site Folder menu, and click Save. The new page is added to the contents of the site's root folder, which appears in the Files tab of the site window.

![Saving a page in the site's root folder.](image)

Note: The site window must be open, but not necessarily selected, before the Site Folder menu will appear in the Save As dialog box.

- Drag a generic page icon from the Site set in the objects toolbox into the Files tab or Extras tab of the site window or next to another page in navigation view.

   You can set a GoLive preference to automatically create a new page when the application is started and display it in the editor or preview mode of your choice. (See “About preferences” on page 34.)
See also

“To create a new movie” on page 526

“To create a new SMIL presentation” on page 487

“To create a Real Player presentation” on page 513

To add an existing file to a site

Do one of the following:

- Drag the file from your desktop into the Files tab in the site window.
- Move the file into the site’s root folder on your desktop. Then select the site window and click the Refresh View button in the toolbar.
- Select the Files tab in the site window. Then choose File > Import > Files To Site. In the dialog box, locate and select the desired file, and click Open. If prompted, click OK to copy the file and update the site.

**Note:** When you create a new page, GoLive automatically adds a meta element that defines the character encoding for text to the head section of the page. If a page does not contain the element, GoLive displays a dialog box when you open the page so that you can temporarily use a default encoding or set the character encoding for the page.

See also

“About GoLive sites” on page 145

Locking and unlocking files

You can use GoLive to unlock files that were locked in the Mac OS Finder or given a Read Only attribute in the Windows Properties dialog box. If you import a site with locally locked files, you’ll need to unlock them before you can edit them. If the files are hidden in Windows Explorer, you need to show them before you can edit them.

Local file locking applies only to the platform where it is applied. For example, if you create a site in Mac OS and lock its HTML files, the files will not be locked when you upload the site to a UNIX® or Windows server. Local file locking does not apply to files on a WebDAV server.

To unlock a locked or read-only file

1. Double-click the file in the site window.

2. Make a change to the file. When GoLive returns the message “The file [file name] is read-only. Would you like to make it writable?” click Yes.

   **To unlock multiple files, select them in the site window. Then, in Windows, choose Site > Explorer > Show Object Information, and deselect Read-Only in the Properties dialog box. In Mac OS, choose Site > Finder > Show Object Information, and deselect Locked in the Info dialog box.**
Setting up pages

Before or after you lay out text and objects on your web pages, you can set up titles, margins, and backgrounds for pages, and a window size that you want your page layouts to fit within. You can add hidden instructions for web browsers about each document by dragging elements and scripts into the head sections (for example, keywords that are used by search engines to find your page).

As you work in the document window, you can set options in the View palette to show or hide certain screen elements that are hidden on pages in the browser, such as line break symbols and comments. You can also use the View palette to set up a profile for previewing a browser simulation of the page layout on a different platform.

Once your page is set up, you can use it as the starting point for other new pages by saving it as stationery or a page template. When you’re looking at your pages in navigation view or links view, you can select an option in the Display tab in the View palette to view them either by page title or by file name.

See also

“About site assets” on page 420

“About graphical site views” on page 214

To change the page title

❖ Do one of the following:
  • Select the default page title Untitled Page in the Title section of the document window, and type your new title.
  • Click the Show Page Properties icon in the upper right corner of the document window and enter the new title in the Page tab of the Page Inspector.
  • Select the page in the Files tab of the site window, navigation view, or links view, and enter the new title in the Page tab of the File Inspector.

When you create a new blank page (a new HTML or XHTML document), it is automatically given a title—“Untitled Page.” Web browsers display page titles in their title bar and use the titles to label a viewer’s bookmarks or favorites. Web browsers and Internet search engines use these titles, along with keywords, to identify content in your pages.

You can create a custom page title on a blank page and set a preference to use that page for creating new pages.

See also

“About preferences” on page 34

To add a reminder to change the title for new pages

❖ Choose Edit > Preferences (Windows) or GoLive > Preferences (Mac OS), select Modules on the left side of the Preferences dialog box, scroll down to Extend Scripts on the right side, select SetTitle, and click OK. Then restart the GoLive application.

When you save a page, GoLive automatically displays the Set Title dialog box if the page title is blank or contains the words “Welcome to Adobe GoLive,” “Welcome to GoLive CyberStudio,” or “untitled.”
To choose a document window size

You can choose a size for the document window to use as a guide when you’re designing your page layout. For example, you may want to set the size of your page layout to 580 pixels or less to accommodate viewers with 14-inch monitors. (The size you choose does not affect the size of the browser window that displays the page.)

- To set the size for the open document window, choose a size from the menu at the bottom of the document window. (If sizes don't appear, choose Show > Page Dimensions from the menu.)
- To set a default size for all document windows, first set the open document window to the size you want all document windows to be by default, and then choose Settings from the menu at the bottom of the document window. Select Markup Document Windows, and click OK.
- To add a size to the Status Page Dimensions menu, choose Options from the menu at the bottom of the document window and click the Create New Window Configuration button. Enter a width, height, and annotation in the text boxes in the Window Size Configuration dialog box, and then click OK. To remove a size from the Status Page Dimensions menu, select it in the Window Size Configuration dialog box, click the Remove Selected Window Configurations button, and then click OK.

To create view configurations for document windows

View configurations let you save the appearance of a document window in the Layout Editor. The default view configuration is Web Layout View (if you choose a mobile document format in the New dialog box, GoLive uses the Mobile View configuration). You can create and save your own view configurations. Once you’ve saved a view configuration, you can use it in any new document by choosing it from the View Configuration menu at the bottom of the document window.

1. Make changes to the document window in the View palette or Layout Editor until you’ve created the desired configuration.
2. Choose View > View Configuration > Save, or choose View Configuration > Save from the menu at the bottom of the document window (if the View Configuration menu doesn't appear, choose Show > View Configuration from the menu).
3. In the Save View Configuration dialog box, enter a name for the view configuration in the Configuration Name box, and set view configuration options as desired.

See also

“To save and use a custom workspace” on page 34
“Designing for mobile devices” on page 461
“To set view options for page layout” on page 159
To specify page margins
Page margins let you control how the contents of a web page are offset in browser windows. The margin width specifies the space between the page's content and the left edge of the browser window, and the margin height specifies the space between the page's content and the top edge of the browser window.

1 Choose Special > Page Properties to open the Page Inspector.

2 In the Page Inspector, click the Page tab and enter values in pixels in the Margin Width and Margin Height text boxes.

3 To remove the automatic margin offset, right-click (Windows) or Control-click (Mac OS) in the page and choose Document > Set Page Margins To Zero from the menu that appears.

Setting view options for page layout
To ensure that page layouts reflect what your viewing audience will see, you can configure the Layout Editor to preview different browsers and devices, and to show or hide screen elements. For example, you can specify an Internet Explorer profile if most of your viewers use Windows, or specify a Nokia or NTT DoCoMo profile for a mobile audience. Changing basic profiles doesn't change source code; rather, it simply provides an accurate preview. You can freely switch from one profile to another as you develop a page.

View options are particularly powerful when combined with the @media rule and media type option for stylesheets. If you've created different styles for media types such as screen and handheld, you can preview each of them by using the Target Media option.

See also
“Media, font, and page rules” on page 329

To set view options for page layout
1 Select the Layout tab in the document window.

2 In the Options tab of the View palette, do any of the following:
   - Choose an option from the Basic Profile menu to view a simulated preview of your page in a web browser for Windows or Mac OS. Profiles you've used recently appear beneath the GoLive profiles at the top of the menu.
   - Choose options from the User Profiles menu to set a default screen size or to show or hide color, fonts and text, or images. Choose a user stylesheet to apply it to the page, or choose a target media option to display a page that contains an @media rule or a link to a stylesheet with a media type specifying formatting for print, screen display, or a handheld device as the page would appear in that media. For example, choose handheld to display the page as it would appear on a mobile device.
   - Choose a stylesheet from the Alternate CSS menu to apply it to the page.
   - Select Negative Margins to preview how elements with negative margin values grow in to adjacent elements.
   - Select Show Invisible Items to display or hide elements that are set by the CSS display property.
   - Click Preferences to open the Invisible Elements Preferences dialog box and choose items that don't show in the browser window. The items you choose are displayed or hidden in GoLive when you select or deselect Show Invisible Items from the View menu.
   - Choose Visited Links, Active State, Hover State, or Focus State to preview the colors that have been chosen for each link state.
See also
“To set default colors for text or links on the page” on page 180

“Media, font, and page rules” on page 329

To open a page from the site in the Layout Editor
❖ Do one of the following:
• Double-click the page in the site window, navigation view, or links view.
• To open a page with a particular tab showing, right-click (Windows) or Control-click (Mac OS) the file and choose an item from the Open > Open in Mode menu. The menu lists all the tabs in the document window.

You can set an application preference to automatically open all pages in another tab.

See also
“About preferences” on page 34

To save pages in the site
You can save your web pages directly to the site's root folder that stores the pages and media for your website. You can also save your pages as components, stationery, or page templates for the site.

1 Open the site file.
2 Do one of the following:
• Select the document window, and choose File > Save or choose File > Save As.
• In the document window, choose Save As from the window menu, and then choose Save As Stationery, Save As Component, or Save As Template.

3 In the Save As dialog box, name the file, using the appropriate file-naming conventions. (For example, it's a good idea to use all lowercase letters and no spaces.) Make sure that you include the appropriate suffix (.htm or .html) for the name to ensure that GoLive and web browsers recognize the format of the file.

4 Choose a site folder (Root, Stationery, Components, or Templates) from the Site Folder menu in the Save As dialog box. (This step is not necessary if you chose an option from the Save As submenu of the document window menu.)

5 Click Save.

6 If the Set Title dialog box appears, enter a name for the page title in the text box or select Set Title To Document Name to automatically enter the filename as the title. To prevent the Set Title dialog box from appearing again, select Don't Remind Me Again. Then click Set.

See also
“To change the page title” on page 157

“About site assets” on page 420

“About site assets” on page 211
Document type definitions

Setting the document type definition
A document's doctype, which is specified in the !DOCTYPE declaration at the beginning of the document, tells HTML validators and browsers which Document Type Definition (DTD) to use when handling the document. The DTD specifies the elements that are allowed in the source code and the attributes for each element. For example, the HTML 4.0 Strict DTD doesn't allow frames in documents, and the XHTML Basic DTD doesn't allow font elements.

By setting a document's doctype, you are declaring that the document complies with a particular DTD, which some devices now require. Some cell phones, for example, require documents to comply with the XHTML Basic DTD. If you are designing a document for display on cell phones, be sure to set the doctype of the document to XHTML Basic. Most current versions of browsers can display documents that are not compliant with the document's declared DTD. But, by setting the doctype and making sure the document is compliant, you are preparing the document for future versions of browsers that will require compliance. If a document doesn't have a doctype, which is the case for most older documents, browsers can still display the document.

If you set a document's doctype and then use the Syntax Checker, GoLive checks the document's structure and syntax, and then highlights any elements that are not compliant with the DTD declared in the doctype. (See “Validating the syntax of source code” on page 591.)

Changing a document's doctype
You can set a document's doctype when you create the document in the New dialog box or change the doctype of one or more existing documents. For example, you can change the doctype of an HTML document, or you can convert a document from HTML to XHTML and then choose an XHTML doctype. For best results, start by creating the type of special document you want to ultimately deploy.

After you choose a doctype, GoLive sets the document's doctype by inserting or changing the !DOCTYPE declaration at the beginning of the document's source code. The doctype you set is also selected as the default DTD in the Syntax Checker.

To change the doctype of one document
The doctype is context-sensitive—that is, if you are editing an HTML document, the valid HTML DTDs are available. For an XHTML document, the XHTML DTDs are available, and for any other doctype, the associated DTDs in the Markup tab of Web Settings are available.

❖ In the Layout Editor, choose Doctype from the document window menu , and then choose a doctype from the menu.

Note: If you associate imported DTDs with text or XML files in the Markup tab of Web Settings, those DTDs are also available on the Doctype menu. (See “To import an XML DTD file” on page 645.)

To change the doctype of multiple files in a site
1 Open a site window.
2 Choose Special > Convert > Doctype and choose a group of files to convert from the Work On menu.
3 Choose a doctype from the New Doctype menu. If Write Full Doctype is available, select it to ensure that GoLive includes a complete doctype with URL, and then click OK.
To convert the doctype of a document from HTML to XHTML

1. Do one of the following:
   - To convert a single document, choose Markup from the document window menu in the Layout Editor, and then choose Convert to XHTML. The Convert To XHTML dialog box opens.
   - To convert multiple documents, open a site, select files you want to convert, and then choose Special > Convert > To XHTML. The Convert To XHTML dialog box opens.

2. To make your converted XHTML document compatible with more browsers, select the following options to set how GoLive converts the document from HTML To XHTML:
   - **Write <?xml?>**
     - Choose Always to always include the <?xml?> declaration, choose Except UTF to include the declaration unless the page's encoding is set to UTF-8 or UTF-16 (<?xml?> declarations are not required if the document's encoding is set to UTF-8 or UTF-16), or choose Never to never include the declaration.
   - **Wrap <style> Content Into CDATA**
     - Wraps all of the text inside stylesheets to conform to the XHTML specification.
   - **Wrap <script> Content Into CDATA**
     - Wraps all of the text inside scripts to conform to the XHTML specification.
   - **Put A Space Character In Front Of “/”**
     - Converts empty tags such as <empty> to <empty /> instead of <empty/> (no blank space before the slash). This option helps make your document compatible with some browsers that can’t handle end tags that have the correct syntax according to standards published by the W3C.
   - **Remove <meta> Encoding Element**
     - Removes the meta encoding element from the head section because the starting XML element contains encoding information.
   - **Remove Encoding Information If It Is UTF-8**
     - Removes the encoding information if it is UTF-8, which is the default encoding for XML.

3. Use the following options to set how you want GoLive to handle the conversion of the name attribute used in the following elements: a, form, img, and map. The conversion of the name attribute can cause compatibility problems in some browsers. HTML requires the name attribute for functionality, but the XHTML Strict DTD doesn’t allow the name attribute in those elements.
   - **Do Not Touch**
     - Does not change the name attribute or its value. For example, <form name="formName"> remains <form name="formName"> after conversion.
   - **Copy To Attribute “ID”**
     - Copies the name attribute and its value to an ID attribute. For example, <form name="formName"> becomes <form name="formName" ID="formName"> after conversion.
   - **Convert To Attribute “ID”**
     - Converts the name attribute to an ID attribute. For example, <form name="formName"> becomes <form ID="formName"> after conversion.

   **Note:** If you select the Do Not Touch option or the Copy To Attribute “ID” option and your document has an XHTML Strict doctype, the Syntax Checker reports an error on the name attribute, but the document works correctly in a browser. If you select the Convert To Attribute “ID” option, and your document has an XHTML Strict doctype, the Syntax Checker doesn’t report an error, but the document might not work correctly in a browser.

4. Click OK.
To convert the doctype of a document from XHTML to HTML

1. Do one of the following tasks:
   - To convert a single document, choose Markup from the document window menu in the Layout Editor, and then choose Convert to HTML. The Convert To HTML dialog box appears.
   - To convert multiple documents, open a site and select the files you want to convert, and then choose Special > Convert > To HTML. The Convert To HTML dialog box appears.

2. Choose Write Full Doctype to ensure that GoLive includes a complete doctype with URL.

3. Use the following options to set how you want GoLive to handle the conversion of the ID attribute used in the following elements: a, form, img, and map.
   - **Do Not Touch**: Does not change ID attributes or their values.
   - **Copy To Attribute “Name” (If There Is No Conflict)**: Copies the ID attribute and its value to a name attribute.
   - **Convert To Attribute “Name” (If There Is No Conflict)**: Converts the ID attribute and its value to a name attribute.

Configuring the objects toolbox for a doctype

After you set a document's doctype, GoLive automatically disables buttons on the toolbar and menu commands so that you can't add elements that are not compliant with the DTD for the current doctype. For example, because the font element doesn't comply with the XHTML Basic DTD, GoLive automatically disables the font size and color options in the toolbar and the Font menu commands.

The one exception where GoLive does not automatically disable tools is the icons in the objects toolbox. You must manually configure the objects toolbox if you want to hide the icons for elements that are not allowed in the current doctype.

*Note: You can't configure the objects toolbox for an imported DTD.*

To configure the objects toolbox for a doctype

1. In the objects toolbox, choose Configure from the Palette Options menu.

2. Do one of the following:
   - To show all icons in the objects toolbox, choose GoLive.
   - To hide the icons for elements not allowed in the current doctype, choose the current doctype.

Adding elements and scripts

To add elements or scripts to the head section

An HTML page consists of two major sections: a head and a body. The Layout Editor in GoLive mirrors this structure by providing a head section pane as part of the document window. You can use the head section pane to store page information that's used by web browsers, including the page title and keywords. The head section of each page already contains a Title element for the page title that appears at the top of the document window.

1. Drag the desired icon from the Head set in the objects toolbox to the body of the page.

GoLive automatically moves it to the head section pane and opens the pane. (You can also click the Toggle Head Section icon in the upper left corner of the document window to open the head section pane.)
You can reposition head elements in the pane by dragging them.
A. Closed head section pane  B. Opened head section pane

2 In the Inspector, choose various options and specify attributes for the selected element or script.

See also
“To add a browser-switch script” on page 166

Head section elements
The options and attributes in the Inspector vary depending on the type of element that is selected in the head section pane. You can add any of the following elements to a page:

The Favorite icon Use to specify an image that appears with your page’s title in the Favorites or Bookmarks menu of a web browser. Favorite icons should be 16x16 pixels. To specify an image that appears with all pages in your site, name the image “favicon.ico” and upload it to your site’s root folder. (See “Publishing a site” on page 439 for more information about uploading files to a publish server.) Use a Smart Favorite icon from the Smart set of the objects toolbox to specify a Smart Object as a favorite icon (see “Smart Favorite icons” on page 166).

The Keywords element Use to specify keywords for your web page. Internet search engines use the information in the Keywords element when constructing their indexes. The Keywords Inspector lets you add, update, delete, and rearrange selected keywords in a list for the element. You can also add a keyword to the first Keywords element in the head section by selecting text in the page and choosing Special > Add to Keywords. If no Keywords element exists in the head section, GoLive adds it automatically. The new keyword appears in the list in the Keywords Inspector.

Internet search engines rely both on keywords and page titles to find your pages. (See “To change the page title” on page 157).

Comment Use to add hidden comments to your web page, such as publishing information for future reference. To view the comments, you need to use GoLive or another source code viewer.

Note: You can also add comments to the body of the page and refer to them as you build the page in the Layout Editor. (See “To add comments to a page” on page 270.)

The Meta element Use to include information about the web page, such as a description of the page content. For each new page, GoLive automatically includes the following information using meta elements: file format (for example, text/HTML), character set used (for example, ISO-8859-1), and file creator (for example, Adobe GoLive). The Meta Inspector lets you choose an HTTP-Equivalent option to simulate header information that accompanies the page when it’s sent by an HTTP server to a browser or the Name option to define a non-HTTP meta element.
**Note:** To prevent GoLive from writing the file creator meta element, choose Edit > Preferences (Windows) or GoLive > Preferences (Mac OS), select General, deselect Write “Generator Adobe GoLive,” and click OK. To change the character set for a new page, select the Encode tag in the head section of the page and select another character set in the Encoding Inspector. To change the character set for all new pages, choose Edit > Preferences (Windows) or GoLive > Preferences (Mac OS), select Encodings, choose a new set, and click OK. To change the encoding for selected files in a site, select files in the Files tab of the site window, choose Special > Convert > Encoding, select a new encoding, and click OK.

**The Script element** Use to add JavaScript to the head section of your web page. A script in the head section is executed while the visible body section of the page is still being loaded. You use the Head Script Inspector to enter a name for the script, choose the language or JavaScript dialect for a browser, specify the script file, and open the JavaScript Editor to edit the script file. (See “Using JavaScript” on page 602.)

**The Refresh element** Use to instruct web browsers to refresh the contents of your web page or replace your page with another after a specified interval. You may want to use this element if your page contains live material or if it’s part of a sequential series of pages you are presenting to viewers. The Refresh Inspector lets you enter a Delay value in seconds to specify an interval before the page is refreshed or replaced with another page. You choose either the Target This Document option to refresh the current page or the Target URL option to replace the page with another page.

You can easily create a slide show by adding a Refresh element to each page that’s part of the slide show. For example, you can add a Refresh element to the first page of the slide show that replaces the first page with the second page, and so on.

**<no edit> elements** Use to add <no edit> elements to the head section of your web page. These are useful for adding code that has unusual syntax or that GoLive can't read, and for adding new unknown elements and ensuring compatibility with future versions of HTML and the web browsers that support these versions. You use the Element Inspector to edit the start and end tags, add the names and values of new attributes, and delete attributes from the list.

**Text character encoding** Use to add a meta element that defines the character encoding for text in a document. By default, all new pages created in GoLive use the meta encoding element in the head section with the UTF-8 character set attribute. You can change the character encoding by selecting the Encode object in the head section and selecting an encoding option in the Encoding Inspector. You can also change the character set for a document by choosing a different set from the File > Document Encoding submenu, or change the character set for selected files in a site by choosing Special > Convert > Encoding and selecting a new encoding in the Change Encoding dialog box. (See “Non-roman character sets” on page 315.)

**The Link element** Use to define relationships between your current web page and other pages in your website, or on the Internet. (If you manage the pages in your site using the GoLive site window, you don't need to use the Link element.) You can use the information in the Link element to keep track of links between pages in a large site. The Link Inspector lets you specify the title, link name, and anchor name for the referenced page, the relationship and reverse relationship between the current page and the source or destination URL, a list of HTTP methods supported by the referenced page, and a Uniform Resource Number (URN) for the page.

**Note:** Most web browsers don't use or support URNs or the Methods attribute.

**The IsIndex element** Use both to inform web browsers that your web page can be examined using a keyword search and to instruct the browsers to display a search text box for keywords when displaying your page. The Prompt text box in the IsIndex Inspector lets you enter the string that you want browsers to display with the search dialog box.

**Note:** The IsIndex element is obsolete.

**The Base element** Use to specify the original location of your web page, also known as the base URL. The base URL is used by web browsers to locate relative links on your page. In the event that your page is moved away from its original location, the browsers can correctly locate the page's relative links using the base URL.
To add a browser-switch script

A browser-switch script detects the web browser loading the page and automatically redirects viewers to an alternate page based on their browser. You can also use the browser-switch script to separate Netscape from Internet Explorer browsers based on browser-specific markup support.

*Note:* The Browser Switch script is ignored by version 2.0 browsers and Microsoft Internet Explorer 3.01 for Mac OS.

1. Drag the Browser Switch icon from the Smart set in the objects toolbox to the body of the page. GoLive automatically moves it to the head section and opens the head section pane.

*Note:* Because an older browser can’t read the browser-switch script, you should make sure that the page you’re placing the script on is built for the oldest of browsers and assumes no redirect is possible.

2. In the Browser Switch Inspector, select the browsers that support the features on your page:
   - To have GoLive determine browser compatibility, select Auto. For example, if your page contains features that can only be interpreted by version 4.0 browsers and later, GoLive configures the script to reroute requests from version 3.0 browsers.
   - If the same browsers are supported in Windows and Mac OS, deselect Auto, choose All from the Supported Platform menu, and select the supported browsers.
   - If different browsers are supported in Windows and Mac OS, choose Windows from the Supported Platform menu and select the supported browsers for Windows. Then choose Mac OS from the Supported Platform menu, and select the supported browsers for Mac OS.

*Note:* In the Browser Switch Inspector, you can select the infinity symbol for Netscape or Explorer to indicate that the supported browser versions are those later than version 6.0.

3. Specify the URL to an alternate page in the Alternate Link text box.

When you have finished, try viewing your page with an incompatible browser and check whether the request is correctly rerouted.

See also

“Specifying the destination URL for a link” on page 169

Smart Favorite icons

Favorite icons let you specify an image that appears with your page's title in the Favorites or Bookmarks menu of a web browser. When you use a Smart Favorite icon, GoLive enables you to include multiple images of different sizes or quality, enabling the browser to choose the most appropriate image for the favorite icon. When you specify multiple images, GoLive sorts the images in the favorite icon to provide best results with browsers that don't support all settings or that simply choose the first available image.

To use Smart Favorite icons

1. Drag the Smart Favorite icon from the Smart set of the objects toolbox to the head section of the page.

2. In the Smart Favorite Icon Inspector, click the Browse button next to the Source field and specify a source image. (Smart Favorite icon source files should be 16x16 pixels.)
3 In the Settings window, choose image quality settings. Leave lower quality settings selected for browsers such as Safari that don't support alpha channels in favorite icons, and disable higher quality settings only if not needed (for example, if your icon doesn’t need true colors or an alpha channel).

4 Click OK, and specify a file name and location for the Smart Favorite icon target file.

*If you use a PSD file as the source file for a Smart Favorite icon, you can choose to use either layers or layer sets as separate images to design specific versions for certain qualities or sizes. For example, you can design a high quality version with a drop shadow in a PSD layer that you can then use only for a 32-bit version in GoLive. Another layer could hold a version designed for fewer colors and without the drop shadow. By using PSD layers with different sizes, you can also specify images for different icon sizes.*

## Creating links

### About links

After you create your site and add all your resources to the site window, you can start linking images or objects on the page to their source files, create a navigational system between the pages in your site, and add navigational links to other sites or external URLs. You can use GoLive's Edit PDF Anchor feature to create links to bookmarks in PDF files. GoLive automatically updates the site with each new link you create and continually verifies the integrity of links as you build your site. If you move or rename a file in the site window, GoLive updates the links to the new paths.

You can view a graphical representation of all the links in your site and the navigational hierarchy between pages. If a link is broken because the destination file was moved or renamed outside of the site window, GoLive displays the orphaned or missing file in the Errors tab of the site window.

For information on creating links that originate from parts of an image, see “Image maps” on page 346.

### See also

“About graphical site views” on page 214

“About site errors” on page 234

### Creating resource and navigational links

When you add images and other types of media to a page, you create resource links from the placeholders on the page to the source files. You can also create navigational links from images or text on a page that viewers click to go to other pages in the site, other anchored locations on the same page, or external URLs or e-mail addresses.

You can set up text or images as empty reference links and specify the destination files for them later or attach actions to them.

### See also

“Specifying the destination URL for a link” on page 169
To create a resource link
❖ Do one of the following:
• Drag the source file (such as a GIF image, a SWF file, or a Photoshop PSD file) from the Files tab of the site window to the page. GoLive automatically creates a resource link between the image on the page and the source file.
• Select the placeholder object (such as an image or a Smart Object) on the page, and specify the source file in the URL text box in the Inspector.

See also
“Specifying the destination URL for a link” on page 169

To create a navigational link
1 Select text, or an image or object on the page.
2 In the Inspector, do one of the following:
• For selected text, specify the destination file for the navigational link in the URL text box. If you type a URL or e-mail address in the text box, include “http://” or “mailto:” at the beginning, respectively.
• For selected images or objects, click the Link tab (if applicable), and then click the Create Link button and specify the destination file for the link in the URL text box.

You can also drag the destination file for a navigational link from the Files tab of the site window onto the selection in the page. (If you drag the file to a page without a selection in it, GoLive creates a hypertext link and uses the name of the file for the text label.)

3 If you want the link destination to appear in a frame or a new web browser window, choose an option from the Target menu in the Inspector.
4 Enter a descriptive title for the link in the Inspector. This title appears in some browsers when you hold the pointer over the link.
5 In the Inspector, choose an option from the Name/ID menu (choose Name & ID for maximum browser compatibility), and then type a unique link name in the Name/ID text box.

See also
“About target frames for linked pages” on page 267

To create an empty reference link
❖ Select the text or object in the page, and click the Create Link button on the toolbar. GoLive displays a bug icon in the site window next to pages that contain empty reference links.

You can specify the destination file for multiple links at once by using the In & Out Links palette. (See “Changing all site URLs or links at once” on page 232.)

To remove a link
❖ Select the text or object in the page, and click the Remove Link button on the toolbar.
Specifying and editing links

Specifying the destination URL for a link

You use the Inspector to specify the destination file or URL for resource and navigational links. You can type the path to the link's destination file directly in the Inspector’s URL text box or use any of a variety of methods to specify it, including dragging files, using the pick whip, browsing, and reusing recently linked files. No matter which method you use, the path to the destination file appears in the Inspector.

Note: The pick whip is also conveniently located in other windows and palettes (such as the In & Out Links palette) when you need to link something to a file in the site.

The pop-up menu to the right of the Browse button in the Inspector contains lists of recently linked files you can use to specify the destination for a link. The lists are organized by categories, including HTML, Images, Misc. URLs, Anchors, and the last five files that have already been used as the destination for links. The Misc. URLs category includes links made to PDF files, favorite URLs, or e-mail addresses collected in the External tab of the site window.

See also

"Changing all site URLs or links at once" on page 232

To specify the link’s URL by dragging the destination file

- For resource links, drag an image file or other media file from the Files tab in the site window to the page. The URL to the source file appears in the Inspector.

- For navigational links, drag an HTML file from the Files tab in the site window to a selected link or text on the page. The destination URL of the page appears in the Inspector. (If you drag the HTML file to the page without a selection in it, GoLive creates a hypertext link and uses the filename for the text label.)

  You can also drag external URLs, e-mail addresses, and snippets from the site window or Library palette to the page. (See "About site assets" on page 420.)

To specify the link’s destination by using the pick whip

1. Select the text, object, placeholder icon, or existing link on the page.

2. Do one of the following to specify the destination file:

   - Drag a line from pick whip to the destination in the site window, which can be a file or an anchor listed under the file in the Files tab, or a URL or an e-mail address in the External tab. You can also drag to the Show Page Properties icon or an anchor in an open page.

   - Alt-drag (Windows) or Command-drag (Mac OS) a line from a selection in the page to the destination file in the site window or to a destination on the page or another open page (creating an anchor).

If the line recoils, you have released the mouse button too soon or the link can’t be created.

Note: As you drag, you can hold the pointer over the Select Window button on the toolbar to bring a window to the front or hold the pointer over a page in the Files tab in the site window to display a list of anchors under the page.
Drag the pick whip in the Inspector to a file in the site window.

**See also**

“Using anchors for links” on page 171

“Site URLs and e-mail addresses” on page 433

**To specify the link’s destination by browsing**

1. Select the text, object, placeholder icon, or existing link on the page.
2. In the Inspector, click the Browse button.
3. In the Open dialog box, select the destination file, and click Open.

If the destination file is not located in the site window, you can use the Browse button to locate it, and link it to the selected text or object. Then you can drag the orphan file from the Errors tab in the site window to the Files tab and click OK to copy the file and update the site. Or, you can use the Clean Up Site command to move a copy of the file into the site.

**See also**

“To specify options for cleaning up a site” on page 210

**To specify the link destination using a recently linked file, e-mail address, or URL**

1. Select the text, object, placeholder icon, or existing link in the page.
2. In the Inspector, choose a recently linked file, HTML file, image, miscellaneous URL, or anchor from pop-up menu to the right of the Browse button.

**Editing links and adding query parameters to links**

You can use the Edit URL dialog box to edit the path to a link’s destination, make the path relative or absolute, and add query parameters to the URL for Common Gateway Interface (CGI) requests and other types of server requests.

Query parameters are used to query servers for information such as data from databases or loading server scripts, such as Perl Script, to process forms.

When you add query parameters to the URL, GoLive inserts a question mark (?) for the query, equal signs (=) between each parameter name and value, and ampersands (&) between each parameter. GoLive displays the complete URL including the CGI or other server request at the bottom of the Edit URL dialog box.
To edit a URL or add query parameters

1 In the Inspector, choose Edit from the pop-up menu to the right of the Browse button.

2 In the Edit URL dialog box, do any of the following:
   • To specify a particular URL, modify or type a new URL in the Path text box.
   • To locate and select a new destination page, click Browse.
   • To use an absolute or relative path for the URL, click Make Absolute or Make Relative. By default, GoLive uses relative URLs for the destinations of links.

Note: You can also make URLs absolute for a specific site, or set a preference to make all URLs absolute for all sites.
   • To add parameter names and values to the list of Query Parameters, type them in the text boxes and click Add Parameter.
   • To remove a parameter from the list, select it and click Delete Parameter.
   • To change the name or value of a parameter, select the parameter in the list, edit the name or value in the text boxes below the list, and click Update.

The complete URL, including the parameters, appears in the Result box at the bottom of the Edit URL dialog box.

3 Click OK.

See also
"To make the path of a link absolute" on page 213

Anchor links

Using anchors for links
An anchor is a specified location on a web page that serves as the destination of a link. Here are some guidelines to follow when creating anchors:

• Don't place anchors directly on a layout grid. Instead, place anchors in the flow of HTML text, a layout text box, or a table cell. When you add an anchor to a layout text box or table cell, make sure that the box or cell has other contents. Otherwise, the anchor will not be recognized by Netscape Navigator. To work around this problem, you can add a nonbreaking space to the empty box or cell. To add a nonbreaking space, click inside the box or cell, and press Shift+spacebar (Windows) or Option+spacebar (Mac OS).

• Place anchors near the left margin of the page, so that the anchors work more consistently across browsers.

• Test links to anchors extensively in browsers before publishing your website. Anchors don't always work the same way in all browsers.

Note: You won't be able to preview certain link and anchor combinations in Layout Preview.
To create an anchor

❖ Do one of the following:

• Drag the Anchor icon from the Basic set of icons in the objects toolbox to the destination on the page where you want the anchor.

• Select a link on the page, drag the pick whip [ ] in the Inspector to a location on the page or another open page where you want to place the anchor, and release the mouse button.

Note: You must save the destination page before you can create an anchor using the pick whip.

To give an anchor a unique name

1 Select the anchor marker ✗ in the page.

2 In the Anchor Inspector, choose an option from the Name/ID menu (choose Name & ID for maximum browser compatibility), and then type a unique anchor name in the Name/ID text box.

You can see a list of all the anchors on a page by clicking the triangle next to the page in the Files tab in the site window.

To create an anchor link to a PDF bookmark

A PDF bookmark links to a specific location in a PDF file. (Anchor links to PDF bookmarks don’t work with Adobe Acrobat® 6.0 in Mac OS X.)

1 Create a link to the PDF file.

2 In the Inspector, click Edit PDF Anchor.

3 In the PDF Anchor Editing dialog box, do one of the following:

• To open the PDF file to a bookmark, select the bookmark in the Settings pane.

• To open the PDF file to a specific page, select Use Page Number and enter the page number in the Use Page Number text box.

4 Select Use Page Mode and choose bookmarks, thumbs, or none to open the PDF file with the bookmarks pane, the thumbnail pane, or no pane visible, respectively.

5 Click OK.

Note: You can’t preview links to PDF bookmarks in GoLive for Windows. To preview the link, upload your site to a web server.

See also

“Creating resource and navigational links” on page 167

“Specifying the destination URL for a link” on page 169
Getting information about documents

To view document statistics for the current page
❖ Do one of the following:
• Choose Show > Document Statistics from the menu at the bottom of the document window to display the size of the page in bytes.
• Choose Special > Document Statistics to display the Document Statistics dialog box, which provides general information about your web page, including its byte size, word count, character count, and the approximate time it takes to download. Note that the byte sizes listed don't include media, such as QuickTime or sound because they may be set to start playing before they are fully downloaded. In addition, the download times listed are only rough estimates based on a well-defined set of circumstances. External conditions, such as heavy traffic on the network and web server overload, may substantially change the real time it takes to download the page.

You can create a query for more detailed information, such as the download time for everything that makes up the page (images, QuickTime movies, and so on).

See also
“Generating queries” on page 237

Using metadata with site files
File information—also called metadata—is increasingly important in all types of publishing. Metadata preserves information about the contents, copyright status, origin, and history of documents, and can be used to search for files.

You can modify the metadata of any site file that already contains XMP data, except HTML files. The information you add is embedded in the file using XMP (eXtensible Metadata Platform). XMP facilitates the exchange of metadata between Adobe applications and across publishing workflows. For example, you can save metadata from one file as a template, and then import the metadata into other files.

Companies can use the XMP Software Development Kit to customize the creation, processing, and interchange of metadata. For example, you can use the XMP SDK to add fields to the File Info dialog box. More information on XMP and the XMP SDK is available on the Adobe Solutions Network at http://partners.adobe.com/public/asn/developer/detail.html.

To add metadata to a document
1 Select one or more files in the site window and choose File > File Info.
2 Select a category from the list on the left, enter the desired information, and click OK.

Note: If you selected more than one file, selecting the checkbox next to items in the Description and Origin categories applies the information to all files.

Description Specifies information about the document, such as title, author, description, and keywords that can be used to search for the document. To specify copyright information, select Copyrighted from the Copyright Status menu. Then enter the copyright notice string and the URL of the person or company who owns the copyright.

Origin Specifies information on the history of the artwork. To enter the current date in a short text format, click Today. For Credit, enter the information needed in the credit line for a copyrighted image. Transmission Reference
provides the Associated Press with information on the original transmission location of the artwork. For Urgency, specify the editorial urgency of the file—not its handling priority.

**Advanced** Lets you view the XMP data for the file in a structured format.

**Raw Data** Lets you view the raw XMP data for the file.

**To save metadata as a template**
1. Click the triangle icon at the top of the File Info dialog box, and choose Save Metadata Template.
2. Enter a template name, and click Save.

**To save metadata to an XMP file**
1. In the Advanced section of the File Info dialog box, click Save.
2. Type a file name, choose a location for the file, and click Save.

**To import metadata into a document**
❖ Select the documents that you want to import metadata into and do one of the following:
   - Click the triangle icon at the top of the File Info dialog box, and choose a template name from the top section of the pop-up menu. The metadata from the template will replace the current metadata. To append the current metadata instead, hold down Ctrl (Windows) or Command (Mac OS) when you choose the template name.
   
   **Note:** You must save a metadata template before you can import metadata from a template.
   - In the Advanced section of the File Info dialog box, click Replace to replace the current information with information stored in an XMP file. Locate the XMP file containing the metadata you want to import, and click Open.
   - In the Advanced section of the File Info dialog box, click Append to add information stored in an XMP file to the current file information. For each File Info field, if the field does not contain information then it will be updated with contents from the file. Keywords will always be appended with the information from the file.

**To delete a metadata template**
1. Click the triangle icon at the top of the File Info dialog box, and choose Delete Metadata Template.
2. Select the name of the template you want to delete, and click Delete.

**To show the location of metadata templates**
❖ Click the triangle icon at the top of the File Info dialog box, and choose Show Templates.
Color

About the Color palette, Swatches palette, and the Color Picker

Use the Color palette, Swatches palette, swatch library palettes, and the Color Picker to apply color to page backgrounds, text, and objects on a page.

**Color palette**  Contains color models based on CMYK, RGB, HSV, HSB (for video hardware), and Grayscale. The Color palette displays the color of the current selection in the preview pane, as well as recently used colors in the Recent Colors list. The Hex Value box displays the hexadecimal value of colors you've chosen.

**Swatches palette, swatch library palettes**  You can add or remove custom swatches to the default Swatches palette, and open multiple swatch library palettes, such as palettes that include site colors (colors you've used in a site) and recent colors (colors you've added to the Recent Colors list in the Color palette). The Show Search Fields option in the Swatches palette and swatch library palettes lets you search for colors by name or hexadecimal value.

**Color Picker**  In the Color Picker, you can select colors based on the HSB (hue, saturation, brightness), RGB (red, green, blue), CMYK (cyan, magenta, yellow, black), or Lab color models. The Color Preview field displays the currently selected color above the previously selected color. You can also specify a color based on hexadecimal values, and add colors from the Color Picker to the Swatches palette. The Color Picker can be set so you choose from only web-safe colors.

![Color Picker](image)

**Eyedropper tool**  Use this tool in the Color palette, Swatches palette, or swatch library palettes to extract colors from an image or screen element.

**Note:** When you use the Color palette, Swatches palette, swatch library palettes, or the Color Picker to apply color to text or objects, GoLive inserts the color attribute inside the font element. Because the font element can cause problems with web browsers, you may want to apply color to text and objects using CSS styles instead of the Color palette, Swatches palette, swatch library palettes, or the Color Picker.

**See also**

"Applying styles" on page 338
To color-manage swatches and the Color Picker

Colors sometimes look different when viewed on different monitors, when printed, or when displayed on the web. Print applications use color management to produce consistent color across different devices. Web browsers don’t use color management to display colors on web pages. GoLive offers you the option to view colors by using a color-managed preview in the Swatches palette, swatch library palettes, or in the Color Picker.

❖ Do one of the following tasks:
  • To view swatches in the default Swatches palette or in a swatch library palette using color management, choose Color Managed View from the palette menu.
  • To view colors in the Color Picker using color management, select Color Managed Preview in the Color Picker window.

To use the Color palette

The Color palette lets you mix and edit colors.

Clicking a color field automatically opens the Color palette.
A. A color field  B. The preview pane  C. Recently used colors

• To display the Color palette, choose Window > Color.

Note: You can also open the Color palette by clicking a color field (for example, in the Inspector or toolbar).

• To change the color model, choose a color model from the Color palette menu, or click a color model button, located at the top of the Color palette.

• To display only web-safe colors, choose Only Web Colors from the Color palette menu. The sliders snap to web-safe colors when you drag them.

Note: Web-safe colors are the 216 colors that are used by browsers, regardless of platform. Browsers change all colors in the image to these colors when displaying the image on an 8-bit screen. By working with web-safe colors, you can ensure that the colors in your web pages will not dither on a system using a 256 color display.

• To display color values in percentages, choose Percent Values from the Color palette menu. Choose Percent Values again to display colors in the 256 numerical scale.

• To show or hide the color model buttons, choose Show Buttons from the palette menu.

• To show or hide the Recent Color list, choose Show Recent Colors from the palette menu.

• To manually add a color to the Recent Color list, either select a colored element on a page, such as colored text, or select a color from the Color or Swatches palette, and then click the Add Color To Recent Colors List button .

To use the Swatches palette or a swatch library palette

You use the default Swatches palette or a swatch library palette to select colors by color swatch, name, or hexadecimal value. You can open multiple swatch libraries concurrently, and save Recent Colors, Site Colors, or custom swatches added to the Swatches palette as an Adobe Swatch Exchange file.
Note: If you click the lower right corner of a color field, GoLive displays the last swatch library viewed.

- To display the Swatches palette, choose Window > Swatches.

![The Swatches palette](image)

A. Search fields  
B. Custom swatches

- To open a swatch library, choose Open Swatch Library from the Swatches palette menu.
- To view recently used colors, choose Open Swatch Library > Recent Colors from the Swatches palette menu. GoLive displays the date and time the swatch was added to the Recent Colors swatch library in the Name text box of the swatch library palette.
- To view a list of site colors, choose Open Swatch Library > Site Colors from the Swatches palette menu. (See “Site colors” on page 430.)
- To add a custom swatch to the Swatches palette, choose a color from the Color palette or a swatch library palette, and then click the Create New Swatch button in the Swatches palette.
- To remove a custom swatch from the Swatches palette, select the swatch and click the Delete Swatch button.
- To edit swatches in the default Swatches palette, click the Edit button in the lower left corner of the Swatches palette and use the Color palette to adjust the swatch. You can also edit the color name and value in the Name and Value boxes while in Edit mode.
- To enable the current swatches in the default Swatches palette or in a swatch library to appear when you next open GoLive, choose Persistent from the Swatches or swatch library palette menu.
- To change how swatches appear in the palette, choose an option from the Swatches palette or swatch library palette menu: List View to display the hexadecimal value and thumbnail of each swatch, or Small Thumbnail to display a thumbnail of each swatch.

**To search for a color in the Swatches palette or in a swatch library palette**

1. If you're using the default Swatches palette, make sure that you're not in Edit mode (deselect Edit Mode from the Swatches palette menu).
2. Choose Show Search Fields from the Swatches palette or swatch library palette menu.
3. Do one of the following, and then press Enter or Return:
   - Type a hexadecimal value in the Value text box.
   - Type a color name in the Name text box.

Note: If the color you're searching for doesn't exist in the current swatches, GoLive displays the nearest color.
To save a swatch library as an Adobe Swatch Exchange file
You can save the Recent Colors swatch library, the Site Colors swatch library, or custom colors added to the Swatches palette in Adobe Swatch Exchange format.

1 Choose Save Swatches for Exchange from the Swatches palette or swatch library palette menu.
2 In the Save Swatch Library As Adobe Swatch Exchange File dialog box, enter a name for the swatch library in the File Name box, and choose a location in which to save the library.
3 Click Save.

To open Adobe Swatch Exchange files, choose Open Swatch Library > Other Library from a swatch library palette menu, select the file, and click Open.

See also
“To share swatches between applications” on page 658

To display the Color Picker
❖ Double-click a color field (for example, in the Inspector or toolbar).

To identify web-safe colors in the Color Picker
❖ Select the Only Web Colors option in the lower left corner of the Color Picker, and then choose any color in the Color Picker. Any color you pick with this option is web-safe.

To specify a color using the Color Picker
- To specify a color in HSB, RGB, or Lab color modes, click a component next to the HSB, RGB, or Lab values and select a color by dragging the triangles along the slider, clicking in the color slider, or clicking in the color field.
- To specify a color in CMYK mode, specify each component value as a percentage of cyan, magenta, yellow, and black.
- To specify a color using hexadecimal values, enter a hexadecimal value in the # box. For example, 000000 is black, ffffff is white, and ff0000 is red.

To add a color from the Color Picker to the Swatches palette
❖ Select a color in the Color Picker and click Add To Swatches.
To apply color to an object

1. Select the object you want to color (for example, a table cell).

2. Do one of the following tasks:
   - Double-click the color field in the Inspector or toolbar, choose a color from the Color Picker, and click OK.
   - In the Inspector or toolbar, click the color field and select a color from the Color palette, the Swatches palette, or a swatch library palette.
   - In the Inspector or toolbar, click the lower right corner of the color field and choose a color from the swatches that appear.
   - In the Inspector or toolbar, click the lower right corner of the color field and choose a swatch library. Click the corner again to choose a color from the swatches displayed above the list of swatch libraries (GoLive displays the swatches from the swatch library you chose).

See also

“To apply an image or color to the page background” on page 179

“To add color to text” on page 303

To remove color from a selection

❖ Select the colored object and do one of the following:
   - Deselect Color in the Inspector.
   - Choose Remove Color from the Color menu in the toolbar.

To extract a color by using the Eyedropper tool

❖ Do one of the following:
   - In the Color palette, click the Eyedropper tool , move it over the color that you want to extract, then click to select the color.
   - In the Swatches palette, make sure that you aren’t in Edit mode (choose Edit Mode from the Swatches palette menu to deselect it), move the pointer over a swatch until it changes to an eyedropper , and then drag the eyedropper to the color that you want to extract.

*Note:* Notice that the color changes in the Color palette as you drag.

To apply an image or color to the page background

1. Click the Show Page Properties icon in the upper right corner of the document window.

2. In the Page Inspector, click the Page tab.

3. Under Background, do one of the following:
   - Select Image and reference an image file.
   - Select color and double-click the color field. Select a color from the Color Picker and click OK.
• Select Color and click inside the color field. Then select a color from the Color palette or the Swatches palette, or from a swatch library palette.

• Select Color, click the lower right corner of the color field, and choose a swatch library. Click the corner again to choose a color from the swatches displayed above the list of swatch libraries (GoLive displays the swatches from the swatch library you chose).

Note: When selecting an image for the background, keep in mind that GoLive and web browsers treat the image as a tile that is repeated to cover the page. Although colors that you choose for page backgrounds override the default colors used by most web browsers, other browser preference colors can override your page background colors.

See also

"About preferences" on page 34

To set default colors for text or links on the page

You use the Page Inspector to set default colors for text that you type on a page and for the three stages of links: normal (the normal appearance of a link in the web browser), active (when the mouse button is held down on a link in the browser), and visited (after a link has been clicked in the browser).

1 Click the Show Page Properties icon in the upper right corner of the document window.
2 In the Page Inspector, click the Page tab and do one of the following tasks:
   • To color all text on the page, select Text.
   • To color the various stages of hypertext links on the page, select Link, Active Link, or Visited Link.
3 Do one of the following tasks:
   • Click the color field, and select a color from the Color, Swatches palette, or a swatch library palette.
   • Click the lower right corner of the color field and choose a color from the swatches that appear.
   • Click the lower right corner of the color field and choose a swatch library. Click the corner again to choose a color from the swatches displayed above the list of swatch libraries (GoLive displays the swatches from the swatch library you chose).
   • Double-click the color field and choose a color from the Color Picker.
Chapter 8: Creating site diagrams

Creating diagrams

About diagrams
The diagram features of Adobe GoLive are powerful presentation and website creation tools. A diagram shows the hierarchy of HTML pages within a site and the links between pages, assets, and other files. It may also contain annotations, level indicators, custom objects, and boxes that hold text or images.

A diagram lets you lay out the structure of a site before you create real pages, and helps you manage the site creation process. You can use multiple prototype diagrams as you build and revise a site, creating and testing designs as you need them. You can present diagrams in print or online in Adobe PDF or SVG format. When you are ready to work with live pages, you submit a diagram, converting its pages to actual pages in the site.

Use the View palette and the Inspector to change the look of the diagram and the appearance and behavior of objects within it.

Setting up diagrams
When setting up a diagram, use this general workflow:

1. Set up the diagram.
   Open a new diagram and use the View palette to set page, grid, and canvas options for the design view, and to specify the appearance and labels of objects in the diagram.

2. Develop the structure of the diagram.
   Add objects to the design view. You can add objects that represent pages or sections (subtrees of pages), and link them in a hierarchy to other pages or sections.
3. **Prepare the diagram for presentation.**

In the design view, you can add annotation objects to provide text commentary, or add level objects to display brackets indicating levels of the site. To make objects appear on each page of a multipage diagram, drag them to the Master tab of the diagram window. To present the diagram to reviewers, print it to paper or export it to Adobe PDF or SVG format.

4. **Submit the diagram.**

Submit an entire diagram or selected items. Submitting converts pages in the diagram to real pages in the site, and creates scratch files for custom objects.

**See also**

“Publishing diagrams” on page 193

“Submitting diagrams” on page 198

“Developing diagrams” on page 182

**To create a new diagram**

1. Open a new or existing site.
2. Choose Diagram > New Diagram.
3. Enter a name for the diagram in the New Diagram box, and click OK. GoLive creates the diagram in the Diagrams tab of the site window.

**To open an existing diagram**

❖ In the Diagrams tab of the site window, double-click the diagram.

### Developing diagrams by adding pages and sections

**Developing diagrams**

You develop a diagram by adding to the design view objects that represent pages, sections (hierarchies of pages), and other items that can be added or linked to the site. After adding objects, you can create new links or redefine links, group and rearrange the objects, and anchor the diagram to an existing page in the site. You can change how design views display by using the View palette and the Layout tab of the Inspector.

If you expect the diagram to occupy several pages, and you want certain text or graphics to appear on each page, you may want to set up these items in the master view before you develop the diagram in the design view.

**See also**

“Changing the display of design views” on page 190

“To specify the layout of objects in a hierarchy” on page 192

“Master items” on page 193
Adding pages

You can add a single page to a diagram as a separate object, or add the page in any family relationship—parent, child, previous sibling, or next sibling—to another page or to a section. You can also add sets of child pages to a page or section. While adding the new child pages, you can make the child pages and their parent a section (or a subsection, if the parent page is within a section).

You can add content to pages while you are working on a diagram, or add the content after you have submitted the pages, and they exist as live pages in the site. Adding pages to a diagram affects its appearance and navigational logic, sometimes changing the position of other pages and the direction of lines that connect those pages. Before arranging a diagram for a presentation, add all pages and other objects, and establish their hierarchical positions.

See also

“Adding and defining sections” on page 184

To add a page outside a hierarchy

❖ Drag the Page icon from the Diagram set of the objects toolbox to an empty area of the design view. After creating the page, you can define it in the Page Inspector. You can also add other pages to the new page, creating family links, or create new hyperlinks.

To add a single page to another page or section

❖ Do one of the following:

• Select the page or section to which you want to add the page, and choose Next Page, Child Page, Previous Page, or Parent Page from the toolbar or the Diagram > New menu.

• Drag the Page icon from the Diagram set of the objects toolbox to the page or section. As you drag, a black bar appears next to the existing page or section, indicating a family relationship to the new page. Drag the Page icon above the page or section to add a parent, to either side of it to add a sibling, or below it to add a child.

To add a set of child pages to another page or section

1 Select the page or section to which you want to add the child pages.

2 Choose Diagram > New Pages.

3 Specify the number of pages to create, their file names, the stationery or template (if any) to use in creating the pages, and the types of links to generate. (See “Adding empty pages and pending links to a hierarchy” on page 227.)

4 If you want the selected page and the child pages you are creating to be a new section or subsection, select Make Parent a Section.

5 Click Create Pages From.

GoLive creates the child pages. If you selected Make Parent a Section, the parent page becomes a section page for the new section or subsection.

See also

“Adding and defining sections” on page 184

“Adding empty pages and pending links to a hierarchy” on page 227
To define a page in the Page Inspector
❖ In the Page tab of the Page Inspector, do any of the following:
  • Enter a design name for the page in the Name box. This name appears in the design view as the label for the page only if Design Name is selected in the Display tab of the View palette. Otherwise the label is its file name or page title.
  • Change the default page title.
  • Specify a template, stationery, or sample file for the page.

See also
“Changing the display of design views” on page 190

To add content to a page in a diagram
❖ In the design view, double-click the page. The page opens in a document window. You can edit the page using the same techniques used to edit pages added directly to a site.

Adding and defining sections
A section is a hierarchy of diagram pages, usually a subtree, that is part of a larger hierarchy. The section and its children are descendents of some other object. You treat a section as a unit to simplify file management. The pages in a section have the same base file name, and you can put them in the same folder and create them using the same template or stationery. Sections can contain other sections (subsections) as well as pages.

The parent page for a section or subsection is called its section page. The file name for a newly created section page is index.html, unless you have changed the home page file name in the site preferences. Section pages are displayed with boldface labels and the Section icon (if diagram objects appear as icons).

To add and define a section
1 Drag the Section icon \ from the Diagram set of the Object palette to the design view to create a section page.
2 If necessary, do one or both of the following in the Page tab of the Section Inspector:
  • Enter a design name for the page in the Name box. This name appears in the design view as the label for the page only if Design Name is selected in the Display tab of the View palette. Otherwise the label is its file name or page title.
  • Change the default page title.

Note: For a section page, don’t use the Target Dir option on the Page tab. You set the folder for the page and its children in the Section tab. Also, you probably don’t need to change the default file name for the section page. Even if the home page for the site has the same file name, the two files have different paths because the section has its own folder.
3 In the Section tab of the Section Inspector, do any of the following:
  • Enter a base file name for the child pages you will place in the section and their descendents. The page file names will be provided automatically. For example, if you enter the base file name Hiking, the page file names will be Hiking.html, Hiking1.html, Hiking 2.html, and so on.
  • Specify a target folder for the section page, the child pages in the section, and their descendents. When you submit the diagram, the pages will be placed in this folder. The target folder should be a subfolder of the root folder, either an existing subfolder or a new one that will be created when you submit the diagram. For example, you might
specify the folder Recreation/Hiking for the pages in the hiking section of a recreation site. If you don't specify a target folder, the folder used is either the root folder or the folder for generated items specified in Site preferences.

- Specify a template or stationery for the pages.

4 If you want to add child pages to the section page at this time, do both of the following:

- Choose the types of parent and sibling links to generate between the section page and its children. (See “Adding empty pages and pending links to a hierarchy” on page 227.)

- In the Count box, enter the number of child pages to add to the section page.

5 Click Create New Pages.

See also

“Changing the display of design views” on page 190

“Adding empty pages and pending links to a hierarchy” on page 227

Adding and editing links in diagrams

Adding and editing pending links

You can add pending links between pages, sections, and custom objects, and change links from one type to another. Tour links connect a series of objects, not necessarily adjacent siblings in a sequence. In the site settings, you can change the colors of links and add new link types.

To add a pending link of the type Hyperlink from one object to another

1 In the design view, select the source object. The pick whip appears.

2 Drag from the pick whip to the target object. A new link appears with the link type Hyperlink.

To add pending links between already linked objects

1 In the design view, do one of the following:

- Select two objects linked to each other.

- Select two or more objects linked in sequence, starting with the first object in the sequence.

> To select any object or link after the first object or link selected, Ctrl-click (Windows) or Shift-click (Mac OS). Repeat to deselect the object or link.

2 Right-click (Windows) or Control-click (Mac OS) and choose a link type from the Add Design Line submenu. Ordinarily, you add a type that complements the current link type. For example, you would add a Child link (parent-to-child) to a Parent link (child-to-parent).
To change a link type

1. In the design view, select a link. A small rectangle appears on the link, and the source and target objects are highlighted.

2. If necessary, select other links. If multiple links are selected, their source and target objects are not highlighted.

3. Choose a new link type in the Link Inspector. Normally you would choose only Hyperlink, Tour, or a user-defined link type because the family link types (Parent, Child, Next, and Previous) are more easily changed by dragging one of the linked objects onto the other one.

   **Important:** If you create a new family link between two objects by dragging one of them onto the other, the link is always valid. However, if you use the Link Inspector to create it, you may create an invalid family hierarchy—for example, a child with two parents.

See also

“Moving and copying objects” on page 188

To edit link types

1. With a site view open, choose Site > Settings > Diagram Link Types.

2. Select Site Specific Settings.

3. Do one or both of the following:
   - To change the color of a link type, select the type, click the lower right corner of the color field, and then specify a new color from the swatches that appear.
   - To add a link type, click the New button, type a name, and then click the lower right corner of the color field to specify a color from the swatches that appear.

Edits to link types apply to all diagrams associated with the current site.

Custom objects

**Custom objects**

You can create custom objects that represent items that you might add or link to a site, and add these objects to the Diagram set of the objects toolbox. The Diagrams set of the objects toolbox contains a number of predefined custom objects representing items such as forms, elements, databases, applets, and scripts. You can edit or delete these objects as needed.

Custom objects are images in GIF format, located in the Modules/Diagram Objects folder in the GoLive application folder. When you add a custom object to a diagram, you can specify whether to create a file for the object when it is submitted, and the type of file to be created. You must create the file from a template, stationery, or sample file. For example, you can add a movie to a site by creating a custom object that uses the movie file as a sample file. When the diagram is submitted, a new movie file is created from the sample file. All non-HTML files created from custom objects become scratch items.
To create a new custom object and add it to the Diagram set of the objects toolbox

1. Save an image using the following file name convention: myfilename-myextension.gif, where myfilename is the name that appears in the objects toolbox tool tip and is the default extension that is used in the file names of the created objects. (If you do not include a default extension and the preceding hyphen, .html is used.)

2. Place the image file in this folder: Adobe/GoLive CS2/Modules/Diagram Objects.

3. Restart GoLive. To be available from the objects toolbox, the custom object must be in the Diagram Objects folder when GoLive starts.

To specify a sample file for a custom object

1. Create a default sample file in the Adobe/GoLive CS2/Settings/DocumentStore/examples folder. The default sample file is used to create a file when you submit the object, unless you specify another file in the Object Inspector.

2. Open the defaults.agldex file in the DocumentStore folder and copy an existing <example></example> specification in this file. Example specifications have this format:

   where ident is the file name you specified for the custom object (without the hyphen and extension), mime is the appropriate mime type, ext is the extension you specified for the object, group is the appropriate group in the defaults.agldex file (markup, css, media, or misc), display name is the file name you specified (to be used in the user interface if the next three items are set to yes), context is no unless you want the file to be listed in the site context menu, menu is no unless you want the file to be listed in the File > New Special menu, sort specifies the sort order for the display name in menus, and file url is the name of your sample file (dialog is not used at this time).

3. Edit the copy of the specification and place it in the appropriate group in the defaults.agldex file.

4. Restart GoLive. To be available as a sample file, the file must be in the examples folder and defined in the defaults.agldex file when GoLive starts.

To add a custom object to a diagram

1. Drag the object from the Diagram set of the objects toolbox to the design view. You can add a custom object to an empty area of the design view, or drag it over an existing page, section, or other custom object to add it as a parent, sibling, or child of the existing object.

2. In the Object tab of the Object Inspector, do any of the following:

   • Enter a design name for the object in the Name box. This name appears in the design view as the label for the object only if Design Name is selected in the Display tab of the View palette. Otherwise the label is its file name or page title.

   • Select Create From to specify that a file will be created when the object is submitted, and then select Stationery, Template, or Sample. You must specify a stationery, template, or sample file in order to create a file for the custom object. To use a stationery or template file, choose the file from a menu. To use a sample file other than the default file in the DocumentStore folder, drag from the pick whip to the sample file. The sample file must be located on your computer.

   • Specify a file name and target folder for the file to be created when the object is submitted.

To edit a custom object

❖ Do any of the following:

   • Change settings for the object in the Object tab of the Object Inspector.

   • Change the sample file in the Adobe/GoLive CS2/Settings/DocumentStore/examples folder.
• Edit the specification for the object in the Adobe/GoLive CS2/Settings/DocumentStore/defaults.agldex file.
• Delete the object by removing its GIF file from the Adobe/GoLive CS2/Modules/Diagram Objects folder.

Moving and copying objects

Moving and copying objects
You can treat any item in a diagram simply as an object in a drawing program, and drag it as you would in such a program. You can also drag a page, section, or custom object onto another page, section, or custom object to create a new family link in the logical hierarchy. You can select a number of objects and drag them all at once. However, a better method is to group the objects and then drag the group.

You can also copy objects in a diagram, and duplicate them along with their links.

See also
“About groups” on page 189

To move an object without changing its position in the logical hierarchy
❖ In the design view, drag the object to a new location. If Collision Avoidance is selected, and you drag the object near or partially over another object, the other object will move (to avoid a collision) when the drag is completed.

Note: If you drag an object over another object and a line appears to the top, bottom, left, or right of the other object, you have dragged too far into the center of the other object. Decrease the overlap until the line disappears.

Any link lines connected to an object move when you drag the object. However, the object's descendents do not move with it as they would if you were moving the object to a new hierarchical position.

To move a page, section, or custom object into a new position in the logical hierarchy
1 In the design view, drag the object onto the page, section, or custom object you want it linked to. Depending on the position of the object you are dragging, a line appears above or below the target object or to its left or right.

2 Drop the object above, below, to the left, or to the right of the target object, depending on the family relationship you want the two objects to have.

See also
“Rearranging the parts of a hierarchy” on page 229

To move a copy of an object to a new location
❖ In the design view, Ctrl-drag (Windows) or Option-drag (Mac OS) the object to another location. A copy of the object is created at that location. If the original object is annotated or linked, the annotations or link lines are not copied.
To duplicate objects
1 In the design view, select the objects you want to duplicate.
2 Choose Edit > Duplicate. The objects and their connectors and links are copied. If you only select one object, it is duplicated along with its links.

Grouping objects

About groups
A group is a rectangle that encloses a number of objects in a diagram and lets you treat the objects as a unit. You can move, copy, or delete the objects in a group by moving, copying, or deleting the group. You can also close a group to temporarily unclutter the diagram.

The objects in a group must be located within the group rectangle, but they don't have to be in any logical relation to one another.

To group selected objects
1 In the design view, select the objects.
2 Choose Edit > Group, or click the Layout Group button in the Transform palette.
A group rectangle encloses the selected objects. If Collision Avoidance is selected, any unselected objects that would be enclosed by the rectangle move out of the way automatically.

To create an empty group in a particular location
1 Drag the Group icon from the Diagram set of the objects toolbox to the design view. If Collision Avoidance is selected, any objects at or near the icon's position move out of the way automatically.
2 Do one or both of the following as needed:
   • Resize the group by dragging one of its corner handles.
   • Reposition the group by dragging its title bar or border.

To set group options
1 Select the group by clicking its title bar or border.
2 In the Group Inspector, do any of the following:
   • Enter a name. It appears in the title bar if the title bar is displayed. You can also enter the name directly in the title bar.
   • Click an Align button to left-align, center-align, or right-align the group name.
   • Select or deselect Display Title Bar.
   • Select or deselect Auto Resize. With Auto Resize selected, the group rectangle is only as large as it needs to be to hold its contents, growing or shrinking as needed.
To add objects to a group
❖ Drag the objects into the group rectangle. If the rectangle is too small to hold the objects and you have selected Auto Resize in the Group Inspector, the rectangle enlarges automatically.

To ungroup, collapse, move, or delete a group
• To ungroup grouped objects, select the group and choose Edit > Ungroup, or click the Layout Ungroup button in the Transform palette.
• To collapse or expand a group, select it and click the Collapse/Expand button in the group's title bar.
• To move a group and its contents, drag its title bar or border.
• To delete a group and its contents, select it and press the Delete key.

Anchoring and displaying diagrams and objects

To anchor a diagram to an existing page in a site
When you submit a diagram, its pages become live pages in the site. To see these pages in the site's navigation view after you submit the diagram, you have to anchor its new pages to an existing page in the site.

1 Display the page that will anchor the diagram in a navigation view, in a links view, or in the Files tab of the site window. A navigation view gives you the best picture of how the diagram will be anchored.
2 Open the diagram window for the diagram and display a design view.
3 Make sure that both windows are accessible, moving one or both if necessary.
4 Drag the page that will anchor the diagram from its window to the design view. The page appears in the design view with the Anchor icon. It is also listed in the Anchor Pages group in the Staging tab of the diagram window.

If you drag the anchor page onto a page in the diagram, establishing a family link, make the anchor page a sibling of the page it is linked to. Parent-child links can produce unexpected results.

Changing the display of design views
The View palette works with design views in the same way it works with navigation and links views. The Design tab of the View palette has controls for viewing collections, for orientation, and for the display of peripheral panes and objects. The Grid tab has controls for the grid, collision avoidance, and the canvas.

Note: Collections are custom sets of page files, which can be visually identified by spotlighting.

See also
“About collections in navigation or links view” on page 222
“Collections” on page 435
**To specify how objects appear in a diagram**

❖ In the Display tab of the View palette, do any of the following:

- Specify whether to display master items, which appear on each canvas page, and whether to display breaks between pages.

- Specify whether to display staging icons next to pages. The Anchor Page icon identifies the page used to anchor a diagram to a site. The Generic Page icon indicates that a file for the page has been created but not edited or submitted. The Real Page icon indicates that the page file has been created and edited, but not submitted. The Live Page icon indicates that the page has been submitted, and that the page file has moved to its target folder in the site.

- Specify whether to show pages, sections, and custom objects as icons, thumbnails, frames, ovals, or icon frames. Ovals are oval if the frame size is set to Wide. Otherwise, they are circles.

- Specify how to label pages in the diagram. You can use as labels the page titles entered in the Page Title box of the Page Inspector, the file names of the pages, or design names entered in the Name box in the Page Inspector.

- Select Multi Line Text to allow long labels to wrap to multiple lines, or Overhang Text to allow the labels to grow horizontally. If you select neither option, long labels are truncated.

- Choose a frame size to set the amount of space around objects displayed as icons, or to set the size of objects displayed as thumbnails, frames, ovals, or icon frames. If you are using icon frames, the best choice for frame size is Wide.

- Click the Item Color box to select a custom color from the Color palette.

**Note:** You can also specify the background color of the design view of the Diagram window.

**See also**

“Customizing view colors” on page 227

**To set options for the grid or for collision avoidance**

1 In the Grid tab of the View palette, select any of the following:

**Visible** Displays horizontal or vertical grid lines, or both. You can also show or hide the grid by choosing View > Show Grid.

**Snap** Snaps objects in the diagram to the horizontal or vertical grid lines, or to both.

**Collision Avoidance** Moves other objects out of the way when you move or insert an object in a diagram.

2 If you selected the grid or collision avoidance, enter values in the Horizontal and Vertical boxes to specify the spacing between grid lines or the avoidance area.

💡 If you are using both the grid and collision avoidance, make the collision avoidance values multiples of the grid values.
To set canvas options

❖ In the Grid tab of the View palette, do any of the following:
  • To prevent the design view canvas from expanding beyond one page, select Canvas Is Single Page. This option
deselects the other options.
  • To allow the canvas to expand as necessary to contain objects added to the diagram, select the Auto options. The
canvas expands or shrinks in increments of pages.
  • To constrain the canvas to the specified number of rows and columns in the grid, enter values for Page Rows and
Columns.

To expand a view of a diagram
1. Choose Panorama Pane from the diagram window menu or select Panorama in the Design tab of the View
   palette. The panorama pane opens, showing the current design view and any parts of the diagram that extend beyond
   it.
2. Move the view box in the panorama pane to view different parts of the diagram.
   You can also expand a view by zooming out.

See also
“About the site view pane” on page 219

To specify the layout of objects in a hierarchy
The Layout tab of the Inspector is available when you add and select objects that can be linked to other objects in a
hierarchy—pages, sections, or custom objects. You can specify how links appear, the alignment of parents and
children, the effects of page breaks and the grid, and the arrowhead style for links.
1. In the design view, select a page, section, or custom object.
2. In the Layout tab of the Inspector, do any of the following:
   • To specify the display of links, choose a Draw Links As option. By default, connectors appear as single green lines
     with arrowheads, lines appear as two green lines with arrowheads, and outlines appear as single straight lines with
     no arrowheads. You can change the arrowhead style for connectors and outlines.
   • To specify the alignment of all child objects with their parents, select a parent object and click an alignment button.
   • To alternate offsets for each child (when links are drawn as connectors), or to display outlines on the right in a
     vertical layout (when links are drawn as outlines), select a parent object, and then select Stagger.
   • To space child objects, as they are added or removed, by using the spacing used for the parent object, select a parent
     object, and then select Auto Position.
   Note: When links are drawn as outlines, all child objects are automatically positioned.
   • To align the first child with the parent, select a parent object and then select Align Children. To center all children
     relative to the parent, select Center Children.
   • To prevent objects from straddling a page break, select Honor Page Breaks.
• To use settings in Grid tab of the View palette when distributing parent, child, and sibling objects, select Honor Grid.

• To specify values for spacing, enter values for the horizontal or vertical spacing between parent, child, and sibling objects, or for both horizontal and vertical spacing. Zero specifies the default spacing.

• To specify the style for connectors and outlines, choose an arrowhead.

Preparing diagrams for presentation

Publishing diagrams
After creating a diagram that represents a site, you can add boxes, annotations, and level objects to provide more information to reviewers or clients. Boxes are rectangular containers for text and graphics. Annotations are text comments that can be displayed along with an icon. Level objects are brackets, with optional labels, that can be used to indicate levels in a site. If you want objects created for presentation purposes to appear on each page of a diagram, you can add them as master items on the Master tab of the diagram window.

You can enhance the appearance of a diagram by aligning and distributing objects and adjusting the curvature of link lines. To publish the diagram, you print it to paper or export it to Adobe PDF or SVG format for an online presentation.

Master items
The Master tab of the diagram window provides a master view with the same grid and canvas settings as the design view. Objects added to the master view (master items) appear on each page of a diagram, but can’t be submitted. You might use master items, for example, to display a logo and title on each page of a diagram.

The master view shows only master items, but the design view shows both master items and objects added to the design view. You can add master items at any time, but it may be most convenient to set them up before beginning work in the design view. That way, you can see the master items while you lay out the diagram in the design view.

To add master items to a diagram
❖ Display the Master tab of the diagram window, and drag objects from the Diagram set of the objects toolbox to the master view.

Boxes in diagrams
Boxes are graphical containers that can hold objects, including text, graphics, and other boxes. All contents within a box are clipped to the box boundaries, and move with the box. You can format text within a box, and use it to present captions, titles, and other information.

When you drag an image to the design view, a box is automatically created to contain the image. You can display the image at its actual size by selecting Size to Image in the Box Inspector.
To add a box to a diagram

1 Drag the Box icon from the Diagram set of the objects toolbox to the design view.

2 In the Box tab of the Box Inspector, do any of the following:
   • Enter text in the Text box. In the design view, you can also enter text directly in the box by clicking in the box and typing the text.
   • Select Single Line to constrain the text to a single line.
   • Select Resize with Text to resize the box to fit the text.
   • Click an Align button to align the text.
   • Enter width and height values for the margins within the box.
   • Select font options for text: Bold, Italic, or both.
   • Specify the location of any image you want to appear in the box, and select Size to Image to size the box to fit the image.

3 In the Graphics tab of the Box Inspector, do any of the following:
   • Specify the color and line width of the border of the design box.
   • Specify the fill color of the design box.
   • Specify the color and font size of the text.

4 Specify how to apply the settings:
   Default Settings Uses the current settings for all subsequent boxes.
   Apply To All Applies the current settings to all existing boxes.

To change the curve of a link line

You can make link lines straight or deflect them from a straight line (curve them) to any degree and in either direction.

1 Select the line.

2 Do one of the following:
   • Drag the line's selection rectangle in the direction you want its deflection to increase or decrease.
   • In the Link Inspector, choose a percentage from the Deflection menu. Positive percentages increase the deflection to the right, negative percentages to the left. (Right and left are from the perspective of the source page—the page that the link arrow points away from.) A deflection of zero produces a straight line.

Note: When two pages are linked by two lines, giving the lines a zero deflection merges the lines. This effect is likely to obscure the design.
Annotations and level objects

Annotations

You use annotations to comment on a diagram or on items in a diagram, or to provide captions. Annotations consist of text with an optional subject line. Each annotation appears as an annotation icon in the diagram, and you can display the subject or text along with the icon. You can place an annotation on an object or link line, or anywhere in the design view. Annotations added to objects stay with the objects when they are moved. Annotations added to link lines stay with the lines when they are moved or deflected.

The Annotations tab in the diagram window shows the subject lines and text of all annotations to a diagram.

To add an annotation to a diagram

1. Drag the Annotation icon from the Diagram set of the Object palette to an object in the design view or a blank area of the canvas.
2. Enter the subject and text by doing one of the following:
   - In the design view, double-click the annotation, select the subject or text, and enter a new subject or text.
   - In the Annotation Inspector, enter the subject and annotation text.
3. In the Annotation tab of the Annotation Inspector, do any of the following:
   - To display the subject line in the diagram, select Display Subject.
   - To specify the alignment of the subject line, click an Align button.
   - To display the text in the diagram, select Display Text. (If you select both Display Subject and Display Text, the text appears under the subject.)
   - Choose a position option to specify whether the subject and text appear to the right or left of the icon, or centered above or below the icon.
4. In the Graphics tab of the Annotation Inspector, do any of the following:
   - Specify the color and line width of the annotation's border.
   - Specify the fill and header color of the annotation.
   - Specify the color and font size of the text.
5. Specify how to apply the settings:
   - Click Default Settings to use the current settings for all subsequent annotations.
   - Click Apply To All to apply the current settings to all existing annotations.

To view the subject and text of an annotation

Do one of the following:
- Double-click the annotation to open it.
- Click the Annotations tab of the diagram window and view it there.
- Select the annotation and view it in the Annotation Inspector.
To edit the subject or text of an annotation
1 In the Design or Annotations tab of the diagram window, select the annotation.
2 Do one of the following:
   • In the Annotation Inspector, enter a new subject or text.
   • In the Design tab, display the subject or text if necessary, and then select and edit the subject or text.
   • In the Annotations tab, select and edit the subject.

To delete an annotation
❖ In the Design or Annotations tab of the diagram window, select the annotation and press Delete.

To add a level object to a diagram
Level objects are brackets, with optional text labels, that you can use to indicate the hierarchy of objects in a diagram. You can place a bracket anywhere in the design view, and resize the bracket to include all the objects at a particular level.

1 Drag the Level icon 📧 from the Diagram set of the objects toolbox to the design view.
2 Position the bracket by dragging it.
3 Resize the bracket by dragging any of its handles.
4 In the Level tab of the Level Inspector, do any of the following:
   • Label the level by entering text in the Text box. You can also label the level in the design view by clicking to the left of the bracket and entering text in the text box that opens.
   • Click a vertical alignment button to position your label.
   • Click a text alignment button to justify the text within the brackets.
   • Select Single Line to constrain the label to remain on one line.
   • Select Center Bracket to center the bracket within its handles.
   • Enter width and height values for the label margins.
   • Select font options for the label text: Bold, Italic, or both.
5 In the Graphics tab of the Level Inspector, do any of the following:
   • Specify the color and line width of the bracket.
   • Specify the color and font size of the text.
6 Specify how to apply the settings:
   • Click Default Settings to use the current settings for all subsequent level objects.
   • Click Apply To All to apply the current settings to all existing level objects.

To align an object with its geometrical parent
1 Select the object.
2 In the Align palette, click one of the Align to Parent buttons.
Note: When you align an object with its parent, the parent is a geometrical dominant, not a logical parent within a hierarchy of family relationships. The geometrical parent is the entire canvas page, or it is the group if the objects you are aligning are in a group.

To align objects with each other
1 Select two or more objects.
2 In the Align palette, click one of the Align Objects buttons.

To distribute objects or spacing
1 Select three or more objects.
2 In the Align palette, do one of the following:
   • Click one of the Distribute Objects buttons.
   • Click one of the Distribute Spacing buttons.
   • In the Distribute Objects or Distribute Spacing section of the palette, select Use Spacing and enter a numeric value for the spacing offset.

Printing and exporting diagrams

To print a diagram
1 Open the design view for the diagram, and choose File > Print.
2 Select print options and click OK.

To export a diagram
1 Choose File > Export > Diagram, or choose Export Diagram from the diagram window menu.
2 Choose SVG or PDF.
3 To give the exported image the background color of the design view, select Preserve Background Color. Otherwise, the image is exported with a white background.
4 If you want the links to open the file, select Make Diagram Objects Into Links and specify the root URL.
5 (Optional) Select an annotation option:
   Static Exports annotations in their current states— with their contents displayed or closed to icons.
   Live Lets you open annotations by clicking them.
Staging and submitting diagrams

Submitting diagrams
When you submit a diagram, GoLive converts its pages and sections to real, editable HTML pages. The pages move to the Files tab, indicating that they exist as files within the site. Files for custom objects are created if possible. When you recall a submitted diagram, you reverse these changes. You can submit and recall a diagram repeatedly while you develop a site. You can also submit and recall selected objects within the diagram.

When you submit a diagram, the following changes take place:

- In the Staging tab of the diagram window, the pages move from the Design Pages group to the Live Pages group. (They also appear with the Live Page Staging icon in the Design tab.) Custom objects move from the Design Objects group to the Live Objects group.
- In the site window, the pages appear in the Files tab. The pages move from the diagram staging folder in the site data folder to the target folder in the root folder.
- In the navigation view, pages that are directly or indirectly linked to an anchor page appear in the central pane in the same hierarchy that they form in the design view. Unanchored pages and custom objects appear in the scratch pane.
- Pending links between pages are updated. The Pending Links palette can be used to resolve any problems with the links.

Note: Before submitting a diagram, you should check its staging and correct any errors that are detected.

Checking the staging of diagrams
When you check the staging of a diagram, you determine whether all its pages are connected by links to an anchor page and whether there will be folder or file name problems when the diagram is submitted. You can then make corrections as needed.

Note: Diagrams with staging errors cannot be submitted, and a few error conditions can be detected only when you attempt a submission. If you check a diagram, detect no errors, but are unable to submit the diagram, check it again.

To check the staging of a diagram
1 In the diagram window, click the Staging tab. If you haven't submitted the diagram, its pages are listed as Design Pages, and custom objects are listed as Design Objects. If you have submitted the diagram, the pages are listed as Live Pages.

2 Click the Check Design button on the toolbar, or choose Diagram > Staging > Check Staging. A check mark in the Check column opposite a page or object means that no errors were detected. Other icons in the column indicate problems or potential problems.
To correct staging errors

❖ Note the error icon or warning icon opposite the page or object in the Check column, and then use the following information to correct the problem:

**File In Use icon**  
Indicates that a page is open in a document window. Close all pages in a diagram before submitting or recalling the diagram.

**Target Folder icon**  
Indicates that the target folder for a page could not be created when you tried to submit the diagram. Change the Folder setting in the Section Inspector for the page's section, or change the Target Dir setting in the Page Inspector if the page doesn't belong to a section. For custom objects, change the Target Dir setting in the Object tab of the Object Inspector.

**Section Name icon**  
Indicates that a section page could not be named index.html (or another name assigned to the home page in Site preferences) because a file with that name already exists in the target folder. Rename the page or specify another folder for the page by changing the Folder setting in the Section Inspector.

**Stage In Scratch icon**  
Indicates that a page is not linked directly or indirectly to an anchor page. Unless you want the page to be treated as a scratch page when the diagram is submitted, drag an anchor page from the navigation view to a page in the design view or link the page to an anchored page in the diagram to create a family link. (See “To anchor a diagram to an existing page in a site” on page 190.)

**File Rename icon**  
Indicates that the page will be renamed automatically when the diagram is submitted. Normally this is an acceptable result.

Submitting all diagram items

You can submit a diagram for the first or only time, submit a diagram you have recalled, or submit a nonrecalled diagram to update a previous submission. To submit all diagram items:

1. Open the diagram in a design view.
2. Click the Submit button on the toolbar, choose Diagram > Staging > Submit All, or choose Submit All from the diagram window menu.

Updating and recalling diagram items

**Updating and recalling**

GoLive stores diagram files in the Diagrams tab of the site window and in the Diagrams folder in the Extras tab of the site window as .aglsd files, and prompts you to update the original diagram when you make changes to a submitted diagram. So, you can continue editing your live site with the confidence that your diagram will also remain current.

In some cases, however, you may find it necessary to recall a diagram. Recalling a diagram reverses the changes that occurred when the diagram was submitted. Recalls are often an expected part of the design process. For example, you might submit a diagram in progress to examine it in a live context, and then recall it for further design work. You can also perform selective submissions and recalls of items in a diagram. For example, you might submit selected items if you are abandoning a diagram as a whole but want to salvage parts of it. Or, you might submit a complete diagram, discover that part of it needs further design work, and recall only that part for retooling.
Updates involving substantial design changes can produce unexpected results. If this happens, try recalling the updated diagram, checking and fixing it, and resubmitting the diagram.

To recall all diagram items
1 Open the diagram in a design view.
2 Click the Recall button on the toolbar, choose Diagram > Staging > Recall All, or choose Recall All from the diagram window menu.

To submit selected items
1 In the Design or Staging tab of the diagram window, select the items.
2 Do one of the following:
   • Choose Submit Items from the Diagram > Staging menu or the diagram window menu.
   • Choose Submit Items to Scratch from the Diagram > Staging menu or the diagram window menu.

To recall selected items
1 In the Design or Staging tab of the diagram window, select the items.
2 Choose Recall Items from the Diagram > Staging menu or the diagram window menu.
Chapter 9: Managing and viewing websites

Site management features and preferences

About site management
A website is built from a collection of linked files. These files can contain objects such as HTML, images and media, and scripts. Maintaining properly linked files and organizing the files into a logical hierarchy are important for managing a site. GoLive offers several tools for managing and viewing sites.

Site window Provides access to all of the site files and assets so that you can view and manipulate files and folders within your site. It’s good practice to maintain all your source files, data, HTML files, scripts, and media in the site window. The site window not only helps you avoid breaking links and creating orphan files, it also gives you easy access for fixing site file errors.

Graphical views Lets you look at the hierarchy of your site with different representations. Graphical site views are useful for examining the navigation of your site, reviewing files, or establishing or correcting links.

In & Out Links palette Lets you manage your links. You can use this link management tool to change links and file references. For example, if you use an application other than GoLive to change the name of an image file, you can use the In & Out Links palette to change all references in your site to the new file name.

See also
“About graphical site views” on page 214
“About GoLive sites” on page 145
“Changing all site URLs or links at once” on page 232
“About the site window” on page 202
“About site assets” on page 420

Specifying preferences and settings for websites
When you manage a website, it’s important to specify several application-wide Site preferences and site-specific settings that affect the site.

The Site preferences establish the way you manage all sites and include settings for general file and folder management, Filename Constraints, Status, Clean Up Site, Upload/Export, Diagram Colors, and Diagram Link Types. Two other categories of application-wide preferences that also affect the management of all sites are the Script Library preferences and Internet preferences. The Script Library preferences include settings for how GoLive handles JavaScripts, and the Internet preferences include settings for connectivity and network status.

In addition to the Site preferences, you can also specify site-specific settings for Publish Servers, URL Handling, URL Mappings, Diagram Colors, Script Library, and others. The site-specific settings override the Site preferences.
To set preferences that affect all sites
1 Choose Edit > Preferences (Windows) or GoLive > Preferences (Mac OS).
2 In the Preferences dialog box, select one of these options from the list on the left: Site preferences 🌐 and a Site category, Script Library 📖, or Internet 🌐.
3 Set the preferences you want to apply to all sites.
4 Click OK.

To specify site-specific settings
1 Open a site.
2 Click the Site Settings button 🔧 on the toolbar or choose Site > Settings.
3 In the Site Settings dialog box, click a category from the list on the left pane and then select options on the right.
4 If the Site Specific Settings option is available for a category, select it to have the site-specific settings override the Site preferences.
5 Click OK.

Working with the site window

About the site window
GoLive organizes a site into ten tabs to handle different aspects of site management:

Files Contains HTML, XHTML, XML, media, and other files, as well as folders that you can use to organize the files.

External Displays external URLs and e-mail addresses referenced by the site files.

Diagrams Contains diagrams with a graphical view of possible site implementations.

Colors Contains a collection of colors used in your site.

Font Sets Contains a collection of font sets used in your site. The font sets are lists of alternative fonts that you use to override the browser's default display font settings.

CSS Contains a list of the external stylesheets, classes, and identifiers (IDs) used in your site. The CSS tab also lists the number of times a stylesheet, class, or identifier is defined in the site and how many times it’s used.

You can also show and hide the right pane of the site window that contains these additional tabs:

Extras Contains all of the files and folders in the site’s web-content folder and web-data folder. The web-data folder contains four types of reusable objects: components, stationery pages, snippets, and page templates. The Extras tab also contains diagrams, Smart Objects, InDesign packages, queries, and files moved to the Site Trash. (See “About site assets” on page 420.)

Errors Contains missing files, orphan files, Smart Object warnings, and files that have a name that doesn't meet your file name constraints. An orphan file is referenced in a link but GoLive can't find the file, or the file is outside the web-content folder. If you manage files in the site window, you can avoid creating orphan files. Click a file in the Errors tab to open the Error Inspector.
Publish Server  Displays the site on a remote server while GoLive is connected to a publish server (an FTP, WebDAV, or local file server).

Collections  Displays custom sets of one or more files that you select manually or define as a result of a query, syntax check, or find operation.

The status column in the site window contains icons that show you each file's status. The checkmark icon ✓ indicates that the file is error-free—that all files referenced in it have been found.

You can also display a third view of the site window that contains two graphical views: navigation and links view.

See also
“About graphical site views” on page 214

To open a site file in the site window
❖ Do one of the following:
  • Choose File > Open, browse to the site file (.site), select it, and then click Open.
  • Double-click the site file on your system desktop.

Opening a site file automatically creates a backup of the file. GoLive deletes the backup when you save and close the site file.

Note: If you need to reopen a site that was open during a computer crash, open the regular site file, not the backup site file. If it is necessary to use the backup, GoLive will inform you.

To show or hide the right pane of the site window
❖ Click the Toggle Split View icon in the scroll bar at the bottom of the window.

To customize the display of the site window tabs
  • To change the sort order of the column that the tab is currently being sorted by, click the column's head.
  • To sort the tab by another column, click the column head.
  • To show and hide columns, choose the column names from the Show Columns menu in the View palette.
  • To resize a column in a tab, drag the right border of the column head to the left or right.
• To change the position of a column in the tab, drag (Windows) or Command-drag (Mac OS) the column head to the left or right. (You can't change the position of the leftmost column in any tab.)

• To go up one level in the folder or group whose contents are listed in the tab, click the Go Up button (Windows) or (Mac OS) at the top of the tab.

**Note:** Once you've reached the topmost level of the folder hierarchy reflected in the site window, GoLive opens the Local File Browser to let you navigate through the file system.

• To show or hide the anchors in a page, click the icon to the left of the page to expand or collapse the page.

• To change the view of items in a tab, choose an option from the Site > View menu.

**See also**

“Displaying palettes and tabs” on page 27

**To restore the original configuration of the site window**

❖ Choose Default Configuration from the site window menu for either pane of the window.

**About site files and folders**

In GoLive, a site is a collection of files that are used as resources for developing and maintaining a website on a web server. Viewers of the website only see files that you upload to the web server. These files include the home page (usually named index.html), pages linked directly or indirectly to the home page, and media files referenced by any of these pages.

Viewers don't see the rest of the files that are usually placed in the web-data and web-settings folders, and normally the contents of these folders are not uploaded to the server.

The files comprising a GoLive site include the site file and the contents of three folders: the web-content folder, the site web-data folder, and the site web-settings folder.

• Files and file information that are managed by the site file are displayed in the various tabs of the site window.

• The contents of the site web-content folder are listed in the Files tab of the site window.

• The contents of the site web-data folder are listed in the Extras tab of the site window.

• The site web-settings folder contains XML files of site-specific settings, and settings for the Colors tab, External tab, and Font Sets tab.

**See also**

“To upload site files to a publish server” on page 443

**Working with files and folders in the site window**

In the site window, arrange files in folders to keep them in order. For example, create separate folders for storing pages, images, and animations in the Files tab in the site window.

**Note:** When using GoLive, you can reference files in any folder on your system. However, if you use a system tool such as Explorer (Windows) or Finder (Mac OS) to move, rename, or delete site files, GoLive doesn't update link and reference information. Therefore, it's highly recommended that you work in the site window when moving, renaming, or deleting files. If you do move, rename, or delete files with a system tool, be sure to refresh the view of files in the site window. (See “To refresh the Files, CSS, Extras, Diagrams, Collections or Publish Server tab” on page 209.)
Similarly, use the site window to arrange non-file items in groups. (GoLive treats and displays a group in the site window as a type of folder, but all groups are stored within the Settings folder rather than within other regular folders on your hard disk.) Items in the Files and Extras tabs are stored in regular folders. All non-file items in the External, Colors, and Font Sets tabs are stored in groups. Items in the Collections tab are stored in collections. Items in the CSS tab are stored in default groups (you can’t organize them in new folders).

**Dragging and dropping files in the site window**

You can drag files around in the site window just like you drag files on your desktop. When you drag in the site window, GoLive continually tracks the files and updates file references in the site accordingly. You can drag files from the site window into an open web page to add images, Smart Objects, site assets, or hypertext links to the page. You can drag text and objects from one page to another, and from one site to another. Using the objects toolbox, you can drag objects representing HTML elements to an open page. You can drag text and objects from the page into the Snippets tab of the Library palette for storage with the site or application.

*Note:* You can’t drag files from the CSS tab of the site window.

If a window is hidden behind other windows, you can drag to the Select Window button on the toolbar to bring the window to the front. When you drag a file or object to a tab on a window, GoLive brings the tab to the front of the window.

**To create a folder (group, regular folder, or collection)**

1. Click the tab where you want to create the folder.
2. If you want the folder you are creating to be subordinate to an existing folder in the tab, select the existing folder.
3. Do one of the following:
   - To create a new folder, click the Create New Folder button on the toolbar.
   - To add a folder to the Files or Extras tab, drag the Folder icon from the Site set of the web to the site window.
   - To add a group to the External tab, drag the URL Group icon or the Address Group icon from the Site set of the objects toolbox to the site window.
   - To add a group to the Colors tab, drag the Color Group icon from the Site set of the objects toolbox to the site window.
   - To add a group to the Font Sets tab, drag the Font Set Group icon from the Site set of the objects toolbox to the site window.
   - To add a collection to the Collections tab, drag the Collection icon from the Site set of the objects toolbox to the site window.

GoLive assigns a generic name of “untitled folder” for a new folder in the File tab; “untitled collection” for a new collection in the Collections tab; and “untitled group” for a new group in the Colors, External, or Font Sets tab.

4. Enter a new name for the folder or group.
5. Move items into the folder as necessary.

   *You can also import files and other items into a site.*

**See also**

“‘To add an existing file to a site” on page 156
To move a file or object to a folder (group or regular folder)

1 Do one of the following:

- Drag the file or object from a folder in the Explorer (Windows) or Finder (Mac OS) into a folder or tab in the site window.
- Drag an object into a group.

Note: If you want the target folder to open so that you can see its contents, position the pointer over its icon before releasing the mouse button. If you want to target a folder one level up from the folder displayed in the tab you are dragging into, drag the file or object to the Go Up button at the top of the tab.

2 If you are moving a file containing links or file references, click OK in the Move Files dialog box to update them.

Important: If you exclude any file from updating, broken links and invalid file references might result.

To open the desktop folder containing a file or folder in the site window

1 Select the file or folder in the site window. You can select only regular folders and files, not groups or objects in groups.

2 Click the Reveal In Explorer (Windows) or Reveal In Finder (Mac OS) button on the toolbar.

Inspecting, tracking, and deleting files

Inspecting files with the File Inspector

The File Inspector for any selected file has a File tab with basic file information, a Name tab with information on whether the file name matches or violates a file name constraint, and a Content tab with a thumbnail of the file. For HTML and XHTML files, the File Inspector includes an additional Page tab with the page title and encoding information. The Folder Inspector includes basic folder information and a Name tab with file name status.

You can also use the File Inspector and Folder Inspector to rename files and folders, or change their publish state and their status label.
To inspect a file or folder

1. Display the Inspector.
2. Select the file or folder in the site window.
3. If you selected a file, click the File, Name, Page, or Content tab in the File Inspector as necessary. If you selected a folder, click the Folder or Name tab in the Folder Inspector as necessary.

To show file information in Explorer or Finder

❖ Click the Show Information In Explorer button (Windows) or the Show Information In Finder button (Mac OS) on the toolbar.

Tracking work on site files

The Workflow palette lets you keep track of what state your site files are in, and is useful whether you’re working alone or in a workgroup. When you select a file in the site window, the Workflow palette lets you indicate who is editing a file and how complete the file is. This information is displayed in two additional columns in the Files tab of the site window for easy reference—in the To Be Edited By column and the Completed column.

Note: You can also add metadata to a file in a site to preserve information about the contents, copyright status, origin, and history of the file.

❖ If you hover the mouse pointer over files in the site window, metadata will appear as a tool tip.

See also

“Using metadata with site files” on page 173

To indicate the state of a file or folder

1. Choose Window > Workflow to display the Workflow palette.

Note: If Workflow does not appear in the Window menu, choose Edit > Preferences (Windows) or GoLive > Preferences (Mac OS), and then click Modules. Make sure the Workflow option, which is at the bottom of the list under Extend Scripts, is selected in the right pane, and then restart GoLive.

2. Select a file or folder in the site window.

3. In the Workflow palette, enter a name in the To Be Edited By text box, and then choose a percentage from the Completed menu.
To delete a file, regular folder, object, or group

You can delete items from all tabs of the site window except for the CSS tab.

1. Select the item.
2. Click the Delete Selected Item button on the toolbar.
3. If necessary, confirm the deletion by clicking Yes.

When you delete a file or folder from the site, you send it to a Site Trash folder or to the system Recycle Bin or Trash. The default destination is Site Trash, but you can select the Recycle Bin or Trash as the destination in the Site preferences.

Note: For many purposes, updating the Files or Extras tab or removing unused objects from the External, Colors, or Font Sets tab is preferable to deleting the file or object. (See "To refresh the Files, CSS, Extras, Diagrams, Collections or Publish Server tab" on page 209.)

To recover a file from the Site Trash

1. If necessary, click the Toggle Split View icon in the scroll bar at the bottom of the site window to show the right pane.
2. Click the Extras tab.
3. Open the Site Trash folder and then select the file you want to recover.
4. Do one of the following:
   • If you haven't performed any other actions since you deleted the file, choose Edit > Undo Move To Trash.
   • Drag the file to its previous location (or another location) in the Files tab.

To move files to the system Recycle Bin or Trash

❖ In the Extras tab, do one of the following:
   • To move all files from the Site Trash to the system Recycle Bin or Trash, right-click (Windows) or Control-click (Mac OS) the Site Trash icon and then choose Empty Site Trash.
   • To move an individual file from the Site Trash to the system Recycle Bin or Trash, select the file and then press Delete (Windows) or Command-Delete (Mac OS).

To change the destination of file and folder deletions

1. Choose Edit > Preferences (Windows) or GoLive > Preferences (Mac OS), and then click Site.
2. Select a trash option, and then click OK.
Refreshing and cleaning up sites

To refresh the Files, CSS, Extras, Diagrams, Collections or Publish Server tab

Refreshing tabs in the site window lets you view the actual site—that is, the contents of the site’s web-content folder (Files tab and CSS tab), web-data folder (Extras and Diagrams tabs), or web-settings folder (Collections tab).

1. Do one of the following:
   - To refresh the Files, CSS, Extras, Diagrams, or Collections tab, click the tab. If you click the Files tab, also open the desired folder.
   - To refresh the Publish Server tab, connect to a publish server, and then open the server directory you want to refresh.

2. Click the Refresh View button on the toolbar or choose Site > Update > Refresh All.

If your site contains a password-protected PDF file, GoLive will prompt you for the password when you refresh the site.

Note: Refreshing the site window may result in files being added to the site window, files being removed, or both, depending on changes you’ve made to files both in and outside GoLive. Refresh the site window if you have been working with files outside GoLive—for example, using the Explorer (Windows) or Finder (Mac OS) instead of GoLive to move, rename, or delete, files in the site window.

Adding used items to and removing unused items from the site window

GoLive can scan all pages in your site for non-file items that are used on a page but are not listed on the External, Colors, or Font Sets tabs. Once found, GoLive adds these items to the appropriate tabs in the site window. For example, GoLive adds a color to the Colors tab if the color is being used on a page but isn’t listed in the Colors tab.

If GoLive finds new references or addresses that need to be listed in the External tab, GoLive creates a Scanned URL or Scanned Addresses group for them in the tab. Similarly, Scanned Colors or Scanned Font Sets groups are created in the Colors or Font Sets tab if new colors or font sets are found.

You can remove references, colors, or font sets that are not being used in your site from the External, Colors, and Font Sets tabs.

To add used items to and remove unused items from the site window

1. Click the External, Colors, or Font Sets tab.

2. Click the Get Used/Remove Unused button on the toolbar.

Note: By default, the Get Used/Remove Unused button adds items in use and removes unused items. To perform a single action only, such as removing unused items, click the triangle to the right of the Get Used/Remove Unused button and choose an option.

3. Click OK to confirm the removal of unused items, if necessary.
To update site files that are dependent on site extras

When you update site files, GoLive checks the content of the Components, Templates, Smart Objects, and InDesign Packages folders in the site’s web-data folder for updates to that content made outside of GoLive.

1 Open a site.

2 Do one of the following:

- To check all components, templates, Smart Objects, or InDesign packages for updates, choose Site > Update > Files Dependent On Site Extras or click the Update Files Dependent On Site Extras button on the toolbar.

- To check specific components, templates, or Smart Objects for updates, select templates, components, or Smart Objects in the Extras tab of the site window (Control-click to select multiple files), and then choose Site > Update > Files Dependent On Selection.

3 If necessary, select files to update in the Update Dependent Files dialog box.

See also

“About site assets” on page 420

“Advantages of Smart Objects” on page 358

“Importing InDesign packages” on page 385

To clean up a site

The Clean Up Site command is essential for maintaining your site and preparing it for publication (uploading to a web server for viewing by the public). Cleaning up a site gets rid of unused links, colors, e-mail addresses, and font sets that can clutter the working version of your locally stored site. You can also use this command to copy any files or objects into the web-content folder that are referenced in your site, but actually located outside the web-content folder.

1 Choose Site > Update > Clean Up Site.

2 If the Clean Up Site Options dialog box appears, select options as necessary, and then click OK. (See “To specify options for cleaning up a site” on page 210.)

3 If the Copy Files or Clean Up Site dialog box appears, select the files you want to copy into or remove from the web-content folder, and then click OK. Click OK in the Update Files dialog box.

To specify options for cleaning up a site

1 Do one of the following:

- To specify options for cleaning up the active site only, click the Site Settings button on the toolbar or choose Site > Settings. Then click Clean Up Site in the left pane, and then select Site Specific Settings.

- To specify options for cleaning up all sites, choose Edit > Preferences (Windows) or GoLive > Preferences (Mac OS), and select Site from the list on the left. Then click Clean Up Site.

2 Select options as follows:

- To refresh the view of items listed in the site window, select Re-search For Files.

- To copy files that are used in your site into the web-content folder if they are stored outside the web-content folder, select Add Used Files. If you want to display a dialog box that lets you select the files to be copied, select the Show List Of Files To Copy option.
• To add non-file items that are used in your site but are not listed in the External, Colors, or Font Sets tab in the site window, select Add Used External Links, Add Used Colors, or Add Used Font Sets.

• To move files not being used in your site to the Site Trash, select Remove Files Not Linked. If you want to display a dialog box that lets you select the files to be removed, select the Show List Of Files To Remove option.

• To remove non-file items that are not being used in your site but are listed in the External, Colors, or Font Sets tab in the site window, select Remove Unused External Links, Remove Unused Colors, or Remove Unused Font Sets.

• To use the default settings for all options, click Factory Settings.

3 Click OK.

Providing names and paths for files

About file names
Files and folders need to be properly named so they can be uploaded correctly to the server hardware you're working with, whether it's Windows, Mac OS, UNIX, MS-DOS®, or some other operating system. GoLive comes with a set of file name rules that ensure cross-platform compatibility. When a file name violates one of the rules, the Errors tab of the site window and the File Inspector indicate the problem. The File Inspector also lists the rule itself.

You can examine, modify, delete, and add file name rules. (See "File name constraints" on page 212.)

When naming files and folders, use lowercase to avoid case-sensitivity problems and don't include spaces in the name. Spaces in file and folder names are automatically converted to the URL escape code ”%20” during the FTP process. As a result, some links and file references might become invalid.

Naming files and folders
When you create a new empty file, GoLive automatically gives it a name. If you know what content that file will contain, you'll probably want to rename it.

When you rename a file that is referenced by other files, you can update the other files with the new file name at the same time. For information on updating an entire site for a URL that other files reference, see "Changing all site URLs or links at once" on page 232.

If you use a name for a file or folder that contains illegal characters as defined by the current file name constraint for the site (or all sites), GoLive displays warnings in the Errors tab of the site window, the Name tab of the File or Folder Inspector, and the Status column of the Files tab.

To rename a folder
❖ Select the folder in the Files tab in the site window and then enter the new name in the Folder tab of the Folder Inspector.

To rename a file
1 Select the file in the Files or CSS tab in the site window and then enter the new name in the File tab or the CSS Item tab of the File Inspector.

2 If there are any other files that contain references to the file you renamed, the Rename File dialog box appears. To have GoLive automatically update the references with the new file name, leave the files selected and then click OK.
File name constraints
GoLive alerts you if you use a file name that doesn't meet the designated file name constraints. GoLive provides several constraint sets, or you can create your own sets. GoLive's default set is called the GoLive standard, a combination of Windows 98, NT®, 2000, XP®, Mac OS, and UNIX. Other sets are GoLive strict, GoLive lower case, Windows (applies to Windows 98, NT, 2000, XP), MS-DOS/Windows 3.1, Mac OS, Mac OS X, and UNIX. You can also select the File System Default set to have your operating system enforce file name constraints instead of GoLive.

To check for file name constraint violations
❖ Select the file, and then click the Name tab in the File Inspector to view any violations.

To change file name constraints
1 Do one of the following:
   • To change file name constraints for the active site only, click the Site Settings button on the toolbar or choose Site > Settings. Then click Filename Constraints on the left, and select Site Specific Settings.
   • To change file name constraints for all sites, choose Edit > Preferences (Windows) or GoLive > Preferences (Mac OS), expand Site on the left, and then click Filename Constraints.
2 Choose a set of constraints from the Selected Constraints menu.
3 Click OK.

See also
“File name constraints” on page 212

To add a set of file name constraints
1 Do one of the following:
   • To add a set for the active site only, click the Site Settings button on the toolbar or choose Site > Settings. Then click Filename Constraints on the left, and select Site Specific Settings.
   • To add a set for all sites, choose Edit > Preferences (Windows) or GoLive > Preferences (Mac OS), expand Site on the left, and then click Filename Constraints.
2 Choose a set of file name constraints from the Selected Constraints menu that most closely matches the set of constraints you want to use.
3 Click Duplicate. This creates a new duplicate set. You can edit and delete a duplicate set, but you can't delete the original.
4 Enter a name for the new set in the Selected Constraints text box.
5 Edit the set in the other text boxes as necessary.
6 Click OK.

See also
“File name constraints” on page 212
Using absolute link paths

About absolute link paths
Site pages contain paths to a variety of linked files: other pages in the site, images displayed on the page, media items embedded in the page, and so on. GoLive automatically uses relative paths—paths that point to the location of a file in relation to the current file—for the destinations of links. In most cases, relative paths are appropriate to use. But, if necessary for special cases, you can selectively change the paths to make them absolute, or set a preference to have GoLive make all new paths you create absolute by default. When you make a path absolute, the entire path from the root folder to the linked file is provided. Otherwise only a relative path is provided.

For example, the page /root/pages/info/page.html (where root is the name of the root folder) references the image /root/images/image.gif. The absolute path to the image file is /images/image.gif. The relative path is ../../images/image.gif.

Absolute paths are useful in the following cases:

- If a form references a CGI script at the root level of the site directory (or any other subdirectory), any references to that file are usually written as absolute.
- If a common navigation bar is used on many pages that reside in folders at various hierarchical levels, you can use an absolute path specification throughout to reference its image files, allowing you to copy and paste the same code snippet onto all the pages.

However, absolute paths work only at sites where there is a web server providing information about the location of the site’s root folder. For the same reason, using absolute paths prevents you from previewing pages in a web browser on your local computer—that is, a previewing browser has no way of locating this root folder.

Note: An absolute path in GoLive is not a full path from the file system root or a fully qualified URL.

See also
“To make the path of a link absolute” on page 213
“To set a preference that makes all new links absolute” on page 214
“To specify a site setting that makes all new links absolute in the active site only” on page 214

To make the path of a link absolute
You can specify absolute paths for all new links or for specific links.

1 Select the link.

2 Do one of the following:
   - Choose Relative from the URL menu to the right of the Browse button in the Inspector, if it is checked. (Unchecked indicates the link is absolute.)
   - Choose Edit from the URL menu in the Inspector. In the Edit URL dialog box, click Make Absolute, and then click OK.

You can also use the Edit URL dialog box to add query parameters to the URL.
See also
“About links” on page 167
“Editing links and adding query parameters to links” on page 170

To set a preference that makes all new links absolute
1 Choose Edit > Preferences (Windows) or GoLive > Preferences (Mac OS).
2 Expand General preferences and select URL Handling.
3 Select Make New Links Absolute, and then click OK.

To specify a site setting that makes all new links absolute in the active site only
1 Open a site.
2 Click the Site Settings button on the toolbar or choose Site > Settings.
3 Select URL Handling.
4 Select Make New Links Absolute, and then click OK.

Working with graphical site views

About graphical site views
GoLive provides site views that are graphical representations of a site’s pages and the links that connect them. You can use the graphical site views with the site window to display and edit the content and structure of your website, and examine the links and relationships between pages.

- The navigation view shows a tree-like hierarchy of pages (beginning with the home page) that underlies the web of links in your site. You can add pages to the structure, move pages around, and open pages from the navigation view.
- The links view shows a web of actual links going in and out from each page to other pages, images, or media files in your site, and to external URLs or e-mail addresses. You can expand or collapse the various levels of links to focus on the overall structure of links in the site or links of a single page.

The pages shown in each graphical site view are also listed in the Files tab of the site window. When you select a page in a view, you can select the same page in the Files tab by clicking the Reveal In Site button on the toolbar. By using options on the View palette, you can expand the site views into additional panes that display a panorama of the site, reference pages used by a selected page in the site, or scratch pages that are not linked to any pages in the site.

GoLive also provides other graphical tools for managing and viewing websites. You can use the In & Out Links palette to see incoming and outgoing links for files, and change links and file references throughout a site. You can also use diagrams to show the hierarchy of pages and the connections between site assets.
To display a graphical site view

1. Open the site file for your site.
2. Choose Navigation or Links from the Site window menu.

Navigation view

With a new imported site, the navigation view shows the structure of the site as a tree-like hierarchy descending from the home page. With a new blank site, the navigation view shows a single home page, and you can build the structure of the site by adding empty pages to the home page in the same sort of hierarchy. You can also use this method to add pages and substructures to an imported site.

In either case, the hierarchy comprises logical pair relationships between pages in which a page is either a child, a parent, a previous sibling, or a next sibling. A typical parent-child relationship is between a home page and pages it links to.
A typical sibling relationship is between the first (previous) and second (next) pages in a book-like sequence of pages. With the structure established, you can fill the empty pages with content and link them together in a way that reflects the structure. Alternatively, you can rebuild the hierarchy with different settings to establish a different structure before you reflect the structure with links.

See also
“Adding empty pages and pending links to a hierarchy” on page 227
“Creating a hierarchical structure” on page 232

Links view
When you open a links view of a site, it shows the site's home page file (often called index.html). If the site contains pages linked to the home page, pages linked to these pages, and so on, you can view them by expanding the view, first from the home page and then from other pages that come into view. Each expansion displays files linked to the expanded file. Expansions in one direction show incoming links—links with their source in other files and the expanded file as their destination. Expansions in the opposite direction show outgoing links—links to other files with their source in the expanded file. An individual file can appear several times in the view—for example, as an incoming link to the left of an expanded file, and as an outgoing link to its right.
You can choose options for displaying incoming links only, outgoing links only, no links, or only the link path you are currently exploring.

To change or fix links, use the links view to select files and the In & Out Links palette to change or fix links.

See also
“To vary the view of link types and link paths” on page 225
“Changing all site URLs or links at once” on page 232

Expanding and collapsing views
When you expand or collapse a file in one of the site views, you show or hide the files linked to it. The feature works in much the same way that expanding and collapsing folders work in Windows Explorer or Mac OS Finder.

When you expand a file, it stays expanded until you collapse it explicitly. For example, if you collapse a file that governs a long path of files, the entire path disappears. If you then expand the same file, the entire path reappears, not just the files linked directly to the expanded file.

You expand files from the home page file to view a whole site. Because most sites contain too many files to view all at once and scrolling the view can be awkward, you sometimes need to collapse files to view another portion of the site. However, there are a number of more precise techniques for moving and limiting the view. (See “To magnify or reduce the view in the main pane with a Zoom menu” on page 221 and “Centering views and displaying partial trees” on page 221.)

To completely expand the view of a site or a tree in the site
1 In a navigation view or links view, do one of the following:
   • To expand the view of a site completely, select the home page (index.html).
   • To expand the view of a tree in the site completely (a selected page and all of its children and grandchildren pages), select the page that is at the root or top of the hierarchy.
2 Click the Unfold Hidden Child Items button on the toolbar.

To incrementally expand the view of a site
1 Do either of the following:
   • In a navigation view, click the Expand button next to a page to view its child page or pages.
   • In a links view, click the Expand button next to a page to view its incoming or outgoing links. The location of the Expand button relative to the page determines whether the links are incoming or outgoing.
2 Continue clicking Expand buttons until the view is expanded in the way that you want.

To incrementally collapse the view of a site
1 Do either of the following:
   • In a navigation view, click the Collapse button next to a page to hide its child page or pages.
   • In a links view, click the Collapse button next to a page to hide its incoming or outgoing links.
2 Continue clicking Collapse buttons until the view is collapsed in the way that you want.
To get advance information about an expansion (Windows only)
❖ Pause the pointer over the Expand button before clicking it. A tool tip provides the number of children, incoming links, or outgoing links the expansion contains.

To change the orientation of a view
When you first view a site, its navigation view has a wide orientation and its links view has a tall orientation. Both navigation view and links view can appear in either wide or tall orientation. Both views use four directions to indicate types of links.

❖ Do either of the following:
   • Click the Toggle Between Horizontal/Vertical Orientation button on the toolbar.
   • In the Navigation tab or Links tab of the View palette, select Tall or Wide.

In wide orientation, a navigation view uses the four directions as follows: Above is the parent page, below is the child page, left is the previous page, and right is the next page. In tall orientation, the parent page is left and the previous page above.

In tall orientation, a links view uses two directions as follows: Left is the incoming link and right is the outgoing link. In wide orientation, the incoming link is above.
Using the peripheral panes of the site views

About the site view pane
The navigation or links site views usually have a single pane, but you can also display up to three additional special-purpose panes on the periphery of the main pane of a view:

Panorama pane Provides a bird’s-eye view of the entire site. The view contains a red view box that corresponds to the current view in the main pane. You can scroll the view of the site that is shown in the main pane by moving the red view box in the panorama pane. You can do anything with the panorama pane that you can do with the main pane—for example, select a page or drag a page to another page in the navigation view to make it that page’s child or parent. The panorama pane is available in the navigation view and links view.

Scratch pane Shows two kinds of files that are stored in the site’s web-content folder and listed in the Files tab of the site window: HTML pages that aren’t part of the site’s navigation hierarchy, and media files that aren’t referenced on any HTML page listed in the Files tab. The scratch pane is available only in the navigation view.

You can drag HTML pages from the navigation view’s scratch pane to its main pane. You use a navigation view’s scratch pane as you would its main pane, dragging a page to a target page in the main pane and positioning it so that it becomes the parent, child, or sibling of the target page. Similarly, you can build up partial trees in the scratch pane and drag them to target pages. (See “Adding empty pages and pending links to a hierarchy” on page 227 and “Rearranging the parts of a hierarchy” on page 229.)

Reference pane Shows media objects embedded in one or more pages that are selected in the main or panorama pane. By selecting different pages in the main pane, you can easily browse the embedded objects. The reference pane doesn’t show media files linked to the HTML page—for example, a large image file linked to a thumbnail version of the same image embedded in a page. The reference pane is available in the navigation view and links view.

In practice, you would probably open only one or two panes at a time, depending on your immediate need.

The peripheral panes in a navigation view in wide orientation
A. Panorama pane  B. Reference pane  C. Main pane  D. Scratch pane

The navigation view shown has a wide orientation. If a navigation view's orientation is tall, the panorama pane is on the left, the scratch pane is on the right, and the reference pane is at the top. (See “To change the orientation of a view” on page 218.)
To show or hide a peripheral pane

1 Do one of the following:
   • If you are in the navigation view, display the navigation view.
   • If you are in the links view, display the links view.

2 Do one of the following:
   • Choose the peripheral pane from the Navigation or Links window menu. Panes showing are checked on the menu. Choose a checked pane to hide the pane.
   • In the Navigation tab of the View palette, select Panorama, Scratch, or Reference to show a pane. Deselect the Show Pane options to hide panes.
   • In the Links tab of the View palette, select Panorama, or Reference. Deselect the Show Pane options to hide panes.

After you show and resize a peripheral pane, that pane, in its current size, becomes part of the default view until you hide the pane.

To resize a peripheral pane

You can change the size of a peripheral pane relative to the size of the main pane. After you resize a peripheral pane, that pane, in its current size, becomes part of the default view until you hide the pane.

1 Show the pane you want to resize.

2 Drag the inside border of the pane toward or away from the main pane.

Note: You can simplify site building by using the scratch pane for building site modules (partial trees) and the main pane for assembling them.

Scrolling, zooming, and centering the site view

Scrolling through the site in the main pane

Both the panorama pane and Site Navigator palette show a miniature version of the complete site with a red view box representing the portion of the site currently shown in the main pane, and both let you scroll the main pane’s view by dragging the box. If you resize the main pane or change the magnification percentage to zoom in or out, the size of the red box changes accordingly in the miniature view.

There is one key difference between the Site Navigator palette and the panorama pane. Although the Site Navigator palette is a picture of the site, the panorama pane is an actual view, so you can work with objects in the panorama pane even if they aren’t visible in the main pane. For example, you can drag a page in the panorama pane that is outside the main pane into a location in the main pane.
To scroll the view in the main pane to another part of the site
1 Do one of the following:
   • Show the panorama pane.
   • Choose Window > Site > Site Navigator.
2 Do one of the following:
   • In the panorama pane or Site Navigator palette, drag the red view box to another part of the site. The view in the main pane scrolls with the box.
   • Select a file entirely outside the view box—that is, one that doesn’t also appear inside the box. The view in the main pane scrolls to show the file.
   • Hold the spacebar and drag the view.

To magnify or reduce the view in the main pane with a Zoom menu
1 Click the Zoom button at the bottom left corner of the main pane, and then choose a magnification level from the pop-up menu.

To zoom in on a particular area
1 Hold down Shift (Windows) or Option (Mac OS). If the pointer is in an area that you have not already zoomed in on, it changes to the Zoom-in tool . Otherwise it changes to the Zoom-out tool .
2 Do one of the following in the main, scratch, or reference pane:
   • Move the pointer to the area and click. The magnification changes to 200% when you do this the first time. It changes to 100% when you do it again in the same pane.
   • Draw a rectangle defining the area and release. The area enlarges to fill the pane. You can do this repeatedly until the magnification reaches 500%.

Note: You can use the Site Navigator palette both for focusing the view on a particular area and for magnifying it. This has the same effect as zooming it.

To magnify or reduce the view in the main pane with the Site Navigator palette
1 Choose Window > Site > Site Navigator.
2 Do one of the following:
   • Click the Zoom Out button or the Zoom In button .
   • Drag the zoom slider.
   • Enter the percentage of magnification or reduction you want in the text box at the bottom left corner of the Site Navigator palette.

Centering views and displaying partial trees
The Move To Center command limits a links view to a page and its incoming and outgoing links. The Display Partial Tree command limits a navigation view to a partial tree—that is, one or more selected pages and the logical descendants (children, grandchildren, and so on).

The most basic way to limit a view is by expanding and collapsing it. You also can limit a view by using the View palette to vary and filter it.
To limit the view to a page and its incoming and outgoing links

1 Right-click (Windows) or Control-click (Mac OS) a page in the main pane of the links view and choose Move To Center. The view is reduced to the file you selected and its incoming and outgoing links.

2 If you want to center the view on another file, select the file and press the Escape key, or choose Move To Center from the context menu again.

See also

“Centering views and displaying partial trees” on page 221

To display only partial trees

1 Select one or more pages in the main pane of a navigation view.

2 Right-click (Windows) or Control-click (Mac OS) the pages and choose Display Partial Tree. The view is reduced to the page(s) you selected and their logical descendents (subtrees).

3 To view the complete tree, press the Escape key or choose Display Partial Tree from the context menu again.

See also

“Centering views and displaying partial trees” on page 221

Using collections in a graphical site view

About collections in navigation or links view

A collection is a custom set of one or more files that you select. After creating a collection, you can perform various file-management tasks on the files in the collection, such as deleting or duplicating. Because you can select all of the files by selecting the collection name, you can perform these tasks on the files quickly.

When you create a collection in navigation or links view, you identify each collection by a unique name, and you can use different spotlight colors for each collection. To display the files in a set, you can spotlight the collection in the navigation view. You can start with an empty collection and add pages to it, or start with the pages and make them a collection all at once.

Collections you create in navigation or links view are saved in the Collections tab of the site window.

Note: You can also create a collection by saving query, find/replace, or syntax check results, or by dragging or copying files from the site window into the Collections tab of the site window.
Using spotlights in a collection of pages
A. Spotlight  B. Collection of pages

See also
“Spotlighting page groupings and collections” on page 224
“Collections” on page 435

To create an empty collection in navigation or links view
1 Right-click (Windows) or Control-click (Mac OS) an empty area of navigation or links view and choose Create Collection.
2 Enter a name for the collection in the text box.
3 Make sure the Add Selection option is not selected, and then click OK.

To create a collection from a selection of pages in navigation or links view
1 Select one or more pages in the navigation view or links view.
2 Right-click (Windows) or Control-click (Mac OS) the pages and choose Create Collection.
3 Enter a name for the collection in the text box.
4 To add the selected pages to the collection, make sure the Add Selection option is selected.
5 To spotlight the collection, select Spotlight Collection.
6 Click OK.

To add pages to or delete pages from a collection in navigation or links view
1 Select one or more pages in the navigation view or links view.
2 Right-click (Windows) or Control-click (Mac OS) the pages and choose Toggle Collection.
3 Do one of the following:
   - To add the page(s) to a collection, choose an unchecked collection from the Toggle Collection submenu.
   - To delete the page(s) from a collection, choose a checked collection.
To select the pages of a collection in navigation or links view
1. Right-click an empty area of navigation or links view and choose Reselect Collection.
2. Choose the collection from the Reselect Collection submenu.

To reveal a collection page in the Collections tab
1. Select one or more pages in the navigation view or links view.
2. Right-click (Windows) or Control-click (Mac OS) the pages, and choose Reveal In Collections.

To rename or delete a collection
❖ Select the collection in the Collections tab of the site window and do one of the following:
• To rename the collection, select it and type a new name in the Collection Inspector.
• To delete the collection, right-click (Windows) or Control-click (Mac OS) it and choose Delete.

To apply a command to a collection
1. Right-click an empty area of navigation or links view and choose Reselect Collection.
2. Choose the collection from the Reselect Collection submenu.
3. Apply the command to the selection.

Spotlighting page groupings and collections
Spotlighting a navigation view is a versatile alternative to centering it. Spotlighting lets you focus on specific pages without removing other pages from the view. You can also spotlight collections in navigation views, where file status information is useful.

You can spotlight these types of page groupings:

Family  Spotlight a selected page, its parent page, and its children.

Incoming  Spotlight any page containing the source of a link to the selected page.

Outgoing  Spotlight any page containing the destination of a link from the selected page.

Pending  Spotlight all pending links in the site.

Collection  Spotlight all pages in the site in a selected collection of pages.

Pending links appear as arrows and their default color is red.
A. Pending links  B. Hierarchy structure
See also

“Checking and resolving pending links” on page 230

“About collections in navigation or links view” on page 222

To spotlight pages in a navigation view
1 Expand the navigation view as necessary to show the pages you want to spotlight.
2 Select the page or pages you want to spotlight. (This step isn’t necessary if you want to spotlight pending links.)
3 Do one of the following:
   • Choose Spotlight Family, Spotlight Incoming, Spotlight Outgoing, or Spotlight Pending from the navigation window menu.
   • In the Navigation tab of the View palette, select Family, Incoming, Outgoing, or Pending.
4 Do either of the following as necessary:
   • Select another file to move the spotlight.
   • Choose another spotlight command to change the type of spotlight.

To spotlight a collection in a navigation view
1 Expand the navigation view as necessary to show the pages you want to spotlight.
2 In the Navigation tab of the View palette, choose a collection from the Collection menu. Choosing a collection automatically selects the Collection button to the left of the menu.

Changing the display of links, thumbnails, and site views

To vary the view of link types and link paths
You can simplify a links view by showing only incoming links or only outgoing links. You can also focus the view on a single path that you are exploring by expanding links. Expanding links automatically collapses other link paths.
1 Display a links view.
2 In the Links tab of the View palette, select (to show), or deselect (to hide) Incoming Links and Outgoing Links.
3 Select Multiple Link Paths or Single Link Path.

Viewing thumbnails
When you edit and save an HTML or XHTML file, its thumbnail is stored in the site file. You can view the thumbnail in the Content tab of the File Inspector. You can also display pages and files as thumbnails in a navigation view or links view. GoLive automatically updates thumbnails when necessary.
Changing the display of the view
You can change display settings for the navigation or links view; for example, to show items as thumbnails. If the view shows the scratch or reference panes as well as the main pane, changes to the display settings apply only to the active pane. Changes you make for the main pane also apply to the panorama pane.

With site views, you can change from the default graphical view to outline view. Outline view is a hierarchical display of folders, subfolders, and files like the one in the Files tab in the site window. Outlines show more detailed and compact representations of the files in the main pane.

To change the display for a site view
1. Display the navigation view or links view.
2. Click the pane you want to change (main, scratch, or reference).
3. Click the Display tab in the View palette.
4. Do any of the following:
   • To show the site view graphically or in outline, select Graphical or Outline. If you select outline, you can show and hide columns in the outline by selecting the columns from the Show Columns menu. If you select Outline for the main pane, the panorama pane closes.
   • To specify how you want to show items in the view, select Icons, Thumbnails, Frames, or Ovals. Ovals are oval-shaped only if the Frame Size is set to Wide. Otherwise they are circles.
   • To specify how you want to show item labels, select File Name or Page Titles.
   • To change the distance between items in a pane, enter a width and height for Cell Size.
   • To change the size of each item in a pane, select a frame size.
   • To change the color of items in a pane, click the Item color field and select a color from the Color palette. Or, click the lower right corner of the Item color field and choose a color from the list of swatches that appear. The color you choose is used for the frames of items, and a lighter tint of it is used for the fill. The color doesn’t apply if you show items as icons.

Filtering the contents of the view
Filtering a view is eliminating certain types of objects, such as media files or cyclic links. You can filter a navigation view and a links view. If the view shows peripheral panes as well as the main pane, the filter applies only to the active pane.

Filtering is particularly useful in the main pane of a links view as a way of simplifying the view of complex sites.

To filter a view
1. Display the navigation view or links view.
2. Click the pane you want to change (main, scratch, or reference).
3. Click the Filter tab in the View palette.
4. Select any combination of items you want to show. (Unselected items are hidden.)
5. Select (to show), or deselect (to hide) any combination of items in the view.
Customizing view colors

When you change settings in the View palette for a site's navigation and links views, the changes persist the next time you display the same site. For example, when you close and reopen the site, GoLive uses the View palette settings for the panes shown in the site's navigation view. You can use this feature to customize your site views for each site.

You can also use the Site Settings dialog box to set the colors of individual parts of the site views, such as the background colors of the individual panes or the colors of items and links.

To change color settings of site views

1. Do one of the following:
   - To change colors for all new sites, choose Edit > Preferences (Windows) or GoLive > Preferences (Mac OS), expand Site in the left pane, and then click Diagram Colors in the left pane.
   - To change colors for the active site only, click the Site Settings button on the toolbar, or choose Site > Settings. In the Site Settings dialog box, click Diagram Colors in the left pane, and then select Site Specific Settings to override the settings in the Preferences dialog box.

   **Note:** If you want the colors in the Preferences dialog box to apply to an existing site, open the site and make sure Site Specific Settings is deselected in the Site Settings dialog box.

2. Click the lower right corner of the color field for any item you want to change, and choose a color from the list of swatches that appear.

3. Click OK.

Building a site map using graphical views

Building a site in navigation view

If you start with a blank site, it's a good idea to begin building the site in a navigation view. You begin by building its structure, arranging empty pages in a hierarchy of unresolved pending links starting with links from and to the home page. At a later stage of site-building when the pages have content, you can resolve these pending links by creating links that reflect them.

This structural approach is also useful for adding new groups of pages to developed sites. You simply anchor the structure of empty pages to an “away” page—a page at the site other than the home page.

Adding empty pages and pending links to a hierarchy

The generic pages you add to a navigation view are blank HTML pages. Such pages have the file name untitled or untitledn. For information on renaming them, see “Naming files and folders” on page 211.

**Note:** Generic pages are blank but contain the basic HTML tags required to form an HTML page.

Pages added are either pages with unresolved pending links or scratch pages. A scratch page has no pending links of any kind. You would add scratch pages to a navigation hierarchy simply to make it easier to link them to the hierarchy as a later step.

See also

“Rearranging the parts of a hierarchy” on page 229
To add a single empty page with pending links
1 Open a navigation view of the site.
2 Select a page in the view.
3 Do one of the following:
   • Click the Create Parent Item button  on the toolbar or choose Diagram > New > Parent Page to insert a page between the selected page and its former parent page. The new page is the child of the former parent page and the parent of the selected page. The three pages are connected by "to child and back" links—that is, pending links from parent pages to child pages, and from child pages to parent pages.
   • Click the Create Child Item button  on the toolbar or choose Diagram > New > Child Page to insert a child page with "to child and back" links from the selected page.
   • Click the Create Next Sibling Item button  on the toolbar or choose Diagram > New > Next Page to insert a next sibling page with "to adjacent siblings" links from the selected page—that is, a pending link from the selected page to the new sibling page, and a pending link from the new sibling page to the selected page.
   • Click the Create Previous Sibling Item button  on the toolbar or choose Diagram > New > Previous Page to insert a previous sibling page with "to adjacent siblings" links from the selected page—that is, a pending link from the selected page to the new sibling page, and a pending link from the new sibling page to the selected page.

Note: If the page you selected is the home page, the only choice available is the Create Child Item button  or Diagram > New > Child Page.

To add a group of child pages with pending links
1 Open a navigation view of the site.
2 Select a page in the view.
3 Choose Diagram > New Pages.
4 In the text box, enter the number of pages to create.
5 Do any or none of the following:
   • To name the pages something other than untitled, enter a file name in the Filenames box.
   • To save the pages in a folder other than the same folder as the selected page, enter the folder name in the Folder text box, or click the folder icon and browse for the folder.
   • To use a stationery page, select Stationery and choose the stationery page from the menu. (See “Stationery” on page 426.)
   • To use a template page, select Template and choose the template page from the menu. (See “Page templates” on page 420.)
6 Choose from the Parent menu to create pending links as follows:
To Each Child  Creates pending links from the parent page to each child page being created.
To Child And Back  Creates bidirectional pending links between the parent page and each child page being created.
To First Child Only  Creates a pending link from the parent page only to the first child page being created.
None  Creates no pending links to the child pages being created.
Choose from the Sibling menu to create pending links as follows:

**To Next Sibling**  Creates previous-to-next pending links between any child pages you are creating. (A previous-to-next link is also created between the first sibling you create and the last of any of its siblings already created.)

**To Adjacent Siblings**  Creates bidirectional pending links between any child pages you are creating. (A bidirectional link is also created between the first sibling you create and the last of any of its siblings already created.)

**To All Siblings**  Creates bidirectional pending links between all child pages you are creating.

**None**  Creates no sibling pending links in either direction from any child pages you are creating.

Click Create. GoLive creates new pages and new unresolved pending links. You resolve a pending link between two pages by adding a link from the source page to the destination page that reflects it. (See “Checking and resolving pending links” on page 230.)

To add an empty scratch page
❖ Select a folder in the Files tab and choose Site > New > From Favorites > HTML Page. GoLive displays scratch pages in the scratch pane of the site’s navigation view.

To add a pending link from one page to another
1  In the navigation view, place the mouse pointer over the page you want to be the source page.
2  Hold down Control-Shift (Windows) or Command (Mac OS). The pointer shows the pick whip.
3  Drag to the destination page. A new pending link is created.

*Note: The source and destination page can be any two pages. They do not need to have a family relationship.*

To remove a page from a navigation view
1  Select the page. If the page you select has descendants, they will be moved to the scratch pane after you remove the selected page.
2  Do one of the following:
   • To move the page to the scratch pane without deleting it, choose Diagram > Move to Scratch.
   • To delete the page, click the Delete Selected Item button on the toolbar, choose Edit > Delete, or press the Delete key.

Rearranging the parts of a hierarchy
It’s easy to move a page from one position in the navigation view to another. You drag the page to another page—its target page—and position it so that it becomes the parent, child, or sibling of the target page. If the page you’re moving has children or descendants, they move with it automatically. And the page’s own family position—its pending links to a parent and siblings—is updated. You can make major revisions to the structure of a site by moving a few pages.

You can also drag pages in the scratch pane to positions in the hierarchy or drag pages out of the hierarchy to the scratch pane.
To move a page and its descendents to another position in the site
❖ In the navigation view, drag the page to its target page as follows:
  • In wide orientation, drag to the top of the target page to make the page you’re dragging its parent, to the bottom to make the page its child, to the left to make it the previous sibling, and to the right to make it the next sibling. A line at the top, bottom, left, or right of the target page appears to show you where to drop the page.
  • In tall orientation, drag to the left of the target page to make the page you’re dragging its parent, to the right to make the page its child, to the bottom to make it the next sibling, and to the top to make it the previous sibling. A line at the left, right, bottom, or top of the target page appears to show you where to drop the page.

Moving a page in a navigation view
A. Moving the page to a new parent  B. The page’s resulting position next to new siblings

To move a scratch page into position in the hierarchy
1 Open the scratch pane in the navigation view.
2 Drag a page from the scratch pane into the appropriate position within the main pane.

Checking and resolving pending links
If you laid out your site in a navigation view before you added content to individual pages and linked the pages, some of the pending links between pages you established may still be unresolved.

Pending links are reminders that pairs of pages, usually pages linked logically, should be actually linked. Like actual links, pending links are directional. For example, a pending parent-child link can be either parent-to-child or parent-to-and-from child. If an actual link has been created between pages to complete a pending link between them, the pending link is resolved. Unresolved pending links have no actual link equivalent. In navigation views, any pages that are the destinations of unresolved pending links for a page selected in the main pane appear in the Pending Links palette.

You should check for unresolved links and resolve them as necessary.
To check for unresolved pending links

1. Open a navigation view of the site.
2. Choose Window > Site > Pending Links.
3. Do one of the following:
   - To check a file for pending links, select the file in the navigation view. If the file contains any pending links, an arrow pointing towards each destination file displays in the Pending column in the Pending Links palette.
   - To display the pending links for all files, choose Spotlight Pending from the navigation view menu to spotlight unresolved pending links with arrows. The arrows point away from the source files that have pending links; that is, the files that don’t have an actual link. If there are two arrows on a line between two files, both files have a pending link.

To resolve an unresolved pending link

1. Choose Window > Site > Pending Links.
2. Select the page in the site window or the navigation view that is the source of the unresolved pending link. The Pending Links palette lists the destination page or pages that the source page has unresolved pending links to. A pending link is indicated by an arrow in the Pending column pointing towards the destination file.
3. Open the source page in the Layout Editor.
4. Do one of the following:
   - Drag a destination page from the Pending Links palette to the source page in the Layout Editor. GoLive creates a link at the insertion point to the destination page.
   - Create a link in the source page to a destination page listed in the Pending Links palette.
After you create the link, GoLive removes the arrow in the Pending Links palette that points towards the destination file.

See also

“About links” on page 167
Creating a hierarchical structure

When you import a site, GoLive automatically analyzes the links in pages and examines the structure of folders to create a hierarchical structure for the site. This process is called solving a hierarchy. The initial structure is based on both the pattern of links present on site pages and the hierarchy of the web-content folder's subfolders. The structure also contains pending links as well as actual links; that is, it contains a record of every parent-child or sibling-sibling relationship possible given the actual hierarchy.

You should solve a hierarchy if you have made changes in your site outside GoLive, or if you want to base the site's navigational structure on different principles. For example, if the hierarchy of the web-content folder's subfolders has nothing to do with the site's navigational logic, you might want to base the structure entirely on links.

To solve the hierarchy of a site

1. Open a navigation view of the site.
2. Choose Diagram > Solve Hierarchy.
3. Select options as necessary:
   - **Links**: Extrapolates the hierarchy from the pattern of links in the site's pages.
   - **Folder Hierarchy**: Bases the hierarchy on the hierarchy of the web-content folder's subfolders.

   *Use Folder Hierarchy if you designed the actual folder hierarchy to reflect the hierarchy of the site's pages.*

Editing links and URLs sitewide

Changing all site URLs or links at once

A site can contain many links to a web page and many URLs that reference media files, external URLs, or e-mail addresses. If you need to change the destination file referenced in all of these links or URLs, you can change them all at once without opening the pages they appear on. For example, you might need to change all URLs to a repeated background image.

Sitewide link editing can't be undone, so use the feature carefully. For example, don't replace a referenced image without making sure that the new image has exactly the same size and width-to-height proportions as the one you want to replace.

Using the In & Out Links palette to view links

The In & Out Links palette is a powerful link management tool that graphically shows you the links or file references to or from a selected file or item in the site window. It is especially useful for troubleshooting link errors listed in the Errors tab of the site window, and showing all of the pages linked to a missing file. You can also create a site map by printing the contents of the In & Out Links palette.

You can use the In & Out Links palette with any file or non-file item in the web-content folder—that is, with any file or item listed in the Files, External, Colors, Font Sets, CSS, Extras, Collections, or Errors tabs in the site window. For example, you can use the In & Out Links palette to show the files that use a color listed in the Colors tab, or use a cascading stylesheet located in the CSS tab. You can also use the In & Out Links palette with a file in the navigation and links views, or with a diagram in the Design tab in the diagram window.
You can use the Renditions tab of the In & Out Links palette to view implied (not actual) links between files. For example, the Renditions tab displays the implied link between a Smart Object source file and its target file, or between a file and its duplicate (created by choosing Edit > Duplicate).

To use the In & Out Links palette to view links and file references
1 Click the Open In & Out Links Palette button on the toolbar and click the Links tab.
2 Do one of the following:
   • Select the file or non-file item in the site window.
   • Select the file in the navigation or links views, or a diagram in the Design tab in the diagram window.
   • Open the file in a document window.

Incoming links to the file appear on the left side of the In & Out Links palette, and outgoing links or file references from the file appear on the right. For non-file items, the files that reference or use the selected item appear on the left. As you move the mouse pointer over a file in the In & Out Links palette, a tool tip appears showing information about the file.

The In & Out Links palette also supports cascading stylesheets (CSS) classes and identifiers. When you click the CSS tab in the site window, and then select a class, the In & Out Links palette shows you all the files where the class has been defined and used.

Use the backward and forward arrow buttons at the bottom left corner of the In & Out Links palette to navigate between link views in the In & Out Links palette.

To limit the types of links appearing in the In & Out Links palette
1 Choose Palette Options from the In & Out Links palette menu.
2 Select the items you want to show. (Unselected items are hidden.)
3 Click OK.

To view implied links in the In & Out Links palette
1 Click the Open In & Out Links Palette button on the toolbar and click the Renditions tab.
2 Do one of the following:
   • Select the file or non-file item in the site window.
   • Select the file in the navigation or links view, or a diagram in the Design tab in the diagram window.
   • Open the file in a document window.

The In & Out Links palette displays implied links to or from the file.

To change all links or URLs to a destination item
1 Display the tab (Files, External, or Extras) in the site window where the destination item you want to replace is listed—for example, a repeated background image.
2 Select the item.
3 Do one of the following:
• If the new destination item you want to use as a replacement is visible in the site window, click the Open In & Out Links Palette button on the toolbar.
• If the new destination item you want to use as a replacement is not visible in the site window, choose Site > Change Links.

4 Do one of the following:
• If the replacement item is visible in the site window, drag from the pick whip in the Links tab of the In & Out Links palette for the old item to the replacement item in the site window.

5 In the Change Reference dialog box, select the files that contain the links or URLs you want to change (all files are selected by default), and then click OK.

Fixing site errors

About site errors
If you consistently use GoLive to manage your site, site errors will rarely occur. GoLive keeps your site intact by tracking when you move, rename, or delete files in the site window and immediately prompts you to update all links and file references. Most site errors are a result of using the Explorer (Windows) or Finder (Mac OS) instead of GoLive to move, rename, or delete files. After you refresh the site window, GoLive lists these files as missing or orphan files, and all links to the files become site errors. GoLive uses the Errors and External tabs in the site window and the In & Out Links palette to list and track link errors.

If a file in the site's web-content folder contains an error or possible error, the Status column of the Files tab in the site window shows one of the error icons rather than the checkmark icon. The error icon also appears next to the file in navigation views and links views. The possible error icons are as follows:

Bug icon Indicates broken links in a web page file.
Alert icon Indicates a Smart Object warning or other warning.
Empty Page icon Indicates an empty page.
Stop icon Indicates a missing file.
Question mark  
Indicates a file that GoLive cannot open.

Error icon  
Indicates one or more files with that error in the folder (the icon appears in the Status column for a folder).

Note: Before checking the site for errors, be sure to refresh the site window to display the latest status information. (See “To refresh the Files, CSS, Extras, Diagrams, Collections or Publish Server tab” on page 209.)

To fix a broken link on a page listed with a Bug icon
1 Make sure the Inspector is displayed.
2 Double-click the page with the broken link in the Files tab of the site window.
3 To show link warnings in the page, do one of the following:
   • Click the Show Link Warnings button on the toolbar or in the Highlight palette.
   • Choose View > Show Link Warnings.
4 If necessary, do either of the following to get information that may help you find the broken link:
   • Locate missing objects on the page (objects with a red border)—for example, an image placeholder where an image should be.
   • Look for link warnings—that is, objects or text with a red border.
5 Select the object or text on the page that contains the broken link.
6 Inspect the link in the URL text box in the Inspector, and then reestablish the link.

See also
“About links” on page 167

To find the source of Smart Object warnings
Smart Object warnings occur when you copy a Smart Object but don't create a separate target file for it (By default, copies share target files).
1 Right-click (Windows) or Control-click (Mac OS) the warning icon .
2 Choose Open > Open Related Smart Object Pages [x], where x is the number of pages that reference the Smart Object.

See also
“To copy Smart Objects” on page 361

Checking the site for missing or orphan files
A file referenced on a page can be missing or orphaned. The Missing File icon  indicates that GoLive can't find a file, possibly because you used the Explorer (Windows) or Finder (Mac OS) instead of GoLive to move, rename, or delete it. The Orphan File icon (Windows) or (Mac OS) indicates that GoLive can find a file locally, but it is stored outside the web-content folder.
The Errors tab in the site window lists missing and orphan files that are referenced in files that will be uploaded to a server. For example, an image file stored outside the web-content folder is listed in the Errors tab as an orphan file if it is referenced in a page listed in the Files tab in the site window. The same image file is not listed in the Errors tab if it is referenced in a template because templates are not uploaded to the server. All files in the Extras tab (such as templates and stationery) are not uploaded to the server.

**To find and relink a missing file**

1. Refresh the site window to display the latest status information.
2. Select the file in the Missing Files list in the Errors tab in the site window.
3. Do any of the following to get information that may help you find and relink the file:
   - To check if the file has a new name, look for the file in the Files tab and, if necessary, change the link to refer to the new name.
   - To use the In & Out Links palette to show the pages that are linked to the file, click the Open In & Out Links Palette button on the toolbar. Then use the pick whip in the Links tab of the In & Out Links palette to fix the link.
   - To use the Inspector to check and fix the URL of the file, open the Inspector and choose Edit from the menu to the right of the URL text box. In the Edit URL dialog box, edit the URL in the Path text box, and then click OK. Select the files you want to update with the new URL, and then click OK.
   - To find the file, use the Find Site Assets window.
   - To restore a file that has been deleted, drag the file from the Site Trash in the Extras tab in the site window to its original location in the Files tab in the site window.

*When you clean up a site, you can specify that GoLive copy all orphan files to the web-content folder and delete the entry for the file from the Orphan list in the Errors tab.*

**See also**

“Changing all site URLs or links at once” on page 232

“To find files within a site” on page 237

“TO specify options for cleaning up a site” on page 210

**Checking external URLs and e-mail addresses**

An external URL references a page outside your file system—that is, a page with an address that begins with http://, ftp://, or so on, and must include a colon. For example, http://www.adobe.com. When specifying an e-mail address, be sure to include an @ in the address.

You can check the validity of external URLs listed in the External tab in the site window.

**See also**

“Site URLs and e-mail addresses” on page 433

**To check the validity of external URLs**

1. Be sure you have online access to the Internet.
2. Open the site.
3 Click the External tab.

4 Choose Site > Update > Add Used > External Links to update the site.

5 Choose Site > Check External Links. The Status column in the External tab shows the Bug icon 🔄 for any invalid external links.

**To find files within a site**

You can find individual files or objects (such as colors and e-mail addresses) throughout your site. This feature is particularly useful if you have a huge site with dozens or even hundreds of pages. Instead of scrolling through long file lists in the site window, you can enter a full or partial file name or URL.

*When To make a quick search for items across your site, use the Quick Search text box 📂 in the site window.*

1 Open a site file, or bring an open site window to the front.

2 Click the Find Site Assets button 📂 in the toolbar.

3 In the Find Site Assets dialog box, choose search options from the pop-up menus next to Find Item Whose.

*Note: Choose Hex value to search for a color by its hexadecimal value.*

4 In the text box, enter the full or partial name, URL, or hexadecimal value of the file or object you are searching for.

5 Choose an option from the Search In menu. For example, choose Colors to search for a color by name or hexadecimal value.

6 Click Find All. GoLive displays the first item found in the active tab in the site window. (Click Instant Find to have GoLive start a search automatically.)

7 To reveal a file in the site, select it in the Matches section of the Find Site Assets dialog box and click Reveal in Site.

*To quickly search again for an item you previously entered in the text box, select the item from the pop-up menu next to the text box.*

**Creating and running queries**

**Generating queries**

The Queries window lets you search for files using a wide range of criteria. You can search in open sites and collections, in a user-defined list of files, or in a result list; and you can view the results in the Query Results window. You can define nested queries to perform complex searches, or use GoLive's predefined queries for simple searches. Use the Query Editor to edit predefined queries or create new queries. Save queries to use with application-wide searches, or save site-specific queries in the Queries folder of the Extras tab. You can also save query results as collections in the Collections tab.
To define a query

Define a query or edit existing queries in the Query Editor. Once you've defined the query, you can test it before actually running it on a site or group of files.

1 Choose Edit > Queries.

*Note:* To create an application-wide query, don't open a site before opening the Query Editor.

2 Choose a portion of the site on which to run the query from the Work On menu, and then click the New Query button.

3 If desired, type a description of the query in the Description field in the Query Editor.

4 Choose an option from the Find What menu (see “Query options” on page 239), and then set options in the Settings pane.

5 To add more criteria to the query, click the arrow to the right of the Find What menu and choose an Add, Or, or Not item:

   **And** Specifies that all criteria must be satisfied. For example, if you select this option and define a query to show files that were created over two weeks ago and contain external links, the query shows only those files created over two weeks ago that contain external links.

   **Or** Specifies that any, but not all, of the criteria must be satisfied. For example, if you select this option and define a query to show files that were created over two weeks ago or contain external links, the query shows the files created over two weeks ago with or without external links, and the files that contain external links regardless of when they were created.

   **Not** Specifies that the first set of criteria must be satisfied but the second set of criteria must not be satisfied. For example, if you select this option and define a query to show files that were created over two weeks ago and do not contain external links, the query shows only those files created over two weeks ago that do not contain external links.

6 Continue to define query criteria using the Find What menus and Add, Or, or Not items. You can drag and drop query criteria above, beneath, or next to other query criteria (as you drag, black bars appear next to the existing criteria, indicating the location of the new criteria).

7 Delete criteria by choosing Delete from the menu to the right of the Find What menu.

8 To test the query, click Test Query.

9 Close the Query Editor to save the query. Enter a name for the query in the Save Query File dialog box (the .aglq extension is provided automatically), and then click Save.

Queries you create and save are listed in the Filename section of the Queries window, and are stored in the Queries folder in the Extras tab of the site window.
To edit an existing query

1. Choose Edit > Queries.
2. Select the query you want to edit and click Edit Query.
3. Make changes to the query.
4. Close the Query Editor and click Yes when prompted to save changes.

See also

“To define a query” on page 238

Query options

When defining a query, you can choose from any of the following options in the Find What menu:

- **Accessibility**  Shows pages that conform to a number of guidelines for making web content accessible to people with disabilities and persons using alternative browsing technologies. Although these guidelines don't offer a complete solution, they can help determine whether your website is accessible.
- **Code Element**  Shows pages with HTML elements and attributes (or a combination of these) that you specify.
- **Download Time**  Shows the files that take longer than a specified amount of time to download, given a specified connection speed.
- **Errors**  Shows pages with missing image attributes, problem titles, and HTML error and warning flags.
- **File Info**  Shows files by type, byte size, download time, modification date, creation date, mime type, and publish state. For HTML files, the Download Takes option in the Download Time tab considers everything that makes up the page (such as images or QuickTime movies) when computing download time.
- **Links**  Shows pages with external links, links to files with a certain extension, and links of one or more protocols (for example, ftp: or mailto:). Links also show you pages that are a certain number of clicks away from a given page.
- **Name**  Shows pages or URLs that are, begin with, end with, or contain a text string you specify, or that match a regular expression you specify.
- **Publish State**  Shows pages within a site that will be uploaded (or not) to the publish server when you publish the site and whether the files in your site are newer than, older than, or in sync with the version of the site that exists on a given server.
- **Site Objects**  Shows pages in a site that use certain components, addresses, fonts, font sets, site colors, and labels. The items that appear in the Site Objects settings are the same items that appear in the site window. If you added or removed items from pages, update the items in the site window and in the Site Objects settings by cleaning up the site.
- **Textual Content**  Shows pages that match text in Layout Mode or encoded or unencoded text in Source Mode.
- **Version Control**  Shows files that are checked out of a version control project site by you or by another user.

See also

“To specify options for cleaning up a site” on page 210

“Version Cue managed projects” on page 71
To run a query

Once you’ve defined a query, you can view the results in the Results window, and then run another query on the result set generated from the first query. You can also save query results as a collection and store it in the Collections tab of the site window.

1. Choose Edit > Queries.

2. Define a new site query or select an existing query.

3. Choose a portion of the site on which to run the query from the Work On menu, and click Start.

GoLive displays the query results in the Results window. The query tree pane of the Results window displays the query, and the text area at the bottom of the Results window shows files that satisfied the query criteria.

Note: Move the pointer over a query criteria in the query tree pane to see a list of files that met that criteria.

4. Do one of the following:
   - To save the query results as a collection with the currently open site, click Save Collection. Enter a name for the collection in the Create A New Collection dialog box, and then click OK.
   - To search within the query results, click Use Result. GoLive opens the Query window with the original query results in the Search In section. You can now run another query on the result set.

See also

“To define a query” on page 238

“Collections” on page 435

Providing file status information

About file status information

As you build and update a website, it might be useful to provide status information so you or a person reviewing the site can determine the state of a particular file or folder. You can provide status information about an individual file or folder by assigning it a publish state or a status label in the File Inspector. The publish state lets you specify whether you want to publish a file or folder on a web server or not.

💡 You can also provide status information about a group of files by creating a collection with a significant name such as “Reviewed.” (See “Collections” on page 435.)

Assigning publish states to files and folders

You can assign three different publish states to files or folders in a site: “publish never,” “publish always,” and “publish if referenced.” You can then use the Honor Publish State option in the Site Upload/Export preferences or site-specific settings to use the publish state to determine which files or folders in a site to upload to a web server.

See also

“To set upload options” on page 445
To assign a publish state to a file or folder

1 Do one of the following:
   - Select the file or folder in either the Files or Extras tab in the site window.
   - Select the file in the navigation or links view.

2 In the File tab of the Inspector, choose a publish state for the file or folder from the Publish menu.

Assigning status labels

GoLive comes with the default color-coded file status labels red, blue, orange, green, yellow, purple, and gray. Color-coded files appear in navigation view and links view when the display of the views is set to thumbnails, frames, or ovals. (See “Changing the display of the view” on page 226.) You can assign any one status to any file, and add new labels to assign to files.

Note: GoLive also uses the term “status” to indicate the state of links and references at a site—for example, in the Status column of the Files tab in the site window. (See “About site errors” on page 234.)

To add or edit a file status label

1 Do one of the following:
   - To add or edit a status label for all sites, choose Edit > Preferences (Windows) or GoLive > Preferences (Mac OS), select Site from the list on the left, and then select Color Labels.

   Note: You can only edit user-defined statuses.

   - To add or edit a status for the active site only, click the Site Settings button on the toolbar, or choose Site > Settings. In the Site Settings dialog box, select Color Labels from the list on the left, and then select Site Specific Settings to override the settings in the Preferences dialog box.

   Note: If you want the status in the Preferences dialog box to apply to an existing site, open the site and make sure that Site Specific Settings is deselected in the Site Settings dialog box.

2 Do one of the following:
   - To add a new label, click the Create New Item button. A new white label appears with the name “New Status” in the bottom of the Site Settings dialog box.
   - To edit an existing user-defined label, select it.

3 Do any of the following:
   - Enter a name for the label in the text box.
   - Click the lower right corner of the color field and select a new color from the swatches that appear.
   - Click the Delete Item button to delete the label.

4 Click OK.

To assign a status label to a file or folder

1 Do one of the following:
   - Select the file or folder in either the Files or Extras tab in the site window.
   - Select the file in the navigation or links view.

2 In the File tab in the Inspector, choose a status for the file from the Label menu.
Chapter 10: Laying out pages

Page layout for the web

Page layout techniques
The Layout Editor in the document window provides the canvas on which you drag files or objects (usually from the site window) onto your page. CSS layout objects, tables, layers, frames, and GoLive layout grids and text boxes provide the containers for holding and positioning text, images, animations, and movies.

CSS-based designs
CSS layout objects enable you to create liquid layouts; that is, layouts that resize to accommodate the viewer’s screen settings. Liquid layouts are quickly becoming the web standard and offer both designers and viewers more flexibility than table-based designs. In GoLive, you can instantly create a liquid layout by simply dragging preconfigured CSS layout objects from the CSS tab of the objects toolbox to the page.

Layout grid-based designs
GoLive CSS-based or table-based layout grids enable you to create designs that let you freely position objects anywhere on the page. You can convert a CSS-based layout grid to a table-based layout grid. You can also convert a table-based layout grid to an HTML table.

Table-based designs
All web browsers can display HTML tables, so they are often used for page layouts. You can position images, text, and other objects on the page by placing them in table cells. To conceal the table structure, you can leave cells empty and hide table borders.

GoLive provides two ways to create table-based page layouts: standard HTML tables or table-based layout grids that let you freely position objects anywhere on the page.

Layer-based designs
Like objects on a layout grid, you can freely position objects in layers anywhere on a page. However, layers also let you overlap objects and interactively show and hide content in a browser. Use the Layer tool in the objects toolbox to draw and size layers on a page.

Image links are attached to show or hide actions for stacked layers. Holding the pointer over an image (A) makes text in layer appear (B).
Photoshop- and Illustrator-based designs

Many web designers create graphically rich page layouts in Adobe Photoshop or Adobe Illustrator and then convert the designs into web pages. GoLive streamlines this process by automatically creating custom tables for sliced images and fully supporting rollover code. With Smart Objects, as you update a design in Photoshop or Illustrator, GoLive automatically optimizes related images for the web.

You can import Photoshop layers as GoLive layers, which you can reposition, overlap, and show or hide. Likewise, you can use a Photoshop-based design as a tracing image and convert individual cutouts into GoLive layers.

Frame sets

Frames divide a web browser window into sections that contain separate pages. Frame sets hold the frame structure. You create a new frame set by choosing a frame set layout in the New dialog box or by using the Frame Editor to create a frame set and lay out frames that display individual web pages.

Site assets

Site assets such as components, stationery, and page templates let you update common elements across your site while restricting changes to specific areas of a layout. GoLive provides page template samples in the New dialog box and in the Web section of the Documents tab of the Library palette.

See also

“Designing with tables” on page 274
“About site assets” on page 420
“Adding sliced Photoshop images” on page 377
“Choosing a format for Illustrator source files” on page 380

Page layout workflow

Use the following workflow when laying out pages:

1. Add assets to the site window.

Add assets, such as images and multimedia files, to the site window. From this location, you can quickly add content to pages and let GoLive keep all paths up to date as you work. You can also set up your pages with common elements like page titles, margins, and page backgrounds (see “Setting up pages” on page 157).

2. Create a content container.

Choose a content container, such as a CSS layout object, layout grid, layer, or table, and drag its icon from the objects toolbox to the Layout Editor.

3. Add content to the container.

Add content to the container by doing either of the following:

- Drag placeholders from the objects toolbox into the container, and then link them to reference files (such as image files) in the site window.
- Drag files directly from the site window into the container. (Dragging image files directly to a container bypasses the step for linking placeholders to reference files.)
CSS layout objects

About CSS layout objects
GoLive lets you add a predesigned CSS layout object, based on layers, to a page, and then add text and objects to the layout just as you would in any other page. CSS layout objects are liquid layouts—they adjust to accommodate the viewer’s screen settings. You don’t need to know how to code CSS to create CSS layout objects, but you can customize them by using the CSS Object Inspector and the CSS Editor.

Note: Viewers may not be able to see CSS layout objects if their browser doesn’t support CSS, the browser’s CSS support has been turned off, or the browser is set to override page styles with a CSS file supplied by the viewer. Web browser support for CSS varies greatly between both browser vendors and browser versions.

💡 If you’re designing pages for mobile devices, designing with liquid layouts is a good way to ensure that your layout resizes to accommodate small screens.

See also
“About cascading stylesheets” on page 318
To add a CSS layout object to a page
❖ Do one of the following:
  • Drag a CSS layout object from the CSS set of the objects toolbox to the page.

  Note: When you hold the pointer over a CSS layout object in the CSS set of the objects toolbox, a description of the CSS layout object appears.

  • Double-click the CSS layout object to place it at the insertion point.

Nest CSS layout objects by dragging a CSS layout object from the CSS set of the objects toolbox to an existing CSS layout object on the page. For example, drag a padded box inside a Left Fixed Box.

  You can use the Select tab of the Table & Boxes palette to navigate in CSS layout objects: Click the Select Parent Table tool to select the parent CSS layout object, or click in a row or column of a CSS layout object in the tab to place an insertion point.

To customize a CSS layout object in the CSS Object Inspector
❖ Select the CSS layout object and set values for ID, width, height, color, or padding in the CSS Object Inspector (available options vary depending on the layout you've selected).

See also
"Relative and absolute units" on page 331

To customize a CSS layout object in the CSS Editor

1 Click a border of the area of the CSS layout object that you want to customize, and note its name in the markup tree bar at the bottom of the document window (for example, div.navboxright_824DC9).

  You can edit the IDs of CSS layout objects: Select the CSS layout object and type a new ID in the ID text field in the CSS Object inspector. For example, change the ID for div.navboxright_824DC9 to “topbox,” so that the CSS layout object’s name is div.navboxright_topbox.

2 Click the Open CSS Editor button in the upper right corner of the document window.

3 In the CSS Definitions tab of the CSS Editor, select the name you noted in step 1, and set attributes by using the Properties tabs in the CSS Editor.
Editing properties of a CSS layout object in the CSS Editor

See also
"About style properties" on page 330

Layout grids

About layout grids
GoLive layout grids take the pain out of creating CSS-based and table-based designs for your web pages. Instead of hand coding CSS or setting up table cells, you can add a single layout grid to the page, draw text boxes or layers, or drag objects anywhere on the grid. GoLive adjusts the properties of the layout grid as you add content and reposition it. Using layout grids, you can position multiple objects on your page with 1-pixel accuracy.

Layout grids and objects on the grid remain fixed in the browser window and don't change to accommodate the viewer's screen settings. If you want your page or individual objects to automatically reflect adjustments to the viewer's screen settings, use CSS layout objects from the CSS tab of the objects toolbox.

By default, layout grids are CSS-based, but you can convert them to a table-based design.

💡 You can add tables to a layout grid (for example, to add a chart with multiple columns and rows).

See also
"Converting a table-based layout grid to a table" on page 252
"About CSS layout objects" on page 245
Guidelines for layout grids

To simplify the task of laying out, grouping, and aligning multiple objects on your page, add a layout grid and make it the same size as the window. After you've added the objects to the grid, you can optimize the grid's size to fit around the objects using the Layout Grid Inspector. For more advanced layouts, you can add multiple layout grids to a page, for example, to lay out objects in a header area and a footer area. However, you should not place a layout grid on top of another layout grid.

If you want the layout grid to cover the entire page without any margins in the browser window, use the Page Inspector to set the page margins to zero—the layout grid moves to the upper left corner of the window. If you know that you'll always want the page margins to be zero, you can set this preference for all new pages.

All objects placed on the layout grid are considered part of the grid object. This placement comes in handy if you create a nice layout grid design and wish to reuse it. You can save the design as a component, page template, stationery, or library object and store it for later use. (See “About site assets” on page 420.)

See also

“To specify page margins” on page 159

To add a layout grid to a page

❖ Drag the Layout Grid icon from the Basic set in the objects toolbox to the page, or double-click the icon to place it at the insertion point.

To convert a CSS-based layout grid to a table-based layout grid

❖ Right-click (Windows) or Control-click (Mac OS) the layout grid icon in the upper right corner of the layout grid and choose Convert To Table Based Grid. To convert the grid back to a CSS-based design, right-click or Control-click the layout grid icon and choose Convert To CSS Based Grid.

To resize a layout grid

❖ Do one of the following:
  - Select the grid and drag one of the three resize handles on the right side, bottom, and lower right corner of the grid. The new width and height appears in the Layout Grid Inspector.
  - In the Layout Grid Inspector, enter the desired measurements for Width and Height.
  - If the layout grid has a background image, click Use Image Size in the Layout Grid Inspector to adjust the size of the grid to the image size.
  - If you have finished laying out objects on the grid, click Optimize in the Layout Grid Inspector to automatically reduce the size of the grid to its minimum size (to fit around the outer borders of all the objects and no more than that). You can Shift-click the Optimize button to reduce the width only and Alt-click (Windows) or Option-click (Mac OS) the Optimize button to reduce the height only.

To minimize horizontal page scrolling in a web browser, make sure that the final width of the layout grid is no larger than 580 pixels, the width of a standard 14-inch monitor.
To customize the behavior of a layout grid
❖ Do any of the following in the Layout Grid Inspector:
• To position objects freely on the grid with 1-pixel accuracy, deselect Snap For Horizontal and Snap For Vertical, and press the arrow keys to move the objects pixel by pixel.
• To make objects move in increments equivalent to the spacing between the grid lines, select Snap For Horizontal and Snap For Vertical, and press the arrow keys.
• To change the spacing between the grid lines, enter a size in pixels in the Horizontal or Vertical text box.
• To hide the grid lines, deselect Visible For Horizontal and Visible For Vertical.
• To set the position of the grid in relation to the document window, choose an alignment from the Align menu in the Layout Grid Inspector. Choose Default to align the grid with the upper left corner of the page. Choose Left or Right to wrap other text and objects around the grid. Choose Center to align the grid with the center of the page.

To add text to a layout grid
1 Do one of the following:
• Use the Grid Text Box tool in the objects toolbox to draw a layout text box on the layout grid.
• Drag a Layout Text Box icon from Basic set in the objects toolbox onto the layout grid.
2 Type or paste text into the layout text box. Layout text boxes can also contain images and other objects that you want to align within the text or wrap text around.

See also
“Methods of formatting text” on page 292
“To wrap text around an image or object” on page 296

To add a background color or image to a layout text box
1 Select the layout text box.
2 In the Layout Text Box Inspector, do one of the following:
• Select Color, click the color field, and choose a color from the Color or Swatches palette.
• Select BgImage, and then select an image file.

To prevent a layout text box from automatically resizing in GoLive
❖ In the Layout Text Box Inspector, select Allow Content Overflow. With this option selected, as more text is added or reformatted, the layout text box does not resize in your page layout. This doesn't affect how it will appear in web browsers.

Note: In a web browser, the layout text box automatically adjusts its size in relation to its content, which resizes according to the platform that the browser is using—for example, to accommodate fonts that appear smaller in Mac OS and larger in Windows. You can assign a pixel size definition for all text using a cascading style sheet. (See “Relative and absolute units” on page 331.)
To add images or other objects to the layout grid
❖ Do one of the following:
- Drag image files or other media files from the site window onto the layout grid or a layout text box on the grid. Dragging the file from the site window automatically creates a resource link between the page and the image or media file.
- Drag object placeholder icons (such as Smart Objects or components) from the objects toolbox onto the grid and link its source file in the Inspector.
- Paste copies of layout text boxes, images, and other objects into a layout grid by clicking in an empty area of the layout grid and choosing Edit > Paste.

While dragging layers, layout grid text boxes, and image map areas, you can show visual smart guides in the layout window by choosing View > Show Smart Guides before you drag.

See also
“To add Smart Objects to pages” on page 360
“Adding multimedia” on page 349
“About links” on page 167

To add a tiled background image to a layout grid
1 Select the layout grid.
2 In the Layout Grid Inspector, select Background Image, and then select an image file.
3 To resize the Layout Grid to the size of the image, select Use Image Size.

To add a background color to a layout grid
❖ In the Layout Grid Inspector, select Background Color, click the color field, and select a color from the Color or Swatches palette.

Grouping and arranging objects on layout grids

To group or ungroup objects
Only objects placed on a layout grid can be grouped. Grouping objects is a great time saver if you need to move multiple objects at once and don't want their position to change in relation to each other. (Grouping is one of the key advantages of the layout grid because it can't be done using a standard HTML table.)

1 Select the objects on the layout grid that you want to group or ungroup. Click to select the first object, and then Shift-click to select each additional object. (You can't group layers.)
2 Click the Group Selection or Ungroup Selection button on the toolbar, or the Layout Group button or the Layout Ungroup button in the Transform palette.

To reposition an object or group of objects
❖ Select the objects and drag them on the layout grid, or enter precise pixel values for the horizontal or vertical position using the toolbar or Transform palette.
To align objects in relation to their container

1. Select the layers, object, or group of objects that you want to align.

2. Do one of the following:
   • On the toolbar, click a horizontal or vertical alignment button.
   • In the Align palette, under Align To Parent, click a horizontal or vertical alignment button. (The buttons in the Align palette are the same as those on the toolbar.)

Note: Because you cannot move a selected object if another object is in the way, some alignment buttons are unavailable depending on the objects selected.

See also

“To wrap text around an image or object” on page 296

To align objects in relation to each other

❖ Select the layers or objects on a layout grid, and click a button under Align Objects in the Align palette. You can align objects along the left, center, or right vertical axis or along the top, center, or bottom horizontal axis.

![Aligning objects to their center horizontal axes](image)

See also

“To wrap text around an image or object” on page 296

To distribute objects in relation to each other

1. Select three or more layers or objects on a layout grid.

2. In the Align palette, do one of the following:
   • To distribute objects relative to their vertical axis (left, center, or right) or horizontal axis (top, center, or bottom), click a button under Distribute Objects.
   • To distribute the space equally between the vertical or horizontal axes of the objects, click a button under Distribute Spacing.
   • To distribute the objects or spacing based on a value, select Use Spacing and enter a pixel value in the box; then click a Distribute Objects or Distribute Spacing button.
Distributing space between objects equally

Converting table-based layout grids to tables

Converting a table-based layout grid to a table
You can convert table-based layout grids to standard HTML tables with fixed table cell sizes and then use the Table Inspector to make the table cells resizeable in the browser window. (See “To fix table, column, or row size conflicts” on page 281.)

When you convert a table-based layout grid to a table, GoLive strips out all of the special code such as cool gridx, gridy, and cntrrow, but it leaves a control row of empty cells at the bottom of the table that's one-pixel high, a control column of empty cells one pixel wide at the right ends of each row in the table, and Netscape Spacer elements inside the empty cells. You can remove the control row and column from the converted table or you can replace the Spacer elements within the empty cells with provided spacer.gif transparent images. (Spacer elements or transparent GIF images are used to solve a problem displaying empty table cells in Netscape browsers. Spacer elements are ignored by Internet Explorer browsers.)

By removing the GoLive code, you'll lose the ability to freely move objects around on the page unless you convert the table back to a CSS-based or table-based layout grid.

See also
“To convert a CSS-based layout grid to a table-based layout grid” on page 248

To convert a table-based layout grid to a standard HTML table
When you convert a table-based layout grid to a table, GoLive strips out the GoLive code and keeps the standard HTML table format.

To retain the flexibility of a layout grid, you can wait to strip out GoLive code until you export or upload the web page to the server. (See “Exporting a site” on page 448.)

1 Select the layout grid and choose Special > Convert > Layout Grid To Table.

Note: If the Layout Grid To Table option doesn't appear in the Special > Convert menu, you need to enable the Layout Grid module. Choose Edit > Preferences (Windows) or GoLive > Preferences (Mac OS), select Modules, select Layout Grid in the Extend Scripts folder, and click OK. Then restart GoLive.
2 In the Convert dialog box, do one of the following:

- To remove the empty, one-pixel control row and column at the bottom and right side of the grid, select Strip Control Row and Column. (This option is selected by default.)
- To replace all Netscape Spacer elements with a spacer.gif transparent image that is one pixel high, deselect Strip Control Row and Column, and select Replace Spacer By Image. You can also enter the name of a different image located in the GoLive application folder.
- To keep the control row and column, and include the Spacer elements, deselect both options.

3 Click OK.

To convert a table back into a table-based layout grid

Select the table and click Convert in the Table Inspector.

Creating layers

About GoLive layers

You can use layers to divide your page into rectangles that can be formatted and positioned individually. Layers can contain any HTML element that a page can contain—such as an image or simple HTML text with formatting. You use the Layer tool and the Layers palette to add and manage multiple layers on the page.

You can import Photoshop layers as GoLive layers. See “Importing layered Photoshop images” on page 377.

GoLive layers are DHTML layers, which you can overlap, hide and show, and animate on a page. For example, layers are commonly used with the Show/Hide action to make them appear and disappear at the trigger of the mouse. Layers can contain background images or color, and they can inherit properties from the page’s cascading style sheet (see “About cascading stylesheets” on page 318). They can be positioned precisely, because they are implemented using the DIV element. The DIV element, formatted with a CSS ID style for the width, visibility, and absolute position of the layer, instructs the browser to create a subdivision that is not part of the normal flow of HTML within the page.

Note: To display properly, layers require web browser versions 4.0 or later. To see what a layer would look like in a web browser that does not support cascading style sheets, turn off CSS support in the browser’s preferences.
Layers are used to hide text and objects and make them reappear.
A. Markers for three layers  B. Image link with Mouse Enter event attached to Show/Hide action  C. Pointer over image triggers layer of text to appear below

See also
“Importing layered Photoshop images” on page 377
“About cascading stylesheets” on page 318

To add a layer to a page
❖ Do one of the following:

• Click the Layer tool in the objects toolbox and drag on the page until the layer is the size you want.

• Drag the Layer icon from the Basic set in the objects toolbox onto the page. If it’s in the middle of text, GoLive inserts a new paragraph to split the text and places the DIV element between them.

• Click in the page to place the insertion point, and then click the Create New Layer button in the Layers palette.

When you add a layer to a page, GoLive inserts a small yellow marker, which stays at the original point of insertion after you move the layer.

To add content to a layer
❖ Click in the layer and type or drag an image or other site asset from the site window or objects toolbox into the layer.

Layers can contain any valid HTML element, such as text and images. However, web browsers may have problems with layers that contain tables or layout grids. If you embed a layer within another layer, the embedded box will inherit any CSS information from the parent layer.
To add a background color or image to a layer

1. Select the layer.

2. In the Background tab of the Layer Inspector, do one of the following:
   - To add an image, select Image, and then select an image file.
     You can set the contents of a layer to be invisible when the page is first loaded into the browser. (See “Hiding and showing layers in a browser” on page 259.)
   - To add a color, select Color, click the color field, and select a color from the Color or Swatches palette.

   **Note:** Avoid using a background image alone in a layer. In Netscape browsers, background images or color may not display unless there are other objects or text in the box as well. To work around this problem, you can add a transparent GIF image to the empty box.

See also

“Hiding and showing layers in a browser” on page 259

“To use a transparent GIF image for spacing” on page 272

Selecting, resizing, and positioning layers

To select a layer

- Do one of the following:
  - Click the layer marker (the small yellow icon).
  - Move the pointer to the top border of the layer until it changes to a hand, and click.
  - Click the name of the layer in the Layers palette.

See also

“To reposition an object or group of objects” on page 250

To move or resize a layer by dragging

- Do one of the following:
  - To move the layer freely on the page, move the pointer to the top border of the layer until it changes to a hand, and drag.
  - To resize a layer, select the layer and drag one of its handles.
To move or resize a layer pixel by pixel

❖ Select the layer, and do one of the following:

- To move a layer pixel by pixel, press an arrow key. Hold down Ctrl (Windows) or Option (Mac OS) while pressing an arrow key to toggle between pixel or grid sized movements.

- To resize a layer pixel by pixel, hold down Shift while pressing an arrow key. Hold down Ctrl (Windows) or Option (Mac OS) while pressing an arrow key to toggle between pixel or grid sized movements.

See also
“To reposition an object or group of objects” on page 250

To set an exact or relative size and position for a layer

1 Select the layer.

2 Do any of the following in the Layer tab of the Layer Inspector:

- Enter exact position coordinates (measured in pixels from the upper left corner of the document window) in the Left and Top text boxes.

- Enter an exact size in the Width and Height text boxes.

- Choose Auto from the Width or Height menus to automatically size the layer in relation to its contents.

- Choose Percent from the Width or Height menus to automatically size the layer in relation to the percentage of the window width or height.

Note: Netscape browsers resize the Percent width of a layer to the width of its contents.

See also
“To reposition an object or group of objects” on page 250

To use grid lines for positioning the layer

1 Select the layer.

2 Do one of the following:

- Choose Layer Grid Settings from the Layers palette menu.

- Choose View > Layer Grid Settings.

3 Define the page grid and its behavior:

- Enter Horizontal and Vertical values to define the spacing between the grid lines.

- Select Snap to have the layer snap to the grid lines when you move it. You can press the arrow keys to move the layer incrementally from one grid line to the next.

- Select Visible to display the grid when you drag the layer.

- Select Prevent Overlapping to prevent layers from overlapping.

See also
“To reposition an object or group of objects” on page 250
To change the stacking order of multiple layers

By assigning a z-index to each layer, you can control the order that the boxes are stacked on top of each other (a layer with a z-index of 2 appears in front of a box with the z-index of 1, and so on).

❖ Select a layer and enter a value in the Z-Index text box in the Layer tab of the Layer Inspector. Enter the z-index of 1 for the bottom layer in the stack, 2 for the next box in the stack, and so on. (You can also change a z-index number by selecting it in the Layers palette and typing a new number.)

Layer symbols and stacking order values
A. Layer object icon  B. Layer marker  C. The first layer has a z-index of 1  D. The layer in the middle has a z-index of 2  E. The layer in the front has a z-index of 3.

Managing layers

Using the Layers palette

You can use the Layers palette (Window > Layers) to quickly select multiple layers for alignment and grouping. You can also use the Layers palette to temporarily lock, hide, or show a layer as you work. (Unlike similar settings in the Layer Inspector, lock, hide, and show settings in the Layers palette do not affect the display of layers in the browser.)

Note: Some settings in the Layers palette are only temporary and will be overridden when you switch document views or click the Play button in the DHTML Timeline Editor for an animated layer.

Options in the Layers palette
A. Temporary hide/show status  B. Temporary lock/unlock status  C. Name of layer  D. Stacking order of z-index values  E. Create new layer  F. Delete selected layer

See also

“To reposition an object or group of objects” on page 250
To name a layer
1. Select the layer in the page or in the list in the Layers palette.
2. Enter a new name either in the Layers palette or in the Name text box in the Layers tab of the Layer Inspector. (Spaces and names that begin with a number are not allowed.)

GoLive displays the names of layers in the Layer palette and in lists to choose from when you're applying actions or animating them. The names are also used for referring to layers in JavaScript.

To temporarily lock, hide, or show a layer
❖ In the Layers palette, select the layer and do one of the following:
   • To temporarily hide or show the content of a layer, click in the eye column. You can also Ctrl-click (Windows) or Command-click (Mac OS) any eye icon to hide or show all layers at once.
   • To temporarily lock and unlock a layer, click in the padlock column. To lock or unlock all layers at once, Ctrl-click (Windows) or Command-click (Mac OS) any padlock icon. When locked, you cannot select or drag the layer or edit its content in the document window.
   • To preserve all temporary hide/show and lock/unlock settings when you click the Play button in the DHTML Timeline Editor or switch views, choose Lock Visibility from the Layers palette menu. 
   • To bring a layer to the foreground and make it temporarily visible and editable regardless of the hide/show and lock/unlock settings, click the name of a layer.

To view the hierarchy of nested layers
❖ Choose Hierarchic from the Layers palette menu.

With this option selected, you can drag layers in the palette to change their nesting order. (To display all the layers at the same level in the list, choose Flat from the palette menu.)

Converting layers into table-based layout grids
You can convert nonoverlapping layers and their contents into objects on a table-based layout grid in a new untitled page. Converting layers is useful if you need a layout-grid-based design for the page in addition to your DHTML layers-based design. If the layer contains text, it converts into a layout text box on the grid. The position, size, and background color attributes of the layer are retained. GoLive creates a new page to contain the converted objects, keeping the original page of layers intact.

❖ You can also convert a table-based grid to a CSS-based grid by right-clicking (Windows) or Control-clicking (Mac OS) the layout grid icon in the upper right corner of the layout grid, and choosing Convert To CSS Based Grid.

To convert a layer into a table-based layout grid
❖ Choose Convert To Layout Grid from the Layers palette menu. (The option is not available if any layers are overlapping.)
You can show or hide the vertical and horizontal grid lines in the layout grid by selecting the layout grid and then selecting or deselecting the Visible options in the Layout Grid Inspector.

Hiding and showing layers in a browser

With layers, you can hide and show images or text when viewers click or move the mouse over links on a page. You can also hide and show layers based on a given amount of time.

See also

“Applying timeline-triggered actions to layers” on page 262

To hide a layer when a page loads

❖ Select the layer and deselect Visible in the Layer tab of the Layer Inspector. (You can use the Layers palette to temporarily show the layer in GoLive as you work.)

To show or hide a layer using a mouse trigger

1 Select the text, object, or image that will serve as the mouse event trigger and click the Create Link button 📐 in the toolbar.

2 In the Inspector, type the number symbol (#) in the URL text box. Or, if the selection will also serve as a navigational link, enter the link’s destination URL in the text box instead of the number symbol.

3 In the Actions palette, select a mouse event (such as Mouse Enter) in the Events list and click the New Action button 📐. Then choose Action > Multimedia > Show Hide from the Action menu, choose your layer from the Layer menu, and choose Show, Hide, or Toggle from the Mode menu. (Toggle shows or hides the layer according to its current visibility status as set in the Layer Inspector.)

4 Save your page and preview the action in a web browser. You must preview actions in a browser.

For information about other scripted actions you can apply to layers, see “About actions” on page 608.
See also

“To name a layer” on page 258

“Specifying the destination URL for a link” on page 169

“Previewing web pages” on page 31

Animating layers

Using the DHTML Timeline Editor

You animate layers in the DHTML Timeline Editor by inserting keyframes in a layer’s time track and repositioning the layer for each keyframe. You can also set the visibility status or the stacking order of a layer based on a selected keyframe in its time track. You can use scenes to include multiple animations in the same web page.

To insert a keyframe in the time track

1. Open the DHTML Timeline Editor by clicking the DHTML Timeline Editor button in the upper right corner of the document window. A time track appears in the DHTML Timeline Editor for each layer on the page. Initially, each time track contains a single keyframe.

2. Click a keyframe to select the time track of a layer. The name of the layer appears in the Layer tab of the Layer Inspector.

3. Ctrl-click (Windows) or Command-click (Mac OS) at the desired position on the time track to insert a new keyframe. You can also Alt-drag (Windows) or Option-drag (Mac OS) a copy of an existing keyframe to the desired position on the time track to create a new keyframe.

The new keyframe marks the end of the play range, indicated by the right play range locator, which follows as you drag the keyframe. If you insert more keyframes, the keyframe farthest to the right always limits the play range. The distance between keyframes determines the playback speed—the shorter the distance, the faster the animation plays back.

To specify layer position for a keyframe

1. In the DHTML Timeline Editor, select the keyframe in the time track for the layer.

2. In the document window, drag the layer to the position where you want it to appear for the selected keyframe. You can also enter the desired position in the Left and Top text boxes in the Layer tab of the Layer Inspector.
3 Click the first keyframe in the DHTML Timeline Editor to return the layer to its start position.

4 Click the Play button at the bottom of the window to preview your animation.

The layer travels across the document window and stops where you set the last keyframe. The Time Cursor in the DHTML Timeline Editor stops at the right play range locator.

5 (Optional) Click the Stop button twice to stop playing and to reset the Time Cursor to the beginning of the play range.

6 (Optional) Click the Backward button to return the Time Cursor by increments to the beginning of the timeline.

To set layer visibility for a keyframe
1 Select the keyframe in the time track from which you want the layer to disappear or reappear.
2 In the Layer tab of the Layer Inspector, deselect or select the Visible option.
3 Click the Play button to preview your animation.

The layer appears or disappears until such time that the Time Cursor reaches another keyframe with a different visibility status.

To record an animation path
1 Open the DHTML Timeline Editor, and select the starting keyframe.
2 Click the Record button in the Timeline tab of the Layer Inspector.
3 In the document window, drag the layer along the desired path. A keyframe appears at each major turn in the path.
4 Click each keyframe and correct the position if necessary.

To specify the shape of an animation path
1 Select one or more keyframes in the time track.
2 Choose an option from the Animation menu in the Timeline tab of the Layer Inspector:
   None  Makes the layer jump between the keyframes.
   Linear (default path shape)  Makes the layer move in a straight line.
   Curve  Creates a smooth curve between keyframes.
   Random  Creates a zigzag path of random lengths between keyframes.

To loop playback
1 Use the Loop and Palindrome buttons in the lower left corner of the DHTML Timeline Editor to control the playback looping:
   Loop button  Plays your animation in an endless loop. When it reaches the end point of the animation path, the layer jumps back to the start and resumes traveling, repeating this cycle indefinitely.
   Palindrome button  Causes the layer to bounce back and forth between the start and end points of the play range. (The Loop button must be active to activate the Palindrome button.)
2 To change the playback speed, select a new frames-per-second option from the FPS menu at the bottom of the DHTML Timeline Editor.
Most browsers can handle the default 15 FPS setting, even if running on systems with average video hardware. If you want to work with higher speeds, be sure to test your animation with a wide selection of system configurations to make sure that playback is smooth.

**To create multiple scenes in an animation**

1. Create an animation. GoLive names the first animation you create “Scene 1” by default.
2. In the upper left corner of the DHTML Timeline Editor, choose Rename Scene from the pop-up menu.
3. Enter a name for the scene, and click OK.
4. Choose New Scene from the pop-up menu.
5. Enter a name for the new scene, and click OK.
6. Add keyframes and animate the layers for the new scene, and then preview the animation for the new scene by clicking the Play button in the DHTML Timeline Editor.

**To control the playback of scenes**

1. Go to the second scene, and click the Autoplay button to deselect it and disable automatic playback.
2. Return to the first scene, and Ctrl-click (Windows) or Command-click (Mac OS) in the Action Track anywhere before the last keyframe position to insert an action marker, indicated by a question mark icon. (The Action Track is the horizontal gray bar between the timeline and the time tracks.)
3. In the Action Inspector, click Show Action Palette, click the Actions tab, and choose Action > Multimedia > Play Scene. Choose the name of the second scene from the pop-up menu.
4. If the first scene is a looped animation or a palindrome, you need to insert a Stop Scene action: Ctrl-click (Windows) or Command-click (Mac OS) in the Action Track at the very last keyframe to insert an action marker. In the Action Inspector, click Show Action Palette, click the Actions tab, choose Action > Multimedia > Stop Scene and choose the first scene from the pop-up menu. The Stop Scene Action icon appears in the Action Track.
5. Move the Time Cursor to the beginning of the first scene and preview the animation in the browser.

**Note:** To give viewers more control over your animation, you can also attach the Play Scene action to a rollover button or hyperlink link in your page. For instructions on using actions with rollover buttons and text, see “About actions” on page 608.

**Applying timeline-triggered actions to layers**

You use the DHTML Timeline Editor to insert actions for layers in a timeline. Actions are ready-to-use scripts that you can use with the DHTML Timeline Editor, rollover buttons, links, and form elements. You can add actions to the timeline of a layer by inserting markers in the Action Track of the Timeline Editor, and defining the actions in the Actions Inspector.

Actions allow you to add sound, trigger the playback of animation scenes, dynamically change the content of images, and control other processes in the browser window. For information on actions you can use with layers, see “About actions” on page 608.
Understanding frames

About frames
Frames divide a web browser window into sections that contain separate pages. Using frames, you can make your page layout more visually interesting and help viewers navigate in your website. Since the content of each frame is a separate page (and separate file) with its own URL, it can be changed and scrolled independently of the pages in other frames. For example, you can use frames to create an onscreen navigation aid or table of contents that remains visible in one frame while the viewer scrolls through the page in another frame.

Note: Frame sets don't work well with web search engines because they have no content. For this reason, it's a good idea to not use a frame set for your index page. Also, you can't set bookmarks in the browser for frame-based web pages because the URLs map to the frame set rather than the desired pages.

Guidelines for frames
You need at least three HTML documents to create a two-frame page layout: one document for the frame set, which holds the frame structure, and two documents for the visible pages of content. The frame set is the master document that defines the size and location of the frames and contains the URL reference links to the content pages. You design the content pages to fit or scroll within specific frames in the frame set.

When working with frames, keep in mind the following browser limitations:

- Browsers tend to offset the content of a page from the edge of their main display area and from the inner edges of frames by a few pixels. This behavior can cause sizing problems. To help solve this problem, you can set the margins of the frame set document to zero. (See "To specify page margins" on page 159.)

- Nesting frame set documents within the frames of other frame sets is possible but can cause serious navigation problems.
Frame layout workflow
Use the following workflow when creating frames for your site:

1. **Create the pages of content.**
   Create the pages that will be displayed in the frames.

2. **Create and configure the frame set and name the frames.**
   In the frame set document, you can set frames to scroll the content of pages and to have visible borders or no borders. You can also set frames to be a fixed size or to resize proportionally when viewers resize their browser windows. (See “Selecting a frame set style” on page 264.)

3. **Link each frame to a content page.**
   If the frame will display multiple pages, link it to the first page you want to appear by default. (See “To set up a frame set” on page 265.)

4. **Open the navigation page.**
   Open the content page that you plan to use as a navigational aid or table of contents, and specify the destination pages and target frame for every link on the page. (See “About target frames for linked pages” on page 267.)

   You can double-click the Page icon in a frame to open the content page in another window.

Previewing frame sets and their contents
You use the Preview tab  to preview the entire contents of the frame set in the document window. You cannot edit the frame set or open linked pages in the Preview tab. (To open and edit linked pages, double-click their page icons in the Frame Editor.) In Mac OS, you can also preview a frame’s content within the frame set by using the Preview Frame button in the Frame tab of the Frame Inspector, or preview all the frames’ content by using the Preview Set button in the Frame Set tab of the Frame Inspector.

Setting up frame sets

Selecting a frame set style
You can use either the New dialog box or the objects toolbox to choose from a selection of frame sets.
The left frame is fixed while the right frame resizes automatically in the browser window.

A. Frame Editor tab  B. Frame set divider  C. Icon representing the page linked to this frame  D. The name of the frame  E. The pink-shaded areas represent frames with fixed pixel sizes.

To set up a frame set

1 Do one of the following tasks:

- Choose File > New, and choose Web > Framesets. Choose a frame set, and click OK.
- Open a new document window, and click the Frame Editor tab at the top of the window. In the Frames set of the objects toolbox, drag a Frame Set icon to the page or double-click it. When you hold the pointer over an icon in the palette, a description of the frame set appears, indicating, for example, which frames are fixed sizes and which ones aren't. Make sure XHTML 1.0 Frameset is chosen in the New Doctype menu, and then click OK in the Change Doctype dialog box.

2 Select the frame set by clicking any of its horizontal or vertical dividers.

3 In the Frame Set tab of the Frame Inspector, do any of the following:

- To arrange the frames in the frame set horizontally (all in one column) or vertically (all in one row), select an Orientation option. You can also select the Matrix option and enter the number of rows and columns in the Rows and Columns text boxes.
- To change the thickness of the selected divider in the document window, select BorderSize and enter a value in pixels.
- To hide a horizontal or vertical border, select BorderSize, and enter 0 in the text box, and then select Frame Border, and choose No from the pop-up menu. (This procedure sets the attributes for all browsers.)
- To assign a color to all borders in the frame set, select BorderColor, click in the color field, and then select a color from the Color palette. This color overrides the gray border that most web browsers display by default.

Note: To color the background of a frame, you must select a background color for the page you want to display in that frame.
4 Name the page title of the frame set document in the Layout Editor.

5 Save the frame set document. Make sure to save it with an .html extension, for example, Frameset.html.

**See also**

“To apply an image or color to the page background” on page 179

“To change the page title” on page 157

**To add another frame to a frame set**

- Do one of the following:
  - To add a frame before the current frame, select the frame and click Create New Frame Before in the Frame tab of the Frame Inspector.
  - To add a frame before the current frame, select the frame and click Create New Frame After in the Frame tab of the Frame Inspector.
  - Drag the Frame icon from the Frames set in the objects toolbox into the frame set.

**To split a frame**

- Select the frame and click Split in the Frame tab of the Frame Inspector.

**To move or copy a frame or a nested frame set**

- Shift-drag to move a frame or nested frame set. Ctrl-drag (Windows) or Option-drag (Mac OS) to copy a frame or frame set.

As you drag, you’ll notice that the frame orientation limits the direction of motion. You can drag vertical frames sideways and horizontal frames up and down, but you cannot extend the frame set by dragging beyond its boundaries.

<Message> You can copy a frame set to other documents or save a reusable copy of the frame set by dragging the frame set to the Snippets tab in the Library palette. (See “Snippets” on page 429.)</Message>

**Setting up individual frames**

**To name a frame**

1 Click inside the frame to select it.

2 In the Frame tab of the Frame Inspector, choose an option from the Name/ID menu (choose Name & ID for maximum browser compatibility), and then type a unique frame name in the Name/ID text box.

You can use the name of the frame as the target when you create links to it from other pages; for example, to make a link’s destination page appear in the frame. (Names assigned to individual frames won’t appear in the browser window.)

**To add a page to a frame**

- Drag the page from the site window into the frame. You can also select the frame and use the Frame Inspector to specify the page in the URL text box.
Note: To make the contents of the frame change when visitors click links on a page in another frame, you make this frame the target for each link. (See “About target frames for linked pages” on page 267.)

See also

“About links” on page 167

“About target frames for linked pages” on page 267

To set scrolling bars for a frame
❖ In the Frame tab of the Frame Inspector, choose Yes, No, or Auto from the Scrolling menu to show or hide scrolling bars. Auto hides the scrolling bars if they aren't needed and shows them if the content is too large for the frame.

To set the size of a frame
❖ In the Frame tab of the Frame Inspector, do any of the following:
• If you want the frame to resize automatically when the browser window is resized, choose Scale from the Width or Height menu.

Note: At least one frame in the frame set must be resizeable.

• If you don't want the frame to be resizeable, choose Pixel from the Width or Height menu, and enter the desired size in pixels. For example, use this technique if the frame will display a small image of known dimensions.

Note: If you specify an absolute size in pixels for one frame, you must set at least one more frame of the same orientation to Scale, or the frame set scales all frames in that direction.

• If you want the frame to have a fixed ratio relative to the overall height or width of the frame set, choose Percent from the Width or Height menu. Then enter a value in the Width or Height text box to preset a percentage. For frames with horizontal orientation, this attribute controls the relative height. For frames with vertical orientation, it controls the relative width.

Note: You can prevent users from dragging frame borders to resize the frame dimensions by deselecting Resize Frame in the Frame tab of the Frame Inspector.

To resize a frame by dragging
❖ Do one of the following:
• Click inside the frame to select it, and drag its vertical or horizontal border to resize the height or width.
• In the Frame tab of the Frame Inspector, choose Pixel or Percent from the Width or Height menu, and drag the frame border to the desired size.

To set the size of a frame border
❖ Select the vertical or horizontal border. In the Frame Set tab of the Frame Set Inspector, select BorderSize and enter a value in pixels in the text box.

About target frames for linked pages
When you set up navigation links to pages that are displayed in a frame set, you must specify each target frame as well as the page’s URL.
For example, if you use a frame set to display a table of contents in one frame and the pages linked to the table of contents in another frame, every link in the table of contents must specify the target frame in which the linked page will appear.

Each navigation link specifies both destination page (content.html) and target frame (Content).

**To specify a target frame for linked pages**

1. Open the content page that contains the navigation links. (You can double-click the Page icon in the frame to open the page.) For information on creating navigation links, see “About links” on page 167.

2. For each link, in the Text Inspector or the Link tab of the Image Inspector, specify the target frame where you want the linked page to appear by choosing an option from the Target menu:

   - **[Frame name]** Displays the linked page in that frame. The frame names of your open frame set appear at the top of the menu.
   - **_top** Displays the linked page in the full web browser window, replacing the current frame set entirely.
   - **_parent** Displays the linked page in the parent of the current document. If the current page has no parent, the target _self is used. (The parent is the next highest frame set in the hierarchy.)
   - **_self** Displays the linked page in the window or frame that contains the link, replacing the navigation page.
   - **_blank** Displays the linked page in a new untitled window.
   - **Default** Removes any previously set target for the page.
   - **QuickTime Plugin (myself)** Replaces the QuickTime movie currently playing.
   - **QuickTime Plugin (quicktimeplayer)** Starts a QuickTime movie in the QuickTime Player.
   - **RealOne Browser (_rpbrowser)** Displays links in the Real Media browser pane.
   - **RealOne External (_rpxternal)** Displays links in a new RealOne window.

💡 You can use the ForceFrame action to prevent browsers from displaying a page outside of the frame set you’ve created for it. You can also use the Target2Frames action to set multiple target frames for a single link.
See also

“About actions” on page 608

**Inline frames**

Inline frames enable you to insert a frame in a non-frameset page. Web browsers typically display the frame with horizontal and vertical scrollbars.

![An inline frame embedded in a page](image)

**To insert an inline frame**

1. Open the page in which you want to insert the frame.

2. Drag the Inline Frame icon ![Inline Frame Icon](image) from the Frames set of the objects toolbox to the page, or double-click the icon to place it at the insertion point.

3. In the Inline Frame Inspector, browse or use the pick whip to link to the file you want contained within the inline frame.

4. In the Inline Frame Inspector, choose an option from the Name/ID menu (choose Name & ID for maximum browser compatibility), and then type a unique name in the Name/ID text box.

5. Do any of the following in the Inline Frame Inspector:
   - Choose a height and width for the inline frame in pixels or percentages.
   - Enter a margin width or margin height for the inline frame.
   - Select alignment and scrolling options.
   - Select Frame Border to display a border around the inline frame.
ADOBE GOLIVE CS2 270
User Guide

Special page elements
To add comments to a page
As you lay out content on your web pages, you can add comments about the design. Comments appear only in
GoLive (in the Comment Inspector and the source code) or other HTML editors and do not appear on the pages in
web browsers. You can also add comments to the head sections of pages.
1 Drag the Comment icon from the Basic set in the objects toolbox to the desired location in the page, or double­
click the Comment icon to place it at the insertion point.

A symbol

appears in the text to indicate the location of the comment.

2 In the Comment Inspector, type your comment.

See also
“Head section elements” on page 164

To add date and time stamps
You can display the date and time that you saved the page; for example, to tell your viewers when you last updated
the page. GoLive reads the current date or time from your computer’s built-in clock and writes the result in a custom
tag. It then updates the information whenever you save the page.
1 If you want descriptive text before the date or time stamp (for example, “Last revised:”), type the text in the page.
2 Drag the Modified Date icon from the Smart set

in the objects toolbox to the page, or double-click the icon to

place it at the insertion point.
3 In the Modified Date Inspector, choose a country from the Format menu and select a date and time format in the
list of options for the specific country.

To add URL pop-up menus
If you have several hypertext links on your page, you can present them in a pop-up menu for your viewers to choose
from. To test the links in the menu, you must preview the page in a web browser.
1 Drag the URL Popup icon from the Smart set in the objects toolbox to your page.

A

B

You can change the Choose... label at the top of the menu or make it blank.
A. URL pop-up menu in the page B. URL Popup icon in the objects toolbox

2 In the URL Popup Inspector, do the following:
• In the Label text box, type a new label to appear at the top of the new pop-up menu or leave it blank.
• To add a URL to the new pop-up menu, click the New Item button

. Type a new label for the URL in the Label
text box, and enter the destination of the link in the URL text box. If you’re using a frame set, specify the target
frame for the URL in the Target text box. You can also click the Duplicate Selected Items button
to create a
copy of a URL already in the pop-up menu and edit the label or URL in the Label, URL, and Target text boxes.


• To move an item up or down in the list, select it and click the arrow buttons.
• To remove an item from the list, select it and click the Remove Selected Items button.

3 Preview the URL pop-up menu and each link in a web browser.

See also
“About frames” on page 263
“About links” on page 167
“Previewing web pages” on page 31

To add horizontal lines
To visually separate blocks of text, you can use horizontal lines (also called rules). You can place horizontal lines in layout text boxes, but not directly in a layout grid.

1 Drag the Line icon from the Basic set in the objects toolbox into a text area, or double-click the Line icon to place it at the insertion point in the text. (Horizontal lines should never be placed directly on a layout grid—but in a layout text box instead.)

2 In the Line Inspector, do any of the following:
• Click a button for Style: the left button to apply a solid style, or the right button to apply a three-dimensional style.
• Choose a measurement from the Width menu. Full and Percent are measured in relation to the container (such as a layout text box, table cell, or the document window).
• In the Height text box, enter a new line height in pixels. You can also select the line, and drag its handle to adjust the height.
• Click a button to align the line in relation to the layout text box, layout grid, or document window. (The buttons are dimmed if the line is full width.)

Adding horizontal space between items on a page
To quickly arrange and space items on a page, use layout grids. Without a layout grid, however, you can still space items horizontally by using the following techniques:

• Use nonbreaking spaces to insert space between text.
• Use transparent GIF images to insert space between text and objects. These images download quickly and can be resized to fill any space.
• Use Netscape spacer elements to insert space between text and objects. These elements function like transparent GIF images, but work only in Netscape Navigator 3 and 4 browsers: they’re ignored by Netscape 6 and later, Internet Explorer, and Safari browsers.

See also
“About layout grids” on page 247

To create a nonbreaking space
❖ Press Shift+spacebar (Windows) or Option+spacebar (Mac OS).
See also
“Adding horizontal space between items on a page” on page 271

To use a transparent GIF image for spacing
1 Create a small (1x1 pixel) transparent GIF image in your image editing software and drag it into the Files tab of your site window.
2 Drag the transparent GIF image from the site window to the desired location in the text. (See “Specifying the destination URL for a link” on page 169.)
3 In the document window, drag the image's selection handles or use the Image Inspector to resize the image. You can also use the Image Inspector to align the transparent image horizontally and vertically within the text. If you have trouble selecting the image on the page, click the <img> tag in the markup tree bar at the bottom of the document window.

You can save the resized transparent GIF image for reuse on other pages by dragging it into the Snippets tab of the Library palette. (See "Snippets" on page 429.)

See also
“To move or resize a layer by dragging” on page 255
“Adding horizontal space between items on a page” on page 271

To use a Netscape spacer element for spacing
Netscape spacers are recognized only by Netscape Navigator 3 and 4 browsers; they’re ignored by Netscape 6 and later, Internet Explorer, and Safari browsers.
1 Drag the Horizontal Spacer icon from the Basic set in the objects toolbox to the desired location in the text.
2 In the Spacer Inspector, select a Horizontal, Vertical, or Block resizing option. (Block allows you to resize the spacer both horizontally and vertically.)
3 Select the spacer and drag its handles to resize it, or enter values (in pixels) in the Width and Height text box.
4 To align a block spacer in relation to the text, select it and choose an option from the Alignment menu in the Spacer Inspector.

See also
“Adding horizontal space between items on a page” on page 271

To create a scrolling marquee
1 Drag the Marquee icon from the Basic set in the objects toolbox to the page.

If you want to control the font and style of the marquee text on a layout grid, place the marquee in a layout text box.

2 In the Basic tab of the Marquee Inspector, type the message for the marquee in the Text box.
3 Choose an option from the Behavior menu:

**Scroll** Causes the message to scroll continuously.

**Slide** Moves the message into the marquee box and to hold it there.

**Alternate** Moves the message into the marquee box and to bounce it between the edges.

4 Determine how long the marquee is visible:

- Select Forever to make the message scroll continuously.
- Enter a required number of repetitions in the Loops text box.

5 Enter the desired scrolling speed in the Amount text box (the scrolling speed is measured in pixels between each scrolling amount in milliseconds).

6 Enter the scrolling delay between repetitions in the Delay text box.

7 Select Left or Right to determine the scrolling direction. When Left is selected, the message appears on the right side of the window and scrolls to the left.

8 Click the More tab in the Marquee Inspector, and do any of the following:

- Enter the dimensions (in pixels or as a percentage) for the marquee in the Width and Height text boxes.
- Enter a value in the HSpace or VSpace text box to set the horizontal or vertical space around the marquee’s text.
- Choose an alignment from the Align menu for the marquee object in relation to text or other objects within the text line.
- Click the color field and select a color in the Color palette for the background of the marquee. Or, click the lower right of the color field and select a color from the swatches that appear.
Chapter 11: Tables

Understanding tables

Designing with tables
In addition to displaying information in rows and columns, you can design tables to create visually rich page layouts. You can lay out text and many kinds of objects—including images, nested tables, Photoshop files, and QuickTime movies—withina table.

Positioning text and objects using tables is even easier if you use a GoLive layout grid with layout text boxes.

See also
“About layout grids” on page 247

GoLive table features
The table features in Adobe GoLive make it easy to lay out entire web pages or organize information in rows and columns. You can instantly generate a table in GoLive by using a table you’ve copied in a different application, including Adobe InDesign, Adobe FrameMaker, and third-party word-processing or spreadsheet applications, such as Microsoft Excel or Microsoft Word.

Format tables with the Table Inspector (left); select table cells and apply table styles with the Table & Boxes palette (right).

To build tables manually, you use the Table icon in the objects toolbox and set table properties in the Table Inspector. You can quickly format tables with the predefined table styles in the Table Style tab of the Table & Boxes palette. The Select tab of the Table & Boxes palette lets you select a group of cells or nested tables with greater ease than in the document window. In addition, the Select tab identifies table size conflicts and enables you to fix them with one click.

Use the Smart Photoshop object to automatically create a table that contains optimized slices of a sliced Photoshop image.

See also
“Adding sliced Photoshop images” on page 377
Creating tables

To create a new empty table

- To place the table at the insertion point with a particular number of rows and columns, Ctrl-drag (Windows) or Command-drag (Mac OS) the Table icon in the Basic set of the objects toolbox. Release the mouse button when the desired number of rows and columns appear.

- To place a table of three rows and three columns at the insertion point, double-click the Table icon in the Basic set of the objects toolbox.

- To place a table of three rows and three columns, drag the Table icon from the objects toolbox to the document window.

See also

“Converting a table-based layout grid to a table” on page 252

To copy GoLive tables

❖ Do one of the following:

- Select one or more cells in an existing GoLive table, and choose Edit > Copy. Then place an insertion point and choose Edit > Paste.

- Select one or more cells in an existing GoLive table. Move the pointer over the black square in the upper left corner of the selection until the pointer changes to the hand icon; then drag the selection to a new location.

See also

“Select a table” on page 277

To copy a table from another application

1 In the other application, select and copy the table or cells you want to paste.

2 In GoLive, select an existing table cell to be the upper left corner cell of the content you copied.

3 Choose Edit > Paste.

The table creates additional rows and columns as needed to include all of the information that was copied.
To convert a table to a layout grid
You may want to convert a table to a layout grid in order to move items around the table more easily. Nested tables and cells that contain text or an object convert to layout text boxes.

❖ In the Table tab of the Table Inspector, click Convert. If desired, customize the appearance of the layout grid and layout text boxes.

See also
"About layout grids" on page 247
"Converting a table-based layout grid to a table" on page 252

Selecting tables, rows, columns, or cells

Selecting tables or cells
GoLive provides a variety of ways to select cells, rows, columns, and nested tables to suit your needs. You can make selections directly in the document window, in the markup tree bar, or in an outline of the table in the Select tab of the Table & Boxes palette. The Select tab shows a table as a bare outline, and enables you to make cell or nested table selections without the risk of resizing the selection or selecting content inside the cell.
Selecting a table cell with the Select tab of the Table & Boxes palette

A. Selected table cell  
B. Nested tables display a gray outline when not selected. (Cells within nested tables appear only when the nested table is selected.)

After you select a row, column, or cell in a table, you can delete the selection, copy and paste it, or drag the selection to move it within the table or to create a new table. Selected cells are outlined in bold in the document window and in the Table & Boxes palette, and highlighted in source code views.

If you place an insertion point in a table cell, select content in a cell, or select a table cell, you can press Ctrl+Enter (Windows) or Control+Return (Mac OS) to expand the selection outward.

**To select a table**

- Do any of the following:
  - Select a cell in the table and press Ctrl+Enter (Windows) or Control+Return (Mac OS). Or place an insertion point in the table or select content within a table cell and press the keys twice.
  - In the document window, move the pointer over the top or left edge of the table until the pointer changes to the Table Selection pointer, and then click.
  - In the document window, place an insertion point in the table or select content within a table cell. Choose Select Table from the context menu in either the document window or the Select tab in the Table & Boxes palette, or click the `<table>` tag in the markup tree bar at the bottom of the page.
  - To select a nested table, in the Select Tab of the Table & Boxes palette, move the pointer over the nested table until the pointer changes to the Nested Table pointer, and click. Click the Select Parent Table button in the Table & Boxes palette to reselect the parent table.
To select rows
❖ Do any of the following:
- In the document window or Select tab of the Table & Boxes palette, move the pointer over the left edge of a row until it changes to the Row Selection pointer \( \rightarrow \), and then click. Drag up or down to add adjacent rows to your selection. Alternatively, with the Row Selection pointer, Shift-click the left edge of each additional row.
- Place an insertion point in the row, and click the rightmost \(<tr>\) tag in the markup tree bar at the bottom of the page. To add rows to your selection, move the pointer over the left edge of each additional row in the document window until it changes to the Row Selection pointer, and then Shift-click.
- Place an insertion point anywhere in the table, click the \(<table>\) tag in the markup tree bar at the bottom of the page, drag to display a pop-up menu, and then choose the \(<tr>\) tag for a row. To add rows to your selection, move the pointer over the left edge of each additional row in the document window until it changes to the Row Selection pointer; then Shift-click.

Selecting a table row with the markup tree bar

To select columns
❖ In the document window or the Select tab of the Table & Boxes palette, move the pointer over the top edge of a column until the pointer changes to the Column Selection pointer \( \downarrow \); then click. Drag left or right to add adjacent columns to your selection. Alternatively, with the Column Selection pointer, Shift-click the top edge of each additional column.

To select cells
❖ Do any of the following:
- To select cells from within the document window, move the pointer over a cell's bottom or right edge until the pointer changes to an arrow \( \rightarrow \) (Windows) or \( \arrow \) (Mac OS), and then click. Drag from the selected cell to add adjacent cells to your selection. Alternatively, Shift-click inside each additional cell.
- Place an insertion point in a cell, and either click the rightmost \(<td>\) tag in the markup tree bar at the bottom of the page and press Ctrl+Enter (Windows) or Control+Return (Mac OS), or choose Special > Table > Select Cell.
- In the Select tab of the Table & Boxes palette, click to select a cell. Drag from the selected cell to add adjacent cells to your selection. Alternatively, Shift-click each additional cell.
- To select all cells, select any corner cell in the document window or the Select tab of the Table & Boxes palette, and then drag over all cells in the table. Or select a cell, and choose Edit > Select All.
- To invert the selection of cells within a row or column, move the pointer over the left edge of the row or the top edge of the column until it changes to the Row or Column Selection pointer \( \rightarrow \) \( \downarrow \) \( \downarrow \), and then Shift-click. (GoLive deselects previously active cells in the row or column and selects previously inactive cells.)
Moving, adding, or deleting rows or columns

To move or duplicate a table column or table row

1. In either the document window or the Select tab of the Table & Boxes palette, select one or more entire columns or rows.

2. Move the pointer over the square icon in the upper left corner of the selection until the pointer changes to a hand.

3. Do one of the following:
   - To move the selection, drag to the desired location within the current table or to a different table. Release when a solid black line appears in the desired location.
   - To duplicate the selection, Ctrl-drag (Windows) or Option-drag (Mac OS) to the desired location within the current table. Release when a solid black line appears in the desired location.

Note: If you drag a selection of cells, you can add the cells to a different table only if the destination table has the same number of rows as the cells that you are dragging. Otherwise the selection becomes a nested table within a cell of the destination table.

To replace table cells

1. Select a single cell or a block of adjacent cells that you want to duplicate.

2. Choose Edit > Copy.

3. Select the block of cells that you want to replace, and choose Edit > Paste to replace the contents of a similar block of cells in a table.

Note: Your target selection must match your source selection. For example, if you copy four cells in a row, you can only use your selection to replace the contents of another four cells in a row.

Moving a table column in a table in the document window
To add a table row or column
❖ Do any of the following:

• Select the table or a cell in the table, and enter the desired number for Rows and Columns in the Table tab of the Table Inspector. (Rows are added to the bottom of the table. Columns are added to the right side of the table.)

• Select a cell adjacent to where you want a new row or column to appear. In the Cell tab of the Table Inspector, click the Add Row Above button \( \text{\textcircled{A}} \), the Add Row Below button \( \text{\textcircled{B}} \), the Add Column To Left button \( \text{\textcircled{C}} \), or the Add Column To Right button \( \text{\textcircled{D}} \).

• Place an insertion point in the last table cell, and then press Tab.

• Select a cell, and choose an insert command from the Special > Table menu.

• Press Ctrl+Shift (Windows) or Command+Shift (Mac OS), and move the pointer over the bottom edge of the table (to add rows), or the right edge of the table (to add columns), until the pointer changes to the Add Rows pointer \( \text{\textcircled{E}} \), or the Add Columns pointer \( \text{\textcircled{F}} \); then drag away from the table.

To delete a table row or column
❖ Select the row or column or one or more cells in the row or column, and then do one of the following:

• In the Table tab of the Table Inspector, enter the desired number for Rows and Columns. (Rows are removed from the bottom of the table. Columns are removed from the right side of the table.)

• Click the Delete Column button \( \text{\textcircled{G}} \), or the Delete Row button \( \text{\textcircled{H}} \) in the cell tab of the Table Inspector.

• Choose a delete command from the Special > Table menu.

• Choose Edit > Cut or Edit > Delete, or press Delete on the keyboard.

Resizing and fixing tables

Table size conflicts
The Select tab of the Table & Boxes palette lets you review the size and units of every row and column within a table, as well as those of the entire table. This tab also lets you identify and quickly fix conflicts in your column, row, and table sizes. These conflicts can occur when the dimensions of content within a table exceed the table properties or when the table properties do not add up properly.
To identify table, row, and column sizes

❖ Select a table, row, column, or cell. In the Select tab of the Table & Boxes palette, selected cells appear in bold outline, and blue lines mark the column and rows shared by the selection.

The width of the active table appears above the table outline between lines spanning the table's width. The table's height appears to the left of the table outline between lines spanning the table's height. Column sizes appear above each column, and row sizes appear to the left of each row.

Table property sizes are shown in black, gray, or red characters to signify different value types:

• If the table, column, or row size is shown in gray characters, the size of the property is set to Auto in the Table Inspector. This means that the size will automatically adjust to the minimum size needed to contain any content within the row, column, or table.

• If the size is shown in black characters, the size is defined either with pixels (when the value is followed by a “p”) or a percentage (when the value is followed by a percent sign, %). A row or column size that is set to a percentage represents a percentage of the table height or width. A table dimension that is set to a percentage represents a percentage of the browser window.

• If the size is shown in red characters, the actual size of the row, column, or table dimension is larger or smaller than the displayed value, which is the size set in the Table inspector. For example, if the table width is set to 300 pixels, but the combined width of the table columns is less or more than 300 pixels, then the value of the table width will be shown in red.

To fix table, column, or row size conflicts

• To set a table property to the pixel size that it requires, in the Select tab of the Table & Boxes palette, move the pointer over the red pixel value until it changes to the Fix pointer , and then click.

• To set a table property to automatically resize as needed, select the table, column, or row that has a red pixel value and set the conflicted property to Auto or Percent in the Table Inspector. (Fix table size conflicts with the Width or Height properties in the Table tab of the Inspector. Fix row size conflicts with the Height property in the Cell tab of the Inspector. Fix column size conflicts with the Width property in the Cell tab of the Inspector.)
To resize a table

- To specify a new size in the Table tab of the Table Inspector, choose an option from the pop-up menu for Width or Height, and enter the desired measurement value. Choose Auto to automatically adjust the width or height to the minimum size needed to contain any content within the table. Choose Percent to set the size of the width or height as a percentage of the browser window.

- To resize a table dimension using fixed pixel values, Alt-drag (Windows) or Option-drag (Mac OS) the right or bottom edge of the table. (If the Width or Height is already set to pixels, you don’t need to press the Alt or Option key while dragging.)

To resize a table row or table column

- To specify a new size in the Table Inspector, select a cell in the row or column that you want to resize, and then in the Cell tab of the Table Inspector, choose an option from the pop-up menu for Width or Height and enter the desired measurement. Choose Auto to automatically adjust the width or height to the minimum size needed to contain any content within the row or column. Choose Percent to set the size of the row or column as a percentage of the table size.

- To resize a row or column using fixed pixel values, Alt-drag (Windows) or Option-drag (Mac OS) the right or bottom border of a cell in the row or column that you want to resize. (If the row or column is already set to pixels, you don’t need to press the Alt or Option key while dragging.)

Formatting tables with table styles

Using table styles

GoLive includes a variety of predefined table styles in the Style tab of the Table & Boxes palette, which you can use to instantly format a table or portions of a table. You can apply a table style to your table and easily remove it if it doesn’t meet your needs. You can also create your own table style, save it, and apply it to other tables on your web pages so you can create a consistent appearance for tables throughout your website. Save different sets of table styles to a file that can be shared with others or import table styles for use with specific sites.

You create styles from existing tables. The style repeats based on the number of rows and columns in the original table. For example, if you create a style from a two-row by two-column table and apply it to a six-row by six-column table, the first row style is applied to the first, third, and fifth rows of the six-by-six table. Tables retain their existing property values if a new value isn’t specified in the table style.

Table styles can contain the following attributes:

- In the Table tab of the Table Inspector: Border, Color, Cell Pad, and Cell Space.
- In the Row tab of the Table Inspector: Vertical Alignment, Horizontal Alignment, and Color.
- In the Cell tab of the Table Inspector: Vertical Alignment, Horizontal Alignment, Color, Header Style, and No Text Wrap.

The Table & Boxes palette displays a preview of a selected table style. Blue brackets indicate which rows and columns contain repeating styles. For example, a blue bracket around only the second and third rows indicates that the first row style is applied only to the first row, while the styles of the second and third rows repeat for all other rows.
To apply a table style to a table or table area
1 Select the table or portions of it that you want to format.
2 In the Style tab of the Table & Boxes palette, choose a table style from the pop-up menu.
3 Resize the blue bracket so that it marks the desired rows or columns to contain repeating styles. (To resize a blue bracket, drag either end of it. The resizable area of the bracket is marked by blue lines at both ends of the bracket.)

Note: Depending on the table style, you may not be able to change which rows or columns contain repeating styles. For example, if the style of all columns is the same and a blue bracket marks the second column, you won't be able to resize the bracket to modify the style.

4 Click Apply or choose Apply Table Style from the Table & Boxes palette menu.

To remove a table style from a table
1 Select the table or portions of the table which you want to remove a predefined style from.
2 In the Style tab of the Table & Boxes palette, click Clear; or, from the Table & Boxes palette menu, choose Clear Table Style.

To add or edit table styles
- To create a new table style based on a table you've created, select the table and click the New Table Style button or choose New Table Style from the Table & Boxes palette menu. Enter a name in the New Table Style dialog box and click OK.
- To create a new table style based on an existing style that's in the Table & Boxes palette, choose a table style in the Style tab of the Table & Boxes palette, and then click the New Table Style button or choose New Table Style from the Table & Boxes palette menu. Enter a name in the New Table Style dialog box and click OK.
- To replace a table style with the appearance of a table you've created, choose a table style in the Style tab of the Table & Boxes palette, select the table in the document, and then click the Capture Table Style button or choose Capture Table Style from the Table & Boxes palette menu.
To rename a table style, choose the table style and then click the Rename Table Style button or choose Rename Table Style from the Table & Boxes palette menu.

To remove a table style from the Table & Boxes palette, in the Style tab, choose a style from the pop-up menu, and then click the Delete Table Style button or choose Delete Table Style from the Table & Boxes palette menu.

**To import or export table styles**

- To export a set of table styles, choose Export Table Styles from the Table & Boxes palette menu, name the file with an .xml extension, and then click Save.
- To import a set of table styles, choose Import Table Styles from the Table & Boxes palette menu, and then open a table styles file with an .xml extension in the file name.

**To undo or redo a table style selection**

❖ Choose Undo Select Table Style or Redo Select Table Style from the Table & Boxes palette menu.

---

**Formatting tables with the Table Inspector**

**Formatting tables**

A well-designed table lets you control the layout of content on your web page and present information in a visually effective way. GoLive lets you precisely format a table by setting table, row, or cell properties in the Table Inspector. Properties in the Table tab of the Table Inspector affect the entire table, and properties in the Row and Cell tabs affect only the current selection.

 Formatting tables to your own specifications can take some time and effort. You can save and reuse a table on other pages by dragging it to the Snippets tab of the Library palette.

The properties in the Table tab of the Table Inspector let you set a variety of properties that affect all of the cells in the table, and let you set the alignment of the table relative to its surroundings. You can also import text into the table, add a caption, or convert the table into a layout grid.

**Note:** In addition to setting options in the Table Inspector, you can customize the appearance of a table by applying a predefined table style to it.

**See also**

“Using table styles” on page 282

“Snippets” on page 429

**To format a table with the Table Inspector**

1. In the Table tab of the Table Inspector, enter the desired Border width value.

   ❖ If you set the border width to 0, borders appear as dashed outlines in the Layout Editor but do not appear in the browser. To hide these outlines in the Layout Editor, choose View > Hide Invisible Items.

2. To change the amount of vertical and horizontal space that appears between cell walls and content within the cells, enter a number for Cell Pad value.

3. To change the size of cell walls, enter a number for Cell Space value.
Border, Cell Pad, and Cell Space table properties compared

A. Border of 1 pixel  B. Border of 10 pixels  C. Cell pad of 5 pixels  D. Cell pad of 10 pixels  E. Cell space of 5 pixels  F. Cell space of 10 pixels

4 Select Color to apply a background color to the table. To set the color value, do one of the following:

- Right-click (Windows) or Control-click (Mac OS) the color field or click the black triangle in the lower right corner of the color field, and then select a color from the color swatches that appear.
- Click the color field, and then select a color from the Color palette that appears.

If a table cell doesn't contain text or other content, the table background color doesn't appear in the Layout Editor or in some browsers. To display background color in empty cells, insert a nonbreaking space into the cell.

5 Choose an option from the Align menu to align the table with respect to the document window. Choose Left or Right to have surrounding text or objects wrap to the side of the Table. Choose Default to have surrounding text or objects wrap along the bottom edge of the table. (You can't use the Align menu to align a table on a layout grid.)

6 Select Caption to add a caption to the table, and then choose a location for the caption from the menu.

7 To apply a background image to the table, select BgImage and then reference an image in the text field.

See also

“About the Color palette, Swatches palette, and the Color Picker” on page 175

“Adding horizontal space between items on a page” on page 271

To format rows with the Table Inspector

The properties you set in the Row tab of the Table Inspector affect all of the cells located in the selected row, including any cells that span downward into other rows.

1 Select the rows or a cell within a row that you want to format.

2 In the Row tab of the Table Inspector, choose a property from the Vertical Alignment pop-up menu to set the vertical alignment of content within the row. Default aligns the content vertically according to the browser’s preferences.

3 Choose a property from the Horizontal Alignment pop-up menu to set the horizontal alignment of content within the row. Default aligns the text horizontally according to the browser’s preferences.
4 Select Color to apply a background color to the row. To set the color value, do one of the following:

- Right-click (Windows) or Control-click (Mac OS) the color field or click the black triangle in the lower right corner of the color field, and then select a color from the color swatches that appear.
- Click the color field, and then select a color from the Color palette.

5 Choose an option from the Height menu to change the height of the row, and then enter the desired measurement. Choose Auto to automatically adjust the height to the minimum size needed to contain any content within the row. Choose Percent to set the height as a percentage of the table height.

See also
“About the Color palette, Swatches palette, and the Color Picker” on page 175

To merge table cells
- To merge selected cells, select two or more adjacent cells, and choose Special > Table > Merge Cells.
- To merge adjacent cells, select a single cell, and choose Special > Table > Merge Cells Right or Merge Cells Down.
- To merge two or more cells in a column, select the topmost cell that you want to merge and enter the number of rows to span in the Row Span box in the Cell tab of the Table Inspector, or press Shift+Down Arrow to extend the cell one row down at a time.
- To merge two or more cells in a row, select the leftmost cell that you want to merge and enter the number of columns to span in the Column Span box in the Cell tab of the Table inspector, or press Shift+Right Arrow key to extend the cell one column to the right at a time.

Note: When you merge cells, the data from the first cell is kept and the data from the other cells is deleted. If you later split a cell you’ve previously merged, the deleted data does not reappear.

To reduce or unmerge a table cell
1 Select a cell that is merged with other cells.

2 Do one of the following:
- To shorten the cell one row up at a time, press Shift+Up Arrow key or choose Special > Table > Reduce Merge Up.
- To shrink the cell one column to the left at a time, press Shift+Left Arrow key or choose Special > Table > Reduce Merge Left.
- To unmerge all cells in the merged cell, choose Special > Table > Split Cell.
To format table cells

1. Select the cells you want to format.

2. In the Cell tab of the Table Inspector, choose a property from the Vertical Alignment pop-up menu to set the alignment of content within the cells. Default aligns the text vertically according to the browser's preferences.

3. Choose a property from the Horizontal Alignment menu to set the horizontal alignment of content within the cells. Default aligns the text horizontally according to the browser's preferences.

4. Select Color to apply a background color to the selection. To set the color value, do one of the following:
   - Click the black triangle in the lower right corner of the color field, and then select a color from the color swatches that appear.
   - Click inside the color field and then select a color from the Color palette.

5. Choose an option from the pop-up menu for Width or Height to adjust the height or width of the cell, and enter the desired measurement. Choose Auto to automatically adjust the width or height to the minimum size needed to contain any content within the row. Choose Percent to make either dimension a percentage of the table size.

   Note: When you adjust the height or width of the cell, GoLive automatically adjusts the width or height of the entire row or column that contains the cell.

6. Select Header Style to format the cell as a subheader, which treats content within it using a table heading style.

7. Select No Text Wrap to suppress automatic text wrapping in the cell.

8. Select BgImage to apply a background image to the cell, and then select an image file.

See also

“About the Color palette, Swatches palette, and the Color Picker” on page 175

Formatting tables with cascading stylesheets

You can use cascading stylesheets (CSS) to set the properties of tables and content within a table. Styles can apply to either all tables in a page or particular tables or cells. If you modify a CSS style, GoLive automatically updates all tables and cells that use it. Pages can reference a unique internal stylesheet or a separate external stylesheet shared by multiple pages.

Note: Some properties in the CSS Editor, such as those in the Background tab, affect the table, whereas other properties, such as those in the Font tab, affect content within a table cell. For example, if a style defines a Font color property for a cell, any text within the cell displays the color property but the cell does not.
To create a CSS element style that applies to all tables, rows, or cells in a page

- To set the properties of all tables in a page, create an HTML element style named after the `<table>` tag.
- To set the properties of all table rows in a page, create an HTML element style named after the `<tr>` tag.
- To set the properties of all table cells in a page, create an HTML element style named after the `<td>` tag.

See also

“About HTML element styles” on page 326

To apply a CSS style to particular tables, rows, or cells

1. Create a class style.
2. Select a table, row, cell, or group of cells.
3. Do one of the following in the CSS palette:
   - To apply the class to a selected table, select the `<table>` column that is adjacent to the style name.
   - To apply the class to a selected row, column, or group of cells, select the `<td>` column that is adjacent to the style name. (If a row or column is selected, the `<td>` column name will be followed by the number of cells in the selection).

See also

“Class styles” on page 327

“Applying styles” on page 338
Text in tables

Adding text to tables
GoLive provides a variety of ways to add text to a table. Besides typing text directly in a table cell, you can copy and paste text from another application, drag text between cells or other containers, and import data from a text file.

When you import data into a table, you need to begin by formatting data in a text file in a way that GoLive accepts. For a single-celled table, you should simply format the data in the other application as you'd like it to appear in the table. For a multiple-celled table, you should format the data so that each line represents the contents of a row and contains column separators (tabs, commas, spaces, or semicolons) to separate the data between columns. Most spreadsheet and database applications can export data to a text file in one of these column-separated formats.

Rather than setting up a column-separated file to import data, you can simply copy the data from cells in another application and paste it into a GoLive table. Rows and columns will be added to the GoLive table as needed.

To paste text into a table
1 Do one of the following:
   • In GoLive, select the text that you want to copy, and choose Edit > Copy.
   • Copy a block of text in another application.
2 In GoLive, place an insertion point in a table cell, and choose Edit > Paste.

To drag text into a table
❖ In GoLive or a different application, select the text you want to copy and then drag it to an empty table cell in GoLive.

Linking text in tables
You can use the Text tab of the Table Inspector as you would use the Text Inspector—to link text that's selected inside a table. You can also use it (and the other tabs in the Table Inspector) as a quick way to toggle between the text and the cell, row, and table that contains it.

See also
“Creating resource and navigational links” on page 167

To import tab-delimited text into a table
1 Select the table on the page.
2 Do one of the following:
   • In the Table Inspector, click Import, select the text file that contains rows and columns of text separated by tabs, and click Open.
   • Choose Special > Table > Import Tab-Delimited Text.
GoLive places the text into table cells according to how many tabs (for columns) and paragraphs (for rows) there are in the text.
This feature is useful for quickly adding data to a table that you have exported from a database or spreadsheet as a tab-delimited text file.

**To export text in a table to tab-delimited text**

1. Select the table.
2. Do one of the following:
   - In the Table tab of the Table inspector, click Export. Give the file a name and click Save.
   - Choose Special > Table > Export Tab-Delimited Text.

**Sorting in tables**

**Sorting content in tables**

You can sort the order of rows in a table so that the contents of one or more columns appear in numerical and alphabetical order, or you can sort the order of columns in the table so that the contents of one or more rows appear in numerical and alphabetical order. You can apply the sort to an entire table, specific rows, specific columns, or specific cells. For example, you can apply the sort to all rows except for a top row that contains column headings.

GoLive performs the sort first in numerical order and second in alphabetical order. It considers the case of characters. By default, GoLive performs the sort in ascending order. If desired, you can specify descending order.

**To sort the contents of a table**

1. Select a table or group of cells you want to sort.
2. Choose Special > Table > Sort Table.
3. In the Sort Table dialog box, choose Rows or Columns from the Sort pop-up menu:
   - Choose Rows if you want the contents of one or more columns to appear in numerical and alphabetical order.
   - Choose Columns if you want the contents of one or more rows to appear in numerical and alphabetical order.
4. In the Sort By pop-up menu, do one of the following:
   - If you chose Rows in step 3, choose the primary column with contents that you want to appear in numerical and alphabetical order.
   - If you chose Columns in step 3, choose the primary row with contents that you want to appear in numerical and alphabetical order.
5. From the adjacent pop-up menu, choose Ascending or Descending to specify the sorting order.
6. In the first Then By pop-up menu, do one of the following:
   - If you don't want to specify a secondary column or row to be used in the sort criteria, choose None.
   - If you chose Rows in step 3, choose the secondary column in the table with contents that you want to appear in numerical and alphabetical order.
   - If you chose Columns in step 3, choose the secondary row in the table with contents that you want to appear in numerical and alphabetical order.
7. From the adjacent pop-up menu, choose Ascending or Descending to specify the sorting order.
8 In the second Then By pop-up menu, do one of the following:

- If you don’t want to specify a tertiary column or row to be used in the sort criteria, choose None.
- If you chose Rows in step 3, choose the tertiary column in the table with contents that you want to appear in numerical and alphabetical order.
- If you chose Columns in step 3, choose the tertiary row in the table with contents that you want to appear in numerical and alphabetical order.

9 From the adjacent pop-up menu, choose Ascending or Descending to specify the sorting order.

10 From the pop-up menu at the bottom of the Sort Table dialog box, choose Sort Whole Table to sort the entire table. Choose Sort Without Header to exclude the first row when the table is sorted. If only a portion of a table is selected, you can choose Sort Selection Only to sort only the selection instead of the entire table.
Chapter 12: Formatting text

Formatting text in web pages

Formatting text for the web
You can make text more interesting and easier to read by formatting it, but keep in mind that text can appear different on other computers, depending on the platform, browser, and browser preferences. You can use the View palette to view a simulation of how your document would appear on different platforms and with different browsers.

See also
“Guidelines for controlling font sizes” on page 302
“Previewing web pages” on page 31
“To set view options for page layout” on page 159

Methods of formatting text
You can add form, color, and presentation to text in GoLive by using cascading stylesheets (CSS), HTML text attributes, and sets of HTML text attributes called HTML Styles.

Cascading stylesheets
Cascading stylesheets define text formatting attributes once and instruct web browsers to reuse the definitions whenever text on a page refers to them. (This process reduces the amount of source code that's required for the page, which helps reduce the page size and the amount of time it takes a web browser to display the page.) Stylesheets give you more design options and control than you get with HTML text attributes. It's easier to maintain or change your site's appearance by using stylesheets—when you change a style in a stylesheet, the change is instantly updated in all text that refers to the style in one or more pages.

HTML text attributes
HTML text attributes define formatting that affects only the text to which you apply the attributes. You can use the Type menu, context menu, and the Main toolbar for applying HTML structuring and formatting attributes to text. The Main toolbar includes paragraph formats, such as headers, font attributes, and numbered and bulleted lists. The Type menu provides these options and more, including options for creating and applying font sets. The context menu for selected text provides a quick way to apply all of these items and more.

HTML Styles
HTML Styles define a set of one or more text formatting attributes that affect only the text to which you apply the style. GoLive HTML Styles are sets of HTML text attributes listed the HTML Styles palette. The palette contains several predefined HTML styles and lets you save custom HTML styles either based upon attributes in text or created from scratch in the New Style dialog box. Unlike CSS styles, changing an HTML style does not change the corresponding text attributes that the HTML style was previously applied to.
**Formatting text with both cascading stylesheets and HTML text attributes**

Pages that use cascading stylesheets load in the browser window much faster than pages that are individually formatted with HTML text attributes—but CSS is not supported by older browsers (including Netscape Navigator 3.x or earlier and Internet Explorer 3.x or earlier). To ensure that your text formatting supports older web browsers, you may want to format your text first using particular HTML text attributes, making it look good for older browsers that don't support CSS, and then use the appropriate CSS *element* styles to format the HTML text attributes that you used, making it look great for those browsers that support CSS.

However, some HTML text attributes rely on the font element, which is known to interfere with CSS. HTML text formatting attributes that use the HTML font element include the Font or Size menu in the Type menu, and the Set Font Size or Set Text Color menus in the Main toolbar. Because the font element can interfere with CSS, you should avoid mixing these two formatting methods in a single document.

💡 To avoid browser problems, you can add a browser switch script to your pages that redirects browsers to alternative pages that you've strictly formatted with either HTML text formatting attributes or CSS.

**See also**

“About cascading styles” on page 318

“About HTML element styles” on page 326

“To add a browser-switch script” on page 166

---

**Adding and selecting text**

**Methods of adding text to pages**

You can add text to your page by typing directly in the document window or a container item such as a table, layout grid, or layer; copying text or a table with text from another application and pasting it into the document; or importing text from another application into a table on the page.

**See also**

“Adding text to tables” on page 289

“About layout grids” on page 247

**To type text into a page**

1. Click inside the page, layout text box, table cell, or layer to place the insertion point.
2. Type the text.
To copy text from a web page

1. In the Layout Editor, Source Code Editor, or Preview window, select the text that you want to copy.

2. Do one of the following:
   - Choose Edit > Copy. To place the insertion point, click inside a layout text box, table cell, layer, the current page or another page. Choose Edit > Paste.
   - Hold down Ctrl (Windows) or Option (Mac OS) and drag the selected text to the desired location.

   *You can also drag text from your collection of site assets in the Library palette to your page. (See “Snippets” on page 429 and “Components” on page 427.)*

To select a paragraph of text and the blank lines that enclose it

1. Click anywhere in the paragraph that you want to copy.

2. Click the last element tag that appears in the markup tree bar at the bottom of the document window. (Tags are surrounded by angle brackets; for example <p> or <h1>.)

Formatting paragraphs with HTML text attributes

Using HTML text attributes

GoLive provides a variety of ways to structure paragraphs of text by using HTML text attributes. You can create headings and subheadings, align or indent paragraphs from the left and right margins, or create a numbered or unnumbered list from multiple paragraphs. You can also control the flow of text in paragraphs by suppressing text wrapping to keep text on the same line or adding a line break to control how text breaks around an adjacent object. Then, once you’ve formatted the structure of your paragraphs, you can use CSS element styles to build on the structured text.

*In addition to formatting text in the Layout Editor, you can also format text by using HTML text attributes while working in the Source Code Editor or the source code pane in the document window.*

See also

“About HTML element styles” on page 326
HTML paragraph formats

You can add structure to your text by using HTML paragraph formats which add a blank line before and after the formatted text in most browsers:

**Header** Use for text that describes the topic of the section that follows the heading and to define a heading's level of importance in the heading hierarchy. Most browsers display header text in bold and with a particular character point size, where Header 1 is the largest and Header 6 is the smallest size.

**Address** Use for a block of text that contains a document author's contact information.

**Preformatted** Retains the character spacing, line spacing, and white space in blocks of text. This is useful for retaining the structure of text you've copied in another application, such as columns of text, or presenting source code with its proper spacing. Most browsers display preformatted text in a monospaced font.

**Paragraph** Use when you want to use the default paragraph format in the browser’s preferences.

**None** Use when you want to remove the blank lines before and after a range of text and remove all paragraph formatting.

All HTML paragraph formats can be enhanced with cascading stylesheets and CSS element styles. See “About HTML element styles” on page 326.

To format a heading, address, or preformatted paragraph

1. Click anywhere in the paragraph that you want to format.
2. Choose a format from the Type > Paragraph Format menu or the Paragraph Format pop-up menu on the Main toolbar.
3. To reset a selected paragraph to the default format, choose Type > Paragraph Format > Paragraph.

See also

“About HTML element styles” on page 326

To remove the blank lines that enclose a selected paragraph

Choose Type > Paragraph Format > None.

Besides using the History palette or choosing Edit > Undo, you can use the HTML Styles palette to remove a paragraph format (such as the Address element) from your text. By choosing Clear Paragraph Styles from the palette menu, all styles applied to a selected paragraph are removed.

See also

“About HTML element styles” on page 326
To align or add margins to a paragraph
You can align a paragraph to the left side, center, or right side of the page or container (such as a table cell). You can also add left and right margins to a paragraph without affecting its alignment.

1. Click anywhere in the paragraph that you want to align or indent.
2. Do one of the following:
   - Choose an alignment from the Type > Alignment menu. Choose Default Alignment to remove any existing alignment from the paragraph.
   - Click the Align Left button , the Align Center button , or the Align Right button on the toolbar.
   - To increase or decrease the paragraph's right and left margins, choose Block Quote from the Type > Paragraph Format menu.

   *If you’re using cascading stylesheets, make sure that the type of alignment matches the corresponding CSS style.*

See also
“To reposition an object or group of objects” on page 250

To wrap text around an image or object
You can make paragraphs of text appear to wrap around an image or other object, or create other effects such as a title or caption for a picture, by aligning the image or object within the text. You can also use line break and nobreak elements to control the way that a line of text breaks around an image or object.

1. Place the image or object at the beginning or within a line of text.
2. Select the image or object and choose Left or Right from the Alignment pop-up menu in the Inspector.
3. Drag the image or object up or down to the position that looks best within the paragraph.

Alignment settings
The Alignment pop-up menu in the Inspector for an image or other object provides the following options:

**Default**  Aligns the object with the baseline of text or adjacent objects in the line or the left side of the document window or container.

**Top, Middle, or Bottom**  Aligns the top, center, or bottom of the object with the top, center, bottom, or baseline of text or adjacent objects on the line.

**Left or Right**  Aligns the left or right side of the object with the left or right side of the line, document window, or container. Any text in the line moves to the left of the object. If there are no other objects or text in the line, the object aligns with the left or right side of the window or container.

**Text Top**  Aligns the top of the object with the top of text (the top of the tallest character) in the line.

**Abs Middle, Baseline, or Abs Bottom**  Aligns the center or bottom of the object with the absolute middle (half way between the top and the bottom), text baseline, or absolute bottom (including text descenders below the baseline) of text or objects in the line.
About text flow on web pages
A paragraph of text on a blank web page or inside a container automatically wraps itself to the left and right edges of the browser window or container. When the browser window or container is resized, the text rewraps as needed.

You can control the flow of entire blocks of text by structuring it with paragraph formats, tables, and layers. You can also control the text flow in any particular place by inserting link breaks or enclosing the text with the nobreak element. You can also use line breaks to create additional space before or after paragraphs or objects.

See also
"Page layout techniques” on page 243

To prevent words breaking onto separate lines
1 Select one or more words that you want to always share the same line.
2 Choose Type > Style > Nobreak.

To insert a line break
You can make a line of text break after a particular word and continue to the next line by inserting a line break after the word; the line break's Clear option causes all text that follows the line break to appear below an adjacent image.

† Drag the Line Break icon from the Basic set in the objects toolbox to the document window, or double-click the icon to insert the line break at the insertion point.

The line breaks at the same position regardless of browser window size.
A. Line break marker  B. Line Break icon

Line Break options
The Line Break Inspector provides the following options for the Clear attribute:

All  Moves the text after the line break to the bottom of any object in the line.
Left  Moves the text after the line break to the bottom of a left-aligned object.
Right  Moves the text after the line break to the bottom of a right-aligned object.

Note: When wrapping text around an object inside a layer, the object must be left-aligned or right-aligned for the Clear attribute to work as expected.

To create a list
You can format text as numbered, bulleted, or definition lists, and create hierarchies within the lists.

1 Do one of the following:
   • To format existing text, select the paragraphs.
   • To create a list from scratch, click in the document window where you want the list to begin.

2 Choose a list format from the Type > List menu.
3. To add items to the list, put the insertion point at the end of the text in the last item in the list, and press Enter or Return.

4. To modify a list item’s appearance, do any of the following:

   - To assign a different leading character to the paragraph, choose a list option from the Type > List menu.
   - To increase or decrease the item’s indent, choose Increase List Level or Decrease List Level from the Type > List menu. When you apply the Decrease List Level option to a list item that’s at the first level in a list hierarchy, the item is converted to an unlisted paragraph.

   You can enhance the appearance of a bulleted or numbered list by using cascading stylesheets. First create your list with the Type > List menu, create a CSS element style based upon the <li> tag, and then use properties in the List Item tab of the CSS Editor to modify the list’s appearance. For more information, see “List item properties for CSS” on page 336.

See also

“About HTML element styles” on page 326

“About style properties” on page 330

### Formatting text inline

**About structural and physical text attributes**

Unlike paragraph formats, structural and physical HTML text attributes affect only the text to which you apply them, without affecting the rest of the paragraph. Structural text attributes appear in the upper half of the Type > Style menu and physical text attributes appear in the lower half of the Type > Style menu.

Structural text attributes (also known as HTML content-based styles) let you define selected text in meaningful categories, such as text that needs special emphasis or a strong pronouncement. Web browsers vary in their interpretations for structural attributes as appropriate for their users. For example, one browser may use italics for the Emphasis attribute, while another browser may use boldface. Another browser used by the blind or physically impaired may use a loud voice.

Physical text attributes, such as italic for text that needs special emphasis or bold for text that needs a strong pronouncement, let you define the appearance of selected text without assigning a structural classification.

See also

“To set font properties for a style” on page 332

“About HTML element styles” on page 326

**Structural text attributes**

The following structural text attributes appear in the upper half of the Type > Style menu.

**Emphasis** Emphasizes text. This is the most commonly used style to emphasize text. In most browsers, the selected text appears italicized.

**Strong** Strongly emphasizing text. In most browsers, it makes the selected text bold.
**Quotation** Identifies the selected text as content taken from another source. Most browsers display quotations using a smaller font size and italics.

**Citation** Identifies the text as the title of a cited work. Most browser display the selected text italicized.

**Inserted** Identifies content that has been inserted. Use this attribute to indicate changes between versions of documents. Most browsers display the text underlined.

**Deleted** Identifies content that has been deleted. Use this attribute to indicate changes between versions of documents. Most browsers display the text with strikethrough.

**Sample** Places special emphasis on small character sequences taken out of their normal context. Most browsers display samples using a monospaced font.

**Definition** Defines special terms or phrases, and to assist in creating a page index or glossary. Most browsers display definitions as plain text.

**Variable** Works most often in conjunction with the Code attribute to represent variable names or user-supplied values within the code. Most browsers display variables with an italicized monospaced font.

**Code** Signifies computer source code or other machine-readable content. Most browsers display code using a monospaced, teletype-style font such as Courier.

**Keyboard** Signifies text that is typed on the keyboard. Most browsers display keyboard entries using a monospaced font.

---

**Physical text attributes**

The following physical text attributes appear in the lower half of the Type > Style menu:

- **Note:** Older browsers may not support physical attributes other than plain, bold, and italic.

- **Plain** Uses the basic format for standard HTML text. It can be overridden by stylesheets.

- **Italic** Instructs browsers to use an italic or oblique typeface. If the typeface is not available, highlighting, reverse video, or underlining may be used.

- **Bold** Instructs browsers to use a bold typeface. If that is not available, browsers might use something like reverse video or underlining.

- **Underline** Instructs browsers to underline text, spaces, and punctuation. (This attribute may be removed from the next version of HTML.)

- **Strikeout** Instructs browsers to put a line through the middle of text. (This attribute may be removed from the next version of HTML.)

- **Superscript** Instructs browsers to display text one-half of a character higher than the rest of the text.

- **Subscript** Instructs browsers to display text one-half of a character lower than the rest of the text.

- **Teletype (tty)** Instructs browsers to display text in a monospaced typeface.

- **Blink** Uses a Netscape extension for reversing the background and foreground colors of text to make text appear to blink on and off.
To apply an HTML physical or structural attribute to text

1. Do one of the following:
   - To format existing text, select the text.
   - To format text you are about to type, click in the document window to place an insertion point.

2. Choose an option from the Type > Style menu.

To remove all HTML physical or structural attributes from selected text

❖ Choose Type > Style > None.

To remove character or paragraph styles from selected text

1. Choose Type > Clear Styles.

2. Choose one or both of the following options:
   - Clear Character Styles to remove character styles, such as color, font, or physical attributes, from the selected text.
   - Clear Paragraph Styles to remove paragraph styles, such as address, preformatted, or a heading, from the selected text.

3. Click OK.

Changing fonts

Using fonts in web pages

If a web page doesn't specify fonts, web browsers normally display text in the page with a default font that's specified by the browser. You can control the font that the browser uses by applying a font set to your text. When displaying text formatted with a font set, the web browser attempts to display the text using the first font listed in the font set, then the second font in the set, and so on. If none of the fonts in the set are installed on the viewer's computer, the browser displays the text using its default font.

To apply a font or font set by using HTML text attributes

The Type > Font menu lists the font sets and preferred fonts that are specified in the Font Editor, and also any font sets that are saved to the current site window. Font sets that are specified in the Font Editor appear at the top of the Font menu; preferred fonts and font sets that are saved to the current site appear at the bottom of the menu.

1. Do one of the following:
   - To format existing text, select the text.
   - To format text you are about to type, click in the document window to place an insertion point.

2. Choose a font set from the Type > Font menu. Choose None if you want web browsers to use their default fonts.

See also

“To set font properties for a style” on page 332
To create a font set
1 Choose Type > Font > Edit.
2 In the Font Editor, click the Default Font Sets tab.
3 Do one of the following:
   • To create a blank font set, click the Create New Font Family button.
   • To create a copy of a font set, hold down the Create New Font Family button and choose the font set.
4 To add fonts to the new font set, click the Add Font button, and then choose a font from the menu.
5 Use the Up button or the Down button to move a selected font in the list. (The order that the fonts appear in the list determines the order that the web browser attempts to use them.)
6 Click OK.

To edit a font set
1 Choose Type > Font > Edit.
2 In the Font Editor, select the Default Font Sets tab.
3 Do any of the following:
   • To add a new font, select the font set or a font in the set, click the Add Font button, and choose a font name.
   • To change the name of a selected font or font set, click the name, and then enter a new name in the text box.
   • To change the order in which one or more fonts, or font sets appear in the Font Editor, select the items and click the Up button or the Down button.
   • To remove a selected font set or fonts from the list, click the Delete button.
4 Click OK.

To edit the Preferred Fonts list
The Preferred Fonts tab in the Font Editor lists the fonts that appear in the Type > Font menu. You can add or remove fonts from the list.
1 Choose Type > Font > Edit.
2 In the Font Editor, select the Preferred Fonts tab.
3 Do any of the following:
   • To add a new font, click the Add Font button, and choose a font name.
   • To change the name of a selected font, click the name, enter a new name in the text box.
   • To remove a selected font from the list, click the Delete button.
4 Click OK.
Changing the size and color of text

Guidelines for controlling font sizes
Font sizes are relative to the font size preferences set in web browsers. In addition, fonts in Windows are about one step larger than in Mac OS because of a difference in pixel resolution between platforms. To make sure that your page layout can handle a range of font sizes across platforms, here are some guidelines to follow when designing it:

- You can control the font size across platforms by using CSS styles. When specifying the font size for a style in a cascading stylesheet, use pixels rather than points. Point sizes will vary on platforms due to pixel resolution, whereas pixels remain fixed. In the Font tab of the CSS Editor, choose Pixel from the Size pop-up menu.

- Before publishing your page on the web, preview it at a variety of font sizes on a variety of platforms and browsers. You can also use the View palette to view a simulated preview of your page in a web browser for Windows or Mac OS.

- Don't use HTML heading elements (Header 1 to Header 6 in the Paragraph Format menu) with relative font sizes. The relative font size can cause the heading to wrap and adversely affect your page layout.

- Use layout text boxes to control the amount of space that appears between text and an image. When text appears at a smaller or larger font size than what you used for the page layout, the image moves up and down as the text resizes.

- Keep in mind that a GoLive layout text box doesn't decrease in size when the text appears at a smaller font size than what you used for the page layout. As a result, extra space can appear between the text in the box and objects below the box. However, a layout text box does increase in size to accommodate the text when the text appears at a larger font size than what you used for the page layout. When the box increases in size, objects below the box are moved downward on the page. (However, by using pixels for the font size in a CSS style, the font size will display the same on all platforms, and therefore the size of the layout text box need not change.)

- Keep in mind that the default font size displayed in the Layout Editor does not necessarily reflect the actual size of text in a web browser, and neither does changing the default font size in the Font preferences affect the actual font size of the page. (The Font preferences are for setting the GoLive display fonts only.)

See also
“To set view options for page layout” on page 159
“To set font properties for a style” on page 332

To apply a relative font size to text
Text formatted with a relative font size appears at a size related to the size specified in the web browser's preferences; most browsers are configured to display text at 12 points by default. By applying a relative font size to text, you can make the text appear the same size as, smaller than, or larger than the text size set by the browsers, or at a smaller or larger size relative to the default size or the base font size of the document.
Note: The relative size attributes are part of the font element, which is known to interfere with cascading stylesheets in the same page; therefore it's safer not to use the font element and CSS in the same page.

1 Do one of the following:
   • To format existing text, select the text.
   • To format text you are about to type, click in the document window to place an insertion point.

2 Choose a size from the Type > Size menu or the Font Size pop-up menu on the toolbar:
   • Choose a size between 1 and 7 to display a size relative to the browser's preferences. Size 3 displays text at the default font size set in the browser’s preferences, sizes 1 and 2 display text at a smaller size, and sizes 4 through 7 display text at a larger size.
   • Choose a size between +1 and +7 to display text at a size that's larger than the default or base font size of the document (+1 displays text one font size larger and so on).
   • Choose a size between -1 and -7 to display text at a size that's smaller than the default or base font size of the document (-1 displays text one font size smaller and so on).

To add color to text
You can add color to selected text without affecting the page's default text color (as specified in the Page Inspector) by using the Set Color menu in the Main toolbar, the Swatches palette, or the Color palette.

Note: If your page uses cascading stylesheets, you should use a CSS style to add color to text instead of these features. These features use the font element which can interfere with cascading stylesheets.

1 Do one of the following:
   • To format existing text, select the text.
   • To format text you are about to type, click in the document window to place an insertion point.

2 Do one of the following:
   • Click the lower right corner of the Set Text Color icon on the toolbar and select a color from the swatches that appear. (The swatches displayed reflect the current settings in the Swatches palette.)
   • Click the Set Text Color icon on the toolbar and use one of the color sliders to select a color from the Color palette. (Choose Only Web Colors from the Color palette menu to select only web safe colors). You can also click a color in the Recently Used Colors list.
   • Select a color in the Swatches palette.

GoLive applies the color to the selected text. If you selected text at the end of a line, the color remains in effect after you press Return or Enter and continue typing.

💡 You can also color selected text by dragging a color from the Colors tab in the site window to the selection in the page.

See also
“Site colors” on page 430
To remove color from selected text
❖ Select the text, and then do one of the following:
  • Choose Type > Remove Color.
  • Click the lower right corner of the Set Text Color icon on the toolbar, and choose Remove Color.

Using HTML text styles

Saving and reusing HTML text styles
You can use the HTML Styles palette to save custom sets of text attributes which you can then apply to text in one or more pages or sites, and share with other GoLive users. HTML styles can be designed to affect either an entire paragraph or only the characters you specify, and either supplement or replace the current formatting in the text.

An HTML style can apply several HTML attributes to text at once.

See also
“About cascading stylesheets” on page 318

Using the HTML Styles palette
Symbols in the left column indicate the HTML style type—whether the HTML style will be applied to inline text or an entire paragraph and whether the HTML style will add to or replace the text. The preview area at the bottom of the palette shows you the appearance of the current HTML style as you edit it.

Symbols indicate whether an HTML style will add to or replace a paragraph or an inline text attribute.
A. Replaces selected paragraph  B. Adds to selected paragraph  C. Adds to selected inline text
See also
“Displaying palettes and tabs” on page 27

To create a new HTML style

1. If you want to base the new HTML style on text that’s already formatted, select the formatted text in the page.
2. Choose Window > HTML Styles.
3. In the HTML Styles palette, click the New Style button.
4. In the New Style dialog box, enter a descriptive name for the HTML style in the Name text box.
5. To specify the text formatting attributes for the new HTML style, do one of the following:
   - Click the Basic tab and choose formatting options such as Font, Size, or Color.
   - Click the Advanced tab and click the New Tag button to add a tag to the top of the scrolling list. For the selected tag, enter a name, attribute, and its value in the text boxes below the list.
6. Click the Apply As Inline button or the Apply As Paragraph button for the HTML style type. Inline text styles apply to selected text only and paragraph styles apply to the entire paragraph regardless of what is selected in the paragraph.

Note: The heading, address, preformatted, and align attributes can only be saved as paragraph styles, not as inline text styles. Clicking the Inline Text button will cause GoLive to reset the attributes to “Paragraph.”

7. Choose one of the following from the Apply Mode menu:
   - Add Supplements the text’s existing formatting with the attributes defined by the HTML style.
   - Replace Removes the text’s current formatting and applies the attributes defined by the HTML style.
8. Click OK.

To edit an HTML style

1. Select the HTML style in the HTML Styles palette.
2. Do any of the following:
   - To replace the style’s formatting attributes with the formatting attributes of text that’s selected on the page, click the Capture button.
   - To change the style, click the Edit Style button. Modify your selections as desired and then click OK. The preview pane at the bottom of the Edit Style dialog box shows you the appearance of the current HTML style as you edit it.

To remove an HTML style from the HTML Styles palette

❖ In the HTML Styles palette, select the HTML style that you want to remove and click the Delete button.
To export HTML styles
Predefined HTML styles that come with GoLive are stored in an html.xml file in the Adobe GoLive application's Settings > Styles folder. You can export the current HTML styles from the HTML Styles palette to a separate XML file, which you can share with others or store for back-up.

1. In the HTML Styles palette, click the Export button.
2. Enter a file name, select a file location, and click Save.

To import a set of HTML styles
When you import a set of HTML styles from an XML file into the HTML Styles palette, all HTML styles in the palette are overwritten by the imported HTML styles.

1. If you want to retain the current set of HTML styles that appear in the HTML Styles palette, export them to an XML file.
2. Do one of the following:
   • In the HTML Styles palette, click the Import button. Select the XML file containing the set of HTML styles that you want to import, and click Open.
   • Drag the XML file containing the set of HTML styles that you want to import from your desktop to the HTML Styles palette.

To apply HTML styles to text
Each style in the HTML Styles palette displays the inline text style icon or the paragraph style icon to indicate whether the style affects the entire paragraph or only the selected text. If the style supplements the text's existing formatting, a plus sign (+) appears next to the style's icon; if the style replaces the text's existing formatting, a double-sided arrow appears next to the style's icon.

1. Do one of the following:
   • To apply an inline HTML style, select the text you want to format.
   • To apply a paragraph HTML style, click anywhere in the paragraph that you want to format.
2. In the HTML Styles palette, do any of the following to apply a style:
   • Drag an inline HTML style from the palette to selected text on a page.
   • Double-click an HTML style.
   • Select an HTML style and click the Apply Styles button.

To remove all HTML styles from selected text
❖ From the HTML Styles palette menu, choose Clear Inline Styles or Clear Paragraph Styles.

Note: To remove an HTML style you've recently applied, you can also use the History palette or choose Edit > Undo Apply Style.

See also
“To undo, redo, and revert actions” on page 36
To replace HTML or CSS styles
GoLive lets you convert styles in multiple files simultaneously. You can replace HTML styles with CSS styles, and vice versa.

1 Choose Special > Convert > Styles.
2 From the Work On menu, select a group of files. Then select specific files in the list below.
3 Click Collect Styles.
4 From a style's Replacement menu, select a different style. (Also select Keep Attributes if you want to retain them.)

See also
“About cascading stylesheets” on page 318

Spelling

To check the spelling in a page or site
You can check the spelling of a single page or an entire site.

1 Select the Layout Editor tab, Source tab, or the site window.
2 Choose Edit > Check Spelling.
3 Set spelling checker options:
   • Choose a spelling checker language from the Language menu.
   • Select From Top to start checking at the top of an open page rather than at the insertion point.
   • Expand More Options and specify conditions for the search, such as to ignore numbers.
4 To check the spelling in multiple files, select Add Files from the Work On menu.
5 Click Start.
GoLive displays a suggestion for the first questionable word in the text box.

6 To change the questionable word, do one of the following:
   • Click Change to use the first suggestion.
   • Double-click another suggestion in the Suggestions list box.
   • Edit the suggestion in the text box, and then click Change.
7 To accept the questionable word, click one of the following:
   Ignore To allow a single occurrence of the word.
   Ignore All To allow the questionable word for the current session. GoLive ignores all occurrences of the word in the page or site.
   Learn To add the questionable word to your personal dictionary. GoLive recognizes the word as correct in the future.
8 To delete a questionable word from the page, click Delete.
9 If you are checking a site, click Next File to quit checking the current page and start checking the next page in the site.
10 To stop checking at any time, click Stop.

To edit a personal dictionary
1 Choose Edit > Preferences (Windows) or GoLive > Preferences (Mac OS) and select Spell Checker from the list on the left.
2 Choose a language set of spelling rules from the Personal Dictionary pop-up menu on the right.
3 Edit the dictionary by doing any of the following:
   • To edit a word in the list, select it and change it in the text box below the scrolling box, and then press Enter.
   • To add a word, click the New Word button, type the word in the text box, and press Enter.
   • To delete a word, select it in the list, and click the Delete button.
4 Click OK.
You can create and edit a personal dictionary for each language that you have installed.

Searching text and HTML source code

Searching for words or HTML strings
Using the GoLive search tools, you can find and replace text or strings of HTML in any file throughout your website. You can search multiple files at a time, specify parameters for narrowing the search, and use wildcards in a search. You can also use GoLive search tools to search for HTML elements with special conditions, search for files in a site, and create and save extensive site queries based on a search.

The Find command lets you specify the text to search for, while the Find Selection command finds the next instance of text that matches text you select in the document window.

To find and replace text or HTML in the current document
You can use the Find & Replace feature in the Layout Editor, Outline Editor, or Source Code Editor to search for text or strings of HTML code in the current document.

1 Choose Edit > Find > Find Text.
2 Do one of the following:
   • Type or paste text or HTML into the Find text box.
   • Select text or HTML in the document window, and drag it into the Find text box.
   • Select a group of files by using the Work On menu.
   • Choose an item from a saved search from the Find Text window menu.
3 Select options to match the case, look for entire words that are not embedded within other words, start searching from the top of the page, wrap around to the beginning of the search, or search for text using wildcards (regular expressions).

Note: Do not use the Regular Expression option unless you understand wildcard searching. This powerful option can cause unexpected results, especially if you plan to search and replace multiple items.

4 If you're searching a site, select a search mode:
   • To search text on web pages, select Layout Search Mode.
   • To search source code, select Source Search Mode.

5 If you want to replace the found text, click the triangle to expand the Replace text box, and type in replacement text.

6 Click Find. GoLive highlights the first match, if any.

7 Do one of the following:
   • To find the next occurrence of the text, click Find Next.
   • To replace the found text, click Replace.
   • To replace the text and find the next occurrence, click Replace & Next.
   • To automatically replace all instances of the text in the document, click Replace All.

See also
“To use wildcards in a search” on page 311

**To search for the next instance of selected text**

❖ Make sure that you select your desired text and then choose Edit > Find > Find Selection.

GoLive starts looking for the text from the current selection and highlights the next occurrence of the text using the current settings in the Find window.
You can also find and replace text without reopening or moving the Find window to the foreground by choosing Edit > Find > Replace or choosing Edit > Find > Replace & Find Next. These commands are only available if the item searched for was found and is still selected.

To find and replace text or HTML in sites or files
You can search and replace text or strings of HTML in multiple files in any open site, or in multiple files in unopen sites.

Note: If you plan to do a global search and replace in multiple files, you should be sure to make a backup of your files and site, especially if you are using wildcard characters.

1 Choose Edit > Find > Find Text.
2 Type the text or HTML code in the Find text box and the Replace text box, and then select search options.
3 Choose a search mode. Choose Layout Search Mode to search the text on your web pages, or choose Source Search Mode to search only the text in your pages’ source code.
4 Click the Work On menu and do one of the following:
   • To search the entirety of a currently open site, choose [site name] > The Whole Site from the menu.
   • To search the files in a specific tab of a currently open site, choose [site name] > [site tab] from the menu, or choose the appropriate file from Collections or Queries. You can also drag a file from the site window to the Find Text dialog box.
   • To search a file that is selected in the site window, choose The Site Selection. You can also drag a file from the site window to the Find Text dialog box.

Note: You can use these methods to search files from any open site. First, you must open any site that you want to search; then choose the appropriate one, as described above.

   • To search files in unopen sites, choose Add Files. Navigate to and select the files that you want to search; then click Open. GoLive adds the selected files to the search list.

5 To exclude items from the search, deselect them by clicking in the corresponding box to remove the check.

Drag files into the Find window to add them to the search.
6 Select options to match the case, look for entire words that are not embedded within other words, start searching from the top of the page, wrap around to the beginning of the search, or search for text using wildcards (regular expressions).

**Note:** Do not use the Regular Expression option unless you understand wildcard searching. This powerful option can cause unexpected results, especially if you plan to search and replace multiple items.

7 Click Find.

GoLive shows you the first file found containing matching text and opens the file.

8 Do one of the following:

- To find or view the next match in the same or next document, click Find Next.
- To find or view all matches, click Find All. In the Result window, all files with matches are marked by a number appearing in the Hits column. Double-click a file with a hit count to open the file and show the first match highlighted.

**See also**

“Locating elements with the Find Code Elements dialog box” on page 596

“To use wildcards in a search” on page 311

**To save search results for use in another search**

- To search within the result set, click Use Result in the Results window. You can remove files from the result set by selecting them and clicking Remove.
- To save the results as a collection in the currently open site, click Save Collection in the Results window (a site must be open for the Save Collection option to be available). You can remove files from the Results window by clicking Remove before saving the collection. Saved collections are displayed in the Collections tab of the Site window.

**See also**

“Collections” on page 435

**To use wildcards in a search**

When you select Regular Expression in the Find Text window, you activate wildcard searching. GoLive makes wildcard searching easier by providing default wildcard patterns.

1 In the Find Text window, do either of the following:

- From the window menu, choose Saved Searches > Regular Expressions > [wildcard pattern].
- Type a search string in the text box. (See the wildcard search options in the table below.)

2 Select Regular Expression.

3 Click Find.
Wildcard patterns appear in the Saved Searches menu.

**Guidelines for wildcard searching**

Use these guidelines when wildcard searching:

- Characters that are used to specify wildcard options, such as “?”, “\”, “[”, and “]”, must be preceded by a backslash. For example, “\?” finds any question mark.

- The caret serves as a wildcard character only when it precedes a range of characters, as in “\[^A-Z\]”.

- The dash does not act as a wildcard character if it precedes a range of characters, as in “\[-ABC\]” or “[^ABC]”. At any other location, it acts as a wildcard character indicating a “from…to” relationship.

**Wildcard search options**

<table>
<thead>
<tr>
<th>Search String</th>
<th>Finds</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adobe</td>
<td>GoLive</td>
</tr>
<tr>
<td>m(i</td>
<td>a)ll</td>
</tr>
<tr>
<td>Adobe(GoLive)?</td>
<td>&quot;GoLive&quot; if the latter exists, else &quot;Adobe&quot;</td>
</tr>
<tr>
<td>&lt;/?HTML&gt;</td>
<td>&quot;&lt;HTML&gt;&quot; and &quot;&lt;/HTML&gt;&quot;</td>
</tr>
<tr>
<td>Yes+</td>
<td>The word &quot;Yes&quot;, containing any number of successive &quot;e&quot; characters, such as &quot;Yes&quot;, &quot;Yees&quot;, &quot;Yeets&quot;, etc.</td>
</tr>
<tr>
<td>Michael J[a-z]*</td>
<td>Any string beginning with &quot;Michael J&quot;, followed by any number of lowercase letters, such as &quot;Michael Jones&quot;, &quot;Michael Jamrosy&quot;, and &quot;Michael Jordan&quot;</td>
</tr>
<tr>
<td>Search String</td>
<td>Finds</td>
</tr>
<tr>
<td>---------------</td>
<td>-------</td>
</tr>
<tr>
<td>&lt;H[1-6]&gt;</td>
<td>HTML headings H1 through H6, including &quot;H1&quot;, &quot;H2&quot;, &quot;H3&quot;, etc.</td>
</tr>
<tr>
<td>&lt;[a-zA-Z][a-zA-Z0-9-]*&gt;</td>
<td>Any start tag that has no attributes, such as &quot;&lt;P&gt;&quot;, &quot;&lt;b&gt;&quot;, &quot;&lt;H2&gt;&quot;, &quot;&lt;Image&gt;&quot;</td>
</tr>
<tr>
<td>&lt;[a-zA-Z][a-zA-Z0-9-]<em>[^&gt;]</em>&gt;</td>
<td>Any start tag, including those with attributes, such as &quot;&lt;image width=20&gt;&quot;</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Wildcard Option</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Wildcards for Single Characters</td>
<td></td>
</tr>
<tr>
<td>.</td>
<td>Finds any single character</td>
</tr>
<tr>
<td>[ ]</td>
<td>Finds any one of the characters in square brackets. For example: &quot;[0123456789]&quot; finds any digit. &quot;[a-zA-Z]&quot; finds any alphabetical character.</td>
</tr>
<tr>
<td>[^]</td>
<td>Finds any one character in a range enclosed in square brackets. For example: &quot;[0-9]&quot; finds any digit.</td>
</tr>
<tr>
<td>^</td>
<td>Finds any character other than the characters following the caret symbol (^) in the brackets. For example: &quot;[^ab]&quot; finds any character, except for &quot;a&quot; and &quot;b&quot;</td>
</tr>
<tr>
<td>[^0-9]</td>
<td>Finds any digit.</td>
</tr>
<tr>
<td>[^a-zA-Z]</td>
<td>Finds any character other than a digit.</td>
</tr>
<tr>
<td>[a-zA-Z]</td>
<td>Finds any character.</td>
</tr>
<tr>
<td>[a-zA-Z]+</td>
<td>Finds any word.</td>
</tr>
<tr>
<td>[^a-zA-Z]</td>
<td>Finds any character other than alphabetical characters.</td>
</tr>
<tr>
<td>[SPACE+\t]</td>
<td>Finds any white space (SPACE = space key).</td>
</tr>
<tr>
<td>[^SPACE\t]</td>
<td>Finds any character other than a white space.</td>
</tr>
<tr>
<td>[^\r]</td>
<td>Finds any line break (in HTML source code).</td>
</tr>
<tr>
<td>[^\t]</td>
<td>Finds any tab character, such as indentations in HTML source code.</td>
</tr>
<tr>
<td>Wildcard Option</td>
<td>Action</td>
</tr>
<tr>
<td>-----------------</td>
<td>--------</td>
</tr>
<tr>
<td><code>\x00 - \xff</code></td>
<td>Finds any character, as identified by its ASCII value. For example: “\x43” finds “C”.</td>
</tr>
</tbody>
</table>

**Quantifiers**

| ?                | The question mark makes the preceding character or string (enclosed in parentheses) optional. For example: “(Adobe)?GoLive” finds “GoLive” and “Adobe GoLive”. |
| +                | The plus sign finds one or more occurrences of the preceding character or search string in a row. For example: “ba+” finds “ba”, “baa”, “baaa”, etc. |
| *                | The star is equivalent to a “?” and a “+”, and can result in a “not found” message if no occurrences are found. The character preceding the “*” is optional. For example: “ba*” finds “b”, “ba”, “baa”, etc. |

**Other Search String Modifiers**

| | The vertical bar serves as a separator for alternative search strings. For example: “Adobe|GoLive|4.0” finds “Adobe”, “GoLive”, and “4.0”. |
| ( )             | Parentheses enclose a search string that serves as a definition for quantifiers. For more information, see the description of “?” above. |
| ^               | In source mode, the caret finds the start of a line. In the Layout Editor, it finds the beginning of a paragraph. |
| $               | In source mode, the dollar sign finds the end of a line. In the Layout Editor, it finds the end of a paragraph. |
Using back-references in wildcard searches

Back-references let you replace a selection with part of the wildcard string you entered in the Find text box. A back-reference consists of a backslash character followed by a number, for example “\1”, “\2”, and so on. The number refers to a subexpression (enclosed in parentheses) of the wildcard search pattern in the Find text box:

- “\1” refers to the first subexpression in the wildcard search pattern. This subexpression starts at the first opening bracket from the left and ends with the complementary closing bracket.
- “\2” refers to the second subexpression, which starts at the second opening bracket from the left and ends with the complementary closing bracket.

When you click the Replace button, each selection is replaced with the part of the matching text that has been recognized by the subexpression that the back-reference refers to.

For example, you enter the wildcard search pattern ((Adobe)?GoLive) in the Find text box to find any occurrence of “GoLive” or “Adobe GoLive”. The “?” character makes the “Adobe” enclosed in the second pair of parentheses optional. If you enter the back-reference \1 CS in the Replace text box, the found text is replaced with the contents of the first pair of parentheses plus the letters CS. If the match is “Adobe GoLive”, the result is Adobe GoLive CS. If the match is “GoLive”, the result is GoLive CS.

Non-roman characters

Non-roman character sets

Your ability to switch between roman and non-roman character sets depends on your operating system:

- In Windows versions earlier than Windows 2000, you cannot directly create non-roman (double-byte) web pages by using a roman (single-byte) operating system. However, you can import double-byte HTML files created with another operating system. You can then view the HTML source code in GoLive, although the double-byte text doesn’t display correctly in the Layout Editor or Preview. Microsoft Internet Explorer 4.0 and later can display double-byte scripts, so you can preview double-byte files using the Show In Browser command in GoLive.
- The Windows 2000 and XP operating systems with Microsoft Internet Explorer 6.0 or later let you view and create double-byte content without the entire native script operating system. You can custom install the Language Pack for the script you need. See your system documentation for further information.
- Mac OS 9.1 and later include Multilingual Internet Access as an optional installation. This software lets GoLive display double-byte scripts, even without the native operating system. With the appropriate Language Kit custom installed, you can create and edit non-roman text. See your system documentation for further information.

Double-byte text in GoLive

By default, GoLive uses Multilingual UTF-8 encoding, which supports both roman and double-byte languages. To create content in a double-byte language, however, you also need the appropriate system fonts.

In the File > Document Encoding submenu, you can choose other encoding options, such as Japanese and Multilingual UTF-16. You can add to these menu options in the Encodings preferences.
To activate encodings for language scripts
In the Encodings preferences, you can select the default language script and activate additional scripts so they appear in the File > Document Encoding menu.

1. Choose Edit > Preferences (Windows) or GoLive > Preferences (Mac OS), and select Encodings from the list on the left.
2. In the right pane of the dialog box, select the desired language encoding option to activate it.
3. To make an encoding option the default, select it in the Default column. The name of the default selection appears in boldface and underlined.
4. Select Use Charset Info to include the encoding and character set information in the Content attribute of the Meta element. When this option is selected, GoLive tries to recognize the encoding based on the characters used. Deselect this option to eliminate language information from the HTML page head section.
5. In the Scanning Limit Characters text box, enter the number of bytes that you want GoLive to search in order to find encoding and character set information when it opens a file. Deselect Use Charset Info to turn off this option automatically.

To create double-byte language pages
1. If you are creating text in a non-Western language, make sure that you have installed the appropriate double-byte script system software and fonts.
2. Open a new document window.
3. Choose File > Document Encoding, and choose the appropriate language encoding option. Be sure that it is equivalent to the internal operating system encoding—for example, Japanese (Shift JIS)—to add that meta information to the head section.
4. Proceed to add text to your page in GoLive.

To import foreign-encoded text files
Before importing foreign-language files or text files from other platforms, you need to know the type of encoding they were written with. If the text was saved with an encoding not recognized by your operating system, it won't display properly. However, the HTML code is still valid. To insert foreign script, you must display your GoLive document in the Source Code Editor, and paste the double-byte text into it.

1. Open a new document window.
2. Choose File > Document Encoding, and choose the language encoding of the file that you want to import. This inserts the encoding information in the head section of the page. (For information on adding language encodings to the File > Document Encoding menu, see “To activate encodings for language scripts” on page 316.)
3. Copy the text from the file that you want to import.
4. Return to GoLive, and display your GoLive document in the Source Code Editor.
5. Paste the copied text between the <body> and </body> tags. Make sure that you don't type over any of the HTML tags.
If your text contains characters that are used in HTML syntax, such as “<”, “>”, and “&”, you must use the proper HTML notation for special characters, such as “&lt;”, “&gt;”, and “&amp;”; otherwise, GoLive interprets them as HTML tags when it reads the text-only file.

6 Choose File > Save As to save the page with the .html extension after the file name.

The text will not display properly without the necessary operating system and fonts. To preview the page, you must use a web browser with the correct encoding running on the necessary operating system.
Chapter 13: Cascading stylesheets

Understanding cascading stylesheets

About cascading stylesheets

Cascading stylesheets (CSS) make it easy to update text properties and other attributes throughout a website. If a CSS style needs to be updated, you simply edit the style and all content that hosts the style will automatically reflect the new properties. With stylesheets you can set text size to display more consistently across different platforms and control the position of content on a page with pixel-level precision. An external stylesheet can be shared by an entire site, giving your pages a consistent presence and enabling you to update the site's styles with a single file.

The GoLive CSS Editor lets you create CSS styles, edit style properties, reference or create external stylesheets, and preview how some style properties may appear. Sample stylesheets are available in the New dialog box.

The CSS tab in the Site window lists external stylesheets, classes, and identifiers used in the site. For more information, see “About the site window” on page 202.

💡 You can use CSS layout objects to create layouts that change in size to accommodate a viewer's browser settings. For more information, see “About CSS layout objects” on page 245.

Some viewers may not be able to see CSS style properties if their browser doesn't support CSS, the browser's CSS support has been turned off, or the browser is set to override page styles with a CSS file supplied by the viewer. Web browser support for CSS varies greatly between both browser vendors and browser versions.

About the GoLive CSS workflow

In GoLive, you typically build cascading stylesheets with the following workflow:

1. Add styles, create links, or create a new stylesheet.

   Use the CSS Editor to add CSS styles to a web page, link to an external stylesheet or create a new external stylesheet. You can also import CSS styles from a different web page or from an external stylesheet, or create a new external stylesheet from one of the stylesheet samples in the New dialog box.

   ![Internal stylesheet in the CSS Editor.
   A. External stylesheet reference  B. List of internal styles](image)
2. Define the properties of each CSS style.

Use the CSS Editor to define the properties of each CSS style. Properties that you can define include font sets, text size, border attributes, list attributes, background attributes, and absolute position coordinates.

![Define style properties in the CSS Editor. A. Selected style  B. Selected style’s properties](image)

3. Create links to an external stylesheet.

If you’re using an external stylesheet, you can link to it from an individual web page with the CSS Editor window menu or from the CSS Editor, or link multiple web pages to it with the CSS palette and the site window.

- Use the In & Out Links palette with the external stylesheets listed in the CSS tab of the Site window to determine where stylesheets are used in the site, and to associate them with new pages. For more information, see “Using the In & Out Links palette to view links” on page 232.

4. Apply styles.

Apply class or ID styles to text and other items. You must manually apply class styles to selections in your page with the CSS palette, and apply ID styles with the Visual Tag Editor or the Source Code Editor. Element and inline styles, in contrast, are automatically applied to HTML tags in your web page.

- You can also apply class styles with the inline CSS Style preview or Type > CSS menu options.

5. Modify styles.

You can continue to modify any style’s properties with the CSS Editor. All content that uses the style will automatically reflect the changes.

![Apply class styles to selections with the CSS palette.](image)
Creating and viewing stylesheets

Choosing between internal and external stylesheets
When you create a stylesheet, first determine whether it should be internal or external. An internal stylesheet is written into the head section of a web page and is typically used if styles are used on only one page. An external stylesheet exists as a separate file, which is useful if you want multiple pages to share the same styles.

You can use both an internal stylesheet and external stylesheets in a single web page. You can also import styles from an external stylesheet into an internal stylesheet, or export internal stylesheets to an external stylesheet file.

With CSS, stylesheets cascade—in other words, several external stylesheets, in addition to an internal stylesheet, may define the properties of a single page and override one another according to certain rules of precedence. When several stylesheets apply their formatting rules to a page, conflicts may arise. These conflicts are resolved by assigning a level of precedence to each style rule. Internal stylesheets will override a rule in an external stylesheet, and external stylesheets are assigned a level of precedence relative to other sheets. By default, the web page's stylesheet overrides the browser's default values.

*Note:* Except for their title bars, internal and external CSS Editors appear identical. An internal CSS Editor displays the web page's file name in the title bar. An external CSS Editor displays the external stylesheet's file name in the title bar.

To display the CSS Editor
1. Do one of the following:
   - Open a page and click the Open CSS Editor button in the upper right corner.
   - Open an external stylesheet that is named with the .css file extension.
   - Double-click a CSS file in the CSS tab of the site window.
2. To change the display on the right side of the CSS Editor in the CSS Definitions tab, do one of the following in the Name column:
   - To display the Create buttons, deselect all styles.
   - To display style properties, select a style.
   - To display external stylesheet properties (though not the style properties within it), select an external stylesheet.

   *Select Show These Buttons At Top to also display the buttons on the right side of the CSS Editor at the top of the CSS Editor.*
3. To display the stylesheet source code, click the Source tab in the CSS Editor, or click the Show Split Source button at the lower left of the CSS Editor to view the source simultaneously with the CSS definitions.
4. To change the CSS source code color display, choose a theme from the Theme menu in the Source tab.

See also
“Source preferences” on page 578
To edit the styles listed in the Create New CSS Statements menu in the CSS Editor

1 Click the Create New CSS Statements button in the CSS Definitions tab of the CSS Editor, and choose New Style > Edit Style Examples.

2 In the exampleStyles.css CSS Editor window, do one of the following:
   • To edit an existing style, select a style to edit under the Name column.
   • To add a style to the list, use any method for creating a new style.

3 Edit the style properties in the exampleStyles.css CSS Editor window.

4 When you are finished editing styles, choose File > Save and close the exampleStyles.css CSS Editor window.

See also

“Types of CSS styles” on page 325

“About style properties” on page 330

View options for the CSS Editor

View options in the CSS Editor window menu include the following:

Show Split Style Preview Displays a preview of a selected style’s effect in the lower pane of the CSS Editor.

Show Split Source Displays the CSS source code in the lower pane of the CSS Editor.

Show Info Column Shows property types for a style.

Folder For Sections Separates the CSS Definitions tab of the CSS Editor into an Internal folder that lists internal styles and an External folder that lists referenced external stylesheets.

Show Statement Filter Displays the Search for CSS Statements menu.

Sort Statements Displays styles in alphabetical order in the CSS Definitions tab.

Show Properties In List Displays properties for a style.

To create an internal stylesheet

1 Click the Open CSS Editor button in the upper right corner of the Layout Editor.

2 Add styles to the stylesheet by doing any of the following:
   • Create new styles.
   • Reference an external stylesheet.
   • Import styles from an external stylesheet.

See also

“Types of CSS styles” on page 325

“To import styles from an external stylesheet” on page 325

“To reference an external stylesheet from web pages” on page 323
To create an external stylesheet

1 Do one of the following:
   - To create a new external stylesheet, choose File > New, and then choose Web > CSS. Choose a preconfigured stylesheet, or choose basic.css to open a simple stylesheet. The external CSS Editor appears.
   - To create an external stylesheet based upon a page's internal stylesheet, open the page, and choose File > Export > Internal Style Sheet. Name the file using .css as the extension, and save the file to your site folder. You can export internal stylesheets only if they contain styles other than inline styles.

2 Add styles to the stylesheet.

   Note: To reference an external stylesheet in an external stylesheet, use the Create@import button. See “To reference an external stylesheet from another external stylesheet” on page 324.

3 Reference the external stylesheet from one or more pages.

   Create different external stylesheets and apply each external stylesheet separately to a page to quickly preview different sets of styles.

To set an external stylesheet as the site default

You can set an external stylesheet to be the default stylesheet for a site. When you set an external stylesheet as the site default, all new files you add to the site will reference it.

1 Select the stylesheet in the CSS tab of the site window.

2 In the Page tab of the File Inspector, choose Default CSS.

See also

“Types of CSS styles” on page 325

“About external stylesheets” on page 323

“To reference an external stylesheet from web pages” on page 323

To add comments to a stylesheet

1 In the CSS Definitions tab in the CSS Editor, click in a blank white area to display the Create buttons on the right side of the Editor.

   Select Show These Buttons At Top to display the Create buttons at the top of the CSS Editor.

2 Click Create Comment in the Advanced section.

3 With the comment selected under the Name column, enter comments in the text field on the right side of the CSS Editor.
Using external stylesheets

About external stylesheets

If multiple pages share style elements, you can create an external stylesheet that you reference from the individual pages. Using external stylesheets helps to keep your page sizes small and lets you update the entire site's styles from within the single external stylesheet.

The order of the external stylesheets in the CSS Editor indicates their order of precedence (cascading order). Sheets that are lower in the list take precedence over sheets that are higher in the list.

To see all the pages that use an external stylesheet, open the In & Out Links palette, and then select the stylesheet in the CSS tab of the site window.

To reference an external stylesheet from web pages

1 Do one of the following:

• To reference an external stylesheet for a single web page, open the CSS Editor and click the Create a Reference To An External Style Sheet File button. Select the empty reference under the Name column and reference the external stylesheet in the Reference text box.

You can also click and hold the CSS Editor button to add links to external stylesheets from a page: the CSS Editor button menu lists all external stylesheets in the site.

• To reference an external stylesheet for multiple web pages, select two or more pages within the site window's File tab. In the CSS palette, click the Create New Link To External CSS button, and then reference an external stylesheet in the text box.

To easily reference a stylesheet document from a page within the same site, drag the stylesheet file icon from the Files tab of the site window to either the page icon in the upper right corner of the page or to a page's CSS Editor.

2 If the styles in the stylesheet are designed for certain media (such as a speech synthesizer, braille device, or PDA), specify the media type in the Media text box.

3 Add additional external stylesheets as needed.

4 To change the order of precedence of an external stylesheet relative to other external stylesheets referenced in the same page, drag the external stylesheet to a new position in the Name column in the CSS Editor of the page.

Use the CSS tab in the Site window and the In & Out Links palette to quickly see which pages in your site reference an external stylesheet. For more information, see “Using the In & Out Links palette to view links” on page 232.

To view or edit a referenced external stylesheet

❖ Do one of the following:

• Choose Special > CSS > Edit [stylesheet]

• Double-click the external stylesheet in the CSS Editor or in the CSS tab of the site window.

• Select the external stylesheet in the CSS Editor and click Edit.
To replace a reference to an external stylesheet
1 In the Files tab of the site window, select the.css file you want to replace.
2 In the In & Out Links palette, use the pick whip that is adjacent to the .css file and reference a different stylesheet document in the site window.
3 (Optional) In the Change Reference dialog box, deselect any files that you don't want to update, and then click OK. All selected files in the Change Reference dialog box use the new external stylesheet. Unselected files use the existing external stylesheet.

To remove a reference to an external stylesheet
❖ Do one of the following:
• In the CSS Editor of a page, select the external stylesheet and press Delete (Windows) or Command-Delete (Mac OS).
• Select one or more pages in the site window, and then select the external stylesheet in the CSS palette and click the Remove Selected Items button.

To reference an external stylesheet from another external stylesheet
1 Open the CSS Editor for the CSS file that you want to reference the external stylesheet.
2 In the CSS Definitions tab, click an empty area to display the Create buttons on the right side of the Editor.
3 Expand the Advanced section and click the Create @import button.
4 Do one of the following:
• Reference an external stylesheet in the Reference text box.
• Click the Create button to create a new external stylesheet. In the Save As dialog box, type a file name for the external stylesheet, and click Save.
5 If the styles in the stylesheet are designed for certain media (such as a speech synthesizer, braille device, or PDA) specify the media type in the Media text box.
6 Do any of the following:
• To edit the external stylesheet, click Edit.
• To display the In & Out Links palette, click In & Out Links.
Creating CSS styles in stylesheets

Types of CSS styles
You can create new CSS styles from scratch or import CSS styles from an external stylesheet. There are four different types of styles you can define in a stylesheet:

**HTML element styles** Are “hard-wired” to specific HTML tags. This means the style properties automatically apply to a tag, and any content it might enclose, wherever the tag appears in a web page. This style type lets you display pages in CSS-enabled browsers exactly as you want them to appear. Simultaneously, browsers with no CSS-support, or incomplete CSS-support, will have the benefit of the HTML-based formatting that is inherent in the tag you specify in the style name. For example, if an HTML element style is named for the `<h3>` tag, any style properties you add to the style will be applied to any text that uses the Header 3 paragraph format in the page when viewed in CSS-enabled browsers. Browsers without CSS-support will display the text using the default Header 3 text properties.

**Class styles** Apply to selected text or objects in a document, similar to the way word processor styles function. Any number of elements inside the BODY section of a page can host a class style. If you modify the class style’s properties, the changes affect all text and objects to which the style was applied. Class styles are more flexible than HTML element styles because a class style can be applied to multiple types of content and only to items you select. For example, you can apply a class style to some of the headings that use the Header 4 paragraph format in a page to distinguish them from other Header 4 headings in the page.

**ID styles** Define unique style properties for one element on a page. This style type is used if the style properties of an item must be distinct from all other items on the page. Consider using a class style instead since it can also be applied to a single item and is more flexible.

**Inline styles** Apply to specific elements on the page and add a style attribute to HTML tags. You create and apply inline styles by using style-attribute editing in the CSS Editor. Because inline styles apply to specific elements on the page, you can use them only in internal stylesheets.

Two major style categories are used with cascading stylesheets:

**Simple Styles** Match elements based on the element type, attributes, for both, but not the element’s position in the document structure. H1 (all level 1 headers) and H1.headline (all level 1 headers with the CLASS attribute.headline) are examples of simple styles.

**Contextual Styles** Match elements based on their position in the document structure. A contextual style consists of several simple styles. H1.headline B (all level 1 headers with the CLASS attribute.headline and bold typeface) is an example of a contextual style consisting of two simple selectors, H1.headline and B.

To import styles from an external stylesheet
You can import styles from an external stylesheet into a web page's internal stylesheet.

1. Open the CSS Editor for the page to which you want to import the CSS styles.
2. Choose File > Import > External Style Sheet.
3. Select an external stylesheet, and click Open. The external stylesheet's styles are added to the list of internal styles in the CSS Editor.
About HTML element styles

One of the more powerful features of cascading stylesheets is the ability to change the properties of a web page based on its HTML elements (tags). By using element styles, you can enhance the presentation of a document and maintain downward compatibility as a courtesy to viewers with browsers that don't support CSS; browsers that support CSS display the enhanced formatting that CSS permits, while the browsers that don't support CSS display HTML-based formatting and structure.

You can use two different types of element styles:

**Simple element styles**  Reformat all instances of a particular element within your page. For example, if you create a style with the text property 36 point and name it with the `<h1>` tag, all text that uses that tag (the Header 1 paragraph format) will display with size 36 point.

**Contextual element styles**  Reformat all instances of a particular element nested within another element. For example, if you create a style named with the `<h1>` `<i>` tags and assign the style a lime color, all text between `<i>` start and end tags (italic style) that are also within `<h1>` start and end tags will display in the lime color. (The proper style name for this example is “h1,i” without the quotation marks. If a comma is inserted in the style name, as in “h1,i,” then any text between `<h1>` or `<i>` start and end tags will use the style.)

To create hypertext links that change color when the mouse pointer hovers over the link, use a contextual element style named after the `<a>` “link” tag. In the CSS Editor, choose a:hover from the Create A Style That Applies to Markup Elements button’s menu.

To create an HTML element style

1. In the CSS Editor, do one of the following:
   - Click the Create A Style That Applies To Markup Elements button.
   - Choose New Element Style from the Create New CSS Statements button menu.
   - Choose Special > CSS > New > Element Style.
   - Choose a tag from the Create A Style That Applies To Markup Elements button menu.

   To add an HTML tag to both menus, choose Edit Style Examples from the Create A Style That Applies To Markup Elements button menu. (See “To edit the styles listed in the Create New CSS Statements menu in the CSS Editor” on page 321.)

   - Select an existing HTML element style in the CSS Editor, and choose Edit > Duplicate.
2 Select the new style in the CSS Editor, and select the Selector And Properties set. If you didn't choose a tag in step one, type an HTML element (tag) name in the Selector text box. If you want to apply the same properties to multiple elements, separate each element name with a comma in the Selector text box.

Element styles use HTML start tags without the less than (<) and greater than (>) characters—for example, h2 for second-level headers, p for paragraphs, td for table cells, and the letter a for hypertext links. For more information on naming HTML element styles to format tables and table content, see "Formatting tables with cascading stylesheets" on page 287.

You can set the shared properties of all text in a page by creating an HTML element style that is named after the tags <body>, <div>, and <td> (for table cells). Add one new HTML element style to the CSS Editor, and in the Basic set of the CSS Inspector, enter the name as "id, body, div" without the quotation marks.

3 In the CSS Editor, add style properties to the selected style.

Any properties you add are automatically applied to the HTML element that the style is named after wherever the tag appears in the page.

See also
“About style properties” on page 330

Class styles
You can apply class styles to any number of selections in a page and most any type of content, including a block of text, a single table cell, an image, and a layer. Typical uses of classes include distinctive formatting for headings, quotes, warning notes, or other special information-carrying items that need to stand out from the rest of the text. You can also use classes to create typographical effects, such as varying font sizes or font colors within a word.

To create a class style
1 In the CSS Editor, do one of the following:
   • Click the Create A New Class Style button.
   • Choose New Class Style from the Create New CSS Statements button menu.
   • Choose Special > CSS > New > Class Style.
   • Select an existing class style, and choose Edit > Duplicate.
2 Select the new style in the CSS Editor, and click the Selector And Properties set. Type an alphanumeric name, preceded by a period in the Selector text box and with no spaces—for example, .myboldclass.

Note: The leading period must precede the class style's name; otherwise, the style changes to an element style and can't be used.

3 In the CSS Editor, add style properties.

See also
“About style properties” on page 330
“Applying styles” on page 338
ID styles

Unlike classes, which you can apply to an unlimited number of items in a page, an ID style lets you apply a specific style only once in a document. Use IDs for a unique paragraph or range of text, such as a headline, warning message, or other text that needs unique and very restrictive treatment to distinguish it from other content in the page.

GoLive layers use ID styles to define their properties. If your document contains layers, the document's CSS Editor lists an ID style for each layer. You can use the CSS Editor to edit many layer properties, such as border size and style, that are not available through the Layer Inspector. (Many of these properties are not available in the Inspector because some browsers may not consistently support them at this time.)

To create an ID style

1 In the CSS Editor, do one of the following:
   • Click the Create a Style That Applies to Unique Elements button.
   • Choose New ID Style from the Create New CSS Statements button menu.
   • Choose Special > CSS > New > ID Style.
   • Select an existing ID style, and choose Edit > Duplicate.

2 Select the new style in the CSS Editor, and click the Selector And Properties set. Type a unique alphanumeric ID name in the Selector text box, preceded by a number sign (#) and with no spaces—for example, #myheaderid.

Important: The number sign must precede the id style’s name; otherwise, the style changes to an element style and can’t be used.

3 In the CSS Editor, add style properties.

4 To apply the ID style, you must hand-edit the source code of your page.

See also

“About style properties” on page 330

“Applying styles” on page 338

Inline styles

Inline styles enable you to apply a style to a single element on a page (for example, a paragraph of text) and add a style attribute to HTML tags (for example, <p style="color:#fa7442">, which displays orange paragraph text). You create and apply inline styles by using style-attribute editing in the CSS Editor. Because inline styles are attached directly to HTML tags, they have a higher cascade precedence than other styles and override all other styles applied to the page—including those specified by external stylesheets. You can use inline styles with any element in a page. Because inline styles apply to specific elements on the page, you can use them only in internal stylesheets.

To create an inline style

1 Select the element on the page to which you want to apply the style (for example, a table cell).

2 Choose Style Attribute Editing from the CSS Editor window menu.

3 In the Name column of the CSS Definitions tab, select the tag that corresponds to the element you selected in step 1 from the Style Attribute list (for example, <td>).

4 In the CSS Editor, add style properties.
See also
“About style properties” on page 330

Media, font, and page rules
You can specify media, font, and page information using CSS rules:

@media rule Specifies styles for different types of media. For example, use @media to specify the font size for print media and a separate font size for the screen.

You can specify media types for external stylesheets by setting the stylesheet's media type in the CSS palette or the CSS Editor. See “To reference an external stylesheet from web pages” on page 323 and “To reference an external stylesheet from another external stylesheet” on page 324.

@font-face rule Specifies a font and its URL location to ensure the font will display on systems without it.

@page rule Specifies the size of pages.

To create an @media, @font-face, or @page rule
1 Open the CSS Editor for the page or .css file.
2 In the CSS Definitions tab, click an empty area to display the Create buttons on the right side of the Editor.
3 Expand the Advanced section and do one of the following:
   • To create an @media rule, click the Create @media button and choose the media type from the Media menu. In the CSS Editor, drag an existing class, ID, or element style to the @media rule, or select the @media rule and create a new class, ID, or element style within it. For more information about creating styles, see “To create an HTML element style” on page 326, “To create a class style” on page 327, and “To create an ID style” on page 328.
   Note: You cannot include links to external stylesheets, @import rules, @media rules, or a folder in an @media rule.
   • To create an @font-face rule, click the Create @font-face button. In the Font Source set, click the Create New Item button and specify the URL of the font. In the Font Styling set, specify font properties.
   • To create an @page rule, click the Create @page button. Choose a selector from the Selector menu, and then choose the type of marks you want from the Marks menu. Enter the margin and size settings for the selector.

To delete a style or external stylesheet from a web page
1 Select one or more styles or external stylesheets in the CSS Editor, and then either press Shift to select adjacent items or press Ctrl to select nonadjacent items.
2 Press Delete (Windows) or Command-Delete (Mac OS).
3 If you deleted one or more styles, choose options in the Delete CSS Style window.

Editing cascading stylesheets manually
If you prefer to manually edit the source code of your cascading stylesheets, you can do so in the Source tab or in the Split Source view of the internal or external CSS Editor.

Begin each style on a new line. Use the following basic guidelines and CSS syntax definitions when editing your stylesheets in the Source tab or the Split Source view of the CSS Editor:

Class styles The syntax consists of a period followed by a unique class name, and a property: value definition enclosed by braces:
.classname { property: value }

**HTML element styles**  The syntax consists of an HTML tag, without the angle brackets < >, followed by a property:
value definition enclosed by braces:
tag { property: value }

**ID styles**  The syntax consists of a pound symbol (#) followed by a unique alphanumerical name, and a property:
value definition enclosed by braces:
#idname {property: value}
If a style has more than one property: value pair, separate each pair with a semicolon. For example:
classname { property: value; property: value}

See also

“About style properties” on page 330

**Defining style properties**

**About style properties**

After you have added a style to your cascading stylesheets, you set the properties of the style in the CSS Editor, which contains all of the style properties that GoLive supports. Some style properties are automatically inherited by items contained within the item that hosts a style.

The CSS Editor includes properties that cover the major part of the CSS specification, with the exception of some style options that browsers don’t consistently support. If a property you want to add is not included in the CSS Editor, you can enter the property and value in the Selector And Properties set or manually in the Source tab or Split Source view of the CSS Editor. You can also store collections of properties and then quickly apply them to a style.

💡 If multiple styles will share a set of properties, you can set the shared properties for each style simultaneously. In the CSS Definitions tab of the CSS Editor, Shift-click to select every style that will share the properties, and then set the shared properties in the CSS Editor.

See also

“Property inheritance” on page 330

**Property inheritance**

Content and tags contained within an item that hosts a style will automatically inherit the inheritable style properties. If you assign a style to an HTML tag or a selection in your document, any tags and content contained between the start and end tags or within the selection will inherit those style specifications. For example, consider an HTML element style named after the <h1> tag (Header 1 paragraph format) and given a blue color property. If the page has text that uses the Header 1 paragraph format, and some of that header text is also italicized with the <i> tag, the italicized text will inherit the blue properties of the <h1> start and end tags that contain it.

<h1>This is a heading of <i>size one</i>.</h1>

If we create an additional HTML element style named after the <i> tag and apply a pink color property to it, the <i> tag HTML element style will take precedence over the <h1> tag HTML element style because the <i> tags are nested within the <h1> tags. The italicized text would display in pink, and the rest of the heading would display in blue.
Inheritance can also impact the value of a style. The value of a style property can be given as a percentage that refers to a property that precedes it. In the following example, the line-height value of 120% is determined by the font-size property that precedes it in the stylesheet.

H1 { font-size: 24pt }
H1 { line-height: 120% }

Children of H1 will inherit the computed value of line-height and be set to 28.8 pt, but they will not inherit the percentage.

When applying a style property to your pages, make sure you test it in all major browsers that support CSS. For more information on browsers that support CSS, visit the World Wide Web Consortium's Cascading Style Sheets Home Page at http://www.w3.org/Style/CSS/.

Relative and absolute units
Stylesheets can contain two types of length units: relative and absolute. Relative units specify a length relative to another length property. Stylesheets that use relative units will scale more easily from one output medium to another (for example, from a computer display to a laser printer). Relative units may also reduce the differences in font size that occur when a page is viewed on different platforms.

In GoLive, you can use the following relative units:

- **pixel** Is relative to the resolution of the computer display. This unit is best for reducing size display differences between browsers on Windows and Mac OS.
- **em** Represents the height of the style item's font.
- **ex** Represents the Height of the letter x.
- **%** Percentage values are always relative to another value—for example, a length unit.

**Keywords** Specify font size relative to the parent element. For example, XX-small through X-large.

Absolute length units are only useful when the physical properties of the output medium are known.

In GoLive, you can use the following absolute length units:

- Inch (in) is equivalent to 2.54 centimeters.
- Centimeters (cm).
- Millimeters (mm).
- Point (pt) is equivalent to 1/72 of an inch.
- Pica (pc) is equivalent to 12 points.

Some properties allow negative length units. However, negative length units may complicate the formatting and there may be browser-specific limitations.
To set font properties for a style

The Font Properties set in the CSS Editor lets you define a font family and make font style settings, including color, font size, and line height. As you set font property options, a preview of the text properties displays in the lower right section of the CSS Editor.

1. Select a style in the CSS Editor and click the Font Properties set.

2. To set the text color, do one of the following:
   - Choose a color from the color field menu.
   - Choose a color name from the Color menu.
   - Click the color field, and then select a color from the Color palette.

3. To display a color behind text, do one of the following:
   - Choose a web-safe color from the Back Color color field menu.
   - Choose a color name from the Back Color menu.
   - Select the Back Color field, and then select a color in the Color palette.

4. To set the font size, choose an absolute, relative, length unit, or a percentage from the Size menu. If you choose a length or percentage unit, enter a font size or percent in the Size text box. For more information on units, see "Relative and absolute units" on page 331. Choose Pixel units to ensure that a font size will display the same across the Mac OS and Windows platforms.

5. To set the distance between the baselines of two adjacent lines of text, choose a unit from the Line Height menu, and enter a number in the text box.

6. To choose the style's preferred font family and alternate fonts and font families to use if the font is not available on the viewer's system, do one of the following:
   - To add a font set, choose a set from the Create New Font Family menu. After choosing a font family, each font from the font set is listed with a plus sign to the left of the font.
   - To add a font, click Create New Font, and then choose a font from the Font menu or enter a font name in the text field.
   - To change a font in the list, select the listed font and then either type a different font name in the text field or choose a font from the pop-up menu.

7. To set the font style, choose a font style from the Style menu.

8. To set the font weight, choose a font weight from the Weight menu. Values of 100–300 are lighter than normal, and values of 500–900 are heavier than normal. Lighter and Bolder apply font weights that are relative to the weight inherited from the parent item.

9. To set text-decoration properties, select any of the following Decoration options: None, Underline, Strike (to display a line through text), Overline (to display a line above text), or blink.

   To remove underlines from hyperlinked text, create an HTML element style named “a” after the <a> tag that is used for links. In the Font set of the CSS Inspector, set the style's Decoration property to None.

See also

"Relative and absolute units" on page 331
To set text spacing, case, and alignment for a style

The Text Properties set of the CSS Inspector lets you define spacing, case, and alignment properties for the selected style.

1. Select a style in the CSS Editor, click the Text Properties set, and do any of the following:
   - To set the horizontal alignment, choose an option from the Text Alignment menu.
   - To use small caps, choose Small Caps from the Font Variant menu.
   - To specify inheritance, choose Inherit from the Font Variant menu.
   - To specify the text case, choose an option from the Transformation menu.
   - To set the text indentation, choose a unit of measurement from the Text Indent menu, and then enter a value in the Text Indent text box.
   - To set word spacing, choose a unit of measurement from the Word Spacing menu, and enter a value in the Word Spacing text box. (This option adds to the default word spacing.)
   - To set letter spacing, choose a unit of measurement from the Letter Spacing menu, and then enter a value in the Letter Spacing text box. (This option adds to the default letter spacing.)
   - To set the font stretch, choose a stretch style from the Font Stretch menu.

   Note: Most browsers don't support font stretch, and GoLive doesn't preview font stretch.

2. Choose an option from the Vertical Align menu:
   - % Raises or lowers the line-height property of the item relative to its parent. Enter a value followed by the percent symbol (%).
   - Baseline Aligns the baseline of the style item with the baseline of the parent.
   - Sub Subscripts the style item.
   - Super Superscripts the style item.
   - Top Aligns the top of the style item with the tallest item on the line (relative to the formatted line that the style item is a part of).
   - Text Top Aligns the top of the style item with the top of the parent’s font.
   - Middle Aligns the vertical midpoint of the style item (typically an image) with the baseline plus half the x-height of the parent.
   - Bottom Aligns the bottom of the style item with the lowest item on the line (relative to the formatted line that the style item is a part of).
   - Text Bottom Aligns the bottom of the style item with the bottom of the parent’s font.

See also
"Relative and absolute units" on page 331

Block properties for CSS

The Block Properties set of the CSS Inspector lets you define the dimensions of the item’s area. Some of the properties in this set are not consistently supported across browsers and platforms. Be sure to test your pages on multiple browsers, browser versions, and platforms.
Cascading stylesheets are based on a simple block-oriented formatting model. Each item that hosts a style consists of one or more rectangular blocks, each of which has a core content area with optional surrounding padding, border, and margin areas. (Use the Margin and Padding Properties set to format surrounding areas.) This formatting model gives you much more flexibility in controlling spacing between objects.

To set block properties for a style
1. Select a style in the CSS Editor and click the Block Properties set of the CSS Inspector.
2. Specify the Width and Height properties for any item formatted with the current style by doing one of the following:
   - Choose a unit of measurement from either the Width or Height Units menu, and enter a value in the text box.
     Leave one dimension set to Auto to ensure that the item scales proportionally.
   - Leave both Width and Height set to Auto to display the referenced item in its original size.

   **Note:** Setting Width and Height is most useful with replaced elements, such as images.
3. In the Float menu, the float property creates a style item that is not part of the normal flow of text. Choose any of the following options:
   - **Left** Moves the style item to the left, so the text wraps on the right side of it.
   - **Right** Moves the style item to the right, so the text wraps on the left side of it.
   - **None** Causes the style item to appear where it occurs in the text.
4 In the Clear menu, specify how an element accepts floating elements.

**Left** Moves the element below any floating element on the left side.

**Right** Moves the element below any floating element on the right side.

**Both** Does not allow floating elements on either side.

**None** Allows floating elements on all sides.

5 In the Visibility menu, specify whether the element should be visible, hidden, or inherited.

**To specify margins and padding for a style**

1 Select a style in the CSS Editor, and click the Margin and Padding Properties set.

2 Choose a unit of measurement and enter a numeric value in any of the Top, Right, Bottom, and Left Margin text boxes, or use the All Margins text box to specify the margin in all four directions at once.

You can decrease the spacing between surrounding elements by entering negative values, which causes two elements to overlap.

> Using the View palette while in the Layout Editor, select Negative Margins to simulate how items with negative margin values overlap adjacent items.

3 In the Padding section, set the amount of space between the block border and the style item.

4 Choose a unit of measurement, and then enter a number in any of the Top, Right, Bottom, and Left Padding text boxes. Or, to specify the spacing in all four directions at once, use the All Paddings text box.

**To set border and outline properties for a style**

The Border and Outline Properties set of the CSS Inspector lets you set the borders and outlines of the block generated by a style, including line width, color, and line style. Some of the properties in this set are not consistently supported across browsers and platforms. Be sure to test your pages on multiple browsers, browser versions, and platforms.

1 Select a style in the CSS Editor, click the Border and Outline Properties set of the CSS Inspector, and do one or both of the following:

- In the Borders section, choose a unit from any of the Units menus; then enter a number in the adjacent border boxes to set the border width for the top, right, bottom, or left borders. Use the All Borders menu to set all four borders at once.

- In the Outline section, choose a unit from the Unit menu, and then enter a number in the All box to set the outline border.

2 To set the border or outline color, do any of the following:

- Choose a color from a color field menu.

- Choose a color name from a color pop-up menu.

- Click a color field, and then select a color from the Color palette.

3 Choose a line style from the Line Style menu.
See also
“Block properties for CSS” on page 333
“Relative and absolute units” on page 331

List item properties for CSS
The List Item and Other Properties set lets you set the appearance of list item markers—for example, the appearance of a bullet in a bulleted list. You can set list item marker shapes and marker positioning, or specify a custom image to serve as the marker.

*Note:* Some of the properties in this set are not consistently supported across browsers and platforms. Be sure to test your pages on multiple browsers, browser versions, and platforms.

**To set properties for list item markers**

1. Select a style in the CSS Editor and click the List Item and Other Properties set.
2. Choose an option from the List Image menu, and then reference the image file to use a custom image as a list item marker.
3. To set the type of the list item marker, choose from the following properties in the List Style menu:
   - To create bulleted lists, choose Disc, Circle, or Square.
   - To create numbered lists, choose Decimal, Lower Roman, or Upper Roman.
   - To create an alphabetical list, choose Lower Alpha or Upper Alpha.
4. To set the position where the list item marker appears, choose one of the following from the List Position menu:
   - **Inside** Sets the list item marker flush with the second, third, and following lines of text.
   - **Outside** Adds a first-line indent, letting the list item marker stand out from the rest of the text (like the bullet at the start of this item).
5. To control white space in the list, choose from the following properties in the White Space menu:
   - To format the lines of text in a list to break normally, choose Normal.
   - To preserve line breaks and other white space, choose Preformatted.
   - To suppress line breaks, choose No Wrap.

To set background properties for a style
The Background Properties set of the CSS Inspector lets you set a background image in the block generated by a style.

*Note:* Some of the properties in this set are not consistently supported across browsers and platforms. Be sure to test your pages on multiple browsers, browser versions, and platforms.

1. Select a style in the CSS Editor and click the Background Properties set.
2. Choose an option from the Image menu, and then reference an image file to set a background image.
3. To tile the background image horizontally, vertically, or in both directions, choose an option from the Repeat menu.
   - **Repeat** Tiles the image both horizontally and vertically.
   - **Repeat x** Tiles the image horizontally.
Repeat y Tiles the image vertically.

Once Disables tiling—that is, the image does not repeat.

To set a background to scroll or not scroll with other elements on the page, choose an option from the Attach menu:

Scroll Makes the image scroll.

Fixed Prevents the image from scrolling.

To set the position of the image within the style item block, choose a length unit or a percentage, and enter a number in the Horizontal and Vertical Align text boxes.

See also
“Block properties for CSS” on page 333

To store and apply property collections
You can store collections of properties and then quickly apply them to a style. GoLive provides several default property collections, available from the Apply Property Collection menu in the CSS Editor.

1 Create properties by using the properties sets of the CSS Editor.

2 Click the Selector And Properties set in the CSS Editor and select the properties you want to store. Shift-click to select adjacent properties; Control-click (Windows) or Command-click (Mac OS) to select nonadjacent properties.

3 Click the Store Property Collection button at the bottom of the CSS Editor.

4 Enter a name for the property collection in the Store Property Collection dialog box, and click OK.

5 Select a style in the CSS Definitions tab of the CSS Editor, click the Apply Property Collection button at the bottom of the CSS Editor and choose a collection.

6 (Optional) To edit one of the default property collections, click the Apply Property Collection button and choose Edit Property Collection. Choose a property collection in the CSS Definitions tab of the PropertyCollection.css window, and edit properties in the properties sets of the propertyCollection.css window.

To create a new property for a style
To ensure upward compatibility with future releases of the CSS Specification, GoLive lets you create new properties and specify their values.

1 Select a style in the CSS Editor, and do one of the following:
   • In the Selector And Properties set of the CSS Inspector, click the Add New Property button. Enter the new property name in the first text box.
   • In the Selector And Properties set, click and hold the Add New Property button and choose a property name.

2 Do one of the following:
   • Set a value for the property in the properties sets of the CSS Editor.
   • Enter a property value in the Source tab or the Split Source view of the CSS Editor immediately after the colon that follows the property name.
Applying styles

Applying styles
After you’ve created your cascading stylesheet, added styles to it, and edited the style properties, you need to apply class and ID styles to text or objects in your pages and reference external stylesheets from your pages.

You can apply styles to text and other objects in one of three different ways, depending on the style type:

**Element styles**  Apply automatically to the HTML tags that share the element style names.

**Class styles**  Require that you select text or other items in the page and apply the style with the CSS palette, the inline CSS Style preview, the Apply CSS Style toolbar button, or the Type > CSS menu options. The CSS palette lists all available class styles defined in a page’s internal or external stylesheets. The inline CSS Style preview displays the Style Apply tab of the CSS palette inline for selected text.

**ID styles**  Require that you apply the style in layout using the Visual Tag Editor or manually in the page’s Source Code Editor.

**Inline styles**  Apply automatically to the element you selected when creating the style.

To apply a class style
1  Do one of the following:
   - To apply the style to an object on a page, select the object, such as text, table, table cell, image, or markup tree tag.
   - To apply a style to the entire body of a page, select the `<body>` tag in the markup tree at the bottom of the page, and then use the formatting options in step 2.

2  Do one of the following:
   - In the CSS palette, select a formatting option adjacent to the class style’s name.
   - Click the Apply CSS Style button in the toolbar, and then select the formatting option in the CSS Style preview that appears. (You can also preview styles by placing the pointer over a formatting option.)
   - Choose Type > CSS [format], and then choose a class style.
   - Choose Type > CSS Style, and then select the formatting option in the inline CSS Style preview that appears. (You can also preview styles by placing the pointer over a formatting option.)

   **Note:** The formatting options in the CSS palette, CSS Style previews, and the CSS commands in the Type menu vary depending on the selection in the document window. For example, if text is selected, the CSS palette displays Inline, Par, and Div options. If a table cell is selected, the palette displays one option for the `<td>` tag.
   - Choose Window > Markup, and apply the style by choosing it from the Class menu in the Markup palette.

Class style format options
You can choose from the following formatting options in the CSS palette or the inline CSS Style preview:

**Inline Style**  Formats an item inline.

**Block Style**  Creates a division that is disconnected from the normal flow of HTML.

`<p>`  Formats an entire paragraph with a style. You don’t need to select the entire paragraph; either place an insertion point in the paragraph or select a portion of it.
**<body>** Applies a style to the entire body of a page. If this option isn't listed, select the `<body>` tag in the markup tree at the bottom of the page, or place an insertion point anywhere in the Layout Editor, except inside a table or layer.

**Specific HTML tags** Apply the style to a selected object, such as a table cell, image, or layer. For example, the `<td>` tag for a table cell, the `<img>` tag for an image object, and the `<div>` tag for a layer.

See also

“Formatting tables with cascading stylesheets” on page 287

**To apply an ID style**

1 In the Layout Editor, select the text, paragraph, or object to which you want to assign the ID, and do one of the following:

   - If the text to be reformatted is a portion of the text within a paragraph, Press Ctrl+Shift+E (Windows) or Command+Shift+E (Mac OS) to open the Visual Tag Editor. Type `<<wrap emphasis>>SPAN ID=[myID]` or `DV ID=[myID] <<wrap emphasis>>` within the brackets.
   
   - Click the Source Code Editor tab and locate the highlighted source code for the selected item. Add the ID style name, without the pound (#) symbol, as an attribute to the selected item’s start tag. For example, if the ID style name is `#headerbox`, and you want to apply it to the entire paragraph, edit the code as follows: `<P ID="headerbox">Welcome to TravelEZ</P>`

2 View the effect in the Layout Preview.
Chapter 14: Adding images and multimedia

Pre-optimized images

Choosing between pre-optimized images and Smart Objects
GoLive offers two primary methods for adding images. You can add pre-optimized images, which you optimize for the web in another application. Or, for maximum control and versatility, you can add Smart Objects, which you optimize in GoLive.

Pre-optimized images and Smart Objects share many features, such as rollovers and image maps. Smart Objects, however, also provide many additional features.

See also
“Advantages of Smart Objects” on page 358

Adding pre-optimized images
You can add pre-optimized images in the GIF, JPEG, PNG, and WBMP formats. When you add a pre-optimized image to a page, GoLive references the path to the image file. To ensure that GoLive can properly manage these references and publish image files, place image files in the site window before adding them to a page. Many web designers store all images in an images folder in the site window. That approach lets you manage numerous image files more easily.

Smart Objects offer more flexibility than pre-optimized images. For example, GoLive automatically reoptimizes Smart Objects if you resize them in the Layout Editor.

See also
“Advantages of Smart Objects” on page 358

To insert a pre-optimized image
❖ Do one of the following:
• Drag the image file from the site window into the Layout Editor.
• Drag the Image icon from the Basic set in the objects toolbox into the document window, or double-click the icon in the palette. In the Image Inspector, specify an image file in the Source text box.
Resizing pre-optimized images

You can resize pre-optimized images to change the design of a page. Before doing so, however, note the following considerations:

- If you shrink a pre-optimized image, your page still references the unnecessarily large image file, resulting in inefficient use of bandwidth.
- If you enlarge a pre-optimized image, it will appear pixelated.

When you change the size of an image, GoLive displays a resize warning icon on top of the image to warn you that the image may have an unnecessarily large file size and is not displayed at its optimum resolution. You can restore the image to its original proportions by clicking the Set To Original Size button in the Image Inspector.

If you often resize images, use Smart Objects for maximum flexibility.

See also

“Resizing Smart Objects” on page 363

To resize an image disproportionately

1. Select the image in the Layout Editor.
2. In the Image Inspector, click the Basic tab.
3. From the Width and Height menus, choose Pixel or Percent, and then enter new values.

To resize an image and constrain proportions

1. In the Layout Editor, select the image, and position the pointer over a corner handle; the pointer becomes a double-arrow.
2. Hold down Shift, and drag.

Setting basic image options

To add alternative text for images

Alternative text replaces images in browsers that are configured to omit images; it is also read aloud by software for the visually impaired. Even in browsers that display images, however, alternative text can be useful. For example, in an image-based menu, alternative text appears while the images download.

1. Select the image or Smart Object on your web page.
2. In the Basic tab of the Image Inspector, type text in the Alt Text text box.

See also

“Creating resource and navigational links” on page 167
To create image borders

You can create image borders to highlight images on a page. Borders around linked and nonlinked images appear in the default colors for links and text, respectively.

1. Select the image, and then select Border in the More tab of the Image Inspector.
2. Type in the desired border width in pixels, and press Enter (Windows) or Return (Mac OS).

See also

“To set default colors for text or links on the page” on page 180

Creating rollovers

About rollovers

Rollovers respond to a viewer’s mouse movements and clicks, providing interactivity on a web page. To aid navigation, you can use rollovers to highlight hyperlinked images. To further enhance interactivity, you can combine rollovers with actions.

Rollovers require separate images for each rollover state: Normal, Over, Down, Click, Up, and Out. The Normal state appears when the mouse is over another part of the page. The remaining states appear when the viewer moves or clicks the mouse over a rollover object.

Note: Normally, images for all states of a rollover have identical dimensions. If a rollover has an image with different dimensions, you can either resize it in a graphic editor, or choose Image from the Width or Height menu in the Image Inspector.

To create self rollovers

With self rollovers, the most common rollover type, mouse actions over an image cause changes in that image alone.

1. In the Layout Editor, select the desired image.
2. In the Rollovers palette, select the desired rollover state, and then click the New Rollover Image button.
3. In the URL text box, specify an image for the state.
4. To force browsers to fully download the image before enabling the rollover, click Preload.
Note: Don’t select Preload for a state that contains an animated GIF file. Some browsers will immediately play the animation after preloading the file.

Identifying a self rollover in the Layout Editor

To create remote rollovers

While self rollovers change trigger images, remote rollovers change images located elsewhere on the page. Because these changes occur elsewhere, trigger objects for remote rollovers can include paragraphs, table cells, or any other HTML element. Only trigger images, however, can combine remote rollovers with self rollovers.

1 In the Layout Editor, select the trigger object.

2 In the Rollovers palette, select the state that will trigger the rollover, and then click the New Rollover Image button.

3 In the Name/ID text box, specify the remote image object.

Note: Use the pick whip to specify an object that lacks a name or ID. If you type a name or ID that doesn’t exist, GoLive displays a bug in the Kind column of the Rollovers palette.

4 In the URL text box, specify the image file for the remote image object.

5 To force browsers to fully download the image before enabling the rollover, click Preload.

To trigger multiple remote rollovers from an object, add more than one rollover image to a state.

Combining self and remote rollovers
A. Normal state.  B. Down state
Importing rollovers from ImageReady

To import ImageReady rollovers, use Smart Photoshop objects. If you change an original ImageReady PSD file, GoLive can automatically update related Smart Objects.

For standard ImageReady rollovers, GoLive displays all states, but you can edit only remote states. For Selected State rollovers, GoLive doesn’t display states.

See also
“Advantages of Smart Objects” on page 358

To add status-bar messages to rollover states

For any rollover state, you can add a message that appears in the status bar of the browser. Such messages can provide helpful additional information for the viewer.

1 In the Rollovers palette, select the state.
2 Click the New Message button, and then type in the Message text box.

To remove rollover images or states

1 In the document window, select the object that contains the image or state.
2 In the Rollovers palette, do one of the following:
   • To remove an individual image or state, drag it to the Delete icon.
   • To remove all states, choose Remove All Rollover States from the palette menu.

To change the size of rollover thumbnails

❖ From the Rollovers palette menu, choose View, and then choose No Thumbnails, Small Thumbnails, Medium Thumbnails, or Large Thumbnails.

To highlight rollovers in the document window

To more easily identify rollovers and rollover code, you can highlight them in the Layout Editor, Source Code Editor, and Outline Editor.

❖ From the Rollovers palette menu, select Highlight Rollovers & Actions.

About hidden rollover states

To ensure that rollovers behave as most viewers expect, GoLive creates additional rollover states that the Rollovers palette hides by default. For example, when you add an Over state, GoLive creates an Out state that uses the Normal image. Without this extra state, the Over image would remain when the mouse left the trigger area.

Use the Expert Mode of the Rollovers palette to prevent GoLive from creating these extra states, or to delete them from existing rollovers. In Expert Mode, only states displayed in the Rollovers palette are added to JavaScript code.

See also
“‘To display all rollover states” on page 345
To display all rollover states
❖ From the Rollovers palette menu  , select Expert Mode.

When Expert Mode is enabled, GoLive displays a warning icon ⚠️ in the Rollovers palette.

See also
“About hidden rollover states” on page 344

Assigning rollover images automatically

Detecting rollover images
The Detect Rollover Images feature automatically assigns images to rollover states. After you specify the file name of the Normal image, GoLive automatically searches for Over, Down, Click, Up, and Out files that use a similar naming convention. For example, if you specify a Normal image named myimage_Base.gif, GoLive looks for myimage_Over.gif. You can edit the rollover naming conventions that GoLive uses.

To use the Detect Rollover Images feature, you must place images for all rollover states (Normal, Over, Down, etc.) in the same folder. If images for some states are not yet complete, you can manually start the rollover detection process after adding the needed images to the folder.

The Detect Rollover Images feature is on by default, but you can turn it off if you prefer to assign rollover images manually.

To determine how GoLive detects rollovers
In the Rollover preferences, you can change how GoLive behaves when it detects rollovers. You can also view and edit the sets of naming conventions that identify rollover images.

1 Choose Edit > Preferences (Windows) or GoLive > Preferences (Mac OS), expand Images, and select Rollover.
2 Do any of the following:
   • To open the Rollovers palette when GoLive detects rollovers, select Automatically Open Rollover Palette.
   • To prevent GoLive from detecting rollovers, deselect Automatically Detect Rollover Images.
   • To overwrite a naming convention set, select it, and type new suffixes in the text boxes for each rollover state.

If you work with ImageReady, do not overwrite the third default set, which conforms to ImageReady’s rollover naming conventions.

To manually detect rollover images
1 Select a rollover object in the Layout Editor.
2 From the Rollovers palette menu  , select Detect Rollover Images.
Using actions with rollovers

Attaching actions to a rollover
The Actions palette lets you attach scripted actions to a rollover—for example, an action that changes the background color of the page. You can even attach actions to a sliced Smart Object containing rollovers. If you edit the source file in Photoshop or Illustrator, GoLive automatically reoptimizes target files and retains attached actions.

To ensure that scripted actions work with rollovers, make sure that all images on a page have a unique name (button1, button2, and so on). Avoid names that contain only numbers (1, 2, 3, and so on) or that start with a number; the names won’t work in all browsers. Finally, do not include spaces or special characters.

See also
“About actions” on page 608

To change default rollover and action code for images
By default, GoLive adds rollover and action code for images to a hyperlink surrounding the image element. This default behavior ensures compatibility with the largest number of browsers. To create smaller code, however, you can instead configure GoLive to apply rollover and action code directly to the image element.

1 Choose Edit > Preferences (Windows) or GoLive > Preferences (Mac OS).
2 In the list on the left, select Images, and then select either Apply To Hyperlink Around <img> Element or Apply To <img> Element.

Creating image maps

Image maps
Image maps consist of clickable hotspots in an image. Image maps are helpful navigational tools, because each hotspot can link to a different destination and have a unique size and shape. GoLive lets you create and edit image maps, and associate them with actions and rollovers.

To create an image map
1 Select an image on your web page.
2 In the Smart Image or Image Inspector, click the More tab and select the Use Map option.

Note: By default, GoLive assigns a unique ID to the image map and enters the ID in the Name text box. You can replace this ID by typing a name for the image map in the Name text box on the More tab.
3 In the toolbar, select the Rectangular tool, the Circular tool, or the Polygonal tool.
4 Drag in the image to define the hotspot. (If you are using the Polygonal tool, click to define each point of the polygon.)
5 In the Map Area Inspector, specify a file for the link destination of the selected hotspot.
6 Use the Target text box to specify the target frame in the destination frame set (if any).

7 Type additional information in the Title text box. Some browsers use this information to display tooltips or voice annotations.

💡 You can also click an image and use the context menu to create a clickable image map.

**To customize the appearance of hotspots in image maps**

1 Select the hotspot in the image.

2 Use the following tools available in the toolbar:
   - To move or resize the hotspot by dragging, use the Select Map Area tool.
   - To display the destination URL in the hotspot, click the URL button. The URL appears in the GoLive Layout Editor for your convenience; it does not appear on the web page.
   - To edit or turn border and color display on and off, respectively, while editing, click the Frame or Color buttons.
   - To change the color used for highlighting, click the Color button.
   - To change the stacking order of multiple overlapping hotspots, use the Bring Region To Front button and the Send Region To Back button in the toolbar.

*Note: The Bring To Front and Send To Back buttons are also available in the Transform palette.*

**To add actions to image maps**

1 Select a hotspot in an image map.

2 In the Actions palette, choose a mouse or key event, and click the New button.

3 Choose the desired action from the Action menu.

See also

“About actions” on page 608

**To associate a rollover with an image map**

1 Select a hotspot in the image map.

2 In the Rollovers palette, create and edit rollover states.

See also

“About rollovers” on page 342

**Low source images**

**About low source images**

A low source image is a low-resolution version of an image that displays until the full-resolution image downloads. Low source images are particularly useful for web audiences with low bandwidth and images with very large file sizes.
You can either specify an existing low source image or have GoLive generate one for you.

**To specify or generate a low source image**
1 In the Image Inspector, click the More tab.
2 Select Low, and then do one of the following:
   • Specify an existing low source image in the text box.
   • Click Generate to create a low source image in the same folder as the original image. To regenerate the low source image if the original changes, also select Auto-update.

**To change default settings for low source images**
1 Choose Edit > Preferences (Windows) or GoLive > Preferences (Mac OS).
2 In the list on the left, select Images.
3 Select a default color mode: Color or Black And White.
4 To instruct GoLive to automatically create a low-resolution copy of each image you add to pages, select Auto-Generate By Default.

### Building a web page using tracing images

**Tracing images**
You can design web pages by using tracing images as visual guides. As a design develops, you can cut out parts of a tracing image and convert them into Smart Objects on the final web page.

You can import the following formats as tracing images: Illustrator AI, Photoshop PSD, JPG, JP2, GIF, PNG, BMP, TARGA, EPS, PCX, PDF, PICT, PIXAR, SVG, TIFF, and Amiga IFF.

**See also**
“Advantages of Smart Objects” on page 358

**To add a tracing image to a page**
1 Select Window > Tracing Image.
2 In the Tracing Image palette, select Source and specify a file for the tracing image.
3 If the source is a PDF file, rotate the document if desired, and then select a page.
4 Set the opacity of the tracing image in the Tracing Image palette.
5 Do one of the following to position the image in the Layout Editor:
   • Type pixel values in the Position text boxes.
   • Click the Move Image tool in the Tracing Image palette, and drag the image in the Layout Editor. When you’re finished, click the Move Image tool again to disable the tool.

**Note:** You can quickly resize the window to fit the tracing image by selecting Tracing Image from the Change Window Size pop-up menu in the bottom right corner of the document window.
To align, reset, or remove a tracing image
❖ Select the image, and then do one of the following:
- To align with an object in the document window, choose Align With Selection from the Tracing palette menu.

  You can align tracing images with objects such as table cells and GoLive layers.

- To return a tracing image to the default position, choose Reset Position from the Tracing palette menu. The image returns to the upper left corner of the page.
- To remove a tracing image, deselect the Source check box in the Tracing Image palette.

To cut out a portion of a tracing image
1. Select the tracing image.
2. In the Tracing Image palette, click the Crop tool. Then select a rectangular portion in the Layout Editor.

   Note: You can cancel the cut out process by clicking the Crop tool again.
3. Double-click the selection in the Layout Editor, or click Cut Out in the Tracing Image palette.
4. In the Save For Web dialog box, make your desired optimization settings, and click Save.
5. Specify a destination for the file and click Save. The cutout becomes a Smart Object in the document window.

Adding multimedia to web pages

Adding multimedia
GoLive supports a variety of plug-ins that let browsers play back multimedia over the web. By using these plug-ins, you can add video and audio clips to your pages.
GoLive offers the generic Plug-in object that you configure, as well as the predefined SWF object, the QuickTime object, the Real object, the SVG object, and the Windows Media object. You can also associate other file types with plug-ins.

To add multimedia objects to pages
1 From the Basic set of the Object palette, drag the desired plug-in object to the document window.
2 In the Basic tab of the Plug-in Inspector, specify a file for your plug-in.

To set basic options for multimedia objects
For the SWF, QuickTime, Real, SVG, and Windows Media plug-in objects, most basic options are predefined. For the generic Plug-in object, however, you must manually specify the MIME type.

1 In the Layout Editor, select a plug-in object.
2 In the Plug-in Inspector, click the Basic tab.
3 If you are setting up a generic Plug-in object, select Mime, and choose the MIME type from the pop-up menu.
4 Enter a value in the Width text box for the width of the media clip in pixels or as a percentage.
5 Enter a value in the Height text box for the height of the media clip in pixels or as a percentage.
6 Choose an alignment option from the Alignment menu:
   - Default: Positions the icon according to the browser's preferences. If the browser does not specify any alignment preferences, the clip will be left-aligned. (Most browsers do not specify alignment preferences.)
   - Left: Positions the icon in the upper left corner.
   - Middle: Positions the icon in the upper middle.
   - Right: Positions the icon in the upper right corner.
7 From the HTML menu, choose the tags that browsers will use to detect the required plug-in.

   Note: If you choose the <object> or <object> <embed> tags for a generic Plug-in object, you must also specify a plug-in class in the Class text box.

To set advanced options for multimedia objects
1 In the Plug-In Inspector, click the More tab.
2 Type a unique name for the multimedia element in the Name text box.
3 Select Page, and specify a file for the link destination for the Plug-in installation instructions. For a SWF or QuickTime plug-in, a destination link appears by default.
4 Select Code for Real and SVG plug-ins, and specify a file for the link destination for the code base. The Macromedia® Flash™ code base, for example, specifies the location of the Macromedia Flash player ActiveX control that the browser can download if the control is not installed. The code base is provided by default when you use the predefined SWF or QuickTime plug-in.
5 From the Palette pop-up menu, select an option to determine whether the plug-in appears in the Foreground or Background palette. Select Default to place the palette in the background.
6 Enter a value in the HSpace text box to set the horizontal space between the multimedia element and the surrounding text (the padding to the left and right).
7. Enter a value in the VSpace text box to set the vertical space between the multimedia element and the surrounding text (padding above and below).

8. Select Is Hidden to hide the plug-in on the page. You might want to hide the plug-in if you want to play an audio clip as soon as the page is loaded (without any controls being displayed on the page).

**To set options for unsupported multimedia objects**

The Attribs tab of the Plug-in Inspector lets you add, edit, and delete plug-in attributes manually. You can use this tab with the generic Plug-in object to set options for multimedia formats that GoLive doesn’t support directly.

1. In the Attribs tab of the Plug-in Inspector, click New to add a new attribute. In the left text box below the list box, type an attribute name. The attribute name appears in the Attribute column of the list box.

2. In the right text box, enter an attribute value. The attribute value appears in the Value column of the list box.

3. To delete an attribute, select the desired entry from the list box, and click Delete.

**Multimedia plug-in options**

**SWF plug-in options**

When you select a SWF object, the SWF tab of the Plug-in Inspector offers the following options:

- **Autoplay** Plays the SWF movie as soon as the page is loaded.
- **Loop** Plays the movie in an endless loop.
- **Quality** Balances visual appearance versus playback speed. From the pop-up menu, choose one of the following:
  - **Default** Uses the player settings.
  - **High** Gives priority to appearance over playback speed.
  - **Autohigh** Emphasizes appearance but improves speed when the frame rate drops below the specified frame rate.
  - **Autolow** Emphasizes speed but improves appearance when the Macromedia® Flash™ player determines that the processor can handle it.
  - **Low** Gives priority to playback speed over appearance.
- **Scale** Specifies how the movie is placed within the browser window if the Width and Height settings specified in the Basic tab are different from those of the movie clip. From the pop-up menu, choose one of the following:
  - **Default** Makes the entire movie visible in the specified area while maintaining the original aspect ratio of the movie. No distortion occurs. Transparent or matte-colored borders may appear on two sides of the movie.
  - **No Border** Scales the movie to fill the specified area while maintaining the original aspect ratio of the movie. Portions of the movie may be cropped. No distortion occurs.
  - **Exact Fit** Makes the entire movie visible in the specified area. No attempt is made to preserve the original aspect ratio. Distortion may occur.
SWF Detect plug-in options
When you select an SWF object, the Detect tab of the Plug-in Inspector offers the following options:

**Type** Specifies how the SWF object relates to the containing web page. Select one of the following, and then set related suboptions:

- **Detect Page** Displays the SWF file in a separate web page, or displays an alternate web page if the browser doesn't have a compatible Flash plug-in.
- **Inline With HTML** Displays the SWF file inline, or inserts the contents of an HTML file if the browser doesn't have a compatible Flash plug-in.
- **Inline With Image** Displays the SWF file inline, or displays an alternate image if the browser doesn't have a compatible Flash plug-in.

**Version** Specifies the required Flash version.

**Require Current Player Revision** Prevents the SWF file from loading if the installed Flash plug-in is outdated.

**Detect Page options**
- **Store Results In A Cookie** Limits browsers to one SWF detect process per session.
- **Flash Page** Specifies the web page for the SWF file.
- **Alternate** Specifies the alternate web page.
- **Create Page** Generates the web pages for the SWF file.

**Inline With HTML options**
- **Load Player Stats From Cookie** Limits browsers to one SWF detect process per session.
- **Source** Specifies the HTML file to insert if a Flash plug-in isn't installed.

**Inline With Image options**
- **Load Player Stats From Cookie** Limits browsers to one SWF detect process per session.
- **Source** Specifies the image file.

**See also**
- “To add alternative text for images” on page 341
- “Resizing pre-optimized images” on page 341

QuickTime plug-in options
When you select a QuickTime object, the QuickTime tab of the Plug-in Inspector provides options on Standard, HREF, and More tabs. On any of these tabs, you can click Open Movie to see a preview in GoLive's QuickTime viewer.

**Important:** Before uploading QuickTime movies, you must flatten them in a web-compatible format. For more information, see “Saving movies” on page 576.

**Standard options**
- **Show Controller** Shows playback controls.
- **BGColor** Displays a background color you specify in the color field.
Cache  Enables caching through the browser when the movie is played back.

Volume  Sets the audio volume. Enter a value from 0 (mute) to 100 (full volume).

Autoplay  Plays the movie automatically when the page opens.

Scale  Resizes the movie. Enter one of the following values:

- Tofit  Scales the movie to the size of the embedded player window.
- Aspect  Scales the movie to the size of the embedded window but maintains aspect ratio.
- A number  Scales the movie by a specific percentage. For example, .5 scales the movie to 50%, and 1.5 scales the movie to 150%.

Loop  Plays the movie in an endless loop.

Palindrome  Plays the movie in a loop from beginning to end and then from end to beginning.

Play Every Frame  Plays all frames of the movie even if it’s necessary to play at a slower rate to do so. This attribute is useful to play simple animations. (Selecting this attribute will turn off all audio tracks in the movie.)

Don’t Flatten  Maintains references to movie assets, rather than flattening them into the movie file.

Auto HREF  Immediately loads any URL specified in the HREF parameter, without waiting for a mouse click.

Enable JavaScript  Enables JavaScript functions to control movies.

Kiosk Mode  Disables Save commands, including drag and drop functionality.

HREF options

Link  Provides a link to another page or movie when the movie is clicked.

Target  Specifies the HTML frame targeted by the Link attribute. If a target isn’t specified, links open in the same frame as the current movie. In addition to standard target options such as _self and _top, two QuickTime-specific options exist:

- QuickTime Plugin (myself)  Replaces the QuickTime movie currently playing. This option is useful for poster movies (still frames that link to full movie files).
- QuickTime Plugin (quicktimeplayer)  Starts a QuickTime movie in the QuickTime Player instead of the browser.

Save Embed Tags  Applies the current plug-in settings to another movie started via the Link, Hotspots, or QTNext options.

Allow Embed Tags Overrides  Enables plug-in settings to be overridden by user preferences or settings embedded in subsequently loaded movies.

More options

From the Tags menu, choose any of the following, and then set related options:

Hotspots  Links a hotspot to the specified URL.

Identifiers  Identifies the movie name and ID for use in wired actions.

QTNext  Specifies the URL of a movie that will play after the current movie.
**Qtsr** Forces browsers to use the QuickTime plug-in for the specified file, regardless of MIME type. Specify data rate in the Speed text box, and choose one of the following caching options from the Use Browser menu:

- **Default** Uses the browser’s caching setting.
- **True** Prevents browser caching.
- **False** Allows browser caching.

**URL Substitute** Replaces every instance of the specified string with the specified URL Substitute.

**Time** Specifies start and end frames for the movie.

**XML List** Specifies an XML list for controlling movie playback.

**See also**

“About the Color palette, Swatches palette, and the Color Picker” on page 175

**Real plug-in options**

When you select a Real object, the Real tab of the Plug-in Inspector offers the following options:

- **Autostart** Plays the audio or video as soon as the viewer opens the page.
- **No Labels** Suppresses display of information such as title, author, and copyright.

- **Controls** Determines what controls are displayed. Choose from the following options in the Controls pop-up menu:
  - **Image Window** Provides a context menu that allows the viewer to control playback in the playback area using controls such as Play and Stop. (Image Window is available only for videos and animations.)
  - **Control Panel (or Default)** Displays the default RealPlayer control panel, which contains Play, Pause, Stop, Fast Forward, and Rewind buttons, Position and Volume sliders, and a Mute button that appears when the speaker is selected.
  - **Play Button** Displays a Play/Pause button.
  - **Play Only Button** Displays a Play button.
  - **Mute Control** Displays a Mute button.
  - **Mute Volume** Displays a Mute button and volume slider.
  - **Position Slider** Displays a clip position slider.
  - **Clip Information** Displays an information field for information about the Real clip.
  - **Home Control** Displays the Real logo.
  - **Info Volume** Displays presentation information as well as a volume slider and a Mute button.
  - **Info Panel** Displays the presentation information panel.
  - **Status Bar** Displays informational messages, the network congestion LED, and the position field, which indicates the current place in the presentation timeline along with total clip length.
  - **Status Field** Displays the message text area of the status bar. If no status field or status bar is embedded, error messages display in the browser’s status bar.
  - **Position Field** Displays the clip’s current place in the presentation timeline and the total clip length.
**Note:** You must have one Real object for each control. For example, Play and Pause buttons require two separate Real objects. For more information, see “To add RealPlayer controls to presentations” on page 512.

**Console** Groups multiple controls using an option you choose from the Console menu. For example, you can place different controls, such as a Play button and a Volume slider, in different HTML table cells. You can then tie these controls together by assigning the same Console name to each of them. You can assign a user-specified name in the Console text box, or you can choose a predefined name from the Console menu:

- **Default** Assigns no Console name.
- **_master** Links the control to all other controls or groups of controls.
- **_unique** Lets you avoid linking the control to any other control.

Controls that have no Console attribute assigned will be grouped together.

**Windows Media plug-in options**

When you select a Windows Media object, the Windows Media tab of the Plug-in Inspector provides options on Basic, URL, Play Rate, and SAMI tabs.

**Basic options**

- **Autoplay** Starts the media file automatically when the page opens.
- **Enable Context Menu** Enables the context menu in the Windows Media Player window.
- **Enable Controls** Reveals player controls during full-screen playback.
- **Full Screen** Plays video in full-screen mode.
- **Invoke URLs** Starts the default web browser automatically in response to URL events; no mouse click is required.
- **Mute Audio** Mutes audio.
- **Stretch To Fit** Enlarges video to fit the dimensions of the video window.
- **Windowless Video** Displays video directly in the browser window, rather than in the Windows Media Player window. (Requires Internet Explorer for Windows XP or later.)

**URL options**

- **Base URL** Converts relative links into absolute links. (Requires a Base element in the Head section of the page. (See “To add elements or scripts to the head section” on page 163.)
- **Default Frame** Specifies the default target frame for URL events. (See “About target frames for linked pages” on page 267.)
- **Caption ID** Identifies the HTML tag used to display captions. (Requires a tag that supports the innerHTML attribute.)
- **Current Position** Indicates the start position of the media file in seconds from the beginning.
- **Current Marker** Starts playback from the specified marker.
- **Play Count** Specifies how many times the media file will play.
- **UI Mode** Specifies which interface elements appear. Choose one of the following from the pop-up menu:
  - **Invisible** Hides all controls and media files.
  - **None** Reveals only media files.
• **Mini** Reveals media files, the status bar, and play, pause, stop, mute, and volume controls.

• **Full** Reveals all media files and controls.

**Play Rate options**

**Play Rate** Determines playback speed. Default value is 1; values such as .5 and 2 equal half-speed and double-speed, respectively. (WMV and ASF files also support negative values, which cause reverse playback.)

**Balance** Determines audio balance between left and right speakers. Possible values range from -100 (full left) to 100 (full right).

**Volume** Determines audio volume. Possible values range from 0-100.

**SAMI options**

**File** Specifies a Synchronized Accessible Media Interchange (SAMI) file containing closed captions.

**Language** Specifies which language to access from a SAMI file.

**Style** Specifies which style definition to access from a SAMI file.

### Java applets and W3C object controls

**Java applets and W3C object controls**

GoLive lets you insert Java applets on a layout grid or in the flow of HTML code, so you can add animation or other advanced features to your page. In GoLive, you can play Java applets in the Preview tab of the document window; you don't need to start a browser.

GoLive also lets you insert W3C object controls, which web browsers can download and execute. In Windows, you can set up these controls with installed ActiveX objects. Mac OS doesn't support ActiveX, but you can specify object files.

**To set up Java applets**

When you set up Java applets, the name of the .class file containing the applet appears in the Code text box of the Java Applet Inspector. The name of the applet appears in the Java Applet icon in the document window.

1. Drag the Java Applet icon from the Basic tab in the objects toolbox to the Layout Editor, or double-click the icon in the objects toolbox.

2. In the Basic tab of the Java Applet Inspector, specify an applet file in the Base text box.

**Note:** With some Java applet generator programs, the extension is not added correctly to the CODE attribute. These applets work in the browser, but they won't display in GoLive.

3. Name the applet by typing a unique name in the Name text box. The name cannot be used by any other object on your page.

4. Resize the applet by dragging the resize handles, or type Width and Height values in the Java Applet Inspector. (The values can be pixels or percentages.)

5. To align an applet with surrounding text when you are not using a layout grid, use the Hspace and Vspace text boxes and the Align pop-up menu.
To set up W3C object controls
1 Drag the Object icon from the Basic tab in the objects toolbox to the Layout Editor, or double-click the icon in the objects toolbox.
2 In the Object Inspector, do one of the following:
   • (Windows) Click Select to open a list of installed ActiveX objects. Select an object to insert, and click OK.
   • (Mac OS) Specify an object in the Base box.

   To view W3C object contents while resizing, Ctrl-drag a corner handle.

To edit properties for Java applets and W3C object controls
1 In the Params tab of the Java Applet Inspector or the Properties tab of the Object Inspector, do either of the following:
   • To add a property, click the Create New Item button, and type a name and value.
   • To delete a property, select it, and click the Remove button.

   Note: You can't delete properties of Windows ActiveX controls.
2 (Windows only) To access a built-in dialog box for an ActiveX control, double-click the control in the Layout Editor, or click Properties in the Basic tab of the Object Inspector.

To add alternative text or HTML objects for Java applets
GoLive lets you enter alternative text or HTML objects in the Java Applet icon. The browser displays alternative text if the applet element is understood but applet loading is turned off; the HTML is used when Java is not supported. By adding images or other HTML objects, you can edit or enrich the text or HTML content of the Java applet.
1 With the Java Applet icon selected, click the Alt tab of the Java Applet Inspector.
2 Do one of the following:
   • In the Alt Text text box, type the text you would like to display in place of the Java applet.
   • Select Show Alternative HTML. In the document window, type the HTML directly into the applet icon, or drag any Basic or Forms icons from the objects toolbox to the icon.
Chapter 15: Working with Smart Objects

Understanding Smart Objects

Advantages of Smart Objects
Smart Objects eliminate the need to preoptimize images outside of GoLive. With Smart Objects, you can import source files in formats such as native Photoshop and Illustrator, and then use GoLive's Save For Web feature to create web-optimized images.

Smart Objects let you automate many common image-related tasks. For example, when you resize a Smart Object in the Layout Editor, GoLive automatically reoptimizes the image, keeping its appearance clear and sharp. Likewise, when you edit the source file of a Smart Object in another application, GoLive can automatically update the object's appearance on your web pages. Smart Objects also streamline the process of adding sliced images to a page: GoLive automatically creates a table with cells for each slice.

The versatility of Smart Objects extends far beyond automated image optimization. They also provide features that let you convert HTML text to an image, create multiple image variations from a single image file, and import text and graphics from Adobe InDesign.

See also
“Choosing between pre-optimized images and Smart Objects” on page 340

About Smart Object source and target files
Smart Objects offer an efficient and powerful way to add images to web pages. After you specify a source file in a format such as Photoshop, Illustrator, PDF, or EPS, GoLive creates a target file in a web-optimized format and maintains a link to the source file.

When you move, resize, or reoptimize a Smart Object, you're really manipulating the target file; the source file does not change. This process lets you generate multiple image variations from a single source file throughout your website.

When you double-click a Smart Object in the Layout Editor, the source file opens in its original application. If you make changes to the source image, GoLive can automatically update the target file.
Storing Smart Object files

When working with Smart Objects, store source and target files in two different places in the site window. Store source files in the Smart Objects folder in the Extras tab, and store target files in the Files tab. From those locations, GoLive can properly update source files and upload target files.

You can store target files anywhere in the Files tab, but many web designers use an images folder to manage numerous image files more easily.

See also

"To add Smart Objects to pages" on page 360
Adding and copying Smart Objects

Adding Smart Objects
To optimize images for standard web graphics, add Smart Photoshop, Smart Illustrator, Smart PDF, or Smart Generic objects. The Smart Generic object supports source files in the following formats: BMP, PCX, Pixar, Amiga IFF, TIFF, TARGA, PDF, EPS, JPEG, JPEG 2000, PNG, and PICT (Mac OS only).

To optimize images for a browser's Favorites or Bookmarks menu, use the Smart Favorite icon. (See "Head section elements" on page 164.)

To add Smart Objects to pages
1. From the Smart set in the objects toolbox, drag a Smart Photoshop, Smart Illustrator, Smart Generic, or Smart PDF object to the Layout Editor.
2. In the Smart Image Inspector, specify a file for the image.
   You can also add a Smart Object by dragging a Smart Object-compatible file to the Layout Editor.
3. Do one of the following:
   • For Smart Photoshop, Illustrator, or Generic objects, set optimization options in the Save For Web dialog box.
   • For Smart PDF objects, click the Rotate Left button or the Rotate Right button if needed. Then navigate to the desired page and click its thumbnail. (See “To navigate to a specific page or set of pages” on page 395.)

See also
“Adding sliced Photoshop images” on page 377
“Choosing a format for Illustrator source files” on page 380

To add Smart Objects to CSS styles
If you use images in CSS backgrounds and lists, automate your workflow by optimizing Smart Objects in the site window; then reference the target file in the CSS editor. If you revise the source file in the future, GoLive can automatically reoptimize the target file and update styles that contain it.
1. In the Extras tab of the site window, select the source file in the Smart Objects folder.
2. In the Smart tab of the File Inspector, click Create Smart Object.
   Alternatively, drag the source file from the Extras tab to the Files tab.
See also

“To optimize and save web graphics” on page 365
“Storing Smart Object files” on page 359
“To update site files that are dependent on site extras” on page 210

To copy Smart Objects
When you copy a Smart Object to a different location, the copy uses the same source and target files as the original. If you want to independently resize and optimize a copy, you can later create a unique target file.

1 Copy a Smart Object to a different location.
2 If desired, create a unique target file for the copy: In the Basic tab of the Image Inspector, click the folder icon to the right of the Target text box.

Note: If a copied Smart Object shares a target file, GoLive displays a warning icon in the upper-left corner of the image. This warning doesn’t indicate a problem with the site; it simply informs you that resizing or reoptimizing the copy will change all related Smart Objects. To locate related copies throughout a site, see “To find the source of Smart Object warnings” on page 235.

See also

“About Smart Object source and target files” on page 358
“Storing Smart Object files” on page 359

Updating and editing Smart Objects

To change the matte color of Smart Objects
To create the illusion of transparency on a page, you can change the matte color of a Smart Object to match the background color of the page. (In the target file, the matte color replaces transparency found in the source file.)

1 In the Layout Editor, select the Smart Object.
2 In the Basic tab of the Smart Image Inspector, specify a color in the Matte color box.
3 Click Apply.

Note: Smart Illustrator objects that use SVG or SWF format do not support matte color.

To configure GoLive to open source files in a separate application

1 Choose Edit > Preferences (Windows) or GoLive > Preferences (Mac OS).
2 In the list on the left, select General.
3 Select Launch Other Applications To Edit Media Files.

See also

“About Smart Object source and target files” on page 358
To edit a Smart Object source file
1 Double-click the Smart Object in the Layout Editor or the source file in the site window.
2 In the native application, edit and resave the file.

Note: In Windows, an SVG file opens in the default browser. To change this behavior, use the Web Settings dialog box to map a different application to SVG files.

See also
"About GoLive Web Settings" on page 640
"About Smart Object source and target files" on page 358

To update target files for an edited source file
❖ Do either of the following:
• Open any pages that contain the target files.
• Use the Update Files Dependent On command. For more information, see “To update site files that are dependent on site extras” on page 210.

See also
"About Smart Object source and target files” on page 358

To reoptimize Smart Object target files
1 Select the Smart Object in the Layout Editor or the target file in the site window.
2 Click the Settings button in the Inspector.
3 Specify new settings in the Save For Web dialog box.

See also
"About Smart Object source and target files” on page 358

To find Smart Object target files
1 In the Extras tab of the site window, select the source file in the Smart Objects folder.
2 In the Smart tab of the File Inspector, click Show Targets.
3 In the In & Out Links palette, note related target files.

See also
"Using the In & Out Links palette to view links” on page 232
To convert Smart Objects to regular image objects
You can convert a Smart Object to a regular image object to unlink the source and target files. When these files are unlinked, changes to the source do not affect the target.

1 Right-click (Windows) or Control-click (Mac OS) a Smart Object.
2 Do one of the following:
   • If your Smart Object is a bitmap image, choose Convert To Regular Image.
   • If your Smart Object is an image in SVG or SWF format, choose Convert To Regular Plugin.
   • If your Smart Object is a sliced Photoshop or Illustrator image, choose Convert To Regular Table.

See also
“Advantages of Smart Objects” on page 358

To set preferences for Smart Objects
1 Choose Edit > Preferences (Windows) or GoLive > Preferences (Mac OS), expand Images, and select Smart Objects.
2 Do any of the following:
   • To reoptimize edited source files when you open pages, select Check For Updates When Opening A Page.
   • To convert large JPEG or GIF images into Smart Objects, select Automatically Convert Large Web Safe Images To Smart Objects. Then enter the required pixel width or height, and select Ask Before Converting if desired.
     The option above is particularly helpful for large images imported from digital cameras.
   • To prevent GoLive from uploading optimization settings files, select Set Publish State Of Settings File (.opt) To Never Publish.
     Deselect the option above only if you plan to share source and target files with other GoLive users.

Resizing and cropping Smart Objects

Resizing Smart Objects
To resize a Smart Object, you can simply drag one of its resizing handles. When you release the mouse, GoLive regenerates the target file using the last-applied optimization settings.

Resizing sliced images is also very easy with Smart Objects. When you resize a sliced Smart Object, GoLive automatically generates a new table and reoptimizes each slice.

Note: Because the SWF and SVG formats are vector-based and scalable, target files in those formats are not reoptimized.
To resize a Smart Object
❖ In the Layout Editor, select the object, and then do one of the following:
• To change width or height, drag a side handle.
• To change both dimensions, drag a corner handle. (To resize proportionately, hold down Shift while dragging or click the Constrain Proportions button  in the Smart Image Inspector.)

To return a resized Smart Object to its original size, in the Basic tab of the Smart Image Inspector, click the Set To Original Size button  .

To fit Smart Objects in smaller table cells and template regions
❖ In the Basic tab of the Smart Image Inspector, choose one of the following from the Scale menu:
Exact Fit  Disproportionately scales the image to the cell or region borders.
No Border  Proportionately crops the image at cell or region borders.
Show All  Proportionately scales the image to the largest size that fits the cell or region.

To crop a Smart Object
With Smart Objects, you can create multiple cropped versions of a single source file—without leaving GoLive.

1 In the Layout Editor, select the object.
2 In the Smart Image Inspector, click the Crop button  .
3 In the Layout Editor, drag across the object to define crop boundaries.
4 To refine the position of crop boundaries, do any of the following:
   • In the Layout Editor, place the cursor inside the crop boundaries, and drag with the Hand tool.
   • In the toolbar, enter pixel coordinates in the Horizontal Position or Vertical Position text boxes.
   • In the toolbar, click the Open Alignment Palette button  , and then click one or more Align To Parent options.
     (See “To align objects in relation to their container” on page 251.)
5 To refine the size of crop boundaries, do one of the following:
• In the Layout Editor, place the cursor over a corner or side handle, and drag.
• In the toolbar, enter pixel dimensions in the Width and Height text boxes.

6 To place crop boundaries at opaque image edges, click one of the following buttons in the toolbar:
• Crop Left Transparent Pixels .
• Crop Right Transparent Pixels .
• Crop Top Transparent Pixels .
• Crop Bottom Transparent Pixels .
• Crop All Transparent Pixels .

7 From the scaling menu in the toolbar, choose one of the following options:
Keep Scaling Maintains the current scale of the target image relative to the source image.
Keep Object Size Resamples the cropped area so it fills the current image dimensions.
Scale To Source File Scales the cropped area to its dimensions in the original source file.

Note: If you use the Keep Size option, the image may become blurry.

8 To apply the crop, either click the Crop Image button in the toolbar, or press Enter (Windows) or Return (Mac OS).

To cancel crop boundaries for a Smart Object
Click the Cancel button in the toolbar, or press the Esc key.

To restore a cropped Smart Object to its original size
1 In the Layout Editor, select the object.
2 In the Smart Image Inspector, click the Crop button .
3 In the toolbar, click the Use Original Image button .

Optimizing and saving web graphics

To optimize and save web graphics
Optimization is the process of compressing and setting display options for web graphics. You use the Save For Web dialog box to optimize, preview, and save web graphics.

1 At the top of the Save For Web dialog box, click a tab to select a display option: Optimized, 2-Up, or 4-Up. If you select 4-Up, click the preview you want to optimize.

2 If your artwork contains multiple slices, select one or more slices you want to optimize.

3 Select a preset optimization setting from the Preset menu, or set individual optimization options. The available options change depending on the file format you select. (See “Comparing web graphics formats” on page 369.)

If you're working in 4-Up mode, choose Repopulate Views from the Optimize menu to have GoLive automatically generate lower-quality versions of the image after you change the optimization settings.
4 Fine-tune the optimization settings until you are satisfied with the balance of image quality and file size. If your artwork contains multiple slices, be sure to optimize all the slices.

   To reset optimization settings to the last saved version, press Alt (Windows) or Option (Mac OS), and click Reset.

5 Click Save.

6 Enter a file name, select a location, and then click Save.

Note: When you optimize a PSD file with slices or rollovers, GoLive saves the containing .data folder. To avoid duplicating files in your site, do not move saved images out of this target folder; GoLive will replace its contents when you next update the related Smart Object.

See also
“Using slices” on page 368

To estimate the download time for a web graphic
1 In the Save For Web dialog box, select your optimization settings.
2 Select an Internet access speed from the Preview menu above the optimized image.

The estimated download time is displayed under the optimized image. If the download time seems too long, try different optimization settings or change the image size in the Save For Web dialog box.

See also
“Comparing web graphics formats” on page 369

To compress a web graphic to a specific file size
1 Click a tab at the top of the Save For Web dialog box to select a display option: Optimized, 2-Up, or 4-Up. If you select 4-Up, select the preview you want to optimize.
2 (Optional) Select the slices you want to optimize and the file format you want to use.
3 Select Optimize To File Size from the Optimize menu (to the right of the Settings menu).
4 Enter the desired file size.
5 Select a Start With option:
   Current Settings Uses the current file format.
   Auto Select GIF/JPEG GoLive automatically selects the format.
6 Select a Use option to specify how you want GoLive to apply the file size to slices in your artwork, and click OK.

See also
“To optimize and save web graphics” on page 365
“Comparing web graphics formats” on page 369
To resize web graphics
You can use the Image Size palette in the Save For Web dialog box to change the pixel dimensions of web graphics.

1. Click the Image Size tab in the Save For Web dialog box.
2. Enter new pixel dimensions or specify a percentage by which to resize the image.
3. Set any of the following options, and click Apply:
   - **Constrain Proportions** Maintains the current proportions of pixel width to pixel height.
   - **Quality** Choose from the following resampling methods:
     - **Nearest Neighbor** Resamples quickly but imprecisely. This method preserves hard edges and produces a smaller file size.
     - **Bilinear** Resamples moderately quickly and precisely.
     - **Bicubic** Resamples slowly but precisely. This method results in the smoothest tonal gradations.
     - **Bicubic Smoother** Greatly enlarges images.
     - **Bicubic Sharper** Greatly reduces images.

See also
“To optimize and save web graphics” on page 365
“Comparing web graphics formats” on page 369

To preview optimized images in a web browser
You can preview an optimized image in any web browser installed on your system. The browser preview displays the image with a caption listing the image’s file type, pixel dimensions, file size, compression specifications, and other HTML information.

- To preview an image in your default web browser, click the browser icon at the bottom of the Save For Web dialog box.
- To select a different browser, select Other from the browser pop-up menu (next to the browser icon).
- To add, edit, or remove a browser in the browser pop-up menu, select Edit List from the browser pop-up menu.

See also
“To optimize and save web graphics” on page 365
“Comparing web graphics formats” on page 369

To create or delete optimization presets
You can save optimization settings as a preset to apply the settings to other images. Presets appear in the Settings pop-up menu of the Save For Web dialog box.

- To create a new preset, select Save Settings from the Optimize menu (to the right of the Settings menu). Name the settings, and select a location where they will be saved. By default, named settings are saved in the Settings/SaveForWeb/Optimize folder inside the Adobe GoLive application folder.
- To delete a preset, select the preset from Settings menu, and select Delete Settings from the Optimize menu.
See also

“To optimize and save web graphics” on page 365
“Comparing web graphics formats” on page 369

Working with slices during optimization

Using slices
If your Photoshop PSD or Illustrator SVG file contains slices, you can specify unique optimization settings for each slice. You can also share optimization settings between slices by linking slices together. Linked slices in GIF and PNG-8 format share a color palette and dither pattern to prevent the appearance of seams between the slices.

For each slice, you can also add a URL link, Alt text, a status message, and a background color.

To show or hide slices in the Save For Web dialog box
❖ Click the Toggle Slice Visibility button.

To select slices in the Save For Web dialog box
1 Select the Slice Select tool.
2 Click a slice to select it. Shift-click or Shift-drag to select multiple slices.

To set options for a user slice
1 Double-click the slice with the Slice Select tool.
2 In the Slice Options dialog box, do any of the following, and click OK:
   • Type the slice name in the Name text box. By default, GoLive uses the slice name as the file name when you save the web page.
   • Specify a URL to make the slice area a hotspot in your web page. You can type a relative URL or a full URL (including http://), or choose a previously created URL from the pop-up menu.
   • If you specified a URL, specify the frame you want the link to target in the Target text box. You can type the name of a target frame, or choose a standard option from the pop-up menu.
   • Type text in the Message text box that will appear in the browser's status area when the mouse is positioned over an image.
   • Type text in the Alt text box that will appear in place of image data in nongraphical browsers (and will be used by voice-recognition software).
   • Choose a color that will appear in the slice area of your web page from the Background pop-up menu.
**Web graphics formats and options**

**Comparing web graphics formats**

Web graphics formats fall into two categories: bitmap and vector. The bitmap formats—GIF, JPEG, PNG, and WBMP—describe artwork as a series of colored dots called pixels. Each pixel in a bitmap image has a fixed size and is therefore resolution-dependent, meaning that dimensions of the image depend on the resolution of the monitor on which it is viewed. The vector formats—SVG and SWF—describe artwork mathematically, as a set of geometric objects. Because of this, vector graphics are resolution-independent and can be scaled up or down without losing any image quality.

**GIF and PNG-8**

GIF is the standard format for compressing images with flat color and crisp detail, such as line art, logos, or illustrations with type. Like the GIF format, the PNG-8 format efficiently compresses solid areas of color while preserving sharp detail; however, not all web browsers can display PNG-8 files. (See “Optimization options for GIF and PNG-8 formats” on page 370.)

*Note:* When optimizing images for i-mode cellphones, use GIF format. For more information, see “To add images to i-mode pages” on page 472.

PNG-8 and GIF files support 8-bit color, so they can display up to 256 colors. The process of determining which colors to use is called indexing, so images in GIF and PNG-8 formats are sometimes called indexed color images. To convert an image to indexed color, GoLive builds a color lookup table, which stores and indexes the colors in the image. If a color in the original image does not appear in the color lookup table, the application either chooses the closest color in the table or simulates the color using a combination of available colors. (See “To customize the color table for GIF and PNG-8 images” on page 372.)

**JPEG**

JPEG is the standard format for compressing continuous-tone images such as photographs. Optimizing an image as a JPEG format relies on lossy compression, which selectively discards data. (See “Optimization options for JPEG format” on page 373.)

**JPEG2000**

The JPEG2000 format builds on the JPEG standard with improved compression schemes and performance.

GoLive can import JPEG2000 files, but not create them. Though you use the Image object to import standard JPEG files, JPEG2000 files require the generic Plug-in object. (See “Adding multimedia” on page 349.)

*Note:* To display JPEG2000 files, most browsers require an additional plug-in.

**PNG-24**

PNG-24 is suitable for compressing continuous-tone images; however, it produces much larger files than JPEG format. The advantage of PNG-24 is that it can preserve up to 256 levels of transparency in an image. (See “Optimization options for PNG-24 format” on page 374.)

*Note:* Internet Explorer for Windows doesn’t support transparency in PNG-24 files.
SWF
The Macromedia® Flash™ (SWF) file format is a vector-based graphics file format for the creation of scalable, compact graphics for the web. Since the file format is vector-based, the artwork maintains its image quality at any resolution and is ideal for the creation of animation frames. (See “Setting optimization options for SVG and SWF files” on page 382.)

SVG
SVG is a vector format that describes images as shapes, paths, text, and filter effects. The resulting files are compact and provide high-quality graphics on the web, in print, and even on resource-constrained, handheld devices. (See “Setting optimization options for SVG and SWF files” on page 382.)

WBMP
WBMP format is the standard format for optimizing images for mobile devices, such as cell phones. WBMP supports 1-bit color, which means that WBMP images contain only black and white pixels. (See “Optimization options for WBMP format” on page 374.)

See also
“To optimize and save web graphics” on page 365

Optimization options for GIF and PNG-8 formats

Lossy (GIF only) Reduces file size by selectively discarding data. A higher Lossy setting results in more data being discarded. You can often apply a Lossy value of 5–10, and sometimes up to 50, without degrading the image. File size can often be reduced 5%–40% using the Lossy option.

Note: You cannot use the Lossy option with the Interlaced option or with Noise or Pattern Dither algorithms.

Color Reduction Method and Colors Specifies a method for generating the color lookup table and the number of colors you want in it. You can select one of the following color reduction methods:

- **Perceptual** Creates a custom color table by giving priority to colors for which the human eye has greater sensitivity.
- **Selective** Creates a color table similar to the Perceptual color table, but favoring broad areas of color and the preservation of web colors. This color table usually produces images with the greatest color integrity. Selective is the default option.
- **Adaptive** Creates a custom color table by sampling colors from the spectrum appearing most commonly in the image. For example, an image with only the colors green and blue produces a color table made primarily of greens and blues. Most images concentrate colors in particular areas of the spectrum.
• **Restrictive (Web)** Uses the standard 216-color color table common to the Windows and Mac OS 8-bit (256-color) palettes. This option ensures that no browser dither is applied to colors when the image is displayed using 8-bit color. Using the web palette can create larger files and is recommended only for audiences using older 256-color monitors.

• **Custom** Preserves the current perceptual, selective, or adaptive color table as a fixed palette that does not update with changes to the image.

> *Use the Color Table palette in the Save For Web dialog box to customize the color lookup table.*

**Dithering Method and Dither** Determines the method and amount of application dithering. Dithering refers to the method of simulating colors not available in the color display system of your computer. A higher dithering percentage creates the appearance of more colors and more detail in an image, but can also increase the file size. For optimal compression, use the lowest percentage of dither that provides the color detail you require. Images with primarily solid colors may work well with no dither. Images with continuous-tone color (especially color gradients) may require dithering to prevent color banding.

You can select one of the following dithering methods:

• **Diffusion** Applies a random pattern that is usually less noticeable than Pattern dither. The dither effects are diffused across adjacent pixels.

• **Pattern** Applies a halftone-like square pattern to simulate any colors not in the color table.

• **Noise** Applies a random pattern similar to the Diffusion dither method, but without diffusing the pattern across adjacent pixels. No seams appear with the Noise dither method.

**Transparency and Matte** Determines how transparent pixels in the image are optimized.

• To make fully transparent pixels transparent and blend partially transparent pixels with a color, select Transparency and select a matte color.

• To make all pixels with greater than 50% transparency fully transparent and all pixels with 50% or less transparency fully opaque, select Transparency and select None from the Matte menu.

• To fill fully transparent pixels with a color and blend partially transparent pixels with the same color, select a matte color and deselect Transparency.

• To select a matte color, click the Matte color swatch and select a color in the color picker. Alternatively, select an option from the Matte menu: Eyedropper (to use the color in the eyedropper sample box), White, Black, or Other (to use the color picker).

**Interlace** Creates an image that displays as a low-resolution version in a browser while the full image file is downloading. Interlacing can make downloading time seem shorter and can assure viewers that downloading is in progress. However, interlacing also increases file size.

**Web Snap** Specifies a tolerance level for shifting colors to the closest web palette equivalents (and prevent the colors from dithering in a browser). A higher value shifts more colors.

**See also**

“To optimize and save web graphics” on page 365

“Comparing web graphics formats” on page 369
To customize the color table for GIF and PNG-8 images

You use the Color Table palette in the Save For Web dialog box to customize the colors in optimized GIF and PNG-8 images. With a maximum of 256 colors, you can add and delete colors in the color table, shift selected colors to web-safe colors, and lock selected colors to prevent them from being dropped from the palette.

- To add new colors to the color table, select the Eyedropper tool, and click a color in the image. (Alternatively, click the color selection box, and use the color picker to select a color.) Then, click the New Color button in the Color Table palette. A small white square with a dark center appears in the lower right corner of the new color, indicating that the color is locked.

Note: If the color table already contains the maximum number of colors (256, or 255 with transparency), you cannot add a new color.

- To change a color in the color table, double-click it. A small plus sign appears in the center of each edited color.

- To delete a color from the color table, select the color and click the Delete button. When you delete a color, areas of the optimized image that previously included that color are re-rendered using the closest color remaining in the palette. Deleting a color changes the color palette type to Custom to prevent the color from being added back to the palette if you reoptimize the image.

- To shift a color to a web-safe color, select the color and click the Web Shift button. A small white diamond appears in the center of selected colors that have been web-shifted (and in all web-safe colors). To restore a shifted color to its original value, click the Web Shift button again. Alternatively, select Shift/Unshift Selected Colors To/From Web Palette or Unshift All Colors from the Color Table palette menu. To specify a tolerance for shifting colors, specify a value for Web Snap in the Settings section of the Save For Web dialog box. A higher value shifts more colors.

- To lock a color so that it won’t be dropped from the color table if you reduce the number, select the color and click the Lock button. A white square with a red center appears in the lower right corner of each locked color. To unlock a color, click the Lock button again. To unlock all colors, select Unlock All Colors from the Color Table palette menu.

- To select multiple colors in the color table, press Shift and click another color. All colors in the rows between the first and second selected colors are selected. To select a nonadjacent group of colors, press Ctrl (Windows) or Command (Mac OS) and click each color that you want to select. The Color Table palette menu also provides commands for selecting colors.

- To sort the colors in the color table, select a sorting command from the Color Table palette menu. You can sort colors by hue (neutral colors are assigned a hue of 0 and located with the reds), luminance (the lightness or brightness of a color), or popularity, making it easier to see an image’s color range and locate particular colors.

- To save a color table, select Save Color Table from the Color Table palette menu. By default, the color table file is given the extension .act (for Adobe Color Table).

- To load a color table, select Load Color Table from the Color Table palette menu. You can load a color table from an .act file or a GIF file (to load the file’s embedded color table). Once you load a new color table, the colors in the optimized image change to reflect the new color table.

See also

“To optimize and save web graphics” on page 365

“Comparing web graphics formats” on page 369
Optimization options for JPEG format

**Quality**  Determines the level of compression. The higher the Quality setting, the more detail the compression algorithm preserves. However, using a high Quality setting results in a larger file size than using a low Quality setting. View the optimized image at several quality settings to determine the best balance of quality and file size.

**Optimized**  Creates an enhanced JPEG with a slightly smaller file size. The Optimized JPEG format is recommended for maximum file compression; however, some older browsers do not support this feature.

**Progressive**  Creates an image that displays progressively in a web browser. The image will display as a series of overlays, enabling viewers to see a low-resolution version of the image before it downloads completely. The Progressive option requires use of the Optimized JPEG format.

*Note: Progressive JPEGs require more RAM for viewing, and are not supported by some browsers.*

**Blur**  Specifies the amount of blur to apply to the image. This option applies an effect identical to that of the Gaussian Blur filter and allows the file to be compressed more, resulting in a smaller file size. A setting of 0.1 to 0.5 is recommended.

**ICC Profile**  Preserves the ICC profile of the artwork with the file. ICC profiles are used by some browsers for color correction. This option is only available if the source file contains an ICC profile.

**Matte**  Specifies a fill color for pixels that were transparent in the original image. Click the Matte color swatch to select a color in the color picker, or select an option from the Matte menu: Eyedropper (to use the color in the eyedropper sample box), White, Black, or Other (to use the Color Picker).

Pixels that were fully transparent in the original image are filled with the selected color; pixels that were partially transparent in the original image are blended with the selected color.

**See also**

“To optimize and save web graphics” on page 365

“Comparing web graphics formats” on page 369
Optimization options for PNG-24 format

Transparency and Matte  Determines how transparent pixels in the image are optimized:

- To save an image with multilevel transparency, select Transparency.
- To fill fully transparent pixels with a color and blend partially transparent pixels with the same color, deselect Transparency and select a matte color.
- To select a matte color, click the Matte color swatch and select a color in the color picker. Alternatively, select an option from the Matte menu: Eyedropper (to use the color in the eyedropper sample box), White, Black, or Other (to use the Color Picker).

Interlace  Creates an image that displays as a low-resolution version in a browser while the full image file is downloading. Interlacing can make downloading time seem shorter and can assure viewers that downloading is in progress. However, interlacing also increases file size.

See also

“To optimize and save web graphics” on page 365
“Comparing web graphics formats” on page 369

Optimization options for WBMP format

The Dithering Method and Dither options determine the method and amount of application dithering. For optimal compression, use the lowest percentage of dither that provides the detail you require.

You can select one of the following dithering methods:

No Dither  Applies no dithering at all and gives straight black and white pixels.

Diffusion  Applies a random pattern that is usually less noticeable than Pattern dither. The dither effects are diffused across adjacent pixels. If you select this algorithm, specify a Dither percentage to control the amount of dithering that is applied to the image.

Note: Diffusion dither may cause detectable seams to appear across slice boundaries. Linking slices diffuses the dither pattern across all linked slices, and eliminates the seams.

Pattern  Applies a halftone-like square pattern to determine the value of pixels.

Noise  Applies a random pattern similar to the Diffusion dithering, but without diffusing the pattern across adjacent pixels. No seams appear with the Noise algorithm.

See also

“To optimize and save web graphics” on page 365
“Comparing web graphics formats” on page 369
Output settings for web graphics

Output settings control how slices and files are named and formatted when you save an optimized image. To view output settings, select Edit Output Settings from the Optimize menu (to the right of the Settings menu) in the Save For Web dialog box.

The Output Settings dialog box contains two sets of options: Slices and Saving Files. To switch to a different set of options, use the menu below the Settings menu.

See also
“To optimize and save web graphics” on page 365
“Comparing web graphics formats” on page 369

Slices output settings

You can set the following options in the Slices options in the Output Settings dialog box:

Generate Table Controls the layout of slices using an HTML table, rather than a Cascading Style Sheet.

Empty Cells Specifies how empty slices are converted to table cells. Select GIF, IMG W&H to use a 1-pixel GIF with width and height values specified in the IMG tag. Select GIF, TD W&H to use a 1-pixel GIF with width and height values specified by the table cell (TD tag). Select NoWrap, TD W&H to place a nonstandard NoWrap attribute on the table data and also place width and height values specified on the TD tags.

TD W&H Specifies when to include width and height attributes for table data: Always, Never, or Auto (the recommended setting).

Spacer Cells Specifies when to add one row and one column of empty spacer cells around the generated table: Always, Never, or Auto (the recommended setting). Adding spacer cells is necessary with table layouts in which slice boundaries do not align, to prevent the table from breaking apart in some browsers.

Default Slice Naming Choose elements from the pop-up menus or enter text into the boxes to be combined into the default names for all user slices. Elements include document name, the word slice, numbers or letters designating slices or rollover states, slice creation date, punctuation, or none.

See also
“Output settings for web graphics” on page 375
“To optimize and save web graphics” on page 365
**Saving Files output settings**

You set the following options in the Saving Files set of the Output Settings dialog box:

**File Naming**  Choose elements from the pop-up menus or enter text into the boxes to be combined into the default names for all files. Elements include document name, slice name, rollover state, trigger slice, file creation date, slice number, punctuation, and file extension. Some options are relevant only if the file contains slices or rollover states.

The text boxes let you change the order and formatting of the file-name parts (for example, letting you indicate rollover state by an abbreviation instead of the full word).

**Filename Compatibility**  Select one or multiple options to make the file name compatible with Windows (permits longer file names), Macintosh, and UNIX operating systems.

**Put Images In Folder**  Specifies a folder name where optimized images are saved (available only with documents containing multiple slices).

**Copy Background Image When Saving**  Preserves a background image that has been specified in the Background preferences set.

**Include Copyright**  Includes copyright information with the image.

**See also**

"Output settings for web graphics" on page 375

“To optimize and save web graphics” on page 365

“To add metadata to a document” on page 173
Chapter 16: Adding content from Adobe applications

Adding Adobe Photoshop images

Adding sliced Photoshop images
To add a sliced Photoshop image to a page, use the Smart Photoshop object 🛠️. After you specify the source Photoshop file and optimize each slice in the Save For Web dialog box, GoLive automatically creates a table to contain the sliced image.

GoLive adds the optimized target file for each slice to an `image_name`.data folder. Save this folder in the site folder so that GoLive can properly manage and publish the target files.

Note: To edit the table attributes of a sliced Photoshop file, you must use Photoshop.

See also
"Using slices" on page 368
"To add Smart Objects to pages" on page 360
"Advantages of Smart Objects" on page 358

Importing layered Photoshop images
GoLive lets you import Photoshop layered images so that each layer in the image is converted into an appropriate web-safe format of your choosing. The imported Photoshop layers appear in the web page as separate GoLive layers, which you can later convert to a layout grid or table if they don't overlap.

Note: This method of importing Photoshop images doesn't involve Smart Photoshop objects, which are flattened into one layer. In other respects, however, Smart Photoshop objects are more flexible.

GoLive uses Photoshop layer names to generate names for the corresponding GoLive layers. Because some browsers incorrectly interpret GoLive layers with names that begin with numbers, avoid creating layer names that begin with numbers in Adobe Photoshop. (If necessary, you can change the names of GoLive layers after importing a layered Photoshop file.)
See also
“About GoLive layers” on page 253
“Advantages of Smart Objects” on page 358

To import a layered Photoshop image
1 Choose File > Import > Photoshop Layers.
2 Select the folder where you want to save the layers, and click Open.
3 In the Save For Web dialog box, choose the optimization settings you want for the first layer, and then do one of the following:
   • Click Save. GoLive adds the first layer as a lowest layer on the page, and then opens the Save For Web dialog box for each remaining layer. Repeat the process of choosing an optimization setting and clicking Save for each layer. Each Photoshop layer is placed in a separate GoLive layer in the Layout Editor.
   • Hold down the Ctrl key and click Save All. Save All applies the same settings to all layers in the imported Photoshop file. Each layer is placed in a separate layer in the Layout Editor.  

   Note: Clicking Cancel only cancels the import process for the current layer. Press Ctrl while clicking Cancel to cancel the import process for all remaining layers.

Creating variations of images
In GoLive, variables let you create multiple image versions from one image file. You first establish variables in Photoshop; then you edit them in GoLive by using Smart Objects. Variables can control elements such as text content and layer visibility. For example, you might have an image with text containing the price of an item. If you want to quickly modify the price, there’s no need to create separate image files in another application. Instead, you can simply modify a text variable in GoLive.
Creating different versions of an image using variables
A. Source file  B. Variables palette in Photoshop  C. Different optimized versions in separate target files, each with different variable settings

The power of variables is that you can create more than one target file, each with different images and text created by assigning different variable settings. Because variables use Smart Objects, you can edit the source file and quickly update all related versions throughout your site. (See “To update site files that are dependent on site extras” on page 210.)

To set variables in a Photoshop file
In a Photoshop file with variables, you can change the content of text layers and the visibility of image layers.

If you import a file with text layers, GoLive automatically imports the topmost text layer as a text variable. GoLive can also import lower text layers as text variables, but only if you first assign variables to the layers in Photoshop.

1 Using a Smart Photoshop object 🔄, add a PSD file with a text layer to the Layout Editor.
2 In the Variable Settings dialog box, do any of the following:
   • To change the original text, select the Use option for the text variable and enter text in the text box.
   • To specify whether the layer is visible or invisible in the target file, select the Use option for the image layer, and then choose an option from the menu.
   • To accept the original layer as is, leave the Use option deselected.

   **Important:** If you select the Use option for a text variable and don’t enter any text, the original text is deleted. GoLive will treat the empty text box as the new value of the text variable.

For information about assigning variables in a Photoshop file, see Photoshop Help.

To update variables in a target file
After you create a target file containing variables, you can update those variables at any time.

1 In the Layout Editor, select the Smart Object that contains the variables.
2 In the Smart Image Inspector, click the Variables button.
3 Make the desired changes in the Variable Settings dialog box, and click OK.
Converting text to an image

You can convert HTML text into an image using the Convert Text To Banner command. This command replaces the HTML text with a Smart Object and requires a Photoshop PSD file with variables.

![Diagram of text conversion process]

Converting text to an image
A. HTML text selected in Layout Editor  B. Source file with text variable  C. Target file replaces original HTML text

See also
“Creating variations of images” on page 378

To convert text to an image
1 Select text in the Layout Editor.
2 Choose Special > Convert > Text To Banner. GoLive replaces the text with a Smart Object.
3 Specify a Photoshop PSD source file with variables, and click Open.
4 To change the text, edit it in the text box of the Variables Settings dialog box.
5 Set optimization options in the Save For Web dialog box.

See also
“Creating variations of images” on page 378
“To set variables in a Photoshop file” on page 379

Adding Adobe Illustrator artwork

Choosing a format for Illustrator source files

For Smart Illustrator objects, you can use source files in AI or SVG format. From AI source files, you can create optimized target files in both vector and bitmap formats. SVG source files require target files in bitmap formats. Use SVG source files if you want to edit slices created in Illustrator.

Note: GoLive does not support multilayered Illustrator files. Layered Illustrator images are flattened during the optimization and conversion process.
See also
“About Smart Object source and target files” on page 358

Choosing a format for Illustrator target files
From an Illustrator AI source file, you can create target files in either the bitmap GIF, JPEG, PNG, or WBMP formats; or the vector SVG, SVGZ, or SWF formats. From an Illustrator SVG source file, you can create target files only in the bitmap formats.

When you specify an AI source file, you must choose between the bitmap and vector optimized formats. If you choose the bitmap formats, you optimize the file in the Save For Web dialog box. If you choose the vector formats, you optimize the file in Illustrator.

To specify a target format for an AI file
1 In the Layout Editor, add a Smart Illustrator object  
2 In the Basic tab of the Smart Illustrator Image Inspector, reference the AI file in the Source text box.
3 In the Conversion Settings dialog box, choose one of the following:
   Bitmap Formats Opens the Save For Web dialog box so you can optimize the file in GIF, JPEG, PNG, or WBMP format.
   SVG or SVG Compressed Opens Illustrator so you can set optimization options in the SVG Options dialog box. (SVG Compressed creates an SVGZ file.)
   SWF Opens Illustrator so you can set optimization options in the Macromedia Flash (SWF) Format Options dialog box.

See also
“Choosing a format for Illustrator target files” on page 381
“Setting optimization options for SVG and SWF files” on page 382

Adding sliced Illustrator SVG images
If you use a Smart Illustrator object, GoLive can work with slices established in Illustrator SVG files. As with sliced Photoshop images, you can assign links to slices and optimize them independently.

GoLive saves the optimized target file for each slice in an image_name.data folder. Place this folder in the site folder so that GoLive can properly manage and publish the target files.

See also
“Using slices” on page 368

To update links in an SVG file
GoLive can track links in Illustrator SVG files. If a link destination moves, GoLive automatically prompts you to update the link.

1 In the Layout Editor, select the SVG object that contains the link.
2 In the In & Out Links palette, specify the link destination.
It's useful to click the External tab in the site window so you can view any redirected external links.

Setting optimization options for SVG and SWF files
When you optimize a Smart Illustrator object in SVG or SWF format, GoLive opens Illustrator so you can access several advanced optimization options. In an SVG file, for example, you can store subsets of fonts and preserve Illustrator-specific data. In an SWF file, you can export Illustrator layers to SWF frames, specify the frame rate, and more.

Optimization options for SVG format
The SVG Options dialog box opens when you add a Smart Illustrator object to the Layout Editor and save the object in SVG format. SVG files can contain sophisticated elements created in Illustrator, such as gradients, animation, and filter effects. (For more information, search for “SVG format” in Illustrator Help.)

DTD Specifies the DTD (Document Type Definition) for the exported file:
- SVG 1.0 and SVG 1.1 Suitable for SVG files that will be viewed on a desktop computer.
- SVG Tiny 1.1 Suitable for SVG files that will be viewed on small devices, such as mobile phones. Does not support gradients, transparency, clipping, masks, symbols, or SVG filter effects.
- SVG Basic 1.1 Suitable for SVG files that will be viewed on medium-powered devices, such as handhelds. Does not support nonrectangular clipping and some SVG filter effects.

Font Type Specifies how fonts are exported. Choose from the following options:
- Adobe CEF Uses font hinting for better rendering of small fonts. This font type is supported by the Adobe SVG Viewer but may not be supported by other SVG viewers.
- SVG Does not use font hinting. This font type is supported by all SVG viewers.
- Convert To Outlines Converts type to vector paths. Use this option to preserve the visual appearance of type in all SVG Viewers.

Font Subsetting Specifies a method for choosing which glyphs are saved with the SVG file. If you are likely to change the text content of the file—for example, if you plan to set variables—do not choose None (Use System Fonts) or Only Glyphs Used; choose one of the other options.
- None (Use System Fonts) Omits all fonts, which keeps the file size as small as possible. However, this setting relies on the fonts being installed on the user's system.
- Only Glyphs Used Includes the set of glyphs for text that exists in the document. This option is not available for linked fonts. Do not use this option if the textual content of the SVG file might change.
- Common English Includes the set of English font characters.
- Common English & Glyphs Used Includes the set of English font characters plus all other glyphs used in the document.
- Common Roman Includes the set of roman-letter font characters.
- Common Roman & Glyphs Used Includes the set of roman-letter font characters plus all other glyphs used in this document.
- All Glyphs Includes the full set of English and roman-letter font characters.
Images Location  Determines whether images are embedded or linked. If your AI file contains a rasterized image, select Embed Images, not Link For Images. Embedding images increases file size but ensures that rasterized images will always be available for viewing by the user.

Preserve Illustrator Editing Capabilities  Preserves Illustrator-specific data in the SVG file.

Advanced SVG options
Click the More Options button in the SVG Options dialog box to access the following options.

CSS Properties  Determines how CSS style attributes are saved in the SVG code.

- **Presentation Attributes method (default)**  Applies properties at the highest point in the hierarchy, which allows the most flexibility for specific edits and transformations.

- **Style Attributes method**  Creates the most readable files but may increase the file size. Choose this method if the SVG code will be used in transformations—for example, transformations using Extensible Stylesheet Language Transformation (XSLT).

- **Entity References method**  Results in faster rendering times and reduced SVG file size.

- **Style Element method**  Is used when sharing files with HTML documents. By selecting Style Element, you can then modify the SVG file to move a style element into an external stylesheet file that is also referenced by the HTML file—however, the Style Element option also results in slower rendering speeds.

Decimal Places  Specifies the precision of vector data in the SVG file. You can set a value of 1 to 7 decimal places. A high value results in a larger file size and increased image quality.

Encoding  Choose a method from the Encoding pop-up menu to determine how to encode characters in the SVG file. ISO 8859-1 is suitable for most European languages, while UTF (Unicode Transformation Format) is preferred for non-roman languages. (UTF-8 is an 8-bit format and usually creates smaller files without losing any information compared to the 16-bit UTF-16 format.)

Optimize for Adobe SVG Viewer  Optimizes for the Adobe SVG viewer through an Adobe XML namespace. This option takes advantage of faster rendering for features such as filter effects.

Include Extended Syntax For Variable Data  Includes all information needed for variable substitution in the SVG file. Select this option if you’re exporting a template for use in AlterCast.

Include Slicing Data  Preserves slice locations and optimization settings.

Include XMP  Includes XMP metadata in the SVG file. Use the Adobe Bridge Browser to enter metadata.

Enable Auto Kerning  Prevents creation of a <tspan> element for auto- or optical-kerned text. The result is a smaller and more compact SVG <text> element.

Use SVG Text On Path  Exports text on path as a <textPath> element. Note that the text may appear differently in the SVG Viewer than it does in Illustrator. In particular, overflow text will be visible in the SVG Viewer.

See also
“About the Metadata panel in Bridge” on page 54
Optimization options for SWF format

The Macromedia Flash (SWF) Format Options dialog box opens when you add a Smart Illustrator object to the Layout Editor and save it in SWF format. Since SWF is a vector-based format, the artwork maintains its image quality at different resolutions and is ideal for the creation of animation frames. Although the SWF format uses vector data, it also uses bitmap data when appropriate. (For more information, search for “SWF format” in Illustrator Help.)

Export As Specifies how to convert Illustrator layers to SWF frames:

- **AI File To SWF File** Exports the artwork to a single frame. Select this option to preserve layer clipping masks.
- **AI Layers To SWF Frames** Exports the artwork on each layer to a separate SWF frame, creating an animated SWF.
- **AI Layers To SWF Files** Exports the artwork on each layer to a separate SWF file. The result is multiple SWF files, each containing a single frame with the artwork from a single Illustrator layer.

Generate HTML Writes HTML code for the SWF file, including its width and height. You can use this code to include the SWF file in a web page. The HTML file is saved to the same location as the SWF file.

Protect From Import Prohibits users from modifying the exported SWF file.

Clip To Artboard Size Exports the entire Illustrator document page (and any artwork within its borders) to the SWF file. Any artwork outside the page's borders will be clipped off.

Export Text As Outlines Converts type to vector paths. Use this option to preserve the visual appearance of type in all Flash players.

Compress File Compresses the SWF data, resulting in a smaller file size. Note that Flash players prior to Flash Player 7 can't display compressed files. Do not use this option if you're not sure what version of the Flash player the file will be viewed on.

Preserve Appearance or Preserve Editability Where Possible Select Preserve Appearance to flatten artwork to a single layer before exporting or Preserve Editability Where Possible to preserve as much layer editability as possible in the SWF file. (These options are only available for AI File To SWF File).

Choose Background Color Specifies a background color for the exported SWF file.

Curve Quality Determines the accuracy of the bezier curves. A low number decreases the exported file size with a slight loss of curve quality. A higher number increases the accuracy of the bezier curve reproduction, but results in a larger file size.

Frame Rate Specifies the rate at which the animation will be played in a Macromedia Flash viewer. (This option is only available for AI Layers To SWF Frames.)

Looping Causes the animation to loop continuously, rather than play once and then stop, when played in a Macromedia Flash viewer. (This option is only available for AI Layers To SWF Frames.)

Use As Background Specifies one or more layers or sublayers to use as a background for the animation. (This option is only available for AI Layers To SWF Frames.)

Layer Order Determines the timeline of the animation. Select Bottom Up to export layers starting with the bottommost layer in the Layers palette. Select Top Down to export layers starting with the topmost layer in the Layers palette. (This option is only available for AI Layers To SWF Frames.)
**Animate Blends**  Specifies whether or not to animate blended objects. Selecting this option produces the same results as manually releasing blended objects to layers before you export. If you select Animate Blends, select a method for exporting the blend:

- **In Sequence**  Exports each object in the blend to a separate frame in the animation.

- **In Build**  Builds up a cumulative sequence of objects in the animation frames. For example, the bottommost object in the blend appears in each of the frames, and the topmost object in the blend appears only in the last frame.

**Image Format**  Determines how the artwork is compressed. Lossless compression maintains the highest image quality but creates a large SWF file. Lossy (JPEG) compression creates a smaller SWF file but adds artifacts to the image. Select Lossless if you intend to continue to work on the file (or files) in Macromedia Flash; select Lossy if you're exporting the final SWF file.

**JPEG Quality**  Specifies the amount of detail in the exported image. The higher the quality, the larger the file size. (This option is only available if you choose Lossy compression.)

**Method**  Specifies the type of JPEG compression that is used. Baseline (Standard) applies the standard type of compression, while Baseline Optimized applies additional optimization. (These options are only available if you choose Lossy compression.)

**Resolution**  Adjusts the screen resolution for bitmap images. Resolution for exported SWF files can be 72 to 2400 pixels per inch (ppi). Higher resolution values result in better image quality but larger file sizes.

---

**Adding Adobe InDesign content**

**About InDesign packages**

With InDesign’s Package For GoLive feature, you can easily incorporate content from InDesign documents into GoLive pages and sites. From open InDesign packages, you can either drag individual text and graphic assets to web pages or export entire InDesign layouts to HTML. If you regularly revise package assets in InDesign, GoLive automatically updates related text and images using components and Smart Objects.

You can show and hide InDesign layers in GoLive’s Layers palette. In InDesign, consider placing web objects on a unique layer so you can control them independently from print objects.

**See also**

“Advantages of Smart Objects” on page 358

“Components” on page 427

**Importing InDesign packages**

If you plan to regularly update a package’s assets throughout a site, import the package into the site window. When you later update the package in InDesign, you can reimport it and use the Update Files Dependent On command to ensure that the site uses the most current package assets.

If you need to quickly import individual package assets that won’t later be updated in InDesign, you can import items individually without adding the entire package to a site. However, you must still store web-optimized CSS and media files in an Accessories folder on your hard disk.
To import a package into a site

When you import a package, GoLive adds it to the InDesignPackages folder in the Extras tab of the site window. From that location, you can automatically update package assets throughout a site (Choose Site > Update > Refresh All).

1. Open the site.
2. Choose File > Import > From InDesign, navigate to the package (.idpk) file, and then click OK.

To export a package directly to a site from InDesign, save the package in the site's web-data/InDesignPackages folder.

To open a previously imported package in a site

❖ In the Extras tab of the site window, double-click the InDesignPackages folder, and then double-click the folder for the package.

To import individual assets from a package

1. Choose File > Import > From InDesign, navigate to the package (.idpk) file, and then click OK.
2. If GoLive asks if you want to copy the package to an open site, click No.
3. When you drag the first asset to a web page, specify the location of the Accessories folder, which contains web-optimized CSS and media files.
See also

“Importing InDesign packages” on page 385

Using the InDesign package window

To add a package asset to a web page
❖ Drag the asset from the package window to the document window.

💡 If you can’t drag an asset from the InDesign Layout tab, ensure that its layer is visible in the Layers palette.

To view a different page of a package
❖ In the InDesign Layout or HTML Preview tab, do one of the following:

• Click the First Page button  , the Previous Page button  , the Next Page button  , or the Last Page button  .
• Type in the Page Number text box.

💡 You can also double-click page borders to view a different page. Double-click the left or top borders to view the previous page; double-click the right or bottom borders to view the next page.

To view package assets by category
1 In the package window, click the Assets tab.
2 Expand one or more asset categories (Stories, Images, Movies, or Sounds), and note information in these columns:

Asset  Shows asset names.
XML  Indicates XML tags, if any.
Content  Shows the content of text assets.
Used On Web Page  Indicates assets that are already used in the site.

Page  Shows an asset's location in the package. To see precisely where an asset appears on a page, right-click it, and select Reveal In InDesign Layout.

To view assets as alphabetized thumbnails
1  In the package window, click the Assets tab.
2  In the lower left of the window, click the View Thumbnail button.

To view assets with XML tags
If you use GoLive templates, InDesign's XML tags are particularly useful. When you drag tagged assets onto pages that use templates, GoLive automatically adds the assets to regions that use the tag name.
1  In the package window, click the XML tab.
2  Expand the Root element, and then note information in these columns:

  Tag  Shows tag names.
  Asset  Shows asset names.
  Content  Shows the content of text assets.
  Page  Shows an asset's location in the original package.

To color tagged assets in the InDesign Layout or HTML Preview tab, select Highlight Tagged Page Items in the View palette.

To zoom and select objects in package previews
  • To zoom in on an object, double-click it. (To zoom back out, double-click the object again.)
  • To select an object from a stack, right-click (Windows) or Control-click (Mac OS) the stack, and choose Select > [object name] from the context menu.

If you can't select an object in the InDesign Layout tab, ensure that its layer is visible in the Layers palette.

  • To prevent an object from being selected, right-click (Windows) or Control-click (Mac OS) the object, and choose Settings > Disable Page Item from the context menu.
  • To re-enable an object to be selected, right-click (Windows) or Control-click (Mac OS) the object in the package preview, and choose Settings > Delete Preferences For Page Item.

To edit the original InDesign document
  • From the package window menu, select Edit InDesign Document.
Adding graphics and images from InDesign packages

Adding graphics from InDesign packages
When you add graphic objects created in InDesign, such as polygons and rectangles, GoLive automatically converts them into Smart PDF objects. You can fine-tune optimization settings for these objects in the Smart PDF Image Inspector.

See also
“To reoptimize Smart Object target files” on page 362

Adding images from InDesign packages
When you create a package in InDesign, you can include image formatting, such as clipping paths and borders. GoLive lets you specify whether to retain this formatting and how to optimize images as Smart Objects.

Note: InDesign supports some image features, such as spot colors, that GoLive does not support. For more information, see InDesign Help.

See also
“Advantages of Smart Objects” on page 358

To add images from a package
1 In the package window, select one or more image assets.
2 In the Asset Conversion Settings Inspector, do the following:
   • Select Use Image With InDesign Formatting to retain formatting such as clipping paths and borders.
   • Select an optimization preset from the Web Format menu. (To customize a preset, select Open Save For Web Dialog.)
3 From the package window, drag the images to a web page.
   From the InDesign Layout or HTML Preview tabs, you can also copy images to web pages.

See also
“Adding images from InDesign packages” on page 389
“To optimize and save web graphics” on page 365
Adding text and tables from InDesign packages

Adding text and tables from InDesign

From InDesign packages, you can add text frames and tables as HTML text, Smart Components, or Smart PDF objects. You can quickly edit HTML text on web pages, but it ignores formatting and automatic updates from InDesign. To apply those features, use Smart Components or Smart PDF objects. Smart Components function similarly to other GoLive components, but to edit them you must use either GoLive's XML editor or Adobe InCopy. Smart PDF objects create image files, which are larger but let you resize extensively and use unusual fonts that many Internet viewers don't have installed.

When you add text assets to web pages, you can convert InDesign paragraph and character styles into CSS styles stored in either internal or external stylesheets. Internal stylesheets let you specify unique formatting for each web page; external stylesheets let you automatically reformat related package assets throughout a site. You can edit both types of stylesheets in the CSS editor. Be aware, however, that CSS doesn't preserve all InDesign character and paragraph attributes. For more information, see InDesign Help.

*Note:* The character encoding of the web page must match the character encoding specified in InDesign's Package For GoLive dialog box; otherwise, characters like apostrophes and curly quotation marks may drop out. For information about character encoding, see “To add elements or scripts to the head section” on page 163.

See also

“Components” on page 427

“Advantages of Smart Objects” on page 358

“To display the CSS Editor” on page 320

To add text or tables from an InDesign package

1. In the package window, select one or more text assets.
2. In the Asset Conversion Settings Inspector, select an Insert As option:
   - **Editable Text** inserts standard HTML text.
   - **Smart Component** inserts an XML component.
   - **Snapshot Image** inserts a Smart PDF object.
3. To specify formatting for editable text and Smart Components, select Use CSS Styles, and then select a Definition option:
   - **External CSS** adds InDesign styles to an external stylesheet that you specify in the Reference box. (By default, GoLive specifies a styles.css file in the package's Accessories folder.)
   - **Internal CSS** adds InDesign styles to a web page's internal stylesheet.
   - **None** removes InDesign formatting, but retains `<span>` tags so you can apply styles manually.
4. From the package window, drag the text assets to a web page.

   From the InDesign Layout or HTML Preview tabs, you can also copy text and tables to web pages.
See also
“Adding text and tables from InDesign” on page 390
“Adding text and tables from InDesign” on page 390

To crop text in a component” on page 428

To edit the default stylesheet for a package
❖ From the package window menu ( ), choose Package CSS > Edit, and then edit styles in the CSS Editor. (To revert to the original default stylesheet, choose Package CSS > Reset from the package window menu.)

See also
“Adding text and tables from InDesign” on page 390
“Adding text and tables from InDesign” on page 390

“Adding text and tables from InDesign” on page 390
“Adding text and tables from InDesign” on page 390

“Adding text and tables from InDesign” on page 390
“Adding text and tables from InDesign” on page 390

Exporting InDesign packages to HTML

Exporting packages to HTML
Sometimes a print design doesn't translate well to the web and on-screen viewing. With the HTML Preview for packages, however, you can optimize any InDesign document for HTML. By default, GoLive reflects the print layout in InDesign, but you can adjust layout scaling to fine-tune the relative proportions of images and text layers. You can also edit and preview CSS for text assets.

If you regularly add objects from a print design to related web pages, integrate InDesign XML tags with GoLive template regions. When you export to HTML, GoLive automatically adds tagged objects to regions of the same name. (For more information about InDesign tags, see InDesign Help.)
Changing layout scaling to adjust the relative proportions of text and image layers

See also

“About GoLive layers” on page 253

“Page templates” on page 420

To export a package to HTML

1 In the package window, click the HTML Preview tab.

2 Specify which assets to export:
   - To exclude a text or image asset, right-click it, and select Export As HTML > Exclude From HTML Export.
   - To include a graphic asset, right-click it, and select Export As HTML > Include For HTML Export. (Graphic assets are excluded by default.)

3 Choose a layout preview method:
   - To view entire pages as you scale a layout, click the Automatic Zoom button.
   - To maintain zoom settings as you scale a layout, click the Manual Zoom button.

4 In the toolbar, click Optimize to best reflect the original layout in InDesign. Then adjust the Layout Scaling slider as needed.

   Note: Layout Scaling changes text layer size, not font size. Font size may appear to change in the preview, however, if Automatic Zoom is enabled.

5 To create visually uniform layout, select Apply To All Pages. Or, to optimize layout independently, repeat step 4 for each page.
6 (Optional) To edit and preview CSS for text assets, click Edit CSS in the Inspector.

7 Click the Export As HTML button in the toolbar, and specify the page range. (If you select All Pages or Page Selection, enter a file name prefix in the Name field.)

8 To apply a template to the exported file, select Use Template, and specify a file in the Reference box.

*The default template adds Previous and Next links to exported pages.*

**See also**

“Exporting packages to HTML” on page 391

“Page templates” on page 420
Chapter 17: Working with PDF documents

Displaying and navigating PDF documents

To display a PDF document
❖ Do either of the following:
• Open a web page, and click the PDF Preview tab in the document window.
• Open an existing PDF file.

See also
“Exporting pages to PDF” on page 399
“Editing PDF link regions” on page 397

To change the display of PDF documents
❖ In the status bar of the document window, do any of the following:
• To change the number of PDF pages displayed simultaneously, click the Single-Page View button ☐, the Double-Page View button ☐, or the Multi-Page View button ☐.

To view more pages at one time in double- or multi-page view, either enlarge the document window or decrease magnification.
• To view PDF pages continuously, rather than in sets, click the Continuous Mode button ☐. In Continuous Mode, you can use the vertical scroll bar to move from page to page.
• To rotate the view of PDF pages, click the Rotate Left button ☐ or the Rotate Right button ☐.

To smooth text, line art, or images in PDF documents
❖ In the View palette, select from the following options: Smooth All, Smooth Text, Smooth Line Art, or Smooth Images.
To navigate to a specific page or set of pages
❖ Do one of the following in the status bar of the document window:
  • Type the page number in the Page Number text box, and then press Enter or Return.
  • Click the First Page button ➟, the Last Page button ➢, the Next button ➤, or the Previous button ◀.

To navigate to a specific area of a page
❖ Do one of the following in the document window:
  • Drag with the Hand tool 👀.
  • Hold down the Control key, and press the arrow keys.

To visually locate and select a page
1 In the status bar of the document window, click the Multi-Page View button 📚.
2 Navigate to the desired set of pages by using the First Page, Last Page, Next, and Previous buttons.
3 In the document window, click the desired page.
Visually locating and selecting a page

**Viewing saved page setup and security settings**

When you view an existing PDF file, the status bar of the document window displays the file's page setup and security settings, including editing and printing restrictions. GoLive honors these settings but doesn't let you change them. For example, if a PDF file has a printing restriction, you can't print the file in GoLive—even if you enter the master password to open the file.

For more information about page setup settings, see “Exporting pages to PDF” on page 399. For more information about security settings, see Adobe Acrobat Help.

*Note: GoLive supports standard Acrobat security, but not Self-Sign Security.*

![Saved security settings in the status bar](image)

A. Security off  
B. Editing allowed  
C. Printing allowed

**To hide PDF status bar options**

❖ From the document window pop-up menu, choose Status Bar, and then select from the following options:

- **PDF Page Control**  Hides page navigation controls.
- **PDF Page Zoom**  Hides magnification controls.
- **PDF Info**  Hides security settings.
- **PDF Page Rotation**  Hides rotation buttons.
- **PDF Display Mode**  Hides display options.

**PDF comments**

**To create, view, or edit a PDF comment**

1. Open an existing PDF file.
2. In the toolbar, click the Note tool 📄.
3 In the PDF Preview, do either of the following:

- Select an existing comment.
- Click to create a new comment.

4 In the text box of the PDF Commenting Inspector, view or edit the comment.

   To quickly view a comment, simply place the pointer over it.

**To hide PDF comments**

❖ In the View palette, deselect Show Annotations to hide all comments or Show Text Annotations to hide only text comments.

**Editing PDF link regions**

**Editing PDF link regions**

With the PDF link editor, you can use GoLive to create, move, resize, and delete link regions in any existing PDF file. You can also specify link destinations such as web pages, HTML anchors, PDF pages, and PDF bookmarks. When you've finished editing links, you can test them by using the PDF Preview tab.

You can manage PDF links with the same site management tools used for HTML links, including the In & Out Links palette. (See “Changing all site URLs or links at once” on page 232.)

   To link from an HTML file to a PDF bookmark, use the Edit PDF Anchor option. (See “To create an anchor link to a PDF bookmark” on page 172.)

![Linking to another PDF file](image)

**A. PDF Link Inspector options**  **B. New link**
To create a new PDF link region
1. Open an existing PDF file, and click the PDF Link Editing tab in the document window.
2. In the toolbar, click the Add New Link button.
3. In the document window, drag across the area you want to link.
4. In the URL text box of the PDF Link Inspector, specify the destination file or anchor. If you specify a PDF file, also enter the destination page number in the Page Number text box, or choose the destination bookmark from the Bookmark list.
   - To change the color used to highlight link regions, specify a new Link Editing Color preference. (See “To change PDF preferences” on page 402.)

See also
“Editing PDF link regions” on page 397

To move, resize, or delete a PDF link region
1. Open an existing PDF file, and click the PDF Link Editing tab in the document window.
2. In the toolbar, click the Edit Links button.
3. In the document window, click the link to select it.
4. Do one of the following:
   - To move the link region, drag it to the desired location on the page.
   - To resize the link region, position the pointer over a corner or side handle. When the pointer becomes a double arrow, drag.
   - To delete the link region, press Delete.
   - To precisely move or resize a link, increase display magnification.

See also
“Editing PDF link regions” on page 397

To change a destination for a PDF link region
1. Open an existing PDF file, and click the PDF Link Editing tab in the document window.
2. In the toolbar, click the Edit Link button.
3. In the document window, select the desired link region.
4. In the URL text box of the PDF Link Inspector, specify the destination file or anchor. If you specify a PDF file, also enter the destination page number in the Page Number text box, or choose the destination bookmark from the Bookmark list.
   - You can point and shoot to a destination file by holding down Alt (Windows) or Command (Mac OS) and dragging from the link region in the document window.
Exporting web pages to PDF

Exporting pages to PDF
You can export web pages to PDF while retaining formatting and features such as links, form elements, and QuickTime movies. You can use this powerful functionality to quickly e-mail PDF versions of web pages or create documents such as interactive PDF forms.

GoLive provides two ways to export PDF files, and each has unique advantages. If you export individual open pages, you can preview various PDF settings with the PDF Creation Inspector. If you export selected files in the site window, you can simultaneously export multiple files—or an entire site—and retain links between files.

Note: Frames, HTML comments, and JavaScript do not export to PDF. Exported anchors, however, become bookmarks in the PDF file.

Using the Shrink Content To Paper Width option:
A. Deselected  B. Selected

See also
“Using anchors for links” on page 171
“Editing PDF link regions” on page 397

See also
“To export a diagram” on page 197
“About web forms” on page 411
To export an open web page to PDF

1. In the document window, click the PDF Preview tab.
2. In the PDF Creation Inspector, set options as desired.
   The Inspector displays only common options. To set additional options, click the Edit Adobe PDF Preset icon.
3. In the toolbar, select any of the following:
   - View PDF After Exporting
   - Use PDF Security Preferences
4. Do any of the following:
   - To attach a PDF file to an e-mail message, click the E-mail PDF button in the toolbar.
   - To quickly save a PDF file, click the Export button in the toolbar.
   - To save a PDF file and customize options, choose File > Export > HTML As Adobe PDF.

See also
“About Adobe PDF presets” on page 402

PDF Creation options for open web pages

When you click PDF Preview tab for an open web page, the PDF Creation Inspector provides the following options.

Note: You can override these options in the Export Adobe PDF dialog box, but it lacks a Refresh PDF Preview button that lets you preview new settings.

- **Preset** Specifies the PDF preset used when exporting. PDF Presets are groups of compression, security, and other settings. To customize presets, click the Edit Adobe PDF Preset button.
- **Size** Sets the paper size. To change page orientation, click the portrait button or landscape button.
- **Margin** Sets the page margins. To set uniform margins, click the Link All Margins icon.
- **Colors** Specifies the ICC profile used for color management:
  - Main Monitor Colors Uses the monitor profile.
  - Working RGB Uses the RGB working space specified in the Color Settings dialog box (Edit > Color Settings).
  - Mac Colors Uses the default profile for Mac OS.
  - Windows Colors Uses the default profile for Windows.
- **Shrink Content to Paper Width** Proportionally shrinks a web page that's wider than the selected paper size.
- **Use Single Page Layout** Extends the PDF page length to contain all the web content.
- **Allow Table Breaks** Breaks tables at page breaks, rather than shifting entire tables and creating excess white space.
- **Allow Image Breaks** Breaks images at page breaks, rather than shifting entire images and creating excess white space.
- **Remove Background** Removes background colors, background images, and CSS background styles, replacing them with a white background that emphasizes the content of a page.
The Remove Background option produces a PDF file that prints more clearly on black-and-white printers.

**Refresh PDF Preview**  Regenerates the PDF preview to reflect new PDF Creation settings.

**See also**

“About Adobe PDF presets” on page 402
“General options for Adobe PDF files” on page 403
“Compression options for Adobe PDF files” on page 406
“HTML Conversion options for Adobe PDF files” on page 407
“Advanced options for Adobe PDF files” on page 408
“Security options for Adobe PDF files” on page 409

**To export selected pages in a site to PDF**

1. In the site window, select one or more pages.
   
   *If you’re exporting an entire site, select only one page; you can later specify the entire site in the Export Adobe PDF dialog box.*

2. Choose File > Export > HTML As Adobe PDF.

3. In the Export Adobe PDF dialog box, select or edit a preset, and then click Export.

**See also**

“General options for Adobe PDF files” on page 403
“Compression options for Adobe PDF files” on page 406
“HTML Conversion options for Adobe PDF files” on page 407
“Site Creation options for Adobe PDF files” on page 408
“Advanced options for Adobe PDF files” on page 408
“Security options for Adobe PDF files” on page 409
Setting global options for PDF documents

To change PDF preferences
GoLive lets you change several conversion, display, and security preferences for PDF documents. If you regularly use certain settings to create PDF files, changing the preferences can help you work more efficiently.

1. Choose Edit > Preferences (Windows) or GoLive > Preferences (Mac OS).
2. In the list on the left, select Adobe PDF, and then select from the following groups of default settings:
   - **HTML To PDF Conversion** Sets the default PDF preset and page size. (GoLive applies the default page size if a preset doesn't specify this information.)
   - **PDF Optimization** Enables or disables Optimize For Fast Web View.
     - To ensure that uploaded PDF files have the smallest file size possible, select Rewrite PDF Files in the Upload/Export section of the Site preferences. For more information, see “To select site export options” on page 448.
   - **Initial View** Determines default Zoom Factor and Display Mode.
   - **Document Display** Determines default smoothing of text and graphics, display of annotations, and colors for page backgrounds and links.
3. If you create secure PDF files, expand Adobe PDF in the list on the left, select Security, and specify default settings.

See also
“PDF Creation options for open web pages” on page 400
“To smooth text, line art, or images in PDF documents” on page 394
“Security options for Adobe PDF files” on page 409

About Adobe PDF presets
A PDF preset is a predefined set of PDF options that you can use to create Adobe PDF files. The settings in default presets balance file size with quality for specific mediums, such as the web, mobile devices, or print. You can also create new presets with custom settings.

All Adobe Creative Suite applications (Acrobat, GoLive, Illustrator, InDesign, and Photoshop) share PDF presets. For more information about shared PDF settings, see the PDF Integration Guide on the Creative Suite CD.

GoLive provides the following Adobe PDF presets:

**Note:** Both of these presets use the Single Page Layout option, which prevents page breaks in web content.

- **GoLive Default** Creates PDF files that are optimized for web browsers, reducing file size for fast downloads while retaining features such as form elements, interactivity, and multimedia. This preset utilizes recent enhancements to the PDF format, producing files that can be opened in Acrobat 6.0 and later.
- **Mobile PDF** Creates PDF files that are optimized for mobile devices, such as cell phones and PDA's. To accommodate these devices, page size is reduced for small screens, and file size is optimized for fast downloads. For broad mobile compatibility, this preset produces files that can be opened in Acrobat 5.0 and later.

Other Adobe CS applications install additional presets. For more information, see InDesign Help, Illustrator Help, or Photoshop Help.
To customize Adobe PDF presets

In GoLive, you can create, edit, and load Adobe PDF presets. Saved preset files use the .joboptions extension. You can transfer these files to a different computer or Adobe Creative Suite application. In GoLive, however, you can't use CMYK presets, which appear with a warning icon.

You can create a new preset while exporting to PDF from the site window. After setting the desired options in the Export Adobe PDF dialog box, click Save Preset.

2. Do one of the following:
   - To create a new preset, click New. Then specify a name for the preset, set the desired options, and click OK.
   - To create a new preset based on an existing one, select the desired preset, and click New. Then, enter a name for the preset, set the desired options, and click OK.
   - To edit a preset, select it, and click Edit. Then set the desired options, and click OK.
   - To delete a preset, select it, and click Delete.
   - To import a preset, click Load. Locate the joboptions file you want to load, and click Open.
   - To save a preset, select it, and click Save. Shared presets are stored in the Adobe PDF\Settings folder. To store the preset in a different location, click Save As, specify a location, and click Save.

See also
“General options for Adobe PDF files” on page 403
“Compression options for Adobe PDF files” on page 406
“HTML Conversion options for Adobe PDF files” on page 407
“Advanced options for Adobe PDF files” on page 408

General options for Adobe PDF files

When you export to PDF or edit a PDF preset, you can set the following General options:

Compatibility Sets the compatibility level of the Adobe PDF file. When you create PDF files, you need to decide which PDF version to use. Generally speaking, you should use the most recent version because it will support the latest features and functionality. However, if you're creating documents that will be distributed widely, consider choosing Acrobat 4.0 (PDF 1.3) or Acrobat 5.0 (PDF 1.4) to ensure that all users can view and print the document.

The following table compares different Adobe PDF compatibility settings.
<table>
<thead>
<tr>
<th>Acrobat 4 (PDF 1.3)</th>
<th>Acrobat 5 (PDF 1.4)</th>
<th>Acrobat 6 (PDF 1.5)</th>
<th>Acrobat 7 (PDF 1.6)</th>
</tr>
</thead>
<tbody>
<tr>
<td>PDF files can be opened with Acrobat 3.0 and Acrobat Reader 3.0 and later.</td>
<td>PDF files can be opened with Acrobat 3.0 and Acrobat Reader 3.0 and later. However, features specific to later versions may be lost or not viewable.</td>
<td>Most PDF files can be opened with Acrobat 4.0 and Acrobat Reader 4.0 and later. However, features specific to later versions may be lost or not viewable.</td>
<td>Most PDF files can be opened with Acrobat 4.0 and Acrobat Reader 4.0 and later. However, features specific to later versions may be lost or not viewable.</td>
</tr>
<tr>
<td>Cannot contain artwork that uses live transparency effects. Any transparency must be flattened prior to converting to PDF 1.3.</td>
<td>Supports the use of live transparency in artwork.</td>
<td>Supports the use of live transparency in artwork.</td>
<td>Supports the use of live transparency in artwork.</td>
</tr>
<tr>
<td>Layers are not supported.</td>
<td>Layers are not supported.</td>
<td>Preserves layers when creating PDF files from applications that support the generation of layered PDF documents, such as Illustrator CS or InDesign CS.</td>
<td>Preserves layers when creating PDF files from applications that support the generation of layered PDF documents, such as Illustrator CS or InDesign CS.</td>
</tr>
<tr>
<td>DeviceN color space with 8 colorants is supported.</td>
<td>DeviceN color space with 8 colorants is supported.</td>
<td>DeviceN color space with up to 31 colorants is supported.</td>
<td>DeviceN color space with up to 31 colorants is supported.</td>
</tr>
<tr>
<td>Double-byte fonts can be embedded.</td>
<td>Double-byte fonts can be embedded.</td>
<td>Double-byte fonts can be embedded.</td>
<td>Double-byte fonts can be embedded.</td>
</tr>
<tr>
<td>40-bit RC4 security supported.</td>
<td>128-bit RC4 security supported.</td>
<td>128-bit RC4 security supported.</td>
<td>128-bit RC4 and 128-bit AES (Advanced Encryption Standard) security supported.</td>
</tr>
</tbody>
</table>

**Description**  Displays the description from the selected preset, and provides a place for you to edit the description. You can paste a description from the clipboard. Editing the description of a preset appends the word “(modified)” to the preset name. Conversely, changing the settings in a preset prepends the description with “[Based on <Current
**Preset Name**: “

**Embed Page Thumbnails**  Creates a thumbnail preview for each page being exported. Adding thumbnails increases the PDF file size.

**Optimize For Fast Web View**  Reduces PDF file size, and optimizes the PDF file for faster viewing in a web browser by restructuring the file for page-at-a-time downloading (byte serving). This option compresses text and line art, regardless of what you have selected as compression settings in the Compression area of the Export Adobe PDF dialog box.

**Create Tagged PDF**  Generates an Adobe PDF file with tagged text, links, and images—the subset of Acrobat 6.0 tags that GoLive supports. If Acrobat 6 (PDF 1.5) or Acrobat 7 (PDF 1.6) is selected for Compatibility, tags are compressed.

**Create Acrobat Layers**  Saves each GoLive layer, including hidden layers, as an Acrobat layer within the PDF document. The layers are fully navigable, which allows Adobe Acrobat 6.0 users to generate multiple versions of the document from a single file. For example, if a document will be published in multiple languages, you can place the text for each language in a different layer. Your can then show and hide the layers in Acrobat 6.0 to generate different versions of the document.

*Note: This option is only available when Compatibility is set to Acrobat 6 (PDF 1.5).*

**Embed Adobe PDF Preset**  Stores the current PDF preset in the exported PDF file.

**View PDF After Exporting**  Opens the newly-created PDF file in the default PDF viewing application.

**Bookmarks**  Creates bookmarks from HTML anchors.

**Hyperlinks**  Creates Adobe PDF hyperlink annotations for GoLive hyperlinks. Set the following sub-options:

- **Honor Base-URL**  Converts relative web links into absolute PDF links. (This option requires a Base element in the head section of the web page. See "Head section elements" on page 164.)

- **Honor Rollover Effect**  Retains HTML rollovers in the exported PDF file.

**Form Elements**  Retains interactive HTML form elements in the exported PDF file.

*Note: JavaScript in forms and elsewhere does not export to PDF.*

**Multimedia**  Lets you specify how to embed or link movies and sounds:

- **Automatic**  Links multimedia for Acrobat 4.0 and 5.0 files; embeds multimedia for Acrobat 6.0 and later files.

- **Link All**  Links sound and movie clips placed in the document. If you choose not to embed media clips in the PDF file, be sure to place the media clips in the same folder as the PDF.

- **Embed All**  Embeds all movies and sounds, regardless of embed settings on individual objects.

*Note: The Multimedia option is only available when Compatibility is set to Acrobat 6 (PDF 1.5) and Interactive Elements is selected.*

**See also**

“Exporting pages to PDF” on page 399

“About Adobe PDF presets” on page 402

“Head section elements” on page 164
Compression options for Adobe PDF files

When you export to PDF or edit a PDF preset, you can set the following compression options for images. You may want to experiment with these options to find an appropriate balance between file size and image quality.

**Downsampling**  To downsample color, grayscale, or monochrome images, GoLive combines pixels in a sample area to make one larger pixel. You provide the resolution of your output device in dots per inch (dpi) and enter a resolution in pixels per inch (ppi) in the For Images Above box. For all images with resolution above this threshold, GoLive combines pixels as needed to reduce the image's resolution (ppi) to the specified dpi setting. The interpolation method you choose determines how pixels are deleted:

- **Average Downsampling To**  Averages the pixels in a sample area and replaces the entire area with the average pixel color at the specified resolution.
- **Subsampling To**  Chooses a pixel in the center of the sample area and replaces the entire area with that pixel color. Subsampling significantly reduces the conversion time compared with downsampling but results in images that are less smooth and continuous.
- **Bicubic Downsampling To**  Uses a weighted average to determine pixel color, which usually yields better results than the simple averaging method of downsampling. Bicubic is the slowest but most precise method, resulting in the smoothest tonal gradations.

**Compression**  Determines the type of compression that is used:

- **Automatic (JPG/ZIP)**  Determines automatically the best quality for color and grayscale images. For most files, this option produces satisfactory results.
- **JPG**  Is suitable for grayscale or color images. JPG compression is *lossy*, which means that it removes image data and may reduce image quality; however, it attempts to reduce file size with a minimal loss of information. Because JPG compression eliminates data, it can achieve much smaller files sizes than ZIP compression.
- **ZIP**  Works well on images with large areas of single colors or repeating patterns, and for black-and-white images that contain repeating patterns. ZIP compression can be lossless or lossy, depending on the Image Quality setting.
- **JPG 2000**  Is the international standard for the compression and packaging of image data. Like JPG compression, JPG 2000 compression is suitable for grayscale or color images. It also provides additional advantages, such as progressive display. The JPG 2000 option is only available when Compatibility is set to Acrobat 6 or later.
- **Automatic (JPG 2000/ZIP)**  Determines automatically the best quality for color and grayscale images. This option is available only when Compatibility is set to Acrobat 6 or later.
- **CCITT (Consultative Committee on International Telegraphy and Telephony) and Run Length**  Are only available for monochrome bitmap images. CCITT compression is appropriate for black-and-white images and any images scanned with an image depth of 1 bit. Group 4 is a general-purpose method that produces good compression for most monochrome images. Group 3, used by most fax machines, compresses monochrome bitmaps one row at a time. Run Length compression produces the best results for images that contain large areas of solid black or white.

**Image Quality**  Determines the amount of compression that is applied. For JPG or JPG 2000 compression, you can choose High, Medium High, Medium, Medium Low, or Low quality. For ZIP compression, only 8-bit is available. If you use 8-bit ZIP compression with 4-bit or 8-bit images, the ZIP method is *lossless*; that is, data is not removed to reduce file size, so image quality is not affected.
**Compress Text And Line Art**  Applies Flate compression to all text and line art in the document, without loss of detail or quality.

**Crop Image Data To Frames**  May reduce file size by exporting only image data that falls within the visible portion of the frame. Do not select this option if postprocessors might require the additional information (for repositioning or bleeding an image, for example).

**See also**

“Exporting pages to PDF” on page 399

“About Adobe PDF presets” on page 402

**HTML Conversion options for Adobe PDF files**

When you export to PDF or edit a PDF preset, you can set the following HTML Conversion options.

**Page Setup**  Specifies paper type, width, height, and orientation.

**Margin**  Sets the page margins. To set uniform margins, click the Link All Margins button.

**Shrink Content To Paper Width**  Proportionally shrinks a web page that’s wider than the selected paper size.

**When Opening Zoom In To Original HTML Font Size**  Selects Acrobat zoom setting that reflects HTML font size in web browser.

**Use Single Page Layout**  Extends the PDF page length to contain all the web content.

**Allow Image Breaks**  Breaks images at page breaks, rather than shifting entire images and creating excess white space.

**Ignore Page Breaks**  Ignores the following HTML comment, which forces a page break in exported PDF files:

```html
<--GLPDF:Pagebreak-->
```

**Remove Background**  Removes background colors, background images, and CSS background styles.

**Mobile Compatible**  Selects the Create Tagged PDF option in the General area of the Adobe PDF Preset dialog box, adding unique formatting tags for mobile devices. Mobile-compatible PDF files are best viewed in Acrobat 5.0 and later.

*Note: Deselecting Mobile Compatible doesn’t deselect Create Tagged PDF; you must deselect that related option manually.*

**Treat Colors In Pages As**  Specifies the ICC profile used for color management:

- **Main Monitor Colors**  Uses the monitor profile.
- **Working RGB**  Uses the RGB working space specified in the Color Settings dialog box (Edit > Color Settings).
- **Mac Colors**  Uses the default profile for Mac OS.
- **Windows Colors**  Uses the default profile for Windows.

**Use Embedded Image Profiles**  Retains image profiles in the exported PDF file.
See also
“To change PDF preferences” on page 402
“Exporting pages to PDF” on page 399
“PDF Creation options for open web pages” on page 400

Site Creation options for Adobe PDF files
When you export to PDF from the site window, you can set the following Site Creation options:

Create A Single PDF From All Files Selected  Exports a single PDF file from all selected web pages.

Create A Separate PDF For Each File Selected  Exports a unique PDF file for each selected web page. To direct links to other exported PDF files, rather than the original web pages, select Resolve Links To Point To The PDF’s.

Work On  specifies the group of web pages to export. For example, The Whole Site specifies all pages, and The Site Selection specifies selected pages.

See also
“Exporting pages to PDF” on page 399

Advanced options for Adobe PDF files
When you export to PDF or edit a PDF preset, you can set the following Advanced options:

Embed Fonts  Includes complete fonts in the exported file. (Some fonts must be embedded to display correctly; GoLive embeds these fonts even if this option is deselected.)

Note: GoLive cannot embed a font if the font vendor has disabled embedding.

Subset Fonts  Includes only the specific font characters present in the document.

Metadata  Stores Title, Author, Subject, and Keywords in the exported PDF file. Select Use HTML Page Title to automatically complete the Title field.

Place Page Information As Headers And Footers  Adds metadata to the top and bottom of each page.

See also
“Exporting pages to PDF” on page 399
“PDF Creation options for open web pages” on page 400
Security options for Adobe PDF files

When you export to PDF, you can set the following Security options:

**Compatibility**  Sets the type of encryption for opening a password-protected document. The Acrobat 4 (PDF 1.3) option uses a low encryption level (40-bit RC4), while the other options use a high encryption level (128-bit RC4). Acrobat 6 (PDF 1.5) or later lets you enable metadata for searching.

Be aware that anyone using an earlier version of Acrobat cannot open a PDF document with a higher compatibility setting. For example, if you select Acrobat 7 (PDF 1.6) compatibility for a document's security setting, the document cannot be opened in Acrobat 6.0 or earlier.

**Require a Password to Open the Document**  Requires anyone who tries to open the PDF file to enter the password you specify.

**Document Open Password**  Sets the password to protect the PDF file. This option is only enabled when the previous option is selected.

*Note:* If you forget a password, there is no way to recover it from the document. It's a good idea to store passwords in a separate secure location in case you forget them.

**Use a Password to Restrict Printing, Editing, and Other Tasks**  Restricts access to the PDF file's security settings. If the file is opened in Adobe Acrobat, the user can view the file but must enter the specified Permissions password in order to change the file's Security and Permissions settings. If the file is opened in Illustrator, Photoshop, InDesign, or GoLive the user must enter the Permissions password, since it is not possible to open the file in a view-only mode.

**Permissions Password**  Sets the password to protect the PDF file. This option is only enabled when the previous option is selected.

**Printing Allowed**  Specifies the level of printing that users are allowed for the PDF document.

  - **None**  Prevents users from printing the document.
  - **Low Resolution (150 dpi)**  Lets users print at no higher than 150-dpi resolution. Printing may be slower because each page is printed as a bitmap image. This option is available only if the Compatibility option is set to Acrobat 5 (PDF 1.4) or a later Acrobat version.
  - **High Resolution**  Lets users print at any resolution, directing high-quality vector output to PostScript and other printers that support advanced high-quality printing features.

**Changes Allowed**  Defines which editing actions are allowed in the PDF document.

  - **None**  Prevents users from making any changes to the document, including filling in signature and form fields.
  - **Inserting, Deleting, And Rotating Pages**  Lets users insert, delete, and rotate pages, as well as create bookmarks and thumbnail pages. This option is only available for high (128-bit RC4) encryption.
  - **Commenting, Filling in Form Fields, and Signing**  Lets users add comments, fill out forms, and add digital signatures. This option doesn't allow users to move page objects or create form fields.
  - **Page Layout, Filling in Form Fields, and Signing**  Lets users fill out forms and add digital signatures. This option doesn't allow users to add comments or create form fields.
  - **Any Except Extracting Pages**  Lets users edit the document, create and fill out form fields, add comments, and add digital signatures.

**Enable Copying of Text, Images, and Other Content**  Allows users to copy and extract content from the PDF document.
Enable Text Access Of Screen Reader Devices For The Visually Impaired  Allows users to access content using software tools for the visually impaired. This option is only available for high (128-bit RC4) encryption.

Enable Plaintext Metadata  Allows users to copy and extract content from the PDF. This option is only available when Compatibility is set to Acrobat 6 or later. Selecting this option allows storage/search systems and search engines to access to metadata stored in this document.

See also

“Exporting pages to PDF” on page 399
Chapter 18: Forms

Creating forms

About web forms
A web form allows viewers to send information to a web server or e-mail address. You can design forms to let viewers sign up for a newsletter, make purchases, and complete a questionnaire. You can use text fields, buttons, lists, and images in your form. You can also add actions and events to your form.

The appearance of your form may vary between computer platforms and web browsers. With GoLive you can get predictable results if you place form elements in HTML tables, rather than on layout grids or directly on a page.

Note: You create the form in GoLive, but your web server actually processes the information using a script that the form specifies. All GoLive form elements fully support HTML 4.0 standards—including labels, tab order, and access keys—and are backward-compatible with the HTML 3.2 specification.

See also
"Exporting pages to PDF" on page 399

To create a form
1 From the Form set in the objects toolbox, drag the Form icon onto a page. This element is a container for individual form elements, such as buttons and fields.

2 To provide the form’s structural foundation, drag the Table icon from the objects toolbox to the form element.

3 Add form items by dragging them from the objects toolbox to the table cells.

Note: Icons from the Forms set in the objects toolbox must be added in the box that encloses the Form icon in the document window; otherwise they will not be part of the form.

4 Add a Submit button so your viewers can submit their data to a server or an e-mail address.

5 Create a tabbing chain to help your viewers navigate within the form using the Tab key. You can specify the order in which the focus moves from one form element to the next.

6 Preview your form in a browser and test its functionality.

GoLive includes several form samples that you can build your form upon. Choose File > New, select Web > Page Samples (Tables), and then select one of the samples named “form”. (See “About the New dialog box” on page 24.)

Designing a form
A. Form icon contains all elements of a fill-in form  B. Form icon  C. Individual form elements placed in table cells
To set up the form element

The form element tells the browser where and how to return form information for processing. If you are using a table to organize the form elements, be sure to put the table inside the form element's box.

1. Drag the Form icon from the Forms set in the objects toolbox to the document window.

2. In the Form Inspector, choose an option from the Name/ID menu (choose Name & ID for maximum browser compatibility), and then type a unique form name in the Name/ID box.

3. Select Action, and then specify the URL of the web server script that will process the form information when the viewer clicks the Submit button.

4. If your form is embedded in a frame set and you want to control where the HTML page returned by the web server appears, choose a target location from the Target menu.

5. Select an encoding method from the Encode pop-up menu:

   - **Default and Application/x-www-form-urlencoded** Use the ASCII character set. These two methods are the same.
   - **Multipart/form-data** Tells the server where the files begin and end.
   - **Text/plain** Sends the form data as plain text.

6. In the Method menu, choose the form delivery method:

   - **Post** Returns data entered by the viewer information separately from the web page.
   - **Get** Sends the viewer's entries appended to the URL in the Action box.
   - **Default** Omits the Method attribute.

   *Note: Get appends the form information to the destination file and may exceed the URL length limit, causing the server to lose information from the form.*

Adding form elements

Types of form buttons and check boxes

You can set up several types of buttons and check boxes on your web page form.

- **Submit buttons** Send data entered in the form to the CGI script for processing.
- **Reset buttons** Clear the current form data, resetting the form to its default values.
- **Radio buttons** Let viewers select one item from a list. To make sure that a list of radio buttons works properly, make sure that each button shares the same Group name.
- **Buttons** Can function like a Reset or Submit button, or perform a custom action that you create. You can use an image for the button label.
- **Check boxes** Let the viewer select one or more items from a list of options.

*See also*

“To insert a label” on page 415
To create a Submit or Reset button
1 Drag the Submit Button icon or the Reset Button icon from the Forms set in the objects toolbox to within your form.
2 To change the label that appears on the face of the button, select Label in the button's Inspector and type a label.

To create a custom button
1 Drag the Button icon from the Forms set in the objects toolbox to your form.
2 Enter a unique button name in the Form Button Inspector.
3 In the Value box, specify an action or a value to be passed to the script.
4 To change the label that appears on the face of the button, do one of the following:
   - To use HTML text, select the text on the button in the document window, and then type the new label. You can format the label using any text formatting method in GoLive.
   - To use an image, drag the Form Input Image icon from the Forms set in the objects toolbox to the button. Use the Form Input Image Inspector to specify the image source and options, which you set just as you set options in the Image Inspector.

See also
“Adding pre-optimized images” on page 340
“Formatting text for the web” on page 292

To create a radio button
1 Drag the Radio Button icon from the Forms set in the objects toolbox to your form.
2 In the Group box, type a name that all radio buttons in its group share, or select an existing group name from the pop-up menu.
3 In the Value box, type a unique value or descriptive name that identifies the button. If the viewer selects this particular radio button, this value is passed to the web server script when they submit the form.
4 If you want the radio button to be selected by default, select Selected.

To create a check box
1 Drag the Check Box icon from the Forms set in the objects toolbox to within your form.
2 In the Name box, type a unique name to identify the check box.
3 In the Value box, type the value for the check box. If the viewer selects this particular check box, this value is passed to the web server script when they submit the form.
4 If you want the check box selected by default, select Selected.
To create a single-line text field or a password field in a form

Text and password fields let viewers enter a single line of text, or a required password. Text area fields let viewers enter multiple lines of text. When a viewer clicks the Submit button, the form passes the text to the web server script.

1. Drag the Text Field icon or the Password icon from the Forms set in the objects toolbox to your form.
2. In the Name box of the Form Text Field Inspector, type a unique name to identify the text field or password field.
3. In the Value box, type default text that can be overwritten by viewers, or leave the box empty.
4. In the Visible box, type the number of characters that appear in the text field. By default, a greater number of characters can still be entered into the box.
5. If you want to restrict the number of characters that can be typed into the text field, type the maximum number in the Max box. If empty, this limit is determined by the viewer's web browser.
6. To make the text field a password text field, select Is Password Field. If this option is selected, web browsers typically display an asterisk (*) or other character rather than text for each character.

Note: Password protection of web pages is an interactive feature that requires a web server. What you create in GoLive is just the appearance for the password protection mechanism.

To create a multiple-line text field in a form

1. Drag the Text Area icon from the Forms set in the objects toolbox to your form.
2. In the Name box of the Form Text Area Inspector, type a unique name to identify the text area.
3. In the Rows box, type the number of rows that the text area displays.
4. In the Columns box, type the number of characters to define the width of the field.
5. From the Wrap menu, choose one of the following to specify how lines of text break:
   - Default: Uses the web browser’s text area settings.
   - Off: Prevents text from wrapping, and the Columns limit is disabled.
   - Virtual: Wraps the text on-screen, but not when the data is processed.
   - Physical: Wraps the text on-screen, and when it’s processed.
6. If you want text to appear in the field by default, such as instructions on what the viewer should type, type in the Content box.

To set up a list box or a pop-up menu

The List Box icon inserts a scrolling list box with multiple options to choose from. The Popup icon inserts a pop-up menu with multiple options to choose from.

1. Drag the List Box icon or the Popup icon from the Forms set in the objects toolbox to your form.
2. In the Name box in the Inspector, type a unique name to identify the field.
3. In the Rows box, type the number of rows that you want to display by default. For a pop-up menu, this is the number of rows viewers see when they open the menu.
4. Do any of the following:
   - To allow viewers to select more than one option, select Multiple Selection.
   - To select the option that appears in the field by default, select the desired option in the Label/Value list box, and then select the box at the bottom of the Inspector.
• To edit the field’s labels and value, select an item in the Label/Value list box, and enter a new label and appropriate value.
• To add, duplicate, or delete an item, select the item in the list, and click the appropriate button at the bottom of the Inspector.
• To move an item in the list, select the item and click either the Up button \u2191 or the Down button \u2193.

**To insert a label**
The Label icon inserts a text-based label for identifying the purpose of an adjacent form element.

1 Drag the Label icon \u2192 from the Forms set in the objects toolbox to your form.
2 Select the text on the label field in the document window, and type the text you want it to display. You can format the label using any text formatting method in GoLive.
3 To associate the label with a particular form field, select the label field and then do one of the following:
   • In the Form Label Inspector, drag from the pick whip \u2192 to the form element you want to label.
   • Alt-click (Windows) or Command-click (Mac OS) the border of the label, and drag to the form element you want to label.

The Reference box of the Form Label Inspector displays the ID that controls the association between the form element and its label.

**See also**
“Formatting text for the web” on page 292

**To group form elements**
You can visually indicate that particular forms are related by placing them within a bounding box and displaying a caption over the group.

*Note: The bounding box and caption may not render correctly in all browser versions. Be sure to preview your form in web browsers and from your web server.*

1 Drag the Fieldset icon \u2192 from the Forms set in the objects toolbox to your form.
2 If you want a caption to appear along the bounding box, select Use Legend in the Form Fieldset Inspector. Select the “Legend” text in the document window, and type the caption. You can choose the legend’s alignment from the Alignment menu in the Inspector. (Default positions the legend according to the browser’s preferences or aligns the legend to the left.)
3 Drag form elements that you want to group, into the Form Fieldset bounding box.

**Adding form navigation**

**Providing form navigation**
You can make your forms easy to navigate by specifying a tabbing chain or assigning a keyboard shortcut that applies focus to a particular form element. A tabbing chain lets you define the order in which form elements are selected when viewers press the Tab key repeatedly.
In an HTML form, each element must receive focus from the viewer to become active and perform its task. In addition to clicking a specific form element, you can use either of these methods for navigating a form using the keyboard:

- Define a tabbing chain, and then type text or press Enter to trigger some form-specific action.
- Provide a platform-specific access key combination, and then type text or press Enter to trigger some form-specific action.

*Note:* Not all browser versions support form navigation control keys.

**Tabbing order**

Navigation proceeds from the form element with the lowest tab index value to the form element with the highest. Tab index values need not be contiguous or start at any particular value. If you assign the same tab index value to two form elements, the order of those particular elements in the source code determines their tab order relative to one another.

**To assign a tabbing order to form elements**

1. In the Layout Editor window, choose Special > Forms > Start Tabulator Indexing.
2. Click each element successively in the desired tabbing order. A tab index number appears in each index box and in the Tab box of the Inspector.
3. When you have specified the tabbing chain, choose Special > Forms > Stop Tabulator Indexing, or click the Start/Stop Indexing button in the Inspector.
4. Test the result in a web browser that supports tabbing navigation, such as Microsoft Internet Explorer 4.0 or later.

![Clicking to assign the tabbing order in a form](image)

A. Text boxes in a form  
B. Yellow index boxes identify form elements that support tabbing  
C. Click elements sequentially to set the tabbing order.

*Note:* You can also assign the tabbing order by selecting each form element individually and entering a number in the Tab box in each element’s Inspector. Form elements that support tabbing have the Tab option in their Inspector.

**To assign a keyboard shortcut to focus on a form element**

You can define a unique access key for some types of form elements to enable viewers to focus on that element by pressing a keyboard shortcut (Alt-S, for example, to activate the Submit button in a Microsoft Windows-based browser).
Note: Some form element types don't support access keys. Form elements that support these keys have the Key option in their Inspector.

1. Select the form element.
2. In the Key box of the Inspector, type any alphanumeric character.
3. Provide the user with instructions next to the element in the document window—for example, drag a Label next to the element or enter text that gives the key combination.
4. Repeat steps 1-3 for the next form element. Do not assign the same key to two form elements.
5. Test the result in a browser that supports navigation using access keys, such as Microsoft Internet Explorer 4.0 or later.

Advanced form elements and properties

Special form elements
A number of special HTML elements in the Forms set of the objects toolbox let you add images to your form buttons, insert hidden data, include cryptographic keys, and insert a file selection dialog box.

Form Input Image icon Inserts an image to a button created with the Button icon or use just the image for a button. Inserting graphics can help viewers navigate through your pages.

Hidden icon Inserts an HTML tag that does not appear in a web browser. However, the form submits the HTML tag values with the rest of the form data.

Key Generator icon Lets viewers address an encryption algorithm for safeguarding transactions with your website.

File Browser icon Inserts a file selection dialog box.

To insert an input image placeholder
1. Drag the Form Input Image icon from the Forms set in the objects toolbox to your form.
2. Link the image placeholder with a graphic by using the pick whip or the Browse button in the Form Input Image Inspector.
3. In the Form Input Image Inspector, choose an option from the Name/ID menu (choose Name & ID for maximum browser compatibility), and then type a unique form input image name in the Name/ID box.

Note: Naming the image is especially important when you are using several graphical Submit buttons within the same form. This name is appended to the x and y coordinates that the CGI script uses to indicate that viewers clicked that specific input image, and to trigger a button-specific action.

4. Select the More tab and set up the input image as desired.

Note: If you plan to use the image as a clickable button, make sure to select Is Form.

See also
“About links” on page 167
“Providing form navigation” on page 415
“To add alternative text for images” on page 341
“To create image borders” on page 342
“Setting up inactive form elements in a form” on page 418

To set up a hidden tag, key generator, or file browser
1 Drag the Hidden, Key Generator, or File Browser icon from the Forms set in the objects toolbox to your form.
2 In the form element’s Inspector, enter a unique name in the Name box.
3 Enter a value:
   • For a Hidden tag, type a default value in the Value box.
   • For a Key Generator tag, type the security level in the Challenge box.
   • For a File Browser, type the file browser window width value in the Visible box.

To set a text or text area form field to read-only status
1 Select the form element.
2 Select Read-only in the Inspector.
You can set text fields to read-only status. For example, you might want to include text that must accompany the form. Only text fields, password fields, and text area fields support read-only status.

Setting up inactive form elements in a form
You can make particular form elements unavailable until the viewer does something, such as activate a script by selecting a particular option or filling in a particular element. For example, you can keep a form’s Submit button inactive until viewers enter some required data. Only text fields, password fields, text areas, all buttons, check boxes, and radio buttons support inactive status.

The Form Inventory feature
When your viewers click the form’s Submit button, the browser sends the contents of the form to a specified server and script for processing. The most common workflow is to pass information to a CGI script. You’ll need to develop your custom scripts and work with the system administrator to implement them.
The Form Inventory feature lets you preview how the information will be returned by your form. This is especially useful if the tasks of graphical form creation and web server integration are accomplished by different persons—for example, a web author and a system administrator.

To create a form inventory
The top pane of the Form Inventory lists all form elements used—the form inventory. The bottom pane is the Form Result Preview pane, which displays the code exactly as it will be passed to the script on the server. You can save the content of both panes as separate text files.
1 Select the Form icon in the document window.
2 In the Form Inspector, click the Inventory button.
3 Select Export for the form inventory and the result preview; then name and save the text files.
To set up an inactive form element

1. Select the form element.
2. Select Disabled in the Inspector.
3. Write a script that dynamically enables the item, and attach the script to the page or to another button.
Chapter 19: Site assets

Understanding site assets

About site assets
Site assets help you maintain a consistency throughout all the pages in your site. They include templates for pages and sites, as well as custom sets of files, text, objects, colors, fonts, and URLs that you can collect and use on any page in your site. You collect and store site assets in the site window, in your site's web-data folder, and as objects in the Library palette. The Library palette lets you store application-wide or site-specific assets, and displays previews of site assets in its preview pane (to display the preview pane, choose Show Preview from the Library palette menu).

GoLive includes many preset page template samples and snippets for common web design tasks. Page template samples are organized in the Documents tab of the Library palette and in the Web section of the New dialog box. Snippet presets are organized in the Application-Wide group in the Snippets tab of the Library palette.

See also
“To create a new page in a site” on page 154

Creating page templates

Page templates
You can save any page as a page template and use it to control the layout and appearance of other pages in your site. Any part of the page template that is not marked as an editable region is automatically locked so that when you or others on the same site project create new pages from the template, only the editable regions can be changed. Nested templates enable you to create new locked and editable regions inside the editable region of another template.
You use color highlighting to show the difference between locked and editable regions. New pages based on a template are automatically updated whenever you make changes to the template (content in the editable regions is not affected).

Note: You can use co-author templates to design a site that others can update using a simple, streamlined story editor. For more information, see “The Co-Author feature” on page 453.

Creating a page template

You use the Template Regions palette to mark regions of the page as editable. You can create two types of editable regions: paragraphs or inline selections within a paragraph. When a region is marked as an inline text style, you can’t insert paragraphs in the region—in other words, you can type in the region but you can’t press return to start a new paragraph.

You can lock or unlock everything in the template that is not marked as an editable region and use the Highlight tab of the View palette to set the color highlighting for locked and editable regions. (Regardless of whether you lock the uneditable regions in the template or not, these regions are automatically locked in all pages created from the template.)

Use Smart Objects for images in your page templates. If you resize a Smart Object in a template, GoLive automatically resizes and optimizes its web image in every page that’s connected to the template.

A. Inline text region  
B. Paragraph region

To create a page template

1. Select an area in the page that you want to mark as an editable region. To select an entire paragraph, click inside it and then click the <p> tag in the markup tree bar at the bottom of the document window.

2. In the Regions tab of the Template Regions palette, click one of the following at the bottom of the palette:

   Create New Editable Paragraph Region button Creates an editable paragraph region.

   Create New Editable Inline Region button Creates an editable inline region.

3. Select the new region listed in the palette and type a new name for it. (Spaces and underscores are not allowed in the name.)
Note: By default, names of new regions are based on the first few characters in a text selection or its object type. To automatically name new regions Region 1, Region 2, Region 3, and so on, deselect Selection Defines Region Name by choosing it from the Template Regions palette menu.

4 Repeat steps 1-3 for every region you want to mark as editable.

5 Choose options for working in the editable regions from the Template Regions palette menu:

Auto Selection  Selects the entire content of the editable region when you click in it.

Cyclic Tabbing  Lets you use the Tab key to cycle through the editable regions on the page.

6 Open the site window and do any of the following to save the page as a template:

• Choose File > Save As, name the template, choose Templates from the Site Folder menu, and click Save.
• Choose Save As > Template from the document window menu, name the template, and click Save.
• In the site window, drag the page from the Files tab to the Templates folder in theExtras tab.

Note: Page templates are stored in the site's web-data/templates folder and appear in the Extras tab of the site window, the Web section of the Documents tab of the Library palette, and in the Web > [site name] Templates section of the New dialog box.

To set the color highlighting of editable and locked regions

❖ In the Highlight tab of the View palette, expand Highlight Colors, and do any of the following:

• Click the color field for the Locked Regions or Editable Regions, and then select a new color in the Color palette.
• Drag a color slider to adjust the color opacity for Locked Regions or Editable Regions.
• Click the button to the right of the color slider for the Locked Regions or Editable Regions to toggle between color highlighting the borders or the background fills of these areas.

To see the color highlighting applied to the locked regions in the template, choose Special > Template > Lock Page, or choose Lock Page from the Template Regions palette menu.
To create a new page using a page template

You can use a variety of methods to create new pages from a page template. Depending on the method you use, GoLive may open the new page in an untitled.html document window or name the file based on the name of the template (for example, New from Template1.html).

❖ Do one of the following:

- Choose File > New, and then click Web. Click [site name] Templates, choose a template from the list, and click OK.
- Double-click the template's icon in the Documents tab of the Library palette or in the Extras tab in the site window, and click Create.
- In the site window, drag the template file from the Extras tab into the Files tab, and click Create.

Page templates with locked and editable regions can be used interchangeably with Macromedia Dreamweaver to create new pages either in Dreamweaver or GoLive.

Nested page templates

Nested templates enable you to create new locked and editable regions inside the editable region of another template. Use nested templates for sites that share some elements but also have some variations. For example, you can create a main template that contains your site's logo and create a nested template from the main template to further define editable regions for a specific section of a site. Changes you make to the main template propagate to the nested template, and to the pages generated from the nested template. However, changes you make to the nested template affect only pages generated from that template.
To create nested page templates

1. Create a main template with locked and editable regions and save it in the Templates folder of the site. See “To create a page template” on page 421.

2. Double-click the template in the Extras tab of the site window and click Create.

3. In the editable regions of the page based on the main template, enter static content and define new editable regions.

4. Choose Save As > Template from the document's palette menu. This document is the nested template.

You can create additional layers of templates by generating pages from the nested template and adding static content and editable regions to the editable regions of the page based on the nested template.

Applying and updating page templates

Applying a page template to existing pages

You can apply a page template to pages that already have content in them. When you apply a page template, GoLive looks for matching names of marked editable regions in the existing content. If any are found, GoLive automatically moves the existing content into the regions. If no matches are found, GoLive displays a list of regions in the template to choose from and the option to overwrite the content by not choosing a specific region.

Using the Template Regions palette, you can quickly prepare existing content for a template by marking new editable regions of the same type (paragraph or inline) and automatically renaming the regions with matching names from the template.

To prepare content on a page with matching region names

1. Display the template and the page side by side.

2. Select the content on the page, and then click the Create New Editable Inline Region button or the Create New Editable Paragraph Region in the Template Regions palette.

3. Control-drag (Windows) or Command-drag (Mac OS) from the new region in the palette to the region in the template that has the name you want to use for the new region. GoLive applies the name of the template's region to the new region.

Ctrl-drag or Command-drag to apply the template's region name 'Months' to a new region.
To apply a page template to an existing page

1 Choose Special > Template > Apply Template. Then select the template and click Open.

If all editable region names in the page match region names in the template, GoLive moves the page content into the regions defined in the template. The Select Editable Region dialog box appears if there is content on the page that is unmarked or marked with nonmatching region names.

2 If the Select Editable Region dialog box appears, do one of the following:
   • Select a region in the template to move the content into and click OK.
   • Select None to overwrite the content on the page and click OK.

To try out multiple templates with matching region names on existing pages

1 Apply the first template to the pages.

2 Select the template in the Extras tab in the site window, and open the In & Out Links palette.

3 Choose Palette Options from the palette menu, select Links To File, and click OK to display all pages that are linked to the template.

4 Drag the pick whip in the Links tab of the In & Out Links palette to the second template in the Extras tab in the site window.

5 Click OK to change the reference.

See also
“Using the In & Out Links palette to view links” on page 232

Updating or detaching a page template

Pages that you create based on a page template remain linked to the template, so that when you make changes to the template, the pages are automatically updated. You can detach the page template from the pages so there is no longer a link between them.

To update a page template

1 Double-click the template file in the Documents tab of the Library palette or in the Extras tab in the site window, and click Modify.

2 Make changes to the template’s page layout as desired, and then do any of the following in the Template Regions palette:
   • Click the Create New Editable Inline Region button or the Create New Editable Paragraph Region button to apply an editable region to a selection in the layout.
   • Select a region name and enter a new name.
   • Select a region and click the Undefined Editable Region button.

Note: You must unmark an editable region before you can delete its content in the document window.

3 Choose File > Save.

4 In the Updating Template dialog box, select the pages that you want to be updated from the modified template, and click OK.
To detach a page from a page template
❖ Right-click (Windows) or Control-click (Mac OS) in the page and choose Template > Detach from Template from the context menu.

Stationery

Stationery
Stationery files can be used as templates for creating new pages. Unlike page templates, stationery has no dynamic link with the pages created from it. Changes you make to a stationery file do not affect pages already created from that file.

Stationery is useful when you want to set up starting elements for a page (such as a background color, no page margins, and an external cascading stylesheet).

See also
"About preferences" on page 34
“Page templates” on page 420

To create a stationery file
1 Prepare the content and layout for the stationery document in the Layout Editor in the document window.
2 Open the site window and do any of the following to save the page as stationery:
   • Choose File > Save As, name the stationery, choose Stationery from the Site Folder menu, and click Save.
   • Choose Save As > Stationery from the document window menu, name the stationery, and click Save.
   • In the site window, drag the page from the Files tab to the Stationery folder in the Extras tab.

Note: Stationery files are stored in the site’s web-data/stationery folder and appear in the Extras tab of the site window, the Web section of the Documents tab of the Library palette, and in the Web > [site name] Stationeries section of the New dialog box.

To create a new page using stationery
❖ Do one of the following:
   • Choose File > New, choose Web > [site name] Stationeries, choose a stationery from the list, and click OK.
   • Double-click the Stationery icon in the Web section of the Documents tab of the Library palette, or in the Stationery folder in the Extras tab in the site window, and then click Create.
   • In the site window, drag the stationery file from the Extras tab into the Files tab, and click Create.
Components

Components
You use GoLive components in your pages to reference one or more elements stored in a single HTML source file. Components are useful for buttons, logos, headers, mastheads, or other common navigation elements that you want to use throughout your site. When you add a component to a page, the component remains linked to its source file until you detach it.

You can double-click components on the page to open their source files and edit the files. Changes you make to elements in a component’s source file are updated dynamically in the pages that use the component. Once you’ve added a component to the page, you can use the Crop Text feature to crop text in components. If you use a component on multiple pages, you can crop each instance uniquely, creating text content specific to each page design.

Note: Components cannot contain objects from the Head set in the Objects palette. Also, you should make sure to use the same character encoding for a component’s source file as the character encoding in the pages that use the component. (See “To add elements or scripts to the head section” on page 163.)

To create a component source file
1 In a new document window, add the desired content for the component (for example, a layout grid with your corporate logo and headline).

2 If you’ve changed Script Library settings in Preferences or changed Site Settings to Write Code In Page, specify that the component source file import the GoLive script library: Click the Show Page Properties icon in the upper right corner of the document window. In the Page Inspector, click the HTML tab, and then click Component.

3 Open the site window and do any of the following to save the page as a component:
   • Choose File > Save As, name the component, choose Components from the Site Folder menu, and click Save.
   • Choose Save As > Component from the document window menu, name the component, and click Save.
   • In the site window, drag the page from the Files tab to the Components folder in the Extras tab, or to the site-specific section of the Components tab in the Library palette.

Note: Components are stored in the site’s web-data/components folder and appear in the Components tab in the Library palette and the Extras tab of the site window.

To use a component
❖ Do one of the following:
   • Drag the component’s icon from the Components tab of the Library palette to the page.
   • From the Smart set in the objects toolbox, drag the Component icon to the page. Then, in the Component Inspector, specify the destination of the link by dragging from the pick whip to the component’s source file in the Extras tab in the site window.
Adding a component to a page

To crop text in a component
You can crop text in components you’ve added to web pages, removing characters, words, or paragraphs. If you use one component on multiple pages, you can crop each instance uniquely, creating text content specific to each page design.

1 In the Layout Editor, select a component.

2 In the Component Inspector, click the Crop Text button.

3 From the Crop Text By menu in the toolbar, select a unit: Characters, Words, Paragraphs, or Custom Breaks.

Note: To use custom breaks, you must first add <agl:custombreak/> in the source code of the component to specify break locations.

4 In the Layout Editor, drag to select the text you want to retain, or use the Selection Start and Selection End boxes in the toolbar to specify the first and last unit retained. (For example, to retain “cat” in “scatter,” specify 2 and 4. If you’re using custom breaks, enter 1 in the Selection Start box to retain the text from the beginning of the text string to the first custom break.)

5 In the toolbar, click the Accept Crop button. (Or, to cancel the crop without applying it, click the Cancel button X.)

To edit the component’s source file
1 Double-click the component on the page to open the source file.

2 Make the desired changes and save the source file.

3 Click OK to update all pages that use the component.

To detach a component from its source file
- To detach one component, select the component on the page, choose Special > Component > Detach Selected Component, and then click OK.
- To detach all components on a page, choose Special > Component > Detach All Components, and then click OK.

The detached component becomes part of the page and does not have a dependent link to the source file. Changing the source file no longer affects the detached component in the page.
Snippets

You can copy portions of source code, text, images, and other objects from pages in GoLive or documents in other applications and add them as snippets, or single objects, to pages. Snippets are similar to components except that snippets do not remain linked to their source files when you add them to a page.

Collecting and organizing snippets

You collect snippets in the Snippets tab of the Library palette. When you save a site-specific snippet, GoLive adds a corresponding source file to the site's web-data folder and displays it in the site-specific section of the Snippets tab in the Library palette and in the Snippets folder in the Extras tab in the site window. Snippets are not limited to HTML—for example, you can drag image files from the site into the Snippets tab of the Library palette.

GoLive includes many preset snippets for common web design tasks. These presets are organized in the application-wide group in the Snippets tab of the Library palette.

To create a snippet

1 Open a site.
2 Select the text, objects, or source code in GoLive or another application. You can also select a snippet from another site.
   To select paragraph formatting for text in the Layout Editor, select the paragraph or heading element in the markup tree bar at the bottom of the document window.
3 Drag the selection into the application-wide or site-specific section of the Snippets tab in the Library palette.
   Note: Site-specific snippets are stored in the site's web-data/snippets folder and appear in the Snippets tab in the Library palette and the Snippets folder in the Extras tab in the site window.
4 To name the snippet, select it in the Snippets tab in the Library palette and type a new name.
Using snippets on your pages
You can add snippets directly from the Snippets tab of the Library palette to the Layout Editor in the same way that you add other objects from the objects toolbox.

You can use the In & Out Links palette to display snippets containing placeholders for other files (such as image files). The In & Out Links palette shows the resource links to the files. If the source file is moved, GoLive displays a dialog box so you can update the link.

This snippet contains a resource link to an image file.

See also
“Using the In & Out Links palette to view links” on page 232

To add a snippet to a page
❖ Drag the snippet from the Snippets tab in the Library palette to the Layout Editor.

To edit a snippet’s source file
❖ Double-click the file in the Snippets tab of the Library palette, modify the contents using either the Layout Editor or the Source Code Editor, and then choose File > Save.

Editing the contents of a snippet’s source file does not affect any pages that already use the snippet.

Site colors

Site colors
You can collect and organize colors for a site and apply them to text and objects on pages in the site. Site colors remain linked to the pages on which they’re used, so you can change a site color and update any page that uses the color. The Colors tab in the site window lets you list site colors individually or in groups. For each color, the list includes a name that you assign, the HTML color name and value, whether the color is web-safe or not, and whether the color has been used on a page in the site. The colors collected in the Colors tab also appear in the Site Colors swatch library.

After you use a site color on a page, you can update the list in the site window to show that the color has been used.

See also
“To use the Swatches palette or a swatch library palette” on page 176
“Adding used items to and removing unused items from the site window” on page 209
“Working with files and folders in the site window” on page 204
To add site colors

1 Do one of the following:
   • Select colored text in the document window and drag it to the Colors tab in the site window. If you select text with multiple colors assigned to it, each color is added to the list of site colors.
   • Select a site color in the Colors tab of another site window and drag it to the Colors tab in the site window.
   • Drag the Color icon from the Site set of the objects toolbox to the Colors tab of the site window, and then click the color field in the Color Inspector and select a new color from the Color palette.
   • Select the Colors tab in the site window and choose Site > Update > Add Used > Colors. GoLive retrieves all the colors used on pages in the site and lists them in the Scanned Colors folder in the Colors tab.

2 Rename the new site colors by entering the new names in the Colors tab in the site window or the Name box in the Color Inspector.

To apply a site color to text or objects on a page

1 Select the text or objects to be colored.

2 Do one of the following:
   • Select a site color from the Site Colors swatch library.
   • Click the color field in the Inspector, and then select a color from the Site Colors swatch library.
   • Drag the site color from the Colors tab in the site window to the selection on the page.

   Note: When you apply site colors, GoLive inserts the color attribute inside the font element. Because the font element can cause problems with web browsers, you may want to apply color to text and objects using CSS styles instead of site colors.

See also

“To use the Swatches palette or a swatch library palette” on page 176

To change a site color and update pages that use it

1 Select the site color, click the color field in the Color Inspector and select a new color from the Swatches or Color palette.

2 In the Change Link dialog box, select the pages that you want to update, and click OK.

   Note: The Change Link dialog box displays only pages that are closed.

To organize site colors in group folders

1 Drag the Color Group icon from the Site set in the objects toolbox to the Colors tab in the site window.

2 Name the group folder as desired.

3 In the Colors tab in the site window, drag colors into the group folder.
Font sets

Collecting font sets for a site
You can collect and name font sets for specific sites, and share them with others working on the same site project on different computers. A font set applied to text provides the web browser with a choice of fonts to use for displaying the text.

Site font sets remain linked to the pages on which they’re used, so you can change a font set and update any page that uses it.

See also
“Using fonts in web pages” on page 300

To add a font set to a site
1  Click the Font Sets tab in the site window.
2  Do one of the following:
   •  Drag text that uses the font set from the page into the Font Sets tab.
   •  Choose Site > Update > Add Used > Font Sets to add all the font sets currently used by pages in the site. GoLive retrieves all the font sets used by pages in the site and lists them in the Scanned Font Sets folder in the Font Sets tab.
   •  Drag a font set from another site window into the Font Sets tab in the site window.
   •  Choose Site > New > Font Set and use the Font Set Inspector to add fonts to the set.
   •  Drag the Font Set icon A from the Site set of the objects toolbox to the Font Sets tab of the site window and use the Font Set Inspector to add fonts to the set.

To name a site font set
1  Select the site font set.
2  Do one of the following:
   •  Enter a name in the Font Sets tab in the site window.
   •  Enter a name in the Name box in the Font Set Inspector.

To add, reorder, or delete fonts in a site font set
1  Select the font set in the Font Sets tab in the site window.
2  In the Font Set Inspector, do any of the following:
   •  Click the Create New Font button ☞ or the Create New Font Family button ☞ and choose a font or font family from the pop-up menu.
   •  Select a font and click the arrow buttons to move it up or down in the list.
   •  Select a font and click the Remove Selected Fonts button ☞ to remove the font from the list.
To use a site font set
1 Select the text on the page.
2 Drag the font set from the Font Sets tab to the selected text.

*Note:* When you apply site font sets, GoLive inserts the face attribute inside the font element. Because the font element can cause problems with web browsers, you may want to apply fonts using CSS styles instead of site fonts.

To change a site font set and update pages that use it
1 Select the font set in the Font Sets tab in the site window.
2 Add, reorder, or delete fonts in the font set in the Font Set Inspector.
3 In the Change Link dialog box, select the pages that you want to update, and click OK.

*Note:* The Change Link dialog box displays only pages that are closed.

To organize font sets in group folders
1 Drag the Font Set Group icon from the Site set in the objects toolbox to the Font Sets tab in the site window.
2 Name the group folder as desired.
3 In the Fonts tab in the site window, drag font sets into the group folder.

Site URLs and e-mail addresses

You can use site URLs, including e-mail addresses, on multiple web pages without having to type them each time you use them. You collect site URLs in the External tab in the site window. You can get the URLs for your site collection by importing them from your web browser’s favorite URLs, copying them from other pages or sites, or entering them in the site window.

If you need to change the value of a site URL that you’ve used on several pages, you can change it in the External tab in the site window. GoLive then updates all the pages that use the site URL.

![Diagram of External Group Inspector]

*Use the External Group Inspector to specify type of folder.*
A. A site e-mail address  B. A site URL  C. Four types of group folders
**Note:** By default, GoLive treats URLs containing the "@" symbol as e-mail addresses and adds "mailto:" to the URL text box in the Inspector. To avoid this behavior, deselect the Auto Add "Mailto:" To Addresses option in the URL Handling section of the Site Settings or Preferences dialog box.

**See also**

"About preferences" on page 34

**To add a URL or e-mail address to the site**

❖ Do one of the following:

- Select the External tab in the site window and choose Site > Update > Add Used > External Links. GoLive retrieves all the URL and e-mail addresses referenced on pages in the site and lists them in the Scanned URLs folder in the External tab.

- Drag the URL icon from the Site set in the objects toolbox into the External tab in the site window. In the External Inspector, enter a name for the site URL in the Name box, and type or paste the complete URL (beginning with the server type such as "http://" or "ftp://") in the URL box.

- Drag the Address icon from the Site set in the objects toolbox to the External tab in the site window. In the External Inspector, enter a name for the site e-mail address in the Name box, and type or paste the address (beginning with "mailto:" ) in the URL box. If you are creating an address list, use commas to separate the multiple addresses you provide.

- Select the URL in a web browser window and drag it (or the icon to its left) to the External tab in the site window.

- Choose File > Import > Favorites As Site Externals. Then select a Bookmarks, Address Book, Nickname, or Favorites file from a web browser or Eudora Pro, and click Open. If the file contains multiple URLs or e-mail addresses, GoLive imports them as URL or Address groups.

- Drag a site URL or e-mail address from the External tab of another site window to the External tab in the site window.

Drag the icon to the External tab to add the URL.
To rename or edit a site URL or e-mail address
1 Select the site URL or e-mail address in the External tab.
2 Do any of the following:
   • Type a new name in the External tab in the site window or the Name box in the External Inspector.
   • Type a new value for the URL or e-mail address in the URL box of the External Inspector.
   • Click Edit in the External Inspector, enter a new URL or e-mail address, and click OK.
3 If the Change Links dialog box appears, click OK to confirm the new URL or e-mail address and update all pages in the site that use it. (If you want to exclude a page from updating, deselect it before clicking OK.)

See also
“Editing links and adding query parameters to links” on page 170

To organize URLs and e-mail addresses in group folders
1 Drag the URL Group or Address Group icon from the Site set in the objects toolbox to the External tab in the site window.
2 Name the group folder as desired.
3 In the External tab in the site window, drag URLs or e-mail addresses into the group folder.

To use a site URL or e-mail address on a page
1 Select the text or object on the page that you want to use as a link.
2 Do one of the following:
   • Drag the site URL or e-mail address from the site window’s External tab to the selection in the page.
   • In the Inspector, specify the site URL or e-mail address as the destination in the URL text box.

See also
“About links” on page 167

Collections

Collections
A collection is a custom set of files that you select. For example, you can collect groups of files that you use frequently in a site. You can perform various file-management tasks on the files in a collection, such as deleting or duplicating one or more files. Because you can select all of the files in a collection by selecting the collection, you can perform these tasks quickly.

You can define a static collection by dragging files from the Files or Extras tab of the site window to the Collections tab or by saving the results of a query, syntax check, or find operation result as a collection or define a dynamic collection by attaching a query to a collection. When you run the query, GoLive populates the collection with the results of the query.
Files in collections are bound to their originals in the Files or Extras tab. If you delete a file in a collection, GoLive asks if you want to delete the collection file, or the collection file and the original.

**To create a static collection by dragging files**

1 Open a site.

2 In the Collections tab, do one of the following:
   - Choose Site > New > Collection.
   - Click the Create New Collection button in the Site toolbar.
   - Drag the Collection object from the Site set of the objects toolbox to the Collections tab in the site window.

3 Type a name for the new collection folder in the Collections tab of the site window or the Name text box in the Collection Inspector.

4 Drag files or folders from the Files or Extras tab to the new folder in the Collections tab.

You can also create collections by using the navigation view of the site. See “Creating and using collections in navigation or links view” in GoLive Help.

See also

“About collections in navigation or links view” on page 222

**To create a static collection by saving query, syntax check, or find operation results**

1 Open a site.

2 Do one of the following:
   - Choose Edit > Queries and run a query; then click Save Collection in the Result dialog box and type a name for the collection in the Create A New Collection dialog box.
   - Choose Edit > Check Syntax and run a syntax check; then click Save Collection in the Check Syntax Result dialog box and type a name for the collection in the Create A New Collection dialog box.
   - Choose Edit > Find > Find Text or Edit > Find > Find Code Elements, enter search criteria and scope, click Find All; then click Save Collection in the Result dialog box and type a name for the collection in the Create A New Collection dialog box.

See also

“Generating queries” on page 237

“Validating the syntax of source code” on page 591

“To find files within a site” on page 237

**To reveal the original collection files in a site**

Select the collection file and choose Open > Reveal In Site from the context menu.
To move or delete collection files
❖ Select the collection file and do one of the following:
• To move the file, drag or copy it to another folder in the Collections tab.
• To delete the file, click the Delete Selected Item button 🗑️ on the toolbar, then click Remove Linked Item to remove only the collection file, or click Remove Both to remove both the collection file and its original.

To create a dynamic collection
1 Open a site.
2 Select a collection in the Collections tab of the site window.
3 Select Dynamic Collection (Attach Query) in the Collection Inspector.
4 Choose a query from the Query menu (choose New Generic to create a new Query in the query Editor).

To detach a query from a dynamic collection
❖ Select the collection, and then choose Static Collection (Add Files By Dragging) in the Collection Inspector.

To run a query attached to a dynamic collection
1 Select a dynamic collection in the Collections tab of the site window.
2 Click Run Query in the Collection Inspector. GoLive loads the most recent query result set into the collection.

To edit a query attached to a dynamic collection
1 Select a dynamic collection in the Collections tab of the site window.
2 Click Edit Query in the Collection Inspector, and then edit the query in the Query Editor.

See also
“Generating queries” on page 237

Site samples

Site samples
Site samples are groups of files and folders that GoLive uses to create new sites. GoLive provides several site samples for your use in the Site section of the New dialog box. You can create site samples of your own to ensure a standard look and functionality to pages in multiple sites.

When you create a site sample, you can attach an image file to it that visually describes the site. This preview image appears as a small thumbnail next to the site sample's name when you create a new site. You should create this image before you create the site sample.

See also
“To create a site from a site sample” on page 147
To create a custom site sample

1. Create a blank site or copy an existing site, including the project folder, the site file, the site’s web-content, web-data, and web-settings folders, and the folder contents.
2. Place the site in one of the subfolders in the Adobe GoLive CS2/Settings/DocumentStore/Sites folder.
3. Open the site.
4. Choose Site > Settings, or click the Site Settings button on the toolbar.
5. Set any of the following options in the Sample Info section of the Site Settings dialog box:
   • Enter a description of the site.
   • Click Set, and select the image file for the site’s preview.
6. Click OK and save the site.

To use a site sample for creating new sites

1. Choose File > New, and then click Site and choose a samples category.
2. Select a site sample, and click Next.
3. Follow the instructions in the wizard to create the new site.
Chapter 20: Publishing websites

Preparing to publish a site

Publishing a site
For the public to view your website, you must first upload, or publish it to an FTP or HTTP (if you're using WebDAV) server that hosts your site files. You can publish your site directly from Adobe GoLive using either of two built-in publish server clients: the Publish Server tab in the site window or the file browser. Before you publish your site, make sure that it is clean and free of errors. You may also need to flatten the script library.

Each subsequent time that you publish your site from GoLive by using a modified-item or synchronized upload, any files that you have changed or added in GoLive will be automatically updated on the published site.

Note: Though rarely necessary, you may also need to export your site before you publish it to comply with certain server policies. Consult your server administrator if you are having trouble publishing your site in the normal manner.

See also
“To specify options for cleaning up a site” on page 210
“Flattening the script library” on page 606

To set up Internet access preferences
Before you can use GoLive to connect to a publish server, you may need to customize the network settings you use to access the Internet. For example, your Internet service provider (ISP) may require you to use a proxy server for security reasons or use passive mode to work with a firewall that forbids incoming connections.

1 Choose Edit > Preferences (Windows) or GoLive > Preferences (Mac OS).
2 Click the Internet icon .
3 Select Internet options as follows:
   • (Mac OS) If you want to use your computer’s system proxy settings for GoLive Internet access, click the Import Now button, and then select Always.
   • If you need to use an FTP proxy or HTTP proxy, select Use FTP Proxy or Use HTTP Proxy and provide a host name and port number. For information, ask your server administrator.
   • (Mac OS) If you use the system Keychain feature for storing passwords, select the Use System Keychain For Passwords option.
   • (Mac OS) Keep the Use ISO 8859-1 Translation option selected to use the Latin 1 character encoding set, which encompasses the majority of Western European languages.
   • If you need to connect to an FTP server in passive mode, select Use Passive Mode.
Note: If you need to connect in passive mode, be sure to select Use Passive Mode in the Advanced FTP Options dialog box when you set up an FTP publish server. For more information about setting up a publish server, see "To set up access to a publish server" on page 440.

- To specify how long GoLive will try to connect to a publish server before cancelling the connection, enter values in the FTP Timeout and HTTP Timeout boxes.
- If you want GoLive to display details after an upload, download, or synchronization, select Ask For Publish Server Report.

4 Click OK.

About GoLive publish server clients
To publish your site, GoLive connects to an FTP server using File Transfer Protocol (FTP), and connects to a WebDAV server using HyperText Transfer Protocol (HTTP). GoLive can also connect to a folder on your local file system or network using the File protocol. To connect to a publish server, GoLive uses either of its two publish server clients—the Publish Server tab in the site window and the file browser. Both clients list the files and folders in the current publish server directory along with file size, modification date, and file type.

Note: The Publish Server Inspector, available when you select a file or folder in the Publish Server tab or the file browser, provides further information about individual files and folders.

Depending on your circumstances, determine the appropriate publish server client according to the below descriptions:

The Publish Server tab
Use the Publish Server tab for uploading and maintaining a one-to-one synchronized relationship between local and remote files. The Publish Server tab gives you access to commands that permit modified and synchronized uploading and downloading, as well as one-step exporting and uploading. The Publish Server tab gives you direct access to all the assets in the site window. Do not use the Publish Server tab for general-purpose file transfer, especially not for dragging files from the desktop to transfer to a server. Doing so causes the site to request deletion of these files the next time you synchronize your site.

The file browser
Use the file browser to quickly inspect files on a publish server, or to update a few files on your published site without opening a site window.

Note: Before you set up access, make sure that you have TCP/IP networking set up properly on your computer. Consult your computer’s Help for details.

To set up access to a publish server

1 Choose Site > Publish Server > Set Up Server. (If you’ve already set up a server for the site, choose Site > Publish Server > Settings.)

2 Click the New Server button in the Publish Server section of the Site Settings dialog box.

3 Type a name in the Nickname text box. Nicknames prevent confusion if you add more servers to the available servers list.
Choose a protocol from the Protocol menu:

File Publishes files to folders on your local file system or on your network.

FTP Transfers files via FTP to a publish server.

HTTP Transfers WebDAV files to a WebDAV server.

If you chose File from the Protocol menu, browse or type the path to the directory to which you want to transfer files, and then click OK.

If you chose FTP or HTTP from the Protocol menu, do all of the following, using values provided by the publish server administrator, and then click OK:

- Type an address in the Server text box (don't include the protocol).
- Type a path name in the Directory text box (click the Browse button to browse to your directory on the server). If your access privileges on an FTP server are limited to your personal folder, you may be able to leave the text box blank.
- Type a user ID in the Username text box.
- Type a password in the Password text box. Select Save if you want GoLive to save the password.

If necessary, click Advanced to set FTP or HTTP options:

- Choose a Security option. For information about security options, check with your server administrator. If you're using FTP and you choose SSH, you can select Use Public Key Authentication and enter a private key and password.
- (FTP only) Select Use Passive Mode if the FTP server is protected by a firewall.
- (FTP only) Keep the Use ISO 8859-1 Translation option (Mac OS only) selected to use the Latin 1 character encoding set, which encompasses the majority of Western European languages.
- Select Use Standard Framework to use the updated framework GoLive CS2 uses to connect to FTP or HTTP servers. This framework enables SSL (Secure Socket Layer) connections.

To add the server to the application-wide list of servers, click Add To Favorites.

Uploading and downloading files

Connecting to a publish server

You connect to a publish server to upload or download a site or to perform any file transfer operation. Before you can connect to a publish server for the first time, you must set up access to it. GoLive lets you store access to more than one publish server. If GoLive can't connect to the publish server, the Log window displays errors regarding the failed connection. You can use this information to troubleshoot the connection with the publish server administrator.

You can connect to a publish server by using either the Publish Server tab or the file browser:

- To transfer entire sites or to synchronize local files with published files, connect to the server from the Publish Server tab.
- To quickly inspect files on a publish server or update a few files on your published site without opening a site window, connect to a publish server by using the file browser.
To have GoLive display status messages while you're connecting to a publish server, select Status Messages in the Log preferences.

To connect to a publish server
Use the Publish Server tab to transfer entire sites or to synchronize local files with published files.

1 Open a site.

2 Click the Connect To Publish Server button on the toolbar, or choose Site > Publish Server > Connect. The site window automatically opens the Publish Server tab once you connect to a server.

3 (Optional) If you have multiple servers available for connections, you can change to another one at any time by right-clicking (Windows) or Control-clicking (Mac OS) in the site window, choosing Active Server, and then choosing another server.

If you receive the message “Can't connect to server [servername]. Reason: Cannot connect to [protocol]”, check your proxy settings, or review connection errors in the Log window (choose File > Log). Information on proxy settings and connection errors is available in the support knowledgebase on the Adobe website.

See also
“To transfer files” on page 447

Types of site uploads
For a first-time upload, GoLive copies the entire site to the server. Subsequent uploads of the same site will update the existing server-based site to reflect any changes that you may have made to the local files. You can perform three types of uploads to the server:

Modified-itemCopies only new or updated site files to the publish server.

SynchronizingCompares the local modification time with the server modification time to decide whether to upload, download, or delete a file. You can confirm synchronization actions assigned to individual files and assign a different synchronization action to a file before uploading.

SelectionUploads only the files that you select in the site window. This method is useful if, for example, you updated multiple files using one of the other update methods and experienced a crash or an update failure. You can use the selection method to upload one or a few files at a time to possibly locate the problematic file.

When GoLive uploads, downloads, or synchronizes files, it displays details regarding the transfer. You can use this information to troubleshoot failed transfers with the publish server administrator. If you don't want GoLive to display transfer details, deselect Ask for Publish Server Report in Internet preferences.

Upload modification times
When uploading files to a publish server, GoLive caches the local modification time for any file you transfer to the server. When an upload is successfully finished, GoLive gets a file listing with the time of the file modifications on the server. GoLive stores both modification times in the site file and in a reference file so GoLive can distinguish newer files from older ones. This enables GoLive to perform modified-item uploads and synchronizations.

In the event that the modification times for the local and server files become out of sync because you used a third-party file transfer client or because an upload was unsuccessful, GoLive lets you manually synchronize the modification times on both the server and local files without transferring any data.
When transferring files, you might receive an FTP reply code that indicates the state of the server you're connecting to. Search the Internet to learn more about FTP reply codes.

See also
“Synchronizing files without transferring data” on page 446

To upload site files to a publish server
You can upload selected files, upload all files, or use the modified-item method for both first-time uploads and subsequent updates.

1 Open the site and connect to the server. (See “To set up access to a publish server” on page 440.)

2 Do one of the following:
   • To upload modified files, click the Upload Modified Files button on the toolbar or choose Site > Publish Server > Upload Modified Files. Review the files to be uploaded in the Upload dialog box, and then click OK. **Note:** Three different commands are associated with the Upload button. To change the button command, click the arrow to the right of the Upload button and choose an option from the Change Upload Button To menu.
   • To upload selected files, select the folder or individual files to upload in the Files tab, and click the Upload Selection button on the toolbar or choose Site > Publish Server > Upload Selection.
   • To upload all files, click the Upload All button on the toolbar or choose Site > Publish Server > Upload All. Review the files to be uploaded in the Upload dialog, and then click OK.
   • To manually upload selected files, drag the desired file or folder from the Files tab of the site window to the desired location in the Publish Server tab.

   When you select a local file on the Files tab, GoLive reveals the related file on the Publish Server tab.

To perform a synchronized upload for an entire site
Once you've uploaded a site, you can synchronize it to ensure that the local site and the site on the server match. (You can also use the synchronize feature for a first-time upload.)

1 Open the site and connect to the server.

2 Do one of the following:
   • Choose Site > Publish Server > Synchronize All.
   • Click the Synchronize With Publish Server button on the toolbar.

The Synchronize dialog box indicates which files will be uploaded to the server, which files will be downloaded to the local copy of the site, and which files will be removed from both the server and the local site. Missing files are indicated by dimmed file icons on either site.

3 Do any of the following:
   • To display files that won't be synchronized, select Show Skipped Items.
   • To view the files as they exist on the server in folders, select Show Folder Structure.
To exclude a synchronization action, deselect it in the Perform Actions section of the Synchronize dialog box. For example, deselect Trash to prevent GoLive from deleting any files during the synchronization.

To view detailed information on a file, select the file in the Synchronize dialog box. The two text areas at the bottom of the dialog box display local and server information on the file.

4 Confirm the synchronization actions assigned to individual files. If you want to assign a different synchronization action to a file, select the file and click the lower right corner of the Synchronization Action icon displayed in the column next to the file to choose a synchronization option:

**Upload** Upload the file to the server.

**Download** Download the file from the server to the local site.

**Delete** Removes the file from the server.

5 If the Synchronization Conflict icon appears by a file name, the file has been changed on the server and the local site. Assign a synchronization action to the file so that it is not excluded from the synchronization. If a Publish Status Conflict icon appears by a file name, the file’s publish status has been set to Never in the File Inspector. If you want to upload the file, set the file’s publish status to Always or If Referenced (to upload it only if the file is referenced in the site) in the File Inspector.

**Note:** By default, GoLive deletes files that exist on the server but not in your local site. To prevent GoLive from deleting such a file, change its synchronization action to Download, or deselect Trash in the Perform Actions section of the Synchronization window to exclude delete actions from the synchronization.

6 Click OK to start the synchronization process.

---

**See also**

“To set up access to a publish server” on page 440
To set upload options
Uploads are carried out according to options that you can change as necessary.

1 Do one of the following:
   • To select options for the active site only, click the Site Settings button on the toolbar or choose Site > Settings, then click Upload/Export and then select Site Specific Settings.
   • To select options for all sites, choose Edit > Preferences (Windows) or GoLive > Preferences (Mac OS), expand Site and click Upload/Export.

2 Select upload options as follows:
   • To use Publish settings for individual files or folders, select an Honor Publish State Of option in the Publish States section. To override individual publish state settings for files and folders, deselect the respective options.
   • To upload only those files that are part of the site hierarchy, select Linked Files Only. Selecting Linked Files Only automatically deselects the Honor Publish State Of Folders and Files options.

3 Select Cleanups options as follows, and then click OK:

Strip HTML Code For Comments And Spaces  Streamline the source code without affecting the appearance of pages.

Strip HTML Code For Adobe GoLive Elements  Removes GoLive tags and attributes that let you edit your animations, scripted actions, and so on.

Strip GoLive Data From Media Files  Checks all GIF, JPEG, PNG, SWF, and SVG files for Smart Object data and removes the data to make the files smaller.

Flatten Script Library  Scans all files that use the GoLive JavaScript library and rewrites the external files so they contain only the exact JavaScript code needed for the site.

Rewrite PDF Files  Scans all PDF files in the site and optimizes them for quicker upload.

See also
“Assigning publish states to files and folders” on page 240
“Flattening the script library” on page 606

To update a site by downloading it
You can update local site files with files on a publish server by downloading them. Use this method if you make changes at the server-based site that need to be reflected at the local site. You can also perform a synchronization to download files from the publish server to the local site.
**Note:** If you remove GoLive tags and attributes from files by selecting Strip GoLive Data From Media Files or Strip HTML Code For Adobe GoLive Elements when you set upload options, upload the files to a server, and then download them to your local site, GoLive overwrites your local files with the versions that don't contain GoLive tags and attributes. This may cause unexpected results. Use care when replacing local files with files from the server.

1. Open the site and connect to the publish server.

2. Choose a Download button command. To change the button command, click the arrow to the right of the Download button and choose an option from the Change Download Button To menu.

   - **Download all** Copies all files from the server.
   - **Newer downloads** Copies only site files with modification times on the server that are newer than the modification times of the corresponding local files. (If a local file has a newer modification time, GoLive won't download the corresponding server file.)
   - **Selection downloads** Copies your selection of files from the server. They are useful for the same reasons that selection uploads are useful.

**See also**

"To set up access to a publish server" on page 440

**Synchronizing files without transferring data**

You must keep both local and server files synchronized for GoLive to perform synchronized uploads and newer downloads. GoLive lets you manually synchronize the modification times for your local site files and server files without transferring data. Synchronizing manually is useful when the modification times of the local and the server files are out of sync even though you know that the files are identical.

Files can get out of synchronization in a variety of ways. For instance, if you use a file transfer client other than GoLive to upload the file, and later try to synchronize the file from within GoLive, your local file appears older than the server file. The local file appears older because GoLive still refers to the timestamps it created the last time it uploaded the file. To keep the files synchronized, GoLive will try to download the server file that appears to be newer. Such downloads are unnecessary and might take a long time if multiple files are involved.

Synchronizing modification times for an entire site changes the modification times of all files, including any that have been edited but not yet uploaded to the server. These files will not be uploaded by GoLive the next time you do a synchronized upload because the modification times of the local files will match those on the server. If an upload gets interrupted, make sure you don't apply the Sync Modification Times command to files that weren't uploaded.

**To manually synchronize modification times without transferring files**

- With the site open and GoLive connected to the publish server, do one of the following:
  - To synchronize the entire site, choose Site > Publish Server > Sync Modification Times > All.
  - To synchronize a selection of files, select a file, a folder, or a selection of files and folders in the Files tab of the site window and choose Site > Publish Server > Sync Modification Times > Selection.

**Downloading a web page**

You can download a web page, complete with all its media and references, from any website that you can visit with a web browser. You don't need FTP access to the directories containing the page and its images. The page you download opens in a GoLive document window when the download is complete.
The page is downloaded to a location you specify, and its media are placed in a folder alongside the page. This folder structure might not reflect the relative locations of the files on the original website. Media files or media referenced by scripting languages like JavaScript are not downloaded. (For example, rollover images are not downloaded.)

*Note:* You can also download web pages by using the Import From Server function in the Site Wizard or the Download command in the context menu of either the External tab of the site window or the In & Out Links palette.

**See also**

“About GoLive sites” on page 145

“Importing sites from FTP or HTTP servers” on page 148

### To download a web page

1. Make sure that you have a live web connection.
3. Enter the URL for the page.
4. Click Save As, specify a location, then click Save.

   *Because the page you’ll download probably consists of several files, consider creating a new folder for them.*

### To transfer files

You can use the file browser for any file transfer purpose, not just for transferring website files. You can open multiple instances of the file browser and even drag files between them.

*Note:* To upload an entire site, or to perform an update so that the local site and the server-based site are synchronized, use an Upload command from the Site > Publish Server submenu.

1. Choose File > Server > Connect To FTP or File > Server > Connect To WebDAV.
2. Choose a server from the Server menu and click Connect.

   *Note:* If no server is available, click Edit Servers and select a server from the Select Server dialog box. If there are no servers listed, click Add New Server and set up a connection to a publish server.

3. To upload a file or folder, drag it from a site window tab or the desktop to the file browser.
4. To download a file or folder, do one of the following:
   - Drag it from the file browser to a site window tab.
   - (Mac OS only) Drag it from the file browser to the desktop.
   - Right-click (Windows) or Control-click (Mac OS) it, choose Download Files, and select a target folder for download.

**See also**

“To set up access to a publish server” on page 440
Exporting sites

Exporting a site

Exporting a site is adapting its folder structure and other details to a particular publish server—the one you plan to upload it to. Exporting is distinct from uploading: you export to a local drive as a separate step before uploading.

Note: Few web servers require that GoLive sites be exported. Consult your server administrator for information before beginning the export process.

To select site export options

- To select options for the active site only, click the Site Settings button on the toolbar or choose Site > Settings, click Upload/Export, and select Site Specific Settings.
- To select options for all sites, choose Edit > Preferences (Windows) or GoLive > Preferences (Mac OS), expand Site, and click Upload/Export.

Site export options

The following options are available for site export:

Honor Publish State Of Files/Folders  Specifies whether to override individual publish state settings for files and folders, deselect the respective options.

Linked Files Only  Specifies whether to upload only those files that are part of the site hierarchy.

As In Site  Maps the hierarchy of groups, pages, and resources within your site window to the resulting root folder.

Separate Pages And Media  Creates a root folder that contains two subfolders for HTML pages and media, respectively.

Flat  Creates a root folder that contains all HTML pages and media, but no subfolders.

Folder Name  Entries apply to the Separate Pages And Media option. For files that are not in the site, the Folder Name entry applies only when you select the Export Linked Files That Are Not Part Of This Site option.

Export Linked Files That Are Not Part Of The Site  Specifies that the export will include orphan files.

Show Options Before Export  Displays these Export options at the time of each export.

Strip HTML Code For  Select Comments or Spaces to streamline the source code without affecting the appearance of pages. Select Adobe GoLive Elements to remove GoLive tags and attributes that let you edit your animations, scripted actions, and so on.

Strip GoLive Data From Media Files  Checks all GIF, JPEG, PNG, SWF, and SVG files for data that has been added to those files to enable the Smart Object workflow. This data is only added to the target files of Smart Objects. The option then removes the data to make the files smaller.

Flatten Script Library  Scans all files that use the GoLive JavaScript library and rewrites the external files so they contain only the exact JavaScript needed for the site. This option is recommended.

Rewrite PDF Files  Scans all PDF files that are part of the site and optimizes them for quicker upload.
To export a site to a local drive
1 Open the site.
2 Choose File > Export > Site.
3 If the Export Site Options dialog box appears, review the options and make changes as needed. The changes you make apply to the current export only.
4 Click Export. By default, the settings in the Export Site Options dialog are identical to those in the Site Settings under Upload/Export.
5 Specify a location on a local drive for the exported root folder of the site.
6 Click Save.
7 Click Yes or No. Clicking Yes displays information about the export: the files exported, the files not exported and the reasons they weren't exported, and the export options used.

Note: If you want the Export Site Options dialog box to appear each time you export a site, choose Edit > Preferences (Windows) or GoLive > Preferences (Mac OS), expand the Site settings, click Upload/Export and make sure the Show Options Before Export Dialog option is selected.

To upload a site you have exported to a local drive
❖ Drag the exported root folder or its contents to its destination folder in the file browser window.

You cannot use an Upload command from the Site > Publish Server submenu or the Upload button on the toolbar for this operation.

Drag the contents of the folder if dragging the folder itself would create an unnecessary extra folder level on the server.

Setting up distributed websites

About distributed websites
Distributed websites are spread across several servers, or subsites. If you plan to distribute your website, you can still develop and test the site as a whole on your local file system. To do so, you need to set up the distributed site with URL mappings between local addresses and server addresses.

The advantage of URL mappings is that you can easily manage multiple sites without having to rewrite URLs or duplicate files. The sites may share many of the same files and may even link to each other.
To set up a distributed website

1. Create a separate site document for each server.
2. Keep index.html as the file name for home page of the site that is the entry point of your distributed site.
3. Rename the home page file name for all the other subsites. Renaming avoids duplicate file names in your distributed site.
4. Add pages and links for all the subsites, linking between subsites as you would if you were linking to another local site. For example, a link from a page in the Soccer subsite to the Putters.html page in the Golf subsite might be addressed file://Golf/Putters.html. Links between subsites can use either relative or full paths.
5. Make the site window containing the index.html home page active.
6. Click the Site Settings button on the toolbar, or choose Site > Settings.
7. Click URL Mappings, and then click the Create New Item button.
8. Choose Root Of This Site from the menu next to the Map Local Folder or Remote Server box.
   The Root Of This Site option displays the path to the root folder corresponding to the current site document. When you provide an external link to an address on the server in the next step, you can probably preserve some of this path.
9. Edit the path so it contains the URL to the location this root folder will have on the server.
   Note: You can also use URL Mappings to map a local folder if you want to conceal your site's folder hierarchy.
10. Choose Root Of This Site from the With Local Folder menu.
   This option maps the current location of the root folder to its future location on the server.
11. Click OK to save the site settings, or repeat steps 4 - 10 for each of the site documents you renamed in step 3.
   Note: If you plan to use the Clean Up Site command with any of the subsites you have created, first deselect Add Used Files and Add Used External References in the Clean Up Site Options dialog box. Otherwise, using the Clean Up Site command will destroy the structure of the distributed site.

To test a distributed site in a browser before uploading

1. View a page in any of the root folders that contains a link that references a page in another root folder.
2. Move the cursor over the link. The link should contain the local path to the page.
3. Repeat these steps for every link referencing a page in another root folder.

Managing websites with WebDAV

About WebDAV

GoLive supports a server technology known as Web Distributed Authoring and Versioning (WebDAV). WebDAV is a standard (RFC 2518). This technology adds extensions to the HTTP protocol that let authors safely work on a website in a workgroup environment. Using WebDAV, you can lock files so that documents will not be accidentally overwritten or updates lost, as well as download and upload files, obtain information about files, and keep a local site and server site fully synchronized. You can find more information and the latest news about WebDAV at www.webdav.org.
To use WebDAV, you must have connection to a server with WebDAV capability, which can be any of the following:

- Adobe Version Cue Workspace (a feature of the Adobe Creative Suite)
- Mac OS X and Mac OS X Server (with mod_dav installed)
- Microsoft IIS 5 (included with Windows 2000) and Microsoft IIS 6
- Microsoft Exchange Server
- Apache (with mod_dav module installed)
- Novell NetWare 6.0
- Tomcat (with Jakarta Slide)
- Tamino WebDAV Server
- Jigsaw
- Python WebDAV Server

A web team can work on a WebDAV production server in house, and then use the GoLive Publish Server feature to upload the site to a public server without WebDAV capability.

**Locking files**

The WebDAV protocol supports two kinds of locks—exclusive and shared:

- An exclusive lock set by someone else is indicated by the padlock icon 
  . Only the user who locked the file can edit it. Other users have read-only access to the file.
- An exclusive lock assigned to you is indicated by the pencil icon 
  . This indicates that only you can edit the file.
- A shared lock assigned to other users is indicated by the shared lock icon 
  . Unlike an exclusive lock, the shared lock simply alerts people that several individuals are editing the same file. It does not actually lock the file. People without a shared lock can only read the document.
- A shared lock you participate in is indicated by a variation of the shared lock icon 
  .

*Note:* Shared locking is not supported by all servers.

**To lock and unlock files and folders**

1. In the Publish Server tab of the site window, select the file or files that you want to lock.
2. Right-click (Windows) or Control-click (Mac OS) the selected files or folders and do one of the following:
   - To lock a file or selection of files, choose Lock or Shared Lock from the context menu, depending on whether you want an exclusive or shared lock. An exclusive lock or shared lock icon appears to the right of the file name in the Publish Server tab.
   - To lock a folder, choose Lock All or Shared Lock All from the context menu.

*Note:* Locking folders is unsupported by many servers, including Microsoft IIS 5. Only single files can be locked and unlocked.

- To unlock files or folders, choose Unlock from the context menu. The locked icon to the right of the file names in the Publish Server tab disappears.

**To delete a file or folder**

- Right-click (Windows) or Control-click (Mac OS) the file or folder and choose Delete from the context menu.
The context menu also lets you refresh the current view, select all files, and create a new folder, as well as set locks and synchronize a site. You can copy and move files using the standard desktop commands for your computer platform.

**To obtain information about files**

1. Select the file in the Publish Server tab of the site window.

2. If the Publish Server Inspector is not showing, choose Window > Inspector.

3. Click one of the tabs in the Inspector:
   - **File tab** Displays a file's name, URL, creation and modification dates, and size.
   - **WebDav Lock tab** Provides information on the file's lock status, including the lock type, owner, access type available, scope of the lock (exclusive or shared), and lock timeout.
Chapter 21: Building and updating Co-Author sections

Understanding co-authoring

The Co-Author feature
Sometimes, the person best suited to update content in certain sections of a website isn’t a web designer, but another employee, who may or may not be web savvy. For example, imagine the News section of a corporate site, which contains articles relevant to the company and needs weekly updating. Rather than use a web designer’s time to revise the content, a marketing intern can be tasked with updating it.

The Co-Author feature in Adobe GoLive allows web designers to build sections of a site that other people can then easily update. Sites can include regular pages that the web designer updates, and template-based pages that the co-author updates. Co-authoring is especially useful when someone unfamiliar with website design needs to update information in targeted areas of a site.

Web designers use the full version of GoLive, including the Co-Author section window, the Co-Author Editor, and the Co-Author palette, to create the site and build the co-author sections. Co-authors use only Adobe Co-Author (not the complete version of GoLive). Adobe Co-Author uses a simple, streamlined interface that provides only those features required by the co-author—features that let you update text, images, and links in pre-designed sections. The Co-Author Editor in GoLive and Adobe Co-Author use the same interface.

Co-authors are responsible only for the updating phase; the web designer creates, tests, and uploads the section and its files before handing it off to the co-author to update the content.

GoLive provides several Co-Author site samples in the New dialog box: Choose File > New, and then click Site > Co-Author Samples.

Co-authoring workflow
Co-authoring consists of two distinct phases: the first performed by a web designer, or a professional skilled in website development and design; the second performed by a co-author, or someone available to continually update the site who is not necessarily an expert in web development.
1. **Consider how to integrate the dynamic content (web designer).**

   Decide which content needs regular updating, and then design the site structure and page layouts appropriate for the content. Use the GoLive Diagram feature to help you conceive your site (see “About diagrams” on page 181 for more information).

2. **Define Co-Author sections (web designer).**

   Create a Co-Author section to hold the data (stories), templates, section file, and other resources GoLive uses to generate the Co-Author web pages.

3. **Designate site templates and designate Co-Author content (web designer).**

   Create the templates that the site's pages will be based on. Use the Co-Author palette to specify the regions that Co-Authors can edit, and match the region names to the item names in the Co-Author section.

4. **Create Co-Author stories (web designer).**

   In the Co-Author Editor, create stories that GoLive will use to generate the HTML pages.

5. **Publish the site and export a Site Locator file (web designer).**

   Generate the Co-Author pages, and then preview and test the site. Export the Site Locator file that the Co-Author uses to download the site for maintenance.

6. **Update the site (co-author).**

   Download the site by using the Site Locator file, and use Adobe Co-Author to update the co-author sections.

   **See also**

   “To create or edit a co-author story” on page 459

---

**Web designer phase: creating Co-Author sections and items**

**Co-Author sections**

As a web designer, you use co-author sections to organize the editable content into major groups, and to specify the individual items, or content containers, within each group. Editable items include such things as headlines, images, and articles for a news site; or product names, photos, descriptions, and prices for a catalog site.
You then link a section to one or more templates, which specify the layout of the items on the page. Each item is placed into an editable region of the template. A single item can be used in multiple templates.

When you create a section, a section folder appears in the site window. This folder contains a section.aglsec file, which is used to manage the items and link to the preview page. The folder also contains separate pages, stories, and templates folders.

**To create a Co-Author section and Co-Author items**

1. Create a new site or open an existing site.

2. Choose Special > Create Co-Author Section, and then enter a Section Title in the “section.aglsec” window that appears.

3. Do one of the following:
   - Import items from an external data source, such as an InDesign Package for GoLive file or a comma-delimited file. (See “To import items from an external data source” on page 455.)
   - Manually enter items in the “section.aglsec” window. (See “To manually enter items in the section window” on page 456.)

   Match the item name to the corresponding region name in the template file to which you’ll link the section. Matching the names ensures that the stories populate the templates correctly.

4. Choose the sort order for the Co-Author Editor and Adobe Co-Author Stories list from the Sort menu:

   - **By Creation Date** Sorts the stories list in the order the items were created.
   - **By Data Item** Sorts the stories list in the order of the specified data item.

5. From the List Item menu, specify the field that you want to appear in the stories list of the Co-Author Editor and Adobe Co-Author. The Sort and List Item fields do not necessarily need to match. For example, you can view product names (List Item) in the stories list, and then sort them by their prices (Data Item).

6. In the Preview Page field, specify the page that you want to appear in the Preview tab of the Co-Author Editor and in Adobe Co-Author. You must create and save the page file before you can specify it.

![Image](image.png)

The Co-Author "section.aglsec" file used to create and manage sections

**To import items from an external data source**

You can use InDesign Package for GoLive (IDPK) files (created from merged InDesign documents) or comma-delimited (CSV) files as external data sources. For example, you can populate fields in Co-Author sections with data from a linked CSV file.
Use the GoLive CS2 SDK Programmer’s Guide to configure Co-Author to import data from additional external data sources. (To access the SDK, open the GoLive CS2/Adobe GoLive SDK folder on your hard disk.)

1 Do one of the following:
   - If you plan to use a CSV file as a data source, make sure that the first row of the file contains the items you wish to use as item names. To use a link col (a column that contains links to an image file), mark it with “@” in the CSV file (for example, @image). Links must be absolute relative to the CSV file.
   - If you plan to use an InDesign Package for GoLive file based on a merged InDesign document, make sure that you place data field placeholders on master pages when you create the merged document in InDesign. (For information about creating merged InDesign documents, search for information about creating target files in InDesign Help.)

2 Click Browse in the Data Source field in the “section.aglsee” window, navigate to the file, and click Open.

   **Note:** When you import items from an external data source, you cannot edit the resulting data in the Co-Author Editor or in Adobe Co-Author. Use the Data Source option only if you have a data source from which you want to automatically generate pages. If you need to make changes, make them in the data source file, and then regenerate the pages in Co-Author.

**To manually enter items in the section window**

1 In the section window, select Name in the Item Name column. When you select an item, it appears in the editable fields at the bottom of the list.

2 In the editable fields, enter the item name and the display name, choose an option for the selected item from the Format Type menu and, if necessary, specify the height of the item as it will appear in the Co-Author Editor and in Adobe Co-Author. (The display name is the name that appears next to the editable field in the Co-Author Editor and in Adobe Co-Author.)

3 Click the Create New Item icon.

4 Repeat steps 1-3 for each item you want to add to the section.

**See also**

“Page templates” on page 420

**Creating co-author templates**

Co-author templates specify the layout of items by using editable regions. A co-author section can have an unlimited number of templates.

You can create two types of templates: page templates and list templates. Page templates let you create a separate web page for each story in the co-author section. List templates let you create a single web page that contains a list of the items (editable regions) from multiple stories.

   **You can use a list template as a component to populate table cells on a static web page. Create the list template, and then link a cell’s component to the template using the Inspector. After you create stories and generate the web pages, the table cell contains a list of the repeated regions from multiple stories.**
To create a page or list template

1. Open a new page, and then choose Window > Site > Co-Author. The Co-Author palette opens.

2. Choose File > Save As and save the template file to the section’s Templates folder. Saving the file to the Templates folder lets you assign editable regions to it.

3. In the Layout window, select the contents of the first editable region you want to create.

4. In the Co-Author palette, select the corresponding item from the Apply Region menu.

5. If you want to create a list template, select the element that contains the regions you want to repeat (such as a table that contains name and price regions), and then select Repeat. By default, GoLive uses all the stories to generate the list. If you want to use only certain stories, enter the number of the first story (according to the sort order) in the Start field, and then enter the total number of stories to use in the Count field.

6. Repeat steps 3-5 until you’ve created editable regions for all the items you want to use in the template.

7. Save the file.

Linking to co-author templates

Creating links between and within templates, and from the templates to other pages in the site, is an important part of creating co-author sections. You can create the following types of links:

**Links between page templates** Use these links to link the generated pages in a one-to-one relationship. For example, if a co-author section contains two template pages, then GoLive generates two separate web pages per story, and links the first page for each story to the corresponding second page.

**Links within page templates** Use these links to create navigational links between the pages generated from each story in the section. To create the links, use the “#next” and “#previous” strings in the link field of the Inspector. When no previous or subsequent story exists, as with the first and last story in the list, the links and their content do not appear.

**Links between list and page templates** Use these links to create navigational components and tables of contents. When you link from a repeated region of a list template, each item (story) in the generated list page contains a link to its corresponding page (generated via the page template).

Using images in co-author pages

Co-author sections can include image items. You can add an image to a co-author template in the following ways:

**Image icon from the objects toolbox** Use to place an image in the template, and then assign the appropriate co-author item region. The width and height of the image used in the template determine the bounding box for the images used in the generated pages. GoLive resizes the image proportionally and converts it to a JPEG image.

**Smart Object** Use to place a Smart Object in the template, and then assign it an item region. Choose a source for the Smart Object and create a target image file in the desired format and with the desired settings. In this method, the source file is unimportant—it’s the target file that specifies the image settings. Make sure you place the source file into the section’s Templates folder.

**Smart Object with variables (assigned in Adobe ImageReady®)** Use to automatically specify the item region according to the variables. Make sure that the variable name matches the item name. Place the image target files in the section’s Templates folder.
Creating the initial co-author stories
The web designer may want to create the initial stories (and resulting web pages) to provide examples for the co-author, and to preview and test the site. To create co-author stories, see “To create or edit a co-author story” on page 459.

Generating and previewing co-author web pages
Typically, the co-author adds and edits stories, and then generates the updated web pages. However, during Co-Author site development, the web designer may generate the initial pages. Generating the initial pages not only provides an example of how the pages appear for the co-author, but also allows you to preview and test the pages to ensure the site is functional and complete.

To generate co-author web pages in GoLive
1. Open a “section.aglsec” file, or select it in the Files tab of the site window.

   Note: To generate pages, you must have previously created a co-author section with items, set up a template with editable regions, and created stories in the Co-Author Editor.

2. Choose Special > Generate Co-Author Pages. GoLive generates a page for each story, placing them in the section's pages folder.

   Note: You can also generate co-author web pages by using the Co-Author Editor.

To preview co-author web pages
- Use either the Preview tab of the page's document window or the Co-Author Editor. (Co-authors preview the pages only from within Adobe Co-Author.)

   The Co-Author Editor lets you edit the page content, but not the layout. The document window lets you edit the layout, but not the content. Keep in mind that co-author pages are based on templates—and only the web designer can edit the templates.

See also
“Previewing web pages” on page 31

Co-author phase: updating a co-authored website

The updating phase
The co-author's work begins when the website design and generation is complete. You use Adobe Co-Author to update the site. Adobe Co-Author has a streamlined, intuitive interface, which makes it easy to use regardless of your experience. The editor lets you perform only the tasks required for updating a section, preventing you from inadvertently changing something other than the targeted content. After you enter the data, Adobe Co-Author passes it through pre-designed templates to generate the section's web pages. You can then upload the updated web pages with the click of a button.
Updating co-author web pages
Use Adobe Co-Author to update pages and create new ones. The update process is as follows:
1. Open or download the site.
2. Edit or create stories (content) for the web pages.
3. Generate and publish new pages.

**Note:** You can update only certain types of content on co-author web pages, including text, links, and images. You cannot change the layout of the pages or otherwise edit them.

To open a website to update
1. Start Adobe Co-Author, and click Edit Web Site.
2. Locate and select a site file, and then click Open. The site file, .site, is at the root level of the site folder.

To download a website to update
1. Start Adobe Co-Author, and click Download Web Site.
2. Locate the Site Locator file (provided by the web designer), and click Open.

To create or edit a co-author story
Co-author stories contain the content (organized by item names) that GoLive places in a template to generate the co-author web pages. You can edit existing stories and create new ones.

**Note:** If the web designer imported items from an external data source, you cannot edit the resulting fields in Adobe Co-Author.
1. In Adobe Co-Author, open the site containing the co-author sections.

**Note:** Web designers can use the Co-Author Editor in GoLive to create initial co-author stories.
2. From the Sections menu, select the section you want to update.
3. In the Stories list, select the story you want to edit, or click New Story to create a new story. (Stories are named according to the item specified in the List Item field of the section.aglsec file.)
4. In the Edit tab, update the item fields as appropriate:
   - For text blocks, you can specify bold and italic styles by using the buttons above the text block, and you can add or update links by using the Link button.
   - For image items, you can click Browse Images to specify a different image.
To preview a co-author web page
1 In the Stories column of Adobe Co-Author, select the story for the page you want to preview.
2 Click the Preview tab.

Note: Links are disabled in the Preview tab.

To generate or publish co-author web pages
As the co-author, after you have created and edited the stories, you can generate the web pages and publish them.
In some cases, you may want to have the pages reviewed before you publish them; in other instances (such as when you’ve simply made text corrections) you may want to publish them directly. Coordinate with the web designer or an administrator to determine the best workflow for a site.

1 In Adobe Co-Author, select a section from the Section menu.
2 Select one of the following:

Generate Lets you create the web pages and place them in the section’s pages folder.

Publish Lets you create the web pages, place them in the section’s pages folder, and then upload them to the server specified by the web designer during the sites creation.
Chapter 22: Authoring mobile content

Authoring for mobile devices

Designing for mobile devices
On mobile telephones and personal digital assistants, viewers can access a variety of mobile web content. Many users pay additional fees for web browsing on their mobile telephones and handheld computers, so developing a successful mobile website requires working within special constraints. You need to optimize text, images and navigation for small screens, and file size for minimal download times.

GoLive helps you optimize mobile designs in several ways. When you create XHTML, i-mode HTML, and WML pages, Mobile View reduces page width in the Layout Editor, and phone emulators provide accurate previews. When you create MMS messages, phone profiles reflect screen size and colors. For any mobile format, you can also preview content using the Small Screen Rendering option in GoLive's built-in Live Rendering browser.

See also
“To change the default preview device for MMS” on page 465
“To set view options for page layout” on page 159
“To preview a page in a phone emulator” on page 483
“To preview your page in the Live Rendering browser” on page 32

Using cascading stylesheets for flexible page designs
With cascading stylesheets, you can create flexible page designs that work well in both standard and mobile browsers. To produce liquid layouts that automatically adjust to different screen dimensions, use GoLive's CSS layout objects. To specify different text formatting for standard and mobile browsers, create separate Screen and Handheld styles (use the @media rule for internal stylesheets, or the Media box for external stylesheets). You can preview both Screen and Handheld styles while laying out a page.

GoLive provides a cascading stylesheet that's optimized for mobile devices: Choose File > New, and select Mobile > CSS > Basic CSS.
See also
“About CSS layout objects” on page 245
“Setting view options for page layout” on page 159
“To create an @media, @font-face, or @page rule” on page 329
“To reference an external stylesheet from web pages” on page 323

Formats for mobile content
In GoLive, you can create content for mobile devices by using the following formats:

Multimedia Messaging Services (MMS) A multimedia standard in SMIL format, which is XML-based. 2.5G and 3G devices support MMS.

Scalable Vector Graphics (SVG) An XML-based format that lets you integrate web graphics with interactive scripting and dynamic databases. GoLive produces SVG Tiny files, which are compatible with a wide range of mobile devices and the Adobe SVG Viewer.

Extensible Hypertext Markup Language (XHTML) An extensible, XML-based version of HTML, supported by 2.5G and 3G mobile devices. For mobile authoring, you can use two types of XHTML: XHTML Basic and the more advanced XHTML Mobile.

i-mode Hypertext Markup Language (i-mode HTML) Also known as cHTML, i-mode HTML is a special subset of HTML developed for use with 2.5G i-mode devices.


Third Generation Partnership Program (3GPP) A movie format designed for 3G mobile devices. In GoLive, you create and edit 3GPP movies by using the QuickTime editor. (Choose File > New, and select Mobile > Multimedia > 3GPP.)

See also
“About SVG Tiny format” on page 466
“About creating a new XHTML Basic or Mobile page” on page 468
“About i-mode HTML” on page 470
“About WML” on page 473
“About editing QuickTime movies” on page 525

Creating MMS messages

About MMS messages
MMS messages are multimedia SMIL files that mobile phones can display. In GoLive, you can edit, preview, and optimize these messages for specific devices. To publish optimized messages, you must deliver related SMIL and media files to a mobile content provider.
MMS messages consist of slides, and each slide can contain one text, image, audio, and video file. You edit this content in the document window and MMS Inspector. In addition to message content, you can attach files that the mobile viewer must open separately.

Workspace for MMS messages
A. Edit duration in Timeline area
B. Edit contents in Slide area
C. Select source files in MMS Inspector

To create or edit an MMS message

When you open an MMS message, GoLive limits the SMIL set in the objects toolbox to these MMS-compatible objects: Audio, Image, SVG, and 3GPP. (Text doesn't require an object because you can type directly in the document window.)

1 Either open an existing MMS (.smil) document, or choose File > New, and select Mobile > Pages > MMS Document.

2 In the toolbar, select one of the following from the Recipient's Device menu:
   • A phone profile to optimize the message for a single device.
   • Multiple Devices to open the MMS Optimizer.

3 In the document window, click the Add Slides button to create blank slides.

4 To add content to slides, do any of the following:
   • From the Gallery tab in the MMS Inspector, drag files to slides.
   • From the SMIL set in the toolbox, drag multimedia objects to slides. Then specify source files in the Message tab of the MMS Inspector.
   • Click the text box below slides, and either type text or specify text files in the Message tab of the MMS Inspector. Then select an Align Text option in the Inspector.

5 To change the overall duration of a slide, enter a value in the Sec box; to change the duration of slide contents, drag clip edges in the Timeline.

6 To change the position of slides or slide contents, drag clip names in the Timeline.
7 To set the message's file size, choose one of the following from the Max Size menu:

- "None" to set no maximum size.
- A preset kilobyte value.
- "Automatic" to optimize the size for the current preview device.
- "Custom" to enter a kilobyte value that isn't listed in the menu.

**Note:** If the source files exceed the size you've specified, GoLive displays a warning icon next to the Max Size menu. Click the icon to downsample images; GoLive can't reduce the size of other file types.

8 Below the phone preview, click the Play button to view the MMS message.

9 Save the message.

GoLive creates a SMIL file for mobile download, and an XML file that references the original source files. (Do not delete the XML file if you plan to reoptimize the message for another device.)

**See also**

“To optimize messages for multiple devices” on page 465

**To add a folder of images as a slide show**

1 In Slideshow tab of the MMS Inspector, select one of the following:

- **Replace Current Slides** Replaces all existing slides.
- **Add Slides** Inserts new slides after existing slides.

2 Enter the Slide Duration for all slides.

3 Click Select Slide Content, select either a folder or specific files, and then click Open.

**To add or remove files in the MMS gallery**

In the MMS Inspector, the Gallery tab provides quick access to a wide range of MMS-compatible content that GoLive installs. You can customize the gallery by adding your own files or removing existing ones.

❖ From the MMS Inspector palette menu, select any of the following:

- **Add MMS To Album** Adds the open MMS message.
- **Add Media To Album** Displays the Open dialog box, where you can select any MMS-compatible file.
- **Remove Media From Album** Removes files you've selected on the Gallery tab.

**To create an MMS message from a PDF file**

1 From the MMS Inspector menu, select Create MMS From PDF.

2 Select a PDF file, and click Open.

**To export an MMS message as a QuickTime movie**

1 From the MMS Inspector menu, select Export MMS As Movie.

2 Specify a file name and location, and click Save.
To optimize messages for multiple devices

When you create or edit an MMS message, you can optimize it for a single phone chosen from the Recipient's Device menu. To optimize messages for multiple devices, however, you must use the MMS Optimizer dialog box.

1. Do either of the following:
   - To optimize an open MMS message, choose Multiple Devices from the Recipient's Device menu in the toolbar, and then skip to step 5.
   - To optimize multiple MMS messages, choose Special > MMS > MMS Optimizer.

2. In the MMS Messages section of the MMS Optimizer dialog box, click the Create New Item button.

3. Select the .smil files you want to optimize, and click Open (Windows) or Choose (Mac OS).

4. To preview a message, select it, and then click the Play button in the MMS Preview section.

5. In the MMS Device section, select the devices you want to optimize for, and click Add.

6. To change a mobile device's color profile, select the device, and click Settings. Set options in the Save For Web dialog box, and click Save.

7. Click Optimize. Then specify a location for the optimized messages, and click OK (Windows) or Choose (Mac OS).

To change the default preview device for MMS

1. Choose Edit > Preferences (Windows) or GoLive > Preferences (Mac OS).

2. Select MMS, and choose a device from the Default menu.

   To download the latest phone profile from Nokia or Sony Ericsson, click Check For Updates.

To create or edit MMS phone profiles

1. Choose Edit > Preferences (Windows) or GoLive > Preferences (Mac OS).

2. Select MMS, and click Configure.

3. Do any of the following:
   - To delete a listed device, select it, and click the Delete button.
   - To create a new device, click the Create New Item button.
   - To change the properties of an existing device, select it.
   - To download the latest phone profiles from Nokia and Sony Ericsson, click Check For Updates.

4. To move a device higher or lower in the menu list, click the up or down arrows.

5. Enter a device name in the Phone text box.

6. To position the phone preview relative to the left and top edges of the GoLive document window, enter Left and Top pixel values.

7. To change the size of the phone display, enter Width and Height pixel values.

8. Select a color depth from the Colors menu.

9. To specify a phone image, click Choose Image, and select a file in the GoLive CS2\Settings\MMS\Phones folder.

10. To change the device's color profile, click Settings. Set options in the Save For Web dialog box, and click Save.
Creating SVG Tiny files

About SVG Tiny format
GoLive creates SVG Tiny files, which are optimized for mobile devices. SVG Tiny normally doesn’t support scripting, but many mobile browsers have added JavaScript support for interactivity. To quickly add commonly supported JavaScript, you can use SVG actions that GoLive provides. You can also add custom JavaScript to integrate with server-side code, such as JSP or PHP.

With the Adobe “SVG” Viewer, you can view SVG Tiny files in a standard web browser.

To create or open an SVG file
❖ Choose File > New, and select Mobile > Multimedia > SVG Tiny Image. Or choose File > Open, and select an .svg or .svgz file.

When you resave an .svgz file, GoLive retains the original compression settings.

Editing SVG in the document window
When you edit an SVG file, the document window displays a preview on the left, and a layer view on the right. The layer view reflects the Layers palette in Adobe Illustrator.

In the preview, you can magnify objects with the Zoom tool and select objects with the Hand tool. When you select objects in either the preview or layer view, GoLive highlights related code in the Source and Outline editors. Revise this code to change object properties such as position and scaling.

To see the preview and layer view with code, click the Show/Hide Split Source button in the lower left of the document window.
SVG actions

When you select an SVG object in the document window, you can use the Action Inspector to apply the following actions to mouse events:

**Scale Shape** Sets scaling and offset position in pixels, and duration in milliseconds.

**Set Attribute** Sets values for XML attributes.

**Set Color** Sets stroke and fill color.

In code, GoLive SVG actions include the comment "agl<<action name>>" for easy identification.

To add custom JavaScript to an SVG file

In the upper left of the document window, click the JavaScript Editor button to the right of the SVG timeline.

*Note:* Each mobile browser treats JavaScript slightly differently. To verify that code functions as you expect, test it in a targeted mobile phone.

See also

“To edit an existing JavaScript” on page 604
XHTML Basic and Mobile

To create a new XHTML Basic or Mobile page

When you create a new XHTML Basic or Mobile page, GoLive automatically uses Mobile View in the Layout Editor and disables unsupported options in the Type menu. However, you must manually configure the objects toolbox so that it provides only compatible items.

❖ Choose File > New, and then select Mobile > Pages > XHTML Basic Page or XHTML-MP Page.

See also

“Designing for mobile devices” on page 461

“To configure the objects toolbox for XHTML Basic or Mobile” on page 469

“To add phone emulators and set a default” on page 482

To convert an HTML page to XHTML Basic or Mobile

1 From the document window menu , choose Markup > Convert To XHTML, and then set conversion options.

2 From the document window menu, choose Doctype > XHTML Basic 1.0 or XHTML Mobile 1.0.

   When you change the doctype, GoLive automatically disables unsupported text formatting options in menus.
See also
“Designing for mobile devices” on page 461
“To convert the doctype of a document from HTML to XHTML” on page 162
“To configure the objects toolbox for XHTML Basic or Mobile” on page 469
“To preview a page in a phone emulator” on page 483

To copy HTML pages to XHTML Mobile
1 Open a page, or select pages in the site window.
2 Choose Special > Convert > To XHTML Mobile, and then set the following options:
   * **Downscale Images Bigger Than** Shrinks large images to the width specified in pixels.
   * **Mobile Display Width** Shrinks pages to the width specified in pixels.
   * **Remove Images Named** Removes spacer images used when laying out web pages. (By default, GoLive removes files named spacer.gif.)
   * **Strip Code Elements** Removes web-based CSS styles or BR tags so that you can reoptimize formatting and layout for mobile devices.
   * **Save To Folder** Saves all copies in the specified folder. Deselect this option to save copies in the same folders as source files.
   
   The file names of saved copies begin with "mb_".

See also
“Designing for mobile devices” on page 461
“To configure the objects toolbox for XHTML Basic or Mobile” on page 469
“To preview a page in a phone emulator” on page 483

To configure the objects toolbox for XHTML Basic or Mobile
XHTML Basic and Mobile are a subset of XHTML, so these formats do not support all elements. You can configure the Objects toolbox to display only supported elements.

❖ From the objects toolbox menu ☐, choose Configure > XHTML Basic 1.0 or XHTML Mobile 1.0.

See also
“Designing for mobile devices” on page 461
“To preview a page in a phone emulator” on page 483
i-mode HTML

About i-mode HTML
i-mode HTML (also called cHTML) is most widely used in Japan for the popular i-mode mobile phone service. In GoLive, you can easily develop i-mode sites for both Roman alphabets and double-byte (Asian) languages.

To efficiently develop an i-mode site, set up an i-mode template page that uses a DoCoMo layout profile, which simulates the page and type size of a phone browser. Then you can quickly create new pages by opening your template page in the site’s Templates folder.

To apply a DoCoMo layout profile, click the Layout tab in the document window. Then, from the Basic Profile menu in the View palette, choose NTT DoCoMo > DoCoMo [browser version].

To create a new i-mode page
When you create a new i-mode page, GoLive automatically uses Mobile View in the Layout Editor and disables unsupported options in the Type menu. However, you must manually configure the objects toolbox so that it provides only compatible items.

❖ Choose File > New, and then select Mobile > Pages > i-mode EU Page or i-mode J Page.

See also
“Designing for mobile devices” on page 461
“To configure the objects toolbox for i-mode HTML” on page 471
“To preview a page in a phone emulator” on page 483

To convert an HTML page to i-mode HTML
❖ From the document window menu ☰, choose Doctype > i-mode HTML [version number].
Note: Scrolling marquees are available only for i-mode HTML 2.0-5.0 pages. Also, when you change the doctype, GoLive automatically disables unsupported text formatting options in menus.

See also
“Designing for mobile devices” on page 461
“To configure the objects toolbox for i-mode HTML” on page 471
“To preview a page in a phone emulator” on page 483

To configure the objects toolbox for i-mode HTML
i-mode HTML is a subset of standard HTML, so not all elements and attributes are supported. You can configure the objects toolbox to display only supported elements.

❖ From the objects toolbox menu  ▽  ▽  ▽, choose Configure, and then choose an i-mode HTML version that’s compatible with targeted mobile browsers.

Note: Avoid using Layer objects in your i-mode pages. Layers include invalid i-mode tags.

See also
“To preview a page in a phone emulator” on page 483
"Designing for mobile devices" on page 461

To enable Japanese i-mode authoring
Japanese i-mode pages require Shift JIS and Unicode UTF-8 character encoding. In addition, to use emoji characters in your pages, you must enable the i-mode Emoji module.

Note: UTF encoding is enabled by default. Use the following procedures to enable Shift JIS encoding as well.

1 Choose Edit > Preferences (Windows) or GoLive > Preferences (Mac OS).
2 Select Encodings from the list on the left.
3 On the right, expand Japanese Windows and select the “shift_jis” charset.
4 Select Modules from the list on the left.
5 On the right, expand the Extend Scripts folder, select i-mode Emoji.
6 Click OK, and then restart GoLive.

Adding emoji characters to an i-mode page
Emoji characters are picture symbols in the i-mode font set. The glyph, or visual representation of the character, is a picture instead of a letter. Because an emoji is a character, it only takes up two bytes of memory—much less than a small GIF image. There are 176 basic emoji characters and 76 extended characters, so you can communicate information very efficiently. In i-mode HTML, emoji are represented by name and category group, by default. You can select one of three methods to insert your emoji entities: Shift JIS Decimal Code, Shift JIS Binary, and Unicode Hexadecimal Code. (Page character encoding must be set to Unicode UTF-8.)

An emoji entity is comprised of an ampersand, a pound sign followed by 5 digits, and an ending semicolon. For example, the code &\#63647 represents the character “fine” (as in “fine weather”), which looks like a shining sun. To add emoji to Roman language pages, you can simply use ampersand code, without enabling Shift_JIS page encoding.
Note: To view emoji characters on a computer, the emoji font must be installed.

**To set default emoji encoding and appearance**

1. Choose Special > i-mode Emoji Settings.
2. Select a default encoding method and emoji appearance, and then click OK.

*Note: If the emoji characters appear as a question mark in the Layout window, make sure that the Default Method setting for emoji is set correctly.*

**To add emoji characters to i-mode pages**

1. Drag the i-mode Emoji icon from the objects toolbox to the Layout Editor.
2. In the i-mode Emoji Inspector, select a character.

*To add links to emoji characters, insert them into inline text.*

**To add images to i-mode pages**

You can place GIF images on an i-mode page, but make sure that the image file size is small. Do your major image editing in a graphics application such as Adobe Photoshop or Adobe Illustrator, and then save a copy as a GIF image. Or better yet, use GoLive Smart Objects and link the original Photoshop or Illustrator image directly to your page. Then you can optimize and resize the GIF image within GoLive.

☆ Do one of the following:

- Add a Smart Photoshop, Smart Illustrator, or Smart Generic Object to your page. In the Save For Web dialog box, choose GIF format, and specify either 2 colors (for simple black-and-white graphics) or 256 colors (for images with intermediate shades).
- Add a preoptimized GIF file to your page by using the Image icon.

See also

“Advantages of Smart Objects” on page 358

**To add a text link that dials a phone number**

1. Select the text you want to link to the phone number.
2. In the Text Inspector, click the New Link button. Then, in the text box next to the button, type “tel:” followed by the phone number (for example, tel:5555555555).

**To add form elements to i-mode pages**

i-mode HTML supports forms so viewers of your site can interact with your pages. The information your viewers send with the form must be processed by a Common Gateway Interface (CGI) script on the host server. Talk with your web hosting provider to set up your CGI functions. Most of the HTML form elements are supported, but be sure to test your form on all the devices you want to reach.

1. From the Form set in the objects toolbox, drag the Form icon to your page. All other form elements should be placed within this container.
2. From the Form set, drag other icons to the new Form object, and configure their Inspectors.
As you add form elements to i-mode pages, keep the following tips in mind:

• Set the visible attribute of text fields to fit within the phone's screen. Usually it's safe to set the visible attribute to 15.

• For form text fields, add the i-style attribute to specify the allowed input type, rather than relying on your users to change it on their phones. You can quickly set the i-style attribute in the Outline Editor by choosing it from the <input> tag's attribute pop-up menu. Japanese is the default when you don't choose a specific istyle. Set istyle to 1 for full-width Japanese Kana. Set istyle to 2 for half-width Japanese Kana. Set istyle to 3 for half-width roman alphanumeric characters (English). Set istyle to 4 for half-width roman numeric characters (English).

• To allow users to quickly select an option using their keypads, set the access option in the Inspector for that element. Generally you'll set a number from 1 to 9. Also remember to label the option with the access key number.

See also

“About web forms” on page 411

“Types of form buttons and check boxes” on page 412

WML

About WML

WML (Wireless Markup Language) is a markup language for displaying information on wireless devices, such as mobile phones.

WML is based on a hierarchy of decks and cards. A deck is the container element for a WML document and is made up of a series of cards. A deck of cards is downloaded to the user's phone all at once. Cards can contain text, images, user input elements, and WML-specific elements that allow navigation and handle user events (such as a user pressing a key on the device).

The document window for a WML deck has three views. Use Layout view to design a WML deck. Use Source view to view WML code in a text editor. Use Outline view to view the structure of a deck in a hierarchical format.

To enable the WML module

You must enable the WML module before you can author in WML. When you enable the module, you'll see the WML Elements set in the objects toolbox.

1 Choose Edit > Preferences (Windows) or GoLive > Preferences (Mac OS).

2 Display the Modules section of the Preferences dialog box, and select WML in the Extend Scripts folder.

3 Restart GoLive.

To create a new WML deck

Decks are the container element for a WML document. When you create a deck, GoLive automatically specifies a document type definition (DTD) for the deck. By default, the DTD version is 1.3; however, you can also specify DTD version 1.1 and 1.2.

❖ Choose File > New, and then select Mobile > Pages > WML Deck.
To change the DTD version
❖ From the document window menu  
, choose a version from the Doctype submenu.

Publishing WML pages
Publishing WML pages requires a Wireless Application Protocol (WAP) gateway. See your wireless site service provider for more information. To transfer your site to the server, you can use GoLive's standard site publishing features.

See also
“Publishing a site” on page 439

Working with WML cards and templates

Creating WML cards
A card is a small collection of data that is displayed in a WML browser. A card can contain text, images, and additional WML elements that allow users to input data and navigate between cards.

When designing a WML deck, keep in mind that navigation between cards is somewhat different than navigation between pages on the web. In WML, navigation between cards typically goes only between cards in the same deck, or back to the top level. Easy navigation is critical when viewing information on a wireless device, so make sure that your WML deck is usable in this constrained environment.

To add a card to a deck
❖ Drag the Card icon from the WML Elements set in the objects toolbox into the document window. Release the mouse button when the pointer is over the colored area of the WML element.

To specify card attributes
1 Select a card in the document window.
2 In the Card Inspector, enter a card title in the Title text box.
WML browsers render card titles in a variety of ways (as bookmark names, tool tips, and so on). Limit titles to 15 characters or fewer to prevent truncation of the text.
3 Set the following optional attributes in the Card Inspector:
   newcontext  Specifies whether or not the browser context should be reinitialized when a user accesses the card. Choose True if you want the browser to clear variable bindings and navigational history when a user accesses the card.
   ordered  Specifies how the card is organized. Choose True if the card will have fields that should be completed in a linear order. Choose False if the card will have fields that can be completed in any order.
   onenterforward, onenterbackward, and ontimer  Include event bindings inside the card element.

See also
“Using events in WML decks” on page 477
To add a template to a deck

A WML template contains events that apply to all the cards in a deck. The template element must be the first element in a deck.

❖ Drag the Template icon from the WML Elements set in the objects toolbox into the document window. Release the mouse button when the pointer is over the colored area of the WML element. If necessary, drag the template element to the top position in the deck.

See also
“To specify image attributes” on page 477

To specify template attributes

1 Select a template element in the document window.

2 To include event bindings inside the template element, set the following attributes in the Template Inspector: onenterforward, onenterbackward, and ontimer.

See also
“To specify image attributes” on page 477

Working with WML elements

About WML elements

Elements are the building blocks of a WML document. You add elements to a document by dragging icons from the WML Elements set of icons in the objects toolbox to the document window.

Note: You must enable the WML module to view the WML Elements in the objects toolbox.

Keep the following in mind as you work with elements:

- Use only WML elements in your deck. If you place elements from the Basic set in the objects toolbox into a WML document, the deck will not work correctly.

- Every element has content rules that determine what the element can contain. For example, a deck element can contain a template element and card elements. The content rules for an element are displayed to the right of the element name in the document window and at the bottom of the objects toolbox when you point to an element icon. The content rules show which elements (and the number permitted) are allowed within an element. A question mark (?) next to an element name means zero or one of those elements are allowed, a plus sign (+) means one or more, an asterisk (*) means zero or more, and the pipe symbol ( | ) between two elements means either element is allowed. For example, the content rule for a card is OnEvent?, Timer*, (Do | P)*. This content rule means zero or one OnEvent element is allowed, zero or more Timers, and zero or more Do or P elements are allowed.

- Limit the size of decks. WML browsers have memory restrictions, and a single large deck can fill up memory very quickly. The recommended size for decks is 500 bytes or less. Choose Special > Document Statistics to display the document size.

- If you edit the WML source code, keep in mind that WML is a case-sensitive language. For example, CARD and card mean different things.
See also
“To enable the WML module” on page 473

To add an element to a deck
1 Drag an element icon from the WML Elements set in the objects toolbox into the document window. Release the mouse button when the pointer is over the colored area of the parent element.

Note: If you drop an element in a location where it is not allowed by the content model, a warning appears and a red border is displayed around the element.

2 Set attributes for the element in its Inspector, including the following common optional attributes:
   id Specifies an identifier for the element that you’ll use later to link to it or use in server-side transformations. GoLive assigns a unique number to the id attribute by default, but you may want to change it to a more meaningful name.
   class Affiliates the element with one or more classes that you can use to group the elements. Separate multiple class names with spaces.

To add text to WML elements
By default, text is enclosed in a p element; however the p element is not displayed when you are working in Layout view. You can also use the pre element to enter preformatted text.

❖ Click the white area of the element, and enter text. Press Return to start a new paragraph.

To use the pre element
❖ Drag the Pre icon from the WML Elements set in the objects toolbox into the document window. Release the mouse button when the pointer is in the desired paragraph.

To add an image to a WML card
You add images to a card using the WML img element. Images must be in WBMP format. You can convert an image to WBMP format by adding a Smart Object to an HTML document in GoLive.

❖ Drag the Img icon from the WML Elements set in the objects toolbox into the document window. Release the mouse button when the pointer is in the desired location in a paragraph, or place the img element in an anchor element to create a linked image.

See also
“Adding multimedia” on page 349
To specify image attributes
1 Select an img element in the document window.
2 In the Img Inspector, set the following attributes:
   alt Specifies alternative text for the image. A WML browser displays alternative text when it does not support images or when the image file cannot be found.
   src Specifies a URL for the image file.
3 Set the following optional attributes in the Img Inspector:
   localsrc Specifies an image file that is local to (saved on) the wireless device. This image file takes precedence over the image file specified by the src attribute.
   vspace and hspace Specify the amount of white space that you want a WML browser to insert around the image in pixels or a percentage. Some browsers may ignore this attribute.
   align Specifies how the image is aligned within a paragraph. Choose Bottom to align the bottom of the image with the current line. Choose Middle to center the image on the current line. Choose Top to align the top of the image with the current line. Some browsers may ignore these attributes.
   height and width Specify the dimensions of the image in pixels or a percentage. Some browsers may ignore these attributes.
   xml:lang Specifies the language of the element or its attributes.

To add a prev, refresh, or noop element
1 Drag the Prev icon, the Refresh icon, or the Noop icon from the WML Elements set in the objects toolbox into the document window. Release the mouse button when the pointer is over the colored area of a do, onevent, or anchor element.
2 For prev and refresh elements, add a setvar element to the task.

See also
“To set variables or postfield elements in a WML deck” on page 477

To set variables or postfield elements in a WML deck
1 Drag the Setvar icon or Postfield icon from the WML Elements set in the objects toolbox into the document window. Release the mouse button when the pointer is over the colored area of a go, prev, or refresh element.
   In the Inspector, specify a name and value for the variable or postfield element.

Working with events and tasks in WML decks

Using events in WML decks
When a user performs an action on a wireless device, the WML browser captures the user's input. In technical terms, the user's action is called an event. You can use events to execute tasks in your WML deck.
The following elements let you bind a task to an event:

**onevent**  Specifies a task to be executed when an *intrinsic* event occurs. An intrinsic event is generated when a user interacts with an element in the WML deck. For example, a user entering a card via the go element is an intrinsic event.

**do**  Specifies a task to be executed when an *extrinsic* event occurs. An extrinsic event is generated when a user presses a key on the device. For example, a user pressing a soft key is an extrinsic event.

You can add these event-binding elements to both cards and templates. When you add a do element or onevent element to a template, the events apply to all the cards in a deck.

**See also**

“Using tasks in WML decks” on page 478

**To add an onevent element**

1. Drag the Onevent icon from the WML Elements set in the objects toolbox into the document window. Release the mouse button when the pointer is over the colored area of a card element, template element, or option element.
2. Choose the type of event to which you want to bind the task from the type pop-up menu.
3. Add a task to the onevent element.

**To add a do element**

1. Drag the Do icon from the WML Elements set in the objects toolbox into the document window. Release the mouse button when the pointer is over the colored area of a card or template element.
2. Choose the type of event to which you want to bind the task from the type pop-up menu.
3. Set the following optional attributes in the Do Inspector:

   **label**  Specifies a text label for the element. A WML browser may display the text as a graphical button. Limit labels to six characters or fewer to prevent truncation of the text.

   **name**  Specifies a name for the event binding.

   **optional**  Specifies whether or not the browser can ignore the do element.

   **xml:lang**  Specifies the language of the element or its attributes.

4. Add a task to the do element.

**Using tasks in WML decks**

Tasks specify processing that is performed in response to an event, such as a user pressing a key, entering a card, or activating a hypertext link. You add tasks to a card using the following elements:

**go**  Navigates to a URL.

**prev**  Navigates to the previous URL or the last viewed page.

**refresh**  Refreshes the content of a card.

**noop**  Specifies that nothing should be done.
To add a go element
1 Drag the Go icon from the WML Elements set in the objects toolbox into the document window. Release the mouse button when the pointer is over the colored area of a do, onevent, or anchor element.
2 In the Inspector, enter the URL of the card to display in the href text box.
3 Set the following optional attributes in the Go Inspector:
   method Specifies a method for submitting data to a server, either get or post. This attribute is only used when sending information for processing on a server.
   accept-charset Lets you enter a list of character encoding (charset) names for data that the origin server accepts when processing input. Separate the character encoding names with spaces or commas. This attribute is only valid when the post method is selected.
   sendreferer Specifies whether or not the browser sends the URL of the current deck along with the URL request. If you choose true, the server can control access to the destination card based on the current deck.
4 Add a setvar or postfield element to the task.

See also
“To set variables or postfield elements in a WML deck” on page 477

Getting user input in WML decks

Creating text and selection fields
You can capture input from users with the following WML elements:
input Creates a text entry field.
fieldset Creates a grouping of text entry fields.
select Creates a list of options from which a user can choose.
option Adds a single option to a selection list.
onoptgroup Groups options together in a selection list.

To create a text entry field
1 Drag the Input icon from the WML Elements set in the objects toolbox into the document window. Release the mouse button when the pointer is in the desired location in a paragraph.
2 In the Input Inspector, specify the name of the variable to set with the user’s input in the Name text box.
3 Set the following optional attributes in the Input Inspector:
   type Specifies whether a user will enter text or a password. If you choose password, the WML browser can obscure the text while a user enters it, such as displaying asterisks in place of characters.
   emptyok Specifies whether or not the user is required to enter text in the input area. If you choose False, the user must enter text before continuing.
   size Specifies the width in characters on the input area. Some browsers may ignore this attribute.
**maxlength** Specifies the maximum number of characters that a user can enter in the input area. To allow an unlimited number of characters, leave this attribute blank.

**tabindex** Specifies the position of the element in the tabbing order (the order in which elements are activated when a user presses the Tab key). Enter 1 if you want the element to be first in the tabbing order. Some browsers may ignore this attribute.

**xml:lang** Specifies the language of the element or its attributes.

**value** Specifies the default value of the variable specified in the name attribute.

**format** Specifies the range of characters that a user can enter.

**title** Specifies a title for the element.

**accesskey** Specifies a key that a user can press to activate the input area. The availability of keys depends on the wireless device. For example, phones have keys 0-9, pound, and asterisk. Some browsers may ignore this attribute.

**See also**

“To set variables or postfield elements in a WML deck” on page 477

**To create a group of text entry fields**

1 Drag the Fieldset icon from the WML Elements set in the objects toolbox into the document window. Release the mouse button when the pointer is in the desired location in a paragraph.

2 Set the following optional attributes in the Fieldset Inspector:

- **title** Specifies a title for the element.
- **xml:lang** Specifies the language of the element or its attributes.

3 Add input elements to the fieldset element.

**To create a selection list**

1 Drag the Select icon from the WML Elements set in the objects toolbox into the document window. Release the mouse button when the pointer is in the desired location in a paragraph.

2 Set the following optional attributes in the Select Inspector:

- **name** Specifies the name of the variable to set with the result of the selection (as determined by the value attribute of the option element).
- **multiple** Specifies whether or not the user can make multiple selections.
- **tabindex** Specifies the position of the element in the tabbing order (the order in which elements are activated when a user presses the Tab key). Enter 1 if you want the element to be first in the tabbing order. Some browsers may ignore this attribute.
- **title** Specifies a title for the element.
- **value** Specifies the default value of the variable named in the name attribute.
- **iname** Specifies the name of the variable to set with the index result of the selection. The first option in the list has an index value of 1, the second option in the list has an index value of 2, and so on. If the user does not select an option, the variable is set to 0.
xml:lang  Specifies the language of the element or its attributes.

ivalue  Specifies a default index value to be used if the variable specified in the iname attribute is not set when the element is displayed.

See also

“To set variables or postfield elements in a WML deck” on page 477

To add individual options to a selection list

1  Drag the Option icon from the WML Elements set in the Objects toolbox into the document window. Release the mouse button when the pointer is over the colored area of a select element.

2  Enter text for the option in the white area of the option element.

3  Set the following optional attributes in the Option Inspector:

title  Specifies a title for the element.

value  Specifies the value with which to populate the select element’s name variable if a user selects the option.

xml:lang  Specifies the language of the element or its attributes.

To create a group of options in a selection list

1  Drag the Optgroup icon from the WML Elements set in the Objects toolbox into the document window. Release the mouse button when the pointer is over the colored area of a select element.

2  Set the following optional attributes in the Optgroup Inspector:

title  Specifies title for the element.

xml:lang  Specifies the language of the element or its attributes.

3  Add option elements to the optgroup element.

Using hypertext links and timers with WML cards

To add hypertext links to WML cards

You can add HTML-style links to a card using the WML anchor element and <a> element. The anchor element allows you to bind text and images to a go, prev, or refresh task. The <a> element is a short form of the anchor element.

1  Drag the Anchor icon or the A icon from the WML Elements set in the Objects toolbox into the document window. Release the mouse button when the pointer is in the desired location in a paragraph.

2  Do one of the following:

• Enter text in the white area of the element.

• Drag an image element into the white area of the element.

3  If you added an <a> element, specify a URL for the link in the href text box.
Set the following optional attributes in the Inspector:

- **title**: Specifies a title for the element.
- **accesskey**: Specifies a key that a user can press to activate the link. The availability of keys depends on the wireless device. For example, phones have 1 through 9 keys and a pound key. Some browsers may ignore this attribute.
- **xml:lang**: Specifies the language of the element or its attributes.

If you added an anchor element, add a go, prev, or element task to it.

### See also
- “To add text to WML elements” on page 476
- “To add an image to a WML card” on page 476
- “Using tasks in WML decks” on page 478

### To add timers to WML cards

Each card can have one timer. The timer is initialized when a user enters the card and stops when the user exits the card. You can use a timer to trigger a task after a specified amount of time has passed.

1. Drag the Timer icon from the WML Elements set in the objects toolbox into the document window. Release the mouse button when the pointer is over the colored area of a card.
2. If the card contains other elements, move the timer element to the top position in the card.
3. In the Inspector, enter the timer value (in tenths of seconds) in the Value text box.
4. Set the optional name attribute in the Inspector to specify a variable to use when initializing the timer.

### Previewing XHTML, i-mode HTML, or WML in a phone emulator (Windows only)

#### To add phone emulators and set a default

You preview XHTML, i-mode HTML, and WML content using emulators provided by mobile phone manufacturers. See the Nokia, Sony Ericsson, DoCoMo, or Opera website for information on acquiring an emulator.

1. Install a mobile phone emulator on your hard disk.
2. Choose Edit > Preferences (Windows) or GoLive > Preferences (Mac OS), and select Browsers from the list on the left.
3. Click Add, navigate to the emulator, select it, and click Open.
4. If you want the phone emulator to be the default browser to preview your page, select it in the scrolling window. Any browsers selected in the list will open and preview your page when you click the Preview In Browser button on the toolbar.
To preview a page in a phone emulator

1. Do one of the following:
   - To preview in the default emulator, click the Preview In Browser button on the toolbar.
   - To preview in another emulator, choose it from the Preview In Browser menu on the toolbar. Or, choose it from the File > Preview In submenu.

2. (Optional) After the emulator is open, use the Launcher window to choose any of the listed phones to emulate.

3. (Optional) In the Viewer window, use the arrow keys and the Enter key to navigate as you would on a phone.

   Note: Generally, you can ignore the Menu button because GoLive automatically sets the path to your file when you use the Preview in Browser button on the toolbar.
Chapter 23: Authoring SMIL presentations

Understanding SMIL

About SMIL
SMIL (Synchronized Multimedia Integration Language) is an XML-compliant markup language that lets you lay out and synchronize the playing of multiple streaming and static media items in a multimedia presentation. For example, you can create a SMIL presentation that plays streaming video, streaming audio, images, and streaming text at the times and in the sizes and positions you specify. You can create hotspots that link specific areas and time periods in your presentation to other media source files, web pages, or other SMIL presentations.

SMIL presentations play in RealNetwork's RealPlayer. You can specify whether your SMIL presentation plays in a separate RealPlayer window or within the browser window, using the RealMedia plug-in.

Note: For SMIL specifications, see the W3C website (www.w3.org). For more information on using SMIL presentations with RealPlayer, see the RealNetworks website (www.realnetworks.com).

SMIL presentation types
You can create three types of SMIL presentations in GoLive:

**SMIL documents**  Let you create a layout for your various media items.

**RealPlayer documents**  Let you add various media items to a pre-designed multi-pane layout. RealPlayer documents combine RealMedia files (including all SMIL presentation types) and HTML content.

**RealPix documents**  Let you create a slide show of still images. RealPix presentations can be stand-alone or included as content in RealPlayer and SMIL presentations.

See also

“To create a new SMIL presentation” on page 487

“About the RealPlayer Editor” on page 513

“RealPix presentations” on page 515

Authoring SMIL presentations in GoLive
When authoring SMIL presentations in GoLive, you work between the presentation's main window (SMIL, RealPlayer, and RealPix windows), the Timeline Editor, the SMIL set of the objects toolbox, and the various Media Inspectors.
You'll perform different tasks in different interface elements:

**SMIL window** Use the Layout tab in the SMIL window to visually arrange the content of the SMIL presentation. You can also use the Source and Outline Editor tabs as necessary. In Windows, you can use the Preview tab.

**Timeline Editor** Use the Timeline Editor to set the timing of your media files for SMIL presentations and to group items together.

**SMIL set of the objects toolbox** Use the icons in the SMIL set to add media items to your SMIL presentation.

**Media Inspectors** Use the Media Inspectors to specify the appropriate settings for your media files.

**RealPlayer Editor** Use the RealPlayer Editor to lay out and edit a RealPlayer document.

**RealPix window** Use the RealPix window to create a slide show.

![Image showing different elements of a SMIL presentation]

Viewing a completed SMIL presentation
A. Streaming animation (SWF)  B. Streaming video  C. Static image used as a background  D. SMIL hotspot that links to a web page

**See also**

"About the Layout tab" on page 492

“To preview SMIL presentations” on page 487

“Setting timing” on page 495

**About the Timeline Editor**

You use the Timeline Editor to set the timing of your presentation and its items.
SMIL Timeline Editor

A. Item list area  B. Time cursor  C. Time ruler  D. Item content area  E. Mouse pointer position in item content area  F. Expands and collapses containers and switch statements  G. Playback controls  H. Time scale slider

**Item list area** Displays a list of the items in the presentation. Each item's timeline bar is identified by its default name (such as `<video>-Untitled`) or title if you enter one in the Media Inspector. To delete an item, select it and choose Edit > Delete (Windows) or Edit > Clear (Mac OS).

**Time cursor** Controls the current time position of a presentation. To change the current time, drag the time cursor left or right or click on the time ruler.

**Time ruler** Displays time intervals for the items in the item content area, depending on what you have selected in the time scale slider at the bottom of the Timeline Editor.

**Item content area** Lists each item's timeline bars. The left edge of the timeline bar marks the start time of the item, and the right edge marks the end time.

**Type** The Type icon indicates the type of item. For example, the Video icon identifies a video item; the Text icon identifies a text item.

**Playback controls** Control the playback of items and anchors that are displayed in the Layout tab. (The contents of static media items, such as static images or static text, appear in the Layout tab of the SMIL window, but the contents of streaming items do not.) Click the Backward button to rewind the presentation by a single step, or hold down the backward button to rewind the presentation continuously. Click the Stop button to stop presentation playback at the current time, or double-click it to rewind the presentation to the beginning. Click the Play button to play the presentation. Click the Forward button to advance the presentation a single step, or hold down this button to advance the presentation continuously.

**Time scale slider** Controls the time scale shown in the item content area. You can adjust the time scale to make it easier to examine the timing relationships between the items. Drag the time scale slider to the right to decrease the resolution of the time scale (up to a maximum of one minute) and compress the item bars. Dragging to the right allows you to survey larger sections of the presentation. Drag the time scale slider to the left to increase the resolution of the time scale (down to a minimum of one frame) and lengthen the item bars. The default time scale setting is six frames per second.
Creating SMIL presentations

To create a new SMIL presentation
You begin creating a SMIL presentation by creating a new SMIL document. The SMIL document contains the SMIL source code that player applications use to play the presentation.

Note: You must have RealPlayer installed on your computer to use GoLive to preview SMIL presentations. For information on installing RealPlayer, see the Real Networks website (www.realnetworks.com).


2. Click the Show Timeline Window button to display the Timeline Editor. GoLive automatically adds a default Parallel Container to a new SMIL presentation and displays the container in the Timeline Editor.

To open an existing SMIL presentation
1. Choose File > Open, navigate to the SMIL presentation, and then open it.

2. In the toolbar, click the Show Timeline Window button to display the Timeline Editor, which lists the existing media items in the presentation.

To save a SMIL presentation
- Choose File > Save As or File > Save. Navigate to a site folder where you want to store the SMIL presentation, enter a file name with a .smil extension, and then click OK.

Note: Because a SMIL presentation can reference various media files and is usually part of site, save the SMIL document in a site folder with the media and other site files.

To set a presentation’s size, title, and background color
All SMIL presentations include the primary player window. You may also include secondary windows. You can change the size and background color of your SMIL presentation’s windows, and specify a title to appear at the top of the RealPlayer window. The default presentation size is 320 x 240 pixels and the default background color is black.

1. Select the Page icon at the top of the Layout tab of the SMIL window next to the title.

2. In the Layout tab of the SMIL Inspector, enter a presentation title in the Title box of the Root Layout section.

3. In the Width and Height boxes, enter values in pixels. GoLive changes the size of the root-layout region shown in the Layout tab to the dimensions you specify.

4. To change the background color of the root-layout region, select BG Color, and then click the color field to select a color from the Color palette. Or, choose a predefined color from the menu next to the color field.

5. To set the properties for secondary windows, create or select the desired layout in the Multi Window Layout section, and then repeat steps 2-4.

To preview SMIL presentations
- (Windows only) To preview the SMIL presentation by using the Preview tab, open the presentation, and then click the Preview tab of the SMIL window.

- To preview a SMIL presentation by using RealPlayer, start RealPlayer, and then open the presentation file.
You can specify RealPlayer in the GoLive Browser preferences to access it more quickly.

Adding, grouping, and repeating media items

Media items
Media items are a presentation's basic unit of media content, and each type of item contains references to a particular kind of information. For example, a video item contains pointers to the presentation's video content, and an audio item points to sound content. To add content to a SMIL presentation, you add the appropriate type of items and specify the media source files for each item.

When adding items, use the Parallel Container if you want the items to play simultaneously, or use the Sequence Container if you want them to play in a sequence. You can also set up items to repeat a specified number of times or indefinitely.

You can add the following types of media items:

- **Video icon**  Use for video files that display continuous motion, such as a RealVideo file (.rm).
- **Animate (SWF) icon**  Use for animation files, such as .swf files.
- **Audio icon**  Use for audio files, such as RealAudio files (.rm or .ra).
- **Image icon**  Use for JPEG, GIF, PNG, or RealPix files.
- **Text icon**  Use for static text files (.txt).
- **Text Stream icon**  Use for streaming text files, such as RealText files (.rt).
- **Media Reference icon**  Use for other media elements, such as .svg files.
- **Brush icon**  Use to paint a solid color or pattern in place of the media object.
- **Transition icon**  Use to add a transition between items.

See also
“Repeating and looping items” on page 491
To add media items to a presentation

1 Drag a Media Item icon from the SMIL set of the objects toolbox into the item content area of the Timeline Editor. (To display the name of each icon, place the pointer over the icon.)

![Diagram of adding an image item to a Parallel Container]

Adding an image item to a Parallel Container
A. Parallel Container  B. Item list area  C. Item content area

Note: By default, the Snap feature is turned on.

2 Name the item by typing a name in the Title box in the Basic tab of the Media Inspector. Or, double-click the item name in the item list area in the Timeline Editor and type a name in the box. (The titles for individual items appear in RealPlayer's playlist and clip info menus.)

3 Identify the item by typing a value in the ID box in the Basic tab of the Media Inspector. The ID attribute uniquely identifies an item within a SMIL document. For example, you can use an ID to identify an item you want to link to.

4 To automatically resize a region to match the size of the source file, select Resize Region. For example, image items have a default region size of 32 x 32 pixels. If you select Resize Region and then use an image source file that has a size of 320 x 240 pixels, GoLive resizes the image item region to 320 x 240 pixels. If you don't select Resize Region before specifying a source, GoLive doesn't change the region size and the image might be clipped.

Note: You must select the Resize Region option before selecting a source file; selecting Resize Region after selecting a new source file has no effect.

5 Specify the source file for the item by entering the full URL for the media file in the Source box in the Basic tab of the Media Inspector. You can also use the pick whip to specify a file in your site window, browse for a local file, or choose a previously selected file from the URL menu to the right of the Source box.

See also

“To link to another SMIL presentation” on page 499

“About the Layout tab” on page 492
To specify presentation information

You can also specify information, such as title, author, and copyright, that is displayed if a viewer chooses the Help > About This Presentation command in RealPlayer.

❖ Select an Information icon  from the Header section of the Layout tab, and enter the appropriate information using the Inspector.

To delete an item

❖ Select the item in the Layout tab of the SMIL window or Timeline Editor, and then choose Edit > Delete (Windows) or Edit > Clear (Mac OS).

Using containers to group items

By using containers, you can determine how a player application will play items.

SMIL Sequence Container  Plays a group of media items one at a time in sequence.

SMIL Parallel Container  Plays a group of media items simultaneously.

SMIL Exclusive Container  Isolates items from the main timeline.

Exclusive Containers  Let you control playback of the included items through user interaction.

When you create a new SMIL document, GoLive automatically adds a default Parallel Container to the presentation and displays the container in the Timeline Editor. If you want the items in your presentation to play simultaneously, you can simply add items to the default Parallel Container. However, if you want the items to play in sequence, delete the default Parallel Container and either add a Sequence Container or don’t include a container in your presentation. (By default, a SMIL presentation plays items in sequence if they aren’t in a container.)

You can also combine the two types of containers into one presentation, one container after the other—for example, you can play one group of items in sequence, and then play another group of items simultaneously. You can even nest any type of container within any other type of container.

To add a container to a presentation

1 From the SMIL set  of the objects toolbox, drag the appropriate container icon into the Timeline Editor.

Note: To nest a container within another Container, drag the container icon to the row containing the target container. Otherwise, drag the container icon above or below the target Container.
2 Name the container by typing a name in the Title box in the Basic tab of the container’s Inspector. Or, double-click the container name in the item list area in the Timeline Editor and type a name in the box.

3 Identify the container by entering a value in the ID box in the Basic tab of the container’s Inspector.

**To add an item to a container**

❖ Drag a SMIL Item icon from the objects toolbox to the row where the container is listed in the item content area of the Timeline Editor. GoLive indents the items under a container and displays an expand/collapse triangle control to show and hide the container’s items.

**See also**

“To add media items to a presentation” on page 489

**To delete a container**

❖ Select the container in the Timeline Editor, and then choose Edit > Delete (Windows) or Edit > Clear (Mac OS). GoLive deletes all items in the container.

**Repeating and looping items**

You can set up an item or container to repeatedly play a specific number of times or loop until the viewer stops playback. If you repeat a container, all items in the container repeat as a group. If you decide to repeat an individual item in a container, be aware of how the item repetition affects the timeline of the container and other items in the container. For example, a repeating item in a Sequence Container must finish its number of repetitions before the next item in the container starts playing. Likewise, a repeating item in a Parallel Container can extend the overall duration of the container.

Other timing options, such as end times, can also affect item and container repetitions. For example, suppose you have a video item with a 30-second internal timeline. If you set an end time of 35 seconds and repeat the item twice, the last frame of the video item plays for 5 seconds before the video repeats a second time.

**To repeat items or containers**

1 Select the item or container in the Timeline Editor.

2 Do one of the following:

- If you are repeating an item, display the Time tab of the Media Inspector.
- If you are repeating a container, display the Basic tab of the container’s Inspector.

3 Do one of the following:

- To repeat the item or container a specific number of times, enter the number in the Repeat box.
- To loop the item or container indefinitely, select Indefinite.
- To specify the duration an element is repeated over, use the Repeat Duration field. If you enter both a repeat duration and a repeat count, the repeat count setting overrides the repeat duration setting.
Laying out SMIL presentations

About the Layout tab
The Layout tab of the SMIL window lets you visually change the sizes and physical positions of items in a presentation. You can also use the Media Inspector, the Align palette, and the Transform palette to resize, reposition, and align items.

Use the Layout tab of the SMIL window to lay out a SMIL presentation.
A. Streaming animation item (SWF)  B. Static image item used as a background  C. Streaming video item  D. Root-layout region  E. Anchor used to define a hotspot link

To show or hide the grid or ruler
❖ With the Layout tab of the SMIL window active, choose one of the following from the View menu:
  • Show Grid.
  • Show Rulers.

To turn snapping and guides on or off
❖ With the Layout tab active, choose one of the following from the View menu:
  Snap To Grid  Places an element at the nearest grid intersection when you release the mouse.
  Show Smart Guides  Shows you vertical and horizontal guidelines when the element you're dragging aligns with another element. Use this option to position your element in relation to another element.

To visually resize or reposition an item
  • To resize an item, drag the item's resize handle.
  • To move an item, drag the item in the root-layout region in the Layout tab of the SMIL window.

See also
“Setting timing” on page 495
To reposition or resize an item using precise values

- To reposition an item by using the Transform palette, select the item and enter a pixel offset from the upper left corner of the root-layout region in the Position boxes.
- To resize an item by using the Transform palette, select the item and enter pixel values in the Size boxes.
- To reposition or resize an item in the Media Inspector, select the item in the Layout tab of the SMIL window or Timeline Editor, and display the Layout tab of the Media Inspector. Specify Pixel, Percentage, or None, and enter values for Left (horizontal position), Top (vertical position), Width, Height, or any combination of these.

Pixel offsets the item from the edges of the root-layout region. Percentage offsets the item relative to the root-layout region's size. For example, an item can be offset from the left border at a position that is 5% of the width of the root-layout region. You can mix pixel and percentage values in the Left, Top, Width, and Height boxes. If you choose None from the menu, GoLive doesn't enter a unit of measurement (pixels or a percent sign) in source code, but the presentation uses the default value, pixels.

See also
“Setting timing” on page 495

To resize an item using the encoded size of the item’s source file

❖ Select the item, and then click the Original Size button in the Layout tab of the Media Inspector.

GoLive resizes the item to the dimensions encoded in the item's source file.

To align items

- To align items in relation to the root-layout region boundaries, select the item or group of items that you want to align. Then, in the Align palette, under Align To Parent, click a horizontal or vertical alignment button.
- To align items in relation to each other, select the items, and then click a button under Align Objects in the Align palette. You can align items along the left, center, or right vertical axis or along the top, center, or bottom horizontal axis.

To specify how an item’s source file fits into the item’s region

If an item's source file is encoded at a size that is different from the size of the item's region in your SMIL presentation, you can specify how the source file fits within the item's region when a player application plays back the presentation.

1. Select the item in the Layout tab or Timeline Editor.
2. In the Media Inspector, choose an option from the Layout tab's Fit menu.

Layout tab’s Fit menu options

Choose one of the following options to specify how an item’s source file fits into the item’s region:

- **None**  Plays back the presentation using the default value, which is Hidden.
- **Hidden**  Uses the encoded size of the source file and positions it in the item region's upper-left corner. If the source file is smaller than the region, the player application uses the item's background color to fill the blank space. If the source file is larger than the region, the player application clips the portion of the source file that doesn't fit.
- **Fill**  Scales the source file to make it fill the item's region completely. The source file is distorted if it has different height and width proportions than the item's region.
Meet Positions the source file at the item region's upper-left corner, and uses the source file's height and width proportions to scale the source file. The player application scales the source file so that one of the source file's dimensions is equal to one of the region's dimensions, and the other dimension is within the region's boundaries. The player application uses the item's background color to fill the blank space.

Scroll Positions the source file at the item region's upper-left corner and plays the source file at its encoded size. The player application adds horizontal or vertical scroll bars if the source file is larger than the region.

Slice Positions the source file at the item region's upper-left corner, and uses the source file's height and width proportions to scale the source file. The player application scales the source file so that one of the source file's dimensions is equal to one of the region's dimensions, and clips the other dimension that exceeds the region's boundaries.

To set the background color of regions
By default, all item regions are transparent. That is, a transparent region is not visible in the player application until an item begins playing in the region. You can set a background color for an item's region.

1 Select the item in the Layout tab or Timeline Editor.
2 In the Media Inspector, select BG Color, and then click the color field to select a color from the Color palette.

See also
“To set a presentation's size, title, and background color” on page 487

Setting the layering order of overlapping items
If items in a SMIL presentation overlap and play simultaneously, you can set the layering order to specify which item plays in front. To set the layering order, you enter z-index values for the items. An item with a larger z-index value appears in front of an item with a smaller value. The root-layout region always appears behind all items and doesn't have a z-index value.

When setting z-index values, consider the following:

- If you don't select the Z-Index option, GoLive doesn't enter a value for z-index in the presentation's source code.
- If you select the Z-Index option but you don't specify a z-index value for an item, GoLive assigns a default value of zero.
- It isn’t required that you assign a continuous sequence of values, such as 1, 2, 3, and so on. You can have gaps in the sequence, such as 1, 3, 7, which is useful if you want to later add overlapping items in layers between existing items.
- You can use a negative value (such as -3) for a z-index to send an item behind other items. For example, an item with a z-index value of -3 appears behind an item with a zero or positive value.
- Items that don't overlap can have the same z-index value. If items overlap and have the same z-index value, the item that begins later appears in front. If the overlapping items also begin at the same time, the item that is at the bottom of the item list in the Timeline Editor appears in front.
To set the layering order of overlapping items

**Note:** You don't have to set z-index values for items that don't overlap in position or time.

1. Select the item in the Timeline Editor.
2. In the Layout tab of the Media Inspector, select the Z-Index option, and then enter a value in the box next to the option.

**See also**

“Creating hotspots” on page 500

Setting the timing of items and containers

**Setting timing**

You can set the timing of containers and media items to precisely synchronize your content. If you don’t change the timing, items start and stop based on their internal timelines and positions within a container and the presentation. For example, when the first item in a sequential container ends, the second item in the same sequential container begins.

By setting timing, you can set when containers or individual items start and stop playing. You can control the timing in a presentation by entering time values in boxes in the Inspectors, or by dragging timeline bars in the Timeline Editor.

**Setting timing using the Media Inspector**

When you enter a time value in a Begin or End box in an Inspector, you can use either of the following formats:

**hh:mm:ss.xyz**  Enter hours (hh), minutes (mm), seconds (ss), tenths of seconds (x), hundredths of seconds (y), and milliseconds (z). You can also omit the number of hours, tenths and hundredths of seconds, and milliseconds. For example, 14:11 is 14 minutes, 11 seconds, and 11:13.5 is 11 minutes, 13.5 seconds.

**Shorthand abbreviations**  Enter the unit of time as an abbreviation. Use **h** for hours, **min** for minutes, **s** for seconds, and **ms** for milliseconds. For example, 4.5min is 4 minutes, 30 seconds, and 55s is 55 seconds. If you don’t specify a unit of time, the default is seconds.

**To set the timing of an item using the Media Inspector**

1. Select the item in the Layout tab of the SMIL window or Timeline Editor.
2. In the Time tab of the Media Inspector, set the item's begin time by choosing one of the following options:
   - **None**  Begins the element at its position in the timeline.
   - **At Time**  Specifies the time to begin the element.
   - **On Sync <event>**  Synchronizes the element's begin time with another element. Drag the pick whip to the desired time on the trackbar of the element you want to sync to.
   - **On <event>**  (Such as On Mouse Click) Synchronizes the element's begin time with an event. Drag the pick whip to the desired time on the trackbar containing the event you want to sync to.
**Note:** The Inspector values for begin and end times reflect the global presentation time; GoLive calculates the actual values before encoding them.

3 Set the container’s end time by doing one of the following:

- Choose None to end the element at its position in the timeline.
- Choose At Time from the menu next to the End box, and then enter a time in the End box to stop the element at a specific time.

4 To change the item’s clip-begin time, choose one of the following from the Clip-Begin menu, and then enter a time value (for SMPTE use hh:mm:ss.xy format) in the Clip-Begin box:

- Normal Play Time.
- SMPTE if the item uses an internal SMPTE time code of 30 frames per second.
- SMPTE-25 if the item uses an internal SMPTE time code of 25 frames per second.
- SMPTE-30 if the item uses an internal SMPTE time code of 29.97 frames per second.

### Setting timing using the Timeline Editor

You can use the Timeline Editor to change start and end times for both containers and items. If the item is in a container, the start time is relative to the start of the container rather than the start of the presentation. You can enter time values, or you can use the pick whip in the Media Inspector to set a time-dependency relationship between an item and another item or container.

You can also use the Timeline Editor to set the clip-begin and clip-end times to be different from the actual internal times encoded in items such as video, audio, and animation. For example, you can set a video item to begin playing at its 5 second time position rather than from its beginning. You can’t set the clip-begin and clip-end times of static items (such as still images) that don’t have internal timelines.

#### To change an item’s clip-start time

- Position the pointer on the left lower corner of the timeline bar so that you see a cursor with a short vertical bar and double arrows, and then drag the left corner to the new clip-start time. Likewise, you can change the clip-end time by dragging the lower right corner.

#### Setting the timing of containers

As with items, you can set the timing of containers in either the Inspector or the Timeline Editor. When you set the timing of a container, you set the timing of all items in the container. By default, the items in the first container in a presentation begin playing immediately at the start of a presentation, and any subsequent container’s items begin after the preceding container (or items) finish playing. You can set a delay on a container’s playback by setting a Begin time. For example, you can delay a container by 5 seconds by setting a Begin time of 5s.
You can stop all items in a container by setting an End time for the container, regardless of their internal timelines or whether they have started or finished playing. For example, suppose all items in Container_A finish playing in 45 seconds. If you set an End time of 50 seconds for Container_A, the next container or item in the presentation begins playing 5 seconds after the end of the last item in Container_A.

**To use the Inspector to set the timing of a container**

1. Select the container in the Timeline Editor.

2. In the Basic tab of the container’s Inspector, do one of the following:
   - To ensure that the container's items don't change when you change the container's duration, deselect Scale Container Elements.
   - To ensure that the container's items scale proportionally when you change to the container's duration, select Scale Container Elements.

3. Set the container's begin time by doing one of the following:
   - To set a specific time, choose At Time from the Begin menu, and then enter a time in the Begin box.
   - To set a time-dependency relationship, drag the pick whip (next to Begin) to the beginning, middle, or end of the target container or item you want to synchronize with. When you drag to the middle of the target, you are synchronizing with an offset time from the beginning of the target's start time.

4. Set the container's end time by doing one of the following:
   - To set a specific time, choose At Time from the menu next to the End box, and then enter a time in the End box.
   - To synchronize the end time with another item, drag the pick whip (next to End) to the beginning, middle, or end of the target container or item you want to synchronize with.
To use the Timeline Editor to set the timing of a container

- To change both start and end times for a container (preserving the container's duration), position the pointer on the container timeline bar so that you see a pointing finger cursor, and then drag the timeline bar to the new start time.

- To change a container's start time only without changing the end time (and thereby change the container's duration), position the pointer on the left edge of the timeline bar so that you see a cursor with a vertical bar and double arrows. Then drag the left edge to the new start time. Likewise, you can change the end time by dragging the right edge.

- To scale the durations of the container's items when you change the container's begin and end times, hold Shift while dragging. As you change the container's duration, the container's items change proportionally.

Using the Timeline Editor to set a container's start and end times

A. Drag timeline bar to change start and end times.  
B. Drag left edge to change start time only.  
C. Drag right edge to change end time only.

To stop all items in a Parallel Container when a particular item stops playing

1. In the Timeline Editor, select the Parallel Container you want to set.
2. In the Basic tab of the Parallel Container Inspector, choose one of the following from the End Sync menu:

   - **None**  Plays the presentation using the default value, which is Last.
   - **Last**  Allows all items in the container to finish playing. That is, all items stop when the longest item finishes playing.
   - **First**  Stops all items in the container when the shortest item finishes playing. This option overrides any other timing settings on the other items.
   - **<name-ID>**  Stops all items in the container when the item chosen from the End Sync menu finishes playing. This option overrides any other timing settings on the other items. The names and IDs displayed in the End Sync menu are obtained from the Basic tab of the Inspector for each item or container in the Parallel Container.

See also

"To add media items to a presentation" on page 489
**To remove or freeze the last frame of an item**

If you set an end time that is beyond the end time of the item's internal timeline, you can either remove the item from the presentation or freeze the last frame after it finishes playing, or at the specified clip-end time.

1. Select the item in the Layout tab of the SMIL window or Timeline Editor.
2. In the Time tab of the Media Inspector, choose Remove or Freeze.

**Adding links to presentations**

**To link to an alternate source file or web page**

You can add a link from a container or item to an alternate source file or web page. If you add a link from a container, the link is active in all items in the container. That is, the viewer can click any region assigned to any item in the container to activate the link.

1. Select the container or item to which you want to add the link.
2. Display the Link tab of the container's Inspector or the item's Media Inspector.
3. Click the New Link button, and specify the linked file.

*Note: Make sure that the file is the appropriate type for the item you selected in step 1. (For example, select a video source file for a video item.)*

**To link to another SMIL presentation**

1. Select the container or item where you want to add the link.
2. In the Inspector for the container or item, click the New Link button, and specify a SMIL file.

**See also**

“To add media items to a presentation” on page 489

“Using containers to group items” on page 490

**To link to a specific container or item**

To link to a specific container or item in a SMIL presentation, you must reference the ID assigned to that container or item.

1. Select the container or item to which you want to add the link.
2. Click the New Link button.
3. In the Inspector for the container or item, specify the container or item you want to link to by entering one of the following:
   - To specify a container or item in the same SMIL document file, enter a # symbol and the container’s ID or the item’s ID in the Link box. (For example, #video_item1)
   - To specify a container or item in another SMIL document file, enter the file name and then a # symbol and the container’s ID or the item’s ID in the Link box. (For example, other_file.smil#video_item1)
To specify a current presentation’s behavior
By default, when a viewer clicks a presentation link, the current presentation pauses and the destination presentation begins playing in the same player application or browser window. You can, however, override this default.

1. Select the container or item.
2. In the Link tab of the Inspector, set the following Current Presentation options:
   - **Play State**: Choose whether the current presentation continues to play, pauses, or stops when a link is activated. Choosing None uses the default, which is pause.
   - **Sound Level**: Enter the percentage of sound for the current presentation.

To specify a destination presentation’s behavior
You can select options to specify the behavior of a destination presentation once it begins to play.

1. Select the container or item.
2. In the Link tab of the Inspector, set the following New Presentation options:
   - **Show**: Select Replace Presentation to use the current player window, New Presentation to open a new player window, or None to use the default, which replaces the presentation in the current player window.
   - **Play State**: Choose whether the current presentation continues to play, pauses, or stops when a link is activated. (Choose None to pause.)
   - **Sound Level**: Enter the percentage of sound for the current presentation.

Creating hotspots in a presentation

Creating hotspots
By using SMIL anchors, you can create hotspots that link specific areas and time periods in your presentation to other media source files, items, web pages, or SMIL presentations.

SMIL anchors let you add links to your presentation that are similar to links in HTML image maps, except that SMIL anchors also have temporal properties in addition to spatial properties; you can set the timing of an anchor so that its link is active for a specified duration in the presentation.
Using anchors to create hotspots in a SMIL presentation
A. Anchor is linked to an alternate video item.  B. Anchor is linked to a website.

To add hotspots to a presentation
You can add hotspots to a presentation by laying them out in the Layout tab of the SMIL window. SMIL hotspots are always associated with an item and not a container, and they cannot be added as an independent element; hotspots are always child elements of an item element. In the Timeline Editor, hotspots are shown indented under the item they are associated with.

1 In the Layout tab of the SMIL window, click the Display URLs button URL, the Show Hotspot Edges button , and the Colorize Hotspots button on the toolbar.
2 Select the appropriate hotspot tool for the shape you want:
   • Rectangular Hotspot tool .
   • Circular Hotspot tool .
   • Polygonal Hotspot tool .
3 In the Layout tab of the SMIL window, drag over an item’s region to create the hotspot.
GoLive adds the hotspot to the Layout tab and under the item in the Timeline Editor.

To link a hotspot to a file or web page
1 In the Layout tab, use the Select Hotspot tool to select the hotspot on which you want to create a link.
2 In the Link tab of the Hotspot Inspector, specify the linked file.
   You can link a hotspot to another SMIL presentation.
3 Specify the options for the Current Presentation and New Presentation.

See also
“To specify a destination presentation’s behavior” on page 500
Changing the display or position of hotspots

To display anchor URLs in the Layout tab of the SMIL window
❖ Click the Display URLs button URL on the toolbar.

To set the layering order of overlapping hotspots
1 With the Layout tab active, select the hotspot you want to the bring to front or send to the back.
2 In the toolbar, click one of the following buttons:
   Bring Hotspot To Front Brings the selected anchor to the top of the layering order.
   Send Hotspot To Back Sends the selected anchor to the bottom of the layering order.

To set the color of hotspots
1 With the Layout tab active, click the Colorize Hotspots button on the toolbar to display the colors of anchor regions.
2 Click the Select Hotspot Color button to display the Color palette, and then select a color.

To delete a hotspot
❖ Do one of the following:
• With the Layout tab active, select the hotspot, and then press Delete.
• In the Timeline Editor, select the hotspot, and then press Delete.

To resize or reposition hotspots using the Layout tab of the SMIL window
• To resize a hotspot, drag the hotspot's resize handle.
• To move a hotspot, drag the hotspot within the item's region in the Layout tab.

Note: All of the hotspots associated with an item must fit within the item's region.

To resize or reposition an anchor using the Hotspot Inspector
1 With the Layout tab active, select the hotspot in the Layout tab. You can also select the hotspot (<area>-untitled) in the Timeline Editor.
2 Click the Basic tab of the Hotspot Inspector.
3 Set the hotspot's position using the properties at the bottom of the Hotspot Inspector. The properties differ, depending on the type of hotspot selected:
   Rectangular hotspots Specify Pixel, Percent, Parent, or None for each of the Left, Top, Right, and Bottom offsets, and then enter the offset values. (None uses the default, which is Pixel.)
   Circular hotspots Specify Pixel, Percent, or None for each of the Center X, Center Y, and Radius offsets, and then enter the offset values. (None uses the default, which is Pixel.)
   Polygonal hotspots Select the first point, enter Pixel, Percent, or None for the X & Y offsets, and then enter the offset values. Repeat this procedure for each point in the polygon. (None uses the default, which is Pixel.)

Note: You can mix pixel and percentage values in the Left, Top, Right, and Bottom boxes.
To resize or reposition a hotspot using the Transform palette
❖ With the Layout tab active, select the hotspot, and then do one of the following in the Transform palette:
• To resize the hotspot, enter pixel values in the Size boxes.
• To reposition the hotspot, enter an offset from the upper left corner of the item's region (in pixels) in the Position boxes.

To align hotspots in relation to the item's boundaries
1 With the Layout tab active, select the hotspot or group of hotspots you want to align.
2 In the Align palette, under Align To Parent, click a horizontal or vertical alignment button.

To align hotspots in relation to each other
❖ With the Layout tab active, select the hotspots, and then click a button under Align Objects in the Align palette. You can align hotspots along the left, center, or right vertical axis, or along the top, center, or bottom horizontal axis.

Setting the timing of hotspots

Setting the timing of hotspots
You can set a hotspot's begin and end time so that its link is active only for a specified duration in the presentation. For example, suppose your presentation shows a video of two different product demonstrations, one after the other. You can add a hotspot for each product, which is linked to the product’s web page, and then set the begin and end time for each anchor to match the portion of the video that demonstrates each particular product; each hotspot's link is active only when the corresponding product is being shown in the video.

Note: A hotspot’s start time is relative to the start time of the item rather than the start time of the presentation.

To use the Timeline Editor to set the timing of a hotspot
1 Position the pointer on the left or right edge of the timeline bar; the double-arrow icon appears.
2 Drag the edge to the new time.
To use the Hotspot Inspector to set the timing of a hotspot

1. Select the hotspot in the Layout tab of the SMIL window or in the Timeline Editor.
2. In the Basic tab of the Area Inspector, set the item's begin time by choosing Normal Play Time from the Begin menu, and then enter a time in the Begin box.
3. Set the container's end time by choosing Normal Play Time from the End menu, and then enter a time in the End box.

Animating items and adding transitions

To animate an item

1. From the SMIL set of the objects toolbox, drag the Animate icon onto the item you want to animate.
2. With “<animate>—Untitled” selected in the Timeline Editor, enter a title and other necessary information in the Animate Motion tab of the Animate Inspector.

For more information on animating items in SMIL presentations, see the RealNetworks website at www.realnetworks.com/resources.

See also

“Animate Motion tab options” on page 504
“Time tab options” on page 505
“More tab options” on page 505

Animate Motion tab options

Title  Specifies a title for the animation item.
Type  Specifies the type of animation you want to create:
• Animate  Lets you animate any of the available attributes (such as Background Color, Media Opacity, and so on).
• Animate Color  Lets you animate the background color.
• Animate Motion  Lets you animate the elements position.
Set  Lets you animate the value of a setting such as background color or width and height values.
Target  Specifies the region you want to animate:
• None  Animates nothing.
• Root-Layout  Animates the root.
• Region <id>  Animates the chosen region.
• <item type>  Animates the chosen item, such as a selected video item.
Attribute  Specifies the attribute you want to animate. The choices that appear depend on the Type selection.
From/To  Specifies the value of the attribute in its initial state (for certain attributes only) using the From field. Specify the value of the final state of the attribute using the To field.
By  Specifies whether to animate using pixels or percent.

Values  Specifies the values to use as attribute keyframes for the animation. Enter the values to use, separated by a semicolon (;). For example, to animate the width attribute between three sizes, enter: 10;30;90.

**Time tab options**

**Begin** Specifies the beginning trigger for the animation:

- **At Time** Specifies a specific time. Enter the time in the Begin field.
- **On Sync <trigger>** Begins the animation based on another item. Select that item using the pick whip next to the Begin field.
- **On <event trigger>** Starts the animation using the event. For example, On Mouse Click begins the animation when the user clicks the mouse. Use the pick whip to link to the item containing the event you want to use.

**End** Specifies the ending trigger for the animation. These options are the same as the Begin options.

**Fill** Specifies the desired fill option.

**Repeat Count** Specifies the number of times the animation should repeat. Select Indefinite to repeat it indefinitely.

**More tab options**

**Accumulate** Works with the repeat settings to grow the animation for each cycle.

- **None** Uses the values specified on the Animate tab.
- **Sum** Adds the specified value to each cycle.

**Additive** Lets you increase animations by increments, as well as absolute values. (You can use the -by attribute for the value to set the increment value, or you can enter a value list, separated by semicolons.)

- **Replace** Uses the value specified on the Animate tab.
- **Sum** Adds the specified value for each cycle.

**Mode** Specifies how you want your animation to proceed:

- **Discrete** Makes the animation jump from point to point, without interpolation.
- **Linear** Creates a smooth animation. This is the default for Animate and Animate Color types.
- **Paced** Creates a smooth animation. This is the default for Motion types of animation.

**To add transitions to a presentation**

You can create visual transitions between items using the Transition object in the SMIL set of the objects toolbox. You add the transitions you want to use to the presentation's header, and then apply them using the Media Inspector.

1. On the Layout tab of the SMIL window, click the triangle next to Header to expand the header section.
2. From the SMIL set of the objects toolbox, drag the Transition icon to the header section.
3. In the Transition Inspector, specify the applicable options.

**See also**

“Transition Inspector options” on page 506
Transition Inspector options

**Type**  Specifies the transition type you want to use.

**Subtype**  Specifies the subtype of transition. The choices available depend on the type of transition chosen.

**Direction**  Specifies the direction. Direction choices vary depending on the type of transition chosen.

**Duration**  Specifies the duration for the transition.

**Start Progress**  Specifies how far to progress into the transition before displaying it. The default setting starts the transition at zero. If, for example, you are using a clock wipe and want the transition to begin at three o’clock, enter a start progress of .25, or one quarter of the way through the transition.

**End Progress**  Specifies when to stop the transition. The default stopping point is 1 (100 percent). If, for example, you are using a clock wipe and want to end the transition when the wipe hits 6 o’clock, set the end progress to .5, or half-way through the transition.

**Horiz. Repeat**  Specifies the number of times for a horizontal repeat.

**Vert. Repeat**  Specifies the number of times for a vertical repeat.

**Border Width**  Specifies the border width.

**Border Color**  Specifies the border color.

**Fade Color**  Specifies the fade color.

To apply transitions to items

After you add transitions to the header section of a presentation, you can apply them to any item you want.

1. Select the item you want to add the transition to. Only items with visual content can use transitions.

2. Click the Time tab of the Media Inspector, select Transition from the Fill menu, and then select the desired In and Out transitions. (To set other transition properties, select the transition in the header section and use the Transition Inspector.)

Matching presentations to a viewer’s system and preferences

**Switch Statements and cases**

The Switch Statement object lets you specify a set of alternative choices (called cases) for a presentation, of which there is only one acceptable case. For example, a set of cases might be audio items in three different languages—the acceptable case is the language of the viewer’s system. If a case has multiple tests, all of the tests for a case must be true in order for its items to be played.

The viewer’s player application evaluates the cases in the order in which they are listed in the Timeline Editor, starting at the top of the list. The player application plays the items associated with the first case that has all of its tests evaluate to true. All other subsequent cases in the same Switch Statement are then ignored.
Using a Switch Statement and cases to match a presentation to a viewer's language preference

A. Switch statement contains cases for testing and selecting language.  B. Cases in Switch Statement  C. Default case  D. Test for German language  E. This German video item plays if the German language test above it is true.

To add a Switch Statement

You can add one or more Switch Statements to a presentation.

1 Drag a Switch Statement icon from the SMIL set of the objects toolbox to the item content area or item list area of the Timeline Editor.

2 After adding a Switch Statement, you must add one or more cases to the Switch Statement to specify the alternative choices within a statement.

See also

“To add a case to a Switch Statement” on page 507

To add a case to a Switch Statement

When you add one or more cases to a Switch Statement, you must order the cases within a Switch Statement from the highest priority to the lowest priority. The last case in each Switch Statement is called default. If the tests for all other cases are false, the player application plays the default case's items.

Note: GoLive automatically adds a default case when you add the first case to a Switch Statement.

1 Drag the System Attributes icon from the SMIL set of the objects toolbox to the row where the Switch Statement is listed in the Timeline Editor.

2 In the System Attributes Inspector, specify the tests for the case. (See “Test options in the System Attributes Inspector” on page 508.)

3 Add the items you want played if the case's tests are true by dragging media item icons from the SMIL set of the objects toolbox to the row where the case is listed in the Timeline Editor.

4 As necessary, drag the System Attributes icon to add more cases to the Switch Statement, and then add the appropriate tests and items for each case.

5 Add items to the default case at the bottom of the Switch Statement.

To arrange cases in priority order within a Switch Statement

❖ To increase a case's priority within a Switch Statement, drag the case up in the item list area of the Timeline Editor.

❖ To decrease a case's priority within a Switch Statement, drag the case down.
Test options in the System Attributes Inspector

The System Attributes Inspector contains the following options that you can select as the tests for a case:

- **Bitrate** Tests the actual bandwidth (not modem speed) that is available to the viewer’s system. From the Bitrate menu, choose a predefined bandwidth (expressed in bits per second), or choose Custom and then enter an integer value greater than zero in the Bitrate box. This test evaluates as true if the viewer’s system bitrate is equal to or greater than the value you specify. Otherwise, the test evaluates as false.

- **Language** Tests for the language that the viewer’s system is using. From the Language menu, choose a predefined language, or choose Custom and then enter a language prefix (such as “ja” for Japanese) in the Language box. This test evaluates as true if the language you choose exactly matches the language that is specified by the viewer’s preferences. Otherwise, the test evaluates as false.

- **Required** Tests whether the viewer’s system supports an extension. Enter the name of the extension in the Required box. This test evaluates as true if the viewer’s system supports the extension. Otherwise, the test evaluates as false.

- **Width and Height** Tests for the viewer’s monitor dimensions. In the Width and Height boxes, enter the width and height (in pixels) of the viewer’s monitor. Enter integer values greater than zero. This test evaluates as true if the player application can display presentations at the dimensions you specify. Otherwise, the test evaluates as false.

- **Depth** Tests for the viewer’s monitor color depth. From the Depth menu, choose the predefined depth of the screen color palette that is required to display the items in the case. You can also choose Custom from the Depth menu and then enter a depth (in bits) in the Depth box. Enter an integer value greater than zero (such as 8). This test evaluates as true if the player application can display a video or image that has the color depth you specify. Otherwise, the test evaluates as false.

- **Use Captions** Tests whether the viewer’s player application is set to display captions. Select this option if your case includes a text version of an audio item—for example, for viewers who have a hearing disability. This test evaluates as true if the viewer’s player application is set to display captions. Otherwise, the test evaluates as false.

- **Overdub** Tests whether the viewer’s player application is set to play audio overdubbing or text captioning. Choose an option from the Overdub menu. This test evaluates as true if the viewer’s preference is the same as the option you chose from the Overdub menu. Otherwise, the test evaluates as false.

Working with regions in SMIL presentations

**About regions**

A region is a defined area of the presentation that controls the size, position, and scaling of a media item. You can also create subregions to place a region in a larger region. Subregions move with their larger region. One advantage of using GoLive to create SMIL presentations is that you don’t have to explicitly define and assign regions. When you add an item, GoLive automatically defines a region for the item and assigns it to the item for you. When you resize or reposition an item, GoLive also changes the region’s properties in the source code for you.

You can also manually create new regions and assign items to the regions. For example, you can assign the same region to display different video items at different times in the same location. Or, you might want to prototype different layouts of items and quickly compare various positions and sizes for the items. After manually creating several alternate regions for the items, you can then reassign the items to the alternate regions and instantly see the different layouts.
About the default root layout region

When you create a new SMIL document, GoLive automatically creates a default root-layout region. This root-layout region defines the size of the overall SMIL presentation that plays within the player application window (default size is 320 x 240 pixels). All of the items in your presentation must fit within the root-layout region—any portion of an item outside the root-layout region is clipped when played in the player application window.

Creating regions manually in a presentation

A. A region that is assigned to a video item   B. Manually created region that is currently unassigned to an item   C. Root-layout region

To use the SMIL Layout Inspector to add regions

The SMIL Layout Inspector lists the regions for the entire presentation.

1. Select the Page icon at the top of the Layout tab next to the title.
2. In the Regions tab of the SMIL Layout Inspector, click the New Item button. GoLive adds a new region to the list.
3. In the ID box, change the region's default ID, if necessary.
   Note: Changing the default ID is optional and only necessary if you want to use a meaningful name or number to identify the region.
4. Set the region's position and size by entering values in the Left, Top, Right, and Bottom boxes.
5. Set the region's layering order by entering a value in the Z-index box.
6. Set the region's background color by selecting BG Color and then clicking the Color field to select a color from the Color palette.

See also

“To reposition or resize an item using precise values” on page 493
“To set the layering order of overlapping items” on page 495

To use the Media Inspector to add regions

The Media Inspector lists the region that the selected item is currently assigned to.

1. Select the item in the Layout tab or Timeline Editor, and then display the Layout tab of the Media Inspector.
2. Choose Create New Region from the menu next to the Region ID box.
3 In the Region ID box, change the region's default ID, if necessary.
4 In the Layout tab, set the region's position, size, and other layout properties.

**See also**

“*To reposition or resize an item using precise values*” on page 493

**To assign a region to an item**

After adding regions, use the Media Inspector to manually assign a region to an item.

1 Select the item and display the Layout tab of the Media Inspector.
2 Choose the region from the menu next to the Region ID box. GoLive positions and sizes the item in the presentation using the region's layout properties.

**Adding SMIL presentations to a site**

**Adding SMIL presentations to a site**

After creating and saving a presentation as a SMIL document, you can add the SMIL presentation to a site. You can either use a link to play the presentation in a separate RealPlayer application window, or you can use the RealMedia plug-in to embed the presentation on a web page. The RealMedia plug-in plays an embedded SMIL presentation in the web browser window without opening a separate RealPlayer application window.

💡 You can preview a presentation by adding a player application (such as RealPlayer) to the list displayed after you click the Show In Browser button in the Layout tab.

**See also**

“*To specify browsers for previewing*” on page 32
To create a Ram file

A Ram file is a text file that contains a URL to the SMIL presentation. If you want to use a link to play a SMIL presentation in a separate RealPlayer application window, the link must reference a Ram text file. When a viewer clicks on the link, the web browser starts RealPlayer, which then opens the Ram file to locate and play the SMIL presentation.

1. Use a text editor to create a text file.
2. On the first line of the text file, enter a URL for your SMIL presentation according to where the presentation is stored:
   - If the SMIL presentation is stored on a streaming RealServer, begin the URL with rtsp://. (For example, rtsp://server.adobe.com/media/mypresentation.smil)
   - If the SMIL presentation is stored on a web server, begin the URL with http://. (For example, http://server.adobe.com/media/mypresentation.smil)
   - If the SMIL presentation is stored locally on the viewer's computer, begin the URL with file://. (For example, file://media/mypresentation.smil)
3. Save the text file with one of the following extensions:
   - To reference the Ram file in a link and play a SMIL presentation in a separate RealPlayer application window, save the text file with a “.ram” extension (For example, mypresentation.ram).
   - To use the Ram file to embed a SMIL presentation on a web page, save the text file with an “.rpm” extension. (For example, mypresentation.rpm).

To play SMIL presentations in the RealPlayer application window

You can use a link to play a SMIL presentation in a separate RealPlayer application window. The link must reference a Ram file that contains a URL to the SMIL presentation. The Ram file must have a “.ram” extension.

1. Open the web page, and then create a link.
2. In the Inspector, enter a URL to a Ram text file that has a .ram extension. (For example, http://www.adobe.com/mypresentation.ram)

Embedding SMIL presentations on a web page

You embed a SMIL presentation on a web page by adding a RealMedia plug-in to the page and then either referencing the SMIL document directly, or referencing a Ram text file that contains a URL to the SMIL document. The Ram text file must have an .rpm extension.

Use a Ram text file if any of the following applies to your situation:

- The RealServer for your SMIL presentation doesn't use RealPlayer Ramgen.
- The SMIL presentation is stored on a web server.
- All of the files referenced in your SMIL presentation are stored on the viewer's local hard disk rather than on the Internet.
To embed a SMIL presentation in a web page

1. Open the web page, and then drag the RealMedia icon from the Basic set in the objects toolbox to the Layout tab.

2. In the Basic tab of the Plug-in Inspector, select File, and then enter one of the following in the URL box:
   - Enter the URL to a SMIL document. (For example, http://www.adobe.com/mypresentation.smil)
   - Enter the URL to a Ram file that has an "rpm" extension. (For example, http://www.adobe.com/mypresentation.rpm)

3. Select Class, and then choose RealPlayer from the menu next to the Class box.

4. Verify the MIME field is set appropriately.

5. Set the width and height dimensions of the RealPlayer plug-in placeholder to the size of your presentation (for example, 400 x 280).

6. Choose <Object> & <Embed> from the HTML menu to embed the scripting that browsers will use to detect the RealMedia plug-in and ensure that the content is played back correctly in different browsers.

7. In the Real tab, choose Image Window from the Controls menu.

   Image Window provides a window for the SMIL presentation to play back in. A context menu is also provided that lets the viewer control playback in the presentation window by choosing menu commands such as Play and Stop. The Image Window doesn't provide any other RealPlayer controls.

8. Choose “_master” from the Console menu.

To add RealPlayer controls to presentations

To add individual RealPlayer controls to a web page, you must add a RealMedia placeholder for each control. For example, to provide both Play and Pause buttons, you must add separate placeholders and specify Play Button for one and Pause Button for the other.

To add all RealPlayer controls to a page, you simply specify the Control Panel option for one RealPlayer placeholder.

1. Drag the RealMedia icon from the Basic set in the objects toolbox to the Layout tab.

2. In the Basic tab of the Plug-in Inspector, enter the URL for the SMIL presentation that you want RealPlayer controls for.

3. Select Class, and choose RealPlayer from the menu next to the Class box.

4. Set the width and height dimensions of the RealPlayer controls. (For example, you might want the width of the RealPlayer controls to be the same as the width of the presentation.)

5. Choose <Object> & <Embed> from the HTML menu.

6. In the Real tab, select the controls you want to display by choosing the appropriate options from the Controls menu.

Controls menu options available in the Real tab

**Image Window** Displays a window for the SMIL presentation to play back in, but doesn't provide a RealMedia Player control panel or buttons. A context menu is provided that lets the viewer control playback in the presentation window by choosing menu commands such as Play and Stop.

**Control Panel** Displays the RealMedia Player control panel, which contains Play, Pause, Stop, Fast Forward, and Rewind buttons; Position and Volume sliders; and a Mute button that appears when the speaker is selected.
Play Button Displays a Play/Pause button.
Play Only Button Displays a Play button.
Pause Button Displays a Pause button.
Stop Button Displays a Stop button.
Fast Forward Control Displays a Fast Forward button.
Rewind control Displays a Rewind button.
Mute Control Displays a Mute button.
Mute Volume Displays a Mute button and Volume slider.
Volume Slider Displays a Volume slider.
Position Slider Displays an Item Position slider.
Clip Information Displays an information field for information about the item.
Home Control Displays the RealMedia logo.
Info Volume Displays presentation information, as well as a Volume slider and a Mute button.
Info Panel Displays the presentation information panel.
Status Bar Displays informational messages, the network congestion LED, and the position field, which indicates the current place in the presentation timeline along with total item length.
Status Field Displays the message text area of the status bar. If no status field or status bar is embedded, error messages display in the browser's status bar.
Position Field Displays the item's current place in the presentation timeline and the total item length.

See also "Real plug-in options" on page 354

Creating RealPlayer presentations

About the RealPlayer Editor
The GoLive RealPlayer Editor lets you integrate SMIL content with HTML content. Use the RealPlayer Editor's three panes and their Inspectors to organize and link SMIL and HTML content as follows:

Media pane Contains RealMedia files such as .rm, .ra, .rp, and SMIL presentations.
Info pane Contains .html pages that include information about the content in the Media Playback pane.
Browser pane Contains .html files relevant to the content.

To create a Real Player presentation
❖ Choose File > New, and then select Web > Multimedia > RealPlayer Document.
GoLive opens the presentation in the Real window (untitled.ram).
To add content to the Media pane

You can add any type of RealMedia content (.rm, .rp, .ram) to the Media pane by entering a URL to the desired media. After you add the content, use the Media Pane Inspector to set its properties.

1 In the RealPlayer Editor, click the Media pane.
2 In the Media Pane Inspector, set the options on the Media tab:
   - **URL** Specifies the URL of the media file you want to appear. Enter the URL or use the pick whip to link to the RealMedia file.
   - **Screen Size** Specifies the desired screen size.
   - **Mode** Specifies the desired mode:
     - **Normal** Opens the presentation in RealPlayer with the controls grouped around the playback window.
     - **Theater** Plays the presentation in the center of a black screen and places the controls at the bottom.
     - **Toolbar** Opens the presentation in RealPlayer and places the controls at the bottom of the screen.
   - **Start Time** Specifies the start time.
   - **End Time** Specifies the end time.
   - **BG Color** Specifies the background color for your presentation.
   - **Description** Provides a description for the content in the Media pane.
3 Click the Clip Info tab, and then enter the information you want to appear. (If you've already specified presentation information, it appears here.)
4 If you're using streaming media, click the Streaming Info tab and enter the appropriate information. For more information on streaming media, see RealMedia's website at www.realmedia.com/resources.
5 Save the presentation.

To add content to the Info pane

You can add HTML content to the Info pane. The HTML content should contain information about the content of the Media pane. If you choose not to include related information, the Info pane will not appear in the RealPlayer—instead, the Media pane appears centered over the Browser pane.

1 In the RealPlayer Editor, click the Info pane.
2 In the Info Pane Inspector, set the options as desired:
   - **URL** Specifies the URL of the HTML page that contains the information you want to display.
   - **URL Params** Specifies the parameters necessary to open HTML files in the Info and Browser panes. Separate the first parameter from the URL with a question mark and precede subsequent parameters with an ampersand, as follows: `URL?parameter=value& parameter=value`
   - **Width** Specifies the width of the Info pane.
   - **Height** Specifies the height of the Info pane.
   - **Delay** Specifies the amount of time to delay the display of the linked HTML page from the start of the media file in the media pane.
To add content to the Browser pane

Use the Browser pane to display HTML pages that further explore the content of the Media pane. You can display the Media pane as part of the RealPlayer window, or as its own browser window.

1. In the RealPlayer Editor, click the Browser pane.

2. In the Browser Pane Inspector, set the options as desired:
   - **URL** Specifies the URL of the HTML page you want to display.
   - **Target** Specifies how you want the Browser pane to appear:
     - **None** Writes no attribute and uses the default Browser pane.
     - **Media Browser** Displays the page in the Browser Pane.
     - **External Window** Displays the linked page in an external browser window.
   - **URL Params** Specifies the parameters necessary to open HTML files in the Info and Media Browser panes. Separate the first parameter from the URL with a question mark and precede subsequent parameters with an ampersand, as follows: `URL?parameter=value& parameter=value`

3. Save the file.

To preview a RealPlayer presentation

❖ Open the presentation in RealPlayer and test its functionality.

You can add RealPlayer to the Browsers list in GoLive's preferences.

See also

“To specify browsers for previewing” on page 32

Creating RealPix presentations

RealPix presentations

The GoLive RealPix Editor lets you create a slide show of streaming images that can include special transition effects such as cross fades and wipes. You create the RealPix slide show presentation by using the RealPix Editor to add images and effects and then set the timing of effects.

The RealPix Editor automatically generates RealPix source code for your presentation and stores the code in a RealPix document. If you’re an experienced RealPix developer, you can also see and edit the source code for your RealPix document in GoLive’s Source Code editor (Window > Source Code).

After you save a RealPix document, you can add it to a SMIL presentation as an Image item. You can also use RealPlayer to view the RealPix document as a stand-alone presentation.

Note: For more information on RealPix, see the RealNetworks website (www.realnetworks.com).

See also

“To add media items to a presentation” on page 489
About the images in a RealPix presentation

You must use an application such as Adobe Photoshop* to create and prepare your images before you begin using the RealPix Editor to create the presentation. You can use the following types of images in a RealPix presentation:

**GIF87a, GIF89a, and animated GIF (.gif)** Although you can use either interlaced or noninterlaced GIFs, noninterlaced GIFs are recommended because RealPix doesn't use the interlaced GIF features.

**JPEG (.jpg)** You can use RGB baseline or grayscale JPEGs. RealPix doesn't support progressive JPEGs.

**PNG (.png)** RealPix uses all of the PNG functions except for the gamma settings.

*Note:* If you add a RealPix presentation to a SMIL presentation, transparency is preserved within the region displaying the RealPix presentation, but not across other regions in the SMIL presentation.

To create or open RealPix documents

❖ Do one of the following:
  • Choose File > New, and then select Web > Multimedia > RealPix Document.
  • Choose File > Open, and select the RealPix document.

To save a RealPix document

❖ Choose File > Save. Navigate to a site folder where you want to store the RealPix document with a SMIL presentation, enter a file name with an .rp extension, and then click OK.

*Note:* If you want to use the RealPix document in a SMIL presentation in Windows, you must store the document in the same folder as the images.

About the RealPix Editor

The RealPix Editor provides several tools for adding effects and images to a presentation; setting and viewing the timing of effects; cropping, resizing, and repositioning images; and previewing the presentation.
The RealPix Editor

A. Images currently in the presentation’s image library
B. Image library area
C. View area
D. Time cursor
E. Time ruler
F. Timeline area
G. Playback controls
H. Current time position
I. Time scale slider
J. Buttons for adding and deleting effects.

Image library area Displays a list of the images that are available for you to use in the presentation. Each image is identified by its handle ID in parenthesis and its file name.

View area Displays the Main Settings view, Preview, Destination view, or Source view. You select a view by clicking the Main Settings button, the Preview button, the Destination View button, or the Source View button below the view area.

Time cursor Controls the current time position of the presentation. To change the current time, drag the time cursor left or right, or click on the time ruler.

Time ruler Displays time intervals for the effects in the timeline area, depending on what you have selected with the time scale slider at the bottom of the window.

Timeline area Displays the effects in the presentation at their starting time position. The left edge of the effect’s icon in the timeline area marks the start time when the effect begins displaying its associated image. The right edge marks the end time of the effect. The same image is displayed in the presentation until the start time of the next effect in the timeline area.

Playback controls Controls the playback of the presentation in the view area. Click the Backward button to rewind the presentation by a single step. Click the Stop button to stop presentation playback at the current time, or double-click to rewind the presentation to the beginning. Click the Play button to play the presentation. Click the Forward button to advance the presentation a single step.

Current time position Displays the current time position of the time cursor.

Time scale slider Controls the time scale shown in the timeline area. You can adjust the time scale to make it easier to examine the timing relationships among the effects. Drag the time scale slider to the right to decrease the resolution of the time scale and compress the effect icons in the timeline area. Dragging to the right lets you survey larger sections of the presentation. Drag the time scale slider to the left to increase the resolution of the time scale and lengthen the effect icons.

Effect buttons Let you add a transition effect along with its associated image to the presentation timeline area.
To set up a RealPix presentation

1. Click the Main Settings button [M].

2. In the Main Settings Inspector, set the appropriate global options for the RealPix presentation, such as the size of the overall RealPix presentation display window. The default presentation size is 240 x 240 pixels.

Properties of RealPix presentations

Set the following options for RealPix presentations in the Main Settings Inspector:

**Duration and Auto Update** Select Auto Update to have the RealPix Editor automatically calculate and set the presentation's total duration time based on the sum of the durations of the individual effects that you add to the timeline. To manually specify a presentation's duration, deselect Auto Update and then enter a time value in the Duration box.

The presentation stops playing when the presentation's duration time is reached, regardless of the timing you set on the individual effects in the timeline. If the total duration time is longer than the last effect in the timeline, the last effect remains displayed in the presentation window until the total duration time is reached.

*Note:* The timing specified in a SMIL presentation can override the duration time that is specified in a RealPix presentation even if the RealPix presentation hasn't finished playing.

**Preroll** Specifies how long you want RealPlayer to buffer your presentation before playing it. Whenever a presentation plays, the preroll value is automatically determined based on the presentation's images and timing. If you enter a preroll value that is smaller than the automatically determined value, the automatically determined value is used. Otherwise, your value is used.

In most cases, you can leave the default preroll value (0) unchanged to have RealPlayer automatically determine the preroll value. However, you can set a high preroll value if necessary. For example, you might want to manage competing bandwidth requirements for multiple items in a SMIL presentation by using a high preroll value to buffer a RealPix presentation before starting to play a streaming video.

**Bit Rate** Specifies the maximum bandwidth (in bits per second) that you want the RealPix presentation to use.

**Use Time Format** Enters time values in the document's source code in the dd:hh:mm:ss.xyz time format. If you deselect this property, the RealPix Editor enters time values in source code as milliseconds. (You can enter time values in either format, whether this option is selected or not.)

**Width and height** Specifies the dimensions of the presentation display window in pixels. Source images scale larger or smaller to fit in the dimensions you specify. You can also crop source images or resize and reposition them within the presentation display window.

**BG Color** Sets the background color of the presentation when it begins playing. The default background color is black. To set a different background color, click the color field and select a color in the Color palette.

**Preserve Image Aspect** Prevents source images from being distorted if the aspect ratio (height to width) of a source rectangle is different than the aspect ratio of a destination rectangle. This option is selected by default, ensuring that the aspect ratio of all source rectangles is preserved. If you deselect this option, the aspect ratio of all source rectangles changes to match the destination rectangle's ratio, distorting some source images.

**URL** Adds a link to a presentation. By default, the link is active for all images in the presentation, but you can specify a unique URL for specific effects.

**Max FPS** Sets the maximum frames per second (fps) for all images in a presentation. This property is optional because RealPlayer automatically optimizes the frames per second setting for each viewer's computer. RealPlayer uses 30 fps (the maximum) whenever possible, but it can also use a lower rate if necessary. However, you may want
to manually set a lower maximum fps rate to distribute the load on the viewer's CPU among multiple RealPix presentations that play simultaneously in a SMIL presentation. (You can override this global setting and use a different maximum fps setting on individual effects.)

**Title, Author, and Copyright** Specifies the title, author, and copyright information for your RealPix presentation. (If you use the RealPix presentation in a SMIL presentation, this information may be overridden by the title, author and copyright information defined in the SMIL presentation.)

**Adding images to a presentation (image library)**
Before you can use images in a presentation, you must first add the images to the presentation's image library. The image library lists the images that are available for the presentation. However, an image is not displayed in the presentation until you associate the image with an effect in the timeline area. Each presentation contains its own image library.

The image library shows the file name and handle ID for each image. When you add an image to the library, the RealPix Editor automatically assigns a unique handle ID. In RealPix source code, this ID references images; file names aren't used. The RealPix Editor automatically manages handle IDs for you. In most cases, you don't need to change the handle ID assigned by the RealPix Editor.

**To add images to the image library**
❖ Do either of the following:

- Drag image files from a site window to the image library area.

- Click the New Item button below the image library. Select the new item in the image library, and then specify the image file in the the Image Inspector's URL box.

**To delete an image from the image library**
❖ Select the image in the image library, and then click the Remove Selected Items button.

**To change a handle ID**
❖ Select the image in the image library, and then enter a unique ID number in the Handle ID box in the Image Inspector.
Using effects in a RealPix presentation

Adding effects to a RealPix presentation

After adding images to a presentation's image library, you can add transition effects to the presentation and associate an image with each effect. When you create a new RealPix document, GoLive automatically adds a default fill effect at the beginning of the presentation. The default Fill effect displays a black rectangle in the presentation display window before any other images appear. You can leave the default fill effect in the presentation as it is, modify its color, or delete it.

If you want to use a fade-in effect to display an image, you can simply drag the image from the site window or image library to the timeline area. A fade-in effect displays a gradual transition from the current color or image in the presentation to a different image. If you want to use one of the other effects, you must first click an effect icon to add the effect to the timeline area, and then choose the image you want to display with the effect. To replace an added effect, you must delete it and then add a different effect.

To add an effect to an image

1. Drag the image file from the site window or image library to the timeline. (If you drag an image from the site window, GoLive automatically adds the image to the image library.)

2. Click the Preview button , the Destination View button , or the Source View button .

3. In the timeline, position the time cursor where you want the effect to start.

4. Add an effect to the timeline by clicking one of the following buttons:

   **Fill Effect**  Displays a colored rectangle. For example, you might want to use a fill effect to cover the previous image before displaying two smaller images next to each other.

   **Fade-in Effect**  Transitions from the current color or image to a different image.

   **Fade-out Effect**  Transitions from the current color or image to a different color.

   **Crossfade Effect**  Transitions from the current color or image to a different image.

   **Animate Effect**  Plays an animated GIF.

   **Wipe Effect**  Displays a transition that slides a different image over the current color or image, or pushes the current image entirely out of the display window.
Select the effect in the timeline area.

Do one of the following in the Transition Inspector:

- To associate and display an image with the effect, choose the image from the Image menu.
- To set the color of a Fill or Fade-out effect, click the color field, and then select a color in the Color palette.
- To set the direction of a Wipe effect, choose a direction from the Wipe Direction menu. To push the current image entirely out of the display window, select Push Background.

**Identifying the type of effect in the timeline**
The icon for each effect in the timeline contains a symbol that identifies the effect type.

![Image](image.png)

Identifying an effect in the timeline
A. The symbol on an effect's icon identifies it.  
B. The symbol matches the button for the effect.

**To delete an effect from the timeline**

In the timeline area, select the effect that you want to delete, and then click the Delete Effect button.

**To add a link to an effect**

1. Click the Preview button, the Destination View button, or the Source View button.
2. In the timeline area, select the effect that you want to add a link to.
3. In the Transition Inspector, select URL, and then specify the linked file.

The link is active for the current effect only; viewers can click the link only when the effect's image is displayed. This URL overrides any global URL setting in the Main Settings Inspector.

**Setting the timing of effects in RealPix presentations**

When you add an effect to the timeline, the start time is determined by where you drag the image, or where you set the time cursor before clicking an effect icon. The default duration for an effect transition is one second.

After adding an effect to the timeline area, you can change its start time or the duration of the effect's transition by using the timeline or the Transition Inspector.

![Image](image.png)

Changing the start time and duration of an effect's transition
A. Drag the effect icon in the timeline area to change the effect's start time.  
B. Drag the effect icon's right edge to change the duration of the effect's transition.
To change the start time of an effect
❖ Do one of the following:
  • In the timeline area, drag the effect.
  • Click the Preview button 
    , the Destination View button 
    , or the Source View button 
    . Then, in the timeline area, select the effect that you want to change and specify the start time in the Transition Inspector.

To change the duration of an effect
  • In the timeline area, drag the effect’s right edge.
  • Click the Preview button 
    , the Destination View button 
    , or the Source View button 
    . Then, in the timeline area, select the effect that you want to change, and specify the duration in the Transition Inspector.

Adjusting images in RealPix presentations

Cropping, resizing, and repositioning images
You can crop source images and display any portion of them in your presentation. You can also resize and reposition images within the overall presentation display window.

You crop a source image by using the Source Rectangle, which defines the area of the source image you want to display. For example, you can place the Source Rectangle around a person’s face to display only the face in the presentation.

You resize and reposition an image by using the Destination Rectangle, which defines the size and location of the image as it appears within the overall presentation display window. By using the Destination Rectangle, you can also resize and position multiple images next to each other.

To crop a source image
1 Click the Source View button 
  .
2 Position the time cursor on the right edge of the image that you want to crop. (The image must be visible in Source View.)
3 Drag the Source Rectangle and its resize handles to define the portion of the source image you want to appear in the presentation display window. (To see how the cropped image appears in the presentation, click the Preview button 
    or the Destination View button 
    .)
Cropping an image with the Source Rectangle
A. Use the Source Rectangle in the Source view to crop an image.  B. The cropped image is resized according to the dimensions of the Destination Rectangle in the Destination view.

To crop an image using precise coordinates
1 In the Preview, Destination view, or Source view, position the time cursor on the right edge of the image that you want to crop.
2 In the X and Y boxes for the Source Rectangle in the Transition Inspector, enter the coordinates for the upper left corner of the Source Rectangle.
3 In the Width and Height boxes for the Source Rectangle, enter dimensions in pixels.

To resize and reposition an image
1 Click the Destination View button to display the Destination view.
2 Position the time cursor on the right edge of the image that you want to resize or reposition.
3 Do any of the following:
   • To resize an image, drag the Destination Rectangle's resize handles to the dimensions you want the image to appear in the presentation display window.
   • To reposition an image, drag the Destination Rectangle to the location where you want the image to appear in the presentation display window.
Resizing and repositioning an image with the Destination Rectangle

A. Use the Destination Rectangle in the Destination view to resize and reposition an image  
B. You can display two images together by resizing and repositioning them in the Destination view.

To resize and reposition an image using precise coordinates

1. In the Preview, Destination, or Source view, position the time cursor on the right edge of the image that you want to resize or reposition.

2. In the X and Y boxes for the Destination Rectangle in the Transition Inspector, enter the coordinates for the upper left corner of the Destination Rectangle.

3. In the Width and Height boxes for the Destination Rectangle, enter the dimensions in pixels.

To preserve the aspect ratio of an effect’s image

1. In the Preview, Destination view, or Source view, position the time cursor on the right edge of the effect you want to set.

2. Select Preserve Image Aspect in the Transition Inspector. (This option is on by default.)
Chapter 24: Editing QuickTime movies

QuickTime in GoLive

About editing QuickTime movies
In GoLive, the main tools you use to edit movies include the movie viewer window, the Timeline Editor, the QuickTime set of the objects toolbox, and the Inspector. The movie viewer contains a Preview tab for previewing a movie, and a Layout tab for editing the spatial attributes of a movie visually (for example, size and position). The Timeline Editor lets you assemble movie tracks, control their behaviors over time, and manage their interaction. The QuickTime set of the objects toolbox provides icons for the tracks you use to assemble movies. The Inspector lets you edit track properties and behaviors.

Editing QuickTime movies
A. Movie viewer window   B. Timeline Editor

See also
“About tracks and track types” on page 531

To set preferences for QuickTime movies
Use QuickTime preferences to customize the layout grid in the movie viewer window and define a movie scratch volume, which GoLive uses to store temporary files.

❖ Choose Edit > Preferences (Windows) or GoLive > Preferences (Mac OS), select QuickTime from the list on the left, and then set options on the right.
Creating and opening QuickTime movies

To create a new movie
2. Select Web > Multimedia > QuickTime Movie, select Show Options, and then do one of the following:
   - Choose a movie size from the Sizes menu.
   - Enter pixel values in the Width and Height boxes.
3. (Optional) Select a new background color. The color you select becomes the default for the color track, which you can change at any time.
4. Click OK.
5. Click the Show Timeline Window button to display the Timeline Editor.

To open an existing movie
1. Choose File > Open, navigate to the movie file, and then open it.
2. Click the Show Timeline Window button to display the Timeline Editor, which lists the existing tracks associated with the movie.

Editing and previewing movies in the movie viewer window

To select tracks in the Layout tab
Some movies have several tracks, and you must select individual tracks to set properties in the Inspector. The Layout tab in the movie viewer window offers a context menu that lists all of the available tracks at the current time and position in the movie. When you select a track in the Layout tab, GoLive also selects the track in the Timeline Editor, and vice versa.

1. If the movie window is hidden or minimized, click in the Timeline Editor and choose Movie > Show Movie.
2. With the Layout tab active, do one of the following:
   - Click inside the track's boundaries.
   - Place the pointer over the track, and then choose the track from the context menu.

To select a group of tracks in the Layout tab
❖ With the Layout tab active, do one of the following:
   - Click to select the first track, and then Shift-click to select each additional track.
   - Drag a selection rectangle over the tracks.
   - Select All from the context menu to select all tracks.
To reposition a track or group of tracks
❖ Drag the tracks in the Layout tab, or enter precise values in the horizontal or vertical Position boxes in the Transform palette.

To align tracks
• To align tracks in relation to the movie window, select the track or tracks; then click a horizontal or vertical alignment button under Align To Parent in the Align palette.
• To align tracks in relation to each other, select the tracks in the Layout tab, and then click a button under Align Objects in the Align palette. You can align tracks along the left, center, or right vertical axis or along the top, center, or bottom horizontal axis.

See also
“To align the timing of tracks and samples” on page 534

To skew a track
1 Select a track in the Layout tab.
2 Click the Skew tool in the toolbar.
3 Drag a blue handle to shape the parallelogram as desired.

To rotate a track
1 Select the track or group of tracks that you want to rotate.
2 Click the Rotate tool in the toolbar.
3 Drag a blue handle to rotate the track as desired.

To set movie properties
❖ With the Inspector open, click the Preview tab in the movie viewer window. Then, set any of these properties in the Basic tab:

Autoplay Sets the movie to start automatically when it is viewed in the QuickTime Player. This option does not affect movie playback in a web page by the QuickTime plug-in. If you select Autoplay and choose None from the Loop menu, the movie plays once.

Loop menu Specifies how you want the movie to play back. Choose None to play the complete movie once and then stop. Choose Loop to play the complete movie from beginning to end repeatedly. Choose Palindrome to play the complete movie forward and then backward repeatedly.

Controller menu Specifies the playback controller for your movie. The type of controller you choose must be compatible with the movie content. For example, don’t choose a QuickTime VR controller for a movie that doesn’t contain QTVR content.

Movie Identifier Specifies the name and ID of a target movie. To name the movie for use as target of a wired action, select Movie Name and enter a name in the box. To assign an ID, select ID and enter a unique ID number. When you specify the target movie of a wired action, such as Child Movie Name or Child Movie ID, use the movie name and ID you specified in this option.
See also
“To wire a movie track with actions” on page 540

To annotate a movie
❖ Click the Annotation tab in the Movie Inspector and fill in any or all of the text boxes.

Editing movies in the Timeline Editor

About the Timeline Editor
You use the Timeline Editor to add tracks, effects, and interactivity to QuickTime movies.

[Image of the Timeline Editor with labels:
A. Sample editing tools
B. Track list area
C. Marker menu
D. Time ruler
E. Time cursor
F. Track content area
G. Mouse pointer position in track content area
H. Expand/collapse tracks with samples
I. Show/hide track information
J. Loop
K. Palindrome control
L. Playback controls
M. Time scale slider]

Selection tool Use the Selection tool to select tracks, samples, and other items in the Timeline Editor. You can also use this tool for dragging tracks in the track list to set the layering order, and to display the properties for a track or sample in the Inspector. To select multiple items, Shift-click or drag a selection rectangle over the tracks. After selecting multiple items, you can use the Multiple Inspector to align the timing of the items.

Sample editing tools Use the sample editing tools to create and manipulate keyframes and samples within tracks. Playba
**Track information** Displays information about the tracks. Show or hide track information by clicking the Show/Hide Track Info button. The columns display the following information:

- **V** Shows whether a track is visible or a sound or MIDI track is audible. Click the Eye icon to show or hide visible tracks, or to turn muting or Mute on and off for audible tracks. In general, hidden tracks can affect the boundaries of a movie.

- **L** Shows whether a track is locked. Click the Lock icon to lock or unlock the track. When a track is locked, you can't change it, and "(locked)" appears next to the track name in the track content area.

- **Type icon** Shows track type. For example, the Video icon identifies a video track, and the Text icon identifies a text track.

**Track list area** This list on the left side of the Time Editor displays the tracks in the movie. Each track bar is identified by its name (such as Video Track 1) or title if you enter one in the appropriate Inspector. To delete a track, select it and choose Edit > Delete (Windows) or Edit > Clear (Mac OS). The relative position of tracks in the track list determines the layering order of a movie.

**Track content area** This list on the right side of the Time Editor displays a bar (or keyframe for a sprite sample) that represents the media on each track. The left edge of the bar marks the start time of the track, and the right edge marks the end time. The keyframe marks the start time of the sprite sample.

**Marker menu** Lists the time markers you create and lets you move the time cursor directly to a point on the time ruler. GoLive displays the frame at that time in the movie window. To create a new marker, position the pointer on the Mouse Time row below the time ruler. When the pointer becomes a small triangle, place the triangle at the time location where you want to create a new marker and then click. Type a name for the marker in the text box.

**Time ruler** Displays time intervals for the tracks in the track content area, depending on what you have selected in the time scale slider at the bottom of the window.

**Time scale slider** Controls the time scale shown in the track content area. You can adjust the time scale to make it easier to examine the timing relationships between the tracks in multiple-track movies. Drag the time scale slider to the right to decrease the resolution of the time scale (up to a maximum of one minute) and compress the track bars. Dragging the time scale slider to the right allows you to survey larger sections of the movie. Drag the time scale slider to the left to increase the resolution of the time scale (down to a minimum of one frame) and lengthen the track bars. Any changes you make with the time scale slider are saved between sessions. The default time scale setting is 6 frames per second.

**Time cursor** Controls the location of the current frame (or time) in a movie that appears in the Preview tab. To change the current frame, drag the time cursor left or right, or click on the time ruler. Before adding a new track, position the time cursor at the time where you want the new track to begin.

**See also**

“To set the layering order of tracks” on page 533

“To align the timing of tracks and samples” on page 534

“To edit a sample” on page 530

**Samples**

Some tracks contain samples that let you define attributes related to the track type. For example, one attribute for a text track is text content, and one attribute for a filter track is effect type (such as Cross Fade or Dissolve).
In addition to defining attributes, a sample takes effect at a specific time and for a specific duration. For example, in one text track, you can add three text samples, each of which contains three different phrases that appear in the movie at three different times for different periods of time. You can also add samples in a filter track to use different effects at different times.

**Note:** Although video and audio tracks can contain samples, GoLive doesn’t currently let you create or edit video or audio samples directly. To create or edit video or audio samples, use a video or audio editing application such as Adobe Premiere Pro or Adobe Audition.

**To edit a sample**

1. Select a track.
2. If the samples below the track are not displayed, click the arrow to the left of the track name in the Timeline Editor to expand the track.
3. Use the tools in the Timeline Editor to add new samples or edit existing samples.

**Create Sample tool** Creates additional samples in the track content area. You also use this tool to create sprite keyframes. Click the Create Sample tool, select a start point in the track content area, and then drag the sample track bar to the desired endpoint. GoLive adds the sample in the track content area and displays the corresponding sample Inspector.

**Divide Sample tool** Divides an existing sample into two samples. The resulting samples have identical content, but their durations are shortened depending on where you divided them. After you select the Divide Sample tool, click the existing sample where you want to divide it. For example, if you divide a 25-second sample at the 10-second mark, the result is a sample of 10 seconds and another sample of 15 seconds. You can then drag each sample to the time interval you want and change its content as necessary.

**Glue Sample tool** Sets the end time of a sample to the start time of the following sample if there is a gap between the samples. After you select the Glue Sample tool, click the first sample. GoLive extends the first sample up to the start time of the following sample.
Delete Sample tool  Deletes a sample (or sprite keyframe). After selecting the Delete Sample tool, click the sample you want to delete.

Swap Sample tool  Swaps two adjacent samples. For example, you can change the order of images in a picture track by swapping its picture samples. After you select the Swap Sample tool, drag the sample you want to swap toward the adjacent sample.

Move Sample tool  Moves multiple samples at a time. After you select the Move Sample tool, drag the sample you want to move. GoLive moves all of the following samples in the same track to the right as a unit. This tool is especially useful for moving multiple picture samples in a picture track. You can't move the first sample of a track because it must have the same start time as the track itself.

Working with tracks

About tracks and track types
Tracks are the basic unit you use to create a QuickTime movie; each type of track contains a particular kind of information. In the Inspector for each track, you set options that affect track appearance and behavior, such as start time, duration, size, position, and visibility. In the site window, you manage the URLs for linked files in tracks.

Some track types specify content (such as video tracks), some specify how the content is combined (such as filter tracks), and others add interactivity (such as sprite tracks). When working with QuickTime movies in GoLive, you can use the following types of tracks:

Movie track  Adds a QuickTime file by referencing its URL.

Video track  Adds a video to a movie.

Color track  Adds a colored layer to a movie.

Picture track  Adds a slide show, or series of still images, to a movie.

Generic Filter track  Adds a cloud, fire, or ripple effect to a movie.

One Source Filter track  Adds a filter to one other video track within the movie.

Two Source Filter track  Transitions between two video tracks.

Three Source Filter track  Blends two video tracks using the luminosity of a third track.

MPEG track  Adds MPEG-1 video to a movie (for audio, use a sound track).

Sprite track  Contains sprite objects, which add interactivity to a movie.

SWF track  Adds SWF files to a movie.

3D track (Windows only)  Adds QuickDraw 3D files to a movie.

HREF track  Embeds URLs on a text track.

Chapter track  Divides a movie into segments.

Text track  Adds text to a movie.

Sound track  Adds audio to a movie.

MIDI track  Adds MIDI to a movie.

Instrument track  Plays a note or sound when an event occurs in the movie.
Streaming track  Adds streaming video and audio to a movie.

Folder track  Organizes other tracks into groups.

Default layout tracks
When you first create a new movie, GoLive automatically adds a default layout track to the movie. Though it isn't visible in the Timeline Editor, this layout track specifies the size and background color for the movie. (If GoLive didn't add a layout track, the movie would have a size of zero width and height.) The default layout track uses the size and background color you specify in the New QuickTime Movie dialog box.

To add or remove tracks
You add content to a movie by adding tracks.

1  In the Timeline Editor, do one of the following:
- To make the track start at the beginning of the movie, drag the time cursor to the leftmost position in the track content area (0 seconds on the time ruler).
- To set the track to start anytime after the movie begins (such as after another track ends), drag the time cursor to the time when you want the track to start.

2  Drag one of the Track icons from the QuickTime set of the objects toolbox to the track list area of the Timeline Editor. You can also drag a Track icon to the track content area.

3  Name the track by typing a name in the Title box in the Basic tab in the Inspector. Or, double-click the track name in the track list and type a name in the box.

4  Set options and properties in the Inspector for the track you inserted.

5  To remove a track, select it, and press Delete.

Note: To add a layout track to a flattened movie, choose Movie > Add Layout Track.
To remove the default layout track

After you add tracks that contain visible content to the movie (such as video tracks), you can delete the default layout track. The movie then resizes to the resulting boundary of the tracks you added.

❖ Choose Movie > Remove Layout Track.

*Note:* To change the size or background color of a flattened movie created outside of GoLive, you first need to add a layout track to the movie.

To set the layering order of tracks

Tracks are arranged in layers. The bottom track in the Timeline Editor is layer 1. Layer 1 covers any other tracks positioned at the same time. For example, in a movie with two layers, layer 2 is covered by layer 1.

❖ Do any of the following:

- To specify the layering order of tracks in the Timeline Editor, drag the tracks up and down in the track list area.
- To place a track closer to the viewer (covering other tracks), drag the track toward the bottom of the list.
- When adding a track, drag the track's icon from the objects toolbox directly to the position you want in the track list.
- Click the Bring To Front or Send To Back button, or choose Movie > Track > [command].

To lock or unlock tracks

You can lock a track to prevent making changes to it, or unlock it to make changes. When you select a locked track, the track's handles appear dimmed in the Layout tab and "locked" appears after the track name in the Timeline Editor.

1 Select the track in the Timeline Editor.
2 Click the Lock icon to the left of the track.

To copy and paste tracks between movies

1 In the track list in the Timeline Editor, or in the Layout tab in the movie viewer window, select the tracks that you want to copy, and then choose Edit > Copy.

2 In the Timeline Editor for the movie into which you want to paste the track, choose Edit > Paste. The new track appears in the Timeline Editor.

3 (Optional) In the track Inspector, type a name in the Title box, or double-click the track name in the track list. Set track properties.

❖ You can also export individual tracks to a movie file for use in other movies or as a standalone movie.
To align the timing of tracks and samples
❖ Select multiple tracks or samples and click one of the following buttons in either the Multiple Track Inspector or Multiple Sample Inspector:

**Align To Tracks'/Samples' Most Left Start Time** Aligns the selected tracks or samples to the start time of the leftmost item. If you don't select the Adjust Track/Sample Duration option before clicking this button, GoLive aligns the items without changing their durations.

**Align To Tracks'/Samples' Most Right End Time** Aligns the selected tracks or samples to the end time of the rightmost item. If you don't select the Adjust Track/Sample Duration option before clicking this button, GoLive aligns the items without changing their durations.

**Adjust Track/Sample Duration** Specifies that the durations of the items change, instead of their start or end times. For items you align to leftmost start time, GoLive changes the durations instead of changing the end times. For items you align to rightmost end time, GoLive changes the durations instead of changing the start times.

**Leap To Base Track's Start Time** Aligns the end times of selected tracks to the base track's start time. Choose the base track from the Base Track menu in the Multiple Track Inspector. Note that there must be enough time before the base track to fit the other selected tracks. For example, if the base track begins at a movie's two-second mark, only tracks with durations of two seconds or less can fit before the base track.

**Leap To Base Track's End Time** Aligns the start times of selected tracks to the base track's end time. Choose the base track from the Base Track menu in the Multiple Track Inspector.

To set the basic track and sample properties
❖ Add or select a track or sample, and then set the appropriate properties in the Basic tab of the track or sample Inspector.

Each track and sample has a corresponding Inspector, which lets you set properties, select filter effects, create sprite actions, and control layout parameters.

**Track and sample properties**
Most of these basic properties are available for video tracks and other visible tracks such as sprites, 3D, text, and SWF files.

Set the following properties for tracks and samples in the Basic tab of the track or sample's Inspector:

**Title** Specifies a name for the track.

**Start Time and Duration** Specifies the beginning time and the length of time the track will run.

**Scale Sample Time** Proportionally changes the duration of tracks containing samples (sprites, text, chapter, HREF, and filters) when you change the duration in the track Inspector (or if you Shift-drag the track bar's end). Deselect this option to lengthen only the last sample to the end of the track bar. This option also works for folder tracks, which contain other tracks.

*Note:* If you use this option with a sprite track containing samples (for example, frame actions) that occur at specific times in a movie, the samples move. If you don’t want the timing of the samples to change, avoid this option.

**Position** Specifies the selected track's horizontal and vertical position. For example, you can place two tracks next to each other by using different positions for each track.

**Size** Specifies the vertical and horizontal dimensions of the selected track. Whenever you adjust dimensions, QuickTime uses a scaling factor to scale the track's size.
**Normalize Track/ Set Track Dimension** Displays a menu that lists the Normalize Track and Set Track Dimension commands. If you changed the dimensions of the selected track, you can use Normalize Track to reset the track to its original size and position. Or, you can use Set Track Dimension to change the track's original size and position to the current dimensions and position.

**Constrain Proportion** Resizes the video track proportionally. For example, when you edit the value in the width box, the height is adjusted to maintain the original aspect ratio of the track, and vice versa.

**Mode** Specifies how a video track overlays other tracks in the movie:

- **Dither Copy (default mode)** Overlays the image on a track directly below it and applies dithering for a more refined look. There is no interaction between a track in Dither Copy mode and tracks below it.

- **Copy** Same as Dither Copy, with one exception: Copy lacks the dithering capability, which makes it less suitable for display on systems in 256-color mode. However, the Copy option may provide better performance in low memory situations.

- **Blend** Makes the track transparent so you can see partially through it to the track below. You can set the degree and color of the transparency by clicking the color field next to the Mode menu to display the Color palette. Drag a color from the preview pane of the Color palette to the Mode color field. The lighter the color, the more opaque the track is; the darker the color, the more transparent it is.

- **Transparent** Lets you define a transparent color for any visual track. Click the color field and drag a color from the preview pane of the Color palette to the color field.

*Note: The Mode menu is not available for movie tracks, and the Type menu on the Basic tab is only available for movie tracks.*

The next four modes determine how alpha channel content appears. An alpha channel defines how an image is combined with a background image already present at the location where the image appears. By defining an alpha channel, you specify which part of a visible image is left out, or masked, to make a background image appear in that area.

- **Straight alpha** Combines the color components of each pixel with the background pixel at the same location based on the value contained in the alpha channel.

- **Premul white alpha** Supports images created on a white background with a premultiplied alpha channel.

- **Premul black alpha** Supports images created on a black background with a premultiplied alpha channel.

- **Straight alpha blend** Is a combination of straight alpha and blend, so the masked areas are transparent and the nontransparent areas are translucent. As with the Blend mode, you can use the Color palette to edit the degree of translucency.

- **Composition (Dither Copy)** Is similar to Copy and Dither Copy, but more appropriate for video tracks created from animated GIF files.

*Note: The Basic tab in the Color Track Inspector also contains a color field below the Mode menu where you can select a fill color for the color track.*

**See also**

“About movie tracks” on page 538

“About color tracks” on page 541
### Animating tracks

#### Animating tracks with keyframes

You can animate tracks by using keyframes in the Timeline Editor. For tracks with visual content, you can animate position, scale, skew, rotation, spin, and blending mode. For tracks with sound and MIDI content, you can animate volume and speaker balance.

GoLive animates tracks by interpolating transition frames between keyframes. If you add two Position keyframes with different pixel coordinates, for example, GoLive interpolates transition frames that make the track appear to move from one position to the next.

#### Working with keyframes in the Timeline Editor

- **Stopwatch**
- **Navigate between keyframes.**
- **Value at time**
- **Default keyframe**
- **Additional keyframes**
- **Selected keyframe**

To show keyframe properties

Before you can animate a track, you must first show and enable keyframe properties, such as Position and Scale.

- In the Timeline Editor, click the pop-up menu to the left of the track name. (By default, GoLive hides keyframes to conserve space.)

**Note:** When you enable a track for animation, its size and position are reset to the default. Therefore, you should enable the track for animation before you transform it.

#### To enable a keyframe property and add initial keyframes

1. In the Timeline Editor, show keyframes for the track.
2. Click the stopwatch for the property.

When you enable a property, GoLive adds two initial keyframes: one at the beginning of the track’s time bar, and a second at the location of the current-time indicator.

#### To add or delete a keyframe for a property

1. In the Timeline Editor, move the current-time indicator to the desired location.
2. To add a keyframe, do either of the following:
   - Click the Keyframe Navigator box for the property.
   - Edit the property settings in the Timeline Editor.
3. To delete a keyframe, select the keyframe and press Delete.

**Note:** Animation requires at least two keyframes.
To navigate through keyframes
❖ To quickly evaluate each keyframe for a property, locate the Keyframe Navigator for the property, and click the Forward or Backward button.

To move a keyframe
You can move existing keyframes to vary the speed of animation changes.
❖ Drag the keyframe to a new timeline position.

Note: When you drag a track time bar to a new timeline position, GoLive moves all keyframes on the track and maintains their temporal relationships.

To change property settings
• To animate a property, specify different property settings for each keyframe.
• To quickly specify a property setting, drag the underlined value into the Timeline Editor.
• To specify a more precise setting, click the underlined value, and then enter a new value in the text boxes in either the Timeline Editor or the Inspector.

Drag the value in the Timeline Editor, or click the value and enter precise values in the box that appears or in the Animation Point Inspector.

• To change volume and balance settings, drag keyframes up or down in the timeline.
Drag an audio keyframe up or down in the Timeline Editor to set the volume and balance.

**Property settings**
For tracks with visual content, you can specify the following property settings:

**Position** Specifies pixel coordinates on the x and y axes.

**Scale** Specifies percentage on the x and y axes.

**Skew** Specifies angle on the x and y axes.

**Rotation** Specifies the rotation in degrees.

**Spin** Defines the number of rotations between keyframes and an initial rotation.

**Mode** Specifies blending mode and color, which are available only in the Inspector.

For tracks with sound or MIDI content, you can specify the following property settings:

**Volume** Specifies a number between 0 and 255.

**Balance** Specifies a number between -128 (full left) and 128 (full right).

**See also**
“To set the basic track and sample properties” on page 534

**Movie tracks**

**About movie tracks**
A movie track lets you embed a digital video file (or any other file supported by QuickTime) that resides anywhere on the web by referencing the file's URL. Movie track options let you control the way the embedded file displays and behaves within the root movie. A root movie is the top-level movie that contains all other tracks. If the movie track contains other movie tracks, the root movie is at the top level of the hierarchy of nested movies.

**Note:** The file you embed in a movie track does not become a part of the root movie when the movie is flattened. The embedded file must reside at the referenced URL in order for the root movie to display it.
You add a movie track to your movie by dragging a Movie Track icon from the QuickTime set of the objects toolbox to the track list area of the Timeline Editor. After you add the movie track, specify the URL for the embedded file in the URL tab of the Movie Track Inspector. You can then set additional options in the Movie Track Inspector.

**See also**

“‘To add or remove tracks’ on page 532

“‘To set the basic track and sample properties’ on page 534

**Type menu options for movie tracks**

Use the Type menu options in the Basic tab of the Movie Track Inspector to specify how the embedded file is displayed within the root movie:

- **None** Displays the embedded file (without any changes) over the tracks below it.
- **Scroll Movie** Scrolls the embedded file if the file's contents exceed the dimensions of its movie track.

**Note:** QuickTime 6 does not support the Scroll Movie feature. (See the Apple QuickTime website for more information.) Until QuickTime supports the Scroll Movie feature, a movie track in a QuickTime movie won't have scroll bars, and the Scroll Movie option results in the same behavior as the Clip Movie option.

- **Clip Movie** Does not display any areas of the embedded file that exceed the dimensions of the movie track.
- **Fill Movie** Reduces or enlarges the embedded file to fill the dimensions of the movie track, but does not maintain the aspect ratio of the file. As a result, the movie may appear stretched. GoLive scales the embedded file to completely fill the track boundaries without changing the track dimensions.
- **Meet Movie** Reduces or enlarges the embedded file to be entirely visible in the movie track while maintaining the aspect ratio of the file.
- **Slice Movie** Reduces or enlarges the embedded file's dimensions proportionally so that the smaller dimension is completely visible. As a result, the larger dimension may be clipped.

**URL options for movie tracks**

In the URL tab of the Movie Track Inspector, you can select the following options:

- **Link** Specifies the URL of the embedded file.
- **Resize Track Box** Resizes the movie track to the dimensions of the embedded file. If this option is deselected, GoLive scales the embedded file to the dimensions of the movie track that you set in the Basic tab of the Movie Track Inspector.
- **Get Movie Properties** Click the Get Movie Properties button to make GoLive use the movie track’s URL to obtain attributes of the movie, including dimensions and duration.
- **Timeout** Choose a duration from the Timeout menu to specify when you want GoLive to stop attempting to connect to a server. This setting applies only when you are working in GoLive, not when viewing the movie in a browser.
More options for movie tracks

In the More tab of the Movie Track Inspector, you can select the following options:

**Slave Time**  Restricts the embedded file from playing until the root movie time reaches the file’s start time. The timeline of the root movie controls the embedded file—it plays like any other nonmovie track. If the embedded file is longer in duration than its movie track duration, this option also stops the movie when the end of the movie track duration bar is reached.

**Autoplay**  Sets the movie track to play immediately whenever a web browser loads the embedded file, even if the root movie is not playing.

**Slave Audio**  Ignores any audio in the embedded file and uses the root movie’s audio instead.

**Frame Stepping**  Specifies whether or not the embedded movie is affected by frame step operations, such as when the viewer uses the QuickTime controller to move the movie forward or backward.

**Slave Graphics Mode**  Ignores the graphics mode of the embedded file and uses the root movie’s graphics mode instead.

**Slave Track Duration**  Sets the movie track’s duration to the full length of the embedded file.

**Loop**  Specifies how the embedded video file plays back. Choose None to play the complete video file once and then stop. Choose Loop to play the complete video file from beginning to end repeatedly if Autoplay is selected and Slave Time is not selected. Choose Palindrome to play the complete video file forward and then backward repeatedly.

**Background Color**  Sets the background color displayed in the movie track area while the embedded file is downloading, or if the embedded file fails to load.

**Enable Clipping Time**  Specifies a portion of the embedded file that you want to play. Enter a start time in the Clip Start Time box, and then enter a duration in the Clip Duration box.

To wire a movie track with actions

In the Actions tab of the Movie Track Inspector, you can set one or more actions that are triggered after the embedded movie file has finished loading. For example, you can use the Track Set Enabled action to display a text track in the root movie, such as “Ready to play,” after the embedded movie has loaded.

1. Select the movie track in the Timeline Editor, and then display the Actions tab of the Movie Track Inspector.

2. In the Actions tab, select the Movie Loaded event in the Events list box, and then click the New Action button below the Actions list box. A dot symbol (“•”) appears to the right of the Movie Loaded event to indicate the event is active.

3. From the pop-up menu below the Events and Actions lists, choose an action, such as GoToURL, and then set its properties as necessary below the pop-up menu.

4. Click Apply. You can wire the movie track with additional actions.

See also

“Actions for setting movie properties” on page 566

“Actions for setting track properties” on page 567
About video tracks
A video track consists of a number of sequential pixel images that play back at a certain speed (called the frame rate and expressed in frames per second) to give the viewer the visual impression of motion.

You add a video track to your movie by dragging a Video Track icon from the QuickTime set of the objects toolbox to the track list area of the Timeline Editor. When you select a file for the Video Track icon, you can choose either of the following:

A video track from another movie If the movie contains more than one video track, GoLive adds the first video track only (or other visible track) in the movie. The first track of a movie file is positioned at the top of the track list in the Timeline Editor. However, don’t confuse the first video track with the topmost layer (called Layer 1) in the movie, which is placed at the bottom of the track list.

An animated GIF file GoLive automatically converts the file to a video track, which you can then play faster or slower by setting the track duration in the Video Track Inspector.

See also
“To add or remove tracks” on page 532
“To set the basic track and sample properties” on page 534

About color tracks
A color track adds a layer of color to the movie window. You add a color track to your movie by dragging a Color Track icon from the QuickTime set of the objects toolbox to the track list area of the Timeline Editor.

A new color track is opaque, by default, and has the same dimensions as the current dimensions of the movie window. To change the fill color of the color track, use the color field in the Basic tab of the Color Track Inspector. To change how the color track overlays other tracks, use the Mode menu in the Basic tab of the Color Track Inspector.

See also
“To add or remove tracks” on page 532
“To set the basic track and sample properties” on page 534

Picture tracks

Picture tracks
When you want to present a slide show or a series of still images as part of a QuickTime movie, use the picture track. You can set the amount of time each picture is displayed, and you can select special effects, such as Dissolve, for the transitions between pictures. You can also set the number of times you want the images to be repeated in a loop.

To add a picture track to a movie
❖ Drag a Picture Track icon from the QuickTime set of the objects toolbox to the track list area of the Timeline Editor.
See also

“To add or remove tracks” on page 532

Setting picture properties and importing picture track images
After you add the picture track, you set picture properties, and then import your picture images. Each image you import becomes a picture sample. When you first add the picture track, GoLive automatically creates the first picture sample as a default image that contains a simple white color and has a duration equivalent to the movie’s duration. You can either keep or edit the default picture sample at the beginning of your slide show, or delete it after importing your own images.

To set picture properties and import images into a picture track
1 Select the picture track in the Timeline Editor, and then display the Slideshow tab of the Picture Track Inspector.
2 In the Slideshow tab, set the following options before importing the images:
   - **Slideshow Time Interval**: Sets the duration of time that each image is displayed in the slide show. This option only affects the new images you insert after you set this option.
   - **Loop**: Specifies the number of times the sequence of images loops.
   - **Use Transition Effect**: Adds a visual transition between one image and the next. Click Select to select a transition effect, and then set effect options.
   - **Duration**: Set the duration of time for the selected transition effect by dragging the Duration slider or by entering a time in the Duration box.
3 In the Images tab of the Picture Track Inspector, set the following options, if necessary:
   - **Images Constrain Proportion**: Scales an image to the track’s dimensions while preserving its aspect ratio.
   - **Background Color**: Sets the background color for the imported images.
4 In the Timeline Editor, position the time cursor in the picture track where you want to insert the images. For example, if you want to insert the images after the last picture sample, position the time cursor after the end time of the last picture sample.
   - **Note**: To avoid changing the duration of an existing picture sample, position the time cursor before the start time or after the end time of the existing picture sample.
5 In the Images tab of the Picture Track Inspector, select the Insert Images option.
6 Click the Import button, navigate to the folder containing the images, and select the images in the order you want them added as picture samples in the picture track and displayed in the slide show.
7 Click Add or Add All to add the images to the list, and then click Done.
8 In the Compression Settings dialog box, select an image compressor and a color depth from the pop-up menus.
9 To change the quality of the compression, drag the Quality slider. The preview area to the right shows how the settings affect the image.
10 Click OK.

See also

“Compression options” on page 543
To replace multiple images in a picture track
1 Select the picture track in the Timeline Editor, and then display the Slideshow tab of the Picture Track Inspector.
2 In the Slideshow tab, change options, if necessary, before importing the images. For example, to change the durations of the new images only, set the Slideshow Time Interval.
3 In the Timeline Editor, position the time cursor at the start time of the first image you want to replace. GoLive replaces images beginning with the first one following the time cursor.
4 In the Images tab of the Picture Track Inspector, select the Replace Images option. Then click the Import button, navigate to the folder containing the images, and then select the images in the order you want them to replace the existing images.

The number of images you select determines the number that are replaced. For example, if you select four images, then the following four images are replaced. If there are only three existing images following the time cursor, then GoLive creates a new picture sample for the fourth image. If there are 10 existing images following the time cursor, then GoLive adds four new images after the time cursor and deletes the remaining six images.
5 Click Add or Add All to add the images to the list, and then click Done.
6 In the Compression Settings dialog box, select an image compressor and a color depth from the pop-up menus, and then click OK.

To replace an image in a picture sample or set individual picture sample properties
1 In the Timeline Editor, select the picture sample that contains the image you want to replace.
2 In the Picture Sample Inspector, change properties if necessary, and then click Replace. Navigate to the folder containing the replacement image, select the image, and then click Open.
3 In the Compression Settings dialog box, select an image compressor and a color depth from the pop-up menus, and then click OK.

Compression options
QuickTime comes with numerous built-in image compressors that cover most of the media formats used on the Internet. Your choice of compressor should depend on the type of image and movie file-size limitations. If the default compressor, JPEG, is unsatisfactory, experiment with other compressors to find the format that best suits your needs.

The options available for color depth depend on the compressor you choose. As you drag the Quality slider between the Least and Best labels, a numerical value from 0 to 100 appears on the slider. Image quality and degree of compression are inversely proportional: the higher you set the quality, the lower the compression ratio is.

Sprite tracks

Sprite tracks
A sprite track lets you apply actions and set individual mouse states to the track's image objects, called sprites. Sprites let you give viewers an interactive experience through objects that affect a behavior, such as jumping to a different web page. You can also animate sprites as you would tracks.
Like a video track, a sprite track consists of a sequence of frames that play back at a certain frame rate. Unlike a video track, which is a continuous stream of pixel images, a sprite track relies on a pool of images that are stored with its first keyframe. The advantage of a sprite track is that subsequent frames need not contain the pixel image itself, but simply a reference to an item in the image pool. As a result, this type of movie is much smaller in file size than pixel-based video, thus making animations load faster.

**To create sprites**

1. Add the sprite track and set sprite track properties.
2. Import images into an image pool to make them available to you when you are adding individual sprites.
3. Set behaviors and actions on the sprites.

**To add sprite tracks and set sprite track properties**

1. Drag a Sprite Track icon from the QuickTime set of the objects toolbox into the track list area of the Timeline Editor.
2. Set the following sprite track properties, in the Sprites tab of the Sprite Track Inspector:
   - **Visible** Displays the sprite track in the movie viewer window. By deselecting this option, you can temporarily hide the sprite track to view tracks under it. Unlike the Show/Hide option in the Timeline Editor, this option doesn't affect the movie's boundaries.
   - **Scale Sprites When Track Is Resized** Ensures that your sprites scale smoothly if you resize the sprite track. Select this option if your sprites contain vector graphics. If this option is not selected, sprites with vector graphics may look jagged after resizing.
   - **Background Color** Specifies a background color. The default background color is black. To select a color, click the color field, and then drag a color from the preview pane of the Color palette to the color field in the Sprite Track Inspector.
   - **Idle Frequency** Specifies the frequency at which idle events are sent to sprites in increments of 1/60th of a second.
   - **Add New Sprites** Specifies the number of sprites you want to add. GoLive assigns the first image listed in your image pool to each sprite you add with this option, which is a default image until you import your own images into the sprite track image pool.

**See also**

- “To add or remove tracks” on page 532
- “To set the basic track and sample properties” on page 534

**Importing images and adding sprites**

Before you can use images as sprites, you must first import them into the image pool. You can use images with the following formats: BMP, GIF, JPEG/JFIF, JPEG2000, MacPaint, Adobe Photoshop, PICT, PNG, QuickDraw GX (Mac OS only, requires the QuickDraw GX extension), QuickTime Image Format, SGI, Targa, and TIFF.

When you first add a sprite track, GoLive automatically adds a default sprite object (called Sprite) and assigns it a default image (called Untitled Image 1) that contains a white color. You can either keep the default sprite object and default image, or delete them after adding your own sprite objects and importing your own images.

You can also import a Photoshop file and automatically create a sprite for each layer in the file at the same time.
See also
“Importing Photoshop layers as sprites” on page 548

To import images into the sprite track image pool
1 Select the sprite track in the track list, and then display the Images tab of the Sprite Track Inspector.
2 If you are importing a Photoshop file and you want to import each layer as an individual image, select Import Multiple Layers. If this option is not selected, GoLive imports all of the layers as one composite image.
Note: Although the Images tab lets you import a Photoshop file and use the imported images with sprites, it doesn’t automatically create sprites and set rollover behavior based on layer names. To do so, use the Sprites tab to import the Photoshop file.
3 Click Import, navigate to the folder containing the images, and then select the images. Click Add or Add All to add the images to the list, and then click Done.
4 In the Compression Settings dialog box, select an image compressor and a color depth from the pop-up menus, and then click OK.
GoLive lists the images in the Images tab of the Sprite Track Inspector. You can select an image name and view the properties, and you can rename each image in the Name box.

See also
“Importing Photoshop layers as sprites” on page 548
“Compression options” on page 543

To add sprites to a sprite track and use images from the image pool
1 Select the sprite track in the track list, and then click the arrow to the left of the track name to expand the track if the sprite objects below the track are not already displayed.
2 In the Add New Sprites box, enter the number of sprites you want to add.
After you press the Enter key or click outside the Sprites tab, GoLive adds the number of sprite images you specified in subtracks below the sprite track, and assigns each sprite a name (Sprite 2, Sprite 3, and so on) and a keyframe. GoLive also assigns the first image listed in your image pool to each sprite you add, which is the default Untitled Image 1 unless you delete it. You can now assign an image from your own image pool.
3 To name a sprite, select it and then enter a name in the Title box in the Sprite Object Inspector. Or, you can double-click the sprite object name in the track list and enter a new name in the text box.

See also
“Setting sprite appearance and behaviors” on page 546

To delete images from the image pool
1 Select the sprite track in the track list and display the Images tab of the Sprite Track Inspector.
2 Select the image in the list box you want to delete.
Note: You can’t delete an image if it’s assigned to a sprite or referenced in an action.
3 Click Delete, and then click Yes.
Setting sprite appearance and behaviors

After you add a sprite, you're ready to set its appearance and behavior. You set its appearance by specifying whether the sprite is visible or invisible in the movie, and how the sprite overlays or interacts with other sprites in the movie. From the image pool, you also select images that you want displayed when the movie runs, and when the viewer moves the mouse pointer over the sprite or clicks inside or outside the sprite.

The list of images and actions for a sprite are stored in its keyframes, which take effect at a specific time. For example, you can create three keyframes for a sprite at different time points, each of which is assigned a different image. As the movie plays, the three images change at the time points where you created the keyframes. In addition, you can assign different actions to the keyframes to have the actions execute at different times.

When you first add a sprite track, GoLive automatically creates a default keyframe for the default sprite object (which cannot be deleted). You can keep the default keyframe as it is if you want. But, in most cases you'll want to use it as a starting point and change its appearance and behavior, assigning your own images instead of using the default Untitled Image 1.

To set sprite appearance and behavior

1. Select the keyframe that you want to set. If you need to create a new keyframe, use the Create Sample tool to place the new keyframe in the desired location on the sprite track.
2. In the Layout tab, right-click (Windows) or Ctrl-click (Mac OS) the sprite, and choose Show Sample Inspector.
3. In the Basic tab of the Sprite Sample Inspector, set either of the following options to set the appearance of the selected keyframe for the sprite:
   - **Visible** Makes the sprite visible in a QuickTime movie.
   - **Mode** Specifies how the sprite overlays other sprites in the movie.

See also

“‘To wire a sprite with action’ on page 547

**To set sprite appearance and behavior**

1. Select the keyframe that you want to set. If you need to create a new keyframe, use the Create Sample tool to place the new keyframe in the desired location on the sprite track.
2. In the Layout tab, right-click (Windows) or Ctrl-click (Mac OS) the sprite, and choose Show Sample Inspector.
3. In the Basic tab of the Sprite Sample Inspector, set either of the following options to set the appearance of the selected keyframe for the sprite:
   - **Visible** Makes the sprite visible in a QuickTime movie.
   - **Mode** Specifies how the sprite overlays other sprites in the movie.

See also

“‘To wire a sprite with action’ on page 547
4 With the Main behavior box selected, assign an image to the keyframe for the sprite by selecting an image from the Image menu. After you select the image, its thumbnail appears in the Main behavior box. QuickTime displays the image assigned to the Main behavior box when the movie with the sprite begins running.

5 To assign other images to other behaviors, select one of the following behavior boxes, and then select an image from the Image menu:

**Over** Reveals the image assigned to it when a viewer passes the pointer over the image assigned to Main. In other words, the Main image rolls over into the Over image.

**Click Inside** Reveals the image assigned to it when a viewer holds down the mouse button.

**Click Outside** Reveals the image assigned to it after a viewer clicks inside the sprite, and then drags outside the sprite.

6 To change the mouse cursor when the viewer passes over the sprite, select a behavior box, and then select an option from the Cursor menu.

7 In the Status box, enter any information about the sprite that you want to display in the web browser window’s status bar when the movie runs.

See also

“To set the basic track and sample properties” on page 534

“Samples” on page 529

**To wire a sprite with action**

You can add wired actions to a sprite by attaching actions to keyframes. For example, by attaching the Go To URL action to the Mouse Click Event for a sprite’s keyframe, you can have a web page open when the viewer clicks the sprite.

1 Select the sprite, and then select the keyframe that you want to attach an action to. If you need to create a new keyframe, use the Create Sample tool to place the new keyframe in the desired location on the sprite track. (See “Samples” on page 529.)

2 Display the Actions tab of the Sprite Sample Inspector. From the Events list, select one of the following mouse events that you want to trigger a sprite action:

**Mouse Down** Triggers an action when the viewer presses the mouse button down (without releasing it) while the pointer is on top of the sprite.

**Mouse Up** Triggers an action when the viewer releases the mouse button while the pointer is on top of the sprite.

**Mouse Click** Triggers an action when the viewer clicks the sprite.

**Mouse Enter** Triggers an action when the viewer moves the mouse pointer over the sprite.

**Mouse Exit** Triggers an action when the viewer moves the mouse pointer away from the sprite.

3 Click the New Item button to attach an action to the event. A dot symbol (•) appears to the right of each event that is active.

4 From the pop-up menu below the Events and Actions lists, choose an action, such as GoToURL, and then set its properties, as necessary, below the pop-up menu. For more information on the actions in the pop-up menu, see “Actions for setting movie properties” on page 566.

5 Click Apply.
You can wire the sprite with additional events and actions. For example, you can combine any of the mouse-click events with one of the two mouse-over events to make the sprite respond not only when the viewer clicks the sprite, but also when the viewer moves the mouse pointer over it.

Using Photoshop images as sprites

Importing Photoshop layers as sprites
Using the Sprites tab of the Sprite Track Inspector, you can import a Photoshop file and automatically create a sprite for each layer in the file. With this method, you can design and lay out sprites in Photoshop (including mouse-over images, and so on), and then quickly import the images into a QuickTime movie. It’s easy to design a great looking interface in Photoshop with all the behavior in the image, and then bring it to life automatically in GoLive without the need to reposition all of the images or assign the behavior to the images manually. By setting up the layer names in advance in Photoshop, you can also automatically assign different rollover behaviors to each sprite at the same time you import the Photoshop file.

You can also use Photoshop as a prototype tool to create the initial appearance of images, and then import the images into GoLive and set up the interactive actions. When you’re ready, you can use Photoshop again to create the final artwork, and then replace the images assigned to the sprites without losing the sprites’ interactive actions or any other work you’ve done in GoLive to create the movie.

Setting up images and layer names in Photoshop for rollover behavior
In Adobe Photoshop, create and lay out the background and sprite images exactly as you want them to appear in the movie. For example, suppose you want to create a movie that displays a television with four buttons for selecting channels. Suppose also that you want to assign rollover behavior to the buttons to have them change appearance when the viewer moves the mouse pointer over them. In the Photoshop file, first create a background image that shows a television. Then add four buttons, each on a different layer, that have the default appearance you want to display when a mouse pointer is not positioned over them. Next, add four alternate button images, each on a different layer, that you want to display when a viewer places a mouse pointer over them. Position these alternate buttons in the exact same locations as the main buttons.

To set up rollover behavior, name each button layer with a meaningful prefix, an underscore, and then an extension that indicates the rollover behavior for that image. For example, the layers containing the main button images might be named channel1_main, channel2_main, and so on. The alternate button images for the mouse-over behaviors might be named channel1_over, channel2_over, and so on. When you set up options in the Sprites tab before importing, you specify the main extension to map the "_main" button layers to the Main behavior box for sprites, and you specify over to map the alternate button layers to the Over behavior box for the same sprites.

Note: You can use any name for the background layer. GoLive can determine the background layer automatically if you choose to import it.
To import a Photoshop file and automatically create sprites

1 Select the sprite track in the track list in the Timeline Editor.

2 Display the Sprites tab of the Sprite Track Inspector and do any of the following:
   • To import the background layer from the Photoshop file and create a sprite that displays the background, select Import Background Layer.
   • To resize the sprite track to the dimensions of the imported images, select Resize Sprite Track. If the Resize Sprite Track option is not selected, GoLive does not resize the sprite track and clips any images that are larger than the sprite track.
   • To map layers in the Photoshop file as the main image for each new sprite, enter the appropriate extension in the Main box. For example, if the main button images are on layers named channel1_main, channel2_main, and so on, enter main as the extension in the Main box. After importing, GoLive assigns the images from the main layers to the Main behavior box in the Basics tab in the Sprite Sample Inspector for each sprite.
   • To map layers in the Photoshop file to the Over behavior box in the Basics tab in the Sprite Sample Inspector for each sprite, enter the appropriate extension in the Over behavior box. For example, if the alternate button images are on layers named channel1_over, channel2_over, and so on, enter _over as the extension in the Over behavior box.
   • To map layers in the Photoshop file to the Click behavior box in the Basics tab in the Sprite Sample Inspector for each sprite, enter the appropriate extension in the Click box. For example, for channel1_click, channel2_click, and so on, enter _click as the extension in the Click behavior box.

3 Click Import, and then navigate to the folder containing the Photoshop file. Select the Photoshop file, and then click Open.

4 In the Compression Settings dialog box, select an image compressor and a color depth from the pop-up menus, and then click OK.

GoLive adds the layers as individual images in the Images tab of the Sprite Track Inspector, adds a sprite for the background image (if you chose to import it), and adds a sprite for each combination of main, over, and click layers. To view or change the properties for each sprite, such as selecting a cursor for an Over image, use the Basic tab in the Sprite Sample Inspector.

See also
“Setting sprite appearance and behaviors” on page 546
“Compression options” on page 543

To replace the images from a Photoshop file and automatically update sprites

1 Make sure that the layer names have not changed in the Photoshop file.

2 Select the sprite track in the track list in the Timeline Editor.

3 Display the Sprites tab of the Sprite Track Inspector, and click Replace.

4 Navigate to the folder containing the Photoshop file, select the Photoshop file, and then click Open.

5 In the Compression Settings dialog box, select an image compressor and a color depth from the pop-up menus, and then click OK. GoLive replaces the images for each sprite.
SWF tracks

SWF tracks
After you create SWF files in an SWF-authoring application and set the correct frame rate, you can use GoLive to integrate SWF tracks into QuickTime movies. With an SWF track, you can use GoLive to attach wired actions to SWF buttons and jump directly to predefined SWF labels at specific points in time. For example, if you have an SWF navigation bar with animated menus, rollovers, and event sounds, you can use the bar with QuickTime actions to control the QuickTime movie. (See the documentation for your SWF-authoring application for details on setting SWF buttons, actions, labels, and frame rates.)

When you add an SWF track to a QuickTime movie, QuickTime matches the SWF time base with the QuickTime time base. For example, if an SWF file has an internal speed of 15 frames per second (fps) and a duration of one minute, the corresponding SWF track also has a duration of one minute.

To add an SWF track
1 Drag an SWF Track icon from the QuickTime set of the objects toolbox into the track list area of the Timeline Editor.
2 (Optional) Set basic properties, jump to SWF labels, and wire actions to Macromedia® Flash™ buttons.

To jump to an SWF label
To jump to a label in an SWF track in GoLive, you must first insert the labels in your SWF file.
1 Select the SWF track in the Timeline Editor, and then display the Labels tab of the SWF Track Inspector.
2 From the Labels menu, choose the label you want to jump to.

See also
“To add or remove tracks” on page 532
“To set the basic track and sample properties” on page 534
To wire an SWF button with actions

1. Select the SWF track in the Timeline Editor, and then display the Actions tab of the SWF Track Inspector.

2. From the Button menu, choose the button you want to wire with actions. Any text you defined in the SWF for the button by using the FSCommand’s arguments appears below the Button menu.

3. From the Events list, select one of the following mouse events for the SWF button that you want to trigger an action:
   - **Mouse Down**: Triggers an action when the viewer presses the mouse button down (without releasing it) while the pointer is on top of the SWF button.
   - **Mouse Up**: Triggers an action when the viewer releases the mouse button while the pointer is on top of the SWF button.
   - **Mouse Click**: Triggers an action when the viewer does a single click on the SWF button.
   - **Mouse Enter**: Triggers an action when the viewer moves the mouse pointer over the SWF button.
   - **Mouse Exit**: Triggers an action when the viewer moves the mouse pointer away from the SWF button.

4. Click the New Item button to attach an action to the event. A dot symbol (“•”) appears to the right of each active event.

5. From the pop-up menu below the Events and Actions lists, choose an action, such as SWF Track Pan, and then set its properties as necessary below the pop-up menu.

6. Click Apply.

You can wire the SWF button with additional events and actions.

See also

“Actions for setting movie properties” on page 566

To define a text string for an SWF button

You can make it easier to identify buttons by defining a descriptive text string for each button, rather than having to rely on IDs. You define the text strings in the SWF file that describes each button.

❖ Insert an FSCommand with two arguments in the SWF file. For example:

```fscommand ("RootButtonScriptA","RootButton_frame1")
```

GoLive displays these two text strings in the Actions tab in the SWF Track Inspector as:

- **URL**: FSCeommand:RootButtonScriptA
- **Target**: RootButton_frame1

Streaming tracks

Streaming tracks

A streaming track lets a viewer begin viewing a movie on a web page (or within the QuickTime Player) almost immediately. GoLive lets you create streaming tracks that reference RTSP streaming movies on an RTSP streaming server.
**HTTP and RTSP streaming**

HTTP streaming is the standard way of viewing QuickTime movies stored on an HTTP server. The GoLive streaming track is for RTSP streaming movies only. GoLive also lets you export movies as RTSP streaming movies for use with the RTSP streaming servers.

**HTTP streaming (Hypertext Transfer Protocol)**  Makes it possible to put movie files on a web (HTTP) server as you do web pages and image files. Movies are downloaded in their entirety to the computer's hard disk where the QuickTime plug-in plays them. Because the movies are downloaded to the hard disk, viewers can replay the movies at any time, and a higher data rate (higher quality) is ensured. If you have sprite tracks or 3D tracks, these are visible to the viewers (whereas these tracks are not visible with RTSP streaming).

**RTSP streaming (Runtime Streaming Protocol)**  Requires a dedicated RTSP streaming server that sends out movie data on an as-needed basis. No file is stored on the viewer's computer. If the Internet is congested, thus preventing portions of the movie from arriving on time, RTSP ignores the fact that some data might be missing. However, because RTSP streaming works without files, it's possible to do live broadcasts, where all viewers see the same movie data at the same time. The advantage of RTSP streaming is that viewers don't have to store large movie files on their hard disks, as they do with HTTP streaming.

**See also**

“To export a movie or track” on page 576

**To add an RTSP streaming track**

The client movie, which is the movie you're creating for RTSP streaming, resides on an HTTP server and references a streaming movie on an RTSP server. The URL to the streaming movie is stored in the client movie's streaming track.

1 Drag a Streaming Track icon from the QuickTime set of the objects toolbox into the track list area of the Timeline Editor.

2 On the Basic tab of the Streaming Track Inspector, set the properties such as the position and size of the streaming track. (See “To set the basic track and sample properties” on page 534.)

3 In the RTSP tab of the Streaming Track Inspector, enter the URL for the streaming movie in the Link box.

4 Click the Get Streaming Properties button to open a connection to the RTSP URL, and then obtain important attributes about the streaming movie, such as dimensions and duration. (If the streaming content is a live broadcast, it has no specific duration.) You can cancel your connection in GoLive to the RTSP server by pressing any key.  

   *Use the Get Streaming Properties button to test the link to the streaming server.*

5 Choose a duration from the Timeout menu to specify when you want GoLive to stop attempting to connect to the streaming server. This setting applies only when you're working in GoLive, and does not apply to viewing the streaming movie in a web page.

**See also**

“To add or remove tracks” on page 532
3D and MPEG tracks

To add a 3D track
If you have QuickDraw 3D files, you can import them in a 3D track in Windows only. (Mac OS X does not support 3D tracks.)

1. Drag a 3D Track icon from the QuickTime set of the objects toolbox to the track list area of the Timeline Editor.
2. (Optional) Set basic properties.

See also
“To add or remove tracks” on page 532
“To set the basic track and sample properties” on page 534

To add an MPEG track
If you have MPEG-1 video files, you can import them into an MPEG track. The MPEG track is for adding MPEG video, not for MPEG audio (such as MP3). Use a sound track for MPEG audio.

1. Drag an MPEG Track icon from the QuickTime set of the objects toolbox to the track list area of the Timeline Editor.
2. (Optional) Set basic properties.

See also
“To add or remove tracks” on page 532
“To set the basic track and sample properties” on page 534

Sound, music, and instrument tracks

To add a sound or MIDI track
You can import sounds in various formats, including AIFF/AIFC, System 7 Sound, WAV, MP3 files, Sound Designer II, and standard MIDI files.

1. Do any of the following:
   • To add an audio file to your movie, drag a Sound Track icon from the QuickTime set of the objects toolbox to the track list area of the Timeline Editor.
   • To add a MIDI file, drag a MIDI icon from the QuickTime set of the objects toolbox to the track list area of the Timeline Editor.
2. Click the Play button in the Timeline Editor to listen to the track and see how it sounds with other tracks.

See also
“To add or remove tracks” on page 532
**Instrument tracks**

Use an instrument track to play a note when a movie track has loaded, or to play sounds when a particular event occurs. For example, you can have a sound play when the viewer clicks in a movie. GoLive obtains the instrument track sounds from a MIDI sound library that is installed with QuickTime.

The instrument track options define the synthesizer used to play the instrument, the instrument category, and the instrument played. You then play the instrument track by targeting it for a Music Play Note wired action that is attached to a track. The Music Play Note action options determine the pitch, volume, and duration of the note. You can attach the Music Play Note action to movie tracks, sprite samples, or text samples.

**See also**

“To add or remove tracks” on page 532

**To add and set up an instrument track**

1. Drag an Instrument Track icon from the QuickTime set of the objects toolbox to the track list area of the Timeline Editor.
2. In the Instruments tab of the Instrument Track Inspector, click Add to select a synthesizer, instrument category, and instrument.

You can add multiple instruments to a track, but a Music Play Note action only plays one of the selected instruments.

**To attach a Music Play Note action to a track or sample**

After setting up an instrument track with one or more instruments, you can use one of the instruments in a Music Play Note wired action for a movie track, sprite sample, or text sample.

1. Select the movie track, sprite sample, or text sample in the Timeline Editor, and then display the Actions tab of the Movie Track Inspector, the Actions tab of the Sprite Sample Inspector, or the Text tab of the Text Sample Inspector.
2. Select an event in the Events list box, and then click the New Action button below the Actions list box. A dot symbol (“•”) appears to the right of the event to indicate it is active.
3. From the pop-up menu below the Events and Actions lists, choose Music Play Note.
4. From the Target Movie menu, choose This Movie.
5. From the Track menu, choose Instrument Track. Change any of the remaining properties, such as volume, as necessary.
6. Click Apply.

**Folder and chapter tracks**

**To add and organize a folder track**

Folder tracks let you organize tracks into groups. For example, you can group together all video tracks, or group tracks that pertain to images (such as pictures or sprites).

1. Drag a Folder Track icon from the QuickTime set of the objects toolbox to the track list area of the Timeline Editor.
2. Set basic properties.
To organize tracks in folders, drag an existing track in the Timeline Editor, or a Track icon from the objects toolbox into the folder track.

Click the triangle next to the folder track to expand or collapse it and display the tracks within the folder track.

Select a track within the folder track to display its corresponding Inspector.

Add as many folders as necessary to organize all of your tracks.

See also
“To set the basic track and sample properties” on page 534
“To add or remove tracks” on page 532

Chapter tracks
Like the chapters of a book, a chapter track subdivides a movie into segments that deal with the same topic. A chapter track provides basic navigation support for QuickTime movies that lets viewers go to selected points in a movie quickly. When viewed in a web browser or the QuickTime Player, the QuickTime plug-in displays the chapter track as a menu in the standard QuickTime controller for the movie.

Note: The chapter track requires a movie to be at least 275 pixels wide in order to display the chapter menu.

To add a chapter track
1 Drag a Chapter Track icon from the QuickTime set of the objects toolbox to the track list area of the Timeline Editor.
2 Select the chapter track in the Timeline Editor, and then display the Chapter Track Inspector.
3 From the Act As Chapter Track For menu, choose any track to associate with the chapters.
4 Select the chapter track sample in the Timeline Editor to display the Chapter Track Sample Inspector.
5 In the Chapter box, enter a chapter title.
6 Add more chapters to the chapter track by using the Create Sample tool to create chapter samples. (See “To edit a sample” on page 530.)
7 Select each new chapter sample, and then enter a title in the Chapter Track Sample Inspector.
8 (Optional) Test your choices in the movie viewer window by choosing chapters from the chapter list on the controller. (You might have to resize the window to see the pop-up menu.)

Note: If you leave gaps in time between chapter samples, no chapter title displays during that section of the movie.

Text and HREF tracks

Text tracks
Text tracks display text, such as subtitles, within a movie. You can subdivide text tracks into segments, and then add messages to a movie to enhance the visual experience. You can link the text to a URL so that when viewers click the word or phrase, a web page opens. You can also add actions to the text link.
To add a text track and text to a movie

1. Drag a Text Track icon from the QuickTime set of the objects toolbox to the track list area of the Timeline Editor.
2. Select the text sample in the track content area of the Timeline Editor, and then display the Text tab of the Text Sample Inspector. (If necessary, expand the text track to display the text samples.)
3. In the large text box in the middle of the Text tab, type the text you want to display in the movie, and then click Apply.
4. To align the text in the movie, choose an alignment option from the Align menu.
5. To add text that appears at different times in the movie, use the Create Sample tool to create new text samples with different text content.

See also

“To edit a sample” on page 530

To add text links with actions

You can link the text in a movie to a web page, file, or any item that has a URL. You can also specify the mouse event that triggers the text link to activate. For example, you can specify that whenever a viewer clicks on a text link, a particular web page opens. You can have multiple text links in a movie.

1. In the Text tab of the Text Sample Inspector, select the text that you want to link to.
2. Click the Link icon. GoLive underlines the selected text and changes its color to blue.
3. From the Events list, select the mouse event that you want to trigger an action:
   - **Mouse Down** Triggers an action when the viewer presses the mouse button down (without releasing it) while the pointer is on top of the text link.
   - **Mouse Up** Triggers an action when the viewer releases the mouse button while the pointer is on top of the text link.
   - **Mouse Click** Triggers an action when the viewer clicks the text link.
   - **Mouse Enter** Triggers an action when the viewer moves the mouse pointer over the text link.
   - **Mouse Exit** Triggers an action when the viewer moves the mouse pointer away from the text link.
4. Click the New Item button to attach an action to the event. A dot symbol (“•”) appears to the right of the event to indicate that it is active.
5 From the pop-up menu below the Events and Actions lists, choose an action, and then set its properties as necessary below the pop-up menu. For more information on the actions in the pop-up menu, see “Actions for setting movie properties” on page 566.

6 Click Apply. You can wire the text link with additional events and actions.

7 To create other text links in the movie, enter the text in the text box and repeat the preceding steps to assign an action to the selected text.

**Text properties in the Text Sample Inspector**

After you select a text sample in the Timeline Editor, you can set the following text properties in the Properties tab of the Text Sample Inspector:

- **Don’t Display** Prevents the text from being displayed in the movie.
- **Don’t Auto Scale** Prevents the text from being scaled automatically.
- **Clip To Text Box** Changes the text box size and does not rewrap the text. Before you select this option, enter positive values (in pixels) in the Margin Width and Margin Height boxes in the Layout tab of the Text Sample Inspector.
- **Use Movie BG Color** Uses the movie background color to color the text.
- **Shrink Text Box** Shrinks the text to new dimensions and rewraps it. Before you select this option, enter positive values (in pixels) in the Margin Width and Margin Height boxes in the Layout tab of the Text Sample Inspector.
- **Scroll Delay** Sets the scroll delay. This option works when scrolling is enabled and the delay time is shorter than the sample duration.
- **Scroll In** Sets the text to scroll vertically from the bottom to the top of the movie.
- **Scroll Out** Sets the text to scroll vertically from the top to the bottom of the movie.
- **Horizontal Scroll** Sets the text to scroll horizontally. This option doesn't work with linking text.
- **Reverse Scroll** Reverses the direction of the scrolling text.
- **Continuous Scroll** Causes two text samples to scroll in and out. Scroll In and Scroll Out must also be selected for this option to work correctly.
- **Flow Horizontal** Lets horizontally scrolled text flow within the text box. If this option is not selected, the text flows as if the text box has no right edge.
- **Inverse Hilite** Reverses the highlighted text color and the text color.
- **Text Color Hilite** Sets the highlighted text color.
- **Start and End** Sets the start and end times of the scrolling text.

**Text layout options in the Text Sample Inspector**

After you select a text sample in the Timeline Editor, you can set the following text options in the Layout tab of the Text Sample Inspector:

- **Margin Width and Margin Height** Specify the text box margins in pixels.
- **Background** Specifies the text track background color.
- **Drop Shadow** Creates shadow text that drops just slightly below and to the right of the original text.
- **Transparent** Hides the text track background color.
**HREF tracks**

You can use an HREF track to embed URLs on an additional text track in a QuickTime movie. A web browser jumps to a URL destination on the web—either automatically or when a viewer clicks the movie display area.

You can also use an HREF track in a web page with HTML frames, where the movie plays back in one frame and a second frame displays the alternative URL destinations during movie playback. Using frames allows the movie to play back continuously while the content of the second frame is being swapped. You can use only one HREF track per movie.

**To add an HREF track**

1. Drag an HREF Track icon from the QuickTime set of the objects toolbox to the track list area of the Timeline Editor.
2. Select the HREF sample in the track content area of the Timeline Editor, and then specify a URL in the Link box of the URL Sample Inspector.
3. From the Target menu, choose a frame in the URL destination or enter a frame name.
4. Do one of the following:
   - To jump automatically to the specified URL as the movie plays, select the Autoload option.
   - To require the viewer to click the QuickTime movie to jump to the specified URL, deselect the Autoload option.

   **Note:** You can't change the HREF default name because QuickTime recognizes an HREF track by the name "HREFTrack."

**To show and hide the HREF track**

Click the Eye icon.

By default, the HREF track is hidden to prevent the URL from appearing in the movie. If you want to display the URL, show the HREF track.

**Filter tracks**

**Filter tracks**

You can use filters in a movie to create special effects, such as changing the color of a video track or blending two video tracks together. You can also use filters to create transition effects between tracks, such as having one video image cross fade over another video image. You can also specify exactly when filters start and end.

A filter track stores the characteristics of a filter and its target video. There are four different filter tracks you can add to a movie:

- **Generic filter tracks** Generate a cloud, fire, or ripple effect.
- **One-source filter tracks** Are applied to one video track only and change the visual presentation of the source track.
- **Two-source filter tracks, or transitions** Fade out one track and fade in another. This filter is applied to two video source tracks. Some examples of transition effects you can select are cross fade, explode, implode, and gradient wipe.
- **Three source filter tracks** Use a track's luminosity to control how two other source tracks blend over each other. This type of filter track is useful when you want to do real-time animated masking.
To add and apply generic filter tracks

Before you add a generic filter track, add the video track or picture track to which you want to apply the generic filter.

1 Drag a Generic Filter Track icon from the QuickTime set ✮ of the objects toolbox to the bottom of the track list area of the Timeline Editor.

2 Select the generic filter sample in the track content area of the Timeline Editor. (If necessary, expand the text track to display the samples.)

3 In the Generic Filter Sample Inspector, click the Select button.

4 In the Select Effect dialog box, do any of the following:
   - Choose an effect from the list box (Cloud, Fire, or Ripple) and, if necessary, select parameters for the effect.
   - Click Save to save the effect as a .qfx file for use later.
   - Click Load to load a previously saved effect.

5 Click OK. GoLive labels the generic filter sample bar in the Timeline Editor with the name of the effect.

6 To add other generic filters that appear at different times in the movie, use the Create Sample tool ✩ to create new generic filter samples.

See also
“Samples” on page 529

Adding and applying one source filter tracks

Before you add a one source filter track, add the video track or picture track that you want to use as the source for the one-source filter track.

Note that when you use a video track as a filter track's source, the original video track's data doesn't appear in the movie. All of the video track data is processed with the specified filter effect in the filter track, which also determines dimensions and position.

To insert a one-source filter

1 Drag a One-Source Filter Track icon from the QuickTime set ✮ of the objects toolbox to the bottom of the track list area of the Timeline Editor.

   Note: You must position the filter track at the bottom of the track list in the Timeline Editor to assign it to the top of the layering order (layer 1).

2 Select the one-source filter track in the Timeline Editor and display the One-Source Filter Track Inspector.

3 From the Source menu, choose the video or picture track to which you want to apply the one source filter track.

4 Select the one source filter sample in the track content area of the Timeline Editor. (If necessary, expand the text track to display the samples.)

5 In the One-Source Filter Sample Inspector, click the Select button.

6 In the Select Effect dialog box, do any of the following:
   - Choose an effect from the list box and then, if necessary, select parameters for the effect.
   - Click Save to save the effect as a .qfx file for later use.
   - Click Load to load a previously saved effect.
7 Click OK. GoLive labels the one source filter sample bar in the Timeline Editor with the name of the effect.

8 To add other one-source filters that appear at different times in the movie, use the Create Sample tool to create new one source filter samples.

See also

“QuickTime one-source filter effects” on page 561

“To set the layering order of tracks” on page 533

“Samples” on page 529

To add and apply two source filter tracks

Before you add a two source filter track, add the two video tracks that you want to use as sources for the filter track.

1 Drag a Two-Source Filter Track icon from the QuickTime set of the objects toolbox to the bottom of the track list area of the Timeline Editor.

   Note: You must position the filter track at the bottom of the track list in the Timeline Editor to assign it to the top of the layering order (layer 1).

2 Select the two-source filter track in the Timeline Editor and display the Two Source Filter Track Inspector.

3 From the Source A menu, choose one of the video tracks that you want to apply the two-source filter track to. From the Source B menu, choose the other video track that you want to apply the two-source filter track to.

4 Select the two-source filter sample in the track content area of the Timeline Editor. (If necessary, expand the text track to display the samples.)

5 In the Two-Source Filter Sample Inspector, click the Select button.

6 In the Select Effect dialog box, do any of the following:

   • Choose an effect from the list box and, if necessary, select parameters for the effect.
   • Click Save to save the effect as a .qfx file for use later.
   • Click Load to load a previously saved effect.

7 Click OK. GoLive labels the two-source filter sample bar in the Timeline Editor with the name of the effect.

8 In the Two-Source Filter Sample Inspector, do one of the following:

   • To have the transition effect proceed from the source A video track to source B, select Transition From Source A To B.
   • To have the transition effect proceed from the source B video track to source A, select Transition From Source B To A.

9 To add other two-source filters that appear at different times in the movie, use the Create Sample tool to create new two-source filter samples.

See also

“QuickTime transition effects for two-source filters” on page 564

“To set the layering order of tracks” on page 533

“Samples” on page 529
To add and apply three-source filter tracks

Before you add a three-source filter track, add the three video tracks that you want to use as sources for the filter track.

1 Drag a Three-Source Filter Track icon from the QuickTime set of the objects toolbox to the bottom of the track list area of the Timeline Editor.

*Note:* You must position the filter track at the bottom of the track list in the Timeline Editor to assign it to the top of the layering order (layer 1).

2 Select the three-source filter track in the Timeline Editor and display the Three Source Filter Track Inspector.

3 From the Source A menu, choose one of the video tracks that you want to apply the three-source filter track to.

4 From the Source B menu, choose the other video track that you want to apply the three-source filter track to.

5 From the Luma Matte menu, choose the video track you want to use to control how the source A and B video tracks blend over each other. (To see the effect more clearly, use a high-contrast grayscale video as the Luma Matte.)

6 Select the three-source filter sample in the track content area of the Timeline Editor. (If necessary, expand the text track to display the samples.)

7 In the Three-Source Filter Sample Inspector, click the Select button.

8 In the Select Effect dialog box, do one of the following:
   • Choose a matte from the Matte menu and, if necessary, select parameters for the effect.
   • Click Save to save the effect as a .qfx file for later use.
   • Click Load to load a previously saved effect.

9 Click OK. GoLive labels the three-source filter sample bar in the Timeline Editor with the name of the effect.

10 To add other three-source filters that appear at different times in the movie, use the Create Sample tool to create new three source filter samples.

See also

“To set the layering order of tracks” on page 533

“Samples” on page 529

QuickTime one-source filter effects

When setting effects for one-source filters, you can set the following filter effects in the Select Effect dialog box:

**Alpha Gain** Manipulates the alpha channel of a single track. This operation is commonly applied before passing the track to the Alpha Compositor effect. You can set these options:

   • **Bottom pin** The minimum value that the alpha channel can take after the gain and offset parameters have been applied.
   • **Top pin** The maximum value that the alpha channel can take after the gain and offset parameters have been applied.
   • **Gain** The value multiplied by the original alpha channel value.
   • **Offset** The value added to the old alpha channel, after it has been multiplied by the gain parameter.

**Blur** Applies a convolution blur effect to a single track. You can control the amount of blurring. The larger the value, the longer the effect takes to run and the greater the degree of blurring.
**Brightness and Contrast** Adjusts the brightness and contrast of the track. The default value is 0. Values between 100 and 0 decrease the brightness and contrast; values between 0 and 100 increase the brightness and contrast.

**Color Style** Lets you apply two color change effects to a single track. Both effects process the red, green, and blue components of each pixel independently. You can set these options:

- **Solarization** Adjusts the color balance of the source track by generating a table of replacement color values from two parameters. The table values start at zero intensity and increase to the maximum intensity at the peak point. After that, the values fall back to zero. You can change the Solarize Amount, the intensity of the solarization table, and the Solarize Point (the peak point of the solarization table).

- **Posterization** Reduces the number of colors in an image by replacing all pixels with colors in a consecutive range within the middle color from that range. This helps to control color banding. Posterize Amount determines the number of colors that are grouped and replaced with the mid-range color.

**Color Tint** Converts the track to grayscale, and then applies a light and a dark color to the image. The light color replaces the white in the grayscale image, and the dark color replaces the black. The end result is a tinted duochrome version of the source image. Tint Type lets you select from a choice of five different tints, including Black and White, X-Ray, Sepia, Cobalt, and Other. Other enables these options:

- **Light or Dark Color** Replaces the white or black of the grayscale image.

- **Brightness** Adjusts the brightness of the source between -255 (all colors replaced with black) and 255 (all colors replaced with white).

- **Contrast** Adjusts the contrast of the source between -128 (minimum contrast) and 128 (maximum contrast).

**ColorSync** (Mac OS only) Adjusts the color balance of an image to match a specified color sync profile. Typically, you would use this to adjust the color profile of an image to match the current display device. This option lets you maintain accurate color representations across devices. You specify both the color sync profile of the source image and the color sync profile of the destination device the image is displayed on. You can select these options:

- Source profile for the source image.

- Destination profile for the target device.

- Matching Option for adjusting converted colors: Peripheral (photos), Saturation (graphics), Absolute Colorimetric (logos), Relative Colorimetric (logos).

**Edge Detection** Applies an edge detection convolution to a single track. The performance of the edge detection is determined by the convolution kernel, which is a matrix of values applied to each pixel of the source to produce the resulting image. You can select these options:

- **Edge thickness** Specifies the width of the edges. The larger the value, the thicker the edges in the resulting image.

- **Colorize Result** Colorizes the edges based on the color of the source pixels around them. Deselect this option to render edges as light gray against a dark gray background.

**Emboss** Applies an emboss convolution to a single track. The higher the value, the heavier the embossing effect.

**Film Noise** Simulates effects that are seen on aged film stock. Use this option to make a video source appear as if it has suffered the effects of age and wear. The Film Noise effect offers the options of hairs and scratches: Hairs simulate hairs lying on the surface of the film, and scratches simulate vertical or near-vertical one-pixel scratch lines. You can adjust five parameters to control the visual impression:

- **Hair Density** Controls the number of hairs that are drawn on each frame and the frequency with which they appear.

- **Hair Length** Specifies the maximum length (in pixels) of the hairs being drawn.
• **Scratch Density** Controls the number of scratches that are drawn on each frame and the frequency with which they appear.

• **Scratch Duration** Specifies the maximum number of frames in which each scratch appears.

• **Scratch Width** Specifies the maximum width, in pixels, of a scratch.

**General Convolution** Applies a general-purpose convolution effect to a single track. The effect that results is determined by the values of the kernel parameters of the effect. The kernel for this convolution is a 3-by-3 matrix of values consisting of cells 1 through 9.

The convolution algorithm examines every pixel of the source and the eight pixels surrounding it. These values are multiplied by the appropriate values in the cells and summerized. This sum is then used as the value of the corresponding destination pixel.

**HSL Balance** Lets you independently adjust the hue, saturation, and lightness channels of a single track. The HSL balance filter effect has three parameters:

• **Hue** Specifies the hue channel value of each pixel.

• **Saturation** Specifies the saturation channel value of each pixel.

• **Lightness** Specifies the lightness channel value of each pixel.

**Lens Flare** Produces a sunspot effect. The Lens Flare filter has two options: Intensity And Flare Center, and Flare Type. The Intensity And Flare Center option has three parameters:

• **Size** Specifies the flare center size. When 1.0 is a small sunspot in the center of the image, and the increasing values expand the flare until the flare covers the entire image at 2.0.

• **Brightness** Specifies the brightness of the flare, where 0.0 is transparent and 1.0 is the most opaque.

• **Flare Center** Specifies the horizontal and vertical motion dispersion of the flare using the x and y axes settings.

• **Flare Type** Displays the type of flare image being used.

**RGB Balance** Lets you independently adjust the red, green, and blue channels of a single track. The RGB balance filter has three parameters:

• **Red multiplier** Specifies the red channel value of each pixel.

• **Green multiplier** Specifies the green channel value of each pixel.

• **Blue multiplier** Specifies the blue channel value of each pixel.

**Sharpen** Specifies the degree of sharpening from 1 (least) to 7 (most). The higher the value, the faster the effect runs and the greater the degree of sharpening.

**See also**

"Adding and applying one source filter tracks" on page 559
QuickTime transition effects for two-source filters
When you set transition effects for two-source filters, you can set the following alpha-channel-based effects in the Select Effect dialog box:

**Alpha Compositor** Combines two images using the alpha channels of the images to control the blending. It provides for the standard alpha blending options, and can handle pre-multiplying by any color, although white and black are the most common and often run faster. The alpha compositor effect has one parameter, Blend mode, that can contain one of the following values:

- **Straight Alpha** Performs a standard alpha blend. The alpha channel value of the first track defines the amount of that track that is included in the composite image. One minus the alpha channel value of the first track defines the amount of the second track that is included in the composite image.
- **Pre-multiply Alpha** Calculates the destination pixel based on the color you specify in the Pre-multiply color field.
- **Reverse Alpha** Performs a reverse alpha blend.

**Chroma Key** Combines two tracks by replacing all the first track’s pixels (specified in the Key Color field) with the corresponding pixels of the second track. This effect reveals the second track below the first in those places where the first track has the specified color. The Key Color is the chroma key color to replace in the first track with pixels from the second track.

The following effects are transitions between two tracks:

**Cross Fade** Also called a **dissolve**, this effect provides a smooth alpha blending between two video sources, which results in a smooth fade out from the first track into the second. This effect has one parameter—Percentage. The two slider controls let you manipulate the degree of visibility of either source during the blend.

**Explode** In an Explode effect, track B grows from a single point; expanding out until it entirely covers track A. This effect has three parameters:

- **Percentage** Specifies the degree of visibility of either source during the blend.
- **Explode Center X** Specifies the x-coordinate (horizontal) of the explosion center.
- **Explode Center Y** Specifies the y-coordinate (vertical) of the explosion center.

**Gradient Wipe** Transitions between two tracks, with the change pattern controlled by an input image. At the start of the effect, the area covered by the input image shows the first track, while the area outside the input image shows the second. Over the duration of the effect, the input image shrinks until only the second track is visible. The Gradient wipe effect has three parameters:

- **Percentage** Specifies the degree of visibility of either source during the blend.
- **Matte** Specifies the input image that controls the transition between the two tracks.
- **Edge Blur** Controls the amount of edge blur, or distortion, that the leading edge of the gradient wipe displays.

**Implode** Shrinks track A down to a single point, revealing track B. The center point of the implosion is defined in the effect parameters. The Implode effect has three parameters:

- **Percentage** Specifies the degree of visibility of either source during the blend.
- **Implode Center X** Specifies the x-coordinate (horizontal) of the implosion center.
- **Implode Center Y** Specifies the y-coordinate (vertical) of the implosion center.
Push  Replaces one source image with another, while both tracks move at the same time. For example, track A would typically occupy the entire screen, and then track B would slide in from the left, while track A slides out to the right at the same time. The Push effect has two parameters:

- **Percentage**  Specifies the degree of visibility of either source during the blend.
- **Push From**  Controls the direction from which track B replaces track A. This parameter can contain Top, Right, Bottom, and Left.

Slide  Slides track B into the screen to cover track A. At the end of the effect, track B completely covers track A. The Slide effect has two parameters:

- **Percentage**  Specifies two slider controls let you manipulate the degree of visibility of either source during the blend.
- **Angle**  Specifies the angle from which track B enters the frame. This value is expressed in degrees, with 0 degrees defined as the top of the screen.

Iris, Matrix Wipe, Radial, Wipe  Each of these effects is an implementation of a series of masking or reveal-type effects that take place between two tracks. Each has seven parameters:

- **Percentage**  Specifies the degree of visibility of either source during the blend.
- **Wipe Type**  Specifies which of the 13 available wipes, listed in the Wipe Type menu, is used. You can preview the wipe types in the preview pane of the Select Effects dialog box.
- **Horizontal Repeat**  Specifies the number of horizontal repeats of the effect that occur in a single track.
- **Vertical Repeat**  Specifies the number of vertical repeats of the effect that are executed in a single track.
- **Border Width**  Specifies the width, in pixels, of a border that is drawn around the second track.
- **Border Color**  Specifies the RGB color of the border around the second track.
- **Soft Edges**  Specifies that the border drawn around the second track is blurred.

Zoom  Produces a zooming effect of one image (B) over (or from) another image (A). The Zoom filter has four parameters:

- **Percentage**  Specifies the percentage, or amount, of the area that the zooming image (B) zooms. The left zoom percentage setting controls the zooming image (B) from its starting point (center to outer), and the right side controls the zooming image from the end point (outer to center). You can adjust the two percentage settings and watch the effects of zooming in and out, zooming image B over a large portion of image A, zooming image B over a very small portion of image A, or a combination of the two such that the zooming object “zooms in place.”
- **Zoom Type**  Controls which images zoom. Zooming B over A zooms image B out from or into a static image A. Zooming B over Zooming A zooms image B out from or into a zooming image A. Zooming A simply zooms image A.
- **Zoom Center**  Specifies the horizontal and vertical start or end point of the zooming image, depending on the area percentage settings.
- **Distance**  Specifies the amount of travel space and with what velocity that the image zooms.

See also

“To add and apply two source filter tracks” on page 560
Using actions to control tracks

Actions for setting movie properties

Use the following actions to set movie properties:

**Movie Set Volume**  Sets the audio volume of the movie. You can set the volume level between 0 (minimum) and 255 (maximum).

**Movie Set Rate**  Sets the movie's playback speed: 1 for normal speed, 2 for double speed, 0 to stop, -1 or -2 and less to play the movie backward.

**Movie Set Looping Flags**  Sets the looping mode for movie playback:
- **None**  Plays the complete movie once and then stops.
- **Loop**  Plays the complete movie from beginning to end repeatedly.
- **Loop and Palindrome**  Play the complete movie forward and then backward repeatedly.

**Movie GoTo Time**  Jumps to the time you enter in the Movie Time box.

**Movie GoTo Beginning**  Jumps to the beginning of the movie.

**Movie GoTo End**  Jumps to the end of the movie.

**Movie Step Forward**  Advances the movie one frame at a time.

**Movie Step Backward**  Rewinds the movie one frame at a time.

**Movie Set Selection**  Selects part of the movie based on the times you enter in the Start Time and End Time boxes. Click the Get Current Selection button to start the time range at the point of the current play selection.

**Movie Set Play Selection**  Enables the Play Selection specified by the Movie Set Selection action. This option lets you toggle the play selection on and off. To actually play the movie, use the Movie Set Rate action.

**Music Play Note**  Plays a (MIDI) note with a sound specified in an Instrument Track.

**Set Child Movie URL and Load Child Movie**  Use these two actions together. Set Child Movie URL specifies a URL for a movie without loading it, so you don't see any visible effect with this action applied alone. Load Child Movie loads the URL you specified with the Set Child Movie URL action, and the result is that the changed content is visible. Use these actions to change a movie track's content while the movie is running, such as when a viewer clicks a sprite.

**GoTo URL**  Jumps the sprite to the specified URL. (This action is global; that is, it doesn't control the movie playback window.) The Link box lets you specify a web page. The Target box and menu are only for an embedded GoTo URL action from within a movie in a web page.

See also

“To wire a movie track with actions” on page 540

“To wire an SWF button with actions” on page 551

“To add text links with actions” on page 556
Actions for setting track properties
Use the following actions to set track properties:

**Track Set Enabled** Enables or disables a track, regardless of its type. You can use it, for example, to switch between two different sound tracks.

**Track Set Layer** Sets the current track's layer number, specifying its front-to-back order relative to the other tracks. Choose the track from the Track menu. The Layer box displays the selected track layer number. You can enter a number to move the selected track forward or backward. The lower the layer number, the closer to the viewer the track appears.

**Track Set Matrix** Sets the dimensions of the target track. Choose the track from the Track menu. The Position and Size boxes display the current settings. To change these settings, deselect the Action Normalizes Track option. The Constrain Proportions option maintains the aspect ratio of the settings.

**Track Set Graphics Mode** Sets the graphics mode of the selected track. Choose the track from the Track menu. From the Mode menu, choose how you want the track to overlay other tracks. Click the color field next to the Mode menu and drag a color from the preview pane of the Color palette to the color field.

**Track Set Sound Volume** Sets the volume for the selected track. Choose the track from the Track menu. You can set the volume level between 0 (minimum) and 255 (maximum).

**Track Set Sound Balance** Sets the sound balance for the selected track. Choose the track from the Track menu. You can set the balance left, center, or right (-128 maximum left to 128 maximum right).

See also
“To wire a movie track with actions” on page 540
“To wire an SWF button with actions” on page 551
“To add text links with actions” on page 556

Actions for setting sprite properties
Use the following actions to set sprite properties:

**Sprite Set Matrix** Sets the position of the target sprite. Choose the track from the Track menu, and then choose the target sprite from the Sprite menu. The Position box displays the current position of the sprite.

**Sprite Set Image Index** Selects the image for the target sprite. This action creates mouseover or rollover effects. Choose the track from the Track menu, and then choose the target sprite from the Sprite menu. From the pop-up menu below the Sprite menu, choose the target image, and then a thumbnail of the image appears in the Actions tab.

**Sprite Set Visible** Shows or hides the target sprite. Choose the track from the Track menu, and then choose the target sprite from the Sprite menu. The Visible option shows and hides the sprite.

**Sprite Set Layer** Sets the target sprite's layer number, specifying its front-to-back order relative to other sprites on the same track. Choose the track from the Track menu, and then choose the target sprite from the Sprite menu. The Layer box displays the selected sprite layer number. You can enter a number to move the selected sprite forward or backward. The lower the layer number, the closer to the viewer the sprite appears.
See also
“To wire a movie track with actions” on page 540
“To wire an SWF button with actions” on page 551
“To add text links with actions” on page 556

Actions for setting text properties
Use the following actions to set text properties for a targeted text track:

**Text Replace**  Replaces text with text you enter in the Text box. In the Start and End boxes, specify the zero-based range of characters to replace. For example, to replace “Go” in the word “GoLive,” specify a range from 0 to 1.

**Text Set Selection**  Selects text using a range you specify in the Start and End boxes. Use with another action that changes properties of the selected text, such as Text Set Font. In the Start and End boxes, specify the zero-based range of characters to replace.

**Text Set Background Color**  Sets the text background color. Click the Color box to specify a color in the Color palette.

**Text Set Foreground Color**  Sets the text color. Click the Color box to specify a color in the Color palette.

**Text Set Font Style**  Sets the font style. Options include Normal, Bold, Italic, Underlined, Outlined, Shadow, Condensed, and Extended.

**Text Set Font**  Sets the font you choose from the Font menu.

**Text Set Font Size**  Sets the font size you enter in the Size box.

**Text Set Key Entry**  Simulates a keyboard entry of ASCII characters specified in the Char box. Requires a Text Set Editable action with Script Editing enabled.

**Text Set Editable**  Sets the text editing status. From the Edit State menu, choose one of the following:

- **None**  Disables text editing.
- **Direct Editing**  Enables text editing by the user.
- **Script Editing**  Enables text editing via a script.

See also
“To wire a movie track with actions” on page 540
“To wire an SWF button with actions” on page 551
“To add text links with actions” on page 556

Actions for setting QTVR properties
Use the following actions to set QTVR properties:

**QTVR GoTo NodeID**  Sets the current node ID of a QuickTime VR movie.

**QTVR Set Pan Angle**  Sets the current pan angle of a QuickTime VR movie.

**QTVR Set Tilt Angle**  Sets the current tilt angle of a QuickTime VR movie.
**QTVR Set Field Of View**  Sets the current field of view of a QuickTime VR movie.

**QTVR Go To Default View**  Sets the current default view of a QuickTime VR movie.

**See also**

“To wire a movie track with actions” on page 540

“To wire an SWF button with actions” on page 551

“To add text links with actions” on page 556

**Actions for setting SWF properties**

Use the following actions to set SWF properties:

- **SWF Track Set Pan**  Sets the current pan percentages for the target SWF track. It moves the SWF track by a relative amount set in the corresponding text boxes.

- **SWF Track Set Zoom Factor**  Zooms the target SWF track by a specified factor (between 0 and 100%). The Action Normalizes Track button resets the SWF track to its default (non-zoomed) size.

- **SWF Track Set Zoom Rect**  Sets the current zoom rectangle for the target SWF track. The zoom rectangle is the area of the SWF track that zooms into the current size of the SWF track. For example, suppose that you have a movie with at least one sprite in it. Import an SWF track and set its size to 320x240 pixels. Click the Actions tab and apply the SWF Track Set Zoom Rect action with the zoom rect set to 160x120 pixels. Select the Mouse Click trigger event. Click the sprite to see the effect: the 160x120 zoom rect is zoomed into the 320x240 pixel track size area.

- **SWF Track GoTo Frame**  Jumps to a specific frame within the target SWF track.

- **SWF Track GoTo Frame Label**  Jumps to a specific frame label within the target SWF track, if the track has labels. (Labels are created in an SWF authoring application.)

**See also**

“To wire a movie track with actions” on page 540

“To wire an SWF button with actions” on page 551

“To add text links with actions” on page 556

**Actions for setting scripting properties**

Use the following actions to set scripting properties:

- **QuickTime Script**  Specifies a QuickTime script for wired actions.

- **Execute Script**  Executes a script command with arguments you specify. In addition to generic scripts, this action supports scripts in the following languages: Apple Script, JavaScript, Lingo, Projector, and Visual Basic.

**See also**

“To wire a movie track with actions” on page 540

“To wire an SWF button with actions” on page 551

“To add text links with actions” on page 556
Actions for setting XML properties
Use the following actions to set XML properties:

Set XML Specifies an XML list at a parent path.

Replace XML Replaces a specified parent path with an XML-formatted string.

Add XML Element Adds an XML element at a specified parent path and index.

Set XML Element Sets an element value for an element path.

Remove XML Element Removes a specified range of elements.

See also
“To wire a movie track with actions” on page 540
“To wire an SWF button with actions” on page 551
“To add text links with actions” on page 556

Scripting with QuickTime Wired Action Programming Language

About QuickTime scripting
Adobe's QuickTime Wired Action Programming Language lets you create sophisticated, interactive movies. Adobe created QuickTime Wired Action Programming Language to expand the functionality of Apple's QuickTime wired actions (the set of predefined actions QuickTime recognizes) and to automate the scripting process in GoLive.

QuickTime Wired Action Programming Language is based on JavaScript syntax and described in XML. The QTScript.xml file, located in the GoLive/Settings/QuickTime folder, describes the actions, operands, targets, expressions, operators, and constants of the language. If Apple releases additional wired actions, you can add them to this file.

The QuickTime scripting windows
GoLive provides three windows that help you create and manage scripts:

QT Wired Actions window Contains the wired actions you use to create and edit scripts. You can view the available wired actions here; or, you can view them in the appendix.

QT Script Debugger window Helps you to fix faulty scripts. It displays all debugString commands.

QT Script Manager window Lists all scripts in a movie. You can double-click a script to open it in the script window.

See also
“About QuickTime scripting” on page 570
Custom functions in QuickTime scripts

QuickTime Wired Action Programming Language lets you create true custom functions, complete with custom arguments and result values. For example, the following uses a custom function called “my Add Func” to add two values and return the sum:

```javascript
function onMouseDown ()
{
    var theResult = myAddFunc (10 + 20);
    debugString (the Result);
}

function myAddFunc (value1, value2)
{
    return (value1 + value2);
}
```

Combining eventhandler actions in one script

You can combine multiple eventhandler scripts into one script file, depending on the track type.

**Note:** When you use an eventhandler in a script, do not use the matching predefined action, as it will be overwritten by the eventhandler in the script.

**Sprite tracks** You can combine onIdle, onListReceived, onKey, onMouseMoved, onMouseDown, onMouseUp, onMouseClick, onMouseEnter, and onMouseExit eventhandlers in one script. OnFrameLoaded requires a separate script file.

**Text tracks** You can combine onMouseDown, onMouseUp, onMouseClick, onMouseEnter, and onMouseExit eventhandlers in one script file. OnIdle, onListReceived, onKey, and onMouseMoved each require a separate script.

**Movie Tracks** Only onMovieLoaded is allowed as an event handler.

**SWF tracks** You can combine onMouseDown, onMouseUp, onMouseClick, onMouseEnter, and onMouseExit.

Variable scopes

QuickTime supports variable scopes, which indicate where and when a variable can be used within a movie. There are four variable scopes.

**Note:** Text, movie, and Flash tracks can use only movie variables. When you add a script to these types of tracks, GoLive generates the required movie variables automatically.

**Movie variables** Movie variables are accessible from all scripts and objects for the length of the movie. Movie variables must have the prefix “m_.” For example, “var m_Counter = 10;” defines a movie variable.

**Global variables** Global variables are only allowed for sprite tracks. They can be accessed by all sprites on a track. Global variables must have the prefix “g_.”

**Sprite variables** Sprite variables, while allowed only for sprites, are accessible from different eventhandlers. Sprite variables must have the prefix “s_.”

**Local variables** Local variables are only allowed for sprites and sprite track actions. They do not require a prefix.
To create and edit QuickTime scripts

You can use the QuickTime script window to create or edit scripts. When working with scripts, you can use the GoLive code completion and syntax highlighting capabilities to simplify script creation.

1. Do one of the following:
   • To create a new script, choose File > New, and then select Scripting > Scripts > QuickTime Script.
   • To open an existing script, choose File > Open.

2. Choose Window > QT Wired Actions to open the QT Wired Actions window, if necessary.

3. Drag the desired scripting component from the Actions column of the QT Wired Actions window to the script window, and then enter any information, such as URLs, time, and volume, required for the script.

4. Save the script.

See also

“Highlighting items in the source code or Layout Editor” on page 594
“‘To set Code Completion preferences’ on page 580
“JavaScript Editor toolbar items” on page 603

To debug a QuickTime script

You can quickly debug a script using the QT Script Debugger window. Use this window to check the actual value of a variable or to check the return value of a wired action.

1. Open a QuickTime movie and its associated QuickTime script.

2. If necessary, choose Window > Script Debugger to open the QT Script Debugger window.

3. In the script window, select a function’s action (the code between the curly brackets { }). In the following simple script, for example, you would select `goToURL (/"URL"/);`

```javascript
function onMouseDown (){goToURL (/"URL"/);}
```

4. Double-click `debugString` in the General Action section of the QT Wired Actions window to replace the function’s action with the `debugString` action. The example script now reads:

```javascript
function onMouseDown (){debugString (/"String"/);}
```

5. Replace the code `/"String"/` with your debugging text in parentheses. The example script now reads:

```javascript
function onMouseDown (){debugString (/"your debugging text"/);}
```

6. Choose Movie > Compile Script, and then save the movie file.

7. Click the Preview tab, and then perform the event trigger (such as clicking the mouse) for the function you’re testing. The text “your debugging text” appears in the QT Script Debugger window. If it doesn’t appear, something is wrong with that function of the script.
To add a QuickTime script as a wired action

You can add a QuickTime script as an action to four types of tracks: sprite, text, movie, and Flash tracks. The event triggers for the action, such as mouse over or mouse click, and the actions vary depending on the track type.

1 In GoLive, do one of the following:
   - To create a new movie, choose File > New, and then select Web > Multimedia > QuickTime Movie.
   - To open an existing movie, choose File > Open.

2 From the QuickTime set of the objects toolbar, drag the movie track, text track, sprite track, or Flash Track icon to the Timeline Editor window.

3 Access the track's Action controls as follows:
   - For a movie track, select the track, and then click Actions in the Movie Track Inspector.
   - For a text track, select the track in the Layout tab, and then Ctrl-click the track and choose Show Sample Inspector from the pop-up menu that appears. The Action controls appear in the center of the Text Sample Inspector.
   - For a sprite track, select the sprite object in the Layout tab. If the sprite track is selected, instead of the sprite object, Ctrl-click the sprite track and choose Sprite from the pop-up menu that appears. Ctrl-click the sprite object, and choose Show Sample Inspector from the pop-up menu that appears. Click the Actions tab in the Sprite Sample Inspector.
   - For a Flash track, make sure that it has buttons to add the action to.

4 Select an event trigger from the Events list.

5 Click the Create New Item icon to add an action, and then select QuickTime Script from the pop-up menu.

6 Do one or more of the following:
   - Use the pick whip to link to an existing script. If you need to edit the linked script, click the double arrows and choose Edit Script from the pop-up menu that appears.
   - Click the double arrows to the right of the Link field and select New Script. Enter the script in the QuickTime Script window (untitled.qtspt) that appears, and then save the script.
   - Click the double arrows to the right of the Link field and select Show QT Action Window to help you create a script.
   - Click the double arrows to the right of the Link field and select Show QT Script Manager Window.

7 Save the movie.

8 Choose Movie > Compile All Scripts, and then preview it using the Preview tab.

See also

"About tracks and track types” on page 531

To create radio-button and toggle-button behaviors

1 In Adobe Photoshop (or another image-editing application), create a PSD file with the desired layers.

Note: Make sure that you name the layers in your Photoshop file so they import correctly.

2 In GoLive, do one of the following:
   - To create a new movie, choose File > New, and then select Web > Multimedia > QuickTime Movie.
   - To open an existing movie, choose File > Open.
3 From the QuickTime set in the objects toolbox, drag the Sprite Track icon to the Timeline Editor window to add it to the movie.

4 With the sprite selected, click the Sprites tab of the Sprite Track Inspector.

5 Click Import, select the desired PSD file, and then click Open.

6 Choose Movie > Radio Button Behavior or Movie > Toggle Button Behavior.

7 If you’re creating button behaviors, click the Create New Item icon to add a radio group. Name the group using the Name field, and then click the Radio Buttons tab.

8 Move the buttons you want to use as radio buttons or toggle buttons from the Sprites pane to the Buttons pane by selecting a button and clicking the double arrows.

9 Click Apply, and then preview the movie.

GoLive automatically generates and applies the necessary QuickTime scripting.

See also

“Importing Photoshop layers as sprites” on page 548

To clear radio-button and toggle-button behaviors

1 Open the movie containing the behavior.

2 Do one of the following:
   • To clear a radio button behavior, delete the radio group, and then click Apply.
   • To clear a toggle button behavior, remove the sprite from the target toggle button list, and then click Apply.

Making movies with XML

QuickTime’s XML support

You can use an XML database to dynamically provide content for QuickTime movies and to control their behaviors. QuickTime can access data from an external XML file or from XML data stored in the movie itself. Typically, you’ll use an external XML file—an external file lets you update the movie by simply updating the external file.

QuickTime’s XML support is property-driven instead of attribute-driven; you can create tags (for example, the source tag: <src> ) but the tags don’t have attributes. To add data to a tag, add it as a property (for example, <src>mymovie.mov</src>).

To create or edit an XML list

Before you create an XML List movie, you need to create the XML list (database) that the movie will use.

1 Do one of the following:
   • To create a list, choose Movie > New XML List.
   • To open an existing XML file, choose Movie > Open XML List.

2 Click the Source tab, enter the data for the source and information tags, and then save the document.
Note: In GoLive, the XML List Movie’s functionality only reads source tags and the information tags from the database of the movie. You can add other functionality to the movie, such as interactive sprites, by using QuickTime Scripting.

Outline tab of XML window shows source and information data.

See also

“About QuickTime scripting” on page 570

To create an XML List Movie

After you’ve created an XML list, you can apply it to a movie. You can either include the XML data in the movie itself or link to an external XML list file.

1 Open an existing movie file or create a new movie.

2 Choose Movie > Make XML List Movie.

3 Specify the following settings:

   • In the XML List tab, choose whether you want to use the movie’s XML list or an external XML list. If you use an external list, you'll need to link to it.

   • In the Navigation tab, specify the sprite track and its interface elements. If no sprites are used, choose None.

   • In the Movie Track tab, specify the movie track that displays the media located at the source URL.

   • In the Info tab, specify the text tracks to display the media information (required) and record information (required only for movies with interactivity).

4 Click Apply. GoLive creates the scripts required for the XML List movie and places them in their own folder.

To clear XML list data from a movie

You can remove XML functionality from a movie. Removing the list from a movie does not delete the scripts created for the movie; you can delete the scripts manually if desired.

❖ Open the movie, and then choose Movie > Clear XML List Movie.
Saving and exporting movies

Saving movies
After you finish editing a movie, you can save it in a QuickTime movie format that you can then add to a web page.

The first time you save a movie, GoLive automatically flattens the movie to copy all referenced data into the movie and make it self-contained. Before GoLive flattens the movie, tracks contain only references to data, not the actual data. To avoid problems with missing data when a viewer opens a web page that contains your movie, GoLive flattens the movie to make it web-ready. (After flattening, the file size of the movie increases because it contains all of the data.)

Note: GoLive flattens movies automatically only the first time you save them. To flatten a movie after saving it the first time, you must choose Movie > Flatten or File > Save As. Also note that the file you embed in the movie track does not become a part of the root movie when the movie is flattened.

See also
“About movie tracks” on page 538
“Sprite tracks” on page 543

To save a movie
1 Choose File > Save or File > Save As.
2 Name the file, and then select the destination folder in the Save As dialog box (typically in the root folder for your site). You might want to create a folder in your site window (for example, Movies), and save your movies in that folder.

To export a movie or track
1 Do one of the following:
   • To export a movie as a different movie format, choose File > Export > Movie.
   • To export a track as a movie, choose File > Export > Track.
2 Choose a movie format from the Export menu.
3 To select compression settings for the movie, click Options, and then click Settings. Select compression settings in the Compression Settings dialog box, and then click OK twice.
4 In the Save Exported File As dialog box, name the file, select the destination folder, and then click Save.

To export a movie as an RTSP streaming movie
1 Choose File > Export > Streaming Movie, name the file, select the destination folder, and then click Save.
2 Select options in the Hint Exporter Settings dialog box, and then click OK. For information on the options in the Hint Exporter Settings dialog box, see Apple's QuickTime documentation.

Note: Before you export a movie to an RTSP streaming movie, see the Apple QuickTime documentation about preparing movie files for RTSP streaming.
See also
“Streaming tracks” on page 551

To create a QuickTime media skin
With QuickTime media skins, you can completely customize the appearance of the QuickTime player window. In GoLive, you can quickly create a media skin by importing a three-layer Photoshop file. Each layer of the file defines a different part of the media skin.

1 In Photoshop, create a three-layer file with the following layer contents and structure:
   • Background layer with a graphic of the media skin.
   • First layer with a window mask. Black areas should reflect the outline of the media skin, defining the edges of the player window.
   • Second layer with a drag mask. Black areas become draggable, allowing the viewer to reposition the player window; white areas define controls and the movie box.

2 In GoLive, choose File > New, select Web > Multimedia > QuickTime Skin, and open the Photoshop file.

3 Specify a file name and location, and then save the media skin.
Chapter 25: Editing source code

Source code editors and preferences

GoLive source code editors
When you work in the Layout Editor, GoLive writes all of the source code for you. If you want to work directly with HTML or JavaScript source code, you can use several different source code editors. Changes you make in the document window are immediately reflected in all source code editors, and vice versa.

Source Code Editor  Lets you edit your document’s HTML source code in text format, perform a syntax check, and visually distinguish elements, attributes and content by color. You can type or paste text from another document or application, and make and save changes.

Source code panel and Source Code palette  Let you edit source code while in the Layout Editor, the Frame Editor, or the Outline Editor without switching tabs in the document window. The source code editing features function just like the Source Code Editor features.

Visual Tag Editor  Lets you insert HTML code or make changes to existing code while working in the Layout Editor.

Markup palette  Lets you insert common HTML or JavaScript attributes while working in the Layout Editor, Frame Editor, or the Outline Editor (for more information, see “To use the Markup palette” on page 580).

Outline Editor  Presents the HTML code of your documents in a hierarchical, organized way, and provides a menu of attributes for every element in the document.

JavaScript Editor  Lets you build scripts in the application, embed them in your document, and test them immediately by launching the targeted browser.

GoLive includes several scripting samples in the New dialog box (File > New). You can choose from a variety of script-based pages and scripting samples, including ASP, JSP, or PHP pages and QuickTime, CGI, Java, and Perl scripts.

See also
“Snippets” on page 429
“Components” on page 427

Source preferences
Source preferences control how the Source Code and JavaScript Editors work, and how source code appears in the Source Code and JavaScript Editors.

Source preferences  Turn on and off word wrapping, support for dragging marked text, and control how source code appears in the Source Code and JavaScript Editors. A preview panel in the Preferences dialog box shows you how the source code appears as a result of the options you select.

Themes preferences  Let you select, customize, and rename source code themes, as well as set color, font face, and font size options for elements in different languages (for example, PHP, JavaScript, and HTML). Key sets enable you
to control how HTML tags are displayed in the Source Code Editor. For example, you can create a key set that displays the table tag in a certain color, face, and size.

**Syntax preferences**  Enable you to turn on context-sensitive code completion options in the Source Code and JavaScript Editors.

**To set general Source preferences**

1. Choose Edit > Preferences (Windows) or GoLive > Preferences (Mac OS), and then click the Source icon.
2. Set the following preferences to control how the Source Code and JavaScript Editors work:
   - **Enable Dragging for Marked Text**  Turns dragging on or off.
   - **Auto Indent**  Controls the automatic indenting of lower level elements.
   - **Tab Size**  Sets the tab size of the auto indent and the number of characters added when you press the Tab key.
   - **Line Numbers**  Displays line numbers at the left margin of the Source Code or JavaScript Editor.
   - **Word Wrap**  Wraps the source code in the Source Code or JavaScript Editor.
   - **Default Theme and Print Theme**  Enables you to select the default and print themes the Source Code or JavaScript Editor uses to display source code.
3. Click OK.

**To set Themes preferences**

1. Choose Edit > Preferences (Windows) or GoLive > Preferences (Mac OS), and then select Themes under Source preferences.
2. Do any of the following:
   - To specify a theme for the source code, choose a theme from the Theme menu.
   - To customize a theme, choose it from the Theme menu and select options from the Text Color, Background, Script, Font, and Size menus.

**To customize the appearance of a specific language in the Source Code Editor**

1. Choose Edit > Preferences (Windows) or GoLive > Preferences (Mac OS), and then click Themes under Source Preferences.
2. Choose a language from the Syntax menu.
3. Select an option from the list beneath the Syntax menu to specify what you want to customize.
4. Specify a color, face, and font size.
5. Repeat steps 2-4 for each language and option you want to customize; then click OK.

**To set key sets for HTML elements**

1. Choose Edit > Web Settings (Windows) or GoLive > Web Settings (Mac OS).
2. In the Markup Language tab, choose an HTML element (for example, Table).
3. Click the Output tab of the Web Settings Element Inspector.
4. Choose a key set from the Group menu, and then close the Web Settings window.
5 Choose Edit > Preferences (Windows) or GoLive > preferences (Mac OS), and then select Themes under Source Preferences.

6 Choose HTML Syntax from the Syntax menu.

7 Select the key set (from step 4) in the list beneath the Syntax menu.

8 Specify color, face, and size for the key set. GoLive displays the HTML element represented by the key set with these attributes in the Source Code Editor.

To set Code Completion preferences
1 Choose Edit > Preferences (Windows) or GoLive > preferences (Mac OS), and then select Syntax under Source preferences.

2 Select Enable Code Completion to turn code completion on.

3 Select Enable Immediate Completion to automatically insert end tags in the code.

4 Select Balance While Typing to automatically jump to the next open bracket when you type a close bracket.

5 Drag the Delay slider to specify a delay speed, and then click OK.

To use the Markup palette
Use the Markup palette to add or edit common HTML attributes (ID, class, title, or language) or JavaScript attributes to any object on the page in the Layout Editor, Frame Editor, or Outline Editor.

1 Choose Window > Markup.

2 In the Layout Editor, Frame Editor, or Outline Editor, select the object to which you want to apply an Attribute.

3 Do one of the following tasks:
   • To add or edit an HTML attribute, click the General tab.
   • To add or edit a JavaScript attribute, click the JavaScript tab.

4 Add or edit attribute values, or choose them from the attribute menu.

Source code management tools

To open the Source Code Editor
❖ Click the Source tab T of the document window. The Source Code toolbar appears below the Source tab. (If you don’t see the Source Code toolbar, choose View > Toolbar from the context menu.)

To hide or display the source code panel
❖ Either click the Show/Hide Split Source button in the document bar at the bottom of the Layout Editor, the Frame Editor, or the Outline Editor, or choose View > Show Split Source.

💡 To quickly change the location and orientation of the source code panel, Alt-click (Windows) or Option-click (Mac OS) the Toggle Split View button. The source code panel moves to the right side of the document window and changes from a horizontal to a vertical orientation. To move the source code panel to the top of the document window (and subsequently to the left, and then back to the bottom), repeat this step.
The Source Code palette

The Source Code palette lets you work in the Layout Editor, Frame Editor, or Outline Editor and see the underlying source code at the same time. If you use two monitors, you can view a document in the Layout Editor on one monitor, and view the underlying source code in the Source Code palette on the second monitor. Changes you make in the Layout Editor are reflected in the Source Code palette, and vice versa, after you click in the Layout Editor again.

You can set the Source Code palette to Local Mode to display only the code for the elements currently selected in the Layout Editor, Frame Editor, or Outline Editor.

To use the Source Code palette

1. In the Layout Editor, Frame Editor, or Outline Editor, choose Window > Source Code to display the palette.
2. Choose any of the following from the Source Code palette menu:
   - **Local Mode**: Displays the code for the currently selected element only in the Layout Editor, Frame Editor, or Outline Editor.
   - **Word Wrap**: Wraps the contents to the margin of the Source Code palette. If you resize the palette with this option enabled, the contents wrap to the palette's new size.
   - **Display Line Numbers**: Shows code line numbers.
   - **Dim When Inactive**: Dims the contents of the Source Code palette when you’re working in the Layout Editor, Frame Editor, or Outline Editor. The dimming turns off when you click in the Source Code palette.

Using the Visual Tag Editor

Editing individual elements with the Visual Tag Editor

The Visual Tag Editor lets you inspect and edit the source code of a single HTML element in the Layout Editor without having to use the Source Code Editor or Source Code palette. The Visual Tag Editor also lets you insert new source code.

The Visual Tag Editor is a good tool for making quick, on-the-fly changes to the source code of a document without leaving the Layout Editor. If you need to perform more extensive editing of the source code, use the Source Code Editor or Source Code palette instead.

Using the Visual Tag Editor

- **A. Inspect and edit the source code associated with the current selection**
- **B. Context-sensitive list of valid tags, attributes, and values**
- **C. The markup tree bar lets you select other elements for editing**
- **D. Information on the element or attribute being edited**
- **E. Current mode**
Adding an element with the Visual Tag Editor

1. In the Layout Editor, place the cursor where you want to insert source code. Be careful to avoid selecting existing text or elements, which would open the Visual Tag Editor in Edit mode.

2. Choose Special > Visual Tag Editor.

3. To insert an element with the Visual Tag Editor, do one of the following:
   - Type the element's tag in the upper panel displaying the empty tag.
   - Double-click the tag in the list box.

4. To insert an attribute, do the following:
   - Type a blank space after the tag (within the angle brackets). Whenever you type a space after a tag, GoLive displays the relevant attributes for that tag in the list box.
   - Insert an attribute by typing the attribute in the upper panel or double-clicking it in the list box.
   - Type a value for the attribute.

Note: GoLive obtains the tags, attributes, and values for the list box in the Visual Tag Editor from the DTD set by the current doctype. (See “Setting the document type definition” on page 161.) If the document doesn't have a doctype, GoLive uses the Markup tab in Web Settings.

5. When you have finished entering the source code, click OK.

To edit an object or element with the Visual Tag Editor

1. In the Layout Editor, do one of the following:
   - Select the object you want to edit by clicking it.
   - Select the element you want to edit by using the markup tree bar at the bottom of the document window.
   - Select more than one paragraph, object, or element by dragging in the Layout Editor.

2. Choose Special > Visual Tag Editor.

3. Edit the element by doing any of the following:
   - Edit an existing attribute by clicking the attribute in the upper panel and typing directly in the upper panel. You can replace the existing attribute by double-clicking another attribute in the list box.
   - Add a new attribute by placing the cursor before or after an existing attribute in the upper panel, and typing a blank space. Then type the new attribute, or double-click an attribute in the list box.
   - If an attribute has predefined values, you can select a value by placing the cursor in the attribute's value in the upper panel, and double-clicking the value in the list box.

   To select a different element without closing the Visual Tag Editor, use the markup tree bar in the Visual Tag Editor. The markup tree bar works the same way in the Visual Tag Editor as it does in the document window.

4. When you have finished editing the source code, click OK.

See also

“Selecting elements using the markup tree bar” on page 593
To add a tag around a selection using the Visual Tag Editor

1. In the Layout Editor, select a range of text, or text plus an object within a single paragraph.
2. Choose Special > Visual Tag Editor.
3. Do one of the following:
   • Type a single start tag (such as <b>) in the upper panel of the Visual Tag Editor.
   • Double-click a tag in the list box.
4. Click OK.

GoLive inserts the start tag at the beginning of the current selection, and a corresponding end tag at the end.

Using the Outline Editor

About the Outline Editor

The Outline Editor, which is available as a tab in the document window, displays HTML elements in a hierarchical, structured view. Using the Outline Editor, you can generate clean, valid source code without typing code. You select elements and attributes from a context-sensitive menu, drag items from the site window or the objects toolbox to the Outline Editor, and use the pick whip to link documents and graphics. You can build documents from scratch, fine-tune your code, and drag elements in the Outline Editor to quickly move elements and their contents in your document.

After checking the syntax of your document and finding errors, you can see an error description next to each element in the Outline Editor where an error is located in your document. You can also highlight all broken links and invalid file references (in red, by default) by using the Link Warnings button on the toolbar while you are working in the Outline Editor.

Note: To use the Outline Editor, the Outline Mode module must be enabled in the Modules preferences.
See also

“Validating the syntax of source code” on page 591

“To activate or deactivate program modules” on page 35

Navigating in the Outline Editor

The outline that appears when you create or view a document in the Outline Editor contains all of the essential elements of an HTML document. You can use this structure as a template and fill it with your own content.

- An element is represented as a box symbol that is labeled with the element’s tag.
- Indents indicate an item’s position within the HTML hierarchy. The head and body elements are indented to show that they are contained within the HTML element. The head element in turn contains a title element.
- Start and end tags are connected by vertical lines to show that they are complementary items.

![Diagram of Outline Editor elements]

To navigate in the Outline Editor

- To collapse or expand the entire outline in the Outline Editor, click the triangle (Mac OS) or +/- sign (Windows) to the left of the HTML element name at the top of the hierarchy.
- To collapse or expand the currently selected element, click the triangle (Mac OS) or +/- sign (Windows) control to the left of the element name, or press Enter (Windows) or Return (Mac OS). This is only possible with binary tags (tags always used in pairs).
- To select a different item in the Outline Editor, click the item or use the arrow keys. The Up Arrow Key selects the item above the current selection, and the Down Arrow key selects the one below. If the cursor is in a text box displaying the contents of an element, the arrow keys move the cursor within the text box.
- To activate the next text box, press Tab. To activate the preceding text box, press the Shift-Tab key.

To move elements or view images in the Outline Editor

- To move an element, drag the handle on the element box to the new location in the outline. To move multiple elements, Shift-click to select them. While you are dragging, Golive displays a horizontal line indicating the element’s new location.
- To view images, select Images in the View palette. If you specified low source (low resolution) images in the More tab of the Image Inspector, you can show the low source images in the Outline Editor by selecting Low Source in the View palette.
Adding elements in the Outline Editor

While working in the Outline Editor, you can quickly add HTML elements along with their start and end tags. You can select an element from a context menu that lists all elements defined in Web Settings, or only the elements that the document's DTD allows within or after the currently selected element. Or, you can define a new element by typing the element's tag directly in the Outline Editor.

When adding an element, you can choose to add the new element either at the same level in the HTML hierarchy as the selected element, or at the next level deeper than the selected element.

See also

"Setting the document type definition" on page 161

To add an element in the Outline Editor

1. In the Outline Editor, select the existing HTML element that is immediately above the location in the outline where you want to add the new element. For example, to add a paragraph element below a table element, select the table element.

2. To add an element at the same level in the HTML hierarchy as the selected element, do one of the following:
   - To choose from a list of allowable elements, right-click and choose Add Item After > By Syntax > [element]. Two boxes representing the start and end tags for the element are added to the outline after the end tag of the previously selected element. (Some elements, such as img or meta elements, cannot have end tags, so only one box is added.)
   - To display a list of elements from the Markup tab of Web Settings, right-click and choose Add Item After > New Element > [element].
   - To enter a new element, right-click and choose Add Item After > New Element > Any, or collapse the existing selected element and click the Add New Element button on the toolbar. Then enter a name for the new element in the text box. The new element is added after the end tag of the previously selected element.

3. To add an element within another element (that is, at the next level deeper in the HTML hierarchy), do one of the following:
   - To display a list of allowable elements, right-click and choose Add Item Into > By Syntax > [element]. The new element is added between the start and end tags of the previously selected element.
   - To display a list of elements from the Markup tab of Web Settings, right-click and choose Add Item Into > New Element > [element].
   - To enter a new element, right-click and choose Add Item Into > New Element > Any or expand the existing selected element and click the New Element button on the toolbar. Then enter a name for the new element in the text box. The new element is added between the start and end tags of the previously selected element.
To add an element attribute with the Outline Editor

You can fine-tune the appearance of your document by adding attributes for an element. Attributes control the way an element is displayed by the browser. Many elements support attributes for specifying special formatting instructions, such as element alignment, color, and directory paths to resource files.

1. In the Outline Editor, select the element you want to add an attribute to.

2. Do one of the following:

   - To choose from a list of attributes defined for the selected element, click the Attributes triangle and choose an attribute from the menu. Or right-click and choose Add Attribute > [attribute].

   ![Using the Attributes triangle](image)

   - To add a new attribute, click the New Attribute button on the toolbar, or right-click and choose Add Attribute > Any. Then enter an attribute name in the text box.

If the attribute is recognized as an enumeration type (such as a color or path), a triangle, color field, path pointer, or comment sign appears to the right of the attribute name.

**Note:** If you are not sure whether an attribute name is valid, refer to the World Wide Web Consortium's (W3C) website at www.W3.org or use GoLive’s Syntax Checker.

3. To specify a value for the attribute, do one of the following:

   - Click the text box to the right of the attribute name, and then enter a value.

   - If there are predefined values for the attribute, the Outline Editor displays the Attribute Values triangle. Click the Attribute Values triangle, and then select a predefined attribute value from the menu.

![Specifying attribute values](image)

   - If the attribute uses a color value (such as a font color), a color field and a color code appear to the right of the attribute name.

   - If the attribute uses a path (such as a path to an image file), a path pointer appears to the right of the attribute name. Click the path pointer, then select a file in the Select File dialog box, and then click OK.
Adding text or comments in the Outline Editor

After adding an element, you can use the Outline Editor to quickly add the contents of that element, such as the text you want to display in your document. For example, you might enter heading text in an h1 element. You can also add a comment for an element, which is any text you want to save but not display in your document when it is viewed in a browser window. Comments are useful for storing notes for editing documents at later dates—for example, if you intend to embed advanced features that require significant background information.

To add text or a comment with the Outline Editor

1. In the Outline Editor, select an HTML element that is immediately above the location in the outline where you want to add the new text or comment.

2. Do one of the following:
   - To add the text or a comment between the start and end tags for the selected element, expand the element and then click the Add New Text button or the Add New Comment button on the toolbar. A text box with default text or comment is added to the outline.
   - To add the text or a comment after the end tag for the selected element or item, collapse the element and then click the Add New Text button or the Add New Comment button on the toolbar.

   Note: You can add a comment anywhere in your document, even before or after the HTML element.

3. Enter your text or comment in the text box. If you temporarily stop entering text and then deselect the text box, you can resume your work by inserting the cursor in the text box.

To add a generic item with the Outline Editor

You can add a generic element or item that contains non-HTML code in your document. For example, you can add a generic item that contains ASP code.

1. In the Outline Editor, select an element or item that is immediately above the location in the outline where you want to add the generic element or item.

2. Do one of the following:
   - To add the generic element or item between the start and end tags for the selected element, expand the element and then click the Add New Generic Item button on the toolbar.
   - To add the generic element or item after the end tag for the selected element, collapse the element and then click the Add New Generic Item button on the toolbar.

   A text box with default text is added to the outline.

3. Click the Subtype triangle and choose a subtype for the generic item, such as ASP, from the menu.

   Using the Subtype triangle to specify the subtype of a generic item

4. Enter the text content of the generic item in the text box. For example, if you selected an ASP subtype for the generic item, enter ASP code in the text box.
**Binary or container tags in the Outline Editor**

You can toggle the binary tag format on and off in the Outline Editor to determine whether a new tag has a complementary end tag or not. Most tags are binary tags, or container tags. Binary tags enclose the content of an element in a pair of tags, called start and end or open and close tags. By default, GoLive displays both parts of a binary tag. A few tags (called unary tags), however, don’t need an end tag. One of the most frequently used unary tags is the `<img>` tag for embedding images.

**To toggle the binary format on and off in the Outline Editor**

You can toggle the binary tag format for the currently selected element only.

1. In the Outline Editor, select an element that has binary tags.
2. Click the Toggle Binary button in the Outline Editor toolbar.

**Adding new elements to source code**

**Adding unknown elements**

HTML is an ever-evolving language, and new elements are created often. To ensure that your documents are always up to date and use the latest technology, you can use the Tag icon to insert placeholders for elements that GoLive doesn’t recognize.

You can also use the Tag icon to prevent GoLive from parsing or changing your source code. After you drag the Tag icon from the objects toolbox to the document window, GoLive adds `</noedit>` and `</noedit>` start and end tags to your source code, and inserts a Tag placeholder in your document in the Layout Editor. You can then enter the code you don’t want parsed in the Content tab of the Tag Inspector. GoLive inserts your code between the `<noedit>` tags without changing it.

**To add an unknown element**

1. In the Layout Editor, drag the Tag icon from the Basic set in the objects toolbox to the document window.

![Tag icon in the objects toolbox](image1.png)

**Using the Tag icon**

* **A.** The Tag placeholder as it appears in the Layout Editor  
**B.** Tag icon in the objects toolbox

2. In the Element tab of the Element Inspector, enter the name of the new element in the Element text box.
3. Click the Create New Item button at the bottom of the Element Inspector. (This activates the text boxes below the list box.)
4. Enter an attribute name in the left text box, and then enter an attribute value in the right text box.
5. To delete the currently selected attribute, click the Remove Selected Items button.

**Note:** To add an unknown element to the head section of your document, drag the Element icon from the Head tab of the objects toolbox to the head section panel of the document window.
To enter code for an unknown element

1. Select the Tag placeholder for the unknown element.

2. In the Content tab of the Element Inspector, enter the source code. You can inspect the code in the Source Code Editor or source code panel.

Working with source code

Dragging objects into the source code

When working in the Source Code Editor, source code panel, Outline Editor, Source Code palette, or JavaScript Editor, you can drag any icon from the objects toolbox into your source code and use it as a starting point for coding the element. You can also drag documents and URLs from the site window to the source to insert a link to the document or URL.

Dragging the QuickTime icon to the Source Code Editor

To modify the appearance of source code

You can use the Source View toolbar in the Source Code Editor, source code panel, CSS Editor Source view, or the JavaScript Editor to choose different themes that affect the appearance of your source code, and to choose whether you want GoLive to display line numbers or wrap your source code at the margins of the editor.

❖ Do one of the following in the Source View toolbar:
   - Choose a theme for the current document from the Theme menu.
   - Click the Colorize Code button  to turn off the colors of all items.

See also

“GoLive source code editors” on page 578

To turn word wrapping on and off in the source code

❖ In the Source Code Editor, source code panel, CSS Editor Source view, or the JavaScript Editor, click the Word Wrap button  in the Source View toolbar.
To show line numbers in source code
❖ In the Source Code Editor, source code panel, CSS Editor Source view, or the JavaScript Editor, click the Line Numbers button in the Source View toolbar.
❖ You can also set options for word wrapping and line numbers in the View palette when you are working in the Source Code Editor.

To look up and insert source code
The GoLive context-sensitive code completion feature enables you to write code without looking up hard-to-remember elements, attributes, or functions. You can use code completion while writing HTML code, as well as other languages such as JavaScript and PHP.

Automatically completing code in the Source Code Editor

1 Begin typing code in the Source Code Editor, source code panel, CSS Editor Source view, or JavaScript Editor.
2 Scroll through the pop-up menu that appears, and then press Enter (Windows) or Return (Mac OS) to select the desired element, attribute, or function.

To compare two files
The Find Differences dialog box lets you compare the source code of two files in a site. GoLive displays differences and lets you set options to control the display.

1 Open a site.
2 Choose Edit > Find > Find Differences.
3 In the Find Differences dialog box, drag the pick whip to the two files you want to compare, or browse for and select the two files you want to compare.
4 Click OK.
GoLive displays the source code of each file in the Find Differences window, and highlights the differences.
5 Click Previous Difference or Next Difference to navigate through different code strings.
6 Customize the view by selecting any of the following Compare Options:
   - **Skip Empty Lines** Skips empty lines in the code.
   - **Show Different Colors** Uses a different color for each code display.
Hide Identical Lines  Hides lines of code that are identical.

Synchronize Scrolling  Scrolls both code displays simultaneously.

Validating the syntax of source code

The GoLive Syntax Checker lets you make sure that one or more documents, or an entire site, contain valid and error-free source code. The Syntax Checker can parse your source code to verify that your documents meet standards of well-formedness, or to verify that your documents are compliant with a particular DTD. Each DTD has different requirements regarding code syntax and the use of elements. The Syntax Checker can use the DTD assigned to the document, or another DTD that you want to check against.

After parsing the source code, the Syntax Checker highlights faulty code elements in the editors, and lists the errors and warnings in the Check Syntax Result window. You can also see the errors next to each element in the Outline Editor where the error is located in your document.

Using the Syntax Checker

A. Compatibility list—select well-formedness, or select the DTDs you want to check compatibility with.  B. Additional elements to allow—select any additional code elements you want to allow in your documents.  C. Location of DTD

See also

“About the Outline Editor” on page 583

“To check syntax” on page 591

To check syntax

1  Do one of the following:

• To check the syntax for all files in a site, open the site.

• To check syntax for a single page, select it in the Files tab of the Site window, or open the page.

2  Choose Edit > Check Syntax, or, if you’ve opened a page, click the Check Syntax button 📋 in the Highlight palette or in the Source View toolbar.
3 Select the DTDs in the Comply With list:

**Well-formedness Only** Checks your document for compatibility with well-formedness standards, but not for compatibility with a DTD or browser set. For example, the Syntax Checker generates error messages for required closing end tags that are missing, attribute values that are required to be enclosed in brackets, or when an attribute is defined more than once. When checking for well-formedness only, the Syntax Checker doesn’t generate error messages for closing end tags that are not required, or for attribute values that are not required to be enclosed in brackets.

**!DOCTYPE assigned** Checks compliance with the DTD for the doctype declared for the document. To use this option, you must have already specified a doctype for the document. (See “Setting the document type definition” on page 161.) The Syntax Checker uses the !DOCTYPE declaration to locate the DTD, which can be on your computer, on a local network, or on the Internet.

*Note:* If the DTD specified for your document is on the Internet, GoLive checks whether the DTD is already cached. If it is, GoLive uses the cached DTD. If it isn’t cached, GoLive displays an alert asking you for permission to access the Internet. If you agree, GoLive downloads the DTD. If you refuse permission, GoLive checks your document for well-formedness, but does not check for compliance with the DTD. The cache is cleared when you quit GoLive.

**A particular DTD (such as HTML 4 Strict)** Checks compliance with that DTD.

4 If you added custom elements or attributes to the Markup tab in Web Settings that are not defined in a DTD, select Elements in the Additionally Allowed list.

5 If you want to allow any additional elements in your document, select the sets of elements in the Additionally Allowed list.

6 To control what to check for and how the Syntax Checker works, select either of the following options:

- **Show Warnings** Checks for syntax warnings. For example, GoLive displays a warning if the value of an attribute is invalid, such as `<body bgcolor= "redd">`. Warnings are much less common than errors.

- **Show Errors** Checks for syntax errors. The Syntax Checker displays an error if it can identify incorrect HTML syntax, or if your document is not compliant with the specified DTD. For example, the Syntax Checker displays an error if your document contains a start tag without a corresponding end tag. For most problems, the Syntax Checker displays errors.

7 Click OK.

GoLive displays errors and warnings in the Syntax Check window, as well as highlighting the errors and warnings in the Source and Outline editors. The Highlight tab in the View palette also opens and displays the total number of errors and warnings.

8 Correct each error, and then follow the steps to check your source code again.

9 Do one of the following:

- To close the Syntax Check window, click OK.
- To create a collection of the syntax results in the currently open site, click Save Collection.

**See also**

“Collections” on page 435
Selecting and highlighting source code

To select items by double-clicking in the source code
Open the Source Code Editor, source code panel, Source Code palette, or CSS Editor source view and do one of the following:

- To select an element and its contents, double-click the angle bracket preceding the element.
- To select only the contents of an element, double-click the angle bracket following the element.
- To select an attribute and its value, double-click the equal sign following the attribute.
- To select only the value of an attribute, double-click the quotation marks preceding the value.
- To select a CSS property and its value, double-click the colon preceding the value.

Selecting elements using the markup tree bar
The markup tree bar at the bottom of the document window provides a navigational tool that makes selecting HTML elements quick and precise, even in complex documents. The markup tree bar represents the current selection in the Layout Editor, Frame Editor, source code panel, or Outline Editor as a path or series of element tags from the root to the currently selected element. For example, with a table cell selected, the markup tree bar displays a path of tags starting with the HTML element, and then the body, table, table row, and table cell elements. When you select an element’s tag in the markup tree bar, the complete element and its contents (including start and end tags) is selected in the document window and in the Source Code palette.

You can use the markup tree bar to select an element within the currently selected element—that is, at the next level lower in the HTML hierarchy. For example, you can select a table row within the currently selected table. Or, you can use the markup tree bar to select an element that is outside the currently selected element—that is, at a level higher or closer to the root. For example, if a table cell is currently selected, you can select the table row or the table where the cell is located.
To select elements with the markup tree bar

1 Display the document in the Layout Editor, Frame Editor, source code panel, or Outline Editor.

2 Do one of the following:

- To select from a list of allowable elements, hold down the mouse button (or drag slowly) on a tag on the markup tree bar and then choose an element from the pop-up menu. Or right-click a tag on the markup tree bar and choose Select Item > [tag]. If the selected element is at the lowest level, such as a table cell, the Select Item menu is not available.

Using the markup tree bar to select an element within another element

- To select an element outside an element (higher in the hierarchy), click any tag currently displayed in the markup tree bar. For example, you can select a table element directly (and all elements within the table such as its rows and cells) by clicking the Table tag.

  The Visual Tag Editor also contains a markup tree bar that works the same way as the markup tree bar in the document window.

See also

“Editing individual elements with the Visual Tag Editor” on page 581

To select the next element higher in the element hierarchy with the Select Upper Block command

❖ With text or an element selected in the Layout Editor, Source Code Editor, or Outline Editor, choose Special > Select Upper Block. GoLive selects the element in the next higher level in the hierarchy.

Highlighting items in the source code or Layout Editor

The Highlight tab in the View palette lets you highlight particular items, warnings, and errors in the Layout Editor, markup tree bar, Source Code Editor, or Outline Editor. For example, you can highlight all elements that contain a URL, all text that has a particular CSS definition, or all syntax and link errors. After highlighting the items, you can use the Highlight tab to select each highlighted item, one at a time.

The Highlight Colors section of the Highlight tab lets you set the highlighting properties (such as colors and borders) of classes of items, such as making all link warnings blue.

  Use the Highlight tab to highlight all elements that have JavaScript actions attached.
Using the Highlight tab in the View palette
A. Select the elements and items in your document you want to highlight.  
B. Number of items highlighted  
C. Click these buttons to select the previous and next highlighted items.  
D. Number of syntax errors and warnings

To highlight elements and other items

1  In the Layout Editor, Source Code Editor, or Outline Editor, choose Window > View to open the View palette.
2  Click the Highlight tab, and do any of the following:
   • To highlight all broken links and invalid file references, click Link Warnings. (You can also show link warnings by clicking the Link Warnings button on the toolbar.)
   • To select the previous or next highlighted item, click the Previous button or the Next button.
   • To highlight one or more particular elements, choose the element(s) from the Elements menu.
   • To highlight text that has a particular CSS definition, choose the definition from the CSS menu.
   • To highlight all elements that have JavaScript actions attached, choose JavaScript Actions from the Special menu.
   • To highlight all items that have a URL, choose Items With URLs from the Special menu.
   • To highlight all text items, choose Text Items from the Special menu.
   • To highlight all comments, choose Comment Items from the Special menu.
   • To highlight all generic items, choose Special Items from the Special menu.
   • To clear all highlighting in the document and all settings in the Highlight tab, click Clear.
   • To rescan after adding new items to the document, click Rescan.

See also
“Validating the syntax of source code” on page 591
“To add a generic item with the Outline Editor” on page 587

To set highlight colors and appearance of items

1  In the Highlight tab of the View palette, click the arrow next to Highlight Colors to expand the section.
2  Do any of the following:
   • To set the color of a category of items (such as all Link Warnings), either click a color field next to a category to select a color in the Color palette, or click the lower right corner of the color field and choose a color from the swatches that appear.
   • To set the color opacity that is applied to a category, drag the color slider next to the category.
   • To set the style of highlighting for each category, click the button to the right of the category to toggle between colored borders or colored background shading.
Note: The settings for Editable Regions in the Highlight tab apply to editable regions in page templates. The settings for Locked Regions apply to locked regions in a document based on a page template.

Locating source code

Locating elements with the Find Code Elements dialog box

Use the Find Code Elements command to find and manipulate elements in a document or throughout an entire site. This feature offers several advantages over the Source Search Mode feature of the Find Text dialog box, which searches for literal text strings. For example, if you use Find Code Elements to search for `<body bgcolor="red">`, you will find perfect matches as well as instances of the element that lack the quotation marks or have other attributes included. In addition, the Find Code Elements command lets you quickly add, delete, or modify attributes of existing elements; delete the content of elements; or replace the plain text contents of elements.

The Find Code Elements dialog box includes three sections:

Find options  Let you select search criteria, including elements and attributes.

Change options  Let you specify changes or actions that you want carried out on any elements or attributes found during a search.

Work On options  Let you specify the scope of a search: one file, several files, an entire site or collection, or a list of previous results. You can also preview and modify the list of files that you want changed by the specified actions, before you have GoLive carry out the actions.

The Find Code Elements dialog box

A. Search section  B. Action section  C. Work On section

By default, the Find Code Elements dialog box appears in structured mode, which enables you to perform a structured search without any coding knowledge. If you want to enter complex search criteria, click Advanced.
To search for elements


2. In the Find section, specify Element options as follows:
   - From the Element menu, choose Is or Matches.
   - In the Element text box, type the name of the element you’re searching for or choose an element from the menu.

3. For a structured search, choose the attribute in the Attribute menu in the Find section, and choose an operator and attribute value in the menus that follow. To add another attribute to the search, click the Add button, and then specify another attribute, operator, and attribute value.

4. (Optional) For an Advanced search, click Advanced and do the following in the Find section:
   - To search for attributes and attribute values, type them in the text box, or select attributes and operators from the Attribute and Operator menus.
   - To search for elements by comparing attribute values, type two attributes and an operator. For example, to search for elements that have a width greater than the height, type the following: `height > width`.
   - To search for the plain text contents of an element, enter the keyword `content`, an equal sign operator, and the text contents in quotes. For example, to search for all occurrences of “June” (no style applied) in the element you specified, type the following: `content = “June”`.

   After specifying the search criteria for plain text, you can specify the text you want to use as a replacement. For example, you can replace all occurrences of “June” in a specified element with “July.” To replace the text contents of an element, use the Replace Content action. (See “Editing elements in multiple files with the Find Code Elements dialog box” on page 598.)

5. Click the Work On menu and do one of the following:
   - To search a currently open site, choose `[site name] > The Whole Site`.
   - To search the files in a specific tab of a currently open site, choose `[site name] > [site tab].` 
   - To search a file that is selected in the site window, choose The Site Selection. You can also drag a file from the site window to the Find Text dialog box.
   - To search files in unopen sites, choose Add Files. Navigate to and select the files that you want to search, then click Open. GoLive adds the selected files to the search list.
   - To search within a previous result set (an open list of matches that resulted from a previous search), choose Result List from the Search In menu.

6. To exclude items from the search, deselect them by clicking in the corresponding box to remove the check.

7. Click Find All. GoLive displays the hits in the Result window.

To save Find Code Elements search results for use in another search

In the Result window, do one of the following:

- To search for another element within the result set, click Use Result. You can remove files from the result set by selecting them and clicking Remove.
- To save the results as a collection in the currently open site, click Save Collection, type a name for the collection in the Create A New Collection dialog box, and then click OK (a site must be open for the Save Collection option to be available). Saved collections are displayed in the Collection tab of the Site window.
See also
“Collections” on page 435

Editing elements in multiple files with the Find Code Elements dialog box
In addition to simply finding elements, you can manipulate elements in a variety of ways by using these commands on the pop-up menu in the middle Change section:

- **Keep** Keeps the element and sets, updates, or deletes its attribute.
- **Rename** Renames the element, but keeps the element's contents. You can keep the element's attributes or change them with an Attribute action.
- **Delete With Content** Deletes the element completely, including its start and end tags as well as its contents.
- **Replace By Its Content** Deletes only the element's start and end tags, leaving its contents untouched.
- **Delete Content Only** Deletes only the contents of the element, leaving its start and end tags in place.
- **Replace Content** Replaces only the contents of the element, leaving its start and end tags in place. This command works on plain text contents only—for example, text that has a style applied to it, such as bold, is not affected by this command.

To modify an existing element
1. Define the search criteria and scope of the search. (See “Locating elements with the Find Code Elements dialog box” on page 596.)
2. In the Change section of the Find Code Elements dialog box, choose Keep from the Element menu.
3. In the Change section, choose an attribute from the Attribute menu, or type an attribute in the text box.
4. Choose one of the following options from the pop-up menu to the right of the Attribute menu:
   - **Set To** Sets the specified attribute and value for the element whether or not the attribute already exists.
   - **Update To** Updates the attribute only if it already exists in the specified element. It does not add the attribute.
   - **Remove** Removes the attribute and its value wherever it appears.
5. Choose an attribute value or type a value in the third Attribute text box.
6. To add another change attribute, click the Add Attribute button and then specify another attribute, operator, and attribute value.
7. Click Apply To All to begin the search and carry out the specified action.

You can also create multiple Attribute actions to be performed during a Keep Element action. Click the Add Attribute button and follow the steps outlined here before you click Apply To All. GoLive performs each Attribute action defined in the Change section. You can remove an Attribute action by selecting it in the list and clicking the Remove Attribute button.
To rename, delete, or replace an existing element

1 Define the search criteria and scope of the search. (See “Locating elements with the Find Code Elements dialog box” on page 596.)

2 In the Change section of the Find Code Elements dialog box, do one of the following:
   - Choose Rename from the Element menu. Then type a new element name in the New Name text box. (You can create Attribute actions for a Rename Element action, if desired.)
   - Choose Delete With Content from the Element menu.
   - Choose Replace By Its Content from the Element menu.

3 Click Apply To All to begin the search and carry out the specified action.

To replace the plain text contents of an element

1 Define the search criteria and scope of the search. (See “Locating elements with the Find Code Elements dialog box” on page 596.)

2 In the Change section of the Find Code Elements dialog box, choose Replace Content from the Element menu. Then type the replacement text in the Content text box. It is not necessary to use quotes around the text.

3 Click Apply To All to begin the search and carry out the specified action.

To delete the contents of an element

1 Define the search criteria and scope of the search. (See “Locating elements with the Find Code Elements dialog box” on page 596.)

2 In the Change section of the Find Code Elements dialog box, choose Delete Content Only from the Element menu.

3 Click Apply To All to begin the search and carry out the specified action.

Saving and reusing a search task

After you specify the settings for a search task, you can save the settings for later use.

1 Choose Save Search from the Find Code Elements window menu.

2 Type a name and click Save.

3 To reapply a saved task, choose Load Search from the Find Code Elements window menu.

4 Select the desired task, and then click Open.

5 Select the files you want to apply the task to in the Search In section.

6 Click Find All.

To reapply a recently saved task, choose the task from the Find Code Elements window menu.
Navigating through source code

Navigating source code by function
The Navigate Through Code menu in the Source Code Editor, JavaScript Editor, and CSS Source Code Editor toolbars lets you navigate through code by function. In addition, you can add custom markers to the source code and Navigate Through Code menu for navigating.

If you're using the JavaScript Editor, navigate using functions of languages such as JavaScript, VBScript, ASP, Perl, and Java. If you're using HTML, you navigate through HTML code using tags that contain the name attribute. If you're using CSS, you can navigate through the code using CSS definitions in the CSS Editor.

To navigate through source code
❖ Choose a function from the Navigate Through Code menu.

💡 The Navigate Through Code menu lists functions in the order they appear in the code. If you want to view the list of functions alphabetically, Control-click (Windows) or Alt-click (Mac OS) the Function menu.

To add or remove markers in the source code
1 In the Source Code Editor, JavaScript Editor, or CSS Source Code Editor, click to place an insertion point in the line of code you want to mark.
2 Choose New Marker from the Navigate Through Code menu.
3 Type a name for the marker in the Add Marker dialog box and click OK.

Inserting or rewriting source code automatically

To rewrite source code automatically
You can use GoLive to automatically rewrite source code that you manually entered yourself. GoLive rewrites the code with indents and line breaks, changes the case of tags and attributes, and sets quotes for attribute values as specified in the Rewrite Source Code dialog box.

1 Open a page, or select multiple pages in the Files tab of the Site window.
2 Choose Special > Source Code > Rewrite Source Code.
3 Specify options as desired. Click No Change to revert any unwanted changes you've made.
4 Click OK.

Inserting text code by using text macros
Text macros can save you time if you frequently use the Source Code Editor and the JavaScript Editor. They eliminate typing lengthy strings of source code for often-used tags and script elements.

The text macros are stored in an editable file, Default.macro, that resides in a special Code folder within the Settings folder in the GoLive program folder.
The Default.macro file can hold any combination of text, HTML or CSS elements and JavaScript strings. Where you can use a given macro definition depends on its type attribute. If the type is set to "all," the macro will be available in all editors, including a simple text document window. If the macro has one of the other type attributes, it is only available in the corresponding editor.

The Default.macro file is loaded when GoLive starts up to make it available throughout the application.

**See also**

“To insert text macros into the source code” on page 601

**To insert text macros into the source code**

Text macros are case-sensitive, which means that you must type them exactly as the name was defined in the macro file.

❖ To insert automated source code, type the macro name and press Shift+Ctrl+M (Windows) or Shift+Command+M (Mac OS). This inserts the text macro identified by the word behind or below the text cursor, provided it exists in the default source macro file.

**Defining text macros**

You define text macros by opening the Default.macro file with GoLive or a text editor and then typing, copying and pasting, or dragging the appropriate code. You can also create your own macro files. Macro files are read in order and the first definition encountered is used where more than one macro definition shares the same name and syntax context. Text macro definitions must have the following basic format:

```xml
<macro name="XY" type="Syntax-Context"><![CDATA[macro-content]]></macro>
```

The first element in a macro definition is the macro name and type, which defines the syntax context. The value of type may be "all", "html", "css", "javascript", "php" or the exact value of the name attribute of a syntax element defined in the Default.syntax settings file or any other installed *.syntax files. With the exception of spaces and tabs, you can use any combination of characters for a macro name, but you should restrict yourself to using letters and digits to avoid using characters which have special meaning in a given syntax context.

The second element specifies the content of the macro—that is, the CDATA tag specifies the replacement text. The selection in the replaced text is defined by the percent character (%). If you require a different selection character, you can add the attribute, "selchar=(character)".

For example, an image element macro with basic attributes could look like this:

```xml
<macro name="image" type="html"><![CDATA[<img src="../GIFS/%???%.GIF" width="20" height="20">]]></macro>
```

You can also use a text macro to insert a string of formatted text. Here is an example:

```xml
<macro name="webdesign" type="html"><![CDATA[This Website was designed using GoLive.]]></macro>
```

**Automating insertion point placement and text selection in text macros**

You can place the insertion point or select text for overtyping anywhere in the insert.

Placing the insertion point in an insert is accomplished by adding an empty selection at the point you wish the cursor to appear. Here is an example:

```xml
<macro name="image" type="html"><![CDATA[<img src="%" width="20" height="20">]]></macro>
```
This places the insertion point so that you can enter the attribute value without having to move the cursor to the desired location.

Selecting text for overtyping is accomplished by enclosing a placeholder word or string within selection characters. Here is an example:

```html
<macro name="image" type="html" [CDATA[<img "src=../GIFS/%???%.GIF " width="20" height="20">]\]>></macro>
```

The three question marks enclosed in quotes will be selected when you insert this example macro, allowing them to be overtyped.

**Using keywords as substitutes for control characters in text macros**

As already noted, you can use three control characters to specify what happens when a text macro is inserted:

- Single quotes (\') mark out a selection.
- The vertical bar places the insertion point.
- Dollar signs are used to reference another text macro.

Now and then, syntax rules may require that you insert a macro with any of those characters in it. For example, JavaScript syntax requires that text strings be enclosed in single quotation marks. This conflict is solved by substituting percent signs (or any other suitable character) for single quotation marks. The GoLive Text Macro tool has three built-in keywords that allow you to redefine control characters:

- **Selection** lets you redefine the selection markers if single quotes are not allowed. Here is an example:
  
  ```javascript
  Selection = %
  write(document, write('%what%'))
  ```

- **Caret** lets you redefine the insertion point marker if the vertical bar is not allowed—for example, because it is used to express a bitwise OR operation in JavaScript.
  
  ```javascript
  CARET = %
  ```

- **Macro** lets you redefine the dollar signs enclosing a macro name.
  
  ```javascript
  MACRO = %
  ```

**JavaScript**

**Using JavaScript**

The GoLive built-in support for JavaScript and JScript lets you add interactivity to your documents, verify form input, enhance visual displays, and dynamically control the browser. The JavaScript Editor lets you build scripts in the application, embed them in your document, and test them immediately by launching the targeted browser.

**Note:** Not all browsers implement JavaScript in the same way. Test all JavaScripts on all of your target browsers.

To make it easy for you to add JavaScript, GoLive provides a complete inventory of building blocks for all major JavaScript dialects and versions. Whenever you drag a Script icon from the objects toolbox to the head section panel, you specify the targeted application in the Inspector, which then configures the JavaScript Editor accordingly. Combined with the ability of JavaScript to identify browsers, this feature makes it easy for you to build documents with multiplatform support.
You can become familiar with the JavaScript environment in GoLive by entering JavaScript expressions into the JavaScript Debugger accessed from the Special menu. This window provides a command line you can use to communicate interactively with the JavaScript engine built into GoLive. For more information on using the JavaScript Debugger, see the SDK documentation.

See also
“Source preferences” on page 578

To set up a JavaScript
You can add JavaScripts to your document. You can also insert JavaScripts in the head section panel of the document window to allow a script to be executed while the visible section of the document is still being loaded.

1 Do any of the following:
   • To add a JavaScript to the body section of a page, drag the JavaScript icon from the Basic tab of the objects toolbox to your document window.
   • To add a JavaScript to the head section of a page, drag the Script icon from the Head tab of the objects toolbox to the document window or the head section panel.

2 If it’s not already selected, select the JavaScript icon in the document window, or the Script icon in the head section panel.

3 In the Inspector, enter a descriptive name in the Name text box. Choose a target browser from the Language menu. The language version corresponding to your browser selection appears in the text box below the menu.

4 To reference an external script file (which must have the .js extension), select Source and do one of the following:
   • Enter a resource locator for your script file.
   • Click the Browse button to select a script.
   • Drag from the pick whip in the Inspector to a script in the site window.

JavaScript Editor toolbar items
When using the JavaScript Editor, you can use the following items on the JavaScript Editor toolbar:

Toggle Error Display button Shows and hides a panel in the top section of the JavaScript Editor. After you check the syntax of your code, any errors are listed in the error display panel. You can move the cursor where an error is located in your code by clicking the error in the error display panel.

Check Syntax button Checks the syntax of your code. If any errors are found, the error display panel opens (if it’s not already open) and the cursor is placed where the first error is located in your code.

Show Errors button Shows the number of errors to the right of the button.

Show Warnings button Shows the number of warnings to the right of the button.

Word Wrap button Toggles the wrapping of source code at the margin of the JavaScript Editor on and off.

Numbers button Shows the code line numbers.

Colorize Code button Turns off the color for all items.

Theme menu Enables you to choose a theme for the current document.

Navigate Through Code menu Enables you to navigate through code.
See also
“Navigating source code by function” on page 600
“Source preferences” on page 578

To edit an existing JavaScript
1 To open the JavaScript Editor, do one of the following:
   • Double-click the JavaScript icon in the document window.
   • Select the JavaScript icon in the document window, and then click the Edit button in the Inspector.
2 If the icons on the toolbar in the JavaScript Editor are inactive, choose a script name from the list at the left side of the JavaScript Editor.

Create event definitions by entering event codes in the Event Code text box.

3 Choose an option from the View menu, and then drag an object from the Object list in the Script Inspector to the JavaScript Editor window. For example, choose Events from the View menu to display a list of JavaScript events that you can insert in your JavaScript.

4 In the Script Inspector, enter event code in the Event Code text box to create event definitions.

Choose a function declaration from the Navigate Through Code pop-up menu in the JavaScript Editor toolbar to navigate directly to that location in the script. (See “Navigating source code by function” on page 600.)

5 Close the JavaScript Editor to save your work.

6 Do one of the following to open your web page in the browser you selected for previewing and testing in the Preferences dialog box:
   • Choose File > Preview In > Default Browser.
   • Click the Preview In Browser button on the toolbar.

Sample JavaScript code
The following sample JavaScript code shows how to use a simple JavaScript to display the time and date obtained from the viewer’s operating system.
JavaScript sample code and result

- The `document.write()` method on the “Your Local Time” line writes an H1-formatted text string from the document to the screen of the browser.
- The `new Date()` method creates a new date object containing the long version of the current date from the viewer’s operating system. This object is assigned to `currtime`.
- The last line is output to the browser’s screen using a `document.write()` method, with the embedded `currtime` variable set to the current time and date.

JavaScript libraries

Shifting code to an external library
GoLive can automatically create an external JavaScript library file that stores shared code from JavaScript actions, rollovers, dynamic components, and animated scenes created in the DHTML Timeline Editor. At the same time, it replaces the shared code in the page with a reference to the library file, leaving only page-specific declarations and parameters in place. The library is then uploaded to the web server to make it available for every page in the site that needs the script.

Benefits of using external JavaScript libraries
Apart from streamlining the code in your pages, this library offers two advantages:

- It remedies a problem associated with the structure of dynamic GoLive components: GoLive invariably places common code for DHTML items and actions in the head section of a page. While this structure works well with “straight” pages, problems could occur in earlier versions when a dynamic component contained DHTML items and scripted actions. As the browser loads only the body section of a dynamic component, it ignores any script code contained in the head section. This problem can be solved by using the external JavaScript library, making JavaScript code in dynamic components work as expected.
- The browser caches the JavaScript library file and less code is written into every page, making the pages load faster.

The JavaScript library
You can choose the external JavaScript library feature on a per-page basis, as a site-wide setting, or as an application-wide preference. If you choose the option in the application preferences or site settings, all new pages and existing pages without preexisting JavaScript will use the new preference setting. Pages that already had actions and other JavaScript added to them will retain their existing JavaScript Functions setting. You must change the setting for these pages in the HTML tab of the Page Inspector.
To set the JavaScript library preference

1. Do one of the following:
   - To affect all new pages, set the application JavaScript library preference: Choose Edit > Preferences, and select Script Library from the list on the left.
   - To affect all new pages in a site window, set the JavaScript library preference in the site settings: Click the Site Settings button in the toolbar, select Script Library from the list on the left, and select Site Specific Settings on the right.
   - To set the preference for a single page, open the HTML tab of the Page Inspector.

2. Use the JavaScript options as follows:
   - To have GoLive write any required JavaScript code into the pages, select Write Code Into Page.
   - To shift all shared JavaScript to an external JavaScript file, select Import GoLive Script Library. The file is saved to a folder named Generated Items by default.

If you select the Import GoLive Script Library option, GoLive reacts in one of two ways, depending on whether or not you have a site document open:

   - If the site document is open, it will create a library file in a new folder named Generated Items at the root level of the site folder when you save the page.
   - If you don't have a site document open in the background when you save the page, GoLive writes the code to a default library file, which can be found in the Modules/JScripts/GlobalScripts subfolder of the GoLive application folder.

*Note: Selecting the Import GoLive Script Library option in the Preferences or Site Settings dialog boxes does not modify the Script Library settings for pages that contained preexisting JavaScript. To move code from those pages to the library, select Import GoLive Script Library in the HTML tab of the Page Inspector for each page.*

3. To rebuild the JavaScript library if it is damaged, click Rebuild in the application JavaScript preferences or in the Site Settings dialog box.

4. Type a folder name for the JavaScript library and a library name with the suffix .js.

Flattening the script library

The external JavaScript library file contains the entire GoLive JavaScript library even if your pages don't use all of the functions within it. You can flatten the file to remove any JavaScript that is not used in the site. Flattening reduces the library's file size and decreases its download time. You can manually flatten the library file of a single site, set a site's Site Upload or Export preferences to automatically flatten the library file, or set the application preferences to flatten the library file of all sites before upload or during export.

To manually flatten the JavaScript library of a single site

❖ Open a site window and choose Site > Update > Flatten Script Library.

To set a site to flatten the JavaScript library upon upload or export

1. In the Site Settings dialog box, select Upload/Export.
2. Select Site Specific settings.
3. Select Flatten Script Library and click OK.
To set all sites to flatten the JavaScript library upon upload or export

1. Choose Edit > Preferences.
2. Expand Site and select Upload / Export.
3. Select Flatten Script Library and click OK.
Chapter 26: Using actions

Actions overview

About actions
Adobe GoLive provides a complete set of pre-built actions—scripts triggered by events. These events may be browser-triggered, such as loading a page, or user-triggered, such as moving the pointer over an image. Actions also can be triggered by a point in time in a timeline sequence. To facilitate setting up actions, the Actions tab displays the selected item at the bottom (to ensure that you're working with the right tag), and the Action menu displays recently applied actions at the top (for quick selection).

You should always preview actions in a variety of web browsers and platforms to determine potential browser differences or incompatibilities. The earliest browser versions that support each action are displayed next to the selected action name in the Actions palette.

To highlight actions in the document window
❖ From the Actions palette menu ☰, choose Highlight Rollovers & Actions.

User-triggered actions are highlighted in the Layout Editor, Source Code Editor, Outline Editor, and markup tree bar. Browser-triggered and timeline-triggered actions highlight the body section of the page.

To filter actions based on browser compatibility
To ensure that particular versions of Internet Explorer and Netscape Navigator support the actions you choose, set an action filter. If an action is not supported by the browsers selected in the action filter, the action will appear dimmed in the Action menu.

1 From the Actions palette menu ☰, choose Set Action Filter.

2 Select the earliest Netscape Navigator version and Internet Explorer version that you want to support.

To remove recent actions from the Action pop-up menu
The upper part of the Action pop-up menu lists recently used actions. You can clear this list if it becomes too long.
❖ From the Actions palette menu ☰, choose Reset Action Menu.
Browser-triggered actions

Browser-triggered actions
Browser-triggered actions take place automatically as the result of browser activity or when the action is “called” (triggered) by another action. You can set up a browser-triggered action to take place as a page loads, when the page is finished loading, when the browser loads a specific line of code in the body or head section of a page, or when another action triggers the action.

To set up a head action
1. Drag the Head Action icon from the Smart Objects set of the objects toolbox to the page or choose Insert Object > Smart > Head Action from the context menu in the head section of the page.
2. In the Actions palette, select a trigger option from the Events list to specify how and when the action executes:
   - OnLoad  Triggers the action after the browser has loaded the page.
   - OnUnload  Triggers the action when the browser leaves the page.
   - OnParse  Triggers the action when the browser reads that section of the source code. This triggers the action before any user interaction occurs.
   - OnCall  Triggers the action later in the browser session by using the Call Action action.
3. Choose an action from the Action menu, and set the action's properties.

To set up a body action
1. Drag the Body Action icon from the SmartObjects set of the objects toolbox to the document window or choose Insert Object > Smart > Body Action from the context menu in the body section of the page.

   There are no trigger options to set up. The action triggers automatically when the browser loads the page section in which the body action resides.
2. Choose an action from the Action pop-up menu, and set the action's properties.

User-triggered actions

User-triggered actions
User-triggered actions occur when a user interacts with some item on the page such as an image, rollover, text, or form element.

GoLive includes the following user triggers:

Mouse Click  Triggers an action after a single mouse click on the linked item.

Note: If you apply a Mouse Click action to a rollover object, the rollover's navigational link (the URL field in the Inspector) is disabled. To set the rollover's link, add Goto Link as the last action for the Mouse Click event. See “Goto Link” on page 615.

Mouse Enter  Triggers an action when the pointer is moved over the linked item.

Mouse Exit  Triggers an action when the pointer is moved away from the linked item.
Double Click  Triggers an action when the viewer double-clicks the linked item.

Mouse Down  Triggers an action when the viewer presses the mouse button while the pointer is over the linked item.

Mouse Up  Triggers an action when the viewer releases the mouse button while the pointer is over the linked item.

Key Down and Key Press  Triggers an action when the viewer presses any key.

Key Up  Triggers an action when the viewer releases any key.

Key Focus (form fields only)  Triggers an action when the field is selected, an insertion point is placed in the field, or when the viewer tabs to it.

Text Change (form fields only)  Triggers an action after text is entered into the field and another field is selected.

Key Blur (form fields only)  Triggers an action when the viewer tabs out of the field.

To set up a user-triggered action
1  In the Layout Editor, select text or an object on the page.
2  In the Actions palette, select a trigger option from the Events list. (See “User-triggered actions” on page 609.)
3  Click the Create New Action button.
4  Choose an action from the Action pop-up menu, and set the action's properties.

To remove all actions from a trigger
❖ Select the user triggered action (linked text, linked objects, or form objects) in the page, and choose Delete All Actions from the Actions palette menu.

Timeline-triggered actions

Timeline-triggered actions
Timeline actions are triggered at the point in time they are located in the DHTML Timeline Editor. In this way, you can initiate time-based actions or actions that interact with a given scene.
Setting up timeline-triggered actions in the DHTML Timeline Editor.

See also
“Using the DHTML Timeline Editor” on page 260

To set up a timeline-triggered action
1. Choose Special > DHTML Timeline > Open Editor.
2. Ctrl-click (Windows) or Command-click (Mac OS) the Actions Track of the DHTML Timeline Editor to insert an action placeholder.
3. In the Actions palette, click the New Item button.
4. Choose an action from the Action pop-up menu, and set the action’s properties.

To delete a timeline-triggered action
❖ Select the action in the Actions Track of the DHTML Timeline Editor, and press Delete.

Getters actions

About Getters actions
The Getters menu in the Actions palette contains actions that work with web page forms and layers.

Field Validator
The Field Validator action validates an entry in a form text, text area, or password field. If the action is applied to a text field, the action is triggered when the viewer tabs out of the field, or enters text in the field and then selects a different field. The action uses one of seven validation criteria.

Select a form text, text area, or password field. In the Actions palette, select a trigger option: Select the Key Blur event for validating entries when the viewer tabs out of the field or the Text Change event for validating entries when the viewer enters text and then selects another field. Choose Action > Getters > Field Validator.
Type the name of the form that contains the text field, and the name of the text field to validate. Select a validation criterion from the Validation to Perform pop-up menu. If you choose the Field Has This Many Characters option, define a numerical value in the # Of Characters text box. If you choose the Field = Exact Text String option, type the text viewers must enter in the field in the Exact Text String text box.

Type an alert message to display if the field entry is not valid.

**Note:** If there are adjacent fields with Field Validator actions assigned to Key Blur events, separate the fields with a field that doesn't have a Key Blur event. Or separate the fields with a label, and assign a tabbing order to the field and labels. (A label must contain at least one character, but you can make it appear blank by entering a space character.)

### Get Layer Position

The Get Layer Position action reads the current position of a layer. You can process this information using, for example, an Idle action that moves a second layer to the current position of that layer. This creates the impression that the second object trails the first.

Trigger the action with a browser-triggered event set to OnCall in the head section of the page. In the Actions palette, choose Action > Getters > Get Layer Pos. Select OnCall from the Events list and give the action a unique alphanumeric name.

Set up a timeline-triggered action to retrieve the layer coordinates from the Get Layer Position action. Some actions you can consider using include Move By and Move To. Either of these actions can be used alone or in combination with a Condition or Idle action. When setting up a Move By or Move To action, click the red “C” icon adjacent to the Position property twice until it changes to a green question mark icon, and choose the Get Layer Position action name from the menu.

**See also**

“Move By” on page 623

“Move To” on page 624

“Condition” on page 633

“Idle” on page 634

### Get Form Value

The Get Form Value action reads the content of a form text, text area, or password field in the current page. This action depends on input from the viewer in the form text field.

Trigger the action with a browser-triggered event set to OnUnload (or OnCall if you attach it to a form image that serves as a Submit button). In the Actions palette, choose Action > Getters > Get Form Value. Enter the name of the form in the Form text box and the name of text field in the Element text box.

If your form contains more fields you want to have read, insert more Get Form Value actions and set them up as required. Set up companion actions that process the result—for example, a Set Cookie action that stores the contents of various Get Form Value actions on the viewer's hard disk.

**See also**

“WriteCookie” on page 638
Image actions

About Image actions
The Image menu in the Actions palette contains actions that enable you to preload images, set an image to automatically change based on certain criteria, and create remote rollovers.

DailyImageURL
DailyImageURL lets you display a different image for each day of the week, according to the date in the viewer’s computer. For example, you can create a banner that changes daily when the page is loaded, or you can create an image viewers can click to replace with the picture of the day.

In the page, select the image you want to replace based on the day of the week. In the More tab of the Image Inspector, enter a unique alphanumeric name in the Name text box.

Tip: Normally, all images will display with the dimensions of the placeholder image. To enable the images to display with different dimensions, change the placeholder image's Width and Height values from Pixel to Image in the Image Inspector.

Trigger the action with a browser-triggered event set to OnLoad, or a user-triggered event. Choose Action > Image > DailyImageURL. Choose the placeholder image's name from the Image menu. (This is the image that is replaced with another image for that day.) For each day, reference the image you want to replace the base image.

Preload Image
The Preload Image action forces the browser to cache specified images before the page displays. This is useful if there are images that don't display until after a user interacts with the page, such as a rollover image, or until a certain point in time. Although the page may take longer to load initially, preloaded images are immediately available when loading is complete. Preloading images enables rollover images to display faster when the viewer interacts with them, and DHTML animations and actions can immediately swap images.

Note: The rollover images referenced in a GoLive Rollover object are automatically preloaded. An additional Preload Image action is not required for it. An Image object with rollover states has a Preload option that can be selected in the Image Inspector.

Trigger the action with a browser-triggered event set to OnLoad. In the Actions palette, choose Action > Image > Preload Image. Reference an image file you want to preload.

If you need to preload multiple images rather than adding a new Head Action icon for each image, set up one Head Action icon with the Action Group action and add each Preload Image action to it. (See “Action Group” on page 633.)

RandomImage
The RandomImage action randomly swaps the contents of an image placeholder with one of three images each time the page is loaded.

In the page, select the image you want to replace, and in the More tab of the Image Inspector, enter a unique alphanumeric name in the Name text box.

Tip: Normally, all images will display with the dimensions of the placeholder image. To enable the images to display with different dimensions, change the placeholder image's Width and Height values from Pixel to Image in the Image Inspector.
Trigger the action with a browser-triggered event set to OnLoad, or a user-triggered event. Choose Action > Image > RandomImage. In the Base Image pop-up menu, choose the base image you want to have replaced. Reference each of the alternate image files.

**Important:** You must reference all three images to replace the placeholder image; otherwise the image will randomly appear as an empty reference.

**Set Image URL**

The Set Image URL action lets you create remote rollovers, also known as secondary or disjointed rollovers, which swap the content of a placeholder image when the viewer interacts with other content on the page. You can also set up multiple timeline-based Set Image URL actions to create a slide show.

In the page, select the image placeholder you want to replace, and in the More tab of the Image Inspector, enter a unique alphanumeric name in the Name text box.

Normally, all images will display with the dimensions of the placeholder image. To enable the images to display with different dimensions, change the placeholder image’s Width and Height values from Pixel to Image in the Image Inspector.

Trigger the action with a user-triggered or timeline-triggered event. Choose Action > Image > Set Image URL. Choose the image you want to replace from the Image pop-up menu and reference the image that will replace the base image.

To restore the base image to its original image, trigger a second mouse event (such as Mouse Exit), key event, or timeline event, and set up a Set Image URL action that specifies the same placeholder image and references the original base image.

**Link actions**

**About Link actions**

The Link menu in the Actions palette contains a wide variety of actions that link to new pages or files, redirect a browser depending on certain criteria, or work within a frame set.

**CSS Redirect**

The CSS Redirect action applies a particular external cascading style sheet to the web page if the action detects a specified platform and browser.

Trigger the action with a browser-triggered event set to OnParse in the head section of the page. In the Actions palette, choose Action > Link > CSS Redirect. Choose a platform and browser from the pop-up menu, and reference the external style sheet that will be used if the selected platform and browser are detected. Add additional Head Action icons, and repeat for any additional platform and browser-specific external cascading style sheets.

**Close Window**

The Close Window action closes the current window. Some browsers will prompt the user to approve or cancel the window closure.

Trigger the action with a user-triggered or timeline-triggered event. Choose Action > Link > Close Window.
ConfirmLink
ConfirmLink displays a confirmation dialog box before loading the linked page. This enables the viewer to confirm whether they want to go to the link or remain on the current page.

Trigger the action with a user-triggered event. In the Actions palette, choose Action > Link > ConfirmLink. Enter the confirmation message in the Message text box. You can force a line break within the message by typing \n. Reference the page you want to link to in the Go To This URL on OK text box. If the current page is in a frame set, enter the frame name you want the linked page to appear within in the Target Frame Name text box. Or leave it blank to replace the entire frame set with the linked page.

DailyRedirect
DailyRedirect lets you display a different web page for each day of the week, based on the date set in the viewer’s computer.

Trigger the action with a user-triggered event, browser-triggered event set to OnLoad, or timeline-triggered event. Alternatively, to trigger the action when the viewer leaves the current page, use a browser-triggered event set to OnUnload. Choose Action > Link > DailyRedirect. For each day of the week, reference a page in your site or an external URL you want to display.

ForceFrame
ForceFrame prevents a page that appears within a frame set from being viewed outside of the frame set. For example, a search engine might link directly to a web page that is supposed to appear in a frame of a frame set page. With ForceFrame, a browser that loads the search engine’s link to your page would load the entire frame set page instead of just the single page. This action is particularly useful if the other frames in your page contain elements such as banner logos that identify your site, or buttons for navigating through the site.

Trigger the action with a browser-triggered event set to OnLoad. The trigger can be applied to all pages that appear within the frame set, but not to the frame set document. In the Actions palette, choose Action > Link > ForceFrame. For the frame set link destination, reference the frame set page in which you want to contain the current page. For Frame, enter the name of the frame in which you want the content page to appear.

Go Last Page
The Go Last Page action forces the browser to jump to the last page visited.

Trigger the action with a user-triggered or timeline-triggered event. Alternatively, to trigger the action when the viewer leaves the current page, trigger the action with a Head Action icon set to OnUnload. Choose Action > Link > Go Last Page.

Goto Link
The Goto Link action links to a page in your site or an external URL. If applied as a timeline-triggered action, the Goto Link action can be used to link to a new page at a certain point in time. If applied as a browser-triggered action set to OnCall, this action can be used to make it easier to maintain links that reference the same URL. In this example, you would apply the Call Action to the links to trigger the Goto Link.
Trigger the action with a user-triggered event, browser-triggered event set to OnCall, or timeline-triggered event. Alternatively, to trigger the action when the viewer leaves the current page, use a browser-triggered action set to OnUnload. Choose Action > Link > Goto Link. In the Link text box, reference a page or URL. If the current page is located in a frame set, enter the frame name you want to target in the Target text box, or leave it blank to have the link replace the current frame.

To link to a URL that you retrieve from a variable, click the small red “C” icon adjacent to the pick whip to change it to a blue circle icon, and choose a variable from the pop-up menu. To link to a URL that you retrieve from a browser-triggered action set to OnCall in the head section, click the icon again to change it to a question mark, and select an action from the pop-up menu.

**See also**

“Call Action” on page 633

**Key Press**

The Key Press action triggers another action when the viewer presses a specified key. You can set one to four keys to trigger different actions.

Before you add the Key Press action, create up to four browser-triggered actions that will be triggered by a key press event and set each to execute OnCall. Enter an alphanumeric name for each action in the Name text box of the Actions palette. Trigger the Key Press action with a browser-triggered event set to OnLoad. Choose Action > Link > Key Press. Enter a single number or lowercase letter in a Key text box and choose an action name from the pop-up menu.

**Note:** There can only be one Key Press action in a page. If a second Key Press action is added, the first Key Press action will not function.

**KillFrame**

KillFrame prevents pages from being loaded into a frame of a frame set. You can use this action to prevent a different website from displaying your page in a frame, and their logo or advertising in another frame on their web page.

Trigger the action with a browser-triggered event set to OnLoad. Choose Action > Link > KillFrame.

**Navigate History**

The Navigate History action makes the browser jump backward or forward through the browser’s history of links by a specified number of pages.

Trigger the action with a user-triggered or timeline-triggered event. Choose Action > Link > Navigate History. To go backward in the history of links, enter a negative integer in the Go Where text box. To go forward, enter a positive integer.

**Open Window**

The Open Window action lets you open a link in a new browser window on top of the current window.

Trigger the action with a browser-triggered event set to OnLoad or a user-triggered event. Alternatively, to trigger the action when the viewer leaves the current page, use a browser-triggered action set to OnUnload. Choose Action > Link > Open Window. Reference a page or external URL for the link destination.
If you plan to use multiple Open Window actions in the current page, and want each link to open in a new window, rather than share a single new window, leave the Target text box blank for each action. To open all links triggered by an Open Window action in the same new window, enter the same alphanumeric name in the Target text box for each action.

Enter the pixel width of the new window in the first Size text box, and the pixel height in the second Size text box. Select any of the remaining options to define the new window properties. Resize and Scroll enable the viewer to resize the browser window and if necessary scroll in the window. The other options will show or hide a browser feature.

### Open Window Prompt

The Open Window Prompt action prompts the viewer to enter width and height pixel values, and then opens the current page in a new window sized to those dimensions.

Trigger the action with a user-triggered event, browser-triggered event set to OnLoad, or timeline-triggered event. Choose Action > Link > Open Window Prompt. Select any of the remaining options to define the new window properties. Resize and Scroll enable the viewer to resize the browser window and if necessary scroll in the window. The other options will show or hide a browser feature.

### PDF Redirect

The PDF Redirect action detects the Adobe Portable Document Format (PDF) browser plug-in and sends the browser to a specified PDF file or web page if the plug-in is installed. If the plug-in is not installed, the browser displays the page in which the PDF Redirect action resides.

Create a page designed for browsers that don't have the PDF plug-in. For example, you can provide the PDF content in HTML format, or include a link to a web page where viewers can download the plug-in.

In the page you designed for browsers that don't have the plug-in, trigger the action with a browser-triggered event set to OnParse in the head section of the page. Choose Action > Link > PDF Redirect. For the PDF Page text box, reference the PDF file or page that viewers will see if their browser has the plug-in installed.

### Random Links

The Random Links action redirects a browser to six random links, and hides the browser window's toolbar and address bar.

Trigger the action with a user-triggered event, browser-triggered event set to OnLoad, or timeline-triggered event. Alternatively, to trigger the action when the viewer leaves the current page, use a Head Action icon set to OnUnload. Set Target to one of the following:

- To replace the current page or frame with the link, leave the text box blank or enter_self.
- To open the link in a new window every time the action is triggered, enter_blank.
- To open the link and each subsequent trigger of the action in the same new window, enter a unique alphanumeric name.
- To open the link in a frame, enter the frame name. The page must be in a frame set to target a frame.

### Redirect Prompt

The Redirect Prompt action prompts the viewer for one of up to five answers and redirects them to a specific page according to their answer.
Trigger the action with a browser-triggered event set to OnLoad, a user-triggered event, or a timeline-triggered event. Choose Action > Link > Redirect Prompt. In the Question text box, enter a question that prompts the viewer for one of up to five answers. Optionally, in the Display Possible Answers text box, enter a message that contains the possible answers. (This message will be the default text in the text box that the viewer uses to enter an answer.) In the Alert If Invalid Answer text box, enter a message that will prompt viewers if they enter an invalid answer.

If you want to redirect the viewer to the same page each time they visit the current page, select the Remember Choice And Auto-redirect Next Time option. (If a viewer's browser is set to disable cookies, this option will not function.) Enter a name for the cookie.

**SWF Redirect**

The SWF Redirect action detects the SWF (Macromedia® Flash™) browser plug-in, and sends the browser to a page with SWF content if the plug-in is installed. If the plug-in is not installed, the browser displays the page in which the action resides.

To set up the SWF Redirect action, create a page designed for browsers that don't have the SWF plug-in. (For example, you can provide the SWF content in a different format, or add a link to a web page where viewers can download the plug-in.)

Trigger the action with a browser-triggered event set to OnParse in the head section of the page. In the Actions palette, choose Action > Link > SWF Redirect. For the SWF Page link destination, specify the web page with SWF content that viewers will see if their browser has the plug-in installed. To display a custom message for viewers without the plug-in, select Display Alert if No Plug-in Found, and enter a message in the Alert text box.

**Slide New Window**

The Slide New Window action opens a new browser window and slides it to the center of the screen.

Trigger the action with a browser-triggered event set to OnLoad, a user-triggered event, or a timeline-triggered event. Choose Action > Link > Slide New Window. Reference the document that will open in the new window. In the Window Name text box, enter a unique alphanumeric name, without spaces. (If the window name is left blank, some browsers will display a new window each time the page containing the action is visited.) Enter the pixel width of the new window in the first Size text box, and the pixel height in the second Size text box. Select any of the remaining options to define the new window properties. Resize and Scroll enable the viewer to resize the browser window and if necessary scroll in the window. The other options will show or hide a browser feature.

**Target2Frames**

Target2Frames lets you target two frames of a frame set with links to two different web pages from a single link.

Trigger the action with a user-triggered event on a page that resides in a frame of a frame set. Choose Action > Link > Target2Frames. In Frame 1, enter the name of the frame in which you want the first link to appear when the action is triggered. Reference the link destination in the Link text box, or enter an external URL. In Frame 2, enter the name of the frame in which you want the second link to appear when the action is triggered. Reference the link destination in the Link text box, or enter an external URL.
TargetRemote

The TargetRemote action opens a link in a window that is already open. The TargetRemote action is applied within a page that has been opened with the Open Window action from another page. For example, you can use Target Remote to set up a small hyperlinked menu outside the main browser window so that when a viewer clicks an item in the menu window, the target URL opens in the main browser window.

Set up an Open Window action in one page to open another page in a new window.

**Important:** If remote windows are resized in Netscape Navigator, they cannot target the original window. For this reason, the OpenWindow action should not have the Resize option selected.

In the page that is opened by the Open Window action, trigger the TargetRemote action with user-triggered event. In the Actions palette, choose Action > Link > TargetRemote. For the URL Link, reference the page or external URL that you want to load in the original window when the link is clicked. If the original window contains a frame set and you want the linked page to open in one of the frames, enter the name of the frame in the Optional Target Frame Name text box. Add additional user-triggered events to the page as needed and repeat.

See also

“Open Window” on page 616

TextSwap

The TextSwap (ID) action can replace text on a page or the contents in either a layer or a table cell with new text. Any content within the layer or table cell will be replaced by the new text. If the item to be replaced is text or the contents of a table cell, either must use an ID style. The new text can either display for a set number of seconds before reverting to the original content or it can disappear without restoring the original content.

**Important:** This action works on Internet Explorer 5+ and Netscape 6+ browsers.

Trigger this action with a user-triggered or timeline-triggered event. Choose Action > Link > TextSwap (ID). If the content to be replaced is inside a layer, choose the layer name from the Layer pop-up menu. If the content to be replaced is text or the contents of a table cell, enter the ID style name used without its # symbol in the Element ID text box. Enter the new text.

Enter the number of seconds the new text will display before it reverts to the original content or simply disappears. If you don't want the original text or content to return to the page when the new text disappears, select Disappear Instead Of Revert. If you want to customize the formatting of the new text, enter an HTML start tag with attributes in the <open> text box and enter its closing tag in the </close> text box. For example, if you want the new text to display in green at size 5, you can enter

```
<font color="#00FF00" size="5">
```

in the <open> text box and

```
</font>
```

in the </close> text box.

See also

"ID styles" on page 328

“Applying styles” on page 338
TimeRedirect

TimeRedirect lets you display a different web page, based on the time set in the viewer's computer. When a viewer loads the page or clicks an item, the browser is redirected to one page if the current time is before the specified time and redirects to a different page if the current time is at or after the specified time.

Trigger the action with a user-triggered or a browser-triggered event. Choose Action > Link > TimeRedirect. For Time, enter the hour before or after you want the redirection to occur as an integer between 1 and 12. Select PM to set the hour as PM; leave it unselected to set the hour as AM. Select Before, and specify a page or URL to display before that time; leave this option unselected if you don't want to redirect the page before the specified time. Select At/After, and reference a page or external URL to display at or after the specified time; leave this option unselected if you don't want to redirect the page at or after the specified time.

Message actions

About Message actions

The Message menu in the Actions palette contains actions that write text on a page, display the date a page was last uploaded to the server, open an alert message, request a password from the viewer, and display text in the browser window's status bar.

Document Write

The Document Write action is applied with a browser-triggered body action. When the browser gets to the action's code in the page, the Document Write action replaces the body action with text or code you specify, the current value retrieved by an action, or the value of a variable.

Trigger the action with a browser-triggered event at a convenient location in the body section of the page. Choose Action > Message > Document Write. Enter the text or code that you want to be written. To retrieve and write text from a variable, click the small red “C” icon adjacent to the HTML text box to change it to a blue circle icon, and choose a variable from the pop-up menu. To retrieve text from a browser-triggered action set to OnCall in the head section, click the icon again to change it to a question mark icon, and select an action from the pop-up menu.

Last Modified (ID)

The Last Modified (ID) action displays the date the page was last uploaded to the server. The date can replace placeholder text on the page, or display in either a layer or a table cell. All content within the layer or table cell will be replaced by the last modified date. If the action is applied to placeholder text or to the contents of a table cell, either must use an ID style.

Important: This action works on Internet Explorer 5+ and Netscape 6+ browsers.

Trigger the action with a browser-triggered event set to Onload or a user-triggered event. Choose Action > Message > Last Modified (ID). If you want the date to appear inside a layer, choose the layer name from the Layer pop-up menu. If the date will appear in place of text on the page or the contents of a table cell, enter the ID style name used without the # symbol in the Element ID text box.
Choose a numerical Date Format from the menu. To display the day of the week preceding the numerical date, select Include Day Of Week. In the Lead In Text text box, enter the text you want to precede the date. If you want to customize the text formatting of the date, enter an HTML start tag with attributes in the <open> text box and enter its closing tag in the </close> text box. For example, if you want the new text to display in green at size 5, you could enter

```html
<font color="#00FF00" size="5"> in the <open> text box and
</font>
in the </close> text box.

See also
“ID styles” on page 328
“Applying styles” on page 338

Last Modified (form)
The Last Modified (form) action displays the date the page was last uploaded to the server. The date displays in a form field and has the option to also display in a browser alert message.

Trigger the action with a browser-triggered event set to OnLoad. Choose Action > Message > Last Modified (form). Enter the form name in the Form text box. (For Internet Explorer viewers, the form name cannot be “form”.) Enter the text field name in the Field text box. Choose a numerical Date Format from the menu. To display the day of the week as a word preceding the numerical date, select Include Day Of Week. An alert message that displays the date appears by default. Select Disable Alert to not display this alert.

Open Alert Window
The Open Alert Window action lets you open an alert dialog box with a custom text message.

Trigger the action with a user-triggered event, browser-triggered event set to OnLoad, or with a timeline-triggered event. Choose Action > Message > Open Alert Window. Enter the message that will appear in the Alert dialog box. Or to retrieve text from a variable, click the small red “C” icon adjacent to the Message text box to change it to a blue circle icon, and choose a variable from the pop-up menu. To retrieve text from a browser-triggered action set to OnCall in the head section, click the icon again to change it to a question mark icon, and select an action from the pop-up menu.

Password
The Password action lets you protect pages with a reasonable level of security without any server-side scripting. Unlike other JavaScript password-protection scripts, this action uses an encrypted password and cannot be bypassed by turning off JavaScript in the browser or viewing the source code. Creating the Password action consists of three parts: using a provided HTML file to generate an encrypted password, naming the password-protected page appropriately, and applying a Password action to a page that refers to the password-protected page.

Although the Password action provides a reasonable level of security, it is still possible to bypass the password. It is therefore not recommended for sites that require a high level of security. Also, the password-protected file must be placed in a directory that contains a default root page such as index.html (depending on your ISP), so that the contents of the directory cannot be viewed by entering the directory location into the browser.
Use your browser to open the file makepassword.html located in the GoLive CS2/Modules/JScript/Actions/Message folder. The password you choose is case-sensitive and should not contain any spaces. Click the link on the makepassword.html page. Enter the password you want to use in the dialog box that appears and click OK. Write down the encrypted version of the password that follows “The encrypted password is” in the alert message.

Name the page that will be password-protected using the nonencrypted version of your password plus the suffix .html. For example, if your password is Sommer, the password-protected page name must be Sommer.html.

Trigger the action with a user-triggered event in a page other than the page that will be password-protected. (Do not link to the password-protected page or to anything else with the trigger link.) Choose Action > Message > Password. In the Encrypted Password text box, enter the encrypted password you wrote down. For Alert On Correct Login, enter any message you want to display when viewers enter the correct, nonencrypted password. Make sure the password-protected page and the page that links to it are located in the same directory.

### Set Status

The Set Status action allows you to display a custom message in the status line at the bottom of the browser window.

Trigger the action with a browser-triggered event set to OnLoad, user-triggered event, or timeline-triggered event. Choose Action > Message > Set Status from the Message. Enter a message in the text box.

### Multimedia actions

#### About Multimedia actions

The Multimedia menu in the Actions palette contains actions that interact with layers, sound, or images on a page.

#### Drag Layer

The Drag layer action allows viewers to drag a layer around the page in their browser window. Make sure that your page has a layer with content within it or visible properties before you create the action. Trigger the action with a browser-triggered event set to OnLoad. Choose Action > Multimedia > Drag Layer. Choose the layer you want to make draggable from the Layer pop-up menu.

#### See also

“To add a layer to a page” on page 254

#### Flip Move

When triggered for the first time, the Flip Move action moves a layer to a new specified position. When triggered for the second time, it moves the layer to a second specified position that can be the original starting location or a new location. For example, you can attach this action to a button to let the viewer flip an object into view that is initially hidden beyond the edge of the browser window and flip it back out of sight again.
Make sure your page has a layer with content within it or visible properties before you create the action. Trigger the action with a user-triggered or timeline-triggered event. Choose Action > Multimedia > Flip Move. Choose the layer you want to move from the Layer pop-up menu. The text boxes adjacent to Position 1 represent the location (Left and Top values) the layer will be moved to when the action is first triggered. Either enter the left and top values in the text boxes, or move the layer to the desired location and click Get to retrieve its current Left and Top coordinates. Position 2 represents the location the layer will be moved to when the action is triggered a second time. Enter the values, or move the layer to the desired location and click Get.

To make the layer slide to each location, select the Animation option, and enter a positive integer in the Ticks text box to specify the animation speed. One tick equals 1/60 of a second. The higher the number of ticks, the slower the movement. If Animation is not selected, the layer instantly appears in each specified location when the action is triggered.

**Float Layer**
The Float Layer action locks a layer's position relative to the browser window as the viewer scrolls the page.

Make sure your page has a layer with content within it or visible properties before you create the action.

*Important:* Internet Explorer 4.5 and earlier will not see the layer in the specified position unless a Move To action is set up for the layer before the Float Layer action. The Float Layer action will work in other browsers whether or not there is a Move To action in the page.

Trigger the action with a browser-triggered action set to OnLoad, user-triggered or timeline-triggered event. Choose Action > Multimedia > Float Layer. Select the layer name from the pop-up menu. Enter the desired position to lock the layer in the Page Position text boxes. (The values use pixel units.)

See also

“Move To” on page 624
“Tab to add a layer to a page” on page 254
“Tab to convert a layer into a table-based layout grid” on page 258

**Mouse Follow**
The Mouse Follow action makes a layer follow the viewer's pointer inside the browser window. (The layer appears below and to the right of the pointer.) If the pointer moves off the window, the layer remains near where the pointer last appeared.

Make sure that your page has a layer with content within it or visible properties before you create the action. Trigger the action with a browser-triggered event set to OnLoad, user-triggered or timeline-triggered event. Choose Action > Multimedia > Mouse Follow. Choose the layer from the Layer pop-up menu.

See also

“Tab to add a layer to a page” on page 254
“Tab to add content to a layer” on page 254

**Move By**
The Move By action moves a layer horizontally, vertically, or both by a specified distance.
Make sure your page has a layer with content within it or visible properties before you create the action. Trigger the action with a user-triggered or timeline-triggered event. Choose Action > Multimedia > Move By. Choose the layer you want to move from the Layer pop-up menu. Enter values in the DeltaX and DeltaY text boxes. (DeltaX represents the distance in pixels to move the layer to the right, and DeltaY is the distance to move the layer down.) Or to retrieve values from a variable, click the small red “C” icon adjacent to the Message text box to change it to a blue circle icon, and choose a variable from the pop-up menu. To retrieve text from a browser-triggered action set to OnCall in the head section, click the icon again to change it to a question mark icon, and select an action from the pop-up menu.

See also

“To add a layer to a page” on page 254
“To add content to a layer” on page 254

Move To

The Move To action moves a layer to a new position on the page.

Make sure that your page has a layer with content within it or visible properties before you create the action. Trigger the action with a user-triggered or timeline-triggered event. Choose Action > Multimedia > Move To. Choose the layer you want to move from the Layer pop-up menu.

Enter values in the Position text boxes (the first text box represents the distance in pixels to move the layer to the right, and the right text box is the distance to move the layer down), or move the layer to the desired location and click Get. Or, to retrieve values from a variable, click the small red “C” icon adjacent to the Message text box to change it to a blue circle icon, and choose a variable from the pop-up menu. To retrieve text from a browser-triggered action set to OnCall in the head section, click the icon again to change it to a question mark icon, and select an action from the pop-up menu.

To make the layer slide to the new location, select the Animated option, and enter a positive integer in the Ticks text box to define the animation speed. One tick equals 1/60 of a second. The higher the number of ticks, the slower the movement. If Animated is not selected, the layer instantly appears in the new location when the action is triggered.

See also

“To add a layer to a page” on page 254
“To add content to a layer” on page 254

Play Scene and Stop Scene

The Play Scene and Stop Scene actions let you manage the playback of single-scene or multiple scene animations created in the DHTML Timeline Editor. You can control multiple-scene animations dynamically by creating timeline-triggered Play Scene and Stop Scene actions or let the viewer control scene playback when they click buttons on the page.

Make sure the page has one or more scenes in it before you create the Play Scene or Stop Scene action. Trigger the action with a user-triggered or timeline-triggered event. Choose Action > Multimedia > Play Scene or Stop Scene. Inserting a Stop Scene action is a good practice before inserting a Play Scene action; it stops any other animation that may still be playing when the viewer clicks the Play button. To set up a Stop Scene action or Play Scene action, choose the scene you want the browser to stop or play back from the Scene pop-up menu.
Play Sound and Stop Sound

The Play Sound and Stop Sound actions let you manage the playback of an audio plug-in on a page. You can control sounds dynamically by creating timeline-triggered Play Sound and Stop Sound actions or let the viewer control sound playback when they click buttons on the page.

Note: The Play Sound action requires a cross-platform, cross-browser audio plug-in that can be controlled by JavaScript, such as the LiveAudio plug-in.

Make sure you have an audio plug-in on the page and that it is named in the More tab of the Inspector. Trigger the action with a user-triggered or timeline-triggered event. Choose Action > Multimedia > Play Sound or Stop Sound. Inserting a Stop Sound action is good practice before inserting a Play Sound action; it stops any other sound track that may still be playing when the viewer clicks the Play button. To set up a Play Sound or Stop Sound action, choose the sound you want to start playing back or the sound you want to stop from the Name pop-up menu.

ShowHide

The Show Hide action lets you show or hide the content of a layer in the page. For example, you can use this action to create drop-down menus that appear when the viewer clicks on a menu item and hide when the pointer rolls off the item. Alternatively, you can show or hide objects dynamically by inserting two keyframes in the DHTML Timeline Editor and adding Show Hide actions to the time track of the layer.

Make sure that your page has a layer with content within it or visible properties before you create the action. If you want a layer to not appear on the page until it is targeted to show by a ShowHide action, deselect Visible in the Layer Inspector. Trigger the ShowHide action with a user-triggered or timeline-triggered event. Choose Action > Multimedia > ShowHide. In the Layer menu, choose a layer. In the Mode menu, choose what should happen to the layer:

- Hide hides the layer until a Show action that targets it is triggered.
- Show displays the layer until a Hide action that targets it is triggered.
- Toggle shows or hides the layer, depending on its current visibility status.

SlideShow and SlideShowAuto

SlideShow and SlideShowAuto let you manage the playback of a series of images. SlideShow lets viewers cycle through a series of images by clicking a link. Each click displays the next image in the series. SlideShowAuto displays a series of images automatically with a specified time interval between images (similar to an animated GIF).

The following rules apply to images used for the SlideShow and SlideShowAuto actions:

- They must be in the same folder as the first image placed on the page.
- They can be either GIF or JPEG images, but you cannot mix GIF and JPEG images in the same slide show.
- They must be named in sequence, ending with 01 and the .gif or .jpg extension. For example, the starting GIF image could be named poster01.gif, and the others would be named poster02.gif, poster03.gif, and so on. Alternatively, you could name the images simply 01.gif, 02.gif, 03.gif, and so on.
- You cannot have more than one SlideShow action and SlideShowAuto action on the same page.

Place the slide show’s first image in the page, and enter a unique alphanumeric name in the More tab of the Image Inspector. Trigger the SlideShow action with a user-triggered or timeline-triggered event, or trigger the SlideShowAuto action with a user-triggered or timeline-triggered event, or with a browser-triggered event set to OnLoad. Choose Action > Multimedia > SlideShow or SlideShowAuto. From the Base Image menu, choose the starting image. For # of Images, enter the total number of images in the slide show.
Playback options for the SlideShow action

Loop  Repeats the slide show after the final image is shown.

Play Backwards  Displays the images from the last to the first. This option lets you create forward and backward links for the slide show.

Palindrome  Plays the slide show forward and then backward continuously. To use this option, you must select Loop as well.

Leaving all three options unselected plays the slide show a single time.

Playback options for the SlideShowAuto action

Interval (in Secs.)  Specifies the number of seconds to wait between displaying images.

Stop At End Of Slideshow  Plays the slide show a single time only. Otherwise, the slideshow will play continuously.

Normally, all images display with the dimensions of the base image. To enable each image to display with its own dimensions, change the base image's Width and Height values from Pixel to Image in the Image Inspector.

SlideShowAutoStop

SlideShowAutoStop is a companion action to SlideShowAuto and lets viewers pause or continue an automatic, timed slide show. For example, to create a “pause” button, you can apply this action to a button on the same page as the automatic slide show. This action can only be used on a page where the SlideShowAuto action is applied.

Trigger the action with a user-triggered event. Choose Action > Multimedia > SlideShowAutoStop.

Stop Complete

The Stop Complete action stops all animation in the browser’s window. As a courtesy to viewers with slow connections, include a Stop Complete button in any animated page you create.

Trigger the action with a user-triggered event. Choose Action > Multimedia > Stop Complete.

Wipe Transition

The Wipe Transition action uses a sliding mask effect to gradually reveal or conceal the content in a layer.

Make sure that your page has a layer with content within it or visible properties before you create the action. Trigger the action with a user-triggered or timeline-triggered event. Choose Action > Multimedia > Wipe Transition.

Choose a layer in the Layer menu. Select an option from the Transition menu to determine the way the layer will be wiped in (revealed) or out (concealed). Enter a positive integer in the Steps text box to determine the number of steps for the transition. The higher the number of steps, the smoother the transition appears.

Others actions

About Others actions

The Others menu in the Actions palette contains actions that display clocks, set browser window properties, print a page, set the page background color, display search engine results, or fix a Netscape CSS and layer-related problem.
Clock Date (ID)
The Clock Date (ID) action displays a live text-based clock that can display the local date, local time, or both. The clock uses the viewer's system clock to determine the local date and time. The clock can replace placeholder text on the page, or display in a layer or a table cell. If the action is applied to placeholder text or the content in a table cell, either must use an ID style.

**Important:** This action works on Internet Explorer 5+ and Netscape 6+ browsers.

Trigger the action with a browser-triggered event set to OnLoad. Choose Action > Others > Clock Date (ID). If you want the clock to appear inside a layer, choose the layer name from the Layer pop-up menu. (All content within the layer will be replaced by the clock.) If the date will appear in place of text on the page or the contents of a table cell, enter the ID style name used without the # symbol in the Element ID text box.

Select Show Local Time if you want to display the time. Select Use 24-hour Time to display 24-hour time, or leave it unselected to display 12-hour A.M. and P.M. time. To display the local date, select Show Date and choose a numerical date format from the pop-up menu. To display the day of the week as a word preceding the numerical date, select Include Day Of Week. In the Lead In Text text box, enter the text you want to precede the date. If you want to customize the text formatting, enter an HTML start tag with attributes in the <open> text box and enter the HTML closing tag in the </close> text box. For example, if you want the new text to display in green with a size of 5, you could enter

```html
<font color="green" size="5">
```

in the <open> text box and

```html
</font>
```

in the </close> text box.

See also

“ID styles” on page 328

“Applying styles” on page 338

Digital Clock

The Digital Clock action displays a live clock that displays the local time using images that you provide. The clock uses the viewer's system clock to determine the local time.

Create ten different images to represent the numbers 0 through 9 and place them in the same folder. The images must all be either GIFs or JPEGs, and cannot be a combination of both. The images must be named either 0.gif, 1.gif, 2.gif, and so on, or 0.jpg, 1.jpg, 2.jpg, and so on. Place any four of the images on your page to serve as placeholders for the clock digits. In the More tab of the Image Inspector, enter a unique name for each image placeholder.

Normally, all images will display with the dimensions of the base image. To enable the images to display with different dimensions, change the base image’s Width and Height values from Pixel to Image in the Image Inspector.

Trigger the action with a browser-triggered event set to OnLoad. Choose Action > Others > Digital Clock. Choose an image name from each of the Digit pull-down menus to associate each clock digit with one of the placeholder images. Select Use 24-hour Time to display 24-hour time, or leave it unselected to display 12-hour A.M. and P.M. time. To identify the clock's image directory, reference any of the ten images that represent the clock numbers.
Netscape CSS Fix
The Netscape CSS Fix action is a workaround for a program error in Netscape Navigator 4.x that causes web pages to lose cascading style sheet information when the viewer resizes the browser window. Use this action on any pages that contain layers because layers are built with cascading style sheets.

Trigger the action with a browser-triggered event set to OnLoad in the head section of the page. Choose Action > Others > Netscape CSS Fix. Test your animations or actions in Netscape Navigator 4.0.

Note: With frame sets, be sure to use the action in the head section of the pages that appear within the frames and not the frame set.

Print Document
The Print Document action displays the browser’s print dialog box to print the current web page or frame of a frame set. The action must reside within the page or frame you want to print and cannot target a different page or frame.

In the page that you want to print, trigger the action with a user-triggered or browser-triggered event. If the page you want to print is part of a frame set, enter the page’s frame name.

ResizeWindow
The ResizeWindow action resizes the browser window. Trigger the action with a user-triggered or timeline-triggered event. Choose Action > Others > ResizeWindow. Enter pixel values for the Width and Height text boxes.

Scroll Down, Left, Right, Up
The Scroll Down, Scroll Left, Scroll Right, and Scroll Up actions let you dynamically scroll the browser window. For example, you can use these actions to let the viewer follow the path of a layer traveling beyond the margin of the window.

Trigger the action with a user-triggered or timeline-triggered event. Choose Action > Others > Scroll Down, Left, Right, or Up. Enter a pixel value in the Scroll Pixels text box to specify the distance that you want the window to scroll. Enter a pixel value in the Scroll Speed text box to specify how fast you want the window to scroll. The higher the value you enter, the faster the speed.

Scroll Status
The Scroll Status action displays a text message that scrolls horizontally in the status bar at the bottom of the browser’s window.

Trigger the action with a user-triggered event, browser-triggered event set to OnLoad, or timeline-triggered event. Choose Action > Others > Scroll Status. Enter a message in the message field. Enter a value between 1 and 1000 for the scrolling speed (1 represents the fastest speed, and 1000 the slowest). Select Scroll Reverse (Left To Right) to have the text scroll from the left side of the window to the right and repeat when the text first reaches the right side of the window. Deselect this option to have the text scroll from the right to the left and off the page in a seamless loop.

Search Engine
The Search Engine action uses input from a predefined search string or viewer input from a form, and opens a new browser window that contains the search engine results.
Trigger the action with a browser-triggered event set to OnLoad, a user-triggered event, or a timeline-triggered event. User-triggered events can be attached to form objects, a submit button, or a form event. (If your action is using viewer input from a form, first create a form and name it, and then choose the trigger.) If the action is attached to a text field, trigger the action with the Key Blur event. If the action is attached to a Text Area field, trigger the action with the Text Change event. Choose Action > Others > Search Engine, and do one of the following:

- To use input from a predefined search string, leave the Form Name and Field Name blank. Select Define Your Own Search String, and enter a text string with a plus sign (+) between each word.
- To use viewer input from a form, enter the name of the form, and the name of the field that will gather the search string. Make sure that Define Your Own Search String is not selected.

Choose a search engine from the Use This Search Engine menu. If you want the search engine results to display in an existing window or frame, enter the window or frame name.

To display search results from multiple search engines, add a new Search Engine action for each desired search engine. If you triggered the first Search Engine action with a user-triggered event, use the same trigger.

**Set BackColor**

The Set BackColor action lets you change the background color of the browser window. Trigger the action with a user-triggered or timeline-triggered event. Choose Action > Others > Set BackColor. Click the Background Color field and select a color from the Color palette.

**World Clock**

The World Clock action displays a live clock showing the time of a specified world time zone. The clock displays in the browser’s status bar, in an existing form field on the page, or both.

**Important:** To create an accurate clock, the local time zone on your computer must be set to the correct time.

Trigger the action with a browser-triggered event set to OnLoad or a user-triggered event. Choose Action > Others > World Clock. To display a message to the left of the clock, enter the message in the Clock Message text box. Select the Use 24-hour Time option to display 24-hour time, or leave it unselected to display 12-hour A.M. and P.M. time.

In the GMT Offset text box, enter the number of hours between your desired location and Greenwich mean time (GMT) as a value between -12 and +12. You can click the Globe icon next to the GMT offset text field to look up a city’s GMT offset. The button launches the default browser, which opens a time zone chart at http://www.timeanddate.com/worldclock/. Click on a city to look up its GMT offset. (GMT is zero; time zones west of GMT have a negative offset value, and time zones east of GMT have a positive offset value. For example, U.S. eastern standard time (EST) is five time zones to the west of GMT and has a GMT offset of –5; central Europe time (CET) is one time zone to the east of GMT and has a GMT offset of +1.)

Select the Daylight Savings Time option if daylight savings time (DST) occurs in the selected time zone. Select the Status Bar option to display the clock in the browser’s status bar, and select the Form Field option to display the clock in an existing form on the page. If you selected Form Field, enter the form name and field name for the text field in which the clock will display.
RealPlayer

About RealPlayer actions
The RealPlayer menu in the Actions palette lists actions you can use to control the playback of presentations in RealPlayer documents or Real Media in the RealPlayer plug-in. In addition, you can retrieve information about the RealPlayer that a viewer is using or about the clips that are playing.

Except for the Embedded Actions action (which appear in the browser itself), you set up RealPlayer actions in the web page that appears in the Browser Pane frame or the Info Pane frame of your RealPlayer document. Trigger the event with a user, timeline, or browser-triggered action, and then choose an action from the Action > RealPlayer menu.

For more information, see the RealOne Player Scripting Guide available on the RealNetworks website at http://service.real.com/help/library/encoders.html.

For more information about creating RealPlayer documents in GoLive, see “About the RealPlayer Editor” on page 513.

Add To Now Playing List
❖ Opens the "Now Playing" list and adds a URL to the clip list after the current clip. Optionally, it displays an associated URL in the page that appears in the Info Pane frame with the specified height and width when the added clip plays, and a URL to the page in the Browser Pane frame.

Choose Action > RealPlayer > AddToNowPlayingList. Reference the URL that you want to add to the RealPlayer clip list in the Clip URL text field. To display a page in the Info Pane frame when the added clip plays, reference the page in the Info Pane URL text field. Use the value, "_keep" in the Info Pane URL to keep the current info pane. To define the width and height of the Info Pane frame, enter a pixel value in the Info Pane Width and Height text boxes. If no value is defined, the width defaults to 320 pixels and the height is the same as the document that displays in the Media Pane frame. To display a media file in the Media Pane frame or in a new browser window, reference the URL in the Media Browser URL text field, and then choose a display option from the Media Browser Target menu. To display information about the clip that is playing, enter values in the Clip Infos text boxes.

Clear Now Playing List
Clears the RealPlayer's current playlist and stops any clips currently playing. Call this method before using any of the other methods to synchronize playback.

Choose Action > RealPlayer > ClearNowPlayingList.

Embedded Actions
Choose from a wide variety of different actions, including setting playback controls, retrieving or setting media and clip information, changing embedded player attributes, and specifying clips to play.

Open the web page that contains an embedded RealPlayer plug-in or RealPlayer active X control, select the Real placeholder on the page, and enter a name for it in the More tab of the Plug-in Inspector. Trigger the action with a user- timeline, or browser-triggered event in the web page. Choose Action > RealPlayer > EmbeddedActions in the Actions palette. Choose the Real file from the Real Object menu, and choose an action from the Method menu.

For more information about the actions listed in the Method menu, see the RealOne Player Scripting Guide available on the RealNetworks website at http://service.real.com/help/library/encoders.html.
**Get Clip Info**
Retrieves the specified value of the clip information as authored by the media provider. This method only works for clips launched from HTML in the Info Pane frame.

Choose Action > RealPlayer > GetClipInfo. Choose the clip property you want to retrieve from the Property menu.

**Get Installed Components**
Returns a string containing all of the DLLs installed by RealPlayer and their associated version numbers. The component type and version number are separated by a colon (:). Each DLL is separated by a pipe symbol (|).

Choose Action > RealPlayer > GetInstalledComponents.

**Get Player Property**
Retrieves the value of a property you specify.

Choose Action > RealPlayer > GetPlayerProperty. Choose a property from the Property menu. For more information on the properties listed in the Property menu, see the RealOne Player Scripting Guide available on the RealNetworks website at http://service.real.com/help/library/encoders.html.

**Get Player State**
Returns an integer to describe the current player state: 0 indicates the player is stopped; 1 is contacting; 2 is buffering; 3 is playing; 4 is paused; 5 is seeking; 6 is showing a modal dialog box.

Choose Action > RealPlayer > GetPlayerState.

**Get Version Number**
Returns the RealPlayer version of the current player or other media plug-in. For more information on this action, see the RealOne Player Scripting Guide available on the RealNetworks website at http://service.real.com/help/library/encoders.html.

Choose Action > RealPlayer > GetVersionNumber. Choose an item from the Application/Component menu; or, to specify an item that isn't listed, enter its name in the Component text field. Enter the Major and Minor version numbers of the RealPlayers that support your presentation in the major Version and minor Version text fields. Select unpack to return the version number in a more readable format.

**Handle Action**
Performs a specified action. CD, MyDevices, Radio, and web display the respective tab in the player. Now Playing displays the “Now Playing” list, and ShowEqualizer displays the player’s Equalizer dialog box.

Choose Action > RealPlayer > Handle Action. Then choose the desired action from the Action pop-up menu.

**Navigate to URL**
Opens a specified URL in a specified target window, and has the option to delay when the URL displays. Choose Action > RealPlayer > NavigateToURL. Enter the URL to display in the Media Browser URL text field, and choose where to display the URL from the Media Browser Target menu. To display the URL after the clip starts playing, enter the number of seconds to delay the clip in the Media Browser Delay text box.
Choose Action > RealPlayer > NavigateToURL. Enter the URL to display in the Media Browser URL text field, and choose where to display the URL from the Media Browser Target menu. To display the URL after the clip starts playing, enter the number of seconds to delay the clip in the Media Browser Delay text box.

**Play Clip**
Plays a clip from a specified URL in the Media Pane frame, and can also display a URL in the Media Pane frame or a new browser window.

Choose Action > RealPlayer > PlayClip. Reference the URL to play the clip. To display a page in the Info Pane frame when the added clip plays, reference the page in the Info Pane URL text field. To define the width and height of the Info Pane frame, enter a pixel value in the Info Pane Width and Height text boxes. If no value is defined, the width defaults to 320 pixels and the height is the same as the document that displays in the Media Pane frame. To display a web page in the Media Pane frame or in a new browser window, reference the URL in the Media Browser URL text field, and then choose a URL display option from the Media Browser Target menu. To display the URL after the clip starts playing, enter the number of seconds you want to delay the clip in the Media Browser Delay text box. To add the clip to the “Now Playing” list, select that option. To display information about the clip that is playing, enter values in the Clip Infos text boxes.

**Preload URL**
Retrieves a specified web page URL to store in memory to be opened later. This enables the specified URL to play back more reliably.

Choose Action > RealPlayer > PreloadURL.

**Set Video Background Color**
Sets the video background to a specified color, and has the option to delay when the color displays.

Choose Action > RealPlayer > SetVideoBackgroundColor. To set the Video Background Color value, either click in the text box to define a color in the Color palette, or click the lower right corner of the Video Background Color text box to choose a color from the pop-up menu. To display the color after the clip starts playing, enter the number of seconds to delay the clip in the Media Browser Delay text box.

**Show Artist Info**
Shows or hides the artist information in the Info Pane frame.

Choose Action > RealPlayer > ShowArtistInfo. Select Show Info to show the artist information or deselect it to hide the information.

**Show Preferences**
Displays the player’s Preferences dialog box with a specified category and page.

Choose Action > RealPlayer > ShowPreferences. Choose a category and page to display from the pop-up menu.
Specials actions

About Specials actions
The Specials menu in the Actions palette contains actions that manage or interact with other actions in a page, or call upon other values in a page.

Action Group
The Action Group action lets you group other actions and trigger them together. This action is most useful on the Actions Track of the Timeline Editor, but can also be used with buttons or a text link if you want to let the viewer decide whether to run the grouped actions or not.

Trigger the action with a user-triggered, timeline-triggered, or browser-triggered action. In the Actions palette, choose Action > Specials > Action Group. Click the Create New Item button, choose an action from the Action pop-up menu, and set its options. Continue to add and choose actions to the Actions List until you have added all the desired actions to the Action Group.

Call Action
The Call Action triggers another action on the page. For Call Action to work, the action it triggers must be set to OnCall. The Call Action action can be used to make your actions modular and easier to maintain. For example, if your page contains a button and a text link that jump to the same URL, you can add a GoToLink action set to OnCall in the header and trigger it with the Call Action applied to the button and the text link. If you decide to change the URL referenced by the two controls, you will only need to change the GoToLink action.

Make sure there are one or more actions set to OnCall on the page. Trigger the CallAction with a user-triggered or timeline-triggered event. Choose Action > Specials > Call Action. Choose an action from the pop-up menu.

Call Function
The Call Function action calls a function from the head section of the page.

Make sure there are one or more functions defined in the head section of the page. Trigger the action with a browser-triggered event set to OnLoad. Choose Action > Specials > Call Function. Choose a function from the Function pop-up menu, and enter a comma-separated list of function arguments in the Argument text box.

Note: Action-based JavaScript calls will make it easier for JavaScript-savvy developers to create new actions.

Condition
The Condition action monitors the browser window for the occurrence or nonoccurrence of an event and triggers one of two other actions if the specified condition is true or false. You can choose among four actions to be the condition: Intersection, KeyCompare, Timeout, and Test Variable. To monitor multiple occurrences of an event in a session, set up an Idle action.

Trigger the action with a browser-triggered event set to OnLoad or a user-triggered event. Choose Action > Specials > Conditions. In the Condition tab of the Actions palette, choose one of the four conditions from the Action > Specials or Action > Variables menu. In the True tab, specify an action to be executed when the specified condition evaluates to true. In the False tab, specify an action to be executed when the specified condition evaluates to false. For example, if you have an image on your page, you can use the Set Image URL action to swap the image content based on the result of the condition action.
See also
“Intersection” on page 634
“KeyCompare” on page 635
“Timeout” on page 635
“Test Variable” on page 638
“Set Image URL” on page 614

Idle
The Idle action inserts a script that monitors the browser window for a specified condition and triggers other actions, depending on whether the condition is true or false. You can choose among four actions to be the condition: Intersection, KeyCompare, Timeout, and Test Variable. These are best used in the head section of the page because the conditions are monitored automatically.

See also
“Intersection” on page 634
“KeyCompare” on page 635
“Timeout” on page 635
“Test Variable” on page 638

Intersection
The Intersection action is designed for use with the Idle or Condition action, which must reside in the head section as a browser-triggered event. The Intersection condition monitors the browser window for the physical intersection of two layers. It is true when the layers overlap in the browser window and false while they don't. You can use the result of this action to trigger two further actions.

This action supplements the Drag Layer action. An intersection occurs when the paths of two layers cross. The Intersection action may be connected, for example, with a Set BackColor action.

To set up an Intersection action, trigger the action with a browser-triggered event set to OnLoad. Choose Action > Specials > Idle or Condition. In the Condition tab of the Actions palette, choose Action > Specials > Intersection. If you chose Idle and want the action to terminate the first time the Timeout Intersection condition is true, select the Exit Idle If Condition Returns True option. By activating this option, you instruct the script to monitor the browser window for a single event.

Select the layers you want to monitor for the intersection from the two Layer pop-up menus. In the True tab, choose the action you want to have triggered when an intersection occurs. In the False tab, choose the action to be executed while the layers don't overlap.

See also
“Drag Layer” on page 622
KeyCompare
The KeyCompare action launches an action when the viewer presses a selected key. This action is designed for use with the Idle action, which must reside in the head section of the page as a browser-triggered event. You can use the KeyCompare action, for example, to simulate Windows-style access keys for objects on your page.

To set up a KeyCompare action, trigger the action with a browser-triggered action set to OnLoad. Choose Action > Specials > Idle. In the Condition tab of the Actions palette, choose Action > Specials > KeyCompare. Enter the ASCII character code that corresponds to the desired keystroke in the CharCode text box. In the True tab, choose the action you want the keystroke to trigger. Return to the page and add a visual hint for the viewer—for example, an instruction such as “Press K”.

Important: Do not specify an action in the False tab. If an action is specified in the False tab, it will be triggered before the user has a chance to press a key to trigger the True condition.

Timeout
The Timeout action is a timer and switch combination that lets you specify a time span after which the browser should switch between two states. This action is designed for use with the Idle action, which must go into the head section of the page as a browser-triggered event. The condition it monitors is false while the timeout period still lasts and true when the timeout period has elapsed. Either state has its own action. You can use this action to implement a timed switch in the browser window—for example, to switch the content of a banner image.

To set up a Timeout action, trigger the action with a browser-triggered event set to OnLoad. In the Actions palette, choose Action > Specials > Idle. In the Condition tab of the Actions palette, choose Action > Specials > Timeout. If you want to have the action stop the first time the Timeout condition is true, select Exit Idle If Condition Returns True. By activating this option, you instruct the browser to switch states once only.

Enter a time span in seconds in the Timeout (secs.) text box. In the True tab, choose the action to be triggered when the Timeout limit has elapsed. For example, set the Timeout action to trigger a Set Image URL action, causing the browser to change the content of a banner image. In the False tab, choose the action to be executed while the Timeout period still lasts. In the example above, you would use a second Set Image URL action that supplies an alternative image.

See also
“Set Image URL” on page 614

Variables actions

About Variables actions
GoLive features a set of actions in the Actions palette that allows you to use variables. You can use variables as input for other scripted actions, replacing settings you would make in the Inspector.
There are two major uses for assigning values to variables at runtime, which you define with the Set Variable action:

- You can use variables as pseudo-constants to specify a fixed value for another action.
- You can dynamically store object properties in variables at runtime and set a cookie to write them to the viewer’s hard disk. This is possible for selected properties of the browser window, such as background color.

To use a variable in a page, you must declare it with the Declare Variable action first. After declaring a variable, you may want to initialize it with the Init Variable action.

**Declare Variable**

To use a variable in a page, you must declare it with the Declare Variable action first.

Trigger the action with a browser-triggered event set to onParse in the head section of the page. Choose Action > Variables > Declare Variable.

Enter a unique name in the Name text box. Choose an appropriate data type from the Type menu:

- **Boolean** Any on/off state.
- **Integer** Any integer value.
- **Float** Any floating point value.
- **String** Any string value.
- **Layer** Any layer in the current page.
- **Layer Position** Location of a layer in the current page.
- **Image** Any image in the current page.
- **URL** Any URL in the current page.
- **Color** Any color in the current page.
- **Scene** Any scene in the current page.
- **OnCall Action** Any action from the head section of the page whose trigger is set to OnCall.
- **Function** Any function declared in the head section of the page.

Use the Cookie text box to enter the name of the cookie in which you want to store the value of the variable on the viewer’s hard disk. Then use the Write Cookie and Read Cookie actions to set the cookie and read its content, respectively.

**DeleteCookie**

DeleteCookie is a companion action to VisitorCookie. It lets you delete an existing cookie by entering the cookie’s name. This is useful for testing the VisitorCookie action. For example, you might be sent to one page the first time you test the VisitorCookie action, and then to another page on subsequent visits. By using the DeleteCookie action, you can change the original page and still be able to revisit it.

Trigger the action with a user-triggered event, or a browser-triggered event set to OnLoad in the head section of the page. Choose Action > Variables > DeleteCookie. For Cookie Name, enter the name of the cookie you want to delete.
**Init Variable**

After declaring a variable, you may want to initialize it with the Init Variable action. Trigger the action with a browser-triggered event set to onParse in the head section of the page. Choose Action > Variables > Init Variable. Choose the variable you want to initialize from the Variable menu. (You must declare your variable beforehand for it to appear in the pop-up menu.)

The Value item changes automatically with the type of the variable. Use the appropriate control to supply an initial value:

- **Boolean** A check box (selected is true, unselected is false).
- **Integer** A text box that accepts whole numbers only.
- **Float** A text box that accepts numbers with decimal points.
- **String** A text box that accepts any string of text.
- **Layer** A pop-up menu showing all layers in the page.
- **LayerPos** Two x and y text boxes for the position of a layer and a Get button that reads the current position.
- **Image** A pop-up menu listing the named images in the current page.
- **URL** A typical text box, Browse button, and pick whip combination for specifying URLs.
- **Color** A color field that brings up the Color palette when clicked.
- **Scenes** A pop-up menu that lists all scenes in the current page.
- **OnCall Action** A pop-up menu listing all actions from the head section that have their trigger set to OnCall.
- **Functions** A pop-up menu that lists all function declarations from the head section of the current page.

**Read Cookie**

The Read Cookie action retrieves information stored in a cookie at runtime and writes a cookie value into all variables assigned to that cookie. A cookie can be read when the page loads, or when a viewer clicks an item in the page.

To have the browser read the cookie when the page loads, trigger the action with a browser-triggered event set to OnLoad in the head section of the page. To have the browser read a cookie when a viewer clicks a specific item in your page, trigger the action with a user-triggered event. Choose Action > Variables > Read Cookie. Enter the name of the cookie specified in the Write Cookie action in the Name text box.

**Set Variable**

You may want to assign a certain value to a variable at runtime. Trigger the action with a browser-triggered event set to OnLoad in the head section of the page or a user-triggered event. Choose Action > Variables > Set Variable. Enter a unique name for the Set Variable action in the Name text box.

Choose the variable whose value you want to set from the Variables pop-up menu. The Value item changes automatically with the type of the variable. Use the appropriate control to supply an initial value with the Init Variable action.

**See also**

"Init Variable" on page 637
Test Variable

Test Variable is an extension to the Idle action that allows you to read the current value of a variable at runtime and compare it with a value you specify. This comparison evaluates either as true or false, and the result can be used to trigger two alternative actions.

Trigger the action with a browser-triggered event set to OnLoad in the head section of the page. In the Actions palette, choose Action > Special > Idle. In the Condition tab of the Actions palette, choose Action > Variables > Test Variable. Choose the variable whose value you want to compare from the Variable menu. The Value item changes automatically with the type of the variable. Use the appropriate control to supply a value you want to test the variable against by using the Init Variable action. Choose the type of comparison from the Operation menu.

Note: Not all comparison operators work with all types of variables. For example, using “Greater than” with a string variable will result in a JavaScript error in the browser because the browser expects a number.

See also

“Init Variable” on page 637

Times Visited

The Times Visited action displays messages that are customized according to the number of times a viewer visits the web page. (This action uses cookies. If a viewer’s browser is set to disable cookies, the action will not function.)

Trigger the action with a browser-triggered event set to OnLoad, a user-triggered event, or a timeline-triggered event. Choose Action > Variables > Times Visited. Enter a message in the 1st Time Visitor Message text box. To display a different message when the viewer revisits the page, select the Show This Message + Total Visits option, and enter a message. (The number of times the viewer has visited the page will appear next to the message in the browser alert window.) To have an additional message appear after the viewer has visited the page a specified number of times, select the Optional Message option, enter a message, and enter the number of visits criterion. Enter a name for the cookie.

When you preview the action multiple times in a browser, you can simulate the browser’s behavior when viewers visit the page for the first time by renaming the cookie before previewing the page.

VisitorCookie

VisitorCookie lets you create a custom page for first-time visitors. The first time a viewer visits the page or performs a specific mouse event, the VisitorCookie action creates a cookie. The cookie is stored on the viewer’s computer if they have not set up their browser to deny cookies. On subsequent visits or mouse events, the viewer is redirected to a different page. For example, you might want first-time visitors to go to a special page with a “Welcome” message, but to the main page on subsequent visits.

Trigger the action with a user-triggered event, or a browser-triggered event set to OnLoad. Choose Action > Variables > VisitorCookie. Enter a name in the Give Your Cookie A Unique Name text box. For Redirect After 1st Visit link destination, reference a page to display the next time the viewer triggers the action.

WriteCookie

The WriteCookie action allows you to store the value of a variable temporarily on the viewer’s hard disk. This function enables you to make viewer-customizable pages, because it allows the viewer to change the properties of the browser window and reload their own personalized version of the page later on.
Trigger the action with a browser-triggered event set to OnLoad in the head section of the page. Choose Action > Special > WriteCookie. Enter a name for the cookie in the Name text box. This name will be used when the Write Cookie action sets the cookie at runtime. In the Expires After text box, enter an expiration date (in hours) to determine how long the cookie will last after it has been set. Set optional attributes:

**Path** Specifies the subset of URLs in a domain for which the cookie is valid. If a cookie has already passed domain matching, then the path name component of the URL is compared with the path attribute, and if there is a match, the cookie is considered valid and is sent along with the URL request.

**Domain** Specifies a valid Internet domain name. When searching the cookie list for valid cookies, the attribute you specify here for the current cookie is compared with the Internet domain name of the host from which the URL will be fetched. If the tails of both domain names match, then the cookie will go through path matching to see if it should be sent.

**Secure** Ensures that the cookie will be transmitted only if the communications channel with the host is a secure one. If secure is not specified, a cookie is considered safe to be sent in the clear over unsecured channels.
Chapter 27: Configuring Web Settings

Web Settings

About GoLive Web Settings
Web Settings is an essential component of GoLive that makes sure your web documents are written with valid source code. It comes with a complete inventory of HTML elements, special character codes, file mappings, and browser display profiles. The Web Settings window contains several different tabs that you can edit to accommodate new or modified elements as standards evolve. Web Settings also serves as a reference manual, assisting web authors in choosing the proper elements and attributes for their web pages.

Important: Errors made while editing Web Settings can cause serious damage to your documents. Before making any changes, check the current HTML specifications defined by the World Wide Web Consortium (W3C) at www.w3c.org.

To access Web Settings
❖ Choose Edit > Web Settings (Windows) or GoLive > Web Settings (Mac OS).

Methods of restoring default Web Settings
If you’ve made changes to Web Settings that you’d like to remove, you have several options. You can prevent the window from saving the changes when you close it, you can restore the default settings of selected items or all settings in a Web Settings tab, or you can restore the entire set of Web Settings to the default settings.

To close Web Settings without saving changes
1 In the Web Settings window, press Alt (Windows) or Option (Mac OS) and close the Web Settings window.
2 Click No when asked if you want to save Web Settings.
3 Quit GoLive, and restart the application.
Web Settings is restored to the settings it contained before you last opened it.

To restore default settings of selected items or delete new items
1 In the Markup, Characters, or File Mappings tab, select any element, attribute, enumeration, character, or suffix that is labeled "change", "new", or "x" under the User column.
2 Press Delete on the keyboard.
3 Click Yes when prompted to confirm the change.

To restore the Web Settings defaults
1 Quit GoLive.
2 Locate the Settings folder:
   • (Windows) Documents and Settings/[username]/Application Data/Adobe/Adobe GoLive/Settings
   • (Mac OS) Mac OS X/Users/[username]/Library/Preferences/Adobe/GoLive/Settings
3 Delete the Main, FileMappings, MarkupGlue, and UserAgentProfiles folders that are inside the Settings folder.

4 Restart GoLive.

A default set of Web Settings is created.

To restore a particular tab to its default settings

1 Locate the Settings folder:
   • (Windows) Documents and Settings/[username]/Application Data/Adobe/Adobe GoLive/Settings
   • (Mac OS) Mac OS X/Users/[username]/Library/Preferences/Adobe/GoLive/Settings

2 Do one of the following:
   • To restore only the Markup Language tab, delete the MarkupGlue folder.
   • To restore only a specific panel of the Markup Language tab, delete a folder in the MarkupGlue folder.
   • To restore only the Characters tab, delete the “user_entities.aglmga” file in the MarkupGlue/html folder.
   • To restore only the File Mappings tab, delete the FileMappings folder.

Markup Language options in Web Settings

Markup Language options

The Markup Language tab of Web Settings contains the entire range of HTML, SMIL, SVG, WML, and GoLive proprietary elements that GoLive can read and write. The information stored in the Markup Language tab is used by GoLive's Syntax Checker. HTML-standard elements include all those specified by the HTML 2.0 and 3.2 standard publications, plus HTML 4.0 forms tags. You can add elements to the list and edit existing elements as the current HTML standard evolves. In addition, you can import an XML Document Type Definition (DTD) file and bind it to file extensions and mime types.

To view elements in the Markup Language tab

You can use Web Settings to look up the proper use of an HTML, SMIL, SVG, or WML element and its attributes. The panes can be organized into sections, or you can view all the elements alphabetically. Element, attribute, or enumeration information is displayed in the Inspector.

1 In the Markup Language tab of Web Settings, expand a section and select a markup language.

2 To show or hide columns, right-click (Windows) or Control-click (Mac OS) a column head, and choose a column name or an option.

3 Scroll through the list on the right (if the view is set to Structured, expand a section), and select an element. The Web Settings Element Inspector displays the structural information for that element.

4 To see an element's attributes in the Markup Language tab, expand the tag, and select the attribute (some tags do not have attributes). To see an attribute's enumeration, expand the attribute, and select the enumeration (some attributes do not have enumerations).
See also

“To edit an element attribute in the Markup Language tab” on page 644

“To edit an enumeration in the Markup Language tab” on page 645

“To edit an element in the Markup Language tab” on page 642

To add a new item to the Markup Language tab

1 In the Markup Language tab of the Web Settings window, select a markup language on the left, click in the right side of the tab, and do one of the following:
   • To add an element, click the New Element button in the toolbar or choose Add Element from the context menu.
   • To add an attribute to an element, select an element or an existing attribute of the element, and click the New Attribute button in the toolbar.
   • To add an enumeration to an attribute, select the attribute. In the Basic tab of the Inspector, choose Enumeration from the Value Type pop-up menu, and click the New Enumeration button in the toolbar.
   • To duplicate an element, attribute, or enumeration, select it and click the Duplicate button in the toolbar.

2 With the new item selected, edit the properties in the Inspector.

Note: To add new Web Settings elements to a document, you must hand-code them in the document’s Source Code Editor. To add new element attributes or enumerations to a document, you must hand-code them in the Source Code Editor, or select them from the attribute or enumeration pop-up menus in the Outline Editor.

See also

“To edit an element attribute in the Markup Language tab” on page 644

“To edit an enumeration in the Markup Language tab” on page 645

“Methods of restoring default Web Settings” on page 640

“To edit an element in the Markup Language tab” on page 642

To delete custom items from the Markup Language tab

❖ Select the item, and press Delete.

Note: You cannot delete any elements that are installed by default.

See also

“Methods of restoring default Web Settings” on page 640

To edit an element in the Markup Language tab

1 Select the element in the Markup Language tab of Web Settings, and in the Basic tab of the Inspector enter the element name in the Name box.

2 Enter a description in the Comment box.
Choose one of the following from the Structure pop-up menu:

**Block**  Creates a block-level container element that can contain other elements (for example, the `<BODY>` tag).

**Inline Visible**  Creates an element that has visible content. This element can only exist within a container element, such as the `<IMG>` tag.

**Inline Invisible**  Creates an element that can only exist within a container element, has visible content, but isn’t visible itself (although it influences a visual property of the content), such as the `<BOLD>` tag.

**Inline Container**  Creates a container element that can only exist within another container element. It can have both non-HTML content and visible HTML content, such as the `<APPLET>` tag.

**Inline Killer**  Is reserved for use with the `<BR>` tag.

Choose one of the following options from the Content pop-up menu to define how the content of an element is treated:

**Normal**  Treats the content as specified by the Structure property.

**Get All Spaces**  Keeps all extra white space when reading the tags. For example, this option enables GoLive to display all spaces between the start and end `<PRE>` tags.

**Core Text**  Preserves the content of a tag without adding or deleting anything.

Choose an option from the End Tag pop-up menu:

**Required**  Specifies that the element needs an end tag.

**Optional (do not write)**  Indicates that the element does not need an end tag and that GoLive is not supposed to read or write one.

**Optional (write)**  Indicates that the element does not require an end tag but GoLive adds it anyway.

**Attribute**  Indicates that GoLive will not change the current end tag setting when rewriting source code.

Choose one of the following:

**Can Be Stripped**  Indicates that the element can be removed from the source code before publishing the page.

**Can Have Any Attribute**  Indicates that the element can have any attribute.

See also

“Methods of restoring default Web Settings” on page 640

**To set basic formatting for an element in the Markup Language tab**

For any element within Web Settings, you can control some basic formatting options in the Output tab of the Web Settings Element Inspector.

1  Select the element in the Markup Language tab of Web Settings.

2  In the Output tab of the Web Settings Element Inspector, choose a property for the following separation options:

**Outside**  Controls the vertical spacing between the start and end tags, and elements above and below them.

**Inside**  Controls the vertical spacing between the start and end tags, and their content.

3  Select the Indent Content option to indent content between start and end tags.

4  From the Group menu, select a Key Set option to format the element with attributes specified in the Source Themes preferences.
See also

“Methods of restoring default Web Settings” on page 640

To edit an element attribute in the Markup Language tab

You can use the Web Settings Attribute Inspector to set an attribute's function, value type, and default value. You can edit attributes or define new attributes.

1. Enter the attribute's name in the Attr Name box.
2. Enter a description in the Comment box.
3. The Attribute Is value is used by the GoLive Syntax Checker to report code errors, but does not determine whether the attribute is written by GoLive. Choose a property from the Attribute Is pop-up menu:
   - **Optional**  Specifies that the attribute is not necessary.
   - **Required**  Specifies that the attribute is required in order for the tag to be read correctly.
   - **Alternate**  Specifies that Optional, Required, or not defined are acceptable.
   - **Fixed**  Specifies that the property has a permanent default value.
4. Choose a property from the Value Type pop-up menu:
   - **Text**  Allows any Western-encoded alphanumeric character string. Use this option if you are not sure about the usage.
   - **Encoded Text**  Allows any alphanumeric character string in any encoding.
   - **Number**  Allows a numerical value only.
   - **Enumeration**  Indicates that a fixed set of properties are available.
   - **Color**  Permits an RGB color code only.
   - **URL**  Allows a Uniform Resource Locator only.
   - **JavaScript**  Allows JavaScript code only.
   - **ID**  Allows a unique string.
   - **IDRef**  Allows a link to an ID.
   - **IDRefs**  Allows a link to a group of IDs.
   - **Entity**  Allows any special character entity.
   - **Entities**  Allows a group of special character entities.
   - **Nmtoken, Nmtokens, and Notation**  Specify valid names and are used in XML.
5. Select Create This Attribute, and choose a property from the pop-up menu (if one is available), or enter a value in the text box.

Note: When Create This Attribute is selected and a value is entered in the text box, some attributes are automatically inserted in the source code when the tag is added to a page. If the attribute is not inserted by GoLive, you can insert it from the tag's attribute pop-up menu in the Outline Editor or enter it manually in the Source Code Editor.

See also

“Methods of restoring default Web Settings” on page 640
To edit an enumeration in the Markup Language tab
1 Enter the enumeration name in the Enum Name box of the Web Settings Enum Inspector.
2 Enter a description in the Comment box.
All enumerations appear in the Value pop-up menu of the Web Settings Attribute Inspector and in the attribute's Enumeration pop-up menu in the Outline Editor.

See also
“Methods of restoring default Web Settings” on page 640

To import an XML DTD file
1 In the Markup Language tab of Web Settings, choose Import XML-DTD from the context menu of the left pane.
2 Open a DTD file.
The DTD file appears within a folder named Imported in the Markup Language tab. Elements, entities, and notations contained in the DTD are listed in the right pane.

See also
“Methods of restoring default Web Settings” on page 640
“To edit an XML DTD file” on page 645

To edit an XML DTD file
An imported Document Type Definition (DTD) file can be bound to file extensions and mime types. This enables GoLive to open any file of that extension and associate it with the imported DTD for syntax checking, and element placement in the Outline Editor.
1 In the Markup Language tab of Web Settings, select the DTD file name on the left.
2 In the XML DTD Inspector, enter an extension, or multiple extensions separated by commas, in the Extensions box.
3 Edit the elements, attributes, and enumerations as needed.

See also
“To import an XML DTD file” on page 645
“To edit an element in the Markup Language tab” on page 642
“To edit an element attribute in the Markup Language tab” on page 644
“Methods of restoring default Web Settings” on page 640
Characters options in Web Settings

Characters options
The Characters tab of Web Settings includes all the special characters specified by ISO 8859-1 and the HTML 3.2 standard. HTML uses a specific notation for encoding special characters to ensure a uniform display across multiple computer platforms. GoLive uses the content of the Characters tab to map special characters added to your HTML documents to their web-specific character entity references.

To view special characters in the Characters tab
You can view the characters sorted by category (Structured), or you can view them alphabetically (Flat). If a character can't be displayed in the system font, a small box (Windows) or an x (Mac OS) appears in the Char column of the Characters tab of Web Settings instead of the character.

1 Open the Characters tab of Web Settings, and in the View palette select one of the following options:
• To view the characters alphabetically, select Flat.
• To view the characters grouped by category, select Structured.
2 Scroll through the list of characters (if the view is set to Structured, then expand a category), and select a character under the Name column. The Web Settings Entity Inspector displays the following information for the character:
• The left Name box displays the character's HTML name, and the right box shows the HTML code that is inserted by default into the source code.
• Comment describes the character.
• The left Unicode box (Windows and Mac OS) displays the character code, the middle (Windows) or right (Mac OS) box displays the byte code, and the right box (Windows only) displays the character's visual representation. You can select and copy the character in the right Unicode box, and paste it into the Layout Editor of a document.
• Select Write to write the related text box into the document rather than the left Name box. Enter the character entity reference without the starting ampersand and closing semicolon. GoLive will insert the new character entity instead of the default entity. This option might be used when you want GoLive to insert a character's numeric HTML entity rather than the named HTML entity.

To show or hide columns in the Characters tab
❖ From the context menu of any of the column heads, Right-click (Windows) or Control-click (Mac OS), and choose a column name or an option. You can show or hide all of the columns, or show a selection of columns.

To add a special character to a document
1 In the Characters tab of Web Settings, select the character.
2 In the Web Settings Entity Inspector, select the character in the third Unicode Code box (Windows) or the third Mac box (Mac OS), and choose Copy from the context menu.
3 In the document Layout Editor, choose Edit > Paste in the desired insertion point.

**Guidelines for adding and editing special characters**

Use the following guidelines when adding new characters:

- New characters must be W3C-specified characters that are supported by browsers.
- GoLive for Mac OS doesn't display all characters. To preview such characters, you may have to launch a browser.
- Characters specific to Mac OS can be added, but they won't display in browsers.

**See also**

"Methods of restoring default Web Settings" on page 640

**To create a special character**

1 In the Characters tab of the Web Settings window, select an existing character or a category to which you want to add a character.

2 Do one of the following:

   - To add a new character, click the New Entity button or choose Add Entity from the context menu.
   - To duplicate a selected character, click the Duplicate button.

3 Select the new character, or copy and edit its properties in the Web Settings Entity Inspector:

   - Enter the HTML name of the new character in the Name box.
   - Enter a description in the Comment box.
   - Enter the Unicode mnemonic code and its equivalent byte code in the Unicode Code boxes.
   - If there is a Mac OS equivalent, select Mac, and enter the mnemonic code and its equivalent byte code. Mac OS characters are displayed in the preview pane.
   - Select Write to write the adjacent text box into the document rather than the Name box. Enter the character entity reference without the starting ampersand and closing semicolon.
Browser Profiles options in Web Settings

Browser Profiles options
The Browser Profiles tab ▶️ in Web Settings contains display profiles of popular browsers on Windows and Mac OS. You can select any listed browser and platform to serve as the default profile for viewing documents in the Layout Editor. The alternate profiles can be used for previewing pages with the View palette.

The profiles let you simulate how fonts and other design elements display on Windows and Mac OS. They do not affect how GoLive writes HTML code, or what the viewer sees when visiting your site. The profiles are made with cascading stylesheets that use element selector styles. If you know how to build cascading stylesheets, you can duplicate an existing profile and edit it to create a new browser profile.

Note: The stylesheets that you create in the CSS Editor are not affected by or related to the stylesheet-based profiles in the Browser Profiles tab of Web Settings.

See also
“Methods of restoring default Web Settings” on page 640

To view browser profiles
The browser profiles in the Browser Profiles tab of Web Settings are write-protected. You can only inspect their properties.

1 In the Browser Profiles tab of the Web Settings window, select a profile from the list.
2 In the Root Style Sheet Inspector, click the Basic tab to view the profiled system and comments.
3 Select the Settings tab to view the screen resolution and other options.

To create a new browser profile
You can create a new browser profile if you want more Profile options in the View palette.

1 In the Browser Profiles tab of the Web Settings window, select the profile that best resembles your target browser, and choose Duplicate from the context menu.
2 Select the new duplicate profile, and in the Basic tab of the Root Style Sheet Inspector, enter a name, system information, and comments.
3 In the Settings tab of the Inspector, enter a screen resolution (96 is typical for Windows, 72 for Mac OS) in the DPI box, and select Can Handle Style Sheets.
4 The new profile appears in the Profile pop-up menu of the View palette.

See also
“Methods of restoring default Web Settings” on page 640
Simulating the effects of different browsers and platforms

The Root profile in the Browser Profiles tab of Web Settings determines the default profile used to display your documents in the Layout Editor. You can use the Basic Profiles and User Profiles menus in the View palette to simulate your document's appearance in different browsers and platforms.

To set a default browser profile for the Layout Editor

❖ In the Browser Profiles tab of Web Settings, select the Root Radio button adjacent to the browser profile under the Root column.

See also

“Methods of restoring default Web Settings” on page 640

File Mappings and Global options in Web Settings

File Mappings options

The File Mappings tab shows the MIME type for various file extensions and the application that is assigned to open each of them. If the Application column in the Web Settings window is set to Default, the application that will be launched is the same as that mapped in the operating system. You can modify the existing mappings or add new ones.

To change the display of file mappings

You can view all of the file name suffixes defined in Web Settings, and also the type of file, MIME type, and the application mapped to each.

1 Open the File Mappings tab of the Web Settings window.
2 In the View palette, select a View property.
3 To show or hide columns, right-click (Windows) or Control-click (Mac OS) and choose a column name.

To edit file mappings

❖ In the File Mappings tab of Web Settings, do any of the following:

- To add a mapping, select By MIME Type in the View palette. Select a Mime type category in the Web Settings window, and click the New Extension button in the toolbar. Edit the new mapping in the File Info Extension Inspector.
- To delete a new mapping, select the suffix, and choose Delete from the context menu or press Delete on the keyboard.
- To set the FTP method, select the mapping suffix, and choose a Transfer property in the File Info Extension Inspector.
• (Mac OS) To change the application that is launched when the file is double-clicked in GoLive, specify the Mac File Type and File Creator in the File Info Extension Inspector. Alternatively, click the Browse button next to the Application box, and browse to the application.

• (Windows) To change the application that is launched when the file is double-clicked in GoLive, click the Browse button next to the Application box in the File Info Extension Inspector, and browse to the application.

See also
“Methods of restoring default Web Settings” on page 640

Global options
The Global tab of the Web Settings window contains options for formatting the source code, such as indentation, and lowercase and uppercase usage. You can preview most changes you make to these options in the Source Code palette.

For information about global XHTML options, see “To convert the doctype of a document from HTML to XHTML” on page 162. Global HTML, CSS, and White Space options appear below:

Tag case, Attribute case Specifies how HTML tags or attributes are written:
- Upper Case Uses only uppercase characters in the tag or attribute name.
- Lower Case Uses only lowercase characters in tags or attributes.
- Capital Capitalizes the first letter of each tag or attribute name.

Quote attribute values Determines whether values for HTML tag attributes are enclosed in straight quotation marks:
- Always Inserts quotation marks around all attribute values, for example, <IMG SRC="logo.gif">.
- Except Numbers Encloses all attribute values, except for numerals, for example, <IMG SRC="logo.gif" width=50>.
- Only if Necessary Inserts quotation marks if there is a risk of ambiguity.

Color name translation Determines whether color values are written using color names:
- Do Not Uses hexadecimal RGB values, for example, "#000000" for "Black".
- 16 Basics Uses the color names for sixteen basic colors, such as “purple” for the hexadecimal value “#800080”, and uses the hexadecimal value for all other colors.
- Netscapes Uses the Netscape-specific color names for certain RGB color values, such as “Lime” for the RGB value “0, 255, 0,” and uses the hexadecimal value for all other colors.

Default Unit Specifies the default unit used in Cascading Style Sheets (CSS).

Output Determines the spatial format used to arrange CSS source code.

Indent with (CSS) Specifies whether CSS source code is indented.
**Indent with (White Space)**  Sets the indentation value and the type of indentation between sets of container tags in the source code.

**Line break character**  Specifies how line breaks are written for your web server platform:

- **Macintosh (CR)**  Inserts a carriage return character only.
- **Unix (LF)**  Inserts a line feed character only.
- **Windows (CR/LF)**  Inserts a carriage return and line feed character combination.
Chapter 28: Color management

Understanding color management

Why colors sometimes don't match

No device in a publishing system is capable of reproducing the full range of colors viewable to the human eye. Each device operates within a specific color space which can produce a certain range, or gamut, of colors.

A color model determines the relationship between values, and the color space defines the absolute meaning of those values as colors. Some color models have a fixed color space (such as Lab) because they relate directly to the way humans perceive color. These models are described as being device-independent. Other color models (RGB, HSL, HSB, CMYK, and so forth) can have many different color spaces. Because these models vary with each associated color space or device, they are described as being device-dependent.

Because of these varying color spaces, colors can shift in appearance as you transfer documents between different devices. Color variations can result from differences in image sources (scanners and software produce art using different color spaces); brands of computer monitors; the way software applications define color; print media (newsprint paper reproduces a smaller gamut than magazine-quality paper); and other natural variations, such as manufacturing differences in monitors or monitor age.

What is a color management system?

Color-matching problems result from various devices and software using different color spaces. One solution is to have a system that interprets and translates color accurately between devices. A color management system (CMS) compares the color space in which a color was created to the color space in which the same color will be output, and makes the necessary adjustments to represent the color as consistently as possible among different devices.

A color management system translates colors with the help of color profiles. A profile is a mathematical description of a device's color space. For example, a scanner profile tells a color management system how your scanner “sees” colors. Adobe applications use ICC profiles, a format defined by the International Color Consortium (ICC) as a cross-platform standard. (See “About color profiles” on page 665.)
Because no single color-translation method is ideal for all types of graphics, a color management system provides a choice of rendering intents, or translation methods, so that you can apply a method appropriate to a particular graphical element. For example, a color translation method that preserves correct relationships among colors in a wildlife photograph may alter the colors in a logo containing flat tints of color. (See “About rendering intents” on page 673.)

**Note:** Don't confuse color management with color correction. A color management system won't correct an image that was saved with tonal or color balance problems. It provides an environment where you can evaluate images reliably in the context of your final output.

**Do you need color management?**

Without a color management system, your color specifications are device-dependent. You might not need color management if your production process is tightly controlled for one medium only. For example, you or your prepress service provider can tailor CMYK images and specify color values for a known, specific set of printing conditions.

The value of color management increases when you have more variables in your production process. Color management is recommended if you anticipate reusing color graphics for print and online media, using various kinds of devices within a single medium (such as different printing presses), or if you manage multiple workstations.

You will benefit from a color management system if you need to accomplish any of the following:

- Get predictable and consistent color output on multiple output devices including color separations, your desktop printer, and your monitor. Color management is especially useful for adjusting color for devices with a relatively limited gamut, such as a four-color process printing press.

- Accurately soft-proof (preview) a color document on your monitor by making it simulate a specific output device. (Soft-proofing is subject to the limitations of monitor display, such as room lighting conditions.)

- Accurately evaluate and consistently incorporate color graphics from many different sources if they also use color management, and even in some cases if they don't.

- Send color documents to different output devices and media without having to manually adjust colors in documents or original graphics. This is valuable when creating images that will eventually be used both in print and online.

- Print color correctly to an unknown color output device; for example, you could store a document online for consistently reproducible on-demand color printing anywhere in the world.

**Creating a viewing environment for color management**

Your work environment influences how you see color on your monitor and on printed output. For best results, control the colors and light in your work environment by doing the following:

- View your documents in an environment that provides a consistent light level and color temperature. For example, the color characteristics of sunlight change throughout the day and alter the way colors appear on your screen, so keep shades closed or work in a windowless room. To eliminate the blue-green cast from fluorescent lighting, you can install D50 (5000˚ Kelvin) lighting. You can also view printed documents using a D50 lightbox.

- View your document in a room with neutral-colored walls and ceiling. A room's color can affect the perception of both monitor color and printed color. The best color for a viewing room is polychromatic gray. Also, the color of your clothing reflecting off the glass of your monitor may affect the appearance of colors on-screen.
- Remove colorful background patterns on your monitor desktop. Busy or bright patterns surrounding a document interfere with accurate color perception. Set your desktop to display neutral grays only.

- View document proofs in the real-world conditions under which your audience will see the final piece. For example, you might want to see how a housewares catalog looks under the incandescent light bulbs used in homes, or view an office furniture catalog under the fluorescent lighting used in offices. However, always make final color judgements under the lighting conditions specified by the legal requirements for contract proofs in your country.

### Keeping colors consistent

#### About color management in Adobe applications

Adobe's color management system helps you maintain the appearance of colors as you bring images in from external sources, edit documents and transfer them between Adobe applications, and output your finished compositions. This system is based on conventions developed by the International Color Consortium (ICC), a group responsible for standardizing profile formats and procedures so that consistent and accurate color can be achieved throughout a workflow.

By default, color management is turned on in Adobe applications. If you purchased the Adobe Creative Suite, color settings are synchronized across applications to provide consistent display for RGB and CMYK colors. This means that colors look the same no matter which application you view them in.

![Color settings for each Creative Suite application are synchronized in a central location through Adobe Bridge.](image)

If you decide to change the default settings, easy-to-use presets let you configure Adobe's color management system to match common output conditions. You can also customize color settings to meet the demands of your particular color workflow.

Keep in mind that the kinds of images you work with and your output requirements influence how you use color management. For example, there are different color-consistency issues for an RGB photo printing workflow, a CMYK commercial printing workflow, a mixed RGB/CMYK digital printing workflow, and an internet publishing workflow.
Basic steps for producing consistent color

1. **Consult with your production partners (if you have any) to ensure that all aspects of your color management workflow integrate seamlessly with theirs.**

   Discuss how the color workflow will be integrated with your workgroups and service providers, how will software and hardware be configured for integration into the color management system, and at what level will color management be implemented. (See “Do you need color management?” on page 653.)

   For more information on common color management workflows, see the Color Workflow Guide on your application CD.

2. **Calibrate and profile your monitor.**

   A monitor profile is the first profile you should create. Seeing accurate color is essential if you are making creative decisions involving the color you specify in your document. (See “To calibrate and profile your monitor” on page 667.)

3. **Add color profiles to your system for any input and output devices you plan to use, such as scanners and printers.**

   The color management system uses profiles to know how a device produces color and what the actual colors in a document are. Device profiles are often installed when a device is added to your system. You can also use third-party software and hardware to create more accurate profiles for specific devices and conditions. If your document will be commercially printed, contact your service provider to determine the profile for the printing device or press condition. (See “About color profiles” on page 665 and “To install a color profile” on page 668.)

4. **Set up color management in Adobe applications.**

   The default color settings are sufficient for most users. However, you can change the color settings by doing one of the following:

   - If you use multiple Adobe applications, use Bridge to choose a standard color management configuration and synchronize color settings across applications before working with documents. (See “To synchronize color settings across Adobe applications” on page 656.)
   - If you use only one Adobe application, or if you want to customize advanced color management options, you can change color settings for a specific application. (See “To set up color management for Illustrator, InDesign, and Photoshop” on page 656 or “To set up color management for GoLive” on page 656.)

5. **(Optional) Preview colors using a soft proof.**

   After you create a document, you can use a soft proof to preview how colors will look when printed or viewed on a specific device. (See “Soft-proofing colors” on page 661.)

   **Note:** A soft proof alone doesn't let you preview how overprinting will look when printed on an offset press. If you work with Illustrator or InDesign documents that contain overprinting, turn on Overprint Preview to accurately preview overprints in a soft proof.

6. **Use color management when printing and saving files.**

   Keeping the appearance of colors consistent across all of the devices in your workflow is the goal of color management. Leave color management options enabled when printing documents, saving files, and preparing files for online viewing. (See “Printing with color management” on page 663 and “Color-managing documents for online viewing” on page 660.)
To synchronize color settings across Adobe applications

When you set up color management using Adobe Bridge, color settings are automatically synchronized across applications. This synchronization ensures that colors look the same in all Adobe Creative Suite applications.

If color settings are not synchronized, a warning message appears at the top of the Color Settings dialog box in every Creative Suite application. Adobe recommends that you synchronize color settings before you work with new or existing documents.

1. Open Bridge.
   To open Bridge from another Creative Suite application, choose File > Browse from the application. To open Bridge directly, either choose Adobe Bridge from the Start menu (Windows) or double-click the Adobe Bridge icon (Mac OS).

2. Choose Edit > Creative Suite Color Settings.

3. Select a color setting from the list, and click Apply.
   If none of the default settings meet your requirements, select Show Expanded List Of Color Setting Files to view additional settings. To install a custom settings file, such as a file you received from a print service provider, click Show Saved Color Settings Files.

To set up color management for Illustrator, InDesign, and Photoshop

1. Choose Edit > Color Settings.

2. Select a color setting from the Settings menu, and click OK.
   The setting you select determines the color working spaces used by the application, what happens when you open and import files with embedded profiles, and how the color management system converts colors. To view a description of a setting, select the setting and then position the pointer over the setting name. The description appears at the bottom of the dialog box.

   In certain situations, such as if your service provider supplies you with a custom output profile, you may need to customize specific options in the Color Settings dialog box. However, customizing is recommended for advanced users only.

   **Note:** If you work with more than one Adobe application, it is highly recommended that you synchronize your color settings across applications. (See “To synchronize color settings across Adobe applications” on page 656.)

See also

“To customize color settings” on page 670

To set up color management for GoLive

By default, GoLive's color management system uses a standard web workflow in which you author web pages and import images in the sRGB color space. sRGB reflects the characteristic of the average PC monitor and is therefore applicable to the majority of web users. If you have a highly controlled distribution for your website (for example, you know that the majority of users will view the site using Apple Macintosh computers), you can override the standard web workflow.

1. Choose Edit > Color Settings.

2. If you want to author web pages in a color space other than sRGB, or you want to preserve embedded profiles in RGB images, deselect Use Standard Web Workflow.
Adobe recommends that you leave the Use Standard Web Workflow option selected.

3 Select a color setting from the Settings menu, and click OK.

The setting you select determines the color working space of the application, what happens when you open and import files with embedded profiles, and how the color management system converts colors. You can view the options for a color setting directly in the Color Settings dialog box.

In most cases, it is best to use a standard color setting and not change specific options in the Color Settings dialog box. Customizing the working spaces, color management policies, and color conversion options is recommended for advanced users only.

Note: If you work with more than one Adobe application, it is recommended that you synchronize your color settings across applications. (See “To synchronize color settings across Adobe applications” on page 656.)

To change the appearance of CMYK black
In Illustrator and InDesign, pure CMYK black (K=100) appears jet black (or rich black) when viewed on-screen, printed to a non-Postscript desktop printer, or exported to an RGB file format. If you prefer to see the difference between pure black and rich black as it will appear when printed on a commercial press, you can change the Appearance Of Black preferences. These preferences do not change the color values in a document.

1 Choose Edit > Preferences > Appearance Of Black (Windows) or Application name > Preferences > Appearance Of Black (Mac OS).

2 Choose an option for On Screen:
   Display All Blacks Accurately Displays pure CMYK black as dark gray. This setting allows you to see the difference between pure black and rich black.
   Display All Blacks As Rich Black Displays pure CMYK black as jet black (RGB=000). This setting makes pure black and rich black appear the same on-screen.

3 Choose an option for Printing/Exporting:
   Output All Blacks Accurately When printing to a non-Postscript desktop printer or exporting to an RGB file format, outputs pure CMYK black as using the color numbers in the document. This setting allows you to see the difference between pure black and rich black.
   Output All Blacks As Rich Black When printing to a non-Postscript desktop printer or exporting to an RGB file format, outputs pure CMYK black as jet black (RGB=000). This setting makes pure black and rich black appear the same.

Managing process and spot colors
When color management is on, any color you apply or create within an Adobe application automatically uses a color profile that corresponds to the document. If you switch color modes, the color management system uses the appropriate profiles to translate the color to the new color model you choose.

Keep in mind the following guidelines for working with process and spot colors:

- Choose a CMYK working space that matches your CMYK output conditions to ensure that you can accurately define and view process colors.
- Select colors from a color library. Adobe applications come with several standard color libraries, which you can load using the Swatches palette menu.
• (Illustrator and InDesign) Turn on Overprint Preview to get an accurate and consistent preview of spot colors.

• (Illustrator and InDesign) Use Lab values (the default) to display predefined spot colors (such as colors from the TOYO, PANTONE, DIC, and HKS libraries) and convert these colors to process colors. Using Lab values provides the greatest accuracy and guarantees the consistent display of colors across Creative Suite applications. If you want the display and output of these colors to match earlier versions of Illustrator or InDesign, use CMYK equivalent values instead. For instructions on switching between Lab values and CMYK values for spot colors, search Illustrator or InDesign Help

Note: Color-managing spot colors provides a close approximation of a spot color on your proofing device and monitor. However, it is difficult to exactly reproduce a spot color on a monitor or proofing device because many spot color inks exist outside the gamuts of many of those devices.

To share swatches between applications
You can share the solid swatches you create in one Adobe CS2 application with any other Adobe CS2 application by saving a swatch library for exchange. The colors appear exactly the same across applications as long as your color settings are synchronized.

1 In the Swatches palette, create the process and spot-color swatches you want to share, and remove any swatches you don’t want to share.

Note: You cannot share the following types of swatches between applications: patterns, gradients, and the Registration swatch from Illustrator or InDesign; and book color references, HSB, XYZ, duotone, monitorRGB, opacity, total ink, and webRGB swatches from Photoshop. These types of swatches are automatically excluded when you save swatches for exchange.

2 Select Save Swatches For Exchange from the Swatches palette menu, and save the swatch libraries in an easily accessible location.

3 Load the swatch library into the Swatches palette for any other Adobe CS2 application. See that application’s Help for additional instructions.

Color-managing imported images

Color-managing imported images
How imported images are integrated into a document’s color space depends on whether or not the image has an embedded profile:

• When you import an image that contains no profile, the Adobe application uses the current document profile to define the colors in the image.

• When you import an image that contains an embedded profile, color policies in the Color Settings dialog box determine how the Adobe application handles the profile. (See “Color Management Policy options” on page 672.)

Using a safe CMYK workflow
In Illustrator and InDesign, a safe CMYK workflow ensures that CMYK color numbers are preserved all the way to the final output device, as opposed to being converted by your color management system. This workflow is beneficial if you want to incrementally adopt color management practices. For example, you can use CMYK profiles to soft-proof and hard-proof documents without the possibility of unintended color conversions occurring during final output.
Illustrator and InDesign support a safe CMYK workflow by default. As a result, when you open or import a CMYK image with an embedded profile, the application ignores the profile and preserves the raw color numbers. If you want your application to adjust color numbers based on an embedded profile, change the CMYK color policy in the Color Settings dialog box. You can easily restore the safe CMYK workflow by changing the CMYK color policy back to Preserve Numbers (Ignore Linked Profiles).

You can override safe CMYK settings when you print a document or save it to PDF. However, doing so may cause colors to be reseparated. For example, pure CMYK black objects may be reseparated as rich black. For more information on color management options for printing and saving PDF files, search in Help.

**See also**

“Color Management Policy options” on page 672

**Preparing imported graphics for color management**

Use the following general guidelines to prepare graphics for being color-managed in Adobe applications:

- Embed an ICC-compliant profile when you save the file. The file formats that support embedded profiles are JPEG, PDF, PSD (Photoshop), AI (Illustrator), INDD (InDesign), and TIFF. (See “To embed a color profile in a document” on page 668.)

- If you plan to reuse a color graphic for multiple final output devices or media, such as for print, video, and the web, prepare the graphic using RGB or Lab colors whenever possible. If you must save in a color model other than RGB or Lab, keep a copy of the original graphic. RGB and Lab color models represent larger color gamuts than most output devices can reproduce, retaining as much color information as possible before being translated to a smaller output color gamut.

**To view or change profiles for imported bitmap images**

InDesign allows you to view, override, or disable profiles for imported bitmap images. This may be necessary when you are importing an image containing no profile or an incorrectly embedded profile. For example, if the scanner manufacturer's default profile was embedded but you have since generated a custom profile, you can assign the newer profile.

1. Do one of the following:

   - If the graphic is already in layout, select it and choose Object > Image Color Settings.
   - If you're about to import the graphic, choose File > Place, select Show Import Options, locate and select the file, and click Place. Then choose Color Settings from the menu at the top of the Image Import Options dialog box that appears.

2. For Profile, choose the source profile to apply to the graphic in your document. If a profile is currently embedded, the profile name appears at the top of the Profile menu.

3. (Optional) For Rendering Intent, choose a rendering intent. In most cases, it's best to use the default rendering intent.

4. Click OK.
Color-managing documents for online viewing

Color-managing documents for online viewing
Color management for online viewing is very different from color management for printed media. With printed media, you have far more control over the appearance of the final document. With online media, your document will appear on a wide range of possibly uncalibrated monitors and video display systems, significantly limiting your control over color consistency.

When you color-manage documents that will be viewed exclusively on the web, Adobe recommends that you use the sRGB color space. sRGB is the default working space for most Adobe color settings, but you can verify that sRGB is selected in the Color Settings dialog box of any Creative Suite application. With the working space set to sRGB, any RGB graphics you create will use sRGB as the color space.

When working with images that have an embedded color profile other than sRGB, you should convert the image's colors to sRGB before you save the image for use on the web. If you want the application to automatically convert the colors to sRGB when you open the image, select Convert To Working Space as the RGB color management policy. In Photoshop and InDesign, you can also manually convert the colors to sRGB using the Edit > Convert To Profile command.

See also
“About color working spaces” on page 670
“Color Management Policy options” on page 672

Color-managing PDF documents for online viewing
When you export Portable Document Format (PDF) files, you can choose to embed profiles. PDF files with embedded profiles reproduce color consistently in Acrobat 4.x or later running under a properly configured color management system. For information about color management in Acrobat software, see Acrobat online Help.

Keep in mind that embedding color profiles increases the size of PDF files. RGB profiles are usually small (around 3K); however, CMYK profiles can range from .5 to 2 MB.

See also
“Color-managing PDF files for printing” on page 664

Color-managing HTML documents for online viewing
Many web browsers do not support color management. Of the browsers that do support color management, not all instances can be considered color-managed because they may be running on systems where the monitors are not calibrated. In addition, few web pages contain images with embedded profiles. If you manage a highly controlled environment, such as the intranet of a design studio, you may be able to achieve some degree of HTML color management for images by equipping everyone with a browser that supports color management and calibrating all monitors.

You can approximate how colors will look on non-calibrated monitors by using the sRGB color space. In Adobe GoLive, you can also preview how colors will look in different browsers using options in the View palette. (See “To preview how colors will appear in a web browser” on page 663.) However, because color reproduction varies among uncalibrated monitors, you still won't be able to anticipate the true range of potential display variations.
Proofing colors

Soft-proofing colors

In a traditional publishing workflow, you print a hard proof of your document to preview how its colors will look when reproduced on a specific output device. In a color-managed workflow, you can use the precision of color profiles to soft-proof your document directly on the monitor. You can display an on-screen preview of how your document’s colors will look when reproduced on a particular output device. If you are authoring a website in GoLive, you can also soft-proof how colors will look when viewed in different browsers and with different color profiles.

Keep in mind that the reliability of the soft proof depends upon the quality of your monitor, the profiles of your monitor and output devices, and the ambient lighting conditions of your work environment.

Note: A soft proof alone doesn't let you preview how overprinting will look when printed on an offset press. If you work with Illustrator or InDesign documents that contain overprinting, turn on Overprint Preview to accurately preview overprints in a soft proof.

Using a soft proof to preview the final output of a document on your monitor

A. Document in the working space  
B. Document's color values are translated to color space of chosen proof profile (usually the output device's profile).  
C. Monitor displays proof profile's interpretation of document's color values.

To soft-proof colors

1 In Illustrator, InDesign, or Photoshop, choose View > Proof Setup, and do one of the following:
   • Choose a preset that corresponds to the output condition you want to simulate. (See “Soft proof presets” on page 662.)
   • Choose Custom (Photoshop and InDesign) or Customize (Illustrator) to create a custom proof setup for a specific output condition. This option is recommended for the most accurate preview of your final printed piece. (See “Custom soft proof options” on page 662.)

2 Choose View > Proof Colors to toggle the soft-proof display on and off. When soft proofing is on, a check mark appears next to the Proof Colors command, and the name of the proof preset or profile appears at the top of the document window.

To compare the colors in the original image and the colors in the soft proof, open the document in a new window before you set up the soft proof.
Soft proof presets

**Working CMYK**  Creates a soft proof of colors using the current CMYK working space as defined in the Color Settings dialog box.

**Document CMYK (InDesign)**  Creates a soft proof of colors using the document’s CMYK profile.

**Working Cyan Plate, Working Magenta Plate, Working Yellow Plate, Working Black Plate, or Working CMY Plates (Photoshop)**  Creates a soft proof of specific CMYK ink colors using the current CMYK working space.

**Macintosh RGB or Windows RGB (Photoshop and Illustrator)**  Creates a soft proof of colors in an image using either a standard Mac OS or Windows monitor as the proof profile space to simulate. Both options assume that the simulated device will display your document without using color management. Neither option is available for Lab or CMYK documents.

**Monitor RGB (Photoshop and Illustrator)**  Creates a soft proof of colors in an RGB document using your current monitor color space as the proof profile space. This option assumes that the simulated device will display your document without using color management. This option is unavailable for Lab and CMYK documents.

Custom soft proof options

**Device To Simulate**  Specifies the color profile of the device for which you want to create the proof. The usefulness of the chosen profile depends on how accurately it describes the device’s behavior. Often, custom profiles for specific paper and printer combinations create the most accurate soft proof.

**Preserve CMYK Numbers or Preserve RGB Numbers**  Simulates how the colors will appear without being converted to the color space of the output device. This option is most useful when you are following a safe CMYK workflow. (See “Using a safe CMYK workflow” on page 658.)

**Rendering Intent (Photoshop and Illustrator)**  When the Preserve Numbers option is deselected, specifies a rendering intent for converting colors to the device you are trying to simulate. (See “About rendering intents” on page 673.)

**Use Black Point Compensation (Photoshop)**  Ensures that the shadow detail in the image is preserved by simulating the full dynamic range of the output device. Select this option if you plan to use black point compensation when printing (which is recommended in most situations).

**Simulate Paper Color**  Simulates the dingy white of real paper, according to the proof profile. Not all profiles support this option.

**Simulate Black Ink**  Simulates the dark gray you really get instead of a solid black on many printers, according to the proof profile. Not all profiles support this option.

*In Photoshop, if you want the custom proof setup to be the default proof setup for documents, close all document windows before choosing the View > Proof Setup > Custom command.*

To save or load a custom proof setup in Photoshop


2. Do either of the following:
   - To save a custom proof setup, click Save. To ensure that the new preset appears in the View > Proof Setup menu, save the preset in the default location.
   - To load a custom proof setup, click Load.
To preview how colors will appear in a web browser

Different web browsers use different color spaces. For example, most Windows browsers display colors using the sRGB color space, while most Mac OS browsers display colors using the Apple RGB color space. You can preview how colors will look when viewed in different browsers using options in GoLive's View palette.

1. In GoLive, select the Layout Editor in the document window.
2. Click the Options tab in the View palette.
3. For Basic Profile, select the browser you want to emulate.
4. (Optional) For User Profiles, select an option from the Color submenu.
   
   For example, if you want to preview how colors look when displayed using embedded profiles, select Use Embedded Profiles. Or, if you want to preview how colors look when displayed in grayscale, select Mac Grayscale (Gray Gamma 1.8) or Windows Grayscale (Gray Gamma 2.2).

   **Note:** The Safari browser (listed under the Basic Profile > Other menu) is currently the only browser that supports embedded color profiles. Therefore, selecting User Profiles > Color > Use Embedded Profiles does not provide an accurate preview for any browser other than Safari.

   Each User Profiles > Color option you select overrides existing Basic Profile and User Profiles options. For example, if you select Explorer 6 Win for Basic Profile and then select Mac Colors (Apple RGB) for User Profiles > Color, GoLive displays colors using the Apple RGB color space.

Color-managing documents when printing

Printing with color management

Color management options for printing let you specify how you want Adobe applications to handle the outgoing image data so the printer will print colors consistent with what you see on your monitor. Your options for printing color-managed documents depend on the Adobe application you use, as well as the output device you select. In general, you have the following choices for handling colors during printing:

- Let the printer determine colors. (See "Letting the printer determine colors when printing" on page 663.)
- Let the application determine colors. (See "Letting the application determine colors when printing" on page 664.)
- (Photoshop and InDesign) Do not use color management. In this workflow, no color conversion occurs. You may also need to turn off color management in your printer driver. This method is useful primarily for printing test targets or generating custom profiles.

Letting the printer determine colors when printing

In this workflow, the application does no color conversion, but sends all necessary conversion information to the output device. This method is especially convenient when printing to inkjet photo printers, because each combination of paper type, printing resolution, and additional printing parameters (such as high speed printing) requires a different profile. Most new inkjet photo printers come with fairly accurate profiles built into the driver, so letting the printer select the right profile saves time and alleviates mistakes. This method is also recommended if you are not familiar with color management.

If you choose this option, it is very important that you set up printing options and turn on color management in your printer driver. Search Help for additional instructions.
If you select a PostScript printer, you can take advantage of PostScript color management. PostScript color management makes it possible to perform color composite output or color separations at the raster image processor (RIP)—a process called **in-RIP separations**—so that a program need only specify parameters for separation and let the device calculate the final color values. PostScript color-managed output workflows require an output device that supports PostScript color management using PostScript level 2, version 2017 or higher; or PostScript 3.

**Letting the application determine colors when printing**
In this workflow, the application does all the color conversion, generating color data specific to one output device. The application uses the assigned color profiles to convert colors to the output device's gamut, and sends the resulting values to the output device. The accuracy of this method depends on the accuracy of the printer profile you select. Use this workflow when you have custom ICC profiles for each specific printer, ink, and paper combination.

If you choose this option, it is very important that you disable color management in your printer driver. Letting the application and the printer driver simultaneously manage colors during printing results in unpredictable color. Search Help for additional instructions.

**Obtaining custom profiles for desktop printers**
If the output profiles that come with your printer don't produce satisfactory results, you obtain custom profiles in the following ways:

- Purchase a profile for your type of printer and paper. This is usually the easiest and least expensive method.
- Purchase a profile for your specific printer and paper. This method involves printing a profiling target on your printer and paper, and providing that target to a company that will create a specific profile. This is more expensive than purchasing a standard profile, but can provide better results because it compensates for any manufacturing variations in printers.
- Create your own profile using a scanner-based system. This method involves using profile-creation software and your own flatbed scanner to scan the profiling target. It can provide excellent results for matte surface papers, but not glossy papers. (Glossy papers tend to have fluorescent brighteners in them that look different to a scanner than they do in room light.)
- Create your own profile using a hardware profile-creation tool. This method is expensive but can provide the best results. A good hardware tool can create an accurate profile even with glossy papers.
- Tweak a profile created using one of the previous methods with profile-editing software. This software can be complex to use, but lets you correct problems with a profile or simply adjust a profile to produce results more to your taste.

**See also**
“To install a color profile” on page 668

**Color-managing PDF files for printing**
When you create Adobe PDF files for commercial printing, you can specify how color information is represented. The easiest way to do this is using a PDF/X standard; however, you can also specify color-handling options manually in the Output section of the PDF dialog box. For more information about PDF/X and how to create PDF files, search Help.
In general, you have the following choices for handling colors when creating PDF files:

- (PDF/X-3) Do not convert colors. Use this method when creating a document that will be printed or displayed on various or unknown devices. When you select a PDF/X-3 standard, color profiles are automatically embedded in the PDF file.

- (PDF/X-1a) Convert all colors to the destination CMYK color space. Use this method if you want to create a press-ready file that does not require any further color conversions. When you select a PDF/X-1a standard, no profiles are embedded in the PDF file.

- (Illustrator and InDesign) Convert colors that have embedded profiles to the destination color space, but preserve the numbers for those colors without embedded profiles. You can manually select this option in the Output section of the PDF dialog box. Use this method if the document contains CMYK images that aren't color-managed and you want to make sure that the color numbers are preserved. (See “Using a safe CMYK workflow” on page 658.)

Note: All spot-color information is preserved during color conversion; only the process color equivalents convert to the designated color space.

Working with color profiles

About color profiles

Precise, consistent color management requires accurate ICC-compliant profiles of all of your color devices. For example, without an accurate scanner profile, a perfectly scanned image may appear incorrect in another program, simply due to any difference between the scanner and the program displaying the image. This misleading representation may cause you to make unnecessary, time-wasting, and potentially damaging “corrections” to an already satisfactory image. With an accurate profile, a program importing the image can correct for any device differences and display a scan's actual colors.

A color management system uses the following kinds of profiles:

Monitor profiles Describe how the monitor is currently reproducing color. This is the first profile you should create because it is absolutely essential for managing color. If what you see on your monitor is not representative of the actual colors in your document, you will not be able to maintain color consistency. (See “To calibrate and profile your monitor” on page 667.)

Input device profiles Describe what colors an input device is capable of capturing or scanning. If your digital camera offers a choice of profiles, Adobe recommends that you select Adobe RGB. Otherwise, use sRGB (which is the default for most cameras). Advanced users may also consider using different profiles for different light sources. For scanner profiles, some photographers create separate profiles for each type or brand of film scanned on a scanner.

Output device profiles Describe the color space of output devices like desktop printers and a printing press. The color management system uses output device profiles to properly map the colors in an document to the colors within the gamut of an output device's color space. The output profile should also take into consideration specific printing conditions, such as the type of paper and ink. For example, glossy paper is capable of displaying a different range of colors than a matte paper.

Most printer drivers come with built-in color profiles. It's a good idea to try these profiles before you invest in custom profiles. For information on how to print using the built-in profiles, see “Letting the printer determine colors when
printing” on page 663. For information on how to obtain custom profiles, see “Obtaining custom profiles for desktop printers” on page 664.

**Document profiles** Define the specific RGB or CMYK color space of a document. By assigning, or tagging, a document with a profile, the application provides a definition of actual color appearances in the document. For example, $R=127$, $G=12$, $B=107$ is just a set of numbers that different devices will display differently. But when tagged with the AdobeRGB color space, these numbers specify an actual color or wavelength of light; in this case, a specific color of purple.

When color management is on, Adobe applications automatically assign new documents a profile based on Working Space options in the Color Settings dialog box. Documents without associated profiles are known as untagged and contain only raw color numbers. When working with untagged documents, Adobe applications use the current working space profile to display and edit colors. (See “About color working spaces” on page 670.)

> To view the current document profile, select Document Color Profile in the status bar.

Managing color with profiles

A. Profiles describe the color spaces of the input device and the document.  
B. Using the profiles’ descriptions, the color management system identifies the document’s actual colors.  
C. The monitor’s profile tells the color management system how to translate the numeric values to the monitor’s color space.  
D. Using the output device’s profile, the color management system translates the document’s numeric values to the color values of the output device so the actual colors are printed.

**About monitor calibration and characterization**

Profiling software such as Adobe Gamma can both calibrate and characterize your monitor. Calibrating your monitor brings it into compliance with a predefined standard; for example, adjusting your monitor so that it displays color using the graphics arts standard white point color temperature of 5000 degrees Kelvin. Characterizing your monitor simply creates a profile that describes how the monitor is currently reproducing color.
Monitor calibration involves adjusting the following video settings, which may be unfamiliar to you.

**Brightness and contrast**  The overall level and range, respectively, of display intensity. These parameters work just as they do on a television. Adobe Gamma helps you set an optimum brightness and contrast range for calibration.

**Gamma**  The brightness of the midtone values. The values produced by a monitor from black to white are nonlinear—if you graph the values, they form a curve, not a straight line. Gamma defines the value of that curve halfway between black and white.

**Phosphors**  The substances that CRT monitors use to emit light. Different phosphors have different color characteristics.

**White point**  The color and intensity of the brightest white the monitor can reproduce.

**To calibrate and profile your monitor**

When you calibrate your monitor, you are adjusting it so it conforms to a known specification. Once your monitor is calibrated, the profiling utility lets you save a color profile. The profile describes the color behavior of the monitor—what colors can or cannot be displayed on the monitor and how the numeric color values in an image must be converted so that colors are displayed accurately.

1. Make sure your monitor has been turned on for at least a half hour. This gives it sufficient time to warm up and produce more consistent output.

2. Make sure your monitor is displaying thousands of colors or more. Ideally, make sure it is displaying millions of colors or 24-bit or higher.

3. Remove colorful background patterns on your monitor desktop and set your desktop to display neutral grays. Busy patterns or bright colors surrounding a document interfere with accurate color perception.

4. Do one of the following to calibrate and profile your monitor:
   - In Windows, use the Adobe Gamma utility, located in the Control Panel.
   - In Mac OS, use the Calibrate utility, located in the System Preferences/Displays/Color tab.
   - For the best results, use third-party software and measuring devices. In general, using a measuring device such as a colorimeter along with software can create more accurate profiles because an instrument can measure the colors displayed on a monitor far more accurately than the human eye.

   **Note:** Monitor performance changes and declines over time; recalibrate and profile your monitor every month or so. If you find it difficult or impossible to calibrate your monitor to a standard, it may be too old and faded.

Most profiling software automatically assigns the new profile as the default monitor profile. For instructions on how to manually assign the monitor profile, refer to the Help system for your operating system.
To install a color profile
Color profiles are often installed when a device is added to your system. The accuracy of these profiles (often called generic profiles or canned profiles) varies from manufacturer to manufacturer. You can also obtain device profiles from your service provider, download profiles from the web, or create custom profiles using professional profiling equipment.

- In Windows, right-click a profile and select Install Profile. Alternatively, copy the profiles into the WINDOWS\system32\spool\drivers\color folder (Windows XP) or the WINNT\system32\spool\drivers\color folder (Windows 2000).
- In Mac OS, copy profiles into the /Library/Application Support/Adobe/Color/Profiles/Recommended folder. You can also copy profiles into the /Users/username/Library/ColorSync/Profiles folder.

After installing color profiles, be sure to restart Adobe applications.

See also
“Obtaining custom profiles for desktop printers” on page 664

To embed a color profile in a document
In order to embed a color profile in a document you created in Photoshop, Illustrator, or InDesign, you must save or export the document in a format that supports ICC profiles.

1 Save or export the document in one of the following file formats: Adobe PDF, PSD (Photoshop), AI (Illustrator), INDD (InDesign), JPEG, or TIFF.
2 Select the option for embedding ICC profiles. The exact name and location of this option varies between applications. Search Help in the relevant CS2 application for additional instructions.

Changing the color profile for a document
There are very few situations that require you to change the color profile for a document. This is because your application automatically assigns the color profile based on the settings you select in the Color Settings dialog box. The only times you should manually change a color profile are when preparing a document for a different output destination or correcting a policy behavior that you no longer want implemented in the document. Changing the profile is recommended for advanced users only.

You can change the color profile for a document in the following ways:

- Assign a new profile. The color numbers in the document remain the same, but the new profile may dramatically change the appearance of the colors as displayed on your monitor.
- Remove the profile so that the document in no longer color-managed.
- (Photoshop and InDesign) Convert the colors in the document to the color space of a different profile. The color numbers are shifted in an effort to preserve the original color appearances.
To assign or remove a color profile from a document in Photoshop or Illustrator

1 Choose Edit > Assign Profile.

2 Select an option, and click OK:

- **Don’t Color Manage This Document**  Removes the existing profile from the document. Select this option only if you are sure that you do not want to color-manage the document. After you remove the profile from a document, the appearance of colors is defined by the application’s working space profiles, and you can no longer embed a profile in the document.

- **Working [color model: working space]**  Assigns the working space profile to the document.

- **Profile**  Lets you select a different profile. The application assigns the new profile to the document without converting colors to the profile space. This may dramatically change the appearance of the colors as displayed on your monitor.

See also

“Changing the color profile for a document” on page 668

To assign or remove a color profile from a document in InDesign

1 Choose Edit > Assign Profiles.

2 For RGB Profile and CMYK Profile, select one of the following:

- **Discard (Use Current Working Space)**  Removes the existing profile from the document. Select this option only if you are sure that you do not want to color-manage the document. After you remove the profile from a document, the appearance of colors is defined by the application’s working space profiles, and you can no longer embed a profile in the document.

- **Assign Current Working Space <working space>**  Assigns the working space profile to the document.

- **Assign Profile**  Lets you select a different profile. The application assigns the new profile to the document without converting colors to the profile space. This may dramatically change the appearance of the colors as displayed on your monitor.

3 Choose a rendering intent for each type of graphic in your document. For each graphic type, you can choose one of the four standard intents, or the Use Color Settings Intent, which uses the rendering intent currently specified in the Color Settings dialog box. For more information on rendering intents, search in Help.

The graphic types include the following:

- **Solid Color Intent**  Sets the rendering intent for all vector art (solid areas of color) in InDesign native objects.

- **Default Image Intent**  Sets the default rendering intent for bitmap images placed in InDesign. You can still override this setting on an image-by-image basis. (See “To view or change profiles for imported bitmap images” on page 659.)

- **After-Blending Intent**  Sets the rendering intent to the proofing or final color space for colors that result from transparency interactions on the page. Use this option when your document includes transparent objects.

4 To preview the effects of the new profile assignment in the document, select Preview, and then click OK.

See also

“Changing the color profile for a document” on page 668
To convert colors in a document to another profile

1 In Photoshop or InDesign, choose Edit > Convert To Profile.

2 Under Destination Space, choose the color profile to which you want to convert the document’s colors. The document will be converted to and tagged with this new profile.

3 Under Conversion Options, specify a color management engine, a rendering intent, and black point and dither options. (See “Color Conversion options” on page 673.)

4 To flatten all layers of the document onto a single layer upon conversion, select Flatten Image.

5 To preview the effects of the conversion in the document, select Preview. This preview becomes more accurate if you select Flatten Image.

See also

“Changing the color profile for a document” on page 668

Color settings

To customize color settings

For most color-managed workflows, it is best to use a preset color setting which has been tested by Adobe Systems. Changing specific options is recommended only if you are knowledgeable about color management and very confident about the changes you make.

After you customize options, you can save them as a preset. Saving color settings ensures that you can reuse them and share them with other users or applications.

- To save color settings as a preset, click Save in the Color Settings dialog box. To ensure that the application displays the setting name in the Color Settings dialog box, save the file in the default location. If you save the file to a different location, you must load the file before you can select the setting.

- To load a color settings preset that’s not saved in the standard location, click Load in the Color Settings dialog box, select the file you want to load, and click Open.

About color working spaces

A working space is an intermediate color space used to define and edit color in Adobe applications. Each color model has a working space profile associated with it. You can choose working space profiles in the Color Settings dialog box.

A working space profile acts as the source profile for newly created documents that use the associated color model. For example, if Adobe RGB (1998) is the current RGB working space profile, each new RGB document that you create will use colors within the Adobe RGB (1998) gamut. Working spaces also determine the appearance of colors in untagged documents.

If you open a document embedded with a color profile that doesn’t match the working space profile, the application uses a color management policy to determine how to handle the color data. In most cases, the default policy is to preserve the embedded profile. For more information on setting up color management policies, see “About missing and mismatched color profiles” on page 671 and “Color Management Policy options” on page 672.
Working Space options
To display working space options, choose Edit > Color Settings.

To view a description of any profile, select the profile and then position the pointer over the profile name. The description appears at the bottom of the dialog box.

**RGB** Determines the RGB color space of the application. In general, it's best to choose Adobe RGB or sRGB, rather than the profile for a specific device (such as a monitor profile).

sRGB is recommended when preparing images for the web, because it defines the color space of the standard monitor used to view images on the web. sRGB is also a good choice when working with images from consumer-level digital cameras, because most of these cameras use sRGB as their default color space.

Adobe RGB is recommended when preparing documents for print, because Adobe RGB's gamut includes some printable colors (cyans and blues in particular) that can't be displayed using sRGB. Adobe RGB is also a good choice when working with images from professional-level digital cameras, because most of these cameras use Adobe RGB as their default color space.

**CMYK** Determines the CMYK color space of the application. All CMYK working spaces are device-dependent, meaning that they are based on actual ink and paper combinations. The CMYK working spaces Adobe supplies are based on standard commercial print conditions.

**Gray (Photoshop)** Determines Grayscale color space of the application.

**Spot (Photoshop)** Specifies the dot gain to use when displaying spot color channels and duotones.

Adobe applications ship with a standard set of working space profiles that have been recommended and tested by Adobe Systems for most color management workflows. By default, only these profiles appear in the working space menus. To display additional color profiles that you have installed on your system, select Advanced Mode (Illustrator and InDesign) or More Options (Photoshop). A color profile must be bi-directional, that is, contain specifications for translating both into and out of color spaces in order to appear in the working space menus.

*Note:* In Photoshop, you can create custom working space profiles. However, Adobe recommends that you use a standard working space profile rather than creating a custom working space profile. For more information, see the Photoshop support knowledgebase at http://www.adobe.com/support/products/photoshop.html.

About missing and mismatched color profiles
For a newly created document, the color workflow usually operates seamlessly: unless specified otherwise, the document uses the working space profile associated with its color mode for creating and editing colors.

However, some existing documents may not use the working space profile that you have specified, and some existing documents may not be color-managed. It is common to encounter the following exceptions to your color-managed workflow:

- You might open a document or import color data (for example, by copying and pasting or dragging and dropping) from a document that is not tagged with a profile. This is often the case when you open a document created in an application that either does not support color management or has color management turned off.
- You might open a document or import color data from a document that is tagged with a profile different from the current working space. This may be the case when you open a document that has been created using different color management settings, or a document that has been scanned and tagged with a scanner profile.

In either case, the application uses a color management policy to decide how to handle the color data in the document. (See “Color Management Policy options” on page 672.)
If the profile is missing or does not match the working space, the application may display a warning message, depending on options you set in the Color Settings dialog box. Profile warnings are turned off by default, but you can turn them on to ensure the appropriate color management of documents on a case-by-case basis. The warning messages vary between applications, but in general you have the following options:

- **(Recommended) Leave the document or imported color data as it is.** For example, you can choose to use the embedded profile (if one exists), leave the document without a color profile (if one doesn't exist), or preserve the numbers in pasted color data.
- **Adjust the document or imported color data.** For example, when opening a document with a missing color profile, you can choose to assign the current working space profile or a different profile. When opening a document with a mismatched color profile, you can choose to discard the profile or convert the colors to the current working space. When importing color data, you can choose to convert the colors to the current working space in order to preserve their appearance.

**Color Management Policy options**

A color management policy determines how the application handles color data when you open a document or import an image. You can choose different policies for RGB and CMYK images, and you can specify when you want warning messages to appear. To display color management policy options, choose Edit > Color Settings.

To view a description of a policy, select the policy and then position the pointer over the policy name. The description appears at the bottom of the dialog box.

**RGB, CMYK, and Gray** Specifies a policy to follow when bringing colors into the current working space (either by opening files or importing images into the current document). (The Grayscale option is available for Photoshop and GoLive only.) Choose from the following options:

- **Preserve Embedded Profiles** Always preserves embedded color profiles when opening files. This is the recommended option for most workflows because it provides consistent color management. One exception is if you're concerned about preserving CMYK numbers, in which case you should select Preserve Numbers (Ignore Linked Profiles) instead.

- **Convert to Working Space** Converts colors to the current working space profile when opening files and importing images. Select this option if you want to force all colors to use a single profile (the current working space profile).

- **Preserve Numbers (Ignore Linked Profiles)** This option is available in InDesign and Illustrator for CMYK. Preserves color numbers when opening files and importing images, but still allows you to use color management to view colors accurately in Adobe applications. Select this option if you want to use a safe CMYK workflow. (See “Using a safe CMYK workflow” on page 658.) In InDesign, you can override this policy on a per-object basis by choosing Object > Image Color Settings.

- **Off** Ignores embedded color profiles when opening files and importing images, and does not assign the working space profile to new documents. Select this option if you want to discard any color metadata provided by the original document creator.

**Profile Mismatches: Ask When Opening** Displays a message whenever you open a document tagged with a profile other than the current working space. You will be given the option to override the policy's default behavior. Select this option if you want to ensure the appropriate color management of documents on a case-by-case basis.

**Profile Mismatches: Ask When Pasting** Displays a message whenever color profile mismatches occur as colors are imported into a document via pasting or dragging-and-dropping. You will be given the option to override the policy's
default behavior. Select this option if you want to ensure the appropriate color management of pasted colors on a case-by-case basis.

**Missing Profiles: Ask When Opening** Displays a message whenever you open an untagged document. You will be given the option to override the policy's default behavior. Select this option if you want to ensure the appropriate color management of documents on a case-by-case basis.

**Color Conversion options**
Color conversion options let you control how the application handles the colors in a document as it moves from one color space to another. Changing these options is recommended only if you are knowledgeable about color management and very confident about the changes you make. To display conversion options, choose Edit > Color Settings, and select Advanced Mode (Illustrator and InDesign) or More Options (Photoshop).

**Engine** Specifies the Color Management Module (CMM) used to map the gamut of one color space to the gamut of another. For most users, the default Adobe (ACE) engine fulfills all conversion needs.

To view a description of an engine or intent option, select the option and then position the pointer over the option name. The description appears at the bottom of the dialog box.

**Intent** Specifies the rendering intent used to translate one color space to another. Differences between rendering intents are apparent only when you print a document or convert it to a different working space.

**Use Black Point Compensation** Ensures that the shadow detail in the image is preserved by simulating the full dynamic range of the output device. Select this option if you plan to use black point compensation when printing (which is recommended in most situations).

**Use Dither (Photoshop)** Controls whether to dither colors when converting 8-bit-per-channel images between color spaces. When the Use Dither option is selected, Photoshop mixes colors in the destination color space to simulate a missing color that existed in the source space. Although dithering helps to reduce the blocky or banded appearance of an image, it may also result in larger file sizes when images are compressed for web use.

**About rendering intents**
A rendering intent determines how a color management system handles color conversion from one color space to another. Different rendering intents use different rules to determine how the source colors are adjusted; for example, colors that fall inside the destination gamut may remain unchanged, or they may be adjusted to preserve the original range of visual relationships when translated to a smaller destination gamut. The result of choosing a rendering intent depends on the graphical content of documents and on the profiles used to specify color spaces. Some profiles produce identical results for different rendering intents.

In general, it is best to use the default rendering intent for the selected color setting, which has been tested by Adobe Systems to meet industry standards. For example, if you choose a color setting for North America or Europe, the default rendering intent is Relative Colorimetric. If you choose a color setting for Japan, the default rendering intent is Perceptual.
You can select a rendering intent when you set color conversion options for the color management system, soft-proof colors, and print artwork:

**Perceptual** Aims to preserve the visual relationship between colors so it's perceived as natural to the human eye, even though the color values themselves may change. This intent is suitable for photographic images with lots of out-of-gamut colors. This is the standard rendering intent for the Japanese printing industry.

**Saturation** Tries to produce vivid colors in an image at the expense of color accuracy. This rendering intent is suitable for business graphics like graphs or charts, where bright saturated colors are more important than the exact relationship between colors.

**Relative Colorimetric** Compares the extreme highlight of the source color space to that of the destination color space and shifts all colors accordingly. Out-of-gamut colors are shifted to the closest reproducible color in the destination color space. Relative colorimetric preserves more of the original colors in an image than Perceptual. This is the standard rendering intent for printing in North America and Europe.

**Absolute Colorimetric** Leaves colors that fall inside the destination gamut unchanged. Out of gamut colors are clipped. No scaling of colors to destination white point is performed. This intent aims to maintain color accuracy at the expense of preserving relationships between colors and is suitable for proofing to simulate the output of a particular device. This intent is particularly useful for previewing how paper color affects printed colors.

**Advanced controls**
In Photoshop you display advanced controls for managing color by choosing Edit > Color Settings and selecting More Options.

**Desaturate Monitor Colors By** Determines whether to desaturate colors by the specified amount when displayed on the monitor. When selected, this option can aid in visualizing the full range of color spaces with gamuts larger than that of the monitor. However, this causes a mismatch between the monitor display and the output. When the option is deselected, distinct colors in the image may display as a single color.

**Blend RGB Colors Using Gamma** Controls how RGB colors blend together to produce composite data (for example, when you blend or paint layers using Normal mode). When the option is selected, RGB colors are blended in the color space corresponding to the specified gamma. A gamma of 1.00 is considered “colorimetrically correct” and should result in the fewest edge artifacts. When the option is deselected, RGB colors are blended directly in the document's color space.

**Note:** When you select Blend RGB Colors Using Gamma, layered documents will look different when displayed in other applications than they do in Photoshop.
Chapter 29: Keyboard shortcuts

Customizing keyboard shortcuts

GoLive provides a shortcut editor in which you can view a list of all shortcuts, and edit or create shortcuts. The shortcut editor includes all commands that support shortcuts, some of which aren't addressed in the default shortcut set.

If the default shortcut set is insufficient, you can create additional custom sets. For example, you can create separate sets for different workspaces chosen from the Window > Workspace menu.

See also
“Keys for configuring the workspace” on page 676

To change the active shortcut set
1 Choose Edit > Keyboard Shortcuts.
2 Select a shortcut set from the Selected Set menu, and click OK.

To create a new shortcut set
1 Choose Edit > Keyboard Shortcuts.
2 Click New Set.
3 Type a name in the Set Name box, and select a shortcut set from the Copy From menu. Then click OK.

To create or redefine a shortcut
1 Choose Edit > Keyboard Shortcuts (Windows) or GoLive > Keyboard Shortcuts (Mac OS).
2 Select an existing shortcut set from the Selected Set menu, or click New Set.

Note: Avoid editing the default shortcut set. Instead, click New Set and select the default set from the Copy From menu.
3 In the list box, expand the menu category containing the desired command, and then select the command.
4 In the Press New Shortcut box, press the keys for your new keyboard shortcut. (If the shortcut is already used by another command, that command appears in the Currently Assigned To area. Either try a different key sequence, or change the shortcut for the other command.)
5 Do one of the following:
   • Click Assign to create a new shortcut.
   • Click Replace to replace an existing shortcut.
6 Repeat steps 3-5 for all shortcuts you want to change, and then click OK.
Default keyboard shortcuts

Keys for configuring the workspace
This isn’t a complete list of shortcuts. This table lists only shortcuts that GoLive doesn’t display in menu commands or tool tips.

<table>
<thead>
<tr>
<th>Result</th>
<th>Windows</th>
<th>Mac OS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open documents that were open when you last closed GoLive</td>
<td></td>
<td>Shift-close Welcome dialog box</td>
</tr>
<tr>
<td>Show next window in workspace</td>
<td>Ctrl+Tab</td>
<td></td>
</tr>
<tr>
<td>Show previous window in workspace</td>
<td>Shift+Ctrl+Tab</td>
<td></td>
</tr>
<tr>
<td>Change focus to Text Inspector Link field</td>
<td></td>
<td>With cursor in document window, Command+, (comma)</td>
</tr>
<tr>
<td>Change focus to document window</td>
<td></td>
<td>With cursor in Text Inspector, Command+, (comma)</td>
</tr>
<tr>
<td>Deselect all user profiles in the Options tab of the View palette</td>
<td>Alt-click an option in the User Profile menu</td>
<td>Option-click an option in the User Profile menu</td>
</tr>
<tr>
<td>Replace a previous selection in the Highlight tab of the View palette</td>
<td>Alt-click the Elements, CSS, or Special menu</td>
<td>Option-click the Elements, CSS, or Special menu</td>
</tr>
<tr>
<td>Deselect media files and images in the Options tab of the View palette</td>
<td>Alt-deselect Display images</td>
<td>Option-deselect Display images</td>
</tr>
</tbody>
</table>

See also
“Customizing keyboard shortcuts” on page 675

Keys for using the document window
This isn’t a complete list of shortcuts. This table lists only shortcuts that GoLive doesn’t display in menu commands or tool tips.
<table>
<thead>
<tr>
<th>Result</th>
<th>Windows</th>
<th>Mac OS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change the position of the Split Source View</td>
<td>Alt-click the Show/Hide Split Source button</td>
<td>Option-click the Show/Hide Split Source button</td>
</tr>
<tr>
<td>Display the Select Encoding dialog box</td>
<td>Alt-open a document</td>
<td>Option-open a document</td>
</tr>
<tr>
<td>Pan the page with the Hand tool</td>
<td>Ctrl+Alt-drag</td>
<td>Ctrl+Option-drag</td>
</tr>
<tr>
<td>Quickly show or hide rulers and suppress sound</td>
<td>Ctrl-choose View &gt; Show/Hide Rulers</td>
<td>Control-choose View &gt; Show/Hide Rulers</td>
</tr>
<tr>
<td>Display the source code for an object as a tool tip</td>
<td>Alt+Shift-move the pointer over an object</td>
<td>Option+Shift-move the pointer over an object</td>
</tr>
<tr>
<td>Retain styles in pasted text from Microsoft Word</td>
<td>Shift-choose Edit &gt; Paste</td>
<td>Shift-choose Edit &gt; Paste</td>
</tr>
<tr>
<td>Set the default state of the Show Link Warning button</td>
<td>Alt-click the Show Link Warning button</td>
<td>Option-click the Show Link Warning button</td>
</tr>
<tr>
<td>Select the &lt;body&gt; element in Split Source View</td>
<td>Shift-click the Page Properties icon</td>
<td>Shift-click the Page Properties icon</td>
</tr>
<tr>
<td>Set zoom to 400%</td>
<td>Shift-click the Zoom menu</td>
<td>Shift-click the Zoom menu</td>
</tr>
</tbody>
</table>

**See also**

“Customizing keyboard shortcuts” on page 675

**Keys for using the site window**

This isn’t a complete list of shortcuts. This table lists only shortcuts that GoLive doesn’t display in menu commands or tool tips.

<table>
<thead>
<tr>
<th>Result</th>
<th>Windows</th>
<th>Mac OS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Locate file in Windows Explorer or Mac OS Finder</td>
<td>Right-click file, and choose Open &gt; Reveal In Explorer</td>
<td>Ctrl-click file, and choose Open &gt; Reveal in Finder</td>
</tr>
<tr>
<td>Show properties for object</td>
<td>Right-click file, and choose Open/Show Properties</td>
<td>Control-click file, and choose Open/Show Properties</td>
</tr>
<tr>
<td>Delete a file without GoLive prompting for confirmation</td>
<td>Ctrl-click the Delete icon</td>
<td>Option-click the Delete icon</td>
</tr>
<tr>
<td>Result</td>
<td>Windows</td>
<td>Mac OS</td>
</tr>
<tr>
<td>-----------------------------------------------------------------------</td>
<td>------------------------------</td>
<td>-----------------------------</td>
</tr>
<tr>
<td>Force save a site</td>
<td>Shift+Ctrl</td>
<td>Shift+Ctrl</td>
</tr>
<tr>
<td>Access the pick whip in the Errors tab</td>
<td>Ctrl-click a file</td>
<td>Command-click a file</td>
</tr>
<tr>
<td>Open the Edit URL dialog box</td>
<td>Alt-click the folder icon in the URL Mappings section of site settings</td>
<td>Option-click the folder icon in the URL Mappings section of site settings</td>
</tr>
<tr>
<td>Update or generate thumbnails</td>
<td>Alt+Shift-choose Site &gt; Update &gt; Refresh All</td>
<td>Option+Shift-choose Site &gt; Update &gt; Refresh All</td>
</tr>
<tr>
<td>Open a site without checking links or verifying files</td>
<td>Shift-open the .site file</td>
<td>Shift-open the .site file</td>
</tr>
<tr>
<td>Move to the next screen</td>
<td>Ctrl-click a radio button in the Site Creation Wizard</td>
<td>Ctrl-click a radio button in the Site Creation Wizard</td>
</tr>
<tr>
<td>Make the site name unique if you enter a name or location that already exists</td>
<td>Ctrl-click the Next button in the Site Creation Wizard</td>
<td>Ctrl-click the Next button in the Site Creation Wizard</td>
</tr>
<tr>
<td>Reformat details in the log window</td>
<td>Shift-click an item</td>
<td>Shift-click an item</td>
</tr>
<tr>
<td>Scroll to the top of details in the log window</td>
<td>Alt-click an item</td>
<td>Option-click an item</td>
</tr>
</tbody>
</table>

**See also**

“Customizing keyboard shortcuts” on page 675

**Keys for using site Navigation or Links views**

This isn’t a complete list of shortcuts. This table lists only shortcuts that GoLive doesn’t display in menu commands or tool tips.

<table>
<thead>
<tr>
<th>Result</th>
<th>Windows</th>
<th>Mac OS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select next file in x-direction</td>
<td>Left Arrow, Right Arrow, Up Arrow, or Down Arrow</td>
<td>Left Arrow, Right Arrow, Up Arrow, or Down Arrow</td>
</tr>
<tr>
<td>Start a partial tree from selection</td>
<td>Ctrl+Up Arrow</td>
<td>Command+Up Arrow</td>
</tr>
<tr>
<td>Toggle expand button (hide/show children)</td>
<td>Ctrl+Down Arrow</td>
<td>Command+Down Arrow</td>
</tr>
<tr>
<td>Add parent to selection</td>
<td>Shift+Up Arrow</td>
<td>Shift+Up Arrow</td>
</tr>
<tr>
<td><strong>Result</strong></td>
<td><strong>Windows</strong></td>
<td><strong>Mac OS</strong></td>
</tr>
<tr>
<td>------------</td>
<td>-------------------</td>
<td>-------------------</td>
</tr>
<tr>
<td>Add children to selection</td>
<td>Shift+Down Arrow</td>
<td>Shift+Down Arrow</td>
</tr>
<tr>
<td>Select previous sibling or jump to nearest item to the left of selection</td>
<td>Ctrl+Left Arrow</td>
<td>Option+Left Arrow</td>
</tr>
<tr>
<td>Select next sibling or jump to nearest item to the right of selection</td>
<td>Ctrl+Right Arrow</td>
<td>Option+Right Arrow</td>
</tr>
<tr>
<td>Select the closest item above selection</td>
<td>Ctrl+Up Arrow</td>
<td>Option+Up Arrow</td>
</tr>
<tr>
<td>Select the closest item below selection</td>
<td>Ctrl+Down Arrow</td>
<td>Option+Down Arrow</td>
</tr>
<tr>
<td>Toggle partial tree from selection and move to center</td>
<td>Esc</td>
<td>Esc</td>
</tr>
<tr>
<td>Select top-level references</td>
<td>Ctrl+Home</td>
<td>Command+Home</td>
</tr>
<tr>
<td>Select first sibling</td>
<td>Home</td>
<td>Home</td>
</tr>
<tr>
<td>Select last sibling</td>
<td>End</td>
<td>End</td>
</tr>
<tr>
<td>Open the selected references</td>
<td>Enter or double-click</td>
<td>Return or double-click</td>
</tr>
<tr>
<td>Hand tool for scrolling</td>
<td>Spacebar</td>
<td>Spacebar</td>
</tr>
<tr>
<td>Select the reference with matching text</td>
<td>Type any characters</td>
<td>Type any characters</td>
</tr>
<tr>
<td>Toggle zoom between 100% and 200%</td>
<td>Shift-click</td>
<td>Option-click</td>
</tr>
<tr>
<td>Zoom in on selected area</td>
<td>Shift-drag</td>
<td>Option-drag</td>
</tr>
</tbody>
</table>

**See also**

“Customizing keyboard shortcuts” on page 675

**Keys for creating page templates**

This isn’t a complete list of shortcuts. This table lists only shortcuts that GoLive doesn’t display in menu commands or tool tips.
<table>
<thead>
<tr>
<th>Result</th>
<th>Windows</th>
<th>Mac OS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undefine all editable regions</td>
<td>Shift-choose Special &gt; Template &gt; Undefine Editable Region</td>
<td>Shift-choose Special &gt; Template &gt; Undefine Editable Region</td>
</tr>
<tr>
<td>Retain all editable regions when detaching a page from a template</td>
<td>Shift-choose Special &gt; Template &gt; Detach From Template</td>
<td>Shift-choose Special &gt; Template &gt; Detach From Template</td>
</tr>
</tbody>
</table>

See also

“Customizing keyboard shortcuts” on page 675

Keys for using tables in the Layout Editor

This isn’t a complete list of shortcuts. This table lists only shortcuts that GoLive doesn’t display in menu commands or tool tips.

<table>
<thead>
<tr>
<th>Result</th>
<th>Windows</th>
<th>Mac OS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change height and width of a row or column</td>
<td>Alt-resize</td>
<td>Option-resize</td>
</tr>
<tr>
<td>Select cells</td>
<td>Click cell border</td>
<td>Click cell border</td>
</tr>
<tr>
<td>Select multiple adjacent cells</td>
<td>Click-drag</td>
<td>Click-drag</td>
</tr>
<tr>
<td>Select multiple nonadjacent cells</td>
<td>Shift-click additional cells</td>
<td>Shift-click additional cells</td>
</tr>
<tr>
<td>Select all cells in column</td>
<td>Click top edge of column</td>
<td>Click top edge of column</td>
</tr>
<tr>
<td>Select all cells in row</td>
<td>Click left edge of row</td>
<td>Click left edge of row</td>
</tr>
<tr>
<td>Add row above</td>
<td>* (asterisk)</td>
<td>* (asterisk)</td>
</tr>
<tr>
<td>Add columns to the left</td>
<td>+ (plus symbol/sign)</td>
<td>+ (plus symbol/sign)</td>
</tr>
<tr>
<td>Add columns to the right</td>
<td>- (hyphen)</td>
<td>- (hyphen)</td>
</tr>
<tr>
<td>Interactively add cells and rows</td>
<td>Ctrl+Shift-drag bottom/right edge of table</td>
<td>Command-drag bottom/right edge of table</td>
</tr>
<tr>
<td>Delete current column</td>
<td>Ctrl+Delete</td>
<td>Control+Delete</td>
</tr>
<tr>
<td>Delete current row</td>
<td>Shift+Ctrl+Delete</td>
<td>Shift+Delete</td>
</tr>
<tr>
<td>Span columns, joining current cell with cell to the right</td>
<td>Shift+Right Arrow</td>
<td>Shift+Right Arrow</td>
</tr>
<tr>
<td>Result</td>
<td>Windows</td>
<td>Mac OS</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>------------------------------</td>
<td>------------------------------</td>
</tr>
<tr>
<td>Reduce column span, splitting the current cell</td>
<td>Shift+Left Arrow</td>
<td>Shift+Left Arrow</td>
</tr>
<tr>
<td>Span rows, joining current cell with cell below</td>
<td>Shift+Down Arrow</td>
<td>Shift+Down Arrow</td>
</tr>
<tr>
<td>Reduce row span, splitting the current cell</td>
<td>Shift+Up Arrow</td>
<td>Shift+Up Arrow</td>
</tr>
<tr>
<td>Move text cursor to next cell to the right</td>
<td>Tab</td>
<td>Tab</td>
</tr>
<tr>
<td>Move text cursor to next cell to the left</td>
<td>Shift+Tab</td>
<td>Shift+Tab</td>
</tr>
<tr>
<td>Switch from text entry to cell selection mode</td>
<td>Ctrl+Enter</td>
<td>Ctrl+Return</td>
</tr>
<tr>
<td>Switch from cell selection to text entry mode</td>
<td>Enter</td>
<td>Return</td>
</tr>
<tr>
<td>Create custom-sized table</td>
<td>Ctrl-drag table icon in objects toolbox</td>
<td>Command-drag table icon in objects toolbox</td>
</tr>
<tr>
<td>Select parent table in Table &amp; Boxes palette</td>
<td>Alt-click</td>
<td>Option-click</td>
</tr>
</tbody>
</table>

**See also**

“Customizing keyboard shortcuts” on page 675

**Keys for working with layout grids and layers**

This isn’t a complete list of shortcuts. This table lists only shortcuts that GoLive doesn’t display in menu commands or tool tips.

<table>
<thead>
<tr>
<th>Result</th>
<th>Windows</th>
<th>Mac OS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Optimize only the height of a layout grid</td>
<td>Alt-click the Optimize Size button in the Layout Grid Inspector</td>
<td>Option-click the Optimize button in the Layout Grid Inspector</td>
</tr>
<tr>
<td>Optimize only the width of a layout grid</td>
<td>Shift-click the Optimize Size button in the Layout Grid Inspector</td>
<td>Shift-click the Optimize button in the Layout Grid Inspector</td>
</tr>
<tr>
<td>Move boxes on layout grid in one-pixel increments</td>
<td>Ctrl+Alt+Arrow keys</td>
<td>Option+Arrow keys</td>
</tr>
<tr>
<td>Result</td>
<td>Windows</td>
<td>Mac OS</td>
</tr>
<tr>
<td>-----------------------------------------------------------------------</td>
<td>------------------</td>
<td>-----------------</td>
</tr>
<tr>
<td>Move boxes based on Snap-To-Grid setting</td>
<td>Arrow keys</td>
<td>Arrow keys</td>
</tr>
<tr>
<td>Move a layer only horizontally or vertically</td>
<td>Shift-drag the layer</td>
<td>Shift-drag the layer</td>
</tr>
<tr>
<td>Resize a layer</td>
<td>Shift+Arrow keys</td>
<td>Shift+ Arrow keys</td>
</tr>
<tr>
<td>Apply Hide or Lock commands to all layers</td>
<td>Ctrl-click a hide or lock icon in the Layers palette</td>
<td>Command-click a Hide or Lock icon in the Layers palette</td>
</tr>
<tr>
<td>Duplicate selected object</td>
<td>Ctrl-drag</td>
<td>Option-drag</td>
</tr>
</tbody>
</table>

**See also**

“Customizing keyboard shortcuts” on page 675

**Keys for using the DHTML timeline**

This isn’t a complete list of shortcuts. This table lists only shortcuts that GoLive doesn’t display in menu commands or tool tips.

<table>
<thead>
<tr>
<th>Result</th>
<th>Windows</th>
<th>Mac OS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select next key-frame</td>
<td>Right Arrow</td>
<td>Right Arrow</td>
</tr>
<tr>
<td>Select previous keyframe</td>
<td>Left Arrow</td>
<td>Left Arrow</td>
</tr>
<tr>
<td>Select next track</td>
<td>Down Arrow</td>
<td>Down Arrow</td>
</tr>
<tr>
<td>Select previous track</td>
<td>Up Arrow</td>
<td>Up Arrow</td>
</tr>
<tr>
<td>Play a scene beginning at the current time cursor location</td>
<td>Enter (numerical keypad)</td>
<td>Enter (numerical keypad)</td>
</tr>
<tr>
<td>Stop scene playback</td>
<td>0 (numerical keypad)</td>
<td>0 (numerical keypad)</td>
</tr>
<tr>
<td>Create a new key-frame</td>
<td>Ctrl-click a time track</td>
<td>Command-click a time track</td>
</tr>
</tbody>
</table>
### Duplicate a keyframe

<table>
<thead>
<tr>
<th>Result</th>
<th>Windows</th>
<th>Mac OS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Duplicate a keyframe</td>
<td>Alt-drag keyframe</td>
<td>Option-drag keyframe</td>
</tr>
</tbody>
</table>

### Create an action placeholder

<table>
<thead>
<tr>
<th>Result</th>
<th>Windows</th>
<th>Mac OS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create an action placeholder</td>
<td>Ctrl-click action on action track</td>
<td>Command-click action on action track</td>
</tr>
</tbody>
</table>

### Scale an animation while maintaining the relative time positions of all keyframes on the same time track

<table>
<thead>
<tr>
<th>Result</th>
<th>Windows</th>
<th>Mac OS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scale an animation while maintaining the relative time positions of all keyframes on the same time track</td>
<td>Ctrl+Shift-drag</td>
<td>Ctrl-drag</td>
</tr>
</tbody>
</table>

### See also

“Customizing keyboard shortcuts” on page 675

### Keys for working with type

This isn’t a complete list of shortcuts. This table lists only shortcuts that GoLive doesn’t display in menu commands or tool tips.

<table>
<thead>
<tr>
<th>Result</th>
<th>Windows</th>
<th>Mac OS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cursor to beginning of current word</td>
<td>Ctrl+Left Arrow</td>
<td>Ctrl+Left Arrow</td>
</tr>
<tr>
<td>Cursor to next word</td>
<td>Ctrl+Right Arrow</td>
<td>Ctrl+Right Arrow</td>
</tr>
<tr>
<td>Cursor to beginning/end of line</td>
<td>Home</td>
<td>Command+Left Arrow</td>
</tr>
<tr>
<td>Cursor to end of line</td>
<td>End</td>
<td>Command+Right Arrow</td>
</tr>
<tr>
<td>Select a word</td>
<td>Double-click</td>
<td>Double-click</td>
</tr>
<tr>
<td>Select a line</td>
<td>Triple-click</td>
<td>Triple-click</td>
</tr>
<tr>
<td>Select a paragraph</td>
<td>Quadruple-click</td>
<td>Quadruple-click</td>
</tr>
<tr>
<td>Increase selection</td>
<td>Shift+Arrow keys</td>
<td>Shift+Arrow keys</td>
</tr>
<tr>
<td>Select to beginning of line</td>
<td>Shift+Home</td>
<td>Command+Shift+Left Arrow</td>
</tr>
<tr>
<td>Select to end of line</td>
<td>Shift+End</td>
<td>Command+Shift+Right Arrow</td>
</tr>
<tr>
<td>New line instead of paragraph</td>
<td>Shift+Enter</td>
<td>Shift+Return</td>
</tr>
<tr>
<td>Nonbreaking space</td>
<td>Shift+Spacebar</td>
<td>Option+Spacebar</td>
</tr>
<tr>
<td>Result</td>
<td>Windows</td>
<td>Mac OS</td>
</tr>
<tr>
<td>-----------------------------------------------------------------------</td>
<td>--------------------------</td>
<td>-----------------------------</td>
</tr>
<tr>
<td>Insert word break tag <code>&lt;WBR&gt;</code>, enabling the browser to hyphenate the work at the point of insertion</td>
<td>Ctrl+dash</td>
<td></td>
</tr>
<tr>
<td>Show font names rather than font families in menus</td>
<td>Alt-access menu</td>
<td>Option-access menu</td>
</tr>
<tr>
<td>Show font families and font names in menus</td>
<td>Alt+Shift</td>
<td>Option+Shift</td>
</tr>
<tr>
<td>Replace existing fonts with new ones in the Font Set Inspector</td>
<td>Alt-click Create New Font button</td>
<td>Option-click Create New Font button</td>
</tr>
<tr>
<td>Add a new font to the top of the list in the Font Set Inspector</td>
<td>Shift</td>
<td>Shift</td>
</tr>
<tr>
<td>Edit a style in the HTML Style palette</td>
<td>Ctrl-click the style</td>
<td>Command-click the style</td>
</tr>
</tbody>
</table>

**See also**

“Customizing keyboard shortcuts” on page 675

**Keys for working with links**

This isn’t a complete list of shortcuts. This table lists only shortcuts that GoLive doesn’t display in menu commands or tool tips.

<table>
<thead>
<tr>
<th>Result</th>
<th>Windows</th>
<th>Mac OS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create new link</td>
<td>Alt-drag selected item to desired destination until the object highlights</td>
<td>Command-drag selected item to desired destination until the object highlights</td>
</tr>
<tr>
<td>Open the Edit URL dialog box</td>
<td>Alt-click the Browse button in the Inspector</td>
<td>Option-click the Browse button in the Inspector</td>
</tr>
<tr>
<td>Prepend http:// to URL</td>
<td>Click in the URL box in the Inspector and press Option+Return</td>
<td></td>
</tr>
<tr>
<td>Link frame with desired content file</td>
<td>Ctrl-drag to desired page in site window</td>
<td>Command-drag to desired page in site window</td>
</tr>
</tbody>
</table>
### See also
“Customizing keyboard shortcuts” on page 675

### Keys for using cascading stylesheets

This isn’t a complete list of shortcuts. This table lists only shortcuts that GoLive doesn’t display in menu commands or tool tips.

<table>
<thead>
<tr>
<th>Result</th>
<th>Windows</th>
<th>Mac OS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Replace existing fonts with new ones</td>
<td>Alt-click the Create New Font Family button in the CSS Editor</td>
<td>Option-click the Create New Font Family button in the CSS Editor</td>
</tr>
<tr>
<td>Add new fonts to the beginning of the list</td>
<td>Shift-click the Create New Font button in the CSS Editor</td>
<td>Shift-click the Create New Font button in the CSS Editor</td>
</tr>
<tr>
<td>Toggle !important state of property value</td>
<td>Shift-click value</td>
<td>Shift-click value</td>
</tr>
<tr>
<td>Open or close all folders in the Style Info tab of the CSS palette</td>
<td>Alt-click a folder in the Style Info tab of the CSS palette</td>
<td>Option-click a folder in the Style Info tab of the CSS palette</td>
</tr>
<tr>
<td>Toggle Apply Information, Cascaded Preview, and Cascaded Properties on or off in the CSS palette window menu</td>
<td>Alt-click the menu item</td>
<td>Option-click the menu item</td>
</tr>
</tbody>
</table>

### See also
“Customizing keyboard shortcuts” on page 675

### Keys for working with images and Smart Objects

This isn’t a complete list of shortcuts. This table lists only shortcuts that GoLive doesn’t display in menu commands or tool tips.

<table>
<thead>
<tr>
<th>Result</th>
<th>Windows</th>
<th>Mac OS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Suppress Save For Web dialog box when you select a new source file for a Smart Object</td>
<td>Alt-select</td>
<td>Option-select</td>
</tr>
<tr>
<td>Cancel a crop for a Smart Object</td>
<td>Command+. (period)</td>
<td></td>
</tr>
<tr>
<td>Move a cropping or tracing rectangle by 10 pixels</td>
<td>Ctrl+Arrow keys</td>
<td>Ctrl+Arrow keys</td>
</tr>
</tbody>
</table>
### Result

<table>
<thead>
<tr>
<th>Windows</th>
<th>Mac OS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Assign a low source image to an image object in the Layout Editor</td>
<td>Alt+Shift-drag from the object to the low source image</td>
</tr>
<tr>
<td>Retain proportions when resizing</td>
<td>Shift-drag</td>
</tr>
<tr>
<td>Move an image-map hotspot one level higher or lower</td>
<td>Alt-click Send To Front or Send To Back button in tool-bar</td>
</tr>
<tr>
<td>Move a hotspot by 10 pixels</td>
<td>Option+Arrow keys</td>
</tr>
<tr>
<td>Link a hotspot to a file</td>
<td>Alt-drag from the hotspot</td>
</tr>
<tr>
<td>Resize a hotspot by one pixel</td>
<td>Shift+Arrow keys</td>
</tr>
<tr>
<td>Resize a hotspot by 10 pixels</td>
<td>Shift+Ctrl+Alt+Arrow keys</td>
</tr>
<tr>
<td>Add SVG object instead of Smart Object</td>
<td>Ctrl-drag SVG file to Layout Editor</td>
</tr>
<tr>
<td>Convert lowest Photoshop layer into page background</td>
<td></td>
</tr>
<tr>
<td>Save or cancel optimization for all imported Photoshop layers</td>
<td>Ctrl-click Save All or Cancel All in the Save For Web dialog box</td>
</tr>
</tbody>
</table>

### See also

“Customizing keyboard shortcuts” on page 675

### Keys for working with PDF files

**Note:** This isn't a complete list of shortcuts. This table lists only shortcuts that GoLive doesn't display in menu commands or tool tips.

<table>
<thead>
<tr>
<th>Windows</th>
<th>Mac OS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move PDF link region by 10 pixels</td>
<td>Ctrl+Arrow keys</td>
</tr>
<tr>
<td>Avoid parsing secure PDF files when opening a site</td>
<td>Shift+Ctrl</td>
</tr>
</tbody>
</table>
See also
“Customizing keyboard shortcuts” on page 675

Keys for editing QuickTime movies
This isn’t a complete list of shortcuts. This table lists only shortcuts that GoLive doesn’t display in menu commands or tool tips.

<table>
<thead>
<tr>
<th>Result</th>
<th>Windows</th>
<th>Mac OS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select keyframe of the upper or lower tracks and samples displayed in the Timeline window</td>
<td>Up Arrow or Down Arrow</td>
<td>Up Arrow or Down Arrow</td>
</tr>
<tr>
<td>In the Track Content area, select previous or next sample</td>
<td>Left Arrow or Right Arrow</td>
<td>Left Arrow or Right Arrow</td>
</tr>
<tr>
<td>In the Track Content area, select upper or lower sample or track</td>
<td>Up Arrow or Down Arrow</td>
<td>Up Arrow or Down Arrow</td>
</tr>
<tr>
<td>In the Track List area, select upper or lower track</td>
<td>Up Arrow or Down Arrow</td>
<td>Up Arrow or Down Arrow</td>
</tr>
<tr>
<td>In the Track Ruler area, step forward or backward</td>
<td>Right Arrow or Left Arrow</td>
<td>Right Arrow or Left Arrow</td>
</tr>
<tr>
<td>Drag and copy track</td>
<td>Ctrl-drag in the Content or List area</td>
<td>Option-drag in the List area</td>
</tr>
<tr>
<td>Create keyframe sample of a sprite</td>
<td>Ctrl-click</td>
<td>Command-click</td>
</tr>
<tr>
<td>Drag and copy keyframe sample of a sprite</td>
<td>Option-drag in Content area</td>
<td></td>
</tr>
<tr>
<td>Select next or previous time marker</td>
<td>Shift+Right Arrow or Left Arrow</td>
<td>Shift+Right Arrow or Left Arrow</td>
</tr>
<tr>
<td>Open or close tracks, subtracks</td>
<td>Ctrl+Up Arrow or Down Arrow</td>
<td>Command+Up Arrow or Down Arrow</td>
</tr>
<tr>
<td>Scale sample time</td>
<td>Shift-drag</td>
<td>Shift-drag</td>
</tr>
<tr>
<td>Jump to start or end of movie in timeline</td>
<td>Ctrl+Left Arrow or Right Arrow</td>
<td>Command+Left Arrow or Right Arrow</td>
</tr>
</tbody>
</table>

See also
“Customizing keyboard shortcuts” on page 675
**Keys for editing source code**

This isn't a complete list of shortcuts. This table lists only shortcuts that GoLive doesn't display in menu commands or tool tips.

<table>
<thead>
<tr>
<th>Result</th>
<th>Windows</th>
<th>Mac OS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cursor to next word</td>
<td>Ctrl+Right Arrow</td>
<td>Option+Right Arrow</td>
</tr>
<tr>
<td>Cursor to preceding word</td>
<td>Ctrl+Left Arrow</td>
<td>Option+Left Arrow</td>
</tr>
<tr>
<td>Cursor to beginning of line</td>
<td>Home</td>
<td>Command+Left Arrow</td>
</tr>
<tr>
<td>Cursor to end of line</td>
<td>End</td>
<td>Command+Right Arrow</td>
</tr>
<tr>
<td>Select a word</td>
<td>Double-click</td>
<td>Double-click</td>
</tr>
<tr>
<td>Select a line</td>
<td>Triple-click</td>
<td>Triple-click</td>
</tr>
<tr>
<td>Decrease selection one character</td>
<td>Shift+Left Arrow</td>
<td>Shift+Left Arrow</td>
</tr>
<tr>
<td>Increase selection one character</td>
<td>Shift+Right Arrow</td>
<td>Shift+Right Arrow</td>
</tr>
<tr>
<td>Decrease selection one word</td>
<td>Ctrl+Shift+Left Arrow</td>
<td>Option+Shift+Left Arrow</td>
</tr>
<tr>
<td>Increase selection one word</td>
<td>Ctrl+Shift+Right Arrow</td>
<td>Option+Shift+Right Arrow</td>
</tr>
<tr>
<td>Decrease selection one line</td>
<td>Shift+Up Arrow</td>
<td>Shift+Up Arrow</td>
</tr>
<tr>
<td>Increase selection one line</td>
<td>Shift+Down Arrow</td>
<td>Shift+Down Arrow</td>
</tr>
<tr>
<td>Decrease selection to beginning of source code</td>
<td>Home+Shift+Up Arrow</td>
<td>Command+Shift+Up Arrow</td>
</tr>
<tr>
<td>Decrease selection to end of source code</td>
<td>Home+Shift+Down Arrow</td>
<td>Command+Shift+Down Arrow</td>
</tr>
<tr>
<td>Increase selection to beginning of source code</td>
<td>End+Shift+Up Arrow</td>
<td>Command+Shift+Up Arrow</td>
</tr>
<tr>
<td>Increase selection to end of source code</td>
<td>End+Shift+Down Arrow</td>
<td>Command+Shift+Down Arrow</td>
</tr>
<tr>
<td>Redo an active syntax check with the same parameters</td>
<td>Alt-click Syntax in the Highlight tab of the View palette</td>
<td>Option-click Syntax in the Highlight tab of the View palette</td>
</tr>
<tr>
<td>Result</td>
<td>Windows</td>
<td>Mac OS</td>
</tr>
<tr>
<td>-----------------------------------------------------------------------</td>
<td>-----------------------------</td>
<td>----------------------------</td>
</tr>
<tr>
<td>Perform a syntax check without opening the Syntax Check window</td>
<td>Shift-click the Syntax Check icon in the Highlight tab of the View palette</td>
<td>Shift-click the Syntax Check icon in the Highlight tab of the View palette</td>
</tr>
<tr>
<td>Deselect all additionally allowed element sets in the Syntax Check window</td>
<td>Option-deselect an additionally allowed element set</td>
<td></td>
</tr>
<tr>
<td>Sort functions alphabetically</td>
<td>Alt-click the Navigate Through Code icon in the Source Code Editor</td>
<td>Option-click the Navigate Through Code icon in the Source Code Editor</td>
</tr>
<tr>
<td>Display child elements in markup tree bar</td>
<td>Alt-click an element in the markup tree bar</td>
<td>Option-click an element in the markup tree bar</td>
</tr>
<tr>
<td>Write URL into doctype</td>
<td>Alt-click OK in the Change Encoding dialog box</td>
<td>Option-click OK in the Change Encoding dialog box</td>
</tr>
<tr>
<td>Display the Select Encoding dialog box when you open a file</td>
<td>Alt-click Open in the Open Document dialog box</td>
<td>Option-click Open in the Open Document dialog box</td>
</tr>
<tr>
<td>Close Result dialog box when you add files with found code elements to the Find Text dialog box</td>
<td>Alt-click Use Result</td>
<td>Option-click Use Result</td>
</tr>
</tbody>
</table>

**See also**

“Customizing keyboard shortcuts” on page 675

**Keys for using the Outline Editor**

This isn’t a complete list of shortcuts. This table lists only shortcuts that GoLive doesn’t display in menu commands or tool tips.

<table>
<thead>
<tr>
<th>Result</th>
<th>Windows</th>
<th>Mac OS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Expand or collapse the selected tag</td>
<td>Enter (numerical keypad)</td>
<td>Return</td>
</tr>
<tr>
<td>Recursively expand or collapse the selected tag</td>
<td>Shift+Enter (numerical keypad)</td>
<td>Option+Return</td>
</tr>
<tr>
<td>Show or hide the tag attribute list</td>
<td>Enter (numerical keypad)</td>
<td>Enter</td>
</tr>
<tr>
<td>Recursively show or hide the tag attribute list</td>
<td>Shift+Enter (numerical keypad)</td>
<td>Option+Enter</td>
</tr>
<tr>
<td>Result</td>
<td>Windows</td>
<td>Mac OS</td>
</tr>
<tr>
<td>--------------------------------------------</td>
<td>------------</td>
<td>------------</td>
</tr>
<tr>
<td>Activate the next text box</td>
<td>Tab</td>
<td>Tab</td>
</tr>
<tr>
<td>Activate the preceding text box</td>
<td>Shift+Tab</td>
<td>Shift+Tab</td>
</tr>
<tr>
<td>Activate the tag selection pop-up menu</td>
<td>Ctrl-click tag name</td>
<td>Command-click tag name</td>
</tr>
<tr>
<td>Display a pop-up menu listing all elements allowed bydoctype</td>
<td>Ctrl-click an element</td>
<td>Command-click an element</td>
</tr>
<tr>
<td>Open the Colors window</td>
<td>Option-click the color icon</td>
<td></td>
</tr>
</tbody>
</table>

**See also**
“Customizing keyboard shortcuts” on page 675

**Keys for working with web settings**
This isn't a complete list of shortcuts. This table lists only shortcuts that GoLive doesn't display in menu commands or tool tips.

<table>
<thead>
<tr>
<th>Result</th>
<th>Windows</th>
<th>Mac OS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Suppress confirmation dialog box when deleting items</td>
<td></td>
<td>Option</td>
</tr>
<tr>
<td>Close Web Settings window without saving changes</td>
<td>Alt</td>
<td>Option</td>
</tr>
<tr>
<td>Change names in the Attribute Inspector without converting to lowercase</td>
<td>Alt</td>
<td>Option</td>
</tr>
<tr>
<td>Copy items on the Markup Languages and Characters tabs</td>
<td>Alt-drag</td>
<td>Option-drag</td>
</tr>
</tbody>
</table>

**See also**
“Customizing keyboard shortcuts” on page 675

**Keys for working with Adobe Bridge**
This is not a complete list of keyboard shortcuts. This table lists only those shortcuts that are not displayed in menu commands or tool tips.
<table>
<thead>
<tr>
<th>Result</th>
<th>Windows</th>
<th>Mac OS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open Adobe Bridge from other Creative Suite application</td>
<td>Control + Alt + O, Control + Shift + O</td>
<td>Command + Option + O, Command + Shift + O</td>
</tr>
<tr>
<td>Switch to the next open Bridge window</td>
<td>Control + ~</td>
<td>Command + ~</td>
</tr>
<tr>
<td>Switch to previous Bridge window</td>
<td>Shift + Control + ~</td>
<td>Shift + Command + ~</td>
</tr>
<tr>
<td>Switches to the next view (As Thumbnails, As Filmstrip, As Details, or As Versions And Alternates)</td>
<td>Control + \</td>
<td>Command + \</td>
</tr>
<tr>
<td>Switch to user-defined workspaces</td>
<td>Control + F6 through Control + F12</td>
<td>Command + F6 through Command + F12</td>
</tr>
<tr>
<td>Switch to previous view</td>
<td>Shift + Control + \</td>
<td>Shift + Command + \</td>
</tr>
<tr>
<td>Show all files</td>
<td>Alt + Control + F</td>
<td>Option + Command + F</td>
</tr>
<tr>
<td>Show files with 1 or more stars</td>
<td>Alt + Control + 1</td>
<td>Option + Command + 1</td>
</tr>
<tr>
<td>Show files with 2 or more stars</td>
<td>Alt + Control + 2</td>
<td>Option + Command + 2</td>
</tr>
<tr>
<td>Show files with 3 or more stars</td>
<td>Alt + Control + 3</td>
<td>Option + Command + 3</td>
</tr>
<tr>
<td>Show files with 4 or more stars</td>
<td>Alt + Control + 4</td>
<td>Option + Command + 4</td>
</tr>
<tr>
<td>Show files with 5 stars</td>
<td>Alt + Control + 5</td>
<td>Option + Command + 5</td>
</tr>
<tr>
<td>Show files with label 1</td>
<td>Alt + Control + 6</td>
<td>Option + Command + 6</td>
</tr>
<tr>
<td>Show files with label 2</td>
<td>Alt + Control + 7</td>
<td>Option + Command + 7</td>
</tr>
<tr>
<td>Show files with label 3</td>
<td>Alt + Control + 8</td>
<td>Option + Command + 8</td>
</tr>
<tr>
<td>Show files with label 4</td>
<td>Alt + Control + 9</td>
<td>Option + Command + 9</td>
</tr>
<tr>
<td>Open selected image in the Camera Raw dialog box in Bridge</td>
<td>Control + R</td>
<td>Command + R</td>
</tr>
<tr>
<td>Open selected image with saved camera raw settings in Photoshop</td>
<td>Shift + Control + O</td>
<td>Shift + Command + O</td>
</tr>
<tr>
<td>Copy camera raw settings from selected file</td>
<td>Alt + Control + C</td>
<td>Option + Command + C</td>
</tr>
<tr>
<td>Paste camera raw settings into selected file</td>
<td>Alt + Control + V</td>
<td>Option + Command + V</td>
</tr>
<tr>
<td>Mark selected Version Cue file as in use</td>
<td>Shift + Control + M</td>
<td>Shift + Command + M</td>
</tr>
<tr>
<td>Synchronize local view and server view of selected Version Cue file</td>
<td>Shift + Control + B</td>
<td>Shift + Command + B</td>
</tr>
<tr>
<td>Make selected Version Cue files alternates of each other</td>
<td>Shift + Control + G</td>
<td>Shift + Command + G</td>
</tr>
<tr>
<td>Create saved version of selected Version Cue file</td>
<td>Shift + Control + V</td>
<td>Shift + Command + V</td>
</tr>
<tr>
<td>Open Version Cue Versions dialog box</td>
<td>Shift + Alt + Control + V</td>
<td>Shift + Option + Command + V</td>
</tr>
<tr>
<td>Return to last application that launched Bridge</td>
<td>Alt + Control + O</td>
<td>Option + Command + O</td>
</tr>
<tr>
<td>Delete selected file</td>
<td>Control + Backspace</td>
<td>Command + Backspace</td>
</tr>
<tr>
<td>Move up a folder (in folder view) or a row</td>
<td>Up Arrow</td>
<td>Up Arrow</td>
</tr>
<tr>
<td>Result</td>
<td>Windows</td>
<td>Mac OS</td>
</tr>
<tr>
<td>--------</td>
<td>---------</td>
<td>--------</td>
</tr>
<tr>
<td>Move down a folder (in folder view) or a row</td>
<td>Down Arrow</td>
<td>Down Arrow</td>
</tr>
<tr>
<td>Move up a level (in folder view)</td>
<td>Control + Up Arrow</td>
<td>Command + Up Arrow</td>
</tr>
<tr>
<td>Move left one item</td>
<td>Left Arrow</td>
<td>Left Arrow</td>
</tr>
<tr>
<td>Move right one item</td>
<td>Right Arrow</td>
<td>Right Arrow</td>
</tr>
<tr>
<td>Move to the first item</td>
<td>Home</td>
<td>Home</td>
</tr>
<tr>
<td>Move to the last item</td>
<td>End</td>
<td>End</td>
</tr>
<tr>
<td>Add to selection (discontiguous)</td>
<td>Control-click</td>
<td>Command-click</td>
</tr>
<tr>
<td>Refresh tree and thumbnail panes</td>
<td>F5</td>
<td>F5</td>
</tr>
<tr>
<td>Add an item to the selection</td>
<td>Shift + Right Arrow, Left Arrow, Up Arrow, or Down Arrow</td>
<td>Shift + Right Arrow, Left Arrow, Up Arrow, or Down Arrow</td>
</tr>
<tr>
<td>Rotate image clockwise</td>
<td>Control + ]</td>
<td>Command + ]</td>
</tr>
<tr>
<td>Rotate image counterclockwise</td>
<td>Control + [</td>
<td>Command + [</td>
</tr>
<tr>
<td>Launch File Bridge in maximized state and auto-hide palettes</td>
<td>Control-click the Open Bridge icon in the options bar</td>
<td>Command-click the Open Bridge icon in the options bar</td>
</tr>
<tr>
<td>Open File Info dialog box</td>
<td>Control + Alt + I</td>
<td>Command + Option + I</td>
</tr>
<tr>
<td>Display Help</td>
<td>F1</td>
<td>F1</td>
</tr>
</tbody>
</table>

### Keys for selecting in Version Cue

<table>
<thead>
<tr>
<th>Result</th>
<th>Windows</th>
<th>Mac OS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select all</td>
<td>A + Control-click</td>
<td>A + Command-click</td>
</tr>
<tr>
<td>Select entries (selective)</td>
<td>Control-click</td>
<td>Command-click</td>
</tr>
<tr>
<td>Select entries (range)</td>
<td>Shift-click</td>
<td>Shift-click</td>
</tr>
<tr>
<td>Select next entry</td>
<td>Down Arrow</td>
<td>Down Arrow</td>
</tr>
<tr>
<td>Select previous entry</td>
<td>Up Arrow</td>
<td>Up Arrow</td>
</tr>
<tr>
<td>Select next entry (additive)</td>
<td>Shift + Down arrow</td>
<td>Shift + Down arrow</td>
</tr>
<tr>
<td>Select previous entry (additive)</td>
<td>Shift + Up Arrow</td>
<td>Shift + Up Arrow</td>
</tr>
<tr>
<td>Select first entry</td>
<td>Page Up or Home</td>
<td>Page Up or Home</td>
</tr>
<tr>
<td>Select last entry</td>
<td>Page down or home</td>
<td>Page Down or Home</td>
</tr>
</tbody>
</table>

### Keys for navigation in Version Cue

<table>
<thead>
<tr>
<th>Result</th>
<th>Windows</th>
<th>Mac OS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open folder</td>
<td>Control + O</td>
<td>Command + O</td>
</tr>
<tr>
<td>New folder</td>
<td>Control + N</td>
<td>Command + N</td>
</tr>
<tr>
<td>Up one level</td>
<td>Backspace</td>
<td>Command + Up Arrow</td>
</tr>
</tbody>
</table>
## Keys for viewing in Version Cue

<table>
<thead>
<tr>
<th>Result</th>
<th>Windows</th>
<th>Mac OS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Details</td>
<td>Control + 1</td>
<td>Command + 1</td>
</tr>
<tr>
<td>Icons</td>
<td>Control + 2</td>
<td>Command + 2</td>
</tr>
<tr>
<td>Thumbnails</td>
<td>Control + 3</td>
<td>Command + 3</td>
</tr>
<tr>
<td>Tiles</td>
<td>Control + 4</td>
<td>Command + 4</td>
</tr>
</tbody>
</table>
Index

A

absolute length units for stylesheets 331
absolute link paths
about 213
setting up in preferences 214
using in links 213
Action Group action 633
Action Inspector 608, 610
actions
about 608
attaching to rollovers 346
audio playback 625
browser compatibility 608
browser-triggered 609
browser-window related 614, 621, 622, 627
clock related 627
form related 611, 620, 621
frame related 614
getters 611
grouping 633
highlighting 608
image related 613
layer timelines, in 260, 262
link 614
message 620
monitoring events 633
Others 627
scene playback control 624
scrolling 628
shifting code to an external library 605
showing and hiding objects 622
specials 633
swapping images 614
Text Swap 619
timeline-triggered 610
user-triggered 609
variables 635
Actions palette
showing and hiding layers 259
ActiveX controls
about 356
editing properties for 357
setting up 357
Add Colors Used command 431
Add New Comment button 587
Add New Text button 587
Add To Favorites command 47, 155
Add Used External Links command 434
Address tags 295
Adobe Acrobat
working with Version Cue 72
Adobe Bridge
See also Bridge window
about 37
adding files to Version Cue projects 90
creating Version Cue projects in 82
Creative Suite color settings 654, 656
deleting Version Cue files in 99, 100
deleting Version Cue projects in 98
revealing Version Cue files in 88
Adobe Co-Author 458
Adobe Creative Suite color settings 654
Adobe dialog box, in Version Cue 73
Adobe GoLive
editing Version Cue files 118
extensions 11
logging into Version Cue 114
new features 10
SDK 11
tutorials 12
using with Version Cue 113
viewing Version Cue information in the site window 115
working files 113
working with Version Cue 72
Adobe Illustrator files
See also Smart Illustrator objects
layered 380
page layout with 244
sliced 381
Adobe InDesign
metadata in 53
Adobe InDesign. See Package For GoLive
Adobe Photoshop files
adding to a web page 244
layered 377
page layout with 244
sliced 377
variables in 379
Adobe Press 9
Adobe RGB color space 671
Adobe Stock Photos
See also Stock Photo accounts
about 61
buying 65, 66
comps 64
in Bridge 37
preferences 70
redownloading photos 69
search tips 63
searching with keywords 63
shopping cart 65
viewing order details 67
Adobe Studio 7
Adobe Studio Exchange 9
Adobe Version Cue
changing site settings in GoLive 116
comparing working copies to master files 120
connecting to projects 150
connecting to remote projects 78
disconnecting in 95
features, availability of 71
folders 77
in Bridge 37
migrating to version 2.0 127
placing existing site into 151
projects folder 76
publishing projects with
GoLive 128
toolbar in GoLive 118
viewing file versions 120
Adobe Version Cue Administration
utility
about 124
deleting projects in 131
duplicating projects in 131
editing project properties 131
exporting projects 132
setting workspace preferences 126
Adobe Version Cue projects
adding files to 89
backup and restoration 133
connecting to remote projects 78
copying 132
copying and moving files
between 91
creating and editing 80
creating in GoLive 113
disconnecting from 96
displaying information about 80
opening 77
opening files in 87
properties 130
restricting access to 135
sharing 84
synchronizing 110
using lock protection in 130
working copies 76
Adobe Version Cue Workspaces
changing the display of 79
creating user IDs in 136
deleting shortcuts 95
displaying information about 139
login, in GoLive 115
logs 126, 139
renaming 126
restarting 74
setting preferences for 74
AI files. See Adobe Illustrator files
Align palette 251
aligning
images within text 296
objects 251
alternate pages for browsers 166
alternates
creating groups, in GoLive 121
groups, in Version Cue 109
in Version Cue 106
making primary 108
making, in Bridge 109
moving to another alternates
group 110
removing 108
saving, in Version Cue 107
viewing, in Bridge 107
viewing, in Version Cue 108
alternative text
for images 341
for slices 368
Anchor Inspector 172
anchors
diagrams 190
exporting in PDF files 405
for link destinations 171
for PDF bookmarks 172
placement 171
animations
animating layers 260
animating SMIL
presentations 491, 504, 523
previewing 261
stopping 626
Annotation Inspector 195
annotations in diagrams
adding and editing 195
using in presentations 197
Annotations tab of diagram
window 195
Appearance Of Black preferences 657
Apply Template command 425
As Details command 43
As Filmstrip command 43
As Versions And Alternates
command 43
Assign Profile command 669
attributes
adding in Outline Editor 586
checking validity of 586
editing in Markup palette 580
selecting values for 586
automated tasks
resources for 8
automated tasks, running 52
B
background
color, matching in Smart
Objects 361
formatting for tables 284
properties for stylesheets 336
Set BackColor action 629
backgrounders 8
back-references in wildcard
searches 315
basic properties for stylesheets 327
Batch Rename command 53
binary tag display, toggling in Outline
Editor 588
black point compensation 673
black, appearance of 657
blinking text 299
block properties for stylesheets 333,
334
blockquote tag 296
Body Action icon 609
bold text 299
borders
for images 342
properties for stylesheets 335
Box Inspector 194
Bridge Center 37
Bridge window
adjusting 40
main components 37
Bridge. See Adobe Bridge
Browse command 39
browser plug-ins
advanced options 350
basic options 350
Browser Profiles tab in Web
Settings 648
Browser Switch Inspector 166
browsers. See web browsers
browser-switch scripts 166, 293
browser-triggered actions 609
bug icon 234
Build Cache For Subfolders command 43
bulleted lists
about 297
buttons
adding to forms 412, 413
images for 417

C
che
about 43
setting centralized and
distributed 42
Call Action action 633
Call Function action 633
camera data, adding to files 56
camera raw files
in Bridge 37
Cancel Mark In Use command 118
canvas
settings for diagrams 192
captions, creating in diagrams 193, 195
Card Inspector 474
Cascade command 26, 27
cascading stylesheets
See also styles
about 292, 318
applying property collections 337
applying styles 328, 338
background properties 336
block properties 333
border properties 335
cascading order 323
class styles, creating 327
classes 325
creating 322
default stylesheets 648
default units 650
editing the source code 329
external stylesheets 320, 322
font properties 332
HTML element styles 325, 326
ID styles 328, 338
inline styles 328
internal stylesheets 320
length units 331
list properties 336
Netscape CSS Fix action 628
samples in New Document dialog box 318
source code formatting 650
storing property collections 337
style attribute editing 328
styles, creating 325
styles, deleting 329
styles, replacing with HTML 307
support for in web browsers 318
supported style properties 330
tables and 287
text properties 332
unsupported properties 337
viewing 323
certification 9
CGI scripts in forms 411, 412, 418, 472
Change User command, in
GoLive 115
Changing file naming rules 212
class attributes as CSS selectors 327
class styles 325, 327, 338
class styles, deleting 329
class styles, replacing with HTML 307
collections
about 435
attaching queries to 436
creating 437
creating in navigation or links
view 222
deleting 437
detaching queries from 437
in Bridge 49, 50
moving 437
revealing files in site 436
spotlighting 224
Collections tab 203
color fields 179
Color Inspector 431
Color Managed View command 176
color management
See also color profiles, color
settings
about 652, 653, 654
appearance of CMYK black 657
basic steps for setting up 655
color settings reference 670
considerations for importing
images 658, 659
considerations for printing
documents 663
considerations for process and
spot colors 657
creating a viewing
environment 653
for online graphics 660
for PDF files 660, 664
soft-proofing colors 661, 663
synchronizing color settings 656
Color palette
about 175
adding color to site collection 431
changing color model 176
displaying web-safe colors 176
mixing and editing colors 176
text and 303
using the Recent Color list 176
color pickers
about 175
using color management 176
color profiles
about 665
assigning and removing from documents 668, 669
converting to another profile 670
creating monitor profiles 666, 667
embedding in documents 668
for desktop printers 664
for imported images 658, 659
installing 668
warning messages for 671
color settings
See also color management
color conversions 673
color management policies 671, 672
customizing 670
for GoLive 656
for Illustrator, InDesign, and Photoshop 656
presets for 670
rendering intents 673
synchronizing with other applications 656
working spaces 670, 671
Color Table palette 372
color tables
saving and loading 372
colors
See also color management, color models
applying from site color lists 431
applying to objects 179
applying to text 303
highlighting page template regions 421
naming 431
of normal, active, and visited links 180
page background, applying to 179
removing 179
saving with a site 430
searching site for 237
setting frame background 265
web-safe 176
Colors tab
about 202
removing unused references from 209
in site window 430
comma-delimited files as data sources in Co-Author 455
Comment Inspector 270
comments
adding to a page 270
adding to head section 164
adding with Outline Editor 587
entering for Version Cue projects 130
compact mode 39
Compact view
of tutorials 7
Compare To Latest Version command 120
Compare To Server Version command 153, 154
components
See also snippets
about 427
adding to pages 427
creating 427
editing source files 428
updating site files dependent on 210
Condition action 633
ConfirmLink action 615
Conflicted Copies file status, in Version Cue 86
Connect To command 78
Connect To FTP/WebDAV command 447
Connect To Publish Server command 442
Connect To Site command 150
Connect To Version Cue command, in Adobe GoLive 114
connecting to web servers 440
connectors in diagrams 192
containers in SMIL presentations 490
content area 37
Content tab 206
context menus
containing lists of recently linked files 169
using 31
Conversion Settings dialog box 381
Convert Text To Banner command 380
Convert To Layout Grid command 258
Convert To Profile command 670
converting
layers to layout grids 258
layout grids to tables 252
tables to table-based layout grids 253
cookies
cookie-related actions 635
deleting 636
cool grids code 252
Copy command 46
copying
objects in diagrams 188
Smart Objects 361
copyright information, adding 56
Create @import command 324
Create Collection command 223
Create Link button 168
Create New Folder command 205
Create Site command 146, 147
Creative Suite color settings 656
cropping Smart Objects 364
CSS Editor
about 318
Background Properties set 336
Block Properties set 334
Border And Outline Properties set 335
Edit Style Examples command 321
INDEX

Font Properties tab 332
List Item And Other Properties set 336
managing styles 329
opening 320
previewing styles in 321
Selector And Properties set 337
Selector And Properties tab 327
Text Properties set 333
view options for 321
viewing source code in 321
CSS ID style for layers 253
CSS layout objects
about 245
adding to a page 246
customizing in the CSS Editor 246
customizing in the CSS Object Inspector 246
navigating with Tables & Boxes palette 246
nesting 246
using in page layout designs 243
CSS Object Inspector 245
CSS palette
about 318
applying class styles 338
CSS Redirect action 614
CSS rules
@font-face rule 329
@import 324
@media rule 329
@page rule 329
CSS tab 202
CSV files as data sources in Co-Author 455
curving link lines in diagrams 194
custom objects in diagrams
adding 186
editing 187
submitting 199
tool tips for 186
Cut command 46
CVS
connecting to projects 150
placing existing site into 151
D
DailyImageURL action 613
DailyRedirect action 615
date and time stamps 270
Declare Variable action 636
Decrease Font Size command 55
Decrease Rating command 49
Default Browser command 33
Default CSS command 322
Default Font command 300
Default Workspace command 28
Default.macro file 600
definition lists 297
deflecting link lines in diagrams 194
Delete command, in Version Cue 98
Delete Metadata Template command 174
Delete Permanent command 100
Delete Workspace command 41
DeleteCookie action 636
Deleted file status, in Version Cue 87
deleting files from Version Cue projects 99, 100
files permanently from Version Cue projects 100
projects in Version Cue 98
versions with Version Cue Administration utility 133
Deselect All command 45
Design tab
of diagram window 182
of View palette 190
design view 182
desktop printers
color profiles for 664
destinations, specifying in links 169
Detach From Template command 426
detaching page template source files 425
developer resources
scripting guides 9
SDK documentation 9
DHTML layers 253
DHTML Timeline Editor about 260
action tracks 610
animation play range 260
Autoplaying 262
inserting keyframes 260
opening 260
playing 261
recording 261
Scenes menu 262
specifying fps 261
diagram window
Annotations tab 195
Design tab 182
Master tab 193
Staging tab 190, 198, 199
diagrams
adding and editing links in 185, 194
adding custom objects to 186
adding objects to 181, 184
adding pages 183
anchoring 190
annotating 195
boxes in 193
brackets in 196
checking staging of 198
collision avoidance in 189, 191
creating and opening 182
editing objects in 188, 189
presenting 193
submitting 198, 199
viewing 190
Diagrams tab
about 202
refreshing 209
using 182
dictionaries
choosing language set 308
editing 308
Digital Clock action 627
dimensions, of web graphics 367
Disconnect command 97
Display Partial Tree command 221
Display tab of View palette 190
distributed sites
setting up 449
testing 450
dithering
  browser 371, 374
  No Dither 374
  DIV element 253
document type
  about 161
  configuring objects toolbox for 163
  converting HTML or XHTML documents 162
declarations in special documents 155
  setting for document 161
document profiles. See color profiles
  Document Statistic command 173
document statistics 173
  Document Type Definition (DTD)
    checking compliance with Syntax Checker 591
    for special documents 155
    importing in Web Settings 645
document window
  head section pane in 26
  laying out pages 243
  opening 26
  resizing 158
  source code pane in 26
  Document Write action 620
documents folder, in Version Cue 77
double-byte languages 315, 316
  Download All command 446
  Download command 149
  Download Page command 446
  Download Selection command 445, 446
downloading
  pages 149, 446
  sites 445
  updates, plug-ins, and tryouts 9
  Drag Layer action 622
  Duplicate command 46, 189
duplicating
  Version Cue projects 131
dynamic collections
  about 435
  creating 437
dynamic effects. See layers, actions
E
  Edit Font Sets command 301
  Edit PDF Anchor command 172
  Edit Properties command 82
  Edit Style dialog box 305
  Edit Style Examples command 321
  editable regions in page templates 421
  editing
    links sitewide 232
    editors, source code 578
  Eject command 46
  elements
    adding in Outline Editor 585
    adding no edit 165
    adding unknown 588
    searching for 597
  e-mail
    saving addresses with a site 433
    searching for addresses 237
Embedded actions 630
  emoji characters 471
  empty
    pages, adding 227
    reference links 167, 168
  Enable Version Control
    command 151
  encoding
    for double-byte text 316
    text character for existing pages 165
    text character for new pages 156
  Encoding Inspector 165
  encryption in forms 417
  errors
    checking 234
    fixing broken links 235
    icons for 234
  Errors tab 170, 202
events
  onload actions 609
  setting up key or mouse events 609
  EXIF 54
  Export Cache command 43
  Export command
    diagrams 197
  Export Internal Style Sheet
    command 322
  Export Site Locator command 150
  Export Tab-Delimited Text
    command 290
  exporting
    sites 448
    stylesheets 320
    Version Cue projects 132
  Extensible Metadata Platform (XMP) 53
  extensions 11
  external code library 605
  External Inspector 434
  external stylesheets
    creating 320, 322
    referencing 324, 338
    setting as site default 322
    styles 320
  External tab
    importing URLs from site levels 149
    removing unused references from 209
    using 433
  external URLs
    checking 236
    saving with a site 433
  Extras tab
    about 202
    refreshing 209
  Eyedropper tool
    about 30, 175
    using to extract color 179
F
  fading out and in 626
  Favorite icon, adding to head section 164
  Favorites As Site Externals
    command 434
  Favorites category in New Document dialog box 155
  Field Validator action 611
  fieldsets, in forms 415
  file browser
    about 440
    elements in forms 418
using 447
file browsing, with Bridge 37
file conflicts in Adobe Version Cue 112
file conflicts, in Version Cue 112
file creator, changing 165
File Info command 56, 173
file information 173
File Inspector 206
file locks, removing in Version Cue 133
File Mappings tab in Web Settings 649
file names
changing 211
changing constraints for 212
File Navigator command 40
file protection, in Version Cue 85
file references, updating 232
file status
in Version Cue 86
publish states and labels 240
File tab of File Inspector 206
File Transfer Protocol. See FTP
files
batch renaming 53
checking for errors 234
deleting 208
dragging 205
finding 49
labeling 48
linking 167
locking on WebDAV servers 451
managing 46
moving to folders 204
navigating 45
opening in Bridge 45
placing, in Version Cue 92
rating 49
recovering 208
renaming 211
revealing in system 206
searching for 237
selecting in Bridge 45
transferring with the file browser 447
unlocking 156
Files tab
about 202
refreshing 209
showing files submitted from diagram 199
unlocking files in Locked column 156
Filmstrip Focus command 40
filtering site views 226
Find Code Elements command
editing elements 598
saving and loading search tasks 599
Find command 49
Find Differences command 590
Find Selection command 309
Find Text command 308, 310
finding and replacing
See also searching
text or HTML 308
finding files and folders, with Bridge 49
fixing broken links 235
Flash file format. See SWF format
flattening
Script Library 606
Flip Move action 622
Float Layer action 623
floating boxes. See layers
folders
creating 204
deleting 208
finding 49
inspecting 206
managing 47
navigating 45
revealing in system 206
understanding in Version Cue 77
Font Editor 301
font element 293, 302, 303
Font menu, changing 301
font properties for stylesheets 332
Font Set Editor 301
Font Set Inspector 432
font sets
See also site fonts
applying to text 433
creating 301
editing 301
saving with a site 432
Font Sets tab
about 202
collecting font sets 432
removing unused references from 209
font size
changing in Metadata panel 55
in browsers 302
Fonts preferences 302
Force Download command 122
ForceFrame action 268, 615
foreign-language files, importing 316
form elements
adding 412
grouping 415
inactive 418
Form Input Image icon 417
Form Inspectors 411, 413, 415
Form Inventory dialog box 418
forms
adding buttons to 412
adding check boxes to 412
conditionally disabled elements in 418
creating 411
custom buttons in 412
hidden data in 417
labels in 415
Last Modified (form) action 621
list boxes in 414
navigation in 415
pop-up menus in 414
reading values from 612
setting up form-related actions 611
special HTML elements in 417
tables for layout 411
text fields and text areas in 414
forums 9
Frame Editor 26, 265
Frame Inspector 266
frame set documents about 263
forms in 412
naming and saving 266
page layout designs 244
samples in New Document dialog box 264
setting up 264
Frame Set Inspector 265
frames
about 263
adding to pages 264
border sizes 267
browser limitations 263
displaying two from one link 618
ForceFrame action 615
in a frame set document 263
frame-related actions 614
hiding borders 265
hypertext links to 168
inline frames 269
KillFrame action 616
linking to pages 266
moving and copying 266
naming 266
preventing page loading 616
previewing 264
resizing 267
setting background colors 265
setting fixed and relative sizes 267
setting scrolling bars 267
setting up frame set 265
table of contents or navigation bar 268
Target2Frames action 618
targeting 268
targets for page links 267
FTP
about 440
options 441
options, advanced 441
servers, importing files from 148
FTP server
exporting Version Cue projects to 132
publishing Version Cue projects to 129, 130
specifying an FTP proxy server in Version Cue 127
functions and Call Function action 633
G
gamut, of colors 652
General preferences
Bridge 42
generic elements, adding 587
Get Form Value action 612
Get Layer Position action 612
Get Used/Remove Unused command 209
GetClipInfo action 631
GetInstalledComponents action 631
GetPlayerProperty action 631
GetPlayerState action 631
getters actions 611
GetVersionNumber action 631
GIF file format
about 369
in i-mode pages 472
optimization settings 369
Global Positioning System (GPS) data 54
Global tab in Web Settings 650
glossary lists 297
GL-Western encoding 316
Go Last Page action 615
GoLive data, stripping 445
GoLive version control
about 151
changing version control settings 154
checking files in 153
checking files out 152
comparing checked in versions 154
comparing files 153
creating for a new site 152
creating for an existing site 151
showing user activity 154
synchronizing 153
workflow 151
GoLive. See Adobe GoLive
Goodies folder 9
Goto Link action 615
GPS information in files 54
graphical site views 214
grid in design view 191, 192
grid lines, showing and hiding 249
Grid tab of View palette 190, 191
Grid Text Box tool 30
Group command 189
Group Inspector 189
grouping
creating groups 205
form elements 415
in diagrams 189, 190
objects 250
H
handle action 631
Head Action icon 609
Head Script Inspector 165
head section
adding elements or scripts 164
adding internal stylesheets 320
displaying 26
Heading tags 295
Help system
PDF version of 8
tutorials in 7
hidden data in forms 417, 418
hidden elements, displaying 159
Hide All Palettes command 28
Hide Grid command 191
Hierarchic command 258
hierarchy of diagram objects
adding custom objects to 187
adding pages to 182, 184
laying out 192
repositioning objects in 188
hierarchy of pages
adding pages 227
adding pending links 227
adding scratch pages 229
building 227
rearranging 229
removing pages from navigation views 229
solving 232
highlight colors 422
Highlight tab of View palette 422
about 594
clearing highlighting 595
highlighting elements 594
selecting previous and next 595
setting highlighting colors and appearance 595
using with template regions 421
history information, adding to files 56
horizontal lines in text 271
Horizontal Spacer icon 272
hotspots
creating in SMIL presentations 500
in sliced images 368
resizing and repositioning for SMIL 502, 503
Href attributes 433
HTML
See also HTML text
converting to i-mode HTML 470
converting to XHTML 468
default Web Settings for 641, 644, 645
element styles 325, 326, 338
elements, adding to forms 417
formatting 643, 650
tags as CSS selectors 326
HTML Styles palette
about 304
applying styles 306
exporting styles 306
importing styles 306
HTML text
formatting attributes 292, 294
headings 302
paragraph attributes 294
structural attributes 298
structural versus physical attributes 298
styles for 292, 304, 307
HTTP
about 440
options, advanced 441
options, standard 441
servers, importing files from 148
HTTP Proxy server, specifying in Version Cue 127
hyperlinks, exporting in PDF files 405
I
ICC profiles
See also color profiles
ICC profiles in image files 373
icons in diagrams 191
ID selectors in stylesheets 328, 338
ID styles
about 325
applying 338
creating 328
Last Modified (ID) action 620
Text Swap action 619
Idle action 634
IDs, in Version Cue 136
Illustrator files. See Adobe Illustrator files
image actions 613
image maps 346
Image Size palette 367
images
adding to a page 340, 358
adding to buttons in forms 417
adding to layers 254
adding transparent GIFs 272
alternative text for 341
applying to page background 179
borders for 342
changing daily 613
in diagrams 186, 193
displaying in low resolution 159
dynamic swapping 614
preloading 613
resizing 341, 363
showing or hiding in layers 259
Smart Objects for 340, 358
swapping in random sequence 613
tiling 336
tracing for web pages 348
variables in 378
i-mode HTML
about 462, 470
form elements 472
images 472
Japanese authoring 471
linking to phones 472
objects toolbox, configuring 471
phone emulators 482
Import GoLive Script Library button 606
Import New Site From Site Locator command 150
Import Version Cue 1.0 Data command 127
importing
Photoshop image layers 244
stylesheets 320
tab-delimited text 289, 293
text into a table 289
In & Out Links palette
about 232
editing links sitewide 232
In Use By file status, in Version Cue 86
In Use By alerts in Version Cue 88
In Use By Me file status, in Version Cue 86
inactive form elements 418
Increase Font Size command 55
Increase Rating command 49
InDesign files
as data sources in Co-Author 455
importing. See Package For GoLive
Init Variable action 637
inline frames 269
inline styles 328
inline text styles, HTML Styles palette 305
inline text, formatting 298, 306
input device profiles 665, 668
Inspectors. See individual Inspector names
installation, software 1
interactive file browsing in forms 417
interactivity. See layers, actions, rollovers
internal preview. See live rendering 31
internal stylesheets
creating 320
exporting to external stylesheets 320
importing 320
referencing external stylesheets 338
International Color Consortium (ICC) 654
Internet
access, setting up 148, 439
preferences 439
search engines 157, 263
Intersection action 634
Invert Selection command 45
IPTC (IIM, legacy) 54
IPTC Core 54
IPTC information 54
IPTC metadata, editing 55
IsIndex element 165
italic text 299
Japanese (Shift JIS) encoding 316
Java applets
about 356
alternative text or HTML for 357
editing parameters for 357
setting up 356
JavaScript
See also JavaScript Editor
adding to head sections 165
flattening the Script Library 606
libraries, external 605
shifting code to an external library 605
support for 602
JavaScript Editor
about 602
adding JavaScripts 603
building blocks 602
editing JavaScripts 604
navigating to a function 604
previewing JavaScripts 604
using text macros 600
JavaScript icon 603
JPEG file format, optimization settings 369
K
key generator elements in forms 418
Key Press action 616
key sets 579
keyboard shortcuts
cascading stylesheets 685
customizing 675
DHTML timeline 682
document window 676
images 685
layout grids and layers 681
links 684
for navigation in forms 415
Outline Editor 689
page templates 679
QuickTime editing 687
site Navigation and Links views 678
site window 677
Smart Objects 685
source code editing 688
tables 680
type 683
web settings 690
workspace 676
KeyCompare action 635
keyframes in layer animations 260
keywords 163
keywords, applying to files in Bridge 58
KillFrame action 616
L
Label commands, in Bridge 48
labels, adding to forms 415
language
assigning in Bridge 42
languages, spelling rules 307, 308
Last Modified (form) action 621
Last Modified (ID) action 620
Layer Inspector 257
adding color or images to a layer 255
showing and hiding layers 259
Layer tool 30, 253
layered effects. See layers
layering items in SMIL presentations 494
layers
about 253
actions 611
adding text and images 254
adding to a page 254
animating 260
changing stacking order 257
converting from Photoshop files 377
converting to table-based layout grids 258
hiding 258
locking 258
managing 257
moving or resizing 255, 256
naming 258
overlapping 257
in page layout designs 243, 253
positioning with Layer Grid Settings command 256
preserving in Adobe Acrobat 405
recording animation path 261
selecting 255
Show Hide using mouse event trigger 259
showing 258
timeline-triggered actions 610
user-triggered actions 609
using DHTML Timeline Editor 260
using Show Hide actions 253, 259
viewing hierarchy 258
z-index attribute 257
Layers palette 253, 258
Layout Editor
displaying source code pane 26
setting default browser profile 649
using for page layout 243
Layout Grid Inspector 248, 249
Layout Grid module 252
Layout Grid To Table command 252
layout grids
See also tables
about 247
adding text, images, and objects 249
adding to a page 248
aligning and distributing objects 251
aligning with document windows 249
converting CSS-based to table-based 248
converting from layers 258
converting from tables 276
converting to tables 252
CSS-based 247
distributing objects 251
grouping objects 250
hiding grid lines 249
for page layout designs 243
resizing 248
spacing between lines 249
table-based 247
Layout Preview 26, 264
layout rulers, showing and hiding 27
Layout tab of Inspector 192
Layout Text Box Inspector 249
layout text boxes
adding text, images, or objects 249
resizing in browsers 249
spacing images and text 302
Level Inspector 196
level objects in diagrams 196
library files, updating site files dependent on 210
Library palette
about 420
preview pane 420
Lightbox command 40
Line Break Inspector 297
line breaks
about 297
Line Inspector 271
lines
horizontal 271
link actions 614
Link Inspector 185, 186, 194, 324
Link Types command 186
linked files
color management considerations 658, 659
in Version Cue 92
linking
See also links
to anchors in pages 171
images and objects to source files 167
navigational 167
resource 167
text, images, and objects to pages 167
using recently linked files 170
using the Browse button 170
using the pick whip 169
links
See also linking
adding and editing in diagrams 185
applying site URLs or e-mail addresses 435
default colors for normal, active, or visited 180
deflecting link lines in diagrams 194
displaying in diagrams 192
editing sitewide 232, 233
empty reference 168
fixing for missing files 235
in PDF documents 397
removing 168
titles for 168
updating in submitted diagrams 199
viewing incoming and outgoing 232
visited, active, hover, and focus viewing options 159
Links palette
replacing placed files with alternates 94
replacing placed files with previous versions 94
using with Version Cue project files 93
viewing alternates and versions in 93
Links tab 28
links view
about 216
changing orientation of 218
peripheral pane 219
showing and hiding 220
liquid layouts 243, 245, 461
list properties for stylesheets 336
lists 297
live rendering
about 31
setting options 32
Lock command 451
lock protection, in Version Cue 130, 133
locked files, unlocking 156
locking files on WebDAV servers 451
locking text. See page templates
logins
creating in Version Cue Administration utility 136
entering in Version Cue Administration utility 124
in GoLive 115
login information 148
privilege levels, in Version Cue 137
logs, in Version Cue 126, 139
looping items in SMIL presentations 490, 491
M
macros. See text macros
magnifying and reducing site views 221
mailto URLs 434
Make Absolute command 171
Make Alternate command, in GoLive 121
Make Alternates command, in Version Cue 109
Make Primary Alternate command, in GoLive 121
Make Primary Alternate command, in Version Cue 108
Make Relative command 171
Manage Workspaces command 34
managing sites
about 201, 204
broken links 235
collections in navigation or links view 222
creating folders and groups 204
INDEX

deleting files and folders 208
errors 234
finding missing files 235
graphical views of 214
recovering files 208
refreshing site window 209
removing unused references 201
setting preferences 201
tools for 201
tracking status 207
updating thumbnails 225
Mark In Use command 111
markers
  adding to Navigate Through Code menu 600
Markup command 580
Markup palette 580
markup snippets. See snippets
Markup tab in Web Settings 641
markup tree bar
  about 593
  selecting elements 593
  using in Visual Tag Editor 582
Marquee Inspector 272
master files, in Version Cue 84
master items, adding to diagrams 193
Master tab of diagram window 193
matte color
  changing in Smart Objects 361
Memory Usage preference 75
menus. See context menus, palette menus 31
message actions 620
meta element, adding to head section 164
Meta Inspector 164
metadata
  about 53, 173
  adding to documents 56
  appending 58
  applying as templates 58
  editing 55
  preferences for 56
  replacing 58
  searching for, in Version Cue 95
  specifying types to display in Metadata panel 56, 57
templates 57
viewing 55
Metadata Focus command 40
Metadata panel 54
metadata, specifying types to display in Metadata panel 57
migrating to Adobe Version Cue 2.0 127
MIME type, setting for plug-ins 350
missing files, finding 235
MMS
  about 462
  messages 462
  optimizing for devices 465
  phone previews 465
  slide shows 463, 464
mobile content
  cascading stylesheets and 461
  formats for 462
  guidelines for designing 461
  mobile phone emulators 482
Modified Date icon 270
Modified Date Inspector 270
modified-item uploads 442
modules 35
Modules Manager 35
monitor profiles 665, 666, 667
mouse event triggers 610
Mouse Follow action 623
Move By action 623
Move To action 624
Move To Center command 221
Move To Bin command 47
Move To Trash command 46, 47
movie viewer window. See QuickTime movies
moving objects
  in diagrams 188
Multilingual Internet Access 315
N
Name tab 206
naming files, in File Inspector 211
Navigate History action 616
Navigate Through Code menu 600
navigation aids in frames 263
Navigation tab 28
navigation view
  about 215
  changing orientation of 218
  peripheral pane 219
  showing and hiding 220
navigational links
  about 167
  creating 167, 168
to pages in frames 267
negative margins 159
nested page templates
  about 423
  creating 423
Netscape CSS Fix action 628
Netscape Spacer elements 252
network settings, customizing 439
New Child Page command 227
New Diagram command 182
New Document command 146, 147
New Document dialog box
  creating pages 155
  Favorites category 155
New Element button 585
new features in GoLive CS2 10
New Folder command 47
New Next Page command 227
New Pages command 183
New Parent Page command 227
New Previous Page command 227
New Project command 81
New Window command 39
no edit elements 165
No Label command 48
No Rating command 49
No Working Copy file status, in Version Cue 86
nobreak elements 297
nonbreaking spaces 271
None privilege, in Version Cue 137
None tag in Paragraph Format menu 295
nonroman character sets 315
numbered lists
  about 297
Object Inspector 187
Object Selection tool 30
objects
aligning and distributing 251
Objects palette. See objects toolbox
objects toolbox
displaying horizontally 28
i-mode configuration 471
separating tools and objects 28
XHTML Basic or Mobile
configuration 469
Offline Copy file status, in Version
Cue 86
offline Version Cue projects, in
GoLive 121
online training 9
Only Copy file status, in Version
Cue 86
Only Web Colors command 176
OnParse action triggers 609
Open Alert Window action 621
Open command
in Bridge 45
Open CSS Editor button 321
Open file status, in Version
Cue 86
Open Window action 616
Open Window Prompt action 617
Open With Camera Raw
command 45
Open With command 45
Opening and closing files, in
Bridge 39
optimizing
GIF and PNG-8 files 369
JPEG files 369
SWF (Flash) files 370
orphan files, fixing 235
Others actions 627
Outdated Copy file status, in Version
Cue 87
Outline Editor
about 583
adding attributes 586
adding comments 587
adding elements 585, 587
adding text 587
expanding and collapsing
outline 584
moving elements 584
navigating in 584
toggling binary tag display 588
outline links in diagrams 192
Outline Mode module 583
output device profiles 664, 665, 668
Output Settings dialog box
file saving options 376
Slices options 375
using 375
overlapping layers 257
Package For GoLive
about 385
assets, adding 387
assets, viewing 387
exporting to HTML 391
graphics, adding 389
importing 385
pages, viewing 387
text, adding 390
padding properties for
stylesheets 335
Page Inspector 157, 179, 180, 248, 427
page layout designs
frame sets 244
layers 243
Page Properties command 159
page scrolling, minimizing 248
Page tab 206
page templates
about 420
applying to new pages 423
applying to pages with content 424
coloring regions 421
creating new pages from 423
detaching from pages 425
fitting Smart Objects in regions
of 364
nested 423
samples, locating 420
updating attached pages 425
updating site files dependent
on 210
page titles
changing 157
in File Inspector 206
in head sections 163
pages
adding color or background
images 252
adding content 244
adding CSS layout objects 246
adding font sets 432
adding frames 264
adding horizontal lines 271
adding to sites 154, 156
adding URL pop-up menu
elements 270
aligning objects 251
browser switching to
alternates 166
changing daily or hourly in the
browser 615, 620
creating from page templates 423
creating in sites 154
CSS layout objects 245
in diagrams 182, 185
downloading 149, 446
HTML head section elements 163
layout grids 247
margins 159
minimizing scrolling 248
previewing 31, 159
refreshing in browser window 165
retitling 157
revealing in site 214
saving with a site 160
selecting window sizes 158
setting up 157
titles for 157
web browser profiles for
previewing 159
palettes
collapsing into side tabs 29
docking 28
grouping 28, 29
menus 30
moving 28
See also individual palette names 28
showing and hiding 28
Paragraph Format menu 295
paragraph styles
HTML Styles palette 305
paragraphs
aligning and indenting 296
default paragraph format 295
formatting with HTML attributes 294
line breaks in 297
lists 297
nonbreaking spaces in 297
removing element tags 295
selecting 294
passive mode 441
Password action 621
password fields in forms 414
Paste command
in Bridge 46
pasting
text 293
PDF files
adding pages as images 360
Advanced export options 408
color management considerations 660, 664
Compression export options 406
displaying 394
exporting 399
General export options 403
HTML Conversion export options 407
links in 397
navigating 395
preferences 402
presets 402
Security export options 409
security settings, viewing 396
Site Creation export options 408
PDF Redirect action 617
PDF/X-compliant files
color management considerations 664
pending links
adding and editing in diagrams 183
Pending Links palette 199
resolving 230
updating in submitted diagrams 199
peripheral pane of navigation or links view 219
Persistent command 58
personal dictionaries for spelling 308
phone emulators 482
Photoshop files. See Adobe Photoshop files
Photoshop Layers command 378
pick whip 169
Place command
in Bridge 46
in Version Cue 92
plain text 299
play range locator 260
Play Scene action 262, 624
Play Sound action 625
PlayClip action 632
Plug-in Inspector, Attribs tab 351
plug-ins 9
See also browser plug-ins in Adobe Store 9
PNG file format
about 369
PNG-8 file format
optimization settings 369
pop-up menus on pages 270
position properties for stylesheets 336
preferences
Adobe PDF 402
Browsers 32
default font size 302
Encodings 316
General 35
Internet 439
Modules 35
Network 201
Preview Mode module 32
Script Library 201
SetTitle extend script 157
Site 201
Source 165, 579
Spell Check 308
Syntax 580
Themes 579
Preferences command
in Bridge 41
Preformatted tags 295
Preload Image action 613
PreloadURL action 632
presets
image optimization 367
PDF export 402
Preview In Browser command 33
Preview Mode module 32
Preview tab 32
previewing
cascading stylesheets 649
forms 418
link colors 159
pages in GoLive 31
pages in target media 159
PDF documents 399
SMIL presentations 487
web browser profiles for 159
previewing colors. See soft-proofing colors
Print command 197
Print Document action 628
printing
color management considerations 663
process colors
color management considerations 657
profiling, simulated preview of pages 159
projects, sharing using Version Cue Administration utility 130
Promote To Current Version command 105
Proof Setup command 661
property collections
applying 337
storing 337
proxy servers, setting up 439
PSD files. See Adobe Photoshop files
public key authentication 441
Publish Server tab 203, 440
publish servers
   clients 440
   connecting to 440, 441
   setting up connection to 439
publish states of files, assigning 240
publishing
   See also sites, uploading a site
   sites 439
   Version Cue projects with GoLive 128
Purge Cache For This Folder command 43
Purge Central Cache command 43

Q
queries
   defining 238
   dynamic collections and 437
   options 239
   parameters, adding to URLs 170
   running 240
QuickTime movies
   adding and editing samples 529
   adding tracks 531
   aligning timing of tracks and samples 534
   annotating movies 527
   Autoplay option 527
   chapter tracks 555
   color tracks 541
   copying tracks between movies 533
   creating and opening 526
   filter tracks 558
   folder tracks 554
   HREF tracks 558
   instrument tracks 554
   layering order of tracks 533
   Movie Inspector 527
   movie tracks 538
   MPEG tracks 553
   Multiple Track Inspector 534
   picture tracks 541
   saving 576
   selecting tracks 526, 528
   sound and MIDI tracks 553
sprite tracks 543
streaming tracks 551
SWF tracks 550
text tracks 555
3D tracks 553
Timeline Editor 528
track and sample Inspectors 534
video tracks 541
QuickTime plug-in options 352

R
radio button groups, in forms 412, 413
RAM file, creating 511
Random Links action 617
RandomImage action 613
rating files, in Bridge 49
Read Cookie action 637
read-only files, unlocking 156
Real plug-in options 354
RealOne Player presentations
   Browser pane 515
   Info pane 514
   Media pane 514
   previewing 515
RealPix presentations
   adding effects 520
   creating 515
   editing images 522
   specifying settings 518
Recall All command 200
Recall Items command 200
Recent Colors list 175
recovering files or folders 208
Redirect Prompt action 617
reference link. See resource link
reference material 8
reference pane of navigation or links view 219
references, creating using Browse button 170
Refresh command 44
Refresh command, in Version Cue 78
Refresh meta element 165
refresh view, site window 209
relative font sizes 302
relative length units for stylesheets 331
relative paths in URLs 171
remote rollovers, creating 614
remote servers, importing files from 148
Remove Alternate command, in GoLive 121
Remove Color command 304
Remove From Favorites command 47
removing software 1
removing working copies, in Version Cue 95
renaming files 53
rendering intents 673
Repopulate Views command 365
reset buttons in forms 412, 413
Reset To Default Workspace command 41
Resize Window action 628
resizing layers 256
sliced images 363
Smart Objects 363
resolving pending links 230
resource links about 167
   creating 167, 168
Resources and Extras CD 8
restarting Version Cue 74
Restore command, in Version Cue 100
retilting HTML pages 157
Reveal In Bridge command 46, 73, 88
Reveal In Explorer command 46, 206
Reveal In Finder command 46, 206
Reveal In Site command 436
Revert To Last Version command 105
Rewrite Source Code command 600
rollovers about 342
Adobe ImageReady 344
attaching actions 346
automatically detecting images 345
code for 346
INDEX

creating secondary or remote 614
deleting states 344
displaying all states 345
editing naming conventions 345
Expert Mode 344
highlighting in document window 344
remote 343
self 342
status bar messages for 344
thumbnail size, changing 344
roman character sets 315
Root Style Sheet Inspector 648
root-layout region for SMIL 509
Rotate 180˚ command 48
Rotate 90˚ Clockwise command 48
Rotate 90˚ Counter-clockwise command 48
rotating images 48
RSS feeds 9, 50
rule lines in text 271
rulers, layout rulers 27

S
Save A Version command 102
Save A Version command, in GoLive 119
Save For Web dialog box, slices in 368
Save Metadata Template command 174
Save Workspace command 34, 41
Scenes menu 262
scratch items 199, 200
scratch pane of navigation or links view 219
Script icon 603
Script Library about 605
flattening 606
preferences 606
scripting
guides for 8
resources for 8
scripting guides
Adobe Bridge 52
for developers 9
scripts
adding to head section 165
executing as document loads 165
Scroll Down action 628
Scroll Left action 628
Scroll Right action 628
Scroll Status action 628
Scroll Up action 628
scrolling marquees 272
SDK documentation 9
SDK for GoLive 11
Search Engine action 628
search engines 157, 263
searching
See also finding and replacing
Find Code Elements command 596
for elements 597
for files within site 237
for selected text 309
for text 310
generating queries 237
in Version Cue projects 95
Query Editor 237
saving result sets for elements 597
wildcards for text 311
searching for files and folders 49
secondary rollovers, creating 614
Section Inspector 184
sections
in Co-Author 454
in diagrams 183, 184
security
assigning user IDs in Version Cue 135
Select All command 45
Select Labeled command 45
Select Unlabeled command 45
Select Upper Block command 594
selecting
files, in Bridge 45
HTML elements 593
selection uploads 442
selectors for stylesheets 325
Send To Recycle Bin command 46
Separate Tools And Objects button 28
server requests 170
Set BackColor action 629
Set Image URL action 614
Set Status action 622
Set Title dialog box, hiding 157
Set Variable action 638
SetVideoBackgroundColor action 632
Share Project command 83
Shared Lock command 451
sharing projects
Adobe Creative Suite 83, 84
using Version Cue Administration utility 130
Shift JIS encoding 471
shortcuts. See keyboard shortcuts
Show All Files command 44
Show Alternates command, in GoLive 121
Show Camera Raw Files Only command 44
Show Document Statistics command 173
Show File In Browser command 107
Show Folders command 44
Show Graphic Files Only command 44
Show Grid command 191
Show Hidden Files command 44
Show Hide actions in timelines 259
with layers 253, 259
Show Invisible Items command 159
Show Objects Information command 156
Show Page Dimensions command 158
Show Page Properties icon 179
Show Search Fields command 175
Show Templates command 174
Show Thumbnail Only command 43
Show User Activity button 154
Show User Activity command 115, 116
Show Vector Files Only command 44
Show Version List button 120
Show Versions command 154
Show Welcome Screen preference 35
ShowArtistInfo action 632
fitting media items into regions 493
freezing last frame of an item 499
hotspots 500, 503
layering overlapping items 494
laying out presentations 492
matching viewer’s system 506
presentations 484, 490
previewing 487
RAM files 511
regions 508
removing last frame of an item 499
repeating and looping media items 490, 491
resizing and repositioning hotspots 489
root-layout regions 509
setting size, title and background 487
setting timing 495, 496, 515
Timeline Editor 485
transitions 505
snapping diagram objects to grid 191
snippets
about 429
presets, locating 420
using in page layouts 430
soft-proofing
about 661
in GoLive 663
in Photoshop, Illustrator and InDesign 661
software
downloads 9
installing 1
plug-ins 9
removing 1
Sort command 44
source code
comparing 590
formatting 643, 650
HTML element (tag), SMIL, SVG, and WML databases 641
Source Code palette 581
source code pane 26
source code panel 580
Source Code Editor
checking syntax 591
dragging elements into 589
source code, editing in JavaScript Editor 602
Markup palette 580
Outline Editor 583
Source Code Editor 580
source code panel 580
Visual Tag Editor 581
Source preferences 165, 579
Spacer Inspector 272
spacer.gif images 252, 272
spaces
nonbreaking 271
special characters
adding 646
special characters, adding 647
Specials actions 633
spell-checking
about 307
spot colors
color management considerations 657
spotlighting collections 224
sRGB color space 660, 671
SSL 441
SSR 32
stacking order
layers 257
staging of diagrams
checking 198
displaying staging icons 191
fixing 199
Staging tab of diagram window 190, 198
Staging tab of diagram window 199
Standard Editing tool 30
standard framework 441
stars, rating files with 49
start and end tags, editing 165
Start Tabulator Indexing command 416
static collections 435, 436
stationery
about 426
creating 426
creating new page from 426
status
icons in Files tab 234
labels 240, 241
providing file information 240
publish states of files 240
viewing file status 203
Stock Photo accounts
benefits 67
changing information 68, 69
creating 67
signing in 68
Stock Photos. See Adobe Stock Photos
Stop Complete action 626
Stop Scene action 262, 624
Stop Sound action 625
Stop Tabulator Indexing command 416
strikeout type 299
Style Attribute Editing command 328
styles
See also cascading stylesheets
applying 338
contextual styles 325, 326
creating 325
editing properties 330
managing 329
property inheritance for 330
relative, absolute, and percentage units 331
simple styles 325, 326
Styles folder 306
submit buttons in forms 412
submitting diagrams 198, 199
superscript type
about 299
support options 6
See also Help
SVG
about 369, 462
actions 467
editing 466
JavaScript, adding 467
SVG Tiny for mobile devices 466
SVG files
Illustrator and 382
links in 381
INDEX

page. See page templates
terms, in glossary lists 297
Test Variable action 638
text
See also paragraphs, layout text
boxes
adding horizontal lines 271
adding to a page 293
adding to layers 254
adding to tables 289
adding with Outline Editor 587
aligning 296
color encoding for new
pages 156
checking spelling 307
controlling flow 297
converting to an image 380
copying 294
default color 180
double-byte 315
defaults in forms 414
files, foreign-language
encoded 316
formatting 292, 293
inline character formatting 298,
306
Last Modified (ID) action 620
line breaks 297
nonbreaking spaces 271
positioning using layout grids 249
properties for stylesheets 332, 333
roman and nonroman character
sets 315
scrolling marquees 272
searching for 309
showing and hiding in layers 259
suppressing wrapping 297
text message actions 620
wrapping around images 296
Text Inspector 168
text macros
about 600
case sensitivity 601
inserting into source code 601
redefining control characters 602
Text Swap action 619
Themes preferences 579
3GPP 462
thumbnails
in diagrams 191
upgrading 225
Tile Horizontally command 26
Tile Vertically command 26
tiling images 336
time and date stamps 270
time tracks for layers 260
timelines. See DHTML Timeline
Editor, QuickTime Timeline
Editor, SMIL Timeline Editor
timeline-triggered actions 610
timeout action 635
TimeRedirect action 620
times visited action 638
timing, setting for SMIL 495, 514
tips and tricks 7
titles
changing for pages 157
for links 168
Toggle Binary button 588
Toggle Split View button 580
tool tips 42
toolbars 30
toolbox. See objects toolbox
tools
Eyedropper tool 30
Grid Text Box tool 30
Layer tool 30
Object Selection tool 30
Standard Editing tool 30
Zoom tool 30
tools commands, in Bridge 52
total training 7
tour links, adding to diagrams 185
tracing images 244, 348
tracks, adding to QuickTime
movies 531
training 7, 9
transferring files with the file
browser 447
Transform palette 189, 190, 250
about 250
transitions, creating in SMIL 505
transparency
resources for developers 8
triggers
action 610
browser 609
tryouts 9
tutorials 7, 12
type. See font sets, text
U
Unavailable file status, in Version
Cue 87
underlining text 299
Unfiltered menu 44
Ungroup command 190
ungrouping
objects 250
objects in diagrams 190
uninstallation, software 1
unknown elements, adding 588
unnumbered lists 297
unresolved links 230
Unshare Project command 83
unsupported properties for
stylesheets 337
Update Files Dependent On
command 210
updates 9
uploading a site
See also uploading a site
site resources 209
sites 442, 445
Upload All command 443
Upload Modified Files command 443
Upload Selection command 443
Upload/Export Options 445
uploading a site
about 442
after exporting 449
modification times,
synchronizing 442
modified items only 442
options 445
selected files 442
uploading files 443
URL mappings 449
URL Popup Inspector 270
URL pop-up menus 270
URLs
See also linking, links
adding query parameters 170
changing relative paths to absolute 170
saving with a site 433
Use Adobe Dialog command 73
User Activity tab, in GoLive 115
user forums 9
user IDs
  changing Version Cue, in GoLive 115
  creating in Version Cue Administration utility 136
  deleting or duplicating in Version Cue Administration utility 137
users
  assigning to Version Cue projects 128, 129, 130
  privilege levels, in Version Cue 137
user-triggered actions 609

V
variables
  about 378
  actions 635
  in Photoshop files 379
  reading value from cookie 637
  setting at runtime 637
  setting up 636
  updating 379
version control in GoLive 150
Version Control toolbar 150
version control, in GoLive 150
Version Cue. See Adobe Version Cue
versions
  deleting in Version Cue 105
  deleting with Version Cue Administration utility 133
  in GoLive 120
  in Version Cue 84
  promoting, in Version Cue 105
  saving, in Version Cue 102
  using, in Version Cue 101
  viewing all, in Bridge 104
  viewing and comparing in Version Cue 102
Versions command 118
video
  training 7
View palette
  adding profiles 648
  changing default profiles 649
  setting controls for diagrams 190
  viewing collections, spotlighting 224
viewing sites
  about 201
  customizing views 217, 227
  filtering views 226
  links and references 232
  panes 219
  reports 240
  scrolling views of 220
  spotlighting 224
VisitorCookie action 638
Visual Tag Editor
  about 581
  inserting source code 582
  wrapping tags around selections 583
W
W3C object controls
  about 356
  editing properties for 357
  setting up 357
WAP (Wireless Application Protocol) 474
WBMP format 369, 476
web browsers
  adding to Preview In Browser menu 32
  browser-window related actions 614
  default font 302
  font size guidelines 302
  limitations for frames
  opening second browser window 616
  setting status line text 622
  structural text attributes and 298
  support for CSS 318
  switching to alternate pages 166
  testing links to anchors 171
Web Distributed Authoring and Versioning. See WebDAV servers
web graphics
  color management considerations 660
Web Settings
  adding sections, tags, and enumerations 642
  adding special characters 647
  Browser Profiles tab 648
  Characters tab 646
  editing attributes 644
  editing enumerations 645
  File Mappings tab 649
  Global tab 650
  Markup tab 641
  restoring 640
  setting element formatting 643
  viewing elements in 641
Web Shift button 372
web-content folder
  about 77, 145
  location in site window 204
web-data folder 77, 145
WebDAV servers
  about 450
  connecting to Cue projects 79
  exporting Version Cue projects to 132
  locking and unlocking files 451
  publishing Version Cue projects to 129, 130
web-safe colors
  adding to text 303
  in GIF and PNG-8 files 371
web-settings folder 145
website management. See managing sites
websites. See sites
Welcome screen, options 24
Western (Latin 1) encoding 316
wildcard searches
  about 311
  back-references 315
  guidelines for 312
windows
  about 26
  arranging 26
  bringing to front 169
menus 30
switching 27
Windows Media plug-in options 355
Wipe Transition action 626
Wireless Markup Language. See WML
wizard. See Site Creation Wizard
WML
about 462, 473
cards 474
elements 475
enabling 473
events 477
images 476
input, capturing from viewers 479
links 481
onevent element 478
phone emulators 482
templates 475
timers 482
Work Offline command, in GoLive 122
Workflow palette 207
Workgroup Size preference 75
working files
editing, in Version Cue 110
in GoLive 113
using, in Version Cue 84
working spaces, color 670, 671
workspaces
in Bridge 40
saving custom 34
World Clock action 629
WriteCookie action 638

X
XHTML
Basic and Mobile 462, 468
phone emulators 482
XMP (eXtensible Metadata Platform)
about 53, 173
Software Development Kit 173

Z
z-index attribute for layers 257
Zoom tool 30, 33